Welcome to the BB FlashBack SDK

Welcome to the FlashBack SDK

The FlashBack SDK makes it easy to add screen-recording and playback capabilities to your software applications. These functions are implemented via ActiveX controls that integrate with major development tools to make them easy to plug in to your applications and use.

Here are some topics you'll need to understand to get started:

Installing the SDK

The SDK supports a number of major integrated development environments. The links below give detailed installation instructions:

Installing on Visual Studio .NET
Installing on Visual Studio C++
Installing on Borland Delphi / C++ Builder

Licensing the SDK

To start using the SDK, you'll need to licence it with a free trial licence key from Blueberry.
For detailed instructions on this and buying full licences see Licensing on development PCs and Runtime licensing on end-user PCs.

SDK Editions

There are three different editions of the SDK, each offering a different set of features.

Basic Edition - screen recording and playback
Professional Edition - screen recording, playback and limited editing
Advanced Edition - screen recording, playback, editing and export

Distributing applications that use the SDK

In order to distribute applications that use the SDK, you will also need to distribute a number of files, depending on what features and classes you make use of. See Distributing applications that use the SDK for more details.

The Base Classes
There are three 'base' classes that provide starting points for the functionality supplied in the SDK:

FBRecorder - enables screen recording.
FBPlayer - enables playback of recordings
FBEditor - enables editing and export of recordings

Copyright© 2016 Blueberry Consultants Ltd. All rights reserved.

Important - Please Read:

Blueberry has made every effort to ascertain the validity of the information contained herein, however may not be held liable for any misrepresentation of information. Blueberry may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Blueberry , the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.


Purchasing the SDK

Basic and Professional Editions

These can be purchased online at http://www.flashbackrecorder.com/store

Licensing is per-seat. No royalty is charged on applications created using the SDK, and no restriction put on sale or distribution of such applications. However, the licence does prohibit developers from producing and distributing general purpose screen recorder applications without explicit permission from Blueberry. See the licence.rtf that was installed with the SDK for details. If you intend to use the SDK to develop an application that may fall into this category, contact us at the phone number or email address below to discuss your requirements.

Advanced edition

We have a number of pricing options available for the Advanced edition which are dependant on your requirements. We would be happy to discuss these with you in further detail. Please contact us at the phone number or email address below:

Phone: +44 (0)121 285 0201
Email: sales@bbsoftware.co.uk

See Licensing on development PCs for details of how to use the licence keys emailed to you by Blueberry and how to ensure the applications you produce are licensed to run on end-user PCs.


Contacting Blueberry

Contacting Blueberry For Support

Technical support

Every purchase of the SDK includes one year of free Premium Support. This entitles you to:

  • Support by email, at flashbacksdk-support@bbsoftware.co.uk.

  • Support by phone (English speaking only) at +44 (0)121 285 0202

  • Minor upgrades for free.

For each subsequent year you want to continue to receive support, Premium Support must be purchased at 20% of the cost of the licences you own. This can be done online at http://www.flashbackrecorder.com/store - login and select the 'Add Premium Support' option for FlashBack SDK.

Sales and licensing support

To discuss sales, licensing or integration options, please contact Blueberry sales support at sales@bbsoftware.co.uk

Or contact us by phone:

Phone: +44 (0)121 285 0201
Fax: +44 (0)121 772 3103


A note for Borland C++ Builder users

A note for users of Borland development tools

There are some respects in which usage of the SDK differs from the documentation, for Borland C++ Builder and Delphi users:

  • Event handler names are prefixed with "On".
    E.g. The FBEditor::SetProgressorCaption event handler becomes OnSetProgressorCaption, and is set like this:

    Editor->OnSetProgressorCaption = EditorSetProgressorCaption;

  • Properties and written to and read from by using get and set methods.
    E.g. The FBEditor::Filename property is changed and read via two methods: FBEditor::get_Filename() and FBEditor::set_Filename()

  • Parameters and properties defined as 'String' type will be defined as BSTR in C++ Builder and WideString in Delphi.
    E.g. FBRecorder::InsertMarker(String sMarkerName); becomes FBRecorder::InsertMarker(BSTR sMarkerName) for C++ Builder users.


Note: exception in .NET projects on 64 bit Windows

A note about Visual Studio .NET projects that show an exception on 64 bit Windows

This note is for developers using MS Visual Studio to create .NET applications that use the BB FlashBack SDK.

Symptoms:

When you run a project that uses the FlashBack SDK on a 64 bit version of Windows, you see this exception:

System.Runtime.InteropServices.COMException: Retrieving the COM class
factory for component with CLSID {...} failed due to the following
error: 80040154.

Reason:

The Interop is a managed assembly using the 64-bit Framework and the SDK contains 32-bit COM objects. If you run these COM objects in a 64 bit environment, you will see the error message above.

Fix:

Modify your project's platform from 'Any CPU' to 'X86' (in Project's Properties, Build/Platform's Target).


Note: using double precision mode on the FPU

A note about using double precision mode on the FPU

On Windows Vista and 7, the FBEditor and FBPlayer classes uses Direct3D to display the movie. Direct3D switches the FPU to single precision for performance reasons. This is a global setting - it affects all applications. If your code requires the FPU to use double precision, you will need to set this after using the FBPlayer or FBEditor class.


Note: Using the SDK in a WPF Application

Symptom: Using the FBEditor, FBLog or FBVDisk classes in a WPF application causes arithmetic overflow exceptions.

Cause: SDK classes have been created with Borland C++ Builder, which uses Floating Point Unit (FPU) exceptions, where WPF does not and this puts the FPU into a state incompatible with WPF.

Workaround: throwing and catching a dummy exception can be used to reset the FPU state after creating an FBEditor, FBLog or FBVDisk object. For example:

FBEditor _fbEditor = new FBEditor();

try { throw new Exception("Ignore this please, resetting the FPU"); }

catch (Exception ex) { }


Note: using the SDK with 64 bit applications

Using the SDK with 64 bit applications

The SDK cannot be used by 64 bit applications. It is 32 bit code and only compatible with 32 bit programs.


Licensing on development PCs

How do I get a free trial licence key?

  1. From the FlashBack SDK program group menus, select 'SDK Licensing'.

  2. On the window that is shown, click the 'Get Trial Licence Key' button.

  3. On the next window shown, enter your name, company name and email address, and click 'Request Key'.

A trial key will be emailed to the address you gave. It enables you to use the SDK for a limited period of time. It also enables you to produce executables that will run on end-user PCs, but these executables will also be time limited in their usage.

How do I use the trial licence key that was emailed to me?

  1. From the FlashBack SDK program group menus, select 'SDK Licensing'.

  2. On the window that is shown, click the 'Enter licence details' button.

  3. Enter the licence key exactly as it was supplied in the email from Blueberry and click OK.

Now you will be able to use the SDK for a trial period. This process need only be performed once.

What happens when the trial expires?

Class constructors will still run, but all method calls will fail.

How do I purchase a full licence?

Visit the online store at http://www.flashbackrecorder.com/store and proceed through the purchase process. Major credit cards and PayPal are accepted and purchase by purchase order is available on request.

Once the purchase process is completed, a full licence key will be emailed to you. Enter this key into the licence details window in the same way described above for the trial licence key to fully licence the SDK. This process need only be performed once.

Licensing is per-seat - the licence key should be used to licence the SDK on only one PC. Advanced edition licensing is more flexible - contact Blueberry to discuss.

What about the different editions of the SDK?

There are three different editions of the SDK: Basic, Professional and Advanced. The Basic and Professional editions have limits on the classes they can use.

The free trial licence key enables all features of the SDK, with no restrictions on the classes you can use.

When you purchase a licence, you will need to select a specific edition, since each edition is priced differently. For more information on the difference between editions, see Features of the Basic Edition, Features of the Professional Edition and Features of the Advanced Edition.


Runtime licensing on end-user PCs

Programs you create that make use of the SDK need to supply a 'runtime' licence key to the SDK classes. Otherwise, calls to SDK classes will throw an exception.

When you enter a trial or full licence key into the SDK Licensing utility (see Licensing on development PCs), the runtime key will be displayed.

In your code, pass the runtime key displayed in the SDK Licensing utility to any instances of FBRecorder, FBEditor or FBVDisk you create. Use the FBRecorder::SetRuntimeLicence, FBEditor::SetRuntimeLicence and FBVDisk::SetRuntimeLicence methods.

For all instances of FBEditor, FBRecorder and FBVDisk, the runtime licence must be set, or calls to any method or read/write of any property will result in an exception being thrown with error code 0x800400FF.

Note: when an SDK is operating under a trial licence, the runtime licences it produces will be similarly time-limited. i.e applications produced with an SDK trial licence will not be able to use the SDK classes beyond the trial period.

Note: you can also get the runtime key by calling the GetRuntimeLicence method of the FBRecorder, FBEditor or FBVDisk classes in a program running on a PC with the SDK installed.

Note for Delphi users: Delphi has a limit for string literals of 255 characters. The runtime licence exceeds this limit, so you must break the licence key into two literals. i.e. code like: MyRecorder.SetRuntimeLicence("abcdef..." + "lmnop...");


Distributing applications that use the SDK

Registering the SDK Classes

Registration of SDK ActiveX Objects

The FlashBack SDK is designed to allow multiple versions of the SDK DLLs to be installed with different applications on the same PC.

Each application that includes the SDK should copy the SDK DLLs into its installation folder, and register them with a relative path such instead of an absolute one. This includes the BBLogs.dll file, if logging classes are used.

e.g. regsvr32 "BB FlashBack Recorder.dll"

Using relative paths means that when an application creates a FlashBack SDK COM object, Windows will use the in-process server DLL installed with that application.

Administrative access rights are required to run regsvr32 and register the SDK objects.

Using a Manifest File to access SDK objects

In Windows XP and above, your application can access SDK classes via a manifest file, which removes the need for COM registration (and administrative access) described above. The manifest is an XML file that describes classes to be used by the application. It can either be included in your executable or be in a separate file named appname.exe.manifest.

The manifest file can be compiled into the executable via the mt.exe utility included with Visual Studio.

For example:

mt.exe -nologo -manifest "PATH\APPNAME.EXE.manifest" -updateresource:"PATH\APPNAME.EXE;#1"

For more information on the mt.exe utility see: http://msdn.microsoft.com/en-us/library/aa375649.aspx

For more information on manifest files, see: http://msdn.microsoft.com/en-us/library/windows/desktop/aa375365(v=vs.85).aspx

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>

<assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0">

    <file
 name="BB FlashBack Player.dll">

<comClass
 description="BB FlashBack Player Class"
clsid="{4BA9089C-DDFC-4206-B937-74484B06D305}"
progid="BBFlashBack.FBPlayer.1"
threadingModel="Apartment"
tlbid="{62DAD5FD-46E4-43B1-B174-9DD2729405E5}"/>

</file>

<file name="BBFlashBackEditor.dll">

       <comClass
 description="BB FlashBack Editor Class"
clsid="{85E44C82-A172-4FDC-A857-D6B7F2BFD770}"
progid="BBFlashBack.FBEditor.1"
threadingModel="Apartment"
tlbid="{8823DF52-5CDD-45DC-BE7D-A5E51C0716CE}"/>

</file>

    <file
 name="BB FlashBack Recorder.dll">

<comClass
 description="BB FlashBack Recorder Class"
clsid="{A3CD4BF9-EC17-47A4-833C-50A324D6FF35}"
progid="BBFlashBack.FBRecorder.1"
threadingModel="Apartment"
tlbid="{1F38C6CA-6D6C-4E3D-9C43-39D8BE41EE47}"/>

</file>

<file name="BBLogs.dll" hashalg="SHA1">

<comClass description="FBLog Object"
threadingModel="Apartment"
clsid="{2AE289F8-4649-4A07-BD3A-57086BBCBA39}"
tlbid="{B4C51199-A31A-42D7-ADEA-E7B23EB97CA4}" >
</comClass>

<typelib tlbid="{B4C51199-A31A-42D7-ADEA-E7B23EB97CA4}" resourceid="1" version="1.0" helpdir="" flags="HASDISKIMAGE"></typelib>

</file>

<comInterfaceExternalProxyStub
name="IFBLog"
iid="{E31FAF17-7139-4213-B37D-2DDF17CD34FA}"
tlbid="{B4C51199-A31A-42D7-ADEA-E7B23EB97CA4}"
proxyStubClsid32="{00020424-0000-0000-C000-000000000046}">
</comInterfaceExternalProxyStub

</assembly>


Files to Include

To deliver an application that makes use of FlashBack SDK classes, you will need to install a number of files along with your program executables.

Some of these are SDK files that implement the classes described in this help file. Other third party files are required by the SDK files to implement some of their functionality.

See also the third party file requirements for each SDK DLL - these are files you need to install to the same folder as the SDK DLL. These files are already installed with the SDK, so you need to include them in your application installation.

All of the files listed on this page should be installed to the same folder as the executable that makes use of the SDK classes. Or, they can be installed to another folder, if that folder is added to the Path environment variable.

  • BB FlashBack Player.dll
    Implements:

FBPlayer

Third party files required:

None.

  • BB FlashBack Recorder.dll
    Implements:

FBRecorder

Optional libraries:

If MP3 compression is used during recording:
twolame.dll

For FLV recording when using the UseWebCamForBitmapMode option:
avcodec-52.dll
avcore-0.dll
avformat-52.dll
avutil-49.dll
swscale-0.dll
LibAVEncoder.dll

If MPEG record mode is used:
avcodec-52.dll
avcore-0.dll
avformat-52.dll
avutil-49.dll
swscale-0.dll
LibAVEncoder.dll

For recording sound on Windows Vista or 7:
VistaCoreSoundAPIWrap.dll

For recording direct to MP4 (more information here)
LibAVEncoder.dll
libiomp5md.dll
BBIPP.dll
avcodec-52.dll
avcore-0.dll
avformat-52.dll
avutil-50.dll
libmfxaudiosw32.dll
libx264-128.dll
swscale-0.dll

Note: the above libraries make use of the LGPL licence. If you distribute them with your product, to comply with the licence you need to include the copyright notice for the libavcodec project (avcodec-52.dll etc.) wherever your application displays its own copyright notice.

  • BBFlashBackEditor.dll
    Implements:

FBEditor
FBMovie
FBFrames
FBFrameProperties

FBExportToAVIParams
FBExportToSWFParams
FBExportToWMVParams

FBBitmaps
FBMarkers
FBSounds
FBTextBoxes
FBBitmapProperties
FBMarkerProperties
FBSoundProperties
FBTextBoxProperties

Other files required by BBFlashBackEditor.dll:

WMVExport.dll
BBLogs.dll
mpglib.dll

Optional libraries:

For exporting:
BBIPP.dll
libiomp5md.dll

If QuickTime exporting is required:
FBQTLibrary.dll

If MP3 compression is in edited recordings:
twolame.dll

If sound is exported in MP3 format:
lame_enc.dll

For export to FLV and MPEG4:
avcodec-52.dll
avcore-0.dll
avformat-52.dll
avutil-50.dll
swscale-0.dll
LibAVEncoder.dll

Note: the optional mp3 and FLV libraries make use of the LGPL licence. If you distribute them with your product, to comply with the licence you need to include the copyright notice for the LAME project (lame_enc.dll) or libavcodec project (avcodec-52.dll etc) wherever your application displays its own copyright notice.

BBFlashBackEditor.dll also requires these sub-folders, within its current folder:

'Custom' - if you intend to have custom mouse click images.
'DefaultTextBoxStyles' - if you intend to create text boxes.
'SWFControlBars' - if you intend to export to Flash format.

These sub folders are created in the SDK installation folder and contain a number of files. BBFlashBackEditor.dll needs these same folders and files to be installed in its current folder, if the above functions are to be used.

  • BBFlashBackVDisk.dll
    Implements:

FBVDisk
FBVFile

Third party files required by BBFlashBackVDisk.dll:

none

  • BBLogs.dll
    Implements

FBLogs

Third party files required by BBLogs.dll

none


System Requirements

SDK Runtime Requirements

For applications being run from Internet Information Services (IIS)
Be aware that the application may be executed using the NETWORK_SERVICE account, or another account, depending on the version of IIS used, and may not have full access to the folder. You will need to set permissions on the folder accordingly. In addition, the folder location may be Documents and Settings\Default User\AppData\Blueberry.

For applications running as a Windows service or being run from IIS
These applications require full access to the folder: [APPDATA]\Blueberry

You will need to create the folder if it does not already exist.

Software Requirements

  • DirectX 7.0 is required to play back movies with the FBPlayer class. Due to this requirement, FBPlayer can not be used on Windows NT 4.0.

  • Windows Media Player 9 or newer needs to be installed in order to export to WMV format.

  • Recording in Windows 256 colour mode is not supported.

  • Administrator rights are required to installed the capture driver.

Hardware Requirements

  • Processor speed: 300Mhz Required, 600Mhz Recommended

  • Memory: 196Mb RAM recommended

  • Display: Super VGA (800x600) or higher resolution

  • Graphics card: 4Mb video memory required, 8Mb and above recommended


Known Issues

Known Issues With Applications That Use The SDK

The FBPlayer class does not support and cannot run on Windows NT4.

When a movie is recorded with a soundtrack, and MP3 compression is not used, and it is then exported to WMV or Flash, the last few seconds of audio is lost. If this causes problems this can be worked around by adding blank audio to the end of the movie to compensate for sound lost upon export.

SWF format files created by FlashBack SDK do not support editing by third party Flash editors. The HTML file through which the SWF movie plays is however fully editable in all HTML editing tools.

Currently, AVI exports produced by FlashBack do not officially support conversion to playable DVD format in a third party DVD editing program. This is being investigated by Blueberry and may be improved in a future release. We encourage users to experiment with the process of making playable DVDs with FlashBack AVI files and report successes and limitations to us.

When recording on PCs that have dual video cards, some text and graphics may be missing from the final movie. The solution to this is to use the DirectX or GDI recording mode instead of the Capture Driver.

Recording is not supported in Windows 256 colour mode.

Exporting to AVI using the DivX v6 codec produces an error. Other DivX codecs can be used successfully.

Some movie/video player applications (e.g VLC player, DivX player) experience problems playing back AVI files exported using the Microsoft Video 1 codec. Use Windows Media Player to play them back correctly.


Installing the Capture Driver on the end user PC

Installing the Capture Driver on an End-User PC

The FlashBack SDK has 3 possible methods of recording the screen. One of these methods is "capture driver" mode, which uses a video driver to capture screen changes in a very CPU-efficient way.

See About Record Modes for more on the advantages and disadvantages of each record mode.

To be able to record with capture driver mode, the driver needs to be installed first.

Note: installing the driver requires administrator level access rights to the PC, and a reboot may be required to complete the installation.

There are two methods of installing the driver:

  1. Via a call to FBRecorder::InstallDriver. See Installing the Capture Driver via the FBRecorder class for details.

  2. By running FlashbackDriverInstaller.exe, a program included in your SDK installation. See Installing the Capture Driver via FlashbackDriverInstaller.exe for details.

Because installing the driver requires administrative access, it may be more convenient for you to install the driver when installing the application (via the .exe) rather than at application run time (via the function calls).


Installing the capture driver

FlashBack SDK: Base Classes

Installing the Capture Driver via the FBRecorder class

Methods and properties of FBRecorder to assist in installing, uninstalling and checking the status of the capture driver are:

Method / Property | Purpose
IsDriverInstalled | Determines whether the capture driver is installed and ready for recording. Reading this property causes a screen blank.
IsDriverVersionOk | Determines whether the driver is installed and the correct version to work with the installed version of the SDK. Use this method to check for the driver without causing a screen blank.
CanDriverBeInstalled | Indicates whether the current operating system will permit installation of the driver.
CheckDriver | Checks whether the driver is installed, whether it is the correct version and whether a reboot is needed to complete installation.
InstallDriver | Installs the driver and informs the caller of the success of the operation and whether a reboot is needed to complete.
UninstallDriver | Uninstalls the driver and informs the caller of the success of the operation and whether a reboot is needed to complete.

Note: we have discovered that a specific 3rd party display driver is incompatible with the capture driver (and other 'mirror' drivers), causing severe system instability. See Software Incompatible with the capture driver for more details.


Installing the Capture Driver via FlashbackDriverInstaller.exe

FlashbackDriverInstaller.exe can be used to install, uninstall and check for the driver installation.

Note: administrative rights are required to run FlashbackDriverInstaller.exe.

Command line switches:

-i | Install the driver.
-u | Uninstall the driver.
-c | Check for driver installation. This check verifies the driver version and that the relevant registry keys are present. It also loads the driver and resets screen settings. This produces a screen "blank".
-h | A "light" check for driver installation. It verifies the driver version and that the relevant registry keys are present. It does not produce the screen blanking produced by the "full" check.
-l | Write a log file to the current folder.
-m | Show messages boxes confirming operation success or failure.

Return codes when installing or uninstalling the driver:

Upper 16 bits

Value | Meaning
SUCCESS_SUCCESS = 0 | Install/Uninstall was a success
SUCCESS_REBOOT_NEEDED = 1 | Install/Uninstall was a success, but a restart of Windows is required to complete the operation.
SUCCESS_NOREBOOT_NEEDED = 2 | Install/Uninstall was a success, no Windows restart required.
FAILURE = 3 | Operation failed. Details of failure are given in the lower 16 bits of the return code.

Lower 16 bits

Value | Meaning
ERROR_UNKNOWN = -1 |
ERROR_NOERROR = 0 |
ERROR_NOADMINRIGHTS = 1 | Administrator rights are required for capture driver installation, and the current login does not have these rights.
ERROR_NOUNSIGNEDDRV_POLICY = 2 | Not used.
ERROR_UNKNOWN = 4 |
ERROR_EXTRACTFILES = 8 | The driver files could not be extracted into the current folder. They need to be extracted prior to being copied into the Windows system folder.
ERROR_RUNONCE_SETUP = 16 | The PC needs to be rebooted to complete the install process.
DRIVER_INSTALLED = 32 | The driver files could not be copied into the Windows system32/drivers folder.
UNINSTALL_FAILURE = 128 | Uninstall failed.
UNINSTALL_SUCCESS = 256 | Uninstall succeeded.
REGISTRY_ERROR = 512 | The registry could not be read or changed.
COPY_FILE_ERROR = 1024 | Error copying new driver files.
INCOMPATIBLE_DRIVER_ERROR = 4096 | An incompatible video driver was detected, and the FlashBack capture driver was not installed
ERROR_COULDNT_INSTALL_INSIDE_TS = 8192 | The FlashBack capture driver cannot be installed from within a Terminal Session.

Return codes when checking the driver:

Upper 16 bits

Value | Meaning
SUCCESS_SUCCESS = 0 | Check was a success
FAILURE = 3 | Check could not be completed.

Lower 16 bits

Value | Meaning
ERROR_UNKNOWN = -1 |
ERROR_UNKNOWN = 4 |
DRIVER_INSTALLED = 32 | Driver is installed
DRIVER_NOTINSTALLED = 64 | Driver is not installed
DRIVER_IS_INSTALLED_BUT_INVALID_VERSION = 2048 | The driver is installed, but is not the version required by applications produced with this version of the SDK.


Software that is incompatible with the capture driver

Software incompatible with the capture driver

We have discovered that the ASUS 'Enhanced Display Driver' can cause severe system instability when installed on the same PC as 'mirror' display drivers, of which the FlashBack capture driver is one.

Specifically, the problems we have observed on PCs that use the ASUS driver are:

  • If the capture driver is used for recording, the PC is reset.

  • Windows fails to start once the capture driver is installed. Windows 'use last good configuration' option must be used on boot up to start the operating system. This option effectively deinstalls the most recently installed of the two drivers.

Because of the severity of these problems, the FBRecorder::InstallDriver method will not install the capture driver if it detects that the ASUS driver is currently installed. A value indicating this is returned from the method, and applications can make use of DirectX and GDI record modes instead, which work without problems.

The ASUS driver is provided on CD with newer graphics cards, and can be downloaded from their website.


Installation - Visual Studio .NET

BB FlashBack SDK: Installation

Visual Studio.NET

The SDK consists of two visual components: FBPlayer and FBRecorder classes, and two non-visual libraries: the BBFlashBackEditor library (contained in BBFlashBackEditor.dll) and BBFlashBackVDisk library (contained in BBFlashBackVDisk.dll).

Note: only the FBPlayer and FBRecorder classes will be visible in Visual Studio at design-time. Other classes have to be created at runtime. See the sample code that was installed with the SDK for examples - in the 'Samples' folder under the SDK installation folder.

To install the visual components in Visual Studio .NET, for use from managed C++, Visual Basic .NET, and C#, follow the steps described below.

  1. Click the right mouse button on the designer toolbox and select Choose Items.

  2. A dialog with two pages appears. Select the second page titled COM Components.

  3. Locate the classes FBPlayer and FBRecorder.

  4. Check the boxes next to the classes and click OK.

  5. The new icons for FBPlayer and FBRecorder are now visible on the designer toolbox.

You may now drop these items on your forms and set their properties, call their methods, etc.

To install the non-visual libraries, you must include the library into the project manually. Right click on the Reference folder in the Solution explorer panel and select the Add Reference... item. Switch to the COM tab sheet and select either BBFlashbackEditor Library or BBFlashbackVDisk Library. Then the proper namespaces will be accessible from code.

Note

Recall that in the .NET environment you may not use the objects before the application has been fully initialized.

See Also

Visual Studio, Borland Delphi / C++ Builder


Installation - Visual Studio

BB FlashBack SDK: Installation

Visual Studio

To install the BB FlashBack SDK components, please carry out the steps corresponding to your development environment.

Note: only the FBPlayer and FBRecorder classes will be visible in Visual Studio at design-time. Other classes have to be created at runtime. See the sample code that was installed with the SDK for examples - in the 'Samples' folder under the SDK installation folder.

Visual C++

You may follow one of the two approaches below:

  • Use ATL or MFC projects and place FBPlayer and FBRecorder classes on the designer toolbox.

  • If you prefer pure C++ instead, use interface descriptions to create and use FBPlayer and FBRecorder objects at runtime.

To use ActiveX objects (such as FBPlayer or FBRecorder) included in the SDK, you can directly add ActiveX Control to your dialogs by selecting the "Insert ActiveX Control..." menu item from the context menu.

To use COM objects (such as FBEditor or FBVDisk) from BB SDK follow these steps:

  1. Add an #import directive to your stdafx.h file. i.e.
    #import "C:\Program Files\Blueberry Software\BB FlashBack SDK\BBFlashBackEditor.dll"
    no_namespace named_guids

  2. Add CComQIPtr<IID> to your application and the object will be available for use.

Visual Basic

  1. Place FBPlayer and FBRecorder classes on the designer toolbox.

  2. Drop the objects on the form and use as you would any other ActiveX object.

You are now ready to use the ActiveX controls in your applications.

See Also

Visual Studio .NET, Borland Delphi / C++ Builder


Borland Delphi / C++ Builder

Note: only the FBPlayer and FBRecorder classes will be visible in Visual Studio at design-time. Other classes have to be created at runtime. See the sample code that was installed with the SDK for examples - in the 'Samples' folder under the SDK installation folder.

Installing

To install the BB FlashBack SDK components into a Borland development IDE, follow the steps described below.

  1. Choose the Component menu, and click Import ActiveX Control.

  2. Scroll down the list of available controls and locate the items BB FlashBack Player and BB FlashBack Recorder. Highlight or the other - you will need to carry out this install process for both.

  3. Click Install to install into an existing (or new) package. You may alternately click Create Unit if you wish to add an import unit directly into your project and create the FlashBack objects dynamically at runtime.

Once the Player and Recorder ActiveX controls are imported, you are ready to use the BB FlashBack SDK components.

Upgrading

If you are upgrading from a previous version of the BB FlashBack SDK, follow the steps below to ensure a successful re-installation into the IDE:

  1. Remove the SDK components from your component packages.

  2. Rebuild and re-install your component packages.

  3. Close the IDE.

  4. Unregister the OCXs.

  5. Delete BB* files in the Imports folder of your IDE.

  6. Re-register the OCXs.

  7. Follow the steps for installing the components.

See Also

Visual Studio .NET, Visual Studio


Features of the Basic Edition

The FlashBack SDK Basic edition enables developers to create applications that:

  • Record movies from the screen, with sound.

  • Play back screen recordings.

You cannot:

  • Add sound to movies

  • Add text, images or other objects.

  • Edit sound or video frames

  • Export movies to a common format like AVI, MP4, WMV or Flash

  • Have direct access to the virtual files in the FBR format via the FBVDisk and FBVFile classes

The Basic edition of the SDK is priced per-seat and applications produced using it can be sold royalty-free. See Purchasing the SDK for more details.


Features of the Professional Edition

The FlashBack SDK Professional edition enables developers to create applications that:

  • Record the screen and sound.

  • Play back screen recordings.

  • Add and edit sounds and markers in the movie.

  • Insert and delete frames in the movie.

  • Have direct access to virtual files and disks within the FBR file format.

You cannot:

  • Export movies to common video formats like AVI, MP4, WMV and Flash.

  • Add objects like images, textboxes, buttons or blurs.

These functions require the Advanced edition.

The Professional edition of the SDK is priced per-seat and applications produced using it can be sold royalty-free. See Purchasing the SDK for more information.


Features of the Advanced Edition

The FlashBack SDK Advanced edition enables developers to create applications that:

  • Record the screen and sound.

  • Play back screen recordings.

  • Add and edit sounds, video, images, text boxes and markers in the movie.

  • Insert and delete movie frames.

  • Have direct access to virtual files and disks within the FBR file format.

  • Export movies as common formats like AVI, MP4, WMV and Flash.

All the methods and properties documented in this help file are available for use.

The Advanced edition of the SDK is priced flexibly, so Blueberry would be happy to discuss your requirements. See Purchasing the SDK for more details.


FBRecorder Class

This class is used to record FlashBack format movie files (.FBR files) of the screen.

These files can be played back using the FBPlayer class, and edited using the FBEditor class.

Record Modes

A number of different recording technologies can be used. The ideal one for any given situation may depend on the operating system in use and the type of material being recorded. See About Record Modes for details.

Installing the Capture Driver

Capture driver recording mode provides a powerful, high peformance method of recording the screen, but the driver needs to be installed before it can be used. See Installing the Capture Driver on an End-User PC for details of how to install the driver.

Recording Windows and Regions

The SDK allows you to record the full desktop, a region, a single window, multiple windows or the windows owned by a specific process. See Recording Windows and Regions for more details.

Recording Sound

The FBRecorder class can record sound at the same time as the screen. You have full control over which sources and devices are recorded. See Recording Sound Sources and Devices for details.

Recording WebCam Video

The FBRecorder class can also record from an attached webcam, including recorded video in the FlashBack movie file along with the sound and screen recordings. See Recording WebCam Video for details.

Virtual Disks and Files

Each .FBR file is constructed internally as a 'virtual disk' which can contain any number of 'virtual files'. This enables storage of other files within the .FBR movie file. See About Virtual Disks and Files for details.

Methods

SoundRelated
GetDefaultSoundDevice
GetSoundDevice
GetSoundDeviceByName
GetSoundLineMuteValue
GetSoundLineVolume
GetSoundSource
GetSoundSources
GetSoundSourcesInfo
GetVistaSoundSource
GetVistaSoundVolumevalue
SetSoundLineMuteValue
SetSoundLineVolume
SetVistaSoundVolumeValue

WebCam Related
GetSelectedWebCamFormat
GetSelectedWebCamSource
GetWebCamFormat
GetWebCamProperties
GetWebCamSource
RecordWebCamToFile
SelectWebCamFormat
SelectWebCamSource
SetWebCamParameters
TestWebCam

CaptureDriver Related
CanDriverBeInstalled
CheckDriver
InstallDriver
IsDriverVersionOK
UninstallDriver

Other Methods
AddBitmapByHandle
AddBitmapFromMemory
AddWndToList
ClearWndList
CurrentFrameNum
GetCurrentMonitor
GetErrorText
GetLicenceInfo
GetMonitor
GetPrimaryMonitor
GetRecordMonitor
GetRecordMonitorsDesktopPosition
GetRecordMonitorsDesktopSize
GetRecordMonitorsNumber
GetRecordRegion
GetRuntimeLicence
InsertMarker
InsertSoundToFBRAtMarker
InsertTextBox
PauseAndSave
RecordMonitor
RecordSingleMonitor
RegionFromHWND
RemoveWndFromList
SaveAndContinue
SelectMonitor
SetProcessId
SetRecordRegion
SetRuntimeLicence
Start
Stop
TestCompatibilityRecordMode
UpdateDisplayList

Properties

Sound Related
CompressSound
CorrectSoundSync
MP3Quality
RecordSound
SoudnDevice
SoundDevicesCount
SoundFormat
SoundSource
SoundSourcesCount
VistaMicrophoneID
VistaRecordDualSources
VistaRecordPCSounds
VistaRecordMicrophone
VistaSoundSource
VistaSoundSourceCount
VistaSoundSourceName

WebCam Related
UseWebCam
WebCamFormatsCount
WebCamKeyFrames
WebCamSourceAvailable
WebCamSourcesCount
WebCamQuality

Other Properties
ActualStartOffset
BitmapModeScreenHeight
BitmapModeScreenWidth
CheckForLimit
CompatibilityMode
CompressionLevel
DCIManagerEnabled
Delay
DelayBeforeStart
DisableHardwareAcceleration
DisableShowWinContents
EnableLogging
Filename
FramesPerSec
IsDriverInstalled
IsRecording
IsVista
KeyFramesFrequency
Limit
LowColorDepth
MonitorsCount
ParentWindow
Pause
RecordExtraMouseEvents
RecordingRegionType
RecordKeyboardEvents
RecordMode
RecordMouseCursor
RegionHeight
RegionWidth
RegionX
RegionY
RuntimeLicence
SaveMovieInOldFormat
SetPlainWallpaper
TimeBetweenFrameRecord
TurnOffUIEffects
UseDesktopDCOnly
UseLowColorDepth
UseRegion

See Also

The FBPlayer Class The FBEditor Class The FBVDisk Class The FBVFile Class


About Record Modes

BB FlashBack SDK has a number of methods of recording the screen. The best choice of record modes depends on the operating system in use on the end-user's PC and what type of material is being recorded.

The four modes - capture driver, MPEG, DirectX, GDI and Bitmap - are outlined below.

GDI Mode

Runs on Windows 98 and newer.

This mode runs on the widest range of operating systems and hardware.

Its disadvantage in comparison to DirectX and capture driver modes is that it often cannot capture the screen at as high a frame rate and may produce a greater impact on PC performance.

Its advantage over the capture driver is that it does not require installation of a driver and can record animating content at a higher frame rate - see Recording Movie Player Applications.

When recording with GDI mode, better performance can be achieved by turning off graphics hardware acceleration in Windows. This also has the effect of preventing media player applications from using 'overlays' which cannot be recorded by the SDK with any record mode.

Select GDI mode by setting FBRecorder::RecordMode to 0 and FBRecorder::CompatibilityMode to 0.

MPEG Mode

Runs on Windows 98 and newer.

This mode is best for recording moving video. It produces a much smaller FBR file than GDI or Capture Driver mode and should achieve a better frame rate. It can produce higher CPU loading though when recording large desktops - it is best used on a region.

Select MPEG mode by setting FBRecorder::RecordMode to 0 and FBRecorder::CompatibilityMode to 3.

Set image quality with the FBRecorder::MPEGQuality property.

Capture driver mode

Runs on Windows 2000 and newer.

This mode is capable of the highest performance on a wide range of hardware. On faster PCs, even if 'integrated' or older graphics hardware is used, this mode usually has a very small impact on PC performance while recording.

It is optimised for recording 'standard' Windows applications, like MS Word or Windows Explorer, that do not contain animations and moving images. It may struggle to capture activity like Flash animations or moving video, producing a low number of frames per second and a larger impact on PC performance. GDI and DirectX modes are a better choice for recording this type of material.

The driver needs to be installed before capture driver mode can be used for recording. A reboot may occasionally be required after installation. Also, administrator rights are required for driver installation.

It cannot record Vista's 'Aero' graphics mode - it will force Vista to Basic mode while recording.

See Installing the Capture Driver for more information on installing the driver.

Select capture driver mode by setting FBRecorder::RecordMode to 1

DirectX mode

Runs on Windows 98, 2000, XP, 2003.

Note: DirectX mode is not available on Windows Vista or 7. An OnError event is generated if FBRecorder::CompatibilityMode is used to select DirectX mode when running on Vista.

Note: DirectX mode can only record the primary monitor.

DirectX 7.0 or newer is required. Windows 98 users may need to update their installation of DirectX. Windows 2000, XP and 2003 should already come installed with DirectX 7.0 or newer.

This mode can give very high performance on PCs with newer graphics hardware.

Its advantages over the capture driver are that it does not require installation of a driver, and can record animating or moving video content at a higher frame rate - see Recording Movie Player Applications.

Its disadvantage is that some PCs are incapable of running the mode.

Select DirectX mode by setting FBRecorder::RecordMode to 0 and FBRecorder::CompatibilityMode to 1.

Bitmap mode

In this mode, the screen is not automatically recorded in the same way as in the modes described above. Once recording is started, images are saved to the movie file via the FBRecorder::AddBitmapByHandle and FBRecorder::AddBitmapFromMemory methods.

When the movie is played back, these images are displayed in the same order they were added, at their specified position. If an image was added 5.5 seconds after the start of recording, then it will be displayed 5.5 seconds after the start of playback.

Select Bitmap mode by setting FBRecorder::RecordMode to 0 and FBRecorder::CompatibilityMode to 2.


Recording Windows and Regions

BB FlashBack SDK can record the entire desktop, selected monitors, a particular region of it, a single window or multiple windows.

Note: capture driver record mode can only record the primary monitor

To record the entire desktop:

  1. Set UseRegion to False.

To record a region of the desktop:

  1. Set UseRegion to True.

  2. Set RecordingRegionType to 1

  3. Define the region with the SetRecordRegion method.

    Or, set the RegionHeight, RegionWidth, RegionX, RegionY properties to define the region you want to record.

The movie produced will be the size of the specified region. The correct monitor (or monitors if the region spans multiple monitors) will be automatically selected.

To record a single window:

  1. Set UseRegion to True

  2. Set RecordingRegionType to 1

  3. Call RegionFromHWND, passing the handle of the window you want to record.

The movie produced will be sized to the dimensions of the selected window. The correct monitor (or monitors if the window spans multiple monitors) will be automatically selected. The recording region defined in this way is static - it will not follow the window if it is moved or resized.

To record a single window and 'follow' it if the window moves

  1. Use SetRecordRegion to set the size of the recording region. The size will not change during the recording, only its position on the desktop.

  2. Set RecordingRegionType to 2

  3. Use AddWndToList to add the window handle of the window you want to record

The recording will display the selected window.

To record multiple windows:

  1. Set UseRegion to True

  2. Set RecordingRegionType to 2

  3. Use AddWndToList, passing the handles of the windows you want to record.

The movie produced will be the size of the desktop, but all areas outside of the specified windows will be blacked out.

To record multiple windows all belonging to one process:

  1. Set RecordingRegionType to 3

  2. Call SetProcessId, passing the Id of the process you want to record.

The movie produced will be the size of the desktop, but all areas outside of the windows owned by the specified process will be blacked out.


Recording Sound

BB FlashBack SDK: Base Classes

Recording Sound Sources and Devices

A PC will typically have a sound 'device' for each sound card installed, and each device will have a number of sources available for recording, such as the microphone, PC sounds, line in and others.

FBRecorder allows you to set the sound device and source to record from, but uses a different set of methods and properties for Windows 2000/XP than for Vista.

For help on accessing individual sound tracks in a recording and saving them to files, see How the sound classes work.

Windows 2000/XP

Setting the Sound Device and Source in Windows 2000/XP

  1. Use SoundDevicesCount to get the number of attached recordable sound devices. This gives the range of valid device indexes.

  2. Pass a device index into GetSoundDevice, to get a device ID and name.

  3. Select a sound device for recording by setting SoundDevice to the ID of the required device.

    Once we've selected a sound device, we follow a similar process to select a sound source on that device.

  4. Call GetSoundSources to prepare the internal list of sound sources. This call has to be made before using SoundSourcesCount, GetSoundSource and GetSoundSourcesInfo.

  5. Use SoundSourcesCount to get the number of sources available on the selected device. This gives the range of valid source indexes.

  6. Set SoundSource to the index of the source to be recorded.

Altering source volume or muting sources in Windows 2000/XP

The GetSoundLineVolume and SetSoundLineVolume methods can be used to retrieve and set the recording volume for a particular source on the current device.

The GetSoundLineMuteValue and SetSoundLineMuteValue can be used to mute a source.

The input to these functions is a LineID, returned from GetSoundSource when the source index is passed in.

Getting the index of the Microphone and "PC sounds" sources

To get the index of the current source, microphone and "mix" source (typically the sounds heard in the PC speakers), use GetSoundSourcesInfo.

Windows Vista and 7

Retrieving the ID and other information for each sound source

Use VistaSoundSourcesCount to get the number of sound devices and sources available for recording. It returns the total number of sources available for recording across all attached devices. The gives a range of valid indexes that can be passed to GetVistaSoundSource.

Pass an index into GetVistaSoundSource to retrieve information, including the ID, for a device-source combination.

To identify microphone sources:

  • The "component type" of microphone sources (returned from GetVistaSoundSource) is 4099 (MIXERLINE_COMPONENTTYPE_SRC_MICROPHONE).

To identify the "PC Sounds" source (the sound you hear through the PC speakers)

  • The "PC Sounds" source has an ID of -1. Retrieve the ID of the source by calling GetVistaSoundSource.

To record a microphone source in Vista:

  • Set VistaRecordPCSounds to False

  • Set VistaSoundSource to the ID of the microphone to record. Get the ID by using GetVistaSoundSource to identify the microphone source (see above).

  • Other properties, such as VistaRecordMicrophone need not be set.

To record the "PC Sounds" source in Vista:

  • Set VistaRecordPCSounds to True

  • Set VistaRecordMicrophone to False

  • Set VistaSoundSourceName to the name of the PC Sounds source.
    Get the name of the source from the SourceFullName property returned from GetVistaSoundSource. The "PC Sounds" source always has an ID of -1.

To record a sound source other than "PC Sounds" or a microphone in Vista:

  • Set VistaRecordPCSounds to False

  • Set VistaSoundSource to the ID of the source to record, as returned by GetVistaSoundSource.

To record PC Sounds and microphone in Vista

Vista has extra sound functionality that enables recording of the microphone and "PC Sounds" source simultaneously, into different tracks.

  • Set VistaRecordPCSounds to True

  • Set VistaRecordMicrophone to True

  • Set VistaSoundSourceName to the name of the PC Sounds source, as returned in the SourceFullName property by GetVistaSoundSource. The "PC Sounds" source always has an ID of -1. Retrieve the ID of the source by calling GetVistaSoundSource.

  • Set VistaMicrophoneID to the ID of a microphone source.

Altering source volume or muting sources in Windows Vista

Use GetVistaSoundVolumeValue and SetVistaSoundVolumeValue to alter the volume of sound recording sources. These methods require source IDs. Call GetVistaSoundSource to obtain the source IDs, or get the ID of the microphone source from VistaMicrophoneID.


Recording Movie Player Applications

BB FlashBack SDK: Base Classes

Recording Movie Player Applications

Movie/Media player-type applications usually use 'overlays' to improve performance. This feature of DirectX allows them to write more directly to the screen, but images drawn in this way cannot be captured by the SDK, whichever record mode is used.

"Hardware acceleration" needs to be disabled during recording, to force the movie player application to use an alternative method of writing to the screen which can be captured successfully. This can be done via the Windows user interface or an API call.

To disable it via the Windows user interface: Go to the Control Panel, open Display, select the Settings tab, click the Advanced button, select the Troubleshoot tab and set Hardware Acceleration to None.

Disabling it via the Windows API requires that you set a registry value "acceleration.level" for the used display device, and use ChangeDisplaySettingsEx to force the change to be applied to the display. The location of this value in the registry varies, but the code below is an example of how it can be found and set:

// Set the acceleration level to 'none' to disable h/w acceleration
SetCurrentVideoAccelerationLevel(5);

// Now refresh the display device - this may cause brief screen blanking

DEVMODE devMode;

if (EnumDisplaySettings(NULL,  ENUM_CURRENT_SETTINGS, &devMode))
ChangeDisplaySettingsEx(NULL, &devMode, NULL, CDS_RESET, 0);

//----------------------------------------------------------------

bool SetCurrentVideoAccelerationLevel(DWORD dwValue)
{
bool res = false;
AnsiString sPath = FindVideoAccelerationKey();

  if (!sPath.IsEmpty())
{
HKEY hKey;

    if (RegOpenKeyEx(HKEY_LOCAL_MACHINE, sPath.c_str(), REG_OPTION_NON_VOLATILE, KEY_SET_VALUE, &hKey) == ERROR_SUCCESS)
 {
  res = true;

      if (dwValue == 0)
    RegDeleteValue(hKey, "Acceleration.Level";
  else
     RegSetValueEx(hKey, "Acceleration.Level", 0, REG_DWORD, (LPBYTE)&dwValue, sizeof(dwValue));

      RegCloseKey(hKey);
 }
}

  return res;
}

//---------------------------------------------------------------

AnsiString FindVideoAccelerationKey()
{
AnsiString sResult = "";
HKEY hKey;

  if (RegOpenKeyEx(HKEY_LOCAL_MACHINE, "HARDWARE\\DEVICEMAP\\VIDEO", REG_OPTION_NON_VOLATILE, KEY_READ, &hKey) == ERROR_SUCCESS)
{
char sTmp[1024];
DWORD dwDummy = sizeof(sTmp);

    sTmp[0] = 0;

    if (RegQueryValueEx(hKey, "\\Device\\Video0", 0, NULL, (LPBYTE)sTmp, &dwDummy) == ERROR_SUCCESS)
 {
  sResult = sTmp;

      if (sResult.LowerCase().Pos("\\registry\\machine\\") == 1)
     sResult.Delete(1, AnsiString("\\registry\\machine\\").Length());

    }
 RegCloseKey(hKey);
}

  return sResult;
}


Recording WebCam Video

BB FlashBack SDK: Base Classes

Recording WebCam Video

The FBRecorder class can record video from an attached webcam while recording the screen. This webcam video footage is saved into the FBR movie file and can be displayed by the FBPlayer class.

How to record webcam video

  1. Use the FBRecorder::WebCamSourceAvailable property to determine whether a webcam is attached.

  2. Use the WebCamFormatsCount and WebCamSourcesCount properties to determine the formats and sources available for the user to choose from. The GetWebCamFormat and GetWebCamSource methods return displayable names and descriptions for the formats and sources.

  3. If you want to allow the user to adjust image quality settings for the webcam:

    • Use the TestWebCam method to display webcam output in a window of your choosing, and display controls to allow the user to adjust brightness, contrast etc

    • Use GetWebCamProperties to get a WebCamProperties object, and change its properties in response to user adjustments to the brightness, contrast controls.

  4. Set the keyframe frequency and quality of video to be captured from the webcam via the WebCamQuality and WebCamKeyFrames properties.

  5. Set UseWebCam to True

  6. Either start recording normally, to have the webcam video recorded at the same time as the screen, or use RecordWebCamToFile to capture only from the webcam.

How to display webcam video

  1. In FBPlayer, use the HasWebCamVideo property to determine whether the movie file contains webcam video.

  2. Use FBMovie::WebCamWindowVisible and FBMovie::WebCamVideoMode to set the appearance of the webcam video in the player. Use FBPlayer::WebCamVideoPositionX and FBPlayer::WebCamVideoPositionY to set its position.


Recording on a system with multiple monitors

BB FlashBack SDK: Base Classes

Recording on a system with multiple monitors

The FBRecorder class can simultaneously record from more than one monitor in a system where the desktop spans multiple monitors. The resulting movie will have dimensions that cover all recorded monitors on the desktop and show regions that fall outside all recorded monitors as black.

Note: when using capture driver mode, only the primary monitor can be recorded

MonitorsCount returns the number of monitors attached to the system.

GetRecordMonitorsNumber returns the number of monitors that will be recorded.

GetMonitor returns information on a monitor.

GetPrimaryMonitor returns the index of the primary monitor.

RecordMonitor is used to select monitors for recording.

RecordSingleMonitor sets a single monitor for recording, de-selecting other monitors.

GetRecordMonitor is used to determine which monitors are selected for recording.

When setting a region to record with SetRecordRegion, or windows to record with RegionFromHWND, AddWndToList or SetProcessId, the monitors to be recorded are set automatically.


Fixing Sound Sync Problems

BB FlashBack SDK: Base Classes

Fixing Sound Sync Problems

Some sound hardware does not apply certain sampling rates precisely. This results in a sound recording that, when played back at the originally selected sample rate, is shorter or longer than the video track recorded at the same time. This can cause sync problems - the audio and video do not appear to be synchronised.

Set FBRecorder::CorrectSoundSync to True to have FBRecorder measure errors in the audio recording sampling rate, and process the recorded audio track to correct these errors. The processing is carried out when recording stops, so there may be a period of time when FBRecorder is unresponsive. Use the FBRecorder::OnCloseOutputFile event to communicate this processing period to the user.

You can either always set CorrectSoundSync to True, and incur this extra processing for every movie recorded, or have a setting in your program GUI: "Correct sound sync problems" (or similar), that sets this property. Sound sync problems should only be experienced with some sound hardware, at some sample rates.


FlashBack Movie File Formats

BB FlashBack SDK: Base Classes

FlashBack Movie File Format Versions

Because features have been added to the FlashBack SDK over time, the FlashBack file format (.FBR files) has also changed over SDK versions.

The different versions of the SDK and the FBR file format versions they produce are:

SDK Version | Produces FBR files of version
1.0 | 1.0
2.0 | 1.4.5
2.5 (current version) | 2.0 or 1.4.5 - see below

How to know what version of the SDK you are using:

  1. Navigate to the FlashBack SDK install folder.

  2. Open the version.txt file in that folder - this file holds the SDK version.

FBR Versions used by version 2.5 of the SDK:

  • FBRecorder saves v1.4.5 FBR files by default, unless FBRecorder::SaveMovieInOldFormat is set to false, in which case it saves v2.0 FBRs.

  • FBEditor saves v2.0 FBR files by default, but FBMovie::SaveAsUsingFormat can be called to save in v1.4.5 format, although this will mean newer features such as Zoom-Pan objects are removed from the movie.

SDK v1.0 classes cannot open v1.4.5 or v2.0 FBRs

SDK v2.0 classes cannot open v2.0 FBRs

How to know the version of an FBR file:

FBEditor::GetMovieVersion and FBEditor::IsMovieInOldFormat can be used to discover the FBR file format.

FBEditor::IsMovieInOldFormat returns false when the FBR version is 2.0, and true for earlier versions.


Displaying a Recording Level indicator

BB FlashBack SDK: Base Classes

Displaying a Recording Level Indicator

The properties EnableSoundInputQuery, SoundInputMaximum and SoundInputValue can be used to get sound input levels in real time from the currently selected recording source.

The PCSoundsMicSoundInputValue and PCSoundsMicSoundInputMaximum properties can also be used when recording the PC Sounds and Microphone sources simultaneously on Windows Vista / 7 to read the levels of the Microphone source. This enables dual recording level indicators - one for PC Sounds and one for the Microphone.

After setting the recording source via the SoundDevice and SoundSource properties (VistaSoundSource property for Windows Vista), set EnableSoundInputQuery to true, and poll the SoundInputMaximum and SoundInputValue properties on a timer to enable display of a recording level indicator.


Recovering Corrupted Recordings

BB FlashBack SDK: Base Classes

Recovering Corrupted Recordings

Recording files (FBR files) can be corrupted by unscheduled termination of the recorder process, so that they cannot be played back. Some corrupted recordings can be recovered if recovery data is created, and the FBRecorder class has a number of methods and properties to assist with the process.

Here is the process for checking and recovering an FBR that was being recorded when FBRecorder experienced an unscheduled termination:

  1. The FBRecorder::CreateRecoverInfo property must have been set to true before recording starts to create the recovery data.

  2. Use FBRecorder::IsMovieStructureOk to check whether the FBR file that was being recorded has been corrupted.

  3. If the file is corrupted, use the FBRecorder::CanMovieBeRecovered method to check that it can be recovered. This method returns the name of the recovery info file.

  4. Use FBRecorder::RecoverMovie to create a new FBR file, using the corrupted FBR and the recovery info file.


Recording to MP4/H264

BB FlashBack SDK: Base Classes

Recording to MP4/H264

MP4/H264 recording is only available in the Pro and Advanced editions of the SDK

The FlashBack SDK can use OpenH264 to record to MP4/H264 format files instead of FBR format.

To record to H264 encoded video in an MP4 container:

  1. Set FBRecorder::OutputFileFormat to 1

  2. Set FBRecorder::OpenH264Config to the path of welsenc.cfg and welslayer.cfg. They must be in the same folder. These files are included in the SDK installation.

  3. Have your application download the archive at http://ciscobinary.openh264.org/openh264-1.2.0-win32msvc.dll.bz2

    Rename the file extracted from the archive to welsenc.dll and copy it to the same folder as your application executable.

    If you download the DLL from the above URL, Cisco will be responsible for royalties payable on H264 video generated by your application. If you do not download the DLL but instead include it in your application installation, then you are liable for H264 royalties levied by MPEG LA. Some more about this: http://www.openh264.org/faq.html

  4. Include these files in the same folder as your application executable (or set the PATH environment variable to point to their folder). They are included in the SDK installation.

    OpenH264Lib.dll
    LibAVEncoder.dll
    libiomp5md.dll
    BBIPP.dll
    avcodec-52.dll
    avcore-0.dll
    avformat-52.dll
    avutil-50.dll
    libmfxaudiosw32.dll
    libx264-128.dll
    swscale-0.dll

MP4 files recorded by the SDK do not include a cursor image.

MP4 files can not be played and edited by FlashBack SDK classes.

Recording Audio

To record audio into MP4, set these properties on FBRecorder:

RecordSound | True
CompressSound | True
AlwaysUseVistaAudioAPI | True
CorrectSoundSync | True
VistaAudioCaptureDeviceName | "devicename1"
VistaSecondAudioCaptureDeviceName (optional) | "devicename2"
MP4Bitrate | 100
MP4AACBitrate | 320000


Sample Code

BB FlashBack SDK: Base Classes

MP4 Recording - Sample Code

The VB.NET code below records video and audio from two sources (the default microphone and one other source) to an MP4 file.

Imports System.Environment
Imports BBFlashBackRecorder
Imports System.IO

Module MainModule

Const MIXERLINE_COMPONENTTYPE_SRC_MICROPHONE = 4099

Function FindMicrophone(recorder As FBRecorder)

      For i = 0 To recorder.VistaSoundSourcesCount - 1
          Dim devname, source, fullname As String
          Dim waveid, componenttype As Long

           devname = ""
          source = ""
          fullname = ""

           recorder.GetVistaSoundSource(i, devname, source, fullname, waveid, componenttype)

           If componenttype = MIXERLINE_COMPONENTTYPE_SRC_MICROPHONE Then
             System.Console.WriteLine("Found microphone: " + fullname)
             Return fullname
          End If
     Next

      Return ""

End Function

Sub Main()

      Dim recorder As New FBRecorder

      recorder.SetRuntimeLicence("YOUR_RUNTIME_LICENCE")
     recorder.SaveMovieInOldFormat = False

      REM select an audio device to be recorded
     REM since Windows Vista we must use recorder.VistaXXXXXX audio methods

      If recorder.VistaSoundSourcesCount > 0 Then

          Dim microphone As String

          microphone = FindMicrophone(recorder)

          If microphone.Length > 0 Then
              System.Console.WriteLine("Use the microphone as the first sound source.")
             recorder.VistaAudioCaptureDeviceName = microphone
             System.Console.WriteLine("Choosing the second audio device...")
         End If

          System.Console.WriteLine("Select audio device to be recorded (use 0 to disable audio recording):")

          Dim audio_devices As New List(Of String)
         Dim audio_device_index As Integer = 0

          For i = 0 To recorder.VistaSoundSourcesCount - 1
              Dim devname, source, fullname As String
              Dim waveid, componenttype As Long

               devname = ""
              source = ""
              fullname = ""

               recorder.GetVistaSoundSource(i, devname, source, fullname, waveid, componenttype)

               If componenttype <> MIXERLINE_COMPONENTTYPE_SRC_MICROPHONE Then
                  audio_devices.Add(fullname)
                  System.Console.WriteLine((audio_device_index + 1).ToString() + ": " + fullname)
                  audio_device_index = audio_device_index + 1
              End If
         Next

          System.Console.Write("Enter audio device index: ")

          Dim audio_device_str As String

          audio_device_str = System.Console.ReadLine()

          Dim audio_device As Long

          If Not Int32.TryParse(audio_device_str, audio_device) Then
             audio_device = 0
         End If

          If audio_device > 0 And audio_device <= recorder.VistaSoundSourcesCount Then
             System.Console.WriteLine("Will record audio " + audio_devices.Item(audio_device - 1))
             recorder.RecordSound = True

              If microphone.Length > 0 Then
                 recorder.VistaSecondAudioCaptureDeviceName = audio_devices.Item(audio_device - 1)
             Else
                 recorder.VistaAudioCaptureDeviceName = audio_devices.Item(audio_device - 1)
             End If
         End If

          If recorder.VistaSecondAudioCaptureDeviceName.Length = 0 And recorder.VistaSecondAudioCaptureDeviceName.Length = 0 Then
             recorder.RecordSound = False
         Else
             recorder.RecordSound = True
         End If

      Else
         System.Console.WriteLine("You have no audio devices.")
         recorder.RecordSound = False
     End If

      recorder.CompressSound = True
     recorder.AlwaysUseVistaAudioAPI = True
     recorder.CorrectSoundSync = True
     recorder.DelayBeforeStart = 0
     recorder.Filename = My.Application.Info.DirectoryPath + "\Test.mp4"

      File.Delete(recorder.Filename)

      recorder.RecordMonitor(0, True)
     recorder.RecordMode = 0
     recorder.UseDesktopDCOnly = True
     recorder.CompatibilityMode = 3
     recorder.FramesPerSec = 10
     recorder.OutputFileFormat = 1
     recorder.RemoveActionsFileForMP4Recording = True
     recorder.OpenH264Config = My.Application.Info.DirectoryPath + "\welsenc.cfg"

      REM recorder.DontUseLowLevelHooks = True

      recorder.MP4QualityMode = 0
     recorder.MP4Quality = 1
     recorder.MP4Bitrate = 100
     recorder.MP4AACBitrate = 320000

      Dim result = recorder.Start()

      If Not result Then
         System.Console.WriteLine("Error!")
     Else
         System.Console.WriteLine("The recording started!")

          REM sleep for 10 seconds to make a recording
         System.Threading.Thread.Sleep(10000)
         recorder.Stop()
         System.Console.WriteLine("The recording stopped!")
     End If

End Sub

End Module


FBRecorder::CompressSound

BB FlashBack SDK: FBRecorder

CompressSound

Description

Determines whether sound is to be compressed to MP3 format once recorded.

Syntax

[C#/C++]
public: Bool CompressSound;

[VB.NET]
Public Property CompressSound As Boolean

See Also


CorrectSoundSync

BB FlashBack SDK: FBRecorder

CorrectSoundSync

Description

Applies processing when recording stops, to correct sound sync problems.

Some sound hardware does not apply certain sampling rates precisely. This results in a sound recording that, when played back at the selected sample rate, is shorter or longer than the video track recorded at the same time. This can cause sync problems - the audio and video do not appear to be synchronised.

Set CorrectSoundSync to True to have FBRecorder measure errors in the audio recording sampling rate, and process the recorded audio track to correct these errors. The processing is carried out when recording stops, so there may be a period of time when FBRecorder is unresponsive. Use the FBRecorder::OnCloseOutputFile event to communicate this processing period to the user.

You can either always set CorrectSoundSync to True, and incur this extra processing for every movie recorded, or have a setting in your program GUI: "Correct sound sync problems" (or similar), that sets this property. Sound sync problems should only be experienced with some sound hardware, at some sample rates.

Syntax

[C#/C++]
public: Bool CorrectSoundSync;

[VB.NET]
Public Property CorrectSoundSync As Boolean

See Also


CurDesync

BB FlashBack SDK: FBRecorder

CurDesync

Description

When a recording stops, this property shows the how far out of synchronisation the audio and video tracks are, in milliseconds.

Syntax

[C#/C++]
public: long CurDesync;

[VB.NET]
Public Property CurDesync As Integer

Remarks

The size of the desynchronisation depends on the PCs audio hardware and CPU loading during recording. The desync value should be compared to WAVEIN_MAX_DESYNC, and if larger, the audio and video tracks resynchronised by calling FBSounds:Resynchronise, passing in the length of the recording (get this via opening the recording in FBPlayer and using the Length property).

See Also

FBSounds::Resynchronise


CustomSoundTrackMaxInterval

BB FlashBack SDK: FBRecorder

CustomSoundTrackMaxInterval

Description

Used when a custom sound track is being created by calls to the AddSoundBlockByPointer method, this property defines the maximum interval in milliseconds between 2 consecutive sound blocks that are considered to be in the same sound clip.

It is used to ensure that any delays in the application processing and capturing sound data and passing it to AddSoundBlockByPointer do not result in gaps between sound blocks.

When a new sound block is added, if the interval between this and the end point of the previous sound block is greater than the CustomSoundTrackMaxInterval, it is added at the current time. If the interval is less than CustomSoundTrackMaxinterval, it is added at the end point of the previous sound block.

The default value is zero, so any intervals between sound blocks will be considered as silence, and the sound blocks created as separate clips.

Syntax

[C#/C++]
public: long CurrentSoundTrackMaxInterval;

[VB.NET]
Public Property CustomSoundTrackMaxInterval As Integer

See Also


EnableSoundInputQuery

BB FlashBack SDK: FBRecorder

EnableSoundInputQuery

Description

Enables an application to monitor sound input levels to the current recording source, enabling display of a 'recording level' type indicator.

Set EnableSoundInputQuery to True to enable reading of sound levels via the SoundInputMaximum, SoundInputValue, PCSoundsMicSoundInputMaximum, PCSoundsMicSoundInputValue properties.

Set EnableSoundInputQuery to False to disable sound level reading.

The recording source is set on Windows 2000 and XP by the SoundDevice and SoundSource properties, and on Windows Vista the VistaSoundSource property.

Syntax

[C#/C++]
public: Bool EnableSoundInputQuery;

[VB.NET]
Public Property EnableSoundInputQuery As Boolean

See Also


MP3Quality

BB FlashBack SDK: FBRecorder

MP3Quality

Description

Sets the quality used for MP3 compression, if that has been enabled via FBRecorder::CompressSound.

Syntax

[C#/C++]
public: long MP3Quality

[VB.NET]
Public Property MP3Quality As Long

Remarks

This property can take one of these values:

Value | Quality
0 | Low
1 | Medium (default)
2 | High

Sound will only be recorded with MP3 compression if CompressSound is set to True.

See Also

FBRecorder::CompressSound


MP4AACBitrate

BB FlashBack SDK: FBRecorder

MP4AACBitrate

Description

Sets the bitrate in KBits per second of audio in the exported movie.

Syntax

[C#/C++]
public long MP4AACBitrate;

[VB.NET]
Public Property MP4AACBitrate As Long

Remarks

This value is used only when ExportSound is set to True.

Audio is exported in AAC format. The higher the bitrate of the audio, the higher the quality.

See also

FBExportToMP4Params::ExportSound


MP4Bitrate

BB FlashBack SDK: FBRecorder

MP4Bitrate

Description

Sets the bitrate in KBits per second of audio in the exported movie.

Syntax

[C#/C++]
public long MP4Bitrate;

[VB.NET]
Public Property MP4Bitrate As Long

Remarks

This value is used only when ExportSound is set to True.

Audio is exported in AAC format. The higher the bitrate of the audio, the higher the quality.

See also

FBExportToMP4Params::ExportSound


PCSoundsMicSoundInputMaximum

BB FlashBack SDK: FBRecorder

PCSoundsMicSoundInputMaximum

Description

Gets the maximum sound level input to the microphone source. This is a read-only property.

This property should only be used on Windows Vista / 7, when the PCSounds and Microphone sources are being recorded together. Otherwise it will return zero.

The property, when used with PCSoundsMicSoundInputValue, EnableSoundInputQuery, SoundInputMaximum and SoundInputValue properties enables display of dual 'recording level' type indicators - one for the PC Sounds source and one for the Microphone source, when both sources are being recorded.

Use the VistaRecordPCSounds and VistaRecordMicrophone properties to record both sources on Windows Vista / 7.

Syntax

[C#/C++]
public: Long SoundInputMaximum;

[VB.NET]
Public Property SoundInputMaximum As Integer

See Also

FBRecorder::EnableSoundInputQuery FBRecorder::SoundInputValue FBRecorder::PCSoundsMicSoundInputValue FBRecorder::SoundInputMaximum FBRecorder::VistaRecordPCSounds FBRecorder::VistaRecordMicrophone


PCSoundsMicSoundInputValue

BB FlashBack SDK: FBRecorder

PCSoundsMicSoundInputValue

Description

Gets the sound level input for the microphone source. This is a read-only property.

This property should only be used on Windows Vista / 7, when the PCSounds and Microphone sources are being recorded together. Otherwise it will return zero.

The property, when used with PCSoundsMicSoundInputMaximum, EnableSoundInputQuery, SoundInputMaximum and SoundInputValue properties enables display of dual 'recording level' type indicators - one for the PC Sounds source and one for the Microphone source, when both sources are being recorded.

Use the VistaRecordPCSounds and VistaRecordMicrophone properties to record both sources on Windows Vista / 7.

Syntax

[C#/C++]
public: Long PCSoundsMicSoundInputValue;

[VB.NET]
Public Property PCSoundsMicSoundInputValue As Integer

See Also

FBRecorder::EnableSoundInputQuery FBRecorder::SoundInputValue FBRecorder::PCSoundsMicSoundInputMaximum FBRecorder::SoundInputMaximum FBRecorder::VistaRecordPCSounds FBRecorder::VistaRecordMicrophone


FBRecorder::RecordSound

BB FlashBack SDK: FBRecorder

RecordSound

Description

Determines whether sound should also be recorded when recording next starts.

Syntax

[C#/C++]
public: Bool RecordSound

[VB.NET]
Public Property RecordSound As Boolean

See Also


SoundDevice

BB FlashBack SDK: FBRecorder

SoundDevice

Description

Sets and reads the ID of the current sound recording device.

Get the IDs of sound devices from FBRecorder::GetSoundDevice.

Syntax

[C#/C++]
public: long SoundDevice

[VB.NET]
Public Property SoundDevice As Integer

See Also

FBRecorder::GetSoundDevice


SoundDevicesCount

BB FlashBack SDK: FBRecorder

SoundDevicesCount

Description

Returns the number of sound devices that can be recorded from. This gives the range of indexes that can be used for GetSoundDevice.

This property is for Windows 2000/XP only. When running on Windows Vista, VistaSoundDevicesCount should be used.

Syntax

[C#/C++]
public: long SoundDevicesCount

[VB.NET]
Public Property SoundDevicesCount As Long

See Also


FBRecorder::SoundFormat

BB FlashBack SDK: FBRecorder

SoundFormat

Description

Sets the sound format used for recording.

Syntax

[C#/C++]
public long SoundFormat;

[VB.NET]
Public Property SoundFormat As Long

Remarks

This can be one of the following standard Win32 SDK constants, describing the number of channels, sample rate and bits per sample:

Value |  | Format
WAVE_FORMAT_1M08 | 0x00000001 | 11.025 kHz, mono, 8-bit.
WAVE_FORMAT_1S08 | 0x00000002 | 11.025 kHz, stereo, 8-bit.
WAVE_FORMAT_1M16 | 0x00000004 | 11.025 kHz, mono, 16-bit.
WAVE_FORMAT_1S16 | 0x00000008 | 11.025 kHz, stereo, 16-bit.
WAVE_FORMAT_2M08 | 0x00000010 | 22.05 kHz, mono, 8-bit.
WAVE_FORMAT_2S08 | 0x00000020 | 22.05 kHz, stereo, 8-bit.
WAVE_FORMAT_2M16 | 0x00000040 | 22.05 kHz, mono, 16-bit.
WAVE_FORMAT_2S16 | 0x00000080 | 22.05 kHz, stereo, 16-bit.
WAVE_FORMAT_4M08 | 0x00000100 | 44.1 kHz, mono, 8-bit.
WAVE_FORMAT_4S08 | 0x00000200 | 44.1 kHz, stereo, 8-bit.
WAVE_FORMAT_4M16 | 0x00000400 | 44.1 kHz, mono, 16-bit.
WAVE_FORMAT_4S16 | 0x00000800 | 44.1 kHz, stereo, 16-bit.
WAVE_FORMAT_48M08 | 0x00001000 | 48 KHz, Mono, 8 bit
WAVE_FORMAT_48S08 | 0x00002000 | 48 KHz, Stereo, 8 bit
WAVE_FORMAT_48M16 | 0x00004000 | 48 KHz, Mono, 16 bit
WAVE_FORMAT_48S16 | 0x00008000 | 48 KHz, Stereo, 16 bit
WAVE_FORMAT_96M08 | 0x00010000 | 96 KHz, Mono, 8 bit
WAVE_FORMAT_96S08 | 0x00020000 | 96 KHz, Stereo, 8 bit
WAVE_FORMAT_96M16 | 0x00040000 | 96 KHz, Mono, 16 bit
WAVE_FORMAT_96S16 | 0x00080000 | 96 KHz, Stereo, 16 bit

See also


SoundInputMaximum

BB FlashBack SDK: FBRecorder

SoundInputMaximum

Description

Gets the maximum sound level input to the currently selected recording source, since EnableSoundInputQuery was set to True.

The EnableSoundInputQuery, SoundInputMaximum and SoundInputValue properties enable display of a 'recording level' type indicator.

Syntax

[C#/C++]
public: Long SoundInputMaximum;

[VB.NET]
Public Property SoundInputMaximum As Integer

See Also


SoundInputValue

BB FlashBack SDK: FBRecorder

SoundInputValue

Description

Gets the sound level input to the currently selected recording source.

The EnableSoundInputQuery, SoundInputMaximum and SoundInputValue properties enable display of a 'recording level' type indicator.

Syntax

[C#/C++]
public: Long SoundInputValue;

[VB.NET]
Public Property SoundInputValue As Integer

See Also


SoundSource

BB FlashBack SDK: FBRecorder

SoundSource

Description

Sets and reads the index of the current sound recording source.

Syntax

[C#/C++]
public: long SoundSource

[VB.NET]
Public Property SoundSource As Integer

See Also

FBRecorder::SoundSourcesCount


SoundSourcesCount

BB FlashBack SDK: FBRecorder

SoundSourcesCount

Description

Returns the number of sound sources that can be recorded on the current sound device. This gives the range of indexes that can be used for GetSoundSource.

This property should be used on Windows 2000/XP. Windows Vista enumerates sound sources differently. When running on Windows Vista, VistaSoundDevicesCount should be used to get the total number of sound sources across all devices.

Note: GetSoundSources should be called before accessing SoundSourcesCount to build an internal list of sound sources.

Syntax

[C#/C++]
public: long SoundSourcesCount;

[VB.NET]
Public Property SoundSourcesCount As Long

See Also


UseCustomSoundTrack

BB FlashBack SDK: FBRecorder

UseCustomSoundTrack

Description

This property is used with the InitCustomSoundTrack and AddSoundBlockByPointer methods to add sound to an in-progress recording. It must be set to true before recording starts.

See InitCustomSoundTrack for an example of usage.

Syntax

[C#/C++]
public: Bool UseCustomSoundTrack;

[VB.NET]
Public Property UseCustomSoundTrack As Boolean

See Also


UseNewSoundFormat

BB FlashBack SDK: FBRecorder

UseNewSoundFormat

Description

This setting determines whether sound is recorded in MP2 or MP3 format, when the CompressSound property is set to true. MP2 format has the advantage that repeated editing will not degrade audio quality.

UseNewSoundFormat is set to true by default. If SaveMovieInOldFOrmat is set to true, UseNewSoundFormat is set to false automatically.

Syntax

[C#/C++]
public: Bool UseNewSoundFormat;

[VB.NET]
Public Property UseNewSoundFormat As Boolean

See Also


ViistaAudioCaptureDeviceName

BB FlashBack SDK: FBRecorder

VistaAudioDeviceCaptureName

Description

Sets and gets the full name of the audio device to be recorded.

Get the full name of sound sources from GetVistaSoundSource.

This property is only used when VistaRecordPCSounds is True. See Recording Sound Sources and Devices for more help.

Syntax

[C#/C++]
public: BSTR VistaAudioDeviceCaptureName;

[VB.NET]
Public Property VistaAudioDeviceCaptureName As String

See Also

FBRecorder::VistaSecondAudioCaptureDeviceName


FBRecorder::VistaMicrophoneID

BB FlashBack SDK: FBRecorder

VistaMicrophoneID

Description

Set this property to the value of a microphone source ID, when recording the "PC Sounds" and microphone sources simultaneously.

See Recording Sound Sources and Devices for more help on recording these 2 sources simultaneously.

This property should only be used when running on Windows Vista.

Syntax

[C#/C++]
public: long VistaMicrophoneID

[VB.NET]
Public Property VistaMicrophoneID As Integer

See Also


VistaRecordDualSources

BB FlashBack SDK: FBRecorder

VistaRecordDualSources

Description

This property has exactly the same function as FBRecorder::VistaRecordPCSounds


RecordPCSounds

BB FlashBack SDK: FBRecorder

VistaRecordPCSounds

Description

Set this property to True to record the "PC Sounds" source.

When set to True, set VistaSoundSourceName to the name of the "PC Sounds" source.

When VistaRecordPCSounds is set to False, set VistaSoundSource to the ID of the source to be recorded.

The ID of the "PC Sounds" source is always -1. Find the IDs and names of sources via the GetVistaSoundSource method.

See Recording sound sources and devices for more help.

This property should be used when running on Windows Vista only.

Syntax

[C#/C++]
public: Bool VistaRecordPCSounds

[VB.NET]
Public Property VistaRecordPCSounds As Boolean

See Also


RecordVistaMicrophone

BB FlashBack SDK: FBRecorder

VistaRecordMicrophone

Description

When VistaRecordPCSounds is set to True, set VistaRecordMicrophone to True to record the microphone source in addition to the source defined by VistaSoundSource. FBRecorder will record the two sources into separate tracks in the FBR file created.

See Recording sound sources and devices for more help.

Syntax

[C#/C++]
public: Bool VistaRecordMicrophone

[VB.NET]
Public Property VistaRecordMicrophone As Boolean

See Also


VistaSecondAudioCaptureDeviceName

BB FlashBack SDK: FBRecorder

VistaSecondAudioDeviceCaptureName

Description

Sets and gets the full name of the second audio device to be recorded.

Get the full name of sound sources from GetVistaSoundSource.

This property is only used when VistaRecordPCSounds is True. See Recording Sound Sources and Devices for more help.

Syntax

[C#/C++]
public: BSTR VistaSecondAudioDeviceCaptureName;

[VB.NET]
Public Property VistaSecondAudioDeviceCaptureName As String

See Also

FBRecorder::VistaAudioCaptureDeviceName


FBRecorder::VistaSoundDevice

BB FlashBack SDK: FBRecorder

VistaSoundSource

Description

Sets and reads the ID of the current sound recording source.

This property is only used when VistaRecordPCSounds is false. See Recording Sound Sources and Devices for more help.

Get the IDs of sound sources from GetVistaSoundSource or VistaMicrophoneID.

Syntax

[C#/C++]
public: long VistaSoundSource

[VB.NET]
Public Property VistaSoundSource As Integer

See Also


FBRecorder::VistaSoundDevicesCount

BB FlashBack SDK: FBRecorder

VistaSoundSourcesCount

Description

Returns the number of sound sources that can be recorded across all devices.

This count is used to determine the range of indexes that can be passed into GetVistaSoundSource.

When running on versions of Windows other than Vista, SoundDevicesCount and SoundSourcesCount should be used.

Syntax

[C#/C++]
public: long VistaSoundSourcesCount

[VB.NET]
Public Property VistaSoundSourcesCount As Long

See Also

FBRecorder::GetVistaSoundSource


PCSoundsDeviceName

BB FlashBack SDK: FBRecorder

VistaSoundSourceName

Description

Sets and gets the full name of the sound source to be recorded in addition to the microphone, when recording dual sources in Vista.

Get the full name of sound sources from GetVistaSoundSource.

This property is only used when VistaRecordPCSounds is True. See Recording Sound Sources and Devices for more help.

Syntax

[C#/C++]
public: BSTR VistaSoundSourceName;

[VB.NET]
Public Property VistaSoundSourceName As String

See Also


UseWebCam

BB FlashBack SDK: FBRecorder

UseWebCam

Description

Set this property to True to have FBRecorder capture a video stream from a connected webcam while recording the screen. The captured video is stored in the FBR file along with the screen and sound recording.

Syntax

[C#/C++]
public: Bool UseWebCam;

[VB.NET]
Public Property UseWebCam As Boolean

Remarks

Your code should also set sensible values for the WebCamKeyFrames and WebCamQuality properties, and set the video format and source via the SelectWebCamVideoFormat and SelectWebCamVideoSource methods.

See Also

FBRecorder::UseWebCam FBRecorder::WebCamKeyFrames FBRecorder::WebCamQuality FBRecorder::SetWebCamParameters

FBRecorder::SelectWebCamSource FBRecorder::SelectWebCamFormat

FBRecorder::TestWebCam FBRecorder::RecordWebCamToFile

FBRecorder::WebCamFormatsCount FBRecorder::WebCamSourcesCount FBRecorder::WebCamSourceAvailable

FBRecorder::GetSelectedWebCamFormat FBRecorder::GetSelectedWebCamSource FBRecorder::GetWebCamFormat FBRecorder::GetWebCamSource FBRecorder::GetWebCamProperties


UseWebCamForBitmapMode

BB FlashBack SDK: FBRecorder

UseWebCamForBitmapMode

Description

When this property is set to True, the FBRecorder::AddBitmapByHandle and FBRecorder::AddBitmapFromMemory methods save bitmaps into the WebCam video stream instead of the main recording. The advantage of this is that the bitmaps are compressed using FLV encoding.

The resulting FBR file will have a WebCam video stream, and a main recording consisting entirely of empty frames.

See About Record Modes for information about bitmap recording mode.

Syntax

[C#/C++]
public: Bool UseWebCamForBitmapMode;

[VB.NET]
Public Property UseWebCamForBitmapMode As Boolean

See Also


FBRecorder::WebCamFormatsCount

BB FlashBack SDK: FBRecorder

WebCamFormatsCount

Description

Returns the number of video formats available to the attached webcam.

Syntax

[C#/C++]
public: long WebCamFormatsCount;

[VB.NET]
Public Property WebCamFormatsCount As Integer

Remarks

Use GetWebCamFormat to get the name of the format. Use SelectWebCamFormat to set this format for use in webcam recording.

See Also

FBRecorder::UseWebCam FBRecorder::WebCamKeyFrames FBRecorder::WebCamQuality FBRecorder::SetWebCamParameters

FBRecorder::SelectWebCamSource FBRecorder::SelectWebCamFormat

FBRecorder::TestWebCam FBRecorder::RecordWebCamToFile

FBRecorder::WebCamFormatsCount FBRecorder::WebCamSourcesCount FBRecorder::WebCamSourceAvailable

FBRecorder::GetSelectedWebCamFormat FBRecorder::GetSelectedWebCamSource FBRecorder::GetWebCamFormat FBRecorder::GetWebCamSource FBRecorder::GetWebCamProperties


FBRecorder::WebCamKeyFrames

BB FlashBack SDK: FBRecorder

WebCamKeyFrames

Description

Sets the frequency of keyframes in the video stream captured from the webcam.

Syntax

[C#/C++]
public: long WebCamKeyFrames;

[VB.NET]
Public Property WebCamKeyFrames As Integer

Remarks

This value should be greater than or equal to 1. It sets the number of frames between keyframes in the webcam video capture. Higher values mean less keyframes, and smaller files, but lower quality. A value of 1 would mean that every frame is a keyframe.

A value of 30 should give a fair balance between filesize and quality.

See Also

FBRecorder::UseWebCam FBRecorder::WebCamKeyFrames FBRecorder::WebCamQuality FBRecorder::SetWebCamParameters

FBRecorder::SelectWebCamSource FBRecorder::SelectWebCamFormat

FBRecorder::TestWebCam FBRecorder::RecordWebCamToFile

FBRecorder::WebCamFormatsCount FBRecorder::WebCamSourcesCount FBRecorder::WebCamSourceAvailable

FBRecorder::GetSelectedWebCamFormat FBRecorder::GetSelectedWebCamSource FBRecorder::GetWebCamFormat FBRecorder::GetWebCamSource FBRecorder::GetWebCamProperties


FBRecorder::WebCamSourceAvailable

BB FlashBack SDK: FBRecorder

WebCamSourceAvailable

Description

Returns True if there is an attached webcam available for recording.

Syntax

[C#/C++]
public: long WebCamSourceAvailable;

[VB.NET]
Public Property WebCamSourceAvailable As Integer

See Also

FBRecorder::UseWebCam FBRecorder::WebCamKeyFrames FBRecorder::WebCamQuality FBRecorder::SetWebCamParameters

FBRecorder::SelectWebCamSource FBRecorder::SelectWebCamFormat

FBRecorder::TestWebCam FBRecorder::RecordWebCamToFile

FBRecorder::WebCamFormatsCount FBRecorder::WebCamSourcesCount FBRecorder::WebCamSourceAvailable

FBRecorder::GetSelectedWebCamFormat FBRecorder::GetSelectedWebCamSource FBRecorder::GetWebCamFormat FBRecorder::GetWebCamSource FBRecorder::GetWebCamProperties


FBRecorder::WebCamSourcesCount

+BB FlashBack SDK: FBRecorder

WebCamSourcesCount

Description

Returns the number of video sources available to the attached webcam.

Syntax

[C#/C++]
public: long WebCamSourcesCount;

[VB.NET]
Public Property WebCamSourcesCount As Integer

Remarks

Use GetWebCamSource to get the description name of the format. Use SelectWebCamSource to set this source for use in webcam recording.

See Also

FBRecorder::UseWebCam FBRecorder::WebCamKeyFrames FBRecorder::WebCamQuality FBRecorder::TestWebCam FBRecorder::RecordWebCamToFile

FBRecorder:: GetSelectedWebCamFormat FBRecorder::GetSelectedWebCamSource FBRecorder::GetWebCamFormat FBRecorder::GetWebCamProperties FBRecorder::SelectWebCamFormat FBRecorder::SelectWebCamSource


FBRecorder::WebCamQuality

BB FlashBack SDK: FBRecorder

WebCamQuality

Description

Sets the quality of video captured from the webcam.

Syntax

[C#/C++]
public: long WebCamQuality;

[VB.NET]
Public Property WebCamQuality As Integer

Remarks

Takes values from 1-100, where 1 = maximum quality. Lower values mean better quality, but larger FBR files.

See Also

FBRecorder::UseWebCam FBRecorder::WebCamKeyFrames FBRecorder::WebCamQuality FBRecorder::TestWebCam FBRecorder::RecordWebCamToFile

FBRecorder:: GetSelectedWebCamFormat FBRecorder::GetSelectedWebCamSource FBRecorder::GetWebCamFormat FBRecorder::GetWebCamProperties FBRecorder::SelectWebCamFormat FBRecorder::SelectWebCamSource


ActualStartOffset

BB FlashBack SDK: FBRecorder

ActualStartOffset

Description

Returns the delay in milliseconds between calling Start and the first frame being recorded.

Syntax

[C#/C++]
public: unsigned long ActualStartOffset

[VB.NET]
Public Property ActualStartOffset As UInt32

See also

FBRecorder::Start


BitmapModeScreenHeight

BB FlashBack SDK: FBRecorder

BitmapModeScreenHeight

Description

When recording in 'bitmap' mode, this property sets the height of the movie.

Syntax

[C#/C++]
public long BitmapModeScreenHeight;

[VB.NET]
public Property BitmapModeScreenHeight As Long

Remarks

The CompatibilityMode property can set the recording mode to 'bitmap' mode. When in this mode, screen changes are not recorded. Instead, bitmaps are sent to FBRecorder via the AddBitmapByHandle and AddBitmapFromMemory methods and these bitmaps form the frames of the movie.

See Also


BitmapModeScreenWidth

BB FlashBack SDK: FBRecorder

BitmapModeScreenWidth

Description

When recording in 'bitmap' mode, this property sets the height of the movie.

Syntax

[C#/C++]
public long BitmapModeScreenHeight;

[VB.NET]
public Property BitmapModeScreenHeight As Long

Remarks

The CompatibilityMode property can set the recording mode to 'bitmap' mode. When in this mode, screen changes are not recorded. Instead, bitmaps are sent to FBRecorder via the AddBitmapByHandle and AddBitmapFromMemory methods and these bitmaps form the frames of the movie.

See Also


CaptureLayeredWindows

BB FlashBack SDK: FBRecorder

CaptureLayeredWindows

Description

Some applications use 'layered' windows, typically for translucent windows but also for things like the Office 2007/2010 "Office Menu" accessed from the top left corner button. These layered windows are only recorded when the CaptureLayeredWindows property is set to true.

If the property is set to false (the default) layered windows are not recorded - they are invisible in the recorded movie.

Setting this property to true can cause cursor flicker. It is not used at all in capture driver mode recording.

Syntax

[C#/C++]
public Bool CaptureLayeredWindows;

[VB.NET]
Public Property CaptureLayeredWindows As Boolean


CheckForLimit

BB FlashBack SDK: FBRecorder

CheckForLimit

Description

Determines whether a limit has been placed on the size of the movie file. If this is True, the limit defined in the Limit property will be used, and earlier moments of the recording discarded so that the final file size does not exceed the limit.

Syntax

[C#/C++]
public Bool CheckForLimit;

[VB.NET]
Public Property CheckForLimit As Boolean

See Also

RecordMode property, Limit property


CompatibilityMode

BB FlashBack SDK: FBRecorder

CompatibilityMode

Description

Sets the recording mode to be used, if the capture driver is not to be used. Record modes that do not use the capture driver are referred to as 'compatibility' modes.

Syntax

[C#/C++]
public: long CompatibilityMode

[VB.NET]
Public Property CompatibilityMode As Long

Remarks

The compatibility record modes are selected by this property as follows:

Value | Mode
0 | GDI mode
1 | DirectX mode
2 | Bitmap mode
3 | MPEG mode

Note: DirectX mode is not available on Windows Vista or 7. An OnError event is generated if CompatibilityMode is set to 1 when running on Vista.

Note: DirectX mode can only record the primary monitor.

See Also

IsDriverInstalled property, SetPlainWallpaper property, TurnOffUIEffects property, DisableShowWinContents property, InstallDriver method


FBRecorder::CompressionLevel

BB FlashBack SDK: FBRecorder

CompressionLevel

Description

Sets the amount of compression to be used within the FBR movie file. Higher compression levels can produce smaller files, but also use more processor power during recording.

Syntax

[C#/C++]
public: long CompressionLevel;

[VB.NET]
public Property CompressionLevel As Long

Remarks

This value can vary from 0 to 9. Higher values mean more compression.

See Also


CreateRecoverInfo

BB FlashBack SDK: FBRecorder

CreateRecoverInfo

Description

Creates recovery data files during recording that an be used to recover a recording corrupted by unscheduled termination of the recorder process.

See Recovering Corrupted Recordings for information on using the files to recover recordings.

Syntax

[C#/C++]
public: Bool CreateRecoverInfo;

[VB.NET]
Public Property CreateRecoverInfo As Boolean

Remarks

Set to True to generate VDRST files. Two files are generated in the same folder as the FBR file: <fbrname>_1.vdrst and <fbrname>_2.vdrst. However, when performing a recovery it is not necessary to understand that these files exist. The application simply needs to pass the recovery file name returned by FBRecorder::CanMovieBeRecovered into FBRecorder::RecoverMovie.

See Also


DCIManagerEnabled

BB FlashBack SDK: FBRecorder

DCIManagerEnabled

Description

Certain types of program, such as some .NET or WinForms applications, make use of DCI - a feature of DirectX that enables drawing direct to the screen. Windows that use DCI cannot be recorded by FBRecorder, regardless of the Record mode used.

Setting DCIManagerEnabled to True disables DCI support while FBRecorder is running, and forces applications to use conventional GDI or GDI+ drawing that can be recorded successfully.

Syntax

[C#/C++]
public: Bool DCIManagerEnabled;

[VB.NET]
Public Property DCIManagerEnabled As Boolean

Remarks

Set to False by default.

DCI enabled applications started while FBRecorder is running and DCIManagerEnabled set to True will be unable to use DCI. DCI enabled applications started before FBRecorder will continue to use DCI.


Delay

BB FlashBack SDK: FBRecorder

Delay

Description

Returns and sets the delay in milliseconds between recording frames, when DirectX or GDI record modes are used.

Syntax

[C#/C++]
public: long Delay;

[VB.NET]
Public Property Delay As Long

Remarks

By varying this value, the frames recorded per second can be set. If the frames per second is too high, recording may produce a noticeable impact on PC performance.

The TestCompatibilityRecordMode method measures video hardware performance to return a sensible recommended value for Delay and CompatibilityMode.

This property is not used if capture driver record mode or bitmap record mode are used.

See also


DelayBeforeStart

BB FlashBack SDK: FBRecorder

DelayBeforeStart

Description

Returns and sets the delay in milliseconds between calling the Start method to start a recording, and recording actually starting.

Default is 3000ms.

Syntax

[C#/C++]
public: long DelayBeforeStart;

[VB.NET]
Public Property DelayBeforeStart As Long

See also

FBRecorder::Start


DisableHardwareAcceleration

BB FlashBack SDK: FBRecorder

DisableHardwareAcceleration

Description

Determines whether hardware acceleration of graphics will be disabled during recording.

Syntax

[C#/C++]
public: Bool DisableHardwareAcceleration

[VB.NET]
Public Property DisableHardwareAcceleration As Boolean

Remarks

Set this property to True and use GDI mode to record media player-type applications that use 'overlays' to display graphics.

Overlays are commonly used by media players to boost performance when displaying moving video. They allow the application to write directly to video memory, bypassing the usual Windows method. This means that the application window cannot be recorded. Disabling hardware acceleration forces the application to use normal Windows GDI calls instead of overlays, and the SDK can capture its contents.

When running Windows Vista in Aero mode, setting this property to True has no effect.


DisableShowWinContents

BB FlashBack SDK: FBRecorder

DisableShowWinContents

Description

Determines whether the Windows setting called 'Show window contents while dragging' is disabled during recording.

If set to True, an outline will be displayed during window resize/move operations. If set to False, the current Windows settings will be used, which may mean that window contents expand and contract dynamically during resize operations.

Showing window contents during move and resize operations will result in more images being saved to the movie file and therefore larger movie files.

Syntax

[C#/C++]
public: Bool DisableShowWinContents

[VB.NET]
Public Property DisableShowWinContents As Boolean

Remarks

Setting this property to false conserves output file size.

See Also

SetPlainWallpaper property, TurnOffUIEffects property, InstallDriver method


FBRecorder::EnableLogging

BB FlashBack SDK: FBRecorder

EnableLogging

Description

Starts logging for this instance of FBRecorder. Its internal code will start to call event handlers on an enabled FBLogs object.

Syntax

[C#/C++]
public Bool EnableLogging

[VB.NET]
Public Property EnableLogging As Boolean

Remarks

To have the FBRecorder class produce an internal log file for troubleshooting purposes, you will first need to create an instance of FBLogs, and enable logging from that object. See Using the FBLogs class for more details.

See also

Using the FBLogs class


FBRecorder::Filename

BB FlashBack SDK: FBRecorder

Filename

Description

Returns or sets the path of the movie file that will be created by recording.

Syntax

[C#/C++]
public: String Filename

[VB.NET]
Public Property Filename As String

See Also

Start method, Stop method


FBRecorder::FramesPerSec

BB FlashBack SDK: FBRecorder

FramesPerSec

Description

Returns and sets the number of frames to be recorded per second, when a compatibility record mode is to be used (GDI or DirectX mode) instead of the capture driver.

Syntax

[C#/C++]
public: Float FramesPerSec;

[VB.NET]
Public Property FramesPerSec As Single

Remarks

FramesPerSec can be < 1. For instance, a value of 0.1 would mean one frame is recorded every 10 seconds.

If the frames per second is too high, recording may produce a noticeable impact on PC performance.

The TimeBetweenFrameRecord property also sets the number of frames recorded per second, by stating the time between frame captures. Setting either of FramesPerSec or TimeBetweenFrameRecord automatically sets the other property.

The TestCompatibilityRecordMode method measures video hardware performance to return a sensible recommended value for FramesPerSec, TimeBetweenFrameRecord and CompatibilityMode.

This property is not used if capture driver record mode or bitmap record mode are used.

See also


IsDriverInstalled

BB FlashBack SDK: FBRecorder

IsDriverInstalled

Description

Use this to check whether the capture driver has been installed and is available for use

Syntax

[C#/C++]
public: Bool IsDriverInstalled

[VB.NET]
Public ReadOnly Property IsDriverInstalled As Boolean

Remarks

Always check this property before changing the RecordMode property to record using the capture driver. If the driver is not installed, call the CanDriverBeInstalled method to determine if it can be installed on the target system. Some systems may not permit installing the capture driver.

Note: reading this property will cause a brief screen blank because it initialises the driver in order to check it. Use FBRecorder::IsDriverVersionOk to check the presence of the driver without causing a screen blank.

See Also

RecordMode property, InstallDriver method, CanDriverBeInstalled method


IsRecording

BB FlashBack SDK: FBRecorder

IsRecording

Description

Returns whether a recording is currently being made.

Syntax

[C#/C++]
public: Bool IsRecording

[VB.NET]
Public ReadOnly Property IsRecording As Boolean

See Also

RecordMode property, Pause property, Start method


IsVista

BB FlashBack SDK: FBRecorder

IsVista

Description

Indicates whether the operating system is Windows Vista or not.

Applications can use this property to determine whether they can make use of the extra sound recording features included in Vista. Different methods and properties are used to set the recorded sound source in Windows Vista and 2000/XP. See Recording Sound Sources and Devices for more details.

Syntax

[C#/C++]
public: Bool IsVista

[VB.NET]
Public ReadOnly Property IsVista As Boolean


KeyFramesFrequency

BB FlashBack SDK: FBRecorder

KeyFramesFrequency

Description

Sets the frequency of keyframes in the recording. Keyframes are fullscreen images. The more keyframes you have, the quicker it is to display random frames within the movie, and it can decrease the time take to export a selection of frames. However, more keyframes means a larger FBR movie file.

Syntax

[C#/C++]
public: long KeyFramesFrequency;

[VB.NET]
Public Property KeyFramesFrequency As Integer

Remarks

This property can take one of 4 values:

0 | No keyframes (smallest FBR file)
1 | Low keyframes
2 | More keyframes
3 | Maximum keyframes (largest FBR file)


Limit

BB FlashBack SDK: FBRecorder

Limit

Description

Returns or sets the upper limit for the size of the output file that will hold the recording. The limit is set in kilobytes. Be sure to allow for at least 380KB of recording space.

This limit is only enforced when the CheckForLimit property is set to True.

Syntax

[C#/C++]
public: long Limit

[VB.NET]
Public Property Limit As Long

See Also

RecordMode property, CheckForLimit property


LowColorDepth

BB FlashBack SDK: FBRecorder

LowColorDepth

Description

The color depth to be used in recordings.

By default FBRecorder records at 8bit colour depth. The UseLowColorDepth and LowColorDepth properties can be used to make reduced color recording that produce smaller file sizes.

Syntax

[C#/C++]
public: Long LowColorDepth;

[VB.NET]
Public Property LowColorDepth As Integer

Remarks

This property specifies the bits per pixel. Possible values:

LowColorDepth (bits per pixel) | Bits per channel (RGB)
3 | 1
6 | 2
9 | 3
12 | 4
15 | 5
18 | 6
21 | 7
24 | 8

See Also

FBRecorder::UseLowColorDepth


FBRecorder::MonitorsCount

BB FlashBack SDK: FBRecorder

MonitorsCount

Description

Returns the number of monitors connected to the PC.

Use FBRecorder::SelectMonitor to select a monitor for recording and FBRecorder::GetCurrentMonitor to get the index of the selected monitor. Use FBRecorder::GetMonitor to get information on attached monitors.

Syntax

[C#/C++]
public: long MonitorsCount

[VB.NET]
Public Property MonitorsCount As Long

See Also


MPEGQuality

BB FlashBack SDK: FBRecorder

MPEGQuality

Description

Sets the image quality when using MPEG record mode.

The value can vary from 0 to 10, where 10 is highest quality.

See About Record Modes for more on MPEG record mode.

Syntax

[C#/C++]
public: long MPEGQuality

[VB.NET]
Public Property MPEGQuality As Integer

See Also

RecordMode property


OpenH264Config

BB FlashBack SDK: FBRecorder

OpenH264Config

MP4/H264 recording is only available in the Pro and Advanced editions of the SDK

Description

Sets the path to the OpenH264 configuration file welsync.cfg

Syntax

[C#/C++]
public: String OpenH264Config

[VB.NET]
Public Property OpenH264Config As String

See Also

Recording to MP4/H264


OutputFileFormat

BB FlashBack SDK: FBRecorder

OutputFileFormat

MP4/H264 recording is only available in the Pro and Advanced editions of the SDK

Description

Sets the file format for recordings.

Syntax

[C#/C++]
public: long OutputFileFormat

[VB.NET]
Public Property OutputFileFormat As Integer

Remarks

0 = FBR format

1 = MP4 format. See Recording to MP4/H264 for more about recording to MP4.


ParentWindow

BB FlashBack SDK: FBRecorder

ParentWindow

Description

Returns the handle to the parent window containing the recorder control.

Syntax

[C#/C++]
public: long ParentWindow

[VB.NET]
Public Property ParentWindow As Long


FBRecorder::Pause

BB FlashBack SDK: FBRecorder

Pause

Description

Returns or sets the pause state of the current recording.

Set this property to True while recording to pause the recording. Then set it to False to restart the recording.

Syntax

[C#/C++]
public: Bool Pause

[VB.NET]
Public Property Pause As Boolean

Remarks

Call the Start method to begin a recording before using this property.

See Also

Start method


RecordExtraMouseEvents

BB FlashBack SDK: FBRecorder

RecordExtraMouseEvents

Description

Determines whether mouse clicks and scrollwheel events will be captured during recording and saved to the movie file.

Syntax

[C#/C++]
public: Bool RecordExtraMouseEvents;

[VB.NET]
Public Property RecordExtraMouseEvents As Boolean

Remarks

Set to True by default.

If RecordMouseCursor is set to False and RecordExtraMouseEvents is set to True, the resulting movie will not contain mouse movement events and therefore will not show the mouse cursor, but it will contain button click events.

See Also

FBRecorder::RecordMouseCursor


RecordingRegionType

BB FlashBack SDK: FBRecorder

RegionRecordingType

Description

Determines what region will be recorded. This property is used only if UseRegion is set to True.

Syntax

[C#/C++]
public long RegionRecordingType;

[VB.NET]
public Property RegionRecordingType as Long;

Remarks

This property can take one of these values:

Value | Region recorded
0 | Entire desktop
1 | Region defined by properties RegionHeight, RegionWidth, RegionX, RegionY
2 | Records movie with dimensions of entire desktop, but only records changes to windows contained in the window list created by calls to FBRecorder::AddWndToList.
3 | Records movie with dimensions of entire desktop, but only records changes to windows owned by the process specified by call to FBRecorder::SetProcessId.

Regions will only be used when UseRegion is set to True. Otherwise the entire desktop will be recorded.

See Recording Windows and Regions for more detailed help.

See Also

FBRecorder::RegionHeight
  FBRecorder::RegionWidth
  FBRecorder::RegionX
  FBRecorder::RegionY
 FBRecorder::SetProcessId  FBRecorder::AddWndToList
  FBRecorder::UseRegion


RecordKeyBoardEvents

BB FlashBack SDK: FBRecorder

RecordKeyboardEvents

Description

Determines whether key press events will be captured during recording and saved to the movie file.

Syntax

[C#/C++]
public: Bool RecordKeyboardEvents;

[VB.NET]
Public Property RecordKeyboardEvents As Boolean

Remarks

Set to True by default.

See Also

FBRecorder::RecordMouseCursor


RecordMode

BB FlashBack SDK: FBRecorder

RecordMode

Description

Returns or sets the recording mode to use.

Syntax

[C#/C++]
public: long RecordMode

[VB.NET]
Public Property RecordMode As Long

Value | Description
0 | Record using compatibility mode
1 | Record using capture driver

Remarks

The capture driver provides screen recordings with lossless image quality and minimal impact on PC performance.

In order to record with the capture driver, the capture driver must have already been installed using the InstallDriver method and the success of the installation checked with the CheckDriver method.

Use the IsDriverInstalled property to determine whether the capture driver has been installed and is available for use.

Some systems may not permit installing/using the capture driver. In these cases, fall back to recording in compatibility mode.

The type of compatibility mode used is determined by the CompatibilityMode property.

See Also

IsDriverInstalled property, SetPlainWallpaper property, TurnOffUIEffects property, DisableShowWinContents property, InstallDriver method


StoreMouseEvents

BB FlashBack SDK: FBRecorder

RecordMouseCursor

Description

Set to True to have mouse cursor shape and movement recorded into the movie file.

Syntax

[C#/C++]
public: Bool RecordMouseCursor;

[VB.NET]
Public Property RecordMouseCursor As Boolean

Remarks

Set to True by default. If set to False during recording, the movie will display no mouse cursor on playback.

See Also

FBRecorder::RecordExtraMouseEvents


RegionHeight

BB FlashBack SDK: FBRecorder

RegionHeight

Description

When recording a region, this property sets the height of the region.

Syntax

[C#/C++]
public long RegionHeight;

[VB.NET]
public property RegionHeight As Long

Remarks

The SDK can be set to record a single region of the desktop via the RecordingRegionType property.

See Also


RegionWidth

BB FlashBack SDK: FBRecorder

RegionWidth

Description

When recording a region, this property sets the width of the region.

Syntax

[C#/C++]
public long RegionWidth;

[VB.NET]
Public Property RegionWidth As Long

Remarks

The SDK can be set to record a single region of the desktop via the RecordingRegionType property.

See Also


RegionX

BB FlashBack SDK: FBRecorder

RegionX

Description

When recording a region, this property sets the x coordinate of the top left corner of the region.

Syntax

[C#/C++]
public long RegionX;

[VB.NET]
Public Property RegionX As Long

Remarks

Use the RecordingRegionType property to set FBRecorder to record a single region of the desktop.

Desktop co-ordinates are used for this property. RegionX can be negative but must be larger than the X position of the top left corner of the leftmost monitor, and lie within the desktop.

See Also


RegionY

BB FlashBack SDK: FBRecorder

RegionY

Description

When recording a region, this property sets the y coordinate of the top left corner of the region.

Syntax

[C#/C++]
public long RegionY;

[VB.NET]
Public Property RegionY As Long

Remarks

Use the RecordingRegionType property to set FBRecorder to record a single region of the desktop.

Desktop co-ordinates are used for this property. RegionY can be negative but must be larger than the Y position of the top left corner of the leftmost monitor, and lie within the desktop.

See Also


RestoreMouseCursorPosition

BB FlashBack SDK: FBRecorder

RestoreMouseCursorPosition

Description

There is a delay between calling FBRecorder::Start() and recording actually starting. When this property is set to true, when recording actually starts, the mouse will jump to the position it had when the start() method was called. When set to false, the mouse will not be repositioned.

The property defaults to true.

Syntax

[C#/C++]
public: Bool RestoreMouseCursorPosition;

[VB.NET]
Public Property RestoreMouseCursorPosition As Boolean


FBRecorder::RuntimeLicence

BB FlashBack SDK: FBRecorder

RuntimeLicence

Description

Sets and gets the 'runtime' licence that licences applications produced using the FlashBack SDK.

Syntax

[C#/C++]
public BSTR RuntimeLicence

[VB.NET]
Public Property RuntimeLicence As String

Remarks

When running applications produced using the SDK on PCs that do not have the SDK installed (i.e. end-user PCs), the runtime licence must be set before any methods are called on an instance of FBRecorder. If the runtime licence is not set, all methods will fail.

It should be set to the runtime licence string obtained (via GetRuntimeLicence() or the RuntimeLicence property) from an instance of FBRecorder running on a development PC (i.e. a PC with the SDK installed).

See also


FBRecorder::SaveMovieInOldFormat

BB FlashBack SDK: FBRecorder

SaveMovieInOldFormat

Description

Determines whether the recording will be saved in the newest format, that can only be opened by applications created with version 2.5 of the SDK, or an older format compatible with version 2.0 of the SDK.

By default, SaveMovieInOldFormat is set to true and FBRecorder saves older format movies.

FBEditor, by default, saves movies in the newer format, which is compatible only with applications created with version 2.5 of the SDK.

See FlashBack movie file format versions for more on SDK and FBR movie format versions.

Syntax

[C#/C++]
public: Bool SaveMovieInOldFormat;

[VB.NET]
Public Property SaveMovieInOldFormat As Boolean

See Also


SetPlainWallpaper

BB FlashBack SDK: FBRecorder

SetPlainWallpaper

Description

Returns or sets whether a plain wallpaper will be temporarily used during recording sessions to conserve output file size.

Syntax

[C#/C++]
public: Bool SetPlainWallpaper

[VB.NET]
Public Property SetPlainWallpaper As Boolean

See Also

TurnOffUIEffects property, DisableShowWinContents property, InstallDriver method


TimeBetweenFrameRecord

BB FlashBack SDK: FBRecorder

TimeBetweenFrameRecord

Description

Returns and sets the delay in milliseconds between recording frames, when DirectX or GDI record modes are used.

Syntax

[C#/C++]
public: long TimeBetweenFrameRecord;

[VB.NET]
Public Property TimeBetweenFrameRecord As Long

Remarks

By varying this value, the frames recorded per second can be set. If the frames per second is too high, recording may produce a noticeable impact on PC performance.

The FramesPerSec property also sets the number of frames recorded per second, by setting the number of frames to be recorder per second. Setting either of FramesPerSec or TimeBetweenFrameRecord automatically sets the other property.

The TestCompatibilityRecordMode method measures video hardware performance to return a sensible recommended value for Delay and CompatibilityMode.

This property is not used if capture driver record mode or bitmap record mode are used.

See also


TurnOffUIEffects

BB FlashBack SDK: FBRecorder

TurnOffUIEffects

Description

Returns or sets whether user interface effects such as sliding menus, fading tool-tips, and other animations should be temporarily disabled during a recording session. Disabling these effects conserves output file size.

Syntax

[C#/C++]
public: Bool TurnOffUIEffects

[VB.NET]
Public Property TurnOffUIEffects As Boolean

See Also

SetPlainWallpaper property, DisableShowWinContents property, InstallDriver method


UseDesktopDCOnly

BB FlashBack SDK: FBRecorder

UseDesktopDCOnly

Description

If set to True, FBRecorder creates a device context for the entire desktop, rather than one for each monitor.

This has lower performance than multiple DCs, but may improve the recording of multiple monitors, particularly if you find that one is not refreshing (in the recording) or you are recording a remote desktop / terminal server session that covers multiple monitors.

Syntax

[C#/C++]
public: Bool UseDesktopDCOnly;

[VB.NET]
Public Property UseDesktopDCOnly As Boolean


UseLowColorDepth

BB FlashBack SDK: FBRecorder

UseLowColorDepth

Description

Set to true to have FBRecorder record using the color depth value in the LowColorDepth property.

Syntax

[C#/C++]
public: Bool UseLowColorDepth;

[VB.NET]
Public Property UseLowColorDepth As Boolean

Remarks

By default FBRecorder records at 8bit colour depth. The UseLowColorDepth and LowColorDepth properties can be used to make reduced color recording that produce smaller file sizes.

See Also

FBRecorder::LowColorDepth


UseRegion

BB FlashBack SDK: FBRecorder

UseRegion

Description

Determines whether the entire desktop or a part of it (a region or window) will be recorded.

Syntax

[C#/C++]
public: Bool UseRegion;

[VB.NET]
Public Property UseRegion As Boolean

Remarks

Set to True to record a region of the desktop. See Recording Windows and Regions for details.

Set to False to record the entire desktop.

See Also


AddSoundBlockByPointer

BB FlashBack SDK: FBRecorder

AddSoundBlockByPointer

Description

Adds sound into the track defined earlier by a call to InitCustomSoundTrack.

This method should only be called while recording is in-progress, and can be called any number of times. The added sound will start at the current point in the recording.

Syntax

[C#/C++]
Public Bool AddSoundBlockByPointer (BYTE* sound_data, long samples);

[VB.NET]
public Function AddSoundBlockByPointer (ByRef sound_data() as Char, ByVal samples as Integer) as Boolean

Parameters

sound_data (in): pointer to the sample data that makes up the new track

samples (in): number of samples in the buffer pointed to by sound_data

Remarks

The samplesize and stereo parameters passed to InitCustomSoundTrack affect the number of bytes in each sample.

See InitCustomSoundTrack for example code.

Return Values

True if successful, False if not.

See Also


FBRecorder::GetDefaultSoundDevice

BB FlashBack SDK: FBRecorder

GetDefaultSoundDevice

Description

Returns the ID of the default recording sound device.

Syntax

[C#/C++]
Public void GetDefaultSoundDevice (long *ID);

[VB.NET]
public Sub GetDefaultSoundDevice (ByRef ID as Integer)

Parameters

ID (out): the ID of the device

Remarks

Use FBRecorder:SoundDevice to set the sound device that will be recorded.

See Also

FBRecorder::SoundDevice


GetSoundDevice

BB FlashBack SDK: FBRecorder

GetSoundDevice

Description

Returns the name and ID of a sound device, given its index.

Find the number of sound devices and therefore the range of indexes by using FBRecorder::SoundDevicesCount.

Syntax

[C#/C++]
Public void GetSoundDevice (long Index, BSTR *DeviceName , long *ID);

[VB.NET]
public Sub GetSoundDevice (ByVal Index as Integer, ByRef DeviceName as String, ByRef ID as Integer)

Parameters

Index (in): the index of the device

DeviceName (out): the name of the sound device

ID (out): the ID of the device

Remarks

Use FBRecorder:SoundDevice to set the sound device that will be recorded.

See Also


GetSoundDeviceByName

BB FlashBack SDK: FBRecorder

GetSoundDeviceByName

Description

Returns the ID of a sound device, given its name.

Find the name of a sound device by using FBRecorder::GetSoundDevice.

Syntax

[C#/C++]
Public void GetSoundDeviceByName (BSTR DeviceName , long *ID);

[VB.NET]
public Sub GetSoundDeviceByName (ByVal DeviceName as String, ByRef ID as Integer)

Parameters

DeviceName (in): the name of the sound device

ID (out): the ID of the device

Remarks

Use FBRecorder:SoundDevice to set the sound device that will be recorded.

See Also


GetSoundLineMuteValue

BB FlashBack SDK: FBRecorder

GetSoundLineMuteValue

Description

Gets the mute value for a sound source.

This method should only be used for Windows 2000/XP. When running on Windows Vista, use GetVistaSoundVolumeValue.

Syntax

[C#/C++]
Public void GetSoundLineMuteValue (long DeviceID, long LineID, bool *Mute);

[VB.NET]
public Sub GetSoundLineMuteValue (ByVal DeviceID as Integer, ByVal SourceLineID As Integer, ByRef Mute As Boolean)

Parameters

DeviceID (in): the ID of a device, returned from GetSoundDevice

SourceLineID (in): the SourceLineID of a sound source, returned from GetSoundSource

Mute (out): a boolean value indicating whether the source is muted or not.

See Also

FBRecorder::GetSoundMuteLineValue


GetSoundLineVolume

BB FlashBack SDK: FBRecorder

GetSoundLineVolume

Description

Gets the volume and min, max volume values for a particular source.

Set the volume of the source with the SetSoundLineVolume.

This method should only be used for Windows 2000/XP. When running on Windows Vista, use GetVistaSoundVolumeValue.

Syntax

[C#/C++]
Public void GetSoundLineVolume (long DeviceID, long SourceLineID, long *VolValue, long *VolMin, long *VolMax);

[VB.NET]
public Sub GetSoundLineVolume (ByVal DeviceID as Integer, ByVal SourceLineID As Integer, ByRef VolValue As Integer, ByRef VolMin As Integer, ByRef VolMax As Integer)

Parameters

DeviceID (in): the ID of a device, returned from GetSoundDevice

SourceLineID (in): the LineID of a sound source, returned from GetSoundSource

VolValue (out): the current volume for this source

VolMin (out): the maximum volume for this source

VolMax (out): the minimum volume for this source

See Also


GetSoundSource

BB FlashBack SDK: FBRecorder

GetSoundSource

Description

Gets the ID of a sound source, its component type, and IDs used to identify changes made to the mute state and volume of the source made elsewhere in Windows.

Note: GetSoundSources should be called before accessing GetSoundSource, to build an internal list of sound sources.

Syntax

[C#/C++]
Public void GetSoundSource (long Index, long *LineID, long *MUXControlID, long *MuteControlID, long *VolControlID, long *ComponentType);

[VB.NET]
public Sub GetSoundSource (ByVal Index as Integer, ByRef LineID As Integer, ByRef MUXControlID As Integer, ByRef MuteControlID As Integer, ByRef VolControlID As Integer, ByRef ComponentType As Integer)

Parameters

Index (in): the index of the sound source

LineID (out): the LineID of the source. Set SoundSource to this ID to enable recording of the source. The ID can also be used in calls to Get/SetSoundLineMuteValue and Get/SetSoundLineVolume.

MUXControlID (out): the ID of the Mixer for this source.

MuteControlID (out): this is used if you want to show the mute state of this source in a window. See Remarks below for details.

VolControlID (out): this is used if you want to show the volume of this source in a window. See Remarks below for details.

ComponentType (out): the component type for this source. Component types would include speakers, microphone, line, aux, compact disc and many others - see MIXERLINE.dwComponentType defines in the Win32 SDK file mmsystem.h. An application can use the component type to display tailored graphics or to search for a particular component.

About the Mute and Volume Control IDs

The MuteControlID and VolControlID parameters returned from this method can be used if you want to display controls that show the mute state and volume of the source.

The mute state and volume can be changed via the Windows interface, and also other applications, and your controls should update in response to these external changes.

If you receive MM_MIXM_CONTROL_CHANGE messages from Windows, inspect at the LParam in these messages and compare to MuteControlID and VolControlID. If there is a match with either ID, the message indicates a change in the corresponding value.

See Also


GetSoundSources

BB FlashBack SDK: FBRecorder

GetSoundSources

Description

This prepares an internal list of recording sound sources used in GetSoundSourcesInfo, GetSoundSource and SoundSourcesCount.

This method should be called before any of the above 3 methods and properties are accessed.

Syntax

[C#/C++]
Public void GetSoundSources (long DeviceID);

[VB.NET]
public Sub GetSoundSources (ByVal DeviceID as Integer)

Parameters

DeviceID (in): the ID of the device for which sources will be read

See Also


GetSoundSourcesInfo

BB FlashBack SDK: FBRecorder

GetSoundSourcesInfo

Description

Gets source indexes of the current sound source, microphone input and "mix" source (typically the sounds heard through the PC speakers) for the currently selected sound device.

Note: GetSoundSources should be called before accessing GetSoundSourcesInfo, to build an internal list of sound sources.

Syntax

[C#/C++]
Public void GetSoundSourcesInfo (long* SelectedIndex, long *MicIndex, long *MixIndex);

[VB.NET]
public Sub GetSoundSourcesInfo (ByRef SelectedIndex as Integer, ByRef MicIndex As Integer, ByRef MixIndex As Integer)

Parameters

SelectedIndex (out): index of the currently selected source on the current device.

MicIndex (out): this is the index of the microphone input source.

MixIndex (out): this is the index of the mix source for the selected sound device. This is typically the sounds heard through the PC speakers.

Remarks

Set the current sound device via the FBRecorder::SoundDevice property.

The MicIndex and MixIndex are can be passed to GetSoundSource in order to get the LineID for those sources. Their LineID can be used in calls to SetSoundLineVolume, GetSoundLineVolume, GetSoundLineMuteValue and SetSoundLineMuteValue.

See Also

FBRecorder::SoundDevice FBRecorder::SetSoundLineVolume FBRecorder::GetSoundLineVolume FBRecorder::GetSoundLineMuteValue FBRecorder::SetSoundLineMuteValue


GetVistaSoundDevice

BB FlashBack SDK: FBRecorder

GetVistaSoundSource

Description

Returns the name, ID and component type of a sound source, given its index.

This method should only be used when the application is running on Windows Vista.

Find the number of sound sources by using FBRecorder::VistaSoundSourcesCount.

Syntax

[C#/C++]
Public void GetVistaSoundSource (long SourceIndex, BSTR *DeviceName , BSTR *SourceName, BSTR *SourceFullName, long *WaveID, long *ComponentType);

[VB.NET]
public Sub GetVistaSoundSource (ByVal SourceIndex as Integer, ByRef DeviceName as String, ByRef SourceName as String, ByRef SourceFullName As String, ByRef WaveID As Integer, ByRef ComponentType as Integer)

Parameters

SourceIndex (in): the index of the source

DeviceName (out): the name of the device the source is on

SourceName (out): name of the sound source

SourceFullName (out): the 'full' name of the device-source combination, in the form "device (source)". This can be passed to VistaSoundSourceName to select the source for recording.

WaveID (out): the ID of the source. This can be passed to VistaSoundSource to set the recording source. It can also be used with GetVistaSoundVolumeValue and SetVistaSoundVolumeValue to set the volume of the source.

Note: the ID of the "PC Sounds" source (the sound heard from the PC speakers) is -1

ComponentType (out): the component type for this source. Component types would include speakers, microphone, line, aux, compact disc and many others - see MIXERLINE.dwComponentType defines in the Win32 SDK file mmsystem.h. An application can use the component type to display tailored graphics or to search for a particular component.

Note: the component type of microphone sources on Windows Vista will be 4099 (MIXERLINE_COMPONENTTYPE_SRC_MICROPHONE).

See Also

FBRecorder::VistaSoundSourcesCount FBRecorder::VistaSoundSourceName FBRecorder::VistaSoundSource FBRecorder::GetVistaSoundVolumeValue FBRecorder::SetVistaSoundVolumeValue


GetVistaSoundVolumeValue

BB FlashBack SDK: FBRecorder

GetVistaSoundVolumeValue

Description

Gets the current volume of a sound recording source, and its maximum and minimum values.

For use with Windows Vista only. Use GetSoundLineVolume for Windows 2000/XP.

Syntax

[C#/C++]
Public void GetVistaSoundVolumeValue (long SourceID, long *VolValue, long *VolMin, long *VolMax);

[VB.NET]
public Sub GetVistaSoundVolumeValue (ByVal SourceID as Integer, ByRef VolValue As Integer, ByRef VolMin As Integer, ByRef VolMax As Integer)

Parameters

DeviceID (in): ID of the device-source combination. Get the ID of sources from GetVistaSoundSource.

VolValue (out): current volume value, ranging from the minimum and maximum values also returned from this method

VolMin (out): minimum volume value

VolMax (out): maximum volume value

See Also

FBRecorder::SetVistaSoundVolumeValue


InitCustomSoundTrack

BB FlashBack SDK: FBRecorder

InitCustomSoundTrack

Description

Initialises the name, sample size, stereo/mono and frequency for the sound track that will be added by calls to AddSoundBlockByPointer during recording.

This method should only be called before recording starts.

To enable adding a custom sound track, the UseCustomSoundTrack property should be set to true before recording starts.

Syntax

[C#/C++]
Public Bool InitCustomSoundTrack (BSTR trackname, long samplesize, bool stereo, long frequency);

[VB.NET]
public Function InitCustomSoundTrack (ByVal trackname As String, ByVal samplesize As Integer, ByVal stereo As Boolean, ByVal frequency As Integer) as Boolean

Parameters

trackname (in): the name of the new track

samplesize (in): should have value 8 or 16, indicating the number of bits in each sample

stereo (in): True or False to indicate whether the track is stereo or mono

frequency (in): frequency of the samples, in KHz. e.g. 22050, 44100

Remarks

Samples are added via the AddSoundBlockByPointer method. The samplesize and stereo parameters affect the number of bytes in each sample.

8 bit mono = 1 byte per sample
8 bit stereo = 2 bytes per sample
16 bit mono = 2 bytes per sample
16 bit stereo = 4 bytes per sample

Sample Code

Setup the custom sound track before recording starts.

recorder.InitCustomSoundTrack(L"testtrack", sample_size, false, frequency); recorder.UseCustomSoundTrack = true;

Then Start recording.

When recording is in progress, sound is added with AddSoundBlockByPointer:

short *sbuffer = (short*)malloc(sample_size/8 * samples);

// generate example sound data - a sine wave
for(int i=0; i<samples; i++)
{
 sbuffer[i] = (int)(sin((double)i) * 10000);
}

// add it to the recording
recorder.AddSoundBlockByPointer((unsigned char*)sbuffer, samples);

free(sbuffer);

Return Values

True if successful, False if not.

See Also


SetSoundLineMuteValue

BB FlashBack SDK: FBRecorder

SetSoundLineMuteValue

Description

Mutes or unmutes a sound source.

This method should only be used for Windows 2000/XP. When running on Windows Vista, use SetVistaSoundVolumeValue.

Syntax

[C#/C++]
Public void SetSoundLineMuteValue (long DeviceID, long SourceLineID, bool Mute);

[VB.NET]
public Sub SetSoundLineMuteValue (ByVal DeviceID as Integer, ByVal SourceLineID As Integer, ByVal Mute As Boolean)

Parameters

DeviceID (in): the ID of a device, returned from GetSoundDevice.

SourceLineID (in): the line ID of a sound source, returned from GetSoundSource.

Mute (in): sets Muting to true or false for the source specified by SourceLineID.

See Also

FBRecorder::GetSoundLineMuteValue


SetSoundLineVolume

BB FlashBack SDK: FBRecorder

SetSoundLineVolume

Description

Sets the volume of a particular sound source.

Get the current, min and max volume values for the source with GetSoundLineVolume.

This method should only be used for Windows 2000/XP. When running on Windows Vista, use SetVistaSoundVolumeValue.

Syntax

[C#/C++]
Public void SetSoundLineVolume (long DeviceID, long SourceLineID, long VolValue);

[VB.NET]
public Sub SetSoundLineVolume (ByVal DeviceID as Integer, ByVal SourceLineID As Integer, ByVal VolValue As Integer)

Parameters

DeviceID (in): the ID of a device, returned from GetSoundDevice.

SourceLineID (in): the line ID of a sound source, returned from GetSoundSource.

VolValue (in): the new volume value for the source.

See Also


SetVistaSoundVolumeValue

BB FlashBack SDK: FBRecorder

SetVistaSoundVolumeValue

Description

Sets the volume of sound recording sources in Vista.

When using Windows 2000/XP, use SetSoundLineVolume instead.

Syntax

[C#/C++]
Public void SetVistaSoundVolumeValue (long DeviceID, long VolValue);

[VB.NET]
public Sub SetVistaSoundVolumeValue (ByVal DeviceID as Integer, ByVal VolValue As Integer)

Parameters

DeviceID (in): the ID of a device-source combination. Get the ID of sources from GetVistaSoundSource.

VolValue (in): volume of the source. Get the minimum and maximum values for this from GetVistaSoundVolumeValue.

See Also

FBRecorder::GetVistaSoundVolumeValue


GetSelectedWebCamFormat

BB FlashBack SDK: FBRecorder

GetSelectedWebCamFormat

Description

Returns the index of the currently selected webcam video format.

Get the name of the format via the GetWebCamFormat method. Select a format via SelectWebCamFormat.

Syntax

[C#/C++]
public long GetSelectedWebCamFormat ();

[VB.NET]
Public Function GetSelectedWebCamFormat () As Integer

Return values

Index of the currently selected video format.

See Also

FBRecorder::UseWebCam FBRecorder::WebCamKeyFrames FBRecorder::WebCamQuality FBRecorder::SetWebCamParameters

FBRecorder::SelectWebCamSource FBRecorder::SelectWebCamFormat

FBRecorder::TestWebCam FBRecorder::RecordWebCamToFile

FBRecorder::WebCamFormatsCount FBRecorder::WebCamSourcesCount FBRecorder::WebCamSourceAvailable

FBRecorder::GetSelectedWebCamFormat FBRecorder::GetSelectedWebCamSource FBRecorder::GetWebCamFormat FBRecorder::GetWebCamSource FBRecorder::GetWebCamProperties


GetSelectedWebCamSource

BB FlashBack SDK: FBRecorder

GetSelectedWebCamSource

Description

Returns the name of the currently selected webcam video source.

Select a source via SelectWebCamSource.

Syntax

[C#/C++]
public BSTR GetSelectedWebCamSource ();

[VB.NET]
Public Function GetSelectedWebCamSource () As String

Return values

Name of the currently selected video source.

See Also

FBRecorder::UseWebCam FBRecorder::WebCamKeyFrames FBRecorder::WebCamQuality FBRecorder::SetWebCamParameters

FBRecorder::SelectWebCamSource FBRecorder::SelectWebCamFormat

FBRecorder::TestWebCam FBRecorder::RecordWebCamToFile

FBRecorder::WebCamFormatsCount FBRecorder::WebCamSourcesCount FBRecorder::WebCamSourceAvailable

FBRecorder::GetSelectedWebCamFormat FBRecorder::GetSelectedWebCamSource FBRecorder::GetWebCamFormat FBRecorder::GetWebCamSource FBRecorder::GetWebCamProperties


GetWebCamFormat

BB FlashBack SDK: FBRecorder

GetWebCamFormat

Description

Returns a description of a webcam video format identified by index. Get the number of available formats via the WebCamFormatsCount property.

Syntax

[C#/C++]
public BSTR GetWebCamFormat (long index);

[VB.NET]
Public Function GetWebCamFormat (ByVal index As Integer) As String

Parameters

index (in) - index of the format

Return values

Description of the video format.

See Also

FBRecorder::UseWebCam FBRecorder::WebCamKeyFrames FBRecorder::WebCamQuality FBRecorder::SetWebCamParameters

FBRecorder::SelectWebCamSource FBRecorder::SelectWebCamFormat

FBRecorder::TestWebCam FBRecorder::RecordWebCamToFile

FBRecorder::WebCamFormatsCount FBRecorder::WebCamSourcesCount FBRecorder::WebCamSourceAvailable

FBRecorder::GetSelectedWebCamFormat FBRecorder::GetSelectedWebCamSource FBRecorder::GetWebCamFormat FBRecorder::GetWebCamSource FBRecorder::GetWebCamProperties


GetWebCamProperties

BB FlashBack SDK: FBRecorder

GetWebCamProperties

Description

Returns a WebCamProperties object. Change the properties on that object to adjust webcam image quality.

Use FBRecorder::TestWebCam to display webcam output in a window, and FBRecorder::GetWebCamProperties to get a WebCamProperties object, then change its properties in response to user input as they adjust image quality for the desired results.

Syntax

[C#/C++]
public WebCamProperties *GetWebCamProperties ();

[VB.NET]
Public Function GetWebCamProperties () As WebCamProperties

Return values

Returns a pointer to a WebCamProperties object.

See Also

FBRecorder::UseWebCam FBRecorder::WebCamKeyFrames FBRecorder::WebCamQuality FBRecorder::SetWebCamParameters

FBRecorder::SelectWebCamSource FBRecorder::SelectWebCamFormat

FBRecorder::TestWebCam FBRecorder::RecordWebCamToFile

FBRecorder::WebCamFormatsCount FBRecorder::WebCamSourcesCount FBRecorder::WebCamSourceAvailable

FBRecorder::GetSelectedWebCamFormat FBRecorder::GetSelectedWebCamSource FBRecorder::GetWebCamFormat FBRecorder::GetWebCamSource FBRecorder::GetWebCamProperties


GetWebCamSource

BB FlashBack SDK: FBRecorder

GetWebCamSource

Description

Returns the name of a webcam source, identified by its index. Get the number of webcam sources available via the WebCamSourcesCount property. Select a webcam source via the SelectWebCamSource method.

Syntax

[C#/C++]
public BSTR GetWebCamSource (long index);

[VB.NET]
Public Function GetWebCamSource (ByVal index As Integer) As Integer

Parameters

index (in) - the index of the source.

Return values

The name of the webcam video source.

See Also

FBRecorder::UseWebCam FBRecorder::WebCamKeyFrames FBRecorder::WebCamQuality FBRecorder::SetWebCamParameters

FBRecorder::SelectWebCamSource FBRecorder::SelectWebCamFormat

FBRecorder::TestWebCam FBRecorder::RecordWebCamToFile

FBRecorder::WebCamFormatsCount FBRecorder::WebCamSourcesCount FBRecorder::WebCamSourceAvailable

FBRecorder::GetSelectedWebCamFormat FBRecorder::GetSelectedWebCamSource FBRecorder::GetWebCamFormat FBRecorder::GetWebCamSource FBRecorder::GetWebCamProperties


RecordWebCamToFile

BB FlashBack SDK: FBRecorder

RecordWebCamToFile

Description

Records output from an attached webcam to a file. This operates independently of the screen recording functions - you do not need to be recording from the screen while recording from the webcam.

Syntax

[C#/C++]
public Bool RecordWebCamToFile (BSTR FileName, Bool Start)

[VB.NET]
Public Function RecordWebCamToFile (ByVal FileName As String, ByVal Start As Boolean) As Boolean

Parameters

FileName (in) - handle of the parent window of the test dialog.

Start (in) - set this to True to start recording, set to False to stop recording.

Return values

Returns True if successful.

See Also

FBRecorder::UseWebCam FBRecorder::WebCamKeyFrames FBRecorder::WebCamQuality FBRecorder::SetWebCamParameters

FBRecorder::SelectWebCamSource FBRecorder::SelectWebCamFormat

FBRecorder::TestWebCam FBRecorder::RecordWebCamToFile

FBRecorder::WebCamFormatsCount FBRecorder::WebCamSourcesCount FBRecorder::WebCamSourceAvailable

FBRecorder::GetSelectedWebCamFormat FBRecorder::GetSelectedWebCamSource FBRecorder::GetWebCamFormat FBRecorder::GetWebCamSource FBRecorder::GetWebCamProperties


SelectWebCamVideoFormat

BB FlashBack SDK: FBRecorder

SelectWebCamFormat

Description

Selects a video format for use in webcam recording

Find the number of formats available by using the FBRecorder::WebCamFormatsCount property and the descriptions of the formats by using FBRecorder::GetWebCamFormat.

Syntax

[C#/C++]
public void SelectWebCamFormat (long index);

[VB.NET]
Public Sub SelectWebCamFormat (ByVal index As Integer)

Parameters

index (in) - index of the video format to select.

See Also

FBRecorder::UseWebCam FBRecorder::WebCamKeyFrames FBRecorder::WebCamQuality FBRecorder::SetWebCamParameters

FBRecorder::SelectWebCamSource FBRecorder::SelectWebCamFormat

FBRecorder::TestWebCam FBRecorder::RecordWebCamToFile

FBRecorder::WebCamFormatsCount FBRecorder::WebCamSourcesCount FBRecorder::WebCamSourceAvailable

FBRecorder::GetSelectedWebCamFormat FBRecorder::GetSelectedWebCamSource FBRecorder::GetWebCamFormat FBRecorder::GetWebCamSource FBRecorder::GetWebCamProperties


SelectWebCamVideoSource

BB FlashBack SDK: FBRecorder

SelectWebCamSource

Description

Activates a webcam source by name. Get the webcam source names from the GetWebCamSource method.

Syntax

[C#/C++]
public void SelectWebCamSource (BSTR Source);

[VB.NET]
Public Sub SelectWebCamSource (ByVal Source As String)

Parameters

Source (in) - name of the source previously returned from a call to GetWebCamSource.

See Also

FBRecorder::UseWebCam FBRecorder::WebCamKeyFrames FBRecorder::WebCamQuality FBRecorder::SetWebCamParameters

FBRecorder::SelectWebCamSource FBRecorder::SelectWebCamFormat

FBRecorder::TestWebCam FBRecorder::RecordWebCamToFile

FBRecorder::WebCamFormatsCount FBRecorder::WebCamSourcesCount FBRecorder::WebCamSourceAvailable

FBRecorder::GetSelectedWebCamFormat FBRecorder::GetSelectedWebCamSource FBRecorder::GetWebCamFormat FBRecorder::GetWebCamSource FBRecorder::GetWebCamProperties


SetWebCamParameters

BB FlashBack SDK: FBRecorder

SetWebCamParameters

Description

Sets webcam video quality parameters.

Syntax

[C#/C++]
public void SetWebCamParameters (long KeyFrames, long Quality)

[VB.NET]
Public Sub SetWebCamParameters (ByVal KeyFrames As Integer, ByVal Quality As Integer)

Parameters

KeyFrames (in) - the number of frames between keyframes. More keyframes means better quality but larger FBR movie files. A value of 1 means that all frames are keyframes.

Quality (in) - Takes values from 1-100, where 1 = maximum quality. Lower values mean better quality, but larger FBR files.

Remarks

This method has the same effect as setting the WebCamQuality and WebCamKeyFrames properties.

See Also

FBRecorder::UseWebCam FBRecorder::WebCamKeyFrames FBRecorder::WebCamQuality FBRecorder::SetWebCamParameters

FBRecorder::SelectWebCamSource FBRecorder::SelectWebCamFormat

FBRecorder::TestWebCam FBRecorder::RecordWebCamToFile

FBRecorder::WebCamFormatsCount FBRecorder::WebCamSourcesCount FBRecorder::WebCamSourceAvailable

FBRecorder::GetSelectedWebCamFormat FBRecorder::GetSelectedWebCamSource FBRecorder::GetWebCamFormat FBRecorder::GetWebCamSource FBRecorder::GetWebCamProperties


TestWebCam

BB FlashBack SDK: FBRecorder

TestWebCam

Description

Starts and stop display of webcam output in the specified window.

Syntax

[C#/C++]
public Bool TestWebCam (long hWnd, Bool StartTest)

[VB.NET]
Public Function TestWebCam (ByVal hWnd As Integer, ByVal StartTest As Boolean) As Boolean

Parameters

hWnd (in) - handle of the window in which to show the webcam output.

StartTest (in) - set this to true to start showing the webcam output in the specified window. Set it to false to stop showing webcam output.

Return values

Returns True if successful.

See Also

FBRecorder::UseWebCam FBRecorder::WebCamKeyFrames FBRecorder::WebCamQuality FBRecorder::SetWebCamParameters

FBRecorder::SelectWebCamSource FBRecorder::SelectWebCamFormat

FBRecorder::TestWebCam FBRecorder::RecordWebCamToFile

FBRecorder::WebCamFormatsCount FBRecorder::WebCamSourcesCount FBRecorder::WebCamSourceAvailable

FBRecorder::GetSelectedWebCamFormat FBRecorder::GetSelectedWebCamSource FBRecorder::GetWebCamFormat FBRecorder::GetWebCamSource FBRecorder::GetWebCamProperties


CanDriverBeInstalled

BB FlashBack SDK: FBRecorder

CanDriverBeInstalled

Description

Returns whether the screen capture driver can be installed on the system. Not all systems will allow installation of the capture driver.

Syntax

[C#/C++]
public Bool CanDriverBeInstalled

[VB.NET]
Public Overridable CanDriverBeInstalled As Boolean

See Also

IsDriverInstalled property, InstallDriver method, UninstallDriver method, IsDriverVersionOK method


CheckDriver

BB FlashBack SDK: FBRecorder

CheckDriver

Description

Returns a value indicating whether the capture driver has been successfully installed or uninstalled and whether a reboot is needed to complete the process.

This method should be used after calling InstallDriver or UninstallDriver, in order to know how to proceed.

Syntax

[C#/C++]
public long CheckDriver();

[VB.NET]
Public Function CheckDriver As Long

Return values

Returns -1 if an error occurs.

Otherwise it returns these values on success:

Upper, most significant 16 bits:

Value | Meaning
1 | PC needs a reboot to complete the installation or uninstallation.
2 | No reboot is required.

Lower 16 bits:

Value | Meaning
1 | Driver is installed
2 | Driver is not installed
12 | Driver is installed but the version does not match that required by this installation of the SDK.

See Also

IsDriverInstalled property, InstallDriver method, UninstallDriver method, IsDriverVersionOK method


InstallDriver

BB FlashBack SDK: FBRecorder

InstallDriver

Description

Attempts to install the screen capture driver on the PC.

Syntax

[C#/C++]
public: long InstallDriver()

[VB.NET]
Public Function InstallDriver() As Integer

Return values

The return value is formatted as follows.

High order word:

Value | Meaning
SUCCESS_SUCCESS = 0 | Successfully installed
SUCCESS_REBOOT_NEEDED = 1 | Successfully installed, but PC needs to be rebooted for the driver to be fully operational.
SUCCESS_NOREBOOT_NEEDED = 2 | Successfully installed and PC does not require reboot.
FAILURE = 3 | Install failed.
INCOMPATIBLE_DRIVER_ERROR = 4096 | Software that is known to be incompatible with the capture driver has been detected on this PC. The capture driver has therefore not been installed. See note below for more details.

Low order word:

Value

Meaning

ERROR_UNKNOWN = -1

ERROR_NOERROR = 0

ERROR_NOADMINRIGHTS = 1

Administrator rights are required for capture driver installation, and the current login does not have these rights.

ERROR_NOUNSIGNEDDRV_POLICY = 2

The current domain has a policy defined that prevents the installation of unsigned drivers, and this has prevented installation.

The capture driver is signed for Windows 2000 and XP, but not for Windows 2003 - users need to explicitly approve the installation of the driver during the install process.

ERROR_UNKNOWN = 4

ERROR_EXTRACTFILES = 8

The driver files could not be extracted into the current folder. They need to be extracted prior to being copied into the Windows system folder.

ERROR_RUNONCE_SETUP = 16

The PC needs to be rebooted to complete the install process.

DRIVER_INSTALLED = 32

The driver files could not be copied into the Windows system32/drivers folder.

REGISTRY_ERROR = 512

The registry could not be read.

Remarks

Administrative access rights are required to install the driver. An alternative method of installing the driver, that can be more easily used at application install-time is via FlashbackDriverInstaller.exe. See Installing the Capture Driver on End-User PCs for details.

Call the CanDriverBeInstalled method to determine if the screen capture driver may be installed on the system.

Read the IsDriverInstalled property or use the CheckDriver method to determine the status of the capture driver - whether it is installed or not and whether a reboot is required to complete an installation or uninstallation.

Note: we have discovered that a specific 3rd party display driver is incompatible with the capture driver (and other 'mirror' drivers), causing severe system instability. See Software Incompatible with the capture driver for more details.

See Also

FBRecorder::IsDriverInstalled
  FBRecorder::UninstallDriver
  FBRecorder::IsDriverVersionOK
  FBRecorder::CanDriverBeInstalled
 FBRecorder::CheckDriver


IsDriverVersionOK

BB FlashBack SDK: FBRecorder

IsDriverVersionOK

Description

Checks whether the capture driver is installed on the PC and the version of the driver is acceptable for use with the current instance of the recording control.

Note: this method checks for the presence of the capture driver without causing a screen blank, unlike FBRecorder::IsDriverInstalled which does cause a blank.

Syntax

[C#/C++]
public: Bool IsDriverVersionOK()

[VB.NET]
Public Function IsDriverVersionOK() As Boolean

See Also

IsDriverInstalled property, InstallDriver method, UninstallDriver method, CanDriverBeInstalled method


UninstallDriver

BB FlashBack SDK: FBRecorder

UninstallDriver

Description

Attempts to uninstall the screen capture driver on the system.

Syntax

[C#/C++]
public: long UninstallDriver()

[VB.NET]
Public Overridable Function UninstallDriver() As Integer

Return Value

The return value is formatted as follows.

High order word:

Value | Meaning
SUCCESS_SUCCESS = 0 | Successfully uninstalled
SUCCESS_REBOOT_NEEDED = 1 | Successfully uninstalled, but PC needs to be rebooted for the process to be completed.
SUCCESS_NOREBOOT_NEEDED = 2 | Successfully uninstalled and PC does not require reboot.
FAILURE = 3 | Uninstall failed.

Low order word:

Value | Meaning
ERROR_UNKNOWN = -1 |
ERROR_NOERROR = 0 |
ERROR_NOADMINRIGHTS = 1 | Administrator rights are required for capture driver uninstallation, and the current user does not have these rights.
ERROR_UNKNOWN = 4 |
ERROR_RUNONCE_SETUP = 16 | The PC needs to be rebooted to complete the uninstall process.
DRIVER_NOTINSTALLED = 64 |
UNINSTALL_FAILURE = 128 |
UNINSTALL_SUCCESS = 256 |
REGISTRY_ERROR = 512 |

Remarks

Administrative access rights are required to uninstall the driver. An alternative method of uninstalling the driver, that can be more easily used at application uninstall-time is via FlashbackDriverInstaller.exe. See Installing the Capture Driver on End-User PCs for details.

Read the IsDriverInstalled property to determine if the screen capture driver has been installed.

See Also

IsDriverInstalled property, InstallDriver method, IsDriverVersionOK method, CanDriverBeInstalled method


AddBitmapByHandle

BB FlashBack SDK: FBRecorder

AddBitmapByHandle

Description

When in 'bitmap' compatibility mode, this method adds a bitmap to the movie file.

Syntax

[C#/C++]
public void AddBitmapByHandle (long hBitmap, long x, long y)

[VB.NET]
Public Sub AddBitmapByHandle (ByVal hBitmap As Long, ByVal x As Long, ByVal y As Long)

Parameters

hBitmap - handle of bitmap to add.

x - X position of the point in the movie at which to add the bitmap.

y - Y position of the point in the movie at which to add the bitmap.

Remarks

The CompatibilityMode property can set the recording mode to 'bitmap' mode. When in this mode, screen changes are not recorded. Instead, bitmaps are sent to FBRecorder via the AddBitmapByHandle and AddBitmapFromMemory methods and when the movie is played back, these bitmaps are displayed in the specified sequence, time and position.

See About Record Modes for more information on record modes, including bitmap mode.

See Also


AddBitmapFromMemory

BB FlashBack SDK: FBRecorder

AddBitmapFromMemory

Description

When in 'bitmap' compatibility mode, this method adds a bitmap to the movie file.

Syntax

[C#/C++]
public void AddBitmapFromMemory (long pData, long bits, long palcolors, long colors, long scanline, Bool topdown, long width, long height, long x, long y)

[VB.NET]
Public Sub AddBitmapFromMemory (ByVal pData As Long, ByVal bits As Long, ByVal palcolors As Long, ByVal colors As Long, ByVal scanline As Long, By Val topdown As Boolean, ByVal width As Long, ByVal height As Long, ByVal x As Long, ByVal y As Long)

Parameters

pData - pointer to the bytes of the bitmap.

bits - The colour depth, or number of bits per pixel. The only allowed values are 8, 16, 24 and 32.

palcolours - the number of colors in the color palette, if one is defined by the colors parameter.

colors - pointer to an array of RGBQUAD structures which forms a color palette. Null if no palette is used.

scanline - the width of a single row in the bitmap.

topdown - True if the bitmap is stored in top down order. False if stored in bottom up order.

width, height - the width and height of the image.

x, y - the position of the image in the movie.

Remarks

The CompatibilityMode property can set the recording mode to 'bitmap' mode. When in this mode, screen changes are not recorded. Instead, bitmaps are sent to the movie via the AddBitmapByHandle and AddBitmapFromMemory methods and when the movie is played back, these bitmaps are displayed in the specified sequence, time and position.

See About Record Modes for more information on record modes, including bitmap mode.

See Also


AddWndToList

BB FlashBack SDK: FBRecorder

AddWndToList

Description

Adds a window to the list of windows that will be recorded.

Syntax

[C#/C++]
public Bool AddWndToList (HWND hWnd)

[VB.NET]
Public Function AddWndToList (ByVal hWnd As HWND) As Boolean

Parameters

hWnd - handle of the window to be added.

Remarks

The SDK can restrict what it records to a number of windows, rather than a region or everything on the desktop.

The set of windows to be recorded can be specified by passing their handles to the AddWndToList method, or by passing a process ID to SetProcessId. In the latter case, all windows owned by that process will be recorded.

In this mode, FlashBack SDK will record a movie with the same dimensions as the entire desktop, but all areas outside of the specified windows will be blacked out.

Only one monitor at a time can be recorded, so all the windows must be displayed on the same monitor. If they are displayed on a secondary monitor, that monitor must be selected for recording by the SelectMonitor method.

See Recording Windows and Regions for details.

Note: to record a single window, use the RegionFromHWND method.

See Also


CanMovieBeRecovered

BB FlashBack SDK: FBRecorder

CanMovieBeRecovered

Description

Checks the given FBR file to see if it can be recovered, and if so returns the filename of recovery information that can be passed to the FBRecorder::RecoverMovie method.

See Recovering Corrupted Recordings for information on using the files to recover recordings.

Syntax

[C#/C++]
public Bool CanMovieBeRecovered (String FileName, String* RecoveryInfoFileName)

[VB.NET]
Public Function CanMovieBeRecovered (ByVal FileName As String, ByRef RecoveryInfoFileName As String) As Boolean

Parameters

FileName : the name of the FBR file to be checked.

RecoveryInfoFileName (output) : if the file can be recovered, this is the name of the recovery info file that should be passed to FBRecorder::RecoverMovie.

Return Value

Returns True if the file can be recovered, False if it can not.

See Also


ClearWndList

BB FlashBack SDK: FBRecorder

ClearWndList

Description

Clears the list of windows to be recorded. when the window list is empty, either a region or the full desktop will be recorded instead.

Syntax

[C#/C++]
public void ClearWndList ();

[VB.NET]
Public Sub ClearWndList

Remarks

The SDK can restrict what it records to a number of windows, rather than a region or everything on the desktop.

The set of windows to be recorded can be specified by passing their handles to the AddWndToList method, or by passing a process ID to SetProcessId. In the latter case, all windows owned by that process will be recorded.

In this mode, FlashBack SDK will record a movie with the same dimensions as the entire desktop, but all areas outside of the specified windows will be blacked out.

See Recording Windows and Regions for details.

See Also


FBRecorder::CurrentFrameNum

BB FlashBack SDK: FBRecorder

CurrentFrameNum

Description

Returns the number of the frame currently being recorded.

Syntax

[C#/C++]
public: long CurrentFrameNum()

[VB.NET]
Public Function CurrentFrameNum As Integer

Remarks

The default frame rate when recording in capture driver mode is 24 frames per second (fps). The default frame rates for GDI and DirectX modes are calculated by measuring the capabilities of the PCs video hardware.


GetCurrentMonitor

BB FlashBack SDK: FBRecorder

GetCurrentMonitor

Description

Returns the index of the monitor currently selected for recording.

Select a monitor for recording with FBRecorder::SelectMonitor.

Syntax

[C#/C++]
Public long GetCurrentMonitor ();

[VB.NET]
public Function GetCurrentMonitor () as Integer

Remarks

Use FBRecorder::MonitorsCount to get the number of attached monitors. Use FBRecorder::GetMonitor to get information about a specified monitor. Use FBRecorder::SelectMonitor to set the monitor to record.

See Also


GetErrorText

BB FlashBack SDK: FBRecorder

GetErrorText

Description

Takes the error code passed into the FBRecorder::OnError event handler and returns the text of the corresponding error message.

Syntax

[C#/C++]
public BSTR* GetErrorText (long ErrCode)

[VB.NET]
public Function GetErrorText (ByVal ErrCode As Integer) as String

Parameters

ErrCode (in) - error code passed to OnError event hander

Return value

When a valid error code is passed in, the function returns the message text for that error.

See Also

FBRecorder::OnError


GetLicenceInfo

BB FlashBack SDK: FBRecorder

GetLicenceInfo

Description

Returns a value indicating the type and validity of the SDK licence currently in use.

Syntax

[C#/C++]
public Bool GetLicenceInfo (long* pLicenceType)

[VB.NET]
public Function GetLicenceInfo (ByRef pLicenceType() As Long) As Boolean

Parameters

pLicenceType : pointer to a long value that will be set to a value indicating the type of licence.

Return Values

If the licence is invalid, the return value is zero.

If the licence is valid, the return value non-zero.

Remarks

Possible values of pLicenceType:

0 | Basic
1 | Professional
2 | Advanced


FBRecorder::GetMonitor

BB FlashBack SDK: FBRecorder

GetMonitor

Description

Returns information on a selected monitor, given its index in the list of monitors detected by Windows.

Syntax

[C#/C++]
Public void GetMonitor (long index, BSTR *DeviceName , long *flags, long *left, long *top, long *right, long *bottom)

[VB.NET]
public Sub GetMonitor (ByVal index as Integer, ByRef DeviceName as String, ByRef flags as Integer, ByRef left as Integer, ByRef top as Integer, ByRef right as Integer, ByRef bottom as Integer)

Parameters

Index (in): the index of the monitor. Use FBRecorder::MonitorsCount to get the number of attached monitors.

DeviceName (out): specifies the name of the display monitor.

Flags (out): if the monitor is the primary monitor, this parameter will be set to MONITORINFOF_PRIMARY, #defined in Win32 SDK as 0x00000001.

Left, Top, Right, Bottom (out): the position of the monitor within the Windows desktop. Note that if the monitor is not the primary monitor, these can be negative values.

Remarks

Use FBRecorder::MonitorsCount to get the number of attached monitors. Use FBRecorder::SelectMonitor to select a monitor for recording and FBRecorder::GetCurrentMonitor to get the currently selected monitor.

See Also


GetPrimaryMonitor

BB FlashBack SDK: FBRecorder

GetPrimaryMonitor

Description

Returns the index of the primary monitor.

By default only the primary monitor is recorded.

Syntax

[C#/C++]
Public void GetPrimaryMonitor (long* index)

[VB.NET]
public sub GetPrimaryMonitor (ByRef index as Integer)

Parameters

index (out) - index of the primary monitor

Remarks

Use FBRecorder::MonitorsCount to find out how many monitors are available. Use FBRecorder::RecordMonitor to set which will be recorded. Monitors are automatically selected for recording if a region or window is set using FBRecorder::SetRecordRegion, FBRecorder::SetProcessId, FBRecorder::RegionFromHWND and FBRecorder::AddWndToList.

See Also


GetRecordMonitor

BB FlashBack SDK: FBRecorder

GetRecordMonitor

Description

Gets a value indicating whether a monitor will be recorded or not.

Syntax

[C#/C++]
Public void GetRecordMonitor (long index, Bool* toRecord)

[VB.NET]
public sub GetRecordMonitor (ByVal index as Integer, ByRef toRecord as Boolean)

Parameters

index (in) - index of the monitor to query

toRecord (out) - boolean indicating whether the monitor is selected to be recorded

Remarks

Use FBRecorder::MonitorsCount to find out how many monitors are available. Use FBRecorder::RecordMonitor to set which will be recorded. Monitors are automatically selected for recording if a region or window is set using FBRecorder::SetRecordRegion, FBRecorder::SetProcessId, FBRecorder::RegionFromHWND and FBRecorder::AddWndToList.

See Also


GetRecordMonitorsDesktopPosition

BB FlashBack SDK: FBRecorder

GetRecordMonitorsDesktopPosition

Description

Returns a desktop region that covers all recorded monitors.

Syntax

[C#/C++]
Public void GetRecordMonitorsDesktopPosition (long* topleft_x, long* topleft_y, long* bottomright_x, long* bottomright_y)

[VB.NET]
public sub GetRecordMonitorsDesktopPosition (ByRef topleft_x as Integer, ByRef topleft_y as Integer, ByRef bottomright_x as Integer, ByRef bottomright_y as Integer)

Parameters

topleft_x (out) - X position of the top left corner of the region

topleft_y (out) - Y position of the top left corner of the region

bottomright_x (out) - X position of the bottom right corner of the region

bottomright_y (out) - Y position of the bottom right corner of the region

Remarks

Use FBRecorder::MonitorsCount to find out how many monitors are available. Use FBRecorder::RecordMonitor to set which will be recorded. Monitors are automatically selected for recording if a region or window is set using FBRecorder::SetRecordRegion, FBRecorder::SetProcessId, FBRecorder::RegionFromHWND and FBRecorder::AddWndToList.

FBRecorder::GetRecordMonitorsDesktopSize returns the width and height of the recorded region.

See Also


GetRecordMonitorsDesktopSize

BB FlashBack SDK: FBRecorder

GetRecordMonitorsDesktopSize

Description

Returns the size of the region that will be recorded. The region includes all recorded monitors.

Syntax

[C#/C++]
Public void GetRecordMonitorsDesktopSize (long* width, long* height)

[VB.NET]
public sub GetRecordMonitorsDesktopSize (ByRef width as Integer, ByRef height as Integer)

Parameters

width (out) - width of the recorded region

height (out) - height of the recorded region

Remarks

Use FBRecorder::MonitorsCount to find out how many monitors are available. Use FBRecorder::RecordMonitor to set which will be recorded. Monitors are automatically selected for recording if a region or window is set using FBRecorder::SetRecordRegion, FBRecorder::SetProcessId, FBRecorder::RegionFromHWND and FBRecorder::AddWndToList.

FBRecorder::GetRecordMonitorsDesktopWidth returns the position and size of the recorded region.

See Also


GetRecordMonitorsNumber

BB FlashBack SDK: FBRecorder

GetRecordMonitorsNumber

Description

Returns the number of monitors to be recorded.

Syntax

[C#/C++]
Public void GetRecordMonitor (long* count)

[VB.NET]
public sub GetRecordMonitor (ByRef count as Integer)

Parameters

count (out) - the number of monitors selected to be recorded

Remarks

Use FBRecorder::MonitorsCount to find out how many monitors are available. Use FBRecorder::RecordMonitor to set which will be recorded. Monitors are automatically selected for recording if a region or window is set using FBRecorder::SetRecordRegion, FBRecorder::SetProcessId, FBRecorder::RegionFromHWND and FBRecorder::AddWndToList.

See Also


GetDesktopRegion

BB FlashBack SDK: FBRecorder

GetRecordRegion

Description

Gets the record region, if it has been set via SetRecordRegion or the RegionX, RegionY, RegionHeight and RegionWidth properties.

Syntax

[C#/C++]
Public Bool GetRecordRegion(long* X, long* Y, long* Width, long* Height);

[VB.NET]
public Function GetRecordRegion (ByRef X As Integer, ByRef Y As Integer, ByRef Width As Integer, ByRef Height As Integer) as Boolean

Parameters

X (out) - X position of the top left corner of the region

Y (out) - Y position of the top left corner of the region

Width (out) - width of the region

Height (out) - height of the region

Returns

Returns True if a record region has already been set by SetRecordRegion or the RegionX, RegionY, RegionHeight, RegionWidth parameters.

Returns False if a record region has not been set.

Remarks

Desktop co-ordinates are used.

See Also


FBRecorder::GetRuntimeLicence

BB FlashBack SDK: FBRecorder

GetRuntimeLicence

Description

Gets the 'runtime' licence key that must be passed to a call to SetRuntimeLicence on the end-user's PC, in order to fully licence applications that use the FlashBack SDK.

Syntax

[C#/C++]
public String GetRuntimeLicence (void)

[VB.NET]
public Function GetRuntimeLicence as String

Return value

When the function succeeds, it returns the runtime licence key string.

Remarks

In the executable delivered to end-users, the first call to FBRecorder after construction must be SetRuntimeLicence, passing in the value returned from a previous call to FBRecorder::GetRuntimeLicence on the developers PC. If this call to SetRuntimeLicence is not made, the delivered executable will not be fully licensed and subsequent calls to objects will fail.

See Also


FBRecorder::InsertMarker

BB FlashBack SDK: FBRecorder

InsertMarker

Description

Inserts a marker with a specified name into the movie being recorded. If the method is called one minute after recording starts, the marker is inserted at the one minute point in the movie.

Syntax

[C#/C++]
public void InsertMarker (String sMarkerName, long* pID)

[VB.NET]
Public Sub InsertMarker (ByVal sMarkerName As String, ByRef pID As Integer)

Parameters

sMarkerName : the name to be given to the marker.

pID : if successful, this points to the new marker when function returns.

Return Value

None.

Remarks

This can only be used when recording is in progress.

See Also

FBRecorder::InsertSoundToFBRAtMarker


InsertSoundToFBRAtMarker

BB FlashBack SDK: FBRecorder

InsertSoundToFBRAtMarker

Description

Adds a sound file to the movie at the specified marker.

Syntax

[C#/C++]
public Bool InsertSoundToFBRAtMarker (String sMovieName, String sSoundName, String sMarkerName);

[VB.NET]
Public Function InsertSoundToFBRAtMarker (ByVal sMovieName As String, ByVal sSoundName as String, ByVal sMarkerName As String) As Boolean

Parameters

sMovieName - file name of the movie to add the sound to.

sSoundName - file name of the sound to add to the movie.

sMarkerName - name of the marker at which to add the sound.

Return values

Returns True is successful, False if not.


FBRecorder::InsertTextBox

BB FlashBack SDK: FBRecorder

InsertTextBox

Description

Inserts a textbox with the specified properties into the movie being recorded. For example: if the method is called one minute after recording starts, the marker is inserted at the one minute point in the movie.

Syntax

[C#/C++]
public void InsertTextBox (InsertTextBoxParams *pParams)

[VB.NET]
Public Function InsertTextBox (ByRef pParams As InsertTextBoxParams) As void

Parameters

pParams : pointer to a InsertTextBoxParams object that defines the properties of the text box.

Remarks

This can only be used when recording is in progress.

See Also

The InsertTextBoxParams class


IsMovieStructureCorrect

BB FlashBack SDK: FBRecorder

IsMovieStructureCorrect

Description

This method checks the structure of an FBR file to see if it can be opened by FBPlayer or FBEditor.

See Recovering Corrupted Recordings for information on using the files to recover recordings.

Syntax

[C#/C++]
public Bool IsMovieStructureCorrect (String MovieName, long* ErrorCode)

[VB.NET]
Public Function IsMovieStructureCorrect (ByVal MovieName As String, ByRef ErrorCode As Integer) As Boolean

Parameters

MovieName : the name of the FBR file to check the structure of

ErrorCode (output): if the structure is incorrect, this error code can be sent to Blueberry for further assistance.

Return Value

False if the structure is incorrect and the file cannot be opened by FBPlayer or FBEditor, True if the file can be opened ok.

See Also


PauseAndSave

BB FlashBack SDK: FBRecorder

PauseAndSave

Description

Pauses recording and saves what has been recorded up to this point to the file defined by the FBRecorder::Filename property. This method also sets the movie filename for subsequent recording after the pause.

Events recorded after calling this method are saved into a new file.

Syntax

[C#/C++]
public: Bool PauseAndSave(BSTR NextFileName, Bool ResetCounter)

[VB.NET]
Public Overridable Function PauseAndSave(String NextFileName, Boolean ResetCounter) As Boolean

Remarks

To continue recording, set FBRecorder::Pause to False. Everything recorded after the pause will be saved to the movie file set by the NextFileName parameter.

Return values

Returns True if recording is successfully paused and saved to a movie file. Returns False if the save was not successful.

Parameters

NextFileName (in) : name of the file into which activity recorded after the pause will be saved.

ResetCounter (in) : resets to zero the IDs of objects (textboxes, images, markers) in the new movie file that FBRecorder continues to record after saving.

i.e. set this to True to have the IDs of objects in this continued recording start from zero. Set this to False to have object IDs continue on from the saved recording.

See Also

RecordMode property, Pause property, Stop method, Filename property


RecordMonitor

BB FlashBack SDK: FBRecorder

RecordMonitor

Description

Sets whether a monitor should be recorded or not. By default, only the primary monitor is recorded.

Syntax

[C#/C++]
Public void RecordMonitor (long index, Bool doRecord)

[VB.NET]
public Sub RecordMonitor (ByVal index as Integer, ByVal doRecord as Boolean)

Parameters

index (in) - index of the monitor to select or deselect for recording

doRecord (in) - boolean indicating whether the monitor is to be recorded

Remarks

Use FBRecorder::MonitorsCount to find out how many monitors are available. Use FBRecorder::RecordMonitor to set which will be recorded. Monitors are automatically selected for recording if a region or window is set using FBRecorder::SetRecordRegion, FBRecorder::SetProcessId, FBRecorder::RegionFromHWND and FBRecorder::AddWndToList.

See Also


RecordSingleMonitor

BB FlashBack SDK: FBRecorder

RecordSingleMonitor

Description

Sets the index of the only monitor to be recorded, effectively deselecting the other monitors. This could be achieved using FBRecorder::RecordMonitor , but RecordSingleMonitor provides a simpler API.

Syntax

[C#/C++]
Public void RecordSingleMonitor (long index)

[VB.NET]
public Sub RecordSingleMonitor (ByVal index as Integer)

Parameters

index (in) - index of the monitor to select for recording

Remarks

Use FBRecorder::MonitorsCount to find out how many monitors are available. Use FBRecorder::RecordMonitor to set which will be recorded. Monitors are automatically selected for recording if a region or window is set using FBRecorder::SetRecordRegion, FBRecorder::SetProcessId, FBRecorder::RegionFromHWND and FBRecorder::AddWndToList.

See Also


RecoverMovie

BB FlashBack SDK: FBRecorder

RecoverMovie

Description

Recovers recordings corrupted by unscheduled recorder process termination.

See Recovering Corrupted Recordings for information on using the files to recover recordings.

Syntax

[C#/C++]
public Bool RecoverMovie (String MovieName, String RecoveryInfoFileName, String NewMovieName, Bool RemoveRecoveryInfoFiles)

[VB.NET]
Public Function RecoverMovie (ByVal MovieName As String, ByVal RecoveryInfoFileName As String, ByVal NewMovieName As String, ByVal RemoveRecoveryInfoFiles As Boolean) As Boolean

Parameters

MovieName : the name of the corrupted FBR file to be recovered

RecoveryInfoFileName : the name of the recovery info file returned from CanMovieBeRecovered.

NewMovieName : the name of the new FBR file to recover to

RemoveRecoveryInfoFiles : set to True to remove the recovery info files if recovery is successful

Return Value

True if recovery is successful.

See Also


RegionFromHWND

BB FlashBack SDK: FBRecorder

RegionFromHWND

Description

Sets the properties that define the recording region (RegionHeight, RegionWidth, RegionX, RegionY) to the size and position of the specified window.

Syntax

[C#/C++]
public void RegionFromHWND (HWND hWnd)

[VB.NET]
Public Sub RegionFromHWND (ByVal hWnd As HWND)

Parameters

hWnd - handle of the window whose region we want to record.

Remarks

Only one monitor at a time can be recorded, so the window must be displayed entirely on one monitor. If the window is on a secondary monitor, the monitor must be selected by the SelectMonitor method.

To record a single window, the SDK can be used like this:

  1. Set FBRecorder::UseRegion to True.

  2. Set FBRecorder::RegionRecordingType = 1 , to record a region.

  3. Pass the handle of the window to be recorded to RegionFromHWND, which defines a region from the window size and position, setting the RegionHeight, RegionWidth, RegionX and RegionY properties accordingly.

See Recording Windows and Regions for more help on how to record windows and regions.

See Also


RemoveWndFromList

BB FlashBack SDK: FBRecorder

RemoveWndFromList

Description

Removes a window from the list of windows that will be recorded.

Syntax

[C#/C++]
public Bool RemoveWndFromList (HWND hWnd)

[VB.NET]
Public Function RemoveWndFromList (ByVal hWnd As HWND) As Bool

Parameters

hWnd - handle of the window to be removed.

Return values

Returns False if the window was not found in the list. Returns True if window successfully removed.

Remarks

The SDK can restrict what it records to a number of windows, rather than a region or everything on the desktop.

The set of windows to be recorded can be specified by passing their handles to the AddWndToList method, or by passing a process ID to SetProcessId. In the latter case, all windows owned by that process will be recorded.

In this mode, FlashBack SDK will record a movie with the same dimensions as the entire desktop, but all areas outside of the specified windows will be blacked out.

If its 'window list' is empty, FlashBack SDK will record either the entire desktop or a region, as specified by the UseRegion and RecordingRegionType flags.

See Also


FBRecorder::SaveAndContinue

BB FlashBack SDK: FBRecorder

SaveAndContinue

Description

Saves the current recording to the file specified by the FBRecorder::Filename parameter, sets the file name of the next recording file to be saved and continues recording.

Events recorded after calling this method are saved into a new file.

Syntax

[C#/C++]
public Bool SaveAndContinue(BSTR FileName, Bool ResetCounter)

[VB.NET]
Public Overrideable Function SaveAndContinue(String FileName, Boolean ResetCounter) As Boolean

Parameters

FileName (in) : name of the file into which the next recording should be saved.

ResetCounter (in) : resets to zero the IDs of objects (textboxes, images, markers) in the new movie file that FBRecorder continues to record after saving.

i.e. set this to True to have the IDs of objects in this continued recording start from zero. Set this to False to have object IDs continue on from the saved recording.

Return values

Returns True if recording is successfully saved. Returns False if the save was not successful.

See Also


SelectMonitor

BB FlashBack SDK: FBRecorder

SelectMonitor

Description

Sets the monitor that FBRecorder will record.

Use FBRecorder::GetCurrentMonitor to get the index of the selected monitor.

Use FBRecorder::MonitorsCount and FBRecorder::GetMonitor to get information on attached monitors.

Syntax

[C#/C++]
Public void SelectMonitor (long index)

[VB.NET]
public Sub SelectMonitor (ByVal index as Integer)

Remarks

DirectX and capture driver record modes can only record the primary monitor.

See Also


SetProcessId

BB FlashBack SDK: FBRecorder

SetProcessId

Description

Sets the Id of a process, for which the SDK will record all owned windows.

Syntax

[C#/C++]
public void SetProcessId (long lProcessID);

[VB.NET]
Public Sub SetProcessId (ByVal lProcessID As Long)

Parameters

lProcessID - the ID of the process for which you want to record all windows.

Remarks

The SDK can restrict what it records to windows owned by a particular process, rather than a region or everything on the desktop. This 'process' mode is selected via the RecordingRegionType property.

The set of windows to be recorded can be specified by passing a process ID to SetProcessId. All windows owned by that process will be recorded.

In this mode, FlashBack SDK will record a movie with the same dimensions as the entire desktop, but all areas outside of the specified windows will be blacked out.

See Also

FBRecorder::RecordingRegionType


SetRecordingRegionPosition

BB FlashBack SDK: FBRecorder

SetRecordingRegionPosition

Description

Sets the position of the recording region while recording is in progress. The monitor or monitors on which the region lies will be automatically selected for recording.

This method only has an effect if region recording was selected for the current recording. See Recording Windows and Regions

This method can only change the region when GDI record mode has been selected. See About Record Modes.

To set the size and position of the initial recording region, use FBRecorder::SetRecordRegion.

Syntax

[C#/C++]
Public Bool SetRecordingRegionPosition (Long X, Long Y);

[VB.NET]
public Function SetRecordingRegionPosition (ByVal X As Integer, ByVal Y As Integer) as Boolean

Parameters

X (in) - X position of the top left corner of the region

Y (in) - Y position of the top left corner of the region

Returns

Returns True if the region is set successfully. Returns False and does not set the record region if the region lies outside of the desktop.

Remarks

Desktop co-ordinates are used for the top left corner specified here. X should be >= the X position of the top left corner of the leftmost monitor. Y should be >= the Y position of the top left corner of the leftmost monitor.

See Also

FBRecorder::GetRecordRegion


SetDesktopRegion

BB FlashBack SDK: FBRecorder

SetRecordRegion

Description

Sets the region to record. The monitor or monitors on which the region lies will be automatically selected for recording.

If you need to change the recorded region while recording is in progress, use FBRecorder::SetRecordingRegionPosition.

Syntax

[C#/C++]
Public Bool SetRecordRegion(Long X, Long Y, Long Width, Long Height);

[VB.NET]
public Function SetRecordRegion (ByVal X As Integer, ByVal Y As Integer, ByVal Width As Integer, ByVal Height As Integer) as Boolean

Parameters

X (in) - X position of the top left corner of the region

Y (in) - Y position of the top left corner of the region

Height (in) - height of the record region

Width (in) - width of the record region

Returns

Returns True if the region is set successfully. Returns False and does not set the record region if the region lies outside of the desktop.

Remarks

Desktop co-ordinates are used for the top left corner specified here. X should be >= the X position of the top left corner of the leftmost monitor. Y should be >= the Y position of the top left corner of the leftmost monitor.

See Also

FBRecorder::GetRecordRegion


FBRecorder::SetRuntimeLicence

BB FlashBack SDK: FBRecorder

SetRuntimeLicence

Description

Sets the 'runtime' licence that licences applications produced using the FlashBack SDK so they can run on end-user PCs.

Syntax

[C#/C++]
public void SetRuntimeLicence (BSTR sLicence)

[VB.NET]
Public Sub SetRuntimeLicence (ByVal sLicence As String)

Remarks

When running applications produced using the SDK on PCs that do not have the SDK installed (i.e. end-user PCs), the runtime licence must be set before any methods are called or properties accessed on an instance of FBRecorder. If the runtime licence is not set, all calls will fail.

It should be set to the runtime licence string obtained from the SDK Licensing utility or via the GetRuntimeLicence method. See Runtime licensing on end-user PCs for details.

Note for Delphi users: Delphi has a limit for string literals of 255 characters. The runtime licence exceeds this limit, so you must break the licence string into two literals. i.e. code like MyRecorder.SetRuntimeLicence("abcdef..." + "lmnop...");

See Also


FBRecorder::Start

BB FlashBack SDK: FBRecorder

Start

Description

Starts a screen recording. Returns a boolean value indicating whether the recording has successfully started.

Syntax

[C#/C++]
public: Bool Start()

[VB.NET]
Public Overridable Function Start() As Boolean

Remarks

Set the Filename property before recording, to set the name of the movie file that will be created.

The RecordMode property determines whether the screen capture driver will be used during the recording.

See Also

RecordMode property, Pause property, Stop method, Filename property


FBRecorder::Stop

BB FlashBack SDK: FBRecorder

Stop

Description

Stops recording. Returns a boolean value indicating whether the recording has successfully stopped.

Syntax

[C#/C++]
public: Bool Stop()

[VB.NET]
Public Overridable Function Stop() As Boolean

Remarks

When recording stops, a .FBR movie file with name defined by FBRecorder::Filename will be created. During this process the OnCloseOutputFile and CloseFilesProgress events handlers will be called.

See Also


TestCompatibilityRecordMode

BB FlashBack SDK: FBRecorder

TestCompatibilityRecordMode

Description

Tests the capabilities of the PC graphics hardware and returns a recommended compatibility mode and frame rate.

Syntax

[C#/C++]
public void TestCompatibilityRecordMode (long *pRecordMode, long *pMaxDelay)

[VB.NET]
Public Sub TestCompatibilityRecordMode (ByRef pRecordMode() As Long, ByRef pMaxDelay() As Long)

Parameters

pRecordMode - pointer to a long variable that will be filled with the recommended compatibility mode recommended for use on the PC.

See Also

FBRecorder::CompatibilityMode


UpdateDisplayList

BB FlashBack SDK: FBRecorder

UpdateDisplayList

Description

This method refreshes settings in FBRecorder that use system display properties, e.g. MonitorsCount. It should be called after making system wide display changes such as changing the desktop resolution.

Syntax

[C#/C++]
public: void UpdateDisplayList();

[VB.NET]
Public Sub UpdateDisplayList


CloseFilesProgress

BB FlashBack SDK: FBRecorder

CloseFilesProgress

Description

This event handler is called to indicate progress in closing the movie file when recording stops.

Syntax

[C#/C++]
protected virtual void CloseFilesProgress (long current, long overall)

[VB.NET]
Protected Overridable Sub CloseFilesProgress(ByVal current As Integer, ByVal overall As Integer)

Parameters

current - the % progress in the current stage. There are 12 stages overall in closing the movie file.

overall - the % progress overall in closing the recording

Remarks

Use this event to display progress indicators while closing movie files after stopping recording.

Setting the event handler

[C#]
fbEditor.CloseFilesProgess += new IFBRecorderEvents_CloseFilesProgressHandler(MyCloseFilesProgressHandler);

[VB]
AddHandler MyRecorder.CloseFilesProgress, AddressOf MyCloseFilesProgressHandler

[Delphi]
MyRecorder.CloseFilesProgress := MyCloseFilesProgressHandler;

[C++ Builder]
MyRecorder->CloseFilesProgress = MyCloseFilesProgressHandler;

See Also


OnCloseOutputFile

BB FlashBack SDK: FBRecorder

OnCloseOutputFile

Description

This event handler is called when FBRecorder has finished writing to the movie file. There may be a delay of a few seconds, depending on the size of the movie, between stopping recording and completing writes to the movie file.

Syntax

[C#/C++]
protected virtual void OnCloseOutputFile(void);

[VB.NET]
Protected Overridable Sub OnCloseOutputFile

Setting the event handler

[C#]
MyRecorder.OnCloseOutputFile += new IFBRecorderEvents_OnCloseOutputFileHandler(MyOnCloseOutputFileHandler);

[VB]
AddHandler MyRecorder.OnCloseOutputFile AddressOf MyOnCloseOutputFileHandler

[Delphi]
MyRecorder.OnCloseOutputFile := MyOnCloseOutputFileHandler;

[C++ Builder]
MyRecorder->OnCloseOutputFile = MyOnCloseOutputFileHandler;

See Also


OnError

BB FlashBack SDK: FBRecorder

OnError

Description

This event handler can be used to catch internal FBRecorder errors, and display messages to the end-user, or write messages to a log file.

Syntax

[C#/C++]
public void OnError (long ErrCode);

[VB.NET]
Public Sub OnError (ByVal ErrCode As Integer)

Parameters

ErrCode - the code of the error message

Remarks

Use FBRecorder::GetErrorText to retrieve the message corresponding to the error code passed into this event handler.

Setting the event handler

[C#]
fbEditor.OnError += new IFBEditorEvents_OnErrorEventHandler(OnErrorHandler);

[VB]
AddHandler fbEditor.OnError, AddressOf OnErrorHandler

[Delphi]
FBEditor.OnError := OnErrorHandler;

[C++ Builder]
Editor->OnError = OnErrorHandler;

See Also

FBRecorder::GetErrorText

List of error codes

Here is a full list of error codes returned to the OnError callback

#define REC_ERROR_NO_ERRORS_0                                0

#define REC_ERROR_NO_BBCAP_DRIVER_FOUND_1                    1

#define REC_ERROR_CANT_CHANGE_DISPLAY_SETTINGS_2             2

#define REC_ERROR_CANT_ACCESS_REGISTRY_3                     3

#define REC_ERROR_CANT_ACCESS_HARDWARE_PROFILES_KEY_4        4

#define REC_ERROR_CANT_SET_ATTACH_TO_DESKTOP_5               5

#define REC_ERROR_CANT_CREATE_BBCAP_SURFACE_6                6

#define REC_ERROR_DRIVER_IS_NOT_ALIVE_7                      7

#define REC_ERROR_DRIVER_HAS_INVALID_VERSION_8               8

#define REC_ERROR_DRIVER_WAS_NOT_UNINITIALIZED_9             9

#define REC_ERROR_DRIVER_WAS_NOT_INITIALIZED_10              10

#define REC_ERROR_DRIVER_WAS_NOT_LOADED_11                   11

#define REC_ERROR_ENUM_DISPLAY_SETTINGS_12                   12

#define REC_ERROR_DRIVER_HAS_INVALID_VERSION_BBCAP_13        13

#define REC_ERROR_DRIVER_HAS_INVALID_VERSION_BBCHLP_14       14

#define REC_ERROR_RECORD_TYPE_NOT_SUPPORTED_15               15

#define REC_ERROR_RECORDER_WAS_NOT_INITIALIZED_16            16

#define REC_ERROR_CANT_CREATE_FILES_17                       17

#define REC_ERROR_CANT_CREATE_DC_18                          18

#define REC_ERROR_CANT_CREATE_MEMDC_19                       19

#define REC_ERROR_CANT_ALLOCATE_MEMORY_20                    20

#define REC_ERROR_CANT_CREATE_THREAD_21                      21

#define REC_ERROR_DRIVER_RETURNED_INVALID_POINTERS_22        22

#define REC_ERROR_RECORDER_WAS_NOT_STARTED_23                23

#define REC_ERROR_CANT_EXTRACT_DRVINSTALLER_24               24

#define REC_ERROR_INVALID_BITMAP_DIMENSIONS_25               25

#define REC_ERROR_BINARY_FILE_IS_NULL_26                     26

#define REC_ERROR_NOT_BITMAP_MODE_27                         27

#define REC_ERROR_BITMAP_IS_INVALID_28                       28

#define REC_ERROR_GETDIBBITS_29                              29

#define REC_ERROR_DRIVER_WAS_UNINITIALIZED_BY_ANOTHER_APP_30 30

#define REC_ERROR_DRIVER_IS_NOT_ACTIVE_31                    31

#define REC_ERROR_CANT_USE_DDCAPTURE_32                      32

#define REC_ERROR_CREATEDIBSECTION_ERROR_33                  33

#define REC_ERROR_RECORDER_IN_PAUSE_MODE_34                  34

#define REC_ERROR_CANT_CREATE_FONT_35                        35

#define REC_ERROR_INVALID_MONITOR_INDEX_36                   36

#define REC_ERROR_NO_WEBCAMERA_37                            37

#define REC_ERROR_CANT_SET_MOUSE_HOOK_38                     38

#define REC_ERROR_CANT_SET_KEYBOARD_HOOK_39                  39

#define REC_ERROR_NO_RECORDER_OBJECT_OR_NOT_VISTA_40         40

#define REC_ERROR_NO_RECORDER_OBJECT_41                      41

#define REC_ERROR_NO_RECORDER_OBJECT_OR_INVALID_INDEX_42     42

#define REC_ERROR_INVALID_ERROR_CODE_43                      43

#define REC_ERROR_INVALID_SOUND_SRC_INDEX_44                 44

#define REC_ERROR_CANT_USE_DD_ON_VISTA_45                    45

#define REC_ERROR_INVALID_REGION_SIZE_46                     46

#define REC_ERROR_MONITOR_INDEX_OUT_OF_BOUNDS_47             47

#define REC_ERROR_NOT_COMP_MODE_48                           48

#define REC_ERROR_NOT_REGION_MODE_49                         49

#define REC_ERROR_DD_SURFACE_WAS_LOST_50                     50


FB Player Class

BB FlashBack SDK: Base Classes

FBPlayer Class

This class is used to play back screen recordings created by FBRecorder.

Properties

Autoscroll
BackgroundColor
BackgroundText
BackgroundTextColor
CacheCompressionType
CacheDiskLimit
CacheEnabled
CacheFramesFrequency
CacheMemoryLimit
CacheType
CurrentFrame
CurrentTime
DisableFullScreenDblClick
EnableLogging
Filename
Frames
FramesPerSec
FullScreen
HasWebCamVideo
HideFullscreenButton
HighlightMouseClicks
HTTPFilename
HWND
IsMovieLoaded
IsToolbarDocked
IsToolbarVisible
Length
Looped
MarkersCount
MonitorsCount
MovieHeight
MovieSpeed
MovieWidth
MuteSound
Pause
PopupMenuItems
Smoothing
SoundVolume
ToolbarColor
ToolbarDisabled
UnpauseByClick
UseGDIOnly
WebCamVideoPositionX
WebCamVideoPositionY
Zoom

Methods

CopyCurrentFrameBitmap
CreateMarkersList
FirstFrame
FrameWithMarker
FrameWithPause
FrameWithUserPause
FreeMarkersList
GetFrameMarkerText
GetFrameRealTime
GetFrameUserPauseID
GetFullScreenMonitor
GetMarkerFrameNum
GetMarkerID
GetMarkerInfoFromList
GetMarkersCountInList
GetMarkerText
GetMonitorInfoA
GotoFrame
GotoFrameRealTime
GotoMarker
GotoMarkerID
GotoMarkerNum
LastFrame
LoadFile
Play
RemoveUserPause
RemoveUserPauses
SetFullScreenMonitor
SetUserPause
Stop
UnloadFile
UpdateSize

Events

OnFrameWithObject
OnPause

See Also

The FBRecorder Class The FBEditor Class


About the player cache

BB FlashBack SDK: Base Classes

The FBPlayer class keeps a cache of frames that have been decompressed from the movie file. This cache makes it faster to display frames out of sequence. When the player is required to show a particular frame, it pulls from the cache the frame nearest and before the requested frame, using this as a convenient starting point from which to render the requested frame.

The larger the cache, the smaller the time taken, on average, to render randomly selected frames.

The type of cache, disk or memory, is selected by the CacheType property.

Setting CacheEnabled to True means FBPlayer will try to set sensible defaults for other cache-related properties. It is not necessary to set these properties manually, unless defaults need to be overridden.

The SDK decides the default cache type as follows: it calculates 2/3 of the free physical memory and tries to allocate that amount. If the allocation succeeds, the cache is held in memory. If the allocation fails, it uses a disk cache of that size.

The CacheFramesFrequency property determines how often frames are saved to the cache.

The CacheDiskLimit and CacheMemoryLimit properties set the maximum size of the cache.

The CacheCompressionType property sets the degree of compression used in the cache.


Restoring Broken Files

BB FlashBack SDK: Base Classes

Restoring Files That Cannot be Opened

It is possible that FBR files can become corrupted in a way that means they cannot be opened by FBPlayer, but can be opened and restored by FBEditor.

To restore an FBR file with FBEditor:

  1. Open it with FBEditor::Load

  2. Save it with FBMovie::SaveAs

  3. Close it with FBMovie::Close

It should now be openable in FBPlayer.


FBPlayer::Autoscroll

BB FlashBack SDK: FBPlayer

Autoscroll

Description

Returns or sets whether the visible display area of the movie will automatically scroll to always keep the recorded mouse pointer location on-screen.

Syntax

[C#/C++]
public Bool Autoscroll

[VB.NET]
Public Autoscroll As Boolean

See Also

Zoom property, Smoothing property, BackgroundText property


FBPlayer::BackgroundColor

BB FlashBack SDK: FBPlayer

BackgroundColor

Description

Defines the background color of the player window - the color that surrounds the movie when it is smaller than the player window.

Syntax

[C#/C++]
public long BackgroundColor

[VB.NET]
Public Property BackgroundColor As Long

Remarks

Colors are specified in a long as a Win32 COLORREF value, which can be created by an RGB macro - see Win32 Platform SDK documentation.


BackgroundText

BB FlashBack SDK: FBPlayer

BackgroundText

Description

Returns or sets text that is shown on the background of the movie display region while no movie is loaded.

Syntax

[C#/C++]
public BSTR BackgroundText

[VB.NET]
Public BackgroundText As String

See Also

Zoom property, Smoothing property, Autoscroll property


BackgroundTextColor

BB FlashBack SDK: FBPlayer

BackgroundTextColor

Description

Defines the color of text in the progress indicators displayed by the SDK and the color of the 'background' text - the text shown in the player window when no movie has yet been loaded.

Syntax

[C#/C++]
public long BackgroundTextColor

[VB.NET]
Public Property BackgroundTextColor As Long

Remarks

Colors are specified in a long as a Win32 COLORREF value, which can be created by an RGB macro - see Win32 Platform SDK documentation.

See also

FBPlayer::BackgroundText


CacheCompressionType

BB FlashBack SDK: FBPlayer

CacheCompressionType

Description

Sets the type of compression used in the image cache.

Syntax

[C#/C++]
public long CacheCompressionType

[VB.NET]
Public Property CacheCompressionType As Long

Remarks

The FBPlayer class keeps a cache of frames that have been decompressed from the movie file, to speed up displaying frames out of sequence. For more details, see About The Player Cache.

The compression types selected by this property are as follows:

Value | Compression type
0 | Run length encoding (RLE).
1 | LZW 'zip' compression.

LZW should give better compression of frames, but will require more processor time to uncompress frames from the cache.

See Also

FBPlayer::CacheCompressionType
  FBPlayer::CacheDiskLimit
  FBPlayer::CacheEnabled
  FBPlayer::CacheFramesFrequency
  FBPlayer::CacheMemoryLimit
  FBPlayer::CacheType


CacheDiskLimit

BB FlashBack SDK: FBPlayer

CacheDiskLimit

Description

Sets the size of the disk cache, in bytes.

Syntax

[C#/C++]
public: long CacheDiskLimit

[VB.NET]
Public Property CacheDiskLimit As Long

Remarks

The FBPlayer class keeps a cache of frames that have been decompressed from the movie file, to speed up displaying frames out of sequence. For more details, see About The Player Cache.

See Also

FBPlayer::CacheCompressionType FBPlayer::CacheDiskLimit FBPlayer::CacheEnabled FBPlayer::CacheFramesFrequency FBPlayer::CacheMemoryLimit FBPlayer::CacheType


FBPlayer::CacheEnabled

BB FlashBack SDK: FBPlayer

CacheEnabled

Description

Determines whether the SDK will use its internal frame cache.

Syntax

[C#/C++]
public: Bool CacheEnabled

[VB.NET]
Public Property CacheEnabled As Boolean

Remarks

The FBPlayer class keeps a cache of frames that have been decompressed from the movie file, to speed up displaying frames out of sequence. For more details, see About The Player Cache.

Setting CacheEnabled to True means FBPlayer will try to set sensible defaults for other cache-related properties. It is not necessary to set these properties manually, unless defaults need to be overridden.

See Also

FBPlayer::CacheCompressionType FBPlayer::CacheDiskLimit FBPlayer::CacheEnabled FBPlayer::CacheFramesFrequency FBPlayer::CacheMemoryLimit FBPlayer::CacheType


CacheFramesFrequency

BB FlashBack SDK: FBPlayer

CacheFramesFrequency

Description

Sets how frequently frames will be stored in the cache by setting the number of pixels that need to change before storing the frame.

Syntax

[C#/C++]
public: long CacheFramesFrequency

[VB.NET]
Public Property CacheFramesFrequency As Long

Remarks

The FBPlayer class keeps a cache of frames that have been decompressed from the movie file, to speed up displaying frames out of sequence. For more details, see About The Player Cache.

How this property is used
Only frames that are 'significant', in that they contain changes from the previously stored frame, are stored in the cache. This property sets the number of pixels that need to change before a frame will be saved to the cache.

Say this value is set to 1,000,000. FBPlayer starts with a changed pixel count of zero. As it renders individual the graphic 'events' that make up frames - the screen changes saved to the FlashBack movie file - it counts the pixels each event changes. Once the count reaches 1,000,000 the full screen image is saved to the cache and the count reset to zero.

The larger this value, the more pixels need to change, and therefore less full-screen images will be stored in the cache.

Smaller values mean more full-screen images will be saved to the cache.

If set to zero, a default is set at 1024x1024x6 = 6921456.

See Also

FBPlayer::CacheCompressionType FBPlayer::CacheDiskLimit FBPlayer::CacheEnabled FBPlayer::CacheFramesFrequency FBPlayer::CacheMemoryLimit FBPlayer::CacheType


CacheMemoryLimit

BB FlashBack SDK: FBPlayer

CacheMemoryLimit

Description

Sets the size of the memory cache, in bytes.

Syntax

[C#/C++]
public: long CacheMemoryLimit

[VB.NET]
Public Property CacheMemoryLimit As Long

Remarks

The FBPlayer class keeps a cache of frames that have been decompressed from the movie file, to speed up displaying frames out of sequence. For more details, see About The Player Cache.

See Also

FBPlayer::CacheCompressionType FBPlayer::CacheDiskLimit FBPlayer::CacheEnabled FBPlayer::CacheFramesFrequency FBPlayer::CacheMemoryLimit FBPlayer::CacheType


FBPlayer::CacheType

BB FlashBack SDK: FBPlayer

CacheType

Description

Sets where the internal frame cache to be used by the SDK will be stored - either in memory or on disk.

Syntax

[C#/C++]
public: long CacheType

[VB.NET]
Public Property CacheType As Long

Remarks

The FlashBack SDK keeps a cache of frames that have been decompressed from the movie file. This cache makes it faster to display frames out of sequence. When the player is required to show a particular frame, it pulls from the cache the frame that is nearest and still before the requested frame, using this as a convenient starting point from which to render the requested frame.

The larger the cache, the smaller the time taken, on average, to render randomly selected frames.

This property determines whether the cache is stored in memory or on the disk, as follows:

Value | Cache type
0 | Default
1 | Memory
2 | Disk

Access to a memory cache will be faster and therefore will give smaller seek times than a disk cache, at a cost of higher memory usage.

The SDK decides the default cache type as follows: it calculates 2/3 of the free physical memory and tries to allocate that amount. If the allocation succeeds, the cache is held in memory. If the allocation fails, it uses a disk cache of that size.

The CacheEnabled property determines whether or not a cache will be used.

See Also

FBPlayer::CacheCompressionType
  FBPlayer::CacheDiskLimit
  FBPlayer::CacheEnabled
  FBPlayer::CacheFramesFrequency
  FBPlayer::CacheMemoryLimit
  FBPlayer::CacheType


FBPlayer::CurrentFrame

BB FlashBack SDK: FBPlayer

CurrentFrame

Description

Returns the current visible frame in the loaded movie.

Syntax

[C#/C++]
public long CurrentFrame

[VB.NET]
Public CurrentFrame As Long

Remarks

Call the LoadFile method to load a movie before reading this property.

See Also

Length property, Frames property, FramesPerSec property, CurrentTime property, LoadFile method, FirstFrame method, LastFrame method, GotoFrame method


FBPlayer::CurrentTime

BB FlashBack SDK: FBPlayer

CurrentTime

Description

Returns the time of the current frame into the movie in milliseconds.

Syntax

[C#/C++]
public long CurrentTime

[VB.NET]
Public CurrentTime As Long

Remarks

Call the LoadFile method to load a movie before reading this property.

See Also

Length property, Frames property, FramesPerSec property, CurrentFrame property, LoadFile method


DisableFullScreenDoubleClick

BB FlashBack SDK: FBPlayer

DisableFullScreenDblClick

Description

FBPlayer can switch to fullscreen mode (where the movie is played back fullscreen and the toolbars hidden) when the movie area is double clicked. This property controls whether a double click switches modes.

By default it is set to True. To enable switch to fullscreen on double click, set it to False.

Syntax

[C#/C++]
public Bool DisableFullScreenDblClick;

[VB.NET]
Public Property DisableFullScreenDblClick As Boolean


DisablePopupMenu

BB FlashBack SDK: FBPlayer

DisablePopupMenu

Description

Disables the right-click popup menu for the FBPlayer component.

Set to false by default.

Syntax

[C#/C++]
public Bool DisablePopupMenu;

[VB.NET]
Public Property DisablePopupMenu As Boolean


FBPlayer::EnableLogging

BB FlashBack SDK: FBPlayer

EnableLogging

Description

Starts logging for this instance of FBPlayer. Its internal code will start to call event handlers on an enabled FBLogs object.

Syntax

[C#/C++]
public Bool EnableLogging

[VB.NET]
Public Property EnableLogging As Boolean

Remarks

To have the FBPlayer class produce an internal log file for troubleshooting purposes, you will first need to create an instance of FBLogs, and enable logging from that object. See Using the FBLogs class for more details.

See also

Using the FBLogs class


FBPlayer::Filename

BB FlashBack SDK: FBPlayer

Filename

Description

Returns or sets the path to the movie file to play.

Syntax

[C#/C++]
public BSTR Filename

[VB.NET]
Public Filename As String

Remarks

To actually load the movie referenced by this property, call the LoadFile method.

See Also

HTTPFilename property, LoadFile method, Play method


FBPlayer::Frames

BB FlashBack SDK: FBPlayer

Frames

Description

Returns the number of frames in the loaded movie.

Syntax

[C#/C++]
public long Frames

[VB.NET]
Public Frames As Long

Remarks

Call the LoadFile method to load a movie before reading this property.

See Also

Length property, FramesPerSec property, CurrentFrame property, CurrentTime property, LoadFile method, FirstFrame method, LastFrame method, GotoFrame method


FBPlayer::FramesPerSec

BB FlashBack SDK: FBPlayer

FramesPerSec

Description

Returns the number of frames per second in the loaded movie.

Syntax

[C#/C++]
public Long FramesPerSec

[VB.NET]
Public FramesPerSec As Long

Remarks

Call the LoadFile method to load a movie before reading this property.

See Also

Length property, Frames property, CurrentFrame property, CurrentTime property, LoadFile method, FirstFrame method, LastFrame method, GotoFrame method


FramesWatched

BB FlashBack SDK: FBPlayer

FramesWatched

Description

Returns the total number of frames played since the movie was opened or since FBPlayer::ResetFramesWatched.

Syntax

[C#/C++]
public long FramesWatched;

[VB.NET]
Public FramesWatched As Long

See Also

FBPlayer::ResetFramesWatched


FullScreen

BB FlashBack SDK: FBPlayer

FullScreen

Description

When FullScreen is set to True, the movie occupies the whole desktop, overwriting the Windows taskbar.

Syntax

[C#/C++]
public Bool FullScreen

[VB.NET]
Public FullScreen As Boolean


HasWebCamVideo

BB FlashBack SDK: FBPlayer

HasWebCamVideo

Description

Indicates whether the current movie includes webcam video.

Syntax

[C#/C++]
public Bool HasWebCamVideo;

[VB.NET]
Public HasWebCamVideo As Boolean

See Also


HideFullscreenButton

BB FlashBack SDK: FBPlayer

HideFullscreenButton

Description

Set this to true to show a Fullscreen toggle button in the Player user interface. The button toggles the Fullscreen state - see the property FBPlayer::FullScreen.

Defaults to true.

Syntax

[C#/C++]
public Bool HideFullscreenButton;

[VB.NET]
Public Property HideFullscreenButton As Boolean

See Also

FBPlayer::FullScreen


HighlightMouseClicks

BB FlashBack SDK: FBPlayer

HighlightMouseClicks

Description

Set this to true to have mouse clicks in the movie highlighted by animating circles.

This property is present to enable users of BB FlashBack SDK Basic edition to change click highlight visibility. Users of the Advanced or Professional editions should use FBMovie::SetCursorHighlightProperties to set a variety of cursor highlight properties.

Syntax

[C#/C++]
public Bool HighlightMouseClicks;

[VB.NET]
Public Property HighlightMouseClicks As Boolean

See Also


HTTPFilename

BB FlashBack SDK: FBPlayer

HTTPFilename

Description

Returns or sets the URL to the movie to play.

Syntax

[C#/C++]
public Bool HTTPFilename

[VB.NET]
Public HTTPFilename As Boolean

Remarks

To actually load the movie referenced by this property, call the LoadFile method.

See Also

Filename property, LoadFile method, Play method


HWND

BB FlashBack SDK: FBPlayer

HWND

Description

Returns the window handle of the player window.

Syntax

[C#/C++]
public HWND HWND

[VB.NET]
Public Property HWND As HWND

See Also


FBPlayer::IsMovieLoaded

BB FlashBack SDK: FBPlayer

IsMovieLoaded

Description

Returns whether a movie is currently loaded in the player.

Syntax

[C#/C++]
public Bool IsMovieLoaded

[VB.NET]
Public IsMovieLoaded As Boolean

See Also

Filename property, HTTPFilename property, LoadFile method


IsToolbarDocked

BB FlashBack SDK: FBPlayer

IsToolbarDocked

Description

Returns or sets the docking state of the player toolbar.

Syntax

[C#/C++]
public Bool IsToolbarDocked

[VB.NET]
Public IsToolbarDocked As Boolean

See Also


IsToolbarVisible

BB FlashBack SDK: FBPlayer

IsToolbarVisible

Description

Returns or sets the visibility state of the player toolbar.

Syntax

[C#/C++]
public Bool IsToolbarVisible

[VB.NET]
Public IsToolbarVisible As Boolean

See Also


FBPlayer::Length

BB FlashBack SDK: FBPlayer

Length

Description

Returns the length of the loaded movie in milliseconds.

Syntax

[C#/C++]
public long Length

[VB.NET]
Public Length As Long

Remarks

Call the LoadFile method to load a movie before reading this property.

See Also

Frames property, FramesPerSec property, CurrentFrame property, CurrentTime property, LoadFile method


Looped

BB FlashBack SDK: FBPlayer

Looped

Description

Returns or sets whether a movie will start playing from the beginning after the end has been reached.

Syntax

[C#/C++]
public Bool Looped

[VB.NET]
Public Looped As Boolean

See Also

Pause property, UnpauseByClick property, Play method


FBPlayer::MarkersCount

BB FlashBack SDK: FBPlayer

MarkersCount

Description

Returns the number of markers in the current movie.

Syntax

[C#/C++]
public long MarkersCount

[VB.NET]
Public MarkersCount As Long

See Also

GetMarkerText method, GotoMarker method, GotoMarkerNum method


FBPlayer::MonitorsCount

BB FlashBack SDK: FBPlayer

MonitorsCount

Description

Returns the number of monitors connected to the PC.

Syntax

[C#/C++]
public long MonitorsCount

[VB.NET]
Public Property MonitorsCount As Long

Remarks

Use GetMonitorInfo and MonitorCount to get information on monitors when setting the 'fullscreen' monitor - the monitor on which the movie plays full screen.

See Also


MovieHeight

BB FlashBack SDK: FBPlayer

MovieHeight

Description

Returns the height of the loaded movie in pixels.

Syntax

[C#/C++]
public long MovieHeight

[VB.NET]
Public MovieHeight As Long

Remarks

Call the LoadFile method to load a movie before reading this property.

See Also

MovieWidth property, LoadFile method


MovieSpeed

BB FlashBack SDK: FBPlayer

MovieSpeed

Description

The speed of the movie. If it is not equal to 1, movie playback is speeded up or slowed down by an appropriate factor.

For example, if MovieSpeed = -2, the movie is played at half speed. If MovieSpeed = 2, the movie is played at double speed.

Non-integer values are permitted.

Syntax

[C#/C++]
public Double MovieSpeed;

[VB.NET]
Public Property MovieSpeed As Single;


MovieWidth

BB FlashBack SDK: FBPlayer

MovieWidth

Description

Returns the width of the loaded movie in pixels.

Syntax

[C#/C++]
public long MovieWidth

[VB.NET]
Public MovieWidth As Long

Remarks

Call the LoadFile method to load a movie before reading this property.

See Also

MovieHeight property, LoadFile method


MuteSound

BB FlashBack SDK: FBPlayer

MuteSound

Description

Enables sound playback to be muted. Set to True to mute sound.

Syntax

[C#/C++]
public Bool MuteSound

[VB.NET]
Public Property MuteSound As Boolean


FBPlayer::Pause

BB FlashBack SDK: FBPlayer

Pause

Description

Returns or sets the paused state of a movie that has already been loaded and is currently playing.

Syntax

[C#/C++]
public Bool Pause

[VB.NET]
Public Pause As Boolean

See Also

Looped property, UnpauseByClick property, Play method


PlaybackSpeed

BB FlashBack SDK: FBPlayer

PlaybackSpeed

Description

Sets the playback speed.

Syntax

[C#/C++]
public: long PlaybackSpeed

[VB.NET]
Public Property PlaybackSpeed As Integer

Remarks

Possible values are:

0 = 100% speed

1 = 50%

2 = 25%

3 = 200%

4 = 400%


PlayPassword

BB FlashBack SDK: FBPlayer

PlayPassword

Description

Sets the password to use when playing back a password protected FBR file.

Syntax

[C#/C++]
public: BSTR PlayPassword

[VB.NET]
Public Property PlayPassword As String

Remarks

For more information about password protecting FBR movie files, see Password Protecting Movie Files.

See also


PopupMenuItems

BB FlashBack SDK: FBPlayer

PopupMenuItems

Description

Returns or sets the popup menu commands available on the player control. The popup menu is displayed when the left mouse button is clicked on the player area.

Syntax

[C#/C++]
public long PopupMenuItems

[VB.NET]
Public PopupMenuItems As Long

Value | Description
0 | No additional popup menu commands.
1 | Display the POPUP_MENU_TOOLBAR command.

Remarks

The menu always contains an About command which cannot be removed. This command displays program and copyright information on the player control.


Smoothing

BB FlashBack SDK: FBPlayer

Smoothing

Description

Returns or sets output smoothing for the movie display. Smoothing has no effect unless a zoom factor has been specified.

Syntax

[C#/C++]
public Bool Smoothing

[VB.NET]
Public Smoothing As Boolean

See Also

Zoom property, Autoscroll property, BackgroundText property


SoundVolume

BB FlashBack SDK: FBPlayer

SoundVolume

Description

Sets the volume of sound playback.

Syntax

[C#/C++]
public long SoundVolume;

[VB.NET]
Public Property SoundVolume As Integer;

Remarks

Must take a value from 0 to 100.


ToolbarColor

BB FlashBack SDK: FBPlayer

ToolbarColor

Description

Returns or sets the color of the player toolbar background.

Syntax

[C#/C++]
public long ToolbarColor

[VB.NET]
Public ToolbarColor As Long

Remarks

Colors are specified in a long as a Win32 COLORREF value, which can be created by an RGB macro - see Win32 Platform SDK documentation.

See Also


ToolbarDisabled

BB FlashBack SDK: FBPlayer

ToolbarDisabled

Description

Enables or disables the Player toolbar.

Syntax

[C#/C++]
public Bool ToolbarDisabled;

[VB.NET]
Public ToolbarDisabled As Boolean

See Also


UnpauseByClick

BB FlashBack SDK: FBPlayer

UnpauseByClick

Description

Returns or sets the ability to resume paused movies by clicking the mouse on the player region.

Syntax

[C#/C++]
public Bool UnpauseByClick

[VB.NET]
Public UnpauseByClick As Boolean

See Also

Pause property, Looped property, Play method


UseGDIOnly

BB FlashBack SDK: FBPlayer

UseGDIOnly

Description

Set to True to have FBPlayer not use DirectX acceleration and only use GDI drawing operations to display the movie. Set to False by default.

Syntax

[C#/C++]
public Bool UseGDIOnly

[VB.NET]
Public Property UseGDIOnly As Boolean


FBPlayer::WebCamVideoPositionX

BB FlashBack SDK: FBPlayer

WebCamVideoPositionX

Description

Returns or sets the X position of the webcam window, when the webcam video mode is 'embedded' - see FBMovie::WebCamVideoMode for more details.

Syntax

[C#/C++]
public long WebCamVideoPositionX;

[VB.NET]
Public WebCamVideoPositionX As Long

See Also


FBPlayer::WebCamVideoPositionY

BB FlashBack SDK: FBPlayer

WebCamVideoPositionY

Description

Returns or sets the X position of the webcam window, when the webcam video mode is 'embedded' - see FBMovie::WebCamVideoMode for more details.

Syntax

[C#/C++]
public long WebCamVideoPositionY;

[VB.NET]
Public WebCamVideoPositionY As Long

See Also


Zoom

BB FlashBack SDK: FBPlayer

Zoom

Description

Returns or sets the zoom factor for the movie display.

Syntax

[C#/C++]
public long Zoom

[VB.NET]
Public Zoom As Long

Value | Description
0 | Scales movie to fit the display window.
25 | Displays movie at 1/4 of original size.
50 | Displays movie at 1/2 of original size.
75 | Displays movie at 3/4 of original size.
100 | Displays movie at original size.

See Also

Smoothing property, Autoscroll property, BackgroundText property


CopyCurrentFrameBitmap

BB FlashBack SDK: FBPlayer

CopyCurrentFrameBitmap

Description

Copies the current frame of the movie to a device context.

Syntax

[C#/C++]
public Bool CopyCurrentFrameBitmap(long hDC)

[VB.NET]
Public Function CopyCurrentFrameBitmap(ByVal hDC As Long) As Boolean

Parameters

hDC - handle of device context into which the frame bitmap should be copied.

Returns

If the bitmap is successfully copied, the method returns True.

If an error occurs on copying, the method returns False.


CreateMarkersList

BB FlashBack SDK: FBPlayer

CreateMarkersList

Description

Creates a list of markers in the movie. You can then use GetMarkersCountInList and GetMarkersInfoFromList to find the names and IDs of markers in the movie.

Syntax

[C#/C++]
public void CreateMarkersList ();

[VB.NET]
Public Sub CreateMarkersList ()

Remarks

Using CreateMarkersList to create a markers list and GetMarkersCountInList and GetMarkerInfoFromList to get marker info instead of MarkersCount and GetMarkerID/Text has performance benefits when the movie contains a large number of markers.

The markers list should be freed up with FreeMarkersList after use.

See Also


FBPlayer::FirstFrame

BB FlashBack SDK: FBPlayer

FirstFrame

Description

Seeks to the first frame of the movie loaded in the player.

Syntax

[C#/C++]
public void FirstFrame()

[VB.NET]
Public Sub FirstFrame

Remarks

The movie must be loaded using the LoadFile method before a seek is attempted.

See Also

LoadFile method, Play method, LastFrame method, GotoFrame method


FBPlayer::FrameWithMarker

BB FlashBack SDK: FBPlayer

FrameWithMarker

Description

Returns a boolean value indicating whether the designated frame contains a marker.

Syntax

[C#/C++]
public Bool FrameWithMarker(int frameNum)

[VB.NET]
Public Function FrameWithMarker(ByVal FrameNum As Integer) As Boolean

Parameters

Parameter | Description
FrameNum | Required. An integer value indicating the frame number to query for marker information.

Remarks

The movie must be loaded using the LoadFile method before a seek is attempted.

See Also

FrameWithPause method, GetFrameMarkerText method, GetMarkerFrameNum method, SetUserPause method, RemoveUserPause method, FrameWithUserPause method, GetFrameUserPauseID method


FBPlayer::FrameWithPause

BB FlashBack SDK: FBPlayer

FrameWithPause

Description

Returns a boolean value indicating whether the designated frame contains a text box or a pause marker.

Syntax

[C#/C++]
public Bool FrameWithPause(int frameNum)

[VB.NET]
Public Function FrameWithPause(ByVal FrameNum As Integer)

Parameters

Parameter | Description
FrameNum | Required. An integer value indicating the frame number to query for pause information.

See Also

FrameWithMarker method, GetFrameMarkerText method, GetMarkerFrameNum method, SetUserPause method, RemoveUserPause method, FrameWithUserPause method, GetFrameUserPauseID method


FBPlayer::FrameWithUserPause

BB FlashBack SDK: FBPlayer

FrameWithUserPause

Description

Returns a boolean value indicating whether the designated frame contains a 'user' pause - a pause created by the SetUserPause method.

Syntax

[C#/C++]
public Bool FrameWithUserPause(int frameNum)

[VB.NET]
Public Function FrameWithUserPause(ByVal FrameNum As Integer) As Boolean

Parameters

Parameter | Description
FrameNum | Required. An integer value indicating the frame number to query for custom pause information.

See Also


FBPlayer::FreeMarkersList

BB FlashBack SDK: FBPlayer

FreeMarkersList

Description

Frees memory used for the markers list created by CreateMarkersList.

Syntax

[C#/C++]
public void FreeMarkersList ();

[VB.NET]
Public Sub FreeMarkersList ()

Remarks

Using CreateMarkersList to create a markers list and GetMarkersCountInList and GetMarkerInfoFromList to get marker info instead of MarkersCount and GetMarkerID/Text has performance benefits when the movie contains a large number of markers.

The markers list should be freed up with FreeMarkersList after use.

See Also


GetFrameMarkerText

BB FlashBack SDK: FBPlayer

GetFrameMarkerText

Description

Returns a string value indicating the text for the indicated marker.

Syntax

[C#/C++]
public string GetFrameMarkerText(int frameNum)

[VB.NET]
Public Function GetFrameMarkerText(ByVal FrameNum As Integer) As String

Parameters

Parameter | Description
FrameNum | Required. An integer value indicating the frame number to query for marker text information.

See Also

FrameWithPause method, FrameWithMarker method, GetMarkerFrameNum method, SetUserPause method, RemoveUserPause method, FrameWithUserPause method, GetFrameUserPauseID method


FBPlayer::GetFrameRealTime

BB FlashBack SDK: FBPlayer

GetFrameRealTime

Description

Returns the 'real time' for a given frame - the local time when the frame was recorded, including the timezone.

Syntax

[C#/C++]
public bool GetFrameRealTime (long framenum, _int64* realtime, long* realtimezone);

[VB.NET]
Public Function GetFrameRealTime (ByVal framenum As Integer, ByRef realtime As Int64, ByRef realtimezone As Integer) As Boolean

Parameters

framenum (in) : the number of the frame for which the realtime will be retrieved.

realtime (out) : a 64 bit integer containing the local time when the frame was recorded, expressed as the number 100 nanosecond intervals since 1st January 1601 - see the FILETIME structure in the Windows SDK.

realtimezone (out) : the difference in minutes between Universal Co-ordinated Time (UTC) and the local time of the PC that recorded the movie, calculated as: difference = UTC - Local Time.

Returns

True if the realtime was found and returned for the frame.

False if framenum < 0, or framenum >= the number of frames in the movie, or there is no realtime information saved in the movie.

See Also

FBPlayer::GotoFrameRealTime


GetFrameUserPauseID

BB FlashBack SDK: FBPlayer

GetFrameUserPauseID

Description

Returns an integer value providing the 'user' pause identifier associated with the designated frame number.

User pauses are created by the SetUserPause method.

Syntax

[C#/C++]
public int GetFrameUserPauseID(int frameNum)

[VB.NET]
Public Function GetFrameUserPauseID(ByVal FrameNum As Integer) As Integer

Parameters

Parameter | Description
FrameNum | Required. An integer value indicating the frame number to query for custom pause information.

See Also


GetFullScreenMonitor

BB FlashBack SDK: FBPlayer

GetFullScreenMonitor

Description

Returns the index of the 'fullscreen' monitor, if one exists. The 'fullscreen' monitor is the monitor on which the movie will playback fullscreen.

Syntax

[C#/C++]
Public void GetFullScreenMonitor (Long *index);

[VB.NET]
public Sub GetFullScreenMonitor (ByRef index as Integer)

Parameters

Index (out): the index of the fullscreen monitor. If there is no 'fullscreen' monitor, this contains the index of the primary monitor.

Remarks

Use GetMonitorInfo and MonitorCount to get information on monitors when setting the 'fullscreen' monitor - the monitor on which the movie plays full screen.

See Also


GetMarkerFrameNum

BB FlashBack SDK: FBPlayer

GetMarkerFrameNum

Description

Returns an integer value indicating the frame number for the marker with the provided index.

Syntax

[C#/C++]
public int GetMarkerFrameNum(int frameNum)

[VB.NET]
Public Function GotoMarker(ByVal FrameNum As Integer) As Integer

Parameters

Parameter | Description
FrameNum | Required. An integer value indicating the marker number to query for frame number information.

See Also

FrameWithPause method, FrameWithMarker method, GetFrameMarkerText method, SetUserPause method, RemoveUserPause method, FrameWithUserPause method, GetFrameUserPauseID method


GetMarkerID

BB FlashBack SDK: FBPlayer

GetMarkerID

Description

Returns the text of the marker with the given ID.

Syntax

[C#/C++]
public long GetMarkerID(long ID)

[VB.NET]
Public Function GetMarkerID(ByVal ID As Long) As Long

Parameters

Parameter | Description
ID | Required. The ID of the required marker.

Remarks

The movie must be loaded using the LoadFile method before a seek is attempted.

See Also


GetMarkerInfoFromList

BB FlashBack SDK: FBPlayer

GetMarkerInfoFromList

Description

Returns info on a marker, given its index in the markers list previously created by CreateMarkersList.

Syntax

[C#/C++]
public void GetMarkerInfoFromList (long index, long *id, long *frame, BSTR* text, Bool* result);

[VB.NET]
Public Sub GetMarkerInfoFromList (ByVal index As Integer, ByRef id As Integer, ByRef frame As Integer, ByRef text As String, ByRef result As Boolean)

Parameters

index (in) : index of the marker in the list.

id (out) : id of the marker.

frame (out) : frame that the marker is in.

text (out) : text label of the marker

result (out) : set to True if successful, False if not.

Remarks

CreateMarkersList must be called before GetMarkerInfoFromList.

The markers list should be freed up with FreeMarkersList after use.

Using CreateMarkersList to create a markers list and GetMarkersCountInList and GetMarkerInfoFromList to get marker info instead of MarkersCount and GetMarkerID/Text has performance benefits when the movie contains a large number of markers.

See Also


GetMarkersCountInList

BB FlashBack SDK: FBPlayer

GetMarkersCountInList

Description

Gets the number of markers in a list previously created by CreateMarkersList.

Syntax

[C#/C++]
public void GetMarkersCountInList (long *count);

[VB.NET]
Public Sub GetMarkersCountInList (ByRef count As Integer)

Parameters

count (out) : the number of markers in the list.

Remarks

CreateMarkersList must be called before GetMarkersCountInList.

The markers list should be freed up with FreeMarkersList after use.

Using CreateMarkersList to create a markers list and GetMarkersCountInList and GetMarkerInfoFromList to get marker info instead of MarkersCount and GetMarkerID/Text has performance benefits when the movie contains a large number of markers.

See Also


GetMarkerText

BB FlashBack SDK: FBPlayer

GetMarkerText

Description

Returns the text of the marker with the given index.

Syntax

[C#/C++]
public string GetMarkerText(int index)

[VB.NET]
Public Function GetMarkerText(ByVal Index As Integer) As String

Parameters

Parameter | Description
Index | Required. Index of the required marker.

Remarks

The movie must be loaded using the LoadFile method before a seek is attempted.

See Also

GotoMarker method, GotoMarkerNum method


FBPlayer::GetMonitorInfoA

BB FlashBack SDK: FBPlayer

GetMonitorInfoA

Description

Returns information on a selected monitor, given its index in the list of monitors detected by Windows.

Syntax

[C#/C++]
Public void GetMonitorInfoA (long index, BSTR *DeviceName , long *flags, long *left, long *top, long *right, long *bottom)

[VB.NET]
public Sub GetMonitorInfoA (ByVal index as Integer, ByRef DeviceName as String, ByRef flags as Integer, ByRef left as Integer, ByRef top as Integer, ByRef right as Integer, ByRef bottom as Integer)

Parameters

Index (in): the index of the monitor

DeviceName (out): specifies the name of the display monitor.

Flags (out): if the monitor is the primary monitor, this parameter will be set to MONITORINFOF_PRIMARY, #defined in Win32 SDK as 0x00000001.

Left, Top, Right, Bottom (out): the position of the monitor within the Windows desktop. Note that if the monitor is not the primary monitor, these can be negative values.

Remarks

Use GetMonitorInfo and MonitorCount to get information on monitors when setting the 'fullscreen' monitor - the monitor on which the movie plays full screen.

See Also


GetMovieLengthFromFile

BB FlashBack SDK: FBPlayer

GetMovieLengthFromFile

Description

Given an FBR movie file, this method returns the length of the movie it contains in milliseconds.

Syntax

[C#/C++]
public Long GetMovieLengthFromFile (BSTR sFileName);

[VB.NET]
Public Function GetMovieLengthFromFile (String sFileName) As Integer

Parameters

sFileName (in) : filename of the FBR movie file


GotoFrame

BB FlashBack SDK: FBPlayer

GotoFrame

Description

Seeks to the numbered frame in the loaded movie.

Syntax

[C#/C++]
public void GotoFrame(int frame)

[VB.NET]
Public Sub GotoFrame(ByVal Frame As Integer)

Parameters

Parameter | Description
Frame | Required. An integer value indicating the frame to seek to.

Remarks

The movie must be loaded using the LoadFile method before a seek is attempted.

See Also


FBPlayer::GotoFrameRealTime

BB FlashBack SDK: FBPlayer

GotoFrameRealTime

Description

Sets the current frame to the frame recorded nearest to but no later than a given time.

FlashBack movies can have realtime data encoded within them. The local time of recording of each frame is known.

Syntax

[C#/C++]
public Bool GotoFrameRealTime (_int64 FrameRealTime);

[VB.NET]
Public Function GotoFrameRealTime (ByVal FrameRealTime As Int64) As Boolean

Parameters

FrameRealTime (in) : the time of the frame you wish to select. This is expressed in 100 nanosecond intervals since 1st Jan 1601 - see the FILETIME structure in the Windows Platform SDK.

Return Values

If the function succeeds, the return value is non-zero.

If the time is before the recording started or there is no realtime data encoded in the movie file, the return value is zero.

If the time is after the recording ended, the last frame of the movie is selected and the return value is non-zero.

Remarks

The frame selected is recorded no later than the time passed in.

See Also

FBPlayer::GetFrameRealTime


GotoMarker

BB FlashBack SDK: FBPlayer

GotoMarker

Description

Sets the current frame of the loaded movie to the desired marker as identified by its text.

Syntax

[C#/C++]
public void GotoMarker(string text)

[VB.NET]
Public Sub GotoMarker(ByVal Text As String)

Parameters

Parameter | Description
Text | Required. A string value indicating the marker text.

Remarks

The movie must be loaded using the LoadFile method before a seek is attempted.

See Also


GotoMarkerID

BB FlashBack SDK: FBPlayer

GotoMarkerID

Description

Sets the current frame in the movie to the desired marker, identified by its ID.

Syntax

[C#/C++]
public Bool GotoMarkerID(long lID)

[VB.NET]
Public Function GotoMarkerID(ByVal lID As Long) As Boolean

Parameters

Parameter | Description
lID | Required. The ID of the marker to move to.

Return Values

Returns 1 if the marker was found and operation was successful, 0 if not.

Remarks

The movie must be loaded using the LoadFile method before a seek is attempted.

See Also


GotoMarkerNum

BB FlashBack SDK: FBPlayer

GotoMarkerNum

Description

Seeks the currently loaded movie to the desired marker as identified by its index.

Syntax

[C#/C++]
public void GotoMarkerNum(int index)

[VB.NET]
Public Sub GotoMarkerNum(ByVal Index As Integer)

Parameters

Parameter | Description
Index | Required. A long integer value indicating the marker index.

Remarks

The movie must be loaded using the LoadFile method before a seek is attempted.

See Also

GotoMarker method, GotoMarkerNum method


LastFrame

BB FlashBack SDK: FBPlayer

LastFrame

Description

Seeks to the last frame of the movie loaded in the player.

Syntax

[C#/C++]
public void LastFrame()

[VB.NET]
Public Sub LastFrame

Remarks

The movie must be loaded using the LoadFile method before a seek is attempted.

See Also

LoadFile method, Play method, FirstFrame method, GotoFrame method


LoadFile

BB FlashBack SDK: FBPlayer

LoadFile

Description

Loads a movie into the player. Returns a boolean value indicating whether the movie was successfully loaded.

Syntax

[C#/C++]
public Bool LoadFile()

[VB.NET]
Public Function LoadFile() As Boolean

Remarks

The LoadFile method loads the movie referenced by the Filename or the HTTPFilename property of the player.
A movie must be loaded before it can be played.

See Also

Filename property, HTTPFilename property, UnloadFile method, Play method


FBPlayer::Play

BB FlashBack SDK: FBPlayer

Play

Description

Begins playing the movie loaded into the player. Returns a boolean value indicating whether the movie has successfully started playing.

Syntax

[C#/C++]
public Bool Play()

[VB.NET]
Public Function Play() As Boolean

Remarks

The movie must be loaded before it can be played. Load movies using the LoadFile method.

See Also

Pause property, LoadFile method, UnloadFile method, Stop method


FBPlayer::RemoveUserPause

BB FlashBack SDK: FBPlayer

RemoveUserPause

Description

Removes the 'user' pause previously set at the requested frame number. User pauses are created by the SetUserPause method.

Syntax

[C#/C++]
public void RemoveUserPause(int frameNum)

[VB.NET]
Public Sub RemoveUserPause(ByVal FrameNum As Integer)

Parameters

Parameter | Description
FrameNum | Required. An integer value identifying the frame number that contains the custom pause to remove.

See Also


FBPlayer::RemoveUserPauses

BB FlashBack SDK: FBPlayer

RemoveUserPauses

Description

Removes all of the 'user' pauses previously created in the movie. User pauses are created by the SetUserPause method.

Syntax

[C#/C++]
public void RemoveUserPauses()

[VB.NET]
Public Sub RemoveUserPauses()

See Also


ResetFramesWatched

BB FlashBack SDK: FBPlayer

ResetFramesWatched

Description

Resets the FBPlayer::FramesWatched property to zero.

Syntax

[C#/C++]
public void ResetFramesWatched()

[VB.NET]
Public Sub ResetFramesWatched()

See Also

FBPlayer::FramesWatched


SetFullScreenMonitor

BB FlashBack SDK: FBPlayer

SetFullScreenMonitor

Description

FBPlayer can play the movie back in fullscreen mode in a secondary monitor, with its toolbars displayed on the primary monitor. The SetFullScreenMonitor property sets the index of the 'fullscreen' monitor.

Syntax

[C#/C++]
Public void SetFullScreenMonitor (long index);

[VB.NET]
public Sub SetFullScreenMonitor (ByVal index as Integer)

Parameters

Index (out): the index of the fullscreen monitor.

Remarks

Use GetMonitorInfo and MonitorCount to get information on monitors when setting the 'fullscreen' monitor.

See Also


SetPlayerWindow

BB FlashBack SDK: FBPlayer

SetPlayerWindow

Description

Sets which window movie playback will be shown in.

Syntax

[C#/C++]
public void SetPlayerWindow (long hWnd)

[VB.NET]
Public Sub SetPlayerWindow (ByVal hWnd As Integer)

Parameters

hWnd : handle of the window in which the movie should be shown.


FBPlayer::SetUserPause

BB FlashBack SDK: FBPlayer

SetUserPause

Description

Sets a custom pause using the provided pause identification number at the requested frame number.

Syntax

[C#/C++]
public void SetUserPause(long frameNum, long pauseID)

[VB.NET]
Public Overridable Sub SetUserPause(ByVal FrameNum As Integer, ByVal PauseID As Integer)

Parameters

Parameter | Description
FrameNum | Required. An integer value indicating the frame number that will contain the custom pause.
PauseID | Required. An integer value providing the pause identification number for the custom pause.

Remarks

Custom pauses are very useful in enabling sophisticated navigation of movies. Below are some example applications of custom pauses:

  • Set a custom pause at the last frame of a movie to be notified that playing is complete.

  • To play a movie between two particular frames, set a custom pause at the ending frame, and when this pause is reached, seek to the starting frame.

Set custom pauses using the SetUserPause method and monitor the OnPause event for notification that it has been reached during playback.

See Also


FBPlayer::Stop

BB FlashBack SDK: FBPlayer

Stop

Description

Stops playing the movie in the player.

Syntax

[C#/C++]
public void Stop()

[VB.NET]
Public Sub Stop

See Also

Pause property, Play method


UnloadFile

BB FlashBack SDK: FBPlayer

UnloadFile

Description

Unloads the loaded movie from the player.

Syntax

[C#/C++]
public void UnloadFile()

[VB.NET]
Public Sub UnloadFile

Remarks

Always accompany each LoadFile call by an UnloadFile call.

See Also

LoadFile method, Play method


UpdateSize

BB FlashBack SDK: FBPlayer

UpdateSize

Description

Informs the FBPlayer object that its size has changed. This should be called when the window containing the FBPlayer display area is resized, forcing the FBPlayer object to resize also.

Syntax

[C#/C++]
public void UpdateSize();

[VB.NET]
Public Sub UpdateSize


OnCurrentFrameChanged

BB FlashBack SDK: FBPlayer

OnCurrentFrameChanged

Description

Event handler called when the current frame changes.

Syntax

[C#/C++]
void OnCurrentFrameChanged (long frame);

[VB.NET]
Public Sub OnCurrentFrameChanged (ByVal frame As Integer)

Parameters

frame - the number of the new current frame

Setting the event handler

[C#]
void OnCurrentFrameChangedHandler(long mouseButton, long X, long Y)
{}

player.OnCurrentFrameChanged += new IFBPlayerEvents_OnCurrentFrameChangedEventHandler(OnCurrentFrameChangedHandler);

[VB]
AddHandler fbPlayer.OnCurrentFrameChanged, AddressOf OnCurrentFrameChangedHandler

[Delphi]
FBPlayer.OnCurrentFrameChanged := OnCurrentFrameChangedHandler;

[C++ Builder]
Player->OnCurrentFrameChanged = OnCurrentFrameChangedHandler;

See Also


OnFrameWithObject

BB FlashBack SDK: FBPlayer

OnFrameWithObject

Description

This event handler is called when playback reaches a frame in which an object (textbox, image, highlight) is first displayed or sound starts playing.

Syntax

[C#/C++]
protected virtual void OnFrameWithObject (int frameNum)

[VB.NET]
Protected Overridable Sub OnFrameWithObject (ByVal frameNum As Integer)

Parameter | Description
FrameNum | The frame of the movie where the action occurs.

Setting the event handler

[C#]
void FrameWithObjectHandler (int frameNum)
{}

player.OnFrameWithObject += new IFBPlayerEvents_OnMouseUpEventHandler(FrameWithObjectHandler);

[VB]
AddHandler fbEditor.OnFrameWithObject, AddressOf FrameWithObjectHandler

[Delphi]
FBEditor.OnFrameWithObject := FrameWithObjectHandler;

[C++ Builder]
Editor->OnFrameWithObject = FrameWithObjectHandler;


OnLoading

BB FlashBack SDK: FBPlayer

OnLoading

Description

This event handler is called to indicate movie loading progress.

Syntax

[C#/C++]
protected virtual void OnLoading(int loaded, int total)

[VB.NET]
Protected Overridable Sub OnLoading(ByVal Loaded As Integer, ByVal Total As Integer)

Parameter | Description
Loaded | The number of movie frames loaded so far.
Total | The number of total frames in the movie.

Remarks

Use this event to display progress indicators while loading lengthy movies.

See Also

OnPause event, LoadFile method, Play method


OnMouseDblClick

BB FlashBack SDK: FBPlayer

OnMouseDblClick

Description

Event handler called when a mouse button is double clicked in the movie playback area.

Syntax

[C#/C++]
void OnMouseDblClick(long mouseButton, long X, long Y);

[VB.NET]
Public Sub OnMouseDblClick (ByVal mouseButton As Integer, ByVal X As Integer, ByVal Y As Integer)

Parameters

mouseButton - 0 = right button, 1 = middle button, 2 = left button

X - the x coordinate of the mouse, relative to the top left corner of the movie playback area.

Y - the y coordinate of the mouse, relative to the top left corner of the movie playback area.

Setting the event handler

[C#]
void OnMouseDblClick (long mouseButton, long X, long Y)
{}

player.OnMouseDblClick += new IFBPlayerEvents_OnMouseDblClickEventHandler(OnMouseDblClickHandler);

[VB]
AddHandler fbPlayer.OnMouseDblClick, AddressOf OnMouseDblClickHandler

[Delphi]
FBPlayer.OnMouseDblClick := OnMouseDblClickHandler;

[C++ Builder]
Player->OnMouseDblClick = OnMouseDblClickHandler;

See Also


OnMouseDown

BB FlashBack SDK: FBPlayer

OnMouseDown

Description

Event handler called when a mouse button is pushed down in the movie playback area.

Syntax

[C#/C++]
void OnMouseDown(long mouseButton, long X, long Y);

[VB.NET]
Public Sub OnMouseDown (ByVal mouseButton As Integer, ByVal X As Integer, ByVal Y As Integer)

Parameters

mouseButton - 0 = right button, 1 = middle button, 2 = left button

X - the x coordinate of the mouse, relative to the top left corner of the movie playback area.

Y - the y coordinate of the mouse, relative to the top left corner of the movie playback area.

Setting the event handler

[C#]
void OnMouseDownHandler (long mouseButton, long X, long Y)
{}

player.OnMouseDown += new IFBPlayerEvents_OnMouseDownEventHandler(OnMouseDownHandler);

[VB]
AddHandler fbPlayer.OnMouseDown, AddressOf OnMouseDownHandler

[Delphi]
FBPlayer.OnMouseDown := OnMouseDownHandler;

[C++ Builder]
Player->OnMouseDown = OnMouseDownHandler;

See Also


OnMouseMove

BB FlashBack SDK: FBPlayer

OnMouseMove

Description

Event handler called when the mouse is moved over the movie playback area.

Syntax

[C#/C++]
void OnMouseMove(long X, long Y);

[VB.NET]
Public Sub OnMouseMove (ByVal X As Long, ByVal Y As Long)

Parameters

X - the x coordinate of the mouse, relative to the top left corner of the movie playback area.

Y - the y coordinate of the mouse, relative to the top left corner of the movie playback area.

Setting the event handler

[C#]
void OnMouseMoveHandler (int X, int Y)
{}

player.OnMouseMove += new IFBPlayerEvents_OnMouseMoveEventHandler(OnMouseMoveHandler);

[VB]
AddHandler fbPlayer.OnMouseMove, AddressOf OnMouseMoveHandler

[Delphi]
FBPlayer.OnMouseMove := OnMouseMoveHandler;

[C++ Builder]
Player->OnMouseMove = OnMouseMoveHandler;

See Also


OnMouseUp

BB FlashBack SDK: FBPlayer

OnMouseUp

Description

Event handler called when a mouse button is released in the movie playback area.

Syntax

[C#/C++]
void OnMouseUp(long mouseButton, long X, long Y);

[VB.NET]
Public Sub OnMouseUp (ByVal mouseButton As Integer, ByVal X As Integer, ByVal Y As Integer)

Parameters

mouseButton - 0 = right button, 1 = middle button, 2 = left button

X - the x coordinate of the mouse, relative to the top left corner of the movie playback area.

Y - the y coordinate of the mouse, relative to the top left corner of the movie playback area.

Setting the event handler

[C#]
void OnMouseUpHandler (long mouseButton, long X, long Y)
{}

player.OnMouseUp += new IFBPlayerEvents_OnMouseUpEventHandler(OnMouseUpHandler);

[VB]
AddHandler fbPlayer.OnMouseUp, AddressOf OnMouseUpHandler

[Delphi]
FBPlayer.OnMouseUp := OnMouseUpHandler;

[C++ Builder]
Player->OnMouseUp = OnMouseUpHandler;

See Also


OnPause

BB FlashBack SDK: FBPlayer

OnPause

Description

This event handler is called when the movie has been paused.

Syntax

[C#/C++]
protected virtual void OnPause(int frameNum)

[VB.NET]
Protected Overridable Sub OnPause(ByVal FrameNum As Integer)

Parameter | Description
FrameNum | The frame of the movie where the pause occurred.

Remarks

The OnPause event can be used in tandem with custom pauses set using the SetUserPause method. This makes advanced movie navigation possible.

For instance, instead of periodically polling the various player properties to determine if a movie has finished playing, set a custom pause at the last frame of the movie, and wait for that marker using the OnPause event.

See Also

OnLoading event, SetUserPause method, LoadFile method, Play> method


The FBEditor Class

This class enables editing operations to be performed on a FlashBack movie.

The first call after construction should be to SetRuntimeLicence to set the runtime licence key, otherwise all subsequent method calls will fail. Following this, the Load method loads a FlashBack movie file, returning a FBMovie object.

The FBEditor class enables addition of images, sounds, text boxes and markers to the movie. It also includes some playback capabilities, so if your application requires some playback and editing features, you may only need to create the FBEditor object rather than both FBEditor and FBPlayer.

The FBMovie class enables frame editing and export operations.

Properties

BackgroundColor
CurrentFrame
CurrentTime
DrawMouseCursor
EnableLogging
Filename
HighlightCursor
HighlightMouseClicks
ImageCacheMode
IsMovieLoaded
IsPaused
IsPlaying
MovieCursorX
MovieCursorY
MovieSize
RuntimeLicence
ShowPauseImage
UndoSpace
UseGDIDrawMode
ZoomPanRectsEnabled

Methods

AppendMovie
CopyCurrentFrame
DisplayKeyLogDialog
ExportEvents
ExportKeyLog
ExportMouseLog
FrameWithUserPause
FreeResources
GetBitmaps
GetDefaultImageProperties
GetDefaultTextboxProperties
GetFrames
GetFrameUserPauseID
GetLicenceInfo
GetMarkers
GetMovieCursor
GetMovieLengthFromFile
GetMovieVersion
GetRuntimeLicence
GetSounds
GetTextBoxes
GetVersion
GetZoomPanObjects
GotoFrame
GotoFrameRealTime
InsertImage
InsertMarker
InsertMovie
InsertSound
InsertTextBox
InsertZoomPan
InsertZoomPanWithDialog
IsMovieInOldFormat
Load
Optimise
Pause
Play
RemoveUserPause
RemoveUserPauses
SetUserPause
SetPlayerWindow
SetPlayerWindow32
SetRuntimeLicence
Stop

Events

GetProgressorCaption
OnClick
OnMouseDown
OnMouseMove
OnMouseUp
OnStop
PauseEvent
PlayEvent
ProgressorEvent
SetProgressorCaption
ShowDialog
ShowMessage
StopEvent


ApplyEffects

BB FlashBack SDK: FBEditor

ApplyEffects

Description

Determines whether any ZoomPan rectangles that have been defined will be applied to the movie displayed by FBEditor, or will be displayed as green rectangles overlaying the movie.

Syntax

[C#/C++]
public Bool ApplyEffects

[VB.NET]
Public Property ApplyEffects As Boolean

Remarks

"Unapplied" effects appear in FBEditor as green rectangles, so you can see the area the effect occupies. Here is a ZoomPan:

When ApplyEffects is set to true, FBEditor displays the results of the effect. In this case the zoomed in area:

The setting of ApplyEffects affects exports. If set to false, zoompan and crop effects will not be displayed in exports.


AutoscrollMode

BB FlashBack SDK: FBEditor

AutoscrollMode

Description

Sets and gets the autoscroll mode for the cropping region. Cropping will only be applied to the movie if UseCroppingAutoscrollRegion is set to true, and a region has been specified using SetCroppingAutoscrollRectangle

Syntax

[C#/C++]
public bool AutoscrollMode

[VB.NET]
Public Property AutoscrollMode As Boolean

Remarks

Possible values are:

None (0) - this means autoscroll is not active. If a crop region has been specified it will be applied without autoscroll. It will not change its position.

Keep mouse exactly in center (1) - the autoscroll region will follow the mouse. It will keep the size set in SetCroppingAutoscrollRectangle, but change its position as the mouse moves.

Keep the mouse visible (6) - the autoscroll region will keep the mouse visible and not let it move right to the edge of the cropping region, but it will change its position less than when it keeps it in the center. This is the generally the most user-friendly setting.

See also

FBEditor::GetCroppingAutoscrollRectangle FBEditor::MakeCroppingPermanent FBEditor::SetCroppingAutoscrollRectangle FBEditor::AutoscrollMode FBEditor::UseCroppingAutoscrollRegion


FBEditor::BackgroundColor

BB FlashBack SDK: FBEditor

BackgroundColor

Description

Defines the background color of the player window - the color that surrounds the movie when it is smaller than the player window.

Syntax

[C#/C++]
public long BackgroundColor

[VB.NET]
Public Property BackgroundColor As Long

Remarks

Colors are specified in a long as a Win32 COLORREF value, which can be created by an RGB macro - see Win32 Platform SDK documentation.


CanExportToQuickTime

BB FlashBack SDK: FBEditor

CanExportToQuickTime

Description

Returns True if the SDK is able to export to QuickTime.

Syntax

[C#/C++]
public Bool CanExportToQuickTime;

[VB.NET]
Public CanExportToQuickTime As Boolean

Remarks

This property effectively checks for installations of Apple QuickTime - the free version or 'Pro'. Version 7 and over are required to be installed to enable export to QuickTime.

See Also


FBEditor::CurrentFrame

BB FlashBack SDK: FBEditor

CurrentFrame

Description

Returns or sets the current frame of the movie.

Syntax

[C#/C++]
public long CurrentFrame

[VB.NET]
Public Property CurrentFrame As Long


FBEditor::CurrentTime

BB FlashBack SDK: FBEditor

CurrentTime

Description

Returns the time of the current frame into the movie, in milliseconds.

Syntax

[C#/C++]
public long CurrentTime

[VB.NET]
Public CurrentTime As Long

Remarks

Call the LoadFile method to load a movie before reading this property.

See Also

Length property, Frames property, FramesPerSec property, CurrentFrame property, LoadFile method


CustomMovieSize

BB FlashBack SDK: FBEditor

CustomMovieSize

Description

Returns or sets the scaling of the movie as it is displayed in the Player window, as a percentage value.

Syntax

[C#/C++]
public long CustomMovieSize;

[VB.NET]
Public Property CustomMovieSize As Integer

Remarks

Setting this property to 25, 50, 75 or 100% also sets FBEditor::MovieSize to the appropriate value. Setting it to anything other than 25, 50, 75 or 100 sets FBEditor::MovieSize to MovieSize_Custom.

See Also

FBEditor::MovieSize


DrawMouseCursor

BB FlashBack SDK: FBEditor

DrawMouseCursor

Description

Set this to False to hide the mouse cursor during movie playback.

Syntax

[C#/C++]
public Bool DrawMouseCursor

[VB.NET]
Public Property DrawMouseCursor As Boolean

Remarks

Set to True by default. Set to False to have FBEditor not display the mouse cursor during playback.


FBEditor::EnableLogging

BB FlashBack SDK: FBEditor

EnableLogging

Description

Starts logging for this instance of FBEditor. Its internal code will start to call event handlers on an enabled FBLogs object.

Syntax

[C#/C++]
public Bool EnableLogging

[VB.NET]
Public Property EnableLogging As Boolean

Remarks

To have the FBEditor class produce an internal log file for troubleshooting purposes, you will first need to create an instance of FBLogs, and enable logging from that object. See Using the FBLogs class for more details.

See also

Using the FBLogs class


FBEditor::Filename

BB FlashBack SDK: FBEditor

Filename

Description

Returns or sets the path of the movie file to edit.

Syntax

[C#/C++]
public BSTR Filename;

[VB.NET]
Public Property Filename as String;

Remarks

To actually load the movie referenced by this property, call the Load method.

See Also

FBEditor::Load


HighlightCursor

BB FlashBack SDK: FBEditor

HighlightCursor

Description

Set this to true to highlight the mouse cursor with a yellow circle.

This property is present for backward compatibility purposes. SDK users should use FBMovie::SetCursorHighlightProperties to set a variety of cursor highlight properties.

Syntax

[C#/C++]
public Bool HighlightCursor;

[VB.NET]
Public Property HighlightCursor As Boolean

See Also


FBEditor::HighlightMouseClicks

BB FlashBack SDK: FBEditor

HighlightMouseClicks

Description

Set this to true to have mouse clicks in the movie highlighted by animating circles.

This property is present for backward compatibility purposes. SDK users should use FBMovie::SetCursorHighlightProperties to set a variety of cursor highlight properties.

Syntax

[C#/C++]
public Bool HighlightMouseClicks;

[VB.NET]
Public Property HighlightMouseClicks As Boolean

See Also


ImageCacheMode

BB FlashBack SDK: FBEditor

ImageCacheMode

Description

Sets how much memory should be used by FBEditor for image caching.

Syntax

[C#/C++]
public: long ImageCacheMode

[VB.NET]
Public Property ImageCacheMode As Long

Remarks

The FlashBack SDK keeps a cache of frames that have been decompressed from the movie file. This cache makes it faster to display frames out of sequence. When the player is required to show a particular frame, it pulls from the cache the frame that is nearest and still before the requested frame, using this as a convenient starting point from which to render the requested frame.

The larger the cache, the smaller the time taken, on average, to render randomly selected frames.

This property determines the size of the cache in memory used by FBEditor.

Value | Cache size
1 | Largest
1 | Medium
2 | Lowest


IsConvertToiPodSupported

BB FlashBack SDK: FBEditor

IsConvertToiPodSupported

Description

Returns True or False depending on whether FBEditor can convert media files to iPod compatible .m4v files via the ConvertQuickTimeToiPod method.

Syntax

[C#/C++]
public Bool IsConvertToiPodSupported;

[VB.NET]
Public Property IsConvertToiPodSupported As Boolean

Remarks

IsConvertToiPodSupported effectively indicates whether QuickTime Pro or version 7.6 or newer of the free edition of QuickTime is installed. These are the versions of QuickTime required to generate iPod compatible files.

See also

FBEditor::ConvertQuickTimeToiPod


FBEditor::IsMovieLoaded

BB FlashBack SDK: FBEditor

IsMovieLoaded

Description

Returns whether a movie is currently loaded.

Syntax

[C#/C++]
public Bool IsMovieLoaded

[VB.NET]
Public IsMovieLoaded As Boolean

See Also


IsPaused

BB FlashBack SDK: FBEditor

IsPaused

Description

Returns True or False depending on whether the movie playback is currently paused or not.

Syntax

[C#/C++]
public Bool IsPaused;

[VB.NET]
Public Property IsPaused As Boolean


IsPlaying

BB FlashBack SDK: FBEditor

IsPlaying

Description

Returns True or False depending on whether the movie is currently playing or not.

Syntax

[C#/C++]
public Bool IsPlaying

[VB.NET]
Public Property IsPlaying As Boolean


MovieCursorX

BB FlashBack SDK: FBEditor

MovieCursorX

Description

Returns the X position of the mouse cursor in the current frame of the loaded movie.

Syntax

[C#/C++]
public long MovieCursorX;

[VB.NET]
Public Property MovieCursorX As Long


MovieCursorY

BB FlashBack SDK: FBEditor

MovieCursorY

Description

Returns the Y position of the mouse cursor in the current frame of the loaded movie.

Syntax

[C#/C++]
public long MovieCursorY;

[VB.NET]
Public Property MovieCursorY As Long


MovieSize

BB FlashBack SDK: FBEditor

MovieSize

Description

Returns or sets the scaling of the movie as it is displayed in the Player window.

Syntax

[C#/C++]
public MovieSizes MovieSize;

[VB.NET]
Public Property MovieSize As MovieSizes

Remarks

MovieSize can be one of these values, defined in the enum MovieSizes:

MovieSize_100 (0) | Displayed at 100% size
MovieSize_75 (1) | Displayed at 75% size
MovieSize_50 (2) | Displayed at 50% size
MovieSize_25 (3) | Displayed at 25% size
MovieSize_Custom (4) | Size has been set by FBEditor::CustomMovieSize to something other than 25, 50, 75 or 100%
MovieSize_FitToWindow (5) | Movie sizes itself to fit into FBPlayer dimensions

Setting MovieSize to 25, 50, 75 or 100% also sets FBEditor::CustomMovieSize accordingly.

See also

FBEditor::CustomMovieSize


FBEditor::RuntimeLicence

BB FlashBack SDK: FBEditor

RuntimeLicence

Description

Sets and gets the 'runtime' licence that licences applications produced using the FlashBack SDK.

Syntax

[C#/C++]
public BSTR RuntimeLicence

[VB.NET]
Public Property RuntimeLicence As String

Remarks

When running applications produced using the SDK on PCs that do not have the SDK installed (i.e. end-user PCs), the runtime licence must be set before any methods are called on an instance of FBEditor. If the runtime licence is not set, all methods will fail.

It should be set to the runtime licence string obtained (via GetRuntimeLicence() or the RuntimeLicence property) from an instance of FBEditor running on a development PC (i.e. a PC with the SDK installed).

See also


ShowPauseImage

BB FlashBack SDK: FBEditor

ShowPauseImage

Description

Set this to True to have a default 'Movie is paused. Click to continue.' image displayed when the movie is paused due to display of a textbox or bitmap.

Syntax

[C#/C++]
public Bool ShowPauseImage;

[VB.NET]
Public Property ShowPauseImage As Boolean


UndoSpace

BB FlashBack SDK: FBEditor

UndoSpace

Description

Gets and Sets the maximum amount of disk space, in bytes, available for undo checkpoints.

Every time an editing operation is performed an undo checkpoint is created to enable rollback of that operation. If the total disk space used by these undo checkpoints exceeds the value specified by UndoSpace, no more checkpoints are created. Previously created checkpoints still exist.

When the file is saved, all checkpoints are discarded, reducing the space they occupy to zero.

Syntax

[C#/C++]
public Long UndoSpace;

[VB.NET]
Public Property UndoSpace As Integer

See also


UseCroppingAutoscrollRegion

BB FlashBack SDK: FBEditor

UseCroppingAutoscrollRegion

Description

Determines whether the cropping region (if one has been specified using SetCroppingAutoscrollRectangle) will be applied to the movie displayed by FBEditor, or will be displayed as a blue frame overlaying the movie.

This setting also determines whether exports will be cropped to the cropping region.

Syntax

[C#/C++]
public Bool UseCroppingAutoscrollRegion

[VB.NET]
Public Property UseCroppingAutoscrollRegion As Boolean

Remarks

An "Unapplied" cropping region appears in FBEditor as a blue frame so you can see the area the effect occupies:

When ApplyEffects is set to true, FBEditor displays the cropped region:

See also


UseGDIDrawMode

BB FlashBack SDK: FBEditor

UseGDIDrawMode

Description

By default, FBEditor uses DirectX to improve playback performance and give smoother scaling when movies are played back at less than their original size.

This use of DirectX means that translucent windows that overlap the movie will flicker while it is playing. If UseGDIDrawMode is set to True, FBEditor will not use DirectX. Scaling of movies will be less smooth, but overlapping translucent windows will not flicker.

Syntax

[C#/C++]
public Bool UseGDIDrawMode

[VB.NET]
Public Property UseGDIDrawMode As Boolean


UseLibavcodec

BB FlashBack SDK: FBEditor

UseLibavcodec

Description

Set this property to True to have the FlashBack SDK use libavcodec for encoding exported FLV files.

Libavcodec encoding gives faster encoding and slightly better quality for the same file size than the 'standard' method.

If the property is set to True, and the libavcodec files have been included in the installation (see Installing the SDK with your application), libavcodec is used for encoding. Otherwise the 'standard' encoding method is used.

Syntax

[C#/C++]
public Bool UseLibavcodec;

[VB.NET]
Public Property UseLibavcodec As Boolean

See also

FBMovie::ExportToFLV


ZoomPanRectsEnabled

BB FlashBack SDK: FBEditor

ZoomPanRectsEnabled

Description

Enables preview of the zoom-pan effect in the FBEditor movie display.

If this property is set to True, the FBEditor movie display shows what the end-user will see when the movie is played or exported.

If this property is set to False, the FBEditor movie display shows any zoom-pan objects in the current frame as a green rectangle, indicating the area that is to be zoomed into.

Syntax

[C#/C++]
public Bool ZoomPanRectsEnabled

[VB.NET]
Public Property ZoomPanRectsEnabled As Boolean

See also


AppendMovie

BB FlashBack SDK: FBEditor

AppendMovie

Description

Appends a FlashBack (.FBR) movie file onto the end of the current movie.

This method is accessible to the Pro and Advanced editions of the SDK only.

Syntax

[C#/C++]
public Bool AppendMovie (BSTR filename);

[VB.NET]
Public Function AppendMovie (ByVal filename As String)

Parameters

filename (in) - name of the FlashBack movie file to append onto the currently open movie.

Return Values

Returns zero if unsuccessful, non-zero if successful.


ConvertQuickTimeToiPod

BB FlashBack SDK: FBEditor

ConvertQuickTimeToiPod

Description

Converts a media file to a format that can be played by an iPod.

Syntax

[C#/C++]
public Bool ConvertQuickTimeToiPod (BSTR sInFile, BSTR sOutFile);

[VB.NET]
Public Function ConvertQuickTimeToiPod (ByVal sInFile As String, ByVal sOutFile As String) As Boolean

Parameters

sInFile : the media file to convert.

sOutFile : The file to create.

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is non-zero.

Remarks

The method accepts as input almost any file that can be played by the QuickTime media player application. This file need not contain a video and audio stream - e.g. it can be an mp3 file.

The converted file will be in the mp4 container format, containing H264 video and AAC audio.

Either QuickTime Pro or version 7.6 or newer of the free version of QuickTime is required to be installed for this method to function correctly. The program can use FBEditor::IsConvertToiPodSupported to check that the correct version of QuickTime is installed.

See also

FBEditor::IsConvertToiPodSupported


CopyCurrentFrame

BB FlashBack SDK: FBEditor

CopyCurrentFrame

Description

Copies a bitmap of the current frame into a device context.

This method is accessible to the Pro and Advanced editions of the SDK only.

Syntax

[C#/C++]
public Bool CopyCurrentFrame (long hDC)

[VB.NET]
Public Function CopyCurrentFrame(ByVal hDC As Long) As Boolean

Return Values

The method returns True is successful, False if not.

Remarks

Set the DrawMouseCursor property to True to have the mouse cursor drawn into the frame, or false to omit it.

The device context should be created as a display device, and a suitable bitmap created and selected into the device context before passing the DC handle to CopyCurrentFrame.

I.e. the C++ code could look something like this:

hdc = CreateDC (TEXT("DISPLAY"),null,null,null);

hbmp = CreateBitmap(...); // suitable size and color format

SelectObject(hdc, hbmp);

Editor->CopyCurrentFrame(hdc);

or this would copy the frame image to a window.

// the window defined by hwnd will receive the image
hdc = GetDC(hwnd);

Editor->CopyCurrentFrame(hdc);


CreateMovie

BB FlashBack SDK: FBEditor

CreateMovie

Description

Creates an empty movie in an FBR file.

Syntax

[C#/C++]
public Bool CreateMovie (BSTR filename, FBCreateMovieParams* createParams);

[VB.NET]
Public Function CreateMovie (String filename, ByRef createParams() As FBCreateMovieParams) As Boolean

Parameters

filename (in) : string containing the name of the new FBR file to create

createParams (in) : pointer to an FBCreateMovieParams structure containing information about the new movie

Remarks

The FBCreateMovieParams structure members:

long FramesPerSecond : greater than or equal to 1

long Width : movie width

long Height : movie height

long BackgroundColor : RGB color

long Length : movie length in ms

String Title : movie title (property not used, leave as blank string)

String Name : author name (property not used, leave as blank string)

String Notes : multi line notes associated with movie (property not used, leave as blank string)


DisplayKeyLogDialog

BB FlashBack SDK: FBEditor

DisplayKeyLogDialog

Description

Shows a dialog that displays key presses recorded in the current movie.

On this dialog are options to show the keypresses in 'raw' or 'sentence' form, search the key presses for a string, show the timestamp for each press or sentence and to 'auto locate' - have FBEditor show the frame corresponding to the keypress or sentence selected in the dialog.

When key presses are displayed in 'sentence' format, they are grouped together into words and lines to make it more human-readable. In 'raw' format, the key presses are shown separately, which is less readable.

Syntax

[C#/C++]
public void DisplayKeyLogDialog ()

[VB.NET]
Public Sub DisplayKeyLogDialog

See Also

FBEditor::ExportKeyLog


DisplayKeyLogDialogExt

BB FlashBack SDK: FBEditor

DisplayKeyLogDialogExt

Description

Shows a dialog that displays key presses recorded in the current movie.

On this dialog are options to show the keypresses in 'raw' or 'sentence' form, search the key presses for a string, show the timestamp for each press or sentence and to 'auto locate' - have FBEditor show the frame corresponding to the keypress or sentence selected in the dialog.

When key presses are displayed in 'sentence' format, they are grouped together into words and lines to make it more human-readable. In 'raw' format, the key presses are shown separately, which is less readable.

Syntax

[C#/C++]
public void DisplayKeyLogDialogExt (long mode)

[VB.NET]
Public Sub DisplayKeyLogDialogExt (ByVal mode As Integer)

Parameters

mode (in) : determines whether the dialog displays key presses in sentence or raw mode.

0 = sentence mode. Key presses are grouped together into words and lines, to make it more easily readable.

1 = raw mode. Each key press is displayed separately.

See Also


DrawCurrentFrame

BB FlashBack SDK: FBEditor

DrawCurrentFrame

Description

Draws a bitmap of the current frame into a device context.

Similar to CopyCurrentFrame, but does not use the DrawMouseCursor property to determine cursor visibility.

This method is accessible to the Pro and Advanced editions of the SDK only.

Syntax

[C#/C++]
public Bool DrawCurrentFrame (long hDC, Bool DrawCursor)

[VB.NET]
Public Function DrawCurrentFrame(ByVal hDC As Long, ByVal DrawCursor As Boolean) As Boolean

Parameters

hDC (in) : handle to device context to draw the frame into

DrawCursor (in) : set to true to draw the cursor, or false to omit the cursor

Return Values

The method returns True is successful, False if not.

Remarks

The device context should be created as a display device, and a suitable bitmap created and selected into the device context before passing the DC handle to DrawCurrentFrame.

I.e. the C++ code could look something like this:

hdc = CreateDC (TEXT("DISPLAY"),null,null,null);

hbmp = CreateBitmap(...); // suitable size and color format

SelectObject(hdc, hbmp);

Editor->DrawCurrentFrame(hdc, True);

or this would copy the frame image to a window.

// the window defined by hwnd will receive the image
hdc = GetDC(hwnd);

Editor->DrawCurrentFrame(hdc, True);


EndBatchOperations

BB FlashBack SDK: FBEditor

EndBatchOperations

Description

Turns on creation of undo checkpoints, and creates a checkpoint, after they have been turned off with StartBatchOperations.

Syntax

[C#/C++]
public void EndBatchOperations ();

[VB.NET]
Public Sub EndBatchOperations ()

See Also

FBEditor::StartBatchOperations


ExportEvents

BB FlashBack SDK: FBEditor

ExportEvents

Description

Exports mouse cursor, keyboard and marker events from a selection of frames to a named XML file.

Syntax

[C#/C++]
public Bool ExportEvents (BSTR filename, long startframe, long endframe, long events)

[VB.NET]
Public Function ExportEvents (ByVal filename As String, ByVal startframe As Integer, ByVal endframe As Integer, ByVal events As Integer ) As Boolean

Parameters

filename (in) - name of the XML file to export to.

startframe (in) - first frame of the sequence for which to export events

endframe (in) - final frame of the sequence for which to export events

events (in) - this parameter filters events exported. The values below should be ORed together to include more than one category of event in the export.

Value | Include this type of event in export
1 | Mouse clicks
2 | Mouse position
4 | Mouse cursor change
8 | Keyboard events
16 | Marker events

Return Values

Returns zero if unsuccessful, non-zero if successful.

Remarks

The types of event exported are:

  • Mouse clicks

  • Mouse position

  • Mouse cursor change

  • Keyboard events

  • Marker events - see The FBMarkers Class for more information on markers.


ExportKeyLog

BB FlashBack SDK: FBEditor

ExportKeyLog

Description

Exports the key press information, recorded at record-time, to an XML file.

Syntax

[C#/C++]
public Bool ExportKeyLog (BSTR sFileName, long mode)

[VB.NET]
Public Function ExportKeyLog (ByVal sFileName As String, ByVal mode As Integer) As Boolean

Parameters

sFileName (in) : the name of the XML file to be created.

mode (in) : takes one of two values.

0 = sentence mode. Key presses are grouped together into words and lines, to make it more easily readable.

1 = raw mode. Each key press is in a separate node.

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is non-zero.

Remarks

The XML created is of this form:

In sentence mode:
<sentence> nodes contain typed text and <virtualkey> nodes contain non-text key presses:

<?xml version="1.0" encoding="UTF-8"?>
<bbkeylog application="BB FlashBack 2 Player" movie="Untitled.fbr">
<sentence timestamp="00:00:08">This is keylog data</sentence>
<virtualkey timestamp="00:00:12">Ret</virtualkey>
<sentence timestamp="00:00:12">And a second line</sentence>
<virtualkey timestamp="00:00:15">Ret</virtualkey>
</bbkeylog>

In raw mode:
<key> nodes contain text key presses and <virtualkey> nodes the non-text key presses:

<?xml version="1.0" encoding="UTF-8"?>
<bbkeylog application="BB FlashBack 2 Player" movie="Untitled.fbr">
<key timestamp="00:00:08">t</key>
<key timestamp="00:00:08">h</key>
<key timestamp="00:00:09">i</key>
<key timestamp="00:00:09">s</key>
<virtualkey timestamp="00:00:09">Spc</virtualkey>
<key timestamp="00:00:09">i</key>
<key timestamp="00:00:09">s</key>
<virtualkey timestamp="00:00:09">Spc</virtualkey>
</bbkeylog>

See Also

FBEditor::DisplayKeyLogDialog


ExportKeyLogExt

BB FlashBack SDK: FBEditor

ExportKeyLogExt

Description

Exports the key press information, recorded at record-time, to an XML or text file in unicode format.

Syntax

[C#/C++]
public Bool ExportKeyLogExt (BSTR sFileName, long mode, bool exportNotes, bool exportKeyLog, long format)

[VB.NET]
Public Function ExportKeyLogExt (ByVal sFileName As String, ByVal mode As Integer, ByVal exportNotes As Boolean, ByVal exportKeyLog As Boolean,ByVal format As Integer) As Boolean

Parameters

sFileName (in) : the name of the XML file to be created.

mode (in) : takes one of two values.

0 = sentence mode. Key presses are grouped together into words and lines, to make it more easily readable.

1 = raw mode. Each key press is in a separate node.

exportNotes (in) : include text in record-time Notes

exportKeyLog (in) : include key presses recorded at record-time

format (in) : this determines whether the exported file is in XML or plain text format and takes one of two values.

0 = text format

1 = XML format

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is non-zero.

Remarks

The XML created is of this form:

In sentence mode:
<sentence> nodes contain typed text and <virtualkey> nodes contain non-text key presses:

<?xml version="1.0" encoding="UTF-8"?>
<bbkeylog application="BB FlashBack 2 Player" movie="Untitled.fbr">
<sentence timestamp="00:00:08">This is keylog data</sentence>
<virtualkey timestamp="00:00:12">Ret</virtualkey>
<sentence timestamp="00:00:12">And a second line</sentence>
<virtualkey timestamp="00:00:15">Ret</virtualkey>
</bbkeylog>

In raw mode:
<key> nodes contain text key presses and <virtualkey> nodes the non-text key presses:

<?xml version="1.0" encoding="UTF-8"?>
<bbkeylog application="BB FlashBack 2 Player" movie="Untitled.fbr">
<key timestamp="00:00:08">t</key>
<key timestamp="00:00:08">h</key>
<key timestamp="00:00:09">i</key>
<key timestamp="00:00:09">s</key>
<virtualkey timestamp="00:00:09">Spc</virtualkey>
<key timestamp="00:00:09">i</key>
<key timestamp="00:00:09">s</key>
<virtualkey timestamp="00:00:09">Spc</virtualkey>
</bbkeylog>

Text format
An example of the data exported in text format:

00:00:04 BB Flashback
00:00:08 Ret
00:00:10 [Note] My note

See Also

FBEditor::DisplayKeyLogDialogExt


ExportMouseLog

BB FlashBack SDK: FBEditor

ExportMouseLog

Description

Exports the cursor events, recorded at record-time, to a text or XML file.

Syntax

[C#/C++]
public Bool ExportMouseLog (BSTR sFileName, long format)

[VB.NET]
Public Function ExportMouseLog (ByVal sFileName As String, ByVal format As Integer) As Boolean

Parameters

sFileName (in) : the name of the text or XML file to be created.

format (in) : takes one of two values.

0 = Text.
An example:

00:00:00 IDCursorShape
00:00:00 IDPosChanged (947, 643)
00:00:00 IDCursorShape
00:00:02 IDPosChanged (493, 1062)
00:00:02 0x0201 at (503, 1069)
00:00:07 IDHidePointer
00:00:09 IDShowPointer
00:00:19 0x0201 at (988, 432)

So the format is: <timestamp> <event type> <cursor position, if included in the event>

There are 5 events types:

IDPosChanged - this includes the X,Y position of the cursor
IDCursorShape
IDHidePointer
IDShowPointer
IDMouseEvent - this is the hex code of the Windows message followed by the cursor position if that data is included in the event. E.g. 0x0201 is WM_LBUTTONDOWN.

1 = XML.
An example:

<?xml version="1.0" encoding="UTF-8"?>
<bbmouselog application="BB FlashBack Pro 5" movie="Untitled156.fbr">
<mouse type="IDCursorShape" timestamp="00:00:00"/>
<mouse type="IDPosChanged" timestamp="00:00:00" position_x="947" position_y="643"/>
<mouse type="IDCursorShape" timestamp="00:00:00"/>
<mouse type="IDMouseEvent" timestamp="00:00:02" message="0x0201" " position_x="503" position_y="1069"/>
<mouse type="IDHidePointer" timestamp="00:00:07"/>
<mouse type="IDShowPointer" timestamp="00:00:09"/>
</bbmouselog>

Event types and extra data are as in the Text example above.

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is non-zero.


FBEditor::FrameWithUserPause

BB FlashBack SDK: FBEditor

FrameWithUserPause

Description

Returns a boolean value indicating whether the designated frame contains a 'user' pause - a pause created by the SetUserPause method.

Syntax

[C#/C++]
public Bool FrameWithUserPause(int frameNum)

[VB.NET]
Public Function FrameWithUserPause(ByVal FrameNum As Integer) As Boolean

Parameters

Parameter | Description
FrameNum | Required. An integer value indicating the frame number to query for custom pause information.

See Also


FBEditor::FreeResources

BB FlashBack SDK: FBEditor

FreeResources

Description

Frees up resources taken by the FBEditor class.

Syntax

[C#/C++]
public void FreeResources ()

[VB.NET]
Public Sub FreeResources

Remarks

This method is for use from managed code environments such as C# or VB.NET, to ensure that an instance of FBEditor releases its resources in a timely fashion. Developers using non-managed code environments like C++ need only delete the pointer to the object - the class destructor will take care of freeing up resources.


GetBitmaps

BB FlashBack SDK: FBEditor

GetBitmaps

Description

Returns, in an FBBitmaps object, a collection of all the bitmaps in the currently open movie.

This method is accessible to the Advanced edition of the SDK only.

Syntax

[C#/C++]
public FBBitmaps* GetBitmaps ()

[VB.NET]
Public Function GetBitmaps() As FBBitmaps

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is a pointer to the FBBitmaps collection.

Remarks

If there are no bitmaps in the movie, the Count property of the returned FBBitmaps collection is set to zero.

See Also

The FBBitmaps Class


GetBlurs

BB FlashBack SDK: FBEditor

GetBlurs

Description

Returns, in an FBBlurs object, a collection of all the blur objects in the currently open movie.

This method is accessible to the Advanced edition of the SDK only.

Syntax

[C#/C++]
public FBBlurs* GetBlurs ()

[VB.NET]
Public Function GetBlurs() As FBBlurs

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is a pointer to the FBBlurs collection.

Remarks

If there are no blurs in the movie, the Count property of the returned FBBlurs collection is set to zero.

See Also

The FBBlurs Class


GetButtons

BB FlashBack SDK: FBEditor

GetButtons

Description

Returns, in an FBButtons object, a collection of all the button objects in the currently open movie.

This method is accessible to the Advanced edition of the SDK only.

Syntax

[C#/C++]
public FBButtons* GetButtons ()

[VB.NET]
Public Function GetButtons() As FBButtons

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is a pointer to the FBButtons collection.

Remarks

If there are no buttons in the movie, the Count property of the returned FBButtons collection is set to zero.

See Also

The FBButtons Class


GetCroppingAutoscrollRectangle

BB FlashBack SDK: FBEditor

GetCroppingAutoscrollRectangle

Description

Gets the cropping rectangle for a particular frame. The position of the rectangle can vary from frame to frame depending on the autoscroll setting defined by FBEditor::AutoscrollMode.

Syntax

[C#/C++]
Public void GetCroppingAutoscrollRectangle (Long lFrame, bool useAutoscroll, bool useAlways, Long* Left, Long* Top, Long* Right, Long* Bottom);

[VB.NET]
public Function GetCroppingAutoscrollRectangle (ByVal lFrame As Integer, ByVal useAutoscroll As Boolean, ByVal useAlways As Boolean, ByRef left As Integer, ByRef top As Integer, ByRef right As Integer, ByRef bottom As Integer)

Parameters

lFrame (in) - the frame to retrieve the cropping region for

useAutoscroll (in) - see the 'Remarks' section below

useAlways (in) - see the 'Remarks' section below

left (out) - X position of the top left corner of the region

top (out) - Y position of the top left corner of the region

right (out) - X position of the bottom right of the record region

bottom (out) - Y position of the bottom right of the record region

Remarks

The region returned from this function varies depending on the useAutoscroll and useAlways parameters and the FBEditor::UseCroppingAutoscrollRegion and FBEditor::AutoscrollMode properties. Here is pseudo code describing the process:

IF (useAlways = true AND FBEditor::UseCroppingAutoscrollRegion = false)
 return the rect for the whole movie

IF (useAutoscroll = false OR FBEditor::AutoscrollMode = None)
 return the rect set by an earlier call to SetCroppingAutoscrollRect

IF (FBEditor::AutoscrollMode = in_center (1))
 return a rect calculated from the mouse position and previously set rect size

If (AutoscrollMode = keep_visible (6))
 return a pre-calculated region that keeps the mouse near the center of the movie

See Also


GetDefaultImageProperties

BB FlashBack SDK: FBEditor

GetDefaultImageProperties

Description

Returns, in an FBBitmapProperties object, the default properties of images in the movie.

Syntax

[C#/C++]
public void GetDefaultImageProperties (FBBitmapProperties* pBitmapProperties)

[VB.NET]
Public Sub GetDefaultImageProperties (ByRef pBitmapProperties() As FBBitmapProperties)

Parameters

pBitmapProperties : pointer to FBBitmapProperties object already created by calling code.

See Also

The FBBitmapProperties Class


GetDefaultTextboxProperties

BB FlashBack SDK: FBEditor

GetDefaultTextboxProperties

Description

Returns, in an FBTextboxProperties object, the default properties of images in the movie.

Syntax

[C#/C++]
public void GetDefaultTextboxProperties (FBTextboxProperties* pTextboxProperties)

[VB.NET]
Public Sub GetDefaultTextboxProperties (ByRef pTextboxProperties() As FBTextboxProperties)

Parameters

pTextboxProperties : pointer to FBTextboxProperties object already created by calling code.

See Also

The FBTextboxProperties Class


GetFrames

BB FlashBack SDK: FBEditor

GetFrames

Description

Returns, in an FBFrames object, a collection of all the frames in the currently open movie.

This method is accessible to the Pro and Advanced editions of the SDK only.

Syntax

[C#/C++]
public FBFrames* GetFrames ()

[VB.NET]
Public Function GetFrames() As FBFrames

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is a pointer to an FBFrames collection.

Remarks

If there are no frames in the movie, the Count property of the returned FBFrames collection is set to zero.

See Also

The FBFrames Class


FBEditor::GetFrameUserPauseID

BB FlashBack SDK: FBEditor

GetFrameUserPauseID

Description

Returns an integer value providing the 'user' pause identifier associated with the designated frame number.

User pauses are created by the SetUserPause method.

Syntax

[C#/C++]
public int GetFrameUserPauseID(int frameNum)

[VB.NET]
Public Function GetFrameUserPauseID(ByVal FrameNum As Integer) As Integer

Parameters

Parameter | Description
FrameNum | Required. An integer value indicating the frame number to query for custom pause information.

See Also


GetHighlights

BB FlashBack SDK: FBEditor

GetHighlights

Description

Returns, in an FBHighlights object, a collection of all the highlight objects in the currently open movie.

This method is accessible to the Advanced edition of the SDK only.

Syntax

[C#/C++]
public FBHighlights* GetHighlights ()

[VB.NET]
Public Function GetHighlights() As FBHighlights

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is a pointer to the FBHighlights collection.

Remarks

If there are no highlights in the movie, the Count property of the returned FBHighlights collection is set to zero.

See Also

The FBHighlights Class


GetLicenceInfo

BB FlashBack SDK: FBEditor

GetLicenceInfo

Description

Returns a value indicating the type and validity of the SDK licence currently in use.

Syntax

[C#/C++]
public Bool GetLicenceInfo (long* pLicenceType)

[VB.NET]
public Function GetLicenceInfo (ByRef pLicenceType() As Long) As Boolean

Parameters

pLicenceType : pointer to a long value that will be set to a value indicating the type of licence.

Return Values

If the licence is invalid, the return value is zero.

If the licence is valid, the return value non-zero.

Remarks

Possible values of pLicenceType:

0 | Basic
1 | Professional
2 | Advanced


GetMarkers

BB FlashBack SDK: FBEditor

GetMarkers

Description

Returns, in an FBMarkers object, a collection of all the markers in the currently open movie.

This method is accessible to the Pro and Advanced editions of the SDK only.

Syntax

[C#/C++]
public FBMarkers* GetMarkers ()

[VB.NET]
Public Function GetMarkers() As FBMarkers

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is a pointer to an FBMarkers collection.

Remarks

If there are no markers in the movie, the Count property of the returned FBMarkers collection is set to zero.

See Also

The FBMarkers Class


GetMovieCursor

BB FlashBack SDK: FBEditor

GetMovieCursor

Description

Returns the position of the mouse cursor in the current frame of the loaded movie.

Syntax

[C#/C++]
public void GetMovieCursor (long* pX, long* pY);

[VB.NET]
Public Sub GetMovieCursor(ByRef pX As Long, ByRef pY As Long)

Parameters

pX - pointer to a long value that will hold the X position of the cursor.

pY - pointer to a long value that will hold the Y position of the cursor.


GetMovieLengthFromFile

BB FlashBack SDK: FBEditor

GetMovieLengthFromFile

Description

Given an FBR movie file, this method returns the length of the movie it contains in milliseconds.

Syntax

[C#/C++]
public Long GetMovieLengthFromFile (BSTR sFileName);

[VB.NET]
Public Function GetMovieLengthFromFile (String sFileName) As Integer

Parameters

sFileName (in) : filename of the FBR movie file


GetMovieVersion

BB FlashBack SDK: FBEditor

GetMovieVersion

Description

Returns the version of the format used in a given FlashBack movie file.

See FlashBack Movie File Format Versions to learn more about FBR file versions and how they relate to SDK versions.

Syntax

[C#/C++]
public long GetMovieVersion ( String sFileName, bool* OldFormat)

[VB.NET]
Public Function GetMovieVersion ( ByVal sFileName As String, ByRef OldFormat As Boolean) As Long

Return Values

If the file is a valid FlashBack movie file, the function returns the version number of the file format.

If the file is not a FlashBack movie file, the function returns zero.

The OldFormat boolean is set to True if the file format is older than that used by this version of the FlashBack SDK (version 2).

See Also


FBEditor::GetRuntimeLicence

BB FlashBack SDK: FBEditor

GetRuntimeLicence

Description

Gets the 'runtime' licence key that must be passed to a call to SetRuntimeLicence on the end-user's PC, in order to fully licence applications that use the FlashBack SDK.

Syntax

[C#/C++]
public String GetRuntimeLicence (void)

[VB.NET]
Public Function GetRuntimeLicence () As String

Return value

When the function succeeds, it returns the runtime licence key string.

Remarks

When running applications produced using the SDK on PCs that do not have the SDK installed (i.e. end-user PCs), the runtime licence must be set before any methods are called on an instance of FBEditor. If the runtime licence is not set, all methods will fail.

It should be set to the runtime licence string obtained (via GetRuntimeLicence() or the RuntimeLicence property) from an instance of FBEditor running on a development PC (i.e. a PC with the SDK installed).

See Also


GetSDKVersion

BB FlashBack SDK: FBEditor

GetSDKVersion

Description

Returns the version of the SDK used to create this instance of FBEditor.

Syntax

[C#/C++]
public BSTR* GetSDKVersion ()

[VB.NET]
Public Function GetSDKVersion() As String

Remarks

The version of the DLL will usually be the same as the version of the SDK read via FBEditor::GetVersion.

They may differ if the version number of the SDK has been advanced, but only some DLLs were changed, and unchanged DLLs did not also advance their version number.

See also

FBEditor::GetVersion


FBEditor::GetSounds

BB FlashBack SDK: FBEditor

GetSounds

Description

Returns, in an FBSounds object, a collection of all the sound tracks in the currently open movie.

This method is accessible to the Pro and Advanced editions of the SDK only.

Syntax

[C#/C++]
public FBSounds* GetSounds ()

[VB.NET]
Public Function GetSounds() As FBSounds

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is a pointer to an FBSounds collection.

Remarks

If there are no sounds in the movie, the Count property of the returned FBSounds collection is set to zero.

The FlashBack SDK can create a number of separate sound tracks in a movie, where each track can contain a number of non-overlapping sound 'clips'. To read more about SDK sound classes, see How the sound classes work.

See Also

The FBSounds Class


FBEditor::GetTextBoxes

BB FlashBack SDK: FBEditor

GetTextBoxes

Description

Returns, in an FBTextBoxes object, a collection of all the textboxes in the currently open movie.

This method is accessible to the Advanced edition of the SDK only.

Syntax

[C#/C++]
public FBTextBoxes* GetTextBoxes ()

[VB.NET]
Public Function GetTextBoxes() As FBTextBoxes

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is a pointer to an FBTextBoxes collection.

Remarks

If there are no text boxes in the movie, the Count property of the returned FBTextBoxes collection is set to zero.

See Also

The FBTextBoxes Class


GetTransitions

BB FlashBack SDK: FBEditor

GetTransitions

Description

Returns, in an FBTransitions object, a collection of all the transition objects in the currently open movie.

This method is accessible to the Advanced edition of the SDK only.

Syntax

[C#/C++]
public FBTransitions* GetTransitions ()

[VB.NET]
Public Function GetTransitions() As FBTransitions

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is a pointer to the FBTransitions collection.

Remarks

If there are no transitions in the movie, the Count property of the returned FBTransitions collection is set to zero.

See Also

The FBTransitions Class


GetVersion

BB FlashBack SDK: FBEditor

GetVersion

Description

Returns the version of the DLL used to create this instance of FBEditor.

Syntax

[C#/C++]
public BSTR* GetVersion ()

[VB.NET]
Public Function GetVersion() As String

Remarks

The version of the DLL will usually be the same as the version of the SDK read via FBEditor::GetSDKVersion. They may differ, if the version number of the SDK has been advanced, but only some DLLs were changed, and unchanged DLLs did not also advance their version number.

See also

FBEditor::GetSDKVersion


GetWatermarks

BB FlashBack SDK: FBEditor

GetWatermarks

Description

Returns, in an FBWatermarks object, a collection of all the watermarks in the movie.

This method is accessible to the Advanced edition of the SDK only.

Syntax

[C#/C++]
public FBWatermarks* GetWatermarks ()

[VB.NET]
Public Sub GetWatermarks As FBWatermarks

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is a pointer to an FBWatermarks collection.

See Also

The FBWatermarks Class


GetZoomPanObjects

BB FlashBack SDK: FBEditor

GetZoomPanObjects

Description

Returns, in an FBZoomPanObjects object, a collection of all the zoom-pan objects in the currently open movie.

This method is accessible to the Pro and Advanced editions of the SDK only.

Syntax

[C#/C++]
public FBZoomPanObjects* GetZoomPanObjects ()

[VB.NET]
Public Function GetZoomPanObjects () As FBZoomPanObjects

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is a pointer to an FBZoomPanObjects collection.

Remarks

If there are no zoom-pan objects in the movie, the Count property of the returned collection is set to zero.

See Also

The FBZoomPanObjects class


GetZoomPanRect

BB FlashBack SDK: FBEditor

GetZoomPanRect

Description

Returns the size and position of any zoompan rectangles added to a given frame.

Syntax

[C#/C++]
public void GetZoomPanRect (long FrameNum, long *X, long *Y, long *Width, long *Height);

[VB.NET]
Public Sub GetZoomPanRect (ByVal FrameNum As Integer, ByRef X As Integer, ByRef Y As Integer, ByRef Width As Integer, ByRef Height As Integer)

Parameters

FrameNum (in) - the number of the frame to retrieve ZoomPan rectangles for

X (out) - X co-ordinate of the top left corner of the ZoomPan rect

Y (out) - Y co-ordinate of the top left corner of the ZoomPan rect

Width (out) - width of the ZoomPan rect

Height (out) - height of the ZoomPan rect

Remarks

If no ZoomPan rectangles have been added to that frame, the returned Height and Width are zero.

See Also

The FBZoomPanObjects class


FBEditor::GotoFrame

BB FlashBack SDK: FBEditor

GotoFrame

Description

Sets the current frame displayed in the movie.

Syntax

[C#/C++]
public Bool GotoFrame (long lFrameNumber)

[VB.NET]
Public Function GotoFrame (ByVal lFrameNumber As Long) As Boolean

Parameters

lFrameNumber : number of frame to set as current.

Return Values

If the frame number is out of range, the return value is zero.

If the function succeeds, the return value is non-zero.


FBEditor::GotoFrameRealTime

BB FlashBack SDK: FBEditor

GotoFrameRealTime

Description

Sets the current frame to the frame recorded nearest to but no later than a given time.

FlashBack movies can have realtime data encoded within them. The local time of recording of each frame is known.

Syntax

[C#/C++]
public Bool GotoFrameRealTime (_int64 FrameRealTime);

[VB.NET]
Public Function GotoFrameRealTime (ByVal FrameRealTime As Int64) As Boolean

Parameters

FrameRealTime (in) : the time of the frame you wish to select. This is expressed in 100 nanosecond intervals since 1st Jan 1601 - see the FILETIME structure in the Windows Platform SDK.

Return Values

If the function succeeds, the return value is non-zero.

If the time is before the recording started or there is no realtime data encoded in the movie file, the return value is zero.

If the time is after the recording ended, the last frame of the movie is selected and the return value is non-zero.

Remarks

The frame selected is recorded no later than the time passed in.

See Also

FBFrames::GetFrameRealTime


InsertHighlight

BB FlashBack SDK: FBEditor

InsertHighlight

Description

Inserts into the current frame of the movie a highlight object with properties defined by the supplied FBHighlightProperties object.

This method is accessible to the Advanced edition of the SDK only.

Syntax

[C#/C++]
public Bool InsertHighlight (FBHighlightProperties* pHighlightProperties)

[VB.NET]
Public Function InsertHighlight (ByRef pHighlightProperties() As FBHighlightProperties) As Boolean

Parameters

pHighlightProperties : [In] Pointer to an FBHighlightProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero. The ID property of the FBHighlightProperties object passed in will be set to the ID of the newly created textbox.

See Also

The FBHighlightProperties Class


InsertImage

BB FlashBack SDK: FBEditor

InsertImage

Description

Inserts into the current frame of the movie an image with properties defined by the supplied FBBitmapProperties object.

This method is accessible to the Advanced edition of the SDK only.

Syntax

[C#/C++]
public Bool InsertImage (FBBitmapProperties* pBitmapProperties)

[VB.NET]
Public Function InsertImage (ByRef pBitmapProperties() As FBBitmapProperties) As Boolean

Parameters

pBitmapProperties : [In] Pointer to an FBBitmapProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero. The ID property of the FBBitmapProperties object passed in will be set to the ID of the newly created bitmap.

Remarks

If the ShowOptions property of the FBBitmapProperties object is set to True, a standard image editing and selection dialog will be displayed, enabling a user to select an image file. Otherwise, the image file specified by the Name property will be inserted with the specified properties.

See Also


InsertImageAtFrame

BB FlashBack SDK: FBEditor

InsertImageAtFrame

Description

Inserts into a given frame of the movie an image with properties defined by the supplied FBBitmapProperties object.

This method is accessible to the Advanced edition of the SDK only.

Syntax

[C#/C++]
public Bool InsertImageAtFrame (long frame, FBBitmapProperties* pBitmapProperties)

[VB.NET]
Public Function InsertImageAtFrame (ByVal frame As Integer, ByRef pBitmapProperties() As FBBitmapProperties) As Boolean

Parameters

frame : [In] number of the frame to insert the image at

pBitmapProperties : [In] Pointer to an FBBitmapProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero. The ID property of the FBBitmapProperties object passed in will be set to the ID of the newly created bitmap.

Remarks

If the ShowOptions property of the FBBitmapProperties object is set to True, a standard image editing and selection dialog will be displayed, enabling a user to select an image file. Otherwise, the image file specified by the Name property will be inserted with the specified properties.

See Also


FBEditor::InsertMarker

BB FlashBack SDK: FBEditor

InsertMarker

Description

Inserts into the current frame of the movie a marker with properties defined by the supplied FBMarkerProperties object.

This method is accessible to the Pro and Advanced editions of the SDK only.

Syntax

[C#/C++]
public Bool InsertMarker (FBMarkerProperties* pMarkerProperties);

[VB.NET]
Public Function InsertMarker (ByRef pMarkerProperties() As FBMarkerProperties) As Boolean

Parameters

pMarkerProperties : Pointer to an FBMarkerProperties object.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero. The ID property of the FBMarkerProperties object passed in will be set to the ID of the newly created marker.

See Also

The FBMarkerProperties Class


InsertMarkerAtFrame

BB FlashBack SDK: FBEditor

InsertMarkerAtFrame

Description

Inserts into a given frame of the movie a marker with properties defined by the supplied FBMarkerProperties object.

This method is accessible to the Pro and Advanced editions of the SDK only.

Syntax

[C#/C++]
public Bool InsertMarkerAtFrame (long frame, FBMarkerProperties* pMarkerProperties);

[VB.NET]
Public Function InsertMarkerAtFrame (ByVal frame As Integer, ByRef pMarkerProperties() As FBMarkerProperties) As Boolean

Parameters

frame : number of the frame to insert the image at

pMarkerProperties : Pointer to an FBMarkerProperties object.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero. The ID property of the FBMarkerProperties object passed in will be set to the ID of the newly created marker.

See Also


InsertMovie

BB FlashBack SDK: FBEditor

InsertMovie

Description

Inserts a FlashBack movie into the currently open movie. The movie is inserted after the frame number passed to the method. So if you passed 100 as the frame number, the inserted movie would start at frame 101 in your current movie.

To insert a movie before frame zero (i.e. to add a movie to the start of your current movie), pass -1 as the frame number.

This method is accessible to the Pro and Advanced editions of the SDK only.

Syntax

[C#/C++]
public long InsertMovie (BSTR sFileName, long lFrameNum);

[VB.NET]
Public Function InsertMovie (ByVal sFileName As String, ByVal lFrameNum As Long) As Long

Parameters

sFileName : String containing filename of the FlashBack movie file to insert.

lFrameNum : the number of the frame at which to insert the movie.

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is non-zero.

Remarks

Regardless of the dimensions of the inserted movie, the current movie maintains its dimensions. The inserted movie is centered within the current movie.

If the inserted movie is larger than the current movie, it is clipped. If the inserted movie is smaller than the current movie, black space is shown, filling the space between the edges of the inserted movie and the current movie.


InsertSound

BB FlashBack SDK: FBEditor

InsertSound

Description

Inserts into the current frame of the movie a sound with properties defined by the supplied FBSoundProperties object.

This method is accessible to the Pro and Advanced editions of the SDK only.

Syntax

[C#/C++]
public Bool InsertSound (FBSoundProperties* pSoundProperties)

[VB.NET]
Public Function InsertSound (ByRef pSoundProperties() As FBSoundProperties) As Boolean

Parameters

pSoundProperties : [In] Pointer to an FBSoundProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero. The ID property of the FBSoundProperties object passed in will be set to the ID of the newly created sound.

Remarks

To insert sounds of an unsupported format:
The BB FlashBack SDK supports WAV, PCM and MP3 sound formats. If you want to insert sounds of an unsupported format, you should:

  1. Be able to play back sound files of that format. i.e. the appropriate DirectShow filter or ACM codec should be installed on your PC.

  2. Use Regsvr32.exe to register the filter bbmemdmpflt.ax, included in the SDK installation folder.

You should then be able to insert sounds in unsupported formats via FBEditor::InsertSound.

See Also

The FBSoundProperties Class


FBEditor::InsertTextBox

BB FlashBack SDK: FBEditor

InsertTextBox

Description

Inserts into the current frame of the movie a text box with properties defined by the supplied FBTextBoxProperties object.

This method is accessible to the Advanced edition of the SDK only.

Syntax

[C#/C++]
public Bool InsertTextBox (FBTextBoxProperties* pTextBoxProperties)

[VB.NET]
Public Function InsertTextBox (ByRef pTextBoxProperties() As FBTextBoxProperties) As Boolean

Parameters

pTextBoxProperties : [In] Pointer to an FBTextBoxProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero. The ID property of the FBTextBoxProperties object passed in will be set to the ID of the newly created textbox.

See Also

The FBTextBoxProperties Class


InsertTransition

BB FlashBack SDK: FBEditor

InsertTransition

Description

Inserts a transition into a specified frame of the movie. Transition occur between the frame at which they are inserted and the frame following, effectively adding time into the movie. Sounds is muted during transitions.

This method is accessible to the Pro and Advanced editions of the SDK only.

Syntax

[C#/C++]
public Bool InsertTransition (long insertAtFrame, FBTransitionProperties* pTransitionProperties)

[VB.NET]
Public Function InsertTransition (ByVal insertAtFrame As Integer, ByRef pTransitionProperties() As FBTransitionProperties) As Boolean

Parameters

insertAtFrame : [in] The frame at which to insert the transition.

pTransitionProperties : [In] Pointer to an FBTransitionProperties object

Return Values

If the function fails, the return value is nonzero. If the function succeeds, the return value is zero.

See Also


InsertVideoFile

BB FlashBack SDK: FBEditor

InsertVideoFile

Description

Inserts a video file at the current frame of the movie.

This method is accessible to the Pro and Advanced editions of the SDK only.

Syntax

[C#/C++]
public long InsertVideoFile (FBInsertVideoFileParameters* pVideoParams)

[VB.NET]
Public Function InsertVideoFile (ByRef pVideoParams As FBInsertVideoFileParameters) As Integer

Parameters

pVideoParams (in) : Pointer to an FBInsertVideoFileParameters object which contains information about the video file and how it is to be inserted. Created by application code previously.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also

The FBInsertVideoFileParameters Class


InsertWatermark

BB FlashBack SDK: FBEditor

InsertWatermark

Description

Inserts into the movie a watermark with properties defined by the supplied FBWatermarkProperties object.

This method is accessible to the Advanced edition of the SDK only.

Syntax

[C#/C++]
public Bool InsertWatermark (FBWatermarkProperties* pWatermarkProperties)

[VB.NET]
Public Function InsertWatermark (ByRef pWatermarkProperties() As FBWatermarkProperties) As Boolean

Parameters

pWatermarkProperties : [In] Pointer to an FBWatermarkProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero. The ID property of the FBWatermarkProperties object passed in will be set to the ID of the new watermark.

See Also

The FBWatermarkProperties Class


InsertZoomPan

BB FlashBack SDK: FBEditor

InsertZoomPan

Description

Inserts a zoom-pan object into a specified frame of the movie.

This method is accessible to the Pro and Advanced editions of the SDK only.

Syntax

[C#/C++]
public Bool InsertZoomPan (Long Frame, FBZoomPanProperties* pZoomPanProperties)

[VB.NET]
Public Function InsertZoomPan (ByVal Frame As Integer, ByRef pZoomPanProperties As FBZoomPanProperties) As Boolean

Parameters

Frame (in) : frame in which to add the zoom-pan object

pZoomPanProperties (in) : Pointer to an FBZoomPanProperties object created by application code previously.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also


InsertZoomPanWithDialog

BB FlashBack SDK: FBEditor

InsertZoomPanWithDialog

Description

Inserts a zoom-pan object into a specified frame of the movie, and displays a dialog on which users can specify the origin, size, and zoom speed of the effect.

This method is accessible to the Pro and Advanced editions of the SDK only.

Syntax

[C#/C++]
public Bool InsertZoomPanwithDialog (Long Frame, FBZoomPanProperties* pZoomPanProperties)

[VB.NET]
Public Function InsertZoomPanWithDialog (ByVal Frame As Integer, ByRef pZoomPanProperties As FBZoomPanProperties) As Boolean

Parameters

Frame (in) : frame in which to add the zoom-pan object

pZoomPanProperties (in) : Pointer to an FBZoomPanProperties object

Remarks

The values displayed in the dialog by default are taken from the FBZoomPanProperties object passed in.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also


IsMovieInOldFormat

BB FlashBack SDK: FBEditor

IsMovieInOldFormat

Description

Determines whether the specified FlashBack movie file (.FBR file) uses an older format than the latest used by version 2.5 of the SDK

See FlashBack Movie File Format Versions to learn more about FBR file formats versions and how they relate to SDK versions.

Syntax

[C#/C++]
public Bool IsMovieInOldFormat (String sFileName)

[VB.NET]
Public Function IsMovieInOldFormat (ByVal sFileName As String) As Boolean

Parameters

sFileName : [In] string containing the file path.

Return Values

Returns True if the file is in an older FBR format than v2.0.

Returns False if the file is FBR v2.0.

Remarks

Older format FBR movies are converted to the new format on loading. FBMovie::SaveAs can be used to save the movie in the new format while retaining the original. You may want to retain the original, because the application that produced it will be unable to work with newer format movies.

FBMovie::SaveAsUsingFormat can be used to save the movie in an older FBR format once loaded into FBEditor.

See Also


Load

BB FlashBack SDK: FBEditor

Load

Description

Loads the specified movie file into the editor, returning a pointer to an FBMovie object.

This method is accessible to the Pro and Advanced editions of the SDK only.

Syntax

[C#/C++]
public FBMovie* Load (String sFileName)

[VB.NET]
Public Function Load (ByVal sFileName As String) As FBMovie

Parameters

sFileName : [In] Filename of the .FBR movie file to load.

Return Values

If the function fails, the return value is a null pointer.

If the function succeeds, the return value is a pointer to a valid FBMovie object.

Remarks

ProgressorEvent events will be generated during movie loading, enabling implementation of a movie loading progress indicator.

See Also


MakeCroppingPermanent

BB FlashBack SDK: FBEditor

MakeCroppingPermanent

Description

Permanently clips the movie to the region specified by SetCroppingAutoscrollRectangle. This will reduce the size of the FBR file.

Syntax

[C#/C++]
public void MakeCroppingPermanent ()

[VB.NET]
Public Sub MakeCroppingPermanent

Remarks

No effect if a cropping rectangle has not been specified

See Also


Optimise

BB FlashBack SDK: FBEditor

Optimise

Description

Optimises the current movie. This is a process that attempts to remove redundant graphics operations from the movie and consolidate others. It should reduce the size of the movie file, and the size of Flash movies exported from it.

Syntax

[C#/C++]
public void Optimise ()

[VB.NET]
Public Sub Optimise


FBEditor::Pause

BB FlashBack SDK: FBEditor

Pause

Description

If movie file is playing, this method pauses playback. If the movie is in the paused state, calling this method resumes playback from the current frame.

Syntax

[C#/C++]
public void Pause ()

[VB.NET]
Public Sub Pause

See Also


FBEditor::Play

BB FlashBack SDK: FBEditor

Play

Description

Starts playback of the currently loaded movie file.

Syntax

[C#/C++]
public void Play ()

[VB.NET]
Public Sub Play

See Also


FBEditor::RemoveUserPause

BB FlashBack SDK: FBEditor

RemoveUserPause

Description

Removes the 'user' pause previously set at the requested frame number. User pauses are created by the SetUserPause method.

Syntax

[C#/C++]
public void RemoveUserPause(int frameNum)

[VB.NET]
Public Sub RemoveUserPause(ByVal FrameNum As Integer)

Parameters

Parameter | Description
FrameNum | Required. An integer value identifying the frame number that contains the custom pause to remove.

See Also


FBEditor::RemoveUserPauses

BB FlashBack SDK: FBEditor

RemoveUserPauses

Description

Removes all of the 'user' pauses previously created in the movie. User pauses are created by the SetUserPause method.

Syntax

[C#/C++]
public void RemoveUserPauses()

[VB.NET]
Public Sub RemoveUserPauses()

See Also


SetCroppingAutoscrollRectangle

BB FlashBack SDK: FBEditor

SetCroppingAutoscrollRectangle

Description

Sets the cropping rectangle.

Syntax

[C#/C++]
Public void SetCroppingAutoscrollRectangle (Long left, Long top, Long right, Long bottom);

[VB.NET]
public Function SetCroppingAutoscrollRectangle (ByVal left As Integer, ByVal top As Integer, ByVal right As Integer, ByVal bottom As Integer)

Parameters

left (in) - X position of the top left corner of the region

top (in) - Y position of the top left corner of the region

right (in) - X position of the bottom right of the record region

bottom (in) - Y position of the bottom right of the record region

Remarks

The cropping region is only applied to the movie if UseCroppingAutoscrollRegion is set to true.

See Also


SetMousePointerVisibility

BB FlashBack SDK: FBEditor

SetMousePointerVisibility

Description

Shows or hides the mouse pointer in a range of frames.

Syntax

[C#/C++]
public void SetMousePointerVisibility (long StartFrame, long EndFrame, Bool Visibility)

[VB.NET]
Public Sub SetMousePointerVisibility (ByVal StartFrame As integer, ByVal EndFrame As integer, ByVal Visibility As Boolean)

Parameters

StartFrame : First frame of the range to set visibility for.

EndFrame : Last frame of the range

Visibility : Visibility of the mouse pointer. Set to False to hide the pointer or True to show it.


SetPlayerWindow

BB FlashBack SDK: FBEditor

SetPlayerWindow

Description

Sets which window movie playback will be shown in.

Syntax

[C#/C++]
public void SetPlayerWindow (int64 hWnd)

[VB.NET]
Public Sub SetPlayerWindow (ByVal hWnd As int64)

Parameters

hWnd : handle of the window in which the movie should be shown.

Remarks

SetPlayerWindow32 performs the same function, but takes a 32 bit long as input parameter.

See also

FBEditor::SetPlayerWindow32


SetPlayerWindow32

BB FlashBack SDK: FBEditor

SetPlayerWindow32

Description

Sets which window movie playback will be shown in.

Syntax

[C#/C++]
public void SetPlayerWindow32 (long hWnd)

[VB.NET]
Public Sub SetPlayerWindow32 (ByVal hWnd As Long)

Parameters

hWnd : handle of the window in which the movie should be shown.

Remarks

SetPlayerWindow performs the same function, but takes a 64 bit long as input parameter.

See also

FBEditor::SetPlayerWindow


FBEditor::SetRuntimeLicence

BB FlashBack SDK: FBEditor

SetRuntimeLicence

Description

Sets the 'runtime' licence that licences applications produced using the FlashBack SDK so they can run on end-user PCs.

Syntax

[C#/C++]
public void SetRuntimeLicence (BSTR sLicence)

[VB.NET]
Public Sub SetRuntimeLicence (ByVal sLicence As String)

Remarks

When running applications produced using the SDK on PCs that do not have the SDK installed (i.e. end-user PCs), the runtime licence must be set before any methods are called or properties accessed on an instance of FBEditor. If the runtime licence is not set, all calls will fail.

It should be set to the runtime licence string obtained from the SDK Licensing utility or via the GetRuntimeLicence method. See Runtime licensing on end-user PCs for details.

Note for Delphi users: Delphi has a limit for string literals of 255 characters. The runtime licence exceeds this limit, so you must break the licence string into two literals. i.e. code like MyEditor.SetRuntimeLicence("abcdef..." + "lmnop...");

See Also


FBEditor::SetUserPause

BB FlashBack SDK: FBEditor

SetUserPause

Description

Sets a custom pause using the provided pause identification number at the requested frame number.

Syntax

[C#/C++]
public: void SetUserPause(long frameNum, long pauseID)

[VB.NET]
Public Overridable Sub SetUserPause(ByVal FrameNum As Integer, ByVal PauseID As Integer)

Parameters

Parameter | Description
FrameNum | Required. An integer value indicating the frame number that will contain the custom pause.
PauseID | Required. An integer value providing the pause identification number for the custom pause.

Remarks

Custom pauses are very useful in enabling sophisticated navigation of movies. Below are some example applications of custom pauses:

  • Set a custom pause at the last frame of a movie to be notified that playing is complete.

  • To play a movie between two particular frames, set a custom pause at the ending frame, and when this pause is reached, seek to the starting frame.

Set custom pauses using the SetUserPause method and monitor the FBEditor::PauseEvent for notification that the pause has been reached.

See Also


StartBatchOperations

BB FlashBack SDK: FBEditor

StartBatchOperations

Description

Turns off creation of undo checkpoints, which may improve performance while editing. By default, an undo checkpoint is created after each edit operation.

To start creating checkpoints again, use the EndBatchOperations method.

Syntax

[C#/C++]
public void StartBatchOperations ();

[VB.NET]
Public Sub StartBatchOperations ()

See Also

FBEditor::EndBatchOperations


FBEditor::Stop

BB FlashBack SDK: FBEditor

Stop

Description

Stops playback of the currently loaded movie file.

Syntax

[C#/C++]
public void Stop ()

[VB.NET]
Public Sub Stop

Remarks

No effect if the movie is not currently playing.

See Also


GetProgressorCaption

BB FlashBack SDK: FBEditor

GetProgressorCaption

Description

This event handler needs to return the current progress window caption, so it can be restored after a sub-operation has changed the caption and completed.

For instance:
AVI exporting (progressor event id=9 - see FBEditor::ProgressorEventEx) has a sub-operation : mixing sounds to one track for inclusion in the AVI (event id = 19).

FBEditor will call SetProgressorCaption at the start of the export to set the caption for the progress dialog to "Exporting to AVI", then call GetProgressorCaption before starting the sound mix operation. It calls SetProgressorCaption again at the start of sound mixing to change the caption to "Mixing sounds" (or similar), and once the sub-operation is complete, restores the progress window caption to whatever was returned from the previous call to GetProgressorCaption.

Syntax

[C#/C++]
public String GetProgressorCaption ()

[VB.NET]
Public Function GetProgressorCaption () As String

Setting the event handler

[C#]
fbEditor.GetProgressorCaption += new IFBEditorEvents_GetProgressorCaptionEventHandler(EditorGetProgressorCaption);

[VB]
AddHandler fbEditor.GetProgressorCaption, AddressOf EditorGetProgressorCaption

[Delphi]
FBEditor.OnGetProgressorCaption := EditorGetProgressorCaption;

[C++ Builder]
Editor->OnGetProgressorCaption = EditorGetProgressorCaption;

See Also


OnClick

BB FlashBack SDK: FBEditor

OnClick

Description

Event handler called when the movie playback area is clicked. It would be called after the OnMouseUp handler, when a click occurs in the movie area.

Syntax

[C#/C++]
public void OnClick (void);

[VB.NET]
Public Sub OnClick

Setting the event handler

[C#]
void OnClickHandler()
{}

editor.OnClick += new IFBEditorEvents_OnClickEventHandler(OnClickHandler);

[VB]
AddHandler fbEditor.OnClick, AddressOf OnClickHandler

[Delphi]
FBEditor.OnClick := OnClickHandler;

[C++ Builder]
Editor->OnClick = OnClickHandler;

See Also


OnMouseDown

BB FlashBack SDK: FBEditor

OnMouseDown

Description

Event handler called when a mouse button is pushed down in the movie playback area of the editor.

Syntax

[C#/C++]
void OnMouseDown(Bool mbLeft, Bool mbRight, Bool mbMiddle, Bool ssShift, Bool ssAlt, Bool ssCtrl, int X, int Y);

[VB.NET]
Public Sub OnMouseDown (ByVal mbLeft As Boolean, ByVal mbRight As Boolean, ByVal mbMiddle As Boolean, ByVal ssShift As Boolean, ByVal ssAlt As Boolean, ByVal ssCtrl As Boolean, ByVal X As Long, ByVal Y As Long)

Parameters

bLeftBtn - set to True when the left button has been pushed.

bRightBtn - set to True when the right button has been pushed.

bMiddleBtn - set to True when the middle button has been pushed.

bShift - set to True if the Shift key is held down.

bAlt - set to True if the Alt key is held down.

bCtrl - set to True if the Ctrl key is held down.

X - the x coordinate of the mouse, relative to the top left corner of the movie playback area.

Y - the y coordinate of the mouse, relative to the top left corner of the movie playback area.

Setting the event handler

[C#]
void OnMouseDownHandler (Bool mbLeft, Bool mbRight, Bool mbMiddle, Bool ssShift, Bool ssAlt, Bool ssCtrl, int X, int Y)
{}

editor.OnMouseDown += new IFBEditorEvents_OnMouseDownEventHandler(OnMouseDownHandler);

[VB]
AddHandler fbEditor.OnMouseDown, AddressOf OnMouseDownHandler

[Delphi]
FBEditor.OnMouseDown := OnMouseDownHandler;

[C++ Builder]
Editor->OnMouseDown = OnMouseDownHandler;

See Also


OnMouseMove

BB FlashBack SDK: FBEditor

OnMouseMove

Description

Event handler called when the mouse is moved over the movie playback area of the editor.

Syntax

[C#/C++]
void OnMouseMove(Bool ssShift, Bool ssAlt, Bool ssCtrl, int X, int Y);

[VB.NET]
Public Sub OnMouseMove (ByVal ssShift As Boolean, ByVal ssAlt As Boolean, ByVal ssCtrl As Boolean, ByVal X As Long, ByVal Y As Long)

Parameters

bShift - set to True if the Shift key is held down.

bAlt - set to True if the Alt key is held down.

bCtrl - set to True if the Ctrl key is held down.

X - the x coordinate of the mouse, relative to the top left corner of the movie playback area.

Y - the y coordinate of the mouse, relative to the top left corner of the movie playback area.

Setting the event handler

[C#]
void OnMouseMoveHandler (Bool ssShift, Bool ssAlt, Bool ssCtrl, int X, int Y)
{}

editor.OnMouseMove += new IFBEditorEvents_OnMouseMoveEventHandler(OnMouseMoveHandler);

[VB]
AddHandler fbEditor.OnMouseMove, AddressOf OnMouseMoveHandler

[Delphi]
FBEditor.OnMouseMove := OnMouseMoveHandler;

[C++ Builder]
Editor->OnMouseMove = OnMouseMoveHandler;

See Also


OnMouseUp

BB FlashBack SDK: FBEditor

OnMouseUp

Description

Event handler called when a mouse button is released in the movie playback area of the editor.

Syntax

[C#/C++]
void OnMouseUp(Bool mbLeft, Bool mbRight, Bool mbMiddle, Bool ssShift, Bool ssAlt, Bool ssCtrl, int X, int Y);

[VB.NET]
Public Sub OnMouseUp (ByVal mbLeft As Boolean, ByVal mbRight As Boolean, ByVal mbMiddle As Boolean, ByVal ssShift As Boolean, ByVal ssAlt As Boolean, ByVal ssCtrl As Boolean, ByVal X As Long, ByVal Y As Long)

Parameters

bLeftBtn - set to True when the left button has been pushed.

bRightBtn - set to True when the right button has been pushed.

bMiddleBtn - set to True when the middle button has been pushed.

bShift - set to True if the Shift key is held down.

bAlt - set to True if the Alt key is held down.

bCtrl - set to True if the Ctrl key is held down.

X - the x coordinate of the mouse, relative to the top left corner of the movie playback area.

Y - the y coordinate of the mouse, relative to the top left corner of the movie playback area.

Setting the event handler

[C#]
void OnMouseUpHandler (Bool mbLeft, Bool mbRight, Bool mbMiddle, Bool ssShift, Bool ssAlt, Bool ssCtrl, int X, int Y)
{}

editor.OnMouseUp += new IFBEditorEvents_OnMouseUpEventHandler(OnMouseUpHandler);

[VB]
AddHandler fbEditor.OnMouseUp, AddressOf OnMouseUpHandler

[Delphi]
FBEditor.OnMouseUp := OnMouseUpHandler;

[C++ Builder]
Editor->OnMouseUp = OnMouseUpHandler;

See Also


StopEvent

BB FlashBack SDK: FBEditor

OnStop

Description

Event handler called when movie stops playback.

Syntax

[C#/C++]
public void OnStop (Bool EndOfMovie);

[VB.NET]
Public Sub OnStop (ByVal EndOfMovie As Boolean)

Parameters

EndOfMovie - set to True if the end of the movie has been reached. Set to False if playback has stopped for another reason.

Setting the event handler

[C#]
fbEditor.OnStop += new IFBEditorEvents_OnStopEventHandler(MyOnStopHandler);

[VB]
AddHandler fbEditor.OnStop, AddressOf MyOnStopHandler

[Delphi]
FBEditor.OnStopEvent := MyOnStopHandler;

[C++ Builder]
Editor->OnStopEvent = MyOnStopHandler;

See Also


PauseEvent

BB FlashBack SDK: FBEditor

PauseEvent

Description

Event handler called when movie is paused.

Syntax

[C#/C++]
public void PauseEvent (Bool *DoPause);

[VB.NET]
Public Sub PauseEvent (ByRef DoPause As Boolean)

Parameters

DoPause - pointer to value that is set to determine of the movie is paused. Set to True to pause the movie, False to have the movie continue to play.

Setting the event handler

[C#]
fbEditor.PauseEvent += new IFBEditorEvents_PauseEventEventHandler(EditorPauseEvent);

[VB]
AddHandler fbEditor.PauseEvent, AddressOf EditorPauseEvent

[Delphi]
FBEditor.OnPauseEvent := EditorPauseEvent;

[C++ Builder]
Editor->OnPauseEvent = EditorPauseEvent;

See Also


PlayEvent

BB FlashBack SDK: FBEditor

PlayEvent

Description

Event handler called during movie play back. It is called once for each frame drawn by the SDK code.

Syntax

[C#/C++]
public void PlayEvent (long Current, long Count)

[VB.NET]
public Sub PlayEvent (ByVal Current As Long, ByVal Count As Long)

Parameters

Current - the number of the frame that has just been drawn.

Count - the total number of frames in the movie.

Setting the event handler

[C#]
fbEditor.PlayEvent += new IFBEditorEvents_PlayEventEventHandler(EditorPlayEvent);

[VB]
AddHandler fbEditor.PlayEvent, AddressOf EditorPlayEvent

[Delphi]
FBEditor.OnPlayEvent := EditorPlayEvent;

[C++ Builder]
Editor->OnPlayEvent = EditorPlayEvent;

See Also


ProgressorEvent

BB FlashBack SDK: FBEditor

ProgressorEvent

Description

This event handler is called as an export or movie loading process progresses.

Note that this event is deprecated in favour of FBEditor::ProgressorEventEx which passes a value into the event handler indicating the event origin.

Syntax

[C#/C++]
public void ProgressorEvent (long Count, long Current, Bool* bStop)

[VB.NET]
Public Sub ProgressorEvent (ByVal Count As Long, ByVal Current As Long, ByRef bStop As Boolean)

Parameters

Count - the total number of steps in the process. The event handler may not be called for every step in the process.

Current - the number of the current stage.

bStop - set this to True to stop the process.

Remarks

The ProgressorEvent event handler is called from all exports, and movie loading.

Setting the event handler

[C#]
fbEditor.ProgressorEvent += new IFBEditorEvents_ProgressorEventEventHandler(EditorProgressorEvent);

[VB]
AddHandler fbEditor.ProgressorEvent, AddressOf EditorProgressorEvent

[Delphi]
FBEditor.OnProgressorEvent := EditorProgressorEvent;

[C++ Builder]
Editor->OnProgressorEvent = EditorProgressorEvent;

See Also


FBEditor::ProgressorEventEx

BB FlashBack SDK: FBEditor

ProgressorEventEx

Description

This event handler is called as an export, import, edit operation or movie loading process progresses.

It replaces FBEditor::ProgressorEvent, which is kept for backward compatibility. It differs from the ProgressorEvent event in that it receives a parameter identifying the event source.

Syntax

[C#/C++]
public void ProgressorEventEx (long Count, long Current, Bool* bStop, ProgressorEventId Id)

[VB.NET]
Public Sub ProgressorEventEx (ByVal Count As Long, ByVal Current As Long, ByRef bStop As Boolean, ByVal Id As ProgressorEventId)

Parameters

Count - the total number of steps in the process. The event handler may not be called for every step in the process.

Current - the number of the current stage.

bStop - set this to True to stop the process.

Id - a value identifying the source of the progressor events. Values and corresponding sources are:

Undefined = 0,

Converting FBR to new format = 1,

Loading movie = 2,

Preparing sound mix during FLV or FBR import = 3,

Deleting frames = 4,

Cropping frames = 5,

Changing FPS = 6,

Importing FLV = 7,

Exporting WebCam video to FLV = 8,

Exporting to AVI = 9,

Exporting to WMV = 10,

Searching for duplicate images during an export = 11,

Exporting to Flash = 12,

Exporting to Exe = 13,

Clipping movie permanently = 14,

Inserting FBR Movie = 15,

Optimizing movie = 16,

Smoothing cursor movements = 17,

Mixing sounds for exporting WebCam to FLV = 18,

Mixing sounds for exporting to AVI = 19,

Mixing sounds for exporting to WMV = 20,

Mixing sounds for exporting to Flash = 21,

Converting sound to internal format during delete frames operation = 22,

Exporting sound track to file = 23,

Moving position of sound clip = 24,

Merging sound tracks = 25,

Pasting sound = 26,

Resyncing sounds = 27,

Initializing objects, during delete sound operation = 28

Remarks

The ProgressorEventEx event handler is called from all exports, FLV and FBR import, edit operations and movie loading.

Setting the event handler

[C#]
fbEditor.ProgressorEventEx += new IFBEditorEvents_ProgressorEventExEventHandler(EditorProgressorEventEx);

[VB]
AddHandler fbEditor.ProgressorEventEx, AddressOf EditorProgressorEventEx

[Delphi]
FBEditor.OnProgressorEventEx := EditorProgressorEventEx;

[C++ Builder]
Editor->OnProgressorEventEx = EditorProgressorEventEx;

See Also


SetProgressorCaption

BB FlashBack SDK: FBEditor

SetProgressorCaption

Description

Event handler called at the start of a process, to pass the name of the process, such as 'Exporting to SWF'. This caption can be used in any progress dialog displayed.

Syntax

[C#/C++]
public void SetProgressorCaption (String sCaption)

[VB.NET]
Public Sub SetProgressorCaption (ByVal sCaption As String)

Parameters

sCaption - the name of the process.

Setting the event handler

[C#]
fbEditor.SetProgressorCaption += new IFBEditorEvents_SetProgressorCaptionEventHandler(EditorSetProgressorCaption);

[VB]
AddHandler fbEditor.SetProgressorCaption, AddressOf EditorSetProgressorCaption

[Delphi]
FBEditor.OnSetProgressorCaption := EditorSetProgressorCaption;

[C++ Builder]
Editor->OnSetProgressorCaption = EditorSetProgressorCaption;

See Also


ShowDialog

BB FlashBack SDK: FBEditor

ShowDialog

Description

Event handler called when a dialog is shown.

Syntax

[C#/C++]
public Long *ShowDialog(BSTR Title, BSTR Text, BSTR CheckBoxText, Long Options, Bool *DontAskChecked, Bool StayOnTop);

[VB.NET]
Public Function ShowDialog(ByVal Title As String, ByVal Text As String, ByVal CheckBoxText As String, ByVal Options As Integer, ByRef DontAskChecked As Boolean, ByVal StayOnTop As Boolean) ByRef As Integer;

Parameters

Title - text shown in the title bar of the dialog.

Text - text shown in the main body of the dialog.

CheckBoxText - the label of the checkbox displayed under the main text. Usually the label is something like "Don't show this message next time.".

Options - defines the buttons and icons to be displayed on the dialog. As used by the Win32 API call MessageBox.

DontAskChecked - event handling code can set this to True to not have this box displayed in the same situation next time.

StayOnTop - set to True if the dialog is of type Stay-on-top.

Return Value

Return a value indicating which button was pushed, containing values as returned from the Win32 API call MessageBox.

Setting the event handler

[C#]
Long * MyShowDialog(BSTR Title, BSTR Text, BSTR CheckBoxText, Long Options, Bool* DontAskChecked, Bool StayOnTop);
{}

editor.ShowDialog += new IFBEditorEvents_ShowDialogEventHandler(MyShowDialog);

[VB]
AddHandler fbEditor.ShowDialog, AddressOf MyShowDialog

[Delphi]
FBEditor.OnShowDialog := MyShowDialog;

[C++ Builder]
Editor->OnShowDialog = MyShowDialog;

See Also


ShowMessage

BB FlashBack SDK: FBEditor

ShowMessage

Description

This event handler is called whenever the FlashBack SDK code wants to display a message to the user.

Syntax

[C#/C++]
public void ShowMessage (String sText, String sCaption, long lType, long* lResult);

[VB.NET]
Public Sub ShowMessage (ByVal sText As String, ByVal sCaption As String, ByVal lType As Long, ByRef lResult As Long)

Parameters

sText - the text to display in the message box.

sCaption - the title of the message box.

lType - the flags used to set the buttons and icons displayed on the message box. These are as defined for the Win32 MessageBox API.

lResult - on function return this holds a value dependant on the button clicked by the user. It uses the same values used by the Win32 MessageBox API.

Remarks

This event is provided so that further action can be taken when a message is displayed, or a customised message dialog be shown. The parameters passed to this event handler can simply be passed onto the MessageBox API.

Setting the event handler

[C#]
fbEditor.ShowMessage += new IFBEditorEvents_ShowMessageEventHandler(EditorShowMessage);

[VB]
AddHandler fbEditor.ShowMessage, AddressOf EditorShowMessage

[Delphi]
FBEditor.OnShowMessage := EditorShowMessage;

[C++ Builder]
Editor->OnShowMessage = EditorShowMessage;

See Also


StopEvent

BB FlashBack SDK: FBEditor

StopEvent

This method has been deprecated - use the OnStop event.


The FBMovie Class

Enables access to frame editing, movie file saving and export functions.

Returned from

FBEditor::Load

Methods

Close
DeleteFrames
ExportFramesToAVI
ExportFramesToFLV
ExportFramesToSWF
ExportFramesToWMV
ExportToAVI
ExportToEXE
ExportToFLV
ExportToSWF
ExportToWMV
GetDefaultAVIParams
GetDefaultEXEParams
GetDefaultFLVParams
GetDefaultSWFParams
GetDefaultWMVParams
InsertFrames
Save
SaveAs
SaveAsUsingFormat
SaveFramesAsNewMovie

Parameters


CheckFLVEncoding

BB FlashBack SDK: FBMovie

CheckFLVMethod

Description

Returns a value indicating whether FLV exports will use libavcodec or 'standard' encoding. Libavcodec encoding is faster than 'standard' encoding and provides higher quality at the same file size.

Set libavcodec or standard encoding via the FBEditor::UseLibavcodec property.

This method is accessible to the Advanced edition of the SDK only.

Syntax

[C#/C++]
public long CheckFLVMethod ();

[VB.NET]
Public Function CheckFLVMethod () As long

Return Values

If the SDK is using standard encoding, the return value is zero.

If the SDK is using libavcodec, return value is 1.

See Also


FBMovie::Close

BB FlashBack SDK: FBMovie

Close

Description

Closes the movie. All subsequent accessing of methods and properties will fail.

Syntax

[C#/C++]
public Bool Close ()

[VB.NET]
Public Function Close () As Boolean

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is non-zero.


DeleteFrames

BB FlashBack SDK: FBMovie

DeleteFrames

Description

Deletes a range of frames from the movie.

Syntax

[C#/C++]
public Bool DeleteFrames (long lStartFrame, long lNumberOfFrames)

[VB.NET]
Public Function DeleteFrames (ByVal lStartFrame As Long, ByVal lNumberOfFrames As Long) as Boolean

Parameters

lStartFrame : the frame at which to start deletion

lNumberOfFrames : the number of frames to delete, starting at lStartFrame.

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is non-zero.

Remarks

If the specified range of frames goes beyond the end of the movie, all frames up to movie end will be deleted.

See Also

FBMovie::InsertFrames


DeleteFramesAndSound

BB FlashBack SDK: FBMovie

DeleteFramesAndSound

Description

Deletes a range of frames from the movie and also any sound in those frames.

Syntax

[C#/C++]
public Bool DeleteFrames (long lStartFrame, long lNumberOfFrames)

[VB.NET]
Public Function DeleteFrames (ByVal lStartFrame As Long, ByVal lNumberOfFrames As Long) as Boolean

Parameters

lStartFrame : the frame at which to start deletion

lNumberOfFrames : the number of frames to delete, starting at lStartFrame.

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is non-zero.

Remarks

If the specified range of frames goes beyond the end of the movie, all frames up to movie end will be deleted.

See Also

FBMovie::InsertFrames


DisplayCursorHighlightDialog

BB FlashBack SDK: FBMovie

DisplayCursorHighlightDialog

Description

Shows the standard dialog used for setting cursor highlight properties, as seen in the BB FlashBack product.

The dialog allows setting of:

  • Highlight mouse clicks

  • Highlight mouse cursor with a circle

  • Color, width and opacity of the highlight circle

  • Color, width and opacity of the border around the highlight circle

Use GetCursorHighlightProps to get the current cursor highlight properties.

See The FBCursorHighlightProps class for details of the cursor highlight properties.

Syntax

[C#/C++]
public void DisplayCursorHighlightDialog ();

[VB.NET]
Public Sub DisplayCursorHighlightDialog

See Also


ExportFramesSequencesToSWF

BB FlashBack SDK: FBMovie

ExportFramesSequencesToSWF

Description

Exports a number of sequences of frames to Flash (SWF) file format, with a specified filename and parameters.

The sequences are combined into one SWF movie.

Syntax

[C#/C++]
public Boolean ExportFramesSequencesToSWF (BSTR Filename, IFBExportToSWFParams* ExportParams, VARIANT FramesSequences, long SequencesCount);

[VB.NET]
Public Function ExportFramesSequencesToSWF (ByVal Filename As String, ByRef ExportParams As FBExportToSWFParams, ByRef FramesSequences As Object, ByVal SequencesCount As Long) As Boolean

Parameters

Filename : the name of the SWF file to be created.

ExportParams : pointer to an FBExportToSWFParams object that contains the parameters to be used in the export process. It should not be null.

FramesSequences : pointer to an array of 4-byte integers. The array contains pairs of values defining the start frame and number of frames to be exported.

SequencesCount: the number of pairs of integers in FramesSequence. It must be larger than zero.

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is non-zero.

Example code

C# example:

int[] frames = new int[4];

frames[0] = 0; //start frame of first sequence
frames[1] = 81; //frames count of first sequence
frames[2] = 143; //start frame of the second sequence
frames[3] = 52; //frames count of the second sequence

FBExportToSWFParamsClass fbExportParams = new FBExportToSWFParamsClass();

fbExportParams.ShowOptions = true;

fbMovie.GetDefaultSWFParams(fbExportParams);

fbMovie.ExportFramesSequencesToSWF("c:\\test.swf", fbExportParams, frames, 2);

//'2' is the number of frames sequences

Remarks

Two or three files are created - one or two SWF files and one HTML file. See About BB FlashBack SDK Flash Exports for details on single and multiple SWF exports.

The HTML file is a page that displays the SWF movie as an embedded object. If a value of "mymovie.swf" is passed in as the FileName parameter, the files would be named "mymovie.swf", "mymovie.html" and (optionally, if multiple SWFs are exported) "mymovie_toolbar.swf".

If the ShowOptions parameter of the export parameters object is set to True, a dialog will be displayed that enables the user to change export parameters. If ShowOptions is set to False, the export takes place using the parameters specified in the export parameters object.

ProgressorEventEx events will be generated on the FBEditor object while the export process runs, enabling implementation of a progress indicator. Set the Stop parameter on progressor events to stop the export.

See Also


ExportFramesToAVI

BB FlashBack SDK: FBMovie

ExportFramesToAVI

Description

Exports selected frames to AVI format, with a specified filename and parameters.

This method is accessible to the Advanced edition of the SDK only.

Syntax

[C#/C++]
public Bool ExportFramesToAVI (String sFileName, FBExportToAVIParams *pExportParams, long StartFrame, long EndFrame)

[VB.NET]
Public Function ExportFramesToAVI (ByVal sFileName As String, ByRef pExportParams() As FBExportToAVIParams, ByVal StartFrame As Long, ByVal EndFrame As Long) As Boolean

Parameters

sFileName : the name of the AVI file to be created.

pExportParams : pointer to an FBExportToAVIParams object that contains the parameters to be used in the export process.

StartFrame, EndFrame : the start and end frames of the sequence to be exported.

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is non-zero.

Remarks

If the ShowOptions parameter of the export parameters object is set to True, a dialog will be displayed that enables the user to change export parameters. If ShowOptions is set to False, the export takes place using the parameters specified in the export parameters object.

ProgressorEventEx events will be generated on the FBEditor object while the export process runs, enabling implementation of a progress indicator. Set the Stop parameter on progressor events to stop the export.

See Also


ExportFramesToFLV

BB FlashBack SDK: FBMovie

ExportFramesToFLV

Description

Exports selected frames to Flash Video (FLV) format, with a specified filename and parameters.

Syntax

[C#/C++]
public Bool ExportFramesToFLV (String sFileName, FBExportToFLVParams *pExportParams, long StartFrame, long EndFrame)

[VB.NET]
Public Function ExportFramesToFLV (ByVal sFileName As String, ByRef pExportParams() As FBExportToFLVParams, ByVal StartFrame As Long, ByVal EndFrame As Long) As Boolean

Parameters

sFileName : the name of the FLV file to be created.

pExportParams : pointer to an FBExportToFLVParams object that contains the parameters to be used in the export process.

StartFrame, EndFrame : the start and end frames of the sequence to be exported.

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is non-zero.

Remarks

ProgressorEventEx events will be generated on the FBEditor object while the export process runs, enabling implementation of a progress indicator. Set the Stop parameter on progressor events to stop the export.

See Also


ExportFramesToQuickTime

BB FlashBack SDK: FBMovie

ExportFramesToQuickTime

Description

Exports selected frames to QuickTime format, with a specified filename and parameters.

This method is accessible to the Advanced edition of the SDK only.

Syntax

[C#/C++]
public Boolean ExportFramesToQuickTime (String sFileName, FBExportToQuickTimeParams *pExportParams, long StartFrame, long EndFrame)

[VB.NET]
Public Function ExportFramesToQuickTime (ByVal sFileName As String, ByRef pExportParams() As FBExportToQuickTimeParams, ByVal StartFrame As Long, ByVal EndFrame As Long) As Boolean

Parameters

sFileName : the name of the QuickTime file to be created.

pExportParams : pointer to an FBExportToQuickTimeParams object that contains the parameters to be used in the export process.

StartFrame, EndFrame : the start and end frames of the sequence to be exported.

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is non-zero.

Remarks

QuickTime (free or Pro version) is required to be installed to export to QuickTime. The developer should check that the SDK is able to export to QuickTime by querying the FBEditor::CanExportToQuickTime property.

If the ShowOptions parameter of the export parameters object is set to True, a dialog will be displayed that enables the user to change export parameters. If ShowOptions is set to False, the export takes place using the parameters specified in the export parameters object.

ProgressorEventEx events will be generated on the FBEditor object while the export process runs, enabling implementation of a progress indicator. Set the Stop parameter on progressor events to stop the export.

See Also


ExportFramesToSWF

BB FlashBack SDK: FBMovie

ExportFramesToSWF

Description

Exports selected frames to Flash (SWF) file format, with a specified filename and parameters.

This method is accessible to the Advanced edition of the SDK only.

Syntax

[C#/C++]
public Boolean ExportFramesToSWF (String sFileName, FBExportToSWFParams *pExportParams, long StartFrame, long EndFrame)

[VB.NET]
Public Function ExportFramesToSWF (ByVal sFileName As String, ByRef pExportParams() As FBExportToSWFParams) As Boolean, ByVal StartFrame As Long, ByVal EndFrame As Long) As Boolean

Parameters

sFileName : the name of the SWF file to be created.

pExportParams : pointer to an FBExportToSWFParams object that contains the parameters to be used in the export process.

StartFrame, EndFrame : the start and end frames of the sequence to be exported.

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is non-zero.

Remarks

Two or three files are created - one or two SWF files and one HTML file. See About BB FlashBack SDK Flash Exports for details on single and multiple SWF exports.

The HTML file is a page that displays the SWF movie as an embedded object. If a value of "mymovie.swf" is passed in as the FileName parameter, the files would be named "mymovie.swf", "mymovie.html" and (optionally, if multiple SWFs are exported) "mymovie_toolbar.swf".

If the ShowOptions parameter of the export parameters object is set to True, a dialog will be displayed that enables the user to change export parameters. If ShowOptions is set to False, the export takes place using the parameters specified in the export parameters object.

ProgressorEventEx events will be generated on the FBEditor object while the export process runs, enabling implementation of a progress indicator. Set the Stop parameter on progressor events to stop the export.

See Also


ExportFramesToWMV

BB FlashBack SDK: FBMovie

ExportFramesToWMV

Description

Exports selected frames to Windows Media Video (WMV) file format, with a specified filename and parameters.

This method is accessible to the Advanced edition of the SDK only.

Syntax

[C#/C++]
public Boolean ExportToWMV (String sFileName, FBExportToWMVParams *pExportParams, long StartFrame, long EndFrame)

[VB.NET]
Public Function ExportToWMV (ByVal sFileName As String, ByRef pExportParams() As FBExportToWMVParams, ByVal StartFrame As Long, ByVal EndFrame As Long) As Boolean

Parameters

sFileName : the name of the WMV file to be created.

pExportParams : pointer to an FBExportToWMVParams object that contains the parameters to be used in the export process.

StartFrame, EndFrame : the start and end frames of the sequence to be exported.

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is non-zero.

Remarks

If the ShowOptions parameter of the export parameters object is set to True, a dialog will be displayed that enables the user to change export parameters. If ShowOptions is set to False, the export takes place using the parameters specified in the export parameters object.

ProgressorEventEx events will be generated on the FBEditor object while the export process runs, enabling implementation of a progress indicator. Set the Stop parameter on progressor events to stop the export.

See Also


ExportToAVI

BB FlashBack SDK: FBMovie

ExportToAVI

Description

Exports the movie to AVI format, with a specified filename and parameters.

Syntax

[C#/C++]
public Bool ExportToAVI (String sFileName, FBExportToAVIParams *pExportParams)

[VB.NET]
Public Function ExportToAVI (ByVal sFileName As String, ByRef pExportParams() As FBExportToAVIParams) As Boolean

Parameters

sFileName : the name of the AVI file to be created.

pExportParams : pointer to an FBExportToAVIParams object that contains the parameters to be used in the export process.

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is non-zero.

Remarks

If the ShowOptions parameter of the export parameters object is set to True, a dialog will be displayed that enables the user to change export parameters. If ShowOptions is set to False, the export takes place using the parameters specified in the export parameters object.

ProgressorEventEx events will be generated on the FBEditor object while the export process runs, enabling implementation of a progress indicator. Set the Stop parameter on progressor events to stop the export.

See Also


ExportToEXE

BB FlashBack SDK: FBMovie

ExportToEXE

Description

Exports the movie to EXE format, with a specified filename and parameters.

Syntax

[C#/C++]
public Bool ExportToEXE (String sFileName, FBExportToEXEParams *pExportParams)

[VB.NET]
Public Function ExportToEXE (ByVal sFileName As String, ByRef pExportParams() As FBExportToEXEParams) As Boolean

Parameters

sFileName : the name of the EXE file to be created.

pExportParams : pointer to an FBExportToEXEParams object that contains the parameters to be used in the export process.

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is non-zero.

Remarks

If the ShowOptions parameter of the export parameters object is set to True, a dialog will be displayed that enables the user to change export parameters. If ShowOptions is set to False, the export takes place using the parameters specified in the export parameters object.

ProgressorEventEx events will be generated on the FBEditor object while the export process runs, enabling implementation of a progress indicator. Set the Stop parameter on progressor events to stop the export.

See Also


ExportToFLV

BB FlashBack SDK: FBMovie

ExportToFLV

Description

Exports the movie to Flash Video (FLV) format, with a specified filename and parameters.

Syntax

[C#/C++]
public Bool ExportToFLV (String sFileName, FBExportToFLVParams *pExportParams)

[VB.NET]
Public Function ExportToFLV (ByVal sFileName As String, ByRef pExportParams() As FBExportToFLVParams) As Boolean

Parameters

sFileName : the name of the FLV file to be created.

pExportParams : pointer to an FBExportToFLVParams object that contains the parameters to be used in the export process.

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is non-zero.

Remarks

ProgressorEventEx events will be generated on the FBEditor object while the export process runs, enabling implementation of a progress indicator. Set the Stop parameter on progressor events to stop the export.

See Also


ExportToGIF

BB FlashBack SDK: FBMovie

ExportToGIF

Description

Exports the movie to GIF format, with a specified filename and parameters.

Syntax

[C#/C++]
public Bool ExportToGIF (String sFileName, FBExportToGIFParams *pExportParams)

[VB.NET]
Public Function ExportToGIF (ByVal sFileName As String, ByRef pExportParams() As FBExportToGIFParams) As Boolean

Parameters

sFileName : the name of the GIF file to be created.

pExportParams : pointer to an FBExportToGIFParams object that contains the parameters to be used in the export process.

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is non-zero.

Remarks

If the ShowOptions parameter of the export parameters object is set to True, a dialog will be displayed that enables the user to change export parameters. If ShowOptions is set to False, the export takes place using the parameters specified in the export parameters object.

ProgressorEventEx events will be generated on the FBEditor object while the export process runs, enabling implementation of a progress indicator. Set the Stop parameter on progressor events to stop the export.

See Also


ExportToMP4

BB FlashBack SDK: FBMovie

ExportToMP4

Description

Exports the movie to MP4 format, with a specified filename and parameters.

Syntax

[C#/C++]
public Bool ExportToMP4 (String sFileName, FBExportToMP4Params *pExportParams)

[VB.NET]
Public Function ExportToMP4 (ByVal sFileName As String, ByRef pExportParams() As FBExportToMP4Params) As Boolean

Parameters

sFileName : the name of the MP4 file to be created.

pExportParams : pointer to an FBExportToMP4Params object that contains the parameters to be used in the export process.

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is non-zero.

Remarks

This method exports H264 video and AAC audio in an MP4 container format.

If the ShowOptions parameter of the export parameters object is set to True, a dialog will be displayed that enables the user to change export parameters. If ShowOptions is set to False, the export takes place using the parameters specified in the export parameters object.

ProgressorEventEx events will be generated on the FBEditor object while the export process runs, enabling implementation of a progress indicator. Set the Stop parameter on progressor events to stop the export.

See Also


ExportToQuickTime

BB FlashBack SDK: FBMovie

ExportToQuickTime

Description

Exports the movie to QuickTime format, with a specified filename and parameters.

Syntax

[C#/C++]
public Bool ExportToQuickTime (String sFileName, FBExportToQuickTimeParams *pExportParams)

[VB.NET]
Public Function ExportToQuickTime (ByVal sFileName As String, ByRef pExportParams() As FBExportToQuickTimeParams) As Boolean

Parameters

sFileName : the name of the QuickTime file to be created.

pExportParams : pointer to an FBExportToQuickTimeParams object that contains the parameters to be used in the export process.

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is non-zero.

Remarks

QuickTime (free or Pro version) is required to be installed to export to QuickTime. The developer should check that the SDK is able to export to QuickTime by querying the FBEditor::CanExportToQuickTime property.

If the ShowOptions parameter of the export parameters object is set to True, a dialog will be displayed that enables the user to change export parameters. If ShowOptions is set to False, the export takes place using the parameters specified in the export parameters object.

ProgressorEventEx events will be generated on the FBEditor object while the export process runs, enabling implementation of a progress indicator. Set the Stop parameter on progressor events to stop the export.

See Also


ExportToSWF

BB FlashBack SDK: FBMovie

ExportToSWF

Description

Exports the movie to Flash (SWF) file format, with a specified filename and parameters.

Syntax

[C#/C++]
public Bool ExportToSWF (String sFileName, FBExportToSWFParams *pExportParams)

[VB.NET]
Public Function ExportToSWF (ByVal sFileName As String, ByRef pExportParams() As FBExportToSWFParams) As Boolean

Parameters

sFileName : the name of the SWF file to be created.

pExportParams : pointer to an FBExportToSWFParams object that contains the parameters to be used in the export process.

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is non-zero.

Remarks

Two or three files are created - one or two SWF files and one HTML file. See About BB FlashBack SDK Flash Exports for details on single and multiple SWF exports.

The HTML file is a page that displays the SWF movie as an embedded object. If a value of "mymovie.swf" is passed in as the FileName parameter, the files would be named "mymovie.swf", "mymovie.html" and (optionally, if multiple SWFs are exported) "mymovie_toolbar.swf".

If the ShowOptions parameter of the export parameters object is set to True, a dialog will be displayed that enables the user to change export parameters. If ShowOptions is set to False, the export takes place using the parameters specified in the export parameters object.

ProgressorEventEx events will be generated on the FBEditor object while the export process runs, enabling implementation of a progress indicator. Set the Stop parameter on progressor events to stop the export.

See Also


ExportToWMV

BB FlashBack SDK: FBMovie

ExportToWMV

Description

Exports the movie to Windows Media Video (WMV) file format, with a specified filename and parameters.

Syntax

[C#/C++]
public Bool ExportToWMV (String sFileName, FBExportToWMVParams *pExportParams)

[VB.NET]
Public Function ExportToWMV (ByVal sFileName As String, ByRef pExportParams() As FBExportToWMVParams) As Boolean

Parameters

sFileName : the name of the WMV file to be created.

pExportParams : pointer to an FBExportToWMVParams object that contains the parameters to be used in the export process.

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is non-zero.

Remarks

If the ShowOptions parameter of the export parameters object is set to True, a dialog will be displayed that enables the user to change export parameters. If ShowOptions is set to False, the export takes place using the parameters specified in the export parameters object.

ProgressorEventEx events will be generated on the FBEditor object while the export process runs, enabling implementation of a progress indicator. Set the Stop parameter on progressor events to stop the export.

See Also


GetCursorHighlightProps

BB FlashBack SDK: FBMovie

GetCursorHighlightProps

Description

Fills out an FBCursorHighlightProps object with the current cursor highlight properties. These include the color, width etc of the border around the cursor, the size of the highlight circle and the properties of the fill used.

Use SetCursorHighlightProps to set the cursor highlight properties.

See The FBCursorHighlightProps class for details of the cursor highlight properties.

Syntax

[C#/C++]
public void GetCursorHighlightProps (FBCursorHighlightProps* pCursorProps);

[VB.NET]
Public Sub GetCursorHighlightProps (ByRef pCursorProps As FBCursorHighlightProps)

Parameters

pCursorProps (in) : pointer to an FBCursorHighlightProps object

See Also


FBMovie::GetDefaultAVIParams

BB FlashBack SDK: FBMovie

GetDefaultAVIParams

Description

Fills out an FBExportToAVIParams object with the default AVI export parameters.

Syntax

[C#/C++]
public void GetDefaultAVIParams (FBExportToAVIParams* pParams);

[VB.NET]
Public Sub GetDefaultAVIParams (ByRef pParams As FBExportToAVIParams)

Parameters

pParams (in) : pointer to an FBExportToAVIParams object.

Remarks

The FBExportToAVIParams object filled out by this method can be passed to a call to ExportToAVI. If its ShowOptions parameter is set to True, a standard options dialog is shown enabling the user to change export parameters.

When the AVI export parameters are changed by the user via the options dialog, these become the new defaults and will be returned from GetDefaultAVIParams the next time it is called.

See Also


GetDefaultEXEParams

BB FlashBack SDK: FBMovie

GetDefaultEXEParams

Description

Fills out an FBExportToEXEParams object with the default EXE export parameters.

Syntax

[C#/C++]
public void GetDefaultEXEParams (FBExportToEXEParams* pParams);

[VB.NET]
Public Sub GetDefaultEXEParams (ByRef pParams As FBExportToEXEParams)

Parameters

pParams (in) : pointer to an FBExportToEXEParams object.

Remarks

The FBExportToEXEParams object filled out by this method can be passed to a call to ExportToEXE. If its ShowOptions parameter is set to True, a standard options dialog is shown enabling the user to change export parameters.

When the EXE export parameters are changed by the user via the options dialog, these become the new defaults and will be returned from GetDefaultEXEParams the next time it is called.

See Also


GetDefaultFLVParams

BB FlashBack SDK: FBMovie

GetDefaultFLVParams

Description

Fills out an FBExportToFLVParams object with the default FLV export parameters.

Syntax

[C#/C++]
public void GetDefaultFLVParams (FBExportToFLVParams* pParams);

[VB.NET]
Public Sub GetDefaultFLVParams (ByRef pParams As FBExportToFLVParams)

Parameters

pParams (in) : pointer to an FBExportToFLVParams object.

Remarks

The FBExportToFLVParams object filled out by this method can be passed to a call to ExportToFLV. If its ShowOptions parameter is set to True, a standard options dialog is shown enabling the user to change export parameters.

When the FLV export parameters are changed by the user via the options dialog, these become the new defaults and will be returned from GetDefaultFLVParams the next time it is called.

See Also


FBMovie::GetDefaultSWFParams

BB FlashBack SDK: FBMovie

GetDefaultSWFParams

Description

Fills out an FBExportToSWFParams object with the default SWF export parameters.

Syntax

[C#/C++]
public void GetDefaultSWFParams (FBExportToSWFParams* pParams);

[VB.NET]
Public Sub GetDefaultSWFParams (ByRef pParams As FBExportToSWFParams)

Parameters

pParams (in) : pointer to an FBExportToSWFParams object.

Remarks

The FBExportToSWFParams object filled out by this method can be passed to a call to ExportToSWF. If its ShowOptions parameter is set to True, a standard options dialog is shown enabling the user to change export parameters.

When the SWF export parameters are changed by the user via the options dialog, these become the new defaults and will be returned from GetDefaultSWFParams the next time it is called.

See Also


GetDefaultWMVParams

BB FlashBack SDK: FBMovie

GetDefaultWMVParams

Description

Fills out an FBExportToWMVParams object with the default WMV export parameters.

Syntax

[C#/C++]
public void GetDefaultWMVParams (FBExportToWMVParams* pParams);

[VB.NET]
Public Sub GetDefaultWMVParams (ByRef pParams As FBExportToWMVParams)

Parameters

pParams (in) : pointer to an FBExportToWMVParams object.

Remarks

The FBExportToWMVParams object filled out by this method can be passed to a call to ExportToWMV. If its ShowOptions parameter is set to True, a standard dialog is shown enabling the user to change export parameters.

When the WMV export parameters are changed by the user via the options dialog, these become the new defaults and will be returned from GetDefaultWMVParams the next time it is called.

See Also


InsertFrames

BB FlashBack SDK: FBMovie

InsertFrames

Description

Inserts a number of frames into the movie, and optionally adds silence to any sounds that are playing through the insertion point.

Syntax

[C#/C++]
public Bool InsertFrames (long lStartFrame, long lNumberOfFrames, Bool bUpdateSounds)

[VB.NET]
Public Function InsertFrames (ByVal lStartFrame As Long, ByVal lNumberOfFrames As Long, ByVal bUpdateSounds As Boolean) As Boolean

Parameters

lStartFrame : the frame at which to insert the new frames

lNumberOfFrames : the quantity of frames to insert

bUpdateSounds : if set to True, silence is inserted into any sound clips (FBSoundClip objects) that are playing at the insertion point. The length of silence corresponds to the number of frames inserted. This has the effect of keeping later portions of the sound in sync with video.

If the value is set to False, no silence is added to sounds.

Return Values

If the function fails, the return value is a null pointer.

If the function succeeds, the return value is non-zero.

Remarks

See How the sound classes work for more information on the sound classes and how edit operations can affect them.

See Also


IsSWFBatchExportReady

BB FlashBack SDK: FBMovie

IsSWFBatchExportReady

Description

Checks that the FBMovie object is ready for a batch export. Batch export parameters are set by a call to PrepareSWFBatchExport. If the movie has been closed or a call made to ExportToSWF since then, batch export parameters are lost, and SWFBatchExport should not be called.

Syntax

[C#/C++]
public Bool IsSWFBatchExportReady ();

[VB.NET]
Public Function IsSWFBatchExportReady () As Boolean

Returns

Returns True when batch export parameters are prepared, False if they are not.

See Also


PrepareSWFBatchExport

BB FlashBack SDK: FBMovie

PrepareSWFBatchExport

Description

Sets the Flash export settings to be used for a batch export.

Using the PrepareSWFBatchExport and SWFBatchExport methods improves performance when repeatedly exporting a movie to Flash, in particular when exporting a small number of frames many times.

Syntax

[C#/C++]
public Bool PrepareSWFBatchExport (FBExportToSWFParams *pExportParams)

[VB.NET]
Public Function PrepareSWFBatchExport (ByRef pExportParams() As FBExportToSWFParams) As Boolean

Parameters

pExportParams : pointer to an FBExportToSWFParams object that contains the parameters to be used in the export process.

Return Values

Returns True if the function succeeds, False if it fails.

Remarks

After setting export parameters with PrepareSWFBatchExport, call the SWFBatchExport method to export the movie to Flash using these parameters.

See Also


FBMovie::Save

BB FlashBack SDK: FBMovie

Save

Description

Saves the movie to its FBR file.

Syntax

[C#/C++]
public Bool Save ()

[VB.NET]
Public Function Save () As Boolean

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is non-zero.

Remarks

See Also


FBMovie::SaveAs

BB FlashBack SDK: FBMovie

SaveAs

Description

Saves the movie to a new FBR file.

Syntax

[C#/C++]
public Bool SaveAs (String sFileName )

[VB.NET]
Public Function SaveAs (ByVal sFileName As String) As Boolean

Parameters

sFileName : name of the new FBR file

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is non-zero.

Remarks

See Also


FBMovie::SaveAsUsingFormat

BB FlashBack SDK: FBMovie

SaveAsUsingFormat

Description

Saves the movie to a new FBR file, using the specified file format.

Use this function to save movies that can be played back by applications produced by version 2.0 of the SDK. The current SDK version is 2.5.

Presentation objects introduced in version 2.5 are removed from the movie. Sound is mixed to a format that can be read by version 2.0 classes.

See FlashBack Movie File Format Versions to learn more about FBR file format versions and how they relate to SDK versions.

Syntax

[C#/C++]
public Bool SaveAsUsingFormat (String sFileName, FBFileFormats format )

[VB.NET]
Public Function SaveAsUsingFormat (ByVal sFileName As String, ByVal format As FBFileFormats) As Boolean

Parameters

sFileName (in) : name of the new FBR file

format (in) : A value from the FBFileFormats enumeration.

Value | Effect
0 | Use FBR format v1.45 - the version used by SDK 2.0 classes
1 | Use FBR format v2.0 - the version used by SDK 2.5 classes

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is non-zero.

See Also


SaveFrameAsJpeg

BB FlashBack SDK: FBMovie

SaveFrameAsJpeg

Description

Saves a frames to a JPEG image file

Syntax

[C#/C++]
public Bool SaveFrameAsJpeg (BSTR FileName, long FrameNum, long Width, long Height, Bool SaveCursor);

[VB.NET]
Public Function SaveFrameAsJpeg (ByVal FileName As String, ByVal FrameNum As Long, ByVal Width As Long, ByVal Height As Long, ByVal SaveCursor As Boolean) As Boolean

Parameters

FileName - name of the Jpeg file to save.

FrameNum - number of the frame to save

Width - width in pixels of the saved image

Height - height in pixels of the saved image

SaveCursor - set to true to save the cursor in the image, or false to omit the cursor

Return Values

If the function fails, the return value is zero.


FBEditor::SaveFramesAsNewMovie

BB FlashBack SDK: FBMovie

SaveFramesAsNewMovie

Description

Saves a sequence of frames to a new FBR movie file.

Syntax

[C#/C++]
public Bool SaveFramesAsNewMovie (BSTR FileName, long StartFrame, long EndFrame);

[VB.NET]
Public Function SaveFramesAsNewMovie (ByVal FileName As String, ByVal StartFrame As Long, ByVal EndFrame As Long) As Boolean

Parameters

FileName - name of the new FBR file to save.

StartFrame - number of the frame that starts the sequence to be saved.

EndFrame - number of the frame that ends the sequence to be saved.

Return Values

If the function fails, the return value is zero.


SetCursorHighlightProps

BB FlashBack SDK: FBMovie

SetCursorHighlightProps

Description

The mouse cursor can be highlit by a circle of colour, and clicks highlit by red circles during movie playback. SetCursorHighlightProps sets the movie cursor highlight properties by passing in a pointer to an FBCursorHighlightProps object.

Use GetCursorHighlightProps to get the current cursor highlight properties.

See The FBCursorHighlightProps class for details of the cursor highlight properties.

Syntax

[C#/C++]
public void SetCursorHighlightProps (FBCursorHighlightProps* pCursorProps);

[VB.NET]
Public Sub SetCursorHighlightProps (ByRef pCursorProps As FBCursorHighlightProps)

Parameters

pCursorProps (in) : pointer to an FBCursorHighlightProps object containing the desired cursor highlight properties.

See Also


SWFBatchExport

BB FlashBack SDK: FBMovie

SWFBatchExport

Description

Exports the movie to Flash.

Using the PrepareSWFBatchExport and SWFBatchExport methods improves performance when repeatedly exporting a movie to Flash, in particular when exporting a small number of frames many times.

Syntax

[C#/C++]
public Bool SWFBatchExport (String sFileName, long StartFrame, long EndFrame, FBBatchExportToSWFParams *pSWFParams);

[VB.NET]
Public Function SWFBatchExport (ByVal sFileName As String, ByVal StartFrame As Long, ByVal EndFrame As Long, ByRef pSWFParams() As FBBatchExportToSWFParams ) As Boolean

Parameters

sFileName : the name of the SWF file to be created.

StartFrame, EndFrame : the start and end frames of the sequence to be exported.

pSWFParams : pointer to an FBBatchExportToSWFParams object that contains the parameters to be used in the export process.

Return Values

Returns True if the function succeeds, False if it fails.

Remarks

Export parameters need to be set using PrepareSWFBatchExport before calling SWFBatchExport.

See Also


EditPassword

BB FlashBack SDK: FBMovie

EditPassword

Description

Used to read and set the 'Edit' password for the movie.

Syntax

[C#/C++]
public BSTR EditPassword;

[VB.NET]
Public EditPassword As String

Remarks

For details of how to password protect movies, see Password Protecting Movie Files.

See Also


FBMovie::Filename

BB FlashBack SDK: FBMovie

Filename

Description

Returns the filename of the movie.

Syntax

[C#/C++]
public BSTR Filename

[VB.NET]
Public Filename As String

See Also

FBMovie::SaveAs


FBMovie::Frames

BB FlashBack SDK: FBMovie

Frames

Description

Returns the number of frames in the currently loaded movie.

Syntax

[C#/C++]
public long Frames

[VB.NET]
public Frames as Long


Rate

BB FlashBack SDK: FBMovie

FramesPerSec

Description

Returns the frame rate of the movie.

Syntax

[C#/C++]
public long FramesPerSec

[VB.NET]
public FramesPerSec as Long

Remarks

The default frame rate of a movie recorded using the capture driver is 24 frames per second (fps).


hasEditPassword

BB FlashBack SDK: FBMovie

hasPlayPassword

Description

Indicates whether the current movie has a FBMovie::PlayPassword set

Syntax

[C#/C++]
public Bool hasPlayPassword;

[VB.NET]
Public hasPlayPassword As Boolean

Remarks

For more information about password protecting FBR movie files, see Password Protecting Movie Files.

See Also


hasPlayPassword

BB FlashBack SDK: FBMovie

hasPlayPassword

Description

Indicates whether the current movie has a FBMovie::PlayPassword set

Syntax

[C#/C++]
public Bool hasPlayPassword;

[VB.NET]
Public hasPlayPassword As Boolean

Remarks

For more information about password protecting FBR movie files, see Password Protecting Movie Files.

See Also


HasWebCamWindow

BB FlashBack SDK: FBMovie

HasWebCamVideo

Description

Indicates whether the current movie includes webcam video.

Syntax

[C#/C++]
public Bool HasWebCamVideo;

[VB.NET]
Public HasWebCamVideo As Boolean

See Also


FBMovie::Height

BB FlashBack SDK: FBMovie

Height

Description

Returns the height of the movie in pixels.

Syntax

[C#/C++]
public long Height

[VB.NET]
public Height as Long


IsChanged

BB FlashBack SDK: FBMovie

IsChanged

Description

Returns True if the movie has been changed in any way since being opened or the most recent call to Save.

Syntax

[C#/C++]
public Bool IsChanged

[VB.NET]
public IsChanged as Boolean


IsOldFormat

BB FlashBack SDK: FBMovie

IsOldFormat

Description

Returns True if the movie loaded is in format older than that used by version 2.5 of the SDK - the current version.

See FlashBack Movie File Format Versions to learn more about FBR file format versions and how they relate to SDK versions.

Syntax

[C#/C++]
public Bool IsOldFormat

[VB.NET]
public IsOldFormat as Boolean

Remarks

Older format FlashBack movies are converted to the new format on loading.

FBMovie::SaveAs should be used to save a new format movie file, while retaining the older format original. You may want to retain the original file, because the application that produced it will be unable to work with newer format FlashBack movies.

FBMovie::SaveAsUsingFormat can be used to save the movie in an older format, compatible with SDK v1.0 and 2.0 classes.

See Also


FBMovie::Length

BB FlashBack SDK: FBMovie

Length

Description

Returns the duration of the movie in milliseconds.

Syntax

[C#/C++]
public long Length

[VB.NET]
public Length as Long


PlayPassword

BB FlashBack SDK: FBMovie

PlayPassword

Description

Used to read and set the 'Play' password for the movie.

Syntax

[C#/C++]
public BSTR PlayPassword;

[VB.NET]
Public PlayPassword As String

Remarks

For details of how to password protect movies, see Password Protecting Movie Files.

See Also


FBMovie::WebCamVideoMode

BB FlashBack SDK: FBMovie

WebCamVideoMode

Description

Sets the webcam video display mode. Webcam video can be displayed in one of two modes:

  • In-own-window
    The webcam video is displayed in its own independant window, which can be positioned anywhere on the desktop. When in this mode, it is not included in exports.

  • Embedded
    The webcam video is displayed in a frame that can be positioned within the movie. When in this mode, it is included in exports.

Syntax

[C#/C++]
public long WebCamVideoMode;

[VB.NET]
Public Property WebCamVideoMode As Long

Remarks

Can be one of these values:

Value | Mode
0 | Embedded
1 | In own window

See Also


FBMovie::WebCamWindowVisible

BB FlashBack SDK: FBMovie

WebCamWindowVisible

Description

Sets visibility of the webcam video window, if there is webcam video in the movie. Use this property to hide and show the webcam video window.

Syntax

[C#/C++]
public Bool WebCamWindowVisible;

[VB.NET]
Public WebCamWindowVisible As Boolean

See Also


FBMovie::Width

BB FlashBack SDK: FBMovie

Width

Description

Returns the width of the movie in pixels.

Syntax

[C#/C++]
public long Width

[VB.NET]
public Width as Long


The FBFrames Class

Enables access to the various objects that can be contained within a frame.

Returned from

FBEditor::GetFrames

Methods

DrawCursor
FramehasPausedObjects
GetBitmaps
GetCursorHotSpot
GetCursorPosition
GetCursorSize
GetFrameActions
GetFrameActionsCount
GetFrameProperties
GetFrameRealTime
GetMarkers
GetTextBoxes
GetTransitions
GetWatermarks

Properties

Count


DrawCursor

BB FlashBack SDK: FBFrames

DrawCursor

Description

Draws the cursor of a particular frame into a device context.

.NET programmers can employ the helper class FBGDIBitmap when using DrawCursor, in order to obtain a bitmap device context handle.

Syntax

[C#/C++]
public void DrawCursor (long framenum, long X, long Y, long hDC);

[VB.NET]
Public Sub DrawCursor (ByVal framenum As Integer, ByVal X As Integer, ByVal Y As Integer, ByVal hDC As Integer)

Parameters

framenum (in) - specifies the frame for which the cursor image will be drawn.

X (in) - the X position at which to draw the cursor.

Y (in) - the Y position at which to draw the cursor.

hDC (in) - handle to the device context into which to draw the cursor.

See Also


FrameHasPausedObjects

BB FlashBack SDK: FBFrames

FrameHasPausedObjects

Description

Returns a boolean value indicating whether the specified frame contains any objects that create a pause.

Syntax

[C#/C++]
public bool FrameHasPausedObjects (long lFrame)

[VB.NET]
Public Function GetWatermarks (ByVal lFrame As Integer) As Boolean

Parameters

lFrame (in) : the number of the frame

Return Values

The function returns true if the frame contains objects that create a pause, false if it does not.


GetBitmaps

BB FlashBack SDK: FBFrames

GetBitmaps

Description

Returns, in an FBBitmaps object, a collection of all the bitmaps shown in the specified frame.

This method is accessible to the Advanced edition of the SDK only.

Syntax

[C#/C++]
public FBBitmaps* GetBitmaps (long lFrameNumber)

[VB.NET]
Public Function GetBitmaps (ByVal lFrameNumber As Long) As FBBitmaps

Parameters

lFrameNumber : the number of the frame for which displayed bitmaps will be retrieved

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is a pointer to an FBBitmaps collection.

Remarks

If there are no bitmaps shown in the frame, the Count property of the returned FBBitmaps collection is set to zero.

See Also

The FBBitmaps Class


GetBlurs

BB FlashBack SDK: FBFrames

GetBlurs

Description

Returns, in an FBBlurs object, a collection of all the blurs shown in the specified frame.

This method is accessible to the Advanced edition of the SDK only.

Syntax

[C#/C++]
public FBBlurs* GetBlurs (long lFrameNumber)

[VB.NET]
Public Function GetBlurs (ByVal lFrameNumber As Long) As FBBlurs

Parameters

lFrameNumber : the number of the frame for which displayed blurs will be retrieved

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is a pointer to an FBBlurs collection.

Remarks

If there are no blurs shown in the frame, the Count property of the returned FBBlurs collection is set to zero.

See Also

The FBBlurs Class


GetButtons

BB FlashBack SDK: FBFrames

GetButtons

Description

Returns, in an FBButtons object, a collection of all the buttons shown in the specified frame.

This method is accessible to the Advanced edition of the SDK only.

Syntax

[C#/C++]
public FBButtons* GetButtons (long lFrameNumber)

[VB.NET]
Public Function GetButtons (ByVal lFrameNumber As Long) As FBButtons

Parameters

lFrameNumber : the number of the frame for which displayed buttons will be retrieved

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is a pointer to an FBButtons collection.

Remarks

If there are no buttons shown in the frame, the Count property of the returned FBButtons collection is set to zero.

See Also

The FBButtons Class


GetCursorAsIcon

BB FlashBack SDK: FBFrames

GetCursorAsHandle

Description

Returns the handle to a Win32 icon object containing the cursor image in the selected frame.

Syntax

[C#/C++]
public HICON GetCursorAsHandle (Long lFrameNumber);

[VB.NET]
Public Function GetCursorAsHandle (ByVal lFrameNumber As Long) As HICON

Parameters

lFrameNumber (in) : the number of the frame for which the cursor handle will be retrieved

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is a HICON - a handle to a Win32 cursor object.

Remarks

The returned icon object should be destroyed by a call to DestroyIcon (Win32), unless the handle is attached to anotehr cursor.


GetCursorBitmapHandle

BB FlashBack SDK: FBFrames

GetCursorBitmapHandle

Description

Returns the handle to a Win32 bitmap object containing the cursor image in the selected frame.

Syntax

[C#/C++]
public Long GetCursorBitmapHandle (Long lFrameNumber, Long* Width, Long* Height, Bool* HasAlpha)

[VB.NET]
Public Function GetCursorBitmapHandle (ByVal lFrameNumber As Long, ByRef Width As Long, ByRef Height As Long, ByRef HasAlpha As Boolean) As Integer

Parameters

lFrameNumber (in) : the number of the frame for which the cursor bitmap will be retrieved

Width (out) : the width of the cursor bitmap

Height (out) : the height of the cursor bitmap

HasAlpha (out) : True if the cursor bitmap has an alpha channel

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is a handle to a Win32 bitmap object.

Remarks

If there is no alpha channel, the return bitmap is double the height of the cursor image and contains two images. The upper half is the colour bitmap of the cursor, and the lower half the mask for the cursor.


GetCursorHotSpot

BB FlashBack SDK: FBFrames

GetCursorHotSpot

Description

Returns the mouse cursor hot spot in the specified frame.

Syntax

[C#/C++]
public void GetCursorHotSpot (long framenum, long* pX, long* pY);

[VB.NET]
Public Sub GetCursorHotSpot (ByVal framenum As Integer, ByRef pX As Integer, ByRef pY As Integer)

Parameters

framenum - the frame for which the cursor position will be retrieved.

pX - pointer to a long value that will hold the X position of the cursor hotspot.

pY - pointer to a long value that will hold the Y position of the cursor hotspot.

See Also


GetCursorPosition

BB FlashBack SDK: FBFrames

GetCursorPosition

Description

Returns the position of the mouse cursor in the specified frame.

Syntax

[C#/C++]
public void GetCursorPosition (long framenum, long* pX, long* pY);

[VB.NET]
Public Sub GetCursorPosition(ByVal framenum As Integer, ByRef pX As Integer, ByRef pY As Integer)

Parameters

framenum - the frame for which the cursor position will be retrieved.

pX - pointer to a long value that will hold the X position of the cursor.

pY - pointer to a long value that will hold the Y position of the cursor.

See Also


GetCursorSize

BB FlashBack SDK: FBFrames

GetCursorSize

Description

Returns the size of the mouse cursor in the specified frame.

Syntax

[C#/C++]
public void GetCursorSize (long framenum, long* width, long* height);

[VB.NET]
Public Sub GetCursorSize (ByVal framenum As Integer, ByRef width As Integer, ByRef height As Integer)

Parameters

framenum - the frame for which the cursor position will be retrieved.

width - pointer to a long value that will hold the width of the cursor.

height - pointer to a long value that will hold the height of the cursor.

See Also


GetFrameActions

BB FlashBack SDK: FBFrames

GetFrameActions

Description

Returns the raw data describing a specified action in the specified frame.

Actions can be:

  • Appearance of presentation objects like textboxes, images, highlights, zoom-pan objects.

  • Keyboard and mouse events.

  • Sound playback.

  • Graphic changes captured by the recording process.

Syntax

[C#/C++]
public void GetFrameActions (long framenum, long actionnumber, VARIANT *data, long* copied, long* actionindex)

[VB.NET]
Public Sub GetFrameActions (ByVal framenum As Integer, ByVal actionnumber As Integer, ByRef data As Object, ByRef copied As Integer, ByRef actionindex As Integer)

Parameters

framenum (in) : the number of the frame for which actions will be retrieved. Use GetFrameActionsCount to get the number of actions in a specified frame.

actionnumber (in) : the number of the action to retrieve data for.

data (out) : this contains the raw action data. The structure of data returned in this buffer is defined in the file FBRActions.h, included with the SDK.

copied (out) : number of bytes copied into the data buffer.

actionindex (out) : sequence number of the action in the global actions list.

See Also

FBFrames::GetFrameActionsCount


GetFrameActionsCount

BB FlashBack SDK: FBFrames

GetFrameActionsCount

Description

Returns the number of actions in a specified frame. Use GetFrameActions to read the data for an action into a buffer.

Syntax

[C#/C++]
public Long GetFrameActionsCount (long lFrameNumber)

[VB.NET]
Public Function GetFrameActionsCount (ByVal lFrameNumber As Long) As Long

Parameters

lFrameNumber : the number of the frame for which the number of actions will be returned.

Return Values

Returns the number of actions in the specified frame.

See Also

FBFrames::GetFrameActions


GetFrameProperties

BB FlashBack SDK: FBFrames

GetFrameProperties

Description

Sets the properties of a FBFrameProperties object to those of a specified frame within the movie, given its index.

Syntax

[C#/C++]
public Bool GetFrameProperties (long lFrameIndex, FBFrameProperties* pFrameProperties)

[VB.NET]
Public Function GetFrameProperties (ByVal lFrameIndex As Long, ByRef pFrameProperties() As FBFrameProperties) As Boolean

Parameters

lFrameIndex : [In] Index of a frame.

pFrameProperties : [In] Pointer to an FBFrameProperties object created by the calling code.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also

The FBFrameProperties Class


FBFrames::GetFrameRealTime

BB FlashBack SDK: FBFrames

GetFrameRealTime

Description

Returns the 'real time' for a given frame - the local time when the frame was recorded, including the timezone.

Syntax

[C#/C++]
public bool GetFrameRealTime (long framenum, _int64* realtime, long* realtimezone);

[VB.NET]
Public Function GetFrameRealTime (ByVal framenum As Integer, ByRef realtime As Int64, ByRef realtimezone As Integer) As Boolean

Parameters

framenum (in) : the number of the frame for which the realtime will be retrieved.

realtime (out) : a 64 bit integer containing the local time when the frame was recorded, expressed as the number 100 nanosecond intervals since 1st January 1601 - see the FILETIME structure in the Windows SDK.

realtimezone (out) : the difference in minutes between Universal Co-ordinated Time (UTC) and the local time of the PC that recorded the movie, calculated as: difference = UTC - Local Time.

Returns

True if the realtime was found and returned for the frame.

False if framenum < 0, or framenum >= the number of frames in the movie, or there is no realtime information saved in the movie.

See Also

FBEditor::GotoFrameRealTime


GetHighlights

BB FlashBack SDK: FBFrames

GetHighlights

Description

Returns, in an FBHighlights object, a collection of all the highlights in the specified frame.

This method is accessible to the Advanced edition of the SDK only.

Syntax

[C#/C++]
public FBHighlights* GetHighlights ()

[VB.NET]
Public Sub GetHighlights As FBHighlights

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is a pointer to an FBHighlights collection.

See Also

The FBHighlights Class


GetMarkers

BB FlashBack SDK: FBFrames

GetMarkers

Description

Returns, in an FBMarkers object, a collection of all the markers in the specified frame.

This method is accessible to the Pro and Advanced editions of the SDK only.

Syntax

[C#/C++]
public FBMarkers* GetMarkers (long lFrameNumber)

[VB.NET]
Public Function GetMarkers (ByVal lFrameNumber As Long) As FBMarkers

Parameters

lFrameNumber : the number of the frame for which markers will be retrieved

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is a pointer to an FBMarkers collection.

Remarks

If there are no markers in the frame, the Count property of the returned FBMarkers collection is set to zero.

See Also

The FBMarkers Class


FBFrames::GetTextBoxes

BB FlashBack SDK: FBFrames

GetTextBoxes

Description

Returns, in an FBTextBoxes object, a collection of all the text boxes shown in the specified frame.

This method is accessible to the Advanced edition of the SDK only.

Syntax

[C#/C++]
public FBTextBoxes* GetTextBoxes (long lFrameNumber)

[VB.NET]
Public Function GetTextBoxes (ByVal lFrameNumber As Long) As FBTextBoxes

Parameters

lFrameNumber : the number of the frame for which displayed text boxes will be retrieved

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is a pointer to an FBTextBoxes collection.

Remarks

If there are no text boxes shown in the frame, the Count property of the returned FBTextBoxes collection is set to zero.

See Also

The FBTextBoxes Class


GetTransitions

BB FlashBack SDK: FBFrames

GetTransitions

Description

Returns, in an FBTransitions object, a collection of all the transitions shown in the specified frame.

This method is accessible to the Advanced edition of the SDK only.

Syntax

[C#/C++]
public FBTransitions* GetTransitions (long lFrameNumber)

[VB.NET]
Public Function GetTransitions (ByVal lFrameNumber As Long) As FBTransitions

Parameters

lFrameNumber : the number of the frame for which displayed transitions will be retrieved

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is a pointer to an FBTransitions collection.

Remarks

If there are no buttons shown in the frame, the Count property of the returned FBTransitions collection is set to zero.

See Also

The FBTransitions Class


GetWatermarks

BB FlashBack SDK: FBFrames

GetWatermarks

Description

Returns, in an FBWatermarks object, a collection of all the watermarks in the movie.

This method is accessible to the Advanced edition of the SDK only.

Syntax

[C#/C++]
public FBWatermarks* GetWatermarks ()

[VB.NET]
Public Sub GetWatermarks As FBWatermarks

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is a pointer to an FBWatermarks collection.

See Also

The FBWatermarks Class


FBFrames::Count

BB FlashBack SDK: FBFrames

Count

Description

Returns the number of frames in the collection.

Syntax

[C#/C++]
public long Count

[VB.NET]
public Count as Long


The FBFrameProperties Class

BB FlashBack SDK: Movie and Frame Handling classes

The FBFramePropertiesClass

This class gives access to counts of the various objects contained within that frame.

Properties


BitmapsCount

BB FlashBack SDK: FBFrameProperties

BitmapsCount

Description

Returns the number of bitmaps displayed in the frame.

Syntax

[C#/C++]
public long BitmapsCount;

[VB.NET]
Public Property BitmapsCount As Long


FrameIndex

BB FlashBack SDK: FBFrameProperties

FrameIndex

Description

Returns the index of the frame.

Syntax

[C#/C++]
public long FrameIndex;

[VB.NET]
Public Property FrameIndex As Integer

Remarks

The frame index is required for some methods.


IsDummy

BB FlashBack SDK: FBFrameProperties

IsDummy

Description

Returns a value indicating whether the frame contains any events.

Syntax

[C#/C++]
public Bool IsDummy;

[VB.NET]
Public Property IsDummy As Boolean

Remarks

A frame is regarded as 'dummy' if it contains no graphical changes, no mouse clicks or keystroke events and no presentation objects are created in that frame.


FBFrameProperties::MarkersCount

BB FlashBack SDK: FBFrameProperties

MarkersCount

Description

Returns the number of markers in the frame.

Syntax

[C#/C++]
public long MarkersCount;

[VB.NET]
Public Property MarkersCount As Long


MousePointerVisible

BB FlashBack SDK: FBFrameProperties

MousePointerVisible

Description

Indicates whether the mouse pointer is visible in the frame.

Syntax

[C#/C++]
public Bool MousePointerVisible;

[VB.NET]
Public Property MousePointerVisible As Boolean


SoundsCount

BB FlashBack SDK: FBFrameProperties

SoundsCount

Description

Returns the number of sounds that start playback in the frame.

Syntax

[C#/C++]
public long SoundsCount;

[VB.NET]
Public Property SoundsCount As Long


TextBoxesCount

BB FlashBack SDK: FBFrameProperties

TextBoxesCount

Description

Returns the number of text boxes displayed in the frame.

Syntax

[C#/C++]
public long TextBoxesCount;

[VB.NET]
Public Property TextBoxesCount As Long


About Export Parameters Classes

These classes are used to pass parameters to the export methods of FBMovie :

Method | Uses class
ExportToAVI | FBExportToAVIParams
ExportToSWF | FBExportToSWFParams
ExportToMP4 | FBExportToMP4Params
ExportToFLV | FBExportToFLVParams
ExportToWMV | FBExportToWMVParams
ExportToGIF | FBExportToGIFParams
ExportToQuickTime | FBExportToQuickTimeParams
ExportToEXE | FBExportToEXEParams
SWFBatchExport | FBBatchExportToSWFParams

A pointer to a parameter class object, with its properties set to defaults, is returned from these methods of FBMovie :
GetDefaultAVIParams
GetDefaultSWFParams
GetDefaultWMVParams
GetDefaultEXEParams
GetDefaultFLVParams

When passing the parameter class object to ExportToXYZ, if its ShowOptions parameter is set to True, a dialog will be displayed that enables the user to change export parameters. If ShowOptions is set to False, the export takes place using the parameters specified in the object, and no dialog is displayed.


Default Export Parameters

The default export parameters:

AVI/FLV:

AutoscrollDimX = 0

AutoscrollDimY = 0

AutoscrollMode = 0 (autoscroll disabled)

DefaultCompressor = 0

DefaultKeyFrameRate = -1 (FLV only)

DefaultQuality = -1

FrameRateCustom = 24

FrameRateMode = 1 (half frame rate of movie)

HighlightMouseClicks = true

OutputSizeKeepAspectRatio = true

OutputSizePercentX = 100

OutputSizePercentY = 100

ShowOptions = false

SoundCompressFormat = 0x0055 (MP3)

SoundFormat = 0 (format determined by format of sounds in the movie)

SoundMP3Profile = MP3_PROFILE_NORMAL_QUALITY

UseBestFormat = true

These are the defaults that are not present in FBExportToAVIParams but are seen on the AVI export dialog, if this is shown.

UseOldAVIFormat = false

ExportSounds = true

FromFrame = -1 (start of movie)

ToFrame = -1 (end of movie)

FLV Only:

ShowPlaybackControls = true;

valign = 0;

halign = 0;

prebuffer = 30;

autohide = false;

WMV

AudioCodecId = 0

AudioFormatId = 0

AudioNumPasses = 1

AudioVBR = true

AutoscrollDimX = 0

AutoscrollDimY = 0

AutoscrollMode = 0 (no autoscroll)

FrameRateCustom = 24

FrameRateMode = 1 (half frame rate of the movie)

HighlightMouseClicks = true

OutputSizeKeepAspectRatio = true

OutputSizePercentX = 100

OutputSizePercentY = 100

VideoBitrate = 600000

VideoCodecId = 0

VideoNumPasses = 1

VideoQuality = 80

VideoVBR = true

These are the defaults that are not present in FBExportToAVIParams but are seen on the AVI export dialog, if this is shown.

ScaleToPercents = true

DrawWatermark = false

ExportSounds = true

FromFrame = -1 (from movie start)

ToFrame = -1 (to movie end)

Flash:

AddControlBar = true;

AutoscrollDimX = 0

AutoscrollDimY = 0

AutoscrollMode = 0 (no autoscroll)

AutostartPlay = true

BitsCount = 32

ColorFormat = BI_JPEG

CompressLevel = 9

ControlBarAutoHide = false

ControlBarMode = 0 (mettalic)

ControlBarName = <blank>

ControlBarPosMode = 1 (top)

ControlBarPosOver = false

FrameRateCustom = 24

FrameRateMode = 1 (half movie frame rate)

HighlightMouseClicks = true

HTMLTemplate = <blank>

JPEGQuality = 80

MXCompression = true

OutputSizeKeepAspectRatio = true

OutputSizePercentX = 100

OutputSizePercentY = 100

PreloadPercent = 0

SecureCode = <blank>

SecureDomains = <blank>

SoundCompressFormat = 0x0055 (MP3)

SoundFormat = 0 (format determined by format of sounds in movie)

SoundMP3Profile = MP3_PROFILE_NORMAL_QUALITY

StopOnLastFrame = true

UseBestFormat = true

UseSecureCode = false

UseSecureDomain = false

These settings are not in FBExportToSWFParams, but are in the Flash export dialog, if shown.

ScaleToPercents = true

DrawWatermark = false

ExportSounds = true

FromFrame = -1 (from movie start)

ToFrame = -1 (to movie end)

ShowAutoHideControl = true

ShowFlashBackIcon = true

ShowVolumeControl = true

ShowFullScreenButton = true

DoNotScaleInFullScreen = false

ShowTimeDuration = true

EXE

Autoscroll = true

CacheDiskSize = 0

CacheEnabled = true

CacheMemorySize = 1

CacheType = 1

CloseOnFinish = false

DisableToolbar = false

FromFrame = -1 (FromFrame and ToFrame both set to -1, so entire movie is exported)

Fullscreen = false

Height = 0

HideMenu = false

HideMovieMenu = false

HighlightMouseClicks = true

Loop = false

MixSounds = true

ShowOptions = true

ShowToolbar = true

ToFrame = -1

Width = 0

WindowSize = 1 (automatically sizes to movie dimensions)

These settings are not in FBExportToEXEParams, but are in the EXE export options dialog, if shown.

Title = "BB FlashBack Movie"

Right click on movie to show popup menu containing playback functions = true


FBExportToAVIParams::AutoscrollDimX

BB FlashBack SDK: FBExportToAVIParams

AutoscrollDimX

Description

Returns and sets the width of the autoscroll frame.

Syntax

[C#/C++]
public long AutoscrollDimX;

[VB.NET]
Public Property AutoscrollDimX As Long

Remarks

The autoscroll feature keeps the mouse cursor at or near the middle of the exported movie by automatically scrolling the 'autoscroll frame'.

Autoscroll is enabled by setting AutoscrollMode to True. The autoscroll frame dimensions are specified by the AutoscrollDimX and AutoscrollDimY properties.

See also


FBExportToAVIParams::AutoscrollDimY

BB FlashBack SDK: FBExportToAVIParams

AutoscrollDimY

Description

Returns and sets the height of the autoscroll frame.

Syntax

[C#/C++]
public long AutoscrollDimY;

[VB.NET]
Public Property AutoscrollDimY As Long

Remarks

The autoscroll feature keeps the mouse cursor at or near the middle of the exported movie by automatically scrolling the 'autoscroll frame'.

Autoscroll is enabled by setting AutoscrollMode to True. The autoscroll frame dimensions are specified by the AutoscrollDimX and AutoscrollDimY properties.

See also


AutoscrollCompressor

BB FlashBack SDK: FBExportToAVIParams

AutoscrollMode

Description

Returns and sets a value indicating whether autoscroll will be used during export.

Syntax

[C#/C++]
public Bool AutoscrollMode;

[VB.NET]
Public Property AutoscrollMode As Boolean

Remarks

Set this property to True to enable autoscroll.

The autoscroll feature keeps the mouse cursor at or near the middle of the exported movie by automatically scrolling the 'autoscroll frame'.

The autoscroll frame dimensions are specified by the AutoscrollDimX and AutoscrollDimY properties.

See also


FBExportToAVIParams::DefaultCompressor

BB FlashBack SDK: FBExportToAVIParams

DefaultCompressor

Description

Sets the FOURCC value indicating which codec to use for video compression during export.

Syntax

[C#/C++]
public long DefaultCompressor;

[VB.NET]
Public Property DefaultCompressor As Long

Remarks

A Four-Character Code used to identify the codec used to compress the movie on export, a FOURCC is a 32-bit quantity represented as a sequence of one to four ASCII alphanumeric characters, padded on the right with blank characters.

Each codec has a unique FOURCC value identifying it. For example, DIVX is the code for the DivX codec, and CRAM indicates the Microsoft Video 1 codec.


FBExportToAVIParams::DefaultKeyFrameRate

BB FlashBack SDK: FBExportToAVIParams

DefaultKeyFrameRate

Description

Sets and returns the default key frame rate.

Syntax

[C#/C++]
public long DefaultKeyFrameRate;

[VB.NET]
Public Property DefaultKeyFrameRate As Long

Remarks

The number of frames between keyframes. If the rate is set to 5, this means that a keyframe is generated once every 5 frames of the movie.

Generally, the more keyframes, the better the quality of the movie, but the larger the AVI file.


FBExportToAVIParams::DefaultQuality

BB FlashBack SDK: FBExportToAVIParams

DefaultQuality

Description

Sets and returns the default quality used when exporting AVI files.

Syntax

[C#/C++]
public long DefaultQuality;

[VB.NET]
Public Property DefaultQuality As Long

Remarks

This value ranges from 1-100, where 100 is the highest quality and 1 is the lowest. The higher the quality, the larger the AVI file exported.


FBExportToAVIParams::FrameRateCustom

BB FlashBack SDK: FBExportToAVIParams

FrameRateCustom

Description

Sets the frame rate, in frames per second, at which to export, when a 'custom' frame rate has been selected via the FrameRateMode property.

Syntax

[C#/C++]
public long FrameRateCustom;

[VB.NET]
Public Property FrameRateCustom As Long

Remarks

This property is only used when FrameRateMode is set to 3.

See Also

FBExportToAVIParams::FrameRateMode


FBExportToAVIParams::FrameRateMode

BB FlashBack SDK: FBExportToAVIParams

FrameRateMode

Description

Sets the frame rate at which to export.

Syntax

[C#/C++]
public long FrameRateMode;

[VB.NET]
Public Property FrameRateMode As Long

Remarks

Can be one of these values:

Value | Frame rate
0 | Same frame rate as the native FBR movie recording.
1 | 1/2 frame rate of movie.
2 | 1/4 frame rate of movie.
3 | Frame rate defined by the FrameRateCustom property.

The default frame rate for movies recorded with the capture driver is 25fps.

See Also

FBExportToAVIParams::FrameRateCustom


FBExportToAVIParams::HighlightMouseClicks

BB FlashBack SDK: FBExportToAVIParams

HighlightMouseClicks

Description

Determines whether mouse clicks are highlighted with animating circles in the exported movie.

Syntax

[C#/C++]
public Bool HighlightMouseClicks;

[VB.NET]
Public Property HighlightMouseClicks As Boolean


FBExportToAVIParams::OutputSizeKeepAspectRatio

BB FlashBack SDK: FBExportToAVIParams

OutputSizeKeepAspectRatio

Description

Returns and sets the value that determines whether the aspect ratio of the movie is maintained when its width or height are altered via the OutputSizePercentX or OutputSizePercentY properties.

Syntax

[C#/C++]
public Bool OutputSizeKeepAspectRatio;

[VB.NET]
Public Property OutputSizeKeepAspectRatio As Boolean

Remarks

If this property is set to True, altering OutputSizePercentX or OutputSizePercentY automatically changes the other percentage to the same value, to maintain the aspect ratio of the movie.

See also


FBExportToAVIParams::OutputSizePercentX

BB FlashBack SDK: FBExportToAVIParams

OutputSizePercentX

Description

Returns and sets the percentage scaling applied to the width of the movie, when exported.

Note: this parameter is deprecated in favour of OutputSizePercentXFloat.

Syntax

[C#/C++]
public long OutputSizePercentX;

[VB.NET]
Public Property OutputSizePercentX As Long

Remarks

If OutputSizeKeepAspectRatio is set to True, changing the percent scaling for the width results in the percent scaling for the height (the OutputSizePercentY property) being set to the same value.

See also

FBExportToAVIParams:OutputSizeKeepAspectRatio FBExportToAVIParams::OutputSizePercentY

FBExportToAVIParams::OutputSizePercentXFloat


OutputSizePercentXFloat

BB FlashBack SDK: FBExportToAVIParams

OutputSizePercentXFloat

Description

Returns and sets the percentage scaling applied to the width of the movie, when exported.

Syntax

[C#/C++]
public float OutputSizePercentXFloat;

[VB.NET]
Public Property OutputSizePercentXFloat As Single

Remarks

If OutputSizeKeepAspectRatio is set to True, changing the percent scaling for the width results in the percent scaling for the height (the OutputSizePercentYFloat property) being set to the same value.

See also


FBExportToAVIParams::OutputSizePercentY

BB FlashBack SDK: FBExportToAVIParams

OutputSizePercentY

Description

Returns and sets the percentage scaling applied to the height of the movie, when exported.

Note: this parameter is deprecated in favour of OutputSizePercentYFloat.

Syntax

[C#/C++]
public long OutputSizePercentY;

[VB.NET]
Public Property OutputSizePercentY As Long

Remarks

If OutputSizeKeepAspectRatio is set to True, changing the percent scaling for the height results in the percent scaling for the width (the OutputSizePercentX property) being set to the same value.

See also

FBExportToAVIParams:OutputSizeKeepAspectRatio FBExportToAVIParams::OutputSizePercentX

FBExportToAVIParams::OutputSizePercentYFloat


OutputSizePercentYFloat

BB FlashBack SDK: FBExportToAVIParams

OutputSizePercentYFloat

Description

Returns and sets the percentage scaling applied to the height of the movie, when exported.

Syntax

[C#/C++]
public float OutputSizePercentYFloat;

[VB.NET]
Public Property OutputSizePercentYFloat As Single

Remarks

If OutputSizeKeepAspectRatio is set to True, changing the percent scaling for the height results in the percent scaling for the width (the OutputSizePercentXFloat property) being set to the same value.

See also


FBExportToAVIParams::ShowOptions

BB FlashBack SDK: FBExportToAVIParams

ShowOptions

Description

Determines the action taken on passing the FBExportToAVIParams object to FBMovie::ExportToAVI.

Syntax

[C#/C++]
public Bool ShowOptions;

[VB.NET]
Public Property ShowOptions As Boolean

Remarks

If ShowOptions is set to True, and the FBExportToAVIParams object is passed to the FBMovie::ExportToAVI method, a dialog is displayed that enables the user to set export parameters.

If ShowOptions is set to False, and the FBExportToAVIParams object is passed to the FBMovie::ExportToAVI method, the export uses the properties of the FBExportToAVIParams object and does not show the export options dialog.

See Also

FBMovie::ExportToAVI


FBExportToAVIParams::SoundCompressFormat

BB FlashBack SDK: FBExportToAVIParams

SoundCompressFormat

Description

Determines whether MP3 compression or no compression at all should be used in the exported AVI file.

Syntax

[C#/C++]
public long SoundCompressFormat;

[VB.NET]
Public Property SoundCompressFormat As Long

Remarks

This can be one of the following standard Win32 SDK constants:

WAVE_FORMAT_PCM = 1

WAVE_FORMAT_MPEGLAYER3 = 85

AVI files exported with sound in PCM (uncompressed) format may be much larger than those exported from the same movie using MP3 format.

See Also

FBExportToAVIParams::SoundMP3Profile


FBExportToAVIParams::SoundFormat

BB FlashBack SDK: FBExportToAVIParams

SoundFormat

Description

Sets the sound format used in the exported AVI file.

Syntax

[C#/C++]
public long SoundFormat;

[VB.NET]
Public Property SoundFormat As Long

Remarks

This can be one of the following standard Win32 SDK constants, describing the number of channels, sample rate and bits per sample:

Value |  | Format
WAVE_FORMAT_1M08 | 0x00000001 | 11.025 kHz, mono, 8-bit.
WAVE_FORMAT_1S08 | 0x00000002 | 11.025 kHz, stereo, 8-bit.
WAVE_FORMAT_1M16 | 0x00000004 | 11.025 kHz, mono, 16-bit.
WAVE_FORMAT_1S16 | 0x00000008 | 11.025 kHz, stereo, 16-bit.
WAVE_FORMAT_2M08 | 0x00000010 | 22.05 kHz, mono, 8-bit.
WAVE_FORMAT_2S08 | 0x00000020 | 22.05 kHz, stereo, 8-bit.
WAVE_FORMAT_2M16 | 0x00000040 | 22.05 kHz, mono, 16-bit.
WAVE_FORMAT_2S16 | 0x00000080 | 22.05 kHz, stereo, 16-bit.
WAVE_FORMAT_4M08 | 0x00000100 | 44.1 kHz, mono, 8-bit.
WAVE_FORMAT_4S08 | 0x00000200 | 44.1 kHz, stereo, 8-bit.
WAVE_FORMAT_4M16 | 0x00000400 | 44.1 kHz, mono, 16-bit.
WAVE_FORMAT_4S16 | 0x00000800 | 44.1 kHz, stereo, 16-bit.
WAVE_FORMAT_48M08 | 0x00001000 | 48 KHz, Mono, 8 bit
WAVE_FORMAT_48S08 | 0x00002000 | 48 KHz, Stereo, 8 bit
WAVE_FORMAT_48M16 | 0x00004000 | 48 KHz, Mono, 16 bit
WAVE_FORMAT_48S16 | 0x00008000 | 48 KHz, Stereo, 16 bit
WAVE_FORMAT_96M08 | 0x00010000 | 96 KHz, Mono, 8 bit
WAVE_FORMAT_96S08 | 0x00020000 | 96 KHz, Stereo, 8 bit
WAVE_FORMAT_96M16 | 0x00040000 | 96 KHz, Mono, 16 bit
WAVE_FORMAT_96S16 | 0x00080000 | 96 KHz, Stereo, 16 bit

If SoundFormat is set to zero, the format used on export is determined by the format of the sounds in the movie. See UseBestFormat for more details.

See also

FBExportToAVIParams::UseBestFormat


FBExportToAVIParams::SoundMP3Profile

BB FlashBack SDK: FBExportToAVIParams

SoundMP3Profile

Description

Sets the level of MP3 compression to be used in the exported AVI file.

Syntax

[C#/C++]
public long SoundMP3Profile;

[VB.NET]
Public Property SoundMP3Profile As Long

Remarks

SoundMP3Profile can be one of the following constants:

Value | Audio Quality
0 | Normal
1 | Low
2 | High
5 | Very high

Higher audio quality means less compression and larger file sizes.

This property is ignored if SoundCompressFormat is not set to MP3.

See Also

FBExportToAVIParams::SoundCompressFormat


UseAVI10Format

BB FlashBack SDK: FBExportToAVIParams

UseAVI10Format

Description

Specifies whether to export an AVI in version 1.0 or 2.0 format.

Syntax

[C#/C++]
public Bool UseAVI10Format;

[VB.NET]
Public Property UseAVI10Format As Boolean

Remarks

Some movie players only support AVI version 1.0 files.

If AVI format version 1.0 is used, AVI files cannot be larger than 4Gb.

AVI format 2.0 supports very large file sizes, and has a different indexing structure that benefits large files.

This works in connection with the SoundFormat property to allow the SDK to automatically determine the sound format to use on export, based on the format of the various sounds in the movie.


FBExportToAVIParams::UseBestFormat

BB FlashBack SDK: FBExportToAVIParams

UseBestFormat

Description

This works in connection with the SoundFormat property to allow the SDK to automatically determine the sound format to use on export, based on the format of the various sounds in the movie.

Syntax

[C#/C++]
public Bool UseBestFormat;

[VB.NET]
Public Property UseBestFormat As Boolean

Remarks

If SoundFormat is set to zero, the value of UseBestFormat determines the sound format to be used on export.

If a movie contains more than one sound file, all sounds have to mixed to a single format before being exported to AVI. Setting UseBestFormat to True means the highest quality format used by any sound in the movie will be used for the export format. Setting UseBestFormat to False means all sounds are mixed to the lowest quality format used by any sound in the movie.

For example, if a movie has two sounds: one at 44Khz and one at 22Khz:

  • SoundFormat = 0 and UseBestFormat = True : all sounds mixed to 44Khz before export

  • SoundFormat = 0 and UseBestFormat = False : all sounds mixed to 22Khz before export

  • SoundFormat != 0 : all sounds are mixed to whatever format is indicated in SoundFormat.

See Also

FBExportToAVIParams::SoundFormat


About BB FlashBack SDK Flash exports

BB FlashBack SDK: FBExportToSWFParams

About BB FlashBack SDK Exports

BB FlashBack SDK can export Flash in one of two ways:

  • Single SWF
    The movie and playback controls are combined in one SWF file, named after the current FBR movie file. For a movie named MyMovie.FBR, the exported file will be named MyMovie.SWF.

    If you plan to embed the movie in a PDF file, a single SWF is required. If you are using an HTML editor like DreamWeaver to embed the movie in a page, this may also require a single SWF.

    If you want to have the movie not download until clicked, you need to export as multiple SWFs. Set this behavior using the StartingPlaybackMode property.

    To export the movie as a single SWF, set the SingleSwf property to True.

  • Multiple SWF
    The movie and playback controls are in separate SWF files, named as <moviename>_toolbar.swf and <moviename>.swf.

    The "_toolbar" SWF should be embedded in webpages - it loads the movie SWF. Movies exported as multiple SWFs cannot be embedded in PDF and you may have problems embedding them into webpages using HTML editors such as DreamWeaver.

    The advantage of exporting as multiple SWFs over a single SWF is that you can set 'do not download until clicked' behavior using the StartingPlaybackMode property.

    To export the movie as multiple SWFs, set the SingleSwf property to False.


Passing Parameters to Flash Exports

BB FlashBack SDK: FBExportToSWFParams

Passing Parameters to Flash Exports

When you set properties of the FBExportToSWFParams class and export to Flash, the settings of these properties are passed to the exported SWF via FlashVars.

If the export is embedded in a webpage, the FlashVars are set within the HTML code, e.g.

<OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,28;"
WIDTH=960 HEIGHT=624>

...

<param name="flashVars" value="scaleMode=noScale&showToolbar=true&topToolbar=false..." >

<EMBED src="48ksoundtest2_toolbar.swf"
flashVars="scaleMode=noScale&showToolbar=true&topToolbar=false..." >

...

</EMBED>

</OBJECT>

When BB FlashBack SDK performs a Flash export, it generates an additional HTML file that contains code that embeds the SWF file and passes the FlashVars to it. This HTML file is named as the SWF filename passed in to FBMovie::ExportToSWF

When embedding the export in a PDF or other document, FlashVars are set from the application (e.g. Acrobat, Powerpoint) you use to embed the SWF file.

List of Properties passed via FlashVars

Property | FlashVar
ScaleMode | scaleMode
AddControlBar | showToolbar
ControlBarPosMode | topToolbar - set to True if the toolbar is above the movie, and false if below it
ShowFullScreen | showFullScreen And setting ShowFullScreen to True creates an additional parameter in the embedding HTML of the form <param name="allowFullScreen" value="True">
ControlBarAutoHide | autoHide
ShowAutoHide | showAutoHide
ShowTimer | showTimer
ShowTimeline | showTimeline
ShowNextPrev | showNextButton
ShowNextPrev | showPrevButton
ShowFBLogo | showFBLogo
ShowVolumeBar | showVolumeBar
PreviewMode | previewMode
ShowPausedOverlay | showPausedOverlay
PauseByClickingOnMovie | pauseByClickingOnMovie
StartingPlaybackMode | startingPlaybackMode
PreloadPercent | preloadPercent

Also passed in via FlashVars:

fileName: the name of the SWF or FLV file containing the movie, if FLV or multiple SWF export is used.

And 3 strings shown on the playback controls:

str1: string shown at the top of the popup window displayed when the BB FlashBack logo at the right end of the playback controls is clicked.

str2: the string shown at the top of the popup window that opens www.bbflashback.com when clicked

str3: the label for the Auto hide button


Restricting usage of exported SWF files

BB FlashBack SDK: FBExportToSWFParams

Restricting usage of exported SWF files

SWF files can be embedded and played back from web pages and other SWF files that exist in completely different domain than the embedded SWF movie.

You may want to impose security restrictions on SWFs you export, so that they cannot be copied and used on a third party website or embedded within third party web pages or SWF files. The SecureDomain and SecureCode properties allow you to do this - see Using the SecureDomain and SecureCode features for details.


Using the SecureDomain and SecureCode features

BB FlashBack SDK: FBExportToSWFParams

Using the SecureDomain and SecureCode features

The SecureDomains and SecureCode properties can be used to restrict how the exported SWF can be played back from third party domains, webpages and SWF files.

1. UseSecureDomain = False and UseSecureCode = false

  • The SWF can only be called from other SWFs that are in the same domain.

  • The SWF can be played back inside webpages in any domain.

2. UseSecureDomain = True and SecureDomain="www.abc.com" and UseSecureCode = false

  • The SWF can be called from any other SWFs in the "www.abc.com" domain.

  • The SWF can be played back from webpages in any domain.

3. UseSecureDomain = True and SecureDomains = "www.abc.com" and UseSecureCode = true and SecureCode = "abc"

  • The SWF can only be called from other SWFs that are in the "www.abc.com" domain and pass the code to the play() method.

  • The SWF can not be played back from any webpages in any domain.

4. UseSecureDomain = False and UseSecureCode = True and SecureCode = "abc"

  • The SWF can be played only from SWFs in the same domain that pass the code to the play() method.

  • The SWF cannot be played back from webpages in any domain.

See also


An note about ZoomPan effects and SWF exports

BB FlashBack SDK: FBExportToSWFParams

ZoomPan object data in SWF exports

If an exported movie contains a ZoomPan effect, and FBExportToSWFParams::ExportZoomPanInfo is set to True, each frame of the exported SWF file in which a ZoomPan is active contains ActionScript code setting variables that describe the size and position of the displayed area. These variable can be used by developers for their own purposes.

The names of the variables:

ZoomPan_XPos
ZoomPan_YPos
ZoomPan_Width
ZoomPan_Height


FBExportToSWFParams::AddControlBar

BB FlashBack SDK: FBExportToSWFParams

AddControlBar

Description

Sets whether a control bar SWF is attached to the exported movie, to allow the user to control playback.

Syntax

[C#/C++]
public Bool AddControlBar;

[VB.NET]
Public Property AddControlBar As Boolean

Remarks

Set to True to have a control bar in the exported movie.

The ControlBarMode and ControlBarName properties define whether a pre-defined or custom control bar will be used.

ControlBarPosMode and ControlBarPosOver define the position of the control bar in relation to the movie.

See also


AS3

BB FlashBack SDK: FBExportToSWFParams

AS3

Description

Determines whether exports without playback controls and only to a single SWF use ActionScript v3 (ActionScript Virtual Machine v2) or ActionScript v2.

Syntax

[C#/C++]
public bool AS3;

[VB.NET]
Public Property AS3 As Boolean

Remarks

IF the export is defined to have no playback controls (defined via the AddControlBar property), AND it is to a single SWF (defined via the SingleSwf property) AND the AS3 property = true THEN the exported SWF uses ActionScript 3 and AVM 2. Otherwise it will use ActionScript 2 and AVM 1.

See also


FBExportToSWFParams::AutoscrollDimX

BB FlashBack SDK: FBExportToSWFParams

AutoscrollDimX

Description

Returns and sets the width of the autoscroll frame.

Syntax

[C#/C++]
public long AutoscrollDimX;

[VB.NET]
Public Property AutoscrollDimX As Long

Remarks

The autoscroll feature keeps the mouse cursor at or near the middle of the exported movie by automatically scrolling the 'autoscroll frame'.

Autoscroll is enabled by setting AutoscrollMode to True. The autoscroll frame dimensions are specified by the AutoscrollDimX and AutoscrollDimY properties.

See also


FBExportToSWFParams::AutoscrollDimY

BB FlashBack SDK: FBExportToSWFParams

AutoscrollDimY

Description

Returns and sets the height of the autoscroll frame.

Syntax

[C#/C++]
public long AutoscrollDimY;

[VB.NET]
Public Property AutoscrollDimY As Long

Remarks

The autoscroll feature keeps the mouse cursor at or near the middle of the exported movie by automatically scrolling the 'autoscroll frame'.

Autoscroll is enabled by setting AutoscrollMode to True. The autoscroll frame dimensions are specified by the AutoscrollDimX and AutoscrollDimY properties.

See also


FBExportToSWFParams::AutoscrollMode

BB FlashBack SDK: FBExportToSWFParams

AutoscrollMode

Description

Returns and sets a value indicating whether autoscroll will be used during export.

Syntax

[C#/C++]
public Bool AutoscrollMode;

[VB.NET]
Public Property AutoscrollMode As Boolean

Remarks

Set this property to True to enable autoscroll.

The autoscroll feature keeps the mouse cursor at or near the middle of the exported movie by automatically scrolling the 'autoscroll frame'.

The autoscroll frame dimensions are specified by the AutoscrollDimX and AutoscrollDimY properties.

See also


FBExportToSWFParams::AutoStartPlay

BB FlashBack SDK: FBExportToSWFParams

AutoStartPlay

Description

Determines whether the movie starts playing as soon as it is loaded.

Syntax

[C#/C++]
public Bool AutoStartPlay;

[VB.NET]
Public Property AutoStartPlay As Boolean

Remarks

Set to True to have the movie start playing as soon as it is able. Because Flash movies stream to the end-user's PC, it may start playing before the entire movie has downloaded.


FBExportToSWFParams::BitsCount

BB FlashBack SDK: FBExportToSWFParams

BitsCount

Description

Sets the color depth - the number of bits per pixel - used on export. More bits means a more accurate range of colors, but can mean a larger SWF file.

Syntax

[C#/C++]
public long BitsCount;

[VB.NET]
Public Property BitsCount As Long

Remarks

When lossless compression is set via the ColorFormat property, the only valid values for BitsCount are 8, 16, 32. Behavior with other values is undefined.

When JPEG compression is set via the ColorFormat property, the only valid values for BitsCount are 8, 24. Behavior with other values is undefined.

See also

FBExportToSWFParams:ColorFormat


FBExportToSWFParams::ColorFormat

BB FlashBack SDK: FBExportToSWFParams

ColorFormat

Description

Determines whether images will be stored with lossless or JPEG compression in the SWF file.

Syntax

[C#/C++]
public long ColorFormat;

[VB.NET]
Public Property ColorFormat As Long

Remarks

Can be one of two values, defined in the Win32 platform SDK:

BI_RGB (=0) : images stored with lossless compression.

BI_JPG (=4) : images stored with JPEG compression.

If lossless compression is used, the CompressLevel property determines the amount of compression. The only valid values for BitsCount are 8, 16, 32. Behavior with other values is undefined.

If JPEG compression is used, the JPEGQuality property determines the amount of compression. The only valid values for BitsCount are 8, 24. Behavior with other values is undefined.

See also


FBExportToSWFParams::CompressLevel

BB FlashBack SDK: FBExportToSWFParams

CompressLevel

Description

Determines the amount of compression applied to images, when lossless compression has been selected via the ColorFormat property.

Syntax

[C#/C++]
public long CompressLevel;

[VB.NET]
Public Property CompressLevel As Long

Remarks

This value in the range 1-9, where 1 is the least and 9 the maximum compression. The higher the compression, the smaller the SWF file, but the longer the export will take.

This compression level is also applied to various other data compressed into the SWF, even when JPEG image compression is used.

See also

FBExportToSWFParams::ColorFormat


ToolbarAutoHide

BB FlashBack SDK: FBExportToSWFParams

ControlBarAutoHide

Description

Determines whether the 'control bar' containing playback controls automatically hides itself.

Syntax

[C#/C++]
public Bool ControlBarAutoHide;

[VB.NET]
Public Property ControlBarAutoHide As Boolean

Remarks

If set to True, the control bar will automatically hide itself after a few seconds of playback. It can be un-hidden by the user if they move the mouse pointer into the top part of the movie.

They can also manually set it to auto-hide via a checkbox on the control bar itself, on the pre-installed control bars.

See also


FBExportToSWFParams::ControlBarMode

BB FlashBack SDK: FBExportToSWFParams

ControlBarMode

Description

Determines what control bar will be embedded into the exported SWF file.

Syntax

[C#/C++]
public long ControlBarMode;

[VB.NET]
Public Property ControlBarMode As Long

Remarks

SWF exports can optionally (determined by AddControlBar) contain a set of playback controls that can be used to stop, pause, jump forwards and backwards in the movie, etc.

ControlBarMode selects either one of the pre-defined control bars or a custom control bar SWF file.

Value | Control bar used
-1 | Custom control bar SWF.
0 | 'metallic'
1 | 'cool white'
2 | 'media player'

If a custom control bar is selected, the name of the SWF file should be defined in the ControlBarName property.

More about custom control bars

FlashBack SDK allows you to create your own playback controls for use in Flash exports. These need to be supplied in the form of an SWF file that contains some specific objects needed to make the export work.

To be able to create the SWF file, you will need a Flash authoring package like Macromedia Flash. This help text assumes knowledge of authoring Flash movies.

The SWF you produce will need to conform to these requirements:

  • The main movie surface can have any dimensions.

  • There are must be two MOVIE CLIPs on the main surface:

    • An empty clip with the name 'SWFplaceholder' at the position (0, 0). The SDK will insert its movie here during the export process.

    • The controls clip with the name 'Controls' at any position.

  • The Controls clip should be at least as wide as the exported FlashBack movie.

  • The Controls clip manages the SWFplaceholder clip via standard ActionScript commands (play, pause, stop etc.)

  • The Controls clip should not be scaled, since its size is used in calculating the dimensions of the movie.

See also


FBExportToSWFParams::ControlBarName

BB FlashBack SDK: FBExportToSWFParams

ControlBarName

Description

The name of a custom SWF file, to be used as the SWF export control bar.

Syntax

[C#/C++]
public String ControlBarName;

[VB.NET]
Public Property ControlBarName As String

Remarks

This file name is only used if ControlBarMode is set to -1. Otherwise, a pre-defined control bar is used.

See also


FBExportToSWFParams::ControlBarPosMode

BB FlashBack SDK: FBExportToSWFParams

ControlBarPosMode

Description

Determines where the control bar will be positioned on the SWF movie.

Syntax

[C#/C++]
public Long ControlBarPosMode;

[VB.NET]
Public Property ControlBarPosMode As Long

Remarks

Can be one of these values:

Value | Control bar position
0 | Not explicitly positioned by the container code of the movie - the position is determined by the control bar SWF.
1 | Top of movie
2 | Bottom of movie

See also


FBExportToSWFParams::ControlBarPosOver

BB FlashBack SDK: FBExportToSWFParams

ControlBarPosOver

Description

Determines whether the control bar will be positioned on top of the movie or above/below it.

Syntax

[C#/C++]
public long ControlBarPosOver;

[VB.NET]
Public Property ControlBarPosOver As Long

Remarks

Set this value to True to have the control bar be positioned on top of the movie, overlapping it.

Set this value to False to have it positioned above or below the movie.

See also


ExportSound

BB FlashBack SDK: FBExportToSWFParams

ExportSound

Description

Determines whether any sound in the movie will be exported with the video.

Syntax

[C#/C++]
public bool ExportSound;

[VB.NET]
Public Property ExportSound As Boolean

See also


ExportZoomPanInfo

BB FlashBack SDK: FBExportToSWFParams

ExportZoomPanInfo

Description

Enables export of ZoomPan area information in each frame of the SWF that contains an active ZoomPan rectangle.

Syntax

[C#/C++]
public Bool ExportZoomPanInfo;

[VB.NET]
Public Property ExportZoomPanInfo As Boolean

Remarks

When this property is set to true, and the exported movie contains ZoomPan objects, each frame of the movie in which a ZoomPan affects the view contains ActionScript that describes the size and position of the ZoomPan rectangle.

The ActionScript sets these 4 variables to pixel values:

ZoomPan_XPos
ZoomPan_YPos
ZoomPan_Width
ZoomPan_Height

See also

The FBZoomPanProperties class


FlashVersion

BB FlashBack SDK: FBExportToSWFParams

FlashVersion

Description

Gets the version of the Flash player that will be required to play the export.

Playback in fullscreen mode requires Flash Player version 9.0.28 and above. Exporting with the ShowFullScreen property set to True gives the user the option of selecting fullscreen mode during playback.

If fullscreen mode is not required, Flash exports from the FlashBack SDK require Flash player version 6 and above.

Syntax

[C#/C++]
public Long FlashVersion;

[VB.NET]
Public Property FlashVersion As Long


FBExportToSWFParams::FrameRateCustom

BB FlashBack SDK: FBExportToSWFParams

FrameRateCustom

Description

Sets the frame rate, in frames per second, at which to export, when a 'custom' frame rate has been selected via the FrameRateMode property.

Syntax

[C#/C++]
public long FrameRateCustom;

[VB.NET]
Public Property FrameRateCustom As Long

Remarks

This property is only used when FrameRateMode is set to 3.

See Also

FBExportToSWFParams::FrameRateMode


FBExportToSWFParams::FrameRateMode

BB FlashBack SDK: FBExportToSWFParams

FrameRateMode

Description

Sets the frame rate at which to export.

Syntax

[C#/C++]
public long FrameRateMode;

[VB.NET]
Public Property FrameRateMode As Long

Remarks

Can be one of these values:

Value | Frame rate
0 | Same frame rate as the native FBR movie recording.
1 | 1/2 frame rate of movie.
2 | 1/4 frame rate of movie.
3 | Frame rate defined by the FrameRateCustom property.

The default frame rate for movies recorded with the capture driver is 25fps.

See Also

FBExportToSWFParams::FrameRateCustom


FBExportToSWFParams::HighlightMouseClicks

BB FlashBack SDK: FBExportToSWFParams

HighlightMouseClicks

Description

Determines whether mouse clicks are highlighted with animating circles in the exported movie.

Syntax

[C#/C++]
public Bool HighlightMouseClicks;

[VB.NET]
Public Property HighlightMouseClicks As Boolean


HTMLTemplate

BB FlashBack SDK: FBExportToSWFParams

HTMLTemplate

Description

Sets the file name of an HTML template that will be used to display the exported SWF file.

Syntax

[C#/C++]
public String HTMLTemplate;

[VB.NET]
Public Property HTMLTemplate As String

Remarks

If the property contains a ":" or "/" character, it is assumed to be the fully qualified path to an HTML template file.

If it does not, it is assumed to be the name (minus the ".html" extension) of an HTML template file in the "Blueberry\Templates" subfolder located within the Windows APPDATA folder - the folder obtained from the SHGetFolderPath Win32 API, passing in a folder ID of CSIDL_APPDATA.

On Windows XP, this folder could be:
C:\Documents and Settings\<username>\Application Data\Blueberry\Templates

About HTML Template Files

When the SDK produces an SWF export file, it also produces an HTML file that is used to view the SWF. This is for two reasons:

  1. Many PCs cannot directly open an SWF file.

  2. The SWF movie will most likely be displayed by being embedded in a web page, so its useful to have the HTML code that performs this embedding.

The HTML file produced has the same file name as the SWF file, but with a .html extension instead. If the .html and .swf files are in the same folder, when the .html file is opened, it displays and plays back the SWF movie.

By default, the HTML file is a very simple page that embeds the SWF file via an <object> tag. The HTMLTemplate tag allows you to replace this simple page with HTML of your own.

The HTMLTemplate property should contain the HTML code for a complete page, plus two special tags that will be used by the export process:

  • <SWFTITLE> - will be replaced by the filename of the .FBR file being exported.

  • <SWFOBJECT> - will be replaced by a <OBJECT> tag that displays the SWF movie.


JPEGQuality

BB FlashBack SDK: FBExportToSWFParams

JPEGQuality

Description

Determines the level of JPEG compression used on images contained in the SWF export.

Syntax

[C#/C++]
public Long JPEGQuality;

[VB.NET]
Public Property JPEGQuality As Long

Remarks

This value can range from 1 to 100, where:

1 = maximum compression, minimum quality.

100 = minimum compression, maximum quality.

This value is only used if JPEG compression has been selected via the ColorFormat property.

See also


MXCompression

BB FlashBack SDK: FBExportToSWFParams

MXCompression

Description

Determines whether MX compression is used in the SWF export file.

Syntax

[C#/C++]
public Bool MXCompression;

[VB.NET]
Public Property MXCompression As Boolean

Remarks

MX compression can significantly reduce the size of the SWF file. However, SWF files that use MX compression require Flash player version 6 and above for playback.


NotScaleInFullScreen

BB FlashBack SDK: FBExportToSWFParams

NotScaleInFullScreen

Description

If this is set to True, when the movie is played in fullscreen mode (i.e. when the user clicks the 'fullscreen' button during playback) it does not scale to fit the PC screen, but remains at the exported dimensions and the screen is padded with white.

If set to False, the movie scales to fit the screen when in fullscreen mode, as seen on YouTube and similar video hosting services.

Syntax

[C#/C++]
public Bool NotScaleInFullScreen;

[VB.NET]
Public Property NotScaleInFullScreen As Boolean

See Also

FBExportToSWFParams::ShowFullScreen


FBExportToSWFParams::OutputSizeKeepAspectRatio

BB FlashBack SDK: FBExportToSWFParams

OutputSizeKeepAspectRatio

Description

Returns and sets the value that determines whether the aspect ratio of the movie is maintained when its width or height are altered via the OutputSizePercentXFloat, OutputSizePercentYFloat, OutputSizeX or OutputSizeY properties.

Syntax

[C#/C++]
public Bool OutputSizeKeepAspectRatio;

[VB.NET]
Public Property OutputSizeKeepAspectRatio As Boolean

Remarks

If this property is set to True, altering OutputSizePercentX or OutputSizePercentY automatically changes the other percentage to the same value, to maintain the aspect ratio of the movie.

See also

FBExportToSWFParams::ScaleToPercents FBExportToSWFParams::OutputSizePercentXFloat FBExportToSWFParams::OutputSizePercentYFloat FBExportToSWFParams::OutputSizeY FBExportToSWFParams::OutputSizeX

Deprecated: FBExportToSWFParams:OutputSizePercentX FBExportToSWFParams::OutputSizePercentY


FBExportToSWFParams::OutputSizePercentX

BB FlashBack SDK: FBExportToSWFParams

OutputSizePercentX

Description

Returns and sets the percentage scaling applied to the width of the movie, when exported.

Note: this parameter is deprecated in favour of OutputSizePercentXFloat.

Syntax

[C#/C++]
public long OutputSizePercentX;

[VB.NET]
Public Property OutputSizePercentX As Long

Remarks

If OutputSizeKeepAspectRatio is set to True, changing the percent scaling for the width results in the percent scaling for the height (the OutputSizePercentY property) being set to the same value.

See also


OutputSizePercentXFloat

BB FlashBack SDK: FBExportToSWFParams

OutputSizePercentXFloat

Description

Returns and sets the percentage scaling applied to the width of the movie, when exported.

Syntax

[C#/C++]
public float OutputSizePercentXFloat;

[VB.NET]
Public Property OutputSizePercentXFloat As Single

Remarks

If OutputSizeKeepAspectRatio is set to True, changing the percent scaling for the width results in the percent scaling for the height (the OutputSizePercentYFloat property) being set to the same value.

See also


FBExportToSWFParams::OutputSizePercentY

BB FlashBack SDK: FBExportToSWFParams

OutputSizePercentY

Description

Returns and sets the percentage scaling applied to the height of the movie, when exported.

Note: this parameter is deprecated in favour of OutputSizePercentYFloat.

Syntax

[C#/C++]
public long OutputSizePercentY;

[VB.NET]
Public Property OutputSizePercentY As Long

Remarks

If OutputSizeKeepAspectRatio is set to True, changing the percent scaling for the height results in the percent scaling for the width (the OutputSizePercentX property) being set to the same value.

See also


OutputSizePercentYFloat

BB FlashBack SDK: FBExportToSWFParams

OutputSizePercentYFloat

Description

Returns and sets the percentage scaling applied to the height of the movie, when exported.

Syntax

[C#/C++]
public float OutputSizePercentYFloat;

[VB.NET]
Public Property OutputSizePercentYFloat As Single

Remarks

If OutputSizeKeepAspectRatio is set to True, changing the percent scaling for the width results in the percent scaling for the height (the OutputSizePercentXFloat property) being set to the same value.

See also


OutputSizeX

BB FlashBack SDK: FBExportToSWFParams

OutputSizeX

Description

Returns and sets the width of the movie in pixels, when exported.

Syntax

[C#/C++]
public long OutputSizeX;

[VB.NET]
Public Property OutputSizeX As Long

Remarks

If OutputSizeKeepAspectRatio is set to True, changing the width results in the height (the OutputSizeY property) being set accordingly.

See also


OutputSizeY

BB FlashBack SDK: FBExportToSWFParams

OutputSizeY

Description

Returns and sets the height of the movie in pixels, when exported.

Syntax

[C#/C++]
public long OutputSizeY;

[VB.NET]
Public Property OutputSizeY As Long

Remarks

If OutputSizeKeepAspectRatio is set to True, changing the height results in the width (the OutputSizeX property) being set accordingly.

See also


PauseByClickingOnMovie

BB FlashBack SDK: FBExportToSWFParams

PauseByClickingOnMovie

Description

Set to true to enable pause and restart of playback by clicking on the movie.

Syntax

[C#/C++]
public Bool PauseByClickingOnMovie;

[VB.NET]
Public Property PauseByClickingOnMovie As Boolean

See Also

FBExportToSWFParams::ShowPausedOverlay


PreloadPercent

BB FlashBack SDK: FBExportToSWFParams

PreloadPercent

Description

Flash movies can start playback before the entire movie is downloaded. This property sets the percentage of the movie file that will be downloaded before playback starts.

Syntax

[C#/C++]
public long PreloadPercent;

[VB.NET]
Public Property PreloadPercent As Long

Remarks

The default value is zero. When set to zero, code in the SWF file will make a decision on whether to start playback or not, depending on the download rate and number of bytes left to download.

Setting this to a non-zero value overrides this processing, and playback will start when the specified percentage of the movie has been downloaded, regardless of the transfer rate.


PreviewMode

BB FlashBack SDK: FBExportToSWFParams

PreviewMode

Description

Determines whether a first frame 'preview image' will be shown before the movie starts to play, and whether it will be stored in a separate SWF file.

Syntax

[C#/C++]
public long PreviewMode;

[VB.NET]
Public Property PreviewMode As Long

Remarks

Value | Control bar used
0 | No preview image
1 | Preview image stored in same "_toolbar" SWF file as the playback controls
2 | Preview image stored in a separate "_preview" SWF file

Note: If the SingleSWF property is true and the PrevieMode property is set to either 1 or 2, the preview image is always included in that SWF. See About BB FlashBack SDK Flash Exports for further details about exporting single or multiple SWFs.

See also

FBExportToSWFParams:SingleSWF


ScaleMode

BB FlashBack SDK: FBExportToSWFParams

ScaleMode

Description

This property determines whether the SWF movie can be scaled during playback.

Syntax

[C#/C++]
public bool ScaleMode;

[VB.NET]
Public Property ScaleMode As Boolean

Remarks

If ScaleMode is false, the SWF will not be displayed scaled, even if the player window is larger or smaller than the originally exported size.

If ScaleMode is true, the SWF will scale to the size of the player, though Flash player scaling is not smooth/bilinear - it can result in low image quality.


ScaleToPercents

BB FlashBack SDK: FBExportToSWFParams

ScaleToPercents

Description

Determines whether percent scaling or pixel sizes should be used to set the dimensions of the exported movie.

The parameters OutputSizeX and OutputSizeY set the pixel size.

The parameters OutputSizePercentXFloat and OutputSizePercentYFloat (and the deprecated parameters OutputSizePercentX and OutputSizePercentY) set the percent scaling.

Syntax

[C#/C++]
public Bool ScaleToPercents;

[VB.NET]
Public Property ScaleToPercents As Boolean

See Also

FBExportToSWFParams:OutputSizeKeepAspectRatio FBExportToSWFParams::OutputSizePercentXFloat FBExportToSWFParams::OutputSizePercentYFloat FBExportToSWFParams::OutputSizeY FBExportToSWFParams::OutputSizeX

Deprecated: FBExportToSWFParams::OutputSizePercentX FBExportToSWFParams::OutputSizePercentY


SecureCode

BB FlashBack SDK: FBExportToSWFParams

SecureCode

Description

Sets a code that prevents the SWF from being played via a second, third party, SWF.

Syntax

[C#/C++]
public String SecureCode;

[VB.NET]
Public Property SecureCode As String

Remarks

The SecureCode property contains a user defined string that must be passed to the play() method of the SWF in order to play it back successfully. In this way, the exported SWF cannot be embedded and played back in a third party SWF.

To embed and play back an SWF exported with this secure code option, it should be called as:

submovie.play(sSecureCode)

For details of how the SecureDomains and SecureCode properties work together to set restrictions on exported SWF usage, see Using the SecureDomains and SecureCode features.

Note: be aware that setting UseSecureCode to True will produce SWF files that cannot be played back from webpages.

See also


SecureDomain

BB FlashBack SDK: FBExportToSWFParams

SecureDomains

Description

Sets the domains at which the exported SWF, or the webpage or SWF containing it must be hosted - it will not play when called from SWF files hosted in other domains.

Syntax

[C#/C++]
public String SecureDomains;

[VB.NET]
Public Property SecureDomains As String

Remarks

The SecureDomains property should contain a list of comma separated domains, e.g. "www.xyz.com,www.mydomain.com". This defines the domains that the exported SWF must be hosted in, to enable playback.

This domain list is only used if UseSecureDomain is set to True - otherwise the SWF can only be called from other SWFs that are in the same domain, although it may be embedded in web pages in any domain.

SWF files that use this feature require Flash player version 6 or newer for playback.

For details of how the SecureDomains and SecureCode properties work together to set restrictions on exported SWF usage, see Using the SecureDomains and SecureCode features.

See also


ShowAutoHide

BB FlashBack SDK: FBExportToSWFParams

ShowAutoHide

Description

Determines whether to show the Auto Hide control on the exported SWF control bar, if the AddControlBar property is set to true.

Syntax

[C#/C++]
public Bool ShowAutoHide;

[VB.NET]
Public Property ShowAutoHide As Boolean

See Also

FBExportToSWFParams::ShowFBLogo FBExportToSWFParams::ShowVolumeBar FBExportToSWFParams::ShowFullScreen FBExportToSWFParams::ShowTimer FBExportToSWFParams::ShowTimeline FBExportToSWFParams::ShowNextPrev


ShowFBLogo

BB FlashBack SDK: FBExportToSWFParams

ShowFBLogo

Description

Determines whether to show the FlashBack logo control on the exported SWF control bar, if the AddControlBar property is set to true.

The FlashBack logo control is a small FlashBack icon at the right end of the control bar. When clicked it shows a menu, which if clicked opens the Blueberry Software website (www.bbsoftware.co.uk) in a new browser window.

Syntax

[C#/C++]
public Bool ShowFBLogo;

[VB.NET]
Public Property ShowFBLogo As Boolean

See Also

FBExportToSWFParams::ShowAutoHide FBExportToSWFParams::ShowVolumeBar FBExportToSWFParams::ShowFullScreen FBExportToSWFParams::ShowTimer FBExportToSWFParams::ShowTimeline FBExportToSWFParams::ShowNextPrev


ShowFullScreen

BB FlashBack SDK: FBExportToSWFParams

ShowFullScreen

Description

Determines whether to show the fullscreen button control on the exported SWF control bar, if the AddControlBar property is set to true. This allows the user to display the movie in fullscreen mode.

If the fullscreen option is offered to the user, Flash player version 9.0.28.0 or later is required.

Syntax

[C#/C++]
public Bool ShowFullScreen;

[VB.NET]
Public Property ShowFullScreen As Boolean

Remarks

The properties of FBExportToSWFParams are passed to the exported SWF via FlashVars. For more details, see Passing Parameters to Flash Exports.

Setting ShowFullScreen to True creates an additional parameter in the embedding HTML of the form
<param name="allowFullScreen" value="True">

See Also

FBExportToSWFParams::ShowAutoHide FBExportToSWFParams::ShowFBLogo FBExportToSWFParams::ShowVolumeBar FBExportToSWFParams::ShowTimer FBExportToSWFParams::ShowTimeline FBExportToSWFParams::ShowNextPrev


ShowMousePointer

BB FlashBack SDK: FBExportToSWFParams

ShowMousePointer

Description

Determines whether to show the mouse pointer in the exported movie. Set the property to true to show the cursor.

Syntax

[C#/C++]
public Bool ShowMousePointer;

[VB.NET]
Public Property ShowMousePointer As Boolean


ShowNextPrev

BB FlashBack SDK: FBExportToSWFParams

ShowNextPrev

Description

Determines whether to show the Next / Previous Frame buttons on the exported SWF control bar, if the AddControlBar property is set to true.

These buttons are shown to the right of the Play and Back to Start buttons, and to the left of the Timeline control.

Syntax

[C#/C++]
public Bool ShowNextPrev;

[VB.NET]
Public Property ShowNextPrev As Boolean

See Also

FBExportToSWFParams::ShowAutoHide FBExportToSWFParams::ShowFBLogo FBExportToSWFParams::ShowVolumeBar FBExportToSWFParams::ShowTimer FBExportToSWFParams::ShowTimeline FBExportToSWFParams::ShowFullScreen


FBExportToSWFParams::ShowOptions

BB FlashBack SDK: FBExportToSWFParams

ShowOptions

Description

Determines the action taken on passing the FBExportToSWFParams object to FBMovie::ExportToSWF.

Syntax

[C#/C++]
public Bool ShowOptions;

[VB.NET]
Public Property ShowOptions As Boolean

Remarks

If ShowOptions is set to True, and the FBExportToSWFParams object is passed to the FBMovie::ExportToSWF method, a dialog is displayed that enables the user to set export parameters.

If ShowOptions is set to False, and the FBExportToSWFParams object is passed to the FBMovie::ExportToSWF method, the export uses the properties of the FBExportToSWFParams object and does not show the export options dialog.

See Also

FBMovie::ExportToSWF


ShowPausedOverlay

BB FlashBack SDK: FBExportToSWFParams

ShowPausedOverlay

Description

Determines whether to overlay a 'paused' symbol on the movie when playback is paused.

Syntax

[C#/C++]
public Bool ShowPausedOverlay;

[VB.NET]
Public Property ShowPausedOverlay As Boolean

See Also

FBExportToSWFParams::PauseByClickingOnMovie


ShowTimeline

BB FlashBack SDK: FBExportToSWFParams

ShowTimeline

Description

Determines whether to show the Timeline controls on the exported SWF control bar, if the AddControlBar property is set to true.

The Timeline shows the current position within the movie duration and allows the user to change the current position by dragging a thumb control.

Syntax

[C#/C++]
public Bool ShowTimeline;

[VB.NET]
Public Property ShowTimeline As Boolean

See Also

FBExportToSWFParams::ShowAutoHide FBExportToSWFParams::ShowFBLogo FBExportToSWFParams::ShowVolumeBar FBExportToSWFParams::ShowTimer FBExportToSWFParams::ShowNextPrev


ShowTimer

BB FlashBack SDK: FBExportToSWFParams

ShowTimer

Description

Determines whether to show the time elapsed / time remaining display to the right of the "timeline" on the exported SWF control bar, if the AddControlBar property is set to true.

Syntax

[C#/C++]
public Bool ShowTimer;

[VB.NET]
Public Property ShowTimer As Boolean

See Also

FBExportToSWFParams::ShowAutoHide FBExportToSWFParams::ShowFBLogo FBExportToSWFParams::ShowVolumeBar FBExportToSWFParams::ShowFullScreen FBExportToSWFParams::ShowTimeline FBExportToSWFParams::ShowNextPrev


ShowSoundBar

BB FlashBack SDK: FBExportToSWFParams

ShowVolumeBar

Description

Determines whether to show the sound volume control on the exported SWF control bar, if the AddControlBar property is set to true.

Syntax

[C#/C++]
public Bool ShowVolumeBar;

[VB.NET]
Public Property ShowVolumeBar As Boolean

See Also

FBExportToSWFParams::ShowAutoHide FBExportToSWFParams::ShowFBLogo FBExportToSWFParams::ShowFullScreen FBExportToSWFParams::ShowTimer FBExportToSWFParams::ShowTimeline FBExportToSWFParams::ShowNextPrev


SingleSwf

BB FlashBack SDK: FBExportToSWFParams

SingleSwf

Description

This property determines whether the movie and playback controls will be in the same SWF file or whether they will go into 2 separate SWF files.

See About BB FlashBack SDK Flash Exports for more details on exporting single and multiple SWFs.

Syntax

[C#/C++]
public bool SingleSwf;

[VB.NET]
Public Property SingleSwf As Boolean


FBExportToSWFParams::SoundCompressFormat

BB FlashBack SDK: FBExportToSWFParams

SoundCompressFormat

Description

Determines whether MP3 compression or no compression at all should be used in the exported SWF file.

Syntax

[C#/C++]
public long SoundCompressFormat;

[VB.NET]
Public Property SoundCompressFormat As Long

Remarks

This can be one of the following standard Win32 SDK constants:

WAVE_FORMAT_PCM = 1

WAVE_FORMAT_MPEGLAYER3 = 85

SWF files exported with sound in PCM (uncompressed) format may be much larger than those exported from the same movie using MP3 format.

See Also

FBExportToSWFParams::SoundMP3Profile


FBExportToSWFParams::SoundFormat

BB FlashBack SDK: FBExportToSWFParams

SoundFormat

Description

Sets the sound format used in the exported SWF file.

Syntax

[C#/C++]
public long SoundFormat;

[VB.NET]
Public Property SoundFormat As Long

Remarks

This can be one of the following standard Win32 SDK constants, describing the number of channels, sample rate and bits per sample:

Value |  | Format
WAVE_FORMAT_1M08 | 0x00000001 | 11.025 kHz, mono, 8-bit.
WAVE_FORMAT_1S08 | 0x00000002 | 11.025 kHz, stereo, 8-bit.
WAVE_FORMAT_1M16 | 0x00000004 | 11.025 kHz, mono, 16-bit.
WAVE_FORMAT_1S16 | 0x00000008 | 11.025 kHz, stereo, 16-bit.
WAVE_FORMAT_2M08 | 0x00000010 | 22.05 kHz, mono, 8-bit.
WAVE_FORMAT_2S08 | 0x00000020 | 22.05 kHz, stereo, 8-bit.
WAVE_FORMAT_2M16 | 0x00000040 | 22.05 kHz, mono, 16-bit.
WAVE_FORMAT_2S16 | 0x00000080 | 22.05 kHz, stereo, 16-bit.
WAVE_FORMAT_4M08 | 0x00000100 | 44.1 kHz, mono, 8-bit.
WAVE_FORMAT_4S08 | 0x00000200 | 44.1 kHz, stereo, 8-bit.
WAVE_FORMAT_4M16 | 0x00000400 | 44.1 kHz, mono, 16-bit.
WAVE_FORMAT_4S16 | 0x00000800 | 44.1 kHz, stereo, 16-bit.
WAVE_FORMAT_48M08 | 0x00001000 | 48 KHz, Mono, 8 bit
WAVE_FORMAT_48S08 | 0x00002000 | 48 KHz, Stereo, 8 bit
WAVE_FORMAT_48M16 | 0x00004000 | 48 KHz, Mono, 16 bit
WAVE_FORMAT_48S16 | 0x00008000 | 48 KHz, Stereo, 16 bit
WAVE_FORMAT_96M08 | 0x00010000 | 96 KHz, Mono, 8 bit
WAVE_FORMAT_96S08 | 0x00020000 | 96 KHz, Stereo, 8 bit
WAVE_FORMAT_96M16 | 0x00040000 | 96 KHz, Mono, 16 bit
WAVE_FORMAT_96S16 | 0x00080000 | 96 KHz, Stereo, 16 bit

If SoundFormat is set to zero, the format used on export is determined by the format of the sounds in the movie. See UseBestFormat for more details.

See also

FBExportToSWFParams::UseBestFormat


FBExportToSWFParams::SoundMP3Profile

BB FlashBack SDK: FBExportToSWFParams

SoundMP3Profile

Description

Sets the level of MP3 compression to be used in the exported SWF file.

Syntax

[C#/C++]
public long SoundMP3Profile;

[VB.NET]
Public Property SoundMP3Profile As Long

Remarks

SoundMP3Profile can be one of the following constants:

Value | Audio Quality
0 | Normal
1 | Low
2 | High
5 | Very high

Higher audio quality means less compression and larger file sizes.

This property is ignored if SoundCompressFormat is not set to MP3.

See Also

FBExportToSWFParams::SoundCompressFormat


StartingPlaybackMode

BB FlashBack SDK: FBExportToSWFParams

StartingPlaybackMode

Description

Determines the actions the movie takes when it is displayed. If the SWF is embedded in a web page, this means the actions it takes when the page is loaded.

BB FlashBack SDK Flash exports comprise two SWF files, or an SWF and FLV file. One SWF file contains the playback controls and the second file (either an SWF or FLV file) contains the main movie. The StartingPlaybackMode property determines how the main movie file is downloaded.

Syntax

[C#/C++]
public Long StartingPlaybackMode;

[VB.NET]
Public Property StartingPlaybackMode As Integer

Remarks

Values for this property are:

0 = spmDownloadOnClick

Do not download the movie or start playback until clicked.

This requires that the movie is exported as multiple SWFs. See About BB FlashBack SDK Flash Exports for further details.

Only the toolbar SWF is loaded, displaying the playback controls. A 'play' symbol is displayed in the center of space that will be occupied by the movie. The main movie SWF or FLV is downloaded when the user clicks the symbol.

1 = spmDownload

Download automatically but do not start playback until clicked

When the toolbar SWF is displayed, it starts download of the main movie. The 'play' symbol shown in the movie center. Playback only starts when the user clicks the symbol.

2 = spmDownloadAndPlay

Automatically download and play the movie

When the toolbar SWF is displayed, it starts download of the main movie. Playback of the movie starts as soon as it is calculated that enough has been downloaded to ensure playback from start to finish with no pauses for further downloading.


StopOnLastFrame

BB FlashBack SDK: FBExportToSWFParams

StopOnLastFrame

Description

Determines whether the movie will stop when it plays the last frame or loop back to the start of the movie.

Syntax

[C#/C++]
public Bool StopOnLastFrame;

[VB.NET]
Public Property StopOnLastFrame As Boolean

Remarks

If set to True, the movie will display the last frame indefinitely when it reaches the end of the movie.

If set to False, when it reaches the end, the movie will loop back to the start and continue to play.

See also

FBRecorder::AutoStartPlay


FBExportToSWFParams::UseBestFormat

BB FlashBack SDK: FBExportToSWFParams

UseBestFormat

Description

This works in connection with the SoundFormat property to allow the SDK to automatically determine the sound format to use on export, based on the format of the various sounds in the movie.

Syntax

[C#/C++]
public Bool UseBestFormat;

[VB.NET]
Public Property UseBestFormat As Boolean

Remarks

If SoundFormat is set to zero, the value of UseBestFormat determines the sound format to be used on export.

If a movie contains more than one sound file, all sounds have to mixed to a single format before being exported to SWF. Setting UseBestFormat to True means the highest quality format used by any sound in the movie will be used for the export format. Setting UseBestFormat to False means all sounds are mixed to the lowest quality format used by any sound in the movie.

For example, if a movie has two sounds: one at 44Khz and one at 22Khz:

  • SoundFormat = 0 and UseBestFormat = True : all sounds mixed to 44Khz before export

  • SoundFormat = 0 and UseBestFormat = False : all sounds mixed to 22Khz before export

  • SoundFormat != 0 : all sounds are mixed to whatever format is indicated in SoundFormat.

See Also

FBExportToSWFParams::SoundFormat


UseSecureCode

BB FlashBack SDK: FBExportToSWFParams

UseSecureCode

Description

Instructs the SDK to export an SWF file that cannot be played via third party SWFs.

Syntax

[C#/C++]
public Bool UseSecureCode;

[VB.NET]
Public Property UseSecureCode As Boolean

Remarks

The SecureCode property contains a user defined string that must be passed to the play() method of the SWF in order to play it back successfully. In this way, the exported SWF cannot be embedded and played back in a third party SWF.

For details of how the SecureDomains and SecureCode properties work together to set restrictions on exported SWF usage, see Using the SecureDomains and SecureCode features.

See Also


UseSecureDomain

BB FlashBack SDK: FBExportToSWFParams

UseSecureDomain

Description

Instructs the SDK to export an SWF file that can only be called from SWF files hosted in domains included in the list contained in the SecureDomains property.

Syntax

[C#/C++]
public Bool UseSecureDomain;

[VB.NET]
Public Property UseSecureDomain As Boolean

Remarks

SWF files that use the secure domain feature can only be called from SWFs hosted in a domain contained in the SecureDomains property. However, the SWF can still be embedded within webpages hosted in any domain - the SecureCode feature must be used to restrict how it can be hosted in webpages.

SWF files that use this feature require Flash player version 6 or newer for playback.

For details of how the SecureDomains and SecureCode properties work together to set restrictions on exported SWF usage, see Using the SecureDomains and SecureCode features.

See Also


Exporting to Windows Media Video

Exporting to Windows Media Video requires you to set a video codec ID, audio codec ID and an audio format ID. These ID numbers are the same as those used by the Microsoft's Windows Media Format SDK classes to identify codecs and formats. You'll need to use these classes to find the ID numbers of the required codecs.

To determine supported WMV video and audio codecs, use the Windows Media Format SDK class IWMCodecInfo3. Its GetCodecInfoCount method returns the number of supported audio or video codecs.

Each WMV audio codec supports a number of formats, where a format typically has a sample rate, number of channels and either a variable or constant bitrate.

Once you've used IWMCodecInfo3::GetCodecInfoCount to discover the number of supported audio codecs, you can then use the GetCodecFormatCount method to discover the number of formats supported by a particular codec, and GetCodecFormat to return the details for a particular format.

Consult the Windows Media Format 9.5 SDK documentation on http://msdn.microsoft.com for details.

Important Note: Windows Media Player 9 or above must be installed in order to export to WMV format. PCs that do not have this pre-requisite installed will not be able to export to WMV.


Sample code - Enumerating audio codecs

Enumerating Audio Codecs

Four properties of FBExportToWMVParams (AudioNumPasses, AudioVBR) require you to select either variable or constant bitrate audio encoding, and to select how many passes will be made in the encoding process.

In order to determine which audio codecs support variable or constant bit rates and multi pass encoding, the IWMCodecInfo3::SetCodecEnumerationSetting method should be used.

The IWMCodecInfo3 interface is defined by the Windows Media Format 9.5 SDK - see http://msdn.microsoft.com for full documentation.

The sample C++ code below uses SetCodecEnumerationSetting to discover which codecs support variable bitrate encoding (VBR), constant bitrate encoding (CBR) and 1 or 2 passes.

wchar_t* wszFormatName;

/* Look first for codecs supporting CBR, then VBR */
for (Bool nVbrEnabled = 0; nVbrEnabled < 2; nVbrEnabled++)
{
 hr = pWMCodecInfo3->SetCodecEnumerationSetting(WMMEDIATYPE_Audio, dwCodecId, g_wszVBREnabled,   WMT_TYPE_BOOL, (BYTE*)&nVbrEnabled, sizeof(nVbrEnabled));

  if (hr == S_OK)
 {

   for (DWORD nNumPasses = 1; nNumPasses <= 2; nNumPasses++)
   {
     hr = pWMCodecInfo3->SetCodecEnumerationSetting(WMMEDIATYPE_Audio, dwCodecId, g_wszNumPasses, WMT_TYPE_DWORD, (BYTE*)&nNumPasses, sizeof(nNumPasses));

      if (hr == S_OK)
     {
       DWORD cFormats;
       hr = pWMCodecInfo3->GetCodecFormatCount(WMMEDIATYPE_Audio, dwCodecId, &cFormats);

        if (hr == S_OK)
       {
         for (DWORD i = 0; i < cFormats; i++)
         {
           ...
           pCallbackFunc(i, wszFormatName, (WAVEFORMATEX*)pMediaType->pbFormat, nCurVBR, nCurNumPasses, bSpeechClassEnabled);
           ...
         }
       }
     }
   }
 }
}


FBExportToWMVParams::AudioCodecID

BB FlashBack SDK: FBExportToWMVParams

AudioCodecID

Description

Sets the audio codec to be used in the export process.

Syntax

[C#/C++]
public long AudioCodecID;

[VB.NET]
Public Property AudioCodecID As Long

Remarks

This must be set to a codec index number ranging from zero to one less than the number of supported codecs.

The FlashBack SDK uses the same index numbers to identify codecs and their formats as is used by Microsoft's Windows Media Format SDK classes.

See Exporting to Windows Media Video for more details.

See also


FBExportToWMVParams::AudioFormatID

BB FlashBack SDK: FBExportToWMVParams

AudioFormatID

Description

Sets the audio format to be used in the export process.

Syntax

[C#/C++]
public long AudioFormatID;

[VB.NET]
Public Property AudioFormatID As Long

Remarks

This is set to a format index ranging from zero to one less than the number of supported formats for a particular codec.

Each WMV audio codec supports a number of formats, where a format typically has a sample rate, number of channels and either a variable or constant bitrate.

The FlashBack SDK uses the same index numbers to identify codecs and their formats as is used by Microsoft's Windows Media Format SDK classes.

See Exporting to Windows Media Video for more details.

See also


FBExportToWMVParams::AudioNumPasses

BB FlashBack SDK: FBExportToWMVParams

AudioNumPasses

Description

Sets the number of passes to be used when encoding the audio stream.

Syntax

[C#/C++]
public long AudioNumPasses;

[VB.NET]
Public Property AudioNumPasses As Long

Remarks

Codecs may support up to two passes, so this value may be 1 or 2. In general, more passes in the encoding process means higher quality.

To find audio codecs that support two pass encoding, use the IWMCodecInfo3 interface defined in the Windows Media Format 9.5 SDK. Its SetCodecEnumerationInfo method can be used to selectively return codecs that support 1 or 2 passes.

See Exporting to Windows Media Video and Enumerating Audio Codecs for some sample code and more help, and see the Windows Media Format 9.5 SDK help at http://msdn.microsoft.com.

See also


FBExportToWMVParams::AudioVBR

BB FlashBack SDK: FBExportToWMVParams

AudioVBR

Description

Sets whether constant or variable bitrates are to be used to encode the audio stream.

Syntax

[C#/C++]
public Bool AudioVBR;

[VB.NET]
Public Property AudioVBR As Boolean

Remarks

A codec may support variable or constant bitrate encoding, or both.

To find which audio codecs support what type of bitrate encoding, use the IWMCodecInfo3 interface defined in the Windows Media Format 9.5 SDK. Its SetCodecEnumerationInfo method can be used to return codecs that support either variable or constant bitrates.

See Exporting to Windows Media Video and Enumerating Audio Codecs for some sample code and more help, and see the Windows Media Format 9.5 SDK help at http://msdn.microsoft.com.

See also


FBExportToWMVParams::AutoscrollDimX

BB FlashBack SDK: FBExportToWMVParams

AutoscrollDimX

Description

Returns and sets the width of the autoscroll frame.

Syntax

[C#/C++]
public long AutoscrollDimX;

[VB.NET]
Public Property AutoscrollDimX As Long

Remarks

The autoscroll feature keeps the mouse cursor at or near the middle of the exported movie by automatically scrolling the 'autoscroll frame'.

Autoscroll is enabled by setting AutoscrollMode to True. The autoscroll frame dimensions are specified by the AutoscrollDimX and AutoscrollDimY properties.

See also


FBExportToWMVParams::AutoscrollDimY

BB FlashBack SDK: FBExportToWMVParams

AutoscrollDimY

Description

Returns and sets the height of the autoscroll frame.

Syntax

[C#/C++]
public long AutoscrollDimY;

[VB.NET]
Public Property AutoscrollDimY As Long

Remarks

The autoscroll feature keeps the mouse cursor at or near the middle of the exported movie by automatically scrolling the 'autoscroll frame'.

Autoscroll is enabled by setting AutoscrollMode to True. The autoscroll frame dimensions are specified by the AutoscrollDimX and AutoscrollDimY properties.

See also


FBExportToWMVParams::AutoscrollMode

BB FlashBack SDK: FBExportToWMVParams

AutoscrollMode

Description

Returns and sets a value indicating whether autoscroll will be used during export.

Syntax

[C#/C++]
public Bool AutoscrollMode;

[VB.NET]
Public Property AutoscrollMode As Boolean

Remarks

Set this property to True to enable autoscroll.

The autoscroll feature keeps the mouse cursor at or near the middle of the exported movie by automatically scrolling the 'autoscroll frame'.

The autoscroll frame dimensions are specified by the AutoscrollDimX and AutoscrollDimY properties.

See also


FBExportToWMVParams::FrameRateCustom

BB FlashBack SDK: FBExportToWMVParams

FrameRateCustom

Description

Sets the frame rate, in frames per second, at which to export, when a 'custom' frame rate has been selected via the FrameRateMode property.

Syntax

[C#/C++]
public long FrameRateCustom;

[VB.NET]
Public Property FrameRateCustom As Long

Remarks

This property is only used when FrameRateMode is set to 3.

See Also

FBExportToWMVParams::FrameRateMode


FBExportToWMVParams::FrameRateMode

BB FlashBack SDK: FBExportToWMVParams

FrameRateMode

Description

Sets the frame rate at which to export.

Syntax

[C#/C++]
public long FrameRateMode;

[VB.NET]
Public Property FrameRateMode As Long

Remarks

Can be one of these values:

Value | Frame rate
0 | Same frame rate as the native FBR movie recording.
1 | 1/2 frame rate of movie.
2 | 1/4 frame rate of movie.
3 | Frame rate defined by the FrameRateCustom property.

The default frame rate for movies recorded with the capture driver is 25fps.

See Also

FBExportToWMVParams::FrameRateCustom


FBExportToWMVParams::HighlightMouseClicks

BB FlashBack SDK: FBExportToWMVParams

HighlightMouseClicks

Description

Determines whether mouse clicks are highlighted with animating circles in the exported movie.

Syntax

[C#/C++]
public Bool HighlightMouseClicks;

[VB.NET]
Public Property HighlightMouseClicks As Boolean


FBExportToWMVParams::OutputSizeKeepAspectRatio

BB FlashBack SDK: FBExportToWMVParams

OutputSizeKeepAspectRatio

Description

Returns and sets the value that determines whether the aspect ratio of the movie is maintained when its width or height are altered via the OutputSizePercentX or OutputSizePercentY properties.

Syntax

[C#/C++]
public Bool OutputSizeKeepAspectRatio;

[VB.NET]
Public Property OutputSizeKeepAspectRatio As Boolean

Remarks

If this property is set to True, altering OutputSizePercentX or OutputSizePercentY automatically changes the other percentage to the same value, to maintain the aspect ratio of the movie.

See also


FBExportToWMVParams::OutputSizePercentX

BB FlashBack SDK: FBExportToWMVParams

OutputSizePercentX

Description

Returns and sets the percentage scaling applied to the width of the movie, when exported.

Note: this property is deprecated in favour of OutputSizePercentXFloat.

Syntax

[C#/C++]
public long OutputSizePercentX;

[VB.NET]
Public Property OutputSizePercentX As Long

Remarks

If OutputSizeKeepAspectRatio is set to True, changing the percent scaling for the width results in the percent scaling for the height (the OutputSizePercentY property) being set to the same value.

See also

FBExportToWMVParams:OutputSizeKeepAspectRatio FBExportToWMVParams::OutputSizePercentY

FBExportToWMVParams::OutputSizePercentXFloat


OutputSizePercentXFloat

BB FlashBack SDK: FBExportToWMVParams

OutputSizePercentXFloat

Description

Returns and sets the percentage scaling applied to the width of the movie, when exported.

Syntax

[C#/C++]
public float OutputSizePercentXFloat;

[VB.NET]
Public Property OutputSizePercentXFloat As Single

Remarks

If OutputSizeKeepAspectRatio is set to True, changing the percent scaling for the width results in the percent scaling for the height (the OutputSizePercentYFloat property) being set to the same value.

See also


FBExportToWMVParams::OutputSizePercentY

BB FlashBack SDK: FBExportToWMVParams

OutputSizePercentY

Description

Returns and sets the percentage scaling applied to the height of the movie, when exported.

Note: this property is deprecated in favour of OutputSizePercentYFloat.

Syntax

[C#/C++]
public long OutputSizePercentY;

[VB.NET]
Public Property OutputSizePercentY As Long

Remarks

If OutputSizeKeepAspectRatio is set to True, changing the percent scaling for the height results in the percent scaling for the width (the OutputSizePercentX property) being set to the same value.

See also

FBExportToWMVParams:OutputSizeKeepAspectRatio FBExportToWMVParams::OutputSizePercentX

FBExportToWMVParams::OutputSizePercentYFloat


OutputSizePercentYFloat

BB FlashBack SDK: FBExportToWMVParams

OutputSizePercentYFloat

Description

Returns and sets the percentage scaling applied to the height of the movie, when exported.

Syntax

[C#/C++]
public float OutputSizePercentYFloat;

[VB.NET]
Public Property OutputSizePercentYFloat As Single

Remarks

If OutputSizeKeepAspectRatio is set to True, changing the percent scaling for the height results in the percent scaling for the width (the OutputSizePercentXFloat property) being set to the same value.

See also


FBExportToWMVParams::ShowOptions

BB FlashBack SDK: FBExportToWMVParams

ShowOptions

Description

Determines the action taken on passing the FBExportToWMVParams object to FBMovie::ExportToWMV.

Syntax

[C#/C++]
public Bool ShowOptions;

[VB.NET]
Public Property ShowOptions As Boolean

Remarks

If ShowOptions is set to True, and the FBExportToWMVParams object is passed to the FBMovie::ExportToWMV method, a dialog is displayed that enables the user to set export parameters.

If ShowOptions is set to False, and the FBExportToWMVParams object is passed to the FBMovie::ExportToWMV method, the export uses the properties of the FBExportToWMVParams object and does not show the export options dialog.

See Also

FBMovie::ExportToWMV


FBExportToWMVParams::VideoBitrate

BB FlashBack SDK: FBExportToWMVParams

VideoBitrate

Description

Sets the bitrate of the video stream in the exported WMV file.

Syntax

[C#/C++]
public long VideoBitrate;

[VB.NET]
Public Property VideoBitrate As Long

Remarks

This value is in bits per second.

Each WMV codec supports a number of formats, where a format typically has a variable or constant bitrate and quality.

See Exporting to Windows Media Video for more details.

See also


FBExportToWMVParams::VideoCodecID

BB FlashBack SDK: FBExportToWMVParams

VideoCodecID

Description

Sets the video codec to be used in the export process.

Syntax

[C#/C++]
public long VideoCodecID;

[VB.NET]
Public Property VideoCodecID As Long

Remarks

This is set to a codec index ranging from zero to one less than the number of supported codecs.

The FlashBack SDK uses the same index numbers to identify codecs and their formats as is used by Microsoft's Windows Media Format SDK classes.

See Exporting to Windows Media Video for more details.

See also


FBExportToWMVParams::VideoNumPasses

BB FlashBack SDK: FBExportToWMVParams

VideoNumPasses

Description

Sets the number of passes to be used encoding the video stream in the export process.

Syntax

[C#/C++]
public long VideoNumPasses;

[VB.NET]
Public Property VideoNumPasses As Long

Remarks

This is the number of passes that will be used to encode the video stream. Generally, more passes gives higher quality, but the maximum number of passes available depends on the WMV codec being used.

As a guide, the codecs represented by these identifiers (see compressed media subtypes in the Windows Media Format 9.5 SDK documentation) allow 1 or 2 pass encoding:

WMMEDIASUBTYPE_WMV1 - Windows Media Video 7
WMMEDIASUBTYPE_WMV2 - Windows Media Video 8
WMMEDIASUBTYPE_WMV3 - Windows Media Video 9

And these only allow 1 pass encoding:

WMMEDIASUBTYPE_MSS1 - Windows Media Screen codec version 1
WMMEDIASUBTYPE_MSS2 - Windows Media Video 9 Screen codec

See Exporting to Windows Media Video for more details on use of WMV codecs and formats.

See also


FBExportToWMVParams::VideoQuality

BB FlashBack SDK: FBExportToWMVParams

VideoQuality

Description

Sets the image quality of the video stream in the exported WMV file.

Syntax

[C#/C++]
public long VideoQuality;

[VB.NET]
Public Property VideoQuality As Long

Remarks

This is a value from 1 to 100, where 1 = lowest quality and 100 = highest.

The FlashBack SDK uses the same index numbers to identify codecs and their formats as is used by Microsoft's Windows Media Format SDK classes.

See Exporting to Windows Media Video for more details.

See also


FBExportToWMVParams::VideoVBR

BB FlashBack SDK: FBExportToWMVParams

VideoVBR

Description

Sets whether constant or variable bitrate encoding will be used in the video stream of the exported WMV file.

Syntax

[C#/C++]
public Bool VideoVBR;

[VB.NET]
Public Property VideoVBR As Boolean

Remarks

Set to True for variable bitrate encoding.

Variable bitrate encoding varies the bitrate of the stream depending on its content at a particular moment. This can mean smaller files This value is in bits per second.

See Exporting to Windows Media Video for more details on using WMV codecs and formats.

See also


AddCuePoints

BB FlashBack SDK: FBExportToFLVParams

AddCuePoints

Description

When set to true, pads the export dimensions to multiples of 4, which can improve compression.

Syntax

[C#/C++]
public bool Padding4px;

[VB.NET]
Public Property Padding4px As Boolean

See also

FBExportToFLVParams:AlignIfPadded


AlignIfPadded

BB FlashBack SDK: FBExportToFLVParams

AlignIfPadded

Description

Determines how the movie is aligned inside the padded dimensions, if FBExportToFLVParams::Padding4px is set to true.

Syntax

[C#/C++]
public long AlignIfPadded;

[VB.NET]
Public Property AlignIfPadded As Integer

Remarks

The property can take the following values:

0 = default, centered

1= top left

2 = top right

3 = bottom right

4 = bottom left

5 = centered

See also

FBExportToFLVParams:Padding4px


FBExportToFLVParams::AutoscrollDimX

BB FlashBack SDK: FBExportToFLVParams

AutoscrollDimX

Description

Returns and sets the width of the autoscroll frame.

Syntax

[C#/C++]
public long AutoscrollDimX;

[VB.NET]
Public Property AutoscrollDimX As Long

Remarks

The autoscroll feature keeps the mouse cursor at or near the middle of the exported movie by automatically scrolling the 'autoscroll frame'.

Autoscroll is enabled by setting AutoscrollMode to True. The autoscroll frame dimensions are specified by the AutoscrollDimX and AutoscrollDimY properties.

See also


FBExportToFLVParams::AutoscrollDimY

BB FlashBack SDK: FBExportToFLVParams

AutoscrollDimY

Description

Returns and sets the height of the autoscroll frame.

Syntax

[C#/C++]
public long AutoscrollDimY;

[VB.NET]
Public Property AutoscrollDimY As Long

Remarks

The autoscroll feature keeps the mouse cursor at or near the middle of the exported movie by automatically scrolling the 'autoscroll frame'.

Autoscroll is enabled by setting AutoscrollMode to True. The autoscroll frame dimensions are specified by the AutoscrollDimX and AutoscrollDimY properties.

See also


FBExportToFLVParams::AutoscrollMode

BB FlashBack SDK: FBExportToFLVParams

AutoscrollMode

Description

Returns and sets a value indicating whether autoscroll will be used during export.

Syntax

[C#/C++]
public Bool AutoscrollMode;

[VB.NET]
Public Property AutoscrollMode As Boolean

Remarks

Set this property to True to enable autoscroll.

The autoscroll feature keeps the mouse cursor at or near the middle of the exported movie by automatically scrolling the 'autoscroll frame'.

The autoscroll frame dimensions are specified by the AutoscrollDimX and AutoscrollDimY properties.

See also


ExportSound

BB FlashBack SDK: FBExportToFLVParams

ExportSound

Description

Determines whether any sound in the movie will be exported with the video.

Syntax

[C#/C++]
public bool ExportSound;

[VB.NET]
Public Property ExportSound As Boolean

See also


FLVBitrate

BB FlashBack SDK: FBExportToFLVParams

FLVBitrate

Description

Sets the bitrate of the export in kilobits per second.

Syntax

[C#/C++]
public long FLVBitrate;

[VB.NET]
Public Property FLVBitrate As Long

Remarks

The higher the bitrate, the higher the image quality of the export. This property defaults to 500 KBits per second.

The parameter is used when the QualityMode parameter is set to 1.

See also

FBExportToFLVParams::QualityMode


FBExportToFLVParams::FLVType

BB FlashBack SDK: FBExportToFLVParams

FLVType

Description

Sets the codec used in the FLV export.

There are two codecs: Sorensen and Screenvideo. Sorensen is lossy compression best suited for moving video. Screenvideo is lossless compression best suited for recording of 'normal' Windows applications that do not contain moving video or complex images.

Syntax

[C#/C++]
public long FLVType;

[VB.NET]
Public Property FLVType As Long

Remarks

This property can take one of two values:

  • 0 = Sorenson

  • 1 = Screenvideo


FBExportToFLVParams::FrameRateCustom

BB FlashBack SDK: FBExportToFLVParams

FrameRateCustom

Description

Sets the frame rate, in frames per second, at which to export, when a 'custom' frame rate has been selected via the FrameRateMode property.

Syntax

[C#/C++]
public long FrameRateCustom;

[VB.NET]
Public Property FrameRateCustom As Long

Remarks

This property is only used when FrameRateMode is set to 3.

See Also

FBExportToFLVParams::FrameRateMode


FBExportToFLVParams::FrameRateMode

BB FlashBack SDK: FBExportToFLVParams

FrameRateMode

Description

Sets the frame rate at which to export.

Syntax

[C#/C++]
public long FrameRateMode;

[VB.NET]
Public Property FrameRateMode As Long

Remarks

Can be one of these values:

Value | Frame rate
0 | Same frame rate as the native FBR movie recording.
1 | 1/2 frame rate of movie.
2 | 1/4 frame rate of movie.
3 | Frame rate defined by the FrameRateCustom property.

The default frame rate for movies recorded with the capture driver is 25fps.

See Also

FBExportToFLVParams::FrameRateCustom


FBExportToFLVParams::HighlightMouseClicks

BB FlashBack SDK: FBExportToFLVParams

HighlightMouseClicks

Description

Determines whether mouse clicks are highlighted with animating circles in the exported movie.

Syntax

[C#/C++]
public Bool HighlightMouseClicks;

[VB.NET]
Public Property HighlightMouseClicks As Boolean


KeyFrames

BB FlashBack SDK: FBExportToFLVParams

KeyFrameRate

Description

Returns and sets the frequency of keyframes in the exported movie.

When set to 1, this would mean that every frame is a keyframe. If set to 10, for example, every 10th frame would be a keyframe.

The more keyframes in the exported video, the better the quality but the larger the filesize.

Syntax

[C#/C++]
public long KeyFrameRate;

[VB.NET]
Public Property KeyFrameRate As Integer


FBExportToFLVParams::OutputSizeKeepAspectRatio

BB FlashBack SDK: FBExportToFLVParams

OutputSizeKeepAspectRatio

Description

Returns and sets the value that determines whether the aspect ratio of the movie is maintained when its width or height are altered via the OutputSizePercentX or OutputSizePercentY properties.

Syntax

[C#/C++]
public Bool OutputSizeKeepAspectRatio;

[VB.NET]
Public Property OutputSizeKeepAspectRatio As Boolean

Remarks

If this property is set to True, altering OutputSizePercentX or OutputSizePercentY automatically changes the other percentage to the same value, to maintain the aspect ratio of the movie.

See also


FBExportToFLVParams::OutputSizePercentX

BB FlashBack SDK: FBExportToFLVParams

OutputSizePercentX

Description

Returns and sets the percentage scaling applied to the width of the movie, when exported.

Syntax

[C#/C++]
public long OutputSizePercentX;

[VB.NET]
Public Property OutputSizePercentX As Long

Remarks

If OutputSizeKeepAspectRatio is set to True, changing the percent scaling for the width results in the percent scaling for the height (the OutputSizePercentY property) being set to the same value.

See also


FBExportToFLVParams::OutputSizePercentY

BB FlashBack SDK: FBExportToFLVParams

OutputSizePercentY

Description

Returns and sets the percentage scaling applied to the height of the movie, when exported.

Syntax

[C#/C++]
public long OutputSizePercentY;

[VB.NET]
Public Property OutputSizePercentY As Long

Remarks

If OutputSizeKeepAspectRatio is set to True, changing the percent scaling for the height results in the percent scaling for the width (the OutputSizePercentX property) being set to the same value.

See also


QMax

BB FlashBack SDK: FBExportToFLVParams

QMax

Description

Sets the maximum quantizer (or quality) level to use when exporting. The smaller the quantizer level, the higher the quality.

The QMax value is used with the QMin property to set the upper and lower boundaries of quality that can be used to achieve the bitrate set by FLVBitrate.

Syntax

[C#/C++]
public long QMax;

[VB.NET]
Public Property QMax As Long

Remarks

QMin and QMax are quantizer levels. The lower the quantizer level, the higher the image quality. 100% quality is set by making QMin=QMax=1.

The FLV encoder uses these levels to create a file with the bitrate specified by the FLVBitrate property. For example, if we set the bitrate to 400000bps, QMin =1 and QMax=50, the encoder may apply any quantizer value between 1 and 50 to achieve maximum quality while not exceeding 400000bps.

However, if qmin and qmax are set to a higher quality than can be achieved with the set bitrate, the quality settings take priority, and the bitrate will be exceeded.

See also


QMin

BB FlashBack SDK: FBExportToFLVParams

QMin

Description

Sets the minimum quantizer (or quality) level to use when exporting. The smaller the quantizer level, the higher the quality.

The QMin value is used with the QMax value to set the upper and lower boundaries of quality that can be used to achieve the bitrate set by FLVBitrate.

Syntax

[C#/C++]
public long QMin;

[VB.NET]
Public Property QMin As Long

Remarks

QMin and QMax are quantizer levels. The lower the quantizer level, the higher the image quality. 100% quality is set by making QMin=QMax=1.

The FLV encoder uses these levels to create a file with the bitrate specified by the FLVBitrate property. For example, if we set the bitrate to 400000bps, QMin =1 and QMax=50, the encoder may apply any quantizer value between 1 and 50 to achieve maximum quality while not exceeding 400000bps.

However, if qmin and qmax are set to a higher quality than can be achieved with the set bitrate, the quality settings take priority, and the bitrate will be exceeded.

See also


Quality

BB FlashBack SDK: FBExportToFLVParams

Quality

Description

Sets and returns the video quality used when exporting FLV files.

Syntax

[C#/C++]
public long Quality;

[VB.NET]
Public Property Quality As Long

Remarks

This value ranges from 1-100, where 1 is the lowest quality and 100 is the highest. The higher the quality, the larger the FLV file exported.

The parameter is used when the QualityMode parameter is set to 0.

See also

FBExportToFLVParams::QualityMode


QualityMode

BB FlashBack SDK: FBExportToFLVParams

QualityMode

Description

Sets whether the quality and filesize of the exported movie are set by the FLVBitrate parameter or the Quality parameter.

Syntax

[C#/C++]
public long QualityMode;

[VB.NET]
Public Property QualityMode As Long

Remarks

When set to 0, the Quality parameter is used. When set to 1, the FLVBitrate parameter is used.

See also


OutputSizePercentXFloat

BB FlashBack SDK: FBExportToFLVParams

OutputSizePercentXFloat

Description

Returns and sets the percentage scaling applied to the width of the movie, when exported.

Syntax

[C#/C++]
public float OutputSizePercentXFloat;

[VB.NET]
Public Property OutputSizePercentXFloat As Single

Remarks

If OutputSizeKeepAspectRatio is set to True, changing the percent scaling for the width results in the percent scaling for the height (the OutputSizePercentYFloat property) being set to the same value.

See also


OutputSizePercentYFloat

BB FlashBack SDK: FBExportToFLVParams

OutputSizePercentYFloat

Description

Returns and sets the percentage scaling applied to the height of the movie, when exported.

Syntax

[C#/C++]
public float OutputSizePercentYFloat;

[VB.NET]
Public Property OutputSizePercentYFloat As Single

Remarks

If OutputSizeKeepAspectRatio is set to True, changing the percent scaling for the width results in the percent scaling for the height (the OutputSizePercentXFloat property) being set to the same value.

See also


OutputSizeX

BB FlashBack SDK: FBExportToFLVParams

OutputSizeX

Description

Returns and sets the width of the movie in pixels, when exported.

Syntax

[C#/C++]
public long OutputSizeX;

[VB.NET]
Public Property OutputSizeX As Long

Remarks

If OutputSizeKeepAspectRatio is set to True, changing the width results in the height (the OutputSizeY property) being set accordingly.

See also


OutputSizeY

BB FlashBack SDK: FBExportToFLVParams

OutputSizeY

Description

Returns and sets the height of the movie in pixels, when exported.

Syntax

[C#/C++]
public long OutputSizeY;

[VB.NET]
Public Property OutputSizeY As Long

Remarks

If OutputSizeKeepAspectRatio is set to True, changing the height results in the width (the OutputSizeX property) being set accordingly.

See also


Padding4px

BB FlashBack SDK: FBExportToFLVParams

Padding4px

Description

When set to true, pads the export dimensions to multiples of 4, which can improve compression.

Syntax

[C#/C++]
public bool Padding4px;

[VB.NET]
Public Property Padding4px As Boolean

See also

FBExportToFLVParams:AlignIfPadded


ScaleToPercents

BB FlashBack SDK: FBExportToFLVParams

ScaleToPercents

Description

Determines whether percent scaling or pixel sizes should be used to set the dimensions of the exported movie.

The parameters OutputSizeX and OutputSizeY set the pixel size.

The parameters OutputSizePercentXFloat and OutputSizePercentYFloat (and the deprecated parameters OutputSizePercentX and OutputSizePercentY) set the percent scaling.

Syntax

[C#/C++]
public Bool ScaleToPercents;

[VB.NET]
Public Property ScaleToPercents As Boolean

See Also

FBExportToFLVParams:OutputSizeKeepAspectRatio FBExportToFLVParams::OutputSizePercentXFloat FBExportToFLVParams::OutputSizePercentYFloat FBExportToFLVParams::OutputSizeY FBExportToFLVParams::OutputSizeX


ShowMousePointer

BB FlashBack SDK: FBExportToFLVParams

ShowMousePointer

Description

Determines whether to show the mouse pointer in the exported movie. Set the property to true to show the cursor.

Syntax

[C#/C++]
public Bool ShowMousePointer;

[VB.NET]
Public Property ShowMousePointer As Boolean


ShowOptions

BB FlashBack SDK: FBExportToFLVParams

ShowOptions

Description

Determines the action taken on passing the FBExportToFLVParams object to FBMovie::ExportToFLV.

Syntax

[C#/C++]
public Bool ShowOptions;

[VB.NET]
Public Property ShowOptions As Boolean

Remarks

If ShowOptions is set to True, and the FBExportToFLVParams object is passed to the FBMovie::ExportToFLV method, a dialog is displayed that enables the user to set export options.

If ShowOptions is set to False, and the FBExportToFLVParams object is passed to the FBMovie::ExportToFLV method, the export uses the properties of the FBExportToFLVParams object and does not show the export options dialog.

See Also

FBMovie::ExportToFLV


FBExportToFLVParams::SoundCompressionFormat

BB FlashBack SDK: FBExportToFLVParams

SoundCompressionFormat

Description

Determines whether MP3 compression or no compression at all should be used in the exported FLV file.

Syntax

[C#/C++]
public long SoundCompressFormat;

[VB.NET]
Public Property SoundCompressFormat As Long

Remarks

This can be one of the following standard Win32 SDK constants:

WAVE_FORMAT_PCM = 1

WAVE_FORMAT_MPEGLAYER3 = 85

FLV files exported with sound in PCM (uncompressed) format may be much larger than those exported from the same movie using MP3 format.

See Also

FBExportToFLVParams::SoundMP3Profile


FBExportToFLVParams::SoundFormat

BB FlashBack SDK: FBExportToFLVParams

SoundFormat

Description

Sets the sound format used in the exported FLV file.

Syntax

[C#/C++]
public long SoundFormat;

[VB.NET]
Public Property SoundFormat As Long

Remarks

This can be one of the following standard Win32 SDK constants, describing the number of channels, sample rate and bits per sample:

Value |  | Format
WAVE_FORMAT_1M08 | 0x00000001 | 11.025 kHz, mono, 8-bit.
WAVE_FORMAT_1S08 | 0x00000002 | 11.025 kHz, stereo, 8-bit.
WAVE_FORMAT_1M16 | 0x00000004 | 11.025 kHz, mono, 16-bit.
WAVE_FORMAT_1S16 | 0x00000008 | 11.025 kHz, stereo, 16-bit.
WAVE_FORMAT_2M08 | 0x00000010 | 22.05 kHz, mono, 8-bit.
WAVE_FORMAT_2S08 | 0x00000020 | 22.05 kHz, stereo, 8-bit.
WAVE_FORMAT_2M16 | 0x00000040 | 22.05 kHz, mono, 16-bit.
WAVE_FORMAT_2S16 | 0x00000080 | 22.05 kHz, stereo, 16-bit.
WAVE_FORMAT_4M08 | 0x00000100 | 44.1 kHz, mono, 8-bit.
WAVE_FORMAT_4S08 | 0x00000200 | 44.1 kHz, stereo, 8-bit.
WAVE_FORMAT_4M16 | 0x00000400 | 44.1 kHz, mono, 16-bit.
WAVE_FORMAT_4S16 | 0x00000800 | 44.1 kHz, stereo, 16-bit.
WAVE_FORMAT_48M08 | 0x00001000 | 48 KHz, Mono, 8 bit
WAVE_FORMAT_48S08 | 0x00002000 | 48 KHz, Stereo, 8 bit
WAVE_FORMAT_48M16 | 0x00004000 | 48 KHz, Mono, 16 bit
WAVE_FORMAT_48S16 | 0x00008000 | 48 KHz, Stereo, 16 bit
WAVE_FORMAT_96M08 | 0x00010000 | 96 KHz, Mono, 8 bit
WAVE_FORMAT_96S08 | 0x00020000 | 96 KHz, Stereo, 8 bit
WAVE_FORMAT_96M16 | 0x00040000 | 96 KHz, Mono, 16 bit
WAVE_FORMAT_96S16 | 0x00080000 | 96 KHz, Stereo, 16 bit

If SoundFormat is set to zero, the format used on export is determined by the format of the sounds in the movie. See UseBestFormat for more details.

See also

FBExportToFLVParams::UseBestFormat


FBExportToFLVParams::SoundMP3Profile

BB FlashBack SDK: FBExportToFLVParams

SoundMP3Profile

Description

Sets the level of MP3 compression to be used in the exported FLV file.

Syntax

[C#/C++]
public long SoundMP3Profile;

[VB.NET]
Public Property SoundMP3Profile As Long

Remarks

SoundMP3Profile can be one of the following constants:

Value | Audio Quality
0 | Normal
1 | Low
2 | High
5 | Very high

Higher audio quality means less compression and larger file sizes.

This property is ignored if SoundCompressFormat is not set to MP3.

See Also

FBExportToFLVParams::SoundCompressFormat


FBExportToFLVParams::UseBestFormat

BB FlashBack SDK: FBExportToFLVParams

UseBestFormat

Description

This works in connection with the SoundFormat property to allow the SDK to automatically determine the sound format to use on export, based on the format of the various sounds in the movie.

Syntax

[C#/C++]
public Bool UseBestFormat;

[VB.NET]
Public Property UseBestFormat As Boolean

Remarks

If SoundFormat is set to zero, the value of UseBestFormat determines the sound format to be used on export.

If a movie contains more than one sound file, all sounds have to mixed to a single format before being exported to AVI. Setting UseBestFormat to True means the highest quality format used by any sound in the movie will be used for the export format. Setting UseBestFormat to False means all sounds are mixed to the lowest quality format used by any sound in the movie.

For example, if a movie has two sounds: one at 44Khz and one at 22Khz:

  • SoundFormat = 0 and UseBestFormat = True : all sounds mixed to 44Khz before export

  • SoundFormat = 0 and UseBestFormat = False : all sounds mixed to 22Khz before export

  • SoundFormat != 0 : all sounds are mixed to whatever format is indicated in SoundFormat.

See Also

FBExportToFLVParams::SoundFormat


UseQMinQMax

BB FlashBack SDK: FBExportToFLVParams

UseQMinQMax

Description

If this property is set to True, the export uses the QMin and QMax properties to set the exported image quality.

If this property is set to False, the export uses the Quality property to set the exported image quality.

Syntax

[C#/C++]
public Bool UseQMinQMax;

[VB.NET]
Public Property UseQMinQMax As Boolean

See Also


FBExportToEXEParams::Autoscroll

BB FlashBack SDK: FBExportToEXEParams

Autoscroll

Description

Returns and sets a value indicating whether autoscroll will be used during export.

Syntax

[C#/C++]
public Bool Autoscroll;

[VB.NET]
Public Property Autoscroll As Boolean

Remarks

Set this property to True to enable autoscroll.

The autoscroll feature keeps the mouse cursor at or near the middle of the exported movie by automatically scrolling the movie area.


CacheDiskSize

BB FlashBack SDK: FBExportToEXEParams

CacheDiskSize

Description

Sets the size of the disk cache, in bytes.

The CacheEnabled and CacheType properties determine whether a cache will be sued and whether it will be a memory or disk cache.

Syntax

[C#/C++]
public: long CacheDiskSize

[VB.NET]
Public Property CacheDiskSize As Long

Remarks

The EXE player keeps a cache of frames to improve performance. If the CacheType property has been set to use a disk cache instead of a memory cache, the CacheDiskSize property determines the size of the cache in bytes. A larger cache means better performance.

See Also


FBExportToEXEParams::CacheEnabled

BB FlashBack SDK: FBExportToEXEParams

CacheEnabled

Description

Determines whether the EXE export will use a frame cache. Use of a frame cache improves performance when seeking to random points within the movie via the playback controls embedded in the EXE export.

Syntax

[C#/C++]
public: Bool CacheEnabled

[VB.NET]
Public Property CacheEnabled As Boolean

See Also


CacheMemorySize

BB FlashBack SDK: FBExportToEXEParams

CacheMemorySize

Description

Sets the size of the memory cache, in bytes.

The CacheEnabled and CacheType properties determine whether a cache will be sued and whether it will be a memory or disk cache.

Syntax

[C#/C++]
public: long CacheMemorySize

[VB.NET]
Public Property CacheMemorySize As Long

Remarks

The EXE player keeps a cache of frames to improve performance. If the CacheType property has been set to use a memory cache instead of a disk cache, the CacheMemorySize property determines the size of the cache in bytes. A larger cache means better performance.

See Also


FBExportToEXEParams::CacheType

BB FlashBack SDK: FBExportToEXEParams

CacheType

Description

Sets where the frame cache to be used by the EXE export player - either in memory or on disk.

Syntax

[C#/C++]
public: long CacheType

[VB.NET]
Public Property CacheType As Long

Remarks

The EXE export player keeps a cache of frames to improve performance. The larger the cache, the better the performance when selecting random frames via the EXE export player playback controls.

This property determines whether the cache is stored in memory or on the disk, as follows:

Value | Cache type
0 | Default
1 | Memory
2 | Disk

Access to a memory cache will be faster and therefore will give smaller seek times than a disk cache, at a cost of higher memory usage.

Setting a value of zero means that the player will use a memory cache if enough free memory is available, and if not, it will use a disk cache.

The CacheEnabled property determines whether or not a cache will be used.

See Also


CloseOnFinish

BB FlashBack SDK: FBExportToEXEParams

CloseOnFinish

Description

Determines whether the EXE export player will close automatically when the movie reaches the end.

Syntax

[C#/C++]
public: Bool CloseOnFinish

[VB.NET]
Public Property CloseOnFinish As Boolean

See Also

FBExportToEXEParams::Loop


FBExportToEXEParams::DisableToolbar

BB FlashBack SDK: FBExportToEXEParams

DisableToolbar

Description

EXE exports can contain playback controls that allow the user to stop, pause, resume playback and jump to any point in the movie.

The DisableToolbar property sets whether the user can hide and unhide the toolbar via an option on the View menu on the EXE export player.

Visibility of the toolbar is set via the ShowToolbar property.

Functions available from the toolbar are:

  • Jump to start of movie

  • Jump to end of movie

  • Pause/Play

  • Stop and return to start

  • A 'timeline' control that enables jumping to any point in the movie

  • Volume adjustment

  • Button to toggle fullscreen mode

Syntax

[C#/C++]
public: Bool DisableToolbar

[VB.NET]
Public Property DisableToolbar As Boolean

See Also

FBExportToEXEParams::ShowToolbar


DisableUserInterface

BB FlashBack SDK: FBExportToEXEParams

DisableUserInterface

Description

Setting this property to True disables parts of the interface in the EXE export that contain English language. The exported EXE will contain no menus, error messages or popup hints.

The Language property enables export of fully localised EXEs.

Syntax

[C#/C++]
public: Bool DisableUserInterface

[VB.NET]
Public Property DisableUserInterface As Boolean

See Also

FBExportToEXEParams::Language


FBExportToEXEParams::FromFrame

BB FlashBack SDK: FBExportToEXEParams

FromFrame

Description

The frame of the movie at which to start the export.

A portion of the movie can be exported, instead of the entire movie, by setting the FromFrame and ToFrame properties.

By default, FromFrame and ToFrame are set to -1, indicating that all the frames in the movie should be exported.

Syntax

[C#/C++]
public: long FromFrame

[VB.NET]
Public Property FromFrame As Integer

See Also

FBExportToEXEParams::ToFrame


FBExportToEXEParams::Fullscreen

BB FlashBack SDK: FBExportToEXEParams

Fullscreen

Description

When Fullscreen is set to True, the EXE export occupies the full screen when opened.

Syntax

[C#/C++]
public Bool Fullscreen

[VB.NET]
Public Fullscreen As Boolean

Remarks

Setting this property to True means the EXE export opens in fullscreen mode - the toolbar is displayed but the menus are hidden. The user can switch between fullscreen and normal mode via a button on the toolbar.

Note: setting this to True overrides player sizes set by the WindowSize, Height and Width properties.


FBExportToEXEParams::Height

BB FlashBack SDK: FBExportToEXEParams

Height

Description

Sets the height that the EXE export player will open at, in pixels.

The Height and Width properties can only be used to set the default size of the EXE export player if the WindowSize property is set to zero, indicating it will open at a fixed size.

Syntax

[C#/C++]
public long Height

[VB.NET]
public Height as Long

See Also


HideMenu

BB FlashBack SDK: FBExportToEXEParams

HideMenu

Description

EXE exports have a menu bar like other applications. Set this property to True, so that when the exported exe is run, no menu bar is visible.

Syntax

[C#/C++]
public: Bool HideMenu

[VB.NET]
Public Property HideMenu As Boolean

See Also


HideMovieMenu

BB FlashBack SDK: FBExportToEXEParams

HideMovieMenu

Description

EXE exports have a menu bar like other applications. One of the menus on this menu bar is 'Movies'. The HideMovieMenu property determines whether this menu is displayed or hidden.

Options on the movie menu are:

  • Play / Pause

  • Stop

  • Go to start

  • Go to end

Syntax

[C#/C++]
public: Bool HideMovieMenu

[VB.NET]
Public Property HideMovieMenu As Boolean

See Also

FBExportToEXEParams::ShowToolbar


FBExportToEXEParams::HighlightMouseClicks

BB FlashBack SDK: FBExportToEXEParams

HighlightMouseClicks

Description

Determines whether mouse clicks are highlighted with animating circles in the exported movie.

Syntax

[C#/C++]
public Bool HighlightMouseClicks;

[VB.NET]
Public Property HighlightMouseClicks As Boolean


Language

BB FlashBack SDK: FBExportToEXEParams

Language

Description

This property enables the export of localised EXEs.

It sets the name of the resource file that text will be read from, to be used in control captions in the exported EXE.

Syntax

[C#/C++]
public BSTR Language;

[VB.NET]
public Language as String

Remarks

The SDK installation folder contains a MicroPlayerLangs folder, which contains a file "original.txt". This contains the English text strings displayed in the EXE export interface by default.

To produce a localised EXE export:

  1. Copy the original.txt file and rename it according to the language it will contain (e.g. "deutsch.txt").

  2. Translate the new .txt file.

  3. Set the Language property of FBExportToEXE to the language name (e.g. "deutsch").

When the EXE export is generated, the SDK looks for the appropriate text file in the MicroPlayerLangs folder and sets control captions and menu items from the strings within.

If the SDK cannot find the txt file set via the Language property, it uses original.txt.

The text files must use unicode encoding.

See Also

FBExportToEXEParams::DisableUserInterface


FBExportToEXEParams::Loop

BB FlashBack SDK: FBExportToEXEParams

Loop

Description

Determines whether the EXE export player will loop back to the start and replay the movie when it reaches the end.

Syntax

[C#/C++]
public: Bool Loop

[VB.NET]
Public Property Loop As Boolean

See Also

FBExportToEXEParams::CloseOnFinish


MixSounds

BB FlashBack SDK: FBExportToEXEParams

MixSounds

Description

Set to True to mix all movie sound tracks into one track for playback in the EXE export. This can reduce the file size for some movies with a number of sound tracks.

Syntax

[C#/C++]
public: Bool MixSounds

[VB.NET]
Public Property MixSounds As Boolean


PlaybackSpeed

BB FlashBack SDK: FBExportToEXEParams

PlaybackSpeed

Description

Sets the default playback speed for the export. The speed can be changed by the user via the EXE export user interface.

Syntax

[C#/C++]
public: long PlaybackSpeed

[VB.NET]
Public Property PlaybackSpeed As Integer

Remarks

Possible values are:

0 = 100% speed

1 = 50%

2 = 25%

3 = 200%

4 = 400%


FBExportToEXEParams::ShowOptions

BB FlashBack SDK: FBExportToEXEParams

ShowOptions

Description

Determines the action taken on passing the FBExportToEXEParams object to FBMovie::ExportToEXE.

Syntax

[C#/C++]
public Bool ShowOptions;

[VB.NET]
Public Property ShowOptions As Boolean

Remarks

If ShowOptions is set to True, and the FBExportToEXEParams object is passed to the FBMovie::ExportToEXE method, a dialog is displayed that enables the user to set export parameters.

If ShowOptions is set to False, and the FBExportToEXEParams object is passed to the FBMovie::ExportToEXE method, the export uses the properties of the FBExportToEXEParams object and does not show the export options dialog.

See Also

FBMovie::ExportToEXE


ShowToolbar

BB FlashBack SDK: FBExportToEXEParams

ShowToolbar

Description

EXE exports can contain playback controls that allow the user to stop, pause, resume playback and jump to any point in the movie.

The ShowToolbar property sets the visibility of the toolbar. Functions available from the toolbar are:

  • Jump to start of movie

  • Jump to end of movie

  • Pause/Play

  • Stop and return to start

  • A 'timeline' control that enables jumping to any point in the movie

  • Volume adjustment

  • Button to toggle fullscreen mode

Note: Even when hidden, the toolbar can be unhidden via the View menu in the EXE player. Set ShowToolbar to False and DisableToolbar to True to ensure that the toolbar is hidden and cannot be unhidden.

Syntax

[C#/C++]
public: Bool ShowToolbar

[VB.NET]
Public Property ShowToolbar As Boolean

See Also

FBExportToEXEParams::DisableToolbar


ToFrame

BB FlashBack SDK: FBExportToEXEParams

ToFrame

Description

The frame of the movie at which to stop the export.

A portion of the movie can be exported, instead of the entire movie, by setting the ToFrame and FromFrame properties.

By default, FromFrame and ToFrame are set to -1, indicating that all the frames in the movie should be exported.

Syntax

[C#/C++]
public: long ToFrame

[VB.NET]
Public Property ToFrame As Integer

See Also

FBExportToEXEParams::FromFrame


FBExportToEXEParams::Width

BB FlashBack SDK: FBExportToEXEParams

Width

Description

Sets the width that the EXE export player will open at, in pixels.

The Height and Width properties can only be used to set the default size of the EXE export player if the WindowSize property is set to zero, indicating it will open at a fixed size.

Syntax

[C#/C++]
public long Width

[VB.NET]
public Width as Long

See Also


WindowSize

BB FlashBack SDK: FBExportToEXEParams

WindowSize

Description

Sets the default size of the exe export player. It can be set to a fixed size, the size of the movie, or maximised.

Syntax

[C#/C++]
public: long WindowSize

[VB.NET]
Public Property WindowSize As Long

Remarks

This property determines the default size of the exe export movie player, as follows:

Value | Player Size
0 | Fixed size, determined by the Height and Width properties.
1 | Automatically sizes to the movie dimensions.
2 | Maximised

Note: setting the Fullscreen property to True overrides player sizes set with WindowSize, Height and Width, and causes the export to open in fullscreen mode, with menus hidden.

See Also


AutoscrollDimX

BB FlashBack SDK: FBExportToQuickTimeParams

AutoscrollDimX

Description

Returns and sets the width of the autoscroll frame.

Syntax

[C#/C++]
public long AutoscrollDimX;

[VB.NET]
Public Property AutoscrollDimX As Long

Remarks

The autoscroll feature keeps the mouse cursor at or near the middle of the exported movie by automatically scrolling the 'autoscroll frame'.

Autoscroll is enabled by setting AutoscrollMode to True. The autoscroll frame dimensions are specified by the AutoscrollDimX and AutoscrollDimY properties.

See also


AutoscrollDimY

BB FlashBack SDK: FBExportToQuickTimeParams

AutoscrollDimY

Description

Returns and sets the height of the autoscroll frame.

Syntax

[C#/C++]
public long AutoscrollDimY;

[VB.NET]
Public Property AutoscrollDimY As Long

Remarks

The autoscroll feature keeps the mouse cursor at or near the middle of the exported movie by automatically scrolling the 'autoscroll frame'.

Autoscroll is enabled by setting AutoscrollMode to True. The autoscroll frame dimensions are specified by the AutoscrollDimX and AutoscrollDimY properties.

See also


AutoscrollMode

BB FlashBack SDK: FBExportToQuickTimeParams

AutoscrollMode

Description

Returns and sets a value indicating whether autoscroll will be used during export.

Syntax

[C#/C++]
public Bool AutoscrollMode;

[VB.NET]
Public Property AutoscrollMode As Boolean

Remarks

Set this property to True to enable autoscroll.

The autoscroll feature keeps the mouse cursor at or near the middle of the exported movie by automatically scrolling the 'autoscroll frame'.

The autoscroll frame dimensions are specified by the AutoscrollDimX and AutoscrollDimY properties.

See also


DataRate

BB FlashBack SDK: FBExportToQuickTimeParams

DataRate

Description

Sets the bitrate in KBytes per second of the exported movie.

Syntax

[C#/C++]
public long DataRate;

[VB.NET]
Public Property DataRate As Long

Remarks

This value is used only when DataRateType is set to 1.

The higher the DataRate of the movie, the higher the image quality.

See also

FBExportToQuickTimeParams::Quality FBExportToQuickTimeParams::DataRateType FBExportToQuickTimeParams::DataRateMin FBExportToQuickTimeParams::DataRateMax FBExportToQuickTimeParams::Multipass FBExportToQuickTimeParams::KeyFrame


DataRateMax

BB FlashBack SDK: FBExportToQuickTimeParams

DataRateMax

Description

Sets the upper boundary for the bitrate in KBytes per second of the exported movie.

Syntax

[C#/C++]
public long DataRateMax;

[VB.NET]
Public Property DataRateMax As Long

Remarks

This value is used only when DataRateType is set to 2.

The higher the DataRate of the movie, the higher the image quality.

See also

FBExportToQuickTimeParams::Quality FBExportToQuickTimeParams::DataRateType FBExportToQuickTimeParams::DataRateMin FBExportToQuickTimeParams::DataRate FBExportToQuickTimeParams::Multipass FBExportToQuickTimeParams::KeyFrame


DataRateMin

BB FlashBack SDK: FBExportToQuickTimeParams

DataRateMin

Description

Sets the lower boundary for the bitrate in KBytes per second of the exported movie.

Syntax

[C#/C++]
public long DataRateMin;

[VB.NET]
Public Property DataRateMin As Long

Remarks

This value is used only when DataRateType is set to 2.

The higher the DataRate of the movie, the higher the image quality.

See also

FBExportToQuickTimeParams::Quality FBExportToQuickTimeParams::DataRateType FBExportToQuickTimeParams::DataRateMax FBExportToQuickTimeParams::DataRate FBExportToQuickTimeParams::Multipass FBExportToQuickTimeParams::KeyFrame


DataRateType

BB FlashBack SDK: FBExportToQuickTimeParams

DataRateType

Description

Determines how the data rate will be set for the exported movie.

Syntax

[C#/C++]
public long DataRateType;

[VB.NET]
Public Property DataRateType As Long

Remarks

DataRateType can take one of the following values:

0 - Automatic (varies according to the Quality property)

1 - Average (the value of the DataRate property is used)

2 - Manual (the DataRateMin and DataRateMax properties are used to determine upper and lower boundaries for the datarate)

See also

FBExportToQuickTimeParams::Quality FBExportToQuickTimeParams::DataRate FBExportToQuickTimeParams::DataRateMin FBExportToQuickTimeParams::DataRateMax FBExportToQuickTimeParams::Multipass FBExportToQuickTimeParams::KeyFrame


ExportSounds

BB FlashBack SDK: FBExportToQuickTimeParams

ExportSounds

Description

Determines whether any sound tracks in the movie are exported.

Syntax

[C#/C++]
public Bool ExportSounds;

[VB.NET]
Public Property ExportSounds As Boolean

See Also


FlattenMovie

BB FlashBack SDK: FBExportToQuickTimeParams

FlattenMovie

Description

Enables 'flattening' of the QuickTime movie which results in reordering of frames so that the movie can be streamed.

Syntax

[C#/C++]
public: Bool FlattenMovie

[VB.NET]
Public Property FlattenMovie As Boolean


FrameRateCustom

BB FlashBack SDK: FBExportToQuickTimeParams

FrameRateCustom

Description

Sets the frame rate, in frames per second, at which to export, when a 'custom' frame rate has been selected via the FrameRateMode property.

Syntax

[C#/C++]
public long FrameRateCustom;

[VB.NET]
Public Property FrameRateCustom As Long

Remarks

This property is only used when FrameRateMode is set to 3.

See Also

FBExportToQuickTimeParams::FrameRateMode


FrameRateMode

BB FlashBack SDK: FBExportToQuickTimeParams

FrameRateMode

Description

Sets the frame rate at which to export.

Syntax

[C#/C++]
public long FrameRateMode;

[VB.NET]
Public Property FrameRateMode As Long

Remarks

Can be one of these values:

Value | Frame rate
0 | Same frame rate as the native FBR movie recording.
1 | 1/2 frame rate of movie.
2 | 1/4 frame rate of movie.
3 | Frame rate defined by the FrameRateCustom property.

The default frame rate for movies recorded with the capture driver is 25fps.

See Also

FBExportToQuickTimeParams::FrameRateCustom


KeyFrame

BB FlashBack SDK: FBExportToQuickTimeParams

KeyFrame

Description

Returns and sets the frequency of keyframes in the exported movie.

When set to 1, this would mean that every frame is a keyframe. If set to 10, for example, every 10th frame would be a keyframe.

The more keyframes in the exported video, the better the quality but the larger the filesize.

Syntax

[C#/C++]
public long KeyFrame;

[VB.NET]
Public Property KeyFrame As Integer

See also

FBExportToQuickTimeParams::Quality FBExportToQuickTimeParams::DataRateType FBExportToQuickTimeParams::DataRate FBExportToQuickTimeParams::DataRateMin FBExportToQuickTimeParams::DataRateMax FBExportToQuickTimeParams::Multipass


Multipass

BB FlashBack SDK: FBExportToQuickTimeParams

Multipass

Description

Sets the number of passes to be used encoding the video stream. Using multiple passes generally results in higher qualiuty, but takes longer to export

Syntax

[C#/C++]
public Bool Multipass;

[VB.NET]
Public Property Multipass As Boolean

See also

FBExportToQuickTimeParams::Quality FBExportToQuickTimeParams::DataRateType FBExportToQuickTimeParams::DataRate FBExportToQuickTimeParams::DataRateMin FBExportToQuickTimeParams::DataRateMax FBExportToQuickTimeParams::KeyFrame


OutputSizeKeepAspectRatio

BB FlashBack SDK: FBExportToQuickTimeParams

OutputSizeKeepAspectRatio

Description

Returns and sets the value that determines whether the aspect ratio of the movie is maintained when its width or height are altered via the OutputSizePercentX or OutputSizePercentY properties.

Syntax

[C#/C++]
public Bool OutputSizeKeepAspectRatio;

[VB.NET]
Public Property OutputSizeKeepAspectRatio As Boolean

Remarks

If this property is set to True, altering OutputSizePercentX or OutputSizePercentY automatically changes the other percentage to the same value, to maintain the aspect ratio of the movie.

See also


OutputSizePercentX

BB FlashBack SDK: FBExportToQuickTimeParams

OutputSizePercentX

Description

Returns and sets the percentage scaling applied to the width of the movie, when exported.

Note: this property is deprecated in favour of OutputSizePercentXFloat.

Syntax

[C#/C++]
public long OutputSizePercentX;

[VB.NET]
Public Property OutputSizePercentX As Long

Remarks

If OutputSizeKeepAspectRatio is set to True, changing the percent scaling for the width results in the percent scaling for the height (the OutputSizePercentY property) being set to the same value.

See also

FBExportToQuickTimeParams::OutputSizeKeepAspectRatio FBExportToQuickTimeParams::OutputSizePercentY

FBExportToQuickTimeParams::OutputSizePercentXFloat


OutputSizePercentXFloat

BB FlashBack SDK: FBExportToQuickTimeParams

OutputSizePercentXFloat

Description

Returns and sets the percentage scaling applied to the width of the movie, when exported.

Syntax

[C#/C++]
public float OutputSizePercentXFloat;

[VB.NET]
Public Property OutputSizePercentXFloat As Single

Remarks

If OutputSizeKeepAspectRatio is set to True, changing the percent scaling for the width results in the percent scaling for the height (the OutputSizePercentYFloat property) being set to the same value.

See also


OutputSizePercentY

BB FlashBack SDK: FBExportToQuickTimeParams

OutputSizePercentY

Description

Returns and sets the percentage scaling applied to the height of the movie, when exported.

Note: this property is deprecated in favour of OutputSizePercentYFloat.

Syntax

[C#/C++]
public long OutputSizePercentY;

[VB.NET]
Public Property OutputSizePercentY As Long

Remarks

If OutputSizeKeepAspectRatio is set to True, changing the percent scaling for the height results in the percent scaling for the width (the OutputSizePercentX property) being set to the same value.

See also

FBExportToQuickTimeParams:OutputSizeKeepAspectRatio FBExportToQuickTimeParams::OutputSizePercentX

FBExportToQuickTimeParams::OutputSizePercentYFloat


OutputSizePercentYFloat

BB FlashBack SDK: FBExportToQuickTimeParams

OutputSizePercentYFloat

Description

Returns and sets the percentage scaling applied to the height of the movie, when exported.

Syntax

[C#/C++]
public float OutputSizePercentYFloat;

[VB.NET]
Public Property OutputSizePercentYFloat As Single

Remarks

If OutputSizeKeepAspectRatio is set to True, changing the percent scaling for the height results in the percent scaling for the width (the OutputSizePercentXFloat property) being set to the same value.

See also


OutputSizeX

BB FlashBack SDK: FBExportToQuickTimeParams

OutputSizeX

Description

Returns and sets the width of the movie in pixels, when exported.

Syntax

[C#/C++]
public long OutputSizeX;

[VB.NET]
Public Property OutputSizeX As Long

Remarks

If OutputSizeKeepAspectRatio is set to True, changing the width results in the height (the OutputSizeY property) being set accordingly.

See also


OutputSizeY

BB FlashBack SDK: FBExportToQuickTimeParams

OutputSizeY

Description

Returns and sets the height of the movie in pixels, when exported.

Syntax

[C#/C++]
public long OutputSizeY;

[VB.NET]
Public Property OutputSizeY As Long

Remarks

If OutputSizeKeepAspectRatio is set to True, changing the height results in the width (the OutputSizeX property) being set accordingly.

See also


Quality

BB FlashBack SDK: FBExportToQuickTimeParams

Quality

Description

Sets and returns the quality used when exporting QuickTime movies.

Syntax

[C#/C++]
public long Quality;

[VB.NET]
Public Property Quality As Long

Remarks

This value ranges from 1-100, where 1 is the lowest quality and 100 is the highest. The higher the quality, the larger the file exported.

See also

FBExportToQuickTimeParams::DataRateType FBExportToQuickTimeParams::DataRate FBExportToQuickTimeParams::DataRateMin FBExportToQuickTimeParams::DataRateMax FBExportToQuickTimeParams::Multipass FBExportToQuickTimeParams::KeyFrame


ScaleToPercents

BB FlashBack SDK: FBExportToQuickTimeParams

ScaleToPercents

Description

Determines whether percent scaling or pixel sizes should be used to set the dimensions of the exported movie.

The parameters OutputSizeX and OutputSizeY set the pixel size.

The parameters OutputSizePercentX and OutputSizePercentY set the percent scaling.

Syntax

[C#/C++]
public Bool ScaleToPercents;

[VB.NET]
Public Property ScaleToPercents As Boolean

See Also


ShowMousePointer

BB FlashBack SDK: FBExportToQuickTimeParams

ShowMousePointer

Description

Determines whether to show the mouse pointer in the exported movie. Set the property to true to show the cursor.

Syntax

[C#/C++]
public Bool ShowMousePointer;

[VB.NET]
Public Property ShowMousePointer As Boolean


ShowOptions

BB FlashBack SDK: FBExportToQuickTimeParams

ShowOptions

Description

Determines the action taken on passing the FBExportToQuickTimeParams object to FBMovie::ExportToQuickTime.

Syntax

[C#/C++]
public Bool ShowOptions;

[VB.NET]
Public Property ShowOptions As Boolean

Remarks

If ShowOptions is set to True, and the FBExportToQuickTimeParams object is passed to the FBMovie::ExportToQuickTime method, a dialog is displayed that enables the user to set export options.

If ShowOptions is set to False, and the FBExportToQuickTimeParams object is passed to the FBMovie::ExportToQuickTime method, the export uses the properties of the FBExportToQuickTimeParams object and does not show the export options dialog.

See Also

FBMovie::ExportToQuickTime


SoundCompressFormat

BB FlashBack SDK: FBExportToQuickTimeParams

SoundCompressFormat

Description

Determines whether MP3 compression or no compression at all should be used in the exported movie.

Syntax

[C#/C++]
public long SoundCompressFormat;

[VB.NET]
Public Property SoundCompressFormat As Long

Remarks

This can be one of the following standard Win32 SDK constants:

WAVE_FORMAT_PCM = 1

WAVE_FORMAT_MPEGLAYER3 = 85

Files exported with sound in PCM (uncompressed) format may be much larger than those exported from the same movie using MP3 format.

See Also

FBExportToQuickTimeParams::SoundMP3Profile


SoundFormat

BB FlashBack SDK: FBExportToQuickTimeParams

SoundFormat

Description

Sets the sound format used in the exported movie.

Syntax

[C#/C++]
public long SoundFormat;

[VB.NET]
Public Property SoundFormat As Long

Remarks

This can be one of the following standard Win32 SDK constants, describing the number of channels, sample rate and bits per sample:

Value |  | Format
WAVE_FORMAT_1M08 | 0x00000001 | 11.025 kHz, mono, 8-bit.
WAVE_FORMAT_1S08 | 0x00000002 | 11.025 kHz, stereo, 8-bit.
WAVE_FORMAT_1M16 | 0x00000004 | 11.025 kHz, mono, 16-bit.
WAVE_FORMAT_1S16 | 0x00000008 | 11.025 kHz, stereo, 16-bit.
WAVE_FORMAT_2M08 | 0x00000010 | 22.05 kHz, mono, 8-bit.
WAVE_FORMAT_2S08 | 0x00000020 | 22.05 kHz, stereo, 8-bit.
WAVE_FORMAT_2M16 | 0x00000040 | 22.05 kHz, mono, 16-bit.
WAVE_FORMAT_2S16 | 0x00000080 | 22.05 kHz, stereo, 16-bit.
WAVE_FORMAT_4M08 | 0x00000100 | 44.1 kHz, mono, 8-bit.
WAVE_FORMAT_4S08 | 0x00000200 | 44.1 kHz, stereo, 8-bit.
WAVE_FORMAT_4M16 | 0x00000400 | 44.1 kHz, mono, 16-bit.
WAVE_FORMAT_4S16 | 0x00000800 | 44.1 kHz, stereo, 16-bit.
WAVE_FORMAT_48M08 | 0x00001000 | 48 KHz, Mono, 8 bit
WAVE_FORMAT_48S08 | 0x00002000 | 48 KHz, Stereo, 8 bit
WAVE_FORMAT_48M16 | 0x00004000 | 48 KHz, Mono, 16 bit
WAVE_FORMAT_48S16 | 0x00008000 | 48 KHz, Stereo, 16 bit
WAVE_FORMAT_96M08 | 0x00010000 | 96 KHz, Mono, 8 bit
WAVE_FORMAT_96S08 | 0x00020000 | 96 KHz, Stereo, 8 bit
WAVE_FORMAT_96M16 | 0x00040000 | 96 KHz, Mono, 16 bit
WAVE_FORMAT_96S16 | 0x00080000 | 96 KHz, Stereo, 16 bit

If SoundFormat is set to zero, the format used on export is determined by the format of the sounds in the movie. See UseBestFormat for more details.

See also

FBExportToQuickTimeParams::UseBestFormat


SoundMP3Format

BB FlashBack SDK: FBExportToQuickTimeParams

SoundMP3Profile

Description

Sets the level of MP3 compression to be used in the exported movie.

Syntax

[C#/C++]
public long SoundMP3Profile;

[VB.NET]
Public Property SoundMP3Profile As Long

Remarks

SoundMP3Profile can be one of the following constants:

Value | Audio Quality
0 | Normal
1 | Low
2 | High
5 | Very high

Higher audio quality means less compression and larger file sizes.

This property is ignored if SoundCompressFormat is not set to MP3.

See Also

FBExportToQuickTimeParams::SoundCompressFormat


UseBestFormat

BB FlashBack SDK: FBExportToQuickTimeParams

UseBestFormat

Description

This works in connection with the SoundFormat property to allow the SDK to automatically determine the sound format to use on export, based on the format of the various sounds in the movie.

Syntax

[C#/C++]
public Bool UseBestFormat;

[VB.NET]
Public Property UseBestFormat As Boolean

Remarks

If SoundFormat is set to zero, the value of UseBestFormat determines the sound format to be used on export.

If a movie contains more than one sound file, all sounds have to mixed to a single format before being exported. Setting UseBestFormat to True means the highest quality format used by any sound in the movie will be used for the export format. Setting UseBestFormat to False means all sounds are mixed to the lowest quality format used by any sound in the movie.

For example, if a movie has two sounds: one at 44Khz and one at 22Khz:

  • SoundFormat = 0 and UseBestFormat = True : all sounds mixed to 44Khz before export

  • SoundFormat = 0 and UseBestFormat = False : all sounds mixed to 22Khz before export

  • SoundFormat != 0 : all sounds are mixed to whatever format is indicated in SoundFormat.

See Also

FBExportToQuickTimeParams::SoundFormat


ShowMousePointer

BB FlashBack SDK: FBBatchExportToSWFParams

ShowMousePointer

Description

Determines whether to show the mouse pointer in the exported movie. Set the property to true to show the cursor.

Syntax

[C#/C++]
public Bool ShowMousePointer;

[VB.NET]
Public Property ShowMousePointer As Boolean


ExportSounds

BB FlashBack SDK: FBBatchExportToSWFParams

ExportSounds

Description

Determines whether any sound tracks in the movies are exported.

Syntax

[C#/C++]
public Bool ExportSounds;

[VB.NET]
Public Property ExportSounds As Boolean


Selecting an MP4 codec

Selecting an MP4 Encoder

The FlashBack SDK does not include code to encode H264 video. However, it can use a variety of 3rd party code to generate H264 encoded video files.

Note: H263 and H264 are not royalty free codecs. If you develop and distribute an application that generates H263/H264 encoded video, you may be liable for royalties - get the advice of a lawyer. The exception to this is if you use the openh264 codec as described below - in this case Cisco has declared that it will cover MPEG LA licensing fees (http://www.openh264.org/faq.html )

Set the FBExportToMP4Params::MP4Codec property to 0 to select h263 encoding or 1 to select h264.

With H264 selected, the FBExportToMP4Params::H264Encoder property selects the H264 encoder used:

  • 1 = QuickTime
    Apple's QuickTime v7 or later must be installed on the user's PC to enable use of this option.

  • 2 = Microsoft Media Foundation
    Microsoft Media Foundation (MSMF) is a component of Windows installed with Vista and newer. Since Windows 7 it includes the ability to encode H264 video.

  • 3 = Openh264
    Cisco has taken their H264 implementation and open sourced it under BSD licence terms, enabling it to be used by open source or commercially licensed projects.

Using OpenH264

If the client application does not include the openh264 binary executable in its distribution, but uses Cisco's distribution, Cisco has stated that they will pay royalties due on H264 generated by the application. Specifically, your application needs to :

  • Download the openh264 binary from http://ciscobinary.openh264.org/openh264-1.2.0-win32msvc.dll.bz2

  • Rename the DLL to welsenc.dll

  • Copy the DLL and the 2 configuration files included in the FlashBack SDK installation - welsenc.cfg, welslayer.cfg - into the same folder as your executable.


AllowStreaming

BB FlashBack SDK: FBExportToMP4Params

AllowStreaming

Description

Set this property to True to enable streaming playback of the exported MP4 file. The property defaults to False.

Syntax

[C#/C++]
public bool AllowStreaming;

[VB.NET]
Public Property AllowStreaming As Boolean


AudioBitrate

BB FlashBack SDK: FBExportToMP4Params

AudioBitrate

Description

Sets the bitrate in KBits per second of audio in the exported movie.

Syntax

[C#/C++]
public long VideoBitrate;

[VB.NET]
Public Property VideoBitrate As Long

Remarks

This value is used only when ExportSound is set to True.

Audio is exported in AAC format. The higher the bitrate of the audio, the higher the quality.

See also

FBExportToMP4Params::ExportSound


CalculateCuePoints

BB FlashBack SDK: FBExportToMP4Params

CalculateCuePoints

Description

When set to True, data describing any 'cue points' in the movie is written into the FBExportToMP4Params::CuePoints property in XML format.

Cue Points are places in the movie where it pauses to wait for user input, such as a 'click to continue' textbox or button. It can be useful to have this information in XML format, to be able to implement interactivity in video playback software. For example, the XML can be passed in a parameter to JW Player and processed by a custom plugin to implement interactivity in MP4 movies played back in a web browser.

See the help for the CuePoints property for information on the format used.

This property defaults to False.

Syntax

[C#/C++]
public bool CalculateCuePoints;

[VB.NET]
Public Property CalculateCuePoints As Boolean

See Also

FBExportToMP4Params::CuePoints


CuePoints

BB FlashBack SDK: FBExportToMP4Params

CuePoints

Description

When the CalculateCuePoints property is set to True, information on "CuePoints" in the movie is written into the CuePoints parameter. If CalculateCuePoints has not been set to True, the CuePoints property is empty.

Cue Points are places in the movie where it pauses to wait for user input, such as a 'click to continue' textbox or button. It can be useful to have this information in XML format, to be able to implement interactivity in video playback software. For example, the XML can be passed in a parameter to JW Player and processed by a custom plugin to implement interactivity in MP4 movies played back in a web browser.

Syntax

[C#/C++]
public BSTR CuePoints;

[VB.NET]
Public Property CuePoints As String

Remarks

The format of the XML is:

<cuePoints>
<cuePoint type="event" time="timestamp" data="cuepoint_description"/>
...more cue points...
</cuePoints>

The "time" attribute is the number of milliseconds from the start of the movie, as a decimal value.

The "data" attribute holds information about the object triggering the cuepoint. Its format is:

fb;<object id>;<object type>;<other object properties separated by ';'>

<object id> is the unique id value for that object in the movie

<object type> is a value specifying the type of object - see below for the values

TextBox:
fb;<id>;10;0|1 (display or do not display pause graphic)

Arrow:
fb;<id>;48;0|1 (display or do not display pause graphic)

Marker:
fb;<id>;9;0|1 (display or do not display pause graphic)

Pause:
fb;<id>;50;0|1 (display or do not display pause graphic);0|1 (wait click);int_duration_ms

Highlight:
fb;<id>;41;0|1 (display or do not display pause graphic)

Image:
fb;<id>;33;0|1 (display or do not display pause graphic)

Button:
fb;<id>;36;0|1 (display or do not display pause graphic);int_pause;int_origin_x;int_origin_y;int_width;int_height;int_duration;int_action;str_url_or_script_or_jumpto_or_playafter

So a full example of the cuepoint XML could be:

<cuePoints>
<cuePoint type="event" time="2500" data="fb;1;33;0"/>
</cuePoints>

This describes a pause at 2.5 seconds into the movie to show an image. The default pause graphic is not displayed.

See Also

FBExportToMP4Params::CalculateCuePoints


DeviceType

BB FlashBack SDK: FBExportToMP4Params

DeviceType

Description

When FreeScaling is set to True, the DeviceType parameter restricts the dimensions of the exported video file.

Syntax

[C#/C++]
public long DeviceType;

[VB.NET]
Public Property DeviceType As Integer

Remarks

Value | Effect
0 | Restricts the height to 240 pixels and width to 320 pixels. The maximum dimensions for playback on the iPod Classic and iPod Nano
1 | Restricts the height to 480 pixels and the width to 640 pixels. The maximum dimensions for playback on the iPhone 3,2,1 or iPod touch.
2 | Restricts the height to 720 pixels and width to 1024 pixels. The maxiumum dimensions for playback on the iPad and iPhone 4

See Also

FBExportToMP4Params::FreeScaling


DrawPauseImage

BB FlashBack SDK: FBExportToMP4Params

DrawPauseImage

Description

Set this property to true to have the export display a pause icon for a short period, where a pause is defined in the FlashBack movie.

Displaying the pause image can be useful if you are playing back the export in your own player and are using CuePoints to pause playback where pauses are defined in the FlashBack movie.

Syntax

[C#/C++]
public Bool DrawPauseImage;

[VB.NET]
Public Property DrawPauseImage As Boolean

See also

FBExportToMP4Params::CuePoints


ExportFromFrame

BB FlashBack SDK: FBExportToMP4Params

ExportFromFrame

Description

Sets the frame in the movie at which the export will start. Set it to -1 to have the export start at the first frame of the movie.

Syntax

[C#/C++]
public long ExportFromFrame;

[VB.NET]
Public Property ExportFromFrame As Long

See also

FBExportToMP4Params::ExportToFrame


ExportSound

BB FlashBack SDK: FBExportToMP4Params

ExportSound

Description

Sets this parameter to True to export any audio in the movie, or False to export without audio.

Syntax

[C#/C++]
public Bool ExportSound;

[VB.NET]
Public Property ExportSound As Boolean

See also

FBExportToMP4Params::AudioBitrate


ExportToFrame

BB FlashBack SDK: FBExportToMP4Params

ExportToFrame

Description

Sets the frame in the movie at which the export will finish. Set it to -1 to have the export finish at the final frame of the movie.

Syntax

[C#/C++]
public long ExportToFrame;

[VB.NET]
Public Property ExportToFrame As Long

See also

FBExportToMP4Params::ExportFromFrame


FrameRate

BB FlashBack SDK: FBExportToMP4Params

FrameRate

Description

Sets the frame rate, in frames per second, at which to export.

Syntax

[C#/C++]
public long FrameRate;

[VB.NET]
Public Property FrameRate As Long

See Also

FBExportToMP4Params::KeyFrames


FreeScaling

BB FlashBack SDK: FBExportToMP4Params

FreeScaling

Description

When set to True, the dimensions of MPEG4 exports are restricted according to the DeviceType property.

This property defaults to False.

Syntax

[C#/C++]
public bool FreeScaling;

[VB.NET]
Public Property FreeScaling As Boolean

See Also

FBExportToMP4Params::DeviceType


H264Encoder

BB FlashBack SDK: FBExportToMP4Params

H264Encoder

Description

Selects the 3rd party H264 encoder to be used, when H264 encoding has been selected by FBExportToMP4Params::MP4Codec

Syntax

[C#/C++]
public long H264Encoder;

[VB.NET]
Public Property H264Encoder As Long

Remarks

1 = QuickTime
Apple's QuickTime v7 or later must be installed on the user's PC to enable use of this option.

2 = Microsoft Media Foundation
Microsoft Media Foundation (MSMF) is a component of Windows installed with Vista and newer. Since Windows 7 it includes the ability to encode H264 video.

3 = Openh264
Cisco has taken their H264 implementation and open sourced it under BSD licence terms, enabling it to be used by open source or commercially licensed projects.

See Selecting an MP4 Encoder for details of how openh264 should be used.

See also


KeyFrames

BB FlashBack SDK: FBExportToMP4Params

KeyFrames

Description

Returns and sets the frequency of keyframes in the exported movie.

When set to 1, this would mean that every frame is a keyframe. If set to 10, for example, every 10th frame would be a keyframe.

The more keyframes in the exported video, the better the quality but the larger the filesize.

Syntax

[C#/C++]
public long KeyFrames;

[VB.NET]
Public Property KeyFrames As Integer

See also

FBExportToMP4Params::FrameRate


MP4Codec

BB FlashBack SDK: FBExportToMP4Params

MP4Codec

Description

Sets the codec to be used - either H263 (MPEG4-ASP) or H264 (MPEG4-AVC).

Set to 0 (the default) to use H263 (MPEG4-ASP)

Set to 1 to use H264 (MPEG4-AVC). For details of how to select the 3rd party H264 encoder that will be used, see Selecting an MP4 Encoder.

Syntax

[C#/C++]
public long MP4Codec;

[VB.NET]
Public Property MP4Codec As Long


OutputSizeKeepAspectRatio

BB FlashBack SDK: FBExportToMP4Params

OutputSizeKeepAspectRatio

Description

Returns and sets the value that determines whether the aspect ratio of the movie is maintained when its width or height are altered via the OutputSizePercentXFloat or OutputSizePercentYFloat properties.

Syntax

[C#/C++]
public Bool OutputSizeKeepAspectRatio;

[VB.NET]
Public Property OutputSizeKeepAspectRatio As Boolean

Remarks

If this property is set to True, altering OutputSizePercentXFloat or OutputSizePercentYFloat automatically changes the other percentage to the same value, to maintain the aspect ratio of the movie.

See also


OutputSizePercentX

BB FlashBack SDK: FBExportToMP4Params

OutputSizePercentX

Description

Returns and sets the percentage scaling applied to the width of the movie, when exported.

Note: this property is deprecated in favour of OutputSizePercentXFloat.

Note: if FreeScaling is set to False, limits are imposed on the export dimensions by the DeviceType property

Syntax

[C#/C++]
public long OutputSizePercentX;

[VB.NET]
Public Property OutputSizePercentX As Long

Remarks

If OutputSizeKeepAspectRatio is set to True, changing the percent scaling for the width results in the percent scaling for the height (the OutputSizePercentY property) being set to the same value.

See also

FBExportToMP4Params::OutputSizeKeepAspectRatio FBExportToMP4Params::OutputSizePercentY

FBExportToMP4Params::OutputSizePercentXFloat


OutputSizePercentXFloat

BB FlashBack SDK: FBExportToMP4Params

OutputSizePercentXFloat

Description

Returns and sets the percentage scaling applied to the width of the movie, when exported.

Note: if FreeScaling is set to False, limits are imposed on the export dimensions by the DeviceType property.

Syntax

[C#/C++]
public float OutputSizePercentXFloat;

[VB.NET]
Public Property OutputSizePercentXFloat As Single

Remarks

If ScaleToPercents is set True, OutputSizePercentXFloat and OutputSizePercentYFloat are used to scale the export. if ScaleToPercents is set to False, OutputSizeX and OutputSizeY are used to scale the export to an exact pixel size.

See also


OutputSizePercentY

BB FlashBack SDK: FBExportToMP4Params

OutputSizePercentY

Description

Returns and sets the percentage scaling applied to the height of the movie, when exported.

Note: this property is deprecated in favour of OutputSizePercentYFloat.

Note: if FreeScaling is set to False, limits are imposed on the export dimensions by the DeviceType property.

Syntax

[C#/C++]
public long OutputSizePercentY;

[VB.NET]
Public Property OutputSizePercentY As Long

Remarks

If OutputSizeKeepAspectRatio is set to True, changing the percent scaling for the height results in the percent scaling for the width (the OutputSizePercentX property) being set to the same value.

See also


OutputSizePercentYFloat

BB FlashBack SDK: FBExportToMP4Params

OutputSizePercentYFloat

Description

Returns and sets the percentage scaling applied to the width of the movie, when exported.

Note: if FreeScaling is set to False, limits are imposed on the export dimensions by the DeviceType property.

Syntax

[C#/C++]
public float OutputSizePercentYFloat;

[VB.NET]
Public Property OutputSizePercentYFloat As Single

Remarks

If ScaleToPercents is set True, OutputSizePercentXFloat and OutputSizePercentYFloat are used to scale the export. if ScaleToPercents is set to False, OutputSizeX and OutputSizeY are used to scale the export to an exact pixel size.

See also


OutputSizeX

BB FlashBack SDK: FBExportToMP4Params

OutputSizeX

Description

Returns and sets the width of the movie in pixels, when exported.

Note: if FreeScaling is set to False, limits are imposed on the export dimensions by the DeviceType property.

Syntax

[C#/C++]
public long OutputSizeX;

[VB.NET]
Public Property OutputSizeX As Long

Remarks

If ScaleToPercents is set True, OutputSizePercentXFloat and OutputSizePercentYFloat are used to scale the export. if ScaleToPercents is set to False, OutputSizeX and OutputSizeY are used to scale the export to an exact pixel size.

See also

FBExportToMP4Params:OutputSizeY FBExportToMP4Params:OutputSizePercentXFloat FBExportToMP4Params::OutputSizePercentYFloat FBExportToMP4Params:ScaleToPercents


OutputSizeY

BB FlashBack SDK: FBExportToMP4Params

OutputSizeY

Description

Returns and sets the height of the movie in pixels, when exported.

Note: if FreeScaling is set to False, limits are imposed on the export dimensions by the DeviceType property.

Syntax

[C#/C++]
public long OutputSizeY;

[VB.NET]
Public Property OutputSizeY As Long

Remarks

If ScaleToPercents is set True, OutputSizePercentXFloat and OutputSizePercentYFloat are used to scale the export. if ScaleToPercents is set to False, OutputSizeX and OutputSizeY are used to scale the export to an exact pixel size.

See also

FBExportToMP4Params:OutputSizeX FBExportToMP4Params:OutputSizePercentXFloat FBExportToMP4Params::OutputSizePercentYFloat FBExportToMP4Params:ScaleToPercents


ScaleToPercents

BB FlashBack SDK: FBExportToMP4Params

ScaleToPercents

Description

Determines whether percent scaling or pixel sizes should be used to set the dimensions of the exported movie.

The parameters OutputSizeX and OutputSizeY set the pixel size.

The parameters OutputSizePercentX and OutputSizePercentY set the percent scaling.

Syntax

[C#/C++]
public Bool ScaleToPercents;

[VB.NET]
Public Property ScaleToPercents As Boolean

See Also


ShowOptions

BB FlashBack SDK: FBExportToMP4Params

ShowOptions

Description

Determines the action taken on passing the FBExportToMP4Params object to FBMovie::ExportToMP4.

Syntax

[C#/C++]
public Bool ShowOptions;

[VB.NET]
Public Property ShowOptions As Boolean

Remarks

If ShowOptions is set to True, and the FBExportToMP4Params object is passed to the FBMovie::ExportToMP4 method, a dialog is displayed that enables the user to set export options.

If ShowOptions is set to False, and the FBExportToMP4Params object is passed to the FBMovie::ExportToMP4 method, the export uses the properties of the FBExportToMP4Params object and does not show the export options dialog.

See Also

FBMovie::ExportToMP4


VideoBitrate

BB FlashBack SDK: FBExportToMP4Params

VideoBitrate

Description

Sets the bitrate in KBytes per second of the exported movie.

Syntax

[C#/C++]
public long VideoBitrate;

[VB.NET]
Public Property VideoBitrate As Long

Remarks

This value is used only when VideoQualityMode is set to 1.

The higher the Bitrate of the movie, the higher the image quality.

See also


VideoQuality

BB FlashBack SDK: FBExportToMP4Params

VideoQuality

Description

Sets the video quality of the exported movie. This parameter can take values from 0 to 10, where 10 is the highest quality. The higher the quality of the movie, the larger the file size.

Syntax

[C#/C++]
public long VideoQuality;

[VB.NET]
Public Property VideoQuality As Long

Remarks

This value is used only when VideoQualityMode is set to 0.

See also


VideoQualityMode

BB FlashBack SDK: FBExportToMP4Params

VideoQualityMode

Description

Sets whether the quality and filesize of the exported movie are set by the VideoBitrate parameter or the VideoQuality parameter.

Syntax

[C#/C++]
public long VideoQualityMode;

[VB.NET]
Public Property VideoQualityMode As Long

Remarks

When set to 0, the VideoQuality parameter is used. When set to 1, the VideoBitrate parameter is used.

See also


FromFrame

BB FlashBack SDK: FBExportToGIFParams

FromFrame

Description

Sets the frame in the movie at which the export will start. Set it to -1 to have the export start at the first frame of the movie.

Syntax

[C#/C++]
public long ExportFromFrame;

[VB.NET]
Public Property ExportFromFrame As Long

See also

FBExportToGIFParams::ToFrame


FrameRate

BB FlashBack SDK: FBExportToGIFParams

FrameRate

Description

Sets the frame rate, in frames per second, at which to export.

Syntax

[C#/C++]
public long FrameRate;

[VB.NET]
Public Property FrameRate As Long

See Also

FBExportToGIFParams::FrameRateMode


FrameRateMode

BB FlashBack SDK: FBExportToGIFParams

FrameRateMode

Description

Sets the frame rate at which to export.

Syntax

[C#/C++]
public long FrameRateMode;

[VB.NET]
Public Property FrameRateMode As Long

Remarks

Can be one of these values:

Value | Frame rate
0 | Same frame rate as the native FBR movie recording.
1 | 1/2 frame rate of movie.
2 | 1/4 frame rate of movie.
3 | Frame rate defined by the FrameRate property.

The default frame rate for movies recorded with the capture driver is 25fps.

See Also

FBExportToGIFParams::FrameRate


KeepAspectRatio

BB FlashBack SDK: FBExportToGIFParams

KeepAspectRatio

Description

Returns and sets the value that determines whether the aspect ratio of the movie is maintained when its width or height are altered via the OutputSizePercentX or OutputSizePercentY properties.

Syntax

[C#/C++]
public Bool KeepAspectRatio;

[VB.NET]
Public Property KeepAspectRatio As Boolean

Remarks

If this property is set to True, altering OutputSizePercentX or OutputSizePercentY automatically changes the other percentage to the same value, to maintain the aspect ratio of the movie.

See also


LoopPlayback

BB FlashBack SDK: FBExportToGIFParams

LoopPlayback

Description

Determines whether playback of the GIF 'loops' indefinitely returning to the start when the final frame is reached.

Syntax

[C#/C++]
public Bool LoopPlayback;

[VB.NET]
Public Property LoopPlayback As Boolean


OutputSizePercentX

BB FlashBack SDK: FBExportToGIFParams

OutputSizePercentX

Description

Returns and sets the percentage scaling applied to the width of the movie, when exported.

Syntax

[C#/C++]
public long OutputSizePercentX;

[VB.NET]
Public Property OutputSizePercentX As Long

Remarks

If KeepAspectRatio is set to True, changing the percent scaling for the width results in the percent scaling for the height (the OutputSizePercentY property) being set to the same value.

See also


OutputSizePercentY

BB FlashBack SDK: FBExportToGIFParams

OutputSizePercentY

Description

Returns and sets the percentage scaling applied to the height of the movie, when exported.

Syntax

[C#/C++]
public long OutputSizePercentY;

[VB.NET]
Public Property OutputSizePercentY As Long

Remarks

If KeepAspectRatio is set to True, changing the percent scaling for the height results in the percent scaling for the width (the OutputSizePercentX property) being set to the same value.

See also


ShowOptions

BB FlashBack SDK: FBExportToGIFParams

ShowOptions

Description

Determines the action taken on passing the FBExportToGIFParams object to FBMovie::ExportToGIF.

Syntax

[C#/C++]
public Bool ShowOptions;

[VB.NET]
Public Property ShowOptions As Boolean

Remarks

If ShowOptions is set to True, and the FBExportToGIFParams object is passed to the FBMovie::ExportToGIF method, a dialog is displayed that enables the user to set export options.

If ShowOptions is set to False, and the FBExportToGIFParams object is passed to the FBMovie::ExportToGIF method, the export uses the properties of the FBExportToGIFParams object and does not show the export options dialog.

See Also

FBMovie::ExportToGIF


ToFrame

BB FlashBack SDK: FBExportToGIFParams

ToFrame

Description

Sets the frame in the movie at which the export will finish. Set it to -1 to have the export finish at the final frame of the movie.

Syntax

[C#/C++]
public long ToFrame;

[VB.NET]
Public Property ToFrame As Long

See also

FBExportToGIFParams::FromFrame


UseSystemPalette

BB FlashBack SDK: FBExportToGIFParams

UseSystemPalette

Description

Set this property to true to use the system colour palette in the GIF. This option should reduce the file size, but also produce lower quality colour reproduction.

Syntax

[C#/C++]
public Bool UseSystemPalette;

[VB.NET]
Public Property UseSystemPalette As Boolean


The FBBitmaps Class

This is a collection class containing all the bitmap objects displayed within the particular frame or movie.

Returned from:

  • The GetBitmaps method of the FBEditor class. In this case it contains all bitmaps displayed in the movie.

  • The GetBitmaps method of the FBFrames class. In this case it contains all bitmaps displayed in a particular frame.

Methods

Delete
DeleteByID
EditProperties
EditPropertiesByID
GetID
GetProperties
GetPropertiesByID
IDExists
SetProperties
SetPropertiesByID

Properties


FBBitmaps::Delete

BB FlashBack SDK: FBBitmaps

Delete

Description

Deletes a bitmap from the collection.

Syntax

[C#/C++]
public Boolean Delete (long lBitmapIndex)

[VB.NET]
Public Function Delete (ByVal lBitmapIndex As Long) As Boolean

Parameters

lBitmapIndex : index of the bitmap object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

See Also

DeleteByID


FBBitmaps::DeleteByID

BB FlashBack SDK: FBBitmaps

DeleteByID

Description

Deletes a bitmap from the collection.

Syntax

[C#/C++]
public Boolean DeleteByID (long lBitmapID)

[VB.NET]
Public Function DeleteByID (ByVal lID As Long) As Boolean

Parameters

lBitmapID : ID of the bitmap object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

See Also

Delete


FBBitmaps::EditProperties

BB FlashBack SDK: FBBitmaps

EditProperties

Description

Displays a dialog that enables editing of the properties of the specified bitmap object.

Syntax

[C#/C++]
public Boolean EditProperties (long lBitmapIndex)

[VB.NET]
Public Function EditProperties (ByVal lIndex As Long) As Boolean

Parameters

lBitmapIndex : Index of the bitmap object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

See Also

EditPropertiesByID


FBBitmaps::EditPropertiesByID

BB FlashBack SDK: FBBitmaps

EditPropertiesByID

Description

Displays a dialog that enables editing of the properties of the specified bitmap object.

Syntax

[C#/C++]
public Boolean EditPropertiesByID (long lBitmapID)

[VB.NET]
Public Function EditPropertiesByID (ByVal lID As Long) As Boolean

Parameters

lBitmapID : ID of the bitmap object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

See Also

EditProperties


FBBitmaps::GetID

BB FlashBack SDK: FBBitmaps

GetID

Description

Returns the ID of a bitmap, given its index.

Syntax

[C#/C++]
public Long GetID (long lIndex);

[VB.NET]
Public Function GetID (ByVal lIndex As Long) As Long

Parameters

lIndex : Index of a bitmap.

Return Values

If the index given is out of range, the return value is -1.

If the function succeeds, the return value is the ID of the bitmap.

Remarks

See Also


FBBitmaps::GetProperties

BB FlashBack SDK: FBBitmaps

GetProperties

Description

Sets the properties of a FBBitmapProperties object to those of a specified bitmap within the movie, given its index.

Syntax

[C#/C++]
public Bool GetProperties (long lIndex, FBBitmapProperties* pBitmapProperties);

[VB.NET]
Public Function GetProperties (ByVal lIndex As Long, ByRef pBitmapProperties() As FBBitmapProperties) As Boolean

Parameters

lIndex : [In] Index of a bitmap.

pBitmapProperties : [In] Pointer to a FBBitmapProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

The caller should create the FBBitmapProperties object before passing its pointer in. After changing the properties of the object, the changes can be committed back to the in-movie bitmap movie by using the SetProperties or SetPropertiesByID methods.

See Also


FBBitmaps::GetPropertiesByID

BB FlashBack SDK: FBBitmaps

GetPropertiesByID

Description

Sets the properties of a FBBitmapProperties object to those of a specified bitmap within the movie, given its ID.

Syntax

[C#/C++]
public Bool GetPropertiesByID (long lID, FBBitmapProperties* pBitmapProperties);

[VB.NET]
Public Function GetPropertiesByID (ByVal lID As Long, ByRef pBitmapProperties() As FBBitmapProperties) As Boolean

Parameters

lID : [In] ID of a bitmap.

pBitmapProperties : [Out] Pointer to a FBBitmapProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

The caller should create the FBBitmapProperties object before passing its pointer in. After changing the properties of the object, the changes can be committed back to the in-movie bitmap movie by using the SetProperties or SetPropertiesByID methods.

See Also


FBBitmaps::IDExists

BB FlashBack SDK: FBBitmaps

IDExists

Description

Checks to see if the given ID corresponds to an existing bitmap object.

Syntax

[C#/C++]
public Bool IDExists (Long lBitmapID)

[VB.NET]
public Function IDExists (ByVal lBitmapID As Long) As Boolean

Parameters

lBitmapID : [In] ID of a bitmap.

Return Values

If the bitmap exists, the return value is zero.

If the bitmap does not exist, the return value is non-zero.


FBBitmaps::SetProperties

BB FlashBack SDK: FBBitmaps

SetProperties

Description

Sets the properties of the specified bitmap object to those in the supplied FBBitmapProperties object.

Syntax

[C#/C++]
public Bool SetProperties (long lBitmapIndex, FBBitmapProperties* pBitmapProperties)

[VB.NET]
Public Function SetProperties (ByVal lIndex As Long, ByRef pBitmapProperties () As FBBitmapProperties) As Boolean

Parameters

lBitmapIndex : [In] Index of a bitmap.

pBitmapProperties : [In] Pointer to an FBBitmapProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

See Also


FBBitmaps::SetPropertiesByID

BB FlashBack SDK: FBBitmaps

SetPropertiesByID

Description

Sets the properties of the specified bitmap object to those in the supplied FBBitmapProperties object.

Syntax

[C#/C++]
public Bool SetPropertiesByID (long lBitmapID, FBBitmapProperties* pBitmapProperties);

[VB.NET]
Public Function SetPropertiesByID (ByVal lID As Long, ByRef pBitmapProperties () As FBBitmapProperties) As Boolean

Parameters

lBitmapID : [In] ID of a bitmap.

pBitmapProperties : [In] Pointer to an FBBitmapProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

See Also


FBBitmaps::Count

BB FlashBack SDK: FBBitmaps

Count

Description

Returns the number of bitmaps in the collection.

Syntax

[C#/C++]
public Long Count

[VB.NET]
Public Property Count As Long


FBBitmaps::Frame

BB FlashBack SDK: FBBitmaps

Frame

Description

If the FBBitmaps collection was returned from a call to FBFrames::GetBitmaps, this property returns the number of the frame that the collection corresponds to.

Syntax

[C#/C++]
public Long Frame

[VB.NET]
Public Property Frame As Long

See Also

FBFrames::GetBitmaps


The FBBlurs Class

This is a collection class containing all the blur objects displayed within the particular frame or movie.

Returned from:

  • The GetBlurs method of the FBEditor class. In this case it contains all blurs displayed in the movie.

  • The GetBlurs method of the FBFrames class. In this case it contains all blurs displayed in a particular frame.

Methods

Delete
DeleteByID
EditProperties
EditPropertiesByID
GetID
GetProperties
GetPropertiesByID
IDExists
SetProperties
SetPropertiesByID

Properties


Delete

BB FlashBack SDK: FBBlurs

Delete

Description

Deletes a blur from the collection.

Syntax

[C#/C++]
public Boolean Delete (long lBlurIndex)

[VB.NET]
Public Function Delete (ByVal lBlurIndex As Long) As Boolean

Parameters

lBlurIndex : index of the blur object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

See Also

FBBlurs::DeleteByID


DeleteByID

BB FlashBack SDK: FBBlurs

DeleteByID

Description

Deletes a blur from the collection.

Syntax

[C#/C++]
public Boolean DeleteByID (long lID)

[VB.NET]
Public Function DeleteByID (ByVal lID As Long) As Boolean

Parameters

lID : ID of the blur object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also

FBBlurs::Delete


EditProperties

BB FlashBack SDK: FBBlurs

EditProperties

Description

Displays a dialog that enables editing of the properties of the specified blur object.

Syntax

[C#/C++]
public Boolean EditProperties (long lIndex)

[VB.NET]
Public Function EditProperties (ByVal lIndex As Long) As Boolean

Parameters

lIndex : Index of the blur object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also

FBBlurs::EditPropertiesByID


EditPropertiesByID

BB FlashBack SDK: FBBlurs

EditPropertiesByID

Description

Displays a dialog that enables editing of the properties of the specified blur object.

Syntax

[C#/C++]
public Boolean EditPropertiesByID (long lID)

[VB.NET]
Public Function EditPropertiesByID (ByVal lID As Long) As Boolean

Parameters

lID : ID of the blur object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also

FBBlurs::EditProperties


GetID

BB FlashBack SDK: FBBlurs

GetID

Description

Returns the ID of a blur, given its index.

Syntax

[C#/C++]
public Long GetID (long lIndex);

[VB.NET]
Public Function GetID (ByVal lIndex As Long) As Long

Parameters

lIndex : Index of a blur.

Return Values

If the index given is out of range, the return value is -1.

If the function succeeds, the return value is the ID of the blur object.


GetProperties

BB FlashBack SDK: FBBlurs

GetProperties

Description

Sets the properties of a FBBlurProperties object to those of a specified blur within the movie, given its index.

Syntax

[C#/C++]
public Bool GetProperties (long lIndex, FBBlurProperties* pBlurProperties);

[VB.NET]
Public Function GetProperties (ByVal lIndex As Long, ByRef pBlurProperties() As FBBlurProperties) As Boolean

Parameters

lIndex : [In] Index of a blur.

pBlurProperties : [In] Pointer to a FBBlurProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

The caller should create the FBBlurProperties object before passing its pointer in. After changing the properties of the object, the changes can be committed back to the in-movie blur movie by using the SetProperties or SetPropertiesByID methods.

See Also


GetPropertiesByID

BB FlashBack SDK: FBBlurs

GetPropertiesByID

Description

Sets the properties of a FBBlurProperties object to those of a specified blur within the movie, given its ID.

Syntax

[C#/C++]
public Bool GetPropertiesByID (long lID, FBBlurProperties* pBlurProperties);

[VB.NET]
Public Function GetPropertiesByID (ByVal lID As Long, ByRef pBlurProperties() As FBBlurProperties) As Boolean

Parameters

lID : [In] ID of a bitmap.

pBlurProperties : [Out] Pointer to a FBBlurProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

The caller should create the FBBlurProperties object before passing its pointer in. After changing the properties of the object, the changes can be committed back to the in-movie bitmap movie by using the SetProperties or SetPropertiesByID methods.

See Also


IDExists

BB FlashBack SDK: FBBlurs

IDExists

Description

Checks to see if the given ID corresponds to an existing blur object.

Syntax

[C#/C++]
public Bool IDExists (Long lID)

[VB.NET]
public Function IDExists (ByVal lID As Long) As Boolean

Parameters

lBlur : [In] ID of a blur.

Return Values

If the blur exists, the return value is zero.

If the blur does not exist, the return value is non-zero.


SetProperties

BB FlashBack SDK: FBBlurs

SetProperties

Description

Sets the properties of the specified blur object to those in the supplied FBBlurProperties object.

Syntax

[C#/C++]
public Bool SetProperties (long lIndex, FBBlurProperties* pBlurProperties)

[VB.NET]
Public Function SetProperties (ByVal lIndex As Long, ByRef pBlurProperties () As FBBlurProperties) As Boolean

Parameters

lIndex : [In] Index of a blur.

pBlurProperties : [In] Pointer to an FBBlurProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also


SetPropertiesByID

BB FlashBack SDK: FBBlurs

SetPropertiesByID

Description

Sets the properties of the specified blur object to those in the supplied FBBlurProperties object.

Syntax

[C#/C++]
public Bool SetPropertiesByID (long lID, FBBlurProperties* pBlurProperties);

[VB.NET]
Public Function SetPropertiesByID (ByVal lID As Long, ByRef pBlurProperties () As FBBlurProperties) As Boolean

Parameters

lID : [In] ID of a blur.

pBlurProperties : [In] Pointer to an FBBlurProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

See Also


Count

BB FlashBack SDK: FBBlurs

Count

Description

Returns the number of blurs in the collection.

Syntax

[C#/C++]
public Long Count

[VB.NET]
Public Property Count As Long


Frame

BB FlashBack SDK: FBBlurs

Frame

Description

If the FBBitmaps collection was returned from a call to FBFrames::GetBitmaps, this property returns the number of the frame that the collection corresponds to.

Syntax

[C#/C++]
public Long Frame

[VB.NET]
Public Property Frame As Long

See Also

FBFrames::GetBitmaps


The FBButtons Class

This is a collection class containing all the button objects displayed within the particular frame or movie.

Returned from:

  • The GetButtons method of the FBEditor class. In this case it contains all buttons displayed in the movie.

  • The GetButtons method of the FBFrames class. In this case it contains all buttons displayed in a particular frame.

Methods

Delete
DeleteByID
EditProperties
EditPropertiesByID
GetID
GetProperties
GetPropertiesByID
IDExists
SetProperties
SetPropertiesByID

Properties


Delete

BB FlashBack SDK: FBButtons

Delete

Description

Deletes a button from the collection.

Syntax

[C#/C++]
public Boolean Delete (long lIndex)

[VB.NET]
Public Function Delete (ByVal lIndex As Long) As Boolean

Parameters

lIndex : index of the button object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

See Also

FBButtons::DeleteByID


DeleteByID

BB FlashBack SDK: FBButtons

DeleteByID

Description

Deletes a button from the collection.

Syntax

[C#/C++]
public Boolean DeleteByID (long lID)

[VB.NET]
Public Function DeleteByID (ByVal lID As Long) As Boolean

Parameters

lID : ID of the button object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also

FBButtons::Delete


EditProperties

BB FlashBack SDK: FBButtons

EditProperties

Description

Displays a dialog that enables editing of the properties of the specified button object.

Syntax

[C#/C++]
public Boolean EditProperties (long lIndex)

[VB.NET]
Public Function EditProperties (ByVal lIndex As Long) As Boolean

Parameters

lIndex : Index of the button object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also

FBButtons::EditPropertiesByID


EditPropertiesByID

BB FlashBack SDK: FBButtons

EditPropertiesByID

Description

Displays a dialog that enables editing of the properties of the specified button object.

Syntax

[C#/C++]
public Boolean EditPropertiesByID (long lID)

[VB.NET]
Public Function EditPropertiesByID (ByVal lID As Long) As Boolean

Parameters

lID : ID of the button object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also

FBButtons::EditProperties


GetID

BB FlashBack SDK: FBButtons

GetID

Description

Returns the ID of a button, given its index.

Syntax

[C#/C++]
public Long GetID (long lIndex);

[VB.NET]
Public Function GetID (ByVal lIndex As Long) As Long

Parameters

lIndex : Index of a button.

Return Values

If the index given is out of range, the return value is -1.

If the function succeeds, the return value is the ID of the button object.


GetPropertiesByID

BB FlashBack SDK: FBButtons

GetPropertiesByID

Description

Sets the properties of a FBButtonProperties object to those of a specified button within the movie, given its ID.

Syntax

[C#/C++]
public Bool GetPropertiesByID (long lID, FBButtonProperties* pButtonProperties);

[VB.NET]
Public Function GetPropertiesByID (ByVal lID As Long, ByRef pButtonProperties() As FBButtonProperties) As Boolean

Parameters

lID : [In] ID of a button.

pButtonProperties : [Out] Pointer to a FBButtonProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

The caller should create the FBButtonProperties object before passing its pointer in. After changing the properties of the object, the changes can be committed back to the in-movie button object by using the SetProperties or SetPropertiesByID methods.

See Also


IDExists

BB FlashBack SDK: FBButtons

IDExists

Description

Checks to see if the given ID corresponds to an existing button object.

Syntax

[C#/C++]
public Bool IDExists (Long lID)

[VB.NET]
public Function IDExists (ByVal lID As Long) As Boolean

Parameters

lBlur : [In] ID of a button.

Return Values

If the button exists, the return value is zero.

If the button does not exist, the return value is non-zero.


SetProperties

BB FlashBack SDK: FBButtons

SetProperties

Description

Sets the properties of the specified button object to those in the supplied FBButtonProperties object.

Syntax

[C#/C++]
public Bool SetProperties (long lIndex, FBButtonProperties* pButtonProperties)

[VB.NET]
Public Function SetProperties (ByVal lIndex As Long, ByRef pButtonProperties () As FBButtonProperties) As Boolean

Parameters

lIndex : [In] Index of a button.

pButtonProperties : [In] Pointer to an FBButtonProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also


SetPropertiesByID

BB FlashBack SDK: FBButtons

SetPropertiesByID

Description

Sets the properties of the specified button object to those in the supplied FBButtonProperties object.

Syntax

[C#/C++]
public Bool SetPropertiesByID (long lID, FBButtonProperties* pButtonProperties);

[VB.NET]
Public Function SetPropertiesByID (ByVal lID As Long, ByRef pButtonProperties () As FBButtonProperties) As Boolean

Parameters

lID : [In] ID of a button.

pButtonProperties : [In] Pointer to an FBButtonProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

See Also


Count

BB FlashBack SDK: FBButtons

Count

Description

Returns the number of buttons in the collection.

Syntax

[C#/C++]
public Long Count

[VB.NET]
Public Property Count As Long


Frame

BB FlashBack SDK: FBButtons

Frame

Description

If the FBButtons collection was returned from a call to FBFrames::GetButtons, this property returns the number of the frame that the collection corresponds to.

Syntax

[C#/C++]
public Long Frame

[VB.NET]
Public Property Frame As Long

See Also

FBFrames::GetButtons


The FBInsertVideoFileParameters Class

BB FlashBack SDK: In-movie Presentation Classes

The FBInsertVideoFileParameters Class

This sets the options used when inserting a video file into a movie via the FBEditor::InsertVideoFile method.

Methods
GetObjectPointer

Properties
InsertAudioTrack
MirrorSourceFrame
PaddingColor
Position
ShowOptions
TransitionInDuration
TransitionInPauseInTheMiddle
TransitionInType
TransitionInZoomOutToShowEntireMovie
TransitionOutDuration
TransitionOutPauseInTheMiddle
TransitionOutType
TransitionOutZoomOutToShowEntireMovie
VideoFileName


InsertAudioTrack

BB FlashBack SDK: FBInsertVideoFileParameters

InsertAudioTrack

Description

Determines whether the audio in the video (if any) is also inserted into the movie to create a new audio track.

Syntax

[C#/C++]
public Bool InsertAudioTrack;

[VB.NET]
Public Property InsertAudioTrack As Boolean


MirrorSourceFrame

BB FlashBack SDK: FBInsertVideoFileParameters

MirrorSourceFrame

Description

Some codecs produce mirrored frame. Set this property to true to correctly import files produced by such codecs.

Syntax

[C#/C++]
public Bool MirrorSourceFrame;

[VB.NET]
Public Property MirrorSourceFrame As Boolean


PaddingColor

BB FlashBack SDK: FBInsertVideoFileParameters

PaddingColor

Description

Returns and sets the color used to pad the inserted video to the dimensions of the movie.

Syntax

[C#/C++]
public ulong PaddingColor

[VB.NET]
Public Property PaddingColor As Long

Remarks

The padding used depends on the Position property.

Colors are specified in a long as a Win32 COLORREF value, which can be created by an RGB macro - see Win32 Platform SDK documentation.

See Also

FBInsertVideoFileProperties::Position


Position

BB FlashBack SDK: FBInsertVideoFileParameters

Position

Description

Returns and sets how the inserted video file will be positioned and scaled within the movie. Inserting a videoi file does not change the dimensions of the movie.

Syntax

[C#/C++]
public long Position

[VB.NET]
Public Property Position As Integer

Remarks

Possible values for the property:

0 = Fill. The video is scaled to fill the entire movie but maintain its aspect ratio. e.g

1 = Fit. The video is scaled to fit into the movie. e.g.

2 = Stretch. The video is scaled to fill the movie, changing its aspect ratio if necessary. e.g.

3 = Center. The video is not scaled, and centered within the movie. e.g.

See Also

FBInsertVideoFileProperties::PaddingColor


ShowOptions

BB FlashBack SDK: FBInsertVideoFileParameters

ShowOptions

Description

Determines the action taken on passing the FBInsertVideoFileParameters object to FBEditor::InsertVideoFile.

Syntax

[C#/C++]
public Bool ShowOptions;

[VB.NET]
Public Property ShowOptions As Boolean

Remarks

If ShowOptions is set to True, a standard dialog for setting textbox properties is displayed.

If ShowOptions is set to False, the insert operation uses the properties defined in the FBInsertVideoFileParameters object.

See Also

FBEditor::InsertVideoFile


TransitionInDuration

BB FlashBack SDK: FBInsertVideoFileParameters

TransitionInDuration

Description

Determines the duration in milliseconds of the 'In' transition used to fade the video into the movie.

Syntax

[C#/C++]
public long TransitionInDuration;

[VB.NET]
Public Property TransitionInDuration As Integer

See Also

FBInsertVideoFileParameters::TransitionInType FBInsertVideoFileParameters::TransitionInPauseInTheMiddle FBInsertVideoFileParameters::TransitionInZoomOutToShowEntireMovie


TransitionInPauseInTheMiddle

BB FlashBack SDK: FBInsertVideoFileParameters

TransitionInPauseInTheMiddle

Description

Determines the duration in milliseconds of any pause in the middle of the 'In' transition. E.g if the transition type was a fade through white, setting this property to 1000 would pause, displaying a white frame in the movie, for 1 second.

Syntax

[C#/C++]
public long TransitionInPauseInTheMiddle;

[VB.NET]
Public Property TransitionInPauseInTheMiddle As Integer

See Also

FBInsertVideoFileParameters::TransitionInType FBInsertVideoFileParameters::TransitionInDuration FBInsertVideoFileParameters::TransitionInZoomOutToShowEntireMovie


TransitionInType

BB FlashBack SDK: FBInsertVideoFileParameters

TransitionInType

Description

Determines the type of the 'In' transition used to fade the video into the movie

Syntax

[C#/C++]
public long TransitionInType;

[VB.NET]
Public Property TransitionInType As Integer

Remarks

Values for the property:

0 = fade through white. The movie will fade to white, then fade from white to the inserted video.

1 = fade through black

2 = no fade

See Also

FBInsertVideoFileParameters::TransitionInDuration FBInsertVideoFileParameters::TransitionInPauseInTheMiddle FBInsertVideoFileParameters::TransitionInZoomOutToShowEntireMovie


TransitionInZoomOutToShowEntireMovie

BB FlashBack SDK: FBInsertVideoFileParameters

TransitionInZoomOutToShowEntireMovie

Description

Determines whether at the end of the 'In' transition, the entire movie is shown. The setting is included because if the movie is zoomed into an area, at the point the video is inserted, the zoom is probably not required for the inserted video. Setting this property to true, removes the zoompan.

Syntax

[C#/C++]
public bool TransitionInZoomOutToShowEntireMovie;

[VB.NET]
Public Property TransitionInZoomOutToShowEntireMovie Type as Boolean

See Also

FBInsertVideoFileParameters::TransitionInDuration FBInsertVideoFileParameters::TransitionInPauseInTheMiddle FBInsertVideoFileParameters::TransitionInType


TransitionOutDuration

BB FlashBack SDK: FBInsertVideoFileParameters

TransitionOutDuration

Description

Determines the duration in milliseconds of the 'Out' transition used to fade back to the movie from the video.

Syntax

[C#/C++]
public long TransitionOutDuration;

[VB.NET]
Public Property TransitionOutDuration As Integer

See Also

FBInsertVideoFileParameters::TransitionOutType FBInsertVideoFileParameters::TransitionOutPauseInTheMiddle FBInsertVideoFileParameters::TransitionOutZoomOutToShowEntireMovie


TransitionOutPauseInTheMiddle

BB FlashBack SDK: FBInsertVideoFileParameters

TransitionOutPauseInTheMiddle

Description

Determines the duration in milliseconds of any pause in the middle of the 'Out' transition. E.g if the transition type was a fade through white, setting this property to 1000 would pause, displaying a white frame in the movie, for 1 second.

Syntax

[C#/C++]
public long TransitionOutPauseInTheMiddle;

[VB.NET]
Public Property TransitionOutPauseInTheMiddle As Integer

See Also

FBInsertVideoFileParameters::TransitionOutType FBInsertVideoFileParameters::TransitionOutDuration FBInsertVideoFileParameters::TransitionOutZoomOutToShowEntireMovie


TransitionOutType

BB FlashBack SDK: FBInsertVideoFileParameters

TransitionOutType

Description

Determines the type of the 'Out' transition used to fade from the video back to the movie.

Syntax

[C#/C++]
public long TransitionOutType;

[VB.NET]
Public Property TransitionOutType As Integer

Remarks

Values for the property:

0 = fade through white. When the inserted video finishes it will fade to white, then fade from white back to the movie.

1 = fade through black

2 = no fade

See Also

FBInsertVideoFileParameters::TransitionOutDuration FBInsertVideoFileParameters::TransitionOutPauseInTheMiddle FBInsertVideoFileParameters::TransitionOutZoomOutToShowEntireMovie


TransitionOutZoomOutToShowEntireMovie

BB FlashBack SDK: FBInsertVideoFileParameters

TransitionOutZoomOutToShowEntireMovie

Description

Determines whether at the end of the 'Out' transition when teh inserted video completes, the entire movie is shown. The setting is included because if a zoompan is added in the video, its probably not needed when switching back to the movie. Setting this property to true, removes the zoompan to display the entire movie.

Syntax

[C#/C++]
public bool TransitionOutZoomOutToShowEntireMovie;

[VB.NET]
Public Property TransitionOutZoomOutToShowEntireMovie Type as Boolean

See Also

FBInsertVideoFileParameters::TransitionOutDuration FBInsertVideoFileParameters::TransitionOutPauseInTheMiddle FBInsertVideoFileParameters::TransitionOutType


VideoFileName

BB FlashBack SDK: FBInsertVideoFileParameters

VideoFileName

Description

Optionally sets the name of the video file to be inserted.

Syntax

[C#/C++]
public String VideoFileName;

[VB.NET]
Public Property VideoFileName As String

Remarks

When inserting a video file into a movie by use of the FBEditor::InsertVideoFile method, the caller passes in an FBInsertVideoFileParameters object. If the ShowOptions property of this object is set to True, a standard video file selection dialog will be displayed, enabling a user to select the video file to be inserted. If the ShowOptions property of the object is set to False, the video file specified by the VideoFileName property will be inserted.

See Also


The FBMarkers Class

BB FlashBack SDK: In-movie Presentation Classes

The FBMarkers Class

This is a collection class containing all the marker objects within the particular frame or movie.

Returned from:

  • The GetMarkers method of the FBEditor class. In this case it contains all markers displayed in the movie.

  • The GetMarkers method of the FBFrames class. In this case it contains all markers displayed in a particular frame.

Methods

Delete
DeleteByID
EditProperties
EditPropertiesByID
GetID
GetProperties
GetPropertiesByID
IDExists
SetProperties
SetPropertiesByID

Properties


FBMarkers::Delete

BB FlashBack SDK: FBMarkers

Delete

Description

Deletes a marker from the collection.

Syntax

[C#/C++]
public Bool Delete (long lIndex)

[VB.NET]
Public Function Delete (ByVal lIndex As Long) As Boolean

Parameters

lIndex : index of the marker object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also

FBMarkers::DeleteByID


FBMarkers::DeleteByID

BB FlashBack SDK: FBMarkers

DeleteByID

Description

Deletes a marker from the collection.

Syntax

[C#/C++]
public Bool DeleteByID (long lID)

[VB.NET]
Public Function DeleteByID (ByVal lID As Long) As Boolean

Parameters

lID : ID of the marker object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also

FBMarkers::Delete


FBMarkers::EditProperties

BB FlashBack SDK: FBMarkers

EditProperties

Description

Displays a dialog that enables editing of the properties of the specified marker object.

Syntax

[C#/C++]
public Bool EditProperties (long lIndex)

[VB.NET]
Public Function EditProperties (ByVal lIndex As Long) As Boolean

Parameters

lIndex : Index of the marker object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also

FBMarkers::EditPropertiesByID


FBMarkers::EditPropertiesByID

BB FlashBack SDK: FBMarkers

EditPropertiesByID

Description

Displays a dialog that enables editing of the properties of the specified marker object.

Syntax

[C#/C++]
public Bool EditPropertiesByID (long lID)

[VB.NET]
Public Function EditPropertiesByID (ByVal lID As Long) As Boolean

Parameters

lID : ID of the marker object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also

FBMarkers::EditProperties


FBMarkers::GetID

BB FlashBack SDK: FBMarkers

GetID

Description

Returns the ID of a marker, given its index.

Syntax

[C#/C++]
public Long GetID (long lIndex);

[VB.NET]
Public Function GetID (ByVal lIndex As Long) As Long

Parameters

lIndex : Index of a marker.

Return Values

If the index given is out of range, the return value is -1.

If the function succeeds, the return value is the ID of the marker.


FBMarkers::GetProperties

BB FlashBack SDK: FBMarkers

GetProperties

Description

Sets the properties of a FBMarkerProperties object to those of a specified marker within the movie, given its index.

Syntax

[C#/C++]
public Bool GetProperties (long lIndex, FBMarkerProperties* pProperties);

[VB.NET]
Public Function GetProperties (ByVal lIndex As Long, ByRef pMarkerProperties() As FBMarkerProperties) As Boolean

Parameters

lIndex : [In] Index of a marker.

pProperties : [In] Pointer to a FBMarkerProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

The caller should create the FBMarkerProperties object before passing its pointer in. After changing the properties of the object, the changes can be committed back to the in-movie marker object by using the SetProperties or SetPropertiesByID methods.

See Also


FBMarkers::GetPropertiesByID

BB FlashBack SDK: FBMarkers

GetPropertiesByID

Description

Sets the properties of a FBMarkerProperties object to those of a specified marker within the movie, given its ID.

Syntax

[C#/C++]
public Bool GetPropertiesByID (long lID, FBMarkerProperties* pProperties)

[VB.NET]
Public Function GetPropertiesByID (ByVal lID As Long, ByRef pMarkerProperties() As FBMarkerProperties) As Boolean

Parameters

lID : [In] ID of a marker.

pProperties : [In] Pointer to a FBMarkerProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

The caller should create the FBMarkerProperties object before passing its pointer in. After changing the properties of the object, the changes can be committed back to the in-movie marker object by using the SetProperties or SetPropertiesByID methods.

See Also


FBMarkers::IDExists

BB FlashBack SDK: FBMarkers

IDExists

Description

Checks to see if the given ID corresponds to an existing marker object.

Syntax

[C#/C++]
public Bool IDExists (Long lID)

[VB.NET]
public Function IDExists (ByVal lID As Long) As Boolean

Parameters

lID : [In] ID of a marker.

Return Values

If the marker exists, the return value is zero.

If the marker does not exist, the return value is non-zero.


FBMarkers::SetProperties

BB FlashBack SDK: FBMarkers

SetProperties

Description

Sets the properties of the specified marker object to those in the supplied FBMarkerProperties object.

Syntax

[C#/C++]
public Bool SetProperties (long lIndex, FBMarkerProperties* pProperties);

[VB.NET]
Public Function SetProperties (ByVal lIndex As Long, ByRef pMarkerProperties() As FBMarkerProperties) As Boolean

Parameters

lIndex : [In] Index of a marker.

pProperties : [In] Pointer to an FBMarkerProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also


FBMarkers::SetPropertiesByID

BB FlashBack SDK: FBMarkers

SetPropertiesByID

Description

Sets the properties of the specified marker object to those in the supplied FBMarkerProperties object.

Syntax

[C#/C++]
public Bool SetPropertiesByID (long lID, FBMarkerProperties* pProperties);

[VB.NET]
Public Function SetPropertiesByID (ByVal lID As Long, ByRef pMarkerProperties() As FBMarkerProperties) As Boolean

Parameters

lID : [In] ID of a marker.

pProperties : [In] Pointer to an FBMarkerProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also


FBMarkers::Count

BB FlashBack SDK: FBMarkers

Count

Description

Returns the number of markers in the collection.

Syntax

[C#/C++]
public Long Count

[VB.NET]
Public Property Count As Long


FBMarkers::Frame

BB FlashBack SDK: FBMarkers

Frame

Description

If the FBMarkers collection was returned from a call to FBFrames::GetMarkers, this property returns the number of the frame that contains the markers of this collection.

Syntax

[C#/C++]
public Long Frame

[VB.NET]
Public Property Frame As Long

Remarks

See Also

FBFrames::GetMarkers


The FBSounds Class

This is a collection class containing all the sound objects displayed within the a particular frame or movie.

Returned from:

  • The GetSounds method of the FBEditor class. The returned collection contains all sounds played in the movie.

  • The GetSounds method of the FBFrames class. The returned collection contains all sounds played in a particular frame.

Methods

Delete
DeleteByID
GetID
GetProperties
GetPropertiesByID
IDExists
MixAndExtractSounds
MixAndExtractSoundsFrames
Resynchronise
ResynchroniseByID
ExtractSound

Properties

Count


How the sound classes work

BB FlashBack SDK: In-movie Presentation Classes

How The Sound Classes Work

The FlashBack SDK can record a number of tracks of sound in a movie. Each track contains a number of non-overlapping sound 'clips'. Each clip can be a sound file or recording.

  • FBSounds class is the container for all sound tracks.

  • FBSoundProperties class corresponds to a sound track. There can be a number of them playing simultaneously in a movie. Each track can contain a number of sound clips.

  • FBSoundClip class corresponds to a single sound - a file or a recording.

Adding a sound file to a movie

  1. Create a new FBSoundProperties object, setting its volume, start frame, and the name of the sound file it is derived from.
    This will create an FBSoundProperties object containing one FBSoundClip - the sound file.

  2. Use FBEditor::InsertSound to add the FBSoundProperties object to the movie.

How to get access to the tracks and sound clips in a movie:

  1. Use FBEditor::GetSounds to get an FBSounds object that contains all the sound tracks in a movie.

  2. Use FBSounds::GetProperties and FBSounds::GetPropertiesByID to get the FBSoundProperties objects.
    Note    : the FBSoundProperties object should be created by your code and the pointer passed into GetProperties.

  3. Use FBSoundProperties::GetSoundClipProperties to get access to the FBSoundClip objects contained within the FBSoundProperties object.
    Note    : the FBSoundClip object should be created by your code and the pointer passed into GetSoundClipProperties.

  4. Properties of the sound clip can be changed and written back to the movie with FBSoundProperties::SetSoundClipProperties.

How edit operations affect sounds

When your code adds a sound to a movie, via FBEditor::InsertSound, this creates a single 'track' - an FBSoundProperties object - containing one FBSoundClip object.

This single clip can be split into multiple clips by calls to FBMovie::InsertFrames, with the UpdateSounds parameter set to true. If you insert frames into a frame where the clip is playing, and set UpdateSounds to true, silence will be inserted into the clip, effectively breaking it into two clips at the insertion point, separated by silence.


CompressVolume

BB FlashBack SDK: FBSounds

CompressVolume

Description

Compression reduces the variation in volume in sound. You can use it to make loud sounds quieter relative to the rest of the selected sound.

Syntax

[C#/C++]
public void CompressVolume (Long lIndex, long Start, long End, float EqBoost, float Threshold, float Ratio);

[VB.NET]
Public Sub CompressVolume (ByVal lIndex As Integer, ByVal Start As Integer, ByVal End As Integer, ByVal EqBoost As Single, ByVal Threshold As Single, ByVal Ratio As Single)

Parameters

lIndex : [In] Index of the track in the collection

Start : [In] frame at which to start the operation

End : [In] frame at which to end the operation

EqBoost : [In] range of values 0 to 60. This is a dB adjustment applied to the sound to compensate for the reduction in volume due to compression.

Threshold : [In] range of values -60 to 0. This indicates the volume above which compression will be applied.

Ratio : [In] range of values from 1 to 7. The strength of the compression applied to loud sounds.


FBSounds::Delete

BB FlashBack SDK: FBSounds

Delete

Description

Deletes a sound from the collection.

Syntax

[C#/C++]
public Bool Delete (long lIndex)

[VB.NET]
Public Function Delete (ByVal lIndex As Long) As Boolean

Parameters

lIndex : index of the sound object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also

FBSounds::DeleteByID


FBSounds::DeleteByID

BB FlashBack SDK: FBSounds

DeleteByID

Description

Deletes a sound from the collection.

Syntax

[C#/C++]
public Bool DeleteByID (long lID)

[VB.NET]
Public Function DeleteByID (ByVal lID As Long) As Boolean

Parameters

lID : ID of the sound object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also

FBSounds::Delete


ExtractSound

BB FlashBack SDK: FBSounds

ExtractSound

Description

Saves a sound track to a file new length. See How The Sound Classes Work for more information on sound tracks.

Syntax

[C#/C++]
public long ExtractSound (long index, BSTR filename, long format);

[VB.NET]
Public Function ExtractSound (ByVal index As Integer, ByVal filename As String, ByVal format As Integer) As Integer

Parameters

index (in) - index of the sound to save.

filename (in) - name of the file to save the sound to.

format (in) - determines the format of the sound file saved. Can take one of three values :

0 | Unchanged - keeps the current format of the sound.
1 | WAV (uncompressed)
2 | MP3

Return Values

Returns zero if unsuccessful, non-zero if successful.

See Also

How the sound classes work


FBSounds::GetID

BB FlashBack SDK: FBSounds

GetID

Description

Returns the ID of a sound, given its index.

Syntax

[C#/C++]
public Long GetID (Long lIndex);

[VB.NET]
Public Function GetID (ByVal lIndex As Long) As Long

Parameters

lIndex : Index of a sound.

Return Values

If the index given is out of range, the return value is -1.

If the function succeeds, the return value is the ID of the sound.


FBSounds::GetProperties

BB FlashBack SDK: FBSounds

GetProperties

Description

Sets the properties of a FBSoundProperties object to those of a specified sound within the movie, given its index.

Syntax

[C#/C++]
public Bool GetProperties (Long lIndex, FBSoundProperties* pProperties);

[VB.NET]
Public Function GetProperties (ByVal lIndex As Integer, ByRef pSoundProperties As FBSoundProperties) As Boolean

Parameters

lIndex : [In] Index of a sound.

pProperties : [In] Pointer to a FBSoundProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

The caller should create the FBSoundProperties object before passing its pointer in. After changing the properties of the object, the changes can be committed back to the in-movie sound object by using the SetProperties or SetPropertiesByID methods.

See Also


FBSounds::GetPropertiesByID

BB FlashBack SDK: FBSounds

GetPropertiesByID

Description

Sets the properties of a FBSoundProperties object to those of a specified sound within the movie, given its ID.

Syntax

[C#/C++]
public Bool GetPropertiesByID (long lID, FBSoundProperties* pProperties)

[VB.NET]
Public Function GetPropertiesByID (ByVal lID As Long, ByRef pSoundProperties() As FBSoundProperties) As Boolean

Parameters

lID : [In] ID of a sound.

pProperties : [In] Pointer to a FBSoundProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

The caller should create the FBSoundProperties object before passing its pointer in. After changing the properties of the object, the changes can be committed back to the in-movie sound object by using the SetProperties or SetPropertiesByID methods.

See Also


FBSounds::IDExists

BB FlashBack SDK: FBSounds

IDExists

Description

Checks to see if the given ID corresponds to an existing sound object.

Syntax

[C#/C++]
public Bool IDExists (Long lID)

[VB.NET]
public Function IDExists (ByVal lID As Long) As Boolean

Parameters

lID : [In] ID of a sound.

Return Values

If the sound exists, the return value is zero.

If the sound does not exist, the return value is non-zero.


MixAndExtractSounds

BB FlashBack SDK: FBSounds

MixAndExtractSounds

Description

Saves all sound tracks in the movie to a single sound file. See How The Sound Classes Work for more information on sound tracks.

Syntax

[C#/C++]
public long MixAndExtractSounds (BSTR Filename, SoundFormat CompressFormat, long Format, long mp3profile, bool UseBestFormat);

[VB.NET]
Public Function MixAndExtractSounds (ByVal Filename As String, ByVal compressformat As SoundFormat, ByVal Format As Integer, ByVal mp3profile As Integer, ByVal UseBestFormat As Boolean) As Integer

Parameters

Filename (in) - name of the file to save the tracks to.

CompressFormat (in) - determines the format of the saved sound file.

0 | Unchanged - keeps the current format of the sound.
1 | WAV (uncompressed)
2 | MP3

Format (in) - this can be one of the following standard Win32 SDK constants, describing the number of channels, sample rate and bits per sample:

Value | Format
WAVE_FORMAT_1M08 | 11.025 kHz, mono, 8-bit.
WAVE_FORMAT_1M16 | 11.025 kHz, mono, 16-bit.
WAVE_FORMAT_1S08 | 11.025 kHz, stereo, 8-bit.
WAVE_FORMAT_1S16 | 11.025 kHz, stereo, 16-bit.
WAVE_FORMAT_2M08 | 22.05 kHz, mono, 8-bit.
WAVE_FORMAT_2M16 | 22.05 kHz, mono, 16-bit.
WAVE_FORMAT_2S08 | 22.05 kHz, stereo, 8-bit.
WAVE_FORMAT_2S16 | 22.05 kHz, stereo, 16-bit.
WAVE_FORMAT_4M08 | 44.1 kHz, mono, 8-bit.
WAVE_FORMAT_4M16 | 44.1 kHz, mono, 16-bit.
WAVE_FORMAT_4S08 | 44.1 kHz, stereo, 8-bit.
WAVE_FORMAT_4S16 | 44.1 kHz, stereo, 16-bit.

mp3profile (in) - This property is ignored if the CompressFormat parameter is not set to MP3.

It can be one of the following constants:

Value | Audio Quality
0 | Normal
1 | Low
2 | High
5 | Very high

Higher audio quality means less compression and larger file sizes.

UseBestFormat (in) - If the Format parameter is set to zero, the value of UseBestFormat determines the sound format to be used on export.

Set UseBestFormat to True to mix all sounds to the highest quality format used by any sound in the movie.

Set UseBestFormat to False to mix all sounds to the lowest quality format used by any sound in the movie.

Return Values

Returns zero if unsuccessful, non-zero if successful.

See Also

How the sound classes work


MixAndExtractSoundsFrames

BB FlashBack SDK: FBSounds

MixAndExtractSoundsFrames

Description

For the selected frames, this method saves all sound tracks to a single sound file.

See How The Sound Classes Work for more information on sound tracks.

Syntax

[C#/C++]
public long MixAndExtractSoundsFrames (BSTR Filename, SoundFormat CompressFormat, long Format, long mp3profile, bool UseBestFormat, long StartFrame, long EndFrame);

[VB.NET]
Public Function MixAndExtractSoundsFrames (ByVal Filename As String, ByVal compressformat As SoundFormat, ByVal Format As Integer, ByVal mp3profile As Integer, ByVal UseBestFormat As Boolean, ByVal StartFrame As Integer, ByVal EndFrame As Integer) As Integer

Parameters

Filename (in) - name of the file to save the tracks to.

CompressFormat (in) - determines the format of the saved sound file.

0 | Unchanged - keeps the current format of the sound.
1 | WAV (uncompressed)
2 | MP3

Format (in) - this can be one of the following standard Win32 SDK constants, describing the number of channels, sample rate and bits per sample:

Value | Format
WAVE_FORMAT_1M08 | 11.025 kHz, mono, 8-bit.
WAVE_FORMAT_1M16 | 11.025 kHz, mono, 16-bit.
WAVE_FORMAT_1S08 | 11.025 kHz, stereo, 8-bit.
WAVE_FORMAT_1S16 | 11.025 kHz, stereo, 16-bit.
WAVE_FORMAT_2M08 | 22.05 kHz, mono, 8-bit.
WAVE_FORMAT_2M16 | 22.05 kHz, mono, 16-bit.
WAVE_FORMAT_2S08 | 22.05 kHz, stereo, 8-bit.
WAVE_FORMAT_2S16 | 22.05 kHz, stereo, 16-bit.
WAVE_FORMAT_4M08 | 44.1 kHz, mono, 8-bit.
WAVE_FORMAT_4M16 | 44.1 kHz, mono, 16-bit.
WAVE_FORMAT_4S08 | 44.1 kHz, stereo, 8-bit.
WAVE_FORMAT_4S16 | 44.1 kHz, stereo, 16-bit.

mp3profile (in) - This property is ignored if the CompressFormat parameter is not set to MP3.

It can be one of the following constants:

Value | Audio Quality
0 | Normal
1 | Low
2 | High
5 | Very high

Higher audio quality means less compression and larger file sizes.

UseBestFormat (in) - If the Format parameter is set to zero, the value of UseBestFormat determines the sound format to be used on export.

Set UseBestFormat to True to mix all sounds to the highest quality format used by any sound in the movie.

Set UseBestFormat to False to mix all sounds to the lowest quality format used by any sound in the movie.

StartFrame (in) - the first frame of the sequence for which sound is to be extracted.

EndFrame (in) - the last frame of the sequence for which sound is to be extracted.

Return Values

Returns zero if unsuccessful, non-zero if successful.

See Also

How the sound classes work


Mute

BB FlashBack SDK: FBSounds

Mute

Description

Mutes or unmutes sounds in specified frames.

Syntax

[C#/C++]
public void Mute (long lIndex, long start, long end, bool mute);

[VB.NET]
Public Sub Mute (ByVal lIndex As Integer, ByVal start As Integer, ByVal end As Integer, ByVal mute As Boolean)

Parameters

lIndex : [In] Index of the track to mute in the FBSounds collection

start : [In] the frame at which to start the mute

end : [In] the frame at which to end the mute

mute : [In] set to true to mute sounds in the selected frames, set to false to unmute them


NormalizeVolume

BB FlashBack SDK: FBSounds

NormalizeVolume

Description

Normalization adjusts the volume of clips to give them the same "loudness" (the volume of the loudest sound in the clip). Normalization is particularly useful when a sound track is composed of a number of clips from different sources with varying volumes, to make the volume in the track more uniform.

Syntax

[C#/C++]
public void NormalizeVolume (Long lIndex, long Start, long End, float volumeLevel);

[VB.NET]
Public Sub CompressVolume (ByVal lIndex As Integer, ByVal Start As Integer, ByVal End As Integer, ByVal volumeLevel As Single)

Parameters

lIndex : [In] Index of the track in the collection

Start : [In] frame at which to start the operation

End : [In] frame at which to end the operation

volumeLevel : [In] range of values -60 to 0. This is a dB adjustment applied to the loudness.


RemoveNoise

BB FlashBack SDK: FBSounds

RemoveNoise

Description

Removes noise from sound in the specified frames.

Syntax

[C#/C++]
public void RemoveNoise (Long lIndex, long start, long end, float Strength, bool removeArtifacts);

[VB.NET]
Public Sub RemoveNoise (ByVal lIndex As Integer, ByVal start As Integer, ByVal end As Integer, ByVal Strength As Single, ByVal removeArtifacts As Boolean)

Parameters

lIndex : [In] Index of the track in the collection

Start : [In] frame at which to start the operation

End : [In] frame at which to end the operation

Strength : [In] value indicating the strength of the noise removal. It can take a range of values from 0.01 to 0.7

removeArtifacts : [In] set to true to remove audio artifacts that can be introduced by noise removal processing


Resynchronise

BB FlashBack SDK: FBSounds

Resynchronise

Description

Adjusts the duration of a sound. The sound is not clipped, but resampled to the new length.

Syntax

[C#/C++]
public Bool Resynchronise (long index, long newlength);

[VB.NET]
Public Function Resynchronise (ByVal index As Integer, ByVal newlength As Integer) As Boolean

Parameters

index (in) - index of the sound to resample.

newlength (in) - new duration of the sound.

Return Values

Returns zero if unsuccessful, non-zero if successful.

See Also

FBSounds::ResynchroniseByID


ResynchroniseByID

BB FlashBack SDK: FBSounds

ResynchroniseByID

Description

Adjusts the duration of a sound. The sound is not clipped, but resampled to the new length.

Syntax

[C#/C++]
public Bool Resynchronise (long id, long newlength);

[VB.NET]
Public Function Resynchronise (ByVal id As Integer, ByVal newlength As Integer) As Boolean

Parameters

id (in) - ID of the sound to resample.

newlength (in) - new duration of the sound.

Return Values

Returns zero if unsuccessful, non-zero if successful.

See Also


FBSounds::Count

BB FlashBack SDK: FBSounds

Count

Description

Returns the number of sounds in the collection.

Syntax

[C#/C++]
public Long Count

[VB.NET]
Public Property Count As Long


The FBTextBoxes Class

This is a collection class containing all the text box objects displayed within the a particular frame or movie.

Returned from:

  • The GetTextBoxes method of the FBEditor class. The returned collection contains all text boxes displayed in the movie.

  • The GetTextBoxes method of the FBFrames class. The returned collection contains all text boxes displayed in a particular frame.

Methods

Delete
DeleteByID
DistributeTextBoxes
EditProperties
EditPropertiesByID
GetID
GetProperties
GetPropertiesByID
IDExists
SetProperties
SetPropertiesByID

Properties


FBTextBoxes::Delete

BB FlashBack SDK: FBTextBoxes

Delete

Description

Deletes a text box from the collection.

Syntax

[C#/C++]
public Bool Delete (long lIndex)

[VB.NET]
Public Function Delete (ByVal lIndex As Long) As Boolean

Parameters

lIndex : index of the text box to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also

FBTextBoxes::DeleteByID


FBTextBoxes::DeleteByID

BB FlashBack SDK: FBTextBoxes

DeleteByID

Description

Deletes a text box from the collection.

Syntax

[C#/C++]
public Bool DeleteByID (long lID)

[VB.NET]
Public Function DeleteByID (ByVal lID As Long) As Boolean

Parameters

lID : ID of the text box to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also

FBTextBoxes::Delete


DistributeTextBoxes

BB FlashBack SDK: FBTextBoxes

DistributeTextBoxes

Description

Sets the duration of textboxes that have property TextTime set to -1, so they are displayed until the appearance of the next textbox.

This changes the TextTime property from -1 to a value that keeps them displayed for the appropriate duration.

If no textbox follows one that has TextTime set to -1, it is displayed until the end of the movie.

Syntax

[C#/C++]
public void DistributeTextBoxes ();

[VB.NET]
Public Sub DistributeTextBoxes ()

See Also

FBTextBoxProperties::TextTime


FBTextBoxes::EditProperties

BB FlashBack SDK: FBTextBoxes

EditProperties

Description

Displays a dialog that enables editing of the properties of the specified text box.

Syntax

[C#/C++]
public Bool EditProperties (long lIndex)

[VB.NET]
Public Function EditProperties (ByVal lIndex As Long) As Boolean

Parameters

lIndex : Index of the text box to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also

FBTextBoxes::EditPropertiesByID


FBTextBoxes::EditPropertiesByID

BB FlashBack SDK: FBTextBoxes

EditPropertiesByID

Description

Displays a dialog that enables editing of the properties of the specified text box.

Syntax

[C#/C++]
public Bool EditPropertiesByID (long lID)

[VB.NET]
Public Function EditPropertiesByID (ByVal lID As Long) As Boolean

Parameters

lID : ID of the text box to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also

FBTextBoxes::EditProperties


FBTextBoxes::GetID

BB FlashBack SDK: FBTextBoxes

GetID

Description

Returns the ID of a text box, given its index.

Syntax

[C#/C++]
public Long GetID (long lIndex);

[VB.NET]
Public Function GetID (ByVal lIndex As Long) As Long

Parameters

lIndex : Index of a text box.

Return Values

If the index given is out of range, the return value is -1.

If the function succeeds, the return value is the ID of the text box.


FBTextBoxes::GetProperties

BB FlashBack SDK: FBTextBoxes

GetProperties

Description

Sets the properties of a FBTextBoxProperties object to those of a specified text box within the movie, given its index.

Syntax

[C#/C++]
public Bool GetProperties (long lIndex, FBTextBoxProperties* pProperties)

[VB.NET]
Public Function GetProperties (ByVal lIndex As Long, ByRef pTextboxProperties() As FBTextBoxProperties) As Boolean

Parameters

lIndex : [In] Index of a text box.

pProperties : [In] Pointer to a FBTextBoxProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

The caller should create the FBTextBoxProperties object before passing its pointer in. After changing the properties of the object, the changes can be committed back to the in-movie text box by using the SetProperties or SetPropertiesByID methods.

See Also


FBTextBoxes::GetPropertiesByID

BB FlashBack SDK: FBTextBoxes

GetPropertiesByID

Description

Sets the properties of a FBTextBoxProperties object to those of a specified text box within the movie, given its ID.

Syntax

[C#/C++]
public Bool GetPropertiesByID (long lID, FBTextBoxProperties* pProperties);

[VB.NET]
Public Function GetPropertiesByID (ByVal lID As Long, ByRef pTextboxProperties() As FBTextBoxProperties) As Boolean

Parameters

lID : [In] ID of a sound.

pProperties : [In] Pointer to a FBTextBoxProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

The caller should create the FBTextBoxProperties object before passing its pointer in. After changing the properties of the object, the changes can be committed back to the in-movie text box by using the SetProperties or SetPropertiesByID methods.

See Also


FBTextBoxes::IDExists

BB FlashBack SDK: FBTextBoxes

IDExists

Description

Checks to see if the given ID corresponds to an existing text box.

Syntax

[C#/C++]
public Bool IDExists (Long lID)

[VB.NET]
public Function IDExists (ByVal lID As Long) As Boolean

Parameters

lID : [In] ID of a text box.

Return Values

If the text box exists, the return value is zero.

If the text box does not exist, the return value is non-zero.


FBTextBoxes::SetProperties

BB FlashBack SDK: FBTextBoxes

SetProperties

Description

Sets the properties of the specified text box to those in the supplied FBTextBoxProperties object.

Syntax

[C#/C++]
public Bool SetProperties (long lIndex, FBTextBoxProperties* pProperties);

[VB.NET]
Public Function SetProperties (ByVal lIndex As Long, ByRef pTextboxProperties() As FBTextBoxProperties) As Boolean

Parameters

lIndex : [In] Index of a text box.

pProperties : [In] Pointer to an FBTextBoxProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also


FBTextBoxes::SetPropertiesByID

BB FlashBack SDK: FBTextBoxes

SetPropertiesByID

Description

Sets the properties of the specified text box to those in the supplied FBTextBoxProperties object.

Syntax

[C#/C++]
public Bool SetPropertiesByID (long lID, FBTextBoxProperties* pProperties);

[VB.NET]
Public Function SetPropertiesByID (ByVal lID As Long, ByRef pTextboxProperties() As FBTextBoxProperties) As Boolean

Parameters

lID : [In] ID of a text box.

pProperties : [In] Pointer to an FBTextBoxProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also


FBTextBoxes::Count

BB FlashBack SDK: FBTextBoxes

Count

Description

Returns the number of text boxes in the collection.

Syntax

[C#/C++]
public Long Count

[VB.NET]
Public Property Count As Long


FBTextBoxes::Frame

BB FlashBack SDK: FBTextBoxes

Frame

Description

If the FBTextBoxes collection was returned from a call to FBFrames::GetTextBoxes, this property returns the number of the frame that the collection corresponds to.

Syntax

[C#/C++]
public Long Frame

[VB.NET]
Public Property Frame As Long

See Also

FBFrames::GetTextBoxes


The FBBitmapProperties Class

This class enables access to the properties of a bitmap object displayed in the movie.

It is returned from the GetProperties and GetPropertiesByID methods of the FBBitmaps class.

Properties:


AlphaMode

BB FlashBack SDK: FBBitmapProperties

AlphaMode

Description

Returns or sets a value that determines whether alpha channel information encoded into the bitmap is used.

Syntax

[C#/C++]
public long AlphaMode

[VB.NET]
Public Property AlphaMode As Long

Remarks

Possible values:

0 | No alpha channel detected in bitmap
1 | Image contains alpha channel and it is being used.
2 | Image contains alpha channel, but it is not used in display.

Setting the value to zero has the same effect as setting it to 2 - any alpha channel information present is ignored.

Setting the value to one only has an effect if the image contains an alpha channel. Of the image formats supported by the SDK, alpha channels are only supported for 24 bit PNG files.

See Also

FBBitmapProperties::Opacity


BitmapHandle

BB FlashBack SDK: FBBitmapProperties

BitmapHandle

Description

Returns the Win32 handle of the bitmap, i.e. a HBITMAP value.

Syntax

[C#/C++]
public long BitmapHandle;

[VB.NET]
Public Property BitmapHandle As Integer


FBBitmapProperties::Depth

BB FlashBack SDK: FBBitmapProperties

Depth

Description

Returns or sets the z-order value for the bitmap, that determines which other presentation objects it falls in front of or behind.

Syntax

[C#/C++]
public long Depth;

[VB.NET]
Public Property Depth As Long


FBBitmapProperties::Duration

BB FlashBack SDK: FBBitmapProperties

Duration

Description

Returns or sets the number of milliseconds the bitmap is displayed for during movie playback.

Syntax

[C#/C++]
public Long Duration;

[VB.NET]
Public Property Duration As Long

Remarks

When the WaitClick property is set to True, the Duration property is ignored. Movie playback pauses when the bitmap is displayed and continues when the user clicks the mouse in the movie area.

See Also

FBBitmapProperties::WaitClick


FBBitmapProperties::Frame

BB FlashBack SDK: FBBitmapProperties

Frame

Description

Returns the frame number in which the bitmap is first displayed.

Syntax

[C#/C++]
public Long Frame

[VB.NET]
Public Property Frame As Long


FBBitmapProperties::Height

BB FlashBack SDK: FBBitmapProperties

Height

Description

Gets and sets the height of the bitmap in pixels.

If the KeepAspect property is set to True, the Width property will be changed accordingly, to maintain the aspect ratio of the bitmap.

Syntax

[C#/C++]
public Long Height

[VB.NET]
Public Property Height As Long

See Also

FBBitmapProperties::Width


FBBitmapProperties::ID

BB FlashBack SDK: FBBitmapProperties

ID

Description

Returns the ID of the image.

Syntax

[C#/C++]
public Long ID;

[VB.NET]
Public Property ID As Long


KeepAspect

BB FlashBack SDK: FBBitmapProperties

KeepAspect

Description

Gets and sets the value that determines whether the bitmap retains its current aspect ratio when its height or width is altered.

Syntax

[C#/C++]
public Bool KeepAspect;

[VB.NET]
Public Property KeepAspect As Boolean

Remarks

When this is set to true, changing either of the Height or Width properties produces a corresponding change in the other property, to maintain the aspect ratio of the image.

See Also


FBBitmapProperties::Name

BB FlashBack SDK: FBBitmapProperties

Name

Description

Optionally sets the filename of the image to insert when using FBEditor::InsertImage.

Valid formats for the file: GIF, BMP, JPG, PNG (8 or 24 bit).

Syntax

[C#/C++]
public String Name

[VB.NET]
Public Property Name As String

Remarks

When inserting an image into a movie by use of the FBEditor::InsertImage method, the caller passes in an FBBitmapProperties object. If the ShowOptions property of this object is set to True, a standard image selection and editing dialog will be displayed, enabling a user to select the image file to be inserted. If the ShowOptions property of the object is set to False, the image file specified by the Name property will be inserted.

See Also


FBBitmapProperties::Opacity

BB FlashBack SDK: FBBitmapProperties

Opacity

Description

Gets and sets the opacity of the bitmap.

Syntax

[C#/C++]
public long Opacity;

[VB.NET]
Public Property Opacity As Long

Remarks

The maximum value of 255 produces complete opacity. The minimum value of 0 produces a completely translucent bitmap that is effectively invisible.

See Also

FBBitmapProperties::AlphaMode


FBBitmapProperties::OriginX

BB FlashBack SDK: FBBitmapProperties

OriginX

Description

Gets and sets the X position, in pixels, of the left hand edge of the bitmap.

Syntax

[C#/C++]
public long OriginX

[VB.NET]
Public Property OriginX As Long

See also

FBBitmapProperties::OriginY


FBBitmapProperties::OriginY

BB FlashBack SDK: FBBitmapProperties

OriginY

Description

Gets and sets the Y position, in pixels, of the top edge of the bitmap.

Syntax

[C#/C++]
public long OriginY

[VB.NET]
Public Property OriginY As Long

See also

FBBitmapProperties::OriginX


FBBitmapProperties::ShowOptions

BB FlashBack SDK: FBBitmapProperties

ShowOptions

Description

Determines the action taken on passing the FBBitmapProperties object to FBEditor::InsertImage.

Syntax

[C#/C++]
public Bool ShowOptions;

[VB.NET]
Public Property ShowOptions As Boolean

Remarks

If ShowOptions is set to True, and the FBBitmapProperties object is passed to the FBEditor::InsertImage method, a standard dialog for selecting and editing image properties is displayed, allowing a user to select an image file and change the image properties as required.

If ShowOptions is set to False, and the FBBitmapProperties object is passed to the FBEditor::InsertImage method, the image file specified by the Name property will be inserted and its properties set to those specified by the FBBitmapProperties object.

See Also

FBBitmapProperties::Name FBEditor::InsertImage


TransparentColor

BB FlashBack SDK: FBBitmapProperties

TransparentColor

Description

Returns and sets the transparent color in the bitmap.

Syntax

[C#/C++]
public ulong TransparentColor

[VB.NET]
Public Property TransparentColor As Long

Remarks

When UseTransparentColor is set to True, all pixels of the specified color become completely transparent.

Colors are specified in a long as a Win32 COLORREF value, which can be created by an RGB macro - see Win32 Platform SDK documentation.

See Also

FBBitmapProperties::UseTransparentColor


UseTransparentColor

BB FlashBack SDK: FBBitmapProperties

UseTransparentColor

Description

This property determines whether the color set in the TransparentColor property is made transparent. When UseTransparentColor is set to True, all pixels of the specified color become completely transparent.

Syntax

[C#/C++]
public Boolean UseTransparentColor

[VB.NET]
Public Property UseTransparentColor As Boolean

Remarks

See Also

FBBitmapProperties::TransparentColor


FBBitmapProperties::WaitClick

BB FlashBack SDK: FBBitmapProperties

WaitClick

Description

This property determines whether displaying this bitmap causes movie playback to pause, and wait for the user to click the mouse in the movie area before continuing.

When this property is set to True, the movie pauses when the bitmap is displayed, and the Duration property is ignored.

Defaults to False.

Syntax

[C#/C++]
public Bool WaitClick;

[VB.NET]
Public Property WaitClick As Boolean

Remarks

See Also

FBBitmapProperties::Duration


FBBitmapProperties::Width

BB FlashBack SDK: FBBitmapProperties

Width

Description

This property gets and sets the width, in pixels, of the bitmap.

Syntax

[C#/C++]
public Long Width

[VB.NET]
Public Property Width As Long

Remarks

If the KeepAspect property is set to True, the Height property will be changed accordingly, to maintain the aspect ratio of the bitmap.

See Also


The FBButtonProperties Class

This class enables access to the properties of a button object displayed in the movie.

It is returned from the GetProperties and GetPropertiesByID methods of the FBButtons class.

Properties:

Action
Alignment
BackColor
Caption
Depth
Duration
FontName
FontSize
FontStyle
Frame
Gradient
GradientColor
Height
ID
JScript
JumpTo
Margin
NoPauseGraphic
Opacity
OriginX
OriginY
OverColor
Pause
PauseId
PlayAfter
TextColor
Url
Width


Action

BB FlashBack SDK: FBButtonProperties

Action

Description

Returns or sets the type of action performed by the button when clicked.

Syntax

[C#/C++]
public Long Action;

[VB.NET]
Public Property Duration As Action

Remarks

Possible values:

1 - play

2 - stop playback

3 - Jump to frame

4 - Jump to marker

5 - Jump to object

7 - Open URL

8 - Execute javascript

See also


Alignment

BB FlashBack SDK: FBButtonProperties

Alignment

Description

Describes the vertical and horizontal alignment of text in the button.

Syntax

[C#/C++]
public Long Alignment;

[VB.NET]
Public Property Alignment As Integer

Remarks

Vertical and horizontal alignment is set via setting bits in the value, as follow:

Bit 0 | Align to left
Bit 1 | Center horizontally
Bit 2 | Align to right
Bit 3 | Not used
Bit 4 | Center vertically
Bit 5 | Align to bottom

Other bits are not used.

If bits 4 and 5 are not set, vertical centering is set to the top of the button.

See Also


BackColor

BB FlashBack SDK: FBButtonProperties

BackColor

Description

Returns and sets the background color for the button.

Syntax

[C#/C++]
public Long BackColor;

[VB.NET]
Public Property BackColor As Integer

Remarks

Colors are specified in a long as a Win32 COLORREF value, which can be created by an RGB macro - see Win32 Platform SDK documentation.

When the Gradient property is set to True, BackColor is the 'start' color of the gradient - the color used on the topmost edge if the gradient is vertical and the left edge if the gradient is horizontal.

See Also


Caption

BB FlashBack SDK: FBButtonProperties

Caption

Description

Defines the text displayed in the button.

Syntax

[C#/C++]
public String Caption

[VB.NET]
Public Property Caption As String

See Also


Depth

BB FlashBack SDK: FBButtonProperties

Depth

Description

Returns or sets the z-order value for the button to determine which other presentation objects it falls in front of or behind.

Syntax

[C#/C++]
public long Depth;

[VB.NET]
Public Property Depth As Long


Duration

BB FlashBack SDK: FBButtonProperties

Duration

Description

Returns or sets the number of milliseconds the button is displayed for during movie playback.

Syntax

[C#/C++]
public Long Duration;

[VB.NET]
Public Property Duration As Long


FontName

BB FlashBack SDK: FBButtonProperties

FontName

Description

The name of the font to be used when rendering text in the button.

Syntax

[C#/C++]
public String FontName;

[VB.NET]
Public Property FontName As String

See Also


FontSize

BB FlashBack SDK: FBButtonProperties

FontSize

Description

The size, in points, of text in this button.

Syntax

[C#/C++]
public long FontSize;

[VB.NET]
Public Property FontSize As Long

See Also


FontStyle

BB FlashBack SDK: FBButtonProperties

FontStyle

Description

Describes the font attributes: bold, italic, underline.

Syntax

[C#/C++]
public long FontStyle;

[VB.NET]
Public Property FontStyle As Long

Remarks

Bits 0-2 determine the font style. Set the bits to enable a particular style:

Bit 0 | Bold
Bit 1 | Italic
Bit 2 | Underlined

See Also


Frame

BB FlashBack SDK: FBButtonProperties

Frame

Description

Returns the frame number in which the button is first displayed.

Syntax

[C#/C++]
public Long Frame

[VB.NET]
Public Property Frame As Long


Gradient

BB FlashBack SDK: FBButtonProperties

Gradient

Description

Set to True to have a gradient fill across the button background, as opposed to a flat fill of a single color.

Syntax

[C#/C++]
public Bool Gradient;

[VB.NET]
Public Property Gradient As Boolean

Remarks

The type of the gradient - horizontal or vertical - is set by GradientType. The start and end colors are defined by BackColor and GradientColor.

See Also


GradientColor

BB FlashBack SDK: FBButtonProperties

GradientColor

Description

Returns and sets the value of the 'end' color if a gradient fill has been specified for the button.

Syntax

[C#/C++]
public ulong GradientColor

[VB.NET]
Public Property GradientColor As Integer

Remarks

Colors are specified in a long as a Win32 COLORREF value, which can be created by an RGB macro - see Win32 Platform SDK documentation.

The 'start' color of the gradient fill is specified by the BackColor property. The type of the gradient - horizontal or vertical - is set by the GradientType property. Gradient fills are enabled by the Gradient property.

See Also


Height

BB FlashBack SDK: FBButtonProperties

Height

Description

Gets and sets the height of the button in pixels.

If the KeepAspect property is set to True, the Width property will be changed accordingly, to maintain the aspect ratio of the button.

Syntax

[C#/C++]
public Long Height

[VB.NET]
Public Property Height As Long

See Also

FBButtonProperties::Width


ID

BB FlashBack SDK: FBButtonProperties

ID

Description

Returns the ID of the button.

Syntax

[C#/C++]
public Long ID;

[VB.NET]
Public Property ID As Long


JScript

BB FlashBack SDK: FBButtonProperties

JScript

Description

The javascript run when the button is clicked, if '7' is set for the Action property.

This code is only run from the Flash export of the movie. There is a limit of 400 characters, so nothing complex can be coded, but javascript functions in the page containing the Flash movie can be called.

Syntax

[C#/C++]
public String JScript

[VB.NET]
Public Property JScript As String


JumpTo

BB FlashBack SDK: FBButtonProperties

JumpTo

Description

Specifies the frame, marker or object the button will trigger a jump to when clicked.

Syntax

[C#/C++]
public Long JumpTo;

[VB.NET]
Public Property JumpTo As Long

Remarks

When the Action property is set to '3' (jump to frame) the JumpTo property indicates the frame the button will jump to.

When the Action property is set to '4' (jump to marker) the JumpTo property indicates the ID of the marker the button will jump to.

When the Action property is set to '5' (jump to object) the JumpTo property indicates the ID of the object the button will jump to.

See Also

FBButtonProperties::Action


Margin

BB FlashBack SDK: FBButtonProperties

Margin

Description

Returns and sets the space, in pixels, between the contents of the button and its border.

Syntax

[C#/C++]
public long Margin;

[VB.NET]
Public Property Margin As Long


NoPauseGraphic

BB FlashBack SDK: FBButtonProperties

NoPauseGraphic

Description

Determines whether the standard pause graphic is displayed when the button pauses the movie.

Syntax

[C#/C++]
public Bool NoPauseGraphic

[VB.NET]
Public Property NoPauseGraphic As Boolean


Opacity

BB FlashBack SDK: FBButtonProperties

Opacity

Description

Gets and sets the opacity of the button.

Syntax

[C#/C++]
public long Opacity;

[VB.NET]
Public Property Opacity As Long

Remarks

The maximum value of 255 produces complete opacity. The minimum value of 0 produces a completely translucent button that is effectively invisible but can still capture clicks.


OriginX

BB FlashBack SDK: FBButtonProperties

OriginX

Description

Gets and sets the X position, in pixels, of the left hand edge of the button.

Syntax

[C#/C++]
public long OriginX

[VB.NET]
Public Property OriginX As Long

See also

FBButtonProperties::OriginY


OriginY

BB FlashBack SDK: FBButtonProperties

OriginY

Description

Gets and sets the Y position, in pixels, of the top edge of the button.

Syntax

[C#/C++]
public long OriginY

[VB.NET]
Public Property OriginY As Long

See also

FBButtonProperties::OriginX


OverColor

BB FlashBack SDK: FBButtonProperties

OverColor

Description

Gets and sets the color used for the highlight drawn when the mouse is over the button. The highlight is drawn inside the border of the button.

Syntax

[C#/C++]
public Long OverColor;

[VB.NET]
Public Property OverColor As Integer

Remarks

Colors are specified in a long as a Win32 COLORREF value, which can be created by an RGB macro - see Win32 Platform SDK documentation.

When the Gradient property is set to True, BackColor is the 'start' color of the gradient - the color used on the topmost edge if the gradient is vertical and the left edge if the gradient is horizontal.

See Also


Pause

BB FlashBack SDK: FBButtonProperties

Pause

Description

Sets and gets whether the movie will pause at the button.

Syntax

[C#/C++]
public Bool Pause

[VB.NET]
Public Property Pause As Boolean

Remarks

If this property is set to True, a Pause object will be created in the same frame as the button and movie playback will pause at the frame. The PauseId property will contain the ID of the Pause object.

See also

FBButtonProperties:PauseId


PauseId

BB FlashBack SDK: FBButtonProperties

PauseId

Description

If the Pause property is set to True, the PauseId property contains the ID of the Pause object that implements the pause

Syntax

[C#/C++]
public Long PauseId;

[VB.NET]
Public Property PauseId As Long

See also

FBButtonProperties::Pause


PlayAfter

BB FlashBack SDK: FBButtonProperties

PlayAfter

Description

Specifies whether the movie will continue playback after a jump has been triggered by the button.

Syntax

[C#/C++]
public Bool PlayAfter;

[VB.NET]
Public Property PlayAfter As Boolean

See Also


TextColor

BB FlashBack SDK: FBButtonProperties

TextColor

Description

Returns and sets the color of the text drawn in the button.

Syntax

[C#/C++]
public ulong TextColor

[VB.NET]
Public Property TextColor As Integer

Remarks

Colors are specified in a long as a Win32 COLORREF value, which can be created by an RGB macro - see Win32 Platform SDK documentation.

See Also


URL

BB FlashBack SDK: FBButtonProperties

Url

Description

Specifies the URL that will be opened by clicking the button, if its Action is set to '7'.

Syntax

[C#/C++]
public String Url;

[VB.NET]
Public Property Url As String

See Also

FBButtonProperties::Action


Width

BB FlashBack SDK: FBButtonProperties

Width

Description

This property gets and sets the width, in pixels, of the button.

Syntax

[C#/C++]
public Long Width

[VB.NET]
Public Property Width As Long

See Also

FBButtonProperties::Height


The FBMarkerProperties Class

This class enables access to the properties of a marker object contained in the movie.

It is returned from the GetProperties and GetPropertiesByID methods of the FBMarkers class.

Properties:


FBMarkerProperties::Frame

BB FlashBack SDK: FBMarkerProperties

Frame

Description

Returns the index of the frame that contains the marker.

Syntax

[C#/C++]
public long Frame

[VB.NET]
Public Property Frame As Long


FBMarkerProperties::ID

BB FlashBack SDK: FBMarkerProperties

ID

Description

Returns the ID of the marker.

Syntax

[C#/C++]
public Long ID;

[VB.NET]
Public Property ID As Long


FBMarkerProperties::Name

BB FlashBack SDK: FBMarkerProperties

Name

Description

Sets and gets the name of the marker.

Syntax

[C#/C++]
public String Name

[VB.NET]
Public Property Name As String


FBMarkerProperties::Pause

BB FlashBack SDK: FBMarkerProperties

Pause

Description

Sets and gets whether the movie will pause at the marker.

Syntax

[C#/C++]
public Bool Pause

[VB.NET]
Public Property Pause As Boolean

Remarks

If this property is set to True, movie playback will pause at the frame containing the marker.


FBMarkerProperties::ShowOptions

BB FlashBack SDK: FBMarkerProperties

ShowOptions

Description

Determines the action taken on passing the FBMarkerProperties object to FBEditor::InsertMarker.

Syntax

[C#/C++]
public Boolean ShowOptions;

[VB.NET]
Public Property ShowOptions As Boolean

Remarks

If ShowOptions is set to True, and the FBMarkerProperties object is passed to the FBEditor::InsertMarker method, a standard dialog for setting marker properties is displayed.

If ShowOptions is set to False, and the FBMarkerProperties object is passed to the FBEditor::InsertMarker method, the new marker takes on the properties of the FBMarkerProperties object.

See Also

FBEditor::InsertMarker


The FBSoundProperties Class

Each movie can contain multiple sound 'tracks'. An FBSoundProperties object represents a single sound track, which can contain a number of FBSoundClip objects.

It is returned from the GetProperties and GetPropertiesByID methods of the FBSounds class.

See How the sound classes work for more information on the sound classes.

Properties

Filename
ID
IsMP3
ShowOptions
SoundClipsCount

Methods


FBSoundProperties::Filename

BB FlashBack SDK: FBSoundProperties

Filename

Description

Optionally sets the filename of the sound when inserted into the movie using FBEditor:InsertSound.

Syntax

[C#/C++]
public String Name;

[VB.NET]
Public Property Filename As String

Remarks

When inserting an sound into a movie by use of the FBEditor::InsertSound method, the caller passes in an FBSoundProperties object. If the ShowOptions property of this object is set to True, a standard sound file selection dialog will be displayed, enabling a user to select the sound file to be inserted. If the ShowOptions property of the object is set to False, the sound file specified by the Filename property will be inserted.

See Also


FBSoundProperties::ID

BB FlashBack SDK: FBSoundProperties

ID

Description

Returns the ID of the sound.

Syntax

[C#/C++]
public Long ID;

[VB.NET]
Public Property ID As Long


IsMP3

BB FlashBack SDK: FBSoundProperties

IsMP3

Description

Returns a value indicating whether the sound is in MP3 format.

Zero for false (sound is not in MP3 format) and non-zero for true.

When a sound is being inserted into a movie by passing an FBSoundProperties object to FBEditor:InsertSound, setting IsMP3 to True for that object means that the sound file will be converted to MP3 format before being inserted.

Setting this value for a sound that has already been inserted into a movie has no effect.

Syntax

[C#/C++]
public long IsMP3;

[VB.NET]
Public Property IsMP3 As Integer


FBSoundProperties::ShowOptions

BB FlashBack SDK: FBSoundProperties

ShowOptions

Description

Determines the action taken on passing the FBSoundProperties object to FBEditor::InsertSound.

Syntax

[C#/C++]
public Bool ShowOptions;

[VB.NET]
Public Property ShowOptions As Boolean

Remarks

If ShowOptions is set to True, and the FBSoundProperties object is passed to the FBEditor::InsertSound method, a standard dialog for selecting a sound file is displayed.

If ShowOptions is set to False, and the FBSoundProperties object is passed to the FBEditor::InsertSound method, the new sound takes on the properties of the FBSoundProperties object.

See Also

FBEditor::InsertSound


SoundClipsCount

BB FlashBack SDK: FBSoundProperties

SoundClipsCount

Description

Returns the number of sounds clips in the sound track represented by the FBSoundProperties object.

Syntax

[C#/C++]
public Long SoundClipsCount;

[VB.NET]
Public Property SoundClipsCount As Integer

See Also


GetSoundClipProperties

BB FlashBack SDK: FBSoundProperties

GetSoundClipProperties

Description

Fills an FBSoundClip object with the properties of a specified sound clip in the sound track represented by the FBSoundProperties object.

Syntax

[C#/C++]
public void GetSoundClipProperties (long index, FBSoundClip* pClip);

[VB.NET]
Public Sub GetSoundClipProperties (ByVal index As Integer, ByRef pClip As FBSoundClip)

Parameters

index (in) - index of the clip to retrieve.

pClip (in/out) - pointer to sound clip object. On method return, this contains properties of the specified sound clip.

Remarks

You should create the FBSoundClip object before passing its pointer into this method.

After returning from this call, you can alter the properties of the FBSoundClip object and pass its pointer into SetSoundClipProperties to write the values back to the movie.

See Also


SetSoundClipProperties

BB FlashBack SDK: FBSoundProperties

SetSoundClipProperties

Description

Sets the properties of a sound clip.

Use FBSoundProperties::GetSoundClipProperties to get a sound clip object, make changes to its properties and then write back these changes to the movie with FBSoundProperties::SetSoundClipProperties.

Syntax

[C#/C++]
public void SetSoundClipProperties (long index, FBSoundClip* pClip);

[VB.NET]
Public Sub SetSoundClipProperties (ByVal index As Integer, ByRef pClip As FBSoundClip)

Parameters

index (in) - index of the clip to retrieve.

pClip (in) - pointer to sound clip object.

Remarks

You should create the FBSoundClip object before passing its pointer into GetSoundClipProperties.

After returning from that call, you can alter the properties of the FBSoundClip object and pass its pointer into SetSoundClipProperties to write the values back to the movie.

See Also


The FBTextBoxProperties Class

This class enables access to the properties of a text box contained in the movie.

It is returned from the GetProperties and GetPropertiesByID methods of the FBTextBoxes class.

Properties

Alignment
BackColor
BorderColor
BorderWidth
Callout
CalloutLeftX
CalloutLeftY
CalloutRightX
CalloutRightY
Depth
DrawBorder
FontName
FontSize
FontStyle
Frame
Gradient
GradientColor
GradientType
Height
Margin
Opacity
OriginX
OriginY
RoundCorners
Shadow
ShadowColor
ShadowOpacity
ShadowWidth
ShowOptions
SolidBox
TextBoxText
TextColor
TextTime
WaitClick
Width


FBTextBoxProperties::Alignment

BB FlashBack SDK: FBTextBoxProperties

Alignment

Description

Describes the vertical and horizontal alignment of text in the textbox.

Syntax

[C#/C++]
public Long Alignment;

[VB.NET]
Public Property Alignment As Integer

Remarks

Vertical and horizontal alignment is set via setting bits in the value, as follow:

Bit 0 | Align to left
Bit 1 | Center horizontally
Bit 2 | Align to right
Bit 3 | Not used
Bit 4 | Center vertically
Bit 5 | Align to bottom

Other bits are not used.

If bits 4 and 5 are not set, vertical centering is set to the top of the box.

See Also


BackColor

BB FlashBack SDK: FBTextBoxProperties

BackColor

Description

Returns and sets the background color for the text box.

Syntax

[C#/C++]
public Long BackColor;

[VB.NET]
Public Property BackColor As Integer

Remarks

Colors are specified in a long as a Win32 COLORREF value, which can be created by an RGB macro - see Win32 Platform SDK documentation.

When the Gradient property is set to True, BackColor is the 'start' color of the gradient - the color used on the topmost edge if the gradient is vertical and the left edge if the gradient is horizontal.

See Also


FBTextBoxProperties::BorderColor

BB FlashBack SDK: FBTextBoxProperties

BorderColor

Description

Returns and sets the border color for the text box.

Syntax

[C#/C++]
public ulong BorderColor;

[VB.NET]
Public Property BorderColor As Integer

Remarks

Colors are specified in a long as a Win32 COLORREF value, which can be created by an RGB macro - see Win32 Platform SDK documentation.

See Also

FBTextBoxProperties::BorderWidth


FBTextBoxProperties::BorderWidth

BB FlashBack SDK: FBTextBoxProperties

BorderWidth

Description

Returns and sets the width, in pixels, of the text box border.

Syntax

[C#/C++]
public Long BorderWidth;

[VB.NET]
Public Property BorderWidth As Integer

See Also

FBTextBoxProperties::BorderColor


FBTextBoxProperties::Callout

BB FlashBack SDK: FBTextBoxProperties

Callout

Description

Set to True to have a 'callout' type pointer extend from the text box.

Syntax

[C#/C++]
public Bool Callout;

[VB.NET]
Public Property Callout As Boolean

Remarks

The position of the end of the callout pointer is set by the CalloutPntX and CalloutPntY properties.

The two points at which the callout triangle meets the edge of the text box are set by the CalloutLeftX, CalloutLeftY and CalloutRightX and CalloutRightY properties.

See Also

FBTextBoxProperties::CalloutLeftX FBTextBoxProperties::CalloutLeftY FBTextBoxProperties::CalloutRightX FBTextBoxProperties::CalloutRightY FBTextBoxProperties::CalloutPntX FBTextBoxProperties::CalloutPntY


FBTextBoxProperties::CalloutLeftX

BB FlashBack SDK: FBTextBoxProperties

CalloutLeftX

Description

Returns the X position of one of the points at where the callout triangle meets the edge of the text box.

Syntax

[C#/C++]
public Long CalloutLeftX;

[VB.NET]
Public Property CalloutLeftX As Long

See Also

FBTextBoxProperties::CalloutLeftY FBTextBoxProperties::CalloutRightX FBTextBoxProperties::CalloutRightY FBTextBoxProperties::CalloutPntX FBTextBoxProperties::CalloutPntY FBTextBoxProperties::Callout


FBTextBoxProperties::CalloutLeftY

BB FlashBack SDK: FBTextBoxProperties

CalloutLeftY

Description

Returns the Y position of one of the points at where the callout triangle meets the edge of the text box.

Syntax

[C#/C++]
public long CalloutLeftY;

[VB.NET]
Public Property CalloutLeftY As Long

See Also

FBTextBoxProperties::CalloutLeftX FBTextBoxProperties::CalloutRightX FBTextBoxProperties::CalloutRightY FBTextBoxProperties::CalloutPntX FBTextBoxProperties::CalloutPntY FBTextBoxProperties::Callout


FBTextBoxProperties::CallloutPntX

BB FlashBack SDK: FBTextBoxProperties

CalloutPntX

Description

Returns and sets the X position of the end point of the callout triangle.

Syntax

[C#/C++]
public long CalloutPntX;

[VB.NET]
Public Property CalloutPntX As Long

See Also

FBTextBoxProperties::CalloutLeftX FBTextBoxProperties::CalloutLeftY FBTextBoxProperties::CalloutRightX FBTextBoxProperties::CalloutRightY FBTextBoxProperties::CalloutPntY FBTextBoxProperties::Callout


FBTextBoxProperties::CalloutPntY

BB FlashBack SDK: FBTextBoxProperties

CalloutPntY

Description

Returns and sets the Y position of the end point of the callout triangle.

Syntax

[C#/C++]
public long CalloutPntY;

[VB.NET]
Public Property CalloutPntY As Long

See Also

FBTextBoxProperties::CalloutLeftX FBTextBoxProperties::CalloutLeftY FBTextBoxProperties::CalloutRightX FBTextBoxProperties::CalloutRightY FBTextBoxProperties::CalloutPntX FBTextBoxProperties::Callout


FBTextBoxProperties::CalloutRightX

BB FlashBack SDK: FBTextBoxProperties

CalloutRightX

Description

Returns the X position of one of the points at where the callout triangle meets the edge of the text box.

Syntax

[C#/C++]
public long CalloutRightX;

[VB.NET]
Public Property CalloutRightX As Long

See Also

FBTextBoxProperties::CalloutLeftX FBTextBoxProperties::CalloutLeftY FBTextBoxProperties::CalloutPntX FBTextBoxProperties::CalloutRightY FBTextBoxProperties::CalloutPntY FBTextBoxProperties::Callout


FBTextBoxProperties::CalloutRightY

BB FlashBack SDK: FBTextBoxProperties

CalloutRightY

Description

Returns the Y position of one of the points at where the callout triangle meets the edge of the text box.

Syntax

[C#/C++]
public long CalloutRightY;

[VB.NET]
Public Property CalloutRightY As Long

See Also

FBTextBoxProperties::CalloutLeftX FBTextBoxProperties::CalloutLeftY FBTextBoxProperties::CalloutPntX FBTextBoxProperties::CalloutRightX FBTextBoxProperties::CalloutPntY FBTextBoxProperties::Callout


FBTextBoxProperties::Depth

BB FlashBack SDK: FBTextBoxProperties

Depth

Description

Returns or sets the z-order value for the text box, that determines which other presentation objects it falls in front of or behind.

Syntax

[C#/C++]
public long Depth;

[VB.NET]
Public Property Depth As Long


FBTextBoxProperties::DrawBorder

BB FlashBack SDK: FBTextBoxProperties

DrawBorder

Description

Set to True to draw a border around the text box. The border width and color are determined by the BorderColor and BorderWidth parameters.

Syntax

[C#/C++]
public Bool DrawBorder;

[VB.NET]
Public Property DrawBorder As Boolean

See Also


FBTextBoxProperties::FontName

BB FlashBack SDK: FBTextBoxProperties

FontName

Description

The name of the font to be used when rendering text in this text box.

Syntax

[C#/C++]
public String FontName;

[VB.NET]
Public Property FontName As String

See Also


FBTextBoxProperties::FontSize

BB FlashBack SDK: FBTextBoxProperties

FontSize

Description

The size, in points, of text in this text box.

Syntax

[C#/C++]
public long FontSize;

[VB.NET]
Public Property FontSize As Long

See Also


FBTextBoxProperties::FontStyle

BB FlashBack SDK: FBTextBoxProperties

FontStyle

Description

Describes the font attributes: bold, italic, underline.

Syntax

[C#/C++]
public long FontStyle;

[VB.NET]
Public Property FontStyle As Long

Remarks

Bits 0-2 determine the font style. Set the bits to enable a particular style:

Bit 0 | Bold
Bit 1 | Italic
Bit 2 | Underlined

See Also


FBTextBoxProperties::Frame

BB FlashBack SDK: FBTextBoxProperties

Frame

Description

Returns the frame number in which the text box is first displayed.

Syntax

[C#/C++]
public long Frame

[VB.NET]
Public Property Frame As Long


Gradient

BB FlashBack SDK: FBTextBoxProperties

Gradient

Description

Set to True to have a gradient fill across the text box background, as opposed to a flat fill of a single color.

Syntax

[C#/C++]
public Bool Gradient;

[VB.NET]
Public Property Gradient As Boolean

Remarks

The type of the gradient - horizontal or vertical - is set by GradientType. The start and end colors are defined by BackColor and GradientColor.

See Also


GradientColor

BB FlashBack SDK: FBTextBoxProperties

GradientColor

Description

Returns and sets the value of the 'end' color if a gradient fill has been specified for the text box.

Syntax

[C#/C++]
public ulong GradientColor

[VB.NET]
Public Property GradientColor As Integer

Remarks

Colors are specified in a long as a Win32 COLORREF value, which can be created by an RGB macro - see Win32 Platform SDK documentation.

The 'start' color of the gradient fill is specified by the BackColor property. The type of the gradient - horizontal or vertical - is set by the GradientType property. Gradient fills are enabled by the Gradient property.

See Also


GradientType

BB FlashBack SDK: FBTextBoxProperties

GradientType

Description

Determines the direction of the gradient - either vertical or horizontal.

Syntax

[C#/C++]
public long GradientType;

[VB.NET]
Public Property GradientType As Long

Remarks

Set this property to zero for a vertical gradient, any other value for horizontal.

Gradient fills are enabled by the Gradient property. The start and end colors are defined by BackColor and GradientColor.

See Also


FBTextBoxProperties::Height

BB FlashBack SDK: FBTextBoxProperties

Height

Description

Gets and sets the height of the text box in pixels.

Syntax

[C#/C++]
public Long Height;

[VB.NET]
Public Property Height As Long

See Also

FBTextBoxProperties::Width


FBTextBoxProperties::ID

BB FlashBack SDK: FBTextBoxProperties

ID

Description

Returns the ID of the text box.

Syntax

[C#/C++]
public Long ID;

[VB.NET]
Public Property ID As Long


Margin

BB FlashBack SDK: FBTextBoxProperties

Margin

Description

Returns and sets the space, in pixels, between the contents of the text box and its border.

Syntax

[C#/C++]
public long Margin;

[VB.NET]
Public Property Margin As Long


FBTextBoxProperties::Opacity

BB FlashBack SDK: FBTextBoxProperties

Opacity

Description

Gets and sets the opacity of the text box.

Syntax

[C#/C++]
public long Opacity;

[VB.NET]
Public Property Opacity As Long

Remarks

The maximum value of 255 produces complete opacity. The minimum value of 0 produces a completely translucent text box that is effectively invisible.


FBTextBoxProperties::OriginX

BB FlashBack SDK: FBTextBoxProperties

OriginX

Description

Gets and sets the X position, in pixels, of the left hand edge of the text box.

Syntax

[C#/C++]
public long OriginX

[VB.NET]
Public Property OriginX As Long

See also

FBTextBoxProperties::OriginY


FBTextBoxProperties::OriginY

BB FlashBack SDK: FBTextBoxProperties

OriginY

Description

Gets and sets the Y position, in pixels, of the top edge of the text box.

Syntax

[C#/C++]
public long OriginY;

[VB.NET]
Public Property OriginY As Long

See also

FBTextBoxProperties::OriginX


RoundCorners

BB FlashBack SDK: FBTextBoxProperties

RoundCorners

Description

Set to True to have the corners of the text box be drawn rounded.

Syntax

[C#/C++]
public Bool RoundCorners;

[VB.NET]
Public Property RoundCorners As Boolean


FBTextBoxProperties::Shadow

BB FlashBack SDK: FBTextBoxProperties

Shadow

Description

Set to True to draw a shadow below and to the right of the text box. The shadow width, color and opacity are determined by the ShadowColor, ShadowWidth and ShadowOpacity parameters.

Syntax

[C#/C++]
public Bool Shadow;

[VB.NET]
Public Property Shadow As Boolean

See Also


FBTextBoxProperties::ShadowColor

BB FlashBack SDK: FBTextBoxProperties

ShadowColor

Description

Returns and sets the value of the shadow color for the text box.

Syntax

[C#/C++]
public long ShadowColor;

[VB.NET]
Public Property ShadowColor As Long

Remarks

Colors are specified in a long as a Win32 COLORREF value, which can be created by an RGB macro - see Win32 Platform SDK documentation.

See Also


FBTextBoxProperties::ShadowOpacity

BB FlashBack SDK: FBTextBoxProperties

ShadowOpacity

Description

Gets and sets the opacity of the text box shadow.

Syntax

[C#/C++]
public long ShadowOpacity;

[VB.NET]
Public Property ShadowOpacity As Long

Remarks

The maximum value of 255 produces complete opacity. The minimum value of 0 produces a completely translucent text box that is effectively invisible.

The Shadow property enables the text box shadow.

See also


FBTextBoxProperties::ShadowWidth

BB FlashBack SDK: FBTextBoxProperties

ShadowWidth

Description

Returns and sets the width, in pixels, of the text box shadow.

Syntax

[C#/C++]
public long ShadowWidth;

[VB.NET]
Public Property ShadowWidth As Long

See Also


FBTextBoxProperties::ShowOptions

BB FlashBack SDK: FBTextBoxProperties

ShowOptions

Description

Determines the action taken on passing the FBTextBoxProperties object to FBEditor::InsertTextBox.

Syntax

[C#/C++]
public Bool ShowOptions;

[VB.NET]
Public Property ShowOptions As Boolean

Remarks

If ShowOptions is set to True, and the FBTextBoxProperties object is passed to the FBEditor::InsertTextBox method, a standard dialog for setting textbox properties is displayed.

If ShowOptions is set to False, and the FBTextBoxProperties object is passed to the FBEditor::InsertTextBox method, the new textbox takes on the properties of the FBTextBoxProperties object.

See Also

FBEditor::InsertSound


SolidBox

BB FlashBack SDK: FBTextBoxProperties

SolidBox

Description

Set to True to have the box background drawn. Set to False to have no background to the box - only the text and borders will be drawn.

Syntax

[C#/C++]
public Bool SolidBox;

[VB.NET]
Public Property SolidBox As Boolean


TextBoxText

BB FlashBack SDK: FBTextBoxProperties

TextBoxText

Description

A string containing the text to be drawn in the text box.

Syntax

[C#/C++]
public String TextBoxText;

[VB.NET]
Public Property TextBoxText As String

See Also


FBTextBoxProperties::TextColor

BB FlashBack SDK: FBTextBoxProperties

TextColor

Description

Returns and sets the color of the text drawn in the text box.

Syntax

[C#/C++]
public ulong TextColor

[VB.NET]
Public Property TextColor As Integer

Remarks

Colors are specified in a long as a Win32 COLORREF value, which can be created by an RGB macro - see Win32 Platform SDK documentation.

See Also

FBTextBoxProperties::BorderWidth


FBTextBoxProperties::TextTime

BB FlashBack SDK: FBTextBoxProperties

TextTime

Description

Returns or sets the number of milliseconds the text box is displayed for during movie playback.

Syntax

[C#/C++]
public long TextTime;

[VB.NET]
Public Property TextTime As Long

Remarks

When the WaitClick property is set to True, the TextTime property is ignored. Movie playback pauses when the text box is displayed and continues when the user clicks the mouse in the movie area.

Set TextTime to -1 and call FBTextBoxes::DistributeTextBoxes to have each text box displayed until the start frame of the next box.

See Also


FBTextBoxProperties::WaitClick

BB FlashBack SDK: FBTextBoxProperties

WaitClick

Description

Determines whether displaying this text box causes movie playback to pause, and wait for the user to click the mouse in the movie area before continuing.

Syntax

[C#/C++]
public Bool WaitClick;

[VB.NET]
Public Property WaitClick As Boolean

Remarks

When this property is set to True, the movie pauses when the text box is displayed, and the TextTime property is ignored.

See Also

FBTextBoxProperties::TextTime


FBTextBoxProperties::Width

BB FlashBack SDK: FBTextBoxProperties

Width

Description

Returns and sets the width, in pixels, of the text box.

Syntax

[C#/C++]
public long Width;

[VB.NET]
Public Property Width As Long

See Also

FBTextBoxProperties::Height


The FBInsertTextBoxParams Class

BB FlashBack SDK: In-movie Presentation Classes

The InsertTextBoxParams Class

This class is used by the FBEditor::InsertTextBox FBRecorder::InsertTextBox method to insert a text box while recording.

Properties


FBInsertTextBoxParams::Alignment

BB FlashBack SDK: InsertTextBoxParams

Alignment

Description

Describes the vertical and horizontal alignment of text in the textbox.

Syntax

[C#/C++]
public long Alignment;

[VB.NET]
Public Property Alignment As Long

Remarks

Vertical and horizontal alignment is set via setting bits in the value, as follow:

Bit 0 | Align to left
Bit 1 | Center horizontally
Bit 2 | Align to right
Bit 3 | Not used
Bit 4 | Center vertically
Bit 5 | Align to bottom

Other bits are not used.

If bits 4 and 5 are not set, vertical centering is set to the top of the box.

See Also


InsertTextBoxParams::BackgroundColor

BB FlashBack SDK: InsertTextBoxParams

BackgroundColor

Description

Returns and sets the background color for the text box.

Syntax

[C#/C++]
public long BackgroundColor;

[VB.NET]
Public Property BackgroundColor As Long

Remarks

Colors are specified in a long as a Win32 COLORREF value, which can be created by an RGB macro - see Win32 Platform SDK documentation.

When the Gradient property is set to True, BackColor is the 'start' color of the gradient - the color used on the topmost edge if the gradient is vertical and the left edge if the gradient is horizontal.

See Also

InsertTextBoxParams::TextColor


FBInsertTextBoxParams::FontName

BB FlashBack SDK: InsertTextBoxParams

FontName

Description

The name of the font to be used when rendering text in this text box.

Syntax

[C#/C++]
public String FontName;

[VB.NET]
Public Property FontName As String

See Also


FBInsertTextBoxParams::FontSize

BB FlashBack SDK: InsertTextBoxParams

FontSize

Description

The size, in points, of text in this text box.

Syntax

[C#/C++]
public long FontSize;

[VB.NET]
Public Property FontSize As Long

See Also


FBInsertTextBoxParams::FontStyle

BB FlashBack SDK: InsertTextBoxParams

FontStyle

Description

Describes the font attributes: bold, italic, underline.

Syntax

[C#/C++]
public long FontStyle;

[VB.NET]
Public Property FontStyle As Long

Remarks

Bits 0-2 determine the font style. Set the bits to enable a particular style:

Bit 0 | Bold
Bit 1 | Italic
Bit 2 | Underlined

See Also


InsertTextBoxParams::Height

BB FlashBack SDK: InsertTextBoxParams

Height

Description

Gets and sets the height of the text box in pixels.

Syntax

[C#/C++]
public Long Height;

[VB.NET]
Public Property Height As Long

See Also

InsertTextBoxParams::Width


InsertTextBoxParams::Opacity

BB FlashBack SDK: InsertTextBoxParams

Opacity

Description

Gets and sets the opacity of the text box.

Syntax

[C#/C++]
public long Opacity;

[VB.NET]
Public Property Opacity As Long

Remarks

The maximum value of 255 produces complete opacity. The minimum value of 0 produces a completely translucent text box that is effectively invisible.


InsertTextBoxParams::Text

BB FlashBack SDK: InsertTextBoxParams

Text

Description

A string containing the text to be drawn in the text box.

Syntax

[C#/C++]
public String Text;

[VB.NET]
Public Property Text As String

See Also


InsertTextBoxParams::TextColor

BB FlashBack SDK: InsertTextBoxParams

TextColor

Description

Returns and sets the color of the text drawn in the text box.

Syntax

[C#/C++]
public long TextColor

[VB.NET]
Public Property TextColor As Long

Remarks

Colors are specified in a long as a Win32 COLORREF value, which can be created by an RGB macro - see Win32 Platform SDK documentation.

See Also

InsertTextBoxParams::Text InsertTextBoxParams::BackgroundColor InsertTextBoxParams::FontName InsertTextBoxParams::FontSize InsertTextBoxParams::FontStyle


InsertTextBoxParams::TextTime

BB FlashBack SDK: InsertTextBoxParams

TextTime

Description

Returns or sets the number of milliseconds the text box is displayed for during movie playback.

Syntax

[C#/C++]
public long TextTime;

[VB.NET]
Public Property TextTime As Long


InsertTextBoxParams::Width

BB FlashBack SDK: InsertTextBoxParams

Width

Description

Returns and sets the width, in pixels, of the text box.

Syntax

[C#/C++]
public long Width;

[VB.NET]
Public Property Width As Long

See Also

InsertTextBoxParams::Height


FBInsertTextBoxParams::X

BB FlashBack SDK: InsertTextBoxParams

X

Description

Gets and sets the X position, in pixels, of the left hand edge of the text box.

Syntax

[C#/C++]
public long X

[VB.NET]
Public Property X As Long

See also

InsertTextBoxParams::Y


FBInsertTextBoxParams::Y

BB FlashBack SDK: InsertTextBoxParams

Y

Description

Gets and sets the Y position, in pixels, of the top edge of the text box.

Syntax

[C#/C++]
public long Y

[VB.NET]
Public Property Y As Long

See also

InsertTextBoxParams::X


The FBSoundClip Class

Each movie can contain multiple sound 'tracks'. An FBSoundProperties object represents a single sound track, which can contain a number of non-overlapping FBSoundClip objects.

Each FBSoundClip object is a portion of sound of which the volume can be changed independently.

Sound clips are created by a call to FBEditor::InsertSound.

If FBEditor::InsertFrames is called with the UpdateSounds property set to True, and the insert point is inside a clip, affected clips will be split into two clips separated by silence equal to the inserted frames.

Use the FBSoundProperties::GetSoundClipProperties method to retrieve sound clips from the FBSoundProperties object.

See How the sound classes work for more information on the sound classes.

Properties


End

BB FlashBack SDK: FBSoundClip

End

Description

Returns or sets the number of the frame in which the sound stops playing.

Syntax

[C#/C++]
public Long End;

[VB.NET]
Public Property End As Integer


FBSoundClip::Mute

BB FlashBack SDK: FBSoundClip

Mute

Description

Set this property to True to mute the sound.

Syntax

[C#/C++]
public Bool Mute;

[VB.NET]
Public Property Mute As Boolean


FBSoundClip::Start

BB FlashBack SDK: FBSoundClip

Start

Description

Returns or sets the number of the frame in which the sound starts playing.

Syntax

[C#/C++]
public Long Start;

[VB.NET]
Public Property Start As Integer


FBSoundClip::Volume

BB FlashBack SDK: FBSoundClip

Volume

Description

This property determines the volume of the sound relative to other sounds in the movie. Set it to zero to effectively mute the sound, or 100 to have it playing at its maximum volume.

Syntax

[C#/C++]
public Long Volume;

[VB.NET]
Public Property Volume As Long


The FBZoomPanProperties Class

A movie can contain a number of ZoomPan objects, where the movie 'zooms in' to a specified area. The FBZoomPanProperties class contains the properties of a ZoomPan object.

Each ZoomPan object has a duration - the length of time the movie is zoomed into that area - and FadeIn, FadeOut times. The FadeIn and FadeOut specify the length of time taken to zoom into the area.

Properties

CurveType
Frame
Height
ID
OriginX
OriginY
Width
Transition

Methods

GetCurveValue
SetCurveValue


CurveType

BB FlashBack SDK: FBZoomPanProperties

CurveType

Description

Sets and gets the acceleration/deceleration curve of the ZoomPan transition.

Syntax

[C#/C++]
public long CurveType

[VB.NET]
Public Property CurveType As Long

Remarks

The 'acceleration' and 'deceleration' for each ZoomPan transition can be adjusted.

The value of CurveType determines the acceleration/deceleration curve for the transition:

0 = Custom curve, set by calls to FBZoomPanProperties::SetCurveValue

1 = Linear speed

2 = gradual start and finish

3 = more gradual start and finish

4 = more gradual start, faster finish

See Also


FBZoomPanProperties::Frame

BB FlashBack SDK: FBZoomPanProperties

Frame

Description

Returns the frame number in which the ZoomPan object is first displayed. Read-only.

Syntax

[C#/C++]
public long Frame

[VB.NET]
Public Property Frame As Long


FBZoomPanProperties::Height

BB FlashBack SDK: FBZoomPanProperties

Height

Description

Gets and sets the height of the ZoomPan object area - the area that the movie will zoom into.

Syntax

[C#/C++]
public Long Height;

[VB.NET]
Public Property Height As Integer

See Also

FBZoomPanProperties::Width


FBZoomPanProperties::ID

BB FlashBack SDK: FBZoomPanProperties

ID

Description

Returns the ID of the ZoomPan object.

Syntax

[C#/C++]
public Long ID;

[VB.NET]
Public Property ID As Long


FBZoomPanProperties::OriginX

BB FlashBack SDK: FBZoomPanProperties

OriginX

Description

Gets and sets the X position, in pixels, of the left hand edge of the ZoomPan rectangle - the area the movie will zoom into.

Syntax

[C#/C++]
public long OriginX

[VB.NET]
Public Property OriginX As Long

See also

FBZoomPanProperties::OriginY


FBZoomPanProperties::OriginY

BB FlashBack SDK: FBZoomPanProperties

OriginY

Description

Gets and sets the Y position, in pixels, of the top edge of the ZoomPan rectangle - the area the movie will zoom into.

Syntax

[C#/C++]
public long OriginY;

[VB.NET]
Public Property OriginY As Long

See also

FBZoomPanProperties::OriginX


FBZoomPanProperties::Width

BB FlashBack SDK: FBZoomPanProperties

Width

Description

Returns and sets the width, in pixels, of the ZoomPan object area - the area the movie will zoom into.

Syntax

[C#/C++]
public long Width;

[VB.NET]
Public Property Width As Long

See Also

FBZoomPanProperties::Height


Transition

BB FlashBack SDK: FBZoomPanProperties

Transition

Description

Returns and sets the time taken, in milliseconds, for the view to change to that specified by this ZoomPan object.

Smaller values mean a faster zoom action.

The 'acceleration' and 'deceleration' of the transition can be set using the CurveType property.

Syntax

[C#/C++]
public long Transition;

[VB.NET]
Public Property Transition As Integer


GetCurveValue

BB FlashBack SDK: FBZoomPanProperties

GetCurveValue

Description

Gets a value for a point in the ZoomPan transition curve.

Syntax

[C#/C++]
public long GetCurveValue (long Index);

[VB.NET]
Public Function GetCurveValue (ByVal Index As Integer) As Integer

Parameters

Index (in) : the index of the required value on the transition curve. There are a maximum of 20 points on the curve, so this index must be between 0 and 19.

Return value

The value of the point selected by the Index parameter. This value will range from 0 to 255.

Remarks

Acceleration and deceleration for a ZoomPan transition are defined by a curve described by a set of values and indexes.

Pre-defined curves can be selected by the CurveType property. If CurveType is set to zero, a custom curve can be defined by calls to SetCurveValue.

See Also


SetCurveValue

BB FlashBack SDK: FBZoomPanProperties

SetCurveValue

Description

Sets a value for a point in the ZoomPan transition curve.

Syntax

[C#/C++]
public void SetCurveValue (long Index, long Value);

[VB.NET]
Public Sub SetCurveValue (ByVal Index As Integer, ByVal Value As Integer)

Parameters

Index (in) : the index of the required value on the transition curve. There are a maximum of 20 points on the curve, so this index must be between 0 and 19.

Value (in) : the value that the selected point should be set to. Minimum value = 0, maximum = 255. The value for point i+1 on the curve must be larger than or equal to the value for point i.

Remarks

Acceleration and deceleration for a ZoomPan transition are defined by a curve described by a set of values and indexes.

Pre-defined curves can be selected by the CurveType property. If CurveType is set to zero, a custom curve can be defined by calls to SetCurveValue.

See Also


The FBZoomPanObjects Class

A collection of all ZoomPan objects in the movie, returned from FBEditor::GetZoomPanObjects.

The properties of individual ZoomPan objects can be get and set using the GetProperties and SetProperties methods.

When exporting to SWF, each frame affected by a ZoomPan object contains Actionscript that defines the size and position of the displayed movie area. See ZoomPan variables in SWF exports for details.

Properties

Count

Methods

Delete
Edit
GetProperties
SetProperties


FBZoomPanObjects::Count

BB FlashBack SDK: FBZoomPanObjects

Count

Description

Returns the number of ZoomPan objects in the collection.

Syntax

[C#/C++]
public Long Count

[VB.NET]
Public Property Count As Long


FBZoomPanObjects::Delete

BB FlashBack SDK: FBZoomPanObjects

Delete

Description

Deletes a ZoomPan object from the collection.

Syntax

[C#/C++]
public Bool Delete (long lIndex)

[VB.NET]
Public Function Delete (ByVal lIndex As Long) As Boolean

Parameters

lIndex : index of the object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.


Edit

BB FlashBack SDK: FBZoomPanObjects

Edit

Description

Displays an edit dialog to enable editing of a specified ZoomPan object.

Syntax

[C#/C++]
public Bool Edit (long index)

[VB.NET]
Public Function Edit (ByVal index As Integer) As Boolean

Parameters

index (in) : index of the ZoomPan object to edit.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

The dialog enables editing of all properties of the ZoomPan object: size, position, duration, Fade in/out.


FBZoomPanObjects::GetProperties

BB FlashBack SDK: FBZoomPanObjects

GetProperties

Description

Retrieves in the properties of a ZoomPan instance into a FBZoomPanProperties object.

Syntax

[C#/C++]
public Bool GetProperties (long lIndex, FBZoomPanProperties* pProperties);

[VB.NET]
Public Function GetProperties (ByVal lIndex As Long, ByRef pProperties As FBZoomPanProperties) As Boolean

Parameters

lIndex : [In] Index of a ZoomPan instance in the collection.

pProperties : [In] Pointer to a FBZoomPanProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

The caller should create the FBZoomPanProperties object before passing its pointer in. After changing the properties of the object, the changes can be committed back to the in-movie ZoomPan object by using FBZoomPanObjects::SetProperties.

See Also


FBZoomPanObjects::SetProperties

BB FlashBack SDK: FBZoomPanObjects

SetProperties

Description

Sets the properties of the specified ZoomPan object to those in the supplied FBZoomPanProperties object.

Syntax

[C#/C++]
public Bool SetProperties (long lIndex, FBZoomPanProperties* pProperties);

[VB.NET]
Public Function SetProperties (ByVal lIndex As Long, ByRef pProperties As FBZoomPanProperties) As Boolean

Parameters

lIndex : [In] Index of a sound.

pProperties : [In] Pointer to an FBZoomPanProperties object.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also


The WebCamProperties Class

BB FlashBack SDK: In-movie Presentation Classes

The WebCamProperties Class

Use this class to adjust the image quality of video recorded from a webcam.

Use FBRecorder::TestWebCam to display webcam output in a window, and FBRecorder::GetWebCamProperties to get a WebCamProperties object, then change its properties in response to user input as they adjust image quality for the desired results.

Properties


Brightness

BB FlashBack SDK: WebCamProperties

Brightness

Description

Returns and sets the brightness of video recorded from the webcam.

Syntax

[C#/C++]
public Long Brightness

[VB.NET]
Public Property Brightness As Long

Remarks

Takes values from 0-100, where 100 is brightest.


Contrast

BB FlashBack SDK: WebCamProperties

Contrast

Description

Returns and sets the contrast of video recorded from the webcam.

Syntax

[C#/C++]
public Long Contrast

[VB.NET]
Public Property Contrast As Long

Remarks

Takes values from 0-100, where 100 is highest contrast.


Gain

BB FlashBack SDK: WebCamProperties

Gain

Description

Returns and sets the gain setting for the webcam.

Higher gain means the webcam is more sensitive to light, and creates a brighter image, but quality will suffer at high gain settings.

Syntax

[C#/C++]
public Long Gain

[VB.NET]
Public Property Gain As Long

Remarks

Takes values from 0-100, where 100 is maximum gain and brightest image.


Gamma

BB FlashBack SDK: WebCamProperties

Gamma

Description

Returns and sets the Gamma setting for the webcam.

Higher Gamma means a brighter image. The brightness, gamma and (on some cameras) gain settings need to be adjusted for best image quality.

Syntax

[C#/C++]
public Long Gamma

[VB.NET]
Public Property Gamma As Long

Remarks

Takes values from 0-100, where 100 is maximum gamma and brightest image.


Hue

BB FlashBack SDK: WebCamProperties

Hue

Description

Returns and sets the Hue setting for the webcam.

The Hue setting determines whether the image colour will tend towards blue, red or neutral.

Syntax

[C#/C++]
public Long Hue

[VB.NET]
Public Property Hue As Long

Remarks

Takes values from 0-100, though the exact effect on image quality may vary from camera to camera.


Saturation

BB FlashBack SDK: WebCamProperties

Saturation

Description

Returns and sets the Saturation setting for the webcam.

Higher Saturation means more saturated colours. Set Saturation to its minimum to produce a monochrome image on some cameras.

Syntax

[C#/C++]
public Long Saturation

[VB.NET]
Public Property Saturation As Long

Remarks

Takes values from 0-100, where 100 is most saturated colours.


Sharpness

BB FlashBack SDK: WebCamProperties

Sharpness

Description

Returns and sets the Sharpness setting for the webcam.

Increase the Sharpness to record sharper video from the webcam. Decrease sharpness to record 'softer' images.

Syntax

[C#/C++]
public Long Sharpness

[VB.NET]
Public Property Sharpness As Long

Remarks

Takes values from 0-100, where 100 is the sharpest image.


WhiteBalance

BB FlashBack SDK: WebCamProperties

WhiteBalance

Description

Returns and sets the WhiteBalance setting for the webcam.

Use the WhiteBalance setting to adjust colours according to the lighting conditions - either outdoor, incandescent lighting, or fluorescent lighting.

Syntax

[C#/C++]
public Long WhiteBalance

[VB.NET]
Public Property WhiteBalance As Long

Remarks

Takes values from 0-100, though the effect seen will vary from camera to camera.


The FBCursorHighlightProps class

BB FlashBack SDK: FBCursorHighlightProps

The FBCursorHighlightProps Class

Use this class to set the cursor highlight properties for a movie. The cursor can be highlit by a solid circle of color that follows it in the movie, and mouse clicks highlit by red circles.

The current cursor highlight properties can be read by FBMovie::GetCursorHighlightProps, and the properties set by FBMovie::SetCursorHighlightProps.

To hide the cursor highlight, set FBCursorHighlightProps::FillHighlight and FBCursorHighlightProps::DrawBorder both to False.

NOTE: for cursor highlights to be visible, the /custom folder (and the image files inside it) in the SDK installation needs to be copied into the folder that also contains your application excecutable.

Properties


FBCursorHighlightProps::BorderColor

BB FlashBack SDK: FBCursorHighlightProps

BorderColor

Description

Returns and sets the border color for the highlight.

Syntax

[C#/C++]
public long BorderColor;

[VB.NET]
Public Property BorderColor As Integer

Remarks

Colors are specified in a long as a Win32 COLORREF value, which can be created by an RGB macro - see Win32 Platform SDK documentation.

See Also


BorderOpacity

BB FlashBack SDK: FBCursorHighlightProps

BorderOpacity

Description

Returns and sets the opacity for the border.

Syntax

[C#/C++]
public long BorderOpacity;

[VB.NET]
Public Property BorderOpacity As Integer

Remarks

Takes values from 0-255, where 0=complete transparency (effectively invisible) and 255=completely opaque.

See Also


FBCursorHighlightProps::BorderWidth

BB FlashBack SDK: FBCursorHighlightProps

BorderWidth

Description

Returns and sets the width, in pixels, of the highlight border.

Syntax

[C#/C++]
public Long BorderWidth;

[VB.NET]
Public Property BorderWidth As Integer

See Also


DrawBorder

BB FlashBack SDK: FBCursorHighlightProps

DrawBorder

Description

Set to True to draw a border around the highlight. The border width and color are determined by the BorderColor and BorderWidth parameters.

Syntax

[C#/C++]
public Bool DrawBorder;

[VB.NET]
Public Property DrawBorder As Boolean

See Also


FillColor

BB FlashBack SDK: FBCursorHighlightProps

FillColor

Description

Returns and sets the color of the highlight fill. The highlight is filled only if FillHighlight is set to true.

Syntax

[C#/C++]
public long FillColor;

[VB.NET]
Public Property FillColor As Integer

Remarks

Colors are specified in a long as a Win32 COLORREF value, which can be created by an RGB macro - see Win32 Platform SDK documentation.

See Also


FillHighlight

BB FlashBack SDK: FBCursorHighlightProps

FillHighlight

Description

Set to True to fill the highlight with a color. The fill color and opacity are determined by the FillColor and FillOpacity parameters.

Syntax

[C#/C++]
public Bool FillHighlight;

[VB.NET]
Public Property FillHighlight As Boolean

See Also


FillOpacity

BB FlashBack SDK: FBCursorHighlightProps

FillOpacity

Description

Returns and sets the opacity for the highlight fill.

Syntax

[C#/C++]
public long FillOpacity;

[VB.NET]
Public Property FillOpacity As Integer

Remarks

Takes values from 0-255, where 0=complete transparency (effectively invisible) and 255=completely opaque.

See Also


HighlightMouseClicks

BB FlashBack SDK: FBCursorHighlightProps

HighlightMouseClicks

Description

Set this to true to have mouse clicks in the movie (and exports) highlighted by animating circles.

Syntax

[C#/C++]
public Bool HighlightMouseClicks;

[VB.NET]
Public Property HighlightMouseClicks As Boolean


HighlightMouseCursor

BB FlashBack SDK: FBCursorHighlightProps

HighlightMouseCursor

Description

Set this to true to highlight the mouse cursor with a circle. The border and fill used by the circle are defined by the other properties of FBCursorHighlightProps.

Syntax

[C#/C++]
public Bool HighlightMouseCursor;

[VB.NET]
Public Property HighlightMouseCursor As Boolean


HighlightSize

BB FlashBack SDK: FBCursorHighlightProps

HighlightSize

Description

Returns and sets the diameter of the highlight circle in pixels.

Syntax

[C#/C++]
public long HighlightSize;

[VB.NET]
Public Property HighlightSize As Integer


FBBlurProperties

BB FlashBack SDK: In-movie Presentation Classes

The FBBlurProperties Class

This class enables access to the properties of a blur object displayed in the movie.

It is returned from the GetProperties and GetPropertiesByID methods of the FBBlurs class.

Properties:


Depth

BB FlashBack SDK: FBBlurProperties

Depth

Description

Returns or sets the z-order value for the blur, to determine which other presentation objects it falls in front of or behind.

Syntax

[C#/C++]
public long Depth;

[VB.NET]
Public Property Depth As Long


Duration

BB FlashBack SDK: FBBlurProperties

Duration

Description

Returns or sets the number of milliseconds the blur is displayed for during movie playback.

Syntax

[C#/C++]
public Long Duration;

[VB.NET]
Public Property Duration As Long

Remarks

When the WaitClick property is set to True, the Duration property is ignored. Movie playback pauses when the blur is displayed and continues when the user clicks the mouse in the movie area.


Frame

BB FlashBack SDK: FBBlurProperties

Frame

Description

Returns the frame number in which the blur object is first displayed. Read-only.

Syntax

[C#/C++]
public long Frame

[VB.NET]
Public Property Frame As Long


Height

BB FlashBack SDK: FBBlurProperties

Height

Description

Gets and sets the height in pixels of the blur.

Syntax

[C#/C++]
public Long Height;

[VB.NET]
Public Property Height As Integer

See Also

FBBlurProperties::Width


ID

BB FlashBack SDK: FBBlurProperties

ID

Description

Returns the ID of the blur.

Syntax

[C#/C++]
public Long ID;

[VB.NET]
Public Property ID As Long


OriginX

BB FlashBack SDK: FBBlurProperties

OriginX

Description

Gets and sets the X position, in pixels, of the left hand edge of the blur.

Syntax

[C#/C++]
public long OriginX

[VB.NET]
Public Property OriginX As Long

See also

FBBlurProperties::OriginY


OriginY

BB FlashBack SDK: FBBlurProperties

OriginY

Description

Gets and sets the position, in pixels, of the top edge of the blur.

Syntax

[C#/C++]
public long OriginY

[VB.NET]
Public Property OriginY As Long

See also

FBBlurProperties::OriginX


Radius

BB FlashBack SDK: FBBlurProperties

Radius

Description

Returns or sets the strength of the blur. Higher values set a stronger blur effect, a value of zero produces no effect.

Syntax

[C#/C++]
public long Radius

[VB.NET]
Public Property Radius As Long


ShowOptions

BB FlashBack SDK: FBBlurProperties

ShowOptions

Description

Determines the action taken on passing the FBBlurProperties object to FBEditor::InsertBlur.

Syntax

[C#/C++]
public Bool ShowOptions;

[VB.NET]
Public Property ShowOptions As Boolean

Remarks

If ShowOptions is set to True, and the FBBlurProperties object is passed to the FBEditor::InsertBlur method, a standard dialog for setting blur properties is displayed.

If ShowOptions is set to False, and the FBBlurProperties object is passed to the FBEditor::InsertBlur method, the new blur takes on the properties of the FBBlurProperties object.

See Also

FBEditor::InsertBlur


Width

BB FlashBack SDK: FBBlurProperties

Width

Description

Returns and sets the width, in pixels, of the blur.

Syntax

[C#/C++]
public long Width;

[VB.NET]
Public Property Width As Long

See Also

FBBlurProperties::Height


The FBTransitionProperties Class

This class enables access to the properties of a transition object displayed in the movie.

It is returned from the GetProperties and GetPropertiesByID methods of the FBTransitions class.

Properties:


Duration

BB FlashBack SDK: FBTransitionProperties

Duration

Description

Returns or sets the number of milliseconds the transition lasts for.

Syntax

[C#/C++]
public Long Duration;

[VB.NET]
Public Property Duration As Long


FadeType

BB FlashBack SDK: FBTransitionProperties

FadeType

Description

Determines the type of transition used. The transition occurs between the frame it is inserted at and the following frame.

Syntax

[C#/C++]
public long FadeType;

[VB.NET]
Public Property FadeType As Integer

Remarks

Values for the property:

0 = fade through white. The movie will fade the frame where the transition is inserted to white, then fade from white to the frame after the insertion point and continue playback.

1 = fade through black. As above but fading through black.

2 = cross fade. Fades between the frame where the transition is inserted to the following frame.


PauseInTheMiddle

BB FlashBack SDK: FBTransitionProperties

PauseInTheMiddle

Description

Determines the duration in milliseconds of any pause in the middle of the transition. E.g if the transition type was a fade through white, setting this property to 1000 would pause, displaying a white frame in the movie, for 1 second.

Syntax

[C#/C++]
public long PauseInTheMiddle;

[VB.NET]
Public Property PauseInTheMiddle As Integer

See Also

FBTransitionProperties::Duration


ShowOptions

BB FlashBack SDK: FBTransitionProperties

ShowOptions

Description

Determines the action taken on passing the FBTransitionProperties object to FBEditor::InsertTransition.

Syntax

[C#/C++]
public Bool ShowOptions;

[VB.NET]
Public Property ShowOptions As Boolean

Remarks

If ShowOptions is set to True, and the FBTransitionProperties object is passed to the FBEditor::InsertTransition method, a standard dialog for setting transition properties is displayed.

If ShowOptions is set to False, and the FBTransitionProperties object is passed to the FBEditor::InsertTransition method, the new transition takes on the properties of the FBTransitionProperties object.

See Also

FBEditor::InsertTransition


ZoomOutToShowEntireMovie

BB FlashBack SDK: FBTransitionProperties

ZoomOutToShowEntireMovie

Description

Determines whether to show the entire movie at the end of the transition. The setting is included for cases where the movie being transitioned from uses a zoompan effect and the one being transitioned to does not.

Syntax

[C#/C++]
public bool ZoomOutToShowEntireMovie;

[VB.NET]
Public Property ZoomOutToShowEntireMovie Type as Boolean


The FBTransitions Class

This is a collection class containing all the transition objects displayed within the particular frame or movie.

Returned from:

  • The GetTransitions method of the FBEditor class. In this case it contains all transitions displayed in the movie.

  • The GetTransitions method of the FBFrames class. In this case it contains all transitions displayed in a particular frame.

Methods

Delete
DeleteByID
EditProperties
EditPropertiesByID
GetID
GetProperties
GetPropertiesByID
IDExists
SetProperties
SetPropertiesByID

Properties


Count

BB FlashBack SDK: FBTransitions

Count

Description

Returns the number of transitions in the collection.

Syntax

[C#/C++]
public Long Count

[VB.NET]
Public Property Count As Long


Frame

BB FlashBack SDK: FBTransitions

Frame

Description

If the FBTransitions collection was returned from a call to FBFrames::GetTransitions, this property returns the number of the frame that contains the markers of this collection.

Syntax

[C#/C++]
public Long Frame

[VB.NET]
Public Property Frame As Long

Remarks

See Also

FBFrames::GetTransitions


Delete

BB FlashBack SDK: FBTransitions

Delete

Description

Deletes a transition from the collection.

Syntax

[C#/C++]
public Bool Delete (long lIndex)

[VB.NET]
Public Function Delete (ByVal lIndex As Long) As Boolean

Parameters

lIndex : index of the transition object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also

FBTransitions::DeleteByID


DeleteByID

BB FlashBack SDK: FBTransitions

DeleteByID

Description

Deletes a transition from the collection.

Syntax

[C#/C++]
public Bool DeleteByID (long lID)

[VB.NET]
Public Function DeleteByID (ByVal lID As Long) As Boolean

Parameters

lID : ID of the transition object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also

FBTransitions::Delete


EditProperties

BB FlashBack SDK: FBTransitions

EditProperties

Description

Displays a dialog that enables editing of the properties of the specified transition object.

Syntax

[C#/C++]
public Boolean EditProperties (long lIndex)

[VB.NET]
Public Function EditProperties (ByVal lIndex As Long) As Boolean

Parameters

lIndex : Index of the transition object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

See Also

EditPropertiesByID


EditPropertiesByID

BB FlashBack SDK: FBTransitions

EditPropertiesByID

Description

Displays a dialog that enables editing of the properties of the specified transition object.

Syntax

[C#/C++]
public Boolean EditPropertiesByID (long lID)

[VB.NET]
Public Function EditPropertiesByID (ByVal lID As Long) As Boolean

Parameters

lID : ID of the transition object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

See Also

EditProperties


GetID

BB FlashBack SDK: FBTransitions

GetID

Description

Returns the ID of a transition, given its index.

Syntax

[C#/C++]
public Long GetID (Long lIndex);

[VB.NET]
Public Function GetID (ByVal lIndex As Long) As Long

Parameters

lIndex : Index of a transition.

Return Values

If the index given is out of range, the return value is -1.

If the function succeeds, the return value is the ID of the transition.


GetPropertiesByID

BB FlashBack SDK: FBTransitions

GetPropertiesByID

Description

Sets the properties of a FBTransitionProperties object to those of a specified transition within the movie, given its ID.

Syntax

[C#/C++]
public Bool GetPropertiesByID (long lID, FBTransitionProperties* pProperties)

[VB.NET]
Public Function GetPropertiesByID (ByVal lID As Long, ByRef pTransitionProperties() As FBTransitionProperties) As Boolean

Parameters

lID : [In] ID of a transition.

pProperties : [In] Pointer to a FBTransitionProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

The caller should create the FBTransitionProperties object before passing its pointer in. After changing the properties of the object, the changes can be committed back to the in-movie transition object by using the SetProperties or SetPropertiesByID methods.

See Also


IDExists

BB FlashBack SDK: FBTransitions

IDExists

Description

Checks to see if the given ID corresponds to an existing transition object.

Syntax

[C#/C++]
public Bool IDExists (Long lID)

[VB.NET]
public Function IDExists (ByVal lID As Long) As Boolean

Parameters

lID : [In] ID of a transition

Return Values

If the transition exists, the return value is zero.

If the transition does not exist, the return value is non-zero.


SetProperties

BB FlashBack SDK: FBTransitions

SetProperties

Description

Sets the properties of the specified transition object to those in the supplied FBTransitionProperties object.

Syntax

[C#/C++]
public Bool SetProperties (long lIndex, FBTransitionProperties* pTransitionProperties)

[VB.NET]
Public Function SetProperties (ByVal lIndex As Long, ByRef pTransitionProperties () As FBTransitionProperties) As Boolean

Parameters

lIndex : [In] Index of a transition.

pTransitionProperties : [In] Pointer to an FBTransitionProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

See Also


SetPropertiesByID

BB FlashBack SDK: FBTransitions

SetPropertiesByID

Description

Sets the properties of the specified transition object to those in the supplied FBTransitionProperties object.

Syntax

[C#/C++]
public Bool SetPropertiesByID (long lID, FBTransitionProperties* pTransitionProperties);

[VB.NET]
Public Function SetPropertiesByID (ByVal lID As Long, ByRef pTransitionProperties () As FBTransitionProperties) As Boolean

Parameters

lID : [In] ID of a transition.

pTransitionProperties : [In] Pointer to an FBTransitionProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

See Also


The FBWatermarkProperties Class

This class enables access to the properties of a watermark object displayed in the movie.

It is returned from the GetProperties and GetPropertiesByID methods of the FBWatermarks class.

Properties:

AlphaMode
BorderColor
BorderWidth
Depth
DrawBorder
FlipHorizontal
FlipVertical
Height
KeepAspect
Name
Opacity
OriginX
OriginY
ShowOptions
TransparentColor
UseTransparentColor
Width


AlphaMode

BB FlashBack SDK: FBWatermarkProperties

AlphaMode

Description

Returns or sets a value that determines whether alpha channel information encoded into the watermark image is used.

Syntax

[C#/C++]
public long AlphaMode

[VB.NET]
Public Property AlphaMode As Long

Remarks

Possible values:

0 | No alpha channel detected in bitmap
1 | Image contains alpha channel and it is being used.
2 | Image contains alpha channel, but it is not used in display.

Setting the value to zero has the same effect as setting it to 2 - any alpha channel information present is ignored.

Setting the value to one only has an effect if the image contains an alpha channel. Of the image formats supported by the SDK, alpha channels are only supported for 24 bit PNG files.

See Also

FBWatermarkProperties::Opacity


BorderColor

BB FlashBack SDK: FBWatermarkProperties

BorderColor

Description

Returns and sets the border color for the watermark.

Syntax

[C#/C++]
public ulong BorderColor;

[VB.NET]
Public Property BorderColor As Integer

Remarks

Colors are specified in a long as a Win32 COLORREF value, which can be created by an RGB macro - see Win32 Platform SDK documentation.

See Also


BorderWidth

BB FlashBack SDK: FBWatermarkProperties

BorderWidth

Description

Returns and sets the width, in pixels, of the watermark border.

Syntax

[C#/C++]
public Long BorderWidth;

[VB.NET]
Public Property BorderWidth As Integer

See Also

FBWatermarkProperties::BorderColor


Depth

BB FlashBack SDK: FBWatermarkProperties

Depth

Description

Returns or sets the z-order value for the watermark, that determines which other presentation objects it falls in front of or behind.

Syntax

[C#/C++]
public long Depth;

[VB.NET]
Public Property Depth As Long


DrawBorder

BB FlashBack SDK: FBWatermarkProperties

DrawBorder

Description

Set to True to draw a border around the watermark. The border width and color are determined by the BorderColor and BorderWidth parameters.

Syntax

[C#/C++]
public Bool DrawBorder;

[VB.NET]
Public Property DrawBorder As Boolean

See Also


FlipHorizontal

BB FlashBack SDK: FBWatermarkProperties

FlipHorizontal

Description

Set to True to flip the watermark image horizontally.

Syntax

[C#/C++]
public Bool FlipHorizontal;

[VB.NET]
Public Property FlipHorizontal As Boolean

See Also

FBWatermarkProperties::FlipVertical


FlipVertical

BB FlashBack SDK: FBWatermarkProperties

FlipVertical

Description

Set to True to flip the watermark image vertically.

Syntax

[C#/C++]
public Bool FlipVertically;

[VB.NET]
Public Property FlipVertically As Boolean

See Also

FBWatermarkProperties::FlipHorizontal


Height

BB FlashBack SDK: FBWatermarkProperties

Height

Description

Gets and sets the height of the watermark in pixels.

Syntax

[C#/C++]
public Long Height;

[VB.NET]
Public Property Height As Long

See Also

FBWatermarkProperties::Width


KeepAspect

BB FlashBack SDK: FBWatermarkProperties

KeepAspect

Description

Gets and sets the value that determines whether the watermark retains its current aspect ratio when its height or width is altered.

Syntax

[C#/C++]
public Bool KeepAspect;

[VB.NET]
Public Property KeepAspect As Boolean

Remarks

When this is set to true, changing either of the Height or Width properties produces a corresponding change in the other property, to maintain the aspect ratio of the image.

See Also


Name

BB FlashBack SDK: FBWatermarkProperties

Name

Description

Optionally sets the filename of the image to insert when using FBEditor::InsertWatermark.

Valid formats for the file: GIF, BMP, JPG, PNG (8 or 24 bit).

Syntax

[C#/C++]
public String Name

[VB.NET]
Public Property Name As String

Remarks

When inserting a watermark into a movie by use of the FBEditor::InsertWatermark method, the caller passes in an FBWatermarkProperties object. If the ShowOptions property of this object is set to True, a standard image selection and editing dialog will be displayed, enabling a user to select the image file to be inserted. If the ShowOptions property of the object is set to False, the image file specified by the Name property will be inserted.

See Also


Opacity

BB FlashBack SDK: FBWatermarkProperties

Opacity

Description

Gets and sets the opacity of the watermark.

Syntax

[C#/C++]
public long Opacity;

[VB.NET]
Public Property Opacity As Long

Remarks

The maximum value of 255 produces complete opacity. The minimum value of 0 produces a completely translucent watermark that is effectively invisible.


OriginX

BB FlashBack SDK: FBWatermarkProperties

OriginX

Description

Gets and sets the X position, in pixels, of the left hand edge of the watermark

Syntax

[C#/C++]
public long OriginX

[VB.NET]
Public Property OriginX As Long

See also

FBWatermarkProperties::OriginY


OriginY

BB FlashBack SDK: FBWatermarkProperties

OriginY

Description

Gets and sets the Y position, in pixels, of the top edge of the watermark.

Syntax

[C#/C++]
public long OriginY

[VB.NET]
Public Property OriginY As Long

See also

FBWatermarkProperties::OriginX


ShowOptions

BB FlashBack SDK: FBWatermarkProperties

ShowOptions

Description

Determines the action taken on passing the FBWatermarkProperties object to FBEditor::InsertWatermark.

Syntax

[C#/C++]
public Bool ShowOptions;

[VB.NET]
Public Property ShowOptions As Boolean

Remarks

If ShowOptions is set to True, and the FBWatermarkProperties object is passed to the FBEditor::InsertWatermark method, a standard dialog for setting watermark properties is displayed.

If ShowOptions is set to False, and the FBWatermarkProperties object is passed to the FBEditor::InsertWatermark method, the new watermark takes on the properties of the FBWatermarkProperties object.

See Also

FBEditor::InsertWatermark


TransparentColor

BB FlashBack SDK: FBWatermarkProperties

TransparentColor

Description

Returns and sets the transparent color in the watermark image.

Syntax

[C#/C++]
public ulong TransparentColor

[VB.NET]
Public Property TransparentColor As Long

Remarks

When UseTransparentColor is set to True, all pixels of the specified color become completely transparent.

Colors are specified in a long as a Win32 COLORREF value, which can be created by an RGB macro - see Win32 Platform SDK documentation.

See Also

FBWatermarkProperties::UseTransparentColor


UseTransparentColor

BB FlashBack SDK: FBWatermarkProperties

UseTransparentColor

Description

This property determines whether the color set in the TransparentColor property is made transparent. When UseTransparentColor is set to True, all pixels of the specified color become completely transparent.

Syntax

[C#/C++]
public Boolean UseTransparentColor

[VB.NET]
Public Property UseTransparentColor As Boolean

Remarks

See Also

FBWatermarkProperties::TransparentColor


Width

BB FlashBack SDK: FBWatermarkProperties

Width

Description

This property gets and sets the width, in pixels, of the watermark bitmap.

Syntax

[C#/C++]
public Long Width

[VB.NET]
Public Property Width As Long

Remarks

If the KeepAspect property is set to True, the Height property will be changed accordingly, to maintain the aspect ratio of the bitmap.

See Also


The FBWatermarks Class

This is a collection class containing all the watermark objects displayed within the particular frame or movie.

Returned from:

  • The GetWatermarks method of the FBEditor class. In this case it contains all watermarks displayed in the movie.

Methods

Delete
DeleteByID
EditProperties
EditPropertiesByID
GetID
GetProperties
GetPropertiesByID
IDExists
SetProperties
SetPropertiesByID

Properties


Count

BB FlashBack SDK: FBWatermarks

Count

Description

Returns the number of watermarks in the collection.

Syntax

[C#/C++]
public Long Count

[VB.NET]
Public Property Count As Long


Delete

BB FlashBack SDK: FBWatermarks

Delete

Description

Deletes a watermark from the collection.

Syntax

[C#/C++]
public Bool Delete (long lIndex)

[VB.NET]
Public Function Delete (ByVal lIndex As Long) As Boolean

Parameters

lIndex : index of the watermark object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also

FBWatermarks::DeleteByID


DeleteByID

BB FlashBack SDK: FBWatermarks

DeleteByID

Description

Deletes a watermark from the collection.

Syntax

[C#/C++]
public Bool DeleteByID (long lID)

[VB.NET]
Public Function DeleteByID (ByVal lID As Long) As Boolean

Parameters

lID : ID of the watermark object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also

FBWatermarks::Delete


EditProperties

BB FlashBack SDK: FBWatermarks

EditProperties

Description

Displays a dialog that enables editing of the properties of the specified watermark object.

Syntax

[C#/C++]
public Boolean EditProperties (long lIndex)

[VB.NET]
Public Function EditProperties (ByVal lIndex As Long) As Boolean

Parameters

lIndex : Index of the watermark object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

See Also

EditPropertiesByID


EditPropertiesByID

BB FlashBack SDK: FBWatermarks

EditPropertiesByID

Description

Displays a dialog that enables editing of the properties of the specified watermark object.

Syntax

[C#/C++]
public Boolean EditPropertiesByID (long lID)

[VB.NET]
Public Function EditPropertiesByID (ByVal lID As Long) As Boolean

Parameters

lID : ID of the watermark object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

See Also

EditProperties


GetID

BB FlashBack SDK: FBWatermarks

GetID

Description

Returns the ID of a watermark given its index.

Syntax

[C#/C++]
public Long GetID (Long lIndex);

[VB.NET]
Public Function GetID (ByVal lIndex As Long) As Long

Parameters

lIndex : Index of a watermark.

Return Values

If the index given is out of range, the return value is -1.

If the function succeeds, the return value is the ID of the watermark.


GetProperties

BB FlashBack SDK: FBWatermarks

GetProperties

Description

Sets the properties of a FBWatermarkProperties object to those of a specified watermark within the movie, given its index.

Syntax

[C#/C++]
public Bool GetProperties (long lIndex, FBWatermarkProperties* pProperties)

[VB.NET]
Public Function GetProperties (ByVal lIndex As Long, ByRef pWatermarkProperties() As FBWatermarkProperties) As Boolean

Parameters

lIndex : [In] Index of a watermark.

pProperties : [In] Pointer to a FBWatermarkProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

The caller should create the FBWatermarkProperties object before passing its pointer in. After changing the properties of the object, the changes can be committed back to the in-movie watermark by using the SetProperties or SetPropertiesByID methods.

See Also


GetPropertiesByID

BB FlashBack SDK: FBWatermarks

GetPropertiesByID

Description

Sets the properties of a FBWatermarkProperties object to those of a specified watermark within the movie, given its ID.

Syntax

[C#/C++]
public Bool GetPropertiesByID (long lID, FBWatermarkProperties* pProperties)

[VB.NET]
Public Function GetPropertiesByID (ByVal lID As Long, ByRef pWatermarkProperties() As FBWatermarkProperties) As Boolean

Parameters

lID : [In] ID of a watermark.

pProperties : [In] Pointer to a FBWatermarkProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

The caller should create the FBWatermarkProperties object before passing its pointer in. After changing the properties of the object, the changes can be committed back to the in-movie watermark object by using the SetProperties or SetPropertiesByID methods.

See Also


IDExists

BB FlashBack SDK: FBWatermarks

IDExists

Description

Checks to see if the given ID corresponds to an existing watermark object.

Syntax

[C#/C++]
public Bool IDExists (Long lID)

[VB.NET]
public Function IDExists (ByVal lID As Long) As Boolean

Parameters

lID : [In] ID of a watermark

Return Values

If the watermark exists, the return value is zero.

If the watermark does not exist, the return value is non-zero.


SetProperties

BB FlashBack SDK: FBWatermarks

SetProperties

Description

Sets the properties of the specified watermark object to those in the supplied FBWatermarkProperties object.

Syntax

[C#/C++]
public Bool SetProperties (long lIndex, FBWatermarkProperties* pWatermarkProperties)

[VB.NET]
Public Function SetProperties (ByVal lIndex As Long, ByRef pWatermarkProperties () As FBWatermarkProperties) As Boolean

Parameters

lIndex : [In] Index of a watermark.

pWatermarkProperties : [In] Pointer to an FBWatermarkProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

See Also


SetPropertiesByID

BB FlashBack SDK: FBWatermarks

SetPropertiesByID

Description

Sets the properties of the specified watermark object to those in the supplied FBWatermarkProperties object.

Syntax

[C#/C++]
public Bool SetPropertiesByID (long lID, FBWatermarkProperties* pWatermarkProperties);

[VB.NET]
Public Function SetPropertiesByID (ByVal lID As Long, ByRef pWatermarkProperties () As FBWatermarkProperties) As Boolean

Parameters

lID : [In] ID of a watermark.

pWatermarkProperties : [In] Pointer to an FBWatermarkProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

See Also


The FBHighlights Class

BB FlashBack SDK: FBHighlights

The FBHighlights Class

This is a collection class containing all the highlight objects displayed within the particular frame or movie.

Returned from:

  • The GetHighlights method of the FBEditor class. In this case it contains all highlights displayed in the movie.

  • The GetHighlights method of the FBFrames class. In this case it contains all highlights in a particular frame.

Methods

Delete
DeleteByID
EditProperties
EditPropertiesByID
GetID
GetProperties
GetPropertiesByID
IDExists
SetProperties
SetPropertiesByID

Properties


Count

BB FlashBack SDK: FBHighlights

Count

Description

Returns the number of highlights in the collection.

Syntax

[C#/C++]
public Long Count

[VB.NET]
Public Property Count As Long


Frame

BB FlashBack SDK: FBHighlights

Frame

Description

If the FBHighlights collection was returned from a call to FBFrames::GetHighlights this property returns the number of the frame that contains the markers of this collection.

Syntax

[C#/C++]
public Long Frame

[VB.NET]
Public Property Frame As Long

Remarks

See Also

FBFrames::GetHighlights


Delete

BB FlashBack SDK: FBHighlights

Delete

Description

Deletes a highlight from the collection.

Syntax

[C#/C++]
public Bool Delete (long lIndex)

[VB.NET]
Public Function Delete (ByVal lIndex As Long) As Boolean

Parameters

lIndex : index of the highlight object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also

FBHighlights::DeleteByID


DeleteByID

BB FlashBack SDK: FBHighlights

DeleteByID

Description

Deletes a highlight from the collection.

Syntax

[C#/C++]
public Bool DeleteByID (long lID)

[VB.NET]
Public Function DeleteByID (ByVal lID As Long) As Boolean

Parameters

lID : ID of the highlight object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also

FBHighlights::Delete


EditProperties

BB FlashBack SDK: FBHighlights

EditProperties

Description

Displays a dialog that enables editing of the properties of the specified highlight object.

Syntax

[C#/C++]
public Boolean EditProperties (long lIndex)

[VB.NET]
Public Function EditProperties (ByVal lIndex As Long) As Boolean

Parameters

lIndex : Index of the highlight object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

See Also

FBHighlights::EditPropertiesByID


EditPropertiesByID

BB FlashBack SDK: FBHighlights

EditPropertiesByID

Description

Displays a dialog that enables editing of the properties of the specified highlight object.

Syntax

[C#/C++]
public Boolean EditPropertiesByID (long lID)

[VB.NET]
Public Function EditPropertiesByID (ByVal lID As Long) As Boolean

Parameters

lID : ID of the highlight object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

See Also

FBHighlights::EditProperties


GetID

BB FlashBack SDK: FBHighlights

GetID

Description

Returns the ID of a highlight given its index.

Syntax

[C#/C++]
public Long GetID (Long lIndex);

[VB.NET]
Public Function GetID (ByVal lIndex As Long) As Long

Parameters

lIndex : Index of a highlight.

Return Values

If the index given is out of range, the return value is -1.

If the function succeeds, the return value is the ID of the highlight.


GetProperties

BB FlashBack SDK: FBHighlights

GetProperties

Description

Sets the properties of a FBHighlightProperties object to those of a specified highlight within the movie, given its index.

Syntax

[C#/C++]
public Bool GetProperties (long lIndex, FBHighlightProperties* pProperties)

[VB.NET]
Public Function GetProperties (ByVal lIndex As Long, ByRef pHighlightProperties() As FBHighlightProperties) As Boolean

Parameters

lIndex : [In] Index of a highlight.

pProperties : [In] Pointer to a FBHighlightProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

The caller should create the FBHighlightProperties object before passing its pointer in. After changing the properties of the object, the changes can be committed back to the in-movie highlight by using the SetProperties or SetPropertiesByID methods.

See Also


GetPropertiesByID

BB FlashBack SDK: FBHighlights

GetPropertiesByID

Description

Sets the properties of a FBHighlightProperties object to those of a specified highlight within the movie, given its ID.

Syntax

[C#/C++]
public Bool GetPropertiesByID (long lID, FBHighlightProperties* pProperties)

[VB.NET]
Public Function GetPropertiesByID (ByVal lID As Long, ByRef pHighlightProperties() As FBHighlightProperties) As Boolean

Parameters

lID : [In] ID of a highlight.

pProperties : [In] Pointer to a FBHighlightProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

The caller should create the FBHighlightProperties object before passing its pointer in. After changing the properties of the object, the changes can be committed back to the in-movie highlight object by using the SetProperties or SetPropertiesByID methods.

See Also


IDExists

BB FlashBack SDK: FBHighlights

IDExists

Description

Checks to see if the given ID corresponds to an existing highlight object.

Syntax

[C#/C++]
public Bool IDExists (Long lID)

[VB.NET]
public Function IDExists (ByVal lID As Long) As Boolean

Parameters

lID : [In] ID of a highlight

Return Values

If the highlight exists, the return value is zero.

If the highlight does not exist, the return value is non-zero.


SetProperties

BB FlashBack SDK: FBHighlights

SetProperties

Description

Sets the properties of the specified highlight object to those in the supplied FBHighlightProperties object.

Syntax

[C#/C++]
public Bool SetProperties (long lIndex, FBHighlightProperties* pHighlightProperties)

[VB.NET]
Public Function SetProperties (ByVal lIndex As Long, ByRef pHighlightProperties () As FBHighlightProperties) As Boolean

Parameters

lIndex : [In] Index of a highlight.

pHighlightProperties : [In] Pointer to an FBHighlightProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

See Also


SetPropertiesByID

BB FlashBack SDK: FBHighlights

SetPropertiesByID

Description

Sets the properties of the specified highlight object to those in the supplied FBHighlightProperties object.

Syntax

[C#/C++]
public Bool SetPropertiesByID (long lID, FBHighlightProperties* pHighlightProperties);

[VB.NET]
Public Function SetPropertiesByID (ByVal lID As Long, ByRef pHighlightProperties () As FBHighlightProperties) As Boolean

Parameters

lID : [In] ID of a highlight.

pHighlightProperties : [In] Pointer to an FBHighlightProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

Remarks

See Also


The FBHighlightProperties Class

This class enables access to the properties of a highlight object displayed in the movie.

It is returned from the GetProperties and GetPropertiesByID methods of the FBHighlights class.

Properties:

BorderColor
BorderWidth
Color
Depth
DrawBorder
Duration
FadeIn
FadeOut
Frame
Height
Inverse
NoPausedGraphic
OriginX
OriginY
Opacity
PauseId
Solid
Type
WaitClick
Width


BorderColor

BB FlashBack SDK: FBHighlightProperties

BorderColor

Description

Returns and sets the border color for the highlight.

Syntax

[C#/C++]
public ulong BorderColor;

[VB.NET]
Public Property BorderColor As Integer

Remarks

Colors are specified in a long as a Win32 COLORREF value, which can be created by an RGB macro - see Win32 Platform SDK documentation.

See Also


BorderWidth

BB FlashBack SDK: FBHighlightProperties

BorderWidth

Description

Returns and sets the width, in pixels, of the highlight border.

Syntax

[C#/C++]
public Long BorderWidth;

[VB.NET]
Public Property BorderWidth As Integer

See Also

FBHighlightProperties::BorderColor


Color

BB FlashBack SDK: FBHighlightProperties

Color

Description

Determines the color of the highlight fill. Used only when the Solid property is set to true

Syntax

[C#/C++]
public Bool Solid

[VB.NET]
Public Property Solid As Boolean

Remarks

Colors are specified in a long as a Win32 COLORREF value, which can be created by an RGB macro - see Win32 Platform SDK documentation.

See Also


Depth

BB FlashBack SDK: FBHighlightProperties

Depth

Description

Returns or sets the z-order value for the highlight that determines which other presentation objects it falls in front of or behind.

Syntax

[C#/C++]
public long Depth;

[VB.NET]
Public Property Depth As Long


DrawBorder

BB FlashBack SDK: FBHighlightProperties

DrawBorder

Description

Set to True to draw a border around the highlight The border width and color are determined by the BorderColor and BorderWidth parameters.

Syntax

[C#/C++]
public Bool DrawBorder;

[VB.NET]
Public Property DrawBorder As Boolean

See Also


Duration

BB FlashBack SDK: FBHighlightProperties

Duration

Description

Returns or sets the number of milliseconds the highlight is displayed for during movie playback.

Syntax

[C#/C++]
public Long Duration;

[VB.NET]
Public Property Duration As Long

Remarks

When the WaitClick property is set to True, the Duration property is ignored. Movie playback pauses when the highlight is displayed and continues when the user clicks the mouse in the movie area.


FadeIn

BB FlashBack SDK: FBHighlightProperties

FadeIn

Description

Determines the length of the fade-in transition, in milliseconds. Set the property to zero to have no transition.

Syntax

[C#/C++]
public long FadeIn;

[VB.NET]
Public Property FadeIn As Long

See also

FBHighlightProperties::FadeOut


FadeOut

BB FlashBack SDK: FBHighlightProperties

FadeOut

Description

Determines the length of the fade-out transition, in milliseconds. Set the property to zero to have no transition.

Syntax

[C#/C++]
public long FadeOut;

[VB.NET]
Public Property FadeOut As Long

See also

FBHighlightProperties::FadeIn


Frame

BB FlashBack SDK: FBHighlightProperties

Frame

Description

Returns the frame number in which the highlight object is first displayed. Read-only.

Syntax

[C#/C++]
public long Frame

[VB.NET]
Public Property Frame As Long


Height

BB FlashBack SDK: FBHighlightProperties

Height

Description

Gets and sets the height of the highlight in pixels.

Syntax

[C#/C++]
public Long Height;

[VB.NET]
Public Property Height As Long

See Also

FBHighlightProperties::Width


Inverse

BB FlashBack SDK: FBHighlightProperties

Inverse

Description

Determines whether the interior or exterior of the highlight is filled. Used only when the Solid property is set to true.

Syntax

[C#/C++]
public Bool Inverse;

[VB.NET]
Public Property Inverse As Boolean


NoPausedGraphic

BB FlashBack SDK: FBHighlightProperties

NoPausedGraphic

Description

Determines whether the standard pause graphic is displayed when the highlight pauses the movie.

Syntax

[C#/C++]
public Bool NoPausedGraphic

[VB.NET]
Public Property NoPausedGraphic As Boolean

See also

FBHighlightProperties::WaitClick


OriginX

BB FlashBack SDK: FBHighlightProperties

OriginX

Description

Gets and sets the X position, in pixels, of the left hand edge of the highlight

Syntax

[C#/C++]
public long OriginX

[VB.NET]
Public Property OriginX As Long

See also

FBHighlightProperties::OriginY


OriginY

BB FlashBack SDK: FBHighlightProperties

OriginY

Description

Gets and sets the Y position, in pixels, of the top edge of the highlight

Syntax

[C#/C++]
public long OriginY

[VB.NET]
Public Property OriginY As Long

See also

FBHighlightProperties::OriginX


Opacity

BB FlashBack SDK: FBHighlightProperties

Opacity

Description

Gets and sets the opacity of the highlight.

Syntax

[C#/C++]
public long Opacity;

[VB.NET]
Public Property Opacity As Long

Remarks

The maximum value of 255 produces complete opacity. The minimum value of 0 produces a completely translucent highlight that is effectively invisible.


PauseId

BB FlashBack SDK: FBHighlightProperties

PauseId

Description

If the WaitClick property is set to True, the PauseId property contains the ID of the Pause object that implements the pause

Syntax

[C#/C++]
public Long PauseId;

[VB.NET]
Public Property PauseId As Long

See also

FBHighlightProperties::WaitClick


Solid

BB FlashBack SDK: FBHighlightProperties

Solid

Description

Determines whether the highlight object will be filled. Set to true to fill the highlight or false if it is to only have a border.

Syntax

[C#/C++]
public Bool Solid

[VB.NET]
Public Property Solid As Boolean

See Also


Type

BB FlashBack SDK: FBHighlightProperties

Type

Description

Determines the shape of highlight - either a rectangle or an ellipse.

Syntax

[C#/C++]
public long Type;

[VB.NET]
Public Property Type As Integer

Remarks

Values for the property:

1 = rectangle

2 = ellipse


WaitClick

BB FlashBack SDK: FBHighlightProperties

WaitClick

Description

Determines whether displaying this highlight causes movie playback to pause, and wait for the user to click the mouse in the movie area before continuing.

Syntax

[C#/C++]
public Bool WaitClick;

[VB.NET]
Public Property WaitClick As Boolean

Remarks

When this property is set to True, the movie pauses when the highlight is displayed, and the Duration property is ignored.

See Also

FBHighlightProperties::Duration


Width

BB FlashBack SDK: FBHighlightProperties

Width

Description

This property gets and sets the width, in pixels, of the highlight

Syntax

[C#/C++]
public Long Width

[VB.NET]
Public Property Width As Long

See Also

FBHighlightProperties::Height


About Virtual Disks and Files

Movie files saved by the FBRecorder and FBEditor classes are in the FlashBack virtual disk format. A virtual disk can contain any number of virtual files. A single physical file can contain only one virtual disk.

The virtual disk contained in a FlashBack movie file is accessed by opening it with the FBVDisk::Open method. Once the disk is opened, the virtual files contained within it are accessed by using the FBVDisk::OpenFile method. Data is read to and from the virtual file via the FBVFile::Read and FBVFile::Write methods.

Because of this system of virtual disks and files, a FlashBack movie file can contain extra files in addition to the movie. For example, BB TestAssistant saves PC configuration information to the physical .FBR file after recording a movie. This information can then be read and displayed by the movie Player.

New virtual disks cannot be created via the FBVDisk class. New disks are created by saving a movie with the FBRecorder or FBEditor classes. Movie files created by FBEditor or FBRecorder can be opened with FBVDisk, and more virtual files added.

The following virtual files are created by FBEditor and FBRecorder within a FlashBack movie file virtual disk. These files can only be opened read-only and cannot be deleted.

binary.dat
events.dat
cursors.dat
sounds\\<sound file names>
bootsector.dat
keyframes.dat
frames.dat"


The FBVDisk Class

The FBVDisk class enables opening of a FlashBack movie file and access of the virtual files it contains. It enables creation and deletion of virtual files and also

See About Virtual Disks and Files for a description of how virtual files and disks should be used.

Methods

Close
Commit
CopyExternalFileToVFile
CreateFile
DeleteFile
FileExists
GetFile
Open
OpenFile
Rollback
GetLicenceInfo
GetRuntimeLicence
SetRuntimeLicence
RegisterSDK

Properties


FBVDisk::Close

BB FlashBack SDK: FBVDisk

Close

Description

Closes the virtual disk, writing all changes made to the physical file. Subsequent calls to methods on the closed disk object will fail.

Syntax

[C#/C++]
public void Close (void);

[VB.NET]
Public Sub Close

See Also

FBVDisk::Open


Commit

BB FlashBack SDK: FBVDisk

Commit

Description

Commits to the virtual disk all changes made since it was opened or since the previous call to Commit or Rollback.

Syntax

[C#/C++]
public void Commit (void);

[VB.NET]
Public Sub Commit

See Also

FBVDisk::Rollback


CopyExternalFileToVFile

BB FlashBack SDK: FBVDisk

CopyExternalFileToVFile

Description

Copies an external file on a physical disk to a virtual file in this virtual disk. The virtual file must have been previously created with a call to FBVDisk::CreateFile.

Syntax

[C#/C++]
public long CopyExternalFileToVFile (String sExtFileName, String sVFileName);

[VB.NET]
Public Function CopyExternalFileToVFile (ByVal sExtFileName As String, ByVal sVFileName As String) As Long

Parameters

sExtFileName - filename of the external, physical file to be copied.

sVFileName - filename of the virtual file that is to receive the contents of the external file.

See Also

FBVDisk::CreateFile


CopyVFileToExternalFile

BB FlashBack SDK: FBVDisk

CopyVFileToExternalFile

Description

Copies a virtual file in this virtual disk to an external file on a physical disk.

Syntax

[C#/C++]
public void CopyVFileToExternalFile (String sVFileName, String sExtFileName, Long* lErr);

[VB.NET]
Public Sub CopyVFileToExternalFile (ByVal sVFileName As String, ByVal sExtFileName As String, ByRef lErr As Integer)

Parameters

sVFileName - filename of the virtual file that is to receive the contents of the external file.

sExtFileName - filename of the external, physical file to be copied.

lErr - pointer to an error code. 0 = success, non-zero = unsuccessful.

See Also

FBVDisk::CreateFile


CreateFile

BB FlashBack SDK: FBVDisk

CreateFile

Description

Creates a new virtual file in the virtual disk.

Syntax

[C#/C++]
public FBVFile* CreateFile (String sFileName, long lCompression)

[VB.NET]
public Function CreateFile (ByVal sFileName As String, ByVal lCompression As Long) As FBVFile

Parameters

sFileName - filename of the virtual file to create.

lCompression - the level of compression to be used for this file. 0 = minimum compression, 9=maximum compression. The higher the compression level, the smaller the movie file, but the longer it will take to decompress and access the file.

Return values

If the function succeeds, the return value is a pointer to the new FBVFile object.

If the function fails, the return value is zero.

See Also


DeleteFile

BB FlashBack SDK: FBVDisk

DeleteFile

Description

Deletes a file from the virtual disk.

Syntax

[C#/C++]
public Bool DeleteFile (String sFileName);

[VB.NET]
Public Function DeleteFile (ByVal sFileName As String) As Boolean

Parameters

sFileName - filename of the virtual file to delete.

Return values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also


FBVDisk::EnableLogging

BB FlashBack SDK: FBVDisk

EnableLogging

Description

Starts logging for this instance of FBVDisk. Its internal code will start to call event handlers on an enabled FBLogs object.

Syntax

[C#/C++]
public Bool EnableLogging

[VB.NET]
Public Property EnableLogging As Boolean

Remarks

To have the FBVDisk class produce an internal log file for troubleshooting purposes, you will first need to create an instance of FBLogs, and enable logging from that object. See Using the FBLogs class for more details.

See also

Using the FBLogs class


FBVDisk::FileExists

BB FlashBack SDK: FBVDisk

FileExists

Description

Checks to see if the given filename corresponds to an existing virtual file.

Syntax

[C#/C++]
public Bool FileExists (String sFileName)

[VB.NET]
Public Function FileExists (ByVal sFileName As String) As Boolean

Parameters

sFileName : name of the virtual file.

Return Values

If the file exists, the return value is zero.

If the file does not exist, the return value is non-zero.


GetFile

BB FlashBack SDK: FBVDisk

GetFile

Description

Returns the name of a virtual file, given its index.

Syntax

[C#/C++]
public String GetFile (long lIndex)

[VB.NET]
Public Function GetFile (ByVal lIndex As Long) As String

Parameters

lIndex : Index of a virtual file.

Return Values

If the index given is out of range, the return value is an empty string.

If the function succeeds, the return value is the name of the virtual file.


GetLicenceInfo

BB FlashBack SDK: FBVDisk

GetLicenceInfo

Description

Returns a value indicating the type and validity of the SDK licence currently in use.

Syntax

[C#/C++]
public Bool GetLicenceInfo (long* pLicenceType)

[VB.NET]
public Function GetLicenceInfo (ByRef pLicenceType() As Long) As Boolean

Parameters

pLicenceType : pointer to a long value that will be set to a value indicating the type of licence.

Return Values

If the licence is invalid, the return value is zero.

If the licence is valid, the return value non-zero.

Remarks

Possible values of pLicenceType:

0 | Basic
1 | Professional
2 | Advanced


FBVDisk::GetRuntimeLicence

BB FlashBack SDK: FBVDisk

GetRuntimeLicence

Description

Gets the 'runtime' licence key that must be passed to a call to SetRuntimeLicence on the end-user's PC, in order to fully licence applications that use the FlashBack SDK.

Syntax

[C#/C++]
public String GetRuntimeLicence (void)

[VB.NET]
Public Function GetRuntimeLicence () As String

Return value

When the function succeeds, it returns the runtime licence key string.

Remarks

In the executable delivered to end-users, the first call to FBVDisk after construction must be SetRuntimeLicence, passing in the value returned from a previous call to FBVDisk::GetRuntimeLicence on the developers PC. If this call to SetRuntimeLicence is not made, the delivered executable will not be fully licensed and subsequent calls to objects will fail.

See Also


FBVDisk::Open

BB FlashBack SDK: FBVDisk

Open

Description

Opens a virtual disk, from the physical file specified.

Syntax

[C#/C++]
public void Open (String sFileName, long lFlags, long* lResult);

[VB.NET]
Public Sub Open (ByVal sFileName As String, ByVal lFlags As Long, ByRef lResult As Long)

Parameters

sFileName : the name of the physical file to open.

lFlags : specifies the type of access to the object and whether changes to it can be rolled back and committed via calls to Rollback and Commit. Its value can be any combination of:

VDISK_FLAGS_READONLY (1) | Opened readonly. If this and the readwrite flags are specified, the disk is opened readonly.
VDISK_FLAGS_READWRITE (2) | Opened for reading and writing
VDISK_FLAGS_UNDO (4) | This flag enables the facility for rolling back changes made to the disk and files by using the FBVDisk::Rollback and FBVDisk::Commit methods.

lResult : on return from function call, this is set according to success. 0 = successful, any other value = not successful.

Remarks

The file should not be open in an FBEditor object when attempting to open it via the FBVDisk class.


FBVDisk::OpenFile

BB FlashBack SDK: FBVDisk

OpenFile

Description

Opens a virtual file.

Syntax

[C#/C++]
public FBVFile* OpenFile (String sFileName, long lFlags);

[VB.NET]
Public Function OpenFile (ByVal sFileName As String, ByVal lFlags As Long) As FBVFile

Parameters

sFileName : the name of the virtual file to open.

lFlags : specifies the type of access to the object and whether changes to it can be rolled back and committed via calls to Rollback and Commit. Its value can be either:

VDISK_FLAGS_READONLY (1) | Opened readonly. (If this and the readwrite flags are specified, the file is opened readonly.)
VDISK_FLAGS_READWRITE (2) | Opened for reading and writing

Return Values

If the function succeeds it returns zero.

If the function fails it returns 1.

See also

The FBVFile Class


RegisterSDK

BB FlashBack SDK: FBVDisk

RegisterSDK

Description

Runs SDKReg.exe, the utility installed with the SDK that is used to request a trial key and into which trial and full keys are entered to active the licence.

Syntax

[C#/C++]
public void RegisterSDK (void);

[VB.NET]
Public Sub RegisterSDK


Rollback

BB FlashBack SDK: FBVDisk

Rollback

Description

Undoes changes made to the virtual disk since it was opened or since the previous call to Commit or Rollback.

Syntax

[C#/C++]
public void Rollback (void)

[VB.NET]
Public Sub Rollback

Remarks

Only virtual disks opened with a flag value of VDISK_FLAGS_UNDO passed into FBVDisk::Open can have the facility to undo changes via the Rollback method.

See Also


FBVDisk::SetRuntimeLicence

BB FlashBack SDK: FBVDisk

SetRuntimeLicence

Description

Sets the 'runtime' licence that licences applications produced using the FlashBack SDK so they can run on end-user PCs.

Syntax

[C#/C++]
public void SetRuntimeLicence (BSTR sLicence)

[VB.NET]
Public Sub SetRuntimeLicence (ByVal sLicence As String)

Remarks

When running applications produced using the SDK on PCs that do not have the SDK installed (i.e. end-user PCs), the runtime licence must be set before any methods are called or properties accessed on an instance of FBVDisk. If the runtime licence is not set, all calls will fail.

It should be set to the runtime licence string obtained from the SDK Licensing utility or via the GetRuntimeLicence method. See Runtime licensing on end-user PCs for details.

Note for Delphi users: Delphi has a limit for string literals of 255 characters. The runtime licence exceeds this limit, so you must break the licence string into two literals. i.e. code like MyDisk.SetRuntimeLicence("abcdef..." + "lmnop...");

See Also


FBVDisk::Filename

BB FlashBack SDK: FBVDisk

Filename

Description

Returns the name of the physical file that contains the virtual disk.

Syntax

[C#/C++]
public String Filename;

[VB.NET]
Public Property Filename As String


FBVDisk::FilesCount

BB FlashBack SDK: FBVDisk

FilesCount

Description

Returns the number of files in the virtual disk.

Syntax

[C#/C++]
public Long FilesCount;

[VB.NET]
Public Property FilesCount As Long


The FBVFile Class

This class enables read and write access to a virtual file.

See About Virtual Disks and Files for a description of virtual file and disk usage.

Returned from

FBVDisk::OpenFile

Methods

Close
Read
Seek
Write

Parameters


FBVFile::Close

BB FlashBack SDK: FBVFile

Close

Description

Closes the virtual file. Subsequent calls to methods on the closed file object will fail.

Syntax

[C#/C++]
public void Close (void)

[VB.NET]
Public Sub Close

See Also

FBVDisk::OpenFile


Read

BB FlashBack SDK: FBVFile

Read

Description

Reads bytes from a virtual file.

Syntax

[C#/C++]
public long Read (unsigned char * pBuffer, long lSize)

[VB.NET]
Public Function Read (ByRef pBuffer() As Char, ByVal lSize As Long) As Long

Parameters

pBuffer - a pointer into a buffer into which the contents of the virtual file will be read. The buffer should have been already allocated by the calling code.

lSize - the maximum number of bytes to read from the virtual file.

Return values

If the function succeeds, the return value is the number of bytes actually read from the virtual file. This may be less than lSize if the end of the file has been reached before reading the requested number of bytes.

If the function fails, the return value is zero.

See Also


Seek

BB FlashBack SDK: FBVFile

Seek

Description

Repositions the file pointer in a previously opened file.

Syntax

[C#/C++]
public int64 Seek (VFILE_SEEK_BASIS vsbSeek, int64 lOffset)

[VB.NET]
Public Function Seek (ByVal vsbSeek As Long, ByVal lOffset As Int64) As Int64

Parameters

vsbSeek - specifies the starting position of the file pointer. Possible values are:

VFILE_SEEK_BEGIN | Moves the file pointer lOffset bytes from the beginning of the file.
VFILE_SEEK_CURRENT | Moves the file pointer lOffset bytes from its current position.
VFILE_SEEK_END | Moves the file pointer lOffset bytes from the end of the file.

lOffset - the number of bytes to move the file pointer.

Return values

The return value specifies the new offset of the pointer, in bytes, from the beginning of the file.

See Also


Write

BB FlashBack SDK: FBVFile

Write

Description

Writes bytes to a virtual file.

Syntax

[C#/C++]
public long Write (unsigned char * pBuffer, long lSize)

[VB.NET]
Public Function Write (ByRef pBuffer() As Char, ByVal lSize As Long) As Long

Parameters

pBuffer - a pointer containing the bytes to be written to the file.

lSize - the maximum number of bytes to write to the virtual file.

Return values

If the function succeeds, the return value is the number of bytes actually written to the virtual file.

If the function fails, the return value is 0.

See Also


Position

BB FlashBack SDK: FBVFile

Position

Description

Returns the current position of the file pointer.

Syntax

[C#/C++]
public int64 Position;

[VB.NET]
Public Property Position As Int64


FBVFile::Size

BB FlashBack SDK: FBVFile

Size

Description

Returns the size of the file in bytes.

Syntax

[C#/C++]
public int64 Size;

[VB.NET]
Public Property Size As Int64


About the FBGDIBitmap class

BB FlashBack SDK: The FBGDIBitmap Classes

The FBGDIBitmap Class

This is a helper class that .NET programmers can use with the FBFrames::DrawCursor method, which requires a device context handle.

Sample usage:

int width = 32;
int height = 32;

FBGDIBitmap gdibmp = new FBGDIBitmap();

gdibmp.Create(width, height, 32);

Bitmap bmp1 = new Bitmap(width, height, PixelFormat.Format32bppRgb);

Graphics g1 = Graphics.FromImage(bmp1);
g1.FillRectangle(new SolidBrush(Color.White), 0, 0, width, height);

Graphics gdi_g = Graphics.FromHdc((IntPtr)gdibmp.GetContext());
gdi_g.DrawImage(bmp1, 0, 0);
gdi_g.Dispose();

FBFrames frames = fbEditor.GetFrames();
frames.DrawCursor(10, 0, 0, gdibmp.GetContext());

IntPtr hdc = g1.GetHdc();

gdibmp.CopyToContext((int)hdc, 0, 0, width, height, 0, 0);

g1.ReleaseHdc(hdc);

Methods
GetContext
GetHandle
FreeResources
Create
SaveToFile
CopyToContext

Properties
Bits
Width
Height


CopyToContext

BB FlashBack SDK: The FBGDIBitmap Class

CopyToContext

Description

Copies the contents of the FBGDIBitmap class into a device context.

Syntax

[C#/C++]
public long CopyToContext (long GDIContext, long CopyToPositionX, long CopyToPositionY, long CopyWidth, long CopyHeight, long CopyFromPositionX, long CopyFromPositionY);

[VB.NET]
Public Function CopyToContext (ByVal GDIContext As Integer, ByVal CopyToPositionX As Integer, ByVal CopyToPositionY As Integer, ByVal CopyWidth As Integer, ByVal CopyHeight As Integer, ByVal CopyFromPositionX As Integer, ByVal CopyFromPositionY As Integer) As Integer

Parameters

GDIContext - handle to a device context

CopyToPositionX - the X co-ordinate of the point in the target device context into which the bitmap will be copied

CopyToPositionY - the Y co-ordinate of the point in the target device context into which the bitmap will be copied

CopyWidth - width of the rectangle to copy from the bitmap

CopyHeight - height of the rectangle to copy from the bitmap

CopyFromPositionX - the X co-ordinate in the bitmap of the top left corner of the rectangle to be copied

CopyFromPositionY - the X co-ordinate in the bitmap of the top left corner of the rectangle to be copied

Returns

Returned values are identical to those returned from the Win32 API BitBlt. CopyToContext calls this function internally.

Remarks

See About the FBGDIBitmap class for example usage.


Create

BB FlashBack SDK: The FBGDIBitmap Class

Create

Description

Creates a bitmap of the specified height, width and bit depth.

Syntax

[C#/C++]
public void Create (long Width, long Height, long Bits);

[VB.NET]
Public Sub Create ( ByVal Width As Integer, ByVal Height As Integer, ByVal Bits As Integer)

Parameters

GDIContext - handle to a device context

CopyToPositionX - the X co-ordinate of the point in the target device context into which the bitmap will be copied

CopyToPositionY - the Y co-ordinate of the point in the target device context into which the bitmap will be copied

CopyWidth - width of the rectangle to copy from the bitmap

CopyHeight - height of the rectangle to copy from the bitmap

CopyFromPositionX - the X co-ordinate in the bitmap of the top left corner of the rectangle to be copied

CopyFromPositionY - the X co-ordinate in the bitmap of the top left corner of the rectangle to be copied

Remarks

See About the FBGDIBitmap class for example usage.

Use FreeResources to free the bitmap and device context created by FBGDIBitmap::Create

See also

FBGDIBitmap::FreeResources


FreeResources

BB FlashBack SDK: The FBGDIBitmap Class

FreeResources

Description

Frees the Win32 bitmap object and device context created by the call to FBGDIBitmap::Create.

Note: not required in .NET environment. The resources will be freed by normal garbage collection.

Syntax

[C#/C++]
public void FreeResources();

[VB.NET]
Public Sub FreeResources()

See also

FBGDIBitmap::Create


GetContext

BB FlashBack SDK: The FBGDIBitmap Class

GetContext

Description

Returns the handle to the device context used by the FBGDIBitmap object

Syntax

[C#/C++]
public long GetContext();

[VB.NET]
Public Function GetContext As Integer

See also

FBGDIBitmap::GetHandle


GetHandle

BB FlashBack SDK: The FBGDIBitmap Class

GetHandle

Description

Returns the handle to the Win32 bitmap object used by the FBGDIBitmap object

Syntax

[C#/C++]
public long GetHandle();

[VB.NET]
Public Function GetHandle As Integer

See also

FBGDIBitmap::GetContext


SaveToFile

BB FlashBack SDK: The FBGDIBitmap Class

SaveToFile

Description

Saves the bitmap to a named file.

Syntax

[C#/C++]
public void SaveToFile(BSTR FileName);

[VB.NET]
Public Sub SaveToFile (ByVal FileName As String)


Bits

BB FlashBack SDK: The FBGDIBitmap Class

Bits

Description

Gets and sets the bits per pixel - the colour depth - of the bitmap.

Syntax

[C#/C++]
public Long Bits

[VB.NET]
Public Property Bits As Integer


Height

BB FlashBack SDK: The FBGDIBitmap Class

Height

Description

Gets and sets the height of the bitmap in pixels.

Syntax

[C#/C++]
public Long Height

[VB.NET]
Public Property Height As Long

See Also

FBGDIBitmap::Width


Width

BB FlashBack SDK: The FBGDIBitmap Class

Width

Description

Gets and sets the width of the bitmap in pixels.

Syntax

[C#/C++]
public Long Width

[VB.NET]
Public Property Width As Long

See Also

FBGDIBitmap::Height


SDK - GUIDs

GUIDs for classes, type libraries:

------ BB FlashBack Editor type library 1.0 (BBFlashBackEditor.dll) ------

8823DF52-5CDD-45DC-BE7D-A5E51C0716CE library BBFlashBackEditor

DF4B2E38-073C-4320-97FD-F621DFC64937 interface IFBList
33F50C58-4F9F-4A0F-A79C-33CA1CEEBED4 dispinterface IFBListEvents
3F4458D3-A8B0-4FD0-88B6-D4B3135CCA6F coclass FBList

4969BE31-B641-4D61-BD84-A8F0B1DAF54B interface IFBEditor
F5BA5D7F-C366-4096-98E0-27FAD1946683 dispinterface IFBEditorEvents
85E44C82-A172-4FDC-A857-D6B7F2BFD770 coclass FBEditor

37C17F41-EADC-4ACD-8E0B-76264C921689 interface IFBMovie
E56E05BC-7622-42B1-8B50-2A536881EDC7 dispinterface IFBMovieEvents
17A65080-8A97-4603-A886-EAA42A47A010 coclass FBMovie

D431893C-DC58-4AAB-933B-774B529AD355 interface IFBTextBoxes
88D70BEC-847D-41B9-A55A-DC7EAB653226 coclass FBTextBoxes

54B4A023-C9D8-4046-A8E5-09823319B8AB interface IFBFrames
5587C65F-553A-4039-827D-9AD7D873C901 coclass FBFrames

9314C20B-9F72-4947-AB7F-0CBDB106EE96 interface IFBFrameProperties
4150E8BB-FD5B-48CE-A93B-88FF0C9CF4AD coclass FBFrameProperties

9F4FFACA-A92F-47C4-869A-74D382AF8AB5 interface IFBBitmaps
CEDF2546-F67D-4763-B62B-C2C3508E56AC coclass FBBitmaps

F631CAF5-E469-42A7-AF35-CEBA42AB3A74 interface IFBTextBoxProperties
DB144D4A-5D21-4F91-8DE9-7358FA14A9C0 coclass FBTextBoxProperties

1AF1504D-3F44-4CF7-8829-61DF2B1BF580 interface IFBBitmapProperties
7B94F3BE-CEDC-480D-A67B-BEEF2D284EE5 coclass FBBitmapProperties

9BC8A289-33B3-4846-B2C0-F58CE168DBD4 interface IFBMarkerProperties
46487320-80B0-4246-A775-52648930F937 coclass FBMarkerProperties

D776C6B0-348C-45D1-AAAF-658DE648DB2F interface IFBMarkers
7AFCB1EA-4C1F-4392-8B82-0602C61FC3EB coclass FBMarkers

178FEBA8-362E-4242-A2CD-827F8CE31193 interface IFBSoundProperties
521F8306-6A41-4068-8AF7-6A0AF84B5973 coclass FBSoundProperties

F7E6C7FF-29B4-4637-BDDD-3710EC8BC65E interface IFBSounds
43B14C8C-D90B-4A68-9B90-F757BAAC61CD coclass FBSounds

A5D9CC79-FEAD-495C-8112-4A89B51CA9F7 interface IFBZoomPanProperties
E21239F9-70A8-43F5-B2BE-9245CCAE947B coclass FBZoomPanProperties

26ED2D46-F0F8-47CF-A1F6-41342986B44B interface IFBZoomPanObjects
2C2CCDF6-57DE-42A3-8E04-3466CA801684 coclass FBZoomPanObjects

8C884532-7DFB-4CF2-BEE7-62FEBCB7AFED interface IFBCursorHighlightProps
BCFD31F3-C01A-4CFE-8184-03A935A4EDF7 coclass FBCursorHighlightProps

78A9D5F2-0422-4579-B4DB-182868D32707 interface IFBGDIBitmap
E2858E65-ED94-421B-949E-3BAC5A3FE9F3 coclass FBGDIBitmap

2390B2AE-60F5-4F61-92D0-74C5BC626F2F typedef enum MovieSizes

AB0F622B-46A6-4D35-B08C-4BB9900E47F8 typedef enum LogTypes

0E345C9C-38EE-4C9B-BA26-9C4451340234 typedef enum WebCamVideoModes

5F41B886-B550-4055-93EE-1E5B4E82200C typedef enum SoundFormat

D9512410-80CB-4C65-A8EC-889C75218D5B interface IFBSoundClip
68C6C695-9CDD-471F-94B2-CEC866DD897C coclass FBSoundClip

16C6DC5E-8839-4AE5-8EE8-7F17C5BB8CFC interface IFBExportToFLVParams
941FDBAE-3542-4EBB-B95B-B0BE78A8D639 coclass FBExportToFLVParams

1D3E4510-161B-4957-8D95-2885BD67293C interface IFBExportToSWFParams
3D1E0083-51F6-41A9-8822-87C6E79099BE coclass FBExportToSWFParams

1DE7EB90-0C5E-4885-8093-6A03FA70AFF5 interface IFBExportToAVIParams
BA822FCD-C1F3-4D49-BD58-BFFF0CE53A63 coclass FBExportToAVIParams

7B30DF3A-73FE-432A-80DA-7BDB4FD19FF7 interface IFBExportToWMVParams
7E3298EE-140A-4E07-BB4A-A92331A05E1F coclass FBExportToWMVParams

9D06B196-9E39-4727-94A6-3D989A9D2A9E interface IFBExportToQuickTimeParams
67252491-501C-44C0-8CD2-739DEE55FDBE coclass FBExportToQuickTimeParams

42C93186-EB47-4721-8E52-0CCAB7A227E3 interface IFBExportToEXEParams

7AE6DACD-13B6-46BC-ACC7-5863158DC678 typedef enum FBFLVTypes

DD06B08D-80A8-466F-8D65-68D3DAB466B3 typedef enum FBFileFormats

9BFD777A-743B-401E-94F4-C24D25C0B7A1 typedef enum FBProgressorEventIDs

------ BB FlashBack Player type library 1.0 (BB FlashBack Player.dll) ------

62DAD5FD-46E4-43B1-B174-9DD2729405E5 library BBFlashBackPlayer

4BA9089C-DDFC-4206-B937-74484B06D305 coclass FBPlayer
EC58BAD0-5AA8-4DD1-AD48-1BE097563266 dispinterface IFBPlayer
C7E27F2B-9B3B-42E4-A283-DE0430E0ED7E dispinterface _IFBPlayerEvents
EC58BAD0-5AA8-4DD1-AD48-1BE097563266 interface IFBPlayer

------ BB FlashBack Recorder type library 1.0 (BB FlashBack Recorder.dll) ------

1F38C6CA-6D6C-4E3D-9C43-39D8BE41EE47 library BBFlashBackRecorder

A3CD4BF9-EC17-47A4-833C-50A324D6FF35 coclass FBRecorder
0B603AFC-85EA-4301-9907-E31803946539 dispinterface IFBRecorder
0B603AFC-85EA-4301-9907-E31803946539 interface IFBRecorder

57733FF6-E100-4A4B-A7D1-A85AD17ABC54 coclass InsertTextBoxParams
2B2B772F-3089-4D60-A45C-4ABC3A451EDC dispinterface IInsertTextBoxParams
2B2B772F-3089-4D60-A45C-4ABC3A451EDC interface IInsertTextBoxParams

9B8E377B-7291-491A-B611-BB3E1D5F99F0 coclass WebCamProperties
38C4BCDE-9058-43CB-8322-5E039AE6339F dispinterface IWebCamProperties
38C4BCDE-9058-43CB-8322-5E039AE6339F interface IWebCamProperties

EB5C82E5-753A-4319-B649-892311239470 dispinterface _IFBRecorderEvents

------ BB FlashBack Virtual Disk type library 1.0 (BBFlashBackVDisk.dll) ------

18BFFEBF-EAE0-4F8B-8456-11039D91F342 library BBFlashBackVDisk

C145E6A4-70EB-45BD-ABB0-47FFF4CD0D0C interface IFBVDisk
F6706093-FA4D-4794-828C-297C17B50D40 coclass FBVDisk

CD7644F8-865F-4538-97B0-AF6B4162172D interface IFBVFile
8FD8E4C0-88A8-4E92-8DCE-D825AE5E47B9 coclass FBVFile

E46D3E04-3AC8-41EA-84C9-CBAFF2376A5D typedef enum VDISK_FLAGS

8A192C87-489C-4677-9945-0BCBAF9218BA typedef enum VFILE_SEEK_BASIS

------ BB Logs type library 1.0 (BBLogs.dll) ------

B4C51199-A31A-42D7-ADEA-E7B23EB97CA4 library BBLogs

E31FAF17-7139-4213-B37D-2DDF17CD34FA interface IFBLog

2927A153-9237-4EE6-B511-79A63A2FA916 dispinterface IFBLogEvents

2AE289F8-4649-4A07-BD3A-57086BBCBA39 coclass FBLog


Password Protecting Movie Files

FlashBack movies can be password protected for playback and editing.

  • FBMovie::EditPassword and FBMovie::PlayPassword are properties used to read and set the two separate passwords.

  • FBMovie::hasPlayPassword and FBMovie::hasEditPassword are boolean properties used to check whether the movie has passwords set.

  • FBPlayer::PlayPassword is used to input a candidate 'play' password before opening the file in FBPlayer. If FBPlayer::PlayPassword is not equal to FBMovie::PlayPassword, then FBPlayer::Load() will fail and return false.

1. To make a movie playable only if the correct password is entered:

The movie must have been saved previously with FBMovie::PlayPassword = <some password> and FBMovie::EditPassword = ""

Set FBPlayer::PlayPassword to the password entered by the user. FBPlayer::Load() will fail and return false if this is not equal to the password previous saved in FBMovie::PlayPassword

2. To make a movie playable without a password and editable when the correct password is entered:

Save the movie with FBMovie::PlayPassword = "" and FBMovie::EditPassword = <some password>

Read the movie edit password via the FBMovie::EditPassword property. Check this against the password entered by the user into your application's user interface, and enable or disable editing functions in your application appropriately. Load the movie using FBEditor::Load

3. To make a movie playable with a password, and editable with a different password:

Save the movie with FBMovie::PlayPassword = <some password> and FBMovie::EditPassword = <some different password>

Load the movie with FBEditor::Load() and read the properties FBMovie::PlayPassword and FBMovie::EditPassword, comparing them with the password entered by the user into your application and enable playback and editing functions in your application as appropriate.

FlashBack movies can be password protected for both playback and editing.

  • FBMovie::EditPassword and FBMovie::PlayPassword are properties used to read and set the password.

  • FBMovie::hasPlayPassword and FBMovie::hasEditPassword are boolean properties used to check whether the movie has passwords set.

  • FBPlayer::PlayPassword and FBEditor::LoadPassword are used to input a candidate password before opening the file for playback or editing.

  • If the candidate password in FBPlayer or FBEditor matches the actual password in FBMovie, then FBPlayer or FBEditor will be able to play and/or edit the movie.

1. To set a movie to be playable if the correct password is entered, but never be editable:

Set FBMovie::PlayPassword to != "" and FBMovie::EditPassword=""

2. To set a movie to be playable without a password and editable when the correct password is entered:

Set FBMovie::PlayPassword = "" and FBMovie::EditPassword != ""

3. To set a movie to be playable with a password, and editable with a different password:

Set FBMovie::PlayPassword != "" and FBMovie::EditPassword != ""

On opening the movie, your code has to set either FBPlayer::PlayPassword or FBEditor::LoadPassword and use the Load() method on whichever object type is opening the movie.

On case #3 above, if the FBMovie::EditPassword == FBEditor::LoadPassword, then the movie is both playable and editable in FBEditor.

To remove a password from a movie, set FBMovie::PlayPassword or FBMovie::EditPassword to a zero length string.

Movie playback and editing can be restricted by setting the FBMovie::PlayPassword and FBMovie::EditPassword properties.

When FBMovie::PlayPassword is set (i.e. != "")

To load a movie by the FBEditor you should assign a movie password for the FBEditor.LoadPassword property and then call FBEditor.Load method.

To load a movie by the FBPlayer you should assign a movie password for the FBPlayer.PlayPassword property and then call FBPlayer.LoadFile method.

To check/read/change the movie password you can use the properties FBMovie.HasPlayPassword, FBMovie.PlayPassword, FBMovie.HasEditPassword and FBMovie.EditPassword.

To remove any password just assign an empty string to the appropriate property.

Both PlayPassword and EditPassword can be used by the FBPlayer and by the FBEditor. The behaviour is exactly as in the FlashBack.

The movie may have PlayPassword or EditPassword or both. PlayPassword allows to replay the movie, EditPassword allows to edit the movie.

If PlayPassword = "" but EditPassword != "" then the movie can be replayed if the EditPassword was entered incorrectly.

If PlayPassword != "" and EditPassword = "" then the movie can't be edited but it can be replayed if the correct play password was supplied to open the movie.

And if both passwords are not empty then you must supply any correct password.


Using the FBLogSys class

Using the FBLogs class

The FBLogs class enables you to write logging information to a file. The FBEditor and FBRecorder classes also write to log files via the same mechanism, so their logging messages may be mixed with your own.

To start using the class:

  1. A single instance of the class should be instantiated.

  2. The event handers LogError, LogInfo and LogWarning must be defined. There is no default definition of these handlers.

  3. The Enabled property should be set to True.

Events are sent to the event handlers from one of two sources:

  1. Internally generated via the FBEditor, FBRecorder, FBPlayer or FBVDisk class code
    Set the EnableLogging property to True for these classes to have their internal code send a stream of messages to the event handlers.

  2. From your application code
    The methods AddError, AddInfo and AddWarning can be called from your application code to send messages to the event handlers.

Your event handler code should take whatever action is required with these messages, such as writing them to a log file.

Note: calls to the event handlers are asynchronous - your code should use critical sections, semaphores or some other mechanism to ensure that writes to the log file are correctly synchronized.


FBLogSys_Enabled

BB FlashBack SDK: FBLogs

Enabled

Description

Starts and stops sending of events to event handlers.

Syntax

[C++]
public: Bool Enabled

[VB.NET]
Public Property Enabled As Boolean

See also

Using the FBLogs class


FBLogSys::AddError

BB FlashBack SDK: FBLogs

AddError

Description

Call this method to trigger the LogError event handler.

Syntax

[C#/C++]
protected virtual void AddError(BSTR message)

[VB.NET]
Protected Overridable Sub AddError(ByVal message As String)

Parameter | Description
message | Text of the error message.

Remarks

You need to define the LogError event handler in order to have the AddError method write any information to log files. There is no default definition of LogError provided.

See Also


FBLogSys::AddInfo

BB FlashBack SDK: FBLogs

AddInfo

Description

Call this method to trigger the LogInfo event handler.

Syntax

[C#/C++]
protected virtual void AddInfo(BSTR message)

[VB.NET]
Protected Overridable Sub AddInfo(ByVal message As String)

Parameter | Description
message | Text of the informational message.

Remarks

You need to define the LogInfo event handler in order to have the AddInfo method write any information to log files. There is no default definition of LogInfo provided.

See Also


AddWarning

BB FlashBack SDK: FBLogs

AddWarning

Description

Call this method to trigger the LogWarning event handler.

Syntax

[C#/C++]
protected virtual void AddWarning(BSTR message)

[VB.NET]
Protected Overridable Sub AddWarning(ByVal message As String)

Parameter | Description
message | Text of the warning message.

Remarks

You need to define the LogWarning event handler in order to have the AddInfo method write any information to log files. There is no default definition of LogInfo provided.

See Also


FBLogs::AddError

BB FlashBack SDK: FBLogs

LogError

Description

This event handler is called by the FBEditor and FBRecorder classes when they encounter an error condition. It is also called when the FBLogs::AddError method is called.

Syntax

[C#/C++]
protected virtual void LogError(BSTR message)

[VB.NET]
Protected Overridable Sub LogError(ByVal message As String)

Parameter | Description
message | Text of the error message.

Remarks

Use this event handler to write debug and error information to a log file.

Note: calls to the event handlers are asynchronous - your code should use critical sections, semaphores or some other mechanism to ensure that writes to the log file are correctly synchronized.

Setting the event handler

In the samples below, fbLogSys is an instance of FBLogs, and fbLogSys_LogError is your event handling method. See the samples that come with the SDK for more examples.

[C#]
fbLogSys.LogError += new IFBLogEvents_LogErrorEventHandler(fbLogSys_LogError);

[VB]
AddHandler fbLogSys.LogError, AddressOf fbLogSys_LogError

[Delphi]
fbLogSys.OnLogError := fbLogSys_LogError;

[C++ Builder]
fbLogSys->OnLogError = fbLogSys_LogError;

See Also


LogInfo

BB FlashBack SDK: FBLogs

LogInfo

Description

This event handler is called by the FBEditor and FBRecorder classes when they want to write informational messages to a log file. It is also called when the FBLogs::AddInfo method is called.

Syntax

[C#/C++]
protected virtual void LogInfo(BSTR message)

[VB.NET]
Protected Overridable Sub LogInfo(ByVal message As String)

Parameter | Description
message | Text of the informational message.

Remarks

Use this event handler to write debug information to a log file.

Note: calls to the event handlers are asynchronous - your code should use critical sections, semaphores or some other mechanism to ensure that writes to the log file are correctly synchronized.

Setting the event handler

In the samples below, fbLogSys is an instance of FBLogs, and fbLogSys_LogInfo is your event handling method. See the samples that come with the SDK for more examples.

[C#]
fbLogSys.LogInfo += new IFBLogEvents_LogInfoEventHandler(fbLogSys_LogInfo);

[VB]
AddHandler fbLogSys.LogInfo, AddressOf fbLogSys_LogInfo

[Delphi]
fbLogSys.OnLogInfo := fbLogSys_LogInfo;

[C++ Builder]
fbLogSys->OnLogInfo = fbLogSys_LogInfo;

See Also


LogWarning

BB FlashBack SDK: FBLogs

LogWarning

Description

This event handler is called by the FBEditor and FBRecorder classes when they want to write warning information to a log file. It is also called when the FBLogs::AddWarning method is called.

Syntax

[C#/C++]
protected virtual void LogWarning(BSTR message)

[VB.NET]
Protected Overridable Sub LogWarning(ByVal message As String)

Parameter | Description
message | Text of the warning message.

Remarks

Use this event handler to write debug information to a log file.

Note: calls to the event handlers are asynchronous - your code should use critical sections, semaphores or some other mechanism to ensure that writes to the log file are correctly synchronized.

Setting the event handler

In the samples below, fbLogSys is an instance of FBLogs, and fbLogSys_LogWarning is your event handling method. See the samples that come with the SDK for more examples.

[C#]
fbLogSys.LogWarning += new IFBLogEvents_LogWarningEventHandler(fbLogSys_LogWarning);

[VB]
AddHandler fbLogSys.LogWarning, AddressOf fbLogSys_LogWarning

[Delphi]
fbLogSys.OnLogWarning := fbLogSys_LogWarning;

[C++ Builder]
fbLogSys->OnLogWarning = fbLogSys_LogWarning;

See Also


Sample Applications

A number of sample applications, with all source code, are installed with the SDK. These show examples of usage for many of the classes described in this Help file. The files are located in the 'Samples' folder, in the SDK installation folder.

Sample code is supplied for these languages/IDEs:

  • Microsoft Visual Studio 2005 : C++, C#, VB.NET

  • Microsoft Visual Studio 2003 : C#, VB.NET

  • Microsoft Visual C++ v6

  • Borland C++ Builder v6

  • Borland Delphi v5

  • Borland Delphi v7


Checking the capture driver

BB FlashBack SDK: Samples
Checking the screen capture driver

[C#/C++]

public boolean TryToInstallDriver()
{
    //Assume we have declared the recorder object earlier
    if(this.Recorder.IsDriverInstalled())
    {
        if(!this.Recorder.IsDriverVersionOK())
        {
            return InstallDriver();
        }
        return true;
    }
    else
    {
        return InstallDriver();
    }
    return false;
}

[VB.NET]

Public Function TryToInstallDriver() As Boolean
    'Assume we have declared the recorder object earlier
    If Me.Recorder.IsDriverInstalled Then
        If Not Me.Recorder.IsDriverVersionOK Then
            Return InstallDriver
        End If
        Return True
    Else
        Return InstallDriver
    End If
    Return false;
End Function


LoadPassword

BB FlashBack SDK: FBEditor

LoadPassword

Description

Sets the password to be used when loading the movie for editing.

Syntax

[C#/C++]
public BSTR LoadPassword

[VB.NET]
Public Property LoadPassword As String

Remarks

For more information about password protecting FBR movie files, see Password Protecting Movie Files.

See Also


FBFrames::GetSounds

BB FlashBack SDK: FBFrames

GetSounds

Description

Returns, in an FBSounds object, a collection of all the sounds in the movie.

Note: This method is deprecated. Use FBEditor:GetSounds instead.

Syntax

[C#/C++]
public FBSounds* GetSounds (long lFrameNumber)

[VB.NET]
Public Function GetSounds (ByVal lFrameNumber As Long) As FBSounds

Parameters

lFrameNumber : this parameter is not used.

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is a pointer to an FBSounds collection.

Remarks

The FlashBack SDK can create a number of separate sound tracks in a movie, where each track can contain a number of non-overlapping sound 'clips'. To read more about SDK sound classes, see How the sound classes work.

See Also


GetObjectPointer

BB FlashBack SDK: FBInsertVideoFileParameters


FBMovie::ImportFLV

BB FlashBack SDK: FBMovie

ImportFLV

Description

Imports a Flash Video (FLV) movie file. The imported file will be treated in FBPlayer as webcam video.

Syntax

[C#/C++]
public Bool ImportFLV (String sFileName)

[VB.NET]
Public Function ImportFLV (ByVal sFileName As String) As Boolean

Parameters

sFileName : the name of the FLV file to be imported.

Return Values

If the function fails, the return value is zero.

If the function succeeds, the return value is non-zero.


CreatePlayerWindow

Type topic text here.


SelectWebCamFormat

BB FlashBack SDK: FBRecorder

SelectWebCamFormat

Description

Syntax

[C#/C++]
public void SelectWebCamFormat (Long index);

[VB.NET]
Public Sub SelectWebCamFormat (ByVal index As Integer)

Parameters

index -

Return values

.

See Also

FBRecorder::UseWebCam FBRecorder::WebCamKeyFrames FBRecorder::WebCamQuality FBRecorder::SelectWebCamVideoSource FBRecorder::TestWebCam FBRecorder::RecordWebCamToFile


SelectWebCamSource

BB FlashBack SDK: FBRecorder

SelectWebCamSource

Description

Syntax

[C#/C++]
public void SelectWebCamSource (BSTR source);

[VB.NET]
Public Sub SelectWebCamSource (ByVal source As String)

Parameters

source -

Return values

.

See Also

FBRecorder::UseWebCam FBRecorder::WebCamKeyFrames FBRecorder::WebCamQuality FBRecorder::SelectWebCamVideoSource FBRecorder::TestWebCam FBRecorder::RecordWebCamToFile


FBSoundProperties::Length

BB FlashBack SDK: FBSoundProperties

Length

Description

Returns the duration of the sound in milliseconds.

Syntax

[C#/C++]
public Long Length;

[VB.NET]
Public Property Length As Long


FBSoundProperties::Loop

BB FlashBack SDK: FBSoundProperties

Loop

Description

This property determines whether the sound will loop continuously or just play once.

Syntax

[C#/C++]
public Bool Loop;

[VB.NET]
Public Property Loop As Boolean


FBSoundProperties::Mute

BB FlashBack SDK: FBSoundProperties

Mute

Description

Set this property to True to mute the sound.

Syntax

[C#/C++]
public Bool Mute;

[VB.NET]
Public Property Mute As Boolean


StartFrame

BB FlashBack SDK: FBSoundProperties

StartFrame

Description

Returns the number of the frame in which the sound starts playing.

Syntax

[C#/C++]
public Long StartFrame;

[VB.NET]
Public Property StartFrame As Long


FBSoundProperties::Volume

BB FlashBack SDK: FBSoundProperties

Volume

Description

This property determines the volume of the sound relative to other sounds in the movie. Set it to zero to effectively mute the sound, or 100 to have it playing at its maximum volume.

Syntax

[C#/C++]
public Long Volume;

[VB.NET]
Public Property Volume As Long


FBSounds::EditProperties

BB FlashBack SDK: FBSounds

EditProperties

Description

Displays a dialog that enables editing of the properties of the specified sound object.

Syntax

[C#/C++]
public Bool EditProperties (long lIndex)

[VB.NET]
Public Function EditProperties (ByVal lIndex As Long) As Boolean

Parameters

lIndex : Index of the sound object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also

FBSounds::EditPropertiesByID


FBSounds::EditPropertiesByID

BB FlashBack SDK: FBSounds

EditPropertiesByID

Description

Displays a dialog that enables editing of the properties of the specified sound object.

Syntax

[C#/C++]
public Bool EditPropertiesByID (long lID)

[VB.NET]
Public Function EditPropertiesByID (ByVal lID As Long) As Boolean

Parameters

lID : ID of the sound object to delete.

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also

FBSounds::EditProperties


FBSounds::Frame

BB FlashBack SDK: FBSounds

Frame

Description

If the FBSounds collection was returned from a call to FBFrames::GetSounds, this property returns the number of the frame that the collection corresponds to.

Syntax

[C#/C++]
public Long Frame

[VB.NET]
Public Property Frame As Long

See Also

FBFrames::GetSounds


FBSounds::SetProperties

BB FlashBack SDK: FBSounds

SetProperties

Description

Sets the properties of the specified sound object to those in the supplied FBSoundProperties object.

Syntax

[C#/C++]
public Bool SetProperties (long lIndex, FBSoundProperties* pProperties);

[VB.NET]
Public Function SetProperties (ByVal lIndex As Long, ByRef pSoundProperties() As FBSoundProperties) As Boolean

Parameters

lIndex : [In] Index of a sound.

pProperties : [In] Pointer to an FBSoundProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also


FBSounds::SetPropertiesByID

BB FlashBack SDK: FBSounds

SetPropertiesByID

Description

Sets the properties of the specified sound object to those in the supplied FBSoundProperties object.

Syntax

[C#/C++]
public Bool SetPropertiesByID (long lID, FBSoundProperties* pProperties);

[VB.NET]
Public Function SetPropertiesByID (ByVal lID As Long, ByRef pSoundProperties() As FBSoundProperties) As Boolean

Parameters

lID : [In] ID of a sound.

pProperties : [In] Pointer to an FBSoundProperties object

Return Values

If the function fails, the return value is nonzero.

If the function succeeds, the return value is zero.

See Also


GetObjectPointer

BB FlashBack SDK: FBTextBoxProperties

GetObjectPointer

Description

Returns the frame number in which the text box is first displayed.

Syntax

[C#/C++]
public long Frame

[VB.NET]
Public Property Frame As Long


Duration

BB FlashBack SDK: FBZoomPanProperties

Duration

Description

Returns or sets the number of milliseconds the ZoomPan will be active for.

Syntax

[C#/C++]
public long Duration;

[VB.NET]
Public Property Duration As Integer


FadeIn

BB FlashBack SDK: FBZoomPanProperties

FadeIn

Description

Returns or sets the number of milliseconds taken to zoom into the area specified by this ZoomPan object.

Syntax

[C#/C++]
public long FadeIn;

[VB.NET]
Public Property FadeIn As Integer

See Also

FBZoomPanProperties::FadeOut


FadeOut

BB FlashBack SDK: FBZoomPanProperties

FadeOut

Description

Returns or sets the number of milliseconds taken to zoom out of the area specified by this ZoomPan object, back to the default view that shows the entire movie.

Syntax

[C#/C++]
public long FadeOut;

[VB.NET]
Public Property FadeOut As Integer

See Also

FBZoomPanProperties::FadeIn


FILL

BB FlashBack SDK: Player
IsMovieLoaded Property

Description

Returns whether a movie is currently loaded in the player.

Syntax

[C#/C++]
public Bool IsMovieLoaded

[VB.NET]
Public IsMovieLoaded As Boolean

See Also

GetMarkerText method,GotoMarkerNum method


Checking the capture driver

BB FlashBack SDK: Samples
Installing the capture driver

[C#]

public boolean TryToInstallDriver()
//declare high order word values
public const int SUCCESS_SUCCESS = 0;
public const int SUCCESS_REBOOT_NEEDED = 1;
public const int SUCCESS_NOREBOOT_NEEDED = 2;
public const int FAILURE = 3;
//declare low order word values
public const int ERROR_NOERROR = 0;
public const int ERROR_NOADMINRIGHTS = 1;
public const int ERROR_NOUNSIGNEDDRV_POLICY = 2;
public const int ERROR_UNKNOWN = 4;
public const int ERROR_EXTRACT_FILES = 8;
public const int ERROR_RUNONCE_SETUP = 16;
public const int DRIVER_INSTALLED  = 32;
public const int DRIVER_NOTINSTALLED = 64;
public const int UNINSTALL_FAILURE = 128;
public const int UNINSTALL_SUCCESS = 256;
public const int REGISTRY_ERROR = 512;
public const int COPY_FILE_ERROR = 1024;
public Install()
{
    /* Assume that we have already declared the recorder object
    driver installation function*/

    if(recoder.CanDriverBeInstalled())
    {
        int result = recorder.InstallDriver();
        int hi = (result >> 16) & &HFFFF;
        int lo = result & &HFFFF;
        if(lo = 0 | lo & DRIVER_INSTALLED > 0)
        {
            if(hi = 0)
            {
                if(recorder.IsDriverVersionOK)
                {
                    return true;
                }
                else
                {
                    //Reboot needed
                }
            }
            else
            {
                if(hi != FAILURE)
                {
                    //reboot needed
                }
            }
        }
    }
    return false;
}

[VB.NET]

'declare high order word values
Public Const SUCCESS_SUCCESS As Integer = 0
Public Const SUCCESS_REBOOT_NEEDED As Integer = 1
Public Const SUCCESS_NOREBOOT_NEEDED As Integer = 2
Public Const FAILURE As Integer = 3
'declare low order word values
Public Const ERROR_NOERROR As Integer = 0
Public Const ERROR_NOADMINRIGHTS As Integer = 1
Public Const ERROR_NOUNSIGNEDDRV_POLICY As Integer = 2
Public Const ERROR_UNKNOWN As Integer = 4
Public Const ERROR_EXTRACT_FILES As Integer = 8
Public Const ERROR_RUNONCE_SETUP As Integer = 16
Public Const DRIVER_INSTALLED As Integer = 32
Public Const DRIVER_NOTINSTALLED As Integer = 64
Public Const UNINSTALL_FAILURE As Integer = 128
Public Const UNINSTALL_SUCCESS As Integer = 256
Public Const REGISTRY_ERROR As Integer = 512
Public Const COPY_FILE_ERROR As Integer = 1024
Function InstallDriver(ByVal obj As Object)
If obj.CanDriverBeInstalled() Then

    Dim result As Integer = obj.InstallDriver()
       Dim hi As Integer = (result >> 16) And &HFFFF
      Dim lo As Integer = result And &HFFFF

    If (lo = 0) Or (lo And DRIVER_INSTALLED > 0) Then
             If hi = 0 Then

          If obj.IsDriverVersionOK() Then
                 Return True
                 Else
                 'reboot needed
                End If

             Else
                If hi  FAILURE Then
                  'reboot needed
                 End If
             End If
       End If
End If

Return False
End Function


Installing the Libraries

Library Files

The BB FlashBack SDK is comprised of the following self-contained libraries:

  • BB FlashBack Player.dll: playback module

  • BB FlashBack Recorder.dll: recording module

These libraries are redistributable along with your application. They must be registered before they can be used, both for your development and target environments.

Registration

You may use the regsvr32.exe command to register the libraries from the command line. If you are going to use an installer to register the libraries, use the self-registering DLL option available in your installer.

See Also

Visual Studio .NET, Visual Studio, Borland Delphi / C++ Builder


CompressSound

BB FlashBack SDK: Recorder
CompressSound Property

Description

Indicates whether or not the sound file produced during the recording should be compressed to the MPEG Layer 3 (mp3) audio format.

Syntax

[C++/C]
public Bool CompressSound

[VB.NET]
Public CompressSound As Boolean

See Also

SoundFormat property, RecordSound property


InsertSoundToFBRByMarker

BB FlashBack SDK: Recorder
InsertSoundToFBRByMarker Method

Description

Inserts a sound file into a .fbr file at the named marker.

Syntax

[C++]
Bool InsertSoundToFBRByMarker(LCPTSTR fbrname, LCPTSTR soundname, LCPTSTR markername)

[C#]
public Bool InsertSoundToFBRMarker(string fbrname, string soundName, string markerName, Bool result)

[VB.NET]
Public Function InsertSoundToFBRMarker(ByVal FbrName As String, ByVal SoundName As String, ByVal MarkerName As String) As Boolean

Parameters

Parameter | Description
FbrName | Required. A string value indicating the FBR file to insert the sound into.
SoundName | Required. A string value indicating the path of the sound file to insert into the FBR file.
MarkerName | Required. A string value indicating the marker at which to insert the sound into the file.
Result | Required. A boolean value indicating whether the operation was successful or not

Remarks

True if the sound file was successfully inserted into the .fbr file, otherwise false.

See Also

GotoMarker, GotoMarkerNum GetMarkerText


RecordSound

BB FlashBack SDK: Recorder
RecordSound Property

Description

Turns sound recording on or off.

Syntax

[C#/C++]
public Bool SoundRecording

[VB.NET]
Public SoundRecording As Boolean

See Also

GetMarkerText method,GotoMarkerNum method