Introduction

Introduction

 Return to chapter overview

CADViewX Lite is an ActiveX control for viewing and printing CAD files. CADViewX supports AutoCAD® DWG™/DXF™, Autodesk® DWF™, HPGL, SVG, CGM, BMP, JPEG, WMF, EMF, GIF and many other formats. Powerful print, easy mouse wheel zoom and right-mouse-button padding are very convenient. Tile feature allows you to print the image onto any quantity of paper with the scale you need. Predefined sizes for standard formats (US: A, B, C, D, E; ISO-A, DIN: A4, A3, A2, A1, A0). Any 'tile' can be printed independently of other 'tiles', so if one sheet of paper is not printed correctly, (printer problems), you can reprint it.

CADViewX Lite provides an API that helps developers to create CAD software with sophisticated capabilities. The functionality of the product can be accessed from programming languages like C++, Visual Basic, Delphi. CADViewX Lite is also .NET compatible meaning that VB.NET, C#, and J# programmers can take full advantage of the product.

CADViewX Lite comes with documentation and several sample applications with source code which demonstrate how the product can be used.

For up-to-date information on CADViewX Lite and other CADSoftTools products, please visit our website.


System Requirements

Introduction >

System Requirements

 Return to chapter overview

Operating System:

·Microsoft Windows 2000/XP/Vista/7/8/8.1/10

·Microsoft Windows Server 2000/2003/2003 R2/2008/2008 R2/2012/2012 R2

Hardware:

·CPU: 1 Ghz

·RAM: 512 MB

·Disk space: 50 MB

Note: Users working with images which contain large amounts of data or large number of images will get a benefit from configurations that exceed the hardware requirements listed above.


Changes

Changes

October, 2018: version 14.0

·Improved import of DWG and DXF files:

oadded support of annotative objects;

oimproved Insert support;

oimproved Clipping support;

oimproved Texts and MTexts support;

oimproved display of SHX fonts;

ospeeded up loading of DXF files.

·Improved export of DWG and DXF files:

oadded export to AutoCAD® DWG 2010.

·Improved export of PDF files:

oadded saving of fonts;

oadded option for saving to raster PDF files.

·Other improvements:

oimproved import of DWF, HPGL, CGM and SVG files;

oimproved export of SVG and HPGL files.

·Bug fixes.

June, 2017: version 12.0

·Import of AutoCAD® DWG 2018 file format

September, 2016: version 11.1

·Speed of DWG/DXF loading greatly increased

·Export to DWG with RGB colors

·Support of Big SHX Fonts (for Asian characters)

·Import and export of the XClipFrame variable into DWG and DXF added

·Export of the SPATIAL_FILTER object added

·Attributes export improved (Attdef/Attrib)

·Multiline text (MTEXT) import improved

·Color import in DWF improved

·DWG and DXF import and export improved

·Third-party applications EED (Entity Extended Data) of the imported drawing is retained

June, 2013: version 9.0

·Import of AutoCAD® DWG™ 2013 file format

·64-bit support

April, 2011: version 8.0

·Support of AutoCAD® DWG™ 2010 (2011-2012) file format

·High speed in loading and visualization of CAD files

·Bug fixes

February, 2009: version 7.0

New features and enhancements:

·Import of DWF files

·Import of DXF binary files

·Complex line types

·Image cutting in DWG/DXF files

·Support of the INSERT with the specified number of columns

·Optimized by memory usage: CIRCLE, ARC, ELLIPSE, SPLINE entities

·AutoCAD® WIPEOUT entity is supported

·AutoCAD® MLINE entity is supported

·AutoCAD® HELIX entity is supported

·AutoCAD® TOLERANCE entity is supported

·AutoCAD® TRACE entity is supported

·AutoCAD® SHAPE entity is supported

·Better displaying of the MTEXT, LEADER, ACAD_PROXY_ENTITY, SPLINE, LWPOLYLINE entities

·Displaying of the ACAD_TABLE entity for DWG files

·Better displaying of DWG, HPGL-2, PCL files

·Older DWG files are supported (down to version AC1002)

·Processing of TIFF files much faster

·Displaying of the POINT entity in different modes

·Displaying of the extended UNICODE for TTF fonts

·All ANSI-codepages are supported

·New snap types

·Export to DXF three-time faster

·Deep scaling much better

·AutoCAD® DWG™ 2007 file format is supported

·AutoCAD® PROXY (including AEC) entities are supported

·HPGL/HPGL2 file format - Bezier splines are supported

·DXF loading is optimized for files with big amount of blocks (layers and styles). In some cases speed is increased up to ten times

·Demos for C#, VB.NET can be executed under 32-bit systems only

·HTML demos can be executed only in 32-bit Internet Explorer or other browsers that supports ActiveX

Bugs fixed:

·Incorrect page size of HPGL files

·Incorrect displaying of texts that are rotated backward

·Incorrect print of the gradient plotting

·Incorrect rotation of a raster image in the block

·Incorrect Xref cyclic reference

New classes, functions, properties:

·New classes: Point2D, Point3D, Rect2D, Rect3D instead of the corresponding structures

·New function ShowRect

·Function DXFImage became a property

·New property UseSizeDialog

May, 2007: version 6.1

New features and enhancements:

·AutoCAD® DWG™ 2007 file format is supported

·Converting to Adobe Acrobat Document PDF file format is supported

·Converting to HPGL/2 file format was added. Multi pages and rectangle viewports are supported

·Converting to AutoCAD® DXF file format has been improved significantly

·CALS Images (*.cal) are supported

·New editing ability makes CADViewX a fully functional editor of CAD files and raster images

·New CAD entities are supported - PROXY (including AEC), TOLERANCE, TRACE and ACAD_TABLE

·HPGL/HPGL2 file format - Bezier splines are supported

·Displaying of the following entities was improved: ACAD_PROXY_ENTITY, LEADER, LWPOLYLINE, MTEXT and SPLINE (with zero Start/End-tangents)

·Displaying files of HPGL-2 and PCL formats was improved

·Displaying files of DWG format versions up to AC1009 (R12) was improved

·Support of the oldest DWG file format versions (up to AC1002) was added

·Speed of conversion to DXF file format is increased three times

·Files of TIFF format are displayed with increased speed

·Support of enhanced Unicode symbols (characters etc.) when converting to DXF format

·DXF loading was optimized for files with big amount of blocks (layers and styles). In some cases speed is increased up to ten times

·Pens for HPGL/2 files are available as a Layers list

·An enhanced ability to work with mm / inches is added. It is used:

·in printing (defining the ratio between drawing's unit and its size)

·in measuring tools (Distance, Area and Polyline length)

·New snap abilities: snapping to lines, line centers and intersection points

·Big raster images are shown better with smoothing technology

·Speed of viewing and scaling raster images is significantly increased

·Gradient filling for complicated types is implemented

·Enhanced Unicode symbols for TTF fonts are supported

·All ANSI-codepages are supported

·Loading files of supported formats from archives (*.zip, *.gz, *.tar)

·Numerous bugs are fixed

September, 2006:

New values for TxToolButton type:

tbCheckUpdates | Checks whether updates are available or not
tbAbout | Calls the About CADViewX dialog
tbProperties | Calls the File information dialog
tbFloatingLicProps | Calls the Floating License dialog

July, 2006:

New functions and properties:

·Zoom

·SaveCopyToFile

·PrintingTitle

May, 2006: version 1.5

·Viewing of HPGL files became significantly faster. Memory requirements lowered 2 to 10 times

·Support for BigFonts

·SHX support - if the given SHX fonts are not found the default SHX fonts will be used

·Support for DWG v. 9, 10 and 11

·Forward references in DWG12

·Bugs fixed for PolyFace in DWG12 and for gradient filling in HPGL

·Bugs fixed for DWG/DXF, HPGL, SVG and CGM file formats

February, 2006:

·New property: ScaleFactor


Installation

Installation

This topic describes how to install the component and how to remove it from the system.


Install/remove from the system

Installation >

Install/remove from the system

 Return to chapter overview

Installation

To install CADViewX Lite into the system and to register it in the system registry unpack cadviewxlite.exe from the cadviewx.zip and run it. The following files will be installed into default prompted folders:

·c:\Program Files (x86)\CADSoftTools\CADViewX Lite 14\CADViewLib:

·CADViewLib.ocx - this file contains the 32-bit OCX version of ActiveX control

·The set of *.lng files provides 27 languages support

·c:\Program Files (x86)\CADSoftTools\CADViewX Lite 14\Demos:

·CADinWord folder - contains files for: the Demo for Word and VB Export to Word demo projects

·Delphi folder - contains files for the Delphi demo project

·DemoC# folder - contains files for the C# demo project

·DemoJ# folder - contains files for the J# demo project

·HTML folder - contains files for: the HTML demo project and HTML Demo for CAD in the Web project

·VB folder - contains files for the VB demo project

·VB.NET folder - contains files for the VB .NET demo project

·c:\Program Files (x86)\CADSoftTools\CADViewX Lite 14\Doc:

·CADViewX Lite.chm help file

Removing

1.Open Programs and Features in the Control Panel: Click Start -> Control Panel -> Double-click Programs and Features

2.Choose CADViewX Lite 12

3.Click Uninstall


Install/remove from Visual Basic 6

Installation >

Install/remove from Visual Basic 6

 Return to chapter overview

Installation

1. Run Visual Basic.

2. Select File > New Project menu command:

3. The New Project dialog box will appear:

4. Select Standard EXE and click OK.

5. Right-click on the toolbox:

6. In the popup menu, select Components....

7. In the Components dialog box on the Controls tab, select and check CADViewX Library and click OK:

8. CADViewX icon will be added to the list of the standard toolbox controls:

Removing

1. Run Visual Basic.

2. Select File > New Project menu command:

3. The New Project dialog box will appear:

4. Select Standard EXE and click OK.

5. Right-click on the toolbox:

6. In the popup menu, select Components....

7. In the Components dialog box on the Controls tab, uncheck CADViewX Library and click OK:


Install/remove from Delphi

Installation >

Install/remove from Delphi

 Return to chapter overview

Installation

1. Run Delphi.

2. Select Components > Import ActiveX Control menu command:

3. In the Import ActiveX dialog box, click Add.

4. In the Register OLE Control dialog box, find CADViewLib.ocx (for example, c:\Program Files (x86)\CADSoftTools\CADViewX Lite 14\CADViewLib\CADViewLib.ocx). Click Open.

5. CADViewX Library will be added to the list of components and TCADViewX will appear in the list of class names:

6. Click Install.

7. In the Install dialog box on the Into existing package tab in the File name field, select any *.dpk file (for example: C:\Program Files\Borland\Delphi7\Lib\dclusr.dpk). Click OK:

8. In the Confirm dialog box, click Yes:

9. In the Information dialog box, click OK:

10. Close the Package - <Package Name>.dpk window:

11. In the Confirm dialog box, click Yes:

12. On the ActiveX components page, CADViewX component will appear:

13. Select Project > Import Type Library... menu command.

14. The Import Type Library dialog box will appear. Select CADViewX Library in the library's list:

15. Click the Create Unit button.

16. In the Confirm dialog box, click Yes.

Removing

1. Run Delphi.

2. Select File > Open Project menu command:

3. Select pointed in Install section: step 7 .dpk file.

4. In the Package - <Package Name>.dpk dialog box, remove CADViewLib_TLB.dcr and CADViewLib_TLB.pas in the Contains folder:

·Select CADViewLib_TLB.dcr by clicking the left mouse button

·In the context menu, select Remove From Project (by right-click):

·In the Confirm dialog box, click Yes:

·Repeat these steps for CADViewLib_TLB.pas

5. Click Compile:

6. In the Information dialog box, click OK:

7. Close the Package - <Package Name>.dpk window:

8. In the Confirm dialog box, click Yes:


AxCADViewLib Namespace

API Reference >

AxCADViewLib Namespace

 Return to chapter overview

Show / hide the hidden text

Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Classes

 | Name | Description
Public class | AxCADViewX | A wrapper class around CADViewX control placed onto a form

Top


AxCADViewX Class

API Reference > AxCADViewLib Namespace >

AxCADViewX Class

 Return to chapter overview

Show / hide the hidden text

A wrapper class around CADViewX control placed onto a form

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Class AxCADViewX

C#

public class AxCADViewX

C++

public ref class AxCADViewX

JScript

public class AxCADViewX

collall Remarks

This class is generated automatically when dragging the control onto a form in .NET application.

collall Inheritance Hierarchy

System.Object

AxCADViewLib.AxCADViewX

collall See Also

Reference

AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX Members

API Reference > AxCADViewLib Namespace > AxCADViewX Class >

AxCADViewX Members

 Return to chapter overview

Show / hide the hidden text

A wrapper class around CADViewX control placed onto a form

The following tables list the members exposed by the AxCADViewX type.

collall Public Constructors

 | Name | Description
Public constructor | AxCADViewX | Initializes a new instance of the AxCADViewX class.

Top

collall Public Properties

 | Name | Description
Public property | Active | Gets a value indicating whether the control is active.
Public property | AlignDisabled | Gets a value indicating whether child control realignment is disabled.
Public property | AutoOpenActiveViewPort | Gets or sets a value indicating whether an active viewport will be opened automatically.
Public property | AutoScroll | Gets or sets a value indicating whether the scrollbars appear automatically after zooming in.
Public property | AxBorderStyle | Gets or sets a border style for the control.
Public property | BackGroundColor | Gets or sets a background color for the loaded CAD drawing.
Public property | BorderWidth | Gets or sets the control's border width.
Public property | CADImage | Gets or sets a CADImage object for the loaded drawing.
Public property | Caption | Gets or sets a caption of the control.
Public property | Color | Gets or sets a background color for the control.
Public property | Count |
Public property | CtlAutoSize | Gets or sets a value indicating whether the control resizes itself to fit its contents.
Public property | CtlFont | Gets or sets a font of the control.
Public property | CtlProductName | Gets a product name for the control.
Public property | CtlProductVersion | Gets a product version for the control.
Public property | CtlVisible | Gets or sets a value indicating whether the control is visible.
Public property | DXFImage | Gets or sets a DXFImage object for the loaded drawing.
Public property | DefaultAcadVersion | Gets or sets the default AutoCAD version for saving to DWG/DXF formats.
Public property | DefaultColor | Gets or sets a default color for the loaded CAD drawing.
Public property | DefaultSHXFont | Gets or sets a name of the default SHX font.
Public property | DefaultSHXPath | Gets or sets the default path to SHX font files.
Public property | DoubleBuffered | Gets or sets a value indicating whether the control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Public property | DrawMode | Gets or sets an appearance of colors in the loaded CAD drawing.
Public property | DropTarget | Gets or sets a value indicating whether the control can be a target for the drag-and-drop operations.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction.
Public property | FileName | Gets or sets a name of the loaded drawing file.
Public property | FileVersion | Gets the file version of CADViewLib.ocx.
Public property | GSDPI | Gets or sets a DPI value for the EPS import.
Public property | GSDllSearchPath | Gets or sets a path to GhostScript library.
Public property | HScrollBarVisible | Gets or sets a value indicating whether the horizontal scroll bar is visible.
Public property | Image | Gets or sets a DXFImage object for the loaded drawing.
Public property | ImageAlign | Gets or sets the alignment of the child control which renders an image.
Public property | ImageBoundsRect | Gets the bounding rectangle for the drawing area.
Public property | ImageHeight | Gets a height of the loaded CAD drawing.
Public property | ImageParentClientRect | Obsolete.
Public property | ImageWidth | Gets a width of the loaded CAD drtawing.
Public property | IsShowPrinterSetupDialog | Gets or sets a value indicating whether the Print dialog box will be displayed.
Public property | IsWithoutBorder | Gets or sets a value indicating whether the loaded CAD drawing is displayed without an additional empty space (borders).
Public property | KeyPreview | Gets or sets a value indicating whether the form-level keyboard event procedures are invoked before the control's keyboard event procedures.
Public property | Language | Gets or sets a language of the control's GUI.
Public property | LanguagesCount | Gets a quantity of available GUI languages.
Public property | LayoutIndex | Gets or sets an index of the currently displayed CAD drawing's layout.
Public property | LayoutToolBox | Provides an access to the layouts combo box.
Public property | LayoutsBarVisible | Gets or sets a value indicating whether the layouts toolbox is visible.
Public property | LayoutsCount | Gets the layouts quantity in the loaded CAD drawing.
Public property | Millimetres | Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file.
Public property | PaperOrientation | Gets or sets the paper orientation for printing.
Public property | Picture | Gets a raster image for the displayed drawing.
Public property | PixelsPerInch | Gets or sets the proportion of the font on the system on which the control's form was designed.
Public property | PrintScale | Gets or sets a value indicating how the drawing will be scaled on print.
Public property | PrintViewArea | Gets or sets a value indicating whether the current view will be printed.
Public property | PrinterIndex | Gets or sets an index of the current printer.
Public property | PrintersCount | Gets a number of printers installed in the operating system.
Public property | PrintingTitle | Gets or sets a document name in the print queue for files yet to be printed from CADViewX.
Public property | ProgressRect | Gets the rectangle area that has been changed and needs to be redrawn.
Public property | RasterColorDepth | Gets or sets a color depth for raster images.
Public property | Rotatable | Gets a value indicating whether the drawing can be rotated on the angle value which is not divisible by 90.
Public property | SHXSearchPaths | Gets or sets the paths to the SHX font files.
Public property | ScaleFactor | Gets or sets a scale factor for CAD drawing's width and height.
Public property | Scaled | Gets or sets a value indicating whether the control's form is scaled according to the PixelsPerInch property value.
Public property | ScreenSnap | Gets or sets a value indicating whether the control's form snaps to edge of screen.
Public property | SearchSHXPaths | Gets or sets a value indicating whether to search the SHX fonts at the specified paths.
Public property | SelfPopupMenu | Gets or sets a value indicating whether the control's context menu is displayed.
Public property | SnapBuffer | Gets or sets a distance for the screen snap.
Public property | ToolBarVisible | Gets or sets a value indicating the control's toolbar visibility.
Public property | ToolBox | Provides an access to the control's toolbar.
Public property | UseSHXFonts | Gets or sets a value indicating whether the SHX fonts will be used in the CAD drawing.
Public property | UseSizeDialog | Gets or sets a value indicating whether the Export file size dialog window is displayed.
Public property | VScrollBarVisible | Gets or sets a value indicating whether the vertical scroll bar is visible.
Public property | VisibleDockClientCount | Gets the number of visible controls that are docked on the windowed control.
Public property | VisibleOrbit3D | Gets or sets a value indicating whether the 3D Orbit tool is visible.
Public property | hDc | Gets a handle to a device context (DC) for the client area of the control.
Public property | hWnd | Gets the window handle that the control is bound to.
Public property | mmHeight | Gets the physical height for the loaded HPGL drawing in millimeters.
Public property | mmWidth | Gets the physical width for the loaded HPGL drawing in millimeters.

Top

collall Public Methods

 | Name | Description
Public method | ActionUpdate | Updates the control's internal state.
Public method | CADCoords | Calculates CAD coordinates for a point specified by the screen coordinates.
Public method | Cancel | Terminates moving (or dragging) of the image.
Public method | Center | Returns the center point of the drawing area.
Public method | CheckUpdates | Checks for a new version of the control available to download.
Public method | CloseFile | Closes the currently opened file.
Public method | ConvertCADToJPEG | Converts a CAD drawing file to the JPEG format.
Public method | ConvertCustom |
Public method | CopyToRaster | Copies the loaded CAD drawing to the clipboard as a bitmap.
Public method | CurrentLayoutIterate | Iterates through the entities on the current drawing layout.
Public method | DoToolButtonClick | Triggers the mouse click on a specified toolbar button.
Public method | Empty | Returns a value indicating whether the control contains any drawing file or not.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportToMetafile | Exports the loaded CAD drawing to Windows metafile.
Public method | FindAutoCADSHXPaths | Returns paths to the SHX fonts installed with Autodesk products (AutoCAD, DWG TrueView).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetOpenDialogFilter | Retrieves a string that indicates the file types and descriptions displayed in the control's open file dialog.
Public method | GetSaveDialogFilter | Retrieves a string that indicates the file types and descriptions displayed in the control's save file dialog.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | HasPrevScale | Check if the drawing was scaled on the screen.
Public method | IsBadRect | Checks if the sizes of a specifed parallelepiped are defined correctly.
Public method | IsVectGraphic | Returns a value indicating whether the loaded file contains vector graphics.
Public method | LoadFile | Loads a specified file.
Public method | LoadFromIni | Loads the control's settings from a specified .ini file.
Public method | MkFPoint | Defines a point in the 3D space.
Public method | MkFRect | Defines a parallelepiped (box).
Public method | OpenActiveViewPort | Displays the active viewport.
Public method | PictureRealign | Realigns the displayed image.
Public method | PictureRect | Returns the bounding rectangle for the displayed image.
Public method | PictureRepaint | Repaints the displayed image.
Public method | Popup | Displays the control's context menu at a given location of the screen.
Public method | PrevScale | Redraws the displayed image with a previous scale factor and boundaries.
Public method | Print | Sends the loaded file to the current printer.
Public method | PrintImage | Sends the loaded file to the current printer.
Public method | ProcessXML | Processes a string which contains the XML instructions.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RefreshAfterPictureAssign | Forces the control to clear the internal data left from the previously loaded file.
Public method | RefreshAfterRotate | Forces the control to refresh the image after rotation.
Public method | SaveCopyToFile | Copies the contents of the loaded file to a stream and saves the copy to a file.
Public method | SaveToFile | Saves the loaded drawing to a specified file.
Public method | SaveToFileEx | Saves the loaded drawing to a specified file.
Public method | SaveToIni | Saves the control's settings to an .ini file
Public method | ScaleImage | Applies the on-screen scaling to the displayed image.
Public method | ScaledRectPicture | Captures a specified rectangle area as an Image object.
Public method | SetImageBounds | Sets the boundaries for the displayed image.
Public method | ShowAbout | Forces the control to display the About dialog window.
Public method | ShowInfo | Displays a caption with a specified size.
Public method | ShowLayersDialog | Forces the control to display the Layers dialog window.
Public method | ShowPoint | (Overloaded) Displays the image centered by a specified point with a certain scale factor.
Public method | ShowPointEx | Displays the image centered by a specified point with a certain scale factor.
Public method | ShowRect | Displays the image centered by a specified rectangle area.
Public method | StRg | Registers CADViewX developer license programmatically in the application.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | UsePictureRect | Obsolete.
Public method | Zoom | Zooms to a specified rectangle area on the loaded drawing.
Public method | get_EnabledAction | Returns a value indicating whether a specified toolbar button is enabled.
Public method | get_Items |
Public method | get_Languages | Retrieves a GUI language name by its index.
Public method | get_Printer | Retrieves a printer name by its index.
Public method | get_VisibleAction | Returns a value indicating whether a specified toolbar button is visible.
Public method | set_EnabledAction | Makes a specified toolbar button enabled or disabled.
Public method | set_Printer | Changes a local name of the printer at the given index.
Public method | set_VisibleAction | Makes a specified toolbar button visible or hidden.

Top

collall Public Events

 | Name | Description
Public event | OnActivate | Occurs when the control is activated.
Public event | OnAfterLoad | Occurs when the drawing file is loaded.
Public event | OnBeforeLoad | Occurs before loading of the drawing file.
Public event | OnClick | Occurs when the control is clicked by the mouse.
Public event | OnCreate | Occurs when the control instance is created.
Public event | OnDblClick | Occurs when the control is double clicked by the mouse.
Public event | OnDeactivate | Occurs when the control is deactivated.
Public event | OnDestroy | Occurs when the control instance is destroyed.
Public event | OnIterate | Occurs when iterating through the entities in the drawing file.
Public event | OnKeyDown | Occurs when a key is pressed while the control has focus.
Public event | OnKeyPress | Occurs when a character, space or backspace key is pressed while the control has focus.
Public event | OnLayoutChange | Occurs when switching between layouts in the loaded drawing.
Public event | OnMouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed.
Public event | OnMouseMove | Occurs when the mouse pointer is moved over the control.
Public event | OnMouseUp | Occurs when the mouse pointer is over the control and a mouse button is released.
Public event | OnMouseWheelDown | Occurs when the mouse wheel moves down while the control has focus.
Public event | OnMouseWheelUp | Occurs when the mouse wheel moves up while the control has focus.
Public event | OnPaint | Occurs when the control is redrawn.
Public event | OnProcess | Occurs when an XML instruction is processed.
Public event | OnProgress | Occurs when the file loading in progress.
Public event | OnScaling | Occurs when the displayed image is scaled.
Public event | OnToolButtonClick | Occurs when the toolbar button is clicked by the mouse.

Top

collall See Also

Reference

AxCADViewX Class
AxCADViewLib Namespace


AxCADViewX Constructor

API Reference > AxCADViewLib Namespace > AxCADViewX Class >

AxCADViewX Constructor

Return to chapter overview

Show / hide the hidden text

Initializes a new instance of the AxCADViewX class.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Sub New()

C#

public AxCADViewX()

C++

public:
AxCADViewX()

JScript

public function AxCADViewX();

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX Properties

API Reference > AxCADViewLib Namespace > AxCADViewX Class >

AxCADViewX Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Active | Gets a value indicating whether the control is active.
Public property | AlignDisabled | Gets a value indicating whether child control realignment is disabled.
Public property | AutoOpenActiveViewPort | Gets or sets a value indicating whether an active viewport will be opened automatically.
Public property | AutoScroll | Gets or sets a value indicating whether the scrollbars appear automatically after zooming in.
Public property | AxBorderStyle | Gets or sets a border style for the control.
Public property | BackGroundColor | Gets or sets a background color for the loaded CAD drawing.
Public property | BorderWidth | Gets or sets the control's border width.
Public property | CADImage | Gets or sets a CADImage object for the loaded drawing.
Public property | Caption | Gets or sets a caption of the control.
Public property | Color | Gets or sets a background color for the control.
Public property | Count |
Public property | CtlAutoSize | Gets or sets a value indicating whether the control resizes itself to fit its contents.
Public property | CtlFont | Gets or sets a font of the control.
Public property | CtlProductName | Gets a product name for the control.
Public property | CtlProductVersion | Gets a product version for the control.
Public property | CtlVisible | Gets or sets a value indicating whether the control is visible.
Public property | DXFImage | Gets or sets a DXFImage object for the loaded drawing.
Public property | DefaultAcadVersion | Gets or sets the default AutoCAD version for saving to DWG/DXF formats.
Public property | DefaultColor | Gets or sets a default color for the loaded CAD drawing.
Public property | DefaultSHXFont | Gets or sets a name of the default SHX font.
Public property | DefaultSHXPath | Gets or sets the default path to SHX font files.
Public property | DoubleBuffered | Gets or sets a value indicating whether the control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Public property | DrawMode | Gets or sets an appearance of colors in the loaded CAD drawing.
Public property | DropTarget | Gets or sets a value indicating whether the control can be a target for the drag-and-drop operations.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction.
Public property | FileName | Gets or sets a name of the loaded drawing file.
Public property | FileVersion | Gets the file version of CADViewLib.ocx.
Public property | GSDPI | Gets or sets a DPI value for the EPS import.
Public property | GSDllSearchPath | Gets or sets a path to GhostScript library.
Public property | HScrollBarVisible | Gets or sets a value indicating whether the horizontal scroll bar is visible.
Public property | Image | Gets or sets a DXFImage object for the loaded drawing.
Public property | ImageAlign | Gets or sets the alignment of the child control which renders an image.
Public property | ImageBoundsRect | Gets the bounding rectangle for the drawing area.
Public property | ImageHeight | Gets a height of the loaded CAD drawing.
Public property | ImageParentClientRect | Obsolete.
Public property | ImageWidth | Gets a width of the loaded CAD drtawing.
Public property | IsShowPrinterSetupDialog | Gets or sets a value indicating whether the Print dialog box will be displayed.
Public property | IsWithoutBorder | Gets or sets a value indicating whether the loaded CAD drawing is displayed without an additional empty space (borders).
Public property | KeyPreview | Gets or sets a value indicating whether the form-level keyboard event procedures are invoked before the control's keyboard event procedures.
Public property | Language | Gets or sets a language of the control's GUI.
Public property | LanguagesCount | Gets a quantity of available GUI languages.
Public property | LayoutIndex | Gets or sets an index of the currently displayed CAD drawing's layout.
Public property | LayoutToolBox | Provides an access to the layouts combo box.
Public property | LayoutsBarVisible | Gets or sets a value indicating whether the layouts toolbox is visible.
Public property | LayoutsCount | Gets the layouts quantity in the loaded CAD drawing.
Public property | Millimetres | Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file.
Public property | PaperOrientation | Gets or sets the paper orientation for printing.
Public property | Picture | Gets a raster image for the displayed drawing.
Public property | PixelsPerInch | Gets or sets the proportion of the font on the system on which the control's form was designed.
Public property | PrintScale | Gets or sets a value indicating how the drawing will be scaled on print.
Public property | PrintViewArea | Gets or sets a value indicating whether the current view will be printed.
Public property | PrinterIndex | Gets or sets an index of the current printer.
Public property | PrintersCount | Gets a number of printers installed in the operating system.
Public property | PrintingTitle | Gets or sets a document name in the print queue for files yet to be printed from CADViewX.
Public property | ProgressRect | Gets the rectangle area that has been changed and needs to be redrawn.
Public property | RasterColorDepth | Gets or sets a color depth for raster images.
Public property | Rotatable | Gets a value indicating whether the drawing can be rotated on the angle value which is not divisible by 90.
Public property | SHXSearchPaths | Gets or sets the paths to the SHX font files.
Public property | ScaleFactor | Gets or sets a scale factor for CAD drawing's width and height.
Public property | Scaled | Gets or sets a value indicating whether the control's form is scaled according to the PixelsPerInch property value.
Public property | ScreenSnap | Gets or sets a value indicating whether the control's form snaps to edge of screen.
Public property | SearchSHXPaths | Gets or sets a value indicating whether to search the SHX fonts at the specified paths.
Public property | SelfPopupMenu | Gets or sets a value indicating whether the control's context menu is displayed.
Public property | SnapBuffer | Gets or sets a distance for the screen snap.
Public property | ToolBarVisible | Gets or sets a value indicating the control's toolbar visibility.
Public property | ToolBox | Provides an access to the control's toolbar.
Public property | UseSHXFonts | Gets or sets a value indicating whether the SHX fonts will be used in the CAD drawing.
Public property | UseSizeDialog | Gets or sets a value indicating whether the Export file size dialog window is displayed.
Public property | VScrollBarVisible | Gets or sets a value indicating whether the vertical scroll bar is visible.
Public property | VisibleDockClientCount | Gets the number of visible controls that are docked on the windowed control.
Public property | VisibleOrbit3D | Gets or sets a value indicating whether the 3D Orbit tool is visible.
Public property | hDc | Gets a handle to a device context (DC) for the client area of the control.
Public property | hWnd | Gets the window handle that the control is bound to.
Public property | mmHeight | Gets the physical height for the loaded HPGL drawing in millimeters.
Public property | mmWidth | Gets the physical width for the loaded HPGL drawing in millimeters.

Top

collall See Also

Reference

AxCADViewX Class
AxCADViewLib Namespace


AxCADViewX.Active Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.Active Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the control is active.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public ReadOnly Overridable Property Active() As Boolean

C#

public virtual bool Active {get;}

C++

public:
virtual property bool Active {
bool get( );
}

JScript

public function get Active() : boolean;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.AlignDisabled Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.AlignDisabled Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether child control realignment is disabled.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public ReadOnly Overridable Property AlignDisabled() As Boolean

C#

public virtual bool AlignDisabled {get;}

C++

public:
virtual property bool AlignDisabled {
bool get( );
}

JScript

public function get AlignDisabled() : boolean;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.AutoOpenActiveViewPort Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.AutoOpenActiveViewPort Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether an active viewport will be opened automatically.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property AutoOpenActiveViewPort() As Boolean

C#

public virtual bool AutoOpenActiveViewPort {get; set;}

C++

public:
virtual property bool AutoOpenActiveViewPort {
bool get( );
void set(
bool value
);
}

JScript

public function get AutoOpenActiveViewPort() : boolean;
public function set AutoOpenActiveViewPort(value : boolean);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.AutoScroll Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.AutoScroll Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the scrollbars appear automatically after zooming in.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property AutoScroll() As Boolean

C#

public virtual bool AutoScroll {get; set;}

C++

public:
virtual property bool AutoScroll {
bool get( );
void set(
bool value
);
}

JScript

public function get AutoScroll() : boolean;
public function set AutoScroll(value : boolean);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.AxBorderStyle Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.AxBorderStyle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a border style for the control.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property AxBorderStyle() As TxActiveFormBorderStyle

C#

public virtual TxActiveFormBorderStyle AxBorderStyle {get; set;}

C++

public:
virtual property TxActiveFormBorderStyle AxBorderStyle {
TxActiveFormBorderStyle get( );
void set(
TxActiveFormBorderStyle value
);
}

JScript

public function get AxBorderStyle() : TxActiveFormBorderStyle;
public function set AxBorderStyle(value : TxActiveFormBorderStyle);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.BackGroundColor Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.BackGroundColor Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a background color for the loaded CAD drawing.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property BackGroundColor() As Color

C#

public virtual Color BackGroundColor {get; set;}

C++

public:
virtual property Color^ BackGroundColor {
Color^ get( );
void set(
Color^ value
);
}

JScript

public function get BackGroundColor() : Color;
public function set BackGroundColor(value : Color);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.BorderWidth Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.BorderWidth Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the control's border width.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property BorderWidth() As Integer

C#

public virtual int BorderWidth {get; set;}

C++

public:
virtual property int BorderWidth {
int get( );
void set(
int value
);
}

JScript

public function get BorderWidth() : int;
public function set BorderWidth(value : int);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.CADImage Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.CADImage Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a CADImage object for the loaded drawing.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property CADImage() As Object

C#

public virtual object CADImage {get; set;}

C++

public:
virtual property object^ CADImage {
object^ get( );
void set(
object^ value
);
}

JScript

public function get CADImage() : object;
public function set CADImage(value : object);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.Caption Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.Caption Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a caption of the control.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property Caption() As String

C#

public virtual string Caption {get; set;}

C++

public:
virtual property String^ Caption {
String^ get( );
void set(
String^ value
);
}

JScript

public function get Caption() : String;
public function set Caption(value : String);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.Color Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.Color Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a background color for the control.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property Color() As Color

C#

public virtual Color Color {get; set;}

C++

public:
virtual property Color^ Color {
Color^ get( );
void set(
Color^ value
);
}

JScript

public function get Color() : Color;
public function set Color(value : Color);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.Count Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.Count Property

 Return to chapter overview

Show / hide the hidden text

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public ReadOnly Overridable Property Count() As Integer

C#

public virtual int Count {get;}

C++

public:
virtual property int Count {
int get( );
}

JScript

public function get Count() : int;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.CtlAutoSize Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.CtlAutoSize Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the control resizes itself to fit its contents.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property CtlAutoSize() As Boolean

C#

public virtual bool CtlAutoSize {get; set;}

C++

public:
virtual property bool CtlAutoSize {
bool get( );
void set(
bool value
);
}

JScript

public function get CtlAutoSize() : boolean;
public function set CtlAutoSize(value : boolean);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.CtlFont Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.CtlFont Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a font of the control.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property CtlFont() As System.Drawing.Font

C#

public virtual System.Drawing.Font CtlFont {get; set;}

C++

public:
virtual property System::Drawing::Font^ CtlFont {
System::Drawing::Font^ get( );
void set(
System::Drawing::Font^ value
);
}

JScript

public function get CtlFont() : System.Drawing.Font;
public function set CtlFont(value : System.Drawing.Font);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.CtlProductName Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.CtlProductName Property

 Return to chapter overview

Show / hide the hidden text

Gets a product name for the control.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public ReadOnly Overridable Property CtlProductName() As String

C#

public virtual string CtlProductName {get;}

C++

public:
virtual property String^ CtlProductName {
String^ get( );
}

JScript

public function get CtlProductName() : String;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.CtlProductVersion Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.CtlProductVersion Property

 Return to chapter overview

Show / hide the hidden text

Gets a product version for the control.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public ReadOnly Overridable Property CtlProductVersion() As String

C#

public virtual string CtlProductVersion {get;}

C++

public:
virtual property String^ CtlProductVersion {
String^ get( );
}

JScript

public function get CtlProductVersion() : String;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.CtlVisible Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.CtlVisible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the control is visible.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property CtlVisible() As Boolean

C#

public virtual bool CtlVisible {get; set;}

C++

public:
virtual property bool CtlVisible {
bool get( );
void set(
bool value
);
}

JScript

public function get CtlVisible() : boolean;
public function set CtlVisible(value : boolean);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.DXFImage Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.DXFImage Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a DXFImage object for the loaded drawing.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property DXFImage() As DXFImage

C#

public virtual DXFImage DXFImage {get; set;}

C++

public:
virtual property DXFImage^ DXFImage {
DXFImage^ get( );
void set(
DXFImage^ value
);
}

JScript

public function get DXFImage() : DXFImage;
public function set DXFImage(value : DXFImage);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.DefaultAcadVersion Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.DefaultAcadVersion Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the default AutoCAD version for saving to DWG/DXF formats.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property DefaultAcadVersion() As TAcadVersion

C#

public virtual TAcadVersion DefaultAcadVersion {get; set;}

C++

public:
virtual property TAcadVersion DefaultAcadVersion {
TAcadVersion get( );
void set(
TAcadVersion value
);
}

JScript

public function get DefaultAcadVersion() : TAcadVersion;
public function set DefaultAcadVersion(value : TAcadVersion);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.DefaultColor Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.DefaultColor Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a default color for the loaded CAD drawing.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property DefaultColor() As Color

C#

public virtual Color DefaultColor {get; set;}

C++

public:
virtual property Color^ DefaultColor {
Color^ get( );
void set(
Color^ value
);
}

JScript

public function get DefaultColor() : Color;
public function set DefaultColor(value : Color);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.DefaultSHXFont Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.DefaultSHXFont Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of the default SHX font.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property DefaultSHXFont() As String

C#

public virtual string DefaultSHXFont {get; set;}

C++

public:
virtual property String^ DefaultSHXFont {
String^ get( );
void set(
String^ value
);
}

JScript

public function get DefaultSHXFont() : String;
public function set DefaultSHXFont(value : String);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.DefaultSHXPath Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.DefaultSHXPath Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the default path to SHX font files.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property DefaultSHXPath() As String

C#

public virtual string DefaultSHXPath {get; set;}

C++

public:
virtual property String^ DefaultSHXPath {
String^ get( );
void set(
String^ value
);
}

JScript

public function get DefaultSHXPath() : String;
public function set DefaultSHXPath(value : String);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.DoubleBuffered Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.DoubleBuffered Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the control should redraw its surface using a secondary buffer to reduce or prevent flicker.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Shadows Property DoubleBuffered() As Boolean

C#

new public virtual bool DoubleBuffered {get; set;}

C++

public:
virtual property bool DoubleBuffered {
bool get( );
void set(
bool value
);
}

JScript

public hide function get DoubleBuffered() : boolean;
public hide function set DoubleBuffered(value : boolean);

Property Value

true if the control paints itself to an in-memory bitmap that is used further to paint the window; otherwise, false.

collall Remarks

Double buffering reduces flicker when the control repaints, but is more memory intensive.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.DrawMode Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.DrawMode Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets an appearance of colors in the loaded CAD drawing.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property DrawMode() As TxDXFDrawMode

C#

public virtual TxDXFDrawMode DrawMode {get; set;}

C++

public:
virtual property TxDXFDrawMode DrawMode {
TxDXFDrawMode get( );
void set(
TxDXFDrawMode value
);
}

JScript

public function get DrawMode() : TxDXFDrawMode;
public function set DrawMode(value : TxDXFDrawMode);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.DropTarget Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.DropTarget Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the control can be a target for the drag-and-drop operations.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property DropTarget() As Boolean

C#

public virtual bool DropTarget {get; set;}

C++

public:
virtual property bool DropTarget {
bool get( );
void set(
bool value
);
}

JScript

public function get DropTarget() : boolean;
public function set DropTarget(value : boolean);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.Enabled Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.Enabled Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the control can respond to user interaction.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overrides Property Enabled() As Boolean

C#

public override bool Enabled {get; set;}

C++

public:
property bool Enabled {
bool get( );
void set(
bool value
);
}

JScript

public function get Enabled() : boolean;
public function set Enabled(value : boolean);

Property Value

true if the control can respond to user interaction; otherwise, false. The default is true.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.FileName Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.FileName Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of the loaded drawing file.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property FileName() As String

C#

public virtual string FileName {get; set;}

C++

public:
virtual property String^ FileName {
String^ get( );
void set(
String^ value
);
}

JScript

public function get FileName() : String;
public function set FileName(value : String);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.FileVersion Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.FileVersion Property

 Return to chapter overview

Show / hide the hidden text

Gets the file version of CADViewLib.ocx.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public ReadOnly Overridable Property FileVersion() As String

C#

public virtual string FileVersion {get;}

C++

public:
virtual property String^ FileVersion {
String^ get( );
}

JScript

public function get FileVersion() : String;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.GSDPI Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.GSDPI Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a DPI value for the EPS import.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property GSDPI() As Integer

C#

public virtual int GSDPI {get; set;}

C++

public:
virtual property int GSDPI {
int get( );
void set(
int value
);
}

JScript

public function get GSDPI() : int;
public function set GSDPI(value : int);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.GSDllSearchPath Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.GSDllSearchPath Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a path to GhostScript library.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property GSDllSearchPath() As String

C#

public virtual string GSDllSearchPath {get; set;}

C++

public:
virtual property String^ GSDllSearchPath {
String^ get( );
void set(
String^ value
);
}

JScript

public function get GSDllSearchPath() : String;
public function set GSDllSearchPath(value : String);

collall Remarks

Ghostscript library is used for EPS import. To be able to open .eps files with CADViewX, you will need to install this library and specify a location of the gsdll32.dll or gsdll64.dll file.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.HScrollBarVisible Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.HScrollBarVisible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the horizontal scroll bar is visible.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property HScrollBarVisible() As Boolean

C#

public virtual bool HScrollBarVisible {get; set;}

C++

public:
virtual property bool HScrollBarVisible {
bool get( );
void set(
bool value
);
}

JScript

public function get HScrollBarVisible() : boolean;
public function set HScrollBarVisible(value : boolean);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.Image Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.Image Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a DXFImage object for the loaded drawing.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public ReadOnly Overridable Property Image() As DXFImage

C#

public virtual DXFImage Image {get;}

C++

public:
virtual property DXFImage^ Image {
DXFImage^ get( );
}

JScript

public function get Image() : DXFImage;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.ImageAlign Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.ImageAlign Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the alignment of the child control which renders an image.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property ImageAlign() As TxAlign

C#

public virtual TxAlign ImageAlign {get; set;}

C++

public:
virtual property TxAlign ImageAlign {
TxAlign get( );
void set(
TxAlign value
);
}

JScript

public function get ImageAlign() : TxAlign;
public function set ImageAlign(value : TxAlign);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.ImageBoundsRect Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.ImageBoundsRect Property

 Return to chapter overview

Show / hide the hidden text

Gets the bounding rectangle for the drawing area.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public ReadOnly Overridable Property ImageBoundsRect() As Rect2D

C#

public virtual Rect2D ImageBoundsRect {get;}

C++

public:
virtual property Rect2D^ ImageBoundsRect {
Rect2D^ get( );
}

JScript

public function get ImageBoundsRect() : Rect2D;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.ImageHeight Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.ImageHeight Property

 Return to chapter overview

Show / hide the hidden text

Gets a height of the loaded CAD drawing.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public ReadOnly Overridable Property ImageHeight() As Integer

C#

public virtual int ImageHeight {get;}

C++

public:
virtual property int ImageHeight {
int get( );
}

JScript

public function get ImageHeight() : int;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.ImageParentClientRect Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.ImageParentClientRect Property

 Return to chapter overview

Show / hide the hidden text

NOTE: This member is now obsolete.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public ReadOnly Overridable Property ImageParentClientRect() As Rect2D

C#

public virtual Rect2D ImageParentClientRect {get;}

C++

public:
virtual property Rect2D^ ImageParentClientRect {
Rect2D^ get( );
}

JScript

public function get ImageParentClientRect() : Rect2D;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.ImageWidth Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.ImageWidth Property

 Return to chapter overview

Show / hide the hidden text

Gets a width of the loaded CAD drawing.

Namespace: AxCADViewLib
Assembly:Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public ReadOnly Overridable Property ImageWidth() As Integer

C#

public virtual int ImageWidth {get;}

C++

public:
virtual property int ImageWidth {
int get( );
}

JScript

public function get ImageWidth() : int;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.IsShowPrinterSetupDialog Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.IsShowPrinterSetupDialog Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the Print dialog box will be displayed.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property IsShowPrinterSetupDialog() As Boolean

C#

public virtual bool IsShowPrinterSetupDialog {get; set;}

C++

public:
virtual property bool IsShowPrinterSetupDialog {
bool get( );
void set(
bool value
);
}

JScript

public function get IsShowPrinterSetupDialog() : boolean;
public function set IsShowPrinterSetupDialog(value : boolean);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.IsWithoutBorder Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.IsWithoutBorder Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the loaded CAD drawing is displayed without an additional empty space (borders).

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property IsWithoutBorder() As Boolean

C#

public virtual bool IsWithoutBorder {get; set;}

C++

public:
virtual property bool IsWithoutBorder {
bool get( );
void set(
bool value
);
}

JScript

public function get IsWithoutBorder() : boolean;
public function set IsWithoutBorder(value : boolean);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.KeyPreview Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.KeyPreview Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the form-level keyboard event procedures are invoked before the control's keyboard event procedures.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property KeyPreview() As Boolean

C#

public virtual bool KeyPreview {get; set;}

C++

public:
virtual property bool KeyPreview {
bool get( );
void set(
bool value
);
}

JScript

public function get KeyPreview() : boolean;
public function set KeyPreview(value : boolean);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.Language Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.Language Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a language of the control's GUI.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property Language() As String

C#

public virtual string Language {get; set;}

C++

public:
virtual property String^ Language {
String^ get( );
void set(
String^ value
);
}

JScript

public function get Language() : String;
public function set Language(value : String);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.LanguagesCount Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.LanguagesCount Property

 Return to chapter overview

Show / hide the hidden text

Gets a quantity of available GUI languages.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public ReadOnly Overridable Property LanguagesCount() As Integer

C#

public virtual int LanguagesCount {get;}

C++

public:
virtual property int LanguagesCount {
int get( );
}

JScript

public function get LanguagesCount() : int;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.LayoutIndex Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.LayoutIndex Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets an index of the currently displayed CAD drawing's layout.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property LayoutIndex() As Integer

C#

public virtual int LayoutIndex {get; set;}

C++

public:
virtual property int LayoutIndex {
int get( );
void set(
int value
);
}

JScript

public function get LayoutIndex() : int;
public function set LayoutIndex(value : int);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.LayoutToolBox Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.LayoutToolBox Property

 Return to chapter overview

Show / hide the hidden text

Provides an access to the layouts combo box.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public ReadOnly Overridable Property LayoutToolBox() As ToolBox

C#

public virtual ToolBox LayoutToolBox {get;}

C++

public:
virtual property ToolBox^ LayoutToolBox {
ToolBox^ get( );
}

JScript

public function get LayoutToolBox() : ToolBox;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.LayoutsBarVisible Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.LayoutsBarVisible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the layouts toolbox is visible.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property LayoutsBarVisible() As Boolean

C#

public virtual bool LayoutsBarVisible {get; set;}

C++

public:
virtual property bool LayoutsBarVisible {
bool get( );
void set(
bool value
);
}

JScript

public function get LayoutsBarVisible() : boolean;
public function set LayoutsBarVisible(value : boolean);

Property Value

true if ; otherwise, false.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.LayoutsCount Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.LayoutsCount Property

 Return to chapter overview

Show / hide the hidden text

Gets the layouts quantity in the loaded CAD drawing.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public ReadOnly Overridable Property LayoutsCount() As Integer

C#

public virtual int LayoutsCount {get;}

C++

public:
virtual property int LayoutsCount {
int get( );
}

JScript

public function get LayoutsCount() : int;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.Millimetres Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.Millimetres Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property Millimetres() As Boolean

C#

public virtual bool Millimetres {get; set;}

C++

public:
virtual property bool Millimetres {
bool get( );
void set(
bool value
);
}

JScript

public function get Millimetres() : boolean;
public function set Millimetres(value : boolean);

Property Value

true if the drawing units are millimeters; false if the drawing units are inches.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.PaperOrientation Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.PaperOrientation Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the paper orientation for printing.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property PaperOrientation() As TxPaperOrientation

C#

public virtual TxPaperOrientation PaperOrientation {get; set;}

C++

public:
virtual property TxPaperOrientation PaperOrientation {
TxPaperOrientation get( );
void set(
TxPaperOrientation value
);
}

JScript

public function get PaperOrientation() : TxPaperOrientation;
public function set PaperOrientation(value : TxPaperOrientation);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.Picture Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.Picture Property

 Return to chapter overview

Show / hide the hidden text

Gets a raster image for the displayed drawing.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property Picture() As System.Drawing.Image

C#

public virtual System.Drawing.Image Picture {get; set;}

C++

public:
virtual property System::Drawing::Image^ Picture {
System::Drawing::Image^ get( );
void set(
System::Drawing::Image^ value
);
}

JScript

public function get Picture() : System.Drawing.Image;
public function set Picture(value : System.Drawing.Image);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.PixelsPerInch Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.PixelsPerInch Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the proportion of the font on the system on which the control's form was designed.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property PixelsPerInch() As Integer

C#

public virtual int PixelsPerInch {get; set;}

C++

public:
virtual property int PixelsPerInch {
int get( );
void set(
int value
);
}

JScript

public function get PixelsPerInch() : int;
public function set PixelsPerInch(value : int);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.PrintScale Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.PrintScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating how the drawing will be scaled on print.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property PrintScale() As TxPrintScale

C#

public virtual TxPrintScale PrintScale {get; set;}

C++

public:
virtual property TxPrintScale PrintScale {
TxPrintScale get( );
void set(
TxPrintScale value
);
}

JScript

public function get PrintScale() : TxPrintScale;
public function set PrintScale(value : TxPrintScale);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.PrintViewArea Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.PrintViewArea Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the current view will be printed.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property PrintViewArea() As Boolean

C#

public virtual bool PrintViewArea {get; set;}

C++

public:
virtual property bool PrintViewArea {
bool get( );
void set(
bool value
);
}

JScript

public function get PrintViewArea() : boolean;
public function set PrintViewArea(value : boolean);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.PrinterIndex Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.PrinterIndex Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets an index of the current printer.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property PrinterIndex() As Integer

C#

public virtual int PrinterIndex {get; set;}

C++

public:
virtual property int PrinterIndex {
int get( );
void set(
int value
);
}

JScript

public function get PrinterIndex() : int;
public function set PrinterIndex(value : int);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.PrintersCount Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.PrintersCount Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of printers installed in the operating system.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public ReadOnly Overridable Property PrintersCount() As Integer

C#

public virtual int PrintersCount {get;}

C++

public:
virtual property int PrintersCount {
int get( );
}

JScript

public function get PrintersCount() : int;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.PrintingTitle Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.PrintingTitle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a document name in the print queue for files yet to be printed from CADViewX.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property PrintingTitle() As String

C#

public virtual string PrintingTitle {get; set;}

C++

public:
virtual property String^ PrintingTitle {
String^ get( );
void set(
String^ value
);
}

JScript

public function get PrintingTitle() : String;
public function set PrintingTitle(value : String);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.ProgressRect Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.ProgressRect Property

 Return to chapter overview

Show / hide the hidden text

Gets the rectangle area that has been changed and needs to be redrawn.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public ReadOnly Overridable Property ProgressRect() As Rect2D

C#

public virtual Rect2D ProgressRect {get;}

C++

public:
virtual property Rect2D^ ProgressRect {
Rect2D^ get( );
}

JScript

public function get ProgressRect() : Rect2D;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.RasterColorDepth Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.RasterColorDepth Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a color depth for raster images.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property RasterColorDepth() As TxColorDepth

C#

public virtual TxColorDepth RasterColorDepth {get; set;}

C++

public:
virtual property TxColorDepth RasterColorDepth {
TxColorDepth get( );
void set(
TxColorDepth value
);
}

JScript

public function get RasterColorDepth() : TxColorDepth;
public function set RasterColorDepth(value : TxColorDepth);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.Rotatable Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.Rotatable Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the drawing can be rotated on the angle value which is not divisible by 90.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public ReadOnly Overridable Property Rotatable() As Boolean

C#

public virtual bool Rotatable {get;}

C++

public:
virtual property bool Rotatable {
bool get( );
}

JScript

public function get Rotatable() : boolean;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.SHXSearchPaths Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.SHXSearchPaths Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the paths to the SHX font files.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property SHXSearchPaths() As String

C#

public virtual string SHXSearchPaths {get; set;}

C++

public:
virtual property String^ SHXSearchPaths {
String^ get( );
void set(
String^ value
);
}

JScript

public function get SHXSearchPaths() : String;
public function set SHXSearchPaths(value : String);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.ScaleFactor Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.ScaleFactor Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a scale factor for CAD drawing's width and height.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property ScaleFactor() As Double

C#

public virtual double ScaleFactor {get; set;}

C++

public:
virtual property double ScaleFactor {
double get( );
void set(
double value
);
}

JScript

public function get ScaleFactor() : double;
public function set ScaleFactor(value : double);

collall Remarks

When you change a value of the ScaleFactor property, the values of ImageWidth and ImageHeight properties will be recalculated (by multiplying on the scale factor).

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.Scaled Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.Scaled Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the control's form is scaled according to the PixelsPerInch property value.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property Scaled() As Boolean

C#

public virtual bool Scaled {get; set;}

C++

public:
virtual property bool Scaled {
bool get( );
void set(
bool value
);
}

JScript

public function get Scaled() : boolean;
public function set Scaled(value : boolean);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.ScreenSnap Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.ScreenSnap Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the control's form snaps to edge of screen.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property ScreenSnap() As Boolean

C#

public virtual bool ScreenSnap {get; set;}

C++

public:
virtual property bool ScreenSnap {
bool get( );
void set(
bool value
);
}

JScript

public function get ScreenSnap() : boolean;
public function set ScreenSnap(value : boolean);

Property Value

true if the edges of the form snap to the edge of the screen when the user moves the form; otherwise, false.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.SearchSHXPaths Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.SearchSHXPaths Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether to search the SHX fonts at the specified paths.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property SearchSHXPaths() As Boolean

C#

public virtual bool SearchSHXPaths {get; set;}

C++

public:
virtual property bool SearchSHXPaths {
bool get( );
void set(
bool value
);
}

JScript

public function get SearchSHXPaths() : boolean;
public function set SearchSHXPaths(value : boolean);

collall Remarks

You can specify the SHX paths using the SHXSearchPaths property.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.SelfPopupMenu Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.SelfPopupMenu Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the control's context menu is displayed.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property SelfPopupMenu() As Boolean

C#

public virtual bool SelfPopupMenu {get; set;}

C++

public:
virtual property bool SelfPopupMenu {
bool get( );
void set(
bool value
);
}

JScript

public function get SelfPopupMenu() : boolean;
public function set SelfPopupMenu(value : boolean);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.SnapBuffer Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.SnapBuffer Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a distance for the screen snap.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property SnapBuffer() As Integer

C#

public virtual int SnapBuffer {get; set;}

C++

public:
virtual property int SnapBuffer {
int get( );
void set(
int value
);
}

JScript

public function get SnapBuffer() : int;
public function set SnapBuffer(value : int);

collall Remarks

If ScreenSnap is true, SnapBuffer determines the maximum number of pixels that be between the form edge and the screen edge before the form snaps to the screen edge.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.ToolBarVisible Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.ToolBarVisible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating the control's toolbar visibility.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property ToolBarVisible() As Boolean

C#

public virtual bool ToolBarVisible {get; set;}

C++

public:
virtual property bool ToolBarVisible {
bool get( );
void set(
bool value
);
}

JScript

public function get ToolBarVisible() : boolean;
public function set ToolBarVisible(value : boolean);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.ToolBox Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.ToolBox Property

 Return to chapter overview

Show / hide the hidden text

Provides an access to the control's toolbar.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public ReadOnly Overridable Property ToolBox() As ToolBox

C#

public virtual ToolBox ToolBox {get;}

C++

public:
virtual property ToolBox^ ToolBox {
ToolBox^ get( );
}

JScript

public function get ToolBox() : ToolBox;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.UseSHXFonts Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.UseSHXFonts Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the SHX fonts will be used in the CAD drawing.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property UseSHXFonts() As Boolean

C#

public virtual bool UseSHXFonts {get; set;}

C++

public:
virtual property bool UseSHXFonts {
bool get( );
void set(
bool value
);
}

JScript

public function get UseSHXFonts() : boolean;
public function set UseSHXFonts(value : boolean);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.UseSizeDialog Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.UseSizeDialog Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the Export file size dialog window is displayed.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property UseSizeDialog() As Boolean

C#

public virtual bool UseSizeDialog {get; set;}

C++

public:
virtual property bool UseSizeDialog {
bool get( );
void set(
bool value
);
}

JScript

public function get UseSizeDialog() : boolean;
public function set UseSizeDialog(value : boolean);

Property Value

true if the Export file size dialog window is displayed when saving to raster formats; otherwise, false.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.VScrollBarVisible Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.VScrollBarVisible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the vertical scroll bar is visible.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property VScrollBarVisible() As Boolean

C#

public virtual bool VScrollBarVisible {get; set;}

C++

public:
virtual property bool VScrollBarVisible {
bool get( );
void set(
bool value
);
}

JScript

public function get VScrollBarVisible() : boolean;
public function set VScrollBarVisible(value : boolean);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.VisibleDockClientCount Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.VisibleDockClientCount Property

 Return to chapter overview

Show / hide the hidden text

Gets the number of visible controls that are docked on the windowed control.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public ReadOnly Overridable Property VisibleDockClientCount() As Integer

C#

public virtual int VisibleDockClientCount {get;}

C++

public:
virtual property int VisibleDockClientCount {
int get( );
}

JScript

public function get VisibleDockClientCount() : int;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.VisibleOrbit3D Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.VisibleOrbit3D Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the 3D Orbit tool is visible.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Property VisibleOrbit3D() As Boolean

C#

public virtual bool VisibleOrbit3D {get; set;}

C++

public:
virtual property bool VisibleOrbit3D {
bool get( );
void set(
bool value
);
}

JScript

public function get VisibleOrbit3D() : boolean;
public function set VisibleOrbit3D(value : boolean);

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.hDc Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.hDc Property

 Return to chapter overview

Show / hide the hidden text

Gets a handle to a device context (DC) for the client area of the control.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public ReadOnly Overridable Property hDc() As Integer

C#

public virtual int hDc {get;}

C++

public:
virtual property int hDc {
int get( );
}

JScript

public function get hDc() : int;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.hWnd Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.hWnd Property

 Return to chapter overview

Show / hide the hidden text

Gets the window handle that the control is bound to.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public ReadOnly Overridable Property hWnd() As Integer

C#

public virtual int hWnd {get;}

C++

public:
virtual property int hWnd {
int get( );
}

JScript

public function get hWnd() : int;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.mmHeight Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.mmHeight Property

 Return to chapter overview

Show / hide the hidden text

Gets the physical height for the loaded HPGL drawing in millimeters.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public ReadOnly Overridable Property mmHeight() As Double

C#

public virtual double mmHeight {get;}

C++

public:
virtual property double mmHeight {
double get( );
}

JScript

public function get mmHeight() : double;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.mmWidth Property

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Properties >

AxCADViewX.mmWidth Property

 Return to chapter overview

Show / hide the hidden text

Gets the physical width for the loaded HPGL drawing in millimeters.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public ReadOnly Overridable Property mmWidth() As Double

C#

public virtual double mmWidth {get;}

C++

public:
virtual property double mmWidth {
double get( );
}

JScript

public function get mmWidth() : double;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX Methods

API Reference > AxCADViewLib Namespace > AxCADViewX Class >

AxCADViewX Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | ActionUpdate | Updates the control's internal state.
Public method | CADCoords | Calculates CAD coordinates for a point specified by the screen coordinates.
Public method | Cancel | Terminates moving (or dragging) of the image.
Public method | Center | Returns the center point of the drawing area.
Public method | CheckUpdates | Checks for a new version of the control available to download.
Public method | CloseFile | Closes the currently opened file.
Public method | ConvertCADToJPEG | Converts a CAD drawing file to the JPEG format.
Public method | ConvertCustom |
Public method | CopyToRaster | Copies the loaded CAD drawing to the clipboard as a bitmap.
Public method | CurrentLayoutIterate | Iterates through the entities on the current drawing layout.
Public method | DoToolButtonClick | Triggers the mouse click on a specified toolbar button.
Public method | Empty | Returns a value indicating whether the control contains any drawing file or not.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportToMetafile | Exports the loaded CAD drawing to Windows metafile.
Public method | FindAutoCADSHXPaths | Returns paths to the SHX fonts installed with Autodesk products (AutoCAD, DWG TrueView).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetOpenDialogFilter | Retrieves a string that indicates the file types and descriptions displayed in the control's open file dialog.
Public method | GetSaveDialogFilter | Retrieves a string that indicates the file types and descriptions displayed in the control's save file dialog.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | HasPrevScale | Check if the drawing was scaled on the screen.
Public method | IsBadRect | Checks if the sizes of a specifed parallelepiped are defined correctly.
Public method | IsVectGraphic | Returns a value indicating whether the loaded file contains vector graphics.
Public method | LoadFile | Loads a specified file.
Public method | LoadFromIni | Loads the control's settings from a specified .ini file.
Public method | MkFPoint | Defines a point in the 3D space.
Public method | MkFRect | Defines a parallelepiped (box).
Public method | OpenActiveViewPort | Displays the active viewport.
Public method | PictureRealign | Realigns the displayed image.
Public method | PictureRect | Returns the bounding rectangle for the displayed image.
Public method | PictureRepaint | Repaints the displayed image.
Public method | Popup | Displays the control's context menu at a given location of the screen.
Public method | PrevScale | Redraws the displayed image with a previous scale factor and boundaries.
Public method | Print | Sends the loaded file to the current printer.
Public method | PrintImage | Sends the loaded file to the current printer.
Public method | ProcessXML | Processes a string which contains the XML instructions.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RefreshAfterPictureAssign | Forces the control to clear the internal data left from the previously loaded file.
Public method | RefreshAfterRotate | Forces the control to refresh the image after rotation.
Public method | SaveCopyToFile | Copies the contents of the loaded file to a stream and saves the copy to a file.
Public method | SaveToFile | Saves the loaded drawing to a specified file.
Public method | SaveToFileEx | Saves the loaded drawing to a specified file.
Public method | SaveToIni | Saves the control's settings to an .ini file
Public method | ScaleImage | Applies the on-screen scaling to the displayed image.
Public method | ScaledRectPicture | Captures a specified rectangle area as an Image object.
Public method | SetImageBounds | Sets the boundaries for the displayed image.
Public method | ShowAbout | Forces the control to display the About dialog window.
Public method | ShowInfo | Displays a caption with a specified size.
Public method | ShowLayersDialog | Forces the control to display the Layers dialog window.
Public method | ShowPoint | (Overloaded) Displays the image centered by a specified point with a certain scale factor.
Public method | ShowPointEx | Displays the image centered by a specified point with a certain scale factor.
Public method | ShowRect | Displays the image centered by a specified rectangle area.
Public method | StRg | Registers CADViewX developer license programmatically in the application.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | UsePictureRect | Obsolete.
Public method | Zoom | Zooms to a specified rectangle area on the loaded drawing.
Public method | get_EnabledAction | Returns a value indicating whether a specified toolbar button is enabled.
Public method | get_Items |
Public method | get_Languages | Retrieves a GUI language name by its index.
Public method | get_Printer | Retrieves a printer name by its index.
Public method | get_VisibleAction | Returns a value indicating whether a specified toolbar button is visible.
Public method | set_EnabledAction | Makes a specified toolbar button enabled or disabled.
Public method | set_Printer | Changes a local name of the printer at the given index.
Public method | set_VisibleAction | Makes a specified toolbar button visible or hidden.

Top

collall See Also

Reference

AxCADViewX Class
AxCADViewLib Namespace


AxCADViewX.ActionUpdate Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.ActionUpdate Method

 Return to chapter overview

Show / hide the hidden text

Updates the control's internal state.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function ActionUpdate() As Boolean

C#

public virtual bool ActionUpdate()

C++

public:
virtual bool ActionUpdate()

JScript

public function ActionUpdate() : boolean;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.CADCoords Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.CADCoords Method

 Return to chapter overview

Show / hide the hidden text

Calculates CAD coordinates for a point specified by the screen coordinates.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function CADCoords( _
ByVal x As Integer, _
ByVal y As Integer _
) As Point3D

C#

public virtual Point3D CADCoords(
intx,
inty
)

C++

public:
virtual Point3D^ CADCoords(
intx,
inty
)

JScript

public function CADCoords(
x : int,
y : int
) : Point3D;

Parameters

x

The X-coordinate of the screen point.

y

The Y-coordinate of the screen point.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.Cancel Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.Cancel Method

 Return to chapter overview

Show / hide the hidden text

Terminates moving (or dragging) of the image.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Sub Cancel()

C#

public virtual void Cancel()

C++

public:
virtual void Cancel()

JScript

public function Cancel();

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.Center Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.Center Method

 Return to chapter overview

Show / hide the hidden text

Returns the center point of the drawing area.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function Center() As Point2D

C#

public virtual Point2D Center()

C++

public:
virtual Point2D^ Center()

JScript

public function Center() : Point2D;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.CheckUpdates Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.CheckUpdates Method

 Return to chapter overview

Show / hide the hidden text

Checks for a new version of the control available to download.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Sub CheckUpdates()

C#

public virtual void CheckUpdates()

C++

public:
virtual void CheckUpdates()

JScript

public function CheckUpdates();

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.CloseFile Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.CloseFile Method

 Return to chapter overview

Show / hide the hidden text

Closes the currently opened file.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Sub CloseFile()

C#

public virtual void CloseFile()

C++

public:
virtual void CloseFile()

JScript

public function CloseFile();

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.ConvertCADToJPEG Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.ConvertCADToJPEG Method

 Return to chapter overview

Show / hide the hidden text

Converts a CAD drawing file to the JPEG format.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function ConvertCADToJPEG( _
ByVal aSrc As String, _
ByVal aDest As String, _
ByVal aMaxDimensions As Integer _
) As Boolean

C#

public virtual bool ConvertCADToJPEG(
stringaSrc,
stringaDest,
intaMaxDimensions
)

C++

public:
virtual bool ConvertCADToJPEG(
String^ aSrc,
String^ aDest,
intaMaxDimensions
)

JScript

public function ConvertCADToJPEG(
aSrc : String,
aDest : String,
aMaxDimensions : int
) : boolean;

Parameters

aSrc

Path to a CAD drawing file.

aDest

Path to the output JPEG file.

aMaxDimensions

Maximum dimensions of the output JPEG image.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.ConvertCustom Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.ConvertCustom Method

 Return to chapter overview

Show / hide the hidden text

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function ConvertCustom( _
ByVal aSrc As Object, _
ByVal aDest As Object, _
ByVal aParams As Object _
) As Object

C#

public virtual object ConvertCustom(
objectaSrc,
objectaDest,
objectaParams
)

C++

public:
virtual object^ ConvertCustom(
object^ aSrc,
object^ aDest,
object^ aParams
)

JScript

public function ConvertCustom(
aSrc : object,
aDest : object,
aParams : object
) : object;

Parameters

aSrc

aDest

aParams

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.CopyToRaster Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.CopyToRaster Method

 Return to chapter overview

Show / hide the hidden text

Copies the loaded CAD drawing to the clipboard as a bitmap.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function CopyToRaster() As Boolean

C#

public virtual bool CopyToRaster()

C++

public:
virtual bool CopyToRaster()

JScript

public function CopyToRaster() : boolean;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.CurrentLayoutIterate Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.CurrentLayoutIterate Method

 Return to chapter overview

Show / hide the hidden text

Iterates through the entities on the current drawing layout.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Sub CurrentLayoutIterate()

C#

public virtual void CurrentLayoutIterate()

C++

public:
virtual void CurrentLayoutIterate()

JScript

public function CurrentLayoutIterate();

collall Remarks

This method fires the OnIterate event for each entity on the current layout.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.DoToolButtonClick Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.DoToolButtonClick Method

 Return to chapter overview

Show / hide the hidden text

Triggers the mouse click on a specified toolbar button.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Sub DoToolButtonClick( _
ByVal toolButton As TxToolButton _
)

C#

public virtual void DoToolButtonClick(
TxToolButtontoolButton
)

C++

public:
virtual void DoToolButtonClick(
TxToolButtontoolButton
)

JScript

public function DoToolButtonClick(
toolButton : TxToolButton
);

Parameters

toolButton

The toolbar button.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.Empty Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.Empty Method

 Return to chapter overview

Show / hide the hidden text

Returns a value indicating whether the control contains any drawing file or not.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function Empty() As Boolean

C#

public virtual bool Empty()

C++

public:
virtual bool Empty()

JScript

public function Empty() : boolean;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.ExportToMetafile Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.ExportToMetafile Method

 Return to chapter overview

Show / hide the hidden text

Exports the loaded CAD drawing to Windows metafile.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Sub ExportToMetafile( _
ByVal fileName As String, _
ByVal aWidth As Integer, _
ByVal aHeight As Integer _
)

C#

public virtual void ExportToMetafile(
stringfileName,
intaWidth,
intaHeight
)

C++

public:
virtual void ExportToMetafile(
String^ fileName,
intaWidth,
intaHeight
)

JScript

public function ExportToMetafile(
fileName : String,
aWidth : int,
aHeight : int
);

Parameters

fileName

Path to the output metafile.

aWidth

Width of the output metafile.

aHeight

Height of the output metafile.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.FindAutoCADSHXPaths Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.FindAutoCADSHXPaths Method

 Return to chapter overview

Show / hide the hidden text

Returns paths to the SHX fonts installed with Autodesk products (AutoCAD, DWG TrueView).

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function FindAutoCADSHXPaths() As String

C#

public virtual string FindAutoCADSHXPaths()

C++

public:
virtual String^ FindAutoCADSHXPaths()

JScript

public function FindAutoCADSHXPaths() : String;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.GetOpenDialogFilter Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.GetOpenDialogFilter Method

 Return to chapter overview

Show / hide the hidden text

Retrieves a string that indicates the file types and descriptions displayed in the control's open file dialog.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function GetOpenDialogFilter() As String

C#

public virtual string GetOpenDialogFilter()

C++

public:
virtual String^ GetOpenDialogFilter()

JScript

public function GetOpenDialogFilter() : String;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.GetSaveDialogFilter Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.GetSaveDialogFilter Method

 Return to chapter overview

Show / hide the hidden text

Retrieves a string that indicates the file types and descriptions displayed in the control's save file dialog.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function GetSaveDialogFilter() As String

C#

public virtual string GetSaveDialogFilter()

C++

public:
virtual String^ GetSaveDialogFilter()

JScript

public function GetSaveDialogFilter() : String;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.HasPrevScale Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.HasPrevScale Method

 Return to chapter overview

Show / hide the hidden text

Check if the drawing was scaled on the screen.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function HasPrevScale() As Boolean

C#

public virtual bool HasPrevScale()

C++

public:
virtual bool HasPrevScale()

JScript

public function HasPrevScale() : boolean;

Return Value

true if the drawing was scaled; otherwise, false.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.IsBadRect Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.IsBadRect Method

 Return to chapter overview

Show / hide the hidden text

Checks if the sizes of a specifed parallelepiped are defined correctly.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function IsBadRect( _
ByVal aRect As Rect3D _
) As Boolean

C#

public virtual bool IsBadRect(
Rect3DaRect
)

C++

public:
virtual bool IsBadRect(
Rect3D^ aRect
)

JScript

public function IsBadRect(
aRect : Rect3D
) : boolean;

Parameters

aRect

A variable that represents a Rect3D object.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.IsVectGraphic Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.IsVectGraphic Method

 Return to chapter overview

Show / hide the hidden text

Returns a value indicating whether the loaded file contains vector graphics.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function IsVectGraphic() As Boolean

C#

public virtual bool IsVectGraphic()

C++

public:
virtual bool IsVectGraphic()

JScript

public function IsVectGraphic() : boolean;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.LoadFile Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.LoadFile Method

 Return to chapter overview

Show / hide the hidden text

Loads a specified file.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Sub LoadFile( _
ByVal fileName As String _
)

C#

public virtual void LoadFile(
stringfileName
)

C++

public:
virtual void LoadFile(
String^ fileName
)

JScript

public function LoadFile(
fileName : String
);

Parameters

fileName

Path to the loaded file.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.LoadFromIni Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.LoadFromIni Method

 Return to chapter overview

Show / hide the hidden text

Loads the control's settings from a specified .ini file.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function LoadFromIni( _
ByVal iniFileName As String _
) As Boolean

C#

public virtual bool LoadFromIni(
stringiniFileName
)

C++

public:
virtual bool LoadFromIni(
String^ iniFileName
)

JScript

public function LoadFromIni(
iniFileName : String
) : boolean;

Parameters

iniFileName

Path to the .ini file.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.MkFPoint Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.MkFPoint Method

 Return to chapter overview

Show / hide the hidden text

Defines a point in the 3D space.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function MkFPoint( _
ByVal x As Double, _
ByVal y As Double, _
ByVal z As Double _
) As Point3D

C#

public virtual Point3D MkFPoint(
doublex,
doubley,
doublez
)

C++

public:
virtual Point3D^ MkFPoint(
doublex,
doubley,
doublez
)

JScript

public function MkFPoint(
x : double,
y : double,
z : double
) : Point3D;

Parameters

x

The x-coordinate of the 3D point.

y

The y-coordinate of the 3D point.

z

The z-coordinate of the 3D point.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.MkFRect Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.MkFRect Method

 Return to chapter overview

Show / hide the hidden text

Defines a parallelepiped (box).

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function MkFRect( _
ByVal left As Double, _
ByVal top As Double, _
ByVal z1 As Double, _
ByVal right As Double, _
ByVal bottom As Double, _
ByVal z2 As Double _
) As Rect3D

C#

public virtual Rect3D MkFRect(
doubleleft,
doubletop,
doublez1,
doubleright,
doublebottom,
doublez2
)

C++

public:
virtual Rect3D^ MkFRect(
doubleleft,
doubletop,
doublez1,
doubleright,
doublebottom,
doublez2
)

JScript

public function MkFRect(
left : double,
top : double,
z1 : double,
right : double,
bottom : double,
z2 : double
) : Rect3D;

Parameters

left

The x-coordinate of the top-left corner.

top

The y-coordinate of the top-left corner.

z1

The z-coordinate of the top-left corner.

right

The x-coordinate of the bottom-right corner.

bottom

The y-coordinate of the bottom-right corner.

z2

The z-coordinate of the bottom-right corner.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.OpenActiveViewPort Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.OpenActiveViewPort Method

 Return to chapter overview

Show / hide the hidden text

Displays the active viewport.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function OpenActiveViewPort() As Boolean

C#

public virtual bool OpenActiveViewPort()

C++

public:
virtual bool OpenActiveViewPort()

JScript

public function OpenActiveViewPort() : boolean;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.PictureRealign Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.PictureRealign Method

 Return to chapter overview

Show / hide the hidden text

Realigns the displayed image.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Sub PictureRealign()

C#

public virtual void PictureRealign()

C++

public:
virtual void PictureRealign()

JScript

public function PictureRealign();

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.PictureRect Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.PictureRect Method

 Return to chapter overview

Show / hide the hidden text

Returns the bounding rectangle for the displayed image.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function PictureRect() As Rect2D

C#

public virtual Rect2D PictureRect()

C++

public:
virtual Rect2D^ PictureRect()

JScript

public function PictureRect() : Rect2D;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.PictureRepaint Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.PictureRepaint Method

 Return to chapter overview

Show / hide the hidden text

Repaints the displayed image.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Sub PictureRepaint()

C#

public virtual void PictureRepaint()

C++

public:
virtual void PictureRepaint()

JScript

public function PictureRepaint();

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.Popup Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.Popup Method

 Return to chapter overview

Show / hide the hidden text

Displays the control's context menu at a given location of the screen.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Sub Popup( _
ByVal x As Integer, _
ByVal y As Integer _
)

C#

public virtual void Popup(
intx,
inty
)

C++

public:
virtual void Popup(
intx,
inty
)

JScript

public function Popup(
x : int,
y : int
);

Parameters

x

X-coordinate of the screen point.

y

Y-coordinate of the screen point.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.PrevScale Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.PrevScale Method

 Return to chapter overview

Show / hide the hidden text

Redraws the displayed image with a previous scale factor and boundaries.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Sub PrevScale()

C#

public virtual void PrevScale()

C++

public:
virtual void PrevScale()

JScript

public function PrevScale();

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.Print Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.Print Method

 Return to chapter overview

Show / hide the hidden text

Sends the loaded file to the current printer.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Sub Print()

C#

public virtual void Print()

C++

public:
virtual void Print()

JScript

public function Print();

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.PrintImage Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.PrintImage Method

 Return to chapter overview

Show / hide the hidden text

Sends the loaded file to the current printer.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Sub PrintImage()

C#

public virtual void PrintImage()

C++

public:
virtual void PrintImage()

JScript

public function PrintImage();

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.ProcessXML Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.ProcessXML Method

 Return to chapter overview

Show / hide the hidden text

Processes a string which contains the XML instructions.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function ProcessXML( _
ByVal aXML As String _
) As String

C#

public virtual string ProcessXML(
stringaXML
)

C++

public:
virtual String^ ProcessXML(
String^ aXML
)

JScript

public function ProcessXML(
aXML : String
) : String;

Parameters

aXML

The string which contains the XML instructions.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.RefreshAfterPictureAssign Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.RefreshAfterPictureAssign Method

 Return to chapter overview

Show / hide the hidden text

Forces the control to clear the internal data left from the previously loaded file.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Sub RefreshAfterPictureAssign()

C#

public virtual void RefreshAfterPictureAssign()

C++

public:
virtual void RefreshAfterPictureAssign()

JScript

public function RefreshAfterPictureAssign();

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.RefreshAfterRotate Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.RefreshAfterRotate Method

 Return to chapter overview

Show / hide the hidden text

Forces the control to refresh the image after rotation.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Sub RefreshAfterRotate()

C#

public virtual void RefreshAfterRotate()

C++

public:
virtual void RefreshAfterRotate()

JScript

public function RefreshAfterRotate();

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.SaveCopyToFile Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.SaveCopyToFile Method

 Return to chapter overview

Show / hide the hidden text

Copies the contents of the loaded file to a stream and saves the copy to a file.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Sub SaveCopyToFile( _
ByVal fileName As String _
)

C#

public virtual void SaveCopyToFile(
stringfileName
)

C++

public:
virtual void SaveCopyToFile(
String^ fileName
)

JScript

public function SaveCopyToFile(
fileName : String
);

Parameters

fileName

Path to the output file.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.SaveToFile Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.SaveToFile Method

 Return to chapter overview

Show / hide the hidden text

Saves the loaded drawing to a specified file.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Sub SaveToFile( _
ByVal fileName As String _
)

C#

public virtual void SaveToFile(
stringfileName
)

C++

public:
virtual void SaveToFile(
String^ fileName
)

JScript

public function SaveToFile(
fileName : String
);

Parameters

fileName

Path to the output file.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.SaveToFileEx Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.SaveToFileEx Method

 Return to chapter overview

Show / hide the hidden text

Saves the loaded drawing to a specified file.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Sub SaveToFileEx( _
ByVal fileName As String, _
ByVal confirm As Boolean, _
ByVal showSizeDialog As Boolean _
)

C#

public virtual void SaveToFileEx(
stringfileName,
boolconfirm,
boolshowSizeDialog
)

C++

public:
virtual void SaveToFileEx(
String^ fileName,
boolconfirm,
boolshowSizeDialog
)

JScript

public function SaveToFileEx(
fileName : String,
confirm : boolean,
showSizeDialog : boolean
);

Parameters

fileName

Path to the output file.

confirm

Value indicating whether the confirmation window will appear if the output file already exists.

showSizeDialog

Value indicating whether the Export file size dialog will appear.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.SaveToIni Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.SaveToIni Method

 Return to chapter overview

Show / hide the hidden text

Saves the control's settings to an .ini file

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function SaveToIni( _
ByVal iniFileName As String _
) As Boolean

C#

public virtual bool SaveToIni(
stringiniFileName
)

C++

public:
virtual bool SaveToIni(
String^ iniFileName
)

JScript

public function SaveToIni(
iniFileName : String
) : boolean;

Parameters

iniFileName

Path to the .ini file.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.ScaleImage Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.ScaleImage Method

 Return to chapter overview

Show / hide the hidden text

Applies the on-screen scaling to the displayed image.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function ScaleImage( _
ByVal abs As Boolean, _
ByVal coef As Double, _
ByVal x As Integer, _
ByVal y As Integer _
) As Integer

C#

public virtual int ScaleImage(
boolabs,
doublecoef,
intx,
inty
)

C++

public:
virtual int ScaleImage(
boolabs,
doublecoef,
intx,
inty
)

JScript

public function ScaleImage(
abs : boolean,
coef : double,
x : int,
y : int
) : int;

Parameters

abs

If set to true, then the absolute scaling will be applied; otherwise, the relative scaling.

coef

The scale factor.

x

X-coordinate of the base point.

y

Y-coordinate of the base point.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.ScaledRectPicture Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.ScaledRectPicture Method

 Return to chapter overview

Show / hide the hidden text

Captures a specified rectangle area as an Image object.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function ScaledRectPicture( _
ByVal x As Integer, _
ByVal y As Integer, _
ByVal scale As Double, _
ByVal dstWidth As Integer, _
ByVal dstHeight As Integer _
) As System.Drawing.Image

C#

public virtual System.Drawing.Image ScaledRectPicture(
intx,
inty,
doublescale,
intdstWidth,
intdstHeight
)

C++

public:
virtual System::Drawing::Image^ ScaledRectPicture(
intx,
inty,
doublescale,
intdstWidth,
intdstHeight
)

JScript

public function ScaledRectPicture(
x : int,
y : int,
scale : double,
dstWidth : int,
dstHeight : int
) : System.Drawing.Image;

Parameters

x

The x-coordinate of the top-left corner of the rectangle.

y

The y-coordinate of the top-left corner of the rectangle.

scale

The scale by which the size of the rectangle will be multiplied.

dstWidth

The width of the rectangle.

dstHeight

The height of the rectangle.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.SetImageBounds Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.SetImageBounds Method

 Return to chapter overview

Show / hide the hidden text

Sets the boundaries for the displayed image.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Sub SetImageBounds( _
ByVal aLeft As Integer, _
ByVal aTop As Integer, _
ByVal aWidth As Integer, _
ByVal aHeight As Integer _
)

C#

public virtual void SetImageBounds(
intaLeft,
intaTop,
intaWidth,
intaHeight
)

C++

public:
virtual void SetImageBounds(
intaLeft,
intaTop,
intaWidth,
intaHeight
)

JScript

public function SetImageBounds(
aLeft : int,
aTop : int,
aWidth : int,
aHeight : int
);

Parameters

aLeft

aTop

aWidth

aHeight

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.ShowAbout Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.ShowAbout Method

 Return to chapter overview

Show / hide the hidden text

Forces the control to display the About dialog window.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Sub ShowAbout()

C#

public virtual void ShowAbout()

C++

public:
virtual void ShowAbout()

JScript

public function ShowAbout();

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.ShowInfo Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.ShowInfo Method

 Return to chapter overview

Show / hide the hidden text

Displays a caption with a specified size.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Sub ShowInfo( _
ByVal aCaption As String, _
ByVal aWidth As Integer, _
ByVal aHeight As Integer, _
ByVal aFontSize As Integer _
)

C#

public virtual void ShowInfo(
stringaCaption,
intaWidth,
intaHeight,
intaFontSize
)

C++

public:
virtual void ShowInfo(
String^ aCaption,
intaWidth,
intaHeight,
intaFontSize
)

JScript

public function ShowInfo(
aCaption : String,
aWidth : int,
aHeight : int,
aFontSize : int
);

Parameters

aCaption

The caption text.

aWidth

The caption width.

aHeight

The caption height.

aFontSize

Font size of the caption text.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.ShowLayersDialog Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.ShowLayersDialog Method

 Return to chapter overview

Show / hide the hidden text

Forces the control to display the Layers dialog window.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Sub ShowLayersDialog()

C#

public virtual void ShowLayersDialog()

C++

public:
virtual void ShowLayersDialog()

JScript

public function ShowLayersDialog();

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.ShowPoint Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.ShowPoint Method

 Return to chapter overview

Show / hide the hidden text

Displays the image centered by a specified point with a certain scale factor.

collall Overload List

Name | Description
ShowPoint(Point3D, double) | Displays the image centered by a specified point with a certain scale factor.
ShowPoint(Point3D, double, Rect3D) | Displays the image centered by a specified point with a certain scale factor.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.ShowPointEx Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.ShowPointEx Method

 Return to chapter overview

Show / hide the hidden text

Displays the image centered by a specified point with a certain scale factor.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function ShowPointEx( _
ByVal x As Double, _
ByVal y As Double, _
ByVal z As Double, _
ByVal aScale As Double, _
ByVal aExtents As Rect3D _
) As Boolean

C#

public virtual bool ShowPointEx(
doublex,
doubley,
doublez,
doubleaScale,
Rect3DaExtents
)

C++

public:
virtual bool ShowPointEx(
doublex,
doubley,
doublez,
doubleaScale,
Rect3D^ aExtents
)

JScript

public function ShowPointEx(
x : double,
y : double,
z : double,
aScale : double,
aExtents : Rect3D
) : boolean;

Parameters

x

The x-coordinate of the centering point.

y

The y-coordinate of the centering point.

z

The z-coordinate of the centering point.

aScale

The scale factor.

aExtents

The parallelepiped indicating the drawing extents.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.ShowRect Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.ShowRect Method

 Return to chapter overview

Show / hide the hidden text

Displays the image centered by a specified rectangle area.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function ShowRect( _
ByVal aRect As Object _
) As Boolean

C#

public virtual bool ShowRect(
objectaRect
)

C++

public:
virtual bool ShowRect(
object^ aRect
)

JScript

public function ShowRect(
aRect : object
) : boolean;

Parameters

aRect

The rectangle area by which the image is centered.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.StRg Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.StRg Method

 Return to chapter overview

Show / hide the hidden text

Registers CADViewX developer license programmatically in the application.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function StRg( _
ByVal aUser As String, _
ByVal aEMail As String, _
ByVal aKey As String _
) As Integer

C#

public virtual int StRg(
stringaUser,
stringaEMail,
stringaKey
)

C++

public:
virtual int StRg(
String^ aUser,
String^ aEMail,
String^ aKey
)

JScript

public function StRg(
aUser : String,
aEMail : String,
aKey : String
) : int;

Parameters

aUser

The licensee name.

aEMail

The licensee's e-mail address.

aKey

License key.

Return Value

1 if the license was registered successfully, otherwise, 0.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.UsePictureRect Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.UsePictureRect Method

 Return to chapter overview

Show / hide the hidden text

NOTE: This member is now obsolete.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function UsePictureRect() As Boolean

C#

public virtual bool UsePictureRect()

C++

public:
virtual bool UsePictureRect()

JScript

public function UsePictureRect() : boolean;

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.Zoom Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.Zoom Method

 Return to chapter overview

Show / hide the hidden text

Zooms to a specified rectangle area on the loaded drawing.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function Zoom( _
ByVal rect As Rect2D _
) As Boolean

C#

public virtual bool Zoom(
Rect2Drect
)

C++

public:
virtual bool Zoom(
Rect2D^ rect
)

JScript

public function Zoom(
rect : Rect2D
) : boolean;

Parameters

rect

The rectangle area to which the drawing will be zoomed.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.get_EnabledAction Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.get_EnabledAction Method

 Return to chapter overview

Show / hide the hidden text

Returns a value indicating whether a specified toolbar button is enabled.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function get_EnabledAction( _
ByVal index As TxToolButton _
) As Boolean

C#

public virtual bool get_EnabledAction(
TxToolButtonindex
)

C++

public:
virtual bool get_EnabledAction(
TxToolButtonindex
)

JScript

public function get_EnabledAction(
index : TxToolButton
) : boolean;

Parameters

index

Index of the toolbar button.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.get_Items Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.get_Items Method

 Return to chapter overview

Show / hide the hidden text

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function get_Items( _
ByVal index As Integer _
) As CADViewX

C#

public virtual CADViewX get_Items(
intindex
)

C++

public:
virtual CADViewX^ get_Items(
intindex
)

JScript

public function get_Items(
index : int
) : CADViewX;

Parameters

index

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.get_Languages Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.get_Languages Method

 Return to chapter overview

Show / hide the hidden text

Retrieves a GUI language name by its index.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function get_Languages( _
ByVal index As Integer _
) As String

C#

public virtual string get_Languages(
intindex
)

C++

public:
virtual String^ get_Languages(
intindex
)

JScript

public function get_Languages(
index : int
) : String;

Parameters

index

Language index.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.get_Printer Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.get_Printer Method

 Return to chapter overview

Show / hide the hidden text

Retrieves a printer name by its index.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function get_Printer( _
ByVal index As Integer _
) As String

C#

public virtual string get_Printer(
intindex
)

C++

public:
virtual String^ get_Printer(
intindex
)

JScript

public function get_Printer(
index : int
) : String;

Parameters

index

The index of the printer.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.get_VisibleAction Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.get_VisibleAction Method

 Return to chapter overview

Show / hide the hidden text

Returns a value indicating whether a specified toolbar button is visible.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Function get_VisibleAction( _
ByVal index As TxToolButton _
) As Boolean

C#

public virtual bool get_VisibleAction(
TxToolButtonindex
)

C++

public:
virtual bool get_VisibleAction(
TxToolButtonindex
)

JScript

public function get_VisibleAction(
index : TxToolButton
) : boolean;

Parameters

index

Index of the toolbar button.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.set_EnabledAction Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.set_EnabledAction Method

 Return to chapter overview

Show / hide the hidden text

Makes a specified toolbar button enabled or disabled.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Sub set_EnabledAction( _
ByVal index As TxToolButton, _
ByVal value As Boolean _
)

C#

public virtual void set_EnabledAction(
TxToolButtonindex,
boolvalue
)

C++

public:
virtual void set_EnabledAction(
TxToolButtonindex,
boolvalue
)

JScript

public function set_EnabledAction(
index : TxToolButton,
value : boolean
);

Parameters

index

Index of the toobar button.

value

If set to true, then the button is enabled; otherwise, the button is disabled.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.set_Printer Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.set_Printer Method

 Return to chapter overview

Show / hide the hidden text

Changes a local name of the printer at the given index.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Sub set_Printer( _
ByVal index As Integer, _
ByVal value As String _
)

C#

public virtual void set_Printer(
intindex,
stringvalue
)

C++

public:
virtual void set_Printer(
intindex,
String^ value
)

JScript

public function set_Printer(
index : int,
value : String
);

Parameters

index

The index of the printer.

value

New printer name.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.set_VisibleAction Method

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Methods >

AxCADViewX.set_VisibleAction Method

 Return to chapter overview

Show / hide the hidden text

Makes a specified toolbar button visible or hidden.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Sub set_VisibleAction( _
ByVal index As TxToolButton, _
ByVal value As Boolean _
)

C#

public virtual void set_VisibleAction(
TxToolButtonindex,
boolvalue
)

C++

public:
virtual void set_VisibleAction(
TxToolButtonindex,
boolvalue
)

JScript

public function set_VisibleAction(
index : TxToolButton,
value : boolean
);

Parameters

index

Index of the toobar button.

value

If set to true, then the button is visible; otherwise, the button is hidden.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX Events

API Reference > AxCADViewLib Namespace > AxCADViewX Class >

AxCADViewX Events

 Return to chapter overview

Show / hide the hidden text

collall Public Events

 | Name | Description
Public event | OnActivate | Occurs when the control is activated.
Public event | OnAfterLoad | Occurs when the drawing file is loaded.
Public event | OnBeforeLoad | Occurs before loading of the drawing file.
Public event | OnClick | Occurs when the control is clicked by the mouse.
Public event | OnCreate | Occurs when the control instance is created.
Public event | OnDblClick | Occurs when the control is double clicked by the mouse.
Public event | OnDeactivate | Occurs when the control is deactivated.
Public event | OnDestroy | Occurs when the control instance is destroyed.
Public event | OnIterate | Occurs when iterating through the entities in the drawing file.
Public event | OnKeyDown | Occurs when a key is pressed while the control has focus.
Public event | OnKeyPress | Occurs when a character, space or backspace key is pressed while the control has focus.
Public event | OnLayoutChange | Occurs when switching between layouts in the loaded drawing.
Public event | OnMouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed.
Public event | OnMouseMove | Occurs when the mouse pointer is moved over the control.
Public event | OnMouseUp | Occurs when the mouse pointer is over the control and a mouse button is released.
Public event | OnMouseWheelDown | Occurs when the mouse wheel moves down while the control has focus.
Public event | OnMouseWheelUp | Occurs when the mouse wheel moves up while the control has focus.
Public event | OnPaint | Occurs when the control is redrawn.
Public event | OnProcess | Occurs when an XML instruction is processed.
Public event | OnProgress | Occurs when the file loading in progress.
Public event | OnScaling | Occurs when the displayed image is scaled.
Public event | OnToolButtonClick | Occurs when the toolbar button is clicked by the mouse.

Top

collall See Also

Reference

AxCADViewX Class
AxCADViewLib Namespace


OnActivate Event

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Events >

OnActivate Event

 Return to chapter overview

Show / hide the hidden text

Occurs when the control is activated.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Event OnActivate() As System.EventHandler

C#

public event System.EventHandler OnActivate

C++

public:
event System::EventHandler^ OnActivate {
}

JScript

JScript supports the use of events, but not the declaration of new ones.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


OnAfterLoad Event

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Events >

OnAfterLoad Event

 Return to chapter overview

Show / hide the hidden text

Occurs when the drawing file is loaded.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Event OnAfterLoad() As System.EventHandler

C#

public event System.EventHandler OnAfterLoad

C++

public:
event System::EventHandler^ OnAfterLoad {
}

JScript

JScript supports the use of events, but not the declaration of new ones.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


OnBeforeLoad Event

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Events >

OnBeforeLoad Event

 Return to chapter overview

Show / hide the hidden text

Occurs before loading of the drawing file.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Event OnBeforeLoad() As System.EventHandler

C#

public event System.EventHandler OnBeforeLoad

C++

public:
event System::EventHandler^ OnBeforeLoad {
}

JScript

JScript supports the use of events, but not the declaration of new ones.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


OnClick Event

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Events >

OnClick Event

 Return to chapter overview

Show / hide the hidden text

Occurs when the control is clicked by the mouse.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Event OnClick() As System.EventHandler

C#

public event System.EventHandler OnClick

C++

public:
event System::EventHandler^ OnClick {
}

JScript

JScript supports the use of events, but not the declaration of new ones.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


OnCreate Event

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Events >

OnCreate Event

 Return to chapter overview

Show / hide the hidden text

Occurs when the control instance is created.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Event OnCreate() As System.EventHandler

C#

public event System.EventHandler OnCreate

C++

public:
event System::EventHandler^ OnCreate {
}

JScript

JScript supports the use of events, but not the declaration of new ones.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


OnDblClick Event

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Events >

OnDblClick Event

 Return to chapter overview

Show / hide the hidden text

Occurs when the control is double clicked by the mouse.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Event OnDblClick() As System.EventHandler

C#

public event System.EventHandler OnDblClick

C++

public:
event System::EventHandler^ OnDblClick {
}

JScript

JScript supports the use of events, but not the declaration of new ones.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


OnDeactivate Event

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Events >

OnDeactivate Event

 Return to chapter overview

Show / hide the hidden text

Occurs when the control is deactivated.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Event OnDeactivate() As System.EventHandler

C#

public event System.EventHandler OnDeactivate

C++

public:
event System::EventHandler^ OnDeactivate {
}

JScript

JScript supports the use of events, but not the declaration of new ones.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


OnDestroy Event

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Events >

OnDestroy Event

 Return to chapter overview

Show / hide the hidden text

Occurs when the control instance is destroyed.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Event OnDestroy() As System.EventHandler

C#

public event System.EventHandler OnDestroy

C++

public:
event System::EventHandler^ OnDestroy {
}

JScript

JScript supports the use of events, but not the declaration of new ones.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


OnIterate Event

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Events >

OnIterate Event

 Return to chapter overview

Show / hide the hidden text

Occurs when iterating through the entities in the drawing file.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Event OnIterate() As CADViewLib.ICADViewXEvents_OnIterateEventHandler

C#

public event CADViewLib.ICADViewXEvents_OnIterateEventHandler OnIterate

C++

public:
event CADViewLib::ICADViewXEvents_OnIterateEventHandler^ OnIterate {
}

JScript

JScript supports the use of events, but not the declaration of new ones.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


OnKeyDown Event

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Events >

OnKeyDown Event

 Return to chapter overview

Show / hide the hidden text

Occurs when a key is pressed while the control has focus.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Event OnKeyDown() As CADViewLib.ICADViewXEvents_OnKeyDownEventHandler

C#

public event CADViewLib.ICADViewXEvents_OnKeyDownEventHandler OnKeyDown

C++

public:
event CADViewLib::ICADViewXEvents_OnKeyDownEventHandler^ OnKeyDown {
}

JScript

JScript supports the use of events, but not the declaration of new ones.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


OnKeyPress Event

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Events >

OnKeyPress Event

 Return to chapter overview

Show / hide the hidden text

Occurs when a character, space or backspace key is pressed while the control has focus.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Event OnKeyPress() As CADViewLib.ICADViewXEvents_OnKeyPressEventHandler

C#

public event CADViewLib.ICADViewXEvents_OnKeyPressEventHandler OnKeyPress

C++

public:
event CADViewLib::ICADViewXEvents_OnKeyPressEventHandler^ OnKeyPress {
}

JScript

JScript supports the use of events, but not the declaration of new ones.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


OnLayoutChange Event

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Events >

OnLayoutChange Event

 Return to chapter overview

Show / hide the hidden text

Occurs when switching between layouts in the loaded drawing.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Event OnLayoutChange() As System.EventHandler

C#

public event System.EventHandler OnLayoutChange

C++

public:
event System::EventHandler^ OnLayoutChange {
}

JScript

JScript supports the use of events, but not the declaration of new ones.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


OnMouseDown Event

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Events >

OnMouseDown Event

 Return to chapter overview

Show / hide the hidden text

Occurs when the mouse pointer is over the control and a mouse button is pressed.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Event OnMouseDown() As CADViewLib.ICADViewXEvents_OnMouseDownEventHandler

C#

public event CADViewLib.ICADViewXEvents_OnMouseDownEventHandler OnMouseDown

C++

public:
event CADViewLib::ICADViewXEvents_OnMouseDownEventHandler^ OnMouseDown {
}

JScript

JScript supports the use of events, but not the declaration of new ones.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


OnMouseMove Event

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Events >

OnMouseMove Event

 Return to chapter overview

Show / hide the hidden text

Occurs when the mouse pointer is moved over the control.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Event OnMouseMove() As CADViewLib.ICADViewXEvents_OnMouseMoveEventHandler

C#

public event CADViewLib.ICADViewXEvents_OnMouseMoveEventHandler OnMouseMove

C++

public:
event CADViewLib::ICADViewXEvents_OnMouseMoveEventHandler^ OnMouseMove {
}

JScript

JScript supports the use of events, but not the declaration of new ones.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


OnMouseUp Event

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Events >

OnMouseUp Event

 Return to chapter overview

Show / hide the hidden text

Occurs when the mouse pointer is over the control and a mouse button is released.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Event OnMouseUp() As CADViewLib.ICADViewXEvents_OnMouseUpEventHandler

C#

public event CADViewLib.ICADViewXEvents_OnMouseUpEventHandler OnMouseUp

C++

public:
event CADViewLib::ICADViewXEvents_OnMouseUpEventHandler^ OnMouseUp {
}

JScript

JScript supports the use of events, but not the declaration of new ones.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


OnMouseWheelDown Event

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Events >

OnMouseWheelDown Event

 Return to chapter overview

Show / hide the hidden text

Occurs when the mouse wheel moves down while the control has focus.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Event OnMouseWheelDown() As CADViewLib.ICADViewXEvents_OnMouseWheelDownEventHandler

C#

public event CADViewLib.ICADViewXEvents_OnMouseWheelDownEventHandler OnMouseWheelDown

C++

public:
event CADViewLib::ICADViewXEvents_OnMouseWheelDownEventHandler^ OnMouseWheelDown {
}

JScript

JScript supports the use of events, but not the declaration of new ones.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


OnMouseWheelUp Event

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Events >

OnMouseWheelUp Event

 Return to chapter overview

Show / hide the hidden text

Occurs when the mouse wheel moves up while the control has focus.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Event OnMouseWheelUp() As CADViewLib.ICADViewXEvents_OnMouseWheelUpEventHandler

C#

public event CADViewLib.ICADViewXEvents_OnMouseWheelUpEventHandler OnMouseWheelUp

C++

public:
event CADViewLib::ICADViewXEvents_OnMouseWheelUpEventHandler^ OnMouseWheelUp {
}

JScript

JScript supports the use of events, but not the declaration of new ones.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


OnPaint Event

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Events >

OnPaint Event

 Return to chapter overview

Show / hide the hidden text

Occurs when the control is redrawn.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Event OnPaint() As System.EventHandler

C#

public event System.EventHandler OnPaint

C++

public:
event System::EventHandler^ OnPaint {
}

JScript

JScript supports the use of events, but not the declaration of new ones.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


OnProcess Event

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Events >

OnProcess Event

 Return to chapter overview

Show / hide the hidden text

Occurs when an XML instruction is processed.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Event OnProcess() As CADViewLib.ICADViewXEvents_OnProcessEventHandler

C#

public event CADViewLib.ICADViewXEvents_OnProcessEventHandler OnProcess

C++

public:
event CADViewLib::ICADViewXEvents_OnProcessEventHandler^ OnProcess {
}

JScript

JScript supports the use of events, but not the declaration of new ones.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace
ProcessXML


OnProgress Event

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Events >

OnProgress Event

 Return to chapter overview

Show / hide the hidden text

Occurs when the file loading in progress.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Event OnProgress() As CADViewLib.ICADViewXEvents_OnProgressEventHandler

C#

public event CADViewLib.ICADViewXEvents_OnProgressEventHandler OnProgress

C++

public:
event CADViewLib::ICADViewXEvents_OnProgressEventHandler^ OnProgress {
}

JScript

JScript supports the use of events, but not the declaration of new ones.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


OnScaling Event

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Events >

OnScaling Event

 Return to chapter overview

Show / hide the hidden text

Occurs when the displayed image is scaled.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Event OnScaling() As System.EventHandler

C#

public event System.EventHandler OnScaling

C++

public:
event System::EventHandler^ OnScaling {
}

JScript

JScript supports the use of events, but not the declaration of new ones.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


OnToolButtonClick Event

API Reference > AxCADViewLib Namespace > AxCADViewX Class > Events >

OnToolButtonClick Event

 Return to chapter overview

Show / hide the hidden text

Occurs when the toolbar button is clicked by the mouse.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Event OnToolButtonClick() As CADViewLib.ICADViewXEvents_OnToolButtonClickEventHandler

C#

public event CADViewLib.ICADViewXEvents_OnToolButtonClickEventHandler OnToolButtonClick

C++

public:
event CADViewLib::ICADViewXEvents_OnToolButtonClickEventHandler^ OnToolButtonClick {
}

JScript

JScript supports the use of events, but not the declaration of new ones.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


CADViewLib Namespace

API Reference >

CADViewLib Namespace

 Return to chapter overview

Show / hide the hidden text

Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Interfaces

 | Name | Description
Public interface | Arc | Provides an access to ARC entities.
Public interface | AttDef | Provides an access to ATTDEF entities.
Public interface | Attrib | Provides an access to ATTRIB entities.
Public interface | Block | Provides an access to BLOCK entities.
Public interface | CADLine | Provides an access to LINE entities.
Public interface | CADViewX | Provides an access to CADViewX control.
Public interface | CGMImage | Provides an access to a CGM drawing.
Public interface | Circle | Provides an access to CIRCLE entities.
Public interface | Converter | Provides an access to the sections of the drawing database.
Public interface | DWGImage | Provides an access to a DWG drawing.
Public interface | DXFImage | Provides an access to a DXF drawing.
Public interface | Dimension | Provides an access to DIMENSION entities.
Public interface | Ellipse | Provides an access to ELLIPSE entities.
Public interface | Entity | Provides an access to an entity in the drawing database.
Public interface | Group | Provides an access to a group of objects.
Public interface | HPGLImage | Provides an access to an HPGL drawing.
Public interface | IArc | Provides an access to ARC entities.
Public interface | IAttDef | Provides an access to ATTDEF entities.
Public interface | IAttrib | Provides an access to ATTRIB entities.
Public interface | IBlock | Provides an access to BLOCK entities.
Public interface | ICADLine | Provides an access to LINE entities.
Public interface | ICADViewX | Provides an access to CADViewX control.
Public interface | ICGMImage | Provides an access to a CGM drawing.
Public interface | ICircle | Provides an access to CIRCLE entities.
Public interface | IConverter | Provides an access to the sections of the drawing database.
Public interface | IDWGImage | Provides an access to a DWG drawing.
Public interface | IDXFImage | Provides an access to a DXF drawing.
Public interface | IDimension | Provides an access to DIMENSION entities.
Public interface | IEllipse | Provides an access to ELLIPSE entities.
Public interface | IEntity | Provides an access to an entity in the drawing database.
Public interface | IGroup | Provides an access to a group of objects.
Public interface | IHPGLImage | Provides an access to an HPGL drawing.
Public interface | IImageEnt | Provides an access to IMAGE entities.
Public interface | IInsert | Provides an access to INSERT entities.
Public interface | ILayer | Provides an access to LAYER objects.
Public interface | ILayout | Provides an access to LAYOUT objects.
Public interface | IPoint2D | Provides an access to 2D points.
Public interface | IPoint3D | Provides an access to 3D points.
Public interface | IPolyline | Provides an access to POLYLINE and LWPOLYLINE entities.
Public interface | IRect2D | Provides an access to a bounding rectangle.
Public interface | IRect3D | Provides an access to a bounding parallelepiped (box).
Public interface | ISVGImage | Provides an access to an SVG drawing.
Public interface | ISolid | Provides an access to SOLID entities.
Public interface | ISpline | Provides an access to SPLINE entities.
Public interface | IText | Provides an access to TEXT entities.
Public interface | IToolBox | Provides an access to the CADViewX toolbar.
Public interface | IVertex | Provides an access to VERTEX entities.
Public interface | ImageEnt | Provides an access to IMAGE entities.
Public interface | Insert | Provides an access to INSERT entities.
Public interface | Layer | Provides an access to LAYER objects.
Public interface | Layout | Provides an access to LAYOUT objects.
Public interface | Point2D | Provides an access to 2D points.
Public interface | Point3D | Provides an access to 3D points.
Public interface | Polyline | Provides an access to POLYLINE and LWPOLYLINE entities.
Public interface | Rect2D | Provides an access to a bounding rectangle.
Public interface | Rect3D | Provides an access to a bounding parallelepiped (box).
Public interface | SVGImage | Provides an access to an SVG drawing.
Public interface | Solid | Provides an access to SOLID entities.
Public interface | Spline | Provides an access to SPLINE entities.
Public interface | Text | Provides an access to TEXT entities.
Public interface | ToolBox | Provides an access to the CADViewX toolbar.
Public interface | Vertex | Provides an access to VERTEX entities.

Top

collall Delegates

 | Name | Description
Public delegate | ICADViewXEvents_OnActivateEventHandler | Delegate for the OnActivate event.
Public delegate | ICADViewXEvents_OnAfterLoadEventHandler | Delegate for the OnAfterLoad event.
Public delegate | ICADViewXEvents_OnBeforeLoadEventHandler | Delegate for the OnBeforeLoad event.
Public delegate | ICADViewXEvents_OnClickEventHandler | Delegate for the OnClick event.
Public delegate | ICADViewXEvents_OnCreateEventHandler | Delegate for the OnCreate event.
Public delegate | ICADViewXEvents_OnDblClickEventHandler | Delegate for the OnDblClick event.
Public delegate | ICADViewXEvents_OnDeactivateEventHandler | Delegate for the OnDeactivate event.
Public delegate | ICADViewXEvents_OnDestroyEventHandler | Delegate for the OnDestroy event.
Public delegate | ICADViewXEvents_OnIterateEventHandler | Delegate for the OnIterate event.
Public delegate | ICADViewXEvents_OnKeyDownEventHandler | Delegate for the OnKeyDown event.
Public delegate | ICADViewXEvents_OnKeyPressEventHandler | Delegate for the OnKeyPress event.
Public delegate | ICADViewXEvents_OnLayoutChangeEventHandler | Delegate for the OnLayoutChange event.
Public delegate | ICADViewXEvents_OnMouseDownEventHandler | Delegate for the OnMouseDown event.
Public delegate | ICADViewXEvents_OnMouseMoveEventHandler | Delegate for the OnMouseMove event.
Public delegate | ICADViewXEvents_OnMouseUpEventHandler | Delegate for the OnMouseUp event.
Public delegate | ICADViewXEvents_OnMouseWheelDownEventHandler | Delegate for the OnMouseWheelDown event.
Public delegate | ICADViewXEvents_OnMouseWheelUpEventHandler | Delegate for the OnMouseWheelUp event.
Public delegate | ICADViewXEvents_OnPaintEventHandler | Delegate for the OnPaint event.
Public delegate | ICADViewXEvents_OnProcessEventHandler | Delegate for the OnProcess event.
Public delegate | ICADViewXEvents_OnProgressEventHandler | Delegate for the OnProgress event.
Public delegate | ICADViewXEvents_OnScalingEventHandler | Delegate for the OnScaling event.
Public delegate | ICADViewXEvents_OnToolButtonClickEventHandler | Delegate for the OnToolButtonClick event.

Top

collall Enumerations

 | Name | Description
Public enumeration | TAcadVersion | Indicates a version of an AutoCAD® drawing file.
Public enumeration | TDistanceUnits | Indicates the drawing units.
Public enumeration | TEntityID | Indicates the entity type ID.
Public enumeration | TxActiveFormBorderStyle | Indicates the border style for the control.
Public enumeration | TxAlign | Indicates the alignment of a control.
Public enumeration | TxAxes | Indicates a 3D axis.
Public enumeration | TxCADClassID | Indicates the CAD drawing type ID.
Public enumeration | TxCADSpace | Indicates the type of CAD space.
Public enumeration | TxColorDepth | Indicates the color depth (in bits per pixel).
Public enumeration | TxConvSection | Indicates a section in the drawing database.
Public enumeration | TxDXFDrawMode | Indicates the appearance of colors in a drawing.
Public enumeration | TxDXFViewDirection | Indicates orthographic and isometric views.
Public enumeration | TxMouseButton | Indicates the mouse button that was clicked.
Public enumeration | TxPaperOrientation | Indicates the paper orientation.
Public enumeration | TxPrintScale | Indicates how a drawing will be scaled on print.
Public enumeration | TxProgressStage | Indicates the current stage of the file loading progress.
Public enumeration | TxShiftState | Indicates what modifier keys and mouse buttons were held down in combination with a normal key.
Public enumeration | TxToolButton | Indicates the toolbar button or context menu item.
Public enumeration | TxsgBorderType | Indicates how a value of the drawing border size is calculated.

Top


Arc Interface

API Reference > CADViewLib Namespace >

Arc Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to ARC entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface Arc
Inherits IArc, _
IEntityEvents_Event

C#

public interface Arc : IArc,
IEntityEvents_Event

C++

public interface class Arc : public IArc^,
public IEntityEvents_Event^

JScript

public interface Arc
implements IArc,
IEntityEvents_Event

collall See Also

Reference

Arc Members
CADViewLib Namespace


Arc Members

API Reference > CADViewLib Namespace > Arc Interface >

Arc Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to ARC entities.

The following tables list the members exposed by the Arc type.

collall Public Properties

 | Name | Description
Public property | ArrowsCount | Gets a quantity of points that form an arrow. (inherited from IArc ).
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from IArc ).
Public property | CADHandle | Gets or sets the object handle. (inherited from IArc ).
Public property | Closed | Gets or sets a value indicating whether this polyline is closed. (inherited from IArc ).
Public property | Color | Gets or sets a color of the object. (inherited from IArc ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from IArc ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from IArc ).
Public property | DottedPointsCount | Gets a quantity of points that determine the dots and dashes for a polyline with non-solid line type. (inherited from IArc ).
Public property | EndAngle | Gets or sets the end angle. (inherited from IArc ).
Public property | EndPoint | Gets or sets the end point of arc/ellipse (inherited from IArc ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from IArc ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from IArc ).
Public property | Flags | Gets or sets a bit-coded flag indicating the polyline type. (inherited from IArc ).
Public property | GlobalWidth | Gets or sets a global width for this polyline. (inherited from IArc ).
Public property | IsMeshMClosed | Gets a value indicating whether the polygon mesh is closed in the M direction. (inherited from IArc ).
Public property | IsMeshNClosed | Gets a value indicating whether the polygon mesh is closed in the N direction. (inherited from IArc ).
Public property | IsPolyFaceMesh | Gets a value indicating whether this polyline is a polyface mesh. (inherited from IArc ).
Public property | IsPolyZThickness | Gets a value indicating whether the polyline has thickness measured along the axis Z. (inherited from IArc ).
Public property | IsPolygonMesh | Gets a value indicating whether this polyline is a polygon mesh. (inherited from IArc ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from IArc ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from IArc ).
Public property | MeshM | Gets or sets a number of vertices for the polygon mesh in the M direction. (inherited from IArc ).
Public property | MeshN | Gets or sets a number of vertices for the polygon mesh in the N direction. (inherited from IArc ).
Public property | Name | Gets or sets a name of this object. (inherited from IArc ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from IArc ).
Public property | PenLine | Gets properties of the pen used for drawing the object. (inherited from IArc ).
Public property | Point | Gets or sets the center point. (inherited from IArc ).
Public property | PointsCount | Gets a number of the polyline points. (inherited from IArc ).
Public property | PolyFaceVertexIndexesCount | Gets a quantity of indices which specify the order of traversing vertices in the polyface mesh. (inherited from IArc ).
Public property | Radius | Gets or sets a radius of the circle/ellipse/arc. (inherited from IArc ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from IArc ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from IArc ).
Public property | StartAngle | Gets or sets the start angle. (inherited from IArc ).
Public property | StartPoint | Gets or sets the start point of arc/ellipse (inherited from IArc ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from IArc ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from IArc ).

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from IArc ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from IArc ).
Public method | CreateEntity | Initializes a new object instance. (inherited from IArc ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from IArc ).
Public method | EntName | Returns a name of the entity. (inherited from IArc ).
Public method | FreeEntity | Destroys the object instance. (inherited from IArc ).
Public method | GetArea | Returns the area bounded by a closed polygon. (inherited from IArc ).
Public method | GetBoxPoints | For internal use. (inherited from IArc ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from IArc ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from IArc ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from IArc ).
Public method | RemoveEntity | Removes a specified entity. (inherited from IArc ).
Public method | SetLType | Sets a line type for this object. (inherited from IArc ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from IArc ).
Public method | get_Arrows | Returns a point of the arrowhead. (inherited from IArc ).
Public method | get_DottedPoints | Returns coordinates of a point in the points array that determines dots and dashes for a non-solid line type. (inherited from IArc ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from IArc ).
Public method | get_Points | Returns coordinates of a point in the points array. (inherited from IArc ).
Public method | get_PolyFaceVertexIndexes | Returns a value which indicates an index of the polyface mesh vertex. (inherited from IArc ).
Public method | set_Arrows | Modifies a point of the arrowhead at the given index. (inherited from IArc ).

Top

collall See Also

Reference

Arc Interface


Arc Properties

API Reference > CADViewLib Namespace > Arc Interface >

Arc Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | ArrowsCount | Gets a quantity of points that form an arrow. (inherited from IArc ).
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from IArc ).
Public property | CADHandle | Gets or sets the object handle. (inherited from IArc ).
Public property | Closed | Gets or sets a value indicating whether this polyline is closed. (inherited from IArc ).
Public property | Color | Gets or sets a color of the object. (inherited from IArc ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from IArc ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from IArc ).
Public property | DottedPointsCount | Gets a quantity of points that determine the dots and dashes for a polyline with non-solid line type. (inherited from IArc ).
Public property | EndAngle | Gets or sets the end angle. (inherited from IArc ).
Public property | EndPoint | Gets or sets the end point of arc/ellipse (inherited from IArc ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from IArc ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from IArc ).
Public property | Flags | Gets or sets a bit-coded flag indicating the polyline type. (inherited from IArc ).
Public property | GlobalWidth | Gets or sets a global width for this polyline. (inherited from IArc ).
Public property | IsMeshMClosed | Gets a value indicating whether the polygon mesh is closed in the M direction. (inherited from IArc ).
Public property | IsMeshNClosed | Gets a value indicating whether the polygon mesh is closed in the N direction. (inherited from IArc ).
Public property | IsPolyFaceMesh | Gets a value indicating whether this polyline is a polyface mesh. (inherited from IArc ).
Public property | IsPolyZThickness | Gets a value indicating whether the polyline has thickness measured along the axis Z. (inherited from IArc ).
Public property | IsPolygonMesh | Gets a value indicating whether this polyline is a polygon mesh. (inherited from IArc ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from IArc ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from IArc ).
Public property | MeshM | Gets or sets a number of vertices for the polygon mesh in the M direction. (inherited from IArc ).
Public property | MeshN | Gets or sets a number of vertices for the polygon mesh in the N direction. (inherited from IArc ).
Public property | Name | Gets or sets a name of this object. (inherited from IArc ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from IArc ).
Public property | PenLine | Gets properties of the pen used for drawing the object. (inherited from IArc ).
Public property | Point | Gets or sets the center point. (inherited from IArc ).
Public property | PointsCount | Gets a number of the polyline points. (inherited from IArc ).
Public property | PolyFaceVertexIndexesCount | Gets a quantity of indices which specify the order of traversing vertices in the polyface mesh. (inherited from IArc ).
Public property | Radius | Gets or sets a radius of the circle/ellipse/arc. (inherited from IArc ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from IArc ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from IArc ).
Public property | StartAngle | Gets or sets the start angle. (inherited from IArc ).
Public property | StartPoint | Gets or sets the start point of arc/ellipse (inherited from IArc ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from IArc ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from IArc ).

Top

collall See Also

Reference

Arc Interface


IArc.ArrowsCount Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.ArrowsCount Property

 Return to chapter overview

Show / hide the hidden text

Gets a quantity of points that form an arrow.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property ArrowsCount() As Integer

C#

int ArrowsCount {get;}

C++

property int ArrowsCount {
int get( );
}

JScript

function get ArrowsCount() : int;

Property Value

An Integer type value indicating a quantity of points that form an arrow.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.Box Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.Box Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the bounding parallelepiped for the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Box() As Rect3D

C#

Rect3D Box {get;}

C++

property Rect3D^ Box {
Rect3D^ get( );
}

JScript

function get Box() : Rect3D;

Property Value

The parallelepiped which encloses the object.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.CADHandle Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.CADHandle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the object handle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CADHandle() As UInt64

C#

UInt64 CADHandle {get; set;}

C++

property UInt64 CADHandle {
UInt64 get( );
void set(
UInt64 value
);
}

JScript

function get CADHandle() : UInt64;
function set CADHandle(value : UInt64);

Property Value

Number that uniquely identifies the object in a CAD drawing.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.Closed Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.Closed Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this polyline is closed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Closed() As Boolean

C#

bool Closed {get; set;}

C++

property bool Closed {
bool get( );
void set(
bool value
);
}

JScript

function get Closed() : boolean;
function set Closed(value : boolean);

Property Value

true if the polyline is closed; otherwise, false

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.Color Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.Color Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a color of the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Color() As UInt32

C#

UInt32 Color {get; set;}

C++

property UInt32 Color {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get Color() : UInt32;
function set Color(value : UInt32);

Property Value

An insigned integer value which defines the object's color.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.Converter Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.Converter Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a Converter instance associated with the CAD image to which this object belongs.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Converter() As Converter

C#

Converter Converter {get;}

C++

property Converter^ Converter {
Converter^ get( );
}

JScript

function get Converter() : Converter;

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.Count Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.Count Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of objects contained within the given object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Count() As Integer

C#

int Count {get;}

C++

property int Count {
int get( );
}

JScript

function get Count() : int;

Property Value

An Integer value indicating a number of objects contained within the given object.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.DottedPointsCount Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.DottedPointsCount Property

 Return to chapter overview

Show / hide the hidden text

Gets a quantity of points that determine the dots and dashes for a polyline with non-solid line type.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property DottedPointsCount() As Integer

C#

int DottedPointsCount {get;}

C++

property int DottedPointsCount {
int get( );
}

JScript

function get DottedPointsCount() : int;

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.EndAngle Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.EndAngle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the end angle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property EndAngle() As Double

C#

double EndAngle {get; set;}

C++

property double EndAngle {
double get( );
void set(
double value
);
}

JScript

function get EndAngle() : double;
function set EndAngle(value : double);

Property Value

Double type value indicating the end angle.

collall Remarks

The angle direction is counterclockwise.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.EndPoint Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.EndPoint Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the end point of arc/ellipse

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property EndPoint() As Point3D

C#

Point3D EndPoint {get; set;}

C++

property Point3D^ EndPoint {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get EndPoint() : Point3D;
function set EndPoint(value : Point3D);

Property Value

Point3D type value indicating the end point.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.EntID Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.EntID Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the entity type ID for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property EntID() As TEntityID

C#

TEntityID EntID {get; set;}

C++

property TEntityID EntID {
TEntityID get( );
void set(
TEntityID value
);
}

JScript

function get EntID() : TEntityID;
function set EntID(value : TEntityID);

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.Extrusion Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.Extrusion Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the extrusion direction vector for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Extrusion() As Point3D

C#

Point3D Extrusion {get; set;}

C++

property Point3D^ Extrusion {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Extrusion() : Point3D;
function set Extrusion(value : Point3D);

Property Value

The 3D point which defines the extrusion direction vector.

collall Remarks

The extrusion direction is the normal vector of the plane which contains the entity and it is applied to the entity base point. The default extrusion direction value is (0, 0, 1).

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.Flags Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.Flags Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a bit-coded flag indicating the polyline type.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Flags() As Integer

C#

int Flags {get; set;}

C++

property int Flags {
int get( );
void set(
int value
);
}

JScript

function get Flags() : int;
function set Flags(value : int);

Property Value

0 = Default value
1 = This is a closed polyline (or a polygon mesh closed in the M direction)
2 = Curve-fit vertices have been added
4 = Spline-fit vertices have been added
8 = This is a 3D polyline
16 = This is a 3D polygon mesh
32 = The polygon mesh is closed in the N direction
64 = The polyline is a polyface mesh
128 = The linetype pattern is generated continuously around the vertices of this polyline

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.GlobalWidth Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.GlobalWidth Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a global width for this polyline.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property GlobalWidth() As Single

C#

float GlobalWidth {get; set;}

C++

property float GlobalWidth {
float get( );
void set(
float value
);
}

JScript

function get GlobalWidth() : float;
function set GlobalWidth(value : float);

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.IsMeshMClosed Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.IsMeshMClosed Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the polygon mesh is closed in the M direction.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsMeshMClosed() As Boolean

C#

bool IsMeshMClosed {get;}

C++

property bool IsMeshMClosed {
bool get( );
}

JScript

function get IsMeshMClosed() : boolean;

Property Value

true if the polygon mesh is closed in the M direction.; otherwise, false.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.IsMeshNClosed Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.IsMeshNClosed Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the polygon mesh is closed in the N direction.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsMeshNClosed() As Boolean

C#

bool IsMeshNClosed {get;}

C++

property bool IsMeshNClosed {
bool get( );
}

JScript

function get IsMeshNClosed() : boolean;

Property Value

true if the polygon mesh is closed in the N direction.; otherwise, false.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.IsPolyFaceMesh Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.IsPolyFaceMesh Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether this polyline is a polyface mesh.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsPolyFaceMesh() As Boolean

C#

bool IsPolyFaceMesh {get;}

C++

property bool IsPolyFaceMesh {
bool get( );
}

JScript

function get IsPolyFaceMesh() : boolean;

Property Value

true if the polyline is a polyface mesh; otherwise, false.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.IsPolyZThickness Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.IsPolyZThickness Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the polyline has thickness measured along the axis Z.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsPolyZThickness() As Boolean

C#

bool IsPolyZThickness {get;}

C++

property bool IsPolyZThickness {
bool get( );
}

JScript

function get IsPolyZThickness() : boolean;

Property Value

true if the polyline has thickness measured along the axis Z; otherwise, false.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.IsPolygonMesh Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.IsPolygonMesh Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether this polyline is a polygon mesh.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsPolygonMesh() As Boolean

C#

bool IsPolygonMesh {get;}

C++

property bool IsPolygonMesh {
bool get( );
}

JScript

function get IsPolygonMesh() : boolean;

Property Value

true if the polyline is a polygon mesh; otherwise, false.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.Layer Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.Layer Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a layer containing this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Layer() As Layer

C#

Layer Layer {get; set;}

C++

property Layer^ Layer {
Layer^ get( );
void set(
Layer^ value
);
}

JScript

function get Layer() : Layer;
function set Layer(value : Layer);

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.LineTypeScale Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.LineTypeScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a quantity of line type elements per unit of its length.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineTypeScale() As Single

C#

float LineTypeScale {get; set;}

C++

property float LineTypeScale {
float get( );
void set(
float value
);
}

JScript

function get LineTypeScale() : float;
function set LineTypeScale(value : float);

Property Value

The quantity of linetype elements per unit of its length.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.MeshM Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.MeshM Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a number of vertices for the polygon mesh in the M direction.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property MeshM() As Integer

C#

int MeshM {get; set;}

C++

property int MeshM {
int get( );
void set(
int value
);
}

JScript

function get MeshM() : int;
function set MeshM(value : int);

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.MeshN Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.MeshN Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a number of vertices for the polygon mesh in the N direction.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property MeshN() As Integer

C#

int MeshN {get; set;}

C++

property int MeshN {
int get( );
void set(
int value
);
}

JScript

function get MeshN() : int;
function set MeshN(value : int);

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.Name Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.Name Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Name() As String

C#

string Name {get; set;}

C++

property String^ Name {
String^ get( );
void set(
String^ value
);
}

JScript

function get Name() : String;
function set Name(value : String);

Property Value

String containing the object name.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.PaperSpace Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.PaperSpace Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is located in Paper space.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PaperSpace() As Integer

C#

int PaperSpace {get; set;}

C++

property int PaperSpace {
int get( );
void set(
int value
);
}

JScript

function get PaperSpace() : int;
function set PaperSpace(value : int);

Property Value

0 - the object is located in Model space, 1 - in Paper space.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.PenLine Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.PenLine Property

 Return to chapter overview

Show / hide the hidden text

Gets properties of the pen used for drawing the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property PenLine() As CADLine

C#

CADLine PenLine {get;}

C++

property CADLine^ PenLine {
CADLine^ get( );
}

JScript

function get PenLine() : CADLine;

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.Point Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.Point Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the center point.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Point() As Point3D

C#

Point3D Point {get; set;}

C++

property Point3D^ Point {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Point() : Point3D;
function set Point(value : Point3D);

Property Value

Point3D value which represents the center point.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.PointsCount Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.PointsCount Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of the polyline points.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property PointsCount() As Integer

C#

int PointsCount {get;}

C++

property int PointsCount {
int get( );
}

JScript

function get PointsCount() : int;

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.PolyFaceVertexIndexesCount Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.PolyFaceVertexIndexesCount Property

 Return to chapter overview

Show / hide the hidden text

Gets a quantity of indices which specify the order of traversing vertices in the polyface mesh.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property PolyFaceVertexIndexesCount() As Integer

C#

int PolyFaceVertexIndexesCount {get;}

C++

property int PolyFaceVertexIndexesCount {
int get( );
}

JScript

function get PolyFaceVertexIndexesCount() : int;

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.Radius Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.Radius Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a radius of the circle/ellipse/arc.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Radius() As Double

C#

double Radius {get; set;}

C++

property double Radius {
double get( );
void set(
double value
);
}

JScript

function get Radius() : double;
function set Radius(value : double);

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.SrcEnd Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.SrcEnd Property

 Return to chapter overview

Show / hide the hidden text

Indicates the end of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcEnd() As String

C#

string SrcEnd {get; set;}

C++

property String^ SrcEnd {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcEnd() : String;
function set SrcEnd(value : String);

Property Value

A String value indicating the end of the record which represents this object in a drawing file.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.SrcStart Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.SrcStart Property

 Return to chapter overview

Show / hide the hidden text

Indicates the beginning of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcStart() As String

C#

string SrcStart {get; set;}

C++

property String^ SrcStart {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcStart() : String;
function set SrcStart(value : String);

Property Value

A String value indicating the beginning of the record which represents this object in a drawing file.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.StartAngle Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.StartAngle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the start angle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property StartAngle() As Double

C#

double StartAngle {get; set;}

C++

property double StartAngle {
double get( );
void set(
double value
);
}

JScript

function get StartAngle() : double;
function set StartAngle(value : double);

Property Value

Double type value indicating the start angle.

collall Remarks

The angle direction is counterclockwise.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.StartPoint Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.StartPoint Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the start point of arc/ellipse

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property StartPoint() As Point3D

C#

Point3D StartPoint {get;}

C++

property Point3D^ StartPoint {
Point3D^ get( );
}

JScript

function get StartPoint() : Point3D;

Property Value

Point3D type value indicating the start point.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.Visibility Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.Visibility Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visibility() As Boolean

C#

bool Visibility {get; set;}

C++

property bool Visibility {
bool get( );
void set(
bool value
);
}

JScript

function get Visibility() : boolean;
function set Visibility(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.Visible Property

API Reference > CADViewLib Namespace > Arc Interface > Properties >

IArc.Visible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visible() As Boolean

C#

bool Visible {get; set;}

C++

property bool Visible {
bool get( );
void set(
bool value
);
}

JScript

function get Visible() : boolean;
function set Visible(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

IArc Interface
IArc IArc Members


Arc Methods

API Reference > CADViewLib Namespace > Arc Interface >

Arc Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from IArc ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from IArc ).
Public method | CreateEntity | Initializes a new object instance. (inherited from IArc ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from IArc ).
Public method | EntName | Returns a name of the entity. (inherited from IArc ).
Public method | FreeEntity | Destroys the object instance. (inherited from IArc ).
Public method | GetArea | Returns the area bounded by a closed polygon. (inherited from IArc ).
Public method | GetBoxPoints | For internal use. (inherited from IArc ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from IArc ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from IArc ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from IArc ).
Public method | RemoveEntity | Removes a specified entity. (inherited from IArc ).
Public method | SetLType | Sets a line type for this object. (inherited from IArc ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from IArc ).
Public method | get_Arrows | Returns a point of the arrowhead. (inherited from IArc ).
Public method | get_DottedPoints | Returns coordinates of a point in the points array that determines dots and dashes for a non-solid line type. (inherited from IArc ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from IArc ).
Public method | get_Points | Returns coordinates of a point in the points array. (inherited from IArc ).
Public method | get_PolyFaceVertexIndexes | Returns a value which indicates an index of the polyface mesh vertex. (inherited from IArc ).
Public method | set_Arrows | Modifies a point of the arrowhead at the given index. (inherited from IArc ).

Top

collall See Also

Reference

Arc Interface


IArc.AddEntity Method

API Reference > CADViewLib Namespace > Arc Interface > Methods >

IArc.AddEntity Method

 Return to chapter overview

Show / hide the hidden text

Adds a new child entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AddEntity( _
ByVal AEntity As Entity _
)

C#

override void AddEntity(
EntityAEntity
)

C++

void AddEntity(
Entity^ AEntity
)

JScript

function AddEntity(
AEntity : Entity
);

Parameters

AEntity

Added entity.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.AssignEntity Method

API Reference > CADViewLib Namespace > Arc Interface > Methods >

IArc.AssignEntity Method

 Return to chapter overview

Show / hide the hidden text

Assigns the properties of the specified entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AssignEntity( _
ByVal Source As Entity _
)

C#

override void AssignEntity(
EntitySource
)

C++

void AssignEntity(
Entity^ Source
)

JScript

function AssignEntity(
Source : Entity
);

Parameters

Source

Entity which has the same type as the current object.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.CreateEntity Method

API Reference > CADViewLib Namespace > Arc Interface > Methods >

IArc.CreateEntity Method

 Return to chapter overview

Show / hide the hidden text

Initializes a new object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub CreateEntity()

C#

override void CreateEntity()

C++

void CreateEntity()

JScript

function CreateEntity();

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.DeleteEntity Method

API Reference > CADViewLib Namespace > Arc Interface > Methods >

IArc.DeleteEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes an entity specified by index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub DeleteEntity( _
ByVal AIndex As Integer _
)

C#

override void DeleteEntity(
intAIndex
)

C++

void DeleteEntity(
intAIndex
)

JScript

function DeleteEntity(
AIndex : int
);

Parameters

AIndex

Index of the entity.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.EntName Method

API Reference > CADViewLib Namespace > Arc Interface > Methods >

IArc.EntName Method

 Return to chapter overview

Show / hide the hidden text

Returns a name of the entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function EntName() As String

C#

override string EntName()

C++

String^ EntName()

JScript

function EntName() : String;

Return Value

A string containing the entity name.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.FreeEntity Method

API Reference > CADViewLib Namespace > Arc Interface > Methods >

IArc.FreeEntity Method

 Return to chapter overview

Show / hide the hidden text

Destroys the object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub FreeEntity()

C#

override void FreeEntity()

C++

void FreeEntity()

JScript

function FreeEntity();

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.GetArea Method

API Reference > CADViewLib Namespace > Arc Interface > Methods >

IArc.GetArea Method

 Return to chapter overview

Show / hide the hidden text

Returns the area bounded by a closed polygon.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetArea() As Double

C#

override double GetArea()

C++

double GetArea()

JScript

function GetArea() : double;

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.GetBoxPoints Method

API Reference > CADViewLib Namespace > Arc Interface > Methods >

IArc.GetBoxPoints Method

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetBoxPoints( _
ByVal Full As Boolean _
) As Boolean

C#

override bool GetBoxPoints(
boolFull
)

C++

bool GetBoxPoints(
boolFull
)

JScript

function GetBoxPoints(
Full : boolean
) : boolean;

Parameters

Full

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.GetThickness Method

API Reference > CADViewLib Namespace > Arc Interface > Methods >

IArc.GetThickness Method

 Return to chapter overview

Show / hide the hidden text

Returns the line thickness for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetThickness() As Double

C#

override double GetThickness()

C++

double GetThickness()

JScript

function GetThickness() : double;

Return Value

A Double type value indicating the line thickness.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.IndexOfEntity Method

API Reference > CADViewLib Namespace > Arc Interface > Methods >

IArc.IndexOfEntity Method

 Return to chapter overview

Show / hide the hidden text

Returns index of the given entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function IndexOfEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int IndexOfEntity(
EntityAEntity
)

C++

int IndexOfEntity(
Entity^ AEntity
)

JScript

function IndexOfEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity whose index is retrieved.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.Iterate Method

API Reference > CADViewLib Namespace > Arc Interface > Methods >

IArc.Iterate Method

 Return to chapter overview

Show / hide the hidden text

Iterates through the entities in the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub Iterate( _
ByVal AConverter As Converter _
)

C#

override void Iterate(
ConverterAConverter
)

C++

void Iterate(
Converter^ AConverter
)

JScript

function Iterate(
AConverter : Converter
);

Parameters

AConverter

Converter which contains the drawing data.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.RemoveEntity Method

API Reference > CADViewLib Namespace > Arc Interface > Methods >

IArc.RemoveEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes a specified entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function RemoveEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int RemoveEntity(
EntityAEntity
)

C++

int RemoveEntity(
Entity^ AEntity
)

JScript

function RemoveEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity which will be removed.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.SetLType Method

API Reference > CADViewLib Namespace > Arc Interface > Methods >

IArc.SetLType Method

 Return to chapter overview

Show / hide the hidden text

Sets a line type for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLType( _
ByVal Value As Entity _
)

C#

override void SetLType(
EntityValue
)

C++

void SetLType(
Entity^ Value
)

JScript

function SetLType(
Value : Entity
);

Parameters

Value

The line type value.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.SetLWeight Method

API Reference > CADViewLib Namespace > Arc Interface > Methods >

IArc.SetLWeight Method

 Return to chapter overview

Show / hide the hidden text

Sets a line weight for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLWeight( _
ByVal Value As Integer _
)

C#

override void SetLWeight(
intValue
)

C++

void SetLWeight(
intValue
)

JScript

function SetLWeight(
Value : int
);

Parameters

Value

The line weight value.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.get_Arrows Method

API Reference > CADViewLib Namespace > Arc Interface > Methods >

IArc.get_Arrows Method

 Return to chapter overview

Show / hide the hidden text

Returns a point of the arrowhead.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Arrows( _
ByVal Index As Integer _
) As Point3D

C#

override Point3D get_Arrows(
intIndex
)

C++

Point3D^ get_Arrows(
intIndex
)

JScript

function get_Arrows(
Index : int
) : Point3D;

Parameters

Index

Index of the point to retrieve.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.get_DottedPoints Method

API Reference > CADViewLib Namespace > Arc Interface > Methods >

IArc.get_DottedPoints Method

 Return to chapter overview

Show / hide the hidden text

Returns coordinates of a point in the points array that determines dots and dashes for a non-solid line type.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_DottedPoints( _
ByVal Index As Integer _
) As Point3D

C#

override Point3D get_DottedPoints(
intIndex
)

C++

Point3D^ get_DottedPoints(
intIndex
)

JScript

function get_DottedPoints(
Index : int
) : Point3D;

Parameters

Index

Index of the point to retrieve.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.get_Entities Method

API Reference > CADViewLib Namespace > Arc Interface > Methods >

IArc.get_Entities Method

 Return to chapter overview

Show / hide the hidden text

Returns the child entity at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Entities( _
ByVal Index As Integer _
) As Entity

C#

override Entity get_Entities(
intIndex
)

C++

Entity^ get_Entities(
intIndex
)

JScript

function get_Entities(
Index : int
) : Entity;

Parameters

Index

The index of the entity to retrieve.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.get_Points Method

API Reference > CADViewLib Namespace > Arc Interface > Methods >

IArc.get_Points Method

 Return to chapter overview

Show / hide the hidden text

Returns coordinates of a point in the points array.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Points( _
ByVal Index As Integer _
) As Point3D

C#

override Point3D get_Points(
intIndex
)

C++

Point3D^ get_Points(
intIndex
)

JScript

function get_Points(
Index : int
) : Point3D;

Parameters

Index

Index of the point to retrieve.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.get_PolyFaceVertexIndexes Method

API Reference > CADViewLib Namespace > Arc Interface > Methods >

IArc.get_PolyFaceVertexIndexes Method

 Return to chapter overview

Show / hide the hidden text

Returns a value which indicates an index of the polyface mesh vertex.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_PolyFaceVertexIndexes( _
ByVal Index As Integer _
) As Object

C#

override object get_PolyFaceVertexIndexes(
intIndex
)

C++

object^ get_PolyFaceVertexIndexes(
intIndex
)

JScript

function get_PolyFaceVertexIndexes(
Index : int
) : object;

Parameters

Index

The index number of the element.

collall See Also

Reference

IArc Interface
IArc IArc Members


IArc.set_Arrows Method

API Reference > CADViewLib Namespace > Arc Interface > Methods >

IArc.set_Arrows Method

 Return to chapter overview

Show / hide the hidden text

Modifies a point of the arrowhead at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub set_Arrows( _
ByVal Index As Integer, _
ByVal Value As Point3D _
)

C#

override void set_Arrows(
intIndex,
Point3DValue
)

C++

void set_Arrows(
intIndex,
Point3D^ Value
)

JScript

function set_Arrows(
Index : int,
Value : Point3D
);

Parameters

Index

The index of the point.

Value

Value to be set for the point.

collall See Also

Reference

IArc Interface
IArc IArc Members


AttDef Interface

API Reference > CADViewLib Namespace >

AttDef Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to ATTDEF entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface AttDef
Inherits IAttDef, _
IEntityEvents_Event

C#

public interface AttDef : IAttDef,
IEntityEvents_Event

C++

public interface class AttDef : public IAttDef^,
public IEntityEvents_Event^

JScript

public interface AttDef
implements IAttDef,
IEntityEvents_Event

collall See Also

Reference

AttDef Members


AttDef Members

API Reference > CADViewLib Namespace > AttDef Interface >

AttDef Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to ATTDEF entities.

The following tables list the members exposed by the AttDef type.

collall Public Properties

 | Name | Description
Public property | Backward | Gets a value indicating whether the text is drawn backwards. (inherited from IAttDef ).
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from IAttDef ).
Public property | CADHandle | Gets or sets the object handle. (inherited from IAttDef ).
Public property | Color | Gets or sets a color of the object. (inherited from IAttDef ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from IAttDef ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from IAttDef ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from IAttDef ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from IAttDef ).
Public property | Flags | Gets or sets the attribute flags. (inherited from IAttDef ).
Public property | Font | Gets or sets a font for displaying the text. (inherited from IAttDef ).
Public property | FontName | Gets or sets a name of the font file. (inherited from IAttDef ).
Public property | Generation | Gets or sets text generation flags. (inherited from IAttDef ).
Public property | HAlign | Gets or sets horizontal text justification type integer codes (not bit-coded). (inherited from IAttDef ).
Public property | Height | Gets or sets a height of the text. (inherited from IAttDef ).
Public property | IsSHXFont | Gets a value indicating whether the text uses an SHX font. (inherited from IAttDef ).
Public property | IsUnicodeText | Gets a value indicating whether the text uses Unicode for characters encoding. (inherited from IAttDef ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from IAttDef ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from IAttDef ).
Public property | Name | Gets or sets a name of this object. (inherited from IAttDef ).
Public property | ObliqueAngle | Gets or sets an oblique angle for text characters. (inherited from IAttDef ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from IAttDef ).
Public property | Point | Gets or sets the first alignment point. (inherited from IAttDef ).
Public property | Point1 | Gets or sets the second alignment point. (inherited from IAttDef ).
Public property | Rotation | Gets or sets the rotation angle of the text. (inherited from IAttDef ).
Public property | SHXFontName | Gets or sets a name of SHX font file. (inherited from IAttDef ).
Public property | SHXText | Gets a string of the SHX text. (inherited from IAttDef ).
Public property | SHXUnicodeText | Gets a string of the SHX Unicode text. (inherited from IAttDef ).
Public property | Scale | Gets or sets relative X scale factor (width). (inherited from IAttDef ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from IAttDef ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from IAttDef ).
Public property | StartPoint | Gets the start point of the text. (inherited from IAttDef ).
Public property | Tag | Gets or sets the tag string. (inherited from IAttDef ).
Public property | Text | Gets or sets the text value. (inherited from IAttDef ).
Public property | UnicodeText | Gets the text value as Unicode string. (inherited from IAttDef ).
Public property | UpsideDown | Gets a value indicating whether the text is upside down (mirrored in Y). (inherited from IAttDef ).
Public property | VAlign | Gets or sets vertical text justification type: integer codes (not bit-coded). (inherited from IAttDef ).
Public property | Value | Gets or sets a value of the attribute. (inherited from IAttDef ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from IAttDef ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from IAttDef ).
Public property | WinFont | Gets a value indicating whether the text is rendered using a Windows font. (inherited from IAttDef ).
Public property | XScale | Gets or sets relative X scale factor (width). (inherited from IAttDef ).

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from IAttDef ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from IAttDef ).
Public method | CreateEntity | Initializes a new object instance. (inherited from IAttDef ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from IAttDef ).
Public method | DoNewText | Replaces the text value with a new string. (inherited from IAttDef ).
Public method | EntName | Returns a name of the entity. (inherited from IAttDef ).
Public method | FreeEntity | Destroys the object instance. (inherited from IAttDef ).
Public method | GetBase | Returns the base point of the text. (inherited from IAttDef ).
Public method | GetBoxPoints | For internal use. (inherited from IAttDef ).
Public method | GetSHXMatrix | Returns a coordinate transformation matrix. (inherited from IAttDef ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from IAttDef ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from IAttDef ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from IAttDef ).
Public method | RemoveEntity | Removes a specified entity. (inherited from IAttDef ).
Public method | SetLType | Sets a line type for this object. (inherited from IAttDef ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from IAttDef ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from IAttDef ).

Top

collall See Also

Reference

AttDef Interface


AttDef Properties

API Reference > CADViewLib Namespace > AttDef Interface >

AttDef Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Backward | Gets a value indicating whether the text is drawn backwards. (inherited from IAttDef ).
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from IAttDef ).
Public property | CADHandle | Gets or sets the object handle. (inherited from IAttDef ).
Public property | Color | Gets or sets a color of the object. (inherited from IAttDef ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from IAttDef ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from IAttDef ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from IAttDef ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from IAttDef ).
Public property | Flags | Gets or sets the attribute flags. (inherited from IAttDef ).
Public property | Font | Gets or sets a font for displaying the text. (inherited from IAttDef ).
Public property | FontName | Gets or sets a name of the font file. (inherited from IAttDef ).
Public property | Generation | Gets or sets text generation flags. (inherited from IAttDef ).
Public property | HAlign | Gets or sets horizontal text justification type integer codes (not bit-coded). (inherited from IAttDef ).
Public property | Height | Gets or sets a height of the text. (inherited from IAttDef ).
Public property | IsSHXFont | Gets a value indicating whether the text uses an SHX font. (inherited from IAttDef ).
Public property | IsUnicodeText | Gets a value indicating whether the text uses Unicode for characters encoding. (inherited from IAttDef ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from IAttDef ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from IAttDef ).
Public property | Name | Gets or sets a name of this object. (inherited from IAttDef ).
Public property | ObliqueAngle | Gets or sets an oblique angle for text characters. (inherited from IAttDef ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from IAttDef ).
Public property | Point | Gets or sets the first alignment point. (inherited from IAttDef ).
Public property | Point1 | Gets or sets the second alignment point. (inherited from IAttDef ).
Public property | Rotation | Gets or sets the rotation angle of the text. (inherited from IAttDef ).
Public property | SHXFontName | Gets or sets a name of SHX font file. (inherited from IAttDef ).
Public property | SHXText | Gets a string of the SHX text. (inherited from IAttDef ).
Public property | SHXUnicodeText | Gets a string of the SHX Unicode text. (inherited from IAttDef ).
Public property | Scale | Gets or sets relative X scale factor (width). (inherited from IAttDef ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from IAttDef ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from IAttDef ).
Public property | StartPoint | Gets the start point of the text. (inherited from IAttDef ).
Public property | Tag | Gets or sets the tag string. (inherited from IAttDef ).
Public property | Text | Gets or sets the text value. (inherited from IAttDef ).
Public property | UnicodeText | Gets the text value as Unicode string. (inherited from IAttDef ).
Public property | UpsideDown | Gets a value indicating whether the text is upside down (mirrored in Y). (inherited from IAttDef ).
Public property | VAlign | Gets or sets vertical text justification type: integer codes (not bit-coded). (inherited from IAttDef ).
Public property | Value | Gets or sets a value of the attribute. (inherited from IAttDef ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from IAttDef ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from IAttDef ).
Public property | WinFont | Gets a value indicating whether the text is rendered using a Windows font. (inherited from IAttDef ).
Public property | XScale | Gets or sets relative X scale factor (width). (inherited from IAttDef ).

Top

collall See Also

Reference

AttDef Interface


IAttDef.Backward Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.Backward Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the text is drawn backwards.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Backward() As Boolean

C#

bool Backward {get;}

C++

property bool Backward {
bool get( );
}

JScript

function get Backward() : boolean;

Property Value

true if the text is drawn backwards; otherwise, false.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.Box Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.Box Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the bounding parallelepiped for the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Box() As Rect3D

C#

Rect3D Box {get;}

C++

property Rect3D^ Box {
Rect3D^ get( );
}

JScript

function get Box() : Rect3D;

Property Value

The parallelepiped which encloses the object.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.CADHandle Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.CADHandle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the object handle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CADHandle() As UInt64

C#

UInt64 CADHandle {get; set;}

C++

property UInt64 CADHandle {
UInt64 get( );
void set(
UInt64 value
);
}

JScript

function get CADHandle() : UInt64;
function set CADHandle(value : UInt64);

Property Value

Number that uniquely identifies the object in a CAD drawing.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.Color Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.Color Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a color of the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Color() As UInt32

C#

UInt32 Color {get; set;}

C++

property UInt32 Color {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get Color() : UInt32;
function set Color(value : UInt32);

Property Value

An insigned integer value which defines the object's color.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.Converter Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.Converter Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a Converter instance associated with the CAD image to which this object belongs.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Converter() As Converter

C#

Converter Converter {get;}

C++

property Converter^ Converter {
Converter^ get( );
}

JScript

function get Converter() : Converter;

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.Count Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.Count Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of objects contained within the given object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Count() As Integer

C#

int Count {get;}

C++

property int Count {
int get( );
}

JScript

function get Count() : int;

Property Value

An Integer value indicating a number of objects contained within the given object.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.EntID Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.EntID Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the entity type ID for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property EntID() As TEntityID

C#

TEntityID EntID {get; set;}

C++

property TEntityID EntID {
TEntityID get( );
void set(
TEntityID value
);
}

JScript

function get EntID() : TEntityID;
function set EntID(value : TEntityID);

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.Extrusion Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.Extrusion Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the extrusion direction vector for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Extrusion() As Point3D

C#

Point3D Extrusion {get; set;}

C++

property Point3D^ Extrusion {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Extrusion() : Point3D;
function set Extrusion(value : Point3D);

Property Value

The 3D point which defines the extrusion direction vector.

collall Remarks

The extrusion direction is the normal vector of the plane which contains the entity and it is applied to the entity base point. The default extrusion direction value is (0, 0, 1).

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.Flags Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.Flags Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the attribute flags.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Flags() As Byte

C#

byte Flags {get; set;}

C++

property Byte Flags {
Byte get( );
void set(
Byte value
);
}

JScript

function get Flags() : byte;
function set Flags(value : byte);

Property Value

1 = Attribute is invisible (does not appear)
2 = This is a constant attribute
4 = Verification is required on input of this attribute
8 = Attribute is preset (no prompt during insertion)

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.Font Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.Font Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a font for displaying the text.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Font() As StdFont

C#

StdFont Font {get; set;}

C++

property StdFont^ Font {
StdFont^ get( );
void set(
StdFont^ value
);
}

JScript

function get Font() : StdFont;
function set Font(value : StdFont);

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.FontName Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.FontName Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of the font file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property FontName() As String

C#

string FontName {get;}

C++

property String^ FontName {
String^ get( );
}

JScript

function get FontName() : String;

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.Generation Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.Generation Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets text generation flags.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Generation() As Byte

C#

byte Generation {get; set;}

C++

property Byte Generation {
Byte get( );
void set(
Byte value
);
}

JScript

function get Generation() : byte;
function set Generation(value : byte);

Property Value

0 = Default value
2 = Text is backward (mirrored in X)
4 = Text is upside down (mirrored in Y)

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.HAlign Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.HAlign Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets horizontal text justification type integer codes (not bit-coded).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property HAlign() As Byte

C#

byte HAlign {get; set;}

C++

property Byte HAlign {
Byte get( );
void set(
Byte value
);
}

JScript

function get HAlign() : byte;
function set HAlign(value : byte);

Property Value

0 = Left
1 = Center
2 = Right
3 = Aligned (if vertical alignment = 0)
4 = Middle (if vertical alignment = 0)
5 = Fit (if vertical alignment = 0)

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.Height Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.Height Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a height of the text.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Height() As Double

C#

double Height {get; set;}

C++

property double Height {
double get( );
void set(
double value
);
}

JScript

function get Height() : double;
function set Height(value : double);

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.IsSHXFont Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.IsSHXFont Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the text uses an SHX font.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsSHXFont() As Boolean

C#

bool IsSHXFont {get;}

C++

property bool IsSHXFont {
bool get( );
}

JScript

function get IsSHXFont() : boolean;

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.IsUnicodeText Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.IsUnicodeText Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the text uses Unicode for characters encoding.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsUnicodeText() As Boolean

C#

bool IsUnicodeText {get;}

C++

property bool IsUnicodeText {
bool get( );
}

JScript

function get IsUnicodeText() : boolean;

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.Layer Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.Layer Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a layer containing this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Layer() As Layer

C#

Layer Layer {get; set;}

C++

property Layer^ Layer {
Layer^ get( );
void set(
Layer^ value
);
}

JScript

function get Layer() : Layer;
function set Layer(value : Layer);

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.LineTypeScale Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.LineTypeScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a quantity of line type elements per unit of its length.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineTypeScale() As Single

C#

float LineTypeScale {get; set;}

C++

property float LineTypeScale {
float get( );
void set(
float value
);
}

JScript

function get LineTypeScale() : float;
function set LineTypeScale(value : float);

Property Value

The quantity of linetype elements per unit of its length.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.Name Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.Name Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Name() As String

C#

string Name {get; set;}

C++

property String^ Name {
String^ get( );
void set(
String^ value
);
}

JScript

function get Name() : String;
function set Name(value : String);

Property Value

String containing the object name.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.ObliqueAngle Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.ObliqueAngle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets an oblique angle for text characters.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property ObliqueAngle() As Double

C#

double ObliqueAngle {get; set;}

C++

property double ObliqueAngle {
double get( );
void set(
double value
);
}

JScript

function get ObliqueAngle() : double;
function set ObliqueAngle(value : double);

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.PaperSpace Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.PaperSpace Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is located in Paper space.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PaperSpace() As Integer

C#

int PaperSpace {get; set;}

C++

property int PaperSpace {
int get( );
void set(
int value
);
}

JScript

function get PaperSpace() : int;
function set PaperSpace(value : int);

Property Value

0 - the object is located in Model space, 1 - in Paper space.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.Point Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.Point Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the first alignment point.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Point() As Point3D

C#

Point3D Point {get; set;}

C++

property Point3D^ Point {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Point() : Point3D;
function set Point(value : Point3D);

Property Value

Point3D object which represents the first alignment point.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.Point1 Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.Point1 Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the second alignment point.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Point1() As Point3D

C#

Point3D Point1 {get; set;}

C++

property Point3D^ Point1 {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Point1() : Point3D;
function set Point1(value : Point3D);

Property Value

Point3D object which represents the second alignment point.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.Rotation Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.Rotation Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the rotation angle of the text.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Rotation() As Double

C#

double Rotation {get; set;}

C++

property double Rotation {
double get( );
void set(
double value
);
}

JScript

function get Rotation() : double;
function set Rotation(value : double);

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.SHXFontName Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.SHXFontName Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of SHX font file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property SHXFontName() As String

C#

string SHXFontName {get;}

C++

property String^ SHXFontName {
String^ get( );
}

JScript

function get SHXFontName() : String;

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.SHXText Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.SHXText Property

 Return to chapter overview

Show / hide the hidden text

Gets a string of the SHX text.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property SHXText() As String

C#

string SHXText {get;}

C++

property String^ SHXText {
String^ get( );
}

JScript

function get SHXText() : String;

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.SHXUnicodeText Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.SHXUnicodeText Property

 Return to chapter overview

Show / hide the hidden text

Gets a string of the SHX Unicode text.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property SHXUnicodeText() As String

C#

string SHXUnicodeText {get;}

C++

property String^ SHXUnicodeText {
String^ get( );
}

JScript

function get SHXUnicodeText() : String;

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.Scale Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.Scale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets relative X scale factor (width).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Scale() As Double

C#

double Scale {get; set;}

C++

property double Scale {
double get( );
void set(
double value
);
}

JScript

function get Scale() : double;
function set Scale(value : double);

Property Value

Default value is 1.
More than 1 if the text letters are stretched; less than 1 and more than 0 if the text letters are squeezed.

collall Remarks

The modified width is equal to the previous text width multiplied by the scale factor.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.SrcEnd Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.SrcEnd Property

 Return to chapter overview

Show / hide the hidden text

Indicates the end of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcEnd() As String

C#

string SrcEnd {get; set;}

C++

property String^ SrcEnd {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcEnd() : String;
function set SrcEnd(value : String);

Property Value

A String value indicating the end of the record which represents this object in a drawing file.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.SrcStart Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.SrcStart Property

 Return to chapter overview

Show / hide the hidden text

Indicates the beginning of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcStart() As String

C#

string SrcStart {get; set;}

C++

property String^ SrcStart {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcStart() : String;
function set SrcStart(value : String);

Property Value

A String value indicating the beginning of the record which represents this object in a drawing file.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.StartPoint Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.StartPoint Property

 Return to chapter overview

Show / hide the hidden text

Gets the start point of the text.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property StartPoint() As Point3D

C#

Point3D StartPoint {get;}

C++

property Point3D^ StartPoint {
Point3D^ get( );
}

JScript

function get StartPoint() : Point3D;

Property Value

Point3D type value indicating the start point of the text.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.Tag Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.Tag Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the tag string.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Tag() As String

C#

string Tag {get; set;}

C++

property String^ Tag {
String^ get( );
void set(
String^ value
);
}

JScript

function get Tag() : String;
function set Tag(value : String);

Property Value

Can contain any characters except spaces or exclamation points.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.Text Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.Text Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the text value.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Text() As String

C#

string Text {get; set;}

C++

property String^ Text {
String^ get( );
void set(
String^ value
);
}

JScript

function get Text() : String;
function set Text(value : String);

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.UnicodeText Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.UnicodeText Property

 Return to chapter overview

Show / hide the hidden text

Gets the text value as Unicode string.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property UnicodeText() As String

C#

string UnicodeText {get;}

C++

property String^ UnicodeText {
String^ get( );
}

JScript

function get UnicodeText() : String;

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.UpsideDown Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.UpsideDown Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the text is upside down (mirrored in Y).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property UpsideDown() As Boolean

C#

bool UpsideDown {get;}

C++

property bool UpsideDown {
bool get( );
}

JScript

function get UpsideDown() : boolean;

Property Value

true if the text is upside down; otherwise, false.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.VAlign Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.VAlign Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets vertical text justification type: integer codes (not bit-coded).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property VAlign() As Byte

C#

byte VAlign {get; set;}

C++

property Byte VAlign {
Byte get( );
void set(
Byte value
);
}

JScript

function get VAlign() : byte;
function set VAlign(value : byte);

Property Value

0 = Baseline
1 = Bottom
2 = Middle
3 = Top

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.Value Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.Value Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value of the attribute.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Value() As String

C#

string Value {get; set;}

C++

property String^ Value {
String^ get( );
void set(
String^ value
);
}

JScript

function get Value() : String;
function set Value(value : String);

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.Visibility Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.Visibility Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visibility() As Boolean

C#

bool Visibility {get; set;}

C++

property bool Visibility {
bool get( );
void set(
bool value
);
}

JScript

function get Visibility() : boolean;
function set Visibility(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.Visible Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.Visible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visible() As Boolean

C#

bool Visible {get; set;}

C++

property bool Visible {
bool get( );
void set(
bool value
);
}

JScript

function get Visible() : boolean;
function set Visible(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.WinFont Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.WinFont Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the text is rendered using a Windows font.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property WinFont() As Boolean

C#

bool WinFont {get;}

C++

property bool WinFont {
bool get( );
}

JScript

function get WinFont() : boolean;

Property Value

true if the text is rendered using a Windows font; otherwise, false.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.XScale Property

API Reference > CADViewLib Namespace > AttDef Interface > Properties >

IAttDef.XScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets relative X scale factor (width).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property XScale() As Double

C#

double XScale {get;}

C++

property double XScale {
double get( );
}

JScript

function get XScale() : double;

Property Value

Default value is 1.
More than 1 if the text letters are stretched; less than 1 and more than 0 if the text letters are squeezed.

collall Remarks

The modified width is equal to the previous text width multiplied by the scale factor.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


AttDef Methods

API Reference > CADViewLib Namespace > AttDef Interface >

AttDef Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from IAttDef ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from IAttDef ).
Public method | CreateEntity | Initializes a new object instance. (inherited from IAttDef ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from IAttDef ).
Public method | DoNewText | Replaces the text value with a new string. (inherited from IAttDef ).
Public method | EntName | Returns a name of the entity. (inherited from IAttDef ).
Public method | FreeEntity | Destroys the object instance. (inherited from IAttDef ).
Public method | GetBase | Returns the base point of the text. (inherited from IAttDef ).
Public method | GetBoxPoints | For internal use. (inherited from IAttDef ).
Public method | GetSHXMatrix | Returns a coordinate transformation matrix. (inherited from IAttDef ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from IAttDef ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from IAttDef ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from IAttDef ).
Public method | RemoveEntity | Removes a specified entity. (inherited from IAttDef ).
Public method | SetLType | Sets a line type for this object. (inherited from IAttDef ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from IAttDef ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from IAttDef ).

Top

collall See Also

Reference

AttDef Interface


IAttDef.AddEntity Method

API Reference > CADViewLib Namespace > AttDef Interface > Methods >

IAttDef.AddEntity Method

 Return to chapter overview

Show / hide the hidden text

Adds a new child entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AddEntity( _
ByVal AEntity As Entity _
)

C#

override void AddEntity(
EntityAEntity
)

C++

void AddEntity(
Entity^ AEntity
)

JScript

function AddEntity(
AEntity : Entity
);

Parameters

AEntity

Added entity.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.AssignEntity Method

API Reference > CADViewLib Namespace > AttDef Interface > Methods >

IAttDef.AssignEntity Method

 Return to chapter overview

Show / hide the hidden text

Assigns the properties of the specified entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AssignEntity( _
ByVal Source As Entity _
)

C#

override void AssignEntity(
EntitySource
)

C++

void AssignEntity(
Entity^ Source
)

JScript

function AssignEntity(
Source : Entity
);

Parameters

Source

Entity which has the same type as the current object.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.CreateEntity Method

API Reference > CADViewLib Namespace > AttDef Interface > Methods >

IAttDef.CreateEntity Method

 Return to chapter overview

Show / hide the hidden text

Initializes a new object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub CreateEntity()

C#

override void CreateEntity()

C++

void CreateEntity()

JScript

function CreateEntity();

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.DeleteEntity Method

API Reference > CADViewLib Namespace > AttDef Interface > Methods >

IAttDef.DeleteEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes an entity specified by index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub DeleteEntity( _
ByVal AIndex As Integer _
)

C#

override void DeleteEntity(
intAIndex
)

C++

void DeleteEntity(
intAIndex
)

JScript

function DeleteEntity(
AIndex : int
);

Parameters

AIndex

Index of the entity.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.DoNewText Method

API Reference > CADViewLib Namespace > AttDef Interface > Methods >

IAttDef.DoNewText Method

 Return to chapter overview

Show / hide the hidden text

Replaces the text value with a new string.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub DoNewText( _
ByVal ANewText As String _
)

C#

override void DoNewText(
stringANewText
)

C++

void DoNewText(
String^ ANewText
)

JScript

function DoNewText(
ANewText : String
);

Parameters

ANewText

New text value.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.EntName Method

API Reference > CADViewLib Namespace > AttDef Interface > Methods >

IAttDef.EntName Method

 Return to chapter overview

Show / hide the hidden text

Returns a name of the entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function EntName() As String

C#

override string EntName()

C++

String^ EntName()

JScript

function EntName() : String;

Return Value

A string containing the entity name.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.FreeEntity Method

API Reference > CADViewLib Namespace > AttDef Interface > Methods >

IAttDef.FreeEntity Method

 Return to chapter overview

Show / hide the hidden text

Destroys the object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub FreeEntity()

C#

override void FreeEntity()

C++

void FreeEntity()

JScript

function FreeEntity();

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.GetBase Method

API Reference > CADViewLib Namespace > AttDef Interface > Methods >

IAttDef.GetBase Method

 Return to chapter overview

Show / hide the hidden text

Returns the base point of the text.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub GetBase( _
ByVal AWidth As Double, _
ByVal AHeight As Double, _
ByRef Base As Point3D, _
ByRef Start As Point3D _
)

C#

override void GetBase(
doubleAWidth,
doubleAHeight,
ref Point3DBase,
ref Point3DStart
)

C++

void GetBase(
doubleAWidth,
doubleAHeight,
Point3D^& Base,
Point3D^& Start
)

JScript

function GetBase(
AWidth : double,
AHeight : double,
Base : Point3D,
Start : Point3D
);

Parameters

AWidth

The text width.

AHeight

The text height.

Base

The base point.

Start

The point starting from which the text is drawn.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.GetBoxPoints Method

API Reference > CADViewLib Namespace > AttDef Interface > Methods >

IAttDef.GetBoxPoints Method

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetBoxPoints( _
ByVal Full As Boolean _
) As Boolean

C#

override bool GetBoxPoints(
boolFull
)

C++

bool GetBoxPoints(
boolFull
)

JScript

function GetBoxPoints(
Full : boolean
) : boolean;

Parameters

Full

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.GetSHXMatrix Method

API Reference > CADViewLib Namespace > AttDef Interface > Methods >

IAttDef.GetSHXMatrix Method

 Return to chapter overview

Show / hide the hidden text

Returns a coordinate transformation matrix.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub GetSHXMatrix( _
ByRef Matrix As Object _
)

C#

override void GetSHXMatrix(
ref objectMatrix
)

C++

void GetSHXMatrix(
object^& Matrix
)

JScript

function GetSHXMatrix(
Matrix : object
);

Parameters

Matrix

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.GetThickness Method

API Reference > CADViewLib Namespace > AttDef Interface > Methods >

IAttDef.GetThickness Method

 Return to chapter overview

Show / hide the hidden text

Returns the line thickness for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetThickness() As Double

C#

override double GetThickness()

C++

double GetThickness()

JScript

function GetThickness() : double;

Return Value

A Double type value indicating the line thickness.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.IndexOfEntity Method

API Reference > CADViewLib Namespace > AttDef Interface > Methods >

IAttDef.IndexOfEntity Method

 Return to chapter overview

Show / hide the hidden text

Returns index of the given entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function IndexOfEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int IndexOfEntity(
EntityAEntity
)

C++

int IndexOfEntity(
Entity^ AEntity
)

JScript

function IndexOfEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity whose index is retrieved.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.Iterate Method

API Reference > CADViewLib Namespace > AttDef Interface > Methods >

IAttDef.Iterate Method

 Return to chapter overview

Show / hide the hidden text

Iterates through the entities in the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub Iterate( _
ByVal AConverter As Converter _
)

C#

override void Iterate(
ConverterAConverter
)

C++

void Iterate(
Converter^ AConverter
)

JScript

function Iterate(
AConverter : Converter
);

Parameters

AConverter

Converter which contains the drawing data.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.RemoveEntity Method

API Reference > CADViewLib Namespace > AttDef Interface > Methods >

IAttDef.RemoveEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes a specified entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function RemoveEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int RemoveEntity(
EntityAEntity
)

C++

int RemoveEntity(
Entity^ AEntity
)

JScript

function RemoveEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity which will be removed.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.SetLType Method

API Reference > CADViewLib Namespace > AttDef Interface > Methods >

IAttDef.SetLType Method

 Return to chapter overview

Show / hide the hidden text

Sets a line type for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLType( _
ByVal Value As Entity _
)

C#

override void SetLType(
EntityValue
)

C++

void SetLType(
Entity^ Value
)

JScript

function SetLType(
Value : Entity
);

Parameters

Value

The line type value.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.SetLWeight Method

API Reference > CADViewLib Namespace > AttDef Interface > Methods >

IAttDef.SetLWeight Method

 Return to chapter overview

Show / hide the hidden text

Sets a line weight for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLWeight( _
ByVal Value As Integer _
)

C#

override void SetLWeight(
intValue
)

C++

void SetLWeight(
intValue
)

JScript

function SetLWeight(
Value : int
);

Parameters

Value

The line weight value.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


IAttDef.get_Entities Method

API Reference > CADViewLib Namespace > AttDef Interface > Methods >

IAttDef.get_Entities Method

 Return to chapter overview

Show / hide the hidden text

Returns the child entity at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Entities( _
ByVal Index As Integer _
) As Entity

C#

override Entity get_Entities(
intIndex
)

C++

Entity^ get_Entities(
intIndex
)

JScript

function get_Entities(
Index : int
) : Entity;

Parameters

Index

The index of the entity to retrieve.

collall See Also

Reference

IAttDef Interface
IAttDef IAttDef Members


Attrib Interface

API Reference > CADViewLib Namespace >

Attrib Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to ATTRIB entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface Attrib
Inherits IAttrib, _
IEntityEvents_Event

C#

public interface Attrib : IAttrib,
IEntityEvents_Event

C++

public interface class Attrib : public IAttrib^,
public IEntityEvents_Event^

JScript

public interface Attrib
implements IAttrib,
IEntityEvents_Event

collall See Also

Reference

Attrib Members


Attrib Members

API Reference > CADViewLib Namespace > Attrib Interface >

Attrib Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to ATTRIB entities.

The following tables list the members exposed by the Attrib type.

collall Public Properties

 | Name | Description
Public property | Backward | Gets a value indicating whether the text is drawn backwards. (inherited from IAttrib ).
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from IAttrib ).
Public property | CADHandle | Gets or sets the object handle. (inherited from IAttrib ).
Public property | Color | Gets or sets a color of the object. (inherited from IAttrib ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from IAttrib ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from IAttrib ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from IAttrib ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from IAttrib ).
Public property | Flags | Gets or sets the attribute flags. (inherited from IAttrib ).
Public property | Font | Gets or sets a font for displaying the text. (inherited from IAttrib ).
Public property | FontName | Gets or sets a name of the font file. (inherited from IAttrib ).
Public property | Generation | Gets or sets text generation flags. (inherited from IAttrib ).
Public property | HAlign | Gets or sets horizontal text justification type integer codes (not bit-coded). (inherited from IAttrib ).
Public property | Height | Gets or sets a height of the text. (inherited from IAttrib ).
Public property | IsSHXFont | Gets a value indicating whether the text uses an SHX font. (inherited from IAttrib ).
Public property | IsUnicodeText | Gets a value indicating whether the text uses Unicode for characters encoding. (inherited from IAttrib ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from IAttrib ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from IAttrib ).
Public property | Name | Gets or sets a name of this object. (inherited from IAttrib ).
Public property | ObliqueAngle | Gets or sets an oblique angle for text characters. (inherited from IAttrib ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from IAttrib ).
Public property | Point | Gets or sets the first alignment point. (inherited from IAttrib ).
Public property | Point1 | Gets or sets the second alignment point. (inherited from IAttrib ).
Public property | Rotation | Gets or sets the rotation angle of the text. (inherited from IAttrib ).
Public property | SHXFontName | Gets or sets a name of SHX font file. (inherited from IAttrib ).
Public property | SHXText | Gets a string of the SHX text. (inherited from IAttrib ).
Public property | SHXUnicodeText | Gets a string of the SHX Unicode text. (inherited from IAttrib ).
Public property | Scale | Gets or sets relative X scale factor (width). (inherited from IAttrib ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from IAttrib ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from IAttrib ).
Public property | StartPoint | Gets the start point of the text. (inherited from IAttrib ).
Public property | Tag | Gets or sets the tag string. (inherited from IAttrib ).
Public property | Text | Gets or sets the text value. (inherited from IAttrib ).
Public property | UnicodeText | Gets the text value as Unicode string. (inherited from IAttrib ).
Public property | UpsideDown | Gets a value indicating whether the text is upside down (mirrored in Y). (inherited from IAttrib ).
Public property | VAlign | Gets or sets vertical text justification type: integer codes (not bit-coded). (inherited from IAttrib ).
Public property | Value | Gets or sets a value of the attribute. (inherited from IAttrib ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from IAttrib ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from IAttrib ).
Public property | WinFont | Gets a value indicating whether the text is rendered using a Windows font. (inherited from IAttrib ).
Public property | XScale | Gets or sets relative X scale factor (width). (inherited from IAttrib ).

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from IAttrib ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from IAttrib ).
Public method | CreateEntity | Initializes a new object instance. (inherited from IAttrib ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from IAttrib ).
Public method | DoNewText | Replaces the text value with a new string. (inherited from IAttrib ).
Public method | EntName | Returns a name of the entity. (inherited from IAttrib ).
Public method | FreeEntity | Destroys the object instance. (inherited from IAttrib ).
Public method | GetBase | Returns the base point of the text. (inherited from IAttrib ).
Public method | GetBoxPoints | For internal use. (inherited from IAttrib ).
Public method | GetSHXMatrix | Returns a coordinate transformation matrix. (inherited from IAttrib ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from IAttrib ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from IAttrib ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from IAttrib ).
Public method | RemoveEntity | Removes a specified entity. (inherited from IAttrib ).
Public method | SetLType | Sets a line type for this object. (inherited from IAttrib ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from IAttrib ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from IAttrib ).

Top

collall See Also

Reference

Attrib Interface


Attrib Properties

API Reference > CADViewLib Namespace > Attrib Interface >

Attrib Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Backward | Gets a value indicating whether the text is drawn backwards. (inherited from IAttrib ).
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from IAttrib ).
Public property | CADHandle | Gets or sets the object handle. (inherited from IAttrib ).
Public property | Color | Gets or sets a color of the object. (inherited from IAttrib ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from IAttrib ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from IAttrib ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from IAttrib ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from IAttrib ).
Public property | Flags | Gets or sets the attribute flags. (inherited from IAttrib ).
Public property | Font | Gets or sets a font for displaying the text. (inherited from IAttrib ).
Public property | FontName | Gets or sets a name of the font file. (inherited from IAttrib ).
Public property | Generation | Gets or sets text generation flags. (inherited from IAttrib ).
Public property | HAlign | Gets or sets horizontal text justification type integer codes (not bit-coded). (inherited from IAttrib ).
Public property | Height | Gets or sets a height of the text. (inherited from IAttrib ).
Public property | IsSHXFont | Gets a value indicating whether the text uses an SHX font. (inherited from IAttrib ).
Public property | IsUnicodeText | Gets a value indicating whether the text uses Unicode for characters encoding. (inherited from IAttrib ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from IAttrib ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from IAttrib ).
Public property | Name | Gets or sets a name of this object. (inherited from IAttrib ).
Public property | ObliqueAngle | Gets or sets an oblique angle for text characters. (inherited from IAttrib ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from IAttrib ).
Public property | Point | Gets or sets the first alignment point. (inherited from IAttrib ).
Public property | Point1 | Gets or sets the second alignment point. (inherited from IAttrib ).
Public property | Rotation | Gets or sets the rotation angle of the text. (inherited from IAttrib ).
Public property | SHXFontName | Gets or sets a name of SHX font file. (inherited from IAttrib ).
Public property | SHXText | Gets a string of the SHX text. (inherited from IAttrib ).
Public property | SHXUnicodeText | Gets a string of the SHX Unicode text. (inherited from IAttrib ).
Public property | Scale | Gets or sets relative X scale factor (width). (inherited from IAttrib ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from IAttrib ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from IAttrib ).
Public property | StartPoint | Gets the start point of the text. (inherited from IAttrib ).
Public property | Tag | Gets or sets the tag string. (inherited from IAttrib ).
Public property | Text | Gets or sets the text value. (inherited from IAttrib ).
Public property | UnicodeText | Gets the text value as Unicode string. (inherited from IAttrib ).
Public property | UpsideDown | Gets a value indicating whether the text is upside down (mirrored in Y). (inherited from IAttrib ).
Public property | VAlign | Gets or sets vertical text justification type: integer codes (not bit-coded). (inherited from IAttrib ).
Public property | Value | Gets or sets a value of the attribute. (inherited from IAttrib ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from IAttrib ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from IAttrib ).
Public property | WinFont | Gets a value indicating whether the text is rendered using a Windows font. (inherited from IAttrib ).
Public property | XScale | Gets or sets relative X scale factor (width). (inherited from IAttrib ).

Top

collall See Also

Reference

Attrib Interface


IAttrib.Backward Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.Backward Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the text is drawn backwards.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Backward() As Boolean

C#

bool Backward {get;}

C++

property bool Backward {
bool get( );
}

JScript

function get Backward() : boolean;

Property Value

true if the text is drawn backwards; otherwise, false.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.Box Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.Box Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the bounding parallelepiped for the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Box() As Rect3D

C#

Rect3D Box {get;}

C++

property Rect3D^ Box {
Rect3D^ get( );
}

JScript

function get Box() : Rect3D;

Property Value

The parallelepiped which encloses the object.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.CADHandle Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.CADHandle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the object handle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CADHandle() As UInt64

C#

UInt64 CADHandle {get; set;}

C++

property UInt64 CADHandle {
UInt64 get( );
void set(
UInt64 value
);
}

JScript

function get CADHandle() : UInt64;
function set CADHandle(value : UInt64);

Property Value

Number that uniquely identifies the object in a CAD drawing.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.Color Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.Color Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a color of the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Color() As UInt32

C#

UInt32 Color {get; set;}

C++

property UInt32 Color {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get Color() : UInt32;
function set Color(value : UInt32);

Property Value

An insigned integer value which defines the object's color.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.Converter Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.Converter Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a Converter instance associated with the CAD image to which this object belongs.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Converter() As Converter

C#

Converter Converter {get;}

C++

property Converter^ Converter {
Converter^ get( );
}

JScript

function get Converter() : Converter;

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.Count Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.Count Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of objects contained within the given object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Count() As Integer

C#

int Count {get;}

C++

property int Count {
int get( );
}

JScript

function get Count() : int;

Property Value

An Integer value indicating a number of objects contained within the given object.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.EntID Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.EntID Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the entity type ID for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property EntID() As TEntityID

C#

TEntityID EntID {get; set;}

C++

property TEntityID EntID {
TEntityID get( );
void set(
TEntityID value
);
}

JScript

function get EntID() : TEntityID;
function set EntID(value : TEntityID);

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.Extrusion Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.Extrusion Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the extrusion direction vector for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Extrusion() As Point3D

C#

Point3D Extrusion {get; set;}

C++

property Point3D^ Extrusion {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Extrusion() : Point3D;
function set Extrusion(value : Point3D);

Property Value

The 3D point which defines the extrusion direction vector.

collall Remarks

The extrusion direction is the normal vector of the plane which contains the entity and it is applied to the entity base point. The default extrusion direction value is (0, 0, 1).

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.Flags Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.Flags Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the attribute flags.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Flags() As Byte

C#

byte Flags {get; set;}

C++

property Byte Flags {
Byte get( );
void set(
Byte value
);
}

JScript

function get Flags() : byte;
function set Flags(value : byte);

Property Value

1 = Attribute is invisible (does not appear)
2 = This is a constant attribute
4 = Verification is required on input of this attribute
8 = Attribute is preset (no prompt during insertion)

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.Font Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.Font Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a font for displaying the text.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Font() As StdFont

C#

StdFont Font {get; set;}

C++

property StdFont^ Font {
StdFont^ get( );
void set(
StdFont^ value
);
}

JScript

function get Font() : StdFont;
function set Font(value : StdFont);

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.FontName Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.FontName Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of the font file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property FontName() As String

C#

string FontName {get;}

C++

property String^ FontName {
String^ get( );
}

JScript

function get FontName() : String;

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.Generation Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.Generation Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets text generation flags.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Generation() As Byte

C#

byte Generation {get; set;}

C++

property Byte Generation {
Byte get( );
void set(
Byte value
);
}

JScript

function get Generation() : byte;
function set Generation(value : byte);

Property Value

0 = Default value
2 = Text is backward (mirrored in X)
4 = Text is upside down (mirrored in Y)

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.HAlign Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.HAlign Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets horizontal text justification type integer codes (not bit-coded).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property HAlign() As Byte

C#

byte HAlign {get; set;}

C++

property Byte HAlign {
Byte get( );
void set(
Byte value
);
}

JScript

function get HAlign() : byte;
function set HAlign(value : byte);

Property Value

0 = Left
1 = Center
2 = Right
3 = Aligned (if vertical alignment = 0)
4 = Middle (if vertical alignment = 0)
5 = Fit (if vertical alignment = 0)

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.Height Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.Height Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a height of the text.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Height() As Double

C#

double Height {get; set;}

C++

property double Height {
double get( );
void set(
double value
);
}

JScript

function get Height() : double;
function set Height(value : double);

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.IsSHXFont Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.IsSHXFont Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the text uses an SHX font.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsSHXFont() As Boolean

C#

bool IsSHXFont {get;}

C++

property bool IsSHXFont {
bool get( );
}

JScript

function get IsSHXFont() : boolean;

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.IsUnicodeText Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.IsUnicodeText Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the text uses Unicode for characters encoding.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsUnicodeText() As Boolean

C#

bool IsUnicodeText {get;}

C++

property bool IsUnicodeText {
bool get( );
}

JScript

function get IsUnicodeText() : boolean;

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.Layer Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.Layer Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a layer containing this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Layer() As Layer

C#

Layer Layer {get; set;}

C++

property Layer^ Layer {
Layer^ get( );
void set(
Layer^ value
);
}

JScript

function get Layer() : Layer;
function set Layer(value : Layer);

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.LineTypeScale Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.LineTypeScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a quantity of line type elements per unit of its length.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineTypeScale() As Single

C#

float LineTypeScale {get; set;}

C++

property float LineTypeScale {
float get( );
void set(
float value
);
}

JScript

function get LineTypeScale() : float;
function set LineTypeScale(value : float);

Property Value

The quantity of linetype elements per unit of its length.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.Name Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.Name Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Name() As String

C#

string Name {get; set;}

C++

property String^ Name {
String^ get( );
void set(
String^ value
);
}

JScript

function get Name() : String;
function set Name(value : String);

Property Value

String containing the object name.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.ObliqueAngle Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.ObliqueAngle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets an oblique angle for text characters.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property ObliqueAngle() As Double

C#

double ObliqueAngle {get; set;}

C++

property double ObliqueAngle {
double get( );
void set(
double value
);
}

JScript

function get ObliqueAngle() : double;
function set ObliqueAngle(value : double);

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.PaperSpace Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.PaperSpace Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is located in Paper space.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PaperSpace() As Integer

C#

int PaperSpace {get; set;}

C++

property int PaperSpace {
int get( );
void set(
int value
);
}

JScript

function get PaperSpace() : int;
function set PaperSpace(value : int);

Property Value

0 - the object is located in Model space, 1 - in Paper space.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.Point Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.Point Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the first alignment point.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Point() As Point3D

C#

Point3D Point {get; set;}

C++

property Point3D^ Point {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Point() : Point3D;
function set Point(value : Point3D);

Property Value

Point3D object which represents the first alignment point.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.Point1 Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.Point1 Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the second alignment point.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Point1() As Point3D

C#

Point3D Point1 {get; set;}

C++

property Point3D^ Point1 {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Point1() : Point3D;
function set Point1(value : Point3D);

Property Value

Point3D object which represents the second alignment point.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.Rotation Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.Rotation Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the rotation angle of the text.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Rotation() As Double

C#

double Rotation {get; set;}

C++

property double Rotation {
double get( );
void set(
double value
);
}

JScript

function get Rotation() : double;
function set Rotation(value : double);

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.SHXFontName Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.SHXFontName Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of SHX font file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property SHXFontName() As String

C#

string SHXFontName {get;}

C++

property String^ SHXFontName {
String^ get( );
}

JScript

function get SHXFontName() : String;

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.SHXText Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.SHXText Property

 Return to chapter overview

Show / hide the hidden text

Gets a string of the SHX text.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property SHXText() As String

C#

string SHXText {get;}

C++

property String^ SHXText {
String^ get( );
}

JScript

function get SHXText() : String;

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.SHXUnicodeText Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.SHXUnicodeText Property

 Return to chapter overview

Show / hide the hidden text

Gets a string of the SHX Unicode text.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property SHXUnicodeText() As String

C#

string SHXUnicodeText {get;}

C++

property String^ SHXUnicodeText {
String^ get( );
}

JScript

function get SHXUnicodeText() : String;

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.Scale Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.Scale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets relative X scale factor (width).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Scale() As Double

C#

double Scale {get; set;}

C++

property double Scale {
double get( );
void set(
double value
);
}

JScript

function get Scale() : double;
function set Scale(value : double);

Property Value

Default value is 1.
More than 1 if the text letters are stretched; less than 1 and more than 0 if the text letters are squeezed.

collall Remarks

The modified width is equal to the previous text width multiplied by the scale factor.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.SrcEnd Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.SrcEnd Property

 Return to chapter overview

Show / hide the hidden text

Indicates the end of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcEnd() As String

C#

string SrcEnd {get; set;}

C++

property String^ SrcEnd {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcEnd() : String;
function set SrcEnd(value : String);

Property Value

A String value indicating the end of the record which represents this object in a drawing file.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.SrcStart Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.SrcStart Property

 Return to chapter overview

Show / hide the hidden text

Indicates the beginning of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcStart() As String

C#

string SrcStart {get; set;}

C++

property String^ SrcStart {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcStart() : String;
function set SrcStart(value : String);

Property Value

A String value indicating the beginning of the record which represents this object in a drawing file.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.StartPoint Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.StartPoint Property

 Return to chapter overview

Show / hide the hidden text

Gets the start point of the text.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property StartPoint() As Point3D

C#

Point3D StartPoint {get;}

C++

property Point3D^ StartPoint {
Point3D^ get( );
}

JScript

function get StartPoint() : Point3D;

Property Value

Point3D type value indicating the start point of the text.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.Tag Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.Tag Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the tag string.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Tag() As String

C#

string Tag {get; set;}

C++

property String^ Tag {
String^ get( );
void set(
String^ value
);
}

JScript

function get Tag() : String;
function set Tag(value : String);

Property Value

Can contain any characters except spaces or exclamation points.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.Text Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.Text Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the text value.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Text() As String

C#

string Text {get; set;}

C++

property String^ Text {
String^ get( );
void set(
String^ value
);
}

JScript

function get Text() : String;
function set Text(value : String);

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.UnicodeText Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.UnicodeText Property

 Return to chapter overview

Show / hide the hidden text

Gets the text value as Unicode string.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property UnicodeText() As String

C#

string UnicodeText {get;}

C++

property String^ UnicodeText {
String^ get( );
}

JScript

function get UnicodeText() : String;

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.UpsideDown Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.UpsideDown Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the text is upside down (mirrored in Y).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property UpsideDown() As Boolean

C#

bool UpsideDown {get;}

C++

property bool UpsideDown {
bool get( );
}

JScript

function get UpsideDown() : boolean;

Property Value

true if the text is upside down; otherwise, false.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.VAlign Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.VAlign Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets vertical text justification type: integer codes (not bit-coded).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property VAlign() As Byte

C#

byte VAlign {get; set;}

C++

property Byte VAlign {
Byte get( );
void set(
Byte value
);
}

JScript

function get VAlign() : byte;
function set VAlign(value : byte);

Property Value

0 = Baseline
1 = Bottom
2 = Middle
3 = Top

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.Value Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.Value Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value of the attribute.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Value() As String

C#

string Value {get; set;}

C++

property String^ Value {
String^ get( );
void set(
String^ value
);
}

JScript

function get Value() : String;
function set Value(value : String);

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.Visibility Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.Visibility Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visibility() As Boolean

C#

bool Visibility {get; set;}

C++

property bool Visibility {
bool get( );
void set(
bool value
);
}

JScript

function get Visibility() : boolean;
function set Visibility(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.Visible Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.Visible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visible() As Boolean

C#

bool Visible {get; set;}

C++

property bool Visible {
bool get( );
void set(
bool value
);
}

JScript

function get Visible() : boolean;
function set Visible(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.WinFont Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.WinFont Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the text is rendered using a Windows font.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property WinFont() As Boolean

C#

bool WinFont {get;}

C++

property bool WinFont {
bool get( );
}

JScript

function get WinFont() : boolean;

Property Value

true if the text is rendered using a Windows font; otherwise, false.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.XScale Property

API Reference > CADViewLib Namespace > Attrib Interface > Properties >

IAttrib.XScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets relative X scale factor (width).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property XScale() As Double

C#

double XScale {get;}

C++

property double XScale {
double get( );
}

JScript

function get XScale() : double;

Property Value

Default value is 1.
More than 1 if the text letters are stretched; less than 1 and more than 0 if the text letters are squeezed.

collall Remarks

The modified width is equal to the previous text width multiplied by the scale factor.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


Attrib Methods

API Reference > CADViewLib Namespace > Attrib Interface >

Attrib Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from IAttrib ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from IAttrib ).
Public method | CreateEntity | Initializes a new object instance. (inherited from IAttrib ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from IAttrib ).
Public method | DoNewText | Replaces the text value with a new string. (inherited from IAttrib ).
Public method | EntName | Returns a name of the entity. (inherited from IAttrib ).
Public method | FreeEntity | Destroys the object instance. (inherited from IAttrib ).
Public method | GetBase | Returns the base point of the text. (inherited from IAttrib ).
Public method | GetBoxPoints | For internal use. (inherited from IAttrib ).
Public method | GetSHXMatrix | Returns a coordinate transformation matrix. (inherited from IAttrib ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from IAttrib ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from IAttrib ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from IAttrib ).
Public method | RemoveEntity | Removes a specified entity. (inherited from IAttrib ).
Public method | SetLType | Sets a line type for this object. (inherited from IAttrib ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from IAttrib ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from IAttrib ).

Top

collall See Also

Reference

Attrib Interface


IAttrib.AddEntity Method

API Reference > CADViewLib Namespace > Attrib Interface > Methods >

IAttrib.AddEntity Method

 Return to chapter overview

Show / hide the hidden text

Adds a new child entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AddEntity( _
ByVal AEntity As Entity _
)

C#

override void AddEntity(
EntityAEntity
)

C++

void AddEntity(
Entity^ AEntity
)

JScript

function AddEntity(
AEntity : Entity
);

Parameters

AEntity

Added entity.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.AssignEntity Method

API Reference > CADViewLib Namespace > Attrib Interface > Methods >

IAttrib.AssignEntity Method

 Return to chapter overview

Show / hide the hidden text

Assigns the properties of the specified entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AssignEntity( _
ByVal Source As Entity _
)

C#

override void AssignEntity(
EntitySource
)

C++

void AssignEntity(
Entity^ Source
)

JScript

function AssignEntity(
Source : Entity
);

Parameters

Source

Entity which has the same type as the current object.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.CreateEntity Method

API Reference > CADViewLib Namespace > Attrib Interface > Methods >

IAttrib.CreateEntity Method

 Return to chapter overview

Show / hide the hidden text

Initializes a new object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub CreateEntity()

C#

override void CreateEntity()

C++

void CreateEntity()

JScript

function CreateEntity();

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.DeleteEntity Method

API Reference > CADViewLib Namespace > Attrib Interface > Methods >

IAttrib.DeleteEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes an entity specified by index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub DeleteEntity( _
ByVal AIndex As Integer _
)

C#

override void DeleteEntity(
intAIndex
)

C++

void DeleteEntity(
intAIndex
)

JScript

function DeleteEntity(
AIndex : int
);

Parameters

AIndex

Index of the entity.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.DoNewText Method

API Reference > CADViewLib Namespace > Attrib Interface > Methods >

IAttrib.DoNewText Method

 Return to chapter overview

Show / hide the hidden text

Replaces the text value with a new string.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub DoNewText( _
ByVal ANewText As String _
)

C#

override void DoNewText(
stringANewText
)

C++

void DoNewText(
String^ ANewText
)

JScript

function DoNewText(
ANewText : String
);

Parameters

ANewText

New text value.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.EntName Method

API Reference > CADViewLib Namespace > Attrib Interface > Methods >

IAttrib.EntName Method

 Return to chapter overview

Show / hide the hidden text

Returns a name of the entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function EntName() As String

C#

override string EntName()

C++

String^ EntName()

JScript

function EntName() : String;

Return Value

A string containing the entity name.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.FreeEntity Method

API Reference > CADViewLib Namespace > Attrib Interface > Methods >

IAttrib.FreeEntity Method

 Return to chapter overview

Show / hide the hidden text

Destroys the object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub FreeEntity()

C#

override void FreeEntity()

C++

void FreeEntity()

JScript

function FreeEntity();

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.GetBase Method

API Reference > CADViewLib Namespace > Attrib Interface > Methods >

IAttrib.GetBase Method

 Return to chapter overview

Show / hide the hidden text

Returns the base point of the text.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub GetBase( _
ByVal AWidth As Double, _
ByVal AHeight As Double, _
ByRef Base As Point3D, _
ByRef Start As Point3D _
)

C#

override void GetBase(
doubleAWidth,
doubleAHeight,
ref Point3DBase,
ref Point3DStart
)

C++

void GetBase(
doubleAWidth,
doubleAHeight,
Point3D^& Base,
Point3D^& Start
)

JScript

function GetBase(
AWidth : double,
AHeight : double,
Base : Point3D,
Start : Point3D
);

Parameters

AWidth

The text width.

AHeight

The text height.

Base

The base point.

Start

The point starting from which the text is drawn.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.GetBoxPoints Method

API Reference > CADViewLib Namespace > Attrib Interface > Methods >

IAttrib.GetBoxPoints Method

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetBoxPoints( _
ByVal Full As Boolean _
) As Boolean

C#

override bool GetBoxPoints(
boolFull
)

C++

bool GetBoxPoints(
boolFull
)

JScript

function GetBoxPoints(
Full : boolean
) : boolean;

Parameters

Full

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.GetSHXMatrix Method

API Reference > CADViewLib Namespace > Attrib Interface > Methods >

IAttrib.GetSHXMatrix Method

 Return to chapter overview

Show / hide the hidden text

Returns a coordinate transformation matrix.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub GetSHXMatrix( _
ByRef Matrix As Object _
)

C#

override void GetSHXMatrix(
ref objectMatrix
)

C++

void GetSHXMatrix(
object^& Matrix
)

JScript

function GetSHXMatrix(
Matrix : object
);

Parameters

Matrix

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.GetThickness Method

API Reference > CADViewLib Namespace > Attrib Interface > Methods >

IAttrib.GetThickness Method

 Return to chapter overview

Show / hide the hidden text

Returns the line thickness for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetThickness() As Double

C#

override double GetThickness()

C++

double GetThickness()

JScript

function GetThickness() : double;

Return Value

A Double type value indicating the line thickness.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.IndexOfEntity Method

API Reference > CADViewLib Namespace > Attrib Interface > Methods >

IAttrib.IndexOfEntity Method

 Return to chapter overview

Show / hide the hidden text

Returns index of the given entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function IndexOfEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int IndexOfEntity(
EntityAEntity
)

C++

int IndexOfEntity(
Entity^ AEntity
)

JScript

function IndexOfEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity whose index is retrieved.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.Iterate Method

API Reference > CADViewLib Namespace > Attrib Interface > Methods >

IAttrib.Iterate Method

 Return to chapter overview

Show / hide the hidden text

Iterates through the entities in the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub Iterate( _
ByVal AConverter As Converter _
)

C#

override void Iterate(
ConverterAConverter
)

C++

void Iterate(
Converter^ AConverter
)

JScript

function Iterate(
AConverter : Converter
);

Parameters

AConverter

Converter which contains the drawing data.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.RemoveEntity Method

API Reference > CADViewLib Namespace > Attrib Interface > Methods >

IAttrib.RemoveEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes a specified entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function RemoveEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int RemoveEntity(
EntityAEntity
)

C++

int RemoveEntity(
Entity^ AEntity
)

JScript

function RemoveEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity which will be removed.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.SetLType Method

API Reference > CADViewLib Namespace > Attrib Interface > Methods >

IAttrib.SetLType Method

 Return to chapter overview

Show / hide the hidden text

Sets a line type for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLType( _
ByVal Value As Entity _
)

C#

override void SetLType(
EntityValue
)

C++

void SetLType(
Entity^ Value
)

JScript

function SetLType(
Value : Entity
);

Parameters

Value

The line type value.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.SetLWeight Method

API Reference > CADViewLib Namespace > Attrib Interface > Methods >

IAttrib.SetLWeight Method

 Return to chapter overview

Show / hide the hidden text

Sets a line weight for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLWeight( _
ByVal Value As Integer _
)

C#

override void SetLWeight(
intValue
)

C++

void SetLWeight(
intValue
)

JScript

function SetLWeight(
Value : int
);

Parameters

Value

The line weight value.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


IAttrib.get_Entities Method

API Reference > CADViewLib Namespace > Attrib Interface > Methods >

IAttrib.get_Entities Method

 Return to chapter overview

Show / hide the hidden text

Returns the child entity at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Entities( _
ByVal Index As Integer _
) As Entity

C#

override Entity get_Entities(
intIndex
)

C++

Entity^ get_Entities(
intIndex
)

JScript

function get_Entities(
Index : int
) : Entity;

Parameters

Index

The index of the entity to retrieve.

collall See Also

Reference

IAttrib Interface
IAttrib IAttrib Members


Block Interface

API Reference > CADViewLib Namespace >

Block Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to BLOCK entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface Block
Inherits IBlock, _
IEntityEvents_Event

C#

public interface Block : IBlock,
IEntityEvents_Event

C++

public interface class Block : public IBlock^,
public IEntityEvents_Event^

JScript

public interface Block
implements IBlock,
IEntityEvents_Event

collall See Also

Reference

Block Members


Block Members

API Reference > CADViewLib Namespace > Block Interface >

Block Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to BLOCK entities.

The following tables list the members exposed by the Block type.

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from IBlock ).
Public property | CADHandle | Gets or sets the object handle. (inherited from IBlock ).
Public property | Color | Gets or sets a color of the object. (inherited from IBlock ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from IBlock ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from IBlock ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from IBlock ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from IBlock ).
Public property | Flags | Gets or sets the block-type flags (bit-coded values, may be combined). (inherited from IBlock ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from IBlock ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from IBlock ).
Public property | Name | Gets or sets a name of this object. (inherited from IBlock ).
Public property | Offset | Gets or sets the block offset point. (inherited from IBlock ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from IBlock ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from IBlock ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from IBlock ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from IBlock ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from IBlock ).
Public property | XrefPath | Gets or sets an Xref path name. (inherited from IBlock ).

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from IBlock ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from IBlock ).
Public method | CreateEntity | Initializes a new object instance. (inherited from IBlock ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from IBlock ).
Public method | EntName | Returns a name of the entity. (inherited from IBlock ).
Public method | FreeEntity | Destroys the object instance. (inherited from IBlock ).
Public method | GetBoxPoints | For internal use. (inherited from IBlock ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from IBlock ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from IBlock ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from IBlock ).
Public method | RemoveEntity | Removes a specified entity. (inherited from IBlock ).
Public method | SetLType | Sets a line type for this object. (inherited from IBlock ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from IBlock ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from IBlock ).

Top

collall See Also

Reference

Block Interface


Block Properties

API Reference > CADViewLib Namespace > Block Interface >

Block Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from IBlock ).
Public property | CADHandle | Gets or sets the object handle. (inherited from IBlock ).
Public property | Color | Gets or sets a color of the object. (inherited from IBlock ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from IBlock ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from IBlock ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from IBlock ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from IBlock ).
Public property | Flags | Gets or sets the block-type flags (bit-coded values, may be combined). (inherited from IBlock ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from IBlock ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from IBlock ).
Public property | Name | Gets or sets a name of this object. (inherited from IBlock ).
Public property | Offset | Gets or sets the block offset point. (inherited from IBlock ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from IBlock ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from IBlock ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from IBlock ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from IBlock ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from IBlock ).
Public property | XrefPath | Gets or sets an Xref path name. (inherited from IBlock ).

Top

collall See Also

Reference

Block Interface


IBlock.Box Property

API Reference > CADViewLib Namespace > Block Interface > Properties >

IBlock.Box Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the bounding parallelepiped for the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Box() As Rect3D

C#

Rect3D Box {get;}

C++

property Rect3D^ Box {
Rect3D^ get( );
}

JScript

function get Box() : Rect3D;

Property Value

The parallelepiped which encloses the object.

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.CADHandle Property

API Reference > CADViewLib Namespace > Block Interface > Properties >

IBlock.CADHandle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the object handle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CADHandle() As UInt64

C#

UInt64 CADHandle {get; set;}

C++

property UInt64 CADHandle {
UInt64 get( );
void set(
UInt64 value
);
}

JScript

function get CADHandle() : UInt64;
function set CADHandle(value : UInt64);

Property Value

Number that uniquely identifies the object in a CAD drawing.

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.Color Property

API Reference > CADViewLib Namespace > Block Interface > Properties >

IBlock.Color Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a color of the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Color() As UInt32

C#

UInt32 Color {get; set;}

C++

property UInt32 Color {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get Color() : UInt32;
function set Color(value : UInt32);

Property Value

An insigned integer value which defines the object's color.

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.Converter Property

API Reference > CADViewLib Namespace > Block Interface > Properties >

IBlock.Converter Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a Converter instance associated with the CAD image to which this object belongs.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Converter() As Converter

C#

Converter Converter {get;}

C++

property Converter^ Converter {
Converter^ get( );
}

JScript

function get Converter() : Converter;

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.Count Property

API Reference > CADViewLib Namespace > Block Interface > Properties >

IBlock.Count Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of objects contained within the given object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Count() As Integer

C#

int Count {get;}

C++

property int Count {
int get( );
}

JScript

function get Count() : int;

Property Value

An Integer value indicating a number of objects contained within the given object.

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.EntID Property

API Reference > CADViewLib Namespace > Block Interface > Properties >

IBlock.EntID Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the entity type ID for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property EntID() As TEntityID

C#

TEntityID EntID {get; set;}

C++

property TEntityID EntID {
TEntityID get( );
void set(
TEntityID value
);
}

JScript

function get EntID() : TEntityID;
function set EntID(value : TEntityID);

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.Extrusion Property

API Reference > CADViewLib Namespace > Block Interface > Properties >

IBlock.Extrusion Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the extrusion direction vector for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Extrusion() As Point3D

C#

Point3D Extrusion {get; set;}

C++

property Point3D^ Extrusion {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Extrusion() : Point3D;
function set Extrusion(value : Point3D);

Property Value

The 3D point which defines the extrusion direction vector.

collall Remarks

The extrusion direction is the normal vector of the plane which contains the entity and it is applied to the entity base point. The default extrusion direction value is (0, 0, 1).

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.Flags Property

API Reference > CADViewLib Namespace > Block Interface > Properties >

IBlock.Flags Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the block-type flags (bit-coded values, may be combined).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Flags() As Integer

C#

int Flags {get; set;}

C++

property int Flags {
int get( );
void set(
int value
);
}

JScript

function get Flags() : int;
function set Flags(value : int);

Property Value

0 = Indicates none of the following flags apply
1 = This is an anonymous block generated by hatching, associative dimensioning, other internal
operations, or an application
2 = This block has non-constant attribute definitions (this bit is not set if the block has any attribute
definitions that are constant, or has no attribute definitions at all)
4 = This block is an external reference (xref)
8 = This block is an xref overlay
16 = This block is externally dependent
32 = This is a resolved external reference, or dependent of an external reference (ignored on input)
64 = This definition is a referenced external reference (ignored on input)

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.Layer Property

API Reference > CADViewLib Namespace > Block Interface > Properties >

IBlock.Layer Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a layer containing this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Layer() As Layer

C#

Layer Layer {get; set;}

C++

property Layer^ Layer {
Layer^ get( );
void set(
Layer^ value
);
}

JScript

function get Layer() : Layer;
function set Layer(value : Layer);

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.LineTypeScale Property

API Reference > CADViewLib Namespace > Block Interface > Properties >

IBlock.LineTypeScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a quantity of line type elements per unit of its length.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineTypeScale() As Single

C#

float LineTypeScale {get; set;}

C++

property float LineTypeScale {
float get( );
void set(
float value
);
}

JScript

function get LineTypeScale() : float;
function set LineTypeScale(value : float);

Property Value

The quantity of linetype elements per unit of its length.

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.Name Property

API Reference > CADViewLib Namespace > Block Interface > Properties >

IBlock.Name Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Name() As String

C#

string Name {get; set;}

C++

property String^ Name {
String^ get( );
void set(
String^ value
);
}

JScript

function get Name() : String;
function set Name(value : String);

Property Value

String containing the object name.

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.Offset Property

API Reference > CADViewLib Namespace > Block Interface > Properties >

IBlock.Offset Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the block offset point.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Offset() As Point3D

C#

Point3D Offset {get; set;}

C++

property Point3D^ Offset {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Offset() : Point3D;
function set Offset(value : Point3D);

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.PaperSpace Property

API Reference > CADViewLib Namespace > Block Interface > Properties >

IBlock.PaperSpace Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is located in Paper space.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PaperSpace() As Integer

C#

int PaperSpace {get; set;}

C++

property int PaperSpace {
int get( );
void set(
int value
);
}

JScript

function get PaperSpace() : int;
function set PaperSpace(value : int);

Property Value

0 - the object is located in Model space, 1 - in Paper space.

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.SrcEnd Property

API Reference > CADViewLib Namespace > Block Interface > Properties >

IBlock.SrcEnd Property

 Return to chapter overview

Show / hide the hidden text

Indicates the end of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcEnd() As String

C#

string SrcEnd {get; set;}

C++

property String^ SrcEnd {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcEnd() : String;
function set SrcEnd(value : String);

Property Value

A String value indicating the end of the record which represents this object in a drawing file.

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.SrcStart Property

API Reference > CADViewLib Namespace > Block Interface > Properties >

IBlock.SrcStart Property

 Return to chapter overview

Show / hide the hidden text

Indicates the beginning of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcStart() As String

C#

string SrcStart {get; set;}

C++

property String^ SrcStart {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcStart() : String;
function set SrcStart(value : String);

Property Value

A String value indicating the beginning of the record which represents this object in a drawing file.

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.Visibility Property

API Reference > CADViewLib Namespace > Block Interface > Properties >

IBlock.Visibility Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visibility() As Boolean

C#

bool Visibility {get; set;}

C++

property bool Visibility {
bool get( );
void set(
bool value
);
}

JScript

function get Visibility() : boolean;
function set Visibility(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.Visible Property

API Reference > CADViewLib Namespace > Block Interface > Properties >

IBlock.Visible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visible() As Boolean

C#

bool Visible {get; set;}

C++

property bool Visible {
bool get( );
void set(
bool value
);
}

JScript

function get Visible() : boolean;
function set Visible(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.XrefPath Property

API Reference > CADViewLib Namespace > Block Interface > Properties >

IBlock.XrefPath Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets an Xref path name.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property XrefPath() As String

C#

string XrefPath {get; set;}

C++

property String^ XrefPath {
String^ get( );
void set(
String^ value
);
}

JScript

function get XrefPath() : String;
function set XrefPath(value : String);

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


Block Methods

API Reference > CADViewLib Namespace > Block Interface >

Block Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from IBlock ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from IBlock ).
Public method | CreateEntity | Initializes a new object instance. (inherited from IBlock ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from IBlock ).
Public method | EntName | Returns a name of the entity. (inherited from IBlock ).
Public method | FreeEntity | Destroys the object instance. (inherited from IBlock ).
Public method | GetBoxPoints | For internal use. (inherited from IBlock ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from IBlock ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from IBlock ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from IBlock ).
Public method | RemoveEntity | Removes a specified entity. (inherited from IBlock ).
Public method | SetLType | Sets a line type for this object. (inherited from IBlock ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from IBlock ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from IBlock ).

Top

collall See Also

Reference

Block Interface


IBlock.AddEntity Method

API Reference > CADViewLib Namespace > Block Interface > Methods >

IBlock.AddEntity Method

 Return to chapter overview

Show / hide the hidden text

Adds a new child entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AddEntity( _
ByVal AEntity As Entity _
)

C#

override void AddEntity(
EntityAEntity
)

C++

void AddEntity(
Entity^ AEntity
)

JScript

function AddEntity(
AEntity : Entity
);

Parameters

AEntity

Added entity.

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.AssignEntity Method

API Reference > CADViewLib Namespace > Block Interface > Methods >

IBlock.AssignEntity Method

 Return to chapter overview

Show / hide the hidden text

Assigns the properties of the specified entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AssignEntity( _
ByVal Source As Entity _
)

C#

override void AssignEntity(
EntitySource
)

C++

void AssignEntity(
Entity^ Source
)

JScript

function AssignEntity(
Source : Entity
);

Parameters

Source

Entity which has the same type as the current object.

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.CreateEntity Method

API Reference > CADViewLib Namespace > Block Interface > Methods >

IBlock.CreateEntity Method

 Return to chapter overview

Show / hide the hidden text

Initializes a new object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub CreateEntity()

C#

override void CreateEntity()

C++

void CreateEntity()

JScript

function CreateEntity();

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.DeleteEntity Method

API Reference > CADViewLib Namespace > Block Interface > Methods >

IBlock.DeleteEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes an entity specified by index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub DeleteEntity( _
ByVal AIndex As Integer _
)

C#

override void DeleteEntity(
intAIndex
)

C++

void DeleteEntity(
intAIndex
)

JScript

function DeleteEntity(
AIndex : int
);

Parameters

AIndex

Index of the entity.

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.EntName Method

API Reference > CADViewLib Namespace > Block Interface > Methods >

IBlock.EntName Method

 Return to chapter overview

Show / hide the hidden text

Returns a name of the entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function EntName() As String

C#

override string EntName()

C++

String^ EntName()

JScript

function EntName() : String;

Return Value

A string containing the entity name.

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.FreeEntity Method

API Reference > CADViewLib Namespace > Block Interface > Methods >

IBlock.FreeEntity Method

 Return to chapter overview

Show / hide the hidden text

Destroys the object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub FreeEntity()

C#

override void FreeEntity()

C++

void FreeEntity()

JScript

function FreeEntity();

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.GetBoxPoints Method

API Reference > CADViewLib Namespace > Block Interface > Methods >

IBlock.GetBoxPoints Method

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetBoxPoints( _
ByVal Full As Boolean _
) As Boolean

C#

override bool GetBoxPoints(
boolFull
)

C++

bool GetBoxPoints(
boolFull
)

JScript

function GetBoxPoints(
Full : boolean
) : boolean;

Parameters

Full

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.GetThickness Method

API Reference > CADViewLib Namespace > Block Interface > Methods >

IBlock.GetThickness Method

 Return to chapter overview

Show / hide the hidden text

Returns the line thickness for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetThickness() As Double

C#

override double GetThickness()

C++

double GetThickness()

JScript

function GetThickness() : double;

Return Value

A Double type value indicating the line thickness.

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.IndexOfEntity Method

API Reference > CADViewLib Namespace > Block Interface > Methods >

IBlock.IndexOfEntity Method

 Return to chapter overview

Show / hide the hidden text

Returns index of the given entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function IndexOfEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int IndexOfEntity(
EntityAEntity
)

C++

int IndexOfEntity(
Entity^ AEntity
)

JScript

function IndexOfEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity whose index is retrieved.

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.Iterate Method

API Reference > CADViewLib Namespace > Block Interface > Methods >

IBlock.Iterate Method

 Return to chapter overview

Show / hide the hidden text

Iterates through the entities in the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub Iterate( _
ByVal AConverter As Converter _
)

C#

override void Iterate(
ConverterAConverter
)

C++

void Iterate(
Converter^ AConverter
)

JScript

function Iterate(
AConverter : Converter
);

Parameters

AConverter

Converter which contains the drawing data.

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.RemoveEntity Method

API Reference > CADViewLib Namespace > Block Interface > Methods >

IBlock.RemoveEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes a specified entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function RemoveEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int RemoveEntity(
EntityAEntity
)

C++

int RemoveEntity(
Entity^ AEntity
)

JScript

function RemoveEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity which will be removed.

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.SetLType Method

API Reference > CADViewLib Namespace > Block Interface > Methods >

IBlock.SetLType Method

 Return to chapter overview

Show / hide the hidden text

Sets a line type for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLType( _
ByVal Value As Entity _
)

C#

override void SetLType(
EntityValue
)

C++

void SetLType(
Entity^ Value
)

JScript

function SetLType(
Value : Entity
);

Parameters

Value

The line type value.

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.SetLWeight Method

API Reference > CADViewLib Namespace > Block Interface > Methods >

IBlock.SetLWeight Method

 Return to chapter overview

Show / hide the hidden text

Sets a line weight for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLWeight( _
ByVal Value As Integer _
)

C#

override void SetLWeight(
intValue
)

C++

void SetLWeight(
intValue
)

JScript

function SetLWeight(
Value : int
);

Parameters

Value

The line weight value.

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


IBlock.get_Entities Method

API Reference > CADViewLib Namespace > Block Interface > Methods >

IBlock.get_Entities Method

 Return to chapter overview

Show / hide the hidden text

Returns the child entity at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Entities( _
ByVal Index As Integer _
) As Entity

C#

override Entity get_Entities(
intIndex
)

C++

Entity^ get_Entities(
intIndex
)

JScript

function get_Entities(
Index : int
) : Entity;

Parameters

Index

The index of the entity to retrieve.

collall See Also

Reference

IBlock Interface
IBlock IBlock Members


CADLine Interface

API Reference > CADViewLib Namespace >

CADLine Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to LINE entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface CADLine
Inherits ICADLine, _
IEntityEvents_Event

C#

public interface CADLine : ICADLine,
IEntityEvents_Event

C++

public interface class CADLine : public ICADLine^,
public IEntityEvents_Event^

JScript

public interface CADLine
implements ICADLine,
IEntityEvents_Event

collall See Also

Reference

CADLine Members


CADLine Members

API Reference > CADViewLib Namespace > CADLine Interface >

CADLine Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to LINE entities.

The following tables list the members exposed by the CADLine type.

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from ICADLine ).
Public property | CADHandle | Gets or sets the object handle. (inherited from ICADLine ).
Public property | Color | Gets or sets a color of the object. (inherited from ICADLine ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from ICADLine ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from ICADLine ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from ICADLine ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from ICADLine ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from ICADLine ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from ICADLine ).
Public property | Name | Gets or sets a name of this object. (inherited from ICADLine ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from ICADLine ).
Public property | Point | Gets or sets the start point. (inherited from ICADLine ).
Public property | Point1 | Gets or sets the endpoint. (inherited from ICADLine ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from ICADLine ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from ICADLine ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from ICADLine ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from ICADLine ).

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from ICADLine ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from ICADLine ).
Public method | CreateEntity | Initializes a new object instance. (inherited from ICADLine ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from ICADLine ).
Public method | EntName | Returns a name of the entity. (inherited from ICADLine ).
Public method | FreeEntity | Destroys the object instance. (inherited from ICADLine ).
Public method | GetBoxPoints | For internal use. (inherited from ICADLine ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from ICADLine ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from ICADLine ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from ICADLine ).
Public method | RemoveEntity | Removes a specified entity. (inherited from ICADLine ).
Public method | SetLType | Sets a line type for this object. (inherited from ICADLine ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from ICADLine ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from ICADLine ).

Top

collall See Also

Reference

CADLine Interface


CADLine Properties

API Reference > CADViewLib Namespace > CADLine Interface >

CADLine Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from ICADLine ).
Public property | CADHandle | Gets or sets the object handle. (inherited from ICADLine ).
Public property | Color | Gets or sets a color of the object. (inherited from ICADLine ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from ICADLine ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from ICADLine ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from ICADLine ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from ICADLine ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from ICADLine ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from ICADLine ).
Public property | Name | Gets or sets a name of this object. (inherited from ICADLine ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from ICADLine ).
Public property | Point | Gets or sets the start point. (inherited from ICADLine ).
Public property | Point1 | Gets or sets the endpoint. (inherited from ICADLine ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from ICADLine ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from ICADLine ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from ICADLine ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from ICADLine ).

Top

collall See Also

Reference

CADLine Interface


ICADLine.Box Property

API Reference > CADViewLib Namespace > CADLine Interface > Properties >

ICADLine.Box Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the bounding parallelepiped for the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Box() As Rect3D

C#

Rect3D Box {get;}

C++

property Rect3D^ Box {
Rect3D^ get( );
}

JScript

function get Box() : Rect3D;

Property Value

The parallelepiped which encloses the object.

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.CADHandle Property

API Reference > CADViewLib Namespace > CADLine Interface > Properties >

ICADLine.CADHandle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the object handle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CADHandle() As UInt64

C#

UInt64 CADHandle {get; set;}

C++

property UInt64 CADHandle {
UInt64 get( );
void set(
UInt64 value
);
}

JScript

function get CADHandle() : UInt64;
function set CADHandle(value : UInt64);

Property Value

Number that uniquely identifies the object in a CAD drawing.

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.Color Property

API Reference > CADViewLib Namespace > CADLine Interface > Properties >

ICADLine.Color Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a color of the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Color() As UInt32

C#

UInt32 Color {get; set;}

C++

property UInt32 Color {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get Color() : UInt32;
function set Color(value : UInt32);

Property Value

An insigned integer value which defines the object's color.

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.Converter Property

API Reference > CADViewLib Namespace > CADLine Interface > Properties >

ICADLine.Converter Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a Converter instance associated with the CAD image to which this object belongs.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Converter() As Converter

C#

Converter Converter {get;}

C++

property Converter^ Converter {
Converter^ get( );
}

JScript

function get Converter() : Converter;

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.Count Property

API Reference > CADViewLib Namespace > CADLine Interface > Properties >

ICADLine.Count Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of objects contained within the given object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Count() As Integer

C#

int Count {get;}

C++

property int Count {
int get( );
}

JScript

function get Count() : int;

Property Value

An Integer value indicating a number of objects contained within the given object.

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.EntID Property

API Reference > CADViewLib Namespace > CADLine Interface > Properties >

ICADLine.EntID Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the entity type ID for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property EntID() As TEntityID

C#

TEntityID EntID {get; set;}

C++

property TEntityID EntID {
TEntityID get( );
void set(
TEntityID value
);
}

JScript

function get EntID() : TEntityID;
function set EntID(value : TEntityID);

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.Extrusion Property

API Reference > CADViewLib Namespace > CADLine Interface > Properties >

ICADLine.Extrusion Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the extrusion direction vector for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Extrusion() As Point3D

C#

Point3D Extrusion {get; set;}

C++

property Point3D^ Extrusion {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Extrusion() : Point3D;
function set Extrusion(value : Point3D);

Property Value

The 3D point which defines the extrusion direction vector.

collall Remarks

The extrusion direction is the normal vector of the plane which contains the entity and it is applied to the entity base point. The default extrusion direction value is (0, 0, 1).

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.Layer Property

API Reference > CADViewLib Namespace > CADLine Interface > Properties >

ICADLine.Layer Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a layer containing this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Layer() As Layer

C#

Layer Layer {get; set;}

C++

property Layer^ Layer {
Layer^ get( );
void set(
Layer^ value
);
}

JScript

function get Layer() : Layer;
function set Layer(value : Layer);

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.LineTypeScale Property

API Reference > CADViewLib Namespace > CADLine Interface > Properties >

ICADLine.LineTypeScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a quantity of line type elements per unit of its length.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineTypeScale() As Single

C#

float LineTypeScale {get; set;}

C++

property float LineTypeScale {
float get( );
void set(
float value
);
}

JScript

function get LineTypeScale() : float;
function set LineTypeScale(value : float);

Property Value

The quantity of linetype elements per unit of its length.

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.Name Property

API Reference > CADViewLib Namespace > CADLine Interface > Properties >

ICADLine.Name Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Name() As String

C#

string Name {get; set;}

C++

property String^ Name {
String^ get( );
void set(
String^ value
);
}

JScript

function get Name() : String;
function set Name(value : String);

Property Value

String containing the object name.

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.PaperSpace Property

API Reference > CADViewLib Namespace > CADLine Interface > Properties >

ICADLine.PaperSpace Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is located in Paper space.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PaperSpace() As Integer

C#

int PaperSpace {get; set;}

C++

property int PaperSpace {
int get( );
void set(
int value
);
}

JScript

function get PaperSpace() : int;
function set PaperSpace(value : int);

Property Value

0 - the object is located in Model space, 1 - in Paper space.

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.Point Property

API Reference > CADViewLib Namespace > CADLine Interface > Properties >

ICADLine.Point Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the start point.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Point() As Point3D

C#

Point3D Point {get; set;}

C++

property Point3D^ Point {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Point() : Point3D;
function set Point(value : Point3D);

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.Point1 Property

API Reference > CADViewLib Namespace > CADLine Interface > Properties >

ICADLine.Point1 Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the endpoint.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Point1() As Point3D

C#

Point3D Point1 {get; set;}

C++

property Point3D^ Point1 {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Point1() : Point3D;
function set Point1(value : Point3D);

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.SrcEnd Property

API Reference > CADViewLib Namespace > CADLine Interface > Properties >

ICADLine.SrcEnd Property

 Return to chapter overview

Show / hide the hidden text

Indicates the end of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcEnd() As String

C#

string SrcEnd {get; set;}

C++

property String^ SrcEnd {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcEnd() : String;
function set SrcEnd(value : String);

Property Value

A String value indicating the end of the record which represents this object in a drawing file.

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.SrcStart Property

API Reference > CADViewLib Namespace > CADLine Interface > Properties >

ICADLine.SrcStart Property

 Return to chapter overview

Show / hide the hidden text

Indicates the beginning of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcStart() As String

C#

string SrcStart {get; set;}

C++

property String^ SrcStart {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcStart() : String;
function set SrcStart(value : String);

Property Value

A String value indicating the beginning of the record which represents this object in a drawing file.

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.Visibility Property

API Reference > CADViewLib Namespace > CADLine Interface > Properties >

ICADLine.Visibility Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visibility() As Boolean

C#

bool Visibility {get; set;}

C++

property bool Visibility {
bool get( );
void set(
bool value
);
}

JScript

function get Visibility() : boolean;
function set Visibility(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.Visible Property

API Reference > CADViewLib Namespace > CADLine Interface > Properties >

ICADLine.Visible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visible() As Boolean

C#

bool Visible {get; set;}

C++

property bool Visible {
bool get( );
void set(
bool value
);
}

JScript

function get Visible() : boolean;
function set Visible(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


CADLine Methods

API Reference > CADViewLib Namespace > CADLine Interface >

CADLine Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from ICADLine ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from ICADLine ).
Public method | CreateEntity | Initializes a new object instance. (inherited from ICADLine ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from ICADLine ).
Public method | EntName | Returns a name of the entity. (inherited from ICADLine ).
Public method | FreeEntity | Destroys the object instance. (inherited from ICADLine ).
Public method | GetBoxPoints | For internal use. (inherited from ICADLine ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from ICADLine ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from ICADLine ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from ICADLine ).
Public method | RemoveEntity | Removes a specified entity. (inherited from ICADLine ).
Public method | SetLType | Sets a line type for this object. (inherited from ICADLine ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from ICADLine ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from ICADLine ).

Top

collall See Also

Reference

CADLine Interface


ICADLine.AddEntity Method

API Reference > CADViewLib Namespace > CADLine Interface > Methods >

ICADLine.AddEntity Method

 Return to chapter overview

Show / hide the hidden text

Adds a new child entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AddEntity( _
ByVal AEntity As Entity _
)

C#

override void AddEntity(
EntityAEntity
)

C++

void AddEntity(
Entity^ AEntity
)

JScript

function AddEntity(
AEntity : Entity
);

Parameters

AEntity

Added entity.

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.AssignEntity Method

API Reference > CADViewLib Namespace > CADLine Interface > Methods >

ICADLine.AssignEntity Method

 Return to chapter overview

Show / hide the hidden text

Assigns the properties of the specified entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AssignEntity( _
ByVal Source As Entity _
)

C#

override void AssignEntity(
EntitySource
)

C++

void AssignEntity(
Entity^ Source
)

JScript

function AssignEntity(
Source : Entity
);

Parameters

Source

Entity which has the same type as the current object.

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.CreateEntity Method

API Reference > CADViewLib Namespace > CADLine Interface > Methods >

ICADLine.CreateEntity Method

 Return to chapter overview

Show / hide the hidden text

Initializes a new object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub CreateEntity()

C#

override void CreateEntity()

C++

void CreateEntity()

JScript

function CreateEntity();

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.DeleteEntity Method

API Reference > CADViewLib Namespace > CADLine Interface > Methods >

ICADLine.DeleteEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes an entity specified by index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub DeleteEntity( _
ByVal AIndex As Integer _
)

C#

override void DeleteEntity(
intAIndex
)

C++

void DeleteEntity(
intAIndex
)

JScript

function DeleteEntity(
AIndex : int
);

Parameters

AIndex

Index of the entity.

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.EntName Method

API Reference > CADViewLib Namespace > CADLine Interface > Methods >

ICADLine.EntName Method

 Return to chapter overview

Show / hide the hidden text

Returns a name of the entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function EntName() As String

C#

override string EntName()

C++

String^ EntName()

JScript

function EntName() : String;

Return Value

A string containing the entity name.

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.FreeEntity Method

API Reference > CADViewLib Namespace > CADLine Interface > Methods >

ICADLine.FreeEntity Method

 Return to chapter overview

Show / hide the hidden text

Destroys the object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub FreeEntity()

C#

override void FreeEntity()

C++

void FreeEntity()

JScript

function FreeEntity();

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.GetBoxPoints Method

API Reference > CADViewLib Namespace > CADLine Interface > Methods >

ICADLine.GetBoxPoints Method

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetBoxPoints( _
ByVal Full As Boolean _
) As Boolean

C#

override bool GetBoxPoints(
boolFull
)

C++

bool GetBoxPoints(
boolFull
)

JScript

function GetBoxPoints(
Full : boolean
) : boolean;

Parameters

Full

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.GetThickness Method

API Reference > CADViewLib Namespace > CADLine Interface > Methods >

ICADLine.GetThickness Method

 Return to chapter overview

Show / hide the hidden text

Returns the line thickness for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetThickness() As Double

C#

override double GetThickness()

C++

double GetThickness()

JScript

function GetThickness() : double;

Return Value

A Double type value indicating the line thickness.

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.IndexOfEntity Method

API Reference > CADViewLib Namespace > CADLine Interface > Methods >

ICADLine.IndexOfEntity Method

 Return to chapter overview

Show / hide the hidden text

Returns index of the given entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function IndexOfEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int IndexOfEntity(
EntityAEntity
)

C++

int IndexOfEntity(
Entity^ AEntity
)

JScript

function IndexOfEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity whose index is retrieved.

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.Iterate Method

API Reference > CADViewLib Namespace > CADLine Interface > Methods >

ICADLine.Iterate Method

 Return to chapter overview

Show / hide the hidden text

Iterates through the entities in the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub Iterate( _
ByVal AConverter As Converter _
)

C#

override void Iterate(
ConverterAConverter
)

C++

void Iterate(
Converter^ AConverter
)

JScript

function Iterate(
AConverter : Converter
);

Parameters

AConverter

Converter which contains the drawing data.

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.RemoveEntity Method

API Reference > CADViewLib Namespace > CADLine Interface > Methods >

ICADLine.RemoveEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes a specified entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function RemoveEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int RemoveEntity(
EntityAEntity
)

C++

int RemoveEntity(
Entity^ AEntity
)

JScript

function RemoveEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity which will be removed.

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.SetLType Method

API Reference > CADViewLib Namespace > CADLine Interface > Methods >

ICADLine.SetLType Method

 Return to chapter overview

Show / hide the hidden text

Sets a line type for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLType( _
ByVal Value As Entity _
)

C#

override void SetLType(
EntityValue
)

C++

void SetLType(
Entity^ Value
)

JScript

function SetLType(
Value : Entity
);

Parameters

Value

The line type value.

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.SetLWeight Method

API Reference > CADViewLib Namespace > CADLine Interface > Methods >

ICADLine.SetLWeight Method

 Return to chapter overview

Show / hide the hidden text

Sets a line weight for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLWeight( _
ByVal Value As Integer _
)

C#

override void SetLWeight(
intValue
)

C++

void SetLWeight(
intValue
)

JScript

function SetLWeight(
Value : int
);

Parameters

Value

The line weight value.

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


ICADLine.get_Entities Method

API Reference > CADViewLib Namespace > CADLine Interface > Methods >

ICADLine.get_Entities Method

 Return to chapter overview

Show / hide the hidden text

Returns the child entity at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Entities( _
ByVal Index As Integer _
) As Entity

C#

override Entity get_Entities(
intIndex
)

C++

Entity^ get_Entities(
intIndex
)

JScript

function get_Entities(
Index : int
) : Entity;

Parameters

Index

The index of the entity to retrieve.

collall See Also

Reference

ICADLine Interface
ICADLine ICADLine Members


CADViewX Interface

API Reference > CADViewLib Namespace >

CADViewX Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to CADViewX control.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface CADViewX
Inherits ICADViewX, _
ICADViewXEvents_Event

C#

public interface CADViewX : ICADViewX,
ICADViewXEvents_Event

C++

public interface class CADViewX : public ICADViewX^,
public ICADViewXEvents_Event^

JScript

public interface CADViewX
implements ICADViewX,
ICADViewXEvents_Event

collall See Also

Reference

CADViewX Members


CADViewX Members

API Reference > CADViewLib Namespace > CADViewX Interface >

CADViewX Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to CADViewX control.

The following tables list the members exposed by the CADViewX type.

collall Public Properties

 | Name | Description
Public property | Active | Gets a value indicating whether the control is active. (inherited from ICADViewX ).
Public property | AlignDisabled | Gets a value indicating whether child control realignment is disabled. (inherited from ICADViewX ).
Public property | AutoOpenActiveViewPort | Gets or sets a value indicating whether an active viewport will be opened automatically. (inherited from ICADViewX ).
Public property | AutoScroll | Gets or sets a value indicating whether the scrollbars appear automatically after zooming in. (inherited from ICADViewX ).
Public property | AutoSize | Gets or sets a value indicating whether the control resizes itself to fit its contents. (inherited from ICADViewX ).
Public property | AxBorderStyle | Gets or sets a border style for the control. (inherited from ICADViewX ).
Public property | BackGroundColor | Gets or sets a background color for the loaded CAD drawing. (inherited from ICADViewX ).
Public property | BorderWidth | Gets or sets the control's border width. (inherited from ICADViewX ).
Public property | CADImage | Gets or sets a CADImage object for the loaded drawing. (inherited from ICADViewX ).
Public property | Caption | Gets or sets a caption of the control. (inherited from ICADViewX ).
Public property | Color | Gets or sets a background color for the control. (inherited from ICADViewX ).
Public property | Count | (inherited from ICADViewX ).
Public property | DXFImage | Gets or sets a DXFImage object for the loaded drawing. (inherited from ICADViewX ).
Public property | DefaultAcadVersion | Gets or sets the default AutoCAD version for saving to DWG/DXF formats. (inherited from ICADViewX ).
Public property | DefaultColor | Gets or sets a default color for the loaded CAD drawing. (inherited from ICADViewX ).
Public property | DefaultSHXFont | Gets or sets a name of the default SHX font. (inherited from ICADViewX ).
Public property | DefaultSHXPath | Gets or sets the default path to SHX font files. (inherited from ICADViewX ).
Public property | DoubleBuffered | Gets or sets a value indicating whether the control should redraw its surface using a secondary buffer to reduce or prevent flicker. (inherited from ICADViewX ).
Public property | DrawMode | Gets or sets an appearance of colors in the loaded CAD drawing. (inherited from ICADViewX ).
Public property | DropTarget | Gets or sets a value indicating whether the control can be a target for the drag-and-drop operations. (inherited from ICADViewX ).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from ICADViewX ).
Public property | FileName | Gets or sets a name of the loaded drawing file. (inherited from ICADViewX ).
Public property | FileVersion | Gets the file version of CADViewLib.ocx. (inherited from ICADViewX ).
Public property | Font | Gets or sets a font of the control. (inherited from ICADViewX ).
Public property | GSDPI | Gets or sets a DPI value for the EPS import. (inherited from ICADViewX ).
Public property | GSDllSearchPath | Gets or sets a path to GhostScript library. (inherited from ICADViewX ).
Public property | HScrollBarVisible | Gets or sets a value indicating whether the horizontal scroll bar is visible. (inherited from ICADViewX ).
Public property | Image | Gets or sets a DXFImage object for the loaded drawing. (inherited from ICADViewX ).
Public property | ImageAlign | Gets or sets the alignment of the child control which renders an image. (inherited from ICADViewX ).
Public property | ImageBoundsRect | Gets the bounding rectangle for the drawing area. (inherited from ICADViewX ).
Public property | ImageHeight | Gets a height of the loaded CAD drawing. (inherited from ICADViewX ).
Public property | ImageParentClientRect | (inherited from ICADViewX ).
Public property | ImageWidth | Gets a width of the loaded CAD drtawing. (inherited from ICADViewX ).
Public property | IsShowPrinterSetupDialog | Gets or sets a value indicating whether the Print dialog box will be displayed. (inherited from ICADViewX ).
Public property | IsWithoutBorder | Gets or sets a value indicating whether the loaded CAD drawing is displayed without an additional empty space (borders). (inherited from ICADViewX ).
Public property | KeyPreview | Gets or sets a value indicating whether the form-level keyboard event procedures are invoked before the control's keyboard event procedures. (inherited from ICADViewX ).
Public property | Language | Gets or sets a language of the control's GUI. (inherited from ICADViewX ).
Public property | LanguagesCount | Gets a quantity of available GUI languages. (inherited from ICADViewX ).
Public property | LayoutIndex | Gets or sets an index of the currently displayed CAD drawing's layout. (inherited from ICADViewX ).
Public property | LayoutToolBox | Provides an access to the layouts combo box. (inherited from ICADViewX ).
Public property | LayoutsBarVisible | Gets or sets a value indicating whether the layouts toolbox is visible. (inherited from ICADViewX ).
Public property | LayoutsCount | Gets the layouts quantity in the loaded CAD drawing. (inherited from ICADViewX ).
Public property | Millimetres | Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file. (inherited from ICADViewX ).
Public property | PaperOrientation | Gets or sets the paper orientation for printing. (inherited from ICADViewX ).
Public property | Picture | Gets a raster image for the displayed drawing. (inherited from ICADViewX ).
Public property | PixelsPerInch | Gets or sets the proportion of the font on the system on which the control's form was designed. (inherited from ICADViewX ).
Public property | PrintScale | Gets or sets a value indicating how the drawing will be scaled on print. (inherited from ICADViewX ).
Public property | PrintViewArea | Gets or sets a value indicating whether the current view will be printed. (inherited from ICADViewX ).
Public property | PrinterIndex | Gets or sets an index of the current printer. (inherited from ICADViewX ).
Public property | PrintersCount | Gets a number of printers installed in the operating system. (inherited from ICADViewX ).
Public property | PrintingTitle | Gets or sets a document name in the print queue for files yet to be printed from CADViewX. (inherited from ICADViewX ).
Public property | ProductName | Gets a product name for the control. (inherited from ICADViewX ).
Public property | ProductVersion | Gets a product version for the control. (inherited from ICADViewX ).
Public property | ProgressRect | Gets the rectangle area that has been changed and needs to be redrawn. (inherited from ICADViewX ).
Public property | RasterColorDepth | Gets or sets a color depth for raster images. (inherited from ICADViewX ).
Public property | Rotatable | Gets a value indicating whether the drawing can be rotated on the angle value which is not divisible by 90. (inherited from ICADViewX ).
Public property | SHXSearchPaths | Gets or sets the paths to the SHX font files. (inherited from ICADViewX ).
Public property | ScaleFactor | Gets or sets a scale factor for CAD drawing's width and height. (inherited from ICADViewX ).
Public property | Scaled | Gets or sets a value indicating whether the control's form is scaled according to the PixelsPerInch property value. (inherited from ICADViewX ).
Public property | ScreenSnap | Gets or sets a value indicating whether the control's form snaps to edge of screen. (inherited from ICADViewX ).
Public property | SearchSHXPaths | Gets or sets a value indicating whether to search the SHX fonts at the specified paths. (inherited from ICADViewX ).
Public property | SelfPopupMenu | Gets or sets a value indicating whether the control's context menu is displayed. (inherited from ICADViewX ).
Public property | SnapBuffer | Gets or sets a distance for the screen snap. (inherited from ICADViewX ).
Public property | ToolBarVisible | Gets or sets a value indicating the control's toolbar visibility. (inherited from ICADViewX ).
Public property | ToolBox | Provides an access to the control's toolbar. (inherited from ICADViewX ).
Public property | UseSHXFonts | Gets or sets a value indicating whether the SHX fonts will be used in the CAD drawing. (inherited from ICADViewX ).
Public property | UseSizeDialog | Gets or sets a value indicating whether the Export file size dialog window is displayed. (inherited from ICADViewX).
Public property | VScrollBarVisible | Gets or sets a value indicating whether the vertical scroll bar is visible. (inherited from ICADViewX ).
Public property | Visible | Gets or sets a value indicating whether the control is visible. (inherited from ICADViewX ).
Public property | VisibleDockClientCount | Gets the number of visible controls that are docked on the windowed control. (inherited from ICADViewX ).
Public property | VisibleOrbit3D | Gets or sets a value indicating whether the 3D Orbit tool is visible. (inherited from ICADViewX ).
Public property | hDc | Gets a handle to a device context (DC) for the client area of the control. (inherited from ICADViewX ).
Public property | hWnd | Gets the window handle that the control is bound to. (inherited from ICADViewX ).
Public property | mmHeight | Gets the physical height for the loaded HPGL drawing in millimeters. (inherited from ICADViewX ).
Public property | mmWidth | Gets the physical width for the loaded HPGL drawing in millimeters. (inherited from ICADViewX ).

Top

collall Public Methods

 | Name | Description
Public method | ActionUpdate | Updates the control's internal state. (inherited from ICADViewX ).
Public method | CADCoords | Calculates CAD coordinates for a point specified by the screen coordinates. (inherited from ICADViewX ).
Public method | Cancel | Terminates moving (or dragging) of the image. (inherited from ICADViewX ).
Public method | Center | Returns the center point of the drawing area. (inherited from ICADViewX ).
Public method | CheckUpdates | Checks for a new version of the control available to download. (inherited from ICADViewX ).
Public method | CloseFile | Closes the currently opened file. (inherited from ICADViewX ).
Public method | ConvertCADToJPEG | Converts a CAD drawing file to the JPEG format. (inherited from ICADViewX ).
Public method | ConvertCustom | (inherited from ICADViewX ).
Public method | CopyToRaster | Copies the loaded CAD drawing to the clipboard as a bitmap. (inherited from ICADViewX ).
Public method | CurrentLayoutIterate | Iterates through the entities on the current drawing layout. (inherited from ICADViewX ).
Public method | DoToolButtonClick | Triggers the mouse click on a specified toolbar button. (inherited from ICADViewX ).
Public method | Empty | Returns a value indicating whether the control contains any drawing file or not. (inherited from ICADViewX ).
Public method | ExportToMetafile | Exports the loaded CAD drawing to Windows metafile. (inherited from ICADViewX ).
Public method | FindAutoCADSHXPaths | Returns paths to the SHX fonts installed with Autodesk products (AutoCAD, DWG TrueView). (inherited from ICADViewX ).
Public method | GetOpenDialogFilter | Retrieves a string that indicates the file types and descriptions displayed in the control's open file dialog. (inherited from ICADViewX ).
Public method | GetSaveDialogFilter | Retrieves a string that indicates the file types and descriptions displayed in the control's save file dialog. (inherited from ICADViewX ).
Public method | HasPrevScale | Check if the drawing was scaled on the screen. (inherited from ICADViewX ).
Public method | IsBadRect | Checks if the sizes of a specifed parallelepiped are defined correctly. (inherited from ICADViewX ).
Public method | IsVectGraphic | Returns a value indicating whether the loaded file contains vector graphics. (inherited from ICADViewX ).
Public method | LoadFile | Loads a specified file. (inherited from ICADViewX ).
Public method | LoadFromIni | Loads the control's settings from a specified .ini file. (inherited from ICADViewX ).
Public method | MkFPoint | Defines a point in the 3D space. (inherited from ICADViewX ).
Public method | MkFRect | Defines a parallelepiped (box). (inherited from ICADViewX ).
Public method | OpenActiveViewPort | Displays the active viewport. (inherited from ICADViewX ).
Public method | PictureRealign | Realigns the displayed image. (inherited from ICADViewX ).
Public method | PictureRect | Returns the bounding rectangle for the displayed image. (inherited from ICADViewX ).
Public method | PictureRepaint | Repaints the displayed image. (inherited from ICADViewX ).
Public method | Popup | Displays the control's context menu at a given location of the screen. (inherited from ICADViewX ).
Public method | PrevScale | Redraws the displayed image with a previous scale factor and boundaries. (inherited from ICADViewX ).
Public method | Print | Sends the loaded file to the current printer. (inherited from ICADViewX ).
Public method | PrintImage | Sends the loaded file to the current printer. (inherited from ICADViewX ).
Public method | ProcessXML | Processes a string which contains the XML instructions. (inherited from ICADViewX ).
Public method | RefreshAfterPictureAssign | Forces the control to clear the internal data left from the previously loaded file. (inherited from ICADViewX ).
Public method | RefreshAfterRotate | Forces the control to refresh the image after rotation. (inherited from ICADViewX ).
Public method | SaveCopyToFile | Copies the contents of the loaded file to a stream and saves the copy to a file. (inherited from ICADViewX ).
Public method | SaveToFile | Saves the loaded drawing to a specified file. (inherited from ICADViewX ).
Public method | SaveToFileEx | Saves the loaded drawing to a specified file. (inherited from ICADViewX ).
Public method | SaveToIni | Saves the control's settings to an .ini file (inherited from ICADViewX ).
Public method | ScaleImage | Applies the on-screen scaling to the displayed image. (inherited from ICADViewX ).
Public method | ScaledRectPicture | Captures a specified rectangle area as an Image object. (inherited from ICADViewX).
Public method | SetImageBounds | Sets the boundaries for the displayed image. (inherited from ICADViewX ).
Public method | ShowAbout | Forces the control to display the About dialog window. (inherited from ICADViewX).
Public method | ShowInfo | Displays a caption with a specified size. (inherited from ICADViewX ).
Public method | ShowLayersDialog | Forces the control to display the Layers dialog window. (inherited from ICADViewX).
Public method | ShowPoint | Displays the image centered by a specified point with a certain scale factor. (inherited from ICADViewX ).
Public method | ShowPointEx | Displays the image centered by a specified point with a certain scale factor. (inherited from ICADViewX ).
Public method | ShowRect | Displays the image centered by a specified rectangle area. (inherited from ICADViewX ).
Public method | StRg | Registers CADViewX developer license programmatically in the application. (inherited from ICADViewX ).
Public method | UsePictureRect | Obsolete. (inherited from ICADViewX ).
Public method | Zoom | Zooms to a specified rectangle area on the loaded drawing. (inherited from ICADViewX ).
Public method | get_EnabledAction | Returns a value indicating whether a specified toolbar button is enabled. (inherited from ICADViewX ).
Public method | get_Items | (inherited from ICADViewX ).
Public method | get_Languages | Retrieves a GUI language name by its index. (inherited from ICADViewX ).
Public method | get_Printer | Retrieves a printer name by its index. (inherited from ICADViewX ).
Public method | get_VisibleAction | Returns a value indicating whether a specified toolbar button is visible. (inherited from ICADViewX ).
Public method | let_Font | Sets a font for the control. (inherited from ICADViewX ).
Public method | set_EnabledAction | Makes a specified toolbar button enabled or disabled. (inherited from ICADViewX ).
Public method | set_Printer | Changes a local name of the printer at the given index. (inherited from ICADViewX ).
Public method | set_VisibleAction | Makes a specified toolbar button visible or hidden. (inherited from ICADViewX ).

Top

collall See Also

Reference

CADViewX Interface


CADViewX Properties

API Reference > CADViewLib Namespace > CADViewX Interface >

CADViewX Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Active | Gets a value indicating whether the control is active. (inherited from ICADViewX ).
Public property | AlignDisabled | Gets a value indicating whether child control realignment is disabled. (inherited from ICADViewX ).
Public property | AutoOpenActiveViewPort | Gets or sets a value indicating whether an active viewport will be opened automatically. (inherited from ICADViewX ).
Public property | AutoScroll | Gets or sets a value indicating whether the scrollbars appear automatically after zooming in. (inherited from ICADViewX ).
Public property | AutoSize | Gets or sets a value indicating whether the control resizes itself to fit its contents. (inherited from ICADViewX ).
Public property | AxBorderStyle | Gets or sets a border style for the control. (inherited from ICADViewX ).
Public property | BackGroundColor | Gets or sets a background color for the loaded CAD drawing. (inherited from ICADViewX ).
Public property | BorderWidth | Gets or sets the control's border width. (inherited from ICADViewX ).
Public property | CADImage | Gets or sets a CADImage object for the loaded drawing. (inherited from ICADViewX ).
Public property | Caption | Gets or sets a caption of the control. (inherited from ICADViewX ).
Public property | Color | Gets or sets a background color for the control. (inherited from ICADViewX ).
Public property | Count | (inherited from ICADViewX ).
Public property | DXFImage | Gets or sets a DXFImage object for the loaded drawing. (inherited from ICADViewX ).
Public property | DefaultAcadVersion | Gets or sets the default AutoCAD version for saving to DWG/DXF formats. (inherited from ICADViewX ).
Public property | DefaultColor | Gets or sets a default color for the loaded CAD drawing. (inherited from ICADViewX ).
Public property | DefaultSHXFont | Gets or sets a name of the default SHX font. (inherited from ICADViewX ).
Public property | DefaultSHXPath | Gets or sets the default path to SHX font files. (inherited from ICADViewX ).
Public property | DoubleBuffered | Gets or sets a value indicating whether the control should redraw its surface using a secondary buffer to reduce or prevent flicker. (inherited from ICADViewX ).
Public property | DrawMode | Gets or sets an appearance of colors in the loaded CAD drawing. (inherited from ICADViewX ).
Public property | DropTarget | Gets or sets a value indicating whether the control can be a target for the drag-and-drop operations. (inherited from ICADViewX ).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from ICADViewX ).
Public property | FileName | Gets or sets a name of the loaded drawing file. (inherited from ICADViewX ).
Public property | FileVersion | Gets the file version of CADViewLib.ocx. (inherited from ICADViewX ).
Public property | Font | Gets or sets a font of the control. (inherited from ICADViewX ).
Public property | GSDPI | Gets or sets a DPI value for the EPS import. (inherited from ICADViewX ).
Public property | GSDllSearchPath | Gets or sets a path to GhostScript library. (inherited from ICADViewX ).
Public property | HScrollBarVisible | Gets or sets a value indicating whether the horizontal scroll bar is visible. (inherited from ICADViewX ).
Public property | Image | Gets or sets a DXFImage object for the loaded drawing. (inherited from ICADViewX ).
Public property | ImageAlign | Gets or sets the alignment of the child control which renders an image. (inherited from ICADViewX ).
Public property | ImageBoundsRect | Gets the bounding rectangle for the drawing area. (inherited from ICADViewX ).
Public property | ImageHeight | Gets a height of the loaded CAD drawing. (inherited from ICADViewX ).
Public property | ImageParentClientRect | (inherited from ICADViewX ).
Public property | ImageWidth | Gets a width of the loaded CAD drtawing. (inherited from ICADViewX ).
Public property | IsShowPrinterSetupDialog | Gets or sets a value indicating whether the Print dialog box will be displayed. (inherited from ICADViewX ).
Public property | IsWithoutBorder | Gets or sets a value indicating whether the loaded CAD drawing is displayed without an additional empty space (borders). (inherited from ICADViewX ).
Public property | KeyPreview | Gets or sets a value indicating whether the form-level keyboard event procedures are invoked before the control's keyboard event procedures. (inherited from ICADViewX ).
Public property | Language | Gets or sets a language of the control's GUI. (inherited from ICADViewX ).
Public property | LanguagesCount | Gets a quantity of available GUI languages. (inherited from ICADViewX ).
Public property | LayoutIndex | Gets or sets an index of the currently displayed CAD drawing's layout. (inherited from ICADViewX ).
Public property | LayoutToolBox | Provides an access to the layouts combo box. (inherited from ICADViewX ).
Public property | LayoutsBarVisible | Gets or sets a value indicating whether the layouts toolbox is visible. (inherited from ICADViewX ).
Public property | LayoutsCount | Gets the layouts quantity in the loaded CAD drawing. (inherited from ICADViewX ).
Public property | Millimetres | Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file. (inherited from ICADViewX ).
Public property | PaperOrientation | Gets or sets the paper orientation for printing. (inherited from ICADViewX ).
Public property | Picture | Gets a raster image for the displayed drawing. (inherited from ICADViewX ).
Public property | PixelsPerInch | Gets or sets the proportion of the font on the system on which the control's form was designed. (inherited from ICADViewX ).
Public property | PrintScale | Gets or sets a value indicating how the drawing will be scaled on print. (inherited from ICADViewX ).
Public property | PrintViewArea | Gets or sets a value indicating whether the current view will be printed. (inherited from ICADViewX ).
Public property | PrinterIndex | Gets or sets an index of the current printer. (inherited from ICADViewX ).
Public property | PrintersCount | Gets a number of printers installed in the operating system. (inherited from ICADViewX ).
Public property | PrintingTitle | Gets or sets a document name in the print queue for files yet to be printed from CADViewX. (inherited from ICADViewX ).
Public property | ProductName | Gets a product name for the control. (inherited from ICADViewX ).
Public property | ProductVersion | Gets a product version for the control. (inherited from ICADViewX ).
Public property | ProgressRect | Gets the rectangle area that has been changed and needs to be redrawn. (inherited from ICADViewX ).
Public property | RasterColorDepth | Gets or sets a color depth for raster images. (inherited from ICADViewX ).
Public property | Rotatable | Gets a value indicating whether the drawing can be rotated on the angle value which is not divisible by 90. (inherited from ICADViewX ).
Public property | SHXSearchPaths | Gets or sets the paths to the SHX font files. (inherited from ICADViewX ).
Public property | ScaleFactor | Gets or sets a scale factor for CAD drawing's width and height. (inherited from ICADViewX ).
Public property | Scaled | Gets or sets a value indicating whether the control's form is scaled according to the PixelsPerInch property value. (inherited from ICADViewX ).
Public property | ScreenSnap | Gets or sets a value indicating whether the control's form snaps to edge of screen. (inherited from ICADViewX ).
Public property | SearchSHXPaths | Gets or sets a value indicating whether to search the SHX fonts at the specified paths. (inherited from ICADViewX ).
Public property | SelfPopupMenu | Gets or sets a value indicating whether the control's context menu is displayed. (inherited from ICADViewX ).
Public property | SnapBuffer | Gets or sets a distance for the screen snap. (inherited from ICADViewX ).
Public property | ToolBarVisible | Gets or sets a value indicating the control's toolbar visibility. (inherited from ICADViewX ).
Public property | ToolBox | Provides an access to the control's toolbar. (inherited from ICADViewX ).
Public property | UseSHXFonts | Gets or sets a value indicating whether the SHX fonts will be used in the CAD drawing. (inherited from ICADViewX ).
Public property | UseSizeDialog | Gets or sets a value indicating whether the Export file size dialog window is displayed. (inherited from ICADViewX).
Public property | VScrollBarVisible | Gets or sets a value indicating whether the vertical scroll bar is visible. (inherited from ICADViewX ).
Public property | Visible | Gets or sets a value indicating whether the control is visible. (inherited from ICADViewX ).
Public property | VisibleDockClientCount | Gets the number of visible controls that are docked on the windowed control. (inherited from ICADViewX ).
Public property | VisibleOrbit3D | Gets or sets a value indicating whether the 3D Orbit tool is visible. (inherited from ICADViewX ).
Public property | hDc | Gets a handle to a device context (DC) for the client area of the control. (inherited from ICADViewX ).
Public property | hWnd | Gets the window handle that the control is bound to. (inherited from ICADViewX ).
Public property | mmHeight | Gets the physical height for the loaded HPGL drawing in millimeters. (inherited from ICADViewX ).
Public property | mmWidth | Gets the physical width for the loaded HPGL drawing in millimeters. (inherited from ICADViewX ).

Top

collall See Also

Reference

CADViewX Interface


ICADViewX.Active Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.Active Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the control is active.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Active() As Boolean

C#

bool Active {get;}

C++

property bool Active {
bool get( );
}

JScript

function get Active() : boolean;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.AlignDisabled Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.AlignDisabled Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether child control realignment is disabled.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property AlignDisabled() As Boolean

C#

bool AlignDisabled {get;}

C++

property bool AlignDisabled {
bool get( );
}

JScript

function get AlignDisabled() : boolean;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.AutoOpenActiveViewPort Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.AutoOpenActiveViewPort Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether an active viewport will be opened automatically.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property AutoOpenActiveViewPort() As Boolean

C#

bool AutoOpenActiveViewPort {get; set;}

C++

property bool AutoOpenActiveViewPort {
bool get( );
void set(
bool value
);
}

JScript

function get AutoOpenActiveViewPort() : boolean;
function set AutoOpenActiveViewPort(value : boolean);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.AutoScroll Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.AutoScroll Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the scrollbars appear automatically after zooming in.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property AutoScroll() As Boolean

C#

bool AutoScroll {get; set;}

C++

property bool AutoScroll {
bool get( );
void set(
bool value
);
}

JScript

function get AutoScroll() : boolean;
function set AutoScroll(value : boolean);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.AutoSize Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.AutoSize Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the control resizes itself to fit its contents.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property AutoSize() As Boolean

C#

bool AutoSize {get; set;}

C++

property bool AutoSize {
bool get( );
void set(
bool value
);
}

JScript

function get AutoSize() : boolean;
function set AutoSize(value : boolean);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.AxBorderStyle Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.AxBorderStyle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a border style for the control.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property AxBorderStyle() As TxActiveFormBorderStyle

C#

TxActiveFormBorderStyle AxBorderStyle {get; set;}

C++

property TxActiveFormBorderStyle AxBorderStyle {
TxActiveFormBorderStyle get( );
void set(
TxActiveFormBorderStyle value
);
}

JScript

function get AxBorderStyle() : TxActiveFormBorderStyle;
function set AxBorderStyle(value : TxActiveFormBorderStyle);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.BackGroundColor Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.BackGroundColor Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a background color for the loaded CAD drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property BackGroundColor() As UInt32

C#

UInt32 BackGroundColor {get; set;}

C++

property UInt32 BackGroundColor {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get BackGroundColor() : UInt32;
function set BackGroundColor(value : UInt32);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.BorderWidth Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.BorderWidth Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the control's border width.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property BorderWidth() As Integer

C#

int BorderWidth {get; set;}

C++

property int BorderWidth {
int get( );
void set(
int value
);
}

JScript

function get BorderWidth() : int;
function set BorderWidth(value : int);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.CADImage Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.CADImage Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a CADImage object for the loaded drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CADImage() As Object

C#

object CADImage {get; set;}

C++

property object^ CADImage {
object^ get( );
void set(
object^ value
);
}

JScript

function get CADImage() : object;
function set CADImage(value : object);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.Caption Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.Caption Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a caption of the control.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Caption() As String

C#

string Caption {get; set;}

C++

property String^ Caption {
String^ get( );
void set(
String^ value
);
}

JScript

function get Caption() : String;
function set Caption(value : String);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.Color Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.Color Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a background color for the control.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Color() As UInt32

C#

UInt32 Color {get; set;}

C++

property UInt32 Color {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get Color() : UInt32;
function set Color(value : UInt32);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.Count Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.Count Property

 Return to chapter overview

Show / hide the hidden text

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Count() As Integer

C#

int Count {get;}

C++

property int Count {
int get( );
}

JScript

function get Count() : int;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.DXFImage Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.DXFImage Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a DXFImage object for the loaded drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DXFImage() As DXFImage

C#

DXFImage DXFImage {get; set;}

C++

property DXFImage^ DXFImage {
DXFImage^ get( );
void set(
DXFImage^ value
);
}

JScript

function get DXFImage() : DXFImage;
function set DXFImage(value : DXFImage);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.DefaultAcadVersion Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.DefaultAcadVersion Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the default AutoCAD version for saving to DWG/DXF formats.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DefaultAcadVersion() As TAcadVersion

C#

TAcadVersion DefaultAcadVersion {get; set;}

C++

property TAcadVersion DefaultAcadVersion {
TAcadVersion get( );
void set(
TAcadVersion value
);
}

JScript

function get DefaultAcadVersion() : TAcadVersion;
function set DefaultAcadVersion(value : TAcadVersion);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.DefaultColor Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.DefaultColor Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a default color for the loaded CAD drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DefaultColor() As UInt32

C#

UInt32 DefaultColor {get; set;}

C++

property UInt32 DefaultColor {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get DefaultColor() : UInt32;
function set DefaultColor(value : UInt32);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.DefaultSHXFont Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.DefaultSHXFont Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of the default SHX font.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DefaultSHXFont() As String

C#

string DefaultSHXFont {get; set;}

C++

property String^ DefaultSHXFont {
String^ get( );
void set(
String^ value
);
}

JScript

function get DefaultSHXFont() : String;
function set DefaultSHXFont(value : String);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.DefaultSHXPath Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.DefaultSHXPath Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the default path to SHX font files.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DefaultSHXPath() As String

C#

string DefaultSHXPath {get; set;}

C++

property String^ DefaultSHXPath {
String^ get( );
void set(
String^ value
);
}

JScript

function get DefaultSHXPath() : String;
function set DefaultSHXPath(value : String);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.DoubleBuffered Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.DoubleBuffered Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the control should redraw its surface using a secondary buffer to reduce or prevent flicker.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DoubleBuffered() As Boolean

C#

bool DoubleBuffered {get; set;}

C++

property bool DoubleBuffered {
bool get( );
void set(
bool value
);
}

JScript

function get DoubleBuffered() : boolean;
function set DoubleBuffered(value : boolean);

Property Value

true if the control paints itself to an in-memory bitmap that is used further to paint the window; otherwise, false.

collall Remarks

Double buffering reduces flicker when the control repaints, but is more memory intensive.

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.DrawMode Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.DrawMode Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets an appearance of colors in the loaded CAD drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DrawMode() As TxDXFDrawMode

C#

TxDXFDrawMode DrawMode {get; set;}

C++

property TxDXFDrawMode DrawMode {
TxDXFDrawMode get( );
void set(
TxDXFDrawMode value
);
}

JScript

function get DrawMode() : TxDXFDrawMode;
function set DrawMode(value : TxDXFDrawMode);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.DropTarget Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.DropTarget Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the control can be a target for the drag-and-drop operations.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DropTarget() As Boolean

C#

bool DropTarget {get; set;}

C++

property bool DropTarget {
bool get( );
void set(
bool value
);
}

JScript

function get DropTarget() : boolean;
function set DropTarget(value : boolean);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.Enabled Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.Enabled Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the control can respond to user interaction.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Enabled() As Boolean

C#

bool Enabled {get; set;}

C++

property bool Enabled {
bool get( );
void set(
bool value
);
}

JScript

function get Enabled() : boolean;
function set Enabled(value : boolean);

Property Value

true if the control can respond to user interaction; otherwise, false. The default is true.

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.FileName Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.FileName Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of the loaded drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property FileName() As String

C#

string FileName {get; set;}

C++

property String^ FileName {
String^ get( );
void set(
String^ value
);
}

JScript

function get FileName() : String;
function set FileName(value : String);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.FileVersion Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.FileVersion Property

 Return to chapter overview

Show / hide the hidden text

Gets the file version of CADViewLib.ocx.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property FileVersion() As String

C#

string FileVersion {get;}

C++

property String^ FileVersion {
String^ get( );
}

JScript

function get FileVersion() : String;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.Font Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.Font Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a font of the control.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Font() As StdFont

C#

StdFont Font {get; set;}

C++

property StdFont^ Font {
StdFont^ get( );
void set(
StdFont^ value
);
}

JScript

function get Font() : StdFont;
function set Font(value : StdFont);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.GSDPI Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.GSDPI Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a DPI value for the EPS import.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property GSDPI() As Integer

C#

int GSDPI {get; set;}

C++

property int GSDPI {
int get( );
void set(
int value
);
}

JScript

function get GSDPI() : int;
function set GSDPI(value : int);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.GSDllSearchPath Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.GSDllSearchPath Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a path to GhostScript library.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property GSDllSearchPath() As String

C#

string GSDllSearchPath {get; set;}

C++

property String^ GSDllSearchPath {
String^ get( );
void set(
String^ value
);
}

JScript

function get GSDllSearchPath() : String;
function set GSDllSearchPath(value : String);

collall Remarks

Ghostscript library is used for EPS import. To be able to open .eps files with CADViewX, you will need to install this library and specify a location of the gsdll32.dll or gsdll64.dll file.

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.HScrollBarVisible Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.HScrollBarVisible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the horizontal scroll bar is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property HScrollBarVisible() As Boolean

C#

bool HScrollBarVisible {get; set;}

C++

property bool HScrollBarVisible {
bool get( );
void set(
bool value
);
}

JScript

function get HScrollBarVisible() : boolean;
function set HScrollBarVisible(value : boolean);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.Image Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.Image Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a DXFImage object for the loaded drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Image() As DXFImage

C#

DXFImage Image {get;}

C++

property DXFImage^ Image {
DXFImage^ get( );
}

JScript

function get Image() : DXFImage;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.ImageAlign Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.ImageAlign Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the alignment of the child control which renders an image.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property ImageAlign() As TxAlign

C#

TxAlign ImageAlign {get; set;}

C++

property TxAlign ImageAlign {
TxAlign get( );
void set(
TxAlign value
);
}

JScript

function get ImageAlign() : TxAlign;
function set ImageAlign(value : TxAlign);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.ImageBoundsRect Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.ImageBoundsRect Property

 Return to chapter overview

Show / hide the hidden text

Gets the bounding rectangle for the drawing area.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property ImageBoundsRect() As Rect2D

C#

Rect2D ImageBoundsRect {get;}

C++

property Rect2D^ ImageBoundsRect {
Rect2D^ get( );
}

JScript

function get ImageBoundsRect() : Rect2D;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.ImageHeight Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.ImageHeight Property

 Return to chapter overview

Show / hide the hidden text

Gets a height of the loaded CAD drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property ImageHeight() As Integer

C#

int ImageHeight {get;}

C++

property int ImageHeight {
int get( );
}

JScript

function get ImageHeight() : int;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.ImageParentClientRect Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.ImageParentClientRect Property

 Return to chapter overview

Show / hide the hidden text

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property ImageParentClientRect() As Rect2D

C#

Rect2D ImageParentClientRect {get;}

C++

property Rect2D^ ImageParentClientRect {
Rect2D^ get( );
}

JScript

function get ImageParentClientRect() : Rect2D;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.ImageWidth Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.ImageWidth Property

 Return to chapter overview

Show / hide the hidden text

Gets a width of the loaded CAD drtawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property ImageWidth() As Integer

C#

int ImageWidth {get;}

C++

property int ImageWidth {
int get( );
}

JScript

function get ImageWidth() : int;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.IsShowPrinterSetupDialog Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.IsShowPrinterSetupDialog Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the Print dialog box will be displayed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsShowPrinterSetupDialog() As Boolean

C#

bool IsShowPrinterSetupDialog {get; set;}

C++

property bool IsShowPrinterSetupDialog {
bool get( );
void set(
bool value
);
}

JScript

function get IsShowPrinterSetupDialog() : boolean;
function set IsShowPrinterSetupDialog(value : boolean);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.IsWithoutBorder Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.IsWithoutBorder Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the loaded CAD drawing is displayed without an additional empty space (borders).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsWithoutBorder() As Boolean

C#

bool IsWithoutBorder {get; set;}

C++

property bool IsWithoutBorder {
bool get( );
void set(
bool value
);
}

JScript

function get IsWithoutBorder() : boolean;
function set IsWithoutBorder(value : boolean);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.KeyPreview Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.KeyPreview Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the form-level keyboard event procedures are invoked before the control's keyboard event procedures.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property KeyPreview() As Boolean

C#

bool KeyPreview {get; set;}

C++

property bool KeyPreview {
bool get( );
void set(
bool value
);
}

JScript

function get KeyPreview() : boolean;
function set KeyPreview(value : boolean);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.Language Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.Language Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a language of the control's GUI.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Language() As String

C#

string Language {get; set;}

C++

property String^ Language {
String^ get( );
void set(
String^ value
);
}

JScript

function get Language() : String;
function set Language(value : String);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.LanguagesCount Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.LanguagesCount Property

 Return to chapter overview

Show / hide the hidden text

Gets a quantity of available GUI languages.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property LanguagesCount() As Integer

C#

int LanguagesCount {get;}

C++

property int LanguagesCount {
int get( );
}

JScript

function get LanguagesCount() : int;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.LayoutIndex Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.LayoutIndex Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets an index of the currently displayed CAD drawing's layout.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LayoutIndex() As Integer

C#

int LayoutIndex {get; set;}

C++

property int LayoutIndex {
int get( );
void set(
int value
);
}

JScript

function get LayoutIndex() : int;
function set LayoutIndex(value : int);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.LayoutToolBox Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.LayoutToolBox Property

 Return to chapter overview

Show / hide the hidden text

Provides an access to the layouts combo box.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property LayoutToolBox() As ToolBox

C#

ToolBox LayoutToolBox {get;}

C++

property ToolBox^ LayoutToolBox {
ToolBox^ get( );
}

JScript

function get LayoutToolBox() : ToolBox;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.LayoutsBarVisible Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.LayoutsBarVisible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the layouts toolbox is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LayoutsBarVisible() As Boolean

C#

bool LayoutsBarVisible {get; set;}

C++

property bool LayoutsBarVisible {
bool get( );
void set(
bool value
);
}

JScript

function get LayoutsBarVisible() : boolean;
function set LayoutsBarVisible(value : boolean);

Property Value

true if ; otherwise, false.

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.LayoutsCount Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.LayoutsCount Property

 Return to chapter overview

Show / hide the hidden text

Gets the layouts quantity in the loaded CAD drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property LayoutsCount() As Integer

C#

int LayoutsCount {get;}

C++

property int LayoutsCount {
int get( );
}

JScript

function get LayoutsCount() : int;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.Millimetres Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.Millimetres Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Millimetres() As Boolean

C#

bool Millimetres {get; set;}

C++

property bool Millimetres {
bool get( );
void set(
bool value
);
}

JScript

function get Millimetres() : boolean;
function set Millimetres(value : boolean);

Property Value

true if the drawing units are millimeters; false if the drawing units are inches.

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.PaperOrientation Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.PaperOrientation Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the paper orientation for printing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PaperOrientation() As TxPaperOrientation

C#

TxPaperOrientation PaperOrientation {get; set;}

C++

property TxPaperOrientation PaperOrientation {
TxPaperOrientation get( );
void set(
TxPaperOrientation value
);
}

JScript

function get PaperOrientation() : TxPaperOrientation;
function set PaperOrientation(value : TxPaperOrientation);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.Picture Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.Picture Property

 Return to chapter overview

Show / hide the hidden text

Gets a raster image for the displayed drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Picture() As StdPicture

C#

StdPicture Picture {get; set;}

C++

property StdPicture^ Picture {
StdPicture^ get( );
void set(
StdPicture^ value
);
}

JScript

function get Picture() : StdPicture;
function set Picture(value : StdPicture);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.PixelsPerInch Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.PixelsPerInch Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the proportion of the font on the system on which the control's form was designed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PixelsPerInch() As Integer

C#

int PixelsPerInch {get; set;}

C++

property int PixelsPerInch {
int get( );
void set(
int value
);
}

JScript

function get PixelsPerInch() : int;
function set PixelsPerInch(value : int);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.PrintScale Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.PrintScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating how the drawing will be scaled on print.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PrintScale() As TxPrintScale

C#

TxPrintScale PrintScale {get; set;}

C++

property TxPrintScale PrintScale {
TxPrintScale get( );
void set(
TxPrintScale value
);
}

JScript

function get PrintScale() : TxPrintScale;
function set PrintScale(value : TxPrintScale);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.PrintViewArea Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.PrintViewArea Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the current view will be printed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PrintViewArea() As Boolean

C#

bool PrintViewArea {get; set;}

C++

property bool PrintViewArea {
bool get( );
void set(
bool value
);
}

JScript

function get PrintViewArea() : boolean;
function set PrintViewArea(value : boolean);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.PrinterIndex Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.PrinterIndex Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets an index of the current printer.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PrinterIndex() As Integer

C#

int PrinterIndex {get; set;}

C++

property int PrinterIndex {
int get( );
void set(
int value
);
}

JScript

function get PrinterIndex() : int;
function set PrinterIndex(value : int);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.PrintersCount Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.PrintersCount Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of printers installed in the operating system.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property PrintersCount() As Integer

C#

int PrintersCount {get;}

C++

property int PrintersCount {
int get( );
}

JScript

function get PrintersCount() : int;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.PrintingTitle Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.PrintingTitle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a document name in the print queue for files yet to be printed from CADViewX.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PrintingTitle() As String

C#

string PrintingTitle {get; set;}

C++

property String^ PrintingTitle {
String^ get( );
void set(
String^ value
);
}

JScript

function get PrintingTitle() : String;
function set PrintingTitle(value : String);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.ProductName Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.ProductName Property

 Return to chapter overview

Show / hide the hidden text

Gets a product name for the control.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property ProductName() As String

C#

string ProductName {get;}

C++

property String^ ProductName {
String^ get( );
}

JScript

function get ProductName() : String;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.ProductVersion Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.ProductVersion Property

 Return to chapter overview

Show / hide the hidden text

Gets a product version for the control.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property ProductVersion() As String

C#

string ProductVersion {get;}

C++

property String^ ProductVersion {
String^ get( );
}

JScript

function get ProductVersion() : String;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.ProgressRect Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.ProgressRect Property

 Return to chapter overview

Show / hide the hidden text

Gets the rectangle area that has been changed and needs to be redrawn.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property ProgressRect() As Rect2D

C#

Rect2D ProgressRect {get;}

C++

property Rect2D^ ProgressRect {
Rect2D^ get( );
}

JScript

function get ProgressRect() : Rect2D;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.RasterColorDepth Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.RasterColorDepth Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a color depth for raster images.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property RasterColorDepth() As TxColorDepth

C#

TxColorDepth RasterColorDepth {get; set;}

C++

property TxColorDepth RasterColorDepth {
TxColorDepth get( );
void set(
TxColorDepth value
);
}

JScript

function get RasterColorDepth() : TxColorDepth;
function set RasterColorDepth(value : TxColorDepth);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.Rotatable Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.Rotatable Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the drawing can be rotated on the angle value which is not divisible by 90.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Rotatable() As Boolean

C#

bool Rotatable {get;}

C++

property bool Rotatable {
bool get( );
}

JScript

function get Rotatable() : boolean;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.SHXSearchPaths Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.SHXSearchPaths Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the paths to the SHX font files.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SHXSearchPaths() As String

C#

string SHXSearchPaths {get; set;}

C++

property String^ SHXSearchPaths {
String^ get( );
void set(
String^ value
);
}

JScript

function get SHXSearchPaths() : String;
function set SHXSearchPaths(value : String);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.ScaleFactor Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.ScaleFactor Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a scale factor for CAD drawing's width and height.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property ScaleFactor() As Double

C#

double ScaleFactor {get; set;}

C++

property double ScaleFactor {
double get( );
void set(
double value
);
}

JScript

function get ScaleFactor() : double;
function set ScaleFactor(value : double);

collall Remarks

When you change a value of the ScaleFactor property, the values of ImageWidth and ImageHeight properties will be recalculated (by multiplying on the scale factor).

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.Scaled Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.Scaled Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the control's form is scaled according to the PixelsPerInch property value.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Scaled() As Boolean

C#

bool Scaled {get; set;}

C++

property bool Scaled {
bool get( );
void set(
bool value
);
}

JScript

function get Scaled() : boolean;
function set Scaled(value : boolean);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.ScreenSnap Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.ScreenSnap Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the control's form snaps to edge of screen.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property ScreenSnap() As Boolean

C#

bool ScreenSnap {get; set;}

C++

property bool ScreenSnap {
bool get( );
void set(
bool value
);
}

JScript

function get ScreenSnap() : boolean;
function set ScreenSnap(value : boolean);

Property Value

true if the edges of the form snap to the edge of the screen when the user moves the form; otherwise, false.

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.SearchSHXPaths Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.SearchSHXPaths Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether to search the SHX fonts at the specified paths.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SearchSHXPaths() As Boolean

C#

bool SearchSHXPaths {get; set;}

C++

property bool SearchSHXPaths {
bool get( );
void set(
bool value
);
}

JScript

function get SearchSHXPaths() : boolean;
function set SearchSHXPaths(value : boolean);

collall Remarks

You can specify the SHX paths using the SHXSearchPaths property.

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.SelfPopupMenu Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.SelfPopupMenu Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the control's context menu is displayed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SelfPopupMenu() As Boolean

C#

bool SelfPopupMenu {get; set;}

C++

property bool SelfPopupMenu {
bool get( );
void set(
bool value
);
}

JScript

function get SelfPopupMenu() : boolean;
function set SelfPopupMenu(value : boolean);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.SnapBuffer Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.SnapBuffer Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a distance for the screen snap.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SnapBuffer() As Integer

C#

int SnapBuffer {get; set;}

C++

property int SnapBuffer {
int get( );
void set(
int value
);
}

JScript

function get SnapBuffer() : int;
function set SnapBuffer(value : int);

collall Remarks

If ScreenSnap is true, SnapBuffer determines the maximum number of pixels that be between the form edge and the screen edge before the form snaps to the screen edge.

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.ToolBarVisible Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.ToolBarVisible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating the control's toolbar visibility.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property ToolBarVisible() As Boolean

C#

bool ToolBarVisible {get; set;}

C++

property bool ToolBarVisible {
bool get( );
void set(
bool value
);
}

JScript

function get ToolBarVisible() : boolean;
function set ToolBarVisible(value : boolean);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.ToolBox Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.ToolBox Property

 Return to chapter overview

Show / hide the hidden text

Provides an access to the control's toolbar.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property ToolBox() As ToolBox

C#

ToolBox ToolBox {get;}

C++

property ToolBox^ ToolBox {
ToolBox^ get( );
}

JScript

function get ToolBox() : ToolBox;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.UseSHXFonts Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.UseSHXFonts Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the SHX fonts will be used in the CAD drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property UseSHXFonts() As Boolean

C#

bool UseSHXFonts {get; set;}

C++

property bool UseSHXFonts {
bool get( );
void set(
bool value
);
}

JScript

function get UseSHXFonts() : boolean;
function set UseSHXFonts(value : boolean);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.UseSizeDialog Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.UseSizeDialog Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the Export file size dialog window is displayed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property UseSizeDialog() As Boolean

C#

bool UseSizeDialog {get; set;}

C++

property bool UseSizeDialog {
bool get( );
void set(
bool value
);
}

JScript

function get UseSizeDialog() : boolean;
function set UseSizeDialog(value : boolean);

Property Value

true if the Export file size dialog window is displayed when saving to raster formats; otherwise, false.

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.VScrollBarVisible Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.VScrollBarVisible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the vertical scroll bar is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property VScrollBarVisible() As Boolean

C#

bool VScrollBarVisible {get; set;}

C++

property bool VScrollBarVisible {
bool get( );
void set(
bool value
);
}

JScript

function get VScrollBarVisible() : boolean;
function set VScrollBarVisible(value : boolean);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.Visible Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.Visible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the control is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visible() As Boolean

C#

bool Visible {get; set;}

C++

property bool Visible {
bool get( );
void set(
bool value
);
}

JScript

function get Visible() : boolean;
function set Visible(value : boolean);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.VisibleDockClientCount Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.VisibleDockClientCount Property

 Return to chapter overview

Show / hide the hidden text

Gets the number of visible controls that are docked on the windowed control.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property VisibleDockClientCount() As Integer

C#

int VisibleDockClientCount {get;}

C++

property int VisibleDockClientCount {
int get( );
}

JScript

function get VisibleDockClientCount() : int;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.VisibleOrbit3D Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.VisibleOrbit3D Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the 3D Orbit tool is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property VisibleOrbit3D() As Boolean

C#

bool VisibleOrbit3D {get; set;}

C++

property bool VisibleOrbit3D {
bool get( );
void set(
bool value
);
}

JScript

function get VisibleOrbit3D() : boolean;
function set VisibleOrbit3D(value : boolean);

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.hDc Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.hDc Property

 Return to chapter overview

Show / hide the hidden text

Gets a handle to a device context (DC) for the client area of the control.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property hDc() As Integer

C#

int hDc {get;}

C++

property int hDc {
int get( );
}

JScript

function get hDc() : int;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.hWnd Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.hWnd Property

 Return to chapter overview

Show / hide the hidden text

Gets the window handle that the control is bound to.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property hWnd() As Integer

C#

int hWnd {get;}

C++

property int hWnd {
int get( );
}

JScript

function get hWnd() : int;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.mmHeight Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.mmHeight Property

 Return to chapter overview

Show / hide the hidden text

Gets the physical height for the loaded HPGL drawing in millimeters.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property mmHeight() As Double

C#

double mmHeight {get;}

C++

property double mmHeight {
double get( );
}

JScript

function get mmHeight() : double;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.mmWidth Property

API Reference > CADViewLib Namespace > CADViewX Interface > Properties >

ICADViewX.mmWidth Property

 Return to chapter overview

Show / hide the hidden text

Gets the physical width for the loaded HPGL drawing in millimeters.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property mmWidth() As Double

C#

double mmWidth {get;}

C++

property double mmWidth {
double get( );
}

JScript

function get mmWidth() : double;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


CADViewX Methods

API Reference > CADViewLib Namespace > CADViewX Interface >

CADViewX Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | ActionUpdate | Updates the control's internal state. (inherited from ICADViewX ).
Public method | CADCoords | Calculates CAD coordinates for a point specified by the screen coordinates. (inherited from ICADViewX ).
Public method | Cancel | Terminates moving (or dragging) of the image. (inherited from ICADViewX ).
Public method | Center | Returns the center point of the drawing area. (inherited from ICADViewX ).
Public method | CheckUpdates | Checks for a new version of the control available to download. (inherited from ICADViewX ).
Public method | CloseFile | Closes the currently opened file. (inherited from ICADViewX ).
Public method | ConvertCADToJPEG | Converts a CAD drawing file to the JPEG format. (inherited from ICADViewX ).
Public method | ConvertCustom | (inherited from ICADViewX ).
Public method | CopyToRaster | Copies the loaded CAD drawing to the clipboard as a bitmap. (inherited from ICADViewX ).
Public method | CurrentLayoutIterate | Iterates through the entities on the current drawing layout. (inherited from ICADViewX ).
Public method | DoToolButtonClick | Triggers the mouse click on a specified toolbar button. (inherited from ICADViewX ).
Public method | Empty | Returns a value indicating whether the control contains any drawing file or not. (inherited from ICADViewX ).
Public method | ExportToMetafile | Exports the loaded CAD drawing to Windows metafile. (inherited from ICADViewX ).
Public method | FindAutoCADSHXPaths | Returns paths to the SHX fonts installed with Autodesk products (AutoCAD, DWG TrueView). (inherited from ICADViewX ).
Public method | GetOpenDialogFilter | Retrieves a string that indicates the file types and descriptions displayed in the control's open file dialog. (inherited from ICADViewX ).
Public method | GetSaveDialogFilter | Retrieves a string that indicates the file types and descriptions displayed in the control's save file dialog. (inherited from ICADViewX ).
Public method | HasPrevScale | Check if the drawing was scaled on the screen. (inherited from ICADViewX ).
Public method | IsBadRect | Checks if the sizes of a specifed parallelepiped are defined correctly. (inherited from ICADViewX ).
Public method | IsVectGraphic | Returns a value indicating whether the loaded file contains vector graphics. (inherited from ICADViewX ).
Public method | LoadFile | Loads a specified file. (inherited from ICADViewX ).
Public method | LoadFromIni | Loads the control's settings from a specified .ini file. (inherited from ICADViewX ).
Public method | MkFPoint | Defines a point in the 3D space. (inherited from ICADViewX ).
Public method | MkFRect | Defines a parallelepiped (box). (inherited from ICADViewX ).
Public method | OpenActiveViewPort | Displays the active viewport. (inherited from ICADViewX ).
Public method | PictureRealign | Realigns the displayed image. (inherited from ICADViewX ).
Public method | PictureRect | Returns the bounding rectangle for the displayed image. (inherited from ICADViewX ).
Public method | PictureRepaint | Repaints the displayed image. (inherited from ICADViewX ).
Public method | Popup | Displays the control's context menu at a given location of the screen. (inherited from ICADViewX ).
Public method | PrevScale | Redraws the displayed image with a previous scale factor and boundaries. (inherited from ICADViewX ).
Public method | Print | Sends the loaded file to the current printer. (inherited from ICADViewX ).
Public method | PrintImage | Sends the loaded file to the current printer. (inherited from ICADViewX ).
Public method | ProcessXML | Processes a string which contains the XML instructions. (inherited from ICADViewX ).
Public method | RefreshAfterPictureAssign | Forces the control to clear the internal data left from the previously loaded file. (inherited from ICADViewX ).
Public method | RefreshAfterRotate | Forces the control to refresh the image after rotation. (inherited from ICADViewX ).
Public method | SaveCopyToFile | Copies the contents of the loaded file to a stream and saves the copy to a file. (inherited from ICADViewX ).
Public method | SaveToFile | Saves the loaded drawing to a specified file. (inherited from ICADViewX ).
Public method | SaveToFileEx | Saves the loaded drawing to a specified file. (inherited from ICADViewX ).
Public method | SaveToIni | Saves the control's settings to an .ini file (inherited from ICADViewX ).
Public method | ScaleImage | Applies the on-screen scaling to the displayed image. (inherited from ICADViewX ).
Public method | ScaledRectPicture | Captures a specified rectangle area as an Image object. (inherited from ICADViewX).
Public method | SetImageBounds | Sets the boundaries for the displayed image. (inherited from ICADViewX ).
Public method | ShowAbout | Forces the control to display the About dialog window. (inherited from ICADViewX).
Public method | ShowInfo | Displays a caption with a specified size. (inherited from ICADViewX ).
Public method | ShowLayersDialog | Forces the control to display the Layers dialog window. (inherited from ICADViewX).
Public method | ShowPoint | Displays the image centered by a specified point with a certain scale factor. (inherited from ICADViewX ).
Public method | ShowPointEx | Displays the image centered by a specified point with a certain scale factor. (inherited from ICADViewX ).
Public method | ShowRect | Displays the image centered by a specified rectangle area. (inherited from ICADViewX ).
Public method | StRg | Registers CADViewX developer license programmatically in the application. (inherited from ICADViewX ).
Public method | UsePictureRect | Obsolete. (inherited from ICADViewX ).
Public method | Zoom | Zooms to a specified rectangle area on the loaded drawing. (inherited from ICADViewX ).
Public method | get_EnabledAction | Returns a value indicating whether a specified toolbar button is enabled. (inherited from ICADViewX ).
Public method | get_Items | (inherited from ICADViewX ).
Public method | get_Languages | Retrieves a GUI language name by its index. (inherited from ICADViewX ).
Public method | get_Printer | Retrieves a printer name by its index. (inherited from ICADViewX ).
Public method | get_VisibleAction | Returns a value indicating whether a specified toolbar button is visible. (inherited from ICADViewX ).
Public method | let_Font | Sets a font for the control. (inherited from ICADViewX ).
Public method | set_EnabledAction | Makes a specified toolbar button enabled or disabled. (inherited from ICADViewX ).
Public method | set_Printer | Changes a local name of the printer at the given index. (inherited from ICADViewX ).
Public method | set_VisibleAction | Makes a specified toolbar button visible or hidden. (inherited from ICADViewX ).

Top

collall See Also

Reference

CADViewX Interface


ICADViewX.ActionUpdate Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.ActionUpdate Method

 Return to chapter overview

Show / hide the hidden text

Updates the control's internal state.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function ActionUpdate() As Boolean

C#

bool ActionUpdate()

C++

bool ActionUpdate()

JScript

function ActionUpdate() : boolean;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.CADCoords Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.CADCoords Method

 Return to chapter overview

Show / hide the hidden text

Calculates CAD coordinates for a point specified by the screen coordinates.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function CADCoords( _
ByVal X As Integer, _
ByVal Y As Integer _
) As Point3D

C#

Point3D CADCoords(
intX,
intY
)

C++

Point3D^ CADCoords(
intX,
intY
)

JScript

function CADCoords(
X : int,
Y : int
) : Point3D;

Parameters

X

Y

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.Cancel Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.Cancel Method

 Return to chapter overview

Show / hide the hidden text

Terminates moving (or dragging) of the image.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub Cancel()

C#

void Cancel()

C++

void Cancel()

JScript

function Cancel();

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.Center Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.Center Method

 Return to chapter overview

Show / hide the hidden text

Returns the center point of the drawing area.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function Center() As Point2D

C#

Point2D Center()

C++

Point2D^ Center()

JScript

function Center() : Point2D;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.CheckUpdates Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.CheckUpdates Method

 Return to chapter overview

Show / hide the hidden text

Checks for a new version of the control available to download.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub CheckUpdates()

C#

void CheckUpdates()

C++

void CheckUpdates()

JScript

function CheckUpdates();

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.CloseFile Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.CloseFile Method

 Return to chapter overview

Show / hide the hidden text

Closes the currently opened file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub CloseFile()

C#

void CloseFile()

C++

void CloseFile()

JScript

function CloseFile();

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.ConvertCADToJPEG Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.ConvertCADToJPEG Method

 Return to chapter overview

Show / hide the hidden text

Converts a CAD drawing file to the JPEG format.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function ConvertCADToJPEG( _
ByVal ASrc As String, _
ByVal ADest As String, _
ByVal AMaxDimensions As Integer _
) As Boolean

C#

bool ConvertCADToJPEG(
stringASrc,
stringADest,
intAMaxDimensions
)

C++

bool ConvertCADToJPEG(
String^ ASrc,
String^ ADest,
intAMaxDimensions
)

JScript

function ConvertCADToJPEG(
ASrc : String,
ADest : String,
AMaxDimensions : int
) : boolean;

Parameters

ASrc

ADest

AMaxDimensions

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.ConvertCustom Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.ConvertCustom Method

 Return to chapter overview

Show / hide the hidden text

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function ConvertCustom( _
ByVal ASrc As Object, _
ByVal ADest As Object, _
ByVal AParams As Object _
) As Object

C#

object ConvertCustom(
objectASrc,
objectADest,
objectAParams
)

C++

object^ ConvertCustom(
object^ ASrc,
object^ ADest,
object^ AParams
)

JScript

function ConvertCustom(
ASrc : object,
ADest : object,
AParams : object
) : object;

Parameters

ASrc

ADest

AParams

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.CopyToRaster Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.CopyToRaster Method

 Return to chapter overview

Show / hide the hidden text

Copies the loaded CAD drawing to the clipboard as a bitmap.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function CopyToRaster() As Boolean

C#

bool CopyToRaster()

C++

bool CopyToRaster()

JScript

function CopyToRaster() : boolean;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.CurrentLayoutIterate Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.CurrentLayoutIterate Method

 Return to chapter overview

Show / hide the hidden text

Iterates through the entities on the current drawing layout.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub CurrentLayoutIterate()

C#

void CurrentLayoutIterate()

C++

void CurrentLayoutIterate()

JScript

function CurrentLayoutIterate();

collall Remarks

This method fires the OnIterate event for each entity on the current layout.

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.DoToolButtonClick Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.DoToolButtonClick Method

 Return to chapter overview

Show / hide the hidden text

Triggers the mouse click on a specified toolbar button.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub DoToolButtonClick( _
ByVal ToolButton As TxToolButton _
)

C#

void DoToolButtonClick(
TxToolButtonToolButton
)

C++

void DoToolButtonClick(
TxToolButtonToolButton
)

JScript

function DoToolButtonClick(
ToolButton : TxToolButton
);

Parameters

ToolButton

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.Empty Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.Empty Method

 Return to chapter overview

Show / hide the hidden text

Returns a value indicating whether the control contains any drawing file or not.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function Empty() As Boolean

C#

bool Empty()

C++

bool Empty()

JScript

function Empty() : boolean;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.ExportToMetafile Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.ExportToMetafile Method

 Return to chapter overview

Show / hide the hidden text

Exports the loaded CAD drawing to Windows metafile.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub ExportToMetafile( _
ByVal FileName As String, _
ByVal AWidth As Integer, _
ByVal AHeight As Integer _
)

C#

void ExportToMetafile(
stringFileName,
intAWidth,
intAHeight
)

C++

void ExportToMetafile(
String^ FileName,
intAWidth,
intAHeight
)

JScript

function ExportToMetafile(
FileName : String,
AWidth : int,
AHeight : int
);

Parameters

FileName

AWidth

AHeight

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.FindAutoCADSHXPaths Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.FindAutoCADSHXPaths Method

 Return to chapter overview

Show / hide the hidden text

Returns paths to the SHX fonts installed with Autodesk products (AutoCAD, DWG TrueView).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function FindAutoCADSHXPaths() As String

C#

string FindAutoCADSHXPaths()

C++

String^ FindAutoCADSHXPaths()

JScript

function FindAutoCADSHXPaths() : String;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.GetOpenDialogFilter Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.GetOpenDialogFilter Method

 Return to chapter overview

Show / hide the hidden text

Retrieves a string that indicates the file types and descriptions displayed in the control's open file dialog.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function GetOpenDialogFilter() As String

C#

string GetOpenDialogFilter()

C++

String^ GetOpenDialogFilter()

JScript

function GetOpenDialogFilter() : String;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.GetSaveDialogFilter Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.GetSaveDialogFilter Method

 Return to chapter overview

Show / hide the hidden text

Retrieves a string that indicates the file types and descriptions displayed in the control's save file dialog.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function GetSaveDialogFilter() As String

C#

string GetSaveDialogFilter()

C++

String^ GetSaveDialogFilter()

JScript

function GetSaveDialogFilter() : String;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.HasPrevScale Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.HasPrevScale Method

 Return to chapter overview

Show / hide the hidden text

Check if the drawing was scaled on the screen.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function HasPrevScale() As Boolean

C#

bool HasPrevScale()

C++

bool HasPrevScale()

JScript

function HasPrevScale() : boolean;

Return Value

true if the drawing was scaled; otherwise, false.

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.IsBadRect Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.IsBadRect Method

 Return to chapter overview

Show / hide the hidden text

Checks if the sizes of a specifed parallelepiped are defined correctly.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function IsBadRect( _
ByVal ARect As Rect3D _
) As Boolean

C#

bool IsBadRect(
Rect3DARect
)

C++

bool IsBadRect(
Rect3D^ ARect
)

JScript

function IsBadRect(
ARect : Rect3D
) : boolean;

Parameters

ARect

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.IsVectGraphic Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.IsVectGraphic Method

 Return to chapter overview

Show / hide the hidden text

Returns a value indicating whether the loaded file contains vector graphics.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function IsVectGraphic() As Boolean

C#

bool IsVectGraphic()

C++

bool IsVectGraphic()

JScript

function IsVectGraphic() : boolean;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.LoadFile Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.LoadFile Method

 Return to chapter overview

Show / hide the hidden text

Loads a specified file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub LoadFile( _
ByVal FileName As String _
)

C#

void LoadFile(
stringFileName
)

C++

void LoadFile(
String^ FileName
)

JScript

function LoadFile(
FileName : String
);

Parameters

FileName

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.LoadFromIni Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.LoadFromIni Method

 Return to chapter overview

Show / hide the hidden text

Loads the control's settings from a specified .ini file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function LoadFromIni( _
ByVal IniFileName As String _
) As Boolean

C#

bool LoadFromIni(
stringIniFileName
)

C++

bool LoadFromIni(
String^ IniFileName
)

JScript

function LoadFromIni(
IniFileName : String
) : boolean;

Parameters

IniFileName

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.MkFPoint Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.MkFPoint Method

 Return to chapter overview

Show / hide the hidden text

Defines a point in the 3D space.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function MkFPoint( _
ByVal X As Double, _
ByVal Y As Double, _
ByVal Z As Double _
) As Point3D

C#

Point3D MkFPoint(
doubleX,
doubleY,
doubleZ
)

C++

Point3D^ MkFPoint(
doubleX,
doubleY,
doubleZ
)

JScript

function MkFPoint(
X : double,
Y : double,
Z : double
) : Point3D;

Parameters

X

Y

Z

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.MkFRect Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.MkFRect Method

 Return to chapter overview

Show / hide the hidden text

Defines a parallelepiped (box).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function MkFRect( _
ByVal Left As Double, _
ByVal Top As Double, _
ByVal Z1 As Double, _
ByVal Right As Double, _
ByVal Bottom As Double, _
ByVal Z2 As Double _
) As Rect3D

C#

Rect3D MkFRect(
doubleLeft,
doubleTop,
doubleZ1,
doubleRight,
doubleBottom,
doubleZ2
)

C++

Rect3D^ MkFRect(
doubleLeft,
doubleTop,
doubleZ1,
doubleRight,
doubleBottom,
doubleZ2
)

JScript

function MkFRect(
Left : double,
Top : double,
Z1 : double,
Right : double,
Bottom : double,
Z2 : double
) : Rect3D;

Parameters

Left

Top

Z1

Right

Bottom

Z2

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.OpenActiveViewPort Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.OpenActiveViewPort Method

 Return to chapter overview

Show / hide the hidden text

Displays the active viewport.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function OpenActiveViewPort() As Boolean

C#

bool OpenActiveViewPort()

C++

bool OpenActiveViewPort()

JScript

function OpenActiveViewPort() : boolean;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.PictureRealign Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.PictureRealign Method

 Return to chapter overview

Show / hide the hidden text

Realigns the displayed image.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub PictureRealign()

C#

void PictureRealign()

C++

void PictureRealign()

JScript

function PictureRealign();

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.PictureRect Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.PictureRect Method

 Return to chapter overview

Show / hide the hidden text

Returns the bounding rectangle for the displayed image.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function PictureRect() As Rect2D

C#

Rect2D PictureRect()

C++

Rect2D^ PictureRect()

JScript

function PictureRect() : Rect2D;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.PictureRepaint Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.PictureRepaint Method

 Return to chapter overview

Show / hide the hidden text

Repaints the displayed image.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub PictureRepaint()

C#

void PictureRepaint()

C++

void PictureRepaint()

JScript

function PictureRepaint();

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.Popup Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.Popup Method

 Return to chapter overview

Show / hide the hidden text

Displays the control's context menu at a given location of the screen.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub Popup( _
ByVal X As Integer, _
ByVal Y As Integer _
)

C#

void Popup(
intX,
intY
)

C++

void Popup(
intX,
intY
)

JScript

function Popup(
X : int,
Y : int
);

Parameters

X

Y

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.PrevScale Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.PrevScale Method

 Return to chapter overview

Show / hide the hidden text

Redraws the displayed image with a previous scale factor and boundaries.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub PrevScale()

C#

void PrevScale()

C++

void PrevScale()

JScript

function PrevScale();

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.Print Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.Print Method

 Return to chapter overview

Show / hide the hidden text

Sends the loaded file to the current printer.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub Print()

C#

void Print()

C++

void Print()

JScript

function Print();

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.PrintImage Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.PrintImage Method

 Return to chapter overview

Show / hide the hidden text

Sends the loaded file to the current printer.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub PrintImage()

C#

void PrintImage()

C++

void PrintImage()

JScript

function PrintImage();

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.ProcessXML Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.ProcessXML Method

 Return to chapter overview

Show / hide the hidden text

Processes a string which contains the XML instructions.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function ProcessXML( _
ByVal AXML As String _
) As String

C#

string ProcessXML(
stringAXML
)

C++

String^ ProcessXML(
String^ AXML
)

JScript

function ProcessXML(
AXML : String
) : String;

Parameters

AXML

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.RefreshAfterPictureAssign Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.RefreshAfterPictureAssign Method

 Return to chapter overview

Show / hide the hidden text

Forces the control to clear the internal data left from the previously loaded file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub RefreshAfterPictureAssign()

C#

void RefreshAfterPictureAssign()

C++

void RefreshAfterPictureAssign()

JScript

function RefreshAfterPictureAssign();

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.RefreshAfterRotate Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.RefreshAfterRotate Method

 Return to chapter overview

Show / hide the hidden text

Forces the control to refresh the image after rotation.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub RefreshAfterRotate()

C#

void RefreshAfterRotate()

C++

void RefreshAfterRotate()

JScript

function RefreshAfterRotate();

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.SaveCopyToFile Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.SaveCopyToFile Method

 Return to chapter overview

Show / hide the hidden text

Copies the contents of the loaded file to a stream and saves the copy to a file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub SaveCopyToFile( _
ByVal FileName As String _
)

C#

void SaveCopyToFile(
stringFileName
)

C++

void SaveCopyToFile(
String^ FileName
)

JScript

function SaveCopyToFile(
FileName : String
);

Parameters

FileName

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.SaveToFile Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.SaveToFile Method

 Return to chapter overview

Show / hide the hidden text

Saves the loaded drawing to a specified file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub SaveToFile( _
ByVal FileName As String _
)

C#

void SaveToFile(
stringFileName
)

C++

void SaveToFile(
String^ FileName
)

JScript

function SaveToFile(
FileName : String
);

Parameters

FileName

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.SaveToFileEx Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.SaveToFileEx Method

 Return to chapter overview

Show / hide the hidden text

Saves the loaded drawing to a specified file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub SaveToFileEx( _
ByVal FileName As String, _
ByVal Confirm As Boolean, _
ByVal ShowSizeDialog As Boolean _
)

C#

void SaveToFileEx(
stringFileName,
boolConfirm,
boolShowSizeDialog
)

C++

void SaveToFileEx(
String^ FileName,
boolConfirm,
boolShowSizeDialog
)

JScript

function SaveToFileEx(
FileName : String,
Confirm : boolean,
ShowSizeDialog : boolean
);

Parameters

FileName

Confirm

ShowSizeDialog

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.SaveToIni Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.SaveToIni Method

 Return to chapter overview

Show / hide the hidden text

Saves the control's settings to an .ini file

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function SaveToIni( _
ByVal IniFileName As String _
) As Boolean

C#

bool SaveToIni(
stringIniFileName
)

C++

bool SaveToIni(
String^ IniFileName
)

JScript

function SaveToIni(
IniFileName : String
) : boolean;

Parameters

IniFileName

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.ScaleImage Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.ScaleImage Method

 Return to chapter overview

Show / hide the hidden text

Applies the on-screen scaling to the displayed image.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function ScaleImage( _
ByVal Abs As Boolean, _
ByVal Coef As Double, _
ByVal X As Integer, _
ByVal Y As Integer _
) As Integer

C#

int ScaleImage(
boolAbs,
doubleCoef,
intX,
intY
)

C++

int ScaleImage(
boolAbs,
doubleCoef,
intX,
intY
)

JScript

function ScaleImage(
Abs : boolean,
Coef : double,
X : int,
Y : int
) : int;

Parameters

Abs

Coef

X

Y

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.ScaledRectPicture Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.ScaledRectPicture Method

 Return to chapter overview

Show / hide the hidden text

Captures a specified rectangle area as an Image object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function ScaledRectPicture( _
ByVal X As Integer, _
ByVal Y As Integer, _
ByVal Scale As Double, _
ByVal DstWidth As Integer, _
ByVal DstHeight As Integer _
) As StdPicture

C#

StdPicture ScaledRectPicture(
intX,
intY,
doubleScale,
intDstWidth,
intDstHeight
)

C++

StdPicture^ ScaledRectPicture(
intX,
intY,
doubleScale,
intDstWidth,
intDstHeight
)

JScript

function ScaledRectPicture(
X : int,
Y : int,
Scale : double,
DstWidth : int,
DstHeight : int
) : StdPicture;

Parameters

X

Y

Scale

DstWidth

DstHeight

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.SetImageBounds Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.SetImageBounds Method

 Return to chapter overview

Show / hide the hidden text

Sets the boundaries for the displayed image.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub SetImageBounds( _
ByVal ALeft As Integer, _
ByVal ATop As Integer, _
ByVal AWidth As Integer, _
ByVal AHeight As Integer _
)

C#

void SetImageBounds(
intALeft,
intATop,
intAWidth,
intAHeight
)

C++

void SetImageBounds(
intALeft,
intATop,
intAWidth,
intAHeight
)

JScript

function SetImageBounds(
ALeft : int,
ATop : int,
AWidth : int,
AHeight : int
);

Parameters

ALeft

ATop

AWidth

AHeight

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.ShowAbout Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.ShowAbout Method

 Return to chapter overview

Show / hide the hidden text

Forces the control to display the About dialog window.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub ShowAbout()

C#

void ShowAbout()

C++

void ShowAbout()

JScript

function ShowAbout();

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.ShowInfo Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.ShowInfo Method

 Return to chapter overview

Show / hide the hidden text

Displays a caption with a specified size.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub ShowInfo( _
ByVal ACaption As String, _
ByVal AWidth As Integer, _
ByVal AHeight As Integer, _
ByVal AFontSize As Integer _
)

C#

void ShowInfo(
stringACaption,
intAWidth,
intAHeight,
intAFontSize
)

C++

void ShowInfo(
String^ ACaption,
intAWidth,
intAHeight,
intAFontSize
)

JScript

function ShowInfo(
ACaption : String,
AWidth : int,
AHeight : int,
AFontSize : int
);

Parameters

ACaption

AWidth

AHeight

AFontSize

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.ShowLayersDialog Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.ShowLayersDialog Method

 Return to chapter overview

Show / hide the hidden text

Forces the control to display the Layers dialog window.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub ShowLayersDialog()

C#

void ShowLayersDialog()

C++

void ShowLayersDialog()

JScript

function ShowLayersDialog();

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.ShowPoint Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.ShowPoint Method

 Return to chapter overview

Show / hide the hidden text

Displays the image centered by a specified point with a certain scale factor.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub ShowPoint( _
ByVal APoint As Point3D, _
ByVal AScale As Double, _
ByVal AExtents As Rect3D _
)

C#

void ShowPoint(
Point3DAPoint,
doubleAScale,
Rect3DAExtents
)

C++

void ShowPoint(
Point3D^ APoint,
doubleAScale,
Rect3D^ AExtents
)

JScript

function ShowPoint(
APoint : Point3D,
AScale : double,
AExtents : Rect3D
);

Parameters

APoint

AScale

AExtents

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.ShowPointEx Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.ShowPointEx Method

 Return to chapter overview

Show / hide the hidden text

Displays the image centered by a specified point with a certain scale factor.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function ShowPointEx( _
ByVal X As Double, _
ByVal Y As Double, _
ByVal Z As Double, _
ByVal AScale As Double, _
ByVal AExtents As Rect3D _
) As Boolean

C#

bool ShowPointEx(
doubleX,
doubleY,
doubleZ,
doubleAScale,
Rect3DAExtents
)

C++

bool ShowPointEx(
doubleX,
doubleY,
doubleZ,
doubleAScale,
Rect3D^ AExtents
)

JScript

function ShowPointEx(
X : double,
Y : double,
Z : double,
AScale : double,
AExtents : Rect3D
) : boolean;

Parameters

X

Y

Z

AScale

AExtents

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.ShowRect Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.ShowRect Method

 Return to chapter overview

Show / hide the hidden text

Displays the image centered by a specified rectangle area.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function ShowRect( _
ByVal ARect As Object _
) As Boolean

C#

bool ShowRect(
objectARect
)

C++

bool ShowRect(
object^ ARect
)

JScript

function ShowRect(
ARect : object
) : boolean;

Parameters

ARect

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.StRg Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.StRg Method

 Return to chapter overview

Show / hide the hidden text

Registers CADViewX developer license programmatically in the application.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function StRg( _
ByVal AUser As String, _
ByVal AEMail As String, _
ByVal AKey As String _
) As Integer

C#

int StRg(
stringAUser,
stringAEMail,
stringAKey
)

C++

int StRg(
String^ AUser,
String^ AEMail,
String^ AKey
)

JScript

function StRg(
AUser : String,
AEMail : String,
AKey : String
) : int;

Parameters

AUser

AEMail

AKey

Return Value

1 if the license was registered successfully, otherwise, 0.

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.UsePictureRect Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.UsePictureRect Method

 Return to chapter overview

Show / hide the hidden text

NOTE: This member is now obsolete.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function UsePictureRect() As Boolean

C#

bool UsePictureRect()

C++

bool UsePictureRect()

JScript

function UsePictureRect() : boolean;

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.Zoom Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.Zoom Method

 Return to chapter overview

Show / hide the hidden text

Zooms to a specified rectangle area on the loaded drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function Zoom( _
ByVal Rect As Rect2D _
) As Boolean

C#

bool Zoom(
Rect2DRect
)

C++

bool Zoom(
Rect2D^ Rect
)

JScript

function Zoom(
Rect : Rect2D
) : boolean;

Parameters

Rect

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.get_EnabledAction Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.get_EnabledAction Method

 Return to chapter overview

Show / hide the hidden text

Returns a value indicating whether a specified toolbar button is enabled.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function get_EnabledAction( _
ByVal Index As TxToolButton _
) As Boolean

C#

bool get_EnabledAction(
TxToolButtonIndex
)

C++

bool get_EnabledAction(
TxToolButtonIndex
)

JScript

function get_EnabledAction(
Index : TxToolButton
) : boolean;

Parameters

Index

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.get_Items Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.get_Items Method

 Return to chapter overview

Show / hide the hidden text

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function get_Items( _
ByVal Index As Integer _
) As CADViewX

C#

CADViewX get_Items(
intIndex
)

C++

CADViewX^ get_Items(
intIndex
)

JScript

function get_Items(
Index : int
) : CADViewX;

Parameters

Index

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.get_Languages Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.get_Languages Method

 Return to chapter overview

Show / hide the hidden text

Retrieves a GUI language name by its index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function get_Languages( _
ByVal Index As Integer _
) As String

C#

string get_Languages(
intIndex
)

C++

String^ get_Languages(
intIndex
)

JScript

function get_Languages(
Index : int
) : String;

Parameters

Index

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.get_Printer Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.get_Printer Method

 Return to chapter overview

Show / hide the hidden text

Retrieves a printer name by its index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function get_Printer( _
ByVal Index As Integer _
) As String

C#

string get_Printer(
intIndex
)

C++

String^ get_Printer(
intIndex
)

JScript

function get_Printer(
Index : int
) : String;

Parameters

Index

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.get_VisibleAction Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.get_VisibleAction Method

 Return to chapter overview

Show / hide the hidden text

Returns a value indicating whether a specified toolbar button is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function get_VisibleAction( _
ByVal Index As TxToolButton _
) As Boolean

C#

bool get_VisibleAction(
TxToolButtonIndex
)

C++

bool get_VisibleAction(
TxToolButtonIndex
)

JScript

function get_VisibleAction(
Index : TxToolButton
) : boolean;

Parameters

Index

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.let_Font Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.let_Font Method

 Return to chapter overview

Show / hide the hidden text

Sets a font for the control.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub let_Font( _
ByVal Value As StdFont _
)

C#

void let_Font(
StdFontValue
)

C++

void let_Font(
StdFont^ Value
)

JScript

function let_Font(
Value : StdFont
);

Parameters

Value

The font value.

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.set_EnabledAction Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.set_EnabledAction Method

 Return to chapter overview

Show / hide the hidden text

Makes a specified toolbar button enabled or disabled.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub set_EnabledAction( _
ByVal Index As TxToolButton, _
ByVal Value As Boolean _
)

C#

void set_EnabledAction(
TxToolButtonIndex,
boolValue
)

C++

void set_EnabledAction(
TxToolButtonIndex,
boolValue
)

JScript

function set_EnabledAction(
Index : TxToolButton,
Value : boolean
);

Parameters

Index

Value

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.set_Printer Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.set_Printer Method

 Return to chapter overview

Show / hide the hidden text

Changes a local name of the printer at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub set_Printer( _
ByVal Index As Integer, _
ByVal Value As String _
)

C#

void set_Printer(
intIndex,
stringValue
)

C++

void set_Printer(
intIndex,
String^ Value
)

JScript

function set_Printer(
Index : int,
Value : String
);

Parameters

Index

Value

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


ICADViewX.set_VisibleAction Method

API Reference > CADViewLib Namespace > CADViewX Interface > Methods >

ICADViewX.set_VisibleAction Method

 Return to chapter overview

Show / hide the hidden text

Makes a specified toolbar button visible or hidden.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub set_VisibleAction( _
ByVal Index As TxToolButton, _
ByVal Value As Boolean _
)

C#

void set_VisibleAction(
TxToolButtonIndex,
boolValue
)

C++

void set_VisibleAction(
TxToolButtonIndex,
boolValue
)

JScript

function set_VisibleAction(
Index : TxToolButton,
Value : boolean
);

Parameters

Index

Value

collall See Also

Reference

ICADViewX Interface
ICADViewX ICADViewX Members


CGMImage Interface

API Reference > CADViewLib Namespace >

CGMImage Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to a CGM drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface CGMImage
Inherits ICGMImage, _
IDXFImageEvents_Event

C#

public interface CGMImage : ICGMImage,
IDXFImageEvents_Event

C++

public interface class CGMImage : public ICGMImage^,
public IDXFImageEvents_Event^

JScript

public interface CGMImage
implements ICGMImage,
IDXFImageEvents_Event

collall See Also

Reference

CGMImage Members


CGMImage Members

API Reference > CADViewLib Namespace > CGMImage Interface >

CGMImage Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to a CGM drawing.

The following tables list the members exposed by the CGMImage type.

collall Public Properties

 | Name | Description
Public property | BackGroundColor | Gets or sets a background color for the drawing. (inherited from ICGMImage ).
Public property | BorderSize | Gets or sets a border size for the drawing. (inherited from ICGMImage ).
Public property | BorderType | Gets or sets a way the drawing's border size is defined (global or ratio). (inherited from ICGMImage ).
Public property | CADClassID | Gets the CAD format identifier for the drawing. (inherited from ICGMImage ).
Public property | CBFormat | Gets or sets the clipboard format. (inherited from ICGMImage ).
Public property | CanStopLoading | Gets a value indicating whether the loading of the drawing data can be terminated. (inherited from ICGMImage ).
Public property | Charset | Gets or sets a character set for the text entities. (inherited from ICGMImage ).
Public property | ColorToLineWeight | Gets or sets a string which contains the color-lineweight pairs. (inherited from ICGMImage ).
Public property | Converter | Gets or sets a Converter associated with this image object. (inherited from ICGMImage ).
Public property | Count | Gets a number of entities in the drawing. (inherited from ICGMImage ).
Public property | CurrentLayout | Gets or sets the current layout for the drawing. (inherited from ICGMImage ).
Public property | DefaultColor | Gets or sets the default color for the drawing. (inherited from ICGMImage ).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions in the drawing are visible. (inherited from ICGMImage ).
Public property | DrawMode | Gets or sets an appearance of colors in the drawing. (inherited from ICGMImage ).
Public property | DrawingBox | Gets or sets the drawing bounding box. (inherited from ICGMImage ).
Public property | Empty | Gets a value indicating whether the drawing is empty. (inherited from ICGMImage ).
Public property | Extents | Gets or sets the drawing's extents. (inherited from ICGMImage ).
Public property | Height | Gets or sets a height of the drawing. (inherited from ICGMImage ).
Public property | Is3D | Gets a value indicating whether the drawing is three-dimensional. (inherited from ICGMImage ).
Public property | IsDraw3DAxes | Gets a value indicating whether 3D axes are visible on the drawing. (inherited from ICGMImage ).
Public property | IsDrawingRotated | Gets a value indicating whether the drawing is rotated. (inherited from ICGMImage ).
Public property | IsLoading | Gets a value indicating whether the process of loading the drawing data is active. (inherited from ICGMImage ).
Public property | IsPlotting | Gets or sets a value indicating whether to plot the image or not. (inherited from ICGMImage ).
Public property | IsProcessMessages | Gets or sets a value indicating whether the messages processing is allowed. (inherited from ICGMImage ).
Public property | IsShowBackground | Gets or sets a value indicating whether the backround is displayed. (inherited from ICGMImage ).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines is determined by the drawing data. (inherited from ICGMImage ).
Public property | IsWithoutBorder | Gets or sets a value indicating whether to display the drawing without borders. (inherited from ICGMImage ).
Public property | LayoutsCount | Gets the number of layouts in the drawing. (inherited from ICGMImage ).
Public property | LineScaled | Gets or sets a value indicating whether the line weight is diplayed. (inherited from ICGMImage ).
Public property | LineWeightScale | Gets or sets a scale for line weights. (inherited from ICGMImage ).
Public property | Millimetres | Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file. (inherited from ICGMImage ).
Public property | Modified | Gets or sets a value indicating whether the drawing is modified. (inherited from ICGMImage ).
Public property | NullWidth | Gets or sets a thickness for lines which have the zero lineweight. (inherited from ICGMImage ).
Public property | OwnSource | For internal use. (inherited from ICGMImage ).
Public property | PureExtents | Gets the drawing's extents excluding the borders. (inherited from ICGMImage ).
Public property | ResizeDisproportionateDrawing | Gets or sets a value indicating whether to resize a drawing with disproportionate sizes. (inherited from ICGMImage ).
Public property | Scale | Gets or sets a 3D point which defines the scale factor. (inherited from ICGMImage ).
Public property | ShowImages | Gets or sets a value indicating whether the raster images are displayed. (inherited from ICGMImage ).
Public property | Stretch | Gets or sets a value indicating whether the displayed image has to be stretched to fit exactly with the drawing rectangle. (inherited from ICGMImage ).
Public property | TextVisible | Gets or sets a value indicating whether texts in the drawing are visible. (inherited from ICGMImage ).
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles are drawn by using GDI+ methods without linearization. (inherited from ICGMImage ).
Public property | ViewRectangle | For internal use. (inherited from ICGMImage ).
Public property | Width | Gets or sets a width of the drawing. (inherited from ICGMImage ).

Top

collall Public Methods

 | Name | Description
Public method | AbsHeight | Returns an absolute height of the CAD drawing. (inherited from ICGMImage ).
Public method | AbsWidth | Returns an absolute width of the CAD drawing. (inherited from ICGMImage ).
Public method | AddScaledDXF | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing. (inherited from ICGMImage ).
Public method | AddScaledDXFEx | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing. (inherited from ICGMImage ).
Public method | AssignImage | Makes a copy of a specified CAD image object and assigns it to this image. (inherited from ICGMImage ).
Public method | CreateImage | Initializes a new CAD image instance. (inherited from ICGMImage ).
Public method | Draw | Draws the CAD image in a specified device context (DC). (inherited from ICGMImage ).
Public method | DrawRect | Draws a specified region of this CAD image in a device context (DC). (inherited from ICGMImage ).
Public method | ExportToMetafile | Exports this CAD image to Windows metafile. (inherited from ICGMImage ).
Public method | FreeImage | Destroys this CAD image object and frees the memory used within the object. (inherited from ICGMImage ).
Public method | GetCADCoords | Returns CAD coordinates for a specified point. (inherited from ICGMImage ).
Public method | GetEntityColor | Returns the color value for a specified entity. (inherited from ICGMImage ).
Public method | GetExtents | Recalculates extents of the CAD image. (inherited from ICGMImage ).
Public method | GetPoint | Gets the on-screen coordinates for a specified CAD point. (inherited from ICGMImage ).
Public method | GetRealImagePoint | Returns CAD coordinates of a specified point considering the drawing's rotation and viewport parameters. (inherited from ICGMImage ).
Public method | HeadVarAsFloat | Returns a value of the DXF header variable as a floating point number. (inherited from ICGMImage ).
Public method | HeadVarAsInteger | Returns a value of the DXF header variable as an integer. (inherited from ICGMImage ).
Public method | HeadVarAsstring | Returns a value of the DXF header variable as a string. (inherited from ICGMImage ).
Public method | LoadFromClipboardFormat | Loads data from the clipboard. (inherited from ICGMImage ).
Public method | LoadFromFile | Loads a CAD drawing from file. (inherited from ICGMImage ).
Public method | LoadFromIStream | Loads a CAD drawing from stream. (inherited from ICGMImage ).
Public method | LoadFromStream | Loads a CAD drawing from stream. (inherited from ICGMImage ).
Public method | RefreshCurrentLayout | Refreshes the current layout. (inherited from ICGMImage ).
Public method | ResetDrawingBox | Switches off the drawing box. (inherited from ICGMImage ).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from ICGMImage ).
Public method | RotToView | Rotates the drawing to a specified view. (inherited from ICGMImage ).
Public method | Rotate | Rotates the drawing. (inherited from ICGMImage ).
Public method | SaveToClipboardFormat | Copies the drawing to the clipboard in a specified format. (inherited from ICGMImage ).
Public method | SaveToFile | Saves the drawing to a specified file. (inherited from ICGMImage ).
Public method | SaveToIStream | Writes the drawing data to a specified stream. (inherited from ICGMImage ).
Public method | SaveToStream | Writes the drawing data to a specified stream. (inherited from ICGMImage ).
Public method | SetClippingRect | Sets a clipping rectangle for the drawing. (inherited from ICGMImage ).
Public method | SetExtentsParameters | Changes the drawing extents. (inherited from ICGMImage ).
Public method | StopLoading | Terminates loading of the drawing data. (inherited from ICGMImage ).
Public method | get_Blocks | Retrieves a BLOCK object by its index. (inherited from ICGMImage ).
Public method | get_Entities | Retrieves an entity by its index. (inherited from ICGMImage ).
Public method | get_Items | (inherited from ICGMImage ).
Public method | get_Layouts | Retrieves a layout by its index. (inherited from ICGMImage ).

Top

collall See Also

Reference

CGMImage Interface


CGMImage Properties

API Reference > CADViewLib Namespace > CGMImage Interface >

CGMImage Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | BackGroundColor | Gets or sets a background color for the drawing. (inherited from ICGMImage ).
Public property | BorderSize | Gets or sets a border size for the drawing. (inherited from ICGMImage ).
Public property | BorderType | Gets or sets a way the drawing's border size is defined (global or ratio). (inherited from ICGMImage ).
Public property | CADClassID | Gets the CAD format identifier for the drawing. (inherited from ICGMImage ).
Public property | CBFormat | Gets or sets the clipboard format. (inherited from ICGMImage ).
Public property | CanStopLoading | Gets a value indicating whether the loading of the drawing data can be terminated. (inherited from ICGMImage ).
Public property | Charset | Gets or sets a character set for the text entities. (inherited from ICGMImage ).
Public property | ColorToLineWeight | Gets or sets a string which contains the color-lineweight pairs. (inherited from ICGMImage ).
Public property | Converter | Gets or sets a Converter associated with this image object. (inherited from ICGMImage ).
Public property | Count | Gets a number of entities in the drawing. (inherited from ICGMImage ).
Public property | CurrentLayout | Gets or sets the current layout for the drawing. (inherited from ICGMImage ).
Public property | DefaultColor | Gets or sets the default color for the drawing. (inherited from ICGMImage ).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions in the drawing are visible. (inherited from ICGMImage ).
Public property | DrawMode | Gets or sets an appearance of colors in the drawing. (inherited from ICGMImage ).
Public property | DrawingBox | Gets or sets the drawing bounding box. (inherited from ICGMImage ).
Public property | Empty | Gets a value indicating whether the drawing is empty. (inherited from ICGMImage ).
Public property | Extents | Gets or sets the drawing's extents. (inherited from ICGMImage ).
Public property | Height | Gets or sets a height of the drawing. (inherited from ICGMImage ).
Public property | Is3D | Gets a value indicating whether the drawing is three-dimensional. (inherited from ICGMImage ).
Public property | IsDraw3DAxes | Gets a value indicating whether 3D axes are visible on the drawing. (inherited from ICGMImage ).
Public property | IsDrawingRotated | Gets a value indicating whether the drawing is rotated. (inherited from ICGMImage ).
Public property | IsLoading | Gets a value indicating whether the process of loading the drawing data is active. (inherited from ICGMImage ).
Public property | IsPlotting | Gets or sets a value indicating whether to plot the image or not. (inherited from ICGMImage ).
Public property | IsProcessMessages | Gets or sets a value indicating whether the messages processing is allowed. (inherited from ICGMImage ).
Public property | IsShowBackground | Gets or sets a value indicating whether the backround is displayed. (inherited from ICGMImage ).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines is determined by the drawing data. (inherited from ICGMImage ).
Public property | IsWithoutBorder | Gets or sets a value indicating whether to display the drawing without borders. (inherited from ICGMImage ).
Public property | LayoutsCount | Gets the number of layouts in the drawing. (inherited from ICGMImage ).
Public property | LineScaled | Gets or sets a value indicating whether the line weight is diplayed. (inherited from ICGMImage ).
Public property | LineWeightScale | Gets or sets a scale for line weights. (inherited from ICGMImage ).
Public property | Millimetres | Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file. (inherited from ICGMImage ).
Public property | Modified | Gets or sets a value indicating whether the drawing is modified. (inherited from ICGMImage ).
Public property | NullWidth | Gets or sets a thickness for lines which have the zero lineweight. (inherited from ICGMImage ).
Public property | OwnSource | For internal use. (inherited from ICGMImage ).
Public property | PureExtents | Gets the drawing's extents excluding the borders. (inherited from ICGMImage ).
Public property | ResizeDisproportionateDrawing | Gets or sets a value indicating whether to resize a drawing with disproportionate sizes. (inherited from ICGMImage ).
Public property | Scale | Gets or sets a 3D point which defines the scale factor. (inherited from ICGMImage ).
Public property | ShowImages | Gets or sets a value indicating whether the raster images are displayed. (inherited from ICGMImage ).
Public property | Stretch | Gets or sets a value indicating whether the displayed image has to be stretched to fit exactly with the drawing rectangle. (inherited from ICGMImage ).
Public property | TextVisible | Gets or sets a value indicating whether texts in the drawing are visible. (inherited from ICGMImage ).
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles are drawn by using GDI+ methods without linearization. (inherited from ICGMImage ).
Public property | ViewRectangle | For internal use. (inherited from ICGMImage ).
Public property | Width | Gets or sets a width of the drawing. (inherited from ICGMImage ).

Top

collall See Also

Reference

CGMImage Interface


ICGMImage.BackGroundColor Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.BackGroundColor Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a background color for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property BackGroundColor() As UInt32

C#

UInt32 BackGroundColor {get; set;}

C++

property UInt32 BackGroundColor {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get BackGroundColor() : UInt32;
function set BackGroundColor(value : UInt32);

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.BorderSize Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.BorderSize Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a border size for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property BorderSize() As Double

C#

double BorderSize {get; set;}

C++

property double BorderSize {
double get( );
void set(
double value
);
}

JScript

function get BorderSize() : double;
function set BorderSize(value : double);

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.BorderType Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.BorderType Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a way the drawing's border size is defined (global or ratio).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property BorderType() As TxsgBorderType

C#

TxsgBorderType BorderType {get; set;}

C++

property TxsgBorderType BorderType {
TxsgBorderType get( );
void set(
TxsgBorderType value
);
}

JScript

function get BorderType() : TxsgBorderType;
function set BorderType(value : TxsgBorderType);

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.CADClassID Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.CADClassID Property

 Return to chapter overview

Show / hide the hidden text

Gets the CAD format identifier for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property CADClassID() As TxCADClassID

C#

TxCADClassID CADClassID {get;}

C++

property TxCADClassID CADClassID {
TxCADClassID get( );
}

JScript

function get CADClassID() : TxCADClassID;

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.CBFormat Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.CBFormat Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the clipboard format.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CBFormat() As UInt16

C#

UInt16 CBFormat {get; set;}

C++

property UInt16 CBFormat {
UInt16 get( );
void set(
UInt16 value
);
}

JScript

function get CBFormat() : UInt16;
function set CBFormat(value : UInt16);

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.CanStopLoading Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.CanStopLoading Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the loading of the drawing data can be terminated.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property CanStopLoading() As Boolean

C#

bool CanStopLoading {get;}

C++

property bool CanStopLoading {
bool get( );
}

JScript

function get CanStopLoading() : boolean;

Property Value

true if the loading can be terminated; otherwise, false.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.Charset Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.Charset Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a character set for the text entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Charset() As Byte

C#

byte Charset {get; set;}

C++

property Byte Charset {
Byte get( );
void set(
Byte value
);
}

JScript

function get Charset() : byte;
function set Charset(value : byte);

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.ColorToLineWeight Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.ColorToLineWeight Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a string which contains the color-lineweight pairs.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property ColorToLineWeight() As String

C#

string ColorToLineWeight {get; set;}

C++

property String^ ColorToLineWeight {
String^ get( );
void set(
String^ value
);
}

JScript

function get ColorToLineWeight() : String;
function set ColorToLineWeight(value : String);

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.Converter Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.Converter Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a Converter associated with this image object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Converter() As Converter

C#

Converter Converter {get;}

C++

property Converter^ Converter {
Converter^ get( );
}

JScript

function get Converter() : Converter;

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.Count Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.Count Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of entities in the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Count() As Integer

C#

int Count {get;}

C++

property int Count {
int get( );
}

JScript

function get Count() : int;

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.CurrentLayout Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.CurrentLayout Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the current layout for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CurrentLayout() As Layout

C#

Layout CurrentLayout {get; set;}

C++

property Layout^ CurrentLayout {
Layout^ get( );
void set(
Layout^ value
);
}

JScript

function get CurrentLayout() : Layout;
function set CurrentLayout(value : Layout);

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.DefaultColor Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.DefaultColor Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the default color for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DefaultColor() As UInt32

C#

UInt32 DefaultColor {get; set;}

C++

property UInt32 DefaultColor {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get DefaultColor() : UInt32;
function set DefaultColor(value : UInt32);

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.DimensionsVisible Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.DimensionsVisible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether dimensions in the drawing are visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DimensionsVisible() As Boolean

C#

bool DimensionsVisible {get; set;}

C++

property bool DimensionsVisible {
bool get( );
void set(
bool value
);
}

JScript

function get DimensionsVisible() : boolean;
function set DimensionsVisible(value : boolean);

Property Value

true if the dimensions are visible; otherwise, false. Default value is true.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.DrawMode Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.DrawMode Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets an appearance of colors in the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DrawMode() As TxDXFDrawMode

C#

TxDXFDrawMode DrawMode {get; set;}

C++

property TxDXFDrawMode DrawMode {
TxDXFDrawMode get( );
void set(
TxDXFDrawMode value
);
}

JScript

function get DrawMode() : TxDXFDrawMode;
function set DrawMode(value : TxDXFDrawMode);

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.DrawingBox Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.DrawingBox Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the drawing bounding box.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DrawingBox() As Rect3D

C#

Rect3D DrawingBox {get; set;}

C++

property Rect3D^ DrawingBox {
Rect3D^ get( );
void set(
Rect3D^ value
);
}

JScript

function get DrawingBox() : Rect3D;
function set DrawingBox(value : Rect3D);

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.Empty Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.Empty Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the drawing is empty.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Empty() As Boolean

C#

bool Empty {get;}

C++

property bool Empty {
bool get( );
}

JScript

function get Empty() : boolean;

Property Value

true if the drawing is empty; otherwise, false.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.Extents Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.Extents Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the drawing's extents.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Extents() As Rect3D

C#

Rect3D Extents {get; set;}

C++

property Rect3D^ Extents {
Rect3D^ get( );
void set(
Rect3D^ value
);
}

JScript

function get Extents() : Rect3D;
function set Extents(value : Rect3D);

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.Height Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.Height Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a height of the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Height() As Integer

C#

int Height {get; set;}

C++

property int Height {
int get( );
void set(
int value
);
}

JScript

function get Height() : int;
function set Height(value : int);

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.Is3D Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.Is3D Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the drawing is three-dimensional.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Is3D() As Boolean

C#

bool Is3D {get; set;}

C++

property bool Is3D {
bool get( );
void set(
bool value
);
}

JScript

function get Is3D() : boolean;
function set Is3D(value : boolean);

Property Value

true if the drawing is three-dimensional; otherwise, false.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.IsDraw3DAxes Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.IsDraw3DAxes Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether 3D axes are visible on the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsDraw3DAxes() As Boolean

C#

bool IsDraw3DAxes {get; set;}

C++

property bool IsDraw3DAxes {
bool get( );
void set(
bool value
);
}

JScript

function get IsDraw3DAxes() : boolean;
function set IsDraw3DAxes(value : boolean);

Property Value

true if the 3D axes are visible; otherwise, false.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.IsDrawingRotated Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.IsDrawingRotated Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the drawing is rotated.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsDrawingRotated() As Boolean

C#

bool IsDrawingRotated {get;}

C++

property bool IsDrawingRotated {
bool get( );
}

JScript

function get IsDrawingRotated() : boolean;

Property Value

true if the drawing is rotated; otherwise, false.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.IsLoading Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.IsLoading Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the process of loading the drawing data is active.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsLoading() As Boolean

C#

bool IsLoading {get;}

C++

property bool IsLoading {
bool get( );
}

JScript

function get IsLoading() : boolean;

Property Value

true if the drawing data is loading into this image object; otherwise, false.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.IsPlotting Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.IsPlotting Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether to plot the image or not.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsPlotting() As Boolean

C#

bool IsPlotting {get; set;}

C++

property bool IsPlotting {
bool get( );
void set(
bool value
);
}

JScript

function get IsPlotting() : boolean;
function set IsPlotting(value : boolean);

Property Value

true if the image should be plotted; otherwise, false.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.IsProcessMessages Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.IsProcessMessages Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the messages processing is allowed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsProcessMessages() As Boolean

C#

bool IsProcessMessages {get; set;}

C++

property bool IsProcessMessages {
bool get( );
void set(
bool value
);
}

JScript

function get IsProcessMessages() : boolean;
function set IsProcessMessages(value : boolean);

Property Value

true if the messages processing is allowed; otherwise, false.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.IsShowBackground Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.IsShowBackground Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the backround is displayed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsShowBackground() As Boolean

C#

bool IsShowBackground {get; set;}

C++

property bool IsShowBackground {
bool get( );
void set(
bool value
);
}

JScript

function get IsShowBackground() : boolean;
function set IsShowBackground(value : boolean);

Property Value

true if the backround is displayed; otherwise, false.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.IsShowLineWeight Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.IsShowLineWeight Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether a thickness of lines is determined by the drawing data.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsShowLineWeight() As Boolean

C#

bool IsShowLineWeight {get; set;}

C++

property bool IsShowLineWeight {
bool get( );
void set(
bool value
);
}

JScript

function get IsShowLineWeight() : boolean;
function set IsShowLineWeight(value : boolean);

Property Value

true if a thickness of lines is determined by the drawing data; otherwise, false.

collall Remarks

If this property value is false, a thickness of lines is determined by the NullWidth property.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.IsWithoutBorder Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.IsWithoutBorder Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether to display the drawing without borders.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsWithoutBorder() As Boolean

C#

bool IsWithoutBorder {get; set;}

C++

property bool IsWithoutBorder {
bool get( );
void set(
bool value
);
}

JScript

function get IsWithoutBorder() : boolean;
function set IsWithoutBorder(value : boolean);

Property Value

true if the borders are not displayed; otherwise, false.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.LayoutsCount Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.LayoutsCount Property

 Return to chapter overview

Show / hide the hidden text

Gets the number of layouts in the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property LayoutsCount() As Integer

C#

int LayoutsCount {get;}

C++

property int LayoutsCount {
int get( );
}

JScript

function get LayoutsCount() : int;

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.LineScaled Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.LineScaled Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the line weight is diplayed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineScaled() As Boolean

C#

bool LineScaled {get; set;}

C++

property bool LineScaled {
bool get( );
void set(
bool value
);
}

JScript

function get LineScaled() : boolean;
function set LineScaled(value : boolean);

Property Value

true if the line weight is displayed; otherwise, false.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.LineWeightScale Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.LineWeightScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a scale for line weights.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineWeightScale() As Double

C#

double LineWeightScale {get; set;}

C++

property double LineWeightScale {
double get( );
void set(
double value
);
}

JScript

function get LineWeightScale() : double;
function set LineWeightScale(value : double);

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.Millimetres Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.Millimetres Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Millimetres() As Boolean

C#

bool Millimetres {get; set;}

C++

property bool Millimetres {
bool get( );
void set(
bool value
);
}

JScript

function get Millimetres() : boolean;
function set Millimetres(value : boolean);

Property Value

true if the drawing units are millimeters; false if the drawing units are inches.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.Modified Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.Modified Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the drawing is modified.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Modified() As Boolean

C#

bool Modified {get; set;}

C++

property bool Modified {
bool get( );
void set(
bool value
);
}

JScript

function get Modified() : boolean;
function set Modified(value : boolean);

Property Value

true if the drawing is modified; otherwise, false.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.NullWidth Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.NullWidth Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a thickness for lines which have the zero lineweight.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property NullWidth() As Integer

C#

int NullWidth {get; set;}

C++

property int NullWidth {
int get( );
void set(
int value
);
}

JScript

function get NullWidth() : int;
function set NullWidth(value : int);

Property Value

Line thickness. Default value is 1.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.OwnSource Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.OwnSource Property

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property OwnSource() As Boolean

C#

bool OwnSource {get; set;}

C++

property bool OwnSource {
bool get( );
void set(
bool value
);
}

JScript

function get OwnSource() : boolean;
function set OwnSource(value : boolean);

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.PureExtents Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.PureExtents Property

 Return to chapter overview

Show / hide the hidden text

Gets the drawing's extents excluding the borders.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property PureExtents() As Rect3D

C#

Rect3D PureExtents {get;}

C++

property Rect3D^ PureExtents {
Rect3D^ get( );
}

JScript

function get PureExtents() : Rect3D;

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.ResizeDisproportionateDrawing Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.ResizeDisproportionateDrawing Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether to resize a drawing with disproportionate sizes.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property ResizeDisproportionateDrawing() As Boolean

C#

bool ResizeDisproportionateDrawing {get; set;}

C++

property bool ResizeDisproportionateDrawing {
bool get( );
void set(
bool value
);
}

JScript

function get ResizeDisproportionateDrawing() : boolean;
function set ResizeDisproportionateDrawing(value : boolean);

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.Scale Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.Scale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a 3D point which defines the scale factor.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Scale() As Point3D

C#

Point3D Scale {get;}

C++

property Point3D^ Scale {
Point3D^ get( );
}

JScript

function get Scale() : Point3D;

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.ShowImages Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.ShowImages Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the raster images are displayed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property ShowImages() As Boolean

C#

bool ShowImages {get; set;}

C++

property bool ShowImages {
bool get( );
void set(
bool value
);
}

JScript

function get ShowImages() : boolean;
function set ShowImages(value : boolean);

Property Value

true if the raster images are displayed; overwise, false.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.Stretch Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.Stretch Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the displayed image has to be stretched to fit exactly with the drawing rectangle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Stretch() As Boolean

C#

bool Stretch {get; set;}

C++

property bool Stretch {
bool get( );
void set(
bool value
);
}

JScript

function get Stretch() : boolean;
function set Stretch(value : boolean);

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.TextVisible Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.TextVisible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether texts in the drawing are visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property TextVisible() As Boolean

C#

bool TextVisible {get; set;}

C++

property bool TextVisible {
bool get( );
void set(
bool value
);
}

JScript

function get TextVisible() : boolean;
function set TextVisible(value : boolean);

Property Value

true if the texts are visible; otherwise, false.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.UseWinEllipse Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.UseWinEllipse Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether arcs and circles are drawn by using GDI+ methods without linearization.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property UseWinEllipse() As Boolean

C#

bool UseWinEllipse {get; set;}

C++

property bool UseWinEllipse {
bool get( );
void set(
bool value
);
}

JScript

function get UseWinEllipse() : boolean;
function set UseWinEllipse(value : boolean);

Property Value

true if the GDI+ methods are used for drawing arcs and circles; otherwise, false.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.ViewRectangle Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.ViewRectangle Property

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property ViewRectangle() As Rect3D

C#

Rect3D ViewRectangle {get; set;}

C++

property Rect3D^ ViewRectangle {
Rect3D^ get( );
void set(
Rect3D^ value
);
}

JScript

function get ViewRectangle() : Rect3D;
function set ViewRectangle(value : Rect3D);

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.Width Property

API Reference > CADViewLib Namespace > CGMImage Interface > Properties >

ICGMImage.Width Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a width of the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Width() As Integer

C#

int Width {get; set;}

C++

property int Width {
int get( );
void set(
int value
);
}

JScript

function get Width() : int;
function set Width(value : int);

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


CGMImage Methods

API Reference > CADViewLib Namespace > CGMImage Interface >

CGMImage Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AbsHeight | Returns an absolute height of the CAD drawing. (inherited from ICGMImage ).
Public method | AbsWidth | Returns an absolute width of the CAD drawing. (inherited from ICGMImage ).
Public method | AddScaledDXF | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing. (inherited from ICGMImage ).
Public method | AddScaledDXFEx | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing. (inherited from ICGMImage ).
Public method | AssignImage | Makes a copy of a specified CAD image object and assigns it to this image. (inherited from ICGMImage ).
Public method | CreateImage | Initializes a new CAD image instance. (inherited from ICGMImage ).
Public method | Draw | Draws the CAD image in a specified device context (DC). (inherited from ICGMImage ).
Public method | DrawRect | Draws a specified region of this CAD image in a device context (DC). (inherited from ICGMImage ).
Public method | ExportToMetafile | Exports this CAD image to Windows metafile. (inherited from ICGMImage ).
Public method | FreeImage | Destroys this CAD image object and frees the memory used within the object. (inherited from ICGMImage ).
Public method | GetCADCoords | Returns CAD coordinates for a specified point. (inherited from ICGMImage ).
Public method | GetEntityColor | Returns the color value for a specified entity. (inherited from ICGMImage ).
Public method | GetExtents | Recalculates extents of the CAD image. (inherited from ICGMImage ).
Public method | GetPoint | Gets the on-screen coordinates for a specified CAD point. (inherited from ICGMImage ).
Public method | GetRealImagePoint | Returns CAD coordinates of a specified point considering the drawing's rotation and viewport parameters. (inherited from ICGMImage ).
Public method | HeadVarAsFloat | Returns a value of the DXF header variable as a floating point number. (inherited from ICGMImage ).
Public method | HeadVarAsInteger | Returns a value of the DXF header variable as an integer. (inherited from ICGMImage ).
Public method | HeadVarAsstring | Returns a value of the DXF header variable as a string. (inherited from ICGMImage ).
Public method | LoadFromClipboardFormat | Loads data from the clipboard. (inherited from ICGMImage ).
Public method | LoadFromFile | Loads a CAD drawing from file. (inherited from ICGMImage ).
Public method | LoadFromIStream | Loads a CAD drawing from stream. (inherited from ICGMImage ).
Public method | LoadFromStream | Loads a CAD drawing from stream. (inherited from ICGMImage ).
Public method | RefreshCurrentLayout | Refreshes the current layout. (inherited from ICGMImage ).
Public method | ResetDrawingBox | Switches off the drawing box. (inherited from ICGMImage ).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from ICGMImage ).
Public method | RotToView | Rotates the drawing to a specified view. (inherited from ICGMImage ).
Public method | Rotate | Rotates the drawing. (inherited from ICGMImage ).
Public method | SaveToClipboardFormat | Copies the drawing to the clipboard in a specified format. (inherited from ICGMImage ).
Public method | SaveToFile | Saves the drawing to a specified file. (inherited from ICGMImage ).
Public method | SaveToIStream | Writes the drawing data to a specified stream. (inherited from ICGMImage ).
Public method | SaveToStream | Writes the drawing data to a specified stream. (inherited from ICGMImage ).
Public method | SetClippingRect | Sets a clipping rectangle for the drawing. (inherited from ICGMImage ).
Public method | SetExtentsParameters | Changes the drawing extents. (inherited from ICGMImage ).
Public method | StopLoading | Terminates loading of the drawing data. (inherited from ICGMImage ).
Public method | get_Blocks | Retrieves a BLOCK object by its index. (inherited from ICGMImage ).
Public method | get_Entities | Retrieves an entity by its index. (inherited from ICGMImage ).
Public method | get_Items | (inherited from ICGMImage ).
Public method | get_Layouts | Retrieves a layout by its index. (inherited from ICGMImage ).

Top

collall See Also

Reference

CGMImage Interface


ICGMImage.AbsHeight Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.AbsHeight Method

 Return to chapter overview

Show / hide the hidden text

Returns an absolute height of the CAD drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function AbsHeight() As Double

C#

override double AbsHeight()

C++

double AbsHeight()

JScript

function AbsHeight() : double;

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.AbsWidth Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.AbsWidth Method

 Return to chapter overview

Show / hide the hidden text

Returns an absolute width of the CAD drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function AbsWidth() As Double

C#

override double AbsWidth()

C++

double AbsWidth()

JScript

function AbsWidth() : double;

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.AddScaledDXF Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.AddScaledDXF Method

 Return to chapter overview

Show / hide the hidden text

Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AddScaledDXF( _
ByVal ACADFile As DXFImage, _
ByVal AName As String, _
ByVal APos As Point3D, _
ByVal AScale As Point3D, _
ByVal Rotation As Single _
)

C#

override void AddScaledDXF(
DXFImageACADFile,
stringAName,
Point3DAPos,
Point3DAScale,
floatRotation
)

C++

void AddScaledDXF(
DXFImage^ ACADFile,
String^ AName,
Point3D^ APos,
Point3D^ AScale,
floatRotation
)

JScript

function AddScaledDXF(
ACADFile : DXFImage,
AName : String,
APos : Point3D,
AScale : Point3D,
Rotation : float
);

Parameters

ACADFile

DXF image which defines the external reference.

AName

User-defined name for the XREF.

APos

The insertion point.

AScale

3D point which determines the scale factor.

Rotation

XREF rotation angle.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.AddScaledDXFEx Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.AddScaledDXFEx Method

 Return to chapter overview

Show / hide the hidden text

Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function AddScaledDXFEx( _
ByVal ACADFile As DXFImage, _
ByVal AName As String, _
ByVal APos As Point3D, _
ByVal AScale As Point3D, _
ByVal Rotation As Single _
) As Insert

C#

override Insert AddScaledDXFEx(
DXFImage ACADFile,
stringAName,
Point3DAPos,
Point3DAScale,
floatRotation
)

C++

Insert^ AddScaledDXFEx(
DXFImage^ ACADFile,
String^ AName,
Point3D^ APos,
Point3D^ AScale,
floatRotation
)

JScript

function AddScaledDXFEx(
ACADFile : DXFImage,
AName : String,
APos : Point3D,
AScale : Point3D,
Rotation : float
) : Insert;

Parameters

ACADFile

DXF image which defines the external reference.

AName

User-defined name for the XREF.

APos

The insertion point.

AScale

3D point which determines the scale factor.

Rotation

XREF rotation angle.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.AssignImage Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.AssignImage Method

 Return to chapter overview

Show / hide the hidden text

Makes a copy of a specified CAD image object and assigns it to this image.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AssignImage( _
ByVal Source As Object _
)

C#

override void AssignImage(
objectSource
)

C++

void AssignImage(
object^ Source
)

JScript

function AssignImage(
Source : object
);

Parameters

Source

The source CAD image object which will be copied.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.CreateImage Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.CreateImage Method

 Return to chapter overview

Show / hide the hidden text

Initializes a new CAD image instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub CreateImage()

C#

override void CreateImage()

C++

void CreateImage()

JScript

function CreateImage();

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.Draw Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.Draw Method

 Return to chapter overview

Show / hide the hidden text

Draws the CAD image in a specified device context (DC).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub Draw( _
ByVal DC As Integer, _
ByVal Rect As Rect2D _
)

C#

override void Draw(
intDC,
Rect2DRect
)

C++

void Draw(
intDC,
Rect2D^ Rect
)

JScript

function Draw(
DC : int,
Rect : Rect2D
);

Parameters

DC

Handle to the DC.

Rect

Rectangle which defines the drawing area in the DC.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.DrawRect Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.DrawRect Method

 Return to chapter overview

Show / hide the hidden text

Draws a specified region of this CAD image in a device context (DC).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub DrawRect( _
ByVal DC As Integer, _
ByVal SourceRect As Rect3D, _
ByVal DestRect As Rect2D _
)

C#

override void DrawRect(
intDC,
Rect3DSourceRect,
Rect2DDestRect
)

C++

void DrawRect(
intDC,
Rect3D^ SourceRect,
Rect2D^ DestRect
)

JScript

function DrawRect(
DC : int,
SourceRect : Rect3D,
DestRect : Rect2D
);

Parameters

DC

Handle to the DC.

SourceRect

The region which will be drawn in the DC.

DestRect

Rectangle which defines the drawing area in the DC.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.ExportToMetafile Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.ExportToMetafile Method

 Return to chapter overview

Show / hide the hidden text

Exports this CAD image to Windows metafile.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub ExportToMetafile( _
ByVal FileName As String, _
ByVal AWidth As Integer, _
ByVal AHeight As Integer _
)

C#

override void ExportToMetafile(
stringFileName,
intAWidth,
intAHeight
)

C++

void ExportToMetafile(
String^ FileName,
intAWidth,
intAHeight
)

JScript

function ExportToMetafile(
FileName : String,
AWidth : int,
AHeight : int
);

Parameters

FileName

Path to the output metafile.

AWidth

Width of the output metafile.

AHeight

Height of the output metafile.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.FreeImage Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.FreeImage Method

 Return to chapter overview

Show / hide the hidden text

Destroys this CAD image object and frees the memory used within the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub FreeImage()

C#

override void FreeImage()

C++

void FreeImage()

JScript

function FreeImage();

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.GetCADCoords Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.GetCADCoords Method

 Return to chapter overview

Show / hide the hidden text

Returns CAD coordinates for a specified point.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetCADCoords( _
ByVal AXScaled As Double, _
ByVal AYScaled As Double _
) As Point3D

C#

override Point3D GetCADCoords(
doubleAXScaled,
doubleAYScaled
)

C++

Point3D^ GetCADCoords(
doubleAXScaled,
doubleAYScaled
)

JScript

function GetCADCoords(
AXScaled : double,
AYScaled : double
) : Point3D;

Parameters

AXScaled

Ratio between the x-coordinate and the drawing's width.

AYScaled

Ratio between the y-coordinate and the drawing's height.

collall Remarks

The z-coordinate of the returned point is equal 0.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.GetEntityColor Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.GetEntityColor Method

 Return to chapter overview

Show / hide the hidden text

Returns the color value for a specified entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetEntityColor( _
ByVal AEntity As Entity, _
ByVal AInsert As Insert _
) As UInt32

C#

override UInt32 GetEntityColor(
EntityAEntity,
InsertAInsert
)

C++

UInt32 GetEntityColor(
Entity^ AEntity,
Insert^ AInsert
)

JScript

function GetEntityColor(
AEntity : Entity,
AInsert : Insert
) : UInt32;

Parameters

AEntity

The entity whose color is retrieved.

AInsert

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.GetExtents Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.GetExtents Method

 Return to chapter overview

Show / hide the hidden text

Recalculates extents of the CAD image.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub GetExtents()

C#

override void GetExtents()

C++

void GetExtents()

JScript

function GetExtents();

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.GetPoint Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.GetPoint Method

 Return to chapter overview

Show / hide the hidden text

Gets the on-screen coordinates for a specified CAD point.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetPoint( _
ByVal P As Point3D _
) As Point2D

C#

override Point2D GetPoint(
Point3D P
)

C++

Point2D^ GetPoint(
Point3D^ P
)

JScript

function GetPoint(
P : Point3D
) : Point2D;

Parameters

P

CAD point coordinates in the 3D space.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.GetRealImagePoint Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.GetRealImagePoint Method

 Return to chapter overview

Show / hide the hidden text

Returns CAD coordinates of a specified point considering the drawing's rotation and viewport parameters.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetRealImagePoint( _
ByVal P As Point3D _
) As Point3D

C#

override Point3D GetRealImagePoint(
Point3D P
)

C++

Point3D^ GetRealImagePoint(
Point3D^ P
)

JScript

function GetRealImagePoint(
P : Point3D
) : Point3D;

Parameters

P

CAD point in the 3D space.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.HeadVarAsFloat Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.HeadVarAsFloat Method

 Return to chapter overview

Show / hide the hidden text

Returns a value of the DXF header variable as a floating point number.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function HeadVarAsFloat( _
ByVal AName As String, _
ByVal ACode As Integer _
) As Double

C#

override double HeadVarAsFloat(
stringAName,
intACode
)

C++

double HeadVarAsFloat(
String^ AName,
intACode
)

JScript

function HeadVarAsFloat(
AName : String,
ACode : int
) : double;

Parameters

AName

The header variable name.

ACode

Group code associated with the variable's value.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.HeadVarAsInteger Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.HeadVarAsInteger Method

 Return to chapter overview

Show / hide the hidden text

Returns a value of the DXF header variable as an integer.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function HeadVarAsInteger( _
ByVal AName As String, _
ByVal ACode As Integer _
) As Integer

C#

override int HeadVarAsInteger(
stringAName,
intACode
)

C++

int HeadVarAsInteger(
String^ AName,
intACode
)

JScript

function HeadVarAsInteger(
AName : String,
ACode : int
) : int;

Parameters

AName

The header variable name.

ACode

Group code associated with the variable's value.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.HeadVarAsstring Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.HeadVarAsstring Method

 Return to chapter overview

Show / hide the hidden text

Returns a value of the DXF header variable as a string.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function HeadVarAsstring( _
ByVal AName As String, _
ByVal ACode As Integer _
) As String

C#

override string HeadVarAsstring(
stringAName,
intACode
)

C++

String^ HeadVarAsstring(
String^ AName,
intACode
)

JScript

function HeadVarAsstring(
AName : String,
ACode : int
) : String;

Parameters

AName

The header variable name.

ACode

Group code associated with the variable's value.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.LoadFromClipboardFormat Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.LoadFromClipboardFormat Method

 Return to chapter overview

Show / hide the hidden text

Loads data from the clipboard.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub LoadFromClipboardFormat( _
ByVal Fmt As UInt16, _
ByVal Data As Integer, _
ByVal Pal As Integer _
)

C#

override void LoadFromClipboardFormat(
UInt16Fmt,
intData,
intPal
)

C++

void LoadFromClipboardFormat(
UInt16Fmt,
intData,
intPal
)

JScript

function LoadFromClipboardFormat(
Fmt : UInt16,
Data : int,
Pal : int
);

Parameters

Fmt

Data

Pal

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.LoadFromFile Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.LoadFromFile Method

 Return to chapter overview

Show / hide the hidden text

Loads a CAD drawing from file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub LoadFromFile( _
ByVal FileName As String _
)

C#

override void LoadFromFile(
stringFileName
)

C++

void LoadFromFile(
String^ FileName
)

JScript

function LoadFromFile(
FileName : String
);

Parameters

FileName

Path to the drawing file.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.LoadFromIStream Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.LoadFromIStream Method

 Return to chapter overview

Show / hide the hidden text

Loads a CAD drawing from stream.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub LoadFromIStream( _
ByVal Stream As Object _
)

C#

override void LoadFromIStream(
objectStream
)

C++

void LoadFromIStream(
object^ Stream
)

JScript

function LoadFromIStream(
Stream : object
);

Parameters

Stream

Stream which contains the CAD drawing data.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.LoadFromStream Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.LoadFromStream Method

 Return to chapter overview

Show / hide the hidden text

Loads a CAD drawing from stream.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub LoadFromStream( _
ByVal hStream As Integer _
)

C#

override void LoadFromStream(
inthStream
)

C++

void LoadFromStream(
inthStream
)

JScript

function LoadFromStream(
hStream : int
);

Parameters

hStream

Handle to the stream which contains the drawing data.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.RefreshCurrentLayout Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.RefreshCurrentLayout Method

 Return to chapter overview

Show / hide the hidden text

Refreshes the current layout.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub RefreshCurrentLayout()

C#

override void RefreshCurrentLayout()

C++

void RefreshCurrentLayout()

JScript

function RefreshCurrentLayout();

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.ResetDrawingBox Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.ResetDrawingBox Method

 Return to chapter overview

Show / hide the hidden text

Switches off the drawing box.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub ResetDrawingBox()

C#

override void ResetDrawingBox()

C++

void ResetDrawingBox()

JScript

function ResetDrawingBox();

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.RotDefault Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.RotDefault Method

 Return to chapter overview

Show / hide the hidden text

Rotates the drawing to the default view.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub RotDefault()

C#

override void RotDefault()

C++

void RotDefault()

JScript

function RotDefault();

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.RotToView Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.RotToView Method

 Return to chapter overview

Show / hide the hidden text

Rotates the drawing to a specified view.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub RotToView( _
ByVal A3DView As TxDXFViewDirection _
)

C#

override void RotToView(
TxDXFViewDirectionA3DView
)

C++

void RotToView(
TxDXFViewDirectionA3DView
)

JScript

function RotToView(
A3DView : TxDXFViewDirection
);

Parameters

A3DView

One of the orthogonal or isometric views.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.Rotate Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.Rotate Method

 Return to chapter overview

Show / hide the hidden text

Rotates the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub Rotate( _
ByVal Axis As TxAxes, _
ByVal Angle As Double _
)

C#

override void Rotate(
TxAxesAxis,
doubleAngle
)

C++

void Rotate(
TxAxesAxis,
doubleAngle
)

JScript

function Rotate(
Axis : TxAxes,
Angle : double
);

Parameters

Axis

Rotation axis.

Angle

Rotation angle (measured in degrees).

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.SaveToClipboardFormat Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.SaveToClipboardFormat Method

 Return to chapter overview

Show / hide the hidden text

Copies the drawing to the clipboard in a specified format.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SaveToClipboardFormat( _
ByRef Fmt As UInt16, _
ByRef Data As Integer, _
ByRef Pal As Integer _
)

C#

override void SaveToClipboardFormat(
ref UInt16Fmt,
ref intData,
ref intPal
)

C++

void SaveToClipboardFormat(
UInt16& Fmt,
int& Data,
int& Pal
)

JScript

function SaveToClipboardFormat(
Fmt : UInt16,
Data : int,
Pal : int
);

Parameters

Fmt

Clipboard format.

Data

Pal

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.SaveToFile Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.SaveToFile Method

 Return to chapter overview

Show / hide the hidden text

Saves the drawing to a specified file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SaveToFile( _
ByVal FileName As String _
)

C#

override void SaveToFile(
stringFileName
)

C++

void SaveToFile(
String^ FileName
)

JScript

function SaveToFile(
FileName : String
);

Parameters

FileName

Path to the output file.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.SaveToIStream Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.SaveToIStream Method

 Return to chapter overview

Show / hide the hidden text

Writes the drawing data to a specified stream.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SaveToIStream( _
ByVal Stream As Object _
)

C#

override void SaveToIStream(
objectStream
)

C++

void SaveToIStream(
object^ Stream
)

JScript

function SaveToIStream(
Stream : object
);

Parameters

Stream

Stream where the drawing data is written.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.SaveToStream Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.SaveToStream Method

 Return to chapter overview

Show / hide the hidden text

Writes the drawing data to a specified stream.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SaveToStream( _
ByVal Stream As Integer _
)

C#

override void SaveToStream(
intStream
)

C++

void SaveToStream(
intStream
)

JScript

function SaveToStream(
Stream : int
);

Parameters

Stream

Stream where the drawing data will be written.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.SetClippingRect Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.SetClippingRect Method

 Return to chapter overview

Show / hide the hidden text

Sets a clipping rectangle for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetClippingRect( _
ByVal Value As Rect3D _
)

C#

override void SetClippingRect(
Rect3DValue
)

C++

void SetClippingRect(
Rect3D^ Value
)

JScript

function SetClippingRect(
Value : Rect3D
);

Parameters

Value

The clipping rectangle area.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.SetExtentsParameters Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.SetExtentsParameters Method

 Return to chapter overview

Show / hide the hidden text

Changes the drawing extents.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetExtentsParameters( _
ByVal ARect As Rect3D, _
ByVal AIs3DExtents As Boolean _
)

C#

override void SetExtentsParameters(
Rect3DARect,
boolAIs3DExtents
)

C++

void SetExtentsParameters(
Rect3D^ ARect,
boolAIs3DExtents
)

JScript

function SetExtentsParameters(
ARect : Rect3D,
AIs3DExtents : boolean
);

Parameters

ARect

The parallelepiped which defines the extents.

AIs3DExtents

If set to true, then the extents are 3D; otherwise, the extents are 2D.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.StopLoading Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.StopLoading Method

 Return to chapter overview

Show / hide the hidden text

Terminates loading of the drawing data.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub StopLoading()

C#

override void StopLoading()

C++

void StopLoading()

JScript

function StopLoading();

collall Remarks

The portion of the drawing data which was loaded can be displayed in the control.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.get_Blocks Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.get_Blocks Method

 Return to chapter overview

Show / hide the hidden text

Retrieves a BLOCK object by its index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Blocks( _
ByVal Index As Integer _
) As Block

C#

override Block get_Blocks(
intIndex
)

C++

Block^ get_Blocks(
intIndex
)

JScript

function get_Blocks(
Index : int
) : Block;

Parameters

Index

Index of the block.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.get_Entities Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.get_Entities Method

 Return to chapter overview

Show / hide the hidden text

Retrieves an entity by its index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Entities( _
ByVal Index As Integer _
) As Entity

C#

override Entity get_Entities(
intIndex
)

C++

Entity^ get_Entities(
intIndex
)

JScript

function get_Entities(
Index : int
) : Entity;

Parameters

Index

Index of the entity.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.get_Items Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.get_Items Method

 Return to chapter overview

Show / hide the hidden text

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Items( _
ByVal Index As Integer _
) As DXFImage

C#

override DXFImage get_Items(
intIndex
)

C++

DXFImage^ get_Items(
intIndex
)

JScript

function get_Items(
Index : int
) : DXFImage;

Parameters

Index

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


ICGMImage.get_Layouts Method

API Reference > CADViewLib Namespace > CGMImage Interface > Methods >

ICGMImage.get_Layouts Method

 Return to chapter overview

Show / hide the hidden text

Retrieves a layout by its index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Layouts( _
ByVal Index As Integer _
) As Layout

C#

override Layout get_Layouts(
intIndex
)

C++

Layout^ get_Layouts(
intIndex
)

JScript

function get_Layouts(
Index : int
) : Layout;

Parameters

Index

Index of the layout.

collall See Also

Reference

ICGMImage Interface
ICGMImage ICGMImage Members


Circle Interface

API Reference > CADViewLib Namespace >

Circle Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to CIRCLE entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface Circle
Inherits ICircle, _
IEntityEvents_Event

C#

public interface Circle : ICircle,
IEntityEvents_Event

C++

public interface class Circle : public ICircle^,
public IEntityEvents_Event^

JScript

public interface Circle
implements ICircle,
IEntityEvents_Event

collall See Also

Reference

Circle Members


Circle Members

API Reference > CADViewLib Namespace > Circle Interface >

Circle Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to CIRCLE entities.

The following tables list the members exposed by the Circle type.

collall Public Properties

 | Name | Description
Public property | ArrowsCount | Gets a quantity of points that form an arrow. (inherited from ICircle ).
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from ICircle ).
Public property | CADHandle | Gets or sets the object handle. (inherited from ICircle ).
Public property | Closed | Gets or sets a value indicating whether this polyline is closed. (inherited from ICircle ).
Public property | Color | Gets or sets a color of the object. (inherited from ICircle ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from ICircle ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from ICircle ).
Public property | DottedPointsCount | Gets a quantity of points that determine the dots and dashes for a polyline with non-solid line type. (inherited from ICircle ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from ICircle ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from ICircle ).
Public property | Flags | Gets or sets a bit-coded flag indicating the polyline type. (inherited from ICircle ).
Public property | GlobalWidth | Gets or sets a global width for this polyline. (inherited from ICircle ).
Public property | IsMeshMClosed | Gets a value indicating whether the polygon mesh is closed in the M direction. (inherited from ICircle ).
Public property | IsMeshNClosed | Gets a value indicating whether the polygon mesh is closed in the N direction. (inherited from ICircle ).
Public property | IsPolyFaceMesh | Gets a value indicating whether this polyline is a polyface mesh. (inherited from ICircle ).
Public property | IsPolyZThickness | Gets a value indicating whether the polyline has thickness measured along the axis Z. (inherited from ICircle ).
Public property | IsPolygonMesh | Gets a value indicating whether this polyline is a polygon mesh. (inherited from ICircle ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from ICircle ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from ICircle ).
Public property | MeshM | Gets or sets a number of vertices for the polygon mesh in the M direction. (inherited from ICircle ).
Public property | MeshN | Gets or sets a number of vertices for the polygon mesh in the N direction. (inherited from ICircle ).
Public property | Name | Gets or sets a name of this object. (inherited from ICircle ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from ICircle ).
Public property | PenLine | Gets properties of the pen used for drawing the object. (inherited from ICircle ).
Public property | Point | Gets or sets the center point. (inherited from ICircle ).
Public property | PointsCount | Gets a number of the polyline points. (inherited from ICircle ).
Public property | PolyFaceVertexIndexesCount | Gets a quantity of indices which specify the order of traversing vertices in the polyface mesh. (inherited from ICircle ).
Public property | Radius | Gets or sets a radius of the circle/ellipse/arc. (inherited from ICircle ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from ICircle ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from ICircle ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from ICircle ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from ICircle ).

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from ICircle ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from ICircle ).
Public method | CreateEntity | Initializes a new object instance. (inherited from ICircle ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from ICircle ).
Public method | EntName | Returns a name of the entity. (inherited from ICircle ).
Public method | FreeEntity | Destroys the object instance. (inherited from ICircle ).
Public method | GetArea | Returns the area bounded by a closed polygon. (inherited from ICircle ).
Public method | GetBoxPoints | For internal use. (inherited from ICircle ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from ICircle ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from ICircle ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from ICircle ).
Public method | RemoveEntity | Removes a specified entity. (inherited from ICircle ).
Public method | SetLType | Sets a line type for this object. (inherited from ICircle ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from ICircle ).
Public method | get_Arrows | Returns a point of the arrowhead. (inherited from ICircle ).
Public method | get_DottedPoints | Returns coordinates of a point in the points array that determines dots and dashes for a non-solid line type. (inherited from ICircle ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from ICircle ).
Public method | get_Points | Returns coordinates of a point in the points array. (inherited from ICircle ).
Public method | get_PolyFaceVertexIndexes | Returns a value which indicates an index of the polyface mesh vertex. (inherited from ICircle ).
Public method | set_Arrows | Modifies a point of the arrowhead at the given index. (inherited from ICircle ).

Top

collall See Also

Reference

Circle Interface


Circle Properties

API Reference > CADViewLib Namespace > Circle Interface >

Circle Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | ArrowsCount | Gets a quantity of points that form an arrow. (inherited from ICircle ).
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from ICircle ).
Public property | CADHandle | Gets or sets the object handle. (inherited from ICircle ).
Public property | Closed | Gets or sets a value indicating whether this polyline is closed. (inherited from ICircle ).
Public property | Color | Gets or sets a color of the object. (inherited from ICircle ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from ICircle ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from ICircle ).
Public property | DottedPointsCount | Gets a quantity of points that determine the dots and dashes for a polyline with non-solid line type. (inherited from ICircle ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from ICircle ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from ICircle ).
Public property | Flags | Gets or sets a bit-coded flag indicating the polyline type. (inherited from ICircle ).
Public property | GlobalWidth | Gets or sets a global width for this polyline. (inherited from ICircle ).
Public property | IsMeshMClosed | Gets a value indicating whether the polygon mesh is closed in the M direction. (inherited from ICircle ).
Public property | IsMeshNClosed | Gets a value indicating whether the polygon mesh is closed in the N direction. (inherited from ICircle ).
Public property | IsPolyFaceMesh | Gets a value indicating whether this polyline is a polyface mesh. (inherited from ICircle ).
Public property | IsPolyZThickness | Gets a value indicating whether the polyline has thickness measured along the axis Z. (inherited from ICircle ).
Public property | IsPolygonMesh | Gets a value indicating whether this polyline is a polygon mesh. (inherited from ICircle ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from ICircle ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from ICircle ).
Public property | MeshM | Gets or sets a number of vertices for the polygon mesh in the M direction. (inherited from ICircle ).
Public property | MeshN | Gets or sets a number of vertices for the polygon mesh in the N direction. (inherited from ICircle ).
Public property | Name | Gets or sets a name of this object. (inherited from ICircle ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from ICircle ).
Public property | PenLine | Gets properties of the pen used for drawing the object. (inherited from ICircle ).
Public property | Point | Gets or sets the center point. (inherited from ICircle ).
Public property | PointsCount | Gets a number of the polyline points. (inherited from ICircle ).
Public property | PolyFaceVertexIndexesCount | Gets a quantity of indices which specify the order of traversing vertices in the polyface mesh. (inherited from ICircle ).
Public property | Radius | Gets or sets a radius of the circle/ellipse/arc. (inherited from ICircle ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from ICircle ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from ICircle ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from ICircle ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from ICircle ).

Top

collall See Also

Reference

Circle Interface


ICircle.ArrowsCount Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.ArrowsCount Property

 Return to chapter overview

Show / hide the hidden text

Gets a quantity of points that form an arrow.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property ArrowsCount() As Integer

C#

int ArrowsCount {get;}

C++

property int ArrowsCount {
int get( );
}

JScript

function get ArrowsCount() : int;

Property Value

An Integer type value indicating a quantity of points that form an arrow.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.Box Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.Box Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the bounding parallelepiped for the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Box() As Rect3D

C#

Rect3D Box {get;}

C++

property Rect3D^ Box {
Rect3D^ get( );
}

JScript

function get Box() : Rect3D;

Property Value

The parallelepiped which encloses the object.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.CADHandle Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.CADHandle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the object handle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CADHandle() As UInt64

C#

UInt64 CADHandle {get; set;}

C++

property UInt64 CADHandle {
UInt64 get( );
void set(
UInt64 value
);
}

JScript

function get CADHandle() : UInt64;
function set CADHandle(value : UInt64);

Property Value

Number that uniquely identifies the object in a CAD drawing.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.Closed Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.Closed Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this polyline is closed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Closed() As Boolean

C#

bool Closed {get; set;}

C++

property bool Closed {
bool get( );
void set(
bool value
);
}

JScript

function get Closed() : boolean;
function set Closed(value : boolean);

Property Value

true if the polyline is closed; otherwise, false

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.Color Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.Color Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a color of the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Color() As UInt32

C#

UInt32 Color {get; set;}

C++

property UInt32 Color {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get Color() : UInt32;
function set Color(value : UInt32);

Property Value

An insigned integer value which defines the object's color.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.Converter Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.Converter Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a Converter instance associated with the CAD image to which this object belongs.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Converter() As Converter

C#

Converter Converter {get;}

C++

property Converter^ Converter {
Converter^ get( );
}

JScript

function get Converter() : Converter;

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.Count Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.Count Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of objects contained within the given object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Count() As Integer

C#

int Count {get;}

C++

property int Count {
int get( );
}

JScript

function get Count() : int;

Property Value

An Integer value indicating a number of objects contained within the given object.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.DottedPointsCount Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.DottedPointsCount Property

 Return to chapter overview

Show / hide the hidden text

Gets a quantity of points that determine the dots and dashes for a polyline with non-solid line type.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property DottedPointsCount() As Integer

C#

int DottedPointsCount {get;}

C++

property int DottedPointsCount {
int get( );
}

JScript

function get DottedPointsCount() : int;

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.EntID Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.EntID Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the entity type ID for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property EntID() As TEntityID

C#

TEntityID EntID {get; set;}

C++

property TEntityID EntID {
TEntityID get( );
void set(
TEntityID value
);
}

JScript

function get EntID() : TEntityID;
function set EntID(value : TEntityID);

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.Extrusion Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.Extrusion Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the extrusion direction vector for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Extrusion() As Point3D

C#

Point3D Extrusion {get; set;}

C++

property Point3D^ Extrusion {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Extrusion() : Point3D;
function set Extrusion(value : Point3D);

Property Value

The 3D point which defines the extrusion direction vector.

collall Remarks

The extrusion direction is the normal vector of the plane which contains the entity and it is applied to the entity base point. The default extrusion direction value is (0, 0, 1).

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.Flags Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.Flags Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a bit-coded flag indicating the polyline type.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Flags() As Integer

C#

int Flags {get; set;}

C++

property int Flags {
int get( );
void set(
int value
);
}

JScript

function get Flags() : int;
function set Flags(value : int);

Property Value

0 = Default value
1 = This is a closed polyline (or a polygon mesh closed in the M direction)
2 = Curve-fit vertices have been added
4 = Spline-fit vertices have been added
8 = This is a 3D polyline
16 = This is a 3D polygon mesh
32 = The polygon mesh is closed in the N direction
64 = The polyline is a polyface mesh
128 = The linetype pattern is generated continuously around the vertices of this polyline

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.GlobalWidth Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.GlobalWidth Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a global width for this polyline.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property GlobalWidth() As Single

C#

float GlobalWidth {get; set;}

C++

property float GlobalWidth {
float get( );
void set(
float value
);
}

JScript

function get GlobalWidth() : float;
function set GlobalWidth(value : float);

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.IsMeshMClosed Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.IsMeshMClosed Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the polygon mesh is closed in the M direction.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsMeshMClosed() As Boolean

C#

bool IsMeshMClosed {get;}

C++

property bool IsMeshMClosed {
bool get( );
}

JScript

function get IsMeshMClosed() : boolean;

Property Value

true if the polygon mesh is closed in the M direction.; otherwise, false.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.IsMeshNClosed Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.IsMeshNClosed Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the polygon mesh is closed in the N direction.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsMeshNClosed() As Boolean

C#

bool IsMeshNClosed {get;}

C++

property bool IsMeshNClosed {
bool get( );
}

JScript

function get IsMeshNClosed() : boolean;

Property Value

true if the polygon mesh is closed in the N direction.; otherwise, false.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.IsPolyFaceMesh Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.IsPolyFaceMesh Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether this polyline is a polyface mesh.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsPolyFaceMesh() As Boolean

C#

bool IsPolyFaceMesh {get;}

C++

property bool IsPolyFaceMesh {
bool get( );
}

JScript

function get IsPolyFaceMesh() : boolean;

Property Value

true if the polyline is a polyface mesh; otherwise, false.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.IsPolyZThickness Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.IsPolyZThickness Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the polyline has thickness measured along the axis Z.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsPolyZThickness() As Boolean

C#

bool IsPolyZThickness {get;}

C++

property bool IsPolyZThickness {
bool get( );
}

JScript

function get IsPolyZThickness() : boolean;

Property Value

true if the polyline has thickness measured along the axis Z; otherwise, false.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.IsPolygonMesh Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.IsPolygonMesh Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether this polyline is a polygon mesh.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsPolygonMesh() As Boolean

C#

bool IsPolygonMesh {get;}

C++

property bool IsPolygonMesh {
bool get( );
}

JScript

function get IsPolygonMesh() : boolean;

Property Value

true if the polyline is a polygon mesh; otherwise, false.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.Layer Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.Layer Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a layer containing this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Layer() As Layer

C#

Layer Layer {get; set;}

C++

property Layer^ Layer {
Layer^ get( );
void set(
Layer^ value
);
}

JScript

function get Layer() : Layer;
function set Layer(value : Layer);

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.LineTypeScale Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.LineTypeScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a quantity of line type elements per unit of its length.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineTypeScale() As Single

C#

float LineTypeScale {get; set;}

C++

property float LineTypeScale {
float get( );
void set(
float value
);
}

JScript

function get LineTypeScale() : float;
function set LineTypeScale(value : float);

Property Value

The quantity of linetype elements per unit of its length.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.MeshM Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.MeshM Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a number of vertices for the polygon mesh in the M direction.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property MeshM() As Integer

C#

int MeshM {get; set;}

C++

property int MeshM {
int get( );
void set(
int value
);
}

JScript

function get MeshM() : int;
function set MeshM(value : int);

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.MeshN Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.MeshN Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a number of vertices for the polygon mesh in the N direction.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property MeshN() As Integer

C#

int MeshN {get; set;}

C++

property int MeshN {
int get( );
void set(
int value
);
}

JScript

function get MeshN() : int;
function set MeshN(value : int);

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.Name Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.Name Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Name() As String

C#

string Name {get; set;}

C++

property String^ Name {
String^ get( );
void set(
String^ value
);
}

JScript

function get Name() : String;
function set Name(value : String);

Property Value

String containing the object name.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.PaperSpace Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.PaperSpace Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is located in Paper space.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PaperSpace() As Integer

C#

int PaperSpace {get; set;}

C++

property int PaperSpace {
int get( );
void set(
int value
);
}

JScript

function get PaperSpace() : int;
function set PaperSpace(value : int);

Property Value

0 - the object is located in Model space, 1 - in Paper space.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.PenLine Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.PenLine Property

 Return to chapter overview

Show / hide the hidden text

Gets properties of the pen used for drawing the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property PenLine() As CADLine

C#

CADLine PenLine {get;}

C++

property CADLine^ PenLine {
CADLine^ get( );
}

JScript

function get PenLine() : CADLine;

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.Point Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.Point Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the center point.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Point() As Point3D

C#

Point3D Point {get; set;}

C++

property Point3D^ Point {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Point() : Point3D;
function set Point(value : Point3D);

Property Value

Point3D value which represents the center point.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.PointsCount Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.PointsCount Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of the polyline points.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property PointsCount() As Integer

C#

int PointsCount {get;}

C++

property int PointsCount {
int get( );
}

JScript

function get PointsCount() : int;

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.PolyFaceVertexIndexesCount Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.PolyFaceVertexIndexesCount Property

 Return to chapter overview

Show / hide the hidden text

Gets a quantity of indices which specify the order of traversing vertices in the polyface mesh.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property PolyFaceVertexIndexesCount() As Integer

C#

int PolyFaceVertexIndexesCount {get;}

C++

property int PolyFaceVertexIndexesCount {
int get( );
}

JScript

function get PolyFaceVertexIndexesCount() : int;

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.Radius Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.Radius Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a radius of the circle/ellipse/arc.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Radius() As Double

C#

double Radius {get; set;}

C++

property double Radius {
double get( );
void set(
double value
);
}

JScript

function get Radius() : double;
function set Radius(value : double);

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.SrcEnd Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.SrcEnd Property

 Return to chapter overview

Show / hide the hidden text

Indicates the end of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcEnd() As String

C#

string SrcEnd {get; set;}

C++

property String^ SrcEnd {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcEnd() : String;
function set SrcEnd(value : String);

Property Value

A String value indicating the end of the record which represents this object in a drawing file.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.SrcStart Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.SrcStart Property

 Return to chapter overview

Show / hide the hidden text

Indicates the beginning of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcStart() As String

C#

string SrcStart {get; set;}

C++

property String^ SrcStart {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcStart() : String;
function set SrcStart(value : String);

Property Value

A String value indicating the beginning of the record which represents this object in a drawing file.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.Visibility Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.Visibility Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visibility() As Boolean

C#

bool Visibility {get; set;}

C++

property bool Visibility {
bool get( );
void set(
bool value
);
}

JScript

function get Visibility() : boolean;
function set Visibility(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.Visible Property

API Reference > CADViewLib Namespace > Circle Interface > Properties >

ICircle.Visible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visible() As Boolean

C#

bool Visible {get; set;}

C++

property bool Visible {
bool get( );
void set(
bool value
);
}

JScript

function get Visible() : boolean;
function set Visible(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


Circle Methods

API Reference > CADViewLib Namespace > Circle Interface >

Circle Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from ICircle ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from ICircle ).
Public method | CreateEntity | Initializes a new object instance. (inherited from ICircle ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from ICircle ).
Public method | EntName | Returns a name of the entity. (inherited from ICircle ).
Public method | FreeEntity | Destroys the object instance. (inherited from ICircle ).
Public method | GetArea | Returns the area bounded by a closed polygon. (inherited from ICircle ).
Public method | GetBoxPoints | For internal use. (inherited from ICircle ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from ICircle ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from ICircle ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from ICircle ).
Public method | RemoveEntity | Removes a specified entity. (inherited from ICircle ).
Public method | SetLType | Sets a line type for this object. (inherited from ICircle ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from ICircle ).
Public method | get_Arrows | Returns a point of the arrowhead. (inherited from ICircle ).
Public method | get_DottedPoints | Returns coordinates of a point in the points array that determines dots and dashes for a non-solid line type. (inherited from ICircle ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from ICircle ).
Public method | get_Points | Returns coordinates of a point in the points array. (inherited from ICircle ).
Public method | get_PolyFaceVertexIndexes | Returns a value which indicates an index of the polyface mesh vertex. (inherited from ICircle ).
Public method | set_Arrows | Modifies a point of the arrowhead at the given index. (inherited from ICircle ).

Top

collall See Also

Reference

Circle Interface


ICircle.AddEntity Method

API Reference > CADViewLib Namespace > Circle Interface > Methods >

ICircle.AddEntity Method

 Return to chapter overview

Show / hide the hidden text

Adds a new child entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AddEntity( _
ByVal AEntity As Entity _
)

C#

override void AddEntity(
EntityAEntity
)

C++

void AddEntity(
Entity^ AEntity
)

JScript

function AddEntity(
AEntity : Entity
);

Parameters

AEntity

Added entity.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.AssignEntity Method

API Reference > CADViewLib Namespace > Circle Interface > Methods >

ICircle.AssignEntity Method

 Return to chapter overview

Show / hide the hidden text

Assigns the properties of the specified entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AssignEntity( _
ByVal Source As Entity _
)

C#

override void AssignEntity(
EntitySource
)

C++

void AssignEntity(
Entity^ Source
)

JScript

function AssignEntity(
Source : Entity
);

Parameters

Source

Entity which has the same type as the current object.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.CreateEntity Method

API Reference > CADViewLib Namespace > Circle Interface > Methods >

ICircle.CreateEntity Method

 Return to chapter overview

Show / hide the hidden text

Initializes a new object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub CreateEntity()

C#

override void CreateEntity()

C++

void CreateEntity()

JScript

function CreateEntity();

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.DeleteEntity Method

API Reference > CADViewLib Namespace > Circle Interface > Methods >

ICircle.DeleteEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes an entity specified by index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub DeleteEntity( _
ByVal AIndex As Integer _
)

C#

override void DeleteEntity(
intAIndex
)

C++

void DeleteEntity(
intAIndex
)

JScript

function DeleteEntity(
AIndex : int
);

Parameters

AIndex

Index of the entity.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.EntName Method

API Reference > CADViewLib Namespace > Circle Interface > Methods >

ICircle.EntName Method

 Return to chapter overview

Show / hide the hidden text

Returns a name of the entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function EntName() As String

C#

override string EntName()

C++

String^ EntName()

JScript

function EntName() : String;

Return Value

A string containing the entity name.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.FreeEntity Method

API Reference > CADViewLib Namespace > Circle Interface > Methods >

ICircle.FreeEntity Method

 Return to chapter overview

Show / hide the hidden text

Destroys the object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub FreeEntity()

C#

override void FreeEntity()

C++

void FreeEntity()

JScript

function FreeEntity();

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.GetArea Method

API Reference > CADViewLib Namespace > Circle Interface > Methods >

ICircle.GetArea Method

 Return to chapter overview

Show / hide the hidden text

Returns the area bounded by a closed polygon.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetArea() As Double

C#

override double GetArea()

C++

double GetArea()

JScript

function GetArea() : double;

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.GetBoxPoints Method

API Reference > CADViewLib Namespace > Circle Interface > Methods >

ICircle.GetBoxPoints Method

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetBoxPoints( _
ByVal Full As Boolean _
) As Boolean

C#

override bool GetBoxPoints(
boolFull
)

C++

bool GetBoxPoints(
boolFull
)

JScript

function GetBoxPoints(
Full : boolean
) : boolean;

Parameters

Full

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.GetThickness Method

API Reference > CADViewLib Namespace > Circle Interface > Methods >

ICircle.GetThickness Method

 Return to chapter overview

Show / hide the hidden text

Returns the line thickness for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetThickness() As Double

C#

override double GetThickness()

C++

double GetThickness()

JScript

function GetThickness() : double;

Return Value

A Double type value indicating the line thickness.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.IndexOfEntity Method

API Reference > CADViewLib Namespace > Circle Interface > Methods >

ICircle.IndexOfEntity Method

 Return to chapter overview

Show / hide the hidden text

Returns index of the given entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function IndexOfEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int IndexOfEntity(
EntityAEntity
)

C++

int IndexOfEntity(
Entity^ AEntity
)

JScript

function IndexOfEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity whose index is retrieved.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.Iterate Method

API Reference > CADViewLib Namespace > Circle Interface > Methods >

ICircle.Iterate Method

 Return to chapter overview

Show / hide the hidden text

Iterates through the entities in the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub Iterate( _
ByVal AConverter As Converter _
)

C#

override void Iterate(
ConverterAConverter
)

C++

void Iterate(
Converter^ AConverter
)

JScript

function Iterate(
AConverter : Converter
);

Parameters

AConverter

Converter which contains the drawing data.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.RemoveEntity Method

API Reference > CADViewLib Namespace > Circle Interface > Methods >

ICircle.RemoveEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes a specified entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function RemoveEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int RemoveEntity(
EntityAEntity
)

C++

int RemoveEntity(
Entity^ AEntity
)

JScript

function RemoveEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity which will be removed.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.SetLType Method

API Reference > CADViewLib Namespace > Circle Interface > Methods >

ICircle.SetLType Method

 Return to chapter overview

Show / hide the hidden text

Sets a line type for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLType( _
ByVal Value As Entity _
)

C#

override void SetLType(
EntityValue
)

C++

void SetLType(
Entity^ Value
)

JScript

function SetLType(
Value : Entity
);

Parameters

Value

The line type value.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.SetLWeight Method

API Reference > CADViewLib Namespace > Circle Interface > Methods >

ICircle.SetLWeight Method

 Return to chapter overview

Show / hide the hidden text

Sets a line weight for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLWeight( _
ByVal Value As Integer _
)

C#

override void SetLWeight(
intValue
)

C++

void SetLWeight(
intValue
)

JScript

function SetLWeight(
Value : int
);

Parameters

Value

The line weight value.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.get_Arrows Method

API Reference > CADViewLib Namespace > Circle Interface > Methods >

ICircle.get_Arrows Method

 Return to chapter overview

Show / hide the hidden text

Returns a point of the arrowhead.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Arrows( _
ByVal Index As Integer _
) As Point3D

C#

override Point3D get_Arrows(
intIndex
)

C++

Point3D^ get_Arrows(
intIndex
)

JScript

function get_Arrows(
Index : int
) : Point3D;

Parameters

Index

Index of the point to retrieve.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.get_DottedPoints Method

API Reference > CADViewLib Namespace > Circle Interface > Methods >

ICircle.get_DottedPoints Method

 Return to chapter overview

Show / hide the hidden text

Returns coordinates of a point in the points array that determines dots and dashes for a non-solid line type.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_DottedPoints( _
ByVal Index As Integer _
) As Point3D

C#

override Point3D get_DottedPoints(
intIndex
)

C++

Point3D^ get_DottedPoints(
intIndex
)

JScript

function get_DottedPoints(
Index : int
) : Point3D;

Parameters

Index

Index of the point to retrieve.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.get_Entities Method

API Reference > CADViewLib Namespace > Circle Interface > Methods >

ICircle.get_Entities Method

 Return to chapter overview

Show / hide the hidden text

Returns the child entity at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Entities( _
ByVal Index As Integer _
) As Entity

C#

override Entity get_Entities(
intIndex
)

C++

Entity^ get_Entities(
intIndex
)

JScript

function get_Entities(
Index : int
) : Entity;

Parameters

Index

The index of the entity to retrieve.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.get_Points Method

API Reference > CADViewLib Namespace > Circle Interface > Methods >

ICircle.get_Points Method

 Return to chapter overview

Show / hide the hidden text

Returns coordinates of a point in the points array.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Points( _
ByVal Index As Integer _
) As Point3D

C#

override Point3D get_Points(
intIndex
)

C++

Point3D^ get_Points(
intIndex
)

JScript

function get_Points(
Index : int
) : Point3D;

Parameters

Index

Index of the point to retrieve.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.get_PolyFaceVertexIndexes Method

API Reference > CADViewLib Namespace > Circle Interface > Methods >

ICircle.get_PolyFaceVertexIndexes Method

 Return to chapter overview

Show / hide the hidden text

Returns a value which indicates an index of the polyface mesh vertex.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_PolyFaceVertexIndexes( _
ByVal Index As Integer _
) As Object

C#

override object get_PolyFaceVertexIndexes(
intIndex
)

C++

object^ get_PolyFaceVertexIndexes(
intIndex
)

JScript

function get_PolyFaceVertexIndexes(
Index : int
) : object;

Parameters

Index

The index number of the element.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


ICircle.set_Arrows Method

API Reference > CADViewLib Namespace > Circle Interface > Methods >

ICircle.set_Arrows Method

 Return to chapter overview

Show / hide the hidden text

Modifies a point of the arrowhead at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub set_Arrows( _
ByVal Index As Integer, _
ByVal Value As Point3D _
)

C#

override void set_Arrows(
intIndex,
Point3DValue
)

C++

void set_Arrows(
intIndex,
Point3D^ Value
)

JScript

function set_Arrows(
Index : int,
Value : Point3D
);

Parameters

Index

The index of the point.

Value

Value to be set for the point.

collall See Also

Reference

ICircle Interface
ICircle ICircle Members


Converter Interface

API Reference > CADViewLib Namespace >

Converter Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to the sections of the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface Converter
Inherits IConverter, _
IConverterEvents_Event

C#

public interface Converter : IConverter,
IConverterEvents_Event

C++

public interface class Converter : public IConverter^,
public IConverterEvents_Event^

JScript

public interface Converter
implements IConverter,
IConverterEvents_Event

collall See Also

Reference

Converter Members


Converter Members

API Reference > CADViewLib Namespace > Converter Interface >

Converter Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to the sections of the drawing database.

The following tables list the members exposed by the Converter type.

collall Public Properties

 | Name | Description
Public property | DefaultLayoutIndex | Gets or sets an index of the active layout. (inherited from IConverter ).
Public property | IsCrossoverMatrix | Obsolete. (inherited from IConverter ).
Public property | LayoutsCount | Gets a number of layouts in the drawing. (inherited from IConverter ).
Public property | NumberOfPartsInCircle | Gets or sets the quantity of lines in a polyline which approximates a circle. (inherited from IConverter ).
Public property | NumberOfPartsInSpline | Gets or sets the quantity of lines in a polyline which approximates a spline. (inherited from IConverter ).

Top

collall Public Methods

 | Name | Description
Public method | Count | Returns the number of entities in the drawing. (inherited from IConverter ).
Public method | GetLayerNames | Writes names of the layers to a string. (inherited from IConverter ).
Public method | IntToColor | Converts an integer color value to a single unsigned integer (uint). (inherited from IConverter ).
Public method | LayerByName | Retrieves a layer with the given name. (inherited from IConverter ).
Public method | Loads | Loads the entity data into the drawing database. (inherited from IConverter ).
Public method | get_Counts | Returns the number of objects in the given section of the drawing database. (inherited from IConverter ).
Public method | get_Layers | Returns the layer at the given index in the drawing database. (inherited from IConverter ).
Public method | get_Layouts | Returns the layout at the given index in the drawing database. (inherited from IConverter ).
Public method | get_Sections | Returns a group of objects which are stored in the given section of the drawing database. (inherited from IConverter ).
Public method | set_Sections | Sets a group of objects to the given section in the drawing database. (inherited from IConverter ).

Top

collall See Also

Reference

Converter Interface


Converter Properties

API Reference > CADViewLib Namespace > Converter Interface >

Converter Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | DefaultLayoutIndex | Gets or sets an index of the active layout. (inherited from IConverter ).
Public property | IsCrossoverMatrix | Obsolete. (inherited from IConverter ).
Public property | LayoutsCount | Gets a number of layouts in the drawing. (inherited from IConverter ).
Public property | NumberOfPartsInCircle | Gets or sets the quantity of lines in a polyline which approximates a circle. (inherited from IConverter ).
Public property | NumberOfPartsInSpline | Gets or sets the quantity of lines in a polyline which approximates a spline. (inherited from IConverter ).

Top

collall See Also

Reference

Converter Interface


IConverter.DefaultLayoutIndex Property

API Reference > CADViewLib Namespace > Converter Interface > Properties >

IConverter.DefaultLayoutIndex Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets an index of the active layout.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DefaultLayoutIndex() As Integer

C#

int DefaultLayoutIndex {get; set;}

C++

property int DefaultLayoutIndex {
int get( );
void set(
int value
);
}

JScript

function get DefaultLayoutIndex() : int;
function set DefaultLayoutIndex(value : int);

collall See Also

Reference

IConverter Interface
IConverter IConverter Members


IConverter.IsCrossoverMatrix Property

API Reference > CADViewLib Namespace > Converter Interface > Properties >

IConverter.IsCrossoverMatrix Property

 Return to chapter overview

Show / hide the hidden text

NOTE: This member is now obsolete.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsCrossoverMatrix() As Boolean

C#

bool IsCrossoverMatrix {get; set;}

C++

property bool IsCrossoverMatrix {
bool get( );
void set(
bool value
);
}

JScript

function get IsCrossoverMatrix() : boolean;
function set IsCrossoverMatrix(value : boolean);

collall See Also

Reference

IConverter Interface
IConverter IConverter Members


IConverter.LayoutsCount Property

API Reference > CADViewLib Namespace > Converter Interface > Properties >

IConverter.LayoutsCount Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of layouts in the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property LayoutsCount() As Integer

C#

int LayoutsCount {get;}

C++

property int LayoutsCount {
int get( );
}

JScript

function get LayoutsCount() : int;

collall See Also

Reference

IConverter Interface
IConverter IConverter Members


IConverter.NumberOfPartsInCircle Property

API Reference > CADViewLib Namespace > Converter Interface > Properties >

IConverter.NumberOfPartsInCircle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the quantity of lines in a polyline which approximates a circle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property NumberOfPartsInCircle() As Integer

C#

int NumberOfPartsInCircle {get; set;}

C++

property int NumberOfPartsInCircle {
int get( );
void set(
int value
);
}

JScript

function get NumberOfPartsInCircle() : int;
function set NumberOfPartsInCircle(value : int);

collall See Also

Reference

IConverter Interface
IConverter IConverter Members


IConverter.NumberOfPartsInSpline Property

API Reference > CADViewLib Namespace > Converter Interface > Properties >

IConverter.NumberOfPartsInSpline Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the quantity of lines in a polyline which approximates a spline.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property NumberOfPartsInSpline() As Integer

C#

int NumberOfPartsInSpline {get; set;}

C++

property int NumberOfPartsInSpline {
int get( );
void set(
int value
);
}

JScript

function get NumberOfPartsInSpline() : int;
function set NumberOfPartsInSpline(value : int);

collall See Also

Reference

IConverter Interface
IConverter IConverter Members


Converter Methods

API Reference > CADViewLib Namespace > Converter Interface >

Converter Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | Count | Returns the number of entities in the drawing. (inherited from IConverter ).
Public method | GetLayerNames | Writes names of the layers to a string. (inherited from IConverter ).
Public method | IntToColor | Converts an integer color value to a single unsigned integer (uint). (inherited from IConverter ).
Public method | LayerByName | Retrieves a layer with the given name. (inherited from IConverter ).
Public method | Loads | Loads the entity data into the drawing database. (inherited from IConverter ).
Public method | get_Counts | Returns the number of objects in the given section of the drawing database. (inherited from IConverter ).
Public method | get_Layers | Returns the layer at the given index in the drawing database. (inherited from IConverter ).
Public method | get_Layouts | Returns the layout at the given index in the drawing database. (inherited from IConverter ).
Public method | get_Sections | Returns a group of objects which are stored in the given section of the drawing database. (inherited from IConverter ).
Public method | set_Sections | Sets a group of objects to the given section in the drawing database. (inherited from IConverter ).

Top

collall See Also

Reference

Converter Interface


IConverter.Count Method

API Reference > CADViewLib Namespace > Converter Interface > Methods >

IConverter.Count Method

 Return to chapter overview

Show / hide the hidden text

Returns the number of entities in the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function Count() As Integer

C#

int Count()

C++

int Count()

JScript

function Count() : int;

collall See Also

Reference

IConverter Interface
IConverter IConverter Members


IConverter.GetLayerNames Method

API Reference > CADViewLib Namespace > Converter Interface > Methods >

IConverter.GetLayerNames Method

 Return to chapter overview

Show / hide the hidden text

Writes names of the layers to a string.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub GetLayerNames( _
ByRef S As String, _
ByVal DoClear As Boolean, _
ByVal IncludeUnused As Boolean _
)

C#

void GetLayerNames(
ref stringS,
boolDoClear,
boolIncludeUnused
)

C++

void GetLayerNames(
String^& S,
boolDoClear,
boolIncludeUnused
)

JScript

function GetLayerNames(
S : String,
DoClear : boolean,
IncludeUnused : boolean
);

Parameters

S

The string filled with layers names.

DoClear

If set to true, then the output string will be cleared before writing; otherwise, new string literals will be added to the existing ones.

IncludeUnused

If set to true, then the output string will contain names of unused layers; otherwise, these layers will be excluded.

collall See Also

Reference

IConverter Interface
IConverter IConverter Members


IConverter.IntToColor Method

API Reference > CADViewLib Namespace > Converter Interface > Methods >

IConverter.IntToColor Method

 Return to chapter overview

Show / hide the hidden text

Converts an integer color value to a single unsigned integer (uint).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function IntToColor( _
ByVal Value As Integer _
) As UInt32

C#

UInt32 IntToColor(
intValue
)

C++

UInt32 IntToColor(
intValue
)

JScript

function IntToColor(
Value : int
) : UInt32;

Parameters

Value

The integer value.

collall See Also

Reference

IConverter Interface
IConverter IConverter Members


IConverter.LayerByName Method

API Reference > CADViewLib Namespace > Converter Interface > Methods >

IConverter.LayerByName Method

 Return to chapter overview

Show / hide the hidden text

Retrieves a layer with the given name.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function LayerByName( _
ByVal AName As String _
) As Layer

C#

Layer LayerByName(
stringAName
)

C++

Layer^ LayerByName(
String^ AName
)

JScript

function LayerByName(
AName : String
) : Layer;

Parameters

AName

The name of the layer to retrieve.

collall See Also

Reference

IConverter Interface
IConverter IConverter Members


IConverter.Loads Method

API Reference > CADViewLib Namespace > Converter Interface > Methods >

IConverter.Loads Method

 Return to chapter overview

Show / hide the hidden text

Loads the entity data into the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub Loads( _
ByVal E As Entity _
)

C#

void Loads(
EntityE
)

C++

void Loads(
Entity^ E
)

JScript

function Loads(
E : Entity
);

Parameters

E

The entity to load.

collall Remarks

Call this method right after creating a new entity or modifying the properties of the loaded entity.

collall See Also

Reference

IConverter Interface
IConverter IConverter Members


IConverter.get_Counts Method

API Reference > CADViewLib Namespace > Converter Interface > Methods >

IConverter.get_Counts Method

 Return to chapter overview

Show / hide the hidden text

Returns the number of objects in the given section of the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function get_Counts( _
ByVal ConvSection As TxConvSection _
) As Integer

C#

int get_Counts(
TxConvSectionConvSection
)

C++

int get_Counts(
TxConvSectionConvSection
)

JScript

function get_Counts(
ConvSection : TxConvSection
) : int;

Parameters

ConvSection

The section of the drawing database.

collall See Also

Reference

IConverter Interface
IConverter IConverter Members


IConverter.get_Layers Method

API Reference > CADViewLib Namespace > Converter Interface > Methods >

IConverter.get_Layers Method

 Return to chapter overview

Show / hide the hidden text

Returns the layer at the given index in the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function get_Layers( _
ByVal Index As Integer _
) As Layer

C#

Layer get_Layers(
intIndex
)

C++

Layer^ get_Layers(
intIndex
)

JScript

function get_Layers(
Index : int
) : Layer;

Parameters

Index

The index of the layer to retrieve.

collall See Also

Reference

IConverter Interface
IConverter IConverter Members


IConverter.get_Layouts Method

API Reference > CADViewLib Namespace > Converter Interface > Methods >

IConverter.get_Layouts Method

 Return to chapter overview

Show / hide the hidden text

Returns the layout at the given index in the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function get_Layouts( _
ByVal Index As Integer _
) As Layout

C#

Layout get_Layouts(
intIndex
)

C++

Layout^ get_Layouts(
intIndex
)

JScript

function get_Layouts(
Index : int
) : Layout;

Parameters

Index

The index of the layout to retrieve.

collall See Also

Reference

IConverter Interface
IConverter IConverter Members


IConverter.get_Sections Method

API Reference > CADViewLib Namespace > Converter Interface > Methods >

IConverter.get_Sections Method

 Return to chapter overview

Show / hide the hidden text

Returns a group of objects which are stored in the given section of the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function get_Sections( _
ByVal Index As TxConvSection _
) As Group

C#

Group get_Sections(
TxConvSection Index
)

C++

Group^ get_Sections(
TxConvSection Index
)

JScript

function get_Sections(
Index : TxConvSection
) : Group;

Parameters

Index

The index of the section to retrieve.

collall See Also

Reference

IConverter Interface
IConverter IConverter Members


IConverter.set_Sections Method

API Reference > CADViewLib Namespace > Converter Interface > Methods >

IConverter.set_Sections Method

 Return to chapter overview

Show / hide the hidden text

Sets a group of objects to the given section in the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub set_Sections( _
ByVal Index As TxConvSection, _
ByVal Value As Group _
)

C#

void set_Sections(
TxConvSectionIndex,
GroupValue
)

C++

void set_Sections(
TxConvSectionIndex,
Group^ Value
)

JScript

function set_Sections(
Index : TxConvSection,
Value : Group
);

Parameters

Index

The index of the section.

Value

Group of objects.

collall See Also

Reference

IConverter Interface
IConverter IConverter Members


DWGImage Interface

API Reference > CADViewLib Namespace >

DWGImage Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to a DWG drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface DWGImage
Inherits IDWGImage, _
IDXFImageEvents_Event

C#

public interface DWGImage : IDWGImage,
IDXFImageEvents_Event

C++

public interface class DWGImage : public IDWGImage^,
public IDXFImageEvents_Event^

JScript

public interface DWGImage
implements IDWGImage,
IDXFImageEvents_Event

collall See Also

Reference

DWGImage Members


DWGImage Members

API Reference > CADViewLib Namespace > DWGImage Interface >

DWGImage Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to a DWG drawing.

The following tables list the members exposed by the DWGImage type.

collall Public Properties

 | Name | Description
Public property | BackGroundColor | Gets or sets a background color for the drawing. (inherited from IDWGImage ).
Public property | BorderSize | Gets or sets a border size for the drawing. (inherited from IDWGImage ).
Public property | BorderType | Gets or sets a way the drawing's border size is defined (global or ratio). (inherited from IDWGImage ).
Public property | CADClassID | Gets the CAD format identifier for the drawing. (inherited from IDWGImage ).
Public property | CBFormat | Gets or sets the clipboard format. (inherited from IDWGImage ).
Public property | CanStopLoading | Gets a value indicating whether the loading of the drawing data can be terminated. (inherited from IDWGImage ).
Public property | Charset | Gets or sets a character set for the text entities. (inherited from IDWGImage ).
Public property | ColorToLineWeight | Gets or sets a string which contains the color-lineweight pairs. (inherited from IDWGImage ).
Public property | Converter | Gets or sets a Converter associated with this image object. (inherited from IDWGImage ).
Public property | Count | Gets a number of entities in the drawing. (inherited from IDWGImage ).
Public property | CurrentLayout | Gets or sets the current layout for the drawing. (inherited from IDWGImage ).
Public property | DefaultColor | Gets or sets the default color for the drawing. (inherited from IDWGImage ).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions in the drawing are visible. (inherited from IDWGImage ).
Public property | DrawMode | Gets or sets an appearance of colors in the drawing. (inherited from IDWGImage ).
Public property | DrawingBox | Gets or sets the drawing bounding box. (inherited from IDWGImage ).
Public property | Empty | Gets a value indicating whether the drawing is empty. (inherited from IDWGImage ).
Public property | Extents | Gets or sets the drawing's extents. (inherited from IDWGImage ).
Public property | Height | Gets or sets a height of the drawing. (inherited from IDWGImage ).
Public property | Is3D | Gets a value indicating whether the drawing is three-dimensional. (inherited from IDWGImage ).
Public property | IsDraw3DAxes | Gets a value indicating whether 3D axes are visible on the drawing. (inherited from IDWGImage ).
Public property | IsDrawingRotated | Gets a value indicating whether the drawing is rotated. (inherited from IDWGImage ).
Public property | IsLoading | Gets a value indicating whether the process of loading the drawing data is active. (inherited from IDWGImage ).
Public property | IsPlotting | Gets or sets a value indicating whether to plot the image or not. (inherited from IDWGImage ).
Public property | IsProcessMessages | Gets or sets a value indicating whether the messages processing is allowed. (inherited from IDWGImage ).
Public property | IsShowBackground | Gets or sets a value indicating whether the backround is displayed. (inherited from IDWGImage ).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines is determined by the drawing data. (inherited from IDWGImage ).
Public property | IsWithoutBorder | Gets or sets a value indicating whether to display the drawing without borders. (inherited from IDWGImage ).
Public property | LayoutsCount | Gets the number of layouts in the drawing. (inherited from IDWGImage ).
Public property | LineScaled | Gets or sets a value indicating whether the line weight is diplayed. (inherited from IDWGImage ).
Public property | LineWeightScale | Gets or sets a scale for line weights. (inherited from IDWGImage ).
Public property | Millimetres | Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file. (inherited from IDWGImage ).
Public property | Modified | Gets or sets a value indicating whether the drawing is modified. (inherited from IDWGImage ).
Public property | NullWidth | Gets or sets a thickness for lines which have the zero lineweight. (inherited from IDWGImage ).
Public property | OwnSource | For internal use. (inherited from IDWGImage ).
Public property | PreviewBitmap | Gets the preview bitmap for the DWG file. (inherited from IDWGImage ).
Public property | PureExtents | Gets the drawing's extents excluding the borders. (inherited from IDWGImage ).
Public property | ResizeDisproportionateDrawing | Gets or sets a value indicating whether to resize a drawing with disproportionate sizes. (inherited from IDWGImage ).
Public property | Scale | Gets or sets a 3D point which defines the scale factor. (inherited from IDWGImage ).
Public property | ShowImages | Gets or sets a value indicating whether the raster images are displayed. (inherited from IDWGImage ).
Public property | Stretch | Gets or sets a value indicating whether the displayed image has to be stretched to fit exactly with the drawing rectangle. (inherited from IDWGImage ).
Public property | TextVisible | Gets or sets a value indicating whether texts in the drawing are visible. (inherited from IDWGImage ).
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles are drawn by using GDI+ methods without linearization. (inherited from IDWGImage ).
Public property | ViewRectangle | For internal use. (inherited from IDWGImage ).
Public property | Width | Gets or sets a width of the drawing. (inherited from IDWGImage ).

Top

collall Public Methods

 | Name | Description
Public method | AbsHeight | Returns an absolute height of the CAD drawing. (inherited from IDWGImage ).
Public method | AbsWidth | Returns an absolute width of the CAD drawing. (inherited from IDWGImage ).
Public method | AddScaledDXF | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing. (inherited from IDWGImage ).
Public method | AddScaledDXFEx | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing. (inherited from IDWGImage ).
Public method | AssignImage | Makes a copy of a specified CAD image object and assigns it to this image. (inherited from IDWGImage ).
Public method | CreateImage | Initializes a new CAD image instance. (inherited from IDWGImage ).
Public method | Draw | Draws the CAD image in a specified device context (DC). (inherited from IDWGImage ).
Public method | DrawRect | Draws a specified region of this CAD image in a device context (DC). (inherited from IDWGImage ).
Public method | ExportToMetafile | Exports this CAD image to Windows metafile. (inherited from IDWGImage ).
Public method | FreeImage | Destroys this CAD image object and frees the memory used within the object. (inherited from IDWGImage ).
Public method | GetCADCoords | Returns CAD coordinates for a specified point. (inherited from IDWGImage ).
Public method | GetEntityColor | Returns the color value for a specified entity. (inherited from IDWGImage ).
Public method | GetExtents | Recalculates extents of the CAD image. (inherited from IDWGImage ).
Public method | GetPoint | Gets the on-screen coordinates for a specified CAD point. (inherited from IDWGImage ).
Public method | GetRealImagePoint | Returns CAD coordinates of a specified point considering the drawing's rotation and viewport parameters. (inherited from IDWGImage ).
Public method | HeadVarAsFloat | Returns a value of the DXF header variable as a floating point number. (inherited from IDWGImage ).
Public method | HeadVarAsInteger | Returns a value of the DXF header variable as an integer. (inherited from IDWGImage ).
Public method | HeadVarAsstring | Returns a value of the DXF header variable as a string. (inherited from IDWGImage ).
Public method | LoadFromClipboardFormat | Loads data from the clipboard. (inherited from IDWGImage ).
Public method | LoadFromFile | Loads a CAD drawing from file. (inherited from IDWGImage ).
Public method | LoadFromIStream | Loads a CAD drawing from stream. (inherited from IDWGImage ).
Public method | LoadFromStream | Loads a CAD drawing from stream. (inherited from IDWGImage ).
Public method | LoadPreviewFromFile | Loads the preview from a file. (inherited from IDWGImage ).
Public method | RefreshCurrentLayout | Refreshes the current layout. (inherited from IDWGImage ).
Public method | ResetDrawingBox | Switches off the drawing box. (inherited from IDWGImage ).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from IDWGImage ).
Public method | RotToView | Rotates the drawing to a specified view. (inherited from IDWGImage ).
Public method | Rotate | Rotates the drawing. (inherited from IDWGImage ).
Public method | SaveToClipboardFormat | Copies the drawing to the clipboard in a specified format. (inherited from IDWGImage ).
Public method | SaveToFile | Saves the drawing to a specified file. (inherited from IDWGImage ).
Public method | SaveToIStream | Writes the drawing data to a specified stream. (inherited from IDWGImage ).
Public method | SaveToStream | Writes the drawing data to a specified stream. (inherited from IDWGImage ).
Public method | SetClippingRect | Sets a clipping rectangle for the drawing. (inherited from IDWGImage ).
Public method | SetExtentsParameters | Changes the drawing extents. (inherited from IDWGImage ).
Public method | StopLoading | Terminates loading of the drawing data. (inherited from IDWGImage ).
Public method | get_Blocks | Retrieves a BLOCK object by its index. (inherited from IDWGImage ).
Public method | get_Entities | Retrieves an entity by its index. (inherited from IDWGImage ).
Public method | get_Items | (inherited from IDWGImage ).
Public method | get_Layouts | Retrieves a layout by its index. (inherited from IDWGImage ).

Top

collall See Also

Reference

DWGImage Interface


DWGImage Properties

API Reference > CADViewLib Namespace > DWGImage Interface >

DWGImage Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | BackGroundColor | Gets or sets a background color for the drawing. (inherited from IDWGImage ).
Public property | BorderSize | Gets or sets a border size for the drawing. (inherited from IDWGImage ).
Public property | BorderType | Gets or sets a way the drawing's border size is defined (global or ratio). (inherited from IDWGImage ).
Public property | CADClassID | Gets the CAD format identifier for the drawing. (inherited from IDWGImage ).
Public property | CBFormat | Gets or sets the clipboard format. (inherited from IDWGImage ).
Public property | CanStopLoading | Gets a value indicating whether the loading of the drawing data can be terminated. (inherited from IDWGImage ).
Public property | Charset | Gets or sets a character set for the text entities. (inherited from IDWGImage ).
Public property | ColorToLineWeight | Gets or sets a string which contains the color-lineweight pairs. (inherited from IDWGImage ).
Public property | Converter | Gets or sets a Converter associated with this image object. (inherited from IDWGImage ).
Public property | Count | Gets a number of entities in the drawing. (inherited from IDWGImage ).
Public property | CurrentLayout | Gets or sets the current layout for the drawing. (inherited from IDWGImage ).
Public property | DefaultColor | Gets or sets the default color for the drawing. (inherited from IDWGImage ).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions in the drawing are visible. (inherited from IDWGImage ).
Public property | DrawMode | Gets or sets an appearance of colors in the drawing. (inherited from IDWGImage ).
Public property | DrawingBox | Gets or sets the drawing bounding box. (inherited from IDWGImage ).
Public property | Empty | Gets a value indicating whether the drawing is empty. (inherited from IDWGImage ).
Public property | Extents | Gets or sets the drawing's extents. (inherited from IDWGImage ).
Public property | Height | Gets or sets a height of the drawing. (inherited from IDWGImage ).
Public property | Is3D | Gets a value indicating whether the drawing is three-dimensional. (inherited from IDWGImage ).
Public property | IsDraw3DAxes | Gets a value indicating whether 3D axes are visible on the drawing. (inherited from IDWGImage ).
Public property | IsDrawingRotated | Gets a value indicating whether the drawing is rotated. (inherited from IDWGImage ).
Public property | IsLoading | Gets a value indicating whether the process of loading the drawing data is active. (inherited from IDWGImage ).
Public property | IsPlotting | Gets or sets a value indicating whether to plot the image or not. (inherited from IDWGImage ).
Public property | IsProcessMessages | Gets or sets a value indicating whether the messages processing is allowed. (inherited from IDWGImage ).
Public property | IsShowBackground | Gets or sets a value indicating whether the backround is displayed. (inherited from IDWGImage ).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines is determined by the drawing data. (inherited from IDWGImage ).
Public property | IsWithoutBorder | Gets or sets a value indicating whether to display the drawing without borders. (inherited from IDWGImage ).
Public property | LayoutsCount | Gets the number of layouts in the drawing. (inherited from IDWGImage ).
Public property | LineScaled | Gets or sets a value indicating whether the line weight is diplayed. (inherited from IDWGImage ).
Public property | LineWeightScale | Gets or sets a scale for line weights. (inherited from IDWGImage ).
Public property | Millimetres | Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file. (inherited from IDWGImage ).
Public property | Modified | Gets or sets a value indicating whether the drawing is modified. (inherited from IDWGImage ).
Public property | NullWidth | Gets or sets a thickness for lines which have the zero lineweight. (inherited from IDWGImage ).
Public property | OwnSource | For internal use. (inherited from IDWGImage ).
Public property | PreviewBitmap | Gets the preview bitmap for the DWG file. (inherited from IDWGImage ).
Public property | PureExtents | Gets the drawing's extents excluding the borders. (inherited from IDWGImage ).
Public property | ResizeDisproportionateDrawing | Gets or sets a value indicating whether to resize a drawing with disproportionate sizes. (inherited from IDWGImage ).
Public property | Scale | Gets or sets a 3D point which defines the scale factor. (inherited from IDWGImage ).
Public property | ShowImages | Gets or sets a value indicating whether the raster images are displayed. (inherited from IDWGImage ).
Public property | Stretch | Gets or sets a value indicating whether the displayed image has to be stretched to fit exactly with the drawing rectangle. (inherited from IDWGImage ).
Public property | TextVisible | Gets or sets a value indicating whether texts in the drawing are visible. (inherited from IDWGImage ).
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles are drawn by using GDI+ methods without linearization. (inherited from IDWGImage ).
Public property | ViewRectangle | For internal use. (inherited from IDWGImage ).
Public property | Width | Gets or sets a width of the drawing. (inherited from IDWGImage ).

Top

collall See Also

Reference

DWGImage Interface


IDWGImage.BackGroundColor Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.BackGroundColor Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a background color for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property BackGroundColor() As UInt32

C#

UInt32 BackGroundColor {get; set;}

C++

property UInt32 BackGroundColor {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get BackGroundColor() : UInt32;
function set BackGroundColor(value : UInt32);

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.BorderSize Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.BorderSize Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a border size for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property BorderSize() As Double

C#

double BorderSize {get; set;}

C++

property double BorderSize {
double get( );
void set(
double value
);
}

JScript

function get BorderSize() : double;
function set BorderSize(value : double);

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.BorderType Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.BorderType Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a way the drawing's border size is defined (global or ratio).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property BorderType() As TxsgBorderType

C#

TxsgBorderType BorderType {get; set;}

C++

property TxsgBorderType BorderType {
TxsgBorderType get( );
void set(
TxsgBorderType value
);
}

JScript

function get BorderType() : TxsgBorderType;
function set BorderType(value : TxsgBorderType);

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.CADClassID Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.CADClassID Property

 Return to chapter overview

Show / hide the hidden text

Gets the CAD format identifier for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property CADClassID() As TxCADClassID

C#

TxCADClassID CADClassID {get;}

C++

property TxCADClassID CADClassID {
TxCADClassID get( );
}

JScript

function get CADClassID() : TxCADClassID;

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.CBFormat Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.CBFormat Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the clipboard format.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CBFormat() As UInt16

C#

UInt16 CBFormat {get; set;}

C++

property UInt16 CBFormat {
UInt16 get( );
void set(
UInt16 value
);
}

JScript

function get CBFormat() : UInt16;
function set CBFormat(value : UInt16);

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.CanStopLoading Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.CanStopLoading Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the loading of the drawing data can be terminated.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property CanStopLoading() As Boolean

C#

bool CanStopLoading {get;}

C++

property bool CanStopLoading {
bool get( );
}

JScript

function get CanStopLoading() : boolean;

Property Value

true if the loading can be terminated; otherwise, false.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.Charset Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.Charset Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a character set for the text entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Charset() As Byte

C#

byte Charset {get; set;}

C++

property Byte Charset {
Byte get( );
void set(
Byte value
);
}

JScript

function get Charset() : byte;
function set Charset(value : byte);

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.ColorToLineWeight Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.ColorToLineWeight Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a string which contains the color-lineweight pairs.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property ColorToLineWeight() As String

C#

string ColorToLineWeight {get; set;}

C++

property String^ ColorToLineWeight {
String^ get( );
void set(
String^ value
);
}

JScript

function get ColorToLineWeight() : String;
function set ColorToLineWeight(value : String);

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.Converter Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.Converter Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a Converter associated with this image object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Converter() As Converter

C#

Converter Converter {get;}

C++

property Converter^ Converter {
Converter^ get( );
}

JScript

function get Converter() : Converter;

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.Count Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.Count Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of entities in the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Count() As Integer

C#

int Count {get;}

C++

property int Count {
int get( );
}

JScript

function get Count() : int;

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.CurrentLayout Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.CurrentLayout Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the current layout for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CurrentLayout() As Layout

C#

Layout CurrentLayout {get; set;}

C++

property Layout^ CurrentLayout {
Layout^ get( );
void set(
Layout^ value
);
}

JScript

function get CurrentLayout() : Layout;
function set CurrentLayout(value : Layout);

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.DefaultColor Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.DefaultColor Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the default color for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DefaultColor() As UInt32

C#

UInt32 DefaultColor {get; set;}

C++

property UInt32 DefaultColor {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get DefaultColor() : UInt32;
function set DefaultColor(value : UInt32);

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.DimensionsVisible Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.DimensionsVisible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether dimensions in the drawing are visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DimensionsVisible() As Boolean

C#

bool DimensionsVisible {get; set;}

C++

property bool DimensionsVisible {
bool get( );
void set(
bool value
);
}

JScript

function get DimensionsVisible() : boolean;
function set DimensionsVisible(value : boolean);

Property Value

true if the dimensions are visible; otherwise, false. Default value is true.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.DrawMode Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.DrawMode Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets an appearance of colors in the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DrawMode() As TxDXFDrawMode

C#

TxDXFDrawMode DrawMode {get; set;}

C++

property TxDXFDrawMode DrawMode {
TxDXFDrawMode get( );
void set(
TxDXFDrawMode value
);
}

JScript

function get DrawMode() : TxDXFDrawMode;
function set DrawMode(value : TxDXFDrawMode);

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.DrawingBox Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.DrawingBox Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the drawing bounding box.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DrawingBox() As Rect3D

C#

Rect3D DrawingBox {get; set;}

C++

property Rect3D^ DrawingBox {
Rect3D^ get( );
void set(
Rect3D^ value
);
}

JScript

function get DrawingBox() : Rect3D;
function set DrawingBox(value : Rect3D);

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.Empty Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.Empty Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the drawing is empty.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Empty() As Boolean

C#

bool Empty {get;}

C++

property bool Empty {
bool get( );
}

JScript

function get Empty() : boolean;

Property Value

true if the drawing is empty; otherwise, false.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.Extents Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.Extents Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the drawing's extents.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Extents() As Rect3D

C#

Rect3D Extents {get; set;}

C++

property Rect3D^ Extents {
Rect3D^ get( );
void set(
Rect3D^ value
);
}

JScript

function get Extents() : Rect3D;
function set Extents(value : Rect3D);

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.Height Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.Height Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a height of the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Height() As Integer

C#

int Height {get; set;}

C++

property int Height {
int get( );
void set(
int value
);
}

JScript

function get Height() : int;
function set Height(value : int);

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.Is3D Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.Is3D Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the drawing is three-dimensional.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Is3D() As Boolean

C#

bool Is3D {get; set;}

C++

property bool Is3D {
bool get( );
void set(
bool value
);
}

JScript

function get Is3D() : boolean;
function set Is3D(value : boolean);

Property Value

true if the drawing is three-dimensional; otherwise, false.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.IsDraw3DAxes Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.IsDraw3DAxes Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether 3D axes are visible on the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsDraw3DAxes() As Boolean

C#

bool IsDraw3DAxes {get; set;}

C++

property bool IsDraw3DAxes {
bool get( );
void set(
bool value
);
}

JScript

function get IsDraw3DAxes() : boolean;
function set IsDraw3DAxes(value : boolean);

Property Value

true if the 3D axes are visible; otherwise, false.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.IsDrawingRotated Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.IsDrawingRotated Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the drawing is rotated.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsDrawingRotated() As Boolean

C#

bool IsDrawingRotated {get;}

C++

property bool IsDrawingRotated {
bool get( );
}

JScript

function get IsDrawingRotated() : boolean;

Property Value

true if the drawing is rotated; otherwise, false.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.IsLoading Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.IsLoading Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the process of loading the drawing data is active.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsLoading() As Boolean

C#

bool IsLoading {get;}

C++

property bool IsLoading {
bool get( );
}

JScript

function get IsLoading() : boolean;

Property Value

true if the drawing data is loading into this image object; otherwise, false.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.IsPlotting Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.IsPlotting Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether to plot the image or not.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsPlotting() As Boolean

C#

bool IsPlotting {get; set;}

C++

property bool IsPlotting {
bool get( );
void set(
bool value
);
}

JScript

function get IsPlotting() : boolean;
function set IsPlotting(value : boolean);

Property Value

true if the image should be plotted; otherwise, false.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.IsProcessMessages Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.IsProcessMessages Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the messages processing is allowed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsProcessMessages() As Boolean

C#

bool IsProcessMessages {get; set;}

C++

property bool IsProcessMessages {
bool get( );
void set(
bool value
);
}

JScript

function get IsProcessMessages() : boolean;
function set IsProcessMessages(value : boolean);

Property Value

true if the messages processing is allowed; otherwise, false.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.IsShowBackground Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.IsShowBackground Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the backround is displayed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsShowBackground() As Boolean

C#

bool IsShowBackground {get; set;}

C++

property bool IsShowBackground {
bool get( );
void set(
bool value
);
}

JScript

function get IsShowBackground() : boolean;
function set IsShowBackground(value : boolean);

Property Value

true if the backround is displayed; otherwise, false.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.IsShowLineWeight Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.IsShowLineWeight Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether a thickness of lines is determined by the drawing data.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsShowLineWeight() As Boolean

C#

bool IsShowLineWeight {get; set;}

C++

property bool IsShowLineWeight {
bool get( );
void set(
bool value
);
}

JScript

function get IsShowLineWeight() : boolean;
function set IsShowLineWeight(value : boolean);

Property Value

true if a thickness of lines is determined by the drawing data; otherwise, false.

collall Remarks

If this property value is false, a thickness of lines is determined by the NullWidth property.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.IsWithoutBorder Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.IsWithoutBorder Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether to display the drawing without borders.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsWithoutBorder() As Boolean

C#

bool IsWithoutBorder {get; set;}

C++

property bool IsWithoutBorder {
bool get( );
void set(
bool value
);
}

JScript

function get IsWithoutBorder() : boolean;
function set IsWithoutBorder(value : boolean);

Property Value

true if the borders are not displayed; otherwise, false.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.LayoutsCount Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.LayoutsCount Property

 Return to chapter overview

Show / hide the hidden text

Gets the number of layouts in the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property LayoutsCount() As Integer

C#

int LayoutsCount {get;}

C++

property int LayoutsCount {
int get( );
}

JScript

function get LayoutsCount() : int;

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.LineScaled Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.LineScaled Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the line weight is diplayed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineScaled() As Boolean

C#

bool LineScaled {get; set;}

C++

property bool LineScaled {
bool get( );
void set(
bool value
);
}

JScript

function get LineScaled() : boolean;
function set LineScaled(value : boolean);

Property Value

true if the line weight is displayed; otherwise, false.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.LineWeightScale Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.LineWeightScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a scale for line weights.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineWeightScale() As Double

C#

double LineWeightScale {get; set;}

C++

property double LineWeightScale {
double get( );
void set(
double value
);
}

JScript

function get LineWeightScale() : double;
function set LineWeightScale(value : double);

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.Millimetres Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.Millimetres Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Millimetres() As Boolean

C#

bool Millimetres {get; set;}

C++

property bool Millimetres {
bool get( );
void set(
bool value
);
}

JScript

function get Millimetres() : boolean;
function set Millimetres(value : boolean);

Property Value

true if the drawing units are millimeters; false if the drawing units are inches.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.Modified Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.Modified Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the drawing is modified.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Modified() As Boolean

C#

bool Modified {get; set;}

C++

property bool Modified {
bool get( );
void set(
bool value
);
}

JScript

function get Modified() : boolean;
function set Modified(value : boolean);

Property Value

true if the drawing is modified; otherwise, false.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.NullWidth Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.NullWidth Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a thickness for lines which have the zero lineweight.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property NullWidth() As Integer

C#

int NullWidth {get; set;}

C++

property int NullWidth {
int get( );
void set(
int value
);
}

JScript

function get NullWidth() : int;
function set NullWidth(value : int);

Property Value

Line thickness. Default value is 1.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.OwnSource Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.OwnSource Property

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property OwnSource() As Boolean

C#

bool OwnSource {get; set;}

C++

property bool OwnSource {
bool get( );
void set(
bool value
);
}

JScript

function get OwnSource() : boolean;
function set OwnSource(value : boolean);

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.PreviewBitmap Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.PreviewBitmap Property

 Return to chapter overview

Show / hide the hidden text

Gets the preview bitmap for the DWG file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property PreviewBitmap() As StdPicture

C#

StdPicture PreviewBitmap {get;}

C++

property StdPicture^ PreviewBitmap {
StdPicture^ get( );
}

JScript

function get PreviewBitmap() : StdPicture;

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.PureExtents Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.PureExtents Property

 Return to chapter overview

Show / hide the hidden text

Gets the drawing's extents excluding the borders.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property PureExtents() As Rect3D

C#

Rect3D PureExtents {get;}

C++

property Rect3D^ PureExtents {
Rect3D^ get( );
}

JScript

function get PureExtents() : Rect3D;

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.ResizeDisproportionateDrawing Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.ResizeDisproportionateDrawing Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether to resize a drawing with disproportionate sizes.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property ResizeDisproportionateDrawing() As Boolean

C#

bool ResizeDisproportionateDrawing {get; set;}

C++

property bool ResizeDisproportionateDrawing {
bool get( );
void set(
bool value
);
}

JScript

function get ResizeDisproportionateDrawing() : boolean;
function set ResizeDisproportionateDrawing(value : boolean);

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.Scale Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.Scale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a 3D point which defines the scale factor.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Scale() As Point3D

C#

Point3D Scale {get;}

C++

property Point3D^ Scale {
Point3D^ get( );
}

JScript

function get Scale() : Point3D;

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.ShowImages Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.ShowImages Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the raster images are displayed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property ShowImages() As Boolean

C#

bool ShowImages {get; set;}

C++

property bool ShowImages {
bool get( );
void set(
bool value
);
}

JScript

function get ShowImages() : boolean;
function set ShowImages(value : boolean);

Property Value

true if the raster images are displayed; overwise, false.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.Stretch Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.Stretch Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the displayed image has to be stretched to fit exactly with the drawing rectangle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Stretch() As Boolean

C#

bool Stretch {get; set;}

C++

property bool Stretch {
bool get( );
void set(
bool value
);
}

JScript

function get Stretch() : boolean;
function set Stretch(value : boolean);

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.TextVisible Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.TextVisible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether texts in the drawing are visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property TextVisible() As Boolean

C#

bool TextVisible {get; set;}

C++

property bool TextVisible {
bool get( );
void set(
bool value
);
}

JScript

function get TextVisible() : boolean;
function set TextVisible(value : boolean);

Property Value

true if the texts are visible; otherwise, false.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.UseWinEllipse Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.UseWinEllipse Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether arcs and circles are drawn by using GDI+ methods without linearization.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property UseWinEllipse() As Boolean

C#

bool UseWinEllipse {get; set;}

C++

property bool UseWinEllipse {
bool get( );
void set(
bool value
);
}

JScript

function get UseWinEllipse() : boolean;
function set UseWinEllipse(value : boolean);

Property Value

true if the GDI+ methods are used for drawing arcs and circles; otherwise, false.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.ViewRectangle Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.ViewRectangle Property

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property ViewRectangle() As Rect3D

C#

Rect3D ViewRectangle {get; set;}

C++

property Rect3D^ ViewRectangle {
Rect3D^ get( );
void set(
Rect3D^ value
);
}

JScript

function get ViewRectangle() : Rect3D;
function set ViewRectangle(value : Rect3D);

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.Width Property

API Reference > CADViewLib Namespace > DWGImage Interface > Properties >

IDWGImage.Width Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a width of the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Width() As Integer

C#

int Width {get; set;}

C++

property int Width {
int get( );
void set(
int value
);
}

JScript

function get Width() : int;
function set Width(value : int);

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


DWGImage Methods

API Reference > CADViewLib Namespace > DWGImage Interface >

DWGImage Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AbsHeight | Returns an absolute height of the CAD drawing. (inherited from IDWGImage ).
Public method | AbsWidth | Returns an absolute width of the CAD drawing. (inherited from IDWGImage ).
Public method | AddScaledDXF | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing. (inherited from IDWGImage ).
Public method | AddScaledDXFEx | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing. (inherited from IDWGImage ).
Public method | AssignImage | Makes a copy of a specified CAD image object and assigns it to this image. (inherited from IDWGImage ).
Public method | CreateImage | Initializes a new CAD image instance. (inherited from IDWGImage ).
Public method | Draw | Draws the CAD image in a specified device context (DC). (inherited from IDWGImage ).
Public method | DrawRect | Draws a specified region of this CAD image in a device context (DC). (inherited from IDWGImage ).
Public method | ExportToMetafile | Exports this CAD image to Windows metafile. (inherited from IDWGImage ).
Public method | FreeImage | Destroys this CAD image object and frees the memory used within the object. (inherited from IDWGImage ).
Public method | GetCADCoords | Returns CAD coordinates for a specified point. (inherited from IDWGImage ).
Public method | GetEntityColor | Returns the color value for a specified entity. (inherited from IDWGImage ).
Public method | GetExtents | Recalculates extents of the CAD image. (inherited from IDWGImage ).
Public method | GetPoint | Gets the on-screen coordinates for a specified CAD point. (inherited from IDWGImage ).
Public method | GetRealImagePoint | Returns CAD coordinates of a specified point considering the drawing's rotation and viewport parameters. (inherited from IDWGImage ).
Public method | HeadVarAsFloat | Returns a value of the DXF header variable as a floating point number. (inherited from IDWGImage ).
Public method | HeadVarAsInteger | Returns a value of the DXF header variable as an integer. (inherited from IDWGImage ).
Public method | HeadVarAsstring | Returns a value of the DXF header variable as a string. (inherited from IDWGImage ).
Public method | LoadFromClipboardFormat | Loads data from the clipboard. (inherited from IDWGImage ).
Public method | LoadFromFile | Loads a CAD drawing from file. (inherited from IDWGImage ).
Public method | LoadFromIStream | Loads a CAD drawing from stream. (inherited from IDWGImage ).
Public method | LoadFromStream | Loads a CAD drawing from stream. (inherited from IDWGImage ).
Public method | LoadPreviewFromFile | Loads the preview from a file. (inherited from IDWGImage ).
Public method | RefreshCurrentLayout | Refreshes the current layout. (inherited from IDWGImage ).
Public method | ResetDrawingBox | Switches off the drawing box. (inherited from IDWGImage ).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from IDWGImage ).
Public method | RotToView | Rotates the drawing to a specified view. (inherited from IDWGImage ).
Public method | Rotate | Rotates the drawing. (inherited from IDWGImage ).
Public method | SaveToClipboardFormat | Copies the drawing to the clipboard in a specified format. (inherited from IDWGImage ).
Public method | SaveToFile | Saves the drawing to a specified file. (inherited from IDWGImage ).
Public method | SaveToIStream | Writes the drawing data to a specified stream. (inherited from IDWGImage ).
Public method | SaveToStream | Writes the drawing data to a specified stream. (inherited from IDWGImage ).
Public method | SetClippingRect | Sets a clipping rectangle for the drawing. (inherited from IDWGImage ).
Public method | SetExtentsParameters | Changes the drawing extents. (inherited from IDWGImage ).
Public method | StopLoading | Terminates loading of the drawing data. (inherited from IDWGImage ).
Public method | get_Blocks | Retrieves a BLOCK object by its index. (inherited from IDWGImage ).
Public method | get_Entities | Retrieves an entity by its index. (inherited from IDWGImage ).
Public method | get_Items | (inherited from IDWGImage ).
Public method | get_Layouts | Retrieves a layout by its index. (inherited from IDWGImage ).

Top

collall See Also

Reference

DWGImage Interface


IDWGImage.AbsHeight Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.AbsHeight Method

 Return to chapter overview

Show / hide the hidden text

Returns an absolute height of the CAD drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function AbsHeight() As Double

C#

override double AbsHeight()

C++

double AbsHeight()

JScript

function AbsHeight() : double;

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.AbsWidth Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.AbsWidth Method

 Return to chapter overview

Show / hide the hidden text

Returns an absolute width of the CAD drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function AbsWidth() As Double

C#

override double AbsWidth()

C++

double AbsWidth()

JScript

function AbsWidth() : double;

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.AddScaledDXF Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.AddScaledDXF Method

 Return to chapter overview

Show / hide the hidden text

Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AddScaledDXF( _
ByVal ACADFile As DXFImage, _
ByVal AName As String, _
ByVal APos As Point3D, _
ByVal AScale As Point3D, _
ByVal Rotation As Single _
)

C#

override void AddScaledDXF(
DXFImageACADFile,
stringAName,
Point3DAPos,
Point3DAScale,
floatRotation
)

C++

void AddScaledDXF(
DXFImage^ ACADFile,
String^ AName,
Point3D^ APos,
Point3D^ AScale,
floatRotation
)

JScript

function AddScaledDXF(
ACADFile : DXFImage,
AName : String,
APos : Point3D,
AScale : Point3D,
Rotation : float
);

Parameters

ACADFile

DXF image which defines the external reference.

AName

User-defined name for the XREF.

APos

The insertion point.

AScale

3D point which determines the scale factor.

Rotation

XREF rotation angle.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.AddScaledDXFEx Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.AddScaledDXFEx Method

 Return to chapter overview

Show / hide the hidden text

Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function AddScaledDXFEx( _
ByVal ACADFile As DXFImage, _
ByVal AName As String, _
ByVal APos As Point3D, _
ByVal AScale As Point3D, _
ByVal Rotation As Single _
) As Insert

C#

override Insert AddScaledDXFEx(
DXFImage ACADFile,
stringAName,
Point3DAPos,
Point3DAScale,
floatRotation
)

C++

Insert^ AddScaledDXFEx(
DXFImage^ ACADFile,
String^ AName,
Point3D^ APos,
Point3D^ AScale,
floatRotation
)

JScript

function AddScaledDXFEx(
ACADFile : DXFImage,
AName : String,
APos : Point3D,
AScale : Point3D,
Rotation : float
) : Insert;

Parameters

ACADFile

DXF image which defines the external reference.

AName

User-defined name for the XREF.

APos

The insertion point.

AScale

3D point which determines the scale factor.

Rotation

XREF rotation angle.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.AssignImage Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.AssignImage Method

 Return to chapter overview

Show / hide the hidden text

Makes a copy of a specified CAD image object and assigns it to this image.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AssignImage( _
ByVal Source As Object _
)

C#

override void AssignImage(
objectSource
)

C++

void AssignImage(
object^ Source
)

JScript

function AssignImage(
Source : object
);

Parameters

Source

The source CAD image object which will be copied.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.CreateImage Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.CreateImage Method

 Return to chapter overview

Show / hide the hidden text

Initializes a new CAD image instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub CreateImage()

C#

override void CreateImage()

C++

void CreateImage()

JScript

function CreateImage();

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.Draw Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.Draw Method

 Return to chapter overview

Show / hide the hidden text

Draws the CAD image in a specified device context (DC).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub Draw( _
ByVal DC As Integer, _
ByVal Rect As Rect2D _
)

C#

override void Draw(
intDC,
Rect2DRect
)

C++

void Draw(
intDC,
Rect2D^ Rect
)

JScript

function Draw(
DC : int,
Rect : Rect2D
);

Parameters

DC

Handle to the DC.

Rect

Rectangle which defines the drawing area in the DC.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.DrawRect Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.DrawRect Method

 Return to chapter overview

Show / hide the hidden text

Draws a specified region of this CAD image in a device context (DC).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub DrawRect( _
ByVal DC As Integer, _
ByVal SourceRect As Rect3D, _
ByVal DestRect As Rect2D _
)

C#

override void DrawRect(
intDC,
Rect3DSourceRect,
Rect2DDestRect
)

C++

void DrawRect(
intDC,
Rect3D^ SourceRect,
Rect2D^ DestRect
)

JScript

function DrawRect(
DC : int,
SourceRect : Rect3D,
DestRect : Rect2D
);

Parameters

DC

Handle to the DC.

SourceRect

The region which will be drawn in the DC.

DestRect

Rectangle which defines the drawing area in the DC.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.ExportToMetafile Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.ExportToMetafile Method

 Return to chapter overview

Show / hide the hidden text

Exports this CAD image to Windows metafile.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub ExportToMetafile( _
ByVal FileName As String, _
ByVal AWidth As Integer, _
ByVal AHeight As Integer _
)

C#

override void ExportToMetafile(
stringFileName,
intAWidth,
intAHeight
)

C++

void ExportToMetafile(
String^ FileName,
intAWidth,
intAHeight
)

JScript

function ExportToMetafile(
FileName : String,
AWidth : int,
AHeight : int
);

Parameters

FileName

Path to the output metafile.

AWidth

Width of the output metafile.

AHeight

Height of the output metafile.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.FreeImage Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.FreeImage Method

 Return to chapter overview

Show / hide the hidden text

Destroys this CAD image object and frees the memory used within the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub FreeImage()

C#

override void FreeImage()

C++

void FreeImage()

JScript

function FreeImage();

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.GetCADCoords Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.GetCADCoords Method

 Return to chapter overview

Show / hide the hidden text

Returns CAD coordinates for a specified point.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetCADCoords( _
ByVal AXScaled As Double, _
ByVal AYScaled As Double _
) As Point3D

C#

override Point3D GetCADCoords(
doubleAXScaled,
doubleAYScaled
)

C++

Point3D^ GetCADCoords(
doubleAXScaled,
doubleAYScaled
)

JScript

function GetCADCoords(
AXScaled : double,
AYScaled : double
) : Point3D;

Parameters

AXScaled

Ratio between the x-coordinate and the drawing's width.

AYScaled

Ratio between the y-coordinate and the drawing's height.

collall Remarks

The z-coordinate of the returned point is equal 0.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.GetEntityColor Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.GetEntityColor Method

 Return to chapter overview

Show / hide the hidden text

Returns the color value for a specified entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetEntityColor( _
ByVal AEntity As Entity, _
ByVal AInsert As Insert _
) As UInt32

C#

override UInt32 GetEntityColor(
EntityAEntity,
InsertAInsert
)

C++

UInt32 GetEntityColor(
Entity^ AEntity,
Insert^ AInsert
)

JScript

function GetEntityColor(
AEntity : Entity,
AInsert : Insert
) : UInt32;

Parameters

AEntity

The entity whose color is retrieved.

AInsert

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.GetExtents Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.GetExtents Method

 Return to chapter overview

Show / hide the hidden text

Recalculates extents of the CAD image.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub GetExtents()

C#

override void GetExtents()

C++

void GetExtents()

JScript

function GetExtents();

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.GetPoint Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.GetPoint Method

 Return to chapter overview

Show / hide the hidden text

Gets the on-screen coordinates for a specified CAD point.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetPoint( _
ByVal P As Point3D _
) As Point2D

C#

override Point2D GetPoint(
Point3D P
)

C++

Point2D^ GetPoint(
Point3D^ P
)

JScript

function GetPoint(
P : Point3D
) : Point2D;

Parameters

P

CAD point coordinates in the 3D space.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.GetRealImagePoint Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.GetRealImagePoint Method

 Return to chapter overview

Show / hide the hidden text

Returns CAD coordinates of a specified point considering the drawing's rotation and viewport parameters.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetRealImagePoint( _
ByVal P As Point3D _
) As Point3D

C#

override Point3D GetRealImagePoint(
Point3D P
)

C++

Point3D^ GetRealImagePoint(
Point3D^ P
)

JScript

function GetRealImagePoint(
P : Point3D
) : Point3D;

Parameters

P

CAD point in the 3D space.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.HeadVarAsFloat Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.HeadVarAsFloat Method

 Return to chapter overview

Show / hide the hidden text

Returns a value of the DXF header variable as a floating point number.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function HeadVarAsFloat( _
ByVal AName As String, _
ByVal ACode As Integer _
) As Double

C#

override double HeadVarAsFloat(
stringAName,
intACode
)

C++

double HeadVarAsFloat(
String^ AName,
intACode
)

JScript

function HeadVarAsFloat(
AName : String,
ACode : int
) : double;

Parameters

AName

The header variable name.

ACode

Group code associated with the variable's value.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.HeadVarAsInteger Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.HeadVarAsInteger Method

 Return to chapter overview

Show / hide the hidden text

Returns a value of the DXF header variable as an integer.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function HeadVarAsInteger( _
ByVal AName As String, _
ByVal ACode As Integer _
) As Integer

C#

override int HeadVarAsInteger(
stringAName,
intACode
)

C++

int HeadVarAsInteger(
String^ AName,
intACode
)

JScript

function HeadVarAsInteger(
AName : String,
ACode : int
) : int;

Parameters

AName

The header variable name.

ACode

Group code associated with the variable's value.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.HeadVarAsstring Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.HeadVarAsstring Method

 Return to chapter overview

Show / hide the hidden text

Returns a value of the DXF header variable as a string.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function HeadVarAsstring( _
ByVal AName As String, _
ByVal ACode As Integer _
) As String

C#

override string HeadVarAsstring(
stringAName,
intACode
)

C++

String^ HeadVarAsstring(
String^ AName,
intACode
)

JScript

function HeadVarAsstring(
AName : String,
ACode : int
) : String;

Parameters

AName

The header variable name.

ACode

Group code associated with the variable's value.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.LoadFromClipboardFormat Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.LoadFromClipboardFormat Method

 Return to chapter overview

Show / hide the hidden text

Loads data from the clipboard.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub LoadFromClipboardFormat( _
ByVal Fmt As UInt16, _
ByVal Data As Integer, _
ByVal Pal As Integer _
)

C#

override void LoadFromClipboardFormat(
UInt16Fmt,
intData,
intPal
)

C++

void LoadFromClipboardFormat(
UInt16Fmt,
intData,
intPal
)

JScript

function LoadFromClipboardFormat(
Fmt : UInt16,
Data : int,
Pal : int
);

Parameters

Fmt

Data

Pal

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.LoadFromFile Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.LoadFromFile Method

 Return to chapter overview

Show / hide the hidden text

Loads a CAD drawing from file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub LoadFromFile( _
ByVal FileName As String _
)

C#

override void LoadFromFile(
stringFileName
)

C++

void LoadFromFile(
String^ FileName
)

JScript

function LoadFromFile(
FileName : String
);

Parameters

FileName

Path to the drawing file.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.LoadFromIStream Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.LoadFromIStream Method

 Return to chapter overview

Show / hide the hidden text

Loads a CAD drawing from stream.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub LoadFromIStream( _
ByVal Stream As Object _
)

C#

override void LoadFromIStream(
objectStream
)

C++

void LoadFromIStream(
object^ Stream
)

JScript

function LoadFromIStream(
Stream : object
);

Parameters

Stream

Stream which contains the CAD drawing data.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.LoadFromStream Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.LoadFromStream Method

 Return to chapter overview

Show / hide the hidden text

Loads a CAD drawing from stream.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub LoadFromStream( _
ByVal hStream As Integer _
)

C#

override void LoadFromStream(
inthStream
)

C++

void LoadFromStream(
inthStream
)

JScript

function LoadFromStream(
hStream : int
);

Parameters

hStream

Handle to the stream which contains the drawing data.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.LoadPreviewFromFile Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.LoadPreviewFromFile Method

 Return to chapter overview

Show / hide the hidden text

Loads the preview from a file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub LoadPreviewFromFile( _
ByVal FileName As String _
)

C#

void LoadPreviewFromFile(
stringFileName
)

C++

void LoadPreviewFromFile(
String^ FileName
)

JScript

function LoadPreviewFromFile(
FileName : String
);

Parameters

FileName

The file name.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.RefreshCurrentLayout Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.RefreshCurrentLayout Method

 Return to chapter overview

Show / hide the hidden text

Refreshes the current layout.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub RefreshCurrentLayout()

C#

override void RefreshCurrentLayout()

C++

void RefreshCurrentLayout()

JScript

function RefreshCurrentLayout();

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.ResetDrawingBox Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.ResetDrawingBox Method

 Return to chapter overview

Show / hide the hidden text

Switches off the drawing box.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub ResetDrawingBox()

C#

override void ResetDrawingBox()

C++

void ResetDrawingBox()

JScript

function ResetDrawingBox();

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.RotDefault Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.RotDefault Method

 Return to chapter overview

Show / hide the hidden text

Rotates the drawing to the default view.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub RotDefault()

C#

override void RotDefault()

C++

void RotDefault()

JScript

function RotDefault();

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.RotToView Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.RotToView Method

 Return to chapter overview

Show / hide the hidden text

Rotates the drawing to a specified view.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub RotToView( _
ByVal A3DView As TxDXFViewDirection _
)

C#

override void RotToView(
TxDXFViewDirectionA3DView
)

C++

void RotToView(
TxDXFViewDirectionA3DView
)

JScript

function RotToView(
A3DView : TxDXFViewDirection
);

Parameters

A3DView

One of the orthogonal or isometric views.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.Rotate Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.Rotate Method

 Return to chapter overview

Show / hide the hidden text

Rotates the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub Rotate( _
ByVal Axis As TxAxes, _
ByVal Angle As Double _
)

C#

override void Rotate(
TxAxesAxis,
doubleAngle
)

C++

void Rotate(
TxAxesAxis,
doubleAngle
)

JScript

function Rotate(
Axis : TxAxes,
Angle : double
);

Parameters

Axis

Rotation axis.

Angle

Rotation angle (measured in degrees).

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.SaveToClipboardFormat Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.SaveToClipboardFormat Method

 Return to chapter overview

Show / hide the hidden text

Copies the drawing to the clipboard in a specified format.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SaveToClipboardFormat( _
ByRef Fmt As UInt16, _
ByRef Data As Integer, _
ByRef Pal As Integer _
)

C#

override void SaveToClipboardFormat(
ref UInt16Fmt,
ref intData,
ref intPal
)

C++

void SaveToClipboardFormat(
UInt16& Fmt,
int& Data,
int& Pal
)

JScript

function SaveToClipboardFormat(
Fmt : UInt16,
Data : int,
Pal : int
);

Parameters

Fmt

Clipboard format.

Data

Pal

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.SaveToFile Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.SaveToFile Method

 Return to chapter overview

Show / hide the hidden text

Saves the drawing to a specified file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SaveToFile( _
ByVal FileName As String _
)

C#

override void SaveToFile(
stringFileName
)

C++

void SaveToFile(
String^ FileName
)

JScript

function SaveToFile(
FileName : String
);

Parameters

FileName

Path to the output file.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.SaveToIStream Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.SaveToIStream Method

 Return to chapter overview

Show / hide the hidden text

Writes the drawing data to a specified stream.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SaveToIStream( _
ByVal Stream As Object _
)

C#

override void SaveToIStream(
objectStream
)

C++

void SaveToIStream(
object^ Stream
)

JScript

function SaveToIStream(
Stream : object
);

Parameters

Stream

Stream where the drawing data is written.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.SaveToStream Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.SaveToStream Method

 Return to chapter overview

Show / hide the hidden text

Writes the drawing data to a specified stream.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SaveToStream( _
ByVal Stream As Integer _
)

C#

override void SaveToStream(
intStream
)

C++

void SaveToStream(
intStream
)

JScript

function SaveToStream(
Stream : int
);

Parameters

Stream

Stream where the drawing data will be written.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.SetClippingRect Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.SetClippingRect Method

 Return to chapter overview

Show / hide the hidden text

Sets a clipping rectangle for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetClippingRect( _
ByVal Value As Rect3D _
)

C#

override void SetClippingRect(
Rect3DValue
)

C++

void SetClippingRect(
Rect3D^ Value
)

JScript

function SetClippingRect(
Value : Rect3D
);

Parameters

Value

The clipping rectangle area.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.SetExtentsParameters Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.SetExtentsParameters Method

 Return to chapter overview

Show / hide the hidden text

Changes the drawing extents.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetExtentsParameters( _
ByVal ARect As Rect3D, _
ByVal AIs3DExtents As Boolean _
)

C#

override void SetExtentsParameters(
Rect3DARect,
boolAIs3DExtents
)

C++

void SetExtentsParameters(
Rect3D^ ARect,
boolAIs3DExtents
)

JScript

function SetExtentsParameters(
ARect : Rect3D,
AIs3DExtents : boolean
);

Parameters

ARect

The parallelepiped which defines the extents.

AIs3DExtents

If set to true, then the extents are 3D; otherwise, the extents are 2D.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.StopLoading Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.StopLoading Method

 Return to chapter overview

Show / hide the hidden text

Terminates loading of the drawing data.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub StopLoading()

C#

override void StopLoading()

C++

void StopLoading()

JScript

function StopLoading();

collall Remarks

The portion of the drawing data which was loaded can be displayed in the control.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.get_Blocks Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.get_Blocks Method

 Return to chapter overview

Show / hide the hidden text

Retrieves a BLOCK object by its index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Blocks( _
ByVal Index As Integer _
) As Block

C#

override Block get_Blocks(
intIndex
)

C++

Block^ get_Blocks(
intIndex
)

JScript

function get_Blocks(
Index : int
) : Block;

Parameters

Index

Index of the block.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.get_Entities Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.get_Entities Method

 Return to chapter overview

Show / hide the hidden text

Retrieves an entity by its index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Entities( _
ByVal Index As Integer _
) As Entity

C#

override Entity get_Entities(
intIndex
)

C++

Entity^ get_Entities(
intIndex
)

JScript

function get_Entities(
Index : int
) : Entity;

Parameters

Index

Index of the entity.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.get_Items Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.get_Items Method

 Return to chapter overview

Show / hide the hidden text

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Items( _
ByVal Index As Integer _
) As DXFImage

C#

override DXFImage get_Items(
intIndex
)

C++

DXFImage^ get_Items(
intIndex
)

JScript

function get_Items(
Index : int
) : DXFImage;

Parameters

Index

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


IDWGImage.get_Layouts Method

API Reference > CADViewLib Namespace > DWGImage Interface > Methods >

IDWGImage.get_Layouts Method

 Return to chapter overview

Show / hide the hidden text

Retrieves a layout by its index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Layouts( _
ByVal Index As Integer _
) As Layout

C#

override Layout get_Layouts(
intIndex
)

C++

Layout^ get_Layouts(
intIndex
)

JScript

function get_Layouts(
Index : int
) : Layout;

Parameters

Index

Index of the layout.

collall See Also

Reference

IDWGImage Interface
IDWGImage IDWGImage Members


DXFImage Interface

API Reference > CADViewLib Namespace >

DXFImage Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to a DXF drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface DXFImage
Inherits IDXFImage, _
IDXFImageEvents_Event

C#

public interface DXFImage : IDXFImage,
IDXFImageEvents_Event

C++

public interface class DXFImage : public IDXFImage^,
public IDXFImageEvents_Event^

JScript

public interface DXFImage
implements IDXFImage,
IDXFImageEvents_Event

collall See Also

Reference

DXFImage Members


DXFImage Members

API Reference > CADViewLib Namespace > DXFImage Interface >

DXFImage Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to a DXF drawing.

The following tables list the members exposed by the DXFImage type.

collall Public Properties

 | Name | Description
Public property | BackGroundColor | Gets or sets a background color for the drawing. (inherited from IDXFImage ).
Public property | BorderSize | Gets or sets a border size for the drawing. (inherited from IDXFImage ).
Public property | BorderType | Gets or sets a way the drawing's border size is defined (global or ratio). (inherited from IDXFImage ).
Public property | CADClassID | Gets the CAD format identifier for the drawing. (inherited from IDXFImage ).
Public property | CBFormat | Gets or sets the clipboard format. (inherited from IDXFImage ).
Public property | CanStopLoading | Gets a value indicating whether the loading of the drawing data can be terminated. (inherited from IDXFImage ).
Public property | Charset | Gets or sets a character set for the text entities. (inherited from IDXFImage ).
Public property | ColorToLineWeight | Gets or sets a string which contains the color-lineweight pairs. (inherited from IDXFImage ).
Public property | Converter | Gets or sets a Converter associated with this image object. (inherited from IDXFImage ).
Public property | Count | Gets a number of entities in the drawing. (inherited from IDXFImage ).
Public property | CurrentLayout | Gets or sets the current layout for the drawing. (inherited from IDXFImage ).
Public property | DefaultColor | Gets or sets the default color for the drawing. (inherited from IDXFImage ).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions in the drawing are visible. (inherited from IDXFImage ).
Public property | DrawMode | Gets or sets an appearance of colors in the drawing. (inherited from IDXFImage ).
Public property | DrawingBox | Gets or sets the drawing bounding box. (inherited from IDXFImage ).
Public property | Empty | Gets a value indicating whether the drawing is empty. (inherited from IDXFImage ).
Public property | Extents | Gets or sets the drawing's extents. (inherited from IDXFImage ).
Public property | Height | Gets or sets a height of the drawing. (inherited from IDXFImage ).
Public property | Is3D | Gets a value indicating whether the drawing is three-dimensional. (inherited from IDXFImage ).
Public property | IsDraw3DAxes | Gets a value indicating whether 3D axes are visible on the drawing. (inherited from IDXFImage ).
Public property | IsDrawingRotated | Gets a value indicating whether the drawing is rotated. (inherited from IDXFImage ).
Public property | IsLoading | Gets a value indicating whether the process of loading the drawing data is active. (inherited from IDXFImage ).
Public property | IsPlotting | Gets or sets a value indicating whether to plot the image or not. (inherited from IDXFImage ).
Public property | IsProcessMessages | Gets or sets a value indicating whether the messages processing is allowed. (inherited from IDXFImage ).
Public property | IsShowBackground | Gets or sets a value indicating whether the backround is displayed. (inherited from IDXFImage ).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines is determined by the drawing data. (inherited from IDXFImage ).
Public property | IsWithoutBorder | Gets or sets a value indicating whether to display the drawing without borders. (inherited from IDXFImage ).
Public property | LayoutsCount | Gets the number of layouts in the drawing. (inherited from IDXFImage ).
Public property | LineScaled | Gets or sets a value indicating whether the line weight is diplayed. (inherited from IDXFImage ).
Public property | LineWeightScale | Gets or sets a scale for line weights. (inherited from IDXFImage ).
Public property | Millimetres | Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file. (inherited from IDXFImage ).
Public property | Modified | Gets or sets a value indicating whether the drawing is modified. (inherited from IDXFImage ).
Public property | NullWidth | Gets or sets a thickness for lines which have the zero lineweight. (inherited from IDXFImage ).
Public property | OwnSource | For internal use. (inherited from IDXFImage ).
Public property | PureExtents | Gets the drawing's extents excluding the borders. (inherited from IDXFImage ).
Public property | ResizeDisproportionateDrawing | Gets or sets a value indicating whether to resize a drawing with disproportionate sizes. (inherited from IDXFImage ).
Public property | Scale | Gets or sets a 3D point which defines the scale factor. (inherited from IDXFImage ).
Public property | ShowImages | Gets or sets a value indicating whether the raster images are displayed. (inherited from IDXFImage ).
Public property | Stretch | Gets or sets a value indicating whether the displayed image has to be stretched to fit exactly with the drawing rectangle. (inherited from IDXFImage ).
Public property | TextVisible | Gets or sets a value indicating whether texts in the drawing are visible. (inherited from IDXFImage ).
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles are drawn by using GDI+ methods without linearization. (inherited from IDXFImage ).
Public property | ViewRectangle | For internal use. (inherited from IDXFImage ).
Public property | Width | Gets or sets a width of the drawing. (inherited from IDXFImage ).

Top

collall Public Methods

 | Name | Description
Public method | AbsHeight | Returns an absolute height of the CAD drawing. (inherited from IDXFImage ).
Public method | AbsWidth | Returns an absolute width of the CAD drawing. (inherited from IDXFImage ).
Public method | AddScaledDXF | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing. (inherited from IDXFImage ).
Public method | AddScaledDXFEx | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing. (inherited from IDXFImage ).
Public method | AssignImage | Makes a copy of a specified CAD image object and assigns it to this image. (inherited from IDXFImage ).
Public method | CreateImage | Initializes a new CAD image instance. (inherited from IDXFImage ).
Public method | Draw | Draws the CAD image in a specified device context (DC). (inherited from IDXFImage ).
Public method | DrawRect | Draws a specified region of this CAD image in a device context (DC). (inherited from IDXFImage ).
Public method | ExportToMetafile | Exports this CAD image to Windows metafile. (inherited from IDXFImage ).
Public method | FreeImage | Destroys this CAD image object and frees the memory used within the object. (inherited from IDXFImage ).
Public method | GetCADCoords | Returns CAD coordinates for a specified point. (inherited from IDXFImage ).
Public method | GetEntityColor | Returns the color value for a specified entity. (inherited from IDXFImage ).
Public method | GetExtents | Recalculates extents of the CAD image. (inherited from IDXFImage ).
Public method | GetPoint | Gets the on-screen coordinates for a specified CAD point. (inherited from IDXFImage ).
Public method | GetRealImagePoint | Returns CAD coordinates of a specified point considering the drawing's rotation and viewport parameters. (inherited from IDXFImage ).
Public method | HeadVarAsFloat | Returns a value of the DXF header variable as a floating point number. (inherited from IDXFImage ).
Public method | HeadVarAsInteger | Returns a value of the DXF header variable as an integer. (inherited from IDXFImage ).
Public method | HeadVarAsstring | Returns a value of the DXF header variable as a string. (inherited from IDXFImage ).
Public method | LoadFromClipboardFormat | Loads data from the clipboard. (inherited from IDXFImage ).
Public method | LoadFromFile | Loads a CAD drawing from file. (inherited from IDXFImage ).
Public method | LoadFromIStream | Loads a CAD drawing from stream. (inherited from IDXFImage ).
Public method | LoadFromStream | Loads a CAD drawing from stream. (inherited from IDXFImage ).
Public method | RefreshCurrentLayout | Refreshes the current layout. (inherited from IDXFImage ).
Public method | ResetDrawingBox | Switches off the drawing box. (inherited from IDXFImage ).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from IDXFImage ).
Public method | RotToView | Rotates the drawing to a specified view. (inherited from IDXFImage ).
Public method | Rotate | Rotates the drawing. (inherited from IDXFImage ).
Public method | SaveToClipboardFormat | Copies the drawing to the clipboard in a specified format. (inherited from IDXFImage ).
Public method | SaveToFile | Saves the drawing to a specified file. (inherited from IDXFImage ).
Public method | SaveToIStream | Writes the drawing data to a specified stream. (inherited from IDXFImage ).
Public method | SaveToStream | Writes the drawing data to a specified stream. (inherited from IDXFImage ).
Public method | SetClippingRect | Sets a clipping rectangle for the drawing. (inherited from IDXFImage ).
Public method | SetExtentsParameters | Changes the drawing extents. (inherited from IDXFImage ).
Public method | StopLoading | Terminates loading of the drawing data. (inherited from IDXFImage ).
Public method | get_Blocks | Retrieves a BLOCK object by its index. (inherited from IDXFImage ).
Public method | get_Entities | Retrieves an entity by its index. (inherited from IDXFImage ).
Public method | get_Items | (inherited from IDXFImage ).
Public method | get_Layouts | Retrieves a layout by its index. (inherited from IDXFImage ).

Top

collall See Also

Reference

DXFImage Interface


DXFImage Properties

API Reference > CADViewLib Namespace > DXFImage Interface >

DXFImage Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | BackGroundColor | Gets or sets a background color for the drawing. (inherited from IDXFImage ).
Public property | BorderSize | Gets or sets a border size for the drawing. (inherited from IDXFImage ).
Public property | BorderType | Gets or sets a way the drawing's border size is defined (global or ratio). (inherited from IDXFImage ).
Public property | CADClassID | Gets the CAD format identifier for the drawing. (inherited from IDXFImage ).
Public property | CBFormat | Gets or sets the clipboard format. (inherited from IDXFImage ).
Public property | CanStopLoading | Gets a value indicating whether the loading of the drawing data can be terminated. (inherited from IDXFImage ).
Public property | Charset | Gets or sets a character set for the text entities. (inherited from IDXFImage ).
Public property | ColorToLineWeight | Gets or sets a string which contains the color-lineweight pairs. (inherited from IDXFImage ).
Public property | Converter | Gets or sets a Converter associated with this image object. (inherited from IDXFImage ).
Public property | Count | Gets a number of entities in the drawing. (inherited from IDXFImage ).
Public property | CurrentLayout | Gets or sets the current layout for the drawing. (inherited from IDXFImage ).
Public property | DefaultColor | Gets or sets the default color for the drawing. (inherited from IDXFImage ).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions in the drawing are visible. (inherited from IDXFImage ).
Public property | DrawMode | Gets or sets an appearance of colors in the drawing. (inherited from IDXFImage ).
Public property | DrawingBox | Gets or sets the drawing bounding box. (inherited from IDXFImage ).
Public property | Empty | Gets a value indicating whether the drawing is empty. (inherited from IDXFImage ).
Public property | Extents | Gets or sets the drawing's extents. (inherited from IDXFImage ).
Public property | Height | Gets or sets a height of the drawing. (inherited from IDXFImage ).
Public property | Is3D | Gets a value indicating whether the drawing is three-dimensional. (inherited from IDXFImage ).
Public property | IsDraw3DAxes | Gets a value indicating whether 3D axes are visible on the drawing. (inherited from IDXFImage ).
Public property | IsDrawingRotated | Gets a value indicating whether the drawing is rotated. (inherited from IDXFImage ).
Public property | IsLoading | Gets a value indicating whether the process of loading the drawing data is active. (inherited from IDXFImage ).
Public property | IsPlotting | Gets or sets a value indicating whether to plot the image or not. (inherited from IDXFImage ).
Public property | IsProcessMessages | Gets or sets a value indicating whether the messages processing is allowed. (inherited from IDXFImage ).
Public property | IsShowBackground | Gets or sets a value indicating whether the backround is displayed. (inherited from IDXFImage ).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines is determined by the drawing data. (inherited from IDXFImage ).
Public property | IsWithoutBorder | Gets or sets a value indicating whether to display the drawing without borders. (inherited from IDXFImage ).
Public property | LayoutsCount | Gets the number of layouts in the drawing. (inherited from IDXFImage ).
Public property | LineScaled | Gets or sets a value indicating whether the line weight is diplayed. (inherited from IDXFImage ).
Public property | LineWeightScale | Gets or sets a scale for line weights. (inherited from IDXFImage ).
Public property | Millimetres | Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file. (inherited from IDXFImage ).
Public property | Modified | Gets or sets a value indicating whether the drawing is modified. (inherited from IDXFImage ).
Public property | NullWidth | Gets or sets a thickness for lines which have the zero lineweight. (inherited from IDXFImage ).
Public property | OwnSource | For internal use. (inherited from IDXFImage ).
Public property | PureExtents | Gets the drawing's extents excluding the borders. (inherited from IDXFImage ).
Public property | ResizeDisproportionateDrawing | Gets or sets a value indicating whether to resize a drawing with disproportionate sizes. (inherited from IDXFImage ).
Public property | Scale | Gets or sets a 3D point which defines the scale factor. (inherited from IDXFImage ).
Public property | ShowImages | Gets or sets a value indicating whether the raster images are displayed. (inherited from IDXFImage ).
Public property | Stretch | Gets or sets a value indicating whether the displayed image has to be stretched to fit exactly with the drawing rectangle. (inherited from IDXFImage ).
Public property | TextVisible | Gets or sets a value indicating whether texts in the drawing are visible. (inherited from IDXFImage ).
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles are drawn by using GDI+ methods without linearization. (inherited from IDXFImage ).
Public property | ViewRectangle | For internal use. (inherited from IDXFImage ).
Public property | Width | Gets or sets a width of the drawing. (inherited from IDXFImage ).

Top

collall See Also

Reference

DXFImage Interface


IDXFImage.BackGroundColor Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.BackGroundColor Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a background color for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property BackGroundColor() As UInt32

C#

UInt32 BackGroundColor {get; set;}

C++

property UInt32 BackGroundColor {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get BackGroundColor() : UInt32;
function set BackGroundColor(value : UInt32);

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.BorderSize Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.BorderSize Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a border size for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property BorderSize() As Double

C#

double BorderSize {get; set;}

C++

property double BorderSize {
double get( );
void set(
double value
);
}

JScript

function get BorderSize() : double;
function set BorderSize(value : double);

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.BorderType Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.BorderType Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a way the drawing's border size is defined (global or ratio).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property BorderType() As TxsgBorderType

C#

TxsgBorderType BorderType {get; set;}

C++

property TxsgBorderType BorderType {
TxsgBorderType get( );
void set(
TxsgBorderType value
);
}

JScript

function get BorderType() : TxsgBorderType;
function set BorderType(value : TxsgBorderType);

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.CADClassID Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.CADClassID Property

 Return to chapter overview

Show / hide the hidden text

Gets the CAD format identifier for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property CADClassID() As TxCADClassID

C#

TxCADClassID CADClassID {get;}

C++

property TxCADClassID CADClassID {
TxCADClassID get( );
}

JScript

function get CADClassID() : TxCADClassID;

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.CBFormat Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.CBFormat Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the clipboard format.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CBFormat() As UInt16

C#

UInt16 CBFormat {get; set;}

C++

property UInt16 CBFormat {
UInt16 get( );
void set(
UInt16 value
);
}

JScript

function get CBFormat() : UInt16;
function set CBFormat(value : UInt16);

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.CanStopLoading Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.CanStopLoading Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the loading of the drawing data can be terminated.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property CanStopLoading() As Boolean

C#

bool CanStopLoading {get;}

C++

property bool CanStopLoading {
bool get( );
}

JScript

function get CanStopLoading() : boolean;

Property Value

true if the loading can be terminated; otherwise, false.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.Charset Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.Charset Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a character set for the text entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Charset() As Byte

C#

byte Charset {get; set;}

C++

property Byte Charset {
Byte get( );
void set(
Byte value
);
}

JScript

function get Charset() : byte;
function set Charset(value : byte);

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.ColorToLineWeight Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.ColorToLineWeight Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a string which contains the color-lineweight pairs.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property ColorToLineWeight() As String

C#

string ColorToLineWeight {get; set;}

C++

property String^ ColorToLineWeight {
String^ get( );
void set(
String^ value
);
}

JScript

function get ColorToLineWeight() : String;
function set ColorToLineWeight(value : String);

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.Converter Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.Converter Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a Converter associated with this image object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Converter() As Converter

C#

Converter Converter {get;}

C++

property Converter^ Converter {
Converter^ get( );
}

JScript

function get Converter() : Converter;

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.Count Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.Count Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of entities in the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Count() As Integer

C#

int Count {get;}

C++

property int Count {
int get( );
}

JScript

function get Count() : int;

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.CurrentLayout Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.CurrentLayout Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the current layout for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CurrentLayout() As Layout

C#

Layout CurrentLayout {get; set;}

C++

property Layout^ CurrentLayout {
Layout^ get( );
void set(
Layout^ value
);
}

JScript

function get CurrentLayout() : Layout;
function set CurrentLayout(value : Layout);

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.DefaultColor Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.DefaultColor Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the default color for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DefaultColor() As UInt32

C#

UInt32 DefaultColor {get; set;}

C++

property UInt32 DefaultColor {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get DefaultColor() : UInt32;
function set DefaultColor(value : UInt32);

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.DimensionsVisible Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.DimensionsVisible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether dimensions in the drawing are visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DimensionsVisible() As Boolean

C#

bool DimensionsVisible {get; set;}

C++

property bool DimensionsVisible {
bool get( );
void set(
bool value
);
}

JScript

function get DimensionsVisible() : boolean;
function set DimensionsVisible(value : boolean);

Property Value

true if the dimensions are visible; otherwise, false. Default value is true.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.DrawMode Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.DrawMode Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets an appearance of colors in the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DrawMode() As TxDXFDrawMode

C#

TxDXFDrawMode DrawMode {get; set;}

C++

property TxDXFDrawMode DrawMode {
TxDXFDrawMode get( );
void set(
TxDXFDrawMode value
);
}

JScript

function get DrawMode() : TxDXFDrawMode;
function set DrawMode(value : TxDXFDrawMode);

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.DrawingBox Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.DrawingBox Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the drawing bounding box.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DrawingBox() As Rect3D

C#

Rect3D DrawingBox {get; set;}

C++

property Rect3D^ DrawingBox {
Rect3D^ get( );
void set(
Rect3D^ value
);
}

JScript

function get DrawingBox() : Rect3D;
function set DrawingBox(value : Rect3D);

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.Empty Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.Empty Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the drawing is empty.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Empty() As Boolean

C#

bool Empty {get;}

C++

property bool Empty {
bool get( );
}

JScript

function get Empty() : boolean;

Property Value

true if the drawing is empty; otherwise, false.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.Extents Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.Extents Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the drawing's extents.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Extents() As Rect3D

C#

Rect3D Extents {get; set;}

C++

property Rect3D^ Extents {
Rect3D^ get( );
void set(
Rect3D^ value
);
}

JScript

function get Extents() : Rect3D;
function set Extents(value : Rect3D);

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.Height Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.Height Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a height of the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Height() As Integer

C#

int Height {get; set;}

C++

property int Height {
int get( );
void set(
int value
);
}

JScript

function get Height() : int;
function set Height(value : int);

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.Is3D Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.Is3D Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the drawing is three-dimensional.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Is3D() As Boolean

C#

bool Is3D {get; set;}

C++

property bool Is3D {
bool get( );
void set(
bool value
);
}

JScript

function get Is3D() : boolean;
function set Is3D(value : boolean);

Property Value

true if the drawing is three-dimensional; otherwise, false.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.IsDraw3DAxes Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.IsDraw3DAxes Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether 3D axes are visible on the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsDraw3DAxes() As Boolean

C#

bool IsDraw3DAxes {get; set;}

C++

property bool IsDraw3DAxes {
bool get( );
void set(
bool value
);
}

JScript

function get IsDraw3DAxes() : boolean;
function set IsDraw3DAxes(value : boolean);

Property Value

true if the 3D axes are visible; otherwise, false.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.IsDrawingRotated Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.IsDrawingRotated Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the drawing is rotated.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsDrawingRotated() As Boolean

C#

bool IsDrawingRotated {get;}

C++

property bool IsDrawingRotated {
bool get( );
}

JScript

function get IsDrawingRotated() : boolean;

Property Value

true if the drawing is rotated; otherwise, false.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.IsLoading Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.IsLoading Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the process of loading the drawing data is active.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsLoading() As Boolean

C#

bool IsLoading {get;}

C++

property bool IsLoading {
bool get( );
}

JScript

function get IsLoading() : boolean;

Property Value

true if the drawing data is loading into this image object; otherwise, false.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.IsPlotting Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.IsPlotting Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether to plot the image or not.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsPlotting() As Boolean

C#

bool IsPlotting {get; set;}

C++

property bool IsPlotting {
bool get( );
void set(
bool value
);
}

JScript

function get IsPlotting() : boolean;
function set IsPlotting(value : boolean);

Property Value

true if the image should be plotted; otherwise, false.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.IsProcessMessages Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.IsProcessMessages Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the messages processing is allowed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsProcessMessages() As Boolean

C#

bool IsProcessMessages {get; set;}

C++

property bool IsProcessMessages {
bool get( );
void set(
bool value
);
}

JScript

function get IsProcessMessages() : boolean;
function set IsProcessMessages(value : boolean);

Property Value

true if the messages processing is allowed; otherwise, false.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.IsShowBackground Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.IsShowBackground Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the backround is displayed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsShowBackground() As Boolean

C#

bool IsShowBackground {get; set;}

C++

property bool IsShowBackground {
bool get( );
void set(
bool value
);
}

JScript

function get IsShowBackground() : boolean;
function set IsShowBackground(value : boolean);

Property Value

true if the backround is displayed; otherwise, false.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.IsShowLineWeight Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.IsShowLineWeight Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether a thickness of lines is determined by the drawing data.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsShowLineWeight() As Boolean

C#

bool IsShowLineWeight {get; set;}

C++

property bool IsShowLineWeight {
bool get( );
void set(
bool value
);
}

JScript

function get IsShowLineWeight() : boolean;
function set IsShowLineWeight(value : boolean);

Property Value

true if a thickness of lines is determined by the drawing data; otherwise, false.

collall Remarks

If this property value is false, a thickness of lines is determined by the NullWidth property.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.IsWithoutBorder Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.IsWithoutBorder Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether to display the drawing without borders.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsWithoutBorder() As Boolean

C#

bool IsWithoutBorder {get; set;}

C++

property bool IsWithoutBorder {
bool get( );
void set(
bool value
);
}

JScript

function get IsWithoutBorder() : boolean;
function set IsWithoutBorder(value : boolean);

Property Value

true if the borders are not displayed; otherwise, false.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.LayoutsCount Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.LayoutsCount Property

 Return to chapter overview

Show / hide the hidden text

Gets the number of layouts in the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property LayoutsCount() As Integer

C#

int LayoutsCount {get;}

C++

property int LayoutsCount {
int get( );
}

JScript

function get LayoutsCount() : int;

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.LineScaled Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.LineScaled Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the line weight is diplayed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineScaled() As Boolean

C#

bool LineScaled {get; set;}

C++

property bool LineScaled {
bool get( );
void set(
bool value
);
}

JScript

function get LineScaled() : boolean;
function set LineScaled(value : boolean);

Property Value

true if the line weight is displayed; otherwise, false.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.LineWeightScale Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.LineWeightScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a scale for line weights.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineWeightScale() As Double

C#

double LineWeightScale {get; set;}

C++

property double LineWeightScale {
double get( );
void set(
double value
);
}

JScript

function get LineWeightScale() : double;
function set LineWeightScale(value : double);

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.Millimetres Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.Millimetres Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Millimetres() As Boolean

C#

bool Millimetres {get; set;}

C++

property bool Millimetres {
bool get( );
void set(
bool value
);
}

JScript

function get Millimetres() : boolean;
function set Millimetres(value : boolean);

Property Value

true if the drawing units are millimeters; false if the drawing units are inches.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.Modified Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.Modified Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the drawing is modified.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Modified() As Boolean

C#

bool Modified {get; set;}

C++

property bool Modified {
bool get( );
void set(
bool value
);
}

JScript

function get Modified() : boolean;
function set Modified(value : boolean);

Property Value

true if the drawing is modified; otherwise, false.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.NullWidth Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.NullWidth Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a thickness for lines which have the zero lineweight.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property NullWidth() As Integer

C#

int NullWidth {get; set;}

C++

property int NullWidth {
int get( );
void set(
int value
);
}

JScript

function get NullWidth() : int;
function set NullWidth(value : int);

Property Value

Line thickness. Default value is 1.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.OwnSource Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.OwnSource Property

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property OwnSource() As Boolean

C#

bool OwnSource {get; set;}

C++

property bool OwnSource {
bool get( );
void set(
bool value
);
}

JScript

function get OwnSource() : boolean;
function set OwnSource(value : boolean);

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.PureExtents Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.PureExtents Property

 Return to chapter overview

Show / hide the hidden text

Gets the drawing's extents excluding the borders.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property PureExtents() As Rect3D

C#

Rect3D PureExtents {get;}

C++

property Rect3D^ PureExtents {
Rect3D^ get( );
}

JScript

function get PureExtents() : Rect3D;

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.ResizeDisproportionateDrawing Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.ResizeDisproportionateDrawing Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether to resize a drawing with disproportionate sizes.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property ResizeDisproportionateDrawing() As Boolean

C#

bool ResizeDisproportionateDrawing {get; set;}

C++

property bool ResizeDisproportionateDrawing {
bool get( );
void set(
bool value
);
}

JScript

function get ResizeDisproportionateDrawing() : boolean;
function set ResizeDisproportionateDrawing(value : boolean);

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.Scale Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.Scale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a 3D point which defines the scale factor.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Scale() As Point3D

C#

Point3D Scale {get;}

C++

property Point3D^ Scale {
Point3D^ get( );
}

JScript

function get Scale() : Point3D;

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.ShowImages Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.ShowImages Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the raster images are displayed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property ShowImages() As Boolean

C#

bool ShowImages {get; set;}

C++

property bool ShowImages {
bool get( );
void set(
bool value
);
}

JScript

function get ShowImages() : boolean;
function set ShowImages(value : boolean);

Property Value

true if the raster images are displayed; overwise, false.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.Stretch Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.Stretch Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the displayed image has to be stretched to fit exactly with the drawing rectangle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Stretch() As Boolean

C#

bool Stretch {get; set;}

C++

property bool Stretch {
bool get( );
void set(
bool value
);
}

JScript

function get Stretch() : boolean;
function set Stretch(value : boolean);

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.TextVisible Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.TextVisible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether texts in the drawing are visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property TextVisible() As Boolean

C#

bool TextVisible {get; set;}

C++

property bool TextVisible {
bool get( );
void set(
bool value
);
}

JScript

function get TextVisible() : boolean;
function set TextVisible(value : boolean);

Property Value

true if the texts are visible; otherwise, false.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.UseWinEllipse Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.UseWinEllipse Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether arcs and circles are drawn by using GDI+ methods without linearization.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property UseWinEllipse() As Boolean

C#

bool UseWinEllipse {get; set;}

C++

property bool UseWinEllipse {
bool get( );
void set(
bool value
);
}

JScript

function get UseWinEllipse() : boolean;
function set UseWinEllipse(value : boolean);

Property Value

true if the GDI+ methods are used for drawing arcs and circles; otherwise, false.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.ViewRectangle Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.ViewRectangle Property

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property ViewRectangle() As Rect3D

C#

Rect3D ViewRectangle {get; set;}

C++

property Rect3D^ ViewRectangle {
Rect3D^ get( );
void set(
Rect3D^ value
);
}

JScript

function get ViewRectangle() : Rect3D;
function set ViewRectangle(value : Rect3D);

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.Width Property

API Reference > CADViewLib Namespace > DXFImage Interface > Properties >

IDXFImage.Width Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a width of the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Width() As Integer

C#

int Width {get; set;}

C++

property int Width {
int get( );
void set(
int value
);
}

JScript

function get Width() : int;
function set Width(value : int);

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


DXFImage Methods

API Reference > CADViewLib Namespace > DXFImage Interface >

DXFImage Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AbsHeight | Returns an absolute height of the CAD drawing. (inherited from IDXFImage ).
Public method | AbsWidth | Returns an absolute width of the CAD drawing. (inherited from IDXFImage ).
Public method | AddScaledDXF | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing. (inherited from IDXFImage ).
Public method | AddScaledDXFEx | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing. (inherited from IDXFImage ).
Public method | AssignImage | Makes a copy of a specified CAD image object and assigns it to this image. (inherited from IDXFImage ).
Public method | CreateImage | Initializes a new CAD image instance. (inherited from IDXFImage ).
Public method | Draw | Draws the CAD image in a specified device context (DC). (inherited from IDXFImage ).
Public method | DrawRect | Draws a specified region of this CAD image in a device context (DC). (inherited from IDXFImage ).
Public method | ExportToMetafile | Exports this CAD image to Windows metafile. (inherited from IDXFImage ).
Public method | FreeImage | Destroys this CAD image object and frees the memory used within the object. (inherited from IDXFImage ).
Public method | GetCADCoords | Returns CAD coordinates for a specified point. (inherited from IDXFImage ).
Public method | GetEntityColor | Returns the color value for a specified entity. (inherited from IDXFImage ).
Public method | GetExtents | Recalculates extents of the CAD image. (inherited from IDXFImage ).
Public method | GetPoint | Gets the on-screen coordinates for a specified CAD point. (inherited from IDXFImage ).
Public method | GetRealImagePoint | Returns CAD coordinates of a specified point considering the drawing's rotation and viewport parameters. (inherited from IDXFImage ).
Public method | HeadVarAsFloat | Returns a value of the DXF header variable as a floating point number. (inherited from IDXFImage ).
Public method | HeadVarAsInteger | Returns a value of the DXF header variable as an integer. (inherited from IDXFImage ).
Public method | HeadVarAsstring | Returns a value of the DXF header variable as a string. (inherited from IDXFImage ).
Public method | LoadFromClipboardFormat | Loads data from the clipboard. (inherited from IDXFImage ).
Public method | LoadFromFile | Loads a CAD drawing from file. (inherited from IDXFImage ).
Public method | LoadFromIStream | Loads a CAD drawing from stream. (inherited from IDXFImage ).
Public method | LoadFromStream | Loads a CAD drawing from stream. (inherited from IDXFImage ).
Public method | RefreshCurrentLayout | Refreshes the current layout. (inherited from IDXFImage ).
Public method | ResetDrawingBox | Switches off the drawing box. (inherited from IDXFImage ).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from IDXFImage ).
Public method | RotToView | Rotates the drawing to a specified view. (inherited from IDXFImage ).
Public method | Rotate | Rotates the drawing. (inherited from IDXFImage ).
Public method | SaveToClipboardFormat | Copies the drawing to the clipboard in a specified format. (inherited from IDXFImage ).
Public method | SaveToFile | Saves the drawing to a specified file. (inherited from IDXFImage ).
Public method | SaveToIStream | Writes the drawing data to a specified stream. (inherited from IDXFImage ).
Public method | SaveToStream | Writes the drawing data to a specified stream. (inherited from IDXFImage ).
Public method | SetClippingRect | Sets a clipping rectangle for the drawing. (inherited from IDXFImage ).
Public method | SetExtentsParameters | Changes the drawing extents. (inherited from IDXFImage ).
Public method | StopLoading | Terminates loading of the drawing data. (inherited from IDXFImage ).
Public method | get_Blocks | Retrieves a BLOCK object by its index. (inherited from IDXFImage ).
Public method | get_Entities | Retrieves an entity by its index. (inherited from IDXFImage ).
Public method | get_Items | (inherited from IDXFImage ).
Public method | get_Layouts | Retrieves a layout by its index. (inherited from IDXFImage ).

Top

collall See Also

Reference

DXFImage Interface


IDXFImage.AbsHeight Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.AbsHeight Method

 Return to chapter overview

Show / hide the hidden text

Returns an absolute height of the CAD drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function AbsHeight() As Double

C#

double AbsHeight()

C++

double AbsHeight()

JScript

function AbsHeight() : double;

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.AbsWidth Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.AbsWidth Method

 Return to chapter overview

Show / hide the hidden text

Returns an absolute width of the CAD drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function AbsWidth() As Double

C#

double AbsWidth()

C++

double AbsWidth()

JScript

function AbsWidth() : double;

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.AddScaledDXF Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.AddScaledDXF Method

 Return to chapter overview

Show / hide the hidden text

Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub AddScaledDXF( _
ByVal ACADFile As DXFImage, _
ByVal AName As String, _
ByVal APos As Point3D, _
ByVal AScale As Point3D, _
ByVal Rotation As Single _
)

C#

void AddScaledDXF(
DXFImageACADFile,
stringAName,
Point3DAPos,
Point3DAScale,
floatRotation
)

C++

void AddScaledDXF(
DXFImage^ ACADFile,
String^ AName,
Point3D^ APos,
Point3D^ AScale,
floatRotation
)

JScript

function AddScaledDXF(
ACADFile : DXFImage,
AName : String,
APos : Point3D,
AScale : Point3D,
Rotation : float
);

Parameters

ACADFile

DXF image which defines the external reference.

AName

User-defined name for the XREF.

APos

The insertion point.

AScale

3D point which determines the scale factor.

Rotation

XREF rotation angle.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.AddScaledDXFEx Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.AddScaledDXFEx Method

 Return to chapter overview

Show / hide the hidden text

Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function AddScaledDXFEx( _
ByVal ACADFile As DXFImage, _
ByVal AName As String, _
ByVal APos As Point3D, _
ByVal AScale As Point3D, _
ByVal Rotation As Single _
) As Insert

C#

Insert AddScaledDXFEx(
DXFImage ACADFile,
stringAName,
Point3DAPos,
Point3DAScale,
floatRotation
)

C++

Insert^ AddScaledDXFEx(
DXFImage^ ACADFile,
String^ AName,
Point3D^ APos,
Point3D^ AScale,
floatRotation
)

JScript

function AddScaledDXFEx(
ACADFile : DXFImage,
AName : String,
APos : Point3D,
AScale : Point3D,
Rotation : float
) : Insert;

Parameters

ACADFile

DXF image which defines the external reference.

AName

User-defined name for the XREF.

APos

The insertion point.

AScale

3D point which determines the scale factor.

Rotation

XREF rotation angle.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.AssignImage Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.AssignImage Method

 Return to chapter overview

Show / hide the hidden text

Makes a copy of a specified CAD image object and assigns it to this image.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub AssignImage( _
ByVal Source As Object _
)

C#

void AssignImage(
objectSource
)

C++

void AssignImage(
object^ Source
)

JScript

function AssignImage(
Source : object
);

Parameters

Source

The source CAD image object which will be copied.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.CreateImage Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.CreateImage Method

 Return to chapter overview

Show / hide the hidden text

Initializes a new CAD image instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub CreateImage()

C#

void CreateImage()

C++

void CreateImage()

JScript

function CreateImage();

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.Draw Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.Draw Method

 Return to chapter overview

Show / hide the hidden text

Draws the CAD image in a specified device context (DC).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub Draw( _
ByVal DC As Integer, _
ByVal Rect As Rect2D _
)

C#

void Draw(
intDC,
Rect2DRect
)

C++

void Draw(
intDC,
Rect2D^ Rect
)

JScript

function Draw(
DC : int,
Rect : Rect2D
);

Parameters

DC

Handle to the DC.

Rect

Rectangle which defines the drawing area in the DC.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.DrawRect Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.DrawRect Method

 Return to chapter overview

Show / hide the hidden text

Draws a specified region of this CAD image in a device context (DC).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub DrawRect( _
ByVal DC As Integer, _
ByVal SourceRect As Rect3D, _
ByVal DestRect As Rect2D _
)

C#

void DrawRect(
intDC,
Rect3DSourceRect,
Rect2DDestRect
)

C++

void DrawRect(
intDC,
Rect3D^ SourceRect,
Rect2D^ DestRect
)

JScript

function DrawRect(
DC : int,
SourceRect : Rect3D,
DestRect : Rect2D
);

Parameters

DC

Handle to the DC.

SourceRect

The region which will be drawn in the DC.

DestRect

Rectangle which defines the drawing area in the DC.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.ExportToMetafile Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.ExportToMetafile Method

 Return to chapter overview

Show / hide the hidden text

Exports this CAD image to Windows metafile.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub ExportToMetafile( _
ByVal FileName As String, _
ByVal AWidth As Integer, _
ByVal AHeight As Integer _
)

C#

void ExportToMetafile(
stringFileName,
intAWidth,
intAHeight
)

C++

void ExportToMetafile(
String^ FileName,
intAWidth,
intAHeight
)

JScript

function ExportToMetafile(
FileName : String,
AWidth : int,
AHeight : int
);

Parameters

FileName

Path to the output metafile.

AWidth

Width of the output metafile.

AHeight

Height of the output metafile.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.FreeImage Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.FreeImage Method

 Return to chapter overview

Show / hide the hidden text

Destroys this CAD image object and frees the memory used within the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub FreeImage()

C#

void FreeImage()

C++

void FreeImage()

JScript

function FreeImage();

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.GetCADCoords Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.GetCADCoords Method

 Return to chapter overview

Show / hide the hidden text

Returns CAD coordinates for a specified point.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function GetCADCoords( _
ByVal AXScaled As Double, _
ByVal AYScaled As Double _
) As Point3D

C#

Point3D GetCADCoords(
doubleAXScaled,
doubleAYScaled
)

C++

Point3D^ GetCADCoords(
doubleAXScaled,
doubleAYScaled
)

JScript

function GetCADCoords(
AXScaled : double,
AYScaled : double
) : Point3D;

Parameters

AXScaled

Ratio between the x-coordinate and the drawing's width.

AYScaled

Ratio between the y-coordinate and the drawing's height.

collall Remarks

The z-coordinate of the returned point is equal 0.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.GetEntityColor Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.GetEntityColor Method

 Return to chapter overview

Show / hide the hidden text

Returns the color value for a specified entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function GetEntityColor( _
ByVal AEntity As Entity, _
ByVal AInsert As Insert _
) As UInt32

C#

UInt32 GetEntityColor(
EntityAEntity,
InsertAInsert
)

C++

UInt32 GetEntityColor(
Entity^ AEntity,
Insert^ AInsert
)

JScript

function GetEntityColor(
AEntity : Entity,
AInsert : Insert
) : UInt32;

Parameters

AEntity

The entity whose color is retrieved.

AInsert

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.GetExtents Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.GetExtents Method

 Return to chapter overview

Show / hide the hidden text

Recalculates extents of the CAD image.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub GetExtents()

C#

void GetExtents()

C++

void GetExtents()

JScript

function GetExtents();

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.GetPoint Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.GetPoint Method

 Return to chapter overview

Show / hide the hidden text

Gets the on-screen coordinates for a specified CAD point.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function GetPoint( _
ByVal P As Point3D _
) As Point2D

C#

Point2D GetPoint(
Point3D P
)

C++

Point2D^ GetPoint(
Point3D^ P
)

JScript

function GetPoint(
P : Point3D
) : Point2D;

Parameters

P

CAD point coordinates in the 3D space.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.GetRealImagePoint Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.GetRealImagePoint Method

 Return to chapter overview

Show / hide the hidden text

Returns CAD coordinates of a specified point considering the drawing's rotation and viewport parameters.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function GetRealImagePoint( _
ByVal P As Point3D _
) As Point3D

C#

Point3D GetRealImagePoint(
Point3D P
)

C++

Point3D^ GetRealImagePoint(
Point3D^ P
)

JScript

function GetRealImagePoint(
P : Point3D
) : Point3D;

Parameters

P

CAD point in the 3D space.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.HeadVarAsFloat Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.HeadVarAsFloat Method

 Return to chapter overview

Show / hide the hidden text

Returns a value of the DXF header variable as a floating point number.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function HeadVarAsFloat( _
ByVal AName As String, _
ByVal ACode As Integer _
) As Double

C#

double HeadVarAsFloat(
stringAName,
intACode
)

C++

double HeadVarAsFloat(
String^ AName,
intACode
)

JScript

function HeadVarAsFloat(
AName : String,
ACode : int
) : double;

Parameters

AName

The header variable name.

ACode

Group code associated with the variable's value.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.HeadVarAsInteger Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.HeadVarAsInteger Method

 Return to chapter overview

Show / hide the hidden text

Returns a value of the DXF header variable as an integer.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function HeadVarAsInteger( _
ByVal AName As String, _
ByVal ACode As Integer _
) As Integer

C#

int HeadVarAsInteger(
stringAName,
intACode
)

C++

int HeadVarAsInteger(
String^ AName,
intACode
)

JScript

function HeadVarAsInteger(
AName : String,
ACode : int
) : int;

Parameters

AName

The header variable name.

ACode

Group code associated with the variable's value.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.HeadVarAsstring Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.HeadVarAsstring Method

 Return to chapter overview

Show / hide the hidden text

Returns a value of the DXF header variable as a string.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function HeadVarAsstring( _
ByVal AName As String, _
ByVal ACode As Integer _
) As String

C#

string HeadVarAsstring(
stringAName,
intACode
)

C++

String^ HeadVarAsstring(
String^ AName,
intACode
)

JScript

function HeadVarAsstring(
AName : String,
ACode : int
) : String;

Parameters

AName

The header variable name.

ACode

Group code associated with the variable's value.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.LoadFromClipboardFormat Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.LoadFromClipboardFormat Method

 Return to chapter overview

Show / hide the hidden text

Loads data from the clipboard.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub LoadFromClipboardFormat( _
ByVal Fmt As UInt16, _
ByVal Data As Integer, _
ByVal Pal As Integer _
)

C#

void LoadFromClipboardFormat(
UInt16Fmt,
intData,
intPal
)

C++

void LoadFromClipboardFormat(
UInt16Fmt,
intData,
intPal
)

JScript

function LoadFromClipboardFormat(
Fmt : UInt16,
Data : int,
Pal : int
);

Parameters

Fmt

Data

Pal

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.LoadFromFile Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.LoadFromFile Method

 Return to chapter overview

Show / hide the hidden text

Loads a CAD drawing from file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub LoadFromFile( _
ByVal FileName As String _
)

C#

void LoadFromFile(
stringFileName
)

C++

void LoadFromFile(
String^ FileName
)

JScript

function LoadFromFile(
FileName : String
);

Parameters

FileName

Path to the drawing file.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.LoadFromIStream Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.LoadFromIStream Method

 Return to chapter overview

Show / hide the hidden text

Loads a CAD drawing from stream.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub LoadFromIStream( _
ByVal Stream As Object _
)

C#

void LoadFromIStream(
objectStream
)

C++

void LoadFromIStream(
object^ Stream
)

JScript

function LoadFromIStream(
Stream : object
);

Parameters

Stream

Stream which contains the CAD drawing data.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.LoadFromStream Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.LoadFromStream Method

 Return to chapter overview

Show / hide the hidden text

Loads a CAD drawing from stream.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub LoadFromStream( _
ByVal hStream As Integer _
)

C#

void LoadFromStream(
inthStream
)

C++

void LoadFromStream(
inthStream
)

JScript

function LoadFromStream(
hStream : int
);

Parameters

hStream

Handle to the stream which contains the drawing data.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.RefreshCurrentLayout Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.RefreshCurrentLayout Method

 Return to chapter overview

Show / hide the hidden text

Refreshes the current layout.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub RefreshCurrentLayout()

C#

void RefreshCurrentLayout()

C++

void RefreshCurrentLayout()

JScript

function RefreshCurrentLayout();

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.ResetDrawingBox Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.ResetDrawingBox Method

 Return to chapter overview

Show / hide the hidden text

Switches off the drawing box.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub ResetDrawingBox()

C#

void ResetDrawingBox()

C++

void ResetDrawingBox()

JScript

function ResetDrawingBox();

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.RotDefault Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.RotDefault Method

 Return to chapter overview

Show / hide the hidden text

Rotates the drawing to the default view.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub RotDefault()

C#

void RotDefault()

C++

void RotDefault()

JScript

function RotDefault();

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.RotToView Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.RotToView Method

 Return to chapter overview

Show / hide the hidden text

Rotates the drawing to a specified view.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub RotToView( _
ByVal A3DView As TxDXFViewDirection _
)

C#

void RotToView(
TxDXFViewDirectionA3DView
)

C++

void RotToView(
TxDXFViewDirectionA3DView
)

JScript

function RotToView(
A3DView : TxDXFViewDirection
);

Parameters

A3DView

One of the orthogonal or isometric views.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.Rotate Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.Rotate Method

 Return to chapter overview

Show / hide the hidden text

Rotates the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub Rotate( _
ByVal Axis As TxAxes, _
ByVal Angle As Double _
)

C#

void Rotate(
TxAxesAxis,
doubleAngle
)

C++

void Rotate(
TxAxesAxis,
doubleAngle
)

JScript

function Rotate(
Axis : TxAxes,
Angle : double
);

Parameters

Axis

Rotation axis.

Angle

Rotation angle (measured in degrees).

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.SaveToClipboardFormat Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.SaveToClipboardFormat Method

 Return to chapter overview

Show / hide the hidden text

Copies the drawing to the clipboard in a specified format.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub SaveToClipboardFormat( _
ByRef Fmt As UInt16, _
ByRef Data As Integer, _
ByRef Pal As Integer _
)

C#

void SaveToClipboardFormat(
ref UInt16Fmt,
ref intData,
ref intPal
)

C++

void SaveToClipboardFormat(
UInt16& Fmt,
int& Data,
int& Pal
)

JScript

function SaveToClipboardFormat(
Fmt : UInt16,
Data : int,
Pal : int
);

Parameters

Fmt

Clipboard format.

Data

Pal

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.SaveToFile Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.SaveToFile Method

 Return to chapter overview

Show / hide the hidden text

Saves the drawing to a specified file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub SaveToFile( _
ByVal FileName As String _
)

C#

void SaveToFile(
stringFileName
)

C++

void SaveToFile(
String^ FileName
)

JScript

function SaveToFile(
FileName : String
);

Parameters

FileName

Path to the output file.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.SaveToIStream Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.SaveToIStream Method

 Return to chapter overview

Show / hide the hidden text

Writes the drawing data to a specified stream.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub SaveToIStream( _
ByVal Stream As Object _
)

C#

void SaveToIStream(
objectStream
)

C++

void SaveToIStream(
object^ Stream
)

JScript

function SaveToIStream(
Stream : object
);

Parameters

Stream

Stream where the drawing data is written.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.SaveToStream Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.SaveToStream Method

 Return to chapter overview

Show / hide the hidden text

Writes the drawing data to a specified stream.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub SaveToStream( _
ByVal Stream As Integer _
)

C#

void SaveToStream(
intStream
)

C++

void SaveToStream(
intStream
)

JScript

function SaveToStream(
Stream : int
);

Parameters

Stream

Stream where the drawing data will be written.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.SetClippingRect Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.SetClippingRect Method

 Return to chapter overview

Show / hide the hidden text

Sets a clipping rectangle for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub SetClippingRect( _
ByVal Value As Rect3D _
)

C#

void SetClippingRect(
Rect3DValue
)

C++

void SetClippingRect(
Rect3D^ Value
)

JScript

function SetClippingRect(
Value : Rect3D
);

Parameters

Value

The clipping rectangle area.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.SetExtentsParameters Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.SetExtentsParameters Method

 Return to chapter overview

Show / hide the hidden text

Changes the drawing extents.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub SetExtentsParameters( _
ByVal ARect As Rect3D, _
ByVal AIs3DExtents As Boolean _
)

C#

void SetExtentsParameters(
Rect3DARect,
boolAIs3DExtents
)

C++

void SetExtentsParameters(
Rect3D^ ARect,
boolAIs3DExtents
)

JScript

function SetExtentsParameters(
ARect : Rect3D,
AIs3DExtents : boolean
);

Parameters

ARect

The parallelepiped which defines the extents.

AIs3DExtents

If set to true, then the extents are 3D; otherwise, the extents are 2D.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.StopLoading Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.StopLoading Method

 Return to chapter overview

Show / hide the hidden text

Terminates loading of the drawing data.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub StopLoading()

C#

void StopLoading()

C++

void StopLoading()

JScript

function StopLoading();

collall Remarks

The portion of the drawing data which was loaded can be displayed in the control.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.get_Blocks Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.get_Blocks Method

 Return to chapter overview

Show / hide the hidden text

Retrieves a BLOCK object by its index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function get_Blocks( _
ByVal Index As Integer _
) As Block

C#

Block get_Blocks(
intIndex
)

C++

Block^ get_Blocks(
intIndex
)

JScript

function get_Blocks(
Index : int
) : Block;

Parameters

Index

Index of the block.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.get_Entities Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.get_Entities Method

 Return to chapter overview

Show / hide the hidden text

Retrieves an entity by its index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function get_Entities( _
ByVal Index As Integer _
) As Entity

C#

Entity get_Entities(
intIndex
)

C++

Entity^ get_Entities(
intIndex
)

JScript

function get_Entities(
Index : int
) : Entity;

Parameters

Index

Index of the entity.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.get_Items Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.get_Items Method

 Return to chapter overview

Show / hide the hidden text

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function get_Items( _
ByVal Index As Integer _
) As DXFImage

C#

DXFImage get_Items(
intIndex
)

C++

DXFImage^ get_Items(
intIndex
)

JScript

function get_Items(
Index : int
) : DXFImage;

Parameters

Index

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


IDXFImage.get_Layouts Method

API Reference > CADViewLib Namespace > DXFImage Interface > Methods >

IDXFImage.get_Layouts Method

 Return to chapter overview

Show / hide the hidden text

Retrieves a layout by its index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function get_Layouts( _
ByVal Index As Integer _
) As Layout

C#

Layout get_Layouts(
intIndex
)

C++

Layout^ get_Layouts(
intIndex
)

JScript

function get_Layouts(
Index : int
) : Layout;

Parameters

Index

Index of the layout.

collall See Also

Reference

IDXFImage Interface
IDXFImage IDXFImage Members


Dimension Interface

API Reference > CADViewLib Namespace >

Dimension Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to DIMENSION entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface Dimension
Inherits IDimension, _
IEllipseEvents_Event

C#

public interface Dimension : IDimension,
IEllipseEvents_Event

C++

public interface class Dimension : public IDimension^,
public IEllipseEvents_Event^

JScript

public interface Dimension
implements IDimension,
IEllipseEvents_Event

collall See Also

Reference

Dimension Members


Dimension Members

API Reference > CADViewLib Namespace > Dimension Interface >

Dimension Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to DIMENSION entities.

The following tables list the members exposed by the Dimension type.

collall Public Properties

 | Name | Description
Public property | Angle | Gets or sets a rotation angle. (inherited from IDimension ).
Public property | Associated | Gets or sets the associated entity. (inherited from IDimension ).
Public property | AttribsCount | Gets a number of the attributes. (inherited from IDimension ).
Public property | Block | Gets or sets the block definition. (inherited from IDimension ).
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from IDimension ).
Public property | CADHandle | Gets or sets the object handle. (inherited from IDimension ).
Public property | Color | Gets or sets a color of the object. (inherited from IDimension ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from IDimension ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from IDimension ).
Public property | DefPoint | Gets or sets the definition point (in WCS). (inherited from IDimension ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from IDimension ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from IDimension ).
Public property | Flags | Gets or sets the flags that represent the dimension type. (inherited from IDimension ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from IDimension ).
Public property | LinDefPoint1 | Gets or sets the first definition point for linear and angular dimensions. (inherited from IDimension ).
Public property | LinDefPoint2 | Gets or sets the second definition point for linear and angular dimensions. (inherited from IDimension ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from IDimension ).
Public property | MiddlePoint | Gets or sets the middle point of dimension text. (inherited from IDimension ).
Public property | Name | Gets or sets a name of this object. (inherited from IDimension ).
Public property | Owner | Gets the block reference which contains this block reference (when blocks are nested). (inherited from IDimension ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from IDimension ).
Public property | Point | Gets or sets the insertion point (in WCS). (inherited from IDimension ).
Public property | Scale | Gets or sets a scale factor. (inherited from IDimension ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from IDimension ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from IDimension ).
Public property | Style | Gets or sets the dimension style. (inherited from IDimension ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from IDimension ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from IDimension ).

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from IDimension ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from IDimension ).
Public method | Attrib | Returns the attribute with the given tag. (inherited from IDimension ).
Public method | CreateEntity | Initializes a new object instance. (inherited from IDimension ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from IDimension ).
Public method | EntName | Returns a name of the entity. (inherited from IDimension ).
Public method | FindBlock | Searches for a block definition with the given name. (inherited from IDimension ).
Public method | FreeEntity | Destroys the object instance. (inherited from IDimension ).
Public method | GetBoxPoints | For internal use. (inherited from IDimension ).
Public method | GetMatrix | Returns a coordinate transformation matrix for this object. (inherited from IDimension ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from IDimension ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from IDimension ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from IDimension ).
Public method | RealColor | Returns the actual color value for a specified color. (inherited from IDimension ).
Public method | RealLayer | Returns the actual layer for the block reference. (inherited from IDimension ).
Public method | RemoveEntity | Removes a specified entity. (inherited from IDimension ).
Public method | SetLType | Sets a line type for this object. (inherited from IDimension ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from IDimension ).
Public method | SetMatrix | Sets a coordinate transformation matrix for this object. (inherited from IDimension ).
Public method | get_Attribs | Returns the attribute at the given index. (inherited from IDimension ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from IDimension ).

Top

collall See Also

Reference

Dimension Interface


Dimension Properties

API Reference > CADViewLib Namespace > Dimension Interface >

Dimension Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Angle | Gets or sets a rotation angle. (inherited from IDimension ).
Public property | Associated | Gets or sets the associated entity. (inherited from IDimension ).
Public property | AttribsCount | Gets a number of the attributes. (inherited from IDimension ).
Public property | Block | Gets or sets the block definition. (inherited from IDimension ).
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from IDimension ).
Public property | CADHandle | Gets or sets the object handle. (inherited from IDimension ).
Public property | Color | Gets or sets a color of the object. (inherited from IDimension ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from IDimension ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from IDimension ).
Public property | DefPoint | Gets or sets the definition point (in WCS). (inherited from IDimension ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from IDimension ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from IDimension ).
Public property | Flags | Gets or sets the flags that represent the dimension type. (inherited from IDimension ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from IDimension ).
Public property | LinDefPoint1 | Gets or sets the first definition point for linear and angular dimensions. (inherited from IDimension ).
Public property | LinDefPoint2 | Gets or sets the second definition point for linear and angular dimensions. (inherited from IDimension ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from IDimension ).
Public property | MiddlePoint | Gets or sets the middle point of dimension text. (inherited from IDimension ).
Public property | Name | Gets or sets a name of this object. (inherited from IDimension ).
Public property | Owner | Gets the block reference which contains this block reference (when blocks are nested). (inherited from IDimension ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from IDimension ).
Public property | Point | Gets or sets the insertion point (in WCS). (inherited from IDimension ).
Public property | Scale | Gets or sets a scale factor. (inherited from IDimension ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from IDimension ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from IDimension ).
Public property | Style | Gets or sets the dimension style. (inherited from IDimension ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from IDimension ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from IDimension ).

Top

collall See Also

Reference

Dimension Interface


IDimension.Angle Property

API Reference > CADViewLib Namespace > Dimension Interface > Properties >

IDimension.Angle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a rotation angle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Angle() As Single

C#

float Angle {get; set;}

C++

property float Angle {
float get( );
void set(
float value
);
}

JScript

function get Angle() : float;
function set Angle(value : float);

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.Associated Property

API Reference > CADViewLib Namespace > Dimension Interface > Properties >

IDimension.Associated Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the associated entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Associated() As Entity

C#

Entity Associated {get; set;}

C++

property Entity^ Associated {
Entity^ get( );
void set(
Entity^ value
);
}

JScript

function get Associated() : Entity;
function set Associated(value : Entity);

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.AttribsCount Property

API Reference > CADViewLib Namespace > Dimension Interface > Properties >

IDimension.AttribsCount Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of the attributes.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property AttribsCount() As Integer

C#

int AttribsCount {get;}

C++

property int AttribsCount {
int get( );
}

JScript

function get AttribsCount() : int;

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.Block Property

API Reference > CADViewLib Namespace > Dimension Interface > Properties >

IDimension.Block Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the block definition.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Block() As Block

C#

Block Block {get; set;}

C++

property Block^ Block {
Block^ get( );
void set(
Block^ value
);
}

JScript

function get Block() : Block;
function set Block(value : Block);

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.Box Property

API Reference > CADViewLib Namespace > Dimension Interface > Properties >

IDimension.Box Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the bounding parallelepiped for the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Box() As Rect3D

C#

Rect3D Box {get;}

C++

property Rect3D^ Box {
Rect3D^ get( );
}

JScript

function get Box() : Rect3D;

Property Value

The parallelepiped which encloses the object.

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.CADHandle Property

API Reference > CADViewLib Namespace > Dimension Interface > Properties >

IDimension.CADHandle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the object handle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CADHandle() As UInt64

C#

UInt64 CADHandle {get; set;}

C++

property UInt64 CADHandle {
UInt64 get( );
void set(
UInt64 value
);
}

JScript

function get CADHandle() : UInt64;
function set CADHandle(value : UInt64);

Property Value

Number that uniquely identifies the object in a CAD drawing.

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.Color Property

API Reference > CADViewLib Namespace > Dimension Interface > Properties >

IDimension.Color Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a color of the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Color() As UInt32

C#

UInt32 Color {get; set;}

C++

property UInt32 Color {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get Color() : UInt32;
function set Color(value : UInt32);

Property Value

An insigned integer value which defines the object's color.

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.Converter Property

API Reference > CADViewLib Namespace > Dimension Interface > Properties >

IDimension.Converter Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a Converter instance associated with the CAD image to which this object belongs.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Converter() As Converter

C#

Converter Converter {get;}

C++

property Converter^ Converter {
Converter^ get( );
}

JScript

function get Converter() : Converter;

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.Count Property

API Reference > CADViewLib Namespace > Dimension Interface > Properties >

IDimension.Count Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of objects contained within the given object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Count() As Integer

C#

int Count {get;}

C++

property int Count {
int get( );
}

JScript

function get Count() : int;

Property Value

An Integer value indicating a number of objects contained within the given object.

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.DefPoint Property

API Reference > CADViewLib Namespace > Dimension Interface > Properties >

IDimension.DefPoint Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the definition point (in WCS).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DefPoint() As Point3D

C#

Point3D DefPoint {get; set;}

C++

property Point3D^ DefPoint {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get DefPoint() : Point3D;
function set DefPoint(value : Point3D);

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.EntID Property

API Reference > CADViewLib Namespace > Dimension Interface > Properties >

IDimension.EntID Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the entity type ID for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property EntID() As TEntityID

C#

TEntityID EntID {get; set;}

C++

property TEntityID EntID {
TEntityID get( );
void set(
TEntityID value
);
}

JScript

function get EntID() : TEntityID;
function set EntID(value : TEntityID);

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.Extrusion Property

API Reference > CADViewLib Namespace > Dimension Interface > Properties >

IDimension.Extrusion Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the extrusion direction vector for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Extrusion() As Point3D

C#

Point3D Extrusion {get; set;}

C++

property Point3D^ Extrusion {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Extrusion() : Point3D;
function set Extrusion(value : Point3D);

Property Value

The 3D point which defines the extrusion direction vector.

collall Remarks

The extrusion direction is the normal vector of the plane which contains the entity and it is applied to the entity base point. The default extrusion direction value is (0, 0, 1).

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.Flags Property

API Reference > CADViewLib Namespace > Dimension Interface > Properties >

IDimension.Flags Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the flags that represent the dimension type.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Flags() As Byte

C#

byte Flags {get; set;}

C++

property Byte Flags {
Byte get( );
void set(
Byte value
);
}

JScript

function get Flags() : byte;
function set Flags(value : byte);

Property Value

0 = Rotated, horizontal, or vertical
1 = Aligned
2 = Angular
3 = Diameter
4 = Radius
5 = Angular 3 point
6 = Ordinate

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.Layer Property

API Reference > CADViewLib Namespace > Dimension Interface > Properties >

IDimension.Layer Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a layer containing this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Layer() As Layer

C#

Layer Layer {get; set;}

C++

property Layer^ Layer {
Layer^ get( );
void set(
Layer^ value
);
}

JScript

function get Layer() : Layer;
function set Layer(value : Layer);

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.LinDefPoint1 Property

API Reference > CADViewLib Namespace > Dimension Interface > Properties >

IDimension.LinDefPoint1 Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the first definition point for linear and angular dimensions.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LinDefPoint1() As Point3D

C#

Point3D LinDefPoint1 {get; set;}

C++

property Point3D^ LinDefPoint1 {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get LinDefPoint1() : Point3D;
function set LinDefPoint1(value : Point3D);

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.LinDefPoint2 Property

API Reference > CADViewLib Namespace > Dimension Interface > Properties >

IDimension.LinDefPoint2 Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the second definition point for linear and angular dimensions.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LinDefPoint2() As Point3D

C#

Point3D LinDefPoint2 {get; set;}

C++

property Point3D^ LinDefPoint2 {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get LinDefPoint2() : Point3D;
function set LinDefPoint2(value : Point3D);

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.LineTypeScale Property

API Reference > CADViewLib Namespace > Dimension Interface > Properties >

IDimension.LineTypeScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a quantity of line type elements per unit of its length.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineTypeScale() As Single

C#

float LineTypeScale {get; set;}

C++

property float LineTypeScale {
float get( );
void set(
float value
);
}

JScript

function get LineTypeScale() : float;
function set LineTypeScale(value : float);

Property Value

The quantity of linetype elements per unit of its length.

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.MiddlePoint Property

API Reference > CADViewLib Namespace > Dimension Interface > Properties >

IDimension.MiddlePoint Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the middle point of dimension text.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property MiddlePoint() As Point3D

C#

Point3D MiddlePoint {get; set;}

C++

property Point3D^ MiddlePoint {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get MiddlePoint() : Point3D;
function set MiddlePoint(value : Point3D);

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.Name Property

API Reference > CADViewLib Namespace > Dimension Interface > Properties >

IDimension.Name Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Name() As String

C#

string Name {get; set;}

C++

property String^ Name {
String^ get( );
void set(
String^ value
);
}

JScript

function get Name() : String;
function set Name(value : String);

Property Value

String containing the object name.

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.Owner Property

API Reference > CADViewLib Namespace > Dimension Interface > Properties >

IDimension.Owner Property

 Return to chapter overview

Show / hide the hidden text

Gets the block reference which contains this block reference (when blocks are nested).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Owner() As Insert

C#

Insert Owner {get;}

C++

property Insert^ Owner {
Insert^ get( );
}

JScript

function get Owner() : Insert;

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.PaperSpace Property

API Reference > CADViewLib Namespace > Dimension Interface > Properties >

IDimension.PaperSpace Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is located in Paper space.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PaperSpace() As Integer

C#

int PaperSpace {get; set;}

C++

property int PaperSpace {
int get( );
void set(
int value
);
}

JScript

function get PaperSpace() : int;
function set PaperSpace(value : int);

Property Value

0 - the object is located in Model space, 1 - in Paper space.

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.Point Property

API Reference > CADViewLib Namespace > Dimension Interface > Properties >

IDimension.Point Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the insertion point (in WCS).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Point() As Point3D

C#

Point3D Point {get; set;}

C++

property Point3D^ Point {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Point() : Point3D;
function set Point(value : Point3D);

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.Scale Property

API Reference > CADViewLib Namespace > Dimension Interface > Properties >

IDimension.Scale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a scale factor.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Scale() As Point3D

C#

Point3D Scale {get; set;}

C++

property Point3D^ Scale {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Scale() : Point3D;
function set Scale(value : Point3D);

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.SrcEnd Property

API Reference > CADViewLib Namespace > Dimension Interface > Properties >

IDimension.SrcEnd Property

 Return to chapter overview

Show / hide the hidden text

Indicates the end of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcEnd() As String

C#

string SrcEnd {get; set;}

C++

property String^ SrcEnd {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcEnd() : String;
function set SrcEnd(value : String);

Property Value

A String value indicating the end of the record which represents this object in a drawing file.

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.SrcStart Property

API Reference > CADViewLib Namespace > Dimension Interface > Properties >

IDimension.SrcStart Property

 Return to chapter overview

Show / hide the hidden text

Indicates the beginning of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcStart() As String

C#

string SrcStart {get; set;}

C++

property String^ SrcStart {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcStart() : String;
function set SrcStart(value : String);

Property Value

A String value indicating the beginning of the record which represents this object in a drawing file.

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.Style Property

API Reference > CADViewLib Namespace > Dimension Interface > Properties >

IDimension.Style Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the dimension style.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Style() As Object

C#

object Style {get; set;}

C++

property object^ Style {
object^ get( );
void set(
object^ value
);
}

JScript

function get Style() : object;
function set Style(value : object);

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.Visibility Property

API Reference > CADViewLib Namespace > Dimension Interface > Properties >

IDimension.Visibility Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visibility() As Boolean

C#

bool Visibility {get; set;}

C++

property bool Visibility {
bool get( );
void set(
bool value
);
}

JScript

function get Visibility() : boolean;
function set Visibility(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.Visible Property

API Reference > CADViewLib Namespace > Dimension Interface > Properties >

IDimension.Visible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visible() As Boolean

C#

bool Visible {get; set;}

C++

property bool Visible {
bool get( );
void set(
bool value
);
}

JScript

function get Visible() : boolean;
function set Visible(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


Dimension Methods

API Reference > CADViewLib Namespace > Dimension Interface >

Dimension Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from IDimension ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from IDimension ).
Public method | Attrib | Returns the attribute with the given tag. (inherited from IDimension ).
Public method | CreateEntity | Initializes a new object instance. (inherited from IDimension ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from IDimension ).
Public method | EntName | Returns a name of the entity. (inherited from IDimension ).
Public method | FindBlock | Searches for a block definition with the given name. (inherited from IDimension ).
Public method | FreeEntity | Destroys the object instance. (inherited from IDimension ).
Public method | GetBoxPoints | For internal use. (inherited from IDimension ).
Public method | GetMatrix | Returns a coordinate transformation matrix for this object. (inherited from IDimension ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from IDimension ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from IDimension ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from IDimension ).
Public method | RealColor | Returns the actual color value for a specified color. (inherited from IDimension ).
Public method | RealLayer | Returns the actual layer for the block reference. (inherited from IDimension ).
Public method | RemoveEntity | Removes a specified entity. (inherited from IDimension ).
Public method | SetLType | Sets a line type for this object. (inherited from IDimension ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from IDimension ).
Public method | SetMatrix | Sets a coordinate transformation matrix for this object. (inherited from IDimension ).
Public method | get_Attribs | Returns the attribute at the given index. (inherited from IDimension ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from IDimension ).

Top

collall See Also

Reference

Dimension Interface


IDimension.AddEntity Method

API Reference > CADViewLib Namespace > Dimension Interface > Methods >

IDimension.AddEntity Method

 Return to chapter overview

Show / hide the hidden text

Adds a new child entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AddEntity( _
ByVal AEntity As Entity _
)

C#

override void AddEntity(
EntityAEntity
)

C++

void AddEntity(
Entity^ AEntity
)

JScript

function AddEntity(
AEntity : Entity
);

Parameters

AEntity

Added entity.

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.AssignEntity Method

API Reference > CADViewLib Namespace > Dimension Interface > Methods >

IDimension.AssignEntity Method

 Return to chapter overview

Show / hide the hidden text

Assigns the properties of the specified entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AssignEntity( _
ByVal Source As Entity _
)

C#

override void AssignEntity(
EntitySource
)

C++

void AssignEntity(
Entity^ Source
)

JScript

function AssignEntity(
Source : Entity
);

Parameters

Source

Entity which has the same type as the current object.

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.Attrib Method

API Reference > CADViewLib Namespace > Dimension Interface > Methods >

IDimension.Attrib Method

 Return to chapter overview

Show / hide the hidden text

Returns the attribute with the given tag.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function Attrib( _
ByVal S As String, _
ByVal P As Point3D _
) As Attrib

C#

override Attrib Attrib(
stringS,
Point3DP
)

C++

Attrib^ Attrib(
String^ S,
Point3D^ P
)

JScript

function Attrib(
S : String,
P : Point3D
) : Attrib;

Parameters

S

A String type value which indicates the attribute tag.

P

The attribute insertion point (returned by the method).

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.CreateEntity Method

API Reference > CADViewLib Namespace > Dimension Interface > Methods >

IDimension.CreateEntity Method

 Return to chapter overview

Show / hide the hidden text

Initializes a new object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub CreateEntity()

C#

override void CreateEntity()

C++

void CreateEntity()

JScript

function CreateEntity();

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.DeleteEntity Method

API Reference > CADViewLib Namespace > Dimension Interface > Methods >

IDimension.DeleteEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes an entity specified by index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub DeleteEntity( _
ByVal AIndex As Integer _
)

C#

override void DeleteEntity(
intAIndex
)

C++

void DeleteEntity(
intAIndex
)

JScript

function DeleteEntity(
AIndex : int
);

Parameters

AIndex

Index of the entity.

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.EntName Method

API Reference > CADViewLib Namespace > Dimension Interface > Methods >

IDimension.EntName Method

 Return to chapter overview

Show / hide the hidden text

Returns a name of the entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function EntName() As String

C#

override string EntName()

C++

String^ EntName()

JScript

function EntName() : String;

Return Value

A string containing the entity name.

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.FindBlock Method

API Reference > CADViewLib Namespace > Dimension Interface > Methods >

IDimension.FindBlock Method

 Return to chapter overview

Show / hide the hidden text

Searches for a block definition with the given name.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function FindBlock( _
ByVal AConverter As Converter, _
ByVal AName As String _
) As Block

C#

override Block FindBlock(
Converter AConverter,
stringAName
)

C++

Block^ FindBlock(
Converter^ AConverter,
String^ AName
)

JScript

function FindBlock(
AConverter : Converter,
AName : String
) : Block;

Parameters

AConverter

The Converter instance where a search takes place.

AName

The block name.

Return Value

The block definition.

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.FreeEntity Method

API Reference > CADViewLib Namespace > Dimension Interface > Methods >

IDimension.FreeEntity Method

 Return to chapter overview

Show / hide the hidden text

Destroys the object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub FreeEntity()

C#

override void FreeEntity()

C++

void FreeEntity()

JScript

function FreeEntity();

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.GetBoxPoints Method

API Reference > CADViewLib Namespace > Dimension Interface > Methods >

IDimension.GetBoxPoints Method

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetBoxPoints( _
ByVal Full As Boolean _
) As Boolean

C#

override bool GetBoxPoints(
boolFull
)

C++

bool GetBoxPoints(
boolFull
)

JScript

function GetBoxPoints(
Full : boolean
) : boolean;

Parameters

Full

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.GetMatrix Method

API Reference > CADViewLib Namespace > Dimension Interface > Methods >

IDimension.GetMatrix Method

 Return to chapter overview

Show / hide the hidden text

Returns a coordinate transformation matrix for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub GetMatrix( _
ByRef Matrix As Object _
)

C#

override void GetMatrix(
ref objectMatrix
)

C++

void GetMatrix(
object^& Matrix
)

JScript

function GetMatrix(
Matrix : object
);

Parameters

Matrix

The coordinate transformation matrix value passed by reference.

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.GetThickness Method

API Reference > CADViewLib Namespace > Dimension Interface > Methods >

IDimension.GetThickness Method

 Return to chapter overview

Show / hide the hidden text

Returns the line thickness for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetThickness() As Double

C#

override double GetThickness()

C++

double GetThickness()

JScript

function GetThickness() : double;

Return Value

A Double type value indicating the line thickness.

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.IndexOfEntity Method

API Reference > CADViewLib Namespace > Dimension Interface > Methods >

IDimension.IndexOfEntity Method

 Return to chapter overview

Show / hide the hidden text

Returns index of the given entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function IndexOfEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int IndexOfEntity(
EntityAEntity
)

C++

int IndexOfEntity(
Entity^ AEntity
)

JScript

function IndexOfEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity whose index is retrieved.

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.Iterate Method

API Reference > CADViewLib Namespace > Dimension Interface > Methods >

IDimension.Iterate Method

 Return to chapter overview

Show / hide the hidden text

Iterates through the entities in the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub Iterate( _
ByVal AConverter As Converter _
)

C#

override void Iterate(
ConverterAConverter
)

C++

void Iterate(
Converter^ AConverter
)

JScript

function Iterate(
AConverter : Converter
);

Parameters

AConverter

Converter which contains the drawing data.

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.RealColor Method

API Reference > CADViewLib Namespace > Dimension Interface > Methods >

IDimension.RealColor Method

 Return to chapter overview

Show / hide the hidden text

Returns the actual color value for a specified color.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function RealColor( _
ByVal AColor As UInt32 _
) As UInt32

C#

override UInt32 RealColor(
UInt32AColor
)

C++

UInt32 RealColor(
UInt32AColor
)

JScript

function RealColor(
AColor : UInt32
) : UInt32;

Parameters

AColor

The color value.

Return Value

If AColor value isn't equal to the layer's color (ByLayer), returns AColor, otherwise, Color value.

If the Color value is equal to the layer's color, this method is called recursively for the owner block reference with the Color value as AColor parameter.

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.RealLayer Method

API Reference > CADViewLib Namespace > Dimension Interface > Methods >

IDimension.RealLayer Method

 Return to chapter overview

Show / hide the hidden text

Returns the actual layer for the block reference.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function RealLayer() As Layer

C#

override Layer RealLayer()

C++

Layer^ RealLayer()

JScript

function RealLayer() : Layer;

Return Value

For XRef block: layer with a name in the given format: {XRef_Block_Name} | {Layer_Name}.

For nested block: layer which contains the owner block reference.

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.RemoveEntity Method

API Reference > CADViewLib Namespace > Dimension Interface > Methods >

IDimension.RemoveEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes a specified entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function RemoveEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int RemoveEntity(
EntityAEntity
)

C++

int RemoveEntity(
Entity^ AEntity
)

JScript

function RemoveEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity which will be removed.

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.SetLType Method

API Reference > CADViewLib Namespace > Dimension Interface > Methods >

IDimension.SetLType Method

 Return to chapter overview

Show / hide the hidden text

Sets a line type for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLType( _
ByVal Value As Entity _
)

C#

override void SetLType(
EntityValue
)

C++

void SetLType(
Entity^ Value
)

JScript

function SetLType(
Value : Entity
);

Parameters

Value

The line type value.

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.SetLWeight Method

API Reference > CADViewLib Namespace > Dimension Interface > Methods >

IDimension.SetLWeight Method

 Return to chapter overview

Show / hide the hidden text

Sets a line weight for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLWeight( _
ByVal Value As Integer _
)

C#

override void SetLWeight(
intValue
)

C++

void SetLWeight(
intValue
)

JScript

function SetLWeight(
Value : int
);

Parameters

Value

The line weight value.

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.SetMatrix Method

API Reference > CADViewLib Namespace > Dimension Interface > Methods >

IDimension.SetMatrix Method

 Return to chapter overview

Show / hide the hidden text

Sets a coordinate transformation matrix for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetMatrix( _
ByVal Matrix As Object _
)

C#

override void SetMatrix(
objectMatrix
)

C++

void SetMatrix(
object^ Matrix
)

JScript

function SetMatrix(
Matrix : object
);

Parameters

Matrix

The coordinate transformation matrix

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.get_Attribs Method

API Reference > CADViewLib Namespace > Dimension Interface > Methods >

IDimension.get_Attribs Method

 Return to chapter overview

Show / hide the hidden text

Returns the attribute at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Attribs( _
ByVal Index As Integer _
) As Attrib

C#

override Attrib get_Attribs(
intIndex
)

C++

Attrib^ get_Attribs(
intIndex
)

JScript

function get_Attribs(
Index : int
) : Attrib;

Parameters

Index

The index of the attribute to retrieve.

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


IDimension.get_Entities Method

API Reference > CADViewLib Namespace > Dimension Interface > Methods >

IDimension.get_Entities Method

 Return to chapter overview

Show / hide the hidden text

Returns the child entity at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Entities( _
ByVal Index As Integer _
) As Entity

C#

override Entity get_Entities(
intIndex
)

C++

Entity^ get_Entities(
intIndex
)

JScript

function get_Entities(
Index : int
) : Entity;

Parameters

Index

The index of the entity to retrieve.

collall See Also

Reference

IDimension Interface
IDimension IDimension Members


Ellipse Interface

API Reference > CADViewLib Namespace >

Ellipse Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to ELLIPSE entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface Ellipse
Inherits IEllipse, _
IEntityEvents_Event

C#

public interface Ellipse : IEllipse,
IEntityEvents_Event

C++

public interface class Ellipse : public IEllipse^,
public IEntityEvents_Event^

JScript

public interface Ellipse
implements IEllipse,
IEntityEvents_Event

collall See Also

Reference

Ellipse Members


Ellipse Members

API Reference > CADViewLib Namespace > Ellipse Interface >

Ellipse Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to ELLIPSE entities.

The following tables list the members exposed by the Ellipse type.

collall Public Properties

 | Name | Description
Public property | Angle | Gets or sets a rotation angle for the ellipse's major axis. (inherited from IEllipse ).
Public property | ArrowsCount | Gets a quantity of points that form an arrow. (inherited from IEllipse ).
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from IEllipse ).
Public property | CADHandle | Gets or sets the object handle. (inherited from IEllipse ).
Public property | Closed | Gets or sets a value indicating whether this polyline is closed. (inherited from IEllipse ).
Public property | Color | Gets or sets a color of the object. (inherited from IEllipse ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from IEllipse ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from IEllipse ).
Public property | DottedPointsCount | Gets a quantity of points that determine the dots and dashes for a polyline with non-solid line type. (inherited from IEllipse ).
Public property | EndAngle | Gets or sets the end angle. (inherited from IEllipse ).
Public property | EndPoint | Gets or sets the end point of arc/ellipse (inherited from IEllipse ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from IEllipse ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from IEllipse ).
Public property | Flags | Gets or sets a bit-coded flag indicating the polyline type. (inherited from IEllipse ).
Public property | GlobalWidth | Gets or sets a global width for this polyline. (inherited from IEllipse ).
Public property | IsMeshMClosed | Gets a value indicating whether the polygon mesh is closed in the M direction. (inherited from IEllipse ).
Public property | IsMeshNClosed | Gets a value indicating whether the polygon mesh is closed in the N direction. (inherited from IEllipse ).
Public property | IsPolyFaceMesh | Gets a value indicating whether this polyline is a polyface mesh. (inherited from IEllipse ).
Public property | IsPolyZThickness | Gets a value indicating whether the polyline has thickness measured along the axis Z. (inherited from IEllipse ).
Public property | IsPolygonMesh | Gets a value indicating whether this polyline is a polygon mesh. (inherited from IEllipse ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from IEllipse ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from IEllipse ).
Public property | MeshM | Gets or sets a number of vertices for the polygon mesh in the M direction. (inherited from IEllipse ).
Public property | MeshN | Gets or sets a number of vertices for the polygon mesh in the N direction. (inherited from IEllipse ).
Public property | Name | Gets or sets a name of this object. (inherited from IEllipse ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from IEllipse ).
Public property | PenLine | Gets properties of the pen used for drawing the object. (inherited from IEllipse ).
Public property | Point | Gets or sets the center point. (inherited from IEllipse ).
Public property | PointsCount | Gets a number of the polyline points. (inherited from IEllipse ).
Public property | PolyFaceVertexIndexesCount | Gets a quantity of indices which specify the order of traversing vertices in the polyface mesh. (inherited from IEllipse ).
Public property | RadPt | Gets an endpoint of major axis, relative to the center. (inherited from IEllipse ).
Public property | Radius | Gets or sets a radius of the circle/ellipse/arc. (inherited from IEllipse ).
Public property | Ratio | Gets or sets a ratio of minor axis to major axis. (inherited from IEllipse ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from IEllipse ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from IEllipse ).
Public property | StartAngle | Gets or sets the start angle. (inherited from IEllipse ).
Public property | StartPoint | Gets or sets the start point of arc/ellipse (inherited from IEllipse ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from IEllipse ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from IEllipse ).

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from IEllipse ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from IEllipse ).
Public method | CreateEntity | Initializes a new object instance. (inherited from IEllipse ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from IEllipse ).
Public method | EntName | Returns a name of the entity. (inherited from IEllipse ).
Public method | FreeEntity | Destroys the object instance. (inherited from IEllipse ).
Public method | GetArea | Returns the area bounded by a closed polygon. (inherited from IEllipse ).
Public method | GetBoxPoints | For internal use. (inherited from IEllipse ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from IEllipse ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from IEllipse ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from IEllipse ).
Public method | RemoveEntity | Removes a specified entity. (inherited from IEllipse ).
Public method | SetLType | Sets a line type for this object. (inherited from IEllipse ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from IEllipse ).
Public method | get_Arrows | Returns a point of the arrowhead. (inherited from IEllipse ).
Public method | get_DottedPoints | Returns coordinates of a point in the points array that determines dots and dashes for a non-solid line type. (inherited from IEllipse ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from IEllipse ).
Public method | get_Points | Returns coordinates of a point in the points array. (inherited from IEllipse ).
Public method | get_PolyFaceVertexIndexes | Returns a value which indicates an index of the polyface mesh vertex. (inherited from IEllipse ).
Public method | set_Arrows | Modifies a point of the arrowhead at the given index. (inherited from IEllipse ).

Top

collall See Also

Reference

Ellipse Interface


Ellipse Properties

API Reference > CADViewLib Namespace > Ellipse Interface >

Ellipse Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Angle | Gets or sets a rotation angle for the ellipse's major axis. (inherited from IEllipse ).
Public property | ArrowsCount | Gets a quantity of points that form an arrow. (inherited from IEllipse ).
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from IEllipse ).
Public property | CADHandle | Gets or sets the object handle. (inherited from IEllipse ).
Public property | Closed | Gets or sets a value indicating whether this polyline is closed. (inherited from IEllipse ).
Public property | Color | Gets or sets a color of the object. (inherited from IEllipse ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from IEllipse ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from IEllipse ).
Public property | DottedPointsCount | Gets a quantity of points that determine the dots and dashes for a polyline with non-solid line type. (inherited from IEllipse ).
Public property | EndAngle | Gets or sets the end angle. (inherited from IEllipse ).
Public property | EndPoint | Gets or sets the end point of arc/ellipse (inherited from IEllipse ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from IEllipse ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from IEllipse ).
Public property | Flags | Gets or sets a bit-coded flag indicating the polyline type. (inherited from IEllipse ).
Public property | GlobalWidth | Gets or sets a global width for this polyline. (inherited from IEllipse ).
Public property | IsMeshMClosed | Gets a value indicating whether the polygon mesh is closed in the M direction. (inherited from IEllipse ).
Public property | IsMeshNClosed | Gets a value indicating whether the polygon mesh is closed in the N direction. (inherited from IEllipse ).
Public property | IsPolyFaceMesh | Gets a value indicating whether this polyline is a polyface mesh. (inherited from IEllipse ).
Public property | IsPolyZThickness | Gets a value indicating whether the polyline has thickness measured along the axis Z. (inherited from IEllipse ).
Public property | IsPolygonMesh | Gets a value indicating whether this polyline is a polygon mesh. (inherited from IEllipse ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from IEllipse ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from IEllipse ).
Public property | MeshM | Gets or sets a number of vertices for the polygon mesh in the M direction. (inherited from IEllipse ).
Public property | MeshN | Gets or sets a number of vertices for the polygon mesh in the N direction. (inherited from IEllipse ).
Public property | Name | Gets or sets a name of this object. (inherited from IEllipse ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from IEllipse ).
Public property | PenLine | Gets properties of the pen used for drawing the object. (inherited from IEllipse ).
Public property | Point | Gets or sets the center point. (inherited from IEllipse ).
Public property | PointsCount | Gets a number of the polyline points. (inherited from IEllipse ).
Public property | PolyFaceVertexIndexesCount | Gets a quantity of indices which specify the order of traversing vertices in the polyface mesh. (inherited from IEllipse ).
Public property | RadPt | Gets an endpoint of major axis, relative to the center. (inherited from IEllipse ).
Public property | Radius | Gets or sets a radius of the circle/ellipse/arc. (inherited from IEllipse ).
Public property | Ratio | Gets or sets a ratio of minor axis to major axis. (inherited from IEllipse ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from IEllipse ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from IEllipse ).
Public property | StartAngle | Gets or sets the start angle. (inherited from IEllipse ).
Public property | StartPoint | Gets or sets the start point of arc/ellipse (inherited from IEllipse ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from IEllipse ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from IEllipse ).

Top

collall See Also

Reference

Ellipse Interface


IEllipse.Angle Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.Angle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a rotation angle for the ellipse's major axis.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Angle() As Double

C#

double Angle {get;}

C++

property double Angle {
double get( );
}

JScript

function get Angle() : double;

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.ArrowsCount Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.ArrowsCount Property

 Return to chapter overview

Show / hide the hidden text

Gets a quantity of points that form an arrow.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property ArrowsCount() As Integer

C#

int ArrowsCount {get;}

C++

property int ArrowsCount {
int get( );
}

JScript

function get ArrowsCount() : int;

Property Value

An Integer type value indicating a quantity of points that form an arrow.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.Box Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.Box Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the bounding parallelepiped for the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Box() As Rect3D

C#

Rect3D Box {get;}

C++

property Rect3D^ Box {
Rect3D^ get( );
}

JScript

function get Box() : Rect3D;

Property Value

The parallelepiped which encloses the object.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.CADHandle Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.CADHandle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the object handle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CADHandle() As UInt64

C#

UInt64 CADHandle {get; set;}

C++

property UInt64 CADHandle {
UInt64 get( );
void set(
UInt64 value
);
}

JScript

function get CADHandle() : UInt64;
function set CADHandle(value : UInt64);

Property Value

Number that uniquely identifies the object in a CAD drawing.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.Closed Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.Closed Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this polyline is closed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Closed() As Boolean

C#

bool Closed {get; set;}

C++

property bool Closed {
bool get( );
void set(
bool value
);
}

JScript

function get Closed() : boolean;
function set Closed(value : boolean);

Property Value

true if the polyline is closed; otherwise, false

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.Color Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.Color Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a color of the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Color() As UInt32

C#

UInt32 Color {get; set;}

C++

property UInt32 Color {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get Color() : UInt32;
function set Color(value : UInt32);

Property Value

An insigned integer value which defines the object's color.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.Converter Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.Converter Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a Converter instance associated with the CAD image to which this object belongs.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Converter() As Converter

C#

Converter Converter {get;}

C++

property Converter^ Converter {
Converter^ get( );
}

JScript

function get Converter() : Converter;

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.Count Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.Count Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of objects contained within the given object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Count() As Integer

C#

int Count {get;}

C++

property int Count {
int get( );
}

JScript

function get Count() : int;

Property Value

An Integer value indicating a number of objects contained within the given object.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.DottedPointsCount Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.DottedPointsCount Property

 Return to chapter overview

Show / hide the hidden text

Gets a quantity of points that determine the dots and dashes for a polyline with non-solid line type.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property DottedPointsCount() As Integer

C#

int DottedPointsCount {get;}

C++

property int DottedPointsCount {
int get( );
}

JScript

function get DottedPointsCount() : int;

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.EndAngle Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.EndAngle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the end angle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property EndAngle() As Double

C#

double EndAngle {get; set;}

C++

property double EndAngle {
double get( );
void set(
double value
);
}

JScript

function get EndAngle() : double;
function set EndAngle(value : double);

Property Value

Double type value indicating the end angle.

collall Remarks

The angle direction is counterclockwise.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.EndPoint Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.EndPoint Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the end point of arc/ellipse

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property EndPoint() As Point3D

C#

Point3D EndPoint {get; set;}

C++

property Point3D^ EndPoint {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get EndPoint() : Point3D;
function set EndPoint(value : Point3D);

Property Value

Point3D type value indicating the end point.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.EntID Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.EntID Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the entity type ID for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property EntID() As TEntityID

C#

TEntityID EntID {get; set;}

C++

property TEntityID EntID {
TEntityID get( );
void set(
TEntityID value
);
}

JScript

function get EntID() : TEntityID;
function set EntID(value : TEntityID);

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.Extrusion Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.Extrusion Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the extrusion direction vector for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Extrusion() As Point3D

C#

Point3D Extrusion {get; set;}

C++

property Point3D^ Extrusion {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Extrusion() : Point3D;
function set Extrusion(value : Point3D);

Property Value

The 3D point which defines the extrusion direction vector.

collall Remarks

The extrusion direction is the normal vector of the plane which contains the entity and it is applied to the entity base point. The default extrusion direction value is (0, 0, 1).

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.Flags Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.Flags Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a bit-coded flag indicating the polyline type.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Flags() As Integer

C#

int Flags {get; set;}

C++

property int Flags {
int get( );
void set(
int value
);
}

JScript

function get Flags() : int;
function set Flags(value : int);

Property Value

0 = Default value
1 = This is a closed polyline (or a polygon mesh closed in the M direction)
2 = Curve-fit vertices have been added
4 = Spline-fit vertices have been added
8 = This is a 3D polyline
16 = This is a 3D polygon mesh
32 = The polygon mesh is closed in the N direction
64 = The polyline is a polyface mesh
128 = The linetype pattern is generated continuously around the vertices of this polyline

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.GlobalWidth Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.GlobalWidth Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a global width for this polyline.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property GlobalWidth() As Single

C#

float GlobalWidth {get; set;}

C++

property float GlobalWidth {
float get( );
void set(
float value
);
}

JScript

function get GlobalWidth() : float;
function set GlobalWidth(value : float);

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.IsMeshMClosed Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.IsMeshMClosed Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the polygon mesh is closed in the M direction.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsMeshMClosed() As Boolean

C#

bool IsMeshMClosed {get;}

C++

property bool IsMeshMClosed {
bool get( );
}

JScript

function get IsMeshMClosed() : boolean;

Property Value

true if the polygon mesh is closed in the M direction.; otherwise, false.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.IsMeshNClosed Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.IsMeshNClosed Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the polygon mesh is closed in the N direction.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsMeshNClosed() As Boolean

C#

bool IsMeshNClosed {get;}

C++

property bool IsMeshNClosed {
bool get( );
}

JScript

function get IsMeshNClosed() : boolean;

Property Value

true if the polygon mesh is closed in the N direction.; otherwise, false.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.IsPolyFaceMesh Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.IsPolyFaceMesh Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether this polyline is a polyface mesh.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsPolyFaceMesh() As Boolean

C#

bool IsPolyFaceMesh {get;}

C++

property bool IsPolyFaceMesh {
bool get( );
}

JScript

function get IsPolyFaceMesh() : boolean;

Property Value

true if the polyline is a polyface mesh; otherwise, false.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.IsPolyZThickness Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.IsPolyZThickness Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the polyline has thickness measured along the axis Z.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsPolyZThickness() As Boolean

C#

bool IsPolyZThickness {get;}

C++

property bool IsPolyZThickness {
bool get( );
}

JScript

function get IsPolyZThickness() : boolean;

Property Value

true if the polyline has thickness measured along the axis Z; otherwise, false.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.IsPolygonMesh Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.IsPolygonMesh Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether this polyline is a polygon mesh.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsPolygonMesh() As Boolean

C#

bool IsPolygonMesh {get;}

C++

property bool IsPolygonMesh {
bool get( );
}

JScript

function get IsPolygonMesh() : boolean;

Property Value

true if the polyline is a polygon mesh; otherwise, false.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.Layer Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.Layer Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a layer containing this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Layer() As Layer

C#

Layer Layer {get; set;}

C++

property Layer^ Layer {
Layer^ get( );
void set(
Layer^ value
);
}

JScript

function get Layer() : Layer;
function set Layer(value : Layer);

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.LineTypeScale Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.LineTypeScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a quantity of line type elements per unit of its length.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineTypeScale() As Single

C#

float LineTypeScale {get; set;}

C++

property float LineTypeScale {
float get( );
void set(
float value
);
}

JScript

function get LineTypeScale() : float;
function set LineTypeScale(value : float);

Property Value

The quantity of linetype elements per unit of its length.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.MeshM Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.MeshM Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a number of vertices for the polygon mesh in the M direction.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property MeshM() As Integer

C#

int MeshM {get; set;}

C++

property int MeshM {
int get( );
void set(
int value
);
}

JScript

function get MeshM() : int;
function set MeshM(value : int);

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.MeshN Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.MeshN Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a number of vertices for the polygon mesh in the N direction.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property MeshN() As Integer

C#

int MeshN {get; set;}

C++

property int MeshN {
int get( );
void set(
int value
);
}

JScript

function get MeshN() : int;
function set MeshN(value : int);

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.Name Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.Name Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Name() As String

C#

string Name {get; set;}

C++

property String^ Name {
String^ get( );
void set(
String^ value
);
}

JScript

function get Name() : String;
function set Name(value : String);

Property Value

String containing the object name.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.PaperSpace Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.PaperSpace Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is located in Paper space.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PaperSpace() As Integer

C#

int PaperSpace {get; set;}

C++

property int PaperSpace {
int get( );
void set(
int value
);
}

JScript

function get PaperSpace() : int;
function set PaperSpace(value : int);

Property Value

0 - the object is located in Model space, 1 - in Paper space.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.PenLine Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.PenLine Property

 Return to chapter overview

Show / hide the hidden text

Gets properties of the pen used for drawing the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property PenLine() As CADLine

C#

CADLine PenLine {get;}

C++

property CADLine^ PenLine {
CADLine^ get( );
}

JScript

function get PenLine() : CADLine;

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.Point Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.Point Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the center point.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Point() As Point3D

C#

Point3D Point {get; set;}

C++

property Point3D^ Point {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Point() : Point3D;
function set Point(value : Point3D);

Property Value

Point3D value which represents the center point.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.PointsCount Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.PointsCount Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of the polyline points.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property PointsCount() As Integer

C#

int PointsCount {get;}

C++

property int PointsCount {
int get( );
}

JScript

function get PointsCount() : int;

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.PolyFaceVertexIndexesCount Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.PolyFaceVertexIndexesCount Property

 Return to chapter overview

Show / hide the hidden text

Gets a quantity of indices which specify the order of traversing vertices in the polyface mesh.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property PolyFaceVertexIndexesCount() As Integer

C#

int PolyFaceVertexIndexesCount {get;}

C++

property int PolyFaceVertexIndexesCount {
int get( );
}

JScript

function get PolyFaceVertexIndexesCount() : int;

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.RadPt Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.RadPt Property

 Return to chapter overview

Show / hide the hidden text

Gets an endpoint of major axis, relative to the center.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property RadPt() As Point3D

C#

Point3D RadPt {get;}

C++

property Point3D^ RadPt {
Point3D^ get( );
}

JScript

function get RadPt() : Point3D;

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.Radius Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.Radius Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a radius of the circle/ellipse/arc.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Radius() As Double

C#

double Radius {get; set;}

C++

property double Radius {
double get( );
void set(
double value
);
}

JScript

function get Radius() : double;
function set Radius(value : double);

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.Ratio Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.Ratio Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a ratio of minor axis to major axis.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Ratio() As Double

C#

double Ratio {get; set;}

C++

property double Ratio {
double get( );
void set(
double value
);
}

JScript

function get Ratio() : double;
function set Ratio(value : double);

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.SrcEnd Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.SrcEnd Property

 Return to chapter overview

Show / hide the hidden text

Indicates the end of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcEnd() As String

C#

string SrcEnd {get; set;}

C++

property String^ SrcEnd {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcEnd() : String;
function set SrcEnd(value : String);

Property Value

A String value indicating the end of the record which represents this object in a drawing file.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.SrcStart Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.SrcStart Property

 Return to chapter overview

Show / hide the hidden text

Indicates the beginning of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcStart() As String

C#

string SrcStart {get; set;}

C++

property String^ SrcStart {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcStart() : String;
function set SrcStart(value : String);

Property Value

A String value indicating the beginning of the record which represents this object in a drawing file.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.StartAngle Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.StartAngle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the start angle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property StartAngle() As Double

C#

double StartAngle {get; set;}

C++

property double StartAngle {
double get( );
void set(
double value
);
}

JScript

function get StartAngle() : double;
function set StartAngle(value : double);

Property Value

Double type value indicating the start angle.

collall Remarks

The angle direction is counterclockwise.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.StartPoint Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.StartPoint Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the start point of arc/ellipse

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property StartPoint() As Point3D

C#

Point3D StartPoint {get;}

C++

property Point3D^ StartPoint {
Point3D^ get( );
}

JScript

function get StartPoint() : Point3D;

Property Value

Point3D type value indicating the start point.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.Visibility Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.Visibility Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visibility() As Boolean

C#

bool Visibility {get; set;}

C++

property bool Visibility {
bool get( );
void set(
bool value
);
}

JScript

function get Visibility() : boolean;
function set Visibility(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.Visible Property

API Reference > CADViewLib Namespace > Ellipse Interface > Properties >

IEllipse.Visible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visible() As Boolean

C#

bool Visible {get; set;}

C++

property bool Visible {
bool get( );
void set(
bool value
);
}

JScript

function get Visible() : boolean;
function set Visible(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


Ellipse Methods

API Reference > CADViewLib Namespace > Ellipse Interface >

Ellipse Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from IEllipse ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from IEllipse ).
Public method | CreateEntity | Initializes a new object instance. (inherited from IEllipse ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from IEllipse ).
Public method | EntName | Returns a name of the entity. (inherited from IEllipse ).
Public method | FreeEntity | Destroys the object instance. (inherited from IEllipse ).
Public method | GetArea | Returns the area bounded by a closed polygon. (inherited from IEllipse ).
Public method | GetBoxPoints | For internal use. (inherited from IEllipse ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from IEllipse ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from IEllipse ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from IEllipse ).
Public method | RemoveEntity | Removes a specified entity. (inherited from IEllipse ).
Public method | SetLType | Sets a line type for this object. (inherited from IEllipse ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from IEllipse ).
Public method | get_Arrows | Returns a point of the arrowhead. (inherited from IEllipse ).
Public method | get_DottedPoints | Returns coordinates of a point in the points array that determines dots and dashes for a non-solid line type. (inherited from IEllipse ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from IEllipse ).
Public method | get_Points | Returns coordinates of a point in the points array. (inherited from IEllipse ).
Public method | get_PolyFaceVertexIndexes | Returns a value which indicates an index of the polyface mesh vertex. (inherited from IEllipse ).
Public method | set_Arrows | Modifies a point of the arrowhead at the given index. (inherited from IEllipse ).

Top

collall See Also

Reference

Ellipse Interface


IEllipse.AddEntity Method

API Reference > CADViewLib Namespace > Ellipse Interface > Methods >

IEllipse.AddEntity Method

 Return to chapter overview

Show / hide the hidden text

Adds a new child entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AddEntity( _
ByVal AEntity As Entity _
)

C#

override void AddEntity(
EntityAEntity
)

C++

void AddEntity(
Entity^ AEntity
)

JScript

function AddEntity(
AEntity : Entity
);

Parameters

AEntity

Added entity.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.AssignEntity Method

API Reference > CADViewLib Namespace > Ellipse Interface > Methods >

IEllipse.AssignEntity Method

 Return to chapter overview

Show / hide the hidden text

Assigns the properties of the specified entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AssignEntity( _
ByVal Source As Entity _
)

C#

override void AssignEntity(
EntitySource
)

C++

void AssignEntity(
Entity^ Source
)

JScript

function AssignEntity(
Source : Entity
);

Parameters

Source

Entity which has the same type as the current object.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.CreateEntity Method

API Reference > CADViewLib Namespace > Ellipse Interface > Methods >

IEllipse.CreateEntity Method

 Return to chapter overview

Show / hide the hidden text

Initializes a new object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub CreateEntity()

C#

override void CreateEntity()

C++

void CreateEntity()

JScript

function CreateEntity();

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.DeleteEntity Method

API Reference > CADViewLib Namespace > Ellipse Interface > Methods >

IEllipse.DeleteEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes an entity specified by index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub DeleteEntity( _
ByVal AIndex As Integer _
)

C#

override void DeleteEntity(
intAIndex
)

C++

void DeleteEntity(
intAIndex
)

JScript

function DeleteEntity(
AIndex : int
);

Parameters

AIndex

Index of the entity.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.EntName Method

API Reference > CADViewLib Namespace > Ellipse Interface > Methods >

IEllipse.EntName Method

 Return to chapter overview

Show / hide the hidden text

Returns a name of the entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function EntName() As String

C#

override string EntName()

C++

String^ EntName()

JScript

function EntName() : String;

Return Value

A string containing the entity name.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.FreeEntity Method

API Reference > CADViewLib Namespace > Ellipse Interface > Methods >

IEllipse.FreeEntity Method

 Return to chapter overview

Show / hide the hidden text

Destroys the object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub FreeEntity()

C#

override void FreeEntity()

C++

void FreeEntity()

JScript

function FreeEntity();

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.GetArea Method

API Reference > CADViewLib Namespace > Ellipse Interface > Methods >

IEllipse.GetArea Method

 Return to chapter overview

Show / hide the hidden text

Returns the area bounded by a closed polygon.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetArea() As Double

C#

override double GetArea()

C++

double GetArea()

JScript

function GetArea() : double;

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.GetBoxPoints Method

API Reference > CADViewLib Namespace > Ellipse Interface > Methods >

IEllipse.GetBoxPoints Method

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetBoxPoints( _
ByVal Full As Boolean _
) As Boolean

C#

override bool GetBoxPoints(
boolFull
)

C++

bool GetBoxPoints(
boolFull
)

JScript

function GetBoxPoints(
Full : boolean
) : boolean;

Parameters

Full

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.GetThickness Method

API Reference > CADViewLib Namespace > Ellipse Interface > Methods >

IEllipse.GetThickness Method

 Return to chapter overview

Show / hide the hidden text

Returns the line thickness for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetThickness() As Double

C#

override double GetThickness()

C++

double GetThickness()

JScript

function GetThickness() : double;

Return Value

A Double type value indicating the line thickness.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.IndexOfEntity Method

API Reference > CADViewLib Namespace > Ellipse Interface > Methods >

IEllipse.IndexOfEntity Method

 Return to chapter overview

Show / hide the hidden text

Returns index of the given entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function IndexOfEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int IndexOfEntity(
EntityAEntity
)

C++

int IndexOfEntity(
Entity^ AEntity
)

JScript

function IndexOfEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity whose index is retrieved.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.Iterate Method

API Reference > CADViewLib Namespace > Ellipse Interface > Methods >

IEllipse.Iterate Method

 Return to chapter overview

Show / hide the hidden text

Iterates through the entities in the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub Iterate( _
ByVal AConverter As Converter _
)

C#

override void Iterate(
ConverterAConverter
)

C++

void Iterate(
Converter^ AConverter
)

JScript

function Iterate(
AConverter : Converter
);

Parameters

AConverter

Converter which contains the drawing data.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.RemoveEntity Method

API Reference > CADViewLib Namespace > Ellipse Interface > Methods >

IEllipse.RemoveEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes a specified entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function RemoveEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int RemoveEntity(
EntityAEntity
)

C++

int RemoveEntity(
Entity^ AEntity
)

JScript

function RemoveEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity which will be removed.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.SetLType Method

API Reference > CADViewLib Namespace > Ellipse Interface > Methods >

IEllipse.SetLType Method

 Return to chapter overview

Show / hide the hidden text

Sets a line type for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLType( _
ByVal Value As Entity _
)

C#

override void SetLType(
EntityValue
)

C++

void SetLType(
Entity^ Value
)

JScript

function SetLType(
Value : Entity
);

Parameters

Value

The line type value.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.SetLWeight Method

API Reference > CADViewLib Namespace > Ellipse Interface > Methods >

IEllipse.SetLWeight Method

 Return to chapter overview

Show / hide the hidden text

Sets a line weight for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLWeight( _
ByVal Value As Integer _
)

C#

override void SetLWeight(
intValue
)

C++

void SetLWeight(
intValue
)

JScript

function SetLWeight(
Value : int
);

Parameters

Value

The line weight value.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.get_Arrows Method

API Reference > CADViewLib Namespace > Ellipse Interface > Methods >

IEllipse.get_Arrows Method

 Return to chapter overview

Show / hide the hidden text

Returns a point of the arrowhead.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Arrows( _
ByVal Index As Integer _
) As Point3D

C#

override Point3D get_Arrows(
intIndex
)

C++

Point3D^ get_Arrows(
intIndex
)

JScript

function get_Arrows(
Index : int
) : Point3D;

Parameters

Index

Index of the point to retrieve.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.get_DottedPoints Method

API Reference > CADViewLib Namespace > Ellipse Interface > Methods >

IEllipse.get_DottedPoints Method

 Return to chapter overview

Show / hide the hidden text

Returns coordinates of a point in the points array that determines dots and dashes for a non-solid line type.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_DottedPoints( _
ByVal Index As Integer _
) As Point3D

C#

override Point3D get_DottedPoints(
intIndex
)

C++

Point3D^ get_DottedPoints(
intIndex
)

JScript

function get_DottedPoints(
Index : int
) : Point3D;

Parameters

Index

Index of the point to retrieve.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.get_Entities Method

API Reference > CADViewLib Namespace > Ellipse Interface > Methods >

IEllipse.get_Entities Method

 Return to chapter overview

Show / hide the hidden text

Returns the child entity at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Entities( _
ByVal Index As Integer _
) As Entity

C#

override Entity get_Entities(
intIndex
)

C++

Entity^ get_Entities(
intIndex
)

JScript

function get_Entities(
Index : int
) : Entity;

Parameters

Index

The index of the entity to retrieve.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.get_Points Method

API Reference > CADViewLib Namespace > Ellipse Interface > Methods >

IEllipse.get_Points Method

 Return to chapter overview

Show / hide the hidden text

Returns coordinates of a point in the points array.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Points( _
ByVal Index As Integer _
) As Point3D

C#

override Point3D get_Points(
intIndex
)

C++

Point3D^ get_Points(
intIndex
)

JScript

function get_Points(
Index : int
) : Point3D;

Parameters

Index

Index of the point to retrieve.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.get_PolyFaceVertexIndexes Method

API Reference > CADViewLib Namespace > Ellipse Interface > Methods >

IEllipse.get_PolyFaceVertexIndexes Method

 Return to chapter overview

Show / hide the hidden text

Returns a value which indicates an index of the polyface mesh vertex.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_PolyFaceVertexIndexes( _
ByVal Index As Integer _
) As Object

C#

override object get_PolyFaceVertexIndexes(
intIndex
)

C++

object^ get_PolyFaceVertexIndexes(
intIndex
)

JScript

function get_PolyFaceVertexIndexes(
Index : int
) : object;

Parameters

Index

The index number of the element.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


IEllipse.set_Arrows Method

API Reference > CADViewLib Namespace > Ellipse Interface > Methods >

IEllipse.set_Arrows Method

 Return to chapter overview

Show / hide the hidden text

Modifies a point of the arrowhead at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub set_Arrows( _
ByVal Index As Integer, _
ByVal Value As Point3D _
)

C#

override void set_Arrows(
intIndex,
Point3DValue
)

C++

void set_Arrows(
intIndex,
Point3D^ Value
)

JScript

function set_Arrows(
Index : int,
Value : Point3D
);

Parameters

Index

The index of the point.

Value

Value to be set for the point.

collall See Also

Reference

IEllipse Interface
IEllipse IEllipse Members


Entity Interface

API Reference > CADViewLib Namespace >

Entity Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to an entity in the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface Entity
Inherits IEntity, _
IEntityEvents_Event

C#

public interface Entity : IEntity,
IEntityEvents_Event

C++

public interface class Entity : public IEntity^,
public IEntityEvents_Event^

JScript

public interface Entity
implements IEntity,
IEntityEvents_Event

collall See Also

Reference

Entity Members


Entity Members

API Reference > CADViewLib Namespace > Entity Interface >

Entity Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to an entity in the drawing database.

The following tables list the members exposed by the Entity type.

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from IEntity ).
Public property | CADHandle | Gets or sets the object handle. (inherited from IEntity ).
Public property | Color | Gets or sets a color of the object. (inherited from IEntity ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from IEntity ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from IEntity ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from IEntity ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from IEntity ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from IEntity ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from IEntity ).
Public property | Name | Gets or sets a name of this object. (inherited from IEntity ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from IEntity ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from IEntity ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from IEntity ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from IEntity ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from IEntity ).

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from IEntity ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from IEntity ).
Public method | CreateEntity | Initializes a new object instance. (inherited from IEntity ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from IEntity ).
Public method | EntName | Returns a name of the entity. (inherited from IEntity ).
Public method | FreeEntity | Destroys the object instance. (inherited from IEntity ).
Public method | GetBoxPoints | For internal use. (inherited from IEntity ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from IEntity ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from IEntity ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from IEntity ).
Public method | RemoveEntity | Removes a specified entity. (inherited from IEntity ).
Public method | SetLType | Sets a line type for this object. (inherited from IEntity ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from IEntity ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from IEntity ).

Top

collall See Also

Reference

Entity Interface


Entity Properties

API Reference > CADViewLib Namespace > Entity Interface >

Entity Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from IEntity ).
Public property | CADHandle | Gets or sets the object handle. (inherited from IEntity ).
Public property | Color | Gets or sets a color of the object. (inherited from IEntity ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from IEntity ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from IEntity ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from IEntity ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from IEntity ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from IEntity ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from IEntity ).
Public property | Name | Gets or sets a name of this object. (inherited from IEntity ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from IEntity ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from IEntity ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from IEntity ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from IEntity ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from IEntity ).

Top

collall See Also

Reference

Entity Interface


IEntity.Box Property

API Reference > CADViewLib Namespace > Entity Interface > Properties >

IEntity.Box Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the bounding parallelepiped for the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Box() As Rect3D

C#

Rect3D Box {get;}

C++

property Rect3D^ Box {
Rect3D^ get( );
}

JScript

function get Box() : Rect3D;

Property Value

The parallelepiped which encloses the object.

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


IEntity.CADHandle Property

API Reference > CADViewLib Namespace > Entity Interface > Properties >

IEntity.CADHandle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the object handle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CADHandle() As UInt64

C#

UInt64 CADHandle {get; set;}

C++

property UInt64 CADHandle {
UInt64 get( );
void set(
UInt64 value
);
}

JScript

function get CADHandle() : UInt64;
function set CADHandle(value : UInt64);

Property Value

Number that uniquely identifies the object in a CAD drawing.

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


IEntity.Color Property

API Reference > CADViewLib Namespace > Entity Interface > Properties >

IEntity.Color Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a color of the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Color() As UInt32

C#

UInt32 Color {get; set;}

C++

property UInt32 Color {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get Color() : UInt32;
function set Color(value : UInt32);

Property Value

An insigned integer value which defines the object's color.

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


IEntity.Converter Property

API Reference > CADViewLib Namespace > Entity Interface > Properties >

IEntity.Converter Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a Converter instance associated with the CAD image to which this object belongs.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Converter() As Converter

C#

Converter Converter {get;}

C++

property Converter^ Converter {
Converter^ get( );
}

JScript

function get Converter() : Converter;

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


IEntity.Count Property

API Reference > CADViewLib Namespace > Entity Interface > Properties >

IEntity.Count Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of objects contained within the given object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Count() As Integer

C#

int Count {get;}

C++

property int Count {
int get( );
}

JScript

function get Count() : int;

Property Value

An Integer value indicating a number of objects contained within the given object.

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


IEntity.EntID Property

API Reference > CADViewLib Namespace > Entity Interface > Properties >

IEntity.EntID Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the entity type ID for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property EntID() As TEntityID

C#

TEntityID EntID {get; set;}

C++

property TEntityID EntID {
TEntityID get( );
void set(
TEntityID value
);
}

JScript

function get EntID() : TEntityID;
function set EntID(value : TEntityID);

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


IEntity.Extrusion Property

API Reference > CADViewLib Namespace > Entity Interface > Properties >

IEntity.Extrusion Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the extrusion direction vector for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Extrusion() As Point3D

C#

Point3D Extrusion {get; set;}

C++

property Point3D^ Extrusion {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Extrusion() : Point3D;
function set Extrusion(value : Point3D);

Property Value

The 3D point which defines the extrusion direction vector.

collall Remarks

The extrusion direction is the normal vector of the plane which contains the entity and it is applied to the entity base point. The default extrusion direction value is (0, 0, 1).

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


IEntity.Layer Property

API Reference > CADViewLib Namespace > Entity Interface > Properties >

IEntity.Layer Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a layer containing this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Layer() As Layer

C#

Layer Layer {get; set;}

C++

property Layer^ Layer {
Layer^ get( );
void set(
Layer^ value
);
}

JScript

function get Layer() : Layer;
function set Layer(value : Layer);

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


IEntity.LineTypeScale Property

API Reference > CADViewLib Namespace > Entity Interface > Properties >

IEntity.LineTypeScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a quantity of line type elements per unit of its length.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineTypeScale() As Single

C#

float LineTypeScale {get; set;}

C++

property float LineTypeScale {
float get( );
void set(
float value
);
}

JScript

function get LineTypeScale() : float;
function set LineTypeScale(value : float);

Property Value

The quantity of linetype elements per unit of its length.

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


IEntity.Name Property

API Reference > CADViewLib Namespace > Entity Interface > Properties >

IEntity.Name Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Name() As String

C#

string Name {get; set;}

C++

property String^ Name {
String^ get( );
void set(
String^ value
);
}

JScript

function get Name() : String;
function set Name(value : String);

Property Value

String containing the object name.

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


IEntity.PaperSpace Property

API Reference > CADViewLib Namespace > Entity Interface > Properties >

IEntity.PaperSpace Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is located in Paper space.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PaperSpace() As Integer

C#

int PaperSpace {get; set;}

C++

property int PaperSpace {
int get( );
void set(
int value
);
}

JScript

function get PaperSpace() : int;
function set PaperSpace(value : int);

Property Value

0 - the object is located in Model space, 1 - in Paper space.

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


IEntity.SrcEnd Property

API Reference > CADViewLib Namespace > Entity Interface > Properties >

IEntity.SrcEnd Property

 Return to chapter overview

Show / hide the hidden text

Indicates the end of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcEnd() As String

C#

string SrcEnd {get; set;}

C++

property String^ SrcEnd {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcEnd() : String;
function set SrcEnd(value : String);

Property Value

A String value indicating the end of the record which represents this object in a drawing file.

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


IEntity.SrcStart Property

API Reference > CADViewLib Namespace > Entity Interface > Properties >

IEntity.SrcStart Property

 Return to chapter overview

Show / hide the hidden text

Indicates the beginning of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcStart() As String

C#

string SrcStart {get; set;}

C++

property String^ SrcStart {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcStart() : String;
function set SrcStart(value : String);

Property Value

A String value indicating the beginning of the record which represents this object in a drawing file.

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


IEntity.Visibility Property

API Reference > CADViewLib Namespace > Entity Interface > Properties >

IEntity.Visibility Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visibility() As Boolean

C#

bool Visibility {get; set;}

C++

property bool Visibility {
bool get( );
void set(
bool value
);
}

JScript

function get Visibility() : boolean;
function set Visibility(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


IEntity.Visible Property

API Reference > CADViewLib Namespace > Entity Interface > Properties >

IEntity.Visible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visible() As Boolean

C#

bool Visible {get; set;}

C++

property bool Visible {
bool get( );
void set(
bool value
);
}

JScript

function get Visible() : boolean;
function set Visible(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


Entity Methods

API Reference > CADViewLib Namespace > Entity Interface >

Entity Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from IEntity ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from IEntity ).
Public method | CreateEntity | Initializes a new object instance. (inherited from IEntity ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from IEntity ).
Public method | EntName | Returns a name of the entity. (inherited from IEntity ).
Public method | FreeEntity | Destroys the object instance. (inherited from IEntity ).
Public method | GetBoxPoints | For internal use. (inherited from IEntity ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from IEntity ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from IEntity ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from IEntity ).
Public method | RemoveEntity | Removes a specified entity. (inherited from IEntity ).
Public method | SetLType | Sets a line type for this object. (inherited from IEntity ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from IEntity ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from IEntity ).

Top

collall See Also

Reference

Entity Interface


IEntity.AddEntity Method

API Reference > CADViewLib Namespace > Entity Interface > Methods >

IEntity.AddEntity Method

 Return to chapter overview

Show / hide the hidden text

Adds a new child entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub AddEntity( _
ByVal AEntity As Entity _
)

C#

void AddEntity(
EntityAEntity
)

C++

void AddEntity(
Entity^ AEntity
)

JScript

function AddEntity(
AEntity : Entity
);

Parameters

AEntity

Added entity.

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


IEntity.AssignEntity Method

API Reference > CADViewLib Namespace > Entity Interface > Methods >

IEntity.AssignEntity Method

 Return to chapter overview

Show / hide the hidden text

Assigns the properties of the specified entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub AssignEntity( _
ByVal Source As Entity _
)

C#

void AssignEntity(
EntitySource
)

C++

void AssignEntity(
Entity^ Source
)

JScript

function AssignEntity(
Source : Entity
);

Parameters

Source

Entity which has the same type as the current object.

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


IEntity.CreateEntity Method

API Reference > CADViewLib Namespace > Entity Interface > Methods >

IEntity.CreateEntity Method

 Return to chapter overview

Show / hide the hidden text

Initializes a new object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub CreateEntity()

C#

void CreateEntity()

C++

void CreateEntity()

JScript

function CreateEntity();

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


IEntity.DeleteEntity Method

API Reference > CADViewLib Namespace > Entity Interface > Methods >

IEntity.DeleteEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes an entity specified by index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub DeleteEntity( _
ByVal AIndex As Integer _
)

C#

void DeleteEntity(
intAIndex
)

C++

void DeleteEntity(
intAIndex
)

JScript

function DeleteEntity(
AIndex : int
);

Parameters

AIndex

Index of the entity.

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


IEntity.EntName Method

API Reference > CADViewLib Namespace > Entity Interface > Methods >

IEntity.EntName Method

 Return to chapter overview

Show / hide the hidden text

Returns a name of the entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function EntName() As String

C#

string EntName()

C++

String^ EntName()

JScript

function EntName() : String;

Return Value

A string containing the entity name.

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


IEntity.FreeEntity Method

API Reference > CADViewLib Namespace > Entity Interface > Methods >

IEntity.FreeEntity Method

 Return to chapter overview

Show / hide the hidden text

Destroys the object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub FreeEntity()

C#

void FreeEntity()

C++

void FreeEntity()

JScript

function FreeEntity();

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


IEntity.GetBoxPoints Method

API Reference > CADViewLib Namespace > Entity Interface > Methods >

IEntity.GetBoxPoints Method

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function GetBoxPoints( _
ByVal Full As Boolean _
) As Boolean

C#

bool GetBoxPoints(
boolFull
)

C++

bool GetBoxPoints(
boolFull
)

JScript

function GetBoxPoints(
Full : boolean
) : boolean;

Parameters

Full

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


IEntity.GetThickness Method

API Reference > CADViewLib Namespace > Entity Interface > Methods >

IEntity.GetThickness Method

 Return to chapter overview

Show / hide the hidden text

Returns the line thickness for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function GetThickness() As Double

C#

double GetThickness()

C++

double GetThickness()

JScript

function GetThickness() : double;

Return Value

A Double type value indicating the line thickness.

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


IEntity.IndexOfEntity Method

API Reference > CADViewLib Namespace > Entity Interface > Methods >

IEntity.IndexOfEntity Method

 Return to chapter overview

Show / hide the hidden text

Returns index of the given entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function IndexOfEntity( _
ByVal AEntity As Entity _
) As Integer

C#

int IndexOfEntity(
EntityAEntity
)

C++

int IndexOfEntity(
Entity^ AEntity
)

JScript

function IndexOfEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity whose index is retrieved.

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


IEntity.Iterate Method

API Reference > CADViewLib Namespace > Entity Interface > Methods >

IEntity.Iterate Method

 Return to chapter overview

Show / hide the hidden text

Iterates through the entities in the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub Iterate( _
ByVal AConverter As Converter _
)

C#

void Iterate(
ConverterAConverter
)

C++

void Iterate(
Converter^ AConverter
)

JScript

function Iterate(
AConverter : Converter
);

Parameters

AConverter

Converter which contains the drawing data.

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


IEntity.RemoveEntity Method

API Reference > CADViewLib Namespace > Entity Interface > Methods >

IEntity.RemoveEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes a specified entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function RemoveEntity( _
ByVal AEntity As Entity _
) As Integer

C#

int RemoveEntity(
EntityAEntity
)

C++

int RemoveEntity(
Entity^ AEntity
)

JScript

function RemoveEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity which will be removed.

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


IEntity.SetLType Method

API Reference > CADViewLib Namespace > Entity Interface > Methods >

IEntity.SetLType Method

 Return to chapter overview

Show / hide the hidden text

Sets a line type for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub SetLType( _
ByVal Value As Entity _
)

C#

void SetLType(
EntityValue
)

C++

void SetLType(
Entity^ Value
)

JScript

function SetLType(
Value : Entity
);

Parameters

Value

The line type value.

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


IEntity.SetLWeight Method

API Reference > CADViewLib Namespace > Entity Interface > Methods >

IEntity.SetLWeight Method

 Return to chapter overview

Show / hide the hidden text

Sets a line weight for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub SetLWeight( _
ByVal Value As Integer _
)

C#

void SetLWeight(
intValue
)

C++

void SetLWeight(
intValue
)

JScript

function SetLWeight(
Value : int
);

Parameters

Value

The line weight value.

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


IEntity.get_Entities Method

API Reference > CADViewLib Namespace > Entity Interface > Methods >

IEntity.get_Entities Method

 Return to chapter overview

Show / hide the hidden text

Returns the child entity at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function get_Entities( _
ByVal Index As Integer _
) As Entity

C#

Entity get_Entities(
intIndex
)

C++

Entity^ get_Entities(
intIndex
)

JScript

function get_Entities(
Index : int
) : Entity;

Parameters

Index

The index of the entity to retrieve.

collall See Also

Reference

IEntity Interface
IEntity IEntity Members


Group Interface

API Reference > CADViewLib Namespace >

Group Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to a group of objects.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface Group
Inherits IGroup, _
IEntityEvents_Event

C#

public interface Group : IGroup,
IEntityEvents_Event

C++

public interface class Group : public IGroup^,
public IEntityEvents_Event^

JScript

public interface Group
implements IGroup,
IEntityEvents_Event

collall See Also

Reference

Group Members


Group Members

API Reference > CADViewLib Namespace > Group Interface >

Group Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to a group of objects.

The following tables list the members exposed by the Group type.

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from IGroup ).
Public property | CADHandle | Gets or sets the object handle. (inherited from IGroup ).
Public property | Color | Gets or sets a color of the object. (inherited from IGroup ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from IGroup ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from IGroup ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from IGroup ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from IGroup ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from IGroup ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from IGroup ).
Public property | Name | Gets or sets a name of this object. (inherited from IGroup ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from IGroup ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from IGroup ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from IGroup ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from IGroup ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from IGroup ).

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from IGroup ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from IGroup ).
Public method | CreateEntity | Initializes a new object instance. (inherited from IGroup ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from IGroup ).
Public method | EntName | Returns a name of the entity. (inherited from IGroup ).
Public method | FreeEntity | Destroys the object instance. (inherited from IGroup ).
Public method | GetBoxPoints | For internal use. (inherited from IGroup ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from IGroup ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from IGroup ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from IGroup ).
Public method | RemoveEntity | Removes a specified entity. (inherited from IGroup ).
Public method | SetLType | Sets a line type for this object. (inherited from IGroup ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from IGroup ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from IGroup ).

Top

collall See Also

Reference

Group Interface


Group Properties

API Reference > CADViewLib Namespace > Group Interface >

Group Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from IGroup ).
Public property | CADHandle | Gets or sets the object handle. (inherited from IGroup ).
Public property | Color | Gets or sets a color of the object. (inherited from IGroup ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from IGroup ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from IGroup ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from IGroup ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from IGroup ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from IGroup ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from IGroup ).
Public property | Name | Gets or sets a name of this object. (inherited from IGroup ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from IGroup ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from IGroup ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from IGroup ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from IGroup ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from IGroup ).

Top

collall See Also

Reference

Group Interface


IGroup.Box Property

API Reference > CADViewLib Namespace > Group Interface > Properties >

IGroup.Box Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the bounding parallelepiped for the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Box() As Rect3D

C#

Rect3D Box {get;}

C++

property Rect3D^ Box {
Rect3D^ get( );
}

JScript

function get Box() : Rect3D;

Property Value

The parallelepiped which encloses the object.

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


IGroup.CADHandle Property

API Reference > CADViewLib Namespace > Group Interface > Properties >

IGroup.CADHandle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the object handle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CADHandle() As UInt64

C#

UInt64 CADHandle {get; set;}

C++

property UInt64 CADHandle {
UInt64 get( );
void set(
UInt64 value
);
}

JScript

function get CADHandle() : UInt64;
function set CADHandle(value : UInt64);

Property Value

Number that uniquely identifies the object in a CAD drawing.

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


IGroup.Color Property

API Reference > CADViewLib Namespace > Group Interface > Properties >

IGroup.Color Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a color of the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Color() As UInt32

C#

UInt32 Color {get; set;}

C++

property UInt32 Color {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get Color() : UInt32;
function set Color(value : UInt32);

Property Value

An insigned integer value which defines the object's color.

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


IGroup.Converter Property

API Reference > CADViewLib Namespace > Group Interface > Properties >

IGroup.Converter Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a Converter instance associated with the CAD image to which this object belongs.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Converter() As Converter

C#

Converter Converter {get;}

C++

property Converter^ Converter {
Converter^ get( );
}

JScript

function get Converter() : Converter;

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


IGroup.Count Property

API Reference > CADViewLib Namespace > Group Interface > Properties >

IGroup.Count Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of objects contained within the given object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Count() As Integer

C#

int Count {get;}

C++

property int Count {
int get( );
}

JScript

function get Count() : int;

Property Value

An Integer value indicating a number of objects contained within the given object.

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


IGroup.EntID Property

API Reference > CADViewLib Namespace > Group Interface > Properties >

IGroup.EntID Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the entity type ID for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property EntID() As TEntityID

C#

TEntityID EntID {get; set;}

C++

property TEntityID EntID {
TEntityID get( );
void set(
TEntityID value
);
}

JScript

function get EntID() : TEntityID;
function set EntID(value : TEntityID);

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


IGroup.Extrusion Property

API Reference > CADViewLib Namespace > Group Interface > Properties >

IGroup.Extrusion Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the extrusion direction vector for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Extrusion() As Point3D

C#

Point3D Extrusion {get; set;}

C++

property Point3D^ Extrusion {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Extrusion() : Point3D;
function set Extrusion(value : Point3D);

Property Value

The 3D point which defines the extrusion direction vector.

collall Remarks

The extrusion direction is the normal vector of the plane which contains the entity and it is applied to the entity base point. The default extrusion direction value is (0, 0, 1).

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


IGroup.Layer Property

API Reference > CADViewLib Namespace > Group Interface > Properties >

IGroup.Layer Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a layer containing this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Layer() As Layer

C#

Layer Layer {get; set;}

C++

property Layer^ Layer {
Layer^ get( );
void set(
Layer^ value
);
}

JScript

function get Layer() : Layer;
function set Layer(value : Layer);

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


IGroup.LineTypeScale Property

API Reference > CADViewLib Namespace > Group Interface > Properties >

IGroup.LineTypeScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a quantity of line type elements per unit of its length.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineTypeScale() As Single

C#

float LineTypeScale {get; set;}

C++

property float LineTypeScale {
float get( );
void set(
float value
);
}

JScript

function get LineTypeScale() : float;
function set LineTypeScale(value : float);

Property Value

The quantity of linetype elements per unit of its length.

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


IGroup.Name Property

API Reference > CADViewLib Namespace > Group Interface > Properties >

IGroup.Name Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Name() As String

C#

string Name {get; set;}

C++

property String^ Name {
String^ get( );
void set(
String^ value
);
}

JScript

function get Name() : String;
function set Name(value : String);

Property Value

String containing the object name.

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


IGroup.PaperSpace Property

API Reference > CADViewLib Namespace > Group Interface > Properties >

IGroup.PaperSpace Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is located in Paper space.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PaperSpace() As Integer

C#

int PaperSpace {get; set;}

C++

property int PaperSpace {
int get( );
void set(
int value
);
}

JScript

function get PaperSpace() : int;
function set PaperSpace(value : int);

Property Value

0 - the object is located in Model space, 1 - in Paper space.

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


IGroup.SrcEnd Property

API Reference > CADViewLib Namespace > Group Interface > Properties >

IGroup.SrcEnd Property

 Return to chapter overview

Show / hide the hidden text

Indicates the end of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcEnd() As String

C#

string SrcEnd {get; set;}

C++

property String^ SrcEnd {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcEnd() : String;
function set SrcEnd(value : String);

Property Value

A String value indicating the end of the record which represents this object in a drawing file.

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


IGroup.SrcStart Property

API Reference > CADViewLib Namespace > Group Interface > Properties >

IGroup.SrcStart Property

 Return to chapter overview

Show / hide the hidden text

Indicates the beginning of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcStart() As String

C#

string SrcStart {get; set;}

C++

property String^ SrcStart {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcStart() : String;
function set SrcStart(value : String);

Property Value

A String value indicating the beginning of the record which represents this object in a drawing file.

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


IGroup.Visibility Property

API Reference > CADViewLib Namespace > Group Interface > Properties >

IGroup.Visibility Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visibility() As Boolean

C#

bool Visibility {get; set;}

C++

property bool Visibility {
bool get( );
void set(
bool value
);
}

JScript

function get Visibility() : boolean;
function set Visibility(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


IGroup.Visible Property

API Reference > CADViewLib Namespace > Group Interface > Properties >

IGroup.Visible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visible() As Boolean

C#

bool Visible {get; set;}

C++

property bool Visible {
bool get( );
void set(
bool value
);
}

JScript

function get Visible() : boolean;
function set Visible(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


Group Methods

API Reference > CADViewLib Namespace > Group Interface >

Group Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from IGroup ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from IGroup ).
Public method | CreateEntity | Initializes a new object instance. (inherited from IGroup ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from IGroup ).
Public method | EntName | Returns a name of the entity. (inherited from IGroup ).
Public method | FreeEntity | Destroys the object instance. (inherited from IGroup ).
Public method | GetBoxPoints | For internal use. (inherited from IGroup ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from IGroup ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from IGroup ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from IGroup ).
Public method | RemoveEntity | Removes a specified entity. (inherited from IGroup ).
Public method | SetLType | Sets a line type for this object. (inherited from IGroup ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from IGroup ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from IGroup ).

Top

collall See Also

Reference

Group Interface


IGroup.AddEntity Method

API Reference > CADViewLib Namespace > Group Interface > Methods >

IGroup.AddEntity Method

 Return to chapter overview

Show / hide the hidden text

Adds a new child entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AddEntity( _
ByVal AEntity As Entity _
)

C#

override void AddEntity(
EntityAEntity
)

C++

void AddEntity(
Entity^ AEntity
)

JScript

function AddEntity(
AEntity : Entity
);

Parameters

AEntity

Added entity.

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


IGroup.AssignEntity Method

API Reference > CADViewLib Namespace > Group Interface > Methods >

IGroup.AssignEntity Method

 Return to chapter overview

Show / hide the hidden text

Assigns the properties of the specified entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AssignEntity( _
ByVal Source As Entity _
)

C#

override void AssignEntity(
EntitySource
)

C++

void AssignEntity(
Entity^ Source
)

JScript

function AssignEntity(
Source : Entity
);

Parameters

Source

Entity which has the same type as the current object.

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


IGroup.CreateEntity Method

API Reference > CADViewLib Namespace > Group Interface > Methods >

IGroup.CreateEntity Method

 Return to chapter overview

Show / hide the hidden text

Initializes a new object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub CreateEntity()

C#

override void CreateEntity()

C++

void CreateEntity()

JScript

function CreateEntity();

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


IGroup.DeleteEntity Method

API Reference > CADViewLib Namespace > Group Interface > Methods >

IGroup.DeleteEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes an entity specified by index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub DeleteEntity( _
ByVal AIndex As Integer _
)

C#

override void DeleteEntity(
intAIndex
)

C++

void DeleteEntity(
intAIndex
)

JScript

function DeleteEntity(
AIndex : int
);

Parameters

AIndex

Index of the entity.

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


IGroup.EntName Method

API Reference > CADViewLib Namespace > Group Interface > Methods >

IGroup.EntName Method

 Return to chapter overview

Show / hide the hidden text

Returns a name of the entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function EntName() As String

C#

override string EntName()

C++

String^ EntName()

JScript

function EntName() : String;

Return Value

A string containing the entity name.

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


IGroup.FreeEntity Method

API Reference > CADViewLib Namespace > Group Interface > Methods >

IGroup.FreeEntity Method

 Return to chapter overview

Show / hide the hidden text

Destroys the object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub FreeEntity()

C#

override void FreeEntity()

C++

void FreeEntity()

JScript

function FreeEntity();

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


IGroup.GetBoxPoints Method

API Reference > CADViewLib Namespace > Group Interface > Methods >

IGroup.GetBoxPoints Method

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetBoxPoints( _
ByVal Full As Boolean _
) As Boolean

C#

override bool GetBoxPoints(
boolFull
)

C++

bool GetBoxPoints(
boolFull
)

JScript

function GetBoxPoints(
Full : boolean
) : boolean;

Parameters

Full

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


IGroup.GetThickness Method

API Reference > CADViewLib Namespace > Group Interface > Methods >

IGroup.GetThickness Method

 Return to chapter overview

Show / hide the hidden text

Returns the line thickness for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetThickness() As Double

C#

override double GetThickness()

C++

double GetThickness()

JScript

function GetThickness() : double;

Return Value

A Double type value indicating the line thickness.

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


IGroup.IndexOfEntity Method

API Reference > CADViewLib Namespace > Group Interface > Methods >

IGroup.IndexOfEntity Method

 Return to chapter overview

Show / hide the hidden text

Returns index of the given entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function IndexOfEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int IndexOfEntity(
EntityAEntity
)

C++

int IndexOfEntity(
Entity^ AEntity
)

JScript

function IndexOfEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity whose index is retrieved.

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


IGroup.Iterate Method

API Reference > CADViewLib Namespace > Group Interface > Methods >

IGroup.Iterate Method

 Return to chapter overview

Show / hide the hidden text

Iterates through the entities in the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub Iterate( _
ByVal AConverter As Converter _
)

C#

override void Iterate(
ConverterAConverter
)

C++

void Iterate(
Converter^ AConverter
)

JScript

function Iterate(
AConverter : Converter
);

Parameters

AConverter

Converter which contains the drawing data.

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


IGroup.RemoveEntity Method

API Reference > CADViewLib Namespace > Group Interface > Methods >

IGroup.RemoveEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes a specified entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function RemoveEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int RemoveEntity(
EntityAEntity
)

C++

int RemoveEntity(
Entity^ AEntity
)

JScript

function RemoveEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity which will be removed.

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


IGroup.SetLType Method

API Reference > CADViewLib Namespace > Group Interface > Methods >

IGroup.SetLType Method

 Return to chapter overview

Show / hide the hidden text

Sets a line type for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLType( _
ByVal Value As Entity _
)

C#

override void SetLType(
EntityValue
)

C++

void SetLType(
Entity^ Value
)

JScript

function SetLType(
Value : Entity
);

Parameters

Value

The line type value.

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


IGroup.SetLWeight Method

API Reference > CADViewLib Namespace > Group Interface > Methods >

IGroup.SetLWeight Method

 Return to chapter overview

Show / hide the hidden text

Sets a line weight for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLWeight( _
ByVal Value As Integer _
)

C#

override void SetLWeight(
intValue
)

C++

void SetLWeight(
intValue
)

JScript

function SetLWeight(
Value : int
);

Parameters

Value

The line weight value.

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


IGroup.get_Entities Method

API Reference > CADViewLib Namespace > Group Interface > Methods >

IGroup.get_Entities Method

 Return to chapter overview

Show / hide the hidden text

Returns the child entity at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Entities( _
ByVal Index As Integer _
) As Entity

C#

override Entity get_Entities(
intIndex
)

C++

Entity^ get_Entities(
intIndex
)

JScript

function get_Entities(
Index : int
) : Entity;

Parameters

Index

The index of the entity to retrieve.

collall See Also

Reference

IGroup Interface
IGroup IGroup Members


HPGLImage Interface

API Reference > CADViewLib Namespace >

HPGLImage Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to an HPGL drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface HPGLImage
Inherits IHPGLImage, _
IDXFImageEvents_Event

C#

public interface HPGLImage : IHPGLImage,
IDXFImageEvents_Event

C++

public interface class HPGLImage : public IHPGLImage^,
public IDXFImageEvents_Event^

JScript

public interface HPGLImage
implements IHPGLImage,
IDXFImageEvents_Event

collall See Also

Reference

HPGLImage Members


HPGLImage Members

API Reference > CADViewLib Namespace > HPGLImage Interface >

HPGLImage Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to an HPGL drawing.

The following tables list the members exposed by the HPGLImage type.

collall Public Properties

 | Name | Description
Public property | BackGroundColor | Gets or sets a background color for the drawing. (inherited from IHPGLImage ).
Public property | BorderSize | Gets or sets a border size for the drawing. (inherited from IHPGLImage ).
Public property | BorderType | Gets or sets a way the drawing's border size is defined (global or ratio). (inherited from IHPGLImage ).
Public property | CADClassID | Gets the CAD format identifier for the drawing. (inherited from IHPGLImage ).
Public property | CBFormat | Gets or sets the clipboard format. (inherited from IHPGLImage ).
Public property | CanStopLoading | Gets a value indicating whether the loading of the drawing data can be terminated. (inherited from IHPGLImage ).
Public property | Charset | Gets or sets a character set for the text entities. (inherited from IHPGLImage ).
Public property | ColorToLineWeight | Gets or sets a string which contains the color-lineweight pairs. (inherited from IHPGLImage ).
Public property | Converter | Gets or sets a Converter associated with this image object. (inherited from IHPGLImage ).
Public property | Count | Gets a number of entities in the drawing. (inherited from IHPGLImage ).
Public property | CurrentLayout | Gets or sets the current layout for the drawing. (inherited from IHPGLImage ).
Public property | DefaultColor | Gets or sets the default color for the drawing. (inherited from IHPGLImage ).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions in the drawing are visible. (inherited from IHPGLImage ).
Public property | DrawMode | Gets or sets an appearance of colors in the drawing. (inherited from IHPGLImage ).
Public property | DrawingBox | Gets or sets the drawing bounding box. (inherited from IHPGLImage ).
Public property | Empty | Gets a value indicating whether the drawing is empty. (inherited from IHPGLImage ).
Public property | Extents | Gets or sets the drawing's extents. (inherited from IHPGLImage ).
Public property | Height | Gets or sets a height of the drawing. (inherited from IHPGLImage ).
Public property | Is3D | Gets a value indicating whether the drawing is three-dimensional. (inherited from IHPGLImage ).
Public property | IsDraw3DAxes | Gets a value indicating whether 3D axes are visible on the drawing. (inherited from IHPGLImage ).
Public property | IsDrawingRotated | Gets a value indicating whether the drawing is rotated. (inherited from IHPGLImage ).
Public property | IsLoading | Gets a value indicating whether the process of loading the drawing data is active. (inherited from IHPGLImage ).
Public property | IsPlotting | Gets or sets a value indicating whether to plot the image or not. (inherited from IHPGLImage ).
Public property | IsProcessMessages | Gets or sets a value indicating whether the messages processing is allowed. (inherited from IHPGLImage ).
Public property | IsShowBackground | Gets or sets a value indicating whether the backround is displayed. (inherited from IHPGLImage ).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines is determined by the drawing data. (inherited from IHPGLImage ).
Public property | IsWithoutBorder | Gets or sets a value indicating whether to display the drawing without borders. (inherited from IHPGLImage ).
Public property | LayoutsCount | Gets the number of layouts in the drawing. (inherited from IHPGLImage ).
Public property | LineScaled | Gets or sets a value indicating whether the line weight is diplayed. (inherited from IHPGLImage ).
Public property | LineWeightScale | Gets or sets a scale for line weights. (inherited from IHPGLImage ).
Public property | Millimetres | Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file. (inherited from IHPGLImage ).
Public property | Modified | Gets or sets a value indicating whether the drawing is modified. (inherited from IHPGLImage ).
Public property | NullWidth | Gets or sets a thickness for lines which have the zero lineweight. (inherited from IHPGLImage ).
Public property | OwnSource | For internal use. (inherited from IHPGLImage ).
Public property | PureExtents | Gets the drawing's extents excluding the borders. (inherited from IHPGLImage ).
Public property | ResizeDisproportionateDrawing | Gets or sets a value indicating whether to resize a drawing with disproportionate sizes. (inherited from IHPGLImage ).
Public property | Scale | Gets or sets a 3D point which defines the scale factor. (inherited from IHPGLImage ).
Public property | ShowImages | Gets or sets a value indicating whether the raster images are displayed. (inherited from IHPGLImage ).
Public property | Stretch | Gets or sets a value indicating whether the displayed image has to be stretched to fit exactly with the drawing rectangle. (inherited from IHPGLImage ).
Public property | TextVisible | Gets or sets a value indicating whether texts in the drawing are visible. (inherited from IHPGLImage ).
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles are drawn by using GDI+ methods without linearization. (inherited from IHPGLImage ).
Public property | ViewRectangle | For internal use. (inherited from IHPGLImage ).
Public property | Width | Gets or sets a width of the drawing. (inherited from IHPGLImage ).
Public property | mmHeight | Gets a height of the HPGL drawing in millimeters. (inherited from IHPGLImage ).
Public property | mmWidth | Gets a width of the HPGL drawing in millimeters. (inherited from IHPGLImage ).

Top

collall Public Methods

 | Name | Description
Public method | AbsHeight | Returns an absolute height of the CAD drawing. (inherited from IHPGLImage ).
Public method | AbsWidth | Returns an absolute width of the CAD drawing. (inherited from IHPGLImage ).
Public method | AddScaledDXF | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing. (inherited from IHPGLImage ).
Public method | AddScaledDXFEx | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing. (inherited from IHPGLImage ).
Public method | AssignImage | Makes a copy of a specified CAD image object and assigns it to this image. (inherited from IHPGLImage ).
Public method | CreateImage | Initializes a new CAD image instance. (inherited from IHPGLImage ).
Public method | Draw | Draws the CAD image in a specified device context (DC). (inherited from IHPGLImage ).
Public method | DrawRect | Draws a specified region of this CAD image in a device context (DC). (inherited from IHPGLImage ).
Public method | ExportToMetafile | Exports this CAD image to Windows metafile. (inherited from IHPGLImage ).
Public method | FreeImage | Destroys this CAD image object and frees the memory used within the object. (inherited from IHPGLImage ).
Public method | GetCADCoords | Returns CAD coordinates for a specified point. (inherited from IHPGLImage ).
Public method | GetEntityColor | Returns the color value for a specified entity. (inherited from IHPGLImage ).
Public method | GetExtents | Recalculates extents of the CAD image. (inherited from IHPGLImage ).
Public method | GetPoint | Gets the on-screen coordinates for a specified CAD point. (inherited from IHPGLImage ).
Public method | GetRealImagePoint | Returns CAD coordinates of a specified point considering the drawing's rotation and viewport parameters. (inherited from IHPGLImage ).
Public method | HeadVarAsFloat | Returns a value of the DXF header variable as a floating point number. (inherited from IHPGLImage ).
Public method | HeadVarAsInteger | Returns a value of the DXF header variable as an integer. (inherited from IHPGLImage ).
Public method | HeadVarAsstring | Returns a value of the DXF header variable as a string. (inherited from IHPGLImage ).
Public method | LoadFromClipboardFormat | Loads data from the clipboard. (inherited from IHPGLImage ).
Public method | LoadFromFile | Loads a CAD drawing from file. (inherited from IHPGLImage ).
Public method | LoadFromIStream | Loads a CAD drawing from stream. (inherited from IHPGLImage ).
Public method | LoadFromStream | Loads a CAD drawing from stream. (inherited from IHPGLImage ).
Public method | RefreshCurrentLayout | Refreshes the current layout. (inherited from IHPGLImage ).
Public method | ResetDrawingBox | Switches off the drawing box. (inherited from IHPGLImage ).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from IHPGLImage ).
Public method | RotToView | Rotates the drawing to a specified view. (inherited from IHPGLImage ).
Public method | Rotate | Rotates the drawing. (inherited from IHPGLImage ).
Public method | SaveToClipboardFormat | Copies the drawing to the clipboard in a specified format. (inherited from IHPGLImage ).
Public method | SaveToFile | Saves the drawing to a specified file. (inherited from IHPGLImage ).
Public method | SaveToIStream | Writes the drawing data to a specified stream. (inherited from IHPGLImage ).
Public method | SaveToStream | Writes the drawing data to a specified stream. (inherited from IHPGLImage ).
Public method | SetClippingRect | Sets a clipping rectangle for the drawing. (inherited from IHPGLImage ).
Public method | SetExtentsParameters | Changes the drawing extents. (inherited from IHPGLImage ).
Public method | StopLoading | Terminates loading of the drawing data. (inherited from IHPGLImage ).
Public method | get_Blocks | Retrieves a BLOCK object by its index. (inherited from IHPGLImage ).
Public method | get_Entities | Retrieves an entity by its index. (inherited from IHPGLImage ).
Public method | get_Items | (inherited from IHPGLImage ).
Public method | get_Layouts | Retrieves a layout by its index. (inherited from IHPGLImage ).

Top

collall See Also

Reference

HPGLImage Interface


HPGLImage Properties

API Reference > CADViewLib Namespace > HPGLImage Interface >

HPGLImage Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | BackGroundColor | Gets or sets a background color for the drawing. (inherited from IHPGLImage ).
Public property | BorderSize | Gets or sets a border size for the drawing. (inherited from IHPGLImage ).
Public property | BorderType | Gets or sets a way the drawing's border size is defined (global or ratio). (inherited from IHPGLImage ).
Public property | CADClassID | Gets the CAD format identifier for the drawing. (inherited from IHPGLImage ).
Public property | CBFormat | Gets or sets the clipboard format. (inherited from IHPGLImage ).
Public property | CanStopLoading | Gets a value indicating whether the loading of the drawing data can be terminated. (inherited from IHPGLImage ).
Public property | Charset | Gets or sets a character set for the text entities. (inherited from IHPGLImage ).
Public property | ColorToLineWeight | Gets or sets a string which contains the color-lineweight pairs. (inherited from IHPGLImage ).
Public property | Converter | Gets or sets a Converter associated with this image object. (inherited from IHPGLImage ).
Public property | Count | Gets a number of entities in the drawing. (inherited from IHPGLImage ).
Public property | CurrentLayout | Gets or sets the current layout for the drawing. (inherited from IHPGLImage ).
Public property | DefaultColor | Gets or sets the default color for the drawing. (inherited from IHPGLImage ).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions in the drawing are visible. (inherited from IHPGLImage ).
Public property | DrawMode | Gets or sets an appearance of colors in the drawing. (inherited from IHPGLImage ).
Public property | DrawingBox | Gets or sets the drawing bounding box. (inherited from IHPGLImage ).
Public property | Empty | Gets a value indicating whether the drawing is empty. (inherited from IHPGLImage ).
Public property | Extents | Gets or sets the drawing's extents. (inherited from IHPGLImage ).
Public property | Height | Gets or sets a height of the drawing. (inherited from IHPGLImage ).
Public property | Is3D | Gets a value indicating whether the drawing is three-dimensional. (inherited from IHPGLImage ).
Public property | IsDraw3DAxes | Gets a value indicating whether 3D axes are visible on the drawing. (inherited from IHPGLImage ).
Public property | IsDrawingRotated | Gets a value indicating whether the drawing is rotated. (inherited from IHPGLImage ).
Public property | IsLoading | Gets a value indicating whether the process of loading the drawing data is active. (inherited from IHPGLImage ).
Public property | IsPlotting | Gets or sets a value indicating whether to plot the image or not. (inherited from IHPGLImage ).
Public property | IsProcessMessages | Gets or sets a value indicating whether the messages processing is allowed. (inherited from IHPGLImage ).
Public property | IsShowBackground | Gets or sets a value indicating whether the backround is displayed. (inherited from IHPGLImage ).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines is determined by the drawing data. (inherited from IHPGLImage ).
Public property | IsWithoutBorder | Gets or sets a value indicating whether to display the drawing without borders. (inherited from IHPGLImage ).
Public property | LayoutsCount | Gets the number of layouts in the drawing. (inherited from IHPGLImage ).
Public property | LineScaled | Gets or sets a value indicating whether the line weight is diplayed. (inherited from IHPGLImage ).
Public property | LineWeightScale | Gets or sets a scale for line weights. (inherited from IHPGLImage ).
Public property | Millimetres | Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file. (inherited from IHPGLImage ).
Public property | Modified | Gets or sets a value indicating whether the drawing is modified. (inherited from IHPGLImage ).
Public property | NullWidth | Gets or sets a thickness for lines which have the zero lineweight. (inherited from IHPGLImage ).
Public property | OwnSource | For internal use. (inherited from IHPGLImage ).
Public property | PureExtents | Gets the drawing's extents excluding the borders. (inherited from IHPGLImage ).
Public property | ResizeDisproportionateDrawing | Gets or sets a value indicating whether to resize a drawing with disproportionate sizes. (inherited from IHPGLImage ).
Public property | Scale | Gets or sets a 3D point which defines the scale factor. (inherited from IHPGLImage ).
Public property | ShowImages | Gets or sets a value indicating whether the raster images are displayed. (inherited from IHPGLImage ).
Public property | Stretch | Gets or sets a value indicating whether the displayed image has to be stretched to fit exactly with the drawing rectangle. (inherited from IHPGLImage ).
Public property | TextVisible | Gets or sets a value indicating whether texts in the drawing are visible. (inherited from IHPGLImage ).
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles are drawn by using GDI+ methods without linearization. (inherited from IHPGLImage ).
Public property | ViewRectangle | For internal use. (inherited from IHPGLImage ).
Public property | Width | Gets or sets a width of the drawing. (inherited from IHPGLImage ).
Public property | mmHeight | Gets a height of the HPGL drawing in millimeters. (inherited from IHPGLImage ).
Public property | mmWidth | Gets a width of the HPGL drawing in millimeters. (inherited from IHPGLImage ).

Top

collall See Also

Reference

HPGLImage Interface


IHPGLImage.BackGroundColor Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.BackGroundColor Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a background color for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property BackGroundColor() As UInt32

C#

UInt32 BackGroundColor {get; set;}

C++

property UInt32 BackGroundColor {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get BackGroundColor() : UInt32;
function set BackGroundColor(value : UInt32);

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.BorderSize Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.BorderSize Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a border size for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property BorderSize() As Double

C#

double BorderSize {get; set;}

C++

property double BorderSize {
double get( );
void set(
double value
);
}

JScript

function get BorderSize() : double;
function set BorderSize(value : double);

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.BorderType Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.BorderType Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a way the drawing's border size is defined (global or ratio).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property BorderType() As TxsgBorderType

C#

TxsgBorderType BorderType {get; set;}

C++

property TxsgBorderType BorderType {
TxsgBorderType get( );
void set(
TxsgBorderType value
);
}

JScript

function get BorderType() : TxsgBorderType;
function set BorderType(value : TxsgBorderType);

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.CADClassID Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.CADClassID Property

 Return to chapter overview

Show / hide the hidden text

Gets the CAD format identifier for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property CADClassID() As TxCADClassID

C#

TxCADClassID CADClassID {get;}

C++

property TxCADClassID CADClassID {
TxCADClassID get( );
}

JScript

function get CADClassID() : TxCADClassID;

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.CBFormat Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.CBFormat Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the clipboard format.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CBFormat() As UInt16

C#

UInt16 CBFormat {get; set;}

C++

property UInt16 CBFormat {
UInt16 get( );
void set(
UInt16 value
);
}

JScript

function get CBFormat() : UInt16;
function set CBFormat(value : UInt16);

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.CanStopLoading Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.CanStopLoading Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the loading of the drawing data can be terminated.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property CanStopLoading() As Boolean

C#

bool CanStopLoading {get;}

C++

property bool CanStopLoading {
bool get( );
}

JScript

function get CanStopLoading() : boolean;

Property Value

true if the loading can be terminated; otherwise, false.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.Charset Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.Charset Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a character set for the text entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Charset() As Byte

C#

byte Charset {get; set;}

C++

property Byte Charset {
Byte get( );
void set(
Byte value
);
}

JScript

function get Charset() : byte;
function set Charset(value : byte);

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.ColorToLineWeight Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.ColorToLineWeight Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a string which contains the color-lineweight pairs.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property ColorToLineWeight() As String

C#

string ColorToLineWeight {get; set;}

C++

property String^ ColorToLineWeight {
String^ get( );
void set(
String^ value
);
}

JScript

function get ColorToLineWeight() : String;
function set ColorToLineWeight(value : String);

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.Converter Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.Converter Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a Converter associated with this image object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Converter() As Converter

C#

Converter Converter {get;}

C++

property Converter^ Converter {
Converter^ get( );
}

JScript

function get Converter() : Converter;

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.Count Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.Count Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of entities in the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Count() As Integer

C#

int Count {get;}

C++

property int Count {
int get( );
}

JScript

function get Count() : int;

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.CurrentLayout Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.CurrentLayout Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the current layout for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CurrentLayout() As Layout

C#

Layout CurrentLayout {get; set;}

C++

property Layout^ CurrentLayout {
Layout^ get( );
void set(
Layout^ value
);
}

JScript

function get CurrentLayout() : Layout;
function set CurrentLayout(value : Layout);

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.DefaultColor Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.DefaultColor Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the default color for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DefaultColor() As UInt32

C#

UInt32 DefaultColor {get; set;}

C++

property UInt32 DefaultColor {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get DefaultColor() : UInt32;
function set DefaultColor(value : UInt32);

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.DimensionsVisible Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.DimensionsVisible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether dimensions in the drawing are visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DimensionsVisible() As Boolean

C#

bool DimensionsVisible {get; set;}

C++

property bool DimensionsVisible {
bool get( );
void set(
bool value
);
}

JScript

function get DimensionsVisible() : boolean;
function set DimensionsVisible(value : boolean);

Property Value

true if the dimensions are visible; otherwise, false. Default value is true.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.DrawMode Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.DrawMode Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets an appearance of colors in the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DrawMode() As TxDXFDrawMode

C#

TxDXFDrawMode DrawMode {get; set;}

C++

property TxDXFDrawMode DrawMode {
TxDXFDrawMode get( );
void set(
TxDXFDrawMode value
);
}

JScript

function get DrawMode() : TxDXFDrawMode;
function set DrawMode(value : TxDXFDrawMode);

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.DrawingBox Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.DrawingBox Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the drawing bounding box.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DrawingBox() As Rect3D

C#

Rect3D DrawingBox {get; set;}

C++

property Rect3D^ DrawingBox {
Rect3D^ get( );
void set(
Rect3D^ value
);
}

JScript

function get DrawingBox() : Rect3D;
function set DrawingBox(value : Rect3D);

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.Empty Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.Empty Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the drawing is empty.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Empty() As Boolean

C#

bool Empty {get;}

C++

property bool Empty {
bool get( );
}

JScript

function get Empty() : boolean;

Property Value

true if the drawing is empty; otherwise, false.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.Extents Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.Extents Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the drawing's extents.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Extents() As Rect3D

C#

Rect3D Extents {get; set;}

C++

property Rect3D^ Extents {
Rect3D^ get( );
void set(
Rect3D^ value
);
}

JScript

function get Extents() : Rect3D;
function set Extents(value : Rect3D);

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.Height Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.Height Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a height of the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Height() As Integer

C#

int Height {get; set;}

C++

property int Height {
int get( );
void set(
int value
);
}

JScript

function get Height() : int;
function set Height(value : int);

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.Is3D Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.Is3D Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the drawing is three-dimensional.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Is3D() As Boolean

C#

bool Is3D {get; set;}

C++

property bool Is3D {
bool get( );
void set(
bool value
);
}

JScript

function get Is3D() : boolean;
function set Is3D(value : boolean);

Property Value

true if the drawing is three-dimensional; otherwise, false.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.IsDraw3DAxes Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.IsDraw3DAxes Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether 3D axes are visible on the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsDraw3DAxes() As Boolean

C#

bool IsDraw3DAxes {get; set;}

C++

property bool IsDraw3DAxes {
bool get( );
void set(
bool value
);
}

JScript

function get IsDraw3DAxes() : boolean;
function set IsDraw3DAxes(value : boolean);

Property Value

true if the 3D axes are visible; otherwise, false.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.IsDrawingRotated Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.IsDrawingRotated Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the drawing is rotated.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsDrawingRotated() As Boolean

C#

bool IsDrawingRotated {get;}

C++

property bool IsDrawingRotated {
bool get( );
}

JScript

function get IsDrawingRotated() : boolean;

Property Value

true if the drawing is rotated; otherwise, false.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.IsLoading Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.IsLoading Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the process of loading the drawing data is active.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsLoading() As Boolean

C#

bool IsLoading {get;}

C++

property bool IsLoading {
bool get( );
}

JScript

function get IsLoading() : boolean;

Property Value

true if the drawing data is loading into this image object; otherwise, false.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.IsPlotting Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.IsPlotting Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether to plot the image or not.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsPlotting() As Boolean

C#

bool IsPlotting {get; set;}

C++

property bool IsPlotting {
bool get( );
void set(
bool value
);
}

JScript

function get IsPlotting() : boolean;
function set IsPlotting(value : boolean);

Property Value

true if the image should be plotted; otherwise, false.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.IsProcessMessages Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.IsProcessMessages Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the messages processing is allowed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsProcessMessages() As Boolean

C#

bool IsProcessMessages {get; set;}

C++

property bool IsProcessMessages {
bool get( );
void set(
bool value
);
}

JScript

function get IsProcessMessages() : boolean;
function set IsProcessMessages(value : boolean);

Property Value

true if the messages processing is allowed; otherwise, false.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.IsShowBackground Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.IsShowBackground Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the backround is displayed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsShowBackground() As Boolean

C#

bool IsShowBackground {get; set;}

C++

property bool IsShowBackground {
bool get( );
void set(
bool value
);
}

JScript

function get IsShowBackground() : boolean;
function set IsShowBackground(value : boolean);

Property Value

true if the backround is displayed; otherwise, false.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.IsShowLineWeight Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.IsShowLineWeight Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether a thickness of lines is determined by the drawing data.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsShowLineWeight() As Boolean

C#

bool IsShowLineWeight {get; set;}

C++

property bool IsShowLineWeight {
bool get( );
void set(
bool value
);
}

JScript

function get IsShowLineWeight() : boolean;
function set IsShowLineWeight(value : boolean);

Property Value

true if a thickness of lines is determined by the drawing data; otherwise, false.

collall Remarks

If this property value is false, a thickness of lines is determined by the NullWidth property.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.IsWithoutBorder Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.IsWithoutBorder Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether to display the drawing without borders.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsWithoutBorder() As Boolean

C#

bool IsWithoutBorder {get; set;}

C++

property bool IsWithoutBorder {
bool get( );
void set(
bool value
);
}

JScript

function get IsWithoutBorder() : boolean;
function set IsWithoutBorder(value : boolean);

Property Value

true if the borders are not displayed; otherwise, false.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.LayoutsCount Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.LayoutsCount Property

 Return to chapter overview

Show / hide the hidden text

Gets the number of layouts in the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property LayoutsCount() As Integer

C#

int LayoutsCount {get;}

C++

property int LayoutsCount {
int get( );
}

JScript

function get LayoutsCount() : int;

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.LineScaled Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.LineScaled Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the line weight is diplayed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineScaled() As Boolean

C#

bool LineScaled {get; set;}

C++

property bool LineScaled {
bool get( );
void set(
bool value
);
}

JScript

function get LineScaled() : boolean;
function set LineScaled(value : boolean);

Property Value

true if the line weight is displayed; otherwise, false.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.LineWeightScale Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.LineWeightScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a scale for line weights.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineWeightScale() As Double

C#

double LineWeightScale {get; set;}

C++

property double LineWeightScale {
double get( );
void set(
double value
);
}

JScript

function get LineWeightScale() : double;
function set LineWeightScale(value : double);

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.Millimetres Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.Millimetres Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Millimetres() As Boolean

C#

bool Millimetres {get; set;}

C++

property bool Millimetres {
bool get( );
void set(
bool value
);
}

JScript

function get Millimetres() : boolean;
function set Millimetres(value : boolean);

Property Value

true if the drawing units are millimeters; false if the drawing units are inches.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.Modified Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.Modified Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the drawing is modified.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Modified() As Boolean

C#

bool Modified {get; set;}

C++

property bool Modified {
bool get( );
void set(
bool value
);
}

JScript

function get Modified() : boolean;
function set Modified(value : boolean);

Property Value

true if the drawing is modified; otherwise, false.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.NullWidth Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.NullWidth Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a thickness for lines which have the zero lineweight.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property NullWidth() As Integer

C#

int NullWidth {get; set;}

C++

property int NullWidth {
int get( );
void set(
int value
);
}

JScript

function get NullWidth() : int;
function set NullWidth(value : int);

Property Value

Line thickness. Default value is 1.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.OwnSource Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.OwnSource Property

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property OwnSource() As Boolean

C#

bool OwnSource {get; set;}

C++

property bool OwnSource {
bool get( );
void set(
bool value
);
}

JScript

function get OwnSource() : boolean;
function set OwnSource(value : boolean);

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.PureExtents Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.PureExtents Property

 Return to chapter overview

Show / hide the hidden text

Gets the drawing's extents excluding the borders.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property PureExtents() As Rect3D

C#

Rect3D PureExtents {get;}

C++

property Rect3D^ PureExtents {
Rect3D^ get( );
}

JScript

function get PureExtents() : Rect3D;

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.ResizeDisproportionateDrawing Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.ResizeDisproportionateDrawing Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether to resize a drawing with disproportionate sizes.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property ResizeDisproportionateDrawing() As Boolean

C#

bool ResizeDisproportionateDrawing {get; set;}

C++

property bool ResizeDisproportionateDrawing {
bool get( );
void set(
bool value
);
}

JScript

function get ResizeDisproportionateDrawing() : boolean;
function set ResizeDisproportionateDrawing(value : boolean);

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.Scale Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.Scale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a 3D point which defines the scale factor.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Scale() As Point3D

C#

Point3D Scale {get;}

C++

property Point3D^ Scale {
Point3D^ get( );
}

JScript

function get Scale() : Point3D;

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.ShowImages Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.ShowImages Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the raster images are displayed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property ShowImages() As Boolean

C#

bool ShowImages {get; set;}

C++

property bool ShowImages {
bool get( );
void set(
bool value
);
}

JScript

function get ShowImages() : boolean;
function set ShowImages(value : boolean);

Property Value

true if the raster images are displayed; overwise, false.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.Stretch Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.Stretch Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the displayed image has to be stretched to fit exactly with the drawing rectangle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Stretch() As Boolean

C#

bool Stretch {get; set;}

C++

property bool Stretch {
bool get( );
void set(
bool value
);
}

JScript

function get Stretch() : boolean;
function set Stretch(value : boolean);

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.TextVisible Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.TextVisible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether texts in the drawing are visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property TextVisible() As Boolean

C#

bool TextVisible {get; set;}

C++

property bool TextVisible {
bool get( );
void set(
bool value
);
}

JScript

function get TextVisible() : boolean;
function set TextVisible(value : boolean);

Property Value

true if the texts are visible; otherwise, false.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.UseWinEllipse Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.UseWinEllipse Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether arcs and circles are drawn by using GDI+ methods without linearization.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property UseWinEllipse() As Boolean

C#

bool UseWinEllipse {get; set;}

C++

property bool UseWinEllipse {
bool get( );
void set(
bool value
);
}

JScript

function get UseWinEllipse() : boolean;
function set UseWinEllipse(value : boolean);

Property Value

true if the GDI+ methods are used for drawing arcs and circles; otherwise, false.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.ViewRectangle Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.ViewRectangle Property

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property ViewRectangle() As Rect3D

C#

Rect3D ViewRectangle {get; set;}

C++

property Rect3D^ ViewRectangle {
Rect3D^ get( );
void set(
Rect3D^ value
);
}

JScript

function get ViewRectangle() : Rect3D;
function set ViewRectangle(value : Rect3D);

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.Width Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.Width Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a width of the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Width() As Integer

C#

int Width {get; set;}

C++

property int Width {
int get( );
void set(
int value
);
}

JScript

function get Width() : int;
function set Width(value : int);

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.mmHeight Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.mmHeight Property

 Return to chapter overview

Show / hide the hidden text

Gets a height of the HPGL drawing in millimeters.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property mmHeight() As Double

C#

double mmHeight {get;}

C++

property double mmHeight {
double get( );
}

JScript

function get mmHeight() : double;

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.mmWidth Property

API Reference > CADViewLib Namespace > HPGLImage Interface > Properties >

IHPGLImage.mmWidth Property

 Return to chapter overview

Show / hide the hidden text

Gets a width of the HPGL drawing in millimeters.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property mmWidth() As Double

C#

double mmWidth {get;}

C++

property double mmWidth {
double get( );
}

JScript

function get mmWidth() : double;

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


HPGLImage Methods

API Reference > CADViewLib Namespace > HPGLImage Interface >

HPGLImage Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AbsHeight | Returns an absolute height of the CAD drawing. (inherited from IHPGLImage ).
Public method | AbsWidth | Returns an absolute width of the CAD drawing. (inherited from IHPGLImage ).
Public method | AddScaledDXF | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing. (inherited from IHPGLImage ).
Public method | AddScaledDXFEx | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing. (inherited from IHPGLImage ).
Public method | AssignImage | Makes a copy of a specified CAD image object and assigns it to this image. (inherited from IHPGLImage ).
Public method | CreateImage | Initializes a new CAD image instance. (inherited from IHPGLImage ).
Public method | Draw | Draws the CAD image in a specified device context (DC). (inherited from IHPGLImage ).
Public method | DrawRect | Draws a specified region of this CAD image in a device context (DC). (inherited from IHPGLImage ).
Public method | ExportToMetafile | Exports this CAD image to Windows metafile. (inherited from IHPGLImage ).
Public method | FreeImage | Destroys this CAD image object and frees the memory used within the object. (inherited from IHPGLImage ).
Public method | GetCADCoords | Returns CAD coordinates for a specified point. (inherited from IHPGLImage ).
Public method | GetEntityColor | Returns the color value for a specified entity. (inherited from IHPGLImage ).
Public method | GetExtents | Recalculates extents of the CAD image. (inherited from IHPGLImage ).
Public method | GetPoint | Gets the on-screen coordinates for a specified CAD point. (inherited from IHPGLImage ).
Public method | GetRealImagePoint | Returns CAD coordinates of a specified point considering the drawing's rotation and viewport parameters. (inherited from IHPGLImage ).
Public method | HeadVarAsFloat | Returns a value of the DXF header variable as a floating point number. (inherited from IHPGLImage ).
Public method | HeadVarAsInteger | Returns a value of the DXF header variable as an integer. (inherited from IHPGLImage ).
Public method | HeadVarAsstring | Returns a value of the DXF header variable as a string. (inherited from IHPGLImage ).
Public method | LoadFromClipboardFormat | Loads data from the clipboard. (inherited from IHPGLImage ).
Public method | LoadFromFile | Loads a CAD drawing from file. (inherited from IHPGLImage ).
Public method | LoadFromIStream | Loads a CAD drawing from stream. (inherited from IHPGLImage ).
Public method | LoadFromStream | Loads a CAD drawing from stream. (inherited from IHPGLImage ).
Public method | RefreshCurrentLayout | Refreshes the current layout. (inherited from IHPGLImage ).
Public method | ResetDrawingBox | Switches off the drawing box. (inherited from IHPGLImage ).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from IHPGLImage ).
Public method | RotToView | Rotates the drawing to a specified view. (inherited from IHPGLImage ).
Public method | Rotate | Rotates the drawing. (inherited from IHPGLImage ).
Public method | SaveToClipboardFormat | Copies the drawing to the clipboard in a specified format. (inherited from IHPGLImage ).
Public method | SaveToFile | Saves the drawing to a specified file. (inherited from IHPGLImage ).
Public method | SaveToIStream | Writes the drawing data to a specified stream. (inherited from IHPGLImage ).
Public method | SaveToStream | Writes the drawing data to a specified stream. (inherited from IHPGLImage ).
Public method | SetClippingRect | Sets a clipping rectangle for the drawing. (inherited from IHPGLImage ).
Public method | SetExtentsParameters | Changes the drawing extents. (inherited from IHPGLImage ).
Public method | StopLoading | Terminates loading of the drawing data. (inherited from IHPGLImage ).
Public method | get_Blocks | Retrieves a BLOCK object by its index. (inherited from IHPGLImage ).
Public method | get_Entities | Retrieves an entity by its index. (inherited from IHPGLImage ).
Public method | get_Items | (inherited from IHPGLImage ).
Public method | get_Layouts | Retrieves a layout by its index. (inherited from IHPGLImage ).

Top

collall See Also

Reference

HPGLImage Interface


IHPGLImage.AbsHeight Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.AbsHeight Method

 Return to chapter overview

Show / hide the hidden text

Returns an absolute height of the CAD drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function AbsHeight() As Double

C#

override double AbsHeight()

C++

double AbsHeight()

JScript

function AbsHeight() : double;

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.AbsWidth Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.AbsWidth Method

 Return to chapter overview

Show / hide the hidden text

Returns an absolute width of the CAD drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function AbsWidth() As Double

C#

override double AbsWidth()

C++

double AbsWidth()

JScript

function AbsWidth() : double;

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.AddScaledDXF Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.AddScaledDXF Method

 Return to chapter overview

Show / hide the hidden text

Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AddScaledDXF( _
ByVal ACADFile As DXFImage, _
ByVal AName As String, _
ByVal APos As Point3D, _
ByVal AScale As Point3D, _
ByVal Rotation As Single _
)

C#

override void AddScaledDXF(
DXFImageACADFile,
stringAName,
Point3DAPos,
Point3DAScale,
floatRotation
)

C++

void AddScaledDXF(
DXFImage^ ACADFile,
String^ AName,
Point3D^ APos,
Point3D^ AScale,
floatRotation
)

JScript

function AddScaledDXF(
ACADFile : DXFImage,
AName : String,
APos : Point3D,
AScale : Point3D,
Rotation : float
);

Parameters

ACADFile

DXF image which defines the external reference.

AName

User-defined name for the XREF.

APos

The insertion point.

AScale

3D point which determines the scale factor.

Rotation

XREF rotation angle.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.AddScaledDXFEx Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.AddScaledDXFEx Method

 Return to chapter overview

Show / hide the hidden text

Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function AddScaledDXFEx( _
ByVal ACADFile As DXFImage, _
ByVal AName As String, _
ByVal APos As Point3D, _
ByVal AScale As Point3D, _
ByVal Rotation As Single _
) As Insert

C#

override Insert AddScaledDXFEx(
DXFImage ACADFile,
stringAName,
Point3DAPos,
Point3DAScale,
floatRotation
)

C++

Insert^ AddScaledDXFEx(
DXFImage^ ACADFile,
String^ AName,
Point3D^ APos,
Point3D^ AScale,
floatRotation
)

JScript

function AddScaledDXFEx(
ACADFile : DXFImage,
AName : String,
APos : Point3D,
AScale : Point3D,
Rotation : float
) : Insert;

Parameters

ACADFile

DXF image which defines the external reference.

AName

User-defined name for the XREF.

APos

The insertion point.

AScale

3D point which determines the scale factor.

Rotation

XREF rotation angle.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.AssignImage Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.AssignImage Method

 Return to chapter overview

Show / hide the hidden text

Makes a copy of a specified CAD image object and assigns it to this image.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AssignImage( _
ByVal Source As Object _
)

C#

override void AssignImage(
objectSource
)

C++

void AssignImage(
object^ Source
)

JScript

function AssignImage(
Source : object
);

Parameters

Source

The source CAD image object which will be copied.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.CreateImage Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.CreateImage Method

 Return to chapter overview

Show / hide the hidden text

Initializes a new CAD image instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub CreateImage()

C#

override void CreateImage()

C++

void CreateImage()

JScript

function CreateImage();

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.Draw Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.Draw Method

 Return to chapter overview

Show / hide the hidden text

Draws the CAD image in a specified device context (DC).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub Draw( _
ByVal DC As Integer, _
ByVal Rect As Rect2D _
)

C#

override void Draw(
intDC,
Rect2DRect
)

C++

void Draw(
intDC,
Rect2D^ Rect
)

JScript

function Draw(
DC : int,
Rect : Rect2D
);

Parameters

DC

Handle to the DC.

Rect

Rectangle which defines the drawing area in the DC.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.DrawRect Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.DrawRect Method

 Return to chapter overview

Show / hide the hidden text

Draws a specified region of this CAD image in a device context (DC).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub DrawRect( _
ByVal DC As Integer, _
ByVal SourceRect As Rect3D, _
ByVal DestRect As Rect2D _
)

C#

override void DrawRect(
intDC,
Rect3DSourceRect,
Rect2DDestRect
)

C++

void DrawRect(
intDC,
Rect3D^ SourceRect,
Rect2D^ DestRect
)

JScript

function DrawRect(
DC : int,
SourceRect : Rect3D,
DestRect : Rect2D
);

Parameters

DC

Handle to the DC.

SourceRect

The region which will be drawn in the DC.

DestRect

Rectangle which defines the drawing area in the DC.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.ExportToMetafile Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.ExportToMetafile Method

 Return to chapter overview

Show / hide the hidden text

Exports this CAD image to Windows metafile.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub ExportToMetafile( _
ByVal FileName As String, _
ByVal AWidth As Integer, _
ByVal AHeight As Integer _
)

C#

override void ExportToMetafile(
stringFileName,
intAWidth,
intAHeight
)

C++

void ExportToMetafile(
String^ FileName,
intAWidth,
intAHeight
)

JScript

function ExportToMetafile(
FileName : String,
AWidth : int,
AHeight : int
);

Parameters

FileName

Path to the output metafile.

AWidth

Width of the output metafile.

AHeight

Height of the output metafile.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.FreeImage Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.FreeImage Method

 Return to chapter overview

Show / hide the hidden text

Destroys this CAD image object and frees the memory used within the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub FreeImage()

C#

override void FreeImage()

C++

void FreeImage()

JScript

function FreeImage();

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.GetCADCoords Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.GetCADCoords Method

 Return to chapter overview

Show / hide the hidden text

Returns CAD coordinates for a specified point.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetCADCoords( _
ByVal AXScaled As Double, _
ByVal AYScaled As Double _
) As Point3D

C#

override Point3D GetCADCoords(
doubleAXScaled,
doubleAYScaled
)

C++

Point3D^ GetCADCoords(
doubleAXScaled,
doubleAYScaled
)

JScript

function GetCADCoords(
AXScaled : double,
AYScaled : double
) : Point3D;

Parameters

AXScaled

Ratio between the x-coordinate and the drawing's width.

AYScaled

Ratio between the y-coordinate and the drawing's height.

collall Remarks

The z-coordinate of the returned point is equal 0.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.GetEntityColor Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.GetEntityColor Method

 Return to chapter overview

Show / hide the hidden text

Returns the color value for a specified entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetEntityColor( _
ByVal AEntity As Entity, _
ByVal AInsert As Insert _
) As UInt32

C#

override UInt32 GetEntityColor(
EntityAEntity,
InsertAInsert
)

C++

UInt32 GetEntityColor(
Entity^ AEntity,
Insert^ AInsert
)

JScript

function GetEntityColor(
AEntity : Entity,
AInsert : Insert
) : UInt32;

Parameters

AEntity

The entity whose color is retrieved.

AInsert

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.GetExtents Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.GetExtents Method

 Return to chapter overview

Show / hide the hidden text

Recalculates extents of the CAD image.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub GetExtents()

C#

override void GetExtents()

C++

void GetExtents()

JScript

function GetExtents();

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.GetPoint Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.GetPoint Method

 Return to chapter overview

Show / hide the hidden text

Gets the on-screen coordinates for a specified CAD point.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetPoint( _
ByVal P As Point3D _
) As Point2D

C#

override Point2D GetPoint(
Point3D P
)

C++

Point2D^ GetPoint(
Point3D^ P
)

JScript

function GetPoint(
P : Point3D
) : Point2D;

Parameters

P

CAD point coordinates in the 3D space.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.GetRealImagePoint Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.GetRealImagePoint Method

 Return to chapter overview

Show / hide the hidden text

Returns CAD coordinates of a specified point considering the drawing's rotation and viewport parameters.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetRealImagePoint( _
ByVal P As Point3D _
) As Point3D

C#

override Point3D GetRealImagePoint(
Point3D P
)

C++

Point3D^ GetRealImagePoint(
Point3D^ P
)

JScript

function GetRealImagePoint(
P : Point3D
) : Point3D;

Parameters

P

CAD point in the 3D space.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.HeadVarAsFloat Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.HeadVarAsFloat Method

 Return to chapter overview

Show / hide the hidden text

Returns a value of the DXF header variable as a floating point number.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function HeadVarAsFloat( _
ByVal AName As String, _
ByVal ACode As Integer _
) As Double

C#

override double HeadVarAsFloat(
stringAName,
intACode
)

C++

double HeadVarAsFloat(
String^ AName,
intACode
)

JScript

function HeadVarAsFloat(
AName : String,
ACode : int
) : double;

Parameters

AName

The header variable name.

ACode

Group code associated with the variable's value.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.HeadVarAsInteger Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.HeadVarAsInteger Method

 Return to chapter overview

Show / hide the hidden text

Returns a value of the DXF header variable as an integer.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function HeadVarAsInteger( _
ByVal AName As String, _
ByVal ACode As Integer _
) As Integer

C#

override int HeadVarAsInteger(
stringAName,
intACode
)

C++

int HeadVarAsInteger(
String^ AName,
intACode
)

JScript

function HeadVarAsInteger(
AName : String,
ACode : int
) : int;

Parameters

AName

The header variable name.

ACode

Group code associated with the variable's value.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.HeadVarAsstring Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.HeadVarAsstring Method

 Return to chapter overview

Show / hide the hidden text

Returns a value of the DXF header variable as a string.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function HeadVarAsstring( _
ByVal AName As String, _
ByVal ACode As Integer _
) As String

C#

override string HeadVarAsstring(
stringAName,
intACode
)

C++

String^ HeadVarAsstring(
String^ AName,
intACode
)

JScript

function HeadVarAsstring(
AName : String,
ACode : int
) : String;

Parameters

AName

The header variable name.

ACode

Group code associated with the variable's value.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.LoadFromClipboardFormat Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.LoadFromClipboardFormat Method

 Return to chapter overview

Show / hide the hidden text

Loads data from the clipboard.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub LoadFromClipboardFormat( _
ByVal Fmt As UInt16, _
ByVal Data As Integer, _
ByVal Pal As Integer _
)

C#

override void LoadFromClipboardFormat(
UInt16Fmt,
intData,
intPal
)

C++

void LoadFromClipboardFormat(
UInt16Fmt,
intData,
intPal
)

JScript

function LoadFromClipboardFormat(
Fmt : UInt16,
Data : int,
Pal : int
);

Parameters

Fmt

Data

Pal

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.LoadFromFile Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.LoadFromFile Method

 Return to chapter overview

Show / hide the hidden text

Loads a CAD drawing from file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub LoadFromFile( _
ByVal FileName As String _
)

C#

override void LoadFromFile(
stringFileName
)

C++

void LoadFromFile(
String^ FileName
)

JScript

function LoadFromFile(
FileName : String
);

Parameters

FileName

Path to the drawing file.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.LoadFromIStream Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.LoadFromIStream Method

 Return to chapter overview

Show / hide the hidden text

Loads a CAD drawing from stream.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub LoadFromIStream( _
ByVal Stream As Object _
)

C#

override void LoadFromIStream(
objectStream
)

C++

void LoadFromIStream(
object^ Stream
)

JScript

function LoadFromIStream(
Stream : object
);

Parameters

Stream

Stream which contains the CAD drawing data.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.LoadFromStream Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.LoadFromStream Method

 Return to chapter overview

Show / hide the hidden text

Loads a CAD drawing from stream.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub LoadFromStream( _
ByVal hStream As Integer _
)

C#

override void LoadFromStream(
inthStream
)

C++

void LoadFromStream(
inthStream
)

JScript

function LoadFromStream(
hStream : int
);

Parameters

hStream

Handle to the stream which contains the drawing data.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.RefreshCurrentLayout Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.RefreshCurrentLayout Method

 Return to chapter overview

Show / hide the hidden text

Refreshes the current layout.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub RefreshCurrentLayout()

C#

override void RefreshCurrentLayout()

C++

void RefreshCurrentLayout()

JScript

function RefreshCurrentLayout();

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.ResetDrawingBox Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.ResetDrawingBox Method

 Return to chapter overview

Show / hide the hidden text

Switches off the drawing box.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub ResetDrawingBox()

C#

override void ResetDrawingBox()

C++

void ResetDrawingBox()

JScript

function ResetDrawingBox();

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.RotDefault Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.RotDefault Method

 Return to chapter overview

Show / hide the hidden text

Rotates the drawing to the default view.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub RotDefault()

C#

override void RotDefault()

C++

void RotDefault()

JScript

function RotDefault();

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.RotToView Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.RotToView Method

 Return to chapter overview

Show / hide the hidden text

Rotates the drawing to a specified view.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub RotToView( _
ByVal A3DView As TxDXFViewDirection _
)

C#

override void RotToView(
TxDXFViewDirectionA3DView
)

C++

void RotToView(
TxDXFViewDirectionA3DView
)

JScript

function RotToView(
A3DView : TxDXFViewDirection
);

Parameters

A3DView

One of the orthogonal or isometric views.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.Rotate Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.Rotate Method

 Return to chapter overview

Show / hide the hidden text

Rotates the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub Rotate( _
ByVal Axis As TxAxes, _
ByVal Angle As Double _
)

C#

override void Rotate(
TxAxesAxis,
doubleAngle
)

C++

void Rotate(
TxAxesAxis,
doubleAngle
)

JScript

function Rotate(
Axis : TxAxes,
Angle : double
);

Parameters

Axis

Rotation axis.

Angle

Rotation angle (measured in degrees).

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.SaveToClipboardFormat Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.SaveToClipboardFormat Method

 Return to chapter overview

Show / hide the hidden text

Copies the drawing to the clipboard in a specified format.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SaveToClipboardFormat( _
ByRef Fmt As UInt16, _
ByRef Data As Integer, _
ByRef Pal As Integer _
)

C#

override void SaveToClipboardFormat(
ref UInt16Fmt,
ref intData,
ref intPal
)

C++

void SaveToClipboardFormat(
UInt16& Fmt,
int& Data,
int& Pal
)

JScript

function SaveToClipboardFormat(
Fmt : UInt16,
Data : int,
Pal : int
);

Parameters

Fmt

Clipboard format.

Data

Pal

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.SaveToFile Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.SaveToFile Method

 Return to chapter overview

Show / hide the hidden text

Saves the drawing to a specified file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SaveToFile( _
ByVal FileName As String _
)

C#

override void SaveToFile(
stringFileName
)

C++

void SaveToFile(
String^ FileName
)

JScript

function SaveToFile(
FileName : String
);

Parameters

FileName

Path to the output file.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.SaveToIStream Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.SaveToIStream Method

 Return to chapter overview

Show / hide the hidden text

Writes the drawing data to a specified stream.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SaveToIStream( _
ByVal Stream As Object _
)

C#

override void SaveToIStream(
objectStream
)

C++

void SaveToIStream(
object^ Stream
)

JScript

function SaveToIStream(
Stream : object
);

Parameters

Stream

Stream where the drawing data is written.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.SaveToStream Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.SaveToStream Method

 Return to chapter overview

Show / hide the hidden text

Writes the drawing data to a specified stream.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SaveToStream( _
ByVal Stream As Integer _
)

C#

override void SaveToStream(
intStream
)

C++

void SaveToStream(
intStream
)

JScript

function SaveToStream(
Stream : int
);

Parameters

Stream

Stream where the drawing data will be written.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.SetClippingRect Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.SetClippingRect Method

 Return to chapter overview

Show / hide the hidden text

Sets a clipping rectangle for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetClippingRect( _
ByVal Value As Rect3D _
)

C#

override void SetClippingRect(
Rect3DValue
)

C++

void SetClippingRect(
Rect3D^ Value
)

JScript

function SetClippingRect(
Value : Rect3D
);

Parameters

Value

The clipping rectangle area.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.SetExtentsParameters Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.SetExtentsParameters Method

 Return to chapter overview

Show / hide the hidden text

Changes the drawing extents.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetExtentsParameters( _
ByVal ARect As Rect3D, _
ByVal AIs3DExtents As Boolean _
)

C#

override void SetExtentsParameters(
Rect3DARect,
boolAIs3DExtents
)

C++

void SetExtentsParameters(
Rect3D^ ARect,
boolAIs3DExtents
)

JScript

function SetExtentsParameters(
ARect : Rect3D,
AIs3DExtents : boolean
);

Parameters

ARect

The parallelepiped which defines the extents.

AIs3DExtents

If set to true, then the extents are 3D; otherwise, the extents are 2D.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.StopLoading Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.StopLoading Method

 Return to chapter overview

Show / hide the hidden text

Terminates loading of the drawing data.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub StopLoading()

C#

override void StopLoading()

C++

void StopLoading()

JScript

function StopLoading();

collall Remarks

The portion of the drawing data which was loaded can be displayed in the control.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.get_Blocks Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.get_Blocks Method

 Return to chapter overview

Show / hide the hidden text

Retrieves a BLOCK object by its index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Blocks( _
ByVal Index As Integer _
) As Block

C#

override Block get_Blocks(
intIndex
)

C++

Block^ get_Blocks(
intIndex
)

JScript

function get_Blocks(
Index : int
) : Block;

Parameters

Index

Index of the block.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.get_Entities Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.get_Entities Method

 Return to chapter overview

Show / hide the hidden text

Retrieves an entity by its index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Entities( _
ByVal Index As Integer _
) As Entity

C#

override Entity get_Entities(
intIndex
)

C++

Entity^ get_Entities(
intIndex
)

JScript

function get_Entities(
Index : int
) : Entity;

Parameters

Index

Index of the entity.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.get_Items Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.get_Items Method

 Return to chapter overview

Show / hide the hidden text

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Items( _
ByVal Index As Integer _
) As DXFImage

C#

override DXFImage get_Items(
intIndex
)

C++

DXFImage^ get_Items(
intIndex
)

JScript

function get_Items(
Index : int
) : DXFImage;

Parameters

Index

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IHPGLImage.get_Layouts Method

API Reference > CADViewLib Namespace > HPGLImage Interface > Methods >

IHPGLImage.get_Layouts Method

 Return to chapter overview

Show / hide the hidden text

Retrieves a layout by its index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Layouts( _
ByVal Index As Integer _
) As Layout

C#

override Layout get_Layouts(
intIndex
)

C++

Layout^ get_Layouts(
intIndex
)

JScript

function get_Layouts(
Index : int
) : Layout;

Parameters

Index

Index of the layout.

collall See Also

Reference

IHPGLImage Interface
IHPGLImage IHPGLImage Members


IArc Interface

API Reference > CADViewLib Namespace >

IArc Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to ARC entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface IArc
Inherits ICircle

C#

public interface IArc : ICircle

C++

public interface class IArc : public ICircle^

JScript

public interface IArc
implements ICircle

collall See Also

Reference

IArc Members


IArc Members

API Reference > CADViewLib Namespace > IArc Interface >

IArc Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to ARC entities.

The following tables list the members exposed by the IArc type.

collall Public Properties

 | Name | Description
Public property | ArrowsCount | Gets a quantity of points that form an arrow.
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Closed | Gets or sets a value indicating whether this polyline is closed.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | DottedPointsCount | Gets a quantity of points that determine the dots and dashes for a polyline with non-solid line type.
Public property | EndAngle | Gets or sets the end angle.
Public property | EndPoint | Gets or sets the end point of arc/ellipse
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Flags | Gets or sets a bit-coded flag indicating the polyline type.
Public property | GlobalWidth | Gets or sets a global width for this polyline.
Public property | IsMeshMClosed | Gets a value indicating whether the polygon mesh is closed in the M direction.
Public property | IsMeshNClosed | Gets a value indicating whether the polygon mesh is closed in the N direction.
Public property | IsPolyFaceMesh | Gets a value indicating whether this polyline is a polyface mesh.
Public property | IsPolyZThickness | Gets a value indicating whether the polyline has thickness measured along the axis Z.
Public property | IsPolygonMesh | Gets a value indicating whether this polyline is a polygon mesh.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | MeshM | Gets or sets a number of vertices for the polygon mesh in the M direction.
Public property | MeshN | Gets or sets a number of vertices for the polygon mesh in the N direction.
Public property | Name | Gets or sets a name of this object.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | PenLine | Gets properties of the pen used for drawing the object.
Public property | Point | Gets or sets the center point.
Public property | PointsCount | Gets a number of the polyline points.
Public property | PolyFaceVertexIndexesCount | Gets a quantity of indices which specify the order of traversing vertices in the polyface mesh.
Public property | Radius | Gets or sets a radius of the circle/ellipse/arc.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | StartAngle | Gets or sets the start angle.
Public property | StartPoint | Gets or sets the start point of arc/ellipse
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetArea | Returns the area bounded by a closed polygon.
Public method | GetBoxPoints | For internal use.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Arrows | Returns a point of the arrowhead.
Public method | get_DottedPoints | Returns coordinates of a point in the points array that determines dots and dashes for a non-solid line type.
Public method | get_Entities | Returns the child entity at the given index.
Public method | get_Points | Returns coordinates of a point in the points array.
Public method | get_PolyFaceVertexIndexes | Returns a value which indicates an index of the polyface mesh vertex.
Public method | set_Arrows | Modifies a point of the arrowhead at the given index.

Top

collall See Also

Reference

IArc Interface


IArc Properties

API Reference > CADViewLib Namespace > IArc Interface >

IArc Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | ArrowsCount | Gets a quantity of points that form an arrow.
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Closed | Gets or sets a value indicating whether this polyline is closed.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | DottedPointsCount | Gets a quantity of points that determine the dots and dashes for a polyline with non-solid line type.
Public property | EndAngle | Gets or sets the end angle.
Public property | EndPoint | Gets or sets the end point of arc/ellipse
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Flags | Gets or sets a bit-coded flag indicating the polyline type.
Public property | GlobalWidth | Gets or sets a global width for this polyline.
Public property | IsMeshMClosed | Gets a value indicating whether the polygon mesh is closed in the M direction.
Public property | IsMeshNClosed | Gets a value indicating whether the polygon mesh is closed in the N direction.
Public property | IsPolyFaceMesh | Gets a value indicating whether this polyline is a polyface mesh.
Public property | IsPolyZThickness | Gets a value indicating whether the polyline has thickness measured along the axis Z.
Public property | IsPolygonMesh | Gets a value indicating whether this polyline is a polygon mesh.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | MeshM | Gets or sets a number of vertices for the polygon mesh in the M direction.
Public property | MeshN | Gets or sets a number of vertices for the polygon mesh in the N direction.
Public property | Name | Gets or sets a name of this object.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | PenLine | Gets properties of the pen used for drawing the object.
Public property | Point | Gets or sets the center point.
Public property | PointsCount | Gets a number of the polyline points.
Public property | PolyFaceVertexIndexesCount | Gets a quantity of indices which specify the order of traversing vertices in the polyface mesh.
Public property | Radius | Gets or sets a radius of the circle/ellipse/arc.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | StartAngle | Gets or sets the start angle.
Public property | StartPoint | Gets or sets the start point of arc/ellipse
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall See Also

Reference

IArc Interface


IArc Methods

API Reference > CADViewLib Namespace > IArc Interface >

IArc Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetArea | Returns the area bounded by a closed polygon.
Public method | GetBoxPoints | For internal use.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Arrows | Returns a point of the arrowhead.
Public method | get_DottedPoints | Returns coordinates of a point in the points array that determines dots and dashes for a non-solid line type.
Public method | get_Entities | Returns the child entity at the given index.
Public method | get_Points | Returns coordinates of a point in the points array.
Public method | get_PolyFaceVertexIndexes | Returns a value which indicates an index of the polyface mesh vertex.
Public method | set_Arrows | Modifies a point of the arrowhead at the given index.

Top

collall See Also

Reference

IArc Interface


IAttDef Interface

API Reference > CADViewLib Namespace >

IAttDef Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to ATTDEF entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface IAttDef
Inherits IText

C#

public interface IAttDef : IText

C++

public interface class IAttDef : public IText^

JScript

public interface IAttDef
implements IText

collall See Also

Reference

IAttDef Members


IAttDef Members

API Reference > CADViewLib Namespace > IAttDef Interface >

IAttDef Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to ATTDEF entities.

The following tables list the members exposed by the IAttDef type.

collall Public Properties

 | Name | Description
Public property | Backward | Gets a value indicating whether the text is drawn backwards.
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Flags | Gets or sets the attribute flags.
Public property | Font | Gets or sets a font for displaying the text.
Public property | FontName | Gets or sets a name of the font file.
Public property | Generation | Gets or sets text generation flags.
Public property | HAlign | Gets or sets horizontal text justification type integer codes (not bit-coded).
Public property | Height | Gets or sets a height of the text.
Public property | IsSHXFont | Gets a value indicating whether the text uses an SHX font.
Public property | IsUnicodeText | Gets a value indicating whether the text uses Unicode for characters encoding.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | Name | Gets or sets a name of this object.
Public property | ObliqueAngle | Gets or sets an oblique angle for text characters.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | Point | Gets or sets the first alignment point.
Public property | Point1 | Gets or sets the second alignment point.
Public property | Rotation | Gets or sets the rotation angle of the text.
Public property | SHXFontName | Gets or sets a name of SHX font file.
Public property | SHXText | Gets a string of the SHX text.
Public property | SHXUnicodeText | Gets a string of the SHX Unicode text.
Public property | Scale | Gets or sets relative X scale factor (width).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | StartPoint | Gets the start point of the text.
Public property | Tag | Gets or sets the tag string.
Public property | Text | Gets or sets the text value.
Public property | UnicodeText | Gets the text value as Unicode string.
Public property | UpsideDown | Gets a value indicating whether the text is upside down (mirrored in Y).
Public property | VAlign | Gets or sets vertical text justification type: integer codes (not bit-coded).
Public property | Value | Gets or sets a value of the attribute.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.
Public property | WinFont | Gets a value indicating whether the text is rendered using a Windows font.
Public property | XScale | Gets or sets relative X scale factor (width).

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | DoNewText | Replaces the text value with a new string.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetBase | Returns the base point of the text.
Public method | GetBoxPoints | For internal use.
Public method | GetSHXMatrix | Returns a coordinate transformation matrix.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Entities | Returns the child entity at the given index.

Top

collall See Also

Reference

IAttDef Interface


IAttDef Properties

API Reference > CADViewLib Namespace > IAttDef Interface >

IAttDef Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Backward | Gets a value indicating whether the text is drawn backwards.
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Flags | Gets or sets the attribute flags.
Public property | Font | Gets or sets a font for displaying the text.
Public property | FontName | Gets or sets a name of the font file.
Public property | Generation | Gets or sets text generation flags.
Public property | HAlign | Gets or sets horizontal text justification type integer codes (not bit-coded).
Public property | Height | Gets or sets a height of the text.
Public property | IsSHXFont | Gets a value indicating whether the text uses an SHX font.
Public property | IsUnicodeText | Gets a value indicating whether the text uses Unicode for characters encoding.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | Name | Gets or sets a name of this object.
Public property | ObliqueAngle | Gets or sets an oblique angle for text characters.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | Point | Gets or sets the first alignment point.
Public property | Point1 | Gets or sets the second alignment point.
Public property | Rotation | Gets or sets the rotation angle of the text.
Public property | SHXFontName | Gets or sets a name of SHX font file.
Public property | SHXText | Gets a string of the SHX text.
Public property | SHXUnicodeText | Gets a string of the SHX Unicode text.
Public property | Scale | Gets or sets relative X scale factor (width).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | StartPoint | Gets the start point of the text.
Public property | Tag | Gets or sets the tag string.
Public property | Text | Gets or sets the text value.
Public property | UnicodeText | Gets the text value as Unicode string.
Public property | UpsideDown | Gets a value indicating whether the text is upside down (mirrored in Y).
Public property | VAlign | Gets or sets vertical text justification type: integer codes (not bit-coded).
Public property | Value | Gets or sets a value of the attribute.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.
Public property | WinFont | Gets a value indicating whether the text is rendered using a Windows font.
Public property | XScale | Gets or sets relative X scale factor (width).

Top

collall See Also

Reference

IAttDef Interface


IAttDef Methods

API Reference > CADViewLib Namespace > IAttDef Interface >

IAttDef Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | DoNewText | Replaces the text value with a new string.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetBase | Returns the base point of the text.
Public method | GetBoxPoints | For internal use.
Public method | GetSHXMatrix | Returns a coordinate transformation matrix.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Entities | Returns the child entity at the given index.

Top

collall See Also

Reference

IAttDef Interface


IAttrib Interface

API Reference > CADViewLib Namespace >

IAttrib Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to ATTRIB entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface IAttrib
Inherits IAttDef

C#

public interface IAttrib : IAttDef

C++

public interface class IAttrib : public IAttDef^

JScript

public interface IAttrib
implements IAttDef

collall See Also

Reference

IAttrib Members


IAttrib Members

API Reference > CADViewLib Namespace > IAttrib Interface >

IAttrib Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to ATTRIB entities.

The following tables list the members exposed by the IAttrib type.

collall Public Properties

 | Name | Description
Public property | Backward | Gets a value indicating whether the text is drawn backwards.
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Flags | Gets or sets the attribute flags.
Public property | Font | Gets or sets a font for displaying the text.
Public property | FontName | Gets or sets a name of the font file.
Public property | Generation | Gets or sets text generation flags.
Public property | HAlign | Gets or sets horizontal text justification type integer codes (not bit-coded).
Public property | Height | Gets or sets a height of the text.
Public property | IsSHXFont | Gets a value indicating whether the text uses an SHX font.
Public property | IsUnicodeText | Gets a value indicating whether the text uses Unicode for characters encoding.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | Name | Gets or sets a name of this object.
Public property | ObliqueAngle | Gets or sets an oblique angle for text characters.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | Point | Gets or sets the first alignment point.
Public property | Point1 | Gets or sets the second alignment point.
Public property | Rotation | Gets or sets the rotation angle of the text.
Public property | SHXFontName | Gets or sets a name of SHX font file.
Public property | SHXText | Gets a string of the SHX text.
Public property | SHXUnicodeText | Gets a string of the SHX Unicode text.
Public property | Scale | Gets or sets relative X scale factor (width).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | StartPoint | Gets the start point of the text.
Public property | Tag | Gets or sets the tag string.
Public property | Text | Gets or sets the text value.
Public property | UnicodeText | Gets the text value as Unicode string.
Public property | UpsideDown | Gets a value indicating whether the text is upside down (mirrored in Y).
Public property | VAlign | Gets or sets vertical text justification type: integer codes (not bit-coded).
Public property | Value | Gets or sets a value of the attribute.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.
Public property | WinFont | Gets a value indicating whether the text is rendered using a Windows font.
Public property | XScale | Gets or sets relative X scale factor (width).

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | DoNewText | Replaces the text value with a new string.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetBase | Returns the base point of the text.
Public method | GetBoxPoints | For internal use.
Public method | GetSHXMatrix | Returns a coordinate transformation matrix.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Entities | Returns the child entity at the given index.

Top

collall See Also

Reference

IAttrib Interface


IAttrib Properties

API Reference > CADViewLib Namespace > IAttrib Interface >

IAttrib Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Backward | Gets a value indicating whether the text is drawn backwards.
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Flags | Gets or sets the attribute flags.
Public property | Font | Gets or sets a font for displaying the text.
Public property | FontName | Gets or sets a name of the font file.
Public property | Generation | Gets or sets text generation flags.
Public property | HAlign | Gets or sets horizontal text justification type integer codes (not bit-coded).
Public property | Height | Gets or sets a height of the text.
Public property | IsSHXFont | Gets a value indicating whether the text uses an SHX font.
Public property | IsUnicodeText | Gets a value indicating whether the text uses Unicode for characters encoding.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | Name | Gets or sets a name of this object.
Public property | ObliqueAngle | Gets or sets an oblique angle for text characters.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | Point | Gets or sets the first alignment point.
Public property | Point1 | Gets or sets the second alignment point.
Public property | Rotation | Gets or sets the rotation angle of the text.
Public property | SHXFontName | Gets or sets a name of SHX font file.
Public property | SHXText | Gets a string of the SHX text.
Public property | SHXUnicodeText | Gets a string of the SHX Unicode text.
Public property | Scale | Gets or sets relative X scale factor (width).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | StartPoint | Gets the start point of the text.
Public property | Tag | Gets or sets the tag string.
Public property | Text | Gets or sets the text value.
Public property | UnicodeText | Gets the text value as Unicode string.
Public property | UpsideDown | Gets a value indicating whether the text is upside down (mirrored in Y).
Public property | VAlign | Gets or sets vertical text justification type: integer codes (not bit-coded).
Public property | Value | Gets or sets a value of the attribute.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.
Public property | WinFont | Gets a value indicating whether the text is rendered using a Windows font.
Public property | XScale | Gets or sets relative X scale factor (width).

Top

collall See Also

Reference

IAttrib Interface


IAttrib Methods

API Reference > CADViewLib Namespace > IAttrib Interface >

IAttrib Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | DoNewText | Replaces the text value with a new string.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetBase | Returns the base point of the text.
Public method | GetBoxPoints | For internal use.
Public method | GetSHXMatrix | Returns a coordinate transformation matrix.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Entities | Returns the child entity at the given index.

Top

collall See Also

Reference

IAttrib Interface


IBlock Interface

API Reference > CADViewLib Namespace >

IBlock Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to BLOCK entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface IBlock
Inherits IGroup

C#

public interface IBlock : IGroup

C++

public interface class IBlock : public IGroup^

JScript

public interface IBlock
implements IGroup

collall See Also

Reference

IBlock Members


IBlock Members

API Reference > CADViewLib Namespace > IBlock Interface >

IBlock Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to BLOCK entities.

The following tables list the members exposed by the IBlock type.

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Flags | Gets or sets the block-type flags (bit-coded values, may be combined).
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | Name | Gets or sets a name of this object.
Public property | Offset | Gets or sets the block offset point.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.
Public property | XrefPath | Gets or sets an Xref path name.

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetBoxPoints | For internal use.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Entities | Returns the child entity at the given index.

Top

collall See Also

Reference

IBlock Interface


IBlock Properties

API Reference > CADViewLib Namespace > IBlock Interface >

IBlock Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Flags | Gets or sets the block-type flags (bit-coded values, may be combined).
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | Name | Gets or sets a name of this object.
Public property | Offset | Gets or sets the block offset point.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.
Public property | XrefPath | Gets or sets an Xref path name.

Top

collall See Also

Reference

IBlock Interface


IBlock Methods

API Reference > CADViewLib Namespace > IBlock Interface >

IBlock Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetBoxPoints | For internal use.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Entities | Returns the child entity at the given index.

Top

collall See Also

Reference

IBlock Interface


ICADLine Interface

API Reference > CADViewLib Namespace >

ICADLine Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to LINE entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface ICADLine
Inherits IEntity

C#

public interface ICADLine : IEntity

C++

public interface class ICADLine : public IEntity^

JScript

public interface ICADLine
implements IEntity

collall See Also

Reference

ICADLine Members


ICADLine Members

API Reference > CADViewLib Namespace > ICADLine Interface >

ICADLine Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to LINE entities.

The following tables list the members exposed by the ICADLine type.

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | Name | Gets or sets a name of this object.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | Point | Gets or sets the start point.
Public property | Point1 | Gets or sets the endpoint.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetBoxPoints | For internal use.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Entities | Returns the child entity at the given index.

Top

collall See Also

Reference

ICADLine Interface


ICADLine Properties

API Reference > CADViewLib Namespace > ICADLine Interface >

ICADLine Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | Name | Gets or sets a name of this object.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | Point | Gets or sets the start point.
Public property | Point1 | Gets or sets the endpoint.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall See Also

Reference

ICADLine Interface


ICADLine Methods

API Reference > CADViewLib Namespace > ICADLine Interface >

ICADLine Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetBoxPoints | For internal use.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Entities | Returns the child entity at the given index.

Top

collall See Also

Reference

ICADLine Interface


ICADViewX Interface

API Reference > CADViewLib Namespace >

ICADViewX Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to CADViewX control.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface ICADViewX

C#

public interface ICADViewX

C++

public interface class ICADViewX

JScript

public interface ICADViewX

collall See Also

Reference

ICADViewX Members


ICADViewX Members

API Reference > CADViewLib Namespace > ICADViewX Interface >

ICADViewX Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to CADViewX control.

The following tables list the members exposed by the ICADViewX type.

collall Public Properties

 | Name | Description
Public property | Active | Gets a value indicating whether the control is active.
Public property | AlignDisabled | Gets a value indicating whether child control realignment is disabled.
Public property | AutoOpenActiveViewPort | Gets or sets a value indicating whether an active viewport will be opened automatically.
Public property | AutoScroll | Gets or sets a value indicating whether the scrollbars appear automatically after zooming in.
Public property | AutoSize | Gets or sets a value indicating whether the control resizes itself to fit its contents.
Public property | AxBorderStyle | Gets or sets a border style for the control.
Public property | BackGroundColor | Gets or sets a background color for the loaded CAD drawing.
Public property | BorderWidth | Gets or sets the control's border width.
Public property | CADImage | Gets or sets a CADImage object for the loaded drawing.
Public property | Caption | Gets or sets a caption of the control.
Public property | Color | Gets or sets a background color for the control.
Public property | Count |
Public property | DXFImage | Gets or sets a DXFImage object for the loaded drawing.
Public property | DefaultAcadVersion | Gets or sets the default AutoCAD version for saving to DWG/DXF formats.
Public property | DefaultColor | Gets or sets a default color for the loaded CAD drawing.
Public property | DefaultSHXFont | Gets or sets a name of the default SHX font.
Public property | DefaultSHXPath | Gets or sets the default path to SHX font files.
Public property | DoubleBuffered | Gets or sets a value indicating whether the control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Public property | DrawMode | Gets or sets an appearance of colors in the loaded CAD drawing.
Public property | DropTarget | Gets or sets a value indicating whether the control can be a target for the drag-and-drop operations.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction.
Public property | FileName | Gets or sets a name of the loaded drawing file.
Public property | FileVersion | Gets the file version of CADViewLib.ocx.
Public property | Font | Gets or sets a font of the control.
Public property | GSDPI | Gets or sets a DPI value for the EPS import.
Public property | GSDllSearchPath | Gets or sets a path to GhostScript library.
Public property | HScrollBarVisible | Gets or sets a value indicating whether the horizontal scroll bar is visible.
Public property | Image | Gets or sets a DXFImage object for the loaded drawing.
Public property | ImageAlign | Gets or sets the alignment of the child control which renders an image.
Public property | ImageBoundsRect | Gets the bounding rectangle for the drawing area.
Public property | ImageHeight | Gets a height of the loaded CAD drawing.
Public property | ImageParentClientRect |
Public property | ImageWidth | Gets a width of the loaded CAD drtawing.
Public property | IsShowPrinterSetupDialog | Gets or sets a value indicating whether the Print dialog box will be displayed.
Public property | IsWithoutBorder | Gets or sets a value indicating whether the loaded CAD drawing is displayed without an additional empty space (borders).
Public property | KeyPreview | Gets or sets a value indicating whether the form-level keyboard event procedures are invoked before the control's keyboard event procedures.
Public property | Language | Gets or sets a language of the control's GUI.
Public property | LanguagesCount | Gets a quantity of available GUI languages.
Public property | LayoutIndex | Gets or sets an index of the currently displayed CAD drawing's layout.
Public property | LayoutToolBox | Provides an access to the layouts combo box.
Public property | LayoutsBarVisible | Gets or sets a value indicating whether the layouts toolbox is visible.
Public property | LayoutsCount | Gets the layouts quantity in the loaded CAD drawing.
Public property | Millimetres | Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file.
Public property | PaperOrientation | Gets or sets the paper orientation for printing.
Public property | Picture | Gets a raster image for the displayed drawing.
Public property | PixelsPerInch | Gets or sets the proportion of the font on the system on which the control's form was designed.
Public property | PrintScale | Gets or sets a value indicating how the drawing will be scaled on print.
Public property | PrintViewArea | Gets or sets a value indicating whether the current view will be printed.
Public property | PrinterIndex | Gets or sets an index of the current printer.
Public property | PrintersCount | Gets a number of printers installed in the operating system.
Public property | PrintingTitle | Gets or sets a document name in the print queue for files yet to be printed from CADViewX.
Public property | ProductName | Gets a product name for the control.
Public property | ProductVersion | Gets a product version for the control.
Public property | ProgressRect | Gets the rectangle area that has been changed and needs to be redrawn.
Public property | RasterColorDepth | Gets or sets a color depth for raster images.
Public property | Rotatable | Gets a value indicating whether the drawing can be rotated on the angle value which is not divisible by 90.
Public property | SHXSearchPaths | Gets or sets the paths to the SHX font files.
Public property | ScaleFactor | Gets or sets a scale factor for CAD drawing's width and height.
Public property | Scaled | Gets or sets a value indicating whether the control's form is scaled according to the PixelsPerInch property value.
Public property | ScreenSnap | Gets or sets a value indicating whether the control's form snaps to edge of screen.
Public property | SearchSHXPaths | Gets or sets a value indicating whether to search the SHX fonts at the specified paths.
Public property | SelfPopupMenu | Gets or sets a value indicating whether the control's context menu is displayed.
Public property | SnapBuffer | Gets or sets a distance for the screen snap.
Public property | ToolBarVisible | Gets or sets a value indicating the control's toolbar visibility.
Public property | ToolBox | Provides an access to the control's toolbar.
Public property | UseSHXFonts | Gets or sets a value indicating whether the SHX fonts will be used in the CAD drawing.
Public property | UseSizeDialog | Gets or sets a value indicating whether the Export file size dialog window is displayed.
Public property | VScrollBarVisible | Gets or sets a value indicating whether the vertical scroll bar is visible.
Public property | Visible | Gets or sets a value indicating whether the control is visible.
Public property | VisibleDockClientCount | Gets the number of visible controls that are docked on the windowed control.
Public property | VisibleOrbit3D | Gets or sets a value indicating whether the 3D Orbit tool is visible.
Public property | hDc | Gets a handle to a device context (DC) for the client area of the control.
Public property | hWnd | Gets the window handle that the control is bound to.
Public property | mmHeight | Gets the physical height for the loaded HPGL drawing in millimeters.
Public property | mmWidth | Gets the physical width for the loaded HPGL drawing in millimeters.

Top

collall Public Methods

 | Name | Description
Public method | ActionUpdate | Updates the control's internal state.
Public method | CADCoords | Calculates CAD coordinates for a point specified by the screen coordinates.
Public method | Cancel | Terminates moving (or dragging) of the image.
Public method | Center | Returns the center point of the drawing area.
Public method | CheckUpdates | Checks for a new version of the control available to download.
Public method | CloseFile | Closes the currently opened file.
Public method | ConvertCADToJPEG | Converts a CAD drawing file to the JPEG format.
Public method | ConvertCustom |
Public method | CopyToRaster | Copies the loaded CAD drawing to the clipboard as a bitmap.
Public method | CurrentLayoutIterate | Iterates through the entities on the current drawing layout.
Public method | DoToolButtonClick | Triggers the mouse click on a specified toolbar button.
Public method | Empty | Returns a value indicating whether the control contains any drawing file or not.
Public method | ExportToMetafile | Exports the loaded CAD drawing to Windows metafile.
Public method | FindAutoCADSHXPaths | Returns paths to the SHX fonts installed with Autodesk products (AutoCAD, DWG TrueView).
Public method | GetOpenDialogFilter | Retrieves a string that indicates the file types and descriptions displayed in the control's open file dialog.
Public method | GetSaveDialogFilter | Retrieves a string that indicates the file types and descriptions displayed in the control's save file dialog.
Public method | HasPrevScale | Check if the drawing was scaled on the screen.
Public method | IsBadRect | Checks if the sizes of a specifed parallelepiped are defined correctly.
Public method | IsVectGraphic | Returns a value indicating whether the loaded file contains vector graphics.
Public method | LoadFile | Loads a specified file.
Public method | LoadFromIni | Loads the control's settings from a specified .ini file.
Public method | MkFPoint | Defines a point in the 3D space.
Public method | MkFRect | Defines a parallelepiped (box).
Public method | OpenActiveViewPort | Displays the active viewport.
Public method | PictureRealign | Realigns the displayed image.
Public method | PictureRect | Returns the bounding rectangle for the displayed image.
Public method | PictureRepaint | Repaints the displayed image.
Public method | Popup | Displays the control's context menu at a given location of the screen.
Public method | PrevScale | Redraws the displayed image with a previous scale factor and boundaries.
Public method | Print | Sends the loaded file to the current printer.
Public method | PrintImage | Sends the loaded file to the current printer.
Public method | ProcessXML | Processes a string which contains the XML instructions.
Public method | RefreshAfterPictureAssign | Forces the control to clear the internal data left from the previously loaded file.
Public method | RefreshAfterRotate | Forces the control to refresh the image after rotation.
Public method | SaveCopyToFile | Copies the contents of the loaded file to a stream and saves the copy to a file.
Public method | SaveToFile | Saves the loaded drawing to a specified file.
Public method | SaveToFileEx | Saves the loaded drawing to a specified file.
Public method | SaveToIni | Saves the control's settings to an .ini file
Public method | ScaleImage | Applies the on-screen scaling to the displayed image.
Public method | ScaledRectPicture | Captures a specified rectangle area as an Image object.
Public method | SetImageBounds | Sets the boundaries for the displayed image.
Public method | ShowAbout | Forces the control to display the About dialog window.
Public method | ShowInfo | Displays a caption with a specified size.
Public method | ShowLayersDialog | Forces the control to display the Layers dialog window.
Public method | ShowPoint | Displays the image centered by a specified point with a certain scale factor.
Public method | ShowPointEx | Displays the image centered by a specified point with a certain scale factor.
Public method | ShowRect | Displays the image centered by a specified rectangle area.
Public method | StRg | Registers CADViewX developer license programmatically in the application.
Public method | UsePictureRect | Obsolete.
Public method | Zoom | Zooms to a specified rectangle area on the loaded drawing.
Public method | get_EnabledAction | Returns a value indicating whether a specified toolbar button is enabled.
Public method | get_Items |
Public method | get_Languages | Retrieves a GUI language name by its index.
Public method | get_Printer | Retrieves a printer name by its index.
Public method | get_VisibleAction | Returns a value indicating whether a specified toolbar button is visible.
Public method | let_Font | Sets a font for the control.
Public method | set_EnabledAction | Makes a specified toolbar button enabled or disabled.
Public method | set_Printer | Changes a local name of the printer at the given index.
Public method | set_VisibleAction | Makes a specified toolbar button visible or hidden.

Top

collall See Also

Reference

ICADViewX Interface


ICADViewX Properties

API Reference > CADViewLib Namespace > ICADViewX Interface >

ICADViewX Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Active | Gets a value indicating whether the control is active.
Public property | AlignDisabled | Gets a value indicating whether child control realignment is disabled.
Public property | AutoOpenActiveViewPort | Gets or sets a value indicating whether an active viewport will be opened automatically.
Public property | AutoScroll | Gets or sets a value indicating whether the scrollbars appear automatically after zooming in.
Public property | AutoSize | Gets or sets a value indicating whether the control resizes itself to fit its contents.
Public property | AxBorderStyle | Gets or sets a border style for the control.
Public property | BackGroundColor | Gets or sets a background color for the loaded CAD drawing.
Public property | BorderWidth | Gets or sets the control's border width.
Public property | CADImage | Gets or sets a CADImage object for the loaded drawing.
Public property | Caption | Gets or sets a caption of the control.
Public property | Color | Gets or sets a background color for the control.
Public property | Count |
Public property | DXFImage | Gets or sets a DXFImage object for the loaded drawing.
Public property | DefaultAcadVersion | Gets or sets the default AutoCAD version for saving to DWG/DXF formats.
Public property | DefaultColor | Gets or sets a default color for the loaded CAD drawing.
Public property | DefaultSHXFont | Gets or sets a name of the default SHX font.
Public property | DefaultSHXPath | Gets or sets the default path to SHX font files.
Public property | DoubleBuffered | Gets or sets a value indicating whether the control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Public property | DrawMode | Gets or sets an appearance of colors in the loaded CAD drawing.
Public property | DropTarget | Gets or sets a value indicating whether the control can be a target for the drag-and-drop operations.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction.
Public property | FileName | Gets or sets a name of the loaded drawing file.
Public property | FileVersion | Gets the file version of CADViewLib.ocx.
Public property | Font | Gets or sets a font of the control.
Public property | GSDPI | Gets or sets a DPI value for the EPS import.
Public property | GSDllSearchPath | Gets or sets a path to GhostScript library.
Public property | HScrollBarVisible | Gets or sets a value indicating whether the horizontal scroll bar is visible.
Public property | Image | Gets or sets a DXFImage object for the loaded drawing.
Public property | ImageAlign | Gets or sets the alignment of the child control which renders an image.
Public property | ImageBoundsRect | Gets the bounding rectangle for the drawing area.
Public property | ImageHeight | Gets a height of the loaded CAD drawing.
Public property | ImageParentClientRect |
Public property | ImageWidth | Gets a width of the loaded CAD drtawing.
Public property | IsShowPrinterSetupDialog | Gets or sets a value indicating whether the Print dialog box will be displayed.
Public property | IsWithoutBorder | Gets or sets a value indicating whether the loaded CAD drawing is displayed without an additional empty space (borders).
Public property | KeyPreview | Gets or sets a value indicating whether the form-level keyboard event procedures are invoked before the control's keyboard event procedures.
Public property | Language | Gets or sets a language of the control's GUI.
Public property | LanguagesCount | Gets a quantity of available GUI languages.
Public property | LayoutIndex | Gets or sets an index of the currently displayed CAD drawing's layout.
Public property | LayoutToolBox | Provides an access to the layouts combo box.
Public property | LayoutsBarVisible | Gets or sets a value indicating whether the layouts toolbox is visible.
Public property | LayoutsCount | Gets the layouts quantity in the loaded CAD drawing.
Public property | Millimetres | Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file.
Public property | PaperOrientation | Gets or sets the paper orientation for printing.
Public property | Picture | Gets a raster image for the displayed drawing.
Public property | PixelsPerInch | Gets or sets the proportion of the font on the system on which the control's form was designed.
Public property | PrintScale | Gets or sets a value indicating how the drawing will be scaled on print.
Public property | PrintViewArea | Gets or sets a value indicating whether the current view will be printed.
Public property | PrinterIndex | Gets or sets an index of the current printer.
Public property | PrintersCount | Gets a number of printers installed in the operating system.
Public property | PrintingTitle | Gets or sets a document name in the print queue for files yet to be printed from CADViewX.
Public property | ProductName | Gets a product name for the control.
Public property | ProductVersion | Gets a product version for the control.
Public property | ProgressRect | Gets the rectangle area that has been changed and needs to be redrawn.
Public property | RasterColorDepth | Gets or sets a color depth for raster images.
Public property | Rotatable | Gets a value indicating whether the drawing can be rotated on the angle value which is not divisible by 90.
Public property | SHXSearchPaths | Gets or sets the paths to the SHX font files.
Public property | ScaleFactor | Gets or sets a scale factor for CAD drawing's width and height.
Public property | Scaled | Gets or sets a value indicating whether the control's form is scaled according to the PixelsPerInch property value.
Public property | ScreenSnap | Gets or sets a value indicating whether the control's form snaps to edge of screen.
Public property | SearchSHXPaths | Gets or sets a value indicating whether to search the SHX fonts at the specified paths.
Public property | SelfPopupMenu | Gets or sets a value indicating whether the control's context menu is displayed.
Public property | SnapBuffer | Gets or sets a distance for the screen snap.
Public property | ToolBarVisible | Gets or sets a value indicating the control's toolbar visibility.
Public property | ToolBox | Provides an access to the control's toolbar.
Public property | UseSHXFonts | Gets or sets a value indicating whether the SHX fonts will be used in the CAD drawing.
Public property | UseSizeDialog | Gets or sets a value indicating whether the Export file size dialog window is displayed.
Public property | VScrollBarVisible | Gets or sets a value indicating whether the vertical scroll bar is visible.
Public property | Visible | Gets or sets a value indicating whether the control is visible.
Public property | VisibleDockClientCount | Gets the number of visible controls that are docked on the windowed control.
Public property | VisibleOrbit3D | Gets or sets a value indicating whether the 3D Orbit tool is visible.
Public property | hDc | Gets a handle to a device context (DC) for the client area of the control.
Public property | hWnd | Gets the window handle that the control is bound to.
Public property | mmHeight | Gets the physical height for the loaded HPGL drawing in millimeters.
Public property | mmWidth | Gets the physical width for the loaded HPGL drawing in millimeters.

Top

collall See Also

Reference

ICADViewX Interface


ICADViewX Methods

API Reference > CADViewLib Namespace > ICADViewX Interface >

ICADViewX Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | ActionUpdate | Updates the control's internal state.
Public method | CADCoords | Calculates CAD coordinates for a point specified by the screen coordinates.
Public method | Cancel | Terminates moving (or dragging) of the image.
Public method | Center | Returns the center point of the drawing area.
Public method | CheckUpdates | Checks for a new version of the control available to download.
Public method | CloseFile | Closes the currently opened file.
Public method | ConvertCADToJPEG | Converts a CAD drawing file to the JPEG format.
Public method | ConvertCustom |
Public method | CopyToRaster | Copies the loaded CAD drawing to the clipboard as a bitmap.
Public method | CurrentLayoutIterate | Iterates through the entities on the current drawing layout.
Public method | DoToolButtonClick | Triggers the mouse click on a specified toolbar button.
Public method | Empty | Returns a value indicating whether the control contains any drawing file or not.
Public method | ExportToMetafile | Exports the loaded CAD drawing to Windows metafile.
Public method | FindAutoCADSHXPaths | Returns paths to the SHX fonts installed with Autodesk products (AutoCAD, DWG TrueView).
Public method | GetOpenDialogFilter | Retrieves a string that indicates the file types and descriptions displayed in the control's open file dialog.
Public method | GetSaveDialogFilter | Retrieves a string that indicates the file types and descriptions displayed in the control's save file dialog.
Public method | HasPrevScale | Check if the drawing was scaled on the screen.
Public method | IsBadRect | Checks if the sizes of a specifed parallelepiped are defined correctly.
Public method | IsVectGraphic | Returns a value indicating whether the loaded file contains vector graphics.
Public method | LoadFile | Loads a specified file.
Public method | LoadFromIni | Loads the control's settings from a specified .ini file.
Public method | MkFPoint | Defines a point in the 3D space.
Public method | MkFRect | Defines a parallelepiped (box).
Public method | OpenActiveViewPort | Displays the active viewport.
Public method | PictureRealign | Realigns the displayed image.
Public method | PictureRect | Returns the bounding rectangle for the displayed image.
Public method | PictureRepaint | Repaints the displayed image.
Public method | Popup | Displays the control's context menu at a given location of the screen.
Public method | PrevScale | Redraws the displayed image with a previous scale factor and boundaries.
Public method | Print | Sends the loaded file to the current printer.
Public method | PrintImage | Sends the loaded file to the current printer.
Public method | ProcessXML | Processes a string which contains the XML instructions.
Public method | RefreshAfterPictureAssign | Forces the control to clear the internal data left from the previously loaded file.
Public method | RefreshAfterRotate | Forces the control to refresh the image after rotation.
Public method | SaveCopyToFile | Copies the contents of the loaded file to a stream and saves the copy to a file.
Public method | SaveToFile | Saves the loaded drawing to a specified file.
Public method | SaveToFileEx | Saves the loaded drawing to a specified file.
Public method | SaveToIni | Saves the control's settings to an .ini file
Public method | ScaleImage | Applies the on-screen scaling to the displayed image.
Public method | ScaledRectPicture | Captures a specified rectangle area as an Image object.
Public method | SetImageBounds | Sets the boundaries for the displayed image.
Public method | ShowAbout | Forces the control to display the About dialog window.
Public method | ShowInfo | Displays a caption with a specified size.
Public method | ShowLayersDialog | Forces the control to display the Layers dialog window.
Public method | ShowPoint | Displays the image centered by a specified point with a certain scale factor.
Public method | ShowPointEx | Displays the image centered by a specified point with a certain scale factor.
Public method | ShowRect | Displays the image centered by a specified rectangle area.
Public method | StRg | Registers CADViewX developer license programmatically in the application.
Public method | UsePictureRect | Obsolete.
Public method | Zoom | Zooms to a specified rectangle area on the loaded drawing.
Public method | get_EnabledAction | Returns a value indicating whether a specified toolbar button is enabled.
Public method | get_Items |
Public method | get_Languages | Retrieves a GUI language name by its index.
Public method | get_Printer | Retrieves a printer name by its index.
Public method | get_VisibleAction | Returns a value indicating whether a specified toolbar button is visible.
Public method | let_Font | Sets a font for the control.
Public method | set_EnabledAction | Makes a specified toolbar button enabled or disabled.
Public method | set_Printer | Changes a local name of the printer at the given index.
Public method | set_VisibleAction | Makes a specified toolbar button visible or hidden.

Top

collall See Also

Reference

ICADViewX Interface


ICGMImage Interface

API Reference > CADViewLib Namespace >

ICGMImage Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to a CGM drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface ICGMImage
Inherits IDXFImage

C#

public interface ICGMImage : IDXFImage

C++

public interface class ICGMImage : public IDXFImage^

JScript

public interface ICGMImage
implements IDXFImage

collall See Also

Reference

ICGMImage Members


ICGMImage Members

API Reference > CADViewLib Namespace > ICGMImage Interface >

ICGMImage Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to a CGM drawing.

The following tables list the members exposed by the ICGMImage type.

collall Public Properties

 | Name | Description
Public property | BackGroundColor | Gets or sets a background color for the drawing.
Public property | BorderSize | Gets or sets a border size for the drawing.
Public property | BorderType | Gets or sets a way the drawing's border size is defined (global or ratio).
Public property | CADClassID | Gets the CAD format identifier for the drawing.
Public property | CBFormat | Gets or sets the clipboard format.
Public property | CanStopLoading | Gets a value indicating whether the loading of the drawing data can be terminated.
Public property | Charset | Gets or sets a character set for the text entities.
Public property | ColorToLineWeight | Gets or sets a string which contains the color-lineweight pairs.
Public property | Converter | Gets or sets a Converter associated with this image object.
Public property | Count | Gets a number of entities in the drawing.
Public property | CurrentLayout | Gets or sets the current layout for the drawing.
Public property | DefaultColor | Gets or sets the default color for the drawing.
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions in the drawing are visible.
Public property | DrawMode | Gets or sets an appearance of colors in the drawing.
Public property | DrawingBox | Gets or sets the drawing bounding box.
Public property | Empty | Gets a value indicating whether the drawing is empty.
Public property | Extents | Gets or sets the drawing's extents.
Public property | Height | Gets or sets a height of the drawing.
Public property | Is3D | Gets a value indicating whether the drawing is three-dimensional.
Public property | IsDraw3DAxes | Gets a value indicating whether 3D axes are visible on the drawing.
Public property | IsDrawingRotated | Gets a value indicating whether the drawing is rotated.
Public property | IsLoading | Gets a value indicating whether the process of loading the drawing data is active.
Public property | IsPlotting | Gets or sets a value indicating whether to plot the image or not.
Public property | IsProcessMessages | Gets or sets a value indicating whether the messages processing is allowed.
Public property | IsShowBackground | Gets or sets a value indicating whether the backround is displayed.
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines is determined by the drawing data.
Public property | IsWithoutBorder | Gets or sets a value indicating whether to display the drawing without borders.
Public property | LayoutsCount | Gets the number of layouts in the drawing.
Public property | LineScaled | Gets or sets a value indicating whether the line weight is diplayed.
Public property | LineWeightScale | Gets or sets a scale for line weights.
Public property | Millimetres | Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file.
Public property | Modified | Gets or sets a value indicating whether the drawing is modified.
Public property | NullWidth | Gets or sets a thickness for lines which have the zero lineweight.
Public property | OwnSource | For internal use.
Public property | PureExtents | Gets the drawing's extents excluding the borders.
Public property | ResizeDisproportionateDrawing | Gets or sets a value indicating whether to resize a drawing with disproportionate sizes.
Public property | Scale | Gets or sets a 3D point which defines the scale factor.
Public property | ShowImages | Gets or sets a value indicating whether the raster images are displayed.
Public property | Stretch | Gets or sets a value indicating whether the displayed image has to be stretched to fit exactly with the drawing rectangle.
Public property | TextVisible | Gets or sets a value indicating whether texts in the drawing are visible.
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles are drawn by using GDI+ methods without linearization.
Public property | ViewRectangle | For internal use.
Public property | Width | Gets or sets a width of the drawing.

Top

collall Public Methods

 | Name | Description
Public method | AbsHeight | Returns an absolute height of the CAD drawing.
Public method | AbsWidth | Returns an absolute width of the CAD drawing.
Public method | AddScaledDXF | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.
Public method | AddScaledDXFEx | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.
Public method | AssignImage | Makes a copy of a specified CAD image object and assigns it to this image.
Public method | CreateImage | Initializes a new CAD image instance.
Public method | Draw | Draws the CAD image in a specified device context (DC).
Public method | DrawRect | Draws a specified region of this CAD image in a device context (DC).
Public method | ExportToMetafile | Exports this CAD image to Windows metafile.
Public method | FreeImage | Destroys this CAD image object and frees the memory used within the object.
Public method | GetCADCoords | Returns CAD coordinates for a specified point.
Public method | GetEntityColor | Returns the color value for a specified entity.
Public method | GetExtents | Recalculates extents of the CAD image.
Public method | GetPoint | Gets the on-screen coordinates for a specified CAD point.
Public method | GetRealImagePoint | Returns CAD coordinates of a specified point considering the drawing's rotation and viewport parameters.
Public method | HeadVarAsFloat | Returns a value of the DXF header variable as a floating point number.
Public method | HeadVarAsInteger | Returns a value of the DXF header variable as an integer.
Public method | HeadVarAsstring | Returns a value of the DXF header variable as a string.
Public method | LoadFromClipboardFormat | Loads data from the clipboard.
Public method | LoadFromFile | Loads a CAD drawing from file.
Public method | LoadFromIStream | Loads a CAD drawing from stream.
Public method | LoadFromStream | Loads a CAD drawing from stream.
Public method | RefreshCurrentLayout | Refreshes the current layout.
Public method | ResetDrawingBox | Switches off the drawing box.
Public method | RotDefault | Rotates the drawing to the default view.
Public method | RotToView | Rotates the drawing to a specified view.
Public method | Rotate | Rotates the drawing.
Public method | SaveToClipboardFormat | Copies the drawing to the clipboard in a specified format.
Public method | SaveToFile | Saves the drawing to a specified file.
Public method | SaveToIStream | Writes the drawing data to a specified stream.
Public method | SaveToStream | Writes the drawing data to a specified stream.
Public method | SetClippingRect | Sets a clipping rectangle for the drawing.
Public method | SetExtentsParameters | Changes the drawing extents.
Public method | StopLoading | Terminates loading of the drawing data.
Public method | get_Blocks | Retrieves a BLOCK object by its index.
Public method | get_Entities | Retrieves an entity by its index.
Public method | get_Items |
Public method | get_Layouts | Retrieves a layout by its index.

Top

collall See Also

Reference

ICGMImage Interface


ICGMImage Properties

API Reference > CADViewLib Namespace > ICGMImage Interface >

ICGMImage Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | BackGroundColor | Gets or sets a background color for the drawing.
Public property | BorderSize | Gets or sets a border size for the drawing.
Public property | BorderType | Gets or sets a way the drawing's border size is defined (global or ratio).
Public property | CADClassID | Gets the CAD format identifier for the drawing.
Public property | CBFormat | Gets or sets the clipboard format.
Public property | CanStopLoading | Gets a value indicating whether the loading of the drawing data can be terminated.
Public property | Charset | Gets or sets a character set for the text entities.
Public property | ColorToLineWeight | Gets or sets a string which contains the color-lineweight pairs.
Public property | Converter | Gets or sets a Converter associated with this image object.
Public property | Count | Gets a number of entities in the drawing.
Public property | CurrentLayout | Gets or sets the current layout for the drawing.
Public property | DefaultColor | Gets or sets the default color for the drawing.
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions in the drawing are visible.
Public property | DrawMode | Gets or sets an appearance of colors in the drawing.
Public property | DrawingBox | Gets or sets the drawing bounding box.
Public property | Empty | Gets a value indicating whether the drawing is empty.
Public property | Extents | Gets or sets the drawing's extents.
Public property | Height | Gets or sets a height of the drawing.
Public property | Is3D | Gets a value indicating whether the drawing is three-dimensional.
Public property | IsDraw3DAxes | Gets a value indicating whether 3D axes are visible on the drawing.
Public property | IsDrawingRotated | Gets a value indicating whether the drawing is rotated.
Public property | IsLoading | Gets a value indicating whether the process of loading the drawing data is active.
Public property | IsPlotting | Gets or sets a value indicating whether to plot the image or not.
Public property | IsProcessMessages | Gets or sets a value indicating whether the messages processing is allowed.
Public property | IsShowBackground | Gets or sets a value indicating whether the backround is displayed.
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines is determined by the drawing data.
Public property | IsWithoutBorder | Gets or sets a value indicating whether to display the drawing without borders.
Public property | LayoutsCount | Gets the number of layouts in the drawing.
Public property | LineScaled | Gets or sets a value indicating whether the line weight is diplayed.
Public property | LineWeightScale | Gets or sets a scale for line weights.
Public property | Millimetres | Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file.
Public property | Modified | Gets or sets a value indicating whether the drawing is modified.
Public property | NullWidth | Gets or sets a thickness for lines which have the zero lineweight.
Public property | OwnSource | For internal use.
Public property | PureExtents | Gets the drawing's extents excluding the borders.
Public property | ResizeDisproportionateDrawing | Gets or sets a value indicating whether to resize a drawing with disproportionate sizes.
Public property | Scale | Gets or sets a 3D point which defines the scale factor.
Public property | ShowImages | Gets or sets a value indicating whether the raster images are displayed.
Public property | Stretch | Gets or sets a value indicating whether the displayed image has to be stretched to fit exactly with the drawing rectangle.
Public property | TextVisible | Gets or sets a value indicating whether texts in the drawing are visible.
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles are drawn by using GDI+ methods without linearization.
Public property | ViewRectangle | For internal use.
Public property | Width | Gets or sets a width of the drawing.

Top

collall See Also

Reference

ICGMImage Interface


ICGMImage Methods

API Reference > CADViewLib Namespace > ICGMImage Interface >

ICGMImage Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AbsHeight | Returns an absolute height of the CAD drawing.
Public method | AbsWidth | Returns an absolute width of the CAD drawing.
Public method | AddScaledDXF | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.
Public method | AddScaledDXFEx | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.
Public method | AssignImage | Makes a copy of a specified CAD image object and assigns it to this image.
Public method | CreateImage | Initializes a new CAD image instance.
Public method | Draw | Draws the CAD image in a specified device context (DC).
Public method | DrawRect | Draws a specified region of this CAD image in a device context (DC).
Public method | ExportToMetafile | Exports this CAD image to Windows metafile.
Public method | FreeImage | Destroys this CAD image object and frees the memory used within the object.
Public method | GetCADCoords | Returns CAD coordinates for a specified point.
Public method | GetEntityColor | Returns the color value for a specified entity.
Public method | GetExtents | Recalculates extents of the CAD image.
Public method | GetPoint | Gets the on-screen coordinates for a specified CAD point.
Public method | GetRealImagePoint | Returns CAD coordinates of a specified point considering the drawing's rotation and viewport parameters.
Public method | HeadVarAsFloat | Returns a value of the DXF header variable as a floating point number.
Public method | HeadVarAsInteger | Returns a value of the DXF header variable as an integer.
Public method | HeadVarAsstring | Returns a value of the DXF header variable as a string.
Public method | LoadFromClipboardFormat | Loads data from the clipboard.
Public method | LoadFromFile | Loads a CAD drawing from file.
Public method | LoadFromIStream | Loads a CAD drawing from stream.
Public method | LoadFromStream | Loads a CAD drawing from stream.
Public method | RefreshCurrentLayout | Refreshes the current layout.
Public method | ResetDrawingBox | Switches off the drawing box.
Public method | RotDefault | Rotates the drawing to the default view.
Public method | RotToView | Rotates the drawing to a specified view.
Public method | Rotate | Rotates the drawing.
Public method | SaveToClipboardFormat | Copies the drawing to the clipboard in a specified format.
Public method | SaveToFile | Saves the drawing to a specified file.
Public method | SaveToIStream | Writes the drawing data to a specified stream.
Public method | SaveToStream | Writes the drawing data to a specified stream.
Public method | SetClippingRect | Sets a clipping rectangle for the drawing.
Public method | SetExtentsParameters | Changes the drawing extents.
Public method | StopLoading | Terminates loading of the drawing data.
Public method | get_Blocks | Retrieves a BLOCK object by its index.
Public method | get_Entities | Retrieves an entity by its index.
Public method | get_Items |
Public method | get_Layouts | Retrieves a layout by its index.

Top

collall See Also

Reference

ICGMImage Interface


ICircle Interface

API Reference > CADViewLib Namespace >

ICircle Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to CIRCLE entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface ICircle
Inherits IPolyline

C#

public interface ICircle : IPolyline

C++

public interface class ICircle : public IPolyline^

JScript

public interface ICircle
implements IPolyline

collall See Also

Reference

ICircle Members


ICircle Members

API Reference > CADViewLib Namespace > ICircle Interface >

ICircle Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to CIRCLE entities.

The following tables list the members exposed by the ICircle type.

collall Public Properties

 | Name | Description
Public property | ArrowsCount | Gets a quantity of points that form an arrow.
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Closed | Gets or sets a value indicating whether this polyline is closed.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | DottedPointsCount | Gets a quantity of points that determine the dots and dashes for a polyline with non-solid line type.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Flags | Gets or sets a bit-coded flag indicating the polyline type.
Public property | GlobalWidth | Gets or sets a global width for this polyline.
Public property | IsMeshMClosed | Gets a value indicating whether the polygon mesh is closed in the M direction.
Public property | IsMeshNClosed | Gets a value indicating whether the polygon mesh is closed in the N direction.
Public property | IsPolyFaceMesh | Gets a value indicating whether this polyline is a polyface mesh.
Public property | IsPolyZThickness | Gets a value indicating whether the polyline has thickness measured along the axis Z.
Public property | IsPolygonMesh | Gets a value indicating whether this polyline is a polygon mesh.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | MeshM | Gets or sets a number of vertices for the polygon mesh in the M direction.
Public property | MeshN | Gets or sets a number of vertices for the polygon mesh in the N direction.
Public property | Name | Gets or sets a name of this object.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | PenLine | Gets properties of the pen used for drawing the object.
Public property | Point | Gets or sets the center point.
Public property | PointsCount | Gets a number of the polyline points.
Public property | PolyFaceVertexIndexesCount | Gets a quantity of indices which specify the order of traversing vertices in the polyface mesh.
Public property | Radius | Gets or sets a radius of the circle/ellipse/arc.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetArea | Returns the area bounded by a closed polygon.
Public method | GetBoxPoints | For internal use.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Arrows | Returns a point of the arrowhead.
Public method | get_DottedPoints | Returns coordinates of a point in the points array that determines dots and dashes for a non-solid line type.
Public method | get_Entities | Returns the child entity at the given index.
Public method | get_Points | Returns coordinates of a point in the points array.
Public method | get_PolyFaceVertexIndexes | Returns a value which indicates an index of the polyface mesh vertex.
Public method | set_Arrows | Modifies a point of the arrowhead at the given index.

Top

collall See Also

Reference

ICircle Interface


ICircle Properties

API Reference > CADViewLib Namespace > ICircle Interface >

ICircle Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | ArrowsCount | Gets a quantity of points that form an arrow.
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Closed | Gets or sets a value indicating whether this polyline is closed.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | DottedPointsCount | Gets a quantity of points that determine the dots and dashes for a polyline with non-solid line type.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Flags | Gets or sets a bit-coded flag indicating the polyline type.
Public property | GlobalWidth | Gets or sets a global width for this polyline.
Public property | IsMeshMClosed | Gets a value indicating whether the polygon mesh is closed in the M direction.
Public property | IsMeshNClosed | Gets a value indicating whether the polygon mesh is closed in the N direction.
Public property | IsPolyFaceMesh | Gets a value indicating whether this polyline is a polyface mesh.
Public property | IsPolyZThickness | Gets a value indicating whether the polyline has thickness measured along the axis Z.
Public property | IsPolygonMesh | Gets a value indicating whether this polyline is a polygon mesh.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | MeshM | Gets or sets a number of vertices for the polygon mesh in the M direction.
Public property | MeshN | Gets or sets a number of vertices for the polygon mesh in the N direction.
Public property | Name | Gets or sets a name of this object.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | PenLine | Gets properties of the pen used for drawing the object.
Public property | Point | Gets or sets the center point.
Public property | PointsCount | Gets a number of the polyline points.
Public property | PolyFaceVertexIndexesCount | Gets a quantity of indices which specify the order of traversing vertices in the polyface mesh.
Public property | Radius | Gets or sets a radius of the circle/ellipse/arc.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall See Also

Reference

ICircle Interface


ICircle Methods

API Reference > CADViewLib Namespace > ICircle Interface >

ICircle Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetArea | Returns the area bounded by a closed polygon.
Public method | GetBoxPoints | For internal use.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Arrows | Returns a point of the arrowhead.
Public method | get_DottedPoints | Returns coordinates of a point in the points array that determines dots and dashes for a non-solid line type.
Public method | get_Entities | Returns the child entity at the given index.
Public method | get_Points | Returns coordinates of a point in the points array.
Public method | get_PolyFaceVertexIndexes | Returns a value which indicates an index of the polyface mesh vertex.
Public method | set_Arrows | Modifies a point of the arrowhead at the given index.

Top

collall See Also

Reference

ICircle Interface


IConverter Interface

API Reference > CADViewLib Namespace >

IConverter Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to the sections of the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface IConverter

C#

public interface IConverter

C++

public interface class IConverter

JScript

public interface IConverter

collall See Also

Reference

IConverter Members


IConverter Members

API Reference > CADViewLib Namespace > IConverter Interface >

IConverter Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to the sections of the drawing database.

The following tables list the members exposed by the IConverter type.

collall Public Properties

 | Name | Description
Public property | DefaultLayoutIndex | Gets or sets an index of the active layout.
Public property | IsCrossoverMatrix | Obsolete.
Public property | LayoutsCount | Gets a number of layouts in the drawing.
Public property | NumberOfPartsInCircle | Gets or sets the quantity of lines in a polyline which approximates a circle.
Public property | NumberOfPartsInSpline | Gets or sets the quantity of lines in a polyline which approximates a spline.

Top

collall Public Methods

 | Name | Description
Public method | Count | Returns the number of entities in the drawing.
Public method | GetLayerNames | Writes names of the layers to a string.
Public method | IntToColor | Converts an integer color value to a single unsigned integer (uint).
Public method | LayerByName | Retrieves a layer with the given name.
Public method | Loads | Loads the entity data into the drawing database.
Public method | get_Counts | Returns the number of objects in the given section of the drawing database.
Public method | get_Layers | Returns the layer at the given index in the drawing database.
Public method | get_Layouts | Returns the layout at the given index in the drawing database.
Public method | get_Sections | Returns a group of objects which are stored in the given section of the drawing database.
Public method | set_Sections | Sets a group of objects to the given section in the drawing database.

Top

collall See Also

Reference

IConverter Interface


IConverter Properties

API Reference > CADViewLib Namespace > IConverter Interface >

IConverter Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | DefaultLayoutIndex | Gets or sets an index of the active layout.
Public property | IsCrossoverMatrix | Obsolete.
Public property | LayoutsCount | Gets a number of layouts in the drawing.
Public property | NumberOfPartsInCircle | Gets or sets the quantity of lines in a polyline which approximates a circle.
Public property | NumberOfPartsInSpline | Gets or sets the quantity of lines in a polyline which approximates a spline.

Top

collall See Also

Reference

IConverter Interface


IConverter Methods

API Reference > CADViewLib Namespace > IConverter Interface >

IConverter Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | Count | Returns the number of entities in the drawing.
Public method | GetLayerNames | Writes names of the layers to a string.
Public method | IntToColor | Converts an integer color value to a single unsigned integer (uint).
Public method | LayerByName | Retrieves a layer with the given name.
Public method | Loads | Loads the entity data into the drawing database.
Public method | get_Counts | Returns the number of objects in the given section of the drawing database.
Public method | get_Layers | Returns the layer at the given index in the drawing database.
Public method | get_Layouts | Returns the layout at the given index in the drawing database.
Public method | get_Sections | Returns a group of objects which are stored in the given section of the drawing database.
Public method | set_Sections | Sets a group of objects to the given section in the drawing database.

Top

collall See Also

Reference

IConverter Interface


IDWGImage Interface

API Reference > CADViewLib Namespace >

IDWGImage Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to a DWG drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface IDWGImage
Inherits IDXFImage

C#

public interface IDWGImage : IDXFImage

C++

public interface class IDWGImage : public IDXFImage^

JScript

public interface IDWGImage
implements IDXFImage

collall See Also

Reference

IDWGImage Members


IDWGImage Members

API Reference > CADViewLib Namespace > IDWGImage Interface >

IDWGImage Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to a DWG drawing.

The following tables list the members exposed by the IDWGImage type.

collall Public Properties

 | Name | Description
Public property | BackGroundColor | Gets or sets a background color for the drawing.
Public property | BorderSize | Gets or sets a border size for the drawing.
Public property | BorderType | Gets or sets a way the drawing's border size is defined (global or ratio).
Public property | CADClassID | Gets the CAD format identifier for the drawing.
Public property | CBFormat | Gets or sets the clipboard format.
Public property | CanStopLoading | Gets a value indicating whether the loading of the drawing data can be terminated.
Public property | Charset | Gets or sets a character set for the text entities.
Public property | ColorToLineWeight | Gets or sets a string which contains the color-lineweight pairs.
Public property | Converter | Gets or sets a Converter associated with this image object.
Public property | Count | Gets a number of entities in the drawing.
Public property | CurrentLayout | Gets or sets the current layout for the drawing.
Public property | DefaultColor | Gets or sets the default color for the drawing.
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions in the drawing are visible.
Public property | DrawMode | Gets or sets an appearance of colors in the drawing.
Public property | DrawingBox | Gets or sets the drawing bounding box.
Public property | Empty | Gets a value indicating whether the drawing is empty.
Public property | Extents | Gets or sets the drawing's extents.
Public property | Height | Gets or sets a height of the drawing.
Public property | Is3D | Gets a value indicating whether the drawing is three-dimensional.
Public property | IsDraw3DAxes | Gets a value indicating whether 3D axes are visible on the drawing.
Public property | IsDrawingRotated | Gets a value indicating whether the drawing is rotated.
Public property | IsLoading | Gets a value indicating whether the process of loading the drawing data is active.
Public property | IsPlotting | Gets or sets a value indicating whether to plot the image or not.
Public property | IsProcessMessages | Gets or sets a value indicating whether the messages processing is allowed.
Public property | IsShowBackground | Gets or sets a value indicating whether the backround is displayed.
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines is determined by the drawing data.
Public property | IsWithoutBorder | Gets or sets a value indicating whether to display the drawing without borders.
Public property | LayoutsCount | Gets the number of layouts in the drawing.
Public property | LineScaled | Gets or sets a value indicating whether the line weight is diplayed.
Public property | LineWeightScale | Gets or sets a scale for line weights.
Public property | Millimetres | Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file.
Public property | Modified | Gets or sets a value indicating whether the drawing is modified.
Public property | NullWidth | Gets or sets a thickness for lines which have the zero lineweight.
Public property | OwnSource | For internal use.
Public property | PreviewBitmap | Gets the preview bitmap for the DWG file.
Public property | PureExtents | Gets the drawing's extents excluding the borders.
Public property | ResizeDisproportionateDrawing | Gets or sets a value indicating whether to resize a drawing with disproportionate sizes.
Public property | Scale | Gets or sets a 3D point which defines the scale factor.
Public property | ShowImages | Gets or sets a value indicating whether the raster images are displayed.
Public property | Stretch | Gets or sets a value indicating whether the displayed image has to be stretched to fit exactly with the drawing rectangle.
Public property | TextVisible | Gets or sets a value indicating whether texts in the drawing are visible.
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles are drawn by using GDI+ methods without linearization.
Public property | ViewRectangle | For internal use.
Public property | Width | Gets or sets a width of the drawing.

Top

collall Public Methods

 | Name | Description
Public method | AbsHeight | Returns an absolute height of the CAD drawing.
Public method | AbsWidth | Returns an absolute width of the CAD drawing.
Public method | AddScaledDXF | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.
Public method | AddScaledDXFEx | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.
Public method | AssignImage | Makes a copy of a specified CAD image object and assigns it to this image.
Public method | CreateImage | Initializes a new CAD image instance.
Public method | Draw | Draws the CAD image in a specified device context (DC).
Public method | DrawRect | Draws a specified region of this CAD image in a device context (DC).
Public method | ExportToMetafile | Exports this CAD image to Windows metafile.
Public method | FreeImage | Destroys this CAD image object and frees the memory used within the object.
Public method | GetCADCoords | Returns CAD coordinates for a specified point.
Public method | GetEntityColor | Returns the color value for a specified entity.
Public method | GetExtents | Recalculates extents of the CAD image.
Public method | GetPoint | Gets the on-screen coordinates for a specified CAD point.
Public method | GetRealImagePoint | Returns CAD coordinates of a specified point considering the drawing's rotation and viewport parameters.
Public method | HeadVarAsFloat | Returns a value of the DXF header variable as a floating point number.
Public method | HeadVarAsInteger | Returns a value of the DXF header variable as an integer.
Public method | HeadVarAsstring | Returns a value of the DXF header variable as a string.
Public method | LoadFromClipboardFormat | Loads data from the clipboard.
Public method | LoadFromFile | Loads a CAD drawing from file.
Public method | LoadFromIStream | Loads a CAD drawing from stream.
Public method | LoadFromStream | Loads a CAD drawing from stream.
Public method | LoadPreviewFromFile | Loads the preview from a file.
Public method | RefreshCurrentLayout | Refreshes the current layout.
Public method | ResetDrawingBox | Switches off the drawing box.
Public method | RotDefault | Rotates the drawing to the default view.
Public method | RotToView | Rotates the drawing to a specified view.
Public method | Rotate | Rotates the drawing.
Public method | SaveToClipboardFormat | Copies the drawing to the clipboard in a specified format.
Public method | SaveToFile | Saves the drawing to a specified file.
Public method | SaveToIStream | Writes the drawing data to a specified stream.
Public method | SaveToStream | Writes the drawing data to a specified stream.
Public method | SetClippingRect | Sets a clipping rectangle for the drawing.
Public method | SetExtentsParameters | Changes the drawing extents.
Public method | StopLoading | Terminates loading of the drawing data.
Public method | get_Blocks | Retrieves a BLOCK object by its index.
Public method | get_Entities | Retrieves an entity by its index.
Public method | get_Items |
Public method | get_Layouts | Retrieves a layout by its index.

Top

collall See Also

Reference

IDWGImage Interface


IDWGImage Properties

API Reference > CADViewLib Namespace > IDWGImage Interface >

IDWGImage Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | BackGroundColor | Gets or sets a background color for the drawing.
Public property | BorderSize | Gets or sets a border size for the drawing.
Public property | BorderType | Gets or sets a way the drawing's border size is defined (global or ratio).
Public property | CADClassID | Gets the CAD format identifier for the drawing.
Public property | CBFormat | Gets or sets the clipboard format.
Public property | CanStopLoading | Gets a value indicating whether the loading of the drawing data can be terminated.
Public property | Charset | Gets or sets a character set for the text entities.
Public property | ColorToLineWeight | Gets or sets a string which contains the color-lineweight pairs.
Public property | Converter | Gets or sets a Converter associated with this image object.
Public property | Count | Gets a number of entities in the drawing.
Public property | CurrentLayout | Gets or sets the current layout for the drawing.
Public property | DefaultColor | Gets or sets the default color for the drawing.
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions in the drawing are visible.
Public property | DrawMode | Gets or sets an appearance of colors in the drawing.
Public property | DrawingBox | Gets or sets the drawing bounding box.
Public property | Empty | Gets a value indicating whether the drawing is empty.
Public property | Extents | Gets or sets the drawing's extents.
Public property | Height | Gets or sets a height of the drawing.
Public property | Is3D | Gets a value indicating whether the drawing is three-dimensional.
Public property | IsDraw3DAxes | Gets a value indicating whether 3D axes are visible on the drawing.
Public property | IsDrawingRotated | Gets a value indicating whether the drawing is rotated.
Public property | IsLoading | Gets a value indicating whether the process of loading the drawing data is active.
Public property | IsPlotting | Gets or sets a value indicating whether to plot the image or not.
Public property | IsProcessMessages | Gets or sets a value indicating whether the messages processing is allowed.
Public property | IsShowBackground | Gets or sets a value indicating whether the backround is displayed.
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines is determined by the drawing data.
Public property | IsWithoutBorder | Gets or sets a value indicating whether to display the drawing without borders.
Public property | LayoutsCount | Gets the number of layouts in the drawing.
Public property | LineScaled | Gets or sets a value indicating whether the line weight is diplayed.
Public property | LineWeightScale | Gets or sets a scale for line weights.
Public property | Millimetres | Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file.
Public property | Modified | Gets or sets a value indicating whether the drawing is modified.
Public property | NullWidth | Gets or sets a thickness for lines which have the zero lineweight.
Public property | OwnSource | For internal use.
Public property | PreviewBitmap | Gets the preview bitmap for the DWG file.
Public property | PureExtents | Gets the drawing's extents excluding the borders.
Public property | ResizeDisproportionateDrawing | Gets or sets a value indicating whether to resize a drawing with disproportionate sizes.
Public property | Scale | Gets or sets a 3D point which defines the scale factor.
Public property | ShowImages | Gets or sets a value indicating whether the raster images are displayed.
Public property | Stretch | Gets or sets a value indicating whether the displayed image has to be stretched to fit exactly with the drawing rectangle.
Public property | TextVisible | Gets or sets a value indicating whether texts in the drawing are visible.
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles are drawn by using GDI+ methods without linearization.
Public property | ViewRectangle | For internal use.
Public property | Width | Gets or sets a width of the drawing.

Top

collall See Also

Reference

IDWGImage Interface


IDWGImage Methods

API Reference > CADViewLib Namespace > IDWGImage Interface >

IDWGImage Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AbsHeight | Returns an absolute height of the CAD drawing.
Public method | AbsWidth | Returns an absolute width of the CAD drawing.
Public method | AddScaledDXF | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.
Public method | AddScaledDXFEx | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.
Public method | AssignImage | Makes a copy of a specified CAD image object and assigns it to this image.
Public method | CreateImage | Initializes a new CAD image instance.
Public method | Draw | Draws the CAD image in a specified device context (DC).
Public method | DrawRect | Draws a specified region of this CAD image in a device context (DC).
Public method | ExportToMetafile | Exports this CAD image to Windows metafile.
Public method | FreeImage | Destroys this CAD image object and frees the memory used within the object.
Public method | GetCADCoords | Returns CAD coordinates for a specified point.
Public method | GetEntityColor | Returns the color value for a specified entity.
Public method | GetExtents | Recalculates extents of the CAD image.
Public method | GetPoint | Gets the on-screen coordinates for a specified CAD point.
Public method | GetRealImagePoint | Returns CAD coordinates of a specified point considering the drawing's rotation and viewport parameters.
Public method | HeadVarAsFloat | Returns a value of the DXF header variable as a floating point number.
Public method | HeadVarAsInteger | Returns a value of the DXF header variable as an integer.
Public method | HeadVarAsstring | Returns a value of the DXF header variable as a string.
Public method | LoadFromClipboardFormat | Loads data from the clipboard.
Public method | LoadFromFile | Loads a CAD drawing from file.
Public method | LoadFromIStream | Loads a CAD drawing from stream.
Public method | LoadFromStream | Loads a CAD drawing from stream.
Public method | LoadPreviewFromFile | Loads the preview from a file.
Public method | RefreshCurrentLayout | Refreshes the current layout.
Public method | ResetDrawingBox | Switches off the drawing box.
Public method | RotDefault | Rotates the drawing to the default view.
Public method | RotToView | Rotates the drawing to a specified view.
Public method | Rotate | Rotates the drawing.
Public method | SaveToClipboardFormat | Copies the drawing to the clipboard in a specified format.
Public method | SaveToFile | Saves the drawing to a specified file.
Public method | SaveToIStream | Writes the drawing data to a specified stream.
Public method | SaveToStream | Writes the drawing data to a specified stream.
Public method | SetClippingRect | Sets a clipping rectangle for the drawing.
Public method | SetExtentsParameters | Changes the drawing extents.
Public method | StopLoading | Terminates loading of the drawing data.
Public method | get_Blocks | Retrieves a BLOCK object by its index.
Public method | get_Entities | Retrieves an entity by its index.
Public method | get_Items |
Public method | get_Layouts | Retrieves a layout by its index.

Top

collall See Also

Reference

IDWGImage Interface


IDXFImage Interface

API Reference > CADViewLib Namespace >

IDXFImage Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to a DXF drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface IDXFImage

C#

public interface IDXFImage

C++

public interface class IDXFImage

JScript

public interface IDXFImage

collall See Also

Reference

IDXFImage Members


IDXFImage Members

API Reference > CADViewLib Namespace > IDXFImage Interface >

IDXFImage Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to a DXF drawing.

The following tables list the members exposed by the IDXFImage type.

collall Public Properties

 | Name | Description
Public property | BackGroundColor | Gets or sets a background color for the drawing.
Public property | BorderSize | Gets or sets a border size for the drawing.
Public property | BorderType | Gets or sets a way the drawing's border size is defined (global or ratio).
Public property | CADClassID | Gets the CAD format identifier for the drawing.
Public property | CBFormat | Gets or sets the clipboard format.
Public property | CanStopLoading | Gets a value indicating whether the loading of the drawing data can be terminated.
Public property | Charset | Gets or sets a character set for the text entities.
Public property | ColorToLineWeight | Gets or sets a string which contains the color-lineweight pairs.
Public property | Converter | Gets or sets a Converter associated with this image object.
Public property | Count | Gets a number of entities in the drawing.
Public property | CurrentLayout | Gets or sets the current layout for the drawing.
Public property | DefaultColor | Gets or sets the default color for the drawing.
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions in the drawing are visible.
Public property | DrawMode | Gets or sets an appearance of colors in the drawing.
Public property | DrawingBox | Gets or sets the drawing bounding box.
Public property | Empty | Gets a value indicating whether the drawing is empty.
Public property | Extents | Gets or sets the drawing's extents.
Public property | Height | Gets or sets a height of the drawing.
Public property | Is3D | Gets a value indicating whether the drawing is three-dimensional.
Public property | IsDraw3DAxes | Gets a value indicating whether 3D axes are visible on the drawing.
Public property | IsDrawingRotated | Gets a value indicating whether the drawing is rotated.
Public property | IsLoading | Gets a value indicating whether the process of loading the drawing data is active.
Public property | IsPlotting | Gets or sets a value indicating whether to plot the image or not.
Public property | IsProcessMessages | Gets or sets a value indicating whether the messages processing is allowed.
Public property | IsShowBackground | Gets or sets a value indicating whether the backround is displayed.
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines is determined by the drawing data.
Public property | IsWithoutBorder | Gets or sets a value indicating whether to display the drawing without borders.
Public property | LayoutsCount | Gets the number of layouts in the drawing.
Public property | LineScaled | Gets or sets a value indicating whether the line weight is diplayed.
Public property | LineWeightScale | Gets or sets a scale for line weights.
Public property | Millimetres | Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file.
Public property | Modified | Gets or sets a value indicating whether the drawing is modified.
Public property | NullWidth | Gets or sets a thickness for lines which have the zero lineweight.
Public property | OwnSource | For internal use.
Public property | PureExtents | Gets the drawing's extents excluding the borders.
Public property | ResizeDisproportionateDrawing | Gets or sets a value indicating whether to resize a drawing with disproportionate sizes.
Public property | Scale | Gets or sets a 3D point which defines the scale factor.
Public property | ShowImages | Gets or sets a value indicating whether the raster images are displayed.
Public property | Stretch | Gets or sets a value indicating whether the displayed image has to be stretched to fit exactly with the drawing rectangle.
Public property | TextVisible | Gets or sets a value indicating whether texts in the drawing are visible.
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles are drawn by using GDI+ methods without linearization.
Public property | ViewRectangle | For internal use.
Public property | Width | Gets or sets a width of the drawing.

Top

collall Public Methods

 | Name | Description
Public method | AbsHeight | Returns an absolute height of the CAD drawing.
Public method | AbsWidth | Returns an absolute width of the CAD drawing.
Public method | AddScaledDXF | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.
Public method | AddScaledDXFEx | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.
Public method | AssignImage | Makes a copy of a specified CAD image object and assigns it to this image.
Public method | CreateImage | Initializes a new CAD image instance.
Public method | Draw | Draws the CAD image in a specified device context (DC).
Public method | DrawRect | Draws a specified region of this CAD image in a device context (DC).
Public method | ExportToMetafile | Exports this CAD image to Windows metafile.
Public method | FreeImage | Destroys this CAD image object and frees the memory used within the object.
Public method | GetCADCoords | Returns CAD coordinates for a specified point.
Public method | GetEntityColor | Returns the color value for a specified entity.
Public method | GetExtents | Recalculates extents of the CAD image.
Public method | GetPoint | Gets the on-screen coordinates for a specified CAD point.
Public method | GetRealImagePoint | Returns CAD coordinates of a specified point considering the drawing's rotation and viewport parameters.
Public method | HeadVarAsFloat | Returns a value of the DXF header variable as a floating point number.
Public method | HeadVarAsInteger | Returns a value of the DXF header variable as an integer.
Public method | HeadVarAsstring | Returns a value of the DXF header variable as a string.
Public method | LoadFromClipboardFormat | Loads data from the clipboard.
Public method | LoadFromFile | Loads a CAD drawing from file.
Public method | LoadFromIStream | Loads a CAD drawing from stream.
Public method | LoadFromStream | Loads a CAD drawing from stream.
Public method | RefreshCurrentLayout | Refreshes the current layout.
Public method | ResetDrawingBox | Switches off the drawing box.
Public method | RotDefault | Rotates the drawing to the default view.
Public method | RotToView | Rotates the drawing to a specified view.
Public method | Rotate | Rotates the drawing.
Public method | SaveToClipboardFormat | Copies the drawing to the clipboard in a specified format.
Public method | SaveToFile | Saves the drawing to a specified file.
Public method | SaveToIStream | Writes the drawing data to a specified stream.
Public method | SaveToStream | Writes the drawing data to a specified stream.
Public method | SetClippingRect | Sets a clipping rectangle for the drawing.
Public method | SetExtentsParameters | Changes the drawing extents.
Public method | StopLoading | Terminates loading of the drawing data.
Public method | get_Blocks | Retrieves a BLOCK object by its index.
Public method | get_Entities | Retrieves an entity by its index.
Public method | get_Items |
Public method | get_Layouts | Retrieves a layout by its index.

Top

collall See Also

Reference

IDXFImage Interface


IDXFImage Properties

API Reference > CADViewLib Namespace > IDXFImage Interface >

IDXFImage Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | BackGroundColor | Gets or sets a background color for the drawing.
Public property | BorderSize | Gets or sets a border size for the drawing.
Public property | BorderType | Gets or sets a way the drawing's border size is defined (global or ratio).
Public property | CADClassID | Gets the CAD format identifier for the drawing.
Public property | CBFormat | Gets or sets the clipboard format.
Public property | CanStopLoading | Gets a value indicating whether the loading of the drawing data can be terminated.
Public property | Charset | Gets or sets a character set for the text entities.
Public property | ColorToLineWeight | Gets or sets a string which contains the color-lineweight pairs.
Public property | Converter | Gets or sets a Converter associated with this image object.
Public property | Count | Gets a number of entities in the drawing.
Public property | CurrentLayout | Gets or sets the current layout for the drawing.
Public property | DefaultColor | Gets or sets the default color for the drawing.
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions in the drawing are visible.
Public property | DrawMode | Gets or sets an appearance of colors in the drawing.
Public property | DrawingBox | Gets or sets the drawing bounding box.
Public property | Empty | Gets a value indicating whether the drawing is empty.
Public property | Extents | Gets or sets the drawing's extents.
Public property | Height | Gets or sets a height of the drawing.
Public property | Is3D | Gets a value indicating whether the drawing is three-dimensional.
Public property | IsDraw3DAxes | Gets a value indicating whether 3D axes are visible on the drawing.
Public property | IsDrawingRotated | Gets a value indicating whether the drawing is rotated.
Public property | IsLoading | Gets a value indicating whether the process of loading the drawing data is active.
Public property | IsPlotting | Gets or sets a value indicating whether to plot the image or not.
Public property | IsProcessMessages | Gets or sets a value indicating whether the messages processing is allowed.
Public property | IsShowBackground | Gets or sets a value indicating whether the backround is displayed.
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines is determined by the drawing data.
Public property | IsWithoutBorder | Gets or sets a value indicating whether to display the drawing without borders.
Public property | LayoutsCount | Gets the number of layouts in the drawing.
Public property | LineScaled | Gets or sets a value indicating whether the line weight is diplayed.
Public property | LineWeightScale | Gets or sets a scale for line weights.
Public property | Millimetres | Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file.
Public property | Modified | Gets or sets a value indicating whether the drawing is modified.
Public property | NullWidth | Gets or sets a thickness for lines which have the zero lineweight.
Public property | OwnSource | For internal use.
Public property | PureExtents | Gets the drawing's extents excluding the borders.
Public property | ResizeDisproportionateDrawing | Gets or sets a value indicating whether to resize a drawing with disproportionate sizes.
Public property | Scale | Gets or sets a 3D point which defines the scale factor.
Public property | ShowImages | Gets or sets a value indicating whether the raster images are displayed.
Public property | Stretch | Gets or sets a value indicating whether the displayed image has to be stretched to fit exactly with the drawing rectangle.
Public property | TextVisible | Gets or sets a value indicating whether texts in the drawing are visible.
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles are drawn by using GDI+ methods without linearization.
Public property | ViewRectangle | For internal use.
Public property | Width | Gets or sets a width of the drawing.

Top

collall See Also

Reference

IDXFImage Interface


IDXFImage Methods

API Reference > CADViewLib Namespace > IDXFImage Interface >

IDXFImage Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AbsHeight | Returns an absolute height of the CAD drawing.
Public method | AbsWidth | Returns an absolute width of the CAD drawing.
Public method | AddScaledDXF | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.
Public method | AddScaledDXFEx | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.
Public method | AssignImage | Makes a copy of a specified CAD image object and assigns it to this image.
Public method | CreateImage | Initializes a new CAD image instance.
Public method | Draw | Draws the CAD image in a specified device context (DC).
Public method | DrawRect | Draws a specified region of this CAD image in a device context (DC).
Public method | ExportToMetafile | Exports this CAD image to Windows metafile.
Public method | FreeImage | Destroys this CAD image object and frees the memory used within the object.
Public method | GetCADCoords | Returns CAD coordinates for a specified point.
Public method | GetEntityColor | Returns the color value for a specified entity.
Public method | GetExtents | Recalculates extents of the CAD image.
Public method | GetPoint | Gets the on-screen coordinates for a specified CAD point.
Public method | GetRealImagePoint | Returns CAD coordinates of a specified point considering the drawing's rotation and viewport parameters.
Public method | HeadVarAsFloat | Returns a value of the DXF header variable as a floating point number.
Public method | HeadVarAsInteger | Returns a value of the DXF header variable as an integer.
Public method | HeadVarAsstring | Returns a value of the DXF header variable as a string.
Public method | LoadFromClipboardFormat | Loads data from the clipboard.
Public method | LoadFromFile | Loads a CAD drawing from file.
Public method | LoadFromIStream | Loads a CAD drawing from stream.
Public method | LoadFromStream | Loads a CAD drawing from stream.
Public method | RefreshCurrentLayout | Refreshes the current layout.
Public method | ResetDrawingBox | Switches off the drawing box.
Public method | RotDefault | Rotates the drawing to the default view.
Public method | RotToView | Rotates the drawing to a specified view.
Public method | Rotate | Rotates the drawing.
Public method | SaveToClipboardFormat | Copies the drawing to the clipboard in a specified format.
Public method | SaveToFile | Saves the drawing to a specified file.
Public method | SaveToIStream | Writes the drawing data to a specified stream.
Public method | SaveToStream | Writes the drawing data to a specified stream.
Public method | SetClippingRect | Sets a clipping rectangle for the drawing.
Public method | SetExtentsParameters | Changes the drawing extents.
Public method | StopLoading | Terminates loading of the drawing data.
Public method | get_Blocks | Retrieves a BLOCK object by its index.
Public method | get_Entities | Retrieves an entity by its index.
Public method | get_Items |
Public method | get_Layouts | Retrieves a layout by its index.

Top

collall See Also

Reference

IDXFImage Interface


IDimension Interface

API Reference > CADViewLib Namespace >

IDimension Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to DIMENSION entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface IDimension
Inherits IInsert

C#

public interface IDimension : IInsert

C++

public interface class IDimension : public IInsert^

JScript

public interface IDimension
implements IInsert

collall See Also

Reference

IDimension Members


IDimension Members

API Reference > CADViewLib Namespace > IDimension Interface >

IDimension Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to DIMENSION entities.

The following tables list the members exposed by the IDimension type.

collall Public Properties

 | Name | Description
Public property | Angle | Gets or sets a rotation angle.
Public property | Associated | Gets or sets the associated entity.
Public property | AttribsCount | Gets a number of the attributes.
Public property | Block | Gets or sets the block definition.
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | DefPoint | Gets or sets the definition point (in WCS).
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Flags | Gets or sets the flags that represent the dimension type.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LinDefPoint1 | Gets or sets the first definition point for linear and angular dimensions.
Public property | LinDefPoint2 | Gets or sets the second definition point for linear and angular dimensions.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | MiddlePoint | Gets or sets the middle point of dimension text.
Public property | Name | Gets or sets a name of this object.
Public property | Owner | Gets the block reference which contains this block reference (when blocks are nested).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | Point | Gets or sets the insertion point (in WCS).
Public property | Scale | Gets or sets a scale factor.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | Style | Gets or sets the dimension style.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | Attrib | Returns the attribute with the given tag.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FindBlock | Searches for a block definition with the given name.
Public method | FreeEntity | Destroys the object instance.
Public method | GetBoxPoints | For internal use.
Public method | GetMatrix | Returns a coordinate transformation matrix for this object.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RealColor | Returns the actual color value for a specified color.
Public method | RealLayer | Returns the actual layer for the block reference.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | SetMatrix | Sets a coordinate transformation matrix for this object.
Public method | get_Attribs | Returns the attribute at the given index.
Public method | get_Entities | Returns the child entity at the given index.

Top

collall See Also

Reference

IDimension Interface


IDimension Properties

API Reference > CADViewLib Namespace > IDimension Interface >

IDimension Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Angle | Gets or sets a rotation angle.
Public property | Associated | Gets or sets the associated entity.
Public property | AttribsCount | Gets a number of the attributes.
Public property | Block | Gets or sets the block definition.
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | DefPoint | Gets or sets the definition point (in WCS).
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Flags | Gets or sets the flags that represent the dimension type.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LinDefPoint1 | Gets or sets the first definition point for linear and angular dimensions.
Public property | LinDefPoint2 | Gets or sets the second definition point for linear and angular dimensions.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | MiddlePoint | Gets or sets the middle point of dimension text.
Public property | Name | Gets or sets a name of this object.
Public property | Owner | Gets the block reference which contains this block reference (when blocks are nested).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | Point | Gets or sets the insertion point (in WCS).
Public property | Scale | Gets or sets a scale factor.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | Style | Gets or sets the dimension style.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall See Also

Reference

IDimension Interface


IDimension Methods

API Reference > CADViewLib Namespace > IDimension Interface >

IDimension Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | Attrib | Returns the attribute with the given tag.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FindBlock | Searches for a block definition with the given name.
Public method | FreeEntity | Destroys the object instance.
Public method | GetBoxPoints | For internal use.
Public method | GetMatrix | Returns a coordinate transformation matrix for this object.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RealColor | Returns the actual color value for a specified color.
Public method | RealLayer | Returns the actual layer for the block reference.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | SetMatrix | Sets a coordinate transformation matrix for this object.
Public method | get_Attribs | Returns the attribute at the given index.
Public method | get_Entities | Returns the child entity at the given index.

Top

collall See Also

Reference

IDimension Interface


IEllipse Interface

API Reference > CADViewLib Namespace >

IEllipse Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to ELLIPSE entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface IEllipse
Inherits IArc

C#

public interface IEllipse : IArc

C++

public interface class IEllipse : public IArc^

JScript

public interface IEllipse
implements IArc

collall See Also

Reference

IEllipse Members


IEllipse Members

API Reference > CADViewLib Namespace > IEllipse Interface >

IEllipse Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to ELLIPSE entities.

The following tables list the members exposed by the IEllipse type.

collall Public Properties

 | Name | Description
Public property | Angle | Gets or sets a rotation angle for the ellipse's major axis.
Public property | ArrowsCount | Gets a quantity of points that form an arrow.
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Closed | Gets or sets a value indicating whether this polyline is closed.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | DottedPointsCount | Gets a quantity of points that determine the dots and dashes for a polyline with non-solid line type.
Public property | EndAngle | Gets or sets the end angle.
Public property | EndPoint | Gets or sets the end point of arc/ellipse
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Flags | Gets or sets a bit-coded flag indicating the polyline type.
Public property | GlobalWidth | Gets or sets a global width for this polyline.
Public property | IsMeshMClosed | Gets a value indicating whether the polygon mesh is closed in the M direction.
Public property | IsMeshNClosed | Gets a value indicating whether the polygon mesh is closed in the N direction.
Public property | IsPolyFaceMesh | Gets a value indicating whether this polyline is a polyface mesh.
Public property | IsPolyZThickness | Gets a value indicating whether the polyline has thickness measured along the axis Z.
Public property | IsPolygonMesh | Gets a value indicating whether this polyline is a polygon mesh.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | MeshM | Gets or sets a number of vertices for the polygon mesh in the M direction.
Public property | MeshN | Gets or sets a number of vertices for the polygon mesh in the N direction.
Public property | Name | Gets or sets a name of this object.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | PenLine | Gets properties of the pen used for drawing the object.
Public property | Point | Gets or sets the center point.
Public property | PointsCount | Gets a number of the polyline points.
Public property | PolyFaceVertexIndexesCount | Gets a quantity of indices which specify the order of traversing vertices in the polyface mesh.
Public property | RadPt | Gets an endpoint of major axis, relative to the center.
Public property | Radius | Gets or sets a radius of the circle/ellipse/arc.
Public property | Ratio | Gets or sets a ratio of minor axis to major axis.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | StartAngle | Gets or sets the start angle.
Public property | StartPoint | Gets or sets the start point of arc/ellipse
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetArea | Returns the area bounded by a closed polygon.
Public method | GetBoxPoints | For internal use.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Arrows | Returns a point of the arrowhead.
Public method | get_DottedPoints | Returns coordinates of a point in the points array that determines dots and dashes for a non-solid line type.
Public method | get_Entities | Returns the child entity at the given index.
Public method | get_Points | Returns coordinates of a point in the points array.
Public method | get_PolyFaceVertexIndexes | Returns a value which indicates an index of the polyface mesh vertex.
Public method | set_Arrows | Modifies a point of the arrowhead at the given index.

Top

collall See Also

Reference

IEllipse Interface


IEllipse Properties

API Reference > CADViewLib Namespace > IEllipse Interface >

IEllipse Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Angle | Gets or sets a rotation angle for the ellipse's major axis.
Public property | ArrowsCount | Gets a quantity of points that form an arrow.
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Closed | Gets or sets a value indicating whether this polyline is closed.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | DottedPointsCount | Gets a quantity of points that determine the dots and dashes for a polyline with non-solid line type.
Public property | EndAngle | Gets or sets the end angle.
Public property | EndPoint | Gets or sets the end point of arc/ellipse
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Flags | Gets or sets a bit-coded flag indicating the polyline type.
Public property | GlobalWidth | Gets or sets a global width for this polyline.
Public property | IsMeshMClosed | Gets a value indicating whether the polygon mesh is closed in the M direction.
Public property | IsMeshNClosed | Gets a value indicating whether the polygon mesh is closed in the N direction.
Public property | IsPolyFaceMesh | Gets a value indicating whether this polyline is a polyface mesh.
Public property | IsPolyZThickness | Gets a value indicating whether the polyline has thickness measured along the axis Z.
Public property | IsPolygonMesh | Gets a value indicating whether this polyline is a polygon mesh.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | MeshM | Gets or sets a number of vertices for the polygon mesh in the M direction.
Public property | MeshN | Gets or sets a number of vertices for the polygon mesh in the N direction.
Public property | Name | Gets or sets a name of this object.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | PenLine | Gets properties of the pen used for drawing the object.
Public property | Point | Gets or sets the center point.
Public property | PointsCount | Gets a number of the polyline points.
Public property | PolyFaceVertexIndexesCount | Gets a quantity of indices which specify the order of traversing vertices in the polyface mesh.
Public property | RadPt | Gets an endpoint of major axis, relative to the center.
Public property | Radius | Gets or sets a radius of the circle/ellipse/arc.
Public property | Ratio | Gets or sets a ratio of minor axis to major axis.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | StartAngle | Gets or sets the start angle.
Public property | StartPoint | Gets or sets the start point of arc/ellipse
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall See Also

Reference

IEllipse Interface


IEllipse Methods

API Reference > CADViewLib Namespace > IEllipse Interface >

IEllipse Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetArea | Returns the area bounded by a closed polygon.
Public method | GetBoxPoints | For internal use.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Arrows | Returns a point of the arrowhead.
Public method | get_DottedPoints | Returns coordinates of a point in the points array that determines dots and dashes for a non-solid line type.
Public method | get_Entities | Returns the child entity at the given index.
Public method | get_Points | Returns coordinates of a point in the points array.
Public method | get_PolyFaceVertexIndexes | Returns a value which indicates an index of the polyface mesh vertex.
Public method | set_Arrows | Modifies a point of the arrowhead at the given index.

Top

collall See Also

Reference

IEllipse Interface


IEntity Interface

API Reference > CADViewLib Namespace >

IEntity Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to an entity in the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface IEntity

C#

public interface IEntity

C++

public interface class IEntity

JScript

public interface IEntity

collall See Also

Reference

IEntity Members


IEntity Members

API Reference > CADViewLib Namespace > IEntity Interface >

IEntity Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to an entity in the drawing database.

The following tables list the members exposed by the IEntity type.

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | Name | Gets or sets a name of this object.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetBoxPoints | For internal use.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Entities | Returns the child entity at the given index.

Top

collall See Also

Reference

IEntity Interface


IEntity Properties

API Reference > CADViewLib Namespace > IEntity Interface >

IEntity Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | Name | Gets or sets a name of this object.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall See Also

Reference

IEntity Interface


IEntity Methods

API Reference > CADViewLib Namespace > IEntity Interface >

IEntity Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetBoxPoints | For internal use.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Entities | Returns the child entity at the given index.

Top

collall See Also

Reference

IEntity Interface


IGroup Interface

API Reference > CADViewLib Namespace >

IGroup Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to a group of objects.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface IGroup
Inherits IEntity

C#

public interface IGroup : IEntity

C++

public interface class IGroup : public IEntity^

JScript

public interface IGroup
implements IEntity

collall See Also

Reference

IGroup Members


IGroup Members

API Reference > CADViewLib Namespace > IGroup Interface >

IGroup Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to a group of objects.

The following tables list the members exposed by the IGroup type.

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | Name | Gets or sets a name of this object.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetBoxPoints | For internal use.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Entities | Returns the child entity at the given index.

Top

collall See Also

Reference

IGroup Interface


IGroup Properties

API Reference > CADViewLib Namespace > IGroup Interface >

IGroup Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | Name | Gets or sets a name of this object.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall See Also

Reference

IGroup Interface


IGroup Methods

API Reference > CADViewLib Namespace > IGroup Interface >

IGroup Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetBoxPoints | For internal use.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Entities | Returns the child entity at the given index.

Top

collall See Also

Reference

IGroup Interface


IHPGLImage Interface

API Reference > CADViewLib Namespace >

IHPGLImage Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to an HPGL drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface IHPGLImage
Inherits IDXFImage

C#

public interface IHPGLImage : IDXFImage

C++

public interface class IHPGLImage : public IDXFImage^

JScript

public interface IHPGLImage
implements IDXFImage

collall See Also

Reference

IHPGLImage Members


IHPGLImage Members

API Reference > CADViewLib Namespace > IHPGLImage Interface >

IHPGLImage Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to an HPGL drawing.

The following tables list the members exposed by the IHPGLImage type.

collall Public Properties

 | Name | Description
Public property | BackGroundColor | Gets or sets a background color for the drawing.
Public property | BorderSize | Gets or sets a border size for the drawing.
Public property | BorderType | Gets or sets a way the drawing's border size is defined (global or ratio).
Public property | CADClassID | Gets the CAD format identifier for the drawing.
Public property | CBFormat | Gets or sets the clipboard format.
Public property | CanStopLoading | Gets a value indicating whether the loading of the drawing data can be terminated.
Public property | Charset | Gets or sets a character set for the text entities.
Public property | ColorToLineWeight | Gets or sets a string which contains the color-lineweight pairs.
Public property | Converter | Gets or sets a Converter associated with this image object.
Public property | Count | Gets a number of entities in the drawing.
Public property | CurrentLayout | Gets or sets the current layout for the drawing.
Public property | DefaultColor | Gets or sets the default color for the drawing.
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions in the drawing are visible.
Public property | DrawMode | Gets or sets an appearance of colors in the drawing.
Public property | DrawingBox | Gets or sets the drawing bounding box.
Public property | Empty | Gets a value indicating whether the drawing is empty.
Public property | Extents | Gets or sets the drawing's extents.
Public property | Height | Gets or sets a height of the drawing.
Public property | Is3D | Gets a value indicating whether the drawing is three-dimensional.
Public property | IsDraw3DAxes | Gets a value indicating whether 3D axes are visible on the drawing.
Public property | IsDrawingRotated | Gets a value indicating whether the drawing is rotated.
Public property | IsLoading | Gets a value indicating whether the process of loading the drawing data is active.
Public property | IsPlotting | Gets or sets a value indicating whether to plot the image or not.
Public property | IsProcessMessages | Gets or sets a value indicating whether the messages processing is allowed.
Public property | IsShowBackground | Gets or sets a value indicating whether the backround is displayed.
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines is determined by the drawing data.
Public property | IsWithoutBorder | Gets or sets a value indicating whether to display the drawing without borders.
Public property | LayoutsCount | Gets the number of layouts in the drawing.
Public property | LineScaled | Gets or sets a value indicating whether the line weight is diplayed.
Public property | LineWeightScale | Gets or sets a scale for line weights.
Public property | Millimetres | Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file.
Public property | Modified | Gets or sets a value indicating whether the drawing is modified.
Public property | NullWidth | Gets or sets a thickness for lines which have the zero lineweight.
Public property | OwnSource | For internal use.
Public property | PureExtents | Gets the drawing's extents excluding the borders.
Public property | ResizeDisproportionateDrawing | Gets or sets a value indicating whether to resize a drawing with disproportionate sizes.
Public property | Scale | Gets or sets a 3D point which defines the scale factor.
Public property | ShowImages | Gets or sets a value indicating whether the raster images are displayed.
Public property | Stretch | Gets or sets a value indicating whether the displayed image has to be stretched to fit exactly with the drawing rectangle.
Public property | TextVisible | Gets or sets a value indicating whether texts in the drawing are visible.
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles are drawn by using GDI+ methods without linearization.
Public property | ViewRectangle | For internal use.
Public property | Width | Gets or sets a width of the drawing.
Public property | mmHeight | Gets a height of the HPGL drawing in millimeters.
Public property | mmWidth | Gets a width of the HPGL drawing in millimeters.

Top

collall Public Methods

 | Name | Description
Public method | AbsHeight | Returns an absolute height of the CAD drawing.
Public method | AbsWidth | Returns an absolute width of the CAD drawing.
Public method | AddScaledDXF | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.
Public method | AddScaledDXFEx | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.
Public method | AssignImage | Makes a copy of a specified CAD image object and assigns it to this image.
Public method | CreateImage | Initializes a new CAD image instance.
Public method | Draw | Draws the CAD image in a specified device context (DC).
Public method | DrawRect | Draws a specified region of this CAD image in a device context (DC).
Public method | ExportToMetafile | Exports this CAD image to Windows metafile.
Public method | FreeImage | Destroys this CAD image object and frees the memory used within the object.
Public method | GetCADCoords | Returns CAD coordinates for a specified point.
Public method | GetEntityColor | Returns the color value for a specified entity.
Public method | GetExtents | Recalculates extents of the CAD image.
Public method | GetPoint | Gets the on-screen coordinates for a specified CAD point.
Public method | GetRealImagePoint | Returns CAD coordinates of a specified point considering the drawing's rotation and viewport parameters.
Public method | HeadVarAsFloat | Returns a value of the DXF header variable as a floating point number.
Public method | HeadVarAsInteger | Returns a value of the DXF header variable as an integer.
Public method | HeadVarAsstring | Returns a value of the DXF header variable as a string.
Public method | LoadFromClipboardFormat | Loads data from the clipboard.
Public method | LoadFromFile | Loads a CAD drawing from file.
Public method | LoadFromIStream | Loads a CAD drawing from stream.
Public method | LoadFromStream | Loads a CAD drawing from stream.
Public method | RefreshCurrentLayout | Refreshes the current layout.
Public method | ResetDrawingBox | Switches off the drawing box.
Public method | RotDefault | Rotates the drawing to the default view.
Public method | RotToView | Rotates the drawing to a specified view.
Public method | Rotate | Rotates the drawing.
Public method | SaveToClipboardFormat | Copies the drawing to the clipboard in a specified format.
Public method | SaveToFile | Saves the drawing to a specified file.
Public method | SaveToIStream | Writes the drawing data to a specified stream.
Public method | SaveToStream | Writes the drawing data to a specified stream.
Public method | SetClippingRect | Sets a clipping rectangle for the drawing.
Public method | SetExtentsParameters | Changes the drawing extents.
Public method | StopLoading | Terminates loading of the drawing data.
Public method | get_Blocks | Retrieves a BLOCK object by its index.
Public method | get_Entities | Retrieves an entity by its index.
Public method | get_Items |
Public method | get_Layouts | Retrieves a layout by its index.

Top

collall See Also

Reference

IHPGLImage Interface


IHPGLImage Properties

API Reference > CADViewLib Namespace > IHPGLImage Interface >

IHPGLImage Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | BackGroundColor | Gets or sets a background color for the drawing.
Public property | BorderSize | Gets or sets a border size for the drawing.
Public property | BorderType | Gets or sets a way the drawing's border size is defined (global or ratio).
Public property | CADClassID | Gets the CAD format identifier for the drawing.
Public property | CBFormat | Gets or sets the clipboard format.
Public property | CanStopLoading | Gets a value indicating whether the loading of the drawing data can be terminated.
Public property | Charset | Gets or sets a character set for the text entities.
Public property | ColorToLineWeight | Gets or sets a string which contains the color-lineweight pairs.
Public property | Converter | Gets or sets a Converter associated with this image object.
Public property | Count | Gets a number of entities in the drawing.
Public property | CurrentLayout | Gets or sets the current layout for the drawing.
Public property | DefaultColor | Gets or sets the default color for the drawing.
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions in the drawing are visible.
Public property | DrawMode | Gets or sets an appearance of colors in the drawing.
Public property | DrawingBox | Gets or sets the drawing bounding box.
Public property | Empty | Gets a value indicating whether the drawing is empty.
Public property | Extents | Gets or sets the drawing's extents.
Public property | Height | Gets or sets a height of the drawing.
Public property | Is3D | Gets a value indicating whether the drawing is three-dimensional.
Public property | IsDraw3DAxes | Gets a value indicating whether 3D axes are visible on the drawing.
Public property | IsDrawingRotated | Gets a value indicating whether the drawing is rotated.
Public property | IsLoading | Gets a value indicating whether the process of loading the drawing data is active.
Public property | IsPlotting | Gets or sets a value indicating whether to plot the image or not.
Public property | IsProcessMessages | Gets or sets a value indicating whether the messages processing is allowed.
Public property | IsShowBackground | Gets or sets a value indicating whether the backround is displayed.
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines is determined by the drawing data.
Public property | IsWithoutBorder | Gets or sets a value indicating whether to display the drawing without borders.
Public property | LayoutsCount | Gets the number of layouts in the drawing.
Public property | LineScaled | Gets or sets a value indicating whether the line weight is diplayed.
Public property | LineWeightScale | Gets or sets a scale for line weights.
Public property | Millimetres | Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file.
Public property | Modified | Gets or sets a value indicating whether the drawing is modified.
Public property | NullWidth | Gets or sets a thickness for lines which have the zero lineweight.
Public property | OwnSource | For internal use.
Public property | PureExtents | Gets the drawing's extents excluding the borders.
Public property | ResizeDisproportionateDrawing | Gets or sets a value indicating whether to resize a drawing with disproportionate sizes.
Public property | Scale | Gets or sets a 3D point which defines the scale factor.
Public property | ShowImages | Gets or sets a value indicating whether the raster images are displayed.
Public property | Stretch | Gets or sets a value indicating whether the displayed image has to be stretched to fit exactly with the drawing rectangle.
Public property | TextVisible | Gets or sets a value indicating whether texts in the drawing are visible.
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles are drawn by using GDI+ methods without linearization.
Public property | ViewRectangle | For internal use.
Public property | Width | Gets or sets a width of the drawing.
Public property | mmHeight | Gets a height of the HPGL drawing in millimeters.
Public property | mmWidth | Gets a width of the HPGL drawing in millimeters.

Top

collall See Also

Reference

IHPGLImage Interface


IHPGLImage Methods

API Reference > CADViewLib Namespace > IHPGLImage Interface >

IHPGLImage Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AbsHeight | Returns an absolute height of the CAD drawing.
Public method | AbsWidth | Returns an absolute width of the CAD drawing.
Public method | AddScaledDXF | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.
Public method | AddScaledDXFEx | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.
Public method | AssignImage | Makes a copy of a specified CAD image object and assigns it to this image.
Public method | CreateImage | Initializes a new CAD image instance.
Public method | Draw | Draws the CAD image in a specified device context (DC).
Public method | DrawRect | Draws a specified region of this CAD image in a device context (DC).
Public method | ExportToMetafile | Exports this CAD image to Windows metafile.
Public method | FreeImage | Destroys this CAD image object and frees the memory used within the object.
Public method | GetCADCoords | Returns CAD coordinates for a specified point.
Public method | GetEntityColor | Returns the color value for a specified entity.
Public method | GetExtents | Recalculates extents of the CAD image.
Public method | GetPoint | Gets the on-screen coordinates for a specified CAD point.
Public method | GetRealImagePoint | Returns CAD coordinates of a specified point considering the drawing's rotation and viewport parameters.
Public method | HeadVarAsFloat | Returns a value of the DXF header variable as a floating point number.
Public method | HeadVarAsInteger | Returns a value of the DXF header variable as an integer.
Public method | HeadVarAsstring | Returns a value of the DXF header variable as a string.
Public method | LoadFromClipboardFormat | Loads data from the clipboard.
Public method | LoadFromFile | Loads a CAD drawing from file.
Public method | LoadFromIStream | Loads a CAD drawing from stream.
Public method | LoadFromStream | Loads a CAD drawing from stream.
Public method | RefreshCurrentLayout | Refreshes the current layout.
Public method | ResetDrawingBox | Switches off the drawing box.
Public method | RotDefault | Rotates the drawing to the default view.
Public method | RotToView | Rotates the drawing to a specified view.
Public method | Rotate | Rotates the drawing.
Public method | SaveToClipboardFormat | Copies the drawing to the clipboard in a specified format.
Public method | SaveToFile | Saves the drawing to a specified file.
Public method | SaveToIStream | Writes the drawing data to a specified stream.
Public method | SaveToStream | Writes the drawing data to a specified stream.
Public method | SetClippingRect | Sets a clipping rectangle for the drawing.
Public method | SetExtentsParameters | Changes the drawing extents.
Public method | StopLoading | Terminates loading of the drawing data.
Public method | get_Blocks | Retrieves a BLOCK object by its index.
Public method | get_Entities | Retrieves an entity by its index.
Public method | get_Items |
Public method | get_Layouts | Retrieves a layout by its index.

Top

collall See Also

Reference

IHPGLImage Interface


IImageEnt Interface

API Reference > CADViewLib Namespace >

IImageEnt Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to IMAGE entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface IImageEnt
Inherits ISolid

C#

public interface IImageEnt : ISolid

C++

public interface class IImageEnt : public ISolid^

JScript

public interface IImageEnt
implements ISolid

collall See Also

Reference

IImageEnt Members


IImageEnt Members

API Reference > CADViewLib Namespace > IImageEnt Interface >

IImageEnt Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to IMAGE entities.

The following tables list the members exposed by the IImageEnt type.

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | ImageDef | Gets or sets a hard reference to ImageDef object.
Public property | IsMonoChrome | Gets or sets a value indicating whether the image is monochromatic.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | Name | Gets or sets a name of this object.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | Picture | Gets or sets a graphics stored in the image entity.
Public property | Point | Gets or sets the insertion point (in WCS).
Public property | Point1 | Gets or sets U-vector of a single pixel (points along the visual bottom of the image, starting at the insertion point) (in WCS).
Public property | Point2 | Gets or sets V-vector of a single pixel (points along the visual left side of the image, starting at the insertion point) (in WCS).
Public property | Point3 | Gets or sets a scale vector.
Public property | Rotate | Gets or sets a rotation angle for the image entity.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FindPicture | Obsolete.
Public method | FreeEntity | Destroys the object instance.
Public method | GetBoxPoints | For internal use.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Entities | Returns the child entity at the given index.

Top

collall See Also

Reference

IImageEnt Interface


IImageEnt Properties

API Reference > CADViewLib Namespace > IImageEnt Interface >

IImageEnt Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | ImageDef | Gets or sets a hard reference to ImageDef object.
Public property | IsMonoChrome | Gets or sets a value indicating whether the image is monochromatic.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | Name | Gets or sets a name of this object.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | Picture | Gets or sets a graphics stored in the image entity.
Public property | Point | Gets or sets the insertion point (in WCS).
Public property | Point1 | Gets or sets U-vector of a single pixel (points along the visual bottom of the image, starting at the insertion point) (in WCS).
Public property | Point2 | Gets or sets V-vector of a single pixel (points along the visual left side of the image, starting at the insertion point) (in WCS).
Public property | Point3 | Gets or sets a scale vector.
Public property | Rotate | Gets or sets a rotation angle for the image entity.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall See Also

Reference

IImageEnt Interface


IImageEnt.Box Property

API Reference > CADViewLib Namespace > IImageEnt Interface > Properties >

IImageEnt.Box Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the bounding parallelepiped for the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Box() As Rect3D

C#

Rect3D Box {get;}

C++

property Rect3D^ Box {
Rect3D^ get( );
}

JScript

function get Box() : Rect3D;

Property Value

The parallelepiped which encloses the object.

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.CADHandle Property

API Reference > CADViewLib Namespace > IImageEnt Interface > Properties >

IImageEnt.CADHandle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the object handle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CADHandle() As UInt64

C#

UInt64 CADHandle {get; set;}

C++

property UInt64 CADHandle {
UInt64 get( );
void set(
UInt64 value
);
}

JScript

function get CADHandle() : UInt64;
function set CADHandle(value : UInt64);

Property Value

Number that uniquely identifies the object in a CAD drawing.

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.Color Property

API Reference > CADViewLib Namespace > IImageEnt Interface > Properties >

IImageEnt.Color Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a color of the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Color() As UInt32

C#

UInt32 Color {get; set;}

C++

property UInt32 Color {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get Color() : UInt32;
function set Color(value : UInt32);

Property Value

An insigned integer value which defines the object's color.

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.Converter Property

API Reference > CADViewLib Namespace > IImageEnt Interface > Properties >

IImageEnt.Converter Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a Converter instance associated with the CAD image to which this object belongs.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Converter() As Converter

C#

Converter Converter {get;}

C++

property Converter^ Converter {
Converter^ get( );
}

JScript

function get Converter() : Converter;

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.Count Property

API Reference > CADViewLib Namespace > IImageEnt Interface > Properties >

IImageEnt.Count Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of objects contained within the given object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Count() As Integer

C#

int Count {get;}

C++

property int Count {
int get( );
}

JScript

function get Count() : int;

Property Value

An Integer value indicating a number of objects contained within the given object.

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.EntID Property

API Reference > CADViewLib Namespace > IImageEnt Interface > Properties >

IImageEnt.EntID Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the entity type ID for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property EntID() As TEntityID

C#

TEntityID EntID {get; set;}

C++

property TEntityID EntID {
TEntityID get( );
void set(
TEntityID value
);
}

JScript

function get EntID() : TEntityID;
function set EntID(value : TEntityID);

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.Extrusion Property

API Reference > CADViewLib Namespace > IImageEnt Interface > Properties >

IImageEnt.Extrusion Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the extrusion direction vector for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Extrusion() As Point3D

C#

Point3D Extrusion {get; set;}

C++

property Point3D^ Extrusion {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Extrusion() : Point3D;
function set Extrusion(value : Point3D);

Property Value

The 3D point which defines the extrusion direction vector.

collall Remarks

The extrusion direction is the normal vector of the plane which contains the entity and it is applied to the entity base point. The default extrusion direction value is (0, 0, 1).

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.ImageDef Property

API Reference > CADViewLib Namespace > IImageEnt Interface > Properties >

IImageEnt.ImageDef Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a hard reference to ImageDef object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property ImageDef() As Integer

C#

int ImageDef {get; set;}

C++

property int ImageDef {
int get( );
void set(
int value
);
}

JScript

function get ImageDef() : int;
function set ImageDef(value : int);

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.IsMonoChrome Property

API Reference > CADViewLib Namespace > IImageEnt Interface > Properties >

IImageEnt.IsMonoChrome Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the image is monochromatic.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsMonoChrome() As Boolean

C#

bool IsMonoChrome {get; set;}

C++

property bool IsMonoChrome {
bool get( );
void set(
bool value
);
}

JScript

function get IsMonoChrome() : boolean;
function set IsMonoChrome(value : boolean);

Property Value

true if the image is monochromatic; otherwise, false.

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.Layer Property

API Reference > CADViewLib Namespace > IImageEnt Interface > Properties >

IImageEnt.Layer Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a layer containing this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Layer() As Layer

C#

Layer Layer {get; set;}

C++

property Layer^ Layer {
Layer^ get( );
void set(
Layer^ value
);
}

JScript

function get Layer() : Layer;
function set Layer(value : Layer);

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.LineTypeScale Property

API Reference > CADViewLib Namespace > IImageEnt Interface > Properties >

IImageEnt.LineTypeScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a quantity of line type elements per unit of its length.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineTypeScale() As Single

C#

float LineTypeScale {get; set;}

C++

property float LineTypeScale {
float get( );
void set(
float value
);
}

JScript

function get LineTypeScale() : float;
function set LineTypeScale(value : float);

Property Value

The quantity of linetype elements per unit of its length.

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.Name Property

API Reference > CADViewLib Namespace > IImageEnt Interface > Properties >

IImageEnt.Name Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Name() As String

C#

string Name {get; set;}

C++

property String^ Name {
String^ get( );
void set(
String^ value
);
}

JScript

function get Name() : String;
function set Name(value : String);

Property Value

String containing the object name.

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.PaperSpace Property

API Reference > CADViewLib Namespace > IImageEnt Interface > Properties >

IImageEnt.PaperSpace Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is located in Paper space.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PaperSpace() As Integer

C#

int PaperSpace {get; set;}

C++

property int PaperSpace {
int get( );
void set(
int value
);
}

JScript

function get PaperSpace() : int;
function set PaperSpace(value : int);

Property Value

0 - the object is located in Model space, 1 - in Paper space.

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.Picture Property

API Reference > CADViewLib Namespace > IImageEnt Interface > Properties >

IImageEnt.Picture Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a graphics stored in the image entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Picture() As StdPicture

C#

StdPicture Picture {get; set;}

C++

property StdPicture^ Picture {
StdPicture^ get( );
void set(
StdPicture^ value
);
}

JScript

function get Picture() : StdPicture;
function set Picture(value : StdPicture);

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.Point Property

API Reference > CADViewLib Namespace > IImageEnt Interface > Properties >

IImageEnt.Point Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the insertion point (in WCS).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Point() As Point3D

C#

Point3D Point {get; set;}

C++

property Point3D^ Point {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Point() : Point3D;
function set Point(value : Point3D);

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.Point1 Property

API Reference > CADViewLib Namespace > IImageEnt Interface > Properties >

IImageEnt.Point1 Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets U-vector of a single pixel (points along the visual bottom of the image, starting at the insertion point) (in WCS).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Point1() As Point3D

C#

Point3D Point1 {get; set;}

C++

property Point3D^ Point1 {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Point1() : Point3D;
function set Point1(value : Point3D);

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.Point2 Property

API Reference > CADViewLib Namespace > IImageEnt Interface > Properties >

IImageEnt.Point2 Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets V-vector of a single pixel (points along the visual left side of the image, starting at the insertion point) (in WCS).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Point2() As Point3D

C#

Point3D Point2 {get; set;}

C++

property Point3D^ Point2 {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Point2() : Point3D;
function set Point2(value : Point3D);

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.Point3 Property

API Reference > CADViewLib Namespace > IImageEnt Interface > Properties >

IImageEnt.Point3 Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a scale vector.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Point3() As Point3D

C#

Point3D Point3 {get; set;}

C++

property Point3D^ Point3 {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Point3() : Point3D;
function set Point3(value : Point3D);

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.Rotate Property

API Reference > CADViewLib Namespace > IImageEnt Interface > Properties >

IImageEnt.Rotate Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a rotation angle for the image entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Rotate() As Double

C#

double Rotate {get; set;}

C++

property double Rotate {
double get( );
void set(
double value
);
}

JScript

function get Rotate() : double;
function set Rotate(value : double);

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.SrcEnd Property

API Reference > CADViewLib Namespace > IImageEnt Interface > Properties >

IImageEnt.SrcEnd Property

 Return to chapter overview

Show / hide the hidden text

Indicates the end of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcEnd() As String

C#

string SrcEnd {get; set;}

C++

property String^ SrcEnd {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcEnd() : String;
function set SrcEnd(value : String);

Property Value

A String value indicating the end of the record which represents this object in a drawing file.

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.SrcStart Property

API Reference > CADViewLib Namespace > IImageEnt Interface > Properties >

IImageEnt.SrcStart Property

 Return to chapter overview

Show / hide the hidden text

Indicates the beginning of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcStart() As String

C#

string SrcStart {get; set;}

C++

property String^ SrcStart {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcStart() : String;
function set SrcStart(value : String);

Property Value

A String value indicating the beginning of the record which represents this object in a drawing file.

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.Visibility Property

API Reference > CADViewLib Namespace > IImageEnt Interface > Properties >

IImageEnt.Visibility Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visibility() As Boolean

C#

bool Visibility {get; set;}

C++

property bool Visibility {
bool get( );
void set(
bool value
);
}

JScript

function get Visibility() : boolean;
function set Visibility(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.Visible Property

API Reference > CADViewLib Namespace > IImageEnt Interface > Properties >

IImageEnt.Visible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visible() As Boolean

C#

bool Visible {get; set;}

C++

property bool Visible {
bool get( );
void set(
bool value
);
}

JScript

function get Visible() : boolean;
function set Visible(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt Methods

API Reference > CADViewLib Namespace > IImageEnt Interface >

IImageEnt Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FindPicture | Obsolete.
Public method | FreeEntity | Destroys the object instance.
Public method | GetBoxPoints | For internal use.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Entities | Returns the child entity at the given index.

Top

collall See Also

Reference

IImageEnt Interface


IImageEnt.AddEntity Method

API Reference > CADViewLib Namespace > IImageEnt Interface > Methods >

IImageEnt.AddEntity Method

 Return to chapter overview

Show / hide the hidden text

Adds a new child entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AddEntity( _
ByVal AEntity As Entity _
)

C#

override void AddEntity(
EntityAEntity
)

C++

void AddEntity(
Entity^ AEntity
)

JScript

function AddEntity(
AEntity : Entity
);

Parameters

AEntity

Added entity.

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.AssignEntity Method

API Reference > CADViewLib Namespace > IImageEnt Interface > Methods >

IImageEnt.AssignEntity Method

 Return to chapter overview

Show / hide the hidden text

Assigns the properties of the specified entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AssignEntity( _
ByVal Source As Entity _
)

C#

override void AssignEntity(
EntitySource
)

C++

void AssignEntity(
Entity^ Source
)

JScript

function AssignEntity(
Source : Entity
);

Parameters

Source

Entity which has the same type as the current object.

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.CreateEntity Method

API Reference > CADViewLib Namespace > IImageEnt Interface > Methods >

IImageEnt.CreateEntity Method

 Return to chapter overview

Show / hide the hidden text

Initializes a new object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub CreateEntity()

C#

override void CreateEntity()

C++

void CreateEntity()

JScript

function CreateEntity();

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.DeleteEntity Method

API Reference > CADViewLib Namespace > IImageEnt Interface > Methods >

IImageEnt.DeleteEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes an entity specified by index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub DeleteEntity( _
ByVal AIndex As Integer _
)

C#

override void DeleteEntity(
intAIndex
)

C++

void DeleteEntity(
intAIndex
)

JScript

function DeleteEntity(
AIndex : int
);

Parameters

AIndex

Index of the entity.

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.EntName Method

API Reference > CADViewLib Namespace > IImageEnt Interface > Methods >

IImageEnt.EntName Method

 Return to chapter overview

Show / hide the hidden text

Returns a name of the entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function EntName() As String

C#

override string EntName()

C++

String^ EntName()

JScript

function EntName() : String;

Return Value

A string containing the entity name.

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.FindPicture Method

API Reference > CADViewLib Namespace > IImageEnt Interface > Methods >

IImageEnt.FindPicture Method

 Return to chapter overview

Show / hide the hidden text

NOTE: This member is now obsolete.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub FindPicture( _
ByVal AConverter As Converter _
)

C#

void FindPicture(
ConverterAConverter
)

C++

void FindPicture(
Converter^ AConverter
)

JScript

function FindPicture(
AConverter : Converter
);

Parameters

AConverter

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.FreeEntity Method

API Reference > CADViewLib Namespace > IImageEnt Interface > Methods >

IImageEnt.FreeEntity Method

 Return to chapter overview

Show / hide the hidden text

Destroys the object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub FreeEntity()

C#

override void FreeEntity()

C++

void FreeEntity()

JScript

function FreeEntity();

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.GetBoxPoints Method

API Reference > CADViewLib Namespace > IImageEnt Interface > Methods >

IImageEnt.GetBoxPoints Method

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetBoxPoints( _
ByVal Full As Boolean _
) As Boolean

C#

override bool GetBoxPoints(
boolFull
)

C++

bool GetBoxPoints(
boolFull
)

JScript

function GetBoxPoints(
Full : boolean
) : boolean;

Parameters

Full

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.GetThickness Method

API Reference > CADViewLib Namespace > IImageEnt Interface > Methods >

IImageEnt.GetThickness Method

 Return to chapter overview

Show / hide the hidden text

Returns the line thickness for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetThickness() As Double

C#

override double GetThickness()

C++

double GetThickness()

JScript

function GetThickness() : double;

Return Value

A Double type value indicating the line thickness.

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.IndexOfEntity Method

API Reference > CADViewLib Namespace > IImageEnt Interface > Methods >

IImageEnt.IndexOfEntity Method

 Return to chapter overview

Show / hide the hidden text

Returns index of the given entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function IndexOfEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int IndexOfEntity(
EntityAEntity
)

C++

int IndexOfEntity(
Entity^ AEntity
)

JScript

function IndexOfEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity whose index is retrieved.

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.Iterate Method

API Reference > CADViewLib Namespace > IImageEnt Interface > Methods >

IImageEnt.Iterate Method

 Return to chapter overview

Show / hide the hidden text

Iterates through the entities in the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub Iterate( _
ByVal AConverter As Converter _
)

C#

override void Iterate(
ConverterAConverter
)

C++

void Iterate(
Converter^ AConverter
)

JScript

function Iterate(
AConverter : Converter
);

Parameters

AConverter

Converter which contains the drawing data.

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.RemoveEntity Method

API Reference > CADViewLib Namespace > IImageEnt Interface > Methods >

IImageEnt.RemoveEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes a specified entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function RemoveEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int RemoveEntity(
EntityAEntity
)

C++

int RemoveEntity(
Entity^ AEntity
)

JScript

function RemoveEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity which will be removed.

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.SetLType Method

API Reference > CADViewLib Namespace > IImageEnt Interface > Methods >

IImageEnt.SetLType Method

 Return to chapter overview

Show / hide the hidden text

Sets a line type for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLType( _
ByVal Value As Entity _
)

C#

override void SetLType(
EntityValue
)

C++

void SetLType(
Entity^ Value
)

JScript

function SetLType(
Value : Entity
);

Parameters

Value

The line type value.

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.SetLWeight Method

API Reference > CADViewLib Namespace > IImageEnt Interface > Methods >

IImageEnt.SetLWeight Method

 Return to chapter overview

Show / hide the hidden text

Sets a line weight for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLWeight( _
ByVal Value As Integer _
)

C#

override void SetLWeight(
intValue
)

C++

void SetLWeight(
intValue
)

JScript

function SetLWeight(
Value : int
);

Parameters

Value

The line weight value.

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IImageEnt.get_Entities Method

API Reference > CADViewLib Namespace > IImageEnt Interface > Methods >

IImageEnt.get_Entities Method

 Return to chapter overview

Show / hide the hidden text

Returns the child entity at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Entities( _
ByVal Index As Integer _
) As Entity

C#

override Entity get_Entities(
intIndex
)

C++

Entity^ get_Entities(
intIndex
)

JScript

function get_Entities(
Index : int
) : Entity;

Parameters

Index

The index of the entity to retrieve.

collall See Also

Reference

IImageEnt Interface
IImageEnt IImageEnt Members


IInsert Interface

API Reference > CADViewLib Namespace >

IInsert Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to INSERT entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface IInsert
Inherits IEntity

C#

public interface IInsert : IEntity

C++

public interface class IInsert : public IEntity^

JScript

public interface IInsert
implements IEntity

collall See Also

Reference

IInsert Members


IInsert Members

API Reference > CADViewLib Namespace > IInsert Interface >

IInsert Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to INSERT entities.

The following tables list the members exposed by the IInsert type.

collall Public Properties

 | Name | Description
Public property | Angle | Gets or sets a rotation angle.
Public property | AttribsCount | Gets a number of the attributes.
Public property | Block | Gets or sets the block definition.
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | Name | Gets or sets a name of this object.
Public property | Owner | Gets the block reference which contains this block reference (when blocks are nested).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | Point | Gets or sets the insertion point (in WCS).
Public property | Scale | Gets or sets a scale factor.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | Attrib | Returns the attribute with the given tag.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FindBlock | Searches for a block definition with the given name.
Public method | FreeEntity | Destroys the object instance.
Public method | GetBoxPoints | For internal use.
Public method | GetMatrix | Returns a coordinate transformation matrix for this object.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RealColor | Returns the actual color value for a specified color.
Public method | RealLayer | Returns the actual layer for the block reference.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | SetMatrix | Sets a coordinate transformation matrix for this object.
Public method | get_Attribs | Returns the attribute at the given index.
Public method | get_Entities | Returns the child entity at the given index.

Top

collall See Also

Reference

IInsert Interface


IInsert Properties

API Reference > CADViewLib Namespace > IInsert Interface >

IInsert Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Angle | Gets or sets a rotation angle.
Public property | AttribsCount | Gets a number of the attributes.
Public property | Block | Gets or sets the block definition.
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | Name | Gets or sets a name of this object.
Public property | Owner | Gets the block reference which contains this block reference (when blocks are nested).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | Point | Gets or sets the insertion point (in WCS).
Public property | Scale | Gets or sets a scale factor.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall See Also

Reference

IInsert Interface


IInsert.Angle Property

API Reference > CADViewLib Namespace > IInsert Interface > Properties >

IInsert.Angle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a rotation angle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Angle() As Single

C#

float Angle {get; set;}

C++

property float Angle {
float get( );
void set(
float value
);
}

JScript

function get Angle() : float;
function set Angle(value : float);

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.AttribsCount Property

API Reference > CADViewLib Namespace > IInsert Interface > Properties >

IInsert.AttribsCount Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of the attributes.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property AttribsCount() As Integer

C#

int AttribsCount {get;}

C++

property int AttribsCount {
int get( );
}

JScript

function get AttribsCount() : int;

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.Block Property

API Reference > CADViewLib Namespace > IInsert Interface > Properties >

IInsert.Block Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the block definition.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Block() As Block

C#

Block Block {get; set;}

C++

property Block^ Block {
Block^ get( );
void set(
Block^ value
);
}

JScript

function get Block() : Block;
function set Block(value : Block);

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.Box Property

API Reference > CADViewLib Namespace > IInsert Interface > Properties >

IInsert.Box Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the bounding parallelepiped for the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Box() As Rect3D

C#

Rect3D Box {get;}

C++

property Rect3D^ Box {
Rect3D^ get( );
}

JScript

function get Box() : Rect3D;

Property Value

The parallelepiped which encloses the object.

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.CADHandle Property

API Reference > CADViewLib Namespace > IInsert Interface > Properties >

IInsert.CADHandle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the object handle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CADHandle() As UInt64

C#

UInt64 CADHandle {get; set;}

C++

property UInt64 CADHandle {
UInt64 get( );
void set(
UInt64 value
);
}

JScript

function get CADHandle() : UInt64;
function set CADHandle(value : UInt64);

Property Value

Number that uniquely identifies the object in a CAD drawing.

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.Color Property

API Reference > CADViewLib Namespace > IInsert Interface > Properties >

IInsert.Color Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a color of the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Color() As UInt32

C#

UInt32 Color {get; set;}

C++

property UInt32 Color {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get Color() : UInt32;
function set Color(value : UInt32);

Property Value

An insigned integer value which defines the object's color.

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.Converter Property

API Reference > CADViewLib Namespace > IInsert Interface > Properties >

IInsert.Converter Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a Converter instance associated with the CAD image to which this object belongs.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Converter() As Converter

C#

Converter Converter {get;}

C++

property Converter^ Converter {
Converter^ get( );
}

JScript

function get Converter() : Converter;

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.Count Property

API Reference > CADViewLib Namespace > IInsert Interface > Properties >

IInsert.Count Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of objects contained within the given object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Count() As Integer

C#

int Count {get;}

C++

property int Count {
int get( );
}

JScript

function get Count() : int;

Property Value

An Integer value indicating a number of objects contained within the given object.

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.EntID Property

API Reference > CADViewLib Namespace > IInsert Interface > Properties >

IInsert.EntID Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the entity type ID for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property EntID() As TEntityID

C#

TEntityID EntID {get; set;}

C++

property TEntityID EntID {
TEntityID get( );
void set(
TEntityID value
);
}

JScript

function get EntID() : TEntityID;
function set EntID(value : TEntityID);

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.Extrusion Property

API Reference > CADViewLib Namespace > IInsert Interface > Properties >

IInsert.Extrusion Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the extrusion direction vector for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Extrusion() As Point3D

C#

Point3D Extrusion {get; set;}

C++

property Point3D^ Extrusion {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Extrusion() : Point3D;
function set Extrusion(value : Point3D);

Property Value

The 3D point which defines the extrusion direction vector.

collall Remarks

The extrusion direction is the normal vector of the plane which contains the entity and it is applied to the entity base point. The default extrusion direction value is (0, 0, 1).

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.Layer Property

API Reference > CADViewLib Namespace > IInsert Interface > Properties >

IInsert.Layer Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a layer containing this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Layer() As Layer

C#

Layer Layer {get; set;}

C++

property Layer^ Layer {
Layer^ get( );
void set(
Layer^ value
);
}

JScript

function get Layer() : Layer;
function set Layer(value : Layer);

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.LineTypeScale Property

API Reference > CADViewLib Namespace > IInsert Interface > Properties >

IInsert.LineTypeScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a quantity of line type elements per unit of its length.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineTypeScale() As Single

C#

float LineTypeScale {get; set;}

C++

property float LineTypeScale {
float get( );
void set(
float value
);
}

JScript

function get LineTypeScale() : float;
function set LineTypeScale(value : float);

Property Value

The quantity of linetype elements per unit of its length.

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.Name Property

API Reference > CADViewLib Namespace > IInsert Interface > Properties >

IInsert.Name Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Name() As String

C#

string Name {get; set;}

C++

property String^ Name {
String^ get( );
void set(
String^ value
);
}

JScript

function get Name() : String;
function set Name(value : String);

Property Value

String containing the object name.

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.Owner Property

API Reference > CADViewLib Namespace > IInsert Interface > Properties >

IInsert.Owner Property

 Return to chapter overview

Show / hide the hidden text

Gets the block reference which contains this block reference (when blocks are nested).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Owner() As Insert

C#

Insert Owner {get;}

C++

property Insert^ Owner {
Insert^ get( );
}

JScript

function get Owner() : Insert;

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.PaperSpace Property

API Reference > CADViewLib Namespace > IInsert Interface > Properties >

IInsert.PaperSpace Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is located in Paper space.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PaperSpace() As Integer

C#

int PaperSpace {get; set;}

C++

property int PaperSpace {
int get( );
void set(
int value
);
}

JScript

function get PaperSpace() : int;
function set PaperSpace(value : int);

Property Value

0 - the object is located in Model space, 1 - in Paper space.

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.Point Property

API Reference > CADViewLib Namespace > IInsert Interface > Properties >

IInsert.Point Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the insertion point (in WCS).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Point() As Point3D

C#

Point3D Point {get; set;}

C++

property Point3D^ Point {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Point() : Point3D;
function set Point(value : Point3D);

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.Scale Property

API Reference > CADViewLib Namespace > IInsert Interface > Properties >

IInsert.Scale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a scale factor.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Scale() As Point3D

C#

Point3D Scale {get; set;}

C++

property Point3D^ Scale {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Scale() : Point3D;
function set Scale(value : Point3D);

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.SrcEnd Property

API Reference > CADViewLib Namespace > IInsert Interface > Properties >

IInsert.SrcEnd Property

 Return to chapter overview

Show / hide the hidden text

Indicates the end of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcEnd() As String

C#

string SrcEnd {get; set;}

C++

property String^ SrcEnd {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcEnd() : String;
function set SrcEnd(value : String);

Property Value

A String value indicating the end of the record which represents this object in a drawing file.

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.SrcStart Property

API Reference > CADViewLib Namespace > IInsert Interface > Properties >

IInsert.SrcStart Property

 Return to chapter overview

Show / hide the hidden text

Indicates the beginning of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcStart() As String

C#

string SrcStart {get; set;}

C++

property String^ SrcStart {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcStart() : String;
function set SrcStart(value : String);

Property Value

A String value indicating the beginning of the record which represents this object in a drawing file.

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.Visibility Property

API Reference > CADViewLib Namespace > IInsert Interface > Properties >

IInsert.Visibility Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visibility() As Boolean

C#

bool Visibility {get; set;}

C++

property bool Visibility {
bool get( );
void set(
bool value
);
}

JScript

function get Visibility() : boolean;
function set Visibility(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.Visible Property

API Reference > CADViewLib Namespace > IInsert Interface > Properties >

IInsert.Visible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visible() As Boolean

C#

bool Visible {get; set;}

C++

property bool Visible {
bool get( );
void set(
bool value
);
}

JScript

function get Visible() : boolean;
function set Visible(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert Methods

API Reference > CADViewLib Namespace > IInsert Interface >

IInsert Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | Attrib | Returns the attribute with the given tag.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FindBlock | Searches for a block definition with the given name.
Public method | FreeEntity | Destroys the object instance.
Public method | GetBoxPoints | For internal use.
Public method | GetMatrix | Returns a coordinate transformation matrix for this object.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RealColor | Returns the actual color value for a specified color.
Public method | RealLayer | Returns the actual layer for the block reference.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | SetMatrix | Sets a coordinate transformation matrix for this object.
Public method | get_Attribs | Returns the attribute at the given index.
Public method | get_Entities | Returns the child entity at the given index.

Top

collall See Also

Reference

IInsert Interface


IInsert.AddEntity Method

API Reference > CADViewLib Namespace > IInsert Interface > Methods >

IInsert.AddEntity Method

 Return to chapter overview

Show / hide the hidden text

Adds a new child entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AddEntity( _
ByVal AEntity As Entity _
)

C#

override void AddEntity(
EntityAEntity
)

C++

void AddEntity(
Entity^ AEntity
)

JScript

function AddEntity(
AEntity : Entity
);

Parameters

AEntity

Added entity.

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.AssignEntity Method

API Reference > CADViewLib Namespace > IInsert Interface > Methods >

IInsert.AssignEntity Method

 Return to chapter overview

Show / hide the hidden text

Assigns the properties of the specified entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AssignEntity( _
ByVal Source As Entity _
)

C#

override void AssignEntity(
EntitySource
)

C++

void AssignEntity(
Entity^ Source
)

JScript

function AssignEntity(
Source : Entity
);

Parameters

Source

Entity which has the same type as the current object.

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.Attrib Method

API Reference > CADViewLib Namespace > IInsert Interface > Methods >

IInsert.Attrib Method

 Return to chapter overview

Show / hide the hidden text

Returns the attribute with the given tag.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function Attrib( _
ByVal S As String, _
ByVal P As Point3D _
) As Attrib

C#

Attrib Attrib(
stringS,
Point3DP
)

C++

Attrib^ Attrib(
String^ S,
Point3D^ P
)

JScript

function Attrib(
S : String,
P : Point3D
) : Attrib;

Parameters

S

A String type value which indicates the attribute tag.

P

The attribute insertion point (returned by the method).

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.CreateEntity Method

API Reference > CADViewLib Namespace > IInsert Interface > Methods >

IInsert.CreateEntity Method

 Return to chapter overview

Show / hide the hidden text

Initializes a new object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub CreateEntity()

C#

override void CreateEntity()

C++

void CreateEntity()

JScript

function CreateEntity();

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.DeleteEntity Method

API Reference > CADViewLib Namespace > IInsert Interface > Methods >

IInsert.DeleteEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes an entity specified by index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub DeleteEntity( _
ByVal AIndex As Integer _
)

C#

override void DeleteEntity(
intAIndex
)

C++

void DeleteEntity(
intAIndex
)

JScript

function DeleteEntity(
AIndex : int
);

Parameters

AIndex

Index of the entity.

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.EntName Method

API Reference > CADViewLib Namespace > IInsert Interface > Methods >

IInsert.EntName Method

 Return to chapter overview

Show / hide the hidden text

Returns a name of the entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function EntName() As String

C#

override string EntName()

C++

String^ EntName()

JScript

function EntName() : String;

Return Value

A string containing the entity name.

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.FindBlock Method

API Reference > CADViewLib Namespace > IInsert Interface > Methods >

IInsert.FindBlock Method

 Return to chapter overview

Show / hide the hidden text

Searches for a block definition with the given name.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function FindBlock( _
ByVal AConverter As Converter, _
ByVal AName As String _
) As Block

C#

Block FindBlock(
Converter AConverter,
stringAName
)

C++

Block^ FindBlock(
Converter^ AConverter,
String^ AName
)

JScript

function FindBlock(
AConverter : Converter,
AName : String
) : Block;

Parameters

AConverter

The Converter instance where a search takes place.

AName

The block name.

Return Value

The block definition.

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.FreeEntity Method

API Reference > CADViewLib Namespace > IInsert Interface > Methods >

IInsert.FreeEntity Method

 Return to chapter overview

Show / hide the hidden text

Destroys the object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub FreeEntity()

C#

override void FreeEntity()

C++

void FreeEntity()

JScript

function FreeEntity();

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.GetBoxPoints Method

API Reference > CADViewLib Namespace > IInsert Interface > Methods >

IInsert.GetBoxPoints Method

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetBoxPoints( _
ByVal Full As Boolean _
) As Boolean

C#

override bool GetBoxPoints(
boolFull
)

C++

bool GetBoxPoints(
boolFull
)

JScript

function GetBoxPoints(
Full : boolean
) : boolean;

Parameters

Full

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.GetMatrix Method

API Reference > CADViewLib Namespace > IInsert Interface > Methods >

IInsert.GetMatrix Method

 Return to chapter overview

Show / hide the hidden text

Returns a coordinate transformation matrix for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub GetMatrix( _
ByRef Matrix As Object _
)

C#

void GetMatrix(
ref objectMatrix
)

C++

void GetMatrix(
object^& Matrix
)

JScript

function GetMatrix(
Matrix : object
);

Parameters

Matrix

The coordinate transformation matrix value passed by reference.

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.GetThickness Method

API Reference > CADViewLib Namespace > IInsert Interface > Methods >

IInsert.GetThickness Method

 Return to chapter overview

Show / hide the hidden text

Returns the line thickness for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetThickness() As Double

C#

override double GetThickness()

C++

double GetThickness()

JScript

function GetThickness() : double;

Return Value

A Double type value indicating the line thickness.

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.IndexOfEntity Method

API Reference > CADViewLib Namespace > IInsert Interface > Methods >

IInsert.IndexOfEntity Method

 Return to chapter overview

Show / hide the hidden text

Returns index of the given entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function IndexOfEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int IndexOfEntity(
EntityAEntity
)

C++

int IndexOfEntity(
Entity^ AEntity
)

JScript

function IndexOfEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity whose index is retrieved.

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.Iterate Method

API Reference > CADViewLib Namespace > IInsert Interface > Methods >

IInsert.Iterate Method

 Return to chapter overview

Show / hide the hidden text

Iterates through the entities in the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub Iterate( _
ByVal AConverter As Converter _
)

C#

override void Iterate(
ConverterAConverter
)

C++

void Iterate(
Converter^ AConverter
)

JScript

function Iterate(
AConverter : Converter
);

Parameters

AConverter

Converter which contains the drawing data.

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.RealColor Method

API Reference > CADViewLib Namespace > IInsert Interface > Methods >

IInsert.RealColor Method

 Return to chapter overview

Show / hide the hidden text

Returns the actual color value for a specified color.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function RealColor( _
ByVal AColor As UInt32 _
) As UInt32

C#

UInt32 RealColor(
UInt32AColor
)

C++

UInt32 RealColor(
UInt32AColor
)

JScript

function RealColor(
AColor : UInt32
) : UInt32;

Parameters

AColor

The color value.

Return Value

If AColor value isn't equal to the layer's color (ByLayer), returns AColor, otherwise, Color value.

If the Color value is equal to the layer's color, this method is called recursively for the owner block reference with the Color value as AColor parameter.

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.RealLayer Method

API Reference > CADViewLib Namespace > IInsert Interface > Methods >

IInsert.RealLayer Method

 Return to chapter overview

Show / hide the hidden text

Returns the actual layer for the block reference.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function RealLayer() As Layer

C#

Layer RealLayer()

C++

Layer^ RealLayer()

JScript

function RealLayer() : Layer;

Return Value

For XRef block: layer with a name in the given format: {XRef_Block_Name} | {Layer_Name}.

For nested block: layer which contains the owner block reference.

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.RemoveEntity Method

API Reference > CADViewLib Namespace > IInsert Interface > Methods >

IInsert.RemoveEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes a specified entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function RemoveEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int RemoveEntity(
EntityAEntity
)

C++

int RemoveEntity(
Entity^ AEntity
)

JScript

function RemoveEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity which will be removed.

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.SetLType Method

API Reference > CADViewLib Namespace > IInsert Interface > Methods >

IInsert.SetLType Method

 Return to chapter overview

Show / hide the hidden text

Sets a line type for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLType( _
ByVal Value As Entity _
)

C#

override void SetLType(
EntityValue
)

C++

void SetLType(
Entity^ Value
)

JScript

function SetLType(
Value : Entity
);

Parameters

Value

The line type value.

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.SetLWeight Method

API Reference > CADViewLib Namespace > IInsert Interface > Methods >

IInsert.SetLWeight Method

 Return to chapter overview

Show / hide the hidden text

Sets a line weight for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLWeight( _
ByVal Value As Integer _
)

C#

override void SetLWeight(
intValue
)

C++

void SetLWeight(
intValue
)

JScript

function SetLWeight(
Value : int
);

Parameters

Value

The line weight value.

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.SetMatrix Method

API Reference > CADViewLib Namespace > IInsert Interface > Methods >

IInsert.SetMatrix Method

 Return to chapter overview

Show / hide the hidden text

Sets a coordinate transformation matrix for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub SetMatrix( _
ByVal Matrix As Object _
)

C#

void SetMatrix(
objectMatrix
)

C++

void SetMatrix(
object^ Matrix
)

JScript

function SetMatrix(
Matrix : object
);

Parameters

Matrix

The coordinate transformation matrix

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.get_Attribs Method

API Reference > CADViewLib Namespace > IInsert Interface > Methods >

IInsert.get_Attribs Method

 Return to chapter overview

Show / hide the hidden text

Returns the attribute at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function get_Attribs( _
ByVal Index As Integer _
) As Attrib

C#

Attrib get_Attribs(
intIndex
)

C++

Attrib^ get_Attribs(
intIndex
)

JScript

function get_Attribs(
Index : int
) : Attrib;

Parameters

Index

The index of the attribute to retrieve.

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


IInsert.get_Entities Method

API Reference > CADViewLib Namespace > IInsert Interface > Methods >

IInsert.get_Entities Method

 Return to chapter overview

Show / hide the hidden text

Returns the child entity at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Entities( _
ByVal Index As Integer _
) As Entity

C#

override Entity get_Entities(
intIndex
)

C++

Entity^ get_Entities(
intIndex
)

JScript

function get_Entities(
Index : int
) : Entity;

Parameters

Index

The index of the entity to retrieve.

collall See Also

Reference

IInsert Interface
IInsert IInsert Members


ILayer Interface

API Reference > CADViewLib Namespace >

ILayer Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to LAYER objects.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface ILayer
Inherits IEntity

C#

public interface ILayer : IEntity

C++

public interface class ILayer : public IEntity^

JScript

public interface ILayer
implements IEntity

collall See Also

Reference

ILayer Members


ILayer Members

API Reference > CADViewLib Namespace > ILayer Interface >

ILayer Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to LAYER objects.

The following tables list the members exposed by the ILayer type.

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Flags | Gets or sets the layer flags (bit-coded values).
Public property | Frozen | Gets or sets a value indicating whether the layer is frozen.
Public property | IsFrozenByViewPort | Gets or sets a value indicating whether the layer is frozen by default in new viewports.
Public property | IsPlotting | Gets or sets a value indicating whether to plot this layer or not.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | Name | Gets or sets a name of this object.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | PenColor | Gets or sets a pen color for this layer.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | Used | Gets a value indicating whether this layer contains entities.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetBoxPoints | For internal use.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Entities | Returns the child entity at the given index.

Top

collall See Also

Reference

ILayer Interface


ILayer Properties

API Reference > CADViewLib Namespace > ILayer Interface >

ILayer Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Flags | Gets or sets the layer flags (bit-coded values).
Public property | Frozen | Gets or sets a value indicating whether the layer is frozen.
Public property | IsFrozenByViewPort | Gets or sets a value indicating whether the layer is frozen by default in new viewports.
Public property | IsPlotting | Gets or sets a value indicating whether to plot this layer or not.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | Name | Gets or sets a name of this object.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | PenColor | Gets or sets a pen color for this layer.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | Used | Gets a value indicating whether this layer contains entities.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall See Also

Reference

ILayer Interface


ILayer.Box Property

API Reference > CADViewLib Namespace > ILayer Interface > Properties >

ILayer.Box Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the bounding parallelepiped for the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Box() As Rect3D

C#

Rect3D Box {get;}

C++

property Rect3D^ Box {
Rect3D^ get( );
}

JScript

function get Box() : Rect3D;

Property Value

The parallelepiped which encloses the object.

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.CADHandle Property

API Reference > CADViewLib Namespace > ILayer Interface > Properties >

ILayer.CADHandle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the object handle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CADHandle() As UInt64

C#

UInt64 CADHandle {get; set;}

C++

property UInt64 CADHandle {
UInt64 get( );
void set(
UInt64 value
);
}

JScript

function get CADHandle() : UInt64;
function set CADHandle(value : UInt64);

Property Value

Number that uniquely identifies the object in a CAD drawing.

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.Color Property

API Reference > CADViewLib Namespace > ILayer Interface > Properties >

ILayer.Color Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a color of the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Color() As UInt32

C#

UInt32 Color {get; set;}

C++

property UInt32 Color {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get Color() : UInt32;
function set Color(value : UInt32);

Property Value

An insigned integer value which defines the object's color.

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.Converter Property

API Reference > CADViewLib Namespace > ILayer Interface > Properties >

ILayer.Converter Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a Converter instance associated with the CAD image to which this object belongs.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Converter() As Converter

C#

Converter Converter {get;}

C++

property Converter^ Converter {
Converter^ get( );
}

JScript

function get Converter() : Converter;

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.Count Property

API Reference > CADViewLib Namespace > ILayer Interface > Properties >

ILayer.Count Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of objects contained within the given object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Count() As Integer

C#

int Count {get;}

C++

property int Count {
int get( );
}

JScript

function get Count() : int;

Property Value

An Integer value indicating a number of objects contained within the given object.

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.EntID Property

API Reference > CADViewLib Namespace > ILayer Interface > Properties >

ILayer.EntID Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the entity type ID for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property EntID() As TEntityID

C#

TEntityID EntID {get; set;}

C++

property TEntityID EntID {
TEntityID get( );
void set(
TEntityID value
);
}

JScript

function get EntID() : TEntityID;
function set EntID(value : TEntityID);

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.Extrusion Property

API Reference > CADViewLib Namespace > ILayer Interface > Properties >

ILayer.Extrusion Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the extrusion direction vector for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Extrusion() As Point3D

C#

Point3D Extrusion {get; set;}

C++

property Point3D^ Extrusion {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Extrusion() : Point3D;
function set Extrusion(value : Point3D);

Property Value

The 3D point which defines the extrusion direction vector.

collall Remarks

The extrusion direction is the normal vector of the plane which contains the entity and it is applied to the entity base point. The default extrusion direction value is (0, 0, 1).

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.Flags Property

API Reference > CADViewLib Namespace > ILayer Interface > Properties >

ILayer.Flags Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the layer flags (bit-coded values).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Flags() As Byte

C#

byte Flags {get; set;}

C++

property Byte Flags {
Byte get( );
void set(
Byte value
);
}

JScript

function get Flags() : byte;
function set Flags(value : byte);

Property Value

1 = Layer is frozen; otherwise layer is thawed
2 = Layer is frozen by default in new viewports
4 = Layer is locked
16 = If set, table entry is externally dependent on an xref
32 = If both this bit and bit 16 are set, the externally dependent xref has been successfully resolved
64 = If set, the table entry was referenced by at least one entity in the drawing the last time the
drawing was edited. (This flag is for the benefit of AutoCAD commands. It can be ignored by
most programs that read DXF files and need not be set by programs that write DXF files)

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.Frozen Property

API Reference > CADViewLib Namespace > ILayer Interface > Properties >

ILayer.Frozen Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the layer is frozen.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Frozen() As Boolean

C#

bool Frozen {get; set;}

C++

property bool Frozen {
bool get( );
void set(
bool value
);
}

JScript

function get Frozen() : boolean;
function set Frozen(value : boolean);

Property Value

true if the layer is frozen; otherwise, false.

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.IsFrozenByViewPort Property

API Reference > CADViewLib Namespace > ILayer Interface > Properties >

ILayer.IsFrozenByViewPort Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the layer is frozen by default in new viewports.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsFrozenByViewPort() As Boolean

C#

bool IsFrozenByViewPort {get;}

C++

property bool IsFrozenByViewPort {
bool get( );
}

JScript

function get IsFrozenByViewPort() : boolean;

Property Value

true if the layer is frozen by default in new viewports; otherwise, false.

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.IsPlotting Property

API Reference > CADViewLib Namespace > ILayer Interface > Properties >

ILayer.IsPlotting Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether to plot this layer or not.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsPlotting() As Boolean

C#

bool IsPlotting {get; set;}

C++

property bool IsPlotting {
bool get( );
void set(
bool value
);
}

JScript

function get IsPlotting() : boolean;
function set IsPlotting(value : boolean);

Property Value

true if the layer should be plotted; otherwise, false.

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.Layer Property

API Reference > CADViewLib Namespace > ILayer Interface > Properties >

ILayer.Layer Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a layer containing this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Layer() As Layer

C#

Layer Layer {get; set;}

C++

property Layer^ Layer {
Layer^ get( );
void set(
Layer^ value
);
}

JScript

function get Layer() : Layer;
function set Layer(value : Layer);

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.LineTypeScale Property

API Reference > CADViewLib Namespace > ILayer Interface > Properties >

ILayer.LineTypeScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a quantity of line type elements per unit of its length.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineTypeScale() As Single

C#

float LineTypeScale {get; set;}

C++

property float LineTypeScale {
float get( );
void set(
float value
);
}

JScript

function get LineTypeScale() : float;
function set LineTypeScale(value : float);

Property Value

The quantity of linetype elements per unit of its length.

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.Name Property

API Reference > CADViewLib Namespace > ILayer Interface > Properties >

ILayer.Name Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Name() As String

C#

string Name {get; set;}

C++

property String^ Name {
String^ get( );
void set(
String^ value
);
}

JScript

function get Name() : String;
function set Name(value : String);

Property Value

String containing the object name.

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.PaperSpace Property

API Reference > CADViewLib Namespace > ILayer Interface > Properties >

ILayer.PaperSpace Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is located in Paper space.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PaperSpace() As Integer

C#

int PaperSpace {get; set;}

C++

property int PaperSpace {
int get( );
void set(
int value
);
}

JScript

function get PaperSpace() : int;
function set PaperSpace(value : int);

Property Value

0 - the object is located in Model space, 1 - in Paper space.

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.PenColor Property

API Reference > CADViewLib Namespace > ILayer Interface > Properties >

ILayer.PenColor Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a pen color for this layer.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PenColor() As UInt32

C#

UInt32 PenColor {get; set;}

C++

property UInt32 PenColor {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get PenColor() : UInt32;
function set PenColor(value : UInt32);

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.SrcEnd Property

API Reference > CADViewLib Namespace > ILayer Interface > Properties >

ILayer.SrcEnd Property

 Return to chapter overview

Show / hide the hidden text

Indicates the end of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcEnd() As String

C#

string SrcEnd {get; set;}

C++

property String^ SrcEnd {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcEnd() : String;
function set SrcEnd(value : String);

Property Value

A String value indicating the end of the record which represents this object in a drawing file.

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.SrcStart Property

API Reference > CADViewLib Namespace > ILayer Interface > Properties >

ILayer.SrcStart Property

 Return to chapter overview

Show / hide the hidden text

Indicates the beginning of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcStart() As String

C#

string SrcStart {get; set;}

C++

property String^ SrcStart {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcStart() : String;
function set SrcStart(value : String);

Property Value

A String value indicating the beginning of the record which represents this object in a drawing file.

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.Used Property

API Reference > CADViewLib Namespace > ILayer Interface > Properties >

ILayer.Used Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether this layer contains entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Used() As Boolean

C#

bool Used {get;}

C++

property bool Used {
bool get( );
}

JScript

function get Used() : boolean;

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.Visibility Property

API Reference > CADViewLib Namespace > ILayer Interface > Properties >

ILayer.Visibility Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visibility() As Boolean

C#

bool Visibility {get; set;}

C++

property bool Visibility {
bool get( );
void set(
bool value
);
}

JScript

function get Visibility() : boolean;
function set Visibility(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.Visible Property

API Reference > CADViewLib Namespace > ILayer Interface > Properties >

ILayer.Visible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visible() As Boolean

C#

bool Visible {get; set;}

C++

property bool Visible {
bool get( );
void set(
bool value
);
}

JScript

function get Visible() : boolean;
function set Visible(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer Methods

API Reference > CADViewLib Namespace > ILayer Interface >

ILayer Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetBoxPoints | For internal use.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Entities | Returns the child entity at the given index.

Top

collall See Also

Reference

ILayer Interface


ILayer.AddEntity Method

API Reference > CADViewLib Namespace > ILayer Interface > Methods >

ILayer.AddEntity Method

 Return to chapter overview

Show / hide the hidden text

Adds a new child entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AddEntity( _
ByVal AEntity As Entity _
)

C#

override void AddEntity(
EntityAEntity
)

C++

void AddEntity(
Entity^ AEntity
)

JScript

function AddEntity(
AEntity : Entity
);

Parameters

AEntity

Added entity.

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.AssignEntity Method

API Reference > CADViewLib Namespace > ILayer Interface > Methods >

ILayer.AssignEntity Method

 Return to chapter overview

Show / hide the hidden text

Assigns the properties of the specified entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AssignEntity( _
ByVal Source As Entity _
)

C#

override void AssignEntity(
EntitySource
)

C++

void AssignEntity(
Entity^ Source
)

JScript

function AssignEntity(
Source : Entity
);

Parameters

Source

Entity which has the same type as the current object.

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.CreateEntity Method

API Reference > CADViewLib Namespace > ILayer Interface > Methods >

ILayer.CreateEntity Method

 Return to chapter overview

Show / hide the hidden text

Initializes a new object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub CreateEntity()

C#

override void CreateEntity()

C++

void CreateEntity()

JScript

function CreateEntity();

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.DeleteEntity Method

API Reference > CADViewLib Namespace > ILayer Interface > Methods >

ILayer.DeleteEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes an entity specified by index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub DeleteEntity( _
ByVal AIndex As Integer _
)

C#

override void DeleteEntity(
intAIndex
)

C++

void DeleteEntity(
intAIndex
)

JScript

function DeleteEntity(
AIndex : int
);

Parameters

AIndex

Index of the entity.

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.EntName Method

API Reference > CADViewLib Namespace > ILayer Interface > Methods >

ILayer.EntName Method

 Return to chapter overview

Show / hide the hidden text

Returns a name of the entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function EntName() As String

C#

override string EntName()

C++

String^ EntName()

JScript

function EntName() : String;

Return Value

A string containing the entity name.

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.FreeEntity Method

API Reference > CADViewLib Namespace > ILayer Interface > Methods >

ILayer.FreeEntity Method

 Return to chapter overview

Show / hide the hidden text

Destroys the object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub FreeEntity()

C#

override void FreeEntity()

C++

void FreeEntity()

JScript

function FreeEntity();

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.GetBoxPoints Method

API Reference > CADViewLib Namespace > ILayer Interface > Methods >

ILayer.GetBoxPoints Method

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetBoxPoints( _
ByVal Full As Boolean _
) As Boolean

C#

override bool GetBoxPoints(
boolFull
)

C++

bool GetBoxPoints(
boolFull
)

JScript

function GetBoxPoints(
Full : boolean
) : boolean;

Parameters

Full

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.GetThickness Method

API Reference > CADViewLib Namespace > ILayer Interface > Methods >

ILayer.GetThickness Method

 Return to chapter overview

Show / hide the hidden text

Returns the line thickness for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetThickness() As Double

C#

override double GetThickness()

C++

double GetThickness()

JScript

function GetThickness() : double;

Return Value

A Double type value indicating the line thickness.

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.IndexOfEntity Method

API Reference > CADViewLib Namespace > ILayer Interface > Methods >

ILayer.IndexOfEntity Method

 Return to chapter overview

Show / hide the hidden text

Returns index of the given entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function IndexOfEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int IndexOfEntity(
EntityAEntity
)

C++

int IndexOfEntity(
Entity^ AEntity
)

JScript

function IndexOfEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity whose index is retrieved.

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.Iterate Method

API Reference > CADViewLib Namespace > ILayer Interface > Methods >

ILayer.Iterate Method

 Return to chapter overview

Show / hide the hidden text

Iterates through the entities in the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub Iterate( _
ByVal AConverter As Converter _
)

C#

override void Iterate(
ConverterAConverter
)

C++

void Iterate(
Converter^ AConverter
)

JScript

function Iterate(
AConverter : Converter
);

Parameters

AConverter

Converter which contains the drawing data.

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.RemoveEntity Method

API Reference > CADViewLib Namespace > ILayer Interface > Methods >

ILayer.RemoveEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes a specified entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function RemoveEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int RemoveEntity(
EntityAEntity
)

C++

int RemoveEntity(
Entity^ AEntity
)

JScript

function RemoveEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity which will be removed.

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.SetLType Method

API Reference > CADViewLib Namespace > ILayer Interface > Methods >

ILayer.SetLType Method

 Return to chapter overview

Show / hide the hidden text

Sets a line type for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLType( _
ByVal Value As Entity _
)

C#

override void SetLType(
EntityValue
)

C++

void SetLType(
Entity^ Value
)

JScript

function SetLType(
Value : Entity
);

Parameters

Value

The line type value.

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.SetLWeight Method

API Reference > CADViewLib Namespace > ILayer Interface > Methods >

ILayer.SetLWeight Method

 Return to chapter overview

Show / hide the hidden text

Sets a line weight for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLWeight( _
ByVal Value As Integer _
)

C#

override void SetLWeight(
intValue
)

C++

void SetLWeight(
intValue
)

JScript

function SetLWeight(
Value : int
);

Parameters

Value

The line weight value.

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayer.get_Entities Method

API Reference > CADViewLib Namespace > ILayer Interface > Methods >

ILayer.get_Entities Method

 Return to chapter overview

Show / hide the hidden text

Returns the child entity at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Entities( _
ByVal Index As Integer _
) As Entity

C#

override Entity get_Entities(
intIndex
)

C++

Entity^ get_Entities(
intIndex
)

JScript

function get_Entities(
Index : int
) : Entity;

Parameters

Index

The index of the entity to retrieve.

collall See Also

Reference

ILayer Interface
ILayer ILayer Members


ILayout Interface

API Reference > CADViewLib Namespace >

ILayout Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to LAYOUT objects.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface ILayout
Inherits IEntity

C#

public interface ILayout : IEntity

C++

public interface class ILayout : public IEntity^

JScript

public interface ILayout
implements IEntity

collall See Also

Reference

ILayout Members


ILayout Members

API Reference > CADViewLib Namespace > ILayout Interface >

ILayout Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to LAYOUT objects.

The following tables list the members exposed by the ILayout type.

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | CADSpace | Gets or sets a style for the layout's space.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | CustomPrintScale | Gets or sets a custom scale for printing.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | IsEmpty | Gets a value indicating whether this layout is empty.
Public property | IsModel | Gets a value indicating whether this layout is Model space.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | Name | Gets or sets a name of this object.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | PaperSpaceBlock | Gets or sets the Paper space block.
Public property | PaperSpaceHandle | Gets or sets ID/handle to this layout's associated paper space.
Public property | PlotPaperUnits | Gets the units which are used for plotting this layout.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetBoxPoints | For internal use.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Entities | Returns the child entity at the given index.

Top

collall See Also

Reference

ILayout Interface


ILayout Properties

API Reference > CADViewLib Namespace > ILayout Interface >

ILayout Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | CADSpace | Gets or sets a style for the layout's space.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | CustomPrintScale | Gets or sets a custom scale for printing.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | IsEmpty | Gets a value indicating whether this layout is empty.
Public property | IsModel | Gets a value indicating whether this layout is Model space.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | Name | Gets or sets a name of this object.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | PaperSpaceBlock | Gets or sets the Paper space block.
Public property | PaperSpaceHandle | Gets or sets ID/handle to this layout's associated paper space.
Public property | PlotPaperUnits | Gets the units which are used for plotting this layout.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall See Also

Reference

ILayout Interface


ILayout.Box Property

API Reference > CADViewLib Namespace > ILayout Interface > Properties >

ILayout.Box Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the bounding parallelepiped for the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Box() As Rect3D

C#

Rect3D Box {get;}

C++

property Rect3D^ Box {
Rect3D^ get( );
}

JScript

function get Box() : Rect3D;

Property Value

The parallelepiped which encloses the object.

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.CADHandle Property

API Reference > CADViewLib Namespace > ILayout Interface > Properties >

ILayout.CADHandle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the object handle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CADHandle() As UInt64

C#

UInt64 CADHandle {get; set;}

C++

property UInt64 CADHandle {
UInt64 get( );
void set(
UInt64 value
);
}

JScript

function get CADHandle() : UInt64;
function set CADHandle(value : UInt64);

Property Value

Number that uniquely identifies the object in a CAD drawing.

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.CADSpace Property

API Reference > CADViewLib Namespace > ILayout Interface > Properties >

ILayout.CADSpace Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a style for the layout's space.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CADSpace() As TxCADSpace

C#

TxCADSpace CADSpace {get; set;}

C++

property TxCADSpace CADSpace {
TxCADSpace get( );
void set(
TxCADSpace value
);
}

JScript

function get CADSpace() : TxCADSpace;
function set CADSpace(value : TxCADSpace);

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.Color Property

API Reference > CADViewLib Namespace > ILayout Interface > Properties >

ILayout.Color Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a color of the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Color() As UInt32

C#

UInt32 Color {get; set;}

C++

property UInt32 Color {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get Color() : UInt32;
function set Color(value : UInt32);

Property Value

An insigned integer value which defines the object's color.

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.Converter Property

API Reference > CADViewLib Namespace > ILayout Interface > Properties >

ILayout.Converter Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a Converter instance associated with the CAD image to which this object belongs.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Converter() As Converter

C#

Converter Converter {get;}

C++

property Converter^ Converter {
Converter^ get( );
}

JScript

function get Converter() : Converter;

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.Count Property

API Reference > CADViewLib Namespace > ILayout Interface > Properties >

ILayout.Count Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of objects contained within the given object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Count() As Integer

C#

int Count {get;}

C++

property int Count {
int get( );
}

JScript

function get Count() : int;

Property Value

An Integer value indicating a number of objects contained within the given object.

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.CustomPrintScale Property

API Reference > CADViewLib Namespace > ILayout Interface > Properties >

ILayout.CustomPrintScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a custom scale for printing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CustomPrintScale() As Double

C#

double CustomPrintScale {get; set;}

C++

property double CustomPrintScale {
double get( );
void set(
double value
);
}

JScript

function get CustomPrintScale() : double;
function set CustomPrintScale(value : double);

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.EntID Property

API Reference > CADViewLib Namespace > ILayout Interface > Properties >

ILayout.EntID Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the entity type ID for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property EntID() As TEntityID

C#

TEntityID EntID {get; set;}

C++

property TEntityID EntID {
TEntityID get( );
void set(
TEntityID value
);
}

JScript

function get EntID() : TEntityID;
function set EntID(value : TEntityID);

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.Extrusion Property

API Reference > CADViewLib Namespace > ILayout Interface > Properties >

ILayout.Extrusion Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the extrusion direction vector for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Extrusion() As Point3D

C#

Point3D Extrusion {get; set;}

C++

property Point3D^ Extrusion {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Extrusion() : Point3D;
function set Extrusion(value : Point3D);

Property Value

The 3D point which defines the extrusion direction vector.

collall Remarks

The extrusion direction is the normal vector of the plane which contains the entity and it is applied to the entity base point. The default extrusion direction value is (0, 0, 1).

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.IsEmpty Property

API Reference > CADViewLib Namespace > ILayout Interface > Properties >

ILayout.IsEmpty Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether this layout is empty.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsEmpty() As Boolean

C#

bool IsEmpty {get;}

C++

property bool IsEmpty {
bool get( );
}

JScript

function get IsEmpty() : boolean;

Property Value

true if the layout doesn't contain objects; otherwise, false.

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.IsModel Property

API Reference > CADViewLib Namespace > ILayout Interface > Properties >

ILayout.IsModel Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether this layout is Model space.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsModel() As Boolean

C#

bool IsModel {get;}

C++

property bool IsModel {
bool get( );
}

JScript

function get IsModel() : boolean;

Property Value

true if the layout is Model space; otherwise, false.

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.Layer Property

API Reference > CADViewLib Namespace > ILayout Interface > Properties >

ILayout.Layer Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a layer containing this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Layer() As Layer

C#

Layer Layer {get; set;}

C++

property Layer^ Layer {
Layer^ get( );
void set(
Layer^ value
);
}

JScript

function get Layer() : Layer;
function set Layer(value : Layer);

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.LineTypeScale Property

API Reference > CADViewLib Namespace > ILayout Interface > Properties >

ILayout.LineTypeScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a quantity of line type elements per unit of its length.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineTypeScale() As Single

C#

float LineTypeScale {get; set;}

C++

property float LineTypeScale {
float get( );
void set(
float value
);
}

JScript

function get LineTypeScale() : float;
function set LineTypeScale(value : float);

Property Value

The quantity of linetype elements per unit of its length.

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.Name Property

API Reference > CADViewLib Namespace > ILayout Interface > Properties >

ILayout.Name Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Name() As String

C#

string Name {get; set;}

C++

property String^ Name {
String^ get( );
void set(
String^ value
);
}

JScript

function get Name() : String;
function set Name(value : String);

Property Value

String containing the object name.

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.PaperSpace Property

API Reference > CADViewLib Namespace > ILayout Interface > Properties >

ILayout.PaperSpace Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is located in Paper space.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PaperSpace() As Integer

C#

int PaperSpace {get; set;}

C++

property int PaperSpace {
int get( );
void set(
int value
);
}

JScript

function get PaperSpace() : int;
function set PaperSpace(value : int);

Property Value

0 - the object is located in Model space, 1 - in Paper space.

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.PaperSpaceBlock Property

API Reference > CADViewLib Namespace > ILayout Interface > Properties >

ILayout.PaperSpaceBlock Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the Paper space block.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PaperSpaceBlock() As Block

C#

Block PaperSpaceBlock {get; set;}

C++

property Block^ PaperSpaceBlock {
Block^ get( );
void set(
Block^ value
);
}

JScript

function get PaperSpaceBlock() : Block;
function set PaperSpaceBlock(value : Block);

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.PaperSpaceHandle Property

API Reference > CADViewLib Namespace > ILayout Interface > Properties >

ILayout.PaperSpaceHandle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets ID/handle to this layout's associated paper space.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PaperSpaceHandle() As Integer

C#

int PaperSpaceHandle {get; set;}

C++

property int PaperSpaceHandle {
int get( );
void set(
int value
);
}

JScript

function get PaperSpaceHandle() : int;
function set PaperSpaceHandle(value : int);

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.PlotPaperUnits Property

API Reference > CADViewLib Namespace > ILayout Interface > Properties >

ILayout.PlotPaperUnits Property

 Return to chapter overview

Show / hide the hidden text

Gets the units which are used for plotting this layout.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property PlotPaperUnits() As Integer

C#

int PlotPaperUnits {get;}

C++

property int PlotPaperUnits {
int get( );
}

JScript

function get PlotPaperUnits() : int;

Property Value

0 = Inches
1 = Millimeters
2 = Pixels

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.SrcEnd Property

API Reference > CADViewLib Namespace > ILayout Interface > Properties >

ILayout.SrcEnd Property

 Return to chapter overview

Show / hide the hidden text

Indicates the end of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcEnd() As String

C#

string SrcEnd {get; set;}

C++

property String^ SrcEnd {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcEnd() : String;
function set SrcEnd(value : String);

Property Value

A String value indicating the end of the record which represents this object in a drawing file.

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.SrcStart Property

API Reference > CADViewLib Namespace > ILayout Interface > Properties >

ILayout.SrcStart Property

 Return to chapter overview

Show / hide the hidden text

Indicates the beginning of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcStart() As String

C#

string SrcStart {get; set;}

C++

property String^ SrcStart {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcStart() : String;
function set SrcStart(value : String);

Property Value

A String value indicating the beginning of the record which represents this object in a drawing file.

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.Visibility Property

API Reference > CADViewLib Namespace > ILayout Interface > Properties >

ILayout.Visibility Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visibility() As Boolean

C#

bool Visibility {get; set;}

C++

property bool Visibility {
bool get( );
void set(
bool value
);
}

JScript

function get Visibility() : boolean;
function set Visibility(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.Visible Property

API Reference > CADViewLib Namespace > ILayout Interface > Properties >

ILayout.Visible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visible() As Boolean

C#

bool Visible {get; set;}

C++

property bool Visible {
bool get( );
void set(
bool value
);
}

JScript

function get Visible() : boolean;
function set Visible(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout Methods

API Reference > CADViewLib Namespace > ILayout Interface >

ILayout Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetBoxPoints | For internal use.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Entities | Returns the child entity at the given index.

Top

collall See Also

Reference

ILayout Interface


ILayout.AddEntity Method

API Reference > CADViewLib Namespace > ILayout Interface > Methods >

ILayout.AddEntity Method

 Return to chapter overview

Show / hide the hidden text

Adds a new child entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AddEntity( _
ByVal AEntity As Entity _
)

C#

override void AddEntity(
EntityAEntity
)

C++

void AddEntity(
Entity^ AEntity
)

JScript

function AddEntity(
AEntity : Entity
);

Parameters

AEntity

Added entity.

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.AssignEntity Method

API Reference > CADViewLib Namespace > ILayout Interface > Methods >

ILayout.AssignEntity Method

 Return to chapter overview

Show / hide the hidden text

Assigns the properties of the specified entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AssignEntity( _
ByVal Source As Entity _
)

C#

override void AssignEntity(
EntitySource
)

C++

void AssignEntity(
Entity^ Source
)

JScript

function AssignEntity(
Source : Entity
);

Parameters

Source

Entity which has the same type as the current object.

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.CreateEntity Method

API Reference > CADViewLib Namespace > ILayout Interface > Methods >

ILayout.CreateEntity Method

 Return to chapter overview

Show / hide the hidden text

Initializes a new object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub CreateEntity()

C#

override void CreateEntity()

C++

void CreateEntity()

JScript

function CreateEntity();

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.DeleteEntity Method

API Reference > CADViewLib Namespace > ILayout Interface > Methods >

ILayout.DeleteEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes an entity specified by index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub DeleteEntity( _
ByVal AIndex As Integer _
)

C#

override void DeleteEntity(
intAIndex
)

C++

void DeleteEntity(
intAIndex
)

JScript

function DeleteEntity(
AIndex : int
);

Parameters

AIndex

Index of the entity.

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.EntName Method

API Reference > CADViewLib Namespace > ILayout Interface > Methods >

ILayout.EntName Method

 Return to chapter overview

Show / hide the hidden text

Returns a name of the entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function EntName() As String

C#

override string EntName()

C++

String^ EntName()

JScript

function EntName() : String;

Return Value

A string containing the entity name.

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.FreeEntity Method

API Reference > CADViewLib Namespace > ILayout Interface > Methods >

ILayout.FreeEntity Method

 Return to chapter overview

Show / hide the hidden text

Destroys the object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub FreeEntity()

C#

override void FreeEntity()

C++

void FreeEntity()

JScript

function FreeEntity();

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.GetBoxPoints Method

API Reference > CADViewLib Namespace > ILayout Interface > Methods >

ILayout.GetBoxPoints Method

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetBoxPoints( _
ByVal Full As Boolean _
) As Boolean

C#

override bool GetBoxPoints(
boolFull
)

C++

bool GetBoxPoints(
boolFull
)

JScript

function GetBoxPoints(
Full : boolean
) : boolean;

Parameters

Full

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.GetThickness Method

API Reference > CADViewLib Namespace > ILayout Interface > Methods >

ILayout.GetThickness Method

 Return to chapter overview

Show / hide the hidden text

Returns the line thickness for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetThickness() As Double

C#

override double GetThickness()

C++

double GetThickness()

JScript

function GetThickness() : double;

Return Value

A Double type value indicating the line thickness.

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.IndexOfEntity Method

API Reference > CADViewLib Namespace > ILayout Interface > Methods >

ILayout.IndexOfEntity Method

 Return to chapter overview

Show / hide the hidden text

Returns index of the given entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function IndexOfEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int IndexOfEntity(
EntityAEntity
)

C++

int IndexOfEntity(
Entity^ AEntity
)

JScript

function IndexOfEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity whose index is retrieved.

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.Iterate Method

API Reference > CADViewLib Namespace > ILayout Interface > Methods >

ILayout.Iterate Method

 Return to chapter overview

Show / hide the hidden text

Iterates through the entities in the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub Iterate( _
ByVal AConverter As Converter _
)

C#

override void Iterate(
ConverterAConverter
)

C++

void Iterate(
Converter^ AConverter
)

JScript

function Iterate(
AConverter : Converter
);

Parameters

AConverter

Converter which contains the drawing data.

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.RemoveEntity Method

API Reference > CADViewLib Namespace > ILayout Interface > Methods >

ILayout.RemoveEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes a specified entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function RemoveEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int RemoveEntity(
EntityAEntity
)

C++

int RemoveEntity(
Entity^ AEntity
)

JScript

function RemoveEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity which will be removed.

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.SetLType Method

API Reference > CADViewLib Namespace > ILayout Interface > Methods >

ILayout.SetLType Method

 Return to chapter overview

Show / hide the hidden text

Sets a line type for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLType( _
ByVal Value As Entity _
)

C#

override void SetLType(
EntityValue
)

C++

void SetLType(
Entity^ Value
)

JScript

function SetLType(
Value : Entity
);

Parameters

Value

The line type value.

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.SetLWeight Method

API Reference > CADViewLib Namespace > ILayout Interface > Methods >

ILayout.SetLWeight Method

 Return to chapter overview

Show / hide the hidden text

Sets a line weight for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLWeight( _
ByVal Value As Integer _
)

C#

override void SetLWeight(
intValue
)

C++

void SetLWeight(
intValue
)

JScript

function SetLWeight(
Value : int
);

Parameters

Value

The line weight value.

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


ILayout.get_Entities Method

API Reference > CADViewLib Namespace > ILayout Interface > Methods >

ILayout.get_Entities Method

 Return to chapter overview

Show / hide the hidden text

Returns the child entity at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Entities( _
ByVal Index As Integer _
) As Entity

C#

override Entity get_Entities(
intIndex
)

C++

Entity^ get_Entities(
intIndex
)

JScript

function get_Entities(
Index : int
) : Entity;

Parameters

Index

The index of the entity to retrieve.

collall See Also

Reference

ILayout Interface
ILayout ILayout Members


IPoint2D Interface

API Reference > CADViewLib Namespace >

IPoint2D Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to 2D points.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface IPoint2D

C#

public interface IPoint2D

C++

public interface class IPoint2D

JScript

public interface IPoint2D

collall See Also

Reference

IPoint2D Members


IPoint2D Members

API Reference > CADViewLib Namespace > IPoint2D Interface >

IPoint2D Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to 2D points.

The following tables list the members exposed by the IPoint2D type.

collall Public Properties

 | Name | Description
Public property | X | Gets or sets the X-coordinate.
Public property | Y | Gets or sets the Y-coordinate.

Top

collall See Also

Reference

IPoint2D Interface


IPoint2D Properties

API Reference > CADViewLib Namespace > IPoint2D Interface >

IPoint2D Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | X | Gets or sets the X-coordinate.
Public property | Y | Gets or sets the Y-coordinate.

Top

collall See Also

Reference

IPoint2D Interface


IPoint2D.X Property

API Reference > CADViewLib Namespace > IPoint2D Interface > Properties >

IPoint2D.X Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the X-coordinate.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property X() As Integer

C#

int X {get; set;}

C++

property int X {
int get( );
void set(
int value
);
}

JScript

function get X() : int;
function set X(value : int);

collall See Also

Reference

IPoint2D Interface
IPoint2D IPoint2D Members


IPoint2D.Y Property

API Reference > CADViewLib Namespace > IPoint2D Interface > Properties >

IPoint2D.Y Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the Y-coordinate.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Y() As Integer

C#

int Y {get; set;}

C++

property int Y {
int get( );
void set(
int value
);
}

JScript

function get Y() : int;
function set Y(value : int);

collall See Also

Reference

IPoint2D Interface
IPoint2D IPoint2D Members


IPoint3D Interface

API Reference > CADViewLib Namespace >

IPoint3D Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to 3D points.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface IPoint3D

C#

public interface IPoint3D

C++

public interface class IPoint3D

JScript

public interface IPoint3D

collall See Also

Reference

IPoint3D Members


IPoint3D Members

API Reference > CADViewLib Namespace > IPoint3D Interface >

IPoint3D Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to 3D points.

The following tables list the members exposed by the IPoint3D type.

collall Public Properties

 | Name | Description
Public property | X | Gets or sets the X-coordinate.
Public property | Y | Gets or sets the Y-coordinate.
Public property | Z | Gets or sets the Z-coordinate.

Top

collall Public Methods

 | Name | Description
Public method | get_V | Returns the element at the given index in the 3D vector.
Public method | set_V | Sets the element in the 3D vector to the given value.

Top

collall See Also

Reference

IPoint3D Interface


IPoint3D Properties

API Reference > CADViewLib Namespace > IPoint3D Interface >

IPoint3D Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | X | Gets or sets the X-coordinate.
Public property | Y | Gets or sets the Y-coordinate.
Public property | Z | Gets or sets the Z-coordinate.

Top

collall See Also

Reference

IPoint3D Interface


IPoint3D.X Property

API Reference > CADViewLib Namespace > IPoint3D Interface > Properties >

IPoint3D.X Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the X-coordinate.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property X() As Double

C#

double X {get; set;}

C++

property double X {
double get( );
void set(
double value
);
}

JScript

function get X() : double;
function set X(value : double);

collall See Also

Reference

IPoint3D Interface
IPoint3D IPoint3D Members


IPoint3D.Y Property

API Reference > CADViewLib Namespace > IPoint3D Interface > Properties >

IPoint3D.Y Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the Y-coordinate.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Y() As Double

C#

double Y {get; set;}

C++

property double Y {
double get( );
void set(
double value
);
}

JScript

function get Y() : double;
function set Y(value : double);

collall See Also

Reference

IPoint3D Interface
IPoint3D IPoint3D Members


IPoint3D.Z Property

API Reference > CADViewLib Namespace > IPoint3D Interface > Properties >

IPoint3D.Z Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the Z-coordinate.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Z() As Double

C#

double Z {get; set;}

C++

property double Z {
double get( );
void set(
double value
);
}

JScript

function get Z() : double;
function set Z(value : double);

collall See Also

Reference

IPoint3D Interface
IPoint3D IPoint3D Members


IPoint3D Methods

API Reference > CADViewLib Namespace > IPoint3D Interface >

IPoint3D Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | get_V | Returns the element at the given index in the 3D vector.
Public method | set_V | Sets the element in the 3D vector to the given value.

Top

collall See Also

Reference

IPoint3D Interface


IPoint3D.get_V Method

API Reference > CADViewLib Namespace > IPoint3D Interface > Methods >

IPoint3D.get_V Method

 Return to chapter overview

Show / hide the hidden text

Returns the element at the given index in the 3D vector.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function get_V( _
ByVal Index As Integer _
) As Double

C#

double get_V(
intIndex
)

C++

double get_V(
intIndex
)

JScript

function get_V(
Index : int
) : double;

Parameters

Index

The index of the element to retrieve.

collall See Also

Reference

IPoint3D Interface
IPoint3D IPoint3D Members


IPoint3D.set_V Method

API Reference > CADViewLib Namespace > IPoint3D Interface > Methods >

IPoint3D.set_V Method

 Return to chapter overview

Show / hide the hidden text

Sets the element in the 3D vector to the given value.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub set_V( _
ByVal Index As Integer, _
ByVal Value As Double _
)

C#

void set_V(
intIndex,
doubleValue
)

C++

void set_V(
intIndex,
doubleValue
)

JScript

function set_V(
Index : int,
Value : double
);

Parameters

Index

The index of the element.

Value

The value to set for the element.

collall See Also

Reference

IPoint3D Interface
IPoint3D IPoint3D Members


IPolyline Interface

API Reference > CADViewLib Namespace >

IPolyline Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to POLYLINE and LWPOLYLINE entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface IPolyline
Inherits IEntity

C#

public interface IPolyline : IEntity

C++

public interface class IPolyline : public IEntity^

JScript

public interface IPolyline
implements IEntity

collall See Also

Reference

IPolyline Members


IPolyline Members

API Reference > CADViewLib Namespace > IPolyline Interface >

IPolyline Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to POLYLINE and LWPOLYLINE entities.

The following tables list the members exposed by the IPolyline type.

collall Public Properties

 | Name | Description
Public property | ArrowsCount | Gets a quantity of points that form an arrow.
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Closed | Gets or sets a value indicating whether this polyline is closed.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | DottedPointsCount | Gets a quantity of points that determine the dots and dashes for a polyline with non-solid line type.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Flags | Gets or sets a bit-coded flag indicating the polyline type.
Public property | GlobalWidth | Gets or sets a global width for this polyline.
Public property | IsMeshMClosed | Gets a value indicating whether the polygon mesh is closed in the M direction.
Public property | IsMeshNClosed | Gets a value indicating whether the polygon mesh is closed in the N direction.
Public property | IsPolyFaceMesh | Gets a value indicating whether this polyline is a polyface mesh.
Public property | IsPolyZThickness | Gets a value indicating whether the polyline has thickness measured along the axis Z.
Public property | IsPolygonMesh | Gets a value indicating whether this polyline is a polygon mesh.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | MeshM | Gets or sets a number of vertices for the polygon mesh in the M direction.
Public property | MeshN | Gets or sets a number of vertices for the polygon mesh in the N direction.
Public property | Name | Gets or sets a name of this object.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | PenLine | Gets properties of the pen used for drawing the object.
Public property | PointsCount | Gets a number of the polyline points.
Public property | PolyFaceVertexIndexesCount | Gets a quantity of indices which specify the order of traversing vertices in the polyface mesh.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetArea | Returns the area bounded by a closed polygon.
Public method | GetBoxPoints | For internal use.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Arrows | Returns a point of the arrowhead.
Public method | get_DottedPoints | Returns coordinates of a point in the points array that determines dots and dashes for a non-solid line type.
Public method | get_Entities | Returns the child entity at the given index.
Public method | get_Points | Returns coordinates of a point in the points array.
Public method | get_PolyFaceVertexIndexes | Returns a value which indicates an index of the polyface mesh vertex.
Public method | set_Arrows | Modifies a point of the arrowhead at the given index.

Top

collall See Also

Reference

IPolyline Interface


IPolyline Properties

API Reference > CADViewLib Namespace > IPolyline Interface >

IPolyline Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | ArrowsCount | Gets a quantity of points that form an arrow.
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Closed | Gets or sets a value indicating whether this polyline is closed.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | DottedPointsCount | Gets a quantity of points that determine the dots and dashes for a polyline with non-solid line type.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Flags | Gets or sets a bit-coded flag indicating the polyline type.
Public property | GlobalWidth | Gets or sets a global width for this polyline.
Public property | IsMeshMClosed | Gets a value indicating whether the polygon mesh is closed in the M direction.
Public property | IsMeshNClosed | Gets a value indicating whether the polygon mesh is closed in the N direction.
Public property | IsPolyFaceMesh | Gets a value indicating whether this polyline is a polyface mesh.
Public property | IsPolyZThickness | Gets a value indicating whether the polyline has thickness measured along the axis Z.
Public property | IsPolygonMesh | Gets a value indicating whether this polyline is a polygon mesh.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | MeshM | Gets or sets a number of vertices for the polygon mesh in the M direction.
Public property | MeshN | Gets or sets a number of vertices for the polygon mesh in the N direction.
Public property | Name | Gets or sets a name of this object.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | PenLine | Gets properties of the pen used for drawing the object.
Public property | PointsCount | Gets a number of the polyline points.
Public property | PolyFaceVertexIndexesCount | Gets a quantity of indices which specify the order of traversing vertices in the polyface mesh.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall See Also

Reference

IPolyline Interface


IPolyline.ArrowsCount Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.ArrowsCount Property

 Return to chapter overview

Show / hide the hidden text

Gets a quantity of points that form an arrow.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property ArrowsCount() As Integer

C#

int ArrowsCount {get;}

C++

property int ArrowsCount {
int get( );
}

JScript

function get ArrowsCount() : int;

Property Value

An Integer type value indicating a quantity of points that form an arrow.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.Box Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.Box Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the bounding parallelepiped for the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Box() As Rect3D

C#

Rect3D Box {get;}

C++

property Rect3D^ Box {
Rect3D^ get( );
}

JScript

function get Box() : Rect3D;

Property Value

The parallelepiped which encloses the object.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.CADHandle Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.CADHandle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the object handle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CADHandle() As UInt64

C#

UInt64 CADHandle {get; set;}

C++

property UInt64 CADHandle {
UInt64 get( );
void set(
UInt64 value
);
}

JScript

function get CADHandle() : UInt64;
function set CADHandle(value : UInt64);

Property Value

Number that uniquely identifies the object in a CAD drawing.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.Closed Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.Closed Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this polyline is closed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Closed() As Boolean

C#

bool Closed {get; set;}

C++

property bool Closed {
bool get( );
void set(
bool value
);
}

JScript

function get Closed() : boolean;
function set Closed(value : boolean);

Property Value

true if the polyline is closed; otherwise, false

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.Color Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.Color Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a color of the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Color() As UInt32

C#

UInt32 Color {get; set;}

C++

property UInt32 Color {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get Color() : UInt32;
function set Color(value : UInt32);

Property Value

An insigned integer value which defines the object's color.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.Converter Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.Converter Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a Converter instance associated with the CAD image to which this object belongs.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Converter() As Converter

C#

Converter Converter {get;}

C++

property Converter^ Converter {
Converter^ get( );
}

JScript

function get Converter() : Converter;

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.Count Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.Count Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of objects contained within the given object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Count() As Integer

C#

int Count {get;}

C++

property int Count {
int get( );
}

JScript

function get Count() : int;

Property Value

An Integer value indicating a number of objects contained within the given object.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.DottedPointsCount Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.DottedPointsCount Property

 Return to chapter overview

Show / hide the hidden text

Gets a quantity of points that determine the dots and dashes for a polyline with non-solid line type.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property DottedPointsCount() As Integer

C#

int DottedPointsCount {get;}

C++

property int DottedPointsCount {
int get( );
}

JScript

function get DottedPointsCount() : int;

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.EntID Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.EntID Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the entity type ID for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property EntID() As TEntityID

C#

TEntityID EntID {get; set;}

C++

property TEntityID EntID {
TEntityID get( );
void set(
TEntityID value
);
}

JScript

function get EntID() : TEntityID;
function set EntID(value : TEntityID);

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.Extrusion Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.Extrusion Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the extrusion direction vector for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Extrusion() As Point3D

C#

Point3D Extrusion {get; set;}

C++

property Point3D^ Extrusion {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Extrusion() : Point3D;
function set Extrusion(value : Point3D);

Property Value

The 3D point which defines the extrusion direction vector.

collall Remarks

The extrusion direction is the normal vector of the plane which contains the entity and it is applied to the entity base point. The default extrusion direction value is (0, 0, 1).

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.Flags Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.Flags Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a bit-coded flag indicating the polyline type.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Flags() As Integer

C#

int Flags {get; set;}

C++

property int Flags {
int get( );
void set(
int value
);
}

JScript

function get Flags() : int;
function set Flags(value : int);

Property Value

0 = Default value
1 = This is a closed polyline (or a polygon mesh closed in the M direction)
2 = Curve-fit vertices have been added
4 = Spline-fit vertices have been added
8 = This is a 3D polyline
16 = This is a 3D polygon mesh
32 = The polygon mesh is closed in the N direction
64 = The polyline is a polyface mesh
128 = The linetype pattern is generated continuously around the vertices of this polyline

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.GlobalWidth Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.GlobalWidth Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a global width for this polyline.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property GlobalWidth() As Single

C#

float GlobalWidth {get; set;}

C++

property float GlobalWidth {
float get( );
void set(
float value
);
}

JScript

function get GlobalWidth() : float;
function set GlobalWidth(value : float);

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.IsMeshMClosed Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.IsMeshMClosed Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the polygon mesh is closed in the M direction.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsMeshMClosed() As Boolean

C#

bool IsMeshMClosed {get;}

C++

property bool IsMeshMClosed {
bool get( );
}

JScript

function get IsMeshMClosed() : boolean;

Property Value

true if the polygon mesh is closed in the M direction.; otherwise, false.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.IsMeshNClosed Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.IsMeshNClosed Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the polygon mesh is closed in the N direction.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsMeshNClosed() As Boolean

C#

bool IsMeshNClosed {get;}

C++

property bool IsMeshNClosed {
bool get( );
}

JScript

function get IsMeshNClosed() : boolean;

Property Value

true if the polygon mesh is closed in the N direction.; otherwise, false.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.IsPolyFaceMesh Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.IsPolyFaceMesh Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether this polyline is a polyface mesh.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsPolyFaceMesh() As Boolean

C#

bool IsPolyFaceMesh {get;}

C++

property bool IsPolyFaceMesh {
bool get( );
}

JScript

function get IsPolyFaceMesh() : boolean;

Property Value

true if the polyline is a polyface mesh; otherwise, false.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.IsPolyZThickness Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.IsPolyZThickness Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the polyline has thickness measured along the axis Z.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsPolyZThickness() As Boolean

C#

bool IsPolyZThickness {get;}

C++

property bool IsPolyZThickness {
bool get( );
}

JScript

function get IsPolyZThickness() : boolean;

Property Value

true if the polyline has thickness measured along the axis Z; otherwise, false.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.IsPolygonMesh Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.IsPolygonMesh Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether this polyline is a polygon mesh.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsPolygonMesh() As Boolean

C#

bool IsPolygonMesh {get;}

C++

property bool IsPolygonMesh {
bool get( );
}

JScript

function get IsPolygonMesh() : boolean;

Property Value

true if the polyline is a polygon mesh; otherwise, false.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.Layer Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.Layer Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a layer containing this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Layer() As Layer

C#

Layer Layer {get; set;}

C++

property Layer^ Layer {
Layer^ get( );
void set(
Layer^ value
);
}

JScript

function get Layer() : Layer;
function set Layer(value : Layer);

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.LineTypeScale Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.LineTypeScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a quantity of line type elements per unit of its length.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineTypeScale() As Single

C#

float LineTypeScale {get; set;}

C++

property float LineTypeScale {
float get( );
void set(
float value
);
}

JScript

function get LineTypeScale() : float;
function set LineTypeScale(value : float);

Property Value

The quantity of linetype elements per unit of its length.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.MeshM Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.MeshM Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a number of vertices for the polygon mesh in the M direction.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property MeshM() As Integer

C#

int MeshM {get; set;}

C++

property int MeshM {
int get( );
void set(
int value
);
}

JScript

function get MeshM() : int;
function set MeshM(value : int);

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.MeshN Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.MeshN Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a number of vertices for the polygon mesh in the N direction.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property MeshN() As Integer

C#

int MeshN {get; set;}

C++

property int MeshN {
int get( );
void set(
int value
);
}

JScript

function get MeshN() : int;
function set MeshN(value : int);

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.Name Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.Name Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Name() As String

C#

string Name {get; set;}

C++

property String^ Name {
String^ get( );
void set(
String^ value
);
}

JScript

function get Name() : String;
function set Name(value : String);

Property Value

String containing the object name.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.PaperSpace Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.PaperSpace Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is located in Paper space.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PaperSpace() As Integer

C#

int PaperSpace {get; set;}

C++

property int PaperSpace {
int get( );
void set(
int value
);
}

JScript

function get PaperSpace() : int;
function set PaperSpace(value : int);

Property Value

0 - the object is located in Model space, 1 - in Paper space.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.PenLine Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.PenLine Property

 Return to chapter overview

Show / hide the hidden text

Gets properties of the pen used for drawing the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property PenLine() As CADLine

C#

CADLine PenLine {get;}

C++

property CADLine^ PenLine {
CADLine^ get( );
}

JScript

function get PenLine() : CADLine;

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.PointsCount Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.PointsCount Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of the polyline points.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property PointsCount() As Integer

C#

int PointsCount {get;}

C++

property int PointsCount {
int get( );
}

JScript

function get PointsCount() : int;

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.PolyFaceVertexIndexesCount Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.PolyFaceVertexIndexesCount Property

 Return to chapter overview

Show / hide the hidden text

Gets a quantity of indices which specify the order of traversing vertices in the polyface mesh.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property PolyFaceVertexIndexesCount() As Integer

C#

int PolyFaceVertexIndexesCount {get;}

C++

property int PolyFaceVertexIndexesCount {
int get( );
}

JScript

function get PolyFaceVertexIndexesCount() : int;

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.SrcEnd Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.SrcEnd Property

 Return to chapter overview

Show / hide the hidden text

Indicates the end of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcEnd() As String

C#

string SrcEnd {get; set;}

C++

property String^ SrcEnd {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcEnd() : String;
function set SrcEnd(value : String);

Property Value

A String value indicating the end of the record which represents this object in a drawing file.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.SrcStart Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.SrcStart Property

 Return to chapter overview

Show / hide the hidden text

Indicates the beginning of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcStart() As String

C#

string SrcStart {get; set;}

C++

property String^ SrcStart {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcStart() : String;
function set SrcStart(value : String);

Property Value

A String value indicating the beginning of the record which represents this object in a drawing file.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.Visibility Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.Visibility Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visibility() As Boolean

C#

bool Visibility {get; set;}

C++

property bool Visibility {
bool get( );
void set(
bool value
);
}

JScript

function get Visibility() : boolean;
function set Visibility(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.Visible Property

API Reference > CADViewLib Namespace > IPolyline Interface > Properties >

IPolyline.Visible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visible() As Boolean

C#

bool Visible {get; set;}

C++

property bool Visible {
bool get( );
void set(
bool value
);
}

JScript

function get Visible() : boolean;
function set Visible(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline Methods

API Reference > CADViewLib Namespace > IPolyline Interface >

IPolyline Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetArea | Returns the area bounded by a closed polygon.
Public method | GetBoxPoints | For internal use.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Arrows | Returns a point of the arrowhead.
Public method | get_DottedPoints | Returns coordinates of a point in the points array that determines dots and dashes for a non-solid line type.
Public method | get_Entities | Returns the child entity at the given index.
Public method | get_Points | Returns coordinates of a point in the points array.
Public method | get_PolyFaceVertexIndexes | Returns a value which indicates an index of the polyface mesh vertex.
Public method | set_Arrows | Modifies a point of the arrowhead at the given index.

Top

collall See Also

Reference

IPolyline Interface


IPolyline.AddEntity Method

API Reference > CADViewLib Namespace > IPolyline Interface > Methods >

IPolyline.AddEntity Method

 Return to chapter overview

Show / hide the hidden text

Adds a new child entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AddEntity( _
ByVal AEntity As Entity _
)

C#

override void AddEntity(
EntityAEntity
)

C++

void AddEntity(
Entity^ AEntity
)

JScript

function AddEntity(
AEntity : Entity
);

Parameters

AEntity

Added entity.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.AssignEntity Method

API Reference > CADViewLib Namespace > IPolyline Interface > Methods >

IPolyline.AssignEntity Method

 Return to chapter overview

Show / hide the hidden text

Assigns the properties of the specified entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AssignEntity( _
ByVal Source As Entity _
)

C#

override void AssignEntity(
EntitySource
)

C++

void AssignEntity(
Entity^ Source
)

JScript

function AssignEntity(
Source : Entity
);

Parameters

Source

Entity which has the same type as the current object.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.CreateEntity Method

API Reference > CADViewLib Namespace > IPolyline Interface > Methods >

IPolyline.CreateEntity Method

 Return to chapter overview

Show / hide the hidden text

Initializes a new object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub CreateEntity()

C#

override void CreateEntity()

C++

void CreateEntity()

JScript

function CreateEntity();

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.DeleteEntity Method

API Reference > CADViewLib Namespace > IPolyline Interface > Methods >

IPolyline.DeleteEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes an entity specified by index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub DeleteEntity( _
ByVal AIndex As Integer _
)

C#

override void DeleteEntity(
intAIndex
)

C++

void DeleteEntity(
intAIndex
)

JScript

function DeleteEntity(
AIndex : int
);

Parameters

AIndex

Index of the entity.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.EntName Method

API Reference > CADViewLib Namespace > IPolyline Interface > Methods >

IPolyline.EntName Method

 Return to chapter overview

Show / hide the hidden text

Returns a name of the entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function EntName() As String

C#

override string EntName()

C++

String^ EntName()

JScript

function EntName() : String;

Return Value

A string containing the entity name.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.FreeEntity Method

API Reference > CADViewLib Namespace > IPolyline Interface > Methods >

IPolyline.FreeEntity Method

 Return to chapter overview

Show / hide the hidden text

Destroys the object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub FreeEntity()

C#

override void FreeEntity()

C++

void FreeEntity()

JScript

function FreeEntity();

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.GetArea Method

API Reference > CADViewLib Namespace > IPolyline Interface > Methods >

IPolyline.GetArea Method

 Return to chapter overview

Show / hide the hidden text

Returns the area bounded by a closed polygon.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function GetArea() As Double

C#

double GetArea()

C++

double GetArea()

JScript

function GetArea() : double;

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.GetBoxPoints Method

API Reference > CADViewLib Namespace > IPolyline Interface > Methods >

IPolyline.GetBoxPoints Method

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetBoxPoints( _
ByVal Full As Boolean _
) As Boolean

C#

override bool GetBoxPoints(
boolFull
)

C++

bool GetBoxPoints(
boolFull
)

JScript

function GetBoxPoints(
Full : boolean
) : boolean;

Parameters

Full

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.GetThickness Method

API Reference > CADViewLib Namespace > IPolyline Interface > Methods >

IPolyline.GetThickness Method

 Return to chapter overview

Show / hide the hidden text

Returns the line thickness for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetThickness() As Double

C#

override double GetThickness()

C++

double GetThickness()

JScript

function GetThickness() : double;

Return Value

A Double type value indicating the line thickness.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.IndexOfEntity Method

API Reference > CADViewLib Namespace > IPolyline Interface > Methods >

IPolyline.IndexOfEntity Method

 Return to chapter overview

Show / hide the hidden text

Returns index of the given entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function IndexOfEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int IndexOfEntity(
EntityAEntity
)

C++

int IndexOfEntity(
Entity^ AEntity
)

JScript

function IndexOfEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity whose index is retrieved.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.Iterate Method

API Reference > CADViewLib Namespace > IPolyline Interface > Methods >

IPolyline.Iterate Method

 Return to chapter overview

Show / hide the hidden text

Iterates through the entities in the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub Iterate( _
ByVal AConverter As Converter _
)

C#

override void Iterate(
ConverterAConverter
)

C++

void Iterate(
Converter^ AConverter
)

JScript

function Iterate(
AConverter : Converter
);

Parameters

AConverter

Converter which contains the drawing data.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.RemoveEntity Method

API Reference > CADViewLib Namespace > IPolyline Interface > Methods >

IPolyline.RemoveEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes a specified entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function RemoveEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int RemoveEntity(
EntityAEntity
)

C++

int RemoveEntity(
Entity^ AEntity
)

JScript

function RemoveEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity which will be removed.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.SetLType Method

API Reference > CADViewLib Namespace > IPolyline Interface > Methods >

IPolyline.SetLType Method

 Return to chapter overview

Show / hide the hidden text

Sets a line type for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLType( _
ByVal Value As Entity _
)

C#

override void SetLType(
EntityValue
)

C++

void SetLType(
Entity^ Value
)

JScript

function SetLType(
Value : Entity
);

Parameters

Value

The line type value.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.SetLWeight Method

API Reference > CADViewLib Namespace > IPolyline Interface > Methods >

IPolyline.SetLWeight Method

 Return to chapter overview

Show / hide the hidden text

Sets a line weight for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLWeight( _
ByVal Value As Integer _
)

C#

override void SetLWeight(
intValue
)

C++

void SetLWeight(
intValue
)

JScript

function SetLWeight(
Value : int
);

Parameters

Value

The line weight value.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.get_Arrows Method

API Reference > CADViewLib Namespace > IPolyline Interface > Methods >

IPolyline.get_Arrows Method

 Return to chapter overview

Show / hide the hidden text

Returns a point of the arrowhead.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function get_Arrows( _
ByVal Index As Integer _
) As Point3D

C#

Point3D get_Arrows(
intIndex
)

C++

Point3D^ get_Arrows(
intIndex
)

JScript

function get_Arrows(
Index : int
) : Point3D;

Parameters

Index

Index of the point to retrieve.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.get_DottedPoints Method

API Reference > CADViewLib Namespace > IPolyline Interface > Methods >

IPolyline.get_DottedPoints Method

 Return to chapter overview

Show / hide the hidden text

Returns coordinates of a point in the points array that determines dots and dashes for a non-solid line type.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function get_DottedPoints( _
ByVal Index As Integer _
) As Point3D

C#

Point3D get_DottedPoints(
intIndex
)

C++

Point3D^ get_DottedPoints(
intIndex
)

JScript

function get_DottedPoints(
Index : int
) : Point3D;

Parameters

Index

Index of the point to retrieve.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.get_Entities Method

API Reference > CADViewLib Namespace > IPolyline Interface > Methods >

IPolyline.get_Entities Method

 Return to chapter overview

Show / hide the hidden text

Returns the child entity at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Entities( _
ByVal Index As Integer _
) As Entity

C#

override Entity get_Entities(
intIndex
)

C++

Entity^ get_Entities(
intIndex
)

JScript

function get_Entities(
Index : int
) : Entity;

Parameters

Index

The index of the entity to retrieve.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.get_Points Method

API Reference > CADViewLib Namespace > IPolyline Interface > Methods >

IPolyline.get_Points Method

 Return to chapter overview

Show / hide the hidden text

Returns coordinates of a point in the points array.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function get_Points( _
ByVal Index As Integer _
) As Point3D

C#

Point3D get_Points(
intIndex
)

C++

Point3D^ get_Points(
intIndex
)

JScript

function get_Points(
Index : int
) : Point3D;

Parameters

Index

Index of the point to retrieve.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.get_PolyFaceVertexIndexes Method

API Reference > CADViewLib Namespace > IPolyline Interface > Methods >

IPolyline.get_PolyFaceVertexIndexes Method

 Return to chapter overview

Show / hide the hidden text

Returns a value which indicates an index of the polyface mesh vertex.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function get_PolyFaceVertexIndexes( _
ByVal Index As Integer _
) As Object

C#

object get_PolyFaceVertexIndexes(
intIndex
)

C++

object^ get_PolyFaceVertexIndexes(
intIndex
)

JScript

function get_PolyFaceVertexIndexes(
Index : int
) : object;

Parameters

Index

The index number of the element.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IPolyline.set_Arrows Method

API Reference > CADViewLib Namespace > IPolyline Interface > Methods >

IPolyline.set_Arrows Method

 Return to chapter overview

Show / hide the hidden text

Modifies a point of the arrowhead at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub set_Arrows( _
ByVal Index As Integer, _
ByVal Value As Point3D _
)

C#

void set_Arrows(
intIndex,
Point3DValue
)

C++

void set_Arrows(
intIndex,
Point3D^ Value
)

JScript

function set_Arrows(
Index : int,
Value : Point3D
);

Parameters

Index

The index of the point.

Value

Value to be set for the point.

collall See Also

Reference

IPolyline Interface
IPolyline IPolyline Members


IRect2D Interface

API Reference > CADViewLib Namespace >

IRect2D Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to a bounding rectangle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface IRect2D

C#

public interface IRect2D

C++

public interface class IRect2D

JScript

public interface IRect2D

collall See Also

Reference

IRect2D Members


IRect2D Members

API Reference > CADViewLib Namespace > IRect2D Interface >

IRect2D Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to a bounding rectangle.

The following tables list the members exposed by the IRect2D type.

collall Public Properties

 | Name | Description
Public property | Bottom | Gets or sets the Y-coordinate of the bottom-right corner.
Public property | BottomRight | Gets or sets a location of the bottom-right corner.
Public property | Left | Gets or sets the X-coordinate of the top-left corner.
Public property | Right | Gets or sets the X-coordinate of the bottom-right corner.
Public property | Top | Gets or sets the Y-coordinate of the top-left corner.
Public property | TopLeft | Gets or sets a location of the top-left corner.

Top

collall See Also

Reference

IRect2D Interface


IRect2D Properties

API Reference > CADViewLib Namespace > IRect2D Interface >

IRect2D Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Bottom | Gets or sets the Y-coordinate of the bottom-right corner.
Public property | BottomRight | Gets or sets a location of the bottom-right corner.
Public property | Left | Gets or sets the X-coordinate of the top-left corner.
Public property | Right | Gets or sets the X-coordinate of the bottom-right corner.
Public property | Top | Gets or sets the Y-coordinate of the top-left corner.
Public property | TopLeft | Gets or sets a location of the top-left corner.

Top

collall See Also

Reference

IRect2D Interface


IRect2D.Bottom Property

API Reference > CADViewLib Namespace > IRect2D Interface > Properties >

IRect2D.Bottom Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the Y-coordinate of the bottom-right corner.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Bottom() As Integer

C#

int Bottom {get; set;}

C++

property int Bottom {
int get( );
void set(
int value
);
}

JScript

function get Bottom() : int;
function set Bottom(value : int);

collall See Also

Reference

IRect2D Interface
IRect2D IRect2D Members


IRect2D.BottomRight Property

API Reference > CADViewLib Namespace > IRect2D Interface > Properties >

IRect2D.BottomRight Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a location of the bottom-right corner.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property BottomRight() As Point2D

C#

Point2D BottomRight {get; set;}

C++

property Point2D^ BottomRight {
Point2D^ get( );
void set(
Point2D^ value
);
}

JScript

function get BottomRight() : Point2D;
function set BottomRight(value : Point2D);

collall See Also

Reference

IRect2D Interface
IRect2D IRect2D Members


IRect2D.Left Property

API Reference > CADViewLib Namespace > IRect2D Interface > Properties >

IRect2D.Left Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the X-coordinate of the top-left corner.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Left() As Integer

C#

int Left {get; set;}

C++

property int Left {
int get( );
void set(
int value
);
}

JScript

function get Left() : int;
function set Left(value : int);

collall See Also

Reference

IRect2D Interface
IRect2D IRect2D Members


IRect2D.Right Property

API Reference > CADViewLib Namespace > IRect2D Interface > Properties >

IRect2D.Right Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the X-coordinate of the bottom-right corner.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Right() As Integer

C#

int Right {get; set;}

C++

property int Right {
int get( );
void set(
int value
);
}

JScript

function get Right() : int;
function set Right(value : int);

collall See Also

Reference

IRect2D Interface
IRect2D IRect2D Members


IRect2D.Top Property

API Reference > CADViewLib Namespace > IRect2D Interface > Properties >

IRect2D.Top Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the Y-coordinate of the top-left corner.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Top() As Integer

C#

int Top {get; set;}

C++

property int Top {
int get( );
void set(
int value
);
}

JScript

function get Top() : int;
function set Top(value : int);

collall See Also

Reference

IRect2D Interface
IRect2D IRect2D Members


IRect2D.TopLeft Property

API Reference > CADViewLib Namespace > IRect2D Interface > Properties >

IRect2D.TopLeft Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a location of the top-left corner.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property TopLeft() As Point2D

C#

Point2D TopLeft {get; set;}

C++

property Point2D^ TopLeft {
Point2D^ get( );
void set(
Point2D^ value
);
}

JScript

function get TopLeft() : Point2D;
function set TopLeft(value : Point2D);

collall See Also

Reference

IRect2D Interface
IRect2D IRect2D Members


IRect3D Interface

API Reference > CADViewLib Namespace >

IRect3D Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to a bounding parallelepiped (box).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface IRect3D

C#

public interface IRect3D

C++

public interface class IRect3D

JScript

public interface IRect3D

collall See Also

Reference

IRect3D Members


IRect3D Members

API Reference > CADViewLib Namespace > IRect3D Interface >

IRect3D Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to a bounding parallelepiped (box).

The following tables list the members exposed by the IRect3D type.

collall Public Properties

 | Name | Description
Public property | Bottom | Gets or sets the Y-coordinate of the bottom-right corner.
Public property | BottomRight | Gets or sets a location of the bottom-right corner.
Public property | Left | Gets or sets the X-coordinate of the top-left corner.
Public property | Right | Gets or sets the X-coordinate of the bottom-right corner.
Public property | Top | Gets or sets the Y-coordinate of the top-left corner.
Public property | TopLeft | Gets or sets a location of the top-left corner.
Public property | Z1 | Gets or sets the Z-coordinate of the top-left corner.
Public property | Z2 | Gets or sets the X-coordinate of the bottom-right corner.

Top

collall See Also

Reference

IRect3D Interface


IRect3D Properties

API Reference > CADViewLib Namespace > IRect3D Interface >

IRect3D Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Bottom | Gets or sets the Y-coordinate of the bottom-right corner.
Public property | BottomRight | Gets or sets a location of the bottom-right corner.
Public property | Left | Gets or sets the X-coordinate of the top-left corner.
Public property | Right | Gets or sets the X-coordinate of the bottom-right corner.
Public property | Top | Gets or sets the Y-coordinate of the top-left corner.
Public property | TopLeft | Gets or sets a location of the top-left corner.
Public property | Z1 | Gets or sets the Z-coordinate of the top-left corner.
Public property | Z2 | Gets or sets the X-coordinate of the bottom-right corner.

Top

collall See Also

Reference

IRect3D Interface


IRect3D.Bottom Property

API Reference > CADViewLib Namespace > IRect3D Interface > Properties >

IRect3D.Bottom Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the Y-coordinate of the bottom-right corner.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Bottom() As Double

C#

double Bottom {get; set;}

C++

property double Bottom {
double get( );
void set(
double value
);
}

JScript

function get Bottom() : double;
function set Bottom(value : double);

collall See Also

Reference

IRect3D Interface
IRect3D IRect3D Members


IRect3D.BottomRight Property

API Reference > CADViewLib Namespace > IRect3D Interface > Properties >

IRect3D.BottomRight Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a location of the bottom-right corner.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property BottomRight() As Point3D

C#

Point3D BottomRight {get; set;}

C++

property Point3D^ BottomRight {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get BottomRight() : Point3D;
function set BottomRight(value : Point3D);

collall See Also

Reference

IRect3D Interface
IRect3D IRect3D Members


IRect3D.Left Property

API Reference > CADViewLib Namespace > IRect3D Interface > Properties >

IRect3D.Left Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the X-coordinate of the top-left corner.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Left() As Double

C#

double Left {get; set;}

C++

property double Left {
double get( );
void set(
double value
);
}

JScript

function get Left() : double;
function set Left(value : double);

collall See Also

Reference

IRect3D Interface
IRect3D IRect3D Members


IRect3D.Right Property

API Reference > CADViewLib Namespace > IRect3D Interface > Properties >

IRect3D.Right Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the X-coordinate of the bottom-right corner.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Right() As Double

C#

double Right {get; set;}

C++

property double Right {
double get( );
void set(
double value
);
}

JScript

function get Right() : double;
function set Right(value : double);

collall See Also

Reference

IRect3D Interface
IRect3D IRect3D Members


IRect3D.Top Property

API Reference > CADViewLib Namespace > IRect3D Interface > Properties >

IRect3D.Top Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the Y-coordinate of the top-left corner.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Top() As Double

C#

double Top {get; set;}

C++

property double Top {
double get( );
void set(
double value
);
}

JScript

function get Top() : double;
function set Top(value : double);

collall See Also

Reference

IRect3D Interface
IRect3D IRect3D Members


IRect3D.TopLeft Property

API Reference > CADViewLib Namespace > IRect3D Interface > Properties >

IRect3D.TopLeft Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a location of the top-left corner.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property TopLeft() As Point3D

C#

Point3D TopLeft {get; set;}

C++

property Point3D^ TopLeft {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get TopLeft() : Point3D;
function set TopLeft(value : Point3D);

collall See Also

Reference

IRect3D Interface
IRect3D IRect3D Members


IRect3D.Z1 Property

API Reference > CADViewLib Namespace > IRect3D Interface > Properties >

IRect3D.Z1 Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the Z-coordinate of the top-left corner.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Z1() As Double

C#

double Z1 {get; set;}

C++

property double Z1 {
double get( );
void set(
double value
);
}

JScript

function get Z1() : double;
function set Z1(value : double);

collall See Also

Reference

IRect3D Interface
IRect3D IRect3D Members


IRect3D.Z2 Property

API Reference > CADViewLib Namespace > IRect3D Interface > Properties >

IRect3D.Z2 Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the X-coordinate of the bottom-right corner.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Z2() As Double

C#

double Z2 {get; set;}

C++

property double Z2 {
double get( );
void set(
double value
);
}

JScript

function get Z2() : double;
function set Z2(value : double);

collall See Also

Reference

IRect3D Interface
IRect3D IRect3D Members


ISVGImage Interface

API Reference > CADViewLib Namespace >

ISVGImage Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to an SVG drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface ISVGImage
Inherits IDXFImage

C#

public interface ISVGImage : IDXFImage

C++

public interface class ISVGImage : public IDXFImage^

JScript

public interface ISVGImage
implements IDXFImage

collall See Also

Reference

ISVGImage Members


ISVGImage Members

API Reference > CADViewLib Namespace > ISVGImage Interface >

ISVGImage Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to an SVG drawing.

The following tables list the members exposed by the ISVGImage type.

collall Public Properties

 | Name | Description
Public property | BackGroundColor | Gets or sets a background color for the drawing.
Public property | BorderSize | Gets or sets a border size for the drawing.
Public property | BorderType | Gets or sets a way the drawing's border size is defined (global or ratio).
Public property | CADClassID | Gets the CAD format identifier for the drawing.
Public property | CBFormat | Gets or sets the clipboard format.
Public property | CanStopLoading | Gets a value indicating whether the loading of the drawing data can be terminated.
Public property | Charset | Gets or sets a character set for the text entities.
Public property | ColorToLineWeight | Gets or sets a string which contains the color-lineweight pairs.
Public property | Converter | Gets or sets a Converter associated with this image object.
Public property | Count | Gets a number of entities in the drawing.
Public property | CurrentLayout | Gets or sets the current layout for the drawing.
Public property | DefaultColor | Gets or sets the default color for the drawing.
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions in the drawing are visible.
Public property | DrawMode | Gets or sets an appearance of colors in the drawing.
Public property | DrawingBox | Gets or sets the drawing bounding box.
Public property | Empty | Gets a value indicating whether the drawing is empty.
Public property | Extents | Gets or sets the drawing's extents.
Public property | Height | Gets or sets a height of the drawing.
Public property | Is3D | Gets a value indicating whether the drawing is three-dimensional.
Public property | IsDraw3DAxes | Gets a value indicating whether 3D axes are visible on the drawing.
Public property | IsDrawingRotated | Gets a value indicating whether the drawing is rotated.
Public property | IsLoading | Gets a value indicating whether the process of loading the drawing data is active.
Public property | IsPlotting | Gets or sets a value indicating whether to plot the image or not.
Public property | IsProcessMessages | Gets or sets a value indicating whether the messages processing is allowed.
Public property | IsShowBackground | Gets or sets a value indicating whether the backround is displayed.
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines is determined by the drawing data.
Public property | IsWithoutBorder | Gets or sets a value indicating whether to display the drawing without borders.
Public property | LayoutsCount | Gets the number of layouts in the drawing.
Public property | LineScaled | Gets or sets a value indicating whether the line weight is diplayed.
Public property | LineWeightScale | Gets or sets a scale for line weights.
Public property | Millimetres | Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file.
Public property | Modified | Gets or sets a value indicating whether the drawing is modified.
Public property | NullWidth | Gets or sets a thickness for lines which have the zero lineweight.
Public property | OwnSource | For internal use.
Public property | PureExtents | Gets the drawing's extents excluding the borders.
Public property | ResizeDisproportionateDrawing | Gets or sets a value indicating whether to resize a drawing with disproportionate sizes.
Public property | Scale | Gets or sets a 3D point which defines the scale factor.
Public property | ShowImages | Gets or sets a value indicating whether the raster images are displayed.
Public property | Stretch | Gets or sets a value indicating whether the displayed image has to be stretched to fit exactly with the drawing rectangle.
Public property | TextVisible | Gets or sets a value indicating whether texts in the drawing are visible.
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles are drawn by using GDI+ methods without linearization.
Public property | ViewRectangle | For internal use.
Public property | Width | Gets or sets a width of the drawing.

Top

collall Public Methods

 | Name | Description
Public method | AbsHeight | Returns an absolute height of the CAD drawing.
Public method | AbsWidth | Returns an absolute width of the CAD drawing.
Public method | AddScaledDXF | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.
Public method | AddScaledDXFEx | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.
Public method | AssignImage | Makes a copy of a specified CAD image object and assigns it to this image.
Public method | CreateImage | Initializes a new CAD image instance.
Public method | Draw | Draws the CAD image in a specified device context (DC).
Public method | DrawRect | Draws a specified region of this CAD image in a device context (DC).
Public method | ExportToMetafile | Exports this CAD image to Windows metafile.
Public method | FreeImage | Destroys this CAD image object and frees the memory used within the object.
Public method | GetCADCoords | Returns CAD coordinates for a specified point.
Public method | GetEntityColor | Returns the color value for a specified entity.
Public method | GetExtents | Recalculates extents of the CAD image.
Public method | GetPoint | Gets the on-screen coordinates for a specified CAD point.
Public method | GetRealImagePoint | Returns CAD coordinates of a specified point considering the drawing's rotation and viewport parameters.
Public method | HeadVarAsFloat | Returns a value of the DXF header variable as a floating point number.
Public method | HeadVarAsInteger | Returns a value of the DXF header variable as an integer.
Public method | HeadVarAsstring | Returns a value of the DXF header variable as a string.
Public method | LoadFromClipboardFormat | Loads data from the clipboard.
Public method | LoadFromFile | Loads a CAD drawing from file.
Public method | LoadFromIStream | Loads a CAD drawing from stream.
Public method | LoadFromStream | Loads a CAD drawing from stream.
Public method | RefreshCurrentLayout | Refreshes the current layout.
Public method | ResetDrawingBox | Switches off the drawing box.
Public method | RotDefault | Rotates the drawing to the default view.
Public method | RotToView | Rotates the drawing to a specified view.
Public method | Rotate | Rotates the drawing.
Public method | SaveToClipboardFormat | Copies the drawing to the clipboard in a specified format.
Public method | SaveToFile | Saves the drawing to a specified file.
Public method | SaveToIStream | Writes the drawing data to a specified stream.
Public method | SaveToStream | Writes the drawing data to a specified stream.
Public method | SetClippingRect | Sets a clipping rectangle for the drawing.
Public method | SetExtentsParameters | Changes the drawing extents.
Public method | StopLoading | Terminates loading of the drawing data.
Public method | get_Blocks | Retrieves a BLOCK object by its index.
Public method | get_Entities | Retrieves an entity by its index.
Public method | get_Items |
Public method | get_Layouts | Retrieves a layout by its index.

Top

collall See Also

Reference

ISVGImage Interface


ISVGImage Properties

API Reference > CADViewLib Namespace > ISVGImage Interface >

ISVGImage Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | BackGroundColor | Gets or sets a background color for the drawing.
Public property | BorderSize | Gets or sets a border size for the drawing.
Public property | BorderType | Gets or sets a way the drawing's border size is defined (global or ratio).
Public property | CADClassID | Gets the CAD format identifier for the drawing.
Public property | CBFormat | Gets or sets the clipboard format.
Public property | CanStopLoading | Gets a value indicating whether the loading of the drawing data can be terminated.
Public property | Charset | Gets or sets a character set for the text entities.
Public property | ColorToLineWeight | Gets or sets a string which contains the color-lineweight pairs.
Public property | Converter | Gets or sets a Converter associated with this image object.
Public property | Count | Gets a number of entities in the drawing.
Public property | CurrentLayout | Gets or sets the current layout for the drawing.
Public property | DefaultColor | Gets or sets the default color for the drawing.
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions in the drawing are visible.
Public property | DrawMode | Gets or sets an appearance of colors in the drawing.
Public property | DrawingBox | Gets or sets the drawing bounding box.
Public property | Empty | Gets a value indicating whether the drawing is empty.
Public property | Extents | Gets or sets the drawing's extents.
Public property | Height | Gets or sets a height of the drawing.
Public property | Is3D | Gets a value indicating whether the drawing is three-dimensional.
Public property | IsDraw3DAxes | Gets a value indicating whether 3D axes are visible on the drawing.
Public property | IsDrawingRotated | Gets a value indicating whether the drawing is rotated.
Public property | IsLoading | Gets a value indicating whether the process of loading the drawing data is active.
Public property | IsPlotting | Gets or sets a value indicating whether to plot the image or not.
Public property | IsProcessMessages | Gets or sets a value indicating whether the messages processing is allowed.
Public property | IsShowBackground | Gets or sets a value indicating whether the backround is displayed.
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines is determined by the drawing data.
Public property | IsWithoutBorder | Gets or sets a value indicating whether to display the drawing without borders.
Public property | LayoutsCount | Gets the number of layouts in the drawing.
Public property | LineScaled | Gets or sets a value indicating whether the line weight is diplayed.
Public property | LineWeightScale | Gets or sets a scale for line weights.
Public property | Millimetres | Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file.
Public property | Modified | Gets or sets a value indicating whether the drawing is modified.
Public property | NullWidth | Gets or sets a thickness for lines which have the zero lineweight.
Public property | OwnSource | For internal use.
Public property | PureExtents | Gets the drawing's extents excluding the borders.
Public property | ResizeDisproportionateDrawing | Gets or sets a value indicating whether to resize a drawing with disproportionate sizes.
Public property | Scale | Gets or sets a 3D point which defines the scale factor.
Public property | ShowImages | Gets or sets a value indicating whether the raster images are displayed.
Public property | Stretch | Gets or sets a value indicating whether the displayed image has to be stretched to fit exactly with the drawing rectangle.
Public property | TextVisible | Gets or sets a value indicating whether texts in the drawing are visible.
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles are drawn by using GDI+ methods without linearization.
Public property | ViewRectangle | For internal use.
Public property | Width | Gets or sets a width of the drawing.

Top

collall See Also

Reference

ISVGImage Interface


ISVGImage.BackGroundColor Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.BackGroundColor Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a background color for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property BackGroundColor() As UInt32

C#

UInt32 BackGroundColor {get; set;}

C++

property UInt32 BackGroundColor {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get BackGroundColor() : UInt32;
function set BackGroundColor(value : UInt32);

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.BorderSize Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.BorderSize Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a border size for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property BorderSize() As Double

C#

double BorderSize {get; set;}

C++

property double BorderSize {
double get( );
void set(
double value
);
}

JScript

function get BorderSize() : double;
function set BorderSize(value : double);

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.BorderType Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.BorderType Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a way the drawing's border size is defined (global or ratio).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property BorderType() As TxsgBorderType

C#

TxsgBorderType BorderType {get; set;}

C++

property TxsgBorderType BorderType {
TxsgBorderType get( );
void set(
TxsgBorderType value
);
}

JScript

function get BorderType() : TxsgBorderType;
function set BorderType(value : TxsgBorderType);

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.CADClassID Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.CADClassID Property

 Return to chapter overview

Show / hide the hidden text

Gets the CAD format identifier for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property CADClassID() As TxCADClassID

C#

TxCADClassID CADClassID {get;}

C++

property TxCADClassID CADClassID {
TxCADClassID get( );
}

JScript

function get CADClassID() : TxCADClassID;

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.CBFormat Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.CBFormat Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the clipboard format.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CBFormat() As UInt16

C#

UInt16 CBFormat {get; set;}

C++

property UInt16 CBFormat {
UInt16 get( );
void set(
UInt16 value
);
}

JScript

function get CBFormat() : UInt16;
function set CBFormat(value : UInt16);

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.CanStopLoading Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.CanStopLoading Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the loading of the drawing data can be terminated.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property CanStopLoading() As Boolean

C#

bool CanStopLoading {get;}

C++

property bool CanStopLoading {
bool get( );
}

JScript

function get CanStopLoading() : boolean;

Property Value

true if the loading can be terminated; otherwise, false.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.Charset Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.Charset Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a character set for the text entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Charset() As Byte

C#

byte Charset {get; set;}

C++

property Byte Charset {
Byte get( );
void set(
Byte value
);
}

JScript

function get Charset() : byte;
function set Charset(value : byte);

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.ColorToLineWeight Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.ColorToLineWeight Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a string which contains the color-lineweight pairs.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property ColorToLineWeight() As String

C#

string ColorToLineWeight {get; set;}

C++

property String^ ColorToLineWeight {
String^ get( );
void set(
String^ value
);
}

JScript

function get ColorToLineWeight() : String;
function set ColorToLineWeight(value : String);

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.Converter Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.Converter Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a Converter associated with this image object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Converter() As Converter

C#

Converter Converter {get;}

C++

property Converter^ Converter {
Converter^ get( );
}

JScript

function get Converter() : Converter;

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.Count Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.Count Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of entities in the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Count() As Integer

C#

int Count {get;}

C++

property int Count {
int get( );
}

JScript

function get Count() : int;

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.CurrentLayout Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.CurrentLayout Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the current layout for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CurrentLayout() As Layout

C#

Layout CurrentLayout {get; set;}

C++

property Layout^ CurrentLayout {
Layout^ get( );
void set(
Layout^ value
);
}

JScript

function get CurrentLayout() : Layout;
function set CurrentLayout(value : Layout);

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.DefaultColor Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.DefaultColor Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the default color for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DefaultColor() As UInt32

C#

UInt32 DefaultColor {get; set;}

C++

property UInt32 DefaultColor {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get DefaultColor() : UInt32;
function set DefaultColor(value : UInt32);

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.DimensionsVisible Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.DimensionsVisible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether dimensions in the drawing are visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DimensionsVisible() As Boolean

C#

bool DimensionsVisible {get; set;}

C++

property bool DimensionsVisible {
bool get( );
void set(
bool value
);
}

JScript

function get DimensionsVisible() : boolean;
function set DimensionsVisible(value : boolean);

Property Value

true if the dimensions are visible; otherwise, false. Default value is true.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.DrawMode Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.DrawMode Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets an appearance of colors in the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DrawMode() As TxDXFDrawMode

C#

TxDXFDrawMode DrawMode {get; set;}

C++

property TxDXFDrawMode DrawMode {
TxDXFDrawMode get( );
void set(
TxDXFDrawMode value
);
}

JScript

function get DrawMode() : TxDXFDrawMode;
function set DrawMode(value : TxDXFDrawMode);

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.DrawingBox Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.DrawingBox Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the drawing bounding box.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property DrawingBox() As Rect3D

C#

Rect3D DrawingBox {get; set;}

C++

property Rect3D^ DrawingBox {
Rect3D^ get( );
void set(
Rect3D^ value
);
}

JScript

function get DrawingBox() : Rect3D;
function set DrawingBox(value : Rect3D);

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.Empty Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.Empty Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the drawing is empty.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Empty() As Boolean

C#

bool Empty {get;}

C++

property bool Empty {
bool get( );
}

JScript

function get Empty() : boolean;

Property Value

true if the drawing is empty; otherwise, false.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.Extents Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.Extents Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the drawing's extents.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Extents() As Rect3D

C#

Rect3D Extents {get; set;}

C++

property Rect3D^ Extents {
Rect3D^ get( );
void set(
Rect3D^ value
);
}

JScript

function get Extents() : Rect3D;
function set Extents(value : Rect3D);

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.Height Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.Height Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a height of the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Height() As Integer

C#

int Height {get; set;}

C++

property int Height {
int get( );
void set(
int value
);
}

JScript

function get Height() : int;
function set Height(value : int);

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.Is3D Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.Is3D Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the drawing is three-dimensional.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Is3D() As Boolean

C#

bool Is3D {get; set;}

C++

property bool Is3D {
bool get( );
void set(
bool value
);
}

JScript

function get Is3D() : boolean;
function set Is3D(value : boolean);

Property Value

true if the drawing is three-dimensional; otherwise, false.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.IsDraw3DAxes Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.IsDraw3DAxes Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether 3D axes are visible on the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsDraw3DAxes() As Boolean

C#

bool IsDraw3DAxes {get; set;}

C++

property bool IsDraw3DAxes {
bool get( );
void set(
bool value
);
}

JScript

function get IsDraw3DAxes() : boolean;
function set IsDraw3DAxes(value : boolean);

Property Value

true if the 3D axes are visible; otherwise, false.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.IsDrawingRotated Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.IsDrawingRotated Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the drawing is rotated.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsDrawingRotated() As Boolean

C#

bool IsDrawingRotated {get;}

C++

property bool IsDrawingRotated {
bool get( );
}

JScript

function get IsDrawingRotated() : boolean;

Property Value

true if the drawing is rotated; otherwise, false.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.IsLoading Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.IsLoading Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the process of loading the drawing data is active.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsLoading() As Boolean

C#

bool IsLoading {get;}

C++

property bool IsLoading {
bool get( );
}

JScript

function get IsLoading() : boolean;

Property Value

true if the drawing data is loading into this image object; otherwise, false.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.IsPlotting Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.IsPlotting Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether to plot the image or not.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsPlotting() As Boolean

C#

bool IsPlotting {get; set;}

C++

property bool IsPlotting {
bool get( );
void set(
bool value
);
}

JScript

function get IsPlotting() : boolean;
function set IsPlotting(value : boolean);

Property Value

true if the image should be plotted; otherwise, false.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.IsProcessMessages Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.IsProcessMessages Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the messages processing is allowed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsProcessMessages() As Boolean

C#

bool IsProcessMessages {get; set;}

C++

property bool IsProcessMessages {
bool get( );
void set(
bool value
);
}

JScript

function get IsProcessMessages() : boolean;
function set IsProcessMessages(value : boolean);

Property Value

true if the messages processing is allowed; otherwise, false.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.IsShowBackground Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.IsShowBackground Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the backround is displayed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsShowBackground() As Boolean

C#

bool IsShowBackground {get; set;}

C++

property bool IsShowBackground {
bool get( );
void set(
bool value
);
}

JScript

function get IsShowBackground() : boolean;
function set IsShowBackground(value : boolean);

Property Value

true if the backround is displayed; otherwise, false.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.IsShowLineWeight Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.IsShowLineWeight Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether a thickness of lines is determined by the drawing data.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsShowLineWeight() As Boolean

C#

bool IsShowLineWeight {get; set;}

C++

property bool IsShowLineWeight {
bool get( );
void set(
bool value
);
}

JScript

function get IsShowLineWeight() : boolean;
function set IsShowLineWeight(value : boolean);

Property Value

true if a thickness of lines is determined by the drawing data; otherwise, false.

collall Remarks

If this property value is false, a thickness of lines is determined by the NullWidth property.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.IsWithoutBorder Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.IsWithoutBorder Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether to display the drawing without borders.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property IsWithoutBorder() As Boolean

C#

bool IsWithoutBorder {get; set;}

C++

property bool IsWithoutBorder {
bool get( );
void set(
bool value
);
}

JScript

function get IsWithoutBorder() : boolean;
function set IsWithoutBorder(value : boolean);

Property Value

true if the borders are not displayed; otherwise, false.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.LayoutsCount Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.LayoutsCount Property

 Return to chapter overview

Show / hide the hidden text

Gets the number of layouts in the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property LayoutsCount() As Integer

C#

int LayoutsCount {get;}

C++

property int LayoutsCount {
int get( );
}

JScript

function get LayoutsCount() : int;

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.LineScaled Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.LineScaled Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the line weight is diplayed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineScaled() As Boolean

C#

bool LineScaled {get; set;}

C++

property bool LineScaled {
bool get( );
void set(
bool value
);
}

JScript

function get LineScaled() : boolean;
function set LineScaled(value : boolean);

Property Value

true if the line weight is displayed; otherwise, false.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.LineWeightScale Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.LineWeightScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a scale for line weights.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineWeightScale() As Double

C#

double LineWeightScale {get; set;}

C++

property double LineWeightScale {
double get( );
void set(
double value
);
}

JScript

function get LineWeightScale() : double;
function set LineWeightScale(value : double);

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.Millimetres Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.Millimetres Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Millimetres() As Boolean

C#

bool Millimetres {get; set;}

C++

property bool Millimetres {
bool get( );
void set(
bool value
);
}

JScript

function get Millimetres() : boolean;
function set Millimetres(value : boolean);

Property Value

true if the drawing units are millimeters; false if the drawing units are inches.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.Modified Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.Modified Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the drawing is modified.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Modified() As Boolean

C#

bool Modified {get; set;}

C++

property bool Modified {
bool get( );
void set(
bool value
);
}

JScript

function get Modified() : boolean;
function set Modified(value : boolean);

Property Value

true if the drawing is modified; otherwise, false.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.NullWidth Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.NullWidth Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a thickness for lines which have the zero lineweight.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property NullWidth() As Integer

C#

int NullWidth {get; set;}

C++

property int NullWidth {
int get( );
void set(
int value
);
}

JScript

function get NullWidth() : int;
function set NullWidth(value : int);

Property Value

Line thickness. Default value is 1.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.OwnSource Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.OwnSource Property

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property OwnSource() As Boolean

C#

bool OwnSource {get; set;}

C++

property bool OwnSource {
bool get( );
void set(
bool value
);
}

JScript

function get OwnSource() : boolean;
function set OwnSource(value : boolean);

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.PureExtents Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.PureExtents Property

 Return to chapter overview

Show / hide the hidden text

Gets the drawing's extents excluding the borders.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property PureExtents() As Rect3D

C#

Rect3D PureExtents {get;}

C++

property Rect3D^ PureExtents {
Rect3D^ get( );
}

JScript

function get PureExtents() : Rect3D;

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.ResizeDisproportionateDrawing Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.ResizeDisproportionateDrawing Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether to resize a drawing with disproportionate sizes.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property ResizeDisproportionateDrawing() As Boolean

C#

bool ResizeDisproportionateDrawing {get; set;}

C++

property bool ResizeDisproportionateDrawing {
bool get( );
void set(
bool value
);
}

JScript

function get ResizeDisproportionateDrawing() : boolean;
function set ResizeDisproportionateDrawing(value : boolean);

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.Scale Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.Scale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a 3D point which defines the scale factor.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Scale() As Point3D

C#

Point3D Scale {get;}

C++

property Point3D^ Scale {
Point3D^ get( );
}

JScript

function get Scale() : Point3D;

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.ShowImages Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.ShowImages Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the raster images are displayed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property ShowImages() As Boolean

C#

bool ShowImages {get; set;}

C++

property bool ShowImages {
bool get( );
void set(
bool value
);
}

JScript

function get ShowImages() : boolean;
function set ShowImages(value : boolean);

Property Value

true if the raster images are displayed; overwise, false.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.Stretch Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.Stretch Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the displayed image has to be stretched to fit exactly with the drawing rectangle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Stretch() As Boolean

C#

bool Stretch {get; set;}

C++

property bool Stretch {
bool get( );
void set(
bool value
);
}

JScript

function get Stretch() : boolean;
function set Stretch(value : boolean);

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.TextVisible Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.TextVisible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether texts in the drawing are visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property TextVisible() As Boolean

C#

bool TextVisible {get; set;}

C++

property bool TextVisible {
bool get( );
void set(
bool value
);
}

JScript

function get TextVisible() : boolean;
function set TextVisible(value : boolean);

Property Value

true if the texts are visible; otherwise, false.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.UseWinEllipse Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.UseWinEllipse Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether arcs and circles are drawn by using GDI+ methods without linearization.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property UseWinEllipse() As Boolean

C#

bool UseWinEllipse {get; set;}

C++

property bool UseWinEllipse {
bool get( );
void set(
bool value
);
}

JScript

function get UseWinEllipse() : boolean;
function set UseWinEllipse(value : boolean);

Property Value

true if the GDI+ methods are used for drawing arcs and circles; otherwise, false.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.ViewRectangle Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.ViewRectangle Property

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property ViewRectangle() As Rect3D

C#

Rect3D ViewRectangle {get; set;}

C++

property Rect3D^ ViewRectangle {
Rect3D^ get( );
void set(
Rect3D^ value
);
}

JScript

function get ViewRectangle() : Rect3D;
function set ViewRectangle(value : Rect3D);

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.Width Property

API Reference > CADViewLib Namespace > ISVGImage Interface > Properties >

ISVGImage.Width Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a width of the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Width() As Integer

C#

int Width {get; set;}

C++

property int Width {
int get( );
void set(
int value
);
}

JScript

function get Width() : int;
function set Width(value : int);

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage Methods

API Reference > CADViewLib Namespace > ISVGImage Interface >

ISVGImage Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AbsHeight | Returns an absolute height of the CAD drawing.
Public method | AbsWidth | Returns an absolute width of the CAD drawing.
Public method | AddScaledDXF | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.
Public method | AddScaledDXFEx | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.
Public method | AssignImage | Makes a copy of a specified CAD image object and assigns it to this image.
Public method | CreateImage | Initializes a new CAD image instance.
Public method | Draw | Draws the CAD image in a specified device context (DC).
Public method | DrawRect | Draws a specified region of this CAD image in a device context (DC).
Public method | ExportToMetafile | Exports this CAD image to Windows metafile.
Public method | FreeImage | Destroys this CAD image object and frees the memory used within the object.
Public method | GetCADCoords | Returns CAD coordinates for a specified point.
Public method | GetEntityColor | Returns the color value for a specified entity.
Public method | GetExtents | Recalculates extents of the CAD image.
Public method | GetPoint | Gets the on-screen coordinates for a specified CAD point.
Public method | GetRealImagePoint | Returns CAD coordinates of a specified point considering the drawing's rotation and viewport parameters.
Public method | HeadVarAsFloat | Returns a value of the DXF header variable as a floating point number.
Public method | HeadVarAsInteger | Returns a value of the DXF header variable as an integer.
Public method | HeadVarAsstring | Returns a value of the DXF header variable as a string.
Public method | LoadFromClipboardFormat | Loads data from the clipboard.
Public method | LoadFromFile | Loads a CAD drawing from file.
Public method | LoadFromIStream | Loads a CAD drawing from stream.
Public method | LoadFromStream | Loads a CAD drawing from stream.
Public method | RefreshCurrentLayout | Refreshes the current layout.
Public method | ResetDrawingBox | Switches off the drawing box.
Public method | RotDefault | Rotates the drawing to the default view.
Public method | RotToView | Rotates the drawing to a specified view.
Public method | Rotate | Rotates the drawing.
Public method | SaveToClipboardFormat | Copies the drawing to the clipboard in a specified format.
Public method | SaveToFile | Saves the drawing to a specified file.
Public method | SaveToIStream | Writes the drawing data to a specified stream.
Public method | SaveToStream | Writes the drawing data to a specified stream.
Public method | SetClippingRect | Sets a clipping rectangle for the drawing.
Public method | SetExtentsParameters | Changes the drawing extents.
Public method | StopLoading | Terminates loading of the drawing data.
Public method | get_Blocks | Retrieves a BLOCK object by its index.
Public method | get_Entities | Retrieves an entity by its index.
Public method | get_Items |
Public method | get_Layouts | Retrieves a layout by its index.

Top

collall See Also

Reference

ISVGImage Interface


ISVGImage.AbsHeight Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.AbsHeight Method

 Return to chapter overview

Show / hide the hidden text

Returns an absolute height of the CAD drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function AbsHeight() As Double

C#

override double AbsHeight()

C++

double AbsHeight()

JScript

function AbsHeight() : double;

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.AbsWidth Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.AbsWidth Method

 Return to chapter overview

Show / hide the hidden text

Returns an absolute width of the CAD drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function AbsWidth() As Double

C#

override double AbsWidth()

C++

double AbsWidth()

JScript

function AbsWidth() : double;

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.AddScaledDXF Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.AddScaledDXF Method

 Return to chapter overview

Show / hide the hidden text

Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AddScaledDXF( _
ByVal ACADFile As DXFImage, _
ByVal AName As String, _
ByVal APos As Point3D, _
ByVal AScale As Point3D, _
ByVal Rotation As Single _
)

C#

override void AddScaledDXF(
DXFImageACADFile,
stringAName,
Point3DAPos,
Point3DAScale,
floatRotation
)

C++

void AddScaledDXF(
DXFImage^ ACADFile,
String^ AName,
Point3D^ APos,
Point3D^ AScale,
floatRotation
)

JScript

function AddScaledDXF(
ACADFile : DXFImage,
AName : String,
APos : Point3D,
AScale : Point3D,
Rotation : float
);

Parameters

ACADFile

DXF image which defines the external reference.

AName

User-defined name for the XREF.

APos

The insertion point.

AScale

3D point which determines the scale factor.

Rotation

XREF rotation angle.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.AddScaledDXFEx Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.AddScaledDXFEx Method

 Return to chapter overview

Show / hide the hidden text

Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function AddScaledDXFEx( _
ByVal ACADFile As DXFImage, _
ByVal AName As String, _
ByVal APos As Point3D, _
ByVal AScale As Point3D, _
ByVal Rotation As Single _
) As Insert

C#

override Insert AddScaledDXFEx(
DXFImage ACADFile,
stringAName,
Point3DAPos,
Point3DAScale,
floatRotation
)

C++

Insert^ AddScaledDXFEx(
DXFImage^ ACADFile,
String^ AName,
Point3D^ APos,
Point3D^ AScale,
floatRotation
)

JScript

function AddScaledDXFEx(
ACADFile : DXFImage,
AName : String,
APos : Point3D,
AScale : Point3D,
Rotation : float
) : Insert;

Parameters

ACADFile

DXF image which defines the external reference.

AName

User-defined name for the XREF.

APos

The insertion point.

AScale

3D point which determines the scale factor.

Rotation

XREF rotation angle.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.AssignImage Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.AssignImage Method

 Return to chapter overview

Show / hide the hidden text

Makes a copy of a specified CAD image object and assigns it to this image.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AssignImage( _
ByVal Source As Object _
)

C#

override void AssignImage(
objectSource
)

C++

void AssignImage(
object^ Source
)

JScript

function AssignImage(
Source : object
);

Parameters

Source

The source CAD image object which will be copied.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.CreateImage Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.CreateImage Method

 Return to chapter overview

Show / hide the hidden text

Initializes a new CAD image instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub CreateImage()

C#

override void CreateImage()

C++

void CreateImage()

JScript

function CreateImage();

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.Draw Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.Draw Method

 Return to chapter overview

Show / hide the hidden text

Draws the CAD image in a specified device context (DC).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub Draw( _
ByVal DC As Integer, _
ByVal Rect As Rect2D _
)

C#

override void Draw(
intDC,
Rect2DRect
)

C++

void Draw(
intDC,
Rect2D^ Rect
)

JScript

function Draw(
DC : int,
Rect : Rect2D
);

Parameters

DC

Handle to the DC.

Rect

Rectangle which defines the drawing area in the DC.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.DrawRect Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.DrawRect Method

 Return to chapter overview

Show / hide the hidden text

Draws a specified region of this CAD image in a device context (DC).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub DrawRect( _
ByVal DC As Integer, _
ByVal SourceRect As Rect3D, _
ByVal DestRect As Rect2D _
)

C#

override void DrawRect(
intDC,
Rect3DSourceRect,
Rect2DDestRect
)

C++

void DrawRect(
intDC,
Rect3D^ SourceRect,
Rect2D^ DestRect
)

JScript

function DrawRect(
DC : int,
SourceRect : Rect3D,
DestRect : Rect2D
);

Parameters

DC

Handle to the DC.

SourceRect

The region which will be drawn in the DC.

DestRect

Rectangle which defines the drawing area in the DC.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.ExportToMetafile Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.ExportToMetafile Method

 Return to chapter overview

Show / hide the hidden text

Exports this CAD image to Windows metafile.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub ExportToMetafile( _
ByVal FileName As String, _
ByVal AWidth As Integer, _
ByVal AHeight As Integer _
)

C#

override void ExportToMetafile(
stringFileName,
intAWidth,
intAHeight
)

C++

void ExportToMetafile(
String^ FileName,
intAWidth,
intAHeight
)

JScript

function ExportToMetafile(
FileName : String,
AWidth : int,
AHeight : int
);

Parameters

FileName

Path to the output metafile.

AWidth

Width of the output metafile.

AHeight

Height of the output metafile.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.FreeImage Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.FreeImage Method

 Return to chapter overview

Show / hide the hidden text

Destroys this CAD image object and frees the memory used within the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub FreeImage()

C#

override void FreeImage()

C++

void FreeImage()

JScript

function FreeImage();

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.GetCADCoords Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.GetCADCoords Method

 Return to chapter overview

Show / hide the hidden text

Returns CAD coordinates for a specified point.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetCADCoords( _
ByVal AXScaled As Double, _
ByVal AYScaled As Double _
) As Point3D

C#

override Point3D GetCADCoords(
doubleAXScaled,
doubleAYScaled
)

C++

Point3D^ GetCADCoords(
doubleAXScaled,
doubleAYScaled
)

JScript

function GetCADCoords(
AXScaled : double,
AYScaled : double
) : Point3D;

Parameters

AXScaled

Ratio between the x-coordinate and the drawing's width.

AYScaled

Ratio between the y-coordinate and the drawing's height.

collall Remarks

The z-coordinate of the returned point is equal 0.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.GetEntityColor Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.GetEntityColor Method

 Return to chapter overview

Show / hide the hidden text

Returns the color value for a specified entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetEntityColor( _
ByVal AEntity As Entity, _
ByVal AInsert As Insert _
) As UInt32

C#

override UInt32 GetEntityColor(
EntityAEntity,
InsertAInsert
)

C++

UInt32 GetEntityColor(
Entity^ AEntity,
Insert^ AInsert
)

JScript

function GetEntityColor(
AEntity : Entity,
AInsert : Insert
) : UInt32;

Parameters

AEntity

The entity whose color is retrieved.

AInsert

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.GetExtents Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.GetExtents Method

 Return to chapter overview

Show / hide the hidden text

Recalculates extents of the CAD image.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub GetExtents()

C#

override void GetExtents()

C++

void GetExtents()

JScript

function GetExtents();

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.GetPoint Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.GetPoint Method

 Return to chapter overview

Show / hide the hidden text

Gets the on-screen coordinates for a specified CAD point.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetPoint( _
ByVal P As Point3D _
) As Point2D

C#

override Point2D GetPoint(
Point3D P
)

C++

Point2D^ GetPoint(
Point3D^ P
)

JScript

function GetPoint(
P : Point3D
) : Point2D;

Parameters

P

CAD point coordinates in the 3D space.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.GetRealImagePoint Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.GetRealImagePoint Method

 Return to chapter overview

Show / hide the hidden text

Returns CAD coordinates of a specified point considering the drawing's rotation and viewport parameters.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetRealImagePoint( _
ByVal P As Point3D _
) As Point3D

C#

override Point3D GetRealImagePoint(
Point3D P
)

C++

Point3D^ GetRealImagePoint(
Point3D^ P
)

JScript

function GetRealImagePoint(
P : Point3D
) : Point3D;

Parameters

P

CAD point in the 3D space.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.HeadVarAsFloat Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.HeadVarAsFloat Method

 Return to chapter overview

Show / hide the hidden text

Returns a value of the DXF header variable as a floating point number.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function HeadVarAsFloat( _
ByVal AName As String, _
ByVal ACode As Integer _
) As Double

C#

override double HeadVarAsFloat(
stringAName,
intACode
)

C++

double HeadVarAsFloat(
String^ AName,
intACode
)

JScript

function HeadVarAsFloat(
AName : String,
ACode : int
) : double;

Parameters

AName

The header variable name.

ACode

Group code associated with the variable's value.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.HeadVarAsInteger Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.HeadVarAsInteger Method

 Return to chapter overview

Show / hide the hidden text

Returns a value of the DXF header variable as an integer.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function HeadVarAsInteger( _
ByVal AName As String, _
ByVal ACode As Integer _
) As Integer

C#

override int HeadVarAsInteger(
stringAName,
intACode
)

C++

int HeadVarAsInteger(
String^ AName,
intACode
)

JScript

function HeadVarAsInteger(
AName : String,
ACode : int
) : int;

Parameters

AName

The header variable name.

ACode

Group code associated with the variable's value.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.HeadVarAsstring Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.HeadVarAsstring Method

 Return to chapter overview

Show / hide the hidden text

Returns a value of the DXF header variable as a string.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function HeadVarAsstring( _
ByVal AName As String, _
ByVal ACode As Integer _
) As String

C#

override string HeadVarAsstring(
stringAName,
intACode
)

C++

String^ HeadVarAsstring(
String^ AName,
intACode
)

JScript

function HeadVarAsstring(
AName : String,
ACode : int
) : String;

Parameters

AName

The header variable name.

ACode

Group code associated with the variable's value.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.LoadFromClipboardFormat Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.LoadFromClipboardFormat Method

 Return to chapter overview

Show / hide the hidden text

Loads data from the clipboard.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub LoadFromClipboardFormat( _
ByVal Fmt As UInt16, _
ByVal Data As Integer, _
ByVal Pal As Integer _
)

C#

override void LoadFromClipboardFormat(
UInt16Fmt,
intData,
intPal
)

C++

void LoadFromClipboardFormat(
UInt16Fmt,
intData,
intPal
)

JScript

function LoadFromClipboardFormat(
Fmt : UInt16,
Data : int,
Pal : int
);

Parameters

Fmt

Data

Pal

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.LoadFromFile Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.LoadFromFile Method

 Return to chapter overview

Show / hide the hidden text

Loads a CAD drawing from file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub LoadFromFile( _
ByVal FileName As String _
)

C#

override void LoadFromFile(
stringFileName
)

C++

void LoadFromFile(
String^ FileName
)

JScript

function LoadFromFile(
FileName : String
);

Parameters

FileName

Path to the drawing file.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.LoadFromIStream Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.LoadFromIStream Method

 Return to chapter overview

Show / hide the hidden text

Loads a CAD drawing from stream.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub LoadFromIStream( _
ByVal Stream As Object _
)

C#

override void LoadFromIStream(
objectStream
)

C++

void LoadFromIStream(
object^ Stream
)

JScript

function LoadFromIStream(
Stream : object
);

Parameters

Stream

Stream which contains the CAD drawing data.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.LoadFromStream Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.LoadFromStream Method

 Return to chapter overview

Show / hide the hidden text

Loads a CAD drawing from stream.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub LoadFromStream( _
ByVal hStream As Integer _
)

C#

override void LoadFromStream(
inthStream
)

C++

void LoadFromStream(
inthStream
)

JScript

function LoadFromStream(
hStream : int
);

Parameters

hStream

Handle to the stream which contains the drawing data.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.RefreshCurrentLayout Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.RefreshCurrentLayout Method

 Return to chapter overview

Show / hide the hidden text

Refreshes the current layout.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub RefreshCurrentLayout()

C#

override void RefreshCurrentLayout()

C++

void RefreshCurrentLayout()

JScript

function RefreshCurrentLayout();

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.ResetDrawingBox Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.ResetDrawingBox Method

 Return to chapter overview

Show / hide the hidden text

Switches off the drawing box.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub ResetDrawingBox()

C#

override void ResetDrawingBox()

C++

void ResetDrawingBox()

JScript

function ResetDrawingBox();

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.RotDefault Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.RotDefault Method

 Return to chapter overview

Show / hide the hidden text

Rotates the drawing to the default view.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub RotDefault()

C#

override void RotDefault()

C++

void RotDefault()

JScript

function RotDefault();

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.RotToView Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.RotToView Method

 Return to chapter overview

Show / hide the hidden text

Rotates the drawing to a specified view.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub RotToView( _
ByVal A3DView As TxDXFViewDirection _
)

C#

override void RotToView(
TxDXFViewDirectionA3DView
)

C++

void RotToView(
TxDXFViewDirectionA3DView
)

JScript

function RotToView(
A3DView : TxDXFViewDirection
);

Parameters

A3DView

One of the orthogonal or isometric views.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.Rotate Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.Rotate Method

 Return to chapter overview

Show / hide the hidden text

Rotates the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub Rotate( _
ByVal Axis As TxAxes, _
ByVal Angle As Double _
)

C#

override void Rotate(
TxAxesAxis,
doubleAngle
)

C++

void Rotate(
TxAxesAxis,
doubleAngle
)

JScript

function Rotate(
Axis : TxAxes,
Angle : double
);

Parameters

Axis

Rotation axis.

Angle

Rotation angle (measured in degrees).

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.SaveToClipboardFormat Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.SaveToClipboardFormat Method

 Return to chapter overview

Show / hide the hidden text

Copies the drawing to the clipboard in a specified format.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SaveToClipboardFormat( _
ByRef Fmt As UInt16, _
ByRef Data As Integer, _
ByRef Pal As Integer _
)

C#

override void SaveToClipboardFormat(
ref UInt16Fmt,
ref intData,
ref intPal
)

C++

void SaveToClipboardFormat(
UInt16& Fmt,
int& Data,
int& Pal
)

JScript

function SaveToClipboardFormat(
Fmt : UInt16,
Data : int,
Pal : int
);

Parameters

Fmt

Clipboard format.

Data

Pal

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.SaveToFile Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.SaveToFile Method

 Return to chapter overview

Show / hide the hidden text

Saves the drawing to a specified file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SaveToFile( _
ByVal FileName As String _
)

C#

override void SaveToFile(
stringFileName
)

C++

void SaveToFile(
String^ FileName
)

JScript

function SaveToFile(
FileName : String
);

Parameters

FileName

Path to the output file.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.SaveToIStream Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.SaveToIStream Method

 Return to chapter overview

Show / hide the hidden text

Writes the drawing data to a specified stream.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SaveToIStream( _
ByVal Stream As Object _
)

C#

override void SaveToIStream(
objectStream
)

C++

void SaveToIStream(
object^ Stream
)

JScript

function SaveToIStream(
Stream : object
);

Parameters

Stream

Stream where the drawing data is written.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.SaveToStream Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.SaveToStream Method

 Return to chapter overview

Show / hide the hidden text

Writes the drawing data to a specified stream.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SaveToStream( _
ByVal Stream As Integer _
)

C#

override void SaveToStream(
intStream
)

C++

void SaveToStream(
intStream
)

JScript

function SaveToStream(
Stream : int
);

Parameters

Stream

Stream where the drawing data will be written.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.SetClippingRect Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.SetClippingRect Method

 Return to chapter overview

Show / hide the hidden text

Sets a clipping rectangle for the drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetClippingRect( _
ByVal Value As Rect3D _
)

C#

override void SetClippingRect(
Rect3DValue
)

C++

void SetClippingRect(
Rect3D^ Value
)

JScript

function SetClippingRect(
Value : Rect3D
);

Parameters

Value

The clipping rectangle area.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.SetExtentsParameters Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.SetExtentsParameters Method

 Return to chapter overview

Show / hide the hidden text

Changes the drawing extents.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetExtentsParameters( _
ByVal ARect As Rect3D, _
ByVal AIs3DExtents As Boolean _
)

C#

override void SetExtentsParameters(
Rect3DARect,
boolAIs3DExtents
)

C++

void SetExtentsParameters(
Rect3D^ ARect,
boolAIs3DExtents
)

JScript

function SetExtentsParameters(
ARect : Rect3D,
AIs3DExtents : boolean
);

Parameters

ARect

The parallelepiped which defines the extents.

AIs3DExtents

If set to true, then the extents are 3D; otherwise, the extents are 2D.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.StopLoading Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.StopLoading Method

 Return to chapter overview

Show / hide the hidden text

Terminates loading of the drawing data.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub StopLoading()

C#

override void StopLoading()

C++

void StopLoading()

JScript

function StopLoading();

collall Remarks

The portion of the drawing data which was loaded can be displayed in the control.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.get_Blocks Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.get_Blocks Method

 Return to chapter overview

Show / hide the hidden text

Retrieves a BLOCK object by its index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Blocks( _
ByVal Index As Integer _
) As Block

C#

override Block get_Blocks(
intIndex
)

C++

Block^ get_Blocks(
intIndex
)

JScript

function get_Blocks(
Index : int
) : Block;

Parameters

Index

Index of the block.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.get_Entities Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.get_Entities Method

 Return to chapter overview

Show / hide the hidden text

Retrieves an entity by its index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Entities( _
ByVal Index As Integer _
) As Entity

C#

override Entity get_Entities(
intIndex
)

C++

Entity^ get_Entities(
intIndex
)

JScript

function get_Entities(
Index : int
) : Entity;

Parameters

Index

Index of the entity.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.get_Items Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.get_Items Method

 Return to chapter overview

Show / hide the hidden text

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Items( _
ByVal Index As Integer _
) As DXFImage

C#

override DXFImage get_Items(
intIndex
)

C++

DXFImage^ get_Items(
intIndex
)

JScript

function get_Items(
Index : int
) : DXFImage;

Parameters

Index

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISVGImage.get_Layouts Method

API Reference > CADViewLib Namespace > ISVGImage Interface > Methods >

ISVGImage.get_Layouts Method

 Return to chapter overview

Show / hide the hidden text

Retrieves a layout by its index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Layouts( _
ByVal Index As Integer _
) As Layout

C#

override Layout get_Layouts(
intIndex
)

C++

Layout^ get_Layouts(
intIndex
)

JScript

function get_Layouts(
Index : int
) : Layout;

Parameters

Index

Index of the layout.

collall See Also

Reference

ISVGImage Interface
ISVGImage ISVGImage Members


ISolid Interface

API Reference > CADViewLib Namespace >

ISolid Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to SOLID entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface ISolid
Inherits ICADLine

C#

public interface ISolid : ICADLine

C++

public interface class ISolid : public ICADLine^

JScript

public interface ISolid
implements ICADLine

collall See Also

Reference

ISolid Members


ISolid Members

API Reference > CADViewLib Namespace > ISolid Interface >

ISolid Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to SOLID entities.

The following tables list the members exposed by the ISolid type.

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | Name | Gets or sets a name of this object.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | Point | Gets or sets coordinates of the first corner.
Public property | Point1 | Gets or sets coordinates of the second corner.
Public property | Point2 | Gets or sets coordinates of the third corner.
Public property | Point3 | Gets or sets coordinates of the fourth corner.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetBoxPoints | For internal use.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Entities | Returns the child entity at the given index.

Top

collall See Also

Reference

ISolid Interface


ISolid Properties

API Reference > CADViewLib Namespace > ISolid Interface >

ISolid Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | Name | Gets or sets a name of this object.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | Point | Gets or sets coordinates of the first corner.
Public property | Point1 | Gets or sets coordinates of the second corner.
Public property | Point2 | Gets or sets coordinates of the third corner.
Public property | Point3 | Gets or sets coordinates of the fourth corner.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall See Also

Reference

ISolid Interface


ISolid.Box Property

API Reference > CADViewLib Namespace > ISolid Interface > Properties >

ISolid.Box Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the bounding parallelepiped for the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Box() As Rect3D

C#

Rect3D Box {get;}

C++

property Rect3D^ Box {
Rect3D^ get( );
}

JScript

function get Box() : Rect3D;

Property Value

The parallelepiped which encloses the object.

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.CADHandle Property

API Reference > CADViewLib Namespace > ISolid Interface > Properties >

ISolid.CADHandle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the object handle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CADHandle() As UInt64

C#

UInt64 CADHandle {get; set;}

C++

property UInt64 CADHandle {
UInt64 get( );
void set(
UInt64 value
);
}

JScript

function get CADHandle() : UInt64;
function set CADHandle(value : UInt64);

Property Value

Number that uniquely identifies the object in a CAD drawing.

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.Color Property

API Reference > CADViewLib Namespace > ISolid Interface > Properties >

ISolid.Color Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a color of the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Color() As UInt32

C#

UInt32 Color {get; set;}

C++

property UInt32 Color {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get Color() : UInt32;
function set Color(value : UInt32);

Property Value

An insigned integer value which defines the object's color.

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.Converter Property

API Reference > CADViewLib Namespace > ISolid Interface > Properties >

ISolid.Converter Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a Converter instance associated with the CAD image to which this object belongs.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Converter() As Converter

C#

Converter Converter {get;}

C++

property Converter^ Converter {
Converter^ get( );
}

JScript

function get Converter() : Converter;

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.Count Property

API Reference > CADViewLib Namespace > ISolid Interface > Properties >

ISolid.Count Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of objects contained within the given object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Count() As Integer

C#

int Count {get;}

C++

property int Count {
int get( );
}

JScript

function get Count() : int;

Property Value

An Integer value indicating a number of objects contained within the given object.

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.EntID Property

API Reference > CADViewLib Namespace > ISolid Interface > Properties >

ISolid.EntID Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the entity type ID for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property EntID() As TEntityID

C#

TEntityID EntID {get; set;}

C++

property TEntityID EntID {
TEntityID get( );
void set(
TEntityID value
);
}

JScript

function get EntID() : TEntityID;
function set EntID(value : TEntityID);

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.Extrusion Property

API Reference > CADViewLib Namespace > ISolid Interface > Properties >

ISolid.Extrusion Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the extrusion direction vector for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Extrusion() As Point3D

C#

Point3D Extrusion {get; set;}

C++

property Point3D^ Extrusion {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Extrusion() : Point3D;
function set Extrusion(value : Point3D);

Property Value

The 3D point which defines the extrusion direction vector.

collall Remarks

The extrusion direction is the normal vector of the plane which contains the entity and it is applied to the entity base point. The default extrusion direction value is (0, 0, 1).

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.Layer Property

API Reference > CADViewLib Namespace > ISolid Interface > Properties >

ISolid.Layer Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a layer containing this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Layer() As Layer

C#

Layer Layer {get; set;}

C++

property Layer^ Layer {
Layer^ get( );
void set(
Layer^ value
);
}

JScript

function get Layer() : Layer;
function set Layer(value : Layer);

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.LineTypeScale Property

API Reference > CADViewLib Namespace > ISolid Interface > Properties >

ISolid.LineTypeScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a quantity of line type elements per unit of its length.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineTypeScale() As Single

C#

float LineTypeScale {get; set;}

C++

property float LineTypeScale {
float get( );
void set(
float value
);
}

JScript

function get LineTypeScale() : float;
function set LineTypeScale(value : float);

Property Value

The quantity of linetype elements per unit of its length.

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.Name Property

API Reference > CADViewLib Namespace > ISolid Interface > Properties >

ISolid.Name Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Name() As String

C#

string Name {get; set;}

C++

property String^ Name {
String^ get( );
void set(
String^ value
);
}

JScript

function get Name() : String;
function set Name(value : String);

Property Value

String containing the object name.

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.PaperSpace Property

API Reference > CADViewLib Namespace > ISolid Interface > Properties >

ISolid.PaperSpace Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is located in Paper space.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PaperSpace() As Integer

C#

int PaperSpace {get; set;}

C++

property int PaperSpace {
int get( );
void set(
int value
);
}

JScript

function get PaperSpace() : int;
function set PaperSpace(value : int);

Property Value

0 - the object is located in Model space, 1 - in Paper space.

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.Point Property

API Reference > CADViewLib Namespace > ISolid Interface > Properties >

ISolid.Point Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets coordinates of the first corner.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Point() As Point3D

C#

Point3D Point {get; set;}

C++

property Point3D^ Point {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Point() : Point3D;
function set Point(value : Point3D);

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.Point1 Property

API Reference > CADViewLib Namespace > ISolid Interface > Properties >

ISolid.Point1 Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets coordinates of the second corner.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Point1() As Point3D

C#

Point3D Point1 {get; set;}

C++

property Point3D^ Point1 {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Point1() : Point3D;
function set Point1(value : Point3D);

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.Point2 Property

API Reference > CADViewLib Namespace > ISolid Interface > Properties >

ISolid.Point2 Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets coordinates of the third corner.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Point2() As Point3D

C#

Point3D Point2 {get; set;}

C++

property Point3D^ Point2 {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Point2() : Point3D;
function set Point2(value : Point3D);

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.Point3 Property

API Reference > CADViewLib Namespace > ISolid Interface > Properties >

ISolid.Point3 Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets coordinates of the fourth corner.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Point3() As Point3D

C#

Point3D Point3 {get; set;}

C++

property Point3D^ Point3 {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Point3() : Point3D;
function set Point3(value : Point3D);

collall Remarks

If only three corners are entered to define the SOLID, then the fourth corner coordinate is the same as the third.

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.SrcEnd Property

API Reference > CADViewLib Namespace > ISolid Interface > Properties >

ISolid.SrcEnd Property

 Return to chapter overview

Show / hide the hidden text

Indicates the end of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcEnd() As String

C#

string SrcEnd {get; set;}

C++

property String^ SrcEnd {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcEnd() : String;
function set SrcEnd(value : String);

Property Value

A String value indicating the end of the record which represents this object in a drawing file.

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.SrcStart Property

API Reference > CADViewLib Namespace > ISolid Interface > Properties >

ISolid.SrcStart Property

 Return to chapter overview

Show / hide the hidden text

Indicates the beginning of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcStart() As String

C#

string SrcStart {get; set;}

C++

property String^ SrcStart {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcStart() : String;
function set SrcStart(value : String);

Property Value

A String value indicating the beginning of the record which represents this object in a drawing file.

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.Visibility Property

API Reference > CADViewLib Namespace > ISolid Interface > Properties >

ISolid.Visibility Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visibility() As Boolean

C#

bool Visibility {get; set;}

C++

property bool Visibility {
bool get( );
void set(
bool value
);
}

JScript

function get Visibility() : boolean;
function set Visibility(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.Visible Property

API Reference > CADViewLib Namespace > ISolid Interface > Properties >

ISolid.Visible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visible() As Boolean

C#

bool Visible {get; set;}

C++

property bool Visible {
bool get( );
void set(
bool value
);
}

JScript

function get Visible() : boolean;
function set Visible(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid Methods

API Reference > CADViewLib Namespace > ISolid Interface >

ISolid Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetBoxPoints | For internal use.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Entities | Returns the child entity at the given index.

Top

collall See Also

Reference

ISolid Interface


ISolid.AddEntity Method

API Reference > CADViewLib Namespace > ISolid Interface > Methods >

ISolid.AddEntity Method

 Return to chapter overview

Show / hide the hidden text

Adds a new child entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AddEntity( _
ByVal AEntity As Entity _
)

C#

override void AddEntity(
EntityAEntity
)

C++

void AddEntity(
Entity^ AEntity
)

JScript

function AddEntity(
AEntity : Entity
);

Parameters

AEntity

Added entity.

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.AssignEntity Method

API Reference > CADViewLib Namespace > ISolid Interface > Methods >

ISolid.AssignEntity Method

 Return to chapter overview

Show / hide the hidden text

Assigns the properties of the specified entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AssignEntity( _
ByVal Source As Entity _
)

C#

override void AssignEntity(
EntitySource
)

C++

void AssignEntity(
Entity^ Source
)

JScript

function AssignEntity(
Source : Entity
);

Parameters

Source

Entity which has the same type as the current object.

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.CreateEntity Method

API Reference > CADViewLib Namespace > ISolid Interface > Methods >

ISolid.CreateEntity Method

 Return to chapter overview

Show / hide the hidden text

Initializes a new object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub CreateEntity()

C#

override void CreateEntity()

C++

void CreateEntity()

JScript

function CreateEntity();

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.DeleteEntity Method

API Reference > CADViewLib Namespace > ISolid Interface > Methods >

ISolid.DeleteEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes an entity specified by index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub DeleteEntity( _
ByVal AIndex As Integer _
)

C#

override void DeleteEntity(
intAIndex
)

C++

void DeleteEntity(
intAIndex
)

JScript

function DeleteEntity(
AIndex : int
);

Parameters

AIndex

Index of the entity.

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.EntName Method

API Reference > CADViewLib Namespace > ISolid Interface > Methods >

ISolid.EntName Method

 Return to chapter overview

Show / hide the hidden text

Returns a name of the entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function EntName() As String

C#

override string EntName()

C++

String^ EntName()

JScript

function EntName() : String;

Return Value

A string containing the entity name.

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.FreeEntity Method

API Reference > CADViewLib Namespace > ISolid Interface > Methods >

ISolid.FreeEntity Method

 Return to chapter overview

Show / hide the hidden text

Destroys the object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub FreeEntity()

C#

override void FreeEntity()

C++

void FreeEntity()

JScript

function FreeEntity();

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.GetBoxPoints Method

API Reference > CADViewLib Namespace > ISolid Interface > Methods >

ISolid.GetBoxPoints Method

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetBoxPoints( _
ByVal Full As Boolean _
) As Boolean

C#

override bool GetBoxPoints(
boolFull
)

C++

bool GetBoxPoints(
boolFull
)

JScript

function GetBoxPoints(
Full : boolean
) : boolean;

Parameters

Full

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.GetThickness Method

API Reference > CADViewLib Namespace > ISolid Interface > Methods >

ISolid.GetThickness Method

 Return to chapter overview

Show / hide the hidden text

Returns the line thickness for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetThickness() As Double

C#

override double GetThickness()

C++

double GetThickness()

JScript

function GetThickness() : double;

Return Value

A Double type value indicating the line thickness.

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.IndexOfEntity Method

API Reference > CADViewLib Namespace > ISolid Interface > Methods >

ISolid.IndexOfEntity Method

 Return to chapter overview

Show / hide the hidden text

Returns index of the given entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function IndexOfEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int IndexOfEntity(
EntityAEntity
)

C++

int IndexOfEntity(
Entity^ AEntity
)

JScript

function IndexOfEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity whose index is retrieved.

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.Iterate Method

API Reference > CADViewLib Namespace > ISolid Interface > Methods >

ISolid.Iterate Method

 Return to chapter overview

Show / hide the hidden text

Iterates through the entities in the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub Iterate( _
ByVal AConverter As Converter _
)

C#

override void Iterate(
ConverterAConverter
)

C++

void Iterate(
Converter^ AConverter
)

JScript

function Iterate(
AConverter : Converter
);

Parameters

AConverter

Converter which contains the drawing data.

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.RemoveEntity Method

API Reference > CADViewLib Namespace > ISolid Interface > Methods >

ISolid.RemoveEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes a specified entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function RemoveEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int RemoveEntity(
EntityAEntity
)

C++

int RemoveEntity(
Entity^ AEntity
)

JScript

function RemoveEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity which will be removed.

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.SetLType Method

API Reference > CADViewLib Namespace > ISolid Interface > Methods >

ISolid.SetLType Method

 Return to chapter overview

Show / hide the hidden text

Sets a line type for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLType( _
ByVal Value As Entity _
)

C#

override void SetLType(
EntityValue
)

C++

void SetLType(
Entity^ Value
)

JScript

function SetLType(
Value : Entity
);

Parameters

Value

The line type value.

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.SetLWeight Method

API Reference > CADViewLib Namespace > ISolid Interface > Methods >

ISolid.SetLWeight Method

 Return to chapter overview

Show / hide the hidden text

Sets a line weight for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLWeight( _
ByVal Value As Integer _
)

C#

override void SetLWeight(
intValue
)

C++

void SetLWeight(
intValue
)

JScript

function SetLWeight(
Value : int
);

Parameters

Value

The line weight value.

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISolid.get_Entities Method

API Reference > CADViewLib Namespace > ISolid Interface > Methods >

ISolid.get_Entities Method

 Return to chapter overview

Show / hide the hidden text

Returns the child entity at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Entities( _
ByVal Index As Integer _
) As Entity

C#

override Entity get_Entities(
intIndex
)

C++

Entity^ get_Entities(
intIndex
)

JScript

function get_Entities(
Index : int
) : Entity;

Parameters

Index

The index of the entity to retrieve.

collall See Also

Reference

ISolid Interface
ISolid ISolid Members


ISpline Interface

API Reference > CADViewLib Namespace >

ISpline Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to SPLINE entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface ISpline
Inherits IPolyline

C#

public interface ISpline : IPolyline

C++

public interface class ISpline : public IPolyline^

JScript

public interface ISpline
implements IPolyline

collall See Also

Reference

ISpline Members


ISpline Members

API Reference > CADViewLib Namespace > ISpline Interface >

ISpline Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to SPLINE entities.

The following tables list the members exposed by the ISpline type.

collall Public Properties

 | Name | Description
Public property | ArrowsCount | Gets a quantity of points that form an arrow.
Public property | BeginningTangent | Gets or sets a point that specifies a tangent condition on the starting point of the spline.
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Closed | Gets or sets a value indicating whether this polyline is closed.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | DottedPointsCount | Gets a quantity of points that determine the dots and dashes for a polyline with non-solid line type.
Public property | EndingTangent | Gets or sets a point that specifies a tangent condition on the ending point of the spline.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Flags | Gets or sets a bit-coded flag indicating the spline type.
Public property | GlobalWidth | Gets or sets a global width for this polyline.
Public property | IsByAngles | Gets a value indicating whether this spline was created by specifying fit points and tangents or by control points and knots.
Public property | IsMeshMClosed | Gets a value indicating whether the polygon mesh is closed in the M direction.
Public property | IsMeshNClosed | Gets a value indicating whether the polygon mesh is closed in the N direction.
Public property | IsPolyFaceMesh | Gets a value indicating whether this polyline is a polyface mesh.
Public property | IsPolyZThickness | Gets a value indicating whether the polyline has thickness measured along the axis Z.
Public property | IsPolygonMesh | Gets a value indicating whether this polyline is a polygon mesh.
Public property | Layer | Gets or sets a layer containing this object.
Public property | Length | Gets a length of this spline.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | MeshM | Gets or sets a number of vertices for the polygon mesh in the M direction.
Public property | MeshN | Gets or sets a number of vertices for the polygon mesh in the N direction.
Public property | Name | Gets or sets a name of this object.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | PenLine | Gets properties of the pen used for drawing the object.
Public property | PointsCount | Gets a number of the polyline points.
Public property | PolyFaceVertexIndexesCount | Gets a quantity of indices which specify the order of traversing vertices in the polyface mesh.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | ControlCount | Returns the number of control points.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FitCount | Returns the number of fit points.
Public method | FreeEntity | Destroys the object instance.
Public method | GetArea | Returns the area bounded by a closed polygon.
Public method | GetBoxPoints | For internal use.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Arrows | Returns a point of the arrowhead.
Public method | get_ControlPoints | Returns the control point at the given index.
Public method | get_DottedPoints | Returns coordinates of a point in the points array that determines dots and dashes for a non-solid line type.
Public method | get_Entities | Returns the child entity at the given index.
Public method | get_FitPoints | Returns the fit point at the given index.
Public method | get_Points | Returns coordinates of a point in the points array.
Public method | get_PolyFaceVertexIndexes | Returns a value which indicates an index of the polyface mesh vertex.
Public method | set_Arrows | Modifies a point of the arrowhead at the given index.

Top

collall See Also

Reference

ISpline Interface


ISpline Properties

API Reference > CADViewLib Namespace > ISpline Interface >

ISpline Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | ArrowsCount | Gets a quantity of points that form an arrow.
Public property | BeginningTangent | Gets or sets a point that specifies a tangent condition on the starting point of the spline.
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Closed | Gets or sets a value indicating whether this polyline is closed.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | DottedPointsCount | Gets a quantity of points that determine the dots and dashes for a polyline with non-solid line type.
Public property | EndingTangent | Gets or sets a point that specifies a tangent condition on the ending point of the spline.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Flags | Gets or sets a bit-coded flag indicating the spline type.
Public property | GlobalWidth | Gets or sets a global width for this polyline.
Public property | IsByAngles | Gets a value indicating whether this spline was created by specifying fit points and tangents or by control points and knots.
Public property | IsMeshMClosed | Gets a value indicating whether the polygon mesh is closed in the M direction.
Public property | IsMeshNClosed | Gets a value indicating whether the polygon mesh is closed in the N direction.
Public property | IsPolyFaceMesh | Gets a value indicating whether this polyline is a polyface mesh.
Public property | IsPolyZThickness | Gets a value indicating whether the polyline has thickness measured along the axis Z.
Public property | IsPolygonMesh | Gets a value indicating whether this polyline is a polygon mesh.
Public property | Layer | Gets or sets a layer containing this object.
Public property | Length | Gets a length of this spline.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | MeshM | Gets or sets a number of vertices for the polygon mesh in the M direction.
Public property | MeshN | Gets or sets a number of vertices for the polygon mesh in the N direction.
Public property | Name | Gets or sets a name of this object.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | PenLine | Gets properties of the pen used for drawing the object.
Public property | PointsCount | Gets a number of the polyline points.
Public property | PolyFaceVertexIndexesCount | Gets a quantity of indices which specify the order of traversing vertices in the polyface mesh.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall See Also

Reference

ISpline Interface


ISpline.ArrowsCount Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.ArrowsCount Property

 Return to chapter overview

Show / hide the hidden text

Gets a quantity of points that form an arrow.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property ArrowsCount() As Integer

C#

int ArrowsCount {get;}

C++

property int ArrowsCount {
int get( );
}

JScript

function get ArrowsCount() : int;

Property Value

An Integer type value indicating a quantity of points that form an arrow.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.BeginningTangent Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.BeginningTangent Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a point that specifies a tangent condition on the starting point of the spline.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property BeginningTangent() As Point3D

C#

Point3D BeginningTangent {get; set;}

C++

property Point3D^ BeginningTangent {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get BeginningTangent() : Point3D;
function set BeginningTangent(value : Point3D);

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.Box Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.Box Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the bounding parallelepiped for the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Box() As Rect3D

C#

Rect3D Box {get;}

C++

property Rect3D^ Box {
Rect3D^ get( );
}

JScript

function get Box() : Rect3D;

Property Value

The parallelepiped which encloses the object.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.CADHandle Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.CADHandle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the object handle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CADHandle() As UInt64

C#

UInt64 CADHandle {get; set;}

C++

property UInt64 CADHandle {
UInt64 get( );
void set(
UInt64 value
);
}

JScript

function get CADHandle() : UInt64;
function set CADHandle(value : UInt64);

Property Value

Number that uniquely identifies the object in a CAD drawing.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.Closed Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.Closed Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this polyline is closed.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Closed() As Boolean

C#

bool Closed {get; set;}

C++

property bool Closed {
bool get( );
void set(
bool value
);
}

JScript

function get Closed() : boolean;
function set Closed(value : boolean);

Property Value

true if the polyline is closed; otherwise, false

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.Color Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.Color Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a color of the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Color() As UInt32

C#

UInt32 Color {get; set;}

C++

property UInt32 Color {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get Color() : UInt32;
function set Color(value : UInt32);

Property Value

An insigned integer value which defines the object's color.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.Converter Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.Converter Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a Converter instance associated with the CAD image to which this object belongs.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Converter() As Converter

C#

Converter Converter {get;}

C++

property Converter^ Converter {
Converter^ get( );
}

JScript

function get Converter() : Converter;

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.Count Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.Count Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of objects contained within the given object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Count() As Integer

C#

int Count {get;}

C++

property int Count {
int get( );
}

JScript

function get Count() : int;

Property Value

An Integer value indicating a number of objects contained within the given object.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.DottedPointsCount Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.DottedPointsCount Property

 Return to chapter overview

Show / hide the hidden text

Gets a quantity of points that determine the dots and dashes for a polyline with non-solid line type.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property DottedPointsCount() As Integer

C#

int DottedPointsCount {get;}

C++

property int DottedPointsCount {
int get( );
}

JScript

function get DottedPointsCount() : int;

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.EndingTangent Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.EndingTangent Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a point that specifies a tangent condition on the ending point of the spline.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property EndingTangent() As Point3D

C#

Point3D EndingTangent {get; set;}

C++

property Point3D^ EndingTangent {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get EndingTangent() : Point3D;
function set EndingTangent(value : Point3D);

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.EntID Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.EntID Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the entity type ID for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property EntID() As TEntityID

C#

TEntityID EntID {get; set;}

C++

property TEntityID EntID {
TEntityID get( );
void set(
TEntityID value
);
}

JScript

function get EntID() : TEntityID;
function set EntID(value : TEntityID);

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.Extrusion Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.Extrusion Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the extrusion direction vector for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Extrusion() As Point3D

C#

Point3D Extrusion {get; set;}

C++

property Point3D^ Extrusion {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Extrusion() : Point3D;
function set Extrusion(value : Point3D);

Property Value

The 3D point which defines the extrusion direction vector.

collall Remarks

The extrusion direction is the normal vector of the plane which contains the entity and it is applied to the entity base point. The default extrusion direction value is (0, 0, 1).

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.Flags Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.Flags Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a bit-coded flag indicating the spline type.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Flags() As Integer

C#

int Flags {get; set;}

C++

property int Flags {
int get( );
void set(
int value
);
}

JScript

function get Flags() : int;
function set Flags(value : int);

Property Value

1 = Closed spline
2 = Periodic spline
4 = Rational spline
8 = Planar
16 = Linear (planar bit is also set)

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.GlobalWidth Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.GlobalWidth Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a global width for this polyline.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property GlobalWidth() As Single

C#

float GlobalWidth {get; set;}

C++

property float GlobalWidth {
float get( );
void set(
float value
);
}

JScript

function get GlobalWidth() : float;
function set GlobalWidth(value : float);

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.IsByAngles Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.IsByAngles Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether this spline was created by specifying fit points and tangents or by control points and knots.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsByAngles() As Boolean

C#

bool IsByAngles {get;}

C++

property bool IsByAngles {
bool get( );
}

JScript

function get IsByAngles() : boolean;

Property Value

true if the spline was created by specifying fit points and tangents on the starting and the ending point;
false if the spline was created by control points and knots.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.IsMeshMClosed Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.IsMeshMClosed Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the polygon mesh is closed in the M direction.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsMeshMClosed() As Boolean

C#

bool IsMeshMClosed {get;}

C++

property bool IsMeshMClosed {
bool get( );
}

JScript

function get IsMeshMClosed() : boolean;

Property Value

true if the polygon mesh is closed in the M direction.; otherwise, false.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.IsMeshNClosed Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.IsMeshNClosed Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the polygon mesh is closed in the N direction.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsMeshNClosed() As Boolean

C#

bool IsMeshNClosed {get;}

C++

property bool IsMeshNClosed {
bool get( );
}

JScript

function get IsMeshNClosed() : boolean;

Property Value

true if the polygon mesh is closed in the N direction.; otherwise, false.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.IsPolyFaceMesh Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.IsPolyFaceMesh Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether this polyline is a polyface mesh.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsPolyFaceMesh() As Boolean

C#

bool IsPolyFaceMesh {get;}

C++

property bool IsPolyFaceMesh {
bool get( );
}

JScript

function get IsPolyFaceMesh() : boolean;

Property Value

true if the polyline is a polyface mesh; otherwise, false.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.IsPolyZThickness Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.IsPolyZThickness Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the polyline has thickness measured along the axis Z.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsPolyZThickness() As Boolean

C#

bool IsPolyZThickness {get;}

C++

property bool IsPolyZThickness {
bool get( );
}

JScript

function get IsPolyZThickness() : boolean;

Property Value

true if the polyline has thickness measured along the axis Z; otherwise, false.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.IsPolygonMesh Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.IsPolygonMesh Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether this polyline is a polygon mesh.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsPolygonMesh() As Boolean

C#

bool IsPolygonMesh {get;}

C++

property bool IsPolygonMesh {
bool get( );
}

JScript

function get IsPolygonMesh() : boolean;

Property Value

true if the polyline is a polygon mesh; otherwise, false.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.Layer Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.Layer Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a layer containing this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Layer() As Layer

C#

Layer Layer {get; set;}

C++

property Layer^ Layer {
Layer^ get( );
void set(
Layer^ value
);
}

JScript

function get Layer() : Layer;
function set Layer(value : Layer);

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.Length Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.Length Property

 Return to chapter overview

Show / hide the hidden text

Gets a length of this spline.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Length() As Double

C#

double Length {get;}

C++

property double Length {
double get( );
}

JScript

function get Length() : double;

Property Value

A Double type value indicating a length of the spline.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.LineTypeScale Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.LineTypeScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a quantity of line type elements per unit of its length.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineTypeScale() As Single

C#

float LineTypeScale {get; set;}

C++

property float LineTypeScale {
float get( );
void set(
float value
);
}

JScript

function get LineTypeScale() : float;
function set LineTypeScale(value : float);

Property Value

The quantity of linetype elements per unit of its length.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.MeshM Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.MeshM Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a number of vertices for the polygon mesh in the M direction.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property MeshM() As Integer

C#

int MeshM {get; set;}

C++

property int MeshM {
int get( );
void set(
int value
);
}

JScript

function get MeshM() : int;
function set MeshM(value : int);

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.MeshN Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.MeshN Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a number of vertices for the polygon mesh in the N direction.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property MeshN() As Integer

C#

int MeshN {get; set;}

C++

property int MeshN {
int get( );
void set(
int value
);
}

JScript

function get MeshN() : int;
function set MeshN(value : int);

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.Name Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.Name Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Name() As String

C#

string Name {get; set;}

C++

property String^ Name {
String^ get( );
void set(
String^ value
);
}

JScript

function get Name() : String;
function set Name(value : String);

Property Value

String containing the object name.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.PaperSpace Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.PaperSpace Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is located in Paper space.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PaperSpace() As Integer

C#

int PaperSpace {get; set;}

C++

property int PaperSpace {
int get( );
void set(
int value
);
}

JScript

function get PaperSpace() : int;
function set PaperSpace(value : int);

Property Value

0 - the object is located in Model space, 1 - in Paper space.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.PenLine Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.PenLine Property

 Return to chapter overview

Show / hide the hidden text

Gets properties of the pen used for drawing the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property PenLine() As CADLine

C#

CADLine PenLine {get;}

C++

property CADLine^ PenLine {
CADLine^ get( );
}

JScript

function get PenLine() : CADLine;

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.PointsCount Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.PointsCount Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of the polyline points.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property PointsCount() As Integer

C#

int PointsCount {get;}

C++

property int PointsCount {
int get( );
}

JScript

function get PointsCount() : int;

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.PolyFaceVertexIndexesCount Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.PolyFaceVertexIndexesCount Property

 Return to chapter overview

Show / hide the hidden text

Gets a quantity of indices which specify the order of traversing vertices in the polyface mesh.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property PolyFaceVertexIndexesCount() As Integer

C#

int PolyFaceVertexIndexesCount {get;}

C++

property int PolyFaceVertexIndexesCount {
int get( );
}

JScript

function get PolyFaceVertexIndexesCount() : int;

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.SrcEnd Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.SrcEnd Property

 Return to chapter overview

Show / hide the hidden text

Indicates the end of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcEnd() As String

C#

string SrcEnd {get; set;}

C++

property String^ SrcEnd {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcEnd() : String;
function set SrcEnd(value : String);

Property Value

A String value indicating the end of the record which represents this object in a drawing file.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.SrcStart Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.SrcStart Property

 Return to chapter overview

Show / hide the hidden text

Indicates the beginning of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcStart() As String

C#

string SrcStart {get; set;}

C++

property String^ SrcStart {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcStart() : String;
function set SrcStart(value : String);

Property Value

A String value indicating the beginning of the record which represents this object in a drawing file.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.Visibility Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.Visibility Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visibility() As Boolean

C#

bool Visibility {get; set;}

C++

property bool Visibility {
bool get( );
void set(
bool value
);
}

JScript

function get Visibility() : boolean;
function set Visibility(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.Visible Property

API Reference > CADViewLib Namespace > ISpline Interface > Properties >

ISpline.Visible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visible() As Boolean

C#

bool Visible {get; set;}

C++

property bool Visible {
bool get( );
void set(
bool value
);
}

JScript

function get Visible() : boolean;
function set Visible(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline Methods

API Reference > CADViewLib Namespace > ISpline Interface >

ISpline Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | ControlCount | Returns the number of control points.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FitCount | Returns the number of fit points.
Public method | FreeEntity | Destroys the object instance.
Public method | GetArea | Returns the area bounded by a closed polygon.
Public method | GetBoxPoints | For internal use.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Arrows | Returns a point of the arrowhead.
Public method | get_ControlPoints | Returns the control point at the given index.
Public method | get_DottedPoints | Returns coordinates of a point in the points array that determines dots and dashes for a non-solid line type.
Public method | get_Entities | Returns the child entity at the given index.
Public method | get_FitPoints | Returns the fit point at the given index.
Public method | get_Points | Returns coordinates of a point in the points array.
Public method | get_PolyFaceVertexIndexes | Returns a value which indicates an index of the polyface mesh vertex.
Public method | set_Arrows | Modifies a point of the arrowhead at the given index.

Top

collall See Also

Reference

ISpline Interface


ISpline.AddEntity Method

API Reference > CADViewLib Namespace > ISpline Interface > Methods >

ISpline.AddEntity Method

 Return to chapter overview

Show / hide the hidden text

Adds a new child entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AddEntity( _
ByVal AEntity As Entity _
)

C#

override void AddEntity(
EntityAEntity
)

C++

void AddEntity(
Entity^ AEntity
)

JScript

function AddEntity(
AEntity : Entity
);

Parameters

AEntity

Added entity.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.AssignEntity Method

API Reference > CADViewLib Namespace > ISpline Interface > Methods >

ISpline.AssignEntity Method

 Return to chapter overview

Show / hide the hidden text

Assigns the properties of the specified entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AssignEntity( _
ByVal Source As Entity _
)

C#

override void AssignEntity(
EntitySource
)

C++

void AssignEntity(
Entity^ Source
)

JScript

function AssignEntity(
Source : Entity
);

Parameters

Source

Entity which has the same type as the current object.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.ControlCount Method

API Reference > CADViewLib Namespace > ISpline Interface > Methods >

ISpline.ControlCount Method

 Return to chapter overview

Show / hide the hidden text

Returns the number of control points.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function ControlCount() As Integer

C#

int ControlCount()

C++

int ControlCount()

JScript

function ControlCount() : int;

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.CreateEntity Method

API Reference > CADViewLib Namespace > ISpline Interface > Methods >

ISpline.CreateEntity Method

 Return to chapter overview

Show / hide the hidden text

Initializes a new object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub CreateEntity()

C#

override void CreateEntity()

C++

void CreateEntity()

JScript

function CreateEntity();

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.DeleteEntity Method

API Reference > CADViewLib Namespace > ISpline Interface > Methods >

ISpline.DeleteEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes an entity specified by index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub DeleteEntity( _
ByVal AIndex As Integer _
)

C#

override void DeleteEntity(
intAIndex
)

C++

void DeleteEntity(
intAIndex
)

JScript

function DeleteEntity(
AIndex : int
);

Parameters

AIndex

Index of the entity.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.EntName Method

API Reference > CADViewLib Namespace > ISpline Interface > Methods >

ISpline.EntName Method

 Return to chapter overview

Show / hide the hidden text

Returns a name of the entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function EntName() As String

C#

override string EntName()

C++

String^ EntName()

JScript

function EntName() : String;

Return Value

A string containing the entity name.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.FitCount Method

API Reference > CADViewLib Namespace > ISpline Interface > Methods >

ISpline.FitCount Method

 Return to chapter overview

Show / hide the hidden text

Returns the number of fit points.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function FitCount() As Integer

C#

int FitCount()

C++

int FitCount()

JScript

function FitCount() : int;

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.FreeEntity Method

API Reference > CADViewLib Namespace > ISpline Interface > Methods >

ISpline.FreeEntity Method

 Return to chapter overview

Show / hide the hidden text

Destroys the object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub FreeEntity()

C#

override void FreeEntity()

C++

void FreeEntity()

JScript

function FreeEntity();

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.GetArea Method

API Reference > CADViewLib Namespace > ISpline Interface > Methods >

ISpline.GetArea Method

 Return to chapter overview

Show / hide the hidden text

Returns the area bounded by a closed polygon.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetArea() As Double

C#

override double GetArea()

C++

double GetArea()

JScript

function GetArea() : double;

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.GetBoxPoints Method

API Reference > CADViewLib Namespace > ISpline Interface > Methods >

ISpline.GetBoxPoints Method

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetBoxPoints( _
ByVal Full As Boolean _
) As Boolean

C#

override bool GetBoxPoints(
boolFull
)

C++

bool GetBoxPoints(
boolFull
)

JScript

function GetBoxPoints(
Full : boolean
) : boolean;

Parameters

Full

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.GetThickness Method

API Reference > CADViewLib Namespace > ISpline Interface > Methods >

ISpline.GetThickness Method

 Return to chapter overview

Show / hide the hidden text

Returns the line thickness for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetThickness() As Double

C#

override double GetThickness()

C++

double GetThickness()

JScript

function GetThickness() : double;

Return Value

A Double type value indicating the line thickness.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.IndexOfEntity Method

API Reference > CADViewLib Namespace > ISpline Interface > Methods >

ISpline.IndexOfEntity Method

 Return to chapter overview

Show / hide the hidden text

Returns index of the given entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function IndexOfEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int IndexOfEntity(
EntityAEntity
)

C++

int IndexOfEntity(
Entity^ AEntity
)

JScript

function IndexOfEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity whose index is retrieved.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.Iterate Method

API Reference > CADViewLib Namespace > ISpline Interface > Methods >

ISpline.Iterate Method

 Return to chapter overview

Show / hide the hidden text

Iterates through the entities in the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub Iterate( _
ByVal AConverter As Converter _
)

C#

override void Iterate(
ConverterAConverter
)

C++

void Iterate(
Converter^ AConverter
)

JScript

function Iterate(
AConverter : Converter
);

Parameters

AConverter

Converter which contains the drawing data.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.RemoveEntity Method

API Reference > CADViewLib Namespace > ISpline Interface > Methods >

ISpline.RemoveEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes a specified entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function RemoveEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int RemoveEntity(
EntityAEntity
)

C++

int RemoveEntity(
Entity^ AEntity
)

JScript

function RemoveEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity which will be removed.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.SetLType Method

API Reference > CADViewLib Namespace > ISpline Interface > Methods >

ISpline.SetLType Method

 Return to chapter overview

Show / hide the hidden text

Sets a line type for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLType( _
ByVal Value As Entity _
)

C#

override void SetLType(
EntityValue
)

C++

void SetLType(
Entity^ Value
)

JScript

function SetLType(
Value : Entity
);

Parameters

Value

The line type value.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.SetLWeight Method

API Reference > CADViewLib Namespace > ISpline Interface > Methods >

ISpline.SetLWeight Method

 Return to chapter overview

Show / hide the hidden text

Sets a line weight for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLWeight( _
ByVal Value As Integer _
)

C#

override void SetLWeight(
intValue
)

C++

void SetLWeight(
intValue
)

JScript

function SetLWeight(
Value : int
);

Parameters

Value

The line weight value.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.get_Arrows Method

API Reference > CADViewLib Namespace > ISpline Interface > Methods >

ISpline.get_Arrows Method

 Return to chapter overview

Show / hide the hidden text

Returns a point of the arrowhead.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Arrows( _
ByVal Index As Integer _
) As Point3D

C#

override Point3D get_Arrows(
intIndex
)

C++

Point3D^ get_Arrows(
intIndex
)

JScript

function get_Arrows(
Index : int
) : Point3D;

Parameters

Index

Index of the point to retrieve.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.get_ControlPoints Method

API Reference > CADViewLib Namespace > ISpline Interface > Methods >

ISpline.get_ControlPoints Method

 Return to chapter overview

Show / hide the hidden text

Returns the control point at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function get_ControlPoints( _
ByVal Index As Integer _
) As Point3D

C#

Point3D get_ControlPoints(
intIndex
)

C++

Point3D^ get_ControlPoints(
intIndex
)

JScript

function get_ControlPoints(
Index : int
) : Point3D;

Parameters

Index

The index of the control point to retrieve.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.get_DottedPoints Method

API Reference > CADViewLib Namespace > ISpline Interface > Methods >

ISpline.get_DottedPoints Method

 Return to chapter overview

Show / hide the hidden text

Returns coordinates of a point in the points array that determines dots and dashes for a non-solid line type.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_DottedPoints( _
ByVal Index As Integer _
) As Point3D

C#

override Point3D get_DottedPoints(
intIndex
)

C++

Point3D^ get_DottedPoints(
intIndex
)

JScript

function get_DottedPoints(
Index : int
) : Point3D;

Parameters

Index

Index of the point to retrieve.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.get_Entities Method

API Reference > CADViewLib Namespace > ISpline Interface > Methods >

ISpline.get_Entities Method

 Return to chapter overview

Show / hide the hidden text

Returns the child entity at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Entities( _
ByVal Index As Integer _
) As Entity

C#

override Entity get_Entities(
intIndex
)

C++

Entity^ get_Entities(
intIndex
)

JScript

function get_Entities(
Index : int
) : Entity;

Parameters

Index

The index of the entity to retrieve.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.get_FitPoints Method

API Reference > CADViewLib Namespace > ISpline Interface > Methods >

ISpline.get_FitPoints Method

 Return to chapter overview

Show / hide the hidden text

Returns the fit point at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Function get_FitPoints( _
ByVal Index As Integer _
) As Point3D

C#

Point3D get_FitPoints(
intIndex
)

C++

Point3D^ get_FitPoints(
intIndex
)

JScript

function get_FitPoints(
Index : int
) : Point3D;

Parameters

Index

The index of the fit point to retrieve.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.get_Points Method

API Reference > CADViewLib Namespace > ISpline Interface > Methods >

ISpline.get_Points Method

 Return to chapter overview

Show / hide the hidden text

Returns coordinates of a point in the points array.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Points( _
ByVal Index As Integer _
) As Point3D

C#

override Point3D get_Points(
intIndex
)

C++

Point3D^ get_Points(
intIndex
)

JScript

function get_Points(
Index : int
) : Point3D;

Parameters

Index

Index of the point to retrieve.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.get_PolyFaceVertexIndexes Method

API Reference > CADViewLib Namespace > ISpline Interface > Methods >

ISpline.get_PolyFaceVertexIndexes Method

 Return to chapter overview

Show / hide the hidden text

Returns a value which indicates an index of the polyface mesh vertex.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_PolyFaceVertexIndexes( _
ByVal Index As Integer _
) As Object

C#

override object get_PolyFaceVertexIndexes(
intIndex
)

C++

object^ get_PolyFaceVertexIndexes(
intIndex
)

JScript

function get_PolyFaceVertexIndexes(
Index : int
) : object;

Parameters

Index

The index number of the element.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


ISpline.set_Arrows Method

API Reference > CADViewLib Namespace > ISpline Interface > Methods >

ISpline.set_Arrows Method

 Return to chapter overview

Show / hide the hidden text

Modifies a point of the arrowhead at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub set_Arrows( _
ByVal Index As Integer, _
ByVal Value As Point3D _
)

C#

override void set_Arrows(
intIndex,
Point3DValue
)

C++

void set_Arrows(
intIndex,
Point3D^ Value
)

JScript

function set_Arrows(
Index : int,
Value : Point3D
);

Parameters

Index

The index of the point.

Value

Value to be set for the point.

collall See Also

Reference

ISpline Interface
ISpline ISpline Members


IText Interface

API Reference > CADViewLib Namespace >

IText Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to TEXT entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface IText
Inherits IEntity

C#

public interface IText : IEntity

C++

public interface class IText : public IEntity^

JScript

public interface IText
implements IEntity

collall See Also

Reference

IText Members


IText Members

API Reference > CADViewLib Namespace > IText Interface >

IText Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to TEXT entities.

The following tables list the members exposed by the IText type.

collall Public Properties

 | Name | Description
Public property | Backward | Gets a value indicating whether the text is drawn backwards.
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Font | Gets or sets a font for displaying the text.
Public property | FontName | Gets or sets a name of the font file.
Public property | Generation | Gets or sets text generation flags.
Public property | HAlign | Gets or sets horizontal text justification type integer codes (not bit-coded).
Public property | Height | Gets or sets a height of the text.
Public property | IsSHXFont | Gets a value indicating whether the text uses an SHX font.
Public property | IsUnicodeText | Gets a value indicating whether the text uses Unicode for characters encoding.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | Name | Gets or sets a name of this object.
Public property | ObliqueAngle | Gets or sets an oblique angle for text characters.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | Point | Gets or sets the first alignment point.
Public property | Point1 | Gets or sets the second alignment point.
Public property | Rotation | Gets or sets the rotation angle of the text.
Public property | SHXFontName | Gets or sets a name of SHX font file.
Public property | SHXText | Gets a string of the SHX text.
Public property | SHXUnicodeText | Gets a string of the SHX Unicode text.
Public property | Scale | Gets or sets relative X scale factor (width).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | StartPoint | Gets the start point of the text.
Public property | Text | Gets or sets the text value.
Public property | UnicodeText | Gets the text value as Unicode string.
Public property | UpsideDown | Gets a value indicating whether the text is upside down (mirrored in Y).
Public property | VAlign | Gets or sets vertical text justification type: integer codes (not bit-coded).
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.
Public property | WinFont | Gets a value indicating whether the text is rendered using a Windows font.
Public property | XScale | Gets or sets relative X scale factor (width).

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | DoNewText | Replaces the text value with a new string.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetBase | Returns the base point of the text.
Public method | GetBoxPoints | For internal use.
Public method | GetSHXMatrix | Returns a coordinate transformation matrix.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Entities | Returns the child entity at the given index.

Top

collall See Also

Reference

IText Interface


IText Properties

API Reference > CADViewLib Namespace > IText Interface >

IText Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Backward | Gets a value indicating whether the text is drawn backwards.
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | CADHandle | Gets or sets the object handle.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Font | Gets or sets a font for displaying the text.
Public property | FontName | Gets or sets a name of the font file.
Public property | Generation | Gets or sets text generation flags.
Public property | HAlign | Gets or sets horizontal text justification type integer codes (not bit-coded).
Public property | Height | Gets or sets a height of the text.
Public property | IsSHXFont | Gets a value indicating whether the text uses an SHX font.
Public property | IsUnicodeText | Gets a value indicating whether the text uses Unicode for characters encoding.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | Name | Gets or sets a name of this object.
Public property | ObliqueAngle | Gets or sets an oblique angle for text characters.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | Point | Gets or sets the first alignment point.
Public property | Point1 | Gets or sets the second alignment point.
Public property | Rotation | Gets or sets the rotation angle of the text.
Public property | SHXFontName | Gets or sets a name of SHX font file.
Public property | SHXText | Gets a string of the SHX text.
Public property | SHXUnicodeText | Gets a string of the SHX Unicode text.
Public property | Scale | Gets or sets relative X scale factor (width).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | StartPoint | Gets the start point of the text.
Public property | Text | Gets or sets the text value.
Public property | UnicodeText | Gets the text value as Unicode string.
Public property | UpsideDown | Gets a value indicating whether the text is upside down (mirrored in Y).
Public property | VAlign | Gets or sets vertical text justification type: integer codes (not bit-coded).
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.
Public property | WinFont | Gets a value indicating whether the text is rendered using a Windows font.
Public property | XScale | Gets or sets relative X scale factor (width).

Top

collall See Also

Reference

IText Interface


IText.Backward Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.Backward Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the text is drawn backwards.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Backward() As Boolean

C#

bool Backward {get;}

C++

property bool Backward {
bool get( );
}

JScript

function get Backward() : boolean;

Property Value

true if the text is drawn backwards; otherwise, false.

collall See Also

Reference

IText Interface
IText IText Members


IText.Box Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.Box Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the bounding parallelepiped for the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Box() As Rect3D

C#

Rect3D Box {get;}

C++

property Rect3D^ Box {
Rect3D^ get( );
}

JScript

function get Box() : Rect3D;

Property Value

The parallelepiped which encloses the object.

collall See Also

Reference

IText Interface
IText IText Members


IText.CADHandle Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.CADHandle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the object handle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CADHandle() As UInt64

C#

UInt64 CADHandle {get; set;}

C++

property UInt64 CADHandle {
UInt64 get( );
void set(
UInt64 value
);
}

JScript

function get CADHandle() : UInt64;
function set CADHandle(value : UInt64);

Property Value

Number that uniquely identifies the object in a CAD drawing.

collall See Also

Reference

IText Interface
IText IText Members


IText.Color Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.Color Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a color of the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Color() As UInt32

C#

UInt32 Color {get; set;}

C++

property UInt32 Color {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get Color() : UInt32;
function set Color(value : UInt32);

Property Value

An insigned integer value which defines the object's color.

collall See Also

Reference

IText Interface
IText IText Members


IText.Converter Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.Converter Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a Converter instance associated with the CAD image to which this object belongs.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Converter() As Converter

C#

Converter Converter {get;}

C++

property Converter^ Converter {
Converter^ get( );
}

JScript

function get Converter() : Converter;

collall See Also

Reference

IText Interface
IText IText Members


IText.Count Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.Count Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of objects contained within the given object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Count() As Integer

C#

int Count {get;}

C++

property int Count {
int get( );
}

JScript

function get Count() : int;

Property Value

An Integer value indicating a number of objects contained within the given object.

collall See Also

Reference

IText Interface
IText IText Members


IText.EntID Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.EntID Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the entity type ID for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property EntID() As TEntityID

C#

TEntityID EntID {get; set;}

C++

property TEntityID EntID {
TEntityID get( );
void set(
TEntityID value
);
}

JScript

function get EntID() : TEntityID;
function set EntID(value : TEntityID);

collall See Also

Reference

IText Interface
IText IText Members


IText.Extrusion Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.Extrusion Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the extrusion direction vector for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Extrusion() As Point3D

C#

Point3D Extrusion {get; set;}

C++

property Point3D^ Extrusion {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Extrusion() : Point3D;
function set Extrusion(value : Point3D);

Property Value

The 3D point which defines the extrusion direction vector.

collall Remarks

The extrusion direction is the normal vector of the plane which contains the entity and it is applied to the entity base point. The default extrusion direction value is (0, 0, 1).

collall See Also

Reference

IText Interface
IText IText Members


IText.Font Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.Font Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a font for displaying the text.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Font() As StdFont

C#

StdFont Font {get; set;}

C++

property StdFont^ Font {
StdFont^ get( );
void set(
StdFont^ value
);
}

JScript

function get Font() : StdFont;
function set Font(value : StdFont);

collall See Also

Reference

IText Interface
IText IText Members


IText.FontName Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.FontName Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of the font file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property FontName() As String

C#

string FontName {get;}

C++

property String^ FontName {
String^ get( );
}

JScript

function get FontName() : String;

collall See Also

Reference

IText Interface
IText IText Members


IText.Generation Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.Generation Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets text generation flags.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Generation() As Byte

C#

byte Generation {get; set;}

C++

property Byte Generation {
Byte get( );
void set(
Byte value
);
}

JScript

function get Generation() : byte;
function set Generation(value : byte);

Property Value

0 = Default value
2 = Text is backward (mirrored in X)
4 = Text is upside down (mirrored in Y)

collall See Also

Reference

IText Interface
IText IText Members


IText.HAlign Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.HAlign Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets horizontal text justification type integer codes (not bit-coded).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property HAlign() As Byte

C#

byte HAlign {get; set;}

C++

property Byte HAlign {
Byte get( );
void set(
Byte value
);
}

JScript

function get HAlign() : byte;
function set HAlign(value : byte);

Property Value

0 = Left
1 = Center
2 = Right
3 = Aligned (if vertical alignment = 0)
4 = Middle (if vertical alignment = 0)
5 = Fit (if vertical alignment = 0)

collall See Also

Reference

IText Interface
IText IText Members


IText.Height Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.Height Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a height of the text.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Height() As Double

C#

double Height {get; set;}

C++

property double Height {
double get( );
void set(
double value
);
}

JScript

function get Height() : double;
function set Height(value : double);

collall See Also

Reference

IText Interface
IText IText Members


IText.IsSHXFont Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.IsSHXFont Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the text uses an SHX font.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsSHXFont() As Boolean

C#

bool IsSHXFont {get;}

C++

property bool IsSHXFont {
bool get( );
}

JScript

function get IsSHXFont() : boolean;

collall See Also

Reference

IText Interface
IText IText Members


IText.IsUnicodeText Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.IsUnicodeText Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the text uses Unicode for characters encoding.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property IsUnicodeText() As Boolean

C#

bool IsUnicodeText {get;}

C++

property bool IsUnicodeText {
bool get( );
}

JScript

function get IsUnicodeText() : boolean;

collall See Also

Reference

IText Interface
IText IText Members


IText.Layer Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.Layer Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a layer containing this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Layer() As Layer

C#

Layer Layer {get; set;}

C++

property Layer^ Layer {
Layer^ get( );
void set(
Layer^ value
);
}

JScript

function get Layer() : Layer;
function set Layer(value : Layer);

collall See Also

Reference

IText Interface
IText IText Members


IText.LineTypeScale Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.LineTypeScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a quantity of line type elements per unit of its length.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineTypeScale() As Single

C#

float LineTypeScale {get; set;}

C++

property float LineTypeScale {
float get( );
void set(
float value
);
}

JScript

function get LineTypeScale() : float;
function set LineTypeScale(value : float);

Property Value

The quantity of linetype elements per unit of its length.

collall See Also

Reference

IText Interface
IText IText Members


IText.Name Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.Name Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Name() As String

C#

string Name {get; set;}

C++

property String^ Name {
String^ get( );
void set(
String^ value
);
}

JScript

function get Name() : String;
function set Name(value : String);

Property Value

String containing the object name.

collall See Also

Reference

IText Interface
IText IText Members


IText.ObliqueAngle Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.ObliqueAngle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets an oblique angle for text characters.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property ObliqueAngle() As Double

C#

double ObliqueAngle {get; set;}

C++

property double ObliqueAngle {
double get( );
void set(
double value
);
}

JScript

function get ObliqueAngle() : double;
function set ObliqueAngle(value : double);

collall See Also

Reference

IText Interface
IText IText Members


IText.PaperSpace Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.PaperSpace Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is located in Paper space.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PaperSpace() As Integer

C#

int PaperSpace {get; set;}

C++

property int PaperSpace {
int get( );
void set(
int value
);
}

JScript

function get PaperSpace() : int;
function set PaperSpace(value : int);

Property Value

0 - the object is located in Model space, 1 - in Paper space.

collall See Also

Reference

IText Interface
IText IText Members


IText.Point Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.Point Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the first alignment point.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Point() As Point3D

C#

Point3D Point {get; set;}

C++

property Point3D^ Point {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Point() : Point3D;
function set Point(value : Point3D);

Property Value

Point3D object which represents the first alignment point.

collall See Also

Reference

IText Interface
IText IText Members


IText.Point1 Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.Point1 Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the second alignment point.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Point1() As Point3D

C#

Point3D Point1 {get; set;}

C++

property Point3D^ Point1 {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Point1() : Point3D;
function set Point1(value : Point3D);

Property Value

Point3D object which represents the second alignment point.

collall See Also

Reference

IText Interface
IText IText Members


IText.Rotation Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.Rotation Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the rotation angle of the text.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Rotation() As Double

C#

double Rotation {get; set;}

C++

property double Rotation {
double get( );
void set(
double value
);
}

JScript

function get Rotation() : double;
function set Rotation(value : double);

collall See Also

Reference

IText Interface
IText IText Members


IText.SHXFontName Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.SHXFontName Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of SHX font file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property SHXFontName() As String

C#

string SHXFontName {get;}

C++

property String^ SHXFontName {
String^ get( );
}

JScript

function get SHXFontName() : String;

collall See Also

Reference

IText Interface
IText IText Members


IText.SHXText Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.SHXText Property

 Return to chapter overview

Show / hide the hidden text

Gets a string of the SHX text.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property SHXText() As String

C#

string SHXText {get;}

C++

property String^ SHXText {
String^ get( );
}

JScript

function get SHXText() : String;

collall See Also

Reference

IText Interface
IText IText Members


IText.SHXUnicodeText Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.SHXUnicodeText Property

 Return to chapter overview

Show / hide the hidden text

Gets a string of the SHX Unicode text.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property SHXUnicodeText() As String

C#

string SHXUnicodeText {get;}

C++

property String^ SHXUnicodeText {
String^ get( );
}

JScript

function get SHXUnicodeText() : String;

collall See Also

Reference

IText Interface
IText IText Members


IText.Scale Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.Scale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets relative X scale factor (width).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Scale() As Double

C#

double Scale {get; set;}

C++

property double Scale {
double get( );
void set(
double value
);
}

JScript

function get Scale() : double;
function set Scale(value : double);

Property Value

Default value is 1.
More than 1 if the text letters are stretched; less than 1 and more than 0 if the text letters are squeezed.

collall Remarks

The modified width is equal to the previous text width multiplied by the scale factor.

collall See Also

Reference

IText Interface
IText IText Members


IText.SrcEnd Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.SrcEnd Property

 Return to chapter overview

Show / hide the hidden text

Indicates the end of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcEnd() As String

C#

string SrcEnd {get; set;}

C++

property String^ SrcEnd {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcEnd() : String;
function set SrcEnd(value : String);

Property Value

A String value indicating the end of the record which represents this object in a drawing file.

collall See Also

Reference

IText Interface
IText IText Members


IText.SrcStart Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.SrcStart Property

 Return to chapter overview

Show / hide the hidden text

Indicates the beginning of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcStart() As String

C#

string SrcStart {get; set;}

C++

property String^ SrcStart {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcStart() : String;
function set SrcStart(value : String);

Property Value

A String value indicating the beginning of the record which represents this object in a drawing file.

collall See Also

Reference

IText Interface
IText IText Members


IText.StartPoint Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.StartPoint Property

 Return to chapter overview

Show / hide the hidden text

Gets the start point of the text.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property StartPoint() As Point3D

C#

Point3D StartPoint {get;}

C++

property Point3D^ StartPoint {
Point3D^ get( );
}

JScript

function get StartPoint() : Point3D;

Property Value

Point3D type value indicating the start point of the text.

collall See Also

Reference

IText Interface
IText IText Members


IText.Text Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.Text Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the text value.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Text() As String

C#

string Text {get; set;}

C++

property String^ Text {
String^ get( );
void set(
String^ value
);
}

JScript

function get Text() : String;
function set Text(value : String);

collall See Also

Reference

IText Interface
IText IText Members


IText.UnicodeText Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.UnicodeText Property

 Return to chapter overview

Show / hide the hidden text

Gets the text value as Unicode string.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property UnicodeText() As String

C#

string UnicodeText {get;}

C++

property String^ UnicodeText {
String^ get( );
}

JScript

function get UnicodeText() : String;

collall See Also

Reference

IText Interface
IText IText Members


IText.UpsideDown Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.UpsideDown Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the text is upside down (mirrored in Y).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property UpsideDown() As Boolean

C#

bool UpsideDown {get;}

C++

property bool UpsideDown {
bool get( );
}

JScript

function get UpsideDown() : boolean;

Property Value

true if the text is upside down; otherwise, false.

collall See Also

Reference

IText Interface
IText IText Members


IText.VAlign Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.VAlign Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets vertical text justification type: integer codes (not bit-coded).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property VAlign() As Byte

C#

byte VAlign {get; set;}

C++

property Byte VAlign {
Byte get( );
void set(
Byte value
);
}

JScript

function get VAlign() : byte;
function set VAlign(value : byte);

Property Value

0 = Baseline
1 = Bottom
2 = Middle
3 = Top

collall See Also

Reference

IText Interface
IText IText Members


IText.Visibility Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.Visibility Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visibility() As Boolean

C#

bool Visibility {get; set;}

C++

property bool Visibility {
bool get( );
void set(
bool value
);
}

JScript

function get Visibility() : boolean;
function set Visibility(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

IText Interface
IText IText Members


IText.Visible Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.Visible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visible() As Boolean

C#

bool Visible {get; set;}

C++

property bool Visible {
bool get( );
void set(
bool value
);
}

JScript

function get Visible() : boolean;
function set Visible(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

IText Interface
IText IText Members


IText.WinFont Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.WinFont Property

 Return to chapter overview

Show / hide the hidden text

Gets a value indicating whether the text is rendered using a Windows font.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property WinFont() As Boolean

C#

bool WinFont {get;}

C++

property bool WinFont {
bool get( );
}

JScript

function get WinFont() : boolean;

Property Value

true if the text is rendered using a Windows font; otherwise, false.

collall See Also

Reference

IText Interface
IText IText Members


IText.XScale Property

API Reference > CADViewLib Namespace > IText Interface > Properties >

IText.XScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets relative X scale factor (width).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property XScale() As Double

C#

double XScale {get;}

C++

property double XScale {
double get( );
}

JScript

function get XScale() : double;

Property Value

Default value is 1.
More than 1 if the text letters are stretched; less than 1 and more than 0 if the text letters are squeezed.

collall Remarks

The modified width is equal to the previous text width multiplied by the scale factor.

collall See Also

Reference

IText Interface
IText IText Members


IText Methods

API Reference > CADViewLib Namespace > IText Interface >

IText Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | DoNewText | Replaces the text value with a new string.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetBase | Returns the base point of the text.
Public method | GetBoxPoints | For internal use.
Public method | GetSHXMatrix | Returns a coordinate transformation matrix.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Entities | Returns the child entity at the given index.

Top

collall See Also

Reference

IText Interface


IText.AddEntity Method

API Reference > CADViewLib Namespace > IText Interface > Methods >

IText.AddEntity Method

 Return to chapter overview

Show / hide the hidden text

Adds a new child entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AddEntity( _
ByVal AEntity As Entity _
)

C#

override void AddEntity(
EntityAEntity
)

C++

void AddEntity(
Entity^ AEntity
)

JScript

function AddEntity(
AEntity : Entity
);

Parameters

AEntity

Added entity.

collall See Also

Reference

IText Interface
IText IText Members


IText.AssignEntity Method

API Reference > CADViewLib Namespace > IText Interface > Methods >

IText.AssignEntity Method

 Return to chapter overview

Show / hide the hidden text

Assigns the properties of the specified entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AssignEntity( _
ByVal Source As Entity _
)

C#

override void AssignEntity(
EntitySource
)

C++

void AssignEntity(
Entity^ Source
)

JScript

function AssignEntity(
Source : Entity
);

Parameters

Source

Entity which has the same type as the current object.

collall See Also

Reference

IText Interface
IText IText Members


IText.CreateEntity Method

API Reference > CADViewLib Namespace > IText Interface > Methods >

IText.CreateEntity Method

 Return to chapter overview

Show / hide the hidden text

Initializes a new object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub CreateEntity()

C#

override void CreateEntity()

C++

void CreateEntity()

JScript

function CreateEntity();

collall See Also

Reference

IText Interface
IText IText Members


IText.DeleteEntity Method

API Reference > CADViewLib Namespace > IText Interface > Methods >

IText.DeleteEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes an entity specified by index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub DeleteEntity( _
ByVal AIndex As Integer _
)

C#

override void DeleteEntity(
intAIndex
)

C++

void DeleteEntity(
intAIndex
)

JScript

function DeleteEntity(
AIndex : int
);

Parameters

AIndex

Index of the entity.

collall See Also

Reference

IText Interface
IText IText Members


IText.DoNewText Method

API Reference > CADViewLib Namespace > IText Interface > Methods >

IText.DoNewText Method

 Return to chapter overview

Show / hide the hidden text

Replaces the text value with a new string.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub DoNewText( _
ByVal ANewText As String _
)

C#

void DoNewText(
stringANewText
)

C++

void DoNewText(
String^ ANewText
)

JScript

function DoNewText(
ANewText : String
);

Parameters

ANewText

New text value.

collall See Also

Reference

IText Interface
IText IText Members


IText.EntName Method

API Reference > CADViewLib Namespace > IText Interface > Methods >

IText.EntName Method

 Return to chapter overview

Show / hide the hidden text

Returns a name of the entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function EntName() As String

C#

override string EntName()

C++

String^ EntName()

JScript

function EntName() : String;

Return Value

A string containing the entity name.

collall See Also

Reference

IText Interface
IText IText Members


IText.FreeEntity Method

API Reference > CADViewLib Namespace > IText Interface > Methods >

IText.FreeEntity Method

 Return to chapter overview

Show / hide the hidden text

Destroys the object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub FreeEntity()

C#

override void FreeEntity()

C++

void FreeEntity()

JScript

function FreeEntity();

collall See Also

Reference

IText Interface
IText IText Members


IText.GetBase Method

API Reference > CADViewLib Namespace > IText Interface > Methods >

IText.GetBase Method

 Return to chapter overview

Show / hide the hidden text

Returns the base point of the text.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub GetBase( _
ByVal AWidth As Double, _
ByVal AHeight As Double, _
ByRef Base As Point3D, _
ByRef Start As Point3D _
)

C#

void GetBase(
doubleAWidth,
doubleAHeight,
ref Point3DBase,
ref Point3DStart
)

C++

void GetBase(
doubleAWidth,
doubleAHeight,
Point3D^& Base,
Point3D^& Start
)

JScript

function GetBase(
AWidth : double,
AHeight : double,
Base : Point3D,
Start : Point3D
);

Parameters

AWidth

The text width.

AHeight

The text height.

Base

The base point.

Start

The point starting from which the text is drawn.

collall See Also

Reference

IText Interface
IText IText Members


IText.GetBoxPoints Method

API Reference > CADViewLib Namespace > IText Interface > Methods >

IText.GetBoxPoints Method

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetBoxPoints( _
ByVal Full As Boolean _
) As Boolean

C#

override bool GetBoxPoints(
boolFull
)

C++

bool GetBoxPoints(
boolFull
)

JScript

function GetBoxPoints(
Full : boolean
) : boolean;

Parameters

Full

collall See Also

Reference

IText Interface
IText IText Members


IText.GetSHXMatrix Method

API Reference > CADViewLib Namespace > IText Interface > Methods >

IText.GetSHXMatrix Method

 Return to chapter overview

Show / hide the hidden text

Returns a coordinate transformation matrix.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub GetSHXMatrix( _
ByRef Matrix As Object _
)

C#

void GetSHXMatrix(
ref objectMatrix
)

C++

void GetSHXMatrix(
object^& Matrix
)

JScript

function GetSHXMatrix(
Matrix : object
);

Parameters

Matrix

collall See Also

Reference

IText Interface
IText IText Members


IText.GetThickness Method

API Reference > CADViewLib Namespace > IText Interface > Methods >

IText.GetThickness Method

 Return to chapter overview

Show / hide the hidden text

Returns the line thickness for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetThickness() As Double

C#

override double GetThickness()

C++

double GetThickness()

JScript

function GetThickness() : double;

Return Value

A Double type value indicating the line thickness.

collall See Also

Reference

IText Interface
IText IText Members


IText.IndexOfEntity Method

API Reference > CADViewLib Namespace > IText Interface > Methods >

IText.IndexOfEntity Method

 Return to chapter overview

Show / hide the hidden text

Returns index of the given entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function IndexOfEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int IndexOfEntity(
EntityAEntity
)

C++

int IndexOfEntity(
Entity^ AEntity
)

JScript

function IndexOfEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity whose index is retrieved.

collall See Also

Reference

IText Interface
IText IText Members


IText.Iterate Method

API Reference > CADViewLib Namespace > IText Interface > Methods >

IText.Iterate Method

 Return to chapter overview

Show / hide the hidden text

Iterates through the entities in the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub Iterate( _
ByVal AConverter As Converter _
)

C#

override void Iterate(
ConverterAConverter
)

C++

void Iterate(
Converter^ AConverter
)

JScript

function Iterate(
AConverter : Converter
);

Parameters

AConverter

Converter which contains the drawing data.

collall See Also

Reference

IText Interface
IText IText Members


IText.RemoveEntity Method

API Reference > CADViewLib Namespace > IText Interface > Methods >

IText.RemoveEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes a specified entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function RemoveEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int RemoveEntity(
EntityAEntity
)

C++

int RemoveEntity(
Entity^ AEntity
)

JScript

function RemoveEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity which will be removed.

collall See Also

Reference

IText Interface
IText IText Members


IText.SetLType Method

API Reference > CADViewLib Namespace > IText Interface > Methods >

IText.SetLType Method

 Return to chapter overview

Show / hide the hidden text

Sets a line type for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLType( _
ByVal Value As Entity _
)

C#

override void SetLType(
EntityValue
)

C++

void SetLType(
Entity^ Value
)

JScript

function SetLType(
Value : Entity
);

Parameters

Value

The line type value.

collall See Also

Reference

IText Interface
IText IText Members


IText.SetLWeight Method

API Reference > CADViewLib Namespace > IText Interface > Methods >

IText.SetLWeight Method

 Return to chapter overview

Show / hide the hidden text

Sets a line weight for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLWeight( _
ByVal Value As Integer _
)

C#

override void SetLWeight(
intValue
)

C++

void SetLWeight(
intValue
)

JScript

function SetLWeight(
Value : int
);

Parameters

Value

The line weight value.

collall See Also

Reference

IText Interface
IText IText Members


IText.get_Entities Method

API Reference > CADViewLib Namespace > IText Interface > Methods >

IText.get_Entities Method

 Return to chapter overview

Show / hide the hidden text

Returns the child entity at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Entities( _
ByVal Index As Integer _
) As Entity

C#

override Entity get_Entities(
intIndex
)

C++

Entity^ get_Entities(
intIndex
)

JScript

function get_Entities(
Index : int
) : Entity;

Parameters

Index

The index of the entity to retrieve.

collall See Also

Reference

IText Interface
IText IText Members


IToolBox Interface

API Reference > CADViewLib Namespace >

IToolBox Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to the CADViewX toolbar.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface IToolBox

C#

public interface IToolBox

C++

public interface class IToolBox

JScript

public interface IToolBox

collall See Also

Reference

IToolBox Members


IToolBox Members

API Reference > CADViewLib Namespace > IToolBox Interface >

IToolBox Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to the CADViewX toolbar.

The following tables list the members exposed by the IToolBox type.

collall Public Properties

 | Name | Description
Public property | Caption | Gets or sets a caption for the toolbox.
Public property | Control | Gets the CADViewX control instance to which this toolbox belongs.
Public property | Enabled | Gets or sets a value indicating whether the toolbox is enabled.
Public property | Handle | Gets or sets a handle to the toolbox.
Public property | Height | Gets or sets the toolbox height.
Public property | ItemCount | Gets a number of toolbox items.
Public property | Left | Gets or sets the X-coordinate of the top-left corner.
Public property | Parent |
Public property | Top | Gets or sets the Y-coordinate of the top-left corner.
Public property | Visible | Gets or sets a value indicating whether the toolbox is visible.
Public property | Width | Gets or sets the toolbox width.

Top

collall Public Methods

 | Name | Description
Public method | Dock | Docks the toolbox to the frame of the CADViewX main window.
Public method | ItemClick | Triggers the mouse click on a specified toolbox button.
Public method | UnDock | Undocks the toolbox from the frame of the CADViewX main window.

Top

collall See Also

Reference

IToolBox Interface


IToolBox Properties

API Reference > CADViewLib Namespace > IToolBox Interface >

IToolBox Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Caption | Gets or sets a caption for the toolbox.
Public property | Control | Gets the CADViewX control instance to which this toolbox belongs.
Public property | Enabled | Gets or sets a value indicating whether the toolbox is enabled.
Public property | Handle | Gets or sets a handle to the toolbox.
Public property | Height | Gets or sets the toolbox height.
Public property | ItemCount | Gets a number of toolbox items.
Public property | Left | Gets or sets the X-coordinate of the top-left corner.
Public property | Parent |
Public property | Top | Gets or sets the Y-coordinate of the top-left corner.
Public property | Visible | Gets or sets a value indicating whether the toolbox is visible.
Public property | Width | Gets or sets the toolbox width.

Top

collall See Also

Reference

IToolBox Interface


IToolBox.Caption Property

API Reference > CADViewLib Namespace > IToolBox Interface > Properties >

IToolBox.Caption Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a caption for the toolbox.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Caption() As String

C#

string Caption {get; set;}

C++

property String^ Caption {
String^ get( );
void set(
String^ value
);
}

JScript

function get Caption() : String;
function set Caption(value : String);

collall See Also

Reference

IToolBox Interface
IToolBox IToolBox Members


IToolBox.Control Property

API Reference > CADViewLib Namespace > IToolBox Interface > Properties >

IToolBox.Control Property

 Return to chapter overview

Show / hide the hidden text

Gets the CADViewX control instance to which this toolbox belongs.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Control() As CADViewX

C#

CADViewX Control {get;}

C++

property CADViewX^ Control {
CADViewX^ get( );
}

JScript

function get Control() : CADViewX;

collall See Also

Reference

IToolBox Interface
IToolBox IToolBox Members


IToolBox.Enabled Property

API Reference > CADViewLib Namespace > IToolBox Interface > Properties >

IToolBox.Enabled Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the toolbox is enabled.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Enabled() As Boolean

C#

bool Enabled {get; set;}

C++

property bool Enabled {
bool get( );
void set(
bool value
);
}

JScript

function get Enabled() : boolean;
function set Enabled(value : boolean);

Property Value

true if the toolbox is enabled; otherwise, false.

collall See Also

Reference

IToolBox Interface
IToolBox IToolBox Members


IToolBox.Handle Property

API Reference > CADViewLib Namespace > IToolBox Interface > Properties >

IToolBox.Handle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a handle to the toolbox.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Handle() As Integer

C#

int Handle {get; set;}

C++

property int Handle {
int get( );
void set(
int value
);
}

JScript

function get Handle() : int;
function set Handle(value : int);

collall See Also

Reference

IToolBox Interface
IToolBox IToolBox Members


IToolBox.Height Property

API Reference > CADViewLib Namespace > IToolBox Interface > Properties >

IToolBox.Height Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the toolbox height.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Height() As Integer

C#

int Height {get; set;}

C++

property int Height {
int get( );
void set(
int value
);
}

JScript

function get Height() : int;
function set Height(value : int);

collall See Also

Reference

IToolBox Interface
IToolBox IToolBox Members


IToolBox.ItemCount Property

API Reference > CADViewLib Namespace > IToolBox Interface > Properties >

IToolBox.ItemCount Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of toolbox items.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property ItemCount() As Integer

C#

int ItemCount {get;}

C++

property int ItemCount {
int get( );
}

JScript

function get ItemCount() : int;

collall See Also

Reference

IToolBox Interface
IToolBox IToolBox Members


IToolBox.Left Property

API Reference > CADViewLib Namespace > IToolBox Interface > Properties >

IToolBox.Left Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the X-coordinate of the top-left corner.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Left() As Integer

C#

int Left {get; set;}

C++

property int Left {
int get( );
void set(
int value
);
}

JScript

function get Left() : int;
function set Left(value : int);

collall See Also

Reference

IToolBox Interface
IToolBox IToolBox Members


IToolBox.Parent Property

API Reference > CADViewLib Namespace > IToolBox Interface > Properties >

IToolBox.Parent Property

 Return to chapter overview

Show / hide the hidden text

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Parent() As Integer

C#

int Parent {get; set;}

C++

property int Parent {
int get( );
void set(
int value
);
}

JScript

function get Parent() : int;
function set Parent(value : int);

collall See Also

Reference

IToolBox Interface
IToolBox IToolBox Members


IToolBox.Top Property

API Reference > CADViewLib Namespace > IToolBox Interface > Properties >

IToolBox.Top Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the Y-coordinate of the top-left corner.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Top() As Integer

C#

int Top {get; set;}

C++

property int Top {
int get( );
void set(
int value
);
}

JScript

function get Top() : int;
function set Top(value : int);

collall See Also

Reference

IToolBox Interface
IToolBox IToolBox Members


IToolBox.Visible Property

API Reference > CADViewLib Namespace > IToolBox Interface > Properties >

IToolBox.Visible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether the toolbox is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visible() As Boolean

C#

bool Visible {get; set;}

C++

property bool Visible {
bool get( );
void set(
bool value
);
}

JScript

function get Visible() : boolean;
function set Visible(value : boolean);

Property Value

true if the toolbox is visible; otherwise, false.

collall See Also

Reference

IToolBox Interface
IToolBox IToolBox Members


IToolBox.Width Property

API Reference > CADViewLib Namespace > IToolBox Interface > Properties >

IToolBox.Width Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the toolbox width.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Width() As Integer

C#

int Width {get; set;}

C++

property int Width {
int get( );
void set(
int value
);
}

JScript

function get Width() : int;
function set Width(value : int);

collall See Also

Reference

IToolBox Interface
IToolBox IToolBox Members


IToolBox Methods

API Reference > CADViewLib Namespace > IToolBox Interface >

IToolBox Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | Dock | Docks the toolbox to the frame of the CADViewX main window.
Public method | ItemClick | Triggers the mouse click on a specified toolbox button.
Public method | UnDock | Undocks the toolbox from the frame of the CADViewX main window.

Top

collall See Also

Reference

IToolBox Interface


IToolBox.Dock Method

API Reference > CADViewLib Namespace > IToolBox Interface > Methods >

IToolBox.Dock Method

 Return to chapter overview

Show / hide the hidden text

Docks the toolbox to the frame of the CADViewX main window.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub Dock()

C#

void Dock()

C++

void Dock()

JScript

function Dock();

collall See Also

Reference

IToolBox Interface
IToolBox IToolBox Members


IToolBox.ItemClick Method

API Reference > CADViewLib Namespace > IToolBox Interface > Methods >

IToolBox.ItemClick Method

 Return to chapter overview

Show / hide the hidden text

Triggers the mouse click on a specified toolbox button.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub ItemClick( _
ByVal ToolButton As TxToolButton _
)

C#

void ItemClick(
TxToolButtonToolButton
)

C++

void ItemClick(
TxToolButtonToolButton
)

JScript

function ItemClick(
ToolButton : TxToolButton
);

Parameters

ToolButton

The toolbox button to click.

collall See Also

Reference

IToolBox Interface
IToolBox IToolBox Members


IToolBox.UnDock Method

API Reference > CADViewLib Namespace > IToolBox Interface > Methods >

IToolBox.UnDock Method

 Return to chapter overview

Show / hide the hidden text

Undocks the toolbox from the frame of the CADViewX main window.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Sub UnDock()

C#

void UnDock()

C++

void UnDock()

JScript

function UnDock();

collall See Also

Reference

IToolBox Interface
IToolBox IToolBox Members


IVertex Interface

API Reference > CADViewLib Namespace >

IVertex Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to VERTEX entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface IVertex
Inherits IEntity

C#

public interface IVertex : IEntity

C++

public interface class IVertex : public IEntity^

JScript

public interface IVertex
implements IEntity

collall See Also

Reference

IVertex Members


IVertex Members

API Reference > CADViewLib Namespace > IVertex Interface >

IVertex Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to VERTEX entities.

The following tables list the members exposed by the IVertex type.

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | Bulge | Gets or sets the bulge value for this vertex.
Public property | CADHandle | Gets or sets the object handle.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | EndWidth | Gets or sets the ending width.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Flags | Gets or sets vertex flags.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | Name | Gets or sets a name of this object.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | Point | Gets or sets the location point for this vertex.
Public property | PolyFaceVertexIndex1 | Gets or sets polyface mesh vertex index.
Public property | PolyFaceVertexIndex2 | Gets or sets polyface mesh vertex index.
Public property | PolyFaceVertexIndex3 | Gets or sets polyface mesh vertex index.
Public property | PolyFaceVertexIndex4 | Gets or sets polyface mesh vertex index.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | StartWidth | Gets or sets the starting width.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetBoxPoints | For internal use.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Entities | Returns the child entity at the given index.

Top

collall See Also

Reference

IVertex Interface


IVertex Properties

API Reference > CADViewLib Namespace > IVertex Interface >

IVertex Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object.
Public property | Bulge | Gets or sets the bulge value for this vertex.
Public property | CADHandle | Gets or sets the object handle.
Public property | Color | Gets or sets a color of the object.
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs.
Public property | Count | Gets a number of objects contained within the given object.
Public property | EndWidth | Gets or sets the ending width.
Public property | EntID | Gets or sets the entity type ID for this object.
Public property | Extrusion | Gets or sets the extrusion direction vector for this object.
Public property | Flags | Gets or sets vertex flags.
Public property | Layer | Gets or sets a layer containing this object.
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length.
Public property | Name | Gets or sets a name of this object.
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space.
Public property | Point | Gets or sets the location point for this vertex.
Public property | PolyFaceVertexIndex1 | Gets or sets polyface mesh vertex index.
Public property | PolyFaceVertexIndex2 | Gets or sets polyface mesh vertex index.
Public property | PolyFaceVertexIndex3 | Gets or sets polyface mesh vertex index.
Public property | PolyFaceVertexIndex4 | Gets or sets polyface mesh vertex index.
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file.
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file.
Public property | StartWidth | Gets or sets the starting width.
Public property | Visibility | Gets or sets a value indicating whether this object is visible.
Public property | Visible | Gets or sets a value indicating whether this object is visible.

Top

collall See Also

Reference

IVertex Interface


IVertex.Box Property

API Reference > CADViewLib Namespace > IVertex Interface > Properties >

IVertex.Box Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the bounding parallelepiped for the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Box() As Rect3D

C#

Rect3D Box {get;}

C++

property Rect3D^ Box {
Rect3D^ get( );
}

JScript

function get Box() : Rect3D;

Property Value

The parallelepiped which encloses the object.

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.Bulge Property

API Reference > CADViewLib Namespace > IVertex Interface > Properties >

IVertex.Bulge Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the bulge value for this vertex.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Bulge() As Double

C#

double Bulge {get; set;}

C++

property double Bulge {
double get( );
void set(
double value
);
}

JScript

function get Bulge() : double;
function set Bulge(value : double);

Property Value

Default is 0.

collall Remarks

The bulge is the tangent of one fourth the included angle for an arc segment, made negative if the arc goes clockwise from the start point to the endpoint. A bulge of 0 indicates a straight segment, and a bulge of 1 is a semicircle.

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.CADHandle Property

API Reference > CADViewLib Namespace > IVertex Interface > Properties >

IVertex.CADHandle Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the object handle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property CADHandle() As UInt64

C#

UInt64 CADHandle {get; set;}

C++

property UInt64 CADHandle {
UInt64 get( );
void set(
UInt64 value
);
}

JScript

function get CADHandle() : UInt64;
function set CADHandle(value : UInt64);

Property Value

Number that uniquely identifies the object in a CAD drawing.

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.Color Property

API Reference > CADViewLib Namespace > IVertex Interface > Properties >

IVertex.Color Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a color of the object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Color() As UInt32

C#

UInt32 Color {get; set;}

C++

property UInt32 Color {
UInt32 get( );
void set(
UInt32 value
);
}

JScript

function get Color() : UInt32;
function set Color(value : UInt32);

Property Value

An insigned integer value which defines the object's color.

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.Converter Property

API Reference > CADViewLib Namespace > IVertex Interface > Properties >

IVertex.Converter Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a Converter instance associated with the CAD image to which this object belongs.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Converter() As Converter

C#

Converter Converter {get;}

C++

property Converter^ Converter {
Converter^ get( );
}

JScript

function get Converter() : Converter;

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.Count Property

API Reference > CADViewLib Namespace > IVertex Interface > Properties >

IVertex.Count Property

 Return to chapter overview

Show / hide the hidden text

Gets a number of objects contained within the given object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

ReadOnly Property Count() As Integer

C#

int Count {get;}

C++

property int Count {
int get( );
}

JScript

function get Count() : int;

Property Value

An Integer value indicating a number of objects contained within the given object.

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.EndWidth Property

API Reference > CADViewLib Namespace > IVertex Interface > Properties >

IVertex.EndWidth Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the ending width.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property EndWidth() As Single

C#

float EndWidth {get; set;}

C++

property float EndWidth {
float get( );
void set(
float value
);
}

JScript

function get EndWidth() : float;
function set EndWidth(value : float);

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.EntID Property

API Reference > CADViewLib Namespace > IVertex Interface > Properties >

IVertex.EntID Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the entity type ID for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property EntID() As TEntityID

C#

TEntityID EntID {get; set;}

C++

property TEntityID EntID {
TEntityID get( );
void set(
TEntityID value
);
}

JScript

function get EntID() : TEntityID;
function set EntID(value : TEntityID);

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.Extrusion Property

API Reference > CADViewLib Namespace > IVertex Interface > Properties >

IVertex.Extrusion Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the extrusion direction vector for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Extrusion() As Point3D

C#

Point3D Extrusion {get; set;}

C++

property Point3D^ Extrusion {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Extrusion() : Point3D;
function set Extrusion(value : Point3D);

Property Value

The 3D point which defines the extrusion direction vector.

collall Remarks

The extrusion direction is the normal vector of the plane which contains the entity and it is applied to the entity base point. The default extrusion direction value is (0, 0, 1).

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.Flags Property

API Reference > CADViewLib Namespace > IVertex Interface > Properties >

IVertex.Flags Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets vertex flags.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Flags() As Byte

C#

byte Flags {get; set;}

C++

property Byte Flags {
Byte get( );
void set(
Byte value
);
}

JScript

function get Flags() : byte;
function set Flags(value : byte);

Property Value

1 = Extra vertex created by curve-fitting
2 = Curve-fit tangent defined for this vertex. A curve-fit tangent direction of 0 may be omitted from DXF output but is significant if this bit is set
4 = Not used
8 = Spline vertex created by spline-fitting
16 = Spline frame control point
32 = 3D polyline vertex
64 = 3D polygon mesh
128 = Polyface mesh vertex

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.Layer Property

API Reference > CADViewLib Namespace > IVertex Interface > Properties >

IVertex.Layer Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a layer containing this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Layer() As Layer

C#

Layer Layer {get; set;}

C++

property Layer^ Layer {
Layer^ get( );
void set(
Layer^ value
);
}

JScript

function get Layer() : Layer;
function set Layer(value : Layer);

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.LineTypeScale Property

API Reference > CADViewLib Namespace > IVertex Interface > Properties >

IVertex.LineTypeScale Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a quantity of line type elements per unit of its length.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property LineTypeScale() As Single

C#

float LineTypeScale {get; set;}

C++

property float LineTypeScale {
float get( );
void set(
float value
);
}

JScript

function get LineTypeScale() : float;
function set LineTypeScale(value : float);

Property Value

The quantity of linetype elements per unit of its length.

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.Name Property

API Reference > CADViewLib Namespace > IVertex Interface > Properties >

IVertex.Name Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a name of this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Name() As String

C#

string Name {get; set;}

C++

property String^ Name {
String^ get( );
void set(
String^ value
);
}

JScript

function get Name() : String;
function set Name(value : String);

Property Value

String containing the object name.

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.PaperSpace Property

API Reference > CADViewLib Namespace > IVertex Interface > Properties >

IVertex.PaperSpace Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is located in Paper space.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PaperSpace() As Integer

C#

int PaperSpace {get; set;}

C++

property int PaperSpace {
int get( );
void set(
int value
);
}

JScript

function get PaperSpace() : int;
function set PaperSpace(value : int);

Property Value

0 - the object is located in Model space, 1 - in Paper space.

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.Point Property

API Reference > CADViewLib Namespace > IVertex Interface > Properties >

IVertex.Point Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the location point for this vertex.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Point() As Point3D

C#

Point3D Point {get; set;}

C++

property Point3D^ Point {
Point3D^ get( );
void set(
Point3D^ value
);
}

JScript

function get Point() : Point3D;
function set Point(value : Point3D);

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.PolyFaceVertexIndex1 Property

API Reference > CADViewLib Namespace > IVertex Interface > Properties >

IVertex.PolyFaceVertexIndex1 Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets polyface mesh vertex index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PolyFaceVertexIndex1() As Integer

C#

int PolyFaceVertexIndex1 {get; set;}

C++

property int PolyFaceVertexIndex1 {
int get( );
void set(
int value
);
}

JScript

function get PolyFaceVertexIndex1() : int;
function set PolyFaceVertexIndex1(value : int);

collall Remarks

If the index is negative, the edge that begins with that vertex is invisible. The first 0 vertex marks the end of the vertices of the face.

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.PolyFaceVertexIndex2 Property

API Reference > CADViewLib Namespace > IVertex Interface > Properties >

IVertex.PolyFaceVertexIndex2 Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets polyface mesh vertex index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PolyFaceVertexIndex2() As Integer

C#

int PolyFaceVertexIndex2 {get; set;}

C++

property int PolyFaceVertexIndex2 {
int get( );
void set(
int value
);
}

JScript

function get PolyFaceVertexIndex2() : int;
function set PolyFaceVertexIndex2(value : int);

collall Remarks

If the index is negative, the edge that begins with that vertex is invisible. The first 0 vertex marks the end of the vertices of the face.

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.PolyFaceVertexIndex3 Property

API Reference > CADViewLib Namespace > IVertex Interface > Properties >

IVertex.PolyFaceVertexIndex3 Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets polyface mesh vertex index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PolyFaceVertexIndex3() As Integer

C#

int PolyFaceVertexIndex3 {get; set;}

C++

property int PolyFaceVertexIndex3 {
int get( );
void set(
int value
);
}

JScript

function get PolyFaceVertexIndex3() : int;
function set PolyFaceVertexIndex3(value : int);

collall Remarks

If the index is negative, the edge that begins with that vertex is invisible. The first 0 vertex marks the end of the vertices of the face.

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.PolyFaceVertexIndex4 Property

API Reference > CADViewLib Namespace > IVertex Interface > Properties >

IVertex.PolyFaceVertexIndex4 Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets polyface mesh vertex index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property PolyFaceVertexIndex4() As Integer

C#

int PolyFaceVertexIndex4 {get; set;}

C++

property int PolyFaceVertexIndex4 {
int get( );
void set(
int value
);
}

JScript

function get PolyFaceVertexIndex4() : int;
function set PolyFaceVertexIndex4(value : int);

collall Remarks

If the index is negative, the edge that begins with that vertex is invisible. The first 0 vertex marks the end of the vertices of the face.

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.SrcEnd Property

API Reference > CADViewLib Namespace > IVertex Interface > Properties >

IVertex.SrcEnd Property

 Return to chapter overview

Show / hide the hidden text

Indicates the end of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcEnd() As String

C#

string SrcEnd {get; set;}

C++

property String^ SrcEnd {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcEnd() : String;
function set SrcEnd(value : String);

Property Value

A String value indicating the end of the record which represents this object in a drawing file.

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.SrcStart Property

API Reference > CADViewLib Namespace > IVertex Interface > Properties >

IVertex.SrcStart Property

 Return to chapter overview

Show / hide the hidden text

Indicates the beginning of the record which represents this object in an drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property SrcStart() As String

C#

string SrcStart {get; set;}

C++

property String^ SrcStart {
String^ get( );
void set(
String^ value
);
}

JScript

function get SrcStart() : String;
function set SrcStart(value : String);

Property Value

A String value indicating the beginning of the record which represents this object in a drawing file.

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.StartWidth Property

API Reference > CADViewLib Namespace > IVertex Interface > Properties >

IVertex.StartWidth Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets the starting width.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property StartWidth() As Single

C#

float StartWidth {get; set;}

C++

property float StartWidth {
float get( );
void set(
float value
);
}

JScript

function get StartWidth() : float;
function set StartWidth(value : float);

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.Visibility Property

API Reference > CADViewLib Namespace > IVertex Interface > Properties >

IVertex.Visibility Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visibility() As Boolean

C#

bool Visibility {get; set;}

C++

property bool Visibility {
bool get( );
void set(
bool value
);
}

JScript

function get Visibility() : boolean;
function set Visibility(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.Visible Property

API Reference > CADViewLib Namespace > IVertex Interface > Properties >

IVertex.Visible Property

 Return to chapter overview

Show / hide the hidden text

Gets or sets a value indicating whether this object is visible.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Property Visible() As Boolean

C#

bool Visible {get; set;}

C++

property bool Visible {
bool get( );
void set(
bool value
);
}

JScript

function get Visible() : boolean;
function set Visible(value : boolean);

Property Value

true if the object is visible; otherwise, false.

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex Methods

API Reference > CADViewLib Namespace > IVertex Interface >

IVertex Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object.
Public method | AssignEntity | Assigns the properties of the specified entity to this object.
Public method | CreateEntity | Initializes a new object instance.
Public method | DeleteEntity | Removes an entity specified by index.
Public method | EntName | Returns a name of the entity.
Public method | FreeEntity | Destroys the object instance.
Public method | GetBoxPoints | For internal use.
Public method | GetThickness | Returns the line thickness for this object.
Public method | IndexOfEntity | Returns index of the given entity.
Public method | Iterate | Iterates through the entities in the drawing database.
Public method | RemoveEntity | Removes a specified entity.
Public method | SetLType | Sets a line type for this object.
Public method | SetLWeight | Sets a line weight for this object.
Public method | get_Entities | Returns the child entity at the given index.

Top

collall See Also

Reference

IVertex Interface


IVertex.AddEntity Method

API Reference > CADViewLib Namespace > IVertex Interface > Methods >

IVertex.AddEntity Method

 Return to chapter overview

Show / hide the hidden text

Adds a new child entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AddEntity( _
ByVal AEntity As Entity _
)

C#

override void AddEntity(
EntityAEntity
)

C++

void AddEntity(
Entity^ AEntity
)

JScript

function AddEntity(
AEntity : Entity
);

Parameters

AEntity

Added entity.

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.AssignEntity Method

API Reference > CADViewLib Namespace > IVertex Interface > Methods >

IVertex.AssignEntity Method

 Return to chapter overview

Show / hide the hidden text

Assigns the properties of the specified entity to this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub AssignEntity( _
ByVal Source As Entity _
)

C#

override void AssignEntity(
EntitySource
)

C++

void AssignEntity(
Entity^ Source
)

JScript

function AssignEntity(
Source : Entity
);

Parameters

Source

Entity which has the same type as the current object.

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.CreateEntity Method

API Reference > CADViewLib Namespace > IVertex Interface > Methods >

IVertex.CreateEntity Method

 Return to chapter overview

Show / hide the hidden text

Initializes a new object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub CreateEntity()

C#

override void CreateEntity()

C++

void CreateEntity()

JScript

function CreateEntity();

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.DeleteEntity Method

API Reference > CADViewLib Namespace > IVertex Interface > Methods >

IVertex.DeleteEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes an entity specified by index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub DeleteEntity( _
ByVal AIndex As Integer _
)

C#

override void DeleteEntity(
intAIndex
)

C++

void DeleteEntity(
intAIndex
)

JScript

function DeleteEntity(
AIndex : int
);

Parameters

AIndex

Index of the entity.

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.EntName Method

API Reference > CADViewLib Namespace > IVertex Interface > Methods >

IVertex.EntName Method

 Return to chapter overview

Show / hide the hidden text

Returns a name of the entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function EntName() As String

C#

override string EntName()

C++

String^ EntName()

JScript

function EntName() : String;

Return Value

A string containing the entity name.

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.FreeEntity Method

API Reference > CADViewLib Namespace > IVertex Interface > Methods >

IVertex.FreeEntity Method

 Return to chapter overview

Show / hide the hidden text

Destroys the object instance.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub FreeEntity()

C#

override void FreeEntity()

C++

void FreeEntity()

JScript

function FreeEntity();

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.GetBoxPoints Method

API Reference > CADViewLib Namespace > IVertex Interface > Methods >

IVertex.GetBoxPoints Method

 Return to chapter overview

Show / hide the hidden text

For internal use.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetBoxPoints( _
ByVal Full As Boolean _
) As Boolean

C#

override bool GetBoxPoints(
boolFull
)

C++

bool GetBoxPoints(
boolFull
)

JScript

function GetBoxPoints(
Full : boolean
) : boolean;

Parameters

Full

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.GetThickness Method

API Reference > CADViewLib Namespace > IVertex Interface > Methods >

IVertex.GetThickness Method

 Return to chapter overview

Show / hide the hidden text

Returns the line thickness for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function GetThickness() As Double

C#

override double GetThickness()

C++

double GetThickness()

JScript

function GetThickness() : double;

Return Value

A Double type value indicating the line thickness.

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.IndexOfEntity Method

API Reference > CADViewLib Namespace > IVertex Interface > Methods >

IVertex.IndexOfEntity Method

 Return to chapter overview

Show / hide the hidden text

Returns index of the given entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function IndexOfEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int IndexOfEntity(
EntityAEntity
)

C++

int IndexOfEntity(
Entity^ AEntity
)

JScript

function IndexOfEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity whose index is retrieved.

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.Iterate Method

API Reference > CADViewLib Namespace > IVertex Interface > Methods >

IVertex.Iterate Method

 Return to chapter overview

Show / hide the hidden text

Iterates through the entities in the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub Iterate( _
ByVal AConverter As Converter _
)

C#

override void Iterate(
ConverterAConverter
)

C++

void Iterate(
Converter^ AConverter
)

JScript

function Iterate(
AConverter : Converter
);

Parameters

AConverter

Converter which contains the drawing data.

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.RemoveEntity Method

API Reference > CADViewLib Namespace > IVertex Interface > Methods >

IVertex.RemoveEntity Method

 Return to chapter overview

Show / hide the hidden text

Removes a specified entity.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function RemoveEntity( _
ByVal AEntity As Entity _
) As Integer

C#

override int RemoveEntity(
EntityAEntity
)

C++

int RemoveEntity(
Entity^ AEntity
)

JScript

function RemoveEntity(
AEntity : Entity
) : int;

Parameters

AEntity

The entity which will be removed.

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.SetLType Method

API Reference > CADViewLib Namespace > IVertex Interface > Methods >

IVertex.SetLType Method

 Return to chapter overview

Show / hide the hidden text

Sets a line type for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLType( _
ByVal Value As Entity _
)

C#

override void SetLType(
EntityValue
)

C++

void SetLType(
Entity^ Value
)

JScript

function SetLType(
Value : Entity
);

Parameters

Value

The line type value.

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.SetLWeight Method

API Reference > CADViewLib Namespace > IVertex Interface > Methods >

IVertex.SetLWeight Method

 Return to chapter overview

Show / hide the hidden text

Sets a line weight for this object.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Sub SetLWeight( _
ByVal Value As Integer _
)

C#

override void SetLWeight(
intValue
)

C++

void SetLWeight(
intValue
)

JScript

function SetLWeight(
Value : int
);

Parameters

Value

The line weight value.

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


IVertex.get_Entities Method

API Reference > CADViewLib Namespace > IVertex Interface > Methods >

IVertex.get_Entities Method

 Return to chapter overview

Show / hide the hidden text

Returns the child entity at the given index.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Overrides Function get_Entities( _
ByVal Index As Integer _
) As Entity

C#

override Entity get_Entities(
intIndex
)

C++

Entity^ get_Entities(
intIndex
)

JScript

function get_Entities(
Index : int
) : Entity;

Parameters

Index

The index of the entity to retrieve.

collall See Also

Reference

IVertex Interface
IVertex IVertex Members


ImageEnt Interface

API Reference > CADViewLib Namespace >

ImageEnt Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to IMAGE entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface ImageEnt
Inherits IImageEnt, _
IEllipseEvents_Event

C#

public interface ImageEnt : IImageEnt,
IEllipseEvents_Event

C++

public interface class ImageEnt : public IImageEnt^,
public IEllipseEvents_Event^

JScript

public interface ImageEnt
implements IImageEnt,
IEllipseEvents_Event

collall See Also

Reference

ImageEnt Members


ImageEnt Members

API Reference > CADViewLib Namespace > ImageEnt Interface >

ImageEnt Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to IMAGE entities.

The following tables list the members exposed by the ImageEnt type.

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from IImageEnt ).
Public property | CADHandle | Gets or sets the object handle. (inherited from IImageEnt ).
Public property | Color | Gets or sets a color of the object. (inherited from IImageEnt ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from IImageEnt ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from IImageEnt ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from IImageEnt ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from IImageEnt ).
Public property | ImageDef | Gets or sets a hard reference to ImageDef object. (inherited from IImageEnt ).
Public property | IsMonoChrome | Gets or sets a value indicating whether the image is monochromatic. (inherited from IImageEnt ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from IImageEnt ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from IImageEnt ).
Public property | Name | Gets or sets a name of this object. (inherited from IImageEnt ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from IImageEnt ).
Public property | Picture | Gets or sets a graphics stored in the image entity. (inherited from IImageEnt ).
Public property | Point | Gets or sets the insertion point (in WCS). (inherited from IImageEnt ).
Public property | Point1 | Gets or sets U-vector of a single pixel (points along the visual bottom of the image, starting at the insertion point) (in WCS). (inherited from IImageEnt ).
Public property | Point2 | Gets or sets V-vector of a single pixel (points along the visual left side of the image, starting at the insertion point) (in WCS). (inherited from IImageEnt ).
Public property | Point3 | Gets or sets a scale vector. (inherited from IImageEnt ).
Public property | Rotate | Gets or sets a rotation angle for the image entity. (inherited from IImageEnt ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from IImageEnt ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from IImageEnt ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from IImageEnt ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from IImageEnt ).

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from IImageEnt ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from IImageEnt ).
Public method | CreateEntity | Initializes a new object instance. (inherited from IImageEnt ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from IImageEnt ).
Public method | EntName | Returns a name of the entity. (inherited from IImageEnt ).
Public method | FindPicture | Obsolete. (inherited from IImageEnt ).
Public method | FreeEntity | Destroys the object instance. (inherited from IImageEnt ).
Public method | GetBoxPoints | For internal use. (inherited from IImageEnt ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from IImageEnt ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from IImageEnt ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from IImageEnt ).
Public method | RemoveEntity | Removes a specified entity. (inherited from IImageEnt ).
Public method | SetLType | Sets a line type for this object. (inherited from IImageEnt ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from IImageEnt ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from IImageEnt ).

Top

collall See Also

Reference

ImageEnt Interface


ImageEnt Properties

API Reference > CADViewLib Namespace > ImageEnt Interface >

ImageEnt Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from IImageEnt ).
Public property | CADHandle | Gets or sets the object handle. (inherited from IImageEnt ).
Public property | Color | Gets or sets a color of the object. (inherited from IImageEnt ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from IImageEnt ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from IImageEnt ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from IImageEnt ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from IImageEnt ).
Public property | ImageDef | Gets or sets a hard reference to ImageDef object. (inherited from IImageEnt ).
Public property | IsMonoChrome | Gets or sets a value indicating whether the image is monochromatic. (inherited from IImageEnt ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from IImageEnt ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from IImageEnt ).
Public property | Name | Gets or sets a name of this object. (inherited from IImageEnt ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from IImageEnt ).
Public property | Picture | Gets or sets a graphics stored in the image entity. (inherited from IImageEnt ).
Public property | Point | Gets or sets the insertion point (in WCS). (inherited from IImageEnt ).
Public property | Point1 | Gets or sets U-vector of a single pixel (points along the visual bottom of the image, starting at the insertion point) (in WCS). (inherited from IImageEnt ).
Public property | Point2 | Gets or sets V-vector of a single pixel (points along the visual left side of the image, starting at the insertion point) (in WCS). (inherited from IImageEnt ).
Public property | Point3 | Gets or sets a scale vector. (inherited from IImageEnt ).
Public property | Rotate | Gets or sets a rotation angle for the image entity. (inherited from IImageEnt ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from IImageEnt ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from IImageEnt ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from IImageEnt ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from IImageEnt ).

Top

collall See Also

Reference

ImageEnt Interface


ImageEnt Methods

API Reference > CADViewLib Namespace > ImageEnt Interface >

ImageEnt Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from IImageEnt ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from IImageEnt ).
Public method | CreateEntity | Initializes a new object instance. (inherited from IImageEnt ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from IImageEnt ).
Public method | EntName | Returns a name of the entity. (inherited from IImageEnt ).
Public method | FindPicture | Obsolete. (inherited from IImageEnt ).
Public method | FreeEntity | Destroys the object instance. (inherited from IImageEnt ).
Public method | GetBoxPoints | For internal use. (inherited from IImageEnt ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from IImageEnt ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from IImageEnt ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from IImageEnt ).
Public method | RemoveEntity | Removes a specified entity. (inherited from IImageEnt ).
Public method | SetLType | Sets a line type for this object. (inherited from IImageEnt ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from IImageEnt ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from IImageEnt ).

Top

collall See Also

Reference

ImageEnt Interface


Insert Interface

API Reference > CADViewLib Namespace >

Insert Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to INSERT entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface Insert
Inherits IInsert, _
IEntityEvents_Event

C#

public interface Insert : IInsert,
IEntityEvents_Event

C++

public interface class Insert : public IInsert^,
public IEntityEvents_Event^

JScript

public interface Insert
implements IInsert,
IEntityEvents_Event

collall See Also

Reference

Insert Members


Insert Members

API Reference > CADViewLib Namespace > Insert Interface >

Insert Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to INSERT entities.

The following tables list the members exposed by the Insert type.

collall Public Properties

 | Name | Description
Public property | Angle | Gets or sets a rotation angle. (inherited from IInsert ).
Public property | AttribsCount | Gets a number of the attributes. (inherited from IInsert ).
Public property | Block | Gets or sets the block definition. (inherited from IInsert ).
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from IInsert ).
Public property | CADHandle | Gets or sets the object handle. (inherited from IInsert ).
Public property | Color | Gets or sets a color of the object. (inherited from IInsert ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from IInsert ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from IInsert ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from IInsert ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from IInsert ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from IInsert ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from IInsert ).
Public property | Name | Gets or sets a name of this object. (inherited from IInsert ).
Public property | Owner | Gets the block reference which contains this block reference (when blocks are nested). (inherited from IInsert ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from IInsert ).
Public property | Point | Gets or sets the insertion point (in WCS). (inherited from IInsert ).
Public property | Scale | Gets or sets a scale factor. (inherited from IInsert ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from IInsert ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from IInsert ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from IInsert ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from IInsert ).

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from IInsert ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from IInsert ).
Public method | Attrib | Returns the attribute with the given tag. (inherited from IInsert ).
Public method | CreateEntity | Initializes a new object instance. (inherited from IInsert ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from IInsert ).
Public method | EntName | Returns a name of the entity. (inherited from IInsert ).
Public method | FindBlock | Searches for a block definition with the given name. (inherited from IInsert ).
Public method | FreeEntity | Destroys the object instance. (inherited from IInsert ).
Public method | GetBoxPoints | For internal use. (inherited from IInsert ).
Public method | GetMatrix | Returns a coordinate transformation matrix for this object. (inherited from IInsert ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from IInsert ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from IInsert ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from IInsert ).
Public method | RealColor | Returns the actual color value for a specified color. (inherited from IInsert ).
Public method | RealLayer | Returns the actual layer for the block reference. (inherited from IInsert ).
Public method | RemoveEntity | Removes a specified entity. (inherited from IInsert ).
Public method | SetLType | Sets a line type for this object. (inherited from IInsert ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from IInsert ).
Public method | SetMatrix | Sets a coordinate transformation matrix for this object. (inherited from IInsert ).
Public method | get_Attribs | Returns the attribute at the given index. (inherited from IInsert ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from IInsert ).

Top

collall See Also

Reference

Insert Interface


Insert Properties

API Reference > CADViewLib Namespace > Insert Interface >

Insert Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Angle | Gets or sets a rotation angle. (inherited from IInsert ).
Public property | AttribsCount | Gets a number of the attributes. (inherited from IInsert ).
Public property | Block | Gets or sets the block definition. (inherited from IInsert ).
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from IInsert ).
Public property | CADHandle | Gets or sets the object handle. (inherited from IInsert ).
Public property | Color | Gets or sets a color of the object. (inherited from IInsert ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from IInsert ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from IInsert ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from IInsert ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from IInsert ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from IInsert ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from IInsert ).
Public property | Name | Gets or sets a name of this object. (inherited from IInsert ).
Public property | Owner | Gets the block reference which contains this block reference (when blocks are nested). (inherited from IInsert ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from IInsert ).
Public property | Point | Gets or sets the insertion point (in WCS). (inherited from IInsert ).
Public property | Scale | Gets or sets a scale factor. (inherited from IInsert ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from IInsert ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from IInsert ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from IInsert ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from IInsert ).

Top

collall See Also

Reference

Insert Interface


Insert Methods

API Reference > CADViewLib Namespace > Insert Interface >

Insert Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from IInsert ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from IInsert ).
Public method | Attrib | Returns the attribute with the given tag. (inherited from IInsert ).
Public method | CreateEntity | Initializes a new object instance. (inherited from IInsert ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from IInsert ).
Public method | EntName | Returns a name of the entity. (inherited from IInsert ).
Public method | FindBlock | Searches for a block definition with the given name. (inherited from IInsert ).
Public method | FreeEntity | Destroys the object instance. (inherited from IInsert ).
Public method | GetBoxPoints | For internal use. (inherited from IInsert ).
Public method | GetMatrix | Returns a coordinate transformation matrix for this object. (inherited from IInsert ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from IInsert ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from IInsert ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from IInsert ).
Public method | RealColor | Returns the actual color value for a specified color. (inherited from IInsert ).
Public method | RealLayer | Returns the actual layer for the block reference. (inherited from IInsert ).
Public method | RemoveEntity | Removes a specified entity. (inherited from IInsert ).
Public method | SetLType | Sets a line type for this object. (inherited from IInsert ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from IInsert ).
Public method | SetMatrix | Sets a coordinate transformation matrix for this object. (inherited from IInsert ).
Public method | get_Attribs | Returns the attribute at the given index. (inherited from IInsert ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from IInsert ).

Top

collall See Also

Reference

Insert Interface


Layer Interface

API Reference > CADViewLib Namespace >

Layer Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to LAYER objects.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface Layer
Inherits ILayer, _
IEntityEvents_Event

C#

public interface Layer : ILayer,
IEntityEvents_Event

C++

public interface class Layer : public ILayer^,
public IEntityEvents_Event^

JScript

public interface Layer
implements ILayer,
IEntityEvents_Event

collall See Also

Reference

Layer Members


Layer Members

API Reference > CADViewLib Namespace > Layer Interface >

Layer Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to LAYER objects.

The following tables list the members exposed by the Layer type.

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from ILayer ).
Public property | CADHandle | Gets or sets the object handle. (inherited from ILayer ).
Public property | Color | Gets or sets a color of the object. (inherited from ILayer ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from ILayer ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from ILayer ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from ILayer ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from ILayer ).
Public property | Flags | Gets or sets the layer flags (bit-coded values). (inherited from ILayer ).
Public property | Frozen | Gets or sets a value indicating whether the layer is frozen. (inherited from ILayer ).
Public property | IsFrozenByViewPort | Gets or sets a value indicating whether the layer is frozen by default in new viewports. (inherited from ILayer ).
Public property | IsPlotting | Gets or sets a value indicating whether to plot this layer or not. (inherited from ILayer ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from ILayer ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from ILayer ).
Public property | Name | Gets or sets a name of this object. (inherited from ILayer ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from ILayer ).
Public property | PenColor | Gets or sets a pen color for this layer. (inherited from ILayer ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from ILayer ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from ILayer ).
Public property | Used | Gets a value indicating whether this layer contains entities. (inherited from ILayer ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from ILayer ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from ILayer ).

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from ILayer ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from ILayer ).
Public method | CreateEntity | Initializes a new object instance. (inherited from ILayer ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from ILayer ).
Public method | EntName | Returns a name of the entity. (inherited from ILayer ).
Public method | FreeEntity | Destroys the object instance. (inherited from ILayer ).
Public method | GetBoxPoints | For internal use. (inherited from ILayer ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from ILayer ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from ILayer ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from ILayer ).
Public method | RemoveEntity | Removes a specified entity. (inherited from ILayer ).
Public method | SetLType | Sets a line type for this object. (inherited from ILayer ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from ILayer ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from ILayer ).

Top

collall See Also

Reference

Layer Interface


Layer Properties

API Reference > CADViewLib Namespace > Layer Interface >

Layer Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from ILayer ).
Public property | CADHandle | Gets or sets the object handle. (inherited from ILayer ).
Public property | Color | Gets or sets a color of the object. (inherited from ILayer ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from ILayer ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from ILayer ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from ILayer ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from ILayer ).
Public property | Flags | Gets or sets the layer flags (bit-coded values). (inherited from ILayer ).
Public property | Frozen | Gets or sets a value indicating whether the layer is frozen. (inherited from ILayer ).
Public property | IsFrozenByViewPort | Gets or sets a value indicating whether the layer is frozen by default in new viewports. (inherited from ILayer ).
Public property | IsPlotting | Gets or sets a value indicating whether to plot this layer or not. (inherited from ILayer ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from ILayer ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from ILayer ).
Public property | Name | Gets or sets a name of this object. (inherited from ILayer ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from ILayer ).
Public property | PenColor | Gets or sets a pen color for this layer. (inherited from ILayer ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from ILayer ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from ILayer ).
Public property | Used | Gets a value indicating whether this layer contains entities. (inherited from ILayer ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from ILayer ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from ILayer ).

Top

collall See Also

Reference

Layer Interface


Layer Methods

API Reference > CADViewLib Namespace > Layer Interface >

Layer Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from ILayer ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from ILayer ).
Public method | CreateEntity | Initializes a new object instance. (inherited from ILayer ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from ILayer ).
Public method | EntName | Returns a name of the entity. (inherited from ILayer ).
Public method | FreeEntity | Destroys the object instance. (inherited from ILayer ).
Public method | GetBoxPoints | For internal use. (inherited from ILayer ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from ILayer ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from ILayer ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from ILayer ).
Public method | RemoveEntity | Removes a specified entity. (inherited from ILayer ).
Public method | SetLType | Sets a line type for this object. (inherited from ILayer ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from ILayer ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from ILayer ).

Top

collall See Also

Reference

Layer Interface


Layout Interface

API Reference > CADViewLib Namespace >

Layout Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to LAYOUT objects.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface Layout
Inherits ILayout, _
IEntityEvents_Event

C#

public interface Layout : ILayout,
IEntityEvents_Event

C++

public interface class Layout : public ILayout^,
public IEntityEvents_Event^

JScript

public interface Layout
implements ILayout,
IEntityEvents_Event

collall See Also

Reference

Layout Members


Layout Members

API Reference > CADViewLib Namespace > Layout Interface >

Layout Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to LAYOUT objects.

The following tables list the members exposed by the Layout type.

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from ILayout ).
Public property | CADHandle | Gets or sets the object handle. (inherited from ILayout ).
Public property | CADSpace | Gets or sets a style for the layout's space. (inherited from ILayout ).
Public property | Color | Gets or sets a color of the object. (inherited from ILayout ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from ILayout ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from ILayout ).
Public property | CustomPrintScale | Gets or sets a custom scale for printing. (inherited from ILayout ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from ILayout ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from ILayout ).
Public property | IsEmpty | Gets a value indicating whether this layout is empty. (inherited from ILayout ).
Public property | IsModel | Gets a value indicating whether this layout is Model space. (inherited from ILayout ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from ILayout ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from ILayout ).
Public property | Name | Gets or sets a name of this object. (inherited from ILayout ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from ILayout ).
Public property | PaperSpaceBlock | Gets or sets the Paper space block. (inherited from ILayout ).
Public property | PaperSpaceHandle | Gets or sets ID/handle to this layout's associated paper space. (inherited from ILayout ).
Public property | PlotPaperUnits | Gets the units which are used for plotting this layout. (inherited from ILayout ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from ILayout ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from ILayout ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from ILayout ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from ILayout ).

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from ILayout ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from ILayout ).
Public method | CreateEntity | Initializes a new object instance. (inherited from ILayout ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from ILayout ).
Public method | EntName | Returns a name of the entity. (inherited from ILayout ).
Public method | FreeEntity | Destroys the object instance. (inherited from ILayout ).
Public method | GetBoxPoints | For internal use. (inherited from ILayout ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from ILayout ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from ILayout ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from ILayout ).
Public method | RemoveEntity | Removes a specified entity. (inherited from ILayout ).
Public method | SetLType | Sets a line type for this object. (inherited from ILayout ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from ILayout ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from ILayout ).

Top

collall See Also

Reference

Layout Interface


Layout Properties

API Reference > CADViewLib Namespace > Layout Interface >

Layout Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from ILayout ).
Public property | CADHandle | Gets or sets the object handle. (inherited from ILayout ).
Public property | CADSpace | Gets or sets a style for the layout's space. (inherited from ILayout ).
Public property | Color | Gets or sets a color of the object. (inherited from ILayout ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from ILayout ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from ILayout ).
Public property | CustomPrintScale | Gets or sets a custom scale for printing. (inherited from ILayout ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from ILayout ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from ILayout ).
Public property | IsEmpty | Gets a value indicating whether this layout is empty. (inherited from ILayout ).
Public property | IsModel | Gets a value indicating whether this layout is Model space. (inherited from ILayout ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from ILayout ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from ILayout ).
Public property | Name | Gets or sets a name of this object. (inherited from ILayout ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from ILayout ).
Public property | PaperSpaceBlock | Gets or sets the Paper space block. (inherited from ILayout ).
Public property | PaperSpaceHandle | Gets or sets ID/handle to this layout's associated paper space. (inherited from ILayout ).
Public property | PlotPaperUnits | Gets the units which are used for plotting this layout. (inherited from ILayout ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from ILayout ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from ILayout ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from ILayout ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from ILayout ).

Top

collall See Also

Reference

Layout Interface


Layout Methods

API Reference > CADViewLib Namespace > Layout Interface >

Layout Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from ILayout ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from ILayout ).
Public method | CreateEntity | Initializes a new object instance. (inherited from ILayout ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from ILayout ).
Public method | EntName | Returns a name of the entity. (inherited from ILayout ).
Public method | FreeEntity | Destroys the object instance. (inherited from ILayout ).
Public method | GetBoxPoints | For internal use. (inherited from ILayout ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from ILayout ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from ILayout ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from ILayout ).
Public method | RemoveEntity | Removes a specified entity. (inherited from ILayout ).
Public method | SetLType | Sets a line type for this object. (inherited from ILayout ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from ILayout ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from ILayout ).

Top

collall See Also

Reference

Layout Interface


Point2D Interface

API Reference > CADViewLib Namespace >

Point2D Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to 2D points.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface Point2D
Inherits IPoint2D

C#

public interface Point2D : IPoint2D

C++

public interface class Point2D : public IPoint2D^

JScript

public interface Point2D
implements IPoint2D

collall See Also

Reference

Point2D Members


Point2D Members

API Reference > CADViewLib Namespace > Point2D Interface >

Point2D Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to 2D points.

The following tables list the members exposed by the Point2D type.

collall Public Properties

 | Name | Description
Public property | X | Gets or sets the X-coordinate. (inherited from IPoint2D ).
Public property | Y | Gets or sets the Y-coordinate. (inherited from IPoint2D ).

Top

collall See Also

Reference

Point2D Interface


Point2D Properties

API Reference > CADViewLib Namespace > Point2D Interface >

Point2D Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | X | Gets or sets the X-coordinate. (inherited from IPoint2D ).
Public property | Y | Gets or sets the Y-coordinate. (inherited from IPoint2D ).

Top

collall See Also

Reference

Point2D Interface


Point3D Interface

API Reference > CADViewLib Namespace >

Point3D Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to 3D points.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface Point3D
Inherits IPoint3D, _
IPoint3DEvents_Event

C#

public interface Point3D : IPoint3D,
IPoint3DEvents_Event

C++

public interface class Point3D : public IPoint3D^,
public IPoint3DEvents_Event^

JScript

public interface Point3D
implements IPoint3D,
IPoint3DEvents_Event

collall See Also

Reference

Point3D Members


Point3D Members

API Reference > CADViewLib Namespace > Point3D Interface >

Point3D Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to 3D points.

The following tables list the members exposed by the Point3D type.

collall Public Properties

 | Name | Description
Public property | X | Gets or sets the X-coordinate. (inherited from IPoint3D ).
Public property | Y | Gets or sets the Y-coordinate. (inherited from IPoint3D ).
Public property | Z | Gets or sets the Z-coordinate. (inherited from IPoint3D ).

Top

collall Public Methods

 | Name | Description
Public method | get_V | Returns the element at the given index in the 3D vector. (inherited from IPoint3D ).
Public method | set_V | Sets the element in the 3D vector to the given value. (inherited from IPoint3D ).

Top

collall See Also

Reference

Point3D Interface


Point3D Properties

API Reference > CADViewLib Namespace > Point3D Interface >

Point3D Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | X | Gets or sets the X-coordinate. (inherited from IPoint3D ).
Public property | Y | Gets or sets the Y-coordinate. (inherited from IPoint3D ).
Public property | Z | Gets or sets the Z-coordinate. (inherited from IPoint3D ).

Top

collall See Also

Reference

Point3D Interface


Point3D Methods

API Reference > CADViewLib Namespace > Point3D Interface >

Point3D Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | get_V | Returns the element at the given index in the 3D vector. (inherited from IPoint3D ).
Public method | set_V | Sets the element in the 3D vector to the given value. (inherited from IPoint3D ).

Top

collall See Also

Reference

Point3D Interface


Polyline Interface

API Reference > CADViewLib Namespace >

Polyline Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to POLYLINE and LWPOLYLINE entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface Polyline
Inherits IPolyline, _
IEntityEvents_Event

C#

public interface Polyline : IPolyline,
IEntityEvents_Event

C++

public interface class Polyline : public IPolyline^,
public IEntityEvents_Event^

JScript

public interface Polyline
implements IPolyline,
IEntityEvents_Event

collall See Also

Reference

Polyline Members


Polyline Members

API Reference > CADViewLib Namespace > Polyline Interface >

Polyline Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to POLYLINE and LWPOLYLINE entities.

The following tables list the members exposed by the Polyline type.

collall Public Properties

 | Name | Description
Public property | ArrowsCount | Gets a quantity of points that form an arrow. (inherited from IPolyline ).
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from IPolyline ).
Public property | CADHandle | Gets or sets the object handle. (inherited from IPolyline ).
Public property | Closed | Gets or sets a value indicating whether this polyline is closed. (inherited from IPolyline ).
Public property | Color | Gets or sets a color of the object. (inherited from IPolyline ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from IPolyline ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from IPolyline ).
Public property | DottedPointsCount | Gets a quantity of points that determine the dots and dashes for a polyline with non-solid line type. (inherited from IPolyline ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from IPolyline ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from IPolyline ).
Public property | Flags | Gets or sets a bit-coded flag indicating the polyline type. (inherited from IPolyline ).
Public property | GlobalWidth | Gets or sets a global width for this polyline. (inherited from IPolyline ).
Public property | IsMeshMClosed | Gets a value indicating whether the polygon mesh is closed in the M direction. (inherited from IPolyline ).
Public property | IsMeshNClosed | Gets a value indicating whether the polygon mesh is closed in the N direction. (inherited from IPolyline ).
Public property | IsPolyFaceMesh | Gets a value indicating whether this polyline is a polyface mesh. (inherited from IPolyline ).
Public property | IsPolyZThickness | Gets a value indicating whether the polyline has thickness measured along the axis Z. (inherited from IPolyline ).
Public property | IsPolygonMesh | Gets a value indicating whether this polyline is a polygon mesh. (inherited from IPolyline ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from IPolyline ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from IPolyline ).
Public property | MeshM | Gets or sets a number of vertices for the polygon mesh in the M direction. (inherited from IPolyline ).
Public property | MeshN | Gets or sets a number of vertices for the polygon mesh in the N direction. (inherited from IPolyline ).
Public property | Name | Gets or sets a name of this object. (inherited from IPolyline ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from IPolyline ).
Public property | PenLine | Gets properties of the pen used for drawing the object. (inherited from IPolyline ).
Public property | PointsCount | Gets a number of the polyline points. (inherited from IPolyline ).
Public property | PolyFaceVertexIndexesCount | Gets a quantity of indices which specify the order of traversing vertices in the polyface mesh. (inherited from IPolyline ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from IPolyline ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from IPolyline ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from IPolyline ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from IPolyline ).

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from IPolyline ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from IPolyline ).
Public method | CreateEntity | Initializes a new object instance. (inherited from IPolyline ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from IPolyline ).
Public method | EntName | Returns a name of the entity. (inherited from IPolyline ).
Public method | FreeEntity | Destroys the object instance. (inherited from IPolyline ).
Public method | GetArea | Returns the area bounded by a closed polygon. (inherited from IPolyline ).
Public method | GetBoxPoints | For internal use. (inherited from IPolyline ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from IPolyline ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from IPolyline ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from IPolyline ).
Public method | RemoveEntity | Removes a specified entity. (inherited from IPolyline ).
Public method | SetLType | Sets a line type for this object. (inherited from IPolyline ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from IPolyline ).
Public method | get_Arrows | Returns a point of the arrowhead. (inherited from IPolyline ).
Public method | get_DottedPoints | Returns coordinates of a point in the points array that determines dots and dashes for a non-solid line type. (inherited from IPolyline ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from IPolyline ).
Public method | get_Points | Returns coordinates of a point in the points array. (inherited from IPolyline ).
Public method | get_PolyFaceVertexIndexes | Returns a value which indicates an index of the polyface mesh vertex. (inherited from IPolyline ).
Public method | set_Arrows | Modifies a point of the arrowhead at the given index. (inherited from IPolyline ).

Top

collall See Also

Reference

Polyline Interface


Polyline Properties

API Reference > CADViewLib Namespace > Polyline Interface >

Polyline Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | ArrowsCount | Gets a quantity of points that form an arrow. (inherited from IPolyline ).
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from IPolyline ).
Public property | CADHandle | Gets or sets the object handle. (inherited from IPolyline ).
Public property | Closed | Gets or sets a value indicating whether this polyline is closed. (inherited from IPolyline ).
Public property | Color | Gets or sets a color of the object. (inherited from IPolyline ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from IPolyline ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from IPolyline ).
Public property | DottedPointsCount | Gets a quantity of points that determine the dots and dashes for a polyline with non-solid line type. (inherited from IPolyline ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from IPolyline ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from IPolyline ).
Public property | Flags | Gets or sets a bit-coded flag indicating the polyline type. (inherited from IPolyline ).
Public property | GlobalWidth | Gets or sets a global width for this polyline. (inherited from IPolyline ).
Public property | IsMeshMClosed | Gets a value indicating whether the polygon mesh is closed in the M direction. (inherited from IPolyline ).
Public property | IsMeshNClosed | Gets a value indicating whether the polygon mesh is closed in the N direction. (inherited from IPolyline ).
Public property | IsPolyFaceMesh | Gets a value indicating whether this polyline is a polyface mesh. (inherited from IPolyline ).
Public property | IsPolyZThickness | Gets a value indicating whether the polyline has thickness measured along the axis Z. (inherited from IPolyline ).
Public property | IsPolygonMesh | Gets a value indicating whether this polyline is a polygon mesh. (inherited from IPolyline ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from IPolyline ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from IPolyline ).
Public property | MeshM | Gets or sets a number of vertices for the polygon mesh in the M direction. (inherited from IPolyline ).
Public property | MeshN | Gets or sets a number of vertices for the polygon mesh in the N direction. (inherited from IPolyline ).
Public property | Name | Gets or sets a name of this object. (inherited from IPolyline ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from IPolyline ).
Public property | PenLine | Gets properties of the pen used for drawing the object. (inherited from IPolyline ).
Public property | PointsCount | Gets a number of the polyline points. (inherited from IPolyline ).
Public property | PolyFaceVertexIndexesCount | Gets a quantity of indices which specify the order of traversing vertices in the polyface mesh. (inherited from IPolyline ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from IPolyline ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from IPolyline ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from IPolyline ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from IPolyline ).

Top

collall See Also

Reference

Polyline Interface


Polyline Methods

API Reference > CADViewLib Namespace > Polyline Interface >

Polyline Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from IPolyline ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from IPolyline ).
Public method | CreateEntity | Initializes a new object instance. (inherited from IPolyline ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from IPolyline ).
Public method | EntName | Returns a name of the entity. (inherited from IPolyline ).
Public method | FreeEntity | Destroys the object instance. (inherited from IPolyline ).
Public method | GetArea | Returns the area bounded by a closed polygon. (inherited from IPolyline ).
Public method | GetBoxPoints | For internal use. (inherited from IPolyline ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from IPolyline ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from IPolyline ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from IPolyline ).
Public method | RemoveEntity | Removes a specified entity. (inherited from IPolyline ).
Public method | SetLType | Sets a line type for this object. (inherited from IPolyline ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from IPolyline ).
Public method | get_Arrows | Returns a point of the arrowhead. (inherited from IPolyline ).
Public method | get_DottedPoints | Returns coordinates of a point in the points array that determines dots and dashes for a non-solid line type. (inherited from IPolyline ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from IPolyline ).
Public method | get_Points | Returns coordinates of a point in the points array. (inherited from IPolyline ).
Public method | get_PolyFaceVertexIndexes | Returns a value which indicates an index of the polyface mesh vertex. (inherited from IPolyline ).
Public method | set_Arrows | Modifies a point of the arrowhead at the given index. (inherited from IPolyline ).

Top

collall See Also

Reference

Polyline Interface


Rect2D Interface

API Reference > CADViewLib Namespace >

Rect2D Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to a bounding rectangle.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface Rect2D
Inherits IRect2D

C#

public interface Rect2D : IRect2D

C++

public interface class Rect2D : public IRect2D^

JScript

public interface Rect2D
implements IRect2D

collall See Also

Reference

Rect2D Members


Rect2D Members

API Reference > CADViewLib Namespace > Rect2D Interface >

Rect2D Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to a bounding rectangle.

The following tables list the members exposed by the Rect2D type.

collall Public Properties

 | Name | Description
Public property | Bottom | Gets or sets the Y-coordinate of the bottom-right corner. (inherited from IRect2D ).
Public property | BottomRight | Gets or sets a location of the bottom-right corner. (inherited from IRect2D ).
Public property | Left | Gets or sets the X-coordinate of the top-left corner. (inherited from IRect2D ).
Public property | Right | Gets or sets the X-coordinate of the bottom-right corner. (inherited from IRect2D ).
Public property | Top | Gets or sets the Y-coordinate of the top-left corner. (inherited from IRect2D ).
Public property | TopLeft | Gets or sets a location of the top-left corner. (inherited from IRect2D ).

Top

collall See Also

Reference

Rect2D Interface


Rect2D Properties

API Reference > CADViewLib Namespace > Rect2D Interface >

Rect2D Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Bottom | Gets or sets the Y-coordinate of the bottom-right corner. (inherited from IRect2D ).
Public property | BottomRight | Gets or sets a location of the bottom-right corner. (inherited from IRect2D ).
Public property | Left | Gets or sets the X-coordinate of the top-left corner. (inherited from IRect2D ).
Public property | Right | Gets or sets the X-coordinate of the bottom-right corner. (inherited from IRect2D ).
Public property | Top | Gets or sets the Y-coordinate of the top-left corner. (inherited from IRect2D ).
Public property | TopLeft | Gets or sets a location of the top-left corner. (inherited from IRect2D ).

Top

collall See Also

Reference

Rect2D Interface


Rect3D Interface

API Reference > CADViewLib Namespace >

Rect3D Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to a bounding parallelepiped (box).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface Rect3D
Inherits IRect3D, _
IRect3DEvents_Event

C#

public interface Rect3D : IRect3D,
IRect3DEvents_Event

C++

public interface class Rect3D : public IRect3D^,
public IRect3DEvents_Event^

JScript

public interface Rect3D
implements IRect3D,
IRect3DEvents_Event

collall See Also

Reference

Rect3D Members


Rect3D Members

API Reference > CADViewLib Namespace > Rect3D Interface >

Rect3D Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to a bounding parallelepiped (box).

The following tables list the members exposed by the Rect3D type.

collall Public Properties

 | Name | Description
Public property | Bottom | Gets or sets the Y-coordinate of the bottom-right corner. (inherited from IRect3D ).
Public property | BottomRight | Gets or sets a location of the bottom-right corner. (inherited from IRect3D ).
Public property | Left | Gets or sets the X-coordinate of the top-left corner. (inherited from IRect3D ).
Public property | Right | Gets or sets the X-coordinate of the bottom-right corner. (inherited from IRect3D ).
Public property | Top | Gets or sets the Y-coordinate of the top-left corner. (inherited from IRect3D ).
Public property | TopLeft | Gets or sets a location of the top-left corner. (inherited from IRect3D ).
Public property | Z1 | Gets or sets the Z-coordinate of the top-left corner. (inherited from IRect3D ).
Public property | Z2 | Gets or sets the X-coordinate of the bottom-right corner. (inherited from IRect3D ).

Top

collall See Also

Reference

Rect3D Interface


Rect3D Properties

API Reference > CADViewLib Namespace > Rect3D Interface >

Rect3D Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Bottom | Gets or sets the Y-coordinate of the bottom-right corner. (inherited from IRect3D ).
Public property | BottomRight | Gets or sets a location of the bottom-right corner. (inherited from IRect3D ).
Public property | Left | Gets or sets the X-coordinate of the top-left corner. (inherited from IRect3D ).
Public property | Right | Gets or sets the X-coordinate of the bottom-right corner. (inherited from IRect3D ).
Public property | Top | Gets or sets the Y-coordinate of the top-left corner. (inherited from IRect3D ).
Public property | TopLeft | Gets or sets a location of the top-left corner. (inherited from IRect3D ).
Public property | Z1 | Gets or sets the Z-coordinate of the top-left corner. (inherited from IRect3D ).
Public property | Z2 | Gets or sets the X-coordinate of the bottom-right corner. (inherited from IRect3D ).

Top

collall See Also

Reference

Rect3D Interface


SVGImage Interface

API Reference > CADViewLib Namespace >

SVGImage Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to an SVG drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface SVGImage
Inherits ISVGImage, _
IDXFImageEvents_Event

C#

public interface SVGImage : ISVGImage,
IDXFImageEvents_Event

C++

public interface class SVGImage : public ISVGImage^,
public IDXFImageEvents_Event^

JScript

public interface SVGImage
implements ISVGImage,
IDXFImageEvents_Event

collall See Also

Reference

SVGImage Members


SVGImage Members

API Reference > CADViewLib Namespace > SVGImage Interface >

SVGImage Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to an SVG drawing.

The following tables list the members exposed by the SVGImage type.

collall Public Properties

 | Name | Description
Public property | BackGroundColor | Gets or sets a background color for the drawing. (inherited from ISVGImage ).
Public property | BorderSize | Gets or sets a border size for the drawing. (inherited from ISVGImage ).
Public property | BorderType | Gets or sets a way the drawing's border size is defined (global or ratio). (inherited from ISVGImage ).
Public property | CADClassID | Gets the CAD format identifier for the drawing. (inherited from ISVGImage ).
Public property | CBFormat | Gets or sets the clipboard format. (inherited from ISVGImage ).
Public property | CanStopLoading | Gets a value indicating whether the loading of the drawing data can be terminated. (inherited from ISVGImage ).
Public property | Charset | Gets or sets a character set for the text entities. (inherited from ISVGImage ).
Public property | ColorToLineWeight | Gets or sets a string which contains the color-lineweight pairs. (inherited from ISVGImage ).
Public property | Converter | Gets or sets a Converter associated with this image object. (inherited from ISVGImage ).
Public property | Count | Gets a number of entities in the drawing. (inherited from ISVGImage ).
Public property | CurrentLayout | Gets or sets the current layout for the drawing. (inherited from ISVGImage ).
Public property | DefaultColor | Gets or sets the default color for the drawing. (inherited from ISVGImage ).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions in the drawing are visible. (inherited from ISVGImage ).
Public property | DrawMode | Gets or sets an appearance of colors in the drawing. (inherited from ISVGImage ).
Public property | DrawingBox | Gets or sets the drawing bounding box. (inherited from ISVGImage ).
Public property | Empty | Gets a value indicating whether the drawing is empty. (inherited from ISVGImage ).
Public property | Extents | Gets or sets the drawing's extents. (inherited from ISVGImage ).
Public property | Height | Gets or sets a height of the drawing. (inherited from ISVGImage ).
Public property | Is3D | Gets a value indicating whether the drawing is three-dimensional. (inherited from ISVGImage ).
Public property | IsDraw3DAxes | Gets a value indicating whether 3D axes are visible on the drawing. (inherited from ISVGImage ).
Public property | IsDrawingRotated | Gets a value indicating whether the drawing is rotated. (inherited from ISVGImage ).
Public property | IsLoading | Gets a value indicating whether the process of loading the drawing data is active. (inherited from ISVGImage ).
Public property | IsPlotting | Gets or sets a value indicating whether to plot the image or not. (inherited from ISVGImage ).
Public property | IsProcessMessages | Gets or sets a value indicating whether the messages processing is allowed. (inherited from ISVGImage ).
Public property | IsShowBackground | Gets or sets a value indicating whether the backround is displayed. (inherited from ISVGImage ).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines is determined by the drawing data. (inherited from ISVGImage ).
Public property | IsWithoutBorder | Gets or sets a value indicating whether to display the drawing without borders. (inherited from ISVGImage ).
Public property | LayoutsCount | Gets the number of layouts in the drawing. (inherited from ISVGImage ).
Public property | LineScaled | Gets or sets a value indicating whether the line weight is diplayed. (inherited from ISVGImage ).
Public property | LineWeightScale | Gets or sets a scale for line weights. (inherited from ISVGImage ).
Public property | Millimetres | Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file. (inherited from ISVGImage ).
Public property | Modified | Gets or sets a value indicating whether the drawing is modified. (inherited from ISVGImage ).
Public property | NullWidth | Gets or sets a thickness for lines which have the zero lineweight. (inherited from ISVGImage ).
Public property | OwnSource | For internal use. (inherited from ISVGImage ).
Public property | PureExtents | Gets the drawing's extents excluding the borders. (inherited from ISVGImage ).
Public property | ResizeDisproportionateDrawing | Gets or sets a value indicating whether to resize a drawing with disproportionate sizes. (inherited from ISVGImage ).
Public property | Scale | Gets or sets a 3D point which defines the scale factor. (inherited from ISVGImage ).
Public property | ShowImages | Gets or sets a value indicating whether the raster images are displayed. (inherited from ISVGImage ).
Public property | Stretch | Gets or sets a value indicating whether the displayed image has to be stretched to fit exactly with the drawing rectangle. (inherited from ISVGImage ).
Public property | TextVisible | Gets or sets a value indicating whether texts in the drawing are visible. (inherited from ISVGImage ).
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles are drawn by using GDI+ methods without linearization. (inherited from ISVGImage ).
Public property | ViewRectangle | For internal use. (inherited from ISVGImage ).
Public property | Width | Gets or sets a width of the drawing. (inherited from ISVGImage ).

Top

collall Public Methods

 | Name | Description
Public method | AbsHeight | Returns an absolute height of the CAD drawing. (inherited from ISVGImage ).
Public method | AbsWidth | Returns an absolute width of the CAD drawing. (inherited from ISVGImage ).
Public method | AddScaledDXF | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing. (inherited from ISVGImage ).
Public method | AddScaledDXFEx | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing. (inherited from ISVGImage ).
Public method | AssignImage | Makes a copy of a specified CAD image object and assigns it to this image. (inherited from ISVGImage ).
Public method | CreateImage | Initializes a new CAD image instance. (inherited from ISVGImage ).
Public method | Draw | Draws the CAD image in a specified device context (DC). (inherited from ISVGImage ).
Public method | DrawRect | Draws a specified region of this CAD image in a device context (DC). (inherited from ISVGImage ).
Public method | ExportToMetafile | Exports this CAD image to Windows metafile. (inherited from ISVGImage ).
Public method | FreeImage | Destroys this CAD image object and frees the memory used within the object. (inherited from ISVGImage ).
Public method | GetCADCoords | Returns CAD coordinates for a specified point. (inherited from ISVGImage ).
Public method | GetEntityColor | Returns the color value for a specified entity. (inherited from ISVGImage ).
Public method | GetExtents | Recalculates extents of the CAD image. (inherited from ISVGImage ).
Public method | GetPoint | Gets the on-screen coordinates for a specified CAD point. (inherited from ISVGImage ).
Public method | GetRealImagePoint | Returns CAD coordinates of a specified point considering the drawing's rotation and viewport parameters. (inherited from ISVGImage ).
Public method | HeadVarAsFloat | Returns a value of the DXF header variable as a floating point number. (inherited from ISVGImage ).
Public method | HeadVarAsInteger | Returns a value of the DXF header variable as an integer. (inherited from ISVGImage ).
Public method | HeadVarAsstring | Returns a value of the DXF header variable as a string. (inherited from ISVGImage ).
Public method | LoadFromClipboardFormat | Loads data from the clipboard. (inherited from ISVGImage ).
Public method | LoadFromFile | Loads a CAD drawing from file. (inherited from ISVGImage ).
Public method | LoadFromIStream | Loads a CAD drawing from stream. (inherited from ISVGImage ).
Public method | LoadFromStream | Loads a CAD drawing from stream. (inherited from ISVGImage ).
Public method | RefreshCurrentLayout | Refreshes the current layout. (inherited from ISVGImage ).
Public method | ResetDrawingBox | Switches off the drawing box. (inherited from ISVGImage ).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from ISVGImage ).
Public method | RotToView | Rotates the drawing to a specified view. (inherited from ISVGImage ).
Public method | Rotate | Rotates the drawing. (inherited from ISVGImage ).
Public method | SaveToClipboardFormat | Copies the drawing to the clipboard in a specified format. (inherited from ISVGImage ).
Public method | SaveToFile | Saves the drawing to a specified file. (inherited from ISVGImage ).
Public method | SaveToIStream | Writes the drawing data to a specified stream. (inherited from ISVGImage ).
Public method | SaveToStream | Writes the drawing data to a specified stream. (inherited from ISVGImage ).
Public method | SetClippingRect | Sets a clipping rectangle for the drawing. (inherited from ISVGImage ).
Public method | SetExtentsParameters | Changes the drawing extents. (inherited from ISVGImage ).
Public method | StopLoading | Terminates loading of the drawing data. (inherited from ISVGImage ).
Public method | get_Blocks | Retrieves a BLOCK object by its index. (inherited from ISVGImage ).
Public method | get_Entities | Retrieves an entity by its index. (inherited from ISVGImage ).
Public method | get_Items | (inherited from ISVGImage ).
Public method | get_Layouts | Retrieves a layout by its index. (inherited from ISVGImage ).

Top

collall See Also

Reference

SVGImage Interface


SVGImage Properties

API Reference > CADViewLib Namespace > SVGImage Interface >

SVGImage Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | BackGroundColor | Gets or sets a background color for the drawing. (inherited from ISVGImage ).
Public property | BorderSize | Gets or sets a border size for the drawing. (inherited from ISVGImage ).
Public property | BorderType | Gets or sets a way the drawing's border size is defined (global or ratio). (inherited from ISVGImage ).
Public property | CADClassID | Gets the CAD format identifier for the drawing. (inherited from ISVGImage ).
Public property | CBFormat | Gets or sets the clipboard format. (inherited from ISVGImage ).
Public property | CanStopLoading | Gets a value indicating whether the loading of the drawing data can be terminated. (inherited from ISVGImage ).
Public property | Charset | Gets or sets a character set for the text entities. (inherited from ISVGImage ).
Public property | ColorToLineWeight | Gets or sets a string which contains the color-lineweight pairs. (inherited from ISVGImage ).
Public property | Converter | Gets or sets a Converter associated with this image object. (inherited from ISVGImage ).
Public property | Count | Gets a number of entities in the drawing. (inherited from ISVGImage ).
Public property | CurrentLayout | Gets or sets the current layout for the drawing. (inherited from ISVGImage ).
Public property | DefaultColor | Gets or sets the default color for the drawing. (inherited from ISVGImage ).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions in the drawing are visible. (inherited from ISVGImage ).
Public property | DrawMode | Gets or sets an appearance of colors in the drawing. (inherited from ISVGImage ).
Public property | DrawingBox | Gets or sets the drawing bounding box. (inherited from ISVGImage ).
Public property | Empty | Gets a value indicating whether the drawing is empty. (inherited from ISVGImage ).
Public property | Extents | Gets or sets the drawing's extents. (inherited from ISVGImage ).
Public property | Height | Gets or sets a height of the drawing. (inherited from ISVGImage ).
Public property | Is3D | Gets a value indicating whether the drawing is three-dimensional. (inherited from ISVGImage ).
Public property | IsDraw3DAxes | Gets a value indicating whether 3D axes are visible on the drawing. (inherited from ISVGImage ).
Public property | IsDrawingRotated | Gets a value indicating whether the drawing is rotated. (inherited from ISVGImage ).
Public property | IsLoading | Gets a value indicating whether the process of loading the drawing data is active. (inherited from ISVGImage ).
Public property | IsPlotting | Gets or sets a value indicating whether to plot the image or not. (inherited from ISVGImage ).
Public property | IsProcessMessages | Gets or sets a value indicating whether the messages processing is allowed. (inherited from ISVGImage ).
Public property | IsShowBackground | Gets or sets a value indicating whether the backround is displayed. (inherited from ISVGImage ).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines is determined by the drawing data. (inherited from ISVGImage ).
Public property | IsWithoutBorder | Gets or sets a value indicating whether to display the drawing without borders. (inherited from ISVGImage ).
Public property | LayoutsCount | Gets the number of layouts in the drawing. (inherited from ISVGImage ).
Public property | LineScaled | Gets or sets a value indicating whether the line weight is diplayed. (inherited from ISVGImage ).
Public property | LineWeightScale | Gets or sets a scale for line weights. (inherited from ISVGImage ).
Public property | Millimetres | Gets or sets a value indicating the drawing units (millimeters or inches) for the loaded DWG/DXF file. (inherited from ISVGImage ).
Public property | Modified | Gets or sets a value indicating whether the drawing is modified. (inherited from ISVGImage ).
Public property | NullWidth | Gets or sets a thickness for lines which have the zero lineweight. (inherited from ISVGImage ).
Public property | OwnSource | For internal use. (inherited from ISVGImage ).
Public property | PureExtents | Gets the drawing's extents excluding the borders. (inherited from ISVGImage ).
Public property | ResizeDisproportionateDrawing | Gets or sets a value indicating whether to resize a drawing with disproportionate sizes. (inherited from ISVGImage ).
Public property | Scale | Gets or sets a 3D point which defines the scale factor. (inherited from ISVGImage ).
Public property | ShowImages | Gets or sets a value indicating whether the raster images are displayed. (inherited from ISVGImage ).
Public property | Stretch | Gets or sets a value indicating whether the displayed image has to be stretched to fit exactly with the drawing rectangle. (inherited from ISVGImage ).
Public property | TextVisible | Gets or sets a value indicating whether texts in the drawing are visible. (inherited from ISVGImage ).
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles are drawn by using GDI+ methods without linearization. (inherited from ISVGImage ).
Public property | ViewRectangle | For internal use. (inherited from ISVGImage ).
Public property | Width | Gets or sets a width of the drawing. (inherited from ISVGImage ).

Top

collall See Also

Reference

SVGImage Interface


SVGImage Methods

API Reference > CADViewLib Namespace > SVGImage Interface >

SVGImage Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AbsHeight | Returns an absolute height of the CAD drawing. (inherited from ISVGImage ).
Public method | AbsWidth | Returns an absolute width of the CAD drawing. (inherited from ISVGImage ).
Public method | AddScaledDXF | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing. (inherited from ISVGImage ).
Public method | AddScaledDXFEx | Adds a scaled external reference (XREF) to the model space of the loaded CAD drawing. (inherited from ISVGImage ).
Public method | AssignImage | Makes a copy of a specified CAD image object and assigns it to this image. (inherited from ISVGImage ).
Public method | CreateImage | Initializes a new CAD image instance. (inherited from ISVGImage ).
Public method | Draw | Draws the CAD image in a specified device context (DC). (inherited from ISVGImage ).
Public method | DrawRect | Draws a specified region of this CAD image in a device context (DC). (inherited from ISVGImage ).
Public method | ExportToMetafile | Exports this CAD image to Windows metafile. (inherited from ISVGImage ).
Public method | FreeImage | Destroys this CAD image object and frees the memory used within the object. (inherited from ISVGImage ).
Public method | GetCADCoords | Returns CAD coordinates for a specified point. (inherited from ISVGImage ).
Public method | GetEntityColor | Returns the color value for a specified entity. (inherited from ISVGImage ).
Public method | GetExtents | Recalculates extents of the CAD image. (inherited from ISVGImage ).
Public method | GetPoint | Gets the on-screen coordinates for a specified CAD point. (inherited from ISVGImage ).
Public method | GetRealImagePoint | Returns CAD coordinates of a specified point considering the drawing's rotation and viewport parameters. (inherited from ISVGImage ).
Public method | HeadVarAsFloat | Returns a value of the DXF header variable as a floating point number. (inherited from ISVGImage ).
Public method | HeadVarAsInteger | Returns a value of the DXF header variable as an integer. (inherited from ISVGImage ).
Public method | HeadVarAsstring | Returns a value of the DXF header variable as a string. (inherited from ISVGImage ).
Public method | LoadFromClipboardFormat | Loads data from the clipboard. (inherited from ISVGImage ).
Public method | LoadFromFile | Loads a CAD drawing from file. (inherited from ISVGImage ).
Public method | LoadFromIStream | Loads a CAD drawing from stream. (inherited from ISVGImage ).
Public method | LoadFromStream | Loads a CAD drawing from stream. (inherited from ISVGImage ).
Public method | RefreshCurrentLayout | Refreshes the current layout. (inherited from ISVGImage ).
Public method | ResetDrawingBox | Switches off the drawing box. (inherited from ISVGImage ).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from ISVGImage ).
Public method | RotToView | Rotates the drawing to a specified view. (inherited from ISVGImage ).
Public method | Rotate | Rotates the drawing. (inherited from ISVGImage ).
Public method | SaveToClipboardFormat | Copies the drawing to the clipboard in a specified format. (inherited from ISVGImage ).
Public method | SaveToFile | Saves the drawing to a specified file. (inherited from ISVGImage ).
Public method | SaveToIStream | Writes the drawing data to a specified stream. (inherited from ISVGImage ).
Public method | SaveToStream | Writes the drawing data to a specified stream. (inherited from ISVGImage ).
Public method | SetClippingRect | Sets a clipping rectangle for the drawing. (inherited from ISVGImage ).
Public method | SetExtentsParameters | Changes the drawing extents. (inherited from ISVGImage ).
Public method | StopLoading | Terminates loading of the drawing data. (inherited from ISVGImage ).
Public method | get_Blocks | Retrieves a BLOCK object by its index. (inherited from ISVGImage ).
Public method | get_Entities | Retrieves an entity by its index. (inherited from ISVGImage ).
Public method | get_Items | (inherited from ISVGImage ).
Public method | get_Layouts | Retrieves a layout by its index. (inherited from ISVGImage ).

Top

collall See Also

Reference

SVGImage Interface


Solid Interface

API Reference > CADViewLib Namespace >

Solid Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to SOLID entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface Solid
Inherits ISolid, _
IEntityEvents_Event

C#

public interface Solid : ISolid,
IEntityEvents_Event

C++

public interface class Solid : public ISolid^,
public IEntityEvents_Event^

JScript

public interface Solid
implements ISolid,
IEntityEvents_Event

collall See Also

Reference

Solid Members


Solid Members

API Reference > CADViewLib Namespace > Solid Interface >

Solid Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to SOLID entities.

The following tables list the members exposed by the Solid type.

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from ISolid ).
Public property | CADHandle | Gets or sets the object handle. (inherited from ISolid ).
Public property | Color | Gets or sets a color of the object. (inherited from ISolid ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from ISolid ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from ISolid ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from ISolid ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from ISolid ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from ISolid ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from ISolid ).
Public property | Name | Gets or sets a name of this object. (inherited from ISolid ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from ISolid ).
Public property | Point | Gets or sets coordinates of the first corner. (inherited from ISolid ).
Public property | Point1 | Gets or sets coordinates of the second corner. (inherited from ISolid ).
Public property | Point2 | Gets or sets coordinates of the third corner. (inherited from ISolid ).
Public property | Point3 | Gets or sets coordinates of the fourth corner. (inherited from ISolid ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from ISolid ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from ISolid ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from ISolid ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from ISolid ).

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from ISolid ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from ISolid ).
Public method | CreateEntity | Initializes a new object instance. (inherited from ISolid ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from ISolid ).
Public method | EntName | Returns a name of the entity. (inherited from ISolid ).
Public method | FreeEntity | Destroys the object instance. (inherited from ISolid ).
Public method | GetBoxPoints | For internal use. (inherited from ISolid ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from ISolid ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from ISolid ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from ISolid ).
Public method | RemoveEntity | Removes a specified entity. (inherited from ISolid ).
Public method | SetLType | Sets a line type for this object. (inherited from ISolid ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from ISolid ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from ISolid ).

Top

collall See Also

Reference

Solid Interface


Solid Properties

API Reference > CADViewLib Namespace > Solid Interface >

Solid Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from ISolid ).
Public property | CADHandle | Gets or sets the object handle. (inherited from ISolid ).
Public property | Color | Gets or sets a color of the object. (inherited from ISolid ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from ISolid ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from ISolid ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from ISolid ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from ISolid ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from ISolid ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from ISolid ).
Public property | Name | Gets or sets a name of this object. (inherited from ISolid ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from ISolid ).
Public property | Point | Gets or sets coordinates of the first corner. (inherited from ISolid ).
Public property | Point1 | Gets or sets coordinates of the second corner. (inherited from ISolid ).
Public property | Point2 | Gets or sets coordinates of the third corner. (inherited from ISolid ).
Public property | Point3 | Gets or sets coordinates of the fourth corner. (inherited from ISolid ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from ISolid ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from ISolid ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from ISolid ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from ISolid ).

Top

collall See Also

Reference

Solid Interface


Solid Methods

API Reference > CADViewLib Namespace > Solid Interface >

Solid Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from ISolid ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from ISolid ).
Public method | CreateEntity | Initializes a new object instance. (inherited from ISolid ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from ISolid ).
Public method | EntName | Returns a name of the entity. (inherited from ISolid ).
Public method | FreeEntity | Destroys the object instance. (inherited from ISolid ).
Public method | GetBoxPoints | For internal use. (inherited from ISolid ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from ISolid ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from ISolid ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from ISolid ).
Public method | RemoveEntity | Removes a specified entity. (inherited from ISolid ).
Public method | SetLType | Sets a line type for this object. (inherited from ISolid ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from ISolid ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from ISolid ).

Top

collall See Also

Reference

Solid Interface


Spline Interface

API Reference > CADViewLib Namespace >

Spline Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to SPLINE entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface Spline
Inherits ISpline, _
IEntityEvents_Event

C#

public interface Spline : ISpline,
IEntityEvents_Event

C++

public interface class Spline : public ISpline^,
public IEntityEvents_Event^

JScript

public interface Spline
implements ISpline,
IEntityEvents_Event

collall See Also

Reference

Spline Members


Spline Members

API Reference > CADViewLib Namespace > Spline Interface >

Spline Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to SPLINE entities.

The following tables list the members exposed by the Spline type.

collall Public Properties

 | Name | Description
Public property | ArrowsCount | Gets a quantity of points that form an arrow. (inherited from ISpline ).
Public property | BeginningTangent | Gets or sets a point that specifies a tangent condition on the starting point of the spline. (inherited from ISpline ).
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from ISpline ).
Public property | CADHandle | Gets or sets the object handle. (inherited from ISpline ).
Public property | Closed | Gets or sets a value indicating whether this polyline is closed. (inherited from ISpline ).
Public property | Color | Gets or sets a color of the object. (inherited from ISpline ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from ISpline ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from ISpline ).
Public property | DottedPointsCount | Gets a quantity of points that determine the dots and dashes for a polyline with non-solid line type. (inherited from ISpline ).
Public property | EndingTangent | Gets or sets a point that specifies a tangent condition on the ending point of the spline. (inherited from ISpline ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from ISpline ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from ISpline ).
Public property | Flags | Gets or sets a bit-coded flag indicating the spline type. (inherited from ISpline ).
Public property | GlobalWidth | Gets or sets a global width for this polyline. (inherited from ISpline ).
Public property | IsByAngles | Gets a value indicating whether this spline was created by specifying fit points and tangents or by control points and knots. (inherited from ISpline ).
Public property | IsMeshMClosed | Gets a value indicating whether the polygon mesh is closed in the M direction. (inherited from ISpline ).
Public property | IsMeshNClosed | Gets a value indicating whether the polygon mesh is closed in the N direction. (inherited from ISpline ).
Public property | IsPolyFaceMesh | Gets a value indicating whether this polyline is a polyface mesh. (inherited from ISpline ).
Public property | IsPolyZThickness | Gets a value indicating whether the polyline has thickness measured along the axis Z. (inherited from ISpline ).
Public property | IsPolygonMesh | Gets a value indicating whether this polyline is a polygon mesh. (inherited from ISpline ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from ISpline ).
Public property | Length | Gets a length of this spline. (inherited from ISpline ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from ISpline ).
Public property | MeshM | Gets or sets a number of vertices for the polygon mesh in the M direction. (inherited from ISpline ).
Public property | MeshN | Gets or sets a number of vertices for the polygon mesh in the N direction. (inherited from ISpline ).
Public property | Name | Gets or sets a name of this object. (inherited from ISpline ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from ISpline ).
Public property | PenLine | Gets properties of the pen used for drawing the object. (inherited from ISpline ).
Public property | PointsCount | Gets a number of the polyline points. (inherited from ISpline ).
Public property | PolyFaceVertexIndexesCount | Gets a quantity of indices which specify the order of traversing vertices in the polyface mesh. (inherited from ISpline ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from ISpline ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from ISpline ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from ISpline ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from ISpline ).

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from ISpline ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from ISpline ).
Public method | ControlCount | Returns the number of control points. (inherited from ISpline ).
Public method | CreateEntity | Initializes a new object instance. (inherited from ISpline ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from ISpline ).
Public method | EntName | Returns a name of the entity. (inherited from ISpline ).
Public method | FitCount | Returns the number of fit points. (inherited from ISpline ).
Public method | FreeEntity | Destroys the object instance. (inherited from ISpline ).
Public method | GetArea | Returns the area bounded by a closed polygon. (inherited from ISpline ).
Public method | GetBoxPoints | For internal use. (inherited from ISpline ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from ISpline ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from ISpline ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from ISpline ).
Public method | RemoveEntity | Removes a specified entity. (inherited from ISpline ).
Public method | SetLType | Sets a line type for this object. (inherited from ISpline ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from ISpline ).
Public method | get_Arrows | Returns a point of the arrowhead. (inherited from ISpline ).
Public method | get_ControlPoints | Returns the control point at the given index. (inherited from ISpline ).
Public method | get_DottedPoints | Returns coordinates of a point in the points array that determines dots and dashes for a non-solid line type. (inherited from ISpline ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from ISpline ).
Public method | get_FitPoints | Returns the fit point at the given index. (inherited from ISpline ).
Public method | get_Points | Returns coordinates of a point in the points array. (inherited from ISpline ).
Public method | get_PolyFaceVertexIndexes | Returns a value which indicates an index of the polyface mesh vertex. (inherited from ISpline ).
Public method | set_Arrows | Modifies a point of the arrowhead at the given index. (inherited from ISpline ).

Top

collall See Also

Reference

Spline Interface


Spline Properties

API Reference > CADViewLib Namespace > Spline Interface >

Spline Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | ArrowsCount | Gets a quantity of points that form an arrow. (inherited from ISpline ).
Public property | BeginningTangent | Gets or sets a point that specifies a tangent condition on the starting point of the spline. (inherited from ISpline ).
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from ISpline ).
Public property | CADHandle | Gets or sets the object handle. (inherited from ISpline ).
Public property | Closed | Gets or sets a value indicating whether this polyline is closed. (inherited from ISpline ).
Public property | Color | Gets or sets a color of the object. (inherited from ISpline ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from ISpline ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from ISpline ).
Public property | DottedPointsCount | Gets a quantity of points that determine the dots and dashes for a polyline with non-solid line type. (inherited from ISpline ).
Public property | EndingTangent | Gets or sets a point that specifies a tangent condition on the ending point of the spline. (inherited from ISpline ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from ISpline ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from ISpline ).
Public property | Flags | Gets or sets a bit-coded flag indicating the spline type. (inherited from ISpline ).
Public property | GlobalWidth | Gets or sets a global width for this polyline. (inherited from ISpline ).
Public property | IsByAngles | Gets a value indicating whether this spline was created by specifying fit points and tangents or by control points and knots. (inherited from ISpline ).
Public property | IsMeshMClosed | Gets a value indicating whether the polygon mesh is closed in the M direction. (inherited from ISpline ).
Public property | IsMeshNClosed | Gets a value indicating whether the polygon mesh is closed in the N direction. (inherited from ISpline ).
Public property | IsPolyFaceMesh | Gets a value indicating whether this polyline is a polyface mesh. (inherited from ISpline ).
Public property | IsPolyZThickness | Gets a value indicating whether the polyline has thickness measured along the axis Z. (inherited from ISpline ).
Public property | IsPolygonMesh | Gets a value indicating whether this polyline is a polygon mesh. (inherited from ISpline ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from ISpline ).
Public property | Length | Gets a length of this spline. (inherited from ISpline ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from ISpline ).
Public property | MeshM | Gets or sets a number of vertices for the polygon mesh in the M direction. (inherited from ISpline ).
Public property | MeshN | Gets or sets a number of vertices for the polygon mesh in the N direction. (inherited from ISpline ).
Public property | Name | Gets or sets a name of this object. (inherited from ISpline ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from ISpline ).
Public property | PenLine | Gets properties of the pen used for drawing the object. (inherited from ISpline ).
Public property | PointsCount | Gets a number of the polyline points. (inherited from ISpline ).
Public property | PolyFaceVertexIndexesCount | Gets a quantity of indices which specify the order of traversing vertices in the polyface mesh. (inherited from ISpline ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from ISpline ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from ISpline ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from ISpline ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from ISpline ).

Top

collall See Also

Reference

Spline Interface


Spline Methods

API Reference > CADViewLib Namespace > Spline Interface >

Spline Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from ISpline ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from ISpline ).
Public method | ControlCount | Returns the number of control points. (inherited from ISpline ).
Public method | CreateEntity | Initializes a new object instance. (inherited from ISpline ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from ISpline ).
Public method | EntName | Returns a name of the entity. (inherited from ISpline ).
Public method | FitCount | Returns the number of fit points. (inherited from ISpline ).
Public method | FreeEntity | Destroys the object instance. (inherited from ISpline ).
Public method | GetArea | Returns the area bounded by a closed polygon. (inherited from ISpline ).
Public method | GetBoxPoints | For internal use. (inherited from ISpline ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from ISpline ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from ISpline ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from ISpline ).
Public method | RemoveEntity | Removes a specified entity. (inherited from ISpline ).
Public method | SetLType | Sets a line type for this object. (inherited from ISpline ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from ISpline ).
Public method | get_Arrows | Returns a point of the arrowhead. (inherited from ISpline ).
Public method | get_ControlPoints | Returns the control point at the given index. (inherited from ISpline ).
Public method | get_DottedPoints | Returns coordinates of a point in the points array that determines dots and dashes for a non-solid line type. (inherited from ISpline ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from ISpline ).
Public method | get_FitPoints | Returns the fit point at the given index. (inherited from ISpline ).
Public method | get_Points | Returns coordinates of a point in the points array. (inherited from ISpline ).
Public method | get_PolyFaceVertexIndexes | Returns a value which indicates an index of the polyface mesh vertex. (inherited from ISpline ).
Public method | set_Arrows | Modifies a point of the arrowhead at the given index. (inherited from ISpline ).

Top

collall See Also

Reference

Spline Interface


Text Interface

API Reference > CADViewLib Namespace >

Text Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to TEXT entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface Text
Inherits IText, _
IEntityEvents_Event

C#

public interface Text : IText,
IEntityEvents_Event

C++

public interface class Text : public IText^,
public IEntityEvents_Event^

JScript

public interface Text
implements IText,
IEntityEvents_Event

collall See Also

Reference

Text Members


Text Members

API Reference > CADViewLib Namespace > Text Interface >

Text Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to TEXT entities.

The following tables list the members exposed by the Text type.

collall Public Properties

 | Name | Description
Public property | Backward | Gets a value indicating whether the text is drawn backwards. (inherited from IText ).
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from IText ).
Public property | CADHandle | Gets or sets the object handle. (inherited from IText ).
Public property | Color | Gets or sets a color of the object. (inherited from IText ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from IText ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from IText ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from IText ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from IText ).
Public property | Font | Gets or sets a font for displaying the text. (inherited from IText ).
Public property | FontName | Gets or sets a name of the font file. (inherited from IText ).
Public property | Generation | Gets or sets text generation flags. (inherited from IText ).
Public property | HAlign | Gets or sets horizontal text justification type integer codes (not bit-coded). (inherited from IText ).
Public property | Height | Gets or sets a height of the text. (inherited from IText ).
Public property | IsSHXFont | Gets a value indicating whether the text uses an SHX font. (inherited from IText ).
Public property | IsUnicodeText | Gets a value indicating whether the text uses Unicode for characters encoding. (inherited from IText ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from IText ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from IText ).
Public property | Name | Gets or sets a name of this object. (inherited from IText ).
Public property | ObliqueAngle | Gets or sets an oblique angle for text characters. (inherited from IText ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from IText ).
Public property | Point | Gets or sets the first alignment point. (inherited from IText ).
Public property | Point1 | Gets or sets the second alignment point. (inherited from IText ).
Public property | Rotation | Gets or sets the rotation angle of the text. (inherited from IText ).
Public property | SHXFontName | Gets or sets a name of SHX font file. (inherited from IText ).
Public property | SHXText | Gets a string of the SHX text. (inherited from IText ).
Public property | SHXUnicodeText | Gets a string of the SHX Unicode text. (inherited from IText ).
Public property | Scale | Gets or sets relative X scale factor (width). (inherited from IText ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from IText ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from IText ).
Public property | StartPoint | Gets the start point of the text. (inherited from IText ).
Public property | Text | Gets or sets the text value. (inherited from IText ).
Public property | UnicodeText | Gets the text value as Unicode string. (inherited from IText ).
Public property | UpsideDown | Gets a value indicating whether the text is upside down (mirrored in Y). (inherited from IText ).
Public property | VAlign | Gets or sets vertical text justification type: integer codes (not bit-coded). (inherited from IText ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from IText ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from IText ).
Public property | WinFont | Gets a value indicating whether the text is rendered using a Windows font. (inherited from IText ).
Public property | XScale | Gets or sets relative X scale factor (width). (inherited from IText ).

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from IText ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from IText ).
Public method | CreateEntity | Initializes a new object instance. (inherited from IText ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from IText ).
Public method | DoNewText | Replaces the text value with a new string. (inherited from IText ).
Public method | EntName | Returns a name of the entity. (inherited from IText ).
Public method | FreeEntity | Destroys the object instance. (inherited from IText ).
Public method | GetBase | Returns the base point of the text. (inherited from IText ).
Public method | GetBoxPoints | For internal use. (inherited from IText ).
Public method | GetSHXMatrix | Returns a coordinate transformation matrix. (inherited from IText ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from IText ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from IText ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from IText ).
Public method | RemoveEntity | Removes a specified entity. (inherited from IText ).
Public method | SetLType | Sets a line type for this object. (inherited from IText ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from IText ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from IText ).

Top

collall See Also

Reference

Text Interface


Text Properties

API Reference > CADViewLib Namespace > Text Interface >

Text Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Backward | Gets a value indicating whether the text is drawn backwards. (inherited from IText ).
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from IText ).
Public property | CADHandle | Gets or sets the object handle. (inherited from IText ).
Public property | Color | Gets or sets a color of the object. (inherited from IText ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from IText ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from IText ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from IText ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from IText ).
Public property | Font | Gets or sets a font for displaying the text. (inherited from IText ).
Public property | FontName | Gets or sets a name of the font file. (inherited from IText ).
Public property | Generation | Gets or sets text generation flags. (inherited from IText ).
Public property | HAlign | Gets or sets horizontal text justification type integer codes (not bit-coded). (inherited from IText ).
Public property | Height | Gets or sets a height of the text. (inherited from IText ).
Public property | IsSHXFont | Gets a value indicating whether the text uses an SHX font. (inherited from IText ).
Public property | IsUnicodeText | Gets a value indicating whether the text uses Unicode for characters encoding. (inherited from IText ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from IText ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from IText ).
Public property | Name | Gets or sets a name of this object. (inherited from IText ).
Public property | ObliqueAngle | Gets or sets an oblique angle for text characters. (inherited from IText ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from IText ).
Public property | Point | Gets or sets the first alignment point. (inherited from IText ).
Public property | Point1 | Gets or sets the second alignment point. (inherited from IText ).
Public property | Rotation | Gets or sets the rotation angle of the text. (inherited from IText ).
Public property | SHXFontName | Gets or sets a name of SHX font file. (inherited from IText ).
Public property | SHXText | Gets a string of the SHX text. (inherited from IText ).
Public property | SHXUnicodeText | Gets a string of the SHX Unicode text. (inherited from IText ).
Public property | Scale | Gets or sets relative X scale factor (width). (inherited from IText ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from IText ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from IText ).
Public property | StartPoint | Gets the start point of the text. (inherited from IText ).
Public property | Text | Gets or sets the text value. (inherited from IText ).
Public property | UnicodeText | Gets the text value as Unicode string. (inherited from IText ).
Public property | UpsideDown | Gets a value indicating whether the text is upside down (mirrored in Y). (inherited from IText ).
Public property | VAlign | Gets or sets vertical text justification type: integer codes (not bit-coded). (inherited from IText ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from IText ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from IText ).
Public property | WinFont | Gets a value indicating whether the text is rendered using a Windows font. (inherited from IText ).
Public property | XScale | Gets or sets relative X scale factor (width). (inherited from IText ).

Top

collall See Also

Reference

Text Interface


Text Methods

API Reference > CADViewLib Namespace > Text Interface >

Text Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from IText ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from IText ).
Public method | CreateEntity | Initializes a new object instance. (inherited from IText ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from IText ).
Public method | DoNewText | Replaces the text value with a new string. (inherited from IText ).
Public method | EntName | Returns a name of the entity. (inherited from IText ).
Public method | FreeEntity | Destroys the object instance. (inherited from IText ).
Public method | GetBase | Returns the base point of the text. (inherited from IText ).
Public method | GetBoxPoints | For internal use. (inherited from IText ).
Public method | GetSHXMatrix | Returns a coordinate transformation matrix. (inherited from IText ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from IText ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from IText ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from IText ).
Public method | RemoveEntity | Removes a specified entity. (inherited from IText ).
Public method | SetLType | Sets a line type for this object. (inherited from IText ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from IText ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from IText ).

Top

collall See Also

Reference

Text Interface


ToolBox Interface

API Reference > CADViewLib Namespace >

ToolBox Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to the CADViewX toolbar.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface ToolBox
Inherits IToolBox, _
IToolBoxEvents_Event

C#

public interface ToolBox : IToolBox,
IToolBoxEvents_Event

C++

public interface class ToolBox : public IToolBox^,
public IToolBoxEvents_Event^

JScript

public interface ToolBox
implements IToolBox,
IToolBoxEvents_Event

collall See Also

Reference

ToolBox Members


ToolBox Members

API Reference > CADViewLib Namespace > ToolBox Interface >

ToolBox Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to the CADViewX toolbar.

The following tables list the members exposed by the ToolBox type.

collall Public Properties

 | Name | Description
Public property | Caption | Gets or sets a caption for the toolbox. (inherited from IToolBox ).
Public property | Control | Gets the CADViewX control instance to which this toolbox belongs. (inherited from IToolBox ).
Public property | Enabled | Gets or sets a value indicating whether the toolbox is enabled. (inherited from IToolBox ).
Public property | Handle | Gets or sets a handle to the toolbox. (inherited from IToolBox ).
Public property | Height | Gets or sets the toolbox height. (inherited from IToolBox ).
Public property | ItemCount | Gets a number of toolbox items. (inherited from IToolBox ).
Public property | Left | Gets or sets the X-coordinate of the top-left corner. (inherited from IToolBox ).
Public property | Parent | (inherited from IToolBox ).
Public property | Top | Gets or sets the Y-coordinate of the top-left corner. (inherited from IToolBox ).
Public property | Visible | Gets or sets a value indicating whether the toolbox is visible. (inherited from IToolBox ).
Public property | Width | Gets or sets the toolbox width. (inherited from IToolBox ).

Top

collall Public Methods

 | Name | Description
Public method | Dock | Docks the toolbox to the frame of the CADViewX main window. (inherited from IToolBox ).
Public method | ItemClick | Triggers the mouse click on a specified toolbox button. (inherited from IToolBox ).
Public method | UnDock | Undocks the toolbox from the frame of the CADViewX main window. (inherited from IToolBox ).

Top

collall See Also

Reference

ToolBox Interface


ToolBox Properties

API Reference > CADViewLib Namespace > ToolBox Interface >

ToolBox Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Caption | Gets or sets a caption for the toolbox. (inherited from IToolBox ).
Public property | Control | Gets the CADViewX control instance to which this toolbox belongs. (inherited from IToolBox ).
Public property | Enabled | Gets or sets a value indicating whether the toolbox is enabled. (inherited from IToolBox ).
Public property | Handle | Gets or sets a handle to the toolbox. (inherited from IToolBox ).
Public property | Height | Gets or sets the toolbox height. (inherited from IToolBox ).
Public property | ItemCount | Gets a number of toolbox items. (inherited from IToolBox ).
Public property | Left | Gets or sets the X-coordinate of the top-left corner. (inherited from IToolBox ).
Public property | Parent | (inherited from IToolBox ).
Public property | Top | Gets or sets the Y-coordinate of the top-left corner. (inherited from IToolBox ).
Public property | Visible | Gets or sets a value indicating whether the toolbox is visible. (inherited from IToolBox ).
Public property | Width | Gets or sets the toolbox width. (inherited from IToolBox ).

Top

collall See Also

Reference

ToolBox Interface


ToolBox Methods

API Reference > CADViewLib Namespace > ToolBox Interface >

ToolBox Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | Dock | Docks the toolbox to the frame of the CADViewX main window. (inherited from IToolBox ).
Public method | ItemClick | Triggers the mouse click on a specified toolbox button. (inherited from IToolBox ).
Public method | UnDock | Undocks the toolbox from the frame of the CADViewX main window. (inherited from IToolBox ).

Top

collall See Also

Reference

ToolBox Interface


Vertex Interface

API Reference > CADViewLib Namespace >

Vertex Interface

 Return to chapter overview

Show / hide the hidden text

Provides an access to VERTEX entities.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Interface Vertex
Inherits IVertex, _
IEntityEvents_Event

C#

public interface Vertex : IVertex,
IEntityEvents_Event

C++

public interface class Vertex : public IVertex^,
public IEntityEvents_Event^

JScript

public interface Vertex
implements IVertex,
IEntityEvents_Event

collall See Also

Reference

Vertex Members


Vertex Members

API Reference > CADViewLib Namespace > Vertex Interface >

Vertex Members

 Return to chapter overview

Show / hide the hidden text

Provides an access to VERTEX entities.

The following tables list the members exposed by the Vertex type.

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from IVertex ).
Public property | Bulge | Gets or sets the bulge value for this vertex. (inherited from IVertex ).
Public property | CADHandle | Gets or sets the object handle. (inherited from IVertex ).
Public property | Color | Gets or sets a color of the object. (inherited from IVertex ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from IVertex ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from IVertex ).
Public property | EndWidth | Gets or sets the ending width. (inherited from IVertex ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from IVertex ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from IVertex ).
Public property | Flags | Gets or sets vertex flags. (inherited from IVertex ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from IVertex ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from IVertex ).
Public property | Name | Gets or sets a name of this object. (inherited from IVertex ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from IVertex ).
Public property | Point | Gets or sets the location point for this vertex. (inherited from IVertex ).
Public property | PolyFaceVertexIndex1 | Gets or sets polyface mesh vertex index. (inherited from IVertex ).
Public property | PolyFaceVertexIndex2 | Gets or sets polyface mesh vertex index. (inherited from IVertex ).
Public property | PolyFaceVertexIndex3 | Gets or sets polyface mesh vertex index. (inherited from IVertex ).
Public property | PolyFaceVertexIndex4 | Gets or sets polyface mesh vertex index. (inherited from IVertex ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from IVertex ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from IVertex ).
Public property | StartWidth | Gets or sets the starting width. (inherited from IVertex ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from IVertex ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from IVertex ).

Top

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from IVertex ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from IVertex ).
Public method | CreateEntity | Initializes a new object instance. (inherited from IVertex ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from IVertex ).
Public method | EntName | Returns a name of the entity. (inherited from IVertex ).
Public method | FreeEntity | Destroys the object instance. (inherited from IVertex ).
Public method | GetBoxPoints | For internal use. (inherited from IVertex ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from IVertex ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from IVertex ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from IVertex ).
Public method | RemoveEntity | Removes a specified entity. (inherited from IVertex ).
Public method | SetLType | Sets a line type for this object. (inherited from IVertex ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from IVertex ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from IVertex ).

Top

collall See Also

Reference

Vertex Interface


Vertex Properties

API Reference > CADViewLib Namespace > Vertex Interface >

Vertex Properties

 Return to chapter overview

Show / hide the hidden text

collall Public Properties

 | Name | Description
Public property | Box | Gets or sets the bounding parallelepiped for the object. (inherited from IVertex ).
Public property | Bulge | Gets or sets the bulge value for this vertex. (inherited from IVertex ).
Public property | CADHandle | Gets or sets the object handle. (inherited from IVertex ).
Public property | Color | Gets or sets a color of the object. (inherited from IVertex ).
Public property | Converter | Gets or sets a Converter instance associated with the CAD image to which this object belongs. (inherited from IVertex ).
Public property | Count | Gets a number of objects contained within the given object. (inherited from IVertex ).
Public property | EndWidth | Gets or sets the ending width. (inherited from IVertex ).
Public property | EntID | Gets or sets the entity type ID for this object. (inherited from IVertex ).
Public property | Extrusion | Gets or sets the extrusion direction vector for this object. (inherited from IVertex ).
Public property | Flags | Gets or sets vertex flags. (inherited from IVertex ).
Public property | Layer | Gets or sets a layer containing this object. (inherited from IVertex ).
Public property | LineTypeScale | Gets or sets a quantity of line type elements per unit of its length. (inherited from IVertex ).
Public property | Name | Gets or sets a name of this object. (inherited from IVertex ).
Public property | PaperSpace | Gets or sets a value indicating whether this object is located in Paper space. (inherited from IVertex ).
Public property | Point | Gets or sets the location point for this vertex. (inherited from IVertex ).
Public property | PolyFaceVertexIndex1 | Gets or sets polyface mesh vertex index. (inherited from IVertex ).
Public property | PolyFaceVertexIndex2 | Gets or sets polyface mesh vertex index. (inherited from IVertex ).
Public property | PolyFaceVertexIndex3 | Gets or sets polyface mesh vertex index. (inherited from IVertex ).
Public property | PolyFaceVertexIndex4 | Gets or sets polyface mesh vertex index. (inherited from IVertex ).
Public property | SrcEnd | Indicates the end of the record which represents this object in an drawing file. (inherited from IVertex ).
Public property | SrcStart | Indicates the beginning of the record which represents this object in an drawing file. (inherited from IVertex ).
Public property | StartWidth | Gets or sets the starting width. (inherited from IVertex ).
Public property | Visibility | Gets or sets a value indicating whether this object is visible. (inherited from IVertex ).
Public property | Visible | Gets or sets a value indicating whether this object is visible. (inherited from IVertex ).

Top

collall See Also

Reference

Vertex Interface


Vertex Methods

API Reference > CADViewLib Namespace > Vertex Interface >

Vertex Methods

 Return to chapter overview

Show / hide the hidden text

collall Public Methods

 | Name | Description
Public method | AddEntity | Adds a new child entity to this object. (inherited from IVertex ).
Public method | AssignEntity | Assigns the properties of the specified entity to this object. (inherited from IVertex ).
Public method | CreateEntity | Initializes a new object instance. (inherited from IVertex ).
Public method | DeleteEntity | Removes an entity specified by index. (inherited from IVertex ).
Public method | EntName | Returns a name of the entity. (inherited from IVertex ).
Public method | FreeEntity | Destroys the object instance. (inherited from IVertex ).
Public method | GetBoxPoints | For internal use. (inherited from IVertex ).
Public method | GetThickness | Returns the line thickness for this object. (inherited from IVertex ).
Public method | IndexOfEntity | Returns index of the given entity. (inherited from IVertex ).
Public method | Iterate | Iterates through the entities in the drawing database. (inherited from IVertex ).
Public method | RemoveEntity | Removes a specified entity. (inherited from IVertex ).
Public method | SetLType | Sets a line type for this object. (inherited from IVertex ).
Public method | SetLWeight | Sets a line weight for this object. (inherited from IVertex ).
Public method | get_Entities | Returns the child entity at the given index. (inherited from IVertex ).

Top

collall See Also

Reference

Vertex Interface


ICADViewXEvents_OnActivateEventHandler Delegate

API Reference > CADViewLib Namespace >

ICADViewXEvents_OnActivateEventHandler Delegate

 Return to chapter overview

Show / hide the hidden text

Delegate for the OnActivate event.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Delegate Sub ICADViewXEvents_OnActivateEventHandler()

C#

public delegate void ICADViewXEvents_OnActivateEventHandler()

C++

public:
delegate void ICADViewXEvents_OnActivateEventHandler()

JScript

JScript supports the use of delegates, but not the declaration of new ones.

collall See Also

Reference

CADViewLib Namespace


ICADViewXEvents_OnAfterLoadEventHandler Delegate

API Reference > CADViewLib Namespace >

ICADViewXEvents_OnAfterLoadEventHandler Delegate

 Return to chapter overview

Show / hide the hidden text

Delegate for the OnAfterLoad event.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Delegate Sub ICADViewXEvents_OnAfterLoadEventHandler()

C#

public delegate void ICADViewXEvents_OnAfterLoadEventHandler()

C++

public:
delegate void ICADViewXEvents_OnAfterLoadEventHandler()

JScript

JScript supports the use of delegates, but not the declaration of new ones.

collall See Also

Reference

CADViewLib Namespace


ICADViewXEvents_OnBeforeLoadEventHandler Delegate

API Reference > CADViewLib Namespace >

ICADViewXEvents_OnBeforeLoadEventHandler Delegate

 Return to chapter overview

Show / hide the hidden text

Delegate for the OnBeforeLoad event.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Delegate Sub ICADViewXEvents_OnBeforeLoadEventHandler()

C#

public delegate void ICADViewXEvents_OnBeforeLoadEventHandler()

C++

public:
delegate void ICADViewXEvents_OnBeforeLoadEventHandler()

JScript

JScript supports the use of delegates, but not the declaration of new ones.

collall See Also

Reference

CADViewLib Namespace


ICADViewXEvents_OnClickEventHandler Delegate

API Reference > CADViewLib Namespace >

ICADViewXEvents_OnClickEventHandler Delegate

 Return to chapter overview

Show / hide the hidden text

Delegate for the OnClick event.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Delegate Sub ICADViewXEvents_OnClickEventHandler()

C#

public delegate void ICADViewXEvents_OnClickEventHandler()

C++

public:
delegate void ICADViewXEvents_OnClickEventHandler()

JScript

JScript supports the use of delegates, but not the declaration of new ones.

collall See Also

Reference

CADViewLib Namespace


ICADViewXEvents_OnCreateEventHandler Delegate

API Reference > CADViewLib Namespace >

ICADViewXEvents_OnCreateEventHandler Delegate

 Return to chapter overview

Show / hide the hidden text

Delegate for the OnCreate event.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Delegate Sub ICADViewXEvents_OnCreateEventHandler()

C#

public delegate void ICADViewXEvents_OnCreateEventHandler()

C++

public:
delegate void ICADViewXEvents_OnCreateEventHandler()

JScript

JScript supports the use of delegates, but not the declaration of new ones.

collall See Also

Reference

CADViewLib Namespace


ICADViewXEvents_OnDblClickEventHandler Delegate

API Reference > CADViewLib Namespace >

ICADViewXEvents_OnDblClickEventHandler Delegate

 Return to chapter overview

Show / hide the hidden text

Delegate for the OnDblClick event.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Delegate Sub ICADViewXEvents_OnDblClickEventHandler()

C#

public delegate void ICADViewXEvents_OnDblClickEventHandler()

C++

public:
delegate void ICADViewXEvents_OnDblClickEventHandler()

JScript

JScript supports the use of delegates, but not the declaration of new ones.

collall See Also

Reference

CADViewLib Namespace


ICADViewXEvents_OnDeactivateEventHandler Delegate

API Reference > CADViewLib Namespace >

ICADViewXEvents_OnDeactivateEventHandler Delegate

 Return to chapter overview

Show / hide the hidden text

Delegate for the OnDeactivate event.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Delegate Sub ICADViewXEvents_OnDeactivateEventHandler()

C#

public delegate void ICADViewXEvents_OnDeactivateEventHandler()

C++

public:
delegate void ICADViewXEvents_OnDeactivateEventHandler()

JScript

JScript supports the use of delegates, but not the declaration of new ones.

collall See Also

Reference

CADViewLib Namespace


ICADViewXEvents_OnDestroyEventHandler Delegate

API Reference > CADViewLib Namespace >

ICADViewXEvents_OnDestroyEventHandler Delegate

 Return to chapter overview

Show / hide the hidden text

Delegate for the OnDestroy event.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Delegate Sub ICADViewXEvents_OnDestroyEventHandler()

C#

public delegate void ICADViewXEvents_OnDestroyEventHandler()

C++

public:
delegate void ICADViewXEvents_OnDestroyEventHandler()

JScript

JScript supports the use of delegates, but not the declaration of new ones.

collall See Also

Reference

CADViewLib Namespace


ICADViewXEvents_OnIterateEventHandler Delegate

API Reference > CADViewLib Namespace >

ICADViewXEvents_OnIterateEventHandler Delegate

 Return to chapter overview

Show / hide the hidden text

Delegate for the OnIterate event.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Delegate Sub ICADViewXEvents_OnIterateEventHandler( _
ByVal AEntity As Object _
)

C#

public delegate void ICADViewXEvents_OnIterateEventHandler(
objectAEntity
)

C++

public:
delegate void ICADViewXEvents_OnIterateEventHandler(
object^ AEntity
)

JScript

JScript supports the use of delegates, but not the declaration of new ones.

Parameters

AEntity

The entity which are currently processed.

collall See Also

Reference

CADViewLib Namespace


ICADViewXEvents_OnKeyDownEventHandler Delegate

API Reference > CADViewLib Namespace >

ICADViewXEvents_OnKeyDownEventHandler Delegate

 Return to chapter overview

Show / hide the hidden text

Delegate for the OnKeyDown event.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Delegate Sub ICADViewXEvents_OnKeyDownEventHandler( _
ByRef Key As Short, _
ByVal Shift As TxShiftState _
)

C#

public delegate void ICADViewXEvents_OnKeyDownEventHandler(
ref shortKey,
TxShiftStateShift
)

C++

public:
delegate void ICADViewXEvents_OnKeyDownEventHandler(
short& Key,
TxShiftStateShift
)

JScript

JScript supports the use of delegates, but not the declaration of new ones.

Parameters

Key

Code of the pressed key.

Shift

Modifier key or mouse button that was held down in combination with the pressed key.

collall See Also

Reference

CADViewLib Namespace


ICADViewXEvents_OnKeyPressEventHandler Delegate

API Reference > CADViewLib Namespace >

ICADViewXEvents_OnKeyPressEventHandler Delegate

 Return to chapter overview

Show / hide the hidden text

Delegate for the OnKeyPress event.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Delegate Sub ICADViewXEvents_OnKeyPressEventHandler( _
ByRef Key As Short _
)

C#

public delegate void ICADViewXEvents_OnKeyPressEventHandler(
ref shortKey
)

C++

public:
delegate void ICADViewXEvents_OnKeyPressEventHandler(
short& Key
)

JScript

JScript supports the use of delegates, but not the declaration of new ones.

Parameters

Key

Code of the pressed key.

collall See Also

Reference

CADViewLib Namespace


ICADViewXEvents_OnLayoutChangeEventHandler Delegate

API Reference > CADViewLib Namespace >

ICADViewXEvents_OnLayoutChangeEventHandler Delegate

 Return to chapter overview

Show / hide the hidden text

Delegate for the OnLayoutChange event.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Delegate Sub ICADViewXEvents_OnLayoutChangeEventHandler()

C#

public delegate void ICADViewXEvents_OnLayoutChangeEventHandler()

C++

public:
delegate void ICADViewXEvents_OnLayoutChangeEventHandler()

JScript

JScript supports the use of delegates, but not the declaration of new ones.

collall See Also

Reference

CADViewLib Namespace


ICADViewXEvents_OnMouseDownEventHandler Delegate

API Reference > CADViewLib Namespace >

ICADViewXEvents_OnMouseDownEventHandler Delegate

 Return to chapter overview

Show / hide the hidden text

Delegate for the OnMouseDown event.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Delegate Sub ICADViewXEvents_OnMouseDownEventHandler( _
ByVal Button As TxMouseButton, _
ByVal Shift As TxShiftState, _
ByVal X As Integer, _
ByVal Y As Integer _
)

C#

public delegate void ICADViewXEvents_OnMouseDownEventHandler(
TxMouseButtonButton,
TxShiftStateShift,
intX,
intY
)

C++

public:
delegate void ICADViewXEvents_OnMouseDownEventHandler(
TxMouseButtonButton,
TxShiftStateShift,
intX,
intY
)

JScript

JScript supports the use of delegates, but not the declaration of new ones.

Parameters

Button

The mouse button that was pressed.

Shift

Modifier key or mouse button that was held down in combination with the pressed button.

X

The X coordinate of the mouse pointer.

Y

The Y coordinate of the mouse pointer.

collall See Also

Reference

CADViewLib Namespace


ICADViewXEvents_OnMouseMoveEventHandler Delegate

API Reference > CADViewLib Namespace >

ICADViewXEvents_OnMouseMoveEventHandler Delegate

 Return to chapter overview

Show / hide the hidden text

Delegate for the OnMouseMove event.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Delegate Sub ICADViewXEvents_OnMouseMoveEventHandler( _
ByVal Shift As TxShiftState, _
ByVal X As Integer, _
ByVal Y As Integer _
)

C#

public delegate void ICADViewXEvents_OnMouseMoveEventHandler(
TxShiftStateShift,
intX,
intY
)

C++

public:
delegate void ICADViewXEvents_OnMouseMoveEventHandler(
TxShiftStateShift,
intX,
intY
)

JScript

JScript supports the use of delegates, but not the declaration of new ones.

Parameters

Shift

Modifier key or mouse button that was held down when moving the mouse.

X

The X coordinate of the mouse pointer.

Y

The Y coordinate of the mouse pointer.

collall See Also

Reference

CADViewLib Namespace


ICADViewXEvents_OnMouseUpEventHandler Delegate

API Reference > CADViewLib Namespace >

ICADViewXEvents_OnMouseUpEventHandler Delegate

 Return to chapter overview

Show / hide the hidden text

Delegate for the OnMouseUp event.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Delegate Sub ICADViewXEvents_OnMouseUpEventHandler( _
ByVal Button As TxMouseButton, _
ByVal Shift As TxShiftState, _
ByVal X As Integer, _
ByVal Y As Integer _
)

C#

public delegate void ICADViewXEvents_OnMouseUpEventHandler(
TxMouseButtonButton,
TxShiftStateShift,
intX,
intY
)

C++

public:
delegate void ICADViewXEvents_OnMouseUpEventHandler(
TxMouseButtonButton,
TxShiftStateShift,
intX,
intY
)

JScript

JScript supports the use of delegates, but not the declaration of new ones.

Parameters

Button

The mouse button that is released.

Shift

Modifier key or mouse button that was held down when the mouse button is released.

X

The X coordinate of the mouse pointer.

Y

The Y coordinate of the mouse pointer.

collall See Also

Reference

CADViewLib Namespace


ICADViewXEvents_OnMouseWheelDownEventHandler Delegate

API Reference > CADViewLib Namespace >

ICADViewXEvents_OnMouseWheelDownEventHandler Delegate

 Return to chapter overview

Show / hide the hidden text

Delegate for the OnMouseWheelDown event.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Delegate Sub ICADViewXEvents_OnMouseWheelDownEventHandler( _
ByVal Shift As TxShiftState, _
ByVal X As Integer, _
ByVal Y As Integer, _
ByRef Handled As Boolean _
)

C#

public delegate void ICADViewXEvents_OnMouseWheelDownEventHandler(
TxShiftStateShift,
intX,
intY,
ref boolHandled
)

C++

public:
delegate void ICADViewXEvents_OnMouseWheelDownEventHandler(
TxShiftStateShift,
intX,
intY,
bool& Handled
)

JScript

JScript supports the use of delegates, but not the declaration of new ones.

Parameters

Shift

Modifier key or mouse button that was held down when moving the mouse wheel.

X

The X coordinate of the mouse pointer.

Y

The Y coordinate of the mouse pointer.

Handled

collall See Also

Reference

CADViewLib Namespace


ICADViewXEvents_OnMouseWheelUpEventHandler Delegate

API Reference > CADViewLib Namespace >

ICADViewXEvents_OnMouseWheelUpEventHandler Delegate

 Return to chapter overview

Show / hide the hidden text

Delegate for the OnMouseWheelUp event.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Delegate Sub ICADViewXEvents_OnMouseWheelUpEventHandler( _
ByVal Shift As TxShiftState, _
ByVal X As Integer, _
ByVal Y As Integer, _
ByRef Handled As Boolean _
)

C#

public delegate void ICADViewXEvents_OnMouseWheelUpEventHandler(
TxShiftStateShift,
intX,
intY,
ref boolHandled
)

C++

public:
delegate void ICADViewXEvents_OnMouseWheelUpEventHandler(
TxShiftStateShift,
intX,
intY,
bool& Handled
)

JScript

JScript supports the use of delegates, but not the declaration of new ones.

Parameters

Shift

Modifier key or mouse button that was held down when moving the mouse wheel.

X

The X coordinate of the mouse pointer.

Y

The Y coordinate of the mouse pointer.

Handled

collall See Also

Reference

CADViewLib Namespace


ICADViewXEvents_OnPaintEventHandler Delegate

API Reference > CADViewLib Namespace >

ICADViewXEvents_OnPaintEventHandler Delegate

 Return to chapter overview

Show / hide the hidden text

Delegate for the OnPaint event.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Delegate Sub ICADViewXEvents_OnPaintEventHandler()

C#

public delegate void ICADViewXEvents_OnPaintEventHandler()

C++

public:
delegate void ICADViewXEvents_OnPaintEventHandler()

JScript

JScript supports the use of delegates, but not the declaration of new ones.

collall See Also

Reference

CADViewLib Namespace


ICADViewXEvents_OnProcessEventHandler Delegate

API Reference > CADViewLib Namespace >

ICADViewXEvents_OnProcessEventHandler Delegate

 Return to chapter overview

Show / hide the hidden text

Delegate for the OnProcess event.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Delegate Sub ICADViewXEvents_OnProcessEventHandler( _
ByVal AXML As String _
)

C#

public delegate void ICADViewXEvents_OnProcessEventHandler(
stringAXML
)

C++

public:
delegate void ICADViewXEvents_OnProcessEventHandler(
String^ AXML
)

JScript

JScript supports the use of delegates, but not the declaration of new ones.

Parameters

AXML

XML data generated by the event.

collall See Also

Reference

CADViewLib Namespace


ICADViewXEvents_OnProgressEventHandler Delegate

API Reference > CADViewLib Namespace >

ICADViewXEvents_OnProgressEventHandler Delegate

 Return to chapter overview

Show / hide the hidden text

Delegate for the OnProgress event.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Delegate Sub ICADViewXEvents_OnProgressEventHandler( _
ByVal State As TxProgressStage, _
ByVal PercentDone As Byte, _
ByVal RedrawNow As Boolean, _
ByVal Msg As String _
)

C#

public delegate void ICADViewXEvents_OnProgressEventHandler(
TxProgressStageState,
bytePercentDone,
boolRedrawNow,
stringMsg
)

C++

public:
delegate void ICADViewXEvents_OnProgressEventHandler(
TxProgressStageState,
BytePercentDone,
boolRedrawNow,
String^ Msg
)

JScript

JScript supports the use of delegates, but not the declaration of new ones.

Parameters

State

PercentDone

RedrawNow

Msg

collall See Also

Reference

CADViewLib Namespace


ICADViewXEvents_OnScalingEventHandler Delegate

API Reference > CADViewLib Namespace >

ICADViewXEvents_OnScalingEventHandler Delegate

 Return to chapter overview

Show / hide the hidden text

Delegate for the OnScaling event.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Delegate Sub ICADViewXEvents_OnScalingEventHandler()

C#

public delegate void ICADViewXEvents_OnScalingEventHandler()

C++

public:
delegate void ICADViewXEvents_OnScalingEventHandler()

JScript

JScript supports the use of delegates, but not the declaration of new ones.

collall See Also

Reference

CADViewLib Namespace


ICADViewXEvents_OnToolButtonClickEventHandler Delegate

API Reference > CADViewLib Namespace >

ICADViewXEvents_OnToolButtonClickEventHandler Delegate

 Return to chapter overview

Show / hide the hidden text

Delegate for the OnToolButtonClick event.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Delegate Sub ICADViewXEvents_OnToolButtonClickEventHandler( _
ByVal ToolButton As TxToolButton _
)

C#

public delegate void ICADViewXEvents_OnToolButtonClickEventHandler(
TxToolButtonToolButton
)

C++

public:
delegate void ICADViewXEvents_OnToolButtonClickEventHandler(
TxToolButtonToolButton
)

JScript

JScript supports the use of delegates, but not the declaration of new ones.

Parameters

ToolButton

Toolbar button or context menu item that was clicked.

collall See Also

Reference

CADViewLib Namespace


TAcadVersion Enumeration

API Reference > CADViewLib Namespace >

TAcadVersion Enumeration

 Return to chapter overview

Show / hide the hidden text

Indicates a version of an AutoCAD® drawing file.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Members

Member name | Description
acR09 | AutoCAD R09
acR10 | AutoCAD R10
acR11 | AutoCAD R11
acR12 | AutoCAD R12
acR13 | AutoCAD R13
acR14 | AutoCAD R14
acR2000 | AutoCAD 2000
acR2004 | AutoCAD 2004
acR2007 | AutoCAD 2007
acR2010 | AutoCAD 2010

collall See Also

Reference

CADViewLib Namespace


TDistanceUnits Enumeration

API Reference > CADViewLib Namespace >

TDistanceUnits Enumeration

 Return to chapter overview

Show / hide the hidden text

Indicates the drawing units.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Members

Member name | Description
duInch | Inches.
duMM | Millimeters.
duNone | None.

collall See Also

Reference

CADViewLib Namespace


TEntityID Enumeration

API Reference > CADViewLib Namespace >

TEntityID Enumeration

 Return to chapter overview

Show / hide the hidden text

Indicates the entity type ID.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Members

Member name | Description
eid3DFace | 3DFACE entity
eidArc | ARC entity
eidAttDef | ATTDEF entity
eidAttrib | ATTRIB entity
eidBlock | BLOCK entity
eidCircle | CIRCLE entity
eidDimension | DIMENSION entity
eidEllipse | ELLIPSE entity
eidFlatPoly | FlatPoly entity (only for HPGL drawings)
eidHatch | HATCH entity
eidImageEnt | IMAGE entity
eidInsert | INSERT entity
eidLType | LTYPE object (linetype)
eidLWPolyline | LWPOLYLINE entity
eidLayer | LAYER object
eidLayout | LAYOUT object
eidLine | LINE entity
eidMText | MTEXT entity
eidPoint | POINT entity
eidPolyline | POLYLINE entity
eidSolid | SOLID entity
eidSpline | SPLINE entity
eidTable | TABLE object
eidText | TEXT entity
eidUnknown | Unknown
eidVertex | VERTEX entity

collall See Also

Reference

CADViewLib Namespace


TxActiveFormBorderStyle Enumeration

API Reference > CADViewLib Namespace >

TxActiveFormBorderStyle Enumeration

 Return to chapter overview

Show / hide the hidden text

Indicates the border style for the control.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Members

Member name | Description
afbNone | No border.
afbRaised | A raised border.
afbSingle | A single-line border.
afbSunken | A sunken border.

collall See Also

Reference

CADViewLib Namespace


TxAlign Enumeration

API Reference > CADViewLib Namespace >

TxAlign Enumeration

 Return to chapter overview

Show / hide the hidden text

Indicates the alignment of a control.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Members

Member name | Description
alxBottom | The control moves to the bottom of its parent and resizes to fill the width of its parent. The height of the control is not affected.
alxClient | The control resizes to fill the client area of its parent.
alxCustom | Any type of custom alignment is allowed.
alxLeft | The control moves to the left side of its parent and resizes to fill the height of its parent. The width of the control is not affected.
alxNone | The control remains where it is positioned.
alxRight | The control moves to the right side of its parent and resizes to fill the height of its parent. The width of the control is not affected.
alxTop | The control moves to the top of its parent and resizes to fill the width of its parent. The height of the control is not affected.

collall See Also

Reference

CADViewLib Namespace


TxAxes Enumeration

API Reference > CADViewLib Namespace >

TxAxes Enumeration

 Return to chapter overview

Show / hide the hidden text

Indicates a 3D axis.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Members

Member name | Description
axisX | The x axis.
axisY | The y axis.
axisZ | The z axis.

collall See Also

Reference

CADViewLib Namespace


TxCADClassID Enumeration

API Reference > CADViewLib Namespace >

TxCADClassID Enumeration

 Return to chapter overview

Show / hide the hidden text

Indicates the CAD drawing type ID.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Members

Member name | Description
ccidCGM | CGM drawing.
ccidDWG | DWG drawing.
ccidDXF | DXF drawing.
ccidHPGL | HPGL drawing.
ccidSVG | SVG drawing.

collall See Also

Reference

CADViewLib Namespace


TxCADSpace Enumeration

API Reference > CADViewLib Namespace >

TxCADSpace Enumeration

 Return to chapter overview

Show / hide the hidden text

Indicates the type of CAD space.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Members

Member name | Description
cs2D | 2D space.
cs3D | 3D space
csUndefined | Undefined.

collall See Also

Reference

CADViewLib Namespace


TxColorDepth Enumeration

API Reference > CADViewLib Namespace >

TxColorDepth Enumeration

 Return to chapter overview

Show / hide the hidden text

Indicates the color depth (in bits per pixel).

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Members

Member name | Description
cd15bit | 15 bits per pixel.
cd16bit | 16 bits per pixel.
cd1bit | 1 bit per pixel.
cd24bit | 24 bits per pixel.
cd32bit | 32 bits per pixel.
cd4bit | 4 bits per pixel.
cd8bit | 8 bits per pixel.
cdCustom | Custom value.
cdDevice | A color depth of the display device.

collall See Also

Reference

CADViewLib Namespace


TxConvSection Enumeration

API Reference > CADViewLib Namespace >

TxConvSection Enumeration

 Return to chapter overview

Show / hide the hidden text

Indicates a section in the drawing database.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Members

Member name | Description
csBlockRecords | BLOCK_RECORDS section.
csBlocks | BLOCKS section.
csDimStyles | DIMSTYLES section.
csEntities | ENTITIES section.
csLTypes | LTYPES section.
csLayers | LAYERS section.
csStyles | STYLES section.
csTables | TABLES section.

collall See Also

Reference

CADViewLib Namespace


TxDXFDrawMode Enumeration

API Reference > CADViewLib Namespace >

TxDXFDrawMode Enumeration

 Return to chapter overview

Show / hide the hidden text

Indicates the appearance of colors in a drawing.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Members

Member name | Description
dmBlack | Objects appear in a black color.
dmGray | Objects appear in shades of gray.
dmNormal | Objects appear in their colors.

collall See Also

Reference

CADViewLib Namespace
DrawMode


TxDXFViewDirection Enumeration

API Reference > CADViewLib Namespace >

TxDXFViewDirection Enumeration

 Return to chapter overview

Show / hide the hidden text

Indicates orthographic and isometric views.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Members

Member name | Description
vdBack | Back view.
vdBottom | Bottom view.
vdFront | Front view.
vdLeft | Left view.
vdNEIsometric | NE (northeast) Isometric view.
vdNWIsometric | NW (northwest) Isometric view.
vdRight | Right view.
vdSEIsometric | SE (southeast) Isometric view.
vdSWIsometric | SW (southwest) Isometric view.
vdTop | Top view.

collall See Also

Reference

CADViewLib Namespace


TxMouseButton Enumeration

API Reference > CADViewLib Namespace >

TxMouseButton Enumeration

 Return to chapter overview

Show / hide the hidden text

Indicates the mouse button that was clicked.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Members

Member name | Description
mbLeft | The left button.
mbMiddle | The wheel button.
mbRight | The right button.

collall See Also

Reference

CADViewLib Namespace


TxPaperOrientation Enumeration

API Reference > CADViewLib Namespace >

TxPaperOrientation Enumeration

 Return to chapter overview

Show / hide the hidden text

Indicates the paper orientation.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Members

Member name | Description
poxLandscape | The landscape orientation.
poxPortrait | The portrait orientation.

collall See Also

Reference

CADViewLib Namespace


TxPrintScale Enumeration

API Reference > CADViewLib Namespace >

TxPrintScale Enumeration

 Return to chapter overview

Show / hide the hidden text

Indicates how a drawing will be scaled on print.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Members

Member name | Description
poNone | No scaling is applied.
poPrintToFit | The drawing is scaled to fill the page.
poProportional | The drawing is scaled proportionally.

collall See Also

Reference

CADViewLib Namespace


TxProgressStage Enumeration

API Reference > CADViewLib Namespace >

TxProgressStage Enumeration

 Return to chapter overview

Show / hide the hidden text

Indicates the current stage of the file loading progress.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Members

Member name | Description
psEnding | The ending stage of the file loading progress.
psRunning | The file loading is running.
psStarting | The starting stage of the file loading progress.

collall See Also

Reference

CADViewLib Namespace


TxShiftState Enumeration

API Reference > CADViewLib Namespace >

TxShiftState Enumeration

 Return to chapter overview

Show / hide the hidden text

Indicates what modifier keys and mouse buttons were held down in combination with a normal key.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Members

Member name | Description
ssAlt | The Alt key is held down.
ssCtrl | The Ctrl key is held down.
ssDouble | The mouse button was double-clicked.
ssLeft | The left mouse button is held down.
ssMiddle | The wheel mouse button is held down.
ssRight | The right mouse button is held down.
ssShift | The Shift key is held down.

collall See Also

Reference

CADViewLib Namespace


TxToolButton Enumeration

API Reference > CADViewLib Namespace >

TxToolButton Enumeration

 Return to chapter overview

Show / hide the hidden text

Indicates the toolbar button or context menu item.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Members

Member name | Description
tbAbout | The About CADViewX menu item.
tbBackBlack | The Black Background button.
tbBackWhite | The White Background button.
tbBlack | The Draw In Black button.
tbBorder | The Border On/Off button.
tbCheckUpdates | The Check Updates menu item.
tbColored | The Draw All Colors button.
tbCopyBMP | The Copy As BMP button.
tbCopyEMF | The Copy As EMF button.
tbFitToWindow | The Fit Drawing To Window button.
tbFloatingLicProps | The Floating License Registration menu item.
tbLayers | The Show Layers button.
tbLayoutToolBox | The Show Layouts Toolbox menu item.
tbOpen | The Open Picture button.
tbOptions | The Options button.
tbOrbit3D | The 3D Orbit button.
tbPrint | The Print button.
tbPrintPreview | The Print Preview button.
tbProperties | The Properties menu item.
tbRegister | The Register CADViewX menu item.
tbRotClockwise | The Rotate Clockwise button.
tbRotateCounterclockwise | The Rotate Counterclockwise button.
tbSave | The Save As button.
tbToolBox | The Show Toolbox menu item.
tbZoomIn | The Zoom In button.
tbZoomOut | The Zoom Out button.

collall See Also

Reference

CADViewLib Namespace


TxsgBorderType Enumeration

API Reference > CADViewLib Namespace >

TxsgBorderType Enumeration

 Return to chapter overview

Show / hide the hidden text

Indicates how a value of the drawing border size is calculated.

Namespace: CADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Members

Member name | Description
btGlobal | An absolute value.
btRatio | Relatively to the drawing extents.

collall See Also

Reference

CADViewLib Namespace


Demo applications

Demo applications

This section covers demo examples in different programming languages included into the package:

·demos for .NET

·demo for Delphi

·demo for HTML

·demo for Visual Basic

·demo for Word

·VB export to Word


.NET Demos

Demo applications >

.NET Demos

 Return to chapter overview

This section covers the samples written in .NET languages.


Demo for C#

Demo applications > .NET Demos >

Demo for C#

 Return to chapter overview

The C# demo application has the following view:

Click the right mouse button when the cursor is over the component window to call the popup menu.

Menu in this demo consists of the following items:

·File:

·Open picture... - calls the Open dialog box

·Save As... - calls the Save As dialog box

·Close picture - closes the currently loaded image

·Print - sends an image to the printer currently installed in the system

·Print preview... - calls the Print Preview dialog box

·Exit - closes application

·View:

·Zoom in - increases the scale of an image

·Zoom out - decreases the scale of an image

·Previous scale - displays the loaded image with the previous scale

·Fit picture to window - fits the loaded image to the size of the component window

·Show/Hide border - switches the visibility of the border around an image

·Rotate +90 deg - rotates an image counterclockwise on 90 degrees

·Rotate -90 deg - rotates an image clockwise on 90 degrees

·Show layers - calls the Layers dialog box

·Show point... - calls the Show point dialog, it allows to display the necessary point of the drawing with the predefined scaling factor

·Options:

·Show/Hide toolbar - switches the visibility of the CADViewX toolbar

·Show/Hide layouts toolbar - switches the visibility of the CADViewX Layouts toolbar

·Show options dialog - calls the Options dialog box

·Load configuration - loads previously saved configuration - changes made in the Print Preview and Options dialog boxes

·Save configuration - saves current configuration - changes made in the Print Preview and Options dialog boxes

·? - calls the About CADViewX Lite dialog box


Demo for J#

Demo applications > .NET Demos >

Demo for J#

 Return to chapter overview

The J# demo application has the following view:

Click the right mouse button click when the cursor is over the component window to call the popup menu.

Menu in this demo consists of the following items:

·File:

·Open picture... - calls the Open dialog box

·Save As... - calls the Save As dialog box

·Close picture - closes the currently loaded image

·Print - sends an image to the printer currently installed in the system

·Print preview... - calls the Print Preview dialog box

·Exit - closes application

·View:

·Zoom in - increases the scale of an image

·Zoom out - decreases the scale of an image

·Previous scale - displays the loaded image with the previous scale

·Fit picture to window - fits the loaded image to the size of the component window

·Show/Hide border - switches the visibility of the border around an image

·Rotate +90 deg - rotates an image counterclockwise on 90 degrees

·Rotate -90 deg - rotates an image clockwise on 90 degrees

·Show layers - calls the Layers dialog box

·Show point... - calls the Show point dialog, it allows to display the necessary point of the drawing with the predefined scaling factor

·Options:

·Show/Hide toolbar - switches the visibility of the CADViewX toolbar

·Show/Hide layouts toolbar - switches the visibility of the CADViewX Layouts toolbar

·Show options dialog - calls the Options dialog box

·Load configuration - loads previously saved configuration - changes made in the Print Preview and Options dialog boxes

·Save configuration - saves current configuration - changes made in the Print Preview and Options dialog boxes

·? - calls the About CADViewX Lite dialog box


Demo for Visual Basic .NET

Demo applications > .NET Demos >

Demo for Visual Basic .NET

 Return to chapter overview

The VB .NET demo application has the following view:

Click the right mouse button when the cursor is over the component window to call the popup menu.

Menu in this demo consists of the following items:

·File:

·Open picture... - calls the Open dialog box

·Save As... - calls the Save As dialog box

·Close - closes the currently loaded image

·Print - sends an image to the printer currently installed in the system

·Print Black and White - prints loaded file in black-and-white mode.

·Print preview... - calls the Print Preview dialog box

·Exit - closes application

·View:

·Zoom in - increases the scale of an image

·Zoom out - decreases the scale of an image

·Previous scale - displays an image with the previous scale

·Fit picture to window - fits an image to the size of the component window

·Show/Hide border - switches the visibility of the border around an image

·Rotate +90 deg - rotates an image counterclockwise on 90 degrees

·Rotate -90 deg - rotates an image clockwise on 90 degrees

·Show layers - calls the Layers dialog box

·Options:

·Show/Hide toolbar - switches the visibility of the CADViewX toolbar

·Show/Hide layouts toolbar - switches the visibility of the CADViewX Layouts toolbar

·Show options dialog - calls the Options dialog box

·Load configuration - loads previously saved configuration - changes made in the Print Preview and Options dialog boxes

·Save configuration - saves current configuration - changes made in the Print Preview and Options dialog boxes

·? - calls the About CADViewX Lite dialog box


Demo for Delphi

Demo applications >

Demo for Delphi

 Return to chapter overview

The Delphi demo application has the following view:

Click the right mouse button when the cursor is over the component window to call the popup menu.

Menu in this demo consists of the following items:

·File:

·Open - calls the standard Open dialog box

·Save - calls the Export file size dialog box and saves the currently loaded file to Windows™ Bitmap file format

·Close - closes the currently loaded image

·Print - sends an image to the printer currently installed in the system

·Print preview... - calls the Print Preview dialog box

·Exit - closes application

·Search:

·Find text - calls the Find text dialog box, creates a list of found text lines

·Find Next - zooms to the text lines from the beginning to the end through the list filled when using the Find text menu item

·Find Previous - zooms to the text lines from the end to the beginning through the list filled when using the Find text menu item

·View:

·Zoom in - increases the scale of an image

·Zoom out - decreases the scale of an image

·Fit drawing to window - fits an image to the size of the component window

·1:1 - displays an image with the scale 1:1

·Previous scale - displays an image with the previous scale

·Show/Hide border - switches the visibility of the border around an image

·Reopen CAD file with same view - demonstrates how to open files with the same scale factor and view point

·Show scaled area - demonstrates how the scaled area of an image around the cursor is displayed in a separate window

·Double buffered - switch this option on to reduce the amount of flicker when an image repaints (more memory is required)

·Options:

·Show/Hide toolbar - switches the visibility of the CADViewX toolbar

·Show/Hide layouts toolbar - switches the visibility of the CADViewX Layouts toolbar

·Options... - calls the Options dialog box

·Load configuration - loads previously saved configuration - changes made in the Print Preview and Options dialog boxes

·Save configuration - saves current configuration - changes made in the Print Preview and Options dialog boxes

·Dockable - makes the CADViewX component docked and undocked

·Help:

·Register CADViewX... - calls the CAViewX Lite Registration dialog box

·Floating licenses registration... - calls the Floating License dialog box

·About - calls the About CADViewX Lite dialog box

·Find text:

·Layers - this drop-down list allows selecting the necessary layer for the search

·Text to find - this field allows to enter the necessary text for the search

·Results - this field displays the results of the search

·Show scaled area:

·Dockable - the CADViewX control is undocked:

This demo application has the following toolbar:

embim34 - calls the standard Open dialog box

embim35 - calls the Export file size dialog box and saves currently loaded file to Windows™ Bitmap file format

embim36 - calls the Print Preview dialog box

embim37 - sends an image to the printer currently installed in the system

embim38 - increases the scale of an image

embim39 - decreases the scale of an image

embim40 - displays an image with the scale 1:1

embim41 - displays an image with the previous scale

embim42 - calls the Layers dialog box

embim43 - switches the visibility of the border around the image

embim44 - calls the Options dialog box

The Layouts drop-down list allows selecting layout from the list:


Demo for HTML

Demo applications >

Demo for HTML

 Return to chapter overview

This demo is designed to show how to use CADViewX in a web browser (Internet Explorer is supported only).

Click the right mouse button when the cursor is over the component window to call the popup menu.

Zoom In - increases the scale of an image

Zoom Out - decreases the scale of an image

Zoom All - fits an image to the component window

Previous scale - displays an image with the previous scale

Border On/Off - switches the visibility of the border around an image

Show layers - calls the Layers dialog box

Print - sends an image to the printer currently installed in the system

Print Preview - calls the Print Preview dialog box

Load file - loads the file available at the specified URL (http://www.soft-gold.ru/cadsofttools_demo.dxf, for example)


Demo for Visual Basic

Demo applications >

Demo for Visual Basic

 Return to chapter overview

The Visual Basic demo application has the following view:

Click the right mouse button when the cursor is over the component window to call the popup menu.

Menu in this demo consists of the following items:

·File:

·Open picture... - calls the standard Open dialog box

·Save as... - calls the Save As dialog box

·Close - closes the currently loaded image

·Print - sends an image to the printer currently installed in the system

·Print Black and White - prints the loaded file in black-and-white mode

·Print preview... - calls the Print Preview dialog box

·Exit - closes application

·Search:

·Find text - calls the Find text dialog box, creates a list of found text lines

·Show point - calls the Show point dialog, it allows to display the necessary point of the drawing with the predefined scaling factor

·Show Rect - calls the Show Rect dialog, it allows to display the necessary block entity available in the loaded file

·Edit:

·Copy as BMP - copies loaded image to the clipboard

·View:

·Zoom in - increases the scale of an image

·Zoom out - decreases the image of an image

·Previous scale - displays an image with the previous scale

·Fit picture to window - fits an image to the size of the component window

·Scale 1:1 - displays an image with the scale 1:1

·Show/Hide border - switches off/on the border around an image

·Rotate +90 deg - rotates an image counterclockwise on 90 degrees

·Rotate -90 deg - rotates an image clockwise on 90 degrees

·Reopen CAD file with same view - demonstrates how to open files with the same scale factor and view point.

·Show layers - calls the Layers dialog box

·Show full picture - demonstrates how to view the loaded file in a separate window

·Show scaled area - demonstrates how to display a scaled area of an image pointed by the cursor in a separate window

·Options:

·Show/Hide toolbar - switches the visibility of the CADViewX toolbar

·Show/Hide layouts toolbar - switches the visibility of the CADViewX Layouts toolbar

·Show options dialog - calls the Options dialog box

·Load configuration - loads previously saved configuration - changes made in the Print Preview and Options dialog boxes

·Save configuration - saves current configuration - changes made in the Print Preview and Options dialog boxes

·Help:

·Register CADViewX... - calls the CAViewX Lite Registration dialog box

·Floating licenses registration... - calls the Floating License dialog box

·About - calls the About CADViewX Lite dialog box

·Find text:

·Layers - this drop-down list allows selecting the necessary layer for the search

·Text to find - this field allows to enter the necessary text for the search

·Results - this field displays the results of the search

·Show point: enter the values of coordinates and the scale and click Show:

·Show Rect:

·Block - this drop-down list contains all BLOCK entities available in the loaded file

·Top-Left and Bottom-Right - the bounding rectangle of the selected BLOCK entity

·Show scaled picture:


Demo for Word

Demo applications >

Demo for Word

 Return to chapter overview

The demo for Microsoft® Office Word has the following view:

Click the right mouse button when the cursor is over the component widow to call the popup menu.

Click the Open... button to open a CAD file.

The Reopen with CAD file same view button demonstrates how to open files with the same scale factor and view point.

Click the Fit to window button to fit an image to the size of the component window.


VB Export to Word

Demo applications >

VB Export to Word

 Return to chapter overview

This demo application is designed to show how to embed the CADViewX control into a newly created Microsoft® Office Word document.

Click the right mouse button when the cursor is over the component window to call the popup menu.

Click the Open in Word button to call Microsoft® Office Word with the embedded CADViewX control.


Common modules

Common modules

This topic covers the list of included modules.


Dialogs

Common modules >

Dialogs

 Return to chapter overview

This topic describes dialog windows that are used in the component.


Export file size

Common modules > Dialogs >

Export file size

 Return to chapter overview

Specifies the size of the drawing (image) to be saved.

1:1 - sets sizes that are equal to the original size of the file.

Actual size - sets sizes according to the current scale of the loaded image.

Maximum recommended size - sets a maximum size that will not cause possible system's slowing down while converting (size values depend on system resources).

Custom size - user-defined size. It is recommended to check Maximum recommended size before setting it.

Note: option 1:1 is unavailable for CAD format files.


File information

Common modules > Dialogs >

File information

 Return to chapter overview

The following actions activate the File information dialog box:

·Right-click on the control, select the Properties item in the popup menu.

·Call the control's DoToolButtonClick method with the tbProperties parameter.


Floating License

Common modules > Dialogs >

Floating License

 Return to chapter overview

The following actions activate the Floating License dialog box:

·Right-click on the component, select the Floating License Registration... item in the popup menu.

·Click the Floating License Registration... button on the CADViewX Registration Dialog.

·Call the DoToolButtonClick method with the tbFloatingLicProps parameter.

Use Floating License Server: set this option on if you purchased floating license from Soft Gold Ltd.

·The Host field must contain server name or Internet IP-address of a computer where CS Floating License Server software have been installed.

·The Port field must contain a port number.

·The App field: CADVIEWX ACTIVEX CONTROL has to be selected in this drop-down list.

Important: When the Use Floating License Server option is switched on, CADViewX ignores registration data entered in the CADViewX Registration Dialog.

Floating license is intended for usage in TCP/IP net. It consists of CS Floating License Server software and applications that use CADViewX component or some other CADSoftTools products installed on computers in the TCP/IP net.

A multi-user floating license uses a server to issue licenses to remote applications. The CS Floating License Server can be run under Windows NT platform (NT 4, 2000, XP, 2003) Server or Workstation.

Floating license allows you to use CADViewX on several computers. Every time a client uses a floating license when (s)he connects to the CS Floating License Server (s)he gets ("leases") a license from that server and the number of available licenses on this server is decreased. When the work of the client is finished, the license is returned to the Floating License Server and it is available for other machines.

Note: Using floating license allows you to save your money. For instance: if you have several computers that would not use CADViewX applications at once you don’t need to purchase licenses for all your computers. It is just enough to purchase floating license for the estimated number of simultaneously run copies of CADViewX application. In this case, CS Floating License Server must be installed on a computer under Windows NT platform (NT 4, 2000, XP, 2003) Server or Workstation for storing and managing registration data. So, CADViewX application can be run everywhere where it can get access to TCP/IP net. And it is not necessary to reenter registration data every time when reloading.


Layers

Common modules > Dialogs >

Layers

 Return to chapter overview

The Layers dialog box allows managing the list of layers. You can activate it by performing one of the following actions:

·Click the [image] button on the toolbar.

·Right-click on the component, select the Show Layers item in the popup menu.

·Call the DoToolButtonClick method with the tbLayers parameter.

Click the icoaddnewlayer button or press (Alt+N) to add a new layer to the list.

Click the icodeletelayer button or press (Alt+D) to delete the selected layer.

Click the icounfreezeall button to unfreeze all layers.

Click the icofreezeall button to freeze all layers.

Click the icoswitchon button to switch all layers on.

Click the icoswitchoff button to switch all layers off.

The Search for layer edit box allows quick search for the necessary layer. Just click the left mouse button inside and enter the layer name.


Options

Common modules > Dialogs >

Options

 Return to chapter overview

The following actions call the Options dialog box:

·Click the [image] button on the toolbar.

·Right-click on the component, select the Options item in the popup menu.

·Call the DoToolButtonClick method with the tbOptions parameter.

The Common tab:

The Common tab contains the following sections:

·Common Options:

·Language - this option allows to select among 27 languages.

·Image Background Color - a click on the Change button calls the Color dialog box.

·Print:

·A click on the button calls the Print Setup dialog box.

·Print View Area - this option allows to print only the visible part of the image.

·Show Printer Setup Dialog - set this option on to call the Print Setup dialog box every time when:

·pressing the [image] button on the toolbar.

·right-clicking on the component, selecting the Print item in the popup menu.

·using the PrintImage method.

·using the DoToolButtonClick method with the tbPrint parameter.

The SHX fonts tab:

The Use SHX fonts checkbox allows to activate/deactivate SHX fonts support (SHX fonts must be installed in the system).

The Search path edit box allows to manage search paths for SHX fonts. Click the [image] button on the right from the Search path edit box to call the Directories dialog box:

The Directories dialog box allows managing lengthy lists of paths, directories, names of SHX units. Use this dialog box to add, replace, and remove strings from a semicolon-delimited list. As you scroll through the list, the text box beneath the list displays the selected path. You can:

·add AutoCAD paths registered in your config files or in the registry by clicking Add AutoCAD paths button;

·add a new path to the list by clicking the [image] button to open the Browse for Folder dialog box, selecting a path and clicking Add button;

·move the selected entry by clicking the [image] and [image] buttons;

·replace the selected entry by clicking the ellipsis button next to the text box and opening the Browse for Folder dialog box, selecting a path, and clicking Replace;

·delete the selected entry by clicking Delete.

You can remove any invalid (grayed out) paths from the path list, even if they aren't currently selected by clicking Delete Invalid Paths.

The SoftGold Direct tab:

The SoftGold Direct tab allows configuring the proxy server (connection between company network and the Internet). It's necessary for automatic or manual update-checks.

Proxy Server:

·Host: here you can enter the Internet IP address or the proxy server name.

·Port: here you can enter a port number.

Authentication:

·Username: here you can enter your proxy server user name. Many proxy servers don't need a user name and password.

·Password: here you can enter proxy server password (if needed). Only enter the password here if your PC is completely secure!

The PDF/EPS Import tab:

The PDF/EPS Import tab contains information about the loaded import library for PDF or EPS.

·Path to GhostScript library - determines the path to the GhostScript library.

·DPI - determines the resolution of your computer screen.


Print Preview

Common modules > Dialogs >

Print Preview

 Return to chapter overview

The Print Preview dialog includes the following tabs:

·Device settings

·Borders

·CAD Image

·Additional Settings

Note: The CAD Image tab is available when the CAD format file is loaded.

Cols and Rows - display the amount of paper of the horizontal and vertical placement. The number of pages is automatically calculated using the image size and the printer's printable area size. Also, the number of pages can be changed manually.

Auto - recalculates an optimal number of columns and rows on a sheet according to the current scale factor.

Click Print to print an image.

Click Close to hide the Print preview dialog.


Device Settings

Common modules > Dialogs > Print Preview >

Device Settings

 Return to chapter overview

Specifies settings for the selected printer.

Printer:

Displays the current printer, paper format and the port to which it is connected or its network location. A click on the button calls the standard Print Setup dialog window.

Paper Orientation:

·Landscape - orients and plots the drawing so that the long edge of the paper represents the top of the page.

·Portrait - orients and plots the drawing so that the short edge of the paper represents the top of the page.

Fit to paper - draws an image within a current number of sheets.

Scale factor - allows to define exact ratio between the line length on a paper sheet (in millimeters or inches) and its length in drawing units. This correlation is expressed by the following formula: X = Y, where X – is one millimeter (inch) of a sheet, Y -– drawing units. Thus, the scale factor 1:2 means that 1 millimeter of a sheet will contain two drawing points.

Predefined format - allows to select the standard paper size (DIN: A4, A3, A2, A1, A0) from the list or input a new one.

A click on the button calls the Formats dialog box.

Allow nonprinting area - set this option on to draw an image without fitting inside of the sheet's drawing area.

What does it mean? Every printer defines an area where it puts ink. This is the printable area. In most cases this area is less than the size of a sheet. The difference between the printable area and the size of a sheet has standard values for every specific printer. For instance, there is a drawing with the bounding rectangle scaled 1:1 within sheet's extents. If Allow nonprinting area is off, the drawing will be limited by bounds of the printable area. Thus, the image will be distorted - it will be less than its real size. If Allow nonprinting area is on, the drawing will fit in the bounds of a sheet and the image will be printed precisely.

Formats dialog box

The Formats dialog box contains the same list of standard formats as Predefined format does and it allows to create new items.

A click on the New or Edit button calls the Edit dialog box:

The Delete button deletes the selected format.

Note: the Edit and Delete buttons are enabled for user-defined formats only.


Borders

Common modules > Dialogs > Print Preview >

Borders

 Return to chapter overview

Specifies the shape, color and line type for drawing's borders.

borders

Drawing frame - specifies the shape, color and line type of the frame on a sheet for printed images.

·Enabled - switches on/off the frame on sheets.

·Line - defines the line type and color of the frame.

·Corner - defines the shape and color of the frame's corner.

Drawing cutting line - specifies the shape, color and line type of the bounding rectangle. The bounding rectangle allows separating the usable area on the sheet from the useless area. It is used when it is necessary to print a big drawing on small sheets for further gluing.

·Enabled - switches on/off the bounding rectangle.

·Line - defines the line type and color of the bounding rectangle.

·Corner - defines the shape and color of the bounding rectangle's corner.


CAD Image

Common modules > Dialogs > Print Preview >

CAD Image

 Return to chapter overview

Specifies parameters for CAD files printing.

Width of zero-width lines

Specifies the width of the lines, which have a width equal to zero, in chosen units (inches or millimeters) for printing. All primitives with null-width will be printed with the width equal to the entered value.

Print lines weight

This option allows all primitives with null (zero) width to be printed with the width equal to the one entered in the edit box Width of null-width lines and all primitives with zero-width to be printed with the width equal to 1 pixel.

Apply scale to line weights

This option allows to scale line weights according to the drawing's scale factor.

Print with colors

This option allows to print drawing in color or black-and-white mode.

Print dimensions

This option allows to print dimensions if they are present on the drawing.

Print texts

This option allows to print texts if they are present on the drawing.

A click on the button calls the Layers dialog box.

Set line weight by color

This option allows manual definition of the line weight according to its color.

In CAD color system each color is identified by an AutoCAD Color Index (ACI) number, an integer from 1 to 255. Standard color names are available only for colors 1 to 7. These colors are named in the following way: 1 Red, 2 Yellow, 3 Green, 4 Cyan, 5 Blue, 6 Magenta, 7 White/Black.

Click Load to load previously saved settings.

Click Save to save the current settings.


Additional Settings

Common modules > Dialogs > Print Preview >

Additional Settings

 Return to chapter overview

Specifies additional options for printing.

Drawing rect

This option specifies the placement of the drawing on a sheet.

Paper offset

This option defines the size of the printable area of a sheet. This option is necessary for the convenient combining of the sheets. It is the gluing maps principle that is used in it - sheets are laid from the left to the right and from the top to the bottom.

Use paper offset - set this option on to draw an image inside of the sheet's drawing area. What does it mean? Every printer defines an area where it puts ink. This is the printable area. In most cases this area is less than the size of a sheet. The difference between the printable area and the size of a sheet has standard values for every specific printer.

For instance, there is a drawing with bounding rectangle scaled 1:1 within sheet's extents. If Use paper offset is on, the drawing will be limited by bounds of the printable area. Thus, the image will be distorted - it will be less than its real size. If Use paper offset is off, the drawing will fit in the bounds of a sheet and the image will be printed precisely.

Overlapped mode

This option defines the area size for adjoining sheets which contain the same drawing parts. This area is used while gluing big drawings printed on small sheets.

Drawing rect position

This option specifies a predefined offset of the drawing on the printer's printable area.


Print Setup

Common modules > Dialogs >

Print Setup

 Return to chapter overview

The Print Setup dialog window allows to change settings for printing: select printer, paper size, orientation and more.

Note: the characteristics of the Print Setup dialog box view depend on your Windows™ version.


Registration Dialog

Common modules > Dialogs >

Registration Dialog

 Return to chapter overview

CADViewX Lite Registration Dialog allows to enter end user's registration data.

The following actions call the CADViewX Lite Registration Dialog dialog box:

·Right-click on the component, select the Register CADViewX... item in the popup menu.

·Use the DoToolButtonClick method with the tbRegister parameter.

Please enter the Name, E-Mail and Key into the corresponding fields, then click Register. If you are only evaluating CADViewX, click Trial.

Click the to call the Floating License dialog.


Popup menu

Common modules >

Popup menu

 Return to chapter overview

The popup menu of the CADViewX Lite component has the following look:

Zoom In (+) - zooms an image in.

Zoom Out (-) - zooms an image out.

Fit drawing to window - fits an image to the size of the component window.

Rotate Clockwise - rotates an image clockwise on 90 degrees.

Rotate Counterclockwise - rotates an image counterclockwise on 90 degrees.

3D Orbit - switches on/off the rotation mode.

Border On/Off - switches on/off the border around an image.

Open Picture - calls the Open dialog box.

Save As - calls the Save As dialog box.

Print - sends an image to the printer currently installed in the system.

Print Preview - calls the Print Preview dialog box.

Copy as BMP - copies an image to the clipboard as Windows™ Bitmap format.

Show Layers - calls the Layers dialog box.

Options - calls the Options dialog box.

Show toolbox - switches on/off the CADViewX component toolbar.

Show layouts toolbox - switches on/off the CADViewX Layouts toolbox.

Properties - calls the File information dialog box.

Register CADViewX... - calls the CADViewX Registration Dialog.

Floating License Registration... - calls the Floating License dialog box.

Check Updates... - checks whether updates are available or not.

About CADViewX... - calls the About CADViewX dialog box.


Toolbar

Common modules >

Toolbar

 Return to chapter overview

The CADViewX Lite toolbar has the following look:

- calls the standard Open dialog box.

- calls the standard Save As dialog box.

- copies an image to the clipboard as Windows™ Bitmap format.

- copies an image to the clipboard as Windows™ Metafile format.

- sends an image to printer currently installed in the system.

- calls the Print Preview dialog box.

- calls the Layers dialog box.

- zooms an image in.

- zooms an image out.

- fits an image to the size of the component window.

- switches on/off the border around an image.

- redraws an image in color. When you push down this button, the [image] button is pushing up.

- redraws an image in black-and-white. When you push down this button, the [image] button is pushing up.

- redraws an image on a custom background with black color as default for entities. When you push down this button, the [image] button is pushing up.

- redraws an image on a black background with white color as default for entities. When you push down this button, the [image] button is pushing up.

- switches on/off the rotation mode.

- rotates an image clockwise on 90 degrees.

- rotates an image counterclockwise on 90 degrees.

- calls the Options dialog box.

The Layouts toolbox allows to select the necessary layout from the drop-down list:


How to...

How to...

 Return to chapter overview

This section contains answers to the most frequently asked questions.


Distribute CADViewX with your applications

How to... >

Distribute CADViewX with your applications

 Return to chapter overview

This section describes how to use the CADViewX control on the computer where it was not installed before:

1.Copy CADViewLib.ocx and CADViewLib.tlb into the same folder (for example, c:\Program Files (x86)\CADSoftTools\CADViewX Lite 14\CADViewLib);

2.Register ActiveX Server from Windows command line: regsvr32.exe /s "c:\Program Files (x86)\CADSoftTools\CADViewX Lite 14\CADViewLib\CADViewLib.ocx";

3.Run your application.


Export image to different formats

How to... >

Export image to different formats

 Return to chapter overview

CADViewX allows to save opened picture as Windows™ Bitmap, Windows™ Metafile, JPEG, GIF image, TIFF or Adobe Acrobat Document PDF format:

1.Select one or more images in the Browse mode.

2.Click the Save [image] button to activate the standard Save as dialog box.

3.Choose the output file format.

4.Specify additional options or HPGL/2 export options.

5.Click OK.


Scale the image

How to... >

Scale the image

 Return to chapter overview

The desired image scaling can be implemented in the following way:

1.Set a value of CADViewX.ScaleFactor property.

2.Use CADViewX.Center() method to get a center point of the drawing area.

3.Call CADViewX.ScaleImage method with X and Y values received by CADViewX.Center() function and value of CADViewX.ScaleFactor property:

CADViewX.ScaleImage(True, CADViewX.ScaleFactor, CADViewX.Center().X, CADViewX.Center().Y)


Use SHX fonts

How to... >

Use SHX fonts

 Return to chapter overview

CADViewX component allows proper displaying of SHX fonts. For using SHX fonts it is necessary to set the CADViewX.UseSHXFonts property to True.

CADViewX searches for the SHX fonts in the paths defined by the CADViewX.SearchSHXPaths property. If the list of paths defined by this property is empty or if there is no need to use the SHX font, CADViewX uses the SHX font defined by the CADViewX.DefaultSHXFont and CADViewX.DefaultSHXPath properties.

If the CADViewX.SearchSHXPaths property is set to True then CADViewX searches the necessary SHX fonts by the following queue:

·SHX font paths defined in the system registry (AutoCAD® SHX font paths etc.);

·SHX font paths defined by the CADViewX.SearchSHXPaths property;

·SHX font paths defined by the CADViewX.DefaultSHXFont and CADViewX.DefaultSHXPath properties.


Credits

Credits

The following libraries which were made by exterior developers are used in this program:

·GraphicEx by Dipl. Ing. Mike Lischke, www.delphi-gems.com

·JEDI Visual Component Library, http://jvcl.sourceforge.net

·Library for animated GIF files support by Anders Melander, anders@melander.dk

·PASZLIB 1.0 by Jacques Nomssi Nzali, http://www.nomssi.de/paszlib/paszlib.html

·The Indy Project Indy.Sockets (VCL), http://www.indyproject.org/

·TurboPower Abbrevia, http://sourceforge.net/projects/tpabbrevia/


License Agreement

License Agreement

CADViewX License Agreement and Limited Warranty

This Soft Gold License Agreement ("LICENSE AGREEMENT") is a legal agreement between you (either individual or an entity) and Soft Gold Limited ("SOFT GOLD") for CADViewX Software ("SOFTWARE"). By installing, copying, accessing, or

otherwise using the SOFTWARE, you agree to be bound by the terms of this LICENSE AGREEMENT. If you do not agree to the terms of this LICENSE AGREEMENT, you must cease using the SOFTWARE immediately.

1.OWNERSHIP

All copyrights to SOFTWARE and everything that comes with it are exclusively owned by the author - SOFT GOLD, CADSoftTools trademark.

This SOFTWARE is protected by copyright laws and international copyright treaties. At all times SOFT GOLD retains full title to the SOFTWARE. Subject to your acceptance of and accordance with the terms and conditions stated in this LICENSE AGREEMENT, you shall be granted a SOFTWARE license. Any previous agreement with SOFT GOLD is superseded by this LICENSE AGREEMENT.

2.UNREGISTERED VERSION

You may distribute the unregistered version of SOFTWARE freely, provided that all files are included and remain unmodified and that no extra files have been added to the package. You may not ask any money for the distribution.You may use the unregistered version of SOFTWARE free of charge for testing purposes, but if you want to use it for other purposes than testing - you have to register it.

The unregistered version has some restrictions: Nagscreen, demo text when saving, copying and printing images.

3.GRANT OF LICENSE AND SCOPE OF USE

3.1. Grant of license.

Subject to the terms and conditions of this License, SOFT GOLD grants to you, if you are an individual, or, if you are an entity, one (1) designated person in your organization ("Named Developer") a personal, nonexclusive, and limited license to use the SOFTWARE solely to create your own application programs and other works ("Works"). You may install the SOFTWARE on a reasonable number of machines provided that the Named Developer is the only individual permitted to use the SOFTWARE. Subject to the other terms and conditions of this License, you may distribute your Works to others for production use. SOFT GOLD reserves the right to refuse granting a license without reasons explanation. All rights not specifically granted to you herein are retained by SOFT GOLD.

3.2 Multiple Licensed Copies.

You may purchase from SOFT GOLD or its authorized reseller additional licenses to permit multiple Named Developers to use the SOFTWARE (each, a "Named Developer License"). Such rights will be effective only when granted in writing by SOFT GOLD or its authorized reseller and are conditioned upon your payment of the applicable fees. If you purchase additional Named Developer Licenses for the SOFTWARE then you are granted for each Named Developer License the personal, nonexclusive, nontransferable and limited license to designate one individual in your organization as the Named Developer and permit such Named Developer to install and use the SOFTWARE solely as permitted under Section 3.1. In such case, the SOFTWARE may be used exclusively by the specifically designated Named Developer, subject to all the terms and conditions of this License. You agree that you will not designate more Named Developers than the number of Named Developer Licenses that SOFT GOLD or its authorized reseller has expressly granted to you and you will not allow the SOFTWARE to be used by any individuals other than the Named Developers designated by you from time to time. You agree to maintain accurate records of the Named Developer designated by you to use the SOFTWARE under each Named Developer License you hold.

3.3 Server licenses

3.3.1 On-Premises licenses

Subject to the terms and conditions of this License, SOFT GOLD grants to you, if you are an entity ("Licensee") a personal, nonexclusive and limited license, which allows to install and use the SOFTWARE on one (1) server or Web-server without end-users royalties. You may also make a reasonable number of copies of the SOFTWARE to backup devices such as hard disks, optical media, or tape and one (1) physical CD media backup copy of the SOFTWARE solely to replace the original copy provided to you if the original copy is damaged or destroyed. SOFT GOLD reserves the right to refuse granting a license without explanation of reasons. All rights not specifically granted to you herein are retained by SOFT GOLD.

The SOFTWARE may be used by all employees of Licensee at facilities governed by Licensee in connection with the server or Web-server. Licensee must use commercially reasonable efforts to restrict network or any other access to the SOFTWARE by anyone outside of Licensee's facilities who is not authorized to use the SOFTWARE.

3.3.2 Web-licenses

Terms and conditions of granting a web-license shall be discussed with SOFT GOLD.

3.3.3 Cloud licenses

Terms and conditions of granting a cloud license shall be discussed with SOFT GOLD.

3.4 Special licenses

If necessary Soft Gold Ltd is entitled to grant you a special license which conditions are preliminarily discussed by the parties and don’t contradict conditions of standard license.

4.DISCLAIMER OF WARRANTY

THIS SOFTWARE AND THE ACCOMPANYING FILES ARE SOLD "AS IS" AND WITHOUT WARRANTIES AS TO PERFORMANCE OF MERCHANTABILITY OR ANY OTHER WARRANTIES WHETHER EXPRESSED OR IMPLIED. BECAUSE OF THE VARIOUS HARDWARE AND SOFTWARE ENVIRONMENTS INTO WHICH SOFTWARE MAY BE PUT, NO WARRANTY OF FITNESS FOR A PARTICULAR PURPOSE IS OFFERED.YOU ASSUME THE WHOLE RISK CONCERNING QUALITY AND WORK OF SOFTWARE.IF THE SOFTWARE PROVES TO BE DEFECTIVE YOU ASSUME COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

Good data processing procedure dictates that any program be thoroughly tested with non-critical data before relying on it. The user must assume the entire risk of using the program.

You may not alter this software in any way, including changing or removing any windows.

5.AGREEMENT PERTAINING TO THE RELEASE OF SOURCE CODE

5.1 Recipient WILL NOT distribute the source. Particularly this includes such files as .dcu, .dfm, .pas and others which SOFTWARE has provided.

5.2 SOFT GOLD reserves the right to change any part of the source in future versions of the product. These changes may include removal of classes, properties and methods or creation of new classes, properties and methods.

6. ENGAGING IN ANY OF THE ACTIVITIES LISTED BELOW WILL TERMINATE THE SOFTWARE LICENSE. IN ADDITION TO SOFTWARE LICENSE TERMINATION, SOFTWARE MAY PURSUE CRIMINAL,CIVIL, OR ANY OTHER AVAILABLE REMEDIES.

6.1. Removal of proprietary notices, labels or marks from the SOFTWARE or SOFTWARE Documentation.

6.2. Utilize the SOFTWARE for the creation of products (whether it be freeware, shareware or a commercial product) which competes directly or indirectly with software published at www.cadsofttools.com, www.cadsofttools.ru, www.cadsofttools.de

6.3. Disclose the SOFTWARE to any person or party, involved in the creation of products which competes directly or indirectly with software published at www.cadsofttools.com.

6.4. Violation of the section 5 of this LICENSE AGREEMENT

7. LIMITATIONS OF DAMAGES

SOFT GOLD LTD SHALL NOT BE LIABLE FOR ANY INDIRECT, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES (INCLUDING DAMAGES FOR LOSS OF BUSINESS, LOSS OF PROFITS, OR THE LIKE), WHETHER BASED ON BREACH OF CONTRACT, TORT (INCLUDING NEGLIGENCE), PRODUCT LIABILITY OR OTHERWISE, EVEN IF SOFT GOLD LTD OR ITS REPRESENTATIVES HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES AND EVEN IF A REMEDY SET FORTH HEREIN IS FOUND TO HAVE FAILED OF ITS ESSENTIAL PURPOSE.

Thank you for using CADViewX!

Soft Gold Ltd., 2018

Address:

Russia, 300057 Tula, Malye Gonchary 14.

Tel: +1 (800) 469-9789

World Wide Web: http://www.cadsofttools.com

E-mail: info@cadsofttools.com


Buy now!

Buy now!

 Return to chapter overview

Please contact us at info@cadsofttools.com to order CADViewX.


CADViewLib Members

CADViewLib Members

Show / hide the hidden text

The following tables list the members exposed by the CADViewLib type.

collall Interfaces

 | Name | Description
Public interface | Arc | Provides an access to ARC entities.
Public interface | AttDef | Provides an access to ATTDEF entities.
Public interface | Attrib | Provides an access to ATTRIB entities.
Public interface | Block | Provides an access to BLOCK entities.
Public interface | CADLine | Provides an access to LINE entities.
Public interface | CADViewX | Provides an access to CADViewX control.
Public interface | CGMImage | Provides an access to a CGM drawing.
Public interface | Circle | Provides an access to CIRCLE entities.
Public interface | Converter | Provides an access to the sections of the drawing database.
Public interface | DWGImage | Provides an access to a DWG drawing.
Public interface | DXFImage | Provides an access to a DXF drawing.
Public interface | Dimension | Provides an access to DIMENSION entities.
Public interface | Ellipse | Provides an access to ELLIPSE entities.
Public interface | Entity | Provides an access to an entity in the drawing database.
Public interface | Group | Provides an access to a group of objects.
Public interface | HPGLImage | Provides an access to an HPGL drawing.
Public interface | IArc | Provides an access to ARC entities.
Public interface | IAttDef | Provides an access to ATTDEF entities.
Public interface | IAttrib | Provides an access to ATTRIB entities.
Public interface | IBlock | Provides an access to BLOCK entities.
Public interface | ICADLine | Provides an access to LINE entities.
Public interface | ICADViewX | Provides an access to CADViewX control.
Public interface | ICGMImage | Provides an access to a CGM drawing.
Public interface | ICircle | Provides an access to CIRCLE entities.
Public interface | IConverter | Provides an access to the sections of the drawing database.
Public interface | IDWGImage | Provides an access to a DWG drawing.
Public interface | IDXFImage | Provides an access to a DXF drawing.
Public interface | IDimension | Provides an access to DIMENSION entities.
Public interface | IEllipse | Provides an access to ELLIPSE entities.
Public interface | IEntity | Provides an access to an entity in the drawing database.
Public interface | IGroup | Provides an access to a group of objects.
Public interface | IHPGLImage | Provides an access to an HPGL drawing.
Public interface | IImageEnt | Provides an access to IMAGE entities.
Public interface | IInsert | Provides an access to INSERT entities.
Public interface | ILayer | Provides an access to LAYER objects.
Public interface | ILayout | Provides an access to LAYOUT objects.
Public interface | IPoint2D | Provides an access to 2D points.
Public interface | IPoint3D | Provides an access to 3D points.
Public interface | IPolyline | Provides an access to POLYLINE and LWPOLYLINE entities.
Public interface | IRect2D | Provides an access to a bounding rectangle.
Public interface | IRect3D | Provides an access to a bounding parallelepiped (box).
Public interface | ISVGImage | Provides an access to an SVG drawing.
Public interface | ISolid | Provides an access to SOLID entities.
Public interface | ISpline | Provides an access to SPLINE entities.
Public interface | IText | Provides an access to TEXT entities.
Public interface | IToolBox | Provides an access to the CADViewX toolbar.
Public interface | IVertex | Provides an access to VERTEX entities.
Public interface | ImageEnt | Provides an access to IMAGE entities.
Public interface | Insert | Provides an access to INSERT entities.
Public interface | Layer | Provides an access to LAYER objects.
Public interface | Layout | Provides an access to LAYOUT objects.
Public interface | Point2D | Provides an access to 2D points.
Public interface | Point3D | Provides an access to 3D points.
Public interface | Polyline | Provides an access to POLYLINE and LWPOLYLINE entities.
Public interface | Rect2D | Provides an access to a bounding rectangle.
Public interface | Rect3D | Provides an access to a bounding parallelepiped (box).
Public interface | SVGImage | Provides an access to an SVG drawing.
Public interface | Solid | Provides an access to SOLID entities.
Public interface | Spline | Provides an access to SPLINE entities.
Public interface | Text | Provides an access to TEXT entities.
Public interface | ToolBox | Provides an access to the CADViewX toolbar.
Public interface | Vertex | Provides an access to VERTEX entities.

Top

collall Delegates

 | Name | Description
Public delegate | ICADViewXEvents_OnActivateEventHandler | Delegate for the OnActivate event.
Public delegate | ICADViewXEvents_OnAfterLoadEventHandler | Delegate for the OnAfterLoad event.
Public delegate | ICADViewXEvents_OnBeforeLoadEventHandler | Delegate for the OnBeforeLoad event.
Public delegate | ICADViewXEvents_OnClickEventHandler | Delegate for the OnClick event.
Public delegate | ICADViewXEvents_OnCreateEventHandler | Delegate for the OnCreate event.
Public delegate | ICADViewXEvents_OnDblClickEventHandler | Delegate for the OnDblClick event.
Public delegate | ICADViewXEvents_OnDeactivateEventHandler | Delegate for the OnDeactivate event.
Public delegate | ICADViewXEvents_OnDestroyEventHandler | Delegate for the OnDestroy event.
Public delegate | ICADViewXEvents_OnIterateEventHandler | Delegate for the OnIterate event.
Public delegate | ICADViewXEvents_OnKeyDownEventHandler | Delegate for the OnKeyDown event.
Public delegate | ICADViewXEvents_OnKeyPressEventHandler | Delegate for the OnKeyPress event.
Public delegate | ICADViewXEvents_OnLayoutChangeEventHandler | Delegate for the OnLayoutChange event.
Public delegate | ICADViewXEvents_OnMouseDownEventHandler | Delegate for the OnMouseDown event.
Public delegate | ICADViewXEvents_OnMouseMoveEventHandler | Delegate for the OnMouseMove event.
Public delegate | ICADViewXEvents_OnMouseUpEventHandler | Delegate for the OnMouseUp event.
Public delegate | ICADViewXEvents_OnMouseWheelDownEventHandler | Delegate for the OnMouseWheelDown event.
Public delegate | ICADViewXEvents_OnMouseWheelUpEventHandler | Delegate for the OnMouseWheelUp event.
Public delegate | ICADViewXEvents_OnPaintEventHandler | Delegate for the OnPaint event.
Public delegate | ICADViewXEvents_OnProcessEventHandler | Delegate for the OnProcess event.
Public delegate | ICADViewXEvents_OnProgressEventHandler | Delegate for the OnProgress event.
Public delegate | ICADViewXEvents_OnScalingEventHandler | Delegate for the OnScaling event.
Public delegate | ICADViewXEvents_OnToolButtonClickEventHandler | Delegate for the OnToolButtonClick event.

Top

collall Enumerations

 | Name | Description
Public enumeration | TAcadVersion | Indicates a version of an AutoCAD® drawing file.
Public enumeration | TDistanceUnits | Indicates the drawing units.
Public enumeration | TEntityID | Indicates the entity type ID.
Public enumeration | TxActiveFormBorderStyle | Indicates the border style for the control.
Public enumeration | TxAlign | Indicates the alignment of a control.
Public enumeration | TxAxes | Indicates a 3D axis.
Public enumeration | TxCADClassID | Indicates the CAD drawing type ID.
Public enumeration | TxCADSpace | Indicates the type of CAD space.
Public enumeration | TxColorDepth | Indicates the color depth (in bits per pixel).
Public enumeration | TxConvSection | Indicates a section in the drawing database.
Public enumeration | TxDXFDrawMode | Indicates the appearance of colors in a drawing.
Public enumeration | TxDXFViewDirection | Indicates orthographic and isometric views.
Public enumeration | TxMouseButton | Indicates the mouse button that was clicked.
Public enumeration | TxPaperOrientation | Indicates the paper orientation.
Public enumeration | TxPrintScale | Indicates how a drawing will be scaled on print.
Public enumeration | TxProgressStage | Indicates the current stage of the file loading progress.
Public enumeration | TxShiftState | Indicates what modifier keys and mouse buttons were held down in combination with a normal key.
Public enumeration | TxToolButton | Indicates the toolbar button or context menu item.
Public enumeration | TxsgBorderType | Indicates how a value of the drawing border size is calculated.

Top

collall See Also

Reference

CADViewLib Namespace


Block Attached Properties

Block Attached Properties

Show / hide the hidden text

collall See Also

Reference

Block Interface


Block Events

Block Events

Show / hide the hidden text

collall See Also

Reference

Block Interface


Block Fields

Block Fields

Show / hide the hidden text

collall See Also

Reference

Block Interface


CADLine Attached Properties

CADLine Attached Properties

Show / hide the hidden text

collall See Also

Reference

CADLine Interface


CADLine Events

CADLine Events

Show / hide the hidden text

collall See Also

Reference

CADLine Interface


CADLine Fields

CADLine Fields

Show / hide the hidden text

collall See Also

Reference

CADLine Interface


CADViewX Attached Properties

CADViewX Attached Properties

Show / hide the hidden text

collall See Also

Reference

CADViewX Interface


CADViewX Events

CADViewX Events

Show / hide the hidden text

collall See Also

Reference

CADViewX Interface


CADViewX Fields

CADViewX Fields

Show / hide the hidden text

collall See Also

Reference

CADViewX Interface


CGMImage Attached Properties

CGMImage Attached Properties

Show / hide the hidden text

collall See Also

Reference

CGMImage Interface


CGMImage Events

CGMImage Events

Show / hide the hidden text

collall See Also

Reference

CGMImage Interface


CGMImage Fields

CGMImage Fields

Show / hide the hidden text

collall See Also

Reference

CGMImage Interface


Circle Attached Properties

Circle Attached Properties

Show / hide the hidden text

collall See Also

Reference

Circle Interface


Circle Events

Circle Events

Show / hide the hidden text

collall See Also

Reference

Circle Interface


Circle Fields

Circle Fields

Show / hide the hidden text

collall See Also

Reference

Circle Interface


Converter Attached Properties

Converter Attached Properties

Show / hide the hidden text

collall See Also

Reference

Converter Interface


Converter Events

Converter Events

Show / hide the hidden text

collall See Also

Reference

Converter Interface


Converter Fields

Converter Fields

Show / hide the hidden text

collall See Also

Reference

Converter Interface


Dimension Attached Properties

Dimension Attached Properties

Show / hide the hidden text

collall See Also

Reference

Dimension Interface


Dimension Events

Dimension Events

Show / hide the hidden text

collall See Also

Reference

Dimension Interface


Dimension Fields

Dimension Fields

Show / hide the hidden text

collall See Also

Reference

Dimension Interface


DWGImage Attached Properties

DWGImage Attached Properties

Show / hide the hidden text

collall See Also

Reference

DWGImage Interface


DWGImage Events

DWGImage Events

Show / hide the hidden text

collall See Also

Reference

DWGImage Interface


DWGImage Fields

DWGImage Fields

Show / hide the hidden text

collall See Also

Reference

DWGImage Interface


DXFImage Attached Properties

DXFImage Attached Properties

Show / hide the hidden text

collall See Also

Reference

DXFImage Interface


DXFImage Events

DXFImage Events

Show / hide the hidden text

collall See Also

Reference

DXFImage Interface


DXFImage Fields

DXFImage Fields

Show / hide the hidden text

collall See Also

Reference

DXFImage Interface


Ellipse Attached Properties

Ellipse Attached Properties

Show / hide the hidden text

collall See Also

Reference

Ellipse Interface


Ellipse Events

Ellipse Events

Show / hide the hidden text

collall See Also

Reference

Ellipse Interface


Ellipse Fields

Ellipse Fields

Show / hide the hidden text

collall See Also

Reference

Ellipse Interface


Entity Attached Properties

Entity Attached Properties

Show / hide the hidden text

collall See Also

Reference

Entity Interface


Entity Events

Entity Events

Show / hide the hidden text

collall See Also

Reference

Entity Interface


Entity Fields

Entity Fields

Show / hide the hidden text

collall See Also

Reference

Entity Interface


Group Attached Properties

Group Attached Properties

Show / hide the hidden text

collall See Also

Reference

Group Interface


Group Events

Group Events

Show / hide the hidden text

collall See Also

Reference

Group Interface


Group Fields

Group Fields

Show / hide the hidden text

collall See Also

Reference

Group Interface


HPGLImage Attached Properties

HPGLImage Attached Properties

Show / hide the hidden text

collall See Also

Reference

HPGLImage Interface


HPGLImage Events

HPGLImage Events

Show / hide the hidden text

collall See Also

Reference

HPGLImage Interface


HPGLImage Fields

HPGLImage Fields

Show / hide the hidden text

collall See Also

Reference

HPGLImage Interface


IArc Attached Properties

IArc Attached Properties

Show / hide the hidden text

collall See Also

Reference

IArc Interface


IArc Events

IArc Events

Show / hide the hidden text

collall See Also

Reference

IArc Interface


IArc Fields

IArc Fields

Show / hide the hidden text

collall See Also

Reference

IArc Interface


IBlock Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IBlock Attached Properties

See Also

Reference

IBlock Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IBlock Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IBlock Events

See Also

Reference

IBlock Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IBlock Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IBlock Fields

See Also

Reference

IBlock Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IAttDef Attached Properties

IAttDef Attached Properties

Show / hide the hidden text

collall See Also

Reference

IAttDef Interface


IAttDef Events

IAttDef Events

Show / hide the hidden text

collall See Also

Reference

IAttDef Interface


IAttDef Fields

IAttDef Fields

Show / hide the hidden text

collall See Also

Reference

IAttDef Interface


IToolBox Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IToolBox Attached Properties

See Also

Reference

IToolBox Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IToolBox Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IToolBox Events

See Also

Reference

IToolBox Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IToolBox Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IToolBox Fields

See Also

Reference

IToolBox Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Arc Attached Properties

Arc Attached Properties

Show / hide the hidden text

collall See Also

Reference

Arc Interface


Arc Events

Arc Events

Show / hide the hidden text

collall See Also

Reference

Arc Interface


Arc Fields

Arc Fields

Show / hide the hidden text

collall See Also

Reference

Arc Interface


ICADViewX Attached Properties

ICADViewX Attached Properties

Show / hide the hidden text

collall See Also

Reference

ICADViewX Interface


ICADViewX Events

ICADViewX Events

Show / hide the hidden text

collall See Also

Reference

ICADViewX Interface


ICADViewX Fields

ICADViewX Fields

Show / hide the hidden text

collall See Also

Reference

ICADViewX Interface


IDWGImage Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IDWGImage Attached Properties

See Also

Reference

IDWGImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IDWGImage Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IDWGImage Events

See Also

Reference

IDWGImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IDWGImage Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IDWGImage Fields

See Also

Reference

IDWGImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


AttDef Attached Properties

AttDef Attached Properties

Show / hide the hidden text

collall See Also

Reference

AttDef Interface


AttDef Events

AttDef Events

Show / hide the hidden text

collall See Also

Reference

AttDef Interface


AttDef Fields

AttDef Fields

Show / hide the hidden text

collall See Also

Reference

AttDef Interface


IRect2D Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IRect2D Attached Properties

See Also

Reference

IRect2D Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IRect2D Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IRect2D Events

See Also

Reference

IRect2D Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IRect2D Methods

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IRect2D Methods

See Also

Reference

IRect2D Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IRect2D Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IRect2D Fields

See Also

Reference

IRect2D Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IConverter Attached Properties

IConverter Attached Properties

Show / hide the hidden text

collall See Also

Reference

IConverter Interface


IConverter Events

IConverter Events

Show / hide the hidden text

collall See Also

Reference

IConverter Interface


IConverter Fields

IConverter Fields

Show / hide the hidden text

collall See Also

Reference

IConverter Interface


IText Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IText Attached Properties

See Also

Reference

IText Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IText Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IText Events

See Also

Reference

IText Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IText Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IText Fields

See Also

Reference

IText Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IDimension Attached Properties

IDimension Attached Properties

Show / hide the hidden text

collall See Also

Reference

IDimension Interface


IDimension Events

IDimension Events

Show / hide the hidden text

collall See Also

Reference

IDimension Interface


IDimension Fields

IDimension Fields

Show / hide the hidden text

collall See Also

Reference

IDimension Interface


Attrib Attached Properties

Attrib Attached Properties

Show / hide the hidden text

collall See Also

Reference

Attrib Interface


Attrib Events

Attrib Events

Show / hide the hidden text

collall See Also

Reference

Attrib Interface


Attrib Fields

Attrib Fields

Show / hide the hidden text

collall See Also

Reference

Attrib Interface


IEllipse Attached Properties

IEllipse Attached Properties

Show / hide the hidden text

collall See Also

Reference

IEllipse Interface


IEllipse Events

IEllipse Events

Show / hide the hidden text

collall See Also

Reference

IEllipse Interface


IEllipse Fields

IEllipse Fields

Show / hide the hidden text

collall See Also

Reference

IEllipse Interface


IPoint2D Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IPoint2D Attached Properties

See Also

Reference

IPoint2D Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IPoint2D Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IPoint2D Events

See Also

Reference

IPoint2D Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IPoint2D Methods

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IPoint2D Methods

See Also

Reference

IPoint2D Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IPoint2D Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IPoint2D Fields

See Also

Reference

IPoint2D Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IDXFImage Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IDXFImage Attached Properties

See Also

Reference

IDXFImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IDXFImage Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IDXFImage Events

See Also

Reference

IDXFImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IDXFImage Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IDXFImage Fields

See Also

Reference

IDXFImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IEntity Attached Properties

IEntity Attached Properties

Show / hide the hidden text

collall See Also

Reference

IEntity Interface


IEntity Events

IEntity Events

Show / hide the hidden text

collall See Also

Reference

IEntity Interface


IEntity Fields

IEntity Fields

Show / hide the hidden text

collall See Also

Reference

IEntity Interface


AxCADViewLib Members

AxCADViewLib Members

Show / hide the hidden text

The following tables list the members exposed by the AxCADViewLib type.

collall Classes

 | Name | Description
Public class | AxCADViewX | A wrapper class around CADViewX control placed onto a form

Top

collall See Also

Reference

AxCADViewLib Namespace


IEntity Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IEntity Attached Properties

See Also

Reference

IEntity Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IEntity Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IEntity Events

See Also

Reference

IEntity Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IEntity Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IEntity Fields

See Also

Reference

IEntity Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ILayer Attached Properties

ILayer Attached Properties

Show / hide the hidden text

collall See Also

Reference

ILayer Interface


ILayer Events

ILayer Events

Show / hide the hidden text

collall See Also

Reference

ILayer Interface


ILayer Fields

ILayer Fields

Show / hide the hidden text

collall See Also

Reference

ILayer Interface


IImageEnt Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IImageEnt Attached Properties

See Also

Reference

IImageEnt Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IImageEnt Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IImageEnt Events

See Also

Reference

IImageEnt Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IImageEnt Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IImageEnt Fields

See Also

Reference

IImageEnt Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ILayout Attached Properties

ILayout Attached Properties

Show / hide the hidden text

collall See Also

Reference

ILayout Interface


ILayout Events

ILayout Events

Show / hide the hidden text

collall See Also

Reference

ILayout Interface


ILayout Fields

ILayout Fields

Show / hide the hidden text

collall See Also

Reference

ILayout Interface


Rect2D Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Rect2D Attached Properties

See Also

Reference

Rect2D Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Rect2D Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Rect2D Events

See Also

Reference

Rect2D Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Rect2D Methods

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Rect2D Methods

See Also

Reference

Rect2D Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Rect2D Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Rect2D Fields

See Also

Reference

Rect2D Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Entity Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Entity Attached Properties

See Also

Reference

Entity Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Entity Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Entity Events

See Also

Reference

Entity Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Entity Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Entity Fields

See Also

Reference

Entity Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Ellipse Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Ellipse Attached Properties

See Also

Reference

Ellipse Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Ellipse Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Ellipse Events

See Also

Reference

Ellipse Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Ellipse Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Ellipse Fields

See Also

Reference

Ellipse Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ISolid Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

ISolid Attached Properties

See Also

Reference

ISolid Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ISolid Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

ISolid Events

See Also

Reference

ISolid Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ISolid Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

ISolid Fields

See Also

Reference

ISolid Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


AxCADViewX Attached Properties

AxCADViewX Attached Properties

Show / hide the hidden text

collall See Also

Reference

AxCADViewX Class
AxCADViewLib Namespace


AxCADViewX Fields

AxCADViewX Fields

Show / hide the hidden text

collall See Also

Reference

AxCADViewX Class
AxCADViewLib Namespace


ISVGImage Attached Properties

ISVGImage Attached Properties

Show / hide the hidden text

collall See Also

Reference

ISVGImage Interface


ISVGImage Events

ISVGImage Events

Show / hide the hidden text

collall See Also

Reference

ISVGImage Interface


ISVGImage Fields

ISVGImage Fields

Show / hide the hidden text

collall See Also

Reference

ISVGImage Interface


CGMImage Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

CGMImage Attached Properties

See Also

Reference

CGMImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


CGMImage Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

CGMImage Events

See Also

Reference

CGMImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


CGMImage Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

CGMImage Fields

See Also

Reference

CGMImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IPolyline Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IPolyline Attached Properties

See Also

Reference

IPolyline Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IPolyline Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IPolyline Events

See Also

Reference

IPolyline Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IPolyline Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IPolyline Fields

See Also

Reference

IPolyline Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ILayout Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

ILayout Attached Properties

See Also

Reference

ILayout Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ILayout Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

ILayout Events

See Also

Reference

ILayout Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ILayout Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

ILayout Fields

See Also

Reference

ILayout Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Text Attached Properties

Text Attached Properties

Show / hide the hidden text

collall See Also

Reference

Text Interface


Text Events

Text Events

Show / hide the hidden text

collall See Also

Reference

Text Interface


Text Fields

Text Fields

Show / hide the hidden text

collall See Also

Reference

Text Interface


ToolBox Attached Properties

ToolBox Attached Properties

Show / hide the hidden text

collall See Also

Reference

ToolBox Interface


ToolBox Events

ToolBox Events

Show / hide the hidden text

collall See Also

Reference

ToolBox Interface


ToolBox Fields

ToolBox Fields

Show / hide the hidden text

collall See Also

Reference

ToolBox Interface


Dimension Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Dimension Attached Properties

See Also

Reference

Dimension Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Dimension Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Dimension Events

See Also

Reference

Dimension Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Dimension Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Dimension Fields

See Also

Reference

Dimension Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IConverter Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IConverter Attached Properties

See Also

Reference

IConverter Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IConverter Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IConverter Events

See Also

Reference

IConverter Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IConverter Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IConverter Fields

See Also

Reference

IConverter Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


AxCADViewX.ShowPoint Method

AxCADViewX.ShowPoint Method

Show / hide the hidden text

Displays the image centered by a specified point with a certain scale factor.

collall Overload List

Name | Description
ShowPoint(Point3D, double) | Displays the image centered by a specified point with a certain scale factor.
ShowPoint(Point3D, double, Rect3D) | Displays the image centered by a specified point with a certain scale factor.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.ShowPoint (Point3D, Double) Method

AxCADViewX.ShowPoint (Point3D, Double) Method

Show / hide the hidden text

Displays the image centered by a specified point with a certain scale factor.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Sub ShowPoint( _
ByVal aPoint As Point3D, _
ByVal aScale As Double _
)

C#

public virtual void ShowPoint(
Point3DaPoint,
doubleaScale
)

C++

public:
virtual void ShowPoint(
Point3D^ aPoint,
doubleaScale
)

JScript

public function ShowPoint(
aPoint : Point3D,
aScale : double
);

Parameters

aPoint

The point by which the image is centered.

aScale

The scale factor.

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


AxCADViewX.ShowPoint (Point3D, Double, Rect3D) Method

AxCADViewX.ShowPoint (Point3D, Double, Rect3D) Method

Show / hide the hidden text

Displays the image centered by a specified point with a certain scale factor.

Namespace: AxCADViewLib
Assembly: Interop.CADViewLib (in Interop.CADViewLib.dll)

collall Syntax

Visual Basic

Public Overridable Sub ShowPoint( _
ByVal aPoint As Point3D, _
ByVal aScale As Double, _
ByVal aExtents As Rect3D _
)

C#

public virtual void ShowPoint(
Point3DaPoint,
doubleaScale,
Rect3DaExtents
)

C++

public:
virtual void ShowPoint(
Point3D^ aPoint,
doubleaScale,
Rect3D^ aExtents
)

JScript

public function ShowPoint(
aPoint : Point3D,
aScale : double,
aExtents : Rect3D
);

Parameters

aPoint

The point by which the image is centered.

aScale

The scale factor.

aExtents

collall See Also

Reference

AxCADViewX Class
AxCADViewX AxCADViewX Members
AxCADViewLib Namespace


ICGMImage Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

ICGMImage Attached Properties

See Also

Reference

ICGMImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ICGMImage Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

ICGMImage Events

See Also

Reference

ICGMImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ICGMImage Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

ICGMImage Fields

See Also

Reference

ICGMImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IBlock Attached Properties

IBlock Attached Properties

Show / hide the hidden text

collall See Also

Reference

IBlock Interface


IBlock Events

IBlock Events

Show / hide the hidden text

collall See Also

Reference

IBlock Interface


IBlock Fields

IBlock Fields

Show / hide the hidden text

collall See Also

Reference

IBlock Interface


IAttDef Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IAttDef Attached Properties

See Also

Reference

IAttDef Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IAttDef Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IAttDef Events

See Also

Reference

IAttDef Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IAttDef Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IAttDef Fields

See Also

Reference

IAttDef Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ICGMImage Attached Properties

ICGMImage Attached Properties

Show / hide the hidden text

collall See Also

Reference

ICGMImage Interface


ICGMImage Events

ICGMImage Events

Show / hide the hidden text

collall See Also

Reference

ICGMImage Interface


ICGMImage Fields

ICGMImage Fields

Show / hide the hidden text

collall See Also

Reference

ICGMImage Interface


ISpline Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

ISpline Attached Properties

See Also

Reference

ISpline Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ISpline Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

ISpline Events

See Also

Reference

ISpline Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ISpline Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

ISpline Fields

See Also

Reference

ISpline Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ICircle Attached Properties

ICircle Attached Properties

Show / hide the hidden text

collall See Also

Reference

ICircle Interface


ICircle Events

ICircle Events

Show / hide the hidden text

collall See Also

Reference

ICircle Interface


ICircle Fields

ICircle Fields

Show / hide the hidden text

collall See Also

Reference

ICircle Interface


Converter Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Converter Attached Properties

See Also

Reference

Converter Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Converter Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Converter Events

See Also

Reference

Converter Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Converter Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Converter Fields

See Also

Reference

Converter Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IDimension Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IDimension Attached Properties

See Also

Reference

IDimension Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IDimension Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IDimension Events

See Also

Reference

IDimension Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IDimension Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IDimension Fields

See Also

Reference

IDimension Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IDXFImage Attached Properties

IDXFImage Attached Properties

Show / hide the hidden text

collall See Also

Reference

IDXFImage Interface


IDXFImage Events

IDXFImage Events

Show / hide the hidden text

collall See Also

Reference

IDXFImage Interface


IDXFImage Fields

IDXFImage Fields

Show / hide the hidden text

collall See Also

Reference

IDXFImage Interface


IEllipse Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IEllipse Attached Properties

See Also

Reference

IEllipse Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IEllipse Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IEllipse Events

See Also

Reference

IEllipse Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IEllipse Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IEllipse Fields

See Also

Reference

IEllipse Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ICADLine Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

ICADLine Attached Properties

See Also

Reference

ICADLine Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ICADLine Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

ICADLine Events

See Also

Reference

ICADLine Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ICADLine Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

ICADLine Fields

See Also

Reference

ICADLine Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Layer Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Layer Attached Properties

See Also

Reference

Layer Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Layer Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Layer Events

See Also

Reference

Layer Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Layer Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Layer Fields

See Also

Reference

Layer Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IArc Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IArc Attached Properties

See Also

Reference

IArc Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IArc Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IArc Events

See Also

Reference

IArc Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IArc Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IArc Fields

See Also

Reference

IArc Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Group Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Group Attached Properties

See Also

Reference

Group Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Group Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Group Events

See Also

Reference

Group Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Group Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Group Fields

See Also

Reference

Group Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Arc Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Arc Attached Properties

See Also

Reference

Arc Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Arc Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Arc Events

See Also

Reference

Arc Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Arc Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Arc Fields

See Also

Reference

Arc Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IInsert Attached Properties

IInsert Attached Properties

Show / hide the hidden text

collall See Also

Reference

IInsert Interface


IInsert Events

IInsert Events

Show / hide the hidden text

collall See Also

Reference

IInsert Interface


IInsert Fields

IInsert Fields

Show / hide the hidden text

collall See Also

Reference

IInsert Interface


IPolyline Attached Properties

IPolyline Attached Properties

Show / hide the hidden text

collall See Also

Reference

IPolyline Interface


IPolyline Events

IPolyline Events

Show / hide the hidden text

collall See Also

Reference

IPolyline Interface


IPolyline Fields

IPolyline Fields

Show / hide the hidden text

collall See Also

Reference

IPolyline Interface


IHPGLImage Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IHPGLImage Attached Properties

See Also

Reference

IHPGLImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IHPGLImage Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IHPGLImage Events

See Also

Reference

IHPGLImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IHPGLImage Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IHPGLImage Fields

See Also

Reference

IHPGLImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


CADLine Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

CADLine Attached Properties

See Also

Reference

CADLine Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


CADLine Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

CADLine Events

See Also

Reference

CADLine Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


CADLine Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

CADLine Fields

See Also

Reference

CADLine Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


CADViewX Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

CADViewX Attached Properties

See Also

Reference

CADViewX Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


CADViewX Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

CADViewX Events

See Also

Reference

CADViewX Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


CADViewX Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

CADViewX Fields

See Also

Reference

CADViewX Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Point2D Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Point2D Attached Properties

See Also

Reference

Point2D Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Point2D Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Point2D Events

See Also

Reference

Point2D Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Point2D Methods

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Point2D Methods

See Also

Reference

Point2D Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Point2D Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Point2D Fields

See Also

Reference

Point2D Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ICircle Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

ICircle Attached Properties

See Also

Reference

ICircle Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ICircle Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

ICircle Events

See Also

Reference

ICircle Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ICircle Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

ICircle Fields

See Also

Reference

ICircle Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IPoint3D Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IPoint3D Attached Properties

See Also

Reference

IPoint3D Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IPoint3D Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IPoint3D Events

See Also

Reference

IPoint3D Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IPoint3D Methods

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IPoint3D Methods

See Also

Reference

IPoint3D Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IPoint3D Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IPoint3D Fields

See Also

Reference

IPoint3D Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Vertex Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Vertex Attached Properties

See Also

Reference

Vertex Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Vertex Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Vertex Events

See Also

Reference

Vertex Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Vertex Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Vertex Fields

See Also

Reference

Vertex Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


AxCADViewLib Members

collall Classes

collall Classes

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

AxCADViewLib Members

See Also

The following tables list the members exposed by the AxCADViewLib type.

 | Name | Description
Public class | AxCADViewX |

Top

collall See Also

Reference

AxCADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


AxCADViewX Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

AxCADViewX Attached Properties

See Also

Reference

AxCADViewX Class

AxCADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


AxCADViewX Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

AxCADViewX Fields

See Also

Reference

AxCADViewX Class

AxCADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


AttDef Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

AttDef Attached Properties

See Also

Reference

AttDef Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


AttDef Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

AttDef Events

See Also

Reference

AttDef Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


AttDef Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

AttDef Fields

See Also

Reference

AttDef Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Layer Attached Properties

Layer Attached Properties

Show / hide the hidden text

collall See Also

Reference

Layer Interface


Layer Events

Layer Events

Show / hide the hidden text

collall See Also

Reference

Layer Interface


Layer Fields

Layer Fields

Show / hide the hidden text

collall See Also

Reference

Layer Interface


Layout Attached Properties

Layout Attached Properties

Show / hide the hidden text

collall See Also

Reference

Layout Interface


Layout Events

Layout Events

Show / hide the hidden text

collall See Also

Reference

Layout Interface


Layout Fields

Layout Fields

Show / hide the hidden text

collall See Also

Reference

Layout Interface


Spline Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Spline Attached Properties

See Also

Reference

Spline Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Spline Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Spline Events

See Also

Reference

Spline Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Spline Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Spline Fields

See Also

Reference

Spline Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IRect3D Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IRect3D Attached Properties

See Also

Reference

IRect3D Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IRect3D Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IRect3D Events

See Also

Reference

IRect3D Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IRect3D Methods

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IRect3D Methods

See Also

Reference

IRect3D Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IRect3D Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IRect3D Fields

See Also

Reference

IRect3D Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Circle Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Circle Attached Properties

See Also

Reference

Circle Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Circle Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Circle Events

See Also

Reference

Circle Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Circle Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Circle Fields

See Also

Reference

Circle Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Block Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Block Attached Properties

See Also

Reference

Block Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Block Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Block Events

See Also

Reference

Block Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Block Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Block Fields

See Also

Reference

Block Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ILayer Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

ILayer Attached Properties

See Also

Reference

ILayer Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ILayer Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

ILayer Events

See Also

Reference

ILayer Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ILayer Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

ILayer Fields

See Also

Reference

ILayer Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IAttrib Attached Properties

IAttrib Attached Properties

Show / hide the hidden text

collall See Also

Reference

IAttrib Interface


IAttrib Events

IAttrib Events

Show / hide the hidden text

collall See Also

Reference

IAttrib Interface


IAttrib Fields

IAttrib Fields

Show / hide the hidden text

collall See Also

Reference

IAttrib Interface


SVGImage Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

SVGImage Attached Properties

See Also

Reference

SVGImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


SVGImage Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

SVGImage Events

See Also

Reference

SVGImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


SVGImage Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

SVGImage Fields

See Also

Reference

SVGImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ISVGImage Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

ISVGImage Attached Properties

See Also

Reference

ISVGImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ISVGImage Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

ISVGImage Events

See Also

Reference

ISVGImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ISVGImage Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

ISVGImage Fields

See Also

Reference

ISVGImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ICADLine Attached Properties

ICADLine Attached Properties

Show / hide the hidden text

collall See Also

Reference

ICADLine Interface


ICADLine Events

ICADLine Events

Show / hide the hidden text

collall See Also

Reference

ICADLine Interface


ICADLine Fields

ICADLine Fields

Show / hide the hidden text

collall See Also

Reference

ICADLine Interface


ICADViewX Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

ICADViewX Attached Properties

See Also

Reference

ICADViewX Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ICADViewX Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

ICADViewX Events

See Also

Reference

ICADViewX Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ICADViewX Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

ICADViewX Fields

See Also

Reference

ICADViewX Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Layout Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Layout Attached Properties

See Also

Reference

Layout Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Layout Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Layout Events

See Also

Reference

Layout Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Layout Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Layout Fields

See Also

Reference

Layout Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IGroup Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IGroup Attached Properties

See Also

Reference

IGroup Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IGroup Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IGroup Events

See Also

Reference

IGroup Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IGroup Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IGroup Fields

See Also

Reference

IGroup Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IDWGImage Attached Properties

IDWGImage Attached Properties

Show / hide the hidden text

collall See Also

Reference

IDWGImage Interface


IDWGImage Events

IDWGImage Events

Show / hide the hidden text

collall See Also

Reference

IDWGImage Interface


IDWGImage Fields

IDWGImage Fields

Show / hide the hidden text

collall See Also

Reference

IDWGImage Interface


Point3D Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Point3D Attached Properties

See Also

Reference

Point3D Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Point3D Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Point3D Events

See Also

Reference

Point3D Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Point3D Methods

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Point3D Methods

See Also

Reference

Point3D Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Point3D Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Point3D Fields

See Also

Reference

Point3D Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IGroup Attached Properties

IGroup Attached Properties

Show / hide the hidden text

collall See Also

Reference

IGroup Interface


IGroup Events

IGroup Events

Show / hide the hidden text

collall See Also

Reference

IGroup Interface


IGroup Fields

IGroup Fields

Show / hide the hidden text

collall See Also

Reference

IGroup Interface


IHPGLImage Attached Properties

IHPGLImage Attached Properties

Show / hide the hidden text

collall See Also

Reference

IHPGLImage Interface


IHPGLImage Events

IHPGLImage Events

Show / hide the hidden text

collall See Also

Reference

IHPGLImage Interface


IHPGLImage Fields

IHPGLImage Fields

Show / hide the hidden text

collall See Also

Reference

IHPGLImage Interface


Polyline Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Polyline Attached Properties

See Also

Reference

Polyline Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Polyline Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Polyline Events

See Also

Reference

Polyline Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Polyline Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Polyline Fields

See Also

Reference

Polyline Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


DXFImage Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

DXFImage Attached Properties

See Also

Reference

DXFImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


DXFImage Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

DXFImage Events

See Also

Reference

DXFImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


DXFImage Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

DXFImage Fields

See Also

Reference

DXFImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


HPGLImage Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

HPGLImage Attached Properties

See Also

Reference

HPGLImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


HPGLImage Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

HPGLImage Events

See Also

Reference

HPGLImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


HPGLImage Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

HPGLImage Fields

See Also

Reference

HPGLImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IInsert Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IInsert Attached Properties

See Also

Reference

IInsert Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IInsert Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IInsert Events

See Also

Reference

IInsert Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IInsert Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IInsert Fields

See Also

Reference

IInsert Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IImageEnt Attached Properties

IImageEnt Attached Properties

Show / hide the hidden text

collall See Also

Reference

IImageEnt Interface


IImageEnt Events

IImageEnt Events

Show / hide the hidden text

collall See Also

Reference

IImageEnt Interface


IImageEnt Fields

IImageEnt Fields

Show / hide the hidden text

collall See Also

Reference

IImageEnt Interface


IVertex Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IVertex Attached Properties

See Also

Reference

IVertex Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IVertex Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IVertex Events

See Also

Reference

IVertex Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IVertex Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

IVertex Fields

See Also

Reference

IVertex Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


ImageEnt Attached Properties

ImageEnt Attached Properties

Show / hide the hidden text

collall See Also

Reference

ImageEnt Interface


ImageEnt Events

ImageEnt Events

Show / hide the hidden text

collall See Also

Reference

ImageEnt Interface


ImageEnt Fields

ImageEnt Fields

Show / hide the hidden text

collall See Also

Reference

ImageEnt Interface


Insert Attached Properties

Insert Attached Properties

Show / hide the hidden text

collall See Also

Reference

Insert Interface


Insert Events

Insert Events

Show / hide the hidden text

collall See Also

Reference

Insert Interface


Insert Fields

Insert Fields

Show / hide the hidden text

collall See Also

Reference

Insert Interface


IPoint2D Attached Properties

IPoint2D Attached Properties

Show / hide the hidden text

collall See Also

Reference

IPoint2D Interface


IPoint2D Events

IPoint2D Events

Show / hide the hidden text

collall See Also

Reference

IPoint2D Interface


IPoint2D Methods

IPoint2D Methods

Show / hide the hidden text

collall See Also

Reference

IPoint2D Interface


IPoint2D Fields

IPoint2D Fields

Show / hide the hidden text

collall See Also

Reference

IPoint2D Interface


IPoint3D Attached Properties

IPoint3D Attached Properties

Show / hide the hidden text

collall See Also

Reference

IPoint3D Interface


IPoint3D Events

IPoint3D Events

Show / hide the hidden text

collall See Also

Reference

IPoint3D Interface


IPoint3D Fields

IPoint3D Fields

Show / hide the hidden text

collall See Also

Reference

IPoint3D Interface


DWGImage Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

DWGImage Attached Properties

See Also

Reference

DWGImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


DWGImage Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

DWGImage Events

See Also

Reference

DWGImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


DWGImage Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

DWGImage Fields

See Also

Reference

DWGImage Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Attrib Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Attrib Attached Properties

See Also

Reference

Attrib Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Attrib Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Attrib Events

See Also

Reference

Attrib Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Attrib Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Attrib Fields

See Also

Reference

Attrib Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Text Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Text Attached Properties

See Also

Reference

Text Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Text Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Text Events

See Also

Reference

Text Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Text Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Text Fields

See Also

Reference

Text Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IRect2D Attached Properties

IRect2D Attached Properties

Show / hide the hidden text

collall See Also

Reference

IRect2D Interface


IRect2D Events

IRect2D Events

Show / hide the hidden text

collall See Also

Reference

IRect2D Interface


IRect2D Methods

IRect2D Methods

Show / hide the hidden text

collall See Also

Reference

IRect2D Interface


IRect2D Fields

IRect2D Fields

Show / hide the hidden text

collall See Also

Reference

IRect2D Interface


IRect3D Attached Properties

IRect3D Attached Properties

Show / hide the hidden text

collall See Also

Reference

IRect3D Interface


IRect3D Events

IRect3D Events

Show / hide the hidden text

collall See Also

Reference

IRect3D Interface


IRect3D Methods

IRect3D Methods

Show / hide the hidden text

collall See Also

Reference

IRect3D Interface


IRect3D Fields

IRect3D Fields

Show / hide the hidden text

collall See Also

Reference

IRect3D Interface


ISolid Attached Properties

ISolid Attached Properties

Show / hide the hidden text

collall See Also

Reference

ISolid Interface


ISolid Events

ISolid Events

Show / hide the hidden text

collall See Also

Reference

ISolid Interface


ISolid Fields

ISolid Fields

Show / hide the hidden text

collall See Also

Reference

ISolid Interface


ISpline Attached Properties

ISpline Attached Properties

Show / hide the hidden text

collall See Also

Reference

ISpline Interface


ISpline Events

ISpline Events

Show / hide the hidden text

collall See Also

Reference

ISpline Interface


ISpline Fields

ISpline Fields

Show / hide the hidden text

collall See Also

Reference

ISpline Interface


Solid Attached Properties

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Solid Attached Properties

See Also

Reference

Solid Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Solid Events

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Solid Events

See Also

Reference

Solid Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


Solid Fields

collall See Also

collall See Also

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

Solid Fields

See Also

Reference

Solid Interface

CADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IText Attached Properties

IText Attached Properties

Show / hide the hidden text

collall See Also

Reference

IText Interface


IText Events

IText Events

Show / hide the hidden text

collall See Also

Reference

IText Interface


IText Fields

IText Fields

Show / hide the hidden text

collall See Also

Reference

IText Interface


AxCADViewX.ShowPoint Method

collall Overload List

collall Overload List

 Return to chapter overview

collall Collapse All Expand All dropdown Language Filter: Code: All Code: Multiple Code: Visual Basic Code: C# Code: Visual C++ Code: J# Code: JScript

[TCheckBoxFormControlObj] Visual Basic

[TCheckBoxFormControlObj] C#

[TCheckBoxFormControlObj] Visual C++

[TCheckBoxFormControlObj] JScript

CADViewX Lite

AxCADViewX.ShowPoint Method

See Also

Draws loaded image centered by a specified point with certain scale factor.

Name | Description
ShowPoint(Point3D, double) | Draws loaded image centered by a specified point with certain scale factor.
ShowPoint(Point3D, double, Rect3D) | Draws loaded image centered by a specified point with certain scale factor.

collall See Also

Reference

AxCADViewX Class

AxCADViewX AxCADViewX Members

AxCADViewLib Namespace

© 2003-2013 Soft Gold Ltd.


IToolBox Attached Properties

IToolBox Attached Properties

Show / hide the hidden text

collall See Also

Reference

IToolBox Interface


IToolBox Events

IToolBox Events

Show / hide the hidden text

collall See Also

Reference

IToolBox Interface


IToolBox Fields

IToolBox Fields

Show / hide the hidden text

collall See Also

Reference

IToolBox Interface


IVertex Attached Properties

IVertex Attached Properties

Show / hide the hidden text

collall See Also

Reference

IVertex Interface


IVertex Events

IVertex Events

Show / hide the hidden text

collall See Also

Reference

IVertex Interface


IVertex Fields

IVertex Fields

Show / hide the hidden text

collall See Also

Reference

IVertex Interface


Point2D Attached Properties

Point2D Attached Properties

Show / hide the hidden text

collall See Also

Reference

Point2D Interface


Point2D Events

Point2D Events

Show / hide the hidden text

collall See Also

Reference

Point2D Interface


Point2D Methods

Point2D Methods

Show / hide the hidden text

collall See Also

Reference

Point2D Interface


Point2D Fields

Point2D Fields

Show / hide the hidden text

collall See Also

Reference

Point2D Interface


Point3D Attached Properties

Point3D Attached Properties

Show / hide the hidden text

collall See Also

Reference

Point3D Interface


Point3D Events

Point3D Events

Show / hide the hidden text

collall See Also

Reference

Point3D Interface


Point3D Fields

Point3D Fields

Show / hide the hidden text

collall See Also

Reference

Point3D Interface


Polyline Attached Properties

Polyline Attached Properties

Show / hide the hidden text

collall See Also

Reference

Polyline Interface


Polyline Events

Polyline Events

Show / hide the hidden text

collall See Also

Reference

Polyline Interface


Polyline Fields

Polyline Fields

Show / hide the hidden text

collall See Also

Reference

Polyline Interface


Rect2D Attached Properties

Rect2D Attached Properties

Show / hide the hidden text

collall See Also

Reference

Rect2D Interface


Rect2D Events

Rect2D Events

Show / hide the hidden text

collall See Also

Reference

Rect2D Interface


Rect2D Methods

Rect2D Methods

Show / hide the hidden text

collall See Also

Reference

Rect2D Interface


Rect2D Fields

Rect2D Fields

Show / hide the hidden text

collall See Also

Reference

Rect2D Interface


Rect3D Attached Properties

Rect3D Attached Properties

Show / hide the hidden text

collall See Also

Reference

Rect3D Interface


Rect3D Events

Rect3D Events

Show / hide the hidden text

collall See Also

Reference

Rect3D Interface


Rect3D Methods

Rect3D Methods

Show / hide the hidden text

collall See Also

Reference

Rect3D Interface


Rect3D Fields

Rect3D Fields

Show / hide the hidden text

collall See Also

Reference

Rect3D Interface


Solid Attached Properties

Solid Attached Properties

Show / hide the hidden text

collall See Also

Reference

Solid Interface


Solid Events

Solid Events

Show / hide the hidden text

collall See Also

Reference

Solid Interface


Solid Fields

Solid Fields

Show / hide the hidden text

collall See Also

Reference

Solid Interface


Spline Attached Properties

Spline Attached Properties

Show / hide the hidden text

collall See Also

Reference

Spline Interface


Spline Events

Spline Events

Show / hide the hidden text

collall See Also

Reference

Spline Interface


Spline Fields

Spline Fields

Show / hide the hidden text

collall See Also

Reference

Spline Interface


SVGImage Attached Properties

SVGImage Attached Properties

Show / hide the hidden text

collall See Also

Reference

SVGImage Interface


SVGImage Events

SVGImage Events

Show / hide the hidden text

collall See Also

Reference

SVGImage Interface


SVGImage Fields

SVGImage Fields

Show / hide the hidden text

collall See Also

Reference

SVGImage Interface


Vertex Attached Properties

Vertex Attached Properties

Show / hide the hidden text

collall See Also

Reference

Vertex Interface


Vertex Events

Vertex Events

Show / hide the hidden text

collall See Also

Reference

Vertex Interface


Vertex Fields

Vertex Fields

Show / hide the hidden text

collall See Also

Reference

Vertex Interface


API Reference

API Reference

Show / hide the hidden text

collall Namespaces

 | Name | Description
Namespace | AxCADViewLib |
Namespace | CADViewLib |

Top