Introduction

CAD .NET is a pack of several powerful classes that can be used in applications providing the possibility to read, edit and write CAD files.

CAD .NET provides API for reading AutoCAD™ DWG/DXF, HPGL/HPGL2 Hewlett Packard, Gerber, GDS and CGM file formats and writing DXF in your applications. CADConverter is the base class of CAD .NET. It provides the list of the CADEntity class based entities, loaded from DXF/DWG/HPGL/HPGL2/CGM file.

You can use AutoCAD™ drawings in your application, preview and import to your file format. CADConverter is a representation of the CAD files in the memory consists the standard TABLES, BLOCKS, ENTITIES sections, each of it has a list of visual primitives (BLOCKS, ENTITIES) or (TABLES).

CAD files can be displayed, printed, saved to BMP, EMF, JPEG, TIFF, GIF and other formats.

© 2005-2019 Soft Gold Ltd.


Changes

Version 14.1:

  • Support of CGM format improved
  • bugs fixed for:

- DWG, HPGL/2 import

- DXF, PDF export

- visualization

Version 14.0:

  • Support of GDSII format added
  • Support of AutoCAD™ 2018 format improved
  • Entities handling improved:

- CADAttdef

- CADAttrib

- CADText

- CADMText

- CADMLine

- CADSpline

- CADHelix

- CADLayout

- CADStyle

- ACIS entities

  • Some bugs fixed

Version 12.2:

  • Extended Data support added
  • Snap to intersection, apparent intersection options added
  • Snap options customization added
  • CADInsert entity support improved, including support clipping
  • CADBlock support improved
  • Big font SHX files support improved
  • Bugs fixed for:

- DWG, DXF import

- DXF, PDF export

- line types

- layers

- some entities

Version 12.1:

  • Export to DWG format is added using additional dynamic link library
  • ARC_DIMENSION, LARGE_RADIAL_DIMENSION dimension types support added
  • Explode, Join, Trim visual tools added
  • 3D Snap for wireframe(GDI+) visualization mode
  • Support enhanced for:

- line types

- polylines

- CADHelix

- CADLayer

- CADMInsert

- CADProxy

- CADTrace

  • Library messages optional processing instead of message boxes
  • Some minor improvements
  • Some bugs fixed

Version 12.0:

  • Support of AutoCAD™ DWG 2018 format is added
  • GDI+ visualization speed enhanced greatly
  • Non-unicode SHX texts/shapes support improved
  • Some bugs fixed

Version 11.2:

  • Export to G-code added
  • Big font SHX files support improved
  • Snap to center point option added
  • CADEditorControl, CADViewerControl components improved
  • Bugs fixed for:

- DWG, DXF, HPGL/2 import

- PDF export

- visualization, print

- visual editing

- external references

Version 11.1:

  • Processing speed and memory consumption for some big files enhanced
  • Visual creation of circles and arcs added
  • Some bugs fixed

Version 11.0:

  • New CLR 4 assembly unit in addition to the common CLR 2.0 assembly
  • Support of STL format is added
  • ACIS objects import speed increased
  • Support of AutoCAD units precision is added
  • AutoCAD current view export to DXF is added
  • HPGL/2 line thickness export is added
  • Bugs fixed for:

- DWG, DXF, GBR import

- CADEllipse

Version 10.2:

  • New demo project: Polylines
  • Reading AutoCAD file properties
  • Marker and PropertyGrid options added for CADText, CADMText
  • CGM export improved
  • Entities handling improved:

- CADText

- CADMText

- CADDimension

- CADAttdef

- CADAttrib

  • Grid color select
  • Bugs fixed for:

- DXF and TIFF import

- PDF export

- dimensions

- blocks

- attributes

- raster images

- line types

Version 10.1:

  • New visual component: Grid
  • New visual component: Ortho mode
  • Inserts visual editing added
  • Alternative CGM export added with curves increased precision and coordinates real precision
  • OLE objects visualization enhanced
  • Hatches visualization enhanced
  • Bugs fixed for:

- CGM and DXF export

- polylines and splines handling

- raster images

- visualization

Version 10.0:

  • New demo projects: AddEntities, GettingStarted
  • Set of basic SHX fonts is provided
  • New entity supported: MPolygon
  • LineTypes visualization enhanced:

- PSLTScale support added

- Plinegen support added

  • Dimensions support enhanced:

- Aligned and rotated dimension types supported

- Dimensions creation improved

- Additional CADDimension constructor added

  • Elevation support added for CADPolyline
  • Drawing speed optimization
  • PropertyGrid visual interface enhanced
  • Improved Layouts programming interface
  • Bugs fixed for:

- line types

- dimensions

- viewports

- hatches

- other bugs

Version 9:

  • Support of AutoCAD™ DWG 2013 format is added

Version 8:

  • Import of the following formats is improved:

- CGM;

- DWG/DXF;

- HPGL/2;

  • Export to vector formats is added:

- CGM;

- DXF;

- PDF;

- HPGL/2;

  • Many bugs relative to import and drawing are fixed;
  • Printing operation is improved;
  • The main settings of CADImage are grouped into CADPresenterSettings class properties;
  • SaveParams and RestoreParams methods are added for saving and restoring of settings (it works like a stack);
  • IMathOperations interface is added.

Version 7:

  • Entities handles are supported;
  • New entities types: WIPEOUT, MLINE, HELIX, MINSERT, TOLERANCE, POINT, IMAGEDEF, IMAGEENT, MLINESTYLE;
  • Complex line types;
  • Fixed bugs:

- printing in Vista;

- reading dwg and dxf formats;

- reading of gerber format;

- reading colors in dwg format;

- reading and drawing of line types;

- reading and drawing of MTEXT;

- reading and drawing of attributes;

- reading and drawing of dimensions;

- drawing of images in HPGL format;

- drawing frozen layers;

- exporting files to dxf format;

- SHX and TTF fonts support;

- many other bugs;

  • Optimized speed and memory usage;
  • Optimized drawing system;
  • Add new properties into object inspector;
  • Work only on Framework 2.0 and older (Framework 1.1 is not supported).

Version 6:

  • CADProxy objects are improved;
  • ACADTable object support was added;
  • CADViewerControl and CADEditorControl controls are added;
  • Handy system for bug report generating;
  • Easy-to-use source code of the demo applications;
  • Functional for visual entities creating and editing by markers was added;
  • Snap was added;
  • Support of Gerber file format (*.gbr);
  • Special drawing for gbr files;
  • Drawing apertures of gbr files as hatch;
  • Samples of code were added;
  • Double buffering mode through metafile was added (Viewer demo);
  • CADPictureBox with scroll bars was added;
  • Two additional SaveToStream methods were added;
  • ControlPaintExt and xor Pen drawing were added;
  • CADListView control for layers list displaying was added;
  • Speed of *.dwg files loading was improved;
  • Support of web paths and loading from web was added;
  • Support of entities serialization was added;
  • Color and dimentions settings for raster images saving were added;
  • Number of points in circles for raster images saving;
  • Copying of raster images from clipboard was added;
  • Pasting of raster images as new RasterImage was added.


Versions

Remarks

If you have any questions, please contact us at info@cadsofttools.com


Installation

To install CAD .NET run CAD .NET 14.x.exe. The following files will be installed into default prompted folders:

  • c:\Users\{UserName}\Documents\CAD .NET 14\:

.\bin - executable files of demo applications, CADImport.dll.

.\bin\Languages - the set of *.lng files - 25 languages support.

.\demo_sources - the source code of the demo applications.

  • c:\Program Files (x86)\CADSoftTools\CAD .NET 14\:

.\doc - documentation for the library in MS Help and .CHM formats.


Getting Started

Start integrating CAD .NET in application in minutes!

Getting Started demo application has simple code examples which can be easily copied to another application in order to use CAD .NET features.

Please click the buttons on the screenshot below to read code examples.

Add the following references to compile examples from this topic:

VB
C#
C++
JScript
Copy

 using CADImport;

 using CADImport.DWG;

 using CADImport.DXF;

 using CADImport.RasterImage;

This language is not supported or no code example is available.

Please look at Viewer and Editor demos to understand the possibilities of the library: zooming, working with layers, printing, editing, etc.

Demo Editor


Read DWG

...

using CADImport;

using CADImport.DWG;

using CADImport.DXF;

using CADImport.RasterImage;

...

VB
C#
C++
JScript
Copy
        private void Read_DWG_Click(object sender, EventArgs e)
         {
             //DWGImage class is used only for reading DWG. To read other
 formatsuse the corresponding classes.
             //E.g. for DXF: CADImage class, for PLT/HPGL: HPGLImage class.
             DWGImage vDrawing = new DWGImage();
             vDrawing.LoadFromFile(@"..\..\..\Files\Gasket.dwg");
             vDrawing.Draw(Image1.CreateGraphics(), new RectangleF(0, 0,
 (float)vDrawing.AbsWidth, (float)vDrawing.AbsHeight));
             // zooming and panning of the drawing are implemented in the demo
 Viewer
             // via a special viewing control class CADPictureBox
         }
This language is not supported or no code example is available.


Load file

...

using CADImport;

using CADImport.DWG;

using CADImport.DXF;

using CADImport.RasterImage;

...

VB
C#
C++
JScript
Copy
          private void Load_file_Click(object sender, EventArgs
 e)
         {
             if ((OpenFileDialog1.ShowDialog() != DialogResult.OK)) return;
             //CADImage.CreateImageByExtension detects format by the extension
 specified in the argument.
             //The correct class for any supported format will be used
 automatically. We recommend to
             //create a new drawing object with CADImage.CreateImageByExtension
 if import from the existed
             //file/stream is required.
             CADImage vDrawing =
 CADImage.CreateImageByExtension(OpenFileDialog1.FileName);
             vDrawing.LoadFromFile(OpenFileDialog1.FileName);
             // adjusting of the visualization sizes to the control area:
             RectangleF vRect;
             double vRatio = (double)(vDrawing.AbsHeight * Image1.ClientSize.Width)
 / (vDrawing.AbsWidth * Image1.ClientSize.Height);
             if (vRatio > 1)
                 vRect = new RectangleF(0, 0, (float)(Image1.ClientSize.Width /
 vRatio), (float)Image1.ClientSize.Height);
             else
                 vRect = new RectangleF(0, 0, (float)Image1.ClientSize.Width,
 (float)(Image1.ClientSize.Height * vRatio));
             //-----------------------------------------------
             vDrawing.Draw(Image1.CreateGraphics(), vRect);
         }
This language is not supported or no code example is available.


Access line

...

using CADImport;

using CADImport.DWG;

using CADImport.DXF;

using CADImport.RasterImage;

...

VB
C#
C++
JScript
Copy
         private void Access_line_data_Click(object sender, EventArgs e)
         {
             //CADImage.CreateImageByExtension detects format with by the extension specified in the argument.
             //The correct class for any supported format will be used automatically. We recommend to
             //create a new drawing object with CADImage.CreateImageByExtension if import from the existed
             //file/stream is required.
             CADImage vDrawing = CADImage.CreateImageByExtension(@"..\..\..\Files\Entities.dxf");
             vDrawing.LoadFromFile(@"..\..\..\Files\Entities.dxf");

             for (int i = 0; i < vDrawing.CurrentLayout.Count; i++)
             {
                 if (vDrawing.CurrentLayout.Entities[i].EntType == EntityType.Line)
                 {
                     CADLine vLine = (CADLine)vDrawing.CurrentLayout.Entities[i];
                     MessageBox.Show("Line is found. Handle = " + vLine.Handle +
                         "; X: " + vLine.Point.X + "; Y: " + vLine.Point.Y +
                         "; X1: " + vLine.Point1.X + "; Y1: " + vLine.Point1.Y);
                     break;
                 }
             }
         }

This language is not supported or no code example is available.


Change layers

...

VB
C#
C++
JScript
Copy
using CADImport;
 using CADImport.DWG;
 using CADImport.DXF;
 using CADImport.RasterImage;
This language is not supported or no code example is available.

...

VB
C#
C++
JScript
Copy
         private void Change_layers_Click(object sender, EventArgs e)
         {
             //CADImage.CreateImageByExtension detects format by the extension specified in the argument.
             //The correct class for any supported format will be used automatically. We recommend to
             //create a new drawing object with CADImage.CreateImageByExtension if import from the existed
             //file/stream is required.
             CADImage vDrawing = CADImage.CreateImageByExtension(@"..\..\..\Files\Entities.dxf");
             vDrawing.LoadFromFile(@"..\..\..\Files\Entities.dxf");
             // Changes color for Layer '0'
             vDrawing.Converter.LayerByName("0").Color = Color.Red;
             // If Layer2 doesn't exist, it will be created
             CADLayer vLayer = vDrawing.Converter.LayerByName("Layer2");
             vLayer.Visible = false; //Changes layer visibility
             // Adjusting visualization sizes to the control area:
             RectangleF vRect;
             double vRatio = (double)(vDrawing.AbsHeight * Image1.ClientSize.Width) / (vDrawing.AbsWidth * Image1.ClientSize.Height);
             if (vRatio > 1)
                 vRect = new RectangleF(0, 0, (float)(Image1.ClientSize.Width / vRatio), (float)Image1.ClientSize.Height);
             else
                 vRect = new RectangleF(0, 0, (float)Image1.ClientSize.Width, (float)(Image1.ClientSize.Height * vRatio));
             //-----------------------------------------------
             vDrawing.Draw(Image1.CreateGraphics(), vRect);
         }
This language is not supported or no code example is available.


Access texts

VB
C#
C++
JScript
Copy
 ...
 using CADImport;
 using CADImport.DWG;
 using CADImport.DXF;
 using CADImport.RasterImage;
 ...
         private void Access_texts_Click(object sender, EventArgs e)
         {
             //CADImage.CreateImageByExtension detects format by the extension specified in the argument.
             //The correct class for any supported format will be used automatically. We recommend to
             //create a new drawing object with CADImage.CreateImageByExtension if import from the existed
             //file/stream is required.
             CADImage vDrawing = CADImage.CreateImageByExtension(@"..\..\..\Files\Entities.dxf");
             vDrawing.LoadFromFile(@"..\..\..\Files\Entities.dxf");
             // Adjusting visualization sizes to the control area:
             RectangleF vRect;
             double vRatio = (double)(vDrawing.AbsHeight * Image1.ClientSize.Width) / (vDrawing.AbsWidth * Image1.ClientSize.Height);
             if (vRatio > 1)
                 vRect = new RectangleF(0, 0, (float)(Image1.ClientSize.Width / vRatio), (float)Image1.ClientSize.Height);
             else
                 vRect = new RectangleF(0, 0, (float)Image1.ClientSize.Width, (float)(Image1.ClientSize.Height * vRatio));
             //-----------------------------------------------
             vDrawing.Draw(Image1.CreateGraphics(), vRect);

                string S = "";
             for (int i = 0; i < vDrawing.CurrentLayout.Count; i++)
             {
                 if (vDrawing.CurrentLayout.Entities[i].EntType == EntityType.Text)
                 {
                     CADText vText = (CADText)vDrawing.CurrentLayout.Entities[i];
                     MessageBox.Show("Text: " + vText.Text);
                 }
                 if (vDrawing.CurrentLayout.Entities[i].EntType == EntityType.MText)
                 {
                     CADMText vMText = (CADMText)vDrawing.CurrentLayout.Entities[i];
                     for (int j = 0; j < vMText.Block.Count; j++)
                         S = S + ((CADText)vMText.Block.Entities[j]).Text + "\n";
                     MessageBox.Show("MText:\n" + S);
                     S = "";
                 }
             }
         }
This language is not supported or no code example is available.


Add, change, delete

VB
C#
C++
JScript
Copy
...
 using CADImport;
 using CADImport.DWG;
 using CADImport.DXF;
 using CADImport.RasterImage;
 ...

         private void Add_change_delete_Click(object sender, EventArgs e)
         {
             //CADImage.CreateImageByExtension detects format by the extension specified in the argument.
             //The correct class for any supported format will be used automatically. We recommend to
             //create a new drawing object with CADImage.CreateImageByExtension if import from the existed
             //file/stream is required.
             CADImage vDrawing = CADImage.CreateImageByExtension(@"..\..\..\Files\Entities.dxf");
             vDrawing.LoadFromFile(@"..\..\..\Files\Entities.dxf");
             // Changes color
             vDrawing.CurrentLayout.Entities[1].Color = Color.Blue;
             vDrawing.CurrentLayout.Entities[1].LineWeight = 2;
             vDrawing.Converter.Loads(vDrawing.CurrentLayout.Entities[1]);
             //Removes the circle entity from the Entities.dxf drawing
             vDrawing.CurrentLayout.Entities.RemoveAt(2);
             // Creating a new entity - line
             CADLine vLine = new CADLine();
             vLine.Point = new DPoint(50, 0, 0);
             vLine.Point1 = new DPoint(50, 70, 10);
             vLine.LineWeight = 1;
             vDrawing.Converter.Loads(vLine);
             vDrawing.CurrentLayout.AddEntity(vLine);
             // Recalculates the extents of the drawing
             vDrawing.GetExtents();
             // Adjusting visualization sizes to the control area:
             RectangleF vRect;
             double vRatio = (double)(vDrawing.AbsHeight * Image1.ClientSize.Width) / (vDrawing.AbsWidth * Image1.ClientSize.Height);
             if (vRatio > 1)
                 vRect = new RectangleF(0, 0, (float)(Image1.ClientSize.Width / vRatio), (float)Image1.ClientSize.Height);
             else
                 vRect = new RectangleF(0, 0, (float)Image1.ClientSize.Width, (float)(Image1.ClientSize.Height * vRatio));
             //-----------------------------------------------
             vDrawing.Draw(Image1.CreateGraphics(), vRect);
         }
This language is not supported or no code example is available.


CAD to BMP

VB
C#
C++
JScript
Copy
...
 using CADImport;
 using CADImport.DWG;
 using CADImport.DXF;
 using CADImport.RasterImage;
 ...

         private void CAD_to_BMP_Click(object sender, EventArgs e)
         {
             if ((OpenFileDialog1.ShowDialog() != DialogResult.OK)) return;
             //CADImage.CreateImageByExtension detects format by the extension specified in the argument.
             //The correct class for any supported format will be used automatically. We recommend to
             //create a new drawing object with CADImage.CreateImageByExtension if import from the existed
             //file/stream is required.
             CADImage vDrawing = CADImage.CreateImageByExtension(OpenFileDialog1.FileName);
             vDrawing.LoadFromFile(OpenFileDialog1.FileName);
             // The bitmap will have 1000 px width, height will be calulated automatically
             Bitmap vBitmap = new Bitmap(1000, (int)(1000 * vDrawing.AbsHeight / vDrawing.AbsWidth));
             Graphics vGr = Graphics.FromImage(vBitmap);
             RectangleF vRect = new RectangleF(0, 0, (float)1000, (float)(vBitmap.Width * vDrawing.AbsHeight / vDrawing.AbsWidth));
             vDrawing.Draw(vGr, vRect);
             vBitmap.Save(OpenFileDialog1.FileName + ".bmp", System.Drawing.Imaging.ImageFormat.Bmp);
         }
This language is not supported or no code example is available.


Find block

VB
C#
C++
JScript
Copy
...
 using CADImport;
 using CADImport.DWG;
 using CADImport.DXF;
 using CADImport.RasterImage;
 ...

         private void Find_block_Click(object sender, EventArgs e)
         {
             //CADImage.CreateImageByExtension detects format by the extension specified in the argument.
             //The correct class for any supported format will be used automatically. We recommend to
             //create a new drawing object with CADImage.CreateImageByExtension if import from the existed
             //file/stream is required.
             CADImage vDrawing = CADImage.CreateImageByExtension(@"..\..\..\Files\Entities.dxf");
             vDrawing.LoadFromFile(@"..\..\..\Files\Entities.dxf");

             string BlockName = "Block1"; //The block name is Block1
             for (int i = 0; i < vDrawing.Converter.Blocks.Count; i++)
                 if (((CADBlock)vDrawing.Converter.Blocks[i]).Name.ToLower() == BlockName.ToLower())
                 { //found
                     MessageBox.Show("Block with name '" + BlockName + "' has found.\nIndex of the block is " + i);
                     break;
                 }
         }
This language is not supported or no code example is available.


Adding a simple CAD view feature to a new application

1. Start new Windows Application project.

2. Save the project to any directory, for instance: c:\Users\{UserName}\Documents\CAD .NET 14\demo_sources\MyDemo.

3. Copy CADImport.dll file to Debug directory, for instance: c:\Users\{UserName}\Documents\CAD .NET 14\demo_sources\MyDemo\WindowsApplication1\WindowsApplication1\bin\Debug\CADImport.dll.

4. Add reference to CADImport.dll in MS Studio: View > Solution Explorer > References > Right mouse click > Add Reference > Browse >c:\Users\{UserName}\Documents\CAD .NET 14\demo_sources\MyDemo\WindowsApplication1\WindowsApplication1\bin\Debug\CADImport.dll or your path to the file CADImport.dll> OK.

Please check whether you see CADImport in the References section like on the picture below:

5. Open code (Solution Explorer > Form1.cs > View code) and add CADImport namespace:

VB
C#
C++
JScript
Copy
..
 using System.Windows.Forms;
 using CADImport;
 ..
This language is not supported or no code example is available.

6. Create a new CADImage class instance and load a CAD file using the following code:

VB
C#
C++
JScript
Copy
 public partial class Form1 : Form
  {
      CADImage cadImage;
      public Form1()
      {
          InitializeComponent();
          string path = @"c:\CADSoftTools.dxf";
          cadImage = CADImage.CreateImageByExtension(path);
          cadImage.LoadFromFile(path);
      }
  }
This language is not supported or no code example is available.

Please note that it is necessary to use exactly CADImage.CreateImageByExtension method to create the object of the right class.

7. In Form Properties (View > Properties window) please select Events > Paint. Double-click there and write the following code to draw the CAD image onto a form with 500 pixels width.

VB
C#
C++
JScript
Copy
 private void Form1_Paint(object sender, PaintEventArgs e)
  {
      if (cadImage != null)
      {
          RectangleF R;
          R = new RectangleF(0, 0, 500, 500);
          R.Height = (float) (R.Width * cadImage.Extents.Height /
 cadImage.Extents.Width);
          // width of image is 500, height depends on height/width of the drawing
          cadImage.Draw(e.Graphics, R);
      }

  }
This language is not supported or no code example is available.


Changing the default color for entities in ViewerDemo

1. Open C:\Users\{UserName}\Documents\CAD .NET 14\demo_sources\ViewerDemo\C#\ViewerDemo.csproj in MS Studio.

2. Press F5.

3. Open a CAD file. You can navigate by mouse wheel and use toolbar buttons to work with the CAD file.

4. Close application, select in MS Studio Solution Explorer > ViewerMainForm.cs, select File > Type Here and type ChangeEntitiesColor:

5. Type the following lines:

Copy
cadImage.DefaultColor = Color.Red;
 cadPictBox.Invalidate();

6. Run application, open a CAD file, then click File > ChangeEntitiesColor - you will see that the entities with default color are red. Entities with non-default color will save their colors in this case.


CADImport Namespace

Assembly: CADImport (in CADImport.dll)

Classes
 | Name | Description
Public class | AssemblyVersion | Represents an object for verification of the assembly version
Public class | CAD2DArc | Represents a hatch border as an arc curve.
Public class | CAD2DBoundaryList | Represents a collection of hatch borders.
Public class | CAD2DCurve | The abstract class. Represents a hatch border as a curve line.
Public class | CAD2DEllipse | Represents a hatch border as an ellipse.
Public class | CAD2DLine | Represents a hatch border as a straight line.
Public class | CAD2DPolyline | Represents a hatch border as a polyline.
Public class | CAD2DSpline | Represents a hatch border as a spline curve.
Public class | CAD3DSolid | Represents a CAD3DSolid descendant of the CADACISEntity class.
Public class | CAD3dFace | Represents a three-dimensional three- or four-sided surface in a CAD image.
Public class | CADACISEntity | Represents entities of incorporate graphics received by 3D modelling engine developed by Spatial company.
Public class | CADAcadTable | Corresponds AcadTable object
Public class | CADArc | Represents an arc in a CAD image.
Public class | CADAttdef | Represents an attribute in a CAD image.
Public class | CADAttrib | Allow to redefy CADAttdef object with corresponding tag property.
Public class | CADBlock | Represents a block in a CAD file.
Public class | CADBlockRecord | This class is for internal use only.
Public class | CADBody | Represents a CADBody descendant of the CADACISEntity class.
Public class | CADCircle | Represents a circle in a CAD image.
Public class | CADCollection<T> | Represents a collection of typed objects.
Public class | CADConst | Auxiliary class.
Public class | CADConverter | Provides methods for loading a file and producing a set of CAD entities contained in the loaded file.
Public class | CADCurvePolygon | Represents a hatch with a border of arbitrary shape.
Public class | CADCustomVertex | Provides a common functionality for the CADText and CADInsert classes.
Public class | CADDXFReferenceCollection | Represents a collection of XRef objects.
Public class | CADDimension | Represents dimensions in a CAD image.
Public class | CADDimensionArc | Represents Arc lenght dimension in a CAD image
Public class | CADDimensionRadialLarge | Represents Large Radial dimension in a CAD image
Public class | CADDimensionStyle | Represents a style applicable to dimension lines in a CAD image.
Public class | CADEllipse | Represents a full ellipse or elliptical arc in a CAD image.
Public class | CADEntity | Represents a base class for all entities in a CAD file.
Public class | CADEntityCollection | Represents a collection of CAD entities.
Public class | CADExtrusion | Provides methods to recalculate coordinates taking into account 3D orientation.
Public class | CADGradientPolygon | Represents a hatch with a gradient filling.
Public class | CADGraphics2D<T> | Abstract class for internal use.
Public class | CADGraphicsGDI | Provides drawing functionality based on GDI+.
Public class | CADGraphicsOpenGL | Provides OpenGL based drawing functionality.
Public class | CADGroup | Represents a base class for all CAD entities that contain other CAD entities.
Public class | CADHatch | Represents a hatch in a CAD image.
Public class | CADHelix | Represents a helix in a CAD image.
Public class | CADImage | Represents a CAD drawing and provides methods for drawing all loaded CAD objects.
Public class | CADImageDef | Represents a raster image inserted in the CAD drawing.
Public class | CADImageEnt | Represents a reference to the raster image in the CAD drawing.
Public class | CADInsert | Represents a block reference in a CAD image.
Public class | CADIterate | Provides a set of data for each CAD entity to be processed by the Iterate method.
Public class | CADLWPolyLine | Represents a planar polyline.
Public class | CADLayer | Represents a layer in a CAD image.
Public class | CADLayout | Represents a layout of the CAD drawing.
Public class | CADLayoutCollection | Represents a collection of CADLayout objects.
Public class | CADLeader | Represents objects consisting of a line segments or a spline with an arrowhead at one end and a multiline text at the other.
Public class | CADLine | Represents a line in a CAD image.
Public class | CADLineType | Represents a linetype in a CAD image.
Public class | CADMInsert | Represents MInsert in a CAD image.
Public class | CADMLine | Represents an MLine object in a CAD image.
Public class | CADMLineEntry | Represents an Tolerance object in a CAD image.
Public class | CADMLineStyle | Represents an Tolerance object in a CAD image.
Public class | CADMPolygon | Represents MPolygon in a CAD image.
Public class | CADMText | Represents a multiline text in a CAD image.
Public class | CADMath | Provides methods for mathematical calculations.
Public class | CADMatrix | Encapsulates a 4-by-3 affine matrix that represents a geometric transform.
Public class | CADOLE2Frame | Represents an OLE object in a CAD image.
Public class | CADObjectEntity | Provides a common functionality for all CAD entities, visual and not visual.
Public class | CADPainter<T> | Implements basic drawing methods.
Public class | CADPenEntity | Represents a base class for all CAD entities that use Pen object for its drawing.
Public class | CADPenLine | Represents a base class for the CADLine and CADPolyPolygon classes.
Public class | CADPenTableItem | Represents a table item for all entities organized in tables in a CAD file.
Public class | CADPlotEntity | Provides a common functionality for all visual CAD entities.
Public class | CADPoint | Represents a point in a CAD image.
Public class | CADPolyLine | Represents objects composed of the connected lines and bulge segments.
Public class | CADPolyPolygon | Represents a simple hatch with a border shaped as polyline.
Public class | CADPolylineBase | Represents a base class for CADCircle,CADArc,CADPolyline,CADWipeout,CADSpline.
Public class | CADPresenter | Implements basic drawing methods.
Public class | CADPresenterSettings | Represents a set of settings for the CADPresenter.
Public class | CADProxy | Represent CAD entities created by applications other than AutoCAD.
Public class | CADRegion | Represents a CADRegion descendant of the CADACISEntity class.
Public class | CADSection | Represents a section of a CAD file.
Public class | CADSelector | Provides functionality for selecting entities on a CAD image.
Public class | CADSeqend | This class is for internal use only.
Public class | CADShape | Represents a shape in a CAD image.
Public class | CADSolid | Represents triangles and four-sided polygons in a CAD image.
Public class | CADSortEntsTable | Represents a table that contains handles of entities before sorting.
Public class | CADSpline | Represents a spline in a CAD image.
Public class | CADStyle | Represents a text style in a CAD image.
Public class | CADSurface | Represents a CADSurface descendant of the CADACISEntity class.
Public class | CADTable | Represents a table that contains data about CAD entities described in the Tables section of a DXF file.
Public class | CADText | Represents a single text line in a CAD image.
Public class | CADTolerance | Represents a Tolerance object in a CAD image.
Public class | CADTrace | Trace entity
Public class | CADVPort | Represents a viewport in a model space.
Public class | CADVertex | Represents a vertex of a CADPolyLine.
Public class | CADViewPort | Represents a layout viewport in a CAD drawing.
Public class | CADWipeout | Represents a wipeout entity.
Public class | CADXRef | Represents an external reference in a CAD image.
Public class | ColorTypeConverter | Provides functionality for both-way converting the string objects to objects representing colors.
Public class | DWGProps | Represents the set of properties for an AutoCAD drawing.
Public class | DynamicArray<T> | Represents an array of typed elements.
Public class | FlatEntity | FlatEntity class defines base class for 2D entities (FlatHatch and FlatPoly).
Public class | FlatHatch | Defines a two-dimensional hatch.
Public class | FlatPoly | Defines a two-dimensional polyline.
Public class | FontsParameters | Represents a set of font parameters.
Public class | HatchPatternData | Represents hatch settings
Public class | HeadVarStruct | Defines the structure which contains some system variables.
Public class | LTypeElementStruct | Provides parameters that specifies a line type in a CAD image.
Public class | LayerConverter | Provides functionality for both-way converting the string objects to objects representing layers.
Public class | LineTypeConverter | Provides functionality for both-way converting the string objects to objects representing lineweight.
Public class | LineWeightConverter | Provides functionality for both-way converting the string objects to objects representing lineweight.
Public class | MVertex | Represents a vertex of a CADMLine.
Public class | ObjEntities | Provides functionality for displaying a collection of CADEntity properties in the PropertyGrid control.
Public class | ObjEntity | Provides functionality for displaying the entity properties in the PropertyGrid control.
Public class | Point3D | Provides methods for displaying the coordinates of three-dimensional point in the properties window.
Public class | Point3DExt | Expand to see the spelling options for the application
Public class | Protection | Provides functionality for the application's registration.
Public class | SGLines | Provides parameters that specify a line type in a CAD image.
Public class | SHXFont | Represents fonts from the compiled shape (SHX) files.
Public class | SHXFontList | Represents a list of SHX fonts among which the default SHX fonts are searched.
Public class | TextStyle | Represents a text style for the SHX fonts.
Public class | Vertex3D | Provides methods for displaying the coordinates of three-dimensional vertex in the properties window.
Public class | Xdata | Represents a single Extended Data entry
Public class | Xtome | Groups Xdata entries by an application
Public class | XtomesList | Represents an Extended Data instance as a list of Xtome instances
Top
Forms
 | Name | Description
Public class | CADTreeView | Represents a form that shows structure of a CAD drawing as a tree.
Top
Structures
 | Name | Description
Public structure | CAD2DPoint | Represents a point in the 2D Cartesian coordinate system.
Public structure | DPoint | Represents a point in the 3D coordinate system.
Public structure | DRect | Represents a parallelepiped.
Public structure | DimStyleStruct | Defines structure that contains some dimension variables.
Public structure | FPoint | Represents a point in the 3D coordinate system.
Public structure | RECT | Specifies the dimensions, in logical coordinates, of a rectangle that is used for clipping, opaquing, or both.
Public structure | Rect2D | Represent a rectangle.
Top
Delegates
 | Name | Description
Public delegate | CADEntityProc | Represents methods for entities.
Public delegate | CADXRefResolver | Represents methods for resolve unknown xrefs.
Public delegate | EndDraw | Represents methods related to end of visualization.
Public delegate | EndThread | Represents methods related to end of a thread.
Public delegate | EventHandler | Represents methods that will handle all events in the CADImport namespace.
Public delegate | FPointProc | Represents methods for getting the entities' points.
Public delegate | PointValueChange | Represents methods that will handle the events of changing the coordinates of a three-dimensional point.
Public delegate | VertexValueChange | Delegate for Vertex3D editing
Top
Enumerations
 | Name | Description
Public enumeration | CADBorderType | Specifies the way the CAD image margins are calculated.
Public enumeration | CADDrawMode | Specifies the color management in the CAD image.
Public enumeration | CADHatchStyle | Specifies a hatch style.
Public enumeration | CADHatchType | Specifies a border type of the hatched area.
Public enumeration | CADSpace | Specifies a type of space used in a CAD drawing.
Public enumeration | CADTextHorizontalAlign | Specifies a horizontal alignment for CADText.
Public enumeration | CADViewDirection | Specifies a direction of viewing a CAD image.
Public enumeration | DimName | Describes dimension variables
Public enumeration | DimTextPosVert | Describes dimension text placement relative dimension line.
Public enumeration | DrawGraphicsMode | Specifies a subsystem used for rendering graphics.
Public enumeration | EntityType | Specifies an entity type.
Public enumeration | FileFormat | List of supported files extensions
Public enumeration | InsUnitsStruct | Default drawing units for AutoCAD DesignCenter blocks
Public enumeration | LicenseType | Specifies the type of license registration.
Public enumeration | MessagesHandling | Messages handling options
Public enumeration | PenStyle | Specifies a type of line used to draw a CAD entity.
Public enumeration | ProgressStage | Specifies a stage of reading a file.
Public enumeration | RenderMode | Rendering modes for OpenGL visualization
Public enumeration | SHXKinds | Specifies a type of the SHX fonts.
Public enumeration | SelectionEntityMode | Specifies a state of the Selection tool.
Public enumeration | TTFSmoothing | Smoothimg modes for TTF fonts visualization
Public enumeration | TextGeneration | Specifies a direction of generating text letters.
Top
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


AssemblyVersion Class

Members See Also

Represents an object for verification of the assembly version

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class AssemblyVersion
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class AssemblyVersion
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.AssemblyVersion
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AssemblyVersion Members
CADImport Namespace


AssemblyVersion Members

AssemblyVersion Class Constructors Methods Properties See Also

Represents an object for verification of the assembly version

The following tables list the members exposed by the AssemblyVersion type.

Constructors
 | Name | Description
Public constructor | AssemblyVersion | Creates an instance of the AssemblyVersion class
Top
Properties
 | Name | Description
Public property | Version | Gets or sets a Version of the current assembly
Top
Methods
 | Name | Description
Public method | CheckVersion | Checks if the current assembly version matches the specified
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

AssemblyVersion Class


AssemblyVersion Constructor

See Also

Creates an instance of the AssemblyVersion class

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public AssemblyVersion()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AssemblyVersion Class
AssemblyVersion Members


AssemblyVersion Properties

AssemblyVersion Class See Also

The following tables list the members exposed by the AssemblyVersion type.

Properties
 | Name | Description
Public property | Version | Gets or sets a Version of the current assembly
Top
See Also

Reference

AssemblyVersion Class


AssemblyVersion.Version Property

Gets or sets a Version of the current assembly

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Version() As Version
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Version Version {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AssemblyVersion Class
AssemblyVersion Members


AssemblyVersion Methods

AssemblyVersion Class See Also

The following tables list the members exposed by the AssemblyVersion type.

Methods
 | Name | Description
Public method | CheckVersion | Checks if the current assembly version matches the specified
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

AssemblyVersion Class


AssemblyVersion.CheckVersion Method

Checks if the current assembly version matches the specified

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function CheckVersion( _
   ByVal val As AssemblyVersion _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool CheckVersion(
   AssemblyVersion val
)
This language is not supported or no code example is available.

Parameters

val

Type: AssemblyVersion

Assembly version

Return Value

Returns true if versions are equals
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AssemblyVersion Class
AssemblyVersion Members


CAD2DArc Class

Members See Also

Represents a hatch border as an arc curve.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CAD2DArc
    Inherits CAD2DCurve
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CAD2DArc : CAD2DCurve
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CAD2DCurve
CADImport.CAD2DArc
CADImport.CAD2DEllipse
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DArc Members


CAD2DArc Members

CAD2DArc Class Constructors Methods Properties See Also

Represents a hatch border as an arc curve.

The following tables list the members exposed by the CAD2DArc type.

Constructors
 | Name | Description
Public constructor | CAD2DArc | Initializes a new instance of the CAD2DArc class.
Top
Properties
 | Name | Description
Public property | CenterPoint | Gets or sets the center point of the CAD2DArc instance.
Public property | CounterClockWise | Gets or sets arc direction.
Public property | EndParam | Gets or sets the end angle of the CAD2DArc instance.
Public property | EndPoint | Gets the end point of the CAD2DArc instance.
Public property | Radius | Gets or sets the radius of the CAD2DArc instance.
Public property | StartParam | Gets or sets the start angle of the CAD2DArc instance.
Public property | StartPoint | Gets the start point of theCAD2DArc instance.
Top
Methods
 | Name | Description
Public method | Clone | Creates and returns a copy of the current CAD2DArc class instance.
Public method | Dispose | Releases all resources used by the CAD2DArc class instance.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CAD2DArc Class


CAD2DArc Constructor

Initializes a new instance of the CAD2DArc class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CAD2DArc()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DArc Class
CAD2DArc Members


CAD2DArc Properties

CAD2DArc Class See Also

The following tables list the members exposed by the CAD2DArc type.

Properties
 | Name | Description
Public property | CenterPoint | Gets or sets the center point of the CAD2DArc instance.
Public property | CounterClockWise | Gets or sets arc direction.
Public property | EndParam | Gets or sets the end angle of the CAD2DArc instance.
Public property | EndPoint | Gets the end point of the CAD2DArc instance.
Public property | Radius | Gets or sets the radius of the CAD2DArc instance.
Public property | StartParam | Gets or sets the start angle of the CAD2DArc instance.
Public property | StartPoint | Gets the start point of theCAD2DArc instance.
Top
See Also

Reference

CAD2DArc Class


CAD2DArc.CenterPoint Property

Gets or sets the center point of the CAD2DArc instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property CenterPoint() As CAD2DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CAD2DPoint CenterPoint {get; set;}
This language is not supported or no code example is available.

Property Value

A CAD2DPoint object representing the center point of the CAD2DArc instance.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DArc Class
CAD2DArc Members


CAD2DArc.CounterClockWise Property

Gets or sets arc direction.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property CounterClockWise() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool CounterClockWise {get; set;}
This language is not supported or no code example is available.
Remarks

if true arc is CounterClockWise, else Arc is ClockWise

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DArc Class
CAD2DArc Members


CAD2DArc.EndParam Property

Gets or sets the end angle of the CAD2DArc instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property EndParam() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double EndParam {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DArc Class
CAD2DArc Members


CAD2DArc.EndPoint Property

Gets the end point of the CAD2DArc instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EndPoint() As CAD2DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override CAD2DPoint EndPoint {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DArc Class
CAD2DArc Members


CAD2DArc.Radius Property

Gets or sets the radius of the CAD2DArc instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Radius() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Radius {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DArc Class
CAD2DArc Members


CAD2DArc.StartParam Property

Gets or sets the start angle of the CAD2DArc instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property StartParam() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double StartParam {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DArc Class
CAD2DArc Members


CAD2DArc.StartPoint Property

Gets the start point of theCAD2DArc instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property StartPoint() As CAD2DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override CAD2DPoint StartPoint {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DArc Class
CAD2DArc Members


CAD2DArc Methods

CAD2DArc Class See Also

The following tables list the members exposed by the CAD2DArc type.

Methods
 | Name | Description
Public method | Clone | Creates and returns a copy of the current CAD2DArc class instance.
Public method | Dispose | Releases all resources used by the CAD2DArc class instance.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CAD2DArc Class


CAD2DArc.Clone Method

Creates and returns a copy of the current CAD2DArc class instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function Clone() As Object
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override object Clone()
This language is not supported or no code example is available.

Return Value

A new object that is a copy of the CAD2DArc class instance.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DArc Class
CAD2DArc Members


CAD2DArc.Dispose Method

Releases all resources used by the CAD2DArc class instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DArc Class
CAD2DArc Members


CAD2DBoundaryList Class

Members See Also

Represents a collection of hatch borders.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CAD2DBoundaryList
    Inherits CADCollection(Of CAD2DCurve)
    Implements IDisposable
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CAD2DBoundaryList : CADCollection<CAD2DCurve>,
   IDisposable
This language is not supported or no code example is available.
Remarks

Each border is represented by one of the following classes: CAD2DCurve, CAD2DArc, CAD2DEllipse, CAD2DLine, CAD2DPolyline, CAD2DSpline.

Inheritance Hierarchy
System.Object
System.Collections.Generic.List<T>
CADImport.CADCollection<T>
CADImport.CAD2DBoundaryList
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DBoundaryList Members


CAD2DBoundaryList Members

CAD2DBoundaryList Class Constructors Methods Properties See Also

Represents a collection of hatch borders.

The following tables list the members exposed by the CAD2DBoundaryList type.

Constructors
 | Name | Description
Public constructor | CAD2DBoundaryList | (Overloaded) Initializes a new instance of the CAD2DBoundaryList class.
Top
Properties
 | Name | Description
Public property | BoundaryType | Gets or sets a type of the CAD2DBoundaryList boundary.
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (inherited from List<T>).
Public property | Count | Gets the number of elements actually contained in the List<T>. (inherited from List<T>).
Public property | IsNotUse | Gets a value indicating whether the CAD2DBoundaryList instance is not used.
Public property | IsTextBox | Gets a value indicating whether the hatch bypasses a box occupied by a text.
Public property | Item | Gets or sets the element at the specified index. (inherited from List<T>).
Public property | Last | Returns the index of a CADCollection<T> last member. (inherited from CADCollection<T>).
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the List<T>. (inherited from List<T>).
Public method | AddRange | Adds the elements of the specified collection to the end of the List<T>. (inherited from List<T>).
Public method | AsReadOnly | Returns a read-only IList<T> wrapper for the current collection. (inherited from List<T>).
Public method | BinarySearch | (Overloaded) Searches a range of elements in the sorted List<T> for an element using the specified comparer and returns the zero-based index of the element. (inherited from List<T>).
Public method | Clear | Removes all elements from the List<T>. (inherited from List<T>).
Public method | Clone | Creates and returns a copy of the current CAD2DBoundaryList class instance.
Public method | Contains | Determines whether an element is in the List<T>. (inherited from List<T>).
Public method | ConvertAll | Converts the elements in the current List<T> to another type, and returns a list containing the converted elements. (inherited from List<T>).
Public method | CopyTo | (Overloaded) Copies the entire List<T> to a compatible one-dimensional array, starting at the beginning of the target array. (inherited from List<T>).
Public method | Dispose | Releases all resources used by the CADCollection<T> object. (inherited from CADCollection<T>).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | Exists | Determines whether the List<T> contains elements that match the conditions defined by the specified predicate. (inherited from List<T>).
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<T>. (inherited from List<T>).
Public method | FindAll | Retrieves the all the elements that match the conditions defined by the specified predicate. (inherited from List<T>).
Public method | FindIndex | (Overloaded) Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<T>. (inherited from List<T>).
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<T>. (inherited from List<T>).
Public method | FindLastIndex | (Overloaded) Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<T>. (inherited from List<T>).
Public method | ForEach | Performs the specified action on each element of the List<T>. (inherited from List<T>).
Public method | GetEnumerator | Returns an enumerator that iterates through the List<T>. (inherited from List<T>).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<T>. (inherited from List<T>).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IndexOf | (Overloaded) Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<T>. (inherited from List<T>).
Public method | Insert | Inserts an element into the List<T> at the specified index. (inherited from List<T>).
Public method | InsertRange | Inserts the elements of a collection into the List<T> at the specified index. (inherited from List<T>).
Public method | LastIndexOf | (Overloaded) Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<T>. (inherited from List<T>).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Remove | Removes the first occurrence of a specific object from the List<T>. (inherited from List<T>).
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (inherited from List<T>).
Public method | RemoveAt | Removes the element at the specified index of the List<T>. (inherited from List<T>).
Public method | RemoveRange | Removes a range of elements from the List<T>. (inherited from List<T>).
Public method | Reverse | (Overloaded) Reverses the order of the elements in the entire List<T>. (inherited from List<T>).
Public method | Sort | (Overloaded) Sorts the elements in the entire List<T> using the default comparer. (inherited from List<T>).
Public method | ToArray | (Overloaded) Creates an array from the current CADCollection<T> object. (inherited from CADCollection<T>).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<T>, if that number is less than a threshold value. (inherited from List<T>).
Public method | TrueForAll | Determines whether every element in the List<T> matches the conditions defined by the specified predicate. (inherited from List<T>).
Top
See Also

Reference

CAD2DBoundaryList Class


CAD2DBoundaryList Constructor

CAD2DBoundaryList Class See Also

Initializes a new instance of the CAD2DBoundaryList class.

Overload List
Name | Description
CAD2DBoundaryList() | Initializes a new instance of the CAD2DBoundaryList class.
CAD2DBoundaryList(int) | Initializes a new instance of the CAD2DBoundaryList class.
See Also

Reference

CAD2DBoundaryList Class
CAD2DBoundaryList Members


CAD2DBoundaryList Properties

CAD2DBoundaryList Class See Also

The following tables list the members exposed by the CAD2DBoundaryList type.

Properties
 | Name | Description
Public property | BoundaryType | Gets or sets a type of the CAD2DBoundaryList boundary.
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (inherited from List<T>).
Public property | Count | Gets the number of elements actually contained in the List<T>. (inherited from List<T>).
Public property | IsNotUse | Gets a value indicating whether the CAD2DBoundaryList instance is not used.
Public property | IsTextBox | Gets a value indicating whether the hatch bypasses a box occupied by a text.
Public property | Item | Gets or sets the element at the specified index. (inherited from List<T>).
Public property | Last | Returns the index of a CADCollection<T> last member. (inherited from CADCollection<T>).
Top
See Also

Reference

CAD2DBoundaryList Class


CAD2DBoundaryList.BoundaryType Property

Gets or sets a type of the CAD2DBoundaryList boundary.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property BoundaryType() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int BoundaryType {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DBoundaryList Class
CAD2DBoundaryList Members


CAD2DBoundaryList.IsNotUse Property

Gets a value indicating whether the CAD2DBoundaryList instance is not used.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property IsNotUse() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsNotUse {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DBoundaryList Class
CAD2DBoundaryList Members


CAD2DBoundaryList.IsTextBox Property

Gets a value indicating whether the hatch bypasses a box occupied by a text.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property IsTextBox() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsTextBox {get;}
This language is not supported or no code example is available.

Property Value

true if the hatch bypasses a box occupied by a text; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DBoundaryList Class
CAD2DBoundaryList Members


CADCollection<T>.Last Property

Returns the index of a CADCollection<T> last member.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Last() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Last {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCollection<T> Class
CADCollection<T> Members


CAD2DBoundaryList Methods

CAD2DBoundaryList Class See Also

The following tables list the members exposed by the CAD2DBoundaryList type.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the List<T>. (inherited from List<T>).
Public method | AddRange | Adds the elements of the specified collection to the end of the List<T>. (inherited from List<T>).
Public method | AsReadOnly | Returns a read-only IList<T> wrapper for the current collection. (inherited from List<T>).
Public method | BinarySearch | (Overloaded) Searches a range of elements in the sorted List<T> for an element using the specified comparer and returns the zero-based index of the element. (inherited from List<T>).
Public method | Clear | Removes all elements from the List<T>. (inherited from List<T>).
Public method | Clone | Creates and returns a copy of the current CAD2DBoundaryList class instance.
Public method | Contains | Determines whether an element is in the List<T>. (inherited from List<T>).
Public method | ConvertAll | Converts the elements in the current List<T> to another type, and returns a list containing the converted elements. (inherited from List<T>).
Public method | CopyTo | (Overloaded) Copies the entire List<T> to a compatible one-dimensional array, starting at the beginning of the target array. (inherited from List<T>).
Public method | Dispose | Releases all resources used by the CADCollection<T> object. (inherited from CADCollection<T>).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | Exists | Determines whether the List<T> contains elements that match the conditions defined by the specified predicate. (inherited from List<T>).
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<T>. (inherited from List<T>).
Public method | FindAll | Retrieves the all the elements that match the conditions defined by the specified predicate. (inherited from List<T>).
Public method | FindIndex | (Overloaded) Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<T>. (inherited from List<T>).
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<T>. (inherited from List<T>).
Public method | FindLastIndex | (Overloaded) Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<T>. (inherited from List<T>).
Public method | ForEach | Performs the specified action on each element of the List<T>. (inherited from List<T>).
Public method | GetEnumerator | Returns an enumerator that iterates through the List<T>. (inherited from List<T>).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<T>. (inherited from List<T>).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IndexOf | (Overloaded) Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<T>. (inherited from List<T>).
Public method | Insert | Inserts an element into the List<T> at the specified index. (inherited from List<T>).
Public method | InsertRange | Inserts the elements of a collection into the List<T> at the specified index. (inherited from List<T>).
Public method | LastIndexOf | (Overloaded) Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<T>. (inherited from List<T>).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Remove | Removes the first occurrence of a specific object from the List<T>. (inherited from List<T>).
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (inherited from List<T>).
Public method | RemoveAt | Removes the element at the specified index of the List<T>. (inherited from List<T>).
Public method | RemoveRange | Removes a range of elements from the List<T>. (inherited from List<T>).
Public method | Reverse | (Overloaded) Reverses the order of the elements in the entire List<T>. (inherited from List<T>).
Public method | Sort | (Overloaded) Sorts the elements in the entire List<T> using the default comparer. (inherited from List<T>).
Public method | ToArray | (Overloaded) Creates an array from the current CADCollection<T> object. (inherited from CADCollection<T>).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<T>, if that number is less than a threshold value. (inherited from List<T>).
Public method | TrueForAll | Determines whether every element in the List<T> matches the conditions defined by the specified predicate. (inherited from List<T>).
Top
See Also

Reference

CAD2DBoundaryList Class


CAD2DBoundaryList.Clone Method

Creates and returns a copy of the current CAD2DBoundaryList class instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function Clone() As Object
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override object Clone()
This language is not supported or no code example is available.

Return Value

A new object that is a copy of the CAD2DBoundaryList class instance.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DBoundaryList Class
CAD2DBoundaryList Members


CADCollection<T>.Dispose Method

Releases all resources used by the CADCollection<T> object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Dispose() Implements  _
   IDisposable.Dispose
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Dispose()
This language is not supported or no code example is available.

Implements

IDisposable.Dispose
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCollection<T> Class
CADCollection<T> Members


CADCollection<T>.ToArray Method

CADCollection<T> Class See Also

Creates an array from the current CADCollection<T> object.

Overload List
Name | Description
ToArray | Copies the elements of the List<T> to a new array. (System.Collections.Generic.List<T>).
ToArray(int) | Creates an array from the current CADCollection<T> object.
See Also

Reference

CADCollection<T> Class
CADCollection<T> Members


CAD2DCurve Class

Members See Also

The abstract class. Represents a hatch border as a curve line.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public MustInherit Class CAD2DCurve
    Implements ICloneable, _
               IDisposable
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public abstract class CAD2DCurve : ICloneable,
   IDisposable
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CAD2DCurve
CADImport.CAD2DArc
CADImport.CAD2DLine
CADImport.CAD2DPolyline
CADImport.CAD2DSpline
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DCurve Members


CAD2DCurve Members

CAD2DCurve Class Methods Properties See Also

The abstract class. Represents a hatch border as a curve line.

The following tables list the members exposed by the CAD2DCurve type.

Properties
 | Name | Description
Public property | EndPoint | Gets or sets the end point for a CAD2DCurve inherited object.
Public property | StartPoint | Gets or sets the start point for a CAD2DCurve inherited object.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of a CAD2DCurve inherited object.
Public method | Dispose | Releases all resources used by a CAD2DCurve inherited object.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CAD2DCurve Class


CAD2DCurve Properties

CAD2DCurve Class See Also

The following tables list the members exposed by the CAD2DCurve type.

Properties
 | Name | Description
Public property | EndPoint | Gets or sets the end point for a CAD2DCurve inherited object.
Public property | StartPoint | Gets or sets the start point for a CAD2DCurve inherited object.
Top
See Also

Reference

CAD2DCurve Class


CAD2DCurve.EndPoint Property

Gets or sets the end point for a CAD2DCurve inherited object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Property EndPoint() As CAD2DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual CAD2DPoint EndPoint {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DCurve Class
CAD2DCurve Members


CAD2DCurve.StartPoint Property

Gets or sets the start point for a CAD2DCurve inherited object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Property StartPoint() As CAD2DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual CAD2DPoint StartPoint {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DCurve Class
CAD2DCurve Members


CAD2DCurve Methods

CAD2DCurve Class See Also

The following tables list the members exposed by the CAD2DCurve type.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of a CAD2DCurve inherited object.
Public method | Dispose | Releases all resources used by a CAD2DCurve inherited object.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CAD2DCurve Class


CAD2DCurve.Clone Method

Creates a new object that is a copy of a CAD2DCurve inherited object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public MustOverride Function Clone() As Object Implements  _
   ICloneable.Clone
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public abstract object Clone()
This language is not supported or no code example is available.

Implements

ICloneable.Clone
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DCurve Class
CAD2DCurve Members


CAD2DCurve.Dispose Method

Releases all resources used by a CAD2DCurve inherited object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub Dispose() Implements  _
   IDisposable.Dispose
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void Dispose()
This language is not supported or no code example is available.

Implements

IDisposable.Dispose
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DCurve Class
CAD2DCurve Members


CAD2DEllipse Class

Members See Also

Represents a hatch border as an ellipse.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CAD2DEllipse
    Inherits CAD2DArc
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CAD2DEllipse : CAD2DArc
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CAD2DCurve
CADImport.CAD2DArc
CADImport.CAD2DEllipse
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DEllipse Members


CAD2DEllipse Members

CAD2DEllipse Class Constructors Methods Properties See Also

Represents a hatch border as an ellipse.

The following tables list the members exposed by the CAD2DEllipse type.

Constructors
 | Name | Description
Public constructor | CAD2DEllipse | Initializes a new instance of the CAD2DEllipse class.
Top
Properties
 | Name | Description
Public property | CenterPoint | Gets or sets the center point of the CAD2DArc instance. (inherited from CAD2DArc).
Public property | CounterClockWise | Gets or sets arc direction. (inherited from CAD2DArc).
Public property | EndParam | Gets or sets the end angle of the CAD2DArc instance. (inherited from CAD2DArc).
Public property | EndPoint | Gets the end point of the CAD2DArc instance. (inherited from CAD2DArc).
Public property | IsAngleInParam | Gets or sets a value indicating which type of angle specifies the start and end points of this CAD2DEllipse.
Public property | MajorPoint | Gets or sets the ellipse's end point of major axis relative to its center point.
Public property | Radius | Gets or sets the radius of the CAD2DArc instance. (inherited from CAD2DArc).
Public property | StartParam | Gets or sets the start angle of the CAD2DArc instance. (inherited from CAD2DArc).
Public property | StartPoint | Gets the start point of theCAD2DArc instance. (inherited from CAD2DArc).
Top
Methods
 | Name | Description
Public method | Clone | Creates and returns a copy of the current CAD2DEllipse class instance.
Public method | Dispose | Releases all resources used by the CAD2DArc class instance. (inherited from CAD2DArc).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CAD2DEllipse Class


CAD2DEllipse Constructor

Initializes a new instance of the CAD2DEllipse class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CAD2DEllipse()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DEllipse Class
CAD2DEllipse Members


CAD2DEllipse Properties

CAD2DEllipse Class See Also

The following tables list the members exposed by the CAD2DEllipse type.

Properties
 | Name | Description
Public property | CenterPoint | Gets or sets the center point of the CAD2DArc instance. (inherited from CAD2DArc).
Public property | CounterClockWise | Gets or sets arc direction. (inherited from CAD2DArc).
Public property | EndParam | Gets or sets the end angle of the CAD2DArc instance. (inherited from CAD2DArc).
Public property | EndPoint | Gets the end point of the CAD2DArc instance. (inherited from CAD2DArc).
Public property | IsAngleInParam | Gets or sets a value indicating which type of angle specifies the start and end points of this CAD2DEllipse.
Public property | MajorPoint | Gets or sets the ellipse's end point of major axis relative to its center point.
Public property | Radius | Gets or sets the radius of the CAD2DArc instance. (inherited from CAD2DArc).
Public property | StartParam | Gets or sets the start angle of the CAD2DArc instance. (inherited from CAD2DArc).
Public property | StartPoint | Gets the start point of theCAD2DArc instance. (inherited from CAD2DArc).
Top
See Also

Reference

CAD2DEllipse Class


CAD2DEllipse.IsAngleInParam Property

Gets or sets a value indicating which type of angle specifies the start and end points of this CAD2DEllipse.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property IsAngleInParam() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsAngleInParam {get; set;}
This language is not supported or no code example is available.

Property Value

true if the start and end points are specified by the angle formed by two radiuses of the external circumference; false if the start and end points are specified by the angle formed by two radiuses of the internal circumference.
Remarks

Each ellipse is specified by two circumferences: internal and external. The internal circumference is incorporated by the ellipse and its diameter coincides with the ellipse's minor axis. The external circumference incorporates the ellipse and its diameter coincides with the ellipse's major axis.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DEllipse Class
CAD2DEllipse Members


CAD2DEllipse.MajorPoint Property

Gets or sets the ellipse's end point of major axis relative to its center point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property MajorPoint() As CAD2DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CAD2DPoint MajorPoint {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DEllipse Class
CAD2DEllipse Members


CAD2DEllipse Methods

CAD2DEllipse Class See Also

The following tables list the members exposed by the CAD2DEllipse type.

Methods
 | Name | Description
Public method | Clone | Creates and returns a copy of the current CAD2DEllipse class instance.
Public method | Dispose | Releases all resources used by the CAD2DArc class instance. (inherited from CAD2DArc).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CAD2DEllipse Class


CAD2DEllipse.Clone Method

Creates and returns a copy of the current CAD2DEllipse class instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function Clone() As Object
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override object Clone()
This language is not supported or no code example is available.

Return Value

A new object that is a copy of the CAD2DEllipse class instance.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DEllipse Class
CAD2DEllipse Members


CAD2DLine Class

Members See Also

Represents a hatch border as a straight line.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CAD2DLine
    Inherits CAD2DCurve
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CAD2DLine : CAD2DCurve
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CAD2DCurve
CADImport.CAD2DLine
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DLine Members


CAD2DLine Members

CAD2DLine Class Methods Properties See Also

Represents a hatch border as a straight line.

The following tables list the members exposed by the CAD2DLine type.

Properties
 | Name | Description
Public property | EndPoint | Gets or sets the end point of the CAD2DLine instance.
Public property | StartPoint | Gets or sets the start point of the CAD2DLine instance.
Top
Methods
 | Name | Description
Public method | Clone | Creates and returns a copy of the current CAD2DLine class instance.
Public method | Dispose | Releases all resources used by a CAD2DCurve inherited object. (inherited from CAD2DCurve).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CAD2DLine Class


CAD2DLine Properties

CAD2DLine Class See Also

The following tables list the members exposed by the CAD2DLine type.

Properties
 | Name | Description
Public property | EndPoint | Gets or sets the end point of the CAD2DLine instance.
Public property | StartPoint | Gets or sets the start point of the CAD2DLine instance.
Top
See Also

Reference

CAD2DLine Class


CAD2DLine.EndPoint Property

Gets or sets the end point of the CAD2DLine instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property EndPoint() As CAD2DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override CAD2DPoint EndPoint {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DLine Class
CAD2DLine Members


CAD2DLine.StartPoint Property

Gets or sets the start point of the CAD2DLine instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property StartPoint() As CAD2DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override CAD2DPoint StartPoint {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DLine Class
CAD2DLine Members


CAD2DLine Methods

CAD2DLine Class See Also

The following tables list the members exposed by the CAD2DLine type.

Methods
 | Name | Description
Public method | Clone | Creates and returns a copy of the current CAD2DLine class instance.
Public method | Dispose | Releases all resources used by a CAD2DCurve inherited object. (inherited from CAD2DCurve).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CAD2DLine Class


CAD2DLine.Clone Method

Creates and returns a copy of the current CAD2DLine class instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function Clone() As Object
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override object Clone()
This language is not supported or no code example is available.

Return Value

A new object that is a copy of the CAD2DLine class instance.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DLine Class
CAD2DLine Members


CAD2DPolyline Class

Members See Also

Represents a hatch border as a polyline.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CAD2DPolyline
    Inherits CAD2DCurve
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CAD2DPolyline : CAD2DCurve
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CAD2DCurve
CADImport.CAD2DPolyline
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPolyline Members


CAD2DPolyline Members

CAD2DPolyline Class Constructors Methods Properties See Also

Represents a hatch border as a polyline.

The following tables list the members exposed by the CAD2DPolyline type.

Constructors
 | Name | Description
Public constructor | CAD2DPolyline | Initializes a new instance of the CAD2DPolyline class.
Top
Properties
 | Name | Description
Public property | Bulges | Represents list of bulges of the CAD2DPolyline instance.
Public property | Closed | Gets or sets true if CAD2DPolyline curve is closed, else gets or sets false.
Public property | EndPoint | Gets or sets the end point of the CAD2DPolyline instance.
Public property | Points | Represents list of points of the CAD2DPolyline instance.
Public property | StartPoint | Gets or sets the start point of the CAD2DPolyline instance.
Public property | Vertexes | Represents list of vertexes of the CAD2DPolyline instance.
Top
Methods
 | Name | Description
Public method | AddVertex | Adds a new CAD2DPoint into points collection of the CAD2DPolyline instance.
Public method | Clone | Creates and returns a copy of the current CAD2DPolyline class instance.
Public method | Dispose | Releases all resources used by the CAD2DPolyline class instance.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CAD2DPolyline Class


CAD2DPolyline Constructor

Initializes a new instance of the CAD2DPolyline class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CAD2DPolyline()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPolyline Class
CAD2DPolyline Members


CAD2DPolyline Properties

CAD2DPolyline Class See Also

The following tables list the members exposed by the CAD2DPolyline type.

Properties
 | Name | Description
Public property | Bulges | Represents list of bulges of the CAD2DPolyline instance.
Public property | Closed | Gets or sets true if CAD2DPolyline curve is closed, else gets or sets false.
Public property | EndPoint | Gets or sets the end point of the CAD2DPolyline instance.
Public property | Points | Represents list of points of the CAD2DPolyline instance.
Public property | StartPoint | Gets or sets the start point of the CAD2DPolyline instance.
Public property | Vertexes | Represents list of vertexes of the CAD2DPolyline instance.
Top
See Also

Reference

CAD2DPolyline Class


CAD2DPolyline.Bulges Property

Represents list of bulges of the CAD2DPolyline instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Bulges() As CADCollection(Of Single)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection<float> Bulges {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPolyline Class
CAD2DPolyline Members


CAD2DPolyline.Closed Property

Gets or sets true if CAD2DPolyline curve is closed, else gets or sets false.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Closed() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Closed {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPolyline Class
CAD2DPolyline Members


CAD2DPolyline.EndPoint Property

Gets or sets the end point of the CAD2DPolyline instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property EndPoint() As CAD2DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override CAD2DPoint EndPoint {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPolyline Class
CAD2DPolyline Members


CAD2DPolyline.Points Property

Represents list of points of the CAD2DPolyline instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Points() As CADCollection(Of CAD2DPoint)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection<CAD2DPoint> Points {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPolyline Class
CAD2DPolyline Members


CAD2DPolyline.StartPoint Property

Gets or sets the start point of the CAD2DPolyline instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property StartPoint() As CAD2DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override CAD2DPoint StartPoint {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPolyline Class
CAD2DPolyline Members


CAD2DPolyline.Vertexes Property

Represents list of vertexes of the CAD2DPolyline instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Vertexes() As CADCollection(Of CAD2DPoint)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection<CAD2DPoint> Vertexes {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPolyline Class
CAD2DPolyline Members


CAD2DPolyline Methods

CAD2DPolyline Class See Also

The following tables list the members exposed by the CAD2DPolyline type.

Methods
 | Name | Description
Public method | AddVertex | Adds a new CAD2DPoint into points collection of the CAD2DPolyline instance.
Public method | Clone | Creates and returns a copy of the current CAD2DPolyline class instance.
Public method | Dispose | Releases all resources used by the CAD2DPolyline class instance.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CAD2DPolyline Class


CAD2DPolyline.AddVertex Method

Adds a new CAD2DPoint into points collection of the CAD2DPolyline instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddVertex( _
   ByVal point As CAD2DPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddVertex(
   CAD2DPoint point
)
This language is not supported or no code example is available.

Parameters

point

Type: CAD2DPoint

A 2D point to add

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPolyline Class
CAD2DPolyline Members


CAD2DPolyline.Clone Method

Creates and returns a copy of the current CAD2DPolyline class instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function Clone() As Object
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override object Clone()
This language is not supported or no code example is available.

Return Value

A new object that is a copy of the CAD2DPolyline class instance.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPolyline Class
CAD2DPolyline Members


CAD2DPolyline.Dispose Method

Releases all resources used by the CAD2DPolyline class instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPolyline Class
CAD2DPolyline Members


CAD2DSpline Class

Members See Also

Represents a hatch border as a spline curve.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CAD2DSpline
    Inherits CAD2DCurve
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CAD2DSpline : CAD2DCurve
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CAD2DCurve
CADImport.CAD2DSpline
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DSpline Members


CAD2DSpline Members

CAD2DSpline Class Constructors Methods Properties See Also

Represents a hatch border as a spline curve.

The following tables list the members exposed by the CAD2DSpline type.

Constructors
 | Name | Description
Public constructor | CAD2DSpline | Initializes a new instance of the CAD2DSpline class.
Top
Properties
 | Name | Description
Public property | Degree | Gets or sets the degree for the spline.
Public property | EndPoint | Gets or sets the end point of the CAD2DSpline instance.
Public property | Rational | Gets or sets a value defining if the spline is rational.
Public property | StartPoint | Gets or sets the start point of the CAD2DSpline instance.
Top
Methods
 | Name | Description
Public method | AddControl | Adds a 2D point to the CAD2DSpline instance.
Public method | AddKnot | Adds a Knot value to the CAD2DSpline instance.
Public method | Clone | Creates and returns a copy of the current CAD2DSpline class instance.
Public method | Dispose | Releases all resources used by the CAD2DSpline class instance.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CAD2DSpline Class


CAD2DSpline Constructor

Initializes a new instance of the CAD2DSpline class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CAD2DSpline()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DSpline Class
CAD2DSpline Members


CAD2DSpline Properties

CAD2DSpline Class See Also

The following tables list the members exposed by the CAD2DSpline type.

Properties
 | Name | Description
Public property | Degree | Gets or sets the degree for the spline.
Public property | EndPoint | Gets or sets the end point of the CAD2DSpline instance.
Public property | Rational | Gets or sets a value defining if the spline is rational.
Public property | StartPoint | Gets or sets the start point of the CAD2DSpline instance.
Top
See Also

Reference

CAD2DSpline Class


CAD2DSpline.Degree Property

Gets or sets the degree for the spline.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Degree() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Degree {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DSpline Class
CAD2DSpline Members


CAD2DSpline.EndPoint Property

Gets or sets the end point of the CAD2DSpline instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property EndPoint() As CAD2DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override CAD2DPoint EndPoint {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DSpline Class
CAD2DSpline Members


CAD2DSpline.Rational Property

Gets or sets a value defining if the spline is rational.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Rational() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Rational {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DSpline Class
CAD2DSpline Members


CAD2DSpline.StartPoint Property

Gets or sets the start point of the CAD2DSpline instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property StartPoint() As CAD2DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override CAD2DPoint StartPoint {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DSpline Class
CAD2DSpline Members


CAD2DSpline Methods

CAD2DSpline Class See Also

The following tables list the members exposed by the CAD2DSpline type.

Methods
 | Name | Description
Public method | AddControl | Adds a 2D point to the CAD2DSpline instance.
Public method | AddKnot | Adds a Knot value to the CAD2DSpline instance.
Public method | Clone | Creates and returns a copy of the current CAD2DSpline class instance.
Public method | Dispose | Releases all resources used by the CAD2DSpline class instance.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CAD2DSpline Class


CAD2DSpline.AddControl Method

Adds a 2D point to the CAD2DSpline instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddControl( _
   ByVal point As CAD2DPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddControl(
   CAD2DPoint point
)
This language is not supported or no code example is available.

Parameters

point

Type: CAD2DPoint

The CAD2DPoint for adding to the spline

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DSpline Class
CAD2DSpline Members


CAD2DSpline.AddKnot Method

Adds a Knot value to the CAD2DSpline instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddKnot( _
   ByVal val As Double _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddKnot(
   double val
)
This language is not supported or no code example is available.

Parameters

val

Type: double

The Knot value

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DSpline Class
CAD2DSpline Members


CAD2DSpline.Clone Method

Creates and returns a copy of the current CAD2DSpline class instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function Clone() As Object
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override object Clone()
This language is not supported or no code example is available.

Return Value

A new object that is a copy of the CAD2DSpline class instance.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DSpline Class
CAD2DSpline Members


CAD2DSpline.Dispose Method

Releases all resources used by the CAD2DSpline class instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DSpline Class
CAD2DSpline Members


CAD3DSolid Class

Members See Also

Represents a CAD3DSolid descendant of the CADACISEntity class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CAD3DSolid
    Inherits CADACISEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CAD3DSolid : CADACISEntity
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADGroup
CADImport.CADACISEntity
CADImport.CAD3DSolid
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD3DSolid Members


CAD3DSolid Members

CAD3DSolid Class Constructors Methods Fields Properties See Also

Represents a CAD3DSolid descendant of the CADACISEntity class.

The following tables list the members exposed by the CAD3DSolid type.

Constructors
 | Name | Description
Public constructor | CAD3DSolid | Initializes a new instance of the CADACISEntity class. (inherited from CADACISEntity).
Top
Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses this CADGroup. (inherited from CADGroup).
Public property | Color | Gets or sets a Color for this CADACISEntity object. (inherited from CADACISEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the specified CADGroup. (inherited from CADGroup).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CAD3DSolid entity.
Public property | Entities | Gets a collection of CAD entities belonging to the given CADGroup. (inherited from CADGroup).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | List | Gets a collection of entities included in the given CADGroup. (inherited from CADGroup).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity (inherited from CADACISEntity).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADACISEntity).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Iterate | Invokes the referenced (by the specified delegate) method for each CAD entity belonging to the given CADGroup. (inherited from CADGroup).
Public method | Loaded | Loads this CADACISEntity to the specified CADConverter. (inherited from CADACISEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RemoveEntityByName | Searches for an entity using its name then removes the entity. (inherited from CADGroup).
Public method | SetLType | Sets a line type for the current instance of the CADACISEntity class. (inherited from CADACISEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CAD3DSolid Class


CADACISEntity Constructor

Initializes a new instance of the CADACISEntity class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADACISEntity()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADACISEntity Class
CADACISEntity Members


CAD3DSolid Properties

CAD3DSolid Class See Also

The following tables list the members exposed by the CAD3DSolid type.

Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses this CADGroup. (inherited from CADGroup).
Public property | Color | Gets or sets a Color for this CADACISEntity object. (inherited from CADACISEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the specified CADGroup. (inherited from CADGroup).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CAD3DSolid entity.
Public property | Entities | Gets a collection of CAD entities belonging to the given CADGroup. (inherited from CADGroup).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | List | Gets a collection of entities included in the given CADGroup. (inherited from CADGroup).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
See Also

Reference

CAD3DSolid Class


CADGroup.Box Property

Gets a three-dimensional box that encloses this CADGroup.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Box() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override DRect Box {get;}
This language is not supported or no code example is available.

Property Value

A DRect object representing the enclosing box for this CADGroup.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGroup Class
CADGroup Members


CADACISEntity.Color Property

Gets or sets a Color for this CADACISEntity object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Color() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override Color Color {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADACISEntity Class
CADACISEntity Members


CADObjectEntity.Converter Property

Gets or sets a CADConverter associated with this CADObjectEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Converter() As CADConverter
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADConverter Converter {get; set;}
This language is not supported or no code example is available.

Property Value

An object of the CADConverter class.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADObjectEntity Class
CADObjectEntity Members


CADGroup.Count Property

Gets a number of entities contained in the specified CADGroup.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Count() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override int Count {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGroup Class
CADGroup Members


CADEntity.EntName Property

Gets a name of the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overridable Property EntName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual string EntName {get;}
This language is not supported or no code example is available.

Property Value

A string containing a name of the CADEntity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntity Class
CADEntity Members


CAD3DSolid.EntType Property

Gets the type of this CAD3DSolid entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD3DSolid Class
CAD3DSolid Members


CADGroup.Entities Property

Gets a collection of CAD entities belonging to the given CADGroup.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Entities() As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override CADEntityCollection Entities {get;}
This language is not supported or no code example is available.

Property Value

A CADEntityCollection containing CAD entities belonging to the given CADGroup.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGroup Class
CADGroup Members


CADEntity.ExtendedData Property

Provides access to entity extended data

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property ExtendedData() As XtomesList
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public XtomesList ExtendedData {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntity Class
CADEntity Members


CADEntity.Handle Property

Gets a CADEntity handle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Property Handle() As UInt64
    Get

This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual UInt64 Handle {get;}
This language is not supported or no code example is available.

Property Value

A number that uniquely identifies a CADEntity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntity Class
CADEntity Members


CADPlotEntity.Layer Property

Gets or sets a layer this CADPlotEntity belongs to.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Layer() As CADLayer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override CADLayer Layer {get; set;}
This language is not supported or no code example is available.

Property Value

A CADlayer this CADPlotEntity belongs to.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPlotEntity Class
CADPlotEntity Members


CADEntity.LineType Property

Gets or sets a linetype of the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Property LineType() As CADLineType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual CADLineType LineType {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntity Class
CADEntity Members


CADPlotEntity.LineTypeScale Property

Gets or sets a value equal to a quantity of linetype elements per unit of its length.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property LineTypeScale() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override float LineTypeScale {get; set;}
This language is not supported or no code example is available.

Property Value

A float value indicating a quantity of linetype elements per unit of its length.
Remarks

The examples of linetype elements are dots and dashes.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPlotEntity Class
CADPlotEntity Members


CADEntity.LineWeight Property

Gets or sets a thickness of lines for this CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Property LineWeight() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual double LineWeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntity Class
CADEntity Members


CADGroup.List Property

Gets a collection of entities included in the given CADGroup.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property List() As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntityCollection List {get;}
This language is not supported or no code example is available.

Property Value

A CADEntityCollection object representing a collection of entities included in this CADGroup.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGroup Class
CADGroup Members


CADEntity.Selected Property

Gets or sets a value indicating whether the CADEntity is selected.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Property Selected() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual bool Selected {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntity Class
CADEntity Members


CADPlotEntity.Visibility Property

Gets or sets a value indicating whether a CADPlotEntity is visible.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Visibility() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool Visibility {get; set;}
This language is not supported or no code example is available.

Property Value

true if a CADPlotEntity is visible; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPlotEntity Class
CADPlotEntity Members


CADPlotEntity.Visible Property

Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Property Visible() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual bool Visible {get; set;}
This language is not supported or no code example is available.

Property Value

true if a CADPlotEntity is visible; otherwise, false.
Remarks

If a layer is frozen the CAD entities it contains will be invisible, even if visible propertiy is true.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPlotEntity Class
CADPlotEntity Members


CAD3DSolid Methods

CAD3DSolid Class See Also

The following tables list the members exposed by the CAD3DSolid type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity (inherited from CADACISEntity).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADACISEntity).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Iterate | Invokes the referenced (by the specified delegate) method for each CAD entity belonging to the given CADGroup. (inherited from CADGroup).
Public method | Loaded | Loads this CADACISEntity to the specified CADConverter. (inherited from CADACISEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RemoveEntityByName | Searches for an entity using its name then removes the entity. (inherited from CADGroup).
Public method | SetLType | Sets a line type for the current instance of the CADACISEntity class. (inherited from CADACISEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CAD3DSolid Class


CADEntity.AddEntity Method

Virtual method. Redefined in descendant classes.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Function AddEntity( _
   ByVal E As CADEntity _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual bool AddEntity(
   CADEntity E
)
This language is not supported or no code example is available.

Parameters

E

Type: CADEntity

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntity Class
CADEntity Members


CADACISEntity.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADACISEntity Class
CADACISEntity Members


CADEntity.ChangeEntity Method

Edits current entity by specified offset

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function ChangeEntity( _
   ByVal dx As Double, _
   ByVal dy As Double, _
   ByVal dz As Double, _
   ByVal conv As CADConverter _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool ChangeEntity(
   double dx,
   double dy,
   double dz,
   CADConverter conv
)
This language is not supported or no code example is available.

Parameters

dx

Type: double

X axis offset

dy

Type: double

Y axis offset

dz

Type: double

Z axis offset

conv

Type: CADConverter

CADConverter object for loading of entity parameters

Return Value

Returns true if the object was edited
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntity Class
CADEntity Members


CADEntity.Clone Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Clone( _
   ByVal ent As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Clone(
   CADEntity ent
)
This language is not supported or no code example is available.

Parameters

ent

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntity Class
CADEntity Members


CADACISEntity.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADACISEntity Class
CADACISEntity Members


CADEntity.DrawEntityTrace Method

Implements drawing of entity with specified offset to specified Control

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub DrawEntityTrace( _
   ByVal dx As Integer, _
   ByVal dy As Integer, _
   ByVal img As CADImage, _
   ByVal control As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void DrawEntityTrace(
   int dx,
   int dy,
   CADImage img,
   Control control
)
This language is not supported or no code example is available.

Parameters

dx

Type: int

X axis offset

dy

Type: int

Y axis offset

img

Type: CADImage

CADImage object for getting display coordinates of the entity

control

Type: Control

Control for drawing of CADEntity

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntity Class
CADEntity Members


CADEntity.GetBoxPoints Method

Checks if the CADEntity must be drawn during a drawing cycle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Function GetBoxPoints( _
   ByVal Proc As FPointProc, _
   ByVal Full As Boolean _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual bool GetBoxPoints(
   FPointProc Proc,
   bool Full
)
This language is not supported or no code example is available.

Parameters

Proc

Type: FPointProc

A FPointProc delegate that references methods for getting CADEntity's points.

Full

Type: bool

A boolean value indicating whether the method realizes full or reduced checking. true if checking is full, false if checking is reduced.

Return Value

true if all points passed to the referenced method are real entity's points; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntity Class
CADEntity Members


CADGroup.Iterate Method

Invokes the referenced (by the specified delegate) method for each CAD entity belonging to the given CADGroup.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub Iterate( _
   ByVal AConverter As CADConverter, _
   ByVal convProc As CADEntityProc, _
   ByVal finishProc As CADEntityProc _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void Iterate(
   CADConverter AConverter,
   CADEntityProc convProc,
   CADEntityProc finishProc
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter that has loaded the CADGroup.

convProc

Type: CADEntityProc

A CADEntityProc delegate that specifies a method to be invoked.

finishProc

Type: CADEntityProc

A CADEntityProc delegate that specifies a method to be finished.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGroup Class
CADGroup Members


CADACISEntity.Loaded Method

Loads this CADACISEntity to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADACISEntity is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADACISEntity Class
CADACISEntity Members


CADEntity.OnDraw Method

Raises a DrawEvent.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub OnDraw( _
   ByVal Sender As Object _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void OnDraw(
   object Sender
)
This language is not supported or no code example is available.

Parameters

Sender

Type: object

A CAD entity that initiates a DrawEvent.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntity Class
CADEntity Members


CADGroup.RemoveEntityByName Method

Searches for an entity using its name then removes the entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub RemoveEntityByName( _
   ByVal AName As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void RemoveEntityByName(
   string AName
)
This language is not supported or no code example is available.

Parameters

AName

Type: string

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGroup Class
CADGroup Members


CADACISEntity.SetLType Method

Sets a line type for the current instance of the CADACISEntity class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub SetLType( _
   ByVal Value As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void SetLType(
   CADEntity Value
)
This language is not supported or no code example is available.

Parameters

Value

Type: CADEntity

A line type to be set for this CADACISEntity object.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADACISEntity Class
CADACISEntity Members


CAD3DSolid Fields

CAD3DSolid Class See Also

The following tables list the members exposed by the CAD3DSolid type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CAD3DSolid Class


DrawEvent Field

Occurs when the CADEntity is drawn in the CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public DrawEvent As EventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public EventHandler DrawEvent
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntity Class
CADEntity Members


CAD3dFace Class

Members See Also

Represents a three-dimensional three- or four-sided surface in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CAD3dFace
    Inherits CADSolid
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CAD3dFace : CADSolid
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.CADPenLine
CADImport.CADLine
CADImport.CADSolid
CADImport.CAD3dFace
CADImport.CAD3D.CAD3DFacet
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD3dFace Members


CAD3dFace Members

CAD3dFace Class Constructors Methods Fields Properties See Also

Represents a three-dimensional three- or four-sided surface in a CAD image.

The following tables list the members exposed by the CAD3dFace type.

Constructors
 | Name | Description
Public constructor | CAD3dFace | Initializes a new instance of the CADLine class. (inherited from CADLine).
Top
Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses the CADSolid entity. (inherited from CADSolid).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | DottedSingPts | Gets a collection of points that specify the dots and dashes of the CADLine. (inherited from CADLine).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CAD3DSolid entity
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Flags | Gets or sets an integer value that provides flags for the CAD3DFace object.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADPenLine).
Public property | Point1 | Gets or sets a second end of the CADLine. (inherited from CADLine).
Public property | Point2 | Gets or sets a third point of the CADSolid object. (inherited from CADSolid).
Public property | Point3 | Gets or sets a fourth point of the CADSolid object. (inherited from CADSolid).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADLine).
Public method | DrawEntityTrace | Implements drawing of an entity with specified offset to specified Control (inherited from CADSolid).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADSolid object must be drawn during a drawing cycle. (inherited from CADSolid).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADSolid object to the specified CADConverter. (inherited from CADSolid).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CAD3dFace Class


CADLine Constructor

Example See Also

Initializes a new instance of the CADLine class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADLine()
This language is not supported or no code example is available.
Example
<p>Creating a new CADLine object example:</p> <p>[C#]</p>
Copy

     CreateNewImage();
     CADLine ln1 = new CADLine();
     ln1.Color = CADConst.clNone;
     ln1.Point = GetRealPoint(100, 100);
     ln1.Point1 = GetRealPoint(300, 300);
     ln1.LineWeight = 0.1;
     ln1.Loaded(cadImage.Converter);
     ln1.Handle = ln1.GetHashCode();
     ln1.KeyEnt = ln1.Handle.ToString();
     cadImage.CurrentLayout.Entities.Add(ln1);
     cadImage.Converter.OnCreate(ln1);
     EditorCADPictureBox.Invalidate();
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLine Class
CADLine Members
CADImport Namespace
CADImage
CADLine
DPoint
clNone


CAD3dFace Properties

CAD3dFace Class See Also

The following tables list the members exposed by the CAD3dFace type.

Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses the CADSolid entity. (inherited from CADSolid).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | DottedSingPts | Gets a collection of points that specify the dots and dashes of the CADLine. (inherited from CADLine).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CAD3DSolid entity
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Flags | Gets or sets an integer value that provides flags for the CAD3DFace object.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADPenLine).
Public property | Point1 | Gets or sets a second end of the CADLine. (inherited from CADLine).
Public property | Point2 | Gets or sets a third point of the CADSolid object. (inherited from CADSolid).
Public property | Point3 | Gets or sets a fourth point of the CADSolid object. (inherited from CADSolid).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
See Also

Reference

CAD3dFace Class


CADSolid.Box Property

Gets a three-dimensional box that encloses the CADSolid entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Box() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override DRect Box {get;}
This language is not supported or no code example is available.

Property Value

A DRect object representing the enclosing box for the CADSolid object.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSolid Class
CADSolid Members


CADPenEntity.Color Property

Gets or sets a color of the pen for this CADPenEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Color() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override Color Color {get; set;}
This language is not supported or no code example is available.

Property Value

A Color for the Pen used for drawing this CADPenEntity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPenEntity Class
CADPenEntity Members


CADEntity.Count Property

Gets a number of entities contained in the given CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overridable Property Count() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual int Count {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntity Class
CADEntity Members


CADPenEntity.DashStyle Property

Gets or sets DashStyle for CADPenEntity object

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DashStyle() As DashStyle
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DashStyle DashStyle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPenEntity Class
CADPenEntity Members


CADLine.DottedSingPts Property

Gets a collection of points that specify the dots and dashes of the CADLine.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property DottedSingPts() As CADCollection(Of DPoint)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection<DPoint> DottedSingPts {get;}
This language is not supported or no code example is available.
Remarks

Each dot or each dash in the line is specified by two DPoints.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLine Class
CADLine Members


CAD3dFace.EntType Property

Gets the type of this CAD3DSolid entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD3dFace Class
CAD3dFace Members


CADEntity.Entities Property

Gets a collection of all entities owned by this CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overridable Property Entities() As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual CADEntityCollection Entities {get;}
This language is not supported or no code example is available.

Property Value

A CADEntityCollection of entities belonging to this CADEntity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntity Class
CADEntity Members


CADPenLine.Extrusion Property

Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Extrusion() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Extrusion {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object specifying a direction of axis Z belonging to the coordinate system of this CADPenLine object.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPenLine Class
CADPenLine Members


CAD3dFace.Flags Property

Gets or sets an integer value that provides flags for the CAD3DFace object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Flags() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Flags {get; set;}
This language is not supported or no code example is available.
Remarks

bit-coded values (default = 0):

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD3dFace Class
CAD3dFace Members


CADPenLine.LineType Property

Gets or sets line type for this CADPenLine object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property LineType() As CADLineType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override CADLineType LineType {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPenLine Class
CADPenLine Members


CADPenLine.LineTypeName Property

Gets a name of line type for this CADPenLine object

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property LineTypeName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string LineTypeName {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPenLine Class
CADPenLine Members


CADPenLine.LineWeight Property

Gets or sets a thickness of lines for this CADPenLine object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property LineWeight() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override double LineWeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPenLine Class
CADPenLine Members


CADPenLine.Lines Property

Gets or sets a type of the line for the CADPenLine entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Lines() As SGLines
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SGLines Lines {get;}
This language is not supported or no code example is available.

Property Value

An object of the SGLines class that specifies a type of the line.
Remarks

Obsolete. We recommend to use LineType property

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPenLine Class
CADPenLine Members


CADPenLine.Point Property

Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Property Point() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual DPoint Point {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object representing a point that specifies a position of the CADPenLine entity in the CAD drawing.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPenLine Class
CADPenLine Members


CADLine.Point1 Property

Gets or sets a second end of the CADLine.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Point1() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Point1 {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object that specifies a second end of the line.
Remarks

A first end of the line is specified by the Point property.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLine Class
CADLine Members


CADSolid.Point2 Property

Gets or sets a third point of the CADSolid object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Point2() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Point2 {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object that specifies a third point of the CADSolid entity.
Remarks

The first point of the CADSolid object is specified by the Point property. The second point is specified by the Point1 property.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSolid Class
CADSolid Members


CADSolid.Point3 Property

Gets or sets a fourth point of the CADSolid object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Point3() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Point3 {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object that specifies a fourth point of the CADSolid entity.
Remarks

A first point of the CADSolid object is specified by the Point property. The second point is specified by the Point1 property. The third point is specified by the Point2 property.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSolid Class
CADSolid Members


CADPenEntity.Width Property

Gets or sets a line width of CADPenEntity object

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Width() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float Width {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPenEntity Class
CADPenEntity Members


CADPenLine.ZThick Property

Gets or sets a line thickness measured along the axis Z for this CADPenLine entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ZThick() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float ZThick {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPenLine Class
CADPenLine Members


CAD3dFace Methods

CAD3dFace Class See Also

The following tables list the members exposed by the CAD3dFace type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADLine).
Public method | DrawEntityTrace | Implements drawing of an entity with specified offset to specified Control (inherited from CADSolid).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADSolid object must be drawn during a drawing cycle. (inherited from CADSolid).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADSolid object to the specified CADConverter. (inherited from CADSolid).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CAD3dFace Class


CADPenLine.AddThick Method

Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddThick( _
   ByRef R As DRect _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddThick(
   ref DRect R
)
This language is not supported or no code example is available.

Parameters

R

Type: DRect

A rectangle that encloses the CADPenLine entity.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPenLine Class
CADPenLine Members


CAD3dFace.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD3dFace Class
CAD3dFace Members


CADLine.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLine Class
CADLine Members


CADSolid.DrawEntityTrace Method

Implements drawing of an entity with specified offset to specified Control

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub DrawEntityTrace( _
   ByVal dx As Integer, _
   ByVal dy As Integer, _
   ByVal img As CADImage, _
   ByVal control As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void DrawEntityTrace(
   int dx,
   int dy,
   CADImage img,
   Control control
)
This language is not supported or no code example is available.

Parameters

dx

Type: int

X axis offset

dy

Type: int

Y axis offset

img

Type: CADImage

CADImage object for getting display coordinates of the entity

control

Type: Control

Control for drawing of CADEntity

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSolid Class
CADSolid Members


CADSolid.GetBoxPoints Method

Checks if the CADSolid object must be drawn during a drawing cycle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function GetBoxPoints( _
   ByVal Proc As FPointProc, _
   ByVal Full As Boolean _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool GetBoxPoints(
   FPointProc Proc,
   bool Full
)
This language is not supported or no code example is available.

Parameters

Proc

Type: FPointProc

A FPointProc delegate that references a method for getting CADSolid object's points.

Full

Type: bool

A boolean value indicating whether the method realizes full or reduced checking. true if checking is full, false if checking is reduced.

Return Value

true if all points passed to the referenced method are real entity's points; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSolid Class
CADSolid Members


CADSolid.Loaded Method

Loads this CADSolid object to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADSolid object is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSolid Class
CADSolid Members


CADPenLine.SetLType Method

Sets a linetype for the CADPenLine entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub SetLType( _
   ByVal Value As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void SetLType(
   CADEntity Value
)
This language is not supported or no code example is available.

Parameters

Value

Type: CADEntity

A CADEntity object representing a linetype.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPenLine Class
CADPenLine Members


CAD3dFace Fields

CAD3dFace Class See Also

The following tables list the members exposed by the CAD3dFace type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CAD3dFace Class


CADACISEntity Class

Members See Also

Represents entities of incorporate graphics received by 3D modelling engine developed by Spatial company.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADACISEntity
    Inherits CADGroup
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADACISEntity : CADGroup
This language is not supported or no code example is available.
Remarks

The CADACISEntity class is a base class for CAD3DSolid, CADBody, CADRegion classes.

Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADGroup
CADImport.CADACISEntity
CADImport.CAD3DSolid
CADImport.CADBody
CADImport.CADRegion
CADImport.CADSurface
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADACISEntity Members


CADACISEntity Members

CADACISEntity Class Constructors Methods Fields Properties See Also

Represents entities of incorporate graphics received by 3D modelling engine developed by Spatial company.

The following tables list the members exposed by the CADACISEntity type.

Constructors
 | Name | Description
Public constructor | CADACISEntity | Initializes a new instance of the CADACISEntity class.
Top
Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses this CADGroup. (inherited from CADGroup).
Public property | Color | Gets or sets a Color for this CADACISEntity object.
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the specified CADGroup. (inherited from CADGroup).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of CAD entities belonging to the given CADGroup. (inherited from CADGroup).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | List | Gets a collection of entities included in the given CADGroup. (inherited from CADGroup).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Iterate | Invokes the referenced (by the specified delegate) method for each CAD entity belonging to the given CADGroup. (inherited from CADGroup).
Public method | Loaded | Loads this CADACISEntity to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RemoveEntityByName | Searches for an entity using its name then removes the entity. (inherited from CADGroup).
Public method | SetLType | Sets a line type for the current instance of the CADACISEntity class.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADACISEntity Class


CADACISEntity Properties

CADACISEntity Class See Also

The following tables list the members exposed by the CADACISEntity type.

Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses this CADGroup. (inherited from CADGroup).
Public property | Color | Gets or sets a Color for this CADACISEntity object.
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the specified CADGroup. (inherited from CADGroup).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of CAD entities belonging to the given CADGroup. (inherited from CADGroup).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | List | Gets a collection of entities included in the given CADGroup. (inherited from CADGroup).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
See Also

Reference

CADACISEntity Class


CADEntity.EntType Property

The entity type defined by the EntityType enumeration.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overridable Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual EntityType EntType {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntity Class
CADEntity Members


CADACISEntity Methods

CADACISEntity Class See Also

The following tables list the members exposed by the CADACISEntity type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Iterate | Invokes the referenced (by the specified delegate) method for each CAD entity belonging to the given CADGroup. (inherited from CADGroup).
Public method | Loaded | Loads this CADACISEntity to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RemoveEntityByName | Searches for an entity using its name then removes the entity. (inherited from CADGroup).
Public method | SetLType | Sets a line type for the current instance of the CADACISEntity class.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADACISEntity Class


CADACISEntity Fields

CADACISEntity Class See Also

The following tables list the members exposed by the CADACISEntity type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADACISEntity Class


CADAcadTable Class

Members See Also

Corresponds AcadTable object

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADAcadTable
    Inherits CADInsert
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADAcadTable : CADInsert
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADCustomVertex
CADImport.CADInsert
CADImport.CADAcadTable
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADAcadTable Members


CADAcadTable Members

CADAcadTable Class Constructors Methods Fields Properties See Also

Corresponds AcadTable object

The following tables list the members exposed by the CADAcadTable type.

Constructors
 | Name | Description
Public constructor | CADAcadTable | Initializes a new instance of the CADInsert class. (inherited from CADInsert).
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets an angle between a referenced block and CAD drawing. (inherited from CADInsert).
Public property | Attribs | Gets a collection of an attribs. (inherited from CADInsert).
Public property | Block | Gets or sets a block referenced by this CADInsert object. (inherited from CADInsert).
Public property | Box | Gets a three-dimensional box that encloses the CADInsert object. (inherited from CADInsert).
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of attribs belonging to the given CADInsert. (inherited from CADInsert).
Public property | EntName | Gets a name of the CADInsert object. (inherited from CADInsert).
Public property | EntType | Gets the type of this CADAcadTable entity
Public property | Entities | Gets a collection of attribs associated with the given CADInsert object. (inherited from CADInsert).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADInsert object. (inherited from CADInsert).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADInsert).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADInsert. (inherited from CADInsert).
Public property | Point | Gets or sets a position of the CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Scale | Gets or sets a scale for drawning of the referenced block in a CAD image. (inherited from CADInsert).
Public property | Selected | Get or sets CADInsert selected. (inherited from CADInsert).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADInsert object. (inherited from CADInsert).
Public method | AssignEntity | Copies an entity (inherited from CADInsert).
Public method | Attrib | Returns an attribute contained in the given CADInsert object. (inherited from CADInsert).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADInsert).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADAcadTable to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADInsert entity. (inherited from CADInsert).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADAcadTable Class


CADInsert Constructor

Initializes a new instance of the CADInsert class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADInsert()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADInsert Class
CADInsert Members


CADAcadTable Properties

CADAcadTable Class See Also

The following tables list the members exposed by the CADAcadTable type.

Properties
 | Name | Description
Public property | Angle | Gets or sets an angle between a referenced block and CAD drawing. (inherited from CADInsert).
Public property | Attribs | Gets a collection of an attribs. (inherited from CADInsert).
Public property | Block | Gets or sets a block referenced by this CADInsert object. (inherited from CADInsert).
Public property | Box | Gets a three-dimensional box that encloses the CADInsert object. (inherited from CADInsert).
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of attribs belonging to the given CADInsert. (inherited from CADInsert).
Public property | EntName | Gets a name of the CADInsert object. (inherited from CADInsert).
Public property | EntType | Gets the type of this CADAcadTable entity
Public property | Entities | Gets a collection of attribs associated with the given CADInsert object. (inherited from CADInsert).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADInsert object. (inherited from CADInsert).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADInsert).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADInsert. (inherited from CADInsert).
Public property | Point | Gets or sets a position of the CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Scale | Gets or sets a scale for drawning of the referenced block in a CAD image. (inherited from CADInsert).
Public property | Selected | Get or sets CADInsert selected. (inherited from CADInsert).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
See Also

Reference

CADAcadTable Class


CADInsert.Angle Property

Gets or sets an angle between a referenced block and CAD drawing.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Angle() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float Angle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADInsert Class
CADInsert Members


CADInsert.Attribs Property

Gets a collection of an attribs.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Attribs() As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntityCollection Attribs {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADInsert Class
CADInsert Members


CADInsert.Block Property

Gets or sets a block referenced by this CADInsert object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Block() As CADBlock
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADBlock Block {get; set;}
This language is not supported or no code example is available.

Property Value

A CADBlock referenced by this CADInsert object.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADInsert Class
CADInsert Members


CADInsert.Box Property

Gets a three-dimensional box that encloses the CADInsert object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Box() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override DRect Box {get;}
This language is not supported or no code example is available.

Property Value

A DRect object representing the enclosing box for the CADInsert entity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADInsert Class
CADInsert Members


CADCustomVertex.Color Property

Gets or sets a color for the this CADCustomVertex object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Color() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override Color Color {get; set;}
This language is not supported or no code example is available.

Property Value

A Color of the entity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCustomVertex Class
CADCustomVertex Members


CADInsert.Count Property

Gets a number of attribs belonging to the given CADInsert.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Count() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override int Count {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADInsert Class
CADInsert Members


CADInsert.EntName Property

Gets a name of the CADInsert object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override string EntName {get;}
This language is not supported or no code example is available.

Property Value

A string containing a name of the CADInsert object.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADInsert Class
CADInsert Members


CADAcadTable.EntType Property

Gets the type of this CADAcadTable entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADAcadTable Class
CADAcadTable Members


CADInsert.Entities Property

Gets a collection of attribs associated with the given CADInsert object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Entities() As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override CADEntityCollection Entities {get;}
This language is not supported or no code example is available.

Property Value

A CADEntityCollection of attribs associated with the block insert.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADInsert Class
CADInsert Members


CADInsert.Extrusion Property

Gets or sets a direction of axis Z belonging to the coordinate system of this CADInsert object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Extrusion() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Extrusion {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object specifying a direction of axis Z belonging to the coordinate system of this CADInsert object.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADInsert Class
CADInsert Members


CADInsert.LineType Property

Gets or sets line type for this CADPenLine object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property LineType() As CADLineType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override CADLineType LineType {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADInsert Class
CADInsert Members


CADInsert.LineWeight Property

Gets or sets a thickness of lines for this CADInsert.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property LineWeight() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override double LineWeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADInsert Class
CADInsert Members


CADCustomVertex.Point Property

Gets or sets a position of the CADCustomVertex object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Property Point() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual DPoint Point {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object that specifies a position of the CADCustomVertex entity in three-dimensional space.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCustomVertex Class
CADCustomVertex Members


CADInsert.Scale Property

Gets or sets a scale for drawning of the referenced block in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Scale() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Scale {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object that specifies a scale in which a referenced block will be drawn in a CAD image.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADInsert Class
CADInsert Members


CADInsert.Selected Property

Get or sets CADInsert selected.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Selected() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool Selected {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADInsert Class
CADInsert Members


CADAcadTable Methods

CADAcadTable Class See Also

The following tables list the members exposed by the CADAcadTable type.

Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADInsert object. (inherited from CADInsert).
Public method | AssignEntity | Copies an entity (inherited from CADInsert).
Public method | Attrib | Returns an attribute contained in the given CADInsert object. (inherited from CADInsert).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADInsert).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADAcadTable to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADInsert entity. (inherited from CADInsert).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADAcadTable Class


CADInsert.AddEntity Method

Adds the specified entity to this CADInsert object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function AddEntity( _
   ByVal E As CADEntity _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool AddEntity(
   CADEntity E
)
This language is not supported or no code example is available.

Parameters

E

Type: CADEntity

A CADEntity to add.

Return Value

true if a CADEntity was added; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADInsert Class
CADInsert Members


CADInsert.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADInsert Class
CADInsert Members


CADInsert.Attrib Method

Returns an attribute contained in the given CADInsert object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Attrib( _
   ByVal S As String, _
   ByRef P As DPoint _
) As CADAttrib
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADAttrib Attrib(
   string S,
   ref DPoint P
)
This language is not supported or no code example is available.

Parameters

S

Type: string

A string containing a name of the attribute to return.

P

Type: DPoint

A DPoint object representing a location of the attribute.

Return Value

A CADAttrib object or null if this CADInsert doesn't contain an attribute with the specified name.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADInsert Class
CADInsert Members


CADInsert.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADInsert Class
CADInsert Members


CADAcadTable.Loaded Method

Loads this CADAcadTable to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADAcadTable is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADAcadTable Class
CADAcadTable Members


CADInsert.SetLType Method

Sets a linetype for the CADInsert entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub SetLType( _
   ByVal Value As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void SetLType(
   CADEntity Value
)
This language is not supported or no code example is available.

Parameters

Value

Type: CADEntity

A CADEntity object representing a linetype.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADInsert Class
CADInsert Members


CADAcadTable Fields

CADAcadTable Class See Also

The following tables list the members exposed by the CADAcadTable type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADAcadTable Class


CADArc Class

Members See Also

Represents an arc in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADArc
    Inherits CADCircle
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADArc : CADCircle
This language is not supported or no code example is available.
Remarks

An arc in a CAD image can be specified by the central Point, Radius or by the central Point, Radius, StartAngle, EndAngle.

Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.CADPenLine
CADImport.CADPolylineBase
CADImport.CADCircle
CADImport.CADArc
CADImport.CADEllipse
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADArc Members


CADArc Members

CADArc Class Constructors Methods Fields Properties See Also

Represents an arc in a CAD image.

The following tables list the members exposed by the CADArc type.

Constructors
 | Name | Description
Public constructor | CADArc | Initializes a new instance of the CADArc object.
Top
Properties
 | Name | Description
Public property | Box | Return box of the current primitive. (inherited from CADPolylineBase).
Public property | Closed | Gets or sets a value indicating whether this CADPolyLine is closed. (inherited from CADPolylineBase).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADPolylineBase. (inherited from CADPolylineBase).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | DottedSingPoints | Gets a collection of points that specify the dots and dashes of the CADPolylineBase. (inherited from CADPolylineBase).
Public property | EndAngle | Gets or sets an angle between axis X and the line connecting the end point with the central Point.
Public property | EndPoint | Gets end point of CADArc object
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADArc entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Flags | Gets or sets a number that specifies an appearance of this CADPolylineBase entity. (inherited from CADPolylineBase).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | IsMeshMClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the M direction. (inherited from CADPolylineBase).
Public property | IsMeshNClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the N direction. (inherited from CADPolylineBase).
Public property | IsPolyFaceMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | IsPolyZThickness | Gets a value indicating whether a line thickness measured along the axis Z is equal to 0. (inherited from CADPolylineBase).
Public property | IsPolygonMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADCircle).
Public property | PolyPoints | Gets a collection of points belonging to the polyline. (inherited from CADPolylineBase).
Public property | Radius | Gets or sets a radius for the CADCircle. (inherited from CADCircle).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | StartAngle | Gets or sets an angle between axis X and the line connecting the start point with the central Point.
Public property | StartPoint | Gets start point of CADArc object
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | ApplyBox | Calculates a box of the current entity. (inherited from CADPolylineBase).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
 | CreateArcFromVertexes | Creates a new instance of the CADArc class using two instances of the CADVertex class.
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADPolylineBase).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADCircle).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Used in drawing cycle for fast checking whether the entity must be drawn (inherited from CADPolylineBase).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADArc to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADArc Class


CADArc Constructor

Example See Also

Initializes a new instance of the CADArc object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADArc()
This language is not supported or no code example is available.
Example
<p>Creating a new CADArc object example:</p> <p>[C#]</p>
Copy

     CreateNewImage();
     CADArc arc = new CADArc();
     arc.Color = CADConst.clNone;
     arc.Point = GetRealPoint(300, 300);
     arc.Radius = 10;
     arc.StartAngle = 0;
     arc.EndAngle = 180;
     arc.LineWeight = 0.1;
     arc.Loaded(cadImage.Converter);
     arc.Handle = arc.GetHashCode();
     arc.KeyEnt = arc.Handle.ToString();
     cadImage.CurrentLayout.Entities.Add(arc);
     cadImage.Converter.OnCreate(arc);
     EditorCADPictureBox.Invalidate();
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADArc Class
CADArc Members
CADImport Namespace
CADArc
CADImage
DPoint
clNone


CADArc Properties

CADArc Class See Also

The following tables list the members exposed by the CADArc type.

Properties
 | Name | Description
Public property | Box | Return box of the current primitive. (inherited from CADPolylineBase).
Public property | Closed | Gets or sets a value indicating whether this CADPolyLine is closed. (inherited from CADPolylineBase).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADPolylineBase. (inherited from CADPolylineBase).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | DottedSingPoints | Gets a collection of points that specify the dots and dashes of the CADPolylineBase. (inherited from CADPolylineBase).
Public property | EndAngle | Gets or sets an angle between axis X and the line connecting the end point with the central Point.
Public property | EndPoint | Gets end point of CADArc object
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADArc entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Flags | Gets or sets a number that specifies an appearance of this CADPolylineBase entity. (inherited from CADPolylineBase).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | IsMeshMClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the M direction. (inherited from CADPolylineBase).
Public property | IsMeshNClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the N direction. (inherited from CADPolylineBase).
Public property | IsPolyFaceMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | IsPolyZThickness | Gets a value indicating whether a line thickness measured along the axis Z is equal to 0. (inherited from CADPolylineBase).
Public property | IsPolygonMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADCircle).
Public property | PolyPoints | Gets a collection of points belonging to the polyline. (inherited from CADPolylineBase).
Public property | Radius | Gets or sets a radius for the CADCircle. (inherited from CADCircle).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | StartAngle | Gets or sets an angle between axis X and the line connecting the start point with the central Point.
Public property | StartPoint | Gets start point of CADArc object
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
See Also

Reference

CADArc Class


CADPolylineBase.Box Property

Return box of the current primitive.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Box() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override DRect Box {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolylineBase Class
CADPolylineBase Members


CADPolylineBase.Closed Property

Gets or sets a value indicating whether this CADPolyLine is closed.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Closed() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Closed {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolylineBase Class
CADPolylineBase Members


CADPolylineBase.Count Property

Gets a number of entities contained in the given CADPolylineBase.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Count() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override int Count {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolylineBase Class
CADPolylineBase Members


CADPolylineBase.DottedSingPoints Property

Gets a collection of points that specify the dots and dashes of the CADPolylineBase.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DottedSingPoints() As CADCollection(Of DPoint)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection<DPoint> DottedSingPoints {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolylineBase Class
CADPolylineBase Members


CADArc.EndAngle Property

Gets or sets an angle between axis X and the line connecting the end point with the central Point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property EndAngle() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double EndAngle {get; set;}
This language is not supported or no code example is available.
Remarks

The angle is formed counterclockwise.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADArc Class
CADArc Members


CADArc.EndPoint Property

Gets end point of CADArc object

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property EndPoint() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint EndPoint {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADArc Class
CADArc Members


CADArc.EntType Property

Gets the type of this CADArc entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADArc Class
CADArc Members


CADPolylineBase.Flags Property

Gets or sets a number that specifies an appearance of this CADPolylineBase entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Flags() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Flags {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolylineBase Class
CADPolylineBase Members


CADPolylineBase.IsMeshMClosed Property

Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the M direction.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property IsMeshMClosed() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsMeshMClosed {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolylineBase Class
CADPolylineBase Members


CADPolylineBase.IsMeshNClosed Property

Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the N direction.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property IsMeshNClosed() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsMeshNClosed {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolylineBase Class
CADPolylineBase Members


CADPolylineBase.IsPolyFaceMesh Property

Indicates that the current primitive is mesh.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overridable Property IsPolyFaceMesh() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual bool IsPolyFaceMesh {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolylineBase Class
CADPolylineBase Members


CADPolylineBase.IsPolyZThickness Property

Gets a value indicating whether a line thickness measured along the axis Z is equal to 0.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property IsPolyZThickness() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsPolyZThickness {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolylineBase Class
CADPolylineBase Members


CADPolylineBase.IsPolygonMesh Property

Indicates that the current primitive is mesh.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overridable Property IsPolygonMesh() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual bool IsPolygonMesh {get;}
This language is not supported or no code example is available.

Property Value

true ,if primitive is mesh else false
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolylineBase Class
CADPolylineBase Members


CADCircle.Point Property

Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Point() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override DPoint Point {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object representing a point that specifies a position of the CADPenLine entity in the CAD drawing.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCircle Class
CADCircle Members


CADPolylineBase.PolyPoints Property

Gets a collection of points belonging to the polyline.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PolyPoints() As CADCollection(Of DPoint)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection<DPoint> PolyPoints {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolylineBase Class
CADPolylineBase Members


CADCircle.Radius Property

Gets or sets a radius for the CADCircle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Radius() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Radius {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCircle Class
CADCircle Members


CADArc.StartAngle Property

Gets or sets an angle between axis X and the line connecting the start point with the central Point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property StartAngle() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double StartAngle {get; set;}
This language is not supported or no code example is available.
Remarks

The angle is formed counterclockwise.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADArc Class
CADArc Members


CADArc.StartPoint Property

Gets start point of CADArc object

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property StartPoint() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint StartPoint {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADArc Class
CADArc Members


CADArc Methods

CADArc Class See Also

The following tables list the members exposed by the CADArc type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | ApplyBox | Calculates a box of the current entity. (inherited from CADPolylineBase).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
 | CreateArcFromVertexes | Creates a new instance of the CADArc class using two instances of the CADVertex class.
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADPolylineBase).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADCircle).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Used in drawing cycle for fast checking whether the entity must be drawn (inherited from CADPolylineBase).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADArc to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADArc Class


CADPolylineBase.ApplyBox Method

Calculates a box of the current entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub ApplyBox()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void ApplyBox()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolylineBase Class
CADPolylineBase Members


CADArc.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADArc Class
CADArc Members


CADArc.CreateArcFromVertexes Method

Creates a new instance of the CADArc class using two instances of the CADVertex class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function CreateArcFromVertexes( _
   ByVal vertex1 As CADVertex, _
   ByVal vertex2 As CADVertex _
) As CADArc
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static CADArc CreateArcFromVertexes(
   CADVertex vertex1,
   CADVertex vertex2
)
This language is not supported or no code example is available.

Parameters

vertex1

Type: CADVertex

The first vertex

vertex2

Type: CADVertex

The second vertex

Return Value

The created instance of the CADArc class. If the first vertex have Bulge value equal to zero, then null returned
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADArc Class
CADArc Members


CADPolylineBase.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolylineBase Class
CADPolylineBase Members


CADCircle.DrawEntityTrace Method

Implements drawing of entity with specified offset to specified Control

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub DrawEntityTrace( _
   ByVal dx As Integer, _
   ByVal dy As Integer, _
   ByVal img As CADImage, _
   ByVal control As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void DrawEntityTrace(
   int dx,
   int dy,
   CADImage img,
   Control control
)
This language is not supported or no code example is available.

Parameters

dx

Type: int

X axis offset

dy

Type: int

Y axis offset

img

Type: CADImage

CADImage object for getting display coordinates of the entity

control

Type: Control

Control for drawing of Entity

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCircle Class
CADCircle Members


CADPolylineBase.GetBoxPoints Method

Used in drawing cycle for fast checking whether the entity must be drawn

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function GetBoxPoints( _
   ByVal func As FPointProc, _
   ByVal full As Boolean _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool GetBoxPoints(
   FPointProc func,
   bool full
)
This language is not supported or no code example is available.

Parameters

func

Type: FPointProc

full

Type: bool

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolylineBase Class
CADPolylineBase Members


CADArc.Loaded Method

Loads this CADArc to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADArc is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADArc Class
CADArc Members


CADArc Fields

CADArc Class See Also

The following tables list the members exposed by the CADArc type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADArc Class


CADAttdef Class

Members See Also

Represents an attribute in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADAttdef
    Inherits CADText
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADAttdef : CADText
This language is not supported or no code example is available.
Remarks

Exists mostly inside the Block objects

Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADCustomVertex
CADImport.CADText
CADImport.CADAttdef
CADImport.CADAttrib
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADAttdef Members


CADAttdef Members

CADAttdef Class Constructors Methods Fields Properties See Also

Represents an attribute in a CAD image.

The following tables list the members exposed by the CADAttdef type.

Constructors
 | Name | Description
Public constructor | CADAttdef | Initializes a new instance of the CADText object. (inherited from CADText).
Top
Properties
 | Name | Description
Public property | Backward | Gets a value indicating whether the text line is turned backwards. (inherited from CADText).
Public property | Box | Gets a three-dimensional box that encloses this CADText object. (inherited from CADText).
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADAttdef object.
Public property | EntType | Gets the type of this CADAttdef entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets the direction of axis Z belonging to the coordinate system of the CADText object. (inherited from CADText).
Public property | Flags | Gets or sets a byte that contains flags for the CADAttdef object.
Public property | FontName | Gets or sets a name of the font used by this CADText object. (inherited from CADText).
Public property | HAlign | Gets or sets a horizontal alignment of a text. (inherited from CADText).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Height | Gets or sets a height of the CADText letters. (inherited from CADText).
Public property | InsideMText | Gets a value indicating whether this CADText object is a part of the multiline text. (inherited from CADText).
Public property | IsSHXFont | Gets a value indicating whether this CADText object contains SHX fonts. (inherited from CADText).
Public property | IsUnicodeText | Gets a value indicating whether this CADText object consists of unicode characters. (inherited from CADText).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADText. (inherited from CADText).
Public property | ObliqueAngle | Gets or sets a tilt angle for the CADText letters. (inherited from CADText).
Public property | Point | Gets or sets a position of the CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Point1 | Gets or sets a second alignment point of the CADText object. (inherited from CADText).
Public property | Rotation | Gets or sets a rotation angle of the CADText object. (inherited from CADText).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADText).
Public property | StartPoint | Gets the start point of the text line. (inherited from CADText).
Public property | Style | Gets or sets a style for the CADText object. (inherited from CADText).
Public property | Tag | Gets or sets a name that identifies each occurrence of the attribute in a CAD image.
Public property | Text | Gets or sets a text contents for the CADText object. (inherited from CADText).
Public property | TextStyle | Gets or sets a style of the CADText. (inherited from CADText).
Public property | UnicodeText | Gets the Unicode text contained in this CADText object. (inherited from CADText).
Public property | UpsideDown | Gets a value indicating whether the text line is turned downwards (mirrored along axis Z). (inherited from CADText).
Public property | VAlign | Gets or sets a vetical alignment of the text. (inherited from CADText).
Public property | Value | Gets or sets string value of this CADAttdef object.
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible.
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | XScale | Gets or sets a width scale (width factor) for the CADText. (inherited from CADText).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | ApplyStyle | Applies a specified CADStyle to the CADText entity. (inherited from CADText).
Public method | AssignEntity | Copies an entity
Public method | ChangeByStyle | Changes CADStyle of the CADText to the specified one. (inherited from CADText).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADText.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExpR | Calculates a rectangle occupied by this CADText. (inherited from CADText).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADText to the specified CADConverter. (inherited from CADText).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADAttdef Class


CADText Constructor

Example See Also

Initializes a new instance of the CADText object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADText()
This language is not supported or no code example is available.
Example
<p>Creating a new CADText object example:</p> <p>[C#]</p>
Copy
 CreateNewImage();
 Point p1 = new Point(100, 100);
 CADText text = new CADText();
 text.FontName = "Txt.shx";
 text.Color = CADConst.clNone;
 text.Point = GetRealPoint(p1.X, p1.Y);
 text.Height = 5.0;
 text.Rotation = 0.0f;
 text.Text = "Any text";
 text.LineWeight = 0.1;
 text.Layer = cadImage.Converter.Layers[0] as CADLayer;
 cadImage.Converter.OnCreate(text);
 text.Handle = text.GetHashCode();
 text.KeyEnt = text.Handle.ToString();
 cadImage.Converter.OnCreate(text);
 cadImage.CurrentLayout.Entities.Add(text);
 EditorCADPictureBox.Invalidate();
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members
CADImport Namespace
CADImage
CADText
DPoint
GetRealPoint
clNone


CADAttdef Properties

CADAttdef Class See Also

The following tables list the members exposed by the CADAttdef type.

Properties
 | Name | Description
Public property | Backward | Gets a value indicating whether the text line is turned backwards. (inherited from CADText).
Public property | Box | Gets a three-dimensional box that encloses this CADText object. (inherited from CADText).
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADAttdef object.
Public property | EntType | Gets the type of this CADAttdef entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets the direction of axis Z belonging to the coordinate system of the CADText object. (inherited from CADText).
Public property | Flags | Gets or sets a byte that contains flags for the CADAttdef object.
Public property | FontName | Gets or sets a name of the font used by this CADText object. (inherited from CADText).
Public property | HAlign | Gets or sets a horizontal alignment of a text. (inherited from CADText).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Height | Gets or sets a height of the CADText letters. (inherited from CADText).
Public property | InsideMText | Gets a value indicating whether this CADText object is a part of the multiline text. (inherited from CADText).
Public property | IsSHXFont | Gets a value indicating whether this CADText object contains SHX fonts. (inherited from CADText).
Public property | IsUnicodeText | Gets a value indicating whether this CADText object consists of unicode characters. (inherited from CADText).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADText. (inherited from CADText).
Public property | ObliqueAngle | Gets or sets a tilt angle for the CADText letters. (inherited from CADText).
Public property | Point | Gets or sets a position of the CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Point1 | Gets or sets a second alignment point of the CADText object. (inherited from CADText).
Public property | Rotation | Gets or sets a rotation angle of the CADText object. (inherited from CADText).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADText).
Public property | StartPoint | Gets the start point of the text line. (inherited from CADText).
Public property | Style | Gets or sets a style for the CADText object. (inherited from CADText).
Public property | Tag | Gets or sets a name that identifies each occurrence of the attribute in a CAD image.
Public property | Text | Gets or sets a text contents for the CADText object. (inherited from CADText).
Public property | TextStyle | Gets or sets a style of the CADText. (inherited from CADText).
Public property | UnicodeText | Gets the Unicode text contained in this CADText object. (inherited from CADText).
Public property | UpsideDown | Gets a value indicating whether the text line is turned downwards (mirrored along axis Z). (inherited from CADText).
Public property | VAlign | Gets or sets a vetical alignment of the text. (inherited from CADText).
Public property | Value | Gets or sets string value of this CADAttdef object.
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible.
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | XScale | Gets or sets a width scale (width factor) for the CADText. (inherited from CADText).
Top
See Also

Reference

CADAttdef Class


CADText.Backward Property

Gets a value indicating whether the text line is turned backwards.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Backward() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Backward {get;}
This language is not supported or no code example is available.

Property Value

true if the text is turned backwards; otherwise, false.
Remarks

When the text line is turned backwards, all letters of the text are also turned backwards.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADText.Box Property

Gets a three-dimensional box that encloses this CADText object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Box() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override DRect Box {get;}
This language is not supported or no code example is available.

Property Value

A DRect object representing the a box that encloses a text.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADAttdef.EntName Property

Gets a name of the CADAttdef object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override string EntName {get;}
This language is not supported or no code example is available.

Property Value

A string containing a name of the CADAttdef object.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADAttdef Class
CADAttdef Members


CADAttdef.EntType Property

Gets the type of this CADAttdef entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADAttdef Class
CADAttdef Members


CADText.Extrusion Property

Gets or sets the direction of axis Z belonging to the coordinate system of the CADText object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Extrusion() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Extrusion {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object specifying the direction of axis Z belonging to the coordinate system of the CADText object.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADAttdef.Flags Property

Gets or sets a byte that contains flags for the CADAttdef object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Flags() As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte Flags {get; set;}
This language is not supported or no code example is available.
Remarks

bit-coded values:

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADAttdef Class
CADAttdef Members


CADText.FontName Property

Gets or sets a name of the font used by this CADText object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property FontName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string FontName {get; set;}
This language is not supported or no code example is available.

Property Value

A string containing a name of the font used by this CADText.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADText.HAlign Property

Gets or sets a horizontal alignment of a text.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property HAlign() As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte HAlign {get; set;}
This language is not supported or no code example is available.

Property Value

A number that identifies a text alignment in reference to the StartPoint.
Remarks

            A horizontal text alignment is specified by the following numbers:
0 - left, 1 - center, 2 - right, 3 - aligned(if vertical alignment = 0),
4 - middle(if vertical alignment = 0),
5 - fit(if vertical alignment = 0).

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADText.Height Property

Gets or sets a height of the CADText letters.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Height() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Height {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADText.InsideMText Property

Gets a value indicating whether this CADText object is a part of the multiline text.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property InsideMText() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool InsideMText {get;}
This language is not supported or no code example is available.

Property Value

true if this text is a part of the multiline text; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADText.IsSHXFont Property

Gets a value indicating whether this CADText object contains SHX fonts.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property IsSHXFont() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsSHXFont {get;}
This language is not supported or no code example is available.

Property Value

true if this text contains SHX fonts; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADText.IsUnicodeText Property

Gets a value indicating whether this CADText object consists of unicode characters.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property IsUnicodeText() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsUnicodeText {get;}
This language is not supported or no code example is available.

Property Value

true if this text consists of unicode characters; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADText.LineWeight Property

Gets or sets a thickness of lines for this CADText.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property LineWeight() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override double LineWeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADText.ObliqueAngle Property

Gets or sets a tilt angle for the CADText letters.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ObliqueAngle() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float ObliqueAngle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADText.Point1 Property

Gets or sets a second alignment point of the CADText object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Point1() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Point1 {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object representing the second alignment point for the CADText.
Remarks

The return value is meaningful only if the HAlign and VAlign values are nonzero.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADText.Rotation Property

Gets or sets a rotation angle of the CADText object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Rotation() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float Rotation {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADText.Selected Property

Gets or sets a value indicating whether the CADEntity is selected.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Selected() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool Selected {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADText.StartPoint Property

Gets the start point of the text line.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property StartPoint() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint StartPoint {get;}
This language is not supported or no code example is available.

Property Value

A DPoint object representing the start point of the text line.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADText.Style Property

Gets or sets a style for the CADText object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Style() As CADStyle
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADStyle Style {get; set;}
This language is not supported or no code example is available.

Property Value

A CADStyle object that represents a style for the single line text.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADAttdef.Tag Property

Gets or sets a name that identifies each occurrence of the attribute in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Property Tag() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual string Tag {get; set;}
This language is not supported or no code example is available.

Property Value

A string containing a name that identifies each occurrence of the attribute in a CAD image.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADAttdef Class
CADAttdef Members


CADText.Text Property

Gets or sets a text contents for the CADText object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Text() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Text {get; set;}
This language is not supported or no code example is available.

Property Value

A string containing a text represented by this CADText object.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADText.TextStyle Property

Gets or sets a style of the CADText.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TextStyle() As FontStyle
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public FontStyle TextStyle {get; set;}
This language is not supported or no code example is available.

Property Value

A FontStyle value containing the style information applied to the CADText.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADText.UnicodeText Property

Gets the Unicode text contained in this CADText object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property UnicodeText() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string UnicodeText {get;}
This language is not supported or no code example is available.

Property Value

A string representing the Unicode text contained in this CADText object.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADText.UpsideDown Property

Gets a value indicating whether the text line is turned downwards (mirrored along axis Z).

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property UpsideDown() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool UpsideDown {get;}
This language is not supported or no code example is available.

Property Value

true if the text is turned downwards; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADText.VAlign Property

Gets or sets a vetical alignment of the text.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property VAlign() As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte VAlign {get; set;}
This language is not supported or no code example is available.

Property Value

A number that identifies a text alignment in reference to the StartPoint.
Remarks

A vertical text alignment is specified by the following numbers: 0 - baseline, 1 - bottom, 2 - middle, 3 - top

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADAttdef.Value Property

Gets or sets string value of this CADAttdef object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Property Value() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual string Value {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADAttdef Class
CADAttdef Members


CADAttdef.Visibility Property

Gets or sets a value indicating whether a CADPlotEntity is visible.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Visibility() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool Visibility {get; set;}
This language is not supported or no code example is available.

Property Value

true if a CADPlotEntity is visible; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADAttdef Class
CADAttdef Members


CADText.XScale Property

Gets or sets a width scale (width factor) for the CADText.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property XScale() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float XScale {get; set;}
This language is not supported or no code example is available.

Property Value

More than one if the text letters are stretched; less than one and more than zero if the text letters are squeezed. A modified width is equal to the previous text width multiplied by a width factor.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADAttdef Methods

CADAttdef Class See Also

The following tables list the members exposed by the CADAttdef type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | ApplyStyle | Applies a specified CADStyle to the CADText entity. (inherited from CADText).
Public method | AssignEntity | Copies an entity
Public method | ChangeByStyle | Changes CADStyle of the CADText to the specified one. (inherited from CADText).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADText.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExpR | Calculates a rectangle occupied by this CADText. (inherited from CADText).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADText to the specified CADConverter. (inherited from CADText).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADAttdef Class


CADText.ApplyStyle Method

Applies a specified CADStyle to the CADText entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ApplyStyle( _
   ByVal style As CADStyle _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ApplyStyle(
   CADStyle style
)
This language is not supported or no code example is available.

Parameters

style

Type: CADStyle

CADStyle to apply to the text.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADAttdef.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADAttdef Class
CADAttdef Members


CADText.ChangeByStyle Method

Changes CADStyle of the CADText to the specified one.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ChangeByStyle( _
   ByVal AStyle As CADStyle _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ChangeByStyle(
   CADStyle AStyle
)
This language is not supported or no code example is available.

Parameters

AStyle

Type: CADStyle

CADStyle to be changed.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADAttdef.Dispose Method

Releases all resources used by the CADText.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADAttdef Class
CADAttdef Members


CADText.ExpR Method

Calculates a rectangle occupied by this CADText.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ExpR( _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal matrix As CADMatrix, _
   ByRef r As DRect _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ExpR(
   double x,
   double y,
   CADMatrix matrix,
   ref DRect r
)
This language is not supported or no code example is available.

Parameters

x

Type: double

The X coordinate of the CADText position.

y

Type: double

The Y coordinate of the CADText position.

matrix

Type: CADMatrix

A CADMatrix used for the CADText transformation.

r

Type: DRect

A DRect object representing a rectangle occupied by this CADText.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADText.Loaded Method

Loads this CADText to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADText object is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADEntity.SetLType Method

Sets a linetype for this CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub SetLType( _
   ByVal Value As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void SetLType(
   CADEntity Value
)
This language is not supported or no code example is available.

Parameters

Value

Type: CADEntity

A CADEntity representing a linetype to be set.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntity Class
CADEntity Members


CADAttdef Fields

CADAttdef Class See Also

The following tables list the members exposed by the CADAttdef type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADAttdef Class


CADAttrib Class

Members See Also

Allow to redefy CADAttdef object with corresponding tag property.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADAttrib
    Inherits CADAttdef
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADAttrib : CADAttdef
This language is not supported or no code example is available.
Remarks

Can only exist inside Insert entity

Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADCustomVertex
CADImport.CADText
CADImport.CADAttdef
CADImport.CADAttrib
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADAttrib Members


CADAttrib Members

CADAttrib Class Constructors Methods Fields Properties See Also

Allow to redefy CADAttdef object with corresponding tag property.

The following tables list the members exposed by the CADAttrib type.

Constructors
 | Name | Description
Public constructor | CADAttrib | Initializes a new instance of the CADText object. (inherited from CADText).
Top
Properties
 | Name | Description
Public property | Backward | Gets a value indicating whether the text line is turned backwards. (inherited from CADText).
Public property | Box | Gets a three-dimensional box that encloses this CADText object. (inherited from CADText).
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADAttdef object. (inherited from CADAttdef).
Public property | EntType | Gets the type of this CADAttrib entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets the direction of axis Z belonging to the coordinate system of the CADText object. (inherited from CADText).
Public property | Flags | Gets or sets a byte that contains flags for the CADAttdef object. (inherited from CADAttdef).
Public property | FontName | Gets or sets a name of the font used by this CADText object. (inherited from CADText).
Public property | HAlign | Gets or sets a horizontal alignment of a text. (inherited from CADText).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Height | Gets or sets a height of the CADText letters. (inherited from CADText).
Public property | InsideMText | Gets a value indicating whether this CADText object is a part of the multiline text. (inherited from CADText).
Public property | IsSHXFont | Gets a value indicating whether this CADText object contains SHX fonts. (inherited from CADText).
Public property | IsUnicodeText | Gets a value indicating whether this CADText object consists of unicode characters. (inherited from CADText).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADText. (inherited from CADText).
Public property | ObliqueAngle | Gets or sets a tilt angle for the CADText letters. (inherited from CADText).
Public property | Point | Gets or sets a position of the CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Point1 | Gets or sets a second alignment point of the CADText object. (inherited from CADText).
Public property | Rotation | Gets or sets a rotation angle of the CADText object. (inherited from CADText).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADText).
Public property | StartPoint | Gets the start point of the text line. (inherited from CADText).
Public property | Style | Gets or sets a style for the CADText object. (inherited from CADText).
Public property | Tag | Gets or sets a name that identifies each occurrence of the attribute in a CAD image.
Public property | Text | Gets or sets a text contents for the CADText object. (inherited from CADText).
Public property | TextStyle | Gets or sets a style of the CADText. (inherited from CADText).
Public property | UnicodeText | Gets the Unicode text contained in this CADText object. (inherited from CADText).
Public property | UpsideDown | Gets a value indicating whether the text line is turned downwards (mirrored along axis Z). (inherited from CADText).
Public property | VAlign | Gets or sets a vetical alignment of the text. (inherited from CADText).
Public property | Value | Gets or sets string value of this CADAttrib object.
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible.
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | XScale | Gets or sets a width scale (width factor) for the CADText. (inherited from CADText).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | ApplyStyle | Applies a specified CADStyle to the CADText entity. (inherited from CADText).
Public method | AssignEntity | Copies an entity
Public method | ChangeByStyle | Changes CADStyle of the CADText to the specified one. (inherited from CADText).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADText. (inherited from CADAttdef).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExpR | Calculates a rectangle occupied by this CADText. (inherited from CADText).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADText to the specified CADConverter. (inherited from CADText).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADAttrib Class


CADAttrib Properties

CADAttrib Class See Also

The following tables list the members exposed by the CADAttrib type.

Properties
 | Name | Description
Public property | Backward | Gets a value indicating whether the text line is turned backwards. (inherited from CADText).
Public property | Box | Gets a three-dimensional box that encloses this CADText object. (inherited from CADText).
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADAttdef object. (inherited from CADAttdef).
Public property | EntType | Gets the type of this CADAttrib entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets the direction of axis Z belonging to the coordinate system of the CADText object. (inherited from CADText).
Public property | Flags | Gets or sets a byte that contains flags for the CADAttdef object. (inherited from CADAttdef).
Public property | FontName | Gets or sets a name of the font used by this CADText object. (inherited from CADText).
Public property | HAlign | Gets or sets a horizontal alignment of a text. (inherited from CADText).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Height | Gets or sets a height of the CADText letters. (inherited from CADText).
Public property | InsideMText | Gets a value indicating whether this CADText object is a part of the multiline text. (inherited from CADText).
Public property | IsSHXFont | Gets a value indicating whether this CADText object contains SHX fonts. (inherited from CADText).
Public property | IsUnicodeText | Gets a value indicating whether this CADText object consists of unicode characters. (inherited from CADText).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADText. (inherited from CADText).
Public property | ObliqueAngle | Gets or sets a tilt angle for the CADText letters. (inherited from CADText).
Public property | Point | Gets or sets a position of the CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Point1 | Gets or sets a second alignment point of the CADText object. (inherited from CADText).
Public property | Rotation | Gets or sets a rotation angle of the CADText object. (inherited from CADText).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADText).
Public property | StartPoint | Gets the start point of the text line. (inherited from CADText).
Public property | Style | Gets or sets a style for the CADText object. (inherited from CADText).
Public property | Tag | Gets or sets a name that identifies each occurrence of the attribute in a CAD image.
Public property | Text | Gets or sets a text contents for the CADText object. (inherited from CADText).
Public property | TextStyle | Gets or sets a style of the CADText. (inherited from CADText).
Public property | UnicodeText | Gets the Unicode text contained in this CADText object. (inherited from CADText).
Public property | UpsideDown | Gets a value indicating whether the text line is turned downwards (mirrored along axis Z). (inherited from CADText).
Public property | VAlign | Gets or sets a vetical alignment of the text. (inherited from CADText).
Public property | Value | Gets or sets string value of this CADAttrib object.
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible.
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | XScale | Gets or sets a width scale (width factor) for the CADText. (inherited from CADText).
Top
See Also

Reference

CADAttrib Class


CADAttrib.EntType Property

Gets the type of this CADAttrib entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADAttrib Class
CADAttrib Members


CADAttrib.Tag Property

Gets or sets a name that identifies each occurrence of the attribute in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Tag() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override string Tag {get; set;}
This language is not supported or no code example is available.

Property Value

A string containing a name that identifies each occurrence of the attribute in a CAD image.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADAttrib Class
CADAttrib Members


CADAttrib.Value Property

Gets or sets string value of this CADAttrib object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Value() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override string Value {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADAttrib Class
CADAttrib Members


CADAttrib.Visibility Property

Gets or sets a value indicating whether a CADPlotEntity is visible.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Visibility() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool Visibility {get; set;}
This language is not supported or no code example is available.

Property Value

true if a CADPlotEntity is visible; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADAttrib Class
CADAttrib Members


CADAttrib Methods

CADAttrib Class See Also

The following tables list the members exposed by the CADAttrib type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | ApplyStyle | Applies a specified CADStyle to the CADText entity. (inherited from CADText).
Public method | AssignEntity | Copies an entity
Public method | ChangeByStyle | Changes CADStyle of the CADText to the specified one. (inherited from CADText).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADText. (inherited from CADAttdef).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExpR | Calculates a rectangle occupied by this CADText. (inherited from CADText).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADText to the specified CADConverter. (inherited from CADText).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADAttrib Class


CADAttrib.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADAttrib Class
CADAttrib Members


CADAttrib Fields

CADAttrib Class See Also

The following tables list the members exposed by the CADAttrib type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADAttrib Class


CADBlock Class

Members See Also

Represents a block in a CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADBlock
    Inherits CADGroup
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADBlock : CADGroup
This language is not supported or no code example is available.
Remarks

A CAD block is a collection of related objects that can be treated as a single object.

Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADGroup
CADImport.CADBlock
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADBlock Members


CADBlock Members

CADBlock Class Constructors Methods Fields Properties See Also

Represents a block in a CAD file.

The following tables list the members exposed by the CADBlock type.

Constructors
 | Name | Description
Public constructor | CADBlock | Initializes a new instance of the CADBlock class.
Top
Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses this CADGroup. (inherited from CADGroup).
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the specified CADGroup. (inherited from CADGroup).
Public property | EntName | Gets a name of the CADBlock.
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of CAD entities belonging to the given CADGroup. (inherited from CADGroup).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Flags | Gets or sets a byte that contains flags for this CADBlock.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | List | Gets a collection of entities included in the given CADGroup. (inherited from CADGroup).
Public property | Name | Gets or sets a CADBlock name read from a CAD file.
Public property | Offset | Gets or sets a base point for the coordinate system of this CADBlock.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | SpecPaperSpace | Gets or sets SpecPaperSpace parameter
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | XrefPath | Gets or sets a path to the file containing a CAD image when this CADBlock represents an external reference.
Top
Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADBlock.
Public method | AssignEntity | Copies an entity (inherited from CADGroup).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Iterate | Invokes the referenced (by the specified delegate) method for each CAD entity belonging to the given CADGroup. (inherited from CADGroup).
Public method | Loaded | Loads this CADBlock to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RemoveEntityByName | Searches for an entity using its name then removes the entity. (inherited from CADGroup).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADBlock Class


CADBlock Constructor

Initializes a new instance of the CADBlock class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADBlock()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADBlock Class
CADBlock Members


CADBlock Properties

CADBlock Class See Also

The following tables list the members exposed by the CADBlock type.

Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses this CADGroup. (inherited from CADGroup).
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the specified CADGroup. (inherited from CADGroup).
Public property | EntName | Gets a name of the CADBlock.
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of CAD entities belonging to the given CADGroup. (inherited from CADGroup).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Flags | Gets or sets a byte that contains flags for this CADBlock.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | List | Gets a collection of entities included in the given CADGroup. (inherited from CADGroup).
Public property | Name | Gets or sets a CADBlock name read from a CAD file.
Public property | Offset | Gets or sets a base point for the coordinate system of this CADBlock.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | SpecPaperSpace | Gets or sets SpecPaperSpace parameter
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | XrefPath | Gets or sets a path to the file containing a CAD image when this CADBlock represents an external reference.
Top
See Also

Reference

CADBlock Class


CADEntity.Color Property

Gets or sets a color for the given CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Property Color() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual Color Color {get; set;}
This language is not supported or no code example is available.

Property Value

A Color object representing a color of the CADEntity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntity Class
CADEntity Members


CADBlock.EntName Property

Gets a name of the CADBlock.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override string EntName {get;}
This language is not supported or no code example is available.

Property Value

A string containing a name of the CADBlock.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADBlock Class
CADBlock Members


CADBlock.Flags Property

Gets or sets a byte that contains flags for this CADBlock.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Flags() As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte Flags {get; set;}
This language is not supported or no code example is available.
Remarks

Block flags:

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADBlock Class
CADBlock Members


CADBlock.Name Property

Gets or sets a CADBlock name read from a CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Name() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Name {get; set;}
This language is not supported or no code example is available.

Property Value

A string containing a CADBlock name read from a CAD file.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADBlock Class
CADBlock Members


CADBlock.Offset Property

Gets or sets a base point for the coordinate system of this CADBlock.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Offset() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Offset {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object representing a base point for the coordinate system of this CADBlock.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADBlock Class
CADBlock Members


CADBlock.SpecPaperSpace Property

Gets or sets SpecPaperSpace parameter

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property SpecPaperSpace() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool SpecPaperSpace {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADBlock Class
CADBlock Members


CADBlock.XrefPath Property

Gets or sets a path to the file containing a CAD image when this CADBlock represents an external reference.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property XrefPath() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string XrefPath {get; set;}
This language is not supported or no code example is available.

Property Value

A string containing a path to the external CAD file.
Remarks

If this CADBlock does't represent an external reference this property returns an empty string.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADBlock Class
CADBlock Members


CADBlock Methods

CADBlock Class See Also

The following tables list the members exposed by the CADBlock type.

Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADBlock.
Public method | AssignEntity | Copies an entity (inherited from CADGroup).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Iterate | Invokes the referenced (by the specified delegate) method for each CAD entity belonging to the given CADGroup. (inherited from CADGroup).
Public method | Loaded | Loads this CADBlock to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RemoveEntityByName | Searches for an entity using its name then removes the entity. (inherited from CADGroup).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADBlock Class


CADBlock.AddEntity Method

Adds the specified entity to this CADBlock.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function AddEntity( _
   ByVal E As CADEntity _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool AddEntity(
   CADEntity E
)
This language is not supported or no code example is available.

Parameters

E

Type: CADEntity

A CADEntity to add.

Return Value

true if a CADEntity was added; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADBlock Class
CADBlock Members


CADGroup.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGroup Class
CADGroup Members


CADBlock.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADBlock Class
CADBlock Members


CADBlock.Loaded Method

Loads this CADBlock to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADBlock is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADBlock Class
CADBlock Members


CADBlock Fields

CADBlock Class See Also

The following tables list the members exposed by the CADBlock type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADBlock Class


CADBlockRecord Class

Members See Also

This class is for internal use only.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADBlockRecord
    Inherits CADPenTableItem
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADBlockRecord : CADPenTableItem
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.CADPenTableItem
CADImport.CADBlockRecord
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADBlockRecord Members


CADBlockRecord Members

CADBlockRecord Class Constructors Methods Fields Properties See Also

This class is for internal use only.

The following tables list the members exposed by the CADBlockRecord type.

Constructors
 | Name | Description
Public constructor | CADBlockRecord | Initializes a new instance of the CADPenEntity class. (inherited from CADPenEntity).
Top
Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | EntName | Gets a name of this CADPenTableItem. (inherited from CADPenTableItem).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Flags | Gets or sets a drawing flags. (inherited from CADPenTableItem).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Name | Gets or sets a name of the CADPenTableItem. (inherited from CADPenTableItem).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity (inherited from CADPenTableItem).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADPenTableItem).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADBlockRecord Class


CADPenEntity Constructor

Initializes a new instance of the CADPenEntity class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADPenEntity()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPenEntity Class
CADPenEntity Members


CADBlockRecord Properties

CADBlockRecord Class See Also

The following tables list the members exposed by the CADBlockRecord type.

Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | EntName | Gets a name of this CADPenTableItem. (inherited from CADPenTableItem).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Flags | Gets or sets a drawing flags. (inherited from CADPenTableItem).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Name | Gets or sets a name of the CADPenTableItem. (inherited from CADPenTableItem).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Top
See Also

Reference

CADBlockRecord Class


CADEntity.Box Property

Gets or sets a three-dimensional box that encloses the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Property Box() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual DRect Box {get; set;}
This language is not supported or no code example is available.

Property Value

A DRect object representing the enclosing box for the CADEntity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntity Class
CADEntity Members


CADPenTableItem.EntName Property

Gets a name of this CADPenTableItem.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override string EntName {get;}
This language is not supported or no code example is available.

Property Value

A string containing a name of this CADPenTableItem.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPenTableItem Class
CADPenTableItem Members


CADPenTableItem.Flags Property

Gets or sets a drawing flags.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Flags() As Short
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public short Flags {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPenTableItem Class
CADPenTableItem Members


CADPenTableItem.Name Property

Gets or sets a name of the CADPenTableItem.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Name() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Name {get; set;}
This language is not supported or no code example is available.
Remarks

A string containing a name of the CADPenTableItem read from a CAD file.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPenTableItem Class
CADPenTableItem Members


CADBlockRecord Methods

CADBlockRecord Class See Also

The following tables list the members exposed by the CADBlockRecord type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity (inherited from CADPenTableItem).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADPenTableItem).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADBlockRecord Class


CADPenTableItem.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPenTableItem Class
CADPenTableItem Members


CADPenTableItem.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPenTableItem Class
CADPenTableItem Members


CADEntity.Loaded Method

Virtual method. Redefined in descendant classes.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntity Class
CADEntity Members


CADBlockRecord Fields

CADBlockRecord Class See Also

The following tables list the members exposed by the CADBlockRecord type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADBlockRecord Class


CADBody Class

Members See Also

Represents a CADBody descendant of the CADACISEntity class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADBody
    Inherits CADACISEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADBody : CADACISEntity
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADGroup
CADImport.CADACISEntity
CADImport.CADBody
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADBody Members


CADBody Members

CADBody Class Constructors Methods Fields Properties See Also

Represents a CADBody descendant of the CADACISEntity class.

The following tables list the members exposed by the CADBody type.

Constructors
 | Name | Description
Public constructor | CADBody | Initializes a new instance of the CADACISEntity class. (inherited from CADACISEntity).
Top
Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses this CADGroup. (inherited from CADGroup).
Public property | Color | Gets or sets a Color for this CADACISEntity object. (inherited from CADACISEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the specified CADGroup. (inherited from CADGroup).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADBody entity.
Public property | Entities | Gets a collection of CAD entities belonging to the given CADGroup. (inherited from CADGroup).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | List | Gets a collection of entities included in the given CADGroup. (inherited from CADGroup).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity (inherited from CADACISEntity).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADACISEntity).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Iterate | Invokes the referenced (by the specified delegate) method for each CAD entity belonging to the given CADGroup. (inherited from CADGroup).
Public method | Loaded | Loads this CADACISEntity to the specified CADConverter. (inherited from CADACISEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RemoveEntityByName | Searches for an entity using its name then removes the entity. (inherited from CADGroup).
Public method | SetLType | Sets a line type for the current instance of the CADACISEntity class. (inherited from CADACISEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADBody Class


CADBody Properties

CADBody Class See Also

The following tables list the members exposed by the CADBody type.

Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses this CADGroup. (inherited from CADGroup).
Public property | Color | Gets or sets a Color for this CADACISEntity object. (inherited from CADACISEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the specified CADGroup. (inherited from CADGroup).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADBody entity.
Public property | Entities | Gets a collection of CAD entities belonging to the given CADGroup. (inherited from CADGroup).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | List | Gets a collection of entities included in the given CADGroup. (inherited from CADGroup).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
See Also

Reference

CADBody Class


CADBody.EntType Property

Gets the type of this CADBody entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADBody Class
CADBody Members


CADBody Methods

CADBody Class See Also

The following tables list the members exposed by the CADBody type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity (inherited from CADACISEntity).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADACISEntity).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Iterate | Invokes the referenced (by the specified delegate) method for each CAD entity belonging to the given CADGroup. (inherited from CADGroup).
Public method | Loaded | Loads this CADACISEntity to the specified CADConverter. (inherited from CADACISEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RemoveEntityByName | Searches for an entity using its name then removes the entity. (inherited from CADGroup).
Public method | SetLType | Sets a line type for the current instance of the CADACISEntity class. (inherited from CADACISEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADBody Class


CADBody Fields

CADBody Class See Also

The following tables list the members exposed by the CADBody type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADBody Class


CADCircle Class

Members See Also

Represents a circle in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADCircle
    Inherits CADPolylineBase
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADCircle : CADPolylineBase
This language is not supported or no code example is available.
Remarks

A circle in a CAD image is specified by the Point and by the Radius.

Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.CADPenLine
CADImport.CADPolylineBase
CADImport.CADCircle
CADImport.CADArc
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCircle Members


CADCircle Members

CADCircle Class Constructors Methods Fields Properties See Also

Represents a circle in a CAD image.

The following tables list the members exposed by the CADCircle type.

Constructors
 | Name | Description
Public constructor | CADCircle | Initializes a new instance of the CADCircle class.
Top
Properties
 | Name | Description
Public property | Box | Return box of the current primitive. (inherited from CADPolylineBase).
Public property | Closed | Gets or sets a value indicating whether this CADPolyLine is closed. (inherited from CADPolylineBase).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADPolylineBase. (inherited from CADPolylineBase).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | DottedSingPoints | Gets a collection of points that specify the dots and dashes of the CADPolylineBase. (inherited from CADPolylineBase).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADCircle entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Flags | Gets or sets a number that specifies an appearance of this CADPolylineBase entity. (inherited from CADPolylineBase).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | IsMeshMClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the M direction. (inherited from CADPolylineBase).
Public property | IsMeshNClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the N direction. (inherited from CADPolylineBase).
Public property | IsPolyFaceMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | IsPolyZThickness | Gets a value indicating whether a line thickness measured along the axis Z is equal to 0. (inherited from CADPolylineBase).
Public property | IsPolygonMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing.
Public property | PolyPoints | Gets a collection of points belonging to the polyline. (inherited from CADPolylineBase).
Public property | Radius | Gets or sets a radius for the CADCircle.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | ApplyBox | Calculates a box of the current entity. (inherited from CADPolylineBase).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADPolylineBase).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Used in drawing cycle for fast checking whether the entity must be drawn (inherited from CADPolylineBase).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADCircle to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADCircle Class


CADCircle Constructor

Example See Also

Initializes a new instance of the CADCircle class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCircle()
This language is not supported or no code example is available.
Example
<p>Creating a new CADCircle object example:</p> <p>[C#]</p>
Copy
     CreateNewImage();
     CADCircle circle = new CADCircle();
     circle.Color = CADConst.clNone;
     circle.Point = GetRealPoint(300, 300);
     circle.Radius = 10;
     circle.LineWeight = 0.1;
     circle.Loaded(cadImage.Converter);
     circle.Handle = circle.GetHashCode();
     circle.KeyEnt = circle.Handle.ToString();
     cadImage.CurrentLayout.Entities.Add(circle);
     cadImage.Converter.OnCreate(circle);
     EditorCADPictureBox.Invalidate();
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCircle Class
CADCircle Members
CADImport Namespace
CADCircle
CADImage
DPoint
clNone


CADCircle Properties

CADCircle Class See Also

The following tables list the members exposed by the CADCircle type.

Properties
 | Name | Description
Public property | Box | Return box of the current primitive. (inherited from CADPolylineBase).
Public property | Closed | Gets or sets a value indicating whether this CADPolyLine is closed. (inherited from CADPolylineBase).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADPolylineBase. (inherited from CADPolylineBase).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | DottedSingPoints | Gets a collection of points that specify the dots and dashes of the CADPolylineBase. (inherited from CADPolylineBase).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADCircle entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Flags | Gets or sets a number that specifies an appearance of this CADPolylineBase entity. (inherited from CADPolylineBase).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | IsMeshMClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the M direction. (inherited from CADPolylineBase).
Public property | IsMeshNClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the N direction. (inherited from CADPolylineBase).
Public property | IsPolyFaceMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | IsPolyZThickness | Gets a value indicating whether a line thickness measured along the axis Z is equal to 0. (inherited from CADPolylineBase).
Public property | IsPolygonMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing.
Public property | PolyPoints | Gets a collection of points belonging to the polyline. (inherited from CADPolylineBase).
Public property | Radius | Gets or sets a radius for the CADCircle.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
See Also

Reference

CADCircle Class


CADCircle.EntType Property

Gets the type of this CADCircle entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCircle Class
CADCircle Members


CADCircle Methods

CADCircle Class See Also

The following tables list the members exposed by the CADCircle type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | ApplyBox | Calculates a box of the current entity. (inherited from CADPolylineBase).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADPolylineBase).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Used in drawing cycle for fast checking whether the entity must be drawn (inherited from CADPolylineBase).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADCircle to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADCircle Class


CADCircle.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCircle Class
CADCircle Members


CADCircle.Loaded Method

Loads this CADCircle to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADCircle is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCircle Class
CADCircle Members


CADCircle Fields

CADCircle Class See Also

The following tables list the members exposed by the CADCircle type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADCircle Class


CADCollection<T> Class

Members See Also

Represents a collection of typed objects.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADCollection(Of  _
   T)
    Inherits List(Of T)
    Implements ICloneable, _
               IDisposable
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADCollection<T> : List<T>,
   ICloneable,
   IDisposable
This language is not supported or no code example is available.

Type Parameters

T

A type of elements

Inheritance Hierarchy
System.Object
System.Collections.Generic.List<T>
CADImport.CADCollection<T>
CADImport.CAD2DBoundaryList
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCollection<T> Members


CADCollection<T> Members

CADCollection<T> Class Constructors Methods Properties See Also

Represents a collection of typed objects.

The following tables list the members exposed by the CADCollection<T> type.

Constructors
 | Name | Description
Public constructor | CADCollection<T> | (Overloaded) Initializes a new instance of the CADCollection<T> Generic class.
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (inherited from List<T>).
Public property | Count | Gets the number of elements actually contained in the List<T>. (inherited from List<T>).
Public property | Item | Gets or sets the element at the specified index. (inherited from List<T>).
Public property | Last | Returns the index of a CADCollection<T> last member.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the List<T>. (inherited from List<T>).
Public method | AddRange | Adds the elements of the specified collection to the end of the List<T>. (inherited from List<T>).
Public method | AsReadOnly | Returns a read-only IList<T> wrapper for the current collection. (inherited from List<T>).
Public method | BinarySearch | (Overloaded) Searches a range of elements in the sorted List<T> for an element using the specified comparer and returns the zero-based index of the element. (inherited from List<T>).
Public method | Clear | Removes all elements from the List<T>. (inherited from List<T>).
Public method | Clone | Creates a new object that is a copy of the current CADCollection<T> class instance.
Public method | Contains | Determines whether an element is in the List<T>. (inherited from List<T>).
Public method | ConvertAll | Converts the elements in the current List<T> to another type, and returns a list containing the converted elements. (inherited from List<T>).
Public method | CopyTo | (Overloaded) Copies the entire List<T> to a compatible one-dimensional array, starting at the beginning of the target array. (inherited from List<T>).
Public method | Dispose | Releases all resources used by the CADCollection<T> object.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | Exists | Determines whether the List<T> contains elements that match the conditions defined by the specified predicate. (inherited from List<T>).
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<T>. (inherited from List<T>).
Public method | FindAll | Retrieves the all the elements that match the conditions defined by the specified predicate. (inherited from List<T>).
Public method | FindIndex | (Overloaded) Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<T>. (inherited from List<T>).
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<T>. (inherited from List<T>).
Public method | FindLastIndex | (Overloaded) Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<T>. (inherited from List<T>).
Public method | ForEach | Performs the specified action on each element of the List<T>. (inherited from List<T>).
Public method | GetEnumerator | Returns an enumerator that iterates through the List<T>. (inherited from List<T>).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<T>. (inherited from List<T>).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IndexOf | (Overloaded) Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<T>. (inherited from List<T>).
Public method | Insert | Inserts an element into the List<T> at the specified index. (inherited from List<T>).
Public method | InsertRange | Inserts the elements of a collection into the List<T> at the specified index. (inherited from List<T>).
Public method | LastIndexOf | (Overloaded) Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<T>. (inherited from List<T>).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Remove | Removes the first occurrence of a specific object from the List<T>. (inherited from List<T>).
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (inherited from List<T>).
Public method | RemoveAt | Removes the element at the specified index of the List<T>. (inherited from List<T>).
Public method | RemoveRange | Removes a range of elements from the List<T>. (inherited from List<T>).
Public method | Reverse | (Overloaded) Reverses the order of the elements in the entire List<T>. (inherited from List<T>).
Public method | Sort | (Overloaded) Sorts the elements in the entire List<T> using the default comparer. (inherited from List<T>).
Public method | ToArray | (Overloaded) Creates an array from the current CADCollection<T> object.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<T>, if that number is less than a threshold value. (inherited from List<T>).
Public method | TrueForAll | Determines whether every element in the List<T> matches the conditions defined by the specified predicate. (inherited from List<T>).
Top
See Also

Reference

CADCollection<T> Class


CADCollection<T> Constructor

CADCollection<T> Class See Also

Initializes a new instance of the CADCollection<T> Generic class.

Overload List
Name | Description
CADCollection() | Initializes a new instance of the CADCollection<T> Generic class.
CADCollection(IEnumerable<T>) | Initializes a new instance of the CADCollection<T> Generic class that contains elements copied from the specified collection and has sufficient capacity to accommodate the number of elements copied.
CADCollection(int) | Initializes a new instance of the CADCollection<T> Generic class that is empty and has the specified initial capacity.
See Also

Reference

CADCollection<T> Class
CADCollection<T> Members


CADCollection<T> Properties

CADCollection<T> Class See Also

The following tables list the members exposed by the CADCollection<T> type.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (inherited from List<T>).
Public property | Count | Gets the number of elements actually contained in the List<T>. (inherited from List<T>).
Public property | Item | Gets or sets the element at the specified index. (inherited from List<T>).
Public property | Last | Returns the index of a CADCollection<T> last member.
Top
See Also

Reference

CADCollection<T> Class


CADCollection<T> Methods

CADCollection<T> Class See Also

The following tables list the members exposed by the CADCollection<T> type.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the List<T>. (inherited from List<T>).
Public method | AddRange | Adds the elements of the specified collection to the end of the List<T>. (inherited from List<T>).
Public method | AsReadOnly | Returns a read-only IList<T> wrapper for the current collection. (inherited from List<T>).
Public method | BinarySearch | (Overloaded) Searches a range of elements in the sorted List<T> for an element using the specified comparer and returns the zero-based index of the element. (inherited from List<T>).
Public method | Clear | Removes all elements from the List<T>. (inherited from List<T>).
Public method | Clone | Creates a new object that is a copy of the current CADCollection<T> class instance.
Public method | Contains | Determines whether an element is in the List<T>. (inherited from List<T>).
Public method | ConvertAll | Converts the elements in the current List<T> to another type, and returns a list containing the converted elements. (inherited from List<T>).
Public method | CopyTo | (Overloaded) Copies the entire List<T> to a compatible one-dimensional array, starting at the beginning of the target array. (inherited from List<T>).
Public method | Dispose | Releases all resources used by the CADCollection<T> object.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | Exists | Determines whether the List<T> contains elements that match the conditions defined by the specified predicate. (inherited from List<T>).
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<T>. (inherited from List<T>).
Public method | FindAll | Retrieves the all the elements that match the conditions defined by the specified predicate. (inherited from List<T>).
Public method | FindIndex | (Overloaded) Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<T>. (inherited from List<T>).
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<T>. (inherited from List<T>).
Public method | FindLastIndex | (Overloaded) Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<T>. (inherited from List<T>).
Public method | ForEach | Performs the specified action on each element of the List<T>. (inherited from List<T>).
Public method | GetEnumerator | Returns an enumerator that iterates through the List<T>. (inherited from List<T>).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<T>. (inherited from List<T>).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IndexOf | (Overloaded) Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<T>. (inherited from List<T>).
Public method | Insert | Inserts an element into the List<T> at the specified index. (inherited from List<T>).
Public method | InsertRange | Inserts the elements of a collection into the List<T> at the specified index. (inherited from List<T>).
Public method | LastIndexOf | (Overloaded) Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<T>. (inherited from List<T>).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Remove | Removes the first occurrence of a specific object from the List<T>. (inherited from List<T>).
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (inherited from List<T>).
Public method | RemoveAt | Removes the element at the specified index of the List<T>. (inherited from List<T>).
Public method | RemoveRange | Removes a range of elements from the List<T>. (inherited from List<T>).
Public method | Reverse | (Overloaded) Reverses the order of the elements in the entire List<T>. (inherited from List<T>).
Public method | Sort | (Overloaded) Sorts the elements in the entire List<T> using the default comparer. (inherited from List<T>).
Public method | ToArray | (Overloaded) Creates an array from the current CADCollection<T> object.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<T>, if that number is less than a threshold value. (inherited from List<T>).
Public method | TrueForAll | Determines whether every element in the List<T> matches the conditions defined by the specified predicate. (inherited from List<T>).
Top
See Also

Reference

CADCollection<T> Class


CADCollection<T>.Clone Method

Creates a new object that is a copy of the current CADCollection<T> class instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Function Clone() As Object Implements  _
   ICloneable.Clone
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual object Clone()
This language is not supported or no code example is available.

Return Value

A new object that is a copy of this CADCollection<T> class instance.

Implements

ICloneable.Clone
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCollection<T> Class
CADCollection<T> Members


CADConst Class

Members See Also

Auxiliary class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public MustInherit Class CADConst
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public abstract class CADConst
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADConst
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Members


CADConst Members

CADConst Class Methods Fields Properties See Also

Auxiliary class.

The following tables list the members exposed by the CADConst type.

Properties
Name | Description
ExtendedTomesNames | Represents a list of application names for Extended Data
ProcessMessages |
SHXSearchPaths | Gets or sets a string containing the directories paths where to search the SHX fonts.
SearchSHXPaths | Gets or sets a value indicating whether a search of SHX fonts is permitted in the SHXSearchPaths directories.
UseMultyTTFFonts | Gets or sets a value indicating whether a multimode is used for showing letters.
UseSHXFonts | Gets or sets a value indicating whether the SHX fonts are used.
UseTTFFonts | Gets or sets a value indicating whether the TTF fonts are used.
Top
Methods
 | Name | Description
 | AddBigfontCodePage |
 | BGRToRGB | Converts a numeric value to RGB color.
 | CorrectByOrtho | Reduces a point coordinates increment to X or Y axis when ortho mode is active
 | DisposeObject | Invokes Dispose method for freeing unmanaged resources.
 | DisposeObject<T> |
 | DoPreExtrusion | Searches coordinates of a point (P) in the new coordinate system. This coordinate system is built respectively to Arbitary Axis Algoritm. OZ axis of the new coordinate system is N.
 | DoScale2D | Adjusts a scale along the axis X and a scale along the axis Y in accordance with the state of the coordinate transformation matrix.
 | EntColor | Gets a color of the specified CAD entity.
 | EntLayer | Gets a layer of the specified CAD entity.
 | EntLineWeight | Returns line width of the current entity by the specified entity and insert.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
 | FindAngle | Returns an angle between two points. The angle calculated based on coordinates increments by X and Y axes.
 | FindAutoCADSHXPaths | (Overloaded) Searhes the paths to the files containing the AutoCAD SHX fonts.
 | FindTrueViewSHXPaths | Searhes the paths to the files containing the DWG TrueView SHX fonts.
 | GetFileFotmat |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
 | GetRealPoint | (Overloaded) Gets a three-dimensional point of the current CAD image from the specified screen point.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | IntToArgb | Converts a numeric value to an ARGB color.
 | IsWebPath | Check whether specified path is a hyperlink
 | LoadDataFromWeb | Loads file from webpage specified by hyperlink
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
 | SGArcCos | Gets an angle of the unit vector with the specified X coordinate.
 | SendExceptionReport | Creates a report containing an exception report
 | SendMail | Creates an e-mail and opens it in the default mail client
 | SetNewRect | Creates rectangle by two points
 | SetNumberOfPartsInCurve | (Overloaded) Sets optimal number of parts for curve partition by the displaying area dimensions (for saving as a raster file).
 | ToInt | Converts the value of the specified double-precision floating-point number to an equivalent 32-bit signed integer (efficiently for drawing).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
Name | Description
AlphaColorMask |
BlueColorMask |
DPointSingle | An end point of vector, recieved by compozition X, Y and Z axis orts.
DXFLineWeights |
DefaultSHXParameters |
FillHatchesDefault |
GreenColorMask |
LogFilePath |
MaxDouble |
MaxRasterImageSize |
MinDouble |
OnMouseScroll | MouseScroll event message number
RedColorMask |
ToolbarButtonNames | Describes names for Toolbar buttons
XOrtAxis | An end point of X axis ort
YOrtAxis | An end point of Y axis ort
ZOrtAxis | An end point of Z axis ort
cl255 |
clByBlock | A color constant that means an entity's color is determined by block.
clByLayer | A color constant that means an entity's color is determined by layer.
clNone | A color constant that means an entity's color is undefined.
cnstBad2DRect |
cnstBadHandle | A constant of the invalid Handle
entityCount |
iDefaultNumberOfCircleParts | A default number that shows how many sections of a circle is divided into.
iDefaultNumberOfSplineParts | A default number that shows how many sections of a spline is divided into.
lngPathDefault | Default path to language files set
respectImageentRatio |
Top
See Also

Reference

CADConst Class


CADConst Properties

CADConst Class See Also

The following tables list the members exposed by the CADConst type.

Properties
Name | Description
ExtendedTomesNames | Represents a list of application names for Extended Data
ProcessMessages |
SHXSearchPaths | Gets or sets a string containing the directories paths where to search the SHX fonts.
SearchSHXPaths | Gets or sets a value indicating whether a search of SHX fonts is permitted in the SHXSearchPaths directories.
UseMultyTTFFonts | Gets or sets a value indicating whether a multimode is used for showing letters.
UseSHXFonts | Gets or sets a value indicating whether the SHX fonts are used.
UseTTFFonts | Gets or sets a value indicating whether the TTF fonts are used.
Top
See Also

Reference

CADConst Class


CADConst.ExtendedTomesNames Property

Represents a list of application names for Extended Data

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Shared Property ExtendedTomesNames() As List(Of String)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static List<string> ExtendedTomesNames {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.ProcessMessages Property

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Property ProcessMessages() As MessagesHandling
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static MessagesHandling ProcessMessages {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.SHXSearchPaths Property

Gets or sets a string containing the directories paths where to search the SHX fonts.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Property SHXSearchPaths() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static string SHXSearchPaths {get; set;}
This language is not supported or no code example is available.

Property Value

The directories where to search the SHX fonts.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.SearchSHXPaths Property

Gets or sets a value indicating whether a search of SHX fonts is permitted in the SHXSearchPaths directories.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Property SearchSHXPaths() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool SearchSHXPaths {get; set;}
This language is not supported or no code example is available.

Property Value

true if a search of SHX fonts is permitted; otherwise, false. The default is true.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.UseMultyTTFFonts Property

Gets or sets a value indicating whether a multimode is used for showing letters.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Property UseMultyTTFFonts() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool UseMultyTTFFonts {get; set;}
This language is not supported or no code example is available.

Property Value

true if multimode is used; otherwise, false. The default is true.
Remarks

Multimode means that the letters are drawn by means of GDI+ if the text has not been rotated and drawn by using polylines if the text has been rotated.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.UseSHXFonts Property

Gets or sets a value indicating whether the SHX fonts are used.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Property UseSHXFonts() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool UseSHXFonts {get; set;}
This language is not supported or no code example is available.

Property Value

true if using the SHX fonts are used; otherwise, false. The default is false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.UseTTFFonts Property

Gets or sets a value indicating whether the TTF fonts are used.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Property UseTTFFonts() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool UseTTFFonts {get; set;}
This language is not supported or no code example is available.

Property Value

true if the TTF fonts are used; otherwise, false. The default is true.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst Methods

CADConst Class See Also

The following tables list the members exposed by the CADConst type.

Methods
 | Name | Description
 | AddBigfontCodePage |
 | BGRToRGB | Converts a numeric value to RGB color.
 | CorrectByOrtho | Reduces a point coordinates increment to X or Y axis when ortho mode is active
 | DisposeObject | Invokes Dispose method for freeing unmanaged resources.
 | DisposeObject<T> |
 | DoPreExtrusion | Searches coordinates of a point (P) in the new coordinate system. This coordinate system is built respectively to Arbitary Axis Algoritm. OZ axis of the new coordinate system is N.
 | DoScale2D | Adjusts a scale along the axis X and a scale along the axis Y in accordance with the state of the coordinate transformation matrix.
 | EntColor | Gets a color of the specified CAD entity.
 | EntLayer | Gets a layer of the specified CAD entity.
 | EntLineWeight | Returns line width of the current entity by the specified entity and insert.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
 | FindAngle | Returns an angle between two points. The angle calculated based on coordinates increments by X and Y axes.
 | FindAutoCADSHXPaths | (Overloaded) Searhes the paths to the files containing the AutoCAD SHX fonts.
 | FindTrueViewSHXPaths | Searhes the paths to the files containing the DWG TrueView SHX fonts.
 | GetFileFotmat |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
 | GetRealPoint | (Overloaded) Gets a three-dimensional point of the current CAD image from the specified screen point.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | IntToArgb | Converts a numeric value to an ARGB color.
 | IsWebPath | Check whether specified path is a hyperlink
 | LoadDataFromWeb | Loads file from webpage specified by hyperlink
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
 | SGArcCos | Gets an angle of the unit vector with the specified X coordinate.
 | SendExceptionReport | Creates a report containing an exception report
 | SendMail | Creates an e-mail and opens it in the default mail client
 | SetNewRect | Creates rectangle by two points
 | SetNumberOfPartsInCurve | (Overloaded) Sets optimal number of parts for curve partition by the displaying area dimensions (for saving as a raster file).
 | ToInt | Converts the value of the specified double-precision floating-point number to an equivalent 32-bit signed integer (efficiently for drawing).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADConst Class


CADConst.AddBigfontCodePage Method

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub AddBigfontCodePage( _
   ByVal bigFontName As String, _
   ByVal codepage As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void AddBigfontCodePage(
   string bigFontName,
   int codepage
)
This language is not supported or no code example is available.

Parameters

bigFontName

Type: string

codepage

Type: int

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.BGRToRGB Method

Converts a numeric value to RGB color.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function BGRToRGB( _
   ByVal color As Integer _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static Color BGRToRGB(
   int color
)
This language is not supported or no code example is available.

Parameters

color

Type: int

An Integer type value

Return Value

A Color object
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.CorrectByOrtho Method

Reduces a point coordinates increment to X or Y axis when ortho mode is active

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub CorrectByOrtho( _
   ByRef newX As Integer, _
   ByRef newY As Integer, _
   ByVal oldX As Integer, _
   ByVal oldY As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void CorrectByOrtho(
   ref int newX,
   ref int newY,
   int oldX,
   int oldY
)
This language is not supported or no code example is available.

Parameters

newX

Type: int

A final X coordinate

newY

Type: int

A final Y coordinate

oldX

Type: int

A start X coordinate

oldY

Type: int

A start Y coordinate

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.DisposeObject Method

Invokes Dispose method for freeing unmanaged resources.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub DisposeObject( _
   ByVal obj As IDisposable _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void DisposeObject(
   IDisposable obj
)
This language is not supported or no code example is available.

Parameters

obj

Type: IDisposable

A Disposable object.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.DisposeObject<T> Method

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub DisposeObject(Of  _
   T)( _
   ByRef obj As T _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void DisposeObject<T>(
   ref T obj
)
This language is not supported or no code example is available.

Type Parameters

T

Parameters

obj

Type: T

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.DoPreExtrusion Method

Searches coordinates of a point (P) in the new coordinate system. This coordinate system is built respectively to Arbitary Axis Algoritm. OZ axis of the new coordinate system is N.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub DoPreExtrusion( _
   ByRef P As DPoint, _
   ByVal N As DPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void DoPreExtrusion(
   ref DPoint P,
   DPoint N
)
This language is not supported or no code example is available.

Parameters

P

Type: DPoint

Point to be changed

N

Type: DPoint

0Z axis of the new coordinate system, where 0X and 0Y are being selected respectively to Arbitary Axis Algoritm

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.DoScale2D Method

Adjusts a scale along the axis X and a scale along the axis Y in accordance with the state of the coordinate transformation matrix.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub DoScale2D( _
   ByRef P As CADIterate _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void DoScale2D(
   ref CADIterate P
)
This language is not supported or no code example is available.

Parameters

P

Type: CADIterate

A CADIterate object that specifies the coordinate transformation matrix and the scales to be adjusted.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.EntColor Method

Gets a color of the specified CAD entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function EntColor( _
   ByVal E As CADEntity, _
   ByVal Ins As CADInsert _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static Color EntColor(
   CADEntity E,
   CADInsert Ins
)
This language is not supported or no code example is available.

Parameters

E

Type: CADEntity

A CADEntity whose color to be returned.

Ins

Type: CADInsert

A reference to the block that includes the specified CAD entity.

Return Value

A Color of the specified CAD entity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.EntLayer Method

Gets a layer of the specified CAD entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function EntLayer( _
   ByVal E As CADEntity, _
   ByVal Ins As CADInsert _
) As CADLayer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static CADLayer EntLayer(
   CADEntity E,
   CADInsert Ins
)
This language is not supported or no code example is available.

Parameters

E

Type: CADEntity

A CADEntity whose layer to be returned.

Ins

Type: CADInsert

A reference to the block that includes the specified CAD entity.

Return Value

A CADLayer of the specified CAD entity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.EntLineWeight Method

Returns line width of the current entity by the specified entity and insert.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function EntLineWeight( _
   ByVal ent As CADEntity, _
   ByVal ins As CADInsert _
) As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static double EntLineWeight(
   CADEntity ent,
   CADInsert ins
)
This language is not supported or no code example is available.

Parameters

ent

Type: CADEntity

Specified entity

ins

Type: CADInsert

Insert which contains the current entity (if the entity does not enter into any insert, then parameter 'ins' equals zero)

Return Value

Line width
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.FindAngle Method

Returns an angle between two points. The angle calculated based on coordinates increments by X and Y axes.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function FindAngle( _
   ByVal dX As Double, _
   ByVal dY As Double _
) As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static double FindAngle(
   double dX,
   double dY
)
This language is not supported or no code example is available.

Parameters

dX

Type: double

Coordinates increment by X axis

dY

Type: double

Coordinates increment by Y axis

Return Value

The angle in degrees
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.FindAutoCADSHXPaths Method

CADConst Class See Also

Searhes the paths to the files containing the AutoCAD SHX fonts.

Overload List
Name | Description
FindAutoCADSHXPaths(ArrayList) | Searhes the paths to the files containing the AutoCAD SHX fonts.
FindAutoCADSHXPaths(List<String>) | Searhes the paths to the files containing the AutoCAD SHX fonts.
See Also

Reference

CADConst Class
CADConst Members


CADConst.FindTrueViewSHXPaths Method

Searhes the paths to the files containing the DWG TrueView SHX fonts.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function FindTrueViewSHXPaths( _
   ByVal aPaths As List(Of String) _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool FindTrueViewSHXPaths(
   List<string> aPaths
)
This language is not supported or no code example is available.

Parameters

aPaths

Type: List<string>

A list of paths where to search the DWG TrueView SHX fonts.

Return Value

true if the files containing the DWG TrueView SHX fonts are found; otherwize, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.GetFileFotmat Method

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function GetFileFotmat( _
   ByVal ext As String _
) As FileFormat
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static FileFormat GetFileFotmat(
   string ext
)
This language is not supported or no code example is available.

Parameters

ext

Type: string

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.GetRealPoint Method

CADConst Class See Also

Gets a three-dimensional point of the current CAD image from the specified screen point.

Overload List
Name | Description
GetRealPoint(int, int, CADImage, RectangleF) | Gets a three-dimensional point of the current CAD image from the specified screen point.
GetRealPoint(int, int, CADImage, RectangleF, bool) | Gets a three-dimensional point of the current CAD image from the specified screen point.
See Also

Reference

CADConst Class
CADConst Members


CADConst.IntToArgb Method

Converts a numeric value to an ARGB color.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function IntToArgb( _
   ByVal Value As Integer _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static Color IntToArgb(
   int Value
)
This language is not supported or no code example is available.

Parameters

Value

Type: int

An Integer type value.

Return Value

A Color object.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.IsWebPath Method

Check whether specified path is a hyperlink

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function IsWebPath( _
   ByVal path As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool IsWebPath(
   string path
)
This language is not supported or no code example is available.

Parameters

path

Type: string

Path to verify

Return Value

True if verified path is a hyperlink. Otherwise false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.LoadDataFromWeb Method

Loads file from webpage specified by hyperlink

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function LoadDataFromWeb( _
   ByVal path As String _
) As Stream
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static Stream LoadDataFromWeb(
   string path
)
This language is not supported or no code example is available.

Parameters

path

Type: string

Hyperlink path to load from

Return Value

Result
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.SGArcCos Method

Gets an angle of the unit vector with the specified X coordinate.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function SGArcCos( _
   ByVal X As Double _
) As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static double SGArcCos(
   double X
)
This language is not supported or no code example is available.

Parameters

X

Type: double

An X coordinate of the unit vector.

Return Value

An angle, measured in radians.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.SendExceptionReport Method

Creates a report containing an exception report

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function SendExceptionReport( _
   ByVal except As Exception _
) As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static string SendExceptionReport(
   Exception except
)
This language is not supported or no code example is available.

Parameters

except

Type: Exception

Exception parameters

Return Value

Created report
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.SendMail Method

Creates an e-mail and opens it in the default mail client

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub SendMail( _
   ByVal mailto As String, _
   ByVal subject As String, _
   ByVal body As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void SendMail(
   string mailto,
   string subject,
   string body
)
This language is not supported or no code example is available.

Parameters

mailto

Type: string

"Mail to" field

subject

Type: string

"Subject" field

body

Type: string

Body of the e-mail

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.SetNewRect Method

Creates rectangle by two points

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function SetNewRect( _
   ByVal p1 As Point, _
   ByVal p2 As Point _
) As Rectangle
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static Rectangle SetNewRect(
   Point p1,
   Point p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: Point

First point

p2

Type: Point

Second point

Return Value

Created rectangle
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.SetNumberOfPartsInCurve Method

CADConst Class See Also

Sets optimal number of parts for curve partition by the displaying area dimensions (for saving as a raster file).

Overload List
Name | Description
SetNumberOfPartsInCurve(DRect) | Sets optimal number of parts for curve partition by the displaying area dimensions (for saving as a raster file).
SetNumberOfPartsInCurve(RectangleF) | Sets optimal number of parts for curve partition by the displaying area dimensions (for saving as a raster file).
See Also

Reference

CADConst Class
CADConst Members


CADConst.ToInt Method

Converts the value of the specified double-precision floating-point number to an equivalent 32-bit signed integer (efficiently for drawing).

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function ToInt( _
   ByVal value As Double _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static int ToInt(
   double value
)
This language is not supported or no code example is available.

Parameters

value

Type: double

The double-precision floating-point number to convert.

Return Value

The integer value
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst Fields

CADConst Class See Also

The following tables list the members exposed by the CADConst type.

Fields
Name | Description
AlphaColorMask |
BlueColorMask |
DPointSingle | An end point of vector, recieved by compozition X, Y and Z axis orts.
DXFLineWeights |
DefaultSHXParameters |
FillHatchesDefault |
GreenColorMask |
LogFilePath |
MaxDouble |
MaxRasterImageSize |
MinDouble |
OnMouseScroll | MouseScroll event message number
RedColorMask |
ToolbarButtonNames | Describes names for Toolbar buttons
XOrtAxis | An end point of X axis ort
YOrtAxis | An end point of Y axis ort
ZOrtAxis | An end point of Z axis ort
cl255 |
clByBlock | A color constant that means an entity's color is determined by block.
clByLayer | A color constant that means an entity's color is determined by layer.
clNone | A color constant that means an entity's color is undefined.
cnstBad2DRect |
cnstBadHandle | A constant of the invalid Handle
entityCount |
iDefaultNumberOfCircleParts | A default number that shows how many sections of a circle is divided into.
iDefaultNumberOfSplineParts | A default number that shows how many sections of a spline is divided into.
lngPathDefault | Default path to language files set
respectImageentRatio |
Top
See Also

Reference

CADConst Class


AlphaColorMask Field

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared ReadOnly AlphaColorMask As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static readonly int AlphaColorMask
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


BlueColorMask Field

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared ReadOnly BlueColorMask As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static readonly int BlueColorMask
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


DPointSingle Field

An end point of vector, recieved by compozition X, Y and Z axis orts.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Shadows ReadOnly DPointSingle As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
new public static readonly DPoint DPointSingle
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


DXFLineWeights Field

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared ReadOnly DXFLineWeights As Integer()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static readonly int[] DXFLineWeights
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


DefaultSHXParameters Field

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared DefaultSHXParameters As FontsParameters
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static FontsParameters DefaultSHXParameters
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


FillHatchesDefault Field

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared FillHatchesDefault As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool FillHatchesDefault
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


GreenColorMask Field

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared ReadOnly GreenColorMask As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static readonly int GreenColorMask
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


LogFilePath Field

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared LogFilePath As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static string LogFilePath
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


MaxDouble Field

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared ReadOnly MaxDouble As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static readonly double MaxDouble
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


MaxRasterImageSize Field

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared MaxRasterImageSize As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static int MaxRasterImageSize
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


MinDouble Field

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared ReadOnly MinDouble As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static readonly double MinDouble
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


OnMouseScroll Field

MouseScroll event message number

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Const OnMouseScroll As Integer = 522
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public const int OnMouseScroll = 522
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


RedColorMask Field

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared ReadOnly RedColorMask As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static readonly int RedColorMask
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


ToolbarButtonNames Field

Describes names for Toolbar buttons

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Shadows ReadOnly ToolbarButtonNames As String()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
new public static readonly string[] ToolbarButtonNames
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


XOrtAxis Field

An end point of X axis ort

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Shadows ReadOnly XOrtAxis As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
new public static readonly DPoint XOrtAxis
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


YOrtAxis Field

An end point of Y axis ort

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Shadows ReadOnly YOrtAxis As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
new public static readonly DPoint YOrtAxis
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


ZOrtAxis Field

An end point of Z axis ort

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Shadows ReadOnly ZOrtAxis As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
new public static readonly DPoint ZOrtAxis
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


cl255 Field

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared ReadOnly cl255 As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static readonly Color cl255
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


clByBlock Field

A color constant that means an entity's color is determined by block.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared ReadOnly clByBlock As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static readonly Color clByBlock
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


clByLayer Field

A color constant that means an entity's color is determined by layer.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared ReadOnly clByLayer As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static readonly Color clByLayer
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


clNone Field

A color constant that means an entity's color is undefined.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared ReadOnly clNone As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static readonly Color clNone
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


cnstBad2DRect Field

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Shadows ReadOnly cnstBad2DRect As Rectangle
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
new public static readonly Rectangle cnstBad2DRect
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


cnstBadHandle Field

A constant of the invalid Handle

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Const cnstBadHandle As UInt64 = 0
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public const UInt64 cnstBadHandle = 0
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


entityCount Field

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared entityCount As UInt64
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static UInt64 entityCount
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


iDefaultNumberOfCircleParts Field

A default number that shows how many sections of a circle is divided into.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Const iDefaultNumberOfCircleParts As Integer = 47
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public const int iDefaultNumberOfCircleParts = 47
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


iDefaultNumberOfSplineParts Field

A default number that shows how many sections of a spline is divided into.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Const iDefaultNumberOfSplineParts As Byte = 24
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public const byte iDefaultNumberOfSplineParts = 24
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


lngPathDefault Field

Default path to language files set

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared ReadOnly lngPathDefault As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static readonly string lngPathDefault
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


respectImageentRatio Field

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared respectImageentRatio As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool respectImageentRatio
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConverter Class

Members See Also

Provides methods for loading a file and producing a set of CAD entities contained in the loaded file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADConverter
    Implements IDisposable
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADConverter : IDisposable
This language is not supported or no code example is available.
Remarks

All loaded entities are descendants of the CADEntity class.

Inheritance Hierarchy
System.Object
CADImport.CADConverter
CADImport.DWG.DWGConverter
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Members


CADConverter Members

CADConverter Class Constructors Events Methods Properties See Also

Provides methods for loading a file and producing a set of CAD entities contained in the loaded file.

The following tables list the members exposed by the CADConverter type.

Constructors
 | Name | Description
Public constructor | CADConverter | Initializes a new instance of the CADConverter class.
Top
Properties
 | Name | Description
Public property | ActiveVPort | Gets or sets active CADVPort object
Public property | AllArcsAsCurves | Gets or sets a value indicating how arcs are drawn.
Public property | Angle | Gets or sets a current rotation angle of the active VPort.
Public property | AutoInsert | Gets or sets a value indicating a way of processing CAD blocks.
Public property | Block | Gets a block to be drawn at spesified layout.
Public property | Blocks | Gets a collection of blocks contained in the loaded CAD file.
Public property | CodePage | Gets or sets a number that identifies the encoding used in the loaded CAD file.
Public property | DWGPROPS | A set of properties for an AutoCAD drawing
Public property | DefaultLayoutIndex | Gets or sets an index of layout that will be shown after opening a CAD file.
Public property | DimensionStyles | Gets a collection of styles used for drawing the dimensions in the loaded CAD file.
Public property | Entities | Gets a collection of entities contained in the loaded CAD file.
Public property | Extents | Gets or sets extents of the loaded CAD file.
Public property | HasActiveVPort | Gets or sets a value idicating whether a loaded CAD file has an active VPort.
Public property | HeadStruct | Gets or sets HeadVarStruct object containing settings of CAD file
Public property | ImageDefs | Gets a collection of raster images contained in the loaded CAD file.
Public property | Is3D | Checks whether a loaded CAD image is three-dimensional.
Public property | IsCrossoverMatrix | Gets or sets a value indicating an orientation of the used coordinate system.
Public property | IsHideWipeouts | Gets or sets a border visibility of all Wipeout objects in CAD file
Public property | IsLoadXrefs | Gets or sets a value indicating whether XRefs to be loaded while opening a CAD file.
Public property | LScale | Gets or sets a scale for all linetypes in the loaded CAD file.
Public property | LTypes | Gets a collection of linetypes contained in the loaded CAD file.
Public property | Layers | Gets a collection of layers contained in the loaded CAD file.
Public property | Layouts | Gets a collection of layouts contained in the loaded CAD file.
Public property | LayoutsCount | Gets a quantity of layouts contained in the loaded CAD file.
Public property | Main | Gets a main section of the loaded CAD file.
Public property | MaxHandle | Gets or sets a maximal handle of a primitive
Public property | ModelLayout | Gets CADLayout object of model
Public property | NumberOfPartsInCircle | Gets or sets a quantity of segments to be used to draw a circle.
Public property | NumberOfPartsInSpline | Gets or sets a quantity of segments to be used to draw a spline.
Public property | Params | Gets or sets parameters to be processed by the Iterate method.
Public property | PointDisplayMode | Gets or sets a value indicating a mode of displaying the CADPoint entities in the loaded CAD file.
Public property | SHXFonts | Gets a list of SHX fonts for the loaded CAD file.
Public property | SHXSettings | Gets SHX fonts settings.
Public property | Source | Gets or sets a path to the loaded file.
Public property | Styles | Gets a collection of styles contained in the loaded CAD file.
Public property | Tables | Gets a collection of tables contained in the loaded CAD file.
Public property | VPort | Gets or sets a viewing direction for the ActiveVPort.
Public property | VPorts | Gets a list of CADVPort objects contained in CAD file
Public property | ViewPortCut | Gets a value indicating whether a loaded CAD file appears inside a viewport.
Public property | XRefs | Gets a collection of external references contained in the loaded CAD file.
Top
Methods
 | Name | Description
Public method | AddDrawingLayout | Creates a CADLayout with the specified name and adds this layout to the specified CAD image.
Public method | AddLayout | Adds object of the CADLayout class.
Public method | AddXRef | Creates a CADXRef object with the specified name and adds this external reference to the specified CAD image.
Public method | AddXRefEx | Creates a CADXRef object with the specified name and adds this external reference to the specified CAD image.
Public method | BlockByName | Searches blocks section and returns a CADBlock object with the specified name.
Public method | CleaningLayouts | Deletes all empty instances of the CADLayout class with the exception of the Model_Space layout.
Public method | DimensionStyleByName | Searches a dimension style with the specified name among the dimension styles from the loaded CAD file.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | DoExtents | Sets extents of the CAD drawing.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetArrowTypeByName | Searches a specified dimension arrow name in array
Public method | GetCounts | Returns a number of elements in the specified section.
Public method | GetDWGCodePage | Returns a number of codepage
Public method | GetDWGVersion | Returns a version of DWG or DXF file
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLayerNames | Adds the names of all layers from the loaded CAD file to the specified list.
Public method | GetSection | Returns a group of objects corresponding to the specified type of CAD section.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Initialize | Initializes a main section of the loaded CAD file.
Public method | InitializeSections | This method makes necessary initializations for sections. Call it when creating CAD object manually.
 | IntToColor | Converts an int value to the Color object.
Public method | Iterate | Invokes a method referenced by the specified delegate for each loaded entity.
Public method | LTypeByName | Returns a linetype with the specified name.
Public method | LayerByName | Returns a layer with the specified name.
Public method | LayoutByName | Searches layouts section and returns a CADLayout object with the specified name.
Public method | LinesByName | Returns a description of linetype with the specified name.
Public method | Loads | Loads the specified entity to the CADConverter.
Public method | OnAfterRead | Raises a AfterReadEvent.
Public method | OnBeforeRead | Raises a BeforeReadEvent.
Public method | OnCreate | Raises an OnCreateEvent.
Public method | OnInsert | Raises an OnInsertEvent.
Public method | OnResolveXRef | Raises an OnResolveXRefEvent.
Public method | OnViewPort | Raises an OnViewPortEvent.
Public method | OnXRef | Raises an OnXRefEvent.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetHandle | Sets a handle for a CADEntity object.
Public method | SetSection | Sets a CADGroup object to the specified section type.
Public method | SortEntities | Sorts CAD entities by their handles according to the CADSortEntsTable loaded from the CAD file.
Public method | StyleByName | Returns a style with the specified name.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Events
 | Name | Description
Public event | AfterReadEvent | Occurs after reading a DXF file.
Public event | BeforeReadEvent | Occurs before reading a DXF file.
Public event | OnCreateEvent | Occurs when an instance of each loaded CAD entity is created.
Public event | OnInsertEvent | Occurs when an object of the CADInsert class or its descendants inserted into a CAD image.
 | OnResolveXRefEvent | Occurs when xref filename not found.
Public event | OnViewPortEvent | Occurs when loading a CADViewPort object into a CAD image is complete.
Top
See Also

Reference

CADConverter Class


CADConverter Constructor

Initializes a new instance of the CADConverter class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADConverter()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter Properties

CADConverter Class See Also

The following tables list the members exposed by the CADConverter type.

Properties
 | Name | Description
Public property | ActiveVPort | Gets or sets active CADVPort object
Public property | AllArcsAsCurves | Gets or sets a value indicating how arcs are drawn.
Public property | Angle | Gets or sets a current rotation angle of the active VPort.
Public property | AutoInsert | Gets or sets a value indicating a way of processing CAD blocks.
Public property | Block | Gets a block to be drawn at spesified layout.
Public property | Blocks | Gets a collection of blocks contained in the loaded CAD file.
Public property | CodePage | Gets or sets a number that identifies the encoding used in the loaded CAD file.
Public property | DWGPROPS | A set of properties for an AutoCAD drawing
Public property | DefaultLayoutIndex | Gets or sets an index of layout that will be shown after opening a CAD file.
Public property | DimensionStyles | Gets a collection of styles used for drawing the dimensions in the loaded CAD file.
Public property | Entities | Gets a collection of entities contained in the loaded CAD file.
Public property | Extents | Gets or sets extents of the loaded CAD file.
Public property | HasActiveVPort | Gets or sets a value idicating whether a loaded CAD file has an active VPort.
Public property | HeadStruct | Gets or sets HeadVarStruct object containing settings of CAD file
Public property | ImageDefs | Gets a collection of raster images contained in the loaded CAD file.
Public property | Is3D | Checks whether a loaded CAD image is three-dimensional.
Public property | IsCrossoverMatrix | Gets or sets a value indicating an orientation of the used coordinate system.
Public property | IsHideWipeouts | Gets or sets a border visibility of all Wipeout objects in CAD file
Public property | IsLoadXrefs | Gets or sets a value indicating whether XRefs to be loaded while opening a CAD file.
Public property | LScale | Gets or sets a scale for all linetypes in the loaded CAD file.
Public property | LTypes | Gets a collection of linetypes contained in the loaded CAD file.
Public property | Layers | Gets a collection of layers contained in the loaded CAD file.
Public property | Layouts | Gets a collection of layouts contained in the loaded CAD file.
Public property | LayoutsCount | Gets a quantity of layouts contained in the loaded CAD file.
Public property | Main | Gets a main section of the loaded CAD file.
Public property | MaxHandle | Gets or sets a maximal handle of a primitive
Public property | ModelLayout | Gets CADLayout object of model
Public property | NumberOfPartsInCircle | Gets or sets a quantity of segments to be used to draw a circle.
Public property | NumberOfPartsInSpline | Gets or sets a quantity of segments to be used to draw a spline.
Public property | Params | Gets or sets parameters to be processed by the Iterate method.
Public property | PointDisplayMode | Gets or sets a value indicating a mode of displaying the CADPoint entities in the loaded CAD file.
Public property | SHXFonts | Gets a list of SHX fonts for the loaded CAD file.
Public property | SHXSettings | Gets SHX fonts settings.
Public property | Source | Gets or sets a path to the loaded file.
Public property | Styles | Gets a collection of styles contained in the loaded CAD file.
Public property | Tables | Gets a collection of tables contained in the loaded CAD file.
Public property | VPort | Gets or sets a viewing direction for the ActiveVPort.
Public property | VPorts | Gets a list of CADVPort objects contained in CAD file
Public property | ViewPortCut | Gets a value indicating whether a loaded CAD file appears inside a viewport.
Public property | XRefs | Gets a collection of external references contained in the loaded CAD file.
Top
See Also

Reference

CADConverter Class


CADConverter.ActiveVPort Property

Gets or sets active CADVPort object

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ActiveVPort() As CADVPort
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADVPort ActiveVPort {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.AllArcsAsCurves Property

Gets or sets a value indicating how arcs are drawn.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property AllArcsAsCurves() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool AllArcsAsCurves {get; set;}
This language is not supported or no code example is available.

Property Value

true if arcs are drawn by means of GDI+; false, if arcs are drawn as polylines.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.Angle Property

Gets or sets a current rotation angle of the active VPort.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Angle() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float Angle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.AutoInsert Property

Gets or sets a value indicating a way of processing CAD blocks.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property AutoInsert() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool AutoInsert {get; set;}
This language is not supported or no code example is available.

Property Value

true if CAD blocks are processed without any conditions; otherwise, false.
Remarks

If this property is set to true, the CADEntityProc delegate does not reference any methods for the CADInsert object when calling the Iterate method.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.Block Property

Gets a block to be drawn at spesified layout.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Block() As CADBlock
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADBlock Block {get;}
This language is not supported or no code example is available.

Property Value

A CADBlock containing the entities
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.Blocks Property

Gets a collection of blocks contained in the loaded CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Blocks() As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntityCollection Blocks {get;}
This language is not supported or no code example is available.

Property Value

A CADEntityCollection containing blocks from the loaded CAD file.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.CodePage Property

Gets or sets a number that identifies the encoding used in the loaded CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property CodePage() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int CodePage {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.DWGPROPS Property

A set of properties for an AutoCAD drawing

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property DWGPROPS() As DWGProps
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DWGProps DWGPROPS {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.DefaultLayoutIndex Property

Gets or sets an index of layout that will be shown after opening a CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DefaultLayoutIndex() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int DefaultLayoutIndex {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.DimensionStyles Property

Gets a collection of styles used for drawing the dimensions in the loaded CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property DimensionStyles() As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntityCollection DimensionStyles {get;}
This language is not supported or no code example is available.

Property Value

A CADEntityCollection containing the dimension styles used in the loaded CAD file.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.Entities Property

Gets a collection of entities contained in the loaded CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Entities() As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntityCollection Entities {get;}
This language is not supported or no code example is available.

Property Value

A CADEntityCollection containing the entities in the loaded CAD file.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.Extents Property

Gets or sets extents of the loaded CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Extents() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DRect Extents {get; set;}
This language is not supported or no code example is available.

Property Value

A DRect object representing extents of a CAD file.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.HasActiveVPort Property

Gets or sets a value idicating whether a loaded CAD file has an active VPort.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property HasActiveVPort() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool HasActiveVPort {get; set;}
This language is not supported or no code example is available.

Property Value

true if CAD file has an active VPort; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.HeadStruct Property

Gets or sets HeadVarStruct object containing settings of CAD file

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property HeadStruct() As HeadVarStruct
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public HeadVarStruct HeadStruct {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.ImageDefs Property

Gets a collection of raster images contained in the loaded CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property ImageDefs() As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntityCollection ImageDefs {get;}
This language is not supported or no code example is available.

Property Value

A CADEntityCollection containing the raster images in the loaded CAD file.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.Is3D Property

Checks whether a loaded CAD image is three-dimensional.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Is3D() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Is3D {get;}
This language is not supported or no code example is available.

Property Value

true if the loaded CAD image is three-dimensional; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.IsCrossoverMatrix Property

Gets or sets a value indicating an orientation of the used coordinate system.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property IsCrossoverMatrix() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsCrossoverMatrix {get; set;}
This language is not supported or no code example is available.

Property Value

true if the zero point is located in the bottom-left corner; false, if the zero point is located in the top-left corner.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.IsHideWipeouts Property

Gets or sets a border visibility of all Wipeout objects in CAD file

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property IsHideWipeouts() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsHideWipeouts {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.IsLoadXrefs Property

Gets or sets a value indicating whether XRefs to be loaded while opening a CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property IsLoadXrefs() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsLoadXrefs {get; set;}
This language is not supported or no code example is available.

Property Value

true if XRefs are to be loaded; false, if XRefs are not to be loaded.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.LScale Property

Gets or sets a scale for all linetypes in the loaded CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LScale() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double LScale {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.LTypes Property

Gets a collection of linetypes contained in the loaded CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property LTypes() As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntityCollection LTypes {get;}
This language is not supported or no code example is available.

Property Value

A CADEntityCollection containing linetypes in the loaded CAD file.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.Layers Property

Gets a collection of layers contained in the loaded CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Layers() As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntityCollection Layers {get;}
This language is not supported or no code example is available.

Property Value

A CADEntityCollection containing the layers in the loaded CAD file.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.Layouts Property

Gets a collection of layouts contained in the loaded CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Layouts() As CADLayoutCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADLayoutCollection Layouts {get;}
This language is not supported or no code example is available.

Property Value

A CADEntityCollection containing the layouts in the loaded CAD file.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.LayoutsCount Property

Gets a quantity of layouts contained in the loaded CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property LayoutsCount() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int LayoutsCount {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.Main Property

Gets a main section of the loaded CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Main() As CADSection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADSection Main {get;}
This language is not supported or no code example is available.
Remarks

A main section is the section that contains other sections of the CAD file.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.MaxHandle Property

Gets or sets a maximal handle of a primitive

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property MaxHandle() As UInt64
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public UInt64 MaxHandle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.ModelLayout Property

Gets CADLayout object of model

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property ModelLayout() As CADLayout
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADLayout ModelLayout {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.NumberOfPartsInCircle Property

Gets or sets a quantity of segments to be used to draw a circle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property NumberOfPartsInCircle() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int NumberOfPartsInCircle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.NumberOfPartsInSpline Property

Gets or sets a quantity of segments to be used to draw a spline.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property NumberOfPartsInSpline() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int NumberOfPartsInSpline {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.Params Property

Gets or sets parameters to be processed by the Iterate method.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Params() As CADIterate
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADIterate Params {get; set;}
This language is not supported or no code example is available.

Property Value

A CADIterate object that contains the parameters.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.PointDisplayMode Property

Gets or sets a value indicating a mode of displaying the CADPoint entities in the loaded CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PointDisplayMode() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int PointDisplayMode {get; set;}
This language is not supported or no code example is available.

Property Value

zero if CADPoints are visible; 1 if CADPoints are invisible.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.SHXFonts Property

Gets a list of SHX fonts for the loaded CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property SHXFonts() As SHXFontList
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SHXFontList SHXFonts {get;}
This language is not supported or no code example is available.
Remarks

SHX fonts search occurs after loading a CAD file.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.SHXSettings Property

Gets SHX fonts settings.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property SHXSettings() As FontsParameters
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public FontsParameters SHXSettings {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.Source Property

Gets or sets a path to the loaded file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Source() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Source {get; set;}
This language is not supported or no code example is available.

Property Value

A string containing a path to the loaded file.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.Styles Property

Gets a collection of styles contained in the loaded CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Styles() As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntityCollection Styles {get;}
This language is not supported or no code example is available.

Property Value

A CADEntityCollection containing styles in the loaded CAD file.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.Tables Property

Gets a collection of tables contained in the loaded CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Tables() As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntityCollection Tables {get;}
This language is not supported or no code example is available.

Property Value

A CADEntityCollection containing tables in the loaded CAD file.
Remarks

The returned collection realizes the indexed access to all tables described in section TABLES of a DXF-file or loaded from other supported CAD files.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.VPort Property

Gets or sets a viewing direction for the ActiveVPort.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property VPort() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint VPort {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object that specifies a viewing direction for the active VPort.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.VPorts Property

Gets a list of CADVPort objects contained in CAD file

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property VPorts() As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntityCollection VPorts {get;}
This language is not supported or no code example is available.

Property Value

A CADEntityCollection containing the layouts in the loaded CAD file.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.ViewPortCut Property

Gets a value indicating whether a loaded CAD file appears inside a viewport.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property ViewPortCut() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool ViewPortCut {get;}
This language is not supported or no code example is available.

Property Value

true if a loaded CAD file appears inside a viewport; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.XRefs Property

Gets a collection of external references contained in the loaded CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property XRefs() As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntityCollection XRefs {get;}
This language is not supported or no code example is available.

Property Value

A CADEntityCollection containing the external references in the loaded CAD file.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter Methods

CADConverter Class See Also

The following tables list the members exposed by the CADConverter type.

Methods
 | Name | Description
Public method | AddDrawingLayout | Creates a CADLayout with the specified name and adds this layout to the specified CAD image.
Public method | AddLayout | Adds object of the CADLayout class.
Public method | AddXRef | Creates a CADXRef object with the specified name and adds this external reference to the specified CAD image.
Public method | AddXRefEx | Creates a CADXRef object with the specified name and adds this external reference to the specified CAD image.
Public method | BlockByName | Searches blocks section and returns a CADBlock object with the specified name.
Public method | CleaningLayouts | Deletes all empty instances of the CADLayout class with the exception of the Model_Space layout.
Public method | DimensionStyleByName | Searches a dimension style with the specified name among the dimension styles from the loaded CAD file.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | DoExtents | Sets extents of the CAD drawing.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetArrowTypeByName | Searches a specified dimension arrow name in array
Public method | GetCounts | Returns a number of elements in the specified section.
Public method | GetDWGCodePage | Returns a number of codepage
Public method | GetDWGVersion | Returns a version of DWG or DXF file
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLayerNames | Adds the names of all layers from the loaded CAD file to the specified list.
Public method | GetSection | Returns a group of objects corresponding to the specified type of CAD section.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Initialize | Initializes a main section of the loaded CAD file.
Public method | InitializeSections | This method makes necessary initializations for sections. Call it when creating CAD object manually.
 | IntToColor | Converts an int value to the Color object.
Public method | Iterate | Invokes a method referenced by the specified delegate for each loaded entity.
Public method | LTypeByName | Returns a linetype with the specified name.
Public method | LayerByName | Returns a layer with the specified name.
Public method | LayoutByName | Searches layouts section and returns a CADLayout object with the specified name.
Public method | LinesByName | Returns a description of linetype with the specified name.
Public method | Loads | Loads the specified entity to the CADConverter.
Public method | OnAfterRead | Raises a AfterReadEvent.
Public method | OnBeforeRead | Raises a BeforeReadEvent.
Public method | OnCreate | Raises an OnCreateEvent.
Public method | OnInsert | Raises an OnInsertEvent.
Public method | OnResolveXRef | Raises an OnResolveXRefEvent.
Public method | OnViewPort | Raises an OnViewPortEvent.
Public method | OnXRef | Raises an OnXRefEvent.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetHandle | Sets a handle for a CADEntity object.
Public method | SetSection | Sets a CADGroup object to the specified section type.
Public method | SortEntities | Sorts CAD entities by their handles according to the CADSortEntsTable loaded from the CAD file.
Public method | StyleByName | Returns a style with the specified name.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADConverter Class


CADConverter.AddDrawingLayout Method

Creates a CADLayout with the specified name and adds this layout to the specified CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddDrawingLayout( _
   ByVal ACADImage As Object, _
   ByVal AName As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddDrawingLayout(
   object ACADImage,
   string AName
)
This language is not supported or no code example is available.

Parameters

ACADImage

Type: object

An Object that represents a CAD image where the newly created layout will be added.

AName

Type: string

A string containing a name for the newly created layout.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.AddLayout Method

Adds object of the CADLayout class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddLayout( _
   ByRef layout As CADLayout _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddLayout(
   out CADLayout layout
)
This language is not supported or no code example is available.

Parameters

layout

Type: CADLayout

Object of the CADLayout class.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.AddXRef Method

Creates a CADXRef object with the specified name and adds this external reference to the specified CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddXRef( _
   ByVal ACADFile As CADImage, _
   ByVal AName As String, _
   ByVal APos As DPoint, _
   ByVal AScale As DPoint, _
   ByVal Rotation As Single _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddXRef(
   CADImage ACADFile,
   string AName,
   DPoint APos,
   DPoint AScale,
   float Rotation
)
This language is not supported or no code example is available.

Parameters

ACADFile

Type: CADImage

A CADImage where the created external reference will be added.

AName

Type: string

A string containing a name for the newly created external reference.

APos

Type: DPoint

A DPoint object representing an insertion point for the newly created external reference.

AScale

Type: DPoint

A DPoint object representing a scale for the newly created external reference.

Rotation

Type: float

A rotation angle for the newly created external reference.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.AddXRefEx Method

Creates a CADXRef object with the specified name and adds this external reference to the specified CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function AddXRefEx( _
   ByVal ACADFile As CADImage, _
   ByVal AName As String, _
   ByVal APos As DPoint, _
   ByVal AScale As DPoint, _
   ByVal Rotation As Single, _
   ByRef layout As CADLayout _
) As CADInsert
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADInsert AddXRefEx(
   CADImage ACADFile,
   string AName,
   DPoint APos,
   DPoint AScale,
   float Rotation,
   out CADLayout layout
)
This language is not supported or no code example is available.

Parameters

ACADFile

Type: CADImage

A CADImage where the created external reference will be added.

AName

Type: string

A string containing a name for the newly created external reference.

APos

Type: DPoint

A DPoint object representing an insertion point for the newly created external reference.

AScale

Type: DPoint

A DPoint object representing a scale for the newly created external reference.

Rotation

Type: float

A rotation angle for the newly created external reference.

layout

Type: CADLayout

The layout which the XRef entity will be added to.

Remarks

The created external reference is added to the default layout.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.BlockByName Method

Searches blocks section and returns a CADBlock object with the specified name.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function BlockByName( _
   ByVal AName As String _
) As CADBlock
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADBlock BlockByName(
   string AName
)
This language is not supported or no code example is available.

Parameters

AName

Type: string

The name of a block

Return Value

The block with the specified name. Null if the block is not found
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.CleaningLayouts Method

Deletes all empty instances of the CADLayout class with the exception of the Model_Space layout.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub CleaningLayouts( _
   ByVal ADeletePSpace As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void CleaningLayouts(
   bool ADeletePSpace
)
This language is not supported or no code example is available.

Parameters

ADeletePSpace

Type: bool

A value indicating whether a Paper_Space layout must be deleted. true, if a Paper_Space layout has to be deleted; otherwise, false.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.DimensionStyleByName Method

Searches a dimension style with the specified name among the dimension styles from the loaded CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function DimensionStyleByName( _
   ByVal AName As String _
) As CADDimensionStyle
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADDimensionStyle DimensionStyleByName(
   string AName
)
This language is not supported or no code example is available.

Parameters

AName

Type: string

A name of the dimension style to search.

Return Value

A CADDimensionStyle object that has the specified name.
Remarks

If it doesn't find such dimension style it creates a CADDimensionStyle object that has the specified name.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub Dispose() Implements  _
   IDisposable.Dispose
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void Dispose()
This language is not supported or no code example is available.

Implements

IDisposable.Dispose
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.DoExtents Method

Sets extents of the CAD drawing.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DoExtents()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DoExtents()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.GetArrowTypeByName Method

Searches a specified dimension arrow name in array

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetArrowTypeByName( _
   ByVal str As String, _
   ByVal defVal As Byte _
) As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte GetArrowTypeByName(
   string str,
   byte defVal
)
This language is not supported or no code example is available.

Parameters

str

Type: string

A name of the dimension arrow

defVal

Type: byte

A default dimension arrow type

Return Value

A type of the specified dimension arrow
Remarks

If the specified name not found, returns default dimension arrow type

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.GetCounts Method

Returns a number of elements in the specified section.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetCounts( _
   ByVal aInd As ConvSection _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int GetCounts(
   ConvSection aInd
)
This language is not supported or no code example is available.

Parameters

aInd

Type: ConvSection

One of the ConvSection values that specify the section in the loaded CAD file.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.GetDWGCodePage Method

Returns a number of codepage

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetDWGCodePage( _
   ByVal str As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int GetDWGCodePage(
   string str
)
This language is not supported or no code example is available.

Parameters

str

Type: string

A string containing codepage name

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.GetDWGVersion Method

Returns a version of DWG or DXF file

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetDWGVersion( _
   ByVal str As String _
) As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte GetDWGVersion(
   string str
)
This language is not supported or no code example is available.

Parameters

str

Type: string

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.GetLayerNames Method

Adds the names of all layers from the loaded CAD file to the specified list.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub GetLayerNames( _
   ByVal S As ArrayList, _
   ByVal DoClear As Boolean, _
   ByVal IncludeUnused As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void GetLayerNames(
   ArrayList S,
   bool DoClear,
   bool IncludeUnused
)
This language is not supported or no code example is available.

Parameters

S

Type: ArrayList

An ArrayList where the names of layers will be added.

DoClear

Type: bool

A value indicating whether to clear the specified ArrayList before adding the names of layers to it.

IncludeUnused

Type: bool

A value indicating whether to include the names of layers that don't contain any entities.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.GetSection Method

Returns a group of objects corresponding to the specified type of CAD section.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetSection( _
   ByVal Index As ConvSection _
) As CADGroup
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADGroup GetSection(
   ConvSection Index
)
This language is not supported or no code example is available.

Parameters

Index

Type: ConvSection

One of the ConvSection values that specify the section in the loaded CAD file.

Return Value

A CADGroup object representing a group of objects from the loaded CAD file.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.Initialize Method

Initializes a main section of the loaded CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub Initialize()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void Initialize()
This language is not supported or no code example is available.
Remarks

A main section is specified by the Main property.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.InitializeSections Method

This method makes necessary initializations for sections. Call it when creating CAD object manually.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub InitializeSections()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void InitializeSections()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.IntToColor Method

Converts an int value to the Color object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function IntToColor( _
   ByVal Value As Integer _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static Color IntToColor(
   int Value
)
This language is not supported or no code example is available.

Parameters

Value

Type: int

An int value to convert.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.Iterate Method

Invokes a method referenced by the specified delegate for each loaded entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Iterate( _
   ByVal convProc As CADEntityProc, _
   ByVal finishProc As CADEntityProc, _
   ByVal Params As CADIterate _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Iterate(
   CADEntityProc convProc,
   CADEntityProc finishProc,
   CADIterate Params
)
This language is not supported or no code example is available.

Parameters

convProc

Type: CADEntityProc

A CADEntityProc delegate that specifies a method to be invoked.

finishProc

Type: CADEntityProc

A CADEntityProc delegate that specifies a method to be finished

Params

Type: CADIterate

A CADIterate object that provides parameters used for setting the CADConverter before invoking the specified method for each loaded entity.

Remarks

This method invokes the referenced (by the delegate) method for each existing entity including block references (inserts) of any nesting level. In other words, this method converts CAD tree structure to a linear sequence of entities. It is a basis for different operations such as drawing or importing the CAD files. Before invoking a referenced procedure it is necessary to set the matrix. This matrix changes automatically on entering a block reference and restores when exiting from it. An additional is a user defined parameter. All other CADIterate fields are initialized by the Iterate method.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.LTypeByName Method

Returns a linetype with the specified name.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function LTypeByName( _
   ByVal AName As String _
) As CADLineType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADLineType LTypeByName(
   string AName
)
This language is not supported or no code example is available.

Parameters

AName

Type: string

A string containing a name of the linetype to be returned.

Return Value

A CADLineType object that has the specified name or null if the linetype with such name was not found.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.LayerByName Method

Returns a layer with the specified name.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function LayerByName( _
   ByVal AName As String _
) As CADLayer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADLayer LayerByName(
   string AName
)
This language is not supported or no code example is available.

Parameters

AName

Type: string

A name of the layer to return.

Return Value

A CADLayer object that has the specified name.
Remarks

This method searches a layer with the specified name among the layers from the loaded CAD file. If it doesn't find such layer it creates a CADLayer object that has the specified name.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.LayoutByName Method

Searches layouts section and returns a CADLayout object with the specified name.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function LayoutByName( _
   ByVal AName As String _
) As CADLayout
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADLayout LayoutByName(
   string AName
)
This language is not supported or no code example is available.

Parameters

AName

Type: string

Return Value

The layout with the specified name. Null if the block is not found
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.LinesByName Method

Returns a description of linetype with the specified name.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function LinesByName( _
   ByVal AName As String _
) As SGLines
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SGLines LinesByName(
   string AName
)
This language is not supported or no code example is available.

Parameters

AName

Type: string

A string containing a name of the linetype to be returned.

Return Value

A sgLines object representing a found linetype or null if the linetype was not found.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.Loads Method

Loads the specified entity to the CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Loads( _
   ByVal E As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Loads(
   CADEntity E
)
This language is not supported or no code example is available.

Parameters

E

Type: CADEntity

A CADEntity to be loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.OnAfterRead Method

Raises a AfterReadEvent.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub OnAfterRead( _
   ByVal Sender As Object _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void OnAfterRead(
   object Sender
)
This language is not supported or no code example is available.

Parameters

Sender

Type: object

A CADConverter object that initiates a AfterReadEvent.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.OnBeforeRead Method

Raises a BeforeReadEvent.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub OnBeforeRead( _
   ByVal Sender As Object _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void OnBeforeRead(
   object Sender
)
This language is not supported or no code example is available.

Parameters

Sender

Type: object

A CADConverter object that initiates a BeforeReadEvent.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.OnCreate Method

Raises an OnCreateEvent.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub OnCreate( _
   ByVal Sender As Object _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void OnCreate(
   object Sender
)
This language is not supported or no code example is available.

Parameters

Sender

Type: object

A CAD entity that initiates an OnCreateEvent.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.OnInsert Method

Raises an OnInsertEvent.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub OnInsert( _
   ByVal Sender As Object _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void OnInsert(
   object Sender
)
This language is not supported or no code example is available.

Parameters

Sender

Type: object

An object of the CADInsert class or its descendants that initiates an insertion event.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.OnResolveXRef Method

Raises an OnResolveXRefEvent.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub OnResolveXRef( _
   ByRef xrefPath As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void OnResolveXRef(
   ref string xrefPath
)
This language is not supported or no code example is available.

Parameters

xrefPath

Type: string

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.OnViewPort Method

Raises an OnViewPortEvent.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub OnViewPort( _
   ByVal Sender As Object _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void OnViewPort(
   object Sender
)
This language is not supported or no code example is available.

Parameters

Sender

Type: object

A CADViewPort object that initiates an OnViewPortEvent.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.OnXRef Method

Raises an OnXRefEvent.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub OnXRef( _
   ByVal Sender As Object _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void OnXRef(
   object Sender
)
This language is not supported or no code example is available.

Parameters

Sender

Type: object

A CADXRef object that initiates an OnXRefEvent.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.SetHandle Method

Sets a handle for a CADEntity object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetHandle( _
   ByVal ent As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetHandle(
   CADEntity ent
)
This language is not supported or no code example is available.

Parameters

ent

Type: CADEntity

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.SetSection Method

Sets a CADGroup object to the specified section type.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetSection( _
   ByVal Index As ConvSection, _
   ByVal Value As CADPlotEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetSection(
   ConvSection Index,
   CADPlotEntity Value
)
This language is not supported or no code example is available.

Parameters

Index

Type: ConvSection

One of the ConvSection values that specify the section type.

Value

Type: CADPlotEntity

A CADGroup object that is set to the specified section type.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.SortEntities Method

Sorts CAD entities by their handles according to the CADSortEntsTable loaded from the CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SortEntities()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SortEntities()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter.StyleByName Method

Returns a style with the specified name.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function StyleByName( _
   ByVal aName As String _
) As CADStyle
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADStyle StyleByName(
   string aName
)
This language is not supported or no code example is available.

Parameters

aName

Type: string

A name of the style to return.

Return Value

A CADStyle object that has the specified name.
Remarks

This method searches a style with the specified name among the styles from the loaded CAD file. If it doesn't find such style it creates a CADStyle object that has the specified name.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADConverter Events

CADConverter Class See Also

The following tables list the members exposed by the CADConverter type.

Events
 | Name | Description
Public event | AfterReadEvent | Occurs after reading a DXF file.
Public event | BeforeReadEvent | Occurs before reading a DXF file.
Public event | OnCreateEvent | Occurs when an instance of each loaded CAD entity is created.
Public event | OnInsertEvent | Occurs when an object of the CADInsert class or its descendants inserted into a CAD image.
 | OnResolveXRefEvent | Occurs when xref filename not found.
Public event | OnViewPortEvent | Occurs when loading a CADViewPort object into a CAD image is complete.
Top
See Also

Reference

CADConverter Class


AfterReadEvent Event

Occurs after reading a DXF file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event AfterReadEvent() As CADImport.EventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.EventHandler AfterReadEvent
This language is not supported or no code example is available.
Remarks

<p>Use an AfterReadEvent handler to take specific actions immediately after the CADConverter has read a DXF file.</p> <p>AfterReadEvent is generated by calls to the Load method.</p>

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


BeforeReadEvent Event

Occurs before reading a DXF file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event BeforeReadEvent() As CADImport.EventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.EventHandler BeforeReadEvent
This language is not supported or no code example is available.
Remarks

This event can be used for creating a progress bar that shows a progress of loading CAD entities.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


OnCreateEvent Event

Occurs when an instance of each loaded CAD entity is created.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event OnCreateEvent() As CADImport.EventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.EventHandler OnCreateEvent
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


OnInsertEvent Event

Occurs when an object of the CADInsert class or its descendants inserted into a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event OnInsertEvent() As CADImport.EventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.EventHandler OnInsertEvent
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


OnResolveXRefEvent Event

Occurs when xref filename not found.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event OnResolveXRefEvent() As CADImport.CADXRefResolver
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADXRefResolver OnResolveXRefEvent
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


OnViewPortEvent Event

Occurs when loading a CADViewPort object into a CAD image is complete.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event OnViewPortEvent() As CADImport.EventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.EventHandler OnViewPortEvent
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConverter Class
CADConverter Members


CADCurvePolygon Class

Members See Also

Represents a hatch with a border of arbitrary shape.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADCurvePolygon
    Inherits CADGradientPolygon
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADCurvePolygon : CADGradientPolygon
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPolyPolygon
CADImport.CADGradientPolygon
CADImport.CADCurvePolygon
CADImport.CADHatch
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCurvePolygon Members


CADCurvePolygon Members

CADCurvePolygon Class Constructors Methods Fields Properties See Also

Represents a hatch with a border of arbitrary shape.

The following tables list the members exposed by the CADCurvePolygon type.

Constructors
 | Name | Description
Public constructor | CADCurvePolygon | Initializes a new instance of the CADCurvePolygon class.
Top
Properties
 | Name | Description
Public property | Boundaries | Gets a collection of boundaries of this CADPolyPolygon. (inherited from CADPolyPolygon).
Public property | BoundaryData | Gets a list of borders for this CADCurvePolygon.
Public property | Box | Gets a three-dimensional box that encloses this CADPolyPolygon. (inherited from CADPolyPolygon).
Public property | Color | Gets or sets a color of this CADPolyPolygon. (inherited from CADPolyPolygon).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | Elevation | Gets or sets a distance on which this CADCurvePolygon is elevated along the Z axis.
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADCurvePolygon entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets the Z axis direction of the CADCurvePolygon object coordinate system.
Public property | Filled | (inherited from CADPolyPolygon).
Public property | GradientColor | Gets or sets a gradient color. (inherited from CADGradientPolygon).
Public property | GradientName | Gets or sets a name of the gradient. (inherited from CADGradientPolygon).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPolyPolygon).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Destroy | Clears a borders list of this CADCurvePolygon.
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADCurvePolygon must be drawn during a drawing cycle.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADPolyPolygon to the specified CADConverter. (inherited from CADPolyPolygon).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADCurvePolygon Class


CADCurvePolygon Constructor

Initializes a new instance of the CADCurvePolygon class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCurvePolygon()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCurvePolygon Class
CADCurvePolygon Members


CADCurvePolygon Properties

CADCurvePolygon Class See Also

The following tables list the members exposed by the CADCurvePolygon type.

Properties
 | Name | Description
Public property | Boundaries | Gets a collection of boundaries of this CADPolyPolygon. (inherited from CADPolyPolygon).
Public property | BoundaryData | Gets a list of borders for this CADCurvePolygon.
Public property | Box | Gets a three-dimensional box that encloses this CADPolyPolygon. (inherited from CADPolyPolygon).
Public property | Color | Gets or sets a color of this CADPolyPolygon. (inherited from CADPolyPolygon).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | Elevation | Gets or sets a distance on which this CADCurvePolygon is elevated along the Z axis.
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADCurvePolygon entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets the Z axis direction of the CADCurvePolygon object coordinate system.
Public property | Filled | (inherited from CADPolyPolygon).
Public property | GradientColor | Gets or sets a gradient color. (inherited from CADGradientPolygon).
Public property | GradientName | Gets or sets a name of the gradient. (inherited from CADGradientPolygon).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPolyPolygon).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
See Also

Reference

CADCurvePolygon Class


CADPolyPolygon.Boundaries Property

Gets a collection of boundaries of this CADPolyPolygon.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Boundaries() As CADCollection(Of CADCollection(Of CAD2DPoint))
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection<CADCollection<CAD2DPoint>> Boundaries {get;}
This language is not supported or no code example is available.

Property Value

An ArrayList containing the CADPolyPolygon boundaries.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyPolygon Class
CADPolyPolygon Members


CADCurvePolygon.BoundaryData Property

Gets a list of borders for this CADCurvePolygon.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property BoundaryData() As CADCollection(Of CAD2DBoundaryList)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection<CAD2DBoundaryList> BoundaryData {get;}
This language is not supported or no code example is available.

Property Value

An ArrayList containing the lists of entities that form a border for this CADCurvePolygon.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCurvePolygon Class
CADCurvePolygon Members


CADPolyPolygon.Box Property

Gets a three-dimensional box that encloses this CADPolyPolygon.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Box() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override DRect Box {get;}
This language is not supported or no code example is available.

Property Value

A DRect object representing the enclosing box for this CADPolyPolygon.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyPolygon Class
CADPolyPolygon Members


CADPolyPolygon.Color Property

Gets or sets a color of this CADPolyPolygon.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Color() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override Color Color {get; set;}
This language is not supported or no code example is available.

Property Value

A Color of this CADPolyPolygon.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyPolygon Class
CADPolyPolygon Members


CADCurvePolygon.Elevation Property

Gets or sets a distance on which this CADCurvePolygon is elevated along the Z axis.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Elevation() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Elevation {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object that defines the elevation level of this CADCurvePolygon along the Z axis in the object coordinate system.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCurvePolygon Class
CADCurvePolygon Members


CADCurvePolygon.EntType Property

Gets the type of this CADCurvePolygon entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCurvePolygon Class
CADCurvePolygon Members


CADCurvePolygon.Extrusion Property

Gets or sets the Z axis direction of the CADCurvePolygon object coordinate system.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Extrusion() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Extrusion {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object that defines the Z axis direction of the CADCurvePolygon object coordinate system in the world coordinate system.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCurvePolygon Class
CADCurvePolygon Members


CADPolyPolygon.Filled Property

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Filled() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Filled {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyPolygon Class
CADPolyPolygon Members


CADGradientPolygon.GradientColor Property

Gets or sets a gradient color.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property GradientColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Color GradientColor {get; set;}
This language is not supported or no code example is available.

Property Value

A Color object representing the gradient color.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGradientPolygon Class
CADGradientPolygon Members


CADGradientPolygon.GradientName Property

Gets or sets a name of the gradient.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property GradientName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string GradientName {get; set;}
This language is not supported or no code example is available.

Property Value

A string containing a name of the gradient.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGradientPolygon Class
CADGradientPolygon Members


CADPolyPolygon.Visibility Property

Gets or sets a value indicating whether a CADPlotEntity is visible.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Visibility() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool Visibility {get; set;}
This language is not supported or no code example is available.

Property Value

true if a CADPlotEntity is visible; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyPolygon Class
CADPolyPolygon Members


CADCurvePolygon Methods

CADCurvePolygon Class See Also

The following tables list the members exposed by the CADCurvePolygon type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Destroy | Clears a borders list of this CADCurvePolygon.
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADCurvePolygon must be drawn during a drawing cycle.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADPolyPolygon to the specified CADConverter. (inherited from CADPolyPolygon).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADCurvePolygon Class


CADCurvePolygon.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCurvePolygon Class
CADCurvePolygon Members


CADCurvePolygon.Destroy Method

Clears a borders list of this CADCurvePolygon.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Destroy()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Destroy()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCurvePolygon Class
CADCurvePolygon Members


CADCurvePolygon.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCurvePolygon Class
CADCurvePolygon Members


CADCurvePolygon.GetBoxPoints Method

Checks if the CADCurvePolygon must be drawn during a drawing cycle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function GetBoxPoints( _
   ByVal Proc As FPointProc, _
   ByVal Full As Boolean _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool GetBoxPoints(
   FPointProc Proc,
   bool Full
)
This language is not supported or no code example is available.

Parameters

Proc

Type: FPointProc

A FPointProc delegate that references a method for getting CADCurvePolygon's points.

Full

Type: bool

A boolean value indicating whether the method realizes full or reduced checking. true if checking is full, false if checking is reduced.

Return Value

true if all points passed to the referenced method are the real entity's points; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCurvePolygon Class
CADCurvePolygon Members


CADPolyPolygon.Loaded Method

Loads this CADPolyPolygon to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADPolyPolygon is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyPolygon Class
CADPolyPolygon Members


CADCurvePolygon Fields

CADCurvePolygon Class See Also

The following tables list the members exposed by the CADCurvePolygon type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADCurvePolygon Class


CADCustomVertex Class

Members See Also

Provides a common functionality for the CADText and CADInsert classes.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADCustomVertex
    Inherits CADPlotEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADCustomVertex : CADPlotEntity
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADCustomVertex
CADImport.CADInsert
CADImport.CADOLE2Frame
CADImport.CADPoint
CADImport.CADText
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCustomVertex Members


CADCustomVertex Members

CADCustomVertex Class Constructors Methods Fields Properties See Also

Provides a common functionality for the CADText and CADInsert classes.

The following tables list the members exposed by the CADCustomVertex type.

Constructors
 | Name | Description
Public constructor | CADCustomVertex | Initializes an object of the CADPlotEntity class. (inherited from CADPlotEntity).
Top
Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses the CADCustomVertex object.
Public property | Color | Gets or sets a color for the this CADCustomVertex object.
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Point | Gets or sets a position of the CADCustomVertex object.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADPlotEntity).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADCustomVertex Class


CADPlotEntity Constructor

Initializes an object of the CADPlotEntity class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADPlotEntity()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPlotEntity Class
CADPlotEntity Members


CADCustomVertex Properties

CADCustomVertex Class See Also

The following tables list the members exposed by the CADCustomVertex type.

Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses the CADCustomVertex object.
Public property | Color | Gets or sets a color for the this CADCustomVertex object.
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Point | Gets or sets a position of the CADCustomVertex object.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
See Also

Reference

CADCustomVertex Class


CADCustomVertex.Box Property

Gets a three-dimensional box that encloses the CADCustomVertex object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Box() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override DRect Box {get;}
This language is not supported or no code example is available.

Property Value

A DRect object representing the enclosing box for the CADCustomVertex entity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCustomVertex Class
CADCustomVertex Members


CADCustomVertex Methods

CADCustomVertex Class See Also

The following tables list the members exposed by the CADCustomVertex type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADPlotEntity).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADCustomVertex Class


CADCustomVertex.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCustomVertex Class
CADCustomVertex Members


CADPlotEntity.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPlotEntity Class
CADPlotEntity Members


CADCustomVertex Fields

CADCustomVertex Class See Also

The following tables list the members exposed by the CADCustomVertex type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADCustomVertex Class


CADDXFReferenceCollection Class

Members See Also

Represents a collection of XRef objects.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADDXFReferenceCollection
    Inherits CollectionBase
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADDXFReferenceCollection : CollectionBase
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Collections.CollectionBase
CADImport.CADDXFReferenceCollection
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDXFReferenceCollection Members


CADDXFReferenceCollection Members

CADDXFReferenceCollection Class Methods Properties See Also

Represents a collection of XRef objects.

The following tables list the members exposed by the CADDXFReferenceCollection type.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase).
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase).
Public property | Item | Gets or sets a long object at the specified index in the collection.
Top
Methods
 | Name | Description
Public method | Add | Adds a DXFReference to the CADDXFReferenceCollection.
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase).
Public method | Contains | Determines whether the collection contains a specified DXFReference.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IndexOf | Determines the index of a specified DXFReference in the collection.
Public method | Insert | Inserts a DXFReference into the collection at the specified position.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Remove | Removes the first occurrence of the specified DXFReference from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADDXFReferenceCollection Class


CADDXFReferenceCollection Properties

CADDXFReferenceCollection Class See Also

The following tables list the members exposed by the CADDXFReferenceCollection type.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase).
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase).
Public property | Item | Gets or sets a long object at the specified index in the collection.
Top
See Also

Reference

CADDXFReferenceCollection Class


CADDXFReferenceCollection.Item Property

Gets or sets a long object at the specified index in the collection.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Item( _
   ByVal index As Integer _
) As DXFReference
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFReference this[
   int index
] {get; set;}
This language is not supported or no code example is available.

Parameters

index

Type: int

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDXFReferenceCollection Class
CADDXFReferenceCollection Members


CADDXFReferenceCollection Methods

CADDXFReferenceCollection Class See Also

The following tables list the members exposed by the CADDXFReferenceCollection type.

Methods
 | Name | Description
Public method | Add | Adds a DXFReference to the CADDXFReferenceCollection.
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase).
Public method | Contains | Determines whether the collection contains a specified DXFReference.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IndexOf | Determines the index of a specified DXFReference in the collection.
Public method | Insert | Inserts a DXFReference into the collection at the specified position.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Remove | Removes the first occurrence of the specified DXFReference from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADDXFReferenceCollection Class


CADDXFReferenceCollection.Add Method

Adds a DXFReference to the CADDXFReferenceCollection.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Add( _
   ByVal value As DXFReference _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Add(
   DXFReference value
)
This language is not supported or no code example is available.

Parameters

value

Type: DXFReference

A DXFReference object to add to the collection.

Return Value

The position into which the new DXFReference was inserted.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDXFReferenceCollection Class
CADDXFReferenceCollection Members


CADDXFReferenceCollection.Contains Method

Determines whether the collection contains a specified DXFReference.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Contains( _
   ByVal value As DXFReference _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Contains(
   DXFReference value
)
This language is not supported or no code example is available.

Parameters

value

Type: DXFReference

A DXFReference to locate in the collection.

Return Value

true if the DXFReference is found in the collection; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDXFReferenceCollection Class
CADDXFReferenceCollection Members


CADDXFReferenceCollection.IndexOf Method

Determines the index of a specified DXFReference in the collection.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function IndexOf( _
   ByVal value As DXFReference _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int IndexOf(
   DXFReference value
)
This language is not supported or no code example is available.

Parameters

value

Type: DXFReference

A DXFReference to locate in the collection.

Return Value

The index of the DXFReference if found in the collection; otherwise, -1.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDXFReferenceCollection Class
CADDXFReferenceCollection Members


CADDXFReferenceCollection.Insert Method

Inserts a DXFReference into the collection at the specified position.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As DXFReference _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Insert(
   int index,
   DXFReference value
)
This language is not supported or no code example is available.

Parameters

index

Type: int

The zero-based index at which the DXFReference should be inserted.

value

Type: DXFReference

The DXFReference to insert into the collection.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDXFReferenceCollection Class
CADDXFReferenceCollection Members


CADDXFReferenceCollection.Remove Method

Removes the first occurrence of the specified DXFReference from the collection.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Remove( _
   ByVal value As DXFReference _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Remove(
   DXFReference value
)
This language is not supported or no code example is available.

Parameters

value

Type: DXFReference

A DXFReference to remove from the collection.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDXFReferenceCollection Class
CADDXFReferenceCollection Members


CADDimension Class

Members See Also

Represents dimensions in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADDimension
    Inherits CADInsert
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADDimension : CADInsert
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADCustomVertex
CADImport.CADInsert
CADImport.CADDimension
CADImport.CADDimensionArc
CADImport.CADDimensionRadialLarge
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Members


CADDimension Members

CADDimension Class Constructors Methods Fields Properties See Also

Represents dimensions in a CAD image.

The following tables list the members exposed by the CADDimension type.

Constructors
 | Name | Description
Public constructor | CADDimension | (Overloaded) Initializes a new instance of the CADDimension class.
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets an angle between a referenced block and CAD drawing. (inherited from CADInsert).
Public property | ArcDefPoint | Gets or sets the point defining dimension arc for angular dimensions (in object coordinates system).
Public property | ArrowSize | Gets or sets dimensioning arrow size.
Public property | ArrowType1 | Gets or sets first arrow block name.
Public property | ArrowType2 | Gets or sets second arrow block name
Public property | Attribs | Gets a collection of an attribs. (inherited from CADInsert).
Public property | Block | Gets or sets a block referenced by this CADInsert object. (inherited from CADInsert).
Public property | Box | Gets a three-dimensional box that encloses the CADInsert object. (inherited from CADInsert).
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of attribs belonging to the given CADInsert. (inherited from CADInsert).
Public property | DIMCLRD | Gets or sets dimension line color. Range is 0 = BYBLOCK; 256 = BYLAYER.
Public property | DIMCLRE | Gets or sets dimension extension line color. Range is 0 = BYBLOCK; 256 = BYLAYER.
Public property | DIMCLRT | Gets or sets dimension text color. Range is 0 = BYBLOCK; 256 = BYLAYER.
Public property | DIMDEC | Gets or sets a number of decimal places for the tolerance values of a primary units dimension.
Public property | DIMLFAC | Gets or sets a linear measurements scale factor.
Public property | DIMLWD | Gets or sets the dimension line lineweight.
Public property | DIMLWE | Gets or sets the extension line lineweight.
Public property | DIMSD1 | Gets or sets a suppression of the first dimensional line.
Public property | DIMSD2 | Gets or sets a suppression of the second dimensional line.
Public property | DIMSE1 | Gets or sets a supression of the first extension line.
Public property | DIMSE2 | Gets or sets a supression of the second extension line.
Public property | DIMTIH | Gets or sets the text inside horizontal if nonzero.
Public property | DIMTIX | Gets or sets the force text inside extensions if nonzero.
Public property | DIMTOH | Gets or sets the text outside horizontal if nonzero.
Public property | DefPoint | Gets or sets a location of the dimension in a CAD image.
Public property | EntName | Gets a name of the CADInsert object. (inherited from CADInsert).
Public property | EntType | Gets the type of this CADDimension entity.
Public property | Entities | Gets a collection of attribs associated with the given CADInsert object. (inherited from CADInsert).
Public property | ExtLineExt | Gets or sets a distance to extend the extension lines above the dimension line.
Public property | ExtLineOffset | Gets or sets a distance to offset the extension lines from the points on the drawing that define the dimension.
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADInsert object. (inherited from CADInsert).
Public property | Flags | Gets or sets a byte containing flags for the CADDimension object.
Public property | ForceText | Outdated.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LinDefPoint1 | Gets or sets an origin of the first extension line of the CADDimension object.
Public property | LinDefPoint2 | Gets or sets an origin of the second extension line of the CADDimension object.
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADInsert).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADInsert. (inherited from CADInsert).
Public property | MeasurementsScale | Outdated.
Public property | MiddlePoint | Gets or sets a middle point of the dimension text.
Public property | Point | Gets or sets a position of the CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Precision | Outdated.
Public property | RadDefPoint | Gets or sets the definition point for diameter, radius, and angular dimensions (in world coordinates system)
Public property | Scale | Gets or sets a scale for drawning of the referenced block in a CAD image. (inherited from CADInsert).
Public property | Selected | Get or sets CADInsert selected. (inherited from CADInsert).
Public property | Style | Gets or sets a style for the CADDimension object.
Public property | TextAlign | Gets the integer value specifing text alignment or sets text alignment by this integer value.
Public property | TextHeight | Gets or sets dimensioning text height.
Public property | TextOffset | Gets or sets a gap between the dimension text and the dimension line.
Public property | TextOverride | For internal uses
Public property | TextPosVert | Gets or sets text above dimension line if nonzero.
Public property | TextRotation | Gets or sets the rotation angle of the dimension text.
Public property | TextStyle | Gets or sets a style of the dimension text.
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADInsert object. (inherited from CADInsert).
Public method | AssignEntity | Copies an entity
Public method | Attrib | Returns an attribute contained in the given CADInsert object. (inherited from CADInsert).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADDimension object to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADInsert entity. (inherited from CADInsert).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Enumerations
 | Name | Description
Public enumeration | DimensionType |
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADDimension Class


DimensionType Enumeration

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Aligned |
Rotated |
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension Constructor

CADDimension Class See Also

Initializes a new instance of the CADDimension class.

Overload List
Name | Description
CADDimension() | Initializes a new instance of the CADDimension class.
CADDimension(DimensionType, DPoint, DPoint, double, bool) |
See Also

Reference

CADDimension Class
CADDimension Members
CADImport Namespace
CADDimension
CADImage
DPoint
clNone


CADDimension Properties

CADDimension Class See Also

The following tables list the members exposed by the CADDimension type.

Properties
 | Name | Description
Public property | Angle | Gets or sets an angle between a referenced block and CAD drawing. (inherited from CADInsert).
Public property | ArcDefPoint | Gets or sets the point defining dimension arc for angular dimensions (in object coordinates system).
Public property | ArrowSize | Gets or sets dimensioning arrow size.
Public property | ArrowType1 | Gets or sets first arrow block name.
Public property | ArrowType2 | Gets or sets second arrow block name
Public property | Attribs | Gets a collection of an attribs. (inherited from CADInsert).
Public property | Block | Gets or sets a block referenced by this CADInsert object. (inherited from CADInsert).
Public property | Box | Gets a three-dimensional box that encloses the CADInsert object. (inherited from CADInsert).
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of attribs belonging to the given CADInsert. (inherited from CADInsert).
Public property | DIMCLRD | Gets or sets dimension line color. Range is 0 = BYBLOCK; 256 = BYLAYER.
Public property | DIMCLRE | Gets or sets dimension extension line color. Range is 0 = BYBLOCK; 256 = BYLAYER.
Public property | DIMCLRT | Gets or sets dimension text color. Range is 0 = BYBLOCK; 256 = BYLAYER.
Public property | DIMDEC | Gets or sets a number of decimal places for the tolerance values of a primary units dimension.
Public property | DIMLFAC | Gets or sets a linear measurements scale factor.
Public property | DIMLWD | Gets or sets the dimension line lineweight.
Public property | DIMLWE | Gets or sets the extension line lineweight.
Public property | DIMSD1 | Gets or sets a suppression of the first dimensional line.
Public property | DIMSD2 | Gets or sets a suppression of the second dimensional line.
Public property | DIMSE1 | Gets or sets a supression of the first extension line.
Public property | DIMSE2 | Gets or sets a supression of the second extension line.
Public property | DIMTIH | Gets or sets the text inside horizontal if nonzero.
Public property | DIMTIX | Gets or sets the force text inside extensions if nonzero.
Public property | DIMTOH | Gets or sets the text outside horizontal if nonzero.
Public property | DefPoint | Gets or sets a location of the dimension in a CAD image.
Public property | EntName | Gets a name of the CADInsert object. (inherited from CADInsert).
Public property | EntType | Gets the type of this CADDimension entity.
Public property | Entities | Gets a collection of attribs associated with the given CADInsert object. (inherited from CADInsert).
Public property | ExtLineExt | Gets or sets a distance to extend the extension lines above the dimension line.
Public property | ExtLineOffset | Gets or sets a distance to offset the extension lines from the points on the drawing that define the dimension.
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADInsert object. (inherited from CADInsert).
Public property | Flags | Gets or sets a byte containing flags for the CADDimension object.
Public property | ForceText | Outdated.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LinDefPoint1 | Gets or sets an origin of the first extension line of the CADDimension object.
Public property | LinDefPoint2 | Gets or sets an origin of the second extension line of the CADDimension object.
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADInsert).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADInsert. (inherited from CADInsert).
Public property | MeasurementsScale | Outdated.
Public property | MiddlePoint | Gets or sets a middle point of the dimension text.
Public property | Point | Gets or sets a position of the CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Precision | Outdated.
Public property | RadDefPoint | Gets or sets the definition point for diameter, radius, and angular dimensions (in world coordinates system)
Public property | Scale | Gets or sets a scale for drawning of the referenced block in a CAD image. (inherited from CADInsert).
Public property | Selected | Get or sets CADInsert selected. (inherited from CADInsert).
Public property | Style | Gets or sets a style for the CADDimension object.
Public property | TextAlign | Gets the integer value specifing text alignment or sets text alignment by this integer value.
Public property | TextHeight | Gets or sets dimensioning text height.
Public property | TextOffset | Gets or sets a gap between the dimension text and the dimension line.
Public property | TextOverride | For internal uses
Public property | TextPosVert | Gets or sets text above dimension line if nonzero.
Public property | TextRotation | Gets or sets the rotation angle of the dimension text.
Public property | TextStyle | Gets or sets a style of the dimension text.
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
See Also

Reference

CADDimension Class


CADDimension.ArcDefPoint Property

Gets or sets the point defining dimension arc for angular dimensions (in object coordinates system).

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ArcDefPoint() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint ArcDefPoint {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.ArrowSize Property

Gets or sets dimensioning arrow size.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ArrowSize() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double ArrowSize {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.ArrowType1 Property

Gets or sets first arrow block name.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ArrowType1() As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte ArrowType1 {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.ArrowType2 Property

Gets or sets second arrow block name

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ArrowType2() As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte ArrowType2 {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.DIMCLRD Property

Gets or sets dimension line color. Range is 0 = BYBLOCK; 256 = BYLAYER.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DIMCLRD() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Color DIMCLRD {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.DIMCLRE Property

Gets or sets dimension extension line color. Range is 0 = BYBLOCK; 256 = BYLAYER.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DIMCLRE() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Color DIMCLRE {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.DIMCLRT Property

Gets or sets dimension text color. Range is 0 = BYBLOCK; 256 = BYLAYER.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DIMCLRT() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Color DIMCLRT {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.DIMDEC Property

Gets or sets a number of decimal places for the tolerance values of a primary units dimension.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DIMDEC() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int DIMDEC {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.DIMLFAC Property

Gets or sets a linear measurements scale factor.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DIMLFAC() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double DIMLFAC {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.DIMLWD Property

Gets or sets the dimension line lineweight.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DIMLWD() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double DIMLWD {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.DIMLWE Property

Gets or sets the extension line lineweight.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DIMLWE() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double DIMLWE {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.DIMSD1 Property

Gets or sets a suppression of the first dimensional line.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DIMSD1() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool DIMSD1 {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.DIMSD2 Property

Gets or sets a suppression of the second dimensional line.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DIMSD2() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool DIMSD2 {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.DIMSE1 Property

Gets or sets a supression of the first extension line.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DIMSE1() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool DIMSE1 {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.DIMSE2 Property

Gets or sets a supression of the second extension line.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DIMSE2() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool DIMSE2 {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.DIMTIH Property

Gets or sets the text inside horizontal if nonzero.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DIMTIH() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool DIMTIH {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.DIMTIX Property

Gets or sets the force text inside extensions if nonzero.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DIMTIX() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int DIMTIX {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.DIMTOH Property

Gets or sets the text outside horizontal if nonzero.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DIMTOH() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool DIMTOH {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.DefPoint Property

Gets or sets a location of the dimension in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DefPoint() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint DefPoint {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object representing a location of the dimension in a CAD image.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.EntType Property

Gets the type of this CADDimension entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.ExtLineExt Property

Gets or sets a distance to extend the extension lines above the dimension line.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ExtLineExt() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double ExtLineExt {get; set;}
This language is not supported or no code example is available.
Remarks

The extension lines are the lines that go from a measured object to the dimesion line.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.ExtLineOffset Property

Gets or sets a distance to offset the extension lines from the points on the drawing that define the dimension.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ExtLineOffset() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double ExtLineOffset {get; set;}
This language is not supported or no code example is available.
Remarks

The extension lines are the lines that go from a measured object to the dimesion line.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.Flags Property

Gets or sets a byte containing flags for the CADDimension object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Flags() As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte Flags {get; set;}
This language is not supported or no code example is available.
Remarks

            The return values 0–6 are integer values that represent the dimension type.
0 = Rotated, horizontal, or vertical;
1 = Aligned;
2 = Angular;
3 = Diameter;
4 = Radius;
5 = Angular 3 point;
6 = Ordinate.
Values 32, 64, and 128 are bit values, which are added to the integer values
(value 32 is always set in R13 and later releases).
32 = Indicates that the block is referenced by this dimension only.
64 = Ordinate type. This is a bit value (bit 7) used only with integer value 6.
    If set, ordinate is X-type; if not set, ordinate is Y-type.
128 = This is a bit value (bit 8) added to the other values if
    the dimension text has been positioned at a user-defined location
    rather than at the default location.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.ForceText Property

Outdated.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ForceText() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int ForceText {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.LinDefPoint1 Property

Gets or sets an origin of the first extension line of the CADDimension object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LinDefPoint1() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint LinDefPoint1 {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object representing an origin of the first extension line.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.LinDefPoint2 Property

Gets or sets an origin of the second extension line of the CADDimension object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LinDefPoint2() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint LinDefPoint2 {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object representing an origin of the second extension line.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.MeasurementsScale Property

Outdated.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property MeasurementsScale() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double MeasurementsScale {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.MiddlePoint Property

Gets or sets a middle point of the dimension text.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property MiddlePoint() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint MiddlePoint {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object representing a middle point of the dimension text.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.Precision Property

Outdated.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Precision() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Precision {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.RadDefPoint Property

Gets or sets the definition point for diameter, radius, and angular dimensions (in world coordinates system)

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property RadDefPoint() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint RadDefPoint {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.Style Property

Gets or sets a style for the CADDimension object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Style() As CADDimensionStyle
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADDimensionStyle Style {get; set;}
This language is not supported or no code example is available.

Property Value

A CADDimensionStyle object.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.TextAlign Property

Gets the integer value specifing text alignment or sets text alignment by this integer value.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TextAlign() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int TextAlign {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.TextHeight Property

Gets or sets dimensioning text height.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TextHeight() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double TextHeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.TextOffset Property

Gets or sets a gap between the dimension text and the dimension line.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TextOffset() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double TextOffset {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.TextOverride Property

For internal uses

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TextOverride() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string TextOverride {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.TextPosVert Property

Gets or sets text above dimension line if nonzero.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TextPosVert() As DimTextPosVert
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DimTextPosVert TextPosVert {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.TextRotation Property

Gets or sets the rotation angle of the dimension text.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TextRotation() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double TextRotation {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.TextStyle Property

Gets or sets a style of the dimension text.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TextStyle() As CADStyle
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADStyle TextStyle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension Methods

CADDimension Class See Also

The following tables list the members exposed by the CADDimension type.

Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADInsert object. (inherited from CADInsert).
Public method | AssignEntity | Copies an entity
Public method | Attrib | Returns an attribute contained in the given CADInsert object. (inherited from CADInsert).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADDimension object to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADInsert entity. (inherited from CADInsert).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADDimension Class


CADDimension.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension.Loaded Method

Loads this CADDimension object to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADDimension object is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CADDimension Fields

CADDimension Class See Also

The following tables list the members exposed by the CADDimension type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADDimension Class


CADDimensionArc Class

Members See Also

Represents Arc lenght dimension in a CAD image

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADDimensionArc
    Inherits CADDimension
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADDimensionArc : CADDimension
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADCustomVertex
CADImport.CADInsert
CADImport.CADDimension
CADImport.CADDimensionArc
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionArc Members


CADDimensionArc Members

CADDimensionArc Class Constructors Methods Fields Properties See Also

Represents Arc lenght dimension in a CAD image

The following tables list the members exposed by the CADDimensionArc type.

Constructors
 | Name | Description
Public constructor | CADDimensionArc | (Overloaded) Initializes a new instance of the CADDimension class. (inherited from CADDimension).
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets an angle between a referenced block and CAD drawing. (inherited from CADInsert).
Public property | ArcDefPoint | Gets or sets the point defining dimension arc for angular dimensions (in object coordinates system). (inherited from CADDimension).
Public property | ArrowSize | Gets or sets dimensioning arrow size. (inherited from CADDimension).
Public property | ArrowType1 | Gets or sets first arrow block name. (inherited from CADDimension).
Public property | ArrowType2 | Gets or sets second arrow block name (inherited from CADDimension).
Public property | Attribs | Gets a collection of an attribs. (inherited from CADInsert).
Public property | Block | Gets or sets a block referenced by this CADInsert object. (inherited from CADInsert).
Public property | Box | Gets a three-dimensional box that encloses the CADInsert object. (inherited from CADInsert).
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of attribs belonging to the given CADInsert. (inherited from CADInsert).
Public property | DIMCLRD | Gets or sets dimension line color. Range is 0 = BYBLOCK; 256 = BYLAYER. (inherited from CADDimension).
Public property | DIMCLRE | Gets or sets dimension extension line color. Range is 0 = BYBLOCK; 256 = BYLAYER. (inherited from CADDimension).
Public property | DIMCLRT | Gets or sets dimension text color. Range is 0 = BYBLOCK; 256 = BYLAYER. (inherited from CADDimension).
Public property | DIMDEC | Gets or sets a number of decimal places for the tolerance values of a primary units dimension. (inherited from CADDimension).
Public property | DIMLFAC | Gets or sets a linear measurements scale factor. (inherited from CADDimension).
Public property | DIMLWD | Gets or sets the dimension line lineweight. (inherited from CADDimension).
Public property | DIMLWE | Gets or sets the extension line lineweight. (inherited from CADDimension).
Public property | DIMSD1 | Gets or sets a suppression of the first dimensional line. (inherited from CADDimension).
Public property | DIMSD2 | Gets or sets a suppression of the second dimensional line. (inherited from CADDimension).
Public property | DIMSE1 | Gets or sets a supression of the first extension line. (inherited from CADDimension).
Public property | DIMSE2 | Gets or sets a supression of the second extension line. (inherited from CADDimension).
Public property | DIMTIH | Gets or sets the text inside horizontal if nonzero. (inherited from CADDimension).
Public property | DIMTIX | Gets or sets the force text inside extensions if nonzero. (inherited from CADDimension).
Public property | DIMTOH | Gets or sets the text outside horizontal if nonzero. (inherited from CADDimension).
Public property | DefPoint | Gets or sets a location of the dimension in a CAD image. (inherited from CADDimension).
Public property | EntName | Gets a name of the CADInsert object. (inherited from CADInsert).
Public property | EntType | Gets the type of this CADDimension entity.
Public property | Entities | Gets a collection of attribs associated with the given CADInsert object. (inherited from CADInsert).
Public property | ExtLineExt | Gets or sets a distance to extend the extension lines above the dimension line. (inherited from CADDimension).
Public property | ExtLineOffset | Gets or sets a distance to offset the extension lines from the points on the drawing that define the dimension. (inherited from CADDimension).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADInsert object. (inherited from CADInsert).
Public property | Flags | Gets or sets a byte containing flags for the CADDimension object. (inherited from CADDimension).
Public property | ForceText | Outdated. (inherited from CADDimension).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LinDefPoint1 | Gets or sets an origin of the first extension line of the CADDimension object. (inherited from CADDimension).
Public property | LinDefPoint2 | Gets or sets an origin of the second extension line of the CADDimension object. (inherited from CADDimension).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADInsert).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADInsert. (inherited from CADInsert).
Public property | MeasurementsScale | Outdated. (inherited from CADDimension).
Public property | MiddlePoint | Gets or sets a middle point of the dimension text. (inherited from CADDimension).
Public property | Point | Gets or sets a position of the CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Precision | Outdated. (inherited from CADDimension).
Public property | RadDefPoint | Gets or sets the definition point for diameter, radius, and angular dimensions (in world coordinates system) (inherited from CADDimension).
Public property | Scale | Gets or sets a scale for drawning of the referenced block in a CAD image. (inherited from CADInsert).
Public property | Selected | Get or sets CADInsert selected. (inherited from CADInsert).
Public property | Style | Gets or sets a style for the CADDimension object. (inherited from CADDimension).
Public property | TextAlign | Gets the integer value specifing text alignment or sets text alignment by this integer value. (inherited from CADDimension).
Public property | TextHeight | Gets or sets dimensioning text height. (inherited from CADDimension).
Public property | TextOffset | Gets or sets a gap between the dimension text and the dimension line. (inherited from CADDimension).
Public property | TextOverride | For internal uses (inherited from CADDimension).
Public property | TextPosVert | Gets or sets text above dimension line if nonzero. (inherited from CADDimension).
Public property | TextRotation | Gets or sets the rotation angle of the dimension text. (inherited from CADDimension).
Public property | TextStyle | Gets or sets a style of the dimension text. (inherited from CADDimension).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADInsert object. (inherited from CADInsert).
Public method | AssignEntity | Copies an entity (inherited from CADDimension).
Public method | Attrib | Returns an attribute contained in the given CADInsert object. (inherited from CADInsert).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADDimension).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADDimension object to the specified CADConverter. (inherited from CADDimension).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADInsert entity. (inherited from CADInsert).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADDimensionArc Class


CADDimensionArc Properties

CADDimensionArc Class See Also

The following tables list the members exposed by the CADDimensionArc type.

Properties
 | Name | Description
Public property | Angle | Gets or sets an angle between a referenced block and CAD drawing. (inherited from CADInsert).
Public property | ArcDefPoint | Gets or sets the point defining dimension arc for angular dimensions (in object coordinates system). (inherited from CADDimension).
Public property | ArrowSize | Gets or sets dimensioning arrow size. (inherited from CADDimension).
Public property | ArrowType1 | Gets or sets first arrow block name. (inherited from CADDimension).
Public property | ArrowType2 | Gets or sets second arrow block name (inherited from CADDimension).
Public property | Attribs | Gets a collection of an attribs. (inherited from CADInsert).
Public property | Block | Gets or sets a block referenced by this CADInsert object. (inherited from CADInsert).
Public property | Box | Gets a three-dimensional box that encloses the CADInsert object. (inherited from CADInsert).
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of attribs belonging to the given CADInsert. (inherited from CADInsert).
Public property | DIMCLRD | Gets or sets dimension line color. Range is 0 = BYBLOCK; 256 = BYLAYER. (inherited from CADDimension).
Public property | DIMCLRE | Gets or sets dimension extension line color. Range is 0 = BYBLOCK; 256 = BYLAYER. (inherited from CADDimension).
Public property | DIMCLRT | Gets or sets dimension text color. Range is 0 = BYBLOCK; 256 = BYLAYER. (inherited from CADDimension).
Public property | DIMDEC | Gets or sets a number of decimal places for the tolerance values of a primary units dimension. (inherited from CADDimension).
Public property | DIMLFAC | Gets or sets a linear measurements scale factor. (inherited from CADDimension).
Public property | DIMLWD | Gets or sets the dimension line lineweight. (inherited from CADDimension).
Public property | DIMLWE | Gets or sets the extension line lineweight. (inherited from CADDimension).
Public property | DIMSD1 | Gets or sets a suppression of the first dimensional line. (inherited from CADDimension).
Public property | DIMSD2 | Gets or sets a suppression of the second dimensional line. (inherited from CADDimension).
Public property | DIMSE1 | Gets or sets a supression of the first extension line. (inherited from CADDimension).
Public property | DIMSE2 | Gets or sets a supression of the second extension line. (inherited from CADDimension).
Public property | DIMTIH | Gets or sets the text inside horizontal if nonzero. (inherited from CADDimension).
Public property | DIMTIX | Gets or sets the force text inside extensions if nonzero. (inherited from CADDimension).
Public property | DIMTOH | Gets or sets the text outside horizontal if nonzero. (inherited from CADDimension).
Public property | DefPoint | Gets or sets a location of the dimension in a CAD image. (inherited from CADDimension).
Public property | EntName | Gets a name of the CADInsert object. (inherited from CADInsert).
Public property | EntType | Gets the type of this CADDimension entity.
Public property | Entities | Gets a collection of attribs associated with the given CADInsert object. (inherited from CADInsert).
Public property | ExtLineExt | Gets or sets a distance to extend the extension lines above the dimension line. (inherited from CADDimension).
Public property | ExtLineOffset | Gets or sets a distance to offset the extension lines from the points on the drawing that define the dimension. (inherited from CADDimension).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADInsert object. (inherited from CADInsert).
Public property | Flags | Gets or sets a byte containing flags for the CADDimension object. (inherited from CADDimension).
Public property | ForceText | Outdated. (inherited from CADDimension).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LinDefPoint1 | Gets or sets an origin of the first extension line of the CADDimension object. (inherited from CADDimension).
Public property | LinDefPoint2 | Gets or sets an origin of the second extension line of the CADDimension object. (inherited from CADDimension).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADInsert).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADInsert. (inherited from CADInsert).
Public property | MeasurementsScale | Outdated. (inherited from CADDimension).
Public property | MiddlePoint | Gets or sets a middle point of the dimension text. (inherited from CADDimension).
Public property | Point | Gets or sets a position of the CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Precision | Outdated. (inherited from CADDimension).
Public property | RadDefPoint | Gets or sets the definition point for diameter, radius, and angular dimensions (in world coordinates system) (inherited from CADDimension).
Public property | Scale | Gets or sets a scale for drawning of the referenced block in a CAD image. (inherited from CADInsert).
Public property | Selected | Get or sets CADInsert selected. (inherited from CADInsert).
Public property | Style | Gets or sets a style for the CADDimension object. (inherited from CADDimension).
Public property | TextAlign | Gets the integer value specifing text alignment or sets text alignment by this integer value. (inherited from CADDimension).
Public property | TextHeight | Gets or sets dimensioning text height. (inherited from CADDimension).
Public property | TextOffset | Gets or sets a gap between the dimension text and the dimension line. (inherited from CADDimension).
Public property | TextOverride | For internal uses (inherited from CADDimension).
Public property | TextPosVert | Gets or sets text above dimension line if nonzero. (inherited from CADDimension).
Public property | TextRotation | Gets or sets the rotation angle of the dimension text. (inherited from CADDimension).
Public property | TextStyle | Gets or sets a style of the dimension text. (inherited from CADDimension).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
See Also

Reference

CADDimensionArc Class


CADDimensionArc.EntType Property

Gets the type of this CADDimension entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionArc Class
CADDimensionArc Members


CADDimensionArc Methods

CADDimensionArc Class See Also

The following tables list the members exposed by the CADDimensionArc type.

Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADInsert object. (inherited from CADInsert).
Public method | AssignEntity | Copies an entity (inherited from CADDimension).
Public method | Attrib | Returns an attribute contained in the given CADInsert object. (inherited from CADInsert).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADDimension).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADDimension object to the specified CADConverter. (inherited from CADDimension).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADInsert entity. (inherited from CADInsert).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADDimensionArc Class


CADDimensionArc Fields

CADDimensionArc Class See Also

The following tables list the members exposed by the CADDimensionArc type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADDimensionArc Class


CADDimensionRadialLarge Class

Members See Also

Represents Large Radial dimension in a CAD image

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADDimensionRadialLarge
    Inherits CADDimension
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADDimensionRadialLarge : CADDimension
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADCustomVertex
CADImport.CADInsert
CADImport.CADDimension
CADImport.CADDimensionRadialLarge
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionRadialLarge Members


CADDimensionRadialLarge Members

CADDimensionRadialLarge Class Constructors Methods Fields Properties See Also

Represents Large Radial dimension in a CAD image

The following tables list the members exposed by the CADDimensionRadialLarge type.

Constructors
 | Name | Description
Public constructor | CADDimensionRadialLarge | (Overloaded) Initializes a new instance of the CADDimension class. (inherited from CADDimension).
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets an angle between a referenced block and CAD drawing. (inherited from CADInsert).
Public property | ArcDefPoint | Gets or sets the point defining dimension arc for angular dimensions (in object coordinates system). (inherited from CADDimension).
Public property | ArrowSize | Gets or sets dimensioning arrow size. (inherited from CADDimension).
Public property | ArrowType1 | Gets or sets first arrow block name. (inherited from CADDimension).
Public property | ArrowType2 | Gets or sets second arrow block name (inherited from CADDimension).
Public property | Attribs | Gets a collection of an attribs. (inherited from CADInsert).
Public property | Block | Gets or sets a block referenced by this CADInsert object. (inherited from CADInsert).
Public property | Box | Gets a three-dimensional box that encloses the CADInsert object. (inherited from CADInsert).
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of attribs belonging to the given CADInsert. (inherited from CADInsert).
Public property | DIMCLRD | Gets or sets dimension line color. Range is 0 = BYBLOCK; 256 = BYLAYER. (inherited from CADDimension).
Public property | DIMCLRE | Gets or sets dimension extension line color. Range is 0 = BYBLOCK; 256 = BYLAYER. (inherited from CADDimension).
Public property | DIMCLRT | Gets or sets dimension text color. Range is 0 = BYBLOCK; 256 = BYLAYER. (inherited from CADDimension).
Public property | DIMDEC | Gets or sets a number of decimal places for the tolerance values of a primary units dimension. (inherited from CADDimension).
Public property | DIMLFAC | Gets or sets a linear measurements scale factor. (inherited from CADDimension).
Public property | DIMLWD | Gets or sets the dimension line lineweight. (inherited from CADDimension).
Public property | DIMLWE | Gets or sets the extension line lineweight. (inherited from CADDimension).
Public property | DIMSD1 | Gets or sets a suppression of the first dimensional line. (inherited from CADDimension).
Public property | DIMSD2 | Gets or sets a suppression of the second dimensional line. (inherited from CADDimension).
Public property | DIMSE1 | Gets or sets a supression of the first extension line. (inherited from CADDimension).
Public property | DIMSE2 | Gets or sets a supression of the second extension line. (inherited from CADDimension).
Public property | DIMTIH | Gets or sets the text inside horizontal if nonzero. (inherited from CADDimension).
Public property | DIMTIX | Gets or sets the force text inside extensions if nonzero. (inherited from CADDimension).
Public property | DIMTOH | Gets or sets the text outside horizontal if nonzero. (inherited from CADDimension).
Public property | DefPoint | Gets or sets a location of the dimension in a CAD image. (inherited from CADDimension).
Public property | EntName | Gets a name of the CADInsert object. (inherited from CADInsert).
Public property | EntType | Gets the type of this CADDimension entity.
Public property | Entities | Gets a collection of attribs associated with the given CADInsert object. (inherited from CADInsert).
Public property | ExtLineExt | Gets or sets a distance to extend the extension lines above the dimension line. (inherited from CADDimension).
Public property | ExtLineOffset | Gets or sets a distance to offset the extension lines from the points on the drawing that define the dimension. (inherited from CADDimension).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADInsert object. (inherited from CADInsert).
Public property | Flags | Gets or sets a byte containing flags for the CADDimension object. (inherited from CADDimension).
Public property | ForceText | Outdated. (inherited from CADDimension).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LinDefPoint1 | Gets or sets an origin of the first extension line of the CADDimension object. (inherited from CADDimension).
Public property | LinDefPoint2 | Gets or sets an origin of the second extension line of the CADDimension object. (inherited from CADDimension).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADInsert).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADInsert. (inherited from CADInsert).
Public property | MeasurementsScale | Outdated. (inherited from CADDimension).
Public property | MiddlePoint | Gets or sets a middle point of the dimension text. (inherited from CADDimension).
Public property | Point | Gets or sets a position of the CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Precision | Outdated. (inherited from CADDimension).
Public property | RadDefPoint | Gets or sets the definition point for diameter, radius, and angular dimensions (in world coordinates system) (inherited from CADDimension).
Public property | Scale | Gets or sets a scale for drawning of the referenced block in a CAD image. (inherited from CADInsert).
Public property | Selected | Get or sets CADInsert selected. (inherited from CADInsert).
Public property | Style | Gets or sets a style for the CADDimension object. (inherited from CADDimension).
Public property | TextAlign | Gets the integer value specifing text alignment or sets text alignment by this integer value. (inherited from CADDimension).
Public property | TextHeight | Gets or sets dimensioning text height. (inherited from CADDimension).
Public property | TextOffset | Gets or sets a gap between the dimension text and the dimension line. (inherited from CADDimension).
Public property | TextOverride | For internal uses (inherited from CADDimension).
Public property | TextPosVert | Gets or sets text above dimension line if nonzero. (inherited from CADDimension).
Public property | TextRotation | Gets or sets the rotation angle of the dimension text. (inherited from CADDimension).
Public property | TextStyle | Gets or sets a style of the dimension text. (inherited from CADDimension).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADInsert object. (inherited from CADInsert).
Public method | AssignEntity | Copies an entity (inherited from CADDimension).
Public method | Attrib | Returns an attribute contained in the given CADInsert object. (inherited from CADInsert).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADDimension).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADDimension object to the specified CADConverter. (inherited from CADDimension).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADInsert entity. (inherited from CADInsert).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADDimensionRadialLarge Class


CADDimensionRadialLarge Properties

CADDimensionRadialLarge Class See Also

The following tables list the members exposed by the CADDimensionRadialLarge type.

Properties
 | Name | Description
Public property | Angle | Gets or sets an angle between a referenced block and CAD drawing. (inherited from CADInsert).
Public property | ArcDefPoint | Gets or sets the point defining dimension arc for angular dimensions (in object coordinates system). (inherited from CADDimension).
Public property | ArrowSize | Gets or sets dimensioning arrow size. (inherited from CADDimension).
Public property | ArrowType1 | Gets or sets first arrow block name. (inherited from CADDimension).
Public property | ArrowType2 | Gets or sets second arrow block name (inherited from CADDimension).
Public property | Attribs | Gets a collection of an attribs. (inherited from CADInsert).
Public property | Block | Gets or sets a block referenced by this CADInsert object. (inherited from CADInsert).
Public property | Box | Gets a three-dimensional box that encloses the CADInsert object. (inherited from CADInsert).
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of attribs belonging to the given CADInsert. (inherited from CADInsert).
Public property | DIMCLRD | Gets or sets dimension line color. Range is 0 = BYBLOCK; 256 = BYLAYER. (inherited from CADDimension).
Public property | DIMCLRE | Gets or sets dimension extension line color. Range is 0 = BYBLOCK; 256 = BYLAYER. (inherited from CADDimension).
Public property | DIMCLRT | Gets or sets dimension text color. Range is 0 = BYBLOCK; 256 = BYLAYER. (inherited from CADDimension).
Public property | DIMDEC | Gets or sets a number of decimal places for the tolerance values of a primary units dimension. (inherited from CADDimension).
Public property | DIMLFAC | Gets or sets a linear measurements scale factor. (inherited from CADDimension).
Public property | DIMLWD | Gets or sets the dimension line lineweight. (inherited from CADDimension).
Public property | DIMLWE | Gets or sets the extension line lineweight. (inherited from CADDimension).
Public property | DIMSD1 | Gets or sets a suppression of the first dimensional line. (inherited from CADDimension).
Public property | DIMSD2 | Gets or sets a suppression of the second dimensional line. (inherited from CADDimension).
Public property | DIMSE1 | Gets or sets a supression of the first extension line. (inherited from CADDimension).
Public property | DIMSE2 | Gets or sets a supression of the second extension line. (inherited from CADDimension).
Public property | DIMTIH | Gets or sets the text inside horizontal if nonzero. (inherited from CADDimension).
Public property | DIMTIX | Gets or sets the force text inside extensions if nonzero. (inherited from CADDimension).
Public property | DIMTOH | Gets or sets the text outside horizontal if nonzero. (inherited from CADDimension).
Public property | DefPoint | Gets or sets a location of the dimension in a CAD image. (inherited from CADDimension).
Public property | EntName | Gets a name of the CADInsert object. (inherited from CADInsert).
Public property | EntType | Gets the type of this CADDimension entity.
Public property | Entities | Gets a collection of attribs associated with the given CADInsert object. (inherited from CADInsert).
Public property | ExtLineExt | Gets or sets a distance to extend the extension lines above the dimension line. (inherited from CADDimension).
Public property | ExtLineOffset | Gets or sets a distance to offset the extension lines from the points on the drawing that define the dimension. (inherited from CADDimension).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADInsert object. (inherited from CADInsert).
Public property | Flags | Gets or sets a byte containing flags for the CADDimension object. (inherited from CADDimension).
Public property | ForceText | Outdated. (inherited from CADDimension).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LinDefPoint1 | Gets or sets an origin of the first extension line of the CADDimension object. (inherited from CADDimension).
Public property | LinDefPoint2 | Gets or sets an origin of the second extension line of the CADDimension object. (inherited from CADDimension).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADInsert).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADInsert. (inherited from CADInsert).
Public property | MeasurementsScale | Outdated. (inherited from CADDimension).
Public property | MiddlePoint | Gets or sets a middle point of the dimension text. (inherited from CADDimension).
Public property | Point | Gets or sets a position of the CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Precision | Outdated. (inherited from CADDimension).
Public property | RadDefPoint | Gets or sets the definition point for diameter, radius, and angular dimensions (in world coordinates system) (inherited from CADDimension).
Public property | Scale | Gets or sets a scale for drawning of the referenced block in a CAD image. (inherited from CADInsert).
Public property | Selected | Get or sets CADInsert selected. (inherited from CADInsert).
Public property | Style | Gets or sets a style for the CADDimension object. (inherited from CADDimension).
Public property | TextAlign | Gets the integer value specifing text alignment or sets text alignment by this integer value. (inherited from CADDimension).
Public property | TextHeight | Gets or sets dimensioning text height. (inherited from CADDimension).
Public property | TextOffset | Gets or sets a gap between the dimension text and the dimension line. (inherited from CADDimension).
Public property | TextOverride | For internal uses (inherited from CADDimension).
Public property | TextPosVert | Gets or sets text above dimension line if nonzero. (inherited from CADDimension).
Public property | TextRotation | Gets or sets the rotation angle of the dimension text. (inherited from CADDimension).
Public property | TextStyle | Gets or sets a style of the dimension text. (inherited from CADDimension).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
See Also

Reference

CADDimensionRadialLarge Class


CADDimensionRadialLarge.EntType Property

Gets the type of this CADDimension entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionRadialLarge Class
CADDimensionRadialLarge Members


CADDimensionRadialLarge Methods

CADDimensionRadialLarge Class See Also

The following tables list the members exposed by the CADDimensionRadialLarge type.

Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADInsert object. (inherited from CADInsert).
Public method | AssignEntity | Copies an entity (inherited from CADDimension).
Public method | Attrib | Returns an attribute contained in the given CADInsert object. (inherited from CADInsert).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADDimension).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADDimension object to the specified CADConverter. (inherited from CADDimension).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADInsert entity. (inherited from CADInsert).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADDimensionRadialLarge Class


CADDimensionRadialLarge Fields

CADDimensionRadialLarge Class See Also

The following tables list the members exposed by the CADDimensionRadialLarge type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADDimensionRadialLarge Class


CADDimensionStyle Class

Members See Also

Represents a style applicable to dimension lines in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADDimensionStyle
    Inherits CADPenTableItem
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADDimensionStyle : CADPenTableItem
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.CADPenTableItem
CADImport.CADDimensionStyle
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Members


CADDimensionStyle Members

CADDimensionStyle Class Constructors Methods Fields Properties See Also

Represents a style applicable to dimension lines in a CAD image.

The following tables list the members exposed by the CADDimensionStyle type.

Constructors
 | Name | Description
Public constructor | CADDimensionStyle | Initializes a new instance of the CADDimensionStyle class.
Top
Properties
 | Name | Description
Public property | ArrowSize | Gets or sets a size of the arrowhead defined by this CADDimensionStyle.
Public property | ArrowType1 | Gets or sets a type of the first arrow exterior
Public property | ArrowType2 | Gets or sets a type of the second arrow exterior
Public property | ArrowTypeL | Gets or sets arrow block name.
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | DIMCLRD | Gets or sets dimension line color. Range is 0 = BYBLOCK; 256 = BYLAYER.
Public property | DIMCLRE | Gets or sets dimension extension line color. Range is 0 = BYBLOCK; 256 = BYLAYER.
Public property | DIMCLRT | Gets or sets dimension text color. Range is 0 = BYBLOCK; 256 = BYLAYER.
Public property | DIMDEC | Gets or sets a number of decimal places for the tolerance values
Public property | DIMLFAC | Gets or sets a linear measurements scale factor
Public property | DIMLWD | Gets or sets the dimension line lineweight.
Public property | DIMLWE | Gets or sets a force text inside extensions
Public property | DIMSD1 | Gets or sets a suppression of the first dimensional line
Public property | DIMSD2 | Gets or sets a suppression of the second dimensional line
Public property | DIMSE1 | Gets or sets a supression of the first extension line
Public property | DIMSE2 | Gets or sets a supression of the second extension line
Public property | DIMTIH | Gets or sets the text inside horizontal if nonzero.
Public property | DIMTIX | Gets or sets the force text inside extensions if nonzero.
Public property | DIMTOH | Gets or sets the text outside horizontal if nonzero.
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | EntName | Gets a name of this CADPenTableItem. (inherited from CADPenTableItem).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtLineExt | Gets or sets a distance to extend the extension lines above the dimension line.
Public property | ExtLineOffset | Gets or sets a distance to offset the extension lines from the points on the drawing that define the dimension.
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Flags | Gets or sets a drawing flags. (inherited from CADPenTableItem).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Name | Gets or sets a name of the CADPenTableItem. (inherited from CADPenTableItem).
Public property | Scale | Gets or sets overall dimensioning scale factor.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | SizeCenterMark | Gets or sets a size of the center mark defined by this CADDimensionStyle.
Public property | TextHeight | Gets or sets a height of the dimension text defined by this CADDimensionStyle.
Public property | TextOffset | Gets or sets a gap between the dimension text and the dimension line.
Public property | TextPosVert | Gets or sets text above dimension line if nonzero.
Public property | TextStyle | Gets or sets a style of the dimension text defined by this CADDimensionStyle.
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | InitDimProperties | Initializes dimension style using default values from the specified header.
Public method | Loaded | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADDimensionStyle Class


CADDimensionStyle Constructor

Initializes a new instance of the CADDimensionStyle class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADDimensionStyle()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle Properties

CADDimensionStyle Class See Also

The following tables list the members exposed by the CADDimensionStyle type.

Properties
 | Name | Description
Public property | ArrowSize | Gets or sets a size of the arrowhead defined by this CADDimensionStyle.
Public property | ArrowType1 | Gets or sets a type of the first arrow exterior
Public property | ArrowType2 | Gets or sets a type of the second arrow exterior
Public property | ArrowTypeL | Gets or sets arrow block name.
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | DIMCLRD | Gets or sets dimension line color. Range is 0 = BYBLOCK; 256 = BYLAYER.
Public property | DIMCLRE | Gets or sets dimension extension line color. Range is 0 = BYBLOCK; 256 = BYLAYER.
Public property | DIMCLRT | Gets or sets dimension text color. Range is 0 = BYBLOCK; 256 = BYLAYER.
Public property | DIMDEC | Gets or sets a number of decimal places for the tolerance values
Public property | DIMLFAC | Gets or sets a linear measurements scale factor
Public property | DIMLWD | Gets or sets the dimension line lineweight.
Public property | DIMLWE | Gets or sets a force text inside extensions
Public property | DIMSD1 | Gets or sets a suppression of the first dimensional line
Public property | DIMSD2 | Gets or sets a suppression of the second dimensional line
Public property | DIMSE1 | Gets or sets a supression of the first extension line
Public property | DIMSE2 | Gets or sets a supression of the second extension line
Public property | DIMTIH | Gets or sets the text inside horizontal if nonzero.
Public property | DIMTIX | Gets or sets the force text inside extensions if nonzero.
Public property | DIMTOH | Gets or sets the text outside horizontal if nonzero.
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | EntName | Gets a name of this CADPenTableItem. (inherited from CADPenTableItem).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtLineExt | Gets or sets a distance to extend the extension lines above the dimension line.
Public property | ExtLineOffset | Gets or sets a distance to offset the extension lines from the points on the drawing that define the dimension.
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Flags | Gets or sets a drawing flags. (inherited from CADPenTableItem).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Name | Gets or sets a name of the CADPenTableItem. (inherited from CADPenTableItem).
Public property | Scale | Gets or sets overall dimensioning scale factor.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | SizeCenterMark | Gets or sets a size of the center mark defined by this CADDimensionStyle.
Public property | TextHeight | Gets or sets a height of the dimension text defined by this CADDimensionStyle.
Public property | TextOffset | Gets or sets a gap between the dimension text and the dimension line.
Public property | TextPosVert | Gets or sets text above dimension line if nonzero.
Public property | TextStyle | Gets or sets a style of the dimension text defined by this CADDimensionStyle.
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Top
See Also

Reference

CADDimensionStyle Class


CADDimensionStyle.ArrowSize Property

Gets or sets a size of the arrowhead defined by this CADDimensionStyle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ArrowSize() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double ArrowSize {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle.ArrowType1 Property

Gets or sets a type of the first arrow exterior

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ArrowType1() As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte ArrowType1 {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle.ArrowType2 Property

Gets or sets a type of the second arrow exterior

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ArrowType2() As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte ArrowType2 {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle.ArrowTypeL Property

Gets or sets arrow block name.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ArrowTypeL() As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte ArrowTypeL {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle.DIMCLRD Property

Gets or sets dimension line color. Range is 0 = BYBLOCK; 256 = BYLAYER.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DIMCLRD() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Color DIMCLRD {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle.DIMCLRE Property

Gets or sets dimension extension line color. Range is 0 = BYBLOCK; 256 = BYLAYER.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DIMCLRE() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Color DIMCLRE {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle.DIMCLRT Property

Gets or sets dimension text color. Range is 0 = BYBLOCK; 256 = BYLAYER.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DIMCLRT() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Color DIMCLRT {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle.DIMDEC Property

Gets or sets a number of decimal places for the tolerance values

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DIMDEC() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int DIMDEC {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle.DIMLFAC Property

Gets or sets a linear measurements scale factor

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DIMLFAC() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double DIMLFAC {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle.DIMLWD Property

Gets or sets the dimension line lineweight.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DIMLWD() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double DIMLWD {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle.DIMLWE Property

Gets or sets a force text inside extensions

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DIMLWE() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double DIMLWE {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle.DIMSD1 Property

Gets or sets a suppression of the first dimensional line

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DIMSD1() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool DIMSD1 {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle.DIMSD2 Property

Gets or sets a suppression of the second dimensional line

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DIMSD2() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool DIMSD2 {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle.DIMSE1 Property

Gets or sets a supression of the first extension line

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DIMSE1() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool DIMSE1 {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle.DIMSE2 Property

Gets or sets a supression of the second extension line

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DIMSE2() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool DIMSE2 {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle.DIMTIH Property

Gets or sets the text inside horizontal if nonzero.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DIMTIH() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool DIMTIH {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle.DIMTIX Property

Gets or sets the force text inside extensions if nonzero.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DIMTIX() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int DIMTIX {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle.DIMTOH Property

Gets or sets the text outside horizontal if nonzero.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DIMTOH() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool DIMTOH {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle.ExtLineExt Property

Gets or sets a distance to extend the extension lines above the dimension line.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ExtLineExt() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double ExtLineExt {get; set;}
This language is not supported or no code example is available.
Remarks

The extension lines are the lines that go from a measured object to the dimesion line.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle.ExtLineOffset Property

Gets or sets a distance to offset the extension lines from the points on the drawing that define the dimension.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ExtLineOffset() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double ExtLineOffset {get; set;}
This language is not supported or no code example is available.
Remarks

The extension lines are the lines that go from a measured object to the dimesion line.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle.Scale Property

Gets or sets overall dimensioning scale factor.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Scale() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Scale {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle.SizeCenterMark Property

Gets or sets a size of the center mark defined by this CADDimensionStyle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property SizeCenterMark() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double SizeCenterMark {get; set;}
This language is not supported or no code example is available.
Remarks

A center mark specifies a center of circle or arc and looks as a small symmetric cross consisting of two perpendicular lines. A size of the center mark is a distance from the center of the circle or arc to the end of the center mark.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle.TextHeight Property

Gets or sets a height of the dimension text defined by this CADDimensionStyle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TextHeight() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double TextHeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle.TextOffset Property

Gets or sets a gap between the dimension text and the dimension line.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TextOffset() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double TextOffset {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle.TextPosVert Property

Gets or sets text above dimension line if nonzero.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TextPosVert() As DimTextPosVert
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DimTextPosVert TextPosVert {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle.TextStyle Property

Gets or sets a style of the dimension text defined by this CADDimensionStyle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TextStyle() As CADStyle
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADStyle TextStyle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle Methods

CADDimensionStyle Class See Also

The following tables list the members exposed by the CADDimensionStyle type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | InitDimProperties | Initializes dimension style using default values from the specified header.
Public method | Loaded | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADDimensionStyle Class


CADDimensionStyle.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle.InitDimProperties Method

Initializes dimension style using default values from the specified header.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub InitDimProperties( _
   ByVal header As HeadVarStruct _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void InitDimProperties(
   HeadVarStruct header
)
This language is not supported or no code example is available.

Parameters

header

Type: HeadVarStruct

The header to get default values from.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimensionStyle Class
CADDimensionStyle Members


CADDimensionStyle Fields

CADDimensionStyle Class See Also

The following tables list the members exposed by the CADDimensionStyle type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADDimensionStyle Class


CADEllipse Class

Members See Also

Represents a full ellipse or elliptical arc in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADEllipse
    Inherits CADArc
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADEllipse : CADArc
This language is not supported or no code example is available.
Remarks

An ellipse is specified by two perpendicular axes that define its width and length. The longer axis is called the major axis, and the shorter one is the minor axis.

Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.CADPenLine
CADImport.CADPolylineBase
CADImport.CADCircle
CADImport.CADArc
CADImport.CADEllipse
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEllipse Members


CADEllipse Members

CADEllipse Class Constructors Methods Fields Properties See Also

Represents a full ellipse or elliptical arc in a CAD image.

The following tables list the members exposed by the CADEllipse type.

Constructors
 | Name | Description
Public constructor | CADEllipse | Initializes a new instance of the CADEllipse class.
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets an angle between axis X in World Coordinate System (WCS) and a major ellipse axis measured counterclockwise.
Public property | Box | Return box of the current primitive. (inherited from CADPolylineBase).
Public property | Closed | Gets or sets a value indicating whether this CADPolyLine is closed. (inherited from CADPolylineBase).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADPolylineBase. (inherited from CADPolylineBase).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | DottedSingPoints | Gets a collection of points that specify the dots and dashes of the CADPolylineBase. (inherited from CADPolylineBase).
Public property | EndAngle | Gets or sets an angle between axis X and the line connecting the end point with the central Point. (inherited from CADArc).
Public property | EndPoint | Gets end point of CADArc object (inherited from CADArc).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADEllipce entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Flags | Gets or sets a number that specifies an appearance of this CADPolylineBase entity. (inherited from CADPolylineBase).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | IsMeshMClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the M direction. (inherited from CADPolylineBase).
Public property | IsMeshNClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the N direction. (inherited from CADPolylineBase).
Public property | IsPolyFaceMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | IsPolyZThickness | Gets a value indicating whether a line thickness measured along the axis Z is equal to 0. (inherited from CADPolylineBase).
Public property | IsPolygonMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADCircle).
Public property | PolyPoints | Gets a collection of points belonging to the polyline. (inherited from CADPolylineBase).
Public property | RadPt | Gets an initial end point of the major axis relative to the ellipse center point.
Public property | Radius | Gets or sets a radius for the CADCircle. (inherited from CADCircle).
Public property | Ratio | Gets or sets a ratio between a minor axis and a major axis of the CADEllipse.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | StartAngle | Gets or sets an angle between axis X and the line connecting the start point with the central Point. (inherited from CADArc).
Public property | StartPoint | Gets start point of CADArc object (inherited from CADArc).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | ApplyBox | Calculates a box of the current entity. (inherited from CADPolylineBase).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
 | CreateArcFromVertexes | Creates a new instance of the CADArc class using two instances of the CADVertex class. (inherited from CADArc).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADPolylineBase).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADCircle).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Used in drawing cycle for fast checking whether the entity must be drawn (inherited from CADPolylineBase).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADEllipse to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADEllipse Class


CADEllipse Constructor

Example See Also

Initializes a new instance of the CADEllipse class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEllipse()
This language is not supported or no code example is available.
Example
<p>Creating a new CADEllipse object example:</p> <p>[C#]</p>
Copy

     CreateNewImage();
     CADEllipse ellipse = new CADEllipse();
     ellipse.Color = CADConst.clNone;
     DPoint pt1 = GetRealPoint(100, 100);
     DPoint pt2 = GetRealPoint(300, 300);
     double dX = (pt2.X - pt1.X) / 2;
     double dY = (pt2.Y - pt1.Y) / 4;
     CADEllipse ell = new CADEllipse();
     ellipse.Point = new DPoint(pt1.X + dX, pt1.Y + dY, 0);
     ellipse.RadPt = new DPoint((pt2.X - pt1.X) / 2, (pt2.Y - pt2.Y) / 2, 0);
     ellipse.Ratio = dY / dX;
     ellipse.LineWeight = 0.1;
     ellipse.StartAngle = 360.0;
     ellipse.EndAngle = 0.0;
     ellipse.LineWeight = 0.1;
     ellipse.Loaded(cadImage.Converter);
     ellipse.Handle = ellipse.GetHashCode();
     ellipse.KeyEnt = ellipse.Handle.ToString();
     cadImage.CurrentLayout.Entities.Add(ellipse);
     cadImage.Converter.OnCreate(ellipse);
     EditorCADPictureBox.Invalidate();
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEllipse Class
CADEllipse Members
CADImport Namespace
CADEllipse
CADImage
DPoint
clNone


CADEllipse Properties

CADEllipse Class See Also

The following tables list the members exposed by the CADEllipse type.

Properties
 | Name | Description
Public property | Angle | Gets or sets an angle between axis X in World Coordinate System (WCS) and a major ellipse axis measured counterclockwise.
Public property | Box | Return box of the current primitive. (inherited from CADPolylineBase).
Public property | Closed | Gets or sets a value indicating whether this CADPolyLine is closed. (inherited from CADPolylineBase).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADPolylineBase. (inherited from CADPolylineBase).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | DottedSingPoints | Gets a collection of points that specify the dots and dashes of the CADPolylineBase. (inherited from CADPolylineBase).
Public property | EndAngle | Gets or sets an angle between axis X and the line connecting the end point with the central Point. (inherited from CADArc).
Public property | EndPoint | Gets end point of CADArc object (inherited from CADArc).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADEllipce entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Flags | Gets or sets a number that specifies an appearance of this CADPolylineBase entity. (inherited from CADPolylineBase).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | IsMeshMClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the M direction. (inherited from CADPolylineBase).
Public property | IsMeshNClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the N direction. (inherited from CADPolylineBase).
Public property | IsPolyFaceMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | IsPolyZThickness | Gets a value indicating whether a line thickness measured along the axis Z is equal to 0. (inherited from CADPolylineBase).
Public property | IsPolygonMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADCircle).
Public property | PolyPoints | Gets a collection of points belonging to the polyline. (inherited from CADPolylineBase).
Public property | RadPt | Gets an initial end point of the major axis relative to the ellipse center point.
Public property | Radius | Gets or sets a radius for the CADCircle. (inherited from CADCircle).
Public property | Ratio | Gets or sets a ratio between a minor axis and a major axis of the CADEllipse.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | StartAngle | Gets or sets an angle between axis X and the line connecting the start point with the central Point. (inherited from CADArc).
Public property | StartPoint | Gets start point of CADArc object (inherited from CADArc).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
See Also

Reference

CADEllipse Class


CADEllipse.Angle Property

Gets or sets an angle between axis X in World Coordinate System (WCS) and a major ellipse axis measured counterclockwise.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Angle() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Angle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEllipse Class
CADEllipse Members


CADEllipse.EntType Property

Gets the type of this CADEllipce entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEllipse Class
CADEllipse Members


CADEllipse.RadPt Property

Gets an initial end point of the major axis relative to the ellipse center point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property RadPt() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint RadPt {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object that represents an initial end point of the major axis relative to the ellipse center point.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEllipse Class
CADEllipse Members


CADEllipse.Ratio Property

Gets or sets a ratio between a minor axis and a major axis of the CADEllipse.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Ratio() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Ratio {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEllipse Class
CADEllipse Members


CADEllipse Methods

CADEllipse Class See Also

The following tables list the members exposed by the CADEllipse type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | ApplyBox | Calculates a box of the current entity. (inherited from CADPolylineBase).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
 | CreateArcFromVertexes | Creates a new instance of the CADArc class using two instances of the CADVertex class. (inherited from CADArc).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADPolylineBase).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADCircle).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Used in drawing cycle for fast checking whether the entity must be drawn (inherited from CADPolylineBase).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADEllipse to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADEllipse Class


CADEllipse.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEllipse Class
CADEllipse Members


CADEllipse.Loaded Method

Loads this CADEllipse to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADEllipse is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEllipse Class
CADEllipse Members


CADEllipse Fields

CADEllipse Class See Also

The following tables list the members exposed by the CADEllipse type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADEllipse Class


CADEntity Class

Members See Also

Represents a base class for all entities in a CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADEntity
    Implements IDisposable
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADEntity : IDisposable
This language is not supported or no code example is available.
Remarks

CADEntity provides a basic functionality for its descendants.

Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADMLineEntry
CADImport.CADObjectEntity
CADImport.CADSeqend
CADImport.CADSortEntsTable
CADImport.CADVPort
CADImport.CADVertex
CADImport.MVertex
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntity Members


CADEntity Members

CADEntity Class Constructors Methods Fields Properties See Also

Represents a base class for all entities in a CAD file.

The following tables list the members exposed by the CADEntity type.

Constructors
 | Name | Description
Public constructor | CADEntity | Initializes a new instance of the CADEntity class.
Top
Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity.
Public property | Color | Gets or sets a color for the given CADEntity.
Public property | Count | Gets a number of entities contained in the given CADEntity.
Public property | EntName | Gets a name of the CADEntity.
Public property | EntType | The entity type defined by the EntityType enumeration.
Public property | Entities | Gets a collection of all entities owned by this CADEntity.
Public property | ExtendedData | Provides access to entity extended data
Public property | Handle | Gets a CADEntity handle.
Public property | Layer | Gets or sets a layer containing this CADEntity.
Public property | LineType | Gets or sets a linetype of the CADEntity.
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length.
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected.
Public property | Visibility | Gets or sets a value indicating whether a CADEntity is visible.
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes.
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset
Public method | Clone | Copies an entity
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Virtual method. Redefined in descendant classes.
Public method | OnDraw | Raises a DrawEvent.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image.
Top
See Also

Reference

CADEntity Class


CADEntity Constructor

Initializes a new instance of the CADEntity class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntity()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntity Class
CADEntity Members


CADEntity Properties

CADEntity Class See Also

The following tables list the members exposed by the CADEntity type.

Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity.
Public property | Color | Gets or sets a color for the given CADEntity.
Public property | Count | Gets a number of entities contained in the given CADEntity.
Public property | EntName | Gets a name of the CADEntity.
Public property | EntType | The entity type defined by the EntityType enumeration.
Public property | Entities | Gets a collection of all entities owned by this CADEntity.
Public property | ExtendedData | Provides access to entity extended data
Public property | Handle | Gets a CADEntity handle.
Public property | Layer | Gets or sets a layer containing this CADEntity.
Public property | LineType | Gets or sets a linetype of the CADEntity.
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length.
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected.
Public property | Visibility | Gets or sets a value indicating whether a CADEntity is visible.
Top
See Also

Reference

CADEntity Class


CADEntity.Layer Property

Gets or sets a layer containing this CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Property Layer() As CADLayer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual CADLayer Layer {get; set;}
This language is not supported or no code example is available.

Property Value

A CADLayer containing this CADEntity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntity Class
CADEntity Members


CADEntity.LineTypeScale Property

Gets or sets a value equal to a quantity of linetype elements per unit of its length.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Property LineTypeScale() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual float LineTypeScale {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntity Class
CADEntity Members


CADEntity.Visibility Property

Gets or sets a value indicating whether a CADEntity is visible.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Property Visibility() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual bool Visibility {get; set;}
This language is not supported or no code example is available.

Property Value

true if a CADEntity is visible; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntity Class
CADEntity Members


CADEntity Methods

CADEntity Class See Also

The following tables list the members exposed by the CADEntity type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes.
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset
Public method | Clone | Copies an entity
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Virtual method. Redefined in descendant classes.
Public method | OnDraw | Raises a DrawEvent.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADEntity Class


CADEntity.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntity Class
CADEntity Members


CADEntity.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub Dispose() Implements  _
   IDisposable.Dispose
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void Dispose()
This language is not supported or no code example is available.

Implements

IDisposable.Dispose
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntity Class
CADEntity Members


CADEntity Fields

CADEntity Class See Also

The following tables list the members exposed by the CADEntity type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image.
Top
See Also

Reference

CADEntity Class


CADEntityCollection Class

Members See Also

Represents a collection of CAD entities.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADEntityCollection
    Inherits List(Of CADEntity)
    Implements IDisposable, _
               INotifyPropertyChanged
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADEntityCollection : List<CADEntity>,
   IDisposable,
   INotifyPropertyChanged
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Collections.Generic.List<T>
CADImport.CADEntityCollection
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntityCollection Members


CADEntityCollection Members

CADEntityCollection Class Constructors Events Methods Properties See Also

Represents a collection of CAD entities.

The following tables list the members exposed by the CADEntityCollection type.

Constructors
 | Name | Description
Public constructor | CADEntityCollection | (Overloaded) Initializes a new instance of the CADEntityCollection class.
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (inherited from List<T>).
Public property | Count | Gets the number of elements actually contained in the List<T>. (inherited from List<T>).
Public property | Item | (Overloaded) Gets the CADEntity by its handle.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the List<T>. (inherited from List<T>).
Public method | AddRange | Adds the elements of the specified collection to the end of the List<T>. (inherited from List<T>).
Public method | AsReadOnly | Returns a read-only IList<T> wrapper for the current collection. (inherited from List<T>).
Public method | BinarySearch | (Overloaded) Searches a range of elements in the sorted List<T> for an element using the specified comparer and returns the zero-based index of the element. (inherited from List<T>).
Public method | Clear | Removes all elements from the List<T>. (inherited from List<T>).
Public method | Clone | Creates a new object that is a copy of the CADEntityCollection class current instance.
Public method | Contains | Determines whether an element is in the List<T>. (inherited from List<T>).
Public method | ConvertAll | Converts the elements in the current List<T> to another type, and returns a list containing the converted elements. (inherited from List<T>).
Public method | CopyTo | (Overloaded) Copies the entire List<T> to a compatible one-dimensional array, starting at the beginning of the target array. (inherited from List<T>).
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | Exists | Determines whether the List<T> contains elements that match the conditions defined by the specified predicate. (inherited from List<T>).
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<T>. (inherited from List<T>).
Public method | FindAll | Retrieves the all the elements that match the conditions defined by the specified predicate. (inherited from List<T>).
Public method | FindIndex | (Overloaded) Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<T>. (inherited from List<T>).
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<T>. (inherited from List<T>).
Public method | FindLastIndex | (Overloaded) Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<T>. (inherited from List<T>).
Public method | ForEach | Performs the specified action on each element of the List<T>. (inherited from List<T>).
Public method | GetEnumerator | Returns an enumerator that iterates through the List<T>. (inherited from List<T>).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<T>. (inherited from List<T>).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IndexOf | (Overloaded) Returns an index of the CADEntity in the CADEntityCollection.
Public method | Insert | Inserts an element into the List<T> at the specified index. (inherited from List<T>).
Public method | InsertRange | Inserts the elements of a collection into the List<T> at the specified index. (inherited from List<T>).
Public method | LastIndexOf | (Overloaded) Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<T>. (inherited from List<T>).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Remove | (Overloaded) Removes the CADEntity by its handle.
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (inherited from List<T>).
Public method | RemoveAt | Removes the element at the specified index of the List<T>. (inherited from List<T>).
Public method | RemoveRange | Removes a range of elements from the List<T>. (inherited from List<T>).
Public method | Reverse | (Overloaded) Reverses the order of the elements in the entire List<T>. (inherited from List<T>).
Public method | Sort | (Overloaded) Sorts the elements in the entire List<T> using the default comparer. (inherited from List<T>).
Public method | SortByHandle | Sorts CAD entities by handle.
Public method | ToArray | Copies the elements of the List<T> to a new array. (inherited from List<T>).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<T>, if that number is less than a threshold value. (inherited from List<T>).
Public method | TrueForAll | Determines whether every element in the List<T> matches the conditions defined by the specified predicate. (inherited from List<T>).
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

CADEntityCollection Class


CADEntityCollection Constructor

CADEntityCollection Class See Also

Initializes a new instance of the CADEntityCollection class.

Overload List
Name | Description
CADEntityCollection() | Initializes a new instance of the CADEntityCollection class.
CADEntityCollection(IEnumerable<CADEntity>) |
CADEntityCollection(int) |
See Also

Reference

CADEntityCollection Class
CADEntityCollection Members


CADEntityCollection Properties

CADEntityCollection Class See Also

The following tables list the members exposed by the CADEntityCollection type.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (inherited from List<T>).
Public property | Count | Gets the number of elements actually contained in the List<T>. (inherited from List<T>).
Public property | Item | (Overloaded) Gets the CADEntity by its handle.
Top
See Also

Reference

CADEntityCollection Class


CADEntityCollection.Item Property

CADEntityCollection Class See Also

Gets the CADEntity by its handle.

Overload List
Name | Description
this[UInt64] | Gets the CADEntity by its handle.
this[int] | Gets the CADEntity by its index.
See Also

Reference

CADEntityCollection Class
CADEntityCollection Members


CADEntityCollection Methods

CADEntityCollection Class See Also

The following tables list the members exposed by the CADEntityCollection type.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the List<T>. (inherited from List<T>).
Public method | AddRange | Adds the elements of the specified collection to the end of the List<T>. (inherited from List<T>).
Public method | AsReadOnly | Returns a read-only IList<T> wrapper for the current collection. (inherited from List<T>).
Public method | BinarySearch | (Overloaded) Searches a range of elements in the sorted List<T> for an element using the specified comparer and returns the zero-based index of the element. (inherited from List<T>).
Public method | Clear | Removes all elements from the List<T>. (inherited from List<T>).
Public method | Clone | Creates a new object that is a copy of the CADEntityCollection class current instance.
Public method | Contains | Determines whether an element is in the List<T>. (inherited from List<T>).
Public method | ConvertAll | Converts the elements in the current List<T> to another type, and returns a list containing the converted elements. (inherited from List<T>).
Public method | CopyTo | (Overloaded) Copies the entire List<T> to a compatible one-dimensional array, starting at the beginning of the target array. (inherited from List<T>).
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | Exists | Determines whether the List<T> contains elements that match the conditions defined by the specified predicate. (inherited from List<T>).
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<T>. (inherited from List<T>).
Public method | FindAll | Retrieves the all the elements that match the conditions defined by the specified predicate. (inherited from List<T>).
Public method | FindIndex | (Overloaded) Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<T>. (inherited from List<T>).
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<T>. (inherited from List<T>).
Public method | FindLastIndex | (Overloaded) Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<T>. (inherited from List<T>).
Public method | ForEach | Performs the specified action on each element of the List<T>. (inherited from List<T>).
Public method | GetEnumerator | Returns an enumerator that iterates through the List<T>. (inherited from List<T>).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<T>. (inherited from List<T>).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IndexOf | (Overloaded) Returns an index of the CADEntity in the CADEntityCollection.
Public method | Insert | Inserts an element into the List<T> at the specified index. (inherited from List<T>).
Public method | InsertRange | Inserts the elements of a collection into the List<T> at the specified index. (inherited from List<T>).
Public method | LastIndexOf | (Overloaded) Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<T>. (inherited from List<T>).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Remove | (Overloaded) Removes the CADEntity by its handle.
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (inherited from List<T>).
Public method | RemoveAt | Removes the element at the specified index of the List<T>. (inherited from List<T>).
Public method | RemoveRange | Removes a range of elements from the List<T>. (inherited from List<T>).
Public method | Reverse | (Overloaded) Reverses the order of the elements in the entire List<T>. (inherited from List<T>).
Public method | Sort | (Overloaded) Sorts the elements in the entire List<T> using the default comparer. (inherited from List<T>).
Public method | SortByHandle | Sorts CAD entities by handle.
Public method | ToArray | Copies the elements of the List<T> to a new array. (inherited from List<T>).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<T>, if that number is less than a threshold value. (inherited from List<T>).
Public method | TrueForAll | Determines whether every element in the List<T> matches the conditions defined by the specified predicate. (inherited from List<T>).
Top
See Also

Reference

CADEntityCollection Class


CADEntityCollection.Clone Method

Creates a new object that is a copy of the CADEntityCollection class current instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shadows Function Clone() As Object
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
new public object Clone()
This language is not supported or no code example is available.

Return Value

A new object that is a copy of this collection.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntityCollection Class
CADEntityCollection Members


CADEntityCollection.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Dispose() Implements  _
   IDisposable.Dispose
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Dispose()
This language is not supported or no code example is available.

Implements

IDisposable.Dispose
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntityCollection Class
CADEntityCollection Members


CADEntityCollection.IndexOf Method

CADEntityCollection Class See Also

Returns an index of the CADEntity in the CADEntityCollection.

Overload List
Name | Description
IndexOf(`0,Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<T> that extends from the specified index to the last element. (inherited from List<T>).
IndexOf(`0,Int32,Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<T> that starts at the specified index and contains the specified number of elements. (inherited from List<T>).
IndexOf(`0) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<T>. (System.Collections.Generic.List<T>).
IndexOf(CADEntity) | Returns an index of the CADEntity in the CADEntityCollection.
See Also

Reference

CADEntityCollection Class
CADEntityCollection Members


CADEntityCollection.Remove Method

CADEntityCollection Class See Also

Removes the CADEntity by its handle.

Overload List
Name | Description
Remove(`0) | Removes the first occurrence of a specific object from the List<T>. (System.Collections.Generic.List<T>).
Remove(UInt64) | Removes the CADEntity by its handle.
See Also

Reference

CADEntityCollection Class
CADEntityCollection Members


CADEntityCollection.SortByHandle Method

Sorts CAD entities by handle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SortByHandle()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SortByHandle()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntityCollection Class
CADEntityCollection Members


CADEntityCollection Events

CADEntityCollection Class See Also

The following tables list the members exposed by the CADEntityCollection type.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

CADEntityCollection Class


PropertyChanged Event

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event PropertyChanged() As System.ComponentModel.PropertyChangedEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event System.ComponentModel.PropertyChangedEventHandler PropertyChanged
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntityCollection Class
CADEntityCollection Members


CADExtrusion Class

Members See Also

Provides methods to recalculate coordinates taking into account 3D orientation.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADExtrusion
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADExtrusion
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADExtrusion
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADExtrusion Members


CADExtrusion Members

CADExtrusion Class Methods See Also

Provides methods to recalculate coordinates taking into account 3D orientation.

The following tables list the members exposed by the CADExtrusion type.

Methods
 | Name | Description
 | DoExtrusion | Recalculates coordinates of a point in the new coordinate system. This coordinate system is built respectively to Arbitary Axis Algoritm.
 | DoNewAutoCADAxes | Defines the axes for coordinates recalculation.
 | DoPreExtrusion | Recalculates coordinates of a point in the basic coordinate system. This coordinate system is built respectively to Arbitary Axis Algoritm.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | GetViewTwistMatrix | Calculates and returns a matrix that specifies a viewport.
 | MatFromExtr | Returns a matrix that specifies the extrusion.
 | Ort | Normalizes a point to Ort.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
 | Reverse | Inverts point coordinates.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
 | TurnAroundOfVector | Rotates a point around a vector by a specified angle.
 | Vector | Returns vector product of two vectors.
Top
See Also

Reference

CADExtrusion Class


CADExtrusion Methods

CADExtrusion Class See Also

The following tables list the members exposed by the CADExtrusion type.

Methods
 | Name | Description
 | DoExtrusion | Recalculates coordinates of a point in the new coordinate system. This coordinate system is built respectively to Arbitary Axis Algoritm.
 | DoNewAutoCADAxes | Defines the axes for coordinates recalculation.
 | DoPreExtrusion | Recalculates coordinates of a point in the basic coordinate system. This coordinate system is built respectively to Arbitary Axis Algoritm.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | GetViewTwistMatrix | Calculates and returns a matrix that specifies a viewport.
 | MatFromExtr | Returns a matrix that specifies the extrusion.
 | Ort | Normalizes a point to Ort.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
 | Reverse | Inverts point coordinates.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
 | TurnAroundOfVector | Rotates a point around a vector by a specified angle.
 | Vector | Returns vector product of two vectors.
Top
See Also

Reference

CADExtrusion Class


CADExtrusion.DoExtrusion Method

Recalculates coordinates of a point in the new coordinate system. This coordinate system is built respectively to Arbitary Axis Algoritm.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub DoExtrusion( _
   ByRef P As DPoint, _
   ByVal N As DPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void DoExtrusion(
   ref DPoint P,
   DPoint N
)
This language is not supported or no code example is available.

Parameters

P

Type: DPoint

A drawing 3D point to be changed

N

Type: DPoint

0Z axis of the new coordinate system, where 0X and 0Y are being selected respectively to Arbitary Axis Algoritm.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADExtrusion Class
CADExtrusion Members


CADExtrusion.DoNewAutoCADAxes Method

Defines the axes for coordinates recalculation.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub DoNewAutoCADAxes( _
   ByVal V As DPoint, _
   ByRef UX As DPoint, _
   ByRef UY As DPoint, _
   ByRef UZ As DPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void DoNewAutoCADAxes(
   DPoint V,
   ref DPoint UX,
   ref DPoint UY,
   ref DPoint UZ
)
This language is not supported or no code example is available.

Parameters

V

Type: DPoint

A vector

UX

Type: DPoint

Receives X direction vector

UY

Type: DPoint

Receives Y direction vector

UZ

Type: DPoint

Receives Z direction vector

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADExtrusion Class
CADExtrusion Members


CADExtrusion.DoPreExtrusion Method

Recalculates coordinates of a point in the basic coordinate system. This coordinate system is built respectively to Arbitary Axis Algoritm.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub DoPreExtrusion( _
   ByRef P As DPoint, _
   ByVal N As DPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void DoPreExtrusion(
   ref DPoint P,
   DPoint N
)
This language is not supported or no code example is available.

Parameters

P

Type: DPoint

A drawing 3D point to be changed

N

Type: DPoint

0Z axis of the basic coordinate system, where 0X and 0Y are being selected respectively to Arbitary Axis Algoritm

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADExtrusion Class
CADExtrusion Members


CADExtrusion.GetViewTwistMatrix Method

Calculates and returns a matrix that specifies a viewport.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function GetViewTwistMatrix( _
   ByVal ADirect As DPoint, _
   ByVal AAngle As Single _
) As CADMatrix
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static CADMatrix GetViewTwistMatrix(
   DPoint ADirect,
   float AAngle
)
This language is not supported or no code example is available.

Parameters

ADirect

Type: DPoint

A viewport view direction point

AAngle

Type: float

A viewport ViewTwistAngle value

Return Value

A matrix that specifies a viewport.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADExtrusion Class
CADExtrusion Members


CADExtrusion.MatFromExtr Method

Returns a matrix that specifies the extrusion.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function MatFromExtr( _
   ByVal P As DPoint, _
   ByVal Angle As Single _
) As CADMatrix
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static CADMatrix MatFromExtr(
   DPoint P,
   float Angle
)
This language is not supported or no code example is available.

Parameters

P

Type: DPoint

A view direction point

Angle

Type: float

A rotation angle

Return Value

A matrix that specify the extrusion
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADExtrusion Class
CADExtrusion Members


CADExtrusion.Ort Method

Normalizes a point to Ort.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function Ort( _
   ByVal P As DPoint _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static DPoint Ort(
   DPoint P
)
This language is not supported or no code example is available.

Parameters

P

Type: DPoint

A drawing 3D point to be normalized

Return Value

The normalized drawing 3D point
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADExtrusion Class
CADExtrusion Members


CADExtrusion.Reverse Method

Inverts point coordinates.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function Reverse( _
   ByVal P As DPoint _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static DPoint Reverse(
   DPoint P
)
This language is not supported or no code example is available.

Parameters

P

Type: DPoint

A drawing 3D point

Return Value

An inverted 3D point
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADExtrusion Class
CADExtrusion Members


CADExtrusion.TurnAroundOfVector Method

Rotates a point around a vector by a specified angle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function TurnAroundOfVector( _
   ByVal APoint As DPoint, _
   ByVal AVect As DPoint, _
   ByVal AAngle As Double _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static DPoint TurnAroundOfVector(
   DPoint APoint,
   DPoint AVect,
   double AAngle
)
This language is not supported or no code example is available.

Parameters

APoint

Type: DPoint

A drawing 3D point to be rotated

AVect

Type: DPoint

A vector

AAngle

Type: double

The rotation angle

Return Value

A rotated drawing 3D point
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADExtrusion Class
CADExtrusion Members


CADExtrusion.Vector Method

Returns vector product of two vectors.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function Vector( _
   ByVal P1 As DPoint, _
   ByVal P2 As DPoint _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static DPoint Vector(
   DPoint P1,
   DPoint P2
)
This language is not supported or no code example is available.

Parameters

P1

Type: DPoint

The first vector

P2

Type: DPoint

The second vector

Return Value

A vector product of two vectors
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADExtrusion Class
CADExtrusion Members


CADGradientPolygon Class

Members See Also

Represents a hatch with a gradient filling.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADGradientPolygon
    Inherits CADPolyPolygon
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADGradientPolygon : CADPolyPolygon
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPolyPolygon
CADImport.CADGradientPolygon
CADImport.CADCurvePolygon
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGradientPolygon Members


CADGradientPolygon Members

CADGradientPolygon Class Constructors Methods Fields Properties See Also

Represents a hatch with a gradient filling.

The following tables list the members exposed by the CADGradientPolygon type.

Constructors
 | Name | Description
Public constructor | CADGradientPolygon | Initializes a new instance of the CADPolyPolygon class. (inherited from CADPolyPolygon).
Top
Properties
 | Name | Description
Public property | Boundaries | Gets a collection of boundaries of this CADPolyPolygon. (inherited from CADPolyPolygon).
Public property | Box | Gets a three-dimensional box that encloses this CADPolyPolygon. (inherited from CADPolyPolygon).
Public property | Color | Gets or sets a color of this CADPolyPolygon. (inherited from CADPolyPolygon).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADGradientPolygon entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Filled | (inherited from CADPolyPolygon).
Public property | GradientColor | Gets or sets a gradient color.
Public property | GradientName | Gets or sets a name of the gradient.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPolyPolygon).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Destroy | Clears a collection of this CADPolyPolygon boundaries. (inherited from CADPolyPolygon).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADPolyPolygon must be drawn during a drawing cycle. (inherited from CADPolyPolygon).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADPolyPolygon to the specified CADConverter. (inherited from CADPolyPolygon).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADGradientPolygon Class


CADPolyPolygon Constructor

Initializes a new instance of the CADPolyPolygon class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADPolyPolygon()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyPolygon Class
CADPolyPolygon Members


CADGradientPolygon Properties

CADGradientPolygon Class See Also

The following tables list the members exposed by the CADGradientPolygon type.

Properties
 | Name | Description
Public property | Boundaries | Gets a collection of boundaries of this CADPolyPolygon. (inherited from CADPolyPolygon).
Public property | Box | Gets a three-dimensional box that encloses this CADPolyPolygon. (inherited from CADPolyPolygon).
Public property | Color | Gets or sets a color of this CADPolyPolygon. (inherited from CADPolyPolygon).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADGradientPolygon entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Filled | (inherited from CADPolyPolygon).
Public property | GradientColor | Gets or sets a gradient color.
Public property | GradientName | Gets or sets a name of the gradient.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPolyPolygon).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
See Also

Reference

CADGradientPolygon Class


CADGradientPolygon.EntType Property

Gets the type of this CADGradientPolygon entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGradientPolygon Class
CADGradientPolygon Members


CADGradientPolygon Methods

CADGradientPolygon Class See Also

The following tables list the members exposed by the CADGradientPolygon type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Destroy | Clears a collection of this CADPolyPolygon boundaries. (inherited from CADPolyPolygon).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADPolyPolygon must be drawn during a drawing cycle. (inherited from CADPolyPolygon).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADPolyPolygon to the specified CADConverter. (inherited from CADPolyPolygon).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADGradientPolygon Class


CADGradientPolygon.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGradientPolygon Class
CADGradientPolygon Members


CADPolyPolygon.Destroy Method

Clears a collection of this CADPolyPolygon boundaries.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub Destroy()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void Destroy()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyPolygon Class
CADPolyPolygon Members


CADGradientPolygon.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGradientPolygon Class
CADGradientPolygon Members


CADPolyPolygon.GetBoxPoints Method

Checks if the CADPolyPolygon must be drawn during a drawing cycle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function GetBoxPoints( _
   ByVal Proc As FPointProc, _
   ByVal Full As Boolean _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool GetBoxPoints(
   FPointProc Proc,
   bool Full
)
This language is not supported or no code example is available.

Parameters

Proc

Type: FPointProc

A FPointProc delegate that references a method for getting CADPolyPolygon's points.

Full

Type: bool

A boolean value indicating whether the method realizes full or reduced checking. true if checking is full, false if checking is reduced.

Return Value

true if all points passed to the referenced method are the real entity's points; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyPolygon Class
CADPolyPolygon Members


CADGradientPolygon Fields

CADGradientPolygon Class See Also

The following tables list the members exposed by the CADGradientPolygon type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADGradientPolygon Class


CADGraphics2D<T> Class

Members See Also

Abstract class for internal use.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public MustInherit Class CADGraphics2D(Of  _
   T As new())
    Inherits CADPainter(Of T)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public abstract class CADGraphics2D<T> : CADPainter<T>
   where T : new()
This language is not supported or no code example is available.

Type Parameters

T

Inheritance Hierarchy
System.Object
CADImport.CADPresenter
CADImport.CADPainter<T>
CADImport.CADGraphics2D<T>
CADImport.CADGraphicsGDI
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphics2D<T> Members


CADGraphics2D<T> Members

CADGraphics2D<T> Class Methods Properties See Also

Abstract class for internal use.

The following tables list the members exposed by the CADGraphics2D<T> type.

Properties
 | Name | Description
Public property | DrawMatrix | (inherited from CADPresenter).
Public property | DrawTarget | Represents a surface for visualization (inherited from CADPresenter).
Public property | DrawTextMeansGDIPlusMethods | Gets or sets drawing mode of simple and not rotated texts by GDI+ drawing text means
Public property | Image | Gets or sets a CADImage for visualization (inherited from CADPresenter).
Public property | RenderMode | Gets or sets rendering mode. (inherited from CADPresenter).
Public property | Settings | Gets a set of settings for visualization. (inherited from CADPresenter).
Public property | UseDoubleBuffering | Outdated. Does Nothing. (inherited from CADPresenter).
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles in the CADImage are drawn with GDI+ drawing methods without linearization.
Public property | VisibleBox | Gets a rectangular area that will be visualized. (inherited from CADPainter<T>).
Top
Methods
 | Name | Description
Public method | Add_T | (Overloaded) Performs addition of two points. (inherited from CADPainter<T>).
Public method | ApplyScale | Calculates a matrix for drawing based on current scale. (inherited from CADPainter<T>).
Public method | ClearMarkers | Clears a collection of markers. (inherited from CADPresenter).
Public method | ConvertTo_T | Converts a DPoint object. (inherited from CADPainter<T>).
Public method | Dispose | For inheritance. (inherited from CADPainter<T>).
Public method | DoFinish | Finishes drawing an entity. (inherited from CADPainter<T>).
Public method | Draw | (Overloaded) Draws a CADImage. (inherited from CADPainter<T>).
Public method | DrawEntities | Invokes drawing method for specified entities if they are visible (inherited from CADPainter<T>).
Public method | DrawEntity | Draws a specified CAD entity in the current CAD image. (inherited from CADPainter<T>).
Public method | DrawImage | (Overloaded) Draws a raster image or a metafile object. (inherited from CADPainter<T>).
Public method | DrawLine | (Overloaded) Draws a polyline by two specified points. (inherited from CADPainter<T>).
Public method | DrawPixel | (Overloaded) Draws a single pixel (inherited from CADPainter<T>).
Public method | DrawPolyPolyLine | (Overloaded) Draws a set of lines or a set of polygons (inherited from CADPainter<T>).
Public method | DrawPolyline | (Overloaded) Draws a polyline (inherited from CADPainter<T>).
Public method | DrawString | (Overloaded) Draws a text string. (inherited from CADPainter<T>).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportToMetafile | (Overloaded) Exports a CAD drawing to Windows Enhanced metafile. (inherited from CADPainter<T>).
Public method | FillPolyPolyLine | (Overloaded) Draws a filled polygons. (inherited from CADPainter<T>).
Public method | FillPolyline | (Overloaded) Draws a filled polyline. (inherited from CADPainter<T>).
Public method | GetExtents | Calculates the current dimensions of the CADImage. (inherited from CADPresenter).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetPoint | Transforms a three-dimensional CAD point into a two-dimensional screen point. (inherited from CADPainter<T>).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IsEqual_T | (Overloaded) Checks if two points are equal. (inherited from CADPainter<T>).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from CADPresenter).
Public method | RotToView | Rotates a CAD image to get a specified view. (inherited from CADPresenter).
Public method | Rotate | Rotates objects in the current drawing. (inherited from CADPresenter).
Public method | SaveImageToClipboard | (Overloaded) Writes a visible part of the current CAD image to the clipboard as a raster image. (inherited from CADPresenter).
Public method | SaveToFile | (Overloaded) Writes a visible part of the current CAD image to the disk as a raster image. (inherited from CADPresenter).
Public method | SaveToStream | (Overloaded) Writes a visible part of the current CAD image to the specified stream as a raster image. (inherited from CADPresenter).
Public method | Sub_T | (Overloaded) Performs subtraction of two points. (inherited from CADPainter<T>).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADGraphics2D<T> Class


CADGraphics2D<T> Properties

CADGraphics2D<T> Class See Also

The following tables list the members exposed by the CADGraphics2D<T> type.

Properties
 | Name | Description
Public property | DrawMatrix | (inherited from CADPresenter).
Public property | DrawTarget | Represents a surface for visualization (inherited from CADPresenter).
Public property | DrawTextMeansGDIPlusMethods | Gets or sets drawing mode of simple and not rotated texts by GDI+ drawing text means
Public property | Image | Gets or sets a CADImage for visualization (inherited from CADPresenter).
Public property | RenderMode | Gets or sets rendering mode. (inherited from CADPresenter).
Public property | Settings | Gets a set of settings for visualization. (inherited from CADPresenter).
Public property | UseDoubleBuffering | Outdated. Does Nothing. (inherited from CADPresenter).
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles in the CADImage are drawn with GDI+ drawing methods without linearization.
Public property | VisibleBox | Gets a rectangular area that will be visualized. (inherited from CADPainter<T>).
Top
See Also

Reference

CADGraphics2D<T> Class


CADPresenter.DrawMatrix Property

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Property DrawMatrix() As CADMatrix
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual CADMatrix DrawMatrix {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.DrawTarget Property

Represents a surface for visualization

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Property DrawTarget() As Graphics
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual Graphics DrawTarget {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADGraphics2D<T>.DrawTextMeansGDIPlusMethods Property

Gets or sets drawing mode of simple and not rotated texts by GDI+ drawing text means

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DrawTextMeansGDIPlusMethods() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool DrawTextMeansGDIPlusMethods {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphics2D<T> Class
CADGraphics2D<T> Members


CADPresenter.Image Property

Gets or sets a CADImage for visualization

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Image() As CADImage
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADImage Image {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.RenderMode Property

Gets or sets rendering mode.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property RenderMode() As RenderMode
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public RenderMode RenderMode {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.Settings Property

Gets a set of settings for visualization.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Settings() As CADPresenterSettings
    Get

This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADPresenterSettings Settings {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.UseDoubleBuffering Property

Outdated. Does Nothing.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Property UseDoubleBuffering() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual bool UseDoubleBuffering {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADGraphics2D<T>.UseWinEllipse Property

Gets or sets a value indicating whether arcs and circles in the CADImage are drawn with GDI+ drawing methods without linearization.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property UseWinEllipse() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool UseWinEllipse {get; set;}
This language is not supported or no code example is available.

Property Value

true if the GDI+ methods are used for drawing arcs and circles in the CADImage; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphics2D<T> Class
CADGraphics2D<T> Members


CADPainter<T>.VisibleBox Property

Gets a rectangular area that will be visualized.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property VisibleBox() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override DRect VisibleBox {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADGraphics2D<T> Methods

CADGraphics2D<T> Class See Also

The following tables list the members exposed by the CADGraphics2D<T> type.

Methods
 | Name | Description
Public method | Add_T | (Overloaded) Performs addition of two points. (inherited from CADPainter<T>).
Public method | ApplyScale | Calculates a matrix for drawing based on current scale. (inherited from CADPainter<T>).
Public method | ClearMarkers | Clears a collection of markers. (inherited from CADPresenter).
Public method | ConvertTo_T | Converts a DPoint object. (inherited from CADPainter<T>).
Public method | Dispose | For inheritance. (inherited from CADPainter<T>).
Public method | DoFinish | Finishes drawing an entity. (inherited from CADPainter<T>).
Public method | Draw | (Overloaded) Draws a CADImage. (inherited from CADPainter<T>).
Public method | DrawEntities | Invokes drawing method for specified entities if they are visible (inherited from CADPainter<T>).
Public method | DrawEntity | Draws a specified CAD entity in the current CAD image. (inherited from CADPainter<T>).
Public method | DrawImage | (Overloaded) Draws a raster image or a metafile object. (inherited from CADPainter<T>).
Public method | DrawLine | (Overloaded) Draws a polyline by two specified points. (inherited from CADPainter<T>).
Public method | DrawPixel | (Overloaded) Draws a single pixel (inherited from CADPainter<T>).
Public method | DrawPolyPolyLine | (Overloaded) Draws a set of lines or a set of polygons (inherited from CADPainter<T>).
Public method | DrawPolyline | (Overloaded) Draws a polyline (inherited from CADPainter<T>).
Public method | DrawString | (Overloaded) Draws a text string. (inherited from CADPainter<T>).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportToMetafile | (Overloaded) Exports a CAD drawing to Windows Enhanced metafile. (inherited from CADPainter<T>).
Public method | FillPolyPolyLine | (Overloaded) Draws a filled polygons. (inherited from CADPainter<T>).
Public method | FillPolyline | (Overloaded) Draws a filled polyline. (inherited from CADPainter<T>).
Public method | GetExtents | Calculates the current dimensions of the CADImage. (inherited from CADPresenter).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetPoint | Transforms a three-dimensional CAD point into a two-dimensional screen point. (inherited from CADPainter<T>).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IsEqual_T | (Overloaded) Checks if two points are equal. (inherited from CADPainter<T>).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from CADPresenter).
Public method | RotToView | Rotates a CAD image to get a specified view. (inherited from CADPresenter).
Public method | Rotate | Rotates objects in the current drawing. (inherited from CADPresenter).
Public method | SaveImageToClipboard | (Overloaded) Writes a visible part of the current CAD image to the clipboard as a raster image. (inherited from CADPresenter).
Public method | SaveToFile | (Overloaded) Writes a visible part of the current CAD image to the disk as a raster image. (inherited from CADPresenter).
Public method | SaveToStream | (Overloaded) Writes a visible part of the current CAD image to the specified stream as a raster image. (inherited from CADPresenter).
Public method | Sub_T | (Overloaded) Performs subtraction of two points. (inherited from CADPainter<T>).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADGraphics2D<T> Class


CADPainter<T>.Add_T Method

CADPainter<T> Class See Also

Performs addition of two points.

Overload List
Name | Description
Add_T(DPoint, DPoint) | Performs addition of two points. (inherited from CADPresenter).
Add_T(T, T) | Performs addition of two points.
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.ApplyScale Method

Calculates a matrix for drawing based on current scale.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ApplyScale( _
   ByVal Arect As RectangleF _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ApplyScale(
   RectangleF Arect
)
This language is not supported or no code example is available.

Parameters

Arect

Type: RectangleF

A current visualization rectangle.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPresenter.ClearMarkers Method

Clears a collection of markers.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ClearMarkers()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ClearMarkers()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPainter<T>.ConvertTo_T Method

Converts a DPoint object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Shadows Function ConvertTo_T( _
   ByVal p As DPoint _
) As T
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
new public virtual T ConvertTo_T(
   DPoint p
)
This language is not supported or no code example is available.

Parameters

p

Type: DPoint

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.Dispose Method

For inheritance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.DoFinish Method

Finishes drawing an entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function DoFinish( _
   ByVal ent As CADEntity _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool DoFinish(
   CADEntity ent
)
This language is not supported or no code example is available.

Parameters

ent

Type: CADEntity

An entity

Return Value

true if succeed; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.Draw Method

CADPainter<T> Class See Also

Draws a CADImage.

Overload List
Name | Description
Draw(Graphics, RectangleF) | Draws a CADImage.
Draw(Graphics, RectangleF, Region) | Draws a CADImage.
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.DrawEntities Method

Invokes drawing method for specified entities if they are visible

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DrawEntities( _
   ByVal entities As SortedList _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DrawEntities(
   SortedList entities
)
This language is not supported or no code example is available.

Parameters

entities

Type: SortedList

A set of drawing entities

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.DrawEntity Method

Draws a specified CAD entity in the current CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function DrawEntity( _
   ByVal Ent As CADEntity _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool DrawEntity(
   CADEntity Ent
)
This language is not supported or no code example is available.

Parameters

Ent

Type: CADEntity

A CADEntity to draw in the current CADImage.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.DrawImage Method

CADPainter<T> Class See Also

Draws a raster image or a metafile object.

Overload List
Name | Description
DrawImage(Image, DPoint[], bool, Color) | Draws a raster image or a metafile object. (inherited from CADPresenter).
DrawImage(Image, T[], bool, Color) | Draws a raster image or a metafile object.
DrawImage(Image, T, T, T, bool, Color) | Draws a raster image or a metafile object.
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.DrawLine Method

CADPainter<T> Class See Also

Draws a polyline by two specified points.

Overload List
Name | Description
DrawLine(DPoint, DPoint) | Draws a polyline by two specified points. (inherited from CADPresenter).
DrawLine(T, T) | Draws a polyline by two specified points.
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.DrawPixel Method

CADPainter<T> Class See Also

Draws a single pixel

Overload List
Name | Description
DrawPixel(DPoint) | Draws a single pixel (inherited from CADPresenter).
DrawPixel(T) | Draws a single pixel
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.DrawPolyPolyLine Method

CADPainter<T> Class See Also

Draws a set of lines or a set of polygons

Overload List
Name | Description
DrawPolyPolyLine(DPoint[], int[], bool) | Draws a set of lines or a set of polygons (inherited from CADPresenter).
DrawPolyPolyLine(T[], int[], bool) | Draws a set of lines or a set of polygons
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.DrawPolyline Method

CADPainter<T> Class See Also

Draws a polyline

Overload List
Name | Description
DrawPolyline(DPoint[], bool) | Draws a polyline (inherited from CADPresenter).
DrawPolyline(T[], bool) | Draws a polyline
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.DrawString Method

CADPainter<T> Class See Also

Draws a text string.

Overload List
Name | Description
DrawString(string, Font, int, DPoint, CADTextHorizontalAlign) | Draws a text string. (inherited from CADPresenter).
DrawString(string, Font, int, T, CADTextHorizontalAlign) | Draws a text string.
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.ExportToMetafile Method

CADPainter<T> Class See Also

Exports a CAD drawing to Windows Enhanced metafile.

Overload List
Name | Description
ExportToMetafile(string, DRect) | Exports a CAD drawing to Windows Enhanced metafile.
ExportToMetafile(string, DRect, Rectangle) | Exports a CAD drawing to Windows Enhanced metafile.
ExportToMetafile(string, DRect, Rectangle, bool) | Exports a CAD drawing to Windows Enhanced metafile.
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.FillPolyPolyLine Method

CADPainter<T> Class See Also

Draws a filled polygons.

Overload List
Name | Description
FillPolyPolyLine(DPoint[], int[]) | Draws a filled polygons. (inherited from CADPresenter).
FillPolyPolyLine(T[], int[]) | Draws a filled polygons.
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.FillPolyline Method

CADPainter<T> Class See Also

Draws a filled polyline.

Overload List
Name | Description
FillPolyline(DPoint[]) | Draws a filled polyline. (inherited from CADPresenter).
FillPolyline(T[]) | Draws a filled polyline.
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPresenter.GetExtents Method

Calculates the current dimensions of the CADImage.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub GetExtents()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void GetExtents()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPainter<T>.GetPoint Method

Example See Also

Transforms a three-dimensional CAD point into a two-dimensional screen point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shadows Function GetPoint( _
   ByVal P As DPoint _
) As T
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
new public T GetPoint(
   DPoint P
)
This language is not supported or no code example is available.

Parameters

P

Type: DPoint

A DPoint object representing a point in three-dimensional coordinate system.

Return Value

A Point object representing a point in two-dimensional coordinate system.
Example
<p>Example use GetPoint method:</p> <p>[C#]</p>
Copy
 ...
 CADLine ln = cadImage.Converter.Entities[0] as CADLine;
 if(ln != null)
 {
     Point p1 = cadImage.GetPoint(ln.Point);
     Point p2 = cadImage.GetPoint(ln.Point1);
     Console.Write(String.Format("Line X1={0} Y1={1} X2={2} Y2={3}", p1.X, p1.Y, p2.X, p2.Y))
 }
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.IsEqual_T Method

CADPainter<T> Class See Also

Checks if two points are equal.

Overload List
Name | Description
IsEqual_T(DPoint, DPoint) | Checks if two points are equal. (inherited from CADPresenter).
IsEqual_T(T, T) | Checks if two points are equal.
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPresenter.RotDefault Method

Rotates the drawing to the default view.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub RotDefault()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void RotDefault()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.RotToView Method

Rotates a CAD image to get a specified view.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub RotToView( _
   ByVal A3DView As CADViewDirection _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void RotToView(
   CADViewDirection A3DView
)
This language is not supported or no code example is available.

Parameters

A3DView

Type: CADViewDirection

One of the CADViewDirection values that specifies a view of the CAD image.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.Rotate Method

Rotates objects in the current drawing.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub Rotate( _
   ByVal Axis As Axes, _
   ByVal Angle As Single _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void Rotate(
   Axes Axis,
   float Angle
)
This language is not supported or no code example is available.

Parameters

Axis

Type: Axes

One of the Axes values specifying an axis of rotation.

Angle

Type: float

An angle of rotation.

Remarks

An angle of rotation is measured in degrees.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.SaveImageToClipboard Method

CADPresenter Class See Also

Writes a visible part of the current CAD image to the clipboard as a raster image.

Overload List
Name | Description
SaveImageToClipboard(DRect) | Writes a visible part of the current CAD image to the clipboard as a raster image.
SaveImageToClipboard(DRect, PixelFormat) | Writes a visible part of the current CAD image to the clipboard as a raster image.
SaveImageToClipboard(DRect, Rectangle) | Writes a specified part of the current CAD image to the clipboard as a raster image.
SaveImageToClipboard(DRect, Rectangle, PixelFormat) | Writes a specified part of the current CAD image to the clipboard as a raster image.
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.SaveToFile Method

CADPresenter Class See Also

Writes a visible part of the current CAD image to the disk as a raster image.

Overload List
Name | Description
SaveToFile(string, ImageFormat, DRect, PixelFormat, RectangleF, Graphics) | Writes a visible part of the current CAD image to the disk as a raster image.
SaveToFile(string, ImageFormat, DRect, RectangleF, Graphics) | Writes a visible part of the current CAD image to the disk as a raster image.
SaveToFile(string, ImageFormat, DRect, Rectangle) | Writes a specified part of the current CAD image to the disk as a raster image.
SaveToFile(string, ImageFormat, DRect, Rectangle, PixelFormat) | Saves a current CAD image to the file of the specified format.
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.SaveToStream Method

CADPresenter Class See Also

Writes a visible part of the current CAD image to the specified stream as a raster image.

Overload List
Name | Description
SaveToStream(Stream, ImageFormat, DRect) | Writes a visible part of the current CAD image to the specified stream as a raster image.
SaveToStream(Stream, ImageFormat, DRect, PixelFormat) | Writes a visible part of the current CAD image to the specified stream as a raster image.
SaveToStream(Stream, ImageFormat, DRect, Rectangle) | Writes a specified part of the current CAD image to the clipboard as a raster image.
SaveToStream(Stream, ImageFormat, DRect, Rectangle, PixelFormat) | Saves a current CAD image to the stream of the specified format.
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPainter<T>.Sub_T Method

CADPainter<T> Class See Also

Performs subtraction of two points.

Overload List
Name | Description
Sub_T(DPoint, DPoint) | Performs subtraction of two points. (inherited from CADPresenter).
Sub_T(T, T) | Performs subtraction of two points.
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADGraphicsGDI Class

Members See Also

Provides drawing functionality based on GDI+.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADGraphicsGDI
    Inherits CADGraphics2D(Of Point)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADGraphicsGDI : CADGraphics2D<Point>
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADPresenter
CADImport.CADPainter<T>
CADImport.CADGraphics2D<T>
CADImport.CADGraphicsGDI
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Members


CADGraphicsGDI Members

CADGraphicsGDI Class Constructors Methods Properties See Also

Provides drawing functionality based on GDI+.

The following tables list the members exposed by the CADGraphicsGDI type.

Constructors
 | Name | Description
Public constructor | CADGraphicsGDI | Initializes a new instance of the CADGraphicsGDI class.
Top
Properties
 | Name | Description
Public property | DrawMatrix | (inherited from CADPresenter).
Public property | DrawTarget | Gets or sets a GDI+ drawing surface.
Public property | DrawTextMeansGDIPlusMethods | Gets or sets drawing mode of simple and not rotated texts by GDI+ drawing text means (inherited from CADGraphics2D<T>).
Public property | HighQualityRendering | Gets or sets a value specifying if visualization quality settings mus be used.
Public property | Image | Gets or sets a CADImage for visualization (inherited from CADPresenter).
Public property | InterpolationMode | Gets or sets the interpolation mode associated with current Graphics object
Public property | RenderMode | Gets or sets rendering mode. (inherited from CADPresenter).
Public property | Settings | Gets a set of settings for visualization. (inherited from CADPresenter).
Public property | UseDoubleBuffering | Outdated. Does nothing
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles in the CADImage are drawn with GDI+ drawing methods without linearization. (inherited from CADGraphics2D<T>).
Public property | VisibleBox | Gets a rectangular area that will be visualized. (inherited from CADPainter<T>).
Top
Methods
 | Name | Description
Public method | Add_T | (Overloaded) Performs addition of two points.
Public method | ApplyScale | Calculates a matrix for drawing based on current scale. (inherited from CADPainter<T>).
Public method | ClearMarkers | Clears a collection of markers. (inherited from CADPresenter).
Public method | ConvertTo_T | Converts a DPoint object into a Point object.
Public method | Dispose | Releases all resources used by the CADGraphicsGDI
Public method | DoFinish | Finishes drawing an entity. (inherited from CADPainter<T>).
Public method | Draw | (Overloaded) Draws a CADImage. (inherited from CADPainter<T>).
Public method | DrawEntities | Invokes drawing method for specified entities if they are visible (inherited from CADPainter<T>).
Public method | DrawEntity | Draws a specified CAD entity in the current CAD image. (inherited from CADPainter<T>).
Public method | DrawImage | (Overloaded) Draws a raster image or a metafile object.
Public method | DrawLine | (Overloaded) Draws a polyline by two specified points.
Public method | DrawPixel | (Overloaded) Draws a single pixel
Public method | DrawPolyPolyLine | (Overloaded) Draws a set of lines or a set of polygons
Public method | DrawPolyline | (Overloaded) Draws a polyline
Public method | DrawString | (Overloaded) Draws a text string.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportToMetafile | (Overloaded) Exports a CAD drawing to Windows Enhanced metafile.
Public method | FillPolyPolyLine | (Overloaded) Draws a filled polygons.
Public method | FillPolyline | (Overloaded) Draws a filled polyline.
Public method | GetExtents | Calculates the current dimensions of the CADImage. (inherited from CADPresenter).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetPoint | Transforms a three-dimensional CAD point into a two-dimensional screen point. (inherited from CADPainter<T>).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IsEqual_T | (Overloaded) Checks if two points are equal.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from CADPresenter).
Public method | RotToView | Rotates a CAD image to get a specified view. (inherited from CADPresenter).
Public method | Rotate | Rotates objects in the current drawing. (inherited from CADPresenter).
Public method | SaveImageToClipboard | (Overloaded) Writes a visible part of the current CAD image to the clipboard as a raster image.
Public method | SaveToFile | (Overloaded) Writes a visible part of the current CAD image to the disk as a raster image.
Public method | SaveToStream | (Overloaded) Saves a current CAD image to the stream of the specified format.
Public method | Sub_T | (Overloaded) Performs substraction of two points.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADGraphicsGDI Class


CADGraphicsGDI Constructor

Initializes a new instance of the CADGraphicsGDI class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADGraphicsGDI()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI Properties

CADGraphicsGDI Class See Also

The following tables list the members exposed by the CADGraphicsGDI type.

Properties
 | Name | Description
Public property | DrawMatrix | (inherited from CADPresenter).
Public property | DrawTarget | Gets or sets a GDI+ drawing surface.
Public property | DrawTextMeansGDIPlusMethods | Gets or sets drawing mode of simple and not rotated texts by GDI+ drawing text means (inherited from CADGraphics2D<T>).
Public property | HighQualityRendering | Gets or sets a value specifying if visualization quality settings mus be used.
Public property | Image | Gets or sets a CADImage for visualization (inherited from CADPresenter).
Public property | InterpolationMode | Gets or sets the interpolation mode associated with current Graphics object
Public property | RenderMode | Gets or sets rendering mode. (inherited from CADPresenter).
Public property | Settings | Gets a set of settings for visualization. (inherited from CADPresenter).
Public property | UseDoubleBuffering | Outdated. Does nothing
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles in the CADImage are drawn with GDI+ drawing methods without linearization. (inherited from CADGraphics2D<T>).
Public property | VisibleBox | Gets a rectangular area that will be visualized. (inherited from CADPainter<T>).
Top
See Also

Reference

CADGraphicsGDI Class


CADGraphicsGDI.DrawTarget Property

Gets or sets a GDI+ drawing surface.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property DrawTarget() As Graphics
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override Graphics DrawTarget {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.HighQualityRendering Property

Gets or sets a value specifying if visualization quality settings mus be used.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property HighQualityRendering() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool HighQualityRendering {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.InterpolationMode Property

Gets or sets the interpolation mode associated with current Graphics object

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property InterpolationMode() As InterpolationMode
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public InterpolationMode InterpolationMode {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.UseDoubleBuffering Property

Outdated. Does nothing

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property UseDoubleBuffering() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool UseDoubleBuffering {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI Methods

CADGraphicsGDI Class See Also

The following tables list the members exposed by the CADGraphicsGDI type.

Methods
 | Name | Description
Public method | Add_T | (Overloaded) Performs addition of two points.
Public method | ApplyScale | Calculates a matrix for drawing based on current scale. (inherited from CADPainter<T>).
Public method | ClearMarkers | Clears a collection of markers. (inherited from CADPresenter).
Public method | ConvertTo_T | Converts a DPoint object into a Point object.
Public method | Dispose | Releases all resources used by the CADGraphicsGDI
Public method | DoFinish | Finishes drawing an entity. (inherited from CADPainter<T>).
Public method | Draw | (Overloaded) Draws a CADImage. (inherited from CADPainter<T>).
Public method | DrawEntities | Invokes drawing method for specified entities if they are visible (inherited from CADPainter<T>).
Public method | DrawEntity | Draws a specified CAD entity in the current CAD image. (inherited from CADPainter<T>).
Public method | DrawImage | (Overloaded) Draws a raster image or a metafile object.
Public method | DrawLine | (Overloaded) Draws a polyline by two specified points.
Public method | DrawPixel | (Overloaded) Draws a single pixel
Public method | DrawPolyPolyLine | (Overloaded) Draws a set of lines or a set of polygons
Public method | DrawPolyline | (Overloaded) Draws a polyline
Public method | DrawString | (Overloaded) Draws a text string.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportToMetafile | (Overloaded) Exports a CAD drawing to Windows Enhanced metafile.
Public method | FillPolyPolyLine | (Overloaded) Draws a filled polygons.
Public method | FillPolyline | (Overloaded) Draws a filled polyline.
Public method | GetExtents | Calculates the current dimensions of the CADImage. (inherited from CADPresenter).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetPoint | Transforms a three-dimensional CAD point into a two-dimensional screen point. (inherited from CADPainter<T>).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IsEqual_T | (Overloaded) Checks if two points are equal.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from CADPresenter).
Public method | RotToView | Rotates a CAD image to get a specified view. (inherited from CADPresenter).
Public method | Rotate | Rotates objects in the current drawing. (inherited from CADPresenter).
Public method | SaveImageToClipboard | (Overloaded) Writes a visible part of the current CAD image to the clipboard as a raster image.
Public method | SaveToFile | (Overloaded) Writes a visible part of the current CAD image to the disk as a raster image.
Public method | SaveToStream | (Overloaded) Saves a current CAD image to the stream of the specified format.
Public method | Sub_T | (Overloaded) Performs substraction of two points.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADGraphicsGDI Class


CADGraphicsGDI.Add_T Method

CADGraphicsGDI Class See Also

Performs addition of two points.

Overload List
Name | Description
Add_T(Point, Point) | Performs addition of two points.
Add_T(DPoint, DPoint) | Performs addition of two points. (inherited from CADPresenter).
Add_T(T, T) | Performs addition of two points. (inherited from CADPainter<T>).
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.ConvertTo_T Method

Converts a DPoint object into a Point object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function ConvertTo_T( _
   ByVal p As DPoint _
) As Point
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override Point ConvertTo_T(
   DPoint p
)
This language is not supported or no code example is available.

Parameters

p

Type: DPoint

A DPoint object to be converted.

Return Value

A Point object.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.Dispose Method

Releases all resources used by the CADGraphicsGDI

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.DrawImage Method

CADGraphicsGDI Class See Also

Draws a raster image or a metafile object.

Overload List
Name | Description
DrawImage(Image, Point[], bool, Color) | Draws a raster image or a metafile object.
DrawImage(Image, DPoint[], bool, Color) | Draws a raster image or a metafile object. (inherited from CADPresenter).
DrawImage(Image, T[], bool, Color) | Draws a raster image or a metafile object. (inherited from CADPainter<T>).
DrawImage(Image, T, T, T, bool, Color) | Draws a raster image or a metafile object. (inherited from CADPainter<T>).
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.DrawLine Method

CADGraphicsGDI Class See Also

Draws a polyline by two specified points.

Overload List
Name | Description
DrawLine(Point, Point) | Draws a polyline by two specified points.
DrawLine(DPoint, DPoint) | Draws a polyline by two specified points. (inherited from CADPresenter).
DrawLine(T, T) | Draws a polyline by two specified points. (inherited from CADPainter<T>).
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.DrawPixel Method

CADGraphicsGDI Class See Also

Draws a single pixel

Overload List
Name | Description
DrawPixel(Point) | Draws a single pixel
DrawPixel(DPoint) | Draws a single pixel (inherited from CADPresenter).
DrawPixel(T) | Draws a single pixel (inherited from CADPainter<T>).
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.DrawPolyPolyLine Method

CADGraphicsGDI Class See Also

Draws a set of lines or a set of polygons

Overload List
Name | Description
DrawPolyPolyLine(Point[], int[], bool) | Draws a set of lines or a set of polygons
DrawPolyPolyLine(DPoint[], int[], bool) | Draws a set of lines or a set of polygons (inherited from CADPresenter).
DrawPolyPolyLine(T[], int[], bool) | Draws a set of lines or a set of polygons (inherited from CADPainter<T>).
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.DrawPolyline Method

CADGraphicsGDI Class See Also

Draws a polyline

Overload List
Name | Description
DrawPolyline(Point[], bool) | Draws a polyline
DrawPolyline(DPoint[], bool) | Draws a polyline (inherited from CADPresenter).
DrawPolyline(T[], bool) | Draws a polyline (inherited from CADPainter<T>).
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.DrawString Method

CADGraphicsGDI Class See Also

Draws a text string.

Overload List
Name | Description
DrawString(string, Font, int, Point, CADTextHorizontalAlign) | Draws a text string.
DrawString(string, Font, int, DPoint, CADTextHorizontalAlign) | Draws a text string. (inherited from CADPresenter).
DrawString(string, Font, int, T, CADTextHorizontalAlign) | Draws a text string. (inherited from CADPainter<T>).
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.ExportToMetafile Method

CADGraphicsGDI Class See Also

Exports a CAD drawing to Windows Enhanced metafile.

Overload List
Name | Description
ExportToMetafile(string, DRect) | Exports a CAD drawing to Windows Enhanced metafile.
ExportToMetafile(string, DRect, Rectangle) | Exports a CAD drawing to Windows Enhanced metafile.
ExportToMetafile(string, DRect, Rectangle, bool) | Exports a CAD drawing to Windows Enhanced metafile.
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.FillPolyPolyLine Method

CADGraphicsGDI Class See Also

Draws a filled polygons.

Overload List
Name | Description
FillPolyPolyLine(Point[], int[]) | Draws a filled polygons.
FillPolyPolyLine(DPoint[], int[]) | Draws a filled polygons. (inherited from CADPresenter).
FillPolyPolyLine(T[], int[]) | Draws a filled polygons. (inherited from CADPainter<T>).
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.FillPolyline Method

CADGraphicsGDI Class See Also

Draws a filled polyline.

Overload List
Name | Description
FillPolyline(Point[]) | Draws a filled polyline.
FillPolyline(DPoint[]) | Draws a filled polyline. (inherited from CADPresenter).
FillPolyline(T[]) | Draws a filled polyline. (inherited from CADPainter<T>).
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.IsEqual_T Method

CADGraphicsGDI Class See Also

Checks if two points are equal.

Overload List
Name | Description
IsEqual_T(Point, Point) | Checks if two points are equal.
IsEqual_T(DPoint, DPoint) | Checks if two points are equal. (inherited from CADPresenter).
IsEqual_T(T, T) | Checks if two points are equal. (inherited from CADPainter<T>).
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.SaveImageToClipboard Method

CADGraphicsGDI Class See Also

Writes a visible part of the current CAD image to the clipboard as a raster image.

Overload List
Name | Description
SaveImageToClipboard(DRect) | Writes a visible part of the current CAD image to the clipboard as a raster image.
SaveImageToClipboard(DRect, PixelFormat) | Writes a visible part of the current CAD image to the clipboard as a raster image.
SaveImageToClipboard(DRect, Rectangle) | Writes a specified part of the current CAD image to the clipboard as a raster image.
SaveImageToClipboard(DRect, Rectangle, PixelFormat) | Writes a specified part of the current CAD image to the clipboard as a raster image.
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.SaveToFile Method

CADGraphicsGDI Class See Also

Writes a visible part of the current CAD image to the disk as a raster image.

Overload List
Name | Description
SaveToFile(string, ImageFormat, DRect, PixelFormat, RectangleF, Graphics) | Writes a visible part of the current CAD image to the disk as a raster image.
SaveToFile(string, ImageFormat, DRect, RectangleF, Graphics) | Writes a visible part of the current CAD image to the disk as a raster image.
SaveToFile(string, ImageFormat, DRect, Rectangle) | Writes a specified part of the current CAD image to the disk as a raster image. (inherited from CADPresenter).
SaveToFile(string, ImageFormat, DRect, Rectangle, PixelFormat) | Saves a current CAD image to the file of the specified format. (inherited from CADPresenter).
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.SaveToStream Method

CADGraphicsGDI Class See Also

Saves a current CAD image to the stream of the specified format.

Overload List
Name | Description
SaveToStream(Stream, ImageFormat, DRect) | Writes a visible part of the current CAD image to the specified stream as a raster image.
SaveToStream(Stream, ImageFormat, DRect, PixelFormat) | Writes a visible part of the current CAD image to the specified stream as a raster image.
SaveToStream(Stream, ImageFormat, DRect, Rectangle) | Saves a part of the current CAD image to the stream of the specified format.
SaveToStream(Stream, ImageFormat, DRect, Rectangle, PixelFormat) | Saves a current CAD image to the stream of the specified format.
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.Sub_T Method

CADGraphicsGDI Class See Also

Performs substraction of two points.

Overload List
Name | Description
Sub_T(Point, Point) | Performs substraction of two points.
Sub_T(DPoint, DPoint) | Performs subtraction of two points. (inherited from CADPresenter).
Sub_T(T, T) | Performs subtraction of two points. (inherited from CADPainter<T>).
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsOpenGL Class

Members See Also

Provides OpenGL based drawing functionality.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADGraphicsOpenGL
    Inherits CADPainter(Of Vector3d)
    Implements IDisposable
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADGraphicsOpenGL : CADPainter<Vector3d>,
   IDisposable
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADPresenter
CADImport.CADPainter<T>
CADImport.CADGraphicsOpenGL
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsOpenGL Members


CADGraphicsOpenGL Members

CADGraphicsOpenGL Class Constructors Methods Properties See Also

Provides OpenGL based drawing functionality.

The following tables list the members exposed by the CADGraphicsOpenGL type.

Constructors
 | Name | Description
Public constructor | CADGraphicsOpenGL | (Overloaded) Initializes a new instance of the CADGraphicsOpenGL class.
Top
Properties
 | Name | Description
Public property | DrawMatrix | (inherited from CADPresenter).
Public property | DrawTarget | Represents a surface for visualization (inherited from CADPresenter).
Public property | Image | Gets or sets a CADImage for visualization (inherited from CADPresenter).
Public property | RenderMode | Gets or sets rendering mode. (inherited from CADPresenter).
Public property | Settings | Gets a set of settings for visualization. (inherited from CADPresenter).
Public property | UseDoubleBuffering | Outdated. Does Nothing. (inherited from CADPresenter).
Public property | VisibleBox | Gets a rectangular area that will be visualized. (inherited from CADPainter<T>).
Top
Methods
 | Name | Description
Public method | Add_T | (Overloaded) Performs addition of two 3D vector points.
Public method | ApplyScale | Calculates a matrix for drawing based on current scale. (inherited from CADPainter<T>).
Public method | ClearMarkers | Clears a collection of markers. (inherited from CADPresenter).
Public method | ConvertTo_T | Converts a DPoint object into a 3D vector point.
Public method | Dispose | For inheritance.
Public method | DoFinish | Finishes drawing an entity. (inherited from CADPainter<T>).
Public method | Draw | (Overloaded) Draws a CADImage.
Public method | DrawEntities | Invokes drawing method for specified entities if they are visible (inherited from CADPainter<T>).
Public method | DrawEntity | Draws a specified CAD entity in the current CAD image. (inherited from CADPainter<T>).
Public method | DrawImage | (Overloaded) Draws a raster image or a metafile object. (inherited from CADPainter<T>).
Public method | DrawLine | (Overloaded) Draws a polyline by two specified points. (inherited from CADPainter<T>).
Public method | DrawPixel | (Overloaded) Draws a single pixel (inherited from CADPainter<T>).
Public method | DrawPolyPolyLine | (Overloaded) Draws a set of lines or a set of polygons
Public method | DrawPolyline | (Overloaded) Draws a polyline
Public method | DrawString | (Overloaded) Draws a text string.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportToMetafile | (Overloaded) Exports a CAD drawing to Windows Enhanced metafile.
Public method | FillPolyPolyLine | (Overloaded) Draws a filled polygons.
Public method | FillPolyline | (Overloaded) Draws a filled polyline. (inherited from CADPainter<T>).
Public method | GetExtents | Calculates the current dimensions of the CADImage. (inherited from CADPresenter).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetPoint | Transforms a three-dimensional CAD point into a two-dimensional screen point. (inherited from CADPainter<T>).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IsEqual_T | (Overloaded) Checks if two 3D vector points are equal.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from CADPresenter).
Public method | RotToView | Rotates a CAD image to get a specified view. (inherited from CADPresenter).
Public method | Rotate | Rotates objects in the current drawing. (inherited from CADPresenter).
Public method | SaveImageToClipboard | (Overloaded) Writes a visible part of the current CAD image to the clipboard as a raster image.
Public method | SaveToFile | (Overloaded) Writes a visible part of the current CAD image to the disk as a raster image.
Public method | SaveToStream | (Overloaded) Saves a current CAD image to the stream of the specified format.
Public method | Sub_T | (Overloaded) Performs substraction of two 3D vector points.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADGraphicsOpenGL Class


CADGraphicsOpenGL Constructor

CADGraphicsOpenGL Class See Also

Initializes a new instance of the CADGraphicsOpenGL class.

Overload List
Name | Description
CADGraphicsOpenGL() | Initializes a new instance of the CADGraphicsOpenGL class.
CADGraphicsOpenGL(Control) | Initializes a new instance of the CADGraphicsOpenGL class.
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL Properties

CADGraphicsOpenGL Class See Also

The following tables list the members exposed by the CADGraphicsOpenGL type.

Properties
 | Name | Description
Public property | DrawMatrix | (inherited from CADPresenter).
Public property | DrawTarget | Represents a surface for visualization (inherited from CADPresenter).
Public property | Image | Gets or sets a CADImage for visualization (inherited from CADPresenter).
Public property | RenderMode | Gets or sets rendering mode. (inherited from CADPresenter).
Public property | Settings | Gets a set of settings for visualization. (inherited from CADPresenter).
Public property | UseDoubleBuffering | Outdated. Does Nothing. (inherited from CADPresenter).
Public property | VisibleBox | Gets a rectangular area that will be visualized. (inherited from CADPainter<T>).
Top
See Also

Reference

CADGraphicsOpenGL Class


CADGraphicsOpenGL Methods

CADGraphicsOpenGL Class See Also

The following tables list the members exposed by the CADGraphicsOpenGL type.

Methods
 | Name | Description
Public method | Add_T | (Overloaded) Performs addition of two 3D vector points.
Public method | ApplyScale | Calculates a matrix for drawing based on current scale. (inherited from CADPainter<T>).
Public method | ClearMarkers | Clears a collection of markers. (inherited from CADPresenter).
Public method | ConvertTo_T | Converts a DPoint object into a 3D vector point.
Public method | Dispose | For inheritance.
Public method | DoFinish | Finishes drawing an entity. (inherited from CADPainter<T>).
Public method | Draw | (Overloaded) Draws a CADImage.
Public method | DrawEntities | Invokes drawing method for specified entities if they are visible (inherited from CADPainter<T>).
Public method | DrawEntity | Draws a specified CAD entity in the current CAD image. (inherited from CADPainter<T>).
Public method | DrawImage | (Overloaded) Draws a raster image or a metafile object. (inherited from CADPainter<T>).
Public method | DrawLine | (Overloaded) Draws a polyline by two specified points. (inherited from CADPainter<T>).
Public method | DrawPixel | (Overloaded) Draws a single pixel (inherited from CADPainter<T>).
Public method | DrawPolyPolyLine | (Overloaded) Draws a set of lines or a set of polygons
Public method | DrawPolyline | (Overloaded) Draws a polyline
Public method | DrawString | (Overloaded) Draws a text string.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportToMetafile | (Overloaded) Exports a CAD drawing to Windows Enhanced metafile.
Public method | FillPolyPolyLine | (Overloaded) Draws a filled polygons.
Public method | FillPolyline | (Overloaded) Draws a filled polyline. (inherited from CADPainter<T>).
Public method | GetExtents | Calculates the current dimensions of the CADImage. (inherited from CADPresenter).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetPoint | Transforms a three-dimensional CAD point into a two-dimensional screen point. (inherited from CADPainter<T>).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IsEqual_T | (Overloaded) Checks if two 3D vector points are equal.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from CADPresenter).
Public method | RotToView | Rotates a CAD image to get a specified view. (inherited from CADPresenter).
Public method | Rotate | Rotates objects in the current drawing. (inherited from CADPresenter).
Public method | SaveImageToClipboard | (Overloaded) Writes a visible part of the current CAD image to the clipboard as a raster image.
Public method | SaveToFile | (Overloaded) Writes a visible part of the current CAD image to the disk as a raster image.
Public method | SaveToStream | (Overloaded) Saves a current CAD image to the stream of the specified format.
Public method | Sub_T | (Overloaded) Performs substraction of two 3D vector points.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADGraphicsOpenGL Class


CADGraphicsOpenGL.Add_T Method

CADGraphicsOpenGL Class See Also

Performs addition of two 3D vector points.

Overload List
Name | Description
Add_T(Vector3d, Vector3d) | Performs addition of two 3D vector points.
Add_T(DPoint, DPoint) | Performs addition of two points. (inherited from CADPresenter).
Add_T(T, T) | Performs addition of two points. (inherited from CADPainter<T>).
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.ConvertTo_T Method

Converts a DPoint object into a 3D vector point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function ConvertTo_T( _
   ByVal p As DPoint _
) As Vector3d
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override Vector3d ConvertTo_T(
   DPoint p
)
This language is not supported or no code example is available.

Parameters

p

Type: DPoint

A DPoint object to be converted.

Return Value

A 3D vector point.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.Dispose Method

For inheritance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose() Implements  _
   IDisposable.Dispose
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.

Implements

IDisposable.Dispose
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.Draw Method

CADGraphicsOpenGL Class See Also

Draws a CADImage.

Overload List
Name | Description
Draw(Graphics, RectangleF, Region) | Draws a CADImage.
Draw(Graphics, RectangleF) | Draws a CADImage. (inherited from CADPresenter).
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.DrawPolyPolyLine Method

CADGraphicsOpenGL Class See Also

Draws a set of lines or a set of polygons

Overload List
Name | Description
DrawPolyPolyLine(Vector3d[], int[], bool) | Draws a set of lines or a set of polygons
DrawPolyPolyLine(DPoint[], int[], bool) | Draws a set of lines or a set of polygons (inherited from CADPresenter).
DrawPolyPolyLine(T[], int[], bool) | Draws a set of lines or a set of polygons (inherited from CADPainter<T>).
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.DrawPolyline Method

CADGraphicsOpenGL Class See Also

Draws a polyline

Overload List
Name | Description
DrawPolyline(Vector3d[], bool) | Draws a polyline
DrawPolyline(DPoint[], bool) | Draws a polyline (inherited from CADPresenter).
DrawPolyline(T[], bool) | Draws a polyline (inherited from CADPainter<T>).
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.DrawString Method

CADGraphicsOpenGL Class See Also

Draws a text string.

Overload List
Name | Description
DrawString(string, Font, int, Vector3d, CADTextHorizontalAlign) | Draws a text string.
DrawString(string, Font, int, DPoint, CADTextHorizontalAlign) | Draws a text string. (inherited from CADPresenter).
DrawString(string, Font, int, T, CADTextHorizontalAlign) | Draws a text string. (inherited from CADPainter<T>).
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.ExportToMetafile Method

CADGraphicsOpenGL Class See Also

Exports a CAD drawing to Windows Enhanced metafile.

Overload List
Name | Description
ExportToMetafile(string, DRect) | Exports a CAD drawing to Windows Enhanced metafile.
ExportToMetafile(string, DRect, Rectangle) | Exports a CAD drawing to Windows Enhanced metafile.
ExportToMetafile(string, DRect, Rectangle, bool) | Exports a CAD drawing to Windows Enhanced metafile.
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.FillPolyPolyLine Method

CADGraphicsOpenGL Class See Also

Draws a filled polygons.

Overload List
Name | Description
FillPolyPolyLine(Vector3d[], int[]) | Draws a filled polygons.
FillPolyPolyLine(DPoint[], int[]) | Draws a filled polygons. (inherited from CADPresenter).
FillPolyPolyLine(T[], int[]) | Draws a filled polygons. (inherited from CADPainter<T>).
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.IsEqual_T Method

CADGraphicsOpenGL Class See Also

Checks if two 3D vector points are equal.

Overload List
Name | Description
IsEqual_T(Vector3d, Vector3d) | Checks if two 3D vector points are equal.
IsEqual_T(DPoint, DPoint) | Checks if two points are equal. (inherited from CADPresenter).
IsEqual_T(T, T) | Checks if two points are equal. (inherited from CADPainter<T>).
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.SaveImageToClipboard Method

CADGraphicsOpenGL Class See Also

Writes a visible part of the current CAD image to the clipboard as a raster image.

Overload List
Name | Description
SaveImageToClipboard(DRect) | Writes a visible part of the current CAD image to the clipboard as a raster image.
SaveImageToClipboard(DRect, PixelFormat) | Writes a visible part of the current CAD image to the clipboard as a raster image.
SaveImageToClipboard(DRect, Rectangle) | Writes a specified part of the current CAD image to the clipboard as a raster image.
SaveImageToClipboard(DRect, Rectangle, PixelFormat) | Writes a specified part of the current CAD image to the clipboard as a raster image.
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.SaveToFile Method

CADGraphicsOpenGL Class See Also

Writes a visible part of the current CAD image to the disk as a raster image.

Overload List
Name | Description
SaveToFile(string, ImageFormat, DRect, RectangleF, Graphics) | Writes a visible part of the current CAD image to the disk as a raster image.
SaveToFile(string, ImageFormat, DRect, PixelFormat, RectangleF, Graphics) | Writes a visible part of the current CAD image to the disk as a raster image.
SaveToFile(string, ImageFormat, DRect, Rectangle) | Writes a specified part of the current CAD image to the disk as a raster image. (inherited from CADPresenter).
SaveToFile(string, ImageFormat, DRect, Rectangle, PixelFormat) | Saves a current CAD image to the file of the specified format. (inherited from CADPresenter).
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.SaveToStream Method

CADGraphicsOpenGL Class See Also

Saves a current CAD image to the stream of the specified format.

Overload List
Name | Description
SaveToStream(Stream, ImageFormat, DRect, Rectangle, PixelFormat) | Saves a current CAD image to the stream of the specified format.
SaveToStream(Stream, ImageFormat, DRect) | Writes a visible part of the current CAD image to the specified stream as a raster image.
SaveToStream(Stream, ImageFormat, DRect, PixelFormat) | Writes a visible part of the current CAD image to the specified stream as a raster image.
SaveToStream(Stream, ImageFormat, DRect, Rectangle) | Writes a specified part of the current CAD image to the clipboard as a raster image.
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.Sub_T Method

CADGraphicsOpenGL Class See Also

Performs substraction of two 3D vector points.

Overload List
Name | Description
Sub_T(Vector3d, Vector3d) | Performs substraction of two 3D vector points.
Sub_T(DPoint, DPoint) | Performs subtraction of two points. (inherited from CADPresenter).
Sub_T(T, T) | Performs subtraction of two points. (inherited from CADPainter<T>).
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGroup Class

Members See Also

Represents a base class for all CAD entities that contain other CAD entities.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADGroup
    Inherits CADPlotEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADGroup : CADPlotEntity
This language is not supported or no code example is available.
Remarks

The examples of the CADGroup entities are CADBlock and CADPolyLine.

Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADGroup
CADImport.CADACISEntity
CADImport.CADBlock
CADImport.CADTable
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGroup Members


CADGroup Members

CADGroup Class Constructors Methods Fields Properties See Also

Represents a base class for all CAD entities that contain other CAD entities.

The following tables list the members exposed by the CADGroup type.

Constructors
 | Name | Description
Public constructor | CADGroup | Initializes a new instance of the CADGroup class.
Top
Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses this CADGroup.
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the specified CADGroup.
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of CAD entities belonging to the given CADGroup.
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | List | Gets a collection of entities included in the given CADGroup.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Iterate | Invokes the referenced (by the specified delegate) method for each CAD entity belonging to the given CADGroup.
Public method | Loaded | Loads this CADGroup to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RemoveEntityByName | Searches for an entity using its name then removes the entity.
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADGroup Class


CADGroup Constructor

Initializes a new instance of the CADGroup class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADGroup()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGroup Class
CADGroup Members


CADGroup Properties

CADGroup Class See Also

The following tables list the members exposed by the CADGroup type.

Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses this CADGroup.
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the specified CADGroup.
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of CAD entities belonging to the given CADGroup.
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | List | Gets a collection of entities included in the given CADGroup.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
See Also

Reference

CADGroup Class


CADGroup Methods

CADGroup Class See Also

The following tables list the members exposed by the CADGroup type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Iterate | Invokes the referenced (by the specified delegate) method for each CAD entity belonging to the given CADGroup.
Public method | Loaded | Loads this CADGroup to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RemoveEntityByName | Searches for an entity using its name then removes the entity.
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADGroup Class


CADGroup.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGroup Class
CADGroup Members


CADGroup.Loaded Method

Loads this CADGroup to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADGroup is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGroup Class
CADGroup Members


CADGroup Fields

CADGroup Class See Also

The following tables list the members exposed by the CADGroup type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADGroup Class


CADHatch Class

Members See Also

Represents a hatch in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADHatch
    Inherits CADCurvePolygon
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADHatch : CADCurvePolygon
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPolyPolygon
CADImport.CADGradientPolygon
CADImport.CADCurvePolygon
CADImport.CADHatch
CADImport.CADMPolygon
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADHatch Members


CADHatch Members

CADHatch Class Constructors Methods Fields Properties See Also

Represents a hatch in a CAD image.

The following tables list the members exposed by the CADHatch type.

Constructors
 | Name | Description
Public constructor | CADHatch | Initializes a new instance of the CADHatch class.
Top
Properties
 | Name | Description
Public property | Boundaries | Gets a collection of boundaries of this CADPolyPolygon. (inherited from CADPolyPolygon).
Public property | BoundaryData | Gets a list of borders for this CADCurvePolygon. (inherited from CADCurvePolygon).
Public property | Box | Gets a three-dimensional box that encloses this CADPolyPolygon. (inherited from CADPolyPolygon).
Public property | Color | Gets or sets a color of this CADPolyPolygon. (inherited from CADPolyPolygon).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | Elevation | Gets or sets a distance on which this CADCurvePolygon is elevated along the Z axis. (inherited from CADCurvePolygon).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADHatch entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets the Z axis direction of the CADCurvePolygon object coordinate system. (inherited from CADCurvePolygon).
Public property | Filled | (inherited from CADPolyPolygon).
Public property | GradientColor | Gets or sets a gradient color. (inherited from CADGradientPolygon).
Public property | GradientName | Gets or sets a name of the gradient. (inherited from CADGradientPolygon).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | HatchName | Gets or sets a name of this CADHatch entity.
Public property | HatchPatternData | Gets a collection of hatch patterns used in the pattern of this CADHatch object.
Public property | HatchStyle | Gets or sets a style of this CADHatch entity.
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADHatch entity.
Public property | Lines | Gets a type of the line used by this CADHatch object.
Public property | ParsedLines | Gets a collection of points that specify the hatch pattern.
Public property | PttBaseP | Gets or sets a base point from which filling a shape with the hatch patterns starts.
Public property | PttLineAngle | Gets or sets an angle for this CADHatch object.
Public property | PttNumLines | Gets or sets a number of lines that specify a linetype for the lines used in this CADHatch entity.
Public property | PttOffset | Gets or sets an offset from the base point of this CADHatch object.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible.
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Destroy | Clears all data that specify a hatch pattern of this CADHatch object.
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADCurvePolygon must be drawn during a drawing cycle. (inherited from CADCurvePolygon).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | HatchLine | For internal use
Public method | Loaded | Loads this CADPolyPolygon to the specified CADConverter. (inherited from CADPolyPolygon).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADHatch Class


CADHatch Constructor

Initializes a new instance of the CADHatch class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADHatch()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADHatch Class
CADHatch Members


CADHatch Properties

CADHatch Class See Also

The following tables list the members exposed by the CADHatch type.

Properties
 | Name | Description
Public property | Boundaries | Gets a collection of boundaries of this CADPolyPolygon. (inherited from CADPolyPolygon).
Public property | BoundaryData | Gets a list of borders for this CADCurvePolygon. (inherited from CADCurvePolygon).
Public property | Box | Gets a three-dimensional box that encloses this CADPolyPolygon. (inherited from CADPolyPolygon).
Public property | Color | Gets or sets a color of this CADPolyPolygon. (inherited from CADPolyPolygon).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | Elevation | Gets or sets a distance on which this CADCurvePolygon is elevated along the Z axis. (inherited from CADCurvePolygon).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADHatch entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets the Z axis direction of the CADCurvePolygon object coordinate system. (inherited from CADCurvePolygon).
Public property | Filled | (inherited from CADPolyPolygon).
Public property | GradientColor | Gets or sets a gradient color. (inherited from CADGradientPolygon).
Public property | GradientName | Gets or sets a name of the gradient. (inherited from CADGradientPolygon).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | HatchName | Gets or sets a name of this CADHatch entity.
Public property | HatchPatternData | Gets a collection of hatch patterns used in the pattern of this CADHatch object.
Public property | HatchStyle | Gets or sets a style of this CADHatch entity.
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADHatch entity.
Public property | Lines | Gets a type of the line used by this CADHatch object.
Public property | ParsedLines | Gets a collection of points that specify the hatch pattern.
Public property | PttBaseP | Gets or sets a base point from which filling a shape with the hatch patterns starts.
Public property | PttLineAngle | Gets or sets an angle for this CADHatch object.
Public property | PttNumLines | Gets or sets a number of lines that specify a linetype for the lines used in this CADHatch entity.
Public property | PttOffset | Gets or sets an offset from the base point of this CADHatch object.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible.
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
See Also

Reference

CADHatch Class


CADHatch.EntType Property

Gets the type of this CADHatch entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADHatch Class
CADHatch Members


CADHatch.HatchName Property

Gets or sets a name of this CADHatch entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property HatchName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string HatchName {get; set;}
This language is not supported or no code example is available.

Property Value

A string containing the name of this CADHatch entity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADHatch Class
CADHatch Members


CADHatch.HatchPatternData Property

Gets a collection of hatch patterns used in the pattern of this CADHatch object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property HatchPatternData() As CADCollection(Of HatchPatternData)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection<HatchPatternData> HatchPatternData {get;}
This language is not supported or no code example is available.

Property Value

An ArrayList containing the hatch patterns used in the pattern of this CADHatch entity.
Remarks

Returns a list of HatchPatternData class elements. Hatch pattern consists of simple lines, which are repeated with offset. HatchPatternData is a list of pointers on lines data. Line data is an instance of HatchPatternData type.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADHatch Class
CADHatch Members


CADHatch.HatchStyle Property

Gets or sets a style of this CADHatch entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property HatchStyle() As CADHatchStyle
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADHatchStyle HatchStyle {get; set;}
This language is not supported or no code example is available.

Property Value

A CADHatchStyle enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADHatch Class
CADHatch Members


CADHatch.LineType Property

Gets or sets line type

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property LineType() As CADLineType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override CADLineType LineType {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADHatch Class
CADHatch Members


CADHatch.LineWeight Property

Gets or sets a thickness of lines for this CADHatch entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property LineWeight() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override double LineWeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADHatch Class
CADHatch Members


CADHatch.Lines Property

Gets a type of the line used by this CADHatch object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Lines() As SGLines
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SGLines Lines {get;}
This language is not supported or no code example is available.

Property Value

An object of the sgLines class that specifies a linetype.
Remarks

Obsolete. We recommend to use LineType property

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADHatch Class
CADHatch Members


CADHatch.ParsedLines Property

Gets a collection of points that specify the hatch pattern.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property ParsedLines() As CADCollection(Of DPoint)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection<DPoint> ParsedLines {get;}
This language is not supported or no code example is available.

Property Value

A ParsedLines object that contains points specifying the pattern for this CADHatch entity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADHatch Class
CADHatch Members


CADHatch.PttBaseP Property

Gets or sets a base point from which filling a shape with the hatch patterns starts.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PttBaseP() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint PttBaseP {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object that defines the base point of this CADHatch entity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADHatch Class
CADHatch Members


CADHatch.PttLineAngle Property

Gets or sets an angle for this CADHatch object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PttLineAngle() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float PttLineAngle {get; set;}
This language is not supported or no code example is available.

Property Value

An angle under which the CADHatch lines are drawn.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADHatch Class
CADHatch Members


CADHatch.PttNumLines Property

Gets or sets a number of lines that specify a linetype for the lines used in this CADHatch entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PttNumLines() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int PttNumLines {get; set;}
This language is not supported or no code example is available.

Property Value

A number of lines that specify a linetype for the lines used in this CADHatch object.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADHatch Class
CADHatch Members


CADHatch.PttOffset Property

Gets or sets an offset from the base point of this CADHatch object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PttOffset() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint PttOffset {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object that specifies an offset from the base point of this CADHatch entity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADHatch Class
CADHatch Members


CADHatch.Visibility Property

Gets or sets a value indicating whether a CADPlotEntity is visible.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Visibility() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool Visibility {get; set;}
This language is not supported or no code example is available.

Property Value

true if a CADPlotEntity is visible; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADHatch Class
CADHatch Members


CADHatch Methods

CADHatch Class See Also

The following tables list the members exposed by the CADHatch type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Destroy | Clears all data that specify a hatch pattern of this CADHatch object.
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADCurvePolygon must be drawn during a drawing cycle. (inherited from CADCurvePolygon).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | HatchLine | For internal use
Public method | Loaded | Loads this CADPolyPolygon to the specified CADConverter. (inherited from CADPolyPolygon).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADHatch Class


CADHatch.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADHatch Class
CADHatch Members


CADHatch.Destroy Method

Clears all data that specify a hatch pattern of this CADHatch object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Destroy()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Destroy()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADHatch Class
CADHatch Members


CADHatch.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADHatch Class
CADHatch Members


CADHatch.HatchLine Method

For internal use

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub HatchLine( _
   ByVal aList As CADCollection(Of Double), _
   ByVal Pt1 As DPoint, _
   ByVal Pt2 As DPoint, _
   ByVal BasePt As DPoint, _
   ByVal DottedSingPts As CADCollection(Of DPoint) _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void HatchLine(
   CADCollection<double> aList,
   DPoint Pt1,
   DPoint Pt2,
   DPoint BasePt,
   CADCollection<DPoint> DottedSingPts
)
This language is not supported or no code example is available.

Parameters

aList

Type: CADCollection<double>

Pt1

Type: DPoint

A first endpoint of the hatch line whose points will be added to the collection.

Pt2

Type: DPoint

A second endpoint of the hatch line whose points will be added to the collection.

BasePt

Type: DPoint

A base point of the hatch line whose points will be added to the collection.

DottedSingPts

Type: CADCollection<DPoint>

A collection where the points of the represented hatch line will be added to.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADHatch Class
CADHatch Members


CADHatch Fields

CADHatch Class See Also

The following tables list the members exposed by the CADHatch type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADHatch Class


CADHelix Class

Members See Also

Represents a helix in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADHelix
    Inherits CADSpline
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADHelix : CADSpline
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.CADPenLine
CADImport.CADPolylineBase
CADImport.CADSpline
CADImport.CADHelix
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADHelix Members


CADHelix Members

CADHelix Class Constructors Methods Fields Properties See Also

Represents a helix in a CAD image.

The following tables list the members exposed by the CADHelix type.

Constructors
 | Name | Description
Public constructor | CADHelix | Initializes a new instance of the CADSpline class. (inherited from CADSpline).
Top
Properties
 | Name | Description
Public property | Box | Return box of the current primitive. (inherited from CADPolylineBase).
Public property | Clockweise | Gets or sets whether or not the CADHelix object is clockwise
Public property | Closed | Gets or sets a value indicating whether this CADPolyLine is closed. (inherited from CADPolylineBase).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | ControlCount | Gets a number of control points. (inherited from CADSpline).
Public property | Controls | Gets or sets a collection of control points. (inherited from CADSpline).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADPolylineBase. (inherited from CADPolylineBase).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | Degree | Gets or sets degree of the CADSpline. (inherited from CADSpline).
Public property | DottedSingPoints | Gets a collection of points that specify the dots and dashes of the CADPolylineBase. (inherited from CADPolylineBase).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADHelix entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Fit | Gets or sets a collection of fit points. (inherited from CADSpline).
Public property | FitCount | Gets a number of fit points. (inherited from CADSpline).
Public property | Flags | Gets or sets a number that specifies an appearance of this CADPolylineBase entity. (inherited from CADPolylineBase).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | IsMeshMClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the M direction. (inherited from CADPolylineBase).
Public property | IsMeshNClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the N direction. (inherited from CADPolylineBase).
Public property | IsPolyFaceMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | IsPolyZThickness | Gets a value indicating whether a line thickness measured along the axis Z is equal to 0. (inherited from CADPolylineBase).
Public property | IsPolygonMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | Knots | Gets a collection of knots for this CADSpline entity. (inherited from CADSpline).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADPenLine).
Public property | PolyPoints | Gets a collection of points belonging to the polyline. (inherited from CADPolylineBase).
Public property | Radius | Gets or sets a start radius of the CADHelix object
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Start | Gets or sets start point of the CADHelix object
Public property | TurnHeight | Gets or sets heigh of one turn of the CADHelix object
Public property | Turns | Gets or sets number of turns in this CADHelix object
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADSpline).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Weights | Gets a collection of weights for CADSpline points. (inherited from CADSpline).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | ApplyBox | Calculates a box of the current entity. (inherited from CADPolylineBase).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADSpline).
Public method | DrawEntityTrace | Implements drawing of an entity with the specified offset to the specified Control (inherited from CADSpline).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Used in drawing cycle for fast checking whether the entity must be drawn (inherited from CADPolylineBase).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADSpline to the specified CADConverter. (inherited from CADSpline).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADHelix Class


CADSpline Constructor

Initializes a new instance of the CADSpline class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADSpline()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSpline Class
CADSpline Members


CADHelix Properties

CADHelix Class See Also

The following tables list the members exposed by the CADHelix type.

Properties
 | Name | Description
Public property | Box | Return box of the current primitive. (inherited from CADPolylineBase).
Public property | Clockweise | Gets or sets whether or not the CADHelix object is clockwise
Public property | Closed | Gets or sets a value indicating whether this CADPolyLine is closed. (inherited from CADPolylineBase).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | ControlCount | Gets a number of control points. (inherited from CADSpline).
Public property | Controls | Gets or sets a collection of control points. (inherited from CADSpline).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADPolylineBase. (inherited from CADPolylineBase).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | Degree | Gets or sets degree of the CADSpline. (inherited from CADSpline).
Public property | DottedSingPoints | Gets a collection of points that specify the dots and dashes of the CADPolylineBase. (inherited from CADPolylineBase).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADHelix entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Fit | Gets or sets a collection of fit points. (inherited from CADSpline).
Public property | FitCount | Gets a number of fit points. (inherited from CADSpline).
Public property | Flags | Gets or sets a number that specifies an appearance of this CADPolylineBase entity. (inherited from CADPolylineBase).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | IsMeshMClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the M direction. (inherited from CADPolylineBase).
Public property | IsMeshNClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the N direction. (inherited from CADPolylineBase).
Public property | IsPolyFaceMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | IsPolyZThickness | Gets a value indicating whether a line thickness measured along the axis Z is equal to 0. (inherited from CADPolylineBase).
Public property | IsPolygonMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | Knots | Gets a collection of knots for this CADSpline entity. (inherited from CADSpline).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADPenLine).
Public property | PolyPoints | Gets a collection of points belonging to the polyline. (inherited from CADPolylineBase).
Public property | Radius | Gets or sets a start radius of the CADHelix object
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Start | Gets or sets start point of the CADHelix object
Public property | TurnHeight | Gets or sets heigh of one turn of the CADHelix object
Public property | Turns | Gets or sets number of turns in this CADHelix object
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADSpline).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Weights | Gets a collection of weights for CADSpline points. (inherited from CADSpline).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
See Also

Reference

CADHelix Class


CADHelix.Clockweise Property

Gets or sets whether or not the CADHelix object is clockwise

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Clockweise() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Clockweise {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADHelix Class
CADHelix Members


CADSpline.ControlCount Property

Gets a number of control points.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property ControlCount() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int ControlCount {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSpline Class
CADSpline Members


CADSpline.Controls Property

Gets or sets a collection of control points.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Controls() As CADCollection(Of DPoint)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection<DPoint> Controls {get; set;}
This language is not supported or no code example is available.

Property Value

A CADSpline that contains control points.
Remarks

Control points form a spline as a continuous approximation line that goes proportionally remote from them.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSpline Class
CADSpline Members


CADSpline.Degree Property

Gets or sets degree of the CADSpline.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Degree() As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte Degree {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSpline Class
CADSpline Members


CADHelix.EntType Property

Gets the type of this CADHelix entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADHelix Class
CADHelix Members


CADSpline.Fit Property

Gets or sets a collection of fit points.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Fit() As CADCollection(Of DPoint)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection<DPoint> Fit {get; set;}
This language is not supported or no code example is available.
Remarks

Fit points are connected by a smooth curve that forms a spline.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSpline Class
CADSpline Members


CADSpline.FitCount Property

Gets a number of fit points.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property FitCount() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int FitCount {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSpline Class
CADSpline Members


CADSpline.Knots Property

Gets a collection of knots for this CADSpline entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Knots() As CADCollection(Of Double)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection<double> Knots {get;}
This language is not supported or no code example is available.

Property Value

Knots are the points on a spline used for specifying domains of influence for each control point. A control point influences the part of the spline between the first and last knot of its domain.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSpline Class
CADSpline Members


CADHelix.Radius Property

Gets or sets a start radius of the CADHelix object

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Radius() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Radius {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADHelix Class
CADHelix Members


CADHelix.Start Property

Gets or sets start point of the CADHelix object

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Start() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Start {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADHelix Class
CADHelix Members


CADHelix.TurnHeight Property

Gets or sets heigh of one turn of the CADHelix object

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TurnHeight() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double TurnHeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADHelix Class
CADHelix Members


CADHelix.Turns Property

Gets or sets number of turns in this CADHelix object

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Turns() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Turns {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADHelix Class
CADHelix Members


CADSpline.Visibility Property

Gets or sets a value indicating whether a CADPlotEntity is visible.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Visibility() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool Visibility {get; set;}
This language is not supported or no code example is available.

Property Value

true if a CADPlotEntity is visible; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSpline Class
CADSpline Members


CADSpline.Weights Property

Gets a collection of weights for CADSpline points.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Weights() As CADCollection(Of Single)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection<float> Weights {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSpline Class
CADSpline Members


CADHelix Methods

CADHelix Class See Also

The following tables list the members exposed by the CADHelix type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | ApplyBox | Calculates a box of the current entity. (inherited from CADPolylineBase).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADSpline).
Public method | DrawEntityTrace | Implements drawing of an entity with the specified offset to the specified Control (inherited from CADSpline).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Used in drawing cycle for fast checking whether the entity must be drawn (inherited from CADPolylineBase).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADSpline to the specified CADConverter. (inherited from CADSpline).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADHelix Class


CADHelix.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADHelix Class
CADHelix Members


CADSpline.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSpline Class
CADSpline Members


CADSpline.DrawEntityTrace Method

Implements drawing of an entity with the specified offset to the specified Control

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub DrawEntityTrace( _
   ByVal dx As Integer, _
   ByVal dy As Integer, _
   ByVal img As CADImage, _
   ByVal control As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void DrawEntityTrace(
   int dx,
   int dy,
   CADImage img,
   Control control
)
This language is not supported or no code example is available.

Parameters

dx

Type: int

X axis offset

dy

Type: int

Y axis offset

img

Type: CADImage

The CADImage object for getting display coordinates of an entity

control

Type: Control

Control for drawing of an CADEntityCADEntity

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSpline Class
CADSpline Members


CADSpline.Loaded Method

Loads this CADSpline to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADSpline is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSpline Class
CADSpline Members


CADHelix Fields

CADHelix Class See Also

The following tables list the members exposed by the CADHelix type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADHelix Class


CADImage Class

Members See Also

Represents a CAD drawing and provides methods for drawing all loaded CAD objects.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADImage
    Implements IDisposable
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADImage : IDisposable
This language is not supported or no code example is available.
Remarks

CADImage class is a superstructure on the CADConverter. This is a base class for AutoCAD™ DXF graphic files objects. CADImage uses GDI+ classes for drawing DXF files. DXF is an acronym for Drawing eXchange Format. DXF is a widely used file format for displaying 2D and 3D CAD data. It's not an open format but owned by AutoDesk Inc. who uses it for their AutoCAD application. With every new version of AutoCAD the definition of DXF is changed but nevertheless there are many programs which are capable to read and write different versions of DXF. DXF is an ASCII replication of the drawing's contents. It enables an interchange of files from AutoCAD to other applications' formats. DXF import/export is supported by a wide variety of applications, ranging from CAD products to word processors, desktop publishing and illustrating tools. The DXF CAD format has become the de facto standard in PC based CAD industry with many other CAD systems able to read and write this format too. <p> Major features :</p> <li>CADImage implements quick and exact reading DXF files and manipulating them using GDI+ functions for drawing. </li> <li>The fastest DXF reader.</li> <li>3D support including nested extrusions.</li> <li>Compatible with AutoDesk DXF Release 12, 13, 14 and 2000, 2002, 2004.</li>

Inheritance Hierarchy
System.Object
CADImport.CADImage
CADImport.CAD3D.STLImage
CADImport.CGM.CGMImage
CADImport.DWG.DWGImage
CADImport.GBR.GBRImage
CADImport.GDS.GDSImage
CADImport.HPGL2.HPGLImage
CADImport.RasterImage.CADRasterImage
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Members


CADImage Members

CADImage Class Constructors Methods Fields Properties See Also

Represents a CAD drawing and provides methods for drawing all loaded CAD objects.

The following tables list the members exposed by the CADImage type.

Constructors
 | Name | Description
Public constructor | CADImage | Initializes a new instance of the CADImage class.
Top
Properties
 | Name | Description
Public property | AbsDepth | Gets an absolute depths of the CADImage.
Public property | AbsHeight | Gets an absolute height of the CADImage.
Public property | AbsWidth | Gets an absolute width of the CADImage.
Public property | Angle | Gets or sets the angle for this CADImage object visualization.
Public property | BackgroundColor | Gets or sets a background color of this CADImage.
Public property | BorderSize | Gets or sets a border size in pixels.
Public property | BorderType | Gets or sets a border type.
Public property | Center | Gets or sets CADImage center point.
Public property | Charset | Gets or sets a character set for the text entities.
 | CodePage | Gets or sets a number that identifies the encoding used in the loaded CAD file.
Public property | Converter | Gets a converter that loads CAD entities from the file to draw them in the current CADImage.
Public property | CurrentLayer | Gets or sets a current layer for the CADImage.
Public property | CurrentLayout | Gets or sets a current layout for the CADImage.
Public property | CurrentLayoutIndex | Gets an index of the current layout.
Public property | CurrentMarker | Gets a currently selected marker.
Public property | DefaultColor | Gets or sets a default color for the CADImage.
Public property | DefaultLayoutIndex | Gets or sets a default layout index.
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions on the drawing are visible.
Public property | DrawMode | Gets or sets a current drawing mode.
Public property | EnableSnap | Gets or sets enablement of snap mode
Public property | Extents | Gets or sets an extents of the CADImage object.
Public property | FileInf | Gets information about a currently open file by means of the FileInfo class.
Public property | GDIPainter | Provides drawing functionality based on GDI+.
Public property | GraphicsOutMode | Specifies image draw mode.
Public property | InterpolationMode | Gets or sets the interpolation mode associated with current Graphics object
Public property | Is3D | Gets a value indicating whether this CADImage is three-dimensional.
Public property | IsDraw3DAxes | Gets or sets a value indicating whether 3D axes are shown on the drawing.
Public property | IsDrawingRotated | Gets a value indicating whether the CADImage has been rotated.
Public property | IsShowBackground | Gets or sets a value indicating using of a BackgroundColor.
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data.
Public property | IsSnapObject | Gets a value, which shows if there is an object for snapping under current coordinates
Public property | IsStopped | For internal use.
Public property | IsWithoutBorder | Gest or sets a value indicating whether to draw the CADImage without borders.
Public property | IsWithoutMargins | Gets or sets a value indicating whether to draw the CADImage without margins.
 | LastLoadedFilePath | Specifying of the search directory (used for X-Refs, ImageEnt)
Public property | LayersCount | Gets a quantity of layers in this CADImage.
Public property | Layouts | Gets a collection of layouts in the current CADImage.
Public property | LayoutsCount | Gets a quantity of layouts in this CADImage.
Public property | LineScaled | Obsolete. Gets or sets a value indicating whether a width of lines to draw all entities in the drawing is specified by the file data.
Public property | LineWeightScale | Gets or sets a scale for drawing lines.
Public property | MMToPixelX | Gets or sets a value corresponding to amount of millimeters per one pixel.
Public property | NullWidth | Gets or sets default thickness for lines used to draw a CADImage.
Public property | NumberOfPartsInCircle | Gets or sets a quantity of segments to be used to draw a circle.
Public property | Painter | Provides image drawing functionality.
Public property | PrintDialog | Gets or sets print dialog
Public property | PureExtents | Gets CADImage extents without margins.
Public property | ResizeDisproportionateDrawing | For internal use
Public property | SHXSearchPaths | Gets or sets paths for searching SHX fonts.
Public property | SearchSHXPaths | Gets or sets a value specifying whether SHX paths will be searched for the fonts.
Public property | SelectEntitiesCount | Gets the number of selected entities
Public property | SelectedEntities | Gets or sets a list of selected entities
Public property | SelectionMode | Gets or sets a state of the Selection tool.
Public property | Selector | Provides selection functionality.
Public property | SkipMMtoPixel | For specific use
Public property | SnapCurrent |
Public property | SnapOptions | Represents Snap options for the CADImage object
Public property | SnapRealPoint | Gets a current point in absolute coordinates (drawing coordinates)
Public property | SnapScreenPoint | Gets current point in display coordinates
Public property | TTFSmoothing | Gets or sets a value indicating whether TTF fonts are smoothed.
Public property | TextVisible | Gets or sets a value indicating whether the texts in the CADImage are visible.
Public property | UndoMode | Gets or sets whether undo/redo is disable or enable for professional version
Public property | UseDoubleBuffering | Outdated. Does nothing
Public property | UseLayerPriority |
Public property | UseMultyTTFFonts | Gets or sets a value indicating whether a multimode is used for showing symbols.
Public property | UseNullWidth | Specifies if default width will be used instead of entity width.
Public property | UseSHXFonts | Specifies if SHX fonts will be used for visualization.
Public property | UseTTFFonts | Specifies if TTF fonts will be used for visualization.
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles in the CADImage are drawn with GDI+ drawing methods without linearization.
Top
Methods
 | Name | Description
Public method | ActiveVPort | Returns drawing area visualized with the active VPort.
Public method | AddScaledDXF | Adds a scaled external reference to the model space of the specified CAD image.
Public method | AddScaledDXFEx | Adds a scaled external reference to the current layout of the specified CAD image.
Public method | AddToUndoList | (Overloaded) Adds operation "create new Entity" to undo list
Public method | ChangeDrawMode | Initializes a new graphic class object if current mode changed.
Public method | ChangeEntities |
Public method | ChangeGraphicsMode | Changes image drawing mode.
Public method | ChangePositionSelectedEntities | Changes position of the selected entities
Public method | ChangePositionSelectedEntity | Changes a position of the selected entity.
Public method | ClearBuffer | Outdated. Does nothing
Public method | ClearMarkers | Clears a collection of markers.
Public method | ClearRedoCollection | Clears redo entity collection
Public method | ClearSelectCollection | Clears a collection of the selected entities.
Public method | ClearSelection | Clears a list of the selected entities.
Public method | ClearSnapTrace | (Overloaded) Clears last drawn snap drawing element
Public method | ClearUndoCollection | Clears undo entity collection
Public method | CopyEntities | (Overloaded) Copies selected entities to the clipboard
Public method | CorrectByGrid | (Overloaded) Reduces a point location on screen to the grid node when the grid is active
Public method | CorrectByGridAndOrtho | Reduces a point relocation sizes on screen to the grid cell sizes when the grid is active
 | CreateImageByExtension | Creates specialised CADImage object for specified file extention
Public method | CutEntities | (Overloaded) Cuts selected entities from collection and paste them to the clipboard
Public method | Dispose | Disposes a CADImage object.
Public method | DoSelectEntities | (Overloaded) Selects inserted list of entities
Public method | DoSelectEntity | Selects inserted entity
Public method | Draw | (Overloaded) Draws a CADImage.
Public method | DrawACISEntity | Draws ACISEntity object
Public method | DrawChangeEntity | Changes a position of the marker designating the selected entity.
Public method | DrawMoveEntityTrace | Draws entities on their offsetting
Public method | DrawSnapTrace | Draws snap icon in case of proximity of object to current coordinates
Public method | EmfConvertToDXF | (Overloaded) Converts emf file to dxf file
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportToMetafile | (Overloaded) Exports a CAD drawing to Windows Enhanced metafile.
Public method | GetAbsPoint | Converts display coordinates into absolute coordinates of a design
Public method | GetCADCoords | Returns coordinates of a point on the drawing.
Public method | GetCenter | Returns the center point of a current layout
Public method | GetExtents | Calculates the current dimensions of the CADImage.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLayerColor | Gets layer color by index
Public method | GetLayerFreeze | Determines whether the layer (CADLayer) is frozen.
Public method | GetLayerName | Gets a name of the layer that has the specified index in the collection of layers.
Public method | GetLayerVisible | Determines whether a layer is visible
Public method | GetLayoutName | Gets a name of the layout that has the specified index in the collection of layouts.
Public method | GetPoint | Transforms a three-dimensional CAD point into a two-dimensional screen point.
Public method | GetRealImagePoint | For internal use.
Public method | GetRealSnapPoint | Smooths a point in absolute coordinates by the entity
Public method | GetSelectEntityRegion | Returns the selected area of the image.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetVPortExtents | Returns extents of the active VPort reduced to the specified size
Public method | InitialNewImage | (Overloaded) Initializes a new image with the default size
Public method | InvalidateSelectEntity | Redraws a selected entity.
Public method | InvalidateSelectedEntities | (Overloaded) Redraws a list of the selected entities
Public method | LoadFromFile | Uses for redefining in a descendant classes, define loading image from the specified file.
Public method | LoadFromStream | Loads a CAD image stored in the specified stream.
Public method | LoadFromWeb | Loads CAD image from hyperlink
Public method | MultipleSelect | Providing CAD image entities' multiple selection within a specified rectangle.
Public method | MultipleSelectExt | Selects all entities inside the inserted rectangle
Public method | PasteEntities | Pastes entities from the clipboard
Public method | PasteEntitiesExt | Pastes entities from the clipboard
Public method | Print | Prints a current CAD image.
Public method | Redo | Redo change
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RefreshCurrentLayout | Refresh current layout.
Public method | RefreshSnapTrace | Refreshes a region of the last drawn snap drawing element
Public method | RemoveEntity | (Overloaded) Removes CADEntity object.
Public method | RotDefault | Rotates the drawing to the default view.
Public method | RotToView | Rotates a CAD image to get a specified view.
Public method | Rotate | Rotates objects in the current drawing.
Public method | SaveAsDXF | Saves a current CAD image in DXF format.
Public method | SaveImageToClipboard | (Overloaded) Writes a visible part of the current CAD image to the clipboard as a raster image.
Public method | SaveToFile | (Overloaded) Saves a part of the current CAD image to the file of the specified format.
Public method | SaveToStream | (Overloaded) Writes a visible part of the current CAD image to the specified stream as a raster image.
Public method | Select | Selects an entity of the CAD image at the specified point.
Public method | SelectExt | Selects an entity of the CAD image at the specified point.
Public method | SetCenter | Sets CADImage center point.
Public method | SetCurrentLayout | Sets a current layout of this CADImage.
Public method | SetLayerColor | (Overloaded) Sets a color for layer (CADLayer) specified by index
Public method | SetLayerFreeze | (Overloaded) Sets freeze parameter for CADLayer
Public method | SetLayerVisible | (Overloaded) Sets a visibility of the layer.
Public method | SetNewEntityMarkerPos | Sets a new position for the selected entity. The entity's new position is defined by the position of the marker.
Public method | SetNewMMToPixel | Sets a quantity of millimeters per pixel for the specified Graphics object.
Public method | SetNewPosEntitiesExt | Sets a new position for the specified entities
Public method | SetNewPosEntity | Sets a new position for the specified entity.
Public method | Stop | For internal use.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | Undo | Undo change
Top
Fields
 | Name | Description
 | EntityBuffer | Represents buffer for CADEntityCollection storing.
Public field | visibleArea | Represents CADImage visible area.
Top
See Also

Reference

CADImage Class


CADImage Constructor

Initializes a new instance of the CADImage class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADImage()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage Properties

CADImage Class See Also

The following tables list the members exposed by the CADImage type.

Properties
 | Name | Description
Public property | AbsDepth | Gets an absolute depths of the CADImage.
Public property | AbsHeight | Gets an absolute height of the CADImage.
Public property | AbsWidth | Gets an absolute width of the CADImage.
Public property | Angle | Gets or sets the angle for this CADImage object visualization.
Public property | BackgroundColor | Gets or sets a background color of this CADImage.
Public property | BorderSize | Gets or sets a border size in pixels.
Public property | BorderType | Gets or sets a border type.
Public property | Center | Gets or sets CADImage center point.
Public property | Charset | Gets or sets a character set for the text entities.
 | CodePage | Gets or sets a number that identifies the encoding used in the loaded CAD file.
Public property | Converter | Gets a converter that loads CAD entities from the file to draw them in the current CADImage.
Public property | CurrentLayer | Gets or sets a current layer for the CADImage.
Public property | CurrentLayout | Gets or sets a current layout for the CADImage.
Public property | CurrentLayoutIndex | Gets an index of the current layout.
Public property | CurrentMarker | Gets a currently selected marker.
Public property | DefaultColor | Gets or sets a default color for the CADImage.
Public property | DefaultLayoutIndex | Gets or sets a default layout index.
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions on the drawing are visible.
Public property | DrawMode | Gets or sets a current drawing mode.
Public property | EnableSnap | Gets or sets enablement of snap mode
Public property | Extents | Gets or sets an extents of the CADImage object.
Public property | FileInf | Gets information about a currently open file by means of the FileInfo class.
Public property | GDIPainter | Provides drawing functionality based on GDI+.
Public property | GraphicsOutMode | Specifies image draw mode.
Public property | InterpolationMode | Gets or sets the interpolation mode associated with current Graphics object
Public property | Is3D | Gets a value indicating whether this CADImage is three-dimensional.
Public property | IsDraw3DAxes | Gets or sets a value indicating whether 3D axes are shown on the drawing.
Public property | IsDrawingRotated | Gets a value indicating whether the CADImage has been rotated.
Public property | IsShowBackground | Gets or sets a value indicating using of a BackgroundColor.
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data.
Public property | IsSnapObject | Gets a value, which shows if there is an object for snapping under current coordinates
Public property | IsStopped | For internal use.
Public property | IsWithoutBorder | Gest or sets a value indicating whether to draw the CADImage without borders.
Public property | IsWithoutMargins | Gets or sets a value indicating whether to draw the CADImage without margins.
 | LastLoadedFilePath | Specifying of the search directory (used for X-Refs, ImageEnt)
Public property | LayersCount | Gets a quantity of layers in this CADImage.
Public property | Layouts | Gets a collection of layouts in the current CADImage.
Public property | LayoutsCount | Gets a quantity of layouts in this CADImage.
Public property | LineScaled | Obsolete. Gets or sets a value indicating whether a width of lines to draw all entities in the drawing is specified by the file data.
Public property | LineWeightScale | Gets or sets a scale for drawing lines.
Public property | MMToPixelX | Gets or sets a value corresponding to amount of millimeters per one pixel.
Public property | NullWidth | Gets or sets default thickness for lines used to draw a CADImage.
Public property | NumberOfPartsInCircle | Gets or sets a quantity of segments to be used to draw a circle.
Public property | Painter | Provides image drawing functionality.
Public property | PrintDialog | Gets or sets print dialog
Public property | PureExtents | Gets CADImage extents without margins.
Public property | ResizeDisproportionateDrawing | For internal use
Public property | SHXSearchPaths | Gets or sets paths for searching SHX fonts.
Public property | SearchSHXPaths | Gets or sets a value specifying whether SHX paths will be searched for the fonts.
Public property | SelectEntitiesCount | Gets the number of selected entities
Public property | SelectedEntities | Gets or sets a list of selected entities
Public property | SelectionMode | Gets or sets a state of the Selection tool.
Public property | Selector | Provides selection functionality.
Public property | SkipMMtoPixel | For specific use
Public property | SnapCurrent |
Public property | SnapOptions | Represents Snap options for the CADImage object
Public property | SnapRealPoint | Gets a current point in absolute coordinates (drawing coordinates)
Public property | SnapScreenPoint | Gets current point in display coordinates
Public property | TTFSmoothing | Gets or sets a value indicating whether TTF fonts are smoothed.
Public property | TextVisible | Gets or sets a value indicating whether the texts in the CADImage are visible.
Public property | UndoMode | Gets or sets whether undo/redo is disable or enable for professional version
Public property | UseDoubleBuffering | Outdated. Does nothing
Public property | UseLayerPriority |
Public property | UseMultyTTFFonts | Gets or sets a value indicating whether a multimode is used for showing symbols.
Public property | UseNullWidth | Specifies if default width will be used instead of entity width.
Public property | UseSHXFonts | Specifies if SHX fonts will be used for visualization.
Public property | UseTTFFonts | Specifies if TTF fonts will be used for visualization.
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles in the CADImage are drawn with GDI+ drawing methods without linearization.
Top
See Also

Reference

CADImage Class


CADImage.AbsDepth Property

Gets an absolute depths of the CADImage.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overridable Property AbsDepth() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual double AbsDepth {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.AbsHeight Property

Gets an absolute height of the CADImage.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overridable Property AbsHeight() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual double AbsHeight {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.AbsWidth Property

Gets an absolute width of the CADImage.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overridable Property AbsWidth() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual double AbsWidth {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.Angle Property

Gets or sets the angle for this CADImage object visualization.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Angle() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float Angle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.BackgroundColor Property

Gets or sets a background color of this CADImage.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property BackgroundColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Color BackgroundColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.BorderSize Property

Gets or sets a border size in pixels.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property BorderSize() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double BorderSize {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.BorderType Property

Gets or sets a border type.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property BorderType() As CADBorderType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADBorderType BorderType {get; set;}
This language is not supported or no code example is available.

Property Value

One of the CADBorderType values.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.Center Property

Gets or sets CADImage center point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Center() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Center {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.Charset Property

Gets or sets a character set for the text entities.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Charset() As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte Charset {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.CodePage Property

Gets or sets a number that identifies the encoding used in the loaded CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Property CodePage() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static int CodePage {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.Converter Property

Gets a converter that loads CAD entities from the file to draw them in the current CADImage.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Converter() As CADConverter
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADConverter Converter {get;}
This language is not supported or no code example is available.

Property Value

An object of the CADConverter class.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.CurrentLayer Property

Gets or sets a current layer for the CADImage.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property CurrentLayer() As CADLayer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADLayer CurrentLayer {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.CurrentLayout Property

Gets or sets a current layout for the CADImage.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property CurrentLayout() As CADLayout
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADLayout CurrentLayout {get; set;}
This language is not supported or no code example is available.

Property Value

A CADLayout representing a current layout of the CAD drawing.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.CurrentLayoutIndex Property

Gets an index of the current layout.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property CurrentLayoutIndex() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int CurrentLayoutIndex {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.CurrentMarker Property

Gets a currently selected marker.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property CurrentMarker() As Marker
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Marker CurrentMarker {get;}
This language is not supported or no code example is available.

Property Value

A currently selected Marker or null if no marker is selected.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.DefaultColor Property

Gets or sets a default color for the CADImage.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DefaultColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Color DefaultColor {get; set;}
This language is not supported or no code example is available.

Property Value

An object of the Color structure. Default value is black.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.DefaultLayoutIndex Property

Gets or sets a default layout index.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DefaultLayoutIndex() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int DefaultLayoutIndex {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.DimensionsVisible Property

Gets or sets a value indicating whether dimensions on the drawing are visible.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DimensionsVisible() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool DimensionsVisible {get; set;}
This language is not supported or no code example is available.

Property Value

true if the dimensions are visible; otherwise, false. Default value is true.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.DrawMode Property

Gets or sets a current drawing mode.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DrawMode() As CADDrawMode
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADDrawMode DrawMode {get; set;}
This language is not supported or no code example is available.

Property Value

One of the CADDrawMode values.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.EnableSnap Property

Gets or sets enablement of snap mode

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property EnableSnap() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool EnableSnap {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.Extents Property

Gets or sets an extents of the CADImage object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Extents() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DRect Extents {get; set;}
This language is not supported or no code example is available.

Property Value

A DRect object that specifies the CADImage extents.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.FileInf Property

Gets information about a currently open file by means of the FileInfo class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property FileInf() As FileInfo
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public FileInfo FileInf {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.GDIPainter Property

Provides drawing functionality based on GDI+.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property GDIPainter() As CADGraphicsGDI
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADGraphicsGDI GDIPainter {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.GraphicsOutMode Property

Specifies image draw mode.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property GraphicsOutMode() As DrawGraphicsMode
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DrawGraphicsMode GraphicsOutMode {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.InterpolationMode Property

Gets or sets the interpolation mode associated with current Graphics object

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property InterpolationMode() As InterpolationMode
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public InterpolationMode InterpolationMode {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.Is3D Property

Gets a value indicating whether this CADImage is three-dimensional.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Is3D() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Is3D {get;}
This language is not supported or no code example is available.

Property Value

true if the CADImage is three-dimensional; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.IsDraw3DAxes Property

Gets or sets a value indicating whether 3D axes are shown on the drawing.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property IsDraw3DAxes() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsDraw3DAxes {get; set;}
This language is not supported or no code example is available.

Property Value

true if the 3D axes are shown; otherwise, false. Default value is false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.IsDrawingRotated Property

Gets a value indicating whether the CADImage has been rotated.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property IsDrawingRotated() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsDrawingRotated {get;}
This language is not supported or no code example is available.

Property Value

true if the CADImage has been rotated; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.IsShowBackground Property

Gets or sets a value indicating using of a BackgroundColor.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property IsShowBackground() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsShowBackground {get; set;}
This language is not supported or no code example is available.

Property Value

true if a background color is used; otherwise, false. Default value is true.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.IsShowLineWeight Property

Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Property IsShowLineWeight() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual bool IsShowLineWeight {get; set;}
This language is not supported or no code example is available.

Property Value

true if a thickness of lines in the CADImage is determined by the file data; otherwise, false.
Remarks

If this property value is false, a thickness of lines in the CADImage is determined by the NullWidth property.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.IsSnapObject Property

Gets a value, which shows if there is an object for snapping under current coordinates

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property IsSnapObject() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsSnapObject {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.IsStopped Property

For internal use.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property IsStopped() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsStopped {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.IsWithoutBorder Property

Gest or sets a value indicating whether to draw the CADImage without borders.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property IsWithoutBorder() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsWithoutBorder {get; set;}
This language is not supported or no code example is available.

Property Value

true if the CADImage is drawn without borders; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.IsWithoutMargins Property

Gets or sets a value indicating whether to draw the CADImage without margins.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property IsWithoutMargins() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsWithoutMargins {get; set;}
This language is not supported or no code example is available.

Property Value

true if the CADImage is drawn without margins; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.LastLoadedFilePath Property

Specifying of the search directory (used for X-Refs, ImageEnt)

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Property LastLoadedFilePath() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static string LastLoadedFilePath {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.LayersCount Property

Gets a quantity of layers in this CADImage.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overridable Property LayersCount() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual int LayersCount {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.Layouts Property

Gets a collection of layouts in the current CADImage.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Layouts() As CADLayoutCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADLayoutCollection Layouts {get;}
This language is not supported or no code example is available.

Property Value

An object of the CADLayoutCollection class.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.LayoutsCount Property

Gets a quantity of layouts in this CADImage.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property LayoutsCount() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int LayoutsCount {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.LineScaled Property

NOTE: This member is now obsolete.use IsShowLineWeight

Gets or sets a value indicating whether a width of lines to draw all entities in the drawing is specified by the file data.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LineScaled() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool LineScaled {get; set;}
This language is not supported or no code example is available.

Property Value

true if a line width is determined by the file data; otherwise, false.
Remarks

If this property returns false a width of lines to draw all CAD entities is specified by the NullWidth property.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.LineWeightScale Property

Gets or sets a scale for drawing lines.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LineWeightScale() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double LineWeightScale {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.MMToPixelX Property

Example See Also

Gets or sets a value corresponding to amount of millimeters per one pixel.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property MMToPixelX() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double MMToPixelX {get; set;}
This language is not supported or no code example is available.
Example
<p>Example use MMToPixelX:</p> <p>[C#]</p>
Copy
 public void SaveRealSizeImage(Control drawingControl)
 {
     Stream str = File.OpenRead(@".\test.dwg");
     CADImage cadImage = new CADImport.DWG.DWGImage();
     cadImage.LoadFromStream(str);
     str.Close();
     DRect tmpRect = new DRect(0, 0, 1, 1);
     cadImage.SetNewMMToPixel(drawingControl.CreateGraphics());
     double realScaleDouble = this.cadImage.AbsWidth / this.cadImage.MMToPixelX;
     tmpRect.Width = tmpRect.Width * realScaleDouble;
     tmpRect.Height = tmpRect.Height * realScaleDouble;
     this.cadImage.SaveToFile(@"result.jpg", ImageFormat.Jpeg, tmpRect);
 }
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.NullWidth Property

Gets or sets default thickness for lines used to draw a CADImage.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property NullWidth() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float NullWidth {get; set;}
This language is not supported or no code example is available.

Property Value

Line thickness. Default value is 1.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.NumberOfPartsInCircle Property

Gets or sets a quantity of segments to be used to draw a circle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property NumberOfPartsInCircle() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int NumberOfPartsInCircle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.Painter Property

Provides image drawing functionality.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Painter() As CADPresenter
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADPresenter Painter {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.PrintDialog Property

Gets or sets print dialog

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PrintDialog() As PrintDialog
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public PrintDialog PrintDialog {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.PureExtents Property

Gets CADImage extents without margins.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property PureExtents() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DRect PureExtents {get;}
This language is not supported or no code example is available.

Property Value

The DRect object that specifies extents of the CADImage without margins.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.ResizeDisproportionateDrawing Property

For internal use

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ResizeDisproportionateDrawing() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool ResizeDisproportionateDrawing {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SHXSearchPaths Property

Gets or sets paths for searching SHX fonts.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property SHXSearchPaths() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string SHXSearchPaths {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SearchSHXPaths Property

Gets or sets a value specifying whether SHX paths will be searched for the fonts.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property SearchSHXPaths() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool SearchSHXPaths {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SelectEntitiesCount Property

Gets the number of selected entities

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property SelectEntitiesCount() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int SelectEntitiesCount {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SelectedEntities Property

Gets or sets a list of selected entities

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property SelectedEntities() As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntityCollection SelectedEntities {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SelectionMode Property

Gets or sets a state of the Selection tool.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property SelectionMode() As SelectionEntityMode
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SelectionEntityMode SelectionMode {get; set;}
This language is not supported or no code example is available.

Property Value

A SelectionEntityMode enumeration value that specifies a state of the Selection tool.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.Selector Property

Provides selection functionality.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Selector() As CADSelector
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADSelector Selector {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SkipMMtoPixel Property

For specific use

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property SkipMMtoPixel() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool SkipMMtoPixel {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SnapCurrent Property

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property SnapCurrent() As SnapMode
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SnapMode SnapCurrent {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SnapOptions Property

Represents Snap options for the CADImage object

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property SnapOptions() As SnapOptions
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SnapOptions SnapOptions {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SnapRealPoint Property

Gets a current point in absolute coordinates (drawing coordinates)

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property SnapRealPoint() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint SnapRealPoint {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SnapScreenPoint Property

Gets current point in display coordinates

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property SnapScreenPoint() As Point
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Point SnapScreenPoint {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.TTFSmoothing Property

Gets or sets a value indicating whether TTF fonts are smoothed.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TTFSmoothing() As TTFSmoothing
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public TTFSmoothing TTFSmoothing {get; set;}
This language is not supported or no code example is available.

Property Value

true if TTF fonts are smoothed; otherwise, false. Default value is false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.TextVisible Property

Gets or sets a value indicating whether the texts in the CADImage are visible.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TextVisible() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool TextVisible {get; set;}
This language is not supported or no code example is available.

Property Value

true if the texts are visible; otherwise, false. Default value is true.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.UndoMode Property

Gets or sets whether undo/redo is disable or enable for professional version

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property UndoMode() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool UndoMode {get; set;}
This language is not supported or no code example is available.

Property Value

true if the undo is enable; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.UseDoubleBuffering Property

Outdated. Does nothing

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property UseDoubleBuffering() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool UseDoubleBuffering {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.UseLayerPriority Property

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property UseLayerPriority() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool UseLayerPriority {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.UseMultyTTFFonts Property

Gets or sets a value indicating whether a multimode is used for showing symbols.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property UseMultyTTFFonts() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool UseMultyTTFFonts {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.UseNullWidth Property

Specifies if default width will be used instead of entity width.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property UseNullWidth() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool UseNullWidth {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.UseSHXFonts Property

Specifies if SHX fonts will be used for visualization.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property UseSHXFonts() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool UseSHXFonts {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.UseTTFFonts Property

Specifies if TTF fonts will be used for visualization.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property UseTTFFonts() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool UseTTFFonts {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.UseWinEllipse Property

Gets or sets a value indicating whether arcs and circles in the CADImage are drawn with GDI+ drawing methods without linearization.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property UseWinEllipse() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool UseWinEllipse {get; set;}
This language is not supported or no code example is available.

Property Value

true if the GDI+ methods are used for drawing arcs and circles in the CADImage; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage Methods

CADImage Class See Also

The following tables list the members exposed by the CADImage type.

Methods
 | Name | Description
Public method | ActiveVPort | Returns drawing area visualized with the active VPort.
Public method | AddScaledDXF | Adds a scaled external reference to the model space of the specified CAD image.
Public method | AddScaledDXFEx | Adds a scaled external reference to the current layout of the specified CAD image.
Public method | AddToUndoList | (Overloaded) Adds operation "create new Entity" to undo list
Public method | ChangeDrawMode | Initializes a new graphic class object if current mode changed.
Public method | ChangeEntities |
Public method | ChangeGraphicsMode | Changes image drawing mode.
Public method | ChangePositionSelectedEntities | Changes position of the selected entities
Public method | ChangePositionSelectedEntity | Changes a position of the selected entity.
Public method | ClearBuffer | Outdated. Does nothing
Public method | ClearMarkers | Clears a collection of markers.
Public method | ClearRedoCollection | Clears redo entity collection
Public method | ClearSelectCollection | Clears a collection of the selected entities.
Public method | ClearSelection | Clears a list of the selected entities.
Public method | ClearSnapTrace | (Overloaded) Clears last drawn snap drawing element
Public method | ClearUndoCollection | Clears undo entity collection
Public method | CopyEntities | (Overloaded) Copies selected entities to the clipboard
Public method | CorrectByGrid | (Overloaded) Reduces a point location on screen to the grid node when the grid is active
Public method | CorrectByGridAndOrtho | Reduces a point relocation sizes on screen to the grid cell sizes when the grid is active
 | CreateImageByExtension | Creates specialised CADImage object for specified file extention
Public method | CutEntities | (Overloaded) Cuts selected entities from collection and paste them to the clipboard
Public method | Dispose | Disposes a CADImage object.
Public method | DoSelectEntities | (Overloaded) Selects inserted list of entities
Public method | DoSelectEntity | Selects inserted entity
Public method | Draw | (Overloaded) Draws a CADImage.
Public method | DrawACISEntity | Draws ACISEntity object
Public method | DrawChangeEntity | Changes a position of the marker designating the selected entity.
Public method | DrawMoveEntityTrace | Draws entities on their offsetting
Public method | DrawSnapTrace | Draws snap icon in case of proximity of object to current coordinates
Public method | EmfConvertToDXF | (Overloaded) Converts emf file to dxf file
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportToMetafile | (Overloaded) Exports a CAD drawing to Windows Enhanced metafile.
Public method | GetAbsPoint | Converts display coordinates into absolute coordinates of a design
Public method | GetCADCoords | Returns coordinates of a point on the drawing.
Public method | GetCenter | Returns the center point of a current layout
Public method | GetExtents | Calculates the current dimensions of the CADImage.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLayerColor | Gets layer color by index
Public method | GetLayerFreeze | Determines whether the layer (CADLayer) is frozen.
Public method | GetLayerName | Gets a name of the layer that has the specified index in the collection of layers.
Public method | GetLayerVisible | Determines whether a layer is visible
Public method | GetLayoutName | Gets a name of the layout that has the specified index in the collection of layouts.
Public method | GetPoint | Transforms a three-dimensional CAD point into a two-dimensional screen point.
Public method | GetRealImagePoint | For internal use.
Public method | GetRealSnapPoint | Smooths a point in absolute coordinates by the entity
Public method | GetSelectEntityRegion | Returns the selected area of the image.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetVPortExtents | Returns extents of the active VPort reduced to the specified size
Public method | InitialNewImage | (Overloaded) Initializes a new image with the default size
Public method | InvalidateSelectEntity | Redraws a selected entity.
Public method | InvalidateSelectedEntities | (Overloaded) Redraws a list of the selected entities
Public method | LoadFromFile | Uses for redefining in a descendant classes, define loading image from the specified file.
Public method | LoadFromStream | Loads a CAD image stored in the specified stream.
Public method | LoadFromWeb | Loads CAD image from hyperlink
Public method | MultipleSelect | Providing CAD image entities' multiple selection within a specified rectangle.
Public method | MultipleSelectExt | Selects all entities inside the inserted rectangle
Public method | PasteEntities | Pastes entities from the clipboard
Public method | PasteEntitiesExt | Pastes entities from the clipboard
Public method | Print | Prints a current CAD image.
Public method | Redo | Redo change
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RefreshCurrentLayout | Refresh current layout.
Public method | RefreshSnapTrace | Refreshes a region of the last drawn snap drawing element
Public method | RemoveEntity | (Overloaded) Removes CADEntity object.
Public method | RotDefault | Rotates the drawing to the default view.
Public method | RotToView | Rotates a CAD image to get a specified view.
Public method | Rotate | Rotates objects in the current drawing.
Public method | SaveAsDXF | Saves a current CAD image in DXF format.
Public method | SaveImageToClipboard | (Overloaded) Writes a visible part of the current CAD image to the clipboard as a raster image.
Public method | SaveToFile | (Overloaded) Saves a part of the current CAD image to the file of the specified format.
Public method | SaveToStream | (Overloaded) Writes a visible part of the current CAD image to the specified stream as a raster image.
Public method | Select | Selects an entity of the CAD image at the specified point.
Public method | SelectExt | Selects an entity of the CAD image at the specified point.
Public method | SetCenter | Sets CADImage center point.
Public method | SetCurrentLayout | Sets a current layout of this CADImage.
Public method | SetLayerColor | (Overloaded) Sets a color for layer (CADLayer) specified by index
Public method | SetLayerFreeze | (Overloaded) Sets freeze parameter for CADLayer
Public method | SetLayerVisible | (Overloaded) Sets a visibility of the layer.
Public method | SetNewEntityMarkerPos | Sets a new position for the selected entity. The entity's new position is defined by the position of the marker.
Public method | SetNewMMToPixel | Sets a quantity of millimeters per pixel for the specified Graphics object.
Public method | SetNewPosEntitiesExt | Sets a new position for the specified entities
Public method | SetNewPosEntity | Sets a new position for the specified entity.
Public method | Stop | For internal use.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | Undo | Undo change
Top
See Also

Reference

CADImage Class


CADImage.ActiveVPort Method

Returns drawing area visualized with the active VPort.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function ActiveVPort() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DRect ActiveVPort()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.AddScaledDXF Method

Adds a scaled external reference to the model space of the specified CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddScaledDXF( _
   ByVal ACADFile As CADImage, _
   ByVal AName As String, _
   ByVal APos As DPoint, _
   ByVal AScale As DPoint, _
   ByVal Rotation As Single _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddScaledDXF(
   CADImage ACADFile,
   string AName,
   DPoint APos,
   DPoint AScale,
   float Rotation
)
This language is not supported or no code example is available.

Parameters

ACADFile

Type: CADImage

A CADImage to which the external reference is added.

AName

Type: string

A string containing a name for the newly created external reference.

APos

Type: DPoint

A DPoint object representing an insertion point for the external reference.

AScale

Type: DPoint

A DPoint object representing a scale for the external reference.

Rotation

Type: float

A rotation angle for the external reference.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.AddScaledDXFEx Method

Adds a scaled external reference to the current layout of the specified CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function AddScaledDXFEx( _
   ByVal ACADFile As CADImage, _
   ByVal AName As String, _
   ByVal APos As DPoint, _
   ByVal AScale As DPoint, _
   ByVal Rotation As Single _
) As CADInsert
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADInsert AddScaledDXFEx(
   CADImage ACADFile,
   string AName,
   DPoint APos,
   DPoint AScale,
   float Rotation
)
This language is not supported or no code example is available.

Parameters

ACADFile

Type: CADImage

A CADImage to which the external reference is added.

AName

Type: string

A string containing a name for the newly created external reference.

APos

Type: DPoint

A DPoint object representing an insertion point for the external reference.

AScale

Type: DPoint

A DPoint object representing a scale for the external reference.

Rotation

Type: float

A rotation angle for the external reference.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.AddToUndoList Method

CADImage Class See Also

Adds operation "create new Entity" to undo list

Overload List
Name | Description
AddToUndoList(CADEntity) | Adds operation "create new Entity" to undo list
AddToUndoList(CADEntity, Operation) | Adds an operation with an entity to undo list
See Also

Reference

CADImage Class
CADImage Members


CADImage.ChangeDrawMode Method

Initializes a new graphic class object if current mode changed.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ChangeDrawMode( _
   ByVal mode As DrawGraphicsMode, _
   ByVal winControl As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ChangeDrawMode(
   DrawGraphicsMode mode,
   Control winControl
)
This language is not supported or no code example is available.

Parameters

mode

Type: DrawGraphicsMode

A mode

winControl

Type: Control

Currently not used

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.ChangeEntities Method

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ChangeEntities( _
   ByVal entities As CADEntityCollection, _
   ByVal dx As Double, _
   ByVal dy As Double, _
   ByVal dz As Double _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ChangeEntities(
   CADEntityCollection entities,
   double dx,
   double dy,
   double dz
)
This language is not supported or no code example is available.

Parameters

entities

Type: CADEntityCollection

dx

Type: double

dy

Type: double

dz

Type: double

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.ChangeGraphicsMode Method

Changes image drawing mode.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ChangeGraphicsMode( _
   ByVal graphicsMode As DrawGraphicsMode, _
   ByVal renderMode As RenderMode _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ChangeGraphicsMode(
   DrawGraphicsMode graphicsMode,
   RenderMode renderMode
)
This language is not supported or no code example is available.

Parameters

graphicsMode

Type: DrawGraphicsMode

renderMode

Type: RenderMode

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.ChangePositionSelectedEntities Method

Changes position of the selected entities

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ChangePositionSelectedEntities( _
   ByVal dx As Double, _
   ByVal dy As Double, _
   ByVal dz As Double, _
   ByVal graph As Graphics, _
   ByVal det As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ChangePositionSelectedEntities(
   double dx,
   double dy,
   double dz,
   Graphics graph,
   bool det
)
This language is not supported or no code example is available.

Parameters

dx

Type: double

A position displacement in the direction of the X axis

dy

Type: double

A position displacement in the direction of the Y axis

dz

Type: double

A position displacement in the direction of the Z axis

graph

Type: Graphics

A Graphics object used for drawing the displaced entity in the new position

det

Type: bool

A boolean value indicating whether the selected entity is redrawn in the new position. true if the entity is redrawn, false if the entity is not redrawn

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.ChangePositionSelectedEntity Method

Changes a position of the selected entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ChangePositionSelectedEntity( _
   ByVal dx As Double, _
   ByVal dy As Double, _
   ByVal dz As Double, _
   ByVal graph As Graphics, _
   ByVal det As Boolean, _
   ByVal sel As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ChangePositionSelectedEntity(
   double dx,
   double dy,
   double dz,
   Graphics graph,
   bool det,
   CADEntity sel
)
This language is not supported or no code example is available.

Parameters

dx

Type: double

A position displacement in the direction of the X axis.

dy

Type: double

A position displacement in the direction of the Y axis.

dz

Type: double

A position displacement in the direction of the Z axis.

graph

Type: Graphics

A Graphics object used for drawing the displaced entity in the new position.

det

Type: bool

A boolean value indicating whether the selected entity is redrawn in the new position. true if the entity is redrawn, false if the entity is not redrawn.

sel

Type: CADEntity

The selected CADEntity.

Return Value

A Rectangle that bounds the selected entity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.ClearBuffer Method

Outdated. Does nothing

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ClearBuffer()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ClearBuffer()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.ClearMarkers Method

Clears a collection of markers.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ClearMarkers()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ClearMarkers()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.ClearRedoCollection Method

Clears redo entity collection

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ClearRedoCollection()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ClearRedoCollection()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.ClearSelectCollection Method

Clears a collection of the selected entities.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ClearSelectCollection()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ClearSelectCollection()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.ClearSelection Method

Clears a list of the selected entities.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ClearSelection()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ClearSelection()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.ClearSnapTrace Method

CADImage Class See Also

Clears last drawn snap drawing element

Overload List
Name | Description
ClearSnapTrace() | Clears the last drawn snap drawing element
ClearSnapTrace(Control) | Clears last drawn snap drawing element
See Also

Reference

CADImage Class
CADImage Members


CADImage.ClearUndoCollection Method

Clears undo entity collection

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ClearUndoCollection()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ClearUndoCollection()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.CopyEntities Method

CADImage Class See Also

Copies selected entities to the clipboard

Overload List
Name | Description
CopyEntities() | Copies selected entities to the clipboard
CopyEntities(CADEntityCollection) | Copies selected entities to the clipboard
See Also

Reference

CADImage Class
CADImage Members


CADImage.CorrectByGrid Method

CADImage Class See Also

Reduces a point location on screen to the grid node when the grid is active

Overload List
Name | Description
CorrectByGrid(ref DPoint) | Reduces a drawing point to the grid node when the grid is active.
CorrectByGrid(ref int, ref int) | Reduces a point location on screen to the grid node when the grid is active
See Also

Reference

CADImage Class
CADImage Members


CADImage.CorrectByGridAndOrtho Method

Reduces a point relocation sizes on screen to the grid cell sizes when the grid is active

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub CorrectByGridAndOrtho( _
   ByRef newPt As Point, _
   ByVal oldX As Integer, _
   ByVal oldY As Integer, _
   ByVal orthoActive As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void CorrectByGridAndOrtho(
   ref Point newPt,
   int oldX,
   int oldY,
   bool orthoActive
)
This language is not supported or no code example is available.

Parameters

newPt

Type: Point

A new screen point

oldX

Type: int

An old X screen point coordinate

oldY

Type: int

An old Y screen point coordinate

orthoActive

Type: bool

Specifies if ortho mode for the control is active

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.CreateImageByExtension Method

Creates specialised CADImage object for specified file extention

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function CreateImageByExtension( _
   ByVal fileName As String _
) As CADImage
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static CADImage CreateImageByExtension(
   string fileName
)
This language is not supported or no code example is available.

Parameters

fileName

Type: string

File name with extention

Return Value

Returns created CADImage object
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.CutEntities Method

CADImage Class See Also

Cuts selected entities from collection and paste them to the clipboard

Overload List
Name | Description
CutEntities() | Cuts selected entities from collection and paste them to the clipboard
CutEntities(CADEntityCollection) | Cuts selected entities from collection and paste them to the clipboard
See Also

Reference

CADImage Class
CADImage Members


CADImage.Dispose Method

Disposes a CADImage object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub Dispose() Implements  _
   IDisposable.Dispose
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void Dispose()
This language is not supported or no code example is available.

Implements

IDisposable.Dispose
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.DoSelectEntities Method

CADImage Class See Also

Selects inserted list of entities

Overload List
Name | Description
DoSelectEntities(CADEntityCollection) | Selects inserted list of entities
DoSelectEntities(SortedList) | Selects inserted list of entities
See Also

Reference

CADImage Class
CADImage Members


CADImage.DoSelectEntity Method

Selects inserted entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub DoSelectEntity( _
   ByVal ent As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void DoSelectEntity(
   CADEntity ent
)
This language is not supported or no code example is available.

Parameters

ent

Type: CADEntity

Inserting entity

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.Draw Method

CADImage Class See Also

Draws a CADImage.

Overload List
Name | Description
Draw(Graphics, RectangleF) | Draws a CADImage(only in GDI+ graphic mode).
Draw(Graphics, RectangleF, Control) | Draws a CADImage.
See Also

Reference

CADImage Class
CADImage Members


CADImage.DrawACISEntity Method

Draws ACISEntity object

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub DrawACISEntity( _
   ByVal sender As Object _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void DrawACISEntity(
   object sender
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

ACISEntity object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.DrawChangeEntity Method

Changes a position of the marker designating the selected entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DrawChangeEntity( _
   ByVal dx As Integer, _
   ByVal dy As Integer, _
   ByVal control As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DrawChangeEntity(
   int dx,
   int dy,
   Control control
)
This language is not supported or no code example is available.

Parameters

dx

Type: int

A position displacement in the direction of the X axis.

dy

Type: int

A position displacement in the direction of the Y axis.

control

Type: Control

A control for drawing

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.DrawMoveEntityTrace Method

Draws entities on their offsetting

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DrawMoveEntityTrace( _
   ByVal dx As Integer, _
   ByVal dy As Integer, _
   ByVal control As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DrawMoveEntityTrace(
   int dx,
   int dy,
   Control control
)
This language is not supported or no code example is available.

Parameters

dx

Type: int

dy

Type: int

control

Type: Control

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.DrawSnapTrace Method

Draws snap icon in case of proximity of object to current coordinates

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function DrawSnapTrace( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal control As Control, _
   ByVal rect As RectangleF _
) As PointF
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public PointF DrawSnapTrace(
   int x,
   int y,
   Control control,
   RectangleF rect
)
This language is not supported or no code example is available.

Parameters

x

Type: int

X coordinate

y

Type: int

Y coordinate

control

Type: Control

Control, where the element is drawn

rect

Type: RectangleF

Current dimensions of the drawing

Return Value

Coordinates of the snap
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.EmfConvertToDXF Method

CADImage Class See Also

Converts emf file to dxf file

Overload List
Name | Description
EmfConvertToDXF(string) | Converts emf file to dxf file
EmfConvertToDXF(string, string) | Convert emf file to dxf file
See Also

Reference

CADImage Class
CADImage Members


CADImage.ExportToMetafile Method

CADImage Class See Also

Exports a CAD drawing to Windows Enhanced metafile.

Overload List
Name | Description
ExportToMetafile(string, DRect) | Exports a CAD drawing to Windows Enhanced metafile.
ExportToMetafile(string, DRect, Rectangle) | Exports a CAD drawing to Windows Enhanced metafile.
ExportToMetafile(string, DRect, Rectangle, bool) | Exports a CAD drawing to Windows Enhanced metafile.
See Also

Reference

CADImage Class
CADImage Members


CADImage.GetAbsPoint Method

Converts display coordinates into absolute coordinates of a design

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetAbsPoint( _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal curRect As RectangleF, _
   ByVal scale As Single, _
   ByVal pos As PointF _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint GetAbsPoint(
   float x,
   float y,
   RectangleF curRect,
   float scale,
   PointF pos
)
This language is not supported or no code example is available.

Parameters

x

Type: float

The X display coordinate

y

Type: float

The Y display coordinate

curRect

Type: RectangleF

The Current drawing rectangle

scale

Type: float

A scale

pos

Type: PointF

An offset

Return Value

Converted coordinates of a Point
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.GetCADCoords Method

Returns coordinates of a point on the drawing.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Function GetCADCoords( _
   ByVal xScaled As Single, _
   ByVal yScaled As Single _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual DPoint GetCADCoords(
   float xScaled,
   float yScaled
)
This language is not supported or no code example is available.

Parameters

xScaled

Type: float

A ratio between the X-coordinate of the point position and the drawing's width.

yScaled

Type: float

A ratio between the Y-coordinate of the point position and the drawing's height.

Return Value

A DPoint object representing a point on a CAD image.
Remarks

The Z-coordinate of the value to be returned equals 0.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.GetCenter Method

Returns the center point of a current layout

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetCenter() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint GetCenter()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.GetExtents Method

Calculates the current dimensions of the CADImage.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub GetExtents()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void GetExtents()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.GetLayerColor Method

Gets layer color by index

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetLayerColor( _
   ByVal ind As Integer _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Color GetLayerColor(
   int ind
)
This language is not supported or no code example is available.

Parameters

ind

Type: int

An index of the layer in the collection of layers

Return Value

A Color of the layer
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.GetLayerFreeze Method

Determines whether the layer (CADLayer) is frozen.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetLayerFreeze( _
   ByVal ind As Integer _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool GetLayerFreeze(
   int ind
)
This language is not supported or no code example is available.

Parameters

ind

Type: int

An index of the layer in the collection of layers

Return Value

True if specified layer is frozen; otherwise false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.GetLayerName Method

Gets a name of the layer that has the specified index in the collection of layers.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetLayerName( _
   ByVal ind As Integer _
) As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string GetLayerName(
   int ind
)
This language is not supported or no code example is available.

Parameters

ind

Type: int

An index of the layer in the collection of layers.

Return Value

A string containing the name of the specified layer.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.GetLayerVisible Method

Determines whether a layer is visible

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetLayerVisible( _
   ByVal ind As Integer _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool GetLayerVisible(
   int ind
)
This language is not supported or no code example is available.

Parameters

ind

Type: int

An index of the layer in the collection of layers

Return Value

true if the specified layer is visible; othewise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.GetLayoutName Method

Gets a name of the layout that has the specified index in the collection of layouts.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetLayoutName( _
   ByVal ind As Integer _
) As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string GetLayoutName(
   int ind
)
This language is not supported or no code example is available.

Parameters

ind

Type: int

An index of the layout in the collection of layouts.

Return Value

A string containing the name of the specified layout.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.GetPoint Method

Example See Also

Transforms a three-dimensional CAD point into a two-dimensional screen point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Function GetPoint( _
   ByVal P As DPoint _
) As Point
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual Point GetPoint(
   DPoint P
)
This language is not supported or no code example is available.

Parameters

P

Type: DPoint

A DPoint object representing a point in three-dimensional coordinate system.

Return Value

A Point object representing a point in two-dimensional coordinate system.
Example
<p>Example use GetPoint method:</p> <p>[C#]</p>
Copy
 ...
 CADLine ln = cadImage.Converter.Entities[0] as CADLine;
 if(ln != null)
 {
     Point p1 = cadImage.GetPoint(ln.Point);
     Point p2 = cadImage.GetPoint(ln.Point1);
     Console.Write(String.Format("Line X1={0} Y1={1} X2={2} Y2={3}", p1.X, p1.Y, p2.X, p2.Y))
 }
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.GetRealImagePoint Method

For internal use.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Function GetRealImagePoint( _
   ByVal P As DPoint _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual DPoint GetRealImagePoint(
   DPoint P
)
This language is not supported or no code example is available.

Parameters

P

Type: DPoint

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.GetRealSnapPoint Method

Smooths a point in absolute coordinates by the entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetRealSnapPoint( _
   ByVal ent As CADEntity, _
   ByVal point As DPoint, _
   ByVal box As DRect _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint GetRealSnapPoint(
   CADEntity ent,
   DPoint point,
   DRect box
)
This language is not supported or no code example is available.

Parameters

ent

Type: CADEntity

CADEntity for which a point is smoothed

point

Type: DPoint

A point (DPoint) to smoothing

box

Type: DRect

Box, where the point is smoothed

Return Value

Returns smoothed point (DPoint)
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.GetSelectEntityRegion Method

Returns the selected area of the image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetSelectEntityRegion( _
   ByVal rect As Rectangle _
) As Region
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Region GetSelectEntityRegion(
   Rectangle rect
)
This language is not supported or no code example is available.

Parameters

rect

Type: Rectangle

A Region object representing the selected area of the image.

Return Value

A Rectangle object specifying the image area to be selected.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.GetVPortExtents Method

Returns extents of the active VPort reduced to the specified size

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetVPortExtents( _
   ByVal clientHeight As Double _
) As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DRect GetVPortExtents(
   double clientHeight
)
This language is not supported or no code example is available.

Parameters

clientHeight

Type: double

The height

Return Value

The extents
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.InitialNewImage Method

CADImage Class See Also

Initializes a new image with the default size

Overload List
Name | Description
InitialNewImage() | Initializes a new image with the default size
InitialNewImage(double, double) | Initializes a new image with the specified size
See Also

Reference

CADImage Class
CADImage Members
CADImport Namespace
CADImage
CADPolyLine
DPoint
clNone


CADImage.InvalidateSelectEntity Method

Redraws a selected entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub InvalidateSelectEntity( _
   ByVal cl1 As Control, _
   ByVal scale As Single _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void InvalidateSelectEntity(
   Control cl1,
   float scale
)
This language is not supported or no code example is available.

Parameters

cl1

Type: Control

A Control on which the selected area is redrawn.

scale

Type: float

A scale in which the selected area is redrawn.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.InvalidateSelectedEntities Method

CADImage Class See Also

Redraws a list of the selected entities

Overload List
Name | Description
InvalidateSelectedEntities(Graphics) | Redraws a list of the selected entities
InvalidateSelectedEntities(Graphics, CADEntityCollection) | Redraws a collection of an entities
See Also

Reference

CADImage Class
CADImage Members


CADImage.LoadFromFile Method

Uses for redefining in a descendant classes, define loading image from the specified file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub LoadFromFile( _
   ByVal path As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void LoadFromFile(
   string path
)
This language is not supported or no code example is available.

Parameters

path

Type: string

A path to the file that contains an image to be loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.LoadFromStream Method

Loads a CAD image stored in the specified stream.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub LoadFromStream( _
   ByVal str As Stream _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void LoadFromStream(
   Stream str
)
This language is not supported or no code example is available.

Parameters

str

Type: Stream

A Stream that contains a CAD image to be loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.LoadFromWeb Method

Loads CAD image from hyperlink

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Function LoadFromWeb( _
   ByVal path As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual bool LoadFromWeb(
   string path
)
This language is not supported or no code example is available.

Parameters

path

Type: string

Hyperlink path

Return Value

true if loading was sucessfull; otherwise false
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.MultipleSelect Method

Providing CAD image entities' multiple selection within a specified rectangle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub MultipleSelect( _
   ByVal rect As DRect, _
   ByVal clearSelCollection As Boolean, _
   ByVal visualSelect As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void MultipleSelect(
   DRect rect,
   bool clearSelCollection,
   bool visualSelect
)
This language is not supported or no code example is available.

Parameters

rect

Type: DRect

Multiple selection rectangle

clearSelCollection

Type: bool

Clear select collection

visualSelect

Type: bool

Visual selecting

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.MultipleSelectExt Method

Selects all entities inside the inserted rectangle

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Function MultipleSelectExt( _
   ByVal rect As DRect, _
   ByVal clearSelCollection As Boolean, _
   ByVal visualSelect As Boolean _
) As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual CADEntityCollection MultipleSelectExt(
   DRect rect,
   bool clearSelCollection,
   bool visualSelect
)
This language is not supported or no code example is available.

Parameters

rect

Type: DRect

Inserting rectangle

clearSelCollection

Type: bool

Clears SelectedEntities object if true

visualSelect

Type: bool

Represents visual selection if true

Return Value

Returns list of selected entities
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.PasteEntities Method

Pastes entities from the clipboard

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function PasteEntities() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int PasteEntities()
This language is not supported or no code example is available.

Return Value

Returns quantity of entities
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.PasteEntitiesExt Method

Pastes entities from the clipboard

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function PasteEntitiesExt() As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntityCollection PasteEntitiesExt()
This language is not supported or no code example is available.

Return Value

Returns list of entities
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.Print Method

Prints a current CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Function Print( _
   ByVal showDialog As Boolean, _
   ByVal printing As Boolean, _
   ByVal printerName As String _
) As PrintDocument
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual PrintDocument Print(
   bool showDialog,
   bool printing,
   string printerName
)
This language is not supported or no code example is available.

Parameters

showDialog

Type: bool

printing

Type: bool

printerName

Type: string

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.Redo Method

Redo change

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Redo()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Redo()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.RefreshCurrentLayout Method

Refresh current layout.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub RefreshCurrentLayout()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void RefreshCurrentLayout()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.RefreshSnapTrace Method

Refreshes a region of the last drawn snap drawing element

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub RefreshSnapTrace( _
   ByVal control As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void RefreshSnapTrace(
   Control control
)
This language is not supported or no code example is available.

Parameters

control

Type: Control

Control, where the drawing element is drawn

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.RemoveEntity Method

CADImage Class See Also

Removes CADEntity object.

Overload List
Name | Description
RemoveEntity() | Removes all entities form list of entities
RemoveEntity(CADEntity) | Removes CADEntity object.
RemoveEntity(CADEntityCollection) | Removes all entities form entities collection
See Also

Reference

CADImage Class
CADImage Members


CADImage.RotDefault Method

Rotates the drawing to the default view.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub RotDefault()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void RotDefault()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.RotToView Method

Rotates a CAD image to get a specified view.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub RotToView( _
   ByVal A3DView As CADViewDirection _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void RotToView(
   CADViewDirection A3DView
)
This language is not supported or no code example is available.

Parameters

A3DView

Type: CADViewDirection

One of the CADViewDirection values that specifies a view of the CAD image.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.Rotate Method

Rotates objects in the current drawing.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub Rotate( _
   ByVal Axis As Axes, _
   ByVal Angle As Single _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void Rotate(
   Axes Axis,
   float Angle
)
This language is not supported or no code example is available.

Parameters

Axis

Type: Axes

One of the Axes values specifying an axis of rotation.

Angle

Type: float

An angle of rotation.

Remarks

An angle of rotation is measured in degrees.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SaveAsDXF Method

Saves a current CAD image in DXF format.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SaveAsDXF( _
   ByVal fName As String, _
   ByVal handle As IntPtr, _
   ByVal aForm As Form _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SaveAsDXF(
   string fName,
   IntPtr handle,
   Form aForm
)
This language is not supported or no code example is available.

Parameters

fName

Type: string

A path to the DXF file to be saved.

handle

Type: IntPtr

A handle used for analyzing records to be written to the intermediate metafile.

aForm

Type: Form

A Form object used for creating the intermediate metafile.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SaveImageToClipboard Method

CADImage Class See Also

Writes a visible part of the current CAD image to the clipboard as a raster image.

Overload List
Name | Description
SaveImageToClipboard(DRect) | Writes a visible part of the current CAD image to the clipboard as a raster image.
SaveImageToClipboard(DRect, PixelFormat) | Writes a visible part of the current CAD image to the clipboard as a raster image.
SaveImageToClipboard(DRect, Rectangle) | Writes a specified part of the current CAD image to the clipboard as a raster image.
SaveImageToClipboard(DRect, Rectangle, PixelFormat) | Writes a specified part of the current CAD image to the clipboard as a raster image.
See Also

Reference

CADImage Class
CADImage Members


CADImage.SaveToFile Method

CADImage Class See Also

Saves a part of the current CAD image to the file of the specified format.

Overload List
Name | Description
SaveToFile(string, ImageFormat, DRect, Rectangle) | Saves a part of the current CAD image to the file of the specified format.
SaveToFile(string, ImageFormat, DRect, Rectangle, PixelFormat) | Saves a part of the current CAD image to the file of the specified format.
SaveToFile(string, ImageFormat, DRect) | Writes a visible part of the current CAD image to the file as a raster image.
SaveToFile(string, ImageFormat, DRect, PixelFormat) | Writes a visible part of the current CAD image to the file as a raster image.
See Also

Reference

CADImage Class
CADImage Members


CADImage.SaveToStream Method

CADImage Class See Also

Writes a visible part of the current CAD image to the specified stream as a raster image.

Overload List
Name | Description
SaveToStream(Stream, ImageFormat, DRect) | Writes a visible part of the current CAD image to the specified stream as a raster image.
SaveToStream(Stream, ImageFormat, DRect, PixelFormat) | Writes a visible part of the current CAD image to the specified stream as a raster image.
SaveToStream(Stream, ImageFormat, DRect, Rectangle) | Saves a part of the current CAD image to the stream of the specified format.
SaveToStream(Stream, ImageFormat, DRect, Rectangle, PixelFormat) | Saves a part of the current CAD image to the stream of the specified format.
See Also

Reference

CADImage Class
CADImage Members


CADImage.Select Method

Selects an entity of the CAD image at the specified point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Select( _
   ByVal x As Integer, _
   ByVal y As Integer _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Select(
   int x,
   int y
)
This language is not supported or no code example is available.

Parameters

x

Type: int

An X coordinate of the point at which the entity to be selected is located.

y

Type: int

An Y coordinate of the point at which the entity to be selected is located.

Remarks

The X and Y coordinates are measured in pixels. This method requires SelectionMode to be switched to be set.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SelectExt Method

Selects an entity of the CAD image at the specified point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function SelectExt( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal clearPrevSelection As Boolean, _
   ByVal visualSelect As Boolean _
) As CADEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntity SelectExt(
   int x,
   int y,
   bool clearPrevSelection,
   bool visualSelect
)
This language is not supported or no code example is available.

Parameters

x

Type: int

An X coordinate of the point at which the entity to be selected is located.

y

Type: int

An Y coordinate of the point at which the entity to be selected is located.

clearPrevSelection

Type: bool

Clears selection of objects if true; adds to selected if false

visualSelect

Type: bool

Visual select entity

Return Value

A CADEntity located at the specified point, or null if nothing is located at the specified point.
Remarks

The X and Y coordinates are measured in pixels. This method requires SelectionMode to be switched to be set.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SetCenter Method

Sets CADImage center point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetCenter()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetCenter()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SetCurrentLayout Method

Sets a current layout of this CADImage.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetCurrentLayout( _
   ByVal ind As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetCurrentLayout(
   int ind
)
This language is not supported or no code example is available.

Parameters

ind

Type: int

An index of the layout to be set as current.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SetLayerColor Method

CADImage Class See Also

Sets a color for layer (CADLayer) specified by index

Overload List
Name | Description
SetLayerColor(int, Color) | Sets a color for layer (CADLayer) specified by index
SetLayerColor(int, Color, bool) | Sets a color for layer (CADLayer) specified by index
See Also

Reference

CADImage Class
CADImage Members


CADImage.SetLayerFreeze Method

CADImage Class See Also

Sets freeze parameter for CADLayer

Overload List
Name | Description
SetLayerFreeze(int, bool) | Sets freeze parameter for CADLayer
SetLayerFreeze(int, bool, bool) | Sets freeze parameter for CADLayer
See Also

Reference

CADImage Class
CADImage Members


CADImage.SetLayerVisible Method

CADImage Class See Also

Sets a visibility of the layer.

Overload List
Name | Description
SetLayerVisible(int, bool) | Sets a visibility of the layer.
SetLayerVisible(int, bool, bool) | Sets a visibility of the layer.
See Also

Reference

CADImage Class
CADImage Members


CADImage.SetNewEntityMarkerPos Method

Sets a new position for the selected entity. The entity's new position is defined by the position of the marker.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetNewEntityMarkerPos( _
   ByVal dx As Double, _
   ByVal dy As Double, _
   ByVal dz As Double _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetNewEntityMarkerPos(
   double dx,
   double dy,
   double dz
)
This language is not supported or no code example is available.

Parameters

dx

Type: double

A position displacement of the marker in the direction of the X axis.

dy

Type: double

A position displacement of the marker in the direction of the Y axis.

dz

Type: double

A position displacement of the marker in the direction of the Z axis.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SetNewMMToPixel Method

Sets a quantity of millimeters per pixel for the specified Graphics object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetNewMMToPixel( _
   ByVal val As Graphics _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetNewMMToPixel(
   Graphics val
)
This language is not supported or no code example is available.

Parameters

val

Type: Graphics

The Graphics object for which a quantity of millimeters per pixel to be set.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SetNewPosEntitiesExt Method

Sets a new position for the specified entities

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetNewPosEntitiesExt( _
   ByVal dx As Double, _
   ByVal dy As Double, _
   ByVal dz As Double, _
   ByVal graph As Graphics _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetNewPosEntitiesExt(
   double dx,
   double dy,
   double dz,
   Graphics graph
)
This language is not supported or no code example is available.

Parameters

dx

Type: double

A position displacement in the direction of the X axis

dy

Type: double

A position displacement in the direction of the Y axis

dz

Type: double

A position displacement in the direction of the Z axis

graph

Type: Graphics

Graph object for entity redrawing

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SetNewPosEntity Method

Sets a new position for the specified entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetNewPosEntity( _
   ByVal dx As Double, _
   ByVal dy As Double, _
   ByVal dz As Double, _
   ByVal ent As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetNewPosEntity(
   double dx,
   double dy,
   double dz,
   CADEntity ent
)
This language is not supported or no code example is available.

Parameters

dx

Type: double

A position displacement in the direction of the X axis.

dy

Type: double

A position displacement in the direction of the Y axis.

dz

Type: double

A position displacement in the direction of the Z axis.

ent

Type: CADEntity

A CADEntity for which a new position is set.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.Stop Method

For internal use.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Stop()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Stop()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.Undo Method

Undo change

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Undo()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Undo()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage Fields

CADImage Class See Also

The following tables list the members exposed by the CADImage type.

Fields
 | Name | Description
 | EntityBuffer | Represents buffer for CADEntityCollection storing.
Public field | visibleArea | Represents CADImage visible area.
Top
See Also

Reference

CADImage Class


EntityBuffer Field

Represents buffer for CADEntityCollection storing.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared EntityBuffer As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static CADEntityCollection EntityBuffer
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


visibleArea Field

Represents CADImage visible area.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public visibleArea As SizeF
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SizeF visibleArea
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImageDef Class

Members See Also

Represents a raster image inserted in the CAD drawing.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADImageDef
    Inherits CADObjectEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADImageDef : CADObjectEntity
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADImageDef
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageDef Members


CADImageDef Members

CADImageDef Class Constructors Methods Fields Properties See Also

Represents a raster image inserted in the CAD drawing.

The following tables list the members exposed by the CADImageDef type.

Constructors
 | Name | Description
Public constructor | CADImageDef | Initializes an object of the CADObjectEntity class. (inherited from CADObjectEntity).
Top
Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADImageDef entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | FileName | Gets or sets an image file name
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer containing this CADEntity. (inherited from CADEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Picture | Gets or sets a Bitmap object.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Size | Gets the size of CADImageDef picture.
Public property | Visibility | Gets or sets a value indicating whether a CADEntity is visible. (inherited from CADEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADImageDef object to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADImageDef Class


CADObjectEntity Constructor

Initializes an object of the CADObjectEntity class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADObjectEntity()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADObjectEntity Class
CADObjectEntity Members


CADImageDef Properties

CADImageDef Class See Also

The following tables list the members exposed by the CADImageDef type.

Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADImageDef entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | FileName | Gets or sets an image file name
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer containing this CADEntity. (inherited from CADEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Picture | Gets or sets a Bitmap object.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Size | Gets the size of CADImageDef picture.
Public property | Visibility | Gets or sets a value indicating whether a CADEntity is visible. (inherited from CADEntity).
Top
See Also

Reference

CADImageDef Class


CADImageDef.EntType Property

Gets the type of this CADImageDef entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageDef Class
CADImageDef Members


CADImageDef.FileName Property

Gets or sets an image file name

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property FileName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string FileName {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageDef Class
CADImageDef Members


CADImageDef.Picture Property

Gets or sets a Bitmap object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Picture() As Bitmap
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Bitmap Picture {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageDef Class
CADImageDef Members


CADImageDef.Size Property

Gets the size of CADImageDef picture.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Size() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Size {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageDef Class
CADImageDef Members


CADImageDef Methods

CADImageDef Class See Also

The following tables list the members exposed by the CADImageDef type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADImageDef object to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADImageDef Class


CADImageDef.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageDef Class
CADImageDef Members


CADImageDef.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageDef Class
CADImageDef Members


CADImageDef.Loaded Method

Loads this CADImageDef object to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADImageDef object is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageDef Class
CADImageDef Members


CADImageDef Fields

CADImageDef Class See Also

The following tables list the members exposed by the CADImageDef type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADImageDef Class


CADImageEnt Class

Members See Also

Represents a reference to the raster image in the CAD drawing.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADImageEnt
    Inherits CADWipeout
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADImageEnt : CADWipeout
This language is not supported or no code example is available.
Remarks

A CAD drawing can have many references to the same raster image.

Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.CADPenLine
CADImport.CADPolylineBase
CADImport.CADWipeout
CADImport.CADImageEnt
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageEnt Members


CADImageEnt Members

CADImageEnt Class Constructors Methods Fields Properties See Also

Represents a reference to the raster image in the CAD drawing.

The following tables list the members exposed by the CADImageEnt type.

Constructors
 | Name | Description
Public constructor | CADImageEnt | Initializes a new instance of the CADImageEnt class.
Top
Properties
 | Name | Description
Public property | Box | Return box of the current primitive. (inherited from CADPolylineBase).
Public property | ClipPoints | Gets or sets a collection of the clipping points. (inherited from CADWipeout).
Public property | ClippingBoundaryType | Gets or sets a type of the clipping boundary of the current wipeout. (inherited from CADWipeout).
Public property | Closed | Gets or sets a value indicating whether this CADPolyLine is closed. (inherited from CADPolylineBase).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADPolylineBase. (inherited from CADPolylineBase).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | DottedSingPoints | Gets a collection of points that specify the dots and dashes of the CADPolylineBase. (inherited from CADPolylineBase).
Public property | EntName | Gets a name of the CADImageEnt object.
Public property | EntType | Gets the type of this CADImageEnt entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Flags | Gets or sets a number that specifies an appearance of this CADPolylineBase entity. (inherited from CADPolylineBase).
Public property | FlagsEx | Gets or sets a flags for drawing a CADImageEnt.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Height | Gets or sets a height of this wipeout. (inherited from CADWipeout).
Public property | ImageDef | Gets or sets a raster image in the CAD drawing.
Public property | IsMeshMClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the M direction. (inherited from CADPolylineBase).
Public property | IsMeshNClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the N direction. (inherited from CADPolylineBase).
Public property | IsMonoChrome | Gets or sets a value indicating whether the referenced raster image is monochrome.
Public property | IsPolyFaceMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | IsPolyZThickness | Gets a value indicating whether a line thickness measured along the axis Z is equal to 0. (inherited from CADPolylineBase).
Public property | IsPolygonMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | IsUseClipping | Indicates whether the clipping is used. (inherited from CADWipeout).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Picture | Gets an image referenced by this CADImageEnt object.
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADPenLine).
Public property | Point1 | This proprty is obsolete. We recommend to use UVector instead of it.
Public property | Point2 | This proprty is obsolete. We recommend to use VVector instead of it.
Public property | Point3 | This proprty is obsolete. We recommend to use Size instead of it.
Public property | PolyPoints | Gets a collection of points belonging to the polyline. (inherited from CADPolylineBase).
Public property | Rotate | Gets or sets a rotation angle of the referenced raster image when inserting it into the CAD drawing.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Size | Gets or sets scale vector. (inherited from CADWipeout).
Public property | Transparency | Gets or sets a value indicating whether the CADImageEnt is transparent.
Public property | TransparentColor | Gets or sets transparent color.
Public property | UVector | Gets or sets UVector. (inherited from CADWipeout).
Public property | VVector | Gets or sets VVector. (inherited from CADWipeout).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a width of the wipeout. (inherited from CADWipeout).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddPoint | Adds a point with x,y coordinates into the clip points. (inherited from CADWipeout).
Public method | AddPt | Performs an addition of coordinates of two points.
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | ApplyBox | Calculates a box of the current entity.
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Used in drawing cycle for fast checking whether the entity must be drawn
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADImageEnt object to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetImage | Sets an image referenced by this CADImageEnt object to the specified image.
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADImageEnt Class


CADImageEnt Constructor

Example See Also

Initializes a new instance of the CADImageEnt class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADImageEnt()
This language is not supported or no code example is available.
Example
<p>Creating a new CADImageEnt object example:</p> <p>[C#]</p>
Copy

     CreateNewImage();
     Point p1 = new Point(100, 100);
     Point p2 = new Point(300, 300);
     Rectangle r1 = CADConst.SetNewRect(p1, p2);
     DPoint pt1 = GetRealPoint(r1.X, r1.Y);
     DPoint pt2 = GetRealPoint(r1.Right, r1.Bottom);
     CADImageEnt imgEnt = new CADImageEnt();
     string path = @"http://www.cadsofttools.com/en/templates/moveax/images/01.gif";
     Bitmap bmpTmp = null;
     Stream tmpStream;
     try
     {
         tmpStream = CADConst.LoadDataFromWeb(path);
         bmpTmp = new Bitmap(tmpStream);
         tmpStream.Close();
     }
     catch
     {
         //error load file from web
         return;
     }
     imgEnt.SetImage(bmpTmp);
     imgEnt.Color = CADConst.clNone;
     imgEnt.Point = new DPoint(pt1.X, pt1.Y, 0);
     imgEnt.Point1 = new DPoint(Math.Abs(pt2.X - pt1.X), -Math.Abs(pt2.Y - pt1.Y), 0);
     imgEnt.Point2 = new DPoint(1.0, 1.0, 0.0);
     imgEnt.Point3 = new DPoint(1.0, 1.0, 0.0);
     imgEnt.Rotate = 0.0;
     imgEnt.LineWeight = 0.1;
     imgEnt.Layer = (CADLayer)cadImage.Converter.Layers[0];
     imgEnt.Loaded(cadImage.Converter);
     imgEnt.Point2 = new DPoint(0.0, 0.0, 0.0);
     imgEnt.Rotate = 0.0;
     imgEnt.Handle = imgEnt.GetHashCode();
     imgEnt.KeyEnt = imgEnt.Handle.ToString();
     cadImage.Converter.OnCreate(imgEnt);
     cadImage.CurrentLayout.Entities.Add(imgEnt);
     EditorCADPictureBox.Invalidate();
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageEnt Class
CADImageEnt Members
CADImport Namespace
CADImage
CADImageEnt
DPoint
clNone


CADImageEnt Properties

CADImageEnt Class See Also

The following tables list the members exposed by the CADImageEnt type.

Properties
 | Name | Description
Public property | Box | Return box of the current primitive. (inherited from CADPolylineBase).
Public property | ClipPoints | Gets or sets a collection of the clipping points. (inherited from CADWipeout).
Public property | ClippingBoundaryType | Gets or sets a type of the clipping boundary of the current wipeout. (inherited from CADWipeout).
Public property | Closed | Gets or sets a value indicating whether this CADPolyLine is closed. (inherited from CADPolylineBase).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADPolylineBase. (inherited from CADPolylineBase).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | DottedSingPoints | Gets a collection of points that specify the dots and dashes of the CADPolylineBase. (inherited from CADPolylineBase).
Public property | EntName | Gets a name of the CADImageEnt object.
Public property | EntType | Gets the type of this CADImageEnt entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Flags | Gets or sets a number that specifies an appearance of this CADPolylineBase entity. (inherited from CADPolylineBase).
Public property | FlagsEx | Gets or sets a flags for drawing a CADImageEnt.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Height | Gets or sets a height of this wipeout. (inherited from CADWipeout).
Public property | ImageDef | Gets or sets a raster image in the CAD drawing.
Public property | IsMeshMClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the M direction. (inherited from CADPolylineBase).
Public property | IsMeshNClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the N direction. (inherited from CADPolylineBase).
Public property | IsMonoChrome | Gets or sets a value indicating whether the referenced raster image is monochrome.
Public property | IsPolyFaceMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | IsPolyZThickness | Gets a value indicating whether a line thickness measured along the axis Z is equal to 0. (inherited from CADPolylineBase).
Public property | IsPolygonMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | IsUseClipping | Indicates whether the clipping is used. (inherited from CADWipeout).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Picture | Gets an image referenced by this CADImageEnt object.
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADPenLine).
Public property | Point1 | This proprty is obsolete. We recommend to use UVector instead of it.
Public property | Point2 | This proprty is obsolete. We recommend to use VVector instead of it.
Public property | Point3 | This proprty is obsolete. We recommend to use Size instead of it.
Public property | PolyPoints | Gets a collection of points belonging to the polyline. (inherited from CADPolylineBase).
Public property | Rotate | Gets or sets a rotation angle of the referenced raster image when inserting it into the CAD drawing.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Size | Gets or sets scale vector. (inherited from CADWipeout).
Public property | Transparency | Gets or sets a value indicating whether the CADImageEnt is transparent.
Public property | TransparentColor | Gets or sets transparent color.
Public property | UVector | Gets or sets UVector. (inherited from CADWipeout).
Public property | VVector | Gets or sets VVector. (inherited from CADWipeout).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a width of the wipeout. (inherited from CADWipeout).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
See Also

Reference

CADImageEnt Class


CADWipeout.ClipPoints Property

Gets or sets a collection of the clipping points.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ClipPoints() As CADCollection(Of DPoint)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection<DPoint> ClipPoints {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADWipeout Class
CADWipeout Members


CADWipeout.ClippingBoundaryType Property

Gets or sets a type of the clipping boundary of the current wipeout.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ClippingBoundaryType() As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte ClippingBoundaryType {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADWipeout Class
CADWipeout Members


CADImageEnt.EntName Property

Gets a name of the CADImageEnt object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override string EntName {get;}
This language is not supported or no code example is available.

Property Value

A string containing a name of the CADImageEnt object.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageEnt Class
CADImageEnt Members


CADImageEnt.EntType Property

Gets the type of this CADImageEnt entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageEnt Class
CADImageEnt Members


CADImageEnt.FlagsEx Property

Gets or sets a flags for drawing a CADImageEnt.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property FlagsEx() As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte FlagsEx {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageEnt Class
CADImageEnt Members


CADWipeout.Height Property

Gets or sets a height of this wipeout.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Height() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Height {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADWipeout Class
CADWipeout Members


CADImageEnt.ImageDef Property

Gets or sets a raster image in the CAD drawing.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ImageDef() As CADImageDef
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADImageDef ImageDef {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageEnt Class
CADImageEnt Members


CADImageEnt.IsMonoChrome Property

Gets or sets a value indicating whether the referenced raster image is monochrome.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property IsMonoChrome() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsMonoChrome {get; set;}
This language is not supported or no code example is available.

Property Value

true if the referenced raster image is monochrome; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageEnt Class
CADImageEnt Members


CADWipeout.IsUseClipping Property

Indicates whether the clipping is used.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property IsUseClipping() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsUseClipping {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADWipeout Class
CADWipeout Members


CADImageEnt.Picture Property

Gets an image referenced by this CADImageEnt object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Picture() As Image
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Image Picture {get;}
This language is not supported or no code example is available.

Property Value

A Image object representing a referenced raster image.
Remarks

A referenced raster image in the CAD drawing is represented by the CADImageDef object.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageEnt Class
CADImageEnt Members


CADImageEnt.Point1 Property

This proprty is obsolete. We recommend to use UVector instead of it.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Point1() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Point1 {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageEnt Class
CADImageEnt Members


CADImageEnt.Point2 Property

This proprty is obsolete. We recommend to use VVector instead of it.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Point2() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Point2 {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageEnt Class
CADImageEnt Members


CADImageEnt.Point3 Property

This proprty is obsolete. We recommend to use Size instead of it.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Point3() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Point3 {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageEnt Class
CADImageEnt Members


CADImageEnt.Rotate Property

Gets or sets a rotation angle of the referenced raster image when inserting it into the CAD drawing.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Rotate() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Rotate {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageEnt Class
CADImageEnt Members


CADWipeout.Size Property

Gets or sets scale vector.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Size() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Size {get; set;}
This language is not supported or no code example is available.
Remarks

Each component of this vector represents a scale of the current wipeout along corresponding direction.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADWipeout Class
CADWipeout Members


CADImageEnt.Transparency Property

Gets or sets a value indicating whether the CADImageEnt is transparent.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Transparency() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Transparency {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageEnt Class
CADImageEnt Members


CADImageEnt.TransparentColor Property

Gets or sets transparent color.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TransparentColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Color TransparentColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageEnt Class
CADImageEnt Members


CADWipeout.UVector Property

Gets or sets UVector.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property UVector() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint UVector {get; set;}
This language is not supported or no code example is available.
Remarks

This vector represent a width of the current wipeout along given direction.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADWipeout Class
CADWipeout Members


CADWipeout.VVector Property

Gets or sets VVector.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property VVector() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint VVector {get; set;}
This language is not supported or no code example is available.
Remarks

This vector represent a height of the current wipeout along given direction.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADWipeout Class
CADWipeout Members


CADWipeout.Width Property

Gets or sets a width of the wipeout.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shadows Property Width() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
new public double Width {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADWipeout Class
CADWipeout Members


CADImageEnt Methods

CADImageEnt Class See Also

The following tables list the members exposed by the CADImageEnt type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddPoint | Adds a point with x,y coordinates into the clip points. (inherited from CADWipeout).
Public method | AddPt | Performs an addition of coordinates of two points.
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | ApplyBox | Calculates a box of the current entity.
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Used in drawing cycle for fast checking whether the entity must be drawn
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADImageEnt object to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetImage | Sets an image referenced by this CADImageEnt object to the specified image.
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADImageEnt Class


CADWipeout.AddPoint Method

Adds a point with x,y coordinates into the clip points.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddPoint( _
   ByVal x As Double, _
   ByVal y As Double _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddPoint(
   double x,
   double y
)
This language is not supported or no code example is available.

Parameters

x

Type: double

x coordinate

y

Type: double

y coordinate

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADWipeout Class
CADWipeout Members


CADImageEnt.AddPt Method

Performs an addition of coordinates of two points.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddPt( _
   ByVal Src As DPoint, _
   ByRef Dst As DPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddPt(
   DPoint Src,
   ref DPoint Dst
)
This language is not supported or no code example is available.

Parameters

Src

Type: DPoint

A DPoint object representing a first point to add.

Dst

Type: DPoint

A DPoint object representing a second point to add. The summarized coordinates will be assigned to this point.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageEnt Class
CADImageEnt Members


CADImageEnt.ApplyBox Method

Calculates a box of the current entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub ApplyBox()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void ApplyBox()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageEnt Class
CADImageEnt Members


CADImageEnt.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageEnt Class
CADImageEnt Members


CADImageEnt.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageEnt Class
CADImageEnt Members


CADImageEnt.DrawEntityTrace Method

Implements drawing of entity with specified offset to specified Control

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub DrawEntityTrace( _
   ByVal dx As Integer, _
   ByVal dy As Integer, _
   ByVal img As CADImage, _
   ByVal control As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void DrawEntityTrace(
   int dx,
   int dy,
   CADImage img,
   Control control
)
This language is not supported or no code example is available.

Parameters

dx

Type: int

X axis offset

dy

Type: int

Y axis offset

img

Type: CADImage

CADImage object for getting display coordinates of the entity

control

Type: Control

Control for drawing of CADEntity

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageEnt Class
CADImageEnt Members


CADImageEnt.GetBoxPoints Method

Used in drawing cycle for fast checking whether the entity must be drawn

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function GetBoxPoints( _
   ByVal func As FPointProc, _
   ByVal full As Boolean _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool GetBoxPoints(
   FPointProc func,
   bool full
)
This language is not supported or no code example is available.

Parameters

func

Type: FPointProc

full

Type: bool

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageEnt Class
CADImageEnt Members


CADImageEnt.Loaded Method

Loads this CADImageEnt object to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADImageEnt object is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageEnt Class
CADImageEnt Members


CADImageEnt.SetImage Method

Sets an image referenced by this CADImageEnt object to the specified image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetImage( _
   ByVal image As Image _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetImage(
   Image image
)
This language is not supported or no code example is available.

Parameters

image

Type: Image

An Image object that will be set as image referenced by this CADImageEnt instance.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImageEnt Class
CADImageEnt Members


CADImageEnt Fields

CADImageEnt Class See Also

The following tables list the members exposed by the CADImageEnt type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADImageEnt Class


CADInsert Class

Members See Also

Represents a block reference in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADInsert
    Inherits CADCustomVertex
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADInsert : CADCustomVertex
This language is not supported or no code example is available.
Remarks

A CADInsert references a block stored in the current CAD drawing. A CAD drawing can have many inserts for one block.

Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADCustomVertex
CADImport.CADInsert
CADImport.CADAcadTable
CADImport.CADDimension
CADImport.CADMInsert
CADImport.CADMLine
CADImport.CADMText
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADInsert Members


CADInsert Members

CADInsert Class Constructors Methods Fields Properties See Also

Represents a block reference in a CAD image.

The following tables list the members exposed by the CADInsert type.

Constructors
 | Name | Description
Public constructor | CADInsert | Initializes a new instance of the CADInsert class.
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets an angle between a referenced block and CAD drawing.
Public property | Attribs | Gets a collection of an attribs.
Public property | Block | Gets or sets a block referenced by this CADInsert object.
Public property | Box | Gets a three-dimensional box that encloses the CADInsert object.
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of attribs belonging to the given CADInsert.
Public property | EntName | Gets a name of the CADInsert object.
Public property | EntType | Gets the type of this CADInsert entity.
Public property | Entities | Gets a collection of attribs associated with the given CADInsert object.
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADInsert object.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object.
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADInsert.
Public property | Point | Gets or sets a position of the CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Scale | Gets or sets a scale for drawning of the referenced block in a CAD image.
Public property | Selected | Get or sets CADInsert selected.
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADInsert object.
Public method | AssignEntity | Copies an entity
Public method | Attrib | Returns an attribute contained in the given CADInsert object.
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADInsert to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADInsert entity.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADInsert Class


CADInsert Properties

CADInsert Class See Also

The following tables list the members exposed by the CADInsert type.

Properties
 | Name | Description
Public property | Angle | Gets or sets an angle between a referenced block and CAD drawing.
Public property | Attribs | Gets a collection of an attribs.
Public property | Block | Gets or sets a block referenced by this CADInsert object.
Public property | Box | Gets a three-dimensional box that encloses the CADInsert object.
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of attribs belonging to the given CADInsert.
Public property | EntName | Gets a name of the CADInsert object.
Public property | EntType | Gets the type of this CADInsert entity.
Public property | Entities | Gets a collection of attribs associated with the given CADInsert object.
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADInsert object.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object.
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADInsert.
Public property | Point | Gets or sets a position of the CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Scale | Gets or sets a scale for drawning of the referenced block in a CAD image.
Public property | Selected | Get or sets CADInsert selected.
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
See Also

Reference

CADInsert Class


CADInsert.EntType Property

Gets the type of this CADInsert entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADInsert Class
CADInsert Members


CADInsert Methods

CADInsert Class See Also

The following tables list the members exposed by the CADInsert type.

Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADInsert object.
Public method | AssignEntity | Copies an entity
Public method | Attrib | Returns an attribute contained in the given CADInsert object.
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADInsert to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADInsert entity.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADInsert Class


CADInsert.Loaded Method

Loads this CADInsert to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADInsert object is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADInsert Class
CADInsert Members


CADInsert Fields

CADInsert Class See Also

The following tables list the members exposed by the CADInsert type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADInsert Class


CADIterate Class

Members See Also

Provides a set of data for each CAD entity to be processed by the Iterate method.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADIterate
    Implements ICloneable, _
               IDisposable
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADIterate : ICloneable,
   IDisposable
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADIterate
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADIterate Members


CADIterate Members

CADIterate Class Constructors Methods Fields See Also

Provides a set of data for each CAD entity to be processed by the Iterate method.

The following tables list the members exposed by the CADIterate type.

Constructors
 | Name | Description
Public constructor | CADIterate | Initializes a new instance of the CADIterate class.
Top
Methods
 | Name | Description
Public method | Clone | Creates an exact copy of this CADIterate object.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | additional | Represents a user-defined value.
Public field | angle | A rotation angle of a CAD entity.
Public field | color | Represents the current block color or clNone.
Public field | convertor | Represents the previous convertor (can be null).
Public field | insert | Represents the current block reference (can be null).
Public field | matrix | Represents a coordinate transformation matrix.
Public field | xScale | A CAD entity scale along the X axis.
Public field | yScale | A CAD entity scale along the Y axis.
Top
See Also

Reference

CADIterate Class


CADIterate Constructor

Initializes a new instance of the CADIterate class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADIterate()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADIterate Class
CADIterate Members


CADIterate Methods

CADIterate Class See Also

The following tables list the members exposed by the CADIterate type.

Methods
 | Name | Description
Public method | Clone | Creates an exact copy of this CADIterate object.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADIterate Class


CADIterate.Clone Method

Creates an exact copy of this CADIterate object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Clone() As Object Implements  _
   ICloneable.Clone
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public object Clone()
This language is not supported or no code example is available.

Return Value

An object of the CADIterate class.

Implements

ICloneable.Clone
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADIterate Class
CADIterate Members


CADIterate.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Dispose() Implements  _
   IDisposable.Dispose
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Dispose()
This language is not supported or no code example is available.

Implements

IDisposable.Dispose
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADIterate Class
CADIterate Members


CADIterate Fields

CADIterate Class See Also

The following tables list the members exposed by the CADIterate type.

Fields
 | Name | Description
Public field | additional | Represents a user-defined value.
Public field | angle | A rotation angle of a CAD entity.
Public field | color | Represents the current block color or clNone.
Public field | convertor | Represents the previous convertor (can be null).
Public field | insert | Represents the current block reference (can be null).
Public field | matrix | Represents a coordinate transformation matrix.
Public field | xScale | A CAD entity scale along the X axis.
Public field | yScale | A CAD entity scale along the Y axis.
Top
See Also

Reference

CADIterate Class


additional Field

Represents a user-defined value.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public additional As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int additional
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADIterate Class
CADIterate Members


angle Field

A rotation angle of a CAD entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public angle As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float angle
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADIterate Class
CADIterate Members


color Field

Represents the current block color or clNone.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public color As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Color color
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADIterate Class
CADIterate Members


convertor Field

Represents the previous convertor (can be null).

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public convertor As CADConverter
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADConverter convertor
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADIterate Class
CADIterate Members


insert Field

Represents the current block reference (can be null).

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public insert As CADInsert
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADInsert insert
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADIterate Class
CADIterate Members


matrix Field

Represents a coordinate transformation matrix.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public matrix As CADMatrix
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADMatrix matrix
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADIterate Class
CADIterate Members


xScale Field

A CAD entity scale along the X axis.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public xScale As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float xScale
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADIterate Class
CADIterate Members


yScale Field

A CAD entity scale along the Y axis.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public yScale As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float yScale
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADIterate Class
CADIterate Members


CADLWPolyLine Class

Members See Also

Represents a planar polyline.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADLWPolyLine
    Inherits CADPolyLine
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADLWPolyLine : CADPolyLine
This language is not supported or no code example is available.
Remarks

All parts of the CADLWPolyLine lie in the same plane.

Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.CADPenLine
CADImport.CADPolylineBase
CADImport.CADPolyLine
CADImport.CADLWPolyLine
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLWPolyLine Members


CADLWPolyLine Members

CADLWPolyLine Class Constructors Methods Fields Properties See Also

Represents a planar polyline.

The following tables list the members exposed by the CADLWPolyLine type.

Constructors
 | Name | Description
Public constructor | CADLWPolyLine | Initializes a new instance of the CADPolyLine class. (inherited from CADPolyLine).
Top
Properties
 | Name | Description
Public property | Arrows | Gets or sets a collection of points that specify an arrow shape for the CADPolyLine segments. (inherited from CADPolyLine).
Public property | Box | Gets or sets a three-dimensional box that encloses the CADPolyLine. (inherited from CADPolyLine).
Public property | Closed | Gets or sets a value indicating whether this CADPolyLine is closed. (inherited from CADPolylineBase).
Public property | Color | Gets or sets a color for the given CADPolyLine entity. (inherited from CADPolyLine).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the specified CADPolyLine object. (inherited from CADPolyLine).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | DottedSingPoints | Gets a collection of points that specify the dots and dashes of the CADPolylineBase. (inherited from CADPolylineBase).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADLWPolyLine entity.
Public property | Entities | Gets a collection of CAD entities belonging to the given CADPolyLine. (inherited from CADPolyLine).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Flags | Gets or sets a number that specifies an appearance of this CADPolylineBase entity. (inherited from CADPolylineBase).
Public property | GlobalWidth | Gets or sets a width for all parts of the CADPolyLine. (inherited from CADPolyLine).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | IsMeshMClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the M direction. (inherited from CADPolylineBase).
Public property | IsMeshNClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the N direction. (inherited from CADPolylineBase).
Public property | IsPlinegen | (inherited from CADPolyLine).
Public property | IsPolyFaceMesh | Gets a value indicating whether this CADPolyLine represents a polyface mesh. (inherited from CADPolyLine).
Public property | IsPolyZThickness | Gets a value indicating whether a line thickness measured along the axis Z is equal to 0. (inherited from CADPolylineBase).
Public property | IsPolygonMesh | Gets a value indicating whether this CADPolyLine represents a polygon mesh. (inherited from CADPolyLine).
Public property | Layer | Gets or sets a layer containing this CADPolyLine. (inherited from CADPolyLine).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of the lines for this CADPolyLine. (inherited from CADPolyLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | MeshM | Gets or sets a number of vertices traversed in a polygon mesh in M direction. (inherited from CADPolyLine).
Public property | MeshN | Gets or sets a number of vertices traversed in a polygon mesh in N direction. (inherited from CADPolyLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADPenLine).
Public property | PolyFaceVertexIndexes | Gets a list of indices specifying an order of traversing vertices of this polyface mesh. (inherited from CADPolyLine).
Public property | PolyLineEntities | Gets a collection of entities included in this CADPolyLine. (inherited from CADPolyLine).
Public property | PolyPoints | Gets a collection of points belonging to the polyline. (inherited from CADPolylineBase).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Vertexes | Gets a collection of vertices of this CADPolyLine. (inherited from CADPolyLine).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADPolyLine. (inherited from CADPolyLine).
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | ApplyBox | Calculates a box of the current entity. (inherited from CADPolyLine).
Public method | AssignEntity | Copies an entity (inherited from CADPolyLine).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADPolyLine).
Public method | DrawEntityTrace | Implements drawing of an entity with specified offset to specified Control (inherited from CADPolyLine).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Used in drawing cycle for fast checking whether the entity must be drawn (inherited from CADPolylineBase).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADPolylineBase to the specified CADConverter. (inherited from CADPolylineBase).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADLWPolyLine Class


CADPolyLine Constructor

Example See Also

Initializes a new instance of the CADPolyLine class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADPolyLine()
This language is not supported or no code example is available.
Example
<p>Creating a new CADPolyLine object example:</p> <p>[C#]</p>
Copy

     CreateNewImage();
     CADPolyLine poly = new CADPolyLine();
     poly.Color = CADConst.clNone;
     CADVertex vert;
     int i = 0;
     while(i != 11)
     {
         vert = new CADVertex();
         vert.Point = GetRealPoint(100 + i*20, 100 + (i%2)*20);
         poly.Entities.Add(vert);
         i++;
     }
     poly.LineWeight = 0.1;
     poly.Loaded(cadImage.Converter);
     poly.Handle = poly.GetHashCode();
     poly.KeyEnt = poly.Handle.ToString();
     cadImage.Converter.Loads(poly);
     cadImage.Converter.OnCreate(poly);
     cadImage.CurrentLayout.Entities.Add(poly);
     EditorCADPictureBox.Invalidate();
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyLine Class
CADPolyLine Members
CADImport Namespace
CADImage
CADPolyLine
DPoint
GetRealPoint
clNone


CADLWPolyLine Properties

CADLWPolyLine Class See Also

The following tables list the members exposed by the CADLWPolyLine type.

Properties
 | Name | Description
Public property | Arrows | Gets or sets a collection of points that specify an arrow shape for the CADPolyLine segments. (inherited from CADPolyLine).
Public property | Box | Gets or sets a three-dimensional box that encloses the CADPolyLine. (inherited from CADPolyLine).
Public property | Closed | Gets or sets a value indicating whether this CADPolyLine is closed. (inherited from CADPolylineBase).
Public property | Color | Gets or sets a color for the given CADPolyLine entity. (inherited from CADPolyLine).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the specified CADPolyLine object. (inherited from CADPolyLine).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | DottedSingPoints | Gets a collection of points that specify the dots and dashes of the CADPolylineBase. (inherited from CADPolylineBase).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADLWPolyLine entity.
Public property | Entities | Gets a collection of CAD entities belonging to the given CADPolyLine. (inherited from CADPolyLine).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Flags | Gets or sets a number that specifies an appearance of this CADPolylineBase entity. (inherited from CADPolylineBase).
Public property | GlobalWidth | Gets or sets a width for all parts of the CADPolyLine. (inherited from CADPolyLine).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | IsMeshMClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the M direction. (inherited from CADPolylineBase).
Public property | IsMeshNClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the N direction. (inherited from CADPolylineBase).
Public property | IsPlinegen | (inherited from CADPolyLine).
Public property | IsPolyFaceMesh | Gets a value indicating whether this CADPolyLine represents a polyface mesh. (inherited from CADPolyLine).
Public property | IsPolyZThickness | Gets a value indicating whether a line thickness measured along the axis Z is equal to 0. (inherited from CADPolylineBase).
Public property | IsPolygonMesh | Gets a value indicating whether this CADPolyLine represents a polygon mesh. (inherited from CADPolyLine).
Public property | Layer | Gets or sets a layer containing this CADPolyLine. (inherited from CADPolyLine).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of the lines for this CADPolyLine. (inherited from CADPolyLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | MeshM | Gets or sets a number of vertices traversed in a polygon mesh in M direction. (inherited from CADPolyLine).
Public property | MeshN | Gets or sets a number of vertices traversed in a polygon mesh in N direction. (inherited from CADPolyLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADPenLine).
Public property | PolyFaceVertexIndexes | Gets a list of indices specifying an order of traversing vertices of this polyface mesh. (inherited from CADPolyLine).
Public property | PolyLineEntities | Gets a collection of entities included in this CADPolyLine. (inherited from CADPolyLine).
Public property | PolyPoints | Gets a collection of points belonging to the polyline. (inherited from CADPolylineBase).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Vertexes | Gets a collection of vertices of this CADPolyLine. (inherited from CADPolyLine).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
See Also

Reference

CADLWPolyLine Class


CADPolyLine.Arrows Property

Gets or sets a collection of points that specify an arrow shape for the CADPolyLine segments.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Arrows() As CADCollection(Of DPoint)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection<DPoint> Arrows {get; set;}
This language is not supported or no code example is available.

Property Value

A CADPolyLine containing a points that specifies an arrow shape for the polyline segments.
Remarks

Each arrow shape is specified by four points: two at the base of arrow head and two at the end of arrow head.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyLine Class
CADPolyLine Members


CADPolyLine.Box Property

Gets or sets a three-dimensional box that encloses the CADPolyLine.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Box() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override DRect Box {get; set;}
This language is not supported or no code example is available.

Property Value

A DRect object representing the enclosing box for the CADEntity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyLine Class
CADPolyLine Members


CADPolyLine.Color Property

Gets or sets a color for the given CADPolyLine entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Color() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override Color Color {get; set;}
This language is not supported or no code example is available.

Property Value

A Color of the polyline.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyLine Class
CADPolyLine Members


CADPolyLine.Count Property

Gets a number of entities contained in the specified CADPolyLine object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Count() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override int Count {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyLine Class
CADPolyLine Members


CADLWPolyLine.EntType Property

Gets the type of this CADLWPolyLine entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLWPolyLine Class
CADLWPolyLine Members


CADPolyLine.Entities Property

Gets a collection of CAD entities belonging to the given CADPolyLine.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Entities() As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override CADEntityCollection Entities {get;}
This language is not supported or no code example is available.

Property Value

A CADEntityCollection containing CAD entities belonging to the given CADPolyLine.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyLine Class
CADPolyLine Members


CADPolyLine.GlobalWidth Property

Gets or sets a width for all parts of the CADPolyLine.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property GlobalWidth() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float GlobalWidth {get; set;}
This language is not supported or no code example is available.
Remarks

If this property returns a value greater than zero, all points specifying an arrow shape coincide with the sides of the polyline (an arrow shapes for all parts of the polyline is disappear).

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyLine Class
CADPolyLine Members


CADPolyLine.IsPlinegen Property

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property IsPlinegen() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsPlinegen {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyLine Class
CADPolyLine Members


CADPolyLine.IsPolyFaceMesh Property

Gets a value indicating whether this CADPolyLine represents a polyface mesh.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property IsPolyFaceMesh() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool IsPolyFaceMesh {get;}
This language is not supported or no code example is available.

Property Value

true if this CADPolyLine is a polyface mesh; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyLine Class
CADPolyLine Members


CADPolyLine.IsPolygonMesh Property

Gets a value indicating whether this CADPolyLine represents a polygon mesh.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property IsPolygonMesh() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool IsPolygonMesh {get;}
This language is not supported or no code example is available.

Property Value

true if this CADPolyLine is a polygon mesh; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyLine Class
CADPolyLine Members


CADPolyLine.Layer Property

Gets or sets a layer containing this CADPolyLine.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Layer() As CADLayer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override CADLayer Layer {get; set;}
This language is not supported or no code example is available.

Property Value

A CADLayer containing this CADPolyLine.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyLine Class
CADPolyLine Members


CADPolyLine.LineWeight Property

Gets or sets a thickness of the lines for this CADPolyLine.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property LineWeight() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override double LineWeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyLine Class
CADPolyLine Members


CADPolyLine.MeshM Property

Gets or sets a number of vertices traversed in a polygon mesh in M direction.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property MeshM() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int MeshM {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyLine Class
CADPolyLine Members


CADPolyLine.MeshN Property

Gets or sets a number of vertices traversed in a polygon mesh in N direction.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property MeshN() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int MeshN {get; set;}
This language is not supported or no code example is available.
Remarks

A number returned by this property represents a quantity of vertices contained on each of M levels.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyLine Class
CADPolyLine Members


CADPolyLine.PolyFaceVertexIndexes Property

Gets a list of indices specifying an order of traversing vertices of this polyface mesh.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property PolyFaceVertexIndexes() As List(Of Integer)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public List<int> PolyFaceVertexIndexes {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyLine Class
CADPolyLine Members


CADPolyLine.PolyLineEntities Property

Gets a collection of entities included in this CADPolyLine.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property PolyLineEntities() As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntityCollection PolyLineEntities {get;}
This language is not supported or no code example is available.

Property Value

A CADEntityCollection object representing a collection of entities included in this CADPolyLine.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyLine Class
CADPolyLine Members


CADPolyLine.Vertexes Property

Gets a collection of vertices of this CADPolyLine.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Vertexes() As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntityCollection Vertexes {get;}
This language is not supported or no code example is available.

Property Value

A CADEntityCollection of vertices belonging to the polyline.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyLine Class
CADPolyLine Members


CADLWPolyLine Methods

CADLWPolyLine Class See Also

The following tables list the members exposed by the CADLWPolyLine type.

Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADPolyLine. (inherited from CADPolyLine).
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | ApplyBox | Calculates a box of the current entity. (inherited from CADPolyLine).
Public method | AssignEntity | Copies an entity (inherited from CADPolyLine).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADPolyLine).
Public method | DrawEntityTrace | Implements drawing of an entity with specified offset to specified Control (inherited from CADPolyLine).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Used in drawing cycle for fast checking whether the entity must be drawn (inherited from CADPolylineBase).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADPolylineBase to the specified CADConverter. (inherited from CADPolylineBase).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADLWPolyLine Class


CADPolyLine.AddEntity Method

Adds the specified entity to this CADPolyLine.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function AddEntity( _
   ByVal E As CADEntity _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool AddEntity(
   CADEntity E
)
This language is not supported or no code example is available.

Parameters

E

Type: CADEntity

A CADEntity to add.

Return Value

true if a CADEntity was added; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyLine Class
CADPolyLine Members


CADPolyLine.ApplyBox Method

Calculates a box of the current entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub ApplyBox()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void ApplyBox()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyLine Class
CADPolyLine Members


CADPolyLine.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyLine Class
CADPolyLine Members


CADPolyLine.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyLine Class
CADPolyLine Members


CADPolyLine.DrawEntityTrace Method

Implements drawing of an entity with specified offset to specified Control

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub DrawEntityTrace( _
   ByVal dx As Integer, _
   ByVal dy As Integer, _
   ByVal img As CADImage, _
   ByVal control As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void DrawEntityTrace(
   int dx,
   int dy,
   CADImage img,
   Control control
)
This language is not supported or no code example is available.

Parameters

dx

Type: int

X axis offset

dy

Type: int

Y axis offset

img

Type: CADImage

CADImage object for getting display coordinates of the entity

control

Type: Control

Control for drawing of Entity

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyLine Class
CADPolyLine Members


CADPolylineBase.Loaded Method

Loads this CADPolylineBase to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADPolylineBase is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolylineBase Class
CADPolylineBase Members


CADLWPolyLine Fields

CADLWPolyLine Class See Also

The following tables list the members exposed by the CADLWPolyLine type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADLWPolyLine Class


CADLayer Class

Members See Also

Represents a layer in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADLayer
    Inherits CADPenTableItem
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADLayer : CADPenTableItem
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.CADPenTableItem
CADImport.CADLayer
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayer Members


CADLayer Members

CADLayer Class Constructors Methods Fields Properties See Also

Represents a layer in a CAD image.

The following tables list the members exposed by the CADLayer type.

Constructors
 | Name | Description
Public constructor | CADLayer | Initializes a new instance of the CADLayer class.
Top
Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | EntName | Gets a name of this CADPenTableItem. (inherited from CADPenTableItem).
Public property | EntType | Gets the type of this CADLayer entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Flags | Gets or sets a drawing flags. (inherited from CADPenTableItem).
Public property | Frozen | Gets or sets a value indicating whether a CADLayer is frozen.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | IsPlotting | Gets or sets a value indicating whether this layer's contents can be plotted.
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type
Public property | LineTypeName | Gets line type name
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADLayer.
Public property | Lines | Gets or sets a type of the line used on this layer.
Public property | Locked |
Public property | Name | Gets or sets a name of the CADPenTableItem. (inherited from CADPenTableItem).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADLayer is visible.
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADLayer to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADLayer entity.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADLayer Class


CADLayer Constructor

Initializes a new instance of the CADLayer class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADLayer()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayer Class
CADLayer Members


CADLayer Properties

CADLayer Class See Also

The following tables list the members exposed by the CADLayer type.

Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | EntName | Gets a name of this CADPenTableItem. (inherited from CADPenTableItem).
Public property | EntType | Gets the type of this CADLayer entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Flags | Gets or sets a drawing flags. (inherited from CADPenTableItem).
Public property | Frozen | Gets or sets a value indicating whether a CADLayer is frozen.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | IsPlotting | Gets or sets a value indicating whether this layer's contents can be plotted.
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type
Public property | LineTypeName | Gets line type name
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADLayer.
Public property | Lines | Gets or sets a type of the line used on this layer.
Public property | Locked |
Public property | Name | Gets or sets a name of the CADPenTableItem. (inherited from CADPenTableItem).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADLayer is visible.
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Top
See Also

Reference

CADLayer Class


CADLayer.EntType Property

Gets the type of this CADLayer entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayer Class
CADLayer Members


CADLayer.Frozen Property

Gets or sets a value indicating whether a CADLayer is frozen.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Frozen() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Frozen {get; set;}
This language is not supported or no code example is available.

Property Value

true if a CADLayer is frozen; otherwise, false.
Remarks

If a layer is frozen all CAD entities it contains will be invisible even if it has inserts of blocks belonging to visible layers.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayer Class
CADLayer Members


CADLayer.IsPlotting Property

Gets or sets a value indicating whether this layer's contents can be plotted.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property IsPlotting() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsPlotting {get; set;}
This language is not supported or no code example is available.

Property Value

true if this layer's contents can be plotted; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayer Class
CADLayer Members


CADLayer.LineType Property

Gets or sets line type

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property LineType() As CADLineType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override CADLineType LineType {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayer Class
CADLayer Members


CADLayer.LineTypeName Property

Gets line type name

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property LineTypeName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string LineTypeName {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayer Class
CADLayer Members


CADLayer.LineWeight Property

Gets or sets a thickness of lines for this CADLayer.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property LineWeight() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override double LineWeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayer Class
CADLayer Members


CADLayer.Lines Property

Gets or sets a type of the line used on this layer.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Lines() As SGLines
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SGLines Lines {get;}
This language is not supported or no code example is available.

Property Value

An object of the sgLines class that specifies a type of the line.
Remarks

Obsolete. We recommend to use LineType property

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayer Class
CADLayer Members


CADLayer.Locked Property

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Locked() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Locked {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayer Class
CADLayer Members


CADLayer.Visible Property

Gets or sets a value indicating whether a CADLayer is visible.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Visible() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool Visible {get; set;}
This language is not supported or no code example is available.

Property Value

true if a CADLayer is visible; otherwise, false.
Remarks

If a layer is frozen or invisible the CAD entities it contains will also be invisible. If a layer is invisible but not frozen and it contains inserts of blocks belonging to visible layers then those blocks will be visible.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayer Class
CADLayer Members


CADLayer Methods

CADLayer Class See Also

The following tables list the members exposed by the CADLayer type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADLayer to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADLayer entity.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADLayer Class


CADLayer.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayer Class
CADLayer Members


CADLayer.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayer Class
CADLayer Members


CADLayer.Loaded Method

Loads this CADLayer to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADLayer is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayer Class
CADLayer Members


CADLayer.SetLType Method

Sets a linetype for the CADLayer entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub SetLType( _
   ByVal Value As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void SetLType(
   CADEntity Value
)
This language is not supported or no code example is available.

Parameters

Value

Type: CADEntity

A CADEntity object representing a linetype.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayer Class
CADLayer Members


CADLayer Fields

CADLayer Class See Also

The following tables list the members exposed by the CADLayer type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADLayer Class


CADLayout Class

Members See Also

Represents a layout of the CAD drawing.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADLayout
    Inherits CADPlotEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADLayout : CADPlotEntity
This language is not supported or no code example is available.
Remarks

A layout is used to compose a CAD drawing for plotting. It may include a title block, one or more viewports, and annotations.

Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADLayout
CADImport.HPGL2.HPGLLayout
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayout Members


CADLayout Members

CADLayout Class Constructors Methods Fields Properties See Also

Represents a layout of the CAD drawing.

The following tables list the members exposed by the CADLayout type.

Constructors
 | Name | Description
Public constructor | CADLayout | Initializes a new instance of the CADLayout class.
Top
Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADLayout object.
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities on this CADLayout.
Public property | EntName | Gets a name of the CADEntity.
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of entities contained in the loaded CAD image.
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | IsEmpty | Gets a value indicating whether this CADLayout is empty.
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Name | Gets or sets a name of the layout which read from a CAD file.
Public property | PSLTScalingByViewport | Gets or sets using PSLTSCALE value for the CADLayout.
Public property | PaperSpaceBlock | Gets or sets a block containing entities that will be drawn to a specified layout.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Adds a new child entity.
Public method | AssignEntity | Copies an entity (inherited from CADPlotEntity).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Iterate | Invokes the referenced (by the specified delegate) method for each CAD entity belonging to the specified CADLayout.
Public method | Loaded | Loads this CADLayout to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADLayout Class


CADLayout Constructor

Initializes a new instance of the CADLayout class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADLayout()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayout Class
CADLayout Members


CADLayout Properties

CADLayout Class See Also

The following tables list the members exposed by the CADLayout type.

Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADLayout object.
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities on this CADLayout.
Public property | EntName | Gets a name of the CADEntity.
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of entities contained in the loaded CAD image.
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | IsEmpty | Gets a value indicating whether this CADLayout is empty.
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Name | Gets or sets a name of the layout which read from a CAD file.
Public property | PSLTScalingByViewport | Gets or sets using PSLTSCALE value for the CADLayout.
Public property | PaperSpaceBlock | Gets or sets a block containing entities that will be drawn to a specified layout.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
See Also

Reference

CADLayout Class


CADLayout.Box Property

Gets or sets a three-dimensional box that encloses the CADLayout object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Box() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override DRect Box {get; set;}
This language is not supported or no code example is available.

Property Value

A DRect object representing the enclosing box for the CADLayout object.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayout Class
CADLayout Members


CADLayout.Count Property

Gets a number of entities on this CADLayout.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Count() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override int Count {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayout Class
CADLayout Members


CADLayout.EntName Property

Gets a name of the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override string EntName {get;}
This language is not supported or no code example is available.

Property Value

A string containing a name of the CADEntity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayout Class
CADLayout Members


CADLayout.Entities Property

Gets a collection of entities contained in the loaded CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Entities() As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override CADEntityCollection Entities {get;}
This language is not supported or no code example is available.

Property Value

A CADEntityCollection containing the entities in the loaded CAD image.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayout Class
CADLayout Members


CADLayout.IsEmpty Property

Gets a value indicating whether this CADLayout is empty.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property IsEmpty() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsEmpty {get;}
This language is not supported or no code example is available.

Property Value

true if this CADLayout doesn't contain any entities; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayout Class
CADLayout Members


CADLayout.Name Property

Gets or sets a name of the layout which read from a CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Name() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Name {get; set;}
This language is not supported or no code example is available.

Property Value

A string containing a layout name.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayout Class
CADLayout Members


CADLayout.PSLTScalingByViewport Property

Gets or sets using PSLTSCALE value for the CADLayout.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PSLTScalingByViewport() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool PSLTScalingByViewport {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayout Class
CADLayout Members


CADLayout.PaperSpaceBlock Property

Gets or sets a block containing entities that will be drawn to a specified layout.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PaperSpaceBlock() As CADBlock
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADBlock PaperSpaceBlock {get; set;}
This language is not supported or no code example is available.

Property Value

A CADBlock object that contains entities that will be drawn to a specified layout.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayout Class
CADLayout Members


CADLayout Methods

CADLayout Class See Also

The following tables list the members exposed by the CADLayout type.

Methods
 | Name | Description
Public method | AddEntity | Adds a new child entity.
Public method | AssignEntity | Copies an entity (inherited from CADPlotEntity).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Iterate | Invokes the referenced (by the specified delegate) method for each CAD entity belonging to the specified CADLayout.
Public method | Loaded | Loads this CADLayout to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADLayout Class


CADLayout.AddEntity Method

Adds a new child entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function AddEntity( _
   ByVal E As CADEntity _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool AddEntity(
   CADEntity E
)
This language is not supported or no code example is available.

Parameters

E

Type: CADEntity

Child entity

Return Value

Returns true if a child entity has been added.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayout Class
CADLayout Members


CADPlotEntity.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPlotEntity Class
CADPlotEntity Members


CADLayout.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayout Class
CADLayout Members


CADLayout.Iterate Method

Invokes the referenced (by the specified delegate) method for each CAD entity belonging to the specified CADLayout.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Iterate( _
   ByVal AConverter As CADConverter, _
   ByVal convProc As CADEntityProc, _
   ByVal Proc As CADEntityProc _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Iterate(
   CADConverter AConverter,
   CADEntityProc convProc,
   CADEntityProc Proc
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter that has loaded the CADLayout.

convProc

Type: CADEntityProc

Proc

Type: CADEntityProc

A CADEntityProc delegate that specifies a method to be invoked.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayout Class
CADLayout Members


CADLayout.Loaded Method

Loads this CADLayout to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADLayout is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayout Class
CADLayout Members


CADLayout Fields

CADLayout Class See Also

The following tables list the members exposed by the CADLayout type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADLayout Class


CADLayoutCollection Class

Members See Also

Represents a collection of CADLayout objects.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADLayoutCollection
    Inherits CADTable
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADLayoutCollection : CADTable
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADGroup
CADImport.CADTable
CADImport.CADLayoutCollection
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayoutCollection Members


CADLayoutCollection Members

CADLayoutCollection Class Constructors Methods Fields Properties See Also

Represents a collection of CADLayout objects.

The following tables list the members exposed by the CADLayoutCollection type.

Constructors
 | Name | Description
Public constructor | CADLayoutCollection | Initializes a new instance of the CADTable class. (inherited from CADTable).
Top
Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses this CADGroup. (inherited from CADGroup).
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the specified CADGroup. (inherited from CADGroup).
Public property | EntName | Gets a name of the CADTable. (inherited from CADTable).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of CAD entities belonging to the given CADGroup. (inherited from CADGroup).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Item | Gets or sets a CADLayout object at the specified index in the collection.
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | List | Gets a collection of entities included in the given CADGroup. (inherited from CADGroup).
Public property | Name | Gets or sets a CADTable name read from a CAD file. (inherited from CADTable).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Adds a CADLayout to this collection.
Public method | AssignEntity | Copies an entity (inherited from CADTable).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADTable).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Iterate | Invokes the referenced (by the specified delegate) method for each CAD entity belonging to the given CADGroup. (inherited from CADGroup).
Public method | Loaded | Loads this CADGroup to the specified CADConverter. (inherited from CADGroup).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RemoveEntityByName | Searches for an entity using its name then removes the entity. (inherited from CADTable).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADLayoutCollection Class


CADTable Constructor

Initializes a new instance of the CADTable class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADTable()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADTable Class
CADTable Members


CADLayoutCollection Properties

CADLayoutCollection Class See Also

The following tables list the members exposed by the CADLayoutCollection type.

Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses this CADGroup. (inherited from CADGroup).
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the specified CADGroup. (inherited from CADGroup).
Public property | EntName | Gets a name of the CADTable. (inherited from CADTable).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of CAD entities belonging to the given CADGroup. (inherited from CADGroup).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Item | Gets or sets a CADLayout object at the specified index in the collection.
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | List | Gets a collection of entities included in the given CADGroup. (inherited from CADGroup).
Public property | Name | Gets or sets a CADTable name read from a CAD file. (inherited from CADTable).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
See Also

Reference

CADLayoutCollection Class


CADTable.EntName Property

Gets a name of the CADTable.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override string EntName {get;}
This language is not supported or no code example is available.

Property Value

A string containing a name of the CADTable.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADTable Class
CADTable Members


CADLayoutCollection.Item Property

Gets or sets a CADLayout object at the specified index in the collection.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Item( _
   ByVal index As Integer _
) As CADLayout
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADLayout this[
   int index
] {get; set;}
This language is not supported or no code example is available.

Parameters

index

Type: int

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayoutCollection Class
CADLayoutCollection Members


CADTable.Name Property

Gets or sets a CADTable name read from a CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Name() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Name {get; set;}
This language is not supported or no code example is available.

Property Value

A string containing a CADTable name read from a CAD file.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADTable Class
CADTable Members


CADLayoutCollection Methods

CADLayoutCollection Class See Also

The following tables list the members exposed by the CADLayoutCollection type.

Methods
 | Name | Description
Public method | AddEntity | Adds a CADLayout to this collection.
Public method | AssignEntity | Copies an entity (inherited from CADTable).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADTable).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Iterate | Invokes the referenced (by the specified delegate) method for each CAD entity belonging to the given CADGroup. (inherited from CADGroup).
Public method | Loaded | Loads this CADGroup to the specified CADConverter. (inherited from CADGroup).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RemoveEntityByName | Searches for an entity using its name then removes the entity. (inherited from CADTable).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADLayoutCollection Class


CADLayoutCollection.AddEntity Method

Adds a CADLayout to this collection.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function AddEntity( _
   ByVal E As CADEntity _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool AddEntity(
   CADEntity E
)
This language is not supported or no code example is available.

Parameters

E

Type: CADEntity

An entity

Return Value

True if the layout was added. False overwise.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLayoutCollection Class
CADLayoutCollection Members


CADTable.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADTable Class
CADTable Members


CADTable.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADTable Class
CADTable Members


CADTable.RemoveEntityByName Method

Searches for an entity using its name then removes the entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub RemoveEntityByName( _
   ByVal AName As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void RemoveEntityByName(
   string AName
)
This language is not supported or no code example is available.

Parameters

AName

Type: string

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADTable Class
CADTable Members


CADLayoutCollection Fields

CADLayoutCollection Class See Also

The following tables list the members exposed by the CADLayoutCollection type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADLayoutCollection Class


CADLeader Class

Members See Also

Represents objects consisting of a line segments or a spline with an arrowhead at one end and a multiline text at the other.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADLeader
    Inherits CADSpline
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADLeader : CADSpline
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.CADPenLine
CADImport.CADPolylineBase
CADImport.CADSpline
CADImport.CADLeader
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLeader Members


CADLeader Members

CADLeader Class Constructors Methods Fields Properties See Also

Represents objects consisting of a line segments or a spline with an arrowhead at one end and a multiline text at the other.

The following tables list the members exposed by the CADLeader type.

Constructors
 | Name | Description
Public constructor | CADLeader | Initializes a new instance of the CADLeader class.
Top
Properties
 | Name | Description
Public property | ArrowScale | Gets or sets a scale for the arrowhead of the CADLeader.
Public property | ArrowSize | Gets or sets a size of the arrowhead of the CADLeader.
Public property | ArrowType | Gets or sets a value of the arrow type
Public property | Arrowhead | Gets or sets a value indicating whether this CADLeader contains an arrow.
Public property | Box | Return box of the current primitive. (inherited from CADPolylineBase).
Public property | Closed | Gets or sets a value indicating whether this CADPolyLine is closed. (inherited from CADPolylineBase).
Public property | Color | Gets or sets a color for the specified CADLeader entity.
Public property | ControlCount | Gets a number of control points. (inherited from CADSpline).
Public property | Controls | Gets or sets a collection of control points. (inherited from CADSpline).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADPolylineBase. (inherited from CADPolylineBase).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | Degree | Gets or sets degree of the CADSpline. (inherited from CADSpline).
Public property | DottedSingPoints | Gets a collection of points that specify the dots and dashes of the CADPolylineBase. (inherited from CADPolylineBase).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADLeader entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Fit | Gets or sets a collection of fit points. (inherited from CADSpline).
Public property | FitCount | Gets a number of fit points. (inherited from CADSpline).
Public property | Flags | Gets or sets a number that specifies an appearance of this CADPolylineBase entity. (inherited from CADPolylineBase).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Insert | Gets an insert associated with the specified CADLeader.
Public property | IsMeshMClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the M direction. (inherited from CADPolylineBase).
Public property | IsMeshNClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the N direction. (inherited from CADPolylineBase).
Public property | IsPolyFaceMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | IsPolyZThickness | Gets a value indicating whether a line thickness measured along the axis Z is equal to 0. (inherited from CADPolylineBase).
Public property | IsPolygonMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | IsSpline | Gets or sets a value indicating whether this CADLeader contains a spline.
Public property | Knots | Gets a collection of knots for this CADSpline entity. (inherited from CADSpline).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADPenLine).
Public property | PolyPoints | Gets a collection of points belonging to the polyline. (inherited from CADPolylineBase).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value determined visibility of this CADLeader object.
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Weights | Gets a collection of weights for CADSpline points. (inherited from CADSpline).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | ApplyBox | Calculates a box of the current entity. (inherited from CADPolylineBase).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of an entity with the specified offset to the specified Control (inherited from CADSpline).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Used in drawing cycle for fast checking whether the entity must be drawn (inherited from CADPolylineBase).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADLeader to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADLeader Class


CADLeader Constructor

Example See Also

Initializes a new instance of the CADLeader class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADLeader()
This language is not supported or no code example is available.
Example
<p>Creating a new CADLeader object example:</p> <p>[C#]</p>
Copy

     CreateNewImage();
     CADLeader leader = new CADLeader();
     leader.Color = CADConst.clNone;
     leader.ArrowSize = 3.5f;
     leader.Arrowhead = true;
     leader.ArrowScale = 1.0f;
     DPoint pt1 = GetRealPoint(100, 100);
     DPoint pt2 = GetRealPoint(500, 500);
     leader.Controls.Add(pt1);
     leader.Controls.Add(pt2);
     leader.LineWeight = 0.1;
     leader.Loaded(cadImage.Converter);
     leader.Handle = leader.GetHashCode();
     leader.KeyEnt = leader.Handle.ToString();
     cadImage.Converter.OnCreate(leader);
     cadImage.CurrentLayout.Entities.Add(leader);
     EditorCADPictureBox.Invalidate();
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLeader Class
CADLeader Members
CADImport Namespace
CADImage
CADLeader
DPoint
clNone


CADLeader Properties

CADLeader Class See Also

The following tables list the members exposed by the CADLeader type.

Properties
 | Name | Description
Public property | ArrowScale | Gets or sets a scale for the arrowhead of the CADLeader.
Public property | ArrowSize | Gets or sets a size of the arrowhead of the CADLeader.
Public property | ArrowType | Gets or sets a value of the arrow type
Public property | Arrowhead | Gets or sets a value indicating whether this CADLeader contains an arrow.
Public property | Box | Return box of the current primitive. (inherited from CADPolylineBase).
Public property | Closed | Gets or sets a value indicating whether this CADPolyLine is closed. (inherited from CADPolylineBase).
Public property | Color | Gets or sets a color for the specified CADLeader entity.
Public property | ControlCount | Gets a number of control points. (inherited from CADSpline).
Public property | Controls | Gets or sets a collection of control points. (inherited from CADSpline).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADPolylineBase. (inherited from CADPolylineBase).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | Degree | Gets or sets degree of the CADSpline. (inherited from CADSpline).
Public property | DottedSingPoints | Gets a collection of points that specify the dots and dashes of the CADPolylineBase. (inherited from CADPolylineBase).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADLeader entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Fit | Gets or sets a collection of fit points. (inherited from CADSpline).
Public property | FitCount | Gets a number of fit points. (inherited from CADSpline).
Public property | Flags | Gets or sets a number that specifies an appearance of this CADPolylineBase entity. (inherited from CADPolylineBase).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Insert | Gets an insert associated with the specified CADLeader.
Public property | IsMeshMClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the M direction. (inherited from CADPolylineBase).
Public property | IsMeshNClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the N direction. (inherited from CADPolylineBase).
Public property | IsPolyFaceMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | IsPolyZThickness | Gets a value indicating whether a line thickness measured along the axis Z is equal to 0. (inherited from CADPolylineBase).
Public property | IsPolygonMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | IsSpline | Gets or sets a value indicating whether this CADLeader contains a spline.
Public property | Knots | Gets a collection of knots for this CADSpline entity. (inherited from CADSpline).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADPenLine).
Public property | PolyPoints | Gets a collection of points belonging to the polyline. (inherited from CADPolylineBase).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value determined visibility of this CADLeader object.
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Weights | Gets a collection of weights for CADSpline points. (inherited from CADSpline).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
See Also

Reference

CADLeader Class


CADLeader.ArrowScale Property

Gets or sets a scale for the arrowhead of the CADLeader.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ArrowScale() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float ArrowScale {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLeader Class
CADLeader Members


CADLeader.ArrowSize Property

Gets or sets a size of the arrowhead of the CADLeader.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ArrowSize() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float ArrowSize {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLeader Class
CADLeader Members


CADLeader.ArrowType Property

Gets or sets a value of the arrow type

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ArrowType() As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte ArrowType {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLeader Class
CADLeader Members


CADLeader.Arrowhead Property

Gets or sets a value indicating whether this CADLeader contains an arrow.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Arrowhead() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Arrowhead {get; set;}
This language is not supported or no code example is available.

Property Value

true if this CADLeader contains an arrow; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLeader Class
CADLeader Members


CADLeader.Color Property

Gets or sets a color for the specified CADLeader entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Color() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override Color Color {get; set;}
This language is not supported or no code example is available.

Property Value

A Color of the CADLeader.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLeader Class
CADLeader Members


CADLeader.EntType Property

Gets the type of this CADLeader entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLeader Class
CADLeader Members


CADLeader.Insert Property

Gets an insert associated with the specified CADLeader.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Insert() As CADInsert
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADInsert Insert {get;}
This language is not supported or no code example is available.

Property Value

A CADInsert object associated with the specified CADLeader.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLeader Class
CADLeader Members


CADLeader.IsSpline Property

Gets or sets a value indicating whether this CADLeader contains a spline.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property IsSpline() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsSpline {get; set;}
This language is not supported or no code example is available.

Property Value

true if this CADLeader contains a spline; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLeader Class
CADLeader Members


CADLeader.Visibility Property

Gets or sets a value determined visibility of this CADLeader object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Visibility() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool Visibility {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLeader Class
CADLeader Members


CADLeader Methods

CADLeader Class See Also

The following tables list the members exposed by the CADLeader type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | ApplyBox | Calculates a box of the current entity. (inherited from CADPolylineBase).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of an entity with the specified offset to the specified Control (inherited from CADSpline).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Used in drawing cycle for fast checking whether the entity must be drawn (inherited from CADPolylineBase).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADLeader to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADLeader Class


CADLeader.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLeader Class
CADLeader Members


CADLeader.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLeader Class
CADLeader Members


CADLeader.Loaded Method

Loads this CADLeader to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADLeader is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLeader Class
CADLeader Members


CADLeader Fields

CADLeader Class See Also

The following tables list the members exposed by the CADLeader type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADLeader Class


CADLine Class

Members See Also

Represents a line in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADLine
    Inherits CADPenLine
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADLine : CADPenLine
This language is not supported or no code example is available.
Remarks

A line in a CAD image is specified by two points, Point and Point1.

Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.CADPenLine
CADImport.CADLine
CADImport.CADSolid
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLine Members


CADLine Members

CADLine Class Constructors Methods Fields Properties See Also

Represents a line in a CAD image.

The following tables list the members exposed by the CADLine type.

Constructors
 | Name | Description
Public constructor | CADLine | Initializes a new instance of the CADLine class.
Top
Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses the CADLine entity.
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | DottedSingPts | Gets a collection of points that specify the dots and dashes of the CADLine.
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADLine entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADPenLine).
Public property | Point1 | Gets or sets a second end of the CADLine.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of an entity with specified offset to specified Control
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADLine must be drawn during a drawing cycle.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADLine to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADLine Class


CADLine Properties

CADLine Class See Also

The following tables list the members exposed by the CADLine type.

Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses the CADLine entity.
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | DottedSingPts | Gets a collection of points that specify the dots and dashes of the CADLine.
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADLine entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADPenLine).
Public property | Point1 | Gets or sets a second end of the CADLine.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
See Also

Reference

CADLine Class


CADLine.Box Property

Gets a three-dimensional box that encloses the CADLine entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Box() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override DRect Box {get;}
This language is not supported or no code example is available.

Property Value

A DRect object representing the enclosing box for the CADLine.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLine Class
CADLine Members


CADLine.EntType Property

Gets the type of this CADLine entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLine Class
CADLine Members


CADLine Methods

CADLine Class See Also

The following tables list the members exposed by the CADLine type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of an entity with specified offset to specified Control
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADLine must be drawn during a drawing cycle.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADLine to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADLine Class


CADLine.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLine Class
CADLine Members


CADLine.DrawEntityTrace Method

Implements drawing of an entity with specified offset to specified Control

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub DrawEntityTrace( _
   ByVal dx As Integer, _
   ByVal dy As Integer, _
   ByVal img As CADImage, _
   ByVal control As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void DrawEntityTrace(
   int dx,
   int dy,
   CADImage img,
   Control control
)
This language is not supported or no code example is available.

Parameters

dx

Type: int

X axis offset

dy

Type: int

Y axis offset

img

Type: CADImage

CADImage object for getting display coordinates of the entity

control

Type: Control

Control for drawing of CADEntity

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLine Class
CADLine Members


CADLine.GetBoxPoints Method

Checks if the CADLine must be drawn during a drawing cycle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function GetBoxPoints( _
   ByVal Proc As FPointProc, _
   ByVal Full As Boolean _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool GetBoxPoints(
   FPointProc Proc,
   bool Full
)
This language is not supported or no code example is available.

Parameters

Proc

Type: FPointProc

A FPointProc delegate that references a method for getting points of the CADLine.

Full

Type: bool

A boolean value indicating whether the method realizes full or reduced checking. true if checking is full, false if checking is reduced.

Return Value

true if all points passed to the referenced method are real entity's points; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLine Class
CADLine Members


CADLine.Loaded Method

Loads this CADLine to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADLine is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLine Class
CADLine Members


CADLine Fields

CADLine Class See Also

The following tables list the members exposed by the CADLine type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADLine Class


CADLineType Class

Members See Also

Represents a linetype in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADLineType
    Inherits CADPenTableItem
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADLineType : CADPenTableItem
This language is not supported or no code example is available.
Remarks

A linetype is a repeating pattern of dashes, dots, and blank spaces displayed in a line or a curve. Linetypes can be assigned to objects either by layer or by specifying the linetype explicitly, independent of layers.

Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.CADPenTableItem
CADImport.CADLineType
CADImport.CADMLineStyle
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLineType Members


CADLineType Members

CADLineType Class Constructors Methods Fields Properties See Also

Represents a linetype in a CAD image.

The following tables list the members exposed by the CADLineType type.

Constructors
 | Name | Description
Public constructor | CADLineType | Initializes a new instance of the CADLineType class.
Top
Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | EntName | Gets a name of this CADPenTableItem. (inherited from CADPenTableItem).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Flags | Gets or sets a drawing flags. (inherited from CADPenTableItem).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Lines | Gets a type of the line used by this CADLineType object.
Public property | MaxSizeOfPatterns | Gets a max size of pattern.
Public property | Name | Gets or sets a name of the CADPenTableItem. (inherited from CADPenTableItem).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads the CADLineType to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADLineType Class


CADLineType Constructor

Initializes a new instance of the CADLineType class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADLineType()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLineType Class
CADLineType Members


CADLineType Properties

CADLineType Class See Also

The following tables list the members exposed by the CADLineType type.

Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | EntName | Gets a name of this CADPenTableItem. (inherited from CADPenTableItem).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Flags | Gets or sets a drawing flags. (inherited from CADPenTableItem).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Lines | Gets a type of the line used by this CADLineType object.
Public property | MaxSizeOfPatterns | Gets a max size of pattern.
Public property | Name | Gets or sets a name of the CADPenTableItem. (inherited from CADPenTableItem).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Top
See Also

Reference

CADLineType Class


CADLineType.Lines Property

Gets a type of the line used by this CADLineType object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Lines() As SGLines
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SGLines Lines {get;}
This language is not supported or no code example is available.

Property Value

An object of the sgLines class that specifies a type of the line.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLineType Class
CADLineType Members


CADLineType.MaxSizeOfPatterns Property

Gets a max size of pattern.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property MaxSizeOfPatterns() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double MaxSizeOfPatterns {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLineType Class
CADLineType Members


CADLineType Methods

CADLineType Class See Also

The following tables list the members exposed by the CADLineType type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads the CADLineType to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADLineType Class


CADLineType.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLineType Class
CADLineType Members


CADLineType.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLineType Class
CADLineType Members


CADLineType.Loaded Method

Loads the CADLineType to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADLineType is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADLineType Class
CADLineType Members


CADLineType Fields

CADLineType Class See Also

The following tables list the members exposed by the CADLineType type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADLineType Class


CADMInsert Class

Members See Also

Represents MInsert in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADMInsert
    Inherits CADInsert
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADMInsert : CADInsert
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADCustomVertex
CADImport.CADInsert
CADImport.CADMInsert
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMInsert Members


CADMInsert Members

CADMInsert Class Constructors Methods Fields Properties See Also

Represents MInsert in a CAD image.

The following tables list the members exposed by the CADMInsert type.

Constructors
 | Name | Description
Public constructor | CADMInsert | Initializes a new instance of the CADInsert class.
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets an angle between a referenced block and CAD drawing. (inherited from CADInsert).
Public property | Attribs | Gets a collection of an attribs. (inherited from CADInsert).
Public property | Block | Gets or sets a block referenced by this CADInsert object. (inherited from CADInsert).
Public property | Box | Gets a three-dimensional box that encloses the CADMInsert entity.
Public property | ColSpacing | Gets or sets an interval between columns
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of attribs belonging to the given CADInsert. (inherited from CADInsert).
Public property | EntName | Gets a name of the CADInsert object. (inherited from CADInsert).
Public property | EntType | Gets the type of this CADInsert entity.
Public property | Entities | Gets a collection of attribs associated with the given CADInsert object. (inherited from CADInsert).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADInsert object. (inherited from CADInsert).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADInsert).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADInsert. (inherited from CADInsert).
Public property | NumCols | Gets or sets a number of a columns
Public property | NumRows | Gets or sets a number of a rows
Public property | Point | Gets or sets a position of the CADCustomVertex object. (inherited from CADCustomVertex).
Public property | RowSpacing | Gets or sets an interval between rows
Public property | Scale | Gets or sets a scale for drawning of the referenced block in a CAD image. (inherited from CADInsert).
Public property | Selected | Get or sets CADInsert selected. (inherited from CADInsert).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADInsert object. (inherited from CADInsert).
Public method | AssignEntity | Copies an entity
Public method | Attrib | Returns an attribute contained in the given CADInsert object. (inherited from CADInsert).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADInsert).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADInsert to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADInsert entity. (inherited from CADInsert).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADMInsert Class


CADMInsert Constructor

Initializes a new instance of the CADInsert class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADMInsert()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMInsert Class
CADMInsert Members


CADMInsert Properties

CADMInsert Class See Also

The following tables list the members exposed by the CADMInsert type.

Properties
 | Name | Description
Public property | Angle | Gets or sets an angle between a referenced block and CAD drawing. (inherited from CADInsert).
Public property | Attribs | Gets a collection of an attribs. (inherited from CADInsert).
Public property | Block | Gets or sets a block referenced by this CADInsert object. (inherited from CADInsert).
Public property | Box | Gets a three-dimensional box that encloses the CADMInsert entity.
Public property | ColSpacing | Gets or sets an interval between columns
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of attribs belonging to the given CADInsert. (inherited from CADInsert).
Public property | EntName | Gets a name of the CADInsert object. (inherited from CADInsert).
Public property | EntType | Gets the type of this CADInsert entity.
Public property | Entities | Gets a collection of attribs associated with the given CADInsert object. (inherited from CADInsert).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADInsert object. (inherited from CADInsert).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADInsert).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADInsert. (inherited from CADInsert).
Public property | NumCols | Gets or sets a number of a columns
Public property | NumRows | Gets or sets a number of a rows
Public property | Point | Gets or sets a position of the CADCustomVertex object. (inherited from CADCustomVertex).
Public property | RowSpacing | Gets or sets an interval between rows
Public property | Scale | Gets or sets a scale for drawning of the referenced block in a CAD image. (inherited from CADInsert).
Public property | Selected | Get or sets CADInsert selected. (inherited from CADInsert).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
See Also

Reference

CADMInsert Class


CADMInsert.Box Property

Gets a three-dimensional box that encloses the CADMInsert entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Box() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override DRect Box {get;}
This language is not supported or no code example is available.

Property Value

A DRect object representing the enclosing box for the CADMInsert.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMInsert Class
CADMInsert Members


CADMInsert.ColSpacing Property

Gets or sets an interval between columns

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ColSpacing() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double ColSpacing {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMInsert Class
CADMInsert Members


CADMInsert.EntType Property

Gets the type of this CADInsert entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMInsert Class
CADMInsert Members


CADMInsert.NumCols Property

Gets or sets a number of a columns

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property NumCols() As UInt16
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public UInt16 NumCols {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMInsert Class
CADMInsert Members


CADMInsert.NumRows Property

Gets or sets a number of a rows

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property NumRows() As UInt16
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public UInt16 NumRows {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMInsert Class
CADMInsert Members


CADMInsert.RowSpacing Property

Gets or sets an interval between rows

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property RowSpacing() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double RowSpacing {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMInsert Class
CADMInsert Members


CADMInsert Methods

CADMInsert Class See Also

The following tables list the members exposed by the CADMInsert type.

Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADInsert object. (inherited from CADInsert).
Public method | AssignEntity | Copies an entity
Public method | Attrib | Returns an attribute contained in the given CADInsert object. (inherited from CADInsert).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADInsert).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADInsert to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADInsert entity. (inherited from CADInsert).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADMInsert Class


CADMInsert.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMInsert Class
CADMInsert Members


CADMInsert.Loaded Method

Loads this CADInsert to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADInsert object is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMInsert Class
CADMInsert Members


CADMInsert Fields

CADMInsert Class See Also

The following tables list the members exposed by the CADMInsert type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADMInsert Class


CADMLine Class

Members See Also

Represents an MLine object in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADMLine
    Inherits CADInsert
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADMLine : CADInsert
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADCustomVertex
CADImport.CADInsert
CADImport.CADMLine
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMLine Members


CADMLine Members

CADMLine Class Constructors Methods Fields Properties See Also

Represents an MLine object in a CAD image.

The following tables list the members exposed by the CADMLine type.

Constructors
 | Name | Description
Public constructor | CADMLine | Initializes a new instance of the CADMLine class.
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets an angle between a referenced block and CAD drawing. (inherited from CADInsert).
Public property | Attribs | Gets a collection of an attribs. (inherited from CADInsert).
Public property | Block | Gets or sets a block referenced by this CADInsert object. (inherited from CADInsert).
Public property | Box | Gets a three-dimensional box that encloses the CADInsert object. (inherited from CADInsert).
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of attribs belonging to the given CADInsert. (inherited from CADInsert).
Public property | EntName | Gets a name of the CADInsert object. (inherited from CADInsert).
Public property | EntType | Gets the type of this CADInsert entity.
Public property | Entities | Gets a collection of attribs associated with the given CADInsert object. (inherited from CADInsert).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADInsert object. (inherited from CADInsert).
Public property | Flags | Gets or sets a flags for this CADMLine object
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Items | Gets or sets a collection of entities for this CADMLine object.
Public property | Justify | Gets or sets a justification for this CADMLine object
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADInsert).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADInsert. (inherited from CADInsert).
Public property | Point | Gets or sets a position of the CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Scale | Gets or sets a scale for drawning of the referenced block in a CAD image. (inherited from CADInsert).
Public property | ScaleFactor | Gets or sets a scale factor for this CADMLine object
Public property | Selected | Get or sets CADInsert selected. (inherited from CADInsert).
Public property | Style | Gets or sets a style for this CADMLine object
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADMLine object.
Public method | AssignEntity | Copies an entity
Public method | Attrib | Returns an attribute contained in the given CADInsert object. (inherited from CADInsert).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADMLine to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADInsert entity. (inherited from CADInsert).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADMLine Class


CADMLine Constructor

Initializes a new instance of the CADMLine class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADMLine()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMLine Class
CADMLine Members


CADMLine Properties

CADMLine Class See Also

The following tables list the members exposed by the CADMLine type.

Properties
 | Name | Description
Public property | Angle | Gets or sets an angle between a referenced block and CAD drawing. (inherited from CADInsert).
Public property | Attribs | Gets a collection of an attribs. (inherited from CADInsert).
Public property | Block | Gets or sets a block referenced by this CADInsert object. (inherited from CADInsert).
Public property | Box | Gets a three-dimensional box that encloses the CADInsert object. (inherited from CADInsert).
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of attribs belonging to the given CADInsert. (inherited from CADInsert).
Public property | EntName | Gets a name of the CADInsert object. (inherited from CADInsert).
Public property | EntType | Gets the type of this CADInsert entity.
Public property | Entities | Gets a collection of attribs associated with the given CADInsert object. (inherited from CADInsert).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADInsert object. (inherited from CADInsert).
Public property | Flags | Gets or sets a flags for this CADMLine object
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Items | Gets or sets a collection of entities for this CADMLine object.
Public property | Justify | Gets or sets a justification for this CADMLine object
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADInsert).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADInsert. (inherited from CADInsert).
Public property | Point | Gets or sets a position of the CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Scale | Gets or sets a scale for drawning of the referenced block in a CAD image. (inherited from CADInsert).
Public property | ScaleFactor | Gets or sets a scale factor for this CADMLine object
Public property | Selected | Get or sets CADInsert selected. (inherited from CADInsert).
Public property | Style | Gets or sets a style for this CADMLine object
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
See Also

Reference

CADMLine Class


CADMLine.EntType Property

Gets the type of this CADInsert entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMLine Class
CADMLine Members


CADMLine.Flags Property

Gets or sets a flags for this CADMLine object

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Flags() As UInt16
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public UInt16 Flags {get; set;}
This language is not supported or no code example is available.
Remarks

            1 = Has at least one vertex.
2 = Closed.
4 = Suppress start caps.
8 = Suppress end caps.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMLine Class
CADMLine Members


CADMLine.Items Property

Gets or sets a collection of entities for this CADMLine object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Items() As CADCollection(Of MVertex)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection<MVertex> Items {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMLine Class
CADMLine Members


CADMLine.Justify Property

Gets or sets a justification for this CADMLine object

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Justify() As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte Justify {get; set;}
This language is not supported or no code example is available.

Property Value

0 = top, 1 = zero, 2 = bottom
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMLine Class
CADMLine Members


CADMLine.ScaleFactor Property

Gets or sets a scale factor for this CADMLine object

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ScaleFactor() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double ScaleFactor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMLine Class
CADMLine Members


CADMLine.Style Property

Gets or sets a style for this CADMLine object

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Style() As CADMLineStyle
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADMLineStyle Style {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMLine Class
CADMLine Members


CADMLine Methods

CADMLine Class See Also

The following tables list the members exposed by the CADMLine type.

Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADMLine object.
Public method | AssignEntity | Copies an entity
Public method | Attrib | Returns an attribute contained in the given CADInsert object. (inherited from CADInsert).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADMLine to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADInsert entity. (inherited from CADInsert).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADMLine Class


CADMLine.AddEntity Method

Adds the specified entity to this CADMLine object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function AddEntity( _
   ByVal E As CADEntity _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool AddEntity(
   CADEntity E
)
This language is not supported or no code example is available.

Parameters

E

Type: CADEntity

A CADEntity to add.

Return Value

true if a CADEntity was added; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMLine Class
CADMLine Members


CADMLine.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMLine Class
CADMLine Members


CADMLine.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMLine Class
CADMLine Members


CADMLine.Loaded Method

Loads this CADMLine to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADMLine is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMLine Class
CADMLine Members


CADMLine Fields

CADMLine Class See Also

The following tables list the members exposed by the CADMLine type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADMLine Class


CADMLineEntry Class

Members See Also

Represents an Tolerance object in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADMLineEntry
    Inherits CADEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADMLineEntry : CADEntity
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADMLineEntry
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMLineEntry Members


CADMLineEntry Members

CADMLineEntry Class Constructors Methods Fields Properties See Also

Represents an Tolerance object in a CAD image.

The following tables list the members exposed by the CADMLineEntry type.

Constructors
 | Name | Description
Public constructor | CADMLineEntry | Initializes a new instance of the CADEntity class. (inherited from CADEntity).
Top
Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color for this CADMLineEntry entity.
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer containing this CADEntity. (inherited from CADEntity).
Public property | LineType | Gets or sets a type of the lines for this CADMLineEntry entity.
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Offset | Gets or sets an offset for this CADMLineEntry entity.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADEntity is visible. (inherited from CADEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity (inherited from CADEntity).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADMLineEntry Class


CADMLineEntry Properties

CADMLineEntry Class See Also

The following tables list the members exposed by the CADMLineEntry type.

Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color for this CADMLineEntry entity.
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer containing this CADEntity. (inherited from CADEntity).
Public property | LineType | Gets or sets a type of the lines for this CADMLineEntry entity.
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Offset | Gets or sets an offset for this CADMLineEntry entity.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADEntity is visible. (inherited from CADEntity).
Top
See Also

Reference

CADMLineEntry Class


CADMLineEntry.Color Property

Gets or sets a color for this CADMLineEntry entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Color() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override Color Color {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMLineEntry Class
CADMLineEntry Members


CADMLineEntry.LineType Property

Gets or sets a type of the lines for this CADMLineEntry entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shadows Property LineType() As CADEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
new public CADEntity LineType {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMLineEntry Class
CADMLineEntry Members


CADMLineEntry.Offset Property

Gets or sets an offset for this CADMLineEntry entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Offset() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Offset {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMLineEntry Class
CADMLineEntry Members


CADMLineEntry Methods

CADMLineEntry Class See Also

The following tables list the members exposed by the CADMLineEntry type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity (inherited from CADEntity).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADMLineEntry Class


CADMLineEntry.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMLineEntry Class
CADMLineEntry Members


CADMLineEntry Fields

CADMLineEntry Class See Also

The following tables list the members exposed by the CADMLineEntry type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADMLineEntry Class


CADMLineStyle Class

Members See Also

Represents an Tolerance object in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADMLineStyle
    Inherits CADLineType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADMLineStyle : CADLineType
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.CADPenTableItem
CADImport.CADLineType
CADImport.CADMLineStyle
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMLineStyle Members


CADMLineStyle Members

CADMLineStyle Class Constructors Methods Fields Properties See Also

Represents an Tolerance object in a CAD image.

The following tables list the members exposed by the CADMLineStyle type.

Constructors
 | Name | Description
Public constructor | CADMLineStyle | Initializes a new instance of the CADMLineStyle class.
Top
Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entries to this CADMLineStyle entity.
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | EntName | Gets a name of this CADPenTableItem. (inherited from CADPenTableItem).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | Entries | Gets or sets a collection of an entries to this CADMLineStyle entity.
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Flags | Gets or sets a drawing flags. (inherited from CADPenTableItem).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Lines | Gets a type of the line used by this CADLineType object. (inherited from CADLineType).
Public property | MaxSizeOfPatterns | Gets a max size of pattern. (inherited from CADLineType).
Public property | Name | Gets or sets a name of the CADPenTableItem. (inherited from CADPenTableItem).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADMLineStyle.
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Invert | Inverts a collection of entries of this CADMLineStyle entity.
Public method | Loaded | Loads this CADMLineStyle to the specified CADConverter.
Public method | NewEntry | Creates a new entry to this CADMLineStyle and adds it to collection of entries.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADMLineStyle Class


CADMLineStyle Constructor

Initializes a new instance of the CADMLineStyle class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADMLineStyle()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMLineStyle Class
CADMLineStyle Members


CADMLineStyle Properties

CADMLineStyle Class See Also

The following tables list the members exposed by the CADMLineStyle type.

Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entries to this CADMLineStyle entity.
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | EntName | Gets a name of this CADPenTableItem. (inherited from CADPenTableItem).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | Entries | Gets or sets a collection of an entries to this CADMLineStyle entity.
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Flags | Gets or sets a drawing flags. (inherited from CADPenTableItem).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Lines | Gets a type of the line used by this CADLineType object. (inherited from CADLineType).
Public property | MaxSizeOfPatterns | Gets a max size of pattern. (inherited from CADLineType).
Public property | Name | Gets or sets a name of the CADPenTableItem. (inherited from CADPenTableItem).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Top
See Also

Reference

CADMLineStyle Class


CADMLineStyle.Count Property

Gets a number of entries to this CADMLineStyle entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Count() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override int Count {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMLineStyle Class
CADMLineStyle Members


CADMLineStyle.Entries Property

Gets or sets a collection of an entries to this CADMLineStyle entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Entries() As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntityCollection Entries {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMLineStyle Class
CADMLineStyle Members


CADMLineStyle Methods

CADMLineStyle Class See Also

The following tables list the members exposed by the CADMLineStyle type.

Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADMLineStyle.
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Invert | Inverts a collection of entries of this CADMLineStyle entity.
Public method | Loaded | Loads this CADMLineStyle to the specified CADConverter.
Public method | NewEntry | Creates a new entry to this CADMLineStyle and adds it to collection of entries.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADMLineStyle Class


CADMLineStyle.AddEntity Method

Adds the specified entity to this CADMLineStyle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function AddEntity( _
   ByVal E As CADEntity _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool AddEntity(
   CADEntity E
)
This language is not supported or no code example is available.

Parameters

E

Type: CADEntity

A CADEntity to add.

Return Value

true if a CADEntity was added; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMLineStyle Class
CADMLineStyle Members


CADMLineStyle.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMLineStyle Class
CADMLineStyle Members


CADMLineStyle.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMLineStyle Class
CADMLineStyle Members


CADMLineStyle.Invert Method

Inverts a collection of entries of this CADMLineStyle entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Invert()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Invert()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMLineStyle Class
CADMLineStyle Members


CADMLineStyle.Loaded Method

Loads this CADMLineStyle to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADMLineStyle is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMLineStyle Class
CADMLineStyle Members


CADMLineStyle.NewEntry Method

Creates a new entry to this CADMLineStyle and adds it to collection of entries.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub NewEntry( _
   ByVal offset As Double, _
   ByVal color As Color, _
   ByVal linetype As CADEntity, _
   ByVal vers As Byte _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void NewEntry(
   double offset,
   Color color,
   CADEntity linetype,
   byte vers
)
This language is not supported or no code example is available.

Parameters

offset

Type: double

An offset for a new entry

color

Type: Color

A color for a new entry

linetype

Type: CADEntity

A linetype for a new entry

vers

Type: byte

A version for a new entry

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMLineStyle Class
CADMLineStyle Members


CADMLineStyle Fields

CADMLineStyle Class See Also

The following tables list the members exposed by the CADMLineStyle type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADMLineStyle Class


CADMPolygon Class

Members See Also

Represents MPolygon in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADMPolygon
    Inherits CADHatch
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADMPolygon : CADHatch
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPolyPolygon
CADImport.CADGradientPolygon
CADImport.CADCurvePolygon
CADImport.CADHatch
CADImport.CADMPolygon
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMPolygon Members


CADMPolygon Members

CADMPolygon Class Constructors Methods Fields Properties See Also

Represents MPolygon in a CAD image.

The following tables list the members exposed by the CADMPolygon type.

Constructors
 | Name | Description
Public constructor | CADMPolygon | Initializes a new instance of the CADMPolygon class.
Top
Properties
 | Name | Description
Public property | Boundaries | Gets a collection of boundaries of this CADPolyPolygon. (inherited from CADPolyPolygon).
Public property | BoundaryData | Gets a list of borders for this CADCurvePolygon. (inherited from CADCurvePolygon).
Public property | Box | Gets a three-dimensional box that encloses this CADPolyPolygon. (inherited from CADPolyPolygon).
Public property | Color | Gets or sets a color of this CADPolyPolygon. (inherited from CADPolyPolygon).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | Elevation | Gets or sets a distance on which this CADCurvePolygon is elevated along the Z axis. (inherited from CADCurvePolygon).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADHatch entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets the Z axis direction of the CADCurvePolygon object coordinate system. (inherited from CADCurvePolygon).
Public property | FillColor | Gets or sets the pattern fill color.
Public property | Filled | (inherited from CADPolyPolygon).
Public property | GradientColor | Gets or sets a gradient color. (inherited from CADGradientPolygon).
Public property | GradientName | Gets or sets a name of the gradient. (inherited from CADGradientPolygon).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | HatchName | Gets or sets a name of this CADHatch entity. (inherited from CADHatch).
Public property | HatchPatternData | Gets a collection of hatch patterns used in the pattern of this CADHatch object. (inherited from CADHatch).
Public property | HatchStyle | Gets or sets a style of this CADHatch entity. (inherited from CADHatch).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type (inherited from CADHatch).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADHatch entity. (inherited from CADHatch).
Public property | Lines | Gets a type of the line used by this CADHatch object. (inherited from CADHatch).
Public property | Offset | Gets or sets the offset vector.
Public property | ParsedLines | Gets a collection of points that specify the hatch pattern. (inherited from CADHatch).
Public property | PttBaseP | Gets or sets a base point from which filling a shape with the hatch patterns starts. (inherited from CADHatch).
Public property | PttLineAngle | Gets or sets an angle for this CADHatch object. (inherited from CADHatch).
Public property | PttNumLines | Gets or sets a number of lines that specify a linetype for the lines used in this CADHatch entity. (inherited from CADHatch).
Public property | PttOffset | Gets or sets an offset from the base point of this CADHatch object. (inherited from CADHatch).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible.
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Destroy | Clears all data that specify a hatch pattern of this CADHatch object. (inherited from CADHatch).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADHatch).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADCurvePolygon must be drawn during a drawing cycle. (inherited from CADCurvePolygon).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | HatchLine | For internal use (inherited from CADHatch).
Public method | Loaded | Loads this CADPolyPolygon to the specified CADConverter. (inherited from CADPolyPolygon).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADMPolygon Class


CADMPolygon Constructor

Initializes a new instance of the CADMPolygon class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADMPolygon()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMPolygon Class
CADMPolygon Members


CADMPolygon Properties

CADMPolygon Class See Also

The following tables list the members exposed by the CADMPolygon type.

Properties
 | Name | Description
Public property | Boundaries | Gets a collection of boundaries of this CADPolyPolygon. (inherited from CADPolyPolygon).
Public property | BoundaryData | Gets a list of borders for this CADCurvePolygon. (inherited from CADCurvePolygon).
Public property | Box | Gets a three-dimensional box that encloses this CADPolyPolygon. (inherited from CADPolyPolygon).
Public property | Color | Gets or sets a color of this CADPolyPolygon. (inherited from CADPolyPolygon).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | Elevation | Gets or sets a distance on which this CADCurvePolygon is elevated along the Z axis. (inherited from CADCurvePolygon).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADHatch entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets the Z axis direction of the CADCurvePolygon object coordinate system. (inherited from CADCurvePolygon).
Public property | FillColor | Gets or sets the pattern fill color.
Public property | Filled | (inherited from CADPolyPolygon).
Public property | GradientColor | Gets or sets a gradient color. (inherited from CADGradientPolygon).
Public property | GradientName | Gets or sets a name of the gradient. (inherited from CADGradientPolygon).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | HatchName | Gets or sets a name of this CADHatch entity. (inherited from CADHatch).
Public property | HatchPatternData | Gets a collection of hatch patterns used in the pattern of this CADHatch object. (inherited from CADHatch).
Public property | HatchStyle | Gets or sets a style of this CADHatch entity. (inherited from CADHatch).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type (inherited from CADHatch).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADHatch entity. (inherited from CADHatch).
Public property | Lines | Gets a type of the line used by this CADHatch object. (inherited from CADHatch).
Public property | Offset | Gets or sets the offset vector.
Public property | ParsedLines | Gets a collection of points that specify the hatch pattern. (inherited from CADHatch).
Public property | PttBaseP | Gets or sets a base point from which filling a shape with the hatch patterns starts. (inherited from CADHatch).
Public property | PttLineAngle | Gets or sets an angle for this CADHatch object. (inherited from CADHatch).
Public property | PttNumLines | Gets or sets a number of lines that specify a linetype for the lines used in this CADHatch entity. (inherited from CADHatch).
Public property | PttOffset | Gets or sets an offset from the base point of this CADHatch object. (inherited from CADHatch).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible.
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
See Also

Reference

CADMPolygon Class


CADMPolygon.EntType Property

Gets the type of this CADHatch entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMPolygon Class
CADMPolygon Members


CADMPolygon.FillColor Property

Gets or sets the pattern fill color.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property FillColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Color FillColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMPolygon Class
CADMPolygon Members


CADMPolygon.Offset Property

Gets or sets the offset vector.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Offset() As CAD2DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CAD2DPoint Offset {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMPolygon Class
CADMPolygon Members


CADMPolygon.Visibility Property

Gets or sets a value indicating whether a CADPlotEntity is visible.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Visibility() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool Visibility {get; set;}
This language is not supported or no code example is available.

Property Value

true if a CADPlotEntity is visible; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMPolygon Class
CADMPolygon Members


CADMPolygon Methods

CADMPolygon Class See Also

The following tables list the members exposed by the CADMPolygon type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Destroy | Clears all data that specify a hatch pattern of this CADHatch object. (inherited from CADHatch).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADHatch).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADCurvePolygon must be drawn during a drawing cycle. (inherited from CADCurvePolygon).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | HatchLine | For internal use (inherited from CADHatch).
Public method | Loaded | Loads this CADPolyPolygon to the specified CADConverter. (inherited from CADPolyPolygon).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADMPolygon Class


CADMPolygon.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMPolygon Class
CADMPolygon Members


CADMPolygon Fields

CADMPolygon Class See Also

The following tables list the members exposed by the CADMPolygon type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADMPolygon Class


CADMText Class

Members See Also

Represents a multiline text in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADMText
    Inherits CADInsert
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADMText : CADInsert
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADCustomVertex
CADImport.CADInsert
CADImport.CADMText
CADImport.CADTolerance
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMText Members


CADMText Members

CADMText Class Constructors Methods Fields Properties See Also

Represents a multiline text in a CAD image.

The following tables list the members exposed by the CADMText type.

Constructors
 | Name | Description
Public constructor | CADMText | Initializes a new instance of the CADMText object.
Top
Properties
 | Name | Description
Public property | Align | Gets or sets an alignment of the text
Public property | Angle | Gets or sets an angle between a referenced block and CAD drawing. (inherited from CADInsert).
Public property | Attribs | Gets a collection of an attribs. (inherited from CADInsert).
Public property | Block | Gets or sets a block referenced by this CADInsert object. (inherited from CADInsert).
Public property | Box | Gets a three-dimensional box that encloses the CADInsert object. (inherited from CADInsert).
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of attribs belonging to the given CADInsert. (inherited from CADInsert).
Public property | EntName | Gets a name of the CADMText object.
Public property | EntType | Gets the type of this CADMText entity.
Public property | Entities | Gets a collection of attribs associated with the given CADInsert object. (inherited from CADInsert).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADInsert object. (inherited from CADInsert).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Height | Gets or sets a height of a text
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineSpacingFactor | Mtext line spacing factor (optional):
Public property | LineSpacingStyle | MText line spacing style (optional):
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADInsert).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADInsert. (inherited from CADInsert).
Public property | OrientedByLayout | Defines orientation by layout for this MText.
Public property | Point | Gets or sets a position of the CADCustomVertex object.
Public property | Point1 | X-axis direction vector (in World Coordinate System).
Public property | RectHeight | Gets or sets a height of the bounding rectangle for the CADMText object.
Public property | RectWidth | Gets or sets a width of the bounding rectangle for the CADMText object.
Public property | Scale | Gets or sets a scale for drawning of the referenced block in a CAD image. (inherited from CADInsert).
Public property | Selected | Get or sets CADInsert selected. (inherited from CADInsert).
Public property | Style | Gets or sets a style for the CADMText object.
Public property | Text | Gets or sets a text contents for this CADMText object.
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADInsert object. (inherited from CADInsert).
Public method | AssignEntity | Copies an entity
Public method | Attrib | Returns an attribute contained in the given CADInsert object. (inherited from CADInsert).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADMText to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADInsert entity. (inherited from CADInsert).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADMText Class


CADMText Constructor

Example See Also

Initializes a new instance of the CADMText object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADMText()
This language is not supported or no code example is available.
Example
<p>Creating a new CADMText object example:</p> <p>[C#]</p>
Copy
 CreateNewImage();
 CADMText mText = new CADMText();
 Point p1 = new Point(100, 100);
 mText.Point = GetRealPoint(p1.X, p1.Y);
 mText.Text = AddEntityOptions.AddNewMTextString("Any Text", "NewMText1", new Font("Arial.ttf", 5), 1);
 mText.LineWeight = 0.1;
 mText.Angle = 0.0f;
 mText.Color = CADConst.clNone;
 mText.Layer = cadImage.Converter.Layers[0] as CADLayer;
 mText.Handle = mText.GetHashCode();
 mText.KeyEnt = mText.Handle.ToString();
 cadImage.Converter.Loads(mText);
 cadImage.Converter.OnCreate(mText);
 cadImage.CurrentLayout.Entities.Add(mText);
 EditorCADPictureBox.Invalidate();
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMText Class
CADMText Members
CADImport Namespace
CADImage
CADMText
DPoint
clNone


CADMText Properties

CADMText Class See Also

The following tables list the members exposed by the CADMText type.

Properties
 | Name | Description
Public property | Align | Gets or sets an alignment of the text
Public property | Angle | Gets or sets an angle between a referenced block and CAD drawing. (inherited from CADInsert).
Public property | Attribs | Gets a collection of an attribs. (inherited from CADInsert).
Public property | Block | Gets or sets a block referenced by this CADInsert object. (inherited from CADInsert).
Public property | Box | Gets a three-dimensional box that encloses the CADInsert object. (inherited from CADInsert).
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of attribs belonging to the given CADInsert. (inherited from CADInsert).
Public property | EntName | Gets a name of the CADMText object.
Public property | EntType | Gets the type of this CADMText entity.
Public property | Entities | Gets a collection of attribs associated with the given CADInsert object. (inherited from CADInsert).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADInsert object. (inherited from CADInsert).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Height | Gets or sets a height of a text
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineSpacingFactor | Mtext line spacing factor (optional):
Public property | LineSpacingStyle | MText line spacing style (optional):
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADInsert).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADInsert. (inherited from CADInsert).
Public property | OrientedByLayout | Defines orientation by layout for this MText.
Public property | Point | Gets or sets a position of the CADCustomVertex object.
Public property | Point1 | X-axis direction vector (in World Coordinate System).
Public property | RectHeight | Gets or sets a height of the bounding rectangle for the CADMText object.
Public property | RectWidth | Gets or sets a width of the bounding rectangle for the CADMText object.
Public property | Scale | Gets or sets a scale for drawning of the referenced block in a CAD image. (inherited from CADInsert).
Public property | Selected | Get or sets CADInsert selected. (inherited from CADInsert).
Public property | Style | Gets or sets a style for the CADMText object.
Public property | Text | Gets or sets a text contents for this CADMText object.
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
See Also

Reference

CADMText Class


CADMText.Align Property

Gets or sets an alignment of the text

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Align() As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte Align {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMText Class
CADMText Members


CADMText.EntName Property

Gets a name of the CADMText object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override string EntName {get;}
This language is not supported or no code example is available.

Property Value

A string containing a name of the CADMText object.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMText Class
CADMText Members


CADMText.EntType Property

Gets the type of this CADMText entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMText Class
CADMText Members


CADMText.Height Property

Gets or sets a height of a text

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Height() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Height {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMText Class
CADMText Members


CADMText.LineSpacingFactor Property

Mtext line spacing factor (optional):

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LineSpacingFactor() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float LineSpacingFactor {get; set;}
This language is not supported or no code example is available.

Property Value

Percentage of default (3-on-5) line spacing to be applied. Valid values range from 0.25 to 4.00
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMText Class
CADMText Members


CADMText.LineSpacingStyle Property

MText line spacing style (optional):

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LineSpacingStyle() As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte LineSpacingStyle {get; set;}
This language is not supported or no code example is available.

Property Value

1 = At least (taller characters will override) 2 = Exact (taller characters will not override)
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMText Class
CADMText Members


CADMText.OrientedByLayout Property

Defines orientation by layout for this MText.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property OrientedByLayout() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool OrientedByLayout {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMText Class
CADMText Members


CADMText.Point Property

Gets or sets a position of the CADCustomVertex object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Point() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override DPoint Point {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object that specifies a position of the CADCustomVertex entity in three-dimensional space.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMText Class
CADMText Members


CADMText.Point1 Property

X-axis direction vector (in World Coordinate System).

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Point1() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Point1 {get; set;}
This language is not supported or no code example is available.
Remarks

It can affect smoothing

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMText Class
CADMText Members


CADMText.RectHeight Property

Gets or sets a height of the bounding rectangle for the CADMText object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property RectHeight() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float RectHeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMText Class
CADMText Members


CADMText.RectWidth Property

Gets or sets a width of the bounding rectangle for the CADMText object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property RectWidth() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float RectWidth {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMText Class
CADMText Members


CADMText.Style Property

Gets or sets a style for the CADMText object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Style() As CADStyle
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADStyle Style {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMText Class
CADMText Members


CADMText.Text Property

Gets or sets a text contents for this CADMText object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Text() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Text {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMText Class
CADMText Members


CADMText Methods

CADMText Class See Also

The following tables list the members exposed by the CADMText type.

Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADInsert object. (inherited from CADInsert).
Public method | AssignEntity | Copies an entity
Public method | Attrib | Returns an attribute contained in the given CADInsert object. (inherited from CADInsert).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADMText to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADInsert entity. (inherited from CADInsert).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADMText Class


CADMText.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMText Class
CADMText Members


CADMText.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMText Class
CADMText Members


CADMText.Loaded Method

Loads this CADMText to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADMText object is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMText Class
CADMText Members


CADMText Fields

CADMText Class See Also

The following tables list the members exposed by the CADMText type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADMText Class


CADMath Class

Members See Also

Provides methods for mathematical calculations.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public MustInherit Class CADMath
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public abstract class CADMath
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADMath
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMath Members


CADMath Members

CADMath Class Methods Fields See Also

Provides methods for mathematical calculations.

The following tables list the members exposed by the CADMath type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
 | GetPointOnCircle | Calculates a point that belongs to the arc of a specified circle.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | Radian | Converts a degree value into a radian value.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
 | Sqr | Raises specified value to the second power.
 | SwapDouble | Swaps two double values.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
Name | Description
accuracy | The accuracity for calculations.
one_64 | The 1/64 value.
Top
See Also

Reference

CADMath Class


CADMath Methods

CADMath Class See Also

The following tables list the members exposed by the CADMath type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
 | GetPointOnCircle | Calculates a point that belongs to the arc of a specified circle.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | Radian | Converts a degree value into a radian value.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
 | Sqr | Raises specified value to the second power.
 | SwapDouble | Swaps two double values.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADMath Class


CADMath.GetPointOnCircle Method

Calculates a point that belongs to the arc of a specified circle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function GetPointOnCircle( _
   ByVal center As DPoint, _
   ByVal radius As Double, _
   ByVal angle As Double _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static DPoint GetPointOnCircle(
   DPoint center,
   double radius,
   double angle
)
This language is not supported or no code example is available.

Parameters

center

Type: DPoint

The center point of a circle

radius

Type: double

The radius of a circle

angle

Type: double

The angle between a required point and OX axis

Return Value

A drawing 3D point
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMath Class
CADMath Members


CADMath.Radian Method

Converts a degree value into a radian value.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function Radian( _
   ByVal Angle As Double _
) As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static double Radian(
   double Angle
)
This language is not supported or no code example is available.

Parameters

Angle

Type: double

An angle in deegrees

Return Value

Converted angle in radians
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMath Class
CADMath Members


CADMath.Sqr Method

Raises specified value to the second power.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function Sqr( _
   ByVal X As Double _
) As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static double Sqr(
   double X
)
This language is not supported or no code example is available.

Parameters

X

Type: double

Input value.

Return Value

The second power of the specified value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMath Class
CADMath Members


CADMath.SwapDouble Method

Swaps two double values.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub SwapDouble( _
   ByRef A As Double, _
   ByRef B As Double _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void SwapDouble(
   ref double A,
   ref double B
)
This language is not supported or no code example is available.

Parameters

A

Type: double

The first value to swap

B

Type: double

The second value to swap

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMath Class
CADMath Members


CADMath Fields

CADMath Class See Also

The following tables list the members exposed by the CADMath type.

Fields
Name | Description
accuracy | The accuracity for calculations.
one_64 | The 1/64 value.
Top
See Also

Reference

CADMath Class


accuracy Field

The accuracity for calculations.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Const accuracy As Double = 1E-06
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public const double accuracy = 1E-06
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMath Class
CADMath Members


one_64 Field

The 1/64 value.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Const one_64 As Double = 0,015625
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public const double one_64 = 0,015625
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMath Class
CADMath Members


CADMatrix Class

Members See Also

Encapsulates a 4-by-3 affine matrix that represents a geometric transform.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADMatrix
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADMatrix
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADMatrix
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMatrix Members


CADMatrix Members

CADMatrix Class Constructors Methods Fields Properties See Also

Encapsulates a 4-by-3 affine matrix that represents a geometric transform.

The following tables list the members exposed by the CADMatrix type.

Constructors
 | Name | Description
Public constructor | CADMatrix | Initializes a new instance of the CADMatrix class.
Top
Properties
 | Name | Description
Public property | Data | Gets or sets matrix data.
Public property | Item | Gets the component at the given row and column in the matrix.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new matrix that is a copy of the current instance.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetArrValues | Gets an array of components for this CADMatrix instance.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IdentityMat | Creates an initial matrix.
Public method | IsZero | Returns a value indicating whether this is a zero matrix.
 | MatOffset | Writes an offset to the last row of the specified matrix.
 | MatXMat | Multiplies two matrixes.
 | Part | for internal use.
Public method | PtXMat | Multiplies a vector and the matrix.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Scale | Returns a scaled CADMatrix.
 | StdMat | Creates a matrix based on the specified scale and offset.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | Translate | Applies an offset to the CADMatrix.
Public method | Transpose | Calculates the transpose of this CADMatrix instance.
Top
Fields
Name | Description
Identity | Represent a default matrix.
Top
See Also

Reference

CADMatrix Class


CADMatrix Constructor

Initializes a new instance of the CADMatrix class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADMatrix()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMatrix Class
CADMatrix Members


CADMatrix Properties

CADMatrix Class See Also

The following tables list the members exposed by the CADMatrix type.

Properties
 | Name | Description
Public property | Data | Gets or sets matrix data.
Public property | Item | Gets the component at the given row and column in the matrix.
Top
See Also

Reference

CADMatrix Class


CADMatrix.Data Property

Gets or sets matrix data.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Data() As Double()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double[] Data {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMatrix Class
CADMatrix Members


CADMatrix.Item Property

Gets the component at the given row and column in the matrix.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Item( _
   ByVal i As Integer, _
   ByVal j As Integer _
) As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double this[
   int i,
   int j
] {get; set;}
This language is not supported or no code example is available.

Parameters

i

Type: int

A row number

j

Type: int

A column number

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMatrix Class
CADMatrix Members


CADMatrix Methods

CADMatrix Class See Also

The following tables list the members exposed by the CADMatrix type.

Methods
 | Name | Description
Public method | Clone | Creates a new matrix that is a copy of the current instance.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetArrValues | Gets an array of components for this CADMatrix instance.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IdentityMat | Creates an initial matrix.
Public method | IsZero | Returns a value indicating whether this is a zero matrix.
 | MatOffset | Writes an offset to the last row of the specified matrix.
 | MatXMat | Multiplies two matrixes.
 | Part | for internal use.
Public method | PtXMat | Multiplies a vector and the matrix.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Scale | Returns a scaled CADMatrix.
 | StdMat | Creates a matrix based on the specified scale and offset.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | Translate | Applies an offset to the CADMatrix.
Public method | Transpose | Calculates the transpose of this CADMatrix instance.
Top
See Also

Reference

CADMatrix Class


CADMatrix.Clone Method

Creates a new matrix that is a copy of the current instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Clone() As Object
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public object Clone()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMatrix Class
CADMatrix Members


CADMatrix.GetArrValues Method

Gets an array of components for this CADMatrix instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetArrValues() As Double()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double[] GetArrValues()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMatrix Class
CADMatrix Members


CADMatrix.IdentityMat Method

Creates an initial matrix.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub IdentityMat()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void IdentityMat()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMatrix Class
CADMatrix Members


CADMatrix.IsZero Method

Returns a value indicating whether this is a zero matrix.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function IsZero() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsZero()
This language is not supported or no code example is available.

Return Value

true if all data values are equal to zero; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMatrix Class
CADMatrix Members


CADMatrix.MatOffset Method

Writes an offset to the last row of the specified matrix.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub MatOffset( _
   ByVal M As CADMatrix, _
   ByVal P As DPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void MatOffset(
   CADMatrix M,
   DPoint P
)
This language is not supported or no code example is available.

Parameters

M

Type: CADMatrix

A CADMatrix object where to write an offset.

P

Type: DPoint

A DPoint object representing a matrix offset.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMatrix Class
CADMatrix Members


CADMatrix.MatXMat Method

Multiplies two matrixes.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function MatXMat( _
   ByVal A As CADMatrix, _
   ByVal B As CADMatrix _
) As CADMatrix
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static CADMatrix MatXMat(
   CADMatrix A,
   CADMatrix B
)
This language is not supported or no code example is available.

Parameters

A

Type: CADMatrix

A CADMatrix object representing a first matrix to be multiplied.

B

Type: CADMatrix

A CADMatrix object representing a second matrix to be multiplied.

Return Value

A CADMatrix object.
Remarks

When multiplying two matrixes an order of multiplying affects the result.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMatrix Class
CADMatrix Members


CADMatrix.Part Method

for internal use.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub Part( _
   ByVal I As Integer, _
   ByVal A As DPoint, _
   ByVal Result As CADMatrix _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void Part(
   int I,
   DPoint A,
   CADMatrix Result
)
This language is not supported or no code example is available.

Parameters

I

Type: int

A

Type: DPoint

Result

Type: CADMatrix

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMatrix Class
CADMatrix Members


CADMatrix.PtXMat Method

Multiplies a vector and the matrix.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function PtXMat( _
   ByVal P As DPoint _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint PtXMat(
   DPoint P
)
This language is not supported or no code example is available.

Parameters

P

Type: DPoint

A DPoint object representing a value to be multiplied.

Return Value

A DPoint object representing a result of multiplication.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMatrix Class
CADMatrix Members


CADMatrix.Scale Method

Returns a scaled CADMatrix.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Scale( _
   ByVal scale As DPoint _
) As CADMatrix
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADMatrix Scale(
   DPoint scale
)
This language is not supported or no code example is available.

Parameters

scale

Type: DPoint

A scale value

Return Value

The scaled matrix.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMatrix Class
CADMatrix Members


CADMatrix.StdMat Method

Creates a matrix based on the specified scale and offset.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function StdMat( _
   ByVal S As DPoint, _
   ByVal P As DPoint _
) As CADMatrix
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static CADMatrix StdMat(
   DPoint S,
   DPoint P
)
This language is not supported or no code example is available.

Parameters

S

Type: DPoint

A DPoint object representing the specified scale.

P

Type: DPoint

A DPoint object representing the specified offset.

Return Value

A CADMatrix object.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMatrix Class
CADMatrix Members


CADMatrix.Translate Method

Applies an offset to the CADMatrix.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Translate( _
   ByVal offset As DPoint _
) As CADMatrix
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADMatrix Translate(
   DPoint offset
)
This language is not supported or no code example is available.

Parameters

offset

Type: DPoint

An offset value.

Return Value

The transformed matrix.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMatrix Class
CADMatrix Members


CADMatrix.Transpose Method

Calculates the transpose of this CADMatrix instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Transpose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Transpose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMatrix Class
CADMatrix Members


CADMatrix Fields

CADMatrix Class See Also

The following tables list the members exposed by the CADMatrix type.

Fields
Name | Description
Identity | Represent a default matrix.
Top
See Also

Reference

CADMatrix Class


Identity Field

Represent a default matrix.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared ReadOnly Identity As CADMatrix
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static readonly CADMatrix Identity
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADMatrix Class
CADMatrix Members


CADOLE2Frame Class

Members See Also

Represents an OLE object in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADOLE2Frame
    Inherits CADCustomVertex
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADOLE2Frame : CADCustomVertex
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADCustomVertex
CADImport.CADOLE2Frame
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADOLE2Frame Members


CADOLE2Frame Members

CADOLE2Frame Class Constructors Methods Fields Properties See Also

Represents an OLE object in a CAD image.

The following tables list the members exposed by the CADOLE2Frame type.

Constructors
 | Name | Description
Public constructor | CADOLE2Frame | Initializes a new instance of the CADOLE2Frame class.
Top
Properties
 | Name | Description
Public property | Aspect | Gets or sets a value indicating a way the CADOLE2Frame object is shown on a CAD image.
Public property | Box | Gets or sets a three-dimensional box that encloses this CADOLE2Frame.
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADOLE2Frame entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Point | Gets or sets a position of the CADCustomVertex object.
Public property | Point1 | Gets or sets a second point that specifies the size and position of the CADOLE2Frame object on a CAD image.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADOLE2Frame entity to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADOLE2Frame Class


CADOLE2Frame Constructor

Initializes a new instance of the CADOLE2Frame class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADOLE2Frame()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADOLE2Frame Class
CADOLE2Frame Members


CADOLE2Frame Properties

CADOLE2Frame Class See Also

The following tables list the members exposed by the CADOLE2Frame type.

Properties
 | Name | Description
Public property | Aspect | Gets or sets a value indicating a way the CADOLE2Frame object is shown on a CAD image.
Public property | Box | Gets or sets a three-dimensional box that encloses this CADOLE2Frame.
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADOLE2Frame entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Point | Gets or sets a position of the CADCustomVertex object.
Public property | Point1 | Gets or sets a second point that specifies the size and position of the CADOLE2Frame object on a CAD image.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
See Also

Reference

CADOLE2Frame Class


CADOLE2Frame.Aspect Property

Gets or sets a value indicating a way the CADOLE2Frame object is shown on a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Aspect() As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte Aspect {get; set;}
This language is not supported or no code example is available.
Remarks

There are two possible ways of displaying the CADOLE2Frame object: as a document of the OLE application, or as an icon of this application.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADOLE2Frame Class
CADOLE2Frame Members


CADOLE2Frame.Box Property

Gets or sets a three-dimensional box that encloses this CADOLE2Frame.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Box() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override DRect Box {get;}
This language is not supported or no code example is available.

Property Value

A DRect object representing the enclosing box for this CADOLE2Frame.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADOLE2Frame Class
CADOLE2Frame Members


CADOLE2Frame.EntType Property

Gets the type of this CADOLE2Frame entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADOLE2Frame Class
CADOLE2Frame Members


CADOLE2Frame.Point Property

Gets or sets a position of the CADCustomVertex object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Point() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override DPoint Point {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object that specifies a position of the CADCustomVertex entity in three-dimensional space.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADOLE2Frame Class
CADOLE2Frame Members


CADOLE2Frame.Point1 Property

Gets or sets a second point that specifies the size and position of the CADOLE2Frame object on a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Point1() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Point1 {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object representing the second point that specifies the size and position of the CADOLE2Frame object on a CAD image.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADOLE2Frame Class
CADOLE2Frame Members


CADOLE2Frame Methods

CADOLE2Frame Class See Also

The following tables list the members exposed by the CADOLE2Frame type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADOLE2Frame entity to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADOLE2Frame Class


CADOLE2Frame.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADOLE2Frame Class
CADOLE2Frame Members


CADOLE2Frame.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADOLE2Frame Class
CADOLE2Frame Members


CADOLE2Frame.Loaded Method

Loads this CADOLE2Frame entity to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADOLE2Frame entity is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADOLE2Frame Class
CADOLE2Frame Members


CADOLE2Frame Fields

CADOLE2Frame Class See Also

The following tables list the members exposed by the CADOLE2Frame type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADOLE2Frame Class


CADObjectEntity Class

Members See Also

Provides a common functionality for all CAD entities, visual and not visual.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADObjectEntity
    Inherits CADEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADObjectEntity : CADEntity
This language is not supported or no code example is available.
Remarks

The examples of not visual CAD entities are CADLayer and CADLayout.

Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADImageDef
CADImport.CADPlotEntity
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADObjectEntity Members


CADObjectEntity Members

CADObjectEntity Class Constructors Methods Fields Properties See Also

Provides a common functionality for all CAD entities, visual and not visual.

The following tables list the members exposed by the CADObjectEntity type.

Constructors
 | Name | Description
Public constructor | CADObjectEntity | Initializes an object of the CADObjectEntity class.
Top
Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity.
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer containing this CADEntity. (inherited from CADEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADEntity is visible. (inherited from CADEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADObjectEntity Class


CADObjectEntity Properties

CADObjectEntity Class See Also

The following tables list the members exposed by the CADObjectEntity type.

Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity.
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer containing this CADEntity. (inherited from CADEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADEntity is visible. (inherited from CADEntity).
Top
See Also

Reference

CADObjectEntity Class


CADObjectEntity Methods

CADObjectEntity Class See Also

The following tables list the members exposed by the CADObjectEntity type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADObjectEntity Class


CADObjectEntity.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADObjectEntity Class
CADObjectEntity Members


CADObjectEntity.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADObjectEntity Class
CADObjectEntity Members


CADObjectEntity Fields

CADObjectEntity Class See Also

The following tables list the members exposed by the CADObjectEntity type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADObjectEntity Class


CADPainter<T> Class

Members See Also

Implements basic drawing methods.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public MustInherit Class CADPainter(Of  _
   T As New)
    Inherits CADPresenter
    Implements IDrawSimple(Of T), _
               IMathOperations(Of T)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public abstract class CADPainter<T> : CADPresenter,
   IDrawSimple<T>,
   IMathOperations<T>
   where T : new()
This language is not supported or no code example is available.

Type Parameters

T

Inheritance Hierarchy
System.Object
CADImport.CADPresenter
CADImport.CADPainter<T>
CADImport.CADGraphics2D<T>
CADImport.CADGraphicsOpenGL
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPainter<T> Members


CADPainter<T> Members

CADPainter<T> Class Methods Properties See Also

Implements basic drawing methods.

The following tables list the members exposed by the CADPainter<T> type.

Properties
 | Name | Description
Public property | DrawMatrix | (inherited from CADPresenter).
Public property | DrawTarget | Represents a surface for visualization (inherited from CADPresenter).
Public property | Image | Gets or sets a CADImage for visualization (inherited from CADPresenter).
Public property | RenderMode | Gets or sets rendering mode. (inherited from CADPresenter).
Public property | Settings | Gets a set of settings for visualization. (inherited from CADPresenter).
Public property | UseDoubleBuffering | Outdated. Does Nothing. (inherited from CADPresenter).
Public property | VisibleBox | Gets a rectangular area that will be visualized.
Top
Methods
 | Name | Description
Public method | Add_T | (Overloaded) Performs addition of two points.
Public method | ApplyScale | Calculates a matrix for drawing based on current scale.
Public method | ClearMarkers | Clears a collection of markers. (inherited from CADPresenter).
Public method | ConvertTo_T | Converts a DPoint object.
Public method | Dispose | For inheritance.
Public method | DoFinish | Finishes drawing an entity.
Public method | Draw | (Overloaded) Draws a CADImage.
Public method | DrawEntities | Invokes drawing method for specified entities if they are visible
Public method | DrawEntity | Draws a specified CAD entity in the current CAD image.
Public method | DrawImage | (Overloaded) Draws a raster image or a metafile object.
Public method | DrawLine | (Overloaded) Draws a polyline by two specified points.
Public method | DrawPixel | (Overloaded) Draws a single pixel
Public method | DrawPolyPolyLine | (Overloaded) Draws a set of lines or a set of polygons
Public method | DrawPolyline | (Overloaded) Draws a polyline
Public method | DrawString | (Overloaded) Draws a text string.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportToMetafile | (Overloaded) Exports a CAD drawing to Windows Enhanced metafile.
Public method | FillPolyPolyLine | (Overloaded) Draws a filled polygons.
Public method | FillPolyline | (Overloaded) Draws a filled polyline.
Public method | GetExtents | Calculates the current dimensions of the CADImage. (inherited from CADPresenter).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetPoint | Transforms a three-dimensional CAD point into a two-dimensional screen point.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IsEqual_T | (Overloaded) Checks if two points are equal.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from CADPresenter).
Public method | RotToView | Rotates a CAD image to get a specified view. (inherited from CADPresenter).
Public method | Rotate | Rotates objects in the current drawing. (inherited from CADPresenter).
Public method | SaveImageToClipboard | (Overloaded) Writes a visible part of the current CAD image to the clipboard as a raster image. (inherited from CADPresenter).
Public method | SaveToFile | (Overloaded) Writes a visible part of the current CAD image to the disk as a raster image. (inherited from CADPresenter).
Public method | SaveToStream | (Overloaded) Writes a visible part of the current CAD image to the specified stream as a raster image. (inherited from CADPresenter).
Public method | Sub_T | (Overloaded) Performs subtraction of two points.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADPainter<T> Class


CADPainter<T> Properties

CADPainter<T> Class See Also

The following tables list the members exposed by the CADPainter<T> type.

Properties
 | Name | Description
Public property | DrawMatrix | (inherited from CADPresenter).
Public property | DrawTarget | Represents a surface for visualization (inherited from CADPresenter).
Public property | Image | Gets or sets a CADImage for visualization (inherited from CADPresenter).
Public property | RenderMode | Gets or sets rendering mode. (inherited from CADPresenter).
Public property | Settings | Gets a set of settings for visualization. (inherited from CADPresenter).
Public property | UseDoubleBuffering | Outdated. Does Nothing. (inherited from CADPresenter).
Public property | VisibleBox | Gets a rectangular area that will be visualized.
Top
See Also

Reference

CADPainter<T> Class


CADPainter<T> Methods

CADPainter<T> Class See Also

The following tables list the members exposed by the CADPainter<T> type.

Methods
 | Name | Description
Public method | Add_T | (Overloaded) Performs addition of two points.
Public method | ApplyScale | Calculates a matrix for drawing based on current scale.
Public method | ClearMarkers | Clears a collection of markers. (inherited from CADPresenter).
Public method | ConvertTo_T | Converts a DPoint object.
Public method | Dispose | For inheritance.
Public method | DoFinish | Finishes drawing an entity.
Public method | Draw | (Overloaded) Draws a CADImage.
Public method | DrawEntities | Invokes drawing method for specified entities if they are visible
Public method | DrawEntity | Draws a specified CAD entity in the current CAD image.
Public method | DrawImage | (Overloaded) Draws a raster image or a metafile object.
Public method | DrawLine | (Overloaded) Draws a polyline by two specified points.
Public method | DrawPixel | (Overloaded) Draws a single pixel
Public method | DrawPolyPolyLine | (Overloaded) Draws a set of lines or a set of polygons
Public method | DrawPolyline | (Overloaded) Draws a polyline
Public method | DrawString | (Overloaded) Draws a text string.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportToMetafile | (Overloaded) Exports a CAD drawing to Windows Enhanced metafile.
Public method | FillPolyPolyLine | (Overloaded) Draws a filled polygons.
Public method | FillPolyline | (Overloaded) Draws a filled polyline.
Public method | GetExtents | Calculates the current dimensions of the CADImage. (inherited from CADPresenter).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetPoint | Transforms a three-dimensional CAD point into a two-dimensional screen point.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IsEqual_T | (Overloaded) Checks if two points are equal.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from CADPresenter).
Public method | RotToView | Rotates a CAD image to get a specified view. (inherited from CADPresenter).
Public method | Rotate | Rotates objects in the current drawing. (inherited from CADPresenter).
Public method | SaveImageToClipboard | (Overloaded) Writes a visible part of the current CAD image to the clipboard as a raster image. (inherited from CADPresenter).
Public method | SaveToFile | (Overloaded) Writes a visible part of the current CAD image to the disk as a raster image. (inherited from CADPresenter).
Public method | SaveToStream | (Overloaded) Writes a visible part of the current CAD image to the specified stream as a raster image. (inherited from CADPresenter).
Public method | Sub_T | (Overloaded) Performs subtraction of two points.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADPainter<T> Class


CADPenEntity Class

Members See Also

Represents a base class for all CAD entities that use Pen object for its drawing.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADPenEntity
    Inherits CADPlotEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADPenEntity : CADPlotEntity
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.CADPenLine
CADImport.CADPenTableItem
CADImport.CADViewPort
CADImport.FlatEntity
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPenEntity Members


CADPenEntity Members

CADPenEntity Class Constructors Methods Fields Properties See Also

Represents a base class for all CAD entities that use Pen object for its drawing.

The following tables list the members exposed by the CADPenEntity type.

Constructors
 | Name | Description
Public constructor | CADPenEntity | Initializes a new instance of the CADPenEntity class.
Top
Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity.
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADPlotEntity).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADPenEntity Class


CADPenEntity Properties

CADPenEntity Class See Also

The following tables list the members exposed by the CADPenEntity type.

Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity.
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object
Top
See Also

Reference

CADPenEntity Class


CADPenEntity Methods

CADPenEntity Class See Also

The following tables list the members exposed by the CADPenEntity type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADPlotEntity).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADPenEntity Class


CADPenEntity.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPenEntity Class
CADPenEntity Members


CADPenEntity Fields

CADPenEntity Class See Also

The following tables list the members exposed by the CADPenEntity type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADPenEntity Class


CADPenLine Class

Members See Also

Represents a base class for the CADLine and CADPolyPolygon classes.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADPenLine
    Inherits CADPenEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADPenLine : CADPenEntity
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.CADPenLine
CADImport.CADLine
CADImport.CADPolylineBase
CADImport.CADProxy
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPenLine Members


CADPenLine Members

CADPenLine Class Constructors Methods Fields Properties See Also

Represents a base class for the CADLine and CADPolyPolygon classes.

The following tables list the members exposed by the CADPenLine type.

Constructors
 | Name | Description
Public constructor | CADPenLine | Initializes a new instance of the CADPenLine class.
Top
Properties
 | Name | Description
Public property | Box | Gets a default three-dimensional box that encloses the CADPenLine entity.
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object.
Public property | LineTypeName | Gets a name of line type for this CADPenLine object
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object.
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity.
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity.
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness.
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADPenLine entity to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADPenLine Class


CADPenLine Constructor

Initializes a new instance of the CADPenLine class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADPenLine()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPenLine Class
CADPenLine Members


CADPenLine Properties

CADPenLine Class See Also

The following tables list the members exposed by the CADPenLine type.

Properties
 | Name | Description
Public property | Box | Gets a default three-dimensional box that encloses the CADPenLine entity.
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object.
Public property | LineTypeName | Gets a name of line type for this CADPenLine object
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object.
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity.
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity.
Top
See Also

Reference

CADPenLine Class


CADPenLine.Box Property

Gets a default three-dimensional box that encloses the CADPenLine entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Box() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override DRect Box {get;}
This language is not supported or no code example is available.

Property Value

A DRect object representing the enclosing box for the CADPenLine entity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPenLine Class
CADPenLine Members


CADPenLine Methods

CADPenLine Class See Also

The following tables list the members exposed by the CADPenLine type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness.
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADPenLine entity to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADPenLine Class


CADPenLine.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPenLine Class
CADPenLine Members


CADPenLine.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPenLine Class
CADPenLine Members


CADPenLine.Loaded Method

Loads this CADPenLine entity to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADPenLine entity is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPenLine Class
CADPenLine Members


CADPenLine Fields

CADPenLine Class See Also

The following tables list the members exposed by the CADPenLine type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADPenLine Class


CADPenTableItem Class

Members See Also

Represents a table item for all entities organized in tables in a CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADPenTableItem
    Inherits CADPenEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADPenTableItem : CADPenEntity
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.CADPenTableItem
CADImport.CADBlockRecord
CADImport.CADDimensionStyle
CADImport.CADLayer
CADImport.CADLineType
CADImport.CADStyle
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPenTableItem Members


CADPenTableItem Members

CADPenTableItem Class Constructors Methods Fields Properties See Also

Represents a table item for all entities organized in tables in a CAD file.

The following tables list the members exposed by the CADPenTableItem type.

Constructors
 | Name | Description
Public constructor | CADPenTableItem | Initializes a new instance of the CADPenEntity class. (inherited from CADPenEntity).
Top
Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | EntName | Gets a name of this CADPenTableItem.
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Flags | Gets or sets a drawing flags.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Name | Gets or sets a name of the CADPenTableItem.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADPenTableItem Class


CADPenTableItem Properties

CADPenTableItem Class See Also

The following tables list the members exposed by the CADPenTableItem type.

Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | EntName | Gets a name of this CADPenTableItem.
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Flags | Gets or sets a drawing flags.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Name | Gets or sets a name of the CADPenTableItem.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Top
See Also

Reference

CADPenTableItem Class


CADPenTableItem Methods

CADPenTableItem Class See Also

The following tables list the members exposed by the CADPenTableItem type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADPenTableItem Class


CADPenTableItem Fields

CADPenTableItem Class See Also

The following tables list the members exposed by the CADPenTableItem type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADPenTableItem Class


CADPlotEntity Class

Members See Also

Provides a common functionality for all visual CAD entities.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADPlotEntity
    Inherits CADObjectEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADPlotEntity : CADObjectEntity
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADCustomVertex
CADImport.CADGroup
CADImport.CADLayout
CADImport.CADPenEntity
CADImport.CADPolyPolygon
CADImport.CADXRef
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPlotEntity Members


CADPlotEntity Members

CADPlotEntity Class Constructors Methods Fields Properties See Also

Provides a common functionality for all visual CAD entities.

The following tables list the members exposed by the CADPlotEntity type.

Constructors
 | Name | Description
Public constructor | CADPlotEntity | Initializes an object of the CADPlotEntity class.
Top
Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to.
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length.
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible.
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to.
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADPlotEntity Class


CADPlotEntity Properties

CADPlotEntity Class See Also

The following tables list the members exposed by the CADPlotEntity type.

Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to.
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length.
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible.
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to.
Top
See Also

Reference

CADPlotEntity Class


CADPlotEntity Methods

CADPlotEntity Class See Also

The following tables list the members exposed by the CADPlotEntity type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADPlotEntity Class


CADPlotEntity Fields

CADPlotEntity Class See Also

The following tables list the members exposed by the CADPlotEntity type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADPlotEntity Class


CADPoint Class

Members See Also

Represents a point in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADPoint
    Inherits CADCustomVertex
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADPoint : CADCustomVertex
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADCustomVertex
CADImport.CADPoint
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPoint Members


CADPoint Members

CADPoint Class Constructors Methods Fields Properties See Also

Represents a point in a CAD image.

The following tables list the members exposed by the CADPoint type.

Constructors
 | Name | Description
Public constructor | CADPoint | Initializes a new instance of the CADPoint class.
Top
Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses the CADPoint object.
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets a type of this CADPoint entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPoint object.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPoint.
Public property | Point | Gets or sets a position of the CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Points | Gets a collection of points for drawing CADPoint object.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible.
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | ZThick | Gets or sets a CADPoint entity thickness.
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADPlotEntity).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADPoint must be drawn during a drawing cycle.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADPoint to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADPoint Class


CADPoint Constructor

Example See Also

Initializes a new instance of the CADPoint class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADPoint()
This language is not supported or no code example is available.
Example
<p>Creating a new CADPoint object example:</p> <p>[C#]</p>
Copy
 CreateNewImage();
 Point p1 = new Point(200, 200);
 CADPoint point = new CADPoint();
 point.Color = CADConst.clNone;
 point.Point = GetRealPoint(p1.X, p1.Y);
 point.LineWeight = 0.1;
 cadImage.Converter.OnCreate(point);
 point.Handle = point.GetHashCode();
 point.KeyEnt = point.Handle.ToString();
 cadImage.Converter.OnCreate(point);
 cadImage.CurrentLayout.Entities.Add(point);
 EditorCADPictureBox.Invalidate();
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPoint Class
CADPoint Members
CADImport Namespace
CADImage
CADPoint
DPoint
clNone


CADPoint Properties

CADPoint Class See Also

The following tables list the members exposed by the CADPoint type.

Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses the CADPoint object.
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets a type of this CADPoint entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPoint object.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPoint.
Public property | Point | Gets or sets a position of the CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Points | Gets a collection of points for drawing CADPoint object.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible.
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | ZThick | Gets or sets a CADPoint entity thickness.
Top
See Also

Reference

CADPoint Class


CADPoint.Box Property

Gets a three-dimensional box that encloses the CADPoint object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Box() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override DRect Box {get;}
This language is not supported or no code example is available.

Property Value

A DRect object representing the enclosing box for the CADPoint entity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPoint Class
CADPoint Members


CADPoint.EntType Property

Gets a type of this CADPoint entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPoint Class
CADPoint Members


CADPoint.Extrusion Property

Gets or sets a direction of axis Z belonging to the coordinate system of this CADPoint object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Extrusion() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Extrusion {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object specifying a direction of axis Z belonging to the coordinate system of this CADPoint object.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPoint Class
CADPoint Members


CADPoint.LineWeight Property

Gets or sets a thickness of lines for this CADPoint.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property LineWeight() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override double LineWeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPoint Class
CADPoint Members


CADPoint.Points Property

Gets a collection of points for drawing CADPoint object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Points() As ArrayList
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ArrayList Points {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPoint Class
CADPoint Members


CADPoint.Visibility Property

Gets or sets a value indicating whether a CADPlotEntity is visible.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Visibility() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool Visibility {get; set;}
This language is not supported or no code example is available.

Property Value

true if a CADPlotEntity is visible; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPoint Class
CADPoint Members


CADPoint.ZThick Property

Gets or sets a CADPoint entity thickness.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ZThick() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float ZThick {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPoint Class
CADPoint Members


CADPoint Methods

CADPoint Class See Also

The following tables list the members exposed by the CADPoint type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADPlotEntity).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADPoint must be drawn during a drawing cycle.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADPoint to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADPoint Class


CADPoint.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPoint Class
CADPoint Members


CADPoint.DrawEntityTrace Method

Implements drawing of entity with specified offset to specified Control

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub DrawEntityTrace( _
   ByVal dx As Integer, _
   ByVal dy As Integer, _
   ByVal img As CADImage, _
   ByVal control As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void DrawEntityTrace(
   int dx,
   int dy,
   CADImage img,
   Control control
)
This language is not supported or no code example is available.

Parameters

dx

Type: int

X axis offset

dy

Type: int

Y axis offset

img

Type: CADImage

CADImage object for getting display coordinates of the entity

control

Type: Control

Control for drawing of Entity

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPoint Class
CADPoint Members


CADPoint.GetBoxPoints Method

Checks if the CADPoint must be drawn during a drawing cycle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function GetBoxPoints( _
   ByVal Proc As FPointProc, _
   ByVal Full As Boolean _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool GetBoxPoints(
   FPointProc Proc,
   bool Full
)
This language is not supported or no code example is available.

Parameters

Proc

Type: FPointProc

A FPointProc delegate that references methods for getting CADPoint.

Full

Type: bool

A boolean value indicating whether the method realizes full or reduced checking. true if checking is full, false if checking is reduced.

Return Value

true if all points passed to the referenced method are real entity's points; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPoint Class
CADPoint Members


CADPoint.Loaded Method

Loads this CADPoint to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADPoint is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPoint Class
CADPoint Members


CADPoint Fields

CADPoint Class See Also

The following tables list the members exposed by the CADPoint type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADPoint Class


CADPolyLine Class

Members See Also

Represents objects composed of the connected lines and bulge segments.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADPolyLine
    Inherits CADPolylineBase
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADPolyLine : CADPolylineBase
This language is not supported or no code example is available.
Remarks

A CADPolyLine object is specified by an array of vertices connected by lines and bulges.

Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.CADPenLine
CADImport.CADPolylineBase
CADImport.CADPolyLine
CADImport.CADLWPolyLine
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyLine Members


CADPolyLine Members

CADPolyLine Class Constructors Methods Fields Properties See Also

Represents objects composed of the connected lines and bulge segments.

The following tables list the members exposed by the CADPolyLine type.

Constructors
 | Name | Description
Public constructor | CADPolyLine | Initializes a new instance of the CADPolyLine class.
Top
Properties
 | Name | Description
Public property | Arrows | Gets or sets a collection of points that specify an arrow shape for the CADPolyLine segments.
Public property | Box | Gets or sets a three-dimensional box that encloses the CADPolyLine.
Public property | Closed | Gets or sets a value indicating whether this CADPolyLine is closed. (inherited from CADPolylineBase).
Public property | Color | Gets or sets a color for the given CADPolyLine entity.
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the specified CADPolyLine object.
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | DottedSingPoints | Gets a collection of points that specify the dots and dashes of the CADPolylineBase. (inherited from CADPolylineBase).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADPolyLine entity.
Public property | Entities | Gets a collection of CAD entities belonging to the given CADPolyLine.
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Flags | Gets or sets a number that specifies an appearance of this CADPolylineBase entity. (inherited from CADPolylineBase).
Public property | GlobalWidth | Gets or sets a width for all parts of the CADPolyLine.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | IsMeshMClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the M direction. (inherited from CADPolylineBase).
Public property | IsMeshNClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the N direction. (inherited from CADPolylineBase).
Public property | IsPlinegen |
Public property | IsPolyFaceMesh | Gets a value indicating whether this CADPolyLine represents a polyface mesh.
Public property | IsPolyZThickness | Gets a value indicating whether a line thickness measured along the axis Z is equal to 0. (inherited from CADPolylineBase).
Public property | IsPolygonMesh | Gets a value indicating whether this CADPolyLine represents a polygon mesh.
Public property | Layer | Gets or sets a layer containing this CADPolyLine.
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of the lines for this CADPolyLine.
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | MeshM | Gets or sets a number of vertices traversed in a polygon mesh in M direction.
Public property | MeshN | Gets or sets a number of vertices traversed in a polygon mesh in N direction.
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADPenLine).
Public property | PolyFaceVertexIndexes | Gets a list of indices specifying an order of traversing vertices of this polyface mesh.
Public property | PolyLineEntities | Gets a collection of entities included in this CADPolyLine.
Public property | PolyPoints | Gets a collection of points belonging to the polyline. (inherited from CADPolylineBase).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Vertexes | Gets a collection of vertices of this CADPolyLine.
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADPolyLine.
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | ApplyBox | Calculates a box of the current entity.
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of an entity with specified offset to specified Control
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Used in drawing cycle for fast checking whether the entity must be drawn (inherited from CADPolylineBase).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADPolylineBase to the specified CADConverter. (inherited from CADPolylineBase).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADPolyLine Class


CADPolyLine Properties

CADPolyLine Class See Also

The following tables list the members exposed by the CADPolyLine type.

Properties
 | Name | Description
Public property | Arrows | Gets or sets a collection of points that specify an arrow shape for the CADPolyLine segments.
Public property | Box | Gets or sets a three-dimensional box that encloses the CADPolyLine.
Public property | Closed | Gets or sets a value indicating whether this CADPolyLine is closed. (inherited from CADPolylineBase).
Public property | Color | Gets or sets a color for the given CADPolyLine entity.
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the specified CADPolyLine object.
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | DottedSingPoints | Gets a collection of points that specify the dots and dashes of the CADPolylineBase. (inherited from CADPolylineBase).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADPolyLine entity.
Public property | Entities | Gets a collection of CAD entities belonging to the given CADPolyLine.
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Flags | Gets or sets a number that specifies an appearance of this CADPolylineBase entity. (inherited from CADPolylineBase).
Public property | GlobalWidth | Gets or sets a width for all parts of the CADPolyLine.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | IsMeshMClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the M direction. (inherited from CADPolylineBase).
Public property | IsMeshNClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the N direction. (inherited from CADPolylineBase).
Public property | IsPlinegen |
Public property | IsPolyFaceMesh | Gets a value indicating whether this CADPolyLine represents a polyface mesh.
Public property | IsPolyZThickness | Gets a value indicating whether a line thickness measured along the axis Z is equal to 0. (inherited from CADPolylineBase).
Public property | IsPolygonMesh | Gets a value indicating whether this CADPolyLine represents a polygon mesh.
Public property | Layer | Gets or sets a layer containing this CADPolyLine.
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of the lines for this CADPolyLine.
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | MeshM | Gets or sets a number of vertices traversed in a polygon mesh in M direction.
Public property | MeshN | Gets or sets a number of vertices traversed in a polygon mesh in N direction.
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADPenLine).
Public property | PolyFaceVertexIndexes | Gets a list of indices specifying an order of traversing vertices of this polyface mesh.
Public property | PolyLineEntities | Gets a collection of entities included in this CADPolyLine.
Public property | PolyPoints | Gets a collection of points belonging to the polyline. (inherited from CADPolylineBase).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Vertexes | Gets a collection of vertices of this CADPolyLine.
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
See Also

Reference

CADPolyLine Class


CADPolyLine.EntType Property

Gets the type of this CADPolyLine entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyLine Class
CADPolyLine Members


CADPolyLine Methods

CADPolyLine Class See Also

The following tables list the members exposed by the CADPolyLine type.

Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADPolyLine.
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | ApplyBox | Calculates a box of the current entity.
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of an entity with specified offset to specified Control
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Used in drawing cycle for fast checking whether the entity must be drawn (inherited from CADPolylineBase).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADPolylineBase to the specified CADConverter. (inherited from CADPolylineBase).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADPolyLine Class


CADPolyLine Fields

CADPolyLine Class See Also

The following tables list the members exposed by the CADPolyLine type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADPolyLine Class


CADPolyPolygon Class

Members See Also

Represents a simple hatch with a border shaped as polyline.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADPolyPolygon
    Inherits CADPlotEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADPolyPolygon : CADPlotEntity
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPolyPolygon
CADImport.CADGradientPolygon
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyPolygon Members


CADPolyPolygon Members

CADPolyPolygon Class Constructors Methods Fields Properties See Also

Represents a simple hatch with a border shaped as polyline.

The following tables list the members exposed by the CADPolyPolygon type.

Constructors
 | Name | Description
Public constructor | CADPolyPolygon | Initializes a new instance of the CADPolyPolygon class.
Top
Properties
 | Name | Description
Public property | Boundaries | Gets a collection of boundaries of this CADPolyPolygon.
Public property | Box | Gets a three-dimensional box that encloses this CADPolyPolygon.
Public property | Color | Gets or sets a color of this CADPolyPolygon.
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets a type of this CADPolyPolygon entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Filled |
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible.
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Destroy | Clears a collection of this CADPolyPolygon boundaries.
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADPolyPolygon must be drawn during a drawing cycle.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADPolyPolygon to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADPolyPolygon Class


CADPolyPolygon Properties

CADPolyPolygon Class See Also

The following tables list the members exposed by the CADPolyPolygon type.

Properties
 | Name | Description
Public property | Boundaries | Gets a collection of boundaries of this CADPolyPolygon.
Public property | Box | Gets a three-dimensional box that encloses this CADPolyPolygon.
Public property | Color | Gets or sets a color of this CADPolyPolygon.
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets a type of this CADPolyPolygon entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Filled |
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible.
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
See Also

Reference

CADPolyPolygon Class


CADPolyPolygon.EntType Property

Gets a type of this CADPolyPolygon entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyPolygon Class
CADPolyPolygon Members


CADPolyPolygon Methods

CADPolyPolygon Class See Also

The following tables list the members exposed by the CADPolyPolygon type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Destroy | Clears a collection of this CADPolyPolygon boundaries.
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADPolyPolygon must be drawn during a drawing cycle.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADPolyPolygon to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADPolyPolygon Class


CADPolyPolygon.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyPolygon Class
CADPolyPolygon Members


CADPolyPolygon.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolyPolygon Class
CADPolyPolygon Members


CADPolyPolygon Fields

CADPolyPolygon Class See Also

The following tables list the members exposed by the CADPolyPolygon type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADPolyPolygon Class


CADPolylineBase Class

Members See Also

Represents a base class for CADCircle,CADArc,CADPolyline,CADWipeout,CADSpline.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public MustInherit Class CADPolylineBase
    Inherits CADPenLine
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public abstract class CADPolylineBase : CADPenLine
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.CADPenLine
CADImport.CADPolylineBase
CADImport.CADCircle
CADImport.CADPolyLine
CADImport.CADSpline
CADImport.CADWipeout
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolylineBase Members


CADPolylineBase Members

CADPolylineBase Class Constructors Methods Fields Properties See Also

Represents a base class for CADCircle,CADArc,CADPolyline,CADWipeout,CADSpline.

The following tables list the members exposed by the CADPolylineBase type.

Constructors
 | Name | Description
Public constructor | CADPolylineBase | Default constructor.
Top
Properties
 | Name | Description
Public property | Box | Return box of the current primitive.
Public property | Closed | Gets or sets a value indicating whether this CADPolyLine is closed.
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADPolylineBase.
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | DottedSingPoints | Gets a collection of points that specify the dots and dashes of the CADPolylineBase.
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Flags | Gets or sets a number that specifies an appearance of this CADPolylineBase entity.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | IsMeshMClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the M direction.
Public property | IsMeshNClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the N direction.
Public property | IsPolyFaceMesh | Indicates that the current primitive is mesh.
Public property | IsPolyZThickness | Gets a value indicating whether a line thickness measured along the axis Z is equal to 0.
Public property | IsPolygonMesh | Indicates that the current primitive is mesh.
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADPenLine).
Public property | PolyPoints | Gets a collection of points belonging to the polyline.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | ApplyBox | Calculates a box of the current entity.
Public method | AssignEntity | Assign given primitive to current primitive.
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Used in drawing cycle for fast checking whether the entity must be drawn
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADPolylineBase to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADPolylineBase Class


CADPolylineBase Constructor

Default constructor.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADPolylineBase()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolylineBase Class
CADPolylineBase Members


CADPolylineBase Properties

CADPolylineBase Class See Also

The following tables list the members exposed by the CADPolylineBase type.

Properties
 | Name | Description
Public property | Box | Return box of the current primitive.
Public property | Closed | Gets or sets a value indicating whether this CADPolyLine is closed.
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADPolylineBase.
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | DottedSingPoints | Gets a collection of points that specify the dots and dashes of the CADPolylineBase.
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Flags | Gets or sets a number that specifies an appearance of this CADPolylineBase entity.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | IsMeshMClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the M direction.
Public property | IsMeshNClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the N direction.
Public property | IsPolyFaceMesh | Indicates that the current primitive is mesh.
Public property | IsPolyZThickness | Gets a value indicating whether a line thickness measured along the axis Z is equal to 0.
Public property | IsPolygonMesh | Indicates that the current primitive is mesh.
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADPenLine).
Public property | PolyPoints | Gets a collection of points belonging to the polyline.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
See Also

Reference

CADPolylineBase Class


CADPolylineBase Methods

CADPolylineBase Class See Also

The following tables list the members exposed by the CADPolylineBase type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | ApplyBox | Calculates a box of the current entity.
Public method | AssignEntity | Assign given primitive to current primitive.
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Used in drawing cycle for fast checking whether the entity must be drawn
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADPolylineBase to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADPolylineBase Class


CADPolylineBase.AssignEntity Method

Assign given primitive to current primitive.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

Given primitive for assignation.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPolylineBase Class
CADPolylineBase Members


CADPolylineBase Fields

CADPolylineBase Class See Also

The following tables list the members exposed by the CADPolylineBase type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADPolylineBase Class


CADPresenter Class

Members See Also

Implements basic drawing methods.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public MustInherit Class CADPresenter
    Implements IDisposable, _
               IDrawSimple(Of DPoint), _
               IMathOperations(Of DPoint)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public abstract class CADPresenter : IDisposable,
   IDrawSimple<DPoint>,
   IMathOperations<DPoint>
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADPresenter
CADImport.CADPainter<T>
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Members


CADPresenter Members

CADPresenter Class Methods Properties See Also

Implements basic drawing methods.

The following tables list the members exposed by the CADPresenter type.

Properties
 | Name | Description
Public property | DrawMatrix |
Public property | DrawTarget | Represents a surface for visualization
Public property | Image | Gets or sets a CADImage for visualization
Public property | RenderMode | Gets or sets rendering mode.
Public property | Settings | Gets a set of settings for visualization.
Public property | UseDoubleBuffering | Outdated. Does Nothing.
Public property | VisibleBox | Gets a rectangular area that will be visualized.
Top
Methods
 | Name | Description
Public method | Add_T | Performs addition of two points.
Public method | ClearMarkers | Clears a collection of markers.
Public method | ConvertTo_T | Converts a DPoint object.
Public method | Dispose | For inheritance.
Public method | Draw | (Overloaded) Draws a CADImage.
Public method | DrawImage | Draws a raster image or a metafile object.
Public method | DrawLine | Draws a polyline by two specified points.
Public method | DrawPixel | Draws a single pixel
Public method | DrawPolyPolyLine | Draws a set of lines or a set of polygons
Public method | DrawPolyline | Draws a polyline
Public method | DrawString | Draws a text string.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FillPolyPolyLine | Draws a filled polygons.
Public method | FillPolyline | Draws a filled polyline.
Public method | GetExtents | Calculates the current dimensions of the CADImage.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IsEqual_T | Checks if two points are equal.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RotDefault | Rotates the drawing to the default view.
Public method | RotToView | Rotates a CAD image to get a specified view.
Public method | Rotate | Rotates objects in the current drawing.
Public method | SaveImageToClipboard | (Overloaded) Writes a visible part of the current CAD image to the clipboard as a raster image.
Public method | SaveToFile | (Overloaded) Writes a visible part of the current CAD image to the disk as a raster image.
Public method | SaveToStream | (Overloaded) Writes a visible part of the current CAD image to the specified stream as a raster image.
Public method | Sub_T | Performs subtraction of two points.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADPresenter Class


CADPresenter Properties

CADPresenter Class See Also

The following tables list the members exposed by the CADPresenter type.

Properties
 | Name | Description
Public property | DrawMatrix |
Public property | DrawTarget | Represents a surface for visualization
Public property | Image | Gets or sets a CADImage for visualization
Public property | RenderMode | Gets or sets rendering mode.
Public property | Settings | Gets a set of settings for visualization.
Public property | UseDoubleBuffering | Outdated. Does Nothing.
Public property | VisibleBox | Gets a rectangular area that will be visualized.
Top
See Also

Reference

CADPresenter Class


CADPresenter.VisibleBox Property

Gets a rectangular area that will be visualized.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overridable Property VisibleBox() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual DRect VisibleBox {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter Methods

CADPresenter Class See Also

The following tables list the members exposed by the CADPresenter type.

Methods
 | Name | Description
Public method | Add_T | Performs addition of two points.
Public method | ClearMarkers | Clears a collection of markers.
Public method | ConvertTo_T | Converts a DPoint object.
Public method | Dispose | For inheritance.
Public method | Draw | (Overloaded) Draws a CADImage.
Public method | DrawImage | Draws a raster image or a metafile object.
Public method | DrawLine | Draws a polyline by two specified points.
Public method | DrawPixel | Draws a single pixel
Public method | DrawPolyPolyLine | Draws a set of lines or a set of polygons
Public method | DrawPolyline | Draws a polyline
Public method | DrawString | Draws a text string.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FillPolyPolyLine | Draws a filled polygons.
Public method | FillPolyline | Draws a filled polyline.
Public method | GetExtents | Calculates the current dimensions of the CADImage.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IsEqual_T | Checks if two points are equal.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RotDefault | Rotates the drawing to the default view.
Public method | RotToView | Rotates a CAD image to get a specified view.
Public method | Rotate | Rotates objects in the current drawing.
Public method | SaveImageToClipboard | (Overloaded) Writes a visible part of the current CAD image to the clipboard as a raster image.
Public method | SaveToFile | (Overloaded) Writes a visible part of the current CAD image to the disk as a raster image.
Public method | SaveToStream | (Overloaded) Writes a visible part of the current CAD image to the specified stream as a raster image.
Public method | Sub_T | Performs subtraction of two points.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADPresenter Class


CADPresenter.Add_T Method

Performs addition of two points.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Function Add_T( _
   ByVal p1 As DPoint, _
   ByVal p2 As DPoint _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual DPoint Add_T(
   DPoint p1,
   DPoint p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: DPoint

p2

Type: DPoint

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.ConvertTo_T Method

Converts a DPoint object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Function ConvertTo_T( _
   ByVal p As DPoint _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual DPoint ConvertTo_T(
   DPoint p
)
This language is not supported or no code example is available.

Parameters

p

Type: DPoint

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.Dispose Method

For inheritance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub Dispose() Implements  _
   IDisposable.Dispose
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.Draw Method

CADPresenter Class See Also

Draws a CADImage.

Overload List
Name | Description
Draw(Graphics, RectangleF) | Draws a CADImage.
Draw(Graphics, RectangleF, Region) | Draws a CADImage.
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.DrawImage Method

Draws a raster image or a metafile object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub DrawImage( _
   ByVal image As Image, _
   ByVal points As DPoint(), _
   ByVal transparent As Boolean, _
   ByVal transparentColor As Color _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void DrawImage(
   Image image,
   DPoint[] points,
   bool transparent,
   Color transparentColor
)
This language is not supported or no code example is available.

Parameters

image

Type: Image

An object of Image derived class

points

Type: DPoint[]

A list of points for a visualization method

transparent

Type: bool

A value specifying image transparency

transparentColor

Type: Color

A transparent color for visualization

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.DrawLine Method

Draws a polyline by two specified points.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub DrawLine( _
   ByVal p1 As DPoint, _
   ByVal p2 As DPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void DrawLine(
   DPoint p1,
   DPoint p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: DPoint

The first point

p2

Type: DPoint

The second point

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.DrawPixel Method

Draws a single pixel

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub DrawPixel( _
   ByVal p As DPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void DrawPixel(
   DPoint p
)
This language is not supported or no code example is available.

Parameters

p

Type: DPoint

A point that will be visualized

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.DrawPolyPolyLine Method

Draws a set of lines or a set of polygons

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub DrawPolyPolyLine( _
   ByVal intPoints As DPoint(), _
   ByVal counts As Integer(), _
   ByVal allClosed As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void DrawPolyPolyLine(
   DPoint[] intPoints,
   int[] counts,
   bool allClosed
)
This language is not supported or no code example is available.

Parameters

intPoints

Type: DPoint[]

The set of points for visualization

counts

Type: int[]

A list of point numbers for figures.

allClosed

Type: bool

A value specifying if visualized figures will be closed

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.DrawPolyline Method

Draws a polyline

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub DrawPolyline( _
   ByVal points As DPoint(), _
   ByVal closed As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void DrawPolyline(
   DPoint[] points,
   bool closed
)
This language is not supported or no code example is available.

Parameters

points

Type: DPoint[]

A list of polyline vertex points

closed

Type: bool

A value specifying if polyline is closed

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.DrawString Method

Draws a text string.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub DrawString( _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal color As Integer, _
   ByVal point As DPoint, _
   ByVal align As CADTextHorizontalAlign _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void DrawString(
   string text,
   Font font,
   int color,
   DPoint point,
   CADTextHorizontalAlign align
)
This language is not supported or no code example is available.

Parameters

text

Type: string

A text

font

Type: Font

A text font

color

Type: int

A text color

point

Type: DPoint

A location point of the text.

align

Type: CADTextHorizontalAlign

A text alignment.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.FillPolyPolyLine Method

Draws a filled polygons.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub FillPolyPolyLine( _
   ByVal intPoints As DPoint(), _
   ByVal counts As Integer() _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void FillPolyPolyLine(
   DPoint[] intPoints,
   int[] counts
)
This language is not supported or no code example is available.

Parameters

intPoints

Type: DPoint[]

The set of points for visualization

counts

Type: int[]

A list of point numbers for figures.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.FillPolyline Method

Draws a filled polyline.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub FillPolyline( _
   ByVal points As DPoint() _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void FillPolyline(
   DPoint[] points
)
This language is not supported or no code example is available.

Parameters

points

Type: DPoint[]

A list of polyline vertex points

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.IsEqual_T Method

Checks if two points are equal.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Function IsEqual_T( _
   ByVal p1 As DPoint, _
   ByVal p2 As DPoint _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual bool IsEqual_T(
   DPoint p1,
   DPoint p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: DPoint

p2

Type: DPoint

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.Sub_T Method

Performs subtraction of two points.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Function Sub_T( _
   ByVal p1 As DPoint, _
   ByVal p2 As DPoint _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual DPoint Sub_T(
   DPoint p1,
   DPoint p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: DPoint

p2

Type: DPoint

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenterSettings Class

Members See Also

Represents a set of settings for the CADPresenter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADPresenterSettings
    Implements ICloneable, _
               IAssign(Of CADPresenterSettings), _
               IDisposable
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADPresenterSettings : ICloneable,
   IAssign<CADPresenterSettings>,
   IDisposable
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADPresenterSettings
CADImport.Export.ExportSettings
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenterSettings Members


CADPresenterSettings Members

CADPresenterSettings Class Constructors Methods Properties See Also

Represents a set of settings for the CADPresenter.

The following tables list the members exposed by the CADPresenterSettings type.

Constructors
 | Name | Description
Public constructor | CADPresenterSettings | (Overloaded) Initializes a new instance of the CADPresenterSettings class.
Top
Properties
 | Name | Description
Public property | BackgroundColor | Gets or sets a background color of this CADImage.
Public property | BorderSize | Gets or sets a border size in pixels.
Public property | BorderType | Gets or sets a border type.
Public property | DefaultAngle | Gets or sets a default color for the CADImage.
Public property | DefaultColor | Gets or sets a default color for the CADImage.
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions on the drawing are visible.
Public property | DrawMode | Gets or sets a current drawing mode.
Public property | IsDraw3DAxes | Gets or sets a value indicating whether 3D axes are shown on the drawing.
Public property | IsShowBackground | Gets or sets a value indicating using of a BackgroundColor.
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data.
Public property | LineScaled | Obsolete. Gets or sets a value indicating whether a width of lines to draw all entities in the drawing is specified by the file data.
Public property | LineWeightScale | Gets or sets a scale for drawing lines.
Public property | NullWidth | Gets or sets default thickness for lines used to draw a CADImage.
Public property | TTFSmoothing | Gets or sets a value indicating whether TTF fonts are smoothed.
Public property | TTFSmoothingStyle | Gets or sets smoothing style for TTF fonts.
Public property | TextVisible | Gets or sets a value indicating whether the texts in the CADImage are visible.
Top
Methods
 | Name | Description
Public method | Assign | Copies the settings from a specified CADPresenterSettings object.
Public method | Clone | Creates a new object that is a copy of the current CADPresenterSettings class instance.
Public method | Dispose |
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RestoreParams | Restores the settings of the CADPresenterSettings.
Public method | SaveParams | Saves the settings of the CADPresenterSettings.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADPresenterSettings Class


CADPresenterSettings Constructor

CADPresenterSettings Class See Also

Initializes a new instance of the CADPresenterSettings class.

Overload List
Name | Description
CADPresenterSettings() | Initializes a new instance of the CADPresenterSettings class.
CADPresenterSettings(CADPresenterSettings) | Initializes a new instance of the CADPresenterSettings class.
See Also

Reference

CADPresenterSettings Class
CADPresenterSettings Members


CADPresenterSettings Properties

CADPresenterSettings Class See Also

The following tables list the members exposed by the CADPresenterSettings type.

Properties
 | Name | Description
Public property | BackgroundColor | Gets or sets a background color of this CADImage.
Public property | BorderSize | Gets or sets a border size in pixels.
Public property | BorderType | Gets or sets a border type.
Public property | DefaultAngle | Gets or sets a default color for the CADImage.
Public property | DefaultColor | Gets or sets a default color for the CADImage.
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions on the drawing are visible.
Public property | DrawMode | Gets or sets a current drawing mode.
Public property | IsDraw3DAxes | Gets or sets a value indicating whether 3D axes are shown on the drawing.
Public property | IsShowBackground | Gets or sets a value indicating using of a BackgroundColor.
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data.
Public property | LineScaled | Obsolete. Gets or sets a value indicating whether a width of lines to draw all entities in the drawing is specified by the file data.
Public property | LineWeightScale | Gets or sets a scale for drawing lines.
Public property | NullWidth | Gets or sets default thickness for lines used to draw a CADImage.
Public property | TTFSmoothing | Gets or sets a value indicating whether TTF fonts are smoothed.
Public property | TTFSmoothingStyle | Gets or sets smoothing style for TTF fonts.
Public property | TextVisible | Gets or sets a value indicating whether the texts in the CADImage are visible.
Top
See Also

Reference

CADPresenterSettings Class


CADPresenterSettings.BackgroundColor Property

Gets or sets a background color of this CADImage.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property BackgroundColor() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int BackgroundColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenterSettings Class
CADPresenterSettings Members


CADPresenterSettings.BorderSize Property

Gets or sets a border size in pixels.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property BorderSize() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double BorderSize {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenterSettings Class
CADPresenterSettings Members


CADPresenterSettings.BorderType Property

Gets or sets a border type.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property BorderType() As CADBorderType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADBorderType BorderType {get; set;}
This language is not supported or no code example is available.

Property Value

One of the CADBorderType values.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenterSettings Class
CADPresenterSettings Members


CADPresenterSettings.DefaultAngle Property

Gets or sets a default color for the CADImage.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DefaultAngle() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float DefaultAngle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenterSettings Class
CADPresenterSettings Members


CADPresenterSettings.DefaultColor Property

Gets or sets a default color for the CADImage.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DefaultColor() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int DefaultColor {get; set;}
This language is not supported or no code example is available.

Property Value

An object of the Color structure. Default value is black.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenterSettings Class
CADPresenterSettings Members


CADPresenterSettings.DimensionsVisible Property

Gets or sets a value indicating whether dimensions on the drawing are visible.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DimensionsVisible() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool DimensionsVisible {get; set;}
This language is not supported or no code example is available.

Property Value

true if the dimensions are visible; otherwise, false. Default value is true.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenterSettings Class
CADPresenterSettings Members


CADPresenterSettings.DrawMode Property

Gets or sets a current drawing mode.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DrawMode() As CADDrawMode
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADDrawMode DrawMode {get; set;}
This language is not supported or no code example is available.

Property Value

One of the CADDrawMode values.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenterSettings Class
CADPresenterSettings Members


CADPresenterSettings.IsDraw3DAxes Property

Gets or sets a value indicating whether 3D axes are shown on the drawing.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property IsDraw3DAxes() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsDraw3DAxes {get; set;}
This language is not supported or no code example is available.

Property Value

true if the 3D axes are shown; otherwise, false. Default value is false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenterSettings Class
CADPresenterSettings Members


CADPresenterSettings.IsShowBackground Property

Gets or sets a value indicating using of a BackgroundColor.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property IsShowBackground() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsShowBackground {get; set;}
This language is not supported or no code example is available.

Property Value

true if a background color is used; otherwise, false. Default value is true.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenterSettings Class
CADPresenterSettings Members


CADPresenterSettings.IsShowLineWeight Property

Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property IsShowLineWeight() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsShowLineWeight {get; set;}
This language is not supported or no code example is available.

Property Value

true if a thickness of lines in the CADImage is determined by the file data; otherwise, false.
Remarks

If this property value is false, a thickness of lines in the CADImage is determined by the NullWidth property.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenterSettings Class
CADPresenterSettings Members


CADPresenterSettings.LineScaled Property

NOTE: This member is now obsolete.use IsShowLineWeight

Gets or sets a value indicating whether a width of lines to draw all entities in the drawing is specified by the file data.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LineScaled() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool LineScaled {get; set;}
This language is not supported or no code example is available.

Property Value

true if a line width is determined by the file data; otherwise, false.
Remarks

If this property returns false a width of lines to draw all CAD entities is specified by the NullWidth property.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenterSettings Class
CADPresenterSettings Members


CADPresenterSettings.LineWeightScale Property

Gets or sets a scale for drawing lines.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LineWeightScale() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double LineWeightScale {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenterSettings Class
CADPresenterSettings Members


CADPresenterSettings.NullWidth Property

Gets or sets default thickness for lines used to draw a CADImage.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property NullWidth() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float NullWidth {get; set;}
This language is not supported or no code example is available.

Property Value

Line thickness. Default value is 1.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenterSettings Class
CADPresenterSettings Members


CADPresenterSettings.TTFSmoothing Property

Gets or sets a value indicating whether TTF fonts are smoothed.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TTFSmoothing() As TTFSmoothing
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public TTFSmoothing TTFSmoothing {get; set;}
This language is not supported or no code example is available.

Property Value

true if TTF fonts are smoothed; otherwise, false. Default value is false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenterSettings Class
CADPresenterSettings Members


CADPresenterSettings.TTFSmoothingStyle Property

Gets or sets smoothing style for TTF fonts.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TTFSmoothingStyle() As TextRenderingHint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public TextRenderingHint TTFSmoothingStyle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenterSettings Class
CADPresenterSettings Members


CADPresenterSettings.TextVisible Property

Gets or sets a value indicating whether the texts in the CADImage are visible.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TextVisible() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool TextVisible {get; set;}
This language is not supported or no code example is available.

Property Value

true if the texts are visible; otherwise, false. Default value is true.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenterSettings Class
CADPresenterSettings Members


CADPresenterSettings Methods

CADPresenterSettings Class See Also

The following tables list the members exposed by the CADPresenterSettings type.

Methods
 | Name | Description
Public method | Assign | Copies the settings from a specified CADPresenterSettings object.
Public method | Clone | Creates a new object that is a copy of the current CADPresenterSettings class instance.
Public method | Dispose |
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RestoreParams | Restores the settings of the CADPresenterSettings.
Public method | SaveParams | Saves the settings of the CADPresenterSettings.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADPresenterSettings Class


CADPresenterSettings.Assign Method

Copies the settings from a specified CADPresenterSettings object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub Assign( _
   ByVal entity As CADPresenterSettings _
) Implements  _
   IAssign.Assign
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void Assign(
   CADPresenterSettings entity
)
This language is not supported or no code example is available.

Parameters

entity

Type: CADPresenterSettings

CADPresenterSettings object to copy settings from.

Implements

IAssign.Assign
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenterSettings Class
CADPresenterSettings Members


CADPresenterSettings.Clone Method

Creates a new object that is a copy of the current CADPresenterSettings class instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Clone() As Object Implements  _
   ICloneable.Clone
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public object Clone()
This language is not supported or no code example is available.

Return Value

A new object that is a copy of this CADPresenterSettings class instance.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenterSettings Class
CADPresenterSettings Members


CADPresenterSettings.Dispose Method

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenterSettings Class
CADPresenterSettings Members


CADPresenterSettings.RestoreParams Method

Restores the settings of the CADPresenterSettings.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub RestoreParams()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void RestoreParams()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenterSettings Class
CADPresenterSettings Members


CADPresenterSettings.SaveParams Method

Saves the settings of the CADPresenterSettings.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SaveParams()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SaveParams()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenterSettings Class
CADPresenterSettings Members


CADProxy Class

Members See Also

Represent CAD entities created by applications other than AutoCAD.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADProxy
    Inherits CADPenLine
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADProxy : CADPenLine
This language is not supported or no code example is available.
Remarks

A CADProxy object is a substitute for a custom object when the application that created this custom object is not available to AutoCAD. If the application becomes available, the CADProxy object is replaced by the custom object.

Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.CADPenLine
CADImport.CADProxy
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADProxy Members


CADProxy Members

CADProxy Class Constructors Methods Fields Properties See Also

Represent CAD entities created by applications other than AutoCAD.

The following tables list the members exposed by the CADProxy type.

Constructors
 | Name | Description
Public constructor | CADProxy | Initializes a new instance of the CADProxy class.
Top
Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses this CADProxy.
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the CADProxy.
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets a type of the CADProxy entity.
Public property | Entities | Gets a collection of CAD entities belonging to the CADProxy.
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADPenLine).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | SubEntitiesProps | Gets a list of objects representing properties of a CAD entity belonging to this CADProxy.
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADInsert object.
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | AssignEntity | Copies an entity (inherited from CADPenLine).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADProxy to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADProxy Class


CADProxy Constructor

Initializes a new instance of the CADProxy class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADProxy()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADProxy Class
CADProxy Members


CADProxy Properties

CADProxy Class See Also

The following tables list the members exposed by the CADProxy type.

Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses this CADProxy.
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the CADProxy.
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets a type of the CADProxy entity.
Public property | Entities | Gets a collection of CAD entities belonging to the CADProxy.
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADPenLine).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | SubEntitiesProps | Gets a list of objects representing properties of a CAD entity belonging to this CADProxy.
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
See Also

Reference

CADProxy Class


CADProxy.Box Property

Gets or sets a three-dimensional box that encloses this CADProxy.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Box() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override DRect Box {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADProxy Class
CADProxy Members


CADProxy.Count Property

Gets a number of entities contained in the CADProxy.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Count() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override int Count {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADProxy Class
CADProxy Members


CADProxy.EntType Property

Gets a type of the CADProxy entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADProxy Class
CADProxy Members


CADProxy.Entities Property

Gets a collection of CAD entities belonging to the CADProxy.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Entities() As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override CADEntityCollection Entities {get;}
This language is not supported or no code example is available.

Property Value

A CADEntityCollection containing CAD entities belonging to the CADProxy.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADProxy Class
CADProxy Members


CADProxy.SubEntitiesProps Property

Gets a list of objects representing properties of a CAD entity belonging to this CADProxy.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property SubEntitiesProps() As ArrayList
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ArrayList SubEntitiesProps {get;}
This language is not supported or no code example is available.

Property Value

An ArrayList containing the objects representing properties of CAD entities belonging to this CADProxy.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADProxy Class
CADProxy Members


CADProxy Methods

CADProxy Class See Also

The following tables list the members exposed by the CADProxy type.

Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADInsert object.
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | AssignEntity | Copies an entity (inherited from CADPenLine).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADProxy to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADProxy Class


CADProxy.AddEntity Method

Adds the specified entity to this CADInsert object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function AddEntity( _
   ByVal E As CADEntity _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool AddEntity(
   CADEntity E
)
This language is not supported or no code example is available.

Parameters

E

Type: CADEntity

A CADEntity to add.

Return Value

true if a CADEntity was added; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADProxy Class
CADProxy Members


CADProxy.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADProxy Class
CADProxy Members


CADProxy.Loaded Method

Loads this CADProxy to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADProxy is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADProxy Class
CADProxy Members


CADProxy Fields

CADProxy Class See Also

The following tables list the members exposed by the CADProxy type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADProxy Class


CADRegion Class

Members See Also

Represents a CADRegion descendant of the CADACISEntity class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADRegion
    Inherits CADACISEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADRegion : CADACISEntity
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADGroup
CADImport.CADACISEntity
CADImport.CADRegion
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADRegion Members


CADRegion Members

CADRegion Class Constructors Methods Fields Properties See Also

Represents a CADRegion descendant of the CADACISEntity class.

The following tables list the members exposed by the CADRegion type.

Constructors
 | Name | Description
Public constructor | CADRegion | Initializes a new instance of the CADACISEntity class. (inherited from CADACISEntity).
Top
Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses this CADGroup. (inherited from CADGroup).
Public property | Color | Gets or sets a Color for this CADACISEntity object. (inherited from CADACISEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the specified CADGroup. (inherited from CADGroup).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets a type of this CADRegion entity.
Public property | Entities | Gets a collection of CAD entities belonging to the given CADGroup. (inherited from CADGroup).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | List | Gets a collection of entities included in the given CADGroup. (inherited from CADGroup).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity (inherited from CADACISEntity).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADACISEntity).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Iterate | Invokes the referenced (by the specified delegate) method for each CAD entity belonging to the given CADGroup. (inherited from CADGroup).
Public method | Loaded | Loads this CADACISEntity to the specified CADConverter. (inherited from CADACISEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RemoveEntityByName | Searches for an entity using its name then removes the entity. (inherited from CADGroup).
Public method | SetLType | Sets a line type for the current instance of the CADACISEntity class. (inherited from CADACISEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADRegion Class


CADRegion Properties

CADRegion Class See Also

The following tables list the members exposed by the CADRegion type.

Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses this CADGroup. (inherited from CADGroup).
Public property | Color | Gets or sets a Color for this CADACISEntity object. (inherited from CADACISEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the specified CADGroup. (inherited from CADGroup).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets a type of this CADRegion entity.
Public property | Entities | Gets a collection of CAD entities belonging to the given CADGroup. (inherited from CADGroup).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | List | Gets a collection of entities included in the given CADGroup. (inherited from CADGroup).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
See Also

Reference

CADRegion Class


CADRegion.EntType Property

Gets a type of this CADRegion entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADRegion Class
CADRegion Members


CADRegion Methods

CADRegion Class See Also

The following tables list the members exposed by the CADRegion type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity (inherited from CADACISEntity).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADACISEntity).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Iterate | Invokes the referenced (by the specified delegate) method for each CAD entity belonging to the given CADGroup. (inherited from CADGroup).
Public method | Loaded | Loads this CADACISEntity to the specified CADConverter. (inherited from CADACISEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RemoveEntityByName | Searches for an entity using its name then removes the entity. (inherited from CADGroup).
Public method | SetLType | Sets a line type for the current instance of the CADACISEntity class. (inherited from CADACISEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADRegion Class


CADRegion Fields

CADRegion Class See Also

The following tables list the members exposed by the CADRegion type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADRegion Class


CADSection Class

Members See Also

Represents a section of a CAD file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADSection
    Inherits CADTable
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADSection : CADTable
This language is not supported or no code example is available.
Remarks

The common sections of a CAD file are: Header, Classes, Objects, Blocks and others.

Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADGroup
CADImport.CADTable
CADImport.CADSection
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSection Members


CADSection Members

CADSection Class Constructors Methods Fields Properties See Also

Represents a section of a CAD file.

The following tables list the members exposed by the CADSection type.

Constructors
 | Name | Description
Public constructor | CADSection | Initializes a new instance of the CADTable class. (inherited from CADTable).
Top
Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses this CADGroup. (inherited from CADGroup).
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the specified CADGroup. (inherited from CADGroup).
Public property | EntName | Gets a name of the CADTable. (inherited from CADTable).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of CAD entities belonging to the given CADGroup. (inherited from CADGroup).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | List | Gets a collection of entities included in the given CADGroup. (inherited from CADGroup).
Public property | Name | Gets or sets a CADTable name read from a CAD file. (inherited from CADTable).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADSection object.
Public method | AssignEntity | Copies an entity (inherited from CADTable).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADTable).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Iterate | Invokes the referenced (by the specified delegate) method for each CAD entity belonging to the given CADGroup. (inherited from CADGroup).
Public method | Loaded | Loads this CADGroup to the specified CADConverter. (inherited from CADGroup).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RemoveEntityByName | Searches for an entity using its name then removes the entity. (inherited from CADTable).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADSection Class


CADSection Properties

CADSection Class See Also

The following tables list the members exposed by the CADSection type.

Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses this CADGroup. (inherited from CADGroup).
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the specified CADGroup. (inherited from CADGroup).
Public property | EntName | Gets a name of the CADTable. (inherited from CADTable).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of CAD entities belonging to the given CADGroup. (inherited from CADGroup).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | List | Gets a collection of entities included in the given CADGroup. (inherited from CADGroup).
Public property | Name | Gets or sets a CADTable name read from a CAD file. (inherited from CADTable).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
See Also

Reference

CADSection Class


CADSection Methods

CADSection Class See Also

The following tables list the members exposed by the CADSection type.

Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADSection object.
Public method | AssignEntity | Copies an entity (inherited from CADTable).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADTable).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Iterate | Invokes the referenced (by the specified delegate) method for each CAD entity belonging to the given CADGroup. (inherited from CADGroup).
Public method | Loaded | Loads this CADGroup to the specified CADConverter. (inherited from CADGroup).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RemoveEntityByName | Searches for an entity using its name then removes the entity. (inherited from CADTable).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADSection Class


CADSection.AddEntity Method

Adds the specified entity to this CADSection object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function AddEntity( _
   ByVal E As CADEntity _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool AddEntity(
   CADEntity E
)
This language is not supported or no code example is available.

Parameters

E

Type: CADEntity

A CADEntity to add.

Return Value

true if a CADEntity was added; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSection Class
CADSection Members


CADSection Fields

CADSection Class See Also

The following tables list the members exposed by the CADSection type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADSection Class


CADSelector Class

Members See Also

Provides functionality for selecting entities on a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADSelector
    Implements IDisposable
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADSelector : IDisposable
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADSelector
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSelector Members


CADSelector Members

CADSelector Class Constructors Methods Properties See Also

Provides functionality for selecting entities on a CAD image.

The following tables list the members exposed by the CADSelector type.

Constructors
 | Name | Description
Public constructor | CADSelector | Initializes a new instance of the CADSelector class.
Top
Properties
 | Name | Description
Public property | Markers | Gets or sets marker collection for entities
Public property | PBExtendedSelection | Gets or sets a value specifying extended selection mode for CADPolylineBase inherited classes. True allows visual select of an entity by clicking within its contour.
Public property | SelectEntitiesCount | Gets the number of selected entities
Public property | SelectedEntities | Gets or sets a list of selected entities
Public property | SelectionEntityMode | Gets or sets selection activity state.
Public property | SelectionMode | Gets or sets a state of the Selection tool.
Public property | UseShiftToAddSelected | Switches visual selection mode. True clears previously selected entities until Shift pressed. False prevents clearing selected entities until Shift pressed.
Top
Methods
 | Name | Description
Public method | AddEntityToSelectCollection | Adds entity to the selected list of entities
Public method | ClearSelectCollection | Clears collection of selected entities
Public method | ClearSelection | Undoes selection
Public method | Dispose | Releases all resources used by the CADSelector instance.
Public method | DoSelectEntities | (Overloaded) Selects inserted list of entities
Public method | DoSelectEntity | Selects an entity.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetSelectEntityRegion | Returns the selected area of the image.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | InvalidateSelectEntity | Redraws a selected entity.
Public method | MultipleSelect | Providing CAD image entities' multiple selection within a specified rectangle.
Public method | MultipleSelectExt | Selects all entities inside the inserted rectangle
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Select | Selects an entity of the CAD image at the specified point.
Public method | SelectExt | Selects an entity of the CAD image at the specified point.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | UndoSelect | Undoes the selection of all entities
Top
See Also

Reference

CADSelector Class


CADSelector Constructor

Initializes a new instance of the CADSelector class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal image As CADImage _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADSelector(
   CADImage image
)
This language is not supported or no code example is available.

Parameters

image

Type: CADImage

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSelector Class
CADSelector Members


CADSelector Properties

CADSelector Class See Also

The following tables list the members exposed by the CADSelector type.

Properties
 | Name | Description
Public property | Markers | Gets or sets marker collection for entities
Public property | PBExtendedSelection | Gets or sets a value specifying extended selection mode for CADPolylineBase inherited classes. True allows visual select of an entity by clicking within its contour.
Public property | SelectEntitiesCount | Gets the number of selected entities
Public property | SelectedEntities | Gets or sets a list of selected entities
Public property | SelectionEntityMode | Gets or sets selection activity state.
Public property | SelectionMode | Gets or sets a state of the Selection tool.
Public property | UseShiftToAddSelected | Switches visual selection mode. True clears previously selected entities until Shift pressed. False prevents clearing selected entities until Shift pressed.
Top
See Also

Reference

CADSelector Class


CADSelector.Markers Property

Gets or sets marker collection for entities

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Markers() As Dictionary(Of UInt64, CADCollection(Of Marker))
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Dictionary<UInt64, CADCollection<Marker>> Markers {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSelector Class
CADSelector Members


CADSelector.PBExtendedSelection Property

Gets or sets a value specifying extended selection mode for CADPolylineBase inherited classes. True allows visual select of an entity by clicking within its contour.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PBExtendedSelection() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool PBExtendedSelection {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSelector Class
CADSelector Members


CADSelector.SelectEntitiesCount Property

Gets the number of selected entities

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property SelectEntitiesCount() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int SelectEntitiesCount {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSelector Class
CADSelector Members


CADSelector.SelectedEntities Property

Gets or sets a list of selected entities

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property SelectedEntities() As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntityCollection SelectedEntities {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSelector Class
CADSelector Members


CADSelector.SelectionEntityMode Property

Gets or sets selection activity state.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property SelectionEntityMode() As SelectionEntityMode
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SelectionEntityMode SelectionEntityMode {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSelector Class
CADSelector Members


CADSelector.SelectionMode Property

Gets or sets a state of the Selection tool.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property SelectionMode() As SelectionEntityMode
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SelectionEntityMode SelectionMode {get; set;}
This language is not supported or no code example is available.

Property Value

A SelectionEntityMode enumeration value that specifies a state of the Selection tool.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSelector Class
CADSelector Members


CADSelector.UseShiftToAddSelected Property

Switches visual selection mode. True clears previously selected entities until Shift pressed. False prevents clearing selected entities until Shift pressed.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property UseShiftToAddSelected() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool UseShiftToAddSelected {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSelector Class
CADSelector Members


CADSelector Methods

CADSelector Class See Also

The following tables list the members exposed by the CADSelector type.

Methods
 | Name | Description
Public method | AddEntityToSelectCollection | Adds entity to the selected list of entities
Public method | ClearSelectCollection | Clears collection of selected entities
Public method | ClearSelection | Undoes selection
Public method | Dispose | Releases all resources used by the CADSelector instance.
Public method | DoSelectEntities | (Overloaded) Selects inserted list of entities
Public method | DoSelectEntity | Selects an entity.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetSelectEntityRegion | Returns the selected area of the image.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | InvalidateSelectEntity | Redraws a selected entity.
Public method | MultipleSelect | Providing CAD image entities' multiple selection within a specified rectangle.
Public method | MultipleSelectExt | Selects all entities inside the inserted rectangle
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Select | Selects an entity of the CAD image at the specified point.
Public method | SelectExt | Selects an entity of the CAD image at the specified point.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | UndoSelect | Undoes the selection of all entities
Top
See Also

Reference

CADSelector Class


CADSelector.AddEntityToSelectCollection Method

Adds entity to the selected list of entities

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddEntityToSelectCollection( _
   ByVal ent As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddEntityToSelectCollection(
   CADEntity ent
)
This language is not supported or no code example is available.

Parameters

ent

Type: CADEntity

Adding entity

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSelector Class
CADSelector Members


CADSelector.ClearSelectCollection Method

Clears collection of selected entities

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ClearSelectCollection()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ClearSelectCollection()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSelector Class
CADSelector Members


CADSelector.ClearSelection Method

Undoes selection

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ClearSelection()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ClearSelection()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSelector Class
CADSelector Members


CADSelector.Dispose Method

Releases all resources used by the CADSelector instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Dispose() Implements  _
   IDisposable.Dispose
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Dispose()
This language is not supported or no code example is available.

Implements

IDisposable.Dispose
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSelector Class
CADSelector Members


CADSelector.DoSelectEntities Method

CADSelector Class See Also

Selects inserted list of entities

Overload List
Name | Description
DoSelectEntities(CADEntityCollection) | Selects inserted list of entities
DoSelectEntities(SortedList) | Selects inserted list of entities
See Also

Reference

CADSelector Class
CADSelector Members


CADSelector.DoSelectEntity Method

Selects an entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub DoSelectEntity( _
   ByVal ent As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void DoSelectEntity(
   CADEntity ent
)
This language is not supported or no code example is available.

Parameters

ent

Type: CADEntity

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSelector Class
CADSelector Members


CADSelector.GetSelectEntityRegion Method

Returns the selected area of the image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetSelectEntityRegion( _
   ByVal rect As Rectangle _
) As Region
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Region GetSelectEntityRegion(
   Rectangle rect
)
This language is not supported or no code example is available.

Parameters

rect

Type: Rectangle

A Region object representing the selected area of the image.

Return Value

A Rectangle object specifying the image area to be selected.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSelector Class
CADSelector Members


CADSelector.InvalidateSelectEntity Method

Redraws a selected entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub InvalidateSelectEntity( _
   ByVal cl1 As Control, _
   ByVal scale As Single _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void InvalidateSelectEntity(
   Control cl1,
   float scale
)
This language is not supported or no code example is available.

Parameters

cl1

Type: Control

A Control on which the selected area is redrawn.

scale

Type: float

A scale in which the selected area is redrawn.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSelector Class
CADSelector Members


CADSelector.MultipleSelect Method

Providing CAD image entities' multiple selection within a specified rectangle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub MultipleSelect( _
   ByVal rect As DRect, _
   ByVal clearSelCollection As Boolean, _
   ByVal visualSelect As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void MultipleSelect(
   DRect rect,
   bool clearSelCollection,
   bool visualSelect
)
This language is not supported or no code example is available.

Parameters

rect

Type: DRect

Multiple selection rectangle

clearSelCollection

Type: bool

Clear select collection

visualSelect

Type: bool

Visual selecting

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSelector Class
CADSelector Members


CADSelector.MultipleSelectExt Method

Selects all entities inside the inserted rectangle

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Function MultipleSelectExt( _
   ByVal rect As DRect, _
   ByVal clearSelCollection As Boolean, _
   ByVal visualSelect As Boolean _
) As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual CADEntityCollection MultipleSelectExt(
   DRect rect,
   bool clearSelCollection,
   bool visualSelect
)
This language is not supported or no code example is available.

Parameters

rect

Type: DRect

Inserting rectangle

clearSelCollection

Type: bool

Clears SelectedEntities object if true

visualSelect

Type: bool

Represents visual selection if true

Return Value

Returns list of selected entities
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSelector Class
CADSelector Members


CADSelector.Select Method

Selects an entity of the CAD image at the specified point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Select( _
   ByVal x As Integer, _
   ByVal y As Integer _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Select(
   int x,
   int y
)
This language is not supported or no code example is available.

Parameters

x

Type: int

An X coordinate of the point at which the entity to be selected is located.

y

Type: int

An Y coordinate of the point at which the entity to be selected is located.

Remarks

The X and Y coordinates are measured in pixels. This method requires SelectionMode to be switched to be set.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSelector Class
CADSelector Members


CADSelector.SelectExt Method

Selects an entity of the CAD image at the specified point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function SelectExt( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal clearPrevSelection As Boolean, _
   ByVal visualSelect As Boolean _
) As CADEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntity SelectExt(
   int x,
   int y,
   bool clearPrevSelection,
   bool visualSelect
)
This language is not supported or no code example is available.

Parameters

x

Type: int

An X coordinate of the point at which the entity to be selected is located.

y

Type: int

An Y coordinate of the point at which the entity to be selected is located.

clearPrevSelection

Type: bool

Clears selection of objects if true; adds to selected if false

visualSelect

Type: bool

Visual select entity

Return Value

A CADEntity located at the specified point, or null if nothing is located at the specified point.
Remarks

The X and Y coordinates are measured in pixels. This method requires SelectionMode to be switched to be set.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSelector Class
CADSelector Members


CADSelector.UndoSelect Method

Undoes the selection of all entities

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub UndoSelect()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void UndoSelect()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSelector Class
CADSelector Members


CADSeqend Class

Members See Also

This class is for internal use only.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADSeqend
    Inherits CADEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADSeqend : CADEntity
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADSeqend
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSeqend Members


CADSeqend Members

CADSeqend Class Constructors Methods Fields Properties See Also

This class is for internal use only.

The following tables list the members exposed by the CADSeqend type.

Constructors
 | Name | Description
Public constructor | CADSeqend | Initializes a new instance of the CADEntity class. (inherited from CADEntity).
Top
Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer containing this CADEntity. (inherited from CADEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADEntity is visible. (inherited from CADEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity (inherited from CADEntity).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADEntity).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADSeqend Class


CADSeqend Properties

CADSeqend Class See Also

The following tables list the members exposed by the CADSeqend type.

Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer containing this CADEntity. (inherited from CADEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADEntity is visible. (inherited from CADEntity).
Top
See Also

Reference

CADSeqend Class


CADSeqend Methods

CADSeqend Class See Also

The following tables list the members exposed by the CADSeqend type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity (inherited from CADEntity).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADEntity).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADSeqend Class


CADSeqend Fields

CADSeqend Class See Also

The following tables list the members exposed by the CADSeqend type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADSeqend Class


CADShape Class

Members See Also

Represents a shape in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADShape
    Inherits CADText
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADShape : CADText
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADCustomVertex
CADImport.CADText
CADImport.CADShape
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADShape Members


CADShape Members

CADShape Class Constructors Methods Fields Properties See Also

Represents a shape in a CAD image.

The following tables list the members exposed by the CADShape type.

Constructors
 | Name | Description
Public constructor | CADShape | Initializes a new instance of the CADText object. (inherited from CADText).
Top
Properties
 | Name | Description
Public property | Backward | Gets a value indicating whether the text line is turned backwards. (inherited from CADText).
Public property | Box | Gets a three-dimensional box that encloses this CADText object. (inherited from CADText).
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of this CADText object. (inherited from CADText).
Public property | EntType | Gets a type of this CADShape entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets the direction of axis Z belonging to the coordinate system of the CADText object. (inherited from CADText).
Public property | FontName | Gets or sets a name of the font used by this CADText object. (inherited from CADText).
Public property | HAlign | Gets or sets a horizontal alignment of a text. (inherited from CADText).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Height | Gets or sets a height of the CADText letters. (inherited from CADText).
Public property | InsideMText | Gets a value indicating whether this CADText object is a part of the multiline text. (inherited from CADText).
Public property | IsSHXFont | Gets a value indicating whether this CADText object contains SHX fonts. (inherited from CADText).
Public property | IsUnicodeText | Gets a value indicating whether this CADText object consists of unicode characters. (inherited from CADText).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADText. (inherited from CADText).
Public property | ObliqueAngle | Gets or sets a tilt angle for the CADText letters. (inherited from CADText).
Public property | Point | Gets or sets a position of the CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Point1 | Gets or sets a second alignment point of the CADText object. (inherited from CADText).
Public property | Rotation | Gets or sets a rotation angle of the CADText object. (inherited from CADText).
Public property | Scale | Relative X scale factor.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADText).
Public property | ShapeName | Gets or sets name of a shape.
Public property | ShapeNumber | Gets or sets number of a shape.
Public property | StartPoint | Gets the start point of the text line. (inherited from CADText).
Public property | Style | Gets or sets a style for the CADText object. (inherited from CADText).
Public property | Text | Gets or sets a text contents for the CADText object. (inherited from CADText).
Public property | TextStyle | Gets or sets a style of the CADText. (inherited from CADText).
Public property | UnicodeText | Gets the Unicode text contained in this CADText object. (inherited from CADText).
Public property | UpsideDown | Gets a value indicating whether the text line is turned downwards (mirrored along axis Z). (inherited from CADText).
Public property | VAlign | Gets or sets a vetical alignment of the text. (inherited from CADText).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | XScale | Gets or sets a width scale (width factor) for the CADText. (inherited from CADText).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | ApplyStyle | Applies a specified CADStyle to the CADText entity. (inherited from CADText).
Public method | AssignEntity | Copies an entity
Public method | ChangeByStyle | Changes CADStyle of the CADText to the specified one. (inherited from CADText).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADText.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExpR | Calculates a rectangle occupied by this CADText. (inherited from CADText).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADShape to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADShape Class


CADShape Properties

CADShape Class See Also

The following tables list the members exposed by the CADShape type.

Properties
 | Name | Description
Public property | Backward | Gets a value indicating whether the text line is turned backwards. (inherited from CADText).
Public property | Box | Gets a three-dimensional box that encloses this CADText object. (inherited from CADText).
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of this CADText object. (inherited from CADText).
Public property | EntType | Gets a type of this CADShape entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets the direction of axis Z belonging to the coordinate system of the CADText object. (inherited from CADText).
Public property | FontName | Gets or sets a name of the font used by this CADText object. (inherited from CADText).
Public property | HAlign | Gets or sets a horizontal alignment of a text. (inherited from CADText).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Height | Gets or sets a height of the CADText letters. (inherited from CADText).
Public property | InsideMText | Gets a value indicating whether this CADText object is a part of the multiline text. (inherited from CADText).
Public property | IsSHXFont | Gets a value indicating whether this CADText object contains SHX fonts. (inherited from CADText).
Public property | IsUnicodeText | Gets a value indicating whether this CADText object consists of unicode characters. (inherited from CADText).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADText. (inherited from CADText).
Public property | ObliqueAngle | Gets or sets a tilt angle for the CADText letters. (inherited from CADText).
Public property | Point | Gets or sets a position of the CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Point1 | Gets or sets a second alignment point of the CADText object. (inherited from CADText).
Public property | Rotation | Gets or sets a rotation angle of the CADText object. (inherited from CADText).
Public property | Scale | Relative X scale factor.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADText).
Public property | ShapeName | Gets or sets name of a shape.
Public property | ShapeNumber | Gets or sets number of a shape.
Public property | StartPoint | Gets the start point of the text line. (inherited from CADText).
Public property | Style | Gets or sets a style for the CADText object. (inherited from CADText).
Public property | Text | Gets or sets a text contents for the CADText object. (inherited from CADText).
Public property | TextStyle | Gets or sets a style of the CADText. (inherited from CADText).
Public property | UnicodeText | Gets the Unicode text contained in this CADText object. (inherited from CADText).
Public property | UpsideDown | Gets a value indicating whether the text line is turned downwards (mirrored along axis Z). (inherited from CADText).
Public property | VAlign | Gets or sets a vetical alignment of the text. (inherited from CADText).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | XScale | Gets or sets a width scale (width factor) for the CADText. (inherited from CADText).
Top
See Also

Reference

CADShape Class


CADText.EntName Property

Gets a name of this CADText object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override string EntName {get;}
This language is not supported or no code example is available.

Property Value

A string containing a name of the CADText object.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADShape.EntType Property

Gets a type of this CADShape entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADShape Class
CADShape Members


CADShape.Scale Property

Relative X scale factor.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Scale() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float Scale {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADShape Class
CADShape Members


CADShape.ShapeName Property

Gets or sets name of a shape.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ShapeName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string ShapeName {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADShape Class
CADShape Members


CADShape.ShapeNumber Property

Gets or sets number of a shape.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ShapeNumber() As UInt16
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public UInt16 ShapeNumber {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADShape Class
CADShape Members


CADShape Methods

CADShape Class See Also

The following tables list the members exposed by the CADShape type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | ApplyStyle | Applies a specified CADStyle to the CADText entity. (inherited from CADText).
Public method | AssignEntity | Copies an entity
Public method | ChangeByStyle | Changes CADStyle of the CADText to the specified one. (inherited from CADText).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADText.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExpR | Calculates a rectangle occupied by this CADText. (inherited from CADText).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADShape to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADShape Class


CADShape.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADShape Class
CADShape Members


CADShape.Dispose Method

Releases all resources used by the CADText.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADShape Class
CADShape Members


CADShape.Loaded Method

Loads this CADShape to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADShape is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADShape Class
CADShape Members


CADShape Fields

CADShape Class See Also

The following tables list the members exposed by the CADShape type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADShape Class


CADSolid Class

Members See Also

Represents triangles and four-sided polygons in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADSolid
    Inherits CADLine
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADSolid : CADLine
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.CADPenLine
CADImport.CADLine
CADImport.CADSolid
CADImport.CAD3dFace
CADImport.CADTrace
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSolid Members


CADSolid Members

CADSolid Class Constructors Methods Fields Properties See Also

Represents triangles and four-sided polygons in a CAD image.

The following tables list the members exposed by the CADSolid type.

Constructors
 | Name | Description
Public constructor | CADSolid | Initializes a new instance of the CADLine class. (inherited from CADLine).
Top
Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses the CADSolid entity.
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | DottedSingPts | Gets a collection of points that specify the dots and dashes of the CADLine. (inherited from CADLine).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets a type of this CADSolid entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADPenLine).
Public property | Point1 | Gets or sets a second end of the CADLine. (inherited from CADLine).
Public property | Point2 | Gets or sets a third point of the CADSolid object.
Public property | Point3 | Gets or sets a fourth point of the CADSolid object.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADLine).
Public method | DrawEntityTrace | Implements drawing of an entity with specified offset to specified Control
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADSolid object must be drawn during a drawing cycle.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADSolid object to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADSolid Class


CADSolid Properties

CADSolid Class See Also

The following tables list the members exposed by the CADSolid type.

Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses the CADSolid entity.
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | DottedSingPts | Gets a collection of points that specify the dots and dashes of the CADLine. (inherited from CADLine).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets a type of this CADSolid entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADPenLine).
Public property | Point1 | Gets or sets a second end of the CADLine. (inherited from CADLine).
Public property | Point2 | Gets or sets a third point of the CADSolid object.
Public property | Point3 | Gets or sets a fourth point of the CADSolid object.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
See Also

Reference

CADSolid Class


CADSolid.EntType Property

Gets a type of this CADSolid entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSolid Class
CADSolid Members


CADSolid Methods

CADSolid Class See Also

The following tables list the members exposed by the CADSolid type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADLine).
Public method | DrawEntityTrace | Implements drawing of an entity with specified offset to specified Control
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADSolid object must be drawn during a drawing cycle.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADSolid object to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADSolid Class


CADSolid.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSolid Class
CADSolid Members


CADSolid Fields

CADSolid Class See Also

The following tables list the members exposed by the CADSolid type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADSolid Class


CADSortEntsTable Class

Members See Also

Represents a table that contains handles of entities before sorting.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADSortEntsTable
    Inherits CADEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADSortEntsTable : CADEntity
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADSortEntsTable
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSortEntsTable Members


CADSortEntsTable Members

CADSortEntsTable Class Constructors Methods Fields Properties See Also

Represents a table that contains handles of entities before sorting.

The following tables list the members exposed by the CADSortEntsTable type.

Constructors
 | Name | Description
Public constructor | CADSortEntsTable | Initializes a new instance of the CADSortEntsTable class.
Top
Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | HandlesNew | Gets a list of new handles of CAD entities.
Public property | HandlesOld | Gets a list of old handles of CAD entities.
Public property | Layer | Gets or sets a layer containing this CADEntity. (inherited from CADEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADEntity is visible. (inherited from CADEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity (inherited from CADEntity).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADSortEntsTable to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADSortEntsTable Class


CADSortEntsTable Constructor

Initializes a new instance of the CADSortEntsTable class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADSortEntsTable()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSortEntsTable Class
CADSortEntsTable Members


CADSortEntsTable Properties

CADSortEntsTable Class See Also

The following tables list the members exposed by the CADSortEntsTable type.

Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | HandlesNew | Gets a list of new handles of CAD entities.
Public property | HandlesOld | Gets a list of old handles of CAD entities.
Public property | Layer | Gets or sets a layer containing this CADEntity. (inherited from CADEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADEntity is visible. (inherited from CADEntity).
Top
See Also

Reference

CADSortEntsTable Class


CADSortEntsTable.HandlesNew Property

Gets a list of new handles of CAD entities.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property HandlesNew() As CADCollection(Of UInt64)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection<UInt64> HandlesNew {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSortEntsTable Class
CADSortEntsTable Members


CADSortEntsTable.HandlesOld Property

Gets a list of old handles of CAD entities.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property HandlesOld() As CADCollection(Of UInt64)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection<UInt64> HandlesOld {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSortEntsTable Class
CADSortEntsTable Members


CADSortEntsTable Methods

CADSortEntsTable Class See Also

The following tables list the members exposed by the CADSortEntsTable type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity (inherited from CADEntity).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADSortEntsTable to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADSortEntsTable Class


CADSortEntsTable.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSortEntsTable Class
CADSortEntsTable Members


CADSortEntsTable.Loaded Method

Loads this CADSortEntsTable to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal aConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter aConverter
)
This language is not supported or no code example is available.

Parameters

aConverter

Type: CADConverter

A CADConverter where to a CADSortEntsTable is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSortEntsTable Class
CADSortEntsTable Members


CADSortEntsTable Fields

CADSortEntsTable Class See Also

The following tables list the members exposed by the CADSortEntsTable type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADSortEntsTable Class


CADSpline Class

Members See Also

Represents a spline in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADSpline
    Inherits CADPolylineBase
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADSpline : CADPolylineBase
This language is not supported or no code example is available.
Remarks

A spline is specified by fit points and control points. Fit points are connected by a smooth curve that forms a spline. Control points form a spline as a continuous approximation line that goes proportionally remote from them.

Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.CADPenLine
CADImport.CADPolylineBase
CADImport.CADSpline
CADImport.CADHelix
CADImport.CADLeader
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSpline Members


CADSpline Members

CADSpline Class Constructors Methods Fields Properties See Also

Represents a spline in a CAD image.

The following tables list the members exposed by the CADSpline type.

Constructors
 | Name | Description
Public constructor | CADSpline | Initializes a new instance of the CADSpline class.
Top
Properties
 | Name | Description
Public property | Box | Return box of the current primitive. (inherited from CADPolylineBase).
Public property | Closed | Gets or sets a value indicating whether this CADPolyLine is closed. (inherited from CADPolylineBase).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | ControlCount | Gets a number of control points.
Public property | Controls | Gets or sets a collection of control points.
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADPolylineBase. (inherited from CADPolylineBase).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | Degree | Gets or sets degree of the CADSpline.
Public property | DottedSingPoints | Gets a collection of points that specify the dots and dashes of the CADPolylineBase. (inherited from CADPolylineBase).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets a type of this CADSpline entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Fit | Gets or sets a collection of fit points.
Public property | FitCount | Gets a number of fit points.
Public property | Flags | Gets or sets a number that specifies an appearance of this CADPolylineBase entity. (inherited from CADPolylineBase).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | IsMeshMClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the M direction. (inherited from CADPolylineBase).
Public property | IsMeshNClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the N direction. (inherited from CADPolylineBase).
Public property | IsPolyFaceMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | IsPolyZThickness | Gets a value indicating whether a line thickness measured along the axis Z is equal to 0. (inherited from CADPolylineBase).
Public property | IsPolygonMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | Knots | Gets a collection of knots for this CADSpline entity.
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADPenLine).
Public property | PolyPoints | Gets a collection of points belonging to the polyline. (inherited from CADPolylineBase).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible.
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Weights | Gets a collection of weights for CADSpline points.
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | ApplyBox | Calculates a box of the current entity. (inherited from CADPolylineBase).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of an entity with the specified offset to the specified Control
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Used in drawing cycle for fast checking whether the entity must be drawn (inherited from CADPolylineBase).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADSpline to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADSpline Class


CADSpline Properties

CADSpline Class See Also

The following tables list the members exposed by the CADSpline type.

Properties
 | Name | Description
Public property | Box | Return box of the current primitive. (inherited from CADPolylineBase).
Public property | Closed | Gets or sets a value indicating whether this CADPolyLine is closed. (inherited from CADPolylineBase).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | ControlCount | Gets a number of control points.
Public property | Controls | Gets or sets a collection of control points.
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADPolylineBase. (inherited from CADPolylineBase).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | Degree | Gets or sets degree of the CADSpline.
Public property | DottedSingPoints | Gets a collection of points that specify the dots and dashes of the CADPolylineBase. (inherited from CADPolylineBase).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets a type of this CADSpline entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Fit | Gets or sets a collection of fit points.
Public property | FitCount | Gets a number of fit points.
Public property | Flags | Gets or sets a number that specifies an appearance of this CADPolylineBase entity. (inherited from CADPolylineBase).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | IsMeshMClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the M direction. (inherited from CADPolylineBase).
Public property | IsMeshNClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the N direction. (inherited from CADPolylineBase).
Public property | IsPolyFaceMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | IsPolyZThickness | Gets a value indicating whether a line thickness measured along the axis Z is equal to 0. (inherited from CADPolylineBase).
Public property | IsPolygonMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | Knots | Gets a collection of knots for this CADSpline entity.
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADPenLine).
Public property | PolyPoints | Gets a collection of points belonging to the polyline. (inherited from CADPolylineBase).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible.
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Weights | Gets a collection of weights for CADSpline points.
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
See Also

Reference

CADSpline Class


CADSpline.EntType Property

Gets a type of this CADSpline entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSpline Class
CADSpline Members


CADSpline Methods

CADSpline Class See Also

The following tables list the members exposed by the CADSpline type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | ApplyBox | Calculates a box of the current entity. (inherited from CADPolylineBase).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of an entity with the specified offset to the specified Control
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Used in drawing cycle for fast checking whether the entity must be drawn (inherited from CADPolylineBase).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADSpline to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADSpline Class


CADSpline.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSpline Class
CADSpline Members


CADSpline Fields

CADSpline Class See Also

The following tables list the members exposed by the CADSpline type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADSpline Class


CADStyle Class

Members See Also

Represents a text style in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADStyle
    Inherits CADPenTableItem
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADStyle : CADPenTableItem
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.CADPenTableItem
CADImport.CADStyle
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADStyle Members


CADStyle Members

CADStyle Class Constructors Methods Fields Properties See Also

Represents a text style in a CAD image.

The following tables list the members exposed by the CADStyle type.

Constructors
 | Name | Description
Public constructor | CADStyle | Initializes a new instance of the CADStyle class.
Top
Properties
 | Name | Description
Public property | Backward | Gets a value indicating whether a text is backward (mirrored in X) or not.
Public property | BigFont | Gets or sets a path to a file containing big fonts.
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | EntName | Gets a name of this CADPenTableItem. (inherited from CADPenTableItem).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | FixedHeight | Gets or sets a fixed text height.
Public property | Flags | Gets or sets a drawing flags. (inherited from CADPenTableItem).
Public property | FontName | Gets or sets a font name.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | LastHeightUsed | Gets or sets an initial height of the last added text defined by this CADStyle.
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Name | Gets or sets a name of the CADPenTableItem. (inherited from CADPenTableItem).
Public property | ObliqueAngle | Gets or sets a tilt angle for letters defined by this CADStyle.
Public property | PrimaryFont | Gets or sets a name of the file containing fonts for texts in a CAD image.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | TextGenFlags | Gets or sets a byte that contains text generation flags.
Public property | UpsideDown | Defines whether text is upside down (mirrored in Y) or not.
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | WidthFactor | Gets or sets a width factor (width scale) defined by this CADStyle.
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADStyle to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADStyle Class


CADStyle Constructor

Initializes a new instance of the CADStyle class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADStyle()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADStyle Class
CADStyle Members


CADStyle Properties

CADStyle Class See Also

The following tables list the members exposed by the CADStyle type.

Properties
 | Name | Description
Public property | Backward | Gets a value indicating whether a text is backward (mirrored in X) or not.
Public property | BigFont | Gets or sets a path to a file containing big fonts.
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | EntName | Gets a name of this CADPenTableItem. (inherited from CADPenTableItem).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | FixedHeight | Gets or sets a fixed text height.
Public property | Flags | Gets or sets a drawing flags. (inherited from CADPenTableItem).
Public property | FontName | Gets or sets a font name.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | LastHeightUsed | Gets or sets an initial height of the last added text defined by this CADStyle.
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Name | Gets or sets a name of the CADPenTableItem. (inherited from CADPenTableItem).
Public property | ObliqueAngle | Gets or sets a tilt angle for letters defined by this CADStyle.
Public property | PrimaryFont | Gets or sets a name of the file containing fonts for texts in a CAD image.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | TextGenFlags | Gets or sets a byte that contains text generation flags.
Public property | UpsideDown | Defines whether text is upside down (mirrored in Y) or not.
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | WidthFactor | Gets or sets a width factor (width scale) defined by this CADStyle.
Top
See Also

Reference

CADStyle Class


CADStyle.Backward Property

Gets a value indicating whether a text is backward (mirrored in X) or not.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Backward() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Backward {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADStyle Class
CADStyle Members


CADStyle.BigFont Property

Gets or sets a path to a file containing big fonts.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property BigFont() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string BigFont {get; set;}
This language is not supported or no code example is available.

Property Value

A string containing a path to a file containing big fonts.
Remarks

Big font files include glyphs for multiple character sets and accommodate many languages.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADStyle Class
CADStyle Members


CADStyle.FixedHeight Property

Gets or sets a fixed text height.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property FixedHeight() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float FixedHeight {get; set;}
This language is not supported or no code example is available.
Remarks

A fixed text height is an initial text height of all newly added texts defined by this CADStyle. A zero value means that a text height is not fixed and a user will be prompted to enter a height value for a newly added text.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADStyle Class
CADStyle Members


CADStyle.FontName Property

Gets or sets a font name.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property FontName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string FontName {get; set;}
This language is not supported or no code example is available.

Property Value

A string containing a font name.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADStyle Class
CADStyle Members


CADStyle.LastHeightUsed Property

Gets or sets an initial height of the last added text defined by this CADStyle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LastHeightUsed() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float LastHeightUsed {get; set;}
This language is not supported or no code example is available.
Remarks

A value returned by this property can coincide with the FixedHeight or be defined at the moment of adding a text to a CAD image.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADStyle Class
CADStyle Members


CADStyle.ObliqueAngle Property

Gets or sets a tilt angle for letters defined by this CADStyle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ObliqueAngle() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float ObliqueAngle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADStyle Class
CADStyle Members


CADStyle.PrimaryFont Property

Gets or sets a name of the file containing fonts for texts in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PrimaryFont() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string PrimaryFont {get; set;}
This language is not supported or no code example is available.

Property Value

A string representing a name of the file containing fonts for texts in a CAD image.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADStyle Class
CADStyle Members


CADStyle.TextGenFlags Property

Gets or sets a byte that contains text generation flags.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TextGenFlags() As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte TextGenFlags {get; set;}
This language is not supported or no code example is available.
Remarks

Text generation flags (bit-coded values): 2 = Text is backward (mirrored in X). 4 = Text is upside down (mirrored in Y).

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADStyle Class
CADStyle Members


CADStyle.UpsideDown Property

Defines whether text is upside down (mirrored in Y) or not.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property UpsideDown() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool UpsideDown {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADStyle Class
CADStyle Members


CADStyle.WidthFactor Property

Gets or sets a width factor (width scale) defined by this CADStyle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property WidthFactor() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float WidthFactor {get; set;}
This language is not supported or no code example is available.

Property Value

More than one if text letters are stretched; less than one and more than zero if the text letters are squeezed. A modified width is equal to the previous width multiplied by a width factor.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADStyle Class
CADStyle Members


CADStyle Methods

CADStyle Class See Also

The following tables list the members exposed by the CADStyle type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADStyle to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADStyle Class


CADStyle.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADStyle Class
CADStyle Members


CADStyle.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADStyle Class
CADStyle Members


CADStyle.Loaded Method

Loads this CADStyle to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADStyle is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADStyle Class
CADStyle Members


CADStyle Fields

CADStyle Class See Also

The following tables list the members exposed by the CADStyle type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADStyle Class


CADSurface Class

Members See Also

Represents a CADSurface descendant of the CADACISEntity class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADSurface
    Inherits CADACISEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADSurface : CADACISEntity
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADGroup
CADImport.CADACISEntity
CADImport.CADSurface
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSurface Members


CADSurface Members

CADSurface Class Constructors Methods Fields Properties See Also

Represents a CADSurface descendant of the CADACISEntity class.

The following tables list the members exposed by the CADSurface type.

Constructors
 | Name | Description
Public constructor | CADSurface | Initializes a new instance of the CADACISEntity class. (inherited from CADACISEntity).
Top
Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses this CADGroup. (inherited from CADGroup).
Public property | Color | Gets or sets a Color for this CADACISEntity object. (inherited from CADACISEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the specified CADGroup. (inherited from CADGroup).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration.
Public property | Entities | Gets a collection of CAD entities belonging to the given CADGroup. (inherited from CADGroup).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | List | Gets a collection of entities included in the given CADGroup. (inherited from CADGroup).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity (inherited from CADACISEntity).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADACISEntity).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Iterate | Invokes the referenced (by the specified delegate) method for each CAD entity belonging to the given CADGroup. (inherited from CADGroup).
Public method | Loaded | Loads this CADACISEntity to the specified CADConverter. (inherited from CADACISEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RemoveEntityByName | Searches for an entity using its name then removes the entity. (inherited from CADGroup).
Public method | SetLType | Sets a line type for the current instance of the CADACISEntity class. (inherited from CADACISEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADSurface Class


CADSurface Properties

CADSurface Class See Also

The following tables list the members exposed by the CADSurface type.

Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses this CADGroup. (inherited from CADGroup).
Public property | Color | Gets or sets a Color for this CADACISEntity object. (inherited from CADACISEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the specified CADGroup. (inherited from CADGroup).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration.
Public property | Entities | Gets a collection of CAD entities belonging to the given CADGroup. (inherited from CADGroup).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | List | Gets a collection of entities included in the given CADGroup. (inherited from CADGroup).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
See Also

Reference

CADSurface Class


CADSurface.EntType Property

The entity type defined by the EntityType enumeration.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSurface Class
CADSurface Members


CADSurface Methods

CADSurface Class See Also

The following tables list the members exposed by the CADSurface type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity (inherited from CADACISEntity).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADACISEntity).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Iterate | Invokes the referenced (by the specified delegate) method for each CAD entity belonging to the given CADGroup. (inherited from CADGroup).
Public method | Loaded | Loads this CADACISEntity to the specified CADConverter. (inherited from CADACISEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RemoveEntityByName | Searches for an entity using its name then removes the entity. (inherited from CADGroup).
Public method | SetLType | Sets a line type for the current instance of the CADACISEntity class. (inherited from CADACISEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADSurface Class


CADSurface Fields

CADSurface Class See Also

The following tables list the members exposed by the CADSurface type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADSurface Class


CADTable Class

Members See Also

Represents a table that contains data about CAD entities described in the Tables section of a DXF file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADTable
    Inherits CADGroup
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADTable : CADGroup
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADGroup
CADImport.CADTable
CADImport.CADLayoutCollection
CADImport.CADSection
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADTable Members


CADTable Members

CADTable Class Constructors Methods Fields Properties See Also

Represents a table that contains data about CAD entities described in the Tables section of a DXF file.

The following tables list the members exposed by the CADTable type.

Constructors
 | Name | Description
Public constructor | CADTable | Initializes a new instance of the CADTable class.
Top
Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses this CADGroup. (inherited from CADGroup).
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the specified CADGroup. (inherited from CADGroup).
Public property | EntName | Gets a name of the CADTable.
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of CAD entities belonging to the given CADGroup. (inherited from CADGroup).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | List | Gets a collection of entities included in the given CADGroup. (inherited from CADGroup).
Public property | Name | Gets or sets a CADTable name read from a CAD file.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADTable object.
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Iterate | Invokes the referenced (by the specified delegate) method for each CAD entity belonging to the given CADGroup. (inherited from CADGroup).
Public method | Loaded | Loads this CADGroup to the specified CADConverter. (inherited from CADGroup).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RemoveEntityByName | Searches for an entity using its name then removes the entity.
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADTable Class


CADTable Properties

CADTable Class See Also

The following tables list the members exposed by the CADTable type.

Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses this CADGroup. (inherited from CADGroup).
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the specified CADGroup. (inherited from CADGroup).
Public property | EntName | Gets a name of the CADTable.
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of CAD entities belonging to the given CADGroup. (inherited from CADGroup).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | List | Gets a collection of entities included in the given CADGroup. (inherited from CADGroup).
Public property | Name | Gets or sets a CADTable name read from a CAD file.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
See Also

Reference

CADTable Class


CADTable Methods

CADTable Class See Also

The following tables list the members exposed by the CADTable type.

Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADTable object.
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Iterate | Invokes the referenced (by the specified delegate) method for each CAD entity belonging to the given CADGroup. (inherited from CADGroup).
Public method | Loaded | Loads this CADGroup to the specified CADConverter. (inherited from CADGroup).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RemoveEntityByName | Searches for an entity using its name then removes the entity.
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADTable Class


CADTable.AddEntity Method

Adds the specified entity to this CADTable object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function AddEntity( _
   ByVal E As CADEntity _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool AddEntity(
   CADEntity E
)
This language is not supported or no code example is available.

Parameters

E

Type: CADEntity

A CADEntity to add.

Return Value

true if a CADEntity was added; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADTable Class
CADTable Members


CADTable Fields

CADTable Class See Also

The following tables list the members exposed by the CADTable type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADTable Class


CADText Class

Members See Also

Represents a single text line in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADText
    Inherits CADCustomVertex
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADText : CADCustomVertex
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADCustomVertex
CADImport.CADText
CADImport.CADAttdef
CADImport.CADShape
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Members


CADText Members

CADText Class Constructors Methods Fields Properties See Also

Represents a single text line in a CAD image.

The following tables list the members exposed by the CADText type.

Constructors
 | Name | Description
Public constructor | CADText | Initializes a new instance of the CADText object.
Top
Properties
 | Name | Description
Public property | Backward | Gets a value indicating whether the text line is turned backwards.
Public property | Box | Gets a three-dimensional box that encloses this CADText object.
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of this CADText object.
Public property | EntType | Gets a type of this CADText entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets the direction of axis Z belonging to the coordinate system of the CADText object.
Public property | FontName | Gets or sets a name of the font used by this CADText object.
Public property | HAlign | Gets or sets a horizontal alignment of a text.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Height | Gets or sets a height of the CADText letters.
Public property | InsideMText | Gets a value indicating whether this CADText object is a part of the multiline text.
Public property | IsSHXFont | Gets a value indicating whether this CADText object contains SHX fonts.
Public property | IsUnicodeText | Gets a value indicating whether this CADText object consists of unicode characters.
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADText.
Public property | ObliqueAngle | Gets or sets a tilt angle for the CADText letters.
Public property | Point | Gets or sets a position of the CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Point1 | Gets or sets a second alignment point of the CADText object.
Public property | Rotation | Gets or sets a rotation angle of the CADText object.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected.
Public property | StartPoint | Gets the start point of the text line.
Public property | Style | Gets or sets a style for the CADText object.
Public property | Text | Gets or sets a text contents for the CADText object.
Public property | TextStyle | Gets or sets a style of the CADText.
Public property | UnicodeText | Gets the Unicode text contained in this CADText object.
Public property | UpsideDown | Gets a value indicating whether the text line is turned downwards (mirrored along axis Z).
Public property | VAlign | Gets or sets a vetical alignment of the text.
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | XScale | Gets or sets a width scale (width factor) for the CADText.
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | ApplyStyle | Applies a specified CADStyle to the CADText entity.
Public method | AssignEntity | Copies an entity
Public method | ChangeByStyle | Changes CADStyle of the CADText to the specified one.
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADText.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExpR | Calculates a rectangle occupied by this CADText.
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADText to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADText Class


CADText Properties

CADText Class See Also

The following tables list the members exposed by the CADText type.

Properties
 | Name | Description
Public property | Backward | Gets a value indicating whether the text line is turned backwards.
Public property | Box | Gets a three-dimensional box that encloses this CADText object.
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of this CADText object.
Public property | EntType | Gets a type of this CADText entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets the direction of axis Z belonging to the coordinate system of the CADText object.
Public property | FontName | Gets or sets a name of the font used by this CADText object.
Public property | HAlign | Gets or sets a horizontal alignment of a text.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Height | Gets or sets a height of the CADText letters.
Public property | InsideMText | Gets a value indicating whether this CADText object is a part of the multiline text.
Public property | IsSHXFont | Gets a value indicating whether this CADText object contains SHX fonts.
Public property | IsUnicodeText | Gets a value indicating whether this CADText object consists of unicode characters.
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADText.
Public property | ObliqueAngle | Gets or sets a tilt angle for the CADText letters.
Public property | Point | Gets or sets a position of the CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Point1 | Gets or sets a second alignment point of the CADText object.
Public property | Rotation | Gets or sets a rotation angle of the CADText object.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected.
Public property | StartPoint | Gets the start point of the text line.
Public property | Style | Gets or sets a style for the CADText object.
Public property | Text | Gets or sets a text contents for the CADText object.
Public property | TextStyle | Gets or sets a style of the CADText.
Public property | UnicodeText | Gets the Unicode text contained in this CADText object.
Public property | UpsideDown | Gets a value indicating whether the text line is turned downwards (mirrored along axis Z).
Public property | VAlign | Gets or sets a vetical alignment of the text.
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | XScale | Gets or sets a width scale (width factor) for the CADText.
Top
See Also

Reference

CADText Class


CADText.EntType Property

Gets a type of this CADText entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADText Methods

CADText Class See Also

The following tables list the members exposed by the CADText type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | ApplyStyle | Applies a specified CADStyle to the CADText entity.
Public method | AssignEntity | Copies an entity
Public method | ChangeByStyle | Changes CADStyle of the CADText to the specified one.
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADText.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExpR | Calculates a rectangle occupied by this CADText.
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADText to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADText Class


CADText.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADText.Dispose Method

Releases all resources used by the CADText.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADText Class
CADText Members


CADText Fields

CADText Class See Also

The following tables list the members exposed by the CADText type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADText Class


CADTolerance Class

Members See Also

Represents a Tolerance object in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADTolerance
    Inherits CADMText
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADTolerance : CADMText
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADCustomVertex
CADImport.CADInsert
CADImport.CADMText
CADImport.CADTolerance
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADTolerance Members


CADTolerance Members

CADTolerance Class Constructors Methods Fields Properties See Also

Represents a Tolerance object in a CAD image.

The following tables list the members exposed by the CADTolerance type.

Constructors
 | Name | Description
Public constructor | CADTolerance | Initializes a new instance of the CADTolerance object.
Top
Properties
 | Name | Description
Public property | Align | Gets or sets an alignment of the text (inherited from CADMText).
Public property | Angle | Gets or sets an angle between a referenced block and CAD drawing. (inherited from CADInsert).
Public property | Attribs | Gets a collection of an attribs. (inherited from CADInsert).
Public property | Block | Gets or sets a block referenced by this CADInsert object. (inherited from CADInsert).
Public property | Box | Gets a three-dimensional box that encloses the CADInsert object. (inherited from CADInsert).
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of attribs belonging to the given CADInsert. (inherited from CADInsert).
Public property | DimScaleOverall | Gets or sets the overall dimensioning scale factor.
Public property | DimStyle | Gets or sets the name of a dimension style.
Public property | DimlineColor | Gets or sets the dimension extension line color.
Public property | EntName | Gets a name of the CADMText object. (inherited from CADMText).
Public property | EntType | Gets a type of this CADTolerance entity.
Public property | Entities | Gets a collection of attribs associated with the given CADInsert object. (inherited from CADInsert).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADInsert object. (inherited from CADInsert).
Public property | GAP | Gets or sets the dimension line gap.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Height | Gets or sets a height of a text (inherited from CADMText).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineSpacingFactor | Mtext line spacing factor (optional): (inherited from CADMText).
Public property | LineSpacingStyle | MText line spacing style (optional): (inherited from CADMText).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADInsert).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADInsert. (inherited from CADInsert).
Public property | OrientedByLayout | Defines orientation by layout for this MText. (inherited from CADMText).
Public property | Point | Gets or sets a position of the CADCustomVertex object. (inherited from CADMText).
Public property | Point1 | X-axis direction vector (in World Coordinate System). (inherited from CADMText).
Public property | RectHeight | Gets or sets a height of the bounding rectangle for the CADMText object. (inherited from CADMText).
Public property | RectWidth | Gets or sets a width of the bounding rectangle for the CADMText object. (inherited from CADMText).
Public property | Scale | Gets or sets a scale for drawning of the referenced block in a CAD image. (inherited from CADInsert).
Public property | Selected | Get or sets CADInsert selected. (inherited from CADInsert).
Public property | Style | Gets or sets a style for the CADMText object. (inherited from CADMText).
Public property | Text | Gets or sets a text contents for this CADMText object. (inherited from CADMText).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADInsert object. (inherited from CADInsert).
Public method | AssignEntity | Copies an entity
Public method | Attrib | Returns an attribute contained in the given CADInsert object. (inherited from CADInsert).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADTolerance to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADInsert entity. (inherited from CADInsert).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADTolerance Class


CADTolerance Constructor

Initializes a new instance of the CADTolerance object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADTolerance()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADTolerance Class
CADTolerance Members


CADTolerance Properties

CADTolerance Class See Also

The following tables list the members exposed by the CADTolerance type.

Properties
 | Name | Description
Public property | Align | Gets or sets an alignment of the text (inherited from CADMText).
Public property | Angle | Gets or sets an angle between a referenced block and CAD drawing. (inherited from CADInsert).
Public property | Attribs | Gets a collection of an attribs. (inherited from CADInsert).
Public property | Block | Gets or sets a block referenced by this CADInsert object. (inherited from CADInsert).
Public property | Box | Gets a three-dimensional box that encloses the CADInsert object. (inherited from CADInsert).
Public property | Color | Gets or sets a color for the this CADCustomVertex object. (inherited from CADCustomVertex).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of attribs belonging to the given CADInsert. (inherited from CADInsert).
Public property | DimScaleOverall | Gets or sets the overall dimensioning scale factor.
Public property | DimStyle | Gets or sets the name of a dimension style.
Public property | DimlineColor | Gets or sets the dimension extension line color.
Public property | EntName | Gets a name of the CADMText object. (inherited from CADMText).
Public property | EntType | Gets a type of this CADTolerance entity.
Public property | Entities | Gets a collection of attribs associated with the given CADInsert object. (inherited from CADInsert).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADInsert object. (inherited from CADInsert).
Public property | GAP | Gets or sets the dimension line gap.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Height | Gets or sets a height of a text (inherited from CADMText).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineSpacingFactor | Mtext line spacing factor (optional): (inherited from CADMText).
Public property | LineSpacingStyle | MText line spacing style (optional): (inherited from CADMText).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADInsert).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADInsert. (inherited from CADInsert).
Public property | OrientedByLayout | Defines orientation by layout for this MText. (inherited from CADMText).
Public property | Point | Gets or sets a position of the CADCustomVertex object. (inherited from CADMText).
Public property | Point1 | X-axis direction vector (in World Coordinate System). (inherited from CADMText).
Public property | RectHeight | Gets or sets a height of the bounding rectangle for the CADMText object. (inherited from CADMText).
Public property | RectWidth | Gets or sets a width of the bounding rectangle for the CADMText object. (inherited from CADMText).
Public property | Scale | Gets or sets a scale for drawning of the referenced block in a CAD image. (inherited from CADInsert).
Public property | Selected | Get or sets CADInsert selected. (inherited from CADInsert).
Public property | Style | Gets or sets a style for the CADMText object. (inherited from CADMText).
Public property | Text | Gets or sets a text contents for this CADMText object. (inherited from CADMText).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
See Also

Reference

CADTolerance Class


CADTolerance.DimScaleOverall Property

Gets or sets the overall dimensioning scale factor.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DimScaleOverall() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float DimScaleOverall {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADTolerance Class
CADTolerance Members


CADTolerance.DimStyle Property

Gets or sets the name of a dimension style.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DimStyle() As CADDimensionStyle
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADDimensionStyle DimStyle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADTolerance Class
CADTolerance Members


CADTolerance.DimlineColor Property

Gets or sets the dimension extension line color.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DimlineColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Color DimlineColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADTolerance Class
CADTolerance Members


CADTolerance.EntType Property

Gets a type of this CADTolerance entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADTolerance Class
CADTolerance Members


CADTolerance.GAP Property

Gets or sets the dimension line gap.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property GAP() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double GAP {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADTolerance Class
CADTolerance Members


CADTolerance Methods

CADTolerance Class See Also

The following tables list the members exposed by the CADTolerance type.

Methods
 | Name | Description
Public method | AddEntity | Adds the specified entity to this CADInsert object. (inherited from CADInsert).
Public method | AssignEntity | Copies an entity
Public method | Attrib | Returns an attribute contained in the given CADInsert object. (inherited from CADInsert).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADTolerance to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADInsert entity. (inherited from CADInsert).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADTolerance Class


CADTolerance.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADTolerance Class
CADTolerance Members


CADTolerance.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADTolerance Class
CADTolerance Members


CADTolerance.Loaded Method

Loads this CADTolerance to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADTolerance is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADTolerance Class
CADTolerance Members


CADTolerance Fields

CADTolerance Class See Also

The following tables list the members exposed by the CADTolerance type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADTolerance Class


CADTrace Class

Members See Also

Trace entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADTrace
    Inherits CADSolid
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADTrace : CADSolid
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.CADPenLine
CADImport.CADLine
CADImport.CADSolid
CADImport.CADTrace
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADTrace Members


CADTrace Members

CADTrace Class Constructors Methods Fields Properties See Also

Trace entity

The following tables list the members exposed by the CADTrace type.

Constructors
 | Name | Description
Public constructor | CADTrace | Initializes a new instance of the CADLine class. (inherited from CADLine).
Top
Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses the CADSolid entity. (inherited from CADSolid).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | DottedSingPts | Gets a collection of points that specify the dots and dashes of the CADLine. (inherited from CADLine).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADTrace entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADPenLine).
Public property | Point1 | Gets or sets a second end of the CADLine. (inherited from CADLine).
Public property | Point2 | Gets or sets a third point of the CADSolid object. (inherited from CADSolid).
Public property | Point3 | Gets or sets a fourth point of the CADSolid object. (inherited from CADSolid).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | AssignEntity | Copies an entity (inherited from CADSolid).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADLine).
Public method | DrawEntityTrace | Implements drawing of an entity with specified offset to specified Control (inherited from CADSolid).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADSolid object must be drawn during a drawing cycle. (inherited from CADSolid).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADSolid object to the specified CADConverter. (inherited from CADSolid).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADTrace Class


CADTrace Properties

CADTrace Class See Also

The following tables list the members exposed by the CADTrace type.

Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses the CADSolid entity. (inherited from CADSolid).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | DottedSingPts | Gets a collection of points that specify the dots and dashes of the CADLine. (inherited from CADLine).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CADTrace entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADPenLine).
Public property | Point1 | Gets or sets a second end of the CADLine. (inherited from CADLine).
Public property | Point2 | Gets or sets a third point of the CADSolid object. (inherited from CADSolid).
Public property | Point3 | Gets or sets a fourth point of the CADSolid object. (inherited from CADSolid).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
See Also

Reference

CADTrace Class


CADTrace.EntType Property

Gets the type of this CADTrace entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADTrace Class
CADTrace Members


CADTrace Methods

CADTrace Class See Also

The following tables list the members exposed by the CADTrace type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | AssignEntity | Copies an entity (inherited from CADSolid).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADLine).
Public method | DrawEntityTrace | Implements drawing of an entity with specified offset to specified Control (inherited from CADSolid).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADSolid object must be drawn during a drawing cycle. (inherited from CADSolid).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADSolid object to the specified CADConverter. (inherited from CADSolid).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADTrace Class


CADTrace Fields

CADTrace Class See Also

The following tables list the members exposed by the CADTrace type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADTrace Class


CADVPort Class

Members See Also

Represents a viewport in a model space.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADVPort
    Inherits CADEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADVPort : CADEntity
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADVPort
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADVPort Members


CADVPort Members

CADVPort Class Constructors Methods Fields Properties See Also

Represents a viewport in a model space.

The following tables list the members exposed by the CADVPort type.

Constructors
 | Name | Description
Public constructor | CADVPort | Initializes a new instance of the CADVPort class.
Top
Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | CircleZoomPercent | Gets or sets a circle zoom percent of this CADVPort object.
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer containing this CADEntity. (inherited from CADEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Name | Gets or sets a name of this CADVPort object.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | UCSOrigin | For internal uses
Public property | UCSVP | For internal uses
Public property | UCSXDir | For internal uses
Public property | UCSYDir | For internal uses
Public property | ViewAspectRatio | Gets or sets a view aspect ratio of this CADVPort object.
Public property | ViewCenterPoint | Gets or sets a view center point of this CADVPort object.
Public property | ViewDirection | Gets or sets a view direction of this CADVPort object.
Public property | ViewHeight | Gets or sets a view height of this CADVPort object.
Public property | ViewTarget | Gets or sets a view target of this CADVPort object.
Public property | ViewTwistAngle | Gets or sets a view twist angle for this CADVPort object.
Public property | Visibility | Gets or sets a value indicating whether a CADEntity is visible. (inherited from CADEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity (inherited from CADEntity).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADVPort to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADVPort Class


CADVPort Constructor

Initializes a new instance of the CADVPort class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADVPort()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADVPort Class
CADVPort Members


CADVPort Properties

CADVPort Class See Also

The following tables list the members exposed by the CADVPort type.

Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | CircleZoomPercent | Gets or sets a circle zoom percent of this CADVPort object.
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer containing this CADEntity. (inherited from CADEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Name | Gets or sets a name of this CADVPort object.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | UCSOrigin | For internal uses
Public property | UCSVP | For internal uses
Public property | UCSXDir | For internal uses
Public property | UCSYDir | For internal uses
Public property | ViewAspectRatio | Gets or sets a view aspect ratio of this CADVPort object.
Public property | ViewCenterPoint | Gets or sets a view center point of this CADVPort object.
Public property | ViewDirection | Gets or sets a view direction of this CADVPort object.
Public property | ViewHeight | Gets or sets a view height of this CADVPort object.
Public property | ViewTarget | Gets or sets a view target of this CADVPort object.
Public property | ViewTwistAngle | Gets or sets a view twist angle for this CADVPort object.
Public property | Visibility | Gets or sets a value indicating whether a CADEntity is visible. (inherited from CADEntity).
Top
See Also

Reference

CADVPort Class


CADVPort.CircleZoomPercent Property

Gets or sets a circle zoom percent of this CADVPort object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property CircleZoomPercent() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int CircleZoomPercent {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADVPort Class
CADVPort Members


CADVPort.Name Property

Gets or sets a name of this CADVPort object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Name() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Name {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADVPort Class
CADVPort Members


CADVPort.UCSOrigin Property

For internal uses

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property UCSOrigin() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint UCSOrigin {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADVPort Class
CADVPort Members


CADVPort.UCSVP Property

For internal uses

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property UCSVP() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool UCSVP {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADVPort Class
CADVPort Members


CADVPort.UCSXDir Property

For internal uses

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property UCSXDir() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint UCSXDir {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADVPort Class
CADVPort Members


CADVPort.UCSYDir Property

For internal uses

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property UCSYDir() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint UCSYDir {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADVPort Class
CADVPort Members


CADVPort.ViewAspectRatio Property

Gets or sets a view aspect ratio of this CADVPort object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ViewAspectRatio() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double ViewAspectRatio {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADVPort Class
CADVPort Members


CADVPort.ViewCenterPoint Property

Gets or sets a view center point of this CADVPort object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ViewCenterPoint() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint ViewCenterPoint {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADVPort Class
CADVPort Members


CADVPort.ViewDirection Property

Gets or sets a view direction of this CADVPort object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ViewDirection() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint ViewDirection {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADVPort Class
CADVPort Members


CADVPort.ViewHeight Property

Gets or sets a view height of this CADVPort object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ViewHeight() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double ViewHeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADVPort Class
CADVPort Members


CADVPort.ViewTarget Property

Gets or sets a view target of this CADVPort object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ViewTarget() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint ViewTarget {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADVPort Class
CADVPort Members


CADVPort.ViewTwistAngle Property

Gets or sets a view twist angle for this CADVPort object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ViewTwistAngle() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float ViewTwistAngle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADVPort Class
CADVPort Members


CADVPort Methods

CADVPort Class See Also

The following tables list the members exposed by the CADVPort type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity (inherited from CADEntity).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADVPort to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADVPort Class


CADVPort.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADVPort Class
CADVPort Members


CADVPort.Loaded Method

Loads this CADVPort to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADVPort is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADVPort Class
CADVPort Members


CADVPort Fields

CADVPort Class See Also

The following tables list the members exposed by the CADVPort type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADVPort Class


CADVertex Class

Members See Also

Represents a vertex of a CADPolyLine.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADVertex
    Inherits CADEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADVertex : CADEntity
This language is not supported or no code example is available.
Remarks

The vertex is a special point of a polyline. It can specify the start point of a polyline, or its end point, or a junction point of two polyline segments. The vertex also has the index value that specifies an order the vertex appears within the polyline, with the first being numbered 1.

Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADVertex
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADVertex Members


CADVertex Members

CADVertex Class Constructors Methods Fields Properties See Also

Represents a vertex of a CADPolyLine.

The following tables list the members exposed by the CADVertex type.

Constructors
 | Name | Description
Public constructor | CADVertex | Initializes a new instance of the CADEntity class. (inherited from CADEntity).
Top
Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses the CADVertex entity.
Public property | Bulge | Gets or sets a bulge for the arc segment starting at this vertex.
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EndWidth | Gets or sets a width at the end point of a polyline segment that started at this vertex.
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Flags | Gets or sets a byte that contains flags for this CADVertex.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer containing this CADEntity. (inherited from CADEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Point | Gets or sets coordinates of the CADVertex.
Public property | PolyFaceVertexIndex1 | Gets or sets an index of this CADVertex when it represents a first vertex specifying a face belonging to the polyface mesh.
Public property | PolyFaceVertexIndex2 | Gets or sets an index of this CADVertex when it represents a second vertex specifying a face belonging to the polyface mesh.
Public property | PolyFaceVertexIndex3 | Gets or sets an index of this CADVertex when it represents a third vertex specifying a face belonging to the polyface mesh.
Public property | PolyFaceVertexIndex4 | Gets or sets an index of this CADVertex when it represents a fourth vertex specifying a face belonging to the polyface mesh.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | StartWidth | Gets or sets a width at the start point of a polyline segment that started at this vertex.
Public property | Visibility | Gets or sets a value indicating whether a CADEntity is visible. (inherited from CADEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADEntity).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADVertex Class


CADVertex Properties

CADVertex Class See Also

The following tables list the members exposed by the CADVertex type.

Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses the CADVertex entity.
Public property | Bulge | Gets or sets a bulge for the arc segment starting at this vertex.
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EndWidth | Gets or sets a width at the end point of a polyline segment that started at this vertex.
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Flags | Gets or sets a byte that contains flags for this CADVertex.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer containing this CADEntity. (inherited from CADEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Point | Gets or sets coordinates of the CADVertex.
Public property | PolyFaceVertexIndex1 | Gets or sets an index of this CADVertex when it represents a first vertex specifying a face belonging to the polyface mesh.
Public property | PolyFaceVertexIndex2 | Gets or sets an index of this CADVertex when it represents a second vertex specifying a face belonging to the polyface mesh.
Public property | PolyFaceVertexIndex3 | Gets or sets an index of this CADVertex when it represents a third vertex specifying a face belonging to the polyface mesh.
Public property | PolyFaceVertexIndex4 | Gets or sets an index of this CADVertex when it represents a fourth vertex specifying a face belonging to the polyface mesh.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | StartWidth | Gets or sets a width at the start point of a polyline segment that started at this vertex.
Public property | Visibility | Gets or sets a value indicating whether a CADEntity is visible. (inherited from CADEntity).
Top
See Also

Reference

CADVertex Class


CADVertex.Box Property

Gets a three-dimensional box that encloses the CADVertex entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Box() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override DRect Box {get;}
This language is not supported or no code example is available.

Property Value

A DRect object representing the enclosing box for the CADVertex.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADVertex Class
CADVertex Members


CADVertex.Bulge Property

Gets or sets a bulge for the arc segment starting at this vertex.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Bulge() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Bulge {get; set;}
This language is not supported or no code example is available.
Remarks

The bulge is the tangent of one fourth the included angle for an arc segment, made negative if the arc goes clockwise from the start point to the end point. A bulge of 0 indicates a straight segment, and a bulge of 1 is a semicircle.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADVertex Class
CADVertex Members


CADVertex.EndWidth Property

Gets or sets a width at the end point of a polyline segment that started at this vertex.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property EndWidth() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float EndWidth {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADVertex Class
CADVertex Members


CADVertex.Flags Property

Gets or sets a byte that contains flags for this CADVertex.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Flags() As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte Flags {get; set;}
This language is not supported or no code example is available.
Remarks

            Vertex flags:
1 = Extra vertex created by curve-fitting.
2 = Curve-fit tangent defined for this vertex. A curve-fit tangent direction of 0 may be omitted from DXF output but is significant if this bit is set.
4 = Not used.
8 = Spline vertex created by spline-fitting.
16 = Spline frame control point.
32 = 3D polyline vertex.
64 = 3D polygon mesh.
128 = Polyface mesh vertex.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADVertex Class
CADVertex Members


CADVertex.Point Property

Gets or sets coordinates of the CADVertex.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Point() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Point {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object that provides coordinates of the vertex.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADVertex Class
CADVertex Members


CADVertex.PolyFaceVertexIndex1 Property

Gets or sets an index of this CADVertex when it represents a first vertex specifying a face belonging to the polyface mesh.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PolyFaceVertexIndex1() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int PolyFaceVertexIndex1 {get; set;}
This language is not supported or no code example is available.
Remarks

Every vertex that is a part of a polyface mesh has its vertex flag 128 bit set.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADVertex Class
CADVertex Members


CADVertex.PolyFaceVertexIndex2 Property

Gets or sets an index of this CADVertex when it represents a second vertex specifying a face belonging to the polyface mesh.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PolyFaceVertexIndex2() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int PolyFaceVertexIndex2 {get; set;}
This language is not supported or no code example is available.
Remarks

Every vertex that is a part of a polyface mesh has its vertex flag 128 bit set.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADVertex Class
CADVertex Members


CADVertex.PolyFaceVertexIndex3 Property

Gets or sets an index of this CADVertex when it represents a third vertex specifying a face belonging to the polyface mesh.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PolyFaceVertexIndex3() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int PolyFaceVertexIndex3 {get; set;}
This language is not supported or no code example is available.
Remarks

Every vertex that is a part of a polyface mesh has its vertex flag 128 bit set.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADVertex Class
CADVertex Members


CADVertex.PolyFaceVertexIndex4 Property

Gets or sets an index of this CADVertex when it represents a fourth vertex specifying a face belonging to the polyface mesh.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PolyFaceVertexIndex4() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int PolyFaceVertexIndex4 {get; set;}
This language is not supported or no code example is available.
Remarks

Every vertex that is a part of a polyface mesh has its vertex flag 128 bit set.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADVertex Class
CADVertex Members


CADVertex.StartWidth Property

Gets or sets a width at the start point of a polyline segment that started at this vertex.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property StartWidth() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float StartWidth {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADVertex Class
CADVertex Members


CADVertex Methods

CADVertex Class See Also

The following tables list the members exposed by the CADVertex type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADEntity).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADVertex Class


CADVertex.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADVertex Class
CADVertex Members


CADVertex Fields

CADVertex Class See Also

The following tables list the members exposed by the CADVertex type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADVertex Class


CADViewPort Class

Members See Also

Represents a layout viewport in a CAD drawing.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADViewPort
    Inherits CADPenEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADViewPort : CADPenEntity
This language is not supported or no code example is available.
Remarks

Viewport is a window through that a model space can be viewed.

Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.CADViewPort
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewPort Members


CADViewPort Members

CADViewPort Class Constructors Methods Fields Properties See Also

Represents a layout viewport in a CAD drawing.

The following tables list the members exposed by the CADViewPort type.

Constructors
 | Name | Description
Public constructor | CADViewPort | Initializes a new instance of the CADViewPort class.
Top
Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses the CADViewPort object.
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets a type of this CADViewPort entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | FrozenLayers | Gets or sets a list of frozen layers in the current viewport.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | MSpaceCenter | Gets or sets a view center point in display coordinate system (DCS).
Public property | MSpaceHeight | Gets or sets a height of the model space displayed in the viewport and measured in model space units.
Public property | PSpaceCenter | Gets or sets a view center point in world coordinate system (WCS).
Public property | PSpaceHeight | Gets or sets a height of the model space displayed in the viewport and measured in paper space units.
Public property | PSpaceWidth | Gets or sets a width of the model space displayed in the viewport and measured in paper space units.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | ViewDirection | Gets or sets a view direction vector in the world coordinate system (WCS).
Public property | ViewTarget | Gets or sets a view target point in the world coordinate system (WCS).
Public property | ViewTwistAngle | Gets or sets a rotation angle for the image displayed in the CADViewPort.
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | VisibleBoundary | Gets or sets a value indicating whether the viewport's boundary is visible.
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoundary | Gets a boundary of the CADViewPort.
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetDrawModel | Returns a value indicating whether a model space can be displayed in the viewport.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADViewPort to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetBoundary | Sets a boundary of the CADViewPort.
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADViewPort Class


CADViewPort Constructor

Initializes a new instance of the CADViewPort class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADViewPort()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewPort Class
CADViewPort Members


CADViewPort Properties

CADViewPort Class See Also

The following tables list the members exposed by the CADViewPort type.

Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses the CADViewPort object.
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets a type of this CADViewPort entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | FrozenLayers | Gets or sets a list of frozen layers in the current viewport.
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | MSpaceCenter | Gets or sets a view center point in display coordinate system (DCS).
Public property | MSpaceHeight | Gets or sets a height of the model space displayed in the viewport and measured in model space units.
Public property | PSpaceCenter | Gets or sets a view center point in world coordinate system (WCS).
Public property | PSpaceHeight | Gets or sets a height of the model space displayed in the viewport and measured in paper space units.
Public property | PSpaceWidth | Gets or sets a width of the model space displayed in the viewport and measured in paper space units.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | ViewDirection | Gets or sets a view direction vector in the world coordinate system (WCS).
Public property | ViewTarget | Gets or sets a view target point in the world coordinate system (WCS).
Public property | ViewTwistAngle | Gets or sets a rotation angle for the image displayed in the CADViewPort.
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | VisibleBoundary | Gets or sets a value indicating whether the viewport's boundary is visible.
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Top
See Also

Reference

CADViewPort Class


CADViewPort.Box Property

Gets a three-dimensional box that encloses the CADViewPort object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Box() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override DRect Box {get;}
This language is not supported or no code example is available.

Property Value

A DRect object representing the box that encloses the CADViewPort object.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewPort Class
CADViewPort Members


CADViewPort.EntType Property

Gets a type of this CADViewPort entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewPort Class
CADViewPort Members


CADViewPort.FrozenLayers Property

Gets or sets a list of frozen layers in the current viewport.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property FrozenLayers() As CADCollection(Of UInt64)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection<UInt64> FrozenLayers {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewPort Class
CADViewPort Members


CADViewPort.MSpaceCenter Property

Gets or sets a view center point in display coordinate system (DCS).

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property MSpaceCenter() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint MSpaceCenter {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object representing a view center point in display coordinate system (DCS).
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewPort Class
CADViewPort Members


CADViewPort.MSpaceHeight Property

Gets or sets a height of the model space displayed in the viewport and measured in model space units.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property MSpaceHeight() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double MSpaceHeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewPort Class
CADViewPort Members


CADViewPort.PSpaceCenter Property

Gets or sets a view center point in world coordinate system (WCS).

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PSpaceCenter() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint PSpaceCenter {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object representing a view center point in world coordinate system (WCS).
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewPort Class
CADViewPort Members


CADViewPort.PSpaceHeight Property

Gets or sets a height of the model space displayed in the viewport and measured in paper space units.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PSpaceHeight() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double PSpaceHeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewPort Class
CADViewPort Members


CADViewPort.PSpaceWidth Property

Gets or sets a width of the model space displayed in the viewport and measured in paper space units.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PSpaceWidth() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double PSpaceWidth {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewPort Class
CADViewPort Members


CADViewPort.ViewDirection Property

Gets or sets a view direction vector in the world coordinate system (WCS).

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ViewDirection() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint ViewDirection {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object specifying a view direction vector.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewPort Class
CADViewPort Members


CADViewPort.ViewTarget Property

Gets or sets a view target point in the world coordinate system (WCS).

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ViewTarget() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint ViewTarget {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object representing a view target point.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewPort Class
CADViewPort Members


CADViewPort.ViewTwistAngle Property

Gets or sets a rotation angle for the image displayed in the CADViewPort.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ViewTwistAngle() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float ViewTwistAngle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewPort Class
CADViewPort Members


CADViewPort.VisibleBoundary Property

Gets or sets a value indicating whether the viewport's boundary is visible.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property VisibleBoundary() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool VisibleBoundary {get; set;}
This language is not supported or no code example is available.

Property Value

true if the boundary is visible; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewPort Class
CADViewPort Members


CADViewPort Methods

CADViewPort Class See Also

The following tables list the members exposed by the CADViewPort type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoundary | Gets a boundary of the CADViewPort.
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetDrawModel | Returns a value indicating whether a model space can be displayed in the viewport.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADViewPort to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetBoundary | Sets a boundary of the CADViewPort.
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADViewPort Class


CADViewPort.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewPort Class
CADViewPort Members


CADViewPort.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewPort Class
CADViewPort Members


CADViewPort.GetBoundary Method

Gets a boundary of the CADViewPort.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetBoundary( _
   ByVal AConverter As CADConverter _
) As CADEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntity GetBoundary(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter that provides an entity specifying a shape of the viewport's boundary.

Return Value

A CADEntity that specifies a shape of the viewport's boundary.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewPort Class
CADViewPort Members


CADViewPort.GetDrawModel Method

Returns a value indicating whether a model space can be displayed in the viewport.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetDrawModel() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool GetDrawModel()
This language is not supported or no code example is available.

Return Value

true if a model space can be displayed in the viewport; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewPort Class
CADViewPort Members


CADViewPort.Loaded Method

Loads this CADViewPort to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADViewPort is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewPort Class
CADViewPort Members


CADViewPort.SetBoundary Method

Sets a boundary of the CADViewPort.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetBoundary( _
   ByVal ABoundary As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetBoundary(
   CADEntity ABoundary
)
This language is not supported or no code example is available.

Parameters

ABoundary

Type: CADEntity

A CADEntity that specifies a shape of the viewport's boundary.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewPort Class
CADViewPort Members


CADViewPort Fields

CADViewPort Class See Also

The following tables list the members exposed by the CADViewPort type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADViewPort Class


CADWipeout Class

Members See Also

Represents a wipeout entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADWipeout
    Inherits CADPolylineBase
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADWipeout : CADPolylineBase
This language is not supported or no code example is available.
Remarks

Wipeout is an analog of the filling by the background color.

Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.CADPenLine
CADImport.CADPolylineBase
CADImport.CADWipeout
CADImport.CADImageEnt
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADWipeout Members


CADWipeout Members

CADWipeout Class Constructors Methods Fields Properties See Also

Represents a wipeout entity.

The following tables list the members exposed by the CADWipeout type.

Constructors
 | Name | Description
Public constructor | CADWipeout | Initializes a new instance of the CADWipeout class.
Top
Properties
 | Name | Description
Public property | Box | Return box of the current primitive. (inherited from CADPolylineBase).
Public property | ClipPoints | Gets or sets a collection of the clipping points.
Public property | ClippingBoundaryType | Gets or sets a type of the clipping boundary of the current wipeout.
Public property | Closed | Gets or sets a value indicating whether this CADPolyLine is closed. (inherited from CADPolylineBase).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADPolylineBase. (inherited from CADPolylineBase).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | DottedSingPoints | Gets a collection of points that specify the dots and dashes of the CADPolylineBase. (inherited from CADPolylineBase).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets a type of this CADWipeout entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Flags | Gets or sets a number that specifies an appearance of this CADPolylineBase entity. (inherited from CADPolylineBase).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Height | Gets or sets a height of this wipeout.
Public property | IsMeshMClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the M direction. (inherited from CADPolylineBase).
Public property | IsMeshNClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the N direction. (inherited from CADPolylineBase).
Public property | IsPolyFaceMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | IsPolyZThickness | Gets a value indicating whether a line thickness measured along the axis Z is equal to 0. (inherited from CADPolylineBase).
Public property | IsPolygonMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | IsUseClipping | Indicates whether the clipping is used.
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADPenLine).
Public property | PolyPoints | Gets a collection of points belonging to the polyline. (inherited from CADPolylineBase).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Size | Gets or sets scale vector.
Public property | UVector | Gets or sets UVector.
Public property | VVector | Gets or sets VVector.
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a width of the wipeout.
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddPoint | Adds a point with x,y coordinates into the clip points.
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | ApplyBox | Calculates a box of the current entity. (inherited from CADPolylineBase).
Public method | AssignEntity | Copies an entity.
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Used in drawing cycle for fast checking whether the entity must be drawn (inherited from CADPolylineBase).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADPolylineBase to the specified CADConverter. (inherited from CADPolylineBase).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADWipeout Class


CADWipeout Constructor

Initializes a new instance of the CADWipeout class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADWipeout()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADWipeout Class
CADWipeout Members


CADWipeout Properties

CADWipeout Class See Also

The following tables list the members exposed by the CADWipeout type.

Properties
 | Name | Description
Public property | Box | Return box of the current primitive. (inherited from CADPolylineBase).
Public property | ClipPoints | Gets or sets a collection of the clipping points.
Public property | ClippingBoundaryType | Gets or sets a type of the clipping boundary of the current wipeout.
Public property | Closed | Gets or sets a value indicating whether this CADPolyLine is closed. (inherited from CADPolylineBase).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADPolylineBase. (inherited from CADPolylineBase).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | DottedSingPoints | Gets a collection of points that specify the dots and dashes of the CADPolylineBase. (inherited from CADPolylineBase).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets a type of this CADWipeout entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Flags | Gets or sets a number that specifies an appearance of this CADPolylineBase entity. (inherited from CADPolylineBase).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Height | Gets or sets a height of this wipeout.
Public property | IsMeshMClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the M direction. (inherited from CADPolylineBase).
Public property | IsMeshNClosed | Gets a value indicating whether a mesh represented by this CADPolylineBase is closed in the N direction. (inherited from CADPolylineBase).
Public property | IsPolyFaceMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | IsPolyZThickness | Gets a value indicating whether a line thickness measured along the axis Z is equal to 0. (inherited from CADPolylineBase).
Public property | IsPolygonMesh | Indicates that the current primitive is mesh. (inherited from CADPolylineBase).
Public property | IsUseClipping | Indicates whether the clipping is used.
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADPenLine).
Public property | PolyPoints | Gets a collection of points belonging to the polyline. (inherited from CADPolylineBase).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Size | Gets or sets scale vector.
Public property | UVector | Gets or sets UVector.
Public property | VVector | Gets or sets VVector.
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a width of the wipeout.
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
See Also

Reference

CADWipeout Class


CADWipeout.EntType Property

Gets a type of this CADWipeout entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADWipeout Class
CADWipeout Members


CADWipeout Methods

CADWipeout Class See Also

The following tables list the members exposed by the CADWipeout type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddPoint | Adds a point with x,y coordinates into the clip points.
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | ApplyBox | Calculates a box of the current entity. (inherited from CADPolylineBase).
Public method | AssignEntity | Copies an entity.
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Used in drawing cycle for fast checking whether the entity must be drawn (inherited from CADPolylineBase).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADPolylineBase to the specified CADConverter. (inherited from CADPolylineBase).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADWipeout Class


CADWipeout.AssignEntity Method

Copies an entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADWipeout Class
CADWipeout Members


CADWipeout.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADWipeout Class
CADWipeout Members


CADWipeout Fields

CADWipeout Class See Also

The following tables list the members exposed by the CADWipeout type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADWipeout Class


CADXRef Class

Members See Also

Represents an external reference in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADXRef
    Inherits CADPlotEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADXRef : CADPlotEntity
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADXRef
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADXRef Members


CADXRef Members

CADXRef Class Constructors Methods Fields Properties See Also

Represents an external reference in a CAD image.

The following tables list the members exposed by the CADXRef type.

Constructors
 | Name | Description
Public constructor | CADXRef | (Overloaded) Initializes a new instance of the CADXRef class.
Top
Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses the CADXref object.
Public property | CADImage | Gets a CAD image received from the referenced file.
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets a type of this CADXRef entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Name | Gets a name of the referenced file.
Public property | Path | Gets a full path to the referenced file.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
Methods
 | Name | Description
Public method | AddCADImage | Adds a CAD image from the specified file to the CAD drawing that owns this external reference.
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADXRef object to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADXRef Class


CADXRef Constructor

CADXRef Class See Also

Initializes a new instance of the CADXRef class.

Overload List
Name | Description
CADXRef() | Initializes a new instance of the CADXRef class.
CADXRef(CADConverter) | Initializes a new instance of the CADXRef class.
See Also

Reference

CADXRef Class
CADXRef Members


CADXRef Properties

CADXRef Class See Also

The following tables list the members exposed by the CADXRef type.

Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses the CADXref object.
Public property | CADImage | Gets a CAD image received from the referenced file.
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets a type of this CADXRef entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Name | Gets a name of the referenced file.
Public property | Path | Gets a full path to the referenced file.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
See Also

Reference

CADXRef Class


CADXRef.Box Property

Gets a three-dimensional box that encloses the CADXref object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Box() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override DRect Box {get;}
This language is not supported or no code example is available.

Property Value

A DRect object representing the enclosing box for the CADXref entity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADXRef Class
CADXRef Members


CADXRef.CADImage Property

Gets a CAD image received from the referenced file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property CADImage() As CADImage
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADImage CADImage {get;}
This language is not supported or no code example is available.

Property Value

An Object representing an image from the referenced file.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADXRef Class
CADXRef Members


CADXRef.EntType Property

Gets a type of this CADXRef entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADXRef Class
CADXRef Members


CADXRef.Name Property

Gets a name of the referenced file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Name {get;}
This language is not supported or no code example is available.
Remarks

A string containing a name of the referenced file.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADXRef Class
CADXRef Members


CADXRef.Path Property

Gets a full path to the referenced file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Path() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Path {get;}
This language is not supported or no code example is available.
Remarks

A string containing a full path to the referenced file.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADXRef Class
CADXRef Members


CADXRef Methods

CADXRef Class See Also

The following tables list the members exposed by the CADXRef type.

Methods
 | Name | Description
Public method | AddCADImage | Adds a CAD image from the specified file to the CAD drawing that owns this external reference.
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADXRef object to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADXRef Class


CADXRef.AddCADImage Method

Adds a CAD image from the specified file to the CAD drawing that owns this external reference.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function AddCADImage( _
   ByVal AFilePath As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool AddCADImage(
   string AFilePath
)
This language is not supported or no code example is available.

Parameters

AFilePath

Type: string

A string containing a full path to the referenced file.

Return Value

true if a CAD image from the referenced file has been added successfully; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADXRef Class
CADXRef Members


CADXRef.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADXRef Class
CADXRef Members


CADXRef.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADXRef Class
CADXRef Members


CADXRef.Loaded Method

Loads this CADXRef object to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADXRef object is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADXRef Class
CADXRef Members


CADXRef Fields

CADXRef Class See Also

The following tables list the members exposed by the CADXRef type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CADXRef Class


ColorTypeConverter Class

Members See Also

Provides functionality for both-way converting the string objects to objects representing colors.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class ColorTypeConverter
    Inherits StringConverter
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class ColorTypeConverter : StringConverter
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.ComponentModel.TypeConverter
System.ComponentModel.StringConverter
CADImport.ColorTypeConverter
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ColorTypeConverter Members


ColorTypeConverter Members

ColorTypeConverter Class Methods See Also

Provides functionality for both-way converting the string objects to objects representing colors.

The following tables list the members exposed by the ColorTypeConverter type.

Methods
 | Name | Description
Public method | CanConvertFrom | (Overloaded) Gets a value indicating whether this converter can convert an object in the given source type to a string using the specified context. (inherited from StringConverter).
Public method | CanConvertTo | (Overloaded) Returns whether this converter can convert the object to the specified type. (inherited from TypeConverter).
Public method | ConvertFrom | (Overloaded) Converts the specified value object to a String object. (inherited from StringConverter).
Public method | ConvertFromInvariantString | (Overloaded) Converts the given string to the type of this converter, using the invariant culture. (inherited from TypeConverter).
Public method | ConvertFromString | (Overloaded) Converts the specified text to an object. (inherited from TypeConverter).
Public method | ConvertTo | (Overloaded) Converts the given value object to the specified type, using the arguments. (inherited from TypeConverter).
Public method | ConvertToInvariantString | (Overloaded) Converts the specified value to a culture-invariant string representation. (inherited from TypeConverter).
Public method | ConvertToString | (Overloaded) Converts the specified value to a string representation. (inherited from TypeConverter).
Public method | CreateInstance | (Overloaded) Re-creates an Object given a set of property values for the object. (inherited from TypeConverter).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetCreateInstanceSupported | (Overloaded) Returns whether changing a value on this object requires a call to the IDictionary) method to create a new value. (inherited from TypeConverter).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetProperties | (Overloaded) Returns a collection of properties for the type of array specified by the value parameter. (inherited from TypeConverter).
Public method | GetPropertiesSupported | (Overloaded) Returns whether this object supports properties. (inherited from TypeConverter).
Public method | GetStandardValues | (Overloaded) Overloaded. Returns a collection of standard color values.
Public method | GetStandardValuesExclusive | (Overloaded) Overloaded. Returns a value indicating that a collection returned by the GetStandardValues method is not an exclusive list.
Public method | GetStandardValuesSupported | (Overloaded) Overloaded. Returns a value indicating that ColorTypeConverter supports standard values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IsValid | (Overloaded) Returns whether the given value object is valid for this type. (inherited from TypeConverter).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

ColorTypeConverter Class


ColorTypeConverter Methods

ColorTypeConverter Class See Also

The following tables list the members exposed by the ColorTypeConverter type.

Methods
 | Name | Description
Public method | CanConvertFrom | (Overloaded) Gets a value indicating whether this converter can convert an object in the given source type to a string using the specified context. (inherited from StringConverter).
Public method | CanConvertTo | (Overloaded) Returns whether this converter can convert the object to the specified type. (inherited from TypeConverter).
Public method | ConvertFrom | (Overloaded) Converts the specified value object to a String object. (inherited from StringConverter).
Public method | ConvertFromInvariantString | (Overloaded) Converts the given string to the type of this converter, using the invariant culture. (inherited from TypeConverter).
Public method | ConvertFromString | (Overloaded) Converts the specified text to an object. (inherited from TypeConverter).
Public method | ConvertTo | (Overloaded) Converts the given value object to the specified type, using the arguments. (inherited from TypeConverter).
Public method | ConvertToInvariantString | (Overloaded) Converts the specified value to a culture-invariant string representation. (inherited from TypeConverter).
Public method | ConvertToString | (Overloaded) Converts the specified value to a string representation. (inherited from TypeConverter).
Public method | CreateInstance | (Overloaded) Re-creates an Object given a set of property values for the object. (inherited from TypeConverter).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetCreateInstanceSupported | (Overloaded) Returns whether changing a value on this object requires a call to the IDictionary) method to create a new value. (inherited from TypeConverter).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetProperties | (Overloaded) Returns a collection of properties for the type of array specified by the value parameter. (inherited from TypeConverter).
Public method | GetPropertiesSupported | (Overloaded) Returns whether this object supports properties. (inherited from TypeConverter).
Public method | GetStandardValues | (Overloaded) Overloaded. Returns a collection of standard color values.
Public method | GetStandardValuesExclusive | (Overloaded) Overloaded. Returns a value indicating that a collection returned by the GetStandardValues method is not an exclusive list.
Public method | GetStandardValuesSupported | (Overloaded) Overloaded. Returns a value indicating that ColorTypeConverter supports standard values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IsValid | (Overloaded) Returns whether the given value object is valid for this type. (inherited from TypeConverter).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

ColorTypeConverter Class


ColorTypeConverter.GetStandardValues Method

ColorTypeConverter Class See Also

Overloaded. Returns a collection of standard color values.

Overload List
Name | Description
GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (System.ComponentModel.TypeConverter).
GetStandardValues(ITypeDescriptorContext) | Overloaded. Returns a collection of standard color values.
See Also

Reference

ColorTypeConverter Class
ColorTypeConverter Members


ColorTypeConverter.GetStandardValuesExclusive Method

ColorTypeConverter Class See Also

Overloaded. Returns a value indicating that a collection returned by the GetStandardValues method is not an exclusive list.

Overload List
Name | Description
GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (System.ComponentModel.TypeConverter).
GetStandardValuesExclusive(ITypeDescriptorContext) | Overloaded. Returns a value indicating that a collection returned by the GetStandardValues method is not an exclusive list.
See Also

Reference

ColorTypeConverter Class
ColorTypeConverter Members


ColorTypeConverter.GetStandardValuesSupported Method

ColorTypeConverter Class See Also

Overloaded. Returns a value indicating that ColorTypeConverter supports standard values.

Overload List
Name | Description
GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (System.ComponentModel.TypeConverter).
GetStandardValuesSupported(ITypeDescriptorContext) | Overloaded. Returns a value indicating that ColorTypeConverter supports standard values.
See Also

Reference

ColorTypeConverter Class
ColorTypeConverter Members


DWGProps Class

Members See Also

Represents the set of properties for an AutoCAD drawing.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class DWGProps
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class DWGProps
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.DWGProps
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DWGProps Members


DWGProps Members

DWGProps Class Methods Fields See Also

Represents the set of properties for an AutoCAD drawing.

The following tables list the members exposed by the DWGProps type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | Author | The author
Public field | Comments | Comments
Public field | DateOfCreation | The date of the drawing creation
Public field | DateOfLastChange | The date of the drawing last change
Public field | HyperlinkBase | The base of a hyperlink
Public field | Keywords | Keywords;
Public field | Other | Other properties
Public field | RevisionNumber | Revision number
Public field | SavedBy | The author of the drawing last edition
Public field | Subject | The subject
Public field | Title | The title
Public field | TotalEditingTime | Total time of drawing editing
Top
See Also

Reference

DWGProps Class


DWGProps Methods

DWGProps Class See Also

The following tables list the members exposed by the DWGProps type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

DWGProps Class


DWGProps Fields

DWGProps Class See Also

The following tables list the members exposed by the DWGProps type.

Fields
 | Name | Description
Public field | Author | The author
Public field | Comments | Comments
Public field | DateOfCreation | The date of the drawing creation
Public field | DateOfLastChange | The date of the drawing last change
Public field | HyperlinkBase | The base of a hyperlink
Public field | Keywords | Keywords;
Public field | Other | Other properties
Public field | RevisionNumber | Revision number
Public field | SavedBy | The author of the drawing last edition
Public field | Subject | The subject
Public field | Title | The title
Public field | TotalEditingTime | Total time of drawing editing
Top
See Also

Reference

DWGProps Class


Author Field

The author

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Author As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Author
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DWGProps Class
DWGProps Members


Comments Field

Comments

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Comments As List(Of String)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public List<string> Comments
This language is not supported or no code example is available.

Type Parameters

string

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DWGProps Class
DWGProps Members


DateOfCreation Field

The date of the drawing creation

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public DateOfCreation As Date
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DateTime DateOfCreation
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DWGProps Class
DWGProps Members


DateOfLastChange Field

The date of the drawing last change

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public DateOfLastChange As Date
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DateTime DateOfLastChange
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DWGProps Class
DWGProps Members


HyperlinkBase Field

The base of a hyperlink

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public HyperlinkBase As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string HyperlinkBase
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DWGProps Class
DWGProps Members


Keywords Field

Keywords;

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Keywords As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Keywords
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DWGProps Class
DWGProps Members


Other Field

Other properties

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Other As SortedList(Of String, String)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SortedList<string, string> Other
This language is not supported or no code example is available.

Type Parameters

string

string

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DWGProps Class
DWGProps Members


RevisionNumber Field

Revision number

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public RevisionNumber As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string RevisionNumber
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DWGProps Class
DWGProps Members


SavedBy Field

The author of the drawing last edition

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public SavedBy As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string SavedBy
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DWGProps Class
DWGProps Members


Subject Field

The subject

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Subject As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Subject
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DWGProps Class
DWGProps Members


Title Field

The title

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Title As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Title
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DWGProps Class
DWGProps Members


TotalEditingTime Field

Total time of drawing editing

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public TotalEditingTime As TimeSpan
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public TimeSpan TotalEditingTime
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DWGProps Class
DWGProps Members


DynamicArray<T> Class

Members See Also

Represents an array of typed elements.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class DynamicArray(Of  _
   T As New)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class DynamicArray<T>
   where T : new()
This language is not supported or no code example is available.

Type Parameters

T

A type of elements

Inheritance Hierarchy
System.Object
CADImport.DynamicArray<T>
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DynamicArray<T> Members


DynamicArray<T> Members

DynamicArray<T> Class Constructors Methods Properties See Also

Represents an array of typed elements.

The following tables list the members exposed by the DynamicArray<T> type.

Constructors
 | Name | Description
Public constructor | DynamicArray<T> | (Overloaded) Initializes a new instance of the DynamicArray<T> class
Top
Properties
 | Name | Description
Public property | Item | Gets or sets an element of this DynamicArray<T>.
Public property | Last | Gets or sets the last element of the DynamicArray<T> object.
Public property | Length | Gets or sets the DynamicArray<T> elements count.
Top
Methods
 | Name | Description
Public method | Add | Adds an element to this DynamicArray<T> object.
Public method | AddRange | Adds an array of elements to this DynamicArray<T> object.
Public method | Clear | Clears the DynamicArray<T> object.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBuffer | Returns an array of DynamicArray<T> elements.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

DynamicArray<T> Class


DynamicArray<T> Constructor

DynamicArray<T> Class See Also

Initializes a new instance of the DynamicArray<T> class

Overload List
Name | Description
DynamicArray() | Initializes a new instance of the DynamicArray<T> class
DynamicArray(int) | Initializes a new instance of the DynamicArray<T> class
See Also

Reference

DynamicArray<T> Class
DynamicArray<T> Members


DynamicArray<T> Properties

DynamicArray<T> Class See Also

The following tables list the members exposed by the DynamicArray<T> type.

Properties
 | Name | Description
Public property | Item | Gets or sets an element of this DynamicArray<T>.
Public property | Last | Gets or sets the last element of the DynamicArray<T> object.
Public property | Length | Gets or sets the DynamicArray<T> elements count.
Top
See Also

Reference

DynamicArray<T> Class


DynamicArray<T>.Item Property

Gets or sets an element of this DynamicArray<T>.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Item( _
   ByVal i As Integer _
) As T
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public T this[
   int i
] {get; set;}
This language is not supported or no code example is available.

Parameters

i

Type: int

An index of the element.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DynamicArray<T> Class
DynamicArray<T> Members


DynamicArray<T>.Last Property

Gets or sets the last element of the DynamicArray<T> object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Last() As T
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public T Last {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DynamicArray<T> Class
DynamicArray<T> Members


DynamicArray<T>.Length Property

Gets or sets the DynamicArray<T> elements count.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Length() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Length {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DynamicArray<T> Class
DynamicArray<T> Members


DynamicArray<T> Methods

DynamicArray<T> Class See Also

The following tables list the members exposed by the DynamicArray<T> type.

Methods
 | Name | Description
Public method | Add | Adds an element to this DynamicArray<T> object.
Public method | AddRange | Adds an array of elements to this DynamicArray<T> object.
Public method | Clear | Clears the DynamicArray<T> object.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBuffer | Returns an array of DynamicArray<T> elements.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

DynamicArray<T> Class


DynamicArray<T>.Add Method

Adds an element to this DynamicArray<T> object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Add( _
   ByVal item As T _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Add(
   T item
)
This language is not supported or no code example is available.

Parameters

item

Type: T

The element to add.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DynamicArray<T> Class
DynamicArray<T> Members


DynamicArray<T>.AddRange Method

Adds an array of elements to this DynamicArray<T> object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddRange( _
   ByVal itemArray As T() _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddRange(
   T[] itemArray
)
This language is not supported or no code example is available.

Parameters

itemArray

Type: T[]

The array of elements to add.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DynamicArray<T> Class
DynamicArray<T> Members


DynamicArray<T>.Clear Method

Clears the DynamicArray<T> object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Clear()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Clear()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DynamicArray<T> Class
DynamicArray<T> Members


DynamicArray<T>.GetBuffer Method

Returns an array of DynamicArray<T> elements.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetBuffer() As T()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public T[] GetBuffer()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DynamicArray<T> Class
DynamicArray<T> Members


FlatEntity Class

Members See Also

FlatEntity class defines base class for 2D entities (FlatHatch and FlatPoly).

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class FlatEntity
    Inherits CADPenEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class FlatEntity : CADPenEntity
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.FlatEntity
CADImport.FlatHatch
CADImport.FlatPoly
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FlatEntity Members


FlatEntity Members

FlatEntity Class Constructors Methods Fields Properties See Also

FlatEntity class defines base class for 2D entities (FlatHatch and FlatPoly).

The following tables list the members exposed by the FlatEntity type.

Constructors
 | Name | Description
Public constructor | FlatEntity | Initializes a new instance of the FlatEntity class.
Top
Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses the CADEntity.
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | Counts | Gets a list of the counters of points.
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets a type of this FlatEntity entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this FlatEntity.
Public property | Points | Gets a list of points representing the vertices of the polyline.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetXY | Gets a point defined by the specified parameter.
Public method | Loaded | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
Public method | PCount | Returns the number of coordinates.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | SetXY | Sets the specified point equal to the specified value.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

FlatEntity Class


FlatEntity Constructor

Initializes a new instance of the FlatEntity class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public FlatEntity()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FlatEntity Class
FlatEntity Members


FlatEntity Properties

FlatEntity Class See Also

The following tables list the members exposed by the FlatEntity type.

Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses the CADEntity.
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | Counts | Gets a list of the counters of points.
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets a type of this FlatEntity entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this FlatEntity.
Public property | Points | Gets a list of points representing the vertices of the polyline.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Top
See Also

Reference

FlatEntity Class


FlatEntity.Box Property

Gets a three-dimensional box that encloses the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Box() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override DRect Box {get;}
This language is not supported or no code example is available.

Property Value

A DRect object representing the enclosing box for the CADEntity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FlatEntity Class
FlatEntity Members


FlatEntity.Counts Property

Gets a list of the counters of points.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Counts() As CADCollection(Of Integer)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection<int> Counts {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FlatEntity Class
FlatEntity Members


FlatEntity.EntType Property

Gets a type of this FlatEntity entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FlatEntity Class
FlatEntity Members


FlatEntity.LineWeight Property

Gets or sets a thickness of lines for this FlatEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property LineWeight() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override double LineWeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FlatEntity Class
FlatEntity Members


FlatEntity.Points Property

Gets a list of points representing the vertices of the polyline.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Points() As CADCollection(Of Single)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection<float> Points {get;}
This language is not supported or no code example is available.

Property Value

An ArrayList containing the points that represents the vertices of the polyline.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FlatEntity Class
FlatEntity Members


FlatEntity Methods

FlatEntity Class See Also

The following tables list the members exposed by the FlatEntity type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetXY | Gets a point defined by the specified parameter.
Public method | Loaded | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
Public method | PCount | Returns the number of coordinates.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | SetXY | Sets the specified point equal to the specified value.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

FlatEntity Class


FlatEntity.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FlatEntity Class
FlatEntity Members


FlatEntity.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FlatEntity Class
FlatEntity Members


FlatEntity.GetXY Method

Gets a point defined by the specified parameter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetXY( _
   ByVal index As Integer _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint GetXY(
   int index
)
This language is not supported or no code example is available.

Parameters

index

Type: int

An index that specifies the point.

Return Value

A DPoint defined by the specified parameter.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FlatEntity Class
FlatEntity Members


FlatEntity.PCount Method

Returns the number of coordinates.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function PCount() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int PCount()
This language is not supported or no code example is available.

Return Value

Returns the number of coordinates. It counts X and Y coordinates.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FlatEntity Class
FlatEntity Members


FlatEntity.SetXY Method

Sets the specified point equal to the specified value.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetXY( _
   ByVal index As Integer, _
   ByVal val As DPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetXY(
   int index,
   DPoint val
)
This language is not supported or no code example is available.

Parameters

index

Type: int

An index that specifies the point.

val

Type: DPoint

The DPoint whose coordinates are used as setup values.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FlatEntity Class
FlatEntity Members


FlatEntity Fields

FlatEntity Class See Also

The following tables list the members exposed by the FlatEntity type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

FlatEntity Class


FlatHatch Class

Members See Also

Defines a two-dimensional hatch.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class FlatHatch
    Inherits FlatEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class FlatHatch : FlatEntity
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.FlatEntity
CADImport.FlatHatch
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FlatHatch Members


FlatHatch Members

FlatHatch Class Constructors Methods Fields Properties See Also

Defines a two-dimensional hatch.

The following tables list the members exposed by the FlatHatch type.

Constructors
 | Name | Description
Public constructor | FlatHatch | Initializes a new instance of the FlatEntity class. (inherited from FlatEntity).
Top
Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses the CADEntity. (inherited from FlatEntity).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | Counts | Gets a list of the counters of points. (inherited from FlatEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets a type of this FlatHatch entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this FlatEntity. (inherited from FlatEntity).
Public property | Points | Gets a list of points representing the vertices of the polyline. (inherited from FlatEntity).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Top
Methods
 | Name | Description
Public method | Accepts | Gets a value indicating if the specified hatch is accepted by this FlatHatch entity.
Public method | Add | Adds the specified hatch to this FlatHatch object.
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity (inherited from FlatEntity).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from FlatEntity).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetXY | Gets a point defined by the specified parameter. (inherited from FlatEntity).
Public method | Loaded | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
Public method | PCount | Returns the number of coordinates. (inherited from FlatEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | SetXY | Sets the specified point equal to the specified value. (inherited from FlatEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

FlatHatch Class


FlatHatch Properties

FlatHatch Class See Also

The following tables list the members exposed by the FlatHatch type.

Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses the CADEntity. (inherited from FlatEntity).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | Counts | Gets a list of the counters of points. (inherited from FlatEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets a type of this FlatHatch entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this FlatEntity. (inherited from FlatEntity).
Public property | Points | Gets a list of points representing the vertices of the polyline. (inherited from FlatEntity).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Top
See Also

Reference

FlatHatch Class


FlatHatch.EntType Property

Gets a type of this FlatHatch entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FlatHatch Class
FlatHatch Members


FlatHatch Methods

FlatHatch Class See Also

The following tables list the members exposed by the FlatHatch type.

Methods
 | Name | Description
Public method | Accepts | Gets a value indicating if the specified hatch is accepted by this FlatHatch entity.
Public method | Add | Adds the specified hatch to this FlatHatch object.
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity (inherited from FlatEntity).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from FlatEntity).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetXY | Gets a point defined by the specified parameter. (inherited from FlatEntity).
Public method | Loaded | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
Public method | PCount | Returns the number of coordinates. (inherited from FlatEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | SetXY | Sets the specified point equal to the specified value. (inherited from FlatEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

FlatHatch Class


FlatHatch.Accepts Method

Gets a value indicating if the specified hatch is accepted by this FlatHatch entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Accepts( _
   ByVal p As CADPolyPolygon _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Accepts(
   CADPolyPolygon p
)
This language is not supported or no code example is available.

Parameters

p

Type: CADPolyPolygon

A CADPolyPolygon object representing the hatch to add to this FlatHatch entity.

Return Value

true if the specified hatch can be accepted by this FlatHatch object; otherwise false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FlatHatch Class
FlatHatch Members


FlatHatch.Add Method

Adds the specified hatch to this FlatHatch object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Add( _
   ByVal p As CADPolyPolygon _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Add(
   CADPolyPolygon p
)
This language is not supported or no code example is available.

Parameters

p

Type: CADPolyPolygon

A CADPolyPolygon object representing the hatched area that will be added to this FlatHatch entity.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FlatHatch Class
FlatHatch Members


FlatHatch Fields

FlatHatch Class See Also

The following tables list the members exposed by the FlatHatch type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

FlatHatch Class


FlatPoly Class

Members See Also

Defines a two-dimensional polyline.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class FlatPoly
    Inherits FlatEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class FlatPoly : FlatEntity
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.FlatEntity
CADImport.FlatPoly
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FlatPoly Members


FlatPoly Members

FlatPoly Class Constructors Methods Fields Properties See Also

Defines a two-dimensional polyline.

The following tables list the members exposed by the FlatPoly type.

Constructors
 | Name | Description
Public constructor | FlatPoly | Initializes a new instance of the FlatEntity class. (inherited from FlatEntity).
Top
Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses the CADEntity. (inherited from FlatEntity).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | Counts | Gets a list of the counters of points. (inherited from FlatEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets a type of this FlatPoly entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this FlatEntity. (inherited from FlatEntity).
Public property | Points | Gets a list of points representing the vertices of the polyline. (inherited from FlatEntity).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Top
Methods
 | Name | Description
Public method | Accepts | Gets a value indicating if the specified polyline is accepted by this FlatPoly entity.
Public method | Add | Adds a polyline to this FlatPoly entity.
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity (inherited from FlatEntity).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from FlatEntity).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetXY | Gets a point defined by the specified parameter. (inherited from FlatEntity).
Public method | Loaded | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
Public method | PCount | Returns the number of coordinates. (inherited from FlatEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | SetXY | Sets the specified point equal to the specified value. (inherited from FlatEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

FlatPoly Class


FlatPoly Properties

FlatPoly Class See Also

The following tables list the members exposed by the FlatPoly type.

Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses the CADEntity. (inherited from FlatEntity).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | Counts | Gets a list of the counters of points. (inherited from FlatEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets a type of this FlatPoly entity.
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this FlatEntity. (inherited from FlatEntity).
Public property | Points | Gets a list of points representing the vertices of the polyline. (inherited from FlatEntity).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Top
See Also

Reference

FlatPoly Class


FlatPoly.EntType Property

Gets a type of this FlatPoly entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property EntType() As EntityType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override EntityType EntType {get;}
This language is not supported or no code example is available.

Property Value

An entity type defined by the EntityType enumeration value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FlatPoly Class
FlatPoly Members


FlatPoly Methods

FlatPoly Class See Also

The following tables list the members exposed by the FlatPoly type.

Methods
 | Name | Description
Public method | Accepts | Gets a value indicating if the specified polyline is accepted by this FlatPoly entity.
Public method | Add | Adds a polyline to this FlatPoly entity.
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity (inherited from FlatEntity).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from FlatEntity).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetXY | Gets a point defined by the specified parameter. (inherited from FlatEntity).
Public method | Loaded | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
Public method | PCount | Returns the number of coordinates. (inherited from FlatEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | SetXY | Sets the specified point equal to the specified value. (inherited from FlatEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

FlatPoly Class


FlatPoly.Accepts Method

Gets a value indicating if the specified polyline is accepted by this FlatPoly entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Accepts( _
   ByVal p As CADPolylineBase _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Accepts(
   CADPolylineBase p
)
This language is not supported or no code example is available.

Parameters

p

Type: CADPolylineBase

A CADPolyLine object to add to this FlatPoly entity.

Return Value

true if the specified polyline can be accepted by this FlatPoly object; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FlatPoly Class
FlatPoly Members


FlatPoly.Add Method

Adds a polyline to this FlatPoly entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Add( _
   ByVal p As CADPolylineBase _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Add(
   CADPolylineBase p
)
This language is not supported or no code example is available.

Parameters

p

Type: CADPolylineBase

A CADPolyline to add.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FlatPoly Class
FlatPoly Members


FlatPoly Fields

FlatPoly Class See Also

The following tables list the members exposed by the FlatPoly type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

FlatPoly Class


FontsParameters Class

Members See Also

Represents a set of font parameters.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class FontsParameters
    Implements ICloneable, _
               IDisposable
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class FontsParameters : ICloneable,
   IDisposable
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.FontsParameters
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FontsParameters Members


FontsParameters Members

FontsParameters Class Constructors Methods Fields Properties See Also

Represents a set of font parameters.

The following tables list the members exposed by the FontsParameters type.

Constructors
 | Name | Description
Public constructor | FontsParameters |
Top
Properties
 | Name | Description
Public property | DefaultSHXTTFFont | Gets or sets default TTF font for drawing instead of SHX fonts in SHX disabled mode
Public property | SHXDefaultFont | Gets or sets an SHX default font.
Public property | SHXFonts | Gets a list of SHX fonts.
Public property | SHXSearchPaths | Gets or sets paths for searching SHX fonts.
Public property | SearchSHXPaths | Gets or sets a value specifying whether SHX paths will be searched for the fonts.
Public property | UseMultyTTFFonts | Gets or sets a value indicating whether a multimode is used.
Public property | UseSHXFonts | Specifies if SHX fonts will be used.
Public property | UseTTFFonts | Specifies if TTF fonts will be used.
Top
Methods
 | Name | Description
Public method | Clone | Copies a FontsParameters instance.
Public method | Dispose | Release all resources used by FontsParameters instance.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetFontFamilyByFontName | Chooses by font name the most suitable font from FontFamily
Public method | GetFontName | Sets a font name for the CADText instance.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetParams | Sets FontsParameters instance members values.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
Name | Description
defaultTTFFont | Represents a default TTF font
extendedTTFFont | Represents an extended TTF font
sDefaultSHXBigfont | Represents a default SHX big font.
sDefaultSHXFont | Represents a default SHX font.
Top
See Also

Reference

FontsParameters Class


FontsParameters Constructor

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public FontsParameters()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FontsParameters Class
FontsParameters Members


FontsParameters Properties

FontsParameters Class See Also

The following tables list the members exposed by the FontsParameters type.

Properties
 | Name | Description
Public property | DefaultSHXTTFFont | Gets or sets default TTF font for drawing instead of SHX fonts in SHX disabled mode
Public property | SHXDefaultFont | Gets or sets an SHX default font.
Public property | SHXFonts | Gets a list of SHX fonts.
Public property | SHXSearchPaths | Gets or sets paths for searching SHX fonts.
Public property | SearchSHXPaths | Gets or sets a value specifying whether SHX paths will be searched for the fonts.
Public property | UseMultyTTFFonts | Gets or sets a value indicating whether a multimode is used.
Public property | UseSHXFonts | Specifies if SHX fonts will be used.
Public property | UseTTFFonts | Specifies if TTF fonts will be used.
Top
See Also

Reference

FontsParameters Class


FontsParameters.DefaultSHXTTFFont Property

Gets or sets default TTF font for drawing instead of SHX fonts in SHX disabled mode

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DefaultSHXTTFFont() As FontFamily
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public FontFamily DefaultSHXTTFFont {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FontsParameters Class
FontsParameters Members


FontsParameters.SHXDefaultFont Property

Gets or sets an SHX default font.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property SHXDefaultFont() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string SHXDefaultFont {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FontsParameters Class
FontsParameters Members


FontsParameters.SHXFonts Property

Gets a list of SHX fonts.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property SHXFonts() As SHXFontList
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SHXFontList SHXFonts {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FontsParameters Class
FontsParameters Members


FontsParameters.SHXSearchPaths Property

Gets or sets paths for searching SHX fonts.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property SHXSearchPaths() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string SHXSearchPaths {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FontsParameters Class
FontsParameters Members


FontsParameters.SearchSHXPaths Property

Gets or sets a value specifying whether SHX paths will be searched for the fonts.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property SearchSHXPaths() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool SearchSHXPaths {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FontsParameters Class
FontsParameters Members


FontsParameters.UseMultyTTFFonts Property

Gets or sets a value indicating whether a multimode is used.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property UseMultyTTFFonts() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool UseMultyTTFFonts {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FontsParameters Class
FontsParameters Members


FontsParameters.UseSHXFonts Property

Specifies if SHX fonts will be used.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property UseSHXFonts() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool UseSHXFonts {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FontsParameters Class
FontsParameters Members


FontsParameters.UseTTFFonts Property

Specifies if TTF fonts will be used.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property UseTTFFonts() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool UseTTFFonts {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FontsParameters Class
FontsParameters Members


FontsParameters Methods

FontsParameters Class See Also

The following tables list the members exposed by the FontsParameters type.

Methods
 | Name | Description
Public method | Clone | Copies a FontsParameters instance.
Public method | Dispose | Release all resources used by FontsParameters instance.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetFontFamilyByFontName | Chooses by font name the most suitable font from FontFamily
Public method | GetFontName | Sets a font name for the CADText instance.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetParams | Sets FontsParameters instance members values.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

FontsParameters Class


FontsParameters.Clone Method

Copies a FontsParameters instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Clone() As Object Implements  _
   ICloneable.Clone
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public object Clone()
This language is not supported or no code example is available.

Return Value

A new FontsParameters instance

Implements

ICloneable.Clone
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FontsParameters Class
FontsParameters Members


FontsParameters.Dispose Method

Release all resources used by FontsParameters instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Dispose() Implements  _
   IDisposable.Dispose
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Dispose()
This language is not supported or no code example is available.

Implements

IDisposable.Dispose
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FontsParameters Class
FontsParameters Members


FontsParameters.GetFontFamilyByFontName Method

Chooses by font name the most suitable font from FontFamily

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetFontFamilyByFontName( _
   ByVal nm As String _
) As Font
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Font GetFontFamilyByFontName(
   string nm
)
This language is not supported or no code example is available.

Parameters

nm

Type: string

Font name

Return Value

Returns chosen FontFamily
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FontsParameters Class
FontsParameters Members


FontsParameters.GetFontName Method

Sets a font name for the CADText instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub GetFontName( _
   ByVal text As CADText _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void GetFontName(
   CADText text
)
This language is not supported or no code example is available.

Parameters

text

Type: CADText

A CADText instance.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FontsParameters Class
FontsParameters Members


FontsParameters.SetParams Method

Sets FontsParameters instance members values.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetParams( _
   ByVal fontsParameters As FontsParameters _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetParams(
   FontsParameters fontsParameters
)
This language is not supported or no code example is available.

Parameters

fontsParameters

Type: FontsParameters

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FontsParameters Class
FontsParameters Members


FontsParameters Fields

FontsParameters Class See Also

The following tables list the members exposed by the FontsParameters type.

Fields
Name | Description
defaultTTFFont | Represents a default TTF font
extendedTTFFont | Represents an extended TTF font
sDefaultSHXBigfont | Represents a default SHX big font.
sDefaultSHXFont | Represents a default SHX font.
Top
See Also

Reference

FontsParameters Class


defaultTTFFont Field

Represents a default TTF font

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared defaultTTFFont As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static string defaultTTFFont
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FontsParameters Class
FontsParameters Members


extendedTTFFont Field

Represents an extended TTF font

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared extendedTTFFont As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static string extendedTTFFont
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FontsParameters Class
FontsParameters Members


sDefaultSHXBigfont Field

Represents a default SHX big font.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared sDefaultSHXBigfont As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static string sDefaultSHXBigfont
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FontsParameters Class
FontsParameters Members


sDefaultSHXFont Field

Represents a default SHX font.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared sDefaultSHXFont As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static string sDefaultSHXFont
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FontsParameters Class
FontsParameters Members


HatchPatternData Class

Members See Also

Represents hatch settings

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class HatchPatternData
    Implements ICloneable, _
               IDisposable
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class HatchPatternData : ICloneable,
   IDisposable
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.HatchPatternData
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HatchPatternData Members


HatchPatternData Members

HatchPatternData Class Constructors Methods Fields See Also

Represents hatch settings

The following tables list the members exposed by the HatchPatternData type.

Constructors
 | Name | Description
Public constructor | HatchPatternData | Initializes a new instance of the HatchPatternData class
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | baseP | Base point of hatch line. From this point lines are begins, using offset.
Public field | dashNum | Number of dash parts of line pattern.
Public field | isDash | Specifies if hatch line is solid.
Public field | lineAngle | Represents a hatch line tilt angle.
Public field | lines | Represents a collection of lines.
Public field | offset | Displacement of pattern line from base point.
Top
See Also

Reference

HatchPatternData Class


HatchPatternData Constructor

Initializes a new instance of the HatchPatternData class

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public HatchPatternData()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HatchPatternData Class
HatchPatternData Members


HatchPatternData Methods

HatchPatternData Class See Also

The following tables list the members exposed by the HatchPatternData type.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

HatchPatternData Class


HatchPatternData.Clone Method

Creates a new object that is a copy of the current instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Clone() As Object Implements  _
   ICloneable.Clone
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public object Clone()
This language is not supported or no code example is available.

Return Value

A new object that is a copy of this instance.

Implements

ICloneable.Clone
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HatchPatternData Class
HatchPatternData Members


HatchPatternData.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Dispose() Implements  _
   IDisposable.Dispose
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Dispose()
This language is not supported or no code example is available.

Implements

IDisposable.Dispose
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HatchPatternData Class
HatchPatternData Members


HatchPatternData Fields

HatchPatternData Class See Also

The following tables list the members exposed by the HatchPatternData type.

Fields
 | Name | Description
Public field | baseP | Base point of hatch line. From this point lines are begins, using offset.
Public field | dashNum | Number of dash parts of line pattern.
Public field | isDash | Specifies if hatch line is solid.
Public field | lineAngle | Represents a hatch line tilt angle.
Public field | lines | Represents a collection of lines.
Public field | offset | Displacement of pattern line from base point.
Top
See Also

Reference

HatchPatternData Class


baseP Field

Base point of hatch line. From this point lines are begins, using offset.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public baseP As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint baseP
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HatchPatternData Class
HatchPatternData Members


dashNum Field

Number of dash parts of line pattern.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public dashNum As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int dashNum
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HatchPatternData Class
HatchPatternData Members


isDash Field

Specifies if hatch line is solid.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public isDash As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool isDash
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HatchPatternData Class
HatchPatternData Members


lineAngle Field

Represents a hatch line tilt angle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public lineAngle As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float lineAngle
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HatchPatternData Class
HatchPatternData Members


lines Field

Represents a collection of lines.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public lines As CADCollection(Of Double)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection<double> lines
This language is not supported or no code example is available.

Type Parameters

double

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HatchPatternData Class
HatchPatternData Members


offset Field

Displacement of pattern line from base point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public offset As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint offset
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HatchPatternData Class
HatchPatternData Members


HeadVarStruct Class

Members See Also

Defines the structure which contains some system variables.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class HeadVarStruct
    Implements ICloneable
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class HeadVarStruct : ICloneable
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.HeadVarStruct
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HeadVarStruct Members


HeadVarStruct Members

HeadVarStruct Class Constructors Methods Fields Properties See Also

Defines the structure which contains some system variables.

The following tables list the members exposed by the HeadVarStruct type.

Constructors
 | Name | Description
Public constructor | HeadVarStruct | Initializes a new instance of the HeadVarStruct class.
Top
Properties
 | Name | Description
 | DefaultValue | Gets a new HeadVarStruct instance with default parameters.
Public property | LUPrec | Units precision for coordinates and distances.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | CodePage | Drawing code page; set to the system code page when a new drawing is created.
Public field | DimStyle | Dimension style name
Public field | DimTextStyle | Dimension text style.
Public field | ELTScale | Current entity linetype scale.
Public field | ELType | Entity linetype name, or BYBLOCK or BYLAYER
Public field | ELWeight | Lineweight of new objects.
Public field | FilledRadius | Fillet radius.
Public field | InsUnits | Default drawing units for DesignCenter blocks
Public field | LScale | Global linetype scale.
Public field | Measurement | Sets drawing units: false = English; true = Metric.
Public field | PSLTScale | Paper space linetype scaling
Public field | PointDisplayMode | Point display mode
Public field | PointDisplaySize | Point display size
Public field | TextSize | Default text height
Public field | TextStyle | A head variable of DXF/DWG files; for internal use.
Public field | TileMode | 1 for previous release compatibility mode; 0 otherwise
Public field | UCSORG | Origin of current UCS (in WCS)
Public field | UCSXDir | A head variable of DXF/DWG files; for internal use.
Public field | UCSYDir | A head variable of DXF/DWG files; for internal use.
Public field | Version | Defines the appearance of existing DXFPoint class objects. Set 0 to make DXFPoint class objects visible. Set 0 to make DXFPoint class objects invisible.
Public field | XClipFrame | Controls visibility of xref clipping bounfaries
Public field | color | Current entity color number: 0 = BYBLOCK; 256 = BYLAYER
Public field | layer | Current layer name.
Top
See Also

Reference

HeadVarStruct Class


HeadVarStruct Constructor

Initializes a new instance of the HeadVarStruct class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public HeadVarStruct()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HeadVarStruct Class
HeadVarStruct Members


HeadVarStruct Properties

HeadVarStruct Class See Also

The following tables list the members exposed by the HeadVarStruct type.

Properties
 | Name | Description
 | DefaultValue | Gets a new HeadVarStruct instance with default parameters.
Public property | LUPrec | Units precision for coordinates and distances.
Top
See Also

Reference

HeadVarStruct Class


HeadVarStruct.DefaultValue Property

Gets a new HeadVarStruct instance with default parameters.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Shared Property DefaultValue() As HeadVarStruct
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static HeadVarStruct DefaultValue {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HeadVarStruct Class
HeadVarStruct Members


HeadVarStruct.LUPrec Property

Units precision for coordinates and distances.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LUPrec() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int LUPrec {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HeadVarStruct Class
HeadVarStruct Members


HeadVarStruct Methods

HeadVarStruct Class See Also

The following tables list the members exposed by the HeadVarStruct type.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

HeadVarStruct Class


HeadVarStruct.Clone Method

Creates a new object that is a copy of the current instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Clone() As Object Implements  _
   ICloneable.Clone
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public object Clone()
This language is not supported or no code example is available.

Return Value

A new object that is a copy of this instance.

Implements

ICloneable.Clone
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HeadVarStruct Class
HeadVarStruct Members


HeadVarStruct Fields

HeadVarStruct Class See Also

The following tables list the members exposed by the HeadVarStruct type.

Fields
 | Name | Description
Public field | CodePage | Drawing code page; set to the system code page when a new drawing is created.
Public field | DimStyle | Dimension style name
Public field | DimTextStyle | Dimension text style.
Public field | ELTScale | Current entity linetype scale.
Public field | ELType | Entity linetype name, or BYBLOCK or BYLAYER
Public field | ELWeight | Lineweight of new objects.
Public field | FilledRadius | Fillet radius.
Public field | InsUnits | Default drawing units for DesignCenter blocks
Public field | LScale | Global linetype scale.
Public field | Measurement | Sets drawing units: false = English; true = Metric.
Public field | PSLTScale | Paper space linetype scaling
Public field | PointDisplayMode | Point display mode
Public field | PointDisplaySize | Point display size
Public field | TextSize | Default text height
Public field | TextStyle | A head variable of DXF/DWG files; for internal use.
Public field | TileMode | 1 for previous release compatibility mode; 0 otherwise
Public field | UCSORG | Origin of current UCS (in WCS)
Public field | UCSXDir | A head variable of DXF/DWG files; for internal use.
Public field | UCSYDir | A head variable of DXF/DWG files; for internal use.
Public field | Version | Defines the appearance of existing DXFPoint class objects. Set 0 to make DXFPoint class objects visible. Set 0 to make DXFPoint class objects invisible.
Public field | XClipFrame | Controls visibility of xref clipping bounfaries
Public field | color | Current entity color number: 0 = BYBLOCK; 256 = BYLAYER
Public field | layer | Current layer name.
Top
See Also

Reference

HeadVarStruct Class


CodePage Field

Drawing code page; set to the system code page when a new drawing is created.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public CodePage As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int CodePage
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HeadVarStruct Class
HeadVarStruct Members


DimStyle Field

Dimension style name

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public DimStyle As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string DimStyle
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HeadVarStruct Class
HeadVarStruct Members


DimTextStyle Field

Dimension text style.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public DimTextStyle As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string DimTextStyle
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HeadVarStruct Class
HeadVarStruct Members


ELTScale Field

Current entity linetype scale.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ELTScale As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double ELTScale
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HeadVarStruct Class
HeadVarStruct Members


ELType Field

Entity linetype name, or BYBLOCK or BYLAYER

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ELType As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string ELType
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HeadVarStruct Class
HeadVarStruct Members


ELWeight Field

Lineweight of new objects.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ELWeight As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double ELWeight
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HeadVarStruct Class
HeadVarStruct Members


FilledRadius Field

Fillet radius.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public FilledRadius As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double FilledRadius
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HeadVarStruct Class
HeadVarStruct Members


InsUnits Field

Default drawing units for DesignCenter blocks

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public InsUnits As InsUnitsStruct
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public InsUnitsStruct InsUnits
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HeadVarStruct Class
HeadVarStruct Members


LScale Field

Global linetype scale.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public LScale As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double LScale
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HeadVarStruct Class
HeadVarStruct Members


Measurement Field

Sets drawing units: false = English; true = Metric.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Measurement As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Measurement
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HeadVarStruct Class
HeadVarStruct Members


PSLTScale Field

Paper space linetype scaling

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public PSLTScale As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int PSLTScale
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HeadVarStruct Class
HeadVarStruct Members


PointDisplayMode Field

Point display mode

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public PointDisplayMode As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int PointDisplayMode
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HeadVarStruct Class
HeadVarStruct Members


PointDisplaySize Field

Point display size

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public PointDisplaySize As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double PointDisplaySize
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HeadVarStruct Class
HeadVarStruct Members


TextSize Field

Default text height

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public TextSize As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double TextSize
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HeadVarStruct Class
HeadVarStruct Members


TextStyle Field

A head variable of DXF/DWG files; for internal use.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public TextStyle As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string TextStyle
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HeadVarStruct Class
HeadVarStruct Members


TileMode Field

1 for previous release compatibility mode; 0 otherwise

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public TileMode As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int TileMode
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HeadVarStruct Class
HeadVarStruct Members


UCSORG Field

Origin of current UCS (in WCS)

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public UCSORG As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint UCSORG
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HeadVarStruct Class
HeadVarStruct Members


UCSXDir Field

A head variable of DXF/DWG files; for internal use.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public UCSXDir As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint UCSXDir
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HeadVarStruct Class
HeadVarStruct Members


UCSYDir Field

A head variable of DXF/DWG files; for internal use.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public UCSYDir As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint UCSYDir
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HeadVarStruct Class
HeadVarStruct Members


Version Field

Defines the appearance of existing DXFPoint class objects. Set 0 to make DXFPoint class objects visible. Set 0 to make DXFPoint class objects invisible.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Version As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte Version
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HeadVarStruct Class
HeadVarStruct Members


XClipFrame Field

Controls visibility of xref clipping bounfaries

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public XClipFrame As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool XClipFrame
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HeadVarStruct Class
HeadVarStruct Members


color Field

Current entity color number: 0 = BYBLOCK; 256 = BYLAYER

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public color As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Color color
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HeadVarStruct Class
HeadVarStruct Members


layer Field

Current layer name.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public layer As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string layer
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HeadVarStruct Class
HeadVarStruct Members


LTypeElementStruct Class

Members See Also

Provides parameters that specifies a line type in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class LTypeElementStruct
    Implements IDisposable, _
               ICloneable
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class LTypeElementStruct : IDisposable,
   ICloneable
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.LTypeElementStruct
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LTypeElementStruct Members


LTypeElementStruct Members

LTypeElementStruct Class Constructors Methods Fields See Also

Provides parameters that specifies a line type in a CAD image.

The following tables list the members exposed by the LTypeElementStruct type.

Constructors
 | Name | Description
Public constructor | LTypeElementStruct | Initializes a new instance of the LTypeElementStruct class.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | ComplexType | Complex linetype element type (one per element). Default is 0 (no embedded shape/text).
Public field | Dash | Dash, dot or space length (one entry per element).
Public field | Rotation | Rotation value in radians of embedded shape or text.
Public field | Scale | Scale value
Public field | Style | Represents a style of the text in LTypeElementStruct.
Public field | StyleHandle | Represents a handle of the text style.
Public field | Text | Text string
Public field | XOffset | X offset value.
Public field | YOffset | Y offset value.
Top
See Also

Reference

LTypeElementStruct Class


LTypeElementStruct Constructor

Initializes a new instance of the LTypeElementStruct class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal scale As Double _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public LTypeElementStruct(
   double scale
)
This language is not supported or no code example is available.

Parameters

scale

Type: double

A scale value.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LTypeElementStruct Class
LTypeElementStruct Members


LTypeElementStruct Methods

LTypeElementStruct Class See Also

The following tables list the members exposed by the LTypeElementStruct type.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

LTypeElementStruct Class


LTypeElementStruct.Clone Method

Creates a new object that is a copy of the current instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Clone() As Object Implements  _
   ICloneable.Clone
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public object Clone()
This language is not supported or no code example is available.

Return Value

A new object that is a copy of this instance.

Implements

ICloneable.Clone
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LTypeElementStruct Class
LTypeElementStruct Members


LTypeElementStruct.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Dispose() Implements  _
   IDisposable.Dispose
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Dispose()
This language is not supported or no code example is available.

Implements

IDisposable.Dispose
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LTypeElementStruct Class
LTypeElementStruct Members


LTypeElementStruct Fields

LTypeElementStruct Class See Also

The following tables list the members exposed by the LTypeElementStruct type.

Fields
 | Name | Description
Public field | ComplexType | Complex linetype element type (one per element). Default is 0 (no embedded shape/text).
Public field | Dash | Dash, dot or space length (one entry per element).
Public field | Rotation | Rotation value in radians of embedded shape or text.
Public field | Scale | Scale value
Public field | Style | Represents a style of the text in LTypeElementStruct.
Public field | StyleHandle | Represents a handle of the text style.
Public field | Text | Text string
Public field | XOffset | X offset value.
Public field | YOffset | Y offset value.
Top
See Also

Reference

LTypeElementStruct Class


ComplexType Field

Complex linetype element type (one per element). Default is 0 (no embedded shape/text).

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ComplexType As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte ComplexType
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LTypeElementStruct Class
LTypeElementStruct Members


Dash Field

Dash, dot or space length (one entry per element).

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Dash As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Dash
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LTypeElementStruct Class
LTypeElementStruct Members


Rotation Field

Rotation value in radians of embedded shape or text.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Rotation As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Rotation
This language is not supported or no code example is available.
Remarks

one per element if ComplexType specifies an embedded shape or text string

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LTypeElementStruct Class
LTypeElementStruct Members


Scale Field

Scale value

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Scale As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Scale
This language is not supported or no code example is available.
Remarks

Optional. Multiple entries can exist

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LTypeElementStruct Class
LTypeElementStruct Members


Style Field

Represents a style of the text in LTypeElementStruct.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Style As CADStyle
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADStyle Style
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LTypeElementStruct Class
LTypeElementStruct Members


StyleHandle Field

Represents a handle of the text style.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public StyleHandle As UInt64
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public UInt64 StyleHandle
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LTypeElementStruct Class
LTypeElementStruct Members


Text Field

Text string

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Text As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Text
This language is not supported or no code example is available.
Remarks

One per element if ComplexType = 2

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LTypeElementStruct Class
LTypeElementStruct Members


XOffset Field

X offset value.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public XOffset As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double XOffset
This language is not supported or no code example is available.
Remarks

Optional. Multiple entries can exist

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LTypeElementStruct Class
LTypeElementStruct Members


YOffset Field

Y offset value.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public YOffset As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double YOffset
This language is not supported or no code example is available.
Remarks

Optional. Multiple entries can exist

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LTypeElementStruct Class
LTypeElementStruct Members


LayerConverter Class

Members See Also

Provides functionality for both-way converting the string objects to objects representing layers.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class LayerConverter
    Inherits StringConverter
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class LayerConverter : StringConverter
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.ComponentModel.TypeConverter
System.ComponentModel.StringConverter
CADImport.LayerConverter
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LayerConverter Members


LayerConverter Members

LayerConverter Class Methods See Also

Provides functionality for both-way converting the string objects to objects representing layers.

The following tables list the members exposed by the LayerConverter type.

Methods
 | Name | Description
Public method | CanConvertFrom | (Overloaded) Gets a value indicating whether this converter can convert an object in the given source type to a string using the specified context. (inherited from StringConverter).
Public method | CanConvertTo | (Overloaded) Returns whether this converter can convert the object to the specified type. (inherited from TypeConverter).
Public method | ConvertFrom | (Overloaded) Converts the specified value object to a String object. (inherited from StringConverter).
Public method | ConvertFromInvariantString | (Overloaded) Converts the given string to the type of this converter, using the invariant culture. (inherited from TypeConverter).
Public method | ConvertFromString | (Overloaded) Converts the specified text to an object. (inherited from TypeConverter).
Public method | ConvertTo | (Overloaded) Converts the given value object to the specified type, using the arguments. (inherited from TypeConverter).
Public method | ConvertToInvariantString | (Overloaded) Converts the specified value to a culture-invariant string representation. (inherited from TypeConverter).
Public method | ConvertToString | (Overloaded) Converts the specified value to a string representation. (inherited from TypeConverter).
Public method | CreateInstance | (Overloaded) Re-creates an Object given a set of property values for the object. (inherited from TypeConverter).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetCreateInstanceSupported | (Overloaded) Returns whether changing a value on this object requires a call to the IDictionary) method to create a new value. (inherited from TypeConverter).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetProperties | (Overloaded) Returns a collection of properties for the type of array specified by the value parameter. (inherited from TypeConverter).
Public method | GetPropertiesSupported | (Overloaded) Returns whether this object supports properties. (inherited from TypeConverter).
Public method | GetStandardValues | (Overloaded) Overloaded. Returns a collection of standard layer values.
Public method | GetStandardValuesExclusive | (Overloaded) Overloaded. Returns a value indicating that a collection returned by the GetStandardValues method is not an exclusive list.
Public method | GetStandardValuesSupported | (Overloaded) Overloaded. Returns a value indicating that LayerConverter supports standard values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IsValid | (Overloaded) Returns whether the given value object is valid for this type. (inherited from TypeConverter).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

LayerConverter Class


LayerConverter Methods

LayerConverter Class See Also

The following tables list the members exposed by the LayerConverter type.

Methods
 | Name | Description
Public method | CanConvertFrom | (Overloaded) Gets a value indicating whether this converter can convert an object in the given source type to a string using the specified context. (inherited from StringConverter).
Public method | CanConvertTo | (Overloaded) Returns whether this converter can convert the object to the specified type. (inherited from TypeConverter).
Public method | ConvertFrom | (Overloaded) Converts the specified value object to a String object. (inherited from StringConverter).
Public method | ConvertFromInvariantString | (Overloaded) Converts the given string to the type of this converter, using the invariant culture. (inherited from TypeConverter).
Public method | ConvertFromString | (Overloaded) Converts the specified text to an object. (inherited from TypeConverter).
Public method | ConvertTo | (Overloaded) Converts the given value object to the specified type, using the arguments. (inherited from TypeConverter).
Public method | ConvertToInvariantString | (Overloaded) Converts the specified value to a culture-invariant string representation. (inherited from TypeConverter).
Public method | ConvertToString | (Overloaded) Converts the specified value to a string representation. (inherited from TypeConverter).
Public method | CreateInstance | (Overloaded) Re-creates an Object given a set of property values for the object. (inherited from TypeConverter).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetCreateInstanceSupported | (Overloaded) Returns whether changing a value on this object requires a call to the IDictionary) method to create a new value. (inherited from TypeConverter).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetProperties | (Overloaded) Returns a collection of properties for the type of array specified by the value parameter. (inherited from TypeConverter).
Public method | GetPropertiesSupported | (Overloaded) Returns whether this object supports properties. (inherited from TypeConverter).
Public method | GetStandardValues | (Overloaded) Overloaded. Returns a collection of standard layer values.
Public method | GetStandardValuesExclusive | (Overloaded) Overloaded. Returns a value indicating that a collection returned by the GetStandardValues method is not an exclusive list.
Public method | GetStandardValuesSupported | (Overloaded) Overloaded. Returns a value indicating that LayerConverter supports standard values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IsValid | (Overloaded) Returns whether the given value object is valid for this type. (inherited from TypeConverter).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

LayerConverter Class


LayerConverter.GetStandardValues Method

LayerConverter Class See Also

Overloaded. Returns a collection of standard layer values.

Overload List
Name | Description
GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (System.ComponentModel.TypeConverter).
GetStandardValues(ITypeDescriptorContext) | Overloaded. Returns a collection of standard layer values.
See Also

Reference

LayerConverter Class
LayerConverter Members


LayerConverter.GetStandardValuesExclusive Method

LayerConverter Class See Also

Overloaded. Returns a value indicating that a collection returned by the GetStandardValues method is not an exclusive list.

Overload List
Name | Description
GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (System.ComponentModel.TypeConverter).
GetStandardValuesExclusive(ITypeDescriptorContext) | Overloaded. Returns a value indicating that a collection returned by the GetStandardValues method is not an exclusive list.
See Also

Reference

LayerConverter Class
LayerConverter Members


LayerConverter.GetStandardValuesSupported Method

LayerConverter Class See Also

Overloaded. Returns a value indicating that LayerConverter supports standard values.

Overload List
Name | Description
GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (System.ComponentModel.TypeConverter).
GetStandardValuesSupported(ITypeDescriptorContext) | Overloaded. Returns a value indicating that LayerConverter supports standard values.
See Also

Reference

LayerConverter Class
LayerConverter Members


LineTypeConverter Class

Members See Also

Provides functionality for both-way converting the string objects to objects representing lineweight.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class LineTypeConverter
    Inherits StringConverter
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class LineTypeConverter : StringConverter
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.ComponentModel.TypeConverter
System.ComponentModel.StringConverter
CADImport.LineTypeConverter
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LineTypeConverter Members


LineTypeConverter Members

LineTypeConverter Class Methods See Also

Provides functionality for both-way converting the string objects to objects representing lineweight.

The following tables list the members exposed by the LineTypeConverter type.

Methods
 | Name | Description
Public method | CanConvertFrom | (Overloaded) Gets a value indicating whether this converter can convert an object in the given source type to a string using the specified context. (inherited from StringConverter).
Public method | CanConvertTo | (Overloaded) Returns whether this converter can convert the object to the specified type. (inherited from TypeConverter).
Public method | ConvertFrom | (Overloaded) Converts the specified value object to a String object. (inherited from StringConverter).
Public method | ConvertFromInvariantString | (Overloaded) Converts the given string to the type of this converter, using the invariant culture. (inherited from TypeConverter).
Public method | ConvertFromString | (Overloaded) Converts the specified text to an object. (inherited from TypeConverter).
Public method | ConvertTo | (Overloaded) Converts the given value object to the specified type, using the arguments. (inherited from TypeConverter).
Public method | ConvertToInvariantString | (Overloaded) Converts the specified value to a culture-invariant string representation. (inherited from TypeConverter).
Public method | ConvertToString | (Overloaded) Converts the specified value to a string representation. (inherited from TypeConverter).
Public method | CreateInstance | (Overloaded) Re-creates an Object given a set of property values for the object. (inherited from TypeConverter).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetCreateInstanceSupported | (Overloaded) Returns whether changing a value on this object requires a call to the IDictionary) method to create a new value. (inherited from TypeConverter).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetProperties | (Overloaded) Returns a collection of properties for the type of array specified by the value parameter. (inherited from TypeConverter).
Public method | GetPropertiesSupported | (Overloaded) Returns whether this object supports properties. (inherited from TypeConverter).
Public method | GetStandardValues | (Overloaded) Overloaded. Returns a collection of standard linetype values.
Public method | GetStandardValuesExclusive | (Overloaded) Overloaded. Returns a value indicating that a collection returned by the GetStandardValues method is not an exclusive list.
Public method | GetStandardValuesSupported | (Overloaded) Overloaded. Returns a value indicating that LineTypeConverter supports standard values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IsValid | (Overloaded) Returns whether the given value object is valid for this type. (inherited from TypeConverter).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

LineTypeConverter Class


LineTypeConverter Methods

LineTypeConverter Class See Also

The following tables list the members exposed by the LineTypeConverter type.

Methods
 | Name | Description
Public method | CanConvertFrom | (Overloaded) Gets a value indicating whether this converter can convert an object in the given source type to a string using the specified context. (inherited from StringConverter).
Public method | CanConvertTo | (Overloaded) Returns whether this converter can convert the object to the specified type. (inherited from TypeConverter).
Public method | ConvertFrom | (Overloaded) Converts the specified value object to a String object. (inherited from StringConverter).
Public method | ConvertFromInvariantString | (Overloaded) Converts the given string to the type of this converter, using the invariant culture. (inherited from TypeConverter).
Public method | ConvertFromString | (Overloaded) Converts the specified text to an object. (inherited from TypeConverter).
Public method | ConvertTo | (Overloaded) Converts the given value object to the specified type, using the arguments. (inherited from TypeConverter).
Public method | ConvertToInvariantString | (Overloaded) Converts the specified value to a culture-invariant string representation. (inherited from TypeConverter).
Public method | ConvertToString | (Overloaded) Converts the specified value to a string representation. (inherited from TypeConverter).
Public method | CreateInstance | (Overloaded) Re-creates an Object given a set of property values for the object. (inherited from TypeConverter).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetCreateInstanceSupported | (Overloaded) Returns whether changing a value on this object requires a call to the IDictionary) method to create a new value. (inherited from TypeConverter).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetProperties | (Overloaded) Returns a collection of properties for the type of array specified by the value parameter. (inherited from TypeConverter).
Public method | GetPropertiesSupported | (Overloaded) Returns whether this object supports properties. (inherited from TypeConverter).
Public method | GetStandardValues | (Overloaded) Overloaded. Returns a collection of standard linetype values.
Public method | GetStandardValuesExclusive | (Overloaded) Overloaded. Returns a value indicating that a collection returned by the GetStandardValues method is not an exclusive list.
Public method | GetStandardValuesSupported | (Overloaded) Overloaded. Returns a value indicating that LineTypeConverter supports standard values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IsValid | (Overloaded) Returns whether the given value object is valid for this type. (inherited from TypeConverter).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

LineTypeConverter Class


LineTypeConverter.GetStandardValues Method

LineTypeConverter Class See Also

Overloaded. Returns a collection of standard linetype values.

Overload List
Name | Description
GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (System.ComponentModel.TypeConverter).
GetStandardValues(ITypeDescriptorContext) | Overloaded. Returns a collection of standard linetype values.
See Also

Reference

LineTypeConverter Class
LineTypeConverter Members


LineTypeConverter.GetStandardValuesExclusive Method

LineTypeConverter Class See Also

Overloaded. Returns a value indicating that a collection returned by the GetStandardValues method is not an exclusive list.

Overload List
Name | Description
GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (System.ComponentModel.TypeConverter).
GetStandardValuesExclusive(ITypeDescriptorContext) | Overloaded. Returns a value indicating that a collection returned by the GetStandardValues method is not an exclusive list.
See Also

Reference

LineTypeConverter Class
LineTypeConverter Members


LineTypeConverter.GetStandardValuesSupported Method

LineTypeConverter Class See Also

Overloaded. Returns a value indicating that LineTypeConverter supports standard values.

Overload List
Name | Description
GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (System.ComponentModel.TypeConverter).
GetStandardValuesSupported(ITypeDescriptorContext) | Overloaded. Returns a value indicating that LineTypeConverter supports standard values.
See Also

Reference

LineTypeConverter Class
LineTypeConverter Members


LineWeightConverter Class

Members See Also

Provides functionality for both-way converting the string objects to objects representing lineweight.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class LineWeightConverter
    Inherits StringConverter
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class LineWeightConverter : StringConverter
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.ComponentModel.TypeConverter
System.ComponentModel.StringConverter
CADImport.LineWeightConverter
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LineWeightConverter Members


LineWeightConverter Members

LineWeightConverter Class Methods See Also

Provides functionality for both-way converting the string objects to objects representing lineweight.

The following tables list the members exposed by the LineWeightConverter type.

Methods
 | Name | Description
Public method | CanConvertFrom | (Overloaded) Gets a value indicating whether this converter can convert an object in the given source type to a string using the specified context. (inherited from StringConverter).
Public method | CanConvertTo | (Overloaded) Returns whether this converter can convert the object to the specified type. (inherited from TypeConverter).
Public method | ConvertFrom | (Overloaded) Converts the specified value object to a String object. (inherited from StringConverter).
Public method | ConvertFromInvariantString | (Overloaded) Converts the given string to the type of this converter, using the invariant culture. (inherited from TypeConverter).
Public method | ConvertFromString | (Overloaded) Converts the specified text to an object. (inherited from TypeConverter).
Public method | ConvertTo | (Overloaded) Converts the given value object to the specified type, using the arguments. (inherited from TypeConverter).
Public method | ConvertToInvariantString | (Overloaded) Converts the specified value to a culture-invariant string representation. (inherited from TypeConverter).
Public method | ConvertToString | (Overloaded) Converts the specified value to a string representation. (inherited from TypeConverter).
Public method | CreateInstance | (Overloaded) Re-creates an Object given a set of property values for the object. (inherited from TypeConverter).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetCreateInstanceSupported | (Overloaded) Returns whether changing a value on this object requires a call to the IDictionary) method to create a new value. (inherited from TypeConverter).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetProperties | (Overloaded) Returns a collection of properties for the type of array specified by the value parameter. (inherited from TypeConverter).
Public method | GetPropertiesSupported | (Overloaded) Returns whether this object supports properties. (inherited from TypeConverter).
Public method | GetStandardValues | (Overloaded) Overloaded. Returns a collection of standard lineweight values.
Public method | GetStandardValuesExclusive | (Overloaded) Overloaded. Returns a value indicating that a collection returned by the GetStandardValues method is not an exclusive list.
Public method | GetStandardValuesSupported | (Overloaded) Overloaded. Returns a value indicating that LineWeightTypeConverter supports standard values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IsValid | (Overloaded) Returns whether the given value object is valid for this type. (inherited from TypeConverter).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

LineWeightConverter Class


LineWeightConverter Methods

LineWeightConverter Class See Also

The following tables list the members exposed by the LineWeightConverter type.

Methods
 | Name | Description
Public method | CanConvertFrom | (Overloaded) Gets a value indicating whether this converter can convert an object in the given source type to a string using the specified context. (inherited from StringConverter).
Public method | CanConvertTo | (Overloaded) Returns whether this converter can convert the object to the specified type. (inherited from TypeConverter).
Public method | ConvertFrom | (Overloaded) Converts the specified value object to a String object. (inherited from StringConverter).
Public method | ConvertFromInvariantString | (Overloaded) Converts the given string to the type of this converter, using the invariant culture. (inherited from TypeConverter).
Public method | ConvertFromString | (Overloaded) Converts the specified text to an object. (inherited from TypeConverter).
Public method | ConvertTo | (Overloaded) Converts the given value object to the specified type, using the arguments. (inherited from TypeConverter).
Public method | ConvertToInvariantString | (Overloaded) Converts the specified value to a culture-invariant string representation. (inherited from TypeConverter).
Public method | ConvertToString | (Overloaded) Converts the specified value to a string representation. (inherited from TypeConverter).
Public method | CreateInstance | (Overloaded) Re-creates an Object given a set of property values for the object. (inherited from TypeConverter).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetCreateInstanceSupported | (Overloaded) Returns whether changing a value on this object requires a call to the IDictionary) method to create a new value. (inherited from TypeConverter).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetProperties | (Overloaded) Returns a collection of properties for the type of array specified by the value parameter. (inherited from TypeConverter).
Public method | GetPropertiesSupported | (Overloaded) Returns whether this object supports properties. (inherited from TypeConverter).
Public method | GetStandardValues | (Overloaded) Overloaded. Returns a collection of standard lineweight values.
Public method | GetStandardValuesExclusive | (Overloaded) Overloaded. Returns a value indicating that a collection returned by the GetStandardValues method is not an exclusive list.
Public method | GetStandardValuesSupported | (Overloaded) Overloaded. Returns a value indicating that LineWeightTypeConverter supports standard values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IsValid | (Overloaded) Returns whether the given value object is valid for this type. (inherited from TypeConverter).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

LineWeightConverter Class


LineWeightConverter.GetStandardValues Method

LineWeightConverter Class See Also

Overloaded. Returns a collection of standard lineweight values.

Overload List
Name | Description
GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (System.ComponentModel.TypeConverter).
GetStandardValues(ITypeDescriptorContext) | Overloaded. Returns a collection of standard lineweight values.
See Also

Reference

LineWeightConverter Class
LineWeightConverter Members


LineWeightConverter.GetStandardValuesExclusive Method

LineWeightConverter Class See Also

Overloaded. Returns a value indicating that a collection returned by the GetStandardValues method is not an exclusive list.

Overload List
Name | Description
GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (System.ComponentModel.TypeConverter).
GetStandardValuesExclusive(ITypeDescriptorContext) | Overloaded. Returns a value indicating that a collection returned by the GetStandardValues method is not an exclusive list.
See Also

Reference

LineWeightConverter Class
LineWeightConverter Members


LineWeightConverter.GetStandardValuesSupported Method

LineWeightConverter Class See Also

Overloaded. Returns a value indicating that LineWeightTypeConverter supports standard values.

Overload List
Name | Description
GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (System.ComponentModel.TypeConverter).
GetStandardValuesSupported(ITypeDescriptorContext) | Overloaded. Returns a value indicating that LineWeightTypeConverter supports standard values.
See Also

Reference

LineWeightConverter Class
LineWeightConverter Members


MVertex Class

Members See Also

Represents a vertex of a CADMLine.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class MVertex
    Inherits CADEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class MVertex : CADEntity
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.MVertex
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MVertex Members


MVertex Members

MVertex Class Constructors Methods Fields Properties See Also

Represents a vertex of a CADMLine.

The following tables list the members exposed by the MVertex type.

Constructors
 | Name | Description
Public constructor | MVertex | Initializes a new instance of the CADEntity class. (inherited from CADEntity).
Top
Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Count | Gets a number of elements within elements collection.
Public property | Direction | Gets or sets a direction vector of segment starting at this vertex.
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer containing this CADEntity. (inherited from CADEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Miter | Gets or sets a direction vector of miter at this vertex
Public property | Params | Gets or sets collection of parameters for elements.
Public property | Point | Gets or sets vector coordinates.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADEntity is visible. (inherited from CADEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Complete | Initializes a new collection of parameters for elements if it doesn't exist.
Public method | CountP | Returns a number of parameters for an element in collection
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

MVertex Class


MVertex Properties

MVertex Class See Also

The following tables list the members exposed by the MVertex type.

Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADEntity. (inherited from CADEntity).
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Count | Gets a number of elements within elements collection.
Public property | Direction | Gets or sets a direction vector of segment starting at this vertex.
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer containing this CADEntity. (inherited from CADEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Miter | Gets or sets a direction vector of miter at this vertex
Public property | Params | Gets or sets collection of parameters for elements.
Public property | Point | Gets or sets vector coordinates.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADEntity is visible. (inherited from CADEntity).
Top
See Also

Reference

MVertex Class


MVertex.Count Property

Gets a number of elements within elements collection.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Count() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override int Count {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MVertex Class
MVertex Members


MVertex.Direction Property

Gets or sets a direction vector of segment starting at this vertex.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Direction() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Direction {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MVertex Class
MVertex Members


MVertex.Miter Property

Gets or sets a direction vector of miter at this vertex

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Miter() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Miter {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MVertex Class
MVertex Members


MVertex.Params Property

Gets or sets collection of parameters for elements.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Params() As CADCollection(Of CADCollection(Of Double))
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection<CADCollection<double>> Params {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MVertex Class
MVertex Members


MVertex.Point Property

Gets or sets vector coordinates.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Point() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Point {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MVertex Class
MVertex Members


MVertex Methods

MVertex Class See Also

The following tables list the members exposed by the MVertex type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AssignEntity | Copies an entity
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Complete | Initializes a new collection of parameters for elements if it doesn't exist.
Public method | CountP | Returns a number of parameters for an element in collection
Public method | Dispose | Releases all resources used by the CADEntity.
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

MVertex Class


MVertex.AssignEntity Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub AssignEntity( _
   ByVal source As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void AssignEntity(
   CADEntity source
)
This language is not supported or no code example is available.

Parameters

source

Type: CADEntity

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MVertex Class
MVertex Members


MVertex.Complete Method

Initializes a new collection of parameters for elements if it doesn't exist.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Complete()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Complete()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MVertex Class
MVertex Members


MVertex.CountP Method

Returns a number of parameters for an element in collection

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function CountP( _
   ByVal index As Integer _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int CountP(
   int index
)
This language is not supported or no code example is available.

Parameters

index

Type: int

The index of an element.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MVertex Class
MVertex Members


MVertex.Dispose Method

Releases all resources used by the CADEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MVertex Class
MVertex Members


MVertex Fields

MVertex Class See Also

The following tables list the members exposed by the MVertex type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

MVertex Class


ObjEntities Class

Members See Also

Provides functionality for displaying a collection of CADEntity properties in the PropertyGrid control.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class ObjEntities
    Inherits ObjEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class ObjEntities : ObjEntity
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.ObjEntity
CADImport.ObjEntities
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntities Members


ObjEntities Members

ObjEntities Class Constructors Methods Fields Properties See Also

Provides functionality for displaying a collection of CADEntity properties in the PropertyGrid control.

The following tables list the members exposed by the ObjEntities type.

Constructors
 | Name | Description
Public constructor | ObjEntities | Sets a list of child entities
Top
Properties
 | Name | Description
Public property | Bottom | Gets the Y coordinate of the entity's lowest point.
Public property | Color | Gets a list of entities
Public property | Color_type | Gets or sets a color type for the entity.
Public property | Count_entities | Gets a count of entities in list.
Public property | EntName | Gets an entity name. (inherited from ObjEntity).
Public property | Handle | Gets a number that uniquely identifies the entity. (inherited from ObjEntity).
Public property | Layer | Gets or sets a name of a layer containing this entity.
 | LayersList | Gets or sets a list of layers for the properties window. (inherited from ObjEntity).
Public property | Left | Gets the X coordinate of the entity's left-most point.
Public property | Line_type | Gets a line type for an entity. (inherited from ObjEntity).
 | Line_types_list | Gets or sets a list of types of the entity's lines (inherited from ObjEntity).
Public property | Line_weight | Gets or sets a thickness of lines used for drawing this entity.
Public property | Name | Gets a name of the entity.
Public property | ReadCom | (inherited from ObjEntity).
Public property | ReadPos | (inherited from ObjEntity).
Public property | Right | Gets the X coordinate of the entity's right-most point.
Public property | Top | Gets the Y coordinate of the entity's highest point.
Public property | Z1 | Gets the Z coordinate of the entity's start point.
Public property | Z2 | Gets the Z coordinate of the entity's end point.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from ObjEntity).
Top
Fields
Name | Description
cadImage | A CADImage which contains this ObjEntity. (inherited from ObjEntity).
propGrid | A PropertyGrid object representing a table where the entity's properties are displayed. (inherited from ObjEntity).
Top
See Also

Reference

ObjEntities Class


ObjEntities Constructor

Sets a list of child entities

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal entLst As CADEntityCollection _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ObjEntities(
   CADEntityCollection entLst
)
This language is not supported or no code example is available.

Parameters

entLst

Type: CADEntityCollection

A list of entities

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntities Class
ObjEntities Members


ObjEntities Properties

ObjEntities Class See Also

The following tables list the members exposed by the ObjEntities type.

Properties
 | Name | Description
Public property | Bottom | Gets the Y coordinate of the entity's lowest point.
Public property | Color | Gets a list of entities
Public property | Color_type | Gets or sets a color type for the entity.
Public property | Count_entities | Gets a count of entities in list.
Public property | EntName | Gets an entity name. (inherited from ObjEntity).
Public property | Handle | Gets a number that uniquely identifies the entity. (inherited from ObjEntity).
Public property | Layer | Gets or sets a name of a layer containing this entity.
 | LayersList | Gets or sets a list of layers for the properties window. (inherited from ObjEntity).
Public property | Left | Gets the X coordinate of the entity's left-most point.
Public property | Line_type | Gets a line type for an entity. (inherited from ObjEntity).
 | Line_types_list | Gets or sets a list of types of the entity's lines (inherited from ObjEntity).
Public property | Line_weight | Gets or sets a thickness of lines used for drawing this entity.
Public property | Name | Gets a name of the entity.
Public property | ReadCom | (inherited from ObjEntity).
Public property | ReadPos | (inherited from ObjEntity).
Public property | Right | Gets the X coordinate of the entity's right-most point.
Public property | Top | Gets the Y coordinate of the entity's highest point.
Public property | Z1 | Gets the Z coordinate of the entity's start point.
Public property | Z2 | Gets the Z coordinate of the entity's end point.
Top
See Also

Reference

ObjEntities Class


ObjEntities.Bottom Property

Gets the Y coordinate of the entity's lowest point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Bottom() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override double Bottom {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntities Class
ObjEntities Members


ObjEntities.Color Property

Gets a list of entities

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Color() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override Color Color {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntities Class
ObjEntities Members


ObjEntities.Color_type Property

Gets or sets a color type for the entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Color_type() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override string Color_type {get; set;}
This language is not supported or no code example is available.

Property Value

A string containing a color type for the entity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntities Class
ObjEntities Members


ObjEntities.Count_entities Property

Gets a count of entities in list.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Count_entities() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Count_entities {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntities Class
ObjEntities Members


ObjEntity.EntName Property

Gets an entity name.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overridable Property EntName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual string EntName {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntity Class
ObjEntity Members


ObjEntity.Handle Property

Gets a number that uniquely identifies the entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Handle() As UInt64
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public UInt64 Handle {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntity Class
ObjEntity Members


ObjEntities.Layer Property

Gets or sets a name of a layer containing this entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Layer() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override string Layer {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntities Class
ObjEntities Members


ObjEntity.LayersList Property

Gets or sets a list of layers for the properties window.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Property LayersList() As String()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static string[] LayersList {get; set;}
This language is not supported or no code example is available.

Property Value

An array of strings containing names of layers.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntity Class
ObjEntity Members


ObjEntities.Left Property

Gets the X coordinate of the entity's left-most point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Left() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override double Left {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntities Class
ObjEntities Members


ObjEntity.Line_type Property

Gets a line type for an entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overridable Property Line_type() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual string Line_type {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntity Class
ObjEntity Members


ObjEntity.Line_types_list Property

Gets or sets a list of types of the entity's lines

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Property Line_types_list() As String()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static string[] Line_types_list {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntity Class
ObjEntity Members


ObjEntities.Line_weight Property

Gets or sets a thickness of lines used for drawing this entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Line_weight() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override string Line_weight {get; set;}
This language is not supported or no code example is available.

Property Value

A string representation of the line thickness used for drawing this entity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntities Class
ObjEntities Members


ObjEntities.Name Property

Gets a name of the entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Name {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntities Class
ObjEntities Members


ObjEntity.ReadCom Property

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property ReadCom() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string ReadCom {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntity Class
ObjEntity Members


ObjEntity.ReadPos Property

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property ReadPos() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int ReadPos {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntity Class
ObjEntity Members


ObjEntities.Right Property

Gets the X coordinate of the entity's right-most point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Right() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override double Right {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntities Class
ObjEntities Members


ObjEntities.Top Property

Gets the Y coordinate of the entity's highest point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Top() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override double Top {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntities Class
ObjEntities Members


ObjEntities.Z1 Property

Gets the Z coordinate of the entity's start point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Z1() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override double Z1 {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntities Class
ObjEntities Members


ObjEntities.Z2 Property

Gets the Z coordinate of the entity's end point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property Z2() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override double Z2 {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntities Class
ObjEntities Members


ObjEntities Methods

ObjEntities Class See Also

The following tables list the members exposed by the ObjEntities type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from ObjEntity).
Top
See Also

Reference

ObjEntities Class


ObjEntity.ToString Method

Returns a String that represents the current Object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function ToString() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override string ToString()
This language is not supported or no code example is available.

Return Value

A String that represents the current Object.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntity Class
ObjEntity Members


ObjEntities Fields

ObjEntities Class See Also

The following tables list the members exposed by the ObjEntities type.

Fields
Name | Description
cadImage | A CADImage which contains this ObjEntity. (inherited from ObjEntity).
propGrid | A PropertyGrid object representing a table where the entity's properties are displayed. (inherited from ObjEntity).
Top
See Also

Reference

ObjEntities Class


cadImage Field

A CADImage which contains this ObjEntity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared cadImage As CADImage
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static CADImage cadImage
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntity Class
ObjEntity Members


propGrid Field

A PropertyGrid object representing a table where the entity's properties are displayed.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared propGrid As CADPropertyGrid
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static CADPropertyGrid propGrid
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntity Class
ObjEntity Members


ObjEntity Class

Members See Also

Provides functionality for displaying the entity properties in the PropertyGrid control.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class ObjEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class ObjEntity
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.ObjEntity
CADImport.ObjEntities
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntity Members


ObjEntity Members

ObjEntity Class Methods Fields Properties See Also

Provides functionality for displaying the entity properties in the PropertyGrid control.

The following tables list the members exposed by the ObjEntity type.

Properties
 | Name | Description
Public property | Bottom | Gets the Y coordinate of the entity's lowest point.
Public property | Color | Gets or sets a color of the entity.
Public property | Color_type | Gets or sets a color type for the entity.
Public property | EntName | Gets an entity name.
Public property | Handle | Gets a number that uniquely identifies the entity.
Public property | Layer | Gets or sets a name of a layer containing this entity.
 | LayersList | Gets or sets a list of layers for the properties window.
Public property | Left | Gets the X coordinate of the entity's left-most point.
Public property | Line_type | Gets a line type for an entity.
 | Line_types_list | Gets or sets a list of types of the entity's lines
Public property | Line_weight | Gets or sets a thickness of lines used for drawing this entity.
Public property | Name | Gets a name of the entity.
Public property | ReadCom |
Public property | ReadPos |
Public property | Right | Gets the X coordinate of the entity's right-most point.
Public property | Top | Gets the Y coordinate of the entity's highest point.
Public property | Z1 | Gets the Z coordinate of the entity's start point.
Public property | Z2 | Gets the Z coordinate of the entity's end point.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object.
Top
Fields
Name | Description
cadImage | A CADImage which contains this ObjEntity.
propGrid | A PropertyGrid object representing a table where the entity's properties are displayed.
Top
See Also

Reference

ObjEntity Class


ObjEntity Properties

ObjEntity Class See Also

The following tables list the members exposed by the ObjEntity type.

Properties
 | Name | Description
Public property | Bottom | Gets the Y coordinate of the entity's lowest point.
Public property | Color | Gets or sets a color of the entity.
Public property | Color_type | Gets or sets a color type for the entity.
Public property | EntName | Gets an entity name.
Public property | Handle | Gets a number that uniquely identifies the entity.
Public property | Layer | Gets or sets a name of a layer containing this entity.
 | LayersList | Gets or sets a list of layers for the properties window.
Public property | Left | Gets the X coordinate of the entity's left-most point.
Public property | Line_type | Gets a line type for an entity.
 | Line_types_list | Gets or sets a list of types of the entity's lines
Public property | Line_weight | Gets or sets a thickness of lines used for drawing this entity.
Public property | Name | Gets a name of the entity.
Public property | ReadCom |
Public property | ReadPos |
Public property | Right | Gets the X coordinate of the entity's right-most point.
Public property | Top | Gets the Y coordinate of the entity's highest point.
Public property | Z1 | Gets the Z coordinate of the entity's start point.
Public property | Z2 | Gets the Z coordinate of the entity's end point.
Top
See Also

Reference

ObjEntity Class


ObjEntity.Bottom Property

Gets the Y coordinate of the entity's lowest point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overridable Property Bottom() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual double Bottom {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntity Class
ObjEntity Members


ObjEntity.Color Property

Gets or sets a color of the entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Property Color() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual Color Color {get; set;}
This language is not supported or no code example is available.

Property Value

A Color of the entity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntity Class
ObjEntity Members


ObjEntity.Color_type Property

Gets or sets a color type for the entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Property Color_type() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual string Color_type {get; set;}
This language is not supported or no code example is available.

Property Value

A string containing a color type for the entity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntity Class
ObjEntity Members


ObjEntity.Layer Property

Gets or sets a name of a layer containing this entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Property Layer() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual string Layer {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntity Class
ObjEntity Members


ObjEntity.Left Property

Gets the X coordinate of the entity's left-most point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overridable Property Left() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual double Left {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntity Class
ObjEntity Members


ObjEntity.Line_weight Property

Gets or sets a thickness of lines used for drawing this entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Property Line_weight() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual string Line_weight {get; set;}
This language is not supported or no code example is available.

Property Value

A string representation of the line thickness used for drawing this entity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntity Class
ObjEntity Members


ObjEntity.Name Property

Gets a name of the entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overridable Property Name() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual string Name {get;}
This language is not supported or no code example is available.

Property Value

A string containing a name of the entity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntity Class
ObjEntity Members


ObjEntity.Right Property

Gets the X coordinate of the entity's right-most point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overridable Property Right() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual double Right {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntity Class
ObjEntity Members


ObjEntity.Top Property

Gets the Y coordinate of the entity's highest point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overridable Property Top() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual double Top {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntity Class
ObjEntity Members


ObjEntity.Z1 Property

Gets the Z coordinate of the entity's start point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Property Z1() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual double Z1 {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntity Class
ObjEntity Members


ObjEntity.Z2 Property

Gets the Z coordinate of the entity's end point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Property Z2() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual double Z2 {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ObjEntity Class
ObjEntity Members


ObjEntity Methods

ObjEntity Class See Also

The following tables list the members exposed by the ObjEntity type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object.
Top
See Also

Reference

ObjEntity Class


ObjEntity Fields

ObjEntity Class See Also

The following tables list the members exposed by the ObjEntity type.

Fields
Name | Description
cadImage | A CADImage which contains this ObjEntity.
propGrid | A PropertyGrid object representing a table where the entity's properties are displayed.
Top
See Also

Reference

ObjEntity Class


Point3D Class

Members See Also

Provides methods for displaying the coordinates of three-dimensional point in the properties window.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class Point3D
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class Point3D
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Point3D
CADImport.Point3DExt
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Point3D Members


Point3D Members

Point3D Class Constructors Events Methods Fields Properties See Also

Provides methods for displaying the coordinates of three-dimensional point in the properties window.

The following tables list the members exposed by the Point3D type.

Constructors
 | Name | Description
Public constructor | Point3D | (Overloaded) Initializes a new instance of the Point3D class.
Top
Properties
 | Name | Description
Public property | X | Gets or sets the X coordinate of this Point3D object.
Public property | Y | Gets or sets the Y coordinate of this Point3D object.
Public property | Z | Gets or sets the Z coordinate of this Point3D object.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | OnValueChange | Raises the ChangeValue event.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Events
 | Name | Description
Public event | ChangeValue | Occurs when a coordinate of a three-dimensional point in the properties window is changed.
Top
Fields
Name | Description
locked |
Top
See Also

Reference

Point3D Class


Point3D Constructor

Point3D Class See Also

Initializes a new instance of the Point3D class.

Overload List
Name | Description
Point3D() | Initializes a new instance of the Point3D class.
Point3D(DPoint) | Initializes a new instance of the Point3D class.
See Also

Reference

Point3D Class
Point3D Members


Point3D Properties

Point3D Class See Also

The following tables list the members exposed by the Point3D type.

Properties
 | Name | Description
Public property | X | Gets or sets the X coordinate of this Point3D object.
Public property | Y | Gets or sets the Y coordinate of this Point3D object.
Public property | Z | Gets or sets the Z coordinate of this Point3D object.
Top
See Also

Reference

Point3D Class


Point3D.X Property

Gets or sets the X coordinate of this Point3D object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property X() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double X {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Point3D Class
Point3D Members


Point3D.Y Property

Gets or sets the Y coordinate of this Point3D object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Y() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Y {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Point3D Class
Point3D Members


Point3D.Z Property

Gets or sets the Z coordinate of this Point3D object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Z() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Z {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Point3D Class
Point3D Members


Point3D Methods

Point3D Class See Also

The following tables list the members exposed by the Point3D type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | OnValueChange | Raises the ChangeValue event.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

Point3D Class


Point3D.OnValueChange Method

Raises the ChangeValue event.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnValueChange( _
   ByVal val As Point3D _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnValueChange(
   Point3D val
)
This language is not supported or no code example is available.

Parameters

val

Type: Point3D

A Point3D object representing the event data.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Point3D Class
Point3D Members


Point3D Events

Point3D Class See Also

The following tables list the members exposed by the Point3D type.

Events
 | Name | Description
Public event | ChangeValue | Occurs when a coordinate of a three-dimensional point in the properties window is changed.
Top
See Also

Reference

Point3D Class


ChangeValue Event

Occurs when a coordinate of a three-dimensional point in the properties window is changed.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeValue() As CADImport.PointValueChange
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.PointValueChange ChangeValue
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Point3D Class
Point3D Members


Point3D Fields

Point3D Class See Also

The following tables list the members exposed by the Point3D type.

Fields
Name | Description
locked |
Top
See Also

Reference

Point3D Class


locked Field

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Const locked As Boolean = True
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public const bool locked = true
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Point3D Class
Point3D Members


Point3DExt Class

Members See Also

Expand to see the spelling options for the application

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class Point3DExt
    Inherits Point3D
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class Point3DExt : Point3D
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Point3D
CADImport.Point3DExt
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Point3DExt Members


Point3DExt Members

Point3DExt Class Constructors Events Methods Fields Properties See Also

Expand to see the spelling options for the application

The following tables list the members exposed by the Point3DExt type.

Constructors
 | Name | Description
Public constructor | Point3DExt | Initializes a new instance of the Point3DExt class.
Top
Properties
 | Name | Description
Public property | X | Gets or sets the X coordinate of this Point3D object. (inherited from Point3D).
Public property | Y | Gets or sets the Y coordinate of this Point3D object. (inherited from Point3D).
Public property | Z | Gets or sets the Z coordinate of this Point3D object. (inherited from Point3D).
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | OnValueChange | Raises the ChangeValue event. (inherited from Point3D).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Events
 | Name | Description
Public event | ChangeValue | Occurs when a coordinate of a three-dimensional point in the properties window is changed. (inherited from Point3D).
Top
Fields
Name | Description
locked | (inherited from Point3D).
Top
See Also

Reference

Point3DExt Class


Point3DExt Constructor

Initializes a new instance of the Point3DExt class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal val As DPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Point3DExt(
   DPoint val
)
This language is not supported or no code example is available.

Parameters

val

Type: DPoint

A DPoint whose coordinates are displayed in the properties window.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Point3DExt Class
Point3DExt Members


Point3DExt Properties

Point3DExt Class See Also

The following tables list the members exposed by the Point3DExt type.

Properties
 | Name | Description
Public property | X | Gets or sets the X coordinate of this Point3D object. (inherited from Point3D).
Public property | Y | Gets or sets the Y coordinate of this Point3D object. (inherited from Point3D).
Public property | Z | Gets or sets the Z coordinate of this Point3D object. (inherited from Point3D).
Top
See Also

Reference

Point3DExt Class


Point3DExt Methods

Point3DExt Class See Also

The following tables list the members exposed by the Point3DExt type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | OnValueChange | Raises the ChangeValue event. (inherited from Point3D).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

Point3DExt Class


Point3DExt Events

Point3DExt Class See Also

The following tables list the members exposed by the Point3DExt type.

Events
 | Name | Description
Public event | ChangeValue | Occurs when a coordinate of a three-dimensional point in the properties window is changed. (inherited from Point3D).
Top
See Also

Reference

Point3DExt Class


Point3DExt Fields

Point3DExt Class See Also

The following tables list the members exposed by the Point3DExt type.

Fields
Name | Description
locked | (inherited from Point3D).
Top
See Also

Reference

Point3DExt Class


Protection Class

Members See Also

Provides functionality for the application's registration.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public MustInherit Class Protection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public abstract class Protection
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Protection
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Protection Members


Protection Members

Protection Class Methods Fields Properties See Also

Provides functionality for the application's registration.

The following tables list the members exposed by the Protection type.

Properties
Name | Description
LicenseType | Gets or sets a type of license registration.
RegData | Gets or sets the registration data.
Top
Methods
 | Name | Description
 | AddDataToRegistry | Adds the registration data to the registry in case of the successful registration process.
 | CloseApplication | Completes the registration process.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
 | GetDataFromRegistry | Gets the key and the registration data from the registry.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
 | Register | (Overloaded) Realizes the registration process.
 | RemoveDataFromRegistry | Removes the key and the registration data from the registry.
 | RemoveRegInfo | Removes the registration data.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
Name | Description
regForm |
Top
See Also

Reference

Protection Class


Protection Properties

Protection Class See Also

The following tables list the members exposed by the Protection type.

Properties
Name | Description
LicenseType | Gets or sets a type of license registration.
RegData | Gets or sets the registration data.
Top
See Also

Reference

Protection Class


Protection.LicenseType Property

Gets or sets a type of license registration.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Property LicenseType() As LicenseType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static LicenseType LicenseType {get; set;}
This language is not supported or no code example is available.

Property Value

A LicenseType object.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Protection Class
Protection Members


Protection.RegData Property

Gets or sets the registration data.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Property RegData() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static string RegData {get; set;}
This language is not supported or no code example is available.

Property Value

A string containing the registration data.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Protection Class
Protection Members


Protection Methods

Protection Class See Also

The following tables list the members exposed by the Protection type.

Methods
 | Name | Description
 | AddDataToRegistry | Adds the registration data to the registry in case of the successful registration process.
 | CloseApplication | Completes the registration process.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
 | GetDataFromRegistry | Gets the key and the registration data from the registry.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
 | Register | (Overloaded) Realizes the registration process.
 | RemoveDataFromRegistry | Removes the key and the registration data from the registry.
 | RemoveRegInfo | Removes the registration data.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

Protection Class


Protection.AddDataToRegistry Method

Adds the registration data to the registry in case of the successful registration process.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub AddDataToRegistry( _
   ByVal val As String, _
   ByVal regData As ArrayList _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void AddDataToRegistry(
   string val,
   ArrayList regData
)
This language is not supported or no code example is available.

Parameters

val

Type: string

The string containing the key entered by user.

regData

Type: ArrayList

The list containing the registration data.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Protection Class
Protection Members


Protection.CloseApplication Method

Completes the registration process.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub CloseApplication()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void CloseApplication()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Protection Class
Protection Members


Protection.GetDataFromRegistry Method

Gets the key and the registration data from the registry.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function GetDataFromRegistry() As ArrayList
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static ArrayList GetDataFromRegistry()
This language is not supported or no code example is available.

Return Value

An ArrayList containing the key and the registration data.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Protection Class
Protection Members


Protection.Register Method

Protection Class See Also

Realizes the registration process.

Overload List
Name | Description
Register(string, string, string, bool) | Realizes the registration process.
Register(string, ArrayList, bool) | Realizes the registration process.
Register(IWin32Window) | Realizes the registration process using the registration form.
See Also

Reference

Protection Class
Protection Members


Protection.RemoveDataFromRegistry Method

Removes the key and the registration data from the registry.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub RemoveDataFromRegistry()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void RemoveDataFromRegistry()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Protection Class
Protection Members


Protection.RemoveRegInfo Method

Removes the registration data.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub RemoveRegInfo()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void RemoveRegInfo()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Protection Class
Protection Members


Protection Fields

Protection Class See Also

The following tables list the members exposed by the Protection type.

Fields
Name | Description
regForm |
Top
See Also

Reference

Protection Class


regForm Field

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared regForm As RegForm
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static RegForm regForm
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Protection Class
Protection Members


SGLines Class

Members See Also

Provides parameters that specify a line type in a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class SGLines
    Implements IDisposable
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class SGLines : IDisposable
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.SGLines
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SGLines Members


SGLines Members

SGLines Class Constructors Methods Properties See Also

Provides parameters that specify a line type in a CAD image.

The following tables list the members exposed by the SGLines type.

Constructors
 | Name | Description
Public constructor | SGLines | Initialises a new instance of the SGLines class.
Top
Properties
 | Name | Description
Public property | Elements | Gets or sets a list of the specific line elements(dash, dot or space).
Public property | IsDotted | Determines if the line is dotted.
Public property | IsUniform | For internal use.
Public property | MaxSize | Gets a max size of pattern.
Public property | PatternLength | Gets or sets a lenght of a pattern of a dotted line.
Public property | Scale | Gets or sets a scale factor of a pattern of a dotted line.
Top
Methods
 | Name | Description
Public method | Add | Adds an element to the list of line elements.
Public method | AddTick | Initializes and adds an element to the list of line elements.
Public method | Assign | Copies an entity
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | HatchLine | For internal use.
Public method | Initialize | Initializes a list of line elements.
Public method | IsSolid | Determines whether or not the specified line is solid.
Public method | Line | Makes a list of points on the basis of the list of line elements and changes straight line in CADImage.
Public method | Loaded | Loads this SGLines to the specified CADConverter.
Public method | Poly | Makes a list of points on the basis of the list of line elements and changes polyline in CADImage.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

SGLines Class


SGLines Constructor

Initialises a new instance of the SGLines class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SGLines()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SGLines Class
SGLines Members


SGLines Properties

SGLines Class See Also

The following tables list the members exposed by the SGLines type.

Properties
 | Name | Description
Public property | Elements | Gets or sets a list of the specific line elements(dash, dot or space).
Public property | IsDotted | Determines if the line is dotted.
Public property | IsUniform | For internal use.
Public property | MaxSize | Gets a max size of pattern.
Public property | PatternLength | Gets or sets a lenght of a pattern of a dotted line.
Public property | Scale | Gets or sets a scale factor of a pattern of a dotted line.
Top
See Also

Reference

SGLines Class


SGLines.Elements Property

Gets or sets a list of the specific line elements(dash, dot or space).

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Elements() As CADCollection(Of LTypeElementStruct)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection<LTypeElementStruct> Elements {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SGLines Class
SGLines Members


SGLines.IsDotted Property

Determines if the line is dotted.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property IsDotted() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsDotted {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SGLines Class
SGLines Members


SGLines.IsUniform Property

For internal use.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property IsUniform() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsUniform {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SGLines Class
SGLines Members


SGLines.MaxSize Property

Gets a max size of pattern.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property MaxSize() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double MaxSize {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SGLines Class
SGLines Members


SGLines.PatternLength Property

Gets or sets a lenght of a pattern of a dotted line.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PatternLength() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double PatternLength {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SGLines Class
SGLines Members


SGLines.Scale Property

Gets or sets a scale factor of a pattern of a dotted line.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Scale() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Scale {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SGLines Class
SGLines Members


SGLines Methods

SGLines Class See Also

The following tables list the members exposed by the SGLines type.

Methods
 | Name | Description
Public method | Add | Adds an element to the list of line elements.
Public method | AddTick | Initializes and adds an element to the list of line elements.
Public method | Assign | Copies an entity
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | HatchLine | For internal use.
Public method | Initialize | Initializes a list of line elements.
Public method | IsSolid | Determines whether or not the specified line is solid.
Public method | Line | Makes a list of points on the basis of the list of line elements and changes straight line in CADImage.
Public method | Loaded | Loads this SGLines to the specified CADConverter.
Public method | Poly | Makes a list of points on the basis of the list of line elements and changes polyline in CADImage.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

SGLines Class


SGLines.Add Method

Adds an element to the list of line elements.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Add( _
   ByVal element As LTypeElementStruct _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Add(
   LTypeElementStruct element
)
This language is not supported or no code example is available.

Parameters

element

Type: LTypeElementStruct

An element to add.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SGLines Class
SGLines Members


SGLines.AddTick Method

Initializes and adds an element to the list of line elements.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddTick( _
   ByVal value As Double _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddTick(
   double value
)
This language is not supported or no code example is available.

Parameters

value

Type: double

An element to add.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SGLines Class
SGLines Members


SGLines.Assign Method

Copies an entity

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Assign( _
   ByVal lines As SGLines _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Assign(
   SGLines lines
)
This language is not supported or no code example is available.

Parameters

lines

Type: SGLines

An entity to copy

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SGLines Class
SGLines Members


SGLines.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Dispose() Implements  _
   IDisposable.Dispose
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Dispose()
This language is not supported or no code example is available.

Implements

IDisposable.Dispose
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SGLines Class
SGLines Members


SGLines.HatchLine Method

For internal use.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub HatchLine( _
   ByVal aList As Double(), _
   ByVal Pt1 As DPoint, _
   ByVal Pt2 As DPoint, _
   ByVal BasePt As DPoint, _
   ByVal DottedSingPts As ArrayList, _
   ByRef index As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void HatchLine(
   double[] aList,
   DPoint Pt1,
   DPoint Pt2,
   DPoint BasePt,
   ArrayList DottedSingPts,
   ref int index
)
This language is not supported or no code example is available.

Parameters

aList

Type: double[]

Pt1

Type: DPoint

Pt2

Type: DPoint

BasePt

Type: DPoint

DottedSingPts

Type: ArrayList

index

Type: int

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SGLines Class
SGLines Members


SGLines.Initialize Method

Initializes a list of line elements.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Initialize( _
   ByVal part As Double() _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Initialize(
   double[] part
)
This language is not supported or no code example is available.

Parameters

part

Type: double[]

A number of elements in list.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SGLines Class
SGLines Members


SGLines.IsSolid Method

Determines whether or not the specified line is solid.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function IsSolid() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsSolid()
This language is not supported or no code example is available.

Return Value

True if line is solid; otherwise false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SGLines Class
SGLines Members


SGLines.Line Method

Makes a list of points on the basis of the list of line elements and changes straight line in CADImage.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Line( _
   ByVal p1 As DPoint, _
   ByVal p2 As DPoint, _
   ByVal dottedSignPts As CADCollection(Of DPoint) _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Line(
   DPoint p1,
   DPoint p2,
   CADCollection<DPoint> dottedSignPts
)
This language is not supported or no code example is available.

Parameters

p1

Type: DPoint

The start point of a line

p2

Type: DPoint

The end point of the line

dottedSignPts

Type: CADCollection<DPoint>

A list of points. It is filled on the basis of a list of line elements.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SGLines Class
SGLines Members


SGLines.Loaded Method

Loads this SGLines to the specified CADConverter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a SGLines is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SGLines Class
SGLines Members


SGLines.Poly Method

Makes a list of points on the basis of the list of line elements and changes polyline in CADImage.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Poly( _
   ByVal points As CADCollection(Of DPoint), _
   ByVal dottedSignPts As CADCollection(Of DPoint), _
   ByVal closed As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Poly(
   CADCollection<DPoint> points,
   CADCollection<DPoint> dottedSignPts,
   bool closed
)
This language is not supported or no code example is available.

Parameters

points

Type: CADCollection<DPoint>

A list of border points of the polyline.

dottedSignPts

Type: CADCollection<DPoint>

A list of points. It is filled on the basis of a list of line elements.

closed

Type: bool

Specifies if the polyline is closed.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SGLines Class
SGLines Members


SHXFont Class

Members See Also

Represents fonts from the compiled shape (SHX) files.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class SHXFont
    Implements IDisposable
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class SHXFont : IDisposable
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.SHXFont
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXFont Members


SHXFont Members

SHXFont Class Constructors Methods Properties See Also

Represents fonts from the compiled shape (SHX) files.

The following tables list the members exposed by the SHXFont type.

Constructors
 | Name | Description
Public constructor | SHXFont | Initializes a new instance of the SHXFont class.
Top
Properties
 | Name | Description
Public property | Loaded | Gets the boolean value indicating whether a SHX font with the specified name had been loaded.
Public property | Name | Gets a full path to the file containing the SHX fonts.
Public property | NumChars | Gets a number of characters in the loaded SHX file.
Top
Methods
 | Name | Description
Public method | AddNewShape | For internal use.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
 | FindShape | For internal use.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | IsUnicodeSHX | Returns a value indicating whether the SHX fonts are the unicode SHX fonts and contained in the specified list.
Public method | Load | Loads the SHX fonts specified by the name property.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

SHXFont Class


SHXFont Constructor

Initializes a new instance of the SHXFont class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal aFontPath As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SHXFont(
   string aFontPath
)
This language is not supported or no code example is available.

Parameters

aFontPath

Type: string

A string containing a path to the SHX file to be loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXFont Class
SHXFont Members


SHXFont Properties

SHXFont Class See Also

The following tables list the members exposed by the SHXFont type.

Properties
 | Name | Description
Public property | Loaded | Gets the boolean value indicating whether a SHX font with the specified name had been loaded.
Public property | Name | Gets a full path to the file containing the SHX fonts.
Public property | NumChars | Gets a number of characters in the loaded SHX file.
Top
See Also

Reference

SHXFont Class


SHXFont.Loaded Property

Gets the boolean value indicating whether a SHX font with the specified name had been loaded.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Loaded() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Loaded {get;}
This language is not supported or no code example is available.

Property Value

true if the SHX fonts had been loaded; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXFont Class
SHXFont Members


SHXFont.Name Property

Gets a full path to the file containing the SHX fonts.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Name {get;}
This language is not supported or no code example is available.

Property Value

A string containing a full path to the SHX file.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXFont Class
SHXFont Members


SHXFont.NumChars Property

Gets a number of characters in the loaded SHX file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property NumChars() As UInt16
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public UInt16 NumChars {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXFont Class
SHXFont Members


SHXFont Methods

SHXFont Class See Also

The following tables list the members exposed by the SHXFont type.

Methods
 | Name | Description
Public method | AddNewShape | For internal use.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
 | FindShape | For internal use.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | IsUnicodeSHX | Returns a value indicating whether the SHX fonts are the unicode SHX fonts and contained in the specified list.
Public method | Load | Loads the SHX fonts specified by the name property.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

SHXFont Class


SHXFont.AddNewShape Method

For internal use.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddNewShape( _
   ByVal shapeNumber As UInt16, _
   ByVal shapeName As String, _
   ByVal shapePoly As ArrayList _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddNewShape(
   UInt16 shapeNumber,
   string shapeName,
   ArrayList shapePoly
)
This language is not supported or no code example is available.

Parameters

shapeNumber

Type: UInt16

shapeName

Type: string

shapePoly

Type: ArrayList

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXFont Class
SHXFont Members


SHXFont.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Dispose() Implements  _
   IDisposable.Dispose
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Dispose()
This language is not supported or no code example is available.

Implements

IDisposable.Dispose
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXFont Class
SHXFont Members


SHXFont.FindShape Method

For internal use.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function FindShape( _
   ByVal shxList As SHXFontList, _
   ByRef shapeNumber As UInt16, _
   ByRef shapeName As String, _
   ByRef fontName As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool FindShape(
   SHXFontList shxList,
   ref UInt16 shapeNumber,
   ref string shapeName,
   ref string fontName
)
This language is not supported or no code example is available.

Parameters

shxList

Type: SHXFontList

shapeNumber

Type: UInt16

shapeName

Type: string

fontName

Type: string

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXFont Class
SHXFont Members


SHXFont.IsUnicodeSHX Method

Returns a value indicating whether the SHX fonts are the unicode SHX fonts and contained in the specified list.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function IsUnicodeSHX( _
   ByVal ASHXStyles As SHXFontList, _
   ByVal AFontName As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool IsUnicodeSHX(
   SHXFontList ASHXStyles,
   string AFontName
)
This language is not supported or no code example is available.

Parameters

ASHXStyles

Type: SHXFontList

A list of the SHX fonts where the specified SHX fonts are searched for.

AFontName

Type: string

A string containing a name of the SHX fonts to search for.

Return Value

true if the SHX fonts are the unicode SHX fonts and contained in the specified list; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXFont Class
SHXFont Members


SHXFont.Load Method

Loads the SHX fonts specified by the name property.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Load() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Load()
This language is not supported or no code example is available.

Return Value

true if the SHX fonts have been loaded; otherwize, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXFont Class
SHXFont Members


SHXFontList Class

Members See Also

Represents a list of SHX fonts among which the default SHX fonts are searched.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class SHXFontList
    Implements IDisposable
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class SHXFontList : IDisposable
This language is not supported or no code example is available.
Remarks

The default SHX fonts are "txt.shx" and location of this file is searched in the list represented by the SHXFontList class.

Inheritance Hierarchy
System.Object
CADImport.SHXFontList
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXFontList Members


SHXFontList Members

SHXFontList Class Constructors Methods Properties See Also

Represents a list of SHX fonts among which the default SHX fonts are searched.

The following tables list the members exposed by the SHXFontList type.

Constructors
 | Name | Description
Public constructor | SHXFontList | Initializes a new instance of the SHXFontList class.
Top
Properties
 | Name | Description
Public property | DefaultFont | Gets a name of the default SHX file.
Public property | DefaultFontPath | Gets or sets a path to the default SHX file.
Public property | FontNames | Gets a list of names of the SHX fonts from the current SHXFontList.
Public property | Fonts | Gets a list of SHX fonts from the current SHXFontList.
Public property | SearchPath | Gets a list of paths from the current SHXFontList.
Public property | SearchedFonts | Gets a list that contains results of search for each SHX font.
Public property | ShapeFonts | Gets or sets a list of shapes of the SHX fonts.
Public property | Styles | Gets a list of font styles from the current SHXFontList.
Top
Methods
 | Name | Description
Public method | AddStyle | Creates a text style and adds it to the current SHXFontList.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

SHXFontList Class


SHXFontList Constructor

Initializes a new instance of the SHXFontList class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SHXFontList()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXFontList Class
SHXFontList Members


SHXFontList Properties

SHXFontList Class See Also

The following tables list the members exposed by the SHXFontList type.

Properties
 | Name | Description
Public property | DefaultFont | Gets a name of the default SHX file.
Public property | DefaultFontPath | Gets or sets a path to the default SHX file.
Public property | FontNames | Gets a list of names of the SHX fonts from the current SHXFontList.
Public property | Fonts | Gets a list of SHX fonts from the current SHXFontList.
Public property | SearchPath | Gets a list of paths from the current SHXFontList.
Public property | SearchedFonts | Gets a list that contains results of search for each SHX font.
Public property | ShapeFonts | Gets or sets a list of shapes of the SHX fonts.
Public property | Styles | Gets a list of font styles from the current SHXFontList.
Top
See Also

Reference

SHXFontList Class


SHXFontList.DefaultFont Property

Gets a name of the default SHX file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property DefaultFont() As SHXFont
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SHXFont DefaultFont {get;}
This language is not supported or no code example is available.

Property Value

A string containing a name of the default SHX file.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXFontList Class
SHXFontList Members


SHXFontList.DefaultFontPath Property

Gets or sets a path to the default SHX file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DefaultFontPath() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string DefaultFontPath {get; set;}
This language is not supported or no code example is available.

Property Value

A string containing a path to the default SHX file.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXFontList Class
SHXFontList Members


SHXFontList.FontNames Property

Gets a list of names of the SHX fonts from the current SHXFontList.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property FontNames() As CADCollection(Of String)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection<string> FontNames {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXFontList Class
SHXFontList Members


SHXFontList.Fonts Property

Gets a list of SHX fonts from the current SHXFontList.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Fonts() As ArrayList
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ArrayList Fonts {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXFontList Class
SHXFontList Members


SHXFontList.SearchPath Property

Gets a list of paths from the current SHXFontList.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property SearchPath() As CADCollection(Of String)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection<string> SearchPath {get;}
This language is not supported or no code example is available.
Remarks

A return value contains a list of paths where search for a default SHX file.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXFontList Class
SHXFontList Members


SHXFontList.SearchedFonts Property

Gets a list that contains results of search for each SHX font.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property SearchedFonts() As Dictionary(Of String, Integer)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Dictionary<string, int> SearchedFonts {get;}
This language is not supported or no code example is available.
Remarks

Implements the way of fonts search caching.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXFontList Class
SHXFontList Members


SHXFontList.ShapeFonts Property

Gets or sets a list of shapes of the SHX fonts.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ShapeFonts() As ArrayList
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ArrayList ShapeFonts {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXFontList Class
SHXFontList Members


SHXFontList.Styles Property

Gets a list of font styles from the current SHXFontList.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Styles() As CADCollection(Of TextStyle)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection<TextStyle> Styles {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXFontList Class
SHXFontList Members


SHXFontList Methods

SHXFontList Class See Also

The following tables list the members exposed by the SHXFontList type.

Methods
 | Name | Description
Public method | AddStyle | Creates a text style and adds it to the current SHXFontList.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

SHXFontList Class


SHXFontList.AddStyle Method

Creates a text style and adds it to the current SHXFontList.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function AddStyle( _
   ByVal aName As String, _
   ByVal aFontName As String, _
   ByVal aBigFontName As String, _
   ByVal aVertical As Boolean, _
   ByVal aUpSideDown As Boolean, _
   ByVal aBackwards As Boolean, _
   ByVal aObliqueAngle As Double, _
   ByVal aWidth As Double _
) As TextStyle
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public TextStyle AddStyle(
   string aName,
   string aFontName,
   string aBigFontName,
   bool aVertical,
   bool aUpSideDown,
   bool aBackwards,
   double aObliqueAngle,
   double aWidth
)
This language is not supported or no code example is available.

Parameters

aName

Type: string

A name of the text style to add to the SHXFontList.

aFontName

Type: string

A name of the SHX fonts to add to the SHXFontList.

aBigFontName

Type: string

A string containing a path to the big fonts file. If the style to be added doesn't specify big fonts, this string is empty.

aVertical

Type: bool

A boolean value indicating whether the text is vertical.

aUpSideDown

Type: bool

A boolean value indicating whether the text is upside down (mirrored in Y direction).

aBackwards

Type: bool

A boolean value indicating whether the text is backward (mirrored in X direction).

aObliqueAngle

Type: double

A tilt angle for the text letters.

aWidth

Type: double

A WidthFactor for the text.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXFontList Class
SHXFontList Members


SHXFontList.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Dispose() Implements  _
   IDisposable.Dispose
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Dispose()
This language is not supported or no code example is available.

Implements

IDisposable.Dispose
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXFontList Class
SHXFontList Members


TextStyle Class

Members See Also

Represents a text style for the SHX fonts.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class TextStyle
    Implements IDisposable
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class TextStyle : IDisposable
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.TextStyle
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TextStyle Members


TextStyle Members

TextStyle Class Methods Fields See Also

Represents a text style for the SHX fonts.

The following tables list the members exposed by the TextStyle type.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | backwards | A boolean value indicating whether the text is backward (mirrored in X direction).
Public field | bigFontIndex | An index of the big SHX font in the SHXFontList.
Public field | bigFontPath | A path to the file containing big fonts.
Public field | fontExists | A boolean value indicating whether the SHX file exists.
Public field | fontIndex | An index of the SHX font in the SHXFontList.
Public field | fontPath | A path to the SHX file.
Public field | name | A name of the text style.
Public field | obliqueAngle | A tilt angle for the letters defined by the style.
Public field | upSideDown | A boolean value indicating whether the text is upside down (mirrored in Y direction).
Public field | vertical | A boolean value indicating whether the text is vertical.
Public field | width | A WidthFactor for the text.
Top
See Also

Reference

TextStyle Class


TextStyle Methods

TextStyle Class See Also

The following tables list the members exposed by the TextStyle type.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

TextStyle Class


TextStyle.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Dispose() Implements  _
   IDisposable.Dispose
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Dispose()
This language is not supported or no code example is available.

Implements

IDisposable.Dispose
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TextStyle Class
TextStyle Members


TextStyle Fields

TextStyle Class See Also

The following tables list the members exposed by the TextStyle type.

Fields
 | Name | Description
Public field | backwards | A boolean value indicating whether the text is backward (mirrored in X direction).
Public field | bigFontIndex | An index of the big SHX font in the SHXFontList.
Public field | bigFontPath | A path to the file containing big fonts.
Public field | fontExists | A boolean value indicating whether the SHX file exists.
Public field | fontIndex | An index of the SHX font in the SHXFontList.
Public field | fontPath | A path to the SHX file.
Public field | name | A name of the text style.
Public field | obliqueAngle | A tilt angle for the letters defined by the style.
Public field | upSideDown | A boolean value indicating whether the text is upside down (mirrored in Y direction).
Public field | vertical | A boolean value indicating whether the text is vertical.
Public field | width | A WidthFactor for the text.
Top
See Also

Reference

TextStyle Class


backwards Field

A boolean value indicating whether the text is backward (mirrored in X direction).

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public backwards As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool backwards
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TextStyle Class
TextStyle Members


bigFontIndex Field

An index of the big SHX font in the SHXFontList.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public bigFontIndex As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int bigFontIndex
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TextStyle Class
TextStyle Members


bigFontPath Field

A path to the file containing big fonts.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public bigFontPath As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string bigFontPath
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TextStyle Class
TextStyle Members


fontExists Field

A boolean value indicating whether the SHX file exists.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public fontExists As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool fontExists
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TextStyle Class
TextStyle Members


fontIndex Field

An index of the SHX font in the SHXFontList.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public fontIndex As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int fontIndex
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TextStyle Class
TextStyle Members


fontPath Field

A path to the SHX file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public fontPath As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string fontPath
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TextStyle Class
TextStyle Members


name Field

A name of the text style.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public name As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string name
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TextStyle Class
TextStyle Members


obliqueAngle Field

A tilt angle for the letters defined by the style.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public obliqueAngle As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double obliqueAngle
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TextStyle Class
TextStyle Members


upSideDown Field

A boolean value indicating whether the text is upside down (mirrored in Y direction).

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public upSideDown As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool upSideDown
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TextStyle Class
TextStyle Members


vertical Field

A boolean value indicating whether the text is vertical.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public vertical As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool vertical
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TextStyle Class
TextStyle Members


width Field

A WidthFactor for the text.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public width As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double width
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TextStyle Class
TextStyle Members


Vertex3D Class

Members See Also

Provides methods for displaying the coordinates of three-dimensional vertex in the properties window.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class Vertex3D
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class Vertex3D
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Vertex3D
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Vertex3D Members


Vertex3D Members

Vertex3D Class Constructors Events Methods Properties See Also

Provides methods for displaying the coordinates of three-dimensional vertex in the properties window.

The following tables list the members exposed by the Vertex3D type.

Constructors
 | Name | Description
Public constructor | Vertex3D | Initializes a new instance of the Vertex3D class.
Top
Properties
 | Name | Description
Public property | Bulge | Gets or sets Vertex3D object roundedness
Public property | EndWidth | Gets or sets a width at the end point of a polyline segment that started at this vertex.
Public property | Point | Gets or sets Vertex3D object position
Public property | StartWidth | Gets or sets a width at the start point of a polyline segment that started at this vertex.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | OnValueChange | Raises the ChangeValue event.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Events
 | Name | Description
Public event | ChangeValue | Occurs when a coordinate of a three-dimensional vertex in the properties window is changed.
Top
See Also

Reference

Vertex3D Class


Vertex3D Constructor

Initializes a new instance of the Vertex3D class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Vertex3D()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Vertex3D Class
Vertex3D Members


Vertex3D Properties

Vertex3D Class See Also

The following tables list the members exposed by the Vertex3D type.

Properties
 | Name | Description
Public property | Bulge | Gets or sets Vertex3D object roundedness
Public property | EndWidth | Gets or sets a width at the end point of a polyline segment that started at this vertex.
Public property | Point | Gets or sets Vertex3D object position
Public property | StartWidth | Gets or sets a width at the start point of a polyline segment that started at this vertex.
Top
See Also

Reference

Vertex3D Class


Vertex3D.Bulge Property

Gets or sets Vertex3D object roundedness

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Bulge() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Bulge {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Vertex3D Class
Vertex3D Members


Vertex3D.EndWidth Property

Gets or sets a width at the end point of a polyline segment that started at this vertex.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property EndWidth() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float EndWidth {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Vertex3D Class
Vertex3D Members


Vertex3D.Point Property

Gets or sets Vertex3D object position

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Point() As Point3DExt
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Point3DExt Point {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Vertex3D Class
Vertex3D Members


Vertex3D.StartWidth Property

Gets or sets a width at the start point of a polyline segment that started at this vertex.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property StartWidth() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float StartWidth {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Vertex3D Class
Vertex3D Members


Vertex3D Methods

Vertex3D Class See Also

The following tables list the members exposed by the Vertex3D type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | OnValueChange | Raises the ChangeValue event.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

Vertex3D Class


Vertex3D.OnValueChange Method

Raises the ChangeValue event.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnValueChange( _
   ByVal val As Vertex3D _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnValueChange(
   Vertex3D val
)
This language is not supported or no code example is available.

Parameters

val

Type: Vertex3D

A Vertex3D object representing the event data.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Vertex3D Class
Vertex3D Members


Vertex3D Events

Vertex3D Class See Also

The following tables list the members exposed by the Vertex3D type.

Events
 | Name | Description
Public event | ChangeValue | Occurs when a coordinate of a three-dimensional vertex in the properties window is changed.
Top
See Also

Reference

Vertex3D Class


ChangeValue Event

Occurs when a coordinate of a three-dimensional vertex in the properties window is changed.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeValue() As CADImport.VertexValueChange
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.VertexValueChange ChangeValue
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Vertex3D Class
Vertex3D Members


Xdata Class

Members See Also

Represents a single Extended Data entry

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class Xdata
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class Xdata
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Xdata
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Xdata Members


Xdata Members

Xdata Class Methods Properties See Also

Represents a single Extended Data entry

The following tables list the members exposed by the Xdata type.

Properties
 | Name | Description
Public property | Code | Represents group code describing the Xdata type
Public property | Data | Represents the value of the Xdata entry
Top
Methods
 | Name | Description
 | CreateRecord | Creates a new Xdata entry
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

Xdata Class


Xdata Properties

Xdata Class See Also

The following tables list the members exposed by the Xdata type.

Properties
 | Name | Description
Public property | Code | Represents group code describing the Xdata type
Public property | Data | Represents the value of the Xdata entry
Top
See Also

Reference

Xdata Class


Xdata.Code Property

Represents group code describing the Xdata type

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Code() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Code {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Xdata Class
Xdata Members


Xdata.Data Property

Represents the value of the Xdata entry

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Data() As Object
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public object Data {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Xdata Class
Xdata Members


Xdata Methods

Xdata Class See Also

The following tables list the members exposed by the Xdata type.

Methods
 | Name | Description
 | CreateRecord | Creates a new Xdata entry
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

Xdata Class


Xdata.CreateRecord Method

Creates a new Xdata entry

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function CreateRecord( _
   ByVal GrCode As Integer, _
   ByVal Value As Object _
) As Xdata
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static Xdata CreateRecord(
   int GrCode,
   object Value
)
This language is not supported or no code example is available.

Parameters

GrCode

Type: int

A group code describing the Xdata type

Value

Type: object

A value of the Xdata entry

Return Value

The type of the Value must be same as described with GrCode. Otherwise null will be returned
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Xdata Class
Xdata Members


Xtome Class

Members See Also

Groups Xdata entries by an application

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class Xtome
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class Xtome
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Xtome
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Xtome Members


Xtome Members

Xtome Class Constructors Methods Properties See Also

Groups Xdata entries by an application

The following tables list the members exposed by the Xtome type.

Constructors
 | Name | Description
Public constructor | Xtome | Initializes a new tome of Xdata entries
Top
Properties
 | Name | Description
Public property | Name | Gets a name of the tome
Public property | Records | Gets entries list of the tome
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

Xtome Class


Xtome Constructor

Initializes a new tome of Xdata entries

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal Value As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Xtome(
   string Value
)
This language is not supported or no code example is available.

Parameters

Value

Type: string

Tome or application name

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Xtome Class
Xtome Members


Xtome Properties

Xtome Class See Also

The following tables list the members exposed by the Xtome type.

Properties
 | Name | Description
Public property | Name | Gets a name of the tome
Public property | Records | Gets entries list of the tome
Top
See Also

Reference

Xtome Class


Xtome.Name Property

Gets a name of the tome

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Name {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Xtome Class
Xtome Members


Xtome.Records Property

Gets entries list of the tome

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Records() As List(Of Xdata)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public List<Xdata> Records {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Xtome Class
Xtome Members


Xtome Methods

Xtome Class See Also

The following tables list the members exposed by the Xtome type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

Xtome Class


XtomesList Class

Members See Also

Represents an Extended Data instance as a list of Xtome instances

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class XtomesList
    Inherits List(Of Xtome)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class XtomesList : List<Xtome>
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Collections.Generic.List<T>
CADImport.XtomesList
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

XtomesList Members


XtomesList Members

XtomesList Class Methods Properties See Also

Represents an Extended Data instance as a list of Xtome instances

The following tables list the members exposed by the XtomesList type.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (inherited from List<T>).
Public property | Count | Gets the number of elements actually contained in the List<T>. (inherited from List<T>).
Public property | Item | Gets or sets the element at the specified index. (inherited from List<T>).
Top
Methods
 | Name | Description
Public method | Add | (Overloaded) Adds an Xtome instanse to the Extended Data instance
Public method | AddRange | (Overloaded) Adds a collection of Xtome instances to the Extended Data instance
Public method | AsReadOnly | Returns a read-only IList<T> wrapper for the current collection. (inherited from List<T>).
Public method | BinarySearch | (Overloaded) Searches a range of elements in the sorted List<T> for an element using the specified comparer and returns the zero-based index of the element. (inherited from List<T>).
Public method | Clear | Removes all elements from the List<T>. (inherited from List<T>).
Public method | Contains | Determines whether an element is in the List<T>. (inherited from List<T>).
Public method | ConvertAll | Converts the elements in the current List<T> to another type, and returns a list containing the converted elements. (inherited from List<T>).
Public method | CopyTo | (Overloaded) Copies the entire List<T> to a compatible one-dimensional array, starting at the beginning of the target array. (inherited from List<T>).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | Exists | Determines whether the List<T> contains elements that match the conditions defined by the specified predicate. (inherited from List<T>).
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<T>. (inherited from List<T>).
Public method | FindAll | Retrieves the all the elements that match the conditions defined by the specified predicate. (inherited from List<T>).
Public method | FindIndex | (Overloaded) Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<T>. (inherited from List<T>).
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<T>. (inherited from List<T>).
Public method | FindLastIndex | (Overloaded) Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<T>. (inherited from List<T>).
Public method | FindTome | Retrieves a tome with a specified name. The name is not case sensitive.
Public method | ForEach | Performs the specified action on each element of the List<T>. (inherited from List<T>).
Public method | GetEnumerator | Returns an enumerator that iterates through the List<T>. (inherited from List<T>).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<T>. (inherited from List<T>).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IndexOf | (Overloaded) Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<T>. (inherited from List<T>).
Public method | Insert | Inserts an element into the List<T> at the specified index. (inherited from List<T>).
Public method | InsertRange | Inserts the elements of a collection into the List<T> at the specified index. (inherited from List<T>).
Public method | LastIndexOf | (Overloaded) Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<T>. (inherited from List<T>).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Remove | Removes the first occurrence of a specific object from the List<T>. (inherited from List<T>).
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (inherited from List<T>).
Public method | RemoveAt | Removes the element at the specified index of the List<T>. (inherited from List<T>).
Public method | RemoveRange | Removes a range of elements from the List<T>. (inherited from List<T>).
Public method | RemoveTome | Removes a tome with the specified name. The name is not case sensitive.
Public method | Reverse | (Overloaded) Reverses the order of the elements in the entire List<T>. (inherited from List<T>).
Public method | Sort | (Overloaded) Sorts the elements in the entire List<T> using the default comparer. (inherited from List<T>).
Public method | ToArray | Copies the elements of the List<T> to a new array. (inherited from List<T>).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<T>, if that number is less than a threshold value. (inherited from List<T>).
Public method | TrueForAll | Determines whether every element in the List<T> matches the conditions defined by the specified predicate. (inherited from List<T>).
Top
See Also

Reference

XtomesList Class


XtomesList Properties

XtomesList Class See Also

The following tables list the members exposed by the XtomesList type.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (inherited from List<T>).
Public property | Count | Gets the number of elements actually contained in the List<T>. (inherited from List<T>).
Public property | Item | Gets or sets the element at the specified index. (inherited from List<T>).
Top
See Also

Reference

XtomesList Class


XtomesList Methods

XtomesList Class See Also

The following tables list the members exposed by the XtomesList type.

Methods
 | Name | Description
Public method | Add | (Overloaded) Adds an Xtome instanse to the Extended Data instance
Public method | AddRange | (Overloaded) Adds a collection of Xtome instances to the Extended Data instance
Public method | AsReadOnly | Returns a read-only IList<T> wrapper for the current collection. (inherited from List<T>).
Public method | BinarySearch | (Overloaded) Searches a range of elements in the sorted List<T> for an element using the specified comparer and returns the zero-based index of the element. (inherited from List<T>).
Public method | Clear | Removes all elements from the List<T>. (inherited from List<T>).
Public method | Contains | Determines whether an element is in the List<T>. (inherited from List<T>).
Public method | ConvertAll | Converts the elements in the current List<T> to another type, and returns a list containing the converted elements. (inherited from List<T>).
Public method | CopyTo | (Overloaded) Copies the entire List<T> to a compatible one-dimensional array, starting at the beginning of the target array. (inherited from List<T>).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | Exists | Determines whether the List<T> contains elements that match the conditions defined by the specified predicate. (inherited from List<T>).
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<T>. (inherited from List<T>).
Public method | FindAll | Retrieves the all the elements that match the conditions defined by the specified predicate. (inherited from List<T>).
Public method | FindIndex | (Overloaded) Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<T>. (inherited from List<T>).
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<T>. (inherited from List<T>).
Public method | FindLastIndex | (Overloaded) Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<T>. (inherited from List<T>).
Public method | FindTome | Retrieves a tome with a specified name. The name is not case sensitive.
Public method | ForEach | Performs the specified action on each element of the List<T>. (inherited from List<T>).
Public method | GetEnumerator | Returns an enumerator that iterates through the List<T>. (inherited from List<T>).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<T>. (inherited from List<T>).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IndexOf | (Overloaded) Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<T>. (inherited from List<T>).
Public method | Insert | Inserts an element into the List<T> at the specified index. (inherited from List<T>).
Public method | InsertRange | Inserts the elements of a collection into the List<T> at the specified index. (inherited from List<T>).
Public method | LastIndexOf | (Overloaded) Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<T>. (inherited from List<T>).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Remove | Removes the first occurrence of a specific object from the List<T>. (inherited from List<T>).
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (inherited from List<T>).
Public method | RemoveAt | Removes the element at the specified index of the List<T>. (inherited from List<T>).
Public method | RemoveRange | Removes a range of elements from the List<T>. (inherited from List<T>).
Public method | RemoveTome | Removes a tome with the specified name. The name is not case sensitive.
Public method | Reverse | (Overloaded) Reverses the order of the elements in the entire List<T>. (inherited from List<T>).
Public method | Sort | (Overloaded) Sorts the elements in the entire List<T> using the default comparer. (inherited from List<T>).
Public method | ToArray | Copies the elements of the List<T> to a new array. (inherited from List<T>).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<T>, if that number is less than a threshold value. (inherited from List<T>).
Public method | TrueForAll | Determines whether every element in the List<T> matches the conditions defined by the specified predicate. (inherited from List<T>).
Top
See Also

Reference

XtomesList Class


XtomesList.Add Method

XtomesList Class See Also

Adds an Xtome instanse to the Extended Data instance

Overload List
Name | Description
Add(`0) | Adds an object to the end of the List<T>. (System.Collections.Generic.List<T>).
Add(Xtome) | Adds an Xtome instanse to the Extended Data instance
See Also

Reference

XtomesList Class
XtomesList Members


XtomesList.AddRange Method

XtomesList Class See Also

Adds a collection of Xtome instances to the Extended Data instance

Overload List
Name | Description
AddRange(IEnumerable{`0}) | Adds the elements of the specified collection to the end of the List<T>. (System.Collections.Generic.List<T>).
AddRange(IEnumerable<Xtome>) | Adds a collection of Xtome instances to the Extended Data instance
See Also

Reference

XtomesList Class
XtomesList Members


XtomesList.FindTome Method

Retrieves a tome with a specified name. The name is not case sensitive.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function FindTome( _
   ByVal name As String _
) As Xtome
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Xtome FindTome(
   string name
)
This language is not supported or no code example is available.

Parameters

name

Type: string

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

XtomesList Class
XtomesList Members


XtomesList.RemoveTome Method

Removes a tome with the specified name. The name is not case sensitive.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub RemoveTome( _
   ByVal name As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void RemoveTome(
   string name
)
This language is not supported or no code example is available.

Parameters

name

Type: string

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

XtomesList Class
XtomesList Members


CADTreeView Class

Members See Also

Represents a form that shows structure of a CAD drawing as a tree.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADTreeView
    Inherits Form
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADTreeView : Form
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
CADImport.CADTreeView
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADTreeView Members


CADTreeView Members

CADTreeView Class Constructors Events Methods Properties See Also

Represents a form that shows structure of a CAD drawing as a tree.

The following tables list the members exposed by the CADTreeView type.

Constructors
 | Name | Description
Public constructor | CADTreeView | Initializes a new instance of the CADTreeView class.
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
 | ActiveForm | Gets the currently active form for this application. (inherited from Form).
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form).
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Form).
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form).
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form).
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | DrawTarget | Gets or sets a control for visualization.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Icon | Gets or sets the icon for the form. (inherited from Form).
Public property | Image | Gets or sets CADImage object for visualization.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form).
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form).
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | Location | (inherited from Form).
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form).
Public property | Margin | (inherited from Form).
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form).
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form).
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form).
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form).
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form).
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form).
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form).
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form).
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form).
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form).
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the size of the form. (inherited from Form).
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form).
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form).
Public property | TabStop | (inherited from Form).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form).
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowState | Gets or sets the form's window state. (inherited from Form).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form).
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Close | Closes the form. (inherited from Form).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Gets the size when autoscaling the form based on a specified font. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form).
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form).
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form).
Public method | Show | (Overloaded) Shows the form with the specified owner to the user. (inherited from Form).
Public method | ShowDialog | (Overloaded) Shows the form as a modal dialog box with the currently active window set as its owner. (inherited from Form).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Form).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form).
Public event | AutoSizeChanged | (inherited from Form).
Public event | AutoValidateChanged | (inherited from Form).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | Closed | Occurs when the form is closed. (inherited from Form).
Public event | Closing | Occurs when the form is closing. (inherited from Form).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | FormClosed | Occurs after the form is closed. (inherited from Form).
Public event | FormClosing | Occurs before the form is closed. (inherited from Form).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form).
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | (inherited from Form).
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form).
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form).
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form).
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form).
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form).
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form).
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form).
Public event | TabStopChanged | (inherited from Form).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

CADTreeView Class


CADTreeView Constructor

Initializes a new instance of the CADTreeView class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADTreeView()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADTreeView Class
CADTreeView Members


CADTreeView Properties

CADTreeView Class See Also

The following tables list the members exposed by the CADTreeView type.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
 | ActiveForm | Gets the currently active form for this application. (inherited from Form).
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form).
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Form).
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form).
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form).
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | DrawTarget | Gets or sets a control for visualization.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Icon | Gets or sets the icon for the form. (inherited from Form).
Public property | Image | Gets or sets CADImage object for visualization.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form).
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form).
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | Location | (inherited from Form).
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form).
Public property | Margin | (inherited from Form).
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form).
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form).
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form).
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form).
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form).
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form).
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form).
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form).
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form).
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form).
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the size of the form. (inherited from Form).
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form).
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form).
Public property | TabStop | (inherited from Form).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form).
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowState | Gets or sets the form's window state. (inherited from Form).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

CADTreeView Class


CADTreeView.DrawTarget Property

Gets or sets a control for visualization.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DrawTarget() As Control
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Control DrawTarget {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADTreeView Class
CADTreeView Members


CADTreeView.Image Property

Gets or sets CADImage object for visualization.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Image() As CADImage
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADImage Image {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADTreeView Class
CADTreeView Members


CADTreeView Methods

CADTreeView Class See Also

The following tables list the members exposed by the CADTreeView type.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form).
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Close | Closes the form. (inherited from Form).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Gets the size when autoscaling the form based on a specified font. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form).
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form).
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form).
Public method | Show | (Overloaded) Shows the form with the specified owner to the user. (inherited from Form).
Public method | ShowDialog | (Overloaded) Shows the form as a modal dialog box with the currently active window set as its owner. (inherited from Form).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Form).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top
See Also

Reference

CADTreeView Class


CADTreeView Events

CADTreeView Class See Also

The following tables list the members exposed by the CADTreeView type.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form).
Public event | AutoSizeChanged | (inherited from Form).
Public event | AutoValidateChanged | (inherited from Form).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | Closed | Occurs when the form is closed. (inherited from Form).
Public event | Closing | Occurs when the form is closing. (inherited from Form).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | FormClosed | Occurs after the form is closed. (inherited from Form).
Public event | FormClosing | Occurs before the form is closed. (inherited from Form).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form).
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | (inherited from Form).
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form).
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form).
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form).
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form).
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form).
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form).
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form).
Public event | TabStopChanged | (inherited from Form).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

CADTreeView Class


CAD2DPoint Structure

Members See Also

Represents a point in the 2D Cartesian coordinate system.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Structure CAD2DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public struct CAD2DPoint
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPoint Members


CAD2DPoint Members

CAD2DPoint Structure Constructors Methods Fields Properties See Also

Represents a point in the 2D Cartesian coordinate system.

The following tables list the members exposed by the CAD2DPoint type.

Constructors
 | Name | Description
Public constructor | CAD2DPoint | (Overloaded) Initializes a new CAD2DPoint with the specified coordinates.
Top
Properties
 | Name | Description
 | Empty | Represents a CAD2DPoint with zero coordinates.
Public property | IsZeroPoint | Gets a value indicating whether the specified CAD2DPoint has zero coordinates.
Public property | Item | An indexer for the CAD2DPoint structure.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether this CAD2DPoint instance and a specified object are equal.
 | GetAngle | Calculates the angle between two points.
Public method | GetHashCode | Overrides the GetHashCode method.
Public method | IsEqual | Determines whether this CAD2DPoint instance is equal to a specified.
 | Swap | Swaps two CAD2DPoints.
Top
Operators
Name | Description
Addition | Summarizes two CAD2DPoint objects.
Equality | Checks the equality of two CAD2DPoint objects.
Implicit Conversion (CAD2DPoint to DPoint) | Converts the CAD2DPoint to a DPoint.
Implicit Conversion (DPoint to CAD2DPoint) | Converts the DPoint to a CAD2DPoint.
Inequality | Checks if two CAD2DPoint objects are unequal.
Multiply | (Overloaded) Multiplies both coordinates of the CAD2DPoint with a double value.
Top
Fields
 | Name | Description
Public field | X | Represents the X-coordinate of this CAD2DPoint.
Public field | Y | Represents the Y-coordinate of this CAD2DPoint.
Top
See Also

Reference

CAD2DPoint Structure


CAD2DPoint Constructor

CAD2DPoint Structure See Also

Initializes a new CAD2DPoint with the specified coordinates.

Overload List
Name | Description
CAD2DPoint(DPoint) | Initializes a new CAD2DPoint using the the specified DPoint.
CAD2DPoint(double, double) | Initializes a new CAD2DPoint with the specified coordinates.
See Also

Reference

CAD2DPoint Structure
CAD2DPoint Members


CAD2DPoint Properties

CAD2DPoint Structure See Also

The following tables list the members exposed by the CAD2DPoint type.

Properties
 | Name | Description
 | Empty | Represents a CAD2DPoint with zero coordinates.
Public property | IsZeroPoint | Gets a value indicating whether the specified CAD2DPoint has zero coordinates.
Public property | Item | An indexer for the CAD2DPoint structure.
Top
See Also

Reference

CAD2DPoint Structure


CAD2DPoint.Empty Property

Represents a CAD2DPoint with zero coordinates.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Shared Property Empty() As CAD2DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static CAD2DPoint Empty {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPoint Structure
CAD2DPoint Members


CAD2DPoint.IsZeroPoint Property

Gets a value indicating whether the specified CAD2DPoint has zero coordinates.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property IsZeroPoint() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsZeroPoint {get;}
This language is not supported or no code example is available.

Property Value

true if this CAD2DPoint has zero coordinates; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPoint Structure
CAD2DPoint Members


CAD2DPoint.Item Property

An indexer for the CAD2DPoint structure.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Item( _
   ByVal id As Integer _
) As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double this[
   int id
] {get; set;}
This language is not supported or no code example is available.

Parameters

id

Type: int

An index of one of two CAD2DPoint's coordinates.

Property Value

X-coordinate if the input parameter equals 0. Y-coordinate if the input parameter equals 1.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPoint Structure
CAD2DPoint Members


CAD2DPoint Methods

CAD2DPoint Structure See Also

The following tables list the members exposed by the CAD2DPoint type.

Methods
 | Name | Description
Public method | Equals | Determines whether this CAD2DPoint instance and a specified object are equal.
 | GetAngle | Calculates the angle between two points.
Public method | GetHashCode | Overrides the GetHashCode method.
Public method | IsEqual | Determines whether this CAD2DPoint instance is equal to a specified.
 | Swap | Swaps two CAD2DPoints.
Top
Operators
Name | Description
Addition | Summarizes two CAD2DPoint objects.
Equality | Checks the equality of two CAD2DPoint objects.
Implicit Conversion (CAD2DPoint to DPoint) | Converts the CAD2DPoint to a DPoint.
Implicit Conversion (DPoint to CAD2DPoint) | Converts the DPoint to a CAD2DPoint.
Inequality | Checks if two CAD2DPoint objects are unequal.
Multiply | (Overloaded) Multiplies both coordinates of the CAD2DPoint with a double value.
Top
See Also

Reference

CAD2DPoint Structure


CAD2DPoint.Addition Operator

Summarizes two CAD2DPoint objects.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Operator +( _
   ByVal p1 As CAD2DPoint, _
   ByVal p2 As CAD2DPoint _
) As CAD2DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static CAD2DPoint operator +(
   CAD2DPoint p1,
   CAD2DPoint p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: CAD2DPoint

The first point

p2

Type: CAD2DPoint

The second point

Return Value

A resulting CAD2DPoint object
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPoint Structure
CAD2DPoint Members


CAD2DPoint.Equality Operator

Checks the equality of two CAD2DPoint objects.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Operator =( _
   ByVal p1 As CAD2DPoint, _
   ByVal p2 As CAD2DPoint _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool operator ==(
   CAD2DPoint p1,
   CAD2DPoint p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: CAD2DPoint

A CAD2DPoint object.

p2

Type: CAD2DPoint

A CAD2DPoint object.

Remarks

Two CAD2DPoints are equal if all two their coordinates are equal.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPoint Structure
CAD2DPoint Members


CAD2DPoint.Equals Method

Determines whether this CAD2DPoint instance and a specified object are equal.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool Equals(
   object obj
)
This language is not supported or no code example is available.

Parameters

obj

Type: object

An object to compare with this CAD2DPoint.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPoint Structure
CAD2DPoint Members


CAD2DPoint.GetAngle Method

Calculates the angle between two points.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function GetAngle( _
   ByVal p As CAD2DPoint, _
   ByVal a As CAD2DPoint _
) As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static float GetAngle(
   CAD2DPoint p,
   CAD2DPoint a
)
This language is not supported or no code example is available.

Parameters

p

Type: CAD2DPoint

First point CAD2DPoint

a

Type: CAD2DPoint

Second point CAD2DPoint

Return Value

float angle beetween two given points
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPoint Structure
CAD2DPoint Members


CAD2DPoint.GetHashCode Method

Overrides the GetHashCode method.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function GetHashCode() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override int GetHashCode()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPoint Structure
CAD2DPoint Members


CAD2DPoint.Implicit Conversion (CAD2DPoint to DPoint) Operator

Converts the CAD2DPoint to a DPoint.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Widening Operator CType( _
   ByVal pt As CAD2DPoint _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static implicit operator DPoint (
   CAD2DPoint pt
)
This language is not supported or no code example is available.

Parameters

pt

Type: CAD2DPoint

CAD2DPoint object to convert

Return Value

DPoint object
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPoint Structure
CAD2DPoint Members


CAD2DPoint.Implicit Conversion (DPoint to CAD2DPoint) Operator

Converts the DPoint to a CAD2DPoint.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Widening Operator CType( _
   ByVal pt As DPoint _
) As CAD2DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static implicit operator CAD2DPoint (
   DPoint pt
)
This language is not supported or no code example is available.

Parameters

pt

Type: DPoint

DPoint object to convert

Return Value

CAD2DPoint object
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPoint Structure
CAD2DPoint Members


CAD2DPoint.Inequality Operator

Checks if two CAD2DPoint objects are unequal.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Operator <>( _
   ByVal p1 As CAD2DPoint, _
   ByVal p2 As CAD2DPoint _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool operator !=(
   CAD2DPoint p1,
   CAD2DPoint p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: CAD2DPoint

A CAD2DPoint object.

p2

Type: CAD2DPoint

A CAD2DPoint object.

Remarks

Two CAD2DPoints are not equal if at least one of their two coordinates is not equal to the corresponding coordinate.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPoint Structure
CAD2DPoint Members


CAD2DPoint.IsEqual Method

Determines whether this CAD2DPoint instance is equal to a specified.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function IsEqual( _
   ByVal point As CAD2DPoint _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsEqual(
   CAD2DPoint point
)
This language is not supported or no code example is available.

Parameters

point

Type: CAD2DPoint

A 2D point to check the equality.

Return Value

true if the points are equal; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPoint Structure
CAD2DPoint Members


Multiply Operator

CAD2DPoint Structure See Also

Multiplies both coordinates of the CAD2DPoint with a double value.

Overload List
Name | Description
Multiply | Multiplies the CAD2DPoint with a matrix.
Multiply | Multiplies both coordinates of the CAD2DPoint with a double value.
See Also

Reference

CAD2DPoint Structure
CAD2DPoint Members


CAD2DPoint.Swap Method

Swaps two CAD2DPoints.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub Swap( _
   ByRef A As CAD2DPoint, _
   ByRef B As CAD2DPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void Swap(
   ref CAD2DPoint A,
   ref CAD2DPoint B
)
This language is not supported or no code example is available.

Parameters

A

Type: CAD2DPoint

A first CAD2DPoint to swap

B

Type: CAD2DPoint

A second CAD2DPoint to swap

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPoint Structure
CAD2DPoint Members


CAD2DPoint Fields

CAD2DPoint Structure See Also

The following tables list the members exposed by the CAD2DPoint type.

Fields
 | Name | Description
Public field | X | Represents the X-coordinate of this CAD2DPoint.
Public field | Y | Represents the Y-coordinate of this CAD2DPoint.
Top
See Also

Reference

CAD2DPoint Structure


X Field

Represents the X-coordinate of this CAD2DPoint.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public X As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double X
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPoint Structure
CAD2DPoint Members


Y Field

Represents the Y-coordinate of this CAD2DPoint.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Y As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Y
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPoint Structure
CAD2DPoint Members


DPoint Structure

Members See Also

Represents a point in the 3D coordinate system.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Structure DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public struct DPoint
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Members


DPoint Members

DPoint Structure Constructors Methods Fields Properties See Also

Represents a point in the 3D coordinate system.

The following tables list the members exposed by the DPoint type.

Constructors
 | Name | Description
Public constructor | DPoint | (Overloaded) Initializes a new DPoint by copying an existing one.
Top
Properties
 | Name | Description
 | Empty | Represents a DPoint that is a null reference (Nothing in Visual Basic).
Public property | Item | Gets or sets single coordinate of DPoint structure.
Public property | Length | Gets the length (magnitude) of the vector.
 | One | Represents a point with all three single coordinates. <remarks>Return point (1.0 , 1.0 , 1.0)</remarks>
Top
Methods
 | Name | Description
 | Cross | (Overloaded) Caclulate the cross (vector) product of two vectors
 | Distance | Returns distance between two points.
Public method | Equals | Determines if this DPoint object and a specified object are equal.
 | Extruded | Checks whether the point is extruded
 | GetAngle | Returns an angle between specified point and the X-axis of the Cartesian coordinate system that specified by another point.
Public method | GetHashCode | Returns the hash code for this instance.
Public method | GetObjectData | Sets the SerializationInfo with information about the serialized object.
 | Middle | Returns a middle point between two points.
 | Minor | For internal use.
Public method | Normalize | Scales the Vector3d to unit length.
Public method | Offset | (Overloaded) Returns a new point recieved by addition or subtraction of two specified points.
Public method | Reverse | Returns a new DPoint that is reversive to this one.
Public method | Rotate | (Overloaded) Rotates the current point in 2D coordinates system (Z coordinate does not changes)
Public method | Scale | (Overloaded) Scales the current Vector3d by the given amounts.
Public method | Swap | Swaps two DPoints.
Public method | XMat | (Overloaded) Returns a new DPoint that is a result of multiplying a this one and a CADMatrix.
Top
Operators
Name | Description
Addition | Summarizes two DPoint objects
Equality | Checks if two DPoints are equal.
Inequality | Checks if two DPoint objects are not equal.
Multiply | (Overloaded) Multiplies all three coordinates of the DPoint by a double value.
Subtraction | Subtracts two DPoint objects
Top
Fields
 | Name | Description
Public field | X | Represents the x-coordinate of this DPoint.
Public field | Y | Represents the y-coordinate of this DPoint.
Public field | Z | Represents the z-coordinate of this DPoint.
Top
See Also

Reference

DPoint Structure


DPoint Constructor

DPoint Structure See Also

Initializes a new DPoint by copying an existing one.

Overload List
Name | Description
DPoint(CAD2DPoint) |
DPoint(DPoint) | Initializes a new DPoint by copying an existing one.
DPoint(SerializationInfo, StreamingContext) |
DPoint(double, double, double) | Initializes a new DPoint with the specified coordinates.
See Also

Reference

DPoint Structure
DPoint Members


DPoint Properties

DPoint Structure See Also

The following tables list the members exposed by the DPoint type.

Properties
 | Name | Description
 | Empty | Represents a DPoint that is a null reference (Nothing in Visual Basic).
Public property | Item | Gets or sets single coordinate of DPoint structure.
Public property | Length | Gets the length (magnitude) of the vector.
 | One | Represents a point with all three single coordinates. <remarks>Return point (1.0 , 1.0 , 1.0)</remarks>
Top
See Also

Reference

DPoint Structure


DPoint.Empty Property

Represents a DPoint that is a null reference (Nothing in Visual Basic).

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Shared Property Empty() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static DPoint Empty {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


DPoint.Item Property

Gets or sets single coordinate of DPoint structure.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Item( _
   ByVal id As Integer _
) As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double this[
   int id
] {get; set;}
This language is not supported or no code example is available.

Parameters

id

Type: int

An index that specifies coordinate of DPoint.

Property Value

X-coordinate if an index equals 0. Y-coordinate if the index equals 1. Z-coordinate if the index equals 2.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


DPoint.Length Property

Gets the length (magnitude) of the vector.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Length() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Length {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


DPoint.One Property

Represents a point with all three single coordinates. <remarks>Return point (1.0 , 1.0 , 1.0)</remarks>

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Shared Property One() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static DPoint One {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


DPoint Methods

DPoint Structure See Also

The following tables list the members exposed by the DPoint type.

Methods
 | Name | Description
 | Cross | (Overloaded) Caclulate the cross (vector) product of two vectors
 | Distance | Returns distance between two points.
Public method | Equals | Determines if this DPoint object and a specified object are equal.
 | Extruded | Checks whether the point is extruded
 | GetAngle | Returns an angle between specified point and the X-axis of the Cartesian coordinate system that specified by another point.
Public method | GetHashCode | Returns the hash code for this instance.
Public method | GetObjectData | Sets the SerializationInfo with information about the serialized object.
 | Middle | Returns a middle point between two points.
 | Minor | For internal use.
Public method | Normalize | Scales the Vector3d to unit length.
Public method | Offset | (Overloaded) Returns a new point recieved by addition or subtraction of two specified points.
Public method | Reverse | Returns a new DPoint that is reversive to this one.
Public method | Rotate | (Overloaded) Rotates the current point in 2D coordinates system (Z coordinate does not changes)
Public method | Scale | (Overloaded) Scales the current Vector3d by the given amounts.
Public method | Swap | Swaps two DPoints.
Public method | XMat | (Overloaded) Returns a new DPoint that is a result of multiplying a this one and a CADMatrix.
Top
Operators
Name | Description
Addition | Summarizes two DPoint objects
Equality | Checks if two DPoints are equal.
Inequality | Checks if two DPoint objects are not equal.
Multiply | (Overloaded) Multiplies all three coordinates of the DPoint by a double value.
Subtraction | Subtracts two DPoint objects
Top
See Also

Reference

DPoint Structure


DPoint.Addition Operator

Summarizes two DPoint objects

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Operator +( _
   ByVal p1 As DPoint, _
   ByVal p2 As DPoint _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static DPoint operator +(
   DPoint p1,
   DPoint p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: DPoint

The first point

p2

Type: DPoint

The second point

Return Value

A new DPoint object
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


DPoint.Cross Method

DPoint Structure See Also

Caclulate the cross (vector) product of two vectors

Overload List
Name | Description
Cross(DPoint, DPoint) | Caclulate the cross (vector) product of two vectors
Cross(ref DPoint, ref DPoint, out DPoint) | Caclulate the cross (vector) product of two vectors
See Also

Reference

DPoint Structure
DPoint Members


DPoint.Distance Method

Returns distance between two points.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function Distance( _
   ByVal point1 As DPoint, _
   ByVal point2 As DPoint _
) As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static double Distance(
   DPoint point1,
   DPoint point2
)
This language is not supported or no code example is available.

Parameters

point1

Type: DPoint

The first point.

point2

Type: DPoint

The second point.

Return Value

double dinstance.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


DPoint.Equality Operator

Checks if two DPoints are equal.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Operator =( _
   ByVal p1 As DPoint, _
   ByVal p2 As DPoint _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool operator ==(
   DPoint p1,
   DPoint p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: DPoint

A DPoint object.

p2

Type: DPoint

A DPoint object.

Remarks

Two DPoints are equal if all coordinates of the first point are equal to the corresponding coordinates of the second.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


DPoint.Equals Method

Determines if this DPoint object and a specified object are equal.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool Equals(
   object obj
)
This language is not supported or no code example is available.

Parameters

obj

Type: object

An object to compare with this DPoint.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


DPoint.Extruded Method

Checks whether the point is extruded

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function Extruded( _
   ByVal P As DPoint _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool Extruded(
   DPoint P
)
This language is not supported or no code example is available.

Parameters

P

Type: DPoint

Checking point

Return Value

Returns true if point is extruded
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


DPoint.GetAngle Method

Returns an angle between specified point and the X-axis of the Cartesian coordinate system that specified by another point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function GetAngle( _
   ByVal p As DPoint, _
   ByVal a As DPoint _
) As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static float GetAngle(
   DPoint p,
   DPoint a
)
This language is not supported or no code example is available.

Parameters

p

Type: DPoint

Zero-point of Cartesian coordinate system.

a

Type: DPoint

Specified point

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


DPoint.GetHashCode Method

Returns the hash code for this instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function GetHashCode() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override int GetHashCode()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


DPoint.GetObjectData Method

Sets the SerializationInfo with information about the serialized object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
This language is not supported or no code example is available.

Parameters

info

Type: SerializationInfo

The SerializationInfo that holds the serialized object data.

context

Type: StreamingContext

The StreamingContext that contains contextual information about the source or destination.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


DPoint.Inequality Operator

Checks if two DPoint objects are not equal.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Operator <>( _
   ByVal p1 As DPoint, _
   ByVal p2 As DPoint _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool operator !=(
   DPoint p1,
   DPoint p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: DPoint

A DPoint object.

p2

Type: DPoint

A DPoint object.

Remarks

Two DPoints are not equal if at least one coordinate of the first point is not equal to the corresponding coordinate of the second.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


DPoint.Middle Method

Returns a middle point between two points.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function Middle( _
   ByVal p1 As DPoint, _
   ByVal p2 As DPoint _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static DPoint Middle(
   DPoint p1,
   DPoint p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: DPoint

First point

p2

Type: DPoint

Second point

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


DPoint.Minor Method

For internal use.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function Minor( _
   ByVal p As DPoint, _
   ByVal pb As DPoint, _
   ByVal mode As Byte _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static DPoint Minor(
   DPoint p,
   DPoint pb,
   byte mode
)
This language is not supported or no code example is available.

Parameters

p

Type: DPoint

pb

Type: DPoint

mode

Type: byte

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


Multiply Operator

DPoint Structure See Also

Multiplies all three coordinates of the DPoint by a double value.

Overload List
Name | Description
Multiply | Multiplies all three coordinates of the DPoint by a double value.
Multiply | Multiplies all three coordinates of the DPoint by a double value.
See Also

Reference

DPoint Structure
DPoint Members


DPoint.Normalize Method

Scales the Vector3d to unit length.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Normalize()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Normalize()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


DPoint.Offset Method

DPoint Structure See Also

Returns a new point recieved by addition or subtraction of two specified points.

Overload List
Name | Description
Offset(DPoint, bool) | Returns a new point recieved by addition or subtraction of two specified points.
Offset(DPoint, DPoint, bool) | Returns a new point recieved by addition or subtraction of two specified points.
See Also

Reference

DPoint Structure
DPoint Members


DPoint.Reverse Method

Returns a new DPoint that is reversive to this one.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Reverse() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Reverse()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


DPoint.Rotate Method

DPoint Structure See Also

Rotates the current point in 2D coordinates system (Z coordinate does not changes)

Overload List
Name | Description
Rotate(double) | Rotates the current point in 2D coordinates system (Z coordinate does not changes)
Rotate(DPoint, DPoint, bool, double) | Returns a new point recieved by addition or subtraction of the current point and the specified point.
Rotate(DPoint, double) | Executes 2D rotation of a point (Z coordinate does not changes)
See Also

Reference

DPoint Structure
DPoint Members


DPoint.Scale Method

DPoint Structure See Also

Scales the current Vector3d by the given amounts.

Overload List
Name | Description
Scale(DPoint) | Scales this instance by the given parameter.
Scale(double, double, double) | Scales the current Vector3d by the given amounts.
See Also

Reference

DPoint Structure
DPoint Members


DPoint.Subtraction Operator

Subtracts two DPoint objects

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Operator -( _
   ByVal p1 As DPoint, _
   ByVal p2 As DPoint _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static DPoint operator -(
   DPoint p1,
   DPoint p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: DPoint

The first point

p2

Type: DPoint

The second point

Return Value

New DPoint object coordinates
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


DPoint.Swap Method

Swaps two DPoints.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Swap( _
   ByRef B As DPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Swap(
   ref DPoint B
)
This language is not supported or no code example is available.

Parameters

B

Type: DPoint

A DPoint to swap with this DPoint.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


DPoint.XMat Method

DPoint Structure See Also

Returns a new DPoint that is a result of multiplying a this one and a CADMatrix.

Overload List
Name | Description
XMat(CADMatrix) | Returns a new DPoint that is a result of multiplying a this one and a CADMatrix.
XMat(DPoint, CADMatrix) | Returns a new DPoint that is a result of multiplying a DPoint and a CADMatrix.
See Also

Reference

DPoint Structure
DPoint Members


DPoint Fields

DPoint Structure See Also

The following tables list the members exposed by the DPoint type.

Fields
 | Name | Description
Public field | X | Represents the x-coordinate of this DPoint.
Public field | Y | Represents the y-coordinate of this DPoint.
Public field | Z | Represents the z-coordinate of this DPoint.
Top
See Also

Reference

DPoint Structure


X Field

Represents the x-coordinate of this DPoint.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public X As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double X
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


Y Field

Represents the y-coordinate of this DPoint.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Y As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Y
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


Z Field

Represents the z-coordinate of this DPoint.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Z As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Z
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


DRect Structure

Members See Also

Represents a parallelepiped.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Structure DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public struct DRect
This language is not supported or no code example is available.
Remarks

A DRect object is specified by two DPoints.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Members


DRect Members

DRect Structure Constructors Methods Fields Properties See Also

Represents a parallelepiped.

The following tables list the members exposed by the DRect type.

Constructors
 | Name | Description
Public constructor | DRect | (Overloaded) Initializes a new instance of the DRect class as a two-dimensional rectangle.
Top
Properties
 | Name | Description
 | BadRect | Indicates if this DRect object is a bad rect.
Public property | BottomRight | Gets or sets the second specified point of the DRect object.
Public property | Center | Gets a center point of this DRect.
 | Empty | Represents a DRect that is a null reference (Nothing in Visual Basic).
Public property | Height | Gets or sets a height of the DRect object.
Public property | TopLeft | Gets or sets the first specified point of the DRect object.
Public property | Width | Gets or sets a width of the DRect object.
Top
Methods
 | Name | Description
Public method | Contains | (Overloaded) Determines if the rectangular region is entirely contained within this DRect structure.
Public method | Equals | Determines whether this DRect instance and a specified object are equal.
Public method | Expand | (Overloaded) Expands the DRect object up to the specified point.
Public method | GetHashCode | Returns the hash code for this instance.
Public method | Inflate | Enlarges this DRect object by specified values.
Public method | Intersect | (Overloaded) Checks DRect and CADMatrix objects for intersection.
Public method | IsBadRect | (Overloaded) Checks if this DRect is not valid
Public method | Norm | Normalizes this DRect object.
Public method | Offset | Adds an offset at x, y and z axes to this DRect object.
Public method | Rotate | Rotates the current DRect object in 2D coordinates system (Z coordinate does not changes)
Public method | RotateAroundPoint | Rotates the current DRect object in 2D coordinates system (Z coordinate does not changes)
Public method | TransRectCorners | Rotates this DRect object by a specified CADMatrix.
Public method | Union | Expands a current DRect object to corner points of specified DRect object.
 | UnitRect | Returns a new DRect with unit sizes.
Top
Operators
Name | Description
Addition | Summarizes two DRect objects
Equality | (Overloaded) Checks if two DRect objects are equal.
Implicit Conversion (DRect to Rectangle) | Converts DRect to Rectangle
Implicit Conversion (DRect to RectangleF) | Converts DRect to RectangleF
Implicit Conversion (Rectangle to DRect) | Converts Rectangle to DRect
Implicit Conversion (RectangleF to DRect) | Converts RectangleF to DRect
Inequality | (Overloaded) Checks if two DRect objects are unequal.
Top
Fields
 | Name | Description
Public field | bottom | The Y-coordinate of the second point that specifies the DRect object.
Public field | left | The X-coordinate of the first point that specifies the DRect object.
Public field | right | The X-coordinate of the second point that specifies the DRect object.
Public field | top | The Y-coordinate of the first point that specifies the DRect object.
Public field | z1 | The Z-coordinate of the first point that specifies the DRect object.
Public field | z2 | The Z-coordinate of the second point that specifies the DRect object.
Top
See Also

Reference

DRect Structure


DRect Constructor

DRect Structure See Also

Initializes a new instance of the DRect class as a two-dimensional rectangle.

Overload List
Name | Description
DRect(double, double, double, double, double, double) | Initializes a new instance of the DRect class as a parallelepiped.
DRect(double, double, double, double) | Initializes a new instance of the DRect class as a two-dimensional rectangle.
See Also

Reference

DRect Structure
DRect Members


DRect Properties

DRect Structure See Also

The following tables list the members exposed by the DRect type.

Properties
 | Name | Description
 | BadRect | Indicates if this DRect object is a bad rect.
Public property | BottomRight | Gets or sets the second specified point of the DRect object.
Public property | Center | Gets a center point of this DRect.
 | Empty | Represents a DRect that is a null reference (Nothing in Visual Basic).
Public property | Height | Gets or sets a height of the DRect object.
Public property | TopLeft | Gets or sets the first specified point of the DRect object.
Public property | Width | Gets or sets a width of the DRect object.
Top
See Also

Reference

DRect Structure


DRect.BadRect Property

Indicates if this DRect object is a bad rect.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Shared Property BadRect() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static DRect BadRect {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.BottomRight Property

Gets or sets the second specified point of the DRect object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property BottomRight() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint BottomRight {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object representing the second specified point of the DRect object.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.Center Property

Gets a center point of this DRect.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Center() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Center {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.Empty Property

Represents a DRect that is a null reference (Nothing in Visual Basic).

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Shared Property Empty() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static DRect Empty {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.Height Property

Gets or sets a height of the DRect object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Height() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Height {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.TopLeft Property

Gets or sets the first specified point of the DRect object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TopLeft() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint TopLeft {get; set;}
This language is not supported or no code example is available.

Property Value

A DPoint object representing the first specified point of the DRect object.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.Width Property

Gets or sets a width of the DRect object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Width() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Width {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect Methods

DRect Structure See Also

The following tables list the members exposed by the DRect type.

Methods
 | Name | Description
Public method | Contains | (Overloaded) Determines if the rectangular region is entirely contained within this DRect structure.
Public method | Equals | Determines whether this DRect instance and a specified object are equal.
Public method | Expand | (Overloaded) Expands the DRect object up to the specified point.
Public method | GetHashCode | Returns the hash code for this instance.
Public method | Inflate | Enlarges this DRect object by specified values.
Public method | Intersect | (Overloaded) Checks DRect and CADMatrix objects for intersection.
Public method | IsBadRect | (Overloaded) Checks if this DRect is not valid
Public method | Norm | Normalizes this DRect object.
Public method | Offset | Adds an offset at x, y and z axes to this DRect object.
Public method | Rotate | Rotates the current DRect object in 2D coordinates system (Z coordinate does not changes)
Public method | RotateAroundPoint | Rotates the current DRect object in 2D coordinates system (Z coordinate does not changes)
Public method | TransRectCorners | Rotates this DRect object by a specified CADMatrix.
Public method | Union | Expands a current DRect object to corner points of specified DRect object.
 | UnitRect | Returns a new DRect with unit sizes.
Top
Operators
Name | Description
Addition | Summarizes two DRect objects
Equality | (Overloaded) Checks if two DRect objects are equal.
Implicit Conversion (DRect to Rectangle) | Converts DRect to Rectangle
Implicit Conversion (DRect to RectangleF) | Converts DRect to RectangleF
Implicit Conversion (Rectangle to DRect) | Converts Rectangle to DRect
Implicit Conversion (RectangleF to DRect) | Converts RectangleF to DRect
Inequality | (Overloaded) Checks if two DRect objects are unequal.
Top
See Also

Reference

DRect Structure


DRect.Addition Operator

Summarizes two DRect objects

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Operator +( _
   ByVal p1 As DRect, _
   ByVal p2 As DRect _
) As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static DRect operator +(
   DRect p1,
   DRect p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: DRect

First DRect object

p2

Type: DRect

Second DRect object

Return Value

Returns result of summation
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.Contains Method

DRect Structure See Also

Determines if the rectangular region is entirely contained within this DRect structure.

Overload List
Name | Description
Contains(DPoint) | Checks if DPoint object belongs to DRect object.
Contains(DRect) | Determines if the rectangular region is entirely contained within this DRect structure.
See Also

Reference

DRect Structure
DRect Members


Equality Operator

DRect Structure See Also

Checks if two DRect objects are equal.

Overload List
Name | Description
Equality | Checks if two DRect objects are equal.
Equality | Checks if DRect object and Rectangle object are equal.
Equality | Checks if Rectangle object and DRect object are equal.
See Also

Reference

DRect Structure
DRect Members


DRect.Equals Method

Determines whether this DRect instance and a specified object are equal.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool Equals(
   object obj
)
This language is not supported or no code example is available.

Parameters

obj

Type: object

An object to compare with this DRect instance.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.Expand Method

DRect Structure See Also

Expands the DRect object up to the specified point.

Overload List
Name | Description
Expand(DPoint) | Expands the DRect object up to the specified point.
Expand(Point) | Expands the DRect object up to the specified point.
Expand(PointF) |
See Also

Reference

DRect Structure
DRect Members


DRect.GetHashCode Method

Returns the hash code for this instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function GetHashCode() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override int GetHashCode()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.Implicit Conversion (DRect to Rectangle) Operator

Converts DRect to Rectangle

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Widening Operator CType( _
   ByVal r As DRect _
) As Rectangle
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static implicit operator Rectangle (
   DRect r
)
This language is not supported or no code example is available.

Parameters

r

Type: DRect

DRect value

Return Value

Rectangle value
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.Implicit Conversion (DRect to RectangleF) Operator

Converts DRect to RectangleF

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Widening Operator CType( _
   ByVal r As DRect _
) As RectangleF
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static implicit operator RectangleF (
   DRect r
)
This language is not supported or no code example is available.

Parameters

r

Type: DRect

DRect value

Return Value

RectangleF value
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.Implicit Conversion (Rectangle to DRect) Operator

Converts Rectangle to DRect

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Widening Operator CType( _
   ByVal r As Rectangle _
) As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static implicit operator DRect (
   Rectangle r
)
This language is not supported or no code example is available.

Parameters

r

Type: Rectangle

Rectangle value

Return Value

DRect value
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.Implicit Conversion (RectangleF to DRect) Operator

Converts RectangleF to DRect

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Widening Operator CType( _
   ByVal r As RectangleF _
) As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static implicit operator DRect (
   RectangleF r
)
This language is not supported or no code example is available.

Parameters

r

Type: RectangleF

RectangleF value

Return Value

DRect value
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


Inequality Operator

DRect Structure See Also

Checks if two DRect objects are unequal.

Overload List
Name | Description
Inequality | Checks if two DRect objects are unequal.
Inequality | Checks if DRect object and Rectangle object are unequal.
Inequality | Checks if Rectangle object and DRect object are unequal.
See Also

Reference

DRect Structure
DRect Members


DRect.Inflate Method

Enlarges this DRect object by specified values.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Inflate( _
   ByVal sizeX As Double, _
   ByVal sizeY As Double _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Inflate(
   double sizeX,
   double sizeY
)
This language is not supported or no code example is available.

Parameters

sizeX

Type: double

X size value

sizeY

Type: double

Y size value

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.Intersect Method

DRect Structure See Also

Checks DRect and CADMatrix objects for intersection.

Overload List
Name | Description
Intersect(DRect) | Checks DRect object for intersection
Intersect(DRect, CADMatrix) | Checks DRect and CADMatrix objects for intersection.
See Also

Reference

DRect Structure
DRect Members


DRect.IsBadRect Method

DRect Structure See Also

Checks if this DRect is not valid

Overload List
Name | Description
IsBadRect() | Checks if this DRect is not valid
IsBadRect(DRect) | Checks if specified DRect object is Bad rect.
See Also

Reference

DRect Structure
DRect Members


DRect.Norm Method

Normalizes this DRect object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Norm()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Norm()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.Offset Method

Adds an offset at x, y and z axes to this DRect object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Offset( _
   ByVal dx As Double, _
   ByVal dy As Double, _
   ByVal dz As Double _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Offset(
   double dx,
   double dy,
   double dz
)
This language is not supported or no code example is available.

Parameters

dx

Type: double

dy

Type: double

dz

Type: double

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.Rotate Method

Rotates the current DRect object in 2D coordinates system (Z coordinate does not changes)

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Rotate( _
   ByVal angle As Double _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Rotate(
   double angle
)
This language is not supported or no code example is available.

Parameters

angle

Type: double

Rotation angle

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.RotateAroundPoint Method

Rotates the current DRect object in 2D coordinates system (Z coordinate does not changes)

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub RotateAroundPoint( _
   ByVal center As DPoint, _
   ByVal angle As Double _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void RotateAroundPoint(
   DPoint center,
   double angle
)
This language is not supported or no code example is available.

Parameters

center

Type: DPoint

Central point for rotation

angle

Type: double

Rotation angle

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.TransRectCorners Method

Rotates this DRect object by a specified CADMatrix.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub TransRectCorners( _
   ByVal matrix As CADMatrix _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void TransRectCorners(
   CADMatrix matrix
)
This language is not supported or no code example is available.

Parameters

matrix

Type: CADMatrix

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.Union Method

Expands a current DRect object to corner points of specified DRect object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Union( _
   ByVal src As DRect _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Union(
   DRect src
)
This language is not supported or no code example is available.

Parameters

src

Type: DRect

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.UnitRect Method

Returns a new DRect with unit sizes.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function UnitRect() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static DRect UnitRect()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect Fields

DRect Structure See Also

The following tables list the members exposed by the DRect type.

Fields
 | Name | Description
Public field | bottom | The Y-coordinate of the second point that specifies the DRect object.
Public field | left | The X-coordinate of the first point that specifies the DRect object.
Public field | right | The X-coordinate of the second point that specifies the DRect object.
Public field | top | The Y-coordinate of the first point that specifies the DRect object.
Public field | z1 | The Z-coordinate of the first point that specifies the DRect object.
Public field | z2 | The Z-coordinate of the second point that specifies the DRect object.
Top
See Also

Reference

DRect Structure


bottom Field

The Y-coordinate of the second point that specifies the DRect object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public bottom As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double bottom
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


left Field

The X-coordinate of the first point that specifies the DRect object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public left As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double left
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


right Field

The X-coordinate of the second point that specifies the DRect object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public right As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double right
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


top Field

The Y-coordinate of the first point that specifies the DRect object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public top As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double top
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


z1 Field

The Z-coordinate of the first point that specifies the DRect object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public z1 As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double z1
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


z2 Field

The Z-coordinate of the second point that specifies the DRect object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public z2 As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double z2
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DimStyleStruct Structure

Members See Also

Defines structure that contains some dimension variables.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Structure DimStyleStruct
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public struct DimStyleStruct
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Members


DimStyleStruct Members

DimStyleStruct Structure Fields See Also

Defines structure that contains some dimension variables.

The following tables list the members exposed by the DimStyleStruct type.

Fields
 | Name | Description
Public field | APost | Alternate dimensioning suffix
Public field | Alt | Alternate unit dimensioning performed if nonzero.
Public field | AltF | Alternate unit scale factor
Public field | Asz | Dimensioning arrow size
Public field | Blk | Arrow block name
Public field | Blk1 | First arrow block name
Public field | Blk2 | Second arrow block name
Public field | Cen | Size of center mark/lines
Public field | ClrD | Dimension line color
Public field | ClrE | Dimension extension line color
Public field | ClrT | Dimension text color
Public field | Dec | Number of decimal places for the tolerance values of a primary units dimension
Public field | Exe | Extension line extension
Public field | Exo | Extension line offset
Public field | Gap | Dimension line gap
Public field | LFac | Linear measurements scale factor
Public field | LrBlk | Arrow block name for leaders
Public field | LwD | Dimension line lineweight
Public field | LwE | Extension line lineweight
Public field | Post | General dimensioning suffix
Public field | SD1 | Suppression of first extension line
Public field | SD2 | Suppression of second extension line
Public field | SE1 | First extension line suppressed if nonzero
Public field | SE2 | Second extension line suppressed if nonzero
Public field | Scale | Overall dimensioning scale factor
Public field | Tad | Text above dimension line if nonzero
Public field | Tih | Text inside horizontal if nonzero
Public field | Tix | Force text inside extensions if nonzero
Public field | Toh | Text outside horizontal if nonzero
Public field | Txt | Dimensioning text height
Top
See Also

Reference

DimStyleStruct Structure


DimStyleStruct Fields

DimStyleStruct Structure See Also

The following tables list the members exposed by the DimStyleStruct type.

Fields
 | Name | Description
Public field | APost | Alternate dimensioning suffix
Public field | Alt | Alternate unit dimensioning performed if nonzero.
Public field | AltF | Alternate unit scale factor
Public field | Asz | Dimensioning arrow size
Public field | Blk | Arrow block name
Public field | Blk1 | First arrow block name
Public field | Blk2 | Second arrow block name
Public field | Cen | Size of center mark/lines
Public field | ClrD | Dimension line color
Public field | ClrE | Dimension extension line color
Public field | ClrT | Dimension text color
Public field | Dec | Number of decimal places for the tolerance values of a primary units dimension
Public field | Exe | Extension line extension
Public field | Exo | Extension line offset
Public field | Gap | Dimension line gap
Public field | LFac | Linear measurements scale factor
Public field | LrBlk | Arrow block name for leaders
Public field | LwD | Dimension line lineweight
Public field | LwE | Extension line lineweight
Public field | Post | General dimensioning suffix
Public field | SD1 | Suppression of first extension line
Public field | SD2 | Suppression of second extension line
Public field | SE1 | First extension line suppressed if nonzero
Public field | SE2 | Second extension line suppressed if nonzero
Public field | Scale | Overall dimensioning scale factor
Public field | Tad | Text above dimension line if nonzero
Public field | Tih | Text inside horizontal if nonzero
Public field | Tix | Force text inside extensions if nonzero
Public field | Toh | Text outside horizontal if nonzero
Public field | Txt | Dimensioning text height
Top
See Also

Reference

DimStyleStruct Structure


APost Field

Alternate dimensioning suffix

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public APost As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string APost
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


Alt Field

Alternate unit dimensioning performed if nonzero.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Alt As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Alt
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


AltF Field

Alternate unit scale factor

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public AltF As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double AltF
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


Asz Field

Dimensioning arrow size

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Asz As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Asz
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


Blk Field

Arrow block name

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Blk As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte Blk
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


Blk1 Field

First arrow block name

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Blk1 As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte Blk1
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


Blk2 Field

Second arrow block name

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Blk2 As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte Blk2
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


Cen Field

Size of center mark/lines

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Cen As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Cen
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


ClrD Field

Dimension line color

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ClrD As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Color ClrD
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


ClrE Field

Dimension extension line color

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ClrE As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Color ClrE
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


ClrT Field

Dimension text color

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ClrT As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Color ClrT
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


Dec Field

Number of decimal places for the tolerance values of a primary units dimension

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Dec As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Dec
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


Exe Field

Extension line extension

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Exe As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Exe
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


Exo Field

Extension line offset

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Exo As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Exo
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


Gap Field

Dimension line gap

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Gap As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Gap
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


LFac Field

Linear measurements scale factor

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public LFac As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double LFac
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


LrBlk Field

Arrow block name for leaders

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public LrBlk As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte LrBlk
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


LwD Field

Dimension line lineweight

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public LwD As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double LwD
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


LwE Field

Extension line lineweight

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public LwE As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double LwE
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


Post Field

General dimensioning suffix

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Post As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Post
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


SD1 Field

Suppression of first extension line

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public SD1 As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool SD1
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


SD2 Field

Suppression of second extension line

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public SD2 As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool SD2
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


SE1 Field

First extension line suppressed if nonzero

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public SE1 As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool SE1
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


SE2 Field

Second extension line suppressed if nonzero

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public SE2 As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool SE2
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


Scale Field

Overall dimensioning scale factor

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Scale As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Scale
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


Tad Field

Text above dimension line if nonzero

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Tad As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Tad
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


Tih Field

Text inside horizontal if nonzero

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Tih As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Tih
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


Tix Field

Force text inside extensions if nonzero

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Tix As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Tix
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


Toh Field

Text outside horizontal if nonzero

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Toh As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Toh
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


Txt Field

Dimensioning text height

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Txt As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Txt
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimStyleStruct Structure
DimStyleStruct Members


FPoint Structure

Members See Also

Represents a point in the 3D coordinate system.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Structure FPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public struct FPoint
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FPoint Members


FPoint Members

FPoint Structure Constructors Methods Fields Properties See Also

Represents a point in the 3D coordinate system.

The following tables list the members exposed by the FPoint type.

Constructors
 | Name | Description
Public constructor | FPoint | Initializes a new FPoint with the specified coordinates.
Top
Properties
 | Name | Description
 | Empty | Represents a FPoint that is a null reference (Nothing in Visual Basic).
Public property | Item | Gets or sets a single coordinate of FPoint structure.
Top
Methods
 | Name | Description
 | Distance | Returns distance between two points.
Public method | Equals | Determines if this FPoint object and a specified object are equal.
 | GetAngle | Returns an angle between specified point and the X-axis of the Cartesian coordinate system that specified by another point.
Public method | GetHashCode | Returns the hash code for this instance.
Public method | Swap | Swaps two FPoints.
Top
Operators
Name | Description
Equality | Checks if two FPoints are equal.
Implicit Conversion (FPoint to DPoint) | Converts FPoint into DPoint.
Inequality | Checks if two FPoint objects are not equal.
Top
Fields
 | Name | Description
Public field | X | Represents the x-coordinate of this FPoint.
Public field | Y | Represents the y-coordinate of this FPoint.
Public field | Z | Represents the z-coordinate of this FPoint.
Top
See Also

Reference

FPoint Structure


FPoint Constructor

Initializes a new FPoint with the specified coordinates.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Z As Single _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public FPoint(
   float X,
   float Y,
   float Z
)
This language is not supported or no code example is available.

Parameters

X

Type: float

The X-coordinate of the FPoint object.

Y

Type: float

The Y-coordinate of the FPoint object.

Z

Type: float

The Z-coordinate of the FPoint object.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FPoint Structure
FPoint Members


FPoint Properties

FPoint Structure See Also

The following tables list the members exposed by the FPoint type.

Properties
 | Name | Description
 | Empty | Represents a FPoint that is a null reference (Nothing in Visual Basic).
Public property | Item | Gets or sets a single coordinate of FPoint structure.
Top
See Also

Reference

FPoint Structure


FPoint.Empty Property

Represents a FPoint that is a null reference (Nothing in Visual Basic).

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Shared Property Empty() As FPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static FPoint Empty {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FPoint Structure
FPoint Members


FPoint.Item Property

Gets or sets a single coordinate of FPoint structure.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Item( _
   ByVal id As Integer _
) As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float this[
   int id
] {get; set;}
This language is not supported or no code example is available.

Parameters

id

Type: int

An index that specifies coordinate of FPoint.

Property Value

X-coordinate if the input parameter equals 0. Y-coordinate if the input parameter equals 1. Z-coordinate if the input parameter equals 2.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FPoint Structure
FPoint Members


FPoint Methods

FPoint Structure See Also

The following tables list the members exposed by the FPoint type.

Methods
 | Name | Description
 | Distance | Returns distance between two points.
Public method | Equals | Determines if this FPoint object and a specified object are equal.
 | GetAngle | Returns an angle between specified point and the X-axis of the Cartesian coordinate system that specified by another point.
Public method | GetHashCode | Returns the hash code for this instance.
Public method | Swap | Swaps two FPoints.
Top
Operators
Name | Description
Equality | Checks if two FPoints are equal.
Implicit Conversion (FPoint to DPoint) | Converts FPoint into DPoint.
Inequality | Checks if two FPoint objects are not equal.
Top
See Also

Reference

FPoint Structure


FPoint.Distance Method

Returns distance between two points.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function Distance( _
   ByVal point1 As PointF, _
   ByVal point2 As PointF _
) As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static float Distance(
   PointF point1,
   PointF point2
)
This language is not supported or no code example is available.

Parameters

point1

Type: PointF

The first point.

point2

Type: PointF

The second point.

Return Value

double dinstance.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FPoint Structure
FPoint Members


FPoint.Equality Operator

Checks if two FPoints are equal.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Operator =( _
   ByVal p1 As FPoint, _
   ByVal p2 As FPoint _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool operator ==(
   FPoint p1,
   FPoint p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: FPoint

A FPoint object.

p2

Type: FPoint

A FPoint object.

Remarks

Two FPoints are equal if all coordinates of the first point are equal to the corresponding coordinates of the second.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FPoint Structure
FPoint Members


FPoint.Equals Method

Determines if this FPoint object and a specified object are equal.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool Equals(
   object obj
)
This language is not supported or no code example is available.

Parameters

obj

Type: object

An object to compare with this FPoint.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FPoint Structure
FPoint Members


FPoint.GetAngle Method

Returns an angle between specified point and the X-axis of the Cartesian coordinate system that specified by another point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function GetAngle( _
   ByVal p As PointF, _
   ByVal a As PointF _
) As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static float GetAngle(
   PointF p,
   PointF a
)
This language is not supported or no code example is available.

Parameters

p

Type: PointF

Zero-point of Cartesian coordinate system.

a

Type: PointF

Specified point

Remarks

The Z-coordinates of the both FPoints will be ignored

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FPoint Structure
FPoint Members


FPoint.GetHashCode Method

Returns the hash code for this instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function GetHashCode() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override int GetHashCode()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FPoint Structure
FPoint Members


FPoint.Implicit Conversion (FPoint to DPoint) Operator

Converts FPoint into DPoint.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Widening Operator CType( _
   ByVal value As FPoint _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static implicit operator DPoint (
   FPoint value
)
This language is not supported or no code example is available.

Parameters

value

Type: FPoint

A FPoint object to convert.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FPoint Structure
FPoint Members


FPoint.Inequality Operator

Checks if two FPoint objects are not equal.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Operator <>( _
   ByVal p1 As FPoint, _
   ByVal p2 As FPoint _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool operator !=(
   FPoint p1,
   FPoint p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: FPoint

A FPoint object.

p2

Type: FPoint

A FPoint object.

Remarks

Two FPoints are not equal if at least one coordinate of the first point is not equal to the corresponding coordinate of the second.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FPoint Structure
FPoint Members


FPoint.Swap Method

Swaps two FPoints.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Swap( _
   ByRef B As FPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Swap(
   ref FPoint B
)
This language is not supported or no code example is available.

Parameters

B

Type: FPoint

A FPoint to swap with this FPoint.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FPoint Structure
FPoint Members


FPoint Fields

FPoint Structure See Also

The following tables list the members exposed by the FPoint type.

Fields
 | Name | Description
Public field | X | Represents the x-coordinate of this FPoint.
Public field | Y | Represents the y-coordinate of this FPoint.
Public field | Z | Represents the z-coordinate of this FPoint.
Top
See Also

Reference

FPoint Structure


X Field

Represents the x-coordinate of this FPoint.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public X As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float X
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FPoint Structure
FPoint Members


Y Field

Represents the y-coordinate of this FPoint.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Y As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float Y
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FPoint Structure
FPoint Members


Z Field

Represents the z-coordinate of this FPoint.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Z As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float Z
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FPoint Structure
FPoint Members


RECT Structure

Members See Also

Specifies the dimensions, in logical coordinates, of a rectangle that is used for clipping, opaquing, or both.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Structure RECT
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public struct RECT
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RECT Members


RECT Members

RECT Structure Constructors Methods Fields See Also

Specifies the dimensions, in logical coordinates, of a rectangle that is used for clipping, opaquing, or both.

The following tables list the members exposed by the RECT type.

Constructors
 | Name | Description
Public constructor | RECT | Initializes fields of the RECT structure by the specified values.
Top
Methods
Name | Description
FromXYWH | Creates a new RECT structure and initializes its fields by the specified values.
Top
Fields
 | Name | Description
Public field | bottom | Specifies the y-coordinate of the lower-right corner of the rectangle.
Public field | left | Specifies the x-coordinate of the upper-left corner of the rectangle.
Public field | right | Specifies the x-coordinate of the lower-right corner of the rectangle.
Public field | top | Specifies the y-coordinate of the upper-left corner of the rectangle.
Top
See Also

Reference

RECT Structure


RECT Constructor

Initializes fields of the RECT structure by the specified values.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal left1 As Integer, _
   ByVal top1 As Integer, _
   ByVal right1 As Integer, _
   ByVal bottom1 As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public RECT(
   int left1,
   int top1,
   int right1,
   int bottom1
)
This language is not supported or no code example is available.

Parameters

left1

Type: int

top1

Type: int

right1

Type: int

bottom1

Type: int

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RECT Structure
RECT Members


RECT Methods

RECT Structure See Also

The following tables list the members exposed by the RECT type.

Methods
Name | Description
FromXYWH | Creates a new RECT structure and initializes its fields by the specified values.
Top
See Also

Reference

RECT Structure


RECT.FromXYWH Method

Creates a new RECT structure and initializes its fields by the specified values.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function FromXYWH( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer _
) As RECT
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static RECT FromXYWH(
   int x,
   int y,
   int width,
   int height
)
This language is not supported or no code example is available.

Parameters

x

Type: int

y

Type: int

width

Type: int

height

Type: int

Return Value

A new RECT structure.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RECT Structure
RECT Members


RECT Fields

RECT Structure See Also

The following tables list the members exposed by the RECT type.

Fields
 | Name | Description
Public field | bottom | Specifies the y-coordinate of the lower-right corner of the rectangle.
Public field | left | Specifies the x-coordinate of the upper-left corner of the rectangle.
Public field | right | Specifies the x-coordinate of the lower-right corner of the rectangle.
Public field | top | Specifies the y-coordinate of the upper-left corner of the rectangle.
Top
See Also

Reference

RECT Structure


bottom Field

Specifies the y-coordinate of the lower-right corner of the rectangle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public bottom As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int bottom
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RECT Structure
RECT Members


left Field

Specifies the x-coordinate of the upper-left corner of the rectangle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public left As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int left
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RECT Structure
RECT Members


right Field

Specifies the x-coordinate of the lower-right corner of the rectangle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public right As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int right
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RECT Structure
RECT Members


top Field

Specifies the y-coordinate of the upper-left corner of the rectangle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public top As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int top
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RECT Structure
RECT Members


Rect2D Structure

Members See Also

Represent a rectangle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Structure Rect2D
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public struct Rect2D
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect2D Members


Rect2D Members

Rect2D Structure Constructors Methods Fields Properties See Also

Represent a rectangle.

The following tables list the members exposed by the Rect2D type.

Constructors
 | Name | Description
Public constructor | Rect2D | Initializes a new instance of the Rect2D class.
Top
Properties
 | Name | Description
 | BadRect | Represents a bad(not valid) rectangle.
Public property | BottomRight | Gets or sets the down-right corner of the Rect2D object as the CAD2DPoint object
 | Empty | Represents The Rect2D that is a null reference (Nothing in Visual Basic).
Public property | Height | Gets or sets a height of the Rect2D object.
Public property | TopLeft | Gets or sets the top-left corner of the Rect2D object as the CAD2DPoint object
Public property | Width | Gets or sets a width of the Rect2D object.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether this Rect2D instance and the specified object are equal.
Public method | Expand | Expands a rectangle to the specified point.
Public method | GetHashCode | Returns the hash code for the instance.
 | IsBadRect | Checks whether or not the specified rectangle is valid.
Public method | Norm | Normalizes this Rect2D object.
Public method | Offset | Adds an offset at X- and Y-axis directions to this Rect2D object.
Public method | TransRectCorners | Rotates this Rect2D object by a specified CADMatrix.
Top
Operators
Name | Description
Equality | Checks if two Rect2D objects are equal.
Implicit Conversion (DRect to Rect2D) | Converts DRect to Rect2D
Implicit Conversion (Rect2D to DRect) | Converts Rect2D to DRect
Implicit Conversion (Rect2D to Rectangle) | Converts Rect2D to Rectangle
Implicit Conversion (RectangleF to Rect2D) | Converts RectangleF to Rect2D
Inequality | Checks if two Rect2D objects are unequal.
Top
Fields
 | Name | Description
Public field | bottom | The bottom border of the Rect2D object
Public field | left | The left border of the Rect2D object
Public field | right | The right border of the Rect2D object
Public field | top | The top border of the Rect2D object
Top
See Also

Reference

Rect2D Structure


Rect2D Constructor

Initializes a new instance of the Rect2D class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal right As Double, _
   ByVal bottom As Double _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Rect2D(
   double left,
   double top,
   double right,
   double bottom
)
This language is not supported or no code example is available.

Parameters

left

Type: double

Left border of Rect2D object

top

Type: double

Top border of Rect2D object

right

Type: double

Right border of Rect2D object

bottom

Type: double

Bottom border of Rect2D object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect2D Structure
Rect2D Members


Rect2D Properties

Rect2D Structure See Also

The following tables list the members exposed by the Rect2D type.

Properties
 | Name | Description
 | BadRect | Represents a bad(not valid) rectangle.
Public property | BottomRight | Gets or sets the down-right corner of the Rect2D object as the CAD2DPoint object
 | Empty | Represents The Rect2D that is a null reference (Nothing in Visual Basic).
Public property | Height | Gets or sets a height of the Rect2D object.
Public property | TopLeft | Gets or sets the top-left corner of the Rect2D object as the CAD2DPoint object
Public property | Width | Gets or sets a width of the Rect2D object.
Top
See Also

Reference

Rect2D Structure


Rect2D.BadRect Property

Represents a bad(not valid) rectangle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Shared Property BadRect() As Rect2D
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static Rect2D BadRect {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect2D Structure
Rect2D Members


Rect2D.BottomRight Property

Gets or sets the down-right corner of the Rect2D object as the CAD2DPoint object

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property BottomRight() As CAD2DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CAD2DPoint BottomRight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect2D Structure
Rect2D Members


Rect2D.Empty Property

Represents The Rect2D that is a null reference (Nothing in Visual Basic).

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Shared Property Empty() As Rect2D
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static Rect2D Empty {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect2D Structure
Rect2D Members


Rect2D.Height Property

Gets or sets a height of the Rect2D object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Height() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Height {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect2D Structure
Rect2D Members


Rect2D.TopLeft Property

Gets or sets the top-left corner of the Rect2D object as the CAD2DPoint object

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TopLeft() As CAD2DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CAD2DPoint TopLeft {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect2D Structure
Rect2D Members


Rect2D.Width Property

Gets or sets a width of the Rect2D object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Width() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Width {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect2D Structure
Rect2D Members


Rect2D Methods

Rect2D Structure See Also

The following tables list the members exposed by the Rect2D type.

Methods
 | Name | Description
Public method | Equals | Determines whether this Rect2D instance and the specified object are equal.
Public method | Expand | Expands a rectangle to the specified point.
Public method | GetHashCode | Returns the hash code for the instance.
 | IsBadRect | Checks whether or not the specified rectangle is valid.
Public method | Norm | Normalizes this Rect2D object.
Public method | Offset | Adds an offset at X- and Y-axis directions to this Rect2D object.
Public method | TransRectCorners | Rotates this Rect2D object by a specified CADMatrix.
Top
Operators
Name | Description
Equality | Checks if two Rect2D objects are equal.
Implicit Conversion (DRect to Rect2D) | Converts DRect to Rect2D
Implicit Conversion (Rect2D to DRect) | Converts Rect2D to DRect
Implicit Conversion (Rect2D to Rectangle) | Converts Rect2D to Rectangle
Implicit Conversion (RectangleF to Rect2D) | Converts RectangleF to Rect2D
Inequality | Checks if two Rect2D objects are unequal.
Top
See Also

Reference

Rect2D Structure


Rect2D.Equality Operator

Checks if two Rect2D objects are equal.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Operator =( _
   ByVal p1 As Rect2D, _
   ByVal p2 As Rect2D _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool operator ==(
   Rect2D p1,
   Rect2D p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: Rect2D

A Rect2D object.

p2

Type: Rect2D

A Rect2D object.

Remarks

Two Rect2D objects are equal if all four coordinates of the first rectangle are equal to corresponding coordinates of the second.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect2D Structure
Rect2D Members


Rect2D.Equals Method

Determines whether this Rect2D instance and the specified object are equal.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool Equals(
   object obj
)
This language is not supported or no code example is available.

Parameters

obj

Type: object

An object to compare with this Rect2D instance.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect2D Structure
Rect2D Members


Rect2D.Expand Method

Expands a rectangle to the specified point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Expand( _
   ByVal p As CAD2DPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Expand(
   CAD2DPoint p
)
This language is not supported or no code example is available.

Parameters

p

Type: CAD2DPoint

A point object.

Remarks

If p is inside of rectangle then expand doesn't take effect.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect2D Structure
Rect2D Members


Rect2D.GetHashCode Method

Returns the hash code for the instance.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function GetHashCode() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override int GetHashCode()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect2D Structure
Rect2D Members


Rect2D.Implicit Conversion (DRect to Rect2D) Operator

Converts DRect to Rect2D

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Widening Operator CType( _
   ByVal r As DRect _
) As Rect2D
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static implicit operator Rect2D (
   DRect r
)
This language is not supported or no code example is available.

Parameters

r

Type: DRect

DRect value

Return Value

Rect2D value
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect2D Structure
Rect2D Members


Rect2D.Implicit Conversion (Rect2D to DRect) Operator

Converts Rect2D to DRect

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Widening Operator CType( _
   ByVal r As Rect2D _
) As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static implicit operator DRect (
   Rect2D r
)
This language is not supported or no code example is available.

Parameters

r

Type: Rect2D

Rect2D value

Return Value

DRect value
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect2D Structure
Rect2D Members


Rect2D.Implicit Conversion (Rect2D to Rectangle) Operator

Converts Rect2D to Rectangle

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Widening Operator CType( _
   ByVal r As Rect2D _
) As Rectangle
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static implicit operator Rectangle (
   Rect2D r
)
This language is not supported or no code example is available.

Parameters

r

Type: Rect2D

Rect2D value

Return Value

Rectagle value
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect2D Structure
Rect2D Members


Rect2D.Implicit Conversion (RectangleF to Rect2D) Operator

Converts RectangleF to Rect2D

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Widening Operator CType( _
   ByVal r As RectangleF _
) As Rect2D
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static implicit operator Rect2D (
   RectangleF r
)
This language is not supported or no code example is available.

Parameters

r

Type: RectangleF

RectangleF value

Return Value

Rect2D value
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect2D Structure
Rect2D Members


Rect2D.Inequality Operator

Checks if two Rect2D objects are unequal.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Operator <>( _
   ByVal p1 As Rect2D, _
   ByVal p2 As Rect2D _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool operator !=(
   Rect2D p1,
   Rect2D p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: Rect2D

A Rect2D object.

p2

Type: Rect2D

A Rect2D object.

Remarks

Two Rect2D objects are not equal if at least one coordinate of the first rectangle is not equal to the corresponding coordinate of the second rectangle.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect2D Structure
Rect2D Members


Rect2D.IsBadRect Method

Checks whether or not the specified rectangle is valid.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function IsBadRect( _
   ByVal rect As Rect2D _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool IsBadRect(
   Rect2D rect
)
This language is not supported or no code example is available.

Parameters

rect

Type: Rect2D

A Rect2D object.

Return Value

true if
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect2D Structure
Rect2D Members


Rect2D.Norm Method

Normalizes this Rect2D object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Norm()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Norm()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect2D Structure
Rect2D Members


Rect2D.Offset Method

Adds an offset at X- and Y-axis directions to this Rect2D object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Offset( _
   ByVal dx As Double, _
   ByVal dy As Double _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Offset(
   double dx,
   double dy
)
This language is not supported or no code example is available.

Parameters

dx

Type: double

dy

Type: double

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect2D Structure
Rect2D Members


Rect2D.TransRectCorners Method

Rotates this Rect2D object by a specified CADMatrix.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub TransRectCorners( _
   ByVal matrix As CADMatrix _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void TransRectCorners(
   CADMatrix matrix
)
This language is not supported or no code example is available.

Parameters

matrix

Type: CADMatrix

A CADMatrix object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect2D Structure
Rect2D Members


Rect2D Fields

Rect2D Structure See Also

The following tables list the members exposed by the Rect2D type.

Fields
 | Name | Description
Public field | bottom | The bottom border of the Rect2D object
Public field | left | The left border of the Rect2D object
Public field | right | The right border of the Rect2D object
Public field | top | The top border of the Rect2D object
Top
See Also

Reference

Rect2D Structure


bottom Field

The bottom border of the Rect2D object

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public bottom As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double bottom
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect2D Structure
Rect2D Members


left Field

The left border of the Rect2D object

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public left As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double left
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect2D Structure
Rect2D Members


right Field

The right border of the Rect2D object

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public right As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double right
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect2D Structure
Rect2D Members


top Field

The top border of the Rect2D object

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public top As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double top
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect2D Structure
Rect2D Members


CADEntityProc Delegate

Represents methods for entities.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Delegate Function CADEntityProc( _
   ByVal Ent As CADEntity _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public delegate bool CADEntityProc(
   CADEntity Ent
)
This language is not supported or no code example is available.

Parameters

Ent

Type: CADEntity

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference


CADXRefResolver Delegate

Represents methods for resolve unknown xrefs.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Delegate Sub CADXRefResolver( _
   ByRef xrefPath As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public delegate void CADXRefResolver(
   ref string xrefPath
)
This language is not supported or no code example is available.

Parameters

xrefPath

Type: string

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference


EndDraw Delegate

Represents methods related to end of visualization.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Delegate Sub EndDraw( _
   ByVal rect As RectangleF, _
   ByVal graph As Graphics _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public delegate void EndDraw(
   RectangleF rect,
   Graphics graph
)
This language is not supported or no code example is available.

Parameters

rect

Type: RectangleF

graph

Type: Graphics

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference


EndThread Delegate

Represents methods related to end of a thread.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Delegate Sub EndThread()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public delegate void EndThread()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference


EventHandler Delegate

Represents methods that will handle all events in the CADImport namespace.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Delegate Sub EventHandler( _
   ByVal Sender As Object _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public delegate void EventHandler(
   object Sender
)
This language is not supported or no code example is available.

Parameters

Sender

Type: object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference


FPointProc Delegate

Represents methods for getting the entities' points.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Delegate Sub FPointProc( _
   ByVal P As DPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public delegate void FPointProc(
   DPoint P
)
This language is not supported or no code example is available.

Parameters

P

Type: DPoint

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference


PointValueChange Delegate

Represents methods that will handle the events of changing the coordinates of a three-dimensional point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Delegate Sub PointValueChange( _
   ByVal val As Point3D _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public delegate void PointValueChange(
   Point3D val
)
This language is not supported or no code example is available.

Parameters

val

Type: Point3D

A Point3D object used for displaying the coordinates of three-dimensional point in the properties window.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference


VertexValueChange Delegate

Delegate for Vertex3D editing

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Delegate Sub VertexValueChange( _
   ByVal val As Vertex3D _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public delegate void VertexValueChange(
   Vertex3D val
)
This language is not supported or no code example is available.

Parameters

val

Type: Vertex3D

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference


CADBorderType Enumeration

Specifies the way the CAD image margins are calculated.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Global | The margins are added to the size of CAD drawing and measured in the same units.
None | The margins are not added to the size of CAD drawing.
Ratio | The margins are added to the size of CAD drawing and calculated as a fraction of its size.
See Also

Reference


CADDrawMode Enumeration

Specifies the color management in the CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Black | CAD image is shown in black and white.
Gray | CAD image is shown in grayscale.
Normal | All colors are shown.
See Also

Reference


CADHatchStyle Enumeration

Specifies a hatch style.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
BDiagonal | A tilt angle of hatch lines is between 90 and 180 degrees. A tilt angle is measured between the positive direction of axis X and a hatch line.
Cross | A hatch consists of crossing vertical and horizontal lines.
DiagCross | A hatch consists of the lines crossing each other under 90 degrees angle. A tilt angle of the lines can be of any value except for 0 and 90 degrees (vertical and horizontal lines).
FDiagonal | A tilt angle of hatch lines is between 0 and 90 degrees. A tilt angle is measured between the positive direction of axis X and a hatch line.
Horizontal | Hatch lines are horizontal.
PatternData | A hatch is specified by pattern.
Solid | Solid hatch.
Vertical | Hatch lines are vertical.
See Also

Reference


CADHatchType Enumeration

Specifies a border type of the hatched area.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Circle | The hatched area is bounded by a circle.
Ellipse | The hatched area is bounded by an ellipse.
None | A default value.
Polyline | The hatched area is bounded by a closed polyline.
Spline | The hatched area is bounded by a closed spline.
Stop | Auxiliary member; for internal use only.
See Also

Reference


CADSpace Enumeration

Specifies a type of space used in a CAD drawing.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
S2D | A CAD drawing has a two-dimensional space.
S3D | A CAD drawing has a three-dimensional space.
Undefined | A space of a CAD drawing is undefined.
See Also

Reference


CADTextHorizontalAlign Enumeration

Specifies a horizontal alignment for CADText.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Center | Align CADText by center.
Left | Align CADText by left.
Right | Align CADText by right.
See Also

Reference


CADViewDirection Enumeration

Specifies a direction of viewing a CAD image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Back | A CAD image is viewed from the back.
Bottom | A CAD image is viewed from the bottom.
Default | Default
Front | A CAD image is viewed from the front.
Left | A CAD image is viewed from the left.
NEIsometric | A CAD image is viewed from the top-back-right.
NWIsometric | A CAD image is viewed from the top-back-left.
Right | A CAD image is viewed from the right.
SEIsometric | A CAD image is viewed from the top-front-right.
SWIsometric | A CAD image is viewed from the top-front-left.
Top | A CAD image is viewed from the top.
See Also

Reference


DimName Enumeration

Describes dimension variables

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
DIMASZ | Dimensioning arrow size
DIMBLK1 | First arrow block name
DIMBLK2 | Second arrow block name
DIMCLRD | Dimension line color
DIMCLRE | Dimension extension line color
DIMCLRT | Dimension text color
DIMDEC | Number of decimal places for the tolerance values of a primary units dimension
DIMEXE | Extension line extension
DIMEXO | Extension line offset
DIMGAP | Dimension line gap
DIMLFAC | Linear measurements scale factor
DIMLWD | Dimension line lineweight
DIMLWE | Extension line lineweight
DIMSD1 | Suppression of first extension line
DIMSD2 | Suppression of second extension line
DIMSE1 | First extension line suppressed if nonzero
DIMSE2 | Second extension line suppressed if nonzero
DIMTAD | Text above dimension line if nonzero
DIMTIH | Text inside horizontal if nonzero
DIMTIX | Force text inside extensions if nonzero
DIMTOH | Text outside horizontal if nonzero
DIMTXSTY | Dimension text style
DIMTXT | Dimensioning text height
None | Default empty
See Also

Reference


DimTextPosVert Enumeration

Describes dimension text placement relative dimension line.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Above | Above dimensional line
Center | At center of dimensional line
JIS | Justified
OutSide | Outside dimension line
See Also

Reference


DrawGraphicsMode Enumeration

Specifies a subsystem used for rendering graphics.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Export | Export mode
GDIPlus | GDI+ (Graphics Device Interface) mode
None | None
OpenGL | OpenGL mode
WPF | WPF (Windows Presentation Foundation) mode
See Also

Reference


EntityType Enumeration

Specifies an entity type.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
ACADTable | ACADTable
Arc | Arc
Attdef | Attdef
Attrib | Attrib
Body | Body
Circle | Circle
CurvePolygon | CurvePolygon
DWGPolyline | DWGPolyline
Dimension | Dimension
DimensionArc | Arc dimension
DimensionRadialLarge | Large radial dimension
Ellipse | Ellipse
Entity | Entity
FlatEntity | FlatEntity
FlatHatch | FlatHatch
FlatPoly | FlatPoly
Gradient | Gradient
GradientPolygon | GradientPolygon
Hatch | Hatch
Helix | Helix object
ImageDef | ImageDef
ImageEnt | ImageEnt
Insert | Insert
LWPolyline | LWPolyline
Layer | Layer
Leader | Leader
Line | Line
MInsert | MInsert
MLine | MLine object
MPolygon | MPoilygon object
MText | MText
Ole2Frame | Ole2Frame
Pattern | Pattern
Point | Point
PolyPolygon | PolyPolygon
Polyline | Polyline
Proxy | Proxy
Region | Region
Shape | Shape object
Solid | Solid
Spline | Spline
Surface | Plane surface
Text | Text
Tolerance | Tolerance object
Trace | Trace
Viewport | Viewport
Wipeout | Wipeout object
XRef | XRef
_3DFace | 3DFace
_3DSolid | 3DSolid
See Also

Reference


FileFormat Enumeration

List of supported files extensions

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Bmp |
Cgm |
Dwg |
Dxf |
Dxt |
Emf |
Gif |
Gl |
Gl2 |
Hg |
Hgl |
Hp |
Hp1 |
Hp2 |
Hp3 |
Hpg |
Hpgl |
Hpgl2 |
Hpp |
Jpeg |
Jpg |
Pcl |
Pdf |
Plo |
Plt |
Png |
Prn |
Rtl |
Spl |
Svg |
Swf |
Tif |
Tiff |
Undefined |
Wmf |
Xaml |
See Also

Reference


InsUnitsStruct Enumeration

Default drawing units for AutoCAD DesignCenter blocks

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Angstroms |
Astronomical |
Centimeters |
Decameters |
Decimeters |
Feet |
Gigameters |
Hectometers |
Inches |
Kilometers |
Lightyears |
Meters |
Microinches |
Microns |
Miles |
Millimeters |
Mils |
Nanometers |
Parsecs |
Unitless |
Yards |
See Also

Reference


LicenseType Enumeration

Specifies the type of license registration.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Floating | The registration is controlled by the LAN server which restricts the number of simultaneously working applications.
Register | The registration key is stored in the registry at the computer where the application is installed.
See Also

Reference


MessagesHandling Enumeration

Messages handling options

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Ignore | Ignore messages
MakeLog | Create a log file
ShowMessageBox | Display message boxes
See Also

Reference


PenStyle Enumeration

Specifies a type of line used to draw a CAD entity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Clear | A line is invisible.
Dash | A CAD entity is drawn by dash lines.
DashDot | A CAD entity is drawn by dash-dot lines.
DashDotDot | A CAD entity is drawn by dash-dot-dot lines.
Dot | A CAD entity is drawn by dot lines.
InsideFrame | A CAD entity is drawn by solid lines inside the bounding rectangle.
Solid | A CAD entity is drawn by solid lines.
See Also

Reference


ProgressStage Enumeration

Specifies a stage of reading a file.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Ending | An end of reading the file.
Running | Reading a file.
Starting | A start of reading a file.
See Also

Reference


RenderMode Enumeration

Rendering modes for OpenGL visualization

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Points | Points
Solid | Solid
Wireframe | Wireframes
See Also

Reference


SHXKinds Enumeration

Specifies a type of the SHX fonts.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
BigSHX | SHX big fonts.
NormSHX | Normal SHX fonts.
UnicodeSHX | SHX unicode fonts.
See Also

Reference


SelectionEntityMode Enumeration

Specifies a state of the Selection tool.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Disabled | The Selection tool is disabled.
Enabled | The Selection tool is enabled.
See Also

Reference


TTFSmoothing Enumeration

Smoothimg modes for TTF fonts visualization

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Always | Use smoothing
Auto | Auto mode
None | No smoothing
See Also

Reference


TextGeneration Enumeration

Specifies a direction of generating text letters.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Backward | Text letters are generated backward (mirrored in X direction).
Normal | Text letters are positioned normally.
UpSideDown | Text letters are positioned upside down (mirrored in Y direction).
See Also

Reference


CADImport.CAD3D Namespace

Assembly: CADImport (in CADImport.dll)

Classes
 | Name | Description
Public class | CAD3DConst | Contains data for 3D drawings
Public class | CAD3DFacet | Represents a three-dimensional three-sided facet in the STL image.
Public class | STLImage | Represents a drawing of the STL format.
Top
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


CAD3DConst Class

Members See Also

Contains data for 3D drawings

Namespace: CADImport.CAD3D
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public MustInherit Class CAD3DConst
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public abstract class CAD3DConst
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CAD3D.CAD3DConst
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD3DConst Members
CADImport.CAD3D Namespace


CAD3DConst Members

CAD3DConst Class Methods Fields See Also

Contains data for 3D drawings

The following tables list the members exposed by the CAD3DConst type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
Name | Description
ObjectDefaultColor | Specifies the default color value for 3D drawings
Top
See Also

Reference

CAD3DConst Class
CADImport.CAD3D Namespace


CAD3DConst Methods

CAD3DConst Class See Also

The following tables list the members exposed by the CAD3DConst type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CAD3DConst Class
CADImport.CAD3D Namespace


CAD3DConst Fields

CAD3DConst Class See Also

The following tables list the members exposed by the CAD3DConst type.

Fields
Name | Description
ObjectDefaultColor | Specifies the default color value for 3D drawings
Top
See Also

Reference

CAD3DConst Class
CADImport.CAD3D Namespace


ObjectDefaultColor Field

Specifies the default color value for 3D drawings

Namespace: CADImport.CAD3D
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared ObjectDefaultColor As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static Color ObjectDefaultColor
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD3DConst Class
CAD3DConst Members
CADImport.CAD3D Namespace


CAD3DFacet Class

Members See Also

Represents a three-dimensional three-sided facet in the STL image.

Namespace: CADImport.CAD3D
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CAD3DFacet
    Inherits CAD3dFace
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CAD3DFacet : CAD3dFace
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADPenEntity
CADImport.CADPenLine
CADImport.CADLine
CADImport.CADSolid
CADImport.CAD3dFace
CADImport.CAD3D.CAD3DFacet
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD3DFacet Members
CADImport.CAD3D Namespace


CAD3DFacet Members

CAD3DFacet Class Constructors Methods Fields Properties See Also

Represents a three-dimensional three-sided facet in the STL image.

The following tables list the members exposed by the CAD3DFacet type.

Constructors
 | Name | Description
Public constructor | CAD3DFacet | Initializes a new instance of the CAD3DFacet class.
Top
Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses the CADSolid entity. (inherited from CADSolid).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | DottedSingPts | Gets a collection of points that specify the dots and dashes of the CADLine. (inherited from CADLine).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CAD3DSolid entity (inherited from CAD3dFace).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Flags | Gets or sets an integer value that provides flags for the CAD3DFace object. (inherited from CAD3dFace).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADPenLine).
Public property | Point1 | Gets or sets a second end of the CADLine. (inherited from CADLine).
Public property | Point2 | Gets or sets a third point of the CAD3DFacet object.
Public property | Point3 | Gets or sets a third point of the CAD3DFacet object.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | AssignEntity | Copies an entity (inherited from CAD3dFace).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADLine).
Public method | DrawEntityTrace | Implements drawing of an entity with specified offset to specified Control (inherited from CADSolid).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADSolid object must be drawn during a drawing cycle. (inherited from CADSolid).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADSolid object to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CAD3DFacet Class
CADImport.CAD3D Namespace


CAD3DFacet Constructor

Initializes a new instance of the CAD3DFacet class.

Namespace: CADImport.CAD3D
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CAD3DFacet()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD3DFacet Class
CAD3DFacet Members
CADImport.CAD3D Namespace


CAD3DFacet Properties

CAD3DFacet Class See Also

The following tables list the members exposed by the CAD3DFacet type.

Properties
 | Name | Description
Public property | Box | Gets a three-dimensional box that encloses the CADSolid entity. (inherited from CADSolid).
Public property | Color | Gets or sets a color of the pen for this CADPenEntity. (inherited from CADPenEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities contained in the given CADEntity. (inherited from CADEntity).
Public property | DashStyle | Gets or sets DashStyle for CADPenEntity object (inherited from CADPenEntity).
Public property | DottedSingPts | Gets a collection of points that specify the dots and dashes of the CADLine. (inherited from CADLine).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADEntity).
Public property | EntType | Gets the type of this CAD3DSolid entity (inherited from CAD3dFace).
Public property | Entities | Gets a collection of all entities owned by this CADEntity. (inherited from CADEntity).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Extrusion | Gets or sets a direction of axis Z belonging to the coordinate system of this CADPenLine object. (inherited from CADPenLine).
Public property | Flags | Gets or sets an integer value that provides flags for the CAD3DFace object. (inherited from CAD3dFace).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets line type for this CADPenLine object. (inherited from CADPenLine).
Public property | LineTypeName | Gets a name of line type for this CADPenLine object (inherited from CADPenLine).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADPenLine object. (inherited from CADPenLine).
Public property | Lines | Gets or sets a type of the line for the CADPenLine entity. (inherited from CADPenLine).
Public property | Point | Gets or sets a point that specifies a position of the CADPenLine entity in the CAD drawing. (inherited from CADPenLine).
Public property | Point1 | Gets or sets a second end of the CADLine. (inherited from CADLine).
Public property | Point2 | Gets or sets a third point of the CAD3DFacet object.
Public property | Point3 | Gets or sets a third point of the CAD3DFacet object.
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | Width | Gets or sets a line width of CADPenEntity object (inherited from CADPenEntity).
Public property | ZThick | Gets or sets a line thickness measured along the axis Z for this CADPenLine entity. (inherited from CADPenLine).
Top
See Also

Reference

CAD3DFacet Class
CADImport.CAD3D Namespace


CAD3DFacet.Point2 Property

Gets or sets a third point of the CAD3DFacet object.

Namespace: CADImport.CAD3D
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shadows Property Point2() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
new public DPoint Point2 {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD3DFacet Class
CAD3DFacet Members
CADImport.CAD3D Namespace


CAD3DFacet.Point3 Property

Gets or sets a third point of the CAD3DFacet object.

Namespace: CADImport.CAD3D
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shadows Property Point3() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
new public DPoint Point3 {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD3DFacet Class
CAD3DFacet Members
CADImport.CAD3D Namespace


CAD3DFacet Methods

CAD3DFacet Class See Also

The following tables list the members exposed by the CAD3DFacet type.

Methods
 | Name | Description
Public method | AddEntity | Virtual method. Redefined in descendant classes. (inherited from CADEntity).
Public method | AddThick | Increases a size of the rectangle that encloses the CADPenLine entity after increasing its thickness. (inherited from CADPenLine).
Public method | AssignEntity | Copies an entity (inherited from CAD3dFace).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADLine).
Public method | DrawEntityTrace | Implements drawing of an entity with specified offset to specified Control (inherited from CADSolid).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADSolid object must be drawn during a drawing cycle. (inherited from CADSolid).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Loaded | Loads this CADSolid object to the specified CADConverter.
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for the CADPenLine entity. (inherited from CADPenLine).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CAD3DFacet Class
CADImport.CAD3D Namespace


CAD3DFacet.Loaded Method

Loads this CADSolid object to the specified CADConverter.

Namespace: CADImport.CAD3D
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Loaded( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Loaded(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

A CADConverter where to a CADSolid object is loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD3DFacet Class
CAD3DFacet Members
CADImport.CAD3D Namespace


CAD3DFacet Fields

CAD3DFacet Class See Also

The following tables list the members exposed by the CAD3DFacet type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

CAD3DFacet Class
CADImport.CAD3D Namespace


STLImage Class

Members See Also

Represents a drawing of the STL format.

Namespace: CADImport.CAD3D
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class STLImage
    Inherits CADImage
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class STLImage : CADImage
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADImage
CADImport.CAD3D.STLImage
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

STLImage Members
CADImport.CAD3D Namespace


STLImage Members

STLImage Class Constructors Methods Fields Properties See Also

Represents a drawing of the STL format.

The following tables list the members exposed by the STLImage type.

Constructors
 | Name | Description
Public constructor | STLImage | Initializes a new instance of the STLImage class.
Top
Properties
 | Name | Description
Public property | AbsDepth | Gets an absolute depths of the CADImage. (inherited from CADImage).
Public property | AbsHeight | Gets an absolute height of the CADImage. (inherited from CADImage).
Public property | AbsWidth | Gets an absolute width of the CADImage. (inherited from CADImage).
Public property | Angle | Gets or sets the angle for this CADImage object visualization. (inherited from CADImage).
Public property | BackgroundColor | Gets or sets a background color of this CADImage. (inherited from CADImage).
Public property | BorderSize | Gets or sets a border size in pixels. (inherited from CADImage).
Public property | BorderType | Gets or sets a border type. (inherited from CADImage).
Public property | Center | Gets or sets CADImage center point. (inherited from CADImage).
Public property | Charset | Gets or sets a character set for the text entities. (inherited from CADImage).
 | CodePage | Gets or sets a number that identifies the encoding used in the loaded CAD file. (inherited from CADImage).
Public property | Converter | Gets a converter that loads CAD entities from the file to draw them in the current CADImage. (inherited from CADImage).
Public property | CurrentLayer | Gets or sets a current layer for the CADImage. (inherited from CADImage).
Public property | CurrentLayout | Gets or sets a current layout for the CADImage. (inherited from CADImage).
Public property | CurrentLayoutIndex | Gets an index of the current layout. (inherited from CADImage).
Public property | CurrentMarker | Gets a currently selected marker. (inherited from CADImage).
Public property | DefaultColor | Gets or sets a default color for the CADImage. (inherited from CADImage).
Public property | DefaultLayoutIndex | Gets or sets a default layout index. (inherited from CADImage).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions on the drawing are visible. (inherited from CADImage).
Public property | DrawMode | Gets or sets a current drawing mode. (inherited from CADImage).
Public property | EnableSnap | Gets or sets enablement of snap mode (inherited from CADImage).
Public property | Extents | Gets or sets an extents of the CADImage object. (inherited from CADImage).
Public property | FileInf | Gets information about a currently open file by means of the FileInfo class. (inherited from CADImage).
Public property | GDIPainter | Provides drawing functionality based on GDI+. (inherited from CADImage).
Public property | GraphicsOutMode | Specifies image draw mode. (inherited from CADImage).
Public property | InterpolationMode | Gets or sets the interpolation mode associated with current Graphics object (inherited from CADImage).
Public property | Is3D | Gets a value indicating whether this CADImage is three-dimensional. (inherited from CADImage).
Public property | IsDraw3DAxes | Gets or sets a value indicating whether 3D axes are shown on the drawing. (inherited from CADImage).
Public property | IsDrawingRotated | Gets a value indicating whether the CADImage has been rotated. (inherited from CADImage).
Public property | IsShowBackground | Gets or sets a value indicating using of a BackgroundColor. (inherited from CADImage).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data. (inherited from CADImage).
Public property | IsSnapObject | Gets a value, which shows if there is an object for snapping under current coordinates (inherited from CADImage).
Public property | IsStopped | For internal use. (inherited from CADImage).
Public property | IsWithoutBorder | Gest or sets a value indicating whether to draw the CADImage without borders. (inherited from CADImage).
Public property | IsWithoutMargins | Gets or sets a value indicating whether to draw the CADImage without margins. (inherited from CADImage).
 | LastLoadedFilePath | Specifying of the search directory (used for X-Refs, ImageEnt) (inherited from CADImage).
Public property | LayersCount | Gets a quantity of layers in this CADImage. (inherited from CADImage).
Public property | Layouts | Gets a collection of layouts in the current CADImage. (inherited from CADImage).
Public property | LayoutsCount | Gets a quantity of layouts in this CADImage. (inherited from CADImage).
Public property | LineScaled | Obsolete. Gets or sets a value indicating whether a width of lines to draw all entities in the drawing is specified by the file data. (inherited from CADImage).
Public property | LineWeightScale | Gets or sets a scale for drawing lines. (inherited from CADImage).
Public property | MMToPixelX | Gets or sets a value corresponding to amount of millimeters per one pixel. (inherited from CADImage).
Public property | NullWidth | Gets or sets default thickness for lines used to draw a CADImage. (inherited from CADImage).
Public property | NumberOfPartsInCircle | Gets or sets a quantity of segments to be used to draw a circle. (inherited from CADImage).
Public property | Painter | Provides image drawing functionality. (inherited from CADImage).
Public property | PrintDialog | Gets or sets print dialog (inherited from CADImage).
Public property | PureExtents | Gets CADImage extents without margins. (inherited from CADImage).
Public property | ResizeDisproportionateDrawing | For internal use (inherited from CADImage).
Public property | SHXSearchPaths | Gets or sets paths for searching SHX fonts. (inherited from CADImage).
Public property | SearchSHXPaths | Gets or sets a value specifying whether SHX paths will be searched for the fonts. (inherited from CADImage).
Public property | SelectEntitiesCount | Gets the number of selected entities (inherited from CADImage).
Public property | SelectedEntities | Gets or sets a list of selected entities (inherited from CADImage).
Public property | SelectionMode | Gets or sets a state of the Selection tool. (inherited from CADImage).
Public property | Selector | Provides selection functionality. (inherited from CADImage).
Public property | SkipMMtoPixel | For specific use (inherited from CADImage).
Public property | SnapCurrent | (inherited from CADImage).
Public property | SnapOptions | Represents Snap options for the CADImage object (inherited from CADImage).
Public property | SnapRealPoint | Gets a current point in absolute coordinates (drawing coordinates) (inherited from CADImage).
Public property | SnapScreenPoint | Gets current point in display coordinates (inherited from CADImage).
Public property | TTFSmoothing | Gets or sets a value indicating whether TTF fonts are smoothed. (inherited from CADImage).
Public property | TextVisible | Gets or sets a value indicating whether the texts in the CADImage are visible. (inherited from CADImage).
Public property | UndoMode | Gets or sets whether undo/redo is disable or enable for professional version (inherited from CADImage).
Public property | UseDoubleBuffering | Outdated. Does nothing (inherited from CADImage).
Public property | UseLayerPriority | (inherited from CADImage).
Public property | UseMultyTTFFonts | Gets or sets a value indicating whether a multimode is used for showing symbols. (inherited from CADImage).
Public property | UseNullWidth | Specifies if default width will be used instead of entity width. (inherited from CADImage).
Public property | UseSHXFonts | Specifies if SHX fonts will be used for visualization. (inherited from CADImage).
Public property | UseTTFFonts | Specifies if TTF fonts will be used for visualization. (inherited from CADImage).
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles in the CADImage are drawn with GDI+ drawing methods without linearization. (inherited from CADImage).
Top
Methods
 | Name | Description
Public method | ActiveVPort | Returns drawing area visualized with the active VPort. (inherited from CADImage).
Public method | AddScaledDXF | Adds a scaled external reference to the model space of the specified CAD image. (inherited from CADImage).
Public method | AddScaledDXFEx | Adds a scaled external reference to the current layout of the specified CAD image. (inherited from CADImage).
Public method | AddToUndoList | (Overloaded) Adds operation "create new Entity" to undo list (inherited from CADImage).
Public method | ChangeDrawMode | Initializes a new graphic class object if current mode changed. (inherited from CADImage).
Public method | ChangeEntities | (inherited from CADImage).
Public method | ChangeGraphicsMode | Changes image drawing mode. (inherited from CADImage).
Public method | ChangePositionSelectedEntities | Changes position of the selected entities (inherited from CADImage).
Public method | ChangePositionSelectedEntity | Changes a position of the selected entity. (inherited from CADImage).
Public method | ClearBuffer | Outdated. Does nothing (inherited from CADImage).
Public method | ClearMarkers | Clears a collection of markers. (inherited from CADImage).
Public method | ClearRedoCollection | Clears redo entity collection (inherited from CADImage).
Public method | ClearSelectCollection | Clears a collection of the selected entities. (inherited from CADImage).
Public method | ClearSelection | Clears a list of the selected entities. (inherited from CADImage).
Public method | ClearSnapTrace | (Overloaded) Clears last drawn snap drawing element (inherited from CADImage).
Public method | ClearUndoCollection | Clears undo entity collection (inherited from CADImage).
Public method | CopyEntities | (Overloaded) Copies selected entities to the clipboard (inherited from CADImage).
Public method | CorrectByGrid | (Overloaded) Reduces a point location on screen to the grid node when the grid is active (inherited from CADImage).
Public method | CorrectByGridAndOrtho | Reduces a point relocation sizes on screen to the grid cell sizes when the grid is active (inherited from CADImage).
 | CreateImageByExtension | Creates specialised CADImage object for specified file extention (inherited from CADImage).
Public method | CutEntities | (Overloaded) Cuts selected entities from collection and paste them to the clipboard (inherited from CADImage).
Public method | Dispose | Disposes a CADImage object.
Public method | DoSelectEntities | (Overloaded) Selects inserted list of entities (inherited from CADImage).
Public method | DoSelectEntity | Selects inserted entity (inherited from CADImage).
Public method | Draw | (Overloaded) Draws a CADImage. (inherited from CADImage).
Public method | DrawACISEntity | Draws ACISEntity object (inherited from CADImage).
Public method | DrawChangeEntity | Changes a position of the marker designating the selected entity. (inherited from CADImage).
Public method | DrawMoveEntityTrace | Draws entities on their offsetting (inherited from CADImage).
Public method | DrawSnapTrace | Draws snap icon in case of proximity of object to current coordinates (inherited from CADImage).
Public method | EmfConvertToDXF | (Overloaded) Converts emf file to dxf file (inherited from CADImage).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportToMetafile | (Overloaded) Exports a CAD drawing to Windows Enhanced metafile. (inherited from CADImage).
Public method | GetAbsPoint | Converts display coordinates into absolute coordinates of a design (inherited from CADImage).
Public method | GetCADCoords | Returns coordinates of a point on the drawing. (inherited from CADImage).
Public method | GetCenter | Returns the center point of a current layout (inherited from CADImage).
Public method | GetExtents | Calculates the current dimensions of the CADImage. (inherited from CADImage).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLayerColor | Gets layer color by index (inherited from CADImage).
Public method | GetLayerFreeze | Determines whether the layer (CADLayer) is frozen. (inherited from CADImage).
Public method | GetLayerName | Gets a name of the layer that has the specified index in the collection of layers. (inherited from CADImage).
Public method | GetLayerVisible | Determines whether a layer is visible (inherited from CADImage).
Public method | GetLayoutName | Gets a name of the layout that has the specified index in the collection of layouts. (inherited from CADImage).
Public method | GetPoint | Transforms a three-dimensional CAD point into a two-dimensional screen point. (inherited from CADImage).
Public method | GetRealImagePoint | For internal use. (inherited from CADImage).
Public method | GetRealSnapPoint | Smooths a point in absolute coordinates by the entity (inherited from CADImage).
Public method | GetSelectEntityRegion | Returns the selected area of the image. (inherited from CADImage).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetVPortExtents | Returns extents of the active VPort reduced to the specified size (inherited from CADImage).
Public method | InitialNewImage | (Overloaded) Initializes a new image with the default size (inherited from CADImage).
Public method | InvalidateSelectEntity | Redraws a selected entity. (inherited from CADImage).
Public method | InvalidateSelectedEntities | (Overloaded) Redraws a list of the selected entities (inherited from CADImage).
Public method | LoadFromFile | Uses for redefining in a descendant classes, define loading image from the specified file. (inherited from CADImage).
Public method | LoadFromStream | Loads a CAD image stored in the specified stream.
Public method | LoadFromWeb | Loads CAD image from hyperlink (inherited from CADImage).
Public method | MultipleSelect | Providing CAD image entities' multiple selection within a specified rectangle. (inherited from CADImage).
Public method | MultipleSelectExt | Selects all entities inside the inserted rectangle (inherited from CADImage).
Public method | PasteEntities | Pastes entities from the clipboard (inherited from CADImage).
Public method | PasteEntitiesExt | Pastes entities from the clipboard (inherited from CADImage).
Public method | Print | Prints a current CAD image. (inherited from CADImage).
Public method | Redo | Redo change (inherited from CADImage).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RefreshCurrentLayout | Refresh current layout. (inherited from CADImage).
Public method | RefreshSnapTrace | Refreshes a region of the last drawn snap drawing element (inherited from CADImage).
Public method | RemoveEntity | (Overloaded) Removes CADEntity object. (inherited from CADImage).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from CADImage).
Public method | RotToView | Rotates a CAD image to get a specified view. (inherited from CADImage).
Public method | Rotate | Rotates objects in the current drawing. (inherited from CADImage).
Public method | SaveAsDXF | Saves a current CAD image in DXF format. (inherited from CADImage).
Public method | SaveImageToClipboard | (Overloaded) Writes a visible part of the current CAD image to the clipboard as a raster image. (inherited from CADImage).
Public method | SaveToFile | (Overloaded) Saves a part of the current CAD image to the file of the specified format. (inherited from CADImage).
Public method | SaveToStream | (Overloaded) Writes a visible part of the current CAD image to the specified stream as a raster image. (inherited from CADImage).
Public method | Select | Selects an entity of the CAD image at the specified point. (inherited from CADImage).
Public method | SelectExt | Selects an entity of the CAD image at the specified point. (inherited from CADImage).
Public method | SetCenter | Sets CADImage center point. (inherited from CADImage).
Public method | SetCurrentLayout | Sets a current layout of this CADImage. (inherited from CADImage).
Public method | SetLayerColor | (Overloaded) Sets a color for layer (CADLayer) specified by index (inherited from CADImage).
Public method | SetLayerFreeze | (Overloaded) Sets freeze parameter for CADLayer (inherited from CADImage).
Public method | SetLayerVisible | (Overloaded) Sets a visibility of the layer. (inherited from CADImage).
Public method | SetNewEntityMarkerPos | Sets a new position for the selected entity. The entity's new position is defined by the position of the marker. (inherited from CADImage).
Public method | SetNewMMToPixel | Sets a quantity of millimeters per pixel for the specified Graphics object. (inherited from CADImage).
Public method | SetNewPosEntitiesExt | Sets a new position for the specified entities (inherited from CADImage).
Public method | SetNewPosEntity | Sets a new position for the specified entity. (inherited from CADImage).
Public method | Stop | For internal use. (inherited from CADImage).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | Undo | Undo change (inherited from CADImage).
Top
Fields
 | Name | Description
 | EntityBuffer | Represents buffer for CADEntityCollection storing. (inherited from CADImage).
Public field | visibleArea | Represents CADImage visible area. (inherited from CADImage).
Top
See Also

Reference

STLImage Class
CADImport.CAD3D Namespace


STLImage Constructor

Initializes a new instance of the STLImage class.

Namespace: CADImport.CAD3D
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public STLImage()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

STLImage Class
STLImage Members
CADImport.CAD3D Namespace


STLImage Properties

STLImage Class See Also

The following tables list the members exposed by the STLImage type.

Properties
 | Name | Description
Public property | AbsDepth | Gets an absolute depths of the CADImage. (inherited from CADImage).
Public property | AbsHeight | Gets an absolute height of the CADImage. (inherited from CADImage).
Public property | AbsWidth | Gets an absolute width of the CADImage. (inherited from CADImage).
Public property | Angle | Gets or sets the angle for this CADImage object visualization. (inherited from CADImage).
Public property | BackgroundColor | Gets or sets a background color of this CADImage. (inherited from CADImage).
Public property | BorderSize | Gets or sets a border size in pixels. (inherited from CADImage).
Public property | BorderType | Gets or sets a border type. (inherited from CADImage).
Public property | Center | Gets or sets CADImage center point. (inherited from CADImage).
Public property | Charset | Gets or sets a character set for the text entities. (inherited from CADImage).
 | CodePage | Gets or sets a number that identifies the encoding used in the loaded CAD file. (inherited from CADImage).
Public property | Converter | Gets a converter that loads CAD entities from the file to draw them in the current CADImage. (inherited from CADImage).
Public property | CurrentLayer | Gets or sets a current layer for the CADImage. (inherited from CADImage).
Public property | CurrentLayout | Gets or sets a current layout for the CADImage. (inherited from CADImage).
Public property | CurrentLayoutIndex | Gets an index of the current layout. (inherited from CADImage).
Public property | CurrentMarker | Gets a currently selected marker. (inherited from CADImage).
Public property | DefaultColor | Gets or sets a default color for the CADImage. (inherited from CADImage).
Public property | DefaultLayoutIndex | Gets or sets a default layout index. (inherited from CADImage).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions on the drawing are visible. (inherited from CADImage).
Public property | DrawMode | Gets or sets a current drawing mode. (inherited from CADImage).
Public property | EnableSnap | Gets or sets enablement of snap mode (inherited from CADImage).
Public property | Extents | Gets or sets an extents of the CADImage object. (inherited from CADImage).
Public property | FileInf | Gets information about a currently open file by means of the FileInfo class. (inherited from CADImage).
Public property | GDIPainter | Provides drawing functionality based on GDI+. (inherited from CADImage).
Public property | GraphicsOutMode | Specifies image draw mode. (inherited from CADImage).
Public property | InterpolationMode | Gets or sets the interpolation mode associated with current Graphics object (inherited from CADImage).
Public property | Is3D | Gets a value indicating whether this CADImage is three-dimensional. (inherited from CADImage).
Public property | IsDraw3DAxes | Gets or sets a value indicating whether 3D axes are shown on the drawing. (inherited from CADImage).
Public property | IsDrawingRotated | Gets a value indicating whether the CADImage has been rotated. (inherited from CADImage).
Public property | IsShowBackground | Gets or sets a value indicating using of a BackgroundColor. (inherited from CADImage).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data. (inherited from CADImage).
Public property | IsSnapObject | Gets a value, which shows if there is an object for snapping under current coordinates (inherited from CADImage).
Public property | IsStopped | For internal use. (inherited from CADImage).
Public property | IsWithoutBorder | Gest or sets a value indicating whether to draw the CADImage without borders. (inherited from CADImage).
Public property | IsWithoutMargins | Gets or sets a value indicating whether to draw the CADImage without margins. (inherited from CADImage).
 | LastLoadedFilePath | Specifying of the search directory (used for X-Refs, ImageEnt) (inherited from CADImage).
Public property | LayersCount | Gets a quantity of layers in this CADImage. (inherited from CADImage).
Public property | Layouts | Gets a collection of layouts in the current CADImage. (inherited from CADImage).
Public property | LayoutsCount | Gets a quantity of layouts in this CADImage. (inherited from CADImage).
Public property | LineScaled | Obsolete. Gets or sets a value indicating whether a width of lines to draw all entities in the drawing is specified by the file data. (inherited from CADImage).
Public property | LineWeightScale | Gets or sets a scale for drawing lines. (inherited from CADImage).
Public property | MMToPixelX | Gets or sets a value corresponding to amount of millimeters per one pixel. (inherited from CADImage).
Public property | NullWidth | Gets or sets default thickness for lines used to draw a CADImage. (inherited from CADImage).
Public property | NumberOfPartsInCircle | Gets or sets a quantity of segments to be used to draw a circle. (inherited from CADImage).
Public property | Painter | Provides image drawing functionality. (inherited from CADImage).
Public property | PrintDialog | Gets or sets print dialog (inherited from CADImage).
Public property | PureExtents | Gets CADImage extents without margins. (inherited from CADImage).
Public property | ResizeDisproportionateDrawing | For internal use (inherited from CADImage).
Public property | SHXSearchPaths | Gets or sets paths for searching SHX fonts. (inherited from CADImage).
Public property | SearchSHXPaths | Gets or sets a value specifying whether SHX paths will be searched for the fonts. (inherited from CADImage).
Public property | SelectEntitiesCount | Gets the number of selected entities (inherited from CADImage).
Public property | SelectedEntities | Gets or sets a list of selected entities (inherited from CADImage).
Public property | SelectionMode | Gets or sets a state of the Selection tool. (inherited from CADImage).
Public property | Selector | Provides selection functionality. (inherited from CADImage).
Public property | SkipMMtoPixel | For specific use (inherited from CADImage).
Public property | SnapCurrent | (inherited from CADImage).
Public property | SnapOptions | Represents Snap options for the CADImage object (inherited from CADImage).
Public property | SnapRealPoint | Gets a current point in absolute coordinates (drawing coordinates) (inherited from CADImage).
Public property | SnapScreenPoint | Gets current point in display coordinates (inherited from CADImage).
Public property | TTFSmoothing | Gets or sets a value indicating whether TTF fonts are smoothed. (inherited from CADImage).
Public property | TextVisible | Gets or sets a value indicating whether the texts in the CADImage are visible. (inherited from CADImage).
Public property | UndoMode | Gets or sets whether undo/redo is disable or enable for professional version (inherited from CADImage).
Public property | UseDoubleBuffering | Outdated. Does nothing (inherited from CADImage).
Public property | UseLayerPriority | (inherited from CADImage).
Public property | UseMultyTTFFonts | Gets or sets a value indicating whether a multimode is used for showing symbols. (inherited from CADImage).
Public property | UseNullWidth | Specifies if default width will be used instead of entity width. (inherited from CADImage).
Public property | UseSHXFonts | Specifies if SHX fonts will be used for visualization. (inherited from CADImage).
Public property | UseTTFFonts | Specifies if TTF fonts will be used for visualization. (inherited from CADImage).
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles in the CADImage are drawn with GDI+ drawing methods without linearization. (inherited from CADImage).
Top
See Also

Reference

STLImage Class
CADImport.CAD3D Namespace


STLImage Methods

STLImage Class See Also

The following tables list the members exposed by the STLImage type.

Methods
 | Name | Description
Public method | ActiveVPort | Returns drawing area visualized with the active VPort. (inherited from CADImage).
Public method | AddScaledDXF | Adds a scaled external reference to the model space of the specified CAD image. (inherited from CADImage).
Public method | AddScaledDXFEx | Adds a scaled external reference to the current layout of the specified CAD image. (inherited from CADImage).
Public method | AddToUndoList | (Overloaded) Adds operation "create new Entity" to undo list (inherited from CADImage).
Public method | ChangeDrawMode | Initializes a new graphic class object if current mode changed. (inherited from CADImage).
Public method | ChangeEntities | (inherited from CADImage).
Public method | ChangeGraphicsMode | Changes image drawing mode. (inherited from CADImage).
Public method | ChangePositionSelectedEntities | Changes position of the selected entities (inherited from CADImage).
Public method | ChangePositionSelectedEntity | Changes a position of the selected entity. (inherited from CADImage).
Public method | ClearBuffer | Outdated. Does nothing (inherited from CADImage).
Public method | ClearMarkers | Clears a collection of markers. (inherited from CADImage).
Public method | ClearRedoCollection | Clears redo entity collection (inherited from CADImage).
Public method | ClearSelectCollection | Clears a collection of the selected entities. (inherited from CADImage).
Public method | ClearSelection | Clears a list of the selected entities. (inherited from CADImage).
Public method | ClearSnapTrace | (Overloaded) Clears last drawn snap drawing element (inherited from CADImage).
Public method | ClearUndoCollection | Clears undo entity collection (inherited from CADImage).
Public method | CopyEntities | (Overloaded) Copies selected entities to the clipboard (inherited from CADImage).
Public method | CorrectByGrid | (Overloaded) Reduces a point location on screen to the grid node when the grid is active (inherited from CADImage).
Public method | CorrectByGridAndOrtho | Reduces a point relocation sizes on screen to the grid cell sizes when the grid is active (inherited from CADImage).
 | CreateImageByExtension | Creates specialised CADImage object for specified file extention (inherited from CADImage).
Public method | CutEntities | (Overloaded) Cuts selected entities from collection and paste them to the clipboard (inherited from CADImage).
Public method | Dispose | Disposes a CADImage object.
Public method | DoSelectEntities | (Overloaded) Selects inserted list of entities (inherited from CADImage).
Public method | DoSelectEntity | Selects inserted entity (inherited from CADImage).
Public method | Draw | (Overloaded) Draws a CADImage. (inherited from CADImage).
Public method | DrawACISEntity | Draws ACISEntity object (inherited from CADImage).
Public method | DrawChangeEntity | Changes a position of the marker designating the selected entity. (inherited from CADImage).
Public method | DrawMoveEntityTrace | Draws entities on their offsetting (inherited from CADImage).
Public method | DrawSnapTrace | Draws snap icon in case of proximity of object to current coordinates (inherited from CADImage).
Public method | EmfConvertToDXF | (Overloaded) Converts emf file to dxf file (inherited from CADImage).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportToMetafile | (Overloaded) Exports a CAD drawing to Windows Enhanced metafile. (inherited from CADImage).
Public method | GetAbsPoint | Converts display coordinates into absolute coordinates of a design (inherited from CADImage).
Public method | GetCADCoords | Returns coordinates of a point on the drawing. (inherited from CADImage).
Public method | GetCenter | Returns the center point of a current layout (inherited from CADImage).
Public method | GetExtents | Calculates the current dimensions of the CADImage. (inherited from CADImage).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLayerColor | Gets layer color by index (inherited from CADImage).
Public method | GetLayerFreeze | Determines whether the layer (CADLayer) is frozen. (inherited from CADImage).
Public method | GetLayerName | Gets a name of the layer that has the specified index in the collection of layers. (inherited from CADImage).
Public method | GetLayerVisible | Determines whether a layer is visible (inherited from CADImage).
Public method | GetLayoutName | Gets a name of the layout that has the specified index in the collection of layouts. (inherited from CADImage).
Public method | GetPoint | Transforms a three-dimensional CAD point into a two-dimensional screen point. (inherited from CADImage).
Public method | GetRealImagePoint | For internal use. (inherited from CADImage).
Public method | GetRealSnapPoint | Smooths a point in absolute coordinates by the entity (inherited from CADImage).
Public method | GetSelectEntityRegion | Returns the selected area of the image. (inherited from CADImage).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetVPortExtents | Returns extents of the active VPort reduced to the specified size (inherited from CADImage).
Public method | InitialNewImage | (Overloaded) Initializes a new image with the default size (inherited from CADImage).
Public method | InvalidateSelectEntity | Redraws a selected entity. (inherited from CADImage).
Public method | InvalidateSelectedEntities | (Overloaded) Redraws a list of the selected entities (inherited from CADImage).
Public method | LoadFromFile | Uses for redefining in a descendant classes, define loading image from the specified file. (inherited from CADImage).
Public method | LoadFromStream | Loads a CAD image stored in the specified stream.
Public method | LoadFromWeb | Loads CAD image from hyperlink (inherited from CADImage).
Public method | MultipleSelect | Providing CAD image entities' multiple selection within a specified rectangle. (inherited from CADImage).
Public method | MultipleSelectExt | Selects all entities inside the inserted rectangle (inherited from CADImage).
Public method | PasteEntities | Pastes entities from the clipboard (inherited from CADImage).
Public method | PasteEntitiesExt | Pastes entities from the clipboard (inherited from CADImage).
Public method | Print | Prints a current CAD image. (inherited from CADImage).
Public method | Redo | Redo change (inherited from CADImage).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RefreshCurrentLayout | Refresh current layout. (inherited from CADImage).
Public method | RefreshSnapTrace | Refreshes a region of the last drawn snap drawing element (inherited from CADImage).
Public method | RemoveEntity | (Overloaded) Removes CADEntity object. (inherited from CADImage).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from CADImage).
Public method | RotToView | Rotates a CAD image to get a specified view. (inherited from CADImage).
Public method | Rotate | Rotates objects in the current drawing. (inherited from CADImage).
Public method | SaveAsDXF | Saves a current CAD image in DXF format. (inherited from CADImage).
Public method | SaveImageToClipboard | (Overloaded) Writes a visible part of the current CAD image to the clipboard as a raster image. (inherited from CADImage).
Public method | SaveToFile | (Overloaded) Saves a part of the current CAD image to the file of the specified format. (inherited from CADImage).
Public method | SaveToStream | (Overloaded) Writes a visible part of the current CAD image to the specified stream as a raster image. (inherited from CADImage).
Public method | Select | Selects an entity of the CAD image at the specified point. (inherited from CADImage).
Public method | SelectExt | Selects an entity of the CAD image at the specified point. (inherited from CADImage).
Public method | SetCenter | Sets CADImage center point. (inherited from CADImage).
Public method | SetCurrentLayout | Sets a current layout of this CADImage. (inherited from CADImage).
Public method | SetLayerColor | (Overloaded) Sets a color for layer (CADLayer) specified by index (inherited from CADImage).
Public method | SetLayerFreeze | (Overloaded) Sets freeze parameter for CADLayer (inherited from CADImage).
Public method | SetLayerVisible | (Overloaded) Sets a visibility of the layer. (inherited from CADImage).
Public method | SetNewEntityMarkerPos | Sets a new position for the selected entity. The entity's new position is defined by the position of the marker. (inherited from CADImage).
Public method | SetNewMMToPixel | Sets a quantity of millimeters per pixel for the specified Graphics object. (inherited from CADImage).
Public method | SetNewPosEntitiesExt | Sets a new position for the specified entities (inherited from CADImage).
Public method | SetNewPosEntity | Sets a new position for the specified entity. (inherited from CADImage).
Public method | Stop | For internal use. (inherited from CADImage).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | Undo | Undo change (inherited from CADImage).
Top
See Also

Reference

STLImage Class
CADImport.CAD3D Namespace


STLImage.Dispose Method

Disposes a CADImage object.

Namespace: CADImport.CAD3D
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

STLImage Class
STLImage Members
CADImport.CAD3D Namespace


STLImage.LoadFromStream Method

Loads a CAD image stored in the specified stream.

Namespace: CADImport.CAD3D
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub LoadFromStream( _
   ByVal stream As Stream _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void LoadFromStream(
   Stream stream
)
This language is not supported or no code example is available.

Parameters

stream

Type: Stream

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

STLImage Class
STLImage Members
CADImport.CAD3D Namespace


STLImage Fields

STLImage Class See Also

The following tables list the members exposed by the STLImage type.

Fields
 | Name | Description
 | EntityBuffer | Represents buffer for CADEntityCollection storing. (inherited from CADImage).
Public field | visibleArea | Represents CADImage visible area. (inherited from CADImage).
Top
See Also

Reference

STLImage Class
CADImport.CAD3D Namespace


CADImport.CADImportControls Namespace

Assembly: CADImport (in CADImport.dll)

Classes
 | Name | Description
Public class | CADEditorControl | Represents CAD files editor component
Public class | CADViewerControl | Provides a possibility of viewing CAD files.
Top
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


CADEditorControl Class

Members See Also

Represents CAD files editor component

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADEditorControl
    Inherits UserControl
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADEditorControl : UserControl
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
CADImport.CADImportControls.CADEditorControl
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl Members

CADEditorControl Class Constructors Events Methods Properties See Also

Represents CAD files editor component

The following tables list the members exposed by the CADEditorControl type.

Constructors
 | Name | Description
Public constructor | CADEditorControl | Initializes a new instance of the CADEditorControl class.
Top
Properties
 | Name | Description
Public property | AboutForm | Gets 'About' window
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | Active | Gets a parameter that indicates if the MainForm window is active
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (inherited from ScrollableControl).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from UserControl).
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (inherited from UserControl).
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (inherited from UserControl).
Public property | BackColor | Gets or sets the background color for the control. (inherited from Control).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | BorderStyle | Gets or sets the border style of the tree view control. (inherited from UserControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (inherited from Control).
Public property | ClipRectangle | Gets or sets an area selection tool
Public property | ColorDraw | Gets a parameter to draw an image in color or black-and-white mode
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | CreateNewEntity | Gets true if entity creating mode is enabled at the moment
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DimensionVisible | Gets or sets dimentions visibility
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | EditorCADPictureBox | Gets CADPictureBox control, where an image is drawn
Public property | EnableSnap | Gets or sets enabling or disabling of the snap
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | EndPoint | Gets or sets the point that belongs to entity after offsetting or editing by marker
Public property | EntitiesCreator | Gets or sets the visual entities creating object
Public property | EntityPropertyGrid | Gets or sets entity properties grid
Public property | EntityPropertyGridVisible | Gets or sets visibility of the entity properties grid
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Image | Gets CADImage object that corresponds the main class for reading/drawing/viewing of cad file contents
Public property | ImageBaseSize | Gets or sets base dimensions of the image drawing area
Public property | ImageDRect | Gets the current size and position of the drawing image
Public property | ImagePosition | Gets or sets a position of the drawing image
Public property | ImageRectangleF | Gets the current size and position of the drawing image as
Public property | ImageScale | Gets or sets scale of the drawing image
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InFileName | Gets or sets a name of the file to open
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | LayerForm | Gets or sets layers settings window
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (inherited from Control).
Public property | Margin | Gets or sets the space between controls. (inherited from Control).
Public property | MaximumSize | Gets or sets the size that is the upper limit that Size) can specify. (inherited from Control).
Public property | MinimumSize | Gets or sets the size that is the lower limit that Size) can specify. (inherited from Control).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | OptionsForm | Gets or sets settings window
Public property | OutFileName | Gets or sets a name of the file to save
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PictureBox | Gets CADPictureBox control that is used for visualization of drawings.
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | PreviousImagePosition | Gets or sets previous position of the drawing image
Public property | PreviousImageScale | Gets or sets previous scale of the drawing image
Public property | PrintingForm | Gets or sets preview and printing settings window
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | PropertyEntityPanelVisible | Gets or sets visibility of the entity properties panel
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | RegForm | Gets the registration window
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RegistrationForm | Gets or sets the registration window
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | SHXForm | Gets or sets shx fonts settings window
Public property | SetRasterSizeForm | Gets or sets the settings window for raster images saving
Public property | ShowLineWeight | Gets or sets lines weight visibility
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the height and width of the control. (inherited from Control).
Public property | StartPoint | Gets or sets the entity point which was selected before offsetting or editing by marker
Public property | StatusBarPanel | Gets or sets status bar panel
Public property | StatusBarPanelVisible | Gets or sets visibility of the status bar panel
Public property | SuppressVisualMove | Prevents entity move by mouse if true
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Control).
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (inherited from Control).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from UserControl).
Public property | TextVisible | Gets or sets text visibility
Public property | ToolsPanel | Gets or sets tools panel
Public property | ToolsPanelVisible | Gets or sets tools panel visibility
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | Black_Click | Paints the CAD image background in the black color.
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | CalculateNewSizeImage | Recalculates the current image sizes.
Public method | ChancelMove | Verifies suitability of the entity moving
Public method | ChangeControlState | Sets the current mode of controls
Public method | ChangeDimensionsVisiblity | Shows or hides dimensions in the current CAD image.
Public method | ChangeEntityOnMouseMove | Changes CADEntity position by changing marker position or entity dragging
Public method | ChangeShowLineWeight | Alternately changes a boolean value that indicates if a thickness of lines is determined by the file data.
Public method | ChangeTextsVisiblity | Shows or hides texts in the current CAD image.
Public method | ChangeTreeVisiblity | Shows or hides a panel that contains the entities tree.
Public method | ClearCADImage | Clears current CADImage object
Public method | ClearSelection | Clears selection and redraws entities
Public method | CloseFile | Closes a currently open CAD file.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateNewImage | (Overloaded) Create a new CADImage object
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | DeleteSelectedEntities | Deletes selected entities
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoBlackColor | Displays a CAD image in black and white colors.
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DoNormalColor | Displays a CAD image in all used colors.
 | DoResize | Resizes the CAD image to fit drawing's bounds.
Public method | DoZoomIn | Increases a scale of the CAD image to twice.
Public method | DoZoomOut | Decreases a scale of the CAD image to twice.
Public method | DrawCADImage | Draws a CAD image from the loaded CAD file.
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EnableButton | Enables or disables buttons of the toolbar and menu items of the main menu.
Public method | EndAddEntity | Finishes adding of the CADEntity
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetRealPoint | (Overloaded) Gets a three-dimensional point of the current CAD image from the specified screen point.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | InvalidateImage | Invalidates a specific region of the control and causes a paint message to be sent to the control.
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LoadFile | (Overloaded) Loads a CAD file into the main application's form.
Public method | LoadSettings | Loads saved application settings
Public method | MoveEntity | Moves a selected entitiy to the specified position
Public method | NewProtectionSettings | Fills the specified list with the current protection settings.
Public method | OnChangeBackgroundColor | Invokes ChangeBackgroundColor event
Public method | OnChangeDimensionShow | Invokes ChangeDimensionShow event
Public method | OnChangeDrawingColors | Invokes ChangeDrawingColors event
Public method | OnChangeEntityPanelVisible | Invokes ChangeEntityPanelVisible event
Public method | OnChangeEntityPropertyGridVisible | Invokes ChangeEntityPropertyGridVisible event
Public method | OnChangeLanguage | Invokes ChangeLanguage event
Public method | OnChangeLineWeightShow | Invokes ChangeLineWeightShow event
Public method | OnChangeSnapEnable | Invokes ChangeSnapEnables event
Public method | OnChangeStatusBarVisible | Invokes ChangeStatusBarVisible event
Public method | OnChangeTextShow | Invokes ChangeTextShow event
Public method | OnChangeToolsPanelVisible | Invokes ChangeToolsPanelVisible event
Public method | OnEndLoadFile | Invokes EndLoadFile event
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PutToClipboard | Saves image to Clipboard
Public method | ReOpen | Reopens a file after selecting or deselecting SHX fonts.
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
Public method | RedoChangeEntity | Performs the last undid changing of the entity
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | Register | Registers the CADImportNet library.
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetScaling | Sets scale and the position of the CAD image to its original values.
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | SaveAsDXF | Saves image as DXF
Public method | SaveAsImage | (Overloaded) Saves current image
Public method | SaveProtectionSettings | Makes the specified settings the current ones.
Public method | SaveSettings | Saves application settings
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectEntity | Selects an entity by the specified coordinates. Sets a number of settings on entity selection.
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAllFormsLanguageSettings | Sets the current language file for all child forms
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBlackBackGround | Sets black color for CADPictureBox background and appropriate lines color on default
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetCADImageOptions | Sets current properties for CADImage for loading file
Public method | SetColorLayer | Sets a layer color by the specified layer index
Public method | SetFreezeLayer | Sets CADLayer.Frozen parameter for the layer by the specified layer index
Public method | SetNewEntityPosition | Sets a new position for CADEntity on offsetting using start and end positions
Public method | SetNewMarkerPosition | Sets a new position for CADEntity on editing by markers using start and end positions
Public method | SetScale | Sets the new scale factor
Public method | SetSizePictureBox | Sets a scroll region for CADPictureBox
Public method | SetSnapMode | Sets the snap mode
Public method | SetVisibleLayer | Sets CADLayer.Visible parameter for the layer by the specified layer index
Public method | SetWhiteBackGround | Sets white color for CADPictureBox background and appropriate lines color on default
Public method | Shift | Moves an image at start position for new sizes, when scale changes.
Public method | Show | (Overloaded) Displays the control to the user. (inherited from Control).
Public method | ShowCustomPrintPreviewDialog | Shows CustomPrintPreview dialog
Public method | ShowPrintPreviewDialog | Shows PrintPreview dialog
Public method | ShowRect |
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (inherited from Component).
Public method | UndoChangeEntity | Undoes last changing of the entity
Public method | Unregister | Closes all registration resources.
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | UseClipRect | Enables ClipRect tool for set of entities selection
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from UserControl).
Public method | ViewLayouts | Creates a list of layouts of the CAD image and sets the current layout.
Public method | White_Click | Paints the CAD image background in the white color.
Public method | Zoom | Adjusts the image size according to the specified scale.
Public method | chLay_ItemCheck | Makes the layers of the loaded CAD image visible or invisible.
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from UserControl).
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (inherited from UserControl).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeBackgroundColor | Occurs when the background of the drawing was changed
Public event | ChangeDimensionShow | Occurs when displaying of the dimensions was enabled or disabled
Public event | ChangeDrawingColors | Occurs when the color type of the drawing was changed (black-and-white/color)
Public event | ChangeEntityPanelVisible | Occurs when visibility of the entity tree was changed
Public event | ChangeEntityPropertyGridVisible | Occurs when visibility of the entity properties inspector was changed
Public event | ChangeLanguage | Appears when the language of the application was changed
Public event | ChangeLineWeightShow | Occurs when displaying of the lines weight was enabled or disabled
Public event | ChangeSnapEnable | Occurs when the snap was enabled or disabled
Public event | ChangeStatusBarVisible | Occurs when visibility of the status panel was changed
Public event | ChangeTextShow | Occurs when displaying of the texts was enabled or disabled
Public event | ChangeToolsPanelVisible | Occurs when visibility of the tool panel was changed
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | EndLoadFile | Occurs when loading of the file was finished
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before the control becomes visible for the first time. (inherited from UserControl).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | Occurs when the control's margin changes. (inherited from Control).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (inherited from Control).
Public event | TabStopChanged | Occurs when the TabStop property value changes. (inherited from Control).
Public event | TextChanged | (inherited from UserControl).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

CADEditorControl Class
CADImport.CADImportControls Namespace


CADEditorControl Constructor

Initializes a new instance of the CADEditorControl class.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEditorControl()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl Properties

CADEditorControl Class See Also

The following tables list the members exposed by the CADEditorControl type.

Properties
 | Name | Description
Public property | AboutForm | Gets 'About' window
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | Active | Gets a parameter that indicates if the MainForm window is active
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (inherited from ScrollableControl).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from UserControl).
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (inherited from UserControl).
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (inherited from UserControl).
Public property | BackColor | Gets or sets the background color for the control. (inherited from Control).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | BorderStyle | Gets or sets the border style of the tree view control. (inherited from UserControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (inherited from Control).
Public property | ClipRectangle | Gets or sets an area selection tool
Public property | ColorDraw | Gets a parameter to draw an image in color or black-and-white mode
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | CreateNewEntity | Gets true if entity creating mode is enabled at the moment
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DimensionVisible | Gets or sets dimentions visibility
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | EditorCADPictureBox | Gets CADPictureBox control, where an image is drawn
Public property | EnableSnap | Gets or sets enabling or disabling of the snap
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | EndPoint | Gets or sets the point that belongs to entity after offsetting or editing by marker
Public property | EntitiesCreator | Gets or sets the visual entities creating object
Public property | EntityPropertyGrid | Gets or sets entity properties grid
Public property | EntityPropertyGridVisible | Gets or sets visibility of the entity properties grid
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Image | Gets CADImage object that corresponds the main class for reading/drawing/viewing of cad file contents
Public property | ImageBaseSize | Gets or sets base dimensions of the image drawing area
Public property | ImageDRect | Gets the current size and position of the drawing image
Public property | ImagePosition | Gets or sets a position of the drawing image
Public property | ImageRectangleF | Gets the current size and position of the drawing image as
Public property | ImageScale | Gets or sets scale of the drawing image
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InFileName | Gets or sets a name of the file to open
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | LayerForm | Gets or sets layers settings window
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (inherited from Control).
Public property | Margin | Gets or sets the space between controls. (inherited from Control).
Public property | MaximumSize | Gets or sets the size that is the upper limit that Size) can specify. (inherited from Control).
Public property | MinimumSize | Gets or sets the size that is the lower limit that Size) can specify. (inherited from Control).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | OptionsForm | Gets or sets settings window
Public property | OutFileName | Gets or sets a name of the file to save
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PictureBox | Gets CADPictureBox control that is used for visualization of drawings.
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | PreviousImagePosition | Gets or sets previous position of the drawing image
Public property | PreviousImageScale | Gets or sets previous scale of the drawing image
Public property | PrintingForm | Gets or sets preview and printing settings window
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | PropertyEntityPanelVisible | Gets or sets visibility of the entity properties panel
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | RegForm | Gets the registration window
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RegistrationForm | Gets or sets the registration window
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | SHXForm | Gets or sets shx fonts settings window
Public property | SetRasterSizeForm | Gets or sets the settings window for raster images saving
Public property | ShowLineWeight | Gets or sets lines weight visibility
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the height and width of the control. (inherited from Control).
Public property | StartPoint | Gets or sets the entity point which was selected before offsetting or editing by marker
Public property | StatusBarPanel | Gets or sets status bar panel
Public property | StatusBarPanelVisible | Gets or sets visibility of the status bar panel
Public property | SuppressVisualMove | Prevents entity move by mouse if true
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Control).
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (inherited from Control).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from UserControl).
Public property | TextVisible | Gets or sets text visibility
Public property | ToolsPanel | Gets or sets tools panel
Public property | ToolsPanelVisible | Gets or sets tools panel visibility
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

CADEditorControl Class
CADImport.CADImportControls Namespace


CADEditorControl.AboutForm Property

Gets 'About' window

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property AboutForm() As AboutForm
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public AboutForm AboutForm {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.Active Property

Gets a parameter that indicates if the MainForm window is active

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Active() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Active {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.ClipRectangle Property

Gets or sets an area selection tool

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ClipRectangle() As ClipRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ClipRect ClipRectangle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.ColorDraw Property

Gets a parameter to draw an image in color or black-and-white mode

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ColorDraw() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool ColorDraw {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.CreateNewEntity Property

Gets true if entity creating mode is enabled at the moment

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property CreateNewEntity() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool CreateNewEntity {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.DimensionVisible Property

Gets or sets dimentions visibility

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DimensionVisible() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool DimensionVisible {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.EditorCADPictureBox Property

Gets CADPictureBox control, where an image is drawn

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property EditorCADPictureBox() As CADPictureBox
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADPictureBox EditorCADPictureBox {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.EnableSnap Property

Gets or sets enabling or disabling of the snap

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property EnableSnap() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool EnableSnap {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.EndPoint Property

Gets or sets the point that belongs to entity after offsetting or editing by marker

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property EndPoint() As Point
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Point EndPoint {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.EntitiesCreator Property

Gets or sets the visual entities creating object

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property EntitiesCreator() As EntitiesCreator
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public EntitiesCreator EntitiesCreator {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.EntityPropertyGrid Property

Gets or sets entity properties grid

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property EntityPropertyGrid() As CADPropertyGrid
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADPropertyGrid EntityPropertyGrid {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.EntityPropertyGridVisible Property

Gets or sets visibility of the entity properties grid

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property EntityPropertyGridVisible() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool EntityPropertyGridVisible {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.Image Property

Gets CADImage object that corresponds the main class for reading/drawing/viewing of cad file contents

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Image() As CADImage
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADImage Image {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.ImageBaseSize Property

Gets or sets base dimensions of the image drawing area

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ImageBaseSize() As SizeF
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SizeF ImageBaseSize {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.ImageDRect Property

Gets the current size and position of the drawing image

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property ImageDRect() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DRect ImageDRect {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.ImagePosition Property

Gets or sets a position of the drawing image

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ImagePosition() As PointF
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public PointF ImagePosition {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.ImageRectangleF Property

Gets the current size and position of the drawing image as

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property ImageRectangleF() As RectangleF
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public RectangleF ImageRectangleF {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.ImageScale Property

Gets or sets scale of the drawing image

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ImageScale() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float ImageScale {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.InFileName Property

Gets or sets a name of the file to open

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property InFileName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string InFileName {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.LayerForm Property

Gets or sets layers settings window

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LayerForm() As LayerForm
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public LayerForm LayerForm {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.OptionsForm Property

Gets or sets settings window

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property OptionsForm() As EditorOptions
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public EditorOptions OptionsForm {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.OutFileName Property

Gets or sets a name of the file to save

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property OutFileName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string OutFileName {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.PictureBox Property

Gets CADPictureBox control that is used for visualization of drawings.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property PictureBox() As CADPictureBox
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADPictureBox PictureBox {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.PreviousImagePosition Property

Gets or sets previous position of the drawing image

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PreviousImagePosition() As PointF
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public PointF PreviousImagePosition {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.PreviousImageScale Property

Gets or sets previous scale of the drawing image

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PreviousImageScale() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float PreviousImageScale {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.PrintingForm Property

Gets or sets preview and printing settings window

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PrintingForm() As PrintingForm
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public PrintingForm PrintingForm {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.PropertyEntityPanelVisible Property

Gets or sets visibility of the entity properties panel

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PropertyEntityPanelVisible() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool PropertyEntityPanelVisible {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.RegForm Property

Gets the registration window

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property RegForm() As RegForm
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public RegForm RegForm {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.RegistrationForm Property

Gets or sets the registration window

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property RegistrationForm() As RegForm
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public RegForm RegistrationForm {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.SHXForm Property

Gets or sets shx fonts settings window

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property SHXForm() As SHXForm
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SHXForm SHXForm {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.SetRasterSizeForm Property

Gets or sets the settings window for raster images saving

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property SetRasterSizeForm() As SetRasterSizeForm
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SetRasterSizeForm SetRasterSizeForm {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.ShowLineWeight Property

Gets or sets lines weight visibility

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ShowLineWeight() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool ShowLineWeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.StartPoint Property

Gets or sets the entity point which was selected before offsetting or editing by marker

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property StartPoint() As Point
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Point StartPoint {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.StatusBarPanel Property

Gets or sets status bar panel

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property StatusBarPanel() As StatusBar
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public StatusBar StatusBarPanel {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.StatusBarPanelVisible Property

Gets or sets visibility of the status bar panel

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property StatusBarPanelVisible() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool StatusBarPanelVisible {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.SuppressVisualMove Property

Prevents entity move by mouse if true

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property SuppressVisualMove() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool SuppressVisualMove {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.TextVisible Property

Gets or sets text visibility

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TextVisible() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool TextVisible {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.ToolsPanel Property

Gets or sets tools panel

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ToolsPanel() As ToolBar
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ToolBar ToolsPanel {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.ToolsPanelVisible Property

Gets or sets tools panel visibility

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ToolsPanelVisible() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool ToolsPanelVisible {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl Methods

CADEditorControl Class See Also

The following tables list the members exposed by the CADEditorControl type.

Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | Black_Click | Paints the CAD image background in the black color.
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | CalculateNewSizeImage | Recalculates the current image sizes.
Public method | ChancelMove | Verifies suitability of the entity moving
Public method | ChangeControlState | Sets the current mode of controls
Public method | ChangeDimensionsVisiblity | Shows or hides dimensions in the current CAD image.
Public method | ChangeEntityOnMouseMove | Changes CADEntity position by changing marker position or entity dragging
Public method | ChangeShowLineWeight | Alternately changes a boolean value that indicates if a thickness of lines is determined by the file data.
Public method | ChangeTextsVisiblity | Shows or hides texts in the current CAD image.
Public method | ChangeTreeVisiblity | Shows or hides a panel that contains the entities tree.
Public method | ClearCADImage | Clears current CADImage object
Public method | ClearSelection | Clears selection and redraws entities
Public method | CloseFile | Closes a currently open CAD file.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateNewImage | (Overloaded) Create a new CADImage object
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | DeleteSelectedEntities | Deletes selected entities
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoBlackColor | Displays a CAD image in black and white colors.
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DoNormalColor | Displays a CAD image in all used colors.
 | DoResize | Resizes the CAD image to fit drawing's bounds.
Public method | DoZoomIn | Increases a scale of the CAD image to twice.
Public method | DoZoomOut | Decreases a scale of the CAD image to twice.
Public method | DrawCADImage | Draws a CAD image from the loaded CAD file.
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EnableButton | Enables or disables buttons of the toolbar and menu items of the main menu.
Public method | EndAddEntity | Finishes adding of the CADEntity
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetRealPoint | (Overloaded) Gets a three-dimensional point of the current CAD image from the specified screen point.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | InvalidateImage | Invalidates a specific region of the control and causes a paint message to be sent to the control.
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LoadFile | (Overloaded) Loads a CAD file into the main application's form.
Public method | LoadSettings | Loads saved application settings
Public method | MoveEntity | Moves a selected entitiy to the specified position
Public method | NewProtectionSettings | Fills the specified list with the current protection settings.
Public method | OnChangeBackgroundColor | Invokes ChangeBackgroundColor event
Public method | OnChangeDimensionShow | Invokes ChangeDimensionShow event
Public method | OnChangeDrawingColors | Invokes ChangeDrawingColors event
Public method | OnChangeEntityPanelVisible | Invokes ChangeEntityPanelVisible event
Public method | OnChangeEntityPropertyGridVisible | Invokes ChangeEntityPropertyGridVisible event
Public method | OnChangeLanguage | Invokes ChangeLanguage event
Public method | OnChangeLineWeightShow | Invokes ChangeLineWeightShow event
Public method | OnChangeSnapEnable | Invokes ChangeSnapEnables event
Public method | OnChangeStatusBarVisible | Invokes ChangeStatusBarVisible event
Public method | OnChangeTextShow | Invokes ChangeTextShow event
Public method | OnChangeToolsPanelVisible | Invokes ChangeToolsPanelVisible event
Public method | OnEndLoadFile | Invokes EndLoadFile event
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PutToClipboard | Saves image to Clipboard
Public method | ReOpen | Reopens a file after selecting or deselecting SHX fonts.
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
Public method | RedoChangeEntity | Performs the last undid changing of the entity
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | Register | Registers the CADImportNet library.
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetScaling | Sets scale and the position of the CAD image to its original values.
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | SaveAsDXF | Saves image as DXF
Public method | SaveAsImage | (Overloaded) Saves current image
Public method | SaveProtectionSettings | Makes the specified settings the current ones.
Public method | SaveSettings | Saves application settings
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectEntity | Selects an entity by the specified coordinates. Sets a number of settings on entity selection.
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAllFormsLanguageSettings | Sets the current language file for all child forms
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBlackBackGround | Sets black color for CADPictureBox background and appropriate lines color on default
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetCADImageOptions | Sets current properties for CADImage for loading file
Public method | SetColorLayer | Sets a layer color by the specified layer index
Public method | SetFreezeLayer | Sets CADLayer.Frozen parameter for the layer by the specified layer index
Public method | SetNewEntityPosition | Sets a new position for CADEntity on offsetting using start and end positions
Public method | SetNewMarkerPosition | Sets a new position for CADEntity on editing by markers using start and end positions
Public method | SetScale | Sets the new scale factor
Public method | SetSizePictureBox | Sets a scroll region for CADPictureBox
Public method | SetSnapMode | Sets the snap mode
Public method | SetVisibleLayer | Sets CADLayer.Visible parameter for the layer by the specified layer index
Public method | SetWhiteBackGround | Sets white color for CADPictureBox background and appropriate lines color on default
Public method | Shift | Moves an image at start position for new sizes, when scale changes.
Public method | Show | (Overloaded) Displays the control to the user. (inherited from Control).
Public method | ShowCustomPrintPreviewDialog | Shows CustomPrintPreview dialog
Public method | ShowPrintPreviewDialog | Shows PrintPreview dialog
Public method | ShowRect |
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (inherited from Component).
Public method | UndoChangeEntity | Undoes last changing of the entity
Public method | Unregister | Closes all registration resources.
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | UseClipRect | Enables ClipRect tool for set of entities selection
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from UserControl).
Public method | ViewLayouts | Creates a list of layouts of the CAD image and sets the current layout.
Public method | White_Click | Paints the CAD image background in the white color.
Public method | Zoom | Adjusts the image size according to the specified scale.
Public method | chLay_ItemCheck | Makes the layers of the loaded CAD image visible or invisible.
Top
See Also

Reference

CADEditorControl Class
CADImport.CADImportControls Namespace


CADEditorControl.Black_Click Method

Paints the CAD image background in the black color.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Black_Click()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Black_Click()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.CalculateNewSizeImage Method

Recalculates the current image sizes.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub CalculateNewSizeImage()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void CalculateNewSizeImage()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.ChancelMove Method

Verifies suitability of the entity moving

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function ChancelMove( _
   ByVal x As Integer, _
   ByVal y As Integer _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool ChancelMove(
   int x,
   int y
)
This language is not supported or no code example is available.

Parameters

x

Type: int

X axis position

y

Type: int

Y axis position

Return Value

Returns true if the offset is minimal
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.ChangeControlState Method

Sets the current mode of controls

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ChangeControlState()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ChangeControlState()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.ChangeDimensionsVisiblity Method

Shows or hides dimensions in the current CAD image.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ChangeDimensionsVisiblity( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ChangeDimensionsVisiblity(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.ChangeEntityOnMouseMove Method

Changes CADEntity position by changing marker position or entity dragging

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function ChangeEntityOnMouseMove( _
   ByVal pt As Point _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool ChangeEntityOnMouseMove(
   Point pt
)
This language is not supported or no code example is available.

Parameters

pt

Type: Point

New coordinates

Return Value

Returns true if the changing is successful
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.ChangeShowLineWeight Method

Alternately changes a boolean value that indicates if a thickness of lines is determined by the file data.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ChangeShowLineWeight( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ChangeShowLineWeight(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.ChangeTextsVisiblity Method

Shows or hides texts in the current CAD image.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ChangeTextsVisiblity( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ChangeTextsVisiblity(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.ChangeTreeVisiblity Method

Shows or hides a panel that contains the entities tree.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ChangeTreeVisiblity( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ChangeTreeVisiblity(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.ClearCADImage Method

Clears current CADImage object

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ClearCADImage()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ClearCADImage()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.ClearSelection Method

Clears selection and redraws entities

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ClearSelection()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ClearSelection()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.CloseFile Method

Closes a currently open CAD file.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub CloseFile()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void CloseFile()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.CreateNewImage Method

CADEditorControl Class See Also

Create a new CADImage object

Overload List
Name | Description
CreateNewImage() | Create a new CADImage object
CreateNewImage(string) | Create a new CADImage object
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.DeleteSelectedEntities Method

Deletes selected entities

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DeleteSelectedEntities()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DeleteSelectedEntities()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.DoBlackColor Method

Displays a CAD image in black and white colors.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DoBlackColor()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DoBlackColor()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.DoNormalColor Method

Displays a CAD image in all used colors.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DoNormalColor()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DoNormalColor()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.DoResize Method

Resizes the CAD image to fit drawing's bounds.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub DoResize( _
   ByVal img As CADImage, _
   ByRef pos As PointF, _
   ByVal pictBox As UserControl, _
   ByRef sizeRect As SizeF, _
   ByVal deactiv As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void DoResize(
   CADImage img,
   ref PointF pos,
   UserControl pictBox,
   ref SizeF sizeRect,
   bool deactiv
)
This language is not supported or no code example is available.

Parameters

img

Type: CADImage

pos

Type: PointF

pictBox

Type: UserControl

sizeRect

Type: SizeF

deactiv

Type: bool

Remarks

This method is invoked when changing layout or working with 3D Orbit tool.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.DoZoomIn Method

Increases a scale of the CAD image to twice.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DoZoomIn()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DoZoomIn()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.DoZoomOut Method

Decreases a scale of the CAD image to twice.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DoZoomOut()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DoZoomOut()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.DrawCADImage Method

Draws a CAD image from the loaded CAD file.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DrawCADImage( _
   ByVal gr As Graphics, _
   ByVal control As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DrawCADImage(
   Graphics gr,
   Control control
)
This language is not supported or no code example is available.

Parameters

gr

Type: Graphics

A Graphics object used to draw the CAD entities.

control

Type: Control

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.EnableButton Method

Enables or disables buttons of the toolbar and menu items of the main menu.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub EnableButton( _
   ByVal aVal As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void EnableButton(
   bool aVal
)
This language is not supported or no code example is available.

Parameters

aVal

Type: bool

true if the buttons and menu items are enabled; false if they are disabled.

Remarks

The buttons and menu items are enabled after loading a CAD file and become disabled after closing the file.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.EndAddEntity Method

Finishes adding of the CADEntity

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub EndAddEntity( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void EndAddEntity(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

A finishing flag of the CADEntityentity adding

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.GetRealPoint Method

CADEditorControl Class See Also

Gets a three-dimensional point of the current CAD image from the specified screen point.

Overload List
Name | Description
GetRealPoint(int, int, bool) | Gets a three-dimensional point of the current CAD image from the specified screen point.
GetRealPoint(int, int, bool, bool) | Gets a three-dimensional point of the current CAD image from the specified screen point.
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.InvalidateImage Method

Invalidates a specific region of the control and causes a paint message to be sent to the control.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub InvalidateImage()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void InvalidateImage()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.LoadFile Method

CADEditorControl Class See Also

Loads a CAD file into the main application's form.

Overload List
Name | Description
LoadFile(bool) | Loads a CAD file into the main application's form.
LoadFile(string) | Loads a CAD file into the main application's form.
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.LoadSettings Method

Loads saved application settings

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub LoadSettings()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void LoadSettings()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.MoveEntity Method

Moves a selected entitiy to the specified position

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub MoveEntity( _
   ByVal x1 As Integer, _
   ByVal y1 As Integer, _
   ByVal x2 As Integer, _
   ByVal y2 As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void MoveEntity(
   int x1,
   int y1,
   int x2,
   int y2
)
This language is not supported or no code example is available.

Parameters

x1

Type: int

Start X position

y1

Type: int

Start Y position

x2

Type: int

End X position

y2

Type: int

End Y position

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.NewProtectionSettings Method

Fills the specified list with the current protection settings.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub NewProtectionSettings( _
   ByVal settingsLst As SortedList _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void NewProtectionSettings(
   SortedList settingsLst
)
This language is not supported or no code example is available.

Parameters

settingsLst

Type: SortedList

A SortedList to fill with the current protection settings.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.OnChangeBackgroundColor Method

Invokes ChangeBackgroundColor event

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnChangeBackgroundColor( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnChangeBackgroundColor(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

If true then background color of the CADImage is black, else the background color is white

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.OnChangeDimensionShow Method

Invokes ChangeDimensionShow event

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnChangeDimensionShow( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnChangeDimensionShow(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

If false - dimensions are disabled, else - enabled

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.OnChangeDrawingColors Method

Invokes ChangeDrawingColors event

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnChangeDrawingColors( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnChangeDrawingColors(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

If false then the drawing is drawn in black-and-white, else in color

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.OnChangeEntityPanelVisible Method

Invokes ChangeEntityPanelVisible event

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub OnChangeEntityPanelVisible( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void OnChangeEntityPanelVisible(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

A value of the visibility of entities tree and properties inspector

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.OnChangeEntityPropertyGridVisible Method

Invokes ChangeEntityPropertyGridVisible event

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub OnChangeEntityPropertyGridVisible( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void OnChangeEntityPropertyGridVisible(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

Setting value of the visibility of the entity properties inspector

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.OnChangeLanguage Method

Invokes ChangeLanguage event

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub OnChangeLanguage( _
   ByVal val As String, _
   ByVal index As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void OnChangeLanguage(
   string val,
   int index
)
This language is not supported or no code example is available.

Parameters

val

Type: string

Language to set

index

Type: int

An index of the language in the language list

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.OnChangeLineWeightShow Method

Invokes ChangeLineWeightShow event

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnChangeLineWeightShow( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnChangeLineWeightShow(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

If false - line weight is disabled, else - enabled

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.OnChangeSnapEnable Method

Invokes ChangeSnapEnables event

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnChangeSnapEnable( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnChangeSnapEnable(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

Snap is disabled if false, else snap is enabled

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.OnChangeStatusBarVisible Method

Invokes ChangeStatusBarVisible event

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub OnChangeStatusBarVisible( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void OnChangeStatusBarVisible(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

A setting value of the status panel visibility

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.OnChangeTextShow Method

Invokes ChangeTextShow event

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnChangeTextShow( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnChangeTextShow(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

If false - texts are disabled, else - enabled

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.OnChangeToolsPanelVisible Method

Invokes ChangeToolsPanelVisible event

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub OnChangeToolsPanelVisible( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void OnChangeToolsPanelVisible(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

Setting value of the tools panel visibility

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.OnEndLoadFile Method

Invokes EndLoadFile event

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnEndLoadFile( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnEndLoadFile(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

If false - the loading is unsuccessful, else - successful

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.PutToClipboard Method

Saves image to Clipboard

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub PutToClipboard()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void PutToClipboard()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.ReOpen Method

Reopens a file after selecting or deselecting SHX fonts.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ReOpen()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ReOpen()
This language is not supported or no code example is available.
Remarks

This method is also called when the paths to the files containing SHX fonts have been edited in the SHX Paths window invoked by the SHX Fonts menu item.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.RedoChangeEntity Method

Performs the last undid changing of the entity

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub RedoChangeEntity()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void RedoChangeEntity()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.Register Method

Registers the CADImportNet library.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Register()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Register()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.ResetScaling Method

Sets scale and the position of the CAD image to its original values.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ResetScaling()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ResetScaling()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.SaveAsDXF Method

Saves image as DXF

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SaveAsDXF( _
   ByVal showdlg As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SaveAsDXF(
   bool showdlg
)
This language is not supported or no code example is available.

Parameters

showdlg

Type: bool

Show dialog

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.SaveAsImage Method

CADEditorControl Class See Also

Saves current image

Overload List
Name | Description
SaveAsImage(bool) | Invokes a SaveFileDialog box where user can select a directory and format for saving the current CAD image.
SaveAsImage(string) | Saves current image
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.SaveProtectionSettings Method

Makes the specified settings the current ones.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SaveProtectionSettings( _
   ByVal settingsLst As SortedList _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SaveProtectionSettings(
   SortedList settingsLst
)
This language is not supported or no code example is available.

Parameters

settingsLst

Type: SortedList

A SortedList containing the settings that will be made current.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.SaveSettings Method

Saves application settings

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SaveSettings()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SaveSettings()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.SelectEntity Method

Selects an entity by the specified coordinates. Sets a number of settings on entity selection.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function SelectEntity( _
   ByVal x As Integer, _
   ByVal y As Integer _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool SelectEntity(
   int x,
   int y
)
This language is not supported or no code example is available.

Parameters

x

Type: int

X axis position

y

Type: int

Y axis position

Return Value

Returns true if there is an entity in specified position and it is selected
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.SetAllFormsLanguageSettings Method

Sets the current language file for all child forms

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetAllFormsLanguageSettings( _
   ByVal path As String, _
   ByVal lngFile As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetAllFormsLanguageSettings(
   string path,
   string lngFile
)
This language is not supported or no code example is available.

Parameters

path

Type: string

lngFile

Type: string

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.SetBlackBackGround Method

Sets black color for CADPictureBox background and appropriate lines color on default

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetBlackBackGround()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetBlackBackGround()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.SetCADImageOptions Method

Sets current properties for CADImage for loading file

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetCADImageOptions()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetCADImageOptions()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.SetColorLayer Method

Sets a layer color by the specified layer index

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetColorLayer( _
   ByVal color As Color, _
   ByVal index As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetColorLayer(
   Color color,
   int index
)
This language is not supported or no code example is available.

Parameters

color

Type: Color

Setting color

index

Type: int

An index of the layer in the layers collection

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.SetFreezeLayer Method

Sets CADLayer.Frozen parameter for the layer by the specified layer index

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetFreezeLayer( _
   ByVal visible As Boolean, _
   ByVal index As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetFreezeLayer(
   bool visible,
   int index
)
This language is not supported or no code example is available.

Parameters

visible

Type: bool

Setting value

index

Type: int

An index of the layer in the layers collection

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.SetNewEntityPosition Method

Sets a new position for CADEntity on offsetting using start and end positions

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetNewEntityPosition()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetNewEntityPosition()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.SetNewMarkerPosition Method

Sets a new position for CADEntity on editing by markers using start and end positions

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetNewMarkerPosition()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetNewMarkerPosition()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.SetScale Method

Sets the new scale factor

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetScale( _
   ByVal valsc As Single _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetScale(
   float valsc
)
This language is not supported or no code example is available.

Parameters

valsc

Type: float

A new value of the scale factor

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.SetSizePictureBox Method

Sets a scroll region for CADPictureBox

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetSizePictureBox( _
   ByVal sz As Size _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetSizePictureBox(
   Size sz
)
This language is not supported or no code example is available.

Parameters

sz

Type: Size

Size to set

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.SetSnapMode Method

Sets the snap mode

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetSnapMode( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetSnapMode(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.SetVisibleLayer Method

Sets CADLayer.Visible parameter for the layer by the specified layer index

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetVisibleLayer( _
   ByVal visible As Boolean, _
   ByVal index As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetVisibleLayer(
   bool visible,
   int index
)
This language is not supported or no code example is available.

Parameters

visible

Type: bool

Setting value

index

Type: int

An index of the layer in the layers collection

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.SetWhiteBackGround Method

Sets white color for CADPictureBox background and appropriate lines color on default

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetWhiteBackGround()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetWhiteBackGround()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.Shift Method

Moves an image at start position for new sizes, when scale changes.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Shift()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Shift()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.ShowCustomPrintPreviewDialog Method

Shows CustomPrintPreview dialog

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ShowCustomPrintPreviewDialog()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ShowCustomPrintPreviewDialog()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.ShowPrintPreviewDialog Method

Shows PrintPreview dialog

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ShowPrintPreviewDialog()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ShowPrintPreviewDialog()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.ShowRect Method

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ShowRect( _
   ByVal rect As DRect _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ShowRect(
   DRect rect
)
This language is not supported or no code example is available.

Parameters

rect

Type: DRect

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.UndoChangeEntity Method

Undoes last changing of the entity

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub UndoChangeEntity()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void UndoChangeEntity()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.Unregister Method

Closes all registration resources.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Unregister()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Unregister()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.UseClipRect Method

Enables ClipRect tool for set of entities selection

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub UseClipRect()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void UseClipRect()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.ViewLayouts Method

Creates a list of layouts of the CAD image and sets the current layout.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ViewLayouts()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ViewLayouts()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.White_Click Method

Paints the CAD image background in the white color.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub White_Click()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void White_Click()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.Zoom Method

Adjusts the image size according to the specified scale.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Zoom( _
   ByVal i As Single _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Zoom(
   float i
)
This language is not supported or no code example is available.

Parameters

i

Type: float

A scale value.

Remarks

If the scale value is more than one the image size increases; otherwise, decreases.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.chLay_ItemCheck Method

Makes the layers of the loaded CAD image visible or invisible.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub chLay_ItemCheck( _
   ByVal sender As Object, _
   ByVal e As ItemCheckEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void chLay_ItemCheck(
   object sender,
   ItemCheckEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

A CheckedListBox that initializes changing a visibility of the layers.

e

Type: ItemCheckEventArgs

An ItemCheckEventArgs object that provides data for the event of changing a layer visibility.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl Events

CADEditorControl Class See Also

The following tables list the members exposed by the CADEditorControl type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from UserControl).
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (inherited from UserControl).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeBackgroundColor | Occurs when the background of the drawing was changed
Public event | ChangeDimensionShow | Occurs when displaying of the dimensions was enabled or disabled
Public event | ChangeDrawingColors | Occurs when the color type of the drawing was changed (black-and-white/color)
Public event | ChangeEntityPanelVisible | Occurs when visibility of the entity tree was changed
Public event | ChangeEntityPropertyGridVisible | Occurs when visibility of the entity properties inspector was changed
Public event | ChangeLanguage | Appears when the language of the application was changed
Public event | ChangeLineWeightShow | Occurs when displaying of the lines weight was enabled or disabled
Public event | ChangeSnapEnable | Occurs when the snap was enabled or disabled
Public event | ChangeStatusBarVisible | Occurs when visibility of the status panel was changed
Public event | ChangeTextShow | Occurs when displaying of the texts was enabled or disabled
Public event | ChangeToolsPanelVisible | Occurs when visibility of the tool panel was changed
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | EndLoadFile | Occurs when loading of the file was finished
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before the control becomes visible for the first time. (inherited from UserControl).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | Occurs when the control's margin changes. (inherited from Control).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (inherited from Control).
Public event | TabStopChanged | Occurs when the TabStop property value changes. (inherited from Control).
Public event | TextChanged | (inherited from UserControl).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

CADEditorControl Class
CADImport.CADImportControls Namespace


ChangeBackgroundColor Event

Occurs when the background of the drawing was changed

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeBackgroundColor() As CADImport.CADImportForms.ChangeOptionsEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeOptionsEventHandler ChangeBackgroundColor
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


ChangeDimensionShow Event

Occurs when displaying of the dimensions was enabled or disabled

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeDimensionShow() As CADImport.CADImportForms.ChangeOptionsEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeOptionsEventHandler ChangeDimensionShow
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


ChangeDrawingColors Event

Occurs when the color type of the drawing was changed (black-and-white/color)

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeDrawingColors() As CADImport.CADImportForms.ChangeOptionsEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeOptionsEventHandler ChangeDrawingColors
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


ChangeEntityPanelVisible Event

Occurs when visibility of the entity tree was changed

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeEntityPanelVisible() As CADImport.CADImportForms.ChangeOptionsEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeOptionsEventHandler ChangeEntityPanelVisible
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


ChangeEntityPropertyGridVisible Event

Occurs when visibility of the entity properties inspector was changed

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeEntityPropertyGridVisible() As CADImport.CADImportForms.ChangeOptionsEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeOptionsEventHandler ChangeEntityPropertyGridVisible
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


ChangeLanguage Event

Appears when the language of the application was changed

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeLanguage() As CADImport.CADImportForms.ChangeLanguageEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeLanguageEventHandler ChangeLanguage
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


ChangeLineWeightShow Event

Occurs when displaying of the lines weight was enabled or disabled

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeLineWeightShow() As CADImport.CADImportForms.ChangeOptionsEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeOptionsEventHandler ChangeLineWeightShow
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


ChangeSnapEnable Event

Occurs when the snap was enabled or disabled

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeSnapEnable() As CADImport.CADImportForms.ChangeOptionsEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeOptionsEventHandler ChangeSnapEnable
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


ChangeStatusBarVisible Event

Occurs when visibility of the status panel was changed

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeStatusBarVisible() As CADImport.CADImportForms.ChangeOptionsEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeOptionsEventHandler ChangeStatusBarVisible
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


ChangeTextShow Event

Occurs when displaying of the texts was enabled or disabled

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeTextShow() As CADImport.CADImportForms.ChangeOptionsEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeOptionsEventHandler ChangeTextShow
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


ChangeToolsPanelVisible Event

Occurs when visibility of the tool panel was changed

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeToolsPanelVisible() As CADImport.CADImportForms.ChangeOptionsEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeOptionsEventHandler ChangeToolsPanelVisible
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


EndLoadFile Event

Occurs when loading of the file was finished

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event EndLoadFile() As CADImport.CADImportForms.ChangeOptionsEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeOptionsEventHandler EndLoadFile
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADViewerControl Class

Members See Also

Provides a possibility of viewing CAD files.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADViewerControl
    Inherits UserControl
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADViewerControl : UserControl
This language is not supported or no code example is available.
Remarks

CADViewerControl has an area where to view CAD files and provides complete functionality for manipulating CAD images.

Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
CADImport.CADImportControls.CADViewerControl
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl Members

CADViewerControl Class Constructors Events Methods Properties See Also

Provides a possibility of viewing CAD files.

The following tables list the members exposed by the CADViewerControl type.

Constructors
 | Name | Description
Public constructor | CADViewerControl | Creates a new instance of the CADViewerControl object.
Top
Properties
 | Name | Description
Public property | AboutForm | Gets 'About' window
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (inherited from ScrollableControl).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from UserControl).
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (inherited from UserControl).
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (inherited from UserControl).
Public property | BackColor | Gets or sets the background color for the control. (inherited from Control).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | BorderStyle | Gets or sets the border style of the tree view control. (inherited from UserControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (inherited from Control).
Public property | ColorDraw | Gets a parameter to draw an image in color or black-and-white mode
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | CurrentXClickPosition | The X coordinate of the last mouse click position on the screen.
Public property | CurrentYClickPosition | The Y coordinate of the last mouse click position on the screen.
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DimensionVisible | Gets or sets dimensions visibility
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | EntityPropertyGrid | Gets or sets the entity properties grid
Public property | EntityPropertyGridVisible | Gets or sets visibility of the entity properties grid
Public property | EntityTree | Gets or sets the entities tree
Public property | EntityTreeVisible | Gets or sets visibility of the entities tree
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Image | A CAD image displayed in the main application form.
Public property | ImageDRect | Gets the current size and position of the drawing image
Public property | ImagePreviousScale | A previous value of the scale in which the current CAD image is displayed in the viewer.
Public property | ImageRectangleF | Gets the current size and position of the drawing image
Public property | ImageScale | Gets or sets a scale in which the current CAD image is displayed in the viewer.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InFileName | Gets or sets a name of the file to open
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | LayerForm | Gets or sets the layers settings window
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | LayoutsPanelVisible | Gets or sets visibility of the layouts panel
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | LeftImagePosition | Gets or sets a position of the drawing image by X axis
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (inherited from Control).
Public property | Margin | Gets or sets the space between controls. (inherited from Control).
Public property | MaximumSize | Gets or sets the size that is the upper limit that Size) can specify. (inherited from Control).
Public property | MinimumSize | Gets or sets the size that is the lower limit that Size) can specify. (inherited from Control).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | OptionsForm | Gets or sets the settings window
Public property | Orb3D | Gets or sets Orbit3D control
Public property | OutFileName | Gets or sets a name of the file to save
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | Position | A position of the current CAD image relatively to the top-left corner of the viewer.
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | PreviousPosition | A previous position of the current CAD image relatively to the top-left corner of the viewer.
Public property | PrintPreviewDialog | Gets or sets the standard window of the print preview
Public property | PrintingForm | Gets or sets the preview and printing settings window
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | PropertyEntityPanelVisible | Gets or sets visibility of the entity properties panel
Public property | RasterSizeForm | Gets the SetRasterSizeForm window
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RegistrationForm | Gets or sets the registration window
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | SHXForm | Gets or sets the shx fonts settings window
Public property | SetRasterSizeForm | Gets or sets the settings window for raster images saving
Public property | ShowLineWeight | Gets or sets lines weight visibility
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the height and width of the control. (inherited from Control).
Public property | StatusBarPanel | Gets or sets the status bar panel
Public property | StatusBarPanelVisible | Gets or sets visibility of the status bar panel
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Control).
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (inherited from Control).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from UserControl).
Public property | TextVisible | Gets or sets texts visibility
Public property | ToolsPanel | Gets or sets the tools panel
Public property | ToolsPanelVisible | Gets or sets tools panel visibility
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopImagePosition | Gets or sets a position of the drawing image by Y axis
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | ViewerCADPictureBox | Gets the CADPictureBox control, where an image is drawn
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | VisibleAreaSize | Gets or sets base dimensions of the image drawing area
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | AddSHXPaths | Displays a form in which a user can add or delete the paths to the SHX files.
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | Black_Click | Paints the CAD image background in the black color.
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Change3DAxesVisiblity | Shows or hides 3D axes.
Public method | ChangeControlState | Changes the current state of controls
Public method | ChangeCurrLayoutIndex | Changes current layout in accordance with its new index in the list of layouts.
Public method | ChangeDimensionsVisiblity | Shows or hides dimensions in the current CAD image.
Public method | ChangeDoubleBufferingMode | Enables/disables the double buffering mode
Public method | ChangeSelectionCond | Enables/disables the entity selection mode
Public method | ChangeShowLineWeight | Alternately changes a boolean value that indicates if a thickness of lines is determined by the file data.
Public method | ChangeTextsVisiblity | Shows or hides texts in the current CAD image.
Public method | ChangeTreeVisiblity | Shows or hides a panel that contains the entities tree.
Public method | ChangeTypeFont | Enables or disables shx fonts
Public method | CloseFile | Closes the currently opened CAD file.
Public method | Color_Click | Paints the CAD image background in the user defined color.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoBlackColor | Displays a CAD image in black and white colors.
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DoEnableRectangle | Enables or disables rectangle tool
Public method | DoNormalColor | Displays a CAD image in all used colors.
Public method | DoResize | (Overloaded) Resizes the CAD image to fit drawing's bounds.
Public method | DoZoomIn | Increases a scale of the CAD image by twice.
Public method | DoZoomOut | Decreases a ImageScale of the CAD image by twice.
Public method | DrawCADImage | Draws a CAD image from the loaded CAD file.
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | Enable3DOrbit | Enables/disables 3DOrbit
Public method | EnableButton | Enables or disables buttons of the toolbar and menu items of the main menu.
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetFromClipboard | Loads raster image from the clipboard
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetRealPoint | Gets a three-dimensional point of the current CAD image from the specified screen point.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Go3dOrbit | Alternately displays or hides the 3D Orbit tool.
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | InvalidateImage | Invalidates a specific region of the control and causes a paint message to be sent to the control.
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LoadFile | Loads a CAD file.
Public method | NewProtectionSettings | Fills the specified list with the current protection settings.
Public method | OnChangeBackgroundColor | Invokes the ChangeBackgroundColor event
Public method | OnChangeDimensionShow | Invokes the ChangeDimensionShow event
Public method | OnChangeDrawingColors | Invokes the ChangeDrawingColors event
Public method | OnChangeEntityPanelVisible | Invokes the ChangeEntityPanelVisible event
Public method | OnChangeEntityPropertyGridVisible | Invokes the ChangeEntityPropertyGridVisible event
Public method | OnChangeLanguage | Invokes the ChangeLanguage event
Public method | OnChangeLineWeightShow | Invokes the ChangeLineWeightShow event
Public method | OnChangeSnapEnable | Invokes the ChangeSnapEnables event
Public method | OnChangeStatusBarVisible | Invokes the ChangeStatusBarVisible event
Public method | OnChangeTextShow | Invokes ChangeTextShow event
Public method | OnChangeToolsPanelVisible | Invokes the ChangeToolsPanelVisible event
Public method | OnEndLoadFile | Invokes the EndLoadFile event
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PutToClipboard | Puts an image as a raster to the clipboard
Public method | ReOpen | Reopens a file after selecting or deselecting SHX fonts.
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | Register | Registers the CADImportNet library.
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetScaling | Sets the scale and position of the current CAD image to its original values.
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Rotate2D | Rotates an image (2D rotation)
Public method | SaveAsDXF | (Overloaded) Saves currently opened file as a DXF file
Public method | SaveAsImage | Invokes the SaveFileDialog box where a user can select a directory and format for saving the current CAD image.
Public method | SaveProtectionSettings | Makes the specified settings the current ones.
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBackView | Sets back view of a drawing
Public method | SetBottomView | Sets bottom view of a drawing
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetCADImageOptions | Sets current properties for CADImage for loading file
Public method | SetColorLayer | Sets a color for layer (CADLayer) specified by index
Public method | SetFreezeLayer | Sets freeze parameter for CADLayer
Public method | SetFrontView | Sets the front view of a drawing
Public method | SetInitialView | Sets an initial view of a drawing
Public method | SetLeftView | Sets the left view of a drawing
Public method | SetNEIsometricView | Sets the NE isometric view of a drawing
Public method | SetNWIsometricView | Sets the NW isometric view of a drawing
Public method | SetRightView | Sets the right view of a drawing
Public method | SetSEIsometricView | Sets the SE isometric view of a drawing
Public method | SetSWIsometricView | Sets the SW isometric view of a drawing
Public method | SetSizePictureBox | Sets scroll region for CADPictureBox
Public method | SetTopView | Sets the top view of a drawing
Public method | SetVisibleLayer | Sets layer's visibility
Public method | Show | (Overloaded) Displays the control to the user. (inherited from Control).
Public method | ShowLoadFileDialog | Invokes open file dialog and loads specified file
Public method | ShowOpenFromWebForm | Opens a form to open a file from the web
Public method | ShowRect | For internal use
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (inherited from Component).
Public method | Unregister | Closes all registration resources.
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | UseWinEllipse | Alternately changes a boolean value indicating whether arcs and circles in the CAD image are drawn with GDI+ drawing methods without linearization.
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from UserControl).
Public method | ViewLayouts | Creates a list of layouts of the CAD image and sets the current layout.
Public method | White_Click | Paints the CAD image background in the white color.
Public method | Zoom | Adjusts the image size according to the specified scale.
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from UserControl).
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (inherited from UserControl).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeBackgroundColor | Occurs when the background of the drawing was changed
Public event | ChangeDimensionShow | Occurs when displaying of the dimensions was enabled or disabled
Public event | ChangeDrawingColorsEvent | Occurs when the color type of the drawing was changed (black-and-white/color)
Public event | ChangeEntityPanelVisible | Occurs when visibility of the entity tree was changed
Public event | ChangeEntityPropertyGridVisible | Occurs when visibility of the entity properties inspector was changed
Public event | ChangeLanguage | Occurs when the language of the application was changed
Public event | ChangeLineWeightShow | Occurs when displaying of the lines weight was enabled or disabled
Public event | ChangeSnapEnable | Occurs when the snap was enabled or disabled
Public event | ChangeStatusBarVisible | Occurs when visibility of the status panel was changed
Public event | ChangeTextShow | Occurs when displaying of the texts was enabled or disabled
Public event | ChangeToolsPanelVisible | Occurs when visibility of the tool panel was changed
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | EndLoadFile | Occurs when loading of the file was finished
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before the control becomes visible for the first time. (inherited from UserControl).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | Occurs when the control's margin changes. (inherited from Control).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (inherited from Control).
Public event | TabStopChanged | Occurs when the TabStop property value changes. (inherited from Control).
Public event | TextChanged | (inherited from UserControl).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

CADViewerControl Class
CADImport.CADImportControls Namespace


CADViewerControl Constructor

Creates a new instance of the CADViewerControl object.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADViewerControl()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl Properties

CADViewerControl Class See Also

The following tables list the members exposed by the CADViewerControl type.

Properties
 | Name | Description
Public property | AboutForm | Gets 'About' window
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (inherited from ScrollableControl).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from UserControl).
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (inherited from UserControl).
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (inherited from UserControl).
Public property | BackColor | Gets or sets the background color for the control. (inherited from Control).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | BorderStyle | Gets or sets the border style of the tree view control. (inherited from UserControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (inherited from Control).
Public property | ColorDraw | Gets a parameter to draw an image in color or black-and-white mode
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | CurrentXClickPosition | The X coordinate of the last mouse click position on the screen.
Public property | CurrentYClickPosition | The Y coordinate of the last mouse click position on the screen.
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DimensionVisible | Gets or sets dimensions visibility
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | EntityPropertyGrid | Gets or sets the entity properties grid
Public property | EntityPropertyGridVisible | Gets or sets visibility of the entity properties grid
Public property | EntityTree | Gets or sets the entities tree
Public property | EntityTreeVisible | Gets or sets visibility of the entities tree
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Image | A CAD image displayed in the main application form.
Public property | ImageDRect | Gets the current size and position of the drawing image
Public property | ImagePreviousScale | A previous value of the scale in which the current CAD image is displayed in the viewer.
Public property | ImageRectangleF | Gets the current size and position of the drawing image
Public property | ImageScale | Gets or sets a scale in which the current CAD image is displayed in the viewer.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InFileName | Gets or sets a name of the file to open
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | LayerForm | Gets or sets the layers settings window
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | LayoutsPanelVisible | Gets or sets visibility of the layouts panel
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | LeftImagePosition | Gets or sets a position of the drawing image by X axis
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (inherited from Control).
Public property | Margin | Gets or sets the space between controls. (inherited from Control).
Public property | MaximumSize | Gets or sets the size that is the upper limit that Size) can specify. (inherited from Control).
Public property | MinimumSize | Gets or sets the size that is the lower limit that Size) can specify. (inherited from Control).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | OptionsForm | Gets or sets the settings window
Public property | Orb3D | Gets or sets Orbit3D control
Public property | OutFileName | Gets or sets a name of the file to save
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | Position | A position of the current CAD image relatively to the top-left corner of the viewer.
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | PreviousPosition | A previous position of the current CAD image relatively to the top-left corner of the viewer.
Public property | PrintPreviewDialog | Gets or sets the standard window of the print preview
Public property | PrintingForm | Gets or sets the preview and printing settings window
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | PropertyEntityPanelVisible | Gets or sets visibility of the entity properties panel
Public property | RasterSizeForm | Gets the SetRasterSizeForm window
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RegistrationForm | Gets or sets the registration window
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | SHXForm | Gets or sets the shx fonts settings window
Public property | SetRasterSizeForm | Gets or sets the settings window for raster images saving
Public property | ShowLineWeight | Gets or sets lines weight visibility
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the height and width of the control. (inherited from Control).
Public property | StatusBarPanel | Gets or sets the status bar panel
Public property | StatusBarPanelVisible | Gets or sets visibility of the status bar panel
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Control).
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (inherited from Control).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from UserControl).
Public property | TextVisible | Gets or sets texts visibility
Public property | ToolsPanel | Gets or sets the tools panel
Public property | ToolsPanelVisible | Gets or sets tools panel visibility
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopImagePosition | Gets or sets a position of the drawing image by Y axis
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | ViewerCADPictureBox | Gets the CADPictureBox control, where an image is drawn
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | VisibleAreaSize | Gets or sets base dimensions of the image drawing area
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

CADViewerControl Class
CADImport.CADImportControls Namespace


CADViewerControl.AboutForm Property

Gets 'About' window

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property AboutForm() As AboutForm
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public AboutForm AboutForm {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.ColorDraw Property

Gets a parameter to draw an image in color or black-and-white mode

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ColorDraw() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool ColorDraw {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.CurrentXClickPosition Property

The X coordinate of the last mouse click position on the screen.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property CurrentXClickPosition() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int CurrentXClickPosition {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.CurrentYClickPosition Property

The Y coordinate of the last mouse click position on the screen.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property CurrentYClickPosition() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int CurrentYClickPosition {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.DimensionVisible Property

Gets or sets dimensions visibility

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DimensionVisible() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool DimensionVisible {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.EntityPropertyGrid Property

Gets or sets the entity properties grid

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property EntityPropertyGrid() As CADPropertyGrid
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADPropertyGrid EntityPropertyGrid {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.EntityPropertyGridVisible Property

Gets or sets visibility of the entity properties grid

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property EntityPropertyGridVisible() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool EntityPropertyGridVisible {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.EntityTree Property

Gets or sets the entities tree

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property EntityTree() As TreeView
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public TreeView EntityTree {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.EntityTreeVisible Property

Gets or sets visibility of the entities tree

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property EntityTreeVisible() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool EntityTreeVisible {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.Image Property

A CAD image displayed in the main application form.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Image() As CADImage
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADImage Image {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.ImageDRect Property

Gets the current size and position of the drawing image

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property ImageDRect() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DRect ImageDRect {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.ImagePreviousScale Property

A previous value of the scale in which the current CAD image is displayed in the viewer.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ImagePreviousScale() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float ImagePreviousScale {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.ImageRectangleF Property

Gets the current size and position of the drawing image

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property ImageRectangleF() As RectangleF
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public RectangleF ImageRectangleF {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.ImageScale Property

Gets or sets a scale in which the current CAD image is displayed in the viewer.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ImageScale() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float ImageScale {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.InFileName Property

Gets or sets a name of the file to open

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property InFileName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string InFileName {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.LayerForm Property

Gets or sets the layers settings window

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LayerForm() As LayerForm
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public LayerForm LayerForm {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.LayoutsPanelVisible Property

Gets or sets visibility of the layouts panel

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LayoutsPanelVisible() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool LayoutsPanelVisible {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.LeftImagePosition Property

Gets or sets a position of the drawing image by X axis

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LeftImagePosition() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float LeftImagePosition {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.OptionsForm Property

Gets or sets the settings window

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property OptionsForm() As OptionsForm
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public OptionsForm OptionsForm {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.Orb3D Property

Gets or sets Orbit3D control

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Orb3D() As Orbit3D
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Orbit3D Orb3D {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.OutFileName Property

Gets or sets a name of the file to save

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property OutFileName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string OutFileName {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.Position Property

A position of the current CAD image relatively to the top-left corner of the viewer.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Position() As PointF
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public PointF Position {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.PreviousPosition Property

A previous position of the current CAD image relatively to the top-left corner of the viewer.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PreviousPosition() As PointF
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public PointF PreviousPosition {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.PrintPreviewDialog Property

Gets or sets the standard window of the print preview

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PrintPreviewDialog() As PrintPreviewDialog
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public PrintPreviewDialog PrintPreviewDialog {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.PrintingForm Property

Gets or sets the preview and printing settings window

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PrintingForm() As PrintingForm
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public PrintingForm PrintingForm {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.PropertyEntityPanelVisible Property

Gets or sets visibility of the entity properties panel

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PropertyEntityPanelVisible() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool PropertyEntityPanelVisible {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.RasterSizeForm Property

Gets the SetRasterSizeForm window

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property RasterSizeForm() As SetRasterSizeForm
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SetRasterSizeForm RasterSizeForm {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.RegistrationForm Property

Gets or sets the registration window

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property RegistrationForm() As RegForm
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public RegForm RegistrationForm {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.SHXForm Property

Gets or sets the shx fonts settings window

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property SHXForm() As SHXForm
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SHXForm SHXForm {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.SetRasterSizeForm Property

Gets or sets the settings window for raster images saving

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property SetRasterSizeForm() As SetRasterSizeForm
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SetRasterSizeForm SetRasterSizeForm {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.ShowLineWeight Property

Gets or sets lines weight visibility

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ShowLineWeight() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool ShowLineWeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.StatusBarPanel Property

Gets or sets the status bar panel

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property StatusBarPanel() As StatusBar
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public StatusBar StatusBarPanel {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.StatusBarPanelVisible Property

Gets or sets visibility of the status bar panel

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property StatusBarPanelVisible() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool StatusBarPanelVisible {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.TextVisible Property

Gets or sets texts visibility

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TextVisible() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool TextVisible {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.ToolsPanel Property

Gets or sets the tools panel

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ToolsPanel() As ToolBar
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ToolBar ToolsPanel {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.ToolsPanelVisible Property

Gets or sets tools panel visibility

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ToolsPanelVisible() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool ToolsPanelVisible {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.TopImagePosition Property

Gets or sets a position of the drawing image by Y axis

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TopImagePosition() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float TopImagePosition {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.ViewerCADPictureBox Property

Gets the CADPictureBox control, where an image is drawn

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ViewerCADPictureBox() As CADPictureBox
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADPictureBox ViewerCADPictureBox {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.VisibleAreaSize Property

Gets or sets base dimensions of the image drawing area

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property VisibleAreaSize() As SizeF
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SizeF VisibleAreaSize {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl Methods

CADViewerControl Class See Also

The following tables list the members exposed by the CADViewerControl type.

Methods
 | Name | Description
Public method | AddSHXPaths | Displays a form in which a user can add or delete the paths to the SHX files.
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | Black_Click | Paints the CAD image background in the black color.
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Change3DAxesVisiblity | Shows or hides 3D axes.
Public method | ChangeControlState | Changes the current state of controls
Public method | ChangeCurrLayoutIndex | Changes current layout in accordance with its new index in the list of layouts.
Public method | ChangeDimensionsVisiblity | Shows or hides dimensions in the current CAD image.
Public method | ChangeDoubleBufferingMode | Enables/disables the double buffering mode
Public method | ChangeSelectionCond | Enables/disables the entity selection mode
Public method | ChangeShowLineWeight | Alternately changes a boolean value that indicates if a thickness of lines is determined by the file data.
Public method | ChangeTextsVisiblity | Shows or hides texts in the current CAD image.
Public method | ChangeTreeVisiblity | Shows or hides a panel that contains the entities tree.
Public method | ChangeTypeFont | Enables or disables shx fonts
Public method | CloseFile | Closes the currently opened CAD file.
Public method | Color_Click | Paints the CAD image background in the user defined color.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoBlackColor | Displays a CAD image in black and white colors.
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DoEnableRectangle | Enables or disables rectangle tool
Public method | DoNormalColor | Displays a CAD image in all used colors.
Public method | DoResize | (Overloaded) Resizes the CAD image to fit drawing's bounds.
Public method | DoZoomIn | Increases a scale of the CAD image by twice.
Public method | DoZoomOut | Decreases a ImageScale of the CAD image by twice.
Public method | DrawCADImage | Draws a CAD image from the loaded CAD file.
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | Enable3DOrbit | Enables/disables 3DOrbit
Public method | EnableButton | Enables or disables buttons of the toolbar and menu items of the main menu.
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetFromClipboard | Loads raster image from the clipboard
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetRealPoint | Gets a three-dimensional point of the current CAD image from the specified screen point.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Go3dOrbit | Alternately displays or hides the 3D Orbit tool.
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | InvalidateImage | Invalidates a specific region of the control and causes a paint message to be sent to the control.
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LoadFile | Loads a CAD file.
Public method | NewProtectionSettings | Fills the specified list with the current protection settings.
Public method | OnChangeBackgroundColor | Invokes the ChangeBackgroundColor event
Public method | OnChangeDimensionShow | Invokes the ChangeDimensionShow event
Public method | OnChangeDrawingColors | Invokes the ChangeDrawingColors event
Public method | OnChangeEntityPanelVisible | Invokes the ChangeEntityPanelVisible event
Public method | OnChangeEntityPropertyGridVisible | Invokes the ChangeEntityPropertyGridVisible event
Public method | OnChangeLanguage | Invokes the ChangeLanguage event
Public method | OnChangeLineWeightShow | Invokes the ChangeLineWeightShow event
Public method | OnChangeSnapEnable | Invokes the ChangeSnapEnables event
Public method | OnChangeStatusBarVisible | Invokes the ChangeStatusBarVisible event
Public method | OnChangeTextShow | Invokes ChangeTextShow event
Public method | OnChangeToolsPanelVisible | Invokes the ChangeToolsPanelVisible event
Public method | OnEndLoadFile | Invokes the EndLoadFile event
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PutToClipboard | Puts an image as a raster to the clipboard
Public method | ReOpen | Reopens a file after selecting or deselecting SHX fonts.
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | Register | Registers the CADImportNet library.
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetScaling | Sets the scale and position of the current CAD image to its original values.
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Rotate2D | Rotates an image (2D rotation)
Public method | SaveAsDXF | (Overloaded) Saves currently opened file as a DXF file
Public method | SaveAsImage | Invokes the SaveFileDialog box where a user can select a directory and format for saving the current CAD image.
Public method | SaveProtectionSettings | Makes the specified settings the current ones.
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBackView | Sets back view of a drawing
Public method | SetBottomView | Sets bottom view of a drawing
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetCADImageOptions | Sets current properties for CADImage for loading file
Public method | SetColorLayer | Sets a color for layer (CADLayer) specified by index
Public method | SetFreezeLayer | Sets freeze parameter for CADLayer
Public method | SetFrontView | Sets the front view of a drawing
Public method | SetInitialView | Sets an initial view of a drawing
Public method | SetLeftView | Sets the left view of a drawing
Public method | SetNEIsometricView | Sets the NE isometric view of a drawing
Public method | SetNWIsometricView | Sets the NW isometric view of a drawing
Public method | SetRightView | Sets the right view of a drawing
Public method | SetSEIsometricView | Sets the SE isometric view of a drawing
Public method | SetSWIsometricView | Sets the SW isometric view of a drawing
Public method | SetSizePictureBox | Sets scroll region for CADPictureBox
Public method | SetTopView | Sets the top view of a drawing
Public method | SetVisibleLayer | Sets layer's visibility
Public method | Show | (Overloaded) Displays the control to the user. (inherited from Control).
Public method | ShowLoadFileDialog | Invokes open file dialog and loads specified file
Public method | ShowOpenFromWebForm | Opens a form to open a file from the web
Public method | ShowRect | For internal use
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (inherited from Component).
Public method | Unregister | Closes all registration resources.
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | UseWinEllipse | Alternately changes a boolean value indicating whether arcs and circles in the CAD image are drawn with GDI+ drawing methods without linearization.
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from UserControl).
Public method | ViewLayouts | Creates a list of layouts of the CAD image and sets the current layout.
Public method | White_Click | Paints the CAD image background in the white color.
Public method | Zoom | Adjusts the image size according to the specified scale.
Top
See Also

Reference

CADViewerControl Class
CADImport.CADImportControls Namespace


CADViewerControl.AddSHXPaths Method

Displays a form in which a user can add or delete the paths to the SHX files.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddSHXPaths()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddSHXPaths()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.Black_Click Method

Paints the CAD image background in the black color.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Black_Click()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Black_Click()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.Change3DAxesVisiblity Method

Shows or hides 3D axes.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Change3DAxesVisiblity()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Change3DAxesVisiblity()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.ChangeControlState Method

Changes the current state of controls

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ChangeControlState()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ChangeControlState()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.ChangeCurrLayoutIndex Method

Changes current layout in accordance with its new index in the list of layouts.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ChangeCurrLayoutIndex()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ChangeCurrLayoutIndex()
This language is not supported or no code example is available.
Remarks

A list of layouts is located below the toolbar.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.ChangeDimensionsVisiblity Method

Shows or hides dimensions in the current CAD image.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ChangeDimensionsVisiblity( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ChangeDimensionsVisiblity(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.ChangeDoubleBufferingMode Method

Enables/disables the double buffering mode

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ChangeDoubleBufferingMode()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ChangeDoubleBufferingMode()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.ChangeSelectionCond Method

Enables/disables the entity selection mode

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ChangeSelectionCond( _
   ByVal invalidate As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ChangeSelectionCond(
   bool invalidate
)
This language is not supported or no code example is available.

Parameters

invalidate

Type: bool

Parameter that indicates if it is necessary to redraw corrupted regions of the drawing

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.ChangeShowLineWeight Method

Alternately changes a boolean value that indicates if a thickness of lines is determined by the file data.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ChangeShowLineWeight( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ChangeShowLineWeight(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.ChangeTextsVisiblity Method

Shows or hides texts in the current CAD image.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ChangeTextsVisiblity( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ChangeTextsVisiblity(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.ChangeTreeVisiblity Method

Shows or hides a panel that contains the entities tree.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ChangeTreeVisiblity( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ChangeTreeVisiblity(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.ChangeTypeFont Method

Enables or disables shx fonts

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ChangeTypeFont()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ChangeTypeFont()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.CloseFile Method

Closes the currently opened CAD file.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub CloseFile()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void CloseFile()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.Color_Click Method

Paints the CAD image background in the user defined color.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Color_Click()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Color_Click()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.DoBlackColor Method

Displays a CAD image in black and white colors.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DoBlackColor()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DoBlackColor()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.DoEnableRectangle Method

Enables or disables rectangle tool

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DoEnableRectangle( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DoEnableRectangle(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

Value to set

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.DoNormalColor Method

Displays a CAD image in all used colors.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DoNormalColor()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DoNormalColor()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.DoResize Method

CADViewerControl Class See Also

Resizes the CAD image to fit drawing's bounds.

Overload List
Name | Description
DoResize(RectangleF, bool) |
DoResize(bool) | Resizes the CAD image to fit drawing's bounds.
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.DoZoomIn Method

Increases a scale of the CAD image by twice.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DoZoomIn()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DoZoomIn()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.DoZoomOut Method

Decreases a ImageScale of the CAD image by twice.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DoZoomOut()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DoZoomOut()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.DrawCADImage Method

Draws a CAD image from the loaded CAD file.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DrawCADImage( _
   ByVal gr As Graphics, _
   ByVal control As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DrawCADImage(
   Graphics gr,
   Control control
)
This language is not supported or no code example is available.

Parameters

gr

Type: Graphics

A Graphics object used to draw the CAD entities.

control

Type: Control

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.Enable3DOrbit Method

Enables/disables 3DOrbit

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Enable3DOrbit()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Enable3DOrbit()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.EnableButton Method

Enables or disables buttons of the toolbar and menu items of the main menu.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub EnableButton( _
   ByVal aVal As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void EnableButton(
   bool aVal
)
This language is not supported or no code example is available.

Parameters

aVal

Type: bool

true if buttons and menu items are enabled; false if disabled.

Remarks

The buttons and menu items are enabled after loading a CAD file and become disabled after closing the file.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.GetFromClipboard Method

Loads raster image from the clipboard

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub GetFromClipboard()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void GetFromClipboard()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.GetRealPoint Method

Gets a three-dimensional point of the current CAD image from the specified screen point.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetRealPoint( _
   ByVal x As Integer, _
   ByVal y As Integer _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint GetRealPoint(
   int x,
   int y
)
This language is not supported or no code example is available.

Parameters

x

Type: int

The X coordinate of a screen point.

y

Type: int

The Y coordinate of a screen point.

Return Value

A three-dimensional point.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.Go3dOrbit Method

Alternately displays or hides the 3D Orbit tool.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Go3dOrbit( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Go3dOrbit(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.InvalidateImage Method

Invalidates a specific region of the control and causes a paint message to be sent to the control.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub InvalidateImage()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void InvalidateImage()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.LoadFile Method

Loads a CAD file.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub LoadFile( _
   ByVal fileName As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void LoadFile(
   string fileName
)
This language is not supported or no code example is available.

Parameters

fileName

Type: string

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.NewProtectionSettings Method

Fills the specified list with the current protection settings.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub NewProtectionSettings( _
   ByVal settingsLst As SortedList _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void NewProtectionSettings(
   SortedList settingsLst
)
This language is not supported or no code example is available.

Parameters

settingsLst

Type: SortedList

A SortedList to fill with the current protection settings.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.OnChangeBackgroundColor Method

Invokes the ChangeBackgroundColor event

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnChangeBackgroundColor( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnChangeBackgroundColor(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

If true then background color of the CADImage is black, else the background color is white

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.OnChangeDimensionShow Method

Invokes the ChangeDimensionShow event

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnChangeDimensionShow( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnChangeDimensionShow(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

If false dimensions are disabled, else - enabled

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.OnChangeDrawingColors Method

Invokes the ChangeDrawingColors event

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnChangeDrawingColors( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnChangeDrawingColors(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

If false then an image is drawn in black-and-white, else in color

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.OnChangeEntityPanelVisible Method

Invokes the ChangeEntityPanelVisible event

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub OnChangeEntityPanelVisible( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void OnChangeEntityPanelVisible(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

A value of visibility of entities tree and properties inspector

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.OnChangeEntityPropertyGridVisible Method

Invokes the ChangeEntityPropertyGridVisible event

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub OnChangeEntityPropertyGridVisible( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void OnChangeEntityPropertyGridVisible(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

A setting value of visibility of the entity properties inspector

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.OnChangeLanguage Method

Invokes the ChangeLanguage event

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub OnChangeLanguage( _
   ByVal val As String, _
   ByVal index As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void OnChangeLanguage(
   string val,
   int index
)
This language is not supported or no code example is available.

Parameters

val

Type: string

A language to set

index

Type: int

An index of a language in the language list

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.OnChangeLineWeightShow Method

Invokes the ChangeLineWeightShow event

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnChangeLineWeightShow( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnChangeLineWeightShow(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

If false line weight is disabled, else - enabled

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.OnChangeSnapEnable Method

Invokes the ChangeSnapEnables event

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnChangeSnapEnable( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnChangeSnapEnable(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

Snap is disabled if false, else snap is enabled

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.OnChangeStatusBarVisible Method

Invokes the ChangeStatusBarVisible event

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub OnChangeStatusBarVisible( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void OnChangeStatusBarVisible(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

A setting value of status panel visibility

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.OnChangeTextShow Method

Invokes ChangeTextShow event

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnChangeTextShow( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnChangeTextShow(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

If false texts are disabled, else - enabled

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.OnChangeToolsPanelVisible Method

Invokes the ChangeToolsPanelVisible event

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub OnChangeToolsPanelVisible( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void OnChangeToolsPanelVisible(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

A setting value of tools panel visibility

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.OnEndLoadFile Method

Invokes the EndLoadFile event

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnEndLoadFile( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnEndLoadFile(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

If false the loading is unsuccessful, else - successful

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.PutToClipboard Method

Puts an image as a raster to the clipboard

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub PutToClipboard()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void PutToClipboard()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.ReOpen Method

Reopens a file after selecting or deselecting SHX fonts.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ReOpen()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ReOpen()
This language is not supported or no code example is available.
Remarks

This method is also called when the paths to the files containing SHX fonts have been edited in the SHX Paths window invoked by the SHX Fonts menu item.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.Register Method

Registers the CADImportNet library.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Register()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Register()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.ResetScaling Method

Sets the scale and position of the current CAD image to its original values.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ResetScaling()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ResetScaling()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.Rotate2D Method

Rotates an image (2D rotation)

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Rotate2D( _
   ByVal angle As Single _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Rotate2D(
   float angle
)
This language is not supported or no code example is available.

Parameters

angle

Type: float

An angle to set (degrees)

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.SaveAsDXF Method

CADViewerControl Class See Also

Saves currently opened file as a DXF file

Overload List
Name | Description
SaveAsDXF() | Saves opened file to DXF format
SaveAsDXF(string) | Saves currently opened file as a DXF file
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.SaveAsImage Method

Invokes the SaveFileDialog box where a user can select a directory and format for saving the current CAD image.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SaveAsImage()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SaveAsImage()
This language is not supported or no code example is available.
Remarks

<p>This method can be invoked from the toolbar and from the main menu.</p> <p>Images can be saved in the following formats: JPG, BMP, TIFF, GIF, EMF.</p>

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.SaveProtectionSettings Method

Makes the specified settings the current ones.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SaveProtectionSettings( _
   ByVal settingsLst As SortedList _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SaveProtectionSettings(
   SortedList settingsLst
)
This language is not supported or no code example is available.

Parameters

settingsLst

Type: SortedList

A SortedList containing the settings that will be made current.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.SetBackView Method

Sets back view of a drawing

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetBackView()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetBackView()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.SetBottomView Method

Sets bottom view of a drawing

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetBottomView()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetBottomView()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.SetCADImageOptions Method

Sets current properties for CADImage for loading file

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetCADImageOptions()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetCADImageOptions()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.SetColorLayer Method

Sets a color for layer (CADLayer) specified by index

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetColorLayer( _
   ByVal color As Color, _
   ByVal index As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetColorLayer(
   Color color,
   int index
)
This language is not supported or no code example is available.

Parameters

color

Type: Color

Color to set

index

Type: int

An index of the layer in the collection of layers

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.SetFreezeLayer Method

Sets freeze parameter for CADLayer

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetFreezeLayer( _
   ByVal visible As Boolean, _
   ByVal index As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetFreezeLayer(
   bool visible,
   int index
)
This language is not supported or no code example is available.

Parameters

visible

Type: bool

A value which the specified layer's visibility will be set to

index

Type: int

An index of the layer in the collection of layers

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.SetFrontView Method

Sets the front view of a drawing

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetFrontView()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetFrontView()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.SetInitialView Method

Sets an initial view of a drawing

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetInitialView()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetInitialView()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.SetLeftView Method

Sets the left view of a drawing

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetLeftView()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetLeftView()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.SetNEIsometricView Method

Sets the NE isometric view of a drawing

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetNEIsometricView()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetNEIsometricView()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.SetNWIsometricView Method

Sets the NW isometric view of a drawing

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetNWIsometricView()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetNWIsometricView()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.SetRightView Method

Sets the right view of a drawing

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetRightView()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetRightView()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.SetSEIsometricView Method

Sets the SE isometric view of a drawing

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetSEIsometricView()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetSEIsometricView()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.SetSWIsometricView Method

Sets the SW isometric view of a drawing

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetSWIsometricView()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetSWIsometricView()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.SetSizePictureBox Method

Sets scroll region for CADPictureBox

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetSizePictureBox( _
   ByVal rect As RectangleF _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetSizePictureBox(
   RectangleF rect
)
This language is not supported or no code example is available.

Parameters

rect

Type: RectangleF

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.SetTopView Method

Sets the top view of a drawing

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetTopView()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetTopView()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.SetVisibleLayer Method

Sets layer's visibility

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetVisibleLayer( _
   ByVal visible As Boolean, _
   ByVal index As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetVisibleLayer(
   bool visible,
   int index
)
This language is not supported or no code example is available.

Parameters

visible

Type: bool

A value which specified layer's visibility will be set to

index

Type: int

An index of a layer in the collection of layers

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.ShowLoadFileDialog Method

Invokes open file dialog and loads specified file

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ShowLoadFileDialog()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ShowLoadFileDialog()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.ShowOpenFromWebForm Method

Opens a form to open a file from the web

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ShowOpenFromWebForm()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ShowOpenFromWebForm()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.ShowRect Method

For internal use

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ShowRect( _
   ByVal rect As DRect _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ShowRect(
   DRect rect
)
This language is not supported or no code example is available.

Parameters

rect

Type: DRect

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.Unregister Method

Closes all registration resources.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Unregister()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Unregister()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.UseWinEllipse Method

Alternately changes a boolean value indicating whether arcs and circles in the CAD image are drawn with GDI+ drawing methods without linearization.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub UseWinEllipse()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void UseWinEllipse()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.ViewLayouts Method

Creates a list of layouts of the CAD image and sets the current layout.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ViewLayouts()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ViewLayouts()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.White_Click Method

Paints the CAD image background in the white color.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub White_Click()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void White_Click()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.Zoom Method

Adjusts the image size according to the specified scale.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Zoom( _
   ByVal i As Single _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Zoom(
   float i
)
This language is not supported or no code example is available.

Parameters

i

Type: float

A scale value.

Remarks

If the scale value is more than one the image size increases; otherwise, decreases.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl Events

CADViewerControl Class See Also

The following tables list the members exposed by the CADViewerControl type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from UserControl).
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (inherited from UserControl).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeBackgroundColor | Occurs when the background of the drawing was changed
Public event | ChangeDimensionShow | Occurs when displaying of the dimensions was enabled or disabled
Public event | ChangeDrawingColorsEvent | Occurs when the color type of the drawing was changed (black-and-white/color)
Public event | ChangeEntityPanelVisible | Occurs when visibility of the entity tree was changed
Public event | ChangeEntityPropertyGridVisible | Occurs when visibility of the entity properties inspector was changed
Public event | ChangeLanguage | Occurs when the language of the application was changed
Public event | ChangeLineWeightShow | Occurs when displaying of the lines weight was enabled or disabled
Public event | ChangeSnapEnable | Occurs when the snap was enabled or disabled
Public event | ChangeStatusBarVisible | Occurs when visibility of the status panel was changed
Public event | ChangeTextShow | Occurs when displaying of the texts was enabled or disabled
Public event | ChangeToolsPanelVisible | Occurs when visibility of the tool panel was changed
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | EndLoadFile | Occurs when loading of the file was finished
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before the control becomes visible for the first time. (inherited from UserControl).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | Occurs when the control's margin changes. (inherited from Control).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (inherited from Control).
Public event | TabStopChanged | Occurs when the TabStop property value changes. (inherited from Control).
Public event | TextChanged | (inherited from UserControl).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

CADViewerControl Class
CADImport.CADImportControls Namespace


ChangeBackgroundColor Event

Occurs when the background of the drawing was changed

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeBackgroundColor() As CADImport.CADImportForms.ChangeOptionsEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeOptionsEventHandler ChangeBackgroundColor
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


ChangeDimensionShow Event

Occurs when displaying of the dimensions was enabled or disabled

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeDimensionShow() As CADImport.CADImportForms.ChangeOptionsEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeOptionsEventHandler ChangeDimensionShow
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


ChangeDrawingColorsEvent Event

Occurs when the color type of the drawing was changed (black-and-white/color)

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeDrawingColorsEvent() As CADImport.CADImportForms.ChangeOptionsEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeOptionsEventHandler ChangeDrawingColorsEvent
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


ChangeEntityPanelVisible Event

Occurs when visibility of the entity tree was changed

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeEntityPanelVisible() As CADImport.CADImportForms.ChangeOptionsEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeOptionsEventHandler ChangeEntityPanelVisible
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


ChangeEntityPropertyGridVisible Event

Occurs when visibility of the entity properties inspector was changed

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeEntityPropertyGridVisible() As CADImport.CADImportForms.ChangeOptionsEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeOptionsEventHandler ChangeEntityPropertyGridVisible
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


ChangeLanguage Event

Occurs when the language of the application was changed

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeLanguage() As CADImport.CADImportForms.ChangeLanguageEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeLanguageEventHandler ChangeLanguage
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


ChangeLineWeightShow Event

Occurs when displaying of the lines weight was enabled or disabled

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeLineWeightShow() As CADImport.CADImportForms.ChangeOptionsEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeOptionsEventHandler ChangeLineWeightShow
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


ChangeSnapEnable Event

Occurs when the snap was enabled or disabled

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeSnapEnable() As CADImport.CADImportForms.ChangeOptionsEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeOptionsEventHandler ChangeSnapEnable
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


ChangeStatusBarVisible Event

Occurs when visibility of the status panel was changed

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeStatusBarVisible() As CADImport.CADImportForms.ChangeOptionsEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeOptionsEventHandler ChangeStatusBarVisible
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


ChangeTextShow Event

Occurs when displaying of the texts was enabled or disabled

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeTextShow() As CADImport.CADImportForms.ChangeOptionsEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeOptionsEventHandler ChangeTextShow
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


ChangeToolsPanelVisible Event

Occurs when visibility of the tool panel was changed

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeToolsPanelVisible() As CADImport.CADImportForms.ChangeOptionsEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeOptionsEventHandler ChangeToolsPanelVisible
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


EndLoadFile Event

Occurs when loading of the file was finished

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event EndLoadFile() As CADImport.CADImportForms.ChangeOptionsEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeOptionsEventHandler EndLoadFile
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADImport.CADImportForms Namespace

Assembly: CADImport (in CADImport.dll)

Classes
 | Name | Description
Public class | LayerChangedEventArgs |
Public class | Pattern | Represents a color pattern on the ColorSelector form.
Public class | RichTextBoxEx |
Top
Forms
 | Name | Description
Public class | AboutForm | Represents a form for the "About" dialog in demos.
Public class | BugReportForm | Represents a form for bug report dialog in demos.
Public class | ColorSelector | Represents a form for selecting a color.
Public class | DemoForm | Represens a form that shows unregistered version info dialog.
Public class | EditorOptions | Represents a form for the options dialog in Editor demo.
Public class | GridForm | Provides visual interface for control grid settings
Public class | LayerForm | Represents form for layers window in demos.
Public class | OpenFileFromWebForm | Represents a form that corresponds to the opening of a file from the web dialog
Public class | OptionsForm | Represents a form for the options dialog in Viewer demo.
Public class | RegForm | Represents a form for the registration dialog.
Public class | SHXForm | Represents a form for SHX fonts dialog.
Public class | SetRasterSizeForm | Represents a form for setup of saved file size.
Top
Delegates
 | Name | Description
Public delegate | ChangeLanguageEventHandler | Represents a set of methods which are invoked on changing of the application language. The set is used for ChangeLanguage event.
Public delegate | ChangeLngPathEventHandler | Represents a set of methods which are invoked on changing of the language files directory. The set is used for ChangeLngPath event
Public delegate | ChangeOptionsEventHandler | Represents a set of methods which are invoked on changing of the application settings. The set is used for ChangeEntityPanelVisible, ChangeBackgroundColor, ChangeDrawingColors events
Top
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


LayerChangedEventArgs Class

Members See Also

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class LayerChangedEventArgs
    Inherits EventArgs
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class LayerChangedEventArgs : EventArgs
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.EventArgs
CADImport.CADImportForms.LayerChangedEventArgs
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LayerChangedEventArgs Members
CADImport.CADImportForms Namespace


LayerChangedEventArgs Members

LayerChangedEventArgs Class Constructors Methods Properties See Also

The following tables list the members exposed by the LayerChangedEventArgs type.

Constructors
 | Name | Description
Public constructor | LayerChangedEventArgs | (Overloaded)
Top
Properties
 | Name | Description
Public property | Index |
Public property | Layer |
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

LayerChangedEventArgs Class
CADImport.CADImportForms Namespace


LayerChangedEventArgs Constructor

LayerChangedEventArgs Class See Also

Overload List
Name | Description
LayerChangedEventArgs(CADLayer, int) |
LayerChangedEventArgs() |
See Also

Reference

LayerChangedEventArgs Class
LayerChangedEventArgs Members
CADImport.CADImportForms Namespace


LayerChangedEventArgs Properties

LayerChangedEventArgs Class See Also

The following tables list the members exposed by the LayerChangedEventArgs type.

Properties
 | Name | Description
Public property | Index |
Public property | Layer |
Top
See Also

Reference

LayerChangedEventArgs Class
CADImport.CADImportForms Namespace


LayerChangedEventArgs.Index Property

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Index() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Index {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LayerChangedEventArgs Class
LayerChangedEventArgs Members
CADImport.CADImportForms Namespace


LayerChangedEventArgs.Layer Property

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Layer() As CADLayer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADLayer Layer {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LayerChangedEventArgs Class
LayerChangedEventArgs Members
CADImport.CADImportForms Namespace


LayerChangedEventArgs Methods

LayerChangedEventArgs Class See Also

The following tables list the members exposed by the LayerChangedEventArgs type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

LayerChangedEventArgs Class
CADImport.CADImportForms Namespace


Pattern Class

Members See Also

Represents a color pattern on the ColorSelector form.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class Pattern
    Inherits Label
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class Pattern : Label
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.Label
CADImport.CADImportForms.Pattern
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Pattern Members
CADImport.CADImportForms Namespace


Pattern Members

Pattern Class Constructors Events Methods Properties See Also

Represents a color pattern on the ColorSelector form.

The following tables list the members exposed by the Pattern type.

Constructors
 | Name | Description
Public constructor | Pattern | Initializes a new instance of the Pattern class.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the Label, denoting that the Label text extends beyond the specified length of the Label. (inherited from Label).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoSize | Gets or sets a value indicating whether the control is automatically resized to display its entire contents. (inherited from Label).
Public property | BackColor | Gets or sets the background color for the control. (inherited from Control).
Public property | BackgroundImage | Gets or sets the image rendered on the background of the control. (inherited from Label).
Public property | BackgroundImageLayout | This property is not relevant for this class. (inherited from Label).
Public property | BindingContext | Gets or sets the BindingContext for the control. (inherited from Control).
Public property | BorderStyle | Gets or sets the border style for the control. (inherited from Label).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (inherited from Control).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (inherited from Control).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | FlatStyle | Gets or sets the flat style appearance of the label control. (inherited from Label).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | Image | Gets or sets the image that is displayed on a Label. (inherited from Label).
Public property | ImageAlign | Gets or sets the alignment of an image that is displayed in the control. (inherited from Label).
Public property | ImageIndex | Gets or sets the index value of the image displayed on the Label. (inherited from Label).
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (inherited from Label).
Public property | ImageList | Gets or sets the ImageList that contains the images to display in the Label control. (inherited from Label).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. (inherited from Label).
Public property | Index | Gets an index number of the color Pattern on the ColorSelector form.
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (inherited from Control).
Public property | Margin | Gets or sets the space between controls. (inherited from Control).
Public property | MaximumSize | Gets or sets the size that is the upper limit that Size) can specify. (inherited from Control).
Public property | MinimumSize | Gets or sets the size that is the lower limit that Size) can specify. (inherited from Control).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | PreferredHeight | Gets the preferred height of the control. (inherited from Label).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | PreferredWidth | Gets the preferred width of the control. (inherited from Label).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the height and width of the control. (inherited from Control).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Control).
Public property | TabStop | Gets or sets a value indicating whether the user can tab to the Label. (inherited from Label).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Label).
Public property | TextAlign | Gets or sets the alignment of text in the label. (inherited from Label).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | UseCompatibleTextRendering | Gets or sets a value that specifies whether text rendering should be compatible with previous releases of Windows Forms. (inherited from Label).
Public property | UseMnemonic | Gets or sets a value indicating whether the control interprets an ampersand character (&) in the control's Text property to be an access key prefix character. (inherited from Label).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | (inherited from Label).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | Show | (Overloaded) Displays the control to the user. (inherited from Control).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Label).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (inherited from Label).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the BackgroundImage property changes. (inherited from Label).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Label).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property changes. (inherited from Label).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when the user presses a key while the label has focus. (inherited from Label).
Public event | KeyPress | Occurs when the user presses a key while the label has focus. (inherited from Label).
Public event | KeyUp | Occurs when the user releases a key while the label has focus. (inherited from Label).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | Occurs when the control's margin changes. (inherited from Control).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (inherited from Control).
Public event | TabStopChanged | Occurs when the TabStop property changes. (inherited from Label).
Public event | TextAlignChanged | Occurs when the value of the TextAlign property has changed. (inherited from Label).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

Pattern Class
CADImport.CADImportForms Namespace


Pattern Constructor

Initializes a new instance of the Pattern class.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal ind As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Pattern(
   int ind
)
This language is not supported or no code example is available.

Parameters

ind

Type: int

An int value that defines an index number of the color Pattern on the ColorSelector form.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Pattern Class
Pattern Members
CADImport.CADImportForms Namespace


Pattern Properties

Pattern Class See Also

The following tables list the members exposed by the Pattern type.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the Label, denoting that the Label text extends beyond the specified length of the Label. (inherited from Label).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoSize | Gets or sets a value indicating whether the control is automatically resized to display its entire contents. (inherited from Label).
Public property | BackColor | Gets or sets the background color for the control. (inherited from Control).
Public property | BackgroundImage | Gets or sets the image rendered on the background of the control. (inherited from Label).
Public property | BackgroundImageLayout | This property is not relevant for this class. (inherited from Label).
Public property | BindingContext | Gets or sets the BindingContext for the control. (inherited from Control).
Public property | BorderStyle | Gets or sets the border style for the control. (inherited from Label).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (inherited from Control).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (inherited from Control).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | FlatStyle | Gets or sets the flat style appearance of the label control. (inherited from Label).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | Image | Gets or sets the image that is displayed on a Label. (inherited from Label).
Public property | ImageAlign | Gets or sets the alignment of an image that is displayed in the control. (inherited from Label).
Public property | ImageIndex | Gets or sets the index value of the image displayed on the Label. (inherited from Label).
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (inherited from Label).
Public property | ImageList | Gets or sets the ImageList that contains the images to display in the Label control. (inherited from Label).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. (inherited from Label).
Public property | Index | Gets an index number of the color Pattern on the ColorSelector form.
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (inherited from Control).
Public property | Margin | Gets or sets the space between controls. (inherited from Control).
Public property | MaximumSize | Gets or sets the size that is the upper limit that Size) can specify. (inherited from Control).
Public property | MinimumSize | Gets or sets the size that is the lower limit that Size) can specify. (inherited from Control).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | PreferredHeight | Gets the preferred height of the control. (inherited from Label).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | PreferredWidth | Gets the preferred width of the control. (inherited from Label).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the height and width of the control. (inherited from Control).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Control).
Public property | TabStop | Gets or sets a value indicating whether the user can tab to the Label. (inherited from Label).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Label).
Public property | TextAlign | Gets or sets the alignment of text in the label. (inherited from Label).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | UseCompatibleTextRendering | Gets or sets a value that specifies whether text rendering should be compatible with previous releases of Windows Forms. (inherited from Label).
Public property | UseMnemonic | Gets or sets a value indicating whether the control interprets an ampersand character (&) in the control's Text property to be an access key prefix character. (inherited from Label).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

Pattern Class
CADImport.CADImportForms Namespace


Pattern.Index Property

Gets an index number of the color Pattern on the ColorSelector form.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Index() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Index {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Pattern Class
Pattern Members
CADImport.CADImportForms Namespace


Pattern Methods

Pattern Class See Also

The following tables list the members exposed by the Pattern type.

Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | (inherited from Label).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | Show | (Overloaded) Displays the control to the user. (inherited from Control).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Label).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Top
See Also

Reference

Pattern Class
CADImport.CADImportForms Namespace


Pattern Events

Pattern Class See Also

The following tables list the members exposed by the Pattern type.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (inherited from Label).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the BackgroundImage property changes. (inherited from Label).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Label).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property changes. (inherited from Label).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when the user presses a key while the label has focus. (inherited from Label).
Public event | KeyPress | Occurs when the user presses a key while the label has focus. (inherited from Label).
Public event | KeyUp | Occurs when the user releases a key while the label has focus. (inherited from Label).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | Occurs when the control's margin changes. (inherited from Control).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (inherited from Control).
Public event | TabStopChanged | Occurs when the TabStop property changes. (inherited from Label).
Public event | TextAlignChanged | Occurs when the value of the TextAlign property has changed. (inherited from Label).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

Pattern Class
CADImport.CADImportForms Namespace


RichTextBoxEx Class

Members See Also

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class RichTextBoxEx
    Inherits RichTextBox
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class RichTextBoxEx : RichTextBox
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.TextBoxBase
System.Windows.Forms.RichTextBox
CADImport.CADImportForms.RichTextBoxEx
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RichTextBoxEx Members
CADImport.CADImportForms Namespace


RichTextBoxEx Members

RichTextBoxEx Class Constructors Events Methods Properties See Also

The following tables list the members exposed by the RichTextBoxEx type.

Constructors
 | Name | Description
Public constructor | RichTextBoxEx |
Top
Properties
 | Name | Description
Public property | AcceptsTab | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order. (inherited from TextBoxBase).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | AllowDrop | Gets or sets a value indicating whether the control will enable drag-and-drop operations. (inherited from RichTextBox).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoSize | This property is not relevant to this class. (inherited from RichTextBox).
Public property | AutoWordSelection | Gets or sets a value indicating whether automatic word selection is enabled. (inherited from RichTextBox).
Public property | BackColor | Gets or sets the background color of the control. (inherited from TextBoxBase).
Public property | BackgroundImage | This property is not relevant to this class. (inherited from RichTextBox).
Public property | BackgroundImageLayout | This property is not relevant to this class. (inherited from RichTextBox).
Public property | BindingContext | Gets or sets the BindingContext for the control. (inherited from Control).
Public property | BorderStyle | Gets or sets the border type of the text box control. (inherited from TextBoxBase).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | BulletIndent | Gets or sets the indentation used in the RichTextBox control when the bullet style is applied to the text. (inherited from RichTextBox).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanRedo | Gets a value indicating whether there are actions that have occurred within the RichTextBox that can be reapplied. (inherited from RichTextBox).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (inherited from TextBoxBase).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (inherited from Control).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DetectUrls |
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (inherited from Control).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | EnableAutoDragDrop | Gets or sets a value that enables drag-and-drop operations on text, pictures, and other data. (inherited from RichTextBox).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font used when displaying text in the control. (inherited from RichTextBox).
Public property | ForeColor | Gets or sets the font used when displaying text in the control. (inherited from RichTextBox).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus. (inherited from TextBoxBase).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | LanguageOption | Gets or sets a value that indicates RichTextBox settings for Input Method Editor (IME) and Asian language support. (inherited from RichTextBox).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | Lines | Gets or sets the lines of text in a text box control. (inherited from TextBoxBase).
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (inherited from Control).
Public property | Margin | Gets or sets the space between controls. (inherited from Control).
Public property | MaxLength | Gets or sets the maximum number of characters the user can type or paste into the rich text box control. (inherited from RichTextBox).
Public property | MaximumSize | Gets or sets the size that is the upper limit that Size) can specify. (inherited from Control).
Public property | MinimumSize | Gets or sets the size that is the lower limit that Size) can specify. (inherited from Control).
Public property | Modified | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set. (inherited from TextBoxBase).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | Multiline | Gets or sets a value indicating whether this is a multiline RichTextBox control. (inherited from RichTextBox).
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Padding | This property is not relevant for this class. (inherited from TextBoxBase).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | PreferredHeight | Gets the preferred height for a text box. (inherited from TextBoxBase).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | ReadOnly | Gets or sets a value indicating whether text in the text box is read-only. (inherited from TextBoxBase).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | RedoActionName | Gets the name of the action that can be reapplied to the control when the Redo method is called. (inherited from RichTextBox).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RichTextShortcutsEnabled | This property is not relevant for this class. (inherited from RichTextBox).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightMargin | Gets or sets the size of a single line of text within the RichTextBox control. (inherited from RichTextBox).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | Rtf | Gets or sets the text of the RichTextBox control, including all rich text format (RTF) codes. (inherited from RichTextBox).
Public property | ScrollBars | Gets or sets the type of scroll bars to display in the RichTextBox control. (inherited from RichTextBox).
Public property | SelectedRtf | Gets or sets the currently selected rich text format (RTF) formatted text in the control. (inherited from RichTextBox).
Public property | SelectedText | Gets or sets the selected text within the RichTextBox. (inherited from RichTextBox).
Public property | SelectionAlignment | Gets or sets the alignment to apply to the current selection or insertion point. (inherited from RichTextBox).
Public property | SelectionBackColor | Gets or sets the color of text when the text is selected in a RichTextBox control. (inherited from RichTextBox).
Public property | SelectionBullet | Gets or sets a value indicating whether the bullet style is applied to the current selection or insertion point. (inherited from RichTextBox).
Public property | SelectionCharOffset | Gets or sets whether text in the control appears on the baseline, as a superscript, or as a subscript below the baseline. (inherited from RichTextBox).
Public property | SelectionColor | Gets or sets the text color of the current text selection or insertion point. (inherited from RichTextBox).
Public property | SelectionFont | Gets or sets the font of the current text selection or insertion point. (inherited from RichTextBox).
Public property | SelectionHangingIndent | Gets or sets the distance between the left edge of the first line of text in the selected paragraph and the left edge of subsequent lines in the same paragraph. (inherited from RichTextBox).
Public property | SelectionIndent | Gets or sets the distance in pixels between the left edge of the RichTextBox and the left edge of the current text selection or text added after the insertion point. (inherited from RichTextBox).
Public property | SelectionLength | Gets or sets the number of characters selected in control. (inherited from RichTextBox).
Public property | SelectionProtected | Gets or sets a value indicating whether the current text selection is protected. (inherited from RichTextBox).
Public property | SelectionRightIndent | The distance (in pixels) between the right edge of the RichTextBox control and the right edge of the text that is selected or added at the current insertion point. (inherited from RichTextBox).
Public property | SelectionStart | Gets or sets the starting point of text selected in the text box. (inherited from TextBoxBase).
Public property | SelectionTabs | Gets or sets the absolute tab stop positions in a RichTextBox control. (inherited from RichTextBox).
Public property | SelectionType | Gets the selection type within the control. (inherited from RichTextBox).
Public property | ShortcutsEnabled | Gets or sets a value indicating whether the defined shortcuts are enabled. (inherited from TextBoxBase).
Public property | ShowSelectionMargin | Gets or sets a value indicating whether a selection margin is displayed in the RichTextBox. (inherited from RichTextBox).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the height and width of the control. (inherited from Control).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Control).
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (inherited from Control).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | Gets or sets the current text in the rich text box. (inherited from RichTextBox).
Public property | TextLength | (inherited from RichTextBox).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | UndoActionName | Gets the name of the action that can be undone in the control when the Undo method is called. (inherited from RichTextBox).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Public property | WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary. (inherited from TextBoxBase).
Public property | ZoomFactor | Gets or sets the current zoom level of the RichTextBox. (inherited from RichTextBox).
Top
Methods
 | Name | Description
Public method | AppendText | Appends text to the current text of a text box. (inherited from TextBoxBase).
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | CanPaste | (inherited from RichTextBox).
Public method | Clear | Clears all text from the text box control. (inherited from TextBoxBase).
Public method | ClearUndo | Clears information about the most recent operation from the undo buffer of the text box. (inherited from TextBoxBase).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | Copy | Copies the current selection in the text box to the Clipboard. (inherited from TextBoxBase).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Cut | Moves the current selection in the text box to the Clipboard. (inherited from TextBoxBase).
Public method | DeselectAll | Specifies that the value of the SelectionLength property is zero so that no characters are selected in the control. (inherited from TextBoxBase).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) This method is not relevant for this class. (inherited from RichTextBox).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | Find | (Overloaded) Searches the text in a RichTextBox control for a string. (inherited from RichTextBox).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
Public method | GetCharFromPosition | Retrieves the character that is closest to the specified location within the control. (inherited from TextBoxBase).
Public method | GetCharIndexFromPosition | Retrieves the index of the character nearest to the specified location. (inherited from RichTextBox).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetFirstCharIndexFromLine | Retrieves the index of the first character of a given line. (inherited from TextBoxBase).
Public method | GetFirstCharIndexOfCurrentLine | Retrieves the index of the first character of the current line. (inherited from TextBoxBase).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetLineFromCharIndex | Retrieves the line number from the specified character position within the text of the RichTextBox control. (inherited from RichTextBox).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPositionFromCharIndex | Retrieves the location within the control at the specified character index. (inherited from RichTextBox).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetSelectionLink | Get the link style for the current selection
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | InsertLink | (Overloaded) Insert a given text as a link into the RichTextBox at the current insert position.
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LoadFile | (Overloaded) Loads a rich text format (RTF) or standard ASCII text file into the RichTextBox control. (inherited from RichTextBox).
Public method | Paste | (Overloaded) (inherited from RichTextBox).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
Public method | Redo | Reapplies the last operation that was undone in the control. (inherited from RichTextBox).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | SaveFile | (Overloaded) Saves the contents of the RichTextBox to a rich text format (RTF) file. (inherited from RichTextBox).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollToCaret | Scrolls the contents of the control to the current caret position. (inherited from TextBoxBase).
Public method | Select | (Overloaded) Selects a range of text in the text box. (inherited from TextBoxBase).
Public method | SelectAll | Selects all text in the text box. (inherited from TextBoxBase).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetSelectionLink | Set the current selection's link style
Public method | Show | (Overloaded) Displays the control to the user. (inherited from Control).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | Returns a string that represents the TextBoxBase control. (inherited from TextBoxBase).
Public method | Undo | Undoes the last edit operation in the text box. (inherited from TextBoxBase).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Top
Events
 | Name | Description
Public event | AcceptsTabChanged | Occurs when the value of the AcceptsTab property has changed. (inherited from TextBoxBase).
Public event | AutoSizeChanged | This event is not relevant for this class. (inherited from TextBoxBase).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from RichTextBox).
Public event | BackgroundImageLayoutChanged | Occurs when the value of the BackgroundImageLayout property changes. (inherited from RichTextBox).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | BorderStyleChanged | Occurs when the value of the BorderStyle property has changed. (inherited from TextBoxBase).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the text box is clicked. (inherited from TextBoxBase).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | ContentsResized | Occurs when contents within the control are resized. (inherited from RichTextBox).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when the user completes a drag-and-drop (inherited from RichTextBox).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from RichTextBox).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from RichTextBox).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from RichTextBox).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from RichTextBox).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HScroll | Occurs when the user clicks the horizontal scroll bar of the control. (inherited from RichTextBox).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | HideSelectionChanged | Occurs when the value of the HideSelection property has changed. (inherited from TextBoxBase).
Public event | ImeChange | Occurs when the user switches input methods on an Asian version of the Windows operating system. (inherited from RichTextBox).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | LinkClicked | Occurs when the user clicks on a link within the text of the control. (inherited from RichTextBox).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | Occurs when the control's margin changes. (inherited from Control).
Public event | ModifiedChanged | Occurs when the value of the Modified property has changed. (inherited from TextBoxBase).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from TextBoxBase).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | MultilineChanged | Occurs when the value of the Multiline property has changed. (inherited from TextBoxBase).
Public event | PaddingChanged | This event is not relevant for this class. (inherited from TextBoxBase).
Public event | Paint | Occurs when the control is redrawn. This event is not relevant for this class. (inherited from TextBoxBase).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | Protected | Occurs when the user attempts to modify protected text in the control. (inherited from RichTextBox).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | This event is not relevant to this class. (inherited from RichTextBox).
Public event | ReadOnlyChanged | Occurs when the value of the ReadOnly property has changed. (inherited from TextBoxBase).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | SelectionChanged | Occurs when the selection of text within the control has changed. (inherited from RichTextBox).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (inherited from Control).
Public event | TabStopChanged | Occurs when the TabStop property value changes. (inherited from Control).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | VScroll | Occurs when the user clicks the vertical scroll bars of the control. (inherited from RichTextBox).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

RichTextBoxEx Class
CADImport.CADImportForms Namespace


RichTextBoxEx Constructor

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public RichTextBoxEx()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RichTextBoxEx Class
RichTextBoxEx Members
CADImport.CADImportForms Namespace


RichTextBoxEx Properties

RichTextBoxEx Class See Also

The following tables list the members exposed by the RichTextBoxEx type.

Properties
 | Name | Description
Public property | AcceptsTab | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order. (inherited from TextBoxBase).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | AllowDrop | Gets or sets a value indicating whether the control will enable drag-and-drop operations. (inherited from RichTextBox).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoSize | This property is not relevant to this class. (inherited from RichTextBox).
Public property | AutoWordSelection | Gets or sets a value indicating whether automatic word selection is enabled. (inherited from RichTextBox).
Public property | BackColor | Gets or sets the background color of the control. (inherited from TextBoxBase).
Public property | BackgroundImage | This property is not relevant to this class. (inherited from RichTextBox).
Public property | BackgroundImageLayout | This property is not relevant to this class. (inherited from RichTextBox).
Public property | BindingContext | Gets or sets the BindingContext for the control. (inherited from Control).
Public property | BorderStyle | Gets or sets the border type of the text box control. (inherited from TextBoxBase).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | BulletIndent | Gets or sets the indentation used in the RichTextBox control when the bullet style is applied to the text. (inherited from RichTextBox).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanRedo | Gets a value indicating whether there are actions that have occurred within the RichTextBox that can be reapplied. (inherited from RichTextBox).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (inherited from TextBoxBase).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (inherited from Control).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DetectUrls |
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (inherited from Control).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | EnableAutoDragDrop | Gets or sets a value that enables drag-and-drop operations on text, pictures, and other data. (inherited from RichTextBox).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font used when displaying text in the control. (inherited from RichTextBox).
Public property | ForeColor | Gets or sets the font used when displaying text in the control. (inherited from RichTextBox).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus. (inherited from TextBoxBase).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | LanguageOption | Gets or sets a value that indicates RichTextBox settings for Input Method Editor (IME) and Asian language support. (inherited from RichTextBox).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | Lines | Gets or sets the lines of text in a text box control. (inherited from TextBoxBase).
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (inherited from Control).
Public property | Margin | Gets or sets the space between controls. (inherited from Control).
Public property | MaxLength | Gets or sets the maximum number of characters the user can type or paste into the rich text box control. (inherited from RichTextBox).
Public property | MaximumSize | Gets or sets the size that is the upper limit that Size) can specify. (inherited from Control).
Public property | MinimumSize | Gets or sets the size that is the lower limit that Size) can specify. (inherited from Control).
Public property | Modified | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set. (inherited from TextBoxBase).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | Multiline | Gets or sets a value indicating whether this is a multiline RichTextBox control. (inherited from RichTextBox).
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Padding | This property is not relevant for this class. (inherited from TextBoxBase).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | PreferredHeight | Gets the preferred height for a text box. (inherited from TextBoxBase).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | ReadOnly | Gets or sets a value indicating whether text in the text box is read-only. (inherited from TextBoxBase).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | RedoActionName | Gets the name of the action that can be reapplied to the control when the Redo method is called. (inherited from RichTextBox).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RichTextShortcutsEnabled | This property is not relevant for this class. (inherited from RichTextBox).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightMargin | Gets or sets the size of a single line of text within the RichTextBox control. (inherited from RichTextBox).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | Rtf | Gets or sets the text of the RichTextBox control, including all rich text format (RTF) codes. (inherited from RichTextBox).
Public property | ScrollBars | Gets or sets the type of scroll bars to display in the RichTextBox control. (inherited from RichTextBox).
Public property | SelectedRtf | Gets or sets the currently selected rich text format (RTF) formatted text in the control. (inherited from RichTextBox).
Public property | SelectedText | Gets or sets the selected text within the RichTextBox. (inherited from RichTextBox).
Public property | SelectionAlignment | Gets or sets the alignment to apply to the current selection or insertion point. (inherited from RichTextBox).
Public property | SelectionBackColor | Gets or sets the color of text when the text is selected in a RichTextBox control. (inherited from RichTextBox).
Public property | SelectionBullet | Gets or sets a value indicating whether the bullet style is applied to the current selection or insertion point. (inherited from RichTextBox).
Public property | SelectionCharOffset | Gets or sets whether text in the control appears on the baseline, as a superscript, or as a subscript below the baseline. (inherited from RichTextBox).
Public property | SelectionColor | Gets or sets the text color of the current text selection or insertion point. (inherited from RichTextBox).
Public property | SelectionFont | Gets or sets the font of the current text selection or insertion point. (inherited from RichTextBox).
Public property | SelectionHangingIndent | Gets or sets the distance between the left edge of the first line of text in the selected paragraph and the left edge of subsequent lines in the same paragraph. (inherited from RichTextBox).
Public property | SelectionIndent | Gets or sets the distance in pixels between the left edge of the RichTextBox and the left edge of the current text selection or text added after the insertion point. (inherited from RichTextBox).
Public property | SelectionLength | Gets or sets the number of characters selected in control. (inherited from RichTextBox).
Public property | SelectionProtected | Gets or sets a value indicating whether the current text selection is protected. (inherited from RichTextBox).
Public property | SelectionRightIndent | The distance (in pixels) between the right edge of the RichTextBox control and the right edge of the text that is selected or added at the current insertion point. (inherited from RichTextBox).
Public property | SelectionStart | Gets or sets the starting point of text selected in the text box. (inherited from TextBoxBase).
Public property | SelectionTabs | Gets or sets the absolute tab stop positions in a RichTextBox control. (inherited from RichTextBox).
Public property | SelectionType | Gets the selection type within the control. (inherited from RichTextBox).
Public property | ShortcutsEnabled | Gets or sets a value indicating whether the defined shortcuts are enabled. (inherited from TextBoxBase).
Public property | ShowSelectionMargin | Gets or sets a value indicating whether a selection margin is displayed in the RichTextBox. (inherited from RichTextBox).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the height and width of the control. (inherited from Control).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Control).
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (inherited from Control).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | Gets or sets the current text in the rich text box. (inherited from RichTextBox).
Public property | TextLength | (inherited from RichTextBox).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | UndoActionName | Gets the name of the action that can be undone in the control when the Undo method is called. (inherited from RichTextBox).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Public property | WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary. (inherited from TextBoxBase).
Public property | ZoomFactor | Gets or sets the current zoom level of the RichTextBox. (inherited from RichTextBox).
Top
See Also

Reference

RichTextBoxEx Class
CADImport.CADImportForms Namespace


RichTextBoxEx.DetectUrls Property

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shadows Property DetectUrls() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
new public bool DetectUrls {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RichTextBoxEx Class
RichTextBoxEx Members
CADImport.CADImportForms Namespace


RichTextBoxEx Methods

RichTextBoxEx Class See Also

The following tables list the members exposed by the RichTextBoxEx type.

Methods
 | Name | Description
Public method | AppendText | Appends text to the current text of a text box. (inherited from TextBoxBase).
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | CanPaste | (inherited from RichTextBox).
Public method | Clear | Clears all text from the text box control. (inherited from TextBoxBase).
Public method | ClearUndo | Clears information about the most recent operation from the undo buffer of the text box. (inherited from TextBoxBase).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | Copy | Copies the current selection in the text box to the Clipboard. (inherited from TextBoxBase).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Cut | Moves the current selection in the text box to the Clipboard. (inherited from TextBoxBase).
Public method | DeselectAll | Specifies that the value of the SelectionLength property is zero so that no characters are selected in the control. (inherited from TextBoxBase).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) This method is not relevant for this class. (inherited from RichTextBox).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | Find | (Overloaded) Searches the text in a RichTextBox control for a string. (inherited from RichTextBox).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
Public method | GetCharFromPosition | Retrieves the character that is closest to the specified location within the control. (inherited from TextBoxBase).
Public method | GetCharIndexFromPosition | Retrieves the index of the character nearest to the specified location. (inherited from RichTextBox).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetFirstCharIndexFromLine | Retrieves the index of the first character of a given line. (inherited from TextBoxBase).
Public method | GetFirstCharIndexOfCurrentLine | Retrieves the index of the first character of the current line. (inherited from TextBoxBase).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetLineFromCharIndex | Retrieves the line number from the specified character position within the text of the RichTextBox control. (inherited from RichTextBox).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPositionFromCharIndex | Retrieves the location within the control at the specified character index. (inherited from RichTextBox).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetSelectionLink | Get the link style for the current selection
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | InsertLink | (Overloaded) Insert a given text as a link into the RichTextBox at the current insert position.
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LoadFile | (Overloaded) Loads a rich text format (RTF) or standard ASCII text file into the RichTextBox control. (inherited from RichTextBox).
Public method | Paste | (Overloaded) (inherited from RichTextBox).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
Public method | Redo | Reapplies the last operation that was undone in the control. (inherited from RichTextBox).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | SaveFile | (Overloaded) Saves the contents of the RichTextBox to a rich text format (RTF) file. (inherited from RichTextBox).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollToCaret | Scrolls the contents of the control to the current caret position. (inherited from TextBoxBase).
Public method | Select | (Overloaded) Selects a range of text in the text box. (inherited from TextBoxBase).
Public method | SelectAll | Selects all text in the text box. (inherited from TextBoxBase).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetSelectionLink | Set the current selection's link style
Public method | Show | (Overloaded) Displays the control to the user. (inherited from Control).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | Returns a string that represents the TextBoxBase control. (inherited from TextBoxBase).
Public method | Undo | Undoes the last edit operation in the text box. (inherited from TextBoxBase).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Top
See Also

Reference

RichTextBoxEx Class
CADImport.CADImportForms Namespace


RichTextBoxEx.GetSelectionLink Method

Get the link style for the current selection

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetSelectionLink() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int GetSelectionLink()
This language is not supported or no code example is available.

Return Value

0: link style not set, 1: link style set, -1: mixed
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RichTextBoxEx Class
RichTextBoxEx Members
CADImport.CADImportForms Namespace


RichTextBoxEx.InsertLink Method

RichTextBoxEx Class See Also

Insert a given text as a link into the RichTextBox at the current insert position.

Overload List
Name | Description
InsertLink(string) | Insert a given text as a link into the RichTextBox at the current insert position.
InsertLink(string, int) | Insert a given text at a given position as a link.
InsertLink(string, string) | Insert a given text at at the current input position as a link. The link text is followed by a hash (#) and the given hyperlink text, both of them invisible. When clicked on, the whole link text and hyperlink string are given in the LinkClickedEventArgs.
InsertLink(string, string, int) | Insert a given text at a given position as a link. The link text is followed by a hash (#) and the given hyperlink text, both of them invisible. When clicked on, the whole link text and hyperlink string are given in the LinkClickedEventArgs.
See Also

Reference

RichTextBoxEx Class
RichTextBoxEx Members
CADImport.CADImportForms Namespace


RichTextBoxEx.SetSelectionLink Method

Set the current selection's link style

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetSelectionLink( _
   ByVal link As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetSelectionLink(
   bool link
)
This language is not supported or no code example is available.

Parameters

link

Type: bool

true: set link style, false: clear link style

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RichTextBoxEx Class
RichTextBoxEx Members
CADImport.CADImportForms Namespace


RichTextBoxEx Events

RichTextBoxEx Class See Also

The following tables list the members exposed by the RichTextBoxEx type.

Events
 | Name | Description
Public event | AcceptsTabChanged | Occurs when the value of the AcceptsTab property has changed. (inherited from TextBoxBase).
Public event | AutoSizeChanged | This event is not relevant for this class. (inherited from TextBoxBase).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from RichTextBox).
Public event | BackgroundImageLayoutChanged | Occurs when the value of the BackgroundImageLayout property changes. (inherited from RichTextBox).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | BorderStyleChanged | Occurs when the value of the BorderStyle property has changed. (inherited from TextBoxBase).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the text box is clicked. (inherited from TextBoxBase).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | ContentsResized | Occurs when contents within the control are resized. (inherited from RichTextBox).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when the user completes a drag-and-drop (inherited from RichTextBox).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from RichTextBox).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from RichTextBox).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from RichTextBox).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from RichTextBox).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HScroll | Occurs when the user clicks the horizontal scroll bar of the control. (inherited from RichTextBox).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | HideSelectionChanged | Occurs when the value of the HideSelection property has changed. (inherited from TextBoxBase).
Public event | ImeChange | Occurs when the user switches input methods on an Asian version of the Windows operating system. (inherited from RichTextBox).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | LinkClicked | Occurs when the user clicks on a link within the text of the control. (inherited from RichTextBox).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | Occurs when the control's margin changes. (inherited from Control).
Public event | ModifiedChanged | Occurs when the value of the Modified property has changed. (inherited from TextBoxBase).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from TextBoxBase).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | MultilineChanged | Occurs when the value of the Multiline property has changed. (inherited from TextBoxBase).
Public event | PaddingChanged | This event is not relevant for this class. (inherited from TextBoxBase).
Public event | Paint | Occurs when the control is redrawn. This event is not relevant for this class. (inherited from TextBoxBase).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | Protected | Occurs when the user attempts to modify protected text in the control. (inherited from RichTextBox).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | This event is not relevant to this class. (inherited from RichTextBox).
Public event | ReadOnlyChanged | Occurs when the value of the ReadOnly property has changed. (inherited from TextBoxBase).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | SelectionChanged | Occurs when the selection of text within the control has changed. (inherited from RichTextBox).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (inherited from Control).
Public event | TabStopChanged | Occurs when the TabStop property value changes. (inherited from Control).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | VScroll | Occurs when the user clicks the vertical scroll bars of the control. (inherited from RichTextBox).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

RichTextBoxEx Class
CADImport.CADImportForms Namespace


AboutForm Class

Members See Also

Represents a form for the "About" dialog in demos.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class AboutForm
    Inherits Form
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class AboutForm : Form
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
CADImport.CADImportForms.AboutForm
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AboutForm Members
CADImport.CADImportForms Namespace


AboutForm Members

AboutForm Class Constructors Events Methods Properties See Also

Represents a form for the "About" dialog in demos.

The following tables list the members exposed by the AboutForm type.

Constructors
 | Name | Description
Public constructor | AboutForm | Initializes a new instance of AboutForm class.
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
 | ActiveForm | Gets the currently active form for this application. (inherited from Form).
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form).
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Form).
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form).
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form).
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Icon | Gets or sets the icon for the form. (inherited from Form).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form).
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form).
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | LngFileName | Gets or sets a name of the language files (.lng)
Public property | Location | (inherited from Form).
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form).
Public property | Margin | (inherited from Form).
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form).
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form).
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form).
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form).
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form).
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form).
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | MultipleLanguagesPath | Gets or sets a path to the folder, that contains language files (.lng)
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form).
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form).
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form).
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form).
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the size of the form. (inherited from Form).
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form).
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form).
Public property | TabStop | (inherited from Form).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form).
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowState | Gets or sets the form's window state. (inherited from Form).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form).
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Close | Closes the form. (inherited from Form).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Gets the size when autoscaling the form based on a specified font. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form).
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form).
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form).
Public method | Show | (Overloaded) Shows the form with the specified owner to the user. (inherited from Form).
Public method | ShowDialog | (Overloaded) Shows the form as a modal dialog box with the currently active window set as its owner. (inherited from Form).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Form).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form).
Public event | AutoSizeChanged | (inherited from Form).
Public event | AutoValidateChanged | (inherited from Form).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | Closed | Occurs when the form is closed. (inherited from Form).
Public event | Closing | Occurs when the form is closing. (inherited from Form).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | FormClosed | Occurs after the form is closed. (inherited from Form).
Public event | FormClosing | Occurs before the form is closed. (inherited from Form).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form).
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | (inherited from Form).
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form).
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form).
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form).
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form).
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form).
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form).
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form).
Public event | TabStopChanged | (inherited from Form).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

AboutForm Class
CADImport.CADImportForms Namespace


AboutForm Constructor

Initializes a new instance of AboutForm class.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public AboutForm()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AboutForm Class
AboutForm Members
CADImport.CADImportForms Namespace


AboutForm Properties

AboutForm Class See Also

The following tables list the members exposed by the AboutForm type.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
 | ActiveForm | Gets the currently active form for this application. (inherited from Form).
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form).
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Form).
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form).
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form).
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Icon | Gets or sets the icon for the form. (inherited from Form).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form).
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form).
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | LngFileName | Gets or sets a name of the language files (.lng)
Public property | Location | (inherited from Form).
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form).
Public property | Margin | (inherited from Form).
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form).
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form).
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form).
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form).
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form).
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form).
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | MultipleLanguagesPath | Gets or sets a path to the folder, that contains language files (.lng)
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form).
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form).
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form).
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form).
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the size of the form. (inherited from Form).
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form).
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form).
Public property | TabStop | (inherited from Form).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form).
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowState | Gets or sets the form's window state. (inherited from Form).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

AboutForm Class
CADImport.CADImportForms Namespace


AboutForm.LngFileName Property

Gets or sets a name of the language files (.lng)

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LngFileName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string LngFileName {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AboutForm Class
AboutForm Members
CADImport.CADImportForms Namespace


AboutForm.MultipleLanguagesPath Property

Gets or sets a path to the folder, that contains language files (.lng)

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property MultipleLanguagesPath() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string MultipleLanguagesPath {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AboutForm Class
AboutForm Members
CADImport.CADImportForms Namespace


AboutForm Methods

AboutForm Class See Also

The following tables list the members exposed by the AboutForm type.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form).
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Close | Closes the form. (inherited from Form).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Gets the size when autoscaling the form based on a specified font. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form).
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form).
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form).
Public method | Show | (Overloaded) Shows the form with the specified owner to the user. (inherited from Form).
Public method | ShowDialog | (Overloaded) Shows the form as a modal dialog box with the currently active window set as its owner. (inherited from Form).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Form).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top
See Also

Reference

AboutForm Class
CADImport.CADImportForms Namespace


AboutForm Events

AboutForm Class See Also

The following tables list the members exposed by the AboutForm type.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form).
Public event | AutoSizeChanged | (inherited from Form).
Public event | AutoValidateChanged | (inherited from Form).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | Closed | Occurs when the form is closed. (inherited from Form).
Public event | Closing | Occurs when the form is closing. (inherited from Form).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | FormClosed | Occurs after the form is closed. (inherited from Form).
Public event | FormClosing | Occurs before the form is closed. (inherited from Form).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form).
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | (inherited from Form).
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form).
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form).
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form).
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form).
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form).
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form).
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form).
Public event | TabStopChanged | (inherited from Form).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

AboutForm Class
CADImport.CADImportForms Namespace


BugReportForm Class

Members See Also

Represents a form for bug report dialog in demos.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class BugReportForm
    Inherits Form
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class BugReportForm : Form
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
CADImport.CADImportForms.BugReportForm
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BugReportForm Members
CADImport.CADImportForms Namespace


BugReportForm Members

BugReportForm Class Constructors Events Methods Properties See Also

Represents a form for bug report dialog in demos.

The following tables list the members exposed by the BugReportForm type.

Constructors
 | Name | Description
Public constructor | BugReportForm | Initializes a new instance of BugReportForm class.
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
 | ActiveForm | Gets the currently active form for this application. (inherited from Form).
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form).
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Form).
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form).
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form).
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Icon | Gets or sets the icon for the form. (inherited from Form).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form).
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form).
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | Location | (inherited from Form).
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form).
Public property | Margin | (inherited from Form).
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form).
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form).
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form).
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form).
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form).
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form).
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form).
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form).
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form).
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form).
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the size of the form. (inherited from Form).
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form).
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form).
Public property | TabStop | (inherited from Form).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form).
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowState | Gets or sets the form's window state. (inherited from Form).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form).
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Close | Closes the form. (inherited from Form).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Gets the size when autoscaling the form based on a specified font. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form).
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form).
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form).
Public method | Show | (Overloaded) Shows the form with the specified owner to the user. (inherited from Form).
Public method | ShowDialog | (Overloaded) Shows the form as a modal dialog box with the currently active window set as its owner. (inherited from Form).
Public method | ShowErrorDialog | Shows the error dialog on exception.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Form).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form).
Public event | AutoSizeChanged | (inherited from Form).
Public event | AutoValidateChanged | (inherited from Form).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | Closed | Occurs when the form is closed. (inherited from Form).
Public event | Closing | Occurs when the form is closing. (inherited from Form).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | FormClosed | Occurs after the form is closed. (inherited from Form).
Public event | FormClosing | Occurs before the form is closed. (inherited from Form).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form).
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | (inherited from Form).
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form).
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form).
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form).
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form).
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form).
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form).
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form).
Public event | TabStopChanged | (inherited from Form).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

BugReportForm Class
CADImport.CADImportForms Namespace


BugReportForm Constructor

Initializes a new instance of BugReportForm class.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public BugReportForm()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BugReportForm Class
BugReportForm Members
CADImport.CADImportForms Namespace


BugReportForm Properties

BugReportForm Class See Also

The following tables list the members exposed by the BugReportForm type.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
 | ActiveForm | Gets the currently active form for this application. (inherited from Form).
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form).
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Form).
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form).
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form).
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Icon | Gets or sets the icon for the form. (inherited from Form).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form).
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form).
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | Location | (inherited from Form).
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form).
Public property | Margin | (inherited from Form).
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form).
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form).
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form).
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form).
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form).
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form).
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form).
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form).
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form).
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form).
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the size of the form. (inherited from Form).
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form).
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form).
Public property | TabStop | (inherited from Form).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form).
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowState | Gets or sets the form's window state. (inherited from Form).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

BugReportForm Class
CADImport.CADImportForms Namespace


BugReportForm Methods

BugReportForm Class See Also

The following tables list the members exposed by the BugReportForm type.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form).
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Close | Closes the form. (inherited from Form).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Gets the size when autoscaling the form based on a specified font. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form).
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form).
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form).
Public method | Show | (Overloaded) Shows the form with the specified owner to the user. (inherited from Form).
Public method | ShowDialog | (Overloaded) Shows the form as a modal dialog box with the currently active window set as its owner. (inherited from Form).
Public method | ShowErrorDialog | Shows the error dialog on exception.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Form).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top
See Also

Reference

BugReportForm Class
CADImport.CADImportForms Namespace


BugReportForm.ShowErrorDialog Method

Shows the error dialog on exception.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ShowErrorDialog( _
   ByVal except As Exception _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ShowErrorDialog(
   Exception except
)
This language is not supported or no code example is available.

Parameters

except

Type: Exception

An exception

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BugReportForm Class
BugReportForm Members
CADImport.CADImportForms Namespace


BugReportForm Events

BugReportForm Class See Also

The following tables list the members exposed by the BugReportForm type.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form).
Public event | AutoSizeChanged | (inherited from Form).
Public event | AutoValidateChanged | (inherited from Form).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | Closed | Occurs when the form is closed. (inherited from Form).
Public event | Closing | Occurs when the form is closing. (inherited from Form).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | FormClosed | Occurs after the form is closed. (inherited from Form).
Public event | FormClosing | Occurs before the form is closed. (inherited from Form).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form).
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | (inherited from Form).
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form).
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form).
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form).
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form).
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form).
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form).
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form).
Public event | TabStopChanged | (inherited from Form).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

BugReportForm Class
CADImport.CADImportForms Namespace


ColorSelector Class

Members See Also

Represents a form for selecting a color.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class ColorSelector
    Inherits Form
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class ColorSelector : Form
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
CADImport.CADImportForms.ColorSelector
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ColorSelector Members
CADImport.CADImportForms Namespace


ColorSelector Members

ColorSelector Class Constructors Events Methods Properties See Also

Represents a form for selecting a color.

The following tables list the members exposed by the ColorSelector type.

Constructors
 | Name | Description
Public constructor | ColorSelector | Initializes a new instance of the ColorSelector class with the specified current color.
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
 | ActiveForm | Gets the currently active form for this application. (inherited from Form).
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form).
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Form).
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | B | Gets the B component of the current color.
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form).
Public property | ColorIndex | Gets or sets an index of the current color.
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form).
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form).
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form).
Public property | G | Gets the G component of the current color.
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Icon | Gets or sets the icon for the form. (inherited from Form).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form).
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form).
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | Location | (inherited from Form).
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form).
Public property | Margin | (inherited from Form).
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form).
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form).
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form).
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form).
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form).
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form).
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form).
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form).
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | R | Gets the R component of the current color.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form).
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form).
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the size of the form. (inherited from Form).
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form).
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form).
Public property | TabStop | (inherited from Form).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form).
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowState | Gets or sets the form's window state. (inherited from Form).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form).
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Close | Closes the form. (inherited from Form).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Gets the size when autoscaling the form based on a specified font. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form).
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form).
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form).
Public method | Show | (Overloaded) Shows the form with the specified owner to the user. (inherited from Form).
Public method | ShowDialog | (Overloaded) Shows the form as a modal dialog box with the currently active window set as its owner. (inherited from Form).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Form).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form).
Public event | AutoSizeChanged | (inherited from Form).
Public event | AutoValidateChanged | (inherited from Form).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | Closed | Occurs when the form is closed. (inherited from Form).
Public event | Closing | Occurs when the form is closing. (inherited from Form).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | FormClosed | Occurs after the form is closed. (inherited from Form).
Public event | FormClosing | Occurs before the form is closed. (inherited from Form).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form).
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | (inherited from Form).
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form).
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form).
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form).
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form).
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form).
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form).
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form).
Public event | TabStopChanged | (inherited from Form).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

ColorSelector Class
CADImport.CADImportForms Namespace


ColorSelector Constructor

Initializes a new instance of the ColorSelector class with the specified current color.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal cIndex As Byte _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ColorSelector(
   byte cIndex
)
This language is not supported or no code example is available.

Parameters

cIndex

Type: byte

An index of the current color.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ColorSelector Class
ColorSelector Members
CADImport.CADImportForms Namespace


ColorSelector Properties

ColorSelector Class See Also

The following tables list the members exposed by the ColorSelector type.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
 | ActiveForm | Gets the currently active form for this application. (inherited from Form).
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form).
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Form).
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | B | Gets the B component of the current color.
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form).
Public property | ColorIndex | Gets or sets an index of the current color.
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form).
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form).
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form).
Public property | G | Gets the G component of the current color.
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Icon | Gets or sets the icon for the form. (inherited from Form).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form).
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form).
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | Location | (inherited from Form).
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form).
Public property | Margin | (inherited from Form).
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form).
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form).
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form).
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form).
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form).
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form).
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form).
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form).
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | R | Gets the R component of the current color.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form).
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form).
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the size of the form. (inherited from Form).
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form).
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form).
Public property | TabStop | (inherited from Form).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form).
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowState | Gets or sets the form's window state. (inherited from Form).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

ColorSelector Class
CADImport.CADImportForms Namespace


ColorSelector.B Property

Gets the B component of the current color.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property B() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int B {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ColorSelector Class
ColorSelector Members
CADImport.CADImportForms Namespace


ColorSelector.ColorIndex Property

Gets or sets an index of the current color.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ColorIndex() As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte ColorIndex {get; set;}
This language is not supported or no code example is available.
Remarks

A color index can accept any integer value between 0 and 255 inclusive.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ColorSelector Class
ColorSelector Members
CADImport.CADImportForms Namespace


ColorSelector.G Property

Gets the G component of the current color.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property G() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int G {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ColorSelector Class
ColorSelector Members
CADImport.CADImportForms Namespace


ColorSelector.R Property

Gets the R component of the current color.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property R() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int R {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ColorSelector Class
ColorSelector Members
CADImport.CADImportForms Namespace


ColorSelector Methods

ColorSelector Class See Also

The following tables list the members exposed by the ColorSelector type.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form).
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Close | Closes the form. (inherited from Form).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Gets the size when autoscaling the form based on a specified font. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form).
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form).
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form).
Public method | Show | (Overloaded) Shows the form with the specified owner to the user. (inherited from Form).
Public method | ShowDialog | (Overloaded) Shows the form as a modal dialog box with the currently active window set as its owner. (inherited from Form).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Form).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top
See Also

Reference

ColorSelector Class
CADImport.CADImportForms Namespace


ColorSelector Events

ColorSelector Class See Also

The following tables list the members exposed by the ColorSelector type.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form).
Public event | AutoSizeChanged | (inherited from Form).
Public event | AutoValidateChanged | (inherited from Form).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | Closed | Occurs when the form is closed. (inherited from Form).
Public event | Closing | Occurs when the form is closing. (inherited from Form).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | FormClosed | Occurs after the form is closed. (inherited from Form).
Public event | FormClosing | Occurs before the form is closed. (inherited from Form).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form).
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | (inherited from Form).
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form).
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form).
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form).
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form).
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form).
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form).
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form).
Public event | TabStopChanged | (inherited from Form).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

ColorSelector Class
CADImport.CADImportForms Namespace


DemoForm Class

Members See Also

Represens a form that shows unregistered version info dialog.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class DemoForm
    Inherits Form
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class DemoForm : Form
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
CADImport.CADImportForms.DemoForm
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DemoForm Members
CADImport.CADImportForms Namespace


DemoForm Members

DemoForm Class Constructors Events Methods Properties See Also

Represens a form that shows unregistered version info dialog.

The following tables list the members exposed by the DemoForm type.

Constructors
 | Name | Description
Public constructor | DemoForm | Initializes a new instance of DemoForm class.
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
 | ActiveForm | Gets the currently active form for this application. (inherited from Form).
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form).
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Form).
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form).
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form).
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Icon | Gets or sets the icon for the form. (inherited from Form).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form).
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form).
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | Location | (inherited from Form).
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form).
Public property | Margin | (inherited from Form).
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form).
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form).
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form).
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form).
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form).
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form).
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form).
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form).
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form).
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form).
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the size of the form. (inherited from Form).
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form).
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form).
Public property | TabStop | (inherited from Form).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form).
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowState | Gets or sets the form's window state. (inherited from Form).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form).
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Close | Closes the form. (inherited from Form).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Gets the size when autoscaling the form based on a specified font. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form).
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form).
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form).
Public method | Show | (Overloaded) Shows the form with the specified owner to the user. (inherited from Form).
Public method | ShowDialog | (Overloaded) Shows the form as a modal dialog box with the currently active window set as its owner. (inherited from Form).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Form).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form).
Public event | AutoSizeChanged | (inherited from Form).
Public event | AutoValidateChanged | (inherited from Form).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | Closed | Occurs when the form is closed. (inherited from Form).
Public event | Closing | Occurs when the form is closing. (inherited from Form).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | FormClosed | Occurs after the form is closed. (inherited from Form).
Public event | FormClosing | Occurs before the form is closed. (inherited from Form).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form).
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | (inherited from Form).
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form).
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form).
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form).
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form).
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form).
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form).
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form).
Public event | TabStopChanged | (inherited from Form).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

DemoForm Class
CADImport.CADImportForms Namespace


DemoForm Constructor

Initializes a new instance of DemoForm class.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DemoForm()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DemoForm Class
DemoForm Members
CADImport.CADImportForms Namespace


DemoForm Properties

DemoForm Class See Also

The following tables list the members exposed by the DemoForm type.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
 | ActiveForm | Gets the currently active form for this application. (inherited from Form).
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form).
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Form).
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form).
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form).
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Icon | Gets or sets the icon for the form. (inherited from Form).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form).
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form).
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | Location | (inherited from Form).
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form).
Public property | Margin | (inherited from Form).
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form).
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form).
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form).
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form).
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form).
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form).
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form).
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form).
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form).
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form).
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the size of the form. (inherited from Form).
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form).
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form).
Public property | TabStop | (inherited from Form).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form).
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowState | Gets or sets the form's window state. (inherited from Form).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

DemoForm Class
CADImport.CADImportForms Namespace


DemoForm Methods

DemoForm Class See Also

The following tables list the members exposed by the DemoForm type.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form).
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Close | Closes the form. (inherited from Form).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Gets the size when autoscaling the form based on a specified font. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form).
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form).
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form).
Public method | Show | (Overloaded) Shows the form with the specified owner to the user. (inherited from Form).
Public method | ShowDialog | (Overloaded) Shows the form as a modal dialog box with the currently active window set as its owner. (inherited from Form).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Form).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top
See Also

Reference

DemoForm Class
CADImport.CADImportForms Namespace


DemoForm Events

DemoForm Class See Also

The following tables list the members exposed by the DemoForm type.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form).
Public event | AutoSizeChanged | (inherited from Form).
Public event | AutoValidateChanged | (inherited from Form).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | Closed | Occurs when the form is closed. (inherited from Form).
Public event | Closing | Occurs when the form is closing. (inherited from Form).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | FormClosed | Occurs after the form is closed. (inherited from Form).
Public event | FormClosing | Occurs before the form is closed. (inherited from Form).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form).
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | (inherited from Form).
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form).
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form).
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form).
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form).
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form).
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form).
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form).
Public event | TabStopChanged | (inherited from Form).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

DemoForm Class
CADImport.CADImportForms Namespace


EditorOptions Class

Members See Also

Represents a form for the options dialog in Editor demo.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class EditorOptions
    Inherits Form
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class EditorOptions : Form
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
CADImport.CADImportForms.EditorOptions
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EditorOptions Members
CADImport.CADImportForms Namespace


EditorOptions Members

EditorOptions Class Constructors Events Methods Properties See Also

Represents a form for the options dialog in Editor demo.

The following tables list the members exposed by the EditorOptions type.

Constructors
 | Name | Description
Public constructor | EditorOptions | Initializes a new instance of EditorOptions class.
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
 | ActiveForm | Gets the currently active form for this application. (inherited from Form).
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form).
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Form).
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form).
Public property | ColorEntity | Gets or sets an entity color
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form).
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form).
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | FileName | Gets or sets a name of loading image for CADImageEnt
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | HatchName | Gets or sets a name for CADHatch object
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Icon | Gets or sets the icon for the form. (inherited from Form).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form).
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form).
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | LngDir | Gets or sets a path to the language files (.lng) folder
Public property | LngFileName | Gets or sets a name of the language file (.lng)
Public property | Location | (inherited from Form).
Public property | MTextPages | A set of strings for CADMText object creation
Public property | MTextRotation | Gets or sets the rotation angle for CADMText object
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form).
Public property | Margin | (inherited from Form).
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form).
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form).
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form).
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form).
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form).
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form).
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | MultipleLanguagesPath | Gets or sets a path to the language files (.lng) folder
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form).
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form).
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form).
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form).
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the size of the form. (inherited from Form).
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form).
Public property | SolidHatch | Gets or sets the solid style for CADHatch
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form).
Public property | TabStop | (inherited from Form).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | TextEntText | Gets or sets a text for the CADText object
Public property | TextHeight | Gets or sets the text height for the CADText object
Public property | TextRotation | Gets or sets the rotation angle for the CADText object
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form).
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowState | Gets or sets the form's window state. (inherited from Form).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form).
 | AddNewMTextString | Generates a string for CADMText
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Close | Closes the form. (inherited from Form).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Gets the size when autoscaling the form based on a specified font. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form).
Public method | OnChangeLanguage | Invokes the ChangeLanguage event
Public method | OnChangeLngPath | Invokes the ChangeLngPath event
Public method | OnChangeLngPathEvent | Invokes the ChangeLngPathEvent event
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectMTextTab | Chooses MText tab in the settings window
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SelectTextTab | Chooses Text tab in the settings window
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form).
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form).
Public method | Show | (Overloaded) Shows the form with the specified owner to the user. (inherited from Form).
Public method | ShowDialog | (Overloaded) Shows the form as a modal dialog box with the currently active window set as its owner. (inherited from Form).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Form).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form).
Public event | AutoSizeChanged | (inherited from Form).
Public event | AutoValidateChanged | (inherited from Form).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeLanguage | Occurs when the language of an application was changed
Public event | ChangeLngPath | Occurs when language files directory was changed
Public event | ChangeLngPathEvent | Occurs when language files directory was changed
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | Closed | Occurs when the form is closed. (inherited from Form).
Public event | Closing | Occurs when the form is closing. (inherited from Form).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | FormClosed | Occurs after the form is closed. (inherited from Form).
Public event | FormClosing | Occurs before the form is closed. (inherited from Form).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form).
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | (inherited from Form).
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form).
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form).
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form).
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form).
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form).
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form).
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form).
Public event | TabStopChanged | (inherited from Form).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

EditorOptions Class
CADImport.CADImportForms Namespace


EditorOptions Constructor

Initializes a new instance of EditorOptions class.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public EditorOptions()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EditorOptions Class
EditorOptions Members
CADImport.CADImportForms Namespace


EditorOptions Properties

EditorOptions Class See Also

The following tables list the members exposed by the EditorOptions type.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
 | ActiveForm | Gets the currently active form for this application. (inherited from Form).
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form).
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Form).
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form).
Public property | ColorEntity | Gets or sets an entity color
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form).
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form).
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | FileName | Gets or sets a name of loading image for CADImageEnt
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | HatchName | Gets or sets a name for CADHatch object
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Icon | Gets or sets the icon for the form. (inherited from Form).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form).
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form).
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | LngDir | Gets or sets a path to the language files (.lng) folder
Public property | LngFileName | Gets or sets a name of the language file (.lng)
Public property | Location | (inherited from Form).
Public property | MTextPages | A set of strings for CADMText object creation
Public property | MTextRotation | Gets or sets the rotation angle for CADMText object
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form).
Public property | Margin | (inherited from Form).
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form).
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form).
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form).
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form).
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form).
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form).
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | MultipleLanguagesPath | Gets or sets a path to the language files (.lng) folder
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form).
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form).
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form).
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form).
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the size of the form. (inherited from Form).
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form).
Public property | SolidHatch | Gets or sets the solid style for CADHatch
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form).
Public property | TabStop | (inherited from Form).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | TextEntText | Gets or sets a text for the CADText object
Public property | TextHeight | Gets or sets the text height for the CADText object
Public property | TextRotation | Gets or sets the rotation angle for the CADText object
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form).
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowState | Gets or sets the form's window state. (inherited from Form).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

EditorOptions Class
CADImport.CADImportForms Namespace


EditorOptions.ColorEntity Property

Gets or sets an entity color

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ColorEntity() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Color ColorEntity {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EditorOptions Class
EditorOptions Members
CADImport.CADImportForms Namespace


EditorOptions.FileName Property

Gets or sets a name of loading image for CADImageEnt

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property FileName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string FileName {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EditorOptions Class
EditorOptions Members
CADImport.CADImportForms Namespace


EditorOptions.HatchName Property

Gets or sets a name for CADHatch object

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property HatchName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string HatchName {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EditorOptions Class
EditorOptions Members
CADImport.CADImportForms Namespace


EditorOptions.LngDir Property

Gets or sets a path to the language files (.lng) folder

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LngDir() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string LngDir {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EditorOptions Class
EditorOptions Members
CADImport.CADImportForms Namespace


EditorOptions.LngFileName Property

Gets or sets a name of the language file (.lng)

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LngFileName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string LngFileName {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EditorOptions Class
EditorOptions Members
CADImport.CADImportForms Namespace


EditorOptions.MTextPages Property

A set of strings for CADMText object creation

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property MTextPages() As String()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string[] MTextPages {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EditorOptions Class
EditorOptions Members
CADImport.CADImportForms Namespace


EditorOptions.MTextRotation Property

Gets or sets the rotation angle for CADMText object

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property MTextRotation() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float MTextRotation {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EditorOptions Class
EditorOptions Members
CADImport.CADImportForms Namespace


EditorOptions.MultipleLanguagesPath Property

Gets or sets a path to the language files (.lng) folder

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property MultipleLanguagesPath() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string MultipleLanguagesPath {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EditorOptions Class
EditorOptions Members
CADImport.CADImportForms Namespace


EditorOptions.SolidHatch Property

Gets or sets the solid style for CADHatch

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property SolidHatch() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool SolidHatch {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EditorOptions Class
EditorOptions Members
CADImport.CADImportForms Namespace


EditorOptions.TextEntText Property

Gets or sets a text for the CADText object

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TextEntText() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string TextEntText {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EditorOptions Class
EditorOptions Members
CADImport.CADImportForms Namespace


EditorOptions.TextHeight Property

Gets or sets the text height for the CADText object

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TextHeight() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float TextHeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EditorOptions Class
EditorOptions Members
CADImport.CADImportForms Namespace


EditorOptions.TextRotation Property

Gets or sets the rotation angle for the CADText object

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TextRotation() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float TextRotation {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EditorOptions Class
EditorOptions Members
CADImport.CADImportForms Namespace


EditorOptions Methods

EditorOptions Class See Also

The following tables list the members exposed by the EditorOptions type.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form).
 | AddNewMTextString | Generates a string for CADMText
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Close | Closes the form. (inherited from Form).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Gets the size when autoscaling the form based on a specified font. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form).
Public method | OnChangeLanguage | Invokes the ChangeLanguage event
Public method | OnChangeLngPath | Invokes the ChangeLngPath event
Public method | OnChangeLngPathEvent | Invokes the ChangeLngPathEvent event
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectMTextTab | Chooses MText tab in the settings window
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SelectTextTab | Chooses Text tab in the settings window
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form).
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form).
Public method | Show | (Overloaded) Shows the form with the specified owner to the user. (inherited from Form).
Public method | ShowDialog | (Overloaded) Shows the form as a modal dialog box with the currently active window set as its owner. (inherited from Form).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Form).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top
See Also

Reference

EditorOptions Class
CADImport.CADImportForms Namespace


EditorOptions.AddNewMTextString Method

Generates a string for CADMText

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function AddNewMTextString( _
   ByVal val As String, _
   ByVal name As String, _
   ByVal fnt As Font, _
   ByVal col As Integer _
) As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static string AddNewMTextString(
   string val,
   string name,
   Font fnt,
   int col
)
This language is not supported or no code example is available.

Parameters

val

Type: string

CADMText text

name

Type: string

CADMText name

fnt

Type: Font

CADMText font

col

Type: int

CADMText color

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EditorOptions Class
EditorOptions Members
CADImport.CADImportForms Namespace


EditorOptions.OnChangeLanguage Method

Invokes the ChangeLanguage event

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnChangeLanguage( _
   ByVal val As String, _
   ByVal index As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnChangeLanguage(
   string val,
   int index
)
This language is not supported or no code example is available.

Parameters

val

Type: string

Specified language

index

Type: int

An index of the specified language in the language list

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EditorOptions Class
EditorOptions Members
CADImport.CADImportForms Namespace


EditorOptions.OnChangeLngPath Method

Invokes the ChangeLngPath event

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnChangeLngPath( _
   ByVal val As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnChangeLngPath(
   string val
)
This language is not supported or no code example is available.

Parameters

val

Type: string

A path to the folder, which contains language files (.lng)

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EditorOptions Class
EditorOptions Members
CADImport.CADImportForms Namespace


EditorOptions.OnChangeLngPathEvent Method

Invokes the ChangeLngPathEvent event

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnChangeLngPathEvent( _
   ByVal val As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnChangeLngPathEvent(
   string val
)
This language is not supported or no code example is available.

Parameters

val

Type: string

A path to language files (.lng) folder

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EditorOptions Class
EditorOptions Members
CADImport.CADImportForms Namespace


EditorOptions.SelectMTextTab Method

Chooses MText tab in the settings window

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SelectMTextTab()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SelectMTextTab()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EditorOptions Class
EditorOptions Members
CADImport.CADImportForms Namespace


EditorOptions.SelectTextTab Method

Chooses Text tab in the settings window

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SelectTextTab()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SelectTextTab()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EditorOptions Class
EditorOptions Members
CADImport.CADImportForms Namespace


EditorOptions Events

EditorOptions Class See Also

The following tables list the members exposed by the EditorOptions type.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form).
Public event | AutoSizeChanged | (inherited from Form).
Public event | AutoValidateChanged | (inherited from Form).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeLanguage | Occurs when the language of an application was changed
Public event | ChangeLngPath | Occurs when language files directory was changed
Public event | ChangeLngPathEvent | Occurs when language files directory was changed
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | Closed | Occurs when the form is closed. (inherited from Form).
Public event | Closing | Occurs when the form is closing. (inherited from Form).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | FormClosed | Occurs after the form is closed. (inherited from Form).
Public event | FormClosing | Occurs before the form is closed. (inherited from Form).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form).
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | (inherited from Form).
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form).
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form).
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form).
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form).
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form).
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form).
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form).
Public event | TabStopChanged | (inherited from Form).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

EditorOptions Class
CADImport.CADImportForms Namespace


ChangeLanguage Event

Occurs when the language of an application was changed

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeLanguage() As CADImport.CADImportForms.ChangeLanguageEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeLanguageEventHandler ChangeLanguage
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EditorOptions Class
EditorOptions Members
CADImport.CADImportForms Namespace


ChangeLngPath Event

Occurs when language files directory was changed

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeLngPath() As CADImport.CADImportForms.ChangeLngPathEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeLngPathEventHandler ChangeLngPath
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EditorOptions Class
EditorOptions Members
CADImport.CADImportForms Namespace


ChangeLngPathEvent Event

Occurs when language files directory was changed

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeLngPathEvent() As CADImport.CADImportForms.ChangeLngPathEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeLngPathEventHandler ChangeLngPathEvent
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EditorOptions Class
EditorOptions Members
CADImport.CADImportForms Namespace


GridForm Class

Members See Also

Provides visual interface for control grid settings

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class GridForm
    Inherits Form
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class GridForm : Form
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
CADImport.CADImportForms.GridForm
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GridForm Members
CADImport.CADImportForms Namespace


GridForm Members

GridForm Class Constructors Events Methods Properties See Also

Provides visual interface for control grid settings

The following tables list the members exposed by the GridForm type.

Constructors
 | Name | Description
Public constructor | GridForm | Initializes a new instance of GridForm class.
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
 | ActiveForm | Gets the currently active form for this application. (inherited from Form).
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form).
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Form).
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form).
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form).
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form).
Public property | GridControl | Gets or sets a CADPictureBox control that will be affected by this GridForm
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Icon | Gets or sets the icon for the form. (inherited from Form).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form).
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form).
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | Location | (inherited from Form).
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form).
Public property | Margin | (inherited from Form).
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form).
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form).
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form).
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form).
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form).
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form).
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form).
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form).
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form).
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form).
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the size of the form. (inherited from Form).
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form).
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form).
Public property | TabStop | (inherited from Form).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form).
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowState | Gets or sets the form's window state. (inherited from Form).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form).
Public method | ActivateGrid | Activates the grid for the chosen control
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Close | Closes the form. (inherited from Form).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | DeactivateGrid | Deactivates the grid for the chosen control
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Gets the size when autoscaling the form based on a specified font. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form).
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form).
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form).
Public method | Show | (Overloaded) Shows the form with the specified owner to the user. (inherited from Form).
Public method | ShowDialog | (Overloaded) Shows the form as a modal dialog box with the currently active window set as its owner. (inherited from Form).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Form).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form).
Public event | AutoSizeChanged | (inherited from Form).
Public event | AutoValidateChanged | (inherited from Form).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | Closed | Occurs when the form is closed. (inherited from Form).
Public event | Closing | Occurs when the form is closing. (inherited from Form).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | FormClosed | Occurs after the form is closed. (inherited from Form).
Public event | FormClosing | Occurs before the form is closed. (inherited from Form).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form).
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | (inherited from Form).
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form).
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form).
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form).
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form).
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form).
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form).
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form).
Public event | TabStopChanged | (inherited from Form).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

GridForm Class
CADImport.CADImportForms Namespace


GridForm Constructor

Initializes a new instance of GridForm class.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public GridForm()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GridForm Class
GridForm Members
CADImport.CADImportForms Namespace


GridForm Properties

GridForm Class See Also

The following tables list the members exposed by the GridForm type.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
 | ActiveForm | Gets the currently active form for this application. (inherited from Form).
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form).
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Form).
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form).
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form).
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form).
Public property | GridControl | Gets or sets a CADPictureBox control that will be affected by this GridForm
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Icon | Gets or sets the icon for the form. (inherited from Form).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form).
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form).
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | Location | (inherited from Form).
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form).
Public property | Margin | (inherited from Form).
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form).
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form).
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form).
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form).
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form).
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form).
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form).
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form).
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form).
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form).
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the size of the form. (inherited from Form).
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form).
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form).
Public property | TabStop | (inherited from Form).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form).
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowState | Gets or sets the form's window state. (inherited from Form).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

GridForm Class
CADImport.CADImportForms Namespace


GridForm.GridControl Property

Gets or sets a CADPictureBox control that will be affected by this GridForm

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property GridControl() As CADPictureBox
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADPictureBox GridControl {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GridForm Class
GridForm Members
CADImport.CADImportForms Namespace


GridForm Methods

GridForm Class See Also

The following tables list the members exposed by the GridForm type.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form).
Public method | ActivateGrid | Activates the grid for the chosen control
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Close | Closes the form. (inherited from Form).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | DeactivateGrid | Deactivates the grid for the chosen control
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Gets the size when autoscaling the form based on a specified font. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form).
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form).
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form).
Public method | Show | (Overloaded) Shows the form with the specified owner to the user. (inherited from Form).
Public method | ShowDialog | (Overloaded) Shows the form as a modal dialog box with the currently active window set as its owner. (inherited from Form).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Form).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top
See Also

Reference

GridForm Class
CADImport.CADImportForms Namespace


GridForm.ActivateGrid Method

Activates the grid for the chosen control

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ActivateGrid()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ActivateGrid()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GridForm Class
GridForm Members
CADImport.CADImportForms Namespace


GridForm.DeactivateGrid Method

Deactivates the grid for the chosen control

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DeactivateGrid()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DeactivateGrid()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GridForm Class
GridForm Members
CADImport.CADImportForms Namespace


GridForm Events

GridForm Class See Also

The following tables list the members exposed by the GridForm type.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form).
Public event | AutoSizeChanged | (inherited from Form).
Public event | AutoValidateChanged | (inherited from Form).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | Closed | Occurs when the form is closed. (inherited from Form).
Public event | Closing | Occurs when the form is closing. (inherited from Form).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | FormClosed | Occurs after the form is closed. (inherited from Form).
Public event | FormClosing | Occurs before the form is closed. (inherited from Form).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form).
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | (inherited from Form).
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form).
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form).
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form).
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form).
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form).
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form).
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form).
Public event | TabStopChanged | (inherited from Form).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

GridForm Class
CADImport.CADImportForms Namespace


LayerForm Class

Members See Also

Represents form for layers window in demos.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class LayerForm
    Inherits Form
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class LayerForm : Form
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
CADImport.CADImportForms.LayerForm
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LayerForm Members
CADImport.CADImportForms Namespace


LayerForm Members

LayerForm Class Constructors Events Methods Properties See Also

Represents form for layers window in demos.

The following tables list the members exposed by the LayerForm type.

Constructors
 | Name | Description
Public constructor | LayerForm | Initializes a new instance of LayerForm class.
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
 | ActiveForm | Gets the currently active form for this application. (inherited from Form).
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form).
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Form).
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form).
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form).
Public property | DetInvalidate | Outdated. Does nothing
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Icon | Gets or sets the icon for the form. (inherited from Form).
Public property | ImageList | Gets an ImageList that contains images corresponding to layers of the current CAD image in the LayerForm.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form).
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form).
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form).
Public property | LayerList | Gets a list of layers and their properties
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | LngFileName | Gets or sets a name of the language file
Public property | Location | (inherited from Form).
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form).
Public property | Margin | (inherited from Form).
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form).
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form).
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form).
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form).
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form).
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form).
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | MultipleLanguagesPath | Gets or sets a path to the language files directory
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form).
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form).
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form).
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form).
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the size of the form. (inherited from Form).
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form).
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form).
Public property | TabStop | (inherited from Form).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form).
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowState | Gets or sets the form's window state. (inherited from Form).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form).
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Close | Closes the form. (inherited from Form).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Gets the size when autoscaling the form based on a specified font. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form).
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form).
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form).
Public method | SetLayList |
Public method | Show | (Overloaded) Shows the form with the specified owner to the user. (inherited from Form).
Public method | ShowDialog | (Overloaded) Shows the form as a modal dialog box with the currently active window set as its owner. (inherited from Form).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Form).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form).
Public event | AutoSizeChanged | (inherited from Form).
Public event | AutoValidateChanged | (inherited from Form).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | Closed | Occurs when the form is closed. (inherited from Form).
Public event | Closing | Occurs when the form is closing. (inherited from Form).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | FormClosed | Occurs after the form is closed. (inherited from Form).
Public event | FormClosing | Occurs before the form is closed. (inherited from Form).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form).
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | LayerChanged |
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | (inherited from Form).
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form).
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form).
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form).
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form).
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form).
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form).
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form).
Public event | TabStopChanged | (inherited from Form).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

LayerForm Class
CADImport.CADImportForms Namespace


LayerForm Constructor

Initializes a new instance of LayerForm class.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public LayerForm()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LayerForm Class
LayerForm Members
CADImport.CADImportForms Namespace


LayerForm Properties

LayerForm Class See Also

The following tables list the members exposed by the LayerForm type.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
 | ActiveForm | Gets the currently active form for this application. (inherited from Form).
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form).
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Form).
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form).
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form).
Public property | DetInvalidate | Outdated. Does nothing
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Icon | Gets or sets the icon for the form. (inherited from Form).
Public property | ImageList | Gets an ImageList that contains images corresponding to layers of the current CAD image in the LayerForm.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form).
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form).
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form).
Public property | LayerList | Gets a list of layers and their properties
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | LngFileName | Gets or sets a name of the language file
Public property | Location | (inherited from Form).
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form).
Public property | Margin | (inherited from Form).
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form).
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form).
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form).
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form).
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form).
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form).
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | MultipleLanguagesPath | Gets or sets a path to the language files directory
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form).
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form).
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form).
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form).
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the size of the form. (inherited from Form).
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form).
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form).
Public property | TabStop | (inherited from Form).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form).
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowState | Gets or sets the form's window state. (inherited from Form).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

LayerForm Class
CADImport.CADImportForms Namespace


LayerForm.DetInvalidate Property

Outdated. Does nothing

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DetInvalidate() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool DetInvalidate {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LayerForm Class
LayerForm Members
CADImport.CADImportForms Namespace


LayerForm.ImageList Property

Gets an ImageList that contains images corresponding to layers of the current CAD image in the LayerForm.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property ImageList() As ImageList
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ImageList ImageList {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LayerForm Class
LayerForm Members
CADImport.CADImportForms Namespace


LayerForm.LayerList Property

Gets a list of layers and their properties

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property LayerList() As CADListView
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADListView LayerList {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LayerForm Class
LayerForm Members
CADImport.CADImportForms Namespace


LayerForm.LngFileName Property

Gets or sets a name of the language file

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LngFileName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string LngFileName {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LayerForm Class
LayerForm Members
CADImport.CADImportForms Namespace


LayerForm.MultipleLanguagesPath Property

Gets or sets a path to the language files directory

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property MultipleLanguagesPath() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string MultipleLanguagesPath {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LayerForm Class
LayerForm Members
CADImport.CADImportForms Namespace


LayerForm Methods

LayerForm Class See Also

The following tables list the members exposed by the LayerForm type.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form).
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Close | Closes the form. (inherited from Form).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Gets the size when autoscaling the form based on a specified font. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form).
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form).
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form).
Public method | SetLayList |
Public method | Show | (Overloaded) Shows the form with the specified owner to the user. (inherited from Form).
Public method | ShowDialog | (Overloaded) Shows the form as a modal dialog box with the currently active window set as its owner. (inherited from Form).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Form).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top
See Also

Reference

LayerForm Class
CADImport.CADImportForms Namespace


LayerForm.SetLayList Method

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetLayList( _
   ByVal layers As CADEntityCollection _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetLayList(
   CADEntityCollection layers
)
This language is not supported or no code example is available.

Parameters

layers

Type: CADEntityCollection

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LayerForm Class
LayerForm Members
CADImport.CADImportForms Namespace


LayerForm Events

LayerForm Class See Also

The following tables list the members exposed by the LayerForm type.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form).
Public event | AutoSizeChanged | (inherited from Form).
Public event | AutoValidateChanged | (inherited from Form).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | Closed | Occurs when the form is closed. (inherited from Form).
Public event | Closing | Occurs when the form is closing. (inherited from Form).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | FormClosed | Occurs after the form is closed. (inherited from Form).
Public event | FormClosing | Occurs before the form is closed. (inherited from Form).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form).
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | LayerChanged |
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | (inherited from Form).
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form).
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form).
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form).
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form).
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form).
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form).
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form).
Public event | TabStopChanged | (inherited from Form).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

LayerForm Class
CADImport.CADImportForms Namespace


LayerChanged Event

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event LayerChanged() As System.EventHandler<CADImport.CADImportForms.LayerChangedEventArgs>
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event System.EventHandler<CADImport.CADImportForms.LayerChangedEventArgs> LayerChanged
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LayerForm Class
LayerForm Members
CADImport.CADImportForms Namespace


OpenFileFromWebForm Class

Members See Also

Represents a form that corresponds to the opening of a file from the web dialog

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class OpenFileFromWebForm
    Inherits Form
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class OpenFileFromWebForm : Form
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
CADImport.CADImportForms.OpenFileFromWebForm
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OpenFileFromWebForm Members
CADImport.CADImportForms Namespace


OpenFileFromWebForm Members

OpenFileFromWebForm Class Constructors Events Methods Properties See Also

Represents a form that corresponds to the opening of a file from the web dialog

The following tables list the members exposed by the OpenFileFromWebForm type.

Constructors
 | Name | Description
Public constructor | OpenFileFromWebForm | Initializes a new instance of OpenFileFromWebForm class.
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
 | ActiveForm | Gets the currently active form for this application. (inherited from Form).
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form).
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Form).
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form).
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form).
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Icon | Gets or sets the icon for the form. (inherited from Form).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form).
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form).
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | Location | (inherited from Form).
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form).
Public property | Margin | (inherited from Form).
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form).
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form).
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form).
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form).
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form).
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form).
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form).
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form).
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | Path | Gets or sets a hyperlink to the opening file
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form).
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form).
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the size of the form. (inherited from Form).
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form).
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form).
Public property | TabStop | (inherited from Form).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form).
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowState | Gets or sets the form's window state. (inherited from Form).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form).
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Close | Closes the form. (inherited from Form).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Gets the size when autoscaling the form based on a specified font. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form).
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form).
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form).
Public method | Show | (Overloaded) Shows the form with the specified owner to the user. (inherited from Form).
Public method | ShowDialog | (Overloaded) Shows the form as a modal dialog box with the currently active window set as its owner. (inherited from Form).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Form).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form).
Public event | AutoSizeChanged | (inherited from Form).
Public event | AutoValidateChanged | (inherited from Form).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | Closed | Occurs when the form is closed. (inherited from Form).
Public event | Closing | Occurs when the form is closing. (inherited from Form).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | FormClosed | Occurs after the form is closed. (inherited from Form).
Public event | FormClosing | Occurs before the form is closed. (inherited from Form).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form).
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | (inherited from Form).
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form).
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form).
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form).
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form).
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form).
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form).
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form).
Public event | TabStopChanged | (inherited from Form).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

OpenFileFromWebForm Class
CADImport.CADImportForms Namespace


OpenFileFromWebForm Constructor

Initializes a new instance of OpenFileFromWebForm class.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public OpenFileFromWebForm()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OpenFileFromWebForm Class
OpenFileFromWebForm Members
CADImport.CADImportForms Namespace


OpenFileFromWebForm Properties

OpenFileFromWebForm Class See Also

The following tables list the members exposed by the OpenFileFromWebForm type.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
 | ActiveForm | Gets the currently active form for this application. (inherited from Form).
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form).
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Form).
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form).
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form).
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Icon | Gets or sets the icon for the form. (inherited from Form).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form).
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form).
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | Location | (inherited from Form).
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form).
Public property | Margin | (inherited from Form).
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form).
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form).
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form).
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form).
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form).
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form).
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form).
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form).
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | Path | Gets or sets a hyperlink to the opening file
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form).
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form).
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the size of the form. (inherited from Form).
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form).
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form).
Public property | TabStop | (inherited from Form).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form).
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowState | Gets or sets the form's window state. (inherited from Form).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

OpenFileFromWebForm Class
CADImport.CADImportForms Namespace


OpenFileFromWebForm.Path Property

Gets or sets a hyperlink to the opening file

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Path() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Path {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OpenFileFromWebForm Class
OpenFileFromWebForm Members
CADImport.CADImportForms Namespace


OpenFileFromWebForm Methods

OpenFileFromWebForm Class See Also

The following tables list the members exposed by the OpenFileFromWebForm type.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form).
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Close | Closes the form. (inherited from Form).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Gets the size when autoscaling the form based on a specified font. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form).
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form).
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form).
Public method | Show | (Overloaded) Shows the form with the specified owner to the user. (inherited from Form).
Public method | ShowDialog | (Overloaded) Shows the form as a modal dialog box with the currently active window set as its owner. (inherited from Form).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Form).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top
See Also

Reference

OpenFileFromWebForm Class
CADImport.CADImportForms Namespace


OpenFileFromWebForm Events

OpenFileFromWebForm Class See Also

The following tables list the members exposed by the OpenFileFromWebForm type.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form).
Public event | AutoSizeChanged | (inherited from Form).
Public event | AutoValidateChanged | (inherited from Form).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | Closed | Occurs when the form is closed. (inherited from Form).
Public event | Closing | Occurs when the form is closing. (inherited from Form).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | FormClosed | Occurs after the form is closed. (inherited from Form).
Public event | FormClosing | Occurs before the form is closed. (inherited from Form).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form).
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | (inherited from Form).
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form).
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form).
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form).
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form).
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form).
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form).
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form).
Public event | TabStopChanged | (inherited from Form).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

OpenFileFromWebForm Class
CADImport.CADImportForms Namespace


OptionsForm Class

Members See Also

Represents a form for the options dialog in Viewer demo.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class OptionsForm
    Inherits Form
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class OptionsForm : Form
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
CADImport.CADImportForms.OptionsForm
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OptionsForm Members
CADImport.CADImportForms Namespace


OptionsForm Members

OptionsForm Class Constructors Events Methods Properties See Also

Represents a form for the options dialog in Viewer demo.

The following tables list the members exposed by the OptionsForm type.

Constructors
 | Name | Description
Public constructor | OptionsForm | Initializes a new instance of OptionsForm class.
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
 | ActiveForm | Gets the currently active form for this application. (inherited from Form).
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form).
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Form).
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form).
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form).
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Icon | Gets or sets the icon for the form. (inherited from Form).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form).
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form).
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | LngFileName | Gets or sets a name of the specified language file (.lng)
Public property | Location | (inherited from Form).
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form).
Public property | Margin | (inherited from Form).
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form).
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form).
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form).
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form).
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form).
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form).
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | MultipleLanguagesPath | Gets or sets a path to the language files directory
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form).
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form).
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form).
Public property | SettingsList | Gets or sets a list of the application settings
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form).
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the size of the form. (inherited from Form).
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form).
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form).
Public property | TabStop | (inherited from Form).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form).
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowState | Gets or sets the form's window state. (inherited from Form).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form).
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Close | Closes the form. (inherited from Form).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Gets the size when autoscaling the form based on a specified font. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form).
Public method | OnChangeBackgroundColor | Invokes the ChangeBackgroundColor event
Public method | OnChangeDrawingColors | Invokes the ChangeDrawingColors event
Public method | OnChangeEntityPanelVisible | Invokes the ChangeEntityPanelVisible event
Public method | OnChangeLanguage | Invokes the ChangeLanguage event
Public method | OnChangeLngPath | Invokes the ChangeLngPath event
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form).
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form).
Public method | Show | (Overloaded) Shows the form with the specified owner to the user. (inherited from Form).
Public method | ShowDialog | (Overloaded) Shows the form as a modal dialog box with the currently active window set as its owner. (inherited from Form).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Form).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form).
Public event | AutoSizeChanged | (inherited from Form).
Public event | AutoValidateChanged | (inherited from Form).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeBackgroundColor | Occurs when the background of the drawing was changed
Public event | ChangeDrawingColors | Occurs when the color type of the drawing was changed (black-and-white/color)
Public event | ChangeEntityPanelVisible | Occurs when visibility of the entity tree was changed
Public event | ChangeLanguage | Occurs when the language of the application was changed
Public event | ChangeLngPath | Occurs when the language files directory was changed
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | Closed | Occurs when the form is closed. (inherited from Form).
Public event | Closing | Occurs when the form is closing. (inherited from Form).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | FormClosed | Occurs after the form is closed. (inherited from Form).
Public event | FormClosing | Occurs before the form is closed. (inherited from Form).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form).
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | (inherited from Form).
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form).
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form).
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form).
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form).
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form).
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form).
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form).
Public event | TabStopChanged | (inherited from Form).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

OptionsForm Class
CADImport.CADImportForms Namespace


OptionsForm Constructor

Initializes a new instance of OptionsForm class.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public OptionsForm()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OptionsForm Class
OptionsForm Members
CADImport.CADImportForms Namespace


OptionsForm Properties

OptionsForm Class See Also

The following tables list the members exposed by the OptionsForm type.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
 | ActiveForm | Gets the currently active form for this application. (inherited from Form).
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form).
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Form).
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form).
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form).
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Icon | Gets or sets the icon for the form. (inherited from Form).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form).
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form).
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | LngFileName | Gets or sets a name of the specified language file (.lng)
Public property | Location | (inherited from Form).
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form).
Public property | Margin | (inherited from Form).
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form).
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form).
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form).
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form).
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form).
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form).
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | MultipleLanguagesPath | Gets or sets a path to the language files directory
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form).
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form).
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form).
Public property | SettingsList | Gets or sets a list of the application settings
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form).
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the size of the form. (inherited from Form).
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form).
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form).
Public property | TabStop | (inherited from Form).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form).
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowState | Gets or sets the form's window state. (inherited from Form).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

OptionsForm Class
CADImport.CADImportForms Namespace


OptionsForm.LngFileName Property

Gets or sets a name of the specified language file (.lng)

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LngFileName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string LngFileName {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OptionsForm Class
OptionsForm Members
CADImport.CADImportForms Namespace


OptionsForm.MultipleLanguagesPath Property

Gets or sets a path to the language files directory

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property MultipleLanguagesPath() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string MultipleLanguagesPath {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OptionsForm Class
OptionsForm Members
CADImport.CADImportForms Namespace


OptionsForm.SettingsList Property

Gets or sets a list of the application settings

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property SettingsList() As SortedList
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SortedList SettingsList {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OptionsForm Class
OptionsForm Members
CADImport.CADImportForms Namespace


OptionsForm Methods

OptionsForm Class See Also

The following tables list the members exposed by the OptionsForm type.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form).
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Close | Closes the form. (inherited from Form).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Gets the size when autoscaling the form based on a specified font. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form).
Public method | OnChangeBackgroundColor | Invokes the ChangeBackgroundColor event
Public method | OnChangeDrawingColors | Invokes the ChangeDrawingColors event
Public method | OnChangeEntityPanelVisible | Invokes the ChangeEntityPanelVisible event
Public method | OnChangeLanguage | Invokes the ChangeLanguage event
Public method | OnChangeLngPath | Invokes the ChangeLngPath event
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form).
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form).
Public method | Show | (Overloaded) Shows the form with the specified owner to the user. (inherited from Form).
Public method | ShowDialog | (Overloaded) Shows the form as a modal dialog box with the currently active window set as its owner. (inherited from Form).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Form).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top
See Also

Reference

OptionsForm Class
CADImport.CADImportForms Namespace


OptionsForm.OnChangeBackgroundColor Method

Invokes the ChangeBackgroundColor event

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnChangeBackgroundColor( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnChangeBackgroundColor(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

If true then background color of the CADImage is black, else the background color is white

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OptionsForm Class
OptionsForm Members
CADImport.CADImportForms Namespace


OptionsForm.OnChangeDrawingColors Method

Invokes the ChangeDrawingColors event

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnChangeDrawingColors( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnChangeDrawingColors(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

If false then the drawing is drawn in black-and-white, else in color

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OptionsForm Class
OptionsForm Members
CADImport.CADImportForms Namespace


OptionsForm.OnChangeEntityPanelVisible Method

Invokes the ChangeEntityPanelVisible event

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnChangeEntityPanelVisible( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnChangeEntityPanelVisible(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

A value of entities tree visibility

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OptionsForm Class
OptionsForm Members
CADImport.CADImportForms Namespace


OptionsForm.OnChangeLanguage Method

Invokes the ChangeLanguage event

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnChangeLanguage( _
   ByVal val As String, _
   ByVal index As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnChangeLanguage(
   string val,
   int index
)
This language is not supported or no code example is available.

Parameters

val

Type: string

The specified language

index

Type: int

An index of specified language in the language list

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OptionsForm Class
OptionsForm Members
CADImport.CADImportForms Namespace


OptionsForm.OnChangeLngPath Method

Invokes the ChangeLngPath event

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnChangeLngPath( _
   ByVal val As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnChangeLngPath(
   string val
)
This language is not supported or no code example is available.

Parameters

val

Type: string

A path to the folder, which contains language files (.lng)

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OptionsForm Class
OptionsForm Members
CADImport.CADImportForms Namespace


OptionsForm Events

OptionsForm Class See Also

The following tables list the members exposed by the OptionsForm type.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form).
Public event | AutoSizeChanged | (inherited from Form).
Public event | AutoValidateChanged | (inherited from Form).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeBackgroundColor | Occurs when the background of the drawing was changed
Public event | ChangeDrawingColors | Occurs when the color type of the drawing was changed (black-and-white/color)
Public event | ChangeEntityPanelVisible | Occurs when visibility of the entity tree was changed
Public event | ChangeLanguage | Occurs when the language of the application was changed
Public event | ChangeLngPath | Occurs when the language files directory was changed
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | Closed | Occurs when the form is closed. (inherited from Form).
Public event | Closing | Occurs when the form is closing. (inherited from Form).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | FormClosed | Occurs after the form is closed. (inherited from Form).
Public event | FormClosing | Occurs before the form is closed. (inherited from Form).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form).
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | (inherited from Form).
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form).
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form).
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form).
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form).
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form).
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form).
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form).
Public event | TabStopChanged | (inherited from Form).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

OptionsForm Class
CADImport.CADImportForms Namespace


ChangeBackgroundColor Event

Occurs when the background of the drawing was changed

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeBackgroundColor() As CADImport.CADImportForms.ChangeOptionsEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeOptionsEventHandler ChangeBackgroundColor
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OptionsForm Class
OptionsForm Members
CADImport.CADImportForms Namespace


ChangeDrawingColors Event

Occurs when the color type of the drawing was changed (black-and-white/color)

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeDrawingColors() As CADImport.CADImportForms.ChangeOptionsEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeOptionsEventHandler ChangeDrawingColors
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OptionsForm Class
OptionsForm Members
CADImport.CADImportForms Namespace


ChangeEntityPanelVisible Event

Occurs when visibility of the entity tree was changed

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeEntityPanelVisible() As CADImport.CADImportForms.ChangeOptionsEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeOptionsEventHandler ChangeEntityPanelVisible
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OptionsForm Class
OptionsForm Members
CADImport.CADImportForms Namespace


ChangeLanguage Event

Occurs when the language of the application was changed

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeLanguage() As CADImport.CADImportForms.ChangeLanguageEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeLanguageEventHandler ChangeLanguage
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OptionsForm Class
OptionsForm Members
CADImport.CADImportForms Namespace


ChangeLngPath Event

Occurs when the language files directory was changed

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ChangeLngPath() As CADImport.CADImportForms.ChangeLngPathEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeLngPathEventHandler ChangeLngPath
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OptionsForm Class
OptionsForm Members
CADImport.CADImportForms Namespace


RegForm Class

Members See Also

Represents a form for the registration dialog.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class RegForm
    Inherits Form
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class RegForm : Form
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
CADImport.CADImportForms.RegForm
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RegForm Members
CADImport.CADImportForms Namespace


RegForm Members

RegForm Class Constructors Events Methods Properties See Also

Represents a form for the registration dialog.

The following tables list the members exposed by the RegForm type.

Constructors
 | Name | Description
Public constructor | RegForm | Initializes a new instance of RegForm class.
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
 | ActiveForm | Gets the currently active form for this application. (inherited from Form).
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form).
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Form).
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form).
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form).
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Icon | Gets or sets the icon for the form. (inherited from Form).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form).
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form).
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | LngFileName | Gets or sets a name of the language file
Public property | Location | (inherited from Form).
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form).
Public property | Margin | (inherited from Form).
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form).
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form).
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form).
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form).
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form).
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form).
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | MultipleLanguagesPath | Gets or sets a path to the language files directory
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form).
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form).
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form).
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form).
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the size of the form. (inherited from Form).
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form).
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form).
Public property | TabStop | (inherited from Form).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form).
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowState | Gets or sets the form's window state. (inherited from Form).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form).
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Close | Closes the form. (inherited from Form).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Gets the size when autoscaling the form based on a specified font. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form).
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form).
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form).
Public method | Show | (Overloaded) Shows the form with the specified owner to the user. (inherited from Form).
Public method | ShowDialog | (Overloaded) Shows the form as a modal dialog box with the currently active window set as its owner. (inherited from Form).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Form).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form).
Public event | AutoSizeChanged | (inherited from Form).
Public event | AutoValidateChanged | (inherited from Form).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | Closed | Occurs when the form is closed. (inherited from Form).
Public event | Closing | Occurs when the form is closing. (inherited from Form).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | FormClosed | Occurs after the form is closed. (inherited from Form).
Public event | FormClosing | Occurs before the form is closed. (inherited from Form).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form).
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | (inherited from Form).
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form).
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form).
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form).
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form).
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form).
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form).
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form).
Public event | TabStopChanged | (inherited from Form).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

RegForm Class
CADImport.CADImportForms Namespace


RegForm Constructor

Initializes a new instance of RegForm class.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public RegForm()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RegForm Class
RegForm Members
CADImport.CADImportForms Namespace


RegForm Properties

RegForm Class See Also

The following tables list the members exposed by the RegForm type.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
 | ActiveForm | Gets the currently active form for this application. (inherited from Form).
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form).
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Form).
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form).
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form).
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Icon | Gets or sets the icon for the form. (inherited from Form).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form).
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form).
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | LngFileName | Gets or sets a name of the language file
Public property | Location | (inherited from Form).
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form).
Public property | Margin | (inherited from Form).
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form).
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form).
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form).
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form).
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form).
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form).
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | MultipleLanguagesPath | Gets or sets a path to the language files directory
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form).
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form).
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form).
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form).
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the size of the form. (inherited from Form).
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form).
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form).
Public property | TabStop | (inherited from Form).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form).
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowState | Gets or sets the form's window state. (inherited from Form).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

RegForm Class
CADImport.CADImportForms Namespace


RegForm.LngFileName Property

Gets or sets a name of the language file

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LngFileName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string LngFileName {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RegForm Class
RegForm Members
CADImport.CADImportForms Namespace


RegForm.MultipleLanguagesPath Property

Gets or sets a path to the language files directory

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property MultipleLanguagesPath() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string MultipleLanguagesPath {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RegForm Class
RegForm Members
CADImport.CADImportForms Namespace


RegForm Methods

RegForm Class See Also

The following tables list the members exposed by the RegForm type.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form).
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Close | Closes the form. (inherited from Form).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Gets the size when autoscaling the form based on a specified font. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form).
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form).
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form).
Public method | Show | (Overloaded) Shows the form with the specified owner to the user. (inherited from Form).
Public method | ShowDialog | (Overloaded) Shows the form as a modal dialog box with the currently active window set as its owner. (inherited from Form).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Form).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top
See Also

Reference

RegForm Class
CADImport.CADImportForms Namespace


RegForm Events

RegForm Class See Also

The following tables list the members exposed by the RegForm type.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form).
Public event | AutoSizeChanged | (inherited from Form).
Public event | AutoValidateChanged | (inherited from Form).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | Closed | Occurs when the form is closed. (inherited from Form).
Public event | Closing | Occurs when the form is closing. (inherited from Form).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | FormClosed | Occurs after the form is closed. (inherited from Form).
Public event | FormClosing | Occurs before the form is closed. (inherited from Form).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form).
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | (inherited from Form).
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form).
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form).
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form).
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form).
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form).
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form).
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form).
Public event | TabStopChanged | (inherited from Form).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

RegForm Class
CADImport.CADImportForms Namespace


SHXForm Class

Members See Also

Represents a form for SHX fonts dialog.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class SHXForm
    Inherits Form
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class SHXForm : Form
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
CADImport.CADImportForms.SHXForm
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXForm Members
CADImport.CADImportForms Namespace


SHXForm Members

SHXForm Class Constructors Events Methods Fields Properties See Also

Represents a form for SHX fonts dialog.

The following tables list the members exposed by the SHXForm type.

Constructors
 | Name | Description
Public constructor | SHXForm | Initializes a new instance of SHXForm class.
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
 | ActiveForm | Gets the currently active form for this application. (inherited from Form).
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form).
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Form).
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form).
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form).
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Icon | Gets or sets the icon for the form. (inherited from Form).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form).
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form).
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | LngFileName | Gets or sets a name of the language file
Public property | Location | (inherited from Form).
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form).
Public property | Margin | (inherited from Form).
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form).
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form).
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form).
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form).
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form).
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form).
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | MultipleLanguagesPath | Gets or sets a path to the language files directory
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | NeedReopen | Gets or sets a value indicating whether reloading of the current file is required after adding new paths to SHX files.
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form).
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form).
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form).
Public property | SHXPaths | Gets paths to the SHX files.
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form).
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the size of the form. (inherited from Form).
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form).
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form).
Public property | TabStop | (inherited from Form).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form).
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowState | Gets or sets the form's window state. (inherited from Form).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form).
Public method | AddDefaultSHXPaths | Adds default paths to the SHX files on the SHXForm.
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form).
Public method | AddPath | Adds a specified path to the list of the paths to SHX files.
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Close | Closes the form. (inherited from Form).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Gets the size when autoscaling the form based on a specified font. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form).
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form).
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form).
Public method | Show | (Overloaded) Shows the form with the specified owner to the user. (inherited from Form).
Public method | ShowDialog | (Overloaded) Shows the form as a modal dialog box with the currently active window set as its owner. (inherited from Form).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Form).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form).
Public event | AutoSizeChanged | (inherited from Form).
Public event | AutoValidateChanged | (inherited from Form).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | Closed | Occurs when the form is closed. (inherited from Form).
Public event | Closing | Occurs when the form is closing. (inherited from Form).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | FormClosed | Occurs after the form is closed. (inherited from Form).
Public event | FormClosing | Occurs before the form is closed. (inherited from Form).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form).
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | (inherited from Form).
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form).
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form).
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form).
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form).
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form).
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form).
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form).
Public event | TabStopChanged | (inherited from Form).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
Fields
 | Name | Description
Public field | lstPath | A SortedList that contains a list of paths to the SHX files.
Top
See Also

Reference

SHXForm Class
CADImport.CADImportForms Namespace


SHXForm Constructor

Initializes a new instance of SHXForm class.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SHXForm()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXForm Class
SHXForm Members
CADImport.CADImportForms Namespace


SHXForm Properties

SHXForm Class See Also

The following tables list the members exposed by the SHXForm type.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
 | ActiveForm | Gets the currently active form for this application. (inherited from Form).
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form).
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Form).
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form).
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form).
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Icon | Gets or sets the icon for the form. (inherited from Form).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form).
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form).
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | LngFileName | Gets or sets a name of the language file
Public property | Location | (inherited from Form).
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form).
Public property | Margin | (inherited from Form).
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form).
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form).
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form).
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form).
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form).
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form).
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | MultipleLanguagesPath | Gets or sets a path to the language files directory
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | NeedReopen | Gets or sets a value indicating whether reloading of the current file is required after adding new paths to SHX files.
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form).
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form).
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form).
Public property | SHXPaths | Gets paths to the SHX files.
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form).
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the size of the form. (inherited from Form).
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form).
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form).
Public property | TabStop | (inherited from Form).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form).
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowState | Gets or sets the form's window state. (inherited from Form).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

SHXForm Class
CADImport.CADImportForms Namespace


SHXForm.LngFileName Property

Gets or sets a name of the language file

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LngFileName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string LngFileName {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXForm Class
SHXForm Members
CADImport.CADImportForms Namespace


SHXForm.MultipleLanguagesPath Property

Gets or sets a path to the language files directory

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property MultipleLanguagesPath() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string MultipleLanguagesPath {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXForm Class
SHXForm Members
CADImport.CADImportForms Namespace


SHXForm.NeedReopen Property

Gets or sets a value indicating whether reloading of the current file is required after adding new paths to SHX files.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property NeedReopen() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool NeedReopen {get; set;}
This language is not supported or no code example is available.

Property Value

true if reloading of the current file is required; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXForm Class
SHXForm Members
CADImport.CADImportForms Namespace


SHXForm.SHXPaths Property

Gets paths to the SHX files.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property SHXPaths() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string SHXPaths {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXForm Class
SHXForm Members
CADImport.CADImportForms Namespace


SHXForm Methods

SHXForm Class See Also

The following tables list the members exposed by the SHXForm type.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form).
Public method | AddDefaultSHXPaths | Adds default paths to the SHX files on the SHXForm.
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form).
Public method | AddPath | Adds a specified path to the list of the paths to SHX files.
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Close | Closes the form. (inherited from Form).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Gets the size when autoscaling the form based on a specified font. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form).
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form).
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form).
Public method | Show | (Overloaded) Shows the form with the specified owner to the user. (inherited from Form).
Public method | ShowDialog | (Overloaded) Shows the form as a modal dialog box with the currently active window set as its owner. (inherited from Form).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Form).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top
See Also

Reference

SHXForm Class
CADImport.CADImportForms Namespace


SHXForm.AddDefaultSHXPaths Method

Adds default paths to the SHX files on the SHXForm.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddDefaultSHXPaths()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddDefaultSHXPaths()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXForm Class
SHXForm Members
CADImport.CADImportForms Namespace


SHXForm.AddPath Method

Adds a specified path to the list of the paths to SHX files.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddPath( _
   ByVal val As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddPath(
   string val
)
This language is not supported or no code example is available.

Parameters

val

Type: string

A string containing a path to the SHX file to be added.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXForm Class
SHXForm Members
CADImport.CADImportForms Namespace


SHXForm Events

SHXForm Class See Also

The following tables list the members exposed by the SHXForm type.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form).
Public event | AutoSizeChanged | (inherited from Form).
Public event | AutoValidateChanged | (inherited from Form).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | Closed | Occurs when the form is closed. (inherited from Form).
Public event | Closing | Occurs when the form is closing. (inherited from Form).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | FormClosed | Occurs after the form is closed. (inherited from Form).
Public event | FormClosing | Occurs before the form is closed. (inherited from Form).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form).
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | (inherited from Form).
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form).
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form).
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form).
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form).
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form).
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form).
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form).
Public event | TabStopChanged | (inherited from Form).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

SHXForm Class
CADImport.CADImportForms Namespace


SHXForm Fields

SHXForm Class See Also

The following tables list the members exposed by the SHXForm type.

Fields
 | Name | Description
Public field | lstPath | A SortedList that contains a list of paths to the SHX files.
Top
See Also

Reference

SHXForm Class
CADImport.CADImportForms Namespace


lstPath Field

A SortedList that contains a list of paths to the SHX files.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public lstPath As SortedList
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SortedList lstPath
This language is not supported or no code example is available.
Remarks

This field is used for checking if the path that will be added is not already in the list of paths to the SHX files.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SHXForm Class
SHXForm Members
CADImport.CADImportForms Namespace


SetRasterSizeForm Class

Members See Also

Represents a form for setup of saved file size.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class SetRasterSizeForm
    Inherits Form
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class SetRasterSizeForm : Form
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
CADImport.CADImportForms.SetRasterSizeForm
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SetRasterSizeForm Members
CADImport.CADImportForms Namespace


SetRasterSizeForm Members

SetRasterSizeForm Class Constructors Events Methods Properties See Also

Represents a form for setup of saved file size.

The following tables list the members exposed by the SetRasterSizeForm type.

Constructors
 | Name | Description
Public constructor | SetRasterSizeForm | Initializes a new instance of SetRasterSizeForm class.
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
 | ActiveForm | Gets the currently active form for this application. (inherited from Form).
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form).
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Form).
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | CurrentSize | Gets or sets the current size of the loaded CAD image.
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form).
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form).
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Icon | Gets or sets the icon for the form. (inherited from Form).
Public property | Image | Gets or sets an image to be saved.
Public property | ImagePixelFormat | PixelFormat of an image
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form).
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form).
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | LngFileName | Gets or sets a name of the language file
Public property | Location | (inherited from Form).
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form).
Public property | Margin | (inherited from Form).
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form).
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form).
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form).
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form).
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form).
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form).
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | MultipleLanguagesPath | Gets or sets a path to the language files directory
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form).
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form).
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form).
Public property | SaveFileName | A saved file name
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form).
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the size of the form. (inherited from Form).
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form).
Public property | SizeImage | Gets a size in which the current CAD image will be saved.
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form).
Public property | TabStop | (inherited from Form).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form).
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowState | Gets or sets the form's window state. (inherited from Form).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form).
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Close | Closes the form. (inherited from Form).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Gets the size when autoscaling the form based on a specified font. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form).
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form).
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form).
Public method | Show | (Overloaded) Shows the form with the specified owner to the user. (inherited from Form).
Public method | ShowDialog | (Overloaded) Shows the form as a modal dialog box with the currently active window set as its owner. (inherited from Form).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Form).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form).
Public event | AutoSizeChanged | (inherited from Form).
Public event | AutoValidateChanged | (inherited from Form).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | Closed | Occurs when the form is closed. (inherited from Form).
Public event | Closing | Occurs when the form is closing. (inherited from Form).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | FormClosed | Occurs after the form is closed. (inherited from Form).
Public event | FormClosing | Occurs before the form is closed. (inherited from Form).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form).
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | (inherited from Form).
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form).
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form).
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form).
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form).
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form).
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form).
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form).
Public event | TabStopChanged | (inherited from Form).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

SetRasterSizeForm Class
CADImport.CADImportForms Namespace


SetRasterSizeForm Constructor

Initializes a new instance of SetRasterSizeForm class.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SetRasterSizeForm()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SetRasterSizeForm Class
SetRasterSizeForm Members
CADImport.CADImportForms Namespace


SetRasterSizeForm Properties

SetRasterSizeForm Class See Also

The following tables list the members exposed by the SetRasterSizeForm type.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
 | ActiveForm | Gets the currently active form for this application. (inherited from Form).
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form).
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Form).
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | CurrentSize | Gets or sets the current size of the loaded CAD image.
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form).
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form).
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Icon | Gets or sets the icon for the form. (inherited from Form).
Public property | Image | Gets or sets an image to be saved.
Public property | ImagePixelFormat | PixelFormat of an image
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form).
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form).
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | LngFileName | Gets or sets a name of the language file
Public property | Location | (inherited from Form).
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form).
Public property | Margin | (inherited from Form).
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form).
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form).
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form).
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form).
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form).
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form).
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | MultipleLanguagesPath | Gets or sets a path to the language files directory
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form).
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form).
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form).
Public property | SaveFileName | A saved file name
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form).
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the size of the form. (inherited from Form).
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form).
Public property | SizeImage | Gets a size in which the current CAD image will be saved.
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form).
Public property | TabStop | (inherited from Form).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form).
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowState | Gets or sets the form's window state. (inherited from Form).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

SetRasterSizeForm Class
CADImport.CADImportForms Namespace


SetRasterSizeForm.CurrentSize Property

Gets or sets the current size of the loaded CAD image.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property CurrentSize() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DRect CurrentSize {get; set;}
This language is not supported or no code example is available.

Property Value

A DRect object representing a current size of the loaded CAD image.
Remarks

A current size can be more or less than the viewing area.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SetRasterSizeForm Class
SetRasterSizeForm Members
CADImport.CADImportForms Namespace


SetRasterSizeForm.Image Property

Gets or sets an image to be saved.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Image() As CADImage
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADImage Image {get; set;}
This language is not supported or no code example is available.

Property Value

A CADImage whose size is set in this SetRasterSizeForm.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SetRasterSizeForm Class
SetRasterSizeForm Members
CADImport.CADImportForms Namespace


SetRasterSizeForm.ImagePixelFormat Property

PixelFormat of an image

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property ImagePixelFormat() As PixelFormat
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public PixelFormat ImagePixelFormat {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SetRasterSizeForm Class
SetRasterSizeForm Members
CADImport.CADImportForms Namespace


SetRasterSizeForm.LngFileName Property

Gets or sets a name of the language file

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LngFileName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string LngFileName {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SetRasterSizeForm Class
SetRasterSizeForm Members
CADImport.CADImportForms Namespace


SetRasterSizeForm.MultipleLanguagesPath Property

Gets or sets a path to the language files directory

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property MultipleLanguagesPath() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string MultipleLanguagesPath {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SetRasterSizeForm Class
SetRasterSizeForm Members
CADImport.CADImportForms Namespace


SetRasterSizeForm.SaveFileName Property

A saved file name

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property SaveFileName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string SaveFileName {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SetRasterSizeForm Class
SetRasterSizeForm Members
CADImport.CADImportForms Namespace


SetRasterSizeForm.SizeImage Property

Gets a size in which the current CAD image will be saved.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property SizeImage() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DRect SizeImage {get;}
This language is not supported or no code example is available.

Property Value

A DRect object representing a size in which the current CAD image will be saved.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SetRasterSizeForm Class
SetRasterSizeForm Members
CADImport.CADImportForms Namespace


SetRasterSizeForm Methods

SetRasterSizeForm Class See Also

The following tables list the members exposed by the SetRasterSizeForm type.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form).
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Close | Closes the form. (inherited from Form).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Gets the size when autoscaling the form based on a specified font. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form).
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form).
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form).
Public method | Show | (Overloaded) Shows the form with the specified owner to the user. (inherited from Form).
Public method | ShowDialog | (Overloaded) Shows the form as a modal dialog box with the currently active window set as its owner. (inherited from Form).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Form).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top
See Also

Reference

SetRasterSizeForm Class
CADImport.CADImportForms Namespace


SetRasterSizeForm Events

SetRasterSizeForm Class See Also

The following tables list the members exposed by the SetRasterSizeForm type.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form).
Public event | AutoSizeChanged | (inherited from Form).
Public event | AutoValidateChanged | (inherited from Form).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | Closed | Occurs when the form is closed. (inherited from Form).
Public event | Closing | Occurs when the form is closing. (inherited from Form).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | FormClosed | Occurs after the form is closed. (inherited from Form).
Public event | FormClosing | Occurs before the form is closed. (inherited from Form).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form).
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | (inherited from Form).
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form).
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form).
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form).
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form).
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form).
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form).
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form).
Public event | TabStopChanged | (inherited from Form).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

SetRasterSizeForm Class
CADImport.CADImportForms Namespace


ChangeLanguageEventHandler Delegate

Represents a set of methods which are invoked on changing of the application language. The set is used for ChangeLanguage event.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Delegate Sub ChangeLanguageEventHandler( _
   ByVal val As String, _
   ByVal index As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public delegate void ChangeLanguageEventHandler(
   string val,
   int index
)
This language is not supported or no code example is available.

Parameters

val

Type: string

index

Type: int

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImport.CADImportForms Namespace


ChangeLngPathEventHandler Delegate

Represents a set of methods which are invoked on changing of the language files directory. The set is used for ChangeLngPath event

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Delegate Sub ChangeLngPathEventHandler( _
   ByVal val As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public delegate void ChangeLngPathEventHandler(
   string val
)
This language is not supported or no code example is available.

Parameters

val

Type: string

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImport.CADImportForms Namespace


ChangeOptionsEventHandler Delegate

Represents a set of methods which are invoked on changing of the application settings. The set is used for ChangeEntityPanelVisible, ChangeBackgroundColor, ChangeDrawingColors events

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Delegate Sub ChangeOptionsEventHandler( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public delegate void ChangeOptionsEventHandler(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImport.CADImportForms Namespace


CADImport.CGM Namespace

Assembly: CADImport (in CADImport.dll)

Classes
 | Name | Description
Public class | CGMImage | Represents a CGM drawing and provides methods for drawing all loaded CAD objects.
Top
Delegates
 | Name | Description
Public delegate | CGMProgressEvent | Represents methods invoked while loading the file.
Top
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


CGMImage Class

Members See Also

Represents a CGM drawing and provides methods for drawing all loaded CAD objects.

Namespace: CADImport.CGM
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CGMImage
    Inherits CADImage
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CGMImage : CADImage
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADImage
CADImport.CGM.CGMImage
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CGMImage Members
CADImport.CGM Namespace


CGMImage Members

CGMImage Class Constructors Methods Fields Properties See Also

Represents a CGM drawing and provides methods for drawing all loaded CAD objects.

The following tables list the members exposed by the CGMImage type.

Constructors
 | Name | Description
Public constructor | CGMImage | Initializes a new instance of the CGMImage class.
Top
Properties
 | Name | Description
Public property | AbsDepth | Gets an absolute depths of the CADImage. (inherited from CADImage).
Public property | AbsHeight | Gets an absolute height of the CADImage. (inherited from CADImage).
Public property | AbsWidth | Gets an absolute width of the CADImage. (inherited from CADImage).
Public property | AllowColorCorrection | Specifies if colors correction mode is enabled. Allows black/white colors inversion when active based on background color.
Public property | Angle | Gets or sets the angle for this CADImage object visualization. (inherited from CADImage).
Public property | BackgroundColor | Gets or sets a background color of this CADImage. (inherited from CADImage).
Public property | BorderSize | Gets or sets a border size in pixels. (inherited from CADImage).
Public property | BorderType | Gets or sets a border type. (inherited from CADImage).
Public property | Center | Gets or sets CADImage center point. (inherited from CADImage).
Public property | Charset | Gets or sets a character set for the text entities. (inherited from CADImage).
 | CodePage | Gets or sets a number that identifies the encoding used in the loaded CAD file. (inherited from CADImage).
Public property | Converter | Gets a converter that loads CAD entities from the file to draw them in the current CADImage. (inherited from CADImage).
Public property | CurrentLayer | Gets or sets a current layer for the CADImage. (inherited from CADImage).
Public property | CurrentLayout | Gets or sets a current layout for the CADImage. (inherited from CADImage).
Public property | CurrentLayoutIndex | Gets an index of the current layout. (inherited from CADImage).
Public property | CurrentMarker | Gets a currently selected marker. (inherited from CADImage).
Public property | DefaultColor | Gets or sets a default color for the CADImage. (inherited from CADImage).
Public property | DefaultLayoutIndex | Gets or sets a default layout index. (inherited from CADImage).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions on the drawing are visible. (inherited from CADImage).
Public property | DrawMode | Gets or sets a current drawing mode. (inherited from CADImage).
Public property | EnableSnap | Gets or sets enablement of snap mode (inherited from CADImage).
Public property | Extents | Gets or sets an extents of the CADImage object. (inherited from CADImage).
Public property | FileInf | Gets information about a currently open file by means of the FileInfo class. (inherited from CADImage).
Public property | GDIPainter | Provides drawing functionality based on GDI+. (inherited from CADImage).
Public property | GraphicsOutMode | Specifies image draw mode. (inherited from CADImage).
Public property | InterpolationMode | Gets or sets the interpolation mode associated with current Graphics object (inherited from CADImage).
Public property | Is3D | Gets a value indicating whether this CADImage is three-dimensional. (inherited from CADImage).
Public property | IsDraw3DAxes | Gets or sets a value indicating whether 3D axes are shown on the drawing. (inherited from CADImage).
Public property | IsDrawingRotated | Gets a value indicating whether the CADImage has been rotated. (inherited from CADImage).
Public property | IsShowBackground | Gets or sets a value indicating using of a BackgroundColor. (inherited from CADImage).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data.
Public property | IsSnapObject | Gets a value, which shows if there is an object for snapping under current coordinates (inherited from CADImage).
Public property | IsStopped | For internal use. (inherited from CADImage).
Public property | IsWithoutBorder | Gest or sets a value indicating whether to draw the CADImage without borders. (inherited from CADImage).
Public property | IsWithoutMargins | Gets or sets a value indicating whether to draw the CADImage without margins. (inherited from CADImage).
 | LastLoadedFilePath | Specifying of the search directory (used for X-Refs, ImageEnt) (inherited from CADImage).
Public property | LayersCount | Gets a quantity of layers in this CADImage. (inherited from CADImage).
Public property | Layouts | Gets a collection of layouts in the current CADImage. (inherited from CADImage).
Public property | LayoutsCount | Gets a quantity of layouts in this CADImage. (inherited from CADImage).
Public property | LineScaled | Obsolete. Gets or sets a value indicating whether a width of lines to draw all entities in the drawing is specified by the file data. (inherited from CADImage).
Public property | LineWeightScale | Gets or sets a scale for drawing lines. (inherited from CADImage).
Public property | MMToPixelX | Gets or sets a value corresponding to amount of millimeters per one pixel. (inherited from CADImage).
Public property | NullWidth | Gets or sets default thickness for lines used to draw a CADImage. (inherited from CADImage).
Public property | NumberOfPartsInCircle | Gets or sets a quantity of segments to be used to draw a circle. (inherited from CADImage).
Public property | Painter | Provides image drawing functionality. (inherited from CADImage).
Public property | PrintDialog | Gets or sets print dialog (inherited from CADImage).
Public property | PureExtents | Gets CADImage extents without margins. (inherited from CADImage).
Public property | ResizeDisproportionateDrawing | For internal use (inherited from CADImage).
Public property | SHXSearchPaths | Gets or sets paths for searching SHX fonts. (inherited from CADImage).
Public property | SearchSHXPaths | Gets or sets a value specifying whether SHX paths will be searched for the fonts. (inherited from CADImage).
Public property | SelectEntitiesCount | Gets the number of selected entities (inherited from CADImage).
Public property | SelectedEntities | Gets or sets a list of selected entities (inherited from CADImage).
Public property | SelectionMode | Gets or sets a state of the Selection tool. (inherited from CADImage).
Public property | Selector | Provides selection functionality. (inherited from CADImage).
Public property | SkipMMtoPixel | For specific use (inherited from CADImage).
Public property | SnapCurrent | (inherited from CADImage).
Public property | SnapOptions | Represents Snap options for the CADImage object (inherited from CADImage).
Public property | SnapRealPoint | Gets a current point in absolute coordinates (drawing coordinates) (inherited from CADImage).
Public property | SnapScreenPoint | Gets current point in display coordinates (inherited from CADImage).
Public property | TTFSmoothing | Gets or sets a value indicating whether TTF fonts are smoothed. (inherited from CADImage).
Public property | TextVisible | Gets or sets a value indicating whether the texts in the CADImage are visible. (inherited from CADImage).
Public property | UndoMode | Gets or sets whether undo/redo is disable or enable for professional version (inherited from CADImage).
Public property | UseDoubleBuffering | Outdated. Does nothing (inherited from CADImage).
Public property | UseLayerPriority | (inherited from CADImage).
Public property | UseMultyTTFFonts | Gets or sets a value indicating whether a multimode is used for showing symbols. (inherited from CADImage).
Public property | UseNullWidth | Specifies if default width will be used instead of entity width. (inherited from CADImage).
Public property | UseSHXFonts | Specifies if SHX fonts will be used for visualization. (inherited from CADImage).
Public property | UseTTFFonts | Specifies if TTF fonts will be used for visualization. (inherited from CADImage).
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles in the CADImage are drawn with GDI+ drawing methods without linearization. (inherited from CADImage).
Top
Methods
 | Name | Description
Public method | ActiveVPort | Returns drawing area visualized with the active VPort. (inherited from CADImage).
Public method | AddScaledDXF | Adds a scaled external reference to the model space of the specified CAD image. (inherited from CADImage).
Public method | AddScaledDXFEx | Adds a scaled external reference to the current layout of the specified CAD image. (inherited from CADImage).
Public method | AddToUndoList | (Overloaded) Adds operation "create new Entity" to undo list (inherited from CADImage).
Public method | ChangeDrawMode | Initializes a new graphic class object if current mode changed. (inherited from CADImage).
Public method | ChangeEntities | (inherited from CADImage).
Public method | ChangeGraphicsMode | Changes image drawing mode. (inherited from CADImage).
Public method | ChangePositionSelectedEntities | Changes position of the selected entities (inherited from CADImage).
Public method | ChangePositionSelectedEntity | Changes a position of the selected entity. (inherited from CADImage).
Public method | ClearBuffer | Outdated. Does nothing (inherited from CADImage).
Public method | ClearMarkers | Clears a collection of markers. (inherited from CADImage).
Public method | ClearRedoCollection | Clears redo entity collection (inherited from CADImage).
Public method | ClearSelectCollection | Clears a collection of the selected entities. (inherited from CADImage).
Public method | ClearSelection | Clears a list of the selected entities. (inherited from CADImage).
Public method | ClearSnapTrace | (Overloaded) Clears last drawn snap drawing element (inherited from CADImage).
Public method | ClearUndoCollection | Clears undo entity collection (inherited from CADImage).
Public method | CopyEntities | (Overloaded) Copies selected entities to the clipboard (inherited from CADImage).
Public method | CorrectByGrid | (Overloaded) Reduces a point location on screen to the grid node when the grid is active (inherited from CADImage).
Public method | CorrectByGridAndOrtho | Reduces a point relocation sizes on screen to the grid cell sizes when the grid is active (inherited from CADImage).
 | CreateImageByExtension | Creates specialised CADImage object for specified file extention (inherited from CADImage).
Public method | CutEntities | (Overloaded) Cuts selected entities from collection and paste them to the clipboard (inherited from CADImage).
Public method | Dispose | Releases the resources used by this CGMImage object.
Public method | DoSelectEntities | (Overloaded) Selects inserted list of entities (inherited from CADImage).
Public method | DoSelectEntity | Selects inserted entity (inherited from CADImage).
Public method | Draw | (Overloaded) Draws a CADImage. (inherited from CADImage).
Public method | DrawACISEntity | Draws ACISEntity object (inherited from CADImage).
Public method | DrawChangeEntity | Changes a position of the marker designating the selected entity. (inherited from CADImage).
Public method | DrawMoveEntityTrace | Draws entities on their offsetting (inherited from CADImage).
Public method | DrawSnapTrace | Draws snap icon in case of proximity of object to current coordinates (inherited from CADImage).
Public method | EmfConvertToDXF | (Overloaded) Converts emf file to dxf file (inherited from CADImage).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportToMetafile | (Overloaded) Exports a CAD drawing to Windows Enhanced metafile. (inherited from CADImage).
Public method | GetAbsPoint | Converts display coordinates into absolute coordinates of a design (inherited from CADImage).
Public method | GetCADCoords | Returns coordinates of a point on the drawing. (inherited from CADImage).
Public method | GetCenter | Returns the center point of a current layout (inherited from CADImage).
Public method | GetExtents | Calculates the current dimensions of the CADImage. (inherited from CADImage).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLayerColor | Gets layer color by index (inherited from CADImage).
Public method | GetLayerFreeze | Determines whether the layer (CADLayer) is frozen. (inherited from CADImage).
Public method | GetLayerName | Gets a name of the layer that has the specified index in the collection of layers. (inherited from CADImage).
Public method | GetLayerVisible | Determines whether a layer is visible (inherited from CADImage).
Public method | GetLayoutName | Gets a name of the layout that has the specified index in the collection of layouts. (inherited from CADImage).
Public method | GetPoint | Transforms a three-dimensional CAD point into a two-dimensional screen point. (inherited from CADImage).
Public method | GetRealImagePoint | For internal use. (inherited from CADImage).
Public method | GetRealSnapPoint | Smooths a point in absolute coordinates by the entity (inherited from CADImage).
Public method | GetSelectEntityRegion | Returns the selected area of the image. (inherited from CADImage).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetVPortExtents | Returns extents of the active VPort reduced to the specified size (inherited from CADImage).
Public method | InitialNewImage | (Overloaded) Initializes a new image with the default size (inherited from CADImage).
Public method | InvalidateSelectEntity | Redraws a selected entity. (inherited from CADImage).
Public method | InvalidateSelectedEntities | (Overloaded) Redraws a list of the selected entities (inherited from CADImage).
Public method | LoadFromFile | Loads a CGM image stored in the specified file.
Public method | LoadFromStream | Loads a CGM image stored in the specified stream.
Public method | LoadFromWeb | Loads CAD image from hyperlink (inherited from CADImage).
Public method | MultipleSelect | Providing CAD image entities' multiple selection within a specified rectangle. (inherited from CADImage).
Public method | MultipleSelectExt | Selects all entities inside the inserted rectangle (inherited from CADImage).
Public method | PasteEntities | Pastes entities from the clipboard (inherited from CADImage).
Public method | PasteEntitiesExt | Pastes entities from the clipboard (inherited from CADImage).
Public method | Print | Prints a current CAD image. (inherited from CADImage).
Public method | Redo | Redo change (inherited from CADImage).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RefreshCurrentLayout | Refresh current layout. (inherited from CADImage).
Public method | RefreshSnapTrace | Refreshes a region of the last drawn snap drawing element (inherited from CADImage).
Public method | RemoveEntity | (Overloaded) Removes CADEntity object. (inherited from CADImage).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from CADImage).
Public method | RotToView | Rotates a CAD image to get a specified view. (inherited from CADImage).
Public method | Rotate | Rotates objects in the current drawing. (inherited from CADImage).
Public method | SaveAsDXF | Saves a current CAD image in DXF format. (inherited from CADImage).
Public method | SaveImageToClipboard | (Overloaded) Writes a visible part of the current CAD image to the clipboard as a raster image. (inherited from CADImage).
Public method | SaveToFile | (Overloaded) Saves a part of the current CAD image to the file of the specified format. (inherited from CADImage).
Public method | SaveToStream | (Overloaded) Writes a visible part of the current CAD image to the specified stream as a raster image. (inherited from CADImage).
Public method | Select | Selects an entity of the CAD image at the specified point. (inherited from CADImage).
Public method | SelectExt | Selects an entity of the CAD image at the specified point. (inherited from CADImage).
Public method | SetCenter | Sets CADImage center point. (inherited from CADImage).
Public method | SetCurrentLayout | Sets a current layout of this CADImage. (inherited from CADImage).
Public method | SetLayerColor | (Overloaded) Sets a color for layer (CADLayer) specified by index (inherited from CADImage).
Public method | SetLayerFreeze | (Overloaded) Sets freeze parameter for CADLayer (inherited from CADImage).
Public method | SetLayerVisible | (Overloaded) Sets a visibility of the layer. (inherited from CADImage).
Public method | SetNewEntityMarkerPos | Sets a new position for the selected entity. The entity's new position is defined by the position of the marker. (inherited from CADImage).
Public method | SetNewMMToPixel | Sets a quantity of millimeters per pixel for the specified Graphics object. (inherited from CADImage).
Public method | SetNewPosEntitiesExt | Sets a new position for the specified entities (inherited from CADImage).
Public method | SetNewPosEntity | Sets a new position for the specified entity. (inherited from CADImage).
Public method | Stop | For internal use. (inherited from CADImage).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | Undo | Undo change (inherited from CADImage).
Top
Fields
 | Name | Description
 | EntityBuffer | Represents buffer for CADEntityCollection storing. (inherited from CADImage).
Public field | progress | A CGMProgressEvent object representing the methods invoked while loading the file.
Public field | visibleArea | Represents CADImage visible area. (inherited from CADImage).
Top
See Also

Reference

CGMImage Class
CADImport.CGM Namespace


CGMImage Constructor

Initializes a new instance of the CGMImage class.

Namespace: CADImport.CGM
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CGMImage()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CGMImage Class
CGMImage Members
CADImport.CGM Namespace


CGMImage Properties

CGMImage Class See Also

The following tables list the members exposed by the CGMImage type.

Properties
 | Name | Description
Public property | AbsDepth | Gets an absolute depths of the CADImage. (inherited from CADImage).
Public property | AbsHeight | Gets an absolute height of the CADImage. (inherited from CADImage).
Public property | AbsWidth | Gets an absolute width of the CADImage. (inherited from CADImage).
Public property | AllowColorCorrection | Specifies if colors correction mode is enabled. Allows black/white colors inversion when active based on background color.
Public property | Angle | Gets or sets the angle for this CADImage object visualization. (inherited from CADImage).
Public property | BackgroundColor | Gets or sets a background color of this CADImage. (inherited from CADImage).
Public property | BorderSize | Gets or sets a border size in pixels. (inherited from CADImage).
Public property | BorderType | Gets or sets a border type. (inherited from CADImage).
Public property | Center | Gets or sets CADImage center point. (inherited from CADImage).
Public property | Charset | Gets or sets a character set for the text entities. (inherited from CADImage).
 | CodePage | Gets or sets a number that identifies the encoding used in the loaded CAD file. (inherited from CADImage).
Public property | Converter | Gets a converter that loads CAD entities from the file to draw them in the current CADImage. (inherited from CADImage).
Public property | CurrentLayer | Gets or sets a current layer for the CADImage. (inherited from CADImage).
Public property | CurrentLayout | Gets or sets a current layout for the CADImage. (inherited from CADImage).
Public property | CurrentLayoutIndex | Gets an index of the current layout. (inherited from CADImage).
Public property | CurrentMarker | Gets a currently selected marker. (inherited from CADImage).
Public property | DefaultColor | Gets or sets a default color for the CADImage. (inherited from CADImage).
Public property | DefaultLayoutIndex | Gets or sets a default layout index. (inherited from CADImage).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions on the drawing are visible. (inherited from CADImage).
Public property | DrawMode | Gets or sets a current drawing mode. (inherited from CADImage).
Public property | EnableSnap | Gets or sets enablement of snap mode (inherited from CADImage).
Public property | Extents | Gets or sets an extents of the CADImage object. (inherited from CADImage).
Public property | FileInf | Gets information about a currently open file by means of the FileInfo class. (inherited from CADImage).
Public property | GDIPainter | Provides drawing functionality based on GDI+. (inherited from CADImage).
Public property | GraphicsOutMode | Specifies image draw mode. (inherited from CADImage).
Public property | InterpolationMode | Gets or sets the interpolation mode associated with current Graphics object (inherited from CADImage).
Public property | Is3D | Gets a value indicating whether this CADImage is three-dimensional. (inherited from CADImage).
Public property | IsDraw3DAxes | Gets or sets a value indicating whether 3D axes are shown on the drawing. (inherited from CADImage).
Public property | IsDrawingRotated | Gets a value indicating whether the CADImage has been rotated. (inherited from CADImage).
Public property | IsShowBackground | Gets or sets a value indicating using of a BackgroundColor. (inherited from CADImage).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data.
Public property | IsSnapObject | Gets a value, which shows if there is an object for snapping under current coordinates (inherited from CADImage).
Public property | IsStopped | For internal use. (inherited from CADImage).
Public property | IsWithoutBorder | Gest or sets a value indicating whether to draw the CADImage without borders. (inherited from CADImage).
Public property | IsWithoutMargins | Gets or sets a value indicating whether to draw the CADImage without margins. (inherited from CADImage).
 | LastLoadedFilePath | Specifying of the search directory (used for X-Refs, ImageEnt) (inherited from CADImage).
Public property | LayersCount | Gets a quantity of layers in this CADImage. (inherited from CADImage).
Public property | Layouts | Gets a collection of layouts in the current CADImage. (inherited from CADImage).
Public property | LayoutsCount | Gets a quantity of layouts in this CADImage. (inherited from CADImage).
Public property | LineScaled | Obsolete. Gets or sets a value indicating whether a width of lines to draw all entities in the drawing is specified by the file data. (inherited from CADImage).
Public property | LineWeightScale | Gets or sets a scale for drawing lines. (inherited from CADImage).
Public property | MMToPixelX | Gets or sets a value corresponding to amount of millimeters per one pixel. (inherited from CADImage).
Public property | NullWidth | Gets or sets default thickness for lines used to draw a CADImage. (inherited from CADImage).
Public property | NumberOfPartsInCircle | Gets or sets a quantity of segments to be used to draw a circle. (inherited from CADImage).
Public property | Painter | Provides image drawing functionality. (inherited from CADImage).
Public property | PrintDialog | Gets or sets print dialog (inherited from CADImage).
Public property | PureExtents | Gets CADImage extents without margins. (inherited from CADImage).
Public property | ResizeDisproportionateDrawing | For internal use (inherited from CADImage).
Public property | SHXSearchPaths | Gets or sets paths for searching SHX fonts. (inherited from CADImage).
Public property | SearchSHXPaths | Gets or sets a value specifying whether SHX paths will be searched for the fonts. (inherited from CADImage).
Public property | SelectEntitiesCount | Gets the number of selected entities (inherited from CADImage).
Public property | SelectedEntities | Gets or sets a list of selected entities (inherited from CADImage).
Public property | SelectionMode | Gets or sets a state of the Selection tool. (inherited from CADImage).
Public property | Selector | Provides selection functionality. (inherited from CADImage).
Public property | SkipMMtoPixel | For specific use (inherited from CADImage).
Public property | SnapCurrent | (inherited from CADImage).
Public property | SnapOptions | Represents Snap options for the CADImage object (inherited from CADImage).
Public property | SnapRealPoint | Gets a current point in absolute coordinates (drawing coordinates) (inherited from CADImage).
Public property | SnapScreenPoint | Gets current point in display coordinates (inherited from CADImage).
Public property | TTFSmoothing | Gets or sets a value indicating whether TTF fonts are smoothed. (inherited from CADImage).
Public property | TextVisible | Gets or sets a value indicating whether the texts in the CADImage are visible. (inherited from CADImage).
Public property | UndoMode | Gets or sets whether undo/redo is disable or enable for professional version (inherited from CADImage).
Public property | UseDoubleBuffering | Outdated. Does nothing (inherited from CADImage).
Public property | UseLayerPriority | (inherited from CADImage).
Public property | UseMultyTTFFonts | Gets or sets a value indicating whether a multimode is used for showing symbols. (inherited from CADImage).
Public property | UseNullWidth | Specifies if default width will be used instead of entity width. (inherited from CADImage).
Public property | UseSHXFonts | Specifies if SHX fonts will be used for visualization. (inherited from CADImage).
Public property | UseTTFFonts | Specifies if TTF fonts will be used for visualization. (inherited from CADImage).
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles in the CADImage are drawn with GDI+ drawing methods without linearization. (inherited from CADImage).
Top
See Also

Reference

CGMImage Class
CADImport.CGM Namespace


CGMImage.AllowColorCorrection Property

Specifies if colors correction mode is enabled. Allows black/white colors inversion when active based on background color.

Namespace: CADImport.CGM
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property AllowColorCorrection() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool AllowColorCorrection {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CGMImage Class
CGMImage Members
CADImport.CGM Namespace


CGMImage.IsShowLineWeight Property

Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data.

Namespace: CADImport.CGM
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Overrides Property IsShowLineWeight() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool IsShowLineWeight {get;}
This language is not supported or no code example is available.

Property Value

true if a thickness of lines in the CADImage is determined by the file data; otherwise, false.
Remarks

If this property value is false, a thickness of lines in the CADImage is determined by the NullWidth property.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CGMImage Class
CGMImage Members
CADImport.CGM Namespace


CGMImage Methods

CGMImage Class See Also

The following tables list the members exposed by the CGMImage type.

Methods
 | Name | Description
Public method | ActiveVPort | Returns drawing area visualized with the active VPort. (inherited from CADImage).
Public method | AddScaledDXF | Adds a scaled external reference to the model space of the specified CAD image. (inherited from CADImage).
Public method | AddScaledDXFEx | Adds a scaled external reference to the current layout of the specified CAD image. (inherited from CADImage).
Public method | AddToUndoList | (Overloaded) Adds operation "create new Entity" to undo list (inherited from CADImage).
Public method | ChangeDrawMode | Initializes a new graphic class object if current mode changed. (inherited from CADImage).
Public method | ChangeEntities | (inherited from CADImage).
Public method | ChangeGraphicsMode | Changes image drawing mode. (inherited from CADImage).
Public method | ChangePositionSelectedEntities | Changes position of the selected entities (inherited from CADImage).
Public method | ChangePositionSelectedEntity | Changes a position of the selected entity. (inherited from CADImage).
Public method | ClearBuffer | Outdated. Does nothing (inherited from CADImage).
Public method | ClearMarkers | Clears a collection of markers. (inherited from CADImage).
Public method | ClearRedoCollection | Clears redo entity collection (inherited from CADImage).
Public method | ClearSelectCollection | Clears a collection of the selected entities. (inherited from CADImage).
Public method | ClearSelection | Clears a list of the selected entities. (inherited from CADImage).
Public method | ClearSnapTrace | (Overloaded) Clears last drawn snap drawing element (inherited from CADImage).
Public method | ClearUndoCollection | Clears undo entity collection (inherited from CADImage).
Public method | CopyEntities | (Overloaded) Copies selected entities to the clipboard (inherited from CADImage).
Public method | CorrectByGrid | (Overloaded) Reduces a point location on screen to the grid node when the grid is active (inherited from CADImage).
Public method | CorrectByGridAndOrtho | Reduces a point relocation sizes on screen to the grid cell sizes when the grid is active (inherited from CADImage).
 | CreateImageByExtension | Creates specialised CADImage object for specified file extention (inherited from CADImage).
Public method | CutEntities | (Overloaded) Cuts selected entities from collection and paste them to the clipboard (inherited from CADImage).
Public method | Dispose | Releases the resources used by this CGMImage object.
Public method | DoSelectEntities | (Overloaded) Selects inserted list of entities (inherited from CADImage).
Public method | DoSelectEntity | Selects inserted entity (inherited from CADImage).
Public method | Draw | (Overloaded) Draws a CADImage. (inherited from CADImage).
Public method | DrawACISEntity | Draws ACISEntity object (inherited from CADImage).
Public method | DrawChangeEntity | Changes a position of the marker designating the selected entity. (inherited from CADImage).
Public method | DrawMoveEntityTrace | Draws entities on their offsetting (inherited from CADImage).
Public method | DrawSnapTrace | Draws snap icon in case of proximity of object to current coordinates (inherited from CADImage).
Public method | EmfConvertToDXF | (Overloaded) Converts emf file to dxf file (inherited from CADImage).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportToMetafile | (Overloaded) Exports a CAD drawing to Windows Enhanced metafile. (inherited from CADImage).
Public method | GetAbsPoint | Converts display coordinates into absolute coordinates of a design (inherited from CADImage).
Public method | GetCADCoords | Returns coordinates of a point on the drawing. (inherited from CADImage).
Public method | GetCenter | Returns the center point of a current layout (inherited from CADImage).
Public method | GetExtents | Calculates the current dimensions of the CADImage. (inherited from CADImage).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLayerColor | Gets layer color by index (inherited from CADImage).
Public method | GetLayerFreeze | Determines whether the layer (CADLayer) is frozen. (inherited from CADImage).
Public method | GetLayerName | Gets a name of the layer that has the specified index in the collection of layers. (inherited from CADImage).
Public method | GetLayerVisible | Determines whether a layer is visible (inherited from CADImage).
Public method | GetLayoutName | Gets a name of the layout that has the specified index in the collection of layouts. (inherited from CADImage).
Public method | GetPoint | Transforms a three-dimensional CAD point into a two-dimensional screen point. (inherited from CADImage).
Public method | GetRealImagePoint | For internal use. (inherited from CADImage).
Public method | GetRealSnapPoint | Smooths a point in absolute coordinates by the entity (inherited from CADImage).
Public method | GetSelectEntityRegion | Returns the selected area of the image. (inherited from CADImage).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetVPortExtents | Returns extents of the active VPort reduced to the specified size (inherited from CADImage).
Public method | InitialNewImage | (Overloaded) Initializes a new image with the default size (inherited from CADImage).
Public method | InvalidateSelectEntity | Redraws a selected entity. (inherited from CADImage).
Public method | InvalidateSelectedEntities | (Overloaded) Redraws a list of the selected entities (inherited from CADImage).
Public method | LoadFromFile | Loads a CGM image stored in the specified file.
Public method | LoadFromStream | Loads a CGM image stored in the specified stream.
Public method | LoadFromWeb | Loads CAD image from hyperlink (inherited from CADImage).
Public method | MultipleSelect | Providing CAD image entities' multiple selection within a specified rectangle. (inherited from CADImage).
Public method | MultipleSelectExt | Selects all entities inside the inserted rectangle (inherited from CADImage).
Public method | PasteEntities | Pastes entities from the clipboard (inherited from CADImage).
Public method | PasteEntitiesExt | Pastes entities from the clipboard (inherited from CADImage).
Public method | Print | Prints a current CAD image. (inherited from CADImage).
Public method | Redo | Redo change (inherited from CADImage).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RefreshCurrentLayout | Refresh current layout. (inherited from CADImage).
Public method | RefreshSnapTrace | Refreshes a region of the last drawn snap drawing element (inherited from CADImage).
Public method | RemoveEntity | (Overloaded) Removes CADEntity object. (inherited from CADImage).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from CADImage).
Public method | RotToView | Rotates a CAD image to get a specified view. (inherited from CADImage).
Public method | Rotate | Rotates objects in the current drawing. (inherited from CADImage).
Public method | SaveAsDXF | Saves a current CAD image in DXF format. (inherited from CADImage).
Public method | SaveImageToClipboard | (Overloaded) Writes a visible part of the current CAD image to the clipboard as a raster image. (inherited from CADImage).
Public method | SaveToFile | (Overloaded) Saves a part of the current CAD image to the file of the specified format. (inherited from CADImage).
Public method | SaveToStream | (Overloaded) Writes a visible part of the current CAD image to the specified stream as a raster image. (inherited from CADImage).
Public method | Select | Selects an entity of the CAD image at the specified point. (inherited from CADImage).
Public method | SelectExt | Selects an entity of the CAD image at the specified point. (inherited from CADImage).
Public method | SetCenter | Sets CADImage center point. (inherited from CADImage).
Public method | SetCurrentLayout | Sets a current layout of this CADImage. (inherited from CADImage).
Public method | SetLayerColor | (Overloaded) Sets a color for layer (CADLayer) specified by index (inherited from CADImage).
Public method | SetLayerFreeze | (Overloaded) Sets freeze parameter for CADLayer (inherited from CADImage).
Public method | SetLayerVisible | (Overloaded) Sets a visibility of the layer. (inherited from CADImage).
Public method | SetNewEntityMarkerPos | Sets a new position for the selected entity. The entity's new position is defined by the position of the marker. (inherited from CADImage).
Public method | SetNewMMToPixel | Sets a quantity of millimeters per pixel for the specified Graphics object. (inherited from CADImage).
Public method | SetNewPosEntitiesExt | Sets a new position for the specified entities (inherited from CADImage).
Public method | SetNewPosEntity | Sets a new position for the specified entity. (inherited from CADImage).
Public method | Stop | For internal use. (inherited from CADImage).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | Undo | Undo change (inherited from CADImage).
Top
See Also

Reference

CGMImage Class
CADImport.CGM Namespace


CGMImage.Dispose Method

Releases the resources used by this CGMImage object.

Namespace: CADImport.CGM
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CGMImage Class
CGMImage Members
CADImport.CGM Namespace


CGMImage.LoadFromFile Method

Loads a CGM image stored in the specified file.

Namespace: CADImport.CGM
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub LoadFromFile( _
   ByVal path As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void LoadFromFile(
   string path
)
This language is not supported or no code example is available.

Parameters

path

Type: string

A path to the file that contains a CGM image to be loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CGMImage Class
CGMImage Members
CADImport.CGM Namespace


CGMImage.LoadFromStream Method

Loads a CGM image stored in the specified stream.

Namespace: CADImport.CGM
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub LoadFromStream( _
   ByVal stream As Stream _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void LoadFromStream(
   Stream stream
)
This language is not supported or no code example is available.

Parameters

stream

Type: Stream

A Stream that contains a CGM image to be loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CGMImage Class
CGMImage Members
CADImport.CGM Namespace


CGMImage Fields

CGMImage Class See Also

The following tables list the members exposed by the CGMImage type.

Fields
 | Name | Description
 | EntityBuffer | Represents buffer for CADEntityCollection storing. (inherited from CADImage).
Public field | progress | A CGMProgressEvent object representing the methods invoked while loading the file.
Public field | visibleArea | Represents CADImage visible area. (inherited from CADImage).
Top
See Also

Reference

CGMImage Class
CADImport.CGM Namespace


progress Field

A CGMProgressEvent object representing the methods invoked while loading the file.

Namespace: CADImport.CGM
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public progress As CGMProgressEvent
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CGMProgressEvent progress
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CGMImage Class
CGMImage Members
CADImport.CGM Namespace


CGMProgressEvent Delegate

Represents methods invoked while loading the file.

Namespace: CADImport.CGM
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Delegate Sub CGMProgressEvent( _
   ByVal stage As ProgressStage, _
   ByVal done As Integer, _
   ByVal count As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public delegate void CGMProgressEvent(
   ProgressStage stage,
   int done,
   int count
)
This language is not supported or no code example is available.

Parameters

stage

Type: ProgressStage

done

Type: int

count

Type: int

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImport.CGM Namespace


CADImport.DWG Namespace

Assembly: CADImport (in CADImport.dll)

Classes
 | Name | Description
Public class | DWGConverter | Provides methods for loading a file and producing a set of CAD entities contained in the loaded file.
Public class | DWGImage | Provides methods for drawing CAD entities loaded from a DWG file.
Top
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


DWGConverter Class

Members See Also

Provides methods for loading a file and producing a set of CAD entities contained in the loaded file.

Namespace: CADImport.DWG
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class DWGConverter
    Inherits CADConverter
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class DWGConverter : CADConverter
This language is not supported or no code example is available.
Remarks

All loaded entities are descendants of the CADEntity class.

Inheritance Hierarchy
System.Object
CADImport.CADConverter
CADImport.DWG.DWGConverter
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DWGConverter Members
CADImport.DWG Namespace


DWGConverter Members

DWGConverter Class Constructors Events Methods Properties See Also

Provides methods for loading a file and producing a set of CAD entities contained in the loaded file.

The following tables list the members exposed by the DWGConverter type.

Constructors
 | Name | Description
Public constructor | DWGConverter | Initializes a new instance of the DWGConverter class.
Top
Properties
 | Name | Description
Public property | ActiveVPort | Gets or sets active CADVPort object (inherited from CADConverter).
Public property | AllArcsAsCurves | Gets or sets a value indicating how arcs are drawn. (inherited from CADConverter).
Public property | Angle | Gets or sets a current rotation angle of the active VPort. (inherited from CADConverter).
Public property | AutoInsert | Gets or sets a value indicating a way of processing CAD blocks. (inherited from CADConverter).
Public property | Block | Gets a block to be drawn at spesified layout. (inherited from CADConverter).
Public property | Blocks | Gets a collection of blocks contained in the loaded CAD file. (inherited from CADConverter).
Public property | CodePage | Gets or sets a number that identifies the encoding used in the loaded CAD file. (inherited from CADConverter).
Public property | DWGPROPS | A set of properties for an AutoCAD drawing (inherited from CADConverter).
Public property | DefaultLayoutIndex | Gets or sets an index of layout that will be shown after opening a CAD file. (inherited from CADConverter).
Public property | DimensionStyles | Gets a collection of styles used for drawing the dimensions in the loaded CAD file. (inherited from CADConverter).
Public property | Entities | Gets a collection of entities contained in the loaded CAD file. (inherited from CADConverter).
Public property | Extents | Gets or sets extents of the loaded CAD file. (inherited from CADConverter).
Public property | HasActiveVPort | Gets or sets a value idicating whether a loaded CAD file has an active VPort. (inherited from CADConverter).
Public property | HeadStruct | Gets or sets HeadVarStruct object containing settings of CAD file (inherited from CADConverter).
Public property | ImageDefs | Gets a collection of raster images contained in the loaded CAD file. (inherited from CADConverter).
Public property | Is3D | Checks whether a loaded CAD image is three-dimensional. (inherited from CADConverter).
Public property | IsCrossoverMatrix | Gets or sets a value indicating an orientation of the used coordinate system. (inherited from CADConverter).
Public property | IsHideWipeouts | Gets or sets a border visibility of all Wipeout objects in CAD file (inherited from CADConverter).
Public property | IsLoadXrefs | Gets or sets a value indicating whether XRefs to be loaded while opening a CAD file. (inherited from CADConverter).
Public property | LScale | Gets or sets a scale for all linetypes in the loaded CAD file. (inherited from CADConverter).
Public property | LTypes | Gets a collection of linetypes contained in the loaded CAD file. (inherited from CADConverter).
Public property | Layers | Gets a collection of layers contained in the loaded CAD file. (inherited from CADConverter).
Public property | Layouts | Gets a collection of layouts contained in the loaded CAD file. (inherited from CADConverter).
Public property | LayoutsCount | Gets a quantity of layouts contained in the loaded CAD file. (inherited from CADConverter).
Public property | Main | Gets a main section of the loaded CAD file. (inherited from CADConverter).
Public property | MaxHandle | Gets or sets a maximal handle of a primitive (inherited from CADConverter).
Public property | ModelLayout | Gets CADLayout object of model (inherited from CADConverter).
Public property | NumberOfPartsInCircle | Gets or sets a quantity of segments to be used to draw a circle. (inherited from CADConverter).
Public property | NumberOfPartsInSpline | Gets or sets a quantity of segments to be used to draw a spline. (inherited from CADConverter).
Public property | Params | Gets or sets parameters to be processed by the Iterate method. (inherited from CADConverter).
Public property | PointDisplayMode | Gets or sets a value indicating a mode of displaying the CADPoint entities in the loaded CAD file. (inherited from CADConverter).
Public property | SHXFonts | Gets a list of SHX fonts for the loaded CAD file. (inherited from CADConverter).
Public property | SHXSettings | Gets SHX fonts settings. (inherited from CADConverter).
Public property | Source | Gets or sets a path to the loaded file. (inherited from CADConverter).
Public property | Styles | Gets a collection of styles contained in the loaded CAD file. (inherited from CADConverter).
Public property | Tables | Gets a collection of tables contained in the loaded CAD file. (inherited from CADConverter).
Public property | VPort | Gets or sets a viewing direction for the ActiveVPort. (inherited from CADConverter).
Public property | VPorts | Gets a list of CADVPort objects contained in CAD file (inherited from CADConverter).
Public property | ViewPortCut | Gets a value indicating whether a loaded CAD file appears inside a viewport. (inherited from CADConverter).
Public property | XRefs | Gets a collection of external references contained in the loaded CAD file. (inherited from CADConverter).
Top
Methods
 | Name | Description
Public method | AddDrawingLayout | Creates a CADLayout with the specified name and adds this layout to the specified CAD image. (inherited from CADConverter).
Public method | AddLayout | Adds object of the CADLayout class. (inherited from CADConverter).
Public method | AddXRef | Creates a CADXRef object with the specified name and adds this external reference to the specified CAD image. (inherited from CADConverter).
Public method | AddXRefEx | Creates a CADXRef object with the specified name and adds this external reference to the specified CAD image. (inherited from CADConverter).
Public method | BlockByName | Searches blocks section and returns a CADBlock object with the specified name. (inherited from CADConverter).
Public method | CleaningLayouts | Deletes all empty instances of the CADLayout class with the exception of the Model_Space layout. (inherited from CADConverter).
Public method | DimensionStyleByName | Searches a dimension style with the specified name among the dimension styles from the loaded CAD file. (inherited from CADConverter).
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from CADConverter).
Public method | DoExtents | Sets extents of the CAD drawing. (inherited from CADConverter).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetArrowTypeByName | Searches a specified dimension arrow name in array (inherited from CADConverter).
Public method | GetCounts | Returns a number of elements in the specified section. (inherited from CADConverter).
Public method | GetDWGCodePage | Returns a number of codepage (inherited from CADConverter).
Public method | GetDWGVersion | Returns a version of DWG or DXF file (inherited from CADConverter).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLayerNames | Adds the names of all layers from the loaded CAD file to the specified list. (inherited from CADConverter).
Public method | GetSection | Returns a group of objects corresponding to the specified type of CAD section. (inherited from CADConverter).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Initialize | Initializes a main section of the loaded CAD file.
Public method | InitializeSections | This method makes necessary initializations for sections. Call it when creating CAD object manually. (inherited from CADConverter).
 | IntToColor | Converts an int value to the Color object. (inherited from CADConverter).
Public method | Iterate | Invokes a method referenced by the specified delegate for each loaded entity. (inherited from CADConverter).
Public method | LTypeByName | Returns a linetype with the specified name. (inherited from CADConverter).
Public method | LayerByName | Returns a layer with the specified name. (inherited from CADConverter).
Public method | LayoutByName | Searches layouts section and returns a CADLayout object with the specified name. (inherited from CADConverter).
Public method | LinesByName | Returns a description of linetype with the specified name. (inherited from CADConverter).
Public method | Loads | Loads the specified entity to the CADConverter. (inherited from CADConverter).
Public method | OnAfterRead | Raises a AfterReadEvent. (inherited from CADConverter).
Public method | OnBeforeRead | Raises a BeforeReadEvent. (inherited from CADConverter).
Public method | OnCreate | Raises an OnCreateEvent. (inherited from CADConverter).
Public method | OnInsert | Raises an OnInsertEvent. (inherited from CADConverter).
Public method | OnResolveXRef | Raises an OnResolveXRefEvent. (inherited from CADConverter).
Public method | OnViewPort | Raises an OnViewPortEvent. (inherited from CADConverter).
Public method | OnXRef | Raises an OnXRefEvent. (inherited from CADConverter).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetHandle | Sets a handle for a CADEntity object. (inherited from CADConverter).
Public method | SetSection | Sets a CADGroup object to the specified section type. (inherited from CADConverter).
Public method | SortEntities | Sorts CAD entities by their handles according to the CADSortEntsTable loaded from the CAD file. (inherited from CADConverter).
Public method | StyleByName | Returns a style with the specified name. (inherited from CADConverter).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Events
 | Name | Description
Public event | AfterReadEvent | Occurs after reading a DXF file. (inherited from CADConverter).
Public event | BeforeReadEvent | Occurs before reading a DXF file. (inherited from CADConverter).
Public event | OnCreateEvent | Occurs when an instance of each loaded CAD entity is created. (inherited from CADConverter).
Public event | OnInsertEvent | Occurs when an object of the CADInsert class or its descendants inserted into a CAD image. (inherited from CADConverter).
 | OnResolveXRefEvent | Occurs when xref filename not found. (inherited from CADConverter).
Public event | OnViewPortEvent | Occurs when loading a CADViewPort object into a CAD image is complete. (inherited from CADConverter).
Top
See Also

Reference

DWGConverter Class
CADImport.DWG Namespace


DWGConverter Constructor

Initializes a new instance of the DWGConverter class.

Namespace: CADImport.DWG
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DWGConverter()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DWGConverter Class
DWGConverter Members
CADImport.DWG Namespace


DWGConverter Properties

DWGConverter Class See Also

The following tables list the members exposed by the DWGConverter type.

Properties
 | Name | Description
Public property | ActiveVPort | Gets or sets active CADVPort object (inherited from CADConverter).
Public property | AllArcsAsCurves | Gets or sets a value indicating how arcs are drawn. (inherited from CADConverter).
Public property | Angle | Gets or sets a current rotation angle of the active VPort. (inherited from CADConverter).
Public property | AutoInsert | Gets or sets a value indicating a way of processing CAD blocks. (inherited from CADConverter).
Public property | Block | Gets a block to be drawn at spesified layout. (inherited from CADConverter).
Public property | Blocks | Gets a collection of blocks contained in the loaded CAD file. (inherited from CADConverter).
Public property | CodePage | Gets or sets a number that identifies the encoding used in the loaded CAD file. (inherited from CADConverter).
Public property | DWGPROPS | A set of properties for an AutoCAD drawing (inherited from CADConverter).
Public property | DefaultLayoutIndex | Gets or sets an index of layout that will be shown after opening a CAD file. (inherited from CADConverter).
Public property | DimensionStyles | Gets a collection of styles used for drawing the dimensions in the loaded CAD file. (inherited from CADConverter).
Public property | Entities | Gets a collection of entities contained in the loaded CAD file. (inherited from CADConverter).
Public property | Extents | Gets or sets extents of the loaded CAD file. (inherited from CADConverter).
Public property | HasActiveVPort | Gets or sets a value idicating whether a loaded CAD file has an active VPort. (inherited from CADConverter).
Public property | HeadStruct | Gets or sets HeadVarStruct object containing settings of CAD file (inherited from CADConverter).
Public property | ImageDefs | Gets a collection of raster images contained in the loaded CAD file. (inherited from CADConverter).
Public property | Is3D | Checks whether a loaded CAD image is three-dimensional. (inherited from CADConverter).
Public property | IsCrossoverMatrix | Gets or sets a value indicating an orientation of the used coordinate system. (inherited from CADConverter).
Public property | IsHideWipeouts | Gets or sets a border visibility of all Wipeout objects in CAD file (inherited from CADConverter).
Public property | IsLoadXrefs | Gets or sets a value indicating whether XRefs to be loaded while opening a CAD file. (inherited from CADConverter).
Public property | LScale | Gets or sets a scale for all linetypes in the loaded CAD file. (inherited from CADConverter).
Public property | LTypes | Gets a collection of linetypes contained in the loaded CAD file. (inherited from CADConverter).
Public property | Layers | Gets a collection of layers contained in the loaded CAD file. (inherited from CADConverter).
Public property | Layouts | Gets a collection of layouts contained in the loaded CAD file. (inherited from CADConverter).
Public property | LayoutsCount | Gets a quantity of layouts contained in the loaded CAD file. (inherited from CADConverter).
Public property | Main | Gets a main section of the loaded CAD file. (inherited from CADConverter).
Public property | MaxHandle | Gets or sets a maximal handle of a primitive (inherited from CADConverter).
Public property | ModelLayout | Gets CADLayout object of model (inherited from CADConverter).
Public property | NumberOfPartsInCircle | Gets or sets a quantity of segments to be used to draw a circle. (inherited from CADConverter).
Public property | NumberOfPartsInSpline | Gets or sets a quantity of segments to be used to draw a spline. (inherited from CADConverter).
Public property | Params | Gets or sets parameters to be processed by the Iterate method. (inherited from CADConverter).
Public property | PointDisplayMode | Gets or sets a value indicating a mode of displaying the CADPoint entities in the loaded CAD file. (inherited from CADConverter).
Public property | SHXFonts | Gets a list of SHX fonts for the loaded CAD file. (inherited from CADConverter).
Public property | SHXSettings | Gets SHX fonts settings. (inherited from CADConverter).
Public property | Source | Gets or sets a path to the loaded file. (inherited from CADConverter).
Public property | Styles | Gets a collection of styles contained in the loaded CAD file. (inherited from CADConverter).
Public property | Tables | Gets a collection of tables contained in the loaded CAD file. (inherited from CADConverter).
Public property | VPort | Gets or sets a viewing direction for the ActiveVPort. (inherited from CADConverter).
Public property | VPorts | Gets a list of CADVPort objects contained in CAD file (inherited from CADConverter).
Public property | ViewPortCut | Gets a value indicating whether a loaded CAD file appears inside a viewport. (inherited from CADConverter).
Public property | XRefs | Gets a collection of external references contained in the loaded CAD file. (inherited from CADConverter).
Top
See Also

Reference

DWGConverter Class
CADImport.DWG Namespace


DWGConverter Methods

DWGConverter Class See Also

The following tables list the members exposed by the DWGConverter type.

Methods
 | Name | Description
Public method | AddDrawingLayout | Creates a CADLayout with the specified name and adds this layout to the specified CAD image. (inherited from CADConverter).
Public method | AddLayout | Adds object of the CADLayout class. (inherited from CADConverter).
Public method | AddXRef | Creates a CADXRef object with the specified name and adds this external reference to the specified CAD image. (inherited from CADConverter).
Public method | AddXRefEx | Creates a CADXRef object with the specified name and adds this external reference to the specified CAD image. (inherited from CADConverter).
Public method | BlockByName | Searches blocks section and returns a CADBlock object with the specified name. (inherited from CADConverter).
Public method | CleaningLayouts | Deletes all empty instances of the CADLayout class with the exception of the Model_Space layout. (inherited from CADConverter).
Public method | DimensionStyleByName | Searches a dimension style with the specified name among the dimension styles from the loaded CAD file. (inherited from CADConverter).
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from CADConverter).
Public method | DoExtents | Sets extents of the CAD drawing. (inherited from CADConverter).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetArrowTypeByName | Searches a specified dimension arrow name in array (inherited from CADConverter).
Public method | GetCounts | Returns a number of elements in the specified section. (inherited from CADConverter).
Public method | GetDWGCodePage | Returns a number of codepage (inherited from CADConverter).
Public method | GetDWGVersion | Returns a version of DWG or DXF file (inherited from CADConverter).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLayerNames | Adds the names of all layers from the loaded CAD file to the specified list. (inherited from CADConverter).
Public method | GetSection | Returns a group of objects corresponding to the specified type of CAD section. (inherited from CADConverter).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Initialize | Initializes a main section of the loaded CAD file.
Public method | InitializeSections | This method makes necessary initializations for sections. Call it when creating CAD object manually. (inherited from CADConverter).
 | IntToColor | Converts an int value to the Color object. (inherited from CADConverter).
Public method | Iterate | Invokes a method referenced by the specified delegate for each loaded entity. (inherited from CADConverter).
Public method | LTypeByName | Returns a linetype with the specified name. (inherited from CADConverter).
Public method | LayerByName | Returns a layer with the specified name. (inherited from CADConverter).
Public method | LayoutByName | Searches layouts section and returns a CADLayout object with the specified name. (inherited from CADConverter).
Public method | LinesByName | Returns a description of linetype with the specified name. (inherited from CADConverter).
Public method | Loads | Loads the specified entity to the CADConverter. (inherited from CADConverter).
Public method | OnAfterRead | Raises a AfterReadEvent. (inherited from CADConverter).
Public method | OnBeforeRead | Raises a BeforeReadEvent. (inherited from CADConverter).
Public method | OnCreate | Raises an OnCreateEvent. (inherited from CADConverter).
Public method | OnInsert | Raises an OnInsertEvent. (inherited from CADConverter).
Public method | OnResolveXRef | Raises an OnResolveXRefEvent. (inherited from CADConverter).
Public method | OnViewPort | Raises an OnViewPortEvent. (inherited from CADConverter).
Public method | OnXRef | Raises an OnXRefEvent. (inherited from CADConverter).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetHandle | Sets a handle for a CADEntity object. (inherited from CADConverter).
Public method | SetSection | Sets a CADGroup object to the specified section type. (inherited from CADConverter).
Public method | SortEntities | Sorts CAD entities by their handles according to the CADSortEntsTable loaded from the CAD file. (inherited from CADConverter).
Public method | StyleByName | Returns a style with the specified name. (inherited from CADConverter).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

DWGConverter Class
CADImport.DWG Namespace


DWGConverter.Initialize Method

Initializes a main section of the loaded CAD file.

Namespace: CADImport.DWG
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Initialize()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Initialize()
This language is not supported or no code example is available.
Remarks

A main section is specified by the Main property.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DWGConverter Class
DWGConverter Members
CADImport.DWG Namespace


DWGConverter Events

DWGConverter Class See Also

The following tables list the members exposed by the DWGConverter type.

Events
 | Name | Description
Public event | AfterReadEvent | Occurs after reading a DXF file. (inherited from CADConverter).
Public event | BeforeReadEvent | Occurs before reading a DXF file. (inherited from CADConverter).
Public event | OnCreateEvent | Occurs when an instance of each loaded CAD entity is created. (inherited from CADConverter).
Public event | OnInsertEvent | Occurs when an object of the CADInsert class or its descendants inserted into a CAD image. (inherited from CADConverter).
 | OnResolveXRefEvent | Occurs when xref filename not found. (inherited from CADConverter).
Public event | OnViewPortEvent | Occurs when loading a CADViewPort object into a CAD image is complete. (inherited from CADConverter).
Top
See Also

Reference

DWGConverter Class
CADImport.DWG Namespace


DWGImage Class

Members See Also

Provides methods for drawing CAD entities loaded from a DWG file.

Namespace: CADImport.DWG
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class DWGImage
    Inherits CADImage
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class DWGImage : CADImage
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADImage
CADImport.DWG.DWGImage
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DWGImage Members
CADImport.DWG Namespace


DWGImage Members

DWGImage Class Constructors Methods Fields Properties See Also

Provides methods for drawing CAD entities loaded from a DWG file.

The following tables list the members exposed by the DWGImage type.

Constructors
 | Name | Description
Public constructor | DWGImage | Initializes a new instance of the DWGImage class.
Top
Properties
 | Name | Description
Public property | AbsDepth | Gets an absolute depths of the CADImage. (inherited from CADImage).
Public property | AbsHeight | Gets an absolute height of the CADImage. (inherited from CADImage).
Public property | AbsWidth | Gets an absolute width of the CADImage. (inherited from CADImage).
Public property | Angle | Gets or sets the angle for this CADImage object visualization. (inherited from CADImage).
Public property | BackgroundColor | Gets or sets a background color of this CADImage. (inherited from CADImage).
Public property | BorderSize | Gets or sets a border size in pixels. (inherited from CADImage).
Public property | BorderType | Gets or sets a border type. (inherited from CADImage).
Public property | Center | Gets or sets CADImage center point. (inherited from CADImage).
Public property | Charset | Gets or sets a character set for the text entities. (inherited from CADImage).
 | CodePage | Gets or sets a number that identifies the encoding used in the loaded CAD file. (inherited from CADImage).
Public property | Converter | Gets a converter that loads CAD entities from the file to draw them in the current CADImage. (inherited from CADImage).
Public property | CurrentLayer | Gets or sets a current layer for the CADImage. (inherited from CADImage).
Public property | CurrentLayout | Gets or sets a current layout for the CADImage. (inherited from CADImage).
Public property | CurrentLayoutIndex | Gets an index of the current layout. (inherited from CADImage).
Public property | CurrentMarker | Gets a currently selected marker. (inherited from CADImage).
Public property | DefaultColor | Gets or sets a default color for the CADImage. (inherited from CADImage).
Public property | DefaultLayoutIndex | Gets or sets a default layout index. (inherited from CADImage).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions on the drawing are visible. (inherited from CADImage).
Public property | DrawMode | Gets or sets a current drawing mode. (inherited from CADImage).
Public property | EnableSnap | Gets or sets enablement of snap mode (inherited from CADImage).
Public property | Extents | Gets or sets an extents of the CADImage object. (inherited from CADImage).
Public property | FileInf | Gets information about a currently open file by means of the FileInfo class. (inherited from CADImage).
Public property | GDIPainter | Provides drawing functionality based on GDI+. (inherited from CADImage).
Public property | GraphicsOutMode | Specifies image draw mode. (inherited from CADImage).
Public property | InterpolationMode | Gets or sets the interpolation mode associated with current Graphics object (inherited from CADImage).
Public property | Is3D | Gets a value indicating whether this CADImage is three-dimensional. (inherited from CADImage).
Public property | IsDraw3DAxes | Gets or sets a value indicating whether 3D axes are shown on the drawing. (inherited from CADImage).
Public property | IsDrawingRotated | Gets a value indicating whether the CADImage has been rotated. (inherited from CADImage).
Public property | IsShowBackground | Gets or sets a value indicating using of a BackgroundColor. (inherited from CADImage).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data. (inherited from CADImage).
Public property | IsSnapObject | Gets a value, which shows if there is an object for snapping under current coordinates (inherited from CADImage).
Public property | IsStopped | For internal use. (inherited from CADImage).
Public property | IsWithoutBorder | Gest or sets a value indicating whether to draw the CADImage without borders. (inherited from CADImage).
Public property | IsWithoutMargins | Gets or sets a value indicating whether to draw the CADImage without margins. (inherited from CADImage).
 | LastLoadedFilePath | Specifying of the search directory (used for X-Refs, ImageEnt) (inherited from CADImage).
Public property | LayersCount | Gets a quantity of layers in this CADImage. (inherited from CADImage).
Public property | Layouts | Gets a collection of layouts in the current CADImage. (inherited from CADImage).
Public property | LayoutsCount | Gets a quantity of layouts in this CADImage. (inherited from CADImage).
Public property | LineScaled | Obsolete. Gets or sets a value indicating whether a width of lines to draw all entities in the drawing is specified by the file data. (inherited from CADImage).
Public property | LineWeightScale | Gets or sets a scale for drawing lines. (inherited from CADImage).
Public property | MMToPixelX | Gets or sets a value corresponding to amount of millimeters per one pixel. (inherited from CADImage).
Public property | NullWidth | Gets or sets default thickness for lines used to draw a CADImage. (inherited from CADImage).
Public property | NumberOfPartsInCircle | Gets or sets a quantity of segments to be used to draw a circle. (inherited from CADImage).
Public property | Painter | Provides image drawing functionality. (inherited from CADImage).
Public property | PrintDialog | Gets or sets print dialog (inherited from CADImage).
Public property | PureExtents | Gets CADImage extents without margins. (inherited from CADImage).
Public property | ResizeDisproportionateDrawing | For internal use (inherited from CADImage).
Public property | SHXSearchPaths | Gets or sets paths for searching SHX fonts. (inherited from CADImage).
Public property | SearchSHXPaths | Gets or sets a value specifying whether SHX paths will be searched for the fonts. (inherited from CADImage).
Public property | SelectEntitiesCount | Gets the number of selected entities (inherited from CADImage).
Public property | SelectedEntities | Gets or sets a list of selected entities (inherited from CADImage).
Public property | SelectionMode | Gets or sets a state of the Selection tool. (inherited from CADImage).
Public property | Selector | Provides selection functionality. (inherited from CADImage).
Public property | SkipMMtoPixel | For specific use (inherited from CADImage).
Public property | SnapCurrent | (inherited from CADImage).
Public property | SnapOptions | Represents Snap options for the CADImage object (inherited from CADImage).
Public property | SnapRealPoint | Gets a current point in absolute coordinates (drawing coordinates) (inherited from CADImage).
Public property | SnapScreenPoint | Gets current point in display coordinates (inherited from CADImage).
Public property | TTFSmoothing | Gets or sets a value indicating whether TTF fonts are smoothed. (inherited from CADImage).
Public property | TextVisible | Gets or sets a value indicating whether the texts in the CADImage are visible. (inherited from CADImage).
Public property | UndoMode | Gets or sets whether undo/redo is disable or enable for professional version (inherited from CADImage).
Public property | UseDoubleBuffering | Outdated. Does nothing (inherited from CADImage).
Public property | UseLayerPriority | (inherited from CADImage).
Public property | UseMultyTTFFonts | Gets or sets a value indicating whether a multimode is used for showing symbols. (inherited from CADImage).
Public property | UseNullWidth | Specifies if default width will be used instead of entity width. (inherited from CADImage).
Public property | UseSHXFonts | Specifies if SHX fonts will be used for visualization. (inherited from CADImage).
Public property | UseTTFFonts | Specifies if TTF fonts will be used for visualization. (inherited from CADImage).
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles in the CADImage are drawn with GDI+ drawing methods without linearization. (inherited from CADImage).
Top
Methods
 | Name | Description
Public method | ActiveVPort | Returns drawing area visualized with the active VPort. (inherited from CADImage).
Public method | AddScaledDXF | Adds a scaled external reference to the model space of the specified CAD image. (inherited from CADImage).
Public method | AddScaledDXFEx | Adds a scaled external reference to the current layout of the specified CAD image. (inherited from CADImage).
Public method | AddToUndoList | (Overloaded) Adds operation "create new Entity" to undo list (inherited from CADImage).
Public method | ChangeDrawMode | Initializes a new graphic class object if current mode changed. (inherited from CADImage).
Public method | ChangeEntities | (inherited from CADImage).
Public method | ChangeGraphicsMode | Changes image drawing mode. (inherited from CADImage).
Public method | ChangePositionSelectedEntities | Changes position of the selected entities (inherited from CADImage).
Public method | ChangePositionSelectedEntity | Changes a position of the selected entity. (inherited from CADImage).
Public method | ClearBuffer | Outdated. Does nothing (inherited from CADImage).
Public method | ClearMarkers | Clears a collection of markers. (inherited from CADImage).
Public method | ClearRedoCollection | Clears redo entity collection (inherited from CADImage).
Public method | ClearSelectCollection | Clears a collection of the selected entities. (inherited from CADImage).
Public method | ClearSelection | Clears a list of the selected entities. (inherited from CADImage).
Public method | ClearSnapTrace | (Overloaded) Clears last drawn snap drawing element (inherited from CADImage).
Public method | ClearUndoCollection | Clears undo entity collection (inherited from CADImage).
Public method | CopyEntities | (Overloaded) Copies selected entities to the clipboard (inherited from CADImage).
Public method | CorrectByGrid | (Overloaded) Reduces a point location on screen to the grid node when the grid is active (inherited from CADImage).
Public method | CorrectByGridAndOrtho | Reduces a point relocation sizes on screen to the grid cell sizes when the grid is active (inherited from CADImage).
 | CreateImageByExtension | Creates specialised CADImage object for specified file extention (inherited from CADImage).
Public method | CutEntities | (Overloaded) Cuts selected entities from collection and paste them to the clipboard (inherited from CADImage).
Public method | Dispose | Disposes a DWGImage object.
Public method | DoSelectEntities | (Overloaded) Selects inserted list of entities (inherited from CADImage).
Public method | DoSelectEntity | Selects inserted entity (inherited from CADImage).
Public method | Draw | (Overloaded) Draws a CADImage. (inherited from CADImage).
Public method | DrawACISEntity | Draws ACISEntity object (inherited from CADImage).
Public method | DrawChangeEntity | Changes a position of the marker designating the selected entity. (inherited from CADImage).
Public method | DrawMoveEntityTrace | Draws entities on their offsetting (inherited from CADImage).
Public method | DrawSnapTrace | Draws snap icon in case of proximity of object to current coordinates (inherited from CADImage).
Public method | EmfConvertToDXF | (Overloaded) Converts emf file to dxf file (inherited from CADImage).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportToMetafile | (Overloaded) Exports a CAD drawing to Windows Enhanced metafile. (inherited from CADImage).
Public method | GetAbsPoint | Converts display coordinates into absolute coordinates of a design (inherited from CADImage).
Public method | GetCADCoords | Returns coordinates of a point on the drawing. (inherited from CADImage).
Public method | GetCenter | Returns the center point of a current layout (inherited from CADImage).
Public method | GetExtents | Calculates the current dimensions of the CADImage. (inherited from CADImage).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLayerColor | Gets layer color by index (inherited from CADImage).
Public method | GetLayerFreeze | Determines whether the layer (CADLayer) is frozen. (inherited from CADImage).
Public method | GetLayerName | Gets a name of the layer that has the specified index in the collection of layers. (inherited from CADImage).
Public method | GetLayerVisible | Determines whether a layer is visible (inherited from CADImage).
Public method | GetLayoutName | Gets a name of the layout that has the specified index in the collection of layouts. (inherited from CADImage).
Public method | GetPoint | Transforms a three-dimensional CAD point into a two-dimensional screen point. (inherited from CADImage).
Public method | GetRealImagePoint | For internal use. (inherited from CADImage).
Public method | GetRealSnapPoint | Smooths a point in absolute coordinates by the entity (inherited from CADImage).
Public method | GetSelectEntityRegion | Returns the selected area of the image. (inherited from CADImage).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetVPortExtents | Returns extents of the active VPort reduced to the specified size (inherited from CADImage).
Public method | InitialNewImage | (Overloaded) Initializes a new image with the default size (inherited from CADImage).
Public method | InvalidateSelectEntity | Redraws a selected entity. (inherited from CADImage).
Public method | InvalidateSelectedEntities | (Overloaded) Redraws a list of the selected entities (inherited from CADImage).
Public method | LoadFromFile | Uses for redefining in a descendant classes, define loading image from the specified file. (inherited from CADImage).
Public method | LoadFromStream | Loads a DWG image from the specified stream.
Public method | LoadFromWeb | Loads CAD image from hyperlink (inherited from CADImage).
Public method | MultipleSelect | Providing CAD image entities' multiple selection within a specified rectangle. (inherited from CADImage).
Public method | MultipleSelectExt | Selects all entities inside the inserted rectangle (inherited from CADImage).
Public method | PasteEntities | Pastes entities from the clipboard (inherited from CADImage).
Public method | PasteEntitiesExt | Pastes entities from the clipboard (inherited from CADImage).
Public method | Print | Prints a current CAD image. (inherited from CADImage).
Public method | Redo | Redo change (inherited from CADImage).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RefreshCurrentLayout | Refresh current layout. (inherited from CADImage).
Public method | RefreshSnapTrace | Refreshes a region of the last drawn snap drawing element (inherited from CADImage).
Public method | RemoveEntity | (Overloaded) Removes CADEntity object. (inherited from CADImage).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from CADImage).
Public method | RotToView | Rotates a CAD image to get a specified view. (inherited from CADImage).
Public method | Rotate | Rotates objects in the current drawing. (inherited from CADImage).
Public method | SaveAsDXF | Saves a current CAD image in DXF format. (inherited from CADImage).
Public method | SaveImageToClipboard | (Overloaded) Writes a visible part of the current CAD image to the clipboard as a raster image. (inherited from CADImage).
Public method | SaveToFile | (Overloaded) Saves a part of the current CAD image to the file of the specified format. (inherited from CADImage).
Public method | SaveToStream | (Overloaded) Writes a visible part of the current CAD image to the specified stream as a raster image. (inherited from CADImage).
Public method | Select | Selects an entity of the CAD image at the specified point. (inherited from CADImage).
Public method | SelectExt | Selects an entity of the CAD image at the specified point. (inherited from CADImage).
Public method | SetCenter | Sets CADImage center point. (inherited from CADImage).
Public method | SetCurrentLayout | Sets a current layout of this CADImage. (inherited from CADImage).
Public method | SetLayerColor | (Overloaded) Sets a color for layer (CADLayer) specified by index (inherited from CADImage).
Public method | SetLayerFreeze | (Overloaded) Sets freeze parameter for CADLayer (inherited from CADImage).
Public method | SetLayerVisible | (Overloaded) Sets a visibility of the layer. (inherited from CADImage).
Public method | SetNewEntityMarkerPos | Sets a new position for the selected entity. The entity's new position is defined by the position of the marker. (inherited from CADImage).
Public method | SetNewMMToPixel | Sets a quantity of millimeters per pixel for the specified Graphics object. (inherited from CADImage).
Public method | SetNewPosEntitiesExt | Sets a new position for the specified entities (inherited from CADImage).
Public method | SetNewPosEntity | Sets a new position for the specified entity. (inherited from CADImage).
Public method | Stop | For internal use. (inherited from CADImage).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | Undo | Undo change (inherited from CADImage).
Top
Fields
 | Name | Description
 | EntityBuffer | Represents buffer for CADEntityCollection storing. (inherited from CADImage).
Public field | visibleArea | Represents CADImage visible area. (inherited from CADImage).
Top
See Also

Reference

DWGImage Class
CADImport.DWG Namespace


DWGImage Constructor

Initializes a new instance of the DWGImage class.

Namespace: CADImport.DWG
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DWGImage()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DWGImage Class
DWGImage Members
CADImport.DWG Namespace


DWGImage Properties

DWGImage Class See Also

The following tables list the members exposed by the DWGImage type.

Properties
 | Name | Description
Public property | AbsDepth | Gets an absolute depths of the CADImage. (inherited from CADImage).
Public property | AbsHeight | Gets an absolute height of the CADImage. (inherited from CADImage).
Public property | AbsWidth | Gets an absolute width of the CADImage. (inherited from CADImage).
Public property | Angle | Gets or sets the angle for this CADImage object visualization. (inherited from CADImage).
Public property | BackgroundColor | Gets or sets a background color of this CADImage. (inherited from CADImage).
Public property | BorderSize | Gets or sets a border size in pixels. (inherited from CADImage).
Public property | BorderType | Gets or sets a border type. (inherited from CADImage).
Public property | Center | Gets or sets CADImage center point. (inherited from CADImage).
Public property | Charset | Gets or sets a character set for the text entities. (inherited from CADImage).
 | CodePage | Gets or sets a number that identifies the encoding used in the loaded CAD file. (inherited from CADImage).
Public property | Converter | Gets a converter that loads CAD entities from the file to draw them in the current CADImage. (inherited from CADImage).
Public property | CurrentLayer | Gets or sets a current layer for the CADImage. (inherited from CADImage).
Public property | CurrentLayout | Gets or sets a current layout for the CADImage. (inherited from CADImage).
Public property | CurrentLayoutIndex | Gets an index of the current layout. (inherited from CADImage).
Public property | CurrentMarker | Gets a currently selected marker. (inherited from CADImage).
Public property | DefaultColor | Gets or sets a default color for the CADImage. (inherited from CADImage).
Public property | DefaultLayoutIndex | Gets or sets a default layout index. (inherited from CADImage).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions on the drawing are visible. (inherited from CADImage).
Public property | DrawMode | Gets or sets a current drawing mode. (inherited from CADImage).
Public property | EnableSnap | Gets or sets enablement of snap mode (inherited from CADImage).
Public property | Extents | Gets or sets an extents of the CADImage object. (inherited from CADImage).
Public property | FileInf | Gets information about a currently open file by means of the FileInfo class. (inherited from CADImage).
Public property | GDIPainter | Provides drawing functionality based on GDI+. (inherited from CADImage).
Public property | GraphicsOutMode | Specifies image draw mode. (inherited from CADImage).
Public property | InterpolationMode | Gets or sets the interpolation mode associated with current Graphics object (inherited from CADImage).
Public property | Is3D | Gets a value indicating whether this CADImage is three-dimensional. (inherited from CADImage).
Public property | IsDraw3DAxes | Gets or sets a value indicating whether 3D axes are shown on the drawing. (inherited from CADImage).
Public property | IsDrawingRotated | Gets a value indicating whether the CADImage has been rotated. (inherited from CADImage).
Public property | IsShowBackground | Gets or sets a value indicating using of a BackgroundColor. (inherited from CADImage).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data. (inherited from CADImage).
Public property | IsSnapObject | Gets a value, which shows if there is an object for snapping under current coordinates (inherited from CADImage).
Public property | IsStopped | For internal use. (inherited from CADImage).
Public property | IsWithoutBorder | Gest or sets a value indicating whether to draw the CADImage without borders. (inherited from CADImage).
Public property | IsWithoutMargins | Gets or sets a value indicating whether to draw the CADImage without margins. (inherited from CADImage).
 | LastLoadedFilePath | Specifying of the search directory (used for X-Refs, ImageEnt) (inherited from CADImage).
Public property | LayersCount | Gets a quantity of layers in this CADImage. (inherited from CADImage).
Public property | Layouts | Gets a collection of layouts in the current CADImage. (inherited from CADImage).
Public property | LayoutsCount | Gets a quantity of layouts in this CADImage. (inherited from CADImage).
Public property | LineScaled | Obsolete. Gets or sets a value indicating whether a width of lines to draw all entities in the drawing is specified by the file data. (inherited from CADImage).
Public property | LineWeightScale | Gets or sets a scale for drawing lines. (inherited from CADImage).
Public property | MMToPixelX | Gets or sets a value corresponding to amount of millimeters per one pixel. (inherited from CADImage).
Public property | NullWidth | Gets or sets default thickness for lines used to draw a CADImage. (inherited from CADImage).
Public property | NumberOfPartsInCircle | Gets or sets a quantity of segments to be used to draw a circle. (inherited from CADImage).
Public property | Painter | Provides image drawing functionality. (inherited from CADImage).
Public property | PrintDialog | Gets or sets print dialog (inherited from CADImage).
Public property | PureExtents | Gets CADImage extents without margins. (inherited from CADImage).
Public property | ResizeDisproportionateDrawing | For internal use (inherited from CADImage).
Public property | SHXSearchPaths | Gets or sets paths for searching SHX fonts. (inherited from CADImage).
Public property | SearchSHXPaths | Gets or sets a value specifying whether SHX paths will be searched for the fonts. (inherited from CADImage).
Public property | SelectEntitiesCount | Gets the number of selected entities (inherited from CADImage).
Public property | SelectedEntities | Gets or sets a list of selected entities (inherited from CADImage).
Public property | SelectionMode | Gets or sets a state of the Selection tool. (inherited from CADImage).
Public property | Selector | Provides selection functionality. (inherited from CADImage).
Public property | SkipMMtoPixel | For specific use (inherited from CADImage).
Public property | SnapCurrent | (inherited from CADImage).
Public property | SnapOptions | Represents Snap options for the CADImage object (inherited from CADImage).
Public property | SnapRealPoint | Gets a current point in absolute coordinates (drawing coordinates) (inherited from CADImage).
Public property | SnapScreenPoint | Gets current point in display coordinates (inherited from CADImage).
Public property | TTFSmoothing | Gets or sets a value indicating whether TTF fonts are smoothed. (inherited from CADImage).
Public property | TextVisible | Gets or sets a value indicating whether the texts in the CADImage are visible. (inherited from CADImage).
Public property | UndoMode | Gets or sets whether undo/redo is disable or enable for professional version (inherited from CADImage).
Public property | UseDoubleBuffering | Outdated. Does nothing (inherited from CADImage).
Public property | UseLayerPriority | (inherited from CADImage).
Public property | UseMultyTTFFonts | Gets or sets a value indicating whether a multimode is used for showing symbols. (inherited from CADImage).
Public property | UseNullWidth | Specifies if default width will be used instead of entity width. (inherited from CADImage).
Public property | UseSHXFonts | Specifies if SHX fonts will be used for visualization. (inherited from CADImage).
Public property | UseTTFFonts | Specifies if TTF fonts will be used for visualization. (inherited from CADImage).
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles in the CADImage are drawn with GDI+ drawing methods without linearization. (inherited from CADImage).
Top
See Also

Reference

DWGImage Class
CADImport.DWG Namespace


DWGImage Methods

DWGImage Class See Also

The following tables list the members exposed by the DWGImage type.

Methods
 | Name | Description
Public method | ActiveVPort | Returns drawing area visualized with the active VPort. (inherited from CADImage).
Public method | AddScaledDXF | Adds a scaled external reference to the model space of the specified CAD image. (inherited from CADImage).
Public method | AddScaledDXFEx | Adds a scaled external reference to the current layout of the specified CAD image. (inherited from CADImage).
Public method | AddToUndoList | (Overloaded) Adds operation "create new Entity" to undo list (inherited from CADImage).
Public method | ChangeDrawMode | Initializes a new graphic class object if current mode changed. (inherited from CADImage).
Public method | ChangeEntities | (inherited from CADImage).
Public method | ChangeGraphicsMode | Changes image drawing mode. (inherited from CADImage).
Public method | ChangePositionSelectedEntities | Changes position of the selected entities (inherited from CADImage).
Public method | ChangePositionSelectedEntity | Changes a position of the selected entity. (inherited from CADImage).
Public method | ClearBuffer | Outdated. Does nothing (inherited from CADImage).
Public method | ClearMarkers | Clears a collection of markers. (inherited from CADImage).
Public method | ClearRedoCollection | Clears redo entity collection (inherited from CADImage).
Public method | ClearSelectCollection | Clears a collection of the selected entities. (inherited from CADImage).
Public method | ClearSelection | Clears a list of the selected entities. (inherited from CADImage).
Public method | ClearSnapTrace | (Overloaded) Clears last drawn snap drawing element (inherited from CADImage).
Public method | ClearUndoCollection | Clears undo entity collection (inherited from CADImage).
Public method | CopyEntities | (Overloaded) Copies selected entities to the clipboard (inherited from CADImage).
Public method | CorrectByGrid | (Overloaded) Reduces a point location on screen to the grid node when the grid is active (inherited from CADImage).
Public method | CorrectByGridAndOrtho | Reduces a point relocation sizes on screen to the grid cell sizes when the grid is active (inherited from CADImage).
 | CreateImageByExtension | Creates specialised CADImage object for specified file extention (inherited from CADImage).
Public method | CutEntities | (Overloaded) Cuts selected entities from collection and paste them to the clipboard (inherited from CADImage).
Public method | Dispose | Disposes a DWGImage object.
Public method | DoSelectEntities | (Overloaded) Selects inserted list of entities (inherited from CADImage).
Public method | DoSelectEntity | Selects inserted entity (inherited from CADImage).
Public method | Draw | (Overloaded) Draws a CADImage. (inherited from CADImage).
Public method | DrawACISEntity | Draws ACISEntity object (inherited from CADImage).
Public method | DrawChangeEntity | Changes a position of the marker designating the selected entity. (inherited from CADImage).
Public method | DrawMoveEntityTrace | Draws entities on their offsetting (inherited from CADImage).
Public method | DrawSnapTrace | Draws snap icon in case of proximity of object to current coordinates (inherited from CADImage).
Public method | EmfConvertToDXF | (Overloaded) Converts emf file to dxf file (inherited from CADImage).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportToMetafile | (Overloaded) Exports a CAD drawing to Windows Enhanced metafile. (inherited from CADImage).
Public method | GetAbsPoint | Converts display coordinates into absolute coordinates of a design (inherited from CADImage).
Public method | GetCADCoords | Returns coordinates of a point on the drawing. (inherited from CADImage).
Public method | GetCenter | Returns the center point of a current layout (inherited from CADImage).
Public method | GetExtents | Calculates the current dimensions of the CADImage. (inherited from CADImage).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLayerColor | Gets layer color by index (inherited from CADImage).
Public method | GetLayerFreeze | Determines whether the layer (CADLayer) is frozen. (inherited from CADImage).
Public method | GetLayerName | Gets a name of the layer that has the specified index in the collection of layers. (inherited from CADImage).
Public method | GetLayerVisible | Determines whether a layer is visible (inherited from CADImage).
Public method | GetLayoutName | Gets a name of the layout that has the specified index in the collection of layouts. (inherited from CADImage).
Public method | GetPoint | Transforms a three-dimensional CAD point into a two-dimensional screen point. (inherited from CADImage).
Public method | GetRealImagePoint | For internal use. (inherited from CADImage).
Public method | GetRealSnapPoint | Smooths a point in absolute coordinates by the entity (inherited from CADImage).
Public method | GetSelectEntityRegion | Returns the selected area of the image. (inherited from CADImage).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetVPortExtents | Returns extents of the active VPort reduced to the specified size (inherited from CADImage).
Public method | InitialNewImage | (Overloaded) Initializes a new image with the default size (inherited from CADImage).
Public method | InvalidateSelectEntity | Redraws a selected entity. (inherited from CADImage).
Public method | InvalidateSelectedEntities | (Overloaded) Redraws a list of the selected entities (inherited from CADImage).
Public method | LoadFromFile | Uses for redefining in a descendant classes, define loading image from the specified file. (inherited from CADImage).
Public method | LoadFromStream | Loads a DWG image from the specified stream.
Public method | LoadFromWeb | Loads CAD image from hyperlink (inherited from CADImage).
Public method | MultipleSelect | Providing CAD image entities' multiple selection within a specified rectangle. (inherited from CADImage).
Public method | MultipleSelectExt | Selects all entities inside the inserted rectangle (inherited from CADImage).
Public method | PasteEntities | Pastes entities from the clipboard (inherited from CADImage).
Public method | PasteEntitiesExt | Pastes entities from the clipboard (inherited from CADImage).
Public method | Print | Prints a current CAD image. (inherited from CADImage).
Public method | Redo | Redo change (inherited from CADImage).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RefreshCurrentLayout | Refresh current layout. (inherited from CADImage).
Public method | RefreshSnapTrace | Refreshes a region of the last drawn snap drawing element (inherited from CADImage).
Public method | RemoveEntity | (Overloaded) Removes CADEntity object. (inherited from CADImage).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from CADImage).
Public method | RotToView | Rotates a CAD image to get a specified view. (inherited from CADImage).
Public method | Rotate | Rotates objects in the current drawing. (inherited from CADImage).
Public method | SaveAsDXF | Saves a current CAD image in DXF format. (inherited from CADImage).
Public method | SaveImageToClipboard | (Overloaded) Writes a visible part of the current CAD image to the clipboard as a raster image. (inherited from CADImage).
Public method | SaveToFile | (Overloaded) Saves a part of the current CAD image to the file of the specified format. (inherited from CADImage).
Public method | SaveToStream | (Overloaded) Writes a visible part of the current CAD image to the specified stream as a raster image. (inherited from CADImage).
Public method | Select | Selects an entity of the CAD image at the specified point. (inherited from CADImage).
Public method | SelectExt | Selects an entity of the CAD image at the specified point. (inherited from CADImage).
Public method | SetCenter | Sets CADImage center point. (inherited from CADImage).
Public method | SetCurrentLayout | Sets a current layout of this CADImage. (inherited from CADImage).
Public method | SetLayerColor | (Overloaded) Sets a color for layer (CADLayer) specified by index (inherited from CADImage).
Public method | SetLayerFreeze | (Overloaded) Sets freeze parameter for CADLayer (inherited from CADImage).
Public method | SetLayerVisible | (Overloaded) Sets a visibility of the layer. (inherited from CADImage).
Public method | SetNewEntityMarkerPos | Sets a new position for the selected entity. The entity's new position is defined by the position of the marker. (inherited from CADImage).
Public method | SetNewMMToPixel | Sets a quantity of millimeters per pixel for the specified Graphics object. (inherited from CADImage).
Public method | SetNewPosEntitiesExt | Sets a new position for the specified entities (inherited from CADImage).
Public method | SetNewPosEntity | Sets a new position for the specified entity. (inherited from CADImage).
Public method | Stop | For internal use. (inherited from CADImage).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | Undo | Undo change (inherited from CADImage).
Top
See Also

Reference

DWGImage Class
CADImport.DWG Namespace


DWGImage.Dispose Method

Disposes a DWGImage object.

Namespace: CADImport.DWG
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DWGImage Class
DWGImage Members
CADImport.DWG Namespace


DWGImage.LoadFromStream Method

Loads a DWG image from the specified stream.

Namespace: CADImport.DWG
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub LoadFromStream( _
   ByVal str As Stream _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void LoadFromStream(
   Stream str
)
This language is not supported or no code example is available.

Parameters

str

Type: Stream

A Stream that contains the DWG image.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DWGImage Class
DWGImage Members
CADImport.DWG Namespace


DWGImage Fields

DWGImage Class See Also

The following tables list the members exposed by the DWGImage type.

Fields
 | Name | Description
 | EntityBuffer | Represents buffer for CADEntityCollection storing. (inherited from CADImage).
Public field | visibleArea | Represents CADImage visible area. (inherited from CADImage).
Top
See Also

Reference

DWGImage Class
CADImport.DWG Namespace


CADImport.DXF Namespace

Assembly: CADImport (in CADImport.dll)

Structures
 | Name | Description
Public structure | DXFReference | Represents a reference to an object.
Top
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


DXFReference Structure

Members See Also

Represents a reference to an object.

Namespace: CADImport.DXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Structure DXFReference
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public struct DXFReference
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFReference Members
CADImport.DXF Namespace


DXFReference Members

DXFReference Structure Constructors Fields See Also

Represents a reference to an object.

The following tables list the members exposed by the DXFReference type.

Constructors
 | Name | Description
Public constructor | DXFReference | Makes a reference to an object
Top
Fields
 | Name | Description
Public field | Entity | A reference to an entity
Public field | RefHandle | A reference to the object's handle
Top
See Also

Reference

DXFReference Structure
CADImport.DXF Namespace


DXFReference Constructor

Makes a reference to an object

Namespace: CADImport.DXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal ent As CADEntity, _
   ByVal handle As UInt64 _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFReference(
   CADEntity ent,
   UInt64 handle
)
This language is not supported or no code example is available.

Parameters

ent

Type: CADEntity

An entity

handle

Type: UInt64

A handle of an object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFReference Structure
DXFReference Members
CADImport.DXF Namespace


DXFReference Fields

DXFReference Structure See Also

The following tables list the members exposed by the DXFReference type.

Fields
 | Name | Description
Public field | Entity | A reference to an entity
Public field | RefHandle | A reference to the object's handle
Top
See Also

Reference

DXFReference Structure
CADImport.DXF Namespace


Entity Field

A reference to an entity

Namespace: CADImport.DXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Entity As CADEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntity Entity
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFReference Structure
DXFReference Members
CADImport.DXF Namespace


RefHandle Field

A reference to the object's handle

Namespace: CADImport.DXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public RefHandle As UInt64
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public UInt64 RefHandle
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFReference Structure
DXFReference Members
CADImport.DXF Namespace


CADImport.Export Namespace

Assembly: CADImport (in CADImport.dll)

Classes
 | Name | Description
Public class | CADExport | Provides functionality for exporting the current CAD file into other formats.
Public class | CADToCGM | Provides functionality for exporting the current CAD file into CGM format.
Public class | CADToHPGL | Provides functionality for exporting the current CAD file into HPGL format.
Public class | CADToPDF | Provides functionality for exporting the current CAD file into PDF format.
Public class | CADtoDWG |
Public class | CADtoGCode | ????? ??? ???????? G-Code
Public class | CGMExportSettings | Represents settings for exporting the current CAD file into CGM format.
Public class | ExportSettings | Represents settings for exporting the current CAD file into other formats.
Public class | ExportSimple<U> | Abstract class for inheritance.
 | GCodeFunctionID |
Public class | HPGLExportSettings | Represents settings for exporting the current CAD file into HPGL format.
Public class | PDFExportSettings | Represents settings for exporting the current CAD file into PDF format.
Top
Structures
 | Name | Description
Public structure | PDFMargins | Represents margins for a document page
Top
Enumerations
 | Name | Description
Public enumeration | GcodeMachineTypeID |
Public enumeration | LayoutsExportOption | Defines layouts that will be exported.
Public enumeration | PDFPrecision | Represents precision options for export.
Top
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


CADExport Class

Members See Also

Provides functionality for exporting the current CAD file into other formats.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public MustInherit Class CADExport
    Implements IDisposable
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public abstract class CADExport : IDisposable
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Export.CADExport
CADImport.Export.DirectCADtoDXF.CADtoDXF
CADImport.Export.ExportSimple<U>
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADExport Members
CADImport.Export Namespace


CADExport Members

CADExport Class Constructors Methods See Also

Provides functionality for exporting the current CAD file into other formats.

The following tables list the members exposed by the CADExport type.

Constructors
 | Name | Description
Public constructor | CADExport | Initializes a new instance of the CADExport class.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SaveToFile | (Overloaded) Exports the current CAD image to the specified file.
Public method | SaveToStream | Exports the current CAD file to the stream defined by the specified StreamWriter.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADExport Class
CADImport.Export Namespace


CADExport Constructor

Initializes a new instance of the CADExport class.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal img As CADImage _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADExport(
   CADImage img
)
This language is not supported or no code example is available.

Parameters

img

Type: CADImage

A CADImage to be exported to other formats.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADExport Class
CADExport Members
CADImport.Export Namespace


CADExport Methods

CADExport Class See Also

The following tables list the members exposed by the CADExport type.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SaveToFile | (Overloaded) Exports the current CAD image to the specified file.
Public method | SaveToStream | Exports the current CAD file to the stream defined by the specified StreamWriter.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADExport Class
CADImport.Export Namespace


CADExport.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Dispose() Implements  _
   IDisposable.Dispose
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Dispose()
This language is not supported or no code example is available.

Implements

IDisposable.Dispose
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADExport Class
CADExport Members
CADImport.Export Namespace


CADExport.SaveToFile Method

CADExport Class See Also

Exports the current CAD image to the specified file.

Overload List
Name | Description
SaveToFile(string) | Exports the current CAD image to the specified file.
SaveToFile(string, Encoding) | Exports the current CAD image to the specified file.
See Also

Reference

CADExport Class
CADExport Members
CADImport.Export Namespace


CADExport.SaveToStream Method

Exports the current CAD file to the stream defined by the specified StreamWriter.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub SaveToStream( _
   ByVal stream As Stream _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void SaveToStream(
   Stream stream
)
This language is not supported or no code example is available.

Parameters

stream

Type: Stream

A StreamWriter object that defines the stream where to the current CAD file will be exported.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADExport Class
CADExport Members
CADImport.Export Namespace


CADToCGM Class

Members See Also

Provides functionality for exporting the current CAD file into CGM format.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADToCGM
    Inherits ExportSimple(Of CGMExportSettings)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADToCGM : ExportSimple<CGMExportSettings>
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Export.CADExport
CADImport.Export.ExportSimple<U>
CADImport.Export.CADToCGM
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADToCGM Members
CADImport.Export Namespace


CADToCGM Members

CADToCGM Class Constructors Methods Properties See Also

Provides functionality for exporting the current CAD file into CGM format.

The following tables list the members exposed by the CADToCGM type.

Constructors
 | Name | Description
Public constructor | CADToCGM | Initializes a new instance of the CADToCGM class.
Top
Properties
 | Name | Description
Public property | Settings | Gets settings for exporting the current CAD drawing. (inherited from ExportSimple<U>).
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from CADExport).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SaveToFile | (Overloaded) Exports the current CAD image to the specified file. (inherited from CADExport).
Public method | SaveToStream | Exports the current CAD file to the stream defined by the specified StreamWriter. (inherited from ExportSimple<U>).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADToCGM Class
CADImport.Export Namespace


CADToCGM Constructor

Initializes a new instance of the CADToCGM class.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal image As CADImage _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADToCGM(
   CADImage image
)
This language is not supported or no code example is available.

Parameters

image

Type: CADImage

A CAD image to drawing.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADToCGM Class
CADToCGM Members
CADImport.Export Namespace


CADToCGM Properties

CADToCGM Class See Also

The following tables list the members exposed by the CADToCGM type.

Properties
 | Name | Description
Public property | Settings | Gets settings for exporting the current CAD drawing. (inherited from ExportSimple<U>).
Top
See Also

Reference

CADToCGM Class
CADImport.Export Namespace


ExportSimple<U>.Settings Property

Gets settings for exporting the current CAD drawing.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Settings() As U
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public U Settings {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExportSimple<U> Class
ExportSimple<U> Members
CADImport.Export Namespace


CADToCGM Methods

CADToCGM Class See Also

The following tables list the members exposed by the CADToCGM type.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from CADExport).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SaveToFile | (Overloaded) Exports the current CAD image to the specified file. (inherited from CADExport).
Public method | SaveToStream | Exports the current CAD file to the stream defined by the specified StreamWriter. (inherited from ExportSimple<U>).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADToCGM Class
CADImport.Export Namespace


ExportSimple<U>.SaveToStream Method

Exports the current CAD file to the stream defined by the specified StreamWriter.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub SaveToStream( _
   ByVal stream As Stream _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void SaveToStream(
   Stream stream
)
This language is not supported or no code example is available.

Parameters

stream

Type: Stream

A StreamWriter object that defines the stream where to the current CAD file will be exported.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExportSimple<U> Class
ExportSimple<U> Members
CADImport.Export Namespace


CADToHPGL Class

Members See Also

Provides functionality for exporting the current CAD file into HPGL format.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADToHPGL
    Inherits ExportSimple(Of HPGLExportSettings)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADToHPGL : ExportSimple<HPGLExportSettings>
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Export.CADExport
CADImport.Export.ExportSimple<U>
CADImport.Export.CADToHPGL
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADToHPGL Members
CADImport.Export Namespace


CADToHPGL Members

CADToHPGL Class Constructors Methods Properties See Also

Provides functionality for exporting the current CAD file into HPGL format.

The following tables list the members exposed by the CADToHPGL type.

Constructors
 | Name | Description
Public constructor | CADToHPGL | Initializes a new instance of the CADToHPGL class.
Top
Properties
 | Name | Description
Public property | Settings | Gets settings for exporting the current CAD drawing. (inherited from ExportSimple<U>).
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from CADExport).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SaveToFile | (Overloaded) Exports the current CAD image to the specified file. (inherited from CADExport).
Public method | SaveToStream | Exports the current CAD file to the stream defined by the specified StreamWriter. (inherited from ExportSimple<U>).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADToHPGL Class
CADImport.Export Namespace


CADToHPGL Constructor

Initializes a new instance of the CADToHPGL class.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal img As CADImage _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADToHPGL(
   CADImage img
)
This language is not supported or no code example is available.

Parameters

img

Type: CADImage

A CAD image to export

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADToHPGL Class
CADToHPGL Members
CADImport.Export Namespace


CADToHPGL Properties

CADToHPGL Class See Also

The following tables list the members exposed by the CADToHPGL type.

Properties
 | Name | Description
Public property | Settings | Gets settings for exporting the current CAD drawing. (inherited from ExportSimple<U>).
Top
See Also

Reference

CADToHPGL Class
CADImport.Export Namespace


CADToHPGL Methods

CADToHPGL Class See Also

The following tables list the members exposed by the CADToHPGL type.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from CADExport).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SaveToFile | (Overloaded) Exports the current CAD image to the specified file. (inherited from CADExport).
Public method | SaveToStream | Exports the current CAD file to the stream defined by the specified StreamWriter. (inherited from ExportSimple<U>).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADToHPGL Class
CADImport.Export Namespace


CADToPDF Class

Members See Also

Provides functionality for exporting the current CAD file into PDF format.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADToPDF
    Inherits ExportSimple(Of PDFExportSettings)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADToPDF : ExportSimple<PDFExportSettings>
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Export.CADExport
CADImport.Export.ExportSimple<U>
CADImport.Export.CADToPDF
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADToPDF Members
CADImport.Export Namespace


CADToPDF Members

CADToPDF Class Constructors Methods Properties See Also

Provides functionality for exporting the current CAD file into PDF format.

The following tables list the members exposed by the CADToPDF type.

Constructors
 | Name | Description
Public constructor | CADToPDF | Initializes a new instance of the CADToPDF class.
Top
Properties
 | Name | Description
Public property | Settings | Gets settings for exporting the current CAD drawing. (inherited from ExportSimple<U>).
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from CADExport).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SaveToFile | (Overloaded) Exports the current CAD image to the specified file. (inherited from CADExport).
Public method | SaveToStream | Exports the current CAD file to the stream defined by the specified StreamWriter. (inherited from ExportSimple<U>).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADToPDF Class
CADImport.Export Namespace


CADToPDF Constructor

Initializes a new instance of the CADToPDF class.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal img As CADImage _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADToPDF(
   CADImage img
)
This language is not supported or no code example is available.

Parameters

img

Type: CADImage

A CAD image to export

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADToPDF Class
CADToPDF Members
CADImport.Export Namespace


CADToPDF Properties

CADToPDF Class See Also

The following tables list the members exposed by the CADToPDF type.

Properties
 | Name | Description
Public property | Settings | Gets settings for exporting the current CAD drawing. (inherited from ExportSimple<U>).
Top
See Also

Reference

CADToPDF Class
CADImport.Export Namespace


CADToPDF Methods

CADToPDF Class See Also

The following tables list the members exposed by the CADToPDF type.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from CADExport).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SaveToFile | (Overloaded) Exports the current CAD image to the specified file. (inherited from CADExport).
Public method | SaveToStream | Exports the current CAD file to the stream defined by the specified StreamWriter. (inherited from ExportSimple<U>).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADToPDF Class
CADImport.Export Namespace


CADtoDWG Class

Members See Also

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADtoDWG
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADtoDWG
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Export.CADtoDWG
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADtoDWG Members
CADImport.Export Namespace


CADtoDWG Members

CADtoDWG Class Methods See Also

The following tables list the members exposed by the CADtoDWG type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
 | SaveAsDWG |
 | SaveToStream |
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADtoDWG Class
CADImport.Export Namespace


CADtoDWG Methods

CADtoDWG Class See Also

The following tables list the members exposed by the CADtoDWG type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
 | SaveAsDWG |
 | SaveToStream |
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADtoDWG Class
CADImport.Export Namespace


CADtoDWG.SaveAsDWG Method

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function SaveAsDWG( _
   ByVal image As CADImage, _
   ByVal fileName As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool SaveAsDWG(
   CADImage image,
   string fileName
)
This language is not supported or no code example is available.

Parameters

image

Type: CADImage

fileName

Type: string

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADtoDWG Class
CADtoDWG Members
CADImport.Export Namespace


CADtoDWG.SaveToStream Method

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub SaveToStream( _
   ByVal image As CADImage, _
   ByVal s As Stream _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void SaveToStream(
   CADImage image,
   Stream s
)
This language is not supported or no code example is available.

Parameters

image

Type: CADImage

s

Type: Stream

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADtoDWG Class
CADtoDWG Members
CADImport.Export Namespace


CADtoGCode Class

Members See Also

????? ??? ???????? G-Code

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADtoGCode
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADtoGCode
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Export.CADtoGCode
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADtoGCode Members
CADImport.Export Namespace


CADtoGCode Members

CADtoGCode Class Constructors Methods Properties See Also

????? ??? ???????? G-Code

The following tables list the members exposed by the CADtoGCode type.

Constructors
 | Name | Description
Public constructor | CADtoGCode | ??????? ????????? ?????? CADtoGCode
Top
Properties
 | Name | Description
Public property | Code | ??? G-Code ??????????? ??????? ????? ???? ????? ??????? CreateCode
Public property | DecimalSeparator | ?????? ??????-??????????? ????? ? ??????? ????? ?????????
Public property | Delay | ?????? ???????? ????? ??????? ????????? (0 - ???? ?? ?????)
Public property | DepartureOnZ | ?????? ??????? ??????????? ??? ????????? ???? (?????? ??? ?????? MillMachine)
Public property | DepthOnZ | ??????? ????????? ??????????? (?????? ??? ?????? MillMachine)
Public property | EndCommand | ?????? ???????? ???????
Public property | FeedOnXY | ???????? ??????????? ???????????
Public property | FeedOnZ | ???????? ???????/????????? ??????????? (?????? ??? ?????? MillMachine)
Public property | Image | ??????????? ?? ???????? ????? ??????????? G-Code
Public property | MachineType | ?????? ??? ?????? (?? ????????? Mill)
Public property | Precision | ???????? ????????? ?????????? ? ?????????? ?????? ????? ??????? (?? 0 ?? 15)
Public property | SpindleSpeed | ?????? ???????? ???????? ???????? (?????? ??? ?????? MillMachine)
Public property | StartCommand | ?????? ????????? ???????
Public property | ToolOffCommand | ?????? ??????? ??? ?????????? ??????????? (?????? ??? CutMachine)
Public property | ToolOnCommand | ?????? ??????? ??? ????????? ??????????? (?????? ??? CutMachine)
Public property | UseIJNotationForArcs | ?????? ??????? ???????? ???????????? ????? IJ ??? R
Top
Methods
 | Name | Description
Public method | CreateCode | ??????? G-Code
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADtoGCode Class
CADImport.Export Namespace


CADtoGCode Constructor

??????? ????????? ?????? CADtoGCode

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal Image As CADImage _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADtoGCode(
   CADImage Image
)
This language is not supported or no code example is available.

Parameters

Image

Type: CADImage

B?????????? ?? ???????? c???????? G-Code

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADtoGCode Class
CADtoGCode Members
CADImport.Export Namespace


CADtoGCode Properties

CADtoGCode Class See Also

The following tables list the members exposed by the CADtoGCode type.

Properties
 | Name | Description
Public property | Code | ??? G-Code ??????????? ??????? ????? ???? ????? ??????? CreateCode
Public property | DecimalSeparator | ?????? ??????-??????????? ????? ? ??????? ????? ?????????
Public property | Delay | ?????? ???????? ????? ??????? ????????? (0 - ???? ?? ?????)
Public property | DepartureOnZ | ?????? ??????? ??????????? ??? ????????? ???? (?????? ??? ?????? MillMachine)
Public property | DepthOnZ | ??????? ????????? ??????????? (?????? ??? ?????? MillMachine)
Public property | EndCommand | ?????? ???????? ???????
Public property | FeedOnXY | ???????? ??????????? ???????????
Public property | FeedOnZ | ???????? ???????/????????? ??????????? (?????? ??? ?????? MillMachine)
Public property | Image | ??????????? ?? ???????? ????? ??????????? G-Code
Public property | MachineType | ?????? ??? ?????? (?? ????????? Mill)
Public property | Precision | ???????? ????????? ?????????? ? ?????????? ?????? ????? ??????? (?? 0 ?? 15)
Public property | SpindleSpeed | ?????? ???????? ???????? ???????? (?????? ??? ?????? MillMachine)
Public property | StartCommand | ?????? ????????? ???????
Public property | ToolOffCommand | ?????? ??????? ??? ?????????? ??????????? (?????? ??? CutMachine)
Public property | ToolOnCommand | ?????? ??????? ??? ????????? ??????????? (?????? ??? CutMachine)
Public property | UseIJNotationForArcs | ?????? ??????? ???????? ???????????? ????? IJ ??? R
Top
See Also

Reference

CADtoGCode Class
CADImport.Export Namespace


CADtoGCode.Code Property

??? G-Code ??????????? ??????? ????? ???? ????? ??????? CreateCode

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Code() As StringBuilder
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public StringBuilder Code {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADtoGCode Class
CADtoGCode Members
CADImport.Export Namespace


CADtoGCode.DecimalSeparator Property

?????? ??????-??????????? ????? ? ??????? ????? ?????????

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DecimalSeparator() As Char
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public char DecimalSeparator {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADtoGCode Class
CADtoGCode Members
CADImport.Export Namespace


CADtoGCode.Delay Property

?????? ???????? ????? ??????? ????????? (0 - ???? ?? ?????)

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Delay() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Delay {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADtoGCode Class
CADtoGCode Members
CADImport.Export Namespace


CADtoGCode.DepartureOnZ Property

?????? ??????? ??????????? ??? ????????? ???? (?????? ??? ?????? MillMachine)

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DepartureOnZ() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double DepartureOnZ {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADtoGCode Class
CADtoGCode Members
CADImport.Export Namespace


CADtoGCode.DepthOnZ Property

??????? ????????? ??????????? (?????? ??? ?????? MillMachine)

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DepthOnZ() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double DepthOnZ {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADtoGCode Class
CADtoGCode Members
CADImport.Export Namespace


CADtoGCode.EndCommand Property

?????? ???????? ???????

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property EndCommand() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string EndCommand {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADtoGCode Class
CADtoGCode Members
CADImport.Export Namespace


CADtoGCode.FeedOnXY Property

???????? ??????????? ???????????

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property FeedOnXY() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int FeedOnXY {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADtoGCode Class
CADtoGCode Members
CADImport.Export Namespace


CADtoGCode.FeedOnZ Property

???????? ???????/????????? ??????????? (?????? ??? ?????? MillMachine)

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property FeedOnZ() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int FeedOnZ {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADtoGCode Class
CADtoGCode Members
CADImport.Export Namespace


CADtoGCode.Image Property

??????????? ?? ???????? ????? ??????????? G-Code

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Image() As CADImage
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADImage Image {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADtoGCode Class
CADtoGCode Members
CADImport.Export Namespace


CADtoGCode.MachineType Property

?????? ??? ?????? (?? ????????? Mill)

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property MachineType() As GcodeMachineTypeID
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public GcodeMachineTypeID MachineType {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADtoGCode Class
CADtoGCode Members
CADImport.Export Namespace


CADtoGCode.Precision Property

???????? ????????? ?????????? ? ?????????? ?????? ????? ??????? (?? 0 ?? 15)

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Precision() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Precision {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADtoGCode Class
CADtoGCode Members
CADImport.Export Namespace


CADtoGCode.SpindleSpeed Property

?????? ???????? ???????? ???????? (?????? ??? ?????? MillMachine)

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property SpindleSpeed() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int SpindleSpeed {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADtoGCode Class
CADtoGCode Members
CADImport.Export Namespace


CADtoGCode.StartCommand Property

?????? ????????? ???????

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property StartCommand() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string StartCommand {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADtoGCode Class
CADtoGCode Members
CADImport.Export Namespace


CADtoGCode.ToolOffCommand Property

?????? ??????? ??? ?????????? ??????????? (?????? ??? CutMachine)

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ToolOffCommand() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string ToolOffCommand {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADtoGCode Class
CADtoGCode Members
CADImport.Export Namespace


CADtoGCode.ToolOnCommand Property

?????? ??????? ??? ????????? ??????????? (?????? ??? CutMachine)

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ToolOnCommand() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string ToolOnCommand {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADtoGCode Class
CADtoGCode Members
CADImport.Export Namespace


CADtoGCode.UseIJNotationForArcs Property

?????? ??????? ???????? ???????????? ????? IJ ??? R

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property UseIJNotationForArcs() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool UseIJNotationForArcs {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADtoGCode Class
CADtoGCode Members
CADImport.Export Namespace


CADtoGCode Methods

CADtoGCode Class See Also

The following tables list the members exposed by the CADtoGCode type.

Methods
 | Name | Description
Public method | CreateCode | ??????? G-Code
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADtoGCode Class
CADImport.Export Namespace


CADtoGCode.CreateCode Method

??????? G-Code

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub CreateCode()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void CreateCode()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADtoGCode Class
CADtoGCode Members
CADImport.Export Namespace


CGMExportSettings Class

Members See Also

Represents settings for exporting the current CAD file into CGM format.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CGMExportSettings
    Inherits ExportSettings
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CGMExportSettings : ExportSettings
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADPresenterSettings
CADImport.Export.ExportSettings
CADImport.Export.CGMExportSettings
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CGMExportSettings Members
CADImport.Export Namespace


CGMExportSettings Members

CGMExportSettings Class Constructors Methods Properties See Also

Represents settings for exporting the current CAD file into CGM format.

The following tables list the members exposed by the CGMExportSettings type.

Constructors
 | Name | Description
Public constructor | CGMExportSettings | Initializes a new instance of the CGMExportSettings class.
Top
Properties
 | Name | Description
Public property | BackgroundColor | Gets or sets a background color of this CADImage. (inherited from CADPresenterSettings).
Public property | BorderSize | Gets or sets a border size in pixels. (inherited from CADPresenterSettings).
Public property | BorderType | Gets or sets a border type. (inherited from CADPresenterSettings).
Public property | ClearStreamByDisposeOnly | Created stream will be closed when disposing export class (inherited from ExportSettings).
Public property | CurvePrecision | Gets or sets a value specifying precision of curves in drawing units.
Public property | DefaultAngle | Gets or sets a default color for the CADImage. (inherited from CADPresenterSettings).
Public property | DefaultColor | Gets or sets a default color for the CADImage. (inherited from CADPresenterSettings).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions on the drawing are visible. (inherited from CADPresenterSettings).
Public property | DrawMode | Gets or sets a current drawing mode. (inherited from CADPresenterSettings).
Public property | ImageRectangle | Represents a rectangle that encloses CADImage object. (inherited from ExportSettings).
Public property | IsDraw3DAxes | Gets or sets a value indicating whether 3D axes are shown on the drawing. (inherited from CADPresenterSettings).
Public property | IsShowBackground | Gets or sets a value indicating using of a BackgroundColor. (inherited from CADPresenterSettings).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data. (inherited from CADPresenterSettings).
Public property | LayoutsExportMode | Gets or sets a value specifying which layouts will be exported. (inherited from ExportSettings).
Public property | LineScaled | Obsolete. Gets or sets a value indicating whether a width of lines to draw all entities in the drawing is specified by the file data. (inherited from CADPresenterSettings).
Public property | LineWeightScale | Gets or sets a scale for drawing lines. (inherited from CADPresenterSettings).
Public property | NullWidth | Gets or sets default thickness for lines used to draw a CADImage. (inherited from CADPresenterSettings).
Public property | TTFSmoothing | Gets or sets a value indicating whether TTF fonts are smoothed. (inherited from CADPresenterSettings).
Public property | TTFSmoothingStyle | Gets or sets smoothing style for TTF fonts. (inherited from CADPresenterSettings).
Public property | TextVisible | Gets or sets a value indicating whether the texts in the CADImage are visible. (inherited from CADPresenterSettings).
Public property | XScale | Gets or sets a scale value for export. (inherited from ExportSettings).
Public property | XSize | For internal use. (inherited from ExportSettings).
Top
Methods
 | Name | Description
Public method | Assign | Copies the settings from a specified CADPresenterSettings object.
Public method | Clone | Creates a new object that is a copy of the current CADPresenterSettings class instance. (inherited from CADPresenterSettings).
Public method | Dispose | (inherited from CADPresenterSettings).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetExportRect | Returns a rectangular area for export.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RestoreParams | Restores the settings of the CADPresenterSettings. (inherited from CADPresenterSettings).
Public method | SaveParams | Saves the settings of the CADPresenterSettings. (inherited from CADPresenterSettings).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CGMExportSettings Class
CADImport.Export Namespace


CGMExportSettings Constructor

Initializes a new instance of the CGMExportSettings class.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CGMExportSettings()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CGMExportSettings Class
CGMExportSettings Members
CADImport.Export Namespace


CGMExportSettings Properties

CGMExportSettings Class See Also

The following tables list the members exposed by the CGMExportSettings type.

Properties
 | Name | Description
Public property | BackgroundColor | Gets or sets a background color of this CADImage. (inherited from CADPresenterSettings).
Public property | BorderSize | Gets or sets a border size in pixels. (inherited from CADPresenterSettings).
Public property | BorderType | Gets or sets a border type. (inherited from CADPresenterSettings).
Public property | ClearStreamByDisposeOnly | Created stream will be closed when disposing export class (inherited from ExportSettings).
Public property | CurvePrecision | Gets or sets a value specifying precision of curves in drawing units.
Public property | DefaultAngle | Gets or sets a default color for the CADImage. (inherited from CADPresenterSettings).
Public property | DefaultColor | Gets or sets a default color for the CADImage. (inherited from CADPresenterSettings).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions on the drawing are visible. (inherited from CADPresenterSettings).
Public property | DrawMode | Gets or sets a current drawing mode. (inherited from CADPresenterSettings).
Public property | ImageRectangle | Represents a rectangle that encloses CADImage object. (inherited from ExportSettings).
Public property | IsDraw3DAxes | Gets or sets a value indicating whether 3D axes are shown on the drawing. (inherited from CADPresenterSettings).
Public property | IsShowBackground | Gets or sets a value indicating using of a BackgroundColor. (inherited from CADPresenterSettings).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data. (inherited from CADPresenterSettings).
Public property | LayoutsExportMode | Gets or sets a value specifying which layouts will be exported. (inherited from ExportSettings).
Public property | LineScaled | Obsolete. Gets or sets a value indicating whether a width of lines to draw all entities in the drawing is specified by the file data. (inherited from CADPresenterSettings).
Public property | LineWeightScale | Gets or sets a scale for drawing lines. (inherited from CADPresenterSettings).
Public property | NullWidth | Gets or sets default thickness for lines used to draw a CADImage. (inherited from CADPresenterSettings).
Public property | TTFSmoothing | Gets or sets a value indicating whether TTF fonts are smoothed. (inherited from CADPresenterSettings).
Public property | TTFSmoothingStyle | Gets or sets smoothing style for TTF fonts. (inherited from CADPresenterSettings).
Public property | TextVisible | Gets or sets a value indicating whether the texts in the CADImage are visible. (inherited from CADPresenterSettings).
Public property | XScale | Gets or sets a scale value for export. (inherited from ExportSettings).
Public property | XSize | For internal use. (inherited from ExportSettings).
Top
See Also

Reference

CGMExportSettings Class
CADImport.Export Namespace


ExportSettings.ClearStreamByDisposeOnly Property

Created stream will be closed when disposing export class

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ClearStreamByDisposeOnly() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool ClearStreamByDisposeOnly {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExportSettings Class
ExportSettings Members
CADImport.Export Namespace


CGMExportSettings.CurvePrecision Property

Gets or sets a value specifying precision of curves in drawing units.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property CurvePrecision() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double CurvePrecision {get; set;}
This language is not supported or no code example is available.
Remarks

Default value is 0, CGM with integer precision created on export. Specifying a positive value will result in CGM export with real precision.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CGMExportSettings Class
CGMExportSettings Members
CADImport.Export Namespace


ExportSettings.ImageRectangle Property

Represents a rectangle that encloses CADImage object.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Property ImageRectangle() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual DRect ImageRectangle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExportSettings Class
ExportSettings Members
CADImport.Export Namespace


ExportSettings.LayoutsExportMode Property

Gets or sets a value specifying which layouts will be exported.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LayoutsExportMode() As LayoutsExportOption
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public LayoutsExportOption LayoutsExportMode {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExportSettings Class
ExportSettings Members
CADImport.Export Namespace


ExportSettings.XScale Property

Gets or sets a scale value for export.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property XScale() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double XScale {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExportSettings Class
ExportSettings Members
CADImport.Export Namespace


ExportSettings.XSize Property

For internal use.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property XSize() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int XSize {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExportSettings Class
ExportSettings Members
CADImport.Export Namespace


CGMExportSettings Methods

CGMExportSettings Class See Also

The following tables list the members exposed by the CGMExportSettings type.

Methods
 | Name | Description
Public method | Assign | Copies the settings from a specified CADPresenterSettings object.
Public method | Clone | Creates a new object that is a copy of the current CADPresenterSettings class instance. (inherited from CADPresenterSettings).
Public method | Dispose | (inherited from CADPresenterSettings).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetExportRect | Returns a rectangular area for export.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RestoreParams | Restores the settings of the CADPresenterSettings. (inherited from CADPresenterSettings).
Public method | SaveParams | Saves the settings of the CADPresenterSettings. (inherited from CADPresenterSettings).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CGMExportSettings Class
CADImport.Export Namespace


CGMExportSettings.Assign Method

Copies the settings from a specified CADPresenterSettings object.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Assign( _
   ByVal entity As CADPresenterSettings _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Assign(
   CADPresenterSettings entity
)
This language is not supported or no code example is available.

Parameters

entity

Type: CADPresenterSettings

CADPresenterSettings object to copy settings from.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CGMExportSettings Class
CGMExportSettings Members
CADImport.Export Namespace


CGMExportSettings.GetExportRect Method

Returns a rectangular area for export.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function GetExportRect() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override DRect GetExportRect()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CGMExportSettings Class
CGMExportSettings Members
CADImport.Export Namespace


ExportSettings Class

Members See Also

Represents settings for exporting the current CAD file into other formats.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class ExportSettings
    Inherits CADPresenterSettings
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class ExportSettings : CADPresenterSettings
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADPresenterSettings
CADImport.Export.ExportSettings
CADImport.Export.CGMExportSettings
CADImport.Export.HPGLExportSettings
CADImport.Export.PDFExportSettings
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExportSettings Members
CADImport.Export Namespace


ExportSettings Members

ExportSettings Class Constructors Methods Properties See Also

Represents settings for exporting the current CAD file into other formats.

The following tables list the members exposed by the ExportSettings type.

Constructors
 | Name | Description
Public constructor | ExportSettings | Initializes a new instance of the ExportSettings class.
Top
Properties
 | Name | Description
Public property | BackgroundColor | Gets or sets a background color of this CADImage. (inherited from CADPresenterSettings).
Public property | BorderSize | Gets or sets a border size in pixels. (inherited from CADPresenterSettings).
Public property | BorderType | Gets or sets a border type. (inherited from CADPresenterSettings).
Public property | ClearStreamByDisposeOnly | Created stream will be closed when disposing export class
Public property | DefaultAngle | Gets or sets a default color for the CADImage. (inherited from CADPresenterSettings).
Public property | DefaultColor | Gets or sets a default color for the CADImage. (inherited from CADPresenterSettings).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions on the drawing are visible. (inherited from CADPresenterSettings).
Public property | DrawMode | Gets or sets a current drawing mode. (inherited from CADPresenterSettings).
Public property | ImageRectangle | Represents a rectangle that encloses CADImage object.
Public property | IsDraw3DAxes | Gets or sets a value indicating whether 3D axes are shown on the drawing. (inherited from CADPresenterSettings).
Public property | IsShowBackground | Gets or sets a value indicating using of a BackgroundColor. (inherited from CADPresenterSettings).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data. (inherited from CADPresenterSettings).
Public property | LayoutsExportMode | Gets or sets a value specifying which layouts will be exported.
Public property | LineScaled | Obsolete. Gets or sets a value indicating whether a width of lines to draw all entities in the drawing is specified by the file data. (inherited from CADPresenterSettings).
Public property | LineWeightScale | Gets or sets a scale for drawing lines. (inherited from CADPresenterSettings).
Public property | NullWidth | Gets or sets default thickness for lines used to draw a CADImage. (inherited from CADPresenterSettings).
Public property | TTFSmoothing | Gets or sets a value indicating whether TTF fonts are smoothed. (inherited from CADPresenterSettings).
Public property | TTFSmoothingStyle | Gets or sets smoothing style for TTF fonts. (inherited from CADPresenterSettings).
Public property | TextVisible | Gets or sets a value indicating whether the texts in the CADImage are visible. (inherited from CADPresenterSettings).
Public property | XScale | Gets or sets a scale value for export.
Public property | XSize | For internal use.
Top
Methods
 | Name | Description
Public method | Assign | Copies the settings from a specified CADPresenterSettings object.
Public method | Clone | Creates a new object that is a copy of the current CADPresenterSettings class instance. (inherited from CADPresenterSettings).
Public method | Dispose | (inherited from CADPresenterSettings).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetExportRect | Returns a rectangular area for export.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RestoreParams | Restores the settings of the CADPresenterSettings. (inherited from CADPresenterSettings).
Public method | SaveParams | Saves the settings of the CADPresenterSettings. (inherited from CADPresenterSettings).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

ExportSettings Class
CADImport.Export Namespace


ExportSettings Constructor

Initializes a new instance of the ExportSettings class.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ExportSettings()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExportSettings Class
ExportSettings Members
CADImport.Export Namespace


ExportSettings Properties

ExportSettings Class See Also

The following tables list the members exposed by the ExportSettings type.

Properties
 | Name | Description
Public property | BackgroundColor | Gets or sets a background color of this CADImage. (inherited from CADPresenterSettings).
Public property | BorderSize | Gets or sets a border size in pixels. (inherited from CADPresenterSettings).
Public property | BorderType | Gets or sets a border type. (inherited from CADPresenterSettings).
Public property | ClearStreamByDisposeOnly | Created stream will be closed when disposing export class
Public property | DefaultAngle | Gets or sets a default color for the CADImage. (inherited from CADPresenterSettings).
Public property | DefaultColor | Gets or sets a default color for the CADImage. (inherited from CADPresenterSettings).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions on the drawing are visible. (inherited from CADPresenterSettings).
Public property | DrawMode | Gets or sets a current drawing mode. (inherited from CADPresenterSettings).
Public property | ImageRectangle | Represents a rectangle that encloses CADImage object.
Public property | IsDraw3DAxes | Gets or sets a value indicating whether 3D axes are shown on the drawing. (inherited from CADPresenterSettings).
Public property | IsShowBackground | Gets or sets a value indicating using of a BackgroundColor. (inherited from CADPresenterSettings).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data. (inherited from CADPresenterSettings).
Public property | LayoutsExportMode | Gets or sets a value specifying which layouts will be exported.
Public property | LineScaled | Obsolete. Gets or sets a value indicating whether a width of lines to draw all entities in the drawing is specified by the file data. (inherited from CADPresenterSettings).
Public property | LineWeightScale | Gets or sets a scale for drawing lines. (inherited from CADPresenterSettings).
Public property | NullWidth | Gets or sets default thickness for lines used to draw a CADImage. (inherited from CADPresenterSettings).
Public property | TTFSmoothing | Gets or sets a value indicating whether TTF fonts are smoothed. (inherited from CADPresenterSettings).
Public property | TTFSmoothingStyle | Gets or sets smoothing style for TTF fonts. (inherited from CADPresenterSettings).
Public property | TextVisible | Gets or sets a value indicating whether the texts in the CADImage are visible. (inherited from CADPresenterSettings).
Public property | XScale | Gets or sets a scale value for export.
Public property | XSize | For internal use.
Top
See Also

Reference

ExportSettings Class
CADImport.Export Namespace


ExportSettings Methods

ExportSettings Class See Also

The following tables list the members exposed by the ExportSettings type.

Methods
 | Name | Description
Public method | Assign | Copies the settings from a specified CADPresenterSettings object.
Public method | Clone | Creates a new object that is a copy of the current CADPresenterSettings class instance. (inherited from CADPresenterSettings).
Public method | Dispose | (inherited from CADPresenterSettings).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetExportRect | Returns a rectangular area for export.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RestoreParams | Restores the settings of the CADPresenterSettings. (inherited from CADPresenterSettings).
Public method | SaveParams | Saves the settings of the CADPresenterSettings. (inherited from CADPresenterSettings).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

ExportSettings Class
CADImport.Export Namespace


ExportSettings.Assign Method

Copies the settings from a specified CADPresenterSettings object.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Assign( _
   ByVal entity As CADPresenterSettings _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Assign(
   CADPresenterSettings entity
)
This language is not supported or no code example is available.

Parameters

entity

Type: CADPresenterSettings

CADPresenterSettings object to copy settings from.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExportSettings Class
ExportSettings Members
CADImport.Export Namespace


ExportSettings.GetExportRect Method

Returns a rectangular area for export.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Function GetExportRect() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual DRect GetExportRect()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExportSettings Class
ExportSettings Members
CADImport.Export Namespace


ExportSimple<U> Class

Members See Also

Abstract class for inheritance.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public MustInherit Class ExportSimple(Of  _
   U As ExportSettings)
    Inherits CADExport
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public abstract class ExportSimple<U> : CADExport
   where U : ExportSettings
This language is not supported or no code example is available.

Type Parameters

U

Inheritance Hierarchy
System.Object
CADImport.Export.CADExport
CADImport.Export.ExportSimple<U>
CADImport.Export.CADToCGM
CADImport.Export.CADToHPGL
CADImport.Export.CADToPDF
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExportSimple<U> Members
CADImport.Export Namespace


ExportSimple<U> Members

ExportSimple<U> Class Constructors Methods Properties See Also

Abstract class for inheritance.

The following tables list the members exposed by the ExportSimple<U> type.

Constructors
 | Name | Description
Public constructor | ExportSimple<U> | Initializes a new instance of the CADExport class. (inherited from CADExport).
Top
Properties
 | Name | Description
Public property | Settings | Gets settings for exporting the current CAD drawing.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from CADExport).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SaveToFile | (Overloaded) Exports the current CAD image to the specified file. (inherited from CADExport).
Public method | SaveToStream | Exports the current CAD file to the stream defined by the specified StreamWriter.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

ExportSimple<U> Class
CADImport.Export Namespace


ExportSimple<U> Properties

ExportSimple<U> Class See Also

The following tables list the members exposed by the ExportSimple<U> type.

Properties
 | Name | Description
Public property | Settings | Gets settings for exporting the current CAD drawing.
Top
See Also

Reference

ExportSimple<U> Class
CADImport.Export Namespace


ExportSimple<U> Methods

ExportSimple<U> Class See Also

The following tables list the members exposed by the ExportSimple<U> type.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from CADExport).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SaveToFile | (Overloaded) Exports the current CAD image to the specified file. (inherited from CADExport).
Public method | SaveToStream | Exports the current CAD file to the stream defined by the specified StreamWriter.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

ExportSimple<U> Class
CADImport.Export Namespace


GCodeFunctionID Class

Members See Also

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class GCodeFunctionID
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static class GCodeFunctionID
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Export.GCodeFunctionID
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GCodeFunctionID Members
CADImport.Export Namespace


GCodeFunctionID Members

GCodeFunctionID Class Methods Fields See Also

The following tables list the members exposed by the GCodeFunctionID type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
Name | Description
G0 |
G1 |
G17 |
G2 |
G21 |
G3 |
G4 |
G90 |
Top
See Also

Reference

GCodeFunctionID Class
CADImport.Export Namespace


GCodeFunctionID Methods

GCodeFunctionID Class See Also

The following tables list the members exposed by the GCodeFunctionID type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

GCodeFunctionID Class
CADImport.Export Namespace


GCodeFunctionID Fields

GCodeFunctionID Class See Also

The following tables list the members exposed by the GCodeFunctionID type.

Fields
Name | Description
G0 |
G1 |
G17 |
G2 |
G21 |
G3 |
G4 |
G90 |
Top
See Also

Reference

GCodeFunctionID Class
CADImport.Export Namespace


G0 Field

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Const G0 As String = "G0 "
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public const string G0 = @"G0 "
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GCodeFunctionID Class
GCodeFunctionID Members
CADImport.Export Namespace


G1 Field

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Const G1 As String = "G1 "
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public const string G1 = @"G1 "
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GCodeFunctionID Class
GCodeFunctionID Members
CADImport.Export Namespace


G17 Field

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Const G17 As String = "G17 "
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public const string G17 = @"G17 "
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GCodeFunctionID Class
GCodeFunctionID Members
CADImport.Export Namespace


G2 Field

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Const G2 As String = "G2 "
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public const string G2 = @"G2 "
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GCodeFunctionID Class
GCodeFunctionID Members
CADImport.Export Namespace


G21 Field

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Const G21 As String = "G21 "
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public const string G21 = @"G21 "
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GCodeFunctionID Class
GCodeFunctionID Members
CADImport.Export Namespace


G3 Field

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Const G3 As String = "G3 "
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public const string G3 = @"G3 "
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GCodeFunctionID Class
GCodeFunctionID Members
CADImport.Export Namespace


G4 Field

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Const G4 As String = "G4 "
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public const string G4 = @"G4 "
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GCodeFunctionID Class
GCodeFunctionID Members
CADImport.Export Namespace


G90 Field

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Const G90 As String = "G90 "
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public const string G90 = @"G90 "
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GCodeFunctionID Class
GCodeFunctionID Members
CADImport.Export Namespace


HPGLExportSettings Class

Members See Also

Represents settings for exporting the current CAD file into HPGL format.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class HPGLExportSettings
    Inherits ExportSettings
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class HPGLExportSettings : ExportSettings
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADPresenterSettings
CADImport.Export.ExportSettings
CADImport.Export.HPGLExportSettings
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HPGLExportSettings Members
CADImport.Export Namespace


HPGLExportSettings Members

HPGLExportSettings Class Constructors Methods Properties See Also

Represents settings for exporting the current CAD file into HPGL format.

The following tables list the members exposed by the HPGLExportSettings type.

Constructors
 | Name | Description
Public constructor | HPGLExportSettings | Initializes a new instance of the ExportSettings class. (inherited from ExportSettings).
Top
Properties
 | Name | Description
Public property | BackgroundColor | Gets or sets a background color of this CADImage. (inherited from CADPresenterSettings).
Public property | BorderSize | Gets or sets a border size in pixels. (inherited from CADPresenterSettings).
Public property | BorderType | Gets or sets a border type. (inherited from CADPresenterSettings).
Public property | ClearStreamByDisposeOnly | Created stream will be closed when disposing export class (inherited from ExportSettings).
Public property | DefaultAngle | Gets or sets a default color for the CADImage. (inherited from CADPresenterSettings).
Public property | DefaultColor | Gets or sets a default color for the CADImage. (inherited from CADPresenterSettings).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions on the drawing are visible. (inherited from CADPresenterSettings).
Public property | DrawMode | Gets or sets a current drawing mode. (inherited from CADPresenterSettings).
Public property | ImageRectangle | Represents a rectangle that encloses CADImage object. (inherited from ExportSettings).
Public property | IsDraw3DAxes | Gets or sets a value indicating whether 3D axes are shown on the drawing. (inherited from CADPresenterSettings).
Public property | IsShowBackground | Gets or sets a value indicating using of a BackgroundColor. (inherited from CADPresenterSettings).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data. (inherited from CADPresenterSettings).
Public property | LayoutsExportMode | Gets or sets a value specifying which layouts will be exported. (inherited from ExportSettings).
Public property | LineScaled | Obsolete. Gets or sets a value indicating whether a width of lines to draw all entities in the drawing is specified by the file data. (inherited from CADPresenterSettings).
Public property | LineWeightScale | Gets or sets a scale for drawing lines. (inherited from CADPresenterSettings).
Public property | NullWidth | Gets or sets default thickness for lines used to draw a CADImage. (inherited from CADPresenterSettings).
Public property | TTFSmoothing | Gets or sets a value indicating whether TTF fonts are smoothed. (inherited from CADPresenterSettings).
Public property | TTFSmoothingStyle | Gets or sets smoothing style for TTF fonts. (inherited from CADPresenterSettings).
Public property | TextVisible | Gets or sets a value indicating whether the texts in the CADImage are visible. (inherited from CADPresenterSettings).
Public property | XScale | Gets or sets a scale value for export. (inherited from ExportSettings).
Public property | XSize | For internal use. (inherited from ExportSettings).
Top
Methods
 | Name | Description
Public method | Assign | Copies the settings from a specified CADPresenterSettings object. (inherited from ExportSettings).
Public method | Clone | Creates a new object that is a copy of the current CADPresenterSettings class instance. (inherited from CADPresenterSettings).
Public method | Dispose | (inherited from CADPresenterSettings).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetExportRect | Returns a rectangular area for export. (inherited from ExportSettings).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RestoreParams | Restores the settings of the CADPresenterSettings. (inherited from CADPresenterSettings).
Public method | SaveParams | Saves the settings of the CADPresenterSettings. (inherited from CADPresenterSettings).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

HPGLExportSettings Class
CADImport.Export Namespace


HPGLExportSettings Properties

HPGLExportSettings Class See Also

The following tables list the members exposed by the HPGLExportSettings type.

Properties
 | Name | Description
Public property | BackgroundColor | Gets or sets a background color of this CADImage. (inherited from CADPresenterSettings).
Public property | BorderSize | Gets or sets a border size in pixels. (inherited from CADPresenterSettings).
Public property | BorderType | Gets or sets a border type. (inherited from CADPresenterSettings).
Public property | ClearStreamByDisposeOnly | Created stream will be closed when disposing export class (inherited from ExportSettings).
Public property | DefaultAngle | Gets or sets a default color for the CADImage. (inherited from CADPresenterSettings).
Public property | DefaultColor | Gets or sets a default color for the CADImage. (inherited from CADPresenterSettings).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions on the drawing are visible. (inherited from CADPresenterSettings).
Public property | DrawMode | Gets or sets a current drawing mode. (inherited from CADPresenterSettings).
Public property | ImageRectangle | Represents a rectangle that encloses CADImage object. (inherited from ExportSettings).
Public property | IsDraw3DAxes | Gets or sets a value indicating whether 3D axes are shown on the drawing. (inherited from CADPresenterSettings).
Public property | IsShowBackground | Gets or sets a value indicating using of a BackgroundColor. (inherited from CADPresenterSettings).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data. (inherited from CADPresenterSettings).
Public property | LayoutsExportMode | Gets or sets a value specifying which layouts will be exported. (inherited from ExportSettings).
Public property | LineScaled | Obsolete. Gets or sets a value indicating whether a width of lines to draw all entities in the drawing is specified by the file data. (inherited from CADPresenterSettings).
Public property | LineWeightScale | Gets or sets a scale for drawing lines. (inherited from CADPresenterSettings).
Public property | NullWidth | Gets or sets default thickness for lines used to draw a CADImage. (inherited from CADPresenterSettings).
Public property | TTFSmoothing | Gets or sets a value indicating whether TTF fonts are smoothed. (inherited from CADPresenterSettings).
Public property | TTFSmoothingStyle | Gets or sets smoothing style for TTF fonts. (inherited from CADPresenterSettings).
Public property | TextVisible | Gets or sets a value indicating whether the texts in the CADImage are visible. (inherited from CADPresenterSettings).
Public property | XScale | Gets or sets a scale value for export. (inherited from ExportSettings).
Public property | XSize | For internal use. (inherited from ExportSettings).
Top
See Also

Reference

HPGLExportSettings Class
CADImport.Export Namespace


HPGLExportSettings Methods

HPGLExportSettings Class See Also

The following tables list the members exposed by the HPGLExportSettings type.

Methods
 | Name | Description
Public method | Assign | Copies the settings from a specified CADPresenterSettings object. (inherited from ExportSettings).
Public method | Clone | Creates a new object that is a copy of the current CADPresenterSettings class instance. (inherited from CADPresenterSettings).
Public method | Dispose | (inherited from CADPresenterSettings).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetExportRect | Returns a rectangular area for export. (inherited from ExportSettings).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RestoreParams | Restores the settings of the CADPresenterSettings. (inherited from CADPresenterSettings).
Public method | SaveParams | Saves the settings of the CADPresenterSettings. (inherited from CADPresenterSettings).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

HPGLExportSettings Class
CADImport.Export Namespace


PDFExportSettings Class

Members See Also

Represents settings for exporting the current CAD file into PDF format.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class PDFExportSettings
    Inherits ExportSettings
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class PDFExportSettings : ExportSettings
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADPresenterSettings
CADImport.Export.ExportSettings
CADImport.Export.PDFExportSettings
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDFExportSettings Members
CADImport.Export Namespace


PDFExportSettings Members

PDFExportSettings Class Constructors Methods Fields Properties See Also

Represents settings for exporting the current CAD file into PDF format.

The following tables list the members exposed by the PDFExportSettings type.

Constructors
 | Name | Description
Public constructor | PDFExportSettings | Initializes a new instance of the PDFExportSettings class.
Top
Properties
 | Name | Description
Public property | BackgroundColor | Gets or sets a background color of this CADImage. (inherited from CADPresenterSettings).
Public property | BorderSize | Gets or sets a border size in pixels. (inherited from CADPresenterSettings).
Public property | BorderType | Gets or sets a border type. (inherited from CADPresenterSettings).
Public property | Centered | Specifies if a page is aligned to center.
Public property | ClearStreamByDisposeOnly | Created stream will be closed when disposing export class (inherited from ExportSettings).
Public property | ClipRectangle | Gets or sets clipping rectangle.
Public property | DefaultAngle | Gets or sets a default color for the CADImage. (inherited from CADPresenterSettings).
Public property | DefaultColor | Gets or sets a default color for the CADImage. (inherited from CADPresenterSettings).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions on the drawing are visible. (inherited from CADPresenterSettings).
Public property | DrawMode | Gets or sets a current drawing mode. (inherited from CADPresenterSettings).
Public property | ImageRectangle | Represents a rectangle that encloses CADImage object. (inherited from ExportSettings).
Public property | IsDraw3DAxes | Gets or sets a value indicating whether 3D axes are shown on the drawing. (inherited from CADPresenterSettings).
Public property | IsShowBackground | Gets or sets a value indicating using of a BackgroundColor. (inherited from CADPresenterSettings).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data. (inherited from CADPresenterSettings).
Public property | LayoutsExportMode | Gets or sets a value specifying which layouts will be exported. (inherited from ExportSettings).
Public property | LineScaled | Obsolete. Gets or sets a value indicating whether a width of lines to draw all entities in the drawing is specified by the file data. (inherited from CADPresenterSettings).
Public property | LineWeightScale | Gets or sets a scale for drawing lines. (inherited from CADPresenterSettings).
Public property | Margins | Gets or sets margins for the page.
Public property | NullWidth | Gets or sets default thickness for lines used to draw a CADImage. (inherited from CADPresenterSettings).
Public property | PageHeight | Gets or sets a height of PDF document page.
Public property | PageWidth | Gets or sets a width of PDF document page.
Public property | Precision | Gets or sets precision of PDF document.
Public property | Quality | Gets or sets a quality of PDF document.
Public property | Shift | For internal use.
Public property | TTFSmoothing | Gets or sets a value indicating whether TTF fonts are smoothed. (inherited from CADPresenterSettings).
Public property | TTFSmoothingStyle | Gets or sets smoothing style for TTF fonts. (inherited from CADPresenterSettings).
Public property | TextVisible | Gets or sets a value indicating whether the texts in the CADImage are visible. (inherited from CADPresenterSettings).
Public property | XScale | Gets or sets a scale value for export. (inherited from ExportSettings).
Public property | XSize | For internal use. (inherited from ExportSettings).
Top
Methods
 | Name | Description
Public method | Assign | Copies the settings from a specified CADPresenterSettings object.
Public method | Clone | Creates a new object that is a copy of the current CADPresenterSettings class instance. (inherited from CADPresenterSettings).
Public method | Dispose | (inherited from CADPresenterSettings).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetClipRect | Returns a clipping rectangle.
Public method | GetExportRect | Returns a rectangular area for export.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetMarginRect | Returns a rectangle formed by margins.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | HasClipRect | Returns a value, specifying if clipping rectangle is defined.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RestoreParams | Restores the settings of the CADPresenterSettings. (inherited from CADPresenterSettings).
Public method | SaveParams | Saves the settings of the CADPresenterSettings. (inherited from CADPresenterSettings).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
Name | Description
MMPerInch | Specifies a ratio between millimeters and inches for PDF export.
MMPerPDFUnit | Specifies a ratio between millimeters and PDF units for PDF export.
Top
See Also

Reference

PDFExportSettings Class
CADImport.Export Namespace


PDFExportSettings Constructor

Initializes a new instance of the PDFExportSettings class.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public PDFExportSettings()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDFExportSettings Class
PDFExportSettings Members
CADImport.Export Namespace


PDFExportSettings Properties

PDFExportSettings Class See Also

The following tables list the members exposed by the PDFExportSettings type.

Properties
 | Name | Description
Public property | BackgroundColor | Gets or sets a background color of this CADImage. (inherited from CADPresenterSettings).
Public property | BorderSize | Gets or sets a border size in pixels. (inherited from CADPresenterSettings).
Public property | BorderType | Gets or sets a border type. (inherited from CADPresenterSettings).
Public property | Centered | Specifies if a page is aligned to center.
Public property | ClearStreamByDisposeOnly | Created stream will be closed when disposing export class (inherited from ExportSettings).
Public property | ClipRectangle | Gets or sets clipping rectangle.
Public property | DefaultAngle | Gets or sets a default color for the CADImage. (inherited from CADPresenterSettings).
Public property | DefaultColor | Gets or sets a default color for the CADImage. (inherited from CADPresenterSettings).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions on the drawing are visible. (inherited from CADPresenterSettings).
Public property | DrawMode | Gets or sets a current drawing mode. (inherited from CADPresenterSettings).
Public property | ImageRectangle | Represents a rectangle that encloses CADImage object. (inherited from ExportSettings).
Public property | IsDraw3DAxes | Gets or sets a value indicating whether 3D axes are shown on the drawing. (inherited from CADPresenterSettings).
Public property | IsShowBackground | Gets or sets a value indicating using of a BackgroundColor. (inherited from CADPresenterSettings).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data. (inherited from CADPresenterSettings).
Public property | LayoutsExportMode | Gets or sets a value specifying which layouts will be exported. (inherited from ExportSettings).
Public property | LineScaled | Obsolete. Gets or sets a value indicating whether a width of lines to draw all entities in the drawing is specified by the file data. (inherited from CADPresenterSettings).
Public property | LineWeightScale | Gets or sets a scale for drawing lines. (inherited from CADPresenterSettings).
Public property | Margins | Gets or sets margins for the page.
Public property | NullWidth | Gets or sets default thickness for lines used to draw a CADImage. (inherited from CADPresenterSettings).
Public property | PageHeight | Gets or sets a height of PDF document page.
Public property | PageWidth | Gets or sets a width of PDF document page.
Public property | Precision | Gets or sets precision of PDF document.
Public property | Quality | Gets or sets a quality of PDF document.
Public property | Shift | For internal use.
Public property | TTFSmoothing | Gets or sets a value indicating whether TTF fonts are smoothed. (inherited from CADPresenterSettings).
Public property | TTFSmoothingStyle | Gets or sets smoothing style for TTF fonts. (inherited from CADPresenterSettings).
Public property | TextVisible | Gets or sets a value indicating whether the texts in the CADImage are visible. (inherited from CADPresenterSettings).
Public property | XScale | Gets or sets a scale value for export. (inherited from ExportSettings).
Public property | XSize | For internal use. (inherited from ExportSettings).
Top
See Also

Reference

PDFExportSettings Class
CADImport.Export Namespace


PDFExportSettings.Centered Property

Specifies if a page is aligned to center.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Centered() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Centered {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDFExportSettings Class
PDFExportSettings Members
CADImport.Export Namespace


PDFExportSettings.ClipRectangle Property

Gets or sets clipping rectangle.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ClipRectangle() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DRect ClipRectangle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDFExportSettings Class
PDFExportSettings Members
CADImport.Export Namespace


PDFExportSettings.Margins Property

Gets or sets margins for the page.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Margins() As PDFMargins
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public PDFMargins Margins {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDFExportSettings Class
PDFExportSettings Members
CADImport.Export Namespace


PDFExportSettings.PageHeight Property

Gets or sets a height of PDF document page.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PageHeight() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double PageHeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDFExportSettings Class
PDFExportSettings Members
CADImport.Export Namespace


PDFExportSettings.PageWidth Property

Gets or sets a width of PDF document page.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PageWidth() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double PageWidth {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDFExportSettings Class
PDFExportSettings Members
CADImport.Export Namespace


PDFExportSettings.Precision Property

Gets or sets precision of PDF document.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Precision() As PDFPrecision
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public PDFPrecision Precision {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDFExportSettings Class
PDFExportSettings Members
CADImport.Export Namespace


PDFExportSettings.Quality Property

Gets or sets a quality of PDF document.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Quality() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Quality {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDFExportSettings Class
PDFExportSettings Members
CADImport.Export Namespace


PDFExportSettings.Shift Property

For internal use.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Shift() As PointF
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public PointF Shift {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDFExportSettings Class
PDFExportSettings Members
CADImport.Export Namespace


PDFExportSettings Methods

PDFExportSettings Class See Also

The following tables list the members exposed by the PDFExportSettings type.

Methods
 | Name | Description
Public method | Assign | Copies the settings from a specified CADPresenterSettings object.
Public method | Clone | Creates a new object that is a copy of the current CADPresenterSettings class instance. (inherited from CADPresenterSettings).
Public method | Dispose | (inherited from CADPresenterSettings).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetClipRect | Returns a clipping rectangle.
Public method | GetExportRect | Returns a rectangular area for export.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetMarginRect | Returns a rectangle formed by margins.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | HasClipRect | Returns a value, specifying if clipping rectangle is defined.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RestoreParams | Restores the settings of the CADPresenterSettings. (inherited from CADPresenterSettings).
Public method | SaveParams | Saves the settings of the CADPresenterSettings. (inherited from CADPresenterSettings).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

PDFExportSettings Class
CADImport.Export Namespace


PDFExportSettings.Assign Method

Copies the settings from a specified CADPresenterSettings object.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Assign( _
   ByVal entity As CADPresenterSettings _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Assign(
   CADPresenterSettings entity
)
This language is not supported or no code example is available.

Parameters

entity

Type: CADPresenterSettings

CADPresenterSettings object to copy settings from.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDFExportSettings Class
PDFExportSettings Members
CADImport.Export Namespace


PDFExportSettings.GetClipRect Method

Returns a clipping rectangle.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetClipRect( _
   ByVal rect As DRect _
) As RectangleF
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public RectangleF GetClipRect(
   DRect rect
)
This language is not supported or no code example is available.

Parameters

rect

Type: DRect

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDFExportSettings Class
PDFExportSettings Members
CADImport.Export Namespace


PDFExportSettings.GetExportRect Method

Returns a rectangular area for export.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function GetExportRect() As DRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override DRect GetExportRect()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDFExportSettings Class
PDFExportSettings Members
CADImport.Export Namespace


PDFExportSettings.GetMarginRect Method

Returns a rectangle formed by margins.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetMarginRect() As RectangleF
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public RectangleF GetMarginRect()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDFExportSettings Class
PDFExportSettings Members
CADImport.Export Namespace


PDFExportSettings.HasClipRect Method

Returns a value, specifying if clipping rectangle is defined.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function HasClipRect() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool HasClipRect()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDFExportSettings Class
PDFExportSettings Members
CADImport.Export Namespace


PDFExportSettings Fields

PDFExportSettings Class See Also

The following tables list the members exposed by the PDFExportSettings type.

Fields
Name | Description
MMPerInch | Specifies a ratio between millimeters and inches for PDF export.
MMPerPDFUnit | Specifies a ratio between millimeters and PDF units for PDF export.
Top
See Also

Reference

PDFExportSettings Class
CADImport.Export Namespace


MMPerInch Field

Specifies a ratio between millimeters and inches for PDF export.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Const MMPerInch As Double = 25,4
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public const double MMPerInch = 25,4
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDFExportSettings Class
PDFExportSettings Members
CADImport.Export Namespace


MMPerPDFUnit Field

Specifies a ratio between millimeters and PDF units for PDF export.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Const MMPerPDFUnit As Double = MMPerInch / 72
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public const double MMPerPDFUnit = MMPerInch / 72
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDFExportSettings Class
PDFExportSettings Members
CADImport.Export Namespace


PDFMargins Structure

Members See Also

Represents margins for a document page

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Structure PDFMargins
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public struct PDFMargins
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDFMargins Members
CADImport.Export Namespace


PDFMargins Members

PDFMargins Structure Constructors Fields Properties See Also

Represents margins for a document page

The following tables list the members exposed by the PDFMargins type.

Constructors
 | Name | Description
Public constructor | PDFMargins |
Top
Properties
 | Name | Description
Public property | Height | Gets the height of margin rectangle.
Public property | Width | Gets the width of margin rectangle.
Top
Fields
 | Name | Description
Public field | Bottom | Bottom border of margin rectangle
Public field | Enabled | Specifyies margins using
Public field | Left | Left border of margin rectangle
Public field | Right | Right border of margin rectangle
Public field | Top | Top border of margin rectangle
Top
See Also

Reference

PDFMargins Structure
CADImport.Export Namespace


PDFMargins Constructor

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal right As Double, _
   ByVal bottom As Double, _
   ByVal enabled As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public PDFMargins(
   double left,
   double top,
   double right,
   double bottom,
   bool enabled
)
This language is not supported or no code example is available.

Parameters

left

Type: double

top

Type: double

right

Type: double

bottom

Type: double

enabled

Type: bool

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDFMargins Structure
PDFMargins Members
CADImport.Export Namespace


PDFMargins Properties

PDFMargins Structure See Also

The following tables list the members exposed by the PDFMargins type.

Properties
 | Name | Description
Public property | Height | Gets the height of margin rectangle.
Public property | Width | Gets the width of margin rectangle.
Top
See Also

Reference

PDFMargins Structure
CADImport.Export Namespace


PDFMargins.Height Property

Gets the height of margin rectangle.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Height() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Height {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDFMargins Structure
PDFMargins Members
CADImport.Export Namespace


PDFMargins.Width Property

Gets the width of margin rectangle.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Width() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Width {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDFMargins Structure
PDFMargins Members
CADImport.Export Namespace


PDFMargins Fields

PDFMargins Structure See Also

The following tables list the members exposed by the PDFMargins type.

Fields
 | Name | Description
Public field | Bottom | Bottom border of margin rectangle
Public field | Enabled | Specifyies margins using
Public field | Left | Left border of margin rectangle
Public field | Right | Right border of margin rectangle
Public field | Top | Top border of margin rectangle
Top
See Also

Reference

PDFMargins Structure
CADImport.Export Namespace


Bottom Field

Bottom border of margin rectangle

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Bottom As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Bottom
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDFMargins Structure
PDFMargins Members
CADImport.Export Namespace


Enabled Field

Specifyies margins using

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Enabled As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Enabled
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDFMargins Structure
PDFMargins Members
CADImport.Export Namespace


Left Field

Left border of margin rectangle

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Left As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Left
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDFMargins Structure
PDFMargins Members
CADImport.Export Namespace


Right Field

Right border of margin rectangle

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Right As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Right
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDFMargins Structure
PDFMargins Members
CADImport.Export Namespace


Top Field

Top border of margin rectangle

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Top As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Top
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDFMargins Structure
PDFMargins Members
CADImport.Export Namespace


GcodeMachineTypeID Enumeration

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Cut | Cutting Machine
Mill | Milling Machine
See Also

Reference

CADImport.Export Namespace


LayoutsExportOption Enumeration

Defines layouts that will be exported.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
All | All layouts
Current | Current layout
See Also

Reference

CADImport.Export Namespace


PDFPrecision Enumeration

Represents precision options for export.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Double | Double precision
Half | 1/2 of Single precision
Integer | Integer precision
Quarter | 1/4 of Single precision
Single | Single precion
See Also

Reference

CADImport.Export Namespace


CADImport.Export.DirectCADtoDXF Namespace

Assembly: CADImport (in CADImport.dll)

Classes
 | Name | Description
Public class | CADtoDXF | Provides a base functionality for direct export of the current CAD file into DXF format.
Top
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


CADtoDXF Class

Members See Also

Provides a base functionality for direct export of the current CAD file into DXF format.

Namespace: CADImport.Export.DirectCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADtoDXF
    Inherits CADExport
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADtoDXF : CADExport
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Export.CADExport
CADImport.Export.DirectCADtoDXF.CADtoDXF
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADtoDXF Members
CADImport.Export.DirectCADtoDXF Namespace


CADtoDXF Members

CADtoDXF Class Constructors Methods See Also

Provides a base functionality for direct export of the current CAD file into DXF format.

The following tables list the members exposed by the CADtoDXF type.

Constructors
 | Name | Description
Public constructor | CADtoDXF | Initializes a new instance of the CADtoDXF object.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from CADExport).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SaveToFile | (Overloaded) Exports the current CAD image to the specified file. (inherited from CADExport).
Public method | SaveToStream | Exports the current CAD file to the stream defined by the StreamWriter.
Public method | SetDXFComment | Sets the 999 group code comment value that will be added at the start of created DXF.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADtoDXF Class
CADImport.Export.DirectCADtoDXF Namespace


CADtoDXF Constructor

Initializes a new instance of the CADtoDXF object.

Namespace: CADImport.Export.DirectCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal img As CADImage _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADtoDXF(
   CADImage img
)
This language is not supported or no code example is available.

Parameters

img

Type: CADImage

The CADImage to be exported to a DXF file.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADtoDXF Class
CADtoDXF Members
CADImport.Export.DirectCADtoDXF Namespace


CADtoDXF Methods

CADtoDXF Class See Also

The following tables list the members exposed by the CADtoDXF type.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from CADExport).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SaveToFile | (Overloaded) Exports the current CAD image to the specified file. (inherited from CADExport).
Public method | SaveToStream | Exports the current CAD file to the stream defined by the StreamWriter.
Public method | SetDXFComment | Sets the 999 group code comment value that will be added at the start of created DXF.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADtoDXF Class
CADImport.Export.DirectCADtoDXF Namespace


CADtoDXF.SaveToStream Method

Exports the current CAD file to the stream defined by the StreamWriter.

Namespace: CADImport.Export.DirectCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub SaveToStream( _
   ByVal wr As Stream _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void SaveToStream(
   Stream wr
)
This language is not supported or no code example is available.

Parameters

wr

Type: Stream

A StreamWriter object that defines the stream where to the current CAD file will be exported.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADtoDXF Class
CADtoDXF Members
CADImport.Export.DirectCADtoDXF Namespace


CADtoDXF.SetDXFComment Method

Sets the 999 group code comment value that will be added at the start of created DXF.

Namespace: CADImport.Export.DirectCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetDXFComment( _
   ByVal comment As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetDXFComment(
   string comment
)
This language is not supported or no code example is available.

Parameters

comment

Type: string

The comment string. Set empty string to switch off the comment

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADtoDXF Class
CADtoDXF Members
CADImport.Export.DirectCADtoDXF Namespace


CADImport.Export.MetaExport Namespace

Assembly: CADImport (in CADImport.dll)

Classes
 | Name | Description
Public class | MetaForm | Implements export to DXF format using a graphic metafile.
Top
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


MetaForm Class

Members See Also

Implements export to DXF format using a graphic metafile.

Namespace: CADImport.Export.MetaExport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class MetaForm
    Implements IDisposable
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class MetaForm : IDisposable
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Export.MetaExport.MetaForm
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MetaForm Members
CADImport.Export.MetaExport Namespace


MetaForm Members

MetaForm Class Constructors Methods Fields Properties See Also

Implements export to DXF format using a graphic metafile.

The following tables list the members exposed by the MetaForm type.

Constructors
 | Name | Description
Public constructor | MetaForm | (Overloaded) Initializes a new instance of the MetaForm class.
Top
Properties
 | Name | Description
Public property | Exporter | Gets the DXFExport class instance.
Public property | FileName | Gets name of a graphic metafile.
Public property | Graphics | Gets a Graphics object from MetaForm.
Top
Methods
 | Name | Description
Public method | AddDrawMetaFormToOnPaint | (Overloaded) Adds an instance of the PaintEventHandler delegate to the Paint event of a specified Control.
Public method | Conversion_Angle | For internal use.
Public method | ConvertToDXF | (Overloaded) Converts a graphic metafile to DXF image.
Public method | Dispose | Releases all resources used by the MetaForm.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | Free |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RemoveDrawMetaFormToOnPaint | (Overloaded) Removes an instance of the PaintEventHandler delegate from the Paint event of a specified Control.
Public method | SaveFromStream | Saves a graphic metafile from file stream to a specified DXF file.
Public method | SplitingToStream | (Overloaded) Saves a graphic metafile to a specified stream.
 | Splitting | Converts a specified graphic metafile to a specified DXF file.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | mfStream |
Top
See Also

Reference

MetaForm Class
CADImport.Export.MetaExport Namespace


MetaForm Constructor

MetaForm Class See Also

Initializes a new instance of the MetaForm class.

Overload List
Name | Description
MetaForm() | Initializes a new instance of the MetaForm class.
MetaForm(EmfType) | Initializes a new instance of the MetaForm class.
MetaForm(string, int, int) | Initializes a new instance of the MetaForm class.
MetaForm(string, int, int, EmfType) | Initializes a new instance of the MetaForm class.
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


MetaForm Properties

MetaForm Class See Also

The following tables list the members exposed by the MetaForm type.

Properties
 | Name | Description
Public property | Exporter | Gets the DXFExport class instance.
Public property | FileName | Gets name of a graphic metafile.
Public property | Graphics | Gets a Graphics object from MetaForm.
Top
See Also

Reference

MetaForm Class
CADImport.Export.MetaExport Namespace


MetaForm.Exporter Property

Gets the DXFExport class instance.

Namespace: CADImport.Export.MetaExport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Exporter() As DXFExport
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFExport Exporter {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


MetaForm.FileName Property

Gets name of a graphic metafile.

Namespace: CADImport.Export.MetaExport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property FileName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string FileName {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


MetaForm.Graphics Property

Gets a Graphics object from MetaForm.

Namespace: CADImport.Export.MetaExport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Graphics() As Graphics
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Graphics Graphics {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


MetaForm Methods

MetaForm Class See Also

The following tables list the members exposed by the MetaForm type.

Methods
 | Name | Description
Public method | AddDrawMetaFormToOnPaint | (Overloaded) Adds an instance of the PaintEventHandler delegate to the Paint event of a specified Control.
Public method | Conversion_Angle | For internal use.
Public method | ConvertToDXF | (Overloaded) Converts a graphic metafile to DXF image.
Public method | Dispose | Releases all resources used by the MetaForm.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | Free |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RemoveDrawMetaFormToOnPaint | (Overloaded) Removes an instance of the PaintEventHandler delegate from the Paint event of a specified Control.
Public method | SaveFromStream | Saves a graphic metafile from file stream to a specified DXF file.
Public method | SplitingToStream | (Overloaded) Saves a graphic metafile to a specified stream.
 | Splitting | Converts a specified graphic metafile to a specified DXF file.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

MetaForm Class
CADImport.Export.MetaExport Namespace


MetaForm.AddDrawMetaFormToOnPaint Method

MetaForm Class See Also

Adds an instance of the PaintEventHandler delegate to the Paint event of a specified Control.

Overload List
Name | Description
AddDrawMetaFormToOnPaint(Control) | Adds an instance of the PaintEventHandler delegate to the Paint event of a specified Control.
AddDrawMetaFormToOnPaint(Form) | Adds an instance of the PaintEventHandler delegate to the Paint event of a specified Form.
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


MetaForm.Conversion_Angle Method

For internal use.

Namespace: CADImport.Export.MetaExport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Conversion_Angle( _
   ByVal Val As Single _
) As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float Conversion_Angle(
   float Val
)
This language is not supported or no code example is available.

Parameters

Val

Type: float

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


MetaForm.ConvertToDXF Method

MetaForm Class See Also

Converts a graphic metafile to DXF image.

Overload List
Name | Description
ConvertToDXF() | Converts a graphic metafile to DXF image.
ConvertToDXF(string) | Converts a graphic metafile to a specified DXF file.
ConvertToDXF(string, float) | Converts a graphic metafile to a specified DXF file.
ConvertToDXF(string, string) | Converts a specified graphic metafile to a specified DXF file.
ConvertToDXF(string, string, float) | Converts a specified graphic metafile to a specified DXF file.
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


MetaForm.Dispose Method

Releases all resources used by the MetaForm.

Namespace: CADImport.Export.MetaExport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Dispose() Implements  _
   IDisposable.Dispose
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Dispose()
This language is not supported or no code example is available.

Implements

IDisposable.Dispose
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


MetaForm.Free Method

Namespace: CADImport.Export.MetaExport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Free()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Free()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


MetaForm.RemoveDrawMetaFormToOnPaint Method

MetaForm Class See Also

Removes an instance of the PaintEventHandler delegate from the Paint event of a specified Control.

Overload List
Name | Description
RemoveDrawMetaFormToOnPaint(Control) | Removes an instance of the PaintEventHandler delegate from the Paint event of a specified Control.
RemoveDrawMetaFormToOnPaint(Form) | Removes an instance of the PaintEventHandler delegate from the Paint event of a specified Form.
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


MetaForm.SaveFromStream Method

Saves a graphic metafile from file stream to a specified DXF file.

Namespace: CADImport.Export.MetaExport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function SaveFromStream( _
   ByVal fName As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool SaveFromStream(
   string fName
)
This language is not supported or no code example is available.

Parameters

fName

Type: string

A name of the output DXF file.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


MetaForm.SplitingToStream Method

MetaForm Class See Also

Saves a graphic metafile to a specified stream.

Overload List
Name | Description
SplitingToStream(StringWriter) | Saves a graphic metafile to a specified stream.
SplitingToStream(StringWriter, float) | Saves a graphic metafile to a specified stream.
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


MetaForm.Splitting Method

Converts a specified graphic metafile to a specified DXF file.

Namespace: CADImport.Export.MetaExport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function Splitting( _
   ByVal inputFile As String, _
   ByVal outFileName As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool Splitting(
   string inputFile,
   string outFileName
)
This language is not supported or no code example is available.

Parameters

inputFile

Type: string

A name of the input graphic metafile.

outFileName

Type: string

A name of the output DXF file.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


MetaForm Fields

MetaForm Class See Also

The following tables list the members exposed by the MetaForm type.

Fields
 | Name | Description
Public field | mfStream |
Top
See Also

Reference

MetaForm Class
CADImport.Export.MetaExport Namespace


mfStream Field

Namespace: CADImport.Export.MetaExport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public mfStream As MemoryStream
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public MemoryStream mfStream
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


CADImport.Export.SimpleCADtoDXF Namespace

Assembly: CADImport (in CADImport.dll)

Classes
 | Name | Description
Public class | DXFArc | Represents an arc in a DXF image.
Public class | DXFBlock | Represents the block entity in a DXF image.
Public class | DXFData | The DXFData class can contain information about any DXF entity.
Public class | DXFDimension | Represents dimensions in a DXF image.
Public class | DXFEllipse | Represents an ellipse in a DXF image.
Public class | DXFExport | This is a basic class of export. All methods for formation of a dxf file are determined here.
Public class | DXFFigure | This is a base class of figures.
Public class | DXFHatch | Represents a hatch in a DXF image.
Public class | DXFLayer | Represents a layer in a DXF image.
Public class | DXFLine | Represents a line in a DXF image.
Public class | DXFMText | DXF metric text class.
Public class | DXFPixel | Represents a pixel in a DXF image.
Public class | DXFPoint | Represents a 3D point in a DXF image.
Public class | DXFPolyBezier | Represents the polybezier line in a DXF image.
Public class | DXFPolyline | Represents a polyline in a DXF image.
Public class | DXFRectangle | Represents a Rectangle in a DXF image.
Public class | DXFSolid | Represents a solid in a DXF image.
Public class | DXFText | Represents a text in a DXF image.
Top
Structures
 | Name | Description
Public structure | DXFHatchPatternData | Represents the hatch pattern data
Public structure | DimensionStyle | A style of dimension
Public structure | Line | Auxiliary structure of a line
Public structure | Rect | Auxiliary structure of a rectangle
Top
Enumerations
 | Name | Description
Public enumeration | ArcType | Types for DXFArc
Public enumeration | AutoCADVersion | Version types of AutoCAD.
Public enumeration | DXFIntConst | Types of DXF color.
Public enumeration | DimensionArrowType | Type of the dimension arrow
Public enumeration | DimensionType | A type of dimension
Public enumeration | HatchBoundaryType | Types for DXFHatch.
Public enumeration | HatchStyle | Type styles of a hatch
Top
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


DXFArc Class

Members See Also

Represents an arc in a DXF image.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class DXFArc
    Inherits DXFFigure
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class DXFArc : DXFFigure
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Export.SimpleCADtoDXF.DXFFigure
CADImport.Export.SimpleCADtoDXF.DXFArc
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFArc Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFArc Members

DXFArc Class Constructors Methods Fields Properties See Also

Represents an arc in a DXF image.

The following tables list the members exposed by the DXFArc type.

Constructors
 | Name | Description
Public constructor | DXFArc | (Overloaded) Initializes a new instance of the DXFArc class.
Top
Properties
 | Name | Description
Public property | Color | Gets or sets a color for this figure. (inherited from DXFFigure).
Public property | EndAngle | Represents the end angle of an arc.
Public property | Layer | Gets or sets the current layer for this figure. (inherited from DXFFigure).
Public property | Point | Gets or sets coordinates of the center point of an arc.
Public property | Radius | Gets or sets the radius of an arc.
Public property | StartAngle | Represents the start angle of an arc.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportAsDXF | Adds an arc to the DXFExport figures collection.
Public method | ExportBlockAsDXF | Virtual function. For redifinition in descendant classes. (inherited from DXFFigure).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ParseToLines | Performs figure approximation by linear segments.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | data | Represents all data (DXFData) of a figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFArc Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFArc Constructor

DXFArc Class See Also

Initializes a new instance of the DXFArc class.

Overload List
Name | Description
DXFArc() | Initializes a new instance of the DXFArc class.
DXFArc(DXFData) | Initializes a new instance of the DXFArc class that have field data copied from specified object.
See Also

Reference

DXFArc Class
DXFArc Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFArc Properties

DXFArc Class See Also

The following tables list the members exposed by the DXFArc type.

Properties
 | Name | Description
Public property | Color | Gets or sets a color for this figure. (inherited from DXFFigure).
Public property | EndAngle | Represents the end angle of an arc.
Public property | Layer | Gets or sets the current layer for this figure. (inherited from DXFFigure).
Public property | Point | Gets or sets coordinates of the center point of an arc.
Public property | Radius | Gets or sets the radius of an arc.
Public property | StartAngle | Represents the start angle of an arc.
Top
See Also

Reference

DXFArc Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFFigure.Color Property

Gets or sets a color for this figure.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Color() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Color {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFFigure Class
DXFFigure Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFArc.EndAngle Property

Represents the end angle of an arc.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property EndAngle() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float EndAngle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFArc Class
DXFArc Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFFigure.Layer Property

Gets or sets the current layer for this figure.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Layer() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Layer {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFFigure Class
DXFFigure Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFArc.Point Property

Gets or sets coordinates of the center point of an arc.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Point() As DXFPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFPoint Point {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFArc Class
DXFArc Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFArc.Radius Property

Gets or sets the radius of an arc.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Radius() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float Radius {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFArc Class
DXFArc Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFArc.StartAngle Property

Represents the start angle of an arc.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property StartAngle() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float StartAngle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFArc Class
DXFArc Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFArc Methods

DXFArc Class See Also

The following tables list the members exposed by the DXFArc type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportAsDXF | Adds an arc to the DXFExport figures collection.
Public method | ExportBlockAsDXF | Virtual function. For redifinition in descendant classes. (inherited from DXFFigure).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ParseToLines | Performs figure approximation by linear segments.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

DXFArc Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFArc.ExportAsDXF Method

Adds an arc to the DXFExport figures collection.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub ExportAsDXF( _
   ByVal ADXFExport As DXFExport _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void ExportAsDXF(
   DXFExport ADXFExport
)
This language is not supported or no code example is available.

Parameters

ADXFExport

Type: DXFExport

DXFExport object.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFArc Class
DXFArc Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFFigure.ExportBlockAsDXF Method

Virtual function. For redifinition in descendant classes.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub ExportBlockAsDXF( _
   ByVal ADXFExport As DXFExport _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void ExportBlockAsDXF(
   DXFExport ADXFExport
)
This language is not supported or no code example is available.

Parameters

ADXFExport

Type: DXFExport

DXFExport object.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFFigure Class
DXFFigure Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFArc.ParseToLines Method

Performs figure approximation by linear segments.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub ParseToLines( _
   ByVal NewElemes As ArrayList _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void ParseToLines(
   ArrayList NewElemes
)
This language is not supported or no code example is available.

Parameters

NewElemes

Type: ArrayList

An array of points that will receive approximation results.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFArc Class
DXFArc Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFArc Fields

DXFArc Class See Also

The following tables list the members exposed by the DXFArc type.

Fields
 | Name | Description
Public field | data | Represents all data (DXFData) of a figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFArc Class
CADImport.Export.SimpleCADtoDXF Namespace


data Field

Represents all data (DXFData) of a figure.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public data As DXFData
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFData data
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFFigure Class
DXFFigure Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFBlock Class

Members See Also

Represents the block entity in a DXF image.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class DXFBlock
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class DXFBlock
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Export.SimpleCADtoDXF.DXFBlock
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFBlock Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFBlock Members

DXFBlock Class Constructors Methods See Also

Represents the block entity in a DXF image.

The following tables list the members exposed by the DXFBlock type.

Constructors
 | Name | Description
Public constructor | DXFBlock | Initializes a new instance of the DXFBlock class.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

DXFBlock Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFBlock Constructor

Initializes a new instance of the DXFBlock class.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal aName As String, _
   ByVal aBlockRecordHandle As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFBlock(
   string aName,
   int aBlockRecordHandle
)
This language is not supported or no code example is available.

Parameters

aName

Type: string

A block name

aBlockRecordHandle

Type: int

A block handle

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFBlock Class
DXFBlock Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFBlock Methods

DXFBlock Class See Also

The following tables list the members exposed by the DXFBlock type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

DXFBlock Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFData Class

Members See Also

The DXFData class can contain information about any DXF entity.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class DXFData
    Implements ICloneable
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class DXFData : ICloneable
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Export.SimpleCADtoDXF.DXFData
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFData Members

DXFData Class Methods Fields See Also

The DXFData class can contain information about any DXF entity.

The following tables list the members exposed by the DXFData type.

Methods
 | Name | Description
Public method | Clear | Resets all initial values for this object.
Public method | Clone | Creates a shallow copy of the DXFData.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | bold | Represents a style for a text.
Public field | color | Represents the color value for this entity.
Public field | count | Represents the number of child entities (for BLOCK, POLYLINE etc). For simple entities such as LINE it is always 0.
Public field | endAngle | Represents the end angle values in degrees for ARC and ELLIPSE.
Public field | fScale | Represents the relative X scale factor (ratio of character width to character height) for text entities.
Public field | flags | Represents the flags byte for different entities, such as LAYER, BLOCK, POLYLINE etc. Has individual meaning for each entity type. For details see AutoCAD DXF Reference.
Public field | globalWidth | Represents a global width.
Public field | hAlign | Specifies the horizontal alignment for text entities.
Public field | height | Specifies the character height for text entities (TEXT, MTEXT or ATTDEF).
Public field | italic | Represents a style for a text.
Public field | name | Represents a name of an object.
Public field | point | Specifies the reference point for this entity. For details see AutoCAD DXF Reference, group codes 10,20,30.
Public field | point1 | Specifies the second reference point for such entities as LINE, TEXT or ELLIPSE. For details see AutoCAD DXF Reference, group codes 11,21,31.
Public field | point2 | Specifies the third points for SOLID and 3DFACE.
Public field | point3 | Specifies the fourth points for SOLID and 3DFACE.
Public field | points | Points to array of DXFPOINT for POLYLINE, LWPOLYLINE and HATCH. The number of points is specified by count.
Public field | rHeight | Specifies the reference retangle height for MTEXT.
Public field | rWidth | Specifies the reference retangle width for MTEXT.
Public field | radius | Specifies the radius value for CIRCLE and ARC or ratio of minor axis to major axis for ELLIPSE.
Public field | rotation | Specifies the rotation angle in degrees for TEXT or INSERT.
Public field | scale | Specifies the X-, Y- and Z-scale values for INSERT.
Public field | selfType | Defines a type of this entity.
Public field | startAngle | Specifies the start angle values in degrees for ARC and ELLIPSE.
Public field | style | Specifies the pen style for drawing of this entity.
Public field | styleObject | Represents an object style.
Public field | tag | Specifies the type of a DXF entity.
Public field | text | Specifies a text value for text entities (TEXT, MTEXT or ATTDEF).
Public field | thickness | Specifies the line width for this entity.
Public field | vAlign | Specifies the vertical alignment for text entities.
Top
See Also

Reference

DXFData Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFData Methods

DXFData Class See Also

The following tables list the members exposed by the DXFData type.

Methods
 | Name | Description
Public method | Clear | Resets all initial values for this object.
Public method | Clone | Creates a shallow copy of the DXFData.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

DXFData Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFData.Clear Method

Resets all initial values for this object.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Clear()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Clear()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFData.Clone Method

Creates a shallow copy of the DXFData.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Clone() As Object Implements  _
   ICloneable.Clone
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public object Clone()
This language is not supported or no code example is available.

Return Value

A shallow copy of the DXFData.

Implements

ICloneable.Clone
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFData Fields

DXFData Class See Also

The following tables list the members exposed by the DXFData type.

Fields
 | Name | Description
Public field | bold | Represents a style for a text.
Public field | color | Represents the color value for this entity.
Public field | count | Represents the number of child entities (for BLOCK, POLYLINE etc). For simple entities such as LINE it is always 0.
Public field | endAngle | Represents the end angle values in degrees for ARC and ELLIPSE.
Public field | fScale | Represents the relative X scale factor (ratio of character width to character height) for text entities.
Public field | flags | Represents the flags byte for different entities, such as LAYER, BLOCK, POLYLINE etc. Has individual meaning for each entity type. For details see AutoCAD DXF Reference.
Public field | globalWidth | Represents a global width.
Public field | hAlign | Specifies the horizontal alignment for text entities.
Public field | height | Specifies the character height for text entities (TEXT, MTEXT or ATTDEF).
Public field | italic | Represents a style for a text.
Public field | name | Represents a name of an object.
Public field | point | Specifies the reference point for this entity. For details see AutoCAD DXF Reference, group codes 10,20,30.
Public field | point1 | Specifies the second reference point for such entities as LINE, TEXT or ELLIPSE. For details see AutoCAD DXF Reference, group codes 11,21,31.
Public field | point2 | Specifies the third points for SOLID and 3DFACE.
Public field | point3 | Specifies the fourth points for SOLID and 3DFACE.
Public field | points | Points to array of DXFPOINT for POLYLINE, LWPOLYLINE and HATCH. The number of points is specified by count.
Public field | rHeight | Specifies the reference retangle height for MTEXT.
Public field | rWidth | Specifies the reference retangle width for MTEXT.
Public field | radius | Specifies the radius value for CIRCLE and ARC or ratio of minor axis to major axis for ELLIPSE.
Public field | rotation | Specifies the rotation angle in degrees for TEXT or INSERT.
Public field | scale | Specifies the X-, Y- and Z-scale values for INSERT.
Public field | selfType | Defines a type of this entity.
Public field | startAngle | Specifies the start angle values in degrees for ARC and ELLIPSE.
Public field | style | Specifies the pen style for drawing of this entity.
Public field | styleObject | Represents an object style.
Public field | tag | Specifies the type of a DXF entity.
Public field | text | Specifies a text value for text entities (TEXT, MTEXT or ATTDEF).
Public field | thickness | Specifies the line width for this entity.
Public field | vAlign | Specifies the vertical alignment for text entities.
Top
See Also

Reference

DXFData Class
CADImport.Export.SimpleCADtoDXF Namespace


bold Field

Represents a style for a text.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public bold As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte bold
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


color Field

Represents the color value for this entity.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public color As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int color
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


count Field

Represents the number of child entities (for BLOCK, POLYLINE etc). For simple entities such as LINE it is always 0.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public count As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int count
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


endAngle Field

Represents the end angle values in degrees for ARC and ELLIPSE.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public endAngle As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float endAngle
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


fScale Field

Represents the relative X scale factor (ratio of character width to character height) for text entities.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public fScale As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float fScale
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


flags Field

Represents the flags byte for different entities, such as LAYER, BLOCK, POLYLINE etc. Has individual meaning for each entity type. For details see AutoCAD DXF Reference.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public flags As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int flags
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


globalWidth Field

Represents a global width.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public globalWidth As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float globalWidth
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


hAlign Field

Specifies the horizontal alignment for text entities.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public hAlign As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte hAlign
This language is not supported or no code example is available.
Remarks

0 = Left; 1 = Center; 2 = Right.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


height Field

Specifies the character height for text entities (TEXT, MTEXT or ATTDEF).

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public height As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float height
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


italic Field

Represents a style for a text.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public italic As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte italic
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


name Field

Represents a name of an object.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public name As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string name
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


point Field

Specifies the reference point for this entity. For details see AutoCAD DXF Reference, group codes 10,20,30.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shadows point As DXFPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
new public DXFPoint point
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


point1 Field

Specifies the second reference point for such entities as LINE, TEXT or ELLIPSE. For details see AutoCAD DXF Reference, group codes 11,21,31.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shadows point1 As DXFPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
new public DXFPoint point1
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


point2 Field

Specifies the third points for SOLID and 3DFACE.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shadows point2 As DXFPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
new public DXFPoint point2
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


point3 Field

Specifies the fourth points for SOLID and 3DFACE.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shadows point3 As DXFPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
new public DXFPoint point3
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


points Field

Points to array of DXFPOINT for POLYLINE, LWPOLYLINE and HATCH. The number of points is specified by count.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shadows points As ArrayList
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
new public ArrayList points
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


rHeight Field

Specifies the reference retangle height for MTEXT.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public rHeight As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float rHeight
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


rWidth Field

Specifies the reference retangle width for MTEXT.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public rWidth As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float rWidth
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


radius Field

Specifies the radius value for CIRCLE and ARC or ratio of minor axis to major axis for ELLIPSE.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public radius As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float radius
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


rotation Field

Specifies the rotation angle in degrees for TEXT or INSERT.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public rotation As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float rotation
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


scale Field

Specifies the X-, Y- and Z-scale values for INSERT.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shadows scale As DXFPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
new public DXFPoint scale
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


selfType Field

Defines a type of this entity.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public selfType As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte selfType
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


startAngle Field

Specifies the start angle values in degrees for ARC and ELLIPSE.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public startAngle As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float startAngle
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


style Field

Specifies the pen style for drawing of this entity.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public style As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte style
This language is not supported or no code example is available.
Remarks

<p>Value Meaning</p> <p>PS_SOLID - Pen is solid.</p> <p>PS_DASH - Pen is dashed.</p> <p>PS_DOT - Pen is dotted.</p> <p>PS_DASHDOT - Pen has alternating dashes and dots.</p> <p>PS_DASHDOTDOT - Pen has dashes and double dots.</p>

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


styleObject Field

Represents an object style.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public styleObject As Object
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public object styleObject
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


tag Field

Specifies the type of a DXF entity.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public tag As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int tag
This language is not supported or no code example is available.
Remarks

<p>DXF_UNKNOWN = 0;</p> <p>DXF_TABLE = 1;</p> <p>DXF_BLOCK = 2;</p> <p>DXF_LTYPE = 3;</p> <p>DXF_LAYER = 4;</p> <p>DXF_VERTEX = 5;</p> <p>DXF_LINE = 6;</p> <p>DXF_SOLID = 7;</p> <p>DXF_CIRCLE = 8;</p> <p>DXF_ARC = 9;</p> <p>DXF_POLYLINE = 10;</p> <p>DXF_LWPOLYLINE = 11;</p> <p>DXF_SPLINE = 12;</p> <p>DXF_INSERT = 13;</p> <p>DXF_DIMENSION = 14;</p> <p>DXF_TEXT = 15;</p> <p>DXF_MTEXT = 16;</p> <p>DXF_ATTDEF = 17;</p> <p>DXF_ELLIPSE = 18;</p> <p>DXF_POINT = 19;</p> <p>DXF_3DFACE = 20;</p>

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


text Field

Specifies a text value for text entities (TEXT, MTEXT or ATTDEF).

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public text As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string text
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


thickness Field

Specifies the line width for this entity.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public thickness As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float thickness
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


vAlign Field

Specifies the vertical alignment for text entities.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public vAlign As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte vAlign
This language is not supported or no code example is available.
Remarks

0 = Baseline; 1 = Bottom; 2 = Middle; 3 = Top.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFData Class
DXFData Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFDimension Class

Members See Also

Represents dimensions in a DXF image.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class DXFDimension
    Inherits DXFFigure
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class DXFDimension : DXFFigure
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Export.SimpleCADtoDXF.DXFFigure
CADImport.Export.SimpleCADtoDXF.DXFDimension
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFDimension Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFDimension Members

DXFDimension Class Constructors Methods Fields Properties See Also

Represents dimensions in a DXF image.

The following tables list the members exposed by the DXFDimension type.

Constructors
 | Name | Description
Public constructor | DXFDimension | Initializes a new instance of the DXFDimension class that have field data copied from specified object.
Top
Properties
 | Name | Description
Public property | Color | Gets or sets a color for this figure. (inherited from DXFFigure).
Public property | Layer | Gets or sets the current layer for this figure. (inherited from DXFFigure).
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportAsDXF | Adds a figure to DXFExport figures collection.
Public method | ExportBlockAsDXF | Virtual function. For redifinition in descendant classes. (inherited from DXFFigure).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ParseToLines | Performs figure approximation by linear segments. (inherited from DXFFigure).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | data | Represents all data (DXFData) of a figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFDimension Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFDimension Constructor

Initializes a new instance of the DXFDimension class that have field data copied from specified object.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal aData As DXFData _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFDimension(
   DXFData aData
)
This language is not supported or no code example is available.

Parameters

aData

Type: DXFData

DXFData object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFDimension Class
DXFDimension Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFDimension Properties

DXFDimension Class See Also

The following tables list the members exposed by the DXFDimension type.

Properties
 | Name | Description
Public property | Color | Gets or sets a color for this figure. (inherited from DXFFigure).
Public property | Layer | Gets or sets the current layer for this figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFDimension Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFDimension Methods

DXFDimension Class See Also

The following tables list the members exposed by the DXFDimension type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportAsDXF | Adds a figure to DXFExport figures collection.
Public method | ExportBlockAsDXF | Virtual function. For redifinition in descendant classes. (inherited from DXFFigure).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ParseToLines | Performs figure approximation by linear segments. (inherited from DXFFigure).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

DXFDimension Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFDimension.ExportAsDXF Method

Adds a figure to DXFExport figures collection.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub ExportAsDXF( _
   ByVal ADXFExport As DXFExport _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void ExportAsDXF(
   DXFExport ADXFExport
)
This language is not supported or no code example is available.

Parameters

ADXFExport

Type: DXFExport

A DXFExport object.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFDimension Class
DXFDimension Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFFigure.ParseToLines Method

Performs figure approximation by linear segments.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub ParseToLines( _
   ByVal NewElemes As ArrayList _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void ParseToLines(
   ArrayList NewElemes
)
This language is not supported or no code example is available.

Parameters

NewElemes

Type: ArrayList

An array of points that will receive approximation results.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFFigure Class
DXFFigure Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFDimension Fields

DXFDimension Class See Also

The following tables list the members exposed by the DXFDimension type.

Fields
 | Name | Description
Public field | data | Represents all data (DXFData) of a figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFDimension Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFEllipse Class

Members See Also

Represents an ellipse in a DXF image.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class DXFEllipse
    Inherits DXFFigure
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class DXFEllipse : DXFFigure
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Export.SimpleCADtoDXF.DXFFigure
CADImport.Export.SimpleCADtoDXF.DXFEllipse
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFEllipse Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFEllipse Members

DXFEllipse Class Constructors Methods Fields Properties See Also

Represents an ellipse in a DXF image.

The following tables list the members exposed by the DXFEllipse type.

Constructors
 | Name | Description
Public constructor | DXFEllipse | (Overloaded) Initializes a new instance of the DXFEllipse class.
Top
Properties
 | Name | Description
Public property | Color | Gets or sets a color for this figure. (inherited from DXFFigure).
Public property | Layer | Gets or sets the current layer for this figure. (inherited from DXFFigure).
Public property | LeftTop | Gets coordinates of the left top point of an ellipse.
Public property | PCenter | Gets or sets coordinates of the center point of an ellipse.
Public property | RightBottom | Gets coordinates of the right bottom point of an ellipse.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportAsDXF | Adds an ellipse to DXFExport figures collection.
Public method | ExportBlockAsDXF | Virtual function. For redifinition in descendant classes. (inherited from DXFFigure).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ParseToLines | Performs figure approximation by linear segments.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | data | Represents all data (DXFData) of a figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFEllipse Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFEllipse Constructor

DXFEllipse Class See Also

Initializes a new instance of the DXFEllipse class.

Overload List
Name | Description
DXFEllipse() | Initializes a new instance of the DXFEllipse class.
DXFEllipse(DXFData, bool) | Initializes a new instance of the DXFEllipse class that have field data copied from the specified object.
See Also

Reference

DXFEllipse Class
DXFEllipse Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFEllipse Properties

DXFEllipse Class See Also

The following tables list the members exposed by the DXFEllipse type.

Properties
 | Name | Description
Public property | Color | Gets or sets a color for this figure. (inherited from DXFFigure).
Public property | Layer | Gets or sets the current layer for this figure. (inherited from DXFFigure).
Public property | LeftTop | Gets coordinates of the left top point of an ellipse.
Public property | PCenter | Gets or sets coordinates of the center point of an ellipse.
Public property | RightBottom | Gets coordinates of the right bottom point of an ellipse.
Top
See Also

Reference

DXFEllipse Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFEllipse.LeftTop Property

Gets coordinates of the left top point of an ellipse.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property LeftTop() As DXFPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFPoint LeftTop {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFEllipse Class
DXFEllipse Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFEllipse.PCenter Property

Gets or sets coordinates of the center point of an ellipse.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PCenter() As DXFPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFPoint PCenter {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFEllipse Class
DXFEllipse Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFEllipse.RightBottom Property

Gets coordinates of the right bottom point of an ellipse.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property RightBottom() As DXFPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFPoint RightBottom {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFEllipse Class
DXFEllipse Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFEllipse Methods

DXFEllipse Class See Also

The following tables list the members exposed by the DXFEllipse type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportAsDXF | Adds an ellipse to DXFExport figures collection.
Public method | ExportBlockAsDXF | Virtual function. For redifinition in descendant classes. (inherited from DXFFigure).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ParseToLines | Performs figure approximation by linear segments.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

DXFEllipse Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFEllipse.ExportAsDXF Method

Adds an ellipse to DXFExport figures collection.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub ExportAsDXF( _
   ByVal ADXFExport As DXFExport _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void ExportAsDXF(
   DXFExport ADXFExport
)
This language is not supported or no code example is available.

Parameters

ADXFExport

Type: DXFExport

DXFExport object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFEllipse Class
DXFEllipse Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFEllipse.ParseToLines Method

Performs figure approximation by linear segments.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub ParseToLines( _
   ByVal NewElemes As ArrayList _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void ParseToLines(
   ArrayList NewElemes
)
This language is not supported or no code example is available.

Parameters

NewElemes

Type: ArrayList

An array of points that will receive approximation results.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFEllipse Class
DXFEllipse Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFEllipse Fields

DXFEllipse Class See Also

The following tables list the members exposed by the DXFEllipse type.

Fields
 | Name | Description
Public field | data | Represents all data (DXFData) of a figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFEllipse Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport Class

Members See Also

This is a basic class of export. All methods for formation of a dxf file are determined here.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class DXFExport
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class DXFExport
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Export.SimpleCADtoDXF.DXFExport
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport Members

DXFExport Class Constructors Methods Fields Properties See Also

This is a basic class of export. All methods for formation of a dxf file are determined here.

The following tables list the members exposed by the DXFExport type.

Constructors
 | Name | Description
Public constructor | DXFExport | Initializes a new instance of the DXFExport class with defaults parameters.
Top
Properties
 | Name | Description
Public property | Block | Gets or sets the current block.
Public property | CurrentLayer | Gets or sets the current DXF layer.
Public property | PenWidthRatio | Gets or sets the current pen width ratio.
Public property | UnitSize | Gets or sets unit size for export.
Top
Methods
 | Name | Description
Public method | Add3DPoint | Adds a 3D point.
Public method | AddArc | Adds an arc.
Public method | AddCircle | Adds a circle.
Public method | AddColor | Adds a color.
Public method | AddDimension | Adds a dimension
Public method | AddDimensionStyle | Adds a dimension style.
Public method | AddEllipse | Adds an ellipse.
Public method | AddEntity | Adds an entity.
Public method | AddFloat | Adds a float value.
Public method | AddHandle | Adds a handle.
Public method | AddHatch | Adds a hatch.
Public method | AddInt | Adds an integer value.
Public method | AddLType | Adds a linetype.
Public method | AddLTypeScale | Adds a linetype scale.
Public method | AddLine | Adds a line.
Public method | AddMText | Adds a Mtext.
Public method | AddName | Adds a name of an object
Public method | AddPixel | Adds a pixel.
Public method | AddPoint | Adds a point.
Public method | AddPolyBezier | Adds the polyBezier line
Public method | AddPolyLine | Adds a polyline.
Public method | AddRectangle | Adds a rectangle.
Public method | AddSolid | Adds a solid.
Public method | AddString | Adds a string.
Public method | AddText | Adds a text.
Public method | AddThickness | Adds thickness
Public method | AddVertex | Adds a vertex.
Public method | BeginBlock | Begins a DXF block
Public method | BeginPoly | Begins a polyline
Public method | Clear | Clears the DXFExport object
 | ColorToDXF | Converts System.Drawing.Color object to the dxf color
Public method | EndBlock | Ends a DXF block
Public method | EndDraw | Ends a draw
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBlockByName | Gets DXF block by its name
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetStrAutoCADVer | Gets the AutoCAD version
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Insert | Inserts an object
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Save | Saves the DXF image
Public method | SaveToFile | Saves DXF to file
Public method | SaveToStream | Saves DXF to stream.
Public method | SetLayerByString | Sets layer by its name.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
 | DXFLineWeights | The array of the line weight constants.
 | accuracy | The maximal accuracy. Default = 0.000001.
 | alternativeBlack | Specifies if the alternative black color will be used.
 | autoCADVer | Represents the current AutoCAD version.
Public field | current | For internal use.
Public field | fOffset | Represents an offset for hatch object.
 | isParseWhite | Specifies if white rectangle object will be used as erasing region.
 | offsetX | Represents offsets on axis x and on axis y.
 | offsetY | Represents offsets on axis x and on axis y.
 | use01MM | Use of factor of scaling.
Top
See Also

Reference

DXFExport Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport Constructor

Initializes a new instance of the DXFExport class with defaults parameters.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFExport()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport Properties

DXFExport Class See Also

The following tables list the members exposed by the DXFExport type.

Properties
 | Name | Description
Public property | Block | Gets or sets the current block.
Public property | CurrentLayer | Gets or sets the current DXF layer.
Public property | PenWidthRatio | Gets or sets the current pen width ratio.
Public property | UnitSize | Gets or sets unit size for export.
Top
See Also

Reference

DXFExport Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.Block Property

Gets or sets the current block.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Block() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Block {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.CurrentLayer Property

Gets or sets the current DXF layer.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property CurrentLayer() As DXFLayer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFLayer CurrentLayer {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.PenWidthRatio Property

Gets or sets the current pen width ratio.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PenWidthRatio() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float PenWidthRatio {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.UnitSize Property

Gets or sets unit size for export.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property UnitSize() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float UnitSize {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport Methods

DXFExport Class See Also

The following tables list the members exposed by the DXFExport type.

Methods
 | Name | Description
Public method | Add3DPoint | Adds a 3D point.
Public method | AddArc | Adds an arc.
Public method | AddCircle | Adds a circle.
Public method | AddColor | Adds a color.
Public method | AddDimension | Adds a dimension
Public method | AddDimensionStyle | Adds a dimension style.
Public method | AddEllipse | Adds an ellipse.
Public method | AddEntity | Adds an entity.
Public method | AddFloat | Adds a float value.
Public method | AddHandle | Adds a handle.
Public method | AddHatch | Adds a hatch.
Public method | AddInt | Adds an integer value.
Public method | AddLType | Adds a linetype.
Public method | AddLTypeScale | Adds a linetype scale.
Public method | AddLine | Adds a line.
Public method | AddMText | Adds a Mtext.
Public method | AddName | Adds a name of an object
Public method | AddPixel | Adds a pixel.
Public method | AddPoint | Adds a point.
Public method | AddPolyBezier | Adds the polyBezier line
Public method | AddPolyLine | Adds a polyline.
Public method | AddRectangle | Adds a rectangle.
Public method | AddSolid | Adds a solid.
Public method | AddString | Adds a string.
Public method | AddText | Adds a text.
Public method | AddThickness | Adds thickness
Public method | AddVertex | Adds a vertex.
Public method | BeginBlock | Begins a DXF block
Public method | BeginPoly | Begins a polyline
Public method | Clear | Clears the DXFExport object
 | ColorToDXF | Converts System.Drawing.Color object to the dxf color
Public method | EndBlock | Ends a DXF block
Public method | EndDraw | Ends a draw
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBlockByName | Gets DXF block by its name
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetStrAutoCADVer | Gets the AutoCAD version
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Insert | Inserts an object
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Save | Saves the DXF image
Public method | SaveToFile | Saves DXF to file
Public method | SaveToStream | Saves DXF to stream.
Public method | SetLayerByString | Sets layer by its name.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

DXFExport Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.Add3DPoint Method

Adds a 3D point.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Add3DPoint( _
   ByVal code As Integer, _
   ByVal p As DXFPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Add3DPoint(
   int code,
   DXFPoint p
)
This language is not supported or no code example is available.

Parameters

code

Type: int

A code

p

Type: DXFPoint

The 3D point to add.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.AddArc Method

Adds an arc.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddArc( _
   ByVal Data As DXFData _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddArc(
   DXFData Data
)
This language is not supported or no code example is available.

Parameters

Data

Type: DXFData

DXFData object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.AddCircle Method

Adds a circle.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddCircle( _
   ByVal Data As DXFData _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddCircle(
   DXFData Data
)
This language is not supported or no code example is available.

Parameters

Data

Type: DXFData

DXFData object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.AddColor Method

Adds a color.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddColor( _
   ByVal Data As DXFData _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddColor(
   DXFData Data
)
This language is not supported or no code example is available.

Parameters

Data

Type: DXFData

DXFData object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.AddDimension Method

Adds a dimension

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddDimension( _
   ByVal aData As DXFData _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddDimension(
   DXFData aData
)
This language is not supported or no code example is available.

Parameters

aData

Type: DXFData

DXFData object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.AddDimensionStyle Method

Adds a dimension style.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddDimensionStyle( _
   ByVal appName As String, _
   ByVal aDimStyle As DimensionStyle _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddDimensionStyle(
   string appName,
   DimensionStyle aDimStyle
)
This language is not supported or no code example is available.

Parameters

appName

Type: string

A name of the dimension style

aDimStyle

Type: DimensionStyle

The dimension style object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.AddEllipse Method

Adds an ellipse.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddEllipse( _
   ByVal Data As DXFData _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddEllipse(
   DXFData Data
)
This language is not supported or no code example is available.

Parameters

Data

Type: DXFData

DXFData object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.AddEntity Method

Adds an entity.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddEntity( _
   ByVal aEntity As DXFFigure _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddEntity(
   DXFFigure aEntity
)
This language is not supported or no code example is available.

Parameters

aEntity

Type: DXFFigure

An entity to add

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.AddFloat Method

Adds a float value.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddFloat( _
   ByVal code As Integer, _
   ByVal Value As Single _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddFloat(
   int code,
   float Value
)
This language is not supported or no code example is available.

Parameters

code

Type: int

A code

Value

Type: float

The float value to add.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.AddHandle Method

Adds a handle.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function AddHandle() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int AddHandle()
This language is not supported or no code example is available.

Return Value

The handle to add.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.AddHatch Method

Adds a hatch.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddHatch( _
   ByVal Data As DXFData _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddHatch(
   DXFData Data
)
This language is not supported or no code example is available.

Parameters

Data

Type: DXFData

DXFData object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.AddInt Method

Adds an integer value.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddInt( _
   ByVal code As Integer, _
   ByVal Value As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddInt(
   int code,
   int Value
)
This language is not supported or no code example is available.

Parameters

code

Type: int

A code

Value

Type: int

The integer value to add.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.AddLType Method

Adds a linetype.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddLType( _
   ByVal aName As String, _
   ByVal aParts As Single() _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddLType(
   string aName,
   float[] aParts
)
This language is not supported or no code example is available.

Parameters

aName

Type: string

A linetype name

aParts

Type: float[]

Linetype parts

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.AddLTypeScale Method

Adds a linetype scale.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddLTypeScale()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddLTypeScale()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.AddLine Method

Adds a line.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddLine( _
   ByVal Data As DXFData _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddLine(
   DXFData Data
)
This language is not supported or no code example is available.

Parameters

Data

Type: DXFData

DXFData object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.AddMText Method

Adds a Mtext.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddMText( _
   ByVal Data As DXFData _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddMText(
   DXFData Data
)
This language is not supported or no code example is available.

Parameters

Data

Type: DXFData

DXFData object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.AddName Method

Adds a name of an object

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function AddName( _
   ByVal aName As String, _
   ByVal aSub As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int AddName(
   string aName,
   string aSub
)
This language is not supported or no code example is available.

Parameters

aName

Type: string

A name

aSub

Type: string

A sub name

Return Value

result
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.AddPixel Method

Adds a pixel.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddPixel( _
   ByVal Data As DXFData _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddPixel(
   DXFData Data
)
This language is not supported or no code example is available.

Parameters

Data

Type: DXFData

DXFData object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.AddPoint Method

Adds a point.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddPoint( _
   ByVal code As Integer, _
   ByVal P As DXFPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddPoint(
   int code,
   DXFPoint P
)
This language is not supported or no code example is available.

Parameters

code

Type: int

A code

P

Type: DXFPoint

The point to add.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.AddPolyBezier Method

Adds the polyBezier line

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddPolyBezier( _
   ByVal Data As DXFData, _
   ByVal aIndex As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddPolyBezier(
   DXFData Data,
   int aIndex
)
This language is not supported or no code example is available.

Parameters

Data

Type: DXFData

DXFData object

aIndex

Type: int

An index

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.AddPolyLine Method

Adds a polyline.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddPolyLine( _
   ByVal Data As DXFData, _
   ByVal aIndex As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddPolyLine(
   DXFData Data,
   int aIndex
)
This language is not supported or no code example is available.

Parameters

Data

Type: DXFData

DXFData object

aIndex

Type: int

An index

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.AddRectangle Method

Adds a rectangle.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddRectangle( _
   ByVal Data As DXFData _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddRectangle(
   DXFData Data
)
This language is not supported or no code example is available.

Parameters

Data

Type: DXFData

DXFData object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.AddSolid Method

Adds a solid.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddSolid( _
   ByVal Data As DXFData _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddSolid(
   DXFData Data
)
This language is not supported or no code example is available.

Parameters

Data

Type: DXFData

DXFData object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.AddString Method

Adds a string.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddString( _
   ByVal code As Integer, _
   ByVal str As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddString(
   int code,
   string str
)
This language is not supported or no code example is available.

Parameters

code

Type: int

A code

str

Type: string

The string to add.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.AddText Method

Adds a text.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddText( _
   ByVal Data As DXFData _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddText(
   DXFData Data
)
This language is not supported or no code example is available.

Parameters

Data

Type: DXFData

DXFData object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.AddThickness Method

Adds thickness

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddThickness( _
   ByVal Data As DXFData _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddThickness(
   DXFData Data
)
This language is not supported or no code example is available.

Parameters

Data

Type: DXFData

DXFData object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.AddVertex Method

Adds a vertex.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddVertex( _
   ByVal P As DXFPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddVertex(
   DXFPoint P
)
This language is not supported or no code example is available.

Parameters

P

Type: DXFPoint

The point of a vertex.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.BeginBlock Method

Begins a DXF block

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub BeginBlock( _
   ByVal aName As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void BeginBlock(
   string aName
)
This language is not supported or no code example is available.

Parameters

aName

Type: string

A block name.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.BeginPoly Method

Begins a polyline

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub BeginPoly( _
   ByVal Data As DXFData, _
   ByVal aCount As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void BeginPoly(
   DXFData Data,
   int aCount
)
This language is not supported or no code example is available.

Parameters

Data

Type: DXFData

DXFData object

aCount

Type: int

A count.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.Clear Method

Clears the DXFExport object

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Clear()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Clear()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.ColorToDXF Method

Converts System.Drawing.Color object to the dxf color

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function ColorToDXF( _
   ByVal Value As Color _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static int ColorToDXF(
   Color Value
)
This language is not supported or no code example is available.

Parameters

Value

Type: Color

System.Drawing.Color object

Return Value

The DXF color
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.EndBlock Method

Ends a DXF block

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub EndBlock()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void EndBlock()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.EndDraw Method

Ends a draw

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub EndDraw()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void EndDraw()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.GetBlockByName Method

Gets DXF block by its name

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetBlockByName( _
   ByVal AName As String _
) As DXFBlock
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFBlock GetBlockByName(
   string AName
)
This language is not supported or no code example is available.

Parameters

AName

Type: string

A name of a block.

Return Value

The DXF block.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.GetStrAutoCADVer Method

Gets the AutoCAD version

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetStrAutoCADVer() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string GetStrAutoCADVer()
This language is not supported or no code example is available.

Return Value

The AutoCAD version
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.Insert Method

Inserts an object

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Insert( _
   ByVal aData As DXFData _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Insert(
   DXFData aData
)
This language is not supported or no code example is available.

Parameters

aData

Type: DXFData

DXFData object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.Save Method

Saves the DXF image

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Save() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Save()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.SaveToFile Method

Saves DXF to file

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function SaveToFile( _
   ByVal fileName As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool SaveToFile(
   string fileName
)
This language is not supported or no code example is available.

Parameters

fileName

Type: string

A file name

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.SaveToStream Method

Saves DXF to stream.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SaveToStream( _
   ByVal St As StringWriter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SaveToStream(
   StringWriter St
)
This language is not supported or no code example is available.

Parameters

St

Type: StringWriter

StringWriter object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport.SetLayerByString Method

Sets layer by its name.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetLayerByString( _
   ByVal aName As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetLayerByString(
   string aName
)
This language is not supported or no code example is available.

Parameters

aName

Type: string

A layer name.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFExport Fields

DXFExport Class See Also

The following tables list the members exposed by the DXFExport type.

Fields
 | Name | Description
 | DXFLineWeights | The array of the line weight constants.
 | accuracy | The maximal accuracy. Default = 0.000001.
 | alternativeBlack | Specifies if the alternative black color will be used.
 | autoCADVer | Represents the current AutoCAD version.
Public field | current | For internal use.
Public field | fOffset | Represents an offset for hatch object.
 | isParseWhite | Specifies if white rectangle object will be used as erasing region.
 | offsetX | Represents offsets on axis x and on axis y.
 | offsetY | Represents offsets on axis x and on axis y.
 | use01MM | Use of factor of scaling.
Top
See Also

Reference

DXFExport Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFLineWeights Field

The array of the line weight constants.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared DXFLineWeights As Integer()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static int[] DXFLineWeights
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


accuracy Field

The maximal accuracy. Default = 0.000001.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared accuracy As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static float accuracy
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


alternativeBlack Field

Specifies if the alternative black color will be used.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared alternativeBlack As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool alternativeBlack
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


autoCADVer Field

Represents the current AutoCAD version.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared autoCADVer As AutoCADVersion
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static AutoCADVersion autoCADVer
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


current Field

For internal use.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shadows current As ArrayList
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
new public ArrayList current
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


fOffset Field

Represents an offset for hatch object.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public fOffset As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float fOffset
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


isParseWhite Field

Specifies if white rectangle object will be used as erasing region.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared isParseWhite As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool isParseWhite
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


offsetX Field

Represents offsets on axis x and on axis y.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared offsetX As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static float offsetX
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


offsetY Field

Represents offsets on axis x and on axis y.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared offsetY As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static float offsetY
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


use01MM Field

Use of factor of scaling.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared use01MM As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool use01MM
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFExport Class
DXFExport Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFFigure Class

Members See Also

This is a base class of figures.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class DXFFigure
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class DXFFigure
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Export.SimpleCADtoDXF.DXFFigure
CADImport.Export.SimpleCADtoDXF.DXFArc
CADImport.Export.SimpleCADtoDXF.DXFDimension
CADImport.Export.SimpleCADtoDXF.DXFEllipse
CADImport.Export.SimpleCADtoDXF.DXFHatch
CADImport.Export.SimpleCADtoDXF.DXFLayer
CADImport.Export.SimpleCADtoDXF.DXFLine
CADImport.Export.SimpleCADtoDXF.DXFMText
CADImport.Export.SimpleCADtoDXF.DXFPixel
CADImport.Export.SimpleCADtoDXF.DXFPolyline
CADImport.Export.SimpleCADtoDXF.DXFRectangle
CADImport.Export.SimpleCADtoDXF.DXFSolid
CADImport.Export.SimpleCADtoDXF.DXFText
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFFigure Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFFigure Members

DXFFigure Class Constructors Methods Fields Properties See Also

This is a base class of figures.

The following tables list the members exposed by the DXFFigure type.

Constructors
 | Name | Description
Public constructor | DXFFigure | (Overloaded) Initializes a new instance of the DXFFigure object.
Top
Properties
 | Name | Description
Public property | Color | Gets or sets a color for this figure.
Public property | Layer | Gets or sets the current layer for this figure.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportAsDXF | Virtual function. For redifinition in descendant classes.
Public method | ExportBlockAsDXF | Virtual function. For redifinition in descendant classes.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ParseToLines | Performs figure approximation by linear segments.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | data | Represents all data (DXFData) of a figure.
Top
See Also

Reference

DXFFigure Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFFigure Constructor

DXFFigure Class See Also

Initializes a new instance of the DXFFigure object.

Overload List
Name | Description
DXFFigure() | Initializes a new instance of the DXFFigure object.
DXFFigure(DXFData) | Initializes a new instance of the DXFFigure object that have field data copied from specified object.
See Also

Reference

DXFFigure Class
DXFFigure Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFFigure Properties

DXFFigure Class See Also

The following tables list the members exposed by the DXFFigure type.

Properties
 | Name | Description
Public property | Color | Gets or sets a color for this figure.
Public property | Layer | Gets or sets the current layer for this figure.
Top
See Also

Reference

DXFFigure Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFFigure Methods

DXFFigure Class See Also

The following tables list the members exposed by the DXFFigure type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportAsDXF | Virtual function. For redifinition in descendant classes.
Public method | ExportBlockAsDXF | Virtual function. For redifinition in descendant classes.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ParseToLines | Performs figure approximation by linear segments.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

DXFFigure Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFFigure.ExportAsDXF Method

Virtual function. For redifinition in descendant classes.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub ExportAsDXF( _
   ByVal ADXFExport As DXFExport _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void ExportAsDXF(
   DXFExport ADXFExport
)
This language is not supported or no code example is available.

Parameters

ADXFExport

Type: DXFExport

DXFExport object.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFFigure Class
DXFFigure Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFFigure Fields

DXFFigure Class See Also

The following tables list the members exposed by the DXFFigure type.

Fields
 | Name | Description
Public field | data | Represents all data (DXFData) of a figure.
Top
See Also

Reference

DXFFigure Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFHatch Class

Members See Also

Represents a hatch in a DXF image.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class DXFHatch
    Inherits DXFFigure
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class DXFHatch : DXFFigure
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Export.SimpleCADtoDXF.DXFFigure
CADImport.Export.SimpleCADtoDXF.DXFHatch
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFHatch Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFHatch Members

DXFHatch Class Constructors Methods Fields Properties See Also

Represents a hatch in a DXF image.

The following tables list the members exposed by the DXFHatch type.

Constructors
 | Name | Description
Public constructor | DXFHatch | (Overloaded) Initializes a new instance of the DXFHatch class.
Top
Properties
 | Name | Description
Public property | BndAmount | Gets the boundaries count of a hatch.
Public property | Color | Gets or sets a color for this figure. (inherited from DXFFigure).
Public property | Layer | Gets or sets the current layer for this figure. (inherited from DXFFigure).
Public property | PatternName | Gets or sets a name of a pattern object.
Public property | Style | Gets a types style of a hatch.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportAsDXF | Adds a hatch to the DXFExport figures collection.
Public method | ExportBlockAsDXF | Virtual function. For redifinition in descendant classes. (inherited from DXFFigure).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetPoint | Returns the specified point from the specified collection of points of a hatch.
Public method | GetPointsNumber | Returns a count of points of a hatch in the specified number of a collection.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ParseToLines | Performs figure approximation by linear segments. (inherited from DXFFigure).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | data | Represents all data (DXFData) of a figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFHatch Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFHatch Constructor

DXFHatch Class See Also

Initializes a new instance of the DXFHatch class.

Overload List
Name | Description
DXFHatch() | Initializes a new instance of the DXFHatch class.
DXFHatch(DXFData) | Initializes a new instance of the DXFHatch class that have field data copied from specified object.
See Also

Reference

DXFHatch Class
DXFHatch Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFHatch Properties

DXFHatch Class See Also

The following tables list the members exposed by the DXFHatch type.

Properties
 | Name | Description
Public property | BndAmount | Gets the boundaries count of a hatch.
Public property | Color | Gets or sets a color for this figure. (inherited from DXFFigure).
Public property | Layer | Gets or sets the current layer for this figure. (inherited from DXFFigure).
Public property | PatternName | Gets or sets a name of a pattern object.
Public property | Style | Gets a types style of a hatch.
Top
See Also

Reference

DXFHatch Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFHatch.BndAmount Property

Gets the boundaries count of a hatch.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property BndAmount() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int BndAmount {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFHatch Class
DXFHatch Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFHatch.PatternName Property

Gets or sets a name of a pattern object.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PatternName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string PatternName {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFHatch Class
DXFHatch Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFHatch.Style Property

Gets a types style of a hatch.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Style() As HatchStyle
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public HatchStyle Style {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFHatch Class
DXFHatch Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFHatch Methods

DXFHatch Class See Also

The following tables list the members exposed by the DXFHatch type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportAsDXF | Adds a hatch to the DXFExport figures collection.
Public method | ExportBlockAsDXF | Virtual function. For redifinition in descendant classes. (inherited from DXFFigure).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetPoint | Returns the specified point from the specified collection of points of a hatch.
Public method | GetPointsNumber | Returns a count of points of a hatch in the specified number of a collection.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ParseToLines | Performs figure approximation by linear segments. (inherited from DXFFigure).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

DXFHatch Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFHatch.ExportAsDXF Method

Adds a hatch to the DXFExport figures collection.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub ExportAsDXF( _
   ByVal ADXFExport As DXFExport _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void ExportAsDXF(
   DXFExport ADXFExport
)
This language is not supported or no code example is available.

Parameters

ADXFExport

Type: DXFExport

DXFExport object.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFHatch Class
DXFHatch Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFHatch.GetPoint Method

Returns the specified point from the specified collection of points of a hatch.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetPoint( _
   ByVal bndIndex As Integer, _
   ByVal aIndex As Integer _
) As DXFPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFPoint GetPoint(
   int bndIndex,
   int aIndex
)
This language is not supported or no code example is available.

Parameters

bndIndex

Type: int

An index of a points collection.

aIndex

Type: int

An index of a point.

Return Value

A point
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFHatch Class
DXFHatch Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFHatch.GetPointsNumber Method

Returns a count of points of a hatch in the specified number of a collection.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetPointsNumber( _
   ByVal bndIndex As Integer _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int GetPointsNumber(
   int bndIndex
)
This language is not supported or no code example is available.

Parameters

bndIndex

Type: int

An index of a points collection.

Return Value

A number of points
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFHatch Class
DXFHatch Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFHatch Fields

DXFHatch Class See Also

The following tables list the members exposed by the DXFHatch type.

Fields
 | Name | Description
Public field | data | Represents all data (DXFData) of a figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFHatch Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFLayer Class

Members See Also

Represents a layer in a DXF image.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class DXFLayer
    Inherits DXFFigure
    Implements ICloneable
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class DXFLayer : DXFFigure,
   ICloneable
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Export.SimpleCADtoDXF.DXFFigure
CADImport.Export.SimpleCADtoDXF.DXFLayer
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFLayer Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFLayer Members

DXFLayer Class Constructors Methods Fields Properties See Also

Represents a layer in a DXF image.

The following tables list the members exposed by the DXFLayer type.

Constructors
 | Name | Description
Public constructor | DXFLayer | (Overloaded) Initializes a new instance of the DXFLayer class.
Top
Properties
 | Name | Description
Public property | Color | Gets or sets a color for this figure. (inherited from DXFFigure).
Public property | DXFColor | Gets or sets a color of a layer.
Public property | Flags | Gets or sets a byte that contains flags for the DXFLayer object.
Public property | Handle | Gets or sets a handle of a layer.
Public property | HardPointer | Gets or sets HardPointer ID/handle
Public property | Layer | Gets or sets the current layer for this figure. (inherited from DXFFigure).
Public property | LineWeight | Gets or sets a line thickness for this layer.
Public property | LinetypeName | Gets or sets a name of a line type for this layer.
Public property | Name | Gets or sets a name of a layer.
Public property | PlottingFlag | Gets or sets flag for plotting.
Top
Methods
 | Name | Description
Public method | Clone | Copies this object and returns the new object.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportAsDXF | Adds a layer to the DXFExport figures collection.
Public method | ExportBlockAsDXF | Virtual function. For redifinition in descendant classes. (inherited from DXFFigure).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ParseToLines | Performs figure approximation by linear segments. (inherited from DXFFigure).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | data | Represents all data (DXFData) of a figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFLayer Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFLayer Constructor

DXFLayer Class See Also

Initializes a new instance of the DXFLayer class.

Overload List
Name | Description
DXFLayer() | Initializes a new instance of the DXFLayer class.
DXFLayer(string) | Initializes a new instance of the DXFLayer class with specified name and defaults parameters.
See Also

Reference

DXFLayer Class
DXFLayer Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFLayer Properties

DXFLayer Class See Also

The following tables list the members exposed by the DXFLayer type.

Properties
 | Name | Description
Public property | Color | Gets or sets a color for this figure. (inherited from DXFFigure).
Public property | DXFColor | Gets or sets a color of a layer.
Public property | Flags | Gets or sets a byte that contains flags for the DXFLayer object.
Public property | Handle | Gets or sets a handle of a layer.
Public property | HardPointer | Gets or sets HardPointer ID/handle
Public property | Layer | Gets or sets the current layer for this figure. (inherited from DXFFigure).
Public property | LineWeight | Gets or sets a line thickness for this layer.
Public property | LinetypeName | Gets or sets a name of a line type for this layer.
Public property | Name | Gets or sets a name of a layer.
Public property | PlottingFlag | Gets or sets flag for plotting.
Top
See Also

Reference

DXFLayer Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFLayer.DXFColor Property

Gets or sets a color of a layer.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DXFColor() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int DXFColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFLayer Class
DXFLayer Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFLayer.Flags Property

Gets or sets a byte that contains flags for the DXFLayer object.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Flags() As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte Flags {get; set;}
This language is not supported or no code example is available.
Remarks

bit-coded values:

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFLayer Class
DXFLayer Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFLayer.Handle Property

Gets or sets a handle of a layer.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Handle() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Handle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFLayer Class
DXFLayer Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFLayer.HardPointer Property

Gets or sets HardPointer ID/handle

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property HardPointer() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string HardPointer {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFLayer Class
DXFLayer Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFLayer.LineWeight Property

Gets or sets a line thickness for this layer.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LineWeight() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int LineWeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFLayer Class
DXFLayer Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFLayer.LinetypeName Property

Gets or sets a name of a line type for this layer.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LinetypeName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string LinetypeName {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFLayer Class
DXFLayer Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFLayer.Name Property

Gets or sets a name of a layer.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Name() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Name {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFLayer Class
DXFLayer Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFLayer.PlottingFlag Property

Gets or sets flag for plotting.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PlottingFlag() As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte PlottingFlag {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFLayer Class
DXFLayer Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFLayer Methods

DXFLayer Class See Also

The following tables list the members exposed by the DXFLayer type.

Methods
 | Name | Description
Public method | Clone | Copies this object and returns the new object.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportAsDXF | Adds a layer to the DXFExport figures collection.
Public method | ExportBlockAsDXF | Virtual function. For redifinition in descendant classes. (inherited from DXFFigure).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ParseToLines | Performs figure approximation by linear segments. (inherited from DXFFigure).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

DXFLayer Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFLayer.Clone Method

Copies this object and returns the new object.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Clone() As Object Implements  _
   ICloneable.Clone
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public object Clone()
This language is not supported or no code example is available.

Return Value

The new layer object

Implements

ICloneable.Clone
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFLayer Class
DXFLayer Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFLayer.ExportAsDXF Method

Adds a layer to the DXFExport figures collection.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub ExportAsDXF( _
   ByVal ADXFExport As DXFExport _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void ExportAsDXF(
   DXFExport ADXFExport
)
This language is not supported or no code example is available.

Parameters

ADXFExport

Type: DXFExport

DXFExport object.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFLayer Class
DXFLayer Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFLayer Fields

DXFLayer Class See Also

The following tables list the members exposed by the DXFLayer type.

Fields
 | Name | Description
Public field | data | Represents all data (DXFData) of a figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFLayer Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFLine Class

Members See Also

Represents a line in a DXF image.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class DXFLine
    Inherits DXFFigure
    Implements ICloneable
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class DXFLine : DXFFigure,
   ICloneable
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Export.SimpleCADtoDXF.DXFFigure
CADImport.Export.SimpleCADtoDXF.DXFLine
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFLine Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFLine Members

DXFLine Class Constructors Methods Fields Properties See Also

Represents a line in a DXF image.

The following tables list the members exposed by the DXFLine type.

Constructors
 | Name | Description
Public constructor | DXFLine | (Overloaded) Initializes a new instance of the DXFLine class.
Top
Properties
 | Name | Description
Public property | Color | Gets or sets a color for this figure. (inherited from DXFFigure).
Public property | EndPoint | Gets or sets the end point of a line object
Public property | Layer | Gets or sets the current layer for this figure. (inherited from DXFFigure).
Public property | StartPoint | Gets or sets the start point of a line object
Top
Methods
 | Name | Description
Public method | Clone | Copies this object and returns the new object.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportAsDXF | Adds a line to the DXFExport figures collection.
Public method | ExportBlockAsDXF | Virtual function. For redifinition in descendant classes. (inherited from DXFFigure).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ParseToLines | Performs figure approximation by linear segments. (inherited from DXFFigure).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | data | Represents all data (DXFData) of a figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFLine Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFLine Constructor

DXFLine Class See Also

Initializes a new instance of the DXFLine class.

Overload List
Name | Description
DXFLine() | Initializes a new instance of the DXFLine class.
DXFLine(DXFData) | Initializes a new instance of the DXFLine class that have field data copied from specified object.
See Also

Reference

DXFLine Class
DXFLine Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFLine Properties

DXFLine Class See Also

The following tables list the members exposed by the DXFLine type.

Properties
 | Name | Description
Public property | Color | Gets or sets a color for this figure. (inherited from DXFFigure).
Public property | EndPoint | Gets or sets the end point of a line object
Public property | Layer | Gets or sets the current layer for this figure. (inherited from DXFFigure).
Public property | StartPoint | Gets or sets the start point of a line object
Top
See Also

Reference

DXFLine Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFLine.EndPoint Property

Gets or sets the end point of a line object

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property EndPoint() As DXFPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFPoint EndPoint {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFLine Class
DXFLine Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFLine.StartPoint Property

Gets or sets the start point of a line object

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property StartPoint() As DXFPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFPoint StartPoint {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFLine Class
DXFLine Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFLine Methods

DXFLine Class See Also

The following tables list the members exposed by the DXFLine type.

Methods
 | Name | Description
Public method | Clone | Copies this object and returns the new object.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportAsDXF | Adds a line to the DXFExport figures collection.
Public method | ExportBlockAsDXF | Virtual function. For redifinition in descendant classes. (inherited from DXFFigure).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ParseToLines | Performs figure approximation by linear segments. (inherited from DXFFigure).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

DXFLine Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFLine.Clone Method

Copies this object and returns the new object.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Clone() As Object Implements  _
   ICloneable.Clone
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public object Clone()
This language is not supported or no code example is available.

Return Value

The new line object

Implements

ICloneable.Clone
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFLine Class
DXFLine Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFLine.ExportAsDXF Method

Adds a line to the DXFExport figures collection.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub ExportAsDXF( _
   ByVal ADXFExport As DXFExport _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void ExportAsDXF(
   DXFExport ADXFExport
)
This language is not supported or no code example is available.

Parameters

ADXFExport

Type: DXFExport

DXFExport object.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFLine Class
DXFLine Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFLine Fields

DXFLine Class See Also

The following tables list the members exposed by the DXFLine type.

Fields
 | Name | Description
Public field | data | Represents all data (DXFData) of a figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFLine Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFMText Class

Members See Also

DXF metric text class.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class DXFMText
    Inherits DXFFigure
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class DXFMText : DXFFigure
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Export.SimpleCADtoDXF.DXFFigure
CADImport.Export.SimpleCADtoDXF.DXFMText
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFMText Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFMText Members

DXFMText Class Constructors Methods Fields Properties See Also

DXF metric text class.

The following tables list the members exposed by the DXFMText type.

Constructors
 | Name | Description
Public constructor | DXFMText | (Overloaded) Initializes a new instance of the DXFMText class.
Top
Properties
 | Name | Description
Public property | Color | Gets or sets a color for this figure. (inherited from DXFFigure).
Public property | Layer | Gets or sets the current layer for this figure. (inherited from DXFFigure).
Public property | Text | Gets or sets text contents of DXFMText object.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportAsDXF | Adds a mtext to DXFExport figures collection.
Public method | ExportBlockAsDXF | Virtual function. For redifinition in descendant classes. (inherited from DXFFigure).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ParseToLines | Performs figure approximation by linear segments. (inherited from DXFFigure).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | data | Represents all data (DXFData) of a figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFMText Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFMText Constructor

DXFMText Class See Also

Initializes a new instance of the DXFMText class.

Overload List
Name | Description
DXFMText() | Initializes a new instance of the DXFMText class.
DXFMText(DXFData) | Initializes a new instance of the DXFMText class that have field data copied from specified object.
See Also

Reference

DXFMText Class
DXFMText Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFMText Properties

DXFMText Class See Also

The following tables list the members exposed by the DXFMText type.

Properties
 | Name | Description
Public property | Color | Gets or sets a color for this figure. (inherited from DXFFigure).
Public property | Layer | Gets or sets the current layer for this figure. (inherited from DXFFigure).
Public property | Text | Gets or sets text contents of DXFMText object.
Top
See Also

Reference

DXFMText Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFMText.Text Property

Gets or sets text contents of DXFMText object.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Text() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Text {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFMText Class
DXFMText Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFMText Methods

DXFMText Class See Also

The following tables list the members exposed by the DXFMText type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportAsDXF | Adds a mtext to DXFExport figures collection.
Public method | ExportBlockAsDXF | Virtual function. For redifinition in descendant classes. (inherited from DXFFigure).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ParseToLines | Performs figure approximation by linear segments. (inherited from DXFFigure).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

DXFMText Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFMText.ExportAsDXF Method

Adds a mtext to DXFExport figures collection.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub ExportAsDXF( _
   ByVal ADXFExport As DXFExport _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void ExportAsDXF(
   DXFExport ADXFExport
)
This language is not supported or no code example is available.

Parameters

ADXFExport

Type: DXFExport

DXFExport object.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFMText Class
DXFMText Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFMText Fields

DXFMText Class See Also

The following tables list the members exposed by the DXFMText type.

Fields
 | Name | Description
Public field | data | Represents all data (DXFData) of a figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFMText Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFPixel Class

Members See Also

Represents a pixel in a DXF image.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class DXFPixel
    Inherits DXFFigure
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class DXFPixel : DXFFigure
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Export.SimpleCADtoDXF.DXFFigure
CADImport.Export.SimpleCADtoDXF.DXFPixel
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFPixel Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFPixel Members

DXFPixel Class Constructors Methods Fields Properties See Also

Represents a pixel in a DXF image.

The following tables list the members exposed by the DXFPixel type.

Constructors
 | Name | Description
Public constructor | DXFPixel | (Overloaded) Initializes a new instance of the DXFPixel class.
Top
Properties
 | Name | Description
Public property | Color | Gets or sets a color for this figure. (inherited from DXFFigure).
Public property | Layer | Gets or sets the current layer for this figure. (inherited from DXFFigure).
Public property | Point | Gets or sets coordinates of the dxf pixel.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportAsDXF | Adds a pixel to the DXFExport figures collection.
Public method | ExportBlockAsDXF | Virtual function. For redifinition in descendant classes. (inherited from DXFFigure).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ParseToLines | Performs figure approximation by linear segments. (inherited from DXFFigure).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | data | Represents all data (DXFData) of a figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFPixel Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFPixel Constructor

DXFPixel Class See Also

Initializes a new instance of the DXFPixel class.

Overload List
Name | Description
DXFPixel() | Initializes a new instance of the DXFPixel class.
DXFPixel(DXFData) | Initializes a new instance of the DXFPixel class that have field data copied from specified object.
See Also

Reference

DXFPixel Class
DXFPixel Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFPixel Properties

DXFPixel Class See Also

The following tables list the members exposed by the DXFPixel type.

Properties
 | Name | Description
Public property | Color | Gets or sets a color for this figure. (inherited from DXFFigure).
Public property | Layer | Gets or sets the current layer for this figure. (inherited from DXFFigure).
Public property | Point | Gets or sets coordinates of the dxf pixel.
Top
See Also

Reference

DXFPixel Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFPixel.Point Property

Gets or sets coordinates of the dxf pixel.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Point() As DXFPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFPoint Point {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFPixel Class
DXFPixel Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFPixel Methods

DXFPixel Class See Also

The following tables list the members exposed by the DXFPixel type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportAsDXF | Adds a pixel to the DXFExport figures collection.
Public method | ExportBlockAsDXF | Virtual function. For redifinition in descendant classes. (inherited from DXFFigure).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ParseToLines | Performs figure approximation by linear segments. (inherited from DXFFigure).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

DXFPixel Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFPixel.ExportAsDXF Method

Adds a pixel to the DXFExport figures collection.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub ExportAsDXF( _
   ByVal ADXFExport As DXFExport _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void ExportAsDXF(
   DXFExport ADXFExport
)
This language is not supported or no code example is available.

Parameters

ADXFExport

Type: DXFExport

DXFExport object.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFPixel Class
DXFPixel Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFPixel Fields

DXFPixel Class See Also

The following tables list the members exposed by the DXFPixel type.

Fields
 | Name | Description
Public field | data | Represents all data (DXFData) of a figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFPixel Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFPoint Class

Members See Also

Represents a 3D point in a DXF image.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class DXFPoint
    Implements ICloneable
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class DXFPoint : ICloneable
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Export.SimpleCADtoDXF.DXFPoint
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFPoint Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFPoint Members

DXFPoint Class Constructors Methods Fields See Also

Represents a 3D point in a DXF image.

The following tables list the members exposed by the DXFPoint type.

Constructors
 | Name | Description
Public constructor | DXFPoint | (Overloaded) Initializes a new instance of the DXFPixel class.
Top
Methods
 | Name | Description
Public method | Clone | Copies this object and returns a new object.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | X | Coordinates of a 3D point in DXF image.
Public field | Y | Coordinates of a 3D point in DXF image.
Public field | Z | Coordinates of a 3D point in DXF image.
Top
See Also

Reference

DXFPoint Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFPoint Constructor

DXFPoint Class See Also

Initializes a new instance of the DXFPixel class.

Overload List
Name | Description
DXFPoint() | Initializes a new instance of the DXFPixel class.
DXFPoint(DXFPoint) | Initializes a new instance of the DXFPixel class that have field data copied from specified object.
DXFPoint(float, float, float) | Initializes a new instance of the DXFPixel class with the specified values.
See Also

Reference

DXFPoint Class
DXFPoint Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFPoint Methods

DXFPoint Class See Also

The following tables list the members exposed by the DXFPoint type.

Methods
 | Name | Description
Public method | Clone | Copies this object and returns a new object.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

DXFPoint Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFPoint.Clone Method

Copies this object and returns a new object.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Clone() As Object Implements  _
   ICloneable.Clone
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public object Clone()
This language is not supported or no code example is available.

Implements

ICloneable.Clone
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFPoint Class
DXFPoint Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFPoint Fields

DXFPoint Class See Also

The following tables list the members exposed by the DXFPoint type.

Fields
 | Name | Description
Public field | X | Coordinates of a 3D point in DXF image.
Public field | Y | Coordinates of a 3D point in DXF image.
Public field | Z | Coordinates of a 3D point in DXF image.
Top
See Also

Reference

DXFPoint Class
CADImport.Export.SimpleCADtoDXF Namespace


X Field

Coordinates of a 3D point in DXF image.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public X As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float X
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFPoint Class
DXFPoint Members
CADImport.Export.SimpleCADtoDXF Namespace


Y Field

Coordinates of a 3D point in DXF image.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Y As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float Y
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFPoint Class
DXFPoint Members
CADImport.Export.SimpleCADtoDXF Namespace


Z Field

Coordinates of a 3D point in DXF image.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Z As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float Z
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFPoint Class
DXFPoint Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFPolyBezier Class

Members See Also

Represents the polybezier line in a DXF image.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class DXFPolyBezier
    Inherits DXFPolyline
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class DXFPolyBezier : DXFPolyline
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Export.SimpleCADtoDXF.DXFFigure
CADImport.Export.SimpleCADtoDXF.DXFPolyline
CADImport.Export.SimpleCADtoDXF.DXFPolyBezier
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFPolyBezier Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFPolyBezier Members

DXFPolyBezier Class Constructors Methods Fields Properties See Also

Represents the polybezier line in a DXF image.

The following tables list the members exposed by the DXFPolyBezier type.

Constructors
 | Name | Description
Public constructor | DXFPolyBezier | (Overloaded) Initializes a new instance of the DXFPolyBezier class.
Top
Properties
 | Name | Description
Public property | Color | Gets or sets a color for this figure. (inherited from DXFFigure).
Public property | Layer | Gets or sets the current layer for this figure. (inherited from DXFFigure).
Public property | PointCount | Gets a number of polyline points. (inherited from DXFPolyline).
Public property | Points | Gets or sets a collection of the polyline points. (inherited from DXFPolyline).
Top
Methods
 | Name | Description
Public method | Clear | Clears the polyline points collection. (inherited from DXFPolyline).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportAsDXF | Adds a polybezier line to the DXFExport figures collection.
Public method | ExportBlockAsDXF | Virtual function. For redifinition in descendant classes. (inherited from DXFFigure).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ParseToLines | Performs figure approximation by linear segments. (inherited from DXFPolyline).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | data | Represents all data (DXFData) of a figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFPolyBezier Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFPolyBezier Constructor

DXFPolyBezier Class See Also

Initializes a new instance of the DXFPolyBezier class.

Overload List
Name | Description
DXFPolyBezier() | Initializes a new instance of the DXFPolyBezier class.
DXFPolyBezier(DXFData, int) | Initializes a new instance of the DXFPolyBezier class that have field data copied from specified object.
See Also

Reference

DXFPolyBezier Class
DXFPolyBezier Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFPolyBezier Properties

DXFPolyBezier Class See Also

The following tables list the members exposed by the DXFPolyBezier type.

Properties
 | Name | Description
Public property | Color | Gets or sets a color for this figure. (inherited from DXFFigure).
Public property | Layer | Gets or sets the current layer for this figure. (inherited from DXFFigure).
Public property | PointCount | Gets a number of polyline points. (inherited from DXFPolyline).
Public property | Points | Gets or sets a collection of the polyline points. (inherited from DXFPolyline).
Top
See Also

Reference

DXFPolyBezier Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFPolyline.PointCount Property

Gets a number of polyline points.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property PointCount() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int PointCount {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFPolyline Class
DXFPolyline Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFPolyline.Points Property

Gets or sets a collection of the polyline points.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Points() As ArrayList
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ArrayList Points {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFPolyline Class
DXFPolyline Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFPolyBezier Methods

DXFPolyBezier Class See Also

The following tables list the members exposed by the DXFPolyBezier type.

Methods
 | Name | Description
Public method | Clear | Clears the polyline points collection. (inherited from DXFPolyline).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportAsDXF | Adds a polybezier line to the DXFExport figures collection.
Public method | ExportBlockAsDXF | Virtual function. For redifinition in descendant classes. (inherited from DXFFigure).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ParseToLines | Performs figure approximation by linear segments. (inherited from DXFPolyline).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

DXFPolyBezier Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFPolyline.Clear Method

Clears the polyline points collection.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Clear()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Clear()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFPolyline Class
DXFPolyline Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFPolyBezier.ExportAsDXF Method

Adds a polybezier line to the DXFExport figures collection.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub ExportAsDXF( _
   ByVal ADXFExport As DXFExport _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void ExportAsDXF(
   DXFExport ADXFExport
)
This language is not supported or no code example is available.

Parameters

ADXFExport

Type: DXFExport

DXFExport object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFPolyBezier Class
DXFPolyBezier Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFPolyline.ParseToLines Method

Performs figure approximation by linear segments.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub ParseToLines( _
   ByVal NewElemes As ArrayList _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void ParseToLines(
   ArrayList NewElemes
)
This language is not supported or no code example is available.

Parameters

NewElemes

Type: ArrayList

An array of points that will receive approximation results.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFPolyline Class
DXFPolyline Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFPolyBezier Fields

DXFPolyBezier Class See Also

The following tables list the members exposed by the DXFPolyBezier type.

Fields
 | Name | Description
Public field | data | Represents all data (DXFData) of a figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFPolyBezier Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFPolyline Class

Members See Also

Represents a polyline in a DXF image.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class DXFPolyline
    Inherits DXFFigure
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class DXFPolyline : DXFFigure
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Export.SimpleCADtoDXF.DXFFigure
CADImport.Export.SimpleCADtoDXF.DXFPolyline
CADImport.Export.SimpleCADtoDXF.DXFPolyBezier
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFPolyline Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFPolyline Members

DXFPolyline Class Constructors Methods Fields Properties See Also

Represents a polyline in a DXF image.

The following tables list the members exposed by the DXFPolyline type.

Constructors
 | Name | Description
Public constructor | DXFPolyline | (Overloaded) Initializes a new instance of the DXFPolyBezier class.
Top
Properties
 | Name | Description
Public property | Color | Gets or sets a color for this figure. (inherited from DXFFigure).
Public property | Layer | Gets or sets the current layer for this figure. (inherited from DXFFigure).
Public property | PointCount | Gets a number of polyline points.
Public property | Points | Gets or sets a collection of the polyline points.
Top
Methods
 | Name | Description
Public method | Clear | Clears the polyline points collection.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportAsDXF | Adds a polyline to the DXFExport figures collection.
Public method | ExportBlockAsDXF | Virtual function. For redifinition in descendant classes. (inherited from DXFFigure).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ParseToLines | Performs figure approximation by linear segments.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | data | Represents all data (DXFData) of a figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFPolyline Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFPolyline Constructor

DXFPolyline Class See Also

Initializes a new instance of the DXFPolyBezier class.

Overload List
Name | Description
DXFPolyline() | Initializes a new instance of the DXFPolyBezier class.
DXFPolyline(DXFData, int) | Initializes a new instance of the DXFPolyBezier class that have field data copied from specified object.
See Also

Reference

DXFPolyline Class
DXFPolyline Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFPolyline Properties

DXFPolyline Class See Also

The following tables list the members exposed by the DXFPolyline type.

Properties
 | Name | Description
Public property | Color | Gets or sets a color for this figure. (inherited from DXFFigure).
Public property | Layer | Gets or sets the current layer for this figure. (inherited from DXFFigure).
Public property | PointCount | Gets a number of polyline points.
Public property | Points | Gets or sets a collection of the polyline points.
Top
See Also

Reference

DXFPolyline Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFPolyline Methods

DXFPolyline Class See Also

The following tables list the members exposed by the DXFPolyline type.

Methods
 | Name | Description
Public method | Clear | Clears the polyline points collection.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportAsDXF | Adds a polyline to the DXFExport figures collection.
Public method | ExportBlockAsDXF | Virtual function. For redifinition in descendant classes. (inherited from DXFFigure).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ParseToLines | Performs figure approximation by linear segments.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

DXFPolyline Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFPolyline.ExportAsDXF Method

Adds a polyline to the DXFExport figures collection.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub ExportAsDXF( _
   ByVal ADXFExport As DXFExport _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void ExportAsDXF(
   DXFExport ADXFExport
)
This language is not supported or no code example is available.

Parameters

ADXFExport

Type: DXFExport

DXFExport object.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFPolyline Class
DXFPolyline Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFPolyline Fields

DXFPolyline Class See Also

The following tables list the members exposed by the DXFPolyline type.

Fields
 | Name | Description
Public field | data | Represents all data (DXFData) of a figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFPolyline Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFRectangle Class

Members See Also

Represents a Rectangle in a DXF image.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class DXFRectangle
    Inherits DXFFigure
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class DXFRectangle : DXFFigure
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Export.SimpleCADtoDXF.DXFFigure
CADImport.Export.SimpleCADtoDXF.DXFRectangle
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFRectangle Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFRectangle Members

DXFRectangle Class Constructors Methods Fields Properties See Also

Represents a Rectangle in a DXF image.

The following tables list the members exposed by the DXFRectangle type.

Constructors
 | Name | Description
Public constructor | DXFRectangle | (Overloaded) Initializes a new instance of the DXFRectangle class.
Top
Properties
 | Name | Description
Public property | Color | Gets or sets a color for this figure. (inherited from DXFFigure).
Public property | Layer | Gets or sets the current layer for this figure. (inherited from DXFFigure).
Public property | LeftTop | Gets or sets coordinates of the left top point of a rectangle.
Public property | RightBottom | Gets or sets coordinates of the right bottom point of a rectangle.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportAsDXF | Adds a figure to the DXFExport figures collection.
Public method | ExportBlockAsDXF | Virtual function. For redifinition in descendant classes. (inherited from DXFFigure).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ParseToLines | Performs figure approximation by linear segments.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | data | Represents all data (DXFData) of a figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFRectangle Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFRectangle Constructor

DXFRectangle Class See Also

Initializes a new instance of the DXFRectangle class.

Overload List
Name | Description
DXFRectangle() | Initializes a new instance of the DXFRectangle class.
DXFRectangle(DXFData) | Initializes a new instance of the DXFRectangle class that have field data copied from the specified object.
See Also

Reference

DXFRectangle Class
DXFRectangle Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFRectangle Properties

DXFRectangle Class See Also

The following tables list the members exposed by the DXFRectangle type.

Properties
 | Name | Description
Public property | Color | Gets or sets a color for this figure. (inherited from DXFFigure).
Public property | Layer | Gets or sets the current layer for this figure. (inherited from DXFFigure).
Public property | LeftTop | Gets or sets coordinates of the left top point of a rectangle.
Public property | RightBottom | Gets or sets coordinates of the right bottom point of a rectangle.
Top
See Also

Reference

DXFRectangle Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFRectangle.LeftTop Property

Gets or sets coordinates of the left top point of a rectangle.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LeftTop() As DXFPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFPoint LeftTop {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFRectangle Class
DXFRectangle Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFRectangle.RightBottom Property

Gets or sets coordinates of the right bottom point of a rectangle.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property RightBottom() As DXFPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFPoint RightBottom {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFRectangle Class
DXFRectangle Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFRectangle Methods

DXFRectangle Class See Also

The following tables list the members exposed by the DXFRectangle type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportAsDXF | Adds a figure to the DXFExport figures collection.
Public method | ExportBlockAsDXF | Virtual function. For redifinition in descendant classes. (inherited from DXFFigure).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ParseToLines | Performs figure approximation by linear segments.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

DXFRectangle Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFRectangle.ExportAsDXF Method

Adds a figure to the DXFExport figures collection.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub ExportAsDXF( _
   ByVal ADXFExport As DXFExport _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void ExportAsDXF(
   DXFExport ADXFExport
)
This language is not supported or no code example is available.

Parameters

ADXFExport

Type: DXFExport

DXFExport object.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFRectangle Class
DXFRectangle Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFRectangle.ParseToLines Method

Performs figure approximation by linear segments.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub ParseToLines( _
   ByVal NewElemes As ArrayList _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void ParseToLines(
   ArrayList NewElemes
)
This language is not supported or no code example is available.

Parameters

NewElemes

Type: ArrayList

An array of points that will receive approximation results.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFRectangle Class
DXFRectangle Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFRectangle Fields

DXFRectangle Class See Also

The following tables list the members exposed by the DXFRectangle type.

Fields
 | Name | Description
Public field | data | Represents all data (DXFData) of a figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFRectangle Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFSolid Class

Members See Also

Represents a solid in a DXF image.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class DXFSolid
    Inherits DXFFigure
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class DXFSolid : DXFFigure
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Export.SimpleCADtoDXF.DXFFigure
CADImport.Export.SimpleCADtoDXF.DXFSolid
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFSolid Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFSolid Members

DXFSolid Class Constructors Methods Fields Properties See Also

Represents a solid in a DXF image.

The following tables list the members exposed by the DXFSolid type.

Constructors
 | Name | Description
Public constructor | DXFSolid | (Overloaded) Initializes a new instance of the DXFSolid class.
Top
Properties
 | Name | Description
Public property | Color | Gets or sets a color for this figure. (inherited from DXFFigure).
Public property | Layer | Gets or sets the current layer for this figure. (inherited from DXFFigure).
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportAsDXF | Adds a solid to the DXFExport figures collection.
Public method | ExportBlockAsDXF | Virtual function. For redifinition in descendant classes. (inherited from DXFFigure).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ParseToLines | Performs figure approximation by linear segments. (inherited from DXFFigure).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | data | Represents all data (DXFData) of a figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFSolid Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFSolid Constructor

DXFSolid Class See Also

Initializes a new instance of the DXFSolid class.

Overload List
Name | Description
DXFSolid() | Initializes a new instance of the DXFSolid class.
DXFSolid(DXFData) | Initializes a new instance of the DXFSolid class that have field data copied from the specified object.
See Also

Reference

DXFSolid Class
DXFSolid Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFSolid Properties

DXFSolid Class See Also

The following tables list the members exposed by the DXFSolid type.

Properties
 | Name | Description
Public property | Color | Gets or sets a color for this figure. (inherited from DXFFigure).
Public property | Layer | Gets or sets the current layer for this figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFSolid Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFSolid Methods

DXFSolid Class See Also

The following tables list the members exposed by the DXFSolid type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportAsDXF | Adds a solid to the DXFExport figures collection.
Public method | ExportBlockAsDXF | Virtual function. For redifinition in descendant classes. (inherited from DXFFigure).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ParseToLines | Performs figure approximation by linear segments. (inherited from DXFFigure).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

DXFSolid Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFSolid.ExportAsDXF Method

Adds a solid to the DXFExport figures collection.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub ExportAsDXF( _
   ByVal ADXFExport As DXFExport _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void ExportAsDXF(
   DXFExport ADXFExport
)
This language is not supported or no code example is available.

Parameters

ADXFExport

Type: DXFExport

DXFExport object.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFSolid Class
DXFSolid Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFSolid Fields

DXFSolid Class See Also

The following tables list the members exposed by the DXFSolid type.

Fields
 | Name | Description
Public field | data | Represents all data (DXFData) of a figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFSolid Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFText Class

Members See Also

Represents a text in a DXF image.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class DXFText
    Inherits DXFFigure
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class DXFText : DXFFigure
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Export.SimpleCADtoDXF.DXFFigure
CADImport.Export.SimpleCADtoDXF.DXFText
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFText Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFText Members

DXFText Class Constructors Methods Fields Properties See Also

Represents a text in a DXF image.

The following tables list the members exposed by the DXFText type.

Constructors
 | Name | Description
Public constructor | DXFText | (Overloaded) Initializes a new instance of the DXFText class.
Top
Properties
 | Name | Description
Public property | Color | Gets or sets a color for this figure. (inherited from DXFFigure).
Public property | Layer | Gets or sets the current layer for this figure. (inherited from DXFFigure).
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportAsDXF | Adds a text to the DXFExport figures collection.
Public method | ExportBlockAsDXF | Virtual function. For redifinition in descendant classes. (inherited from DXFFigure).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ParseToLines | Performs figure approximation by linear segments. (inherited from DXFFigure).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | data | Represents all data (DXFData) of a figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFText Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFText Constructor

DXFText Class See Also

Initializes a new instance of the DXFText class.

Overload List
Name | Description
DXFText() | Initializes a new instance of the DXFText class.
DXFText(DXFData) | Initializes a new instance of the DXFText class that have field data copied from the specified object.
See Also

Reference

DXFText Class
DXFText Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFText Properties

DXFText Class See Also

The following tables list the members exposed by the DXFText type.

Properties
 | Name | Description
Public property | Color | Gets or sets a color for this figure. (inherited from DXFFigure).
Public property | Layer | Gets or sets the current layer for this figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFText Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFText Methods

DXFText Class See Also

The following tables list the members exposed by the DXFText type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportAsDXF | Adds a text to the DXFExport figures collection.
Public method | ExportBlockAsDXF | Virtual function. For redifinition in descendant classes. (inherited from DXFFigure).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ParseToLines | Performs figure approximation by linear segments. (inherited from DXFFigure).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

DXFText Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFText.ExportAsDXF Method

Adds a text to the DXFExport figures collection.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub ExportAsDXF( _
   ByVal ADXFExport As DXFExport _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void ExportAsDXF(
   DXFExport ADXFExport
)
This language is not supported or no code example is available.

Parameters

ADXFExport

Type: DXFExport

DXFExport object.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFText Class
DXFText Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFText Fields

DXFText Class See Also

The following tables list the members exposed by the DXFText type.

Fields
 | Name | Description
Public field | data | Represents all data (DXFData) of a figure. (inherited from DXFFigure).
Top
See Also

Reference

DXFText Class
CADImport.Export.SimpleCADtoDXF Namespace


DXFHatchPatternData Structure

Members See Also

Represents the hatch pattern data

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Structure DXFHatchPatternData
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public struct DXFHatchPatternData
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFHatchPatternData Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFHatchPatternData Members

DXFHatchPatternData Structure Fields See Also

Represents the hatch pattern data

The following tables list the members exposed by the DXFHatchPatternData type.

Fields
 | Name | Description
Public field | angle | Represents an angle
Public field | basePointX | Represents the X and Y coordinates of the base point of a hatch.
Public field | basePointY | Represents the X and Y coordinates of the base point of a hatch.
Public field | offsetX | Represents the offsets on X and Y axes.
Public field | offsetY | Represents the offsets on X and Y axes.
Top
See Also

Reference

DXFHatchPatternData Structure
CADImport.Export.SimpleCADtoDXF Namespace


DXFHatchPatternData Fields

DXFHatchPatternData Structure See Also

The following tables list the members exposed by the DXFHatchPatternData type.

Fields
 | Name | Description
Public field | angle | Represents an angle
Public field | basePointX | Represents the X and Y coordinates of the base point of a hatch.
Public field | basePointY | Represents the X and Y coordinates of the base point of a hatch.
Public field | offsetX | Represents the offsets on X and Y axes.
Public field | offsetY | Represents the offsets on X and Y axes.
Top
See Also

Reference

DXFHatchPatternData Structure
CADImport.Export.SimpleCADtoDXF Namespace


angle Field

Represents an angle

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public angle As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float angle
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFHatchPatternData Structure
DXFHatchPatternData Members
CADImport.Export.SimpleCADtoDXF Namespace


basePointX Field

Represents the X and Y coordinates of the base point of a hatch.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public basePointX As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float basePointX
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFHatchPatternData Structure
DXFHatchPatternData Members
CADImport.Export.SimpleCADtoDXF Namespace


basePointY Field

Represents the X and Y coordinates of the base point of a hatch.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public basePointY As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float basePointY
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFHatchPatternData Structure
DXFHatchPatternData Members
CADImport.Export.SimpleCADtoDXF Namespace


offsetX Field

Represents the offsets on X and Y axes.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public offsetX As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float offsetX
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFHatchPatternData Structure
DXFHatchPatternData Members
CADImport.Export.SimpleCADtoDXF Namespace


offsetY Field

Represents the offsets on X and Y axes.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public offsetY As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float offsetY
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFHatchPatternData Structure
DXFHatchPatternData Members
CADImport.Export.SimpleCADtoDXF Namespace


DimensionStyle Structure

Members See Also

A style of dimension

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Structure DimensionStyle
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public struct DimensionStyle
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimensionStyle Members
CADImport.Export.SimpleCADtoDXF Namespace


DimensionStyle Members

DimensionStyle Structure Fields See Also

A style of dimension

The following tables list the members exposed by the DimensionStyle type.

Fields
 | Name | Description
Public field | arrow1 | Arrow1 type
Public field | arrow2 | Arrow2 type
Public field | arrowBlock1 | Arrow1 block
Public field | arrowBlock2 | Arrow2 block
Public field | arrowSize | Arrow size
Public field | extLineExt | Extension line extension
Public field | extLineOffset | Extension line offset
Public field | textHeight | Text height
Public field | textOffset | Text offset
Top
See Also

Reference

DimensionStyle Structure
CADImport.Export.SimpleCADtoDXF Namespace


DimensionStyle Fields

DimensionStyle Structure See Also

The following tables list the members exposed by the DimensionStyle type.

Fields
 | Name | Description
Public field | arrow1 | Arrow1 type
Public field | arrow2 | Arrow2 type
Public field | arrowBlock1 | Arrow1 block
Public field | arrowBlock2 | Arrow2 block
Public field | arrowSize | Arrow size
Public field | extLineExt | Extension line extension
Public field | extLineOffset | Extension line offset
Public field | textHeight | Text height
Public field | textOffset | Text offset
Top
See Also

Reference

DimensionStyle Structure
CADImport.Export.SimpleCADtoDXF Namespace


arrow1 Field

Arrow1 type

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public arrow1 As DimensionArrowType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DimensionArrowType arrow1
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimensionStyle Structure
DimensionStyle Members
CADImport.Export.SimpleCADtoDXF Namespace


arrow2 Field

Arrow2 type

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public arrow2 As DimensionArrowType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DimensionArrowType arrow2
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimensionStyle Structure
DimensionStyle Members
CADImport.Export.SimpleCADtoDXF Namespace


arrowBlock1 Field

Arrow1 block

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public arrowBlock1 As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int arrowBlock1
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimensionStyle Structure
DimensionStyle Members
CADImport.Export.SimpleCADtoDXF Namespace


arrowBlock2 Field

Arrow2 block

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public arrowBlock2 As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int arrowBlock2
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimensionStyle Structure
DimensionStyle Members
CADImport.Export.SimpleCADtoDXF Namespace


arrowSize Field

Arrow size

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public arrowSize As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float arrowSize
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimensionStyle Structure
DimensionStyle Members
CADImport.Export.SimpleCADtoDXF Namespace


extLineExt Field

Extension line extension

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public extLineExt As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float extLineExt
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimensionStyle Structure
DimensionStyle Members
CADImport.Export.SimpleCADtoDXF Namespace


extLineOffset Field

Extension line offset

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public extLineOffset As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float extLineOffset
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimensionStyle Structure
DimensionStyle Members
CADImport.Export.SimpleCADtoDXF Namespace


textHeight Field

Text height

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public textHeight As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float textHeight
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimensionStyle Structure
DimensionStyle Members
CADImport.Export.SimpleCADtoDXF Namespace


textOffset Field

Text offset

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public textOffset As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float textOffset
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DimensionStyle Structure
DimensionStyle Members
CADImport.Export.SimpleCADtoDXF Namespace


Line Structure

Members See Also

Auxiliary structure of a line

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Structure Line
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public struct Line
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Line Members
CADImport.Export.SimpleCADtoDXF Namespace


Line Members

Line Structure Constructors Fields See Also

Auxiliary structure of a line

The following tables list the members exposed by the Line type.

Constructors
 | Name | Description
Public constructor | Line | Initializes a new instance of the Line class with the specified location and size.
Top
Fields
 | Name | Description
Public field | x1 | x1 coordinate
Public field | x2 | x2 coordinate
Public field | y1 | y1 coordinate
Public field | y2 | y2 coordinate
Top
See Also

Reference

Line Structure
CADImport.Export.SimpleCADtoDXF Namespace


Line Constructor

Initializes a new instance of the Line class with the specified location and size.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal ax1 As Integer, _
   ByVal ay1 As Integer, _
   ByVal ax2 As Integer, _
   ByVal ay2 As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Line(
   int ax1,
   int ay1,
   int ax2,
   int ay2
)
This language is not supported or no code example is available.

Parameters

ax1

Type: int

The left coordinate of the line.

ay1

Type: int

The top coordinate of the line.

ax2

Type: int

The right coordinate the line.

ay2

Type: int

The bottom coordinate of the line.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Line Structure
Line Members
CADImport.Export.SimpleCADtoDXF Namespace


Line Fields

Line Structure See Also

The following tables list the members exposed by the Line type.

Fields
 | Name | Description
Public field | x1 | x1 coordinate
Public field | x2 | x2 coordinate
Public field | y1 | y1 coordinate
Public field | y2 | y2 coordinate
Top
See Also

Reference

Line Structure
CADImport.Export.SimpleCADtoDXF Namespace


x1 Field

x1 coordinate

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public x1 As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int x1
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Line Structure
Line Members
CADImport.Export.SimpleCADtoDXF Namespace


x2 Field

x2 coordinate

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public x2 As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int x2
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Line Structure
Line Members
CADImport.Export.SimpleCADtoDXF Namespace


y1 Field

y1 coordinate

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public y1 As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int y1
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Line Structure
Line Members
CADImport.Export.SimpleCADtoDXF Namespace


y2 Field

y2 coordinate

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public y2 As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int y2
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Line Structure
Line Members
CADImport.Export.SimpleCADtoDXF Namespace


Rect Structure

Members See Also

Auxiliary structure of a rectangle

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Structure Rect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public struct Rect
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect Members
CADImport.Export.SimpleCADtoDXF Namespace


Rect Members

Rect Structure Constructors Fields See Also

Auxiliary structure of a rectangle

The following tables list the members exposed by the Rect type.

Constructors
 | Name | Description
Public constructor | Rect | Initializes a new instance of the Rect class with the specified location and size.
Top
Fields
 | Name | Description
Public field | X1 | X1 coordinate of a rectangle
Public field | X2 | X2 coordinate of a rectangle
Public field | Y1 | Y1 coordinate of a rectangle
Public field | Y2 | Y2 coordinate of a rectangle
Top
See Also

Reference

Rect Structure
CADImport.Export.SimpleCADtoDXF Namespace


Rect Constructor

Initializes a new instance of the Rect class with the specified location and size.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal x1 As Integer, _
   ByVal y1 As Integer, _
   ByVal x2 As Integer, _
   ByVal y2 As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Rect(
   int x1,
   int y1,
   int x2,
   int y2
)
This language is not supported or no code example is available.

Parameters

x1

Type: int

The left coordinate of the rectangle.

y1

Type: int

The top coordinate of the rectangle.

x2

Type: int

The right coordinate the rectangle.

y2

Type: int

The bottom coordinate of the rectangle.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect Structure
Rect Members
CADImport.Export.SimpleCADtoDXF Namespace


Rect Fields

Rect Structure See Also

The following tables list the members exposed by the Rect type.

Fields
 | Name | Description
Public field | X1 | X1 coordinate of a rectangle
Public field | X2 | X2 coordinate of a rectangle
Public field | Y1 | Y1 coordinate of a rectangle
Public field | Y2 | Y2 coordinate of a rectangle
Top
See Also

Reference

Rect Structure
CADImport.Export.SimpleCADtoDXF Namespace


X1 Field

X1 coordinate of a rectangle

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public X1 As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int X1
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect Structure
Rect Members
CADImport.Export.SimpleCADtoDXF Namespace


X2 Field

X2 coordinate of a rectangle

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public X2 As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int X2
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect Structure
Rect Members
CADImport.Export.SimpleCADtoDXF Namespace


Y1 Field

Y1 coordinate of a rectangle

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Y1 As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Y1
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect Structure
Rect Members
CADImport.Export.SimpleCADtoDXF Namespace


Y2 Field

Y2 coordinate of a rectangle

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Y2 As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Y2
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Rect Structure
Rect Members
CADImport.Export.SimpleCADtoDXF Namespace


ArcType Enumeration

Types for DXFArc

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Circle | Cicle - arc has the form of a circle.
Ellipse | Ellipse - arc has the form of an ellipse.
See Also

Reference

CADImport.Export.SimpleCADtoDXF Namespace


AutoCADVersion Enumeration

Version types of AutoCAD.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
R14 | AutoCAD version 14.
R2000 | AutoCAD version 2000.
See Also

Reference

CADImport.Export.SimpleCADtoDXF Namespace


DXFIntConst Enumeration

Types of DXF color.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
DXF_ALTERNATIVEBLACK | AlternativeBlack
DXF_AQUA | Aqua
DXF_BLACK | Black
DXF_BLUE | Blue
DXF_BYBLOCK | ByBlock
DXF_BYLAYER | ByLayer
DXF_DKGRAY | Dark gray
DXF_FUCHSIA | Fuchsia
DXF_GRAY | Gray
DXF_GREEN | Green
DXF_LIME | Lime
DXF_LTGRAY | Light gray
DXF_MAROON | Maroon
DXF_NAVY | Navy
DXF_OLIVE | Olive
DXF_PURPLE | Purple
DXF_RED | Red
DXF_SILVER | Silver
DXF_TEAL | Teal
DXF_WHITE | White
DXF_YELLOW | Yellow
See Also

Reference

CADImport.Export.SimpleCADtoDXF Namespace


DimensionArrowType Enumeration

Type of the dimension arrow

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
ArchitecturalTick | Architectural tick style
Box | Box style
BoxFilled | BoxFilled style
Closed | Closed style
ClosedBlank | ClosedBlank style
ClosedFilled | ClosedFilled style
DatumTriangle | DatumTriangle style
Dot | Dot style
DotBlank | DotBlank style
DotSmall | DotSmall style
DotSmallBlank | DotSmallBlank style
Integral | Integral style
None | None style
Oblique | Oblique style
Open | Open style
Open30 | Open30 style
Origin | Origin style
Origin2 | Origin2 style
RightAngle | Right angle style
UserArrow | UserArrow style
See Also

Reference

CADImport.Export.SimpleCADtoDXF Namespace


DimensionType Enumeration

A type of dimension

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Aligned | Aligned type
Angular | Angular type
Angular3Point | Angular3Point type
Diameter | Diameter type
Ordinate | Ordinate type
Radius | Radius type
Rotated | Rotated type
See Also

Reference

CADImport.Export.SimpleCADtoDXF Namespace


HatchBoundaryType Enumeration

Types for DXFHatch.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Circle | Hatch as a circle
Ellipse | Hatch as an ellipse
PolyPolyline | Hatch as a polyline
See Also

Reference

CADImport.Export.SimpleCADtoDXF Namespace


HatchStyle Enumeration

Type styles of a hatch

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
BDiagonal | "\\\\\\\\\\"
Cross | "+++++"
DiagCross | "xxxxx"
FDiagonal | "//////////"
Horizontal | "----------"
PatternData | pattern style
Solid | ""
Vertical | "||||||||||"
See Also

Reference

CADImport.Export.SimpleCADtoDXF Namespace


CADImport.Extensions.WinApiModule Namespace

Assembly: CADImport (in CADImport.dll)

Classes
 | Name | Description
Public class | GDIApi |
Top
Enumerations
 | Name | Description
Public enumeration | DeviceCap | Device-specific information.
Top
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


GDIApi Class

Members See Also

Namespace: CADImport.Extensions.WinApiModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public MustInherit Class GDIApi
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public abstract class GDIApi
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Extensions.WinApiModule.GDIApi
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GDIApi Members
CADImport.Extensions.WinApiModule Namespace


GDIApi Members

GDIApi Class Methods See Also

The following tables list the members exposed by the GDIApi type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

GDIApi Class
CADImport.Extensions.WinApiModule Namespace


GDIApi Methods

GDIApi Class See Also

The following tables list the members exposed by the GDIApi type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

GDIApi Class
CADImport.Extensions.WinApiModule Namespace


DeviceCap Enumeration

Device-specific information.

Namespace: CADImport.Extensions.WinApiModule
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
ASPECTX | Relative width of a device pixel used for line drawing.
ASPECTXY | Diagonal width of the device pixel used for line drawing.
ASPECTY | Relative height of a device pixel used for line drawing.
BITSPIXEL | Number of adjacent color bits for each pixel.
CLIPCAPS | Flag that indicates the clipping capabilities of the device.
COLORRES | Actual color resolution of the device, in bits per pixel.
CURVECAPS | Value that indicates the curve capabilities of the device.
DRIVERVERSION | The device driver version.
HORZRES | Width, in pixels, of the screen.
HORZSIZE | Width, in millimeters, of the physical screen.
LINECAPS | Value that indicates the line capabilities of the device.
LOGPIXELSX | Number of pixels per logical inch along the screen width.
LOGPIXELSY | Number of pixels per logical inch along the screen height.
NUMBRUSHES | Number of device-specific brushes.
NUMCOLORS | Number of entries in the device's color table.
NUMFONTS | Number of device-specific fonts.
NUMMARKERS | Number of device-specific markers.
NUMPENS | Number of device-specific pens.
NUMRESERVED | Number of reserved entries in the system palette.
PDEVICESIZE | Reserved.
PHYSICALHEIGHT | For printing devices: the height of the physical page, in device units. For example, a printer set to print at 600 dpi on 8.5-by-11-inch paper has a physical height value of 6600 device units.
PHYSICALOFFSETX | For printing devices: the distance from the left edge of the physical page to the left edge of the printable area, in device units. For example, a printer set to print at 600 dpi on 8.5-by-11-inch paper, that cannot print on the leftmost 0.25-inch of paper, has a horizontal physical offset of 150 device units.
PHYSICALOFFSETY | For printing devices: the distance from the top edge of the physical page to the top edge of the printable area, in device units. For example, a printer set to print at 600 dpi on 8.5-by-11-inch paper, that cannot print on the topmost 0.5-inch of paper, has a vertical physical offset of 300 device units.
PHYSICALWIDTH | For printing devices: the width of the physical page, in device units. For example, a printer set to print at 600 dpi on 8.5-x11-inch paper has a physical width value of 5100 device units.
PLANES | Number of color planes.
POLYGONALCAPS | Value that indicates the polygon capabilities of the device.
RASTERCAPS | Value that indicates the raster capabilities of the device.
SCALINGFACTORX | Scaling factor for the x-axis of the printer.
SCALINGFACTORY | Scaling factor for the y-axis of the printer.
SIZEPALETTE | Number of entries in the system palette.
TECHNOLOGY | Device technology.
TEXTCAPS | Value that indicates the text capabilities of the device.
VERTRES | Height, in raster lines, of the screen.
VERTSIZE | Height, in millimeters, of the physical screen.
See Also

Reference

CADImport.Extensions.WinApiModule Namespace


CADImport.FaceModule Namespace

Assembly: CADImport (in CADImport.dll)

Classes
 | Name | Description
Public class | CADImportFace | Provides functionality for creating the entities tree in the user interface.
Public class | CADListView | Displays items list in CADListView control item: as text fields, images and special cell drawing methods
Public class | CADPictureBox | Represents the advanced PictureBox object with scroll bars
Public class | CADPropertyGrid |
Public class | ClipRect | Represents the Rectangle tool.
Public class | Grid | Represents the grid object for a control.
Public class | ListEventSelectArgs | Contains parameters of cell selection event
Public class | ListHeader | Represents the CADListView header cell
Public class | ListHeaderCollection | Represents the CADListView headers collection
Public class | ListItem | Represents the CADListView cell
Public class | ListItemCollection | Represents the CADListView cells collection
Public class | MultipleLanguage | Provides support for multiple languages.
Public class | Orbit3D | Provides a possibility of drawing's rotation.
Public class | PenXorDrawing | Auxiliary class for drawing in xor mode
Public class | SaveSettings | Provides methods for saving the application's settings.
Public class | ScrollEventArgsExt | Provides data for the Scroll event.
Top
Delegates
 | Name | Description
Public delegate | CADImportEventHandler | Represents the method that handles the RotateEvent event
Public delegate | DrawListItemCell | Represents cell drawing method
Public delegate | ListCellSelectEventHandler | Represents a list of functions invoked on cell selection event
Public delegate | ListItemSelectEventHandler | Represents a list of functions invoked on item selection event
Public delegate | ScrollEventHandlerExt | Represents the method that handles the Scroll event of a FormsGridView, ScrollBar, TrackBar, or FormsGrid.
Top
Enumerations
 | Name | Description
Public enumeration | Axes | Specifies coordinate axes in the orthogonal coordinate system.
Public enumeration | ConvSection | Specifies a type of section in a CAD file.
Public enumeration | RectangleType | Specifies the working modes for the Rectangle tool.
Public enumeration | ScrollBarsShow | Represents options for the scrollbars activity
Public enumeration | ScrollOrientation | Specifies the scroll bar orientation for the Scroll event.
Public enumeration | s3DStates | Specifies cursors for the 3D Orbit tool.
Top
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


CADImportFace Class

Members See Also

Provides functionality for creating the entities tree in the user interface.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADImportFace
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADImportFace
This language is not supported or no code example is available.
Remarks

The entities tree allows to look through all entities in the loaded CAD file. It also allows to turn off or turn on a visibility of a separate entity.

Inheritance Hierarchy
System.Object
CADImport.FaceModule.CADImportFace
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImportFace Members
CADImport.FaceModule Namespace


CADImportFace Members

CADImportFace Class Methods Properties See Also

Provides functionality for creating the entities tree in the user interface.

The following tables list the members exposed by the CADImportFace type.

Properties
Name | Description
EntityPropertyGrid | Gets or sets a properties window where the properties of the selected entity can be viewed and modified.
Top
Methods
 | Name | Description
 | DecodeEntity | Selects an entity on the CAD image and displays its properties in the properties window.
 | DecodeEntityExt | Selects an entity on the CAD image and displays its properties in the properties window.
 | DoCheckTreeNode | Checks for the entity's visibility.
 | DrawEntityBox | Gets a rectangle incorporating and designating the selected entity.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | LoadTreeNodes | Loads entities of the specified CAD image to the entities tree.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
 | SelectLayer | Displays the properties of the selected layer in the Properties window.
 | SelectObject | Creates and sets an object in EntityPropertyGrid by the specified CADEntity
 | SetName | Sets a name of the specified CADEntity.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADImportFace Class
CADImport.FaceModule Namespace


CADImportFace Properties

CADImportFace Class See Also

The following tables list the members exposed by the CADImportFace type.

Properties
Name | Description
EntityPropertyGrid | Gets or sets a properties window where the properties of the selected entity can be viewed and modified.
Top
See Also

Reference

CADImportFace Class
CADImport.FaceModule Namespace


CADImportFace.EntityPropertyGrid Property

Gets or sets a properties window where the properties of the selected entity can be viewed and modified.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Property EntityPropertyGrid() As CADPropertyGrid
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static CADPropertyGrid EntityPropertyGrid {get; set;}
This language is not supported or no code example is available.

Property Value

A PropertyGrid object representing the properties window.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImportFace Class
CADImportFace Members
CADImport.FaceModule Namespace


CADImportFace Methods

CADImportFace Class See Also

The following tables list the members exposed by the CADImportFace type.

Methods
 | Name | Description
 | DecodeEntity | Selects an entity on the CAD image and displays its properties in the properties window.
 | DecodeEntityExt | Selects an entity on the CAD image and displays its properties in the properties window.
 | DoCheckTreeNode | Checks for the entity's visibility.
 | DrawEntityBox | Gets a rectangle incorporating and designating the selected entity.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | LoadTreeNodes | Loads entities of the specified CAD image to the entities tree.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
 | SelectLayer | Displays the properties of the selected layer in the Properties window.
 | SelectObject | Creates and sets an object in EntityPropertyGrid by the specified CADEntity
 | SetName | Sets a name of the specified CADEntity.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

CADImportFace Class
CADImport.FaceModule Namespace


CADImportFace.DecodeEntity Method

Selects an entity on the CAD image and displays its properties in the properties window.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function DecodeEntity( _
   ByVal node As TreeNode, _
   ByVal img As CADImage, _
   ByVal cl1 As Control, _
   ByVal scale As Single _
) As CADEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static CADEntity DecodeEntity(
   TreeNode node,
   CADImage img,
   Control cl1,
   float scale
)
This language is not supported or no code example is available.

Parameters

node

Type: TreeNode

A TreeNode object that represents the entity in the TreeView and clicking on which initializes selecting the entity on the CAD image.

img

Type: CADImage

A CADImage on which the entity to be selected is located.

cl1

Type: Control

A Control on which the CAD image is drawn.

scale

Type: float

A scale in which the CAD image is drawn.

Return Value

The selected CADEntity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImportFace Class
CADImportFace Members
CADImport.FaceModule Namespace


CADImportFace.DecodeEntityExt Method

Selects an entity on the CAD image and displays its properties in the properties window.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function DecodeEntityExt( _
   ByVal node As TreeNode, _
   ByVal img As CADImage, _
   ByVal cl1 As Control, _
   ByVal scale As Single _
) As CADEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static CADEntity DecodeEntityExt(
   TreeNode node,
   CADImage img,
   Control cl1,
   float scale
)
This language is not supported or no code example is available.

Parameters

node

Type: TreeNode

A TreeNode object that represents the entity in the TreeView and clicking on which initializes selecting the entity on the CAD image.

img

Type: CADImage

A CADImage on which the entity to be selected is located.

cl1

Type: Control

A Control on which the CAD image is drawn.

scale

Type: float

A scale in which the CAD image is drawn.

Return Value

The selected CADEntity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImportFace Class
CADImportFace Members
CADImport.FaceModule Namespace


CADImportFace.DoCheckTreeNode Method

Checks for the entity's visibility.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub DoCheckTreeNode( _
   ByVal aNodes As TreeNodeCollection, _
   ByVal aNode As TreeNode, _
   ByVal img As CADImage, _
   ByVal parent As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void DoCheckTreeNode(
   TreeNodeCollection aNodes,
   TreeNode aNode,
   CADImage img,
   Control parent
)
This language is not supported or no code example is available.

Parameters

aNodes

Type: TreeNodeCollection

A TreeNodeCollection that contains the tree nodes.

aNode

Type: TreeNode

A TreeNode representing an entity whose visibility is to be checked.

img

Type: CADImage

A CADImage that provides entities for the tree.

parent

Type: Control

A control where the drawing is displayed

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImportFace Class
CADImportFace Members
CADImport.FaceModule Namespace


CADImportFace.DrawEntityBox Method

Gets a rectangle incorporating and designating the selected entity.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function DrawEntityBox( _
   ByVal node As TreeNode, _
   ByVal image As CADImage _
) As Rectangle
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static Rectangle DrawEntityBox(
   TreeNode node,
   CADImage image
)
This language is not supported or no code example is available.

Parameters

node

Type: TreeNode

A TreeNode object corresponding to the selected entity.

image

Type: CADImage

A CADImage on which the selected entity is located.

Return Value

A Rectangle that designates the selected entity.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImportFace Class
CADImportFace Members
CADImport.FaceModule Namespace


CADImportFace.LoadTreeNodes Method

Loads entities of the specified CAD image to the entities tree.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub LoadTreeNodes( _
   ByVal aNodes As TreeNodeCollection, _
   ByVal aCADImage As CADImage _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void LoadTreeNodes(
   TreeNodeCollection aNodes,
   CADImage aCADImage
)
This language is not supported or no code example is available.

Parameters

aNodes

Type: TreeNodeCollection

A TreeNodeCollection where the tree nodes representing the entities will be added to.

aCADImage

Type: CADImage

A CADImage that provides entities for the entities tree.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImportFace Class
CADImportFace Members
CADImport.FaceModule Namespace


CADImportFace.SelectLayer Method

Displays the properties of the selected layer in the Properties window.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub SelectLayer( _
   ByVal ind As Integer, _
   ByVal img As CADImage _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void SelectLayer(
   int ind,
   CADImage img
)
This language is not supported or no code example is available.

Parameters

ind

Type: int

An index of the selected layer.

img

Type: CADImage

The CADImage on which the layer has been selected.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImportFace Class
CADImportFace Members
CADImport.FaceModule Namespace


CADImportFace.SelectObject Method

Creates and sets an object in EntityPropertyGrid by the specified CADEntity

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub SelectObject( _
   ByVal ent As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void SelectObject(
   CADEntity ent
)
This language is not supported or no code example is available.

Parameters

ent

Type: CADEntity

The specified entity

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImportFace Class
CADImportFace Members
CADImport.FaceModule Namespace


CADImportFace.SetName Method

Sets a name of the specified CADEntity.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function SetName( _
   ByVal aEnt As CADEntity _
) As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static string SetName(
   CADEntity aEnt
)
This language is not supported or no code example is available.

Parameters

aEnt

Type: CADEntity

A CADEntity whose name will be set.

Return Value

A string containing a name of the specified CADEntity.
Remarks

A name of the CAD entity is determined by the name of its class. If the CAD entity is not supported it will be named just "Entity".

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImportFace Class
CADImportFace Members
CADImport.FaceModule Namespace


CADListView Class

Members See Also

Displays items list in CADListView control item: as text fields, images and special cell drawing methods

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADListView
    Inherits UserControl
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADListView : UserControl
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
CADImport.FaceModule.CADListView
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Members
CADImport.FaceModule Namespace


CADListView Members

CADListView Class Constructors Events Methods Properties See Also

Displays items list in CADListView control item: as text fields, images and special cell drawing methods

The following tables list the members exposed by the CADListView type.

Constructors
 | Name | Description
Public constructor | CADListView | Initializes new instance of CADListView class.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (inherited from ScrollableControl).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from UserControl).
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (inherited from UserControl).
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (inherited from UserControl).
Public property | BackColor | Gets or sets the background color for the control. (inherited from Control).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | BorderStyle | Gets or sets the border style of the tree view control. (inherited from UserControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
Public property | CellHeight | Gets or sets cells height
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (inherited from Control).
Public property | Columns | Returns the collection of all table headers of current control item
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | GridColor | Gets or sets a color of the table grid
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | HeaderColor | Gets or sets a color of the table header
Public property | HeaderFont | Gets or sets a font of the table header
Public property | HeaderHeight | Gets or sets height of the table header
Public property | HeaderStringFormat | Gets or sets the CADListView header string format
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | ImageList | Gets or sets ImageList for CADListView cells
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | ItemColor | Gets or sets a color of CADListView cell
Public property | ItemFont | Gets or sets a font of CADListView cells
Public property | ItemStringFormat | Gets or sets CADListView cell string format
Public property | Items | Gets the CADListView cells list
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (inherited from Control).
Public property | Margin | Gets or sets the space between controls. (inherited from Control).
Public property | MaximumSize | Gets or sets the size that is the upper limit that Size) can specify. (inherited from Control).
Public property | MinimumSize | Gets or sets the size that is the lower limit that Size) can specify. (inherited from Control).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | MultipleSelection | Gets or sets the multiple selection mode
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | Position | Gets or sets the scrolling position
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | SelectColor | Gets or sets a highlight color of selected cells
Public property | SelectedCells | Gets or sets a list of the selected cells
Public property | ShowGrid | Gets or sets grid visibility
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the height and width of the control. (inherited from Control).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Control).
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (inherited from Control).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from UserControl).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | ViewSize | Gets or sets the scrolling region size
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Clear | Clears all CADListView nodes
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Deselect | Cancels selection of all items.
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | InvalidateCell | Redraws a cell with the specified number
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | OnSelectCell | Invokes SelectCellEvent event
Public method | OnSelectItem | Invokes SelectItemEvent event
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectCells | Selects a cell or an item by the specified coordinates
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetAutoSize | Sets columns width; equals the longest row in the column
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | Show | (Overloaded) Displays the control to the user. (inherited from Control).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (inherited from Component).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from UserControl).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from UserControl).
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (inherited from UserControl).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before the control becomes visible for the first time. (inherited from UserControl).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | Occurs when the control's margin changes. (inherited from Control).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | SelectCellEvent | Occurs on user cell selection.
Public event | SelectItemEvent | Occurs on user item selection.
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (inherited from Control).
Public event | TabStopChanged | Occurs when the TabStop property value changes. (inherited from Control).
Public event | TextChanged | (inherited from UserControl).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

CADListView Class
CADImport.FaceModule Namespace


CADListView Constructor

Initializes new instance of CADListView class.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADListView()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Class
CADListView Members
CADImport.FaceModule Namespace


CADListView Properties

CADListView Class See Also

The following tables list the members exposed by the CADListView type.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (inherited from ScrollableControl).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from UserControl).
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (inherited from UserControl).
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (inherited from UserControl).
Public property | BackColor | Gets or sets the background color for the control. (inherited from Control).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | BorderStyle | Gets or sets the border style of the tree view control. (inherited from UserControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
Public property | CellHeight | Gets or sets cells height
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (inherited from Control).
Public property | Columns | Returns the collection of all table headers of current control item
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | GridColor | Gets or sets a color of the table grid
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | HeaderColor | Gets or sets a color of the table header
Public property | HeaderFont | Gets or sets a font of the table header
Public property | HeaderHeight | Gets or sets height of the table header
Public property | HeaderStringFormat | Gets or sets the CADListView header string format
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | ImageList | Gets or sets ImageList for CADListView cells
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | ItemColor | Gets or sets a color of CADListView cell
Public property | ItemFont | Gets or sets a font of CADListView cells
Public property | ItemStringFormat | Gets or sets CADListView cell string format
Public property | Items | Gets the CADListView cells list
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (inherited from Control).
Public property | Margin | Gets or sets the space between controls. (inherited from Control).
Public property | MaximumSize | Gets or sets the size that is the upper limit that Size) can specify. (inherited from Control).
Public property | MinimumSize | Gets or sets the size that is the lower limit that Size) can specify. (inherited from Control).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | MultipleSelection | Gets or sets the multiple selection mode
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | Position | Gets or sets the scrolling position
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | SelectColor | Gets or sets a highlight color of selected cells
Public property | SelectedCells | Gets or sets a list of the selected cells
Public property | ShowGrid | Gets or sets grid visibility
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the height and width of the control. (inherited from Control).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Control).
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (inherited from Control).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from UserControl).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | ViewSize | Gets or sets the scrolling region size
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

CADListView Class
CADImport.FaceModule Namespace


CADListView.CellHeight Property

Gets or sets cells height

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property CellHeight() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int CellHeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Class
CADListView Members
CADImport.FaceModule Namespace


CADListView.Columns Property

Returns the collection of all table headers of current control item

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Columns() As ListHeaderCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ListHeaderCollection Columns {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Class
CADListView Members
CADImport.FaceModule Namespace


CADListView.GridColor Property

Gets or sets a color of the table grid

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property GridColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Color GridColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Class
CADListView Members
CADImport.FaceModule Namespace


CADListView.HeaderColor Property

Gets or sets a color of the table header

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property HeaderColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Color HeaderColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Class
CADListView Members
CADImport.FaceModule Namespace


CADListView.HeaderFont Property

Gets or sets a font of the table header

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property HeaderFont() As Font
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Font HeaderFont {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Class
CADListView Members
CADImport.FaceModule Namespace


CADListView.HeaderHeight Property

Gets or sets height of the table header

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property HeaderHeight() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int HeaderHeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Class
CADListView Members
CADImport.FaceModule Namespace


CADListView.HeaderStringFormat Property

Gets or sets the CADListView header string format

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property HeaderStringFormat() As StringFormat
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public StringFormat HeaderStringFormat {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Class
CADListView Members
CADImport.FaceModule Namespace


CADListView.ImageList Property

Gets or sets ImageList for CADListView cells

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ImageList() As ImageList
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ImageList ImageList {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Class
CADListView Members
CADImport.FaceModule Namespace


CADListView.ItemColor Property

Gets or sets a color of CADListView cell

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ItemColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Color ItemColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Class
CADListView Members
CADImport.FaceModule Namespace


CADListView.ItemFont Property

Gets or sets a font of CADListView cells

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ItemFont() As Font
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Font ItemFont {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Class
CADListView Members
CADImport.FaceModule Namespace


CADListView.ItemStringFormat Property

Gets or sets CADListView cell string format

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ItemStringFormat() As StringFormat
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public StringFormat ItemStringFormat {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Class
CADListView Members
CADImport.FaceModule Namespace


CADListView.Items Property

Gets the CADListView cells list

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Items() As ListItemCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ListItemCollection Items {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Class
CADListView Members
CADImport.FaceModule Namespace


CADListView.MultipleSelection Property

Gets or sets the multiple selection mode

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property MultipleSelection() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool MultipleSelection {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Class
CADListView Members
CADImport.FaceModule Namespace


CADListView.Position Property

Gets or sets the scrolling position

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Position() As Point
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Point Position {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Class
CADListView Members
CADImport.FaceModule Namespace


CADListView.SelectColor Property

Gets or sets a highlight color of selected cells

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property SelectColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Color SelectColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Class
CADListView Members
CADImport.FaceModule Namespace


CADListView.SelectedCells Property

Gets or sets a list of the selected cells

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property SelectedCells() As ArrayList
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ArrayList SelectedCells {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Class
CADListView Members
CADImport.FaceModule Namespace


CADListView.ShowGrid Property

Gets or sets grid visibility

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ShowGrid() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool ShowGrid {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Class
CADListView Members
CADImport.FaceModule Namespace


CADListView.ViewSize Property

Gets or sets the scrolling region size

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ViewSize() As Size
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Size ViewSize {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Class
CADListView Members
CADImport.FaceModule Namespace


CADListView Methods

CADListView Class See Also

The following tables list the members exposed by the CADListView type.

Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Clear | Clears all CADListView nodes
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Deselect | Cancels selection of all items.
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | InvalidateCell | Redraws a cell with the specified number
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | OnSelectCell | Invokes SelectCellEvent event
Public method | OnSelectItem | Invokes SelectItemEvent event
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectCells | Selects a cell or an item by the specified coordinates
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetAutoSize | Sets columns width; equals the longest row in the column
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | Show | (Overloaded) Displays the control to the user. (inherited from Control).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (inherited from Component).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from UserControl).
Top
See Also

Reference

CADListView Class
CADImport.FaceModule Namespace


CADListView.Clear Method

Clears all CADListView nodes

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Clear()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Clear()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Class
CADListView Members
CADImport.FaceModule Namespace


CADListView.Deselect Method

Cancels selection of all items.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Deselect()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Deselect()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Class
CADListView Members
CADImport.FaceModule Namespace


CADListView.InvalidateCell Method

Redraws a cell with the specified number

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub InvalidateCell( _
   ByVal cnt As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void InvalidateCell(
   int cnt
)
This language is not supported or no code example is available.

Parameters

cnt

Type: int

A cell number

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Class
CADListView Members
CADImport.FaceModule Namespace


CADListView.OnSelectCell Method

Invokes SelectCellEvent event

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnSelectCell( _
   ByVal item As ListItem, _
   ByVal e As ListEventSelectArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnSelectCell(
   ListItem item,
   ListEventSelectArgs e
)
This language is not supported or no code example is available.

Parameters

item

Type: ListItem

Contains the selected cell

e

Type: ListEventSelectArgs

Contains information about event

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Class
CADListView Members
CADImport.FaceModule Namespace


CADListView.OnSelectItem Method

Invokes SelectItemEvent event

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnSelectItem( _
   ByVal items As ArrayList, _
   ByVal e As ListEventSelectArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnSelectItem(
   ArrayList items,
   ListEventSelectArgs e
)
This language is not supported or no code example is available.

Parameters

items

Type: ArrayList

Contains the selected cells

e

Type: ListEventSelectArgs

Contains information about event

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Class
CADListView Members
CADImport.FaceModule Namespace


CADListView.SelectCells Method

Selects a cell or an item by the specified coordinates

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SelectCells( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal fullItem As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SelectCells(
   int x,
   int y,
   bool fullItem
)
This language is not supported or no code example is available.

Parameters

x

Type: int

The X display coordinate

y

Type: int

The Y display coordinate

fullItem

Type: bool

Full item selection

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Class
CADListView Members
CADImport.FaceModule Namespace


CADListView.SetAutoSize Method

Sets columns width; equals the longest row in the column

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetAutoSize()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetAutoSize()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Class
CADListView Members
CADImport.FaceModule Namespace


CADListView Events

CADListView Class See Also

The following tables list the members exposed by the CADListView type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from UserControl).
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (inherited from UserControl).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before the control becomes visible for the first time. (inherited from UserControl).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | Occurs when the control's margin changes. (inherited from Control).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | SelectCellEvent | Occurs on user cell selection.
Public event | SelectItemEvent | Occurs on user item selection.
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (inherited from Control).
Public event | TabStopChanged | Occurs when the TabStop property value changes. (inherited from Control).
Public event | TextChanged | (inherited from UserControl).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

CADListView Class
CADImport.FaceModule Namespace


SelectCellEvent Event

Occurs on user cell selection.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event SelectCellEvent() As CADImport.FaceModule.ListCellSelectEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.FaceModule.ListCellSelectEventHandler SelectCellEvent
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Class
CADListView Members
CADImport.FaceModule Namespace


SelectItemEvent Event

Occurs on user item selection.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event SelectItemEvent() As CADImport.FaceModule.ListItemSelectEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.FaceModule.ListItemSelectEventHandler SelectItemEvent
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADListView Class
CADListView Members
CADImport.FaceModule Namespace


CADPictureBox Class

Members See Also

Represents the advanced PictureBox object with scroll bars

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADPictureBox
    Inherits UserControl
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADPictureBox : UserControl
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
CADImport.FaceModule.CADPictureBox
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPictureBox Members
CADImport.FaceModule Namespace


CADPictureBox Members

CADPictureBox Class Constructors Events Methods Fields Properties See Also

Represents the advanced PictureBox object with scroll bars

The following tables list the members exposed by the CADPictureBox type.

Constructors
 | Name | Description
Public constructor | CADPictureBox | Creates an instance of the CADPictureBox class
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (inherited from ScrollableControl).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from UserControl).
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (inherited from UserControl).
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (inherited from UserControl).
Public property | BackColor | Gets or sets the background color for the control. (inherited from Control).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | BorderSize | Returns border size for this CADPictureBox object.
Public property | BorderStyle | Gets or sets the border style of the tree view control. (inherited from UserControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (inherited from Control).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | DoubleBuffering | Gets or sets Double Buffering mode
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | Grid | Defines the grid for the CADPictureBox instance.
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (inherited from Control).
Public property | Margin | Gets or sets the space between controls. (inherited from Control).
Public property | MaximumSize | Gets or sets the size that is the upper limit that Size) can specify. (inherited from Control).
Public property | MinimumSize | Gets or sets the size that is the lower limit that Size) can specify. (inherited from Control).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Ortho | Defines the ortho mode for the CADPictureBox instance.
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | Position | Gets or sets scroll bars position
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | ScrollBars | Gets or sets a value defining the scrollbars activity.
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the height and width of the control. (inherited from Control).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Control).
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (inherited from Control).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from UserControl).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | VirtualSize | Gets or sets the full image size include the scrolling region
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | OnScroll | Invokes the image scrolling event with scroll bars
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | Set3DStyle | Sets options for OpenGL visualization.
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetGDIStyle | Sets options for GDI+ visualization.
Public method | SetPositionNoInvalidate | Sets a new scrolling position
Public method | SetVirtualSizeNoInvalidate | Sets the new size of the scrolling region
Public method | Show | (Overloaded) Displays the control to the user. (inherited from Control).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (inherited from Component).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from UserControl).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from UserControl).
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (inherited from UserControl).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before the control becomes visible for the first time. (inherited from UserControl).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | Occurs when the control's margin changes. (inherited from Control).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | ScrollEvent | Occurs on changing of the image position with scroll bars
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (inherited from Control).
Public event | TabStopChanged | Occurs when the TabStop property value changes. (inherited from Control).
Public event | TextChanged | (inherited from UserControl).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
Fields
Name | Description
gdiStyle | Represents options for GDI+ visualization.
xnaStyle | Represents options for OpenGL visualization.
Top
See Also

Reference

CADPictureBox Class
CADImport.FaceModule Namespace


CADPictureBox Constructor

Creates an instance of the CADPictureBox class

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADPictureBox()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPictureBox Class
CADPictureBox Members
CADImport.FaceModule Namespace


CADPictureBox Properties

CADPictureBox Class See Also

The following tables list the members exposed by the CADPictureBox type.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (inherited from ScrollableControl).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from UserControl).
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (inherited from UserControl).
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (inherited from UserControl).
Public property | BackColor | Gets or sets the background color for the control. (inherited from Control).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | BorderSize | Returns border size for this CADPictureBox object.
Public property | BorderStyle | Gets or sets the border style of the tree view control. (inherited from UserControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (inherited from Control).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | DoubleBuffering | Gets or sets Double Buffering mode
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | Grid | Defines the grid for the CADPictureBox instance.
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (inherited from Control).
Public property | Margin | Gets or sets the space between controls. (inherited from Control).
Public property | MaximumSize | Gets or sets the size that is the upper limit that Size) can specify. (inherited from Control).
Public property | MinimumSize | Gets or sets the size that is the lower limit that Size) can specify. (inherited from Control).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Ortho | Defines the ortho mode for the CADPictureBox instance.
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | Position | Gets or sets scroll bars position
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | ScrollBars | Gets or sets a value defining the scrollbars activity.
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the height and width of the control. (inherited from Control).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Control).
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (inherited from Control).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from UserControl).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | VirtualSize | Gets or sets the full image size include the scrolling region
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

CADPictureBox Class
CADImport.FaceModule Namespace


CADPictureBox.BorderSize Property

Returns border size for this CADPictureBox object.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property BorderSize() As Size
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Size BorderSize {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPictureBox Class
CADPictureBox Members
CADImport.FaceModule Namespace


CADPictureBox.DoubleBuffering Property

Gets or sets Double Buffering mode

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DoubleBuffering() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool DoubleBuffering {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPictureBox Class
CADPictureBox Members
CADImport.FaceModule Namespace


CADPictureBox.Grid Property

Defines the grid for the CADPictureBox instance.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Grid() As Grid
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Grid Grid {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPictureBox Class
CADPictureBox Members
CADImport.FaceModule Namespace


CADPictureBox.Ortho Property

Defines the ortho mode for the CADPictureBox instance.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Ortho() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Ortho {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPictureBox Class
CADPictureBox Members
CADImport.FaceModule Namespace


CADPictureBox.Position Property

Gets or sets scroll bars position

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Position() As Point
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Point Position {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPictureBox Class
CADPictureBox Members
CADImport.FaceModule Namespace


CADPictureBox.ScrollBars Property

Gets or sets a value defining the scrollbars activity.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ScrollBars() As ScrollBarsShow
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ScrollBarsShow ScrollBars {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPictureBox Class
CADPictureBox Members
CADImport.FaceModule Namespace


CADPictureBox.VirtualSize Property

Gets or sets the full image size include the scrolling region

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property VirtualSize() As Size
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Size VirtualSize {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPictureBox Class
CADPictureBox Members
CADImport.FaceModule Namespace


CADPictureBox Methods

CADPictureBox Class See Also

The following tables list the members exposed by the CADPictureBox type.

Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | OnScroll | Invokes the image scrolling event with scroll bars
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | Set3DStyle | Sets options for OpenGL visualization.
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetGDIStyle | Sets options for GDI+ visualization.
Public method | SetPositionNoInvalidate | Sets a new scrolling position
Public method | SetVirtualSizeNoInvalidate | Sets the new size of the scrolling region
Public method | Show | (Overloaded) Displays the control to the user. (inherited from Control).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (inherited from Component).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from UserControl).
Top
See Also

Reference

CADPictureBox Class
CADImport.FaceModule Namespace


CADPictureBox.OnScroll Method

Invokes the image scrolling event with scroll bars

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnScroll( _
   ByVal sender As Object, _
   ByVal e As ScrollEventArgsExt _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnScroll(
   object sender,
   ScrollEventArgsExt e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The object caused an event

e

Type: ScrollEventArgsExt

Contains event data

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPictureBox Class
CADPictureBox Members
CADImport.FaceModule Namespace


CADPictureBox.Set3DStyle Method

Sets options for OpenGL visualization.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Set3DStyle()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Set3DStyle()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPictureBox Class
CADPictureBox Members
CADImport.FaceModule Namespace


CADPictureBox.SetGDIStyle Method

Sets options for GDI+ visualization.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetGDIStyle()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetGDIStyle()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPictureBox Class
CADPictureBox Members
CADImport.FaceModule Namespace


CADPictureBox.SetPositionNoInvalidate Method

Sets a new scrolling position

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetPositionNoInvalidate( _
   ByVal value As Point _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetPositionNoInvalidate(
   Point value
)
This language is not supported or no code example is available.

Parameters

value

Type: Point

A new position

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPictureBox Class
CADPictureBox Members
CADImport.FaceModule Namespace


CADPictureBox.SetVirtualSizeNoInvalidate Method

Sets the new size of the scrolling region

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetVirtualSizeNoInvalidate( _
   ByVal value As Size _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetVirtualSizeNoInvalidate(
   Size value
)
This language is not supported or no code example is available.

Parameters

value

Type: Size

A new size

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPictureBox Class
CADPictureBox Members
CADImport.FaceModule Namespace


CADPictureBox Events

CADPictureBox Class See Also

The following tables list the members exposed by the CADPictureBox type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from UserControl).
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (inherited from UserControl).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before the control becomes visible for the first time. (inherited from UserControl).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | Occurs when the control's margin changes. (inherited from Control).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | ScrollEvent | Occurs on changing of the image position with scroll bars
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (inherited from Control).
Public event | TabStopChanged | Occurs when the TabStop property value changes. (inherited from Control).
Public event | TextChanged | (inherited from UserControl).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

CADPictureBox Class
CADImport.FaceModule Namespace


ScrollEvent Event

Occurs on changing of the image position with scroll bars

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event ScrollEvent() As CADImport.FaceModule.ScrollEventHandlerExt
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.FaceModule.ScrollEventHandlerExt ScrollEvent
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPictureBox Class
CADPictureBox Members
CADImport.FaceModule Namespace


CADPictureBox Fields

CADPictureBox Class See Also

The following tables list the members exposed by the CADPictureBox type.

Fields
Name | Description
gdiStyle | Represents options for GDI+ visualization.
xnaStyle | Represents options for OpenGL visualization.
Top
See Also

Reference

CADPictureBox Class
CADImport.FaceModule Namespace


gdiStyle Field

Represents options for GDI+ visualization.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared gdiStyle As ControlStyles
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static ControlStyles gdiStyle
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPictureBox Class
CADPictureBox Members
CADImport.FaceModule Namespace


xnaStyle Field

Represents options for OpenGL visualization.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared xnaStyle As ControlStyles
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static ControlStyles xnaStyle
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPictureBox Class
CADPictureBox Members
CADImport.FaceModule Namespace


CADPropertyGrid Class

Members See Also

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADPropertyGrid
    Inherits UserControl
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADPropertyGrid : UserControl
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
CADImport.FaceModule.CADPropertyGrid
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPropertyGrid Members
CADImport.FaceModule Namespace


CADPropertyGrid Members

CADPropertyGrid Class Constructors Events Methods Properties See Also

The following tables list the members exposed by the CADPropertyGrid type.

Constructors
 | Name | Description
Public constructor | CADPropertyGrid |
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (inherited from ScrollableControl).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from UserControl).
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (inherited from UserControl).
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (inherited from UserControl).
Public property | BackColor | Gets or sets the background color for the control. (inherited from Control).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | BorderStyle | Gets or sets the border style of the tree view control. (inherited from UserControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (inherited from Control).
Public property | ComboBox |
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (inherited from Control).
Public property | Margin | Gets or sets the space between controls. (inherited from Control).
Public property | MaximumSize | Gets or sets the size that is the upper limit that Size) can specify. (inherited from Control).
Public property | MinimumSize | Gets or sets the size that is the lower limit that Size) can specify. (inherited from Control).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | Propertygrid |
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | SelectedObject |
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the height and width of the control. (inherited from Control).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Control).
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (inherited from Control).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from UserControl).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | Show | (Overloaded) Displays the control to the user. (inherited from Control).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (inherited from Component).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from UserControl).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from UserControl).
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (inherited from UserControl).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before the control becomes visible for the first time. (inherited from UserControl).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | Occurs when the control's margin changes. (inherited from Control).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | PropertyValueChanged |
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (inherited from Control).
Public event | TabStopChanged | Occurs when the TabStop property value changes. (inherited from Control).
Public event | TextChanged | (inherited from UserControl).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

CADPropertyGrid Class
CADImport.FaceModule Namespace


CADPropertyGrid Constructor

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADPropertyGrid()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPropertyGrid Class
CADPropertyGrid Members
CADImport.FaceModule Namespace


CADPropertyGrid Properties

CADPropertyGrid Class See Also

The following tables list the members exposed by the CADPropertyGrid type.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (inherited from ScrollableControl).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from UserControl).
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (inherited from UserControl).
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (inherited from UserControl).
Public property | BackColor | Gets or sets the background color for the control. (inherited from Control).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | BorderStyle | Gets or sets the border style of the tree view control. (inherited from UserControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (inherited from Control).
Public property | ComboBox |
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (inherited from Control).
Public property | Margin | Gets or sets the space between controls. (inherited from Control).
Public property | MaximumSize | Gets or sets the size that is the upper limit that Size) can specify. (inherited from Control).
Public property | MinimumSize | Gets or sets the size that is the lower limit that Size) can specify. (inherited from Control).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | Propertygrid |
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | SelectedObject |
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the height and width of the control. (inherited from Control).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Control).
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (inherited from Control).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from UserControl).
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

CADPropertyGrid Class
CADImport.FaceModule Namespace


CADPropertyGrid.ComboBox Property

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property ComboBox() As ComboBox
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ComboBox ComboBox {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPropertyGrid Class
CADPropertyGrid Members
CADImport.FaceModule Namespace


CADPropertyGrid.Propertygrid Property

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Propertygrid() As PropertyGrid
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public PropertyGrid Propertygrid {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPropertyGrid Class
CADPropertyGrid Members
CADImport.FaceModule Namespace


CADPropertyGrid.SelectedObject Property

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public WriteOnly Property SelectedObject() As Object
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public object SelectedObject {set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPropertyGrid Class
CADPropertyGrid Members
CADImport.FaceModule Namespace


CADPropertyGrid Methods

CADPropertyGrid Class See Also

The following tables list the members exposed by the CADPropertyGrid type.

Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | Show | (Overloaded) Displays the control to the user. (inherited from Control).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (inherited from Component).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from UserControl).
Top
See Also

Reference

CADPropertyGrid Class
CADImport.FaceModule Namespace


CADPropertyGrid Events

CADPropertyGrid Class See Also

The following tables list the members exposed by the CADPropertyGrid type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from UserControl).
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (inherited from UserControl).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before the control becomes visible for the first time. (inherited from UserControl).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | Occurs when the control's margin changes. (inherited from Control).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | PropertyValueChanged |
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (inherited from Control).
Public event | TabStopChanged | Occurs when the TabStop property value changes. (inherited from Control).
Public event | TextChanged | (inherited from UserControl).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

CADPropertyGrid Class
CADImport.FaceModule Namespace


PropertyValueChanged Event

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event PropertyValueChanged() As System.Windows.Forms.PropertyValueChangedEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event System.Windows.Forms.PropertyValueChangedEventHandler PropertyValueChanged
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPropertyGrid Class
CADPropertyGrid Members
CADImport.FaceModule Namespace


ClipRect Class

Members See Also

Represents the Rectangle tool.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class ClipRect
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class ClipRect
This language is not supported or no code example is available.
Remarks

The Rectangle tool is a visual tool for selecting an area, its zooming and possible subsequent saving.

Inheritance Hierarchy
System.Object
CADImport.FaceModule.ClipRect
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ClipRect Members
CADImport.FaceModule Namespace


ClipRect Members

ClipRect Class Constructors Methods Properties See Also

Represents the Rectangle tool.

The following tables list the members exposed by the ClipRect type.

Constructors
 | Name | Description
Public constructor | ClipRect | (Overloaded) Initializes a new instance of the ClipRect class.
Top
Properties
 | Name | Description
Public property | ClientRectangle | Gets or sets an image area selected by the Rectangle tool.
Public property | Color | Gets or sets a color of the Rectangle tool's bounding lines.
Public property | Enabled | Gets a value indicating whether the Rectangle tool is enabled.
Public property | MarkerSize | Gets or sets the markers' size of the Rectangle tool.
Public property | MultySelect | Gets or sets the multiple selection mode
Public property | Type | Gets or sets a working mode for the Rectangle tool.
Top
Methods
 | Name | Description
Public method | DisableRect | Disables the Rectangle tool.
Public method | EnableRect | (Overloaded) Enables the Rectangle tool.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

ClipRect Class
CADImport.FaceModule Namespace


ClipRect Constructor

ClipRect Class See Also

Initializes a new instance of the ClipRect class.

Overload List
Name | Description
ClipRect(Control) | Initializes a new instance of the ClipRect class.
ClipRect(Control, Rectangle, Color) | Initializes a new instance of the ClipRect class.
See Also

Reference

ClipRect Class
ClipRect Members
CADImport.FaceModule Namespace


ClipRect Properties

ClipRect Class See Also

The following tables list the members exposed by the ClipRect type.

Properties
 | Name | Description
Public property | ClientRectangle | Gets or sets an image area selected by the Rectangle tool.
Public property | Color | Gets or sets a color of the Rectangle tool's bounding lines.
Public property | Enabled | Gets a value indicating whether the Rectangle tool is enabled.
Public property | MarkerSize | Gets or sets the markers' size of the Rectangle tool.
Public property | MultySelect | Gets or sets the multiple selection mode
Public property | Type | Gets or sets a working mode for the Rectangle tool.
Top
See Also

Reference

ClipRect Class
CADImport.FaceModule Namespace


ClipRect.ClientRectangle Property

Gets or sets an image area selected by the Rectangle tool.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ClientRectangle() As Rectangle
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Rectangle ClientRectangle {get; set;}
This language is not supported or no code example is available.

Property Value

A Rectangle object representing an image area selected by the Rectangle tool.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ClipRect Class
ClipRect Members
CADImport.FaceModule Namespace


ClipRect.Color Property

Gets or sets a color of the Rectangle tool's bounding lines.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Color() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Color Color {get; set;}
This language is not supported or no code example is available.

Property Value

A Color of the Rectangle tool's bounding lines.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ClipRect Class
ClipRect Members
CADImport.FaceModule Namespace


ClipRect.Enabled Property

Gets a value indicating whether the Rectangle tool is enabled.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Enabled() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Enabled {get;}
This language is not supported or no code example is available.

Property Value

A boolean value indicating whether the Rectangle tool is enabled.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ClipRect Class
ClipRect Members
CADImport.FaceModule Namespace


ClipRect.MarkerSize Property

Gets or sets the markers' size of the Rectangle tool.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property MarkerSize() As Size
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Size MarkerSize {get; set;}
This language is not supported or no code example is available.

Property Value

A Size of the Rectangle tool's markers.
Remarks

The markers' size is set in pixels.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ClipRect Class
ClipRect Members
CADImport.FaceModule Namespace


ClipRect.MultySelect Property

Gets or sets the multiple selection mode

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property MultySelect() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool MultySelect {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ClipRect Class
ClipRect Members
CADImport.FaceModule Namespace


ClipRect.Type Property

Gets or sets a working mode for the Rectangle tool.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Type() As RectangleType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public RectangleType Type {get; set;}
This language is not supported or no code example is available.

Property Value

A RectangleType value.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ClipRect Class
ClipRect Members
CADImport.FaceModule Namespace


ClipRect Methods

ClipRect Class See Also

The following tables list the members exposed by the ClipRect type.

Methods
 | Name | Description
Public method | DisableRect | Disables the Rectangle tool.
Public method | EnableRect | (Overloaded) Enables the Rectangle tool.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

ClipRect Class
CADImport.FaceModule Namespace


ClipRect.DisableRect Method

Disables the Rectangle tool.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DisableRect()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DisableRect()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ClipRect Class
ClipRect Members
CADImport.FaceModule Namespace


ClipRect.EnableRect Method

ClipRect Class See Also

Enables the Rectangle tool.

Overload List
Name | Description
EnableRect(RectangleType) | Enables the Rectangle tool.
EnableRect(RectangleType, Rectangle) | Enables the Rectangle tool.
See Also

Reference

ClipRect Class
ClipRect Members
CADImport.FaceModule Namespace


Grid Class

Members See Also

Represents the grid object for a control.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class Grid
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class Grid
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.FaceModule.Grid
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Grid Members
CADImport.FaceModule Namespace


Grid Members

Grid Class Constructors Methods Properties See Also

Represents the grid object for a control.

The following tables list the members exposed by the Grid type.

Constructors
 | Name | Description
Public constructor | Grid | Creates a new instance of the Grid class
Top
Properties
 | Name | Description
Public property | CellScreenSize | Gets or sets the size of the grid cell on screen. Takes effect when step of the greed on screen is not enough for good resolution. <remarks>The value must belong to interval from 10 to 100. Default value is 30.</remarks>
Public property | Color | Gets or sets a color for the grid.
Public property | IsActive | Displays grid object activity state
Public property | StepX | Gets or sets the grid step by X axis
Public property | StepY | Gets or sets the grid step by Y axis
Top
Methods
 | Name | Description
Public method | Activate | Activates the grid object
Public method | Deactivate | Deactivates the grid object
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

Grid Class
CADImport.FaceModule Namespace


Grid Constructor

Creates a new instance of the Grid class

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal owner As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Grid(
   Control owner
)
This language is not supported or no code example is available.

Parameters

owner

Type: Control

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Grid Class
Grid Members
CADImport.FaceModule Namespace


Grid Properties

Grid Class See Also

The following tables list the members exposed by the Grid type.

Properties
 | Name | Description
Public property | CellScreenSize | Gets or sets the size of the grid cell on screen. Takes effect when step of the greed on screen is not enough for good resolution. <remarks>The value must belong to interval from 10 to 100. Default value is 30.</remarks>
Public property | Color | Gets or sets a color for the grid.
Public property | IsActive | Displays grid object activity state
Public property | StepX | Gets or sets the grid step by X axis
Public property | StepY | Gets or sets the grid step by Y axis
Top
See Also

Reference

Grid Class
CADImport.FaceModule Namespace


Grid.CellScreenSize Property

Gets or sets the size of the grid cell on screen. Takes effect when step of the greed on screen is not enough for good resolution. <remarks>The value must belong to interval from 10 to 100. Default value is 30.</remarks>

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property CellScreenSize() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int CellScreenSize {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Grid Class
Grid Members
CADImport.FaceModule Namespace


Grid.Color Property

Gets or sets a color for the grid.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Color() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Color Color {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Grid Class
Grid Members
CADImport.FaceModule Namespace


Grid.IsActive Property

Displays grid object activity state

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property IsActive() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsActive {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Grid Class
Grid Members
CADImport.FaceModule Namespace


Grid.StepX Property

Gets or sets the grid step by X axis

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property StepX() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double StepX {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Grid Class
Grid Members
CADImport.FaceModule Namespace


Grid.StepY Property

Gets or sets the grid step by Y axis

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property StepY() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double StepY {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Grid Class
Grid Members
CADImport.FaceModule Namespace


Grid Methods

Grid Class See Also

The following tables list the members exposed by the Grid type.

Methods
 | Name | Description
Public method | Activate | Activates the grid object
Public method | Deactivate | Deactivates the grid object
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

Grid Class
CADImport.FaceModule Namespace


Grid.Activate Method

Activates the grid object

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Activate()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Activate()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Grid Class
Grid Members
CADImport.FaceModule Namespace


Grid.Deactivate Method

Deactivates the grid object

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Deactivate()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Deactivate()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Grid Class
Grid Members
CADImport.FaceModule Namespace


ListEventSelectArgs Class

Members See Also

Contains parameters of cell selection event

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class ListEventSelectArgs
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class ListEventSelectArgs
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.FaceModule.ListEventSelectArgs
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListEventSelectArgs Members
CADImport.FaceModule Namespace


ListEventSelectArgs Members

ListEventSelectArgs Class Constructors Methods Properties See Also

Contains parameters of cell selection event

The following tables list the members exposed by the ListEventSelectArgs type.

Constructors
 | Name | Description
Public constructor | ListEventSelectArgs | (Overloaded) Creates ListEventSelectArgs class instance
Top
Properties
 | Name | Description
Public property | ItemIndex | An index of the cell in collection
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

ListEventSelectArgs Class
CADImport.FaceModule Namespace


ListEventSelectArgs Constructor

ListEventSelectArgs Class See Also

Creates ListEventSelectArgs class instance

Overload List
Name | Description
ListEventSelectArgs() | Creates ListEventSelectArgs class instance
ListEventSelectArgs(int) | Creates ListEventSelectArgs class instance
See Also

Reference

ListEventSelectArgs Class
ListEventSelectArgs Members
CADImport.FaceModule Namespace


ListEventSelectArgs Properties

ListEventSelectArgs Class See Also

The following tables list the members exposed by the ListEventSelectArgs type.

Properties
 | Name | Description
Public property | ItemIndex | An index of the cell in collection
Top
See Also

Reference

ListEventSelectArgs Class
CADImport.FaceModule Namespace


ListEventSelectArgs.ItemIndex Property

An index of the cell in collection

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property ItemIndex() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int ItemIndex {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListEventSelectArgs Class
ListEventSelectArgs Members
CADImport.FaceModule Namespace


ListEventSelectArgs Methods

ListEventSelectArgs Class See Also

The following tables list the members exposed by the ListEventSelectArgs type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

ListEventSelectArgs Class
CADImport.FaceModule Namespace


ListHeader Class

Members See Also

Represents the CADListView header cell

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class ListHeader
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class ListHeader
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.FaceModule.ListHeader
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListHeader Members
CADImport.FaceModule Namespace


ListHeader Members

ListHeader Class Constructors Methods Properties See Also

Represents the CADListView header cell

The following tables list the members exposed by the ListHeader type.

Constructors
 | Name | Description
Public constructor | ListHeader | (Overloaded) Initializes a new instance of the ListHeader class.
Top
Properties
 | Name | Description
Public property | Index | Gets or sets a column number
Public property | Name | Gets or sets a column name
Public property | Text | Gets or sets a column header text
Public property | Width | Gets or sets a column width
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

ListHeader Class
CADImport.FaceModule Namespace


ListHeader Constructor

ListHeader Class See Also

Initializes a new instance of the ListHeader class.

Overload List
Name | Description
ListHeader() | Initializes a new instance of the ListHeader class.
ListHeader(string, string, int) | Initializes a new instance of the ListHeader class.
See Also

Reference

ListHeader Class
ListHeader Members
CADImport.FaceModule Namespace


ListHeader Properties

ListHeader Class See Also

The following tables list the members exposed by the ListHeader type.

Properties
 | Name | Description
Public property | Index | Gets or sets a column number
Public property | Name | Gets or sets a column name
Public property | Text | Gets or sets a column header text
Public property | Width | Gets or sets a column width
Top
See Also

Reference

ListHeader Class
CADImport.FaceModule Namespace


ListHeader.Index Property

Gets or sets a column number

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Index() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Index {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListHeader Class
ListHeader Members
CADImport.FaceModule Namespace


ListHeader.Name Property

Gets or sets a column name

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Name() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Name {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListHeader Class
ListHeader Members
CADImport.FaceModule Namespace


ListHeader.Text Property

Gets or sets a column header text

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Text() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Text {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListHeader Class
ListHeader Members
CADImport.FaceModule Namespace


ListHeader.Width Property

Gets or sets a column width

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Width() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Width {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListHeader Class
ListHeader Members
CADImport.FaceModule Namespace


ListHeader Methods

ListHeader Class See Also

The following tables list the members exposed by the ListHeader type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

ListHeader Class
CADImport.FaceModule Namespace


ListHeaderCollection Class

Members See Also

Represents the CADListView headers collection

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class ListHeaderCollection
    Inherits CollectionBase
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class ListHeaderCollection : CollectionBase
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Collections.CollectionBase
CADImport.FaceModule.ListHeaderCollection
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListHeaderCollection Members
CADImport.FaceModule Namespace


ListHeaderCollection Members

ListHeaderCollection Class Methods Properties See Also

Represents the CADListView headers collection

The following tables list the members exposed by the ListHeaderCollection type.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase).
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase).
Public property | Item | Gets or sets a ListHeader object at the specified index in the collection.
Top
Methods
 | Name | Description
Public method | Add | Adds a ListHeader to the ListHeaderCollection.
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase).
Public method | Contains | Determines whether the collection contains the specified ListHeader.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IndexOf | Determines the index of the specified ListHeader in the collection.
Public method | Insert | Inserts a ListHeader into the collection at the specified position.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Remove | Removes the first occurrence of the specified ListHeader from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

ListHeaderCollection Class
CADImport.FaceModule Namespace


ListHeaderCollection Properties

ListHeaderCollection Class See Also

The following tables list the members exposed by the ListHeaderCollection type.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase).
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase).
Public property | Item | Gets or sets a ListHeader object at the specified index in the collection.
Top
See Also

Reference

ListHeaderCollection Class
CADImport.FaceModule Namespace


ListHeaderCollection.Item Property

Gets or sets a ListHeader object at the specified index in the collection.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Item( _
   ByVal index As Integer _
) As ListHeader
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ListHeader this[
   int index
] {get; set;}
This language is not supported or no code example is available.

Parameters

index

Type: int

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListHeaderCollection Class
ListHeaderCollection Members
CADImport.FaceModule Namespace


ListHeaderCollection Methods

ListHeaderCollection Class See Also

The following tables list the members exposed by the ListHeaderCollection type.

Methods
 | Name | Description
Public method | Add | Adds a ListHeader to the ListHeaderCollection.
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase).
Public method | Contains | Determines whether the collection contains the specified ListHeader.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IndexOf | Determines the index of the specified ListHeader in the collection.
Public method | Insert | Inserts a ListHeader into the collection at the specified position.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Remove | Removes the first occurrence of the specified ListHeader from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

ListHeaderCollection Class
CADImport.FaceModule Namespace


ListHeaderCollection.Add Method

Adds a ListHeader to the ListHeaderCollection.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Add( _
   ByVal value As ListHeader _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Add(
   ListHeader value
)
This language is not supported or no code example is available.

Parameters

value

Type: ListHeader

A ListHeader object to add to the collection.

Return Value

The position into which the new ListHeader was inserted.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListHeaderCollection Class
ListHeaderCollection Members
CADImport.FaceModule Namespace


ListHeaderCollection.Contains Method

Determines whether the collection contains the specified ListHeader.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Contains( _
   ByVal value As ListHeader _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Contains(
   ListHeader value
)
This language is not supported or no code example is available.

Parameters

value

Type: ListHeader

A ListHeader to locate in the collection.

Return Value

true if the ListHeader is found in the collection; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListHeaderCollection Class
ListHeaderCollection Members
CADImport.FaceModule Namespace


ListHeaderCollection.IndexOf Method

Determines the index of the specified ListHeader in the collection.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function IndexOf( _
   ByVal value As ListHeader _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int IndexOf(
   ListHeader value
)
This language is not supported or no code example is available.

Parameters

value

Type: ListHeader

A ListHeader to locate in the collection.

Return Value

The index of the ListHeader if found in the collection; otherwise, -1.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListHeaderCollection Class
ListHeaderCollection Members
CADImport.FaceModule Namespace


ListHeaderCollection.Insert Method

Inserts a ListHeader into the collection at the specified position.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As ListHeader _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Insert(
   int index,
   ListHeader value
)
This language is not supported or no code example is available.

Parameters

index

Type: int

The zero-based index at which the ListHeader will be inserted.

value

Type: ListHeader

The ListHeader to insert into the collection.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListHeaderCollection Class
ListHeaderCollection Members
CADImport.FaceModule Namespace


ListHeaderCollection.Remove Method

Removes the first occurrence of the specified ListHeader from the collection.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Remove( _
   ByVal value As ListHeader _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Remove(
   ListHeader value
)
This language is not supported or no code example is available.

Parameters

value

Type: ListHeader

A ListHeader to remove from the collection.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListHeaderCollection Class
ListHeaderCollection Members
CADImport.FaceModule Namespace


ListItem Class

Members See Also

Represents the CADListView cell

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class ListItem
    Implements ICloneable
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class ListItem : ICloneable
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.FaceModule.ListItem
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListItem Members
CADImport.FaceModule Namespace


ListItem Members

ListItem Class Constructors Events Methods Properties See Also

Represents the CADListView cell

The following tables list the members exposed by the ListItem type.

Constructors
 | Name | Description
Public constructor | ListItem | Initializes a new instance of the ListItem class.
Top
Properties
 | Name | Description
Public property | BackColor | Gets or sets the background color of cells
Public property | DrawColorRect | Gets or sets necessity of color rectangle drawing in the current cell
Public property | Image | Gets or sets the image of an item.
Public property | ImageIndex | Gets or sets a cell number
Public property | ImageRect | Gets or sets borders of the image, drawn in a cell
Public property | Selected | Gets or sets selection of the current cell
Public property | Text | Gets or sets an item text
Public property | TextInVisible | Gets or sets text visibility in a cell
Top
Methods
 | Name | Description
Public method | Clear | Clears the ListItem object.
Public method | Clone | Creates a copy of the ListItem object
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | OnDrawCell | Invokes the DrawCellEvent event.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Events
 | Name | Description
Public event | DrawCellEvent | Occurs on CADListView cell drawing method.
Top
See Also

Reference

ListItem Class
CADImport.FaceModule Namespace


ListItem Constructor

Initializes a new instance of the ListItem class.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ListItem()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListItem Class
ListItem Members
CADImport.FaceModule Namespace


ListItem Properties

ListItem Class See Also

The following tables list the members exposed by the ListItem type.

Properties
 | Name | Description
Public property | BackColor | Gets or sets the background color of cells
Public property | DrawColorRect | Gets or sets necessity of color rectangle drawing in the current cell
Public property | Image | Gets or sets the image of an item.
Public property | ImageIndex | Gets or sets a cell number
Public property | ImageRect | Gets or sets borders of the image, drawn in a cell
Public property | Selected | Gets or sets selection of the current cell
Public property | Text | Gets or sets an item text
Public property | TextInVisible | Gets or sets text visibility in a cell
Top
See Also

Reference

ListItem Class
CADImport.FaceModule Namespace


ListItem.BackColor Property

Gets or sets the background color of cells

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property BackColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Color BackColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListItem Class
ListItem Members
CADImport.FaceModule Namespace


ListItem.DrawColorRect Property

Gets or sets necessity of color rectangle drawing in the current cell

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DrawColorRect() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool DrawColorRect {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListItem Class
ListItem Members
CADImport.FaceModule Namespace


ListItem.Image Property

Gets or sets the image of an item.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Image() As Image
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Image Image {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListItem Class
ListItem Members
CADImport.FaceModule Namespace


ListItem.ImageIndex Property

Gets or sets a cell number

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ImageIndex() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int ImageIndex {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListItem Class
ListItem Members
CADImport.FaceModule Namespace


ListItem.ImageRect Property

Gets or sets borders of the image, drawn in a cell

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ImageRect() As Rectangle
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Rectangle ImageRect {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListItem Class
ListItem Members
CADImport.FaceModule Namespace


ListItem.Selected Property

Gets or sets selection of the current cell

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Selected() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Selected {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListItem Class
ListItem Members
CADImport.FaceModule Namespace


ListItem.Text Property

Gets or sets an item text

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Text() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Text {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListItem Class
ListItem Members
CADImport.FaceModule Namespace


ListItem.TextInVisible Property

Gets or sets text visibility in a cell

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TextInVisible() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool TextInVisible {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListItem Class
ListItem Members
CADImport.FaceModule Namespace


ListItem Methods

ListItem Class See Also

The following tables list the members exposed by the ListItem type.

Methods
 | Name | Description
Public method | Clear | Clears the ListItem object.
Public method | Clone | Creates a copy of the ListItem object
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | OnDrawCell | Invokes the DrawCellEvent event.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

ListItem Class
CADImport.FaceModule Namespace


ListItem.Clear Method

Clears the ListItem object.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Clear()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Clear()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListItem Class
ListItem Members
CADImport.FaceModule Namespace


ListItem.Clone Method

Creates a copy of the ListItem object

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Clone() As Object Implements  _
   ICloneable.Clone
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public object Clone()
This language is not supported or no code example is available.

Implements

ICloneable.Clone
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListItem Class
ListItem Members
CADImport.FaceModule Namespace


ListItem.OnDrawCell Method

Invokes the DrawCellEvent event.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnDrawCell( _
   ByVal graph As Graphics, _
   ByVal posX As Integer, _
   ByVal posY As Integer, _
   ByVal sizeX As Integer, _
   ByVal sizeY As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnDrawCell(
   Graphics graph,
   int posX,
   int posY,
   int sizeX,
   int sizeY
)
This language is not supported or no code example is available.

Parameters

graph

Type: Graphics

Graphics drawing object

posX

Type: int

The cell x-position

posY

Type: int

The cell y-position

sizeX

Type: int

The cell x-size

sizeY

Type: int

The cell y-size

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListItem Class
ListItem Members
CADImport.FaceModule Namespace


ListItem Events

ListItem Class See Also

The following tables list the members exposed by the ListItem type.

Events
 | Name | Description
Public event | DrawCellEvent | Occurs on CADListView cell drawing method.
Top
See Also

Reference

ListItem Class
CADImport.FaceModule Namespace


DrawCellEvent Event

Occurs on CADListView cell drawing method.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event DrawCellEvent() As CADImport.FaceModule.DrawListItemCell
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.FaceModule.DrawListItemCell DrawCellEvent
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListItem Class
ListItem Members
CADImport.FaceModule Namespace


ListItemCollection Class

Members See Also

Represents the CADListView cells collection

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class ListItemCollection
    Inherits CollectionBase
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class ListItemCollection : CollectionBase
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Collections.CollectionBase
CADImport.FaceModule.ListItemCollection
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListItemCollection Members
CADImport.FaceModule Namespace


ListItemCollection Members

ListItemCollection Class Methods Properties See Also

Represents the CADListView cells collection

The following tables list the members exposed by the ListItemCollection type.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase).
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase).
Public property | Item | Gets or sets a ListItem object at the specified index in the collection.
Top
Methods
 | Name | Description
Public method | Add | Adds a ListItem to the ListItemCollection.
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase).
Public method | Contains | Determines whether the collection contains the specified ListItem.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IndexOf | Determines the index of the specified ListItem in the collection.
Public method | Insert | Inserts a ListItem into the collection at the specified position.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Remove | Removes the first occurrence of the specified ListItem from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

ListItemCollection Class
CADImport.FaceModule Namespace


ListItemCollection Properties

ListItemCollection Class See Also

The following tables list the members exposed by the ListItemCollection type.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase).
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase).
Public property | Item | Gets or sets a ListItem object at the specified index in the collection.
Top
See Also

Reference

ListItemCollection Class
CADImport.FaceModule Namespace


ListItemCollection.Item Property

Gets or sets a ListItem object at the specified index in the collection.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Item( _
   ByVal index As Integer _
) As ListItem
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ListItem this[
   int index
] {get; set;}
This language is not supported or no code example is available.

Parameters

index

Type: int

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListItemCollection Class
ListItemCollection Members
CADImport.FaceModule Namespace


ListItemCollection Methods

ListItemCollection Class See Also

The following tables list the members exposed by the ListItemCollection type.

Methods
 | Name | Description
Public method | Add | Adds a ListItem to the ListItemCollection.
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase).
Public method | Contains | Determines whether the collection contains the specified ListItem.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IndexOf | Determines the index of the specified ListItem in the collection.
Public method | Insert | Inserts a ListItem into the collection at the specified position.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Remove | Removes the first occurrence of the specified ListItem from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

ListItemCollection Class
CADImport.FaceModule Namespace


ListItemCollection.Add Method

Adds a ListItem to the ListItemCollection.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Add( _
   ByVal value As ListItem _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Add(
   ListItem value
)
This language is not supported or no code example is available.

Parameters

value

Type: ListItem

A ListItem object to add to the collection.

Return Value

The position into which the new ListItem was inserted.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListItemCollection Class
ListItemCollection Members
CADImport.FaceModule Namespace


ListItemCollection.Contains Method

Determines whether the collection contains the specified ListItem.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Contains( _
   ByVal value As ListItem _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Contains(
   ListItem value
)
This language is not supported or no code example is available.

Parameters

value

Type: ListItem

A ListItem to locate in the collection.

Return Value

true if the ListItem is found in the collection; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListItemCollection Class
ListItemCollection Members
CADImport.FaceModule Namespace


ListItemCollection.IndexOf Method

Determines the index of the specified ListItem in the collection.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function IndexOf( _
   ByVal value As ListItem _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int IndexOf(
   ListItem value
)
This language is not supported or no code example is available.

Parameters

value

Type: ListItem

A ListItem to locate in the collection.

Return Value

The index of the ListItem if found in the collection; otherwise, -1.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListItemCollection Class
ListItemCollection Members
CADImport.FaceModule Namespace


ListItemCollection.Insert Method

Inserts a ListItem into the collection at the specified position.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As ListItem _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Insert(
   int index,
   ListItem value
)
This language is not supported or no code example is available.

Parameters

index

Type: int

The zero-based index at which the ListItem should be inserted.

value

Type: ListItem

The ListItem to insert into the collection.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListItemCollection Class
ListItemCollection Members
CADImport.FaceModule Namespace


ListItemCollection.Remove Method

Removes the first occurrence of the specified ListItem from the collection.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Remove( _
   ByVal value As ListItem _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Remove(
   ListItem value
)
This language is not supported or no code example is available.

Parameters

value

Type: ListItem

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListItemCollection Class
ListItemCollection Members
CADImport.FaceModule Namespace


MultipleLanguage Class

Members See Also

Provides support for multiple languages.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class MultipleLanguage
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class MultipleLanguage
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.FaceModule.MultipleLanguage
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultipleLanguage Members
CADImport.FaceModule Namespace


MultipleLanguage Members

MultipleLanguage Class Constructors Methods Properties See Also

Provides support for multiple languages.

The following tables list the members exposed by the MultipleLanguage type.

Constructors
 | Name | Description
Public constructor | MultipleLanguage | Initializes a new instance of the MultipleLanguage class.
Top
Properties
 | Name | Description
Public property | Language | Gets a string containing a name of the current language.
Public property | LanguagesList | Gets an array containing the names of the supported languages.
Public property | LngFilesList | Gets or sets a list of all texts used for the user interface in the current language.
Public property | Path | Gets or sets a string containing a path to the directory where to look for files of language support.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadLNG | (Overloaded) Loads a specified file of the language support.
Public method | LoadLngFileList | Creates a list of the supported languages.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RestoreLanguage | Translates all texts of the user interface into the default language.
Public method | SaveNameMenuItem | Temporarily saves the text contents of all menu items.
Public method | SaveNameNoNameElement | Temporarily saves the text contents of the controls without names.
Public method | SetLanguage | Translates all texts of the user interface into the current language.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

MultipleLanguage Class
CADImport.FaceModule Namespace


MultipleLanguage Constructor

Initializes a new instance of the MultipleLanguage class.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal aVal As Type _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public MultipleLanguage(
   Type aVal
)
This language is not supported or no code example is available.

Parameters

aVal

Type: Type

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultipleLanguage Class
MultipleLanguage Members
CADImport.FaceModule Namespace


MultipleLanguage Properties

MultipleLanguage Class See Also

The following tables list the members exposed by the MultipleLanguage type.

Properties
 | Name | Description
Public property | Language | Gets a string containing a name of the current language.
Public property | LanguagesList | Gets an array containing the names of the supported languages.
Public property | LngFilesList | Gets or sets a list of all texts used for the user interface in the current language.
Public property | Path | Gets or sets a string containing a path to the directory where to look for files of language support.
Top
See Also

Reference

MultipleLanguage Class
CADImport.FaceModule Namespace


MultipleLanguage.Language Property

Gets a string containing a name of the current language.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Language() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Language {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultipleLanguage Class
MultipleLanguage Members
CADImport.FaceModule Namespace


MultipleLanguage.LanguagesList Property

Gets an array containing the names of the supported languages.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property LanguagesList() As String()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string[] LanguagesList {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultipleLanguage Class
MultipleLanguage Members
CADImport.FaceModule Namespace


MultipleLanguage.LngFilesList Property

Gets or sets a list of all texts used for the user interface in the current language.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LngFilesList() As SortedList
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SortedList LngFilesList {get; set;}
This language is not supported or no code example is available.
Remarks

This list contains pairs of key and value. English text is used as a key. A translation of this text into the current language is used as a corresponding value.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultipleLanguage Class
MultipleLanguage Members
CADImport.FaceModule Namespace


MultipleLanguage.Path Property

Gets or sets a string containing a path to the directory where to look for files of language support.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Path() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Path {get; set;}
This language is not supported or no code example is available.
Remarks

If the specified directory doesn't contain files of language support, the application will look for them in the application's current directory.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultipleLanguage Class
MultipleLanguage Members
CADImport.FaceModule Namespace


MultipleLanguage Methods

MultipleLanguage Class See Also

The following tables list the members exposed by the MultipleLanguage type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadLNG | (Overloaded) Loads a specified file of the language support.
Public method | LoadLngFileList | Creates a list of the supported languages.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RestoreLanguage | Translates all texts of the user interface into the default language.
Public method | SaveNameMenuItem | Temporarily saves the text contents of all menu items.
Public method | SaveNameNoNameElement | Temporarily saves the text contents of the controls without names.
Public method | SetLanguage | Translates all texts of the user interface into the current language.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

MultipleLanguage Class
CADImport.FaceModule Namespace


MultipleLanguage.LoadLNG Method

MultipleLanguage Class See Also

Loads a specified file of the language support.

Overload List
Name | Description
LoadLNG(Stream, string) | Loads a specified file of the language support.
LoadLNG(string) | Loads a specified file of the language support.
See Also

Reference

MultipleLanguage Class
MultipleLanguage Members
CADImport.FaceModule Namespace


MultipleLanguage.LoadLngFileList Method

Creates a list of the supported languages.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub LoadLngFileList( _
   ByVal aMenu As Menu, _
   ByVal aProc As EventHandler _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void LoadLngFileList(
   Menu aMenu,
   EventHandler aProc
)
This language is not supported or no code example is available.

Parameters

aMenu

Type: Menu

A Menu that will contain a list of the supported languages.

aProc

Type: EventHandler

An EventHandler that handles the Click event.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultipleLanguage Class
MultipleLanguage Members
CADImport.FaceModule Namespace


MultipleLanguage.RestoreLanguage Method

Translates all texts of the user interface into the default language.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub RestoreLanguage( _
   ByVal aControls As ControlCollection, _
   ByVal aMenu As MainMenu _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void RestoreLanguage(
   ControlCollection aControls,
   MainMenu aMenu
)
This language is not supported or no code example is available.

Parameters

aControls

Type: ControlCollection

A collection of all controls that form the user interface.

aMenu

Type: MainMenu

A menu of the main application's form.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultipleLanguage Class
MultipleLanguage Members
CADImport.FaceModule Namespace


MultipleLanguage.SaveNameMenuItem Method

Temporarily saves the text contents of all menu items.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SaveNameMenuItem( _
   ByVal aMenu As MenuItemCollection _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SaveNameMenuItem(
   MenuItemCollection aMenu
)
This language is not supported or no code example is available.

Parameters

aMenu

Type: MenuItemCollection

A collection of menu items from all menus in the user interface.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultipleLanguage Class
MultipleLanguage Members
CADImport.FaceModule Namespace


MultipleLanguage.SaveNameNoNameElement Method

Temporarily saves the text contents of the controls without names.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SaveNameNoNameElement( _
   ByVal aControls As ControlCollection _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SaveNameNoNameElement(
   ControlCollection aControls
)
This language is not supported or no code example is available.

Parameters

aControls

Type: ControlCollection

A collection of all controls that form the user interface.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultipleLanguage Class
MultipleLanguage Members
CADImport.FaceModule Namespace


MultipleLanguage.SetLanguage Method

Translates all texts of the user interface into the current language.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function SetLanguage( _
   ByVal aControls As ControlCollection, _
   ByVal aMenu As MainMenu, _
   ByVal aCaption As String _
) As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string SetLanguage(
   ControlCollection aControls,
   MainMenu aMenu,
   string aCaption
)
This language is not supported or no code example is available.

Parameters

aControls

Type: ControlCollection

A collection of all controls that form the user interface.

aMenu

Type: MainMenu

A menu of the main application's form.

aCaption

Type: string

A string containing a caption of the main application's form.

Return Value

A string containing a caption of the main application's form translated into the current language.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultipleLanguage Class
MultipleLanguage Members
CADImport.FaceModule Namespace


Orbit3D Class

Members See Also

Provides a possibility of drawing's rotation.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class Orbit3D
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class Orbit3D
This language is not supported or no code example is available.
Remarks

<p>A drawing for rotation is set by the CADImage property of the Orbit3D class. When the Visible property is set to true, a 3D Orbit tool is displayed within the active viewport. After that you may rotate the drawing.</p> <p>Note: It’s necessary to set the Parent property that returns a control on which the CAD image is drawn. If a resizing the drawing is necessary call Draw method with new parameters.</p> <p>Click and drag the cursor to rotate the image. When you move your cursor over different parts of the 3D Orbit tool, the cursor icon changes. When you click to start dragging the appearance of your cursor indicates the rotation of the image as follows:</p> <p>A small sphere encircled by two lines is the cursor icon displayed when you move the cursor inside the 3D Orbit tool. When the cursor is a sphere you can manipulate the image by clicking and dragging. It works as if your cursor grabs a sphere surrounding the objects and drags the sphere around the target point. You can drag horizontally, vertically, and diagonally.</p> <p>A circular arrow around a small sphere is the cursor icon displayed when you move the cursor outside the 3D Orbit tool. Clicking outside the 3D Orbit tool and dragging the cursor around it moves the image around an axis that extends through the center of the 3D Orbit tool, perpendicular to the screen. This is called a "roll".</p> <p>A horizontal ellipse around a small sphere is the cursor icon displayed when you move the cursor over one of the smaller circles on the left or right side of the 3D Orbit tool. Clicking and dragging from either of these points rotates the image around the vertical or Y axis that extends through the center of the 3D Orbit tool. The Y axis is represented by a vertical line on the cursor.</p> <p>A vertical ellipse around a small sphere is the cursor displayed when you move the cursor over one of the smaller circles on the top or bottom of the 3D Orbit tool. Clicking and dragging from either of these points rotates the image around the horizontal or X axis that extends through the center of the 3D Orbit tool. The X axis is represented by a horizontal line on the cursor .</p>

Inheritance Hierarchy
System.Object
CADImport.FaceModule.Orbit3D
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Orbit3D Members
CADImport.FaceModule Namespace


Orbit3D Members

Orbit3D Class Constructors Events Methods Properties See Also

Provides a possibility of drawing's rotation.

The following tables list the members exposed by the Orbit3D type.

Constructors
 | Name | Description
Public constructor | Orbit3D | Creates a new instance of the Orbit3D object.
Top
Properties
 | Name | Description
Public property | CADImage | Gets or sets a CADImage object that is manipulated by the 3D Orbit tool.
Public property | Height | Gets or sets a height of the 3D Orbit tool.
Public property | IsMouseDown | Gets or sets a value indicating whether a mouse button is pressed.
Public property | Parent | Gets or sets a Control on which a CADImage is drawn.
Public property | Visible | Gets or sets a value indicating whether the 3D Orbit tool is visible.
Public property | Width | Gets or sets a width of the 3D Orbit tool.
Top
Methods
 | Name | Description
Public method | Disable3dOrbit | Deactivates the 3D Orbit tool.
Public method | Enable3dOrbit | Activates the 3D Orbit tool.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | OnMouseDown | Handles the MouseDown event.
Public method | OnMouseMove | Handles the MouseMove event.
Public method | OnMouseUp | Handles the MouseUp event.
Public method | OnPaint | Handles the Paint event.
Public method | OnRotate | Invokes RotateEvent
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Events
 | Name | Description
Public event | RotateEvent | Occurs when the drawing is rotated with Orbit3D tool
Top
See Also

Reference

Orbit3D Class
CADImport.FaceModule Namespace


Orbit3D Constructor

Creates a new instance of the Orbit3D object.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Orbit3D()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Orbit3D Class
Orbit3D Members
CADImport.FaceModule Namespace


Orbit3D Properties

Orbit3D Class See Also

The following tables list the members exposed by the Orbit3D type.

Properties
 | Name | Description
Public property | CADImage | Gets or sets a CADImage object that is manipulated by the 3D Orbit tool.
Public property | Height | Gets or sets a height of the 3D Orbit tool.
Public property | IsMouseDown | Gets or sets a value indicating whether a mouse button is pressed.
Public property | Parent | Gets or sets a Control on which a CADImage is drawn.
Public property | Visible | Gets or sets a value indicating whether the 3D Orbit tool is visible.
Public property | Width | Gets or sets a width of the 3D Orbit tool.
Top
See Also

Reference

Orbit3D Class
CADImport.FaceModule Namespace


Orbit3D.CADImage Property

Gets or sets a CADImage object that is manipulated by the 3D Orbit tool.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property CADImage() As CADImage
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADImage CADImage {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Orbit3D Class
Orbit3D Members
CADImport.FaceModule Namespace


Orbit3D.Height Property

Gets or sets a height of the 3D Orbit tool.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Height() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Height {get; set;}
This language is not supported or no code example is available.

Property Value

An int value representing a height of the 3D Orbit tool in pixels.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Orbit3D Class
Orbit3D Members
CADImport.FaceModule Namespace


Orbit3D.IsMouseDown Property

Gets or sets a value indicating whether a mouse button is pressed.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property IsMouseDown() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsMouseDown {get; set;}
This language is not supported or no code example is available.

Property Value

true if a mouse button is pressed; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Orbit3D Class
Orbit3D Members
CADImport.FaceModule Namespace


Orbit3D.Parent Property

Gets or sets a Control on which a CADImage is drawn.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Parent() As Control
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Control Parent {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Orbit3D Class
Orbit3D Members
CADImport.FaceModule Namespace


Orbit3D.Visible Property

Gets or sets a value indicating whether the 3D Orbit tool is visible.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Visible() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Visible {get; set;}
This language is not supported or no code example is available.

Property Value

true if the 3D Orbit tool is visible; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Orbit3D Class
Orbit3D Members
CADImport.FaceModule Namespace


Orbit3D.Width Property

Gets or sets a width of the 3D Orbit tool.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Width() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Width {get; set;}
This language is not supported or no code example is available.

Property Value

An int value representing a width of the 3D Orbit tool in pixels.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Orbit3D Class
Orbit3D Members
CADImport.FaceModule Namespace


Orbit3D Methods

Orbit3D Class See Also

The following tables list the members exposed by the Orbit3D type.

Methods
 | Name | Description
Public method | Disable3dOrbit | Deactivates the 3D Orbit tool.
Public method | Enable3dOrbit | Activates the 3D Orbit tool.
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | OnMouseDown | Handles the MouseDown event.
Public method | OnMouseMove | Handles the MouseMove event.
Public method | OnMouseUp | Handles the MouseUp event.
Public method | OnPaint | Handles the Paint event.
Public method | OnRotate | Invokes RotateEvent
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

Orbit3D Class
CADImport.FaceModule Namespace


Orbit3D.Disable3dOrbit Method

Deactivates the 3D Orbit tool.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Disable3dOrbit() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Disable3dOrbit()
This language is not supported or no code example is available.

Return Value

true if the 3D Orbit tool is deactivated; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Orbit3D Class
Orbit3D Members
CADImport.FaceModule Namespace


Orbit3D.Enable3dOrbit Method

Activates the 3D Orbit tool.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Enable3dOrbit() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Enable3dOrbit()
This language is not supported or no code example is available.

Return Value

true if the 3D Orbit tool is activated; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Orbit3D Class
Orbit3D Members
CADImport.FaceModule Namespace


Orbit3D.OnMouseDown Method

Handles the MouseDown event.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub OnMouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void OnMouseDown(
   object sender,
   MouseEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

An object that raises the MouseDown event.

e

Type: MouseEventArgs

A MouseEventArgs object that provides data for the MouseDown event.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Orbit3D Class
Orbit3D Members
CADImport.FaceModule Namespace


Orbit3D.OnMouseMove Method

Handles the MouseMove event.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub OnMouseMove( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void OnMouseMove(
   object sender,
   MouseEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

An object that raises the MouseMove event.

e

Type: MouseEventArgs

A MouseEventArgs object that provides data for the MouseMove event.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Orbit3D Class
Orbit3D Members
CADImport.FaceModule Namespace


Orbit3D.OnMouseUp Method

Handles the MouseUp event.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub OnMouseUp( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void OnMouseUp(
   object sender,
   MouseEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

An object that raises the MouseUp event.

e

Type: MouseEventArgs

A MouseEventArgs object that provides data for the MouseUp event.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Orbit3D Class
Orbit3D Members
CADImport.FaceModule Namespace


Orbit3D.OnPaint Method

Handles the Paint event.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub OnPaint( _
   ByVal sender As Object, _
   ByVal e As PaintEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void OnPaint(
   object sender,
   PaintEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

An object that raises the Paint event.

e

Type: PaintEventArgs

A PaintEventArgs object that provides data for the Paint event.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Orbit3D Class
Orbit3D Members
CADImport.FaceModule Namespace


Orbit3D.OnRotate Method

Invokes RotateEvent

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnRotate()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnRotate()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Orbit3D Class
Orbit3D Members
CADImport.FaceModule Namespace


Orbit3D Events

Orbit3D Class See Also

The following tables list the members exposed by the Orbit3D type.

Events
 | Name | Description
Public event | RotateEvent | Occurs when the drawing is rotated with Orbit3D tool
Top
See Also

Reference

Orbit3D Class
CADImport.FaceModule Namespace


RotateEvent Event

Occurs when the drawing is rotated with Orbit3D tool

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event RotateEvent() As CADImport.FaceModule.CADImportEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.FaceModule.CADImportEventHandler RotateEvent
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Orbit3D Class
Orbit3D Members
CADImport.FaceModule Namespace


PenXorDrawing Class

Members See Also

Auxiliary class for drawing in xor mode

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class PenXorDrawing
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class PenXorDrawing
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.FaceModule.PenXorDrawing
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PenXorDrawing Members
CADImport.FaceModule Namespace


PenXorDrawing Members

PenXorDrawing Class Methods See Also

Auxiliary class for drawing in xor mode

The following tables list the members exposed by the PenXorDrawing type.

Methods
 | Name | Description
 | DrawXORCircle |
 | DrawXORLine | Draws a line in a xor mode on the specified window unit
 | DrawXORLines | Draws lines in a xor mode on the specified window unit
 | DrawXORRectangle | Draws a rectangle in a xor mode on the specified window unit
 | DrawXORRectangles | Draws two rectangles in a xor mode on the specified window unit
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

PenXorDrawing Class
CADImport.FaceModule Namespace


PenXorDrawing Methods

PenXorDrawing Class See Also

The following tables list the members exposed by the PenXorDrawing type.

Methods
 | Name | Description
 | DrawXORCircle |
 | DrawXORLine | Draws a line in a xor mode on the specified window unit
 | DrawXORLines | Draws lines in a xor mode on the specified window unit
 | DrawXORRectangle | Draws a rectangle in a xor mode on the specified window unit
 | DrawXORRectangles | Draws two rectangles in a xor mode on the specified window unit
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

PenXorDrawing Class
CADImport.FaceModule Namespace


PenXorDrawing.DrawXORCircle Method

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub DrawXORCircle( _
   ByVal x1 As Integer, _
   ByVal y1 As Integer, _
   ByVal x2 As Integer, _
   ByVal y2 As Integer, _
   ByVal control As Control, _
   ByVal applyOrtho As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void DrawXORCircle(
   int x1,
   int y1,
   int x2,
   int y2,
   Control control,
   bool applyOrtho
)
This language is not supported or no code example is available.

Parameters

x1

Type: int

y1

Type: int

x2

Type: int

y2

Type: int

control

Type: Control

applyOrtho

Type: bool

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PenXorDrawing Class
PenXorDrawing Members
CADImport.FaceModule Namespace


PenXorDrawing.DrawXORLine Method

Draws a line in a xor mode on the specified window unit

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub DrawXORLine( _
   ByVal x1 As Integer, _
   ByVal y1 As Integer, _
   ByVal x2 As Integer, _
   ByVal y2 As Integer, _
   ByVal control As Control, _
   ByVal applyOrtho As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void DrawXORLine(
   int x1,
   int y1,
   int x2,
   int y2,
   Control control,
   bool applyOrtho
)
This language is not supported or no code example is available.

Parameters

x1

Type: int

The extreme left position

y1

Type: int

The extreme top position

x2

Type: int

The extreme right position

y2

Type: int

The extreme bottom position

control

Type: Control

Control, where the drawing is implemented

applyOrtho

Type: bool

True if ortho correction wasn't applied to the coordinates.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PenXorDrawing Class
PenXorDrawing Members
CADImport.FaceModule Namespace


PenXorDrawing.DrawXORLines Method

Draws lines in a xor mode on the specified window unit

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub DrawXORLines( _
   ByVal points As Point(), _
   ByVal control As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void DrawXORLines(
   Point[] points,
   Control control
)
This language is not supported or no code example is available.

Parameters

points

Type: Point[]

A set of points lines are drawn by.

control

Type: Control

Control, where the drawing is implemented

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PenXorDrawing Class
PenXorDrawing Members
CADImport.FaceModule Namespace


PenXorDrawing.DrawXORRectangle Method

Draws a rectangle in a xor mode on the specified window unit

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub DrawXORRectangle( _
   ByVal x1 As Integer, _
   ByVal y1 As Integer, _
   ByVal x2 As Integer, _
   ByVal y2 As Integer, _
   ByVal fill As Boolean, _
   ByVal rect As Boolean, _
   ByVal control As Control, _
   ByVal dashed As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void DrawXORRectangle(
   int x1,
   int y1,
   int x2,
   int y2,
   bool fill,
   bool rect,
   Control control,
   bool dashed
)
This language is not supported or no code example is available.

Parameters

x1

Type: int

The extreme left position

y1

Type: int

The extreme top position

x2

Type: int

The extreme right position

y2

Type: int

The extreme bottom position

fill

Type: bool

Draw filled

rect

Type: bool

Draw frame

control

Type: Control

Control, where the drawing is implemented

dashed

Type: bool

Draw dashed

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PenXorDrawing Class
PenXorDrawing Members
CADImport.FaceModule Namespace


PenXorDrawing.DrawXORRectangles Method

Draws two rectangles in a xor mode on the specified window unit

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub DrawXORRectangles( _
   ByVal rect1 As Rectangle, _
   ByVal rect2 As Rectangle, _
   ByVal fill As Boolean, _
   ByVal control As Control, _
   ByVal dashed As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void DrawXORRectangles(
   Rectangle rect1,
   Rectangle rect2,
   bool fill,
   Control control,
   bool dashed
)
This language is not supported or no code example is available.

Parameters

rect1

Type: Rectangle

The first rectangle

rect2

Type: Rectangle

The second rectangle

fill

Type: bool

Draw filled

control

Type: Control

Control, where the drawing is implemented

dashed

Type: bool

Draw dashed lines

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PenXorDrawing Class
PenXorDrawing Members
CADImport.FaceModule Namespace


SaveSettings Class

Members See Also

Provides methods for saving the application's settings.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class SaveSettings
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class SaveSettings
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.FaceModule.SaveSettings
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SaveSettings Members
CADImport.FaceModule Namespace


SaveSettings Members

SaveSettings Class Constructors Methods See Also

Provides methods for saving the application's settings.

The following tables list the members exposed by the SaveSettings type.

Constructors
 | Name | Description
Public constructor | SaveSettings | Initializes a new instance of the SaveSettings class.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadOptions | Loads the application's settings from the file.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SaveOptions | Saves the application's settings to the file.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

SaveSettings Class
CADImport.FaceModule Namespace


SaveSettings Constructor

Initializes a new instance of the SaveSettings class.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal aName As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SaveSettings(
   string aName
)
This language is not supported or no code example is available.

Parameters

aName

Type: string

A string containing a complete path to the file in which the application's settings will be saved.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SaveSettings Class
SaveSettings Members
CADImport.FaceModule Namespace


SaveSettings Methods

SaveSettings Class See Also

The following tables list the members exposed by the SaveSettings type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadOptions | Loads the application's settings from the file.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SaveOptions | Saves the application's settings to the file.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

SaveSettings Class
CADImport.FaceModule Namespace


SaveSettings.LoadOptions Method

Loads the application's settings from the file.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function LoadOptions() As SortedList
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public SortedList LoadOptions()
This language is not supported or no code example is available.

Return Value

A SortedList that contains the application's settings.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SaveSettings Class
SaveSettings Members
CADImport.FaceModule Namespace


SaveSettings.SaveOptions Method

Saves the application's settings to the file.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SaveOptions( _
   ByVal sr1 As SortedList _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SaveOptions(
   SortedList sr1
)
This language is not supported or no code example is available.

Parameters

sr1

Type: SortedList

A SortedList that contains the application's settings.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SaveSettings Class
SaveSettings Members
CADImport.FaceModule Namespace


ScrollEventArgsExt Class

Members See Also

Provides data for the Scroll event.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class ScrollEventArgsExt
    Inherits EventArgs
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class ScrollEventArgsExt : EventArgs
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.EventArgs
CADImport.FaceModule.ScrollEventArgsExt
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScrollEventArgsExt Members
CADImport.FaceModule Namespace


ScrollEventArgsExt Members

ScrollEventArgsExt Class Constructors Methods Properties See Also

Provides data for the Scroll event.

The following tables list the members exposed by the ScrollEventArgsExt type.

Constructors
 | Name | Description
Public constructor | ScrollEventArgsExt | (Overloaded) Initializes a new instance of the ScrollEventArgs class using the specified values for the Type and NewValue properties.
Top
Properties
 | Name | Description
Public property | NewValue | Gets or sets the new Value of the scroll bar.
Public property | OldValue | Gets the old Value of the scroll bar.
Public property | ScrollOrientation | Gets the scroll bar orientation that raised the Scroll event.
Public property | Type | Gets the type of scroll event that occurred.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

ScrollEventArgsExt Class
CADImport.FaceModule Namespace


ScrollEventArgsExt Constructor

ScrollEventArgsExt Class See Also

Initializes a new instance of the ScrollEventArgs class using the specified values for the Type and NewValue properties.

Overload List
Name | Description
ScrollEventArgsExt(ScrollEventType) | Initializes a new instance of the ScrollEventArgs class using the specified values for the Type and NewValue properties.
ScrollEventArgsExt(ScrollEventType, int) | Initializes a new instance of the ScrollEventArgs class using the specified values for the Type and NewValue properties.
ScrollEventArgsExt(ScrollEventType, int, ScrollOrientation) | Initializes a new instance of the ScrollEventArgs class using the given values for the Type, NewValue, and ScrollOrientation properties.
ScrollEventArgsExt(ScrollEventType, int, int) | Initializes a new instance of the ScrollEventArgs class using the specified values for the Type, OldValue, and NewValue properties.
ScrollEventArgsExt(ScrollEventType, int, int, ScrollOrientation) | Initializes a new instance of the ScrollEventArgs class using the given values for the Type, OldValue, NewValue, and ScrollOrientation properties.
See Also

Reference

ScrollEventArgsExt Class
ScrollEventArgsExt Members
CADImport.FaceModule Namespace


ScrollEventArgsExt Properties

ScrollEventArgsExt Class See Also

The following tables list the members exposed by the ScrollEventArgsExt type.

Properties
 | Name | Description
Public property | NewValue | Gets or sets the new Value of the scroll bar.
Public property | OldValue | Gets the old Value of the scroll bar.
Public property | ScrollOrientation | Gets the scroll bar orientation that raised the Scroll event.
Public property | Type | Gets the type of scroll event that occurred.
Top
See Also

Reference

ScrollEventArgsExt Class
CADImport.FaceModule Namespace


ScrollEventArgsExt.NewValue Property

Gets or sets the new Value of the scroll bar.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property NewValue() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int NewValue {get; set;}
This language is not supported or no code example is available.

Property Value

The numeric value to change the Value property.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScrollEventArgsExt Class
ScrollEventArgsExt Members
CADImport.FaceModule Namespace


ScrollEventArgsExt.OldValue Property

Gets the old Value of the scroll bar.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property OldValue() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int OldValue {get;}
This language is not supported or no code example is available.

Property Value

The numeric value that the Value property contained before it was changed.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScrollEventArgsExt Class
ScrollEventArgsExt Members
CADImport.FaceModule Namespace


ScrollEventArgsExt.ScrollOrientation Property

Gets the scroll bar orientation that raised the Scroll event.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property ScrollOrientation() As ScrollOrientation
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ScrollOrientation ScrollOrientation {get;}
This language is not supported or no code example is available.

Property Value

One of the ScrollOrientation values.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScrollEventArgsExt Class
ScrollEventArgsExt Members
CADImport.FaceModule Namespace


ScrollEventArgsExt.Type Property

Gets the type of scroll event that occurred.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Type() As ScrollEventType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ScrollEventType Type {get;}
This language is not supported or no code example is available.

Property Value

One of the ScrollEventType values.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScrollEventArgsExt Class
ScrollEventArgsExt Members
CADImport.FaceModule Namespace


ScrollEventArgsExt Methods

ScrollEventArgsExt Class See Also

The following tables list the members exposed by the ScrollEventArgsExt type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

ScrollEventArgsExt Class
CADImport.FaceModule Namespace


CADImportEventHandler Delegate

Represents the method that handles the RotateEvent event

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Delegate Sub CADImportEventHandler()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public delegate void CADImportEventHandler()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImport.FaceModule Namespace


DrawListItemCell Delegate

Represents cell drawing method

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Delegate Sub DrawListItemCell( _
   ByVal graph As Graphics, _
   ByVal posX As Integer, _
   ByVal posY As Integer, _
   ByVal sizeX As Integer, _
   ByVal sizeY As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public delegate void DrawListItemCell(
   Graphics graph,
   int posX,
   int posY,
   int sizeX,
   int sizeY
)
This language is not supported or no code example is available.

Parameters

graph

Type: Graphics

posX

Type: int

posY

Type: int

sizeX

Type: int

sizeY

Type: int

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImport.FaceModule Namespace


ListCellSelectEventHandler Delegate

Represents a list of functions invoked on cell selection event

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Delegate Sub ListCellSelectEventHandler( _
   ByVal item As ListItem, _
   ByVal e As ListEventSelectArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public delegate void ListCellSelectEventHandler(
   ListItem item,
   ListEventSelectArgs e
)
This language is not supported or no code example is available.

Parameters

item

Type: ListItem

e

Type: ListEventSelectArgs

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImport.FaceModule Namespace


ListItemSelectEventHandler Delegate

Represents a list of functions invoked on item selection event

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Delegate Sub ListItemSelectEventHandler( _
   ByVal items As ArrayList, _
   ByVal e As ListEventSelectArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public delegate void ListItemSelectEventHandler(
   ArrayList items,
   ListEventSelectArgs e
)
This language is not supported or no code example is available.

Parameters

items

Type: ArrayList

e

Type: ListEventSelectArgs

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImport.FaceModule Namespace


ScrollEventHandlerExt Delegate

Represents the method that handles the Scroll event of a FormsGridView, ScrollBar, TrackBar, or FormsGrid.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Delegate Sub ScrollEventHandlerExt( _
   ByVal sender As Object, _
   ByVal e As ScrollEventArgsExt _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public delegate void ScrollEventHandlerExt(
   object sender,
   ScrollEventArgsExt e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: ScrollEventArgsExt

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImport.FaceModule Namespace


Axes Enumeration

Specifies coordinate axes in the orthogonal coordinate system.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
X | Axis X.
Y | Axis Y.
Z | Axis Z.
See Also

Reference

CADImport.FaceModule Namespace


ConvSection Enumeration

Specifies a type of section in a CAD file.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
BlockRecords | Auxiliary member; for internal use only.
Blocks | A CAD section that contains data about CAD blocks.
DimStyles | A CAD section that contains data about dimension styles used in a CAD drawing.
Entities | A CAD section that contains data about CAD entities.
ImageDefs | A CAD section that contains data about IMAGEDEF objects of a CAD drawing.
LTypes | A CAD section that contains data about linetypes used in a CAD drawing.
Layers | A CAD section that contains data about layers in a CAD drawing.
Layouts | A CAD section that contains data about layouts of a CAD drawing.
MLine | A CAD section that contains data about CADMLines in a CAD drawing.
Styles | A CAD section that contains data about styles used in a CAD drawing.
Tables | A CAD section in which data stored in a table.
VPorts | A CAD section that contains data about CADVPorts in a CAD drawing.
See Also

Reference

CADImport.FaceModule Namespace


RectangleType Enumeration

Specifies the working modes for the Rectangle tool.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Selecting | Selects an image area for sending to the clipboard or subsequent saving to a file.
Zooming | Zooms the area selected by the Rectangle tool to fit the viewer window.
See Also

Reference

CADImport.FaceModule Namespace


ScrollBarsShow Enumeration

Represents options for the scrollbars activity

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Always | Always displayed
Automatic | Appear when necessary
None | Do not display scrollbars
See Also

Reference

CADImport.FaceModule Namespace


ScrollOrientation Enumeration

Specifies the scroll bar orientation for the Scroll event.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
HorizontalScroll | Horizontal orientation
VerticalScroll | Vertical orientation
See Also

Reference

CADImport.FaceModule Namespace


s3DStates Enumeration

Specifies cursors for the 3D Orbit tool.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
X | A cursor looks as a vertical ellipse around a small sphere when it hovers over one of the smaller circles on the top or bottom of the 3D Orbit tool. Clicking and dragging from either of these points rotates the CAD image around the horizontal or X axis that extends through the center of the 3D Orbit tool.
XY | A cursor looks as a small sphere encircled by two lines when it is positioned over the arcball of the 3D Orbit tool. Clicking inside the arcball and dragging the cursor rotates the CAD image around X axis, or Y axis, or X and Y axes simultaneously depending on the direction the cursor moves.
Y | A cursor looks as a horisontal ellipse around a small sphere when it hovers over one of the smaller circles on the left or right sides of the 3D Orbit tool. Clicking and dragging from either of these points rotates the CAD image around the vertical or Y axis that extends through the center of the 3D Orbit tool.
Z | A cursor looks as a circular arrow around a small sphere when it moves outside the arcball of the 3D Orbit tool. Clicking outside the arcball and dragging the cursor around the arcball moves the CAD image around the Z axis that extends through the center of the 3D Orbit tool, perpendicular to the screen.
See Also

Reference

CADImport.FaceModule Namespace


CADImport.FaceModule.SnapModule Namespace

Assembly: CADImport (in CADImport.dll)

Classes
 | Name | Description
Public class | SnapOptions | Prvides options to customize the snap
Top
Enumerations
 | Name | Description
Public enumeration | SnapMode | Represents supported types for snap
Top
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


SnapOptions Class

Members See Also

Prvides options to customize the snap

Namespace: CADImport.FaceModule.SnapModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class SnapOptions
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class SnapOptions
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.FaceModule.SnapModule.SnapOptions
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SnapOptions Members
CADImport.FaceModule.SnapModule Namespace


SnapOptions Members

SnapOptions Class Methods See Also

Prvides options to customize the snap

The following tables list the members exposed by the SnapOptions type.

Methods
 | Name | Description
Public method | DisableOption | Disables a snap option
Public method | EnableOption | Enables a snap option
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | OptionActive | Checks if the snap option is active
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

SnapOptions Class
CADImport.FaceModule.SnapModule Namespace


SnapOptions Methods

SnapOptions Class See Also

The following tables list the members exposed by the SnapOptions type.

Methods
 | Name | Description
Public method | DisableOption | Disables a snap option
Public method | EnableOption | Enables a snap option
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | OptionActive | Checks if the snap option is active
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

SnapOptions Class
CADImport.FaceModule.SnapModule Namespace


SnapOptions.DisableOption Method

Disables a snap option

Namespace: CADImport.FaceModule.SnapModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DisableOption( _
   ByVal option As SnapMode _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DisableOption(
   SnapMode option
)
This language is not supported or no code example is available.

Parameters

option

Type: SnapMode

Snap options that will be disabled

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SnapOptions Class
SnapOptions Members
CADImport.FaceModule.SnapModule Namespace


SnapOptions.EnableOption Method

Enables a snap option

Namespace: CADImport.FaceModule.SnapModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub EnableOption( _
   ByVal option As SnapMode _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void EnableOption(
   SnapMode option
)
This language is not supported or no code example is available.

Parameters

option

Type: SnapMode

Snap option that will be enabled

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SnapOptions Class
SnapOptions Members
CADImport.FaceModule.SnapModule Namespace


SnapOptions.OptionActive Method

Checks if the snap option is active

Namespace: CADImport.FaceModule.SnapModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function OptionActive( _
   ByVal option As SnapMode _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool OptionActive(
   SnapMode option
)
This language is not supported or no code example is available.

Parameters

option

Type: SnapMode

Snap options to check

Return Value

True if the option enabled
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SnapOptions Class
SnapOptions Members
CADImport.FaceModule.SnapModule Namespace


SnapMode Enumeration

Represents supported types for snap

Namespace: CADImport.FaceModule.SnapModule
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Center | Center point
Insertion | Insertion point
Intersection | Intersection point
Intersection_apparent | Apparent intersection point. Value is equal to Intersection point optiion
Middle | Middle point
None | No snap
Object | Object closest point
Point | Point or marker
See Also

Reference

CADImport.FaceModule.SnapModule Namespace


CADImport.GBR Namespace

Assembly: CADImport (in CADImport.dll)

Classes
 | Name | Description
Public class | Aperture | Defines brush appearance. For more information please see Gerber RS-274X Format User’s Guide.
Public class | GBRImage | Represents a Gerber files drawing and provides methods for drawing all loaded GBR objects.
Top
Delegates
 | Name | Description
Public delegate | EndGBRProgramEventHandler | A delegate on the basis of which stop/finish loading of GBR file event is set
Top
Enumerations
 | Name | Description
Public enumeration | ApertureType | Enum of aperture types
Public enumeration | DCommand | GBR file D code (plot functions). Selects and controls tools, specify line type, etc. For more information please see Gerber RS-274X Format User’s Guide.
Public enumeration | GBRDrawStatus | Current status of GBR file loading
Public enumeration | GCommand | GBR file G code (general functions). Specifies how to interpolate and move to the coordinate locations following the code until changed or until a new layer is generated (modal). For more information please see Gerber RS-274X Format User’s Guide.
Top
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


Aperture Class

Members See Also

Defines brush appearance. For more information please see Gerber RS-274X Format User’s Guide.

Namespace: CADImport.GBR
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class Aperture
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class Aperture
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.GBR.Aperture
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Aperture Members
CADImport.GBR Namespace


Aperture Members

Aperture Class Methods Fields See Also

Defines brush appearance. For more information please see Gerber RS-274X Format User’s Guide.

The following tables list the members exposed by the Aperture type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | name | The aperture name field
Public field | type | Defines an aperture type
Public field | values | The aperture property field. For more information please see Gerber RS-274X Format User’s Guide.
Top
See Also

Reference

Aperture Class
CADImport.GBR Namespace


Aperture Methods

Aperture Class See Also

The following tables list the members exposed by the Aperture type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

Aperture Class
CADImport.GBR Namespace


Aperture Fields

Aperture Class See Also

The following tables list the members exposed by the Aperture type.

Fields
 | Name | Description
Public field | name | The aperture name field
Public field | type | Defines an aperture type
Public field | values | The aperture property field. For more information please see Gerber RS-274X Format User’s Guide.
Top
See Also

Reference

Aperture Class
CADImport.GBR Namespace


name Field

The aperture name field

Namespace: CADImport.GBR
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public name As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string name
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Aperture Class
Aperture Members
CADImport.GBR Namespace


type Field

Defines an aperture type

Namespace: CADImport.GBR
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public type As ApertureType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ApertureType type
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Aperture Class
Aperture Members
CADImport.GBR Namespace


values Field

The aperture property field. For more information please see Gerber RS-274X Format User’s Guide.

Namespace: CADImport.GBR
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public values As ArrayList
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ArrayList values
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Aperture Class
Aperture Members
CADImport.GBR Namespace


GBRImage Class

Members See Also

Represents a Gerber files drawing and provides methods for drawing all loaded GBR objects.

Namespace: CADImport.GBR
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class GBRImage
    Inherits CADImage
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class GBRImage : CADImage
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADImage
CADImport.GBR.GBRImage
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GBRImage Members
CADImport.GBR Namespace


GBRImage Members

GBRImage Class Constructors Events Methods Fields Properties See Also

Represents a Gerber files drawing and provides methods for drawing all loaded GBR objects.

The following tables list the members exposed by the GBRImage type.

Constructors
 | Name | Description
Public constructor | GBRImage | Initializes a new instance of the GBRImage class.
Top
Properties
 | Name | Description
Public property | AbsDepth | Gets an absolute depths of the CADImage. (inherited from CADImage).
Public property | AbsHeight | Gets an absolute height of the CADImage. (inherited from CADImage).
Public property | AbsWidth | Gets an absolute width of the CADImage. (inherited from CADImage).
Public property | Angle | Gets or sets the angle for this CADImage object visualization. (inherited from CADImage).
Public property | BackgroundColor | Gets or sets a background color of this CADImage. (inherited from CADImage).
Public property | BorderSize | Gets or sets a border size in pixels. (inherited from CADImage).
Public property | BorderType | Gets or sets a border type. (inherited from CADImage).
Public property | Center | Gets or sets CADImage center point. (inherited from CADImage).
Public property | Charset | Gets or sets a character set for the text entities. (inherited from CADImage).
 | CodePage | Gets or sets a number that identifies the encoding used in the loaded CAD file. (inherited from CADImage).
Public property | Converter | Gets a converter that loads CAD entities from the file to draw them in the current CADImage. (inherited from CADImage).
Public property | CurrentLayer | Gets or sets a current layer for the CADImage. (inherited from CADImage).
Public property | CurrentLayout | Gets or sets a current layout for the CADImage. (inherited from CADImage).
Public property | CurrentLayoutIndex | Gets an index of the current layout. (inherited from CADImage).
Public property | CurrentMarker | Gets a currently selected marker. (inherited from CADImage).
Public property | DefaultColor | Gets or sets a default color for the CADImage. (inherited from CADImage).
Public property | DefaultLayoutIndex | Gets or sets a default layout index. (inherited from CADImage).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions on the drawing are visible. (inherited from CADImage).
Public property | DrawMode | Gets or sets a current drawing mode. (inherited from CADImage).
Public property | EnableSnap | Gets or sets enablement of snap mode (inherited from CADImage).
Public property | Extents | Gets or sets an extents of the CADImage object. (inherited from CADImage).
Public property | FileInf | Gets information about a currently open file by means of the FileInfo class. (inherited from CADImage).
Public property | GDIPainter | Provides drawing functionality based on GDI+. (inherited from CADImage).
Public property | GraphicsOutMode | Specifies image draw mode. (inherited from CADImage).
Public property | InterpolationMode | Gets or sets the interpolation mode associated with current Graphics object (inherited from CADImage).
Public property | Is3D | Gets a value indicating whether this CADImage is three-dimensional. (inherited from CADImage).
Public property | IsDraw3DAxes | Gets or sets a value indicating whether 3D axes are shown on the drawing. (inherited from CADImage).
Public property | IsDrawingRotated | Gets a value indicating whether the CADImage has been rotated. (inherited from CADImage).
Public property | IsShowBackground | Gets or sets a value indicating using of a BackgroundColor. (inherited from CADImage).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data. (inherited from CADImage).
Public property | IsSnapObject | Gets a value, which shows if there is an object for snapping under current coordinates (inherited from CADImage).
Public property | IsStopped | For internal use. (inherited from CADImage).
Public property | IsWithoutBorder | Gest or sets a value indicating whether to draw the CADImage without borders. (inherited from CADImage).
Public property | IsWithoutMargins | Gets or sets a value indicating whether to draw the CADImage without margins. (inherited from CADImage).
 | LastLoadedFilePath | Specifying of the search directory (used for X-Refs, ImageEnt) (inherited from CADImage).
Public property | LayersCount | Gets a quantity of layers in this CADImage. (inherited from CADImage).
Public property | Layouts | Gets a collection of layouts in the current CADImage. (inherited from CADImage).
Public property | LayoutsCount | Gets a quantity of layouts in this CADImage. (inherited from CADImage).
Public property | LineScaled | Obsolete. Gets or sets a value indicating whether a width of lines to draw all entities in the drawing is specified by the file data. (inherited from CADImage).
Public property | LineWeightScale | Gets or sets a scale for drawing lines. (inherited from CADImage).
Public property | MMToPixelX | Gets or sets a value corresponding to amount of millimeters per one pixel. (inherited from CADImage).
Public property | NullWidth | Gets or sets default thickness for lines used to draw a CADImage. (inherited from CADImage).
Public property | NumberOfPartsInCircle | Gets or sets a quantity of segments to be used to draw a circle. (inherited from CADImage).
Public property | Painter | Provides image drawing functionality. (inherited from CADImage).
Public property | PrintDialog | Gets or sets print dialog (inherited from CADImage).
Public property | PureExtents | Gets CADImage extents without margins. (inherited from CADImage).
Public property | ResizeDisproportionateDrawing | For internal use (inherited from CADImage).
Public property | SHXSearchPaths | Gets or sets paths for searching SHX fonts. (inherited from CADImage).
Public property | SearchSHXPaths | Gets or sets a value specifying whether SHX paths will be searched for the fonts. (inherited from CADImage).
Public property | SelectEntitiesCount | Gets the number of selected entities (inherited from CADImage).
Public property | SelectedEntities | Gets or sets a list of selected entities (inherited from CADImage).
Public property | SelectionMode | Gets or sets a state of the Selection tool. (inherited from CADImage).
Public property | Selector | Provides selection functionality. (inherited from CADImage).
Public property | SkipMMtoPixel | For specific use (inherited from CADImage).
Public property | SnapCurrent | (inherited from CADImage).
Public property | SnapOptions | Represents Snap options for the CADImage object (inherited from CADImage).
Public property | SnapRealPoint | Gets a current point in absolute coordinates (drawing coordinates) (inherited from CADImage).
Public property | SnapScreenPoint | Gets current point in display coordinates (inherited from CADImage).
Public property | TTFSmoothing | Gets or sets a value indicating whether TTF fonts are smoothed. (inherited from CADImage).
Public property | TextVisible | Gets or sets a value indicating whether the texts in the CADImage are visible. (inherited from CADImage).
Public property | UndoMode | Gets or sets whether undo/redo is disable or enable for professional version (inherited from CADImage).
Public property | UseDoubleBuffering | Outdated. Does nothing (inherited from CADImage).
Public property | UseLayerPriority | (inherited from CADImage).
Public property | UseMultyTTFFonts | Gets or sets a value indicating whether a multimode is used for showing symbols. (inherited from CADImage).
Public property | UseNullWidth | Specifies if default width will be used instead of entity width. (inherited from CADImage).
Public property | UseSHXFonts | Specifies if SHX fonts will be used for visualization. (inherited from CADImage).
Public property | UseTTFFonts | Specifies if TTF fonts will be used for visualization. (inherited from CADImage).
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles in the CADImage are drawn with GDI+ drawing methods without linearization. (inherited from CADImage).
Top
Methods
 | Name | Description
Public method | ActiveVPort | Returns drawing area visualized with the active VPort. (inherited from CADImage).
Public method | AddScaledDXF | Adds a scaled external reference to the model space of the specified CAD image. (inherited from CADImage).
Public method | AddScaledDXFEx | Adds a scaled external reference to the current layout of the specified CAD image. (inherited from CADImage).
Public method | AddToUndoList | (Overloaded) Adds operation "create new Entity" to undo list (inherited from CADImage).
Public method | ChangeDrawMode | Initializes a new graphic class object if current mode changed. (inherited from CADImage).
Public method | ChangeEntities | (inherited from CADImage).
Public method | ChangeGraphicsMode | Changes image drawing mode. (inherited from CADImage).
Public method | ChangePositionSelectedEntities | Changes position of the selected entities (inherited from CADImage).
Public method | ChangePositionSelectedEntity | Changes a position of the selected entity. (inherited from CADImage).
Public method | ClearBuffer | Outdated. Does nothing (inherited from CADImage).
Public method | ClearMarkers | Clears a collection of markers. (inherited from CADImage).
Public method | ClearRedoCollection | Clears redo entity collection (inherited from CADImage).
Public method | ClearSelectCollection | Clears a collection of the selected entities. (inherited from CADImage).
Public method | ClearSelection | Clears a list of the selected entities. (inherited from CADImage).
Public method | ClearSnapTrace | (Overloaded) Clears last drawn snap drawing element (inherited from CADImage).
Public method | ClearUndoCollection | Clears undo entity collection (inherited from CADImage).
Public method | CopyEntities | (Overloaded) Copies selected entities to the clipboard (inherited from CADImage).
Public method | CorrectByGrid | (Overloaded) Reduces a point location on screen to the grid node when the grid is active (inherited from CADImage).
Public method | CorrectByGridAndOrtho | Reduces a point relocation sizes on screen to the grid cell sizes when the grid is active (inherited from CADImage).
 | CreateImageByExtension | Creates specialised CADImage object for specified file extention (inherited from CADImage).
Public method | CutEntities | (Overloaded) Cuts selected entities from collection and paste them to the clipboard (inherited from CADImage).
Public method | Dispose | Disposes a CADImage object. (inherited from CADImage).
Public method | DoSelectEntities | (Overloaded) Selects inserted list of entities (inherited from CADImage).
Public method | DoSelectEntity | Selects inserted entity (inherited from CADImage).
Public method | Draw | (Overloaded) Draws a CADImage. (inherited from CADImage).
Public method | DrawACISEntity | Draws ACISEntity object (inherited from CADImage).
Public method | DrawArc | Draws GBRArc object
Public method | DrawChangeEntity | Changes a position of the marker designating the selected entity. (inherited from CADImage).
Public method | DrawLine | Darws GBRLine object
Public method | DrawMoveEntityTrace | Draws entities on their offsetting (inherited from CADImage).
Public method | DrawPoint | Draws GBRPoint object
Public method | DrawSnapTrace | Draws snap icon in case of proximity of object to current coordinates (inherited from CADImage).
Public method | EmfConvertToDXF | (Overloaded) Converts emf file to dxf file (inherited from CADImage).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportToMetafile | (Overloaded) Exports a CAD drawing to Windows Enhanced metafile. (inherited from CADImage).
Public method | GetAbsPoint | Converts display coordinates into absolute coordinates of a design (inherited from CADImage).
Public method | GetCADCoords | Returns coordinates of a point on the drawing. (inherited from CADImage).
Public method | GetCenter | Returns the center point of a current layout (inherited from CADImage).
Public method | GetExtents | Calculates the current dimensions of the CADImage. (inherited from CADImage).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLayerColor | Gets layer color by index (inherited from CADImage).
Public method | GetLayerFreeze | Determines whether the layer (CADLayer) is frozen. (inherited from CADImage).
Public method | GetLayerName | Gets a name of the layer that has the specified index in the collection of layers. (inherited from CADImage).
Public method | GetLayerVisible | Determines whether a layer is visible (inherited from CADImage).
Public method | GetLayoutName | Gets a name of the layout that has the specified index in the collection of layouts. (inherited from CADImage).
Public method | GetPoint | Transforms a three-dimensional CAD point into a two-dimensional screen point. (inherited from CADImage).
Public method | GetRealImagePoint | For internal use. (inherited from CADImage).
Public method | GetRealSnapPoint | Smooths a point in absolute coordinates by the entity (inherited from CADImage).
Public method | GetSelectEntityRegion | Returns the selected area of the image. (inherited from CADImage).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetVPortExtents | Returns extents of the active VPort reduced to the specified size (inherited from CADImage).
Public method | InitialNewImage | (Overloaded) Initializes a new image with the default size (inherited from CADImage).
Public method | InvalidateSelectEntity | Redraws a selected entity. (inherited from CADImage).
Public method | InvalidateSelectedEntities | (Overloaded) Redraws a list of the selected entities (inherited from CADImage).
Public method | LoadFromFile | Uses for redefining in a descendant classes, define loading image from the specified file. (inherited from CADImage).
Public method | LoadFromStream | Loads a GBR image stored in the specified stream.
Public method | LoadFromWeb | Loads CAD image from hyperlink (inherited from CADImage).
Public method | MultipleSelect | Providing CAD image entities' multiple selection within a specified rectangle. (inherited from CADImage).
Public method | MultipleSelectExt | Selects all entities inside the inserted rectangle (inherited from CADImage).
Public method | OnEndGBRProgram | Invokes the EndGBRProgram event
Public method | PasteEntities | Pastes entities from the clipboard (inherited from CADImage).
Public method | PasteEntitiesExt | Pastes entities from the clipboard (inherited from CADImage).
Public method | Print | Prints a current CAD image. (inherited from CADImage).
Public method | Redo | Redo change (inherited from CADImage).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RefreshCurrentLayout | Refresh current layout. (inherited from CADImage).
Public method | RefreshSnapTrace | Refreshes a region of the last drawn snap drawing element (inherited from CADImage).
Public method | RemoveEntity | (Overloaded) Removes CADEntity object. (inherited from CADImage).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from CADImage).
Public method | RotToView | Rotates a CAD image to get a specified view. (inherited from CADImage).
Public method | Rotate | Rotates objects in the current drawing. (inherited from CADImage).
Public method | SaveAsDXF | Saves a current CAD image in DXF format. (inherited from CADImage).
Public method | SaveImageToClipboard | (Overloaded) Writes a visible part of the current CAD image to the clipboard as a raster image. (inherited from CADImage).
Public method | SaveToFile | (Overloaded) Saves a part of the current CAD image to the file of the specified format. (inherited from CADImage).
Public method | SaveToStream | (Overloaded) Writes a visible part of the current CAD image to the specified stream as a raster image. (inherited from CADImage).
Public method | Select | Selects an entity of the CAD image at the specified point. (inherited from CADImage).
Public method | SelectExt | Selects an entity of the CAD image at the specified point. (inherited from CADImage).
Public method | SetCenter | Sets CADImage center point. (inherited from CADImage).
Public method | SetCurrentLayout | Sets a current layout of this CADImage. (inherited from CADImage).
Public method | SetLayerColor | (Overloaded) Sets a color for layer (CADLayer) specified by index (inherited from CADImage).
Public method | SetLayerFreeze | (Overloaded) Sets freeze parameter for CADLayer (inherited from CADImage).
Public method | SetLayerVisible | (Overloaded) Sets a visibility of the layer. (inherited from CADImage).
Public method | SetNewEntityMarkerPos | Sets a new position for the selected entity. The entity's new position is defined by the position of the marker. (inherited from CADImage).
Public method | SetNewMMToPixel | Sets a quantity of millimeters per pixel for the specified Graphics object. (inherited from CADImage).
Public method | SetNewPosEntitiesExt | Sets a new position for the specified entities (inherited from CADImage).
Public method | SetNewPosEntity | Sets a new position for the specified entity. (inherited from CADImage).
Public method | Stop | For internal use. (inherited from CADImage).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | Undo | Undo change (inherited from CADImage).
Top
Events
 | Name | Description
Public event | EndGBRProgram | Occurs on stop/finish of loading GBR file.
Top
Fields
 | Name | Description
 | EntityBuffer | Represents buffer for CADEntityCollection storing. (inherited from CADImage).
Public field | visibleArea | Represents CADImage visible area. (inherited from CADImage).
Top
See Also

Reference

GBRImage Class
CADImport.GBR Namespace


GBRImage Constructor

Initializes a new instance of the GBRImage class.

Namespace: CADImport.GBR
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public GBRImage()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GBRImage Class
GBRImage Members
CADImport.GBR Namespace


GBRImage Properties

GBRImage Class See Also

The following tables list the members exposed by the GBRImage type.

Properties
 | Name | Description
Public property | AbsDepth | Gets an absolute depths of the CADImage. (inherited from CADImage).
Public property | AbsHeight | Gets an absolute height of the CADImage. (inherited from CADImage).
Public property | AbsWidth | Gets an absolute width of the CADImage. (inherited from CADImage).
Public property | Angle | Gets or sets the angle for this CADImage object visualization. (inherited from CADImage).
Public property | BackgroundColor | Gets or sets a background color of this CADImage. (inherited from CADImage).
Public property | BorderSize | Gets or sets a border size in pixels. (inherited from CADImage).
Public property | BorderType | Gets or sets a border type. (inherited from CADImage).
Public property | Center | Gets or sets CADImage center point. (inherited from CADImage).
Public property | Charset | Gets or sets a character set for the text entities. (inherited from CADImage).
 | CodePage | Gets or sets a number that identifies the encoding used in the loaded CAD file. (inherited from CADImage).
Public property | Converter | Gets a converter that loads CAD entities from the file to draw them in the current CADImage. (inherited from CADImage).
Public property | CurrentLayer | Gets or sets a current layer for the CADImage. (inherited from CADImage).
Public property | CurrentLayout | Gets or sets a current layout for the CADImage. (inherited from CADImage).
Public property | CurrentLayoutIndex | Gets an index of the current layout. (inherited from CADImage).
Public property | CurrentMarker | Gets a currently selected marker. (inherited from CADImage).
Public property | DefaultColor | Gets or sets a default color for the CADImage. (inherited from CADImage).
Public property | DefaultLayoutIndex | Gets or sets a default layout index. (inherited from CADImage).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions on the drawing are visible. (inherited from CADImage).
Public property | DrawMode | Gets or sets a current drawing mode. (inherited from CADImage).
Public property | EnableSnap | Gets or sets enablement of snap mode (inherited from CADImage).
Public property | Extents | Gets or sets an extents of the CADImage object. (inherited from CADImage).
Public property | FileInf | Gets information about a currently open file by means of the FileInfo class. (inherited from CADImage).
Public property | GDIPainter | Provides drawing functionality based on GDI+. (inherited from CADImage).
Public property | GraphicsOutMode | Specifies image draw mode. (inherited from CADImage).
Public property | InterpolationMode | Gets or sets the interpolation mode associated with current Graphics object (inherited from CADImage).
Public property | Is3D | Gets a value indicating whether this CADImage is three-dimensional. (inherited from CADImage).
Public property | IsDraw3DAxes | Gets or sets a value indicating whether 3D axes are shown on the drawing. (inherited from CADImage).
Public property | IsDrawingRotated | Gets a value indicating whether the CADImage has been rotated. (inherited from CADImage).
Public property | IsShowBackground | Gets or sets a value indicating using of a BackgroundColor. (inherited from CADImage).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data. (inherited from CADImage).
Public property | IsSnapObject | Gets a value, which shows if there is an object for snapping under current coordinates (inherited from CADImage).
Public property | IsStopped | For internal use. (inherited from CADImage).
Public property | IsWithoutBorder | Gest or sets a value indicating whether to draw the CADImage without borders. (inherited from CADImage).
Public property | IsWithoutMargins | Gets or sets a value indicating whether to draw the CADImage without margins. (inherited from CADImage).
 | LastLoadedFilePath | Specifying of the search directory (used for X-Refs, ImageEnt) (inherited from CADImage).
Public property | LayersCount | Gets a quantity of layers in this CADImage. (inherited from CADImage).
Public property | Layouts | Gets a collection of layouts in the current CADImage. (inherited from CADImage).
Public property | LayoutsCount | Gets a quantity of layouts in this CADImage. (inherited from CADImage).
Public property | LineScaled | Obsolete. Gets or sets a value indicating whether a width of lines to draw all entities in the drawing is specified by the file data. (inherited from CADImage).
Public property | LineWeightScale | Gets or sets a scale for drawing lines. (inherited from CADImage).
Public property | MMToPixelX | Gets or sets a value corresponding to amount of millimeters per one pixel. (inherited from CADImage).
Public property | NullWidth | Gets or sets default thickness for lines used to draw a CADImage. (inherited from CADImage).
Public property | NumberOfPartsInCircle | Gets or sets a quantity of segments to be used to draw a circle. (inherited from CADImage).
Public property | Painter | Provides image drawing functionality. (inherited from CADImage).
Public property | PrintDialog | Gets or sets print dialog (inherited from CADImage).
Public property | PureExtents | Gets CADImage extents without margins. (inherited from CADImage).
Public property | ResizeDisproportionateDrawing | For internal use (inherited from CADImage).
Public property | SHXSearchPaths | Gets or sets paths for searching SHX fonts. (inherited from CADImage).
Public property | SearchSHXPaths | Gets or sets a value specifying whether SHX paths will be searched for the fonts. (inherited from CADImage).
Public property | SelectEntitiesCount | Gets the number of selected entities (inherited from CADImage).
Public property | SelectedEntities | Gets or sets a list of selected entities (inherited from CADImage).
Public property | SelectionMode | Gets or sets a state of the Selection tool. (inherited from CADImage).
Public property | Selector | Provides selection functionality. (inherited from CADImage).
Public property | SkipMMtoPixel | For specific use (inherited from CADImage).
Public property | SnapCurrent | (inherited from CADImage).
Public property | SnapOptions | Represents Snap options for the CADImage object (inherited from CADImage).
Public property | SnapRealPoint | Gets a current point in absolute coordinates (drawing coordinates) (inherited from CADImage).
Public property | SnapScreenPoint | Gets current point in display coordinates (inherited from CADImage).
Public property | TTFSmoothing | Gets or sets a value indicating whether TTF fonts are smoothed. (inherited from CADImage).
Public property | TextVisible | Gets or sets a value indicating whether the texts in the CADImage are visible. (inherited from CADImage).
Public property | UndoMode | Gets or sets whether undo/redo is disable or enable for professional version (inherited from CADImage).
Public property | UseDoubleBuffering | Outdated. Does nothing (inherited from CADImage).
Public property | UseLayerPriority | (inherited from CADImage).
Public property | UseMultyTTFFonts | Gets or sets a value indicating whether a multimode is used for showing symbols. (inherited from CADImage).
Public property | UseNullWidth | Specifies if default width will be used instead of entity width. (inherited from CADImage).
Public property | UseSHXFonts | Specifies if SHX fonts will be used for visualization. (inherited from CADImage).
Public property | UseTTFFonts | Specifies if TTF fonts will be used for visualization. (inherited from CADImage).
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles in the CADImage are drawn with GDI+ drawing methods without linearization. (inherited from CADImage).
Top
See Also

Reference

GBRImage Class
CADImport.GBR Namespace


GBRImage Methods

GBRImage Class See Also

The following tables list the members exposed by the GBRImage type.

Methods
 | Name | Description
Public method | ActiveVPort | Returns drawing area visualized with the active VPort. (inherited from CADImage).
Public method | AddScaledDXF | Adds a scaled external reference to the model space of the specified CAD image. (inherited from CADImage).
Public method | AddScaledDXFEx | Adds a scaled external reference to the current layout of the specified CAD image. (inherited from CADImage).
Public method | AddToUndoList | (Overloaded) Adds operation "create new Entity" to undo list (inherited from CADImage).
Public method | ChangeDrawMode | Initializes a new graphic class object if current mode changed. (inherited from CADImage).
Public method | ChangeEntities | (inherited from CADImage).
Public method | ChangeGraphicsMode | Changes image drawing mode. (inherited from CADImage).
Public method | ChangePositionSelectedEntities | Changes position of the selected entities (inherited from CADImage).
Public method | ChangePositionSelectedEntity | Changes a position of the selected entity. (inherited from CADImage).
Public method | ClearBuffer | Outdated. Does nothing (inherited from CADImage).
Public method | ClearMarkers | Clears a collection of markers. (inherited from CADImage).
Public method | ClearRedoCollection | Clears redo entity collection (inherited from CADImage).
Public method | ClearSelectCollection | Clears a collection of the selected entities. (inherited from CADImage).
Public method | ClearSelection | Clears a list of the selected entities. (inherited from CADImage).
Public method | ClearSnapTrace | (Overloaded) Clears last drawn snap drawing element (inherited from CADImage).
Public method | ClearUndoCollection | Clears undo entity collection (inherited from CADImage).
Public method | CopyEntities | (Overloaded) Copies selected entities to the clipboard (inherited from CADImage).
Public method | CorrectByGrid | (Overloaded) Reduces a point location on screen to the grid node when the grid is active (inherited from CADImage).
Public method | CorrectByGridAndOrtho | Reduces a point relocation sizes on screen to the grid cell sizes when the grid is active (inherited from CADImage).
 | CreateImageByExtension | Creates specialised CADImage object for specified file extention (inherited from CADImage).
Public method | CutEntities | (Overloaded) Cuts selected entities from collection and paste them to the clipboard (inherited from CADImage).
Public method | Dispose | Disposes a CADImage object. (inherited from CADImage).
Public method | DoSelectEntities | (Overloaded) Selects inserted list of entities (inherited from CADImage).
Public method | DoSelectEntity | Selects inserted entity (inherited from CADImage).
Public method | Draw | (Overloaded) Draws a CADImage. (inherited from CADImage).
Public method | DrawACISEntity | Draws ACISEntity object (inherited from CADImage).
Public method | DrawArc | Draws GBRArc object
Public method | DrawChangeEntity | Changes a position of the marker designating the selected entity. (inherited from CADImage).
Public method | DrawLine | Darws GBRLine object
Public method | DrawMoveEntityTrace | Draws entities on their offsetting (inherited from CADImage).
Public method | DrawPoint | Draws GBRPoint object
Public method | DrawSnapTrace | Draws snap icon in case of proximity of object to current coordinates (inherited from CADImage).
Public method | EmfConvertToDXF | (Overloaded) Converts emf file to dxf file (inherited from CADImage).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportToMetafile | (Overloaded) Exports a CAD drawing to Windows Enhanced metafile. (inherited from CADImage).
Public method | GetAbsPoint | Converts display coordinates into absolute coordinates of a design (inherited from CADImage).
Public method | GetCADCoords | Returns coordinates of a point on the drawing. (inherited from CADImage).
Public method | GetCenter | Returns the center point of a current layout (inherited from CADImage).
Public method | GetExtents | Calculates the current dimensions of the CADImage. (inherited from CADImage).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLayerColor | Gets layer color by index (inherited from CADImage).
Public method | GetLayerFreeze | Determines whether the layer (CADLayer) is frozen. (inherited from CADImage).
Public method | GetLayerName | Gets a name of the layer that has the specified index in the collection of layers. (inherited from CADImage).
Public method | GetLayerVisible | Determines whether a layer is visible (inherited from CADImage).
Public method | GetLayoutName | Gets a name of the layout that has the specified index in the collection of layouts. (inherited from CADImage).
Public method | GetPoint | Transforms a three-dimensional CAD point into a two-dimensional screen point. (inherited from CADImage).
Public method | GetRealImagePoint | For internal use. (inherited from CADImage).
Public method | GetRealSnapPoint | Smooths a point in absolute coordinates by the entity (inherited from CADImage).
Public method | GetSelectEntityRegion | Returns the selected area of the image. (inherited from CADImage).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetVPortExtents | Returns extents of the active VPort reduced to the specified size (inherited from CADImage).
Public method | InitialNewImage | (Overloaded) Initializes a new image with the default size (inherited from CADImage).
Public method | InvalidateSelectEntity | Redraws a selected entity. (inherited from CADImage).
Public method | InvalidateSelectedEntities | (Overloaded) Redraws a list of the selected entities (inherited from CADImage).
Public method | LoadFromFile | Uses for redefining in a descendant classes, define loading image from the specified file. (inherited from CADImage).
Public method | LoadFromStream | Loads a GBR image stored in the specified stream.
Public method | LoadFromWeb | Loads CAD image from hyperlink (inherited from CADImage).
Public method | MultipleSelect | Providing CAD image entities' multiple selection within a specified rectangle. (inherited from CADImage).
Public method | MultipleSelectExt | Selects all entities inside the inserted rectangle (inherited from CADImage).
Public method | OnEndGBRProgram | Invokes the EndGBRProgram event
Public method | PasteEntities | Pastes entities from the clipboard (inherited from CADImage).
Public method | PasteEntitiesExt | Pastes entities from the clipboard (inherited from CADImage).
Public method | Print | Prints a current CAD image. (inherited from CADImage).
Public method | Redo | Redo change (inherited from CADImage).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RefreshCurrentLayout | Refresh current layout. (inherited from CADImage).
Public method | RefreshSnapTrace | Refreshes a region of the last drawn snap drawing element (inherited from CADImage).
Public method | RemoveEntity | (Overloaded) Removes CADEntity object. (inherited from CADImage).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from CADImage).
Public method | RotToView | Rotates a CAD image to get a specified view. (inherited from CADImage).
Public method | Rotate | Rotates objects in the current drawing. (inherited from CADImage).
Public method | SaveAsDXF | Saves a current CAD image in DXF format. (inherited from CADImage).
Public method | SaveImageToClipboard | (Overloaded) Writes a visible part of the current CAD image to the clipboard as a raster image. (inherited from CADImage).
Public method | SaveToFile | (Overloaded) Saves a part of the current CAD image to the file of the specified format. (inherited from CADImage).
Public method | SaveToStream | (Overloaded) Writes a visible part of the current CAD image to the specified stream as a raster image. (inherited from CADImage).
Public method | Select | Selects an entity of the CAD image at the specified point. (inherited from CADImage).
Public method | SelectExt | Selects an entity of the CAD image at the specified point. (inherited from CADImage).
Public method | SetCenter | Sets CADImage center point. (inherited from CADImage).
Public method | SetCurrentLayout | Sets a current layout of this CADImage. (inherited from CADImage).
Public method | SetLayerColor | (Overloaded) Sets a color for layer (CADLayer) specified by index (inherited from CADImage).
Public method | SetLayerFreeze | (Overloaded) Sets freeze parameter for CADLayer (inherited from CADImage).
Public method | SetLayerVisible | (Overloaded) Sets a visibility of the layer. (inherited from CADImage).
Public method | SetNewEntityMarkerPos | Sets a new position for the selected entity. The entity's new position is defined by the position of the marker. (inherited from CADImage).
Public method | SetNewMMToPixel | Sets a quantity of millimeters per pixel for the specified Graphics object. (inherited from CADImage).
Public method | SetNewPosEntitiesExt | Sets a new position for the specified entities (inherited from CADImage).
Public method | SetNewPosEntity | Sets a new position for the specified entity. (inherited from CADImage).
Public method | Stop | For internal use. (inherited from CADImage).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | Undo | Undo change (inherited from CADImage).
Top
See Also

Reference

GBRImage Class
CADImport.GBR Namespace


GBRImage.DrawArc Method

Draws GBRArc object

Namespace: CADImport.GBR
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DrawArc( _
   ByVal sender As Object _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DrawArc(
   object sender
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

GBRArc object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GBRImage Class
GBRImage Members
CADImport.GBR Namespace


GBRImage.DrawLine Method

Darws GBRLine object

Namespace: CADImport.GBR
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DrawLine( _
   ByVal sender As Object _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DrawLine(
   object sender
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

GBRLine object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GBRImage Class
GBRImage Members
CADImport.GBR Namespace


GBRImage.DrawPoint Method

Draws GBRPoint object

Namespace: CADImport.GBR
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DrawPoint( _
   ByVal sender As Object _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DrawPoint(
   object sender
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

GBRPoint object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GBRImage Class
GBRImage Members
CADImport.GBR Namespace


GBRImage.LoadFromStream Method

Loads a GBR image stored in the specified stream.

Namespace: CADImport.GBR
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub LoadFromStream( _
   ByVal str As Stream _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void LoadFromStream(
   Stream str
)
This language is not supported or no code example is available.

Parameters

str

Type: Stream

A Stream that contains a GBR image to be loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GBRImage Class
GBRImage Members
CADImport.GBR Namespace


GBRImage.OnEndGBRProgram Method

Invokes the EndGBRProgram event

Namespace: CADImport.GBR
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnEndGBRProgram( _
   ByVal status As GBRDrawStatus _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnEndGBRProgram(
   GBRDrawStatus status
)
This language is not supported or no code example is available.

Parameters

status

Type: GBRDrawStatus

GBR file loading status to set (GBRDrawStatus)

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GBRImage Class
GBRImage Members
CADImport.GBR Namespace


GBRImage Events

GBRImage Class See Also

The following tables list the members exposed by the GBRImage type.

Events
 | Name | Description
Public event | EndGBRProgram | Occurs on stop/finish of loading GBR file.
Top
See Also

Reference

GBRImage Class
CADImport.GBR Namespace


EndGBRProgram Event

Occurs on stop/finish of loading GBR file.

Namespace: CADImport.GBR
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event EndGBRProgram() As CADImport.GBR.EndGBRProgramEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.GBR.EndGBRProgramEventHandler EndGBRProgram
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GBRImage Class
GBRImage Members
CADImport.GBR Namespace


GBRImage Fields

GBRImage Class See Also

The following tables list the members exposed by the GBRImage type.

Fields
 | Name | Description
 | EntityBuffer | Represents buffer for CADEntityCollection storing. (inherited from CADImage).
Public field | visibleArea | Represents CADImage visible area. (inherited from CADImage).
Top
See Also

Reference

GBRImage Class
CADImport.GBR Namespace


EndGBRProgramEventHandler Delegate

A delegate on the basis of which stop/finish loading of GBR file event is set

Namespace: CADImport.GBR
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Delegate Sub EndGBRProgramEventHandler( _
   ByVal status As GBRDrawStatus _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public delegate void EndGBRProgramEventHandler(
   GBRDrawStatus status
)
This language is not supported or no code example is available.

Parameters

status

Type: GBRDrawStatus

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImport.GBR Namespace


ApertureType Enumeration

Enum of aperture types

Namespace: CADImport.GBR
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Circle | Circle aperture type
FromFile | Aperture type specified in a file
Obround | Oval aperture type
Rectangle | Rectangle aperture type
RegularPolygon | Regular polygon aperture type
See Also

Reference

CADImport.GBR Namespace


DCommand Enumeration

GBR file D code (plot functions). Selects and controls tools, specify line type, etc. For more information please see Gerber RS-274X Format User’s Guide.

Namespace: CADImport.GBR
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
D01 | Draw line, exposure on
D02 | Exposure off
D03 | Flash aperture
SelectByAd | Select an aperture defined by an AD parameter.
See Also

Reference

CADImport.GBR Namespace


GBRDrawStatus Enumeration

Current status of GBR file loading

Namespace: CADImport.GBR
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
EndProgram | Loading is finished
OptionalStop | Loading is paused
ProgramStop | Loading is stopped
RunProgram | Loading is in progress
See Also

Reference

CADImport.GBR Namespace


GCommand Enumeration

GBR file G code (general functions). Specifies how to interpolate and move to the coordinate locations following the code until changed or until a new layer is generated (modal). For more information please see Gerber RS-274X Format User’s Guide.

Namespace: CADImport.GBR
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
G00 | Moves brush tool without drawing
G01 | Specifies linear interpolation (1X scale)
G02 | Specifies clockwise circular interpolation
G03 | Specifies counterclockwise circular interpolation
G10 | Specifies linear interpolation (10X scale)
G11 | Specifies linear interpolation (0.1X scale)
G12 | Specifies linear interpolation (0.01X scale)
G36 | Turns on polygon area fill.
G37 | Turns off polygon area fill.
G54 | Tool prepare
G74 | Turns off 360° circular interpolation
G75 | Turns on 360° circular interpolation
See Also

Reference

CADImport.GBR Namespace


CADImport.GDS Namespace

Assembly: CADImport (in CADImport.dll)

Classes
 | Name | Description
Public class | GDSImage | Represents converted GDS image
Public class | GDSObject | Represents base class for all GDS entities read from the GDS-file
Public class | GDSStructure | Represents GDS structure read from the GDS file
Top
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


GDSImage Class

Members See Also

Represents converted GDS image

Namespace: CADImport.GDS
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class GDSImage
    Inherits CADImage
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class GDSImage : CADImage
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADImage
CADImport.GDS.GDSImage
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GDSImage Members
CADImport.GDS Namespace


GDSImage Members

GDSImage Class Constructors Methods Fields Properties See Also

Represents converted GDS image

The following tables list the members exposed by the GDSImage type.

Constructors
 | Name | Description
Public constructor | GDSImage |
Top
Properties
 | Name | Description
Public property | AbsDepth | Gets an absolute depths of the CADImage. (inherited from CADImage).
Public property | AbsHeight | Gets an absolute height of the CADImage. (inherited from CADImage).
Public property | AbsWidth | Gets an absolute width of the CADImage. (inherited from CADImage).
Public property | Angle | Gets or sets the angle for this CADImage object visualization. (inherited from CADImage).
Public property | BackgroundColor | Gets or sets a background color of this CADImage. (inherited from CADImage).
Public property | BorderSize | Gets or sets a border size in pixels. (inherited from CADImage).
Public property | BorderType | Gets or sets a border type. (inherited from CADImage).
Public property | Center | Gets or sets CADImage center point. (inherited from CADImage).
Public property | Charset | Gets or sets a character set for the text entities. (inherited from CADImage).
 | CodePage | Gets or sets a number that identifies the encoding used in the loaded CAD file. (inherited from CADImage).
Public property | Converter | Gets a converter that loads CAD entities from the file to draw them in the current CADImage. (inherited from CADImage).
Public property | CurrentLayer | Gets or sets a current layer for the CADImage. (inherited from CADImage).
Public property | CurrentLayout | Gets or sets a current layout for the CADImage. (inherited from CADImage).
Public property | CurrentLayoutIndex | Gets an index of the current layout. (inherited from CADImage).
Public property | CurrentMarker | Gets a currently selected marker. (inherited from CADImage).
Public property | DefaultColor | Gets or sets a default color for the CADImage. (inherited from CADImage).
Public property | DefaultFontSize |
Public property | DefaultLayoutIndex | Gets or sets a default layout index. (inherited from CADImage).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions on the drawing are visible. (inherited from CADImage).
Public property | DrawMode | Gets or sets a current drawing mode. (inherited from CADImage).
Public property | EnableSnap | Gets or sets enablement of snap mode (inherited from CADImage).
Public property | Extents | Gets or sets an extents of the CADImage object. (inherited from CADImage).
Public property | FileInf | Gets information about a currently open file by means of the FileInfo class. (inherited from CADImage).
Public property | GDIPainter | Provides drawing functionality based on GDI+. (inherited from CADImage).
Public property | GDSStructures |
Public property | GraphicsOutMode | Specifies image draw mode. (inherited from CADImage).
 | ImportClosedPoly | Gets the value or sets CADPolyLine, received from GDSPath as Closed if Width is zero and the first and the last points of GDSPath coincide
Public property | InterpolationMode | Gets or sets the interpolation mode associated with current Graphics object (inherited from CADImage).
Public property | Is3D | Gets a value indicating whether this CADImage is three-dimensional. (inherited from CADImage).
Public property | IsDraw3DAxes | Gets or sets a value indicating whether 3D axes are shown on the drawing. (inherited from CADImage).
Public property | IsDrawingRotated | Gets a value indicating whether the CADImage has been rotated. (inherited from CADImage).
Public property | IsShowBackground | Gets or sets a value indicating using of a BackgroundColor. (inherited from CADImage).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data. (inherited from CADImage).
Public property | IsSnapObject | Gets a value, which shows if there is an object for snapping under current coordinates (inherited from CADImage).
Public property | IsStopped | For internal use. (inherited from CADImage).
Public property | IsWithoutBorder | Gest or sets a value indicating whether to draw the CADImage without borders. (inherited from CADImage).
Public property | IsWithoutMargins | Gets or sets a value indicating whether to draw the CADImage without margins. (inherited from CADImage).
 | LastLoadedFilePath | Specifying of the search directory (used for X-Refs, ImageEnt) (inherited from CADImage).
Public property | LayersCount | Gets a quantity of layers in this CADImage. (inherited from CADImage).
Public property | Layouts | Gets a collection of layouts in the current CADImage. (inherited from CADImage).
Public property | LayoutsCount | Gets a quantity of layouts in this CADImage. (inherited from CADImage).
Public property | LineScaled | Obsolete. Gets or sets a value indicating whether a width of lines to draw all entities in the drawing is specified by the file data. (inherited from CADImage).
Public property | LineWeightScale | Gets or sets a scale for drawing lines. (inherited from CADImage).
Public property | MMToPixelX | Gets or sets a value corresponding to amount of millimeters per one pixel. (inherited from CADImage).
Public property | NullWidth | Gets or sets default thickness for lines used to draw a CADImage. (inherited from CADImage).
Public property | NumberOfPartsInCircle | Gets or sets a quantity of segments to be used to draw a circle. (inherited from CADImage).
Public property | Painter | Provides image drawing functionality. (inherited from CADImage).
Public property | PrintDialog | Gets or sets print dialog (inherited from CADImage).
Public property | PureExtents | Gets CADImage extents without margins. (inherited from CADImage).
Public property | ResizeDisproportionateDrawing | For internal use (inherited from CADImage).
Public property | SHXSearchPaths | Gets or sets paths for searching SHX fonts. (inherited from CADImage).
Public property | SearchSHXPaths | Gets or sets a value specifying whether SHX paths will be searched for the fonts. (inherited from CADImage).
Public property | SelectEntitiesCount | Gets the number of selected entities (inherited from CADImage).
Public property | SelectedEntities | Gets or sets a list of selected entities (inherited from CADImage).
Public property | SelectionMode | Gets or sets a state of the Selection tool. (inherited from CADImage).
Public property | Selector | Provides selection functionality. (inherited from CADImage).
Public property | SkipMMtoPixel | For specific use (inherited from CADImage).
Public property | SnapCurrent | (inherited from CADImage).
Public property | SnapOptions | Represents Snap options for the CADImage object (inherited from CADImage).
Public property | SnapRealPoint | Gets a current point in absolute coordinates (drawing coordinates) (inherited from CADImage).
Public property | SnapScreenPoint | Gets current point in display coordinates (inherited from CADImage).
Public property | TTFSmoothing | Gets or sets a value indicating whether TTF fonts are smoothed. (inherited from CADImage).
Public property | TextVisible | Gets or sets a value indicating whether the texts in the CADImage are visible. (inherited from CADImage).
Public property | UndoMode | Gets or sets whether undo/redo is disable or enable for professional version (inherited from CADImage).
Public property | UseDoubleBuffering | Outdated. Does nothing (inherited from CADImage).
Public property | UseLayerPriority | (inherited from CADImage).
Public property | UseMultyTTFFonts | Gets or sets a value indicating whether a multimode is used for showing symbols. (inherited from CADImage).
Public property | UseNullWidth | Specifies if default width will be used instead of entity width. (inherited from CADImage).
Public property | UseSHXFonts | Specifies if SHX fonts will be used for visualization. (inherited from CADImage).
Public property | UseTTFFonts | Specifies if TTF fonts will be used for visualization. (inherited from CADImage).
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles in the CADImage are drawn with GDI+ drawing methods without linearization. (inherited from CADImage).
Top
Methods
 | Name | Description
Public method | ActiveVPort | Returns drawing area visualized with the active VPort. (inherited from CADImage).
Public method | AddScaledDXF | Adds a scaled external reference to the model space of the specified CAD image. (inherited from CADImage).
Public method | AddScaledDXFEx | Adds a scaled external reference to the current layout of the specified CAD image. (inherited from CADImage).
Public method | AddToUndoList | (Overloaded) Adds operation "create new Entity" to undo list (inherited from CADImage).
Public method | ChangeDrawMode | Initializes a new graphic class object if current mode changed. (inherited from CADImage).
Public method | ChangeEntities | (inherited from CADImage).
Public method | ChangeGraphicsMode | Changes image drawing mode. (inherited from CADImage).
Public method | ChangePositionSelectedEntities | Changes position of the selected entities (inherited from CADImage).
Public method | ChangePositionSelectedEntity | Changes a position of the selected entity. (inherited from CADImage).
Public method | ClearBuffer | Outdated. Does nothing (inherited from CADImage).
Public method | ClearMarkers | Clears a collection of markers. (inherited from CADImage).
Public method | ClearRedoCollection | Clears redo entity collection (inherited from CADImage).
Public method | ClearSelectCollection | Clears a collection of the selected entities. (inherited from CADImage).
Public method | ClearSelection | Clears a list of the selected entities. (inherited from CADImage).
Public method | ClearSnapTrace | (Overloaded) Clears last drawn snap drawing element (inherited from CADImage).
Public method | ClearUndoCollection | Clears undo entity collection (inherited from CADImage).
Public method | CopyEntities | (Overloaded) Copies selected entities to the clipboard (inherited from CADImage).
Public method | CorrectByGrid | (Overloaded) Reduces a point location on screen to the grid node when the grid is active (inherited from CADImage).
Public method | CorrectByGridAndOrtho | Reduces a point relocation sizes on screen to the grid cell sizes when the grid is active (inherited from CADImage).
 | CreateImageByExtension | Creates specialised CADImage object for specified file extention (inherited from CADImage).
Public method | CutEntities | (Overloaded) Cuts selected entities from collection and paste them to the clipboard (inherited from CADImage).
Public method | Dispose | Disposes a CADImage object. (inherited from CADImage).
Public method | DoSelectEntities | (Overloaded) Selects inserted list of entities (inherited from CADImage).
Public method | DoSelectEntity | Selects inserted entity (inherited from CADImage).
Public method | Draw | (Overloaded) Draws a CADImage. (inherited from CADImage).
Public method | DrawACISEntity | Draws ACISEntity object (inherited from CADImage).
Public method | DrawChangeEntity | Changes a position of the marker designating the selected entity. (inherited from CADImage).
Public method | DrawMoveEntityTrace | Draws entities on their offsetting (inherited from CADImage).
Public method | DrawSnapTrace | Draws snap icon in case of proximity of object to current coordinates (inherited from CADImage).
Public method | EmfConvertToDXF | (Overloaded) Converts emf file to dxf file (inherited from CADImage).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportToMetafile | (Overloaded) Exports a CAD drawing to Windows Enhanced metafile. (inherited from CADImage).
Public method | GetAbsPoint | Converts display coordinates into absolute coordinates of a design (inherited from CADImage).
Public method | GetCADCoords | Returns coordinates of a point on the drawing. (inherited from CADImage).
Public method | GetCenter | Returns the center point of a current layout (inherited from CADImage).
Public method | GetExtents | Calculates the current dimensions of the CADImage. (inherited from CADImage).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLayerColor | Gets layer color by index (inherited from CADImage).
Public method | GetLayerFreeze | Determines whether the layer (CADLayer) is frozen. (inherited from CADImage).
Public method | GetLayerName | Gets a name of the layer that has the specified index in the collection of layers. (inherited from CADImage).
Public method | GetLayerVisible | Determines whether a layer is visible (inherited from CADImage).
Public method | GetLayoutName | Gets a name of the layout that has the specified index in the collection of layouts. (inherited from CADImage).
Public method | GetPoint | Transforms a three-dimensional CAD point into a two-dimensional screen point. (inherited from CADImage).
Public method | GetRealImagePoint | For internal use. (inherited from CADImage).
Public method | GetRealSnapPoint | Smooths a point in absolute coordinates by the entity (inherited from CADImage).
Public method | GetSelectEntityRegion | Returns the selected area of the image. (inherited from CADImage).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetVPortExtents | Returns extents of the active VPort reduced to the specified size (inherited from CADImage).
Public method | InitialNewImage | (Overloaded) Initializes a new image with the default size (inherited from CADImage).
Public method | InvalidateSelectEntity | Redraws a selected entity. (inherited from CADImage).
Public method | InvalidateSelectedEntities | (Overloaded) Redraws a list of the selected entities (inherited from CADImage).
Public method | LoadFromFile | Uses for redefining in a descendant classes, define loading image from the specified file. (inherited from CADImage).
Public method | LoadFromStream | Loads a CAD image stored in the specified stream.
Public method | LoadFromStructureList |
Public method | LoadFromWeb | Loads CAD image from hyperlink (inherited from CADImage).
Public method | MultipleSelect | Providing CAD image entities' multiple selection within a specified rectangle. (inherited from CADImage).
Public method | MultipleSelectExt | Selects all entities inside the inserted rectangle (inherited from CADImage).
Public method | PasteEntities | Pastes entities from the clipboard (inherited from CADImage).
Public method | PasteEntitiesExt | Pastes entities from the clipboard (inherited from CADImage).
Public method | Print | Prints a current CAD image. (inherited from CADImage).
Public method | Redo | Redo change (inherited from CADImage).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RefreshCurrentLayout | Refresh current layout. (inherited from CADImage).
Public method | RefreshSnapTrace | Refreshes a region of the last drawn snap drawing element (inherited from CADImage).
Public method | RemoveEntity | (Overloaded) Removes CADEntity object. (inherited from CADImage).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from CADImage).
Public method | RotToView | Rotates a CAD image to get a specified view. (inherited from CADImage).
Public method | Rotate | Rotates objects in the current drawing. (inherited from CADImage).
Public method | SaveAsDXF | Saves a current CAD image in DXF format. (inherited from CADImage).
Public method | SaveImageToClipboard | (Overloaded) Writes a visible part of the current CAD image to the clipboard as a raster image. (inherited from CADImage).
Public method | SaveToFile | (Overloaded) Saves a part of the current CAD image to the file of the specified format. (inherited from CADImage).
Public method | SaveToStream | (Overloaded) Writes a visible part of the current CAD image to the specified stream as a raster image. (inherited from CADImage).
Public method | Select | Selects an entity of the CAD image at the specified point. (inherited from CADImage).
Public method | SelectExt | Selects an entity of the CAD image at the specified point. (inherited from CADImage).
Public method | SetCenter | Sets CADImage center point. (inherited from CADImage).
Public method | SetCurrentLayout | Sets a current layout of this CADImage. (inherited from CADImage).
Public method | SetLayerColor | (Overloaded) Sets a color for layer (CADLayer) specified by index (inherited from CADImage).
Public method | SetLayerFreeze | (Overloaded) Sets freeze parameter for CADLayer (inherited from CADImage).
Public method | SetLayerVisible | (Overloaded) Sets a visibility of the layer. (inherited from CADImage).
Public method | SetNewEntityMarkerPos | Sets a new position for the selected entity. The entity's new position is defined by the position of the marker. (inherited from CADImage).
Public method | SetNewMMToPixel | Sets a quantity of millimeters per pixel for the specified Graphics object. (inherited from CADImage).
Public method | SetNewPosEntitiesExt | Sets a new position for the specified entities (inherited from CADImage).
Public method | SetNewPosEntity | Sets a new position for the specified entity. (inherited from CADImage).
Public method | Stop | For internal use. (inherited from CADImage).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | Undo | Undo change (inherited from CADImage).
Top
Fields
 | Name | Description
 | EntityBuffer | Represents buffer for CADEntityCollection storing. (inherited from CADImage).
Public field | visibleArea | Represents CADImage visible area. (inherited from CADImage).
Top
See Also

Reference

GDSImage Class
CADImport.GDS Namespace


GDSImage Constructor

Namespace: CADImport.GDS
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public GDSImage()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GDSImage Class
GDSImage Members
CADImport.GDS Namespace


GDSImage Properties

GDSImage Class See Also

The following tables list the members exposed by the GDSImage type.

Properties
 | Name | Description
Public property | AbsDepth | Gets an absolute depths of the CADImage. (inherited from CADImage).
Public property | AbsHeight | Gets an absolute height of the CADImage. (inherited from CADImage).
Public property | AbsWidth | Gets an absolute width of the CADImage. (inherited from CADImage).
Public property | Angle | Gets or sets the angle for this CADImage object visualization. (inherited from CADImage).
Public property | BackgroundColor | Gets or sets a background color of this CADImage. (inherited from CADImage).
Public property | BorderSize | Gets or sets a border size in pixels. (inherited from CADImage).
Public property | BorderType | Gets or sets a border type. (inherited from CADImage).
Public property | Center | Gets or sets CADImage center point. (inherited from CADImage).
Public property | Charset | Gets or sets a character set for the text entities. (inherited from CADImage).
 | CodePage | Gets or sets a number that identifies the encoding used in the loaded CAD file. (inherited from CADImage).
Public property | Converter | Gets a converter that loads CAD entities from the file to draw them in the current CADImage. (inherited from CADImage).
Public property | CurrentLayer | Gets or sets a current layer for the CADImage. (inherited from CADImage).
Public property | CurrentLayout | Gets or sets a current layout for the CADImage. (inherited from CADImage).
Public property | CurrentLayoutIndex | Gets an index of the current layout. (inherited from CADImage).
Public property | CurrentMarker | Gets a currently selected marker. (inherited from CADImage).
Public property | DefaultColor | Gets or sets a default color for the CADImage. (inherited from CADImage).
Public property | DefaultFontSize |
Public property | DefaultLayoutIndex | Gets or sets a default layout index. (inherited from CADImage).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions on the drawing are visible. (inherited from CADImage).
Public property | DrawMode | Gets or sets a current drawing mode. (inherited from CADImage).
Public property | EnableSnap | Gets or sets enablement of snap mode (inherited from CADImage).
Public property | Extents | Gets or sets an extents of the CADImage object. (inherited from CADImage).
Public property | FileInf | Gets information about a currently open file by means of the FileInfo class. (inherited from CADImage).
Public property | GDIPainter | Provides drawing functionality based on GDI+. (inherited from CADImage).
Public property | GDSStructures |
Public property | GraphicsOutMode | Specifies image draw mode. (inherited from CADImage).
 | ImportClosedPoly | Gets the value or sets CADPolyLine, received from GDSPath as Closed if Width is zero and the first and the last points of GDSPath coincide
Public property | InterpolationMode | Gets or sets the interpolation mode associated with current Graphics object (inherited from CADImage).
Public property | Is3D | Gets a value indicating whether this CADImage is three-dimensional. (inherited from CADImage).
Public property | IsDraw3DAxes | Gets or sets a value indicating whether 3D axes are shown on the drawing. (inherited from CADImage).
Public property | IsDrawingRotated | Gets a value indicating whether the CADImage has been rotated. (inherited from CADImage).
Public property | IsShowBackground | Gets or sets a value indicating using of a BackgroundColor. (inherited from CADImage).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data. (inherited from CADImage).
Public property | IsSnapObject | Gets a value, which shows if there is an object for snapping under current coordinates (inherited from CADImage).
Public property | IsStopped | For internal use. (inherited from CADImage).
Public property | IsWithoutBorder | Gest or sets a value indicating whether to draw the CADImage without borders. (inherited from CADImage).
Public property | IsWithoutMargins | Gets or sets a value indicating whether to draw the CADImage without margins. (inherited from CADImage).
 | LastLoadedFilePath | Specifying of the search directory (used for X-Refs, ImageEnt) (inherited from CADImage).
Public property | LayersCount | Gets a quantity of layers in this CADImage. (inherited from CADImage).
Public property | Layouts | Gets a collection of layouts in the current CADImage. (inherited from CADImage).
Public property | LayoutsCount | Gets a quantity of layouts in this CADImage. (inherited from CADImage).
Public property | LineScaled | Obsolete. Gets or sets a value indicating whether a width of lines to draw all entities in the drawing is specified by the file data. (inherited from CADImage).
Public property | LineWeightScale | Gets or sets a scale for drawing lines. (inherited from CADImage).
Public property | MMToPixelX | Gets or sets a value corresponding to amount of millimeters per one pixel. (inherited from CADImage).
Public property | NullWidth | Gets or sets default thickness for lines used to draw a CADImage. (inherited from CADImage).
Public property | NumberOfPartsInCircle | Gets or sets a quantity of segments to be used to draw a circle. (inherited from CADImage).
Public property | Painter | Provides image drawing functionality. (inherited from CADImage).
Public property | PrintDialog | Gets or sets print dialog (inherited from CADImage).
Public property | PureExtents | Gets CADImage extents without margins. (inherited from CADImage).
Public property | ResizeDisproportionateDrawing | For internal use (inherited from CADImage).
Public property | SHXSearchPaths | Gets or sets paths for searching SHX fonts. (inherited from CADImage).
Public property | SearchSHXPaths | Gets or sets a value specifying whether SHX paths will be searched for the fonts. (inherited from CADImage).
Public property | SelectEntitiesCount | Gets the number of selected entities (inherited from CADImage).
Public property | SelectedEntities | Gets or sets a list of selected entities (inherited from CADImage).
Public property | SelectionMode | Gets or sets a state of the Selection tool. (inherited from CADImage).
Public property | Selector | Provides selection functionality. (inherited from CADImage).
Public property | SkipMMtoPixel | For specific use (inherited from CADImage).
Public property | SnapCurrent | (inherited from CADImage).
Public property | SnapOptions | Represents Snap options for the CADImage object (inherited from CADImage).
Public property | SnapRealPoint | Gets a current point in absolute coordinates (drawing coordinates) (inherited from CADImage).
Public property | SnapScreenPoint | Gets current point in display coordinates (inherited from CADImage).
Public property | TTFSmoothing | Gets or sets a value indicating whether TTF fonts are smoothed. (inherited from CADImage).
Public property | TextVisible | Gets or sets a value indicating whether the texts in the CADImage are visible. (inherited from CADImage).
Public property | UndoMode | Gets or sets whether undo/redo is disable or enable for professional version (inherited from CADImage).
Public property | UseDoubleBuffering | Outdated. Does nothing (inherited from CADImage).
Public property | UseLayerPriority | (inherited from CADImage).
Public property | UseMultyTTFFonts | Gets or sets a value indicating whether a multimode is used for showing symbols. (inherited from CADImage).
Public property | UseNullWidth | Specifies if default width will be used instead of entity width. (inherited from CADImage).
Public property | UseSHXFonts | Specifies if SHX fonts will be used for visualization. (inherited from CADImage).
Public property | UseTTFFonts | Specifies if TTF fonts will be used for visualization. (inherited from CADImage).
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles in the CADImage are drawn with GDI+ drawing methods without linearization. (inherited from CADImage).
Top
See Also

Reference

GDSImage Class
CADImport.GDS Namespace


GDSImage.DefaultFontSize Property

Namespace: CADImport.GDS
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DefaultFontSize() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int DefaultFontSize {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GDSImage Class
GDSImage Members
CADImport.GDS Namespace


GDSImage.GDSStructures Property

Namespace: CADImport.GDS
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property GDSStructures() As List(Of GDSStructure)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public List<GDSStructure> GDSStructures {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GDSImage Class
GDSImage Members
CADImport.GDS Namespace


GDSImage.ImportClosedPoly Property

Gets the value or sets CADPolyLine, received from GDSPath as Closed if Width is zero and the first and the last points of GDSPath coincide

Namespace: CADImport.GDS
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Property ImportClosedPoly() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool ImportClosedPoly {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GDSImage Class
GDSImage Members
CADImport.GDS Namespace


GDSImage Methods

GDSImage Class See Also

The following tables list the members exposed by the GDSImage type.

Methods
 | Name | Description
Public method | ActiveVPort | Returns drawing area visualized with the active VPort. (inherited from CADImage).
Public method | AddScaledDXF | Adds a scaled external reference to the model space of the specified CAD image. (inherited from CADImage).
Public method | AddScaledDXFEx | Adds a scaled external reference to the current layout of the specified CAD image. (inherited from CADImage).
Public method | AddToUndoList | (Overloaded) Adds operation "create new Entity" to undo list (inherited from CADImage).
Public method | ChangeDrawMode | Initializes a new graphic class object if current mode changed. (inherited from CADImage).
Public method | ChangeEntities | (inherited from CADImage).
Public method | ChangeGraphicsMode | Changes image drawing mode. (inherited from CADImage).
Public method | ChangePositionSelectedEntities | Changes position of the selected entities (inherited from CADImage).
Public method | ChangePositionSelectedEntity | Changes a position of the selected entity. (inherited from CADImage).
Public method | ClearBuffer | Outdated. Does nothing (inherited from CADImage).
Public method | ClearMarkers | Clears a collection of markers. (inherited from CADImage).
Public method | ClearRedoCollection | Clears redo entity collection (inherited from CADImage).
Public method | ClearSelectCollection | Clears a collection of the selected entities. (inherited from CADImage).
Public method | ClearSelection | Clears a list of the selected entities. (inherited from CADImage).
Public method | ClearSnapTrace | (Overloaded) Clears last drawn snap drawing element (inherited from CADImage).
Public method | ClearUndoCollection | Clears undo entity collection (inherited from CADImage).
Public method | CopyEntities | (Overloaded) Copies selected entities to the clipboard (inherited from CADImage).
Public method | CorrectByGrid | (Overloaded) Reduces a point location on screen to the grid node when the grid is active (inherited from CADImage).
Public method | CorrectByGridAndOrtho | Reduces a point relocation sizes on screen to the grid cell sizes when the grid is active (inherited from CADImage).
 | CreateImageByExtension | Creates specialised CADImage object for specified file extention (inherited from CADImage).
Public method | CutEntities | (Overloaded) Cuts selected entities from collection and paste them to the clipboard (inherited from CADImage).
Public method | Dispose | Disposes a CADImage object. (inherited from CADImage).
Public method | DoSelectEntities | (Overloaded) Selects inserted list of entities (inherited from CADImage).
Public method | DoSelectEntity | Selects inserted entity (inherited from CADImage).
Public method | Draw | (Overloaded) Draws a CADImage. (inherited from CADImage).
Public method | DrawACISEntity | Draws ACISEntity object (inherited from CADImage).
Public method | DrawChangeEntity | Changes a position of the marker designating the selected entity. (inherited from CADImage).
Public method | DrawMoveEntityTrace | Draws entities on their offsetting (inherited from CADImage).
Public method | DrawSnapTrace | Draws snap icon in case of proximity of object to current coordinates (inherited from CADImage).
Public method | EmfConvertToDXF | (Overloaded) Converts emf file to dxf file (inherited from CADImage).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportToMetafile | (Overloaded) Exports a CAD drawing to Windows Enhanced metafile. (inherited from CADImage).
Public method | GetAbsPoint | Converts display coordinates into absolute coordinates of a design (inherited from CADImage).
Public method | GetCADCoords | Returns coordinates of a point on the drawing. (inherited from CADImage).
Public method | GetCenter | Returns the center point of a current layout (inherited from CADImage).
Public method | GetExtents | Calculates the current dimensions of the CADImage. (inherited from CADImage).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLayerColor | Gets layer color by index (inherited from CADImage).
Public method | GetLayerFreeze | Determines whether the layer (CADLayer) is frozen. (inherited from CADImage).
Public method | GetLayerName | Gets a name of the layer that has the specified index in the collection of layers. (inherited from CADImage).
Public method | GetLayerVisible | Determines whether a layer is visible (inherited from CADImage).
Public method | GetLayoutName | Gets a name of the layout that has the specified index in the collection of layouts. (inherited from CADImage).
Public method | GetPoint | Transforms a three-dimensional CAD point into a two-dimensional screen point. (inherited from CADImage).
Public method | GetRealImagePoint | For internal use. (inherited from CADImage).
Public method | GetRealSnapPoint | Smooths a point in absolute coordinates by the entity (inherited from CADImage).
Public method | GetSelectEntityRegion | Returns the selected area of the image. (inherited from CADImage).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetVPortExtents | Returns extents of the active VPort reduced to the specified size (inherited from CADImage).
Public method | InitialNewImage | (Overloaded) Initializes a new image with the default size (inherited from CADImage).
Public method | InvalidateSelectEntity | Redraws a selected entity. (inherited from CADImage).
Public method | InvalidateSelectedEntities | (Overloaded) Redraws a list of the selected entities (inherited from CADImage).
Public method | LoadFromFile | Uses for redefining in a descendant classes, define loading image from the specified file. (inherited from CADImage).
Public method | LoadFromStream | Loads a CAD image stored in the specified stream.
Public method | LoadFromStructureList |
Public method | LoadFromWeb | Loads CAD image from hyperlink (inherited from CADImage).
Public method | MultipleSelect | Providing CAD image entities' multiple selection within a specified rectangle. (inherited from CADImage).
Public method | MultipleSelectExt | Selects all entities inside the inserted rectangle (inherited from CADImage).
Public method | PasteEntities | Pastes entities from the clipboard (inherited from CADImage).
Public method | PasteEntitiesExt | Pastes entities from the clipboard (inherited from CADImage).
Public method | Print | Prints a current CAD image. (inherited from CADImage).
Public method | Redo | Redo change (inherited from CADImage).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RefreshCurrentLayout | Refresh current layout. (inherited from CADImage).
Public method | RefreshSnapTrace | Refreshes a region of the last drawn snap drawing element (inherited from CADImage).
Public method | RemoveEntity | (Overloaded) Removes CADEntity object. (inherited from CADImage).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from CADImage).
Public method | RotToView | Rotates a CAD image to get a specified view. (inherited from CADImage).
Public method | Rotate | Rotates objects in the current drawing. (inherited from CADImage).
Public method | SaveAsDXF | Saves a current CAD image in DXF format. (inherited from CADImage).
Public method | SaveImageToClipboard | (Overloaded) Writes a visible part of the current CAD image to the clipboard as a raster image. (inherited from CADImage).
Public method | SaveToFile | (Overloaded) Saves a part of the current CAD image to the file of the specified format. (inherited from CADImage).
Public method | SaveToStream | (Overloaded) Writes a visible part of the current CAD image to the specified stream as a raster image. (inherited from CADImage).
Public method | Select | Selects an entity of the CAD image at the specified point. (inherited from CADImage).
Public method | SelectExt | Selects an entity of the CAD image at the specified point. (inherited from CADImage).
Public method | SetCenter | Sets CADImage center point. (inherited from CADImage).
Public method | SetCurrentLayout | Sets a current layout of this CADImage. (inherited from CADImage).
Public method | SetLayerColor | (Overloaded) Sets a color for layer (CADLayer) specified by index (inherited from CADImage).
Public method | SetLayerFreeze | (Overloaded) Sets freeze parameter for CADLayer (inherited from CADImage).
Public method | SetLayerVisible | (Overloaded) Sets a visibility of the layer. (inherited from CADImage).
Public method | SetNewEntityMarkerPos | Sets a new position for the selected entity. The entity's new position is defined by the position of the marker. (inherited from CADImage).
Public method | SetNewMMToPixel | Sets a quantity of millimeters per pixel for the specified Graphics object. (inherited from CADImage).
Public method | SetNewPosEntitiesExt | Sets a new position for the specified entities (inherited from CADImage).
Public method | SetNewPosEntity | Sets a new position for the specified entity. (inherited from CADImage).
Public method | Stop | For internal use. (inherited from CADImage).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | Undo | Undo change (inherited from CADImage).
Top
See Also

Reference

GDSImage Class
CADImport.GDS Namespace


GDSImage.LoadFromStream Method

Loads a CAD image stored in the specified stream.

Namespace: CADImport.GDS
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub LoadFromStream( _
   ByVal stream As Stream _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void LoadFromStream(
   Stream stream
)
This language is not supported or no code example is available.

Parameters

stream

Type: Stream

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GDSImage Class
GDSImage Members
CADImport.GDS Namespace


GDSImage.LoadFromStructureList Method

Namespace: CADImport.GDS
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub LoadFromStructureList( _
   ByVal structures As List(Of GDSStructure) _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void LoadFromStructureList(
   List<GDSStructure> structures
)
This language is not supported or no code example is available.

Parameters

structures

Type: List<GDSStructure>

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GDSImage Class
GDSImage Members
CADImport.GDS Namespace


GDSImage Fields

GDSImage Class See Also

The following tables list the members exposed by the GDSImage type.

Fields
 | Name | Description
 | EntityBuffer | Represents buffer for CADEntityCollection storing. (inherited from CADImage).
Public field | visibleArea | Represents CADImage visible area. (inherited from CADImage).
Top
See Also

Reference

GDSImage Class
CADImport.GDS Namespace


GDSObject Class

Members See Also

Represents base class for all GDS entities read from the GDS-file

Namespace: CADImport.GDS
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public MustInherit Class GDSObject
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public abstract class GDSObject
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.GDS.GDSObject
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GDSObject Members
CADImport.GDS Namespace


GDSObject Members

GDSObject Class Methods Properties See Also

Represents base class for all GDS entities read from the GDS-file

The following tables list the members exposed by the GDSObject type.

Properties
 | Name | Description
Public property | DataType |
Public property | Layer |
Public property | Width |
Top
Methods
 | Name | Description
Public method | AddPoint |
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToCADEntity |
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

GDSObject Class
CADImport.GDS Namespace


GDSObject Properties

GDSObject Class See Also

The following tables list the members exposed by the GDSObject type.

Properties
 | Name | Description
Public property | DataType |
Public property | Layer |
Public property | Width |
Top
See Also

Reference

GDSObject Class
CADImport.GDS Namespace


GDSObject.DataType Property

Namespace: CADImport.GDS
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DataType() As Short
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public short DataType {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GDSObject Class
GDSObject Members
CADImport.GDS Namespace


GDSObject.Layer Property

Namespace: CADImport.GDS
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Layer() As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public byte Layer {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GDSObject Class
GDSObject Members
CADImport.GDS Namespace


GDSObject.Width Property

Namespace: CADImport.GDS
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Property Width() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual double Width {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GDSObject Class
GDSObject Members
CADImport.GDS Namespace


GDSObject Methods

GDSObject Class See Also

The following tables list the members exposed by the GDSObject type.

Methods
 | Name | Description
Public method | AddPoint |
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToCADEntity |
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

GDSObject Class
CADImport.GDS Namespace


GDSObject.AddPoint Method

Namespace: CADImport.GDS
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public MustOverride Sub AddPoint( _
   ByVal x As Double, _
   ByVal y As Double _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public abstract void AddPoint(
   double x,
   double y
)
This language is not supported or no code example is available.

Parameters

x

Type: double

y

Type: double

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GDSObject Class
GDSObject Members
CADImport.GDS Namespace


GDSObject.ToCADEntity Method

Namespace: CADImport.GDS
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Function ToCADEntity( _
   ByVal conv As CADConverter _
) As CADEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual CADEntity ToCADEntity(
   CADConverter conv
)
This language is not supported or no code example is available.

Parameters

conv

Type: CADConverter

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GDSObject Class
GDSObject Members
CADImport.GDS Namespace


GDSStructure Class

Members See Also

Represents GDS structure read from the GDS file

Namespace: CADImport.GDS
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class GDSStructure
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class GDSStructure
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.GDS.GDSStructure
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GDSStructure Members
CADImport.GDS Namespace


GDSStructure Members

GDSStructure Class Methods Properties See Also

Represents GDS structure read from the GDS file

The following tables list the members exposed by the GDSStructure type.

Properties
 | Name | Description
Public property | CreationDate |
Public property | Entities |
Public property | ModificationDate |
Public property | Name |
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object.
Top
See Also

Reference

GDSStructure Class
CADImport.GDS Namespace


GDSStructure Properties

GDSStructure Class See Also

The following tables list the members exposed by the GDSStructure type.

Properties
 | Name | Description
Public property | CreationDate |
Public property | Entities |
Public property | ModificationDate |
Public property | Name |
Top
See Also

Reference

GDSStructure Class
CADImport.GDS Namespace


GDSStructure.CreationDate Property

Namespace: CADImport.GDS
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property CreationDate() As Date
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DateTime CreationDate {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GDSStructure Class
GDSStructure Members
CADImport.GDS Namespace


GDSStructure.Entities Property

Namespace: CADImport.GDS
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Entities() As List(Of GDSObject)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public List<GDSObject> Entities {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GDSStructure Class
GDSStructure Members
CADImport.GDS Namespace


GDSStructure.ModificationDate Property

Namespace: CADImport.GDS
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ModificationDate() As Date
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DateTime ModificationDate {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GDSStructure Class
GDSStructure Members
CADImport.GDS Namespace


GDSStructure.Name Property

Namespace: CADImport.GDS
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Name() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string Name {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GDSStructure Class
GDSStructure Members
CADImport.GDS Namespace


GDSStructure Methods

GDSStructure Class See Also

The following tables list the members exposed by the GDSStructure type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object.
Top
See Also

Reference

GDSStructure Class
CADImport.GDS Namespace


GDSStructure.ToString Method

Returns a String that represents the current Object.

Namespace: CADImport.GDS
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function ToString() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override string ToString()
This language is not supported or no code example is available.

Return Value

A String that represents the current Object.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GDSStructure Class
GDSStructure Members
CADImport.GDS Namespace


CADImport.HPGL2 Namespace

Assembly: CADImport (in CADImport.dll)

Classes
 | Name | Description
Public class | HPGLImage | Represents HPGL image.
Public class | HPGLLayout | Represents a layout of the HPGL drawing.
Top
Structures
 | Name | Description
Public structure | PaperSize | Represents paper sizes in millimetres
Top
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


HPGLImage Class

Members See Also

Represents HPGL image.

Namespace: CADImport.HPGL2
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class HPGLImage
    Inherits CADImage
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class HPGLImage : CADImage
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADImage
CADImport.HPGL2.HPGLImage
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HPGLImage Members
CADImport.HPGL2 Namespace


HPGLImage Members

HPGLImage Class Constructors Methods Fields Properties See Also

Represents HPGL image.

The following tables list the members exposed by the HPGLImage type.

Constructors
 | Name | Description
Public constructor | HPGLImage | Initializes a new instance of the HPGLImage class.
Top
Properties
 | Name | Description
Public property | AbsDepth | Gets an absolute depths of the CADImage. (inherited from CADImage).
Public property | AbsHeight | Gets an absolute height of the CADImage. (inherited from CADImage).
Public property | AbsWidth | Gets an absolute width of the CADImage. (inherited from CADImage).
Public property | Angle | Gets or sets the angle for this CADImage object visualization. (inherited from CADImage).
Public property | BackgroundColor | Gets or sets a background color of this CADImage. (inherited from CADImage).
Public property | BorderSize | Gets or sets a border size in pixels. (inherited from CADImage).
Public property | BorderType | Gets or sets a border type. (inherited from CADImage).
Public property | Center | Gets or sets CADImage center point. (inherited from CADImage).
Public property | Charset | Gets or sets a character set for the text entities. (inherited from CADImage).
 | CodePage | Gets or sets a number that identifies the encoding used in the loaded CAD file. (inherited from CADImage).
Public property | Converter | Gets a converter that loads CAD entities from the file to draw them in the current CADImage. (inherited from CADImage).
Public property | CurrentLayer | Gets or sets a current layer for the CADImage. (inherited from CADImage).
Public property | CurrentLayout | Gets or sets a current layout for the CADImage. (inherited from CADImage).
Public property | CurrentLayoutIndex | Gets an index of the current layout. (inherited from CADImage).
Public property | CurrentMarker | Gets a currently selected marker. (inherited from CADImage).
Public property | DefaultColor | Gets or sets a default color for the CADImage. (inherited from CADImage).
Public property | DefaultLayoutIndex | Gets or sets a default layout index. (inherited from CADImage).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions on the drawing are visible. (inherited from CADImage).
Public property | DrawMode | Gets or sets a current drawing mode. (inherited from CADImage).
Public property | EnableSnap | Gets or sets enablement of snap mode (inherited from CADImage).
Public property | Extents | Gets or sets an extents of the CADImage object. (inherited from CADImage).
Public property | FileInf | Gets information about a currently open file by means of the FileInfo class. (inherited from CADImage).
Public property | GDIPainter | Provides drawing functionality based on GDI+. (inherited from CADImage).
Public property | GraphicsOutMode | Specifies image draw mode. (inherited from CADImage).
Public property | InterpolationMode | Gets or sets the interpolation mode associated with current Graphics object (inherited from CADImage).
Public property | Is3D | Gets a value indicating whether this CADImage is three-dimensional. (inherited from CADImage).
Public property | IsDraw3DAxes | Gets or sets a value indicating whether 3D axes are shown on the drawing. (inherited from CADImage).
Public property | IsDrawingRotated | Gets a value indicating whether the CADImage has been rotated. (inherited from CADImage).
Public property | IsShowBackground | Gets or sets a value indicating using of a BackgroundColor. (inherited from CADImage).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data. (inherited from CADImage).
Public property | IsSnapObject | Gets a value, which shows if there is an object for snapping under current coordinates (inherited from CADImage).
Public property | IsStopped | For internal use. (inherited from CADImage).
Public property | IsWithoutBorder | Gest or sets a value indicating whether to draw the CADImage without borders. (inherited from CADImage).
Public property | IsWithoutMargins | Gets or sets a value indicating whether to draw the CADImage without margins. (inherited from CADImage).
 | LastLoadedFilePath | Specifying of the search directory (used for X-Refs, ImageEnt) (inherited from CADImage).
Public property | LayersCount | Gets a quantity of layers in this CADImage. (inherited from CADImage).
Public property | Layouts | Gets a collection of layouts in the current CADImage. (inherited from CADImage).
Public property | LayoutsCount | Gets a quantity of layouts in this CADImage. (inherited from CADImage).
Public property | LineScaled | Obsolete. Gets or sets a value indicating whether a width of lines to draw all entities in the drawing is specified by the file data. (inherited from CADImage).
Public property | LineWeightScale | Gets or sets a scale for drawing lines. (inherited from CADImage).
Public property | MMToPixelX | Gets or sets a value corresponding to amount of millimeters per one pixel. (inherited from CADImage).
Public property | NullWidth | Gets or sets default thickness for lines used to draw a CADImage. (inherited from CADImage).
Public property | NumberOfPartsInCircle | Gets or sets a quantity of segments to be used to draw a circle. (inherited from CADImage).
Public property | Painter | Provides image drawing functionality. (inherited from CADImage).
Public property | PrintDialog | Gets or sets print dialog (inherited from CADImage).
Public property | PureExtents | Gets CADImage extents without margins. (inherited from CADImage).
Public property | ResizeDisproportionateDrawing | For internal use (inherited from CADImage).
Public property | SHXSearchPaths | Gets or sets paths for searching SHX fonts. (inherited from CADImage).
Public property | SearchSHXPaths | Gets or sets a value specifying whether SHX paths will be searched for the fonts. (inherited from CADImage).
Public property | SelectEntitiesCount | Gets the number of selected entities (inherited from CADImage).
Public property | SelectedEntities | Gets or sets a list of selected entities (inherited from CADImage).
Public property | SelectionMode | Gets or sets a state of the Selection tool. (inherited from CADImage).
Public property | Selector | Provides selection functionality. (inherited from CADImage).
Public property | SkipMMtoPixel | For specific use (inherited from CADImage).
Public property | SnapCurrent | (inherited from CADImage).
Public property | SnapOptions | Represents Snap options for the CADImage object (inherited from CADImage).
Public property | SnapRealPoint | Gets a current point in absolute coordinates (drawing coordinates) (inherited from CADImage).
Public property | SnapScreenPoint | Gets current point in display coordinates (inherited from CADImage).
Public property | TTFSmoothing | Gets or sets a value indicating whether TTF fonts are smoothed. (inherited from CADImage).
Public property | TextVisible | Gets or sets a value indicating whether the texts in the CADImage are visible. (inherited from CADImage).
Public property | UndoMode | Gets or sets whether undo/redo is disable or enable for professional version (inherited from CADImage).
Public property | UseDoubleBuffering | Outdated. Does nothing (inherited from CADImage).
Public property | UseLayerPriority | (inherited from CADImage).
Public property | UseMultyTTFFonts | Gets or sets a value indicating whether a multimode is used for showing symbols. (inherited from CADImage).
Public property | UseNullWidth | Specifies if default width will be used instead of entity width. (inherited from CADImage).
Public property | UseSHXFonts | Specifies if SHX fonts will be used for visualization. (inherited from CADImage).
Public property | UseTTFFonts | Specifies if TTF fonts will be used for visualization. (inherited from CADImage).
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles in the CADImage are drawn with GDI+ drawing methods without linearization. (inherited from CADImage).
Top
Methods
 | Name | Description
Public method | ActiveVPort | Returns drawing area visualized with the active VPort. (inherited from CADImage).
Public method | AddScaledDXF | Adds a scaled external reference to the model space of the specified CAD image. (inherited from CADImage).
Public method | AddScaledDXFEx | Adds a scaled external reference to the current layout of the specified CAD image. (inherited from CADImage).
Public method | AddToUndoList | (Overloaded) Adds operation "create new Entity" to undo list (inherited from CADImage).
Public method | ChangeDrawMode | Initializes a new graphic class object if current mode changed. (inherited from CADImage).
Public method | ChangeEntities | (inherited from CADImage).
Public method | ChangeGraphicsMode | Changes image drawing mode. (inherited from CADImage).
Public method | ChangePositionSelectedEntities | Changes position of the selected entities (inherited from CADImage).
Public method | ChangePositionSelectedEntity | Changes a position of the selected entity. (inherited from CADImage).
Public method | ClearBuffer | Outdated. Does nothing (inherited from CADImage).
Public method | ClearMarkers | Clears a collection of markers. (inherited from CADImage).
Public method | ClearRedoCollection | Clears redo entity collection (inherited from CADImage).
Public method | ClearSelectCollection | Clears a collection of the selected entities. (inherited from CADImage).
Public method | ClearSelection | Clears a list of the selected entities. (inherited from CADImage).
Public method | ClearSnapTrace | (Overloaded) Clears last drawn snap drawing element (inherited from CADImage).
Public method | ClearUndoCollection | Clears undo entity collection (inherited from CADImage).
Public method | CopyEntities | (Overloaded) Copies selected entities to the clipboard (inherited from CADImage).
Public method | CorrectByGrid | (Overloaded) Reduces a point location on screen to the grid node when the grid is active (inherited from CADImage).
Public method | CorrectByGridAndOrtho | Reduces a point relocation sizes on screen to the grid cell sizes when the grid is active (inherited from CADImage).
 | CreateImageByExtension | Creates specialised CADImage object for specified file extention (inherited from CADImage).
Public method | CutEntities | (Overloaded) Cuts selected entities from collection and paste them to the clipboard (inherited from CADImage).
Public method | Dispose | Disposes a CADImage object.
Public method | DoSelectEntities | (Overloaded) Selects inserted list of entities (inherited from CADImage).
Public method | DoSelectEntity | Selects inserted entity (inherited from CADImage).
Public method | Draw | (Overloaded) Draws a CADImage. (inherited from CADImage).
Public method | DrawACISEntity | Draws ACISEntity object (inherited from CADImage).
Public method | DrawChangeEntity | Changes a position of the marker designating the selected entity. (inherited from CADImage).
Public method | DrawMoveEntityTrace | Draws entities on their offsetting (inherited from CADImage).
Public method | DrawSnapTrace | Draws snap icon in case of proximity of object to current coordinates (inherited from CADImage).
Public method | EmfConvertToDXF | (Overloaded) Converts emf file to dxf file (inherited from CADImage).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportToMetafile | (Overloaded) Exports a CAD drawing to Windows Enhanced metafile. (inherited from CADImage).
Public method | GetAbsPoint | Converts display coordinates into absolute coordinates of a design (inherited from CADImage).
Public method | GetCADCoords | Returns coordinates of a point on the drawing. (inherited from CADImage).
Public method | GetCenter | Returns the center point of a current layout (inherited from CADImage).
Public method | GetExtents | Calculates the current dimensions of the CADImage. (inherited from CADImage).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLayerColor | Gets layer color by index (inherited from CADImage).
Public method | GetLayerFreeze | Determines whether the layer (CADLayer) is frozen. (inherited from CADImage).
Public method | GetLayerName | Gets a name of the layer that has the specified index in the collection of layers. (inherited from CADImage).
Public method | GetLayerVisible | Determines whether a layer is visible (inherited from CADImage).
Public method | GetLayoutName | Gets a name of the layout that has the specified index in the collection of layouts. (inherited from CADImage).
Public method | GetPoint | Transforms a three-dimensional CAD point into a two-dimensional screen point. (inherited from CADImage).
Public method | GetRealImagePoint | For internal use. (inherited from CADImage).
Public method | GetRealSnapPoint | Smooths a point in absolute coordinates by the entity (inherited from CADImage).
Public method | GetSelectEntityRegion | Returns the selected area of the image. (inherited from CADImage).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetVPortExtents | Returns extents of the active VPort reduced to the specified size (inherited from CADImage).
Public method | InitialNewImage | (Overloaded) Initializes a new image with the default size (inherited from CADImage).
Public method | InvalidateSelectEntity | Redraws a selected entity. (inherited from CADImage).
Public method | InvalidateSelectedEntities | (Overloaded) Redraws a list of the selected entities (inherited from CADImage).
Public method | LoadFromFile | Loads the HPGL image stored in the specified file.
Public method | LoadFromStream | Loads the HPGL image stored in the specified stream.
Public method | LoadFromWeb | Loads CAD image from hyperlink (inherited from CADImage).
Public method | MultipleSelect | Providing CAD image entities' multiple selection within a specified rectangle. (inherited from CADImage).
Public method | MultipleSelectExt | Selects all entities inside the inserted rectangle (inherited from CADImage).
Public method | PasteEntities | Pastes entities from the clipboard (inherited from CADImage).
Public method | PasteEntitiesExt | Pastes entities from the clipboard (inherited from CADImage).
Public method | Print | Prints a current CAD image. (inherited from CADImage).
Public method | Redo | Redo change (inherited from CADImage).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RefreshCurrentLayout | Refresh current layout. (inherited from CADImage).
Public method | RefreshSnapTrace | Refreshes a region of the last drawn snap drawing element (inherited from CADImage).
Public method | RemoveEntity | (Overloaded) Removes CADEntity object. (inherited from CADImage).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from CADImage).
Public method | RotToView | Rotates a CAD image to get a specified view. (inherited from CADImage).
Public method | Rotate | Rotates objects in the current drawing. (inherited from CADImage).
Public method | SaveAsDXF | Saves a current CAD image in DXF format. (inherited from CADImage).
Public method | SaveImageToClipboard | (Overloaded) Writes a visible part of the current CAD image to the clipboard as a raster image. (inherited from CADImage).
Public method | SaveToFile | (Overloaded) Saves a part of the current CAD image to the file of the specified format. (inherited from CADImage).
Public method | SaveToStream | (Overloaded) Writes a visible part of the current CAD image to the specified stream as a raster image. (inherited from CADImage).
Public method | Select | Selects an entity of the CAD image at the specified point. (inherited from CADImage).
Public method | SelectExt | Selects an entity of the CAD image at the specified point. (inherited from CADImage).
Public method | SetCenter | Sets CADImage center point. (inherited from CADImage).
Public method | SetCurrentLayout | Sets a current layout of this CADImage. (inherited from CADImage).
Public method | SetLayerColor | (Overloaded) Sets a color for layer (CADLayer) specified by index (inherited from CADImage).
Public method | SetLayerFreeze | (Overloaded) Sets freeze parameter for CADLayer (inherited from CADImage).
Public method | SetLayerVisible | (Overloaded) Sets a visibility of the layer. (inherited from CADImage).
Public method | SetNewEntityMarkerPos | Sets a new position for the selected entity. The entity's new position is defined by the position of the marker. (inherited from CADImage).
Public method | SetNewMMToPixel | Sets a quantity of millimeters per pixel for the specified Graphics object. (inherited from CADImage).
Public method | SetNewPosEntitiesExt | Sets a new position for the specified entities (inherited from CADImage).
Public method | SetNewPosEntity | Sets a new position for the specified entity. (inherited from CADImage).
Public method | Stop | For internal use. (inherited from CADImage).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | Undo | Undo change (inherited from CADImage).
Top
Fields
 | Name | Description
 | EntityBuffer | Represents buffer for CADEntityCollection storing. (inherited from CADImage).
Public field | visibleArea | Represents CADImage visible area. (inherited from CADImage).
Top
See Also

Reference

HPGLImage Class
CADImport.HPGL2 Namespace


HPGLImage Constructor

Initializes a new instance of the HPGLImage class.

Namespace: CADImport.HPGL2
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public HPGLImage()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HPGLImage Class
HPGLImage Members
CADImport.HPGL2 Namespace


HPGLImage Properties

HPGLImage Class See Also

The following tables list the members exposed by the HPGLImage type.

Properties
 | Name | Description
Public property | AbsDepth | Gets an absolute depths of the CADImage. (inherited from CADImage).
Public property | AbsHeight | Gets an absolute height of the CADImage. (inherited from CADImage).
Public property | AbsWidth | Gets an absolute width of the CADImage. (inherited from CADImage).
Public property | Angle | Gets or sets the angle for this CADImage object visualization. (inherited from CADImage).
Public property | BackgroundColor | Gets or sets a background color of this CADImage. (inherited from CADImage).
Public property | BorderSize | Gets or sets a border size in pixels. (inherited from CADImage).
Public property | BorderType | Gets or sets a border type. (inherited from CADImage).
Public property | Center | Gets or sets CADImage center point. (inherited from CADImage).
Public property | Charset | Gets or sets a character set for the text entities. (inherited from CADImage).
 | CodePage | Gets or sets a number that identifies the encoding used in the loaded CAD file. (inherited from CADImage).
Public property | Converter | Gets a converter that loads CAD entities from the file to draw them in the current CADImage. (inherited from CADImage).
Public property | CurrentLayer | Gets or sets a current layer for the CADImage. (inherited from CADImage).
Public property | CurrentLayout | Gets or sets a current layout for the CADImage. (inherited from CADImage).
Public property | CurrentLayoutIndex | Gets an index of the current layout. (inherited from CADImage).
Public property | CurrentMarker | Gets a currently selected marker. (inherited from CADImage).
Public property | DefaultColor | Gets or sets a default color for the CADImage. (inherited from CADImage).
Public property | DefaultLayoutIndex | Gets or sets a default layout index. (inherited from CADImage).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions on the drawing are visible. (inherited from CADImage).
Public property | DrawMode | Gets or sets a current drawing mode. (inherited from CADImage).
Public property | EnableSnap | Gets or sets enablement of snap mode (inherited from CADImage).
Public property | Extents | Gets or sets an extents of the CADImage object. (inherited from CADImage).
Public property | FileInf | Gets information about a currently open file by means of the FileInfo class. (inherited from CADImage).
Public property | GDIPainter | Provides drawing functionality based on GDI+. (inherited from CADImage).
Public property | GraphicsOutMode | Specifies image draw mode. (inherited from CADImage).
Public property | InterpolationMode | Gets or sets the interpolation mode associated with current Graphics object (inherited from CADImage).
Public property | Is3D | Gets a value indicating whether this CADImage is three-dimensional. (inherited from CADImage).
Public property | IsDraw3DAxes | Gets or sets a value indicating whether 3D axes are shown on the drawing. (inherited from CADImage).
Public property | IsDrawingRotated | Gets a value indicating whether the CADImage has been rotated. (inherited from CADImage).
Public property | IsShowBackground | Gets or sets a value indicating using of a BackgroundColor. (inherited from CADImage).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data. (inherited from CADImage).
Public property | IsSnapObject | Gets a value, which shows if there is an object for snapping under current coordinates (inherited from CADImage).
Public property | IsStopped | For internal use. (inherited from CADImage).
Public property | IsWithoutBorder | Gest or sets a value indicating whether to draw the CADImage without borders. (inherited from CADImage).
Public property | IsWithoutMargins | Gets or sets a value indicating whether to draw the CADImage without margins. (inherited from CADImage).
 | LastLoadedFilePath | Specifying of the search directory (used for X-Refs, ImageEnt) (inherited from CADImage).
Public property | LayersCount | Gets a quantity of layers in this CADImage. (inherited from CADImage).
Public property | Layouts | Gets a collection of layouts in the current CADImage. (inherited from CADImage).
Public property | LayoutsCount | Gets a quantity of layouts in this CADImage. (inherited from CADImage).
Public property | LineScaled | Obsolete. Gets or sets a value indicating whether a width of lines to draw all entities in the drawing is specified by the file data. (inherited from CADImage).
Public property | LineWeightScale | Gets or sets a scale for drawing lines. (inherited from CADImage).
Public property | MMToPixelX | Gets or sets a value corresponding to amount of millimeters per one pixel. (inherited from CADImage).
Public property | NullWidth | Gets or sets default thickness for lines used to draw a CADImage. (inherited from CADImage).
Public property | NumberOfPartsInCircle | Gets or sets a quantity of segments to be used to draw a circle. (inherited from CADImage).
Public property | Painter | Provides image drawing functionality. (inherited from CADImage).
Public property | PrintDialog | Gets or sets print dialog (inherited from CADImage).
Public property | PureExtents | Gets CADImage extents without margins. (inherited from CADImage).
Public property | ResizeDisproportionateDrawing | For internal use (inherited from CADImage).
Public property | SHXSearchPaths | Gets or sets paths for searching SHX fonts. (inherited from CADImage).
Public property | SearchSHXPaths | Gets or sets a value specifying whether SHX paths will be searched for the fonts. (inherited from CADImage).
Public property | SelectEntitiesCount | Gets the number of selected entities (inherited from CADImage).
Public property | SelectedEntities | Gets or sets a list of selected entities (inherited from CADImage).
Public property | SelectionMode | Gets or sets a state of the Selection tool. (inherited from CADImage).
Public property | Selector | Provides selection functionality. (inherited from CADImage).
Public property | SkipMMtoPixel | For specific use (inherited from CADImage).
Public property | SnapCurrent | (inherited from CADImage).
Public property | SnapOptions | Represents Snap options for the CADImage object (inherited from CADImage).
Public property | SnapRealPoint | Gets a current point in absolute coordinates (drawing coordinates) (inherited from CADImage).
Public property | SnapScreenPoint | Gets current point in display coordinates (inherited from CADImage).
Public property | TTFSmoothing | Gets or sets a value indicating whether TTF fonts are smoothed. (inherited from CADImage).
Public property | TextVisible | Gets or sets a value indicating whether the texts in the CADImage are visible. (inherited from CADImage).
Public property | UndoMode | Gets or sets whether undo/redo is disable or enable for professional version (inherited from CADImage).
Public property | UseDoubleBuffering | Outdated. Does nothing (inherited from CADImage).
Public property | UseLayerPriority | (inherited from CADImage).
Public property | UseMultyTTFFonts | Gets or sets a value indicating whether a multimode is used for showing symbols. (inherited from CADImage).
Public property | UseNullWidth | Specifies if default width will be used instead of entity width. (inherited from CADImage).
Public property | UseSHXFonts | Specifies if SHX fonts will be used for visualization. (inherited from CADImage).
Public property | UseTTFFonts | Specifies if TTF fonts will be used for visualization. (inherited from CADImage).
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles in the CADImage are drawn with GDI+ drawing methods without linearization. (inherited from CADImage).
Top
See Also

Reference

HPGLImage Class
CADImport.HPGL2 Namespace


HPGLImage Methods

HPGLImage Class See Also

The following tables list the members exposed by the HPGLImage type.

Methods
 | Name | Description
Public method | ActiveVPort | Returns drawing area visualized with the active VPort. (inherited from CADImage).
Public method | AddScaledDXF | Adds a scaled external reference to the model space of the specified CAD image. (inherited from CADImage).
Public method | AddScaledDXFEx | Adds a scaled external reference to the current layout of the specified CAD image. (inherited from CADImage).
Public method | AddToUndoList | (Overloaded) Adds operation "create new Entity" to undo list (inherited from CADImage).
Public method | ChangeDrawMode | Initializes a new graphic class object if current mode changed. (inherited from CADImage).
Public method | ChangeEntities | (inherited from CADImage).
Public method | ChangeGraphicsMode | Changes image drawing mode. (inherited from CADImage).
Public method | ChangePositionSelectedEntities | Changes position of the selected entities (inherited from CADImage).
Public method | ChangePositionSelectedEntity | Changes a position of the selected entity. (inherited from CADImage).
Public method | ClearBuffer | Outdated. Does nothing (inherited from CADImage).
Public method | ClearMarkers | Clears a collection of markers. (inherited from CADImage).
Public method | ClearRedoCollection | Clears redo entity collection (inherited from CADImage).
Public method | ClearSelectCollection | Clears a collection of the selected entities. (inherited from CADImage).
Public method | ClearSelection | Clears a list of the selected entities. (inherited from CADImage).
Public method | ClearSnapTrace | (Overloaded) Clears last drawn snap drawing element (inherited from CADImage).
Public method | ClearUndoCollection | Clears undo entity collection (inherited from CADImage).
Public method | CopyEntities | (Overloaded) Copies selected entities to the clipboard (inherited from CADImage).
Public method | CorrectByGrid | (Overloaded) Reduces a point location on screen to the grid node when the grid is active (inherited from CADImage).
Public method | CorrectByGridAndOrtho | Reduces a point relocation sizes on screen to the grid cell sizes when the grid is active (inherited from CADImage).
 | CreateImageByExtension | Creates specialised CADImage object for specified file extention (inherited from CADImage).
Public method | CutEntities | (Overloaded) Cuts selected entities from collection and paste them to the clipboard (inherited from CADImage).
Public method | Dispose | Disposes a CADImage object.
Public method | DoSelectEntities | (Overloaded) Selects inserted list of entities (inherited from CADImage).
Public method | DoSelectEntity | Selects inserted entity (inherited from CADImage).
Public method | Draw | (Overloaded) Draws a CADImage. (inherited from CADImage).
Public method | DrawACISEntity | Draws ACISEntity object (inherited from CADImage).
Public method | DrawChangeEntity | Changes a position of the marker designating the selected entity. (inherited from CADImage).
Public method | DrawMoveEntityTrace | Draws entities on their offsetting (inherited from CADImage).
Public method | DrawSnapTrace | Draws snap icon in case of proximity of object to current coordinates (inherited from CADImage).
Public method | EmfConvertToDXF | (Overloaded) Converts emf file to dxf file (inherited from CADImage).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportToMetafile | (Overloaded) Exports a CAD drawing to Windows Enhanced metafile. (inherited from CADImage).
Public method | GetAbsPoint | Converts display coordinates into absolute coordinates of a design (inherited from CADImage).
Public method | GetCADCoords | Returns coordinates of a point on the drawing. (inherited from CADImage).
Public method | GetCenter | Returns the center point of a current layout (inherited from CADImage).
Public method | GetExtents | Calculates the current dimensions of the CADImage. (inherited from CADImage).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLayerColor | Gets layer color by index (inherited from CADImage).
Public method | GetLayerFreeze | Determines whether the layer (CADLayer) is frozen. (inherited from CADImage).
Public method | GetLayerName | Gets a name of the layer that has the specified index in the collection of layers. (inherited from CADImage).
Public method | GetLayerVisible | Determines whether a layer is visible (inherited from CADImage).
Public method | GetLayoutName | Gets a name of the layout that has the specified index in the collection of layouts. (inherited from CADImage).
Public method | GetPoint | Transforms a three-dimensional CAD point into a two-dimensional screen point. (inherited from CADImage).
Public method | GetRealImagePoint | For internal use. (inherited from CADImage).
Public method | GetRealSnapPoint | Smooths a point in absolute coordinates by the entity (inherited from CADImage).
Public method | GetSelectEntityRegion | Returns the selected area of the image. (inherited from CADImage).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetVPortExtents | Returns extents of the active VPort reduced to the specified size (inherited from CADImage).
Public method | InitialNewImage | (Overloaded) Initializes a new image with the default size (inherited from CADImage).
Public method | InvalidateSelectEntity | Redraws a selected entity. (inherited from CADImage).
Public method | InvalidateSelectedEntities | (Overloaded) Redraws a list of the selected entities (inherited from CADImage).
Public method | LoadFromFile | Loads the HPGL image stored in the specified file.
Public method | LoadFromStream | Loads the HPGL image stored in the specified stream.
Public method | LoadFromWeb | Loads CAD image from hyperlink (inherited from CADImage).
Public method | MultipleSelect | Providing CAD image entities' multiple selection within a specified rectangle. (inherited from CADImage).
Public method | MultipleSelectExt | Selects all entities inside the inserted rectangle (inherited from CADImage).
Public method | PasteEntities | Pastes entities from the clipboard (inherited from CADImage).
Public method | PasteEntitiesExt | Pastes entities from the clipboard (inherited from CADImage).
Public method | Print | Prints a current CAD image. (inherited from CADImage).
Public method | Redo | Redo change (inherited from CADImage).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RefreshCurrentLayout | Refresh current layout. (inherited from CADImage).
Public method | RefreshSnapTrace | Refreshes a region of the last drawn snap drawing element (inherited from CADImage).
Public method | RemoveEntity | (Overloaded) Removes CADEntity object. (inherited from CADImage).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from CADImage).
Public method | RotToView | Rotates a CAD image to get a specified view. (inherited from CADImage).
Public method | Rotate | Rotates objects in the current drawing. (inherited from CADImage).
Public method | SaveAsDXF | Saves a current CAD image in DXF format. (inherited from CADImage).
Public method | SaveImageToClipboard | (Overloaded) Writes a visible part of the current CAD image to the clipboard as a raster image. (inherited from CADImage).
Public method | SaveToFile | (Overloaded) Saves a part of the current CAD image to the file of the specified format. (inherited from CADImage).
Public method | SaveToStream | (Overloaded) Writes a visible part of the current CAD image to the specified stream as a raster image. (inherited from CADImage).
Public method | Select | Selects an entity of the CAD image at the specified point. (inherited from CADImage).
Public method | SelectExt | Selects an entity of the CAD image at the specified point. (inherited from CADImage).
Public method | SetCenter | Sets CADImage center point. (inherited from CADImage).
Public method | SetCurrentLayout | Sets a current layout of this CADImage. (inherited from CADImage).
Public method | SetLayerColor | (Overloaded) Sets a color for layer (CADLayer) specified by index (inherited from CADImage).
Public method | SetLayerFreeze | (Overloaded) Sets freeze parameter for CADLayer (inherited from CADImage).
Public method | SetLayerVisible | (Overloaded) Sets a visibility of the layer. (inherited from CADImage).
Public method | SetNewEntityMarkerPos | Sets a new position for the selected entity. The entity's new position is defined by the position of the marker. (inherited from CADImage).
Public method | SetNewMMToPixel | Sets a quantity of millimeters per pixel for the specified Graphics object. (inherited from CADImage).
Public method | SetNewPosEntitiesExt | Sets a new position for the specified entities (inherited from CADImage).
Public method | SetNewPosEntity | Sets a new position for the specified entity. (inherited from CADImage).
Public method | Stop | For internal use. (inherited from CADImage).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | Undo | Undo change (inherited from CADImage).
Top
See Also

Reference

HPGLImage Class
CADImport.HPGL2 Namespace


HPGLImage.Dispose Method

Disposes a CADImage object.

Namespace: CADImport.HPGL2
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HPGLImage Class
HPGLImage Members
CADImport.HPGL2 Namespace


HPGLImage.LoadFromFile Method

Loads the HPGL image stored in the specified file.

Namespace: CADImport.HPGL2
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub LoadFromFile( _
   ByVal path As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void LoadFromFile(
   string path
)
This language is not supported or no code example is available.

Parameters

path

Type: string

A path to the file that contains an HPGL image to be loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HPGLImage Class
HPGLImage Members
CADImport.HPGL2 Namespace


HPGLImage.LoadFromStream Method

Loads the HPGL image stored in the specified stream.

Namespace: CADImport.HPGL2
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub LoadFromStream( _
   ByVal str As Stream _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void LoadFromStream(
   Stream str
)
This language is not supported or no code example is available.

Parameters

str

Type: Stream

A Stream that contains HPGL image to be loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HPGLImage Class
HPGLImage Members
CADImport.HPGL2 Namespace


HPGLImage Fields

HPGLImage Class See Also

The following tables list the members exposed by the HPGLImage type.

Fields
 | Name | Description
 | EntityBuffer | Represents buffer for CADEntityCollection storing. (inherited from CADImage).
Public field | visibleArea | Represents CADImage visible area. (inherited from CADImage).
Top
See Also

Reference

HPGLImage Class
CADImport.HPGL2 Namespace


HPGLLayout Class

Members See Also

Represents a layout of the HPGL drawing.

Namespace: CADImport.HPGL2
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class HPGLLayout
    Inherits CADLayout
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class HPGLLayout : CADLayout
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.CADEntity
CADImport.CADObjectEntity
CADImport.CADPlotEntity
CADImport.CADLayout
CADImport.HPGL2.HPGLLayout
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HPGLLayout Members
CADImport.HPGL2 Namespace


HPGLLayout Members

HPGLLayout Class Constructors Methods Fields Properties See Also

Represents a layout of the HPGL drawing.

The following tables list the members exposed by the HPGLLayout type.

Constructors
 | Name | Description
Public constructor | HPGLLayout | Initializes a new instance of the CADLayout class. (inherited from CADLayout).
Top
Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADLayout object. (inherited from CADLayout).
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities on this CADLayout. (inherited from CADLayout).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADLayout).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of entities contained in the loaded CAD image. (inherited from CADLayout).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | IsEmpty | Gets a value indicating whether this CADLayout is empty. (inherited from CADLayout).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Name | Gets or sets a name of the layout which read from a CAD file. (inherited from CADLayout).
Public property | PSLTScalingByViewport | Gets or sets using PSLTSCALE value for the CADLayout. (inherited from CADLayout).
Public property | PSize | Gets paper size for the layout
Public property | PaperSpaceBlock | Gets or sets a block containing entities that will be drawn to a specified layout. (inherited from CADLayout).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
Methods
 | Name | Description
Public method | AddEntity | Adds a new child entity. (inherited from CADLayout).
Public method | AssignEntity | Copies an entity (inherited from CADPlotEntity).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADLayout).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Iterate | Invokes the referenced (by the specified delegate) method for each CAD entity belonging to the specified CADLayout. (inherited from CADLayout).
Public method | Loaded | Loads this CADLayout to the specified CADConverter. (inherited from CADLayout).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

HPGLLayout Class
CADImport.HPGL2 Namespace


HPGLLayout Properties

HPGLLayout Class See Also

The following tables list the members exposed by the HPGLLayout type.

Properties
 | Name | Description
Public property | Box | Gets or sets a three-dimensional box that encloses the CADLayout object. (inherited from CADLayout).
Public property | Color | Gets or sets a color for the given CADEntity. (inherited from CADEntity).
Public property | Converter | Gets or sets a CADConverter associated with this CADObjectEntity. (inherited from CADObjectEntity).
Public property | Count | Gets a number of entities on this CADLayout. (inherited from CADLayout).
Public property | EntName | Gets a name of the CADEntity. (inherited from CADLayout).
Public property | EntType | The entity type defined by the EntityType enumeration. (inherited from CADEntity).
Public property | Entities | Gets a collection of entities contained in the loaded CAD image. (inherited from CADLayout).
Public property | ExtendedData | Provides access to entity extended data (inherited from CADEntity).
Public property | Handle | Gets a CADEntity handle. (inherited from CADEntity).
Public property | IsEmpty | Gets a value indicating whether this CADLayout is empty. (inherited from CADLayout).
Public property | Layer | Gets or sets a layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Public property | LineType | Gets or sets a linetype of the CADEntity. (inherited from CADEntity).
Public property | LineTypeScale | Gets or sets a value equal to a quantity of linetype elements per unit of its length. (inherited from CADPlotEntity).
Public property | LineWeight | Gets or sets a thickness of lines for this CADEntity. (inherited from CADEntity).
Public property | Name | Gets or sets a name of the layout which read from a CAD file. (inherited from CADLayout).
Public property | PSLTScalingByViewport | Gets or sets using PSLTSCALE value for the CADLayout. (inherited from CADLayout).
Public property | PSize | Gets paper size for the layout
Public property | PaperSpaceBlock | Gets or sets a block containing entities that will be drawn to a specified layout. (inherited from CADLayout).
Public property | Selected | Gets or sets a value indicating whether the CADEntity is selected. (inherited from CADEntity).
Public property | Visibility | Gets or sets a value indicating whether a CADPlotEntity is visible. (inherited from CADPlotEntity).
Public property | Visible | Gets or sets a value indicating whether a CADPlotEntity is visible taking into account a state of the layer this CADPlotEntity belongs to. (inherited from CADPlotEntity).
Top
See Also

Reference

HPGLLayout Class
CADImport.HPGL2 Namespace


HPGLLayout.PSize Property

Gets paper size for the layout

Namespace: CADImport.HPGL2
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property PSize() As PaperSize
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public PaperSize PSize {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HPGLLayout Class
HPGLLayout Members
CADImport.HPGL2 Namespace


HPGLLayout Methods

HPGLLayout Class See Also

The following tables list the members exposed by the HPGLLayout type.

Methods
 | Name | Description
Public method | AddEntity | Adds a new child entity. (inherited from CADLayout).
Public method | AssignEntity | Copies an entity (inherited from CADPlotEntity).
Public method | ChangeEntity | Edits current entity by specified offset (inherited from CADEntity).
Public method | Clone | Copies an entity (inherited from CADEntity).
Public method | Dispose | Releases all resources used by the CADEntity. (inherited from CADLayout).
Public method | DrawEntityTrace | Implements drawing of entity with specified offset to specified Control (inherited from CADEntity).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetBoxPoints | Checks if the CADEntity must be drawn during a drawing cycle. (inherited from CADEntity).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Iterate | Invokes the referenced (by the specified delegate) method for each CAD entity belonging to the specified CADLayout. (inherited from CADLayout).
Public method | Loaded | Loads this CADLayout to the specified CADConverter. (inherited from CADLayout).
Public method | OnDraw | Raises a DrawEvent. (inherited from CADEntity).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | SetLType | Sets a linetype for this CADEntity. (inherited from CADEntity).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

HPGLLayout Class
CADImport.HPGL2 Namespace


HPGLLayout Fields

HPGLLayout Class See Also

The following tables list the members exposed by the HPGLLayout type.

Fields
 | Name | Description
Public field | DrawEvent | Occurs when the CADEntity is drawn in the CAD image. (inherited from CADEntity).
Top
See Also

Reference

HPGLLayout Class
CADImport.HPGL2 Namespace


PaperSize Structure

Members See Also

Represents paper sizes in millimetres

Namespace: CADImport.HPGL2
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Structure PaperSize
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public struct PaperSize
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PaperSize Members
CADImport.HPGL2 Namespace


PaperSize Members

PaperSize Structure Fields See Also

Represents paper sizes in millimetres

The following tables list the members exposed by the PaperSize type.

Fields
 | Name | Description
Public field | PAPERLENGTH | Represents paper length
Public field | PAPERWIDTH | Represents paper width
Top
See Also

Reference

PaperSize Structure
CADImport.HPGL2 Namespace


PaperSize Fields

PaperSize Structure See Also

The following tables list the members exposed by the PaperSize type.

Fields
 | Name | Description
Public field | PAPERLENGTH | Represents paper length
Public field | PAPERWIDTH | Represents paper width
Top
See Also

Reference

PaperSize Structure
CADImport.HPGL2 Namespace


PAPERLENGTH Field

Represents paper length

Namespace: CADImport.HPGL2
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public PAPERLENGTH As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int PAPERLENGTH
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PaperSize Structure
PaperSize Members
CADImport.HPGL2 Namespace


PAPERWIDTH Field

Represents paper width

Namespace: CADImport.HPGL2
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public PAPERWIDTH As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int PAPERWIDTH
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PaperSize Structure
PaperSize Members
CADImport.HPGL2 Namespace


CADImport.Printing Namespace

Assembly: CADImport (in CADImport.dll)

Classes
 | Name | Description
Public class | PrintPreviewControlEx | Represents the raw "preview" part of print previewing, without any dialog boxes or buttons. Most PrintPreviewControl objects are found on PrintPreviewDialog objects, but they do not have to be.
Top
Forms
 | Name | Description
Public class | PrintingForm | Represents a form that implements printing operations.
Top
Enumerations
 | Name | Description
Public enumeration | DrawingSize | Sets a size type of an image
Public enumeration | PlotPaperUnits | Sets units of the drawing image
Top
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


PrintPreviewControlEx Class

Members See Also

Represents the raw "preview" part of print previewing, without any dialog boxes or buttons. Most PrintPreviewControl objects are found on PrintPreviewDialog objects, but they do not have to be.

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class PrintPreviewControlEx
    Inherits Control
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class PrintPreviewControlEx : Control
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
CADImport.Printing.PrintPreviewControlEx
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintPreviewControlEx Members
CADImport.Printing Namespace


PrintPreviewControlEx Members

PrintPreviewControlEx Class Constructors Events Methods Properties See Also

Represents the raw "preview" part of print previewing, without any dialog boxes or buttons. Most PrintPreviewControl objects are found on PrintPreviewDialog objects, but they do not have to be.

The following tables list the members exposed by the PrintPreviewControlEx type.

Constructors
 | Name | Description
Public constructor | PrintPreviewControlEx | Initializes a new instance of the PrintPreviewControlEx class.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoSize | This property is not relevant for this class. (inherited from Control).
Public property | AutoZoom | Gets or sets a value indicating whether resizing the control or changing the number of pages shown automatically adjusts the Zoom property.
Public property | BackColor | Gets or sets the background color for the control. (inherited from Control).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | Gets or sets the BindingContext for the control. (inherited from Control).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (inherited from Control).
Public property | Columns | Gets or sets the number of pages displayed horizontally across the screen.
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DeselectedPages | Gets or sets pages, which will be passed on printing
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (inherited from Control).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | Document | Gets or sets the document to preview.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (inherited from Control).
Public property | Margin | Gets or sets the space between controls. (inherited from Control).
Public property | MaximumSize | Gets or sets the size that is the upper limit that Size) can specify. (inherited from Control).
Public property | MinimumSize | Gets or sets the size that is the lower limit that Size) can specify. (inherited from Control).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | Rows | Gets or sets the number of pages displayed vertically down the screen.
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the height and width of the control. (inherited from Control).
Public property | StartPage | Gets or sets the page number of the upper left page.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Control).
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (inherited from Control).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | Gets or sets the text associated with this control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | UseAntiAlias | Gets or sets a value indicating whether printing uses the anti-aliasing features of the operating system.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Public property | Zoom | Gets or sets a value indicating how large the pages will appear.
Top
Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | InvalidatePreview | Refreshes the preview of the document.
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | Show | (Overloaded) Displays the control to the user. (inherited from Control).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (inherited from Component).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (inherited from Control).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | Occurs when the control's margin changes. (inherited from Control).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StartPageChanged | Occurs when the start page changes.
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (inherited from Control).
Public event | TabStopChanged | Occurs when the TabStop property value changes. (inherited from Control).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

PrintPreviewControlEx Class
CADImport.Printing Namespace


PrintPreviewControlEx Constructor

Initializes a new instance of the PrintPreviewControlEx class.

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public PrintPreviewControlEx()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintPreviewControlEx Class
PrintPreviewControlEx Members
CADImport.Printing Namespace


PrintPreviewControlEx Properties

PrintPreviewControlEx Class See Also

The following tables list the members exposed by the PrintPreviewControlEx type.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoSize | This property is not relevant for this class. (inherited from Control).
Public property | AutoZoom | Gets or sets a value indicating whether resizing the control or changing the number of pages shown automatically adjusts the Zoom property.
Public property | BackColor | Gets or sets the background color for the control. (inherited from Control).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | Gets or sets the BindingContext for the control. (inherited from Control).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (inherited from Control).
Public property | Columns | Gets or sets the number of pages displayed horizontally across the screen.
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DeselectedPages | Gets or sets pages, which will be passed on printing
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (inherited from Control).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | Document | Gets or sets the document to preview.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (inherited from Control).
Public property | Margin | Gets or sets the space between controls. (inherited from Control).
Public property | MaximumSize | Gets or sets the size that is the upper limit that Size) can specify. (inherited from Control).
Public property | MinimumSize | Gets or sets the size that is the lower limit that Size) can specify. (inherited from Control).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | Rows | Gets or sets the number of pages displayed vertically down the screen.
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the height and width of the control. (inherited from Control).
Public property | StartPage | Gets or sets the page number of the upper left page.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Control).
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (inherited from Control).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | Gets or sets the text associated with this control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | UseAntiAlias | Gets or sets a value indicating whether printing uses the anti-aliasing features of the operating system.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Public property | Zoom | Gets or sets a value indicating how large the pages will appear.
Top
See Also

Reference

PrintPreviewControlEx Class
CADImport.Printing Namespace


PrintPreviewControlEx.AutoZoom Property

Gets or sets a value indicating whether resizing the control or changing the number of pages shown automatically adjusts the Zoom property.

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property AutoZoom() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool AutoZoom {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintPreviewControlEx Class
PrintPreviewControlEx Members
CADImport.Printing Namespace


PrintPreviewControlEx.Columns Property

Gets or sets the number of pages displayed horizontally across the screen.

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Columns() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Columns {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintPreviewControlEx Class
PrintPreviewControlEx Members
CADImport.Printing Namespace


PrintPreviewControlEx.DeselectedPages Property

Gets or sets pages, which will be passed on printing

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property DeselectedPages() As ArrayList
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ArrayList DeselectedPages {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintPreviewControlEx Class
PrintPreviewControlEx Members
CADImport.Printing Namespace


PrintPreviewControlEx.Document Property

Gets or sets the document to preview.

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Document() As PrintDocument
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public PrintDocument Document {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintPreviewControlEx Class
PrintPreviewControlEx Members
CADImport.Printing Namespace


PrintPreviewControlEx.Rows Property

Gets or sets the number of pages displayed vertically down the screen.

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Rows() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Rows {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintPreviewControlEx Class
PrintPreviewControlEx Members
CADImport.Printing Namespace


PrintPreviewControlEx.StartPage Property

Gets or sets the page number of the upper left page.

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property StartPage() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int StartPage {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintPreviewControlEx Class
PrintPreviewControlEx Members
CADImport.Printing Namespace


PrintPreviewControlEx.Text Property

Gets or sets the text associated with this control.

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Property Text() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override string Text {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintPreviewControlEx Class
PrintPreviewControlEx Members
CADImport.Printing Namespace


PrintPreviewControlEx.UseAntiAlias Property

Gets or sets a value indicating whether printing uses the anti-aliasing features of the operating system.

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property UseAntiAlias() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool UseAntiAlias {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintPreviewControlEx Class
PrintPreviewControlEx Members
CADImport.Printing Namespace


PrintPreviewControlEx.Zoom Property

Gets or sets a value indicating how large the pages will appear.

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Zoom() As Double
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public double Zoom {get; set;}
This language is not supported or no code example is available.
Exceptions
Exception type | Condition
ArgumentException | The value is less than 0.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintPreviewControlEx Class
PrintPreviewControlEx Members
CADImport.Printing Namespace


PrintPreviewControlEx Methods

PrintPreviewControlEx Class See Also

The following tables list the members exposed by the PrintPreviewControlEx type.

Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | InvalidatePreview | Refreshes the preview of the document.
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | Show | (Overloaded) Displays the control to the user. (inherited from Control).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (inherited from Component).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Top
See Also

Reference

PrintPreviewControlEx Class
CADImport.Printing Namespace


PrintPreviewControlEx.InvalidatePreview Method

Refreshes the preview of the document.

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub InvalidatePreview()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void InvalidatePreview()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintPreviewControlEx Class
PrintPreviewControlEx Members
CADImport.Printing Namespace


PrintPreviewControlEx Events

PrintPreviewControlEx Class See Also

The following tables list the members exposed by the PrintPreviewControlEx type.

Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (inherited from Control).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | Occurs when the control's margin changes. (inherited from Control).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StartPageChanged | Occurs when the start page changes.
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (inherited from Control).
Public event | TabStopChanged | Occurs when the TabStop property value changes. (inherited from Control).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

PrintPreviewControlEx Class
CADImport.Printing Namespace


StartPageChanged Event

Occurs when the start page changes.

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event StartPageChanged() As System.EventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event System.EventHandler StartPageChanged
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintPreviewControlEx Class
PrintPreviewControlEx Members
CADImport.Printing Namespace


PrintingForm Class

Members See Also

Represents a form that implements printing operations.

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class PrintingForm
    Inherits Form
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class PrintingForm : Form
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
CADImport.Printing.PrintingForm
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Members
CADImport.Printing Namespace


PrintingForm Members

PrintingForm Class Constructors Events Methods Properties See Also

Represents a form that implements printing operations.

The following tables list the members exposed by the PrintingForm type.

Constructors
 | Name | Description
Public constructor | PrintingForm | Initializes a new instance of the PrintingForm class.
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
 | ActiveForm | Gets the currently active form for this application. (inherited from Form).
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form).
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Form).
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | ButtonsImageList | Gets ImageList unit, contains images for control items of the current window
Public property | CADDrawingTabPage | Gets TabPage unit, contains control items for specifying general settings of the current image
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form).
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form).
Public property | DeviceSettingsTabPage | Gets TabPage unit, contains control items for specifying general settings of the printing device
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | DrawingSettingsTabPage | Gets TabPage unit, contains control items for specifying general settings of the current image
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form).
Public property | FormatSize | Gets or sets size of the page where the current image is scaled
Public property | FormatSizeGrBox | Gets GroupBox unit, contains control items for specifying the image size
Public property | GroupScaleGrBox | Gets GroupBox unit, contains control items for specifying the image size
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Icon | Gets or sets the icon for the form. (inherited from Form).
Public property | Image | Gets or sets current image
Public property | ImageRectangleF | For internal use.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form).
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form).
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form).
Public property | LayerForm | Gets or sets layer selection window for current image
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | LeftImagePos | Offsets the drawing image to left/right
Public property | LngFileName | Gets or sets a name of the language file
Public property | Location | (inherited from Form).
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form).
Public property | Margin | (inherited from Form).
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form).
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form).
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form).
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form).
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form).
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form).
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | MultipleLanguagesPath | Gets or sets a path to the language files directory
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | NullWidth | Gets or sets a minimal (zero) line width for the current image
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form).
Public property | OptionsTabControl | Gets or sets TabControl unit, contains control items for specifying general printing parameters
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form).
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | PageBoundsGrBox | Gets GroupBox unit, contains control items for specifying the page paragraphs
Public property | PaperOrientationGrBox | Gets GroupBox unit, contains control items for specifying orientation parameters of the printing page
Public property | PaperSizes | A list of available paper sizes for current printer
Public property | PaperUnitsGrBox | Gets GroupBox unit, contains control items for specifying current image units
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PlotUnit | Gets or sets units for current printing image from PlotPaperUnits value set
Public property | PositionGrBox | Gets GroupBox unit, contains control items for specifying the image position
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | PreviewControl | Gets or sets PrintPreviewControlEx control item to preview, how the document will be printed.
Public property | PrintDocument | Printing document
Public property | PrintersGrBox | Gets GroupBox unit, contains control items for specifying general printer parameters
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form).
Public property | Scale | Gets or sets current scaling factor for the image
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form).
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the size of the form. (inherited from Form).
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form).
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form).
Public property | TabStop | (inherited from Form).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | ToolButtonsPanel | Gets or sets ToolBar control item with the set of functional buttons for setting printing parameters
Public property | ToolButtonsPanel2 | Gets or sets ToolBar control item with the set of functional buttons for setting printing parameters
Public property | ToolPrintPanel | Gets Panel unit, contains control items for specifying general settings of the current image
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopImagePos | Offsets the drawing image up/down
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form).
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form).
Public property | TypePage | Gets or sets current scaling type from the DrawingSize value set
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | VisibleRectangle | Gets or sets visible rectangle.
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowState | Gets or sets the form's window state. (inherited from Form).
Public property | WindowTarget | (inherited from Control).
Public property | ZeroLineWidth | Gets NumericUpDown control unit, contains zero width of a line for the current image
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form).
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BeginPrintEvent | Handles BeginPrint event.
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Close | Closes the form. (inherited from Form).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateNewPages | Creates new PrintDocument
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Gets the size when autoscaling the form based on a specified font. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetFitScale |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form).
Public method | LoadPagesList | Loads a list of the page formats available for the current printer
Public method | LoadPrinterList | Loads a list of installed printers
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | Print | Prints a current CAD image.
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form).
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form).
Public method | Show | (Overloaded) Shows the form with the specified owner to the user. (inherited from Form).
Public method | ShowDialog | (Overloaded) Shows the form as a modal dialog box with the currently active window set as its owner. (inherited from Form).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Form).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form).
Public event | AutoSizeChanged | (inherited from Form).
Public event | AutoValidateChanged | (inherited from Form).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | Closed | Occurs when the form is closed. (inherited from Form).
Public event | Closing | Occurs when the form is closing. (inherited from Form).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | FormClosed | Occurs after the form is closed. (inherited from Form).
Public event | FormClosing | Occurs before the form is closed. (inherited from Form).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form).
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | (inherited from Form).
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form).
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form).
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form).
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form).
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form).
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form).
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form).
Public event | TabStopChanged | (inherited from Form).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

PrintingForm Class
CADImport.Printing Namespace


PrintingForm Constructor

Initializes a new instance of the PrintingForm class.

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public PrintingForm()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm Properties

PrintingForm Class See Also

The following tables list the members exposed by the PrintingForm type.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form).
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control).
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control).
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control).
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl).
 | ActiveForm | Gets the currently active form for this application. (inherited from Form).
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form).
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control).
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form).
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control).
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form).
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form).
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl).
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form).
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in Control). (inherited from Control).
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Form).
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control).
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control).
Public property | ButtonsImageList | Gets ImageList unit, contains images for control items of the current window
Public property | CADDrawingTabPage | Gets TabPage unit, contains control items for specifying general settings of the current image
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control).
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control).
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Gets or sets a value indicating whether to catch calls on the wrong thread that access a control's Handle property. (inherited from Control).
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control).
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form).
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control).
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component).
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control).
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control).
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control).
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form).
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control).
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl).
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control).
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control).
 | DefaultBackColor | Gets the default background color of the control. (inherited from Control).
 | DefaultFont | Gets the default font of the control. (inherited from Control).
 | DefaultForeColor | Gets the default foreground color of the control. (inherited from Control).
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form).
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form).
Public property | DeviceSettingsTabPage | Gets TabPage unit, contains control items for specifying general settings of the printing device
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form).
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl).
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control).
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control).
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl).
Public property | DrawingSettingsTabPage | Gets TabPage unit, contains control items for specifying general settings of the current image
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control).
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control).
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control).
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control).
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form).
Public property | FormatSize | Gets or sets size of the page where the current image is scaled
Public property | FormatSizeGrBox | Gets GroupBox unit, contains control items for specifying the image size
Public property | GroupScaleGrBox | Gets GroupBox unit, contains control items for specifying the image size
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control).
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control).
Public property | Height | Gets or sets the height of the control. (inherited from Control).
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form).
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl).
Public property | Icon | Gets or sets the icon for the form. (inherited from Form).
Public property | Image | Gets or sets current image
Public property | ImageRectangleF | For internal use.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control).
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control).
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control).
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control).
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control).
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form).
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form).
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control).
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form).
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form).
Public property | LayerForm | Gets or sets layer selection window for current image
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control).
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | LeftImagePos | Offsets the drawing image to left/right
Public property | LngFileName | Gets or sets a name of the language file
Public property | Location | (inherited from Form).
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form).
Public property | Margin | (inherited from Form).
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form).
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form).
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form).
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form).
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form).
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form).
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form).
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form).
 | ModifierKeys | Gets a value indicating which of the modifier keys (SHIFT, CTRL, and ALT) is in a pressed state. (inherited from Control).
 | MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state. (inherited from Control).
 | MousePosition | Gets the position of the mouse cursor in screen coordinates. (inherited from Control).
Public property | MultipleLanguagesPath | Gets or sets a path to the language files directory
Public property | Name | Gets or sets the name of the control. (inherited from Control).
Public property | NullWidth | Gets or sets a minimal (zero) line width for the current image
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form).
Public property | OptionsTabControl | Gets or sets TabControl unit, contains control items for specifying general printing parameters
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form).
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form).
Public property | Padding | Gets or sets padding within the control. (inherited from Control).
Public property | PageBoundsGrBox | Gets GroupBox unit, contains control items for specifying the page paragraphs
Public property | PaperOrientationGrBox | Gets GroupBox unit, contains control items for specifying orientation parameters of the printing page
Public property | PaperSizes | A list of available paper sizes for current printer
Public property | PaperUnitsGrBox | Gets GroupBox unit, contains control items for specifying current image units
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control).
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl).
Public property | PlotUnit | Gets or sets units for current printing image from PlotPaperUnits value set
Public property | PositionGrBox | Gets GroupBox unit, contains control items for specifying the image position
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control).
Public property | PreviewControl | Gets or sets PrintPreviewControlEx control item to preview, how the document will be printed.
Public property | PrintDocument | Printing document
Public property | PrintersGrBox | Gets GroupBox unit, contains control items for specifying general printer parameters
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control).
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control).
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control).
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control).
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form).
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control).
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control).
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form).
Public property | Scale | Gets or sets current scaling factor for the image
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form).
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form).
Public property | Site | Gets or sets the site of the control. (inherited from Control).
Public property | Size | Gets or sets the size of the form. (inherited from Form).
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form).
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form).
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form).
Public property | TabStop | (inherited from Form).
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | ToolButtonsPanel | Gets or sets ToolBar control item with the set of functional buttons for setting printing parameters
Public property | ToolButtonsPanel2 | Gets or sets ToolBar control item with the set of functional buttons for setting printing parameters
Public property | ToolPrintPanel | Gets Panel unit, contains control items for specifying general settings of the current image
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control).
Public property | TopImagePos | Offsets the drawing image up/down
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form).
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control).
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form).
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form).
Public property | TypePage | Gets or sets current scaling type from the DrawingSize value set
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control).
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl).
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control).
Public property | VisibleRectangle | Gets or sets visible rectangle.
Public property | Width | Gets or sets the width of the control. (inherited from Control).
Public property | WindowState | Gets or sets the form's window state. (inherited from Form).
Public property | WindowTarget | (inherited from Control).
Public property | ZeroLineWidth | Gets NumericUpDown control unit, contains zero width of a line for the current image
Top
See Also

Reference

PrintingForm Class
CADImport.Printing Namespace


PrintingForm.ButtonsImageList Property

Gets ImageList unit, contains images for control items of the current window

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property ButtonsImageList() As ImageList
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ImageList ButtonsImageList {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.CADDrawingTabPage Property

Gets TabPage unit, contains control items for specifying general settings of the current image

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property CADDrawingTabPage() As TabPage
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public TabPage CADDrawingTabPage {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.DeviceSettingsTabPage Property

Gets TabPage unit, contains control items for specifying general settings of the printing device

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property DeviceSettingsTabPage() As TabPage
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public TabPage DeviceSettingsTabPage {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.DrawingSettingsTabPage Property

Gets TabPage unit, contains control items for specifying general settings of the current image

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property DrawingSettingsTabPage() As TabPage
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public TabPage DrawingSettingsTabPage {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.FormatSize Property

Gets or sets size of the page where the current image is scaled

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property FormatSize() As PaperSize
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public PaperSize FormatSize {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.FormatSizeGrBox Property

Gets GroupBox unit, contains control items for specifying the image size

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property FormatSizeGrBox() As GroupBox
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public GroupBox FormatSizeGrBox {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.GroupScaleGrBox Property

Gets GroupBox unit, contains control items for specifying the image size

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property GroupScaleGrBox() As GroupBox
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public GroupBox GroupScaleGrBox {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.Image Property

Gets or sets current image

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Image() As CADImage
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADImage Image {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.ImageRectangleF Property

For internal use.

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ImageRectangleF() As RectangleF
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public RectangleF ImageRectangleF {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.LayerForm Property

Gets or sets layer selection window for current image

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LayerForm() As LayerForm
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public LayerForm LayerForm {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.LeftImagePos Property

Offsets the drawing image to left/right

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LeftImagePos() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int LeftImagePos {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.LngFileName Property

Gets or sets a name of the language file

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property LngFileName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string LngFileName {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.MultipleLanguagesPath Property

Gets or sets a path to the language files directory

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property MultipleLanguagesPath() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string MultipleLanguagesPath {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.NullWidth Property

Gets or sets a minimal (zero) line width for the current image

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property NullWidth() As Decimal
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public decimal NullWidth {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.OptionsTabControl Property

Gets or sets TabControl unit, contains control items for specifying general printing parameters

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property OptionsTabControl() As TabControl
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public TabControl OptionsTabControl {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.PageBoundsGrBox Property

Gets GroupBox unit, contains control items for specifying the page paragraphs

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property PageBoundsGrBox() As GroupBox
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public GroupBox PageBoundsGrBox {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.PaperOrientationGrBox Property

Gets GroupBox unit, contains control items for specifying orientation parameters of the printing page

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property PaperOrientationGrBox() As GroupBox
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public GroupBox PaperOrientationGrBox {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.PaperSizes Property

A list of available paper sizes for current printer

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property PaperSizes() As PaperSizeCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public PaperSizeCollection PaperSizes {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.PaperUnitsGrBox Property

Gets GroupBox unit, contains control items for specifying current image units

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property PaperUnitsGrBox() As GroupBox
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public GroupBox PaperUnitsGrBox {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.PlotUnit Property

Gets or sets units for current printing image from PlotPaperUnits value set

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PlotUnit() As PlotPaperUnits
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public PlotPaperUnits PlotUnit {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.PositionGrBox Property

Gets GroupBox unit, contains control items for specifying the image position

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property PositionGrBox() As GroupBox
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public GroupBox PositionGrBox {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.PreviewControl Property

Gets or sets PrintPreviewControlEx control item to preview, how the document will be printed.

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PreviewControl() As PrintPreviewControlEx
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public PrintPreviewControlEx PreviewControl {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.PrintDocument Property

Printing document

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property PrintDocument() As PrintDocument
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public PrintDocument PrintDocument {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.PrintersGrBox Property

Gets GroupBox unit, contains control items for specifying general printer parameters

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property PrintersGrBox() As GroupBox
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public GroupBox PrintersGrBox {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.Scale Property

Gets or sets current scaling factor for the image

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shadows Property Scale() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
new public float Scale {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.ToolButtonsPanel Property

Gets or sets ToolBar control item with the set of functional buttons for setting printing parameters

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ToolButtonsPanel() As ToolBar
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ToolBar ToolButtonsPanel {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.ToolButtonsPanel2 Property

Gets or sets ToolBar control item with the set of functional buttons for setting printing parameters

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ToolButtonsPanel2() As ToolBar
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ToolBar ToolButtonsPanel2 {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.ToolPrintPanel Property

Gets Panel unit, contains control items for specifying general settings of the current image

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property ToolPrintPanel() As Panel
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Panel ToolPrintPanel {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.TopImagePos Property

Offsets the drawing image up/down

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TopImagePos() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int TopImagePos {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.TypePage Property

Gets or sets current scaling type from the DrawingSize value set

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TypePage() As DrawingSize
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DrawingSize TypePage {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.VisibleRectangle Property

Gets or sets visible rectangle.

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property VisibleRectangle() As RectangleF
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public RectangleF VisibleRectangle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.ZeroLineWidth Property

Gets NumericUpDown control unit, contains zero width of a line for the current image

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property ZeroLineWidth() As NumericUpDown
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public NumericUpDown ZeroLineWidth {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm Methods

PrintingForm Class See Also

The following tables list the members exposed by the PrintingForm type.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form).
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control).
Public method | BeginPrintEvent | Handles BeginPrint event.
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control).
Public method | Close | Closes the form. (inherited from Form).
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control).
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control).
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control).
Public method | CreateNewPages | Creates new PrintDocument
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject).
Public method | Dispose | Releases all resources used by the Component. (inherited from Component).
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control).
Public method | DrawToBitmap | (Overloaded) Supports rendering to the specified bitmap. (inherited from Control).
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control).
Public method | Focus | Sets input focus to the control. (inherited from Control).
 | FromChildHandle | Retrieves the control that contains the specified handle. (inherited from Control).
 | FromHandle | Returns the control that is currently associated with the specified handle. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Gets the size when autoscaling the form based on a specified font. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (inherited from Control).
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control).
Public method | GetFitScale |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control).
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Hide | Conceals the control from the user. (inherited from Control).
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (inherited from Control).
Public method | Invoke | (Overloaded) Executes the specified delegate on the thread that owns the control's underlying window handle. (inherited from Control).
 | IsKeyLocked | Determines whether the CAPS LOCK, NUM LOCK, or SCROLL LOCK key is in effect. (inherited from Control).
 | IsMnemonic | Determines if the specified character is the mnemonic character assigned to the control in the specified string. (inherited from Control).
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form).
Public method | LoadPagesList | Loads a list of the page formats available for the current printer
Public method | LoadPrinterList | Loads a list of installed printers
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Forces the control to apply layout logic to all its child controls. (inherited from Control).
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control).
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control).
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control).
Public method | Print | Prints a current CAD image.
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control).
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control).
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | Resets the Text property to its default value. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Resumes usual layout logic. (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl).
Public method | Select | (Overloaded) Activates the control. (inherited from Control).
Public method | SelectNextControl | Activates the next control. (inherited from Control).
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control).
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Sets the bounds of the control to the specified location and size. (inherited from Control).
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form).
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form).
Public method | Show | (Overloaded) Shows the form with the specified owner to the user. (inherited from Form).
Public method | ShowDialog | (Overloaded) Shows the form as a modal dialog box with the currently active window set as its owner. (inherited from Form).
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control).
Public method | ToString | (inherited from Form).
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control).
Public method | Validate | (Overloaded) Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top
See Also

Reference

PrintingForm Class
CADImport.Printing Namespace


PrintingForm.BeginPrintEvent Method

Handles BeginPrint event.

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub BeginPrintEvent( _
   ByVal sender As Object, _
   ByVal e As PrintEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void BeginPrintEvent(
   object sender,
   PrintEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: PrintEventArgs

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.CreateNewPages Method

Creates new PrintDocument

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub CreateNewPages()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void CreateNewPages()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.GetFitScale Method

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetFitScale() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float GetFitScale()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.LoadPagesList Method

Loads a list of the page formats available for the current printer

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub LoadPagesList()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void LoadPagesList()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.LoadPrinterList Method

Loads a list of installed printers

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub LoadPrinterList()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void LoadPrinterList()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm.Print Method

Prints a current CAD image.

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Function Print( _
   ByVal sendToPrinter As Boolean _
) As PrintDocument
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual PrintDocument Print(
   bool sendToPrinter
)
This language is not supported or no code example is available.

Parameters

sendToPrinter

Type: bool

Send print document to printer

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PrintingForm Class
PrintingForm Members
CADImport.Printing Namespace


PrintingForm Events

PrintingForm Class See Also

The following tables list the members exposed by the PrintingForm type.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form).
Public event | AutoSizeChanged | (inherited from Form).
Public event | AutoValidateChanged | (inherited from Form).
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control).
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control).
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control).
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control).
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control).
Public event | Click | Occurs when the control is clicked. (inherited from Control).
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control).
Public event | Closed | Occurs when the form is closed. (inherited from Form).
Public event | Closing | Occurs when the form is closing. (inherited from Form).
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control).
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control).
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control).
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control).
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control).
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form).
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component).
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control).
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control).
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control).
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control).
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control).
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control).
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control).
Public event | Enter | Occurs when the control is entered. (inherited from Control).
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control).
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control).
Public event | FormClosed | Occurs after the form is closed. (inherited from Form).
Public event | FormClosing | Occurs before the form is closed. (inherited from Form).
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control).
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control).
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control).
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control).
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form).
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control).
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control).
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form).
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form).
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control).
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control).
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control).
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control).
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control).
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form).
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control).
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control).
Public event | MarginChanged | (inherited from Form).
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form).
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form).
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form).
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form).
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form).
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form).
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control).
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control).
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control).
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control).
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control).
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control).
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control).
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control).
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control).
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control).
Public event | Move | Occurs when the control is moved. (inherited from Control).
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control).
Public event | Paint | Occurs when the control is redrawn. (inherited from Control).
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control).
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control).
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control).
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control).
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control).
Public event | Resize | Occurs when the control is resized. (inherited from Control).
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form).
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form).
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control).
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form).
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl).
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form).
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control).
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control).
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control).
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form).
Public event | TabStopChanged | (inherited from Form).
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control).
Public event | Validated | Occurs when the control is finished validating. (inherited from Control).
Public event | Validating | Occurs when the control is validating. (inherited from Control).
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control).
Top
See Also

Reference

PrintingForm Class
CADImport.Printing Namespace


DrawingSize Enumeration

Sets a size type of an image

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Fit | Stretches an image by the printing page keeping proportions
Format | Stretches an image by the specified format
Real | Sets 1:1 scale
See Also

Reference

CADImport.Printing Namespace


PlotPaperUnits Enumeration

Sets units of the drawing image

Namespace: CADImport.Printing
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Inches | Sets inches for the image units
Millimeters | Sets millimeters for the image units
Pixels | Sets pixels for the image units
See Also

Reference

CADImport.Printing Namespace


CADImport.Professional Namespace

Assembly: CADImport (in CADImport.dll)

Classes
 | Name | Description
Public class | EntitiesCreator | Contains a set of tools for visual creating of entities
Public class | Marker | Represents a marker on the selected entity
Public class | RedoClass | Auxiliary class for redo and undo operation, for professional version
 | ToolsSettings |
Top
Delegates
 | Name | Description
Public delegate | CreateNewObjectEventHandler | Represents a set of methods which are invoked on new entity creating; The set is used for CreateNewCADImageEvent event
Public delegate | GetRealPointEvent | Represents a set of methods for getting real (drawing) coordinates by display coordinates
Top
Enumerations
 | Name | Description
Public enumeration | CreatorType | Types list of the creating entities
Public enumeration | Operation | Operation, for professional version
Top
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


EntitiesCreator Class

Members See Also

Contains a set of tools for visual creating of entities

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class EntitiesCreator
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class EntitiesCreator
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Professional.EntitiesCreator
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EntitiesCreator Members
CADImport.Professional Namespace


EntitiesCreator Members

EntitiesCreator Class Constructors Events Methods Properties See Also

Contains a set of tools for visual creating of entities

The following tables list the members exposed by the EntitiesCreator type.

Constructors
 | Name | Description
Public constructor | EntitiesCreator | Creates an instance of EntitiesCreator class
Top
Properties
 | Name | Description
Public property | ColorEntity | Gets or sets a color of the creating entity
Public property | Enabled | Gets a status of the EntitiesCreator object
Public property | EndPoly | Gets or sets end flag of the CADPolyLine creating
Public property | HatchName | Gets or sets a name of CADHatch object
Public property | Image | Gets or sets CADImage object where new entities are added
Public property | OptionsForm | Gets or sets instance of editor settings class
Public property | Points | Gets or sets points of the creating object in display coordinates
Public property | RealPoints | Gets or sets points of the creating object in real (drawing) coordinates
Public property | ShowOptionsForm | Gets or sets a flag of editor settings form visibility
Public property | SolidHatch | Gets or sets a type (solid or not solid) of the CADHatch object
Public property | TextHeight | Gets or sets height of CADText object
Public property | TextRotation | Gets or sets rotation angle of CADText object
Public property | Type | Gets or sets a type of the creating object
Top
Methods
 | Name | Description
Public method | BeginEntity | Starts entity drawing
Public method | Disable | Disables EntitiesCreator tool
Public method | Dispose | A default Dispose method.
Public method | DrawNewEntityCreator | Draws EntitiesCreator tool
Public method | EnableCreator | Enables EntitiesCreator tool
Public method | EndDrawPolyline | Finishes Polyline entity drawing
Public method | EndEntity | Finishes entity drawing
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | OnCreateNewCADImage | Invokes CreateNewCADImageEvent event
Public method | OnEndEntityDraw | Invokes EndEntityDraw event
Public method | OnGetRealPoint | Invokes GetRealPointEvent event
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Events
 | Name | Description
Public event | CreateNewCADImageEvent | Invokes on new CADImage creating
Public event | EndEntityDraw | Invokes on finishing of the entity drawing
Public event | GetRealPointEvent | Invokes on getting of the real coordinates of the point
Top
See Also

Reference

EntitiesCreator Class
CADImport.Professional Namespace


EntitiesCreator Constructor

Creates an instance of EntitiesCreator class

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal aParent As Control, _
   ByVal aColor As Color _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public EntitiesCreator(
   Control aParent,
   Color aColor
)
This language is not supported or no code example is available.

Parameters

aParent

Type: Control

Parent control for which EntitiesCreator is created

aColor

Type: Color

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EntitiesCreator Class
EntitiesCreator Members
CADImport.Professional Namespace


EntitiesCreator Properties

EntitiesCreator Class See Also

The following tables list the members exposed by the EntitiesCreator type.

Properties
 | Name | Description
Public property | ColorEntity | Gets or sets a color of the creating entity
Public property | Enabled | Gets a status of the EntitiesCreator object
Public property | EndPoly | Gets or sets end flag of the CADPolyLine creating
Public property | HatchName | Gets or sets a name of CADHatch object
Public property | Image | Gets or sets CADImage object where new entities are added
Public property | OptionsForm | Gets or sets instance of editor settings class
Public property | Points | Gets or sets points of the creating object in display coordinates
Public property | RealPoints | Gets or sets points of the creating object in real (drawing) coordinates
Public property | ShowOptionsForm | Gets or sets a flag of editor settings form visibility
Public property | SolidHatch | Gets or sets a type (solid or not solid) of the CADHatch object
Public property | TextHeight | Gets or sets height of CADText object
Public property | TextRotation | Gets or sets rotation angle of CADText object
Public property | Type | Gets or sets a type of the creating object
Top
See Also

Reference

EntitiesCreator Class
CADImport.Professional Namespace


EntitiesCreator.ColorEntity Property

Gets or sets a color of the creating entity

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ColorEntity() As Color
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Color ColorEntity {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EntitiesCreator Class
EntitiesCreator Members
CADImport.Professional Namespace


EntitiesCreator.Enabled Property

Gets a status of the EntitiesCreator object

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Enabled() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Enabled {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EntitiesCreator Class
EntitiesCreator Members
CADImport.Professional Namespace


EntitiesCreator.EndPoly Property

Gets or sets end flag of the CADPolyLine creating

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property EndPoly() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool EndPoly {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EntitiesCreator Class
EntitiesCreator Members
CADImport.Professional Namespace


EntitiesCreator.HatchName Property

Gets or sets a name of CADHatch object

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property HatchName() As String
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public string HatchName {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EntitiesCreator Class
EntitiesCreator Members
CADImport.Professional Namespace


EntitiesCreator.Image Property

Gets or sets CADImage object where new entities are added

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Image() As CADImage
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADImage Image {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EntitiesCreator Class
EntitiesCreator Members
CADImport.Professional Namespace


EntitiesCreator.OptionsForm Property

Gets or sets instance of editor settings class

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property OptionsForm() As EditorOptions
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public EditorOptions OptionsForm {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EntitiesCreator Class
EntitiesCreator Members
CADImport.Professional Namespace


EntitiesCreator.Points Property

Gets or sets points of the creating object in display coordinates

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Points() As ArrayList
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ArrayList Points {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EntitiesCreator Class
EntitiesCreator Members
CADImport.Professional Namespace


EntitiesCreator.RealPoints Property

Gets or sets points of the creating object in real (drawing) coordinates

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property RealPoints() As ArrayList
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ArrayList RealPoints {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EntitiesCreator Class
EntitiesCreator Members
CADImport.Professional Namespace


EntitiesCreator.ShowOptionsForm Property

Gets or sets a flag of editor settings form visibility

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property ShowOptionsForm() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool ShowOptionsForm {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EntitiesCreator Class
EntitiesCreator Members
CADImport.Professional Namespace


EntitiesCreator.SolidHatch Property

Gets or sets a type (solid or not solid) of the CADHatch object

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property SolidHatch() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool SolidHatch {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EntitiesCreator Class
EntitiesCreator Members
CADImport.Professional Namespace


EntitiesCreator.TextHeight Property

Gets or sets height of CADText object

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TextHeight() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float TextHeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EntitiesCreator Class
EntitiesCreator Members
CADImport.Professional Namespace


EntitiesCreator.TextRotation Property

Gets or sets rotation angle of CADText object

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property TextRotation() As Single
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public float TextRotation {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EntitiesCreator Class
EntitiesCreator Members
CADImport.Professional Namespace


EntitiesCreator.Type Property

Gets or sets a type of the creating object

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Type() As CreatorType
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CreatorType Type {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EntitiesCreator Class
EntitiesCreator Members
CADImport.Professional Namespace


EntitiesCreator Methods

EntitiesCreator Class See Also

The following tables list the members exposed by the EntitiesCreator type.

Methods
 | Name | Description
Public method | BeginEntity | Starts entity drawing
Public method | Disable | Disables EntitiesCreator tool
Public method | Dispose | A default Dispose method.
Public method | DrawNewEntityCreator | Draws EntitiesCreator tool
Public method | EnableCreator | Enables EntitiesCreator tool
Public method | EndDrawPolyline | Finishes Polyline entity drawing
Public method | EndEntity | Finishes entity drawing
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | OnCreateNewCADImage | Invokes CreateNewCADImageEvent event
Public method | OnEndEntityDraw | Invokes EndEntityDraw event
Public method | OnGetRealPoint | Invokes GetRealPointEvent event
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

EntitiesCreator Class
CADImport.Professional Namespace


EntitiesCreator.BeginEntity Method

Starts entity drawing

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub BeginEntity( _
   ByVal bt As MouseButtons, _
   ByVal x As Integer, _
   ByVal y As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void BeginEntity(
   MouseButtons bt,
   int x,
   int y
)
This language is not supported or no code example is available.

Parameters

bt

Type: MouseButtons

Pressed mouse button

x

Type: int

X axis position

y

Type: int

Y axis position

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EntitiesCreator Class
EntitiesCreator Members
CADImport.Professional Namespace


EntitiesCreator.Disable Method

Disables EntitiesCreator tool

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Disable()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Disable()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EntitiesCreator Class
EntitiesCreator Members
CADImport.Professional Namespace


EntitiesCreator.Dispose Method

A default Dispose method.

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EntitiesCreator Class
EntitiesCreator Members
CADImport.Professional Namespace


EntitiesCreator.DrawNewEntityCreator Method

Draws EntitiesCreator tool

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DrawNewEntityCreator()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DrawNewEntityCreator()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EntitiesCreator Class
EntitiesCreator Members
CADImport.Professional Namespace


EntitiesCreator.EnableCreator Method

Enables EntitiesCreator tool

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub EnableCreator( _
   ByVal entityType As CreatorType _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void EnableCreator(
   CreatorType entityType
)
This language is not supported or no code example is available.

Parameters

entityType

Type: CreatorType

Entity type

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EntitiesCreator Class
EntitiesCreator Members
CADImport.Professional Namespace


EntitiesCreator.EndDrawPolyline Method

Finishes Polyline entity drawing

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub EndDrawPolyline()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void EndDrawPolyline()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EntitiesCreator Class
EntitiesCreator Members
CADImport.Professional Namespace


EntitiesCreator.EndEntity Method

Finishes entity drawing

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub EndEntity()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void EndEntity()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EntitiesCreator Class
EntitiesCreator Members
CADImport.Professional Namespace


EntitiesCreator.OnCreateNewCADImage Method

Invokes CreateNewCADImageEvent event

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnCreateNewCADImage()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnCreateNewCADImage()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EntitiesCreator Class
EntitiesCreator Members
CADImport.Professional Namespace


EntitiesCreator.OnEndEntityDraw Method

Invokes EndEntityDraw event

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub OnEndEntityDraw( _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void OnEndEntityDraw(
   bool val
)
This language is not supported or no code example is available.

Parameters

val

Type: bool

A value of the entity creation finishing

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EntitiesCreator Class
EntitiesCreator Members
CADImport.Professional Namespace


EntitiesCreator.OnGetRealPoint Method

Invokes GetRealPointEvent event

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function OnGetRealPoint( _
   ByVal x As Integer, _
   ByVal y As Integer _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint OnGetRealPoint(
   int x,
   int y
)
This language is not supported or no code example is available.

Parameters

x

Type: int

X axis position in display coordinates

y

Type: int

Y axis position in display coordinates

Return Value

Real coordinates of the point (drawing coordinates)
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EntitiesCreator Class
EntitiesCreator Members
CADImport.Professional Namespace


EntitiesCreator Events

EntitiesCreator Class See Also

The following tables list the members exposed by the EntitiesCreator type.

Events
 | Name | Description
Public event | CreateNewCADImageEvent | Invokes on new CADImage creating
Public event | EndEntityDraw | Invokes on finishing of the entity drawing
Public event | GetRealPointEvent | Invokes on getting of the real coordinates of the point
Top
See Also

Reference

EntitiesCreator Class
CADImport.Professional Namespace


CreateNewCADImageEvent Event

Invokes on new CADImage creating

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event CreateNewCADImageEvent() As CADImport.Professional.CreateNewObjectEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.Professional.CreateNewObjectEventHandler CreateNewCADImageEvent
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EntitiesCreator Class
EntitiesCreator Members
CADImport.Professional Namespace


EndEntityDraw Event

Invokes on finishing of the entity drawing

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event EndEntityDraw() As CADImport.CADImportForms.ChangeOptionsEventHandler
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.CADImportForms.ChangeOptionsEventHandler EndEntityDraw
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EntitiesCreator Class
EntitiesCreator Members
CADImport.Professional Namespace


GetRealPointEvent Event

Invokes on getting of the real coordinates of the point

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Event GetRealPointEvent() As CADImport.Professional.GetRealPointEvent
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public event CADImport.Professional.GetRealPointEvent GetRealPointEvent
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EntitiesCreator Class
EntitiesCreator Members
CADImport.Professional Namespace


Marker Class

Members See Also

Represents a marker on the selected entity

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class Marker
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class Marker
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Professional.Marker
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Marker Members
CADImport.Professional Namespace


Marker Members

Marker Class Constructors Methods Properties See Also

Represents a marker on the selected entity

The following tables list the members exposed by the Marker type.

Constructors
 | Name | Description
Public constructor | Marker | Initializes a new instance of the Marker class.
Top
Properties
 | Name | Description
Public property | Entity | An entity for which current marker was created
Public property | Index | Marker's number in the collection of markers
Public property | Point | Absolute coordinates of the marker
Public property | Selected | Gets or sets a value indicating whether this Marker is selected.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Paint | Draws markers on the selected entity.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

Marker Class
CADImport.Professional Namespace


Marker Constructor

Initializes a new instance of the Marker class.

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal ent As CADEntity, _
   ByVal typePt As Byte, _
   ByVal index As Integer, _
   ByVal pt As DPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Marker(
   CADEntity ent,
   byte typePt,
   int index,
   DPoint pt
)
This language is not supported or no code example is available.

Parameters

ent

Type: CADEntity

The selected CADEntity.

typePt

Type: byte

Marker type; sets how Entity will be changed using this marker

index

Type: int

An index of the marker in the collection of markers used for selecting the CADEntity.

pt

Type: DPoint

A DPoint specifying a position of the Marker on the CAD image.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Marker Class
Marker Members
CADImport.Professional Namespace


Marker Properties

Marker Class See Also

The following tables list the members exposed by the Marker type.

Properties
 | Name | Description
Public property | Entity | An entity for which current marker was created
Public property | Index | Marker's number in the collection of markers
Public property | Point | Absolute coordinates of the marker
Public property | Selected | Gets or sets a value indicating whether this Marker is selected.
Top
See Also

Reference

Marker Class
CADImport.Professional Namespace


Marker.Entity Property

An entity for which current marker was created

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Entity() As CADEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntity Entity {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Marker Class
Marker Members
CADImport.Professional Namespace


Marker.Index Property

Marker's number in the collection of markers

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public ReadOnly Property Index() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Index {get;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Marker Class
Marker Members
CADImport.Professional Namespace


Marker.Point Property

Absolute coordinates of the marker

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Point() As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Point {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Marker Class
Marker Members
CADImport.Professional Namespace


Marker.Selected Property

Gets or sets a value indicating whether this Marker is selected.

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Selected() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Selected {get; set;}
This language is not supported or no code example is available.

Property Value

true if this Marker is selected; otherwise, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Marker Class
Marker Members
CADImport.Professional Namespace


Marker Methods

Marker Class See Also

The following tables list the members exposed by the Marker type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Paint | Draws markers on the selected entity.
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

Marker Class
CADImport.Professional Namespace


Marker.Paint Method

Draws markers on the selected entity.

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Paint( _
   ByVal gr As Graphics, _
   ByVal img As CADImage _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Paint(
   Graphics gr,
   CADImage img
)
This language is not supported or no code example is available.

Parameters

gr

Type: Graphics

A Graphics object used for drawing the markers.

img

Type: CADImage

A CADImage on which the selected entity is located.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Marker Class
Marker Members
CADImport.Professional Namespace


RedoClass Class

Members See Also

Auxiliary class for redo and undo operation, for professional version

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class RedoClass
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class RedoClass
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Professional.RedoClass
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RedoClass Members
CADImport.Professional Namespace


RedoClass Members

RedoClass Class Methods Fields Properties See Also

Auxiliary class for redo and undo operation, for professional version

The following tables list the members exposed by the RedoClass type.

Properties
 | Name | Description
Public property | Entity | Gets or sets the first entity in entity collection
Public property | EntityCollection | Gets or sets a list of entities which are under effect
Top
Methods
 | Name | Description
Public method | AddEntityToCollect | Adds entity to entity collection
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | entityCollection | CADEntity object.
Public field | operation | Operation
Top
See Also

Reference

RedoClass Class
CADImport.Professional Namespace


RedoClass Properties

RedoClass Class See Also

The following tables list the members exposed by the RedoClass type.

Properties
 | Name | Description
Public property | Entity | Gets or sets the first entity in entity collection
Public property | EntityCollection | Gets or sets a list of entities which are under effect
Top
See Also

Reference

RedoClass Class
CADImport.Professional Namespace


RedoClass.Entity Property

Gets or sets the first entity in entity collection

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Entity() As CADEntity
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntity Entity {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RedoClass Class
RedoClass Members
CADImport.Professional Namespace


RedoClass.EntityCollection Property

Gets or sets a list of entities which are under effect

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property EntityCollection() As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntityCollection EntityCollection {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RedoClass Class
RedoClass Members
CADImport.Professional Namespace


RedoClass Methods

RedoClass Class See Also

The following tables list the members exposed by the RedoClass type.

Methods
 | Name | Description
Public method | AddEntityToCollect | Adds entity to entity collection
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

RedoClass Class
CADImport.Professional Namespace


RedoClass.AddEntityToCollect Method

Adds entity to entity collection

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddEntityToCollect( _
   ByVal ent As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddEntityToCollect(
   CADEntity ent
)
This language is not supported or no code example is available.

Parameters

ent

Type: CADEntity

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RedoClass Class
RedoClass Members
CADImport.Professional Namespace


RedoClass Fields

RedoClass Class See Also

The following tables list the members exposed by the RedoClass type.

Fields
 | Name | Description
Public field | entityCollection | CADEntity object.
Public field | operation | Operation
Top
See Also

Reference

RedoClass Class
CADImport.Professional Namespace


entityCollection Field

CADEntity object.

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public entityCollection As CADEntityCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntityCollection entityCollection
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RedoClass Class
RedoClass Members
CADImport.Professional Namespace


operation Field

Operation

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public operation As Operation
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Operation operation
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RedoClass Class
RedoClass Members
CADImport.Professional Namespace


ToolsSettings Class

Members See Also

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class ToolsSettings
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static class ToolsSettings
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CADImport.Professional.ToolsSettings
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ToolsSettings Members
CADImport.Professional Namespace


ToolsSettings Members

ToolsSettings Class Methods Properties See Also

The following tables list the members exposed by the ToolsSettings type.

Properties
Name | Description
Precision |
ShowJoinErrorMessage |
SingleTrim |
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

ToolsSettings Class
CADImport.Professional Namespace


ToolsSettings Properties

ToolsSettings Class See Also

The following tables list the members exposed by the ToolsSettings type.

Properties
Name | Description
Precision |
ShowJoinErrorMessage |
SingleTrim |
Top
See Also

Reference

ToolsSettings Class
CADImport.Professional Namespace


ToolsSettings.Precision Property

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Property Precision() As Byte
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static byte Precision {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ToolsSettings Class
ToolsSettings Members
CADImport.Professional Namespace


ToolsSettings.ShowJoinErrorMessage Property

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Property ShowJoinErrorMessage() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool ShowJoinErrorMessage {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ToolsSettings Class
ToolsSettings Members
CADImport.Professional Namespace


ToolsSettings.SingleTrim Property

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Property SingleTrim() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool SingleTrim {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ToolsSettings Class
ToolsSettings Members
CADImport.Professional Namespace


ToolsSettings Methods

ToolsSettings Class See Also

The following tables list the members exposed by the ToolsSettings type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Top
See Also

Reference

ToolsSettings Class
CADImport.Professional Namespace


CreateNewObjectEventHandler Delegate

Represents a set of methods which are invoked on new entity creating; The set is used for CreateNewCADImageEvent event

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Delegate Sub CreateNewObjectEventHandler()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public delegate void CreateNewObjectEventHandler()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImport.Professional Namespace


GetRealPointEvent Delegate

Represents a set of methods for getting real (drawing) coordinates by display coordinates

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Delegate Function GetRealPointEvent( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal useGrid As Boolean _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public delegate DPoint GetRealPointEvent(
   int x,
   int y,
   bool useGrid
)
This language is not supported or no code example is available.

Parameters

x

Type: int

y

Type: int

useGrid

Type: bool

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImport.Professional Namespace


CreatorType Enumeration

Types list of the creating entities

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Arc | Arc
Circle | Circle
Cloud | Cloud
Ellipse | Ellipse
Hatch | Hatch
Image | Image
Leader | Leader
Line | Line
MText | MText
Pen | Pen
Point | Point
Polyline | PolyLine
Rectangle | Rectangle
Text | Text
Undetected | Undetected
See Also

Reference

CADImport.Professional Namespace


Operation Enumeration

Operation, for professional version

Namespace: CADImport.Professional
Assembly: CADImport (in CADImport.dll)

Members
Member name | Description
Change | Change
Create | Create
Delete | Delete
See Also

Reference

CADImport.Professional Namespace


CADImport.RasterImage Namespace

Assembly: CADImport (in CADImport.dll)

Classes
 | Name | Description
Public class | CADRasterImage | Represents a raster image.
Top
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


CADRasterImage Class

Members See Also

Represents a raster image.

Namespace: CADImport.RasterImage
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Class CADRasterImage
    Inherits CADImage
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public class CADRasterImage : CADImage
This language is not supported or no code example is available.
Remarks

A CADRasterImage class provides methods for drawing raster images in the viewer.

Inheritance Hierarchy
System.Object
CADImport.CADImage
CADImport.RasterImage.CADRasterImage
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADRasterImage Members
CADImport.RasterImage Namespace


CADRasterImage Members

CADRasterImage Class Constructors Methods Fields Properties See Also

Represents a raster image.

The following tables list the members exposed by the CADRasterImage type.

Constructors
 | Name | Description
Public constructor | CADRasterImage | (Overloaded) Initializes a new instance of the CADRasterImage class.
Top
Properties
 | Name | Description
Public property | AbsDepth | Gets an absolute depths of the CADImage. (inherited from CADImage).
Public property | AbsHeight | Gets an absolute height of the CADImage. (inherited from CADImage).
Public property | AbsWidth | Gets an absolute width of the CADImage. (inherited from CADImage).
Public property | Angle | Gets or sets the angle for this CADImage object visualization. (inherited from CADImage).
Public property | BackgroundColor | Gets or sets a background color of this CADImage. (inherited from CADImage).
Public property | BorderSize | Gets or sets a border size in pixels. (inherited from CADImage).
Public property | BorderType | Gets or sets a border type. (inherited from CADImage).
Public property | Center | Gets or sets CADImage center point. (inherited from CADImage).
Public property | Charset | Gets or sets a character set for the text entities. (inherited from CADImage).
 | CodePage | Gets or sets a number that identifies the encoding used in the loaded CAD file. (inherited from CADImage).
Public property | Control | Gets or sets control element required for gif images animation
Public property | Converter | Gets a converter that loads CAD entities from the file to draw them in the current CADImage. (inherited from CADImage).
Public property | CurrentLayer | Gets or sets a current layer for the CADImage. (inherited from CADImage).
Public property | CurrentLayout | Gets or sets a current layout for the CADImage. (inherited from CADImage).
Public property | CurrentLayoutIndex | Gets an index of the current layout. (inherited from CADImage).
Public property | CurrentMarker | Gets a currently selected marker. (inherited from CADImage).
Public property | DefaultColor | Gets or sets a default color for the CADImage. (inherited from CADImage).
Public property | DefaultLayoutIndex | Gets or sets a default layout index. (inherited from CADImage).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions on the drawing are visible. (inherited from CADImage).
Public property | DrawMode | Gets or sets a current drawing mode. (inherited from CADImage).
Public property | EnableSnap | Gets or sets enablement of snap mode (inherited from CADImage).
Public property | Extents | Gets or sets an extents of the CADImage object. (inherited from CADImage).
Public property | FileInf | Gets information about a currently open file by means of the FileInfo class. (inherited from CADImage).
Public property | GDIPainter | Provides drawing functionality based on GDI+. (inherited from CADImage).
Public property | GraphicsOutMode | Specifies image draw mode. (inherited from CADImage).
Public property | InterpolationMode | Gets or sets the interpolation mode associated with current Graphics object (inherited from CADImage).
Public property | Is3D | Gets a value indicating whether this CADImage is three-dimensional. (inherited from CADImage).
Public property | IsDraw3DAxes | Gets or sets a value indicating whether 3D axes are shown on the drawing. (inherited from CADImage).
Public property | IsDrawingRotated | Gets a value indicating whether the CADImage has been rotated. (inherited from CADImage).
Public property | IsShowBackground | Gets or sets a value indicating using of a BackgroundColor. (inherited from CADImage).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data. (inherited from CADImage).
Public property | IsSnapObject | Gets a value, which shows if there is an object for snapping under current coordinates (inherited from CADImage).
Public property | IsStopped | For internal use. (inherited from CADImage).
Public property | IsWithoutBorder | Gest or sets a value indicating whether to draw the CADImage without borders. (inherited from CADImage).
Public property | IsWithoutMargins | Gets or sets a value indicating whether to draw the CADImage without margins. (inherited from CADImage).
 | LastLoadedFilePath | Specifying of the search directory (used for X-Refs, ImageEnt) (inherited from CADImage).
Public property | LayersCount | Gets a quantity of layers in this CADImage. (inherited from CADImage).
Public property | Layouts | Gets a collection of layouts in the current CADImage. (inherited from CADImage).
Public property | LayoutsCount | Gets a quantity of layouts in this CADImage. (inherited from CADImage).
Public property | LineScaled | Obsolete. Gets or sets a value indicating whether a width of lines to draw all entities in the drawing is specified by the file data. (inherited from CADImage).
Public property | LineWeightScale | Gets or sets a scale for drawing lines. (inherited from CADImage).
Public property | MMToPixelX | Gets or sets a value corresponding to amount of millimeters per one pixel. (inherited from CADImage).
Public property | NullWidth | Gets or sets default thickness for lines used to draw a CADImage. (inherited from CADImage).
Public property | NumberOfPartsInCircle | Gets or sets a quantity of segments to be used to draw a circle. (inherited from CADImage).
Public property | Painter | Provides image drawing functionality. (inherited from CADImage).
Public property | PrintDialog | Gets or sets print dialog (inherited from CADImage).
Public property | PureExtents | Gets CADImage extents without margins. (inherited from CADImage).
Public property | ResizeDisproportionateDrawing | For internal use (inherited from CADImage).
Public property | SHXSearchPaths | Gets or sets paths for searching SHX fonts. (inherited from CADImage).
Public property | SearchSHXPaths | Gets or sets a value specifying whether SHX paths will be searched for the fonts. (inherited from CADImage).
Public property | SelectEntitiesCount | Gets the number of selected entities (inherited from CADImage).
Public property | SelectedEntities | Gets or sets a list of selected entities (inherited from CADImage).
Public property | SelectionMode | Gets or sets a state of the Selection tool. (inherited from CADImage).
Public property | Selector | Provides selection functionality. (inherited from CADImage).
Public property | SkipMMtoPixel | For specific use (inherited from CADImage).
Public property | SnapCurrent | (inherited from CADImage).
Public property | SnapOptions | Represents Snap options for the CADImage object (inherited from CADImage).
Public property | SnapRealPoint | Gets a current point in absolute coordinates (drawing coordinates) (inherited from CADImage).
Public property | SnapScreenPoint | Gets current point in display coordinates (inherited from CADImage).
Public property | TTFSmoothing | Gets or sets a value indicating whether TTF fonts are smoothed. (inherited from CADImage).
Public property | TextVisible | Gets or sets a value indicating whether the texts in the CADImage are visible. (inherited from CADImage).
Public property | UndoMode | Gets or sets whether undo/redo is disable or enable for professional version (inherited from CADImage).
Public property | UseDoubleBuffering | Outdated. Does nothing (inherited from CADImage).
Public property | UseLayerPriority | (inherited from CADImage).
Public property | UseMultyTTFFonts | Gets or sets a value indicating whether a multimode is used for showing symbols. (inherited from CADImage).
Public property | UseNullWidth | Specifies if default width will be used instead of entity width. (inherited from CADImage).
Public property | UseSHXFonts | Specifies if SHX fonts will be used for visualization. (inherited from CADImage).
Public property | UseTTFFonts | Specifies if TTF fonts will be used for visualization. (inherited from CADImage).
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles in the CADImage are drawn with GDI+ drawing methods without linearization. (inherited from CADImage).
Top
Methods
 | Name | Description
Public method | ActiveVPort | Returns drawing area visualized with the active VPort. (inherited from CADImage).
Public method | AddScaledDXF | Adds a scaled external reference to the model space of the specified CAD image. (inherited from CADImage).
Public method | AddScaledDXFEx | Adds a scaled external reference to the current layout of the specified CAD image. (inherited from CADImage).
Public method | AddToUndoList | (Overloaded) Adds operation "create new Entity" to undo list (inherited from CADImage).
Public method | ChangeDrawMode | Initializes a new graphic class object if current mode changed. (inherited from CADImage).
Public method | ChangeEntities | (inherited from CADImage).
Public method | ChangeGraphicsMode | Changes image drawing mode. (inherited from CADImage).
Public method | ChangePositionSelectedEntities | Changes position of the selected entities (inherited from CADImage).
Public method | ChangePositionSelectedEntity | Changes a position of the selected entity. (inherited from CADImage).
Public method | ClearBuffer | Outdated. Does nothing (inherited from CADImage).
Public method | ClearMarkers | Clears a collection of markers. (inherited from CADImage).
Public method | ClearRedoCollection | Clears redo entity collection (inherited from CADImage).
Public method | ClearSelectCollection | Clears a collection of the selected entities. (inherited from CADImage).
Public method | ClearSelection | Clears a list of the selected entities. (inherited from CADImage).
Public method | ClearSnapTrace | (Overloaded) Clears last drawn snap drawing element (inherited from CADImage).
Public method | ClearUndoCollection | Clears undo entity collection (inherited from CADImage).
Public method | CopyEntities | (Overloaded) Copies selected entities to the clipboard (inherited from CADImage).
Public method | CorrectByGrid | (Overloaded) Reduces a point location on screen to the grid node when the grid is active (inherited from CADImage).
Public method | CorrectByGridAndOrtho | Reduces a point relocation sizes on screen to the grid cell sizes when the grid is active (inherited from CADImage).
 | CreateImageByExtension | Creates specialised CADImage object for specified file extention (inherited from CADImage).
Public method | CutEntities | (Overloaded) Cuts selected entities from collection and paste them to the clipboard (inherited from CADImage).
Public method | Dispose | Disposes a CADImage object.
Public method | DoSelectEntities | (Overloaded) Selects inserted list of entities (inherited from CADImage).
Public method | DoSelectEntity | Selects inserted entity (inherited from CADImage).
Public method | Draw | (Overloaded) Draws a CADImage. (inherited from CADImage).
Public method | DrawACISEntity | Draws ACISEntity object (inherited from CADImage).
Public method | DrawChangeEntity | Changes a position of the marker designating the selected entity. (inherited from CADImage).
Public method | DrawMoveEntityTrace | Draws entities on their offsetting (inherited from CADImage).
Public method | DrawSnapTrace | Draws snap icon in case of proximity of object to current coordinates (inherited from CADImage).
Public method | EmfConvertToDXF | (Overloaded) Converts emf file to dxf file (inherited from CADImage).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportToMetafile | (Overloaded) Exports a CAD drawing to Windows Enhanced metafile. (inherited from CADImage).
Public method | GetAbsPoint | Converts display coordinates into absolute coordinates of a design (inherited from CADImage).
Public method | GetCADCoords | Returns coordinates of a point on the drawing. (inherited from CADImage).
Public method | GetCenter | Returns the center point of a current layout (inherited from CADImage).
Public method | GetExtents | Calculates the current dimensions of the CADImage. (inherited from CADImage).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLayerColor | Gets layer color by index (inherited from CADImage).
Public method | GetLayerFreeze | Determines whether the layer (CADLayer) is frozen. (inherited from CADImage).
Public method | GetLayerName | Gets a name of the layer that has the specified index in the collection of layers. (inherited from CADImage).
Public method | GetLayerVisible | Determines whether a layer is visible (inherited from CADImage).
Public method | GetLayoutName | Gets a name of the layout that has the specified index in the collection of layouts. (inherited from CADImage).
Public method | GetPoint | Transforms a three-dimensional CAD point into a two-dimensional screen point. (inherited from CADImage).
Public method | GetRealImagePoint | For internal use. (inherited from CADImage).
Public method | GetRealSnapPoint | Smooths a point in absolute coordinates by the entity (inherited from CADImage).
Public method | GetSelectEntityRegion | Returns the selected area of the image. (inherited from CADImage).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetVPortExtents | Returns extents of the active VPort reduced to the specified size (inherited from CADImage).
Public method | InitialNewImage | (Overloaded) Initializes a new image with the default size (inherited from CADImage).
Public method | InvalidateSelectEntity | Redraws a selected entity. (inherited from CADImage).
Public method | InvalidateSelectedEntities | (Overloaded) Redraws a list of the selected entities (inherited from CADImage).
Public method | LoadFromFile | Loads a raster image from the specified file.
Public method | LoadFromImage | Loads CADRasterImage from ImageSystem.Drawing.Image
Public method | LoadFromStream | (Overloaded) Loads a CAD image stored in the specified stream.
Public method | LoadFromWeb | Loads CAD image from hyperlink (inherited from CADImage).
Public method | LoadMetafile | Load metafile
Public method | MultipleSelect | Providing CAD image entities' multiple selection within a specified rectangle. (inherited from CADImage).
Public method | MultipleSelectExt | Selects all entities inside the inserted rectangle (inherited from CADImage).
Public method | PasteEntities | Pastes entities from the clipboard (inherited from CADImage).
Public method | PasteEntitiesExt | Pastes entities from the clipboard (inherited from CADImage).
Public method | Print | Prints a current CAD image. (inherited from CADImage).
Public method | Redo | Redo change (inherited from CADImage).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RefreshCurrentLayout | Refresh current layout. (inherited from CADImage).
Public method | RefreshSnapTrace | Refreshes a region of the last drawn snap drawing element (inherited from CADImage).
Public method | RemoveEntity | (Overloaded) Removes CADEntity object. (inherited from CADImage).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from CADImage).
Public method | RotToView | Rotates a CAD image to get a specified view. (inherited from CADImage).
Public method | Rotate | Rotates objects in the current drawing. (inherited from CADImage).
Public method | SaveAsDXF | Saves a current CAD image in DXF format. (inherited from CADImage).
Public method | SaveImageToClipboard | (Overloaded) Writes a visible part of the current CAD image to the clipboard as a raster image. (inherited from CADImage).
Public method | SaveToFile | (Overloaded) Saves a part of the current CAD image to the file of the specified format. (inherited from CADImage).
Public method | SaveToStream | (Overloaded) Writes a visible part of the current CAD image to the specified stream as a raster image. (inherited from CADImage).
Public method | Select | Selects an entity of the CAD image at the specified point. (inherited from CADImage).
Public method | SelectExt | Selects an entity of the CAD image at the specified point. (inherited from CADImage).
Public method | SetCenter | Sets CADImage center point. (inherited from CADImage).
Public method | SetCurrentLayout | Sets a current layout of this CADImage. (inherited from CADImage).
Public method | SetLayerColor | (Overloaded) Sets a color for layer (CADLayer) specified by index (inherited from CADImage).
Public method | SetLayerFreeze | (Overloaded) Sets freeze parameter for CADLayer (inherited from CADImage).
Public method | SetLayerVisible | (Overloaded) Sets a visibility of the layer. (inherited from CADImage).
Public method | SetNewEntityMarkerPos | Sets a new position for the selected entity. The entity's new position is defined by the position of the marker. (inherited from CADImage).
Public method | SetNewMMToPixel | Sets a quantity of millimeters per pixel for the specified Graphics object. (inherited from CADImage).
Public method | SetNewPosEntitiesExt | Sets a new position for the specified entities (inherited from CADImage).
Public method | SetNewPosEntity | Sets a new position for the specified entity. (inherited from CADImage).
Public method | Stop | For internal use. (inherited from CADImage).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | Undo | Undo change (inherited from CADImage).
Top
Fields
 | Name | Description
 | EntityBuffer | Represents buffer for CADEntityCollection storing. (inherited from CADImage).
Public field | visibleArea | Represents CADImage visible area. (inherited from CADImage).
Top
See Also

Reference

CADRasterImage Class
CADImport.RasterImage Namespace


CADRasterImage Constructor

CADRasterImage Class See Also

Initializes a new instance of the CADRasterImage class.

Overload List
Name | Description
CADRasterImage() | Initializes a new instance of the CADRasterImage class.
CADRasterImage(Control) | Initializes a new instance of the CADRasterImage class.
See Also

Reference

CADRasterImage Class
CADRasterImage Members
CADImport.RasterImage Namespace


CADRasterImage Properties

CADRasterImage Class See Also

The following tables list the members exposed by the CADRasterImage type.

Properties
 | Name | Description
Public property | AbsDepth | Gets an absolute depths of the CADImage. (inherited from CADImage).
Public property | AbsHeight | Gets an absolute height of the CADImage. (inherited from CADImage).
Public property | AbsWidth | Gets an absolute width of the CADImage. (inherited from CADImage).
Public property | Angle | Gets or sets the angle for this CADImage object visualization. (inherited from CADImage).
Public property | BackgroundColor | Gets or sets a background color of this CADImage. (inherited from CADImage).
Public property | BorderSize | Gets or sets a border size in pixels. (inherited from CADImage).
Public property | BorderType | Gets or sets a border type. (inherited from CADImage).
Public property | Center | Gets or sets CADImage center point. (inherited from CADImage).
Public property | Charset | Gets or sets a character set for the text entities. (inherited from CADImage).
 | CodePage | Gets or sets a number that identifies the encoding used in the loaded CAD file. (inherited from CADImage).
Public property | Control | Gets or sets control element required for gif images animation
Public property | Converter | Gets a converter that loads CAD entities from the file to draw them in the current CADImage. (inherited from CADImage).
Public property | CurrentLayer | Gets or sets a current layer for the CADImage. (inherited from CADImage).
Public property | CurrentLayout | Gets or sets a current layout for the CADImage. (inherited from CADImage).
Public property | CurrentLayoutIndex | Gets an index of the current layout. (inherited from CADImage).
Public property | CurrentMarker | Gets a currently selected marker. (inherited from CADImage).
Public property | DefaultColor | Gets or sets a default color for the CADImage. (inherited from CADImage).
Public property | DefaultLayoutIndex | Gets or sets a default layout index. (inherited from CADImage).
Public property | DimensionsVisible | Gets or sets a value indicating whether dimensions on the drawing are visible. (inherited from CADImage).
Public property | DrawMode | Gets or sets a current drawing mode. (inherited from CADImage).
Public property | EnableSnap | Gets or sets enablement of snap mode (inherited from CADImage).
Public property | Extents | Gets or sets an extents of the CADImage object. (inherited from CADImage).
Public property | FileInf | Gets information about a currently open file by means of the FileInfo class. (inherited from CADImage).
Public property | GDIPainter | Provides drawing functionality based on GDI+. (inherited from CADImage).
Public property | GraphicsOutMode | Specifies image draw mode. (inherited from CADImage).
Public property | InterpolationMode | Gets or sets the interpolation mode associated with current Graphics object (inherited from CADImage).
Public property | Is3D | Gets a value indicating whether this CADImage is three-dimensional. (inherited from CADImage).
Public property | IsDraw3DAxes | Gets or sets a value indicating whether 3D axes are shown on the drawing. (inherited from CADImage).
Public property | IsDrawingRotated | Gets a value indicating whether the CADImage has been rotated. (inherited from CADImage).
Public property | IsShowBackground | Gets or sets a value indicating using of a BackgroundColor. (inherited from CADImage).
Public property | IsShowLineWeight | Gets or sets a value indicating whether a thickness of lines in the CADImage is determined by the file data. (inherited from CADImage).
Public property | IsSnapObject | Gets a value, which shows if there is an object for snapping under current coordinates (inherited from CADImage).
Public property | IsStopped | For internal use. (inherited from CADImage).
Public property | IsWithoutBorder | Gest or sets a value indicating whether to draw the CADImage without borders. (inherited from CADImage).
Public property | IsWithoutMargins | Gets or sets a value indicating whether to draw the CADImage without margins. (inherited from CADImage).
 | LastLoadedFilePath | Specifying of the search directory (used for X-Refs, ImageEnt) (inherited from CADImage).
Public property | LayersCount | Gets a quantity of layers in this CADImage. (inherited from CADImage).
Public property | Layouts | Gets a collection of layouts in the current CADImage. (inherited from CADImage).
Public property | LayoutsCount | Gets a quantity of layouts in this CADImage. (inherited from CADImage).
Public property | LineScaled | Obsolete. Gets or sets a value indicating whether a width of lines to draw all entities in the drawing is specified by the file data. (inherited from CADImage).
Public property | LineWeightScale | Gets or sets a scale for drawing lines. (inherited from CADImage).
Public property | MMToPixelX | Gets or sets a value corresponding to amount of millimeters per one pixel. (inherited from CADImage).
Public property | NullWidth | Gets or sets default thickness for lines used to draw a CADImage. (inherited from CADImage).
Public property | NumberOfPartsInCircle | Gets or sets a quantity of segments to be used to draw a circle. (inherited from CADImage).
Public property | Painter | Provides image drawing functionality. (inherited from CADImage).
Public property | PrintDialog | Gets or sets print dialog (inherited from CADImage).
Public property | PureExtents | Gets CADImage extents without margins. (inherited from CADImage).
Public property | ResizeDisproportionateDrawing | For internal use (inherited from CADImage).
Public property | SHXSearchPaths | Gets or sets paths for searching SHX fonts. (inherited from CADImage).
Public property | SearchSHXPaths | Gets or sets a value specifying whether SHX paths will be searched for the fonts. (inherited from CADImage).
Public property | SelectEntitiesCount | Gets the number of selected entities (inherited from CADImage).
Public property | SelectedEntities | Gets or sets a list of selected entities (inherited from CADImage).
Public property | SelectionMode | Gets or sets a state of the Selection tool. (inherited from CADImage).
Public property | Selector | Provides selection functionality. (inherited from CADImage).
Public property | SkipMMtoPixel | For specific use (inherited from CADImage).
Public property | SnapCurrent | (inherited from CADImage).
Public property | SnapOptions | Represents Snap options for the CADImage object (inherited from CADImage).
Public property | SnapRealPoint | Gets a current point in absolute coordinates (drawing coordinates) (inherited from CADImage).
Public property | SnapScreenPoint | Gets current point in display coordinates (inherited from CADImage).
Public property | TTFSmoothing | Gets or sets a value indicating whether TTF fonts are smoothed. (inherited from CADImage).
Public property | TextVisible | Gets or sets a value indicating whether the texts in the CADImage are visible. (inherited from CADImage).
Public property | UndoMode | Gets or sets whether undo/redo is disable or enable for professional version (inherited from CADImage).
Public property | UseDoubleBuffering | Outdated. Does nothing (inherited from CADImage).
Public property | UseLayerPriority | (inherited from CADImage).
Public property | UseMultyTTFFonts | Gets or sets a value indicating whether a multimode is used for showing symbols. (inherited from CADImage).
Public property | UseNullWidth | Specifies if default width will be used instead of entity width. (inherited from CADImage).
Public property | UseSHXFonts | Specifies if SHX fonts will be used for visualization. (inherited from CADImage).
Public property | UseTTFFonts | Specifies if TTF fonts will be used for visualization. (inherited from CADImage).
Public property | UseWinEllipse | Gets or sets a value indicating whether arcs and circles in the CADImage are drawn with GDI+ drawing methods without linearization. (inherited from CADImage).
Top
See Also

Reference

CADRasterImage Class
CADImport.RasterImage Namespace


CADRasterImage.Control Property

Gets or sets control element required for gif images animation

Namespace: CADImport.RasterImage
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Control() As Control
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Control Control {get; set;}
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADRasterImage Class
CADRasterImage Members
CADImport.RasterImage Namespace


CADRasterImage Methods

CADRasterImage Class See Also

The following tables list the members exposed by the CADRasterImage type.

Methods
 | Name | Description
Public method | ActiveVPort | Returns drawing area visualized with the active VPort. (inherited from CADImage).
Public method | AddScaledDXF | Adds a scaled external reference to the model space of the specified CAD image. (inherited from CADImage).
Public method | AddScaledDXFEx | Adds a scaled external reference to the current layout of the specified CAD image. (inherited from CADImage).
Public method | AddToUndoList | (Overloaded) Adds operation "create new Entity" to undo list (inherited from CADImage).
Public method | ChangeDrawMode | Initializes a new graphic class object if current mode changed. (inherited from CADImage).
Public method | ChangeEntities | (inherited from CADImage).
Public method | ChangeGraphicsMode | Changes image drawing mode. (inherited from CADImage).
Public method | ChangePositionSelectedEntities | Changes position of the selected entities (inherited from CADImage).
Public method | ChangePositionSelectedEntity | Changes a position of the selected entity. (inherited from CADImage).
Public method | ClearBuffer | Outdated. Does nothing (inherited from CADImage).
Public method | ClearMarkers | Clears a collection of markers. (inherited from CADImage).
Public method | ClearRedoCollection | Clears redo entity collection (inherited from CADImage).
Public method | ClearSelectCollection | Clears a collection of the selected entities. (inherited from CADImage).
Public method | ClearSelection | Clears a list of the selected entities. (inherited from CADImage).
Public method | ClearSnapTrace | (Overloaded) Clears last drawn snap drawing element (inherited from CADImage).
Public method | ClearUndoCollection | Clears undo entity collection (inherited from CADImage).
Public method | CopyEntities | (Overloaded) Copies selected entities to the clipboard (inherited from CADImage).
Public method | CorrectByGrid | (Overloaded) Reduces a point location on screen to the grid node when the grid is active (inherited from CADImage).
Public method | CorrectByGridAndOrtho | Reduces a point relocation sizes on screen to the grid cell sizes when the grid is active (inherited from CADImage).
 | CreateImageByExtension | Creates specialised CADImage object for specified file extention (inherited from CADImage).
Public method | CutEntities | (Overloaded) Cuts selected entities from collection and paste them to the clipboard (inherited from CADImage).
Public method | Dispose | Disposes a CADImage object.
Public method | DoSelectEntities | (Overloaded) Selects inserted list of entities (inherited from CADImage).
Public method | DoSelectEntity | Selects inserted entity (inherited from CADImage).
Public method | Draw | (Overloaded) Draws a CADImage. (inherited from CADImage).
Public method | DrawACISEntity | Draws ACISEntity object (inherited from CADImage).
Public method | DrawChangeEntity | Changes a position of the marker designating the selected entity. (inherited from CADImage).
Public method | DrawMoveEntityTrace | Draws entities on their offsetting (inherited from CADImage).
Public method | DrawSnapTrace | Draws snap icon in case of proximity of object to current coordinates (inherited from CADImage).
Public method | EmfConvertToDXF | (Overloaded) Converts emf file to dxf file (inherited from CADImage).
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to the current Object. (inherited from Object).
Public method | ExportToMetafile | (Overloaded) Exports a CAD drawing to Windows Enhanced metafile. (inherited from CADImage).
Public method | GetAbsPoint | Converts display coordinates into absolute coordinates of a design (inherited from CADImage).
Public method | GetCADCoords | Returns coordinates of a point on the drawing. (inherited from CADImage).
Public method | GetCenter | Returns the center point of a current layout (inherited from CADImage).
Public method | GetExtents | Calculates the current dimensions of the CADImage. (inherited from CADImage).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object).
Public method | GetLayerColor | Gets layer color by index (inherited from CADImage).
Public method | GetLayerFreeze | Determines whether the layer (CADLayer) is frozen. (inherited from CADImage).
Public method | GetLayerName | Gets a name of the layer that has the specified index in the collection of layers. (inherited from CADImage).
Public method | GetLayerVisible | Determines whether a layer is visible (inherited from CADImage).
Public method | GetLayoutName | Gets a name of the layout that has the specified index in the collection of layouts. (inherited from CADImage).
Public method | GetPoint | Transforms a three-dimensional CAD point into a two-dimensional screen point. (inherited from CADImage).
Public method | GetRealImagePoint | For internal use. (inherited from CADImage).
Public method | GetRealSnapPoint | Smooths a point in absolute coordinates by the entity (inherited from CADImage).
Public method | GetSelectEntityRegion | Returns the selected area of the image. (inherited from CADImage).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetVPortExtents | Returns extents of the active VPort reduced to the specified size (inherited from CADImage).
Public method | InitialNewImage | (Overloaded) Initializes a new image with the default size (inherited from CADImage).
Public method | InvalidateSelectEntity | Redraws a selected entity. (inherited from CADImage).
Public method | InvalidateSelectedEntities | (Overloaded) Redraws a list of the selected entities (inherited from CADImage).
Public method | LoadFromFile | Loads a raster image from the specified file.
Public method | LoadFromImage | Loads CADRasterImage from ImageSystem.Drawing.Image
Public method | LoadFromStream | (Overloaded) Loads a CAD image stored in the specified stream.
Public method | LoadFromWeb | Loads CAD image from hyperlink (inherited from CADImage).
Public method | LoadMetafile | Load metafile
Public method | MultipleSelect | Providing CAD image entities' multiple selection within a specified rectangle. (inherited from CADImage).
Public method | MultipleSelectExt | Selects all entities inside the inserted rectangle (inherited from CADImage).
Public method | PasteEntities | Pastes entities from the clipboard (inherited from CADImage).
Public method | PasteEntitiesExt | Pastes entities from the clipboard (inherited from CADImage).
Public method | Print | Prints a current CAD image. (inherited from CADImage).
Public method | Redo | Redo change (inherited from CADImage).
 | ReferenceEquals | Determines whether the specified Object instances are the same instance. (inherited from Object).
Public method | RefreshCurrentLayout | Refresh current layout. (inherited from CADImage).
Public method | RefreshSnapTrace | Refreshes a region of the last drawn snap drawing element (inherited from CADImage).
Public method | RemoveEntity | (Overloaded) Removes CADEntity object. (inherited from CADImage).
Public method | RotDefault | Rotates the drawing to the default view. (inherited from CADImage).
Public method | RotToView | Rotates a CAD image to get a specified view. (inherited from CADImage).
Public method | Rotate | Rotates objects in the current drawing. (inherited from CADImage).
Public method | SaveAsDXF | Saves a current CAD image in DXF format. (inherited from CADImage).
Public method | SaveImageToClipboard | (Overloaded) Writes a visible part of the current CAD image to the clipboard as a raster image. (inherited from CADImage).
Public method | SaveToFile | (Overloaded) Saves a part of the current CAD image to the file of the specified format. (inherited from CADImage).
Public method | SaveToStream | (Overloaded) Writes a visible part of the current CAD image to the specified stream as a raster image. (inherited from CADImage).
Public method | Select | Selects an entity of the CAD image at the specified point. (inherited from CADImage).
Public method | SelectExt | Selects an entity of the CAD image at the specified point. (inherited from CADImage).
Public method | SetCenter | Sets CADImage center point. (inherited from CADImage).
Public method | SetCurrentLayout | Sets a current layout of this CADImage. (inherited from CADImage).
Public method | SetLayerColor | (Overloaded) Sets a color for layer (CADLayer) specified by index (inherited from CADImage).
Public method | SetLayerFreeze | (Overloaded) Sets freeze parameter for CADLayer (inherited from CADImage).
Public method | SetLayerVisible | (Overloaded) Sets a visibility of the layer. (inherited from CADImage).
Public method | SetNewEntityMarkerPos | Sets a new position for the selected entity. The entity's new position is defined by the position of the marker. (inherited from CADImage).
Public method | SetNewMMToPixel | Sets a quantity of millimeters per pixel for the specified Graphics object. (inherited from CADImage).
Public method | SetNewPosEntitiesExt | Sets a new position for the specified entities (inherited from CADImage).
Public method | SetNewPosEntity | Sets a new position for the specified entity. (inherited from CADImage).
Public method | Stop | For internal use. (inherited from CADImage).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object).
Public method | Undo | Undo change (inherited from CADImage).
Top
See Also

Reference

CADRasterImage Class
CADImport.RasterImage Namespace


CADRasterImage.Dispose Method

Disposes a CADImage object.

Namespace: CADImport.RasterImage
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Dispose()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Dispose()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADRasterImage Class
CADRasterImage Members
CADImport.RasterImage Namespace


CADRasterImage.LoadFromFile Method

Loads a raster image from the specified file.

Namespace: CADImport.RasterImage
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub LoadFromFile( _
   ByVal path As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void LoadFromFile(
   string path
)
This language is not supported or no code example is available.

Parameters

path

Type: string

A string containing a path to the file where the raster image is loaded from.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADRasterImage Class
CADRasterImage Members
CADImport.RasterImage Namespace


CADRasterImage.LoadFromImage Method

Loads CADRasterImage from ImageSystem.Drawing.Image

Namespace: CADImport.RasterImage
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub LoadFromImage( _
   ByVal img As Image _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void LoadFromImage(
   Image img
)
This language is not supported or no code example is available.

Parameters

img

Type: Image

Loading Imageimage

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADRasterImage Class
CADRasterImage Members
CADImport.RasterImage Namespace


CADRasterImage.LoadFromStream Method

CADRasterImage Class See Also

Loads a CAD image stored in the specified stream.

Overload List
Name | Description
LoadFromStream(Stream) | Loads a CAD image stored in the specified stream.
LoadFromStream(Stream, string) | Loads a CAD image stored in the specified stream.
See Also

Reference

CADRasterImage Class
CADRasterImage Members
CADImport.RasterImage Namespace


CADRasterImage.LoadMetafile Method

Load metafile

Namespace: CADImport.RasterImage
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub LoadMetafile( _
   ByVal meta As Metafile _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void LoadMetafile(
   Metafile meta
)
This language is not supported or no code example is available.

Parameters

meta

Type: Metafile

Metafile data

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADRasterImage Class
CADRasterImage Members
CADImport.RasterImage Namespace


CADRasterImage Fields

CADRasterImage Class See Also

The following tables list the members exposed by the CADRasterImage type.

Fields
 | Name | Description
 | EntityBuffer | Represents buffer for CADEntityCollection storing. (inherited from CADImage).
Public field | visibleArea | Represents CADImage visible area. (inherited from CADImage).
Top
See Also

Reference

CADRasterImage Class
CADImport.RasterImage Namespace


CAD File Database

The structure of kernel CAD .NET classes is similar to Autodesk DXF structure. If you need to work with the structure of DWG or DXF drawings we suggest studying this format a little.

DXF files are standard ASCII text files. They are easily translated to other CAD system formats or are submitted to other programs for direct processing. A Drawing Interchange File is an ASCII text file with the .DXF file extension and specially formatted text. This is analogous to the ASCII .RTF (Rich Text Format) published by Microsoft for exchange of binary Word document (.DOC) files. The overall organization of a DXF file is as follows:

1. The HEADER section contains general information about the drawing. It consists of the drawing's database version number and the number of system variables. Each parameter contains a variable name and an associated value.

2.The CLASSES section holds the information for application defined classes, whose instances are in the BLOCKS, ENTITIES, and OBJECTS sections. A class definition is eminently fixed in the class hierarchy.

TABLES section—Contains definitions for the following symbol tables.

·Linetype table (LTYPE)

·Layer table (LAYER)

·Text style table (STYLE)

·View table (VIEW)

·User Coordinate System table (UCS)

·Viewport configuration table (VPORT)

·Dimension Style table (DIMSTYLE)

·Application Identification table (APPID)

·Block Record table (BLOCK_RECORD)

3.The BLOCKS section—Contains block definition and drawing entities that make up each block reference in the drawing.

4.The ENTITIES section—Contains the graphical objects (entities) in the drawing, including block references (insert entities).

5.The OBJECTS section—Contains the non - graphical objects in the drawing. All objects that are not entities or symbol table records or symbol tables are stored in this section. Examples of entries in the OBJECTS section are dictionaries that contain mline styles and groups.

6. A DXF file is composed of many groups, each of which occupies two lines in the DXF file. The first line is a group code. The second line is the group value, in a format that depends on the type of group specified by the group code.

For more information:

See AutoCAD™ DXF documentation: http://images.autodesk.com/adsk/files/autocad_2014_pdf_dxf_reference_enu.pdf


Scheme

© 2005-2019 Soft Gold Ltd.


Demos

CAD .NET package contains the following demo applications:

Add Entities

This demo shows how to add new entities to the drawing or how to create new drawings. These entities can also be saved to DXF, so this is the main demo for creating DXF and other CAD files. For export to DXF please also refer to the demo MefafileExport.

AspNet

The demo explains how to use CAD .NET for ASP.NET sites. Please refer to Web CAD SDK and ShareCAD.org for other CADSoftTools CAD SDKs for ASP.NET and html/javascript.

EditorControl

The demo shows how to use CAD .NET Editor Control.

Editor

The demo stores CAD Editor with possibilities to select entities, move, change properties, add, delete and others.

Getting Started

The demo is created with idea of HOW TO model. Each button refers to small number of code lines in one function, so it is easy to copy and paste it to another application.

Import

The demo explains how to access the drawing database. For instance, if you need to get all the entities with their properties please use this example.

MetafileExport

The demo gives an automatic way to create DXF /CGM / PLT and other CAD files. It is possible to "draw to DXF" like to "draw on canvas", metafile is used as temprorary format for this.

Polylines

The demo shows how to convert drawing entities to polylines and access polylines data.

Viewer

The demo shows basic viewer features: open, zoom, pan, change layers, print, save to raster, etc.

WFP

The demo describes how to use CAD .NET in WPF.


License

CAD .NET License Agreement and Limited Warranty

=================================

This Soft Gold License Agreement ("LICENSE AGREEMENT") is a legal agreement between you (either individual or an entity) and Soft Gold Limited ("SOFT GOLD") for CAD .NET Software ("SOFTWARE"). By installing, copying, accessing, or

otherwise using the SOFTWARE, you agree to be bound by the terms of this LICENSE AGREEMENT.

If you do not agree to the terms of this LICENSE AGREEMENT, you must cease using the SOFTWARE immediately.

1.OWNERSHIP

=========

All copyrights to SOFTWARE and everything that comes with it are exclusively owned by the author - SOFT GOLD, CADSoftTools trademark.

This SOFTWARE is protected by copyright laws and international copyright treaties. At all times SOFT GOLD retains

full title to the SOFTWARE. Subject to your acceptance of and accordance with the terms and conditions stated

in this LICENSE AGREEMENT, you shall be granted a SOFTWARE license. Any previous agreement with SOFT GOLD is superseded

by this LICENSE AGREEMENT.

2.UNREGISTERED VERSION

==================

You may distribute the unregistered version of SOFTWARE freely, provided that all files are included and remain unmodified

and that no extra files have been added to the package. You may not ask any money for the distribution.

You may use the unregistered version of SOFTWARE free of charge for testing purposes, but if you want to use it for

other purposes than testing - you have to register it with the author.

The unregistered version have some restrictions: Nagscreen, demo text when saving, copying and printing images.

3.GRANT OF LICENSE AND SCOPE OF USE

===========================

3.1. Grant of license.

Subject to the terms and conditions of this License, SOFT GOLD grants to you, if you are an individual, or, if you are

an entity, one (1) designated person in your organization ("Named Developer") a personal, nonexclusive, and limited license

to use the SOFTWARE solely to create your own application programs and other works ("Works").

You may install the SOFTWARE on a reasonable number of machines provided that the Named Developer is the only

individual permitted to use the SOFTWARE. Subject to the other terms and conditions of this License, you may distribute

your Works to others for production use. SOFT GOLD reserves the right to refuse granting a license without reasons

explanation. All rights not specifically granted to you herein are retained by SOFT GOLD.

3.2 Multiple Licensed Copies.

You may purchase from SOFT GOLD or its authorized reseller additional licenses to permit multiple Named Developers

to use the SOFTWARE (each, a "Named Developer License"). Such rights will be effective only when granted in writing

by SOFT GOLD or its authorized reseller and are conditioned upon your payment of the applicable fees.

If you purchase additional Named Developer Licenses for the SOFTWARE then you are granted for each Named Developer License

the personal, nonexclusive, nontransferable and limited license to designate one individual in your organization

as the Named Developer and permit such Named Developer to install and use the SOFTWARE solely as permitted under

Section 3.1. In such case, the SOFTWARE may be used exclusively by the specifically designated Named Developer,

subject to all the terms and conditions of this License. You agree that you will not designate more Named Developers

than the number of Named Developer Licenses that SOFT GOLD or its authorized reseller has expressly granted to you

and you will not allow the SOFTWARE to be used by any individuals other than the Named Developers designated by you

from time to time. You agree to maintain accurate records of the Named Developer designated by you to use

the SOFTWARE under each Named Developer License you hold.

3.3 Server licenses

3.3.1 On-Premises licenses

Subject to the terms and conditions of this License, SOFT GOLD grants to you, if you are an entity ("Licensee") a personal, nonexclusive and limited license, which allows to install and use the SOFTWARE on one (1) server or Web-server without end-users royalties. You may also make a reasonable number of copies of the SOFTWARE to backup devices such as hard disks, optical media, or tape and one (1) physical CD media backup copy of the SOFTWARE solely to replace the original copy provided to you if the original copy is damaged or destroyed. SOFT GOLD reserves the right to refuse granting a license without explanation of reasons. All rights not specifically granted to you herein are retained by SOFT GOLD.

The SOFTWARE may be used by all employees of Licensee at facilities governed by Licensee in connection with the server or Web-server. Licensee must use commercially reasonable efforts to restrict network or any other access to the SOFTWARE by anyone outside of Licensee's facilities who is not authorized to use the SOFTWARE.

3.3.2 Web-licenses

Terms and conditions of granting a web-license shall be discussed with SOFT GOLD.

3.3.3 Cloud licenses

Terms and conditions of granting a cloud license shall be discussed with SOFT GOLD.

3.4 Special licenses

If necessary Soft Gold Ltd is entitled to grant you a special license which conditions are preliminarily discussed by the parties and don’t contradict conditions of standard license.

4.DISCLAIMER OF WARRANTY

===================

THIS SOFTWARE AND THE ACCOMPANYING FILES ARE SOLD "AS IS" AND WITHOUT WARRANTIES AS TO PERFORMANCE OF MERCHANTABILITY

OR ANY OTHER WARRANTIES WHETHER EXPRESSED OR IMPLIED. BECAUSE OF THE VARIOUS HARDWARE AND SOFTWARE ENVIRONMENTS INTO

WHICH SOFTWARE MAY BE PUT, NO WARRANTY OF FITNESS FOR A PARTICULAR PURPOSE IS OFFERED.YOU ASSUME THE WHOLE RISK

CONCERNING QUALITY AND WORK OF SOFTWARE.IF THE SOFTWARE PROVES TO BE DEFECTIVE YOU ASSUME COST OF ALL NECESSARY SERVICING,

REPAIR OR CORRECTION.

Good data processing procedure dictates that any program be thoroughly tested with non-critical data before relying on it.

The user must assume the entire risk of using the program.

You may not alter this software in any way, including changing or removing any windows.

5.AGREEMENT PERTAINING TO THE RELEASE OF SOURCE CODE

=========================================

5.1 Recipient WILL NOT distribute the source. Particularly this includes such files as .dcu, .dfm, .pas and others

which SOFTWARE has provided.

5.2 SOFT GOLD reserves the right to change any part of the source in future versions of the product.

These changes may include removal of classes, properties and methods or creation of new classes, properties and methods.

6. ENGAGING IN ANY OF THE ACTIVITIES LISTED BELOW WILL TERMINATE THE SOFTWARE LICENSE.

IN ADDITION TO SOFTWARE LICENSE TERMINATION, SOFTWARE MAY PURSUE CRIMINAL,CIVIL, OR ANY OTHER AVAILABLE REMEDIES.

=================================================================

6.1. Removal of proprietary notices, labels or marks from the SOFTWARE or SOFTWARE Documentation.

6.2. Utilize the SOFTWARE for the creation of products (whether it be freeware, shareware or a commercial product)

which competes directly or indirectly with software published at www.cadsofttools.com,

www.cadsofttools.ru, www.cadsofttools.de

6.3. Disclose the SOFTWARE to any person or party, involved in the creation of products which competes directly or

indirectly with software published at www.cadsofttools.com.

6.4. Violation of the section 5 of this LICENSE AGREEMENT

7. LIMITATIONS OF DAMAGES

===================

SOFT GOLD LTD SHALL NOT BE LIABLE FOR ANY INDIRECT, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES

(INCLUDING DAMAGES FOR LOSS OF BUSINESS, LOSS OF PROFITS, OR THE LIKE), WHETHER BASED ON BREACH OF CONTRACT,

TORT (INCLUDING NEGLIGENCE), PRODUCT LIABILITY OR OTHERWISE, EVEN IF SOFT GOLD LTD OR ITS REPRESENTATIVES

HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES AND EVEN IF A REMEDY SET FORTH HEREIN IS FOUND TO HAVE FAILED

OF ITS ESSENTIAL PURPOSE.

Thank you for using CAD .NET!

====================

Soft Gold Ltd., 2019

Address:

Russia, 300057 Tula, Malye Gonchary 14.

Tel: +1 (800) 469-9789

World Wide Web: http://www.cadsofttools.com

E-mail: info@cadsofttools.com


Contacts

Address: Russia, 300057 Tula, Malye Gonchary 14

Tel: +1 (800) 469-9789

World Wide Web: http://www.cadsofttools.com

Email: info@cadsofttools.com

Support: support@cadsofttools.com


CAD2DPoint Constructor (Double, Double)

Initializes a new CAD2DPoint with the specified coordinates.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal X As Double, _
   ByVal Y As Double _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CAD2DPoint(
   double X,
   double Y
)
This language is not supported or no code example is available.

Parameters

X

Type: double

X-coordinate of the CAD2DPoint object.

Y

Type: double

Y-coordinate of the CAD2DPoint object.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPoint Structure
CAD2DPoint Members


CAD2DPoint Constructor (DPoint)

Initializes a new CAD2DPoint using the the specified DPoint.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal p As DPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CAD2DPoint(
   DPoint p
)
This language is not supported or no code example is available.

Parameters

p

Type: DPoint

A 3D point that will provide X and Y coordinates for created 2D point.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPoint Structure
CAD2DPoint Members


CAD2DPoint.Multiply (CAD2DPoint, Double) Operator

Multiplies both coordinates of the CAD2DPoint with a double value.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Operator *( _
   ByVal p1 As CAD2DPoint, _
   ByVal aVal As Double _
) As CAD2DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static CAD2DPoint operator *(
   CAD2DPoint p1,
   double aVal
)
This language is not supported or no code example is available.

Parameters

p1

Type: CAD2DPoint

A CAD2DPoint that specifies initial coordinates.

aVal

Type: double

A double multiplier.

Return Value

A resulting CAD2DPoint object
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPoint Structure
CAD2DPoint Members


DXFText Constructor

Initializes a new instance of the DXFText class.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFText()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFText Class
DXFText Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFText Constructor (DXFData)

Initializes a new instance of the DXFText class that have field data copied from the specified object.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal aData As DXFData _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFText(
   DXFData aData
)
This language is not supported or no code example is available.

Parameters

aData

Type: DXFData

DXFData object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFText Class
DXFText Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFFigure Constructor

Initializes a new instance of the DXFFigure object.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFFigure()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFFigure Class
DXFFigure Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFFigure Constructor (DXFData)

Initializes a new instance of the DXFFigure object that have field data copied from specified object.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal dt As DXFData _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFFigure(
   DXFData dt
)
This language is not supported or no code example is available.

Parameters

dt

Type: DXFData

DXFData object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFFigure Class
DXFFigure Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFLine Constructor

Initializes a new instance of the DXFLine class.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFLine()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFLine Class
DXFLine Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFLine Constructor (DXFData)

Initializes a new instance of the DXFLine class that have field data copied from specified object.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal aData As DXFData _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFLine(
   DXFData aData
)
This language is not supported or no code example is available.

Parameters

aData

Type: DXFData

DXFLine object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFLine Class
DXFLine Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFPixel Constructor

Initializes a new instance of the DXFPixel class.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFPixel()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFPixel Class
DXFPixel Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFPixel Constructor (DXFData)

Initializes a new instance of the DXFPixel class that have field data copied from specified object.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal aData As DXFData _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFPixel(
   DXFData aData
)
This language is not supported or no code example is available.

Parameters

aData

Type: DXFData

DXFData object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFPixel Class
DXFPixel Members
CADImport.Export.SimpleCADtoDXF Namespace


CAD2DPoint.Multiply (CAD2DPoint, CADMatrix) Operator

Multiplies the CAD2DPoint with a matrix.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Operator *( _
   ByVal p As CAD2DPoint, _
   ByVal matrix As CADMatrix _
) As CAD2DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static CAD2DPoint operator *(
   CAD2DPoint p,
   CADMatrix matrix
)
This language is not supported or no code example is available.

Parameters

p

Type: CAD2DPoint

An initial CAD2DPoint

matrix

Type: CADMatrix

A matrix

Return Value

A resulting CAD2DPoint object
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DPoint Structure
CAD2DPoint Members


DXFSolid Constructor

Initializes a new instance of the DXFSolid class.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFSolid()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFSolid Class
DXFSolid Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFSolid Constructor (DXFData)

Initializes a new instance of the DXFSolid class that have field data copied from the specified object.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal aData As DXFData _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFSolid(
   DXFData aData
)
This language is not supported or no code example is available.

Parameters

aData

Type: DXFData

DXFData object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFSolid Class
DXFSolid Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFMText Constructor

Initializes a new instance of the DXFMText class.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFMText()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFMText Class
DXFMText Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFMText Constructor (DXFData)

Initializes a new instance of the DXFMText class that have field data copied from specified object.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal aData As DXFData _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFMText(
   DXFData aData
)
This language is not supported or no code example is available.

Parameters

aData

Type: DXFData

DXFData object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFMText Class
DXFMText Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFLayer Constructor

Initializes a new instance of the DXFLayer class.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFLayer()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFLayer Class
DXFLayer Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFLayer Constructor (String)

Initializes a new instance of the DXFLayer class with specified name and defaults parameters.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal aName As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFLayer(
   string aName
)
This language is not supported or no code example is available.

Parameters

aName

Type: string

Name of layer

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFLayer Class
DXFLayer Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFArc Constructor

Initializes a new instance of the DXFArc class.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFArc()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFArc Class
DXFArc Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFArc Constructor (DXFData)

Initializes a new instance of the DXFArc class that have field data copied from specified object.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal aData As DXFData _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFArc(
   DXFData aData
)
This language is not supported or no code example is available.

Parameters

aData

Type: DXFData

DXFData object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFArc Class
DXFArc Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFPolyline Constructor

Initializes a new instance of the DXFPolyBezier class.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFPolyline()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFPolyline Class
DXFPolyline Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFPolyline Constructor (DXFData, Int32)

Initializes a new instance of the DXFPolyBezier class that have field data copied from specified object.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal aData As DXFData, _
   ByVal aIndex As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFPolyline(
   DXFData aData,
   int aIndex
)
This language is not supported or no code example is available.

Parameters

aData

Type: DXFData

DXFData object

aIndex

Type: int

Data index

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFPolyline Class
DXFPolyline Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFRectangle Constructor

Initializes a new instance of the DXFRectangle class.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFRectangle()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFRectangle Class
DXFRectangle Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFRectangle Constructor (DXFData)

Initializes a new instance of the DXFRectangle class that have field data copied from the specified object.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal aData As DXFData _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFRectangle(
   DXFData aData
)
This language is not supported or no code example is available.

Parameters

aData

Type: DXFData

DXFData object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFRectangle Class
DXFRectangle Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFEllipse Constructor

Initializes a new instance of the DXFEllipse class.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFEllipse()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFEllipse Class
DXFEllipse Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFEllipse Constructor (DXFData, Boolean)

Initializes a new instance of the DXFEllipse class that have field data copied from the specified object.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal aData As DXFData, _
   ByVal aEllipse As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFEllipse(
   DXFData aData,
   bool aEllipse
)
This language is not supported or no code example is available.

Parameters

aData

Type: DXFData

The DXFData object

aEllipse

Type: bool

Specifies if entity is an ellipse

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFEllipse Class
DXFEllipse Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFPolyBezier Constructor

Initializes a new instance of the DXFPolyBezier class.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFPolyBezier()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFPolyBezier Class
DXFPolyBezier Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFPolyBezier Constructor (DXFData, Int32)

Initializes a new instance of the DXFPolyBezier class that have field data copied from specified object.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal aData As DXFData, _
   ByVal aIndex As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFPolyBezier(
   DXFData aData,
   int aIndex
)
This language is not supported or no code example is available.

Parameters

aData

Type: DXFData

DXFData object

aIndex

Type: int

index

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFPolyBezier Class
DXFPolyBezier Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFHatch Constructor

Initializes a new instance of the DXFHatch class.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFHatch()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFHatch Class
DXFHatch Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFHatch Constructor (DXFData)

Initializes a new instance of the DXFHatch class that have field data copied from specified object.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal aData As DXFData _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFHatch(
   DXFData aData
)
This language is not supported or no code example is available.

Parameters

aData

Type: DXFData

DXFData object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFHatch Class
DXFHatch Members
CADImport.Export.SimpleCADtoDXF Namespace


MultipleLanguage.LoadLNG (String) Method

Loads a specified file of the language support.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub LoadLNG( _
   ByVal aName As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void LoadLNG(
   string aName
)
This language is not supported or no code example is available.

Parameters

aName

Type: string

A string containing a name of the language support file.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultipleLanguage Class
MultipleLanguage Members
CADImport.FaceModule Namespace


MultipleLanguage.LoadLNG (Stream, String) Method

Loads a specified file of the language support.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub LoadLNG( _
   ByVal aFile As Stream, _
   ByVal aName As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void LoadLNG(
   Stream aFile,
   string aName
)
This language is not supported or no code example is available.

Parameters

aFile

Type: Stream

A Stream containing the language support file.

aName

Type: string

A string containing a name of the language support file.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultipleLanguage Class
MultipleLanguage Members
CADImport.FaceModule Namespace


LayerChangedEventArgs Constructor (CADLayer, Int32)

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal l As CADLayer, _
   ByVal index As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public LayerChangedEventArgs(
   CADLayer l,
   int index
)
This language is not supported or no code example is available.

Parameters

l

Type: CADLayer

index

Type: int

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LayerChangedEventArgs Class
LayerChangedEventArgs Members
CADImport.CADImportForms Namespace


LayerChangedEventArgs Constructor

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public LayerChangedEventArgs()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LayerChangedEventArgs Class
LayerChangedEventArgs Members
CADImport.CADImportForms Namespace


MetaForm Constructor

Initializes a new instance of the MetaForm class.

Namespace: CADImport.Export.MetaExport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public MetaForm()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


MetaForm Constructor (EmfType)

Initializes a new instance of the MetaForm class.

Namespace: CADImport.Export.MetaExport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal mfType As EmfType _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public MetaForm(
   EmfType mfType
)
This language is not supported or no code example is available.

Parameters

mfType

Type: EmfType

Type of the Initializes a new instance of the MetaForm object.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


MetaForm Constructor (String, Int32, Int32)

Initializes a new instance of the MetaForm class.

Namespace: CADImport.Export.MetaExport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal name As String, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public MetaForm(
   string name,
   int width,
   int height
)
This language is not supported or no code example is available.

Parameters

name

Type: string

A name of the Initializes a new instance of the MetaForm object.

width

Type: int

A width of the Initializes a new instance of the MetaForm object.

height

Type: int

A height of the Initializes a new instance of the MetaForm object.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


MetaForm Constructor (String, Int32, Int32, EmfType)

Initializes a new instance of the MetaForm class.

Namespace: CADImport.Export.MetaExport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal name As String, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal emfType As EmfType _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public MetaForm(
   string name,
   int width,
   int height,
   EmfType emfType
)
This language is not supported or no code example is available.

Parameters

name

Type: string

A name of the Initializes a new instance of the MetaForm object.

width

Type: int

A width of the Initializes a new instance of the MetaForm object.

height

Type: int

A height of the Initializes a new instance of the MetaForm object.

emfType

Type: EmfType

Type of the Initializes a new instance of the MetaForm object.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


MetaForm.RemoveDrawMetaFormToOnPaint (Control) Method

Removes an instance of the PaintEventHandler delegate from the Paint event of a specified Control.

Namespace: CADImport.Export.MetaExport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub RemoveDrawMetaFormToOnPaint( _
   ByVal control As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void RemoveDrawMetaFormToOnPaint(
   Control control
)
This language is not supported or no code example is available.

Parameters

control

Type: Control

A Control.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


MetaForm.RemoveDrawMetaFormToOnPaint (Form) Method

Removes an instance of the PaintEventHandler delegate from the Paint event of a specified Form.

Namespace: CADImport.Export.MetaExport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub RemoveDrawMetaFormToOnPaint( _
   ByVal control As Form _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void RemoveDrawMetaFormToOnPaint(
   Form control
)
This language is not supported or no code example is available.

Parameters

control

Type: Form

A Form.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


MetaForm.AddDrawMetaFormToOnPaint (Control) Method

Adds an instance of the PaintEventHandler delegate to the Paint event of a specified Control.

Namespace: CADImport.Export.MetaExport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddDrawMetaFormToOnPaint( _
   ByVal control As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddDrawMetaFormToOnPaint(
   Control control
)
This language is not supported or no code example is available.

Parameters

control

Type: Control

A Control.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


MetaForm.AddDrawMetaFormToOnPaint (Form) Method

Adds an instance of the PaintEventHandler delegate to the Paint event of a specified Form.

Namespace: CADImport.Export.MetaExport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddDrawMetaFormToOnPaint( _
   ByVal control As Form _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddDrawMetaFormToOnPaint(
   Form control
)
This language is not supported or no code example is available.

Parameters

control

Type: Form

A Form.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


MetaForm.SplitingToStream (StringWriter) Method

Saves a graphic metafile to a specified stream.

Namespace: CADImport.Export.MetaExport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function SplitingToStream( _
   ByVal stream As StringWriter _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool SplitingToStream(
   StringWriter stream
)
This language is not supported or no code example is available.

Parameters

stream

Type: StringWriter

A stream where a graphic metafile is saved to.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


MetaForm.SplitingToStream (StringWriter, Single) Method

Saves a graphic metafile to a specified stream.

Namespace: CADImport.Export.MetaExport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function SplitingToStream( _
   ByVal stream As StringWriter, _
   ByVal unitSize As Single _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool SplitingToStream(
   StringWriter stream,
   float unitSize
)
This language is not supported or no code example is available.

Parameters

stream

Type: StringWriter

A stream where a graphic metafile is saved to.

unitSize

Type: float

A unit size for the export.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


MetaForm.ConvertToDXF Method

Converts a graphic metafile to DXF image.

Namespace: CADImport.Export.MetaExport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function ConvertToDXF() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool ConvertToDXF()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


MetaForm.ConvertToDXF (String) Method

Converts a graphic metafile to a specified DXF file.

Namespace: CADImport.Export.MetaExport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function ConvertToDXF( _
   ByVal FileName As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool ConvertToDXF(
   string FileName
)
This language is not supported or no code example is available.

Parameters

FileName

Type: string

A name of the output DXF file.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


MetaForm.ConvertToDXF (String, Single) Method

Converts a graphic metafile to a specified DXF file.

Namespace: CADImport.Export.MetaExport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function ConvertToDXF( _
   ByVal FileName As String, _
   ByVal unitSize As Single _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool ConvertToDXF(
   string FileName,
   float unitSize
)
This language is not supported or no code example is available.

Parameters

FileName

Type: string

A name of the output DXF file.

unitSize

Type: float

A unit size for the export.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


MetaForm.ConvertToDXF (String, String) Method

Converts a specified graphic metafile to a specified DXF file.

Namespace: CADImport.Export.MetaExport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function ConvertToDXF( _
   ByVal fromFile As String, _
   ByVal outFileName As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool ConvertToDXF(
   string fromFile,
   string outFileName
)
This language is not supported or no code example is available.

Parameters

fromFile

Type: string

A name of the input graphic metafile.

outFileName

Type: string

A name of the output DXF file.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


MetaForm.ConvertToDXF (String, String, Single) Method

Converts a specified graphic metafile to a specified DXF file.

Namespace: CADImport.Export.MetaExport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function ConvertToDXF( _
   ByVal fromFile As String, _
   ByVal outFileName As String, _
   ByVal unitSize As Single _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool ConvertToDXF(
   string fromFile,
   string outFileName,
   float unitSize
)
This language is not supported or no code example is available.

Parameters

fromFile

Type: string

A name of the input graphic metafile.

outFileName

Type: string

A name of the output DXF file.

unitSize

Type: float

A unit size for the export.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MetaForm Class
MetaForm Members
CADImport.Export.MetaExport Namespace


Point3D Constructor (DPoint)

Initializes a new instance of the Point3D class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal val As DPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Point3D(
   DPoint val
)
This language is not supported or no code example is available.

Parameters

val

Type: DPoint

A DPoint whose coordinates are displayed in the properties window.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Point3D Class
Point3D Members


Point3D Constructor

Initializes a new instance of the Point3D class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public Point3D()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Point3D Class
Point3D Members


ColorTypeConverter.GetStandardValuesExclusive Method

Overloaded. Returns a value indicating that a collection returned by the GetStandardValues method is not an exclusive list.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function GetStandardValuesExclusive( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool GetStandardValuesExclusive(
   ITypeDescriptorContext context
)
This language is not supported or no code example is available.

Parameters

context

Type: ITypeDescriptorContext

An ITypeDescriptorContext that provides a format context.

Return Value

false.
Remarks

If the list is exclusive, such as in an enumeration data type, then no other values are valid. If the list is not exclusive, then other valid values might exist in addition to the list of standard values that GetStandardValues provides.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ColorTypeConverter Class
ColorTypeConverter Members


LineWeightConverter.GetStandardValuesSupported Method

Overloaded. Returns a value indicating that LineWeightTypeConverter supports standard values.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function GetStandardValuesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool GetStandardValuesSupported(
   ITypeDescriptorContext context
)
This language is not supported or no code example is available.

Parameters

context

Type: ITypeDescriptorContext

An ITypeDescriptorContext that provides a format context.

Return Value

true.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LineWeightConverter Class
LineWeightConverter Members


LineWeightConverter.GetStandardValues Method

Overloaded. Returns a collection of standard lineweight values.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function GetStandardValues( _
   ByVal context As ITypeDescriptorContext _
) As StandardValuesCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override StandardValuesCollection GetStandardValues(
   ITypeDescriptorContext context
)
This language is not supported or no code example is available.

Parameters

context

Type: ITypeDescriptorContext

An ITypeDescriptorContext that provides a format context.

Return Value

A StandardValuesCollection that holds a standard set of valid values: Default, ByLayer, ByBlock, .
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LineWeightConverter Class
LineWeightConverter Members


LineWeightConverter.GetStandardValuesExclusive Method

Overloaded. Returns a value indicating that a collection returned by the GetStandardValues method is not an exclusive list.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function GetStandardValuesExclusive( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool GetStandardValuesExclusive(
   ITypeDescriptorContext context
)
This language is not supported or no code example is available.

Parameters

context

Type: ITypeDescriptorContext

An ITypeDescriptorContext that provides a format context.

Return Value

false.
Remarks

If the list is exclusive, such as in an enumeration data type, then no other values are valid. If the list is not exclusive, then other valid values might exist in addition to the list of standard values that GetStandardValues provides.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LineWeightConverter Class
LineWeightConverter Members


LayerConverter.GetStandardValuesSupported Method

Overloaded. Returns a value indicating that LayerConverter supports standard values.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function GetStandardValuesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool GetStandardValuesSupported(
   ITypeDescriptorContext context
)
This language is not supported or no code example is available.

Parameters

context

Type: ITypeDescriptorContext

An ITypeDescriptorContext that provides a format context.

Return Value

true.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LayerConverter Class
LayerConverter Members


LayerConverter.GetStandardValues Method

Overloaded. Returns a collection of standard layer values.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function GetStandardValues( _
   ByVal context As ITypeDescriptorContext _
) As StandardValuesCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override StandardValuesCollection GetStandardValues(
   ITypeDescriptorContext context
)
This language is not supported or no code example is available.

Parameters

context

Type: ITypeDescriptorContext

An ITypeDescriptorContext that provides a format context.

Return Value

A StandardValuesCollection that holds a set of valid layers loaded from the current CAD image.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LayerConverter Class
LayerConverter Members


LayerConverter.GetStandardValuesExclusive Method

Overloaded. Returns a value indicating that a collection returned by the GetStandardValues method is not an exclusive list.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function GetStandardValuesExclusive( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool GetStandardValuesExclusive(
   ITypeDescriptorContext context
)
This language is not supported or no code example is available.

Parameters

context

Type: ITypeDescriptorContext

An ITypeDescriptorContext that provides a format context.

Return Value

false.
Remarks

If the list is exclusive, such as in an enumeration data type, then no other values are valid. If the list is not exclusive, then other valid values might exist in addition to the list of standard values that GetStandardValues provides.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LayerConverter Class
LayerConverter Members


ColorTypeConverter.GetStandardValuesSupported Method

Overloaded. Returns a value indicating that ColorTypeConverter supports standard values.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function GetStandardValuesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool GetStandardValuesSupported(
   ITypeDescriptorContext context
)
This language is not supported or no code example is available.

Parameters

context

Type: ITypeDescriptorContext

An ITypeDescriptorContext that provides a format context.

Return Value

true.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ColorTypeConverter Class
ColorTypeConverter Members


Protection.Register (String, String, String, Boolean) Method

Realizes the registration process.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function Register( _
   ByVal name As String, _
   ByVal mail As String, _
   ByVal key As String, _
   ByVal addToReg As Boolean _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool Register(
   string name,
   string mail,
   string key,
   bool addToReg
)
This language is not supported or no code example is available.

Parameters

name

Type: string

The string containing the licensee name.

mail

Type: string

The string containing the licensee e-mail address.

key

Type: string

The string containing the registration key.

addToReg

Type: bool

The boolean value indicating if the registration data is added to the registry. true if the registration data is added to the registry; otherwise, false.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Protection Class
Protection Members


ColorTypeConverter.GetStandardValues Method

Overloaded. Returns a collection of standard color values.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function GetStandardValues( _
   ByVal context As ITypeDescriptorContext _
) As StandardValuesCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override StandardValuesCollection GetStandardValues(
   ITypeDescriptorContext context
)
This language is not supported or no code example is available.

Parameters

context

Type: ITypeDescriptorContext

An ITypeDescriptorContext that provides a format context.

Return Value

A StandardValuesCollection that holds a standard set of valid values: ByValue, ByLayer, ByBlock, None.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ColorTypeConverter Class
ColorTypeConverter Members


LineTypeConverter.GetStandardValuesSupported Method

Overloaded. Returns a value indicating that LineTypeConverter supports standard values.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function GetStandardValuesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool GetStandardValuesSupported(
   ITypeDescriptorContext context
)
This language is not supported or no code example is available.

Parameters

context

Type: ITypeDescriptorContext

An ITypeDescriptorContext that provides a format context.

Return Value

true.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LineTypeConverter Class
LineTypeConverter Members


LineTypeConverter.GetStandardValues Method

Overloaded. Returns a collection of standard linetype values.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function GetStandardValues( _
   ByVal context As ITypeDescriptorContext _
) As StandardValuesCollection
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override StandardValuesCollection GetStandardValues(
   ITypeDescriptorContext context
)
This language is not supported or no code example is available.

Parameters

context

Type: ITypeDescriptorContext

An ITypeDescriptorContext that provides a format context.

Return Value

A StandardValuesCollection that holds a standard set of valid values: ByLayer, ByBlock.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LineTypeConverter Class
LineTypeConverter Members


LineTypeConverter.GetStandardValuesExclusive Method

Overloaded. Returns a value indicating that a collection returned by the GetStandardValues method is not an exclusive list.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function GetStandardValuesExclusive( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool GetStandardValuesExclusive(
   ITypeDescriptorContext context
)
This language is not supported or no code example is available.

Parameters

context

Type: ITypeDescriptorContext

An ITypeDescriptorContext that provides a format context.

Return Value

false.
Remarks

If the list is exclusive, such as in an enumeration data type, then no other values are valid. If the list is not exclusive, then other valid values might exist in addition to the list of standard values that GetStandardValues provides.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LineTypeConverter Class
LineTypeConverter Members


Protection.Register (String, ArrayList, Boolean) Method

Realizes the registration process.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function Register( _
   ByVal val As String, _
   ByVal regData As ArrayList, _
   ByVal addToReg As Boolean _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool Register(
   string val,
   ArrayList regData,
   bool addToReg
)
This language is not supported or no code example is available.

Parameters

val

Type: string

The string containing the registration key.

regData

Type: ArrayList

A set of registration data.

addToReg

Type: bool

The boolean value indicating if the registration data is added to the registry. true if the registration data is added to the registry; otherwise, false.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Protection Class
Protection Members


Protection.Register (IWin32Window) Method

Realizes the registration process using the registration form.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub Register( _
   ByVal form As IWin32Window _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void Register(
   IWin32Window form
)
This language is not supported or no code example is available.

Parameters

form

Type: IWin32Window

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Protection Class
Protection Members


IArrayPoints.PointsCount Method

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Function PointsCount() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
int PointsCount()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference


CADSelector.DoSelectEntities (SortedList) Method

Selects inserted list of entities

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DoSelectEntities( _
   ByVal lst As SortedList _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DoSelectEntities(
   SortedList lst
)
This language is not supported or no code example is available.

Parameters

lst

Type: SortedList

Inserting list of entities

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSelector Class
CADSelector Members


CADSelector.DoSelectEntities (CADEntityCollection) Method

Selects inserted list of entities

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DoSelectEntities( _
   ByVal lst As CADEntityCollection _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DoSelectEntities(
   CADEntityCollection lst
)
This language is not supported or no code example is available.

Parameters

lst

Type: CADEntityCollection

Inserting list of entities

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADSelector Class
CADSelector Members


IArrayPoints.GetPoint Method

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Function GetPoint( _
   ByVal index As Integer _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
DPoint GetPoint(
   int index
)
This language is not supported or no code example is available.

Parameters

index

Type: int

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference


IArrayPoints.Equal Method

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Function Equal( _
   ByVal index As Integer _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
bool Equal(
   int index
)
This language is not supported or no code example is available.

Parameters

index

Type: int

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference


CADCollection<T>.ToArray Method

Creates an array from the current CADCollection<T> object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function ToArray( _
   ByVal count As Integer _
) As T()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public T[] ToArray(
   int count
)
This language is not supported or no code example is available.

Parameters

count

Type: int

Members count

Return Value

The created array
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCollection<T> Class
CADCollection<T> Members


CADCollection<T> Constructor

Initializes a new instance of the CADCollection<T> Generic class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCollection<T> Class
CADCollection<T> Members


CADCollection<T> Constructor (Int32)

Initializes a new instance of the CADCollection<T> Generic class that is empty and has the specified initial capacity.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal count As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection(
   int count
)
This language is not supported or no code example is available.

Parameters

count

Type: int

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCollection<T> Class
CADCollection<T> Members


CADCollection<T> Constructor (IEnumerable<T>)

Initializes a new instance of the CADCollection<T> Generic class that contains elements copied from the specified collection and has sufficient capacity to accommodate the number of elements copied.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal arr As IEnumerable(Of T) _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADCollection(
   IEnumerable<T> arr
)
This language is not supported or no code example is available.

Parameters

arr

Type: IEnumerable<T>

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADCollection<T> Class
CADCollection<T> Members


DynamicArray<T> Constructor (Int32)

Initializes a new instance of the DynamicArray<T> class

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal capacity As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DynamicArray(
   int capacity
)
This language is not supported or no code example is available.

Parameters

capacity

Type: int

Capacity of the created DynamicArray<T> object.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DynamicArray<T> Class
DynamicArray<T> Members


DynamicArray<T> Constructor

Initializes a new instance of the DynamicArray<T> class

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DynamicArray()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DynamicArray<T> Class
DynamicArray<T> Members


CADGraphicsOpenGL.SaveToStream (Stream, ImageFormat, DRect, Rectangle) Method

Writes a specified part of the current CAD image to the clipboard as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub SaveToStream( _
   ByVal str As Stream, _
   ByVal ImgFormat As ImageFormat, _
   ByVal aCurRect As DRect, _
   ByVal clipRect As Rectangle _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void SaveToStream(
   Stream str,
   ImageFormat ImgFormat,
   DRect aCurRect,
   Rectangle clipRect
)
This language is not supported or no code example is available.

Parameters

str

Type: Stream

A stream, where the image is saved

ImgFormat

Type: ImageFormat

A ImageFormat object specifying a format of the file to save.

aCurRect

Type: DRect

A curRect object specifying a size of the current CADImage.

clipRect

Type: Rectangle

A Rectangle object that specifies a part of the current CAD image to be written to the clipboard.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.Draw Method

Draws a CADImage.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Draw( _
   ByVal e As Graphics, _
   ByVal Rect As RectangleF, _
   ByVal visibleRegion As Region _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Draw(
   Graphics e,
   RectangleF Rect,
   Region visibleRegion
)
This language is not supported or no code example is available.

Parameters

e

Type: Graphics

A Graphics surface on which to draw the CAD image.

Rect

Type: RectangleF

A RectangleF object representing an area of the CAD image.

visibleRegion

Type: Region

Region of visible

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.ExportToMetafile (String, DRect) Method

Exports a CAD drawing to Windows Enhanced metafile.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub ExportToMetafile( _
   ByVal aName As String, _
   ByVal aCurRect As DRect _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void ExportToMetafile(
   string aName,
   DRect aCurRect
)
This language is not supported or no code example is available.

Parameters

aName

Type: string

A path to a newly created metafile.

aCurRect

Type: DRect

A DRect object specifying a size of the CADImage.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.ExportToMetafile (String, DRect, Rectangle) Method

Exports a CAD drawing to Windows Enhanced metafile.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub ExportToMetafile( _
   ByVal aName As String, _
   ByVal aCurRect As DRect, _
   ByVal clipRect As Rectangle _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void ExportToMetafile(
   string aName,
   DRect aCurRect,
   Rectangle clipRect
)
This language is not supported or no code example is available.

Parameters

aName

Type: string

A path to a newly created metafile.

aCurRect

Type: DRect

A DRect object specifying a size of the CADImage.

clipRect

Type: Rectangle

A Rectangle object that specifies a part of the current CAD image to be saved.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.ExportToMetafile (String, DRect, Rectangle, Boolean) Method

Exports a CAD drawing to Windows Enhanced metafile.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub ExportToMetafile( _
   ByVal aName As String, _
   ByVal aCurRect As DRect, _
   ByVal clipRect As Rectangle, _
   ByVal callGetExtents As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void ExportToMetafile(
   string aName,
   DRect aCurRect,
   Rectangle clipRect,
   bool callGetExtents
)
This language is not supported or no code example is available.

Parameters

aName

Type: string

A path to a newly created metafile.

aCurRect

Type: DRect

A DRect object specifying a size of the CADImage.

clipRect

Type: Rectangle

A Rectangle object that specifies a part of the current CAD image to be saved.

callGetExtents

Type: bool

If true call GetExtents method

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.SaveToStream (Stream, ImageFormat, DRect) Method

Writes a visible part of the current CAD image to the specified stream as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub SaveToStream( _
   ByVal aSt As Stream, _
   ByVal ImgFormat As ImageFormat, _
   ByVal curRect As DRect _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void SaveToStream(
   Stream aSt,
   ImageFormat ImgFormat,
   DRect curRect
)
This language is not supported or no code example is available.

Parameters

aSt

Type: Stream

A stream which the image is saved to.

ImgFormat

Type: ImageFormat

A ImageFormat object specifying a format of the file to save.

curRect

Type: DRect

A DRect object specifying a size of the CADImage.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.SaveToStream (Stream, ImageFormat, DRect, PixelFormat) Method

Writes a visible part of the current CAD image to the specified stream as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub SaveToStream( _
   ByVal aSt As Stream, _
   ByVal ImgFormat As ImageFormat, _
   ByVal curRect As DRect, _
   ByVal pixelFormat As PixelFormat _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void SaveToStream(
   Stream aSt,
   ImageFormat ImgFormat,
   DRect curRect,
   PixelFormat pixelFormat
)
This language is not supported or no code example is available.

Parameters

aSt

Type: Stream

A stream which the image is saved to.

ImgFormat

Type: ImageFormat

A ImageFormat object specifying a format of the file to save.

curRect

Type: DRect

A DRect object specifying a size of the CADImage.

pixelFormat

Type: PixelFormat

PixelFormat of image

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.SaveImageToClipboard (DRect) Method

Writes a visible part of the current CAD image to the clipboard as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub SaveImageToClipboard( _
   ByVal curRect As DRect _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void SaveImageToClipboard(
   DRect curRect
)
This language is not supported or no code example is available.

Parameters

curRect

Type: DRect

A DRect object specifying a size of the CADImage.

Remarks

This method works only for windows application.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.SaveImageToClipboard (DRect, PixelFormat) Method

Writes a visible part of the current CAD image to the clipboard as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub SaveImageToClipboard( _
   ByVal curRect As DRect, _
   ByVal pixelFormat As PixelFormat _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void SaveImageToClipboard(
   DRect curRect,
   PixelFormat pixelFormat
)
This language is not supported or no code example is available.

Parameters

curRect

Type: DRect

A DRect object specifying a size of the CADImage.

pixelFormat

Type: PixelFormat

PixelFormat of image

Remarks

This method works only for windows application.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.SaveImageToClipboard (DRect, Rectangle) Method

Writes a specified part of the current CAD image to the clipboard as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub SaveImageToClipboard( _
   ByVal curRect As DRect, _
   ByVal clipRect As Rectangle _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void SaveImageToClipboard(
   DRect curRect,
   Rectangle clipRect
)
This language is not supported or no code example is available.

Parameters

curRect

Type: DRect

A curRect object specifying a size of the current CADImage.

clipRect

Type: Rectangle

A Rectangle object that specifies a part of the current CAD image to be written to the clipboard.

Remarks

This method works only for windows application.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.SaveImageToClipboard (DRect, Rectangle, PixelFormat) Method

Writes a specified part of the current CAD image to the clipboard as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub SaveImageToClipboard( _
   ByVal curRect As DRect, _
   ByVal clipRect As Rectangle, _
   ByVal pixelFormat As PixelFormat _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void SaveImageToClipboard(
   DRect curRect,
   Rectangle clipRect,
   PixelFormat pixelFormat
)
This language is not supported or no code example is available.

Parameters

curRect

Type: DRect

A curRect object specifying a size of the current CADImage.

clipRect

Type: Rectangle

A Rectangle object that specifies a part of the current CAD image to be written to the clipboard.

pixelFormat

Type: PixelFormat

PixelFormat of image

Remarks

This method works only for windows application.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.SaveToFile (String, ImageFormat, DRect, RectangleF, Graphics) Method

Writes a visible part of the current CAD image to the disk as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub SaveToFile( _
   ByVal FileName As String, _
   ByVal ImgFormat As ImageFormat, _
   ByVal curRect As DRect, _
   ByVal rect As RectangleF, _
   ByVal e As Graphics _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void SaveToFile(
   string FileName,
   ImageFormat ImgFormat,
   DRect curRect,
   RectangleF rect,
   Graphics e
)
This language is not supported or no code example is available.

Parameters

FileName

Type: string

A location on the disk where to save the image.

ImgFormat

Type: ImageFormat

A ImageFormat object specifying a format of the file to save.

curRect

Type: DRect

A DRect object specifying a size of the CADImage.

rect

Type: RectangleF

e

Type: Graphics

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.SaveToFile (String, ImageFormat, DRect, PixelFormat, RectangleF, Graphics) Method

Writes a visible part of the current CAD image to the disk as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub SaveToFile( _
   ByVal FileName As String, _
   ByVal ImgFormat As ImageFormat, _
   ByVal curRect As DRect, _
   ByVal pixelFormat As PixelFormat, _
   ByVal rect As RectangleF, _
   ByVal e As Graphics _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void SaveToFile(
   string FileName,
   ImageFormat ImgFormat,
   DRect curRect,
   PixelFormat pixelFormat,
   RectangleF rect,
   Graphics e
)
This language is not supported or no code example is available.

Parameters

FileName

Type: string

A location on the disk where to save the image.

ImgFormat

Type: ImageFormat

A ImageFormat object specifying a format of the file to save.

curRect

Type: DRect

A DRect object specifying a size of the CADImage.

pixelFormat

Type: PixelFormat

PixelFormat of image

rect

Type: RectangleF

e

Type: Graphics

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.DrawString Method

Draws a text string.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub DrawString( _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal color As Integer, _
   ByVal point As Vector3d, _
   ByVal align As CADTextHorizontalAlign _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void DrawString(
   string text,
   Font font,
   int color,
   Vector3d point,
   CADTextHorizontalAlign align
)
This language is not supported or no code example is available.

Parameters

text

Type: string

A text

font

Type: Font

A text font

color

Type: int

A text color

point

Type: Vector3d

A location point of the text.

align

Type: CADTextHorizontalAlign

A text alignment.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.DrawPolyPolyLine Method

Draws a set of lines or a set of polygons

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub DrawPolyPolyLine( _
   ByVal intPoints As Vector3d(), _
   ByVal counts As Integer(), _
   ByVal allClosed As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void DrawPolyPolyLine(
   Vector3d[] intPoints,
   int[] counts,
   bool allClosed
)
This language is not supported or no code example is available.

Parameters

intPoints

Type: Vector3d[]

The set of points for visualization

counts

Type: int[]

A list of point numbers for figures.

allClosed

Type: bool

A value specifying if visualized figures will be closed

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.DrawPolyline Method

Draws a polyline

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub DrawPolyline( _
   ByVal points As Vector3d(), _
   ByVal closed As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void DrawPolyline(
   Vector3d[] points,
   bool closed
)
This language is not supported or no code example is available.

Parameters

points

Type: Vector3d[]

A list of polyline vertex points

closed

Type: bool

A value specifying if polyline is closed

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.FillPolyPolyLine Method

Draws a filled polygons.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub FillPolyPolyLine( _
   ByVal intPoints As Vector3d(), _
   ByVal counts As Integer() _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void FillPolyPolyLine(
   Vector3d[] intPoints,
   int[] counts
)
This language is not supported or no code example is available.

Parameters

intPoints

Type: Vector3d[]

The set of points for visualization

counts

Type: int[]

A list of point numbers for figures.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.Add_T Method

Performs addition of two 3D vector points.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function Add_T( _
   ByVal p1 As Vector3d, _
   ByVal p2 As Vector3d _
) As Vector3d
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override Vector3d Add_T(
   Vector3d p1,
   Vector3d p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: Vector3d

The first vector point

p2

Type: Vector3d

The second vector point

Return Value

The resulting vector point
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.Sub_T Method

Performs substraction of two 3D vector points.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function Sub_T( _
   ByVal p1 As Vector3d, _
   ByVal p2 As Vector3d _
) As Vector3d
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override Vector3d Sub_T(
   Vector3d p1,
   Vector3d p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: Vector3d

The first vector point

p2

Type: Vector3d

The second vector point

Return Value

The resulting vector point
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.IsEqual_T Method

Checks if two 3D vector points are equal.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function IsEqual_T( _
   ByVal p1 As Vector3d, _
   ByVal p2 As Vector3d _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool IsEqual_T(
   Vector3d p1,
   Vector3d p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: Vector3d

The first vector point

p2

Type: Vector3d

The second vector point

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADImage.DoSelectEntities (SortedList) Method

Selects inserted list of entities

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DoSelectEntities( _
   ByVal lst As SortedList _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DoSelectEntities(
   SortedList lst
)
This language is not supported or no code example is available.

Parameters

lst

Type: SortedList

Inserting list of entities

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.DoSelectEntities (CADEntityCollection) Method

Selects inserted list of entities

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DoSelectEntities( _
   ByVal lst As CADEntityCollection _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DoSelectEntities(
   CADEntityCollection lst
)
This language is not supported or no code example is available.

Parameters

lst

Type: CADEntityCollection

Inserting list of entities

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


DRect.Expand (DPoint) Method

Expands the DRect object up to the specified point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Expand( _
   ByVal p As DPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Expand(
   DPoint p
)
This language is not supported or no code example is available.

Parameters

p

Type: DPoint

A DPoint that defines a new extent of the DRect object.

Remarks

<p>The specified point defines only two-dimensional expansion.</p> <p>The specified point will be part of the expanded parallelepiped.</p>

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.Expand (PointF) Method

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Expand( _
   ByVal p As PointF _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Expand(
   PointF p
)
This language is not supported or no code example is available.

Parameters

p

Type: PointF

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.Intersect (DRect, CADMatrix) Method

Checks DRect and CADMatrix objects for intersection.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Intersect( _
   ByVal rect As DRect, _
   ByVal matrix As CADMatrix _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Intersect(
   DRect rect,
   CADMatrix matrix
)
This language is not supported or no code example is available.

Parameters

rect

Type: DRect

A DRect object

matrix

Type: CADMatrix

A CADMatrix object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.Intersect (DRect) Method

Checks DRect object for intersection

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Intersect( _
   ByVal rect As DRect _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int Intersect(
   DRect rect
)
This language is not supported or no code example is available.

Parameters

rect

Type: DRect

A DRect object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.Equality (DRect, Rectangle) Operator

Checks if DRect object and Rectangle object are equal.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Operator =( _
   ByVal p1 As DRect, _
   ByVal p2 As Rectangle _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool operator ==(
   DRect p1,
   Rectangle p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: DRect

A DRect object.

p2

Type: Rectangle

A Rectangle object.

Remarks

Two 3D objects are equal if all six coordinates of the first object are equal to the corresponding coordinates of the second.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.Inequality (DRect, DRect) Operator

Checks if two DRect objects are unequal.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Operator <>( _
   ByVal p1 As DRect, _
   ByVal p2 As DRect _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool operator !=(
   DRect p1,
   DRect p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: DRect

A DRect object.

p2

Type: DRect

A DRect object.

Remarks

Two DRect objects are not equal if at least one coordinate of the first object is not equal to the corresponding coordinate of the second object.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.Inequality (Rectangle, DRect) Operator

Checks if Rectangle object and DRect object are unequal.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Operator <>( _
   ByVal p1 As Rectangle, _
   ByVal p2 As DRect _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool operator !=(
   Rectangle p1,
   DRect p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: Rectangle

A Rectangle object.

p2

Type: DRect

A DRect object.

Remarks

Two 3D objects are not equal if at least one coordinate of the first object is not equal to the corresponding coordinate of the second object.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.Inequality (DRect, Rectangle) Operator

Checks if DRect object and Rectangle object are unequal.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Operator <>( _
   ByVal p1 As DRect, _
   ByVal p2 As Rectangle _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool operator !=(
   DRect p1,
   Rectangle p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: DRect

A DRect object.

p2

Type: Rectangle

A Rectangle object.

Remarks

Two 3D objects are not equal if at least one coordinate of the first object is not equal to the corresponding coordinate of the second object.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


CADXRef Constructor

Initializes a new instance of the CADXRef class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADXRef()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADXRef Class
CADXRef Members


CADXRef Constructor (CADConverter)

Initializes a new instance of the CADXRef class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal AConverter As CADConverter _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADXRef(
   CADConverter AConverter
)
This language is not supported or no code example is available.

Parameters

AConverter

Type: CADConverter

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADXRef Class
CADXRef Members


ScrollEventArgsExt Constructor (ScrollEventType)

Initializes a new instance of the ScrollEventArgs class using the specified values for the Type and NewValue properties.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal type As ScrollEventType _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ScrollEventArgsExt(
   ScrollEventType type
)
This language is not supported or no code example is available.

Parameters

type

Type: ScrollEventType

One of the ScrollEventType values.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScrollEventArgsExt Class
ScrollEventArgsExt Members
CADImport.FaceModule Namespace


ScrollEventArgsExt Constructor (ScrollEventType, Int32)

Initializes a new instance of the ScrollEventArgs class using the specified values for the Type and NewValue properties.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal type As ScrollEventType, _
   ByVal newValue As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ScrollEventArgsExt(
   ScrollEventType type,
   int newValue
)
This language is not supported or no code example is available.

Parameters

type

Type: ScrollEventType

One of the ScrollEventType values.

newValue

Type: int

The new value for the scroll bar.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScrollEventArgsExt Class
ScrollEventArgsExt Members
CADImport.FaceModule Namespace


ScrollEventArgsExt Constructor (ScrollEventType, Int32, Int32)

Initializes a new instance of the ScrollEventArgs class using the specified values for the Type, OldValue, and NewValue properties.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal type As ScrollEventType, _
   ByVal oldValue As Integer, _
   ByVal newValue As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ScrollEventArgsExt(
   ScrollEventType type,
   int oldValue,
   int newValue
)
This language is not supported or no code example is available.

Parameters

type

Type: ScrollEventType

One of the ScrollEventType values.

oldValue

Type: int

The old value for the scroll bar.

newValue

Type: int

The new value for the scroll bar.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScrollEventArgsExt Class
ScrollEventArgsExt Members
CADImport.FaceModule Namespace


ScrollEventArgsExt Constructor (ScrollEventType, Int32, ScrollOrientation)

Initializes a new instance of the ScrollEventArgs class using the given values for the Type, NewValue, and ScrollOrientation properties.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal type As ScrollEventType, _
   ByVal newValue As Integer, _
   ByVal scroll As ScrollOrientation _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ScrollEventArgsExt(
   ScrollEventType type,
   int newValue,
   ScrollOrientation scroll
)
This language is not supported or no code example is available.

Parameters

type

Type: ScrollEventType

One of the ScrollEventType values.

newValue

Type: int

The new value for the scroll bar.

scroll

Type: ScrollOrientation

One of the ScrollOrientation values.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScrollEventArgsExt Class
ScrollEventArgsExt Members
CADImport.FaceModule Namespace


ScrollEventArgsExt Constructor (ScrollEventType, Int32, Int32, ScrollOrientation)

Initializes a new instance of the ScrollEventArgs class using the given values for the Type, OldValue, NewValue, and ScrollOrientation properties.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal type As ScrollEventType, _
   ByVal oldValue As Integer, _
   ByVal newValue As Integer, _
   ByVal scroll As ScrollOrientation _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ScrollEventArgsExt(
   ScrollEventType type,
   int oldValue,
   int newValue,
   ScrollOrientation scroll
)
This language is not supported or no code example is available.

Parameters

type

Type: ScrollEventType

One of the ScrollEventType values.

oldValue

Type: int

The old value for the scroll bar.

newValue

Type: int

The new value for the scroll bar.

scroll

Type: ScrollOrientation

One of the ScrollOrientation values.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScrollEventArgsExt Class
ScrollEventArgsExt Members
CADImport.FaceModule Namespace


CADPresenter.Draw (Graphics, RectangleF, Region) Method

Draws a CADImage.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub Draw( _
   ByVal e As Graphics, _
   ByVal Rect As RectangleF, _
   ByVal visibleRegion As Region _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void Draw(
   Graphics e,
   RectangleF Rect,
   Region visibleRegion
)
This language is not supported or no code example is available.

Parameters

e

Type: Graphics

A Graphics surface on which to draw the CAD image.

Rect

Type: RectangleF

A RectangleF object representing an area of the CAD image.

visibleRegion

Type: Region

Region of visible

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.Draw (Graphics, RectangleF) Method

Draws a CADImage.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub Draw( _
   ByVal e As Graphics, _
   ByVal Rect As RectangleF _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void Draw(
   Graphics e,
   RectangleF Rect
)
This language is not supported or no code example is available.

Parameters

e

Type: Graphics

A Graphics surface on which to draw the CAD image.

Rect

Type: RectangleF

A RectangleF object representing an area of the CAD image.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.SaveImageToClipboard (DRect) Method

Writes a visible part of the current CAD image to the clipboard as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub SaveImageToClipboard( _
   ByVal curRect As DRect _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void SaveImageToClipboard(
   DRect curRect
)
This language is not supported or no code example is available.

Parameters

curRect

Type: DRect

A DRect object specifying a size of the CADImage.

Remarks

This method works only for windows application.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.SaveImageToClipboard (DRect, PixelFormat) Method

Writes a visible part of the current CAD image to the clipboard as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub SaveImageToClipboard( _
   ByVal curRect As DRect, _
   ByVal pixelFormat As PixelFormat _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void SaveImageToClipboard(
   DRect curRect,
   PixelFormat pixelFormat
)
This language is not supported or no code example is available.

Parameters

curRect

Type: DRect

A DRect object specifying a size of the CADImage.

pixelFormat

Type: PixelFormat

PixelFormat of image

Remarks

This method works only for windows application.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.SaveImageToClipboard (DRect, Rectangle) Method

Writes a specified part of the current CAD image to the clipboard as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub SaveImageToClipboard( _
   ByVal curRect As DRect, _
   ByVal clipRect As Rectangle _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void SaveImageToClipboard(
   DRect curRect,
   Rectangle clipRect
)
This language is not supported or no code example is available.

Parameters

curRect

Type: DRect

A curRect object specifying a size of the current CADImage.

clipRect

Type: Rectangle

A Rectangle object that specifies a part of the current CAD image to be written to the clipboard.

Remarks

This method works only for windows application.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.SaveToFile (String, ImageFormat, DRect, RectangleF, Graphics) Method

Writes a visible part of the current CAD image to the disk as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub SaveToFile( _
   ByVal FileName As String, _
   ByVal ImgFormat As ImageFormat, _
   ByVal curRect As DRect, _
   ByVal rect As RectangleF, _
   ByVal e As Graphics _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void SaveToFile(
   string FileName,
   ImageFormat ImgFormat,
   DRect curRect,
   RectangleF rect,
   Graphics e
)
This language is not supported or no code example is available.

Parameters

FileName

Type: string

A location on the disk where to save the image.

ImgFormat

Type: ImageFormat

A ImageFormat object specifying a format of the file to save.

curRect

Type: DRect

A DRect object specifying a size of the CADImage.

rect

Type: RectangleF

e

Type: Graphics

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.SaveToFile (String, ImageFormat, DRect, PixelFormat, RectangleF, Graphics) Method

Writes a visible part of the current CAD image to the disk as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub SaveToFile( _
   ByVal FileName As String, _
   ByVal ImgFormat As ImageFormat, _
   ByVal curRect As DRect, _
   ByVal pixelFormat As PixelFormat, _
   ByVal rect As RectangleF, _
   ByVal e As Graphics _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void SaveToFile(
   string FileName,
   ImageFormat ImgFormat,
   DRect curRect,
   PixelFormat pixelFormat,
   RectangleF rect,
   Graphics e
)
This language is not supported or no code example is available.

Parameters

FileName

Type: string

A location on the disk where to save the image.

ImgFormat

Type: ImageFormat

A ImageFormat object specifying a format of the file to save.

curRect

Type: DRect

A DRect object specifying a size of the CADImage.

pixelFormat

Type: PixelFormat

PixelFormat of image

rect

Type: RectangleF

e

Type: Graphics

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


DPoint.Rotate (Double) Method

Rotates the current point in 2D coordinates system (Z coordinate does not changes)

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Rotate( _
   ByVal angle As Double _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Rotate(
   double angle
)
This language is not supported or no code example is available.

Parameters

angle

Type: double

Rotation angle

Return Value

Returns a new point recieved after rotation
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


CADPresenter.SaveToFile (String, ImageFormat, DRect, Rectangle) Method

Writes a specified part of the current CAD image to the disk as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SaveToFile( _
   ByVal FileName As String, _
   ByVal ImgFormat As ImageFormat, _
   ByVal aCurRect As DRect, _
   ByVal clipRect As Rectangle _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SaveToFile(
   string FileName,
   ImageFormat ImgFormat,
   DRect aCurRect,
   Rectangle clipRect
)
This language is not supported or no code example is available.

Parameters

FileName

Type: string

A location on the disk where to save the image.

ImgFormat

Type: ImageFormat

A ImageFormat object specifying a format of the file to save.

aCurRect

Type: DRect

A DRect object specifying a size of the CADImage.

clipRect

Type: Rectangle

A Rectangle object that specifies a part of the current CAD image to be written to the clipboard.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.SaveToFile (String, ImageFormat, DRect, Rectangle, PixelFormat) Method

Saves a current CAD image to the file of the specified format.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SaveToFile( _
   ByVal FileName As String, _
   ByVal ImgFormat As ImageFormat, _
   ByVal aCurRect As DRect, _
   ByVal clipRect As Rectangle, _
   ByVal pixelFormat As PixelFormat _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SaveToFile(
   string FileName,
   ImageFormat ImgFormat,
   DRect aCurRect,
   Rectangle clipRect,
   PixelFormat pixelFormat
)
This language is not supported or no code example is available.

Parameters

FileName

Type: string

A path to the file to be saved.

ImgFormat

Type: ImageFormat

A ImageFormat object specifying a format of the file to save.

aCurRect

Type: DRect

A DRect object specifying a size of the CADImage.

clipRect

Type: Rectangle

A Rectangle object that specifies a part of the current CAD image to be saved.

pixelFormat

Type: PixelFormat

PixelFormat of image

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.SaveToStream (Stream, ImageFormat, DRect) Method

Writes a visible part of the current CAD image to the specified stream as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub SaveToStream( _
   ByVal aSt As Stream, _
   ByVal ImgFormat As ImageFormat, _
   ByVal curRect As DRect _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void SaveToStream(
   Stream aSt,
   ImageFormat ImgFormat,
   DRect curRect
)
This language is not supported or no code example is available.

Parameters

aSt

Type: Stream

A stream which the image is saved to.

ImgFormat

Type: ImageFormat

A ImageFormat object specifying a format of the file to save.

curRect

Type: DRect

A DRect object specifying a size of the CADImage.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.SaveToStream (Stream, ImageFormat, DRect, PixelFormat) Method

Writes a visible part of the current CAD image to the specified stream as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub SaveToStream( _
   ByVal aSt As Stream, _
   ByVal ImgFormat As ImageFormat, _
   ByVal curRect As DRect, _
   ByVal pixelFormat As PixelFormat _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void SaveToStream(
   Stream aSt,
   ImageFormat ImgFormat,
   DRect curRect,
   PixelFormat pixelFormat
)
This language is not supported or no code example is available.

Parameters

aSt

Type: Stream

A stream which the image is saved to.

ImgFormat

Type: ImageFormat

A ImageFormat object specifying a format of the file to save.

curRect

Type: DRect

A DRect object specifying a size of the CADImage.

pixelFormat

Type: PixelFormat

PixelFormat of image

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.SaveImageToClipboard (DRect, Rectangle, PixelFormat) Method

Writes a specified part of the current CAD image to the clipboard as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub SaveImageToClipboard( _
   ByVal curRect As DRect, _
   ByVal clipRect As Rectangle, _
   ByVal pixelFormat As PixelFormat _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void SaveImageToClipboard(
   DRect curRect,
   Rectangle clipRect,
   PixelFormat pixelFormat
)
This language is not supported or no code example is available.

Parameters

curRect

Type: DRect

A curRect object specifying a size of the current CADImage.

clipRect

Type: Rectangle

A Rectangle object that specifies a part of the current CAD image to be written to the clipboard.

pixelFormat

Type: PixelFormat

PixelFormat of image

Remarks

This method works only for windows application.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.SaveToStream (Stream, ImageFormat, DRect, Rectangle, PixelFormat) Method

Saves a current CAD image to the stream of the specified format.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub SaveToStream( _
   ByVal str As Stream, _
   ByVal ImgFormat As ImageFormat, _
   ByVal aCurRect As DRect, _
   ByVal clipRect As Rectangle, _
   ByVal format As PixelFormat _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void SaveToStream(
   Stream str,
   ImageFormat ImgFormat,
   DRect aCurRect,
   Rectangle clipRect,
   PixelFormat format
)
This language is not supported or no code example is available.

Parameters

str

Type: Stream

A stream, where the image is saved

ImgFormat

Type: ImageFormat

A ImageFormat object specifying a format of the file to save.

aCurRect

Type: DRect

A DRect object specifying a size of the CADImage.

clipRect

Type: Rectangle

A Rectangle object that specifies a part of the current CAD image to be saved.

format

Type: PixelFormat

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


CADPresenter.SaveToStream (Stream, ImageFormat, DRect, Rectangle) Method

Writes a specified part of the current CAD image to the clipboard as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub SaveToStream( _
   ByVal str As Stream, _
   ByVal ImgFormat As ImageFormat, _
   ByVal aCurRect As DRect, _
   ByVal clipRect As Rectangle _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void SaveToStream(
   Stream str,
   ImageFormat ImgFormat,
   DRect aCurRect,
   Rectangle clipRect
)
This language is not supported or no code example is available.

Parameters

str

Type: Stream

A stream, where the image is saved

ImgFormat

Type: ImageFormat

A ImageFormat object specifying a format of the file to save.

aCurRect

Type: DRect

A curRect object specifying a size of the current CADImage.

clipRect

Type: Rectangle

A Rectangle object that specifies a part of the current CAD image to be written to the clipboard.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenter Class
CADPresenter Members


DPoint.Rotate (DPoint, Double) Method

Executes 2D rotation of a point (Z coordinate does not changes)

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function Rotate( _
   ByVal p As DPoint, _
   ByVal angle As Double _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static DPoint Rotate(
   DPoint p,
   double angle
)
This language is not supported or no code example is available.

Parameters

p

Type: DPoint

A point

angle

Type: double

Rotation angle

Return Value

Returns a new point recieved after rotation
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


CADPainter<T>.Draw (Graphics, RectangleF) Method

Draws a CADImage.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Draw( _
   ByVal e As Graphics, _
   ByVal Rect As RectangleF _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Draw(
   Graphics e,
   RectangleF Rect
)
This language is not supported or no code example is available.

Parameters

e

Type: Graphics

A Graphics surface on which to draw the CAD image.

Rect

Type: RectangleF

A RectangleF object representing an area of the CAD image.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.Draw (Graphics, RectangleF, Region) Method

Draws a CADImage.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub Draw( _
   ByVal e As Graphics, _
   ByVal Rect As RectangleF, _
   ByVal visibleRegion As Region _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void Draw(
   Graphics e,
   RectangleF Rect,
   Region visibleRegion
)
This language is not supported or no code example is available.

Parameters

e

Type: Graphics

A Graphics surface on which to draw the CAD image.

Rect

Type: RectangleF

A RectangleF object representing an area of the CAD image.

visibleRegion

Type: Region

Region of visible

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


DPoint.Multiply (DPoint, Double) Operator

Multiplies all three coordinates of the DPoint by a double value.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Operator *( _
   ByVal p1 As DPoint, _
   ByVal val As Double _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static DPoint operator *(
   DPoint p1,
   double val
)
This language is not supported or no code example is available.

Parameters

p1

Type: DPoint

A DPoint object.

val

Type: double

A double multiplier.

Return Value

A DPoint object whose coordinates are received by multiplication of initial coordinates on the double multiplier.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


CADPresenterSettings Constructor

Initializes a new instance of the CADPresenterSettings class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADPresenterSettings()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenterSettings Class
CADPresenterSettings Members


DPoint.Multiply (Double, DPoint) Operator

Multiplies all three coordinates of the DPoint by a double value.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Operator *( _
   ByVal val As Double, _
   ByVal p1 As DPoint _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static DPoint operator *(
   double val,
   DPoint p1
)
This language is not supported or no code example is available.

Parameters

val

Type: double

A double multiplier.

p1

Type: DPoint

A DPoint object.

Return Value

A DPoint object whose coordinates are received by multiplication of initial coordinates on the double multiplier.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


CADPresenterSettings Constructor (CADPresenterSettings)

Initializes a new instance of the CADPresenterSettings class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal settings As CADPresenterSettings _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADPresenterSettings(
   CADPresenterSettings settings
)
This language is not supported or no code example is available.

Parameters

settings

Type: CADPresenterSettings

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPresenterSettings Class
CADPresenterSettings Members


DPoint.XMat (DPoint, CADMatrix) Method

Returns a new DPoint that is a result of multiplying a DPoint and a CADMatrix.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function XMat( _
   ByVal p As DPoint, _
   ByVal m As CADMatrix _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static DPoint XMat(
   DPoint p,
   CADMatrix m
)
This language is not supported or no code example is available.

Parameters

p

Type: DPoint

DPoint for multiplying

m

Type: CADMatrix

CADMatrix for multiplying

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


ClipRect Constructor (Control)

Initializes a new instance of the ClipRect class.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal aParent As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ClipRect(
   Control aParent
)
This language is not supported or no code example is available.

Parameters

aParent

Type: Control

A Control on which a Rectangle tool will appear.

Remarks

By default, the Rectangle tool is 100 pixels wide and 100 pixels high.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ClipRect Class
ClipRect Members
CADImport.FaceModule Namespace


ClipRect Constructor (Control, Rectangle, Color)

Initializes a new instance of the ClipRect class.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal aParent As Control, _
   ByVal aCurrentRectanle As Rectangle, _
   ByVal aColor As Color _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ClipRect(
   Control aParent,
   Rectangle aCurrentRectanle,
   Color aColor
)
This language is not supported or no code example is available.

Parameters

aParent

Type: Control

A Control on which a Rectangle tool will appear.

aCurrentRectanle

Type: Rectangle

A Rectangle object representing an image area selected by this Rectangle tool.

aColor

Type: Color

A Color of the Rectangle tool's bounding lines.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ClipRect Class
ClipRect Members
CADImport.FaceModule Namespace


ClipRect.EnableRect (RectangleType) Method

Enables the Rectangle tool.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub EnableRect( _
   ByVal aType As RectangleType _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void EnableRect(
   RectangleType aType
)
This language is not supported or no code example is available.

Parameters

aType

Type: RectangleType

A RectangleType value specifying a working mode for this Rectangle tool.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ClipRect Class
ClipRect Members
CADImport.FaceModule Namespace


ClipRect.EnableRect (RectangleType, Rectangle) Method

Enables the Rectangle tool.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub EnableRect( _
   ByVal aType As RectangleType, _
   ByVal aRect As Rectangle _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void EnableRect(
   RectangleType aType,
   Rectangle aRect
)
This language is not supported or no code example is available.

Parameters

aType

Type: RectangleType

A RectangleType value specifying a working mode for this Rectangle tool.

aRect

Type: Rectangle

A Rectangle object representing an image area selected by this Rectangle tool.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ClipRect Class
ClipRect Members
CADImport.FaceModule Namespace


RichTextBoxEx.InsertLink (String) Method

Insert a given text as a link into the RichTextBox at the current insert position.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub InsertLink( _
   ByVal text As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void InsertLink(
   string text
)
This language is not supported or no code example is available.

Parameters

text

Type: string

Text to be inserted

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RichTextBoxEx Class
RichTextBoxEx Members
CADImport.CADImportForms Namespace


RichTextBoxEx.InsertLink (String, Int32) Method

Insert a given text at a given position as a link.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub InsertLink( _
   ByVal text As String, _
   ByVal position As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void InsertLink(
   string text,
   int position
)
This language is not supported or no code example is available.

Parameters

text

Type: string

Text to be inserted

position

Type: int

Insert position

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RichTextBoxEx Class
RichTextBoxEx Members
CADImport.CADImportForms Namespace


RichTextBoxEx.InsertLink (String, String) Method

Insert a given text at at the current input position as a link. The link text is followed by a hash (#) and the given hyperlink text, both of them invisible. When clicked on, the whole link text and hyperlink string are given in the LinkClickedEventArgs.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub InsertLink( _
   ByVal text As String, _
   ByVal hyperlink As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void InsertLink(
   string text,
   string hyperlink
)
This language is not supported or no code example is available.

Parameters

text

Type: string

Text to be inserted

hyperlink

Type: string

Invisible hyperlink string to be inserted

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RichTextBoxEx Class
RichTextBoxEx Members
CADImport.CADImportForms Namespace


RichTextBoxEx.InsertLink (String, String, Int32) Method

Insert a given text at a given position as a link. The link text is followed by a hash (#) and the given hyperlink text, both of them invisible. When clicked on, the whole link text and hyperlink string are given in the LinkClickedEventArgs.

Namespace: CADImport.CADImportForms
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub InsertLink( _
   ByVal text As String, _
   ByVal hyperlink As String, _
   ByVal position As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void InsertLink(
   string text,
   string hyperlink,
   int position
)
This language is not supported or no code example is available.

Parameters

text

Type: string

Text to be inserted

hyperlink

Type: string

Invisible hyperlink string to be inserted

position

Type: int

Insert position

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RichTextBoxEx Class
RichTextBoxEx Members
CADImport.CADImportForms Namespace


DXFPoint Constructor

Initializes a new instance of the DXFPixel class.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFPoint()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFPoint Class
DXFPoint Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFPoint Constructor (Single, Single, Single)

Initializes a new instance of the DXFPixel class with the specified values.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal z As Single _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFPoint(
   float x,
   float y,
   float z
)
This language is not supported or no code example is available.

Parameters

x

Type: float

The X coordinate

y

Type: float

The Y coordinate

z

Type: float

The Z coordinate

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFPoint Class
DXFPoint Members
CADImport.Export.SimpleCADtoDXF Namespace


DXFPoint Constructor (DXFPoint)

Initializes a new instance of the DXFPixel class that have field data copied from specified object.

Namespace: CADImport.Export.SimpleCADtoDXF
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal dxfP As DXFPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DXFPoint(
   DXFPoint dxfP
)
This language is not supported or no code example is available.

Parameters

dxfP

Type: DXFPoint

DXFPoint object

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DXFPoint Class
DXFPoint Members
CADImport.Export.SimpleCADtoDXF Namespace


CADEditorControl.LoadFile (String) Method

Loads a CAD file into the main application's form.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub LoadFile( _
   ByVal fileName As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void LoadFile(
   string fileName
)
This language is not supported or no code example is available.

Parameters

fileName

Type: string

File name

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.LoadFile (Boolean) Method

Loads a CAD file into the main application's form.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub LoadFile( _
   ByVal dlg As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void LoadFile(
   bool dlg
)
This language is not supported or no code example is available.

Parameters

dlg

Type: bool

A value indicating if an OpenFileDialog box is invoked for selecting and loading a CAD file. true, if an OpenFileDialog box is invoked; otherwise, false.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.GetRealPoint (Int32, Int32, Boolean) Method

Gets a three-dimensional point of the current CAD image from the specified screen point.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetRealPoint( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal useGrid As Boolean _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint GetRealPoint(
   int x,
   int y,
   bool useGrid
)
This language is not supported or no code example is available.

Parameters

x

Type: int

An X coordinate of the screen point.

y

Type: int

An Y coordinate of the screen point.

useGrid

Type: bool

Defines if the point will be reduced to a grid node.

Return Value

A three-dimensional point.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.GetRealPoint (Int32, Int32, Boolean, Boolean) Method

Gets a three-dimensional point of the current CAD image from the specified screen point.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function GetRealPoint( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal useGrid As Boolean, _
   ByVal rounding As Boolean _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint GetRealPoint(
   int x,
   int y,
   bool useGrid,
   bool rounding
)
This language is not supported or no code example is available.

Parameters

x

Type: int

An X coordinate of the screen point.

y

Type: int

A Y coordinate of the screen point.

useGrid

Type: bool

Defines if the point will be reduced to a grid node.

rounding

Type: bool

Defines if rounding will be applied.

Return Value

A three-dimensional point.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADGraphicsGDI.SaveToStream (Stream, ImageFormat, DRect, PixelFormat) Method

Writes a visible part of the current CAD image to the specified stream as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub SaveToStream( _
   ByVal aSt As Stream, _
   ByVal ImgFormat As ImageFormat, _
   ByVal curRect As DRect, _
   ByVal pixelFormat As PixelFormat _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void SaveToStream(
   Stream aSt,
   ImageFormat ImgFormat,
   DRect curRect,
   PixelFormat pixelFormat
)
This language is not supported or no code example is available.

Parameters

aSt

Type: Stream

A stream which the image is saved to.

ImgFormat

Type: ImageFormat

A ImageFormat object specifying a format of the file to save.

curRect

Type: DRect

A DRect object specifying a size of the CADImage.

pixelFormat

Type: PixelFormat

PixelFormat of image

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.SaveImageToClipboard (DRect, PixelFormat) Method

Writes a visible part of the current CAD image to the clipboard as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub SaveImageToClipboard( _
   ByVal curRect As DRect, _
   ByVal pixelFormat As PixelFormat _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void SaveImageToClipboard(
   DRect curRect,
   PixelFormat pixelFormat
)
This language is not supported or no code example is available.

Parameters

curRect

Type: DRect

A DRect object specifying a size of the CADImage.

pixelFormat

Type: PixelFormat

PixelFormat of image

Remarks

This method works only for windows application.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.SaveImageToClipboard (DRect, Rectangle) Method

Writes a specified part of the current CAD image to the clipboard as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub SaveImageToClipboard( _
   ByVal curRect As DRect, _
   ByVal clipRect As Rectangle _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void SaveImageToClipboard(
   DRect curRect,
   Rectangle clipRect
)
This language is not supported or no code example is available.

Parameters

curRect

Type: DRect

A curRect object specifying a size of the current CADImage.

clipRect

Type: Rectangle

A Rectangle object that specifies a part of the current CAD image to be written to the clipboard.

Remarks

This method works only for windows application.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.SaveImageToClipboard (DRect, Rectangle, PixelFormat) Method

Writes a specified part of the current CAD image to the clipboard as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub SaveImageToClipboard( _
   ByVal curRect As DRect, _
   ByVal clipRect As Rectangle, _
   ByVal pixelFormat As PixelFormat _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void SaveImageToClipboard(
   DRect curRect,
   Rectangle clipRect,
   PixelFormat pixelFormat
)
This language is not supported or no code example is available.

Parameters

curRect

Type: DRect

A curRect object specifying a size of the current CADImage.

clipRect

Type: Rectangle

A Rectangle object that specifies a part of the current CAD image to be written to the clipboard.

pixelFormat

Type: PixelFormat

PixelFormat of image

Remarks

This method works only for windows application.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.SaveImageToClipboard (DRect) Method

Writes a visible part of the current CAD image to the clipboard as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub SaveImageToClipboard( _
   ByVal curRect As DRect _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void SaveImageToClipboard(
   DRect curRect
)
This language is not supported or no code example is available.

Parameters

curRect

Type: DRect

A DRect object specifying a size of the CADImage.

Remarks

This method works only for windows application.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.DrawImage Method

Draws a raster image or a metafile object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub DrawImage( _
   ByVal image As Image, _
   ByVal points As Point(), _
   ByVal transparent As Boolean, _
   ByVal transparentColor As Color _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void DrawImage(
   Image image,
   Point[] points,
   bool transparent,
   Color transparentColor
)
This language is not supported or no code example is available.

Parameters

image

Type: Image

An object of Image derived class.

points

Type: Point[]

A list of points for a visualization method

transparent

Type: bool

A value specifying image transparency

transparentColor

Type: Color

A transparent color for visualization

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsOpenGL Constructor

Initializes a new instance of the CADGraphicsOpenGL class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADGraphicsOpenGL()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL Constructor (Control)

Initializes a new instance of the CADGraphicsOpenGL class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal render As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADGraphicsOpenGL(
   Control render
)
This language is not supported or no code example is available.

Parameters

render

Type: Control

A drawing control.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADGraphicsOpenGL.SaveToStream (Stream, ImageFormat, DRect, Rectangle, PixelFormat) Method

Saves a current CAD image to the stream of the specified format.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub SaveToStream( _
   ByVal str As Stream, _
   ByVal ImgFormat As ImageFormat, _
   ByVal aCurRect As DRect, _
   ByVal clipRect As Rectangle, _
   ByVal format As PixelFormat _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void SaveToStream(
   Stream str,
   ImageFormat ImgFormat,
   DRect aCurRect,
   Rectangle clipRect,
   PixelFormat format
)
This language is not supported or no code example is available.

Parameters

str

Type: Stream

A stream, where the image is saved

ImgFormat

Type: ImageFormat

A ImageFormat object specifying a format of the file to save.

aCurRect

Type: DRect

A DRect object specifying a size of the CADImage.

clipRect

Type: Rectangle

A Rectangle object that specifies a part of the current CAD image to be saved.

format

Type: PixelFormat

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsOpenGL Class
CADGraphicsOpenGL Members


CADImage.SetLayerColor (Int32, Color) Method

Sets a color for layer (CADLayer) specified by index

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetLayerColor( _
   ByVal ind As Integer, _
   ByVal val As Color _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetLayerColor(
   int ind,
   Color val
)
This language is not supported or no code example is available.

Parameters

ind

Type: int

An index of the layer in the collection of layers

val

Type: Color

Setting color

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SetLayerColor (Int32, Color, Boolean) Method

Sets a color for layer (CADLayer) specified by index

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetLayerColor( _
   ByVal ind As Integer, _
   ByVal val As Color, _
   ByVal detInvalidate As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetLayerColor(
   int ind,
   Color val,
   bool detInvalidate
)
This language is not supported or no code example is available.

Parameters

ind

Type: int

An index of the layer in the collection of layers

val

Type: Color

Setting color

detInvalidate

Type: bool

Outdated. Does nothing

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.Draw (Graphics, RectangleF, Control) Method

Draws a CADImage.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Draw( _
   ByVal gr As Graphics, _
   ByVal Rect As RectangleF, _
   ByVal control As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Draw(
   Graphics gr,
   RectangleF Rect,
   Control control
)
This language is not supported or no code example is available.

Parameters

gr

Type: Graphics

Rect

Type: RectangleF

A RectangleF object representing an area of the CAD image.

control

Type: Control

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.Draw (Graphics, RectangleF) Method

Draws a CADImage(only in GDI+ graphic mode).

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Draw( _
   ByVal gr As Graphics, _
   ByVal Rect As RectangleF _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Draw(
   Graphics gr,
   RectangleF Rect
)
This language is not supported or no code example is available.

Parameters

gr

Type: Graphics

Rect

Type: RectangleF

A RectangleF object representing an area of the CAD image.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SaveImageToClipboard (DRect, Rectangle) Method

Writes a specified part of the current CAD image to the clipboard as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub SaveImageToClipboard( _
   ByVal curRect As DRect, _
   ByVal clipRect As Rectangle _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void SaveImageToClipboard(
   DRect curRect,
   Rectangle clipRect
)
This language is not supported or no code example is available.

Parameters

curRect

Type: DRect

A DRect object specifying a size of the current CADImage.

clipRect

Type: Rectangle

A Rectangle object that specifies a part of the current CAD image to be written to the clipboard.

Remarks

This method works only for windows application.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SaveImageToClipboard (DRect, Rectangle, PixelFormat) Method

Writes a specified part of the current CAD image to the clipboard as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub SaveImageToClipboard( _
   ByVal curRect As DRect, _
   ByVal clipRect As Rectangle, _
   ByVal pixelFormat As PixelFormat _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void SaveImageToClipboard(
   DRect curRect,
   Rectangle clipRect,
   PixelFormat pixelFormat
)
This language is not supported or no code example is available.

Parameters

curRect

Type: DRect

A curRect object specifying a size of the current CADImage.

clipRect

Type: Rectangle

A Rectangle object that specifies a part of the current CAD image to be written to the clipboard.

pixelFormat

Type: PixelFormat

PixelFormat of image

Remarks

This method works only for windows application.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.CorrectByGrid (Int32, Int32) Method

Reduces a point location on screen to the grid node when the grid is active

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub CorrectByGrid( _
   ByRef x As Integer, _
   ByRef y As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void CorrectByGrid(
   ref int x,
   ref int y
)
This language is not supported or no code example is available.

Parameters

x

Type: int

The X screen point coordinate

y

Type: int

The Y screen point coordinate

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.CorrectByGrid (DPoint) Method

Reduces a drawing point to the grid node when the grid is active.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub CorrectByGrid( _
   ByRef realPt As DPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void CorrectByGrid(
   ref DPoint realPt
)
This language is not supported or no code example is available.

Parameters

realPt

Type: DPoint

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.InvalidateSelectedEntities (Graphics) Method

Redraws a list of the selected entities

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub InvalidateSelectedEntities( _
   ByVal graph As Graphics _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void InvalidateSelectedEntities(
   Graphics graph
)
This language is not supported or no code example is available.

Parameters

graph

Type: Graphics

Graphics object for entity redrawing

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.InvalidateSelectedEntities (Graphics, CADEntityCollection) Method

Redraws a collection of an entities

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub InvalidateSelectedEntities( _
   ByVal graph As Graphics, _
   ByVal lst As CADEntityCollection _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void InvalidateSelectedEntities(
   Graphics graph,
   CADEntityCollection lst
)
This language is not supported or no code example is available.

Parameters

graph

Type: Graphics

Graphics object for entity redrawing

lst

Type: CADEntityCollection

Redrawing collection of entities

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.ClearSnapTrace Method

Clears the last drawn snap drawing element

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ClearSnapTrace()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ClearSnapTrace()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


DRect Constructor (Double, Double, Double, Double)

Initializes a new instance of the DRect class as a two-dimensional rectangle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal x1 As Double, _
   ByVal x2 As Double, _
   ByVal x3 As Double, _
   ByVal x4 As Double _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DRect(
   double x1,
   double x2,
   double x3,
   double x4
)
This language is not supported or no code example is available.

Parameters

x1

Type: double

X-coordinate of the rectangle's top-left corner.

x2

Type: double

Y-coordinate of the rectangle's top-left corner.

x3

Type: double

X-coordinate of the rectangle's bottom-right corner.

x4

Type: double

Y-coordinate of the rectangle's bottom-right corner.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect Constructor (Double, Double, Double, Double, Double, Double)

Initializes a new instance of the DRect class as a parallelepiped.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal aLeft As Double, _
   ByVal aTop As Double, _
   ByVal aZ1 As Double, _
   ByVal aRight As Double, _
   ByVal aBottom As Double, _
   ByVal aZ2 As Double _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DRect(
   double aLeft,
   double aTop,
   double aZ1,
   double aRight,
   double aBottom,
   double aZ2
)
This language is not supported or no code example is available.

Parameters

aLeft

Type: double

X-coordinate of the parallelepiped's first specifying point.

aTop

Type: double

Y-coordinate of the parallelepiped's first specifying point.

aZ1

Type: double

Z-coordinate of the parallelepiped's first specifying point.

aRight

Type: double

X-coordinate of the parallelepiped's second specifying point.

aBottom

Type: double

Y-coordinate of the parallelepiped's second specifying point.

aZ2

Type: double

Z-coordinate of the parallelepiped's second specifying point.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.Expand (Point) Method

Expands the DRect object up to the specified point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Expand( _
   ByVal P As Point _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Expand(
   Point P
)
This language is not supported or no code example is available.

Parameters

P

Type: Point

A Point that defines a new extent of the DRect object.

Remarks

<p>The specified point defines only two-dimensional expansion.</p> <p>The specified point will be part of the expanded parallelepiped.</p>

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.IsBadRect Method

Checks if this DRect is not valid

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function IsBadRect() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool IsBadRect()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.IsBadRect (DRect) Method

Checks if specified DRect object is Bad rect.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function IsBadRect( _
   ByVal rect As DRect _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool IsBadRect(
   DRect rect
)
This language is not supported or no code example is available.

Parameters

rect

Type: DRect

Checked DRect

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.Equality (DRect, DRect) Operator

Checks if two DRect objects are equal.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Operator =( _
   ByVal p1 As DRect, _
   ByVal p2 As DRect _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool operator ==(
   DRect p1,
   DRect p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: DRect

A DRect object.

p2

Type: DRect

A DRect object.

Remarks

Two DRect objects are equal if all six coordinates of the first object are equal to corresponding coordinates of the second.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.Equality (Rectangle, DRect) Operator

Checks if Rectangle object and DRect object are equal.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Operator =( _
   ByVal p1 As Rectangle, _
   ByVal p2 As DRect _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool operator ==(
   Rectangle p1,
   DRect p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: Rectangle

A Rectangle object.

p2

Type: DRect

A DRect object.

Remarks

Two 3D objects are equal if all six coordinates of the first object are equal to the corresponding coordinates of the second.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.Contains (DRect) Method

Determines if the rectangular region is entirely contained within this DRect structure.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Contains( _
   ByVal rect As DRect _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Contains(
   DRect rect
)
This language is not supported or no code example is available.

Parameters

rect

Type: DRect

The DRect region to check.

Return Value

This method returns true if the rectangular region represented by rect is entirely contained within this DRect structure; otherwise false.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


DRect.Contains (DPoint) Method

Checks if DPoint object belongs to DRect object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Contains( _
   ByVal pt As DPoint _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool Contains(
   DPoint pt
)
This language is not supported or no code example is available.

Parameters

pt

Type: DPoint

Checking point

Return Value

Returns true if the point belongs to rectangle; otherwise false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DRect Structure
DRect Members


ListHeader Constructor

Initializes a new instance of the ListHeader class.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ListHeader()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListHeader Class
ListHeader Members
CADImport.FaceModule Namespace


DPoint.Rotate (DPoint, DPoint, Boolean, Double) Method

Returns a new point recieved by addition or subtraction of the current point and the specified point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function Rotate( _
   ByVal p As DPoint, _
   ByVal center As DPoint, _
   ByVal abs As Boolean, _
   ByVal angle As Double _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static DPoint Rotate(
   DPoint p,
   DPoint center,
   bool abs,
   double angle
)
This language is not supported or no code example is available.

Parameters

p

Type: DPoint

An offset point

center

Type: DPoint

abs

Type: bool

if true then offset would be added to pt else offset would be removed from pt

angle

Type: double

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


CADPainter<T>.FillPolyline Method

Draws a filled polyline.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub FillPolyline( _
   ByVal points As T() _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void FillPolyline(
   T[] points
)
This language is not supported or no code example is available.

Parameters

points

Type: T[]

A list of polyline vertex points

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.FillPolyPolyLine Method

Draws a filled polygons.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub FillPolyPolyLine( _
   ByVal intPoints As T(), _
   ByVal counts As Integer() _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void FillPolyPolyLine(
   T[] intPoints,
   int[] counts
)
This language is not supported or no code example is available.

Parameters

intPoints

Type: T[]

The set of points for visualization

counts

Type: int[]

A list of point numbers for figures.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.DrawString Method

Draws a text string.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub DrawString( _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal color As Integer, _
   ByVal point As T, _
   ByVal align As CADTextHorizontalAlign _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void DrawString(
   string text,
   Font font,
   int color,
   T point,
   CADTextHorizontalAlign align
)
This language is not supported or no code example is available.

Parameters

text

Type: string

A text

font

Type: Font

A text font

color

Type: int

A text color

point

Type: T

A location point of the text.

align

Type: CADTextHorizontalAlign

A text alignment.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.Add_T Method

Performs addition of two points.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Function Add_T( _
   ByVal p1 As T, _
   ByVal p2 As T _
) As T
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual T Add_T(
   T p1,
   T p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: T

p2

Type: T

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.Sub_T Method

Performs subtraction of two points.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Function Sub_T( _
   ByVal p1 As T, _
   ByVal p2 As T _
) As T
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual T Sub_T(
   T p1,
   T p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: T

p2

Type: T

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.IsEqual_T Method

Checks if two points are equal.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Function IsEqual_T( _
   ByVal p1 As T, _
   ByVal p2 As T _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual bool IsEqual_T(
   T p1,
   T p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: T

p2

Type: T

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


DPoint.Offset (DPoint, Boolean) Method

Returns a new point recieved by addition or subtraction of two specified points.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function Offset( _
   ByVal offset As DPoint, _
   ByVal add As Boolean _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint Offset(
   DPoint offset,
   bool add
)
This language is not supported or no code example is available.

Parameters

offset

Type: DPoint

An offset point

add

Type: bool

if true then offset would be added to pt else offset would be removed from pt

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


CADRasterImage Constructor (Control)

Initializes a new instance of the CADRasterImage class.

Namespace: CADImport.RasterImage
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal parentControl As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADRasterImage(
   Control parentControl
)
This language is not supported or no code example is available.

Parameters

parentControl

Type: Control

A Control that is redrawn to receive an animated GIF image.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADRasterImage Class
CADRasterImage Members
CADImport.RasterImage Namespace


CADRasterImage Constructor

Initializes a new instance of the CADRasterImage class.

Namespace: CADImport.RasterImage
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADRasterImage()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADRasterImage Class
CADRasterImage Members
CADImport.RasterImage Namespace


CADRasterImage.LoadFromStream (Stream) Method

Loads a CAD image stored in the specified stream.

Namespace: CADImport.RasterImage
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub LoadFromStream( _
   ByVal str As Stream _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void LoadFromStream(
   Stream str
)
This language is not supported or no code example is available.

Parameters

str

Type: Stream

A Stream that contains a CAD image to be loaded.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADRasterImage Class
CADRasterImage Members
CADImport.RasterImage Namespace


DPoint.Offset (DPoint, DPoint, Boolean) Method

Returns a new point recieved by addition or subtraction of two specified points.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function Offset( _
   ByVal pt As DPoint, _
   ByVal offset As DPoint, _
   ByVal add As Boolean _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static DPoint Offset(
   DPoint pt,
   DPoint offset,
   bool add
)
This language is not supported or no code example is available.

Parameters

pt

Type: DPoint

The first point

offset

Type: DPoint

An offset point

add

Type: bool

if true then offset would be added to pt else offset would be removed from pt

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


DPoint Constructor (DPoint)

Initializes a new DPoint by copying an existing one.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal p As DPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint(
   DPoint p
)
This language is not supported or no code example is available.

Parameters

p

Type: DPoint

a point that would be cloned.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


DPoint Constructor (CAD2DPoint)

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal p As CAD2DPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint(
   CAD2DPoint p
)
This language is not supported or no code example is available.

Parameters

p

Type: CAD2DPoint

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


DPoint Constructor (Double, Double, Double)

Initializes a new DPoint with the specified coordinates.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal z As Double _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint(
   double x,
   double y,
   double z
)
This language is not supported or no code example is available.

Parameters

x

Type: double

The X-coordinate of the DPoint object.

y

Type: double

The Y-coordinate of the DPoint object.

z

Type: double

The Z-coordinate of the DPoint object.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


CADConst.SetNumberOfPartsInCurve (DRect) Method

Sets optimal number of parts for curve partition by the displaying area dimensions (for saving as a raster file).

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function SetNumberOfPartsInCurve( _
   ByVal rect As DRect _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static int SetNumberOfPartsInCurve(
   DRect rect
)
This language is not supported or no code example is available.

Parameters

rect

Type: DRect

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.SetNumberOfPartsInCurve (RectangleF) Method

Sets optimal number of parts for curve partition by the displaying area dimensions (for saving as a raster file).

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function SetNumberOfPartsInCurve( _
   ByVal rect As RectangleF _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static int SetNumberOfPartsInCurve(
   RectangleF rect
)
This language is not supported or no code example is available.

Parameters

rect

Type: RectangleF

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


DPoint Constructor (SerializationInfo, StreamingContext)

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint(
   SerializationInfo info,
   StreamingContext context
)
This language is not supported or no code example is available.

Parameters

info

Type: SerializationInfo

context

Type: StreamingContext

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


CADConst.FindAutoCADSHXPaths (ArrayList) Method

Searhes the paths to the files containing the AutoCAD SHX fonts.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function FindAutoCADSHXPaths( _
   ByVal aPaths As ArrayList _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool FindAutoCADSHXPaths(
   ArrayList aPaths
)
This language is not supported or no code example is available.

Parameters

aPaths

Type: ArrayList

A list of paths where to search the AutoCAD SHX fonts.

Return Value

true if the files containing the AutoCAD SHX fonts are found; otherwize, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.FindAutoCADSHXPaths (List<String>) Method

Searhes the paths to the files containing the AutoCAD SHX fonts.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function FindAutoCADSHXPaths( _
   ByVal aPaths As List(Of String) _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static bool FindAutoCADSHXPaths(
   List<string> aPaths
)
This language is not supported or no code example is available.

Parameters

aPaths

Type: List<string>

A list of paths where to search the AutoCAD SHX fonts.

Return Value

true if the files containing the AutoCAD SHX fonts are found; otherwize, false.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


DPoint.Scale (Double, Double, Double) Method

Scales the current Vector3d by the given amounts.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Scale( _
   ByVal sx As Double, _
   ByVal sy As Double, _
   ByVal sz As Double _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Scale(
   double sx,
   double sy,
   double sz
)
This language is not supported or no code example is available.

Parameters

sx

Type: double

The scale of the X component.

sy

Type: double

The scale of the Y component.

sz

Type: double

The scale of the Z component.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


DPoint.Scale (DPoint) Method

Scales this instance by the given parameter.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub Scale( _
   ByVal scale As DPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void Scale(
   DPoint scale
)
This language is not supported or no code example is available.

Parameters

scale

Type: DPoint

The scaling of the individual components.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


DPoint.Cross (DPoint, DPoint) Method

Caclulate the cross (vector) product of two vectors

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function Cross( _
   ByVal left As DPoint, _
   ByVal right As DPoint _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static DPoint Cross(
   DPoint left,
   DPoint right
)
This language is not supported or no code example is available.

Parameters

left

Type: DPoint

First operand

right

Type: DPoint

Second operand

Return Value

The cross product of the two inputs
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


DPoint.Cross (DPoint, DPoint, DPoint) Method

Caclulate the cross (vector) product of two vectors

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Sub Cross( _
   ByRef left As DPoint, _
   ByRef right As DPoint, _
   ByRef result As DPoint _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static void Cross(
   ref DPoint left,
   ref DPoint right,
   out DPoint result
)
This language is not supported or no code example is available.

Parameters

left

Type: DPoint

First operand

right

Type: DPoint

Second operand

result

Type: DPoint

The cross product of the two inputs

Return Value

The cross product of the two inputs
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


CADEntityCollection.Remove Method

Removes the CADEntity by its handle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shadows Function Remove( _
   ByVal item As UInt64 _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
new public bool Remove(
   UInt64 item
)
This language is not supported or no code example is available.

Parameters

item

Type: UInt64

The handle value

Return Value

True if the entity deleted. False overwise.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntityCollection Class
CADEntityCollection Members


DPoint.XMat (CADMatrix) Method

Returns a new DPoint that is a result of multiplying a this one and a CADMatrix.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function XMat( _
   ByVal m As CADMatrix _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public DPoint XMat(
   CADMatrix m
)
This language is not supported or no code example is available.

Parameters

m

Type: CADMatrix

CADMatrix for multiplying

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DPoint Structure
DPoint Members


CADViewerControl.SaveAsDXF (String) Method

Saves currently opened file as a DXF file

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SaveAsDXF( _
   ByVal fName As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SaveAsDXF(
   string fName
)
This language is not supported or no code example is available.

Parameters

fName

Type: string

File name

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.SaveAsDXF Method

Saves opened file to DXF format

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SaveAsDXF()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SaveAsDXF()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADEditorControl.CreateNewImage Method

Create a new CADImage object

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub CreateNewImage()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void CreateNewImage()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.CreateNewImage (String) Method

Create a new CADImage object

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub CreateNewImage( _
   ByVal filename As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void CreateNewImage(
   string filename
)
This language is not supported or no code example is available.

Parameters

filename

Type: string

File name with extension

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.SaveAsImage (String) Method

Saves current image

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SaveAsImage( _
   ByVal fileName As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SaveAsImage(
   string fileName
)
This language is not supported or no code example is available.

Parameters

fileName

Type: string

File name

Remarks

<p>This method can be invoked from the toolbar and from the main menu.</p> <p>Images can be saved in the following formats: JPG, BMP, TIFF, GIF, EMF.</p>

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADEditorControl.SaveAsImage (Boolean) Method

Invokes a SaveFileDialog box where user can select a directory and format for saving the current CAD image.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SaveAsImage( _
   ByVal showdlg As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SaveAsImage(
   bool showdlg
)
This language is not supported or no code example is available.

Parameters

showdlg

Type: bool

Show SaveFileDialog

Remarks

<p>This method can be invoked from the toolbar and from the main menu.</p> <p>Images can be saved in the following formats: JPG, BMP, TIFF, GIF, EMF.</p>

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEditorControl Class
CADEditorControl Members
CADImport.CADImportControls Namespace


CADExport.SaveToFile (String, Encoding) Method

Exports the current CAD image to the specified file.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SaveToFile( _
   ByVal fileName As String, _
   ByVal encoding As Encoding _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SaveToFile(
   string fileName,
   Encoding encoding
)
This language is not supported or no code example is available.

Parameters

fileName

Type: string

A path to the file where to the current CAD image will be saved.

encoding

Type: Encoding

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADExport Class
CADExport Members
CADImport.Export Namespace


CADExport.SaveToFile (String) Method

Exports the current CAD image to the specified file.

Namespace: CADImport.Export
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SaveToFile( _
   ByVal fileName As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SaveToFile(
   string fileName
)
This language is not supported or no code example is available.

Parameters

fileName

Type: string

A path to the file where to the current CAD image will be saved.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADExport Class
CADExport Members
CADImport.Export Namespace


CADGraphicsGDI.ExportToMetafile (String, DRect, Rectangle) Method

Exports a CAD drawing to Windows Enhanced metafile.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub ExportToMetafile( _
   ByVal aName As String, _
   ByVal aCurRect As DRect, _
   ByVal clipRect As Rectangle _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void ExportToMetafile(
   string aName,
   DRect aCurRect,
   Rectangle clipRect
)
This language is not supported or no code example is available.

Parameters

aName

Type: string

A path to a newly created metafile.

aCurRect

Type: DRect

A DRect object specifying a size of the CADImage.

clipRect

Type: Rectangle

A Rectangle object that specifies a part of the current CAD image to be saved.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.ExportToMetafile (String, DRect, Rectangle, Boolean) Method

Exports a CAD drawing to Windows Enhanced metafile.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub ExportToMetafile( _
   ByVal aName As String, _
   ByVal aCurRect As DRect, _
   ByVal clipRect As Rectangle, _
   ByVal callGetExtents As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void ExportToMetafile(
   string aName,
   DRect aCurRect,
   Rectangle clipRect,
   bool callGetExtents
)
This language is not supported or no code example is available.

Parameters

aName

Type: string

A path to a newly created metafile.

aCurRect

Type: DRect

A DRect object specifying a size of the CADImage.

clipRect

Type: Rectangle

A Rectangle object that specifies a part of the current CAD image to be saved.

callGetExtents

Type: bool

If true call GetExtents method

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.ExportToMetafile (String, DRect) Method

Exports a CAD drawing to Windows Enhanced metafile.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub ExportToMetafile( _
   ByVal aName As String, _
   ByVal aCurRect As DRect _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void ExportToMetafile(
   string aName,
   DRect aCurRect
)
This language is not supported or no code example is available.

Parameters

aName

Type: string

A path to a newly created metafile.

aCurRect

Type: DRect

A DRect object specifying a size of the CADImage.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.SaveToStream (Stream, ImageFormat, DRect, Rectangle, PixelFormat) Method

Saves a current CAD image to the stream of the specified format.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub SaveToStream( _
   ByVal str As Stream, _
   ByVal ImgFormat As ImageFormat, _
   ByVal aCurRect As DRect, _
   ByVal clipRect As Rectangle, _
   ByVal pixelFormat As PixelFormat _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void SaveToStream(
   Stream str,
   ImageFormat ImgFormat,
   DRect aCurRect,
   Rectangle clipRect,
   PixelFormat pixelFormat
)
This language is not supported or no code example is available.

Parameters

str

Type: Stream

A stream, where the image is saved

ImgFormat

Type: ImageFormat

A ImageFormat object specifying a format of the file to save.

aCurRect

Type: DRect

A DRect object specifying a size of the CADImage.

clipRect

Type: Rectangle

A Rectangle object that specifies a part of the current CAD image to be saved.

pixelFormat

Type: PixelFormat

PixelFormat of image

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.SaveToStream (Stream, ImageFormat, DRect, Rectangle) Method

Saves a part of the current CAD image to the stream of the specified format.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub SaveToStream( _
   ByVal str As Stream, _
   ByVal ImgFormat As ImageFormat, _
   ByVal aCurRect As DRect, _
   ByVal clipRect As Rectangle _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void SaveToStream(
   Stream str,
   ImageFormat ImgFormat,
   DRect aCurRect,
   Rectangle clipRect
)
This language is not supported or no code example is available.

Parameters

str

Type: Stream

A stream, where to save an image

ImgFormat

Type: ImageFormat

A ImageFormat object specifying a format of the file to save.

aCurRect

Type: DRect

A DRect object specifying a size of the CADImage.

clipRect

Type: Rectangle

A Rectangle object that specifies a part of the current CAD image to be saved.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.SaveToFile (String, ImageFormat, DRect, RectangleF, Graphics) Method

Writes a visible part of the current CAD image to the disk as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub SaveToFile( _
   ByVal FileName As String, _
   ByVal ImgFormat As ImageFormat, _
   ByVal curRect As DRect, _
   ByVal rect As RectangleF, _
   ByVal e As Graphics _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void SaveToFile(
   string FileName,
   ImageFormat ImgFormat,
   DRect curRect,
   RectangleF rect,
   Graphics e
)
This language is not supported or no code example is available.

Parameters

FileName

Type: string

A location on the disk where to save the image.

ImgFormat

Type: ImageFormat

A ImageFormat object specifying a format of the file to save.

curRect

Type: DRect

A DRect object specifying a size of the CADImage.

rect

Type: RectangleF

e

Type: Graphics

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.SaveToFile (String, ImageFormat, DRect, PixelFormat, RectangleF, Graphics) Method

Writes a visible part of the current CAD image to the disk as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub SaveToFile( _
   ByVal FileName As String, _
   ByVal ImgFormat As ImageFormat, _
   ByVal curRect As DRect, _
   ByVal pixelFormat As PixelFormat, _
   ByVal rect As RectangleF, _
   ByVal e As Graphics _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void SaveToFile(
   string FileName,
   ImageFormat ImgFormat,
   DRect curRect,
   PixelFormat pixelFormat,
   RectangleF rect,
   Graphics e
)
This language is not supported or no code example is available.

Parameters

FileName

Type: string

A location on the disk where to save the image.

ImgFormat

Type: ImageFormat

A ImageFormat object specifying a format of the file to save.

curRect

Type: DRect

A DRect object specifying a size of the CADImage.

pixelFormat

Type: PixelFormat

PixelFormat of image

rect

Type: RectangleF

e

Type: Graphics

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.SaveToStream (Stream, ImageFormat, DRect) Method

Writes a visible part of the current CAD image to the specified stream as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub SaveToStream( _
   ByVal aSt As Stream, _
   ByVal ImgFormat As ImageFormat, _
   ByVal curRect As DRect _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void SaveToStream(
   Stream aSt,
   ImageFormat ImgFormat,
   DRect curRect
)
This language is not supported or no code example is available.

Parameters

aSt

Type: Stream

A stream which the image is saved to.

ImgFormat

Type: ImageFormat

A ImageFormat object specifying a format of the file to save.

curRect

Type: DRect

A DRect object specifying a size of the CADImage.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.DrawPolyPolyLine Method

Draws a set of lines or a set of polygons

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub DrawPolyPolyLine( _
   ByVal intPoints As Point(), _
   ByVal counts As Integer(), _
   ByVal allClosed As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void DrawPolyPolyLine(
   Point[] intPoints,
   int[] counts,
   bool allClosed
)
This language is not supported or no code example is available.

Parameters

intPoints

Type: Point[]

The set of points for visualization

counts

Type: int[]

A list of point numbers for figures.

allClosed

Type: bool

A value specifying if visualized figures will be closed

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.DrawLine Method

Draws a polyline by two specified points.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub DrawLine( _
   ByVal p1 As Point, _
   ByVal p2 As Point _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void DrawLine(
   Point p1,
   Point p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: Point

The first point

p2

Type: Point

The second point

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.DrawPixel Method

Draws a single pixel

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub DrawPixel( _
   ByVal p As Point _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void DrawPixel(
   Point p
)
This language is not supported or no code example is available.

Parameters

p

Type: Point

A point that will be visualized

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.DrawPolyline Method

Draws a polyline

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub DrawPolyline( _
   ByVal points As Point(), _
   ByVal closed As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void DrawPolyline(
   Point[] points,
   bool closed
)
This language is not supported or no code example is available.

Parameters

points

Type: Point[]

A list of polyline vertex points

closed

Type: bool

A value specifying if polyline is closed

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.FillPolyline Method

Draws a filled polyline.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub FillPolyline( _
   ByVal points As Point() _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void FillPolyline(
   Point[] points
)
This language is not supported or no code example is available.

Parameters

points

Type: Point[]

A list of polyline vertex points

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.FillPolyPolyLine Method

Draws a filled polygons.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub FillPolyPolyLine( _
   ByVal intPoints As Point(), _
   ByVal counts As Integer() _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void FillPolyPolyLine(
   Point[] intPoints,
   int[] counts
)
This language is not supported or no code example is available.

Parameters

intPoints

Type: Point[]

The set of points for visualization

counts

Type: int[]

A list of point numbers for figures.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.DrawString Method

Draws a text string.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Sub DrawString( _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal color As Integer, _
   ByVal point As Point, _
   ByVal align As CADTextHorizontalAlign _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override void DrawString(
   string text,
   Font font,
   int color,
   Point point,
   CADTextHorizontalAlign align
)
This language is not supported or no code example is available.

Parameters

text

Type: string

A text

font

Type: Font

A text font

color

Type: int

A text color

point

Type: Point

A location point of the text.

align

Type: CADTextHorizontalAlign

A text alignment.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.Add_T Method

Performs addition of two points.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function Add_T( _
   ByVal p1 As Point, _
   ByVal p2 As Point _
) As Point
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override Point Add_T(
   Point p1,
   Point p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: Point

The first point

p2

Type: Point

The second point

Return Value

The resulting point
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.Sub_T Method

Performs substraction of two points.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function Sub_T( _
   ByVal p1 As Point, _
   ByVal p2 As Point _
) As Point
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override Point Sub_T(
   Point p1,
   Point p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: Point

The first point

p2

Type: Point

The second point

Return Value

The resulting point
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADGraphicsGDI.IsEqual_T Method

Checks if two points are equal.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overrides Function IsEqual_T( _
   ByVal p1 As Point, _
   ByVal p2 As Point _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public override bool IsEqual_T(
   Point p1,
   Point p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: Point

The first point

p2

Type: Point

The second point

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADGraphicsGDI Class
CADGraphicsGDI Members


CADImage.SetLayerVisible (Int32, Boolean) Method

Sets a visibility of the layer.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetLayerVisible( _
   ByVal ind As Integer, _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetLayerVisible(
   int ind,
   bool val
)
This language is not supported or no code example is available.

Parameters

ind

Type: int

An index of the layer in the collection of layers.

val

Type: bool

A value which the specified layer's visibility will be set to.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SetLayerVisible (Int32, Boolean, Boolean) Method

Sets a visibility of the layer.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetLayerVisible( _
   ByVal ind As Integer, _
   ByVal val As Boolean, _
   ByVal detInvalidate As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetLayerVisible(
   int ind,
   bool val,
   bool detInvalidate
)
This language is not supported or no code example is available.

Parameters

ind

Type: int

An index of the layer in the collection of layers.

val

Type: bool

A value which the specified layer's visibility will be set to.

detInvalidate

Type: bool

Outdated. Does nothing

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SetLayerFreeze (Int32, Boolean) Method

Sets freeze parameter for CADLayer

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetLayerFreeze( _
   ByVal ind As Integer, _
   ByVal val As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetLayerFreeze(
   int ind,
   bool val
)
This language is not supported or no code example is available.

Parameters

ind

Type: int

An index of the layer in the collection of layers

val

Type: bool

Setting value

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SetLayerFreeze (Int32, Boolean, Boolean) Method

Sets freeze parameter for CADLayer

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub SetLayerFreeze( _
   ByVal ind As Integer, _
   ByVal val As Boolean, _
   ByVal detInvalidate As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void SetLayerFreeze(
   int ind,
   bool val,
   bool detInvalidate
)
This language is not supported or no code example is available.

Parameters

ind

Type: int

An index of the layer in the collection of layers

val

Type: bool

Setting value

detInvalidate

Type: bool

Outdated. Does nothing

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SaveToFile (String, ImageFormat, DRect, Rectangle) Method

Saves a part of the current CAD image to the file of the specified format.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub SaveToFile( _
   ByVal FileName As String, _
   ByVal ImgFormat As ImageFormat, _
   ByVal aCurRect As DRect, _
   ByVal clipRect As Rectangle _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void SaveToFile(
   string FileName,
   ImageFormat ImgFormat,
   DRect aCurRect,
   Rectangle clipRect
)
This language is not supported or no code example is available.

Parameters

FileName

Type: string

A path to the file to be saved.

ImgFormat

Type: ImageFormat

A ImageFormat object specifying a format of the file to save.

aCurRect

Type: DRect

A DRect object specifying a size of the CADImage.

clipRect

Type: Rectangle

A Rectangle object that specifies a part of the current CAD image to be saved.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SaveToFile (String, ImageFormat, DRect, Rectangle, PixelFormat) Method

Saves a part of the current CAD image to the file of the specified format.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub SaveToFile( _
   ByVal FileName As String, _
   ByVal ImgFormat As ImageFormat, _
   ByVal aCurRect As DRect, _
   ByVal clipRect As Rectangle, _
   ByVal pixelFormat As PixelFormat _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void SaveToFile(
   string FileName,
   ImageFormat ImgFormat,
   DRect aCurRect,
   Rectangle clipRect,
   PixelFormat pixelFormat
)
This language is not supported or no code example is available.

Parameters

FileName

Type: string

A path to the file to be saved.

ImgFormat

Type: ImageFormat

A ImageFormat object specifying a format of the file to save.

aCurRect

Type: DRect

A DRect object specifying a size of the CADImage.

clipRect

Type: Rectangle

A Rectangle object that specifies a part of the current CAD image to be saved.

pixelFormat

Type: PixelFormat

PixelFormat of image

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SaveToFile (String, ImageFormat, DRect) Method

Writes a visible part of the current CAD image to the file as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub SaveToFile( _
   ByVal FileName As String, _
   ByVal ImgFormat As ImageFormat, _
   ByVal curRect As DRect _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void SaveToFile(
   string FileName,
   ImageFormat ImgFormat,
   DRect curRect
)
This language is not supported or no code example is available.

Parameters

FileName

Type: string

A path to the file to be saved.

ImgFormat

Type: ImageFormat

A ImageFormat object specifying a format of the file to save.

curRect

Type: DRect

A DRect object specifying a size of the CADImage.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SaveToFile (String, ImageFormat, DRect, PixelFormat) Method

Writes a visible part of the current CAD image to the file as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub SaveToFile( _
   ByVal FileName As String, _
   ByVal ImgFormat As ImageFormat, _
   ByVal curRect As DRect, _
   ByVal pixelFormat As PixelFormat _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void SaveToFile(
   string FileName,
   ImageFormat ImgFormat,
   DRect curRect,
   PixelFormat pixelFormat
)
This language is not supported or no code example is available.

Parameters

FileName

Type: string

A path to the file to be saved.

ImgFormat

Type: ImageFormat

A ImageFormat object specifying a format of the file to save.

curRect

Type: DRect

A DRect object specifying a size of the CADImage.

pixelFormat

Type: PixelFormat

PixelFormat of image

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SaveToStream (Stream, ImageFormat, DRect) Method

Writes a visible part of the current CAD image to the specified stream as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub SaveToStream( _
   ByVal aSt As Stream, _
   ByVal ImgFormat As ImageFormat, _
   ByVal curRect As DRect _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void SaveToStream(
   Stream aSt,
   ImageFormat ImgFormat,
   DRect curRect
)
This language is not supported or no code example is available.

Parameters

aSt

Type: Stream

A stream, where to save an image

ImgFormat

Type: ImageFormat

A ImageFormat object specifying a format of the file to save.

curRect

Type: DRect

A DRect object specifying a size of the CADImage.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SaveToStream (Stream, ImageFormat, DRect, Rectangle) Method

Saves a part of the current CAD image to the stream of the specified format.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub SaveToStream( _
   ByVal str As Stream, _
   ByVal ImgFormat As ImageFormat, _
   ByVal aCurRect As DRect, _
   ByVal clipRect As Rectangle _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void SaveToStream(
   Stream str,
   ImageFormat ImgFormat,
   DRect aCurRect,
   Rectangle clipRect
)
This language is not supported or no code example is available.

Parameters

str

Type: Stream

A stream, where to save an image

ImgFormat

Type: ImageFormat

A ImageFormat object specifying a format of the file to save.

aCurRect

Type: DRect

A DRect object specifying a size of the CADImage.

clipRect

Type: Rectangle

A Rectangle object that specifies a part of the current CAD image to be saved.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SaveToStream (Stream, ImageFormat, DRect, Rectangle, PixelFormat) Method

Saves a part of the current CAD image to the stream of the specified format.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub SaveToStream( _
   ByVal str As Stream, _
   ByVal ImgFormat As ImageFormat, _
   ByVal aCurRect As DRect, _
   ByVal clipRect As Rectangle, _
   ByVal pixelFormat As PixelFormat _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void SaveToStream(
   Stream str,
   ImageFormat ImgFormat,
   DRect aCurRect,
   Rectangle clipRect,
   PixelFormat pixelFormat
)
This language is not supported or no code example is available.

Parameters

str

Type: Stream

A stream, where to save an image

ImgFormat

Type: ImageFormat

A ImageFormat object specifying a format of the file to save.

aCurRect

Type: DRect

A DRect object specifying a size of the CADImage.

clipRect

Type: Rectangle

A Rectangle object that specifies a part of the current CAD image to be saved.

pixelFormat

Type: PixelFormat

PixelFormat of image

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SaveToStream (Stream, ImageFormat, DRect, PixelFormat) Method

Writes a visible part of the current CAD image to the specified stream as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub SaveToStream( _
   ByVal aSt As Stream, _
   ByVal ImgFormat As ImageFormat, _
   ByVal curRect As DRect, _
   ByVal pixelFormat As PixelFormat _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void SaveToStream(
   Stream aSt,
   ImageFormat ImgFormat,
   DRect curRect,
   PixelFormat pixelFormat
)
This language is not supported or no code example is available.

Parameters

aSt

Type: Stream

A stream, where to save an image

ImgFormat

Type: ImageFormat

A ImageFormat object specifying a format of the file to save.

curRect

Type: DRect

A DRect object specifying a size of the CADImage.

pixelFormat

Type: PixelFormat

PixelFormat of image

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SaveImageToClipboard (DRect) Method

Writes a visible part of the current CAD image to the clipboard as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub SaveImageToClipboard( _
   ByVal curRect As DRect _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void SaveImageToClipboard(
   DRect curRect
)
This language is not supported or no code example is available.

Parameters

curRect

Type: DRect

A DRect object specifying a size of the CADImage.

Remarks

This method works only for windows application.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.SaveImageToClipboard (DRect, PixelFormat) Method

Writes a visible part of the current CAD image to the clipboard as a raster image.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub SaveImageToClipboard( _
   ByVal curRect As DRect, _
   ByVal pixelFormat As PixelFormat _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void SaveImageToClipboard(
   DRect curRect,
   PixelFormat pixelFormat
)
This language is not supported or no code example is available.

Parameters

curRect

Type: DRect

A DRect object specifying a size of the CADImage.

pixelFormat

Type: PixelFormat

PixelFormat of image

Remarks

This method works only for windows application.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.ExportToMetafile (String, DRect) Method

Exports a CAD drawing to Windows Enhanced metafile.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub ExportToMetafile( _
   ByVal aName As String, _
   ByVal aCurRect As DRect _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void ExportToMetafile(
   string aName,
   DRect aCurRect
)
This language is not supported or no code example is available.

Parameters

aName

Type: string

A path to a newly created metafile.

aCurRect

Type: DRect

A DRect object specifying a size of the CADImage.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.ExportToMetafile (String, DRect, Rectangle, Boolean) Method

Exports a CAD drawing to Windows Enhanced metafile.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub ExportToMetafile( _
   ByVal aName As String, _
   ByVal aCurRect As DRect, _
   ByVal clipRect As Rectangle, _
   ByVal callGetExtents As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void ExportToMetafile(
   string aName,
   DRect aCurRect,
   Rectangle clipRect,
   bool callGetExtents
)
This language is not supported or no code example is available.

Parameters

aName

Type: string

A path to a newly created metafile.

aCurRect

Type: DRect

A DRect object specifying a size of the CADImage.

clipRect

Type: Rectangle

A Rectangle object that specifies a part of the current CAD image to be saved.

callGetExtents

Type: bool

If true call GetExtents method

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.ExportToMetafile (String, DRect, Rectangle) Method

Exports a CAD drawing to Windows Enhanced metafile.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub ExportToMetafile( _
   ByVal aName As String, _
   ByVal aCurRect As DRect, _
   ByVal clipRect As Rectangle _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void ExportToMetafile(
   string aName,
   DRect aCurRect,
   Rectangle clipRect
)
This language is not supported or no code example is available.

Parameters

aName

Type: string

A path to a newly created metafile.

aCurRect

Type: DRect

A DRect object specifying a size of the CADImage.

clipRect

Type: Rectangle

A Rectangle object that specifies a part of the current CAD image to be saved.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.EmfConvertToDXF (String) Method

Converts emf file to dxf file

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub EmfConvertToDXF( _
   ByVal fileName As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void EmfConvertToDXF(
   string fileName
)
This language is not supported or no code example is available.

Parameters

fileName

Type: string

Name of file

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.EmfConvertToDXF (String, String) Method

Convert emf file to dxf file

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub EmfConvertToDXF( _
   ByVal fileName As String, _
   ByVal outFileName As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void EmfConvertToDXF(
   string fileName,
   string outFileName
)
This language is not supported or no code example is available.

Parameters

fileName

Type: string

Name of file

outFileName

Type: string

Out file name

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.CopyEntities (CADEntityCollection) Method

Copies selected entities to the clipboard

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function CopyEntities( _
   ByVal selEnt As CADEntityCollection _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int CopyEntities(
   CADEntityCollection selEnt
)
This language is not supported or no code example is available.

Parameters

selEnt

Type: CADEntityCollection

Return Value

Returns quantity of entities. Returns -1 if there is nothing to copy
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.CopyEntities Method

Copies selected entities to the clipboard

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function CopyEntities() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int CopyEntities()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.CutEntities (CADEntityCollection) Method

Cuts selected entities from collection and paste them to the clipboard

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function CutEntities( _
   ByVal selEnt As CADEntityCollection _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int CutEntities(
   CADEntityCollection selEnt
)
This language is not supported or no code example is available.

Parameters

selEnt

Type: CADEntityCollection

Return Value

Returns quantity of entities
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.CutEntities Method

Cuts selected entities from collection and paste them to the clipboard

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function CutEntities() As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public int CutEntities()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.RemoveEntity (CADEntity) Method

Removes CADEntity object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function RemoveEntity( _
   ByVal ent As CADEntity _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool RemoveEntity(
   CADEntity ent
)
This language is not supported or no code example is available.

Parameters

ent

Type: CADEntity

An entity to remove

Return Value

true if sucessfull, otherwise false
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.RemoveEntity Method

Removes all entities form list of entities

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function RemoveEntity() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool RemoveEntity()
This language is not supported or no code example is available.

Return Value

true if sucessfull, otherwise false
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.RemoveEntity (CADEntityCollection) Method

Removes all entities form entities collection

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Function RemoveEntity( _
   ByVal entCollection As CADEntityCollection _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public bool RemoveEntity(
   CADEntityCollection entCollection
)
This language is not supported or no code example is available.

Parameters

entCollection

Type: CADEntityCollection

Return Value

true if sucessfull, otherwise false
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.AddToUndoList (CADEntity) Method

Adds operation "create new Entity" to undo list

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddToUndoList( _
   ByVal ent As CADEntity _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddToUndoList(
   CADEntity ent
)
This language is not supported or no code example is available.

Parameters

ent

Type: CADEntity

Adding entity

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.AddToUndoList (CADEntity, Operation) Method

Adds an operation with an entity to undo list

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub AddToUndoList( _
   ByVal ent As CADEntity, _
   ByVal operation As Operation _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void AddToUndoList(
   CADEntity ent,
   Operation operation
)
This language is not supported or no code example is available.

Parameters

ent

Type: CADEntity

Adding entity

operation

Type: Operation

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.ClearSnapTrace (Control) Method

Clears last drawn snap drawing element

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub ClearSnapTrace( _
   ByVal control As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void ClearSnapTrace(
   Control control
)
This language is not supported or no code example is available.

Parameters

control

Type: Control

ControlControl, where the drawing element is drawn

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADImage.InitialNewImage Method

Example See Also

Initializes a new image with the default size

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub InitialNewImage()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void InitialNewImage()
This language is not supported or no code example is available.
Example
<p>Use InitialNewImage example:</p> <p>[C#]</p>
Copy

     if(cadImage != null)
         cadImage.Dispose();
     scale = 1;
     prev_scale = 1;
     pos = new PointF();
     cadImage = new CADImage();
     cadImage.SelectionMode = SelectionEntityMode.Enabled;
     if(cadPictBox.BackColor == Color.White)
         White_Click();
     else
         Black_Click();
     cadImage.InitialNewImage();
     EnableButton(true);
     trvEntity.Nodes.Clear();
     DoResize(cadImage, ref pos, cadPictBox, ref curClRect, deactiv);
     ObjEntity.cadImage = cadImage;										//for object inspector
     ObjEntity.propGrid = propGrid;										//for object inspector
     cadImage.UseWinEllipse = false;
     entCreator.Image = cadImage;
     prtForm.Image = cadImage;
     SetLayList();
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members
CADImport Namespace
CADImage
CADPolyLine
DPoint
clNone


CADImage.InitialNewImage (Double, Double) Method

Initializes a new image with the specified size

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub InitialNewImage( _
   ByVal x As Double, _
   ByVal y As Double _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void InitialNewImage(
   double x,
   double y
)
This language is not supported or no code example is available.

Parameters

x

Type: double

y

Type: double

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADImage Class
CADImage Members


CADDimension Constructor

Example See Also

Initializes a new instance of the CADDimension class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADDimension()
This language is not supported or no code example is available.
Example
<p>Creating a new CADDimension object example:</p> <p>[C#]</p>
Copy
 CreateNewImage();
 DPoint startPoint = GetRealPoint(10.0f / 100.0f , 1.0f - 10.0f / 100.0f);
 DPoint endPoint = GetRealPoint(20.0f / 100.0f, 1.0f - 20.0f / 100.0f);
 CADDimension vDimension = new CADDimension();
 vDimension.Flags = 1;
 vDimension.Color = CADConst.clNone;
 vDimension.LinDefPoint1 = startPoint;
 vDimension.LinDefPoint2 = endPoint;
 vDimension.DefPoint = new DPoint(endPoint.X, endPoint.Y + 20.0, 0.0);
 vDimension.Style = new CADDimensionStyle();
 vDimension.Style.ArrowSize = 0.5;
 vDimension.Style.TextHeight = 0.5;
 cadImage.Converter.OnCreate(vDimension);
 cadImage.Converter.Loads(vDimension);
 cadImage.Converter.Entities.Add(vDimension);
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members
CADImport Namespace
CADDimension
CADImage
DPoint
clNone


CADDimension Constructor (DimensionType, DPoint, DPoint, Double, Boolean)

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal dType As DimensionType, _
   ByVal LnDefPoint1 As DPoint, _
   ByVal LnDefPoint2 As DPoint, _
   ByVal ExtLine2height As Double, _
   ByVal rotatedToAxisX As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADDimension(
   DimensionType dType,
   DPoint LnDefPoint1,
   DPoint LnDefPoint2,
   double ExtLine2height,
   bool rotatedToAxisX
)
This language is not supported or no code example is available.

Parameters

dType

Type: DimensionType

LnDefPoint1

Type: DPoint

LnDefPoint2

Type: DPoint

ExtLine2height

Type: double

rotatedToAxisX

Type: bool

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADDimension Class
CADDimension Members


CAD2DBoundaryList Constructor

Initializes a new instance of the CAD2DBoundaryList class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CAD2DBoundaryList()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DBoundaryList Class
CAD2DBoundaryList Members


CAD2DBoundaryList Constructor (Int32)

Initializes a new instance of the CAD2DBoundaryList class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal capacity As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CAD2DBoundaryList(
   int capacity
)
This language is not supported or no code example is available.

Parameters

capacity

Type: int

A recommended amount of the internal data members.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CAD2DBoundaryList Class
CAD2DBoundaryList Members


ListHeader Constructor (String, String, Int32)

Initializes a new instance of the ListHeader class.

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal name As String, _
   ByVal text As String, _
   ByVal width As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ListHeader(
   string name,
   string text,
   int width
)
This language is not supported or no code example is available.

Parameters

name

Type: string

A name

text

Type: string

A text

width

Type: int

Width

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListHeader Class
ListHeader Members
CADImport.FaceModule Namespace


ListEventSelectArgs Constructor

Creates ListEventSelectArgs class instance

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ListEventSelectArgs()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListEventSelectArgs Class
ListEventSelectArgs Members
CADImport.FaceModule Namespace


ListEventSelectArgs Constructor (Int32)

Creates ListEventSelectArgs class instance

Namespace: CADImport.FaceModule
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal index As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public ListEventSelectArgs(
   int index
)
This language is not supported or no code example is available.

Parameters

index

Type: int

An index of the cell in collection

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ListEventSelectArgs Class
ListEventSelectArgs Members
CADImport.FaceModule Namespace


CADPainter<T>.ExportToMetafile (String, DRect) Method

Exports a CAD drawing to Windows Enhanced metafile.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub ExportToMetafile( _
   ByVal aName As String, _
   ByVal aCurRect As DRect _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void ExportToMetafile(
   string aName,
   DRect aCurRect
)
This language is not supported or no code example is available.

Parameters

aName

Type: string

A path to a newly created metafile.

aCurRect

Type: DRect

A DRect object specifying a size of the CADImage.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.ExportToMetafile (String, DRect, Rectangle) Method

Exports a CAD drawing to Windows Enhanced metafile.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub ExportToMetafile( _
   ByVal aName As String, _
   ByVal aCurRect As DRect, _
   ByVal clipRect As Rectangle _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void ExportToMetafile(
   string aName,
   DRect aCurRect,
   Rectangle clipRect
)
This language is not supported or no code example is available.

Parameters

aName

Type: string

A path to a newly created metafile.

aCurRect

Type: DRect

A DRect object specifying a size of the CADImage.

clipRect

Type: Rectangle

A Rectangle object that specifies a part of the current CAD image to be saved.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.ExportToMetafile (String, DRect, Rectangle, Boolean) Method

Exports a CAD drawing to Windows Enhanced metafile.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub ExportToMetafile( _
   ByVal aName As String, _
   ByVal aCurRect As DRect, _
   ByVal clipRect As Rectangle, _
   ByVal callGetExtents As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void ExportToMetafile(
   string aName,
   DRect aCurRect,
   Rectangle clipRect,
   bool callGetExtents
)
This language is not supported or no code example is available.

Parameters

aName

Type: string

A path to a newly created metafile.

aCurRect

Type: DRect

A DRect object specifying a size of the CADImage.

clipRect

Type: Rectangle

A Rectangle object that specifies a part of the current CAD image to be saved.

callGetExtents

Type: bool

If true call GetExtents method

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.DrawImage (Image, T(), Boolean, Color) Method

Draws a raster image or a metafile object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub DrawImage( _
   ByVal image As Image, _
   ByVal points As T(), _
   ByVal transparent As Boolean, _
   ByVal transparentColor As Color _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void DrawImage(
   Image image,
   T[] points,
   bool transparent,
   Color transparentColor
)
This language is not supported or no code example is available.

Parameters

image

Type: Image

An object of Image derived class.

points

Type: T[]

A list of points for a visualization method

transparent

Type: bool

A value specifying image transparency

transparentColor

Type: Color

A transparent color for visualization

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.DrawImage (Image, T, T, T, Boolean, Color) Method

Draws a raster image or a metafile object.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DrawImage( _
   ByVal image As Image, _
   ByVal point As T, _
   ByVal width As T, _
   ByVal height As T, _
   ByVal transparent As Boolean, _
   ByVal transparentColor As Color _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DrawImage(
   Image image,
   T point,
   T width,
   T height,
   bool transparent,
   Color transparentColor
)
This language is not supported or no code example is available.

Parameters

image

Type: Image

An object of Image derived class.

point

Type: T

A location point

width

Type: T

A width of the image object

height

Type: T

A height of the image object

transparent

Type: bool

A value specifying image transparency

transparentColor

Type: Color

A transparent color for visualization

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.DrawPolyPolyLine Method

Draws a set of lines or a set of polygons

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub DrawPolyPolyLine( _
   ByVal intPoints As T(), _
   ByVal counts As Integer(), _
   ByVal allClosed As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void DrawPolyPolyLine(
   T[] intPoints,
   int[] counts,
   bool allClosed
)
This language is not supported or no code example is available.

Parameters

intPoints

Type: T[]

The set of points for visualization

counts

Type: int[]

A list of point numbers for figures.

allClosed

Type: bool

A value specifying if visualized figures will be closed

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.DrawLine Method

Draws a polyline by two specified points.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub DrawLine( _
   ByVal p1 As T, _
   ByVal p2 As T _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void DrawLine(
   T p1,
   T p2
)
This language is not supported or no code example is available.

Parameters

p1

Type: T

The first point

p2

Type: T

The second point

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.DrawPixel Method

Draws a single pixel

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub DrawPixel( _
   ByVal p As T _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void DrawPixel(
   T p
)
This language is not supported or no code example is available.

Parameters

p

Type: T

A point that will be visualized

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADPainter<T>.DrawPolyline Method

Draws a polyline

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub DrawPolyline( _
   ByVal points As T(), _
   ByVal closed As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void DrawPolyline(
   T[] points,
   bool closed
)
This language is not supported or no code example is available.

Parameters

points

Type: T[]

A list of polyline vertex points

closed

Type: bool

A value specifying if polyline is closed

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADPainter<T> Class
CADPainter<T> Members


CADRasterImage.LoadFromStream (Stream, String) Method

Loads a CAD image stored in the specified stream.

Namespace: CADImport.RasterImage
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Overridable Sub LoadFromStream( _
   ByVal str As Stream, _
   ByVal ext As String _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public virtual void LoadFromStream(
   Stream str,
   string ext
)
This language is not supported or no code example is available.

Parameters

str

Type: Stream

A Stream that contains a CAD image to be loaded.

ext

Type: string

File extension

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADRasterImage Class
CADRasterImage Members
CADImport.RasterImage Namespace


IAssign<T>.Assign Method

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Sub Assign( _
   ByVal entity As T _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
void Assign(
   T entity
)
This language is not supported or no code example is available.

Parameters

entity

Type: T

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference


CADConst.GetRealPoint (Int32, Int32, CADImage, RectangleF, Boolean) Method

Gets a three-dimensional point of the current CAD image from the specified screen point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function GetRealPoint( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal img As CADImage, _
   ByVal rect As RectangleF, _
   ByVal rounding As Boolean _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static DPoint GetRealPoint(
   int x,
   int y,
   CADImage img,
   RectangleF rect,
   bool rounding
)
This language is not supported or no code example is available.

Parameters

x

Type: int

The X coordinate of the screen point.

y

Type: int

The Y coordinate of the screen point.

img

Type: CADImage

CADImage for GetRealPoint

rect

Type: RectangleF

Drawing rect

rounding

Type: bool

A value specify if rounding will be applied to the returned value

Return Value

A three-dimensional point.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADConst.GetRealPoint (Int32, Int32, CADImage, RectangleF) Method

Gets a three-dimensional point of the current CAD image from the specified screen point.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shared Function GetRealPoint( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal img As CADImage, _
   ByVal rect As RectangleF _
) As DPoint
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public static DPoint GetRealPoint(
   int x,
   int y,
   CADImage img,
   RectangleF rect
)
This language is not supported or no code example is available.

Parameters

x

Type: int

The X coordinate of the screen point.

y

Type: int

The Y coordinate of the screen point.

img

Type: CADImage

CADImage for GetRealPoint

rect

Type: RectangleF

Drawing rect

Return Value

A three-dimensional point.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADConst Class
CADConst Members


CADEntityCollection Constructor

Initializes a new instance of the CADEntityCollection class.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntityCollection()
This language is not supported or no code example is available.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntityCollection Class
CADEntityCollection Members


CADEntityCollection Constructor (IEnumerable<CADEntity>)

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal entities As IEnumerable(Of CADEntity) _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntityCollection(
   IEnumerable<CADEntity> entities
)
This language is not supported or no code example is available.

Parameters

entities

Type: IEnumerable<CADEntity>

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntityCollection Class
CADEntityCollection Members


CADEntityCollection Constructor (Int32)

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub New( _
   ByVal capacity As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntityCollection(
   int capacity
)
This language is not supported or no code example is available.

Parameters

capacity

Type: int

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntityCollection Class
CADEntityCollection Members


CADEntityCollection.Item (System.UInt64) Property

Gets the CADEntity by its handle.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Property Item( _
   ByVal handle As UInt64 _
) As CADEntity
    Get

This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public CADEntity this[
   UInt64 handle
] {get;}
This language is not supported or no code example is available.

Parameters

handle

Type: UInt64

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntityCollection Class
CADEntityCollection Members


CADEntityCollection.IndexOf Method

Returns an index of the CADEntity in the CADEntityCollection.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shadows Function IndexOf( _
   ByVal ent As CADEntity _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
new public int IndexOf(
   CADEntity ent
)
This language is not supported or no code example is available.

Parameters

ent

Type: CADEntity

Return Value

An index of the entity in the collection.
Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntityCollection Class
CADEntityCollection Members


CADEntityCollection.Item (System.Int32) Property

Gets the CADEntity by its index.

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shadows Property Item( _
   ByVal index As Integer _
) As CADEntity
    Get

This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
new public CADEntity this[
   int index
] {get;}
This language is not supported or no code example is available.

Parameters

index

Type: int

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADEntityCollection Class
CADEntityCollection Members


XtomesList.Add Method

Adds an Xtome instanse to the Extended Data instance

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shadows Sub Add( _
   ByVal item As Xtome _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
new public void Add(
   Xtome item
)
This language is not supported or no code example is available.

Parameters

item

Type: Xtome

The Xtome instance to add

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

XtomesList Class
XtomesList Members


XtomesList.AddRange Method

Adds a collection of Xtome instances to the Extended Data instance

Namespace: CADImport
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Shadows Sub AddRange( _
   ByVal collection As IEnumerable(Of Xtome) _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
new public void AddRange(
   IEnumerable<Xtome> collection
)
This language is not supported or no code example is available.

Parameters

collection

Type: IEnumerable<Xtome>

The collection of Xtome instances to add

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

XtomesList Class
XtomesList Members


CADViewerControl.DoResize (Boolean) Method

Resizes the CAD image to fit drawing's bounds.

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DoResize( _
   ByVal positioned As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DoResize(
   bool positioned
)
This language is not supported or no code example is available.

Parameters

positioned

Type: bool

Remarks

This method is invoked when changing layout or working with a 3D Orbit tool.

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace


CADViewerControl.DoResize (RectangleF, Boolean) Method

Namespace: CADImport.CADImportControls
Assembly: CADImport (in CADImport.dll)

Syntax
VB
C#
C++
JScript
Copy
Public Sub DoResize( _
   ByVal rect As RectangleF, _
   ByVal positioned As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
JScript
Copy
public void DoResize(
   RectangleF rect,
   bool positioned
)
This language is not supported or no code example is available.

Parameters

rect

Type: RectangleF

positioned

Type: bool

Platforms

Windows NT 4.0, Windows 98, Windows XP, Windows Server 2003, Windows Vista; Windows Server 2008 R2, Windows 7

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.0 - 4

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CADViewerControl Class
CADViewerControl Members
CADImport.CADImportControls Namespace